Технологическая платформа "Мельница Данных"

Мельница данных (22.10.2024)
(одним файлом)
Технологическая платформа "Мельница Данных"
Документация online
Мельница Данных

Документация по технологической платформе.
  • Руководство пользователя обозревателя данных
  • Руководство пользователя построителя запросов
  • Руководство администратора
  • Руководство разработчика на платформе
  • Руководство разработчика для построителя запросов


Руководство пользователя обозревателя данных

(раздел целиком) (одним файлом)
Руководство пользователя обозревателя данных
  • Запуск обозревателя данных
  • Элементы интерфейса пользователя
  • Работа с формами и таблицами данных
  • Работа с Инспектором объектов
  • Работа с формой задания параметров
  • Формирование отчетов Microsoft Excel
  • Формирование отчетов в виде HTML-документов
  • Взаимодействие с разработчиком в случае ошибок, проблем, вопросов по работе системы


Запуск обозревателя данных

(одним файлом)
Запуск обозревателя данных

Для начала работы необходимо запустить исполняемый файл DataBrowser.exe. Это можно сделать посредством ярлыка, создаваемого инсталлятором Системы:

Ярлык обозревателя данных

При его запуске отобразится окно входа в систему:

Окно логина обозревателя данных

Для запуска системы необходимо заполнить поля формы входа в систему, после чего нажать кнопку ОК или клавишу Enter на клавиатуре. Если система ранее запускалась на Вашем локальном компьютере, то поля формы (за исключением поля Пароль) будут заполнены данными, введенными в прошлый раз. Если система на компьютере запускается впервые, то при открытии формы ее поля будут пустыми. Для заполнения полей формы необходимо знать, на каком типе сервера БД работает система, имя базы данных, с которой предстоит работать, имя пользователя и пароль. Если Вы не располагаете такой информацией, узнайте ее у администратора системы.

  • Источник данных - в этом поле из выпадающего списка выберите тип сервера баз данных, на котором функционирует система; возможен выбор из трех вариантов:
    • если система работает на сервере Interbase (Firebird), выберите пункт Interbase/FireBird Server;
    • если система работает на сервере Oracle, выберите пункт Oracle Database Server;
    • если система работает на сервере MSSQL, выберите пункт Microsoft SQL Server.
  • База данных - в этом поле необходимо указать имя базы данных.
  • Имя пользователя - в этом поле введите Ваше имя пользователя (логин).
  • Пароль - в это поле введите Ваш пароль.
Для удобства последующего запуска системы Вы можете воспользоваться флажками "Сохранить пароль" и "Входить автоматически".
  • Сохранить пароль - если установить этот флажок, то Ваш пароль будет запомнен и подставлен в поле Пароль при следующем запуске системы. В связи с тем, что информация о вводимом Вами пароле будет сохранена на Вашем локальном компьютере, пользоваться этим флажком рекомендуется только в том случае, если возможность несанкционированного доступа к Вашему компьютеру исключена.
  • Входить автоматически - этот флажок доступен только при установленном флажке "Сохранить пароль". Если установить этот флажок, то при следующем входе в систему Вам не придется заполнять поля формы и нажимать кнопку OK или клавишу Enter. Форма покажется на некоторое время, после чего произойдет автоматический вход в систему.

Если Вы установили флажок "Входить автоматически", но хотите изменить ранее введенную в поля информацию, необходимо выполнить щелчок мышью (здесь и далее "щелчок мышью" означает щелчок ЛЕВОЙ кнопкой мыши. Если необходим щелчок ПРАВОЙ кнопкой мыши, то будет указано "щелчок правой кнопкой мыши") на форме во время ее показа. После этого можно будет изменить ранее установленные в полях значения.


Элементы интерфейса пользователя

(одним файлом)
Элементы интерфейса пользователя

При входе в систему на экране отобразиться ее главное окно. Макет главного окна системы:

Макет главного окна обозревателя данных

В заголовке главного окна системы отображается имя запущенного приложения (Databrowser.exe), имя пользователя (sysdba) и имя базы данных (C:\project\databases\icecream.fdb). Интерфейс состоит из трех основных элементов:

  1. В верхней части экрана расположена Панель инструментов. На ней расположены иконки, соответствующие доступным в настоящее время действиям, а также доступным для текущего пользователя формам.
  2. В левой части экрана расположен Инспектор объектов, позволяющий просматривать и редактировать свойства объектов, выбранных в таблицах данных.
  3. Основную часть экрана занимают Формы с Таблицами данных. Таблицы данных используются для просмотра и редактирования объектов, учитываемых в системе.


Работа с формами и таблицами данных

(раздел целиком) (одним файлом)
Работа с формами и таблицами данных

Для отображения записей об учитываемых в системе объектах используются формы с таблицами данных. Каждая форма представляет собой отдельное окно с заголовком, на котором отображается ее наименование. Основную часть окна формы занимают таблицы данных. Переключаться между доступными формами можно либо при помощи щелчка мышью по иконке, соответствующей форме на Панели инструментов, либо при щелчке мышью на самом окне формы (если форма видна). В каждый момент времени активной является одна из форм (или ни одной). Окно формы можно "перетаскивать" (здесь и далее "перетащить" объект означает подвести к нему указатель мыши, нажать левую кнопку, удерживая кнопку переместить объект на новое место, после чего отпустить кнопку мыши) по экрану за заголовок, изменять его размеры, минимизировать, восстановить, раскрывать на весь экран или закрывать. Эти действия осуществляются стандартным для среды Windows образом. При закрытии формы соответствующая ей иконка на панели инструментов будет отображена неактивной. При щелчке мышью по такой иконке форма откроется, и иконка станет активной.

Таблицы данных в форме расположены на закладках с заголовками, соответствующими наименованиям таблиц данных. Например, на предыдущем рисунке активна форма "Продажи мороженого". В этой форме на первом уровне расположены таблицы данных "Регионы", "Сорта мороженого", "Сорта фруктового мороженого", "Представительства", "Все продажи". Активной в настоящее время является таблица данных "Представительства".

  • Подчиненные таблицы данных и взаимное расположение главной и подчиненных таблиц
  • Отображение учитываемых объектов в таблице данных
  • Выбор объектов в таблице данных
  • Изменение порядка отображения колонок
  • Скрытие и отображение колонок
  • Сортировка данных в таблицах
  • Группировка данных в таблицах
  • Фильтрация данных в таблицах
  • Отображение итоговых значений (агрегатов) по колонкам
  • Редактирование данных в таблице
  • Выполнение действий над объектами
  • Работа с панелью инструментов
  • Стандартные действия, доступные в любых таблицах данных


Подчиненные таблицы данных и взаимное расположение главной и подчиненных таблиц

(одним файлом)
Подчиненные таблицы данных и взаимное расположение главной и подчиненных таблиц

Таблицы данных могут иметь подчиненные таблицы. Подчиненные таблицы по умолчанию отображаются в нижней части главной таблицы. Набор записей, отображаемых в подчиненной таблице, зависит от того, какие записи выбраны в главной таблице.

Например, на рисунке в главной таблице "Представительства" выбрано представительство ООО "Холод плюс". При этом в подчиненной таблице "Продажи представительства" отображаются только те продажи, которые осуществлены данным представительством.

Подчиненные таблицы могут располагаться двумя способами:

  • на закладках - в этом случае в нижней части главной таблицы отображаются закладки с наименованиями подчиненных таблиц; переключаться между подчиненными таблицами можно путем щелчка мышью по соответствующей закладке;
    Отображение подчиненных таблиц на закладках
  • в отдельных окнах - в этом случае каждая из подчиненных таблиц располагается в своем окне; окна имеют заголовки, соответствующие наименованиям таблиц; окна, в которых отображаются подчиненные таблицы, можно перетаскивать за заголовок в любое другое место экрана, минимизировать, восстанавливать, закрывать и т.д.
    Отображение подчиненных представлений в отдельных окнах

Изменять соотношение размера главной и подчиненных таблиц можно путем перетаскивания горизонтального разделителя мышью. Для этого необходимо подвести указатель мыши к границе раздела зон главной и подчиненных таблиц и когда курсор примет форму горизонтального разделителя ( Горизонтальный разделитель) перетащить разделитель выше или ниже. При отображении подчиненных таблиц в отдельных окнах можно изменять соотношение ширины подчиненных таблиц. Для этого нужно подвести указатель мыши к вертикальной границе таблиц и когда указатель примет форму вертикального разделителя ( Вертикальный разделитель), перетащить разделитель вправо или влево.

При отображении подчиненных таблиц на закладках занимаемая ими область также может быть минимизирована. Для этого необходимо подвести курсор к границе раздела зон главной и подчиненной таблиц и когда он примет форму горизонтального разделителя ( Горизонтальный разделитель) выполнить двойной щелчок мышью.

Минимизация зоны подчиненных таблиц

Восстановить отображение подчиненных таблиц можно либо путем нажатия кнопки "Восстановить" ( Кнопка восстановления размеров зоны подчиненных таблиц) в заголовке минимизированного окна, либо при помощи двойного щелчка мышью на этом заголовке.


Отображение учитываемых объектов в таблице данных

(раздел целиком) (одним файлом)
Отображение учитываемых объектов в таблице данных

Таблица данных имеет строки и колонки. Строки таблицы (или записи) соответствуют учитываемым объектам. Колонки таблицы соответствуют свойствам объектов.

Макет таблицы данных

На рисунке представлен макет таблицы данных, в которой отображаются объекты, соответствующие сортам фруктового мороженого. Таблица данных имеет наименование "Сорта фруктового мороженого", которое отображается на соответствующей закладке (1). Таблица имеет пять строк (2), соответствующих пяти сортам фруктового мороженого. Выделенной в настоящее время является первая строка. Таблица имеет пять колонок, соответствующих свойствам учитываемых сортов мороженого. Каждая колонка имеет заголовок (4), отражающий отображаемое в этой колонке свойство. Активной в настоящее время является первая колонка. Активным элементом данных (3) является ячейка, расположенная в первой строке в первом столбце.

На рисунке активная строка и активный элемент данных выделяются оттенками синего цвета. Цвета, применяемые для выделения элементов данных, зависят от локальных настроек операционной системы Windows (стилей) на компьютере пользователя.

Под заголовком каждой колонки расположена строка фильтра (5). При помощи ввода в этой строке условия отбора или выбора значений из выпадающего списка можно осуществлять фильтрацию отображаемых в таблице данных.

Если отображаемые данные не помещаются в окно по ширине, то активной становится горизонтальная полоса прокрутки (7). С ее помощью можно пролистывать колонки таблицы вправо и влево. Если данные не помещаются в окно по вертикали, то активной становится вертикальная полоса прокрутки (8). С ее помощью можно пролистывать записи об объектах вверх и вниз. При щелчке правой кнопкой мыши на полосе прокрутки (если она активна) доступны действия по быстрой прокрутке содержимого таблицы.

При щелчке правой кнопкой мыши в области таблицы данных отображается контекстное меню. Контекстное меню отображает список действий, доступных над объектами, отображаемыми в таблице данных. Вызываемые действия выполняются для тех объектов, которые являются выделенными в таблице данных. Если ни одного объекта не выделено, некоторые действия контекстного меню могут быть недоступны. Набор действий, отображаемых в контекстном меню различен в разных таблицах данных.

  1. Заголовок закладки с именем таблицы данных.
  2. Выделенный объект.
  3. Выделенный элемент данных.
  4. Заголовок колонки.
  5. Строка фильтра.
  6. Флажок для выбора объектов.
  7. Горизонтальная полоса прокрутки.
  8. Вертикальная полоса прокрутки
  • Иерархические таблицы данных


Иерархические таблицы данных

(одним файлом)
Иерархические таблицы данных

Если отображаемые в таблице данные имеют иерархическую структуру (т.е. присутствует "вхождение" одних объектов в другие), то в таблице данных объекты могут отображаться в виде "дерева".

Иерархическая таблица данных

На рисунке представлена таблица данных, отображающая периоды обучения студентов. Эти данные имеют иерархическую структуру, которая отражает вхождение учебных модулей в состав семестров, а семестров в состав учебных годов. В первой колонке иерархической таблицы данных слева от элементов данных, имеющих подчиненные элементы, отображаются значки Свернутый узел дерева или Развернутый узел дерева. При щелчке мышью по значку Свернутый узел дерева отображаются подчиненные объекты. Значок Свернутый узел дерева при этом превращается в значок Развернутый узел дерева. При щелчке мышью по значку Развернутый узел дерева подчиненные объекты скрываются и значок Развернутый узел дерева превращается в Свернутый узел дерева. На рисунке для объектов "Учебный год 2005-2006" и его подчиненных объектов "I семестр" и "II семестр" подчиненные объекты отображены. Щелчком по значку Развернутый узел дерева подчиненные объекты можно скрыть. Для объектов "I семестр" и "II семестр" учебного года 2006-2007 подчиненные объекты скрыты. Щелчком по значку Свернутый узел дерева их можно отобразить. При горизонтальном пролистывании таблицы данных вправо или влево "дерево" объектов всегда отображается слева от самого левого столбца.

В иерархических таблицах данных доступны дополнительные действия по управлению отображением и выбору объектов, которые описаны в разделе 4.7.1.


Выбор объектов в таблице данных

(одним файлом)
Выбор объектов в таблице данных

Выбор одного объекта в таблице данных может осуществляться либо щелчком мышью в соответствующей строке, либо при помощи стрелок ("вверх" и "вниз") на клавиатуре. Выбор активной колонки и активного элемента данных также может производиться щелчком мышью или при помощи стрелок ("вправо" и "влево") на клавиатуре.

В таблице данных можно также осуществлять произвольный выбор нескольких объектов путем установки флажка в строке, отображающей объект. Установка или снятие флажка производится при помощи щелчка мышью.

При выборе нескольких объектов в главной таблице в подчиненной таблице будут отображены записи, соответствующие подчиненным объектам, отобранным для ВСЕХ объектов, выбранных в главной таблице.

Произвольный выбор объектов

На рисунке представлена таблица данных "Учащиеся", имеющая ряд подчиненных таблиц. На рисунке открыта подчиненная таблица "Родственники и контактные лица". В таблице данных "Учащиеся" путем установки флажка произвольным образом выбраны три учащихся с фамилиями Матвеева, Зимогляд и Анчевский. При этом в подчиненной таблице "Родственники и контактные лица" отображены родители всех троих учащихся.

При выборе объектов путем простановки флажков необходимо осуществлять щелчок мышью именно на флажке. Если выполнить щелчок мышью в любой другом месте записи, ранее установленные флажки будут сняты, и выбранной станет одна эта запись.

Для быстроты и удобства выбора объектов доступны дополнительные возможности:

  • для выделения нескольких объектов подряд можно щелкнуть мышью в любом месте записи, соответствующей первому объекту, а затем, удерживая клавишу Shift, щелкнуть по записи, соответствующей последнему объекту; все объекты между первым и последним, включая их, будут выделены;
  • осуществлять произвольный выбор объектов можно щелчком мышью в любом месте записи, удерживая клавишу Ctrl ;
  • можно воспользоваться действиями, доступными в подменю "Выбранные" на панели инструментов или в контекстном меню:
    • Выбрать все - все отображаемые в настоящий момент в таблице данных объекты будут выбраны;
    • Показать только выбранные - в таблице данных будут отображены только те объекты, которые помечены как выбранные; остальные объекты будут скрыты;
    • Показать все - если ранее было установлен отбор только выбранных объектов, этот отбор будет снят, и снова будут отображены все доступные в таблице объекты.

При выборе объектов изменяется информация, отображаемая Инспектором объектов. Если выбран один объект, то Инспектор объектов отображает и позволяет редактировать все доступные пользователю свойства этого объекта. Если выбрано несколько объектов, отображение и редактирование свойств Инспектором объектов происходит по правилам, описанным в разделе 5 "Работа с Инспектором объектов".

При выполнении действий над объектами выбранное действие будет выполнено для всех выбранных объектов. Если не выбрано ни одного объекта, некоторые действия могут быть недоступны.

При одновременном выборе большого числа объектов быстродействие системы может снижаться. При необходимости работы с большой выборкой объектов лучше воспользоваться возможностью фильтрации данных.


Изменение порядка отображения колонок

(одним файлом)
Изменение порядка отображения колонок

Порядок отображения колонок может быть изменен путем "перетаскивания" их заголовков. Для того чтобы переместить колонку правее или левее, подведите указатель мыши к заголовку колонки, нажмите левую кнопку мыши и, не отпуская ее, перетащите заголовок колонки вправо или влево. После того, как Вы отпустите кнопку мыши, порядок отображения колонок изменится.

Изменение порядка отображения колонок

На рисунке изображено перетаскивание заголовка колонки "Вид упаковки" в таблице данных "Сорта мороженого". После того, как кнопка мыши будет отпущена, колонка "Вид упаковки" станет третьей слева, а колонка "Число продаж" второй.


Скрытие и отображение колонок

(одним файлом)
Скрытие и отображение колонок

Любая из видимых в таблице данных колонок может быть скрыта. Для этого необходимо выделить любой элемент данных в колонке, щелчком правой кнопкой мыши открыть контекстное меню и в нем в подменю "колонка" выбрать действие "Скрыть эту колонку".

На рисунке показано как скрыть колонку "Вид упаковки" в таблице данных "Сорта мороженого". Описанным выше образом можно скрыть любое число колонок таблицы данных кроме последней. Если в таблице данных осталась одна колонка, то действие "Скрыть эту колонку" будет недоступно. Для отображения скрытых ранее колонок таблицы данных необходимо воспользоваться действием "Показать скрытые колонки" в подменю "колонка" контекстного меню. (На рис. 12. действие располагается ниже действия "Скрыть эту колонку"). Если ни одной колонки таблицы данных не скрыто, то действие "Показать скрытые колонки" будет недоступно. Действия, расположенные в подменю "колонка" доступны также на панели инструментов.


Сортировка данных в таблицах

(одним файлом)
Сортировка данных в таблицах

Отображаемые в таблице данные могут быть отсортированы по возрастанию или по убыванию значений свойств, отображаемых в одной или нескольких колонках. Для сортировки данных по одной колонке необходимо выполнить щелчок мышью не ее заголовке. Данные будут отсортированы по возрастанию значения в этой колонке. Если щелкнуть мышью по заголовку колонки еще раз, то данные будут отсортированы по убыванию значения в этой колонке. В заголовке конке появится стрелочка, отображающая порядок сортировки (направленная вверх в случае сортировки по возрастанию и вниз в случае сортировки по убыванию). Если выполнить щелчок мышью по заголовку другой колонки, то данные будут отсортированы по значению в новой колонке.

Сортировка данных по одной колонке

На рисунке данные в таблице данных "Учащиеся" отсортированы по значению в колонке "Фамилия" по возрастанию. В заголовке колонки "Фамилия" отображается направленная вверх стрелочка. Для сортировки данных по значениям в нескольких колонках необходимо выполнить щелчок мышью на заголовке первой колонки, затем, удерживая клавишу Ctrl, выполнить щелчок по заголовку второй колонки и т.д. При этом в заголовках колонок будут отображаться стрелочки, соответствующие направлению сортировки и цифры, соответствующие порядку колонок в сортировке.

Сортировка данных по нескольким колонкам

На рисунке представлен пример сортировки данных таблицы данных "Учащиеся" по региону (по возрастанию), затем по полу (по убыванию) и затем по фамилии (по возрастанию). В заголовках колонок отображены соответствующие стрелочки с цифрами 1, 2 и 3.

В иерархических таблицах данные сортируются в пределах каждого уровня иерархии.

Сортировка данных в иерархической таблице

На рисунке данные в иерархической таблице данных "Направления и специальности" отсортированы по колонке "Наименование" по возрастанию.


Группировка данных в таблицах

(одним файлом)
Группировка данных в таблицах

Данные в таблице данных могут быть сгруппированы по значениям свойств, отображаемым в одной или в нескольких колонках.

Для осуществления группировки по значению в одной из колонок необходимо выделить любой элемент данных в этой колонке. Затем щелчком правой кнопки мыши открыть контекстное меню и в нем в подменю "колонка" выбрать действие "Группировать по этой колонке".

Осуществление группировки данных

На рисунке показано, как при помощи действия в контекстном меню осуществляется группировка данных в таблице данных "Все продажи" по значению в колонке "Представительство".

При отображении данных в сгруппированном виде для каждой группы будет отображен заголовок на более темном фоне. В заголовке группы будут отображены наименование и значение свойства, по которому осуществлена группировка, а слева от наименования будет расположен значок Развернутый узел дерева или Свернутый узел дерева. При нажатии на значок Развернутый узел дерева можно скрывать объекты группы (для группы будет отображен только ее заголовок). Значок Развернутый узел дерева при этом изменится на Свернутый узел дерева. При нажатии на значок Свернутый узел дерева объекты, входящие в группу, будут снова отображены.

Отображение данных в сгруппированном виде

На рисунке данные в таблице данных "Все продажи" сгруппированы по значению в колонке "Представительство". Группы объектов, соответствующие представительствам ЗАО "Айс девелопмент", ЗАО "Фрост интернешнл" и ООО "Заморозь соседа", раскрыты. Группы, соответствующие ОАО "Красный нос" и ООО "Дед мороз и лето", свернуты.

Данные могут группироваться и по нескольким колонкам. Для этого необходимо повторить описанные выше действия для всех колонок, которые должны быть включены в группировку.

Группировка данных по нескольким колонкам

На рисунке представлен пример группировки данных, отображаемых в таблице данных "Все продажи" по колонкам "Регион" и "Сорт мороженого".

Для снятия группировки и отображения данных в стандартном виде необходимо воспользоваться действием "Очистить группировку", которое также доступно в контекстном меню в подменю "колонка" (на рисунке расположено в выпадающем меню ниже действия "Группировать по этой колонке").

Действия, расположенные в подменю "колонка", доступны также на панели инструментов.


Фильтрация данных в таблицах

(одним файлом)
Фильтрация данных в таблицах

Фильтрация данных (отображение только тех данных, которые удовлетворяют некоторому условию) осуществляется по значениям, отображаемым в колонках, при помощи строки фильтра. Строка фильтра расположена ниже заголовка колонки. Фильтрация данных может осуществляться двумя способами:

  • путем выбора значения из выпадающего списка, доступного при нажатии кнопки Кнопка выпадающего списка в строке фильтра
  • путем записи условия фильтрации в строке фильтра

При нажатии кнопки Кнопка выпадающего списка в строке фильтра отображается выпадающий список значений, которые могут быть выбраны. Перечень отображаемых значений зависит от типа данных, отображаемых в колонке. В первой строке списка расположен пункт "(Все)". При выборе этого пункта фильтрация данных по этой колонке не осуществляется. При выборе одного из доступных значений в таблице данных будут отображены только те объекты, для которых значение свойства, отображаемого в данной колонке, равно выбранному. После осуществления фильтрации в строке фильтра будет отображено выбранное значение. Выбор значений можно осуществить в нескольких колонках. В этом случае условия отбора по каждой колонке будут объединены логическим "И".

Фильтрация данных путем выбора значения в строке фильтра

На рисунке показано, как осуществить фильтрацию данных по значению "эскимо" в колонке "Вид упаковки". После выполнения фильтрации эта таблица данных будет выглядеть следующим образом:

Отображение данных в отфильтрованном виде

В таблице данных на рисунке отображены записи только о тех сортах мороженого, которые продаются в виде эскимо. Значение "эскимо" отображено в строке фильтра в колонке "Вид упаковки".

Для фильтрации данных по более сложному условию можно воспользоваться вторым способом - записью условия фильтрации в строке фильтра. Условие фильтрации записывается по следующим правилам:

  1. Строка разделяется на части посредством системного разделителя (системный разделитель устанавливается в настройках операционной системы Windows). Обычно - точка с запятой, ";"
  2. Каждая часть строки интерпретируется самостоятельно, и эти части объединяются логическим "ИЛИ"
  3. При интерпретации каждой части проверяются следующие условия:
    Часть строки | Правило отбора объектов
    * Будут отобраны только те объекты, у которых значение в колонке не является пустым (установлено).
    !* Будут отобраны только те объекты, у которых значение в колонке является пустым (не установлено).
    начинается с символов '<=', '<', '>=', '>' | Будут отобраны только те объекты, у которых значение в колонке удовлетворяет условию.
    включает в себя символы '*' и/или '?' | Будут отобраны только те объекты, у которых значение в колонке удовлетворяет шаблону, в котором знак '?' соответствует одному любому символу, а знак '*' - любому количеству любых символов.
    начинается с символа '!' | Будут отобраны только те объекты, у которых значение в колонке не удовлетворяет условию, переданному оставшейся частью строки (знак '!' означает отрицание).
    представляет собой строку в апострофах (одиночных кавычках) | Содержание строки не анализируется по приведенным выше правилам. Будут отобраны только те объекты, у которых значение данного свойства соответствует строке, заключенной в апострофы.
    любая другая строка | Будут отобраны только те объекты, у которых значение данного свойства соответствует введенной строке (строки чувствительны к регистру).
  4. Условия, указанные в разных колонках, объединяются логическим "И"

После ввода в строке фильтр требуемого условия необходимо нажать клавишу Enter.

Фильтрация данных по сложному условию

В таблице данных "Все продажи" на рисунке отобраны только те записи, для которых верно следующее: Продажи осуществлены в регионе "Москва" или "Тверская область"; при этом наименование проданного сорта мороженого начинается с "Б"; при этом число продаж данного сорта больше 100.

Сделать заключение о том, что отображаемые в таблице данные отфильтрованы, можно по наличию в строке фильтра записи отличной от "(Все)". Снять фильтрацию данных можно одним из двух способов:

  • выбрать в строке фильтра из выпадающего списка пункт "(Все)"
  • удалить все символы, записанные в строке фильтра и нажать клавишу Enter


Отображение итоговых значений (агрегатов) по колонкам

(одним файлом)
Отображение итоговых значений (агрегатов) по колонкам

По любой из колонок таблицы данных может быть рассчитано и отображено итоговое значение (агрегат). В зависимости от типа отображаемого в колонке свойства могут быть вычислены следующие агрегаты:

  • количество объектов (для свойств любых типов)
  • сумма значений (для числовых значений)
  • наименьшее (минимальное) значение (для строковых, числовых, логических значений, перечислений, значений типа даты, времени, даты со временем)
  • наибольшее (максимальное) значение (аналогично наименьшему значению)
  • среднее значение (для числовых значений)

Для отображения агрегата по одной из колонок необходимо выделить элемент данных в этой колонке, при помощи щелчка правой кнопкой мыши отобразить контекстное меню и в нем в подменю "колонка" выбрать действие, соответствующее нужному агрегату. После выполнения этого действия таблица данных будет выглядеть следующим образом:

Таблица данных с агрегатом по одной из колонок

На рисунке в нижней части таблицы данных отображена строка на светло-желтом фоне, в которой в колонке "Число продаж" показана сумма числа всех продаж, отображаемых в таблице.

Агрегат может быть вычислен и показан по любой из колонок.

Если данные в таблице отфильтрованы, то агрегат будет рассчитан только по тем записям, которые отобраны по условию фильтрации.

Если данные в таблице сгруппированы, то агрегаты будут рассчитаны как для всех отображаемых в таблице данных, так и отдельно для каждой группы.

Отображение агрегатов для сгруппированных данных

На рисунке данные о продажах сгруппированы по региону. Суммы числа продаж и среднее значение выручки отображены как для каждого региона (в строках на ярко-желтом фоне), так и для всех продаж в целом (в строке на светло-желтом фоне внизу таблицы).

Если свернуть группы, то можно просматривать только итоговые значения агрегатов для групп и для всех объектов в целом. Агрегаты при этом будут видны только в случае, если они отображаются правее надписи с именем и значением параметра группировки.

Режим отображения только агрегатов для групп


Редактирование данных в таблице

(одним файлом)
Редактирование данных в таблице

В таблице данных может редактироваться значение одного свойства одного объекта. Для того чтобы изменить отображаемое в таблице данных значение необходимо выделить требуемый элемент данных щелчком мышью или клавишами со стрелками на клавиатуре, после чего перевести элемент данных в режим редактирования. Это можно сделать одним из двух способов:

  • выполнить двойной щелчок мышью на элементе данных
  • при выделенном активном элементе данных нажать клавишу Enter на клавиатуре

После перевода элемента данных в режим редактирования отображаемый в нем текст будет выделен. Текст может быть отображен на белом или на сером фоне. Справа от текста могут появиться кнопки.

Перевод элемента данных в режим редактирования

На рисунке элемент данных в пятой сверху строке в первой колонке (текст "Белоснежка") переведен в режим редактирования.

Отображение элемента данных в режиме редактирования зависит от типа отображаемого свойства, доступности свойства для изменения и допустимости установленного значения.

  1. Редактирование значения "только для чтения"
    Если текст отображается на сером фоне, это означает, что свойство доступно только для чтения. У Вас нет возможности изменять его значение. Такое значение (или его часть) можно выделить и скопировать при помощи сочетания клавиш Ctrl+Ins или Ctrl+C и затем вставить в доступном для ввода значений месте в этом или в любом другом приложении.

  2. Редактирование недопустимого значения
    Если текст отображается на зеленом фоне, это означает, что установленное в данный момент значение недопустимо. Значение считается недопустимым, в одном из следующих случаев:
    • значение, обязательное для заполнения, не установлено
    • для свойства установлено значение, не удовлетворяющее его типу (например, на приведенном выше рисунке для числового свойства установлено значение, включающее буквы). Форматы, допустимые для значений различных типов, соответствуют локальным настройкам операционной системы Windows
    • длина текста для свойства строкового типа превышает максимально допустимую длину
    • введенное значение больше максимально допустимого или меньше минимально допустимого
    • для свойства, предполагающего выбор из списка или из справочника, установлено значение, не соответствующее ни одному из допустимых значений из списка или справочника
    Пока для свойства не будет установлено допустимое значение, применить выполненное изменение не удастся.

  3. Редактирование значения
    Если в режиме редактирования в ячейке отображается обычный текст на белом фоне, то значение свойства доступно для изменения. Редактирование значения производится при помощи клавиш клавиатуры. Выделенное значение или его часть может быть скопирована и вставлена стандартным образом. При редактировании текста обращайте внимание на тип свойства (строковое, числовое, дата и т.п.). Если введенное значение не будет удовлетворять типу, то оно будет считаться недопустимым и станет отображаться на зеленом фоне. Форматы, допустимые для значений различных типов, соответствуют локальным настройкам операционной системы Windows. После изменения значения необходимо нажать клавишу Enter для того, чтобы применить сделанные изменения.
  4. Если слева от текста в ячейке отображается флажок, это означает, что свойство может иметь одно из двух возможных значений. Одно из значений соответствует установленному флажку, другое - снятому. Если для свойства допустимо пустое значение, то в случае его установки флажок будет отображен на сером фоне и справа от него будет отображен текст "(Нет)".
    Редактирование логического значения "истина" Редактирование логического значения "ложь"
    Изменение значения такого свойства производится либо щелчком мыши по флажку, либо путем нажатия клавиши Пробел на клавиатуре.
  5. Редактирование значения в выпадающем списке
    Если справа от текста отображается кнопка с направленной вниз стрелкой, это означает, что значение свойства должно быть выбрано из списка допустимых значений. Изменять такое значение можно двумя способами:

    • Нажать на кнопку Кнопка выпадающего списка, расположенную справа от текста, в открывшемся выпадающем списке выбрать новое значение.

      Выбор значения из таблицы данных

      На рисунке показан выбор значения из выпадающего списка. Если Вы выбираете значение при помощи мыши, то достаточно выполнить щелчок мышью на нужном значении. Для выбора значения при помощи клавиатуры необходимо воспользоваться клавишами-стрелками "вверх" и "вниз", и когда нужное значение будет выделено, нажать клавишу Enter. Если для свойства допустимо пустое значение, то первым элементом выпадающего списка будет элемент "(Нет)". Если список включает больше восьми элементов, то в нем будет доступна вертикальная полоса прокрутки.

    • Ввести текст, соответствующий нужному элементу списка, с клавиатуры. В процессе ввода будут предлагаться допустимые для выбора значения. Если введенный с клавиатуры текст не будет удовлетворять ни одному из элементов списка, он будет отображен на зеленом фоне, и установить новое значение не удастся. При вводе значения с клавиатуры следите за регистром символов. После ввода нового значения необходимо нажать клавишу Enter.

  6. Редактирование значения с выбором
    Если справа от текста отображается кнопка с тремя точками, это означает, что данное свойство предполагает выбор значения из другой таблицы данных. Изменять такое значение можно двумя способами:

    • Нажать на кнопку Кнопка выбора, расположенную справа от текста; при этом откроется таблица данных, в которой нужно будет выбрать новое значение. В правом нижнем углу этой таблицы данных будут расположены кнопки OK и Отмена. Для выбора значения можно щелкнуть мышью по нужной записи или воспользоваться стрелками на клавиатуре. После выбора нужного значения нажмите кнопку OK. Если Вы не хотите менять ранее установленное значение, нажмите кнопку Отмена.

      Выбор значения из таблицы данных

      На рисунке представлена таблица данных, которая будет отображена для выбора значения свойства, представляющего собой сорт мороженого.

    • Ввести текст, соответствующий нужному значению, с клавиатуры. В процессе ввода будут предлагаться допустимые для выбора значения. Если введенный с клавиатуры текст не будет совпадать ни с одним из допустимых значений, он будет отображен на зеленом фоне, и установить новое значение не удастся. При вводе значения с клавиатуры следите за регистром символов. После ввода нового значения необходимо нажать клавишу Enter.

  7. Редактирование значения с выбором и выпадающим списком
    Если справа от текста отображаются две кнопки - кнопка со стрелкой и кнопка с тремя точками, то можно как выбирать значение из выпадающего списка, так и выбирать значение из таблицы данных (описано выше). В этом случае так же можно вводить текст, соответствующий допустимому значению с клавиатуры. После ввода значения с клавиатуры необходимо нажать клавишу Enter.

  8. Редактирование большого значения

    Если справа от текста отображены три кнопки, а сам текст представляет собой строку "(Данные)" или строку "(Нет)" это означает, что данное свойство представляет собой большой объект. Большой объект может быть текстом, файлом, содержащим изображение, xml-документ, исходный текст программных модулей или просто любые бинарные данные.

    При нажатии на кнопку Кнопка выбора отобразится окно, отображающее и позволяющее редактировать данные, представляющие собой большой объект.

    Окно для редактирования большого объекта

    На рисунке изображено окно, в котором может редактироваться исходный текст метода. После внесения изменений в текст окно редактирования нужно закрыть. Если в тексте действительно произошли изменения, то будет отображено предупреждение:

    Предупреждение окна редактирования большого объекта

    При нажатии кнопки Да окно редактирования будет закрыто, и изменения будут сохранены. При нажатии кнопки Нет окно редактирования будет закрыто, но произведенные изменения сохранены не будут. При нажатии кнопки Отмена окно редактирования останется открытым и работу с текстом можно будет продолжить.

    Копка Кнопка загрузки из файла позволяет загрузить содержимое большого объекта из файла. При нажатии этой кнопки отобразится стандартный диалог открытия файла Windows, в котором можно выбрать нужный файл, после чего нажать кнопку Открыть. При замене содержимого большого объекта новым будет отображено предупреждение:

    Предупреждение при загрузке из файла большого объекта

    Если нажать кнопку Да, то содержание большого объекта будет заменено новым, загруженным из указанного файла. Если нажать кнопку Нет, то содержание большого объекта не изменится

    Кнопка Кнопка сохранения в файл позволяет сохранить содержимое большого объекта в файл. При нажатии этой кнопки отобразится стандартный диалог сохранения файла Windows, в котором необходимо задать расположение и имя файла и нажать кнопку Сохранить. При сохранении файла необходимо явно указать его расширение. При сохранении файла никаких предупреждений не отображается.

    После изменения содержания большого объекта необходимо нажать клавишу Enter.


Выполнение действий над объектами

(одним файлом)
Выполнение действий над объектами

Все действия, которые могут быть произведены над объектами, могут быть выполнены одним из трех способов:

  • выбор действия в контекстном меню
  • вызов действия при помощи клавиш клавиатуры - "горячих клавиш" (доступно не для всех действий)
  • вызов действия при помощи иконки на панели инструментов (доступно не для всех действий)

При помощи действий производится добавление, удаление объектов, запуск различных процедур, выполняемых над данными, формирование отчетов.

Перечень всех действий, доступных в текущей таблице данных расположен в контекстном меню, которое отображается при нажатии правой кнопки мыши в зоне таблицы данных. Некоторые из действий выполняются для выбранных объектов (одного или нескольких), например, действие "Удалить". Для выполнения других действий выбор конкретного объекта не нужен, например, для действия "Добавить". Выбор действия в контекстном меню может производиться как при помощи мыши, так и при помощи стрелок на клавиатуре.

Если для действия установлены " горячие клавиши ", то из обозначения можно будет увидеть в правой части пункта контекстного меню. Действия могут вызываться как при нажатии одной клавиши, так и при помощи сочетания клавиш.

В некоторых пунктах контекстного меню может быть расположена стрелка Стрелка раскрытия контекстного меню. При выборе такого пункта никакого действия не выполняется, а открывается " подменю ", содержащее другие действия.

Выполнение действий над объектами при помощи контекстного меню

На рисунке изображено контекстное меню, отображающее все действия, доступные над объектом, соответствующим студенту Алехиной Елене Михайловне. Действиям "Добавить студента-специалиста", "Удалить" и "Обновить" соответствуют "горячие клавиши". Пункты меню "Перемещения", "Колонка", "Выбранные" имеют подменю. На рисунке открыто подменю пункта "Перемещения".

Для некоторых действий могут быть установлены изображения-иконки. В этом случае иконки отображаются на панели инструментов (подробнее в разделе 4.13. "Работа с панелью инструментов").

Если выполнение процедуры или отчета требует задания параметров, то при вызове действия отобразится форма задания параметров. Для выполнения действия необходимо заполнить поля формы и нажать кнопку OK (подробнее в разделе 6 "Работа с формой задания параметров").

Перед выполнением некоторых действий может быть отображено предупреждение. Например, перед удалением объекта может отображаться следующее окно:

Предупреждение при выполнении действия

Если в таком окне нажать кнопку Да, то действие будет выполнено. Если нажать кнопку Нет, то действие будет отменено.


Работа с панелью инструментов

(одним файлом)
Работа с панелью инструментов

На панели инструментов отображаются иконки, соответствующие доступным пользователю действиям и формам. Иконки могут иметь подписи, соответствующие наименованием действий или форм. Вызов действий или переключение между активными формами осуществляется при помощи щелчка мышью на одной из иконок. Если иконок много и они не помещаются на панели инструментов по ширине, то слева или справа отображаются кнопки прокрутки. Для прокрутки содержимого панели инструментов достаточно подвести указатель мыши к кнопке прокрутки.

На рисунке представлен пример панели инструментов. Иконки с подписями "Создать", "Удалить", "Колонка", "Выбранные", "Перенос в Excel" соответствуют доступным в текущей таблице данных действиям. Иконки с надписями "Системная форма" и "Продажи мороженого" соответствуют доступным пользователю формам. Справа от иконки "Продажи мороженого" расположена кнопка прокрутки. Подведя указатель мыши к этой кнопке, можно увидеть иконки, расположенные правее и не поместившиеся на панели инструментов.

Некоторые кнопки панели инструментов могут иметь выпадающие кнопки. Выпадающие кнопки соответствуют пунктам подменю контекстного меню. Справа от кнопок, имеющих выпадающие кнопки, расположена направленная вниз стрелочка. Если нажать мышью на эту стрелочку, то отобразится панель с выпадающими кнопками. На рисунке кнопки "Колонка" и "Выбранные" имеют выпадающие кнопки.

Панель выпадающих кнопок

Как и в контекстном меню, на панели инструментов некоторые кнопки могут быть недоступны. Доступность кнопки зависит от того, какие объекты в настоящий момент выделены, и от применимости действия к выделенным объектам.


Стандартные действия, доступные в любых таблицах данных

(раздел целиком) (одним файлом)
Стандартные действия, доступные в любых таблицах данных

Ряд стандартных действий, доступных объектов любого типа, может быть вызван из любой таблицы данных. Разработчиком конкретной прикладной системы некоторые из перечисленных в данном разделе действий могут быть скрыты. Также перечень доступных стандартных действий зависит от прав доступа конкретного пользователя.

Взаимное расположение, наименования и доступность стандартных действий могут зависеть от реализации прикладной системы. В следующих разделах описаны все стандартные действия, реализованные средствами платформы.

  • Копирование и вставка объектов
  • Подменю "Колонка" - работа с колонкой
  • Подменю "Выбранные" - работа с выбранными объектами
  • Перенос в Excel
  • Экспорт данных
  • Обновление данных таблицы
  • Доступ к настройкам системы
  • Дополнительные действия, доступные в иерархических таблицах данных


Копирование и вставка объектов

(одним файлом)
Копирование и вставка объектов

Объекты, отображаемые в таблице данных, можно копировать и вставлять. Вставлять объекты можно как в ту же таблицу данных, из которой они были скопированы, так и в другую таблицу данных, отображающую объекты того же типа. Для этого необходимо выполнить следующие действия:

  1. Выбрать один или несколько объектов, которые Вы хотите скопировать (см. раздел 4.3. "Выбор объектов в таблице данных").
  2. Вызвать действие "Копировать" из контекстного меню или при помощи иконки на панели инструментов.
  3. Перейти в таблицу данных, в которую Вы хотите вставить скопированные объекты.
  4. Вызвать действие "Вставить" из контекстного меню или при помощи иконки на панели инструментов.

При копировании и вставке происходит создание копии объекта. Все свойства нового объекта, кроме свойства "Имя" (или замещающего его свойства), будут такими же, как у первичного объекта. Свойство имя будет равно строке, составленной из слова "Копия " и имени первичного объекта. После вставки объекта значение свойства "Имя" можно изменить.

Действия "Копировать" и "Вставить" имеют соответствующие иконки на панели инструментов:
Кнопка "копировать" Кнопка "вставить"


Подменю "Колонка" - работа с колонкой

(одним файлом)
Подменю "Колонка" - работа с колонкой

Действия, доступные в подменю "Колонка" в контекстном меню или на панели инструментов могут быть применены к колонкам любой таблицы данных. Доступность тех или иных действий над колонкой зависит от типа данных, отображаемых в колонке, и от того, какие действия над колонкой уже совершены (например, нельзя вычислить сумму значений строкового типа, или нельзя очистить группировку, если данные не сгруппированы).

Иконка "Колонка" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с колонкой

Действия, доступные в подменю "Колонка", описаны в разделах 4.6. "Скрытие и отображение колонок", 4.8. "Группировка данных в таблицах", 4.10. "Отображение итоговых значений (агрегатов) по колонкам".


Подменю "Выбранные" - работа с выбранными объектами

(одним файлом)
Подменю "Выбранные" - работа с выбранными объектами

Действия, доступные в подменю "Выбранные" позволяют быстро отбирать и снимать отбор с объектов, а также устанавливать режим отображения в таблице данных только тех объектов, которые помечены как выбранные.

Иконка "Выбранные" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с выбранными объектами

Назначение этих действий описано в разделе 4.3. "Выбор объектов в таблице данных".


Перенос в Excel

(одним файлом)
Перенос в Excel

Данные, отображаемые в любой из таблиц данных, могут быть перенесены в MS Excel. При этом в MS Excel будут сохранены все настройки отображения данных (сортировка по одной или нескольким колонкам, группировка, отображение итоговых значений). Действие "Перенос в Excel" может быть вызвано из контекстного меню или при помощи иконки на панели инструментов. С данными, перенесенными в MS Excel, далее могут производиться любые манипуляции средствами этого приложения.

Если в таблице много записей, то перенос данных в Excel может занять некоторое время. Если это время превышает 10 сек., то отобразится окно, сообщающая, что система находится в работе. В этом окне будет отображен индикатор процесса переноса данных:
Индикатор прогресса переноса данных в Excel

Действие "Перенос в Excel" имеет соответствующую иконку на панели инструментов:
Кнопка переноса в Excel


Экспорт данных

(одним файлом)
Экспорт данных

Отображаемые в таблицах данных объекты могут быть экспортированы в виде xml-документа. Для того, чтобы осуществить экспорт объектов, необходимо выполнить следующее:

  1. Выбрать объекты, подлежащие экспорту (см. раздел 4.3. "Выбор объектов в таблице данных").
  2. Вызвать действие "Экспортировать" из контекстного меню или при помощи иконки на панели инструментов.
  3. В открывшемся окне сохранения файла указать местоположение и имя файла. Дать файлу расширение .xml.


Обновление данных таблицы

(одним файлом)
Обновление данных таблицы

После выполнения действий над различными объектами, хранящимися в системе, их новое состояние может сразу не отобразиться в таблице данных. Для того чтобы получить из базы данных последние актуальные данные необходимо воспользоваться действием "Обновить", которое доступно в контекстном меню, при помощи иконки на панели инструментов, а также может быть доступно при нажатии клавиши F5.

Действие "Обновить" имеет соответствующую иконку на панели инструментов:
Кнопка обновления набора данных


Доступ к настройкам системы

(одним файлом)
Доступ к настройкам системы

При наличии соответствующих прав доступа Вы можете просматривать и изменять настройки системы. Доступ к меню настроек осуществляется при помощи действия "Настройки", которое может быть вызвано из контекстного меню или при помощи иконки на панели инструментов. При вызове этого действия отобразится форма задания настроек. Эта форма аналогична форме задания параметров (см. раздел 6 "Работа с формой задания параметров"). Если Вы имеете права администратора системы, то форма задания настроек, кроме кнопок OK и Отмена, будет иметь кнопку "По умолчанию". При нажатии этой кнопки значения, установленные в полях формы станут значениями настроек по умолчанию.

Форма задания настроек системы

Если в системе нет доступных для текущего пользователя настроек, то при вызове действия "Настройки" отобразится окно:
Сообщение об отсутствии доступных настроек

Действие "Настройки" имеет соответствующую иконку на панели инструментов:
Кнопка формы настроек


Дополнительные действия, доступные в иерархических таблицах данных

(одним файлом)
Дополнительные действия, доступные в иерархических таблицах данных

В иерархических таблицах данных дополнительно доступны действия, позволяющие управлять раскрытием и свертыванием элементов иерархии. Эти действия расположены в подменю "Дерево". Иконка "Дерево" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с иерархией

При помощи этих действий можно управлять отображением дерева иерархически организованных объектов следующим образом:

  • Развернуть все - все элементы дерева будут раскрыты.
  • Свернуть все - все дочерние элементы будут свернуты. Отображенными останутся только элементы первого уровня (не имеющие родительских элементов).
  • Развернуть от выбранного - узел дерева, соответствующий выбранному объекту и все его дочерние узлы будут раскрыты.
  • Свернуть к выбранному - узел дерева, соответствующий выбранному объекту у все его дочерние узлы будут свернуты.
  • Свернуть к этому уровню - все узлы дерева, лежащие на том же уровне, что и выбранный объект или на более низких уровнях будут свернуты.
  • Выделить дочерние - все объекты, дочерние по отношению к выбранному, будут выделены.


Работа с Инспектором объектов

(раздел целиком) (одним файлом)
Работа с Инспектором объектов
  • Отображение свойств Инспектором объектов
  • Управление положением Инспектора объектов на экране и порядком отображения свойств
  • Редактирование значений свойств при помощи Инспектора объектов


Отображение свойств Инспектором объектов

(одним файлом)
Отображение свойств Инспектором объектов

Инспектор объектов предназначен для просмотра и редактирования свойств одного или нескольких объектов, выбранных в активной таблице данных. Инспектор объектов имеет две колонки. В левой колонке отображаются наименования свойств, в правой колонке отображаются значения свойств. Набор отображаемых свойств и их значений зависит от того, сколько объектов каких типов выбрано в текущей таблице данных (подробнее о выборе объектов см. раздел 4.3. "Выбор объектов в таблице данных"). Свойства выбранных объектов отображаются Инспектором объектов по следующим правилам:

  1. Если в таблице данных выбран один объект, то в Инспекторе объектов отображаются все свойства этого объекта, видимые пользователю.
  2. Если в таблице данных выбрано несколько объектов, то
    • Инспектор объектов будет иметь строки, соответствующие только тем свойствам, которые есть у всех выделенных объектов;
    • если у всех выделенных объектов значение свойства одинаково, то это значение будет отображено в правой колонке; в противном случае в правой колонке будет отображено пустое значение.
  3. При изменении значения свойства в Инспекторе объектов новое значение будет установлено для всех выделенных объектов.

Выбран один объект - вид на инспектор объектов
Выбран один объект - вид на таблицу

На рисунке представлен пример таблицы данных, отображающей учитываемые в системе сорта мороженого. Среди сортов мороженого есть как обычные сорта, так и сорта фруктового мороженого, дополнительно обладающие свойством "Фрукт". В таблице данных выделен один объект, соответствующий сорту фруктового мороженого "Тропический рай". При этом Инспектор объектов отображает все свойства данного объекта (в том числе свойство "Фрукт").

Выбрано несколько объектов - вид на инспектор объектов

Выбрано несколько объектов - вид на таблицу

На рисунке в той же таблице данных выбрано два объекта: сорт мороженого "Тропический рай" (фруктовое мороженое) и сорт "Белый Бим черное ухо" (обычное мороженое). При этом в Инспекторе объектов отображаются только те свойства, которые являются общими для выделенных объектов (свойство "Фрукт" не отображается). Значения свойств "Вид упаковки" и "Вес" для выбранных объектов одинаковы, поэтому их значения отображены в правой колонке Инспектора объектов. Значения остальных свойств для данных объектов различны, поэтому для этих свойств отображаются пустые значения. Если изменить одно из свойств в Инспекторе объектов, то новое значение будет установлено как для сорта мороженого "Тропический рай", так и для сорта мороженого "Белый Бим черное ухо".

Порядок отображения свойств в Инспекторе объектов устанавливается разработчиком прикладной системы. Также разработчиком прикладной системы может быть установлено отнесение свойств к категориям. В этом случае свойства могут отображаться сгруппированными по категориям. Слева от наименования каждой категории будет отображен значок Свернутый узел дерева или Развернутый узел дерева. Нажатием мышью на значок Развернутый узел дерева свойства, входящие в категорию, можно свернуть, нажатием на значок Свернутый узел дерева их можно снова отобразить.

Отображение Инспектором объектов свойств, сгруппированных по категориям

На рисунке представлен пример отображения Инспектором объектов свойств объекта, соответствующего дисциплине учебного плана студентов. Свойства, отнесенные к категориям "Формы текущего контроля" и "Распределение аудиторных часов по модулям", свернуты. Свойства, отнесенные к категории "Учебные часы" раскрыты.

В связи с тем, что выбор свойств объектов для отображения, получение и сравнение их значений происходит по специальному алгоритму, в случае одновременного выбора большого числа объектов скорость работы Инспектора объектов может снижаться. Если на вычисление значения общего свойства группы объектов требуется значительное время, то такое свойство может отображаться как свойство с отложенным вычислением. Для такого свойства в правой колонке вместо значения может отображаться строка (...). При активизации этого свойства справа отобразится кнопка со знаком вопроса Кнопка вычисления отложенного свойства. Если нажать на эту кнопку, то значение свойства будет определено и отображено.

Свойство с отложенным вычислением


Управление положением Инспектора объектов на экране и порядком отображения свойств

(одним файлом)
Управление положением Инспектора объектов на экране и порядком отображения свойств

Инспектор объектов отображается в отдельном окне. Это окно можно перетаскивать по экрану за заголовок, изменять его размеры стандартным для операционной системы Windows образом. На панели инструментов всегда присутствует иконка Инспектора объектов, при нажатии которой можно отобразить окно Инспектора (если оно не видимо) и сделать его активным:
Кнопка инспектора объектов

При нажатии правой кнопки мыши в левом столбце Инспектора объектов или в свободном нижнем поле доступно контекстное меню Инспектора объектов. При помощи действий, расположенных в этом меню можно управлять режимом работы окна Инспектора и порядком отображения свойств.

Контекстное меню инспектора объектов

Выбор одного из пунктов контекстного меню переводит Инспектор объектов в новый режим работы. После этого рядом с пунктом меню отображается галочка Флажок в контекстном меню или точка Радиокнопка в контекстном меню. При повторном выборе помеченного пункта меню соответствующий режим работы отменяется и отметка снимается. Доступные пункты контекстного меню позволяют устанавливать следующие режимы работы Инспектора объектов.

  • При выборе пункта меню Всегда наверху окно Инспектора объектов будет всегда отображаться на переднем плане независимо от переключения между активными таблицами данных.
  • Если выбрать пункт меню Прозрачное окно, то окно Инспектора объектов станет полупрозрачным.
  • Если выбрать пункт меню Показать скрытые свойства, то кроме свойств, отображаемых в обычном режиме (свойства, созданные разработчиком прикладной системы как " видимые ") будут отображены свойства объектов, " невидимые " пользователю.
  • Пункт меню Сортировать по алфавиту позволяет отображать свойства не в порядке, установленном разработчиком прикладной системы, а в алфавитном порядке их наименований. Такой режим работы удобен в случае, если необходимо найти свойство по его наименованию.
  • Пункты подменю Группировка позволяют:
    • Группировать по категории - свойства будут отображены сгруппированными по категориям (показано на рисунке);
    • Группировать по классу - свойства будут отображены сгруппированными по классу объектов, членами которого они являются;
    • Не группировать - свойства будут отображены без группировки.


Редактирование значений свойств при помощи Инспектора объектов

(одним файлом)
Редактирование значений свойств при помощи Инспектора объектов

При помощи Инспектора объектов удобно изменять значения свойств одного или одновременно нескольких выбранных объектов (о выборе объектов см. раздел 4.3. "Выбор объектов в таблице данных"). Одно из свойств, отображаемых в Инспекторе объектов, всегда является активным. Активное значение выделяется в Инспекторе объектов рамкой, его значение отображается в режиме редактирования.

Отображение свойств в режиме редактирования и способы изменения значений свойств аналогичны редактированию данных в таблице данных (см. раздел 4.11. "Редактирование данных в таблицах"). Отличие работы Инспектора объектов заключается в том, что с его помощью можно изменять значение свойства сразу нескольких выбранных объектов.


Работа с формой задания параметров

(одним файлом)
Работа с формой задания параметров

Форма задания параметров используется для организации диалога с пользователем по заданию параметров, необходимых для выполнения метода или формирования отчета. Форма задания параметров открывается при вызове действия, для выполнения которого необходимо задать параметры.

Форма задания параметров представляет собой форму, содержащую поля различного вида. В правом нижнем углу формы расположены кнопки ОК и Отмена.

Форма задания параметров

Слева или сверху от каждого поля расположено его наименование. Наименования поля отражает, какие данные должны быть в него введены. Поля формы объединяются в группы. Группы полей могут располагаться в столбцах или на закладках. На рисунке выше поля формы расположены в двух столбцах. Если поля расположены на закладках, то в верхней части формы отображаются заголовки закладок с их наименованиями.

Расположение полей формы на закладках

На рисунке представлена та же форма, что и на рисунке выше, но с расположением параметров на закладках.

Порядок отображения полей на форме, а также способ их отображения (в столбцах или на закладках) задается разработчиком прикладной системы. Переход от одного поля к другому может осуществляться либо щелчком мышью на новом поле, либо при помощи клавиши Tab на клавиатуре. Переключаться между закладками можно путем нажатия мышью ни их заголовок.

Для выполнения действия, требующего задания параметров, необходимо заполнить все обязательные поля формы. После установления допустимых значений все поля формы должны приобрести белый фон. При этом условии кнопка OK станет доступной. После нажатия кнопки OK будет выполнен вызываемый метод или сформирован отчет. Если Вы хотите отменить выполнение действия, нажмите кнопку Отмена.

Поля формы могут иметь белый, зеленый или серый фон, а также могут иметь различный внешний вид. Цвет фона зависит от доступности для изменения и допустимости введенного в поле значения. Внешний вид поля зависит от типа данных, которые должны быть в него введены. Возможны следующие варианты внешнего вида полей и способ установления в них значений:

  1. Если поле имеет серый фон, то его значение недоступно для изменения. Такие поля используются для отображения дополнительной информации. Значения в таких полях могут изменяться автоматически при установке новых значений в других полях формы.
    Редактирование значения "только для чтения" на форме
  2. Обычное поле отображается в случае, когда в него должно быть введено строковое значение длиной до 128 символов, целочисленное, вещественное (с целой и дробной частью) значение, значение типа даты, времени, или даты со временем
    Редактирование недопустимого значения на форме
    В таком поле можно вводить текст с клавиатуры, копировать и вставлять его. Введенные в такое поле символы проверяются на соответствие типу данным (на основе локальных настроек компьютера) и на удовлетворение значения дополнительным условиям, которые могут быть установлены разработчиком прикладной системы. В случае если введенный набор символов соответствует недопустимому для данного поля значению, поле приобретет зеленый фон.
    Редактирование значения на форме - установлено допустимое значение
    Редактирование недопустимого значения даты на форме - установлено недопустимое значение.
  3. Для ввода строковых значений, длина которых может превышать 128 символов, отображаются расширенные поля ввода:
    Редактирование длинной строки на форме
    В таком поле можно вводить текст с клавиатуры, копировать его и вставлять. Также в таком поле может вводится многострочный текст. Перенос строки осуществляется нажатием клавиш Ctrl+Enter. Если текст имеет большое число строк, для его просмотра используется вертикальная полоса прокрутки.
  4. Для выбора значения из двух возможных вариантов используется поля, в котором отображается флажок и текстовое значение.
    Редактирование логического значения на форме
    Изменение значения в таком поле может производиться либо щелчком мыши по флажку, либо при помощи клавиши Пробел на клавиатуре. Если в данном поле пустое значение недопустимо, то переключение происходит между двумя возможными значениями (например, для поля "Пол" между значениями "Муж." и "Жен."). Если пустое значение допустимо, то переключение происходит между тремя вариантами: двумя значениями и пустым значением, для которого отображается строка "(Нет)".
  5. Если значение поля должно быть установлено путем выбора из списка допустимых значений, то в правой части поля отображается кнопка с направленной вниз стрелкой.
    Редактирование значения из выпадающего списка на форме
    Установление значения в таком поле может производиться либо при помощи выбора из выпадающего списка, открывающегося при нажатии на кнопку Кнопка выпадающего списка, либо путем ввода с клавиатуры текста, соответствующего выбираемому значению. В процессе ввода будут предлагаться допустимые варианты.
  6. Если поле предполагает ввод большого объекта, то оно отображается следующим образом:
    Редактирование большого значения на форме
    Если в поле значение не установлено, то отображается текст "(Нет)". Если значение установлено, то отображается текст "(Данные)". В правой части поля ввода расположено три кнопки:
    • Кнопка выбора при нажатии этой кнопки будет отображено окно редактирования текста большого объекта;
    • Кнопка загрузки из файла при нажатии этой кнопки большой объект можно загрузить из файла при помощи стандартного диалога открытия файла Windows;
    • Кнопка сохранения в файл при нажатии этой кнопки большой объект можно сохранить в файл при помощи стандартного диалога сохранения файла Windows.
  7. Если поле предполагает выбор объекта из другой таблицы данных, то в правой части поля отображается кнопка с тремя точками или кнопка со стрелкой и кнопка с тремя точками.
    Редактирование значения с выбором на форме
    Выбор значений в таком поле производится путем нажатия на одну из кнопок:
    • Кнопка выпадающего списка при нажатии данной кнопки отображается выпадающий список объектов которые могут быть выбраны в данном поле;
    • Кнопка выбора - при нажатии данной кнопки будет открыта таблица данных, и в ее правом нижнем углу будут расположены кнопки OK и Отмена. В открывшейся таблице нужно выбрать один объект, после чего нажать кнопку ОК.

При работе с формой задания параметров рекомендуется устанавливать в полях значения в порядке их следования на форме. Разработчиком прикладной системы может быть установлена зависимость между значениями полей. В этом случае при изменении значения в одном из полей, в других полях значения также могут автоматически измениться. Допустимость значений в одних полях может зависеть от того, какие значения установлены в других полях.

Также необходимо помнить о том, что кнопка ОК на форме задания параметров станет доступной только тогда, когда во всех полях будут установлены допустимые значения.


Формирование отчетов Microsoft Excel

(одним файлом)
Формирование отчетов Microsoft Excel

Формирование отчетов, выгружаемых в MS Excel происходит при помощи вызова действий в таблицах данных (подробнее о вызове действий см. раздел 4.12 "Выполнение действий над объектами"). При вызове отчета на выполнение может отобразиться форма задания параметров отчета. Поля этой формы необходимо заполнить, после чего нажать кнопку ОК (подробнее о работе с формой задания параметров см. раздел 6. "Работа с формой задания параметров").

Отчеты, выгружаемые в MS Excel, как правило, имеют иконки на панели инструментов, характерные для рабочих книг Excel:
Кнопка формирования отчета Microsoft Excel

При запуске отчета на исполнение происходит создание рабочей книги Excel, в которую передаются данные, хранящиеся в базе данных. Рабочая книга может содержать данные, диаграммы, интерактивные элементы управления, и проч.. Далее средствами MS Excel могут осуществляться любые доступные действия с рабочей книгой.

Отчеты в MS Excel используются для вывода на печать документов и стандартных форм отчетности. Шаблоны отчетов создаются разработчиками прикладной системы.

Полученный в результате формирования отчета файл MS Excel может далее использоваться для дальнейшей работы с данными, может быть распечатан, сохранен, отправлен по электронной почте и т.п.


Формирование отчетов в виде HTML-документов

(одним файлом)
Формирование отчетов в виде HTML-документов

В целях публикации отчетной информации в Internet средствами системы могут формироваться отчеты в виде HTML-документов. Формирование таких отчетов происходит путем вызова действий в таблицах данных (подробнее о вызове действий см. раздел 4.12 "Выполнение действий над объектами"). При вызове отчета на выполнение может отобразиться форма задания параметров отчета. Поля этой формы необходимо заполнить, после чего нажать кнопку ОК (подробнее о работе с формой задания параметров см. раздел 6. "Работа с формой задания параметров").

Отчеты, формируемые в виде HTML-документов, как правило имеют иконки на панели инструментов, характерные для приложения MS Internet Explorer:
Кнопка формирования XSLT-отчета

В результате работы отчета создается HTML-документ, который может содержать таблицы с данными, рисунки, ссылки и проч. Сформированный документ показывается при помощи приложения Internet Explorer. Полученный html-файл может быть опубликован в Internet, сохранен, распечатан и т.д.

Сформированный html-документ сохраняет связь в базой данных. Если в ранее открытом документе выполнить процедуру обновления, по документ отобразит последнюю версию хранящихся на сервере БД данных.


Взаимодействие с разработчиком в случае ошибок, проблем, вопросов по работе системы

(раздел целиком) (одним файлом)
Взаимодействие с разработчиком в случае ошибок, проблем, вопросов по работе системы

В ситуациях, когда в работе системы происходят ошибки, когда система ведет себя неожиданным для пользователя образом, наблюдаются проблемы с быстродействием или другими аспектами работы системы, если у пользователей возникают вопросы, не освещенные в Руководстве пользователя, возникает необходимость обратиться к разработчику. Для того, чтобы разработчик мог решить проблему или ответить на вопрос быстро, полно и компетентно, ему нужно предоставить информацию о среде работе системы, о решаемых пользователем задачах, последовательности действий пользователя, приведших к проблемной ситуации.

Общими принципами сбора информации для обращения к разработчику должны быть:

  1. Необходимо быть готовым изложить последовательность действий пользователя в системе, начиная с открытия системы до ситуации, приводящей к ошибке, проблемной ситуации или ситуации, вызывающей вопрос.
  2. Если ошибка или проблема имеет визуальное проявление, нужно сделать скриншот (снимок) экрана. Желательно предоставлять скриншот всего экрана компьютера, а не только активного окна приложения, это даст разработчику дополнительную полезную информацию. Скришот экрана при работе в операционной системе MS Windows можно получить путем одновременного нажатия клавиш Ctrl + Print Screen (PrtScr) и последующей вставки (сочетание клавиш Shift + Ins) в какое-либо графическое приложение, например, программу Paint.
  3. Если ошибка заключается не в отображении специального окна с сообщением об ошибке, а в том, что результат работы системы является, с точки зрения пользователя, некорректным, то нужно быть готовым изложить, каким должен быть корректный результат, и чем именно результат работы системы некорректен.
  4. Если ошибка, проблема или вопрос связаны с работой третьесторонних приложений (например, отчеты, формируемые в MS Excel или MS Word, работа web-приложений системы посредством интернет-браузеров), нужно быть готовым предоставить информацию о версии третьесторонних приложений.
  5. Нужно быть готовым предоставить информацию о конфигурации рабочего места пользователя, версии операционной системы, установленном программном обеспечении и его версии, включая средства анитивирусной защиты.

Для сбора информации, необходимой разработчику для решения проблем, система предоставляет ряд средств: Приложение Отладочный монитор, возможность получения файла, содержащего информацию об ошибке, также ниже приведены рекомендации по получению информации о третесторонних приложениях.

  • Приложение Отладочный монитор
  • Получение файла, содержащего информацию об ошибке
  • Получение информации о третесторонних приложениях


Приложение Отладочный монитор

(одним файлом)
Приложение Отладочный монитор

Приложение Отладочный монитор (DebugView.exe) устанавливается при установке платформы в любой конфигурации, предусмотренной по умолчанию, включая конфигурацию "Рабочее место пользователя". Открыть приложение можно при помощи иконки:

Иконка Debug Monitor

Когда приложение Отладочный монитор запущено, приложение Обозреватель данных выводит в него поток сообщений о действиях и событиях, происходящих в системе. В Отладочный монитор попадают все sql-запросы, направляемые с рабочего места пользователя на сервер баз данных (в случае удаленного подключения - html-запросы, направляемые на сервер приложений), информационные сообщения, предупреждения, отладочная информация, сообщения об ошибках и прочие данные.

Для того, чтобы собрать и передать разработчику информацию об ошибке или проблемной ситуации при помощи Отладочного монитора, нужно выполнить следующие действия:

  1. Закрыть приложение Обозреватель данных, если оно было открыто.
  2. Запустить приложение Отладочный монитор. Если это приложение уже было открыто, то выполнить очитку всех имеющихся в нем сообщений при помощи кнопки Очистить.
  3. В приложение Обозреватель данных выполнить всю последовательность действий, приводящих в появлению ошибки или проблемной ситуации.
  4. После возникновения ошибки или проблемной ситуации в приложении Отладочный монитор нажать кнопку Сохранить в файл, выбрать место сохранения и задать имя файла. Файл будет сохранен в формате.txt.
  5. Отправить полученный.txt-файл разработчику в составе других информационных материалов, которыми должны быть:
    • Словесное описание проблемы и способа ее воспроизведения
    • Один или несколько скриншотов экрана, иллюстрирующих проблему

После получения информации, состав которой описан в пункте 5, разработчик может запросить дополнительную информацию о проблеме.


Получение файла, содержащего информацию об ошибке

(одним файлом)
Получение файла, содержащего информацию об ошибке

В ходе работы с системой могут отображаться специальные окна с информацией об ошибках. Эти окна могут быть двух видов:

  1. Окно с информацией о недопустимом действии пользователя (окно с шапкой синего цвета):

    Окно ошибки. Синяя шапка.

    Как правило, отображение такого окна с информацией об ошибке свидетельствует не об ошибке в функциональности системы, а о том, что пользователем выполнено недопустимое действие. Информация о том, в чем именно действие не допустимо, содержится в тексте, отображаемом в окне. Например, на приведенном выше скриншоте мы видим окно с ошибкой, отображено после попытки пользователя создать в справочнике "Уровни образования и курсы" второй записи с именем "1 курс", подчиненной родительской записи "Бакалавриат", что недопустимо. Поэтому сообщение об ошибке говорит о дублировании объекта по полю Имя.

    Информация, отображаемая в окне данного вида, предназначена для пользователя. Вы можете направить информацию о такой ошибке разработчику в случае, если сообщение об ошибке непонятно, либо если считаете, что выполненное пользователем действие должно быть допустимым, и ошибка системы в том, что действие было расценено как недопустимое.

    При отображении окна данного вида пользователь может продолжить работу, нажав на кнопку Продолжить. При необходимости обратиться в данной ситуации к разработчику до нажатия кнопки Продолжить необходимо получить и сохранить информацию, необходимую разработчику для анализа ситуации, при помощи ссылок "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки". Подробнее о сохранении этой информации написано ниже.

  2. Окно с информацией об ошибке системы (окно с шапкой красного цвета).

    Окно ошибки. Красная шапка.

    При возникновении ситуации, сопровождающейся появлением такого окна, необходимо получить и сохранить информацию, необходимую разработчику для анализа ситуации, при помощи ссылок "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки". Подробнее о сохранении этой информации написано ниже.

    После сохранения информации об ошибке можно попытаться продолжить работу, нажав кнопку Продолжить. В некоторых случаях, в зависимости от характера произошедшей ошибки, продолжение работы может оказаться невозможным, в таких случаях нужно нажать кнопку Закрыть приложение. После того, как приложение будет закрыто, его можно будет открыть снова и продолжить работу.

Сохранение информации для направления разработчику.

Информация, которая поможет разработчику решить проблему, не отображается в самом окне, поэтому направлять разработчику скриншот именно этого окна не имеет смысла. Для получения необходимой для разработчика информации в окнах с сообщением об ошибке обоих видов расположены ссылки "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки".

По ссылке Показать информацию для службы поддержки информация отображается в том же окне. Весь текст изначально выделен, его можно сразу скопировать и вставить в текстовый файл, в тело письма и т.д. Данный текст содержит сам текст ошибки, а также информацию об операционной системе пользователя и ее версии, загруженных модулях, переменных окружения и проч.

Информация для службы поддержки

При помощи ссылки Сформировать файл для службы поддержки можно собрать в удобном виде наиболее полную и полезную для разработчика информацию. После нажатия на ссылку будет предложен диалог сохранения файла. По умолчанию файлу будет дано имя ExceptionInfo.err. Это имя можно изменить, но расширение необходимо файла сохранить. После выбора места сохранения и имени файла и нажатия кнопки Сохранить, система отобразить предупреждение:

Предупреждение при сохранении файла для службы поддержки

К данному предупреждению нужно отнестись ответственно - отправлять полученный файл только на адреса службы поддержки системы в вашей организации или на официальный контактный адрес разработчика (если вы взаимодействуете с разработчиком напрямую). После отправки этот файл необходимо удалить.

Предоставление разработчику информации в виде.err-файла - это самый удобный и надежный вариант взаимодействия, который даст возможность разработчику решить проблему или ответить на вопрос наиболее эффективным и быстрым образом. Данный файл содержит все виды информации, которые могут быть собраны другими способами:

  • Информацию об ошибке, которая отображается по ссылке "Показать информацию для службы поддержки"
  • Сообщения Отладочного монитора, собранные за некоторое время до возникновения ошибки
  • Скриншоты экрана пользователя, включая скриншот окна с информацией об ошибке.

При отправке файла разработчику дополнительно нужно описать последовательность действий, приведших к ошибке или ситуации, вызывающей вопросы. После получения файла и дополнительной информации, разработчик может попросить предоставить дополнительную информацию о проблемной ситуации, о конфигурации рабочего места пользователя, прочем установленном на рабочем месте ПО и проч.

Если вы хотите обратиться к разработчику по поводу ситуации, которая не сопровождается отображением окна с ошибкой, то.err-файл можно получить следующим образом: нужно кликнуть левой кнопкой мыши по иконке с мельницей в левом углу заголовка окна текущей формы и из выпадающего меню выбрать пункт Сохранить файл для службы поддержки.

Получение файла для службы поддержки


Получение информации о третесторонних приложениях

(одним файлом)
Получение информации о третесторонних приложениях

В случае, если ошибка произошла при взаимодействии системы с третьесторонним приложением, например, при выполнении отчета MS Excel, MS Word, pdf, при работе web-приложений системы через интернет-браузер, разработчику, в дополнение к файлу с информацией об ошибке, понадобится информация о версии третьестороннего приложения, при взаимодействии с которым произошла ошибка.

Получить информацию о версии приложения можно, как правило, в окне О программе ("About box"), которое в большинстве программных продуктов представлено в пункте меню Справка.

Разработчику в составе информационных материалов нужно отправить скриншот этого окна.

В продуктах семейства Microsoft Office вызвать окно О программе можно разными способами в зависимости от версии MS Office. В программных продуктах версий до 2003 включительно это окно доступно в меню Справка / О программе. В программных продуктах версий 2007 и выше вызвать это окно можно следующим образом:

  1. В меню Файл открыть выпадающий список доступных действий и нажать кнопку Параметры Excel :
    Параметры Excel
  2. В открывшемся окне выбрать раздел Ресурсы, в правой части окна нажать кнопку О программе :
    Вызов окна О программе Excel

Окно О программе в случае MS Excel выглядит следующим образом:

Окно О программе Excel

В программе Acrobat Reader окно О программе можно вызвать из меню Справка / О программе :

Вызов окна О программе Acrobat Reader

В интернет-браузерах окно "О программе" (О Google Chrome, О FireFox, О Internet Explorer) также можно вызвать из меню Справка. Строка меню в интернет-браузерах часто бывает по умолчанию скрыта. Для того, чтобы ее отобразить, нужно нажать клавишу Alt на клавиатуре.


Руководство пользователя построителя запросов

(одним файлом)
Руководство пользователя построителя запросов

Этот раздел еще предстоит написать.


Руководство администратора

(раздел целиком) (одним файлом)
Руководство администратора
  • Установка программного обеспечения СУБД
  • Установка программного обеспечения платформы "Мельница данных"
  • Создание и начальная инициализация базы данных
  • Управление доступом пользователей
  • Ключи командной строки утилиты обслуживания БД
  • Ключи командной строки инсталлятора платформы
  • Форматы и соглашения


Установка программного обеспечения СУБД

(раздел целиком) (одним файлом)
Установка программного обеспечения СУБД

Прежде, чем устанавливать программноге обеспечение "Мельница данных" необходимо установить и настроить программное обеспечение СУБД.

Для конфигурирования сервера БД необходимо последовать советам раздела "Конфигурирование сервера". В этом разделе описаны шаги, которые необходимо предпринять для установки сервера "с нуля". Если сервер БД у вас уже установлен и настроен, то использовать рекомендации этого раздела нет необходимости. Раздел описывает установку сервера БД минимальной поддерживаемой версии в минимально необходимой для работы "Мельницы данных" конфигурации. Если вы собираетесь использовать сервер БД для более широкого круга задач, то пользуйтесь руководствами по соответствующим СУБД.
Документация по СУБД, а также любая другая информация, полученная от производителей СУБД, имеет абсолютный приоритет перед утверждениями настоящего документа.

На каждой рабочей станции должно быть установлено и настроено программное обеспечение клиентской части СУБД. Это, как правило, некий набор библиотек и компонентов, наличие которых необходимо для соединения с сервером БД. Для обеспечения рабочей станции этими компонентами необходимо последовать советам раздела Конфигурирование клиента. В этом разделе описаны шаги, которые необходимо предпринять для установки клиентской части СУБД "с нуля". Если клиентская часть СУБД у вас уже установлена и настроена, то использовать рекомендации этого раздела нет необходимости. Раздел описывает установку клиентской части СУБД минимальной поддерживаемой версии в минимально необходимой для работы "Мельницы данных" конфигурации.

В настоящий момент поддерживаемые СУБД приведены в таблице:
СУБД Минимальная
требуемая версия 		Разработчик Сопровождение в России
Firebird
Open source
1.5.4.4910 http://www.firebirdsql.org
Страница загрузки 		http://www.ibase.ru
Oracle database
Коммерческое ПО
9.2.0.1 http://www.oracle.com
Страница загрузки 		http://www.oracle.com/global/ru/index.html

  • Конфигурирование сервера
  • Конфигурирование клиента


Конфигурирование сервера

(одним файлом)
Конфигурирование сервера

Младшая тестированная на совместимость версия - 1.5.4.4910. Использование более младшей версии на сервере недопустимо. Шаги установки примерно следующие:

  1. Первая страница содержит логотип проекта Firebird
    Установка FireBird (первая страница)
  2. Вторая страница содержит лицензионное соглашение. Для продолжения установки необходимо установить кнопку "I accept the agreement".
    Установка FireBird (вторая страница)
  3. Третья страница содержит информацию, необходимую для установки.
    Установка FireBird (третья страница)
  4. Четвертая страница позволяет указать папку на диске, в которую будут установлены файлы Firebird.
    Установка FireBird (четвертая страница)
  5. На пятой странице определяется тип установки. Мы конфигурируем сервер БД, и, соответственно, выбираем из выпадающего списка пункт "Full installation of Server and development tools". Необходимо определиться с выбором между различными архитектурами сервера. Если вы затрудняетесь в выборе между вариантами архитектуры сервера, то помните, что для однопроцессорных систем предпочтительнее Super Server, для многопроцессорных используется только Classic Server. Подробности можно посмотреть на сайте сопровождающей компании или на сайте проекта. Особое внимание требуется обратить на работу сервера на процессоре в режиме HyperThreading.
    Установка серверной части FireBird - выбор типа установки
  6. На шестой странице предлагается выбрать имя папки меню "Пуск", в которой будут созданы полезные ярлыки. В нашем случае ярлыки будут созданы для файлов документации, бесполезной в конечном счете для конечного пользователя. Поэтому мы ставим флажок "Don't create any icons".
    Установка FireBird (шестая страница)
  7. На седьмой странице необходимо выбрать параметры установки. Настоятельно рекомендуется включить флажок "Use the Guardian to control the server" и запускать сервер в режиме службы, то есть выбрать кнопку "Run as a Service". Также настоятельно рекомендуется установить флажок "Start Firebird automatically everytime you boot up". Программное обеспечение "Мельница данных" использует в работе библиотеку gds32.dll , загружая ее из системного каталога Windows. Поэтому в целях обеспечения нормальной работы необходимо установить оба флажка - "Copy Firebird client library to <system> directory" и "Generate client library as GDS32.DLL for legacy app. support".
    Установка серверной части FireBird - параметры установки
  8. На восьмой странице необходимо подтвердить установку с выбранными параметрами.
    Установка серверной части FireBird - подтверждение установки
  9. После установки на девятой странице можно ознакомиться с информацией об установленной версии.
    Установка FireBird (девятая страница)
  10. Десятая страница информирует об успешном завершении установки и позволяет запустить сервер немедленно. Рекомендуется установить флажок "Start Firebird Service now".
    Установка серверной части FireBird - установка завершена

Убедиться в том, что сервер установлен и запущен, можно из окна служб (Start → Control Panel → Administrative Tools → Services):

Установленный FireBird в списке сервисов

Использование embedded-сервера вполне допустимо, с учетом ограничений, налагаемых разработчиком. Для использования embedded-сервера необходимо положить файлы (с полным путем) из архива embedded-сервера рядом с исполняемыми файлами нашей системы, и переименовать файл FBEMBED.DLL в GDS32.DLL , примерно следующим образом:

Использование FireBird Embedded

Для работы с embedded-сервером имя сервера в строке соединения указывать нельзя. Кроме того, необходимо соблюдать рекомендации и требования разработчиков сервера.

Младшая тестированная на совместимость версия - 9.2.0.1. Использование более младшей версии недопустимо.

Если вы устанавливаете Oracle не с компакт-дисков, то не пользуйтесь программой автозапуска, лежащей в корне первого установочного диска, а запустите setup.exe из каталога install\win32 на первом установочном диске.

Шаги установки примерно следующие:

  1. Первая страница содержит логотип Oracle и командные кнопки. Для продолжения установки нажмите кнопку "Next".
    Установка Oracle (первая страница)
  2. На второй странице необходимо определиться с путями установки и источника, а также с именем "дома". Настоятельно рекомендуется принять значения, предлагаемые по умолчанию.
    Установка Oracle (вторая страница)
  3. На третьей странице необходимо выбрать устанавливаемый продукт. Для сервера БД необходимо выбрать продукт "Oracle9i Database 9.2.0.1.0".
    Установка серверной части Oracle
  4. На четвертой странице необходимо выбрать тип установки. Для обеспечения требуемой функциональности выберите тип "Standard Edition".
    Установка серверной части Oracle - выбор типа установки
  5. На пятой странице необходимо выбрать параметры базы данных, создаваемой автоматически при установке сервера. Рекомендуется никакой базы данных при установке не создавать, для чего выбрать пункт "Software Only".
    Установка серверной части Oracle - отказ от автоматического создания БД
  6. На шестой странице необходимо выбрать порт TCP/IP, используемый Oracle Services for MTS. По умолчанию 2030.
    Установка серверной части Oracle - порт MTS
  7. На седьмой странице необходимо подтвердить правильность параметров установки.
    Установка серверной части Oracle - подтверждение установки
  8. После окончания процесса вы увидете сообщение об успешном завершении установки. Нажмите кнопку "Exit".
    Установка серверной части Oracle - завершено
  9. После завршения работы инсталлятора автоматически будет запущено приложение "Enterprise Manager Console". Если по каким-либо причинам этого не произошло, запустите это приложение самостоятельно через меню "Пуск". В окне "Add Databases To Tree" нажмите кнопку "Cancel".
    Установка серверной части Oracle - отказ от использования Enterprise Manager Console
  10. Из меню выберите пункт Tools → Service Management → Oracle Net Manager.
    Установка серверной части Oracle - вызов Oracle Net Manager
  11. В появивщемся окне приложения "Oracle Net Manager" раскройте узел дерева "Local", встаньте на узел дерева "Listener" и нажмите на кнопку с большим зеленым плюсом в панели инструменов (слева).
    Установка серверной части Oracle - Oracle Net Manager
  12. В появивщемся окне добавления Listener'a введите имя (по умолчанию - LISTENER). Настоятельно рекомендуется принять умолчание.
    Установка серверной части Oracle - создание Listener'a
  13. Нажмите на кнопку "Add Address" в нижней части окна.
    Установка серверной части Oracle - создание адреса Listener'a
  14. В появившемся окне отображена информация о том, каким образом клиенты будут осуществлять соединение с сервером БД. Настоятельно рекомендуется принять умолчания - протокол TCP/IP, порт 1521.
    Установка серверной части Oracle - адрес Listener'a создан
  15. Из меню выберите пункт File → Save Network Configuration
    Установка серверной части Oracle - сохранение конфигурации
  16. Служба Listener'a будет создана при первой попытке создать базу данных. Закройте приложения "Oracle Net Manager" и "Enterprise Manager Console".


Конфигурирование клиента

(одним файлом)
Конфигурирование клиента

Младшая тестированная на совместимость версия - 1.5.4.4910. Использование более младшей версии на клиенте недопустимо. Шаги установки примерно следующие:

  1. Первая страница содержит логотип проекта Firebird
    Установка FireBird (первая страница)
  2. Вторая страница содержит лицензионное соглашение. Для продолжения установки необходимо установить кнопку "I accept the agreement".
    Установка FireBird (вторая страница)
  3. Третья страница содержит информацию, необходимую для установки.
    Установка FireBird (третья страница)
  4. Четвертая страница позволяет указать папку на диске, в которую будут установлены файлы Firebird.
    Установка FireBird (четвертая страница)
  5. На пятой странице определяется тип установки. Мы конфигурируем клиентскую часть, и, соответственно, выбираем из выпадающего списка пункт "Minimum client install - no server, no tools". Кнопки в списке устанавливаемых компонентов будут автоматически выставлены в правильное положение.
    Установка клиентской части FireBird - выбор типа установки
  6. На шестой странице предлагается выбрать имя папки меню "Пуск", в которой будут созданы полезные ярлыки. В нашем случае ярлыки будут созданы для файлов документации, бесполезной в конечном счете для конечного пользователя. Поэтому мы ставим флажок "Don't create any icons".
    Установка FireBird (шестая страница)
  7. На седьмой странице необходимо выбрать параметры установки. Программное обеспечение "Мельница данных" использует в работе библиотеку gds32.dll, загружая ее из системного каталога Windows. Поэтому в целях обеспечения нормальной работы необходимо установить оба флажка - "Copy Firebird client library to <system> directory" и "Generate client library as GDS32.DLL for legacy app. support".
    Установка клиентской части FireBird - параметры установки
  8. На восьмой странице необходимо подтвердить установку с выбранными параметрами.
    Установка клиентской части FireBird - подтверждение установки
  9. После установки на девятой странице можно ознакомиться с информацией об установленной версии.
    Установка FireBird (девятая страница)
  10. Десятая страница информирует об успешном завершении установки.
    Установка клиентской части FireBird - установка завершена

Младшая тестированная на совместимость версия - 9.2.0.1. Использование более младшей версии на клиенте недопустимо.

Если вы устанавливаете Oracle не с компакт-дисков, то не пользуйтесь программой автозапуска, лежащей в корне первого установочного диска, а запустите setup.exe из каталога install\win32 на первом установочном диске.

Шаги установки примерно следующие:

  1. Первая страница содержит логотип Oracle и командные кнопки. Для продолжения установки нажмите кнопку "Next".
    Установка Oracle (первая страница)
  2. На второй странице необходимо определиться с путями установки и источника, а также с именем "дома". Настоятельно рекомендуется принять значения, предлагаемые по умолчанию.
    Установка Oracle (вторая страница)
  3. На третьей странице необходимо выбрать устанавливаемый продукт. Для рабочей станции необходимо установить продукт "Oracle9i Client 9.2.0.1.0".
    Установка клиентской части Oracle
  4. На четвертой странице необходимо выбрать тип установки. Для обеспечения требуемой функциональности выберите тип "Runtime".
    Установка клиентской части Oracle - выбор типа установки
  5. На пятой странице необходимо подтвердить правильность параметров установки.
    Установка клиентской части Oracle - подтверждение установки
  6. В процессе установки инсталлятор потребует настроить параметры соединения с сервером БД. Для этого запустится отдельный мастер "Oracle Net Configuration Assistant", и процесс установки будет приостановлен на время работы этого мастера.
    Если этого по каким-либо причинам не произошло, то после завершнения установки необходимо запустить это приложение из меню "Пуск" и выполнить описанные в этом и следующих шагах действия.
    На этой (первой) странице мастера необходимо отказаться от использования службы каталогов, выбрав кнопку "No, I will create net service names myself...".
    Установка клиентской части Oracle - конфигурирование подключения к БД - не использовать directory service.
  7. На второй странице мастера необходимо выбрать версию базы данных. Базы данных версии Oracle8 в любом случае не поддерживаются "Мельницей данных", поэтому выберите кнопку "Oracle8i or later database or service".
    Установка клиентской части Oracle - конфигурирование подключения к БД - версия БД
  8. На третьей странице мастера необходимо ввести имя сервиса, идентифицирующего базу данных на сервере (в данном случае - "RTT"). Это имя устанавливается при создании базы данных.
    Установка клиентской части Oracle - конфигурирование подключения к БД - имя сервиса
  9. На четвертой странице мастера выберите из списка доступных для соединения с БД протоколов протокол "TCP".
    Установка клиентской части Oracle - конфигурирование подключения к БД - протокол
  10. На пятой странице мастера введите адрес сервера, на котором установлена БД. Можно вводить как символьное имя сервера, так и IP-адрес. На этой же странице выберите порт TCP/IP, по которому будет производиться соединение с сервером. Порт по умолчанию - 1521.
    Установка клиентской части Oracle - конфигурирование подключения к БД - сервер и порт
  11. На шестой странице мастер предлагает протестировать заданные на предыдущих шагах параметры. Выберите кнопку "Yes, perform a test".
    Установка клиентской части Oracle - конфигурирование подключения к БД - тестирование соединения
  12. Если введенные на предыдущих страницах параметры соединения с БД были заданы корректно, то мастер сообщит об этом:
    Установка клиентской части Oracle - конфигурирование подключения к БД - успешное соединение
  13. На восьмой странице введите имя псевдонима подключения, который будет использоваться в дальнейшем для установки соединения с БД приложениями "Мальницы данных". Во избежание путаницы настоятельно рекомендуется именовать псевдоним так же, как и службу на сервере (в данном случае - RTT). сообщит об этом:
    Установка клиентской части Oracle - конфигурирование подключения к БД - псевдоним соедиения
  14. На девятой странице мастера у вас есть возможность выбрать, настроить еще одно подключение или завершить работу с мастером. После завршения установки вы всегда сможете вернуться к процедуре создания псевдонима подключений, вызвав из меню "Пуск" приложение "Oracle Net Configuration Assistant".
    Установка клиентской части Oracle - конфигурирование подключения к БД - отказ от создания следующего соединения
  15. На десятой странице мастер сообщает об успешном создании псевдонима соединения с БД.
    Установка клиентской части Oracle - конфигурирование подключения к БД - завершено конфигурирование соединения
  16. На десятой странице мастер сообщает об успешном завершении своей работы.
    Установка клиентской части Oracle - конфигурирование подключения к БД - завершено
  17. После завршения работы мастера "Oracle Net Configuration Assistant" вы увидете сообщение об успешном завершении работы инсталлятора. Нажмите кнопку "Exit".
    Установка клиентской части Oracle - завершено


Установка программного обеспечения платформы "Мельница данных"

(раздел целиком) (одним файлом)
Установка программного обеспечения платформы "Мельница данных"

Для установки ПП "Мельница данных" необходимо запустить файл setup.exe, расположенный на поставляемом компакт диске. После запуска программы установки необходимо следовать указаниям мастера установки.

Шаг 1: Выбор языка

Установка Мельницы Выбор языка

Шаг 2: Информация о версии устанавливаемого ПП

Установка Мельницы. Версия ПП

Шаг3: Выбор каталога установки файлов ПП

Установка Мельницы. Папка установки.

Шаг 4: Выбор файла лицензии

Установка Мельницы. Выбор лицензии.

Файл лицензии также расположен на поставляемом компакт-диске или высылается по электронной почте. В случае если не выбран никакой файл лицензий, то программа будет установлена в демонстрационном режиме. В последующем после получения файла лицензий необходимо будет переустановить ПП. Подробнее с лицензионным соглашением можно ознакомится в одноименном разделе настоящей документации.

Шаг 5: Выбор компонентов для установки

Установка Мельницы. Выбор компонентов.

На данном шаге вам необходимо выбрать набор компонентов для установки на локальный компьютер. В зависимости от специфики использования рабочего места, на которое устанавливается ПО, необходимо выбрать тип установки. Предлагаемые типы установок:

  • Рабочее место пользователя
  • Рабочее место администратора
  • Рабочее место разработчика
  • Только построитель запросов
  • По выбору

Для каждого из типов установки по умолчанию устанавливается свой набор компонентов. Вы можете дополнительно отметить тот или иной необходимый вам компонент для установки. Для выбора будут отображены только те компоненты, которые влачены в указанном вами лицензионном файле.

Полный перечень компонентов для установки:

  1. Обозреватель данных
  2. Построитель запросов
  3. Утилита обслуживания баз данных
  4. Утилита слияния баз данных
  5. Инструменты разработчика / Инструмент поставки решений
  6. Отладочный монитор
  7. Документация

Для некоторых из вышеперечисленных компонентов также можно выбрать состав устанавливаемого компонента. Описание назначений поставляемых компонент описано в разделе "Поставляемые компоненты ПП" настоящей документации.

После указания всех параметров мастер установки скопирует файлы на локальный компьютер и создаст в меню программ папку с ярлыками к установленным компонентам:

Установка Мельницы. Ярлыки после установки.
  • Поставляемые компоненты ПП "Мельница данных"


Поставляемые компоненты ПП "Мельница данных"

(одним файлом)
Поставляемые компоненты ПП "Мельница данных"
Обозреватель данных | Обозреватель данных (DataBrowser) - Основное приложение позволяющее просматривать и модифицировать данные. Приложение используется для разработки прикладных решений. Позволяет описывать объекты БД, их свойства, методы, пользовательские формы и отчеты. Это же приложение используется для работы с разработанными прикладными решения пользователями на локальных рабочих местах.
Утилита обслуживания БД | Утилита обслуживания базы данных (DBSetupShell) - Приложение, позволяющее создавать и обслуживать выбранную базу данных любой из поддерживаемых СУБД. Также при помощи данной утилиты можно создавать и удалять пользователей БД, создавать и восстанавливать резервные копии БД, импортировать и экспортировать данные из/в БД, а также выполнять процедуры по контролю целостности БД.
Построитель запросов | Построитель запросов (QueryBuilder) - Приложение, позволяющее визуальными средствами создавать интерактивные запросы на основе данных хранящихся в используемой БД. Созданные запросы сохраняются в стандартный формате SQL и полностью удовлетворяют архитектуре клиент-сервер. Сохраненные в виде файла запросы могут быть открыты пользователем по необходимости. Полученная таким образом информация будет актуальна в любой момент времени. Также существует возможность создания статистического отчета на основе Excel шаблона.
Отладочный монитор | Отладочный монитор (DebugView) - Средство позволяющее отслеживать все запросы к БД генерируемые "клиентской частью" прикладного решения, а также результат их исполнения сервером СУБД. Используется для отладки в процессе разработки прикладного решения.
Утилита слияния баз данных | Утилита слияния баз данных (Merger) - Данная утилита позволяет сравнивать данные и метаданные 2х различных БД. При помощи данного приложения можно с легкостью перенести, например данные из резервной копии в рабочую БД в случае не преднамеренного удаления большого числа объектов, тем самым избежать необходимости восстановления резервной копии недельной давности. Также используется для обновления версии ПП.
Редактор файлов документации | Редактор файлов документации (HelpEditor) - Незаменимое средство создания электронной справки и файлов документации в стандартном формате chm.


Создание и начальная инициализация базы данных

(одним файлом)
Создание и начальная инициализация базы данных

Для создания БД необходимо вопрользоваться утилитой обслуживания базы данных, поставляемой в комплекте ПП. После запуска одноименного приложения откроется окно панели управления утилиты:

После запуска одноименного приложения откроется окно панели управления утилиты:

Создание БД. Утилита обслуживания БД.

Для доступа к задачам необходимо заполнить параметры работы с базой данных:

  1. Источник данных : Необходимо указать используемую СУБД.
  2. База данных : Необходимо указать наименование создаваемого файла БД и его месторасположение. (Пример: c:\databases\base.fdb)
  3. Пользователь : Указать имя пользователя (Администратора) для используемой СУБД. Для Interbase/FireBird - SYSDBA, для Oracle - SYS.
  4. Пароль : Указать пароль пользователя (Администратора) для используемой СУБД. Для Interbase/FireBird - masterkey, для Oracle - SYS.

После заполнения полей параметров можно приступать к созданию БД. Для создания новой базы данных необходимо воспользоваться задачей "Создать новую БД". После нажатия кнопки "Выполнить" будут выполнены команды отображенные в окне "Командная строка".

Днные команды можно выполнить самостоятельно из командной строки операционой системы или из любого другого приложения. Также создать пустую БД можно средствами входящими в комплекты поставок соответствуеющих СУБД.
Создание БД. Вывод консольного приложения.

В окне "Вывод консольного приложения" будет отображен результат выполнения команд по созданию БД. В случае успешного выполнения всех необходимых команд, БД будет создана по указанному в параметрах месторасположению.

После создания пустой БД необходимо наполнить ее системными объектами (метаданными) для последующей работы с ПП "Мельница данных". Для этого необходимо выполнить задачу "Синхронизировать базу данных". После нажатия кнопки "Выполнить" будет автоматически запущен отладочный монитор отображающий процесс наполнения БД необходимыми метаданными. Данный процесс может занять от одной до нескольких минут в зависимости от используемой СУБД и производительности сервера. (Обычно около минуты) По окончании процесса в окне "Вывод консольного приложения" будет отображен результат выполнения инициализации базы данных.

Инициализация БД. Вывод консольного приложения.

Все действия по созданию и инициализации БД выполнены. БД готова к эксплуатации.


Управление доступом пользователей

(раздел целиком) (одним файлом)
Управление доступом пользователей

После того, как база данных создана и инициализирована метаданными платформы, доступ к системе будет иметь один пользователь - администратор созданной БД. Добавление других пользователей, ролей пользователей и включение пользователей в роли выполняется в представлениях Пользователи и Роли в Системной форме. После начальной инициализации БД на вкладке Пользователи можно увидеть одного пользователя с именем, соответствующим логину администратора БД (Например, для FireBird пользователь SYSDBA), на вкладке Роли можно увидеть одну роль с наименованием Администраторы. На подчиненных вкладках этих представлений можно увидеть, что пользователь - администратор включен в роль Администраторы.

Профиль пользователя формируется путем определения для него:

  1. Перечня доступных форм
  2. Перечня доступных визуальных групп
  3. Перечня групп запретов

Формирование профиля происходит одинаково как для роли, так и для отдельного пользователя. Однако рекомендуется формировать профили для ролей, а не для отдельных пользователей. В этом случае при подключении к системе новых пользователей, изменении параметров доступа для существующего пользователя достаточно будет включить пользователя в одну из ролей, или исключить его из роли. Роли рекомендуется формировать содержательным образом на основе распределения обязанностей реальных пользователей, работающих с прикладным решением.

  • Создание пользователей
  • Создание ролей
  • Включение пользователей в роли
  • Формирование перечня доступных визуальных групп
  • Формирование перечня доступных форм
  • Формирование перечня групп запретов


Создание пользователей

(одним файлом)
Создание пользователей

Создание пользователя системы включает в себя два этапа:

  1. Создание пользователя БД средствами используемой СУБД. Для этого наряду с возможностями каждой из СУБД Утилитой обслуживания БД предлагается действие Создать пользователя. Предлагаемые Утилитой по умолчанию пути к БД и параметры доступа требуют уточнения в зависимости от условий функционирования реальной БД. Задавать права доступа пользователя к объектам БД на данном этапе не надо.
  2. В Системной форме на вкладке Пользователи создать нового пользователя при помощи соответствующего действия контекстного меню.
    В поле Имя нужно вветси строку, строго соответствующую логину пользователя БД в вернем регистре.
    Особых требований к полю Наименование не предъявляется. Однако рекомендуется вводить в это поле фамилию и имя реального пользователя системы, например, Смирнов Иван Николаевич, что позволить в последующем получать информативные данных об активности пользователей системы.


Создание ролей

(одним файлом)
Создание ролей

Создание ролей производится на вкладке Роли Системной формы при помощи действия Создать, вызываемого из контекстного меню. Имя и наименование роли могут быть любыми строками. Однако именовать роли по названиям соответствющих функциональных участков системы, например,

  • Начальник отдела кадров
  • Инспектора по работе с личными данными персонала
  • Инспектора по социальным вопросам
В случаях, когда реальные пользователи совмещают несколько ролей, роли лучше формировать отдельно, после чего одного пользователя можно влючить одновременно в несколько ролей.


Включение пользователей в роли

(одним файлом)
Включение пользователей в роли

В роль могут включаться как пользователи, так и другие роли. Для добавления в роль нового члена роли нужно выбрать роль на вкладке Роли, отрыть подчиненную вкладку Члены роли и вызвать на ней действие Создать. Поля формы параметров заполняются следующим образом:

  • Пользователь - в этом поле необходимо выбрать либо одного из пользователей, либо одну из ролей. В зависимости от того, выбран ли пользователь или роль, будет меняться доступность следующих ниже полей.
  • Основная роль - в этом поле можно установить значение Да или Нет. Если пользователь включен в нескольно ролей, то среди них можно выделить одну основную. Разработчик прикладного решения на платформе сможет использовать это значение для управления доступом к объектам системы. Поле доступно для выбора значения только в том случае, если в поле Пользователь выбран именно пользователь, а не роль.
  • Добавить связанные роли - в этом поле можно установить значение Да или Нет. Поле доступно для выбора значения только в том случае, если в поле Пользователь выбрана роль. При установке значения Да в роль будут включены также все роли, входящие в выбранную. при установке значения Нет будет включена только одна роль без подчиненных ролей.

После включения пользователя в роль он получает права доступа ко всем визуальным группам и формам, а также к группам запретов, заданным для роли.


Формирование перечня доступных визуальных групп

(одним файлом)
Формирование перечня доступных визуальных групп

Визуальные группы создаются разработчиком прикладного решения. Работа с визуальными группами ведется в Системной форме на вкладке Визуальные группы. Каждая визуальная группа содержит набор форм и также может быть снабжена иконкой. Визуальные группы отображаются на Консоли управления, которая показывается при запуске системы.

Для каждой роли (или для отдельного пользователя) формируется перечень визуальных групп, которые будут ему доступны на Консоли управления. Если визуальных групп в прикладном решение не создано, или если пользователю не доступно ни одной визуальной группы, консоль управления не будет отображена. В этом случае при открытии системы пользователь увидит первую из доступных ему форм, которая открывается автоматически.

Для добавления новой визуальной группы, доступной роли или пользователю, необходимо выбрать роль или пользователя на соответствующей вкладке (Роли или Пользователи), отрыть подчиненное представление Доступные визуальные группы и выполнить в нем действие Создать. В форме параметров нужно выбрать одну из существующих визуальных групп. Если необходимо дать доступ к нескольким визуальным группам, действие создания нужно повторить.

Если пользователь включен в несколько ролей, то достаточно наличия доступа к визуальной группе в одной из этих ролей.


Формирование перечня доступных форм

(одним файлом)
Формирование перечня доступных форм

Формы создаются разработчиком прикладного решения. Работа с визуальными группами ведется в Системной форме на вкладке Формы. Каждая форма представляет собой набор представлений, связанных друг с другом определенным образом. Иконки всех форм, доступных пользователю, отображаются на Панели инструментов в верхней части экрана. Нажимая на одну из иконок форм, пользователь может переключаться между ними. Если форма входит в одну из доступных пользователю визуальных групп, она отобразится на консоли управления. В этом случае переключаться между формами пользователь сможет как на Панели инструментов, так и на Консоли управления.

Для каждой роли (или для отдельного пользователя) формируется перечень форм, которые будут ему доступны на Консоли управления. При открытии системы пользователь видит первую из доступных ему форм, открываемую автоматически.

Для добавления новой формы, доступной роли или пользователю, необходимо выбрать роль или пользователя на соответствующей вкладке (Роли или Пользователи), отрыть подчиненное представление Доступные формы и выполнить в нем действие Создать. В форме параметров нужно выбрать одну из существующих форм. Если необходимо дать доступ к нескольким формам, действие создания нужно повторить.

Если пользователь включен в несколько ролей, то достаточно наличия доступа к форме в одной из этих ролей.


Формирование перечня групп запретов

(одним файлом)
Формирование перечня групп запретов

Группы запретов могут формироваться как разработчиком прикладного решения, так и администратором системы. Работа с группами запретов ведется на соответствующей вкладке Системной формы. В каждую группу запретов включаются запреты трех видов:

  • Запрет на класс
  • Запрет на свойство
  • Запрет на подпрограмму

Запреты на класс и свойство могут даваться как только на запись, так и на чтение и запись объектов. Наличие запретов для определенной роли или пользователя приводит к тому, что пользователь не видит или не имеет прав на модификацю объетов определенных классов или отдельных их свойств. Запреты на подпрограммы выражаются в том, что для пользователя не отображаются действия, вызывающие ряд подпрограмм.


Ключи командной строки утилиты обслуживания БД

(раздел целиком) (одним файлом)
Ключи командной строки утилиты обслуживания БД

Утилита обслуживания БД - консольное приложение. При запуске приложения оно сообщает о поддерживаемых режимах и ключах командной строки. Ключи указываются через пробел. Ключ должен начинаться символом "/". Для ключей, содержащих значения параметров, между ключем и значением должен быть пробел. Имена файлов и папок, содержащие пробелы, в командной строке должны быть заключены в кавычки.

При работе с утилитой общее правило состоит в том, что первым параметром передается строка соединения с БД, вторым параметром необязательная команда. Остальные параметры и ключи указываются в зависимости от выбранной команды.

Если работа утилиты завершилась успешно, то она возвращает код завершения 0. Если в процессе работы утилиты произошли ошибки, то код завершения будет равен 1. Если работа утилиты завершилась успешно, но были выданы предупреждения, то она возвращает код завершения 2.

Поддерживаемые команды:

<Команда не указана> | Инициализация/cинхронизация БД
ping | Проверка доступности БД
pump | Перекачка данных
check | Проверка целостности БД
build | Перестройка всех метаданных
load | Загрузка доступных файлов
export | Экспорт реплики данных
import | Импорт реплики данных

Далее будут рассмотрены подробности работы каждого из режимов.

  • Перекачка данных


Перекачка данных

(раздел целиком) (одним файлом)
Перекачка данных

Для осуществления перекачки данных необходимо:

  1. Иметь права владельца схемы в БД - приемнике.
  2. Иметь права владельца схемы в БД - источнике.
  3. Если не задан ключ /M, то БД - приемник должен быть пустой схемой, не содержащей никаких объектов.
Эти условия контролируются утилитой dbsetup.exe.

Перекачка данных осуществляется в любом направлении. Ниже представлены варианты сочетания источников и приемников данных. В случае, если попытка использовать тот или иной оптимизационный механизм оказалась неудачной, производится стандартная перекачка.

Приемник | Источник
 | БД MSSQL | БД Firebird | БД Oracle | БД PostgreSQL | Папка, файл, zip-архив
БД MSSQL | Стандартная перекачка данных
БД Firebird | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("external table"). | Предпринимается попытка использовать механизм "внешний источник данных" ("external data source"). | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("external table").
БД Oracle | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("table organization external"). |  | Предпринимается попытка использовать механизм "связи БД" ("database link"). | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("table organization external").
БД PostgreSQL | Предпринимается попытка использовать механизм загрузки данных из внешнего текстового файла оператором COPY. |  |  | Предпринимается попытка использовать расширение "dblink". | Предпринимается попытка использовать механизм загрузки данных из внешнего текстового файла оператором COPY.
Папка, файл, zip-архив | Стандартная перекачка данных | Предпринимается попытка собрать на сервере blob, содержащий целевой xml-документ. |  |  | Не имеет смысла. Просто скопируйте файлы.

Используемые параметры и ключи командной строки:

Для перекачки данных используюется команда pump. В строке соединения указывается БД-приемник, кроме случая перекачки данных из БД в папку, файл или zip-архив. Для всех случаев кроме случая перекачки данных из БД в папку, файл или zip-архив командная строка содержит кляузу pump from. Для случая перекачки данных из БД в папку, файл или zip-архив командная строка содержит кляузу pump to.
Перекача данных из БД Oracle в БД Firebird:
dbsetup.exe fb#sysdba/masterkey@host:database pump from ora#dataowner/password@host/sid.dataowner
Перекача данных из zip-архива в БД Firebird:
dbsetup.exe fb#sysdba/masterkey@host:database pump from c:\dbbackup.zip
Перекача данных из БД Firebird в zip-архив:
dbsetup.exe fb#sysdba/masterkey@host:database pump to c:\dbbackup.zip

Ключ | Назначение
/J <Целое число> | Определяет число потоков, осуществляющих перекачку данных. По умолчанию соответствует количеству ядер процессора.
/H <Целое число> | Определяет базовое количество записей в блоке перекачки. По умолчанию - 1 млн. записей. Для таблиц, содержащих большие объекты (blob и/или clob) размер блока перекачки определяется как базовый размер блока, деленный на 100. Если источником является папка, файл или zip-архив - ключ игнорируется.
/M | Пропустить этап создания таблиц и последовательностей в БД (таблицы и последовательности должны быть созданы заранее).
/G | Пропустить этап заливки данных, произвести только создание таблиц и последовательностей в БД.
/K <Список таблиц> | Не перекачивать данные указанных таблиц. Список таблиц разделяется символом ";" (точка с запятой).
/NODBLINK | Принудительно отключает механизмы связи между БД на сервере.
/NOCSV | Принудительно отключает механизмы загрузки данных из внешнего файла.
/NOXML | Принудительно отключает механизмы cборки xml-документа на сервере.

Информация о значениях типа "внешние данные" будет перенесена из источника в приемник, сами внешние данные при этом перенесены в хранилище не будут.

При перекачке данных учитыватся табличное пространство ("группа файлов") каждой таблицы в случае, если это понятие релевантно для источника и приемника. При использовании папки, файла или zip-архива имя табличного пространства каждой таблицы сохраняется в файле RTTI, и будет использовано, если окажется релевантным. Если в приемнике имеется возможность разместить таблицу в табличное пространство с тем же именем, которое указано в источнике, то это будет сделано.

При перекачке данных таже осуществляется перенос последовательностей. При этом переносится текущее значение каждой из последовательностей. Значение кеша последовательности переносится только в том случае, если это понятие релевантно для источника и для приемника. При использовании папки, файла или zip-архива значение кеша сохраняется в файле Sequences, и будет использовано, если окажется релевантным.

После завершения перекачки данных в схеме-приемнике остаются следующие объекты:

  • Таблицы данных.
  • Первичные ключи таблиц данных.
  • Последовательности.
  • Заголовки системных объектов платформы.

Этот набор минимально достаточен, чтобы с помощью синхронизации (загрузив метаданные из таблиц, с ключем /T) восстановить метаданные БД в соответствующей схеме, и работать с ней средствами платформы.

Особенности перекачки данных в папку, файл или zip-архив:

При использовании папки она рассматривается как хранилище файлов перекачки. При использовании файла он рассматривается как хранилище файлов перекачки в формате Microsoft Compound File. При использовании zip-архива он рассматривается как хранилище файлов перекачки. Хранилище файлов перекачки содержит следующие файлы:

  • FormatSettings - xml-файл с информацией о региональных настройках процесса, сформировавшего хранилище.
  • Sequences - xml-файл с информацией о текущих значениях последовательностей.
  • RTTI - xml-файл с информацией о таблицах и полях. Также содержит информацию о табличных пространствах.
  • <Имя Таблицы> с возможным числовым постфиксом в скобках - xml-файл с данными таблицы в стандартном xml-представлении.
  • #<Длина файла в 16-ричном представлении, 16 символов><CRC файла в 16-ричном представлении, 8 символов> - двоичный файл с содержимым blob/clob. Такие файлы формируются для объектов, чей размер превышает 1MB.

Остальные файлы в хранилище будут проигнорированы (если хранилище используется как источник) или удалены (если хранилище используется как приемник).

Если в качестве приемника используется zip-архив, то механизм перекачки данных будет использовать информацию об уже содержащихся в архиве файлах, и не будет повторно "пересжимать" уже имеющиеся файлы. Таким образом, можно удобно релизовать "инкрементальное резервное копирование", указывая в качестве приемника перекачки данных один и тот же zip-архив.

  • Стандартная перекачка данных
  • Механизмы связи между БД на сервере
  • Загрузка данных из внешнего файла
  • Сборка xml-документа на сервере


Стандартная перекачка данных

(одним файлом)
Стандартная перекачка данных

Стандартная процедура перекачки блока данных заключается в открытии однонаправленного курсора на основании запроса типа select... from "..." к таблице-источнику, подготовке запроса insert into "..."("ID",.....) values (:Param1, :Param2....) к приемнику, и многократному выполнению этого единожды подготовленного запроса по мере продвижения вперед по курсору-источнику. Все значения полей при этом проходят через клиентскую сторону, и заливка данных осуществляется по одной записи за одно выполнение запроса. Характерная скорость такой заливки - порядка 5000 записей в секунду.

Оператор INSERT в процессах перекачки данных всегда формируется с подсказкой /*+ APPEND */.

Описанные далее механизмы оптимизации не могут использоваться одновременно. Если какой-либо из них может быть использован в вашей ситуации - постарайтесь обеспечить условия, необходимые для их работы. Вы получите значительное ускорение перекачки.


Механизмы связи между БД на сервере

(одним файлом)
Механизмы связи между БД на сервере

Будут формироваться и выполняться блоки вида
01execute block as
02  declare "ID" BIGINT;
03  declare "P0" SMALLINT;
04  .....
05begin
06  for execute statement 'select "ID", .... from "...."'
07    on external data source '....' as user '...' password '....'
08    into :"ID",:"P0",..... do
09      insert into "...."("ID",....)
10      values (:"ID",:"P0",.....);
11end

Механизм может быть использован, если пользователь-владелец схемы имеет право CREATE DATABASE LINK, и оператор create database link будет выполнен без ошибок. При этом будет создан link с именем "SYS$PUMP". После завершения процедуры перекачки данных link будет удален. Таким образом, можно в целях безопасности выдавать право CREATE DATABASE LINK владельцу схемы данных только на время перекачки данных. При этом генерируются и выполняются операторы вида
1INSERT /*+ APPEND */ INTO "..."("ID", ....)
2SELECT "ID", ....
3  FROM "..."@"SYS$PUMP"
4...

Механизм может быть использован, если в БД установлено стандартное расширение "dblink", и оператор select public.dblink_connect('user=... password=.......') будет выполнен без ошибок. При этом генерируются и выполняются операторы вида
01do $$
02declare
03  cnt int;
04begin
05  perform public.dblink_connect('user=... password=... ....');
06  perform public.dblink_open('SYS$....', 'select T."ID", ..... from "...." T');
07  loop
08    insert into "...." ("ID", .....)
09    select T."ID" from public.dblink_fetch('SYS$.....', 1000000)
10    as T("ID" bigint, .....);
11    get diagnostics cnt = row_count;
12    exit when cnt = 0;
13  end loop;
14end; $$

Механизм может быть принудительно заблокирован ключем /NODBLINK.


Загрузка данных из внешнего файла

(одним файлом)
Загрузка данных из внешнего файла

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Временная папка процесса dbsetup.exe (переменная окружения %TMP%) доступна сервису Firebird как источник внешних данных (в конфигурации FireBird - параметр ExternalFileAccess).
  • Таблица не содержит полей типа BLOB.
  • Таблица не содержит обнуляемых полей, все поля таблицы обязательные.
  • Загружаемый блок содержит как минимум 1000 записей.
В этом случае во временной папке будет создан временный файл, содержащий загружаемые данные в требуемом Firebird формате, и выполнены операторы:
1create table "DML..." external '.....'
2  ("ID" BIGINT,
3  ....);
4insert into "..."("ID", ...)
5  select "ID", ....
6  from "DML....";
7drop table "DML....";
После чего временный файл будет удален.

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Владельцу данных доступна на чтение и запись хотя бы одна папка (directory). Этого можно достичь, например, такими операторами:
    1CREATE DIRECTORY dir_name AS 'D:\TEMP';
2GRANT READ,WRITE ON DIRECTORY dir_name TO user_name;
    При этом папка (на диске) должна быть доступна на запись процессу dbsetup.exe.
  • Оператор
    01create table "DML...."
02(
03 ....
04) ORGANIZATION EXTERNAL (
05  DEFAULT DIRECTORY ....
06  ACCESS PARAMETERS (
07    RECORDS DELIMITED BY NEWLINE
08    FIELDS TERMINATED BY '....'
09  )
10  LOCATION ('DML.....')
11)
    выполняется без ошибок. Созданная при этом таблица доступна для чтения.
  • Таблица не содержит полей типа BLOB.
  • Загружаемый блок содержит как минимум 1000 записей.
В этом случае в папке, которая доступна, будет создан временный файл, содержащий загружаемые данные в требуемом Oracle формате, и выполнены операторы:
1create table "DML....."
2(
3 ....
4) ORGANIZATION EXTERNAL (
5....);
6insert into "..."("ID", ...)
7  select "ID", ....
8  from "DML....";
9drop table "DML....";
После чего временный файл будет удален.

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Временная папка процесса dbsetup.exe (переменная окружения %TMP%) доступна сервису PostgreSQL как источник внешних данных.
В этом случае в папке, которая доступна, будет создан временный файл, содержащий загружаемые данные в требуемом Postgres формате. В случае, когда размер файла превысит 1GB, а также по исчерпании источника, будет выполнен оператор
  copy "..."(...) from %TEMP%\DML....CSV with (format csv, encoding UTF8)
После чего временный файл будет удален.

Механизм может быть принудительно заблокирован ключем /NOCSV.


Сборка xml-документа на сервере

(одним файлом)
Сборка xml-документа на сервере

Механизм создает большую нагрузку на сервер БД, но в то же время позволяет существенно ускорить перекачку данных.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующие условия:
  • Таблица не содержит полей типа BLOB.
  • Таблица не содержит строковых полей, которые могут содержать не-xml-compaint символы (определяется по свойствам соответствующего строкового домена.
В этом случае будут формироваться и выполняться запросы вида
1with T as (select T.* from "...." T order by T."ID")
2select cast(cast(
3  '<data handle="' || count(1) ||  '" eof="1">' || list('<row>' ||
4    '<ID type="int64">' || T."ID" || '</ID>' ||
5      case when T."..." is null then '<.../>' else '<... type="int">' || T."..." || '</...>' end ||
6      ......
7    || '</row>' , '') || '</data>' as blob sub_type 1 character set utf8) as blob sub_type 0), count(1)
8  from T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующие условия:
  • Используется Oracle версии не ниже 11.
  • Таблица не содержит полей типа BLOB.
В этом случае будут формироваться и выполняться запросы вида
1with T as (select T.* from "..." T )
2select "SYS$HELPER"."ClobToBlob"('<data handle="' || count(1) || '" eof="1">' ||
3  xmlagg(xmlelement("row", xmlelement("ID", xmlattributes('int64' as "type"), T."ID"),
4    case when "..." is null then xmltype('<..../>') else
5      xmlelement("....", xmlattributes('ascii' as "type"), "SYS$HELPER"."XMLEscape"(asciistr(T."...."), 0)) end,
6    ....
7 order by T."ID").getclobval() || '</data>'), count(1) from T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующее условие:
  • Таблица не содержит полей типа BLOB.
В этом случае будут формироваться и выполняться запросы вида
1select convert_to( '<data handle="' || count(1) ||  '" eof="1">' || string_agg(
2  '<row>' ||
3    '<ID type="int64">' || T."ID" || '</ID>' ||
4    case when T."...." is null then '<..../>' else '<.... type="int64">' || T."...." || '</....>' end ||
5    .....
6  '</row>', '' order by T."ID") || '</data>', 'UTF8'), count(1) from "..." T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Механизм может быть принудительно заблокирован ключем /NOXML.


Ключи командной строки инсталлятора платформы

(одним файлом)
Ключи командной строки инсталлятора платформы

Для автоматизации установки или обновления платформы инсталлятор платфромы setup.exe поддерживает ключи командной строки.
Указание ключей командной строки не превращет инсталлятор платфромы setup.exe в консольное приложение. Поэтому если вы включаете запуск инсталлятора в файл пакетной обработки, вам, возможно, потребуется дождаться завершения процесса установки. Для этого рекомендуется использовать команду start (с ключем /w или /wait. Рекомендуется ознакомиться со справкой по команде start перед ее использованием) :
start /w "SOME_TITLE" "...\SOME_FOLDER\setup.exe" /N /S /P /F .....

Ключи указываются через пробел. Ключ должен начинаться символом "/". Для ключей, содержащих значения параметров, между ключем, символом "=" и значением параметра пробелов быть не должно.

Ключи командной строки:

Ключ | Назначение
/S | Запускает инсталлятор в режиме "без пользовательского интерфейса". Никакого взаимодействия с пользоваетелем не предусматривается. Если ключ /S не указан, то режимы, устанавливаемые остальными ключами, будут являться умолчаниями, и пользователь сможет их изменить в процессе взаимодействия с инсталлятором.
/NCRC | Отключает проверку целостности инсталлятора перед запуском.
/x64 | Устанавливает компоненты 64-разрядной редакции. См. замечание 1.
/L="<Файл лицензии>" | Позволяет указать файл лицензии. Необходимо использовать полный путь к файлу. Если имя файла лицензии содержит пробелы, то его необходимо заключать в кавычки. См. замечание 2.
/T=<Число от 0 до 7> Выбирает тип установки (состав устанавливаемых компонент).
  • 0 - Рабочее место пользователя
  • 1 - Рабочее место администратора
  • 2 - Рабочее место разработчика
  • 3 - Только построитель запросов
  • 4 - Сервер приложений
  • 5 - Только сервер приложений
  • 6 - Только отладочный монитор
  • 7 - Только системные файлы
Точно установить, какие конкретно компоненты входят в тот или иной тип установки можно, запустив инсталлятор, на странице "Параметры установки". Там указано соответствие между типами установки и устанавливаемыми компонентами.
/LANG=<Идентификатор языка> Поддерживаемые языки:
  • 1033 - Английский
  • 1049 - Русский
  • 1034 - Испанский
/N | Без регистрации компонентов в реестре и создания ярлыков. Только копирование файлов.
/NOREGISTER
/U | Без создания ярлыков. Только копирование файлов и регистрация компонентов.
/UPDATE
/NOSERVICE | Не регистрировать сервисы в системе.
/P | Не проверять возможность обновления файлов.
/NOPROCLIST
/F | Не устанавливать третьесторонние распространяемые файлы.
/NOINSTALLREDIST
/NODISABLEOFFICECLIPBOARD | Не устанавливать библиотеку поддержки приложений Microsoft Office.
/NO_DISABLE_OFFICE_CLIPBOARD
/D=<Папка установки> Указывает папку установки. Необходимо указывать полный путь к папке.
Этот ключ может быть указан только последним в командной строке, либо не указан вообще.
Даже если имя папки установки содержит пробелы, то заключать в кавычки значение ключа /D не нужно.
setup.exe /NCRC /S /D=C:\Program Files\Data Mill

Замечания:

  1. Если ключ /x64 не задан, но в папке установки уже содержится папка WIN64, то все равно будет устанавливаться (в данном случае - обновляться) 64-битная редакция.
  2. Если ключ /L=... не задан, но рядом с инсталлятором пллатформы setup.exe находится хотя бы один файл с расширением .license, то в качестве файла лицензии будет использоваться один из этих файлов (первый найденный).


Форматы и соглашения

(раздел целиком) (одним файлом)
Форматы и соглашения
  • Стандартная адресация базы данных платформы


Стандартная адресация базы данных платформы

(одним файлом)
Стандартная адресация базы данных платформы

Строка адресации БД платформы "Мельница данных" состоит из следующих элементов:
Сервер#Пользователь:Роль/Пароль@БазаДанных

Сервер - один из следующих вариантов:

  • MS - БД MSSQL
  • FB - БД Firebird
  • ORA - БД Oracle Database
  • PG - БД PostgreSQL
  • MY - БД MySQL
  • APP - Удаленное подключение к БД через сервер приложений

Пользователь - имя пользователя, используемого для соедиения.

Роль - роль, ассоциированная с соединением.
Роль, заданная в строке адресации БД, используется для установки соединения с БД (передается через параметр isc_dpb_sql_role_name)
Для всех СУБД, кроме Firebird, указание роли имеет смысл только для утилиты обслуживания БД.

Пароль - пароль пользователя, используемый для соедиения. Пароль также может быть не задан в строке соединения (после символа "/" сразу следует символ "@"). В этом случае пароль будет запрошен у пользователя (если будет такая возможность), или будет использоваться Negotiate-аутентификация.

БазаДанных - адресует собственно базу или схему данных.
При использовании удаленного подключения к БД через сервер приложений используется нотация
protocol://Host:Port/handler
Протокол (protocol) может быть http или https. По умолчанию используется протокол http. Порт (Port) по умолчанию 80 для протокол http и 443 для протокола https может быть опущен.
Host:Port\\InstanceName.Database
Порт (Port) по умолчанию 1433 может быть опущен вместе с двоеточнием. Хост (Host) может быть опущен, если используется локально. Имя экземпляра (InstanceName) может быть опущено, если используется имя "MSSQLSERVER". Следующие строки эквивалентны:
1localhost:1433\\MSSQLSERVER.MillDatabase
2localhost\\MSSQLSERVER.MillDatabase
3localhost.MillDatabase
4MillDatabase

Host/Port:DBPath
Порт (Port) по умолчанию 3050 может быть опущен. Если опущен хост (Host), то используется локальный протокол доступа к БД. Файл базы данных (DBPath) может быть задан как полное имя файла в файловой системе сервера, так и быть псевдонимом, настроенным на сервере.
Host:Port/SID.schema
Порт (Port) по умолчанию 1521 может быть опущен. Если опущен хост (Host), то используется имя из файа TNSNAMES.ORA в используемой клиентской части СУБД. Указание SID и имени схемы (schema) обязательно.
Host:Port/DataBase.schema
Порт (Port) по умолчанию 5432 может быть опущен. Если опущен хост (Host), то используется локальное соединение. Указание имени базы данных (DataBase) и имени схемы (schema) обязательно.
Host:Port/schema
Порт (Port) по умолчанию 3306 может быть опущен. Если опущен хост (Host), то используется локальное соединение. Указание имени схемы (schema) обязательно.

Прямое подключение к БД от имени владельца схемы данных является административным.
Владельцем схемы данных является пользователь, имя которого совпадает с именем схемы.
Никакое подключения к БД через сервер приложений не является административным.


Руководство разработчика на платформе

(раздел целиком) (одним файлом)
Руководство разработчика на платформе
  • Решения, предлагаемые технологией "Мельница данных"
  • Системный слой объектной модели "Мельница данных"
  • Наследование и переопределение членов класса и параметров подпрограмм
  • Средства моделирования пользовательского интерфейса
  • Объектно-реляционное отображение
  • Обзор возможностей Платформы
  • Этапы разработки прикладных решений
  • Интеграция
  • Положения и определения
  • Облачные вычисления
  • OLTP и OLAP
  • RESTful-service стандартного обработчика


Решения, предлагаемые технологией "Мельница данных"

(одним файлом)
Решения, предлагаемые технологией "Мельница данных"

Технология "Мельница данных" предлагает решения традиционных проблем разработки и сопровождения учетных систем за счет следующих инноваций:

  1. Объектная модель хранится в системе по тем же принципам, что и модель бизнес-данных, т.е. объекты классов, описывающих метаданные системы (классы, поля, методы, свойства, пользовательские формы) хранятся в базе данных и отображаются при помощи стандартного пользовательского интерфейса. Моделирование системного слоя метаданных системы произведено разработчиками платформы. Модель системного слоя документирована и доступна для просмотра и использования разработчикам прикладных систем.
  2. Разработка прикладных учетных систем ведется в той же среде, что и работа конечных пользователей. Текущая модель прикладной системы доступна для просмотра и использования всеми разработчиками.
  3. На основе заложенной объектной модели прикладной системы автоматически генерируется SQL-код (как DML, так и DDL составляющие), что полностью освобождает разработчика прикладной системы от SQL-программирования.
  4. Пользовательские интерфейсы (формы, представления) также описываются при помощи объектной модели и хранятся в базе данных. Это позволяет автоматически генерировать формы просмотра данных и формы задания параметров методов, что освобождает разработчика прикладной системы от написания кода клиентского приложения. Для тонкого управления поведением форм задания параметров может использоваться язык VB-script.
  5. При внесении изменений в объектную модель:
    • новое состояние модели отображается в пользовательском интерфейсе в доступной для всех разработчиков форме;
    • текущая объектная модель в виде диаграммы классов может быть выгружена в HTML-отчет, что является базовой возможностью платформы;
    • внесение изменений в структуру базы данных и пользовательские интерфейсы производится автоматически средствами платформы.

Основными элементами стандартизованного пользовательского интерфейса являются развитые элементы управления, работающие с данными:

  • Таблицы данных - отображают списки объектов в табличной форме, удобной для восприятия пользователя. Таблицы данных позволяют производить сортировку, группировку объектов, фильтрацию данных по ряду условий, подведение агрегатов (количества объектов, наибольшего, наименьшего значения, суммы, среднего и т.д.), отображение и скрытие групп, подведение итогов по группе. Таблицы данных имеют функционал, позволяющий отображать иерархические структуры, а также производить произвольный отбор отображаемых объектов пользователем. Используемые таблицы данных позволяют работать с большими объемами данных без потери производительности.
  • Инспектор объектов - отображает все свойства выбранных (одного или нескольких) объектов в двух колонках: имя свойства - значение свойства. Инспектор объектов позволяет просматривать все свойства объектов, а также изменять значения свойств как одного объекта, так и для всех выделенных объектов одним действием.
  • Форма задания параметров - отображается при вызове пользователем одного из методов. На форме расположены элементы управления Поле ввода, соответствующие описанным для метода параметрам. Внешний вид и поведение элементов управления зависят от типа описанных параметров. Поведением элементов управления на форме можно управлять при помощи скрипта формы, разрабатываемого на языке VB-script.
  • Поле ввода - используется для задания значений свойств и параметров как в Таблице данных, так и в Инспекторе объектов и на формах задания параметров. Имеет функционал, позволяющий редактировать значения различных типов. Использование стандартизованного пользовательского интерфейса позволяет снизить издержки как на его сопровождение, так и на обучение пользователей работе на новых участках.

Реализованы развитые возможности интеграции с третьесторонними системами. Они обеспечиваются следующими механизмами:

  1. Возможность переноса в Microsoft Excel любого видимого представления "as-is" с сохранением всех группировок, сортировок, агрегатов и т. п.
  2. Возможность вывода отчетов в виде документов Microsoft Office с передачей в среду функционирования Office соединения с БД, что позволяет строить отчеты любой степени сложности.
  3. Возможность использования в системе любого внешнего Ole-объекта как метода любого класса без ограничений.
  4. Возможность использования скриптлетов (фрагментов кода на скриптовом языке VBScript и/или JScript) как методов системы, фактически - возможность реализации на этих языках сколь угодно сложного поведения.
  5. Возможность формирования отчетов непосредственно в виде html-документов для последующей публикации их в сети Internet.


Системный слой объектной модели "Мельница данных"

(одним файлом)
Системный слой объектной модели "Мельница данных"

Технология разработки и сопровождения учетных систем "Мельница данных" требует для своего функционирования объектную модель бизнес-сущностей. Технология диктует ряд дополнительных требований к объектной модели.

  1. Все классы наследуются от единого корня, класса TObject. Класс TObject вводит ряд элементов состояния, поведения и представления, которые наследуются всеми учитываемыми объектами в обязательном порядке.
  2. Множественное наследование не поддерживается (т.е. у каждого класса может быть один и только один родитель).
  3. Множественная инкапсуляция не поддерживается (т.е. у каждого объекта может быть один либо ни одного инкапсулирующего объекта).
  4. Простые типы данных вводятся посредством доменов. Домены определяют обязательность своих значений, а также другие характеристики, зависящие от класса домена. Домены бывают:
    • строковые (определяют максимальную длину строки);
    • целочисленные (определяют максимальное и минимальное значение целого числа);
    • вещественные (определяют максимальное и минимальное значение числа, количество значащих цифр);
    • логические;
    • значения типа "дата";
    • значения типа "время";
    • значения типа "дата со временем";
    • перечисления (определяют список возможных значений);
    • ссылка (определяют класс-приемник ссылки);
    • большие двоичные объекты (текст, изображение, файл, и т.д.).


Наследование и переопределение членов класса и параметров подпрограмм

(одним файлом)
Наследование и переопределение членов класса и параметров подпрограмм

Все члены родительского класса наследуются дочерним классом следующим образом:

Поля

Все поля родительского класса доступны в дочернем классе. При создании в дочернем классе поля с тем же именем, что и в родительском классе, класс-наследник теряет возможность напрямую манипулировать полем родительского класса и получает поле с тем же именем. Можно сказать, что новое поле "закрывает" старое, но не "замещает" его.

Методы

Все методы родительского класса наследуются дочерним классом. При создании в дочернем классе метода с тем же именем, что и в родительском классе, метод переопределяется, т.е. вместо старого метода будет существовать новый. Единственный способом обратиться к старому (унаследованному) методу является использование в теле метода оператора унаследованного вызова inherited (см. раздел 5.3.14.). Переопределенный метод имеет все параметры родительского метода и может расширять список параметров, а также переопределять унаследованные параметры (создавая параметры с тем же именем и изменяя любой другой атрибут параметра по своему усмотрению). Скрипты форм задания параметров не наследуются и должны быть полностью заданы в переопределенном методе. Изображения-иконки методов наследуются и могут не переопределяться явно.

Свойства

Все свойства родительского класса доступны в дочернем классе. При создании в дочернем классе свойства с тем же именем, что и в родительском классе, класс-наследник теряет возможность напрямую манипулировать свойством родительского класса и получает свойство с тем же именем. Можно сказать, что новое свойство "закрывает" старое, но не "замещает" его. На практике часто бывает необходимо в унаследованном методе (особенно в конструкторе) скрыть часть параметров от пользователя, либо сузить область выбора значений для каких либо параметров. В этом случае необходимо переопределить параметры в унаследованном методе с новыми значениями свойства Scope ("Область видимости") или Domain ("Домен"). Это нормальная рекомендуемая практика. Необходимо понимать, что скрыв с формы элемент управления, соответствующий параметру, значение которого обязательно, необходимо предусмотреть, чтобы этот параметр получил значение до вызова унаследованного метода, либо из скрипта формы задания параметров, либо в теле самого метода.

В конструкторе класса, унаследованного от класса TObject, переопределен параметр Name, таким образом, что в свойстве "Область видимости" установлено значение "Не видимо пользователям". При этом тело метода конструктора должно выглядеть следующим образом:
1begin
2  Name := UniqueValue;                    (1)
3  inherited;                         (2)
4  // инициализация собственных полей
5end;
Параметр конструктора Description, унаследованный от конструктора класса TObject останется видимым и его значение будет в обязательном порядке установлено пользователем при помощи формы задания параметров. Значения параметров Parent и Master будут определены из контекста вызова или запрошены у пользователя. Параметр Name не будет отображен на форме задания параметров и в начале выполнения тела метода его значение будет пустым (nil). В связи с этим в строке (1) тела метода производится установка значения параметра Name при помощи функции UniqueValue. Если этого не сделать, то вызов унаследованного метода при помощи оператора inherited вернет ошибку, связанную с тем, что параметр Name имеет недопустимое значение.


Средства моделирования пользовательского интерфейса

(раздел целиком) (одним файлом)
Средства моделирования пользовательского интерфейса
  • Представления
  • Визуальные группы
  • Формы, связь представлений в формах


Представления

(одним файлом)
Представления

Этот раздел еще предстоит написать.


Визуальные группы

(одним файлом)
Визуальные группы

Этот раздел еще предстоит написать.


Формы, связь представлений в формах

(одним файлом)
Формы, связь представлений в формах

Этот раздел еще предстоит написать.


Объектно-реляционное отображение

(одним файлом)
Объектно-реляционное отображение

Этот раздел еще предстоит написать.


Обзор возможностей Платформы

(одним файлом)
Обзор возможностей Платформы

Этот раздел еще предстоит написать.


Этапы разработки прикладных решений

(раздел целиком) (одним файлом)
Этапы разработки прикладных решений
  • Формирование видения модели
  • Создание структур хранения и средств обработки данных
  • Синхронизаци базы данных
  • Создание пользователей и ролей
  • Средства моделирования пользовательских интерфейсов
  • Разработка отчетов
  • Поставка решений


Формирование видения модели

(одним файлом)
Формирование видения модели

Этот раздел еще предстоит написать.


Создание структур хранения и средств обработки данных

(раздел целиком) (одним файлом)
Создание структур хранения и средств обработки данных
  • Класс TObject, члены класса TОbject
  • Создание классов
  • Создание полей
  • Создание свойств
  • Создание методов


Класс TObject, члены класса TОbject

(одним файлом)
Класс TObject, члены класса TОbject

Этот раздел еще предстоит написать.


Создание классов

(одним файлом)
Создание классов

Этот раздел еще предстоит написать.


Создание полей

(одним файлом)
Создание полей

Этот раздел еще предстоит написать.


Создание свойств

(одним файлом)
Создание свойств

Этот раздел еще предстоит написать.


Создание методов

(одним файлом)
Создание методов

Этот раздел еще предстоит написать.


Синхронизаци базы данных

(одним файлом)
Синхронизаци базы данных

Этот раздел еще предстоит написать.


Создание пользователей и ролей

(одним файлом)
Создание пользователей и ролей

Этот раздел еще предстоит написать.


Средства моделирования пользовательских интерфейсов

(раздел целиком) (одним файлом)
Средства моделирования пользовательских интерфейсов
  • Представления
  • Формы. Включение представлений в формы
  • Визуальные группы. Включение форм в визуальные группы
  • Организация доступа пользователей к формам и визуальным группам


Формы. Включение представлений в формы

(одним файлом)
Формы. Включение представлений в формы

Этот раздел еще предстоит написать.


Визуальные группы. Включение форм в визуальные группы

(одним файлом)
Визуальные группы. Включение форм в визуальные группы

Этот раздел еще предстоит написать.


Организация доступа пользователей к формам и визуальным группам

(одним файлом)
Организация доступа пользователей к формам и визуальным группам

Этот раздел еще предстоит написать.


Разработка отчетов

(раздел целиком) (одним файлом)
Разработка отчетов
  • Создание шаблонов PDF-отчетов
  • Справочник по интерфейсам


Создание шаблонов PDF-отчетов

(раздел целиком) (одним файлом)
Создание шаблонов PDF-отчетов
  • Описание
  • Методы
  • Порядок создания


Описание

(одним файлом)
Описание

Portable Document Format (PDF) — кроссплатформенный формат электронных документов, созданный фирмой Adobe Systems с использованием ряда возможностей языка PostScript. В первую очередь предназначен для представления в электронном виде полиграфической продукции, — значительное количество современного профессионального печатного оборудования может обрабатывать PDF непосредственно. Для просмотра можно использовать официальную бесплатную программу Adobe Reader, а также программы сторонних разработчиков. Традиционным способом создания PDF-документов является виртуальный принтер, то есть документ как таковой готовится в своей специализированной программе — графической программе или текстовом редакторе, САПР и т. д., а затем экспортируется в формат PDF для распространения в электронном виде, передачи в типографию и т. п. Формат PDF позволяет внедрять необходимые шрифты (построчный текст), векторные и растровые изображения, формы и мультимедиа-вставки. Поддерживает RGB, CMYK, Grayscale, Lab, Duotone, Bitmap, несколько типов сжатия растровой информации. Имеет собственные технические форматы для полиграфии: PDF/X-1, PDF/X-3. Включает механизм электронных подписей для защиты и проверки подлинности документов. В этом формате распространяется большое количество сопутствующей документации. Чаще всего PDF-файл является комбинацией текста с растровой и векторной графикой, реже — текста с формами, JavaScript'ом, 3D-графикой и другими типами элементов.

В приложениях Платформы "Мельница данных" для создания PDF-документов используется собственная библиотека PDFCreator.dll. С помощью библиотеки возможно прямое создание документов версии 1.3 . Создание PDF-документов осуществляется путем ввода предопределенных в библиотеке команд, которые в дальнейшем интерпретируются на основе языка описания страниц POSTSCRIPT.

Все размеры графических объектов, размеры страниц, шрифтов и т.п. по умолчанию заданы в миллиметрах.
Для удобства построения шаблона PDF-документа создана функция DrawGrid. При ее включении при отладке при создании шаблона будет отображена визуальная сетка с шагом 5 миллиметров.


Методы

(раздел целиком) (одним файлом)
Методы
  • Свойства документа
  • Свойства страницы
  • Графика
  • Шрифты


Свойства документа

(одним файлом)
Свойства документа

Для создания и описания свойств PDF-документа в библиотеке PDFCreator.dll используется класс IPDFDocument, обладающий следующими свойствами:

  • Title (WideString) - заголовок документа. По умолчанию - пустая строка.
    Title = "DOC1"
  • CanEmbedFonts (WordBool) - Признак возможности построения PDF- документа со встроенными шрифтами (Embedded Fonts). В случае включения признака, все объявленные в скрипте шрифты будут включены в сборку документа и будут передаваться целиком вместе с документом. По умолчанию - False.
    CanEmbedFonts = True
CanEmbedFonts = False
  • CanCompress (WordBool) - признак сжатия документа при создании по собственным алгоритмам. По умолчанию - True.
    CanCompress = False
CanCompress = True
  • Author (WideString) - автор документа. По умолчанию - текущий пользователь ОС.
  • Subject (WideString) - описание документа. По умолчанию - пустая строка.
  • Keywords (WideString) - ключевые слова для поиска по документу. По умолчанию - пустая строка.
  • Creator (WideString) - приложение-родитель документа. Указывается в том случае, если документ был сконвертирован из другого формата.
  • PageCount (Integer) - свойство, содержащее общее количество страниц в документе.
  • Pages[Index: Integer]: IPDFPage - свойство документа, предназначенное для перебора страниц документа для совершения над ними однотипных действий.

    Пример использования:

    1for I = 0 to PageCount - 1
2  Pages(I).rectangle 10,10,10,10, false
3next
Save "c:\pdf.pdf"

    Результат: На всех страницах документа будут нарисованы квадраты 10х10 мм.
  • procedure Save(Target: OleVariant) - процедура для сохранения документа PDF на жесткий диск сразу после создания.
    Save "c:\pdf.pdf"
    - сохранит документ в файл c:\pdf.pdf


Свойства страницы

(раздел целиком) (одним файлом)
Свойства страницы

Для создания страницы используется функция

function CreatePage(Parent: OleVariant): IPDFPage;

Параметр Parent указывает страницу-родителя для данной страницы. Если страницы- родителя быть не должно - формат вызова функции примет вид:

set page = CreatePage(Null)

Параметры страницы:

  • Title - заголовок страницы.
    page.Title = "Page name"
  • Width - ширина страницы, миллиметры
    page.Width = 80
  • Height - высота страницы, миллиметры
    page.Height = 80
  • DrawGrid - процедура, выводящая на страницу сетку с шагом 5 миллиметров для удобства отладки вида документа.
  • Perform - процедура, позволяющая выполнить дополнительные команды PostScript на странице.
    page.perform "1 0.7 0 0 k"page.perform "0 0 m"
  • Объявление цвета


Объявление цвета

(одним файлом)
Объявление цвета

Для объявления цвета объектов на странице используется цветовая модель R:G:B (Red:Green:Blue). Объявление цвета для выполнения последующих операций (цвет шрифта, цвет линии/фигуры) осуществляется процедурой

procedure SetColor(R: Integer; G: Integer; B: Integer);
Где параметры R, G, B - значения базисных цветов для выбранного цвета (от 0 до 255).

Цвет | R | G | B |
Белый | 255 | 255 | 255 | +++
Черный | 0 | 0 | 0 | +++
Серый | 190 | 190 | 190 | +++
Синий | 0 | 0 | 255 | +++
Красный | 255 | 0 | 0 | +++
Зеленый | 0 | 255 | 0 | +++

Если предварительно цвет не был объявлен, используется цвет по умолчанию - черный (0,0,0)


Графика

(раздел целиком) (одним файлом)
Графика
  • Линии
  • Прямоугольник
  • Вставка готовых изображений
  • Векторная графика


Линии

(одним файлом)
Линии

Для отрисовки линий используется процедура

procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double);
Здесь:

  • X1 - координата начала линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y1 - координата начала линии по вертикали в миллиметрах от верхнего левого угла листа.
  • X2 - координата конца линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y2 - координата Конца линии по вертикали в миллиметрах от верхнего левого угла листа.

Для задания толщины линии используется свойство

property LineWidth: Double
Значение толщины задается в миллиметрах. Значение по умолчанию - минимально возможная единица рисования для устройства. Так для монитора - 1 pixel, для принтера - 1 dot (точка)

Для задания стиля отрисовки начала/окончания линии используется свойство property LineCap: TPDFLineCap
Возможные стили:
Значение свойства: | Отображение: | Описание:
0 | Линия 0 | Прямой срез точно по точкам начала и окончания линии (по умолчанию)
1 | Линия 1 | С закруглением
2 | Линия 2 | Прямой срез с продолжением линии на половину толщины линии

Объявление цвета линии.

Две линии разной толщины, с разными окончаниями и цветами:
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineCap = 1
06
07page.LineWidth = 2
08
09page.Line 10, 10, 30, 30
10
11page.LineWidth = 4
12
13page.SetColor 255, 0, 0
14
15page.LineCap = 2
16
page.Line 10, 30, 30, 10."I

Результат:
2 линии

При необходимости соединения линий под углом в определенной точке можно задать тип соединения. Для объявления типа соединения используется свойство property LineJoin: TPDFLineJoin;
Типы соединения двух линий:
Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пунктир

Для создания пунктира используется процедура отображения линии с предварительно объявленными дополнительными значениями.

Процедура procedure SetDash(DashArray: OleVariant; Phase: Integer); Здесь DashArray - массив значений в миллиметрах, указывающий последовательность чередования штрихов и пропусков на линии, Phase - смещение в миллиметрах по линии.

Пример 1. Штрих 10 мм, Промежуток 5 мм, Смещения нет
Пример 2. Штрих 10 мм, Промежуток 5 мм, Смещение 5 мм
Пример 3. Различные значения штрихов и промежутков, Смещения нет
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 3
06
07page.SetDash Array(10, 5), 0
08
09page.Line 10, 10, 100, 10
10
11page.SetDash Array(10, 5), 5
12
13page.Line 10, 20, 100, 20
14
15page.SetDash Array(10, 5, 3, 2, 12, 20), 0
16
page.Line 10, 30, 100, 30

Результат:
Пунктир 1

Ломанная линия - здесь непрерывная линия, состоящая из нескольких прямых. Для отображения ломанной используется процедура procedure Poly(Points: OleVariant; Fill: WordBool), где Points - массив координат точек соединяемых прямыми, а Fill - признак заливки полученной замкнутой фигуры (если замкнута).

Пример Звезда без заливки
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), false

Результат:
Звезда
Пример Звезда с заливкой
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), true

Результат:
Звезда заливка


Прямоугольник

(одним файлом)
Прямоугольник

Rectangle (Прямоугольник) - для создания используется процедура:

procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double; Fill: WordBool);
Здесь:

  • X1 - координата верхнего левого угла прямоугольника по горизонтали в миллиметрах от верхнего левого угла листа шаблона.
  • Y1 - координата верхнего левого угла прямоугольника по вертикали в миллиметрах от верхнего левого угла листа шаблона.
  • Width - ширина прямоугольника с миллиметрах.
  • Height - высота прямоугольника с миллиметрах.
  • Fill - признак заливки прямоугольника (True/False). Если значение True то заливка производится объявленным заранее цветом (см. Объявление цвета). Если False - заливка не производится. Прямоугольник отрисовывается линиями с предварительно заданной толщиной. См. Линии
Пример 1. Создание красного прямоугольника:
1set page = CreatePage(Null)
2
3page.SetColor 255, 0, 0
4
5page.Rectangle 10, 15, 40, 20, True
6
page.DrawGrid
Результат:
Прямоугольник
Пример 2. Пустой прямоугольник без задания цвета:
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.Rectangle 12, 17, 42, 25, false
6
page.DrawGrid

Результат:
Прямоугольник false

Также существует возможность изменения стиля отображения углов прямоугольника. Для этого нужно использовать свойство property LineJoin: TPDFLineJoin;

Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пример построения прямоугольников с различными типами соединения сторон:

01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 4
06
07page.LineJoin = 0
08
09page.Rectangle 10, 10, 20, 10, false
10
11page.LineJoin = 1
12
13page.Rectangle 40, 10, 20, 10, false
14
15page.LineJoin = 2
16
page.Rectangle 70, 10, 20, 10, false

Результат:
3 прямоугольника


Вставка готовых изображений

(одним файлом)
Вставка готовых изображений

Для вставки на создаваемую страницу готового изображения используется процедура procedure Image(const FileName: WideString; X: Double; Y: Double; Width: Double; Height: Double)

Параметры:

  • const FileName - имя файла изображения и путь к нему на жестком диске. Задается в кавычках.
  • X - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по горизонтали в миллиметрах
  • Y - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по вертикали в миллиметрах
  • Width - ширина изображения в миллиметрах
  • Height - высота изображения в миллиметрах.
1set page = CreatePage(Null)
2page.drawgrid
page.Image "c:\mill.bmp", 10,10, 30, 30

Результат:
Картинка

Вне зависимости от размера исходного изображения, при вставке изображения на создаваемую страницу оно будет растянуто по размерам, прописанным в процедуре.


Векторная графика

(одним файлом)
Векторная графика

Язык PostScript, с помощью которого создаются векторные изображения для PDF-документа, поддерживает создание типичных примитивных объектов, таких как:

  • Прямые и ломанные линии
  • Многоугольники
  • Окружности и эллипсы
  • Кривые Безье
  • Текст

При создании векторного изображения на странице PDF-документа в приложениях Платформы, команды построения примитивных объектов PostScript передаются на исполнение при помощи процедуры Perform. Подробнее об операторах и командах PostScript для создания PDF-документов можно узнать на сайте Adobe


Шрифты

(одним файлом)
Шрифты

Шрифты, которые должны использоваться в создаваемом документе, должны быть предварительно объявлены. Для объявления используемых шрифтов используется функция
function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool; Italic: WordBool): IPDFFont; где:

  • const FontName - имя шрифта, аналогичное имени объявляемого шрифта в операционной системе. В Функции объявляется в кавычках.
  • Size - размер шрифта в пунктах
  • Bold - признак начертания шрифта "жирный". Значения - True или False
  • Italic - признак начертания шрифта "курсив". Значения - True или False
Примеры объявления шрифтов:
1set font = page.createFont("Arial", 20, False, False)
2set labelFont = page.createFont("Times New Roman", 16, False, True)
3set dataFont = page.createFont("Tahoma", 18, True, False)

Для вывода текстовой информации на страницу используются процедуры:

  • procedure WriteLine(const LineText: WideString; X: Double; Y: Double);
    - используется для вывода текстовой строки
  • function WriteText(const AText: WideString; X: Double; Y: Double; Width: Double; Alignment: TPDFTextAlignment): Double;
    - используется для вывода текстового блока.

Параметры для procedure WriteLine :

  • const LineText - текстовая строка для вывода. Прописывается в кавычках. Будет выведена на страницу одной строкой.
  • X - координата верхней левой точки текстовой строки по горизонтали в миллиметрах.
  • Y - координата верхней левой точки текстовой строки по вертикали в миллиметрах.
Примеры вывода текстов на страницу:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Times New Roman", 16, False, True)
05set dataFont = page.createFont("Tahoma", 18, True, False)
06Font.WriteLine "Фамилия", 5, 2
07Font.WriteLine "Имя", 5, 10
08Font.WriteLine "Отчество", 5, 18
09labelFont.WriteLine "Дата рождения", 5, 26
10dataFont.WriteLine "Национальность", 5, 34

Результат:
Разные шрифты

Параметры для function WriteText :

  • const AText - текст для вывода на страницу. Прописывается в кавычках. Будет выведена на страницу в виде текстового блока.
  • X - координата верхней левой точки текстового блока по горизонтали в миллиметрах.
  • Y - координата верхней левой точки текстового блока по вертикали в миллиметрах.
  • Width - ширина текстового блока в миллиметрах
  • Alignment - тип выравнивания текста в текстовом блоке.
    Значение параметра | Тип выравнивания
    0 | По левому краю
    1 | По правому краю
    2 | По центру
    3 | Выравнивание по ширине
Примеры вывода текстовых блоков на страницу:
1set page = CreatePage(Null)
2page.DrawGrid
3set font = page.createFont("Arial", 14, False, False)
4set labelFont = page.createFont("Times New Roman", 12, False, True)
5set dataFont = page.createFont("Tahoma", 11, True, False)
6Q = font.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 5, 100, 0)
7Q = labelFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 35, 100, 1)
8Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 55, 100, 2)
9Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 80, 100, 3)

Результат:
Выравнивание

Свойства шрифтов:

property Spacing: Double; - свойство, отвечающее за величину промежутка между буквами в слове. Задается в виде отклонения от промежутка между буквами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Spacing = 0
07labelFont.Spacing = 1
08dataFont.Spacing = 2
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (1 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 15

Результат:
Промежуток букв

property WordSpacing: Double; - свойство, отвечающее за величину промежутка между соседними словами. Задается в виде отклонения от промежутка между словами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.WordSpacing = 0
07labelFont.WordSpacing = 2
08dataFont.WordSpacing = 5
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (5 мм)", 5, 15

Результат:
Промежуток слов

property Scaling: Double; - свойство, отвечающее за горизонтальное масштабирование букв используемого шрифта. Устанавливается в процентах. Горизонтальный масштаб по умолчанию - 100%.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Scaling = 50
07labelFont.Scaling = 100
08dataFont.Scaling = 200
09font.WriteLine "Сжатие (50)", 5, 5
10labelFont.WriteLine "По умолчанию (100)", 5, 10
11dataFont.WriteLine "Растягивание (150)", 5, 15

Результат:
Scaling

property RenderingMode: TPDFFontRenderingMode; - свойство, отвечающее за заливку букв используемого шрифта.
Типы заливки:
Значение параметра: | Отображение: | Описание:
0 | Font Fill | Сплошная заливка (по умолчанию). Буква заливается сплошным цветом, объявленным на данный момент.
1 | Font Stroke | Только граница. Прорисовывается граница буквы. Тело остается незалитым.
2 | Font FillStroke | Сначала заливка, потом граница. Граница прорисовывается всегда черным цветом. Заливка осуществляется сплошным цветом, объявленным на данный момент.
3 | Inv | Невидимый шрифт.

Пример:
01set page = CreatePage(Null)
02set font = page.createFont("Arial", 20, False, False)
03set labelFont = page.createFont("Arial", 20, False, False)
04set dataFont = page.createFont("Arial", 20, False, False)
05font.RenderingMode = 0
06labelFont.RenderingMode = 1
07dataFont.RenderingMode = 2
08page.setColor 255, 0, 0
09Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
10Q = labelFont.WriteText ("Олимпиада", 5, 15, 50, 0)
11Q = dataFont.WriteText ("Олимпиада", 5, 25, 50, 0)

Результат:
Заливка букв

property Rise: Double; - свойство, отвечающее за перемещение текста по вертикали.

01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Arial", 7, False, False)
05set dataFont = page.createFont("Arial", 7, False, False)
06labelFont.rise = -17
07dataFont.rise = -2
08Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
09Q = labelFont.WriteText ("Олимпиада", 44, 5, 50, 0)
10Q = dataFont.WriteText ("Олимпиада", 44, 5, 50, 0)

Результат:
Rise

Для определения размеров текстовой строки используется процедура MeasureLine(const LineText: WideString; out Width: OleVariant; out Height: OleVariant);

Здесь:

  • LineText - исходный текст для размещения на странице
  • Width - возвращаемый параметр ширины текстового блока на странице
  • Height - возвращаемый параметр высоты текстового блока на странице
1S = "шифр"
2font.MeasureLine S, W, H
3Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2)

Здесь для текста "Шифр" замеряется ширина и высота получившегося текстового блока. Затем полученные данные используются для корректного размещения текста на странице.

Для определения высоты текстового блока используется функция MeasureText(const AText: WideString; Width: Double): Double; safecall;

Функция распределит текст по задаваемому значению ширины текстового блока и вернет значение высоты текстового блока в милиметрах.

Здесь:

  • AText - исходный текст для размещения на странице. Прописывается в кавычках.
  • Width - задаваемая ширина текстового блока на странице в милиметрах.
1S = "Текст для размещения на странице..."
2Q = font.MeasureText(S, 139)
Здесь для текста "Текст для размещения на странице..." замеряется высота получившегося текстового блока. Затем полученные данные могут использоваться для корректного размещения текста на странице.


Порядок создания

(одним файлом)
Порядок создания

Для создания шаблона PDF-документа необходимо в системной форме Платформы выбрать класс, к которому будет строиться документ. В подменю "Подпрограммы" вызвать контекстное меню и выбрать пункт "Создать шаблон отчета PDF". Заполнить необходимые поля и приступить к созданию скрипта в окне "Скрипт шаблона".

  1. Объявляем все переменные.
  2. Создаем страницы
  3. Устанавливаем все свойства документа и страниц
  4. Рисуем простые графические объекты
  5. Объявляем все используемые шрифты
  6. Расставляем постоянный текст на странице
  7. Расставляем переменный текст на странице
  8. Вставляем или создаем сложные графические объекты
Пример документа PDF:
001set LDataSet = createDataSet("TRoundAbiturSt")
002'Объявление переменных
003LDataSet.AddQueryItem 1, "ID", ID
004LDataSet.AddQueryItem 0, "RoundComp$N"
005LDataSet.AddQueryItem 0, "BachRound$N"
006LDataSet.AddQueryItem 0, "LastName"
007LDataSet.AddQueryItem 0, "FirstName"
008LDataSet.AddQueryItem 0, "MiddleName"
009LDataSet.AddQueryItem 0, "BirthDate"
010LDataSet.AddQueryItem 0, "RegNumber"
011LDataSet.AddQueryItem 0, "SecondStageCity$D"
012LDataSet.AddQueryItem 0, "PhoneList"
013
014'Присваивание переменным значений
015OlympName = LDataSet.Field("RoundComp$N")
016OlympClass = LDataSet.Field("BachRound$N")
017LastName = LDataSet.Field("LastName")
018FirstName = LDataSet.Field("FirstName")
019MiddleName = LDataSet.Field("MiddleName")
020if not IsNull(LDataSet.Field("BirthDate")) then
021  BirthDate = LDataSet.Field("BirthDate")
022else
023  BirthDate = "(не задана)"
024end if
025RegNo = LDataSet.Field("RegNumber")
026if not IsNull(LDataSet.Field("SecondStageCity$D")) then
027  OlympCity = LDataSet.Field("SecondStageCity$D")
028else
029  OlympCity = "(не выбран город участия)"
030end if
031if not IsNull(LDataSet.Field("PhoneList")) then
032  Phone = LDataSet.Field("PhoneList")
033else
034  Phone = ""
035end if
036
037'CanCompress = False - признак сжатия файла
038set page = CreatePage(Null) ' создаем страницу
039'Объявляем используемые шрифты
040set font = page.createFont("Arial", 20, False, False)
041set labelFont = page.createFont("Arial", 16, False, False)
042set dataFont = page.createFont("Arial", 18, True, False)
043set bigFont = page.createFont("Arial", 24, False, False)
044
045'page.DrawGrid  - рисуем сетку для удобства отладки
046
047page.LineWidth = 0.5 ' Установка толщины линии
048
049' Рисуем прямоугольники
050page.Rectangle 8, 12, 4, 4, True
051page.Rectangle 190, 12, 4, 4, True
052
053page.Rectangle 8, 273, 4, 4, True
054page.Rectangle 105, 273, 4, 4, True
055page.Rectangle 190, 273, 4, 4, True
056
057'Выводим постоянный и переменный текст
058Q = font.WriteText ("Межрегиональная олимпиада школьников", 12, 20, 178, 2)
059Q = bigFont.WriteText (OlympName, 12, 45, 178, 2)
060Q = bigFont.WriteText (OlympClass, 12, 56, 178, 2)
061
062Q = font.WriteText ("Титульный лист", 12, 72, 178, 2)
063
064labelFont.WriteLine "Фамилия", 25, 115 - 23
065labelFont.WriteLine "Имя", 25, 123 - 23
066labelFont.WriteLine "Отчество", 25, 131 - 23
067labelFont.WriteLine "Дата", 25, 139 - 23
068labelFont.WriteLine "рождения", 25, 145 - 23
069
070labelFont.WriteLine "Регистрационный номер", 25, 169 - 30
071labelFont.WriteLine "Город проведения", 25, 177 - 30
072labelFont.WriteLine "Аудитория", 25, 185 - 30
073
074
075labelFont.WriteLine "Дата", 25, 211
076labelFont.WriteLine "Подпись", 25, 219
077labelFont.WriteLine "Телефон", 25, 227
078
079
080dataFont.WriteLine LastName, 63, 114 - 23
081dataFont.WriteLine FirstName, 63, 122 - 23
082dataFont.WriteLine MiddleName, 63, 130 - 23
083dataFont.WriteLine BirthDate, 63, 141 - 23
084
085dataFont.WriteLine RegNo, 100, 168 - 30
086dataFont.WriteLine OlympCity, 100, 176 - 30
087
088' Рисуем линии
089page.line 100, 192 - 30, 150, 192 - 30
090page.line 58, 218, 108, 218
091page.line 58, 226, 108, 226
092Q = dataFont.WriteText(Phone, 58, 226, 65, 0)
093
094
095
096' Устанавливаем новый цвет
097page.setColor 192, 192, 192
098
099S = "шифр"
100font.MeasureLine S, W, H  ' измеряем текстовый блок
101Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2) ' располагаем текстовый
102блок на странице
103
104' Устанавливаем новый цвет
105page.setColor 255, 0, 0
106' Устанавливаем толщину линий в 1 пиксель
107page.LineWidth = 0
108' Рисуем линии по координатам
109X = 139
110Y = 267
111
112page.line X, Y - 3, X, Y + 3
113page.line X - 3, Y, X + 3, Y
114
115X = X + 40
116page.line X, Y - 3, X, Y + 3
117page.line X - 3, Y, X + 3, Y
118
119
120Y = Y - 23
121page.line X, Y - 3, X, Y + 3
122page.line X - 3, Y, X + 3, Y
123
124X = X - 40
125page.line X, Y - 3, X, Y + 3
page.line X - 3, Y, X + 3, Y

Результат:


Справочник по интерфейсам

(раздел целиком) (одним файлом)
Справочник по интерфейсам
  • Перечисление TPDFFontRenderingMode
  • Перечисление TPDFLineCap
  • Перечисление TPDFLineJoin
  • Перечисление TPDFTextAlignment
  • Интерфейс IPDFDocument
  • Интерфейс IPDFFont
  • Интерфейс IPDFPage


Перечисление TPDFFontRenderingMode

(одним файлом)
Перечисление TPDFFontRenderingMode
1type
2  TPDFFontRenderingMode = (frmFillText, frmStrokeText, frmFillThenStrokeText,
3    frmInvisible);

Или

1type
2  TPDFFontRenderingMode = TOleEnum;
3const
4  frmFillText = $00000000;
5  frmStrokeText = $00000001;
6  frmFillThenStrokeText = $00000002;
7  frmInvisible = $00000003;

Элементы перечисления:

Имя | Значение | Назначение
frmFillText | 0 |
frmStrokeText | 1 |
frmFillThenStrokeText | 2 |
frmInvisible | 3 |


Перечисление TPDFLineCap

(одним файлом)
Перечисление TPDFLineCap
1type
2  TPDFLineCap = (lcBuss, lcRound, lcProtecting);

Или

1type
2  TPDFLineCap = TOleEnum;
3const
4  lcBuss = $00000000;
5  lcRound = $00000001;
6  lcProtecting = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
lcBuss | 0 |
lcRound | 1 |
lcProtecting | 2 |


Перечисление TPDFLineJoin

(одним файлом)
Перечисление TPDFLineJoin
1type
2  TPDFLineJoin = (ljMiter, ljRound, ljBevel);

Или

1type
2  TPDFLineJoin = TOleEnum;
3const
4  ljMiter = $00000000;
5  ljRound = $00000001;
6  ljBevel = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
ljMiter | 0 |
ljRound | 1 |
ljBevel | 2 |


Перечисление TPDFTextAlignment

(одним файлом)
Перечисление TPDFTextAlignment
1type
2  TPDFTextAlignment = (ptaLeft, ptaRight, ptaCenter, ptaJustified);

Или

1type
2  TPDFTextAlignment = TOleEnum;
3const
4  ptaLeft = $00000000;
5  ptaRight = $00000001;
6  ptaCenter = $00000002;
7  ptaJustified = $00000003;

Элементы перечисления:

Имя | Значение | Назначение
ptaLeft | 0 |
ptaRight | 1 |
ptaCenter | 2 |
ptaJustified | 3 |


Интерфейс IPDFDocument

(раздел целиком) (одним файлом)
Интерфейс IPDFDocument

01type
02  IPDFDocument = interface(IDispatch)
03    ['{E57FFE9D-6B85-45E6-A5D0-9DD17950A666}']
04    procedure Save(Target: OleVariant); safecall;
05    function CreatePage(Parent: OleVariant): IPDFPage; safecall;
06    function Get_Title: WideString; safecall;
07    procedure Set_Title(Value: WideString); safecall;
08    function Get_CanEmbedFonts: WordBool; safecall;
09    procedure Set_CanEmbedFonts(Value: WordBool); safecall;
10    function Get_CanCompress: WordBool; safecall;
11    procedure Set_CanCompress(Value: WordBool); safecall;
12    function Get_Author: WideString; safecall;
13    procedure Set_Author(Value: WideString); safecall;
14    function Get_Subject: WideString; safecall;
15    procedure Set_Subject(Value: WideString); safecall;
16    function Get_Keywords: WideString; safecall;
17    procedure Set_Keywords(Value: WideString); safecall;
18    function Get_Creator: WideString; safecall;
19    procedure Set_Creator(Value: WideString); safecall;
20    function Get_Pages(Index: Integer): IPDFPage; safecall;
21    function Get_PageCount: Integer; safecall;
22    procedure Close; safecall;
23    procedure Serialize(const Stream: IUnknown); safecall;
24    function Get_MinCompressSize: Integer; safecall;
25    procedure Set_MinCompressSize(Value: Integer); safecall;
26    function Get_MaxCompressSize: Integer; safecall;
27    procedure Set_MaxCompressSize(Value: Integer); safecall;
28    function CreatePageFromImage(Image: OleVariant; PageWidth: Double;
29      PageHeight: Double; Margin: Double): WordBool; safecall;
30    procedure SaveToXML(Target: OleVariant); safecall;
31    property Title: WideString read Get_Title write Set_Title;
32    property CanEmbedFonts: WordBool read Get_CanEmbedFonts write Set_CanEmbedFonts;
33    property CanCompress: WordBool read Get_CanCompress write Set_CanCompress;
34    property Author: WideString read Get_Author write Set_Author;
35    property Subject: WideString read Get_Subject write Set_Subject;
36    property Keywords: WideString read Get_Keywords write Set_Keywords;
37    property Creator: WideString read Get_Creator write Set_Creator;
38    property Pages[Index: Integer]: IPDFPage read Get_Pages;
39    property PageCount: Integer read Get_PageCount;
40    property MinCompressSize: Integer read Get_MinCompressSize
41      write Set_MinCompressSize;
42    property MaxCompressSize: Integer read Get_MaxCompressSize
43      write Set_MaxCompressSize;
44  end;
  • Свойства
  • Метод Close
  • Метод CreatePage
  • Метод CreatePageFromImage
  • Метод Save
  • Метод SaveToXML
  • Метод Serialize


Свойства

(одним файлом)
Свойства

Свойства интерфейса IPDFDocument:

Имя | Тип | Доступ | Назначение
Author | WideString | Чтение/Запись |
CanCompress | WordBool | Чтение/Запись |
CanEmbedFonts | WordBool | Чтение/Запись |
Creator | WideString | Чтение/Запись |
Keywords | WideString | Чтение/Запись |
MaxCompressSize | Integer | Чтение/Запись |
MinCompressSize | Integer | Чтение/Запись |
PageCount | Integer | Только для чтения |
Pages[Index: Integer] | IPDFPage | Только для чтения |
Subject | WideString | Чтение/Запись |
Title | WideString | Чтение/Запись |

См. также
  • Интерфейс IPDFPage


Метод Close

(одним файлом)
Метод Close

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Close;

Метод не имеет параметров.


Метод CreatePage

(одним файлом)
Метод CreatePage

Метод интерфейса IPDFDocument.

function IPDFDocument.CreatePage(Parent: OleVariant): IPDFPage;

Параметры:

Имя | Тип | Обязательно | Значение
Parent | OleVariant | Да |

Замечания:

Возвращает значение типа IPDFPage.

См. также
  • Интерфейс IPDFPage


Метод CreatePageFromImage

(одним файлом)
Метод CreatePageFromImage

Метод интерфейса IPDFDocument.

1function IPDFDocument.CreatePageFromImage(Image: OleVariant; PageWidth: Double;
2  PageHeight: Double; Margin: Double): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Image | OleVariant | Да |
PageWidth | Double | Да |
PageHeight | Double | Да |
Margin | Double | Да |

Замечания:

Возвращает значение типа WordBool.


Метод Save

(одним файлом)
Метод Save

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Save(Target: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Target | OleVariant | Да |


Метод SaveToXML

(одним файлом)
Метод SaveToXML

Метод интерфейса IPDFDocument.

procedure IPDFDocument.SaveToXML(Target: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Target | OleVariant | Да |


Метод Serialize

(одним файлом)
Метод Serialize

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Serialize(const Stream: IUnknown);

Параметры:

Имя | Тип | Обязательно | Значение
Stream | IUnknown | Да |


Интерфейс IPDFFont

(раздел целиком) (одним файлом)
Интерфейс IPDFFont

01type
02  IPDFFont = interface(IDispatch)
03    ['{43FE399A-A724-4076-BAFA-098639628385}']
04    function Get_Spacing: Double; safecall;
05    procedure Set_Spacing(Value: Double); safecall;
06    function Get_WordSpacing: Double; safecall;
07    procedure Set_WordSpacing(Value: Double); safecall;
08    function Get_Scaling: Double; safecall;
09    procedure Set_Scaling(Value: Double); safecall;
10    function Get_RenderingMode: TPDFFontRenderingMode; safecall;
11    procedure Set_RenderingMode(Value: TPDFFontRenderingMode); safecall;
12    function Get_Rise: Double; safecall;
13    procedure Set_Rise(Value: Double); safecall;
14    procedure WriteLine(const LineText: WideString; X: Double; Y: Double); safecall;
15    procedure MeasureLine(const LineText: WideString; out Width: OleVariant;
16      out Height: OleVariant); safecall;
17    function WriteText(const AText: WideString; X: Double; Y: Double;
18      Width: Double; Alignment: TPDFTextAlignment): Double; safecall;
19    function MeasureText(const AText: WideString; Width: Double): Double; safecall;
20    function Get_Angle: Double; safecall;
21    procedure Set_Angle(Value: Double); safecall;
22    function Get_LineSpacing: Double; safecall;
23    procedure Set_LineSpacing(Value: Double); safecall;
24    property Spacing: Double read Get_Spacing write Set_Spacing;
25    property WordSpacing: Double read Get_WordSpacing write Set_WordSpacing;
26    property Scaling: Double read Get_Scaling write Set_Scaling;
27    property RenderingMode: TPDFFontRenderingMode read Get_RenderingMode
28      write Set_RenderingMode;
29    property Rise: Double read Get_Rise write Set_Rise;
30    property Angle: Double read Get_Angle write Set_Angle;
31    property LineSpacing: Double read Get_LineSpacing write Set_LineSpacing;
32  end;
  • Свойства
  • Метод MeasureLine
  • Метод MeasureText
  • Метод WriteLine
  • Метод WriteText


Свойства

(одним файлом)
Свойства

Свойства интерфейса IPDFFont:

Имя | Тип | Доступ | Назначение
Angle | Double | Чтение/Запись |
LineSpacing | Double | Чтение/Запись |
RenderingMode | TPDFFontRenderingMode | Чтение/Запись |
Rise | Double | Чтение/Запись |
Scaling | Double | Чтение/Запись |
Spacing | Double | Чтение/Запись |
WordSpacing | Double | Чтение/Запись |

См. также
  • Перечисление TPDFFontRenderingMode


Метод MeasureLine

(одним файлом)
Метод MeasureLine

Метод интерфейса IPDFFont.

1procedure IPDFFont.MeasureLine(const LineText: WideString;
2  out Width: OleVariant; out Height: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
LineText | WideString | Да |
Width | OleVariant | Да |
Height | OleVariant | Да |


Метод MeasureText

(одним файлом)
Метод MeasureText

Метод интерфейса IPDFFont.

function IPDFFont.MeasureText(const AText: WideString; Width: Double): Double;

Параметры:

Имя | Тип | Обязательно | Значение
AText | WideString | Да |
Width | Double | Да |

Замечания:

Возвращает значение типа Double.


Метод WriteLine

(одним файлом)
Метод WriteLine

Метод интерфейса IPDFFont.

procedure IPDFFont.WriteLine(const LineText: WideString; X: Double; Y: Double);

Параметры:

Имя | Тип | Обязательно | Значение
LineText | WideString | Да |
X | Double | Да |
Y | Double | Да |


Метод WriteText

(одним файлом)
Метод WriteText

Метод интерфейса IPDFFont.

1function IPDFFont.WriteText(const AText: WideString; X: Double; Y: Double;
2  Width: Double; Alignment: TPDFTextAlignment): Double;

Параметры:

Имя | Тип | Обязательно | Значение
AText | WideString | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Alignment | TPDFTextAlignment | Да |

Замечания:

Возвращает значение типа Double.

См. также
  • Перечисление TPDFTextAlignment


Интерфейс IPDFPage

(раздел целиком) (одним файлом)
Интерфейс IPDFPage

01type
02  IPDFPage = interface(IDispatch)
03    ['{749FB131-80FE-46E9-8330-22C1DC346FE7}']
04    function Get_Parent: IPDFPage; safecall;
05    function Get_Title: WideString; safecall;
06    procedure Set_Title(Value: WideString); safecall;
07    function Get_Width: Double; safecall;
08    procedure Set_Width(Value: Double); safecall;
09    function Get_Height: Double; safecall;
10    procedure Set_Height(Value: Double); safecall;
11    function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool;
12      Italic: WordBool): IPDFFont; safecall;
13    procedure Perform(const Command: WideString); safecall;
14    function Get_LineWidth: Double; safecall;
15    procedure Set_LineWidth(Value: Double); safecall;
16    procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double); safecall;
17    procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double;
18      Fill: WordBool); safecall;
19    function Get_LineCap: TPDFLineCap; safecall;
20    procedure Set_LineCap(Value: TPDFLineCap); safecall;
21    function Get_LineJoin: TPDFLineJoin; safecall;
22    procedure Set_LineJoin(Value: TPDFLineJoin); safecall;
23    procedure SetDash(DashArray: OleVariant; Phase: Integer); safecall;
24    procedure SetColor(R: Integer; G: Integer; B: Integer); safecall;
25    procedure PerformColor(const Command: WideString); safecall;
26    procedure Poly(Points: OleVariant; Fill: WordBool); safecall;
27    procedure Image(Image: OleVariant; X: Double; Y: Double; Width: Double;
28      Height: Double; Transparent: WordBool); safecall;
29    procedure DrawGrid; safecall;
30    procedure Arc(X: Double; Y: Double; Radius: Double; StartAngle: Double;
31      EndAngle: Double; FillSegment: WordBool; FillSector: WordBool); safecall;
32    procedure Curve(Points: OleVariant; Fill: WordBool); safecall;
33    procedure HyperLink(const URI: WideString; X: Double; Y: Double; Width: Double;
34      Height: Double); safecall;
35    procedure Pattern(X1: Double; Y1: Double; Width: Double; Height: Double;
36      PatternPointSize: Double; Percentage: Integer); safecall;
37    procedure Bezier(Points: OleVariant; Fill: WordBool); safecall;
38    procedure XObject(Data: OleVariant); safecall;
39    procedure SetColorCMYK(C: Double; M: Double; Y: Double; K: Double); safecall;
40    procedure LocalLink(const Page: IDispatch; DestinationX: Double;
41      DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
42      X: Double; Y: Double; Width: Double; Height: Double); safecall;
43    property Parent: IPDFPage read Get_Parent;
44    property Title: WideString read Get_Title write Set_Title;
45    property Width: Double read Get_Width write Set_Width;
46    property Height: Double read Get_Height write Set_Height;
47    property LineWidth: Double read Get_LineWidth write Set_LineWidth;
48    property LineCap: TPDFLineCap read Get_LineCap write Set_LineCap;
49    property LineJoin: TPDFLineJoin read Get_LineJoin write Set_LineJoin;
50  end;
  • Свойства
  • Метод Arc
  • Метод Bezier
  • Метод CreateFont
  • Метод Curve
  • Метод DrawGrid
  • Метод HyperLink
  • Метод Image
  • Метод Line
  • Метод LocalLink
  • Метод Pattern
  • Метод Perform
  • Метод PerformColor
  • Метод Poly
  • Метод Rectangle
  • Метод SetColor
  • Метод SetColorCMYK
  • Метод SetDash
  • Метод XObject


Свойства

(одним файлом)
Свойства

Свойства интерфейса IPDFPage:

Имя | Тип | Доступ | Назначение
Height | Double | Чтение/Запись |
LineCap | TPDFLineCap | Чтение/Запись |
LineJoin | TPDFLineJoin | Чтение/Запись |
LineWidth | Double | Чтение/Запись |
Parent | IPDFPage | Только для чтения |
Title | WideString | Чтение/Запись |
Width | Double | Чтение/Запись |

См. также
  • Перечисление TPDFLineCap
  • Перечисление TPDFLineJoin


Метод Arc

(одним файлом)
Метод Arc

Метод интерфейса IPDFPage.

1procedure IPDFPage.Arc(X: Double; Y: Double; Radius: Double;
2  StartAngle: Double; EndAngle: Double; FillSegment: WordBool;
3  FillSector: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
X | Double | Да |
Y | Double | Да |
Radius | Double | Да |
StartAngle | Double | Да |
EndAngle | Double | Да |
FillSegment | WordBool | Да |
FillSector | WordBool | Да |


Метод Bezier

(одним файлом)
Метод Bezier

Метод интерфейса IPDFPage.

procedure IPDFPage.Bezier(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |


Метод CreateFont

(одним файлом)
Метод CreateFont

Метод интерфейса IPDFPage.

1function IPDFPage.CreateFont(const FontName: WideString; Size: Double;
2  Bold: WordBool; Italic: WordBool): IPDFFont;

Параметры:

Имя | Тип | Обязательно | Значение
FontName | WideString | Да |
Size | Double | Да |
Bold | WordBool | Да |
Italic | WordBool | Да |

Замечания:

Возвращает значение типа IPDFFont.

См. также
  • Интерфейс IPDFFont


Метод Curve

(одним файлом)
Метод Curve

Метод интерфейса IPDFPage.

procedure IPDFPage.Curve(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |


Метод DrawGrid

(одним файлом)
Метод DrawGrid

Метод интерфейса IPDFPage.

procedure IPDFPage.DrawGrid;

Метод не имеет параметров.


Метод HyperLink

(одним файлом)
Метод HyperLink

Метод интерфейса IPDFPage.

1procedure IPDFPage.HyperLink(const URI: WideString; X: Double; Y: Double;
2  Width: Double; Height: Double);

Параметры:

Имя | Тип | Обязательно | Значение
URI | WideString | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |


Метод Image

(одним файлом)
Метод Image

Метод интерфейса IPDFPage.

1procedure IPDFPage.Image(Image: OleVariant; X: Double; Y: Double;
2  Width: Double; Height: Double; Transparent: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Image | OleVariant | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |
Transparent | WordBool | Нет |


Метод Line

(одним файлом)
Метод Line

Метод интерфейса IPDFPage.

procedure IPDFPage.Line(X1: Double; Y1: Double; X2: Double; Y2: Double);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
X2 | Double | Да |
Y2 | Double | Да |


Метод LocalLink

(одним файлом)
Метод LocalLink

Метод интерфейса IPDFPage.

1procedure IPDFPage.LocalLink(const Page: IDispatch; DestinationX: Double;
2  DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
3  X: Double; Y: Double; Width: Double; Height: Double);

Параметры:

Имя | Тип | Обязательно | Значение
Page | IDispatch | Да |
DestinationX | Double | Да |
DestinationY | Double | Да |
DestinationWidth | Double | Да |
DestinationHeight | Double | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |


Метод Pattern

(одним файлом)
Метод Pattern

Метод интерфейса IPDFPage.

1procedure IPDFPage.Pattern(X1: Double; Y1: Double; Width: Double;
2  Height: Double; PatternPointSize: Double; Percentage: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
Width | Double | Да |
Height | Double | Да |
PatternPointSize | Double | Да |
Percentage | Integer | Да |


Метод Perform

(одним файлом)
Метод Perform

Метод интерфейса IPDFPage.

procedure IPDFPage.Perform(const Command: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Command | WideString | Да |


Метод PerformColor

(одним файлом)
Метод PerformColor

Метод интерфейса IPDFPage.

procedure IPDFPage.PerformColor(const Command: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Command | WideString | Да |


Метод Poly

(одним файлом)
Метод Poly

Метод интерфейса IPDFPage.

procedure IPDFPage.Poly(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |


Метод Rectangle

(одним файлом)
Метод Rectangle

Метод интерфейса IPDFPage.

1procedure IPDFPage.Rectangle(X1: Double; Y1: Double; Width: Double;
2  Height: Double; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
Width | Double | Да |
Height | Double | Да |
Fill | WordBool | Да |


Метод SetColor

(одним файлом)
Метод SetColor

Метод интерфейса IPDFPage.

procedure IPDFPage.SetColor(R: Integer; G: Integer; B: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
R | Integer | Да |
G | Integer | Да |
B | Integer | Да |


Метод SetColorCMYK

(одним файлом)
Метод SetColorCMYK

Метод интерфейса IPDFPage.

procedure IPDFPage.SetColorCMYK(C: Double; M: Double; Y: Double; K: Double);

Параметры:

Имя | Тип | Обязательно | Значение
C | Double | Да |
M | Double | Да |
Y | Double | Да |
K | Double | Да |


Метод SetDash

(одним файлом)
Метод SetDash

Метод интерфейса IPDFPage.

procedure IPDFPage.SetDash(DashArray: OleVariant; Phase: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
DashArray | OleVariant | Да |
Phase | Integer | Да |


Метод XObject

(одним файлом)
Метод XObject

Метод интерфейса IPDFPage.

procedure IPDFPage.XObject(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |


Поставка решений

(одним файлом)
Поставка решений

Этот раздел еще предстоит написать.


Интеграция

(раздел целиком) (одним файлом)
Интеграция

Интеграция - комплекс работ по настройке механизмов взаимодействия между различными учетными системами, которые функционируют независимо друг от друга в одной организационной структуре ("лоскутная" автоматизация).

Концептуально реализация интеграции может быть осуществлена двумя способами (рассмотрены более подробно далее):

  • Интеграция на базе интеграционной платформы (некоего ядра, которое осуществляет взаимодействие между учетными системами)
  • Интеграция без внедрения интеграционной платформы, с использованием связей между учетными системами только там где это необходимо.

Практически, реализация интеграции может быть осуществлена слежующими способами:

  • Интеграция данных
  • Интеграция функций


Интеграция данных

(раздел целиком) (одним файлом)
Интеграция данных

В свою очередь интеграцию данных можно разделить на два типа:

  • Репликативная интеграция
  • On-Line доступ


Репликативная интеграция

(одним файлом)
Репликативная интеграция

Репликативная интеграция - передающая сторона формирует реплику, передает ее принимающей стороне, которая в свою очередь загружает в себя реплику. В этом случае стандартами формата реплики являются двоичный формат и XML-схема. Платформа Мельница Данных имеет готовые механизмы для реализации обоих форматов.

Варианты реализации репликационной интеграции:

1. Данные должны быть переданы из сторонней учетной системы и загружены в Платформу Мельница данных:

В Платформе уже реализованы механизмы загрузки реплик в двоичном (бинарном) формате, а также в формате XML-схемы. В случае, если разработчики или сопровождающие сотрудники сторонней учетной системы имеют возможность выгрузки реплики в данных форматах, взаимодействие производится стандартными средствами Платформы. В противном случае создается конвертер для перевода данных реплики в один из стандартных форматов для дальнейшей загрузки реплики в Мельницу Данных.

2. Данные должны быть переданы из Платформы Мельница Данных и загружены в стороннюю учетную систему:

При необходимости выгрузки данных из Платформы Мельница Данных используются стандартные механизмы выгрузки реплики в двоичном (бинарном) формате или в формате XML-схемы. В случае, если эти варианты не являются приемлемыми для принимающей стороны (сторонней учетной системы), можно выполнить выгрузку данных через скриптлет, Microsoft Excel-файл, отчет или любыми механизмами просто выгрузить требуемый файл для дальнейшей обработки (загрузки) принимающей стороной. В этом случае необходимо четкое согласование протоколов и форматов обмена данными.

3. Данные должны быть переданы из одной сторонней учетной системы в другую. При этом Платформа Мельница Данных выступает в качестве интеграционной платформы:

МД - интеграционное ядро

Если Платформа выступает в качестве интеграционного ядра, в ней необходимо объявить структуры для хранения тех элементов данных, которые в Платформе по умолчанию не хранятся, но загружаются в нее из сторонних учетных систем и в дальнейшем подлежат какому-либо анализу. При этом нет необходимости обеспечивать функционирование бизнес-процессов над этими данными в рамках Платформы, данные просто хранятся.

Подобная интеграция осуществляется простыми готовыми средствами платформы в самые сжатые сроки.


On-Line доступ

(одним файлом)
On-Line доступ

Второй путь интеграции данных - Интеграция с использованием доступа к данным в режиме On-Line.

1. В том случае когда Платформа является серверной стороной, то есть стороной-поставщиком данных для других систем, возможны следующие варианты предоставления данных:

- СУБД, то есть база данных, которая хранит все данные Платформы. На данный момент поддерживаются Oracle, Firebird, MS SQL. Возможна реализация поддержки и других систем управления базами данных. Для указанных баз данных доступны стандартные протоколы доступа, с помощью которых осуществляются запросы к данным Платформы непосредственно. Запросы формируются при помощи стандартизированного языка запросов Structured Query Language (SQL).

- RESTful-сервис используется для реализации более сложной механики предоставления доступа к данным и входит в состав поставки сервера приложений Платформы. С его помощью, в частности, осуществляется удаленный доступ и доступ к данным через SOAP (Simple Object Access Protocol — простой протокол доступа к объектам) с автоматическим формированием по данным Платформы WSDL-документа, описывающего сервисы. Таким образом реализуется продвинутый функционал по отбору объекта по критериям, а также в части доступа ко всем данным Платформы по протоколу SOAP/

В случае если требуются какие-либо специфические протоколы для обмена данными, они реализовываются на уровне обработчика сервера-приложения. То есть осуществляется "надстройка" сервера приложений Платформы для работы с данными в том виде, в котором это необходимо и по тому протоколу, который требуется в каждом конкретном случае. Таким образом, Сервер приложений Платформы востребован в большинстве случаев организации взаимодействия между системами.

Практический пример реализации:

Компания "Мельница технологий" в одном из московских ВУЗов осуществяла интеграцию с тестирующей системой по проведению олимпиад. С использованием протокола SOAP в тестирующую систему из Платформы предоставлялась информация о реквизитах олимпиад, которые были выбраны каждым школьником-участником. Был реализован обработчик-"переходник", через который передавалсь информация.

Для системы LMS (Learning Management System) компании Asteros данные также предоставляются по протоколу SOAP.

2. В случае когда Платформе необходим доступ к данным сторонних систем, используется готовый RESTful-"обработчик". Частными случаями данной ситуции являются взаимодействия Платформы с различными собственными web-приложениями, а также с "Обозревателем данных", работающим через удаленный доступ.

Для получения данных в режиме On-Line от сторонних систем используются те же стандартные протоколы. При необходимости создаются "обработчики", которые отображают для конечного пользователя в визуальных формах Платформы данные, полученные из сторонних систем.

3. При использовании Платформы в качестве платформы интеграции различных сторонних систем, данные предварительно загруженные по описанным выше протоколам могут передаваться средствами Платформы. Однако, может быть реализован и механизм прозрачной передачи данных между сторонними системами.


Интеграция функций

(раздел целиком) (одним файлом)
Интеграция функций
Данный тип развития интеграции в свою очередь можно разделить на 2 пути:
  • Взаимные вызовы
  • Встраивание


Взаимные вызовы

(одним файлом)
Взаимные вызовы

В данном случае подразумевается, что какая-либо учетная система открывает возможность вызова своих встроенных функций из сторонних систем.

Доступ к функциям возможен с помощью выполнения хранимых процедур (каждое бизнес-действие, которое производит пользователь, обязательно оформляется в виде хранимой процедуры на уровне СУБД Платформы). Процедуру можно вызывать, получив доступ к СУБД. Аналогично тому, как создаются select-запросы, запросы к данным, можно делать запросы, вызывающие бизнес-функции. Все методы, отчеты, и все, что доступно пользователю, может быть вызвано и через RESTful-сервис. При этом методы будут выполняться, отчеты будут формироваться в виде Excel, Word, PDF, HTML, в соответствии с запросом вызывающей стороны. Данный функционал обеспечивается готовым "обработчиком", входящим в состав поставки Платформы.

С помощью протокола SOAP можно вызывать любой метод любого объекта, получать результаты его выполнения без ограничений.

В случае когда необходимо в Платформе использовать чужие функции, набор действий по вызову такой функции оформляется в виде скриптлета.

Пример реализации:

В ВУЗе при формировании приказа о зачислении студента в Платформе, также автоматически создается объект "Приказ" в системе документооборота ВУЗа. В дальнейшем, передвижение приказа по маршруту согласования в решении на Платформе аналогично отображается в системе документооборота.

Если для сторонней системы существуют какие-либо стандартные протоколы, по которым можно вызывать функцию, то средствами Платформы не составляет труда вызов данной функции.


Встраивание

(одним файлом)
Встраивание

Данный путь интеграции функций представляет собой ситуацию, когда сторонняя система непосредственно "встраивается" в решения на Платформе и код сторонней системы исполняется с использованием данных Платформы.

Существуют разные способы реализации данного пути:

- В open-source системах, как правило, слой доступа к данным вынесен в некий отдельный модуль. Характерный пример - это LMS eFront. Это Open-Source разработка, содержащая в себе большой объем php-кода, с развитым web-интерфейсом, и, в том числе, содержащая модуль доступа к данным. В процессе работы создается база MySQL база достаточно примитивной структуры. В этом случае можно изменить модуль доступа, так, чтобы вместо запросов к MySQL-базе механика делала бы запросы к базе данных Платформы. Тогда исполнение php-кода, его интерпретация происходит в рамках сервера приложений Платформы.

Пример реализации:

Так как в базе данных Платформы уже хранятся данные о студентах, преподавателях, курсах и т.д., то при взаимодействии с системой обучения LMS, естественным, удобным и надежным решением является хранение все этих данных в одной базе данных

- В тех случаях, когда решения Платформы сами являются частью какой-либо более общей системы, и должны предоставлять свои функции, то это решается на уровне СУБД. То есть, сгенерированный Платформой прикладной код (код на соответствующем диалекте SQL) может быть интегрирован в код более масштабного хранилища, функционировать там, исполняться там, если в этом есть необходимость.

Прикладные системы на базе СУБД Teradata позволяют использовать PL/SQL-код для каких-либо наборов данных, притом, что сама база гораздо имеет продвинутые возможности автоматического контроля версий, хроникальности, аналитики.


Положения и определения

(раздел целиком) (одним файлом)
Положения и определения
  • Работа с типами данных
  • Язык PascalScript
  • Интерфейсы взаимодействия с внешними подсистемами
  • Справочник по метаданным
  • Терминология


Работа с типами данных

(раздел целиком) (одним файлом)
Работа с типами данных
  • Домены


Домены

(одним файлом)
Домены

Этот раздел еще предстоит написать.


Язык PascalScript

(раздел целиком) (одним файлом)
Язык PascalScript

На языке PascalScript на платформе "Мельница данных" описываются тела методов и выражения. Выражения используются в условиях отбора объектов определенного класса при их отображении в представлениях, а также как встраиваемые выражения, которые могут служить членами класса для чтения свойств.

Здесь и далее зарезервированные слова выделены жирным шрифтом.

  • Структура программного блока тела метода
  • Описание переменных
  • Операторы PascalScript
  • Выражения и операции
  • Формальная грамматика
  • Соглашения


Структура программного блока тела метода

(одним файлом)
Структура программного блока тела метода
1  [Описание переменных]
2  begin
3    //Операторы
  end;

Комментарии расположены между символами { и } либо от символов // до конца строки.


Описание переменных

(одним файлом)
Описание переменных
1 var
2    Имя переменной[, Имя переменной…]: Тип;
3    Имя переменной[, Имя переменной…]: Тип;
4    ...
Имя переменной должно быть идентификатором (последовательность символов a-z, A-Z, 0-9, _). "Тип" может быть одним из следующих:
  • integer - определяет переменные целочисленного типа;
  • string[целое_число] - определяет переменные строкового типа с заданной максимальной длиной; максимальная длина задается в квадратных скобках и обязательна для задания;
  • float - определяет переменные вещественного типа;
  • date - определяет переменные типа "дата";
  • time - определяет переменные типа "время";
  • datetime - определяет переменные типа "дата со временем";
  • boolean - определяет переменные логического типа;
  • blob - определяет переменные типа больших двоичных объектов;
  • Имя класса - определяет переменные-ссылки на экземпляры соответствующих классов;
1  var
2   I: integer;
3   LSomeObject: TObject;
4   LStart, LStop: datetime;
   LNewName: string[64];


Операторы PascalScript

(раздел целиком) (одним файлом)
Операторы PascalScript

Операторы разделяются точкой с запятой (;). Операторы могут быть одним из следующих:

  • Составной оператор
  • Оператор присваивания
  • Оператор вызова
  • Оператор ветвления
  • Оператор выбора
  • Цикл с предусловием
  • Цикл с постусловием
  • Цикл с параметром
  • Цикл по экземплярам
  • Оператор прекращения цикла
  • Оператор выхода из подпрограммы
  • Оператор защиты завершения
  • Оператор обработки исключительных ситуаций
  • Оператор возбуждения исключения
  • Оператор унаследованного вызова


Составной оператор

(одним файлом)
Составной оператор
1 begin
2  //Другие операторы
end
Операторы, размещенные внутри составного оператора, разделяются точкой с запятой. Никаких ограничений на состав операторов и количество уровней вложенности не накладывается.
1begin
2  Result := LCurrentValue;
3  Exit;
4end;


Оператор присваивания

(одним файлом)
Оператор присваивания
Выражение1 := Выражение2

Присваивает значение выражения Выражение2 выражению Выражение1. Типы Выражения1 и Выражения2 должны быть совместимы (совпадать по классу домена либо оба быть числовыми). Для этого на Выражение1 (стоящее слева от знака равенства, lvalue) накладывается ряд ограничений. Это выражение должно быть:

  • Полем или свойством экземпляра класса
  • Локальной переменной
  • Параметром
  • Зарезервированной переменной Result
LObject.Name := 'Новое имя';
Result := 25;
LStartTime := StrToDateTime('01.01.2006 00:00:30');
01var
02  LObject: TObject;
03  LClass: TClass;
04  I: Integer;
05  F: Float;
06begin
07  I := F;  //неверно
08  F := I;  //верно
09  LObject := LClass; //верно
10  LClass := LObject; //неверно. Должно быть LClass := (LObject as TClass);
11end;


Оператор вызова

(одним файлом)
Оператор вызова
ИмяПроцедуры [(Параметр1, Параметр2 ...)]

"ИмяПроцедуры" должно быть:

  • Именем метода класса и вызываться с указанием класса либо экземпляра;
  • Именем метода экземпляра и вызываться с указанием экземпляра;
  • Именем метода своего класса либо предка и вызываться без указания спецификаторов.
Порядок и количество параметров в операторе вызова должны строго совпадать с описанием метода.

1  //метод класса, указан класс
2  LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3
4  //метод экземпляра, указан экземпляр. Метод не имеет параметров.
5  LList.Destroy;
6
7  //свой либо унаследованный метод
8  BuildDefaultActions(Name, True);


Оператор ветвления

(одним файлом)
Оператор ветвления
1 if Выражение then
2  //Оператор1
3[else
4  //Оператор2]

Выражение должно быть логического типа. В случае если значение Выражения истинно, выполняется Оператор1. Часть else является необязательной и относится к последнему оператору if, не имеющему таковой. В случае ее наличия Оператор2 выполняется, если значение Выражения ложно.

1if LIndex > 25 then
2  raise 'Индекс слишком большой.';

1if LMonth = 'январь' then
2  January
3else if LMonth = 'февраль' then
4  February
5else
6  OtherMonth;  //обратите внимание на точки с запятой.


Оператор выбора

(одним файлом)
Оператор выбора
1 case Выражение of
2  Значение1: //Оператор1
3  Значение2: //Оператор2
4  ...
5[else
6  //Оператор ]
end

Заменяет каскад операторов if. Значение Выражения должно быть числового типа. Часть else выполняется в случае, если Выражение не равно ни одному из перечисленных вариантов. Эта часть не является обязательной.

1сase LIndex of
2  0: ZeroIndex;
3  1,2,3: SmallIndex;
4  4,5,6,7,8,9,10: BigIndex;
5else
6  raise 'Слишком большой или отрицательный индекс.';
7end;


Цикл с предусловием

(одним файлом)
Цикл с предусловием
1 while Выражение do
2  //Оператор

Оператор выполняется до тех пор, пока значение Выражения истинно. Выражение должно быть логического типа. Если при входе в цикл Выражение не истинно, то тело цикла не будет выполнено ни одного раза.

01while LList.Count > 0 do
02  LList.GetItem(0).Destroy;
03
04while True do
05begin
06  LValue := LValue.NextValue;
07  if LValue.Value > 10 then
08  begin
09    Result := LValue.Value;
10    exit;
11  end;
12end;


Цикл с постусловием

(одним файлом)
Цикл с постусловием
1 repeat
2  //Операторы
3until Выражение

Операторы выполняются до тех пор, пока значение Выражения ложно. Выражение должно быть логического типа. Обратите внимание, что внутри себя оператор может содержать несколько операторов, разделенных точкой с запятой. Тело цикла обязательно будет выполнено хотя бы один раз.

1repeat
2  Result := Result + 1;
3  LObject := LObject.Parent;
4until LObject = nil;


Цикл с параметром

(одним файлом)
Цикл с параметром
1 for Параметр := Выражение1 (to|downto) Выражение2 do
2  //Оператор

Параметр цикла обязан быть простой локальной переменной. Функционально цикл с параметром эквивалентен циклам:

  • Для формы to
    1Параметр := Выражение1;
2while Параметр <= Выражение2 do begin
3  Оператор;
4  Параметр :=  Параметр + 1;
end;
  • Для формы downto
    1Параметр := Выражение1;
2while Параметр >= Выражение2 do begin
3  Оператор;
4  Параметр :=  Параметр - 1;
end;
Если Выражение1 равно Выражению2, тело цикла будет выполнено один раз.

1for I := LList.Length - 1 downto 0 do
2// если LList.Length = 0, тело цикла ни разу не будет выполнено.
3begin
4  LClass := LList.GetItem(I);
5  LMethod := any(TMethod with (Name = LName) and (Master = LClass));
6  LParamList.Add(any(TMethod with (Name = LName) and (Master = LClass)));
7end;


Цикл по экземплярам

(одним файлом)
Цикл по экземплярам
1 for each Параметр of ИмяКласса [with Выражение]
2  [by [-] Выражение [, [-] Выражение]] do
3    //Оператор

Цикл осуществляется по выборке среди экземпляров класса ИмяКласса, для которых истинно Выражение. Если Выражение не задано, то по всем экземплярам. Ссылка на текущий в рамках цикла экземпляр присваивается в локальную переменную Параметр. Выражение должно определяться относительно переменной Параметр. Выраженния, следующие за ключевым словом by, определяют порядок обхода экземпляров. Знак "-" перед выражением (любого типа) определяет обратный порядок обхода.

1for each LOption of TOption with LOption.Domain.Required do
2    // для каждой настройки, домен которой обязателен
3  LOption.SetDefaultValue;


Оператор прекращения цикла

(одним файлом)
Оператор прекращения цикла
break

Происходит немедленный выход из цикла. Выполняется финализация операторов защиты завершения, которыми защищено тело цикла. Допустим только в теле цикла с предусловием, цикла с постусловием, цикла с параметром или цикла по экземплярам.


Оператор выхода из подпрограммы

(одним файлом)
Оператор выхода из подпрограммы
exit

Происходит немедленный выход из программного блока. Выполняется финализация операторов защиты завершения.


Оператор защиты завершения

(одним файлом)
Оператор защиты завершения
1 try
2  //Операторы1
3finally
4  //Операторы2
end

Выполняются операторы Операторы1, разделенные точкой с запятой. В случае возникновения исключительной ситуации управление сразу передается на Операторы2, и после их выполнения исключение остается активным. Если исключения не произошло, выполняются Операторы2. Если среди Операторов1 встречается оператор exit, то Операторы2 все равно выполняются.

1//создание временного объекта-списка
2LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3try
4  LList.Add(LValue);
5  Exit;
6finally
7  //гарантированное уничтожение созданного объекта независимо от исключений.
8  LList.Destroy;
9end;


Оператор обработки исключительных ситуаций

(одним файлом)
Оператор обработки исключительных ситуаций
1 try
2  //Операторы1
3except
4  //Операторы2
end

Выполняются операторы Операторы1. В случае возникновения исключительной ситуации управление передается на Операторы2. Если исключительных ситуаций не возникло, Операторы2 не выполняются никогда. При передаче управления на Операторы2 исключительная ситуация деактивирована. Для ее повторного возбуждения можно воспользоваться оператором возбуждения исключения без указания текстовой строки сообщения.

1try
2  LObject.NeverTouch := True;
3  LObject.ExecuteCoolMethod; //если метод выполнен неудачно
4except
5  LObject.NeverTouch := True;  //установить флаг и ничего не сообщать пользователю.
6end;

1try
2   LObject.ExecuteCoolMethod; //если метод выполнен неудачно
3except
4   LObject.Destroy; //удалить неудачный объект
5   raise;           // продолжить обработку исключения.
6end;


Оператор возбуждения исключения

(одним файлом)
Оператор возбуждения исключения
 raise [Выражение]
Возбуждает исключение, которое, если не было обработано блоком except оператора обработки, дойдет до пользователя. Пользователь увидит сообщение, определяемое Выражением. Выражение должно иметь строковый тип и является обязательным для всех случаев, кроме части except оператора обработки исключений.


Оператор унаследованного вызова

(одним файлом)
Оператор унаследованного вызова
 inherited

Работает только в унаследованном переопределенном методе. Вызывается метод предка с параметрами, заданными в параметрах к моменту вызова. Если программный блок представляет собой тело функции, то в псевдопеременной Result будет результат выполнения метода предка.

1// в теле конструктора
2Name := 'Object name';
3Description := 'Object description';
4inherited; //вызов предка с параметрами Name и Description,
5           //заданными двумя предыдущими операторами. Ссылка на
6           //созданный объект лежит в
7           //псевдопеременной Result
8Result.Name := 'New name';


Выражения и операции

(раздел целиком) (одним файлом)
Выражения и операции
  • Состав выражения
  • Квалификатор
  • Агрегат
  • Операции


Состав выражения

(одним файлом)
Состав выражения
Любое выражение имеет тип. Выражения состоят из следующих элементов:
  • Целая числовая константа (0 3 234);
  • Вещественная числовая константа. Дробная часть отделяется от целой точкой (".") (3.14 2.71);
  • Строковая константа. Заключается в апострофы. ('Some string' '10', '01.01.2006' 'now');
  • Логическая константа (True False);
  • Безтиповая (любого типа) константа nil;
  • Зарезервированное слово Self. Обозначает разный объект в зависимости от контекста:
    • В методах класса кроме конструктора - использование запрещено.
    • В методах экземпляра - всегда экземпляр, для которого вызван метод.
    • В конструкторе - до вызова унаследованного метода значение не определено. После вызова - ссылка на сконструированный объект.
    • В выражениях условий отбора - объект, для которого принимается решение о его вхождении в отбор.
  • Квалификатор.
  • Агрегат.


Квалификатор

(одним файлом)
Квалификатор

Квалификатор обозначает объект, переменную, параметр, свойство, поле, вызов функции. Квалификатор состоит из идентификаторов, разделенных точкой.

Result
AName
Caption
LObject.Name
LObject.Parent.Name
LObject.ChildCount
LObject.HasAsParent(LOtherObject)

При интерпретации квалификатора используется следующий порядок разбора идентификатора:

  1. Контекстная переменная (для выражений условий отбора доменов)
  2. Локальная переменная
  3. Параметр
  4. Имя элемента перечисления
  5. Имя класса. Вне контекста означает ссылку на соответствующий объект класса TClass
  6. Имя поля
  7. Имя метода
  8. Имя свойства

При интерпретации квалификатора внутри выражения агрегата правила разбора идентификатора изменяются:

  1. Контекстная переменная (для выражений условий отбора доменов)
  2. Имя элемента перечисления
  3. Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту
  4. Имя поля
  5. Имя метода
  6. Имя свойства
  7. Локальная переменная
  8. Параметр


Агрегат

(одним файлом)
Агрегат

Агрегат определяет агрегированное значение над экземплярами определенного класса, удовлетворяющими условиям агрегации. Агрегаты бывают следующих типов:

  • any - первый попавшийся объект. Результат имеет тип ссылки на объект агрегируемого класса.
    1any(TObject with Master = Self.Parent)
2//первый попавшийся объект, имеющий значение
3//свойства Master равным значению свойства
4//Parent текущего (контекстного) объекта.
  • count - количество объектов. Результат имеет целочисленный тип.
    1count(TObject with Master = Self.Parent)
2//количество объектов, имеющих значение свойства
3//Master равным значению свойства Parent
4//текущего объекта.
  • sum - сумма значений свойства, поля или функции объектов. Результат имеет тип суммируемого поля, свойства или функции
    1sum(TExam.Mark with Master = LStudent) //сумма
2//баллов студента по его испытаниям
  • max, min - соответственно максимальное и минимальное значений свойства, поля или функции объектов. Результат имеет тип агрегируемого поля, свойства или функции
    1min(TObject.Created) // момент создания первого
2//объекта Системы.

Внутри выражения агрегата правила разбора идентификатора изменяются на следующие:

  1. Контекстная переменная (для выражений условий отбора доменов)
  2. Имя элемента перечисления
  3. Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту
  4. Имя поля
  5. Имя метода
  6. Имя свойства
  7. Локальная переменная
  8. Параметр


Операции

(раздел целиком) (одним файлом)
Операции

Операции связывают элементы выражений.

Таблица операций в порядке приоритета:
Левый операнд | Правый операнд
 | Целый | Вещест- венный | Дата | Время | Дата со временем | Логи- ческий | Строковый | Объект | nil
not
Нет | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
* (звездочка)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
/ (слэш, дробь)
Целый | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
div
Целый | Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
and
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
or
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
+ (плюс)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Дата | Дата со временем | Запрещено | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Время | Время | Дата со временем | Время | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Дата со временем | Дата со временем | Запрещено | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Строковый | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
- (минус)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Дата | Дата со временем | Целый | Дата со временем | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено
Время | Время | Время | Дата со временем | Время | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Дата со временем | Дата со временем | Вещест- венный | Дата со временем | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
=, <> (равно, не равно)
Целый | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Вещест- венный | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Дата | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Логи- ческий
Время | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Дата со временем | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Логи- ческий
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Логи- ческий
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Логи- ческий
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
<, >, <=, >= (меньше, больше, меньше либо равно, больше либо равно)
Целый | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
is
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
as
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Объект | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено

  • Особенности применения операций


Особенности применения операций

(одним файлом)
Особенности применения операций
  1. Приоритет сравнений ниже приоритета операций булевой логики. Поэтому выражение
    LObject.Master = LMaster and LObject.Parent = LParent
    будет интерпретироваться следующим образом:
    LObject.Master = (LMaster  and LObject.Parent) = LParent
    и вызовет ошибку компиляции из-за применения операции and к объектам. Необходимо писать:
    (LObject.Master = LMaster) and (LObject.Parent = LParent)
  2. Любое значение (выражение любого типа) сравнивается с безтиповой константой nil:
    1      LObject := any(TObject with Name = 'Some name');
2      if LObject = nil then
3         .....
  3. Операции "Унарный минус" не существует. Для задания отрицательных констант пользуйтесь конструкцией 0-Значение:
    Result := 0-1;


Формальная грамматика

(одним файлом)
Формальная грамматика
001Goal: MethodBody | Expression;
002
003MethodBody: [ConstantDeclaration] [VariableDeclaration] CompoundStatement ";";
004
005ConstantDeclaration: "const" Ident ":" DomainSpecification ";"
006  [{Ident ":" DomainSpecification ";"}];
007
008VariableDeclaration: "var" DomainDefinition [{DomainDefinition}];
009
010DomainDefinition: Ident ":" DomainSpecification ";";
011
012DomainSpecification: IntegerDomainDefinition
013  | StringDomainDefinition
014  | FloatDomainDefinition
015  | DateDomainDefinition
016  | TimeDomainDefinition
017  | DateTimeDomainDefinition
018  | BooleanDomainDefinition
019  | BlobDomainDefinition
020  | EnumerationDomainDefinition
021  | Ident;
022
023IntegerDomainDefinition: "integer";
024StringDomainDefinition: "string" "[" Number "]";
025FloatDomainDefinition: "float" ["(" Number ["." Number] ")"];
026DateDomainDefinition: "date";
027TimeDomainDefinition: "time";
028DateTimeDomainDefinition: "datetime";
029BooleanDomainDefinition: "boolean";
030BlobDomainDefinition: "blob" | "clob";
031EnumerationDomainDefinition: "(" Ident {"," Ident} ")";
032
033CompoundStatement: "begin" Statement [{";" Statement}] "end";
034
035Statement:
036  | CompoundStatement
037  | AssignmentStatement
038  | InheritedStatement
039  | CallStatement
040  | IfStatement
041  | CaseStatement
042  | ForStatement
043  | WhileStatement
044  | RepeatStatement
045  | TryFinallyStatement
046  | TryExceptStatement
047  | RaiseStatement
048  | ForEachStatement
049  | ExitStatement;
050
051AssignmentStatement:  Qualifier ":=" Expression;
052
053CallStatement: Qualifier;
054
055InheritedStatement: "inherited";
056
057IfStatement: "if" Expression "then" Statement ["else" Statement];
058
059CaseStatement: "case" Expression "of" {CaseBranch} ["else" Statement ";"] "end";
060
061CaseBranch: CaseLabel [{',' CaseLabel}] ":" Statement ";";
062
063CaseLabel: Number | Ident;
064
065ForStatement: "for" Ident ":=" Expression ("to"|"downto")
066  Expression "do" Statement;
067
068WhileStatement: "while" Expression "do" Statement;
069
070RepeatStatement: "repeat" Statement [{";" Statement}] "until" Expression;
071
072TryFinallyStatement: "try" Statement [{";" Statement}] "finally"
073  Statement [{";" Statement}] "end";
074
075TryExceptStatement: "try" Statement [{";" Statement}] "except"
076  Statement [{";" Statement}] "end";
077
078RaiseStatement: "raise" [Expression];
079
080ForEachStatement: "for" "each" Ident "of" Ident ["with" Expression]
081  ["by" Expression] "do" Statement;
082
083ExitStatement: "exit";
084
085Expression: ComparedExpression [{RelationOperation Expression}];
086
087ComparedExpression: Addon [{AdditionOperaton ComparedExpression}];
088
089Addon: Factor [{MultiplicativeOperation Addon}];
090
091Factor: "(" Expression ")"
092  | "not" Expression
093  | Number ["." Number]
094  | StringConstant
095  | Qualifier
096  | "nil"
097  | "True"
098  | "False"
099  | "(" Expression "is" Ident ")"
100  | "any" Aggregate
101  | "count" Aggregate
102  | "sum" Aggregate
103  | "max" Aggregate
104  | "min" Aggregate;
105
106Aggregate: "(" Ident ["." Ident] ["with" Expression] ")";
107
108Qualifier: QualifierPart [{"." QualifierPart}];
109
110QualifierPart: Ident ["(" Expression [{", " Expression}] ")"]
111  | "self"
112  | "(" Qualifier "as" Ident ")";
113
114RelationOperation: "<"
115  | ">"
116  | "<="
117  | ">="
118  | "="
119  | "<>";
120
121AdditionOperaton: "+"
122  | "-"
123  | "or";
124
125MultiplicativeOperation: "*"
126  | "/"
127  | "div"
128  | "and";


Соглашения

(раздел целиком) (одним файлом)
Соглашения
  • Соглашения о наименованиях
  • Стилевое оформление исходного кода


Соглашения о наименованиях

(одним файлом)
Соглашения о наименованиях

В качестве вводимых (объявляемых) идентификаторов необходимо использовать так называемую нотацию InfixCaps. Если при создании имени используется несколько слов, то необходимо использовать заглавную букву для каждого слова в имени. Для разделения слов нельзя использовать символ подчеркивания. Все сущности именуются на английском языке, при этом использование сокращений является оправданным только в случае, если длина образуемого имени не согласуется с внешними по отношению к соображениям бизнес-логики ограничениям.

  • Имя класса должно начинаться с латинской буквы 'T'.
    Имя | Наименование
    TObjectList | Список объектов
    TLearnPlan | Учебный план
  • Имя поля должно начинаться с латинской буквы 'F'.
    Имя | Наименование
    FLearnPeriod | Период обучения
    FExamMark | Оценка за экзамен
  • Имя свойства не имеет префикса.
    Имя | Наименование
    ExamKind | Вид рубежного испытания
    ContactPhone | Контактный телефон
    Если членом класса для чтения свойства является поля, то имя свойства должно повторять имя поля без префикса 'F'. Если членом класса для чтения свойства является метод, то имя поля должно повторять имя метода без слова 'Get'.
  • Имя параметра не имеет префикса.
    Имя | Наименование
    OrderNumber | Номер приказа
    ExamDate | Дата проведения экзамена
    Параметры, используемые для инициализации значений полей, должны иметь имя, повторяющее имя поля без префикса 'F'. При компиляции тела метода, написанного на языке PascalScript имена параметров и имена свойств будут распознаваться в соответствии с порядком разбора идентификаторов, как это описано здесь и здесь.
  • Имена методов должны представлять собой императивный глагол на английском языке, выражающий смысл того, что метод делает. Имена методов не имеют префикса. Имена методов, используемых для получения значений свойств должны (как члены класса для чтения), должны начинаться со слова Get. Имена методов, используемых для установки значений свойств должны (как члены класса для записи), должны начинаться со слова Set.
    Имя | Наименование
    CountMarkSumm | Вычислить сумму баллов
    GetAge | Получить значение возраста
    SetMark | Установить значение оценки
  • Имена локальных переменных должны начинаться с латинской буквы 'L'.
    LMarkSumm (сумма баллов), LObjectCount (количество объектов).
  • Имена доменов должны начинаться с латинской буквы 'T'. В именах доменов допустимы пробелы. Рекомендуется к имени домена добавлять слово 'domain' (через пробел), а для обязательных доменов 'required domain' (через пробел) тогда, когда необходимо исключить возможность использования этих доменов в текстах на PascalScript. Первым словом в имени домена-ссылки должно быть имя класса домена. Исключением являются имена доменов, соответствующих простым типам данных без дополнительных ограничений. Имена таких доменов могут повторять имена типов языка PascalScript (Integer, Boolean, Float).
    Имя | Класс домена | Наименование
    TPrice domain | Вещественный | домен Цена
    TWeight required domain | Целочисленный | домен Вес (обязательный)
    Boolean | Логический | Логический
    TClassMember required domain | Ссылка | домен Член класса
  • Имена элементов перечислений должны иметь префикс из двух или трех символов, идентифицирующий соответствующий домен-перечисление. Префикс записывается строчными буквами. Например,
    Имя | Наименование
    для домена TExamKind (вид испытания)
    ekTest | зачет
    ekExam | экзамен
    ekDifTest | дифференцированный зачет
    для домена TAggregateKind (вид агрегата)
    agCount | количество
    agSumm | сумма
    agAverage | среднее значение
    Настоятельно рекомендуется давать уникальные имена элементов перечислений в пределах всей системы.


Стилевое оформление исходного кода

(раздел целиком) (одним файлом)
Стилевое оформление исходного кода

Код на языке PascalScript, являющийся частью поставляемого решения, должен быть оформлен в соответствии с изложенными правилами.

  • Использование строк, пробелов и отступов
  • Оформление объявлений и операторов


Использование строк, пробелов и отступов

(одним файлом)
Использование строк, пробелов и отступов

Пустые строки могут повысить читабельность путем группирования секций кода, которые логически связаны между собой.

Пробелы, запрещенные к использованию:

  • До или после точки "."
  • Между именем вызываемого метода и открывающей скобкой "("
  • После открывающей скобки "(" или перед закрывающей ")"
  • Перед точкой с запятой ";"
  • Перед двоеточием ":"
  • Перед запятой ","

Двоеточие для всех объявлений переменных не должно содержать перед собой пробелов и иметь один пробел после перед именем типа.

Всегда необходимо использовать два пробела для всех уровней отступа. Другими словами, первый уровень отступает на два пробела, второй на четыре и так далее. Никогда не используйте символы табуляции.

Существует несколько исключений из этого правила. Зарезервированные слова var, begin и end, относящиеся к программному блоку вцелом, всегда должны примыкать к левой границе. Код внутри блока begin..end должен иметь отступ два символа.

Все строки должны быть ограничены 80 столбцами. Строки, длиннее чем 80 столбцов должны быть разделены и перенесены. Все перенесенные строки должны быть выровнены по первой строке и иметь отступ в два символа. Зарезервированное слово begin всегда должно находиться на своей отдельной строке.

Нельзя переносить строки в тех местах, где не допускаются пробелы, например между именем метода и открывающей скобкой. Никогда нельзя помещать зарезервированное слово begin на строку, содержащую другой код.


Оформление объявлений и операторов

(одним файлом)
Оформление объявлений и операторов

Все переменные с их типами должны быть объявлены на различных строках.

Простые операторы содержат одну точку с запятой. Если Вам необходимо разделить оператор, то перенесите продолжение оператора на следующую строку с отступом в два пробела.
  MyValue :=
    MyValue + (SomeVeryLongStatement / OtherLongStatement);

Составные операторы всегда заканчиваются точкой с запятой.
1begin
2  MyStatement;
3  MyNext Statement;
4  MyLastStatement;
end;

Каждое присвоение и каждое выражение должно располагаться на разных строках.

Оператор "if"

Оператор if всегда должен располагаться по крайней мере на двух строках
if A < B then DoSomething;
if A < B then
  DoSomething;
В случае составного оператора необходимо поместить каждый оператор на новую строку.
1  if A < B then begin
2    DoSomething;
3    DoSomethingElse;
4  end else begin
5    DoThis;
6    DoThat;
7  end;

1  if A < B then
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end
6  else
7  begin
8    DoThis;
9    DoThat;
  end;
Все остальные варианты расположения операторов не рекомендуются и не одобряются, хотя и являются синтаксически правильными.

Оператор "for"

1  for i := 0 to 10 do begin
2    DoSomething;
3    DoSomethingElse;
4  end;

1  for i := 0 to 10 do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  for I := 0 to 10 do
8    DoSomething;

Оператор "while"

1  while x < j  do begin
2    DoSomething;
3    DoSomethingElse;
  end;
1  while x < j do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  while x < j do
8    Something;

Оператор "repeat..until"

1  repeat
2    x := j;
3    j := UpdateValue;
4  until j > 25;

Оператор "case"

Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01  case LCode of
02    1, 3:
03      begin
04        Incr := FIncrement + 1;
05        FinalIncr := FIncrement div FLineDiv;
06        Count := FLineDiv;
07      end;
08    2, 4:
09      begin
10        Incr := FPageIncrement;
11        FinalIncr := Incr + 1;
12        Incr := Incr div FPageDiv;
13        Count := FPageDiv;
14      end;
15  else
16    begin
17      Count := 0;
18      Incr := 0;
19      FinalIncr := 0;
20    end;
  end;

Оператор "try"

Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01try
02  try
03    EnumItems(CurrentThreadID, LDisable, 0);
04    Result := TaskList;
05  except
06    EnableItems(TaskList);
07    raise;
08  end;
09finally
10  TaskList := SaveList;
11  TaskActive := SaveActive;
end;


Интерфейсы взаимодействия с внешними подсистемами

(раздел целиком) (одним файлом)
Интерфейсы взаимодействия с внешними подсистемами

Системный слой платформы "Мельница данных" предоставляет сторонним системам ряд интерфейсов, дающих возможность обращаться к объектам базы данных и их свойствам, вызывать методы классов и объектов, осуществлять запросы к базе данных, управлять поведением элементов управления и проч.

  • Интерфейс IContext
  • Интерфейс IContextDataSet
  • Интерфейс IConstants
  • Интерфейс IFormContext
  • Интерфейс IControl
  • Интерфейс IButton
  • Интерфейс IBinaryData
  • Интерфейс IContextExpressionInfo
  • Интерфейс IExceptionHandler
  • Справочник по интерфейсам
  • Дополнительные интерфейсы


Интерфейс IContext

(одним файлом)
Интерфейс IContext
01  IContext = interface(IDispatch)
02    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
03    function Handle: Integer;
04    function getName(ID: OleVariant): WideString;
05    function getDescription(ID: OleVariant): WideString;
06    function createDataSet(const TargetClassName: WideString):
07      IContextDataSet;
08    function executeMethod(const ClassName: WideString;
09      const MethodName: WideString;
10      Params: OleVariant): OleVariant;
11    function executeReport(const ClassName: WideString;
12      const TemplateName: WideString;
13      Params: OleVariant): IDispatch;
14    function getPropValue(const ClassName: WideString;
15      const PropName: WideString;
16      const ID: OleVariant): OleVariant;
17    procedure setPropValue(const ClassName: WideString;
18      const PropName: WideString;
19      const ID: OleVariant; Value: OleVariant);
20    function select(const ClassName: WideString;
21      QueryItems: OleVariant): IDispatch;
22    function enumerationItem(ItemIdentifier: OleVariant): WideString;
23    function getClass(const ClassName: WideString): WideString;
24    function createGUID: WideString;
25    procedure processStart(const Description: WideString;
26      ItemCount: Integer);
27    procedure processStep;
28    procedure processStop;
29    function PlaceDataSet(const Range: IDispatch;
30      const DataSet: IContextDataSet;
31      ShiftRows: WordBool; ShiftColumns: WordBool): Integer;
32    procedure DebugString(const Message: WideString);
33    procedure ExportObject(var Document: OleVariant; const ID: WideString;
34      const ClassID: WideString);
35    function callRoutine(const ClassName, RoutineName: WideString;
36      var RetValue: OleVariant; const ScriptPart: OleVariant): WordBool;
37    function getOleObject(const ClassID, AccessibleFileName: WideString): IDispatch;
38    function getResource(const Name: WideString): WideString;
39    function getTempFileName(const Extension: WideString): WideString;
40    function selectVaue(const ClassDomain: WideString;
41      const ExpressionContext: IContextExpressionInfo;
42      var Value: OleVariant): WordBool;
43    procedure raiseManagedException(const ExceptionMessage: WideString);
44    function getCRC(Data: OleVariant): WideString;
45    function downloadData(const Host: WideString; const Url: WideString;
46      const UserName: WideString; const Password: WideString;
47      NegotiateAuth: WordBool; PostData: OleVariant;
48      const PostContentType: WideString; PostDataIsBinary: WordBool;
49      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;
50    function createBinaryData: IDispatch;
51    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
52    function editValues(const ValuesList: WideString; const Title: WideString;
53      UseTabs: WordBool; HideOKButton: WordBool;
54      const ScriptPart: OleVariant): WordBool;
55    function MsgBox(const Prompt: WideString; Buttons: LongWord;
56      const Title: WideString;
57      const HelpFile: WideString; Context: LongWord): Integer;
58    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
59      const Title: WideString;
60      const HelpFile: WideString; Context: LongWord): Integer;
61    function buildNamedFile(const Data: IDispatch; const StoredFileName: WideString;
62                            Propmpt: WordBool; Compress: WordBool): IDispatch;
63    procedure parseNamedFile(const NamedFile: IDispatch; out FileName: OleVariant;
64                             out Data: OleVariant);
65    procedure showView(const ViewName: WideString; Key: OleVariant;
66                       const DetailPropertyName: WideString);
67    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
68                          ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
69                          TakeActionsFromView: OleVariant);
70    function executeConsoleProcess(const CommandLine: WideString; MaxDuration: Integer;
71                                   const OutputData: OleVariant): Integer;
72    function createRaster: IDispatch;
73    function createZIPArchive: IDispatch;
74    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch;
75    property ContextObject: IDispatch;
76    property Language: WideString;
77    property UserName: WideString;
78    property NegotiateAuth: WordBool;
79    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant;
80  end;

Члены интерфейса доступны для использования в скриптах форм задания параметров, а также в отчетах как члены класса передаваемого контекстного объекта.

  • Функция Handle возвращает дескриптор главного окна приложения.
  • Функция getName возвращает имя объекта по его идентификатору.
  • Функция getDescription возвращает наименование объекта по его идентификатору.
  • Функция createDataSet создает набор данных, основанный на экземплярах класса, имя которого передано как параметр. Возвращаемый объект реализует интерфейс IContextDataSet.
  • Функция executeMethod осуществляет вызов метода с параметрами. Имя класса передается в параметре ClassName, имя вызываемого метода - в параметре MethodName. Если вызываемый метод явяется функцией, то результат ее выполнения возвращается как результат вызова executeMethod. Параметры вызова метода передаются через параметр Params следующим образом:
    • Для методов класса без параметров можно передавать любое значение, например, Null.
    • Для методов класса, имеющих один параметр, значение Params есть значение этого единственного параметра.
    • Для методов класса, имеющих более одного параметра, значение Params есть массив значений параметров.
      VBScript, VBA | LValue = executeMethod("TObject", "Round", Array(10.24, 1))
      JScript | LValue = executeMethod("TObject", "Round", new Array(10.24, 1));
      Object Pascal | LValue := executeMethod('TObject', 'Round', VarArrayOf([10.24, 1]));
    • Для методов экземпляра без параметров значение Params есть идентификатор объекта, для которого вызывается метод.
    • Для методов экземпляра, имеющих параметры, значение Params есть массив значений параметров. При этом первым элементом массива является идентификатор объекта, для которого вызывается метод.
      VBScript, VBA | executeMethod "TObject", "MergeTo", Array(LOldObject, LNewObject)
      JScript | executeMethod("TObject", "MergeTo", new Array(LOldObject, LNewObject));
      Object Pascal | executeMethod('TObject', 'MergeTo', VarArrayOf([LOldObject, LNewObject]));
  • Функция executeReport осуществляет вызов отчета с параметрами. Имя класса передается в параметре ClassName, имя вызываемого метода - в параметре TemplateName. Параметры вызова передаются в параметре Params аналогично вызову executeMethod. В результате вызова функции возвращается ссылка на рабочую книгу Microsoft Excel, документ Microsoft Word и так далее. Судьба приложения, в рамках которого создан возвращенный объект, остается на усмотрение вызывающей стороны. Если вызывающая сторона предполагает взаимодействие объекта с пользователем, то необходимо обеспечить видимость объекта-приложения (Application.Visible := True;). В противном случае необходимо закрыть приложение после освобождения объекта документа (Application.Quit).
  • Функция getPropValue возвращает значение свойства объекта. Имя класса, имя свойства и идентификатор объекта задаются в параметрах.
  • Процедура setPropValue устанавливает значение свойства объекта в значение, заданное параметром Value. Для очистки значения можно использовать пустую строку или значение Null. Имя класса, имя свойства и идентификатор объекта задаются в параметрах.
  • Функция select возвращает ссылку на XML-документ, содержащий в корневом элементе элементы, представляющие собой записи набора данных на основе класса ClassName (с полями, разнесенными по элементам), определяемого структурой параметра QueryItems.
  • Функция enumerationItem возвращает идентификатор элемента перечисления по имени.
    VBScript, VBA | LItemID = enumerationItem("rsReplicatableMetadata")
    JScript | LItemID = enumerationItem("rsReplicatableMetadata");
    Object Pascal | LItemID := enumerationItem('rsReplicatableMetadata');
  • Функция getClass возвращает идентификатор объекта типа Класс TClass (Классы) по имени.
    VBScript, VBA | LClassID = getClass("TDocumentType")
    JScript | LClassID = getClass("TDocumentType");
    Object Pascal | LClassID := getClass('TDocumentType');
  • функция createGUID является оберткой над функцией Windows API CoCreateGuid. Возвращает сгенерированный глобально-уникальный идентификатор, преобразованный в строку.
  • процедура processStart информирует систему о необходимости показать окно выполнения длительного процесса. Текст, описывающий процесс (он появляется в показываемом окне) задается параметром Description. В случае, если есть возможность определить количество "шагов" процесса, то это количество необходимо передать в параметре ItemCount. В случае, если параметр ItemCount больше нуля, окно выполнения будет снабжено индикатором прогресса. Если значение ItemCount равно нулю, то окно появится без индикатора прогресса. Если значение ItemCount меньше нуля, то решение о появлении окна будет принято системой самостоятельно на основании загрузки процессора и окно процесса не появится, если процесс завершится достаточно быстро.
  • процедура processStep информирует систему о завершении очередного "шага" процесса, что найдет отражение в индикаторе прогресса окна выполнения длительного процесса, если таковые случатся.
  • процедура processStop информирует систему о завершении длительного процесса, что приведет к закрытию окна выполнения длительного процесса, если таковое случится.
  • функция PlaceDataSet осуществляет перенос данных из набора, задаваемого параметром DataSet в некоторое место документа Microsoft Office. Место назначения определяется параметром Range следующим образом:
    Microsoft Word
    • Объект Range. По месту расположения этого объекта будет создана таблица (Table), в которой будут размещены данные из набора.
      PlaceDataSet ThisDocument.Bookmarks("BookMarkName").Range, LDataSet
      PlaceDataSet Selection.Range, LDataSet
    • Объект Document. В самом начале переданного документа будет создана таблица (Table), в которой будут размещены данные из набора.
      PlaceDataSet ThisDocument, LDataSet
    Microsoft Excel
    • Объект Range. По месту расположения этого объекта (диапазона) будут размещены данные из набора. Если параметр ShiftRows задан и равен True, то заданный диапазон будет расширен вниз на необходимое количество строк, и информация, лежащая ниже переданного диапазона, будет по-прежнему лежать ниже. Если нет, то она (скорее всего) будет затёрта данными набора. Если параметр ShiftColumns задан и равен True, то этот диапазон будет расширен вправо на необходимое количество столбцов, и информация, лежащая правее переданного диапазона, будет по-прежнему лежать правее. Если нет, то она (скорее всего) будет затёрта данными набора.
      PlaceDataSet Range("C4"), LDataSet
    • Объект WorkSheet. На переданном листе будут размещены данные из набора.
      PlaceDataSet WorkSheets("HiddenSheet"), LDataSet
    Функция возвращает количество размещенных записей.
  • процедура DebugString выводит переданную в качестве аргумента строку в отладочный монитор.
  • процедура ExportObject осуществляет экспорт информации об объекте, задаваемом параметром ID в XML-документ, передаваемый в параметре Document. Если объект документа не был создан, то он создается автоматически. Если документ не имеет корневого узла, он будет создан автоматически.
    01set LDataSet = CreateDataSet("TSecurityAccount")
02
03LDataSet.AddQueryItem qpWhat, "ID"
04
05set LDocument = CreateObject("Msxml2.DOMDocument.4.0") 'Не обязательно.
06
07while not LDataSet.Eof
08  ExportObject LDocument, LDataSet.Field("ID")
09  LDataSet.Next
10wend
11
12LDocument.save "c:\RolesAndUsers.xml"
  • Функция callRoutine осуществляет вызов подпрограммы. Параметры будут запрошены у пользователя обычным порядком (с показом формы задания параметров, отработки ее скрипта и т. д.). Имя класса передается в параметре ClassName, имя вызываемой подпрограммы - в параметре RoutineName. Если пользователь разрешил выполнение подпрограммы (либо для выполнения не требовалось разрешения пользователя), функция вернет True, иначе False. Значение, возвращаемое подпрограммой, может быть возвращено через необязательный параметр RetValue. Через значение необязательного параметра ScriptPart можно передать скрипт на языке VBScript, который будет "приклеен" сверху к скрипту формы параметров вызываемой подпрограммы.
  • Функция getOleObject возвращает ссылку на Ole-объект с идентификатором класса, переданном в параметре ClassID. Объект создается на основе библиотеки кода, сохраненной в доступном файле с именем, заданным параметром AccessibleFileName. Регистр символов имени доступного файла важен.
  • Функция getResource возвращает значение ресурсной строки по имени ресурса (элемента перечислимого домена Resource strings или перевода (объекта класса TLanguageTranslation).
    MsgBox getResource("rssMyErrorMessage")
  • Функция getTempFileName возвращает сгенерированное системой имя временного файла с расширением, переданным в параметре Extension.
  • Функция selectVaue позволяет пользователю выбрать значение на основе ссылочного домена, имя которого передается в параметре ClassDomain. Вызывающая сторона может реализовать интерфейс IContextExpressionInfo, через который передается информация о контексте вызова для интерпретации выражений условий отбора, и передать ссылку на него через параметр ExpressionContext. Выбранное значение передается в обе стороны через параметр Value. Если пользователь подтвердил выбор значения, функция возвращает значение True, и устанавливает значение параметра Value, равное идентификатору выбранного пользователем объекта. Если пользователь отказался от выбора, функция возвращает значение False.
  • Процедура raiseManagedException возбуждает управляемую исключительную ситуацию с сообщением для пользователя, заданным параметром ExceptionMessage.
  • Функция getCRC возвращает шестнадцатиричное представление контрольной суммы переданных в параметре Data данных. Параметр может быть
    • Объектом, реализующим интерфейс IBinaryData
    • Объектом, реализующим интерфейс IStream
    • Объектом, реализующим интерфейс ISequentialStream
    • Объектом, реализующим интерфейс IFile объектной модели FileSystemObject
    • Строкой данных. Строка будет преобразована в байты в соответствии с кодировкой UTF-8.
  • Функция downloadData осуществляет обращение к указанному ресурсу по протоколу http (https), и возвращает ответ сервера в виде объекта, реализующего интерфейс IBinaryData. Параметр Host определяет http-сервер, параметр Url - Url, к которому будет происходить обращение. Параметры UserName и Password определяют имя пользователя и пароль, если http-сервер требует авторизовать пользователя. Параметр NegotiateAuth устанавливает режим аутентификации. (Basic или Negotiate). Параметры PostData, PostContentType и PostDataIsBinary определяют содержимое тела POST-запроса (если не определено, функция отправит GET-запрос). Параметр CanCache позволяет использовать локальный кеш http-ответов. Параметр NewSession требует принудительного создания новой сессии при вызове функции. Параметр TimeOut определяет максимальное время ожидания ответа в секундах.
  • Функция createBinaryData создает пустой объект, реализующий интерфейс IBinaryData.
  • Функция BinaryToBitmap конвертирует переданный графический файл в формат BMP. Объекты во входном и выходном параметрах должны реализовывать интерфейс IBinaryData.
  • Функция editValues создает и показывает форму редактирования группы значений. Параметр ValuesList содержит идентификатор объекта класса TObjectList. Этот список содержит ссылки на редактируемые значения (объекты класса TTypedValue), и командные кнопки формы (объекты класса TTypedValueButton). Параметр Title определяет заголовок формы, параметр UseTabs определяет, будут ли показаны закладки на форме редактирования. Параметр HideOKButton позволяет скрыть кнопку "OK" на показываемой форме. Параметр ScriptPart определяет скрипт показываемой формы.

    01  LValue1 = executeMethod ("TTypedValue", "CreateStrValue", _
02    Array("Value1", "Первый параметр", Null, Null, _
03    "TLongString", Null, Null, Null, Null, Null, "Значение по  умолчанию первого параметра"))
04  LValue2 = executeMethod ("TTypedValue", "CreateStrValue", _
05    Array("Value2", "Второй параметр", Null, Null, _
06    "TLongString", Null, Null, Null, Null, Null, "Значение по  умолчанию второго параметра"))
07
08  LValues = executeMethod("TObjectList", "CreateFromString", _
09    LValue1 & ";" & LValue2)
10
11  if editValues(LValues, "Введите два строковых значения, друзья", True, False, "") then
12    MsgBox getPropValue("TTypedValue", "StrValue", LValue1) & _
13      " " & _
14      getPropValue("TTypedValue", "StrValue", LValue2)
15  end if
16
17  executeMethod "TObject", "Destroy", LValues
18  executeMethod "TObject", "Destroy", LValue1
19  executeMethod "TObject", "Destroy", LValue2

    01  LScriptPart =  "Buttons(""NextButton"").Enabled = ParentForm.NavigatorCanNext" & Chr(10) & _
02    "Buttons(""PrevButton"").Enabled = ParentForm.NavigatorCanPrevious"
03
04  LValue1 = executeMethod ("TTypedValue", "CreateStrValue", _
05    Array("Value1", "Первый параметр", Null, Null, "TLongString", Null, Null, Null, Null, Null, _
06    "Значение по  умолчанию первого параметра"))
07  LValue2 = executeMethod ("TTypedValue", "CreateStrValue", _
08    Array("Value2", "Второй параметр", Null, Null, "TLongString", Null, Null, Null, Null, Null, _
09    "Значение по  умолчанию второго параметра"))
10
11  LNextButton = executeMethod ("TTypedValueButton", "Create", Array("NextButton", "Вперед!", _
12    Null, Null, Null, Null, 0, Null, Null, _
13    "ParentForm.NavigatorNext"  & Chr(10) & LScriptPart, enumerationItem("scPublic"), 1, Null))
14
15  LPrevButton = executeMethod ("TTypedValueButton", "Create", Array("PrevButton", "Назад!", _
16    Null, Null, Null, Null, 1, Null, Null, _
17    "ParentForm.NavigatorPrevious" & Chr(10) & LScriptPart, enumerationItem("scPublic"), 1, Null))
18
19  LValues = executeMethod("TObjectList", "CreateFromString", _
20    LValue1 & ";" & LValue2 & ";" & LNextButton & ";" & LPrevButton)
21
22  if editValues(LValues, "Введите два строковых значения, друзья", True, True, LScriptPart) then
23    MsgBox getPropValue("TTypedValue", "StrValue", LValue1) & _
24      " " & _
25      getPropValue("TTypedValue", "StrValue", LValue2)
26  end if
27
28  executeMethod "TObject", "Destroy", LValues
29  executeMethod "TObject", "Destroy", LValue1
30  executeMethod "TObject", "Destroy", LValue2
31  executeMethod "TObject", "Destroy", LNextButton
32  executeMethod "TObject", "Destroy", LPrevButton

  • Функции MsgBox и ShowMsgBox (это синонимы одной точки входа) полностью аналогичны функции Basic MsgBox по поведению и набору параметров.
  • Функция buildNamedFile формирует значение типа "Именованный файл" на основе объекта, реализующего интерфейс IBinaryData (параметр Data) и информации об имени и параметрах именованного файла.
  • Процедура parseNamedFile разбирает значение типа "Именованный файл". Выходной параметр FileName будет содержать сохраненное имя файла, выходной параметр Data - объект, реализующего интерфейс IBinaryData и содержащий данные именованного файла.
  • Свойство ContextObject позволяет получить ссылку на этот же самый контекстный объект.
  • Свойство UserName позволяет получить логин текущего пользователя.
  • Свойство NegotiateAuth позволяет получить признак доменной аутентификации пользователя.
  • Свойство Language позволяет получать и устанавливать текущий языковой контекст, в котором будут выполняться обращения к БД. Значение свойства либо пустая строка (используется язык БД по умолчанию), либо имя объекта класса TLanguage
  • Свойство Variable позволяет сохранять и получать произвольные значения, которые могут хранится постоянно (в реестре) или только в текущем сеансе, в зависимости от параметра Persistent.
    1'сохранить на время текущего сеанса значение в переменную с именем SameVariableName
2Variable("SameVariableName", False) = "Value"
3
4'получить значение переменной с именем SameVariableName хранимой в текущем сеансе
5LValue = Variable("SameVariableName", False)
  • Процедура showView осуществляет показ в модальном окне представления с именем ViewName. С помощью параметров DetailPropertyName и Key можно наложить на представление дополнительное условие отбора.


Интерфейс IContextDataSet

(одним файлом)
Интерфейс IContextDataSet
01  IContextDataSet = interface(IDispatch)
02    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
03    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
04      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant);
05    function Eof: WordBool;
06    function Field(const Name: WideString): OleVariant;
07    function FieldCount: Integer;
08    function FieldName(Index: Integer): WideString;
09    procedure Next;
10  end;

Интерфейс предоставляет возможности формирования и выполнения запросов к базе данных с целью получения свойств объектов определенного класса, предоставляет доступ к объекту набора данных. Работа с объектом, реализующим интерфейс IContextDataSet заключается в формировании структуры набора данных и последующих обращениях к ним.

  • Процедура AddQueryItem добавляет элемент набора данных. Элементы могут добавляться в любом порядке до первого обращения к данным набора. Символические имена всех предопределенных для параметров этого метода констант являются членами интерфейса IConstants.
    • часть запроса определяется параметром Part, который может принимать одно из следующих предопределенных значений:
      Символическое имя | Числовое значение | Описание
      qpWhat | 0 | Добавляет поле (столбец), определяемое параметром Name, к результирующему набору данных. Параметр Value игнорируется.
      qpWhere | 1 | Определяет условие, налагаемое на свойства объектов класса, передаваемое остальными параметрами.
      qpOrder | 2 | Определяет порядок сортировки записей результирующего набора данных. Параметр Value игнорируется.
      qpGroup | 3 | Определяет, что записи результирующего набора данных будут сгруппированы по столбцу, переданному в параметре Name. Параметры Value и Special игнорируются.
    • параметр Name должен быть именем свойства класса, на котором основан набор данных, либо зарезервированным словом "ID" (без кавычек).
    • параметр Value (необязательный) определяет условия отбора, накладываемые на свойство, заданное параметром Name. Имеет смысл только если значение параметра Part равно qpWhere. Условие задается посредством строки, интерпретируемой следующим образом:
      • строка разделяется на части посредством системного разделителя
      • каждая часть интерпретируется самостоятельно, и эти части объединяются логическим "ИЛИ"
      • при интерпретации каждой части проверяются следующие условия:
        * проверка значения на непустоту (IS NOT NULL)
        !* проверка значения на пустоту (IS NULL)
        начинается с символов
        '<=', '<', '>=', '>'         		проверка соответствующего отношения между значением свойства, переданного параметром Name и оставшейся частью строки
        включает в себя символы '*' и/или '?' | проверка соответствия значения шаблону, в котором знак '?' соответствует одному любому символу, а знак '*' - любому количеству любых символов
        начинается с символа '!' | символ '!' означает отрицание условия, переданного оставшейся частью строки
        представляет собой строку в апострофах (одиночных кавычках) | содержание строки не анализируется по приведенным выше условиям
        любая другая строка | проверка равенства значения свойства, переданного параметром Name значению, переданному строкой
    • параметр Special (необязательный) обеспечивает дополнительное поведение набора данных (если параметр Special используется, необходимо использовать и параметр Value, можно передавать пустую строку):
      Символическое имя | Числовое значение | Описание
      qsNone | 0 | Параметр не используется. Значение по умолчанию.
      qsDescending | 7 | Используется при значении qpOrder параметра Part. В этом случае производится сортировка по убыванию.
      qsCount | 8 | Используется при значении qpWhat параметра Part. Определяют тип агрегации по свойству, заданному параметром Name.
      qsSum | 9
      qsMin | 10
      qsMax | 11
      qsAverage | 12
      qsFunction | 22 | Используется для включения в запрос вызова функции. Используется при значении qpWhat параметра Part.
    • параметр Context (необязательный) определяет дополнительные параметры элемента запроса.
    01'включить в набор данных свойство Name
02LDataSet.AddQueryItem 0, "Name"
03'включить в набор данных среднее значение цены
04LDataSet.AddQueryItem 0, "Price", "", 12
05'включить в набор данных идентификатор объекта
06LDataSet.AddQueryItem 0, "ID"
07'включить в набор данных вызов функции. В поле IsCompany будет значение True, если объект является организацией
08LDataSet.AddQueryItem 0, "IsCompany", "TObject.IsInstanceOf", 22, Array(getClass("TCompany"))
09'наложить на набор данных условие
10LDataSet.AddQueryItem 1, "Organization", "фирма Елочка"

    1LDataSet.AddQueryItem 0, "Organization"              '(1)
2LDataSet.AddQueryItem 0, "SalesCount", "", "9"       '(2)
3LDataSet.AddQueryItem 1, "SaleDate", ">10.09.2005"   '(3)
4LDataSet.AddQueryItem 2, "Organization"              '(4)
5LDataSet.AddQueryItem 3, "Organization"              '(5)
    Производится отбор из класса, описывающего число продаж некоего продукта различными организациями. При этом в набор данных включаются колонки "Organization" (строка 1) и "SalesCount" (строка 2). При этом будет произведена группировка по свойству "Organization" (строка 5) (что гарантирует вхождение каждой организации в результирующий набор данных не более одного раза). Набор данных будет отсортирован по организации (строка 4). При этом в колонке "SalesCount" будет сумма (строка 2) всех продаж, осуществленных каждой организацией после 10.09.2005 (строка 3).
  • Функция FieldCount возвращает количество полей (столбцов) набора данных.
  • Функция FieldName возвращает имя поля (столбца) с номером, переданным в параметре Index.
  • Функция Field возвращает значение, содержащееся в поле с именем или индексом, заданным параметром Name (строкового типа) текущей записи набора данных. При первом обращении к набору данных текущей является первая запись. Если параметр определяет номер, то поиск поля производится по номеру. Если имя, то по имени.
  • Процедура Next осуществляет переход к следующей записи набора данных.
  • Функция Eof возвращает False, если текущая запись набора данных существует; в случаях, если набор данных пустой, или при помощи метода Next достигнут конец набора данных, возвращает True.
    01If LDataSet.Eof then
02  'набор данных пуст. Ничего не отобрано.
03Else
04  While Not LDataSet.Eof
05    'работа с очередной отобранной записью
06    Cells(LRow, 1).Value = LDataSet.Field("Name")
07    Cells(LRow, 2).Value = LDataSet.Field("Description")
08    Cells(LRow, 2).Value = LDataSet.Field("Count")
09    'переход к следующей записи
10    LDataSet.Next
11    LRow = LRow + 1
12  Wend
13End If


Интерфейс IConstants

(одним файлом)
Интерфейс IConstants
01  IConstants = interface(IDispatch)
02    ['{7E7B2D66-5E7C-496A-AE06-EFC485007500}']
03    property qpWhat: Integer;
04    property qpWhere: Integer;
05    property qpOrder: Integer;
06    property qpGroup: Integer;
07    property qpHaving: Integer;
08    property qsNone: Integer;
09    property qsObjectID: Integer;
10    property qsParentID: Integer;
11    property qsHasChildren: Integer;
12    property qsFilterCondition: Integer;
13    property qsUplink: Integer;
14    property qsRootOnly: Integer;
15    property qsDescending: Integer;
16    property qsCount: Integer;
17    property qsSum: Integer;
18    property qsMin: Integer;
19    property qsMax: Integer;
20    property qsAverage: Integer;
21    property qsMasterLink: Integer;
22    property qsSelectedOnly: Integer;
23  end;

Интерфейс предоставляет символические имена констант, необходимых для работы с объектом, реализующим интерфейс IContextDataSet.

Свойство | Значение
qpWhat | 0
qpWhere | 1
qpOrder | 2
qpGroup | 3
qpHaving | 4
qsNone | 0
qsObjectID | 1
qsParentID | 2
qsHasChildren | 3
qsFilterCondition | 4
qsUplink | 5
qsRootOnly | 6
qsDescending | 7
qsCount | 8
qsSum | 9
qsMin | 10
qsMax | 11
qsAverage | 12
qsMasterLink | 13
qsSelectedOnly | 14


Интерфейс IFormContext

(одним файлом)
Интерфейс IFormContext
01  IFormContext = interface(IDispatch)
02    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
03    function ChangedControl: OleVariant;
04    function ControlCount: Integer;
05    function ButtonCount: Integer;
06    function ID: WideString;
07    procedure Cancel;
08    function ControlExists(const Name: WideString): WordBool;
09    function ChangedControlName: WideString;
10    function ParentForm: OleVariant;
11    function RoutineID: WideString;
12    procedure PreInitControl(const Name: WideString; Value: OleVariant);
13    procedure NavigatorNext;
14    procedure NavigatorPrevious;
15    function NavigatorCanNext: WordBool;
16    function NavigatorCanPrevious: WordBool;
17    procedure RefreshView(RefreshAll: WordBool);
18    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
19    property Controls[Name: OleVariant]: IControl;
20    property Buttons[Name: OleVariant]: IButton;
21    property Enabled: WordBool;
22  end;

Представляет собой модель формы задания параметров. Члены интерфейса доступны для использования в скриптах форм задания параметров.

  • Функция ChangedControl возвращает объект, реализующий интерфейс IControl, соответствующий элементу управления, изменение которого вызвало исполнение скрипта формы параметров. Если выполнение скрипта вызвано инициализацией формы задания параметров, то значение функции - Empty. Пустоту значения можно проверить с помощью функции VBScript IsEmpty.
  • Функция ControlCount возвращает число элементов управления на форме параметров, как видимых так и невидимых.
  • Функция ButtonCount возвращает число командных кнопок на форме параметров, как видимых так и невидимых.
  • Функция ID возвращает значение идентификатора объекта, для которого вызван метод. Для методов класса возвращает пустое значение.
  • Функция ControlExists возвращает True, если элемент управления с именем Name существует на форме, и, соответственно, существует соответствующий параметр.
  • Функция ChangedControlName возвращает имя элемента управления, изменение которого вызвало исполнение скрипта формы параметров. Если выполнение скрипта вызвано инициализацией формы задания параметров, то значение функции - пустая строка.
  • Процедура Cancel прекращет работу формы задания параметров. Форма закрывается, выполнение действия блокируется.
  • Функция ParentForm возвращает ссылку на контекст родительской формы в цепочке вызовов. В контексте первой формы (вызванной с грида немодальной формы) возвращает пустое значение (Empty). Пустоту значения можно проверить с помощью функции VBScript IsEmpty.
  • Функция RoutineID возвращает идентификатор подпрограммы, для которой вызвана форма.
  • Процедура PreInitControl имитирует предварительную инициализацию элемента управления с именем Name значением, переданным в параметре Value. Сам элемент управления при этом будет скрыт, и не будет показан вплоть до следующего вызова формы пользователем.
  • Процедура NavigatorNext выполняет переход к следующему объекту набора данных, для которого показывается форма параметров.
  • Процедура NavigatorPrevious выполняет переход к предыдущему объекту набора данных, для которого показывается форма параметров.
  • Функция NavigatorCanNext возвращает True, если возможен переход к следующему объекту набора данных, для которого показывается форма параметров.
  • Функция NavigatorCanPrevious возвращает True, если возможен переход к предыдущему объекту набора данных, для которого показывается форма параметров.
  • Процедура RefreshView обновляет набор данных, для которого показывается форма параметров. Если значение параметра RefreshAll равно True, то будет обновлен весь набор, если False, то только выделенные записи.
  • Свойство Controls позволяет обращаться к элементам управления на форме задания параметров, их свойствам и методам. Каждый элемент управления реализует интерфейс IControl. В параметре Name (строкового типа)может быть передано как имя элемента управления, так и его индекс (в этом случае индекс должен быть передан как строка). Имена элементов управления на форме параметров соответствуют именам параметров подпрограммы (метода, отчета, etc).
  • Свойство Buttons позволяет обращаться к командным кнопкам на форме задания параметров, их свойствам и методам. Каждая командная кнопка реализует интерфейс IButton. В параметре Name (строкового типа)может быть передано как имя командной кнопки, так и ее индекс (в этом случае индекс должен быть передан как строка).
  • Свойство Enabled позволяет получать и устанавливать доступность кнопки OK на форме задания параметров. Если на форме есть невалидные (имеющие недопустимые значения) элементы управления, значение свойства всегда равно False и устанавливать его в явном виде в True не рекомендуется. Для учета дополнительного условия рекомендуется использовать следующую конструкцию: Enabled = Enabled and (Controls("SalesCount").Value > 10)
  • Функция ExpressionContextValue возвращает значение переменной контекста с именем Name, которая используется для интeрпретации выражений условий отбора на форме.


Интерфейс IControl

(одним файлом)
Интерфейс IControl
01  IControl = interface(IDispatch)
02    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
03    function Name: WideString;
04    procedure SetHint(const Value: WideString);
05    procedure RefreshLinkedView;
06    property Value: OleVariant;
07    property ReadOnly: WordBool;
08    property IsValid: WordBool;
09    property IsEmpty: WordBool;
10  end;

Моделирует элемент управления на форме задания параметров. Позволяет управлять поведением элементов управления на форме.

  • Функция Name возвращает имя элемента управления; имена элементов управления всегда совпадают с именамим соответствующих параметров подпрограммы.
  • Процедура SetHint устанавливает текст всплывающей подсказки элемента управления. Всплывыющая подсказка показывается только если значение элемента управления недопустимо (свойство IsValid равно False).
  • Процедура RefreshLinkedView обновит связанное с элементом управления представление.
  • Свойство Value позволяет получать и устанавливать значение, введенное в элемент управления.
  • Свойство ReadOnly позволяет получать и устанавливать доступность элемента управления для записи; при значении True элемент управления не доступен для записи и отображается неактивным.
  • Свойство IsValid позволяет получать и устанавливать "валидность" элемента управления; по умолчанию валидным элемент управления является в том случае, если введенное в него значение соответствует домену соответствующего параметра подпрограммы с учетом наложенного на него условия отбора.
  • Свойство IsEmpty имеет значение True в случае, если в элемент управления не введено никакого значения (элемент управления пустой), в противном случае имеет значение False.


Интерфейс IButton

(одним файлом)
Интерфейс IButton
1  IButton = interface(IDispatch)
2    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
3    function Name: WideString; safecall;
4    procedure Click; safecall;
5    property Enabled: WordBool;
6  end;

Моделирует командную кнопку на форме задания параметров. Позволяет управлять поведением кнопки на форме.

  • Функция Name возвращает имя кнопки.
  • Процедура Click эмулирует нажатие на кнопку.
  • Свойство Enabled позволяет получать и устанавливать доступность кнопки.


Интерфейс IBinaryData

(одним файлом)
Интерфейс IBinaryData
01  IBinaryData = interface(IDispatch)
02    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
03    procedure Load(const Src: OleVariant);
04    procedure Append(const Src: OleVariant);
05    procedure Save(const Dst: OleVariant);
06    function Size: Cardinal;
07    function ToString(Encoding: WideString): WideString;
08    procedure FromString(Data: OleVariant);
09    procedure AppendString(Data: OleVariant);
10    function ToBase64: WideString;
11    procedure FromBase64(Data: OleVariant);

Представляет набор двоичных данных.

  • Процедура Load загружает двоичные данные из переданного источника. Источник может быть
    • Объектом, реализующим интерфейс IStream
    • Объектом, реализующим интерфейс ISequentialStream
    • Строкой, содержащей имя файла
  • Процедура Append добавляет двоичные данные из переданного источника. Источник может быть
    • Объектом, реализующим интерфейс IStream
    • Объектом, реализующим интерфейс ISequentialStream
    • Строкой, содержащей имя файла
  • Процедура Save сохраняет двоичные данные в переданный приемник. Приемник может быть
    • Объектом, реализующим интерфейс IStream
    • Объектом, реализующим интерфейс ISequentialStream
    • Строкой, содержащей имя файла
  • Функция ToString переводит данные в строку. Байты, содержашиеся в объекте, будут рассматриваться как содержащие строку в кодировке, заданной параметром Encoding. По умолчанию используется кодировка UTF-8
  • Процедура FromString загружает данные из строки, переданной в параметре Data, перекодировав ее в кодировку UTF-8
  • Процедура AppendString добавляет данные из строки, переданной в параметре Data, перекодировав ее в кодировку UTF-8
  • Функция ToBase64 возвращает строку, полученную путем кодирования в формат Base64, данных содержащихся в объекте
  • Процедура FromBase64 загружает данные из строки, переданной в параметре Data, раскодировав ее из формата Base64


Интерфейс IContextExpressionInfo

(одним файлом)
Интерфейс IContextExpressionInfo
1  IContextExpressionInfo = interface(IUnknown)
2    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
3    function Count: Integer;
4    function ItemName(Index: Integer): WideString;
5    function ItemValue(Index: Integer): OleVariant;
6    function ItemDomain(Index: Integer): OleVariant;
7  end;

Через реализацию этого интерфейса передаются значения контекстных переменных при обращении к функции selectValue интерфейса IContext.

  • Функция Count возвращает количество используемых контекстных переменных. Нумерация контекстных переменных начинается с нуля.
  • Функция ItemName возвращает имя контекстной переменной c номером, переданным в параметре Index.
  • Функция ItemValue возвращает значение контекстной переменной c номером, переданным в параметре Index.
  • Функция ItemDomain возвращает имя домена контекстной переменной c номером, переданным в параметре Index.


Интерфейс IExceptionHandler

(одним файлом)
Интерфейс IExceptionHandler
1  IExceptionHandler = interface(IDispatch)
2    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
3    procedure HandleException(ContextObject: OleVariant;
4      const Message: WideString;
5      const ExtentedInfo: WideString);
6  end;

Реализовав интерфейс IExceptionHandler разработчик решений может получать уведомления о возникающих при работе исключительных ситуациях. При возникновении исключения объект, реализующий интерфейс, получит текст сообщения об ошибке и расширенную информацию.

Для реализации интерфеса используется библиотека hse.tlb, входящая в состав поставки решения. Перед началом работы с ней, необходимо зарегистрировать ее в операционной системе.

Для установки настроек интерфейса необходимо открыть Системную форму раздела АДМИНИСТРАТОРУ, перейти на вкладку Настройки и в столбце "Заголовок закладки" установить фильтр "Обработка ошибок".

После этого в качестве значения Идентификатора класса установить "IExceptionHandler" без кавычек.

Для Библиотеки кода указать значение HSE.tlb


Справочник по интерфейсам

(раздел целиком) (одним файлом)
Справочник по интерфейсам
  • Перечисление TQueryPart
  • Перечисление TQuerySpecial
  • Интерфейс IButton
  • Интерфейс IContext
  • Интерфейс IContextDataSet
  • Интерфейс IContextExpressionInfo
  • Интерфейс IControl
  • Интерфейс IExceptionHandler
  • Интерфейс IExternalContext
  • Интерфейс IFormContext
  • Интерфейс IRaster
  • Интерфейс IScannerTools
  • Интерфейс ISetOfObjectsEditor
  • Интерфейс IZIPArchive


Перечисление TQueryPart

(одним файлом)
Перечисление TQueryPart
1type
2  TQueryPart = (qpWhat, qpWhere, qpOrder, qpGroup, qpHaving, qpInnerJoin,
3    qpOuterJoin);

Или

01type
02  TQueryPart = TOleEnum;
03const
04  qpWhat = $00000000;
05  qpWhere = $00000001;
06  qpOrder = $00000002;
07  qpGroup = $00000003;
08  qpHaving = $00000004;
09  qpInnerJoin = $00000005;
10  qpOuterJoin = $00000006;

Элементы перечисления:

Имя | Значение | Назначение
qpWhat | 0 |
qpWhere | 1 |
qpOrder | 2 |
qpGroup | 3 |
qpHaving | 4 |
qpInnerJoin | 5 |
qpOuterJoin | 6 |


Перечисление TQuerySpecial

(одним файлом)
Перечисление TQuerySpecial
1type
2  TQuerySpecial = (qsNone, qsObjectID, qsParentID, qsHasChildren,
3    qsFilterCondition, qsUplink, qsRootOnly, qsDescending, qsCount, qsSum, qsMin,
4    qsMax, qsAverage, qsMasterLink, qsSelectedOnly, qsDistinct, qsViewCondition,
5    qsCaseInsensitive, qsAsString, qsListed, qsName, qsDescription, qsFunction,
6    qsCountDistinct, qsBoolean, qsExact, qsSearchIndex, qsOptimizationParameters);

Или

01type
02  TQuerySpecial = TOleEnum;
03const
04  qsNone = $00000000;
05  qsObjectID = $00000001;
06  qsParentID = $00000002;
07  qsHasChildren = $00000003;
08  qsFilterCondition = $00000004;
09  qsUplink = $00000005;
10  qsRootOnly = $00000006;
11  qsDescending = $00000007;
12  qsCount = $00000008;
13  qsSum = $00000009;
14  qsMin = $0000000A;
15  qsMax = $0000000B;
16  qsAverage = $0000000C;
17  qsMasterLink = $0000000D;
18  qsSelectedOnly = $0000000E;
19  qsDistinct = $0000000F;
20  qsViewCondition = $00000010;
21  qsCaseInsensitive = $00000011;
22  qsAsString = $00000012;
23  qsListed = $00000013;
24  qsName = $00000014;
25  qsDescription = $00000015;
26  qsFunction = $00000016;
27  qsCountDistinct = $00000017;
28  qsBoolean = $00000018;
29  qsExact = $00000019;
30  qsSearchIndex = $0000001A;
31  qsOptimizationParameters = $0000001B;

Элементы перечисления:

Имя | Значение | Назначение
qsNone | 0 |
qsObjectID | 1 |
qsParentID | 2 |
qsHasChildren | 3 |
qsFilterCondition | 4 |
qsUplink | 5 |
qsRootOnly | 6 |
qsDescending | 7 |
qsCount | 8 |
qsSum | 9 |
qsMin | 10 |
qsMax | 11 |
qsAverage | 12 |
qsMasterLink | 13 |
qsSelectedOnly | 14 |
qsDistinct | 15 |
qsViewCondition | 16 |
qsCaseInsensitive | 17 |
qsAsString | 18 |
qsListed | 19 |
qsName | 20 |
qsDescription | 21 |
qsFunction | 22 |
qsCountDistinct | 23 |
qsBoolean | 24 |
qsExact | 25 |
qsSearchIndex | 26 |
qsOptimizationParameters | 27 |


Интерфейс IButton

(раздел целиком) (одним файлом)
Интерфейс IButton

1type
2  IButton = interface(IDispatch)
3    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
4    function Get_Enabled: WordBool; safecall;
5    procedure Set_Enabled(Value: WordBool); safecall;
6    function Name: WideString; safecall;
7    procedure Click; safecall;
8    property Enabled: WordBool read Get_Enabled write Set_Enabled;
9  end;
  • Свойства
  • Метод Click
  • Метод Name


Свойства

(одним файлом)
Свойства

Свойства интерфейса IButton:

Имя | Тип | Доступ | Назначение
Enabled | WordBool | Чтение/Запись |


Метод Click

(одним файлом)
Метод Click

Метод интерфейса IButton.

procedure IButton.Click;

Метод не имеет параметров.


Метод Name

(одним файлом)
Метод Name

Метод интерфейса IButton.

function IButton.Name: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.


Интерфейс IContext

(раздел целиком) (одним файлом)
Интерфейс IContext

001type
002  IContext = interface(IDispatch)
003    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
004    function Get_ContextObject: IDispatch; safecall;
005    function Get_UserName: WideString; safecall;
006    function Get_NegotiateAuth: WordBool; safecall;
007    function Get_Language: WideString; safecall;
008    procedure Set_Language(Value: WideString); safecall;
009    function Get_TimeBias: Double; safecall;
010    function getName(ID: OleVariant): WideString; safecall;
011    function getDescription(ID: OleVariant): WideString; safecall;
012    function getPropValue(const ClassName: WideString; const PropName: WideString;
013      ID: OleVariant): OleVariant; safecall;
014    procedure setPropValue(const ClassName: WideString; const PropName: WideString;
015      ID: OleVariant; Value: OleVariant); safecall;
016    procedure getPropValues(const ClassName: WideString;
017      const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
018      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
019    procedure setPropValues(const ClassName: WideString;
020      const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
021      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
022    function createDataSet(const TargetClassName: WideString): IContextDataSet; safecall;
023    function select(const ClassName: WideString; QueryItems: OleVariant): IDispatch; safecall;
024    function executeMethod(const ClassName: WideString;
025      const MethodName: WideString; Params: OleVariant): OleVariant; safecall;
026    function getClass(const ClassName: WideString): WideString; safecall;
027    function enumerationItem(ItemIdentifier: OleVariant): WideString; safecall;
028    function getResource(const Name: WideString): WideString; safecall;
029    function bulkInsert(const ClassName: WideString;
030      const Data: IDispatch): IContextDataSet; safecall;
031    function PreProcessScript(const Script: WideString; Indent: WordBool;
032      const CommentMark: WideString): WideString; safecall;
033    function executeReport(const ClassName: WideString;
034      const TemplateName: WideString; Params: OleVariant): IDispatch; safecall;
035    procedure saveReport(const ClassName: WideString;
036      const TemplateName: WideString; Params: OleVariant; const FileName: WideString); safecall;
037    function Get_Variable(const Name: WideString; Persistent: WordBool): OleVariant; safecall;
038    procedure Set_Variable(const Name: WideString; Persistent: WordBool;
039      Value: OleVariant); safecall;
040    function DebugString(const Message: WideString): WideString; safecall;
041    procedure raiseManagedException(const ExceptionMessage: WideString); safecall;
042    function createGUID: WideString; safecall;
043    function getTempFileName(const Extension: WideString): WideString; safecall;
044    function HasUI: WordBool; safecall;
045    function Handle: Integer; safecall;
046    procedure processStart(const Description: WideString; ItemCount: Integer;
047      CanAbort: WordBool); safecall;
048    function processStep: WordBool; safecall;
049    procedure processStop; safecall;
050    procedure Sleep(MSecs: Integer); safecall;
051    function executeConsoleProcess(const CommandLine: WideString;
052      MaxDuration: Integer; const OutputData: OleVariant): Integer; safecall;
053    function downloadData(const Host: WideString; const Url: WideString;
054      const UserName: WideString; const Password: WideString;
055      NegotiateAuth: WordBool; PostData: OleVariant;
056      const PostContentType: WideString; PostDataIsBinary: WordBool;
057      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant; safecall;
058    function LineBreak: WideString; safecall;
059    function Transliterate(const Value: WideString): WideString; safecall;
060    procedure CompareLists(var List1: OleVariant; var List2: OleVariant;
061      const Delimiter: WideString; CaseSensitive: WordBool); safecall;
062    function parseJSON(const JSON: WideString): WideString; safecall;
063    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch; safecall;
064    function createBinaryData: IDispatch; safecall;
065    function getCRC(Data: OleVariant): WideString; safecall;
066    function buildNamedFile(const Data: IDispatch;
067      const StoredFileName: WideString; Propmpt: WordBool;
068      Compress: WordBool): IDispatch; safecall;
069    procedure parseNamedFile(NamedFile: OleVariant; out FileName: OleVariant;
070      out Data: OleVariant); safecall;
071    function createRaster: IDispatch; safecall;
072    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
073    function getOleObject(const ClassID: WideString;
074      const AccessibleFileName: WideString): IDispatch; safecall;
075    function PlaceDataSet(const Range: IDispatch; const DataSet: IContextDataSet;
076      ShiftRows: WordBool; ShiftColumns: WordBool): Integer; safecall;
077    procedure ExportObject(var Document: OleVariant; const ID: WideString;
078      const ClassID: WideString); safecall;
079    function createZIPArchive: IDispatch; safecall;
080    function callRoutine(const ClassName: WideString;
081      const RoutineName: WideString; var RetValue: OleVariant;
082      const ScriptPart: OleVariant): WordBool; safecall;
083    function selectVaue(const ClassDomain: WideString;
084      const ExpressionContext: IUnknown; var Value: OleVariant): WordBool; safecall;
085    function editValues(const ValuesList: WideString; const Title: WideString;
086      UseTabs: WordBool; HideOKButton: WordBool;
087      const ScriptPart: OleVariant): WordBool; safecall;
088    function MsgBox(const Prompt: WideString; Buttons: LongWord;
089      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
090    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
091      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
092    procedure showView(const ViewName: WideString; Key: OleVariant;
093      const DetailPropertyName: WideString); safecall;
094    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
095      ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
096      TakeActionsFromView: OleVariant); safecall;
097    procedure SaveExternalDataToFolder(const Resource: WideString;
098      const Folder: WideString); safecall;
099    function PerformAsyncTask(ID: OleVariant): WordBool; safecall;
100    procedure RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
101      ThreadCount: Integer); safecall;
102    function MainHandle: Integer; safecall;
103    function IsHTMLDocumentSafe(const HTML: WideString): WordBool; safecall;
104    function EnsafeHTMLDocument(const HTML: WideString; RemoveHead: WordBool;
105      Format: WordBool; PureXML: WordBool): WideString; safecall;
106    property ContextObject: IDispatch read Get_ContextObject;
107    property UserName: WideString read Get_UserName;
108    property NegotiateAuth: WordBool read Get_NegotiateAuth;
109    property Language: WideString read Get_Language write Set_Language;
110    property TimeBias: Double read Get_TimeBias;
111    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant
112      read Get_Variable write Set_Variable;
113  end;
  • Свойства
  • Метод BinaryToBitmap
  • Метод buildNamedFile
  • Метод bulkInsert
  • Метод callRoutine
  • Метод CompareLists
  • Метод ConvertExcel
  • Метод createBinaryData
  • Метод createDataSet
  • Метод createGUID
  • Метод createRaster
  • Метод createZIPArchive
  • Метод DebugString
  • Метод downloadData
  • Метод editValues
  • Метод EnsafeHTMLDocument
  • Метод enumerationItem
  • Метод executeConsoleProcess
  • Метод executeMethod
  • Метод executeReport
  • Метод ExportObject
  • Метод getClass
  • Метод getCRC
  • Метод getDescription
  • Метод getName
  • Метод getOleObject
  • Метод getPropValue
  • Метод getPropValues
  • Метод getResource
  • Метод getTempFileName
  • Метод Handle
  • Метод HasUI
  • Метод IsHTMLDocumentSafe
  • Метод LineBreak
  • Метод MainHandle
  • Метод MsgBox
  • Метод parseJSON
  • Метод parseNamedFile
  • Метод PerformAsyncTask
  • Метод PlaceDataSet
  • Метод PreProcessScript
  • Метод processStart
  • Метод processStep
  • Метод processStop
  • Метод raiseManagedException
  • Метод RebuildTextIndex
  • Метод SaveExternalDataToFolder
  • Метод saveReport
  • Метод select
  • Метод selectVaue
  • Метод setPropValue
  • Метод setPropValues
  • Метод showDataSet
  • Метод ShowMsgBox
  • Метод showView
  • Метод Sleep
  • Метод Transliterate


Свойства

(одним файлом)
Свойства

Свойства интерфейса IContext:

Имя | Тип | Доступ | Назначение
ContextObject | IDispatch | Только для чтения |
Language | WideString | Чтение/Запись |
NegotiateAuth | WordBool | Только для чтения |
TimeBias | Double | Только для чтения |
UserName | WideString | Только для чтения |
Variable[const Name: WideString, Persistent: WordBool] | OleVariant | Чтение/Запись |


Метод BinaryToBitmap

(одним файлом)
Метод BinaryToBitmap

Метод интерфейса IContext.

function IContext.BinaryToBitmap(const Data: IDispatch): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Data | IDispatch | Да |

Замечания:

Возвращает значение типа IDispatch.


Метод buildNamedFile

(одним файлом)
Метод buildNamedFile

Метод интерфейса IContext.

1function IContext.buildNamedFile(const Data: IDispatch;
2  const StoredFileName: WideString; Propmpt: WordBool;
3  Compress: WordBool): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Data | IDispatch | Да |
StoredFileName | WideString | Да |
Propmpt | WordBool | Да |
Compress | WordBool | Да |

Замечания:

Возвращает значение типа IDispatch.


Метод bulkInsert

(одним файлом)
Метод bulkInsert

Метод интерфейса IContext.

1function IContext.bulkInsert(const ClassName: WideString;
2  const Data: IDispatch): IContextDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
Data | IDispatch | Да |

Замечания:

Возвращает значение типа IContextDataSet.

См. также
  • Интерфейс IContextDataSet


Метод callRoutine

(одним файлом)
Метод callRoutine

Метод интерфейса IContext.

1function IContext.callRoutine(const ClassName: WideString;
2  const RoutineName: WideString; var RetValue: OleVariant;
3  const ScriptPart: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
RoutineName | WideString | Да |
RetValue | OleVariant | Нет |
ScriptPart | OleVariant | Нет |

Замечания:

Возвращает значение типа WordBool.


Метод CompareLists

(одним файлом)
Метод CompareLists

Метод интерфейса IContext.

1procedure IContext.CompareLists(var List1: OleVariant; var List2: OleVariant;
2  const Delimiter: WideString; CaseSensitive: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
List1 | OleVariant | Да |
List2 | OleVariant | Да |
Delimiter | WideString | Да |
CaseSensitive | WordBool | Да |


Метод ConvertExcel

(одним файлом)
Метод ConvertExcel

Метод интерфейса IContext.

1function IContext.ConvertExcel(Source: OleVariant;
2  const Format: WideString): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Source | OleVariant | Да |
Format | WideString | Да |

Замечания:

Возвращает значение типа IDispatch.


Метод createBinaryData

(одним файлом)
Метод createBinaryData

Метод интерфейса IContext.

function IContext.createBinaryData: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.


Метод createDataSet

(одним файлом)
Метод createDataSet

Метод интерфейса IContext.

function IContext.createDataSet(const TargetClassName: WideString): IContextDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
TargetClassName | WideString | Да |

Замечания:

Возвращает значение типа IContextDataSet.

См. также
  • Интерфейс IContextDataSet


Метод createGUID

(одним файлом)
Метод createGUID

Метод интерфейса IContext.

function IContext.createGUID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.


Метод createRaster

(одним файлом)
Метод createRaster

Метод интерфейса IContext.

function IContext.createRaster: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.


Метод createZIPArchive

(одним файлом)
Метод createZIPArchive

Метод интерфейса IContext.

function IContext.createZIPArchive: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.


Метод DebugString

(одним файлом)
Метод DebugString

Метод интерфейса IContext.

function IContext.DebugString(const Message: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Message | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Метод downloadData

(одним файлом)
Метод downloadData

Метод интерфейса IContext.

1function IContext.downloadData(const Host: WideString; const Url: WideString;
2  const UserName: WideString; const Password: WideString;
3  NegotiateAuth: WordBool; PostData: OleVariant;
4  const PostContentType: WideString; PostDataIsBinary: WordBool;
5  CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Host | WideString | Да |
Url | WideString | Да |
UserName | WideString | Да |
Password | WideString | Да |
NegotiateAuth | WordBool | Да |
PostData | OleVariant | Да |
PostContentType | WideString | Да |
PostDataIsBinary | WordBool | Да |
CanCache | WordBool | Да |
NewSession | WordBool | Да |
TimeOut | Integer | Да |

Замечания:

Возвращает значение типа OleVariant.


Метод editValues

(одним файлом)
Метод editValues

Метод интерфейса IContext.

1function IContext.editValues(const ValuesList: WideString;
2  const Title: WideString; UseTabs: WordBool; HideOKButton: WordBool;
3  const ScriptPart: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ValuesList | WideString | Да |
Title | WideString | Да |
UseTabs | WordBool | Да |
HideOKButton | WordBool | Да |
ScriptPart | OleVariant | Нет |

Замечания:

Возвращает значение типа WordBool.


Метод EnsafeHTMLDocument

(одним файлом)
Метод EnsafeHTMLDocument

Метод интерфейса IContext.

1function IContext.EnsafeHTMLDocument(const HTML: WideString;
2  RemoveHead: WordBool; Format: WordBool; PureXML: WordBool): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
HTML | WideString | Да |
RemoveHead | WordBool | Да |
Format | WordBool | Да |
PureXML | WordBool | Да |

Замечания:

Возвращает значение типа WideString.


Метод enumerationItem

(одним файлом)
Метод enumerationItem

Метод интерфейса IContext.

function IContext.enumerationItem(ItemIdentifier: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ItemIdentifier | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.


Метод executeConsoleProcess

(одним файлом)
Метод executeConsoleProcess

Метод интерфейса IContext.

1function IContext.executeConsoleProcess(const CommandLine: WideString;
2  MaxDuration: Integer; const OutputData: OleVariant): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
CommandLine | WideString | Да |
MaxDuration | Integer | Да |
OutputData | OleVariant | Да |

Замечания:

Возвращает значение типа Integer.


Метод executeMethod

(одним файлом)
Метод executeMethod

Метод интерфейса IContext.

1function IContext.executeMethod(const ClassName: WideString;
2  const MethodName: WideString; Params: OleVariant): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
MethodName | WideString | Да |
Params | OleVariant | Да |

Замечания:

Возвращает значение типа OleVariant.


Метод executeReport

(одним файлом)
Метод executeReport

Метод интерфейса IContext.

1function IContext.executeReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
TemplateName | WideString | Да |
Params | OleVariant | Да |

Замечания:

Возвращает значение типа IDispatch.


Метод ExportObject

(одним файлом)
Метод ExportObject

Метод интерфейса IContext.

1procedure IContext.ExportObject(var Document: OleVariant; const ID: WideString;
2  const ClassID: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Document | OleVariant | Да |
ID | WideString | Да |
ClassID | WideString | Да |


Метод getClass

(одним файлом)
Метод getClass

Метод интерфейса IContext.

function IContext.getClass(const ClassName: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Метод getCRC

(одним файлом)
Метод getCRC

Метод интерфейса IContext.

function IContext.getCRC(Data: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.


Метод getDescription

(одним файлом)
Метод getDescription

Метод интерфейса IContext.

function IContext.getDescription(ID: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.


Метод getName

(одним файлом)
Метод getName

Метод интерфейса IContext.

function IContext.getName(ID: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.


Метод getOleObject

(одним файлом)
Метод getOleObject

Метод интерфейса IContext.

1function IContext.getOleObject(const ClassID: WideString;
2  const AccessibleFileName: WideString): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassID | WideString | Да |
AccessibleFileName | WideString | Да |

Замечания:

Возвращает значение типа IDispatch.


Метод getPropValue

(одним файлом)
Метод getPropValue

Метод интерфейса IContext.

1function IContext.getPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
ID | OleVariant | Да |

Замечания:

Возвращает значение типа OleVariant.


Метод getPropValues

(одним файлом)
Метод getPropValues

Метод интерфейса IContext.

1procedure IContext.getPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
IDS | OleVariant | Да |
OnValueEvent | OleVariant | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |


Метод getResource

(одним файлом)
Метод getResource

Метод интерфейса IContext.

function IContext.getResource(const Name: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Метод getTempFileName

(одним файлом)
Метод getTempFileName

Метод интерфейса IContext.

function IContext.getTempFileName(const Extension: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Extension | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Метод Handle

(одним файлом)
Метод Handle

Метод интерфейса IContext.

function IContext.Handle: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод HasUI

(одним файлом)
Метод HasUI

Метод интерфейса IContext.

function IContext.HasUI: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.


Метод IsHTMLDocumentSafe

(одним файлом)
Метод IsHTMLDocumentSafe

Метод интерфейса IContext.

function IContext.IsHTMLDocumentSafe(const HTML: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
HTML | WideString | Да |

Замечания:

Возвращает значение типа WordBool.


Метод LineBreak

(одним файлом)
Метод LineBreak

Метод интерфейса IContext.

function IContext.LineBreak: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.


Метод MainHandle

(одним файлом)
Метод MainHandle

Метод интерфейса IContext.

function IContext.MainHandle: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод MsgBox

(одним файлом)
Метод MsgBox

Метод интерфейса IContext.

1function IContext.MsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Prompt | WideString | Да |
Buttons | LongWord | Нет |
Title | WideString | Нет |
HelpFile | WideString | Нет |
Context | LongWord | Нет |

Замечания:

Возвращает значение типа Integer.


Метод parseJSON

(одним файлом)
Метод parseJSON

Метод интерфейса IContext.

function IContext.parseJSON(const JSON: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
JSON | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Метод parseNamedFile

(одним файлом)
Метод parseNamedFile

Метод интерфейса IContext.

1procedure IContext.parseNamedFile(NamedFile: OleVariant;
2  out FileName: OleVariant; out Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
NamedFile | OleVariant | Да |
FileName | OleVariant | Да |
Data | OleVariant | Да |


Метод PerformAsyncTask

(одним файлом)
Метод PerformAsyncTask

Метод интерфейса IContext.

function IContext.PerformAsyncTask(ID: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WordBool.


Метод PlaceDataSet

(одним файлом)
Метод PlaceDataSet

Метод интерфейса IContext.

1function IContext.PlaceDataSet(const Range: IDispatch;
2  const DataSet: IContextDataSet; ShiftRows: WordBool;
3  ShiftColumns: WordBool): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Range | IDispatch | Да |
DataSet | IContextDataSet | Да |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |

Замечания:

Возвращает значение типа Integer.

См. также
  • Интерфейс IContextDataSet


Метод PreProcessScript

(одним файлом)
Метод PreProcessScript

Метод интерфейса IContext.

1function IContext.PreProcessScript(const Script: WideString; Indent: WordBool;
2  const CommentMark: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Script | WideString | Да |
Indent | WordBool | Да |
CommentMark | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Метод processStart

(одним файлом)
Метод processStart

Метод интерфейса IContext.

1procedure IContext.processStart(const Description: WideString;
2  ItemCount: Integer; CanAbort: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Description | WideString | Да |
ItemCount | Integer | Нет |
CanAbort | WordBool | Нет |


Метод processStep

(одним файлом)
Метод processStep

Метод интерфейса IContext.

function IContext.processStep: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.


Метод processStop

(одним файлом)
Метод processStop

Метод интерфейса IContext.

procedure IContext.processStop;

Метод не имеет параметров.


Метод raiseManagedException

(одним файлом)
Метод raiseManagedException

Метод интерфейса IContext.

procedure IContext.raiseManagedException(const ExceptionMessage: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ExceptionMessage | WideString | Да |


Метод RebuildTextIndex

(одним файлом)
Метод RebuildTextIndex

Метод интерфейса IContext.

1procedure IContext.RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
2  ThreadCount: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
ClassID | OleVariant | Да |
FieldID | OleVariant | Да |
ThreadCount | Integer | Да |


Метод SaveExternalDataToFolder

(одним файлом)
Метод SaveExternalDataToFolder

Метод интерфейса IContext.

1procedure IContext.SaveExternalDataToFolder(const Resource: WideString;
2  const Folder: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Resource | WideString | Да |
Folder | WideString | Да |


Метод saveReport

(одним файлом)
Метод saveReport

Метод интерфейса IContext.

1procedure IContext.saveReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant; const FileName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
TemplateName | WideString | Да |
Params | OleVariant | Да |
FileName | WideString | Да |


Метод select

(одним файлом)
Метод select

Метод интерфейса IContext.

1function IContext.select(const ClassName: WideString;
2  QueryItems: OleVariant): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
QueryItems | OleVariant | Да |

Замечания:

Возвращает значение типа IDispatch.


Метод selectVaue

(одним файлом)
Метод selectVaue

Метод интерфейса IContext.

1function IContext.selectVaue(const ClassDomain: WideString;
2  const ExpressionContext: IUnknown; var Value: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ClassDomain | WideString | Да |
ExpressionContext | IUnknown | Да |
Value | OleVariant | Да |

Замечания:

Возвращает значение типа WordBool.


Метод setPropValue

(одним файлом)
Метод setPropValue

Метод интерфейса IContext.

1procedure IContext.setPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant; Value: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
ID | OleVariant | Да |
Value | OleVariant | Да |


Метод setPropValues

(одним файлом)
Метод setPropValues

Метод интерфейса IContext.

1procedure IContext.setPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
IDS | OleVariant | Да |
OnValueNeededEvent | OleVariant | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |


Метод showDataSet

(одним файлом)
Метод showDataSet

Метод интерфейса IContext.

1procedure IContext.showDataSet(const DataSet: ContextDataSet;
2  const Caption: WideString; ColumnCaptions: OleVariant;
3  ColumnOnChangeHandlers: OleVariant; TakeActionsFromView: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
DataSet | ContextDataSet | Да |
Caption | WideString | Да |
ColumnCaptions | OleVariant | Да |
ColumnOnChangeHandlers | OleVariant | Да |
TakeActionsFromView | OleVariant | Да |


Метод ShowMsgBox

(одним файлом)
Метод ShowMsgBox

Метод интерфейса IContext.

1function IContext.ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Prompt | WideString | Да |
Buttons | LongWord | Нет |
Title | WideString | Нет |
HelpFile | WideString | Нет |
Context | LongWord | Нет |

Замечания:

Возвращает значение типа Integer.


Метод showView

(одним файлом)
Метод showView

Метод интерфейса IContext.

1procedure IContext.showView(const ViewName: WideString; Key: OleVariant;
2  const DetailPropertyName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ViewName | WideString | Да |
Key | OleVariant | Да |
DetailPropertyName | WideString | Да |


Метод Sleep

(одним файлом)
Метод Sleep

Метод интерфейса IContext.

procedure IContext.Sleep(MSecs: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
MSecs | Integer | Да |


Метод Transliterate

(одним файлом)
Метод Transliterate

Метод интерфейса IContext.

function IContext.Transliterate(const Value: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Value | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Интерфейс IContextDataSet

(раздел целиком) (одним файлом)
Интерфейс IContextDataSet

01type
02  IContextDataSet = interface(IDispatch)
03    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
04    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
05      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant); safecall;
06    function Eof: WordBool; safecall;
07    function Field(const Name: WideString): OleVariant; safecall;
08    function FieldCount: Integer; safecall;
09    function FieldName(Index: Integer): WideString; safecall;
10    procedure Next; safecall;
11    procedure Split(OnRowEvent: OleVariant; ChunkSize: Integer;
12      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
13    function AsJSON: WideString; safecall;
14    function AsXML: WideString; safecall;
15    function AsBinaryData: IDispatch; safecall;
16  end;
  • Метод AddQueryItem
  • Метод AsBinaryData
  • Метод AsJSON
  • Метод AsXML
  • Метод Eof
  • Метод Field
  • Метод FieldCount
  • Метод FieldName
  • Метод Next
  • Метод Split


Метод AddQueryItem

(одним файлом)
Метод AddQueryItem

Метод интерфейса IContextDataSet.

1procedure IContextDataSet.AddQueryItem(Part: TQueryPart;
2  const Name: WideString; Value: OleVariant; Special: TQuerySpecial;
3  Context: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Part | TQueryPart | Да |
Name | WideString | Да |
Value | OleVariant | Нет |
Special | TQuerySpecial | Нет |
Context | OleVariant | Нет |

См. также
  • Перечисление TQueryPart
  • Перечисление TQuerySpecial


Метод AsBinaryData

(одним файлом)
Метод AsBinaryData

Метод интерфейса IContextDataSet.

function IContextDataSet.AsBinaryData: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.


Метод AsJSON

(одним файлом)
Метод AsJSON

Метод интерфейса IContextDataSet.

function IContextDataSet.AsJSON: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.


Метод AsXML

(одним файлом)
Метод AsXML

Метод интерфейса IContextDataSet.

function IContextDataSet.AsXML: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.


Метод Eof

(одним файлом)
Метод Eof

Метод интерфейса IContextDataSet.

function IContextDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.


Метод Field

(одним файлом)
Метод Field

Метод интерфейса IContextDataSet.

function IContextDataSet.Field(const Name: WideString): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа OleVariant.


Метод FieldCount

(одним файлом)
Метод FieldCount

Метод интерфейса IContextDataSet.

function IContextDataSet.FieldCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод FieldName

(одним файлом)
Метод FieldName

Метод интерфейса IContextDataSet.

function IContextDataSet.FieldName(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.


Метод Next

(одним файлом)
Метод Next

Метод интерфейса IContextDataSet.

procedure IContextDataSet.Next;

Метод не имеет параметров.


Метод Split

(одним файлом)
Метод Split

Метод интерфейса IContextDataSet.

1procedure IContextDataSet.Split(OnRowEvent: OleVariant; ChunkSize: Integer;
2  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
OnRowEvent | OleVariant | Да |
ChunkSize | Integer | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |


Интерфейс IContextExpressionInfo

(раздел целиком) (одним файлом)
Интерфейс IContextExpressionInfo

1type
2  IContextExpressionInfo = interface(IUnknown)
3    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
4    function LookupExpressionContext(const Identifier: WideString;
5      out DomainID: WideString; out Value: WideString): WordBool; safecall;
6    procedure SerializeExpressionContext(const RootNode: IDispatch); safecall;
7  end;
  • Метод LookupExpressionContext
  • Метод SerializeExpressionContext


Метод LookupExpressionContext

(одним файлом)
Метод LookupExpressionContext

Метод интерфейса IContextExpressionInfo.

1function IContextExpressionInfo.LookupExpressionContext(const Identifier: WideString;
2  out DomainID: WideString; out Value: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Identifier | WideString | Да |
DomainID | WideString | Да |
Value | WideString | Да |

Замечания:

Возвращает значение типа WordBool.


Метод SerializeExpressionContext

(одним файлом)
Метод SerializeExpressionContext

Метод интерфейса IContextExpressionInfo.

procedure IContextExpressionInfo.SerializeExpressionContext(const RootNode: IDispatch);

Параметры:

Имя | Тип | Обязательно | Значение
RootNode | IDispatch | Да |


Интерфейс IControl

(раздел целиком) (одним файлом)
Интерфейс IControl

01type
02  IControl = interface(IDispatch)
03    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
04    function Name: WideString; safecall;
05    function Get_Value: OleVariant; safecall;
06    procedure Set_Value(Value: OleVariant); safecall;
07    function Get_ReadOnly: WordBool; safecall;
08    procedure Set_ReadOnly(Value: WordBool); safecall;
09    function Get_IsValid: WordBool; safecall;
10    procedure Set_IsValid(Value: WordBool); safecall;
11    function Get_IsEmpty: WordBool; safecall;
12    procedure SetHint(const Value: WideString); safecall;
13    procedure RefreshLinkedView; safecall;
14    function Get_Visible: WordBool; safecall;
15    property Value: OleVariant read Get_Value write Set_Value;
16    property ReadOnly: WordBool read Get_ReadOnly write Set_ReadOnly;
17    property IsValid: WordBool read Get_IsValid write Set_IsValid;
18    property IsEmpty: WordBool read Get_IsEmpty;
19    property Visible: WordBool read Get_Visible;
20  end;
  • Свойства
  • Метод Name
  • Метод RefreshLinkedView
  • Метод SetHint


Свойства

(одним файлом)
Свойства

Свойства интерфейса IControl:

Имя | Тип | Доступ | Назначение
IsEmpty | WordBool | Только для чтения |
IsValid | WordBool | Чтение/Запись |
ReadOnly | WordBool | Чтение/Запись |
Value | OleVariant | Чтение/Запись |
Visible | WordBool | Только для чтения |


Метод Name

(одним файлом)
Метод Name

Метод интерфейса IControl.

function IControl.Name: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.


Метод RefreshLinkedView

(одним файлом)
Метод RefreshLinkedView

Метод интерфейса IControl.

procedure IControl.RefreshLinkedView;

Метод не имеет параметров.


Метод SetHint

(одним файлом)
Метод SetHint

Метод интерфейса IControl.

procedure IControl.SetHint(const Value: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Value | WideString | Да |


Интерфейс IExceptionHandler

(раздел целиком) (одним файлом)
Интерфейс IExceptionHandler

1type
2  IExceptionHandler = interface(IDispatch)
3    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
4    procedure HandleException(ContextObject: OleVariant; const Message: WideString;
5      const ExtentedInfo: WideString; SupportServiceData: OleVariant); safecall;
6  end;
  • Метод HandleException


Метод HandleException

(одним файлом)
Метод HandleException

Метод интерфейса IExceptionHandler.

1procedure IExceptionHandler.HandleException(ContextObject: OleVariant;
2  const Message: WideString; const ExtentedInfo: WideString;
3  SupportServiceData: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
ContextObject | OleVariant | Да |
Message | WideString | Да |
ExtentedInfo | WideString | Да |
SupportServiceData | OleVariant | Да |


Интерфейс IExternalContext

(раздел целиком) (одним файлом)
Интерфейс IExternalContext

1type
2  IExternalContext = interface(IDispatch)
3    ['{EA2F1CDA-53F6-40E9-A2B7-0A80AB84D177}']
4    procedure Connect(const Database: WideString); safecall;
5  end;
  • Метод Connect


Метод Connect

(одним файлом)
Метод Connect

Метод интерфейса IExternalContext.

procedure IExternalContext.Connect(const Database: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Database | WideString | Да |


Интерфейс IFormContext

(раздел целиком) (одним файлом)
Интерфейс IFormContext

01type
02  IFormContext = interface(IDispatch)
03    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
04    function ID: WideString; safecall;
05    function RoutineID: WideString; safecall;
06    function ControlCount: Integer; safecall;
07    function Get_Controls(Name: OleVariant): IControl; safecall;
08    function ControlExists(const Name: WideString): WordBool; safecall;
09    function ButtonCount: Integer; safecall;
10    function Get_Buttons(Name: OleVariant): IButton; safecall;
11    function Get_Enabled: WordBool; safecall;
12    procedure Set_Enabled(Value: WordBool); safecall;
13    function ChangedControl: OleVariant; safecall;
14    function ChangedControlName: WideString; safecall;
15    procedure Cancel; safecall;
16    function ParentForm: OleVariant; safecall;
17    procedure PreInitControl(const Name: WideString; Value: OleVariant); safecall;
18    procedure NavigatorNext; safecall;
19    procedure NavigatorPrevious; safecall;
20    function NavigatorCanNext: WordBool; safecall;
21    function NavigatorCanPrevious: WordBool; safecall;
22    procedure RefreshView(RefreshAll: WordBool); safecall;
23    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
24    property Controls[Name: OleVariant]: IControl read Get_Controls;
25    property Buttons[Name: OleVariant]: IButton read Get_Buttons;
26    property Enabled: WordBool read Get_Enabled write Set_Enabled;
27  end;
  • Свойства
  • Метод ButtonCount
  • Метод Cancel
  • Метод ChangedControl
  • Метод ChangedControlName
  • Метод ControlCount
  • Метод ControlExists
  • Метод ExpressionContextValue
  • Метод ID
  • Метод NavigatorCanNext
  • Метод NavigatorCanPrevious
  • Метод NavigatorNext
  • Метод NavigatorPrevious
  • Метод ParentForm
  • Метод PreInitControl
  • Метод RefreshView
  • Метод RoutineID


Свойства

(одним файлом)
Свойства

Свойства интерфейса IFormContext:

Имя | Тип | Доступ | Назначение
Buttons[Name: OleVariant] | IButton | Только для чтения |
Controls[Name: OleVariant] | IControl | Только для чтения |
Enabled | WordBool | Чтение/Запись |

См. также
  • Интерфейс IButton
  • Интерфейс IControl


Метод ButtonCount

(одним файлом)
Метод ButtonCount

Метод интерфейса IFormContext.

function IFormContext.ButtonCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод Cancel

(одним файлом)
Метод Cancel

Метод интерфейса IFormContext.

procedure IFormContext.Cancel;

Метод не имеет параметров.


Метод ChangedControl

(одним файлом)
Метод ChangedControl

Метод интерфейса IFormContext.

function IFormContext.ChangedControl: OleVariant;

Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.


Метод ChangedControlName

(одним файлом)
Метод ChangedControlName

Метод интерфейса IFormContext.

function IFormContext.ChangedControlName: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.


Метод ControlCount

(одним файлом)
Метод ControlCount

Метод интерфейса IFormContext.

function IFormContext.ControlCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод ControlExists

(одним файлом)
Метод ControlExists

Метод интерфейса IFormContext.

function IFormContext.ControlExists(const Name: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа WordBool.


Метод ExpressionContextValue

(одним файлом)
Метод ExpressionContextValue

Метод интерфейса IFormContext.

function IFormContext.ExpressionContextValue(const Name: WideString): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа OleVariant.


Метод ID

(одним файлом)
Метод ID

Метод интерфейса IFormContext.

function IFormContext.ID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.


Метод NavigatorCanNext

(одним файлом)
Метод NavigatorCanNext

Метод интерфейса IFormContext.

function IFormContext.NavigatorCanNext: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.


Метод NavigatorCanPrevious

(одним файлом)
Метод NavigatorCanPrevious

Метод интерфейса IFormContext.

function IFormContext.NavigatorCanPrevious: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.


Метод NavigatorNext

(одним файлом)
Метод NavigatorNext

Метод интерфейса IFormContext.

procedure IFormContext.NavigatorNext;

Метод не имеет параметров.


Метод NavigatorPrevious

(одним файлом)
Метод NavigatorPrevious

Метод интерфейса IFormContext.

procedure IFormContext.NavigatorPrevious;

Метод не имеет параметров.


Метод ParentForm

(одним файлом)
Метод ParentForm

Метод интерфейса IFormContext.

function IFormContext.ParentForm: OleVariant;

Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.


Метод PreInitControl

(одним файлом)
Метод PreInitControl

Метод интерфейса IFormContext.

procedure IFormContext.PreInitControl(const Name: WideString; Value: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |
Value | OleVariant | Да |


Метод RefreshView

(одним файлом)
Метод RefreshView

Метод интерфейса IFormContext.

procedure IFormContext.RefreshView(RefreshAll: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
RefreshAll | WordBool | Да |


Метод RoutineID

(одним файлом)
Метод RoutineID

Метод интерфейса IFormContext.

function IFormContext.RoutineID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.


Интерфейс IRaster

(раздел целиком) (одним файлом)
Интерфейс IRaster

01type
02  IRaster = interface(IDispatch)
03    ['{4F27D016-03C2-4D48-ABF7-FD547E859F79}']
04    function Get_Width: Integer; safecall;
05    procedure Set_Width(Value: Integer); safecall;
06    function Get_Height: Integer; safecall;
07    procedure Set_Height(Value: Integer); safecall;
08    function Get_DefaultColor: Integer; safecall;
09    procedure Set_DefaultColor(Value: Integer); safecall;
10    procedure Load(Src: OleVariant); safecall;
11    procedure SaveBitmap(Dst: OleVariant); safecall;
12    procedure SavePNG(Dst: OleVariant); safecall;
13    procedure SaveJPG(Dst: OleVariant; Quality: Integer); safecall;
14    procedure FlipVertical; safecall;
15    procedure FlipHorizontal; safecall;
16    procedure Rotate; safecall;
17    procedure Resize(NewWidth: Integer; NewHeight: Integer; Center: WordBool); safecall;
18    procedure Stretch(NewWidth: Integer; NewHeight: Integer); safecall;
19    procedure StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
20      MaxSize: OleVariant); safecall;
21    procedure Overlay(Src: OleVariant; X: Integer; Y: Integer; Width: Integer;
22      Height: Integer); safecall;
23    property Width: Integer read Get_Width write Set_Width;
24    property Height: Integer read Get_Height write Set_Height;
25    property DefaultColor: Integer read Get_DefaultColor write Set_DefaultColor;
26  end;
  • Свойства
  • Метод FlipHorizontal
  • Метод FlipVertical
  • Метод Load
  • Метод Overlay
  • Метод Resize
  • Метод Rotate
  • Метод SaveBitmap
  • Метод SaveJPG
  • Метод SavePNG
  • Метод Stretch
  • Метод StretchToSize


Свойства

(одним файлом)
Свойства

Свойства интерфейса IRaster:

Имя | Тип | Доступ | Назначение
DefaultColor | Integer | Чтение/Запись |
Height | Integer | Чтение/Запись |
Width | Integer | Чтение/Запись |


Метод FlipHorizontal

(одним файлом)
Метод FlipHorizontal

Метод интерфейса IRaster.

procedure IRaster.FlipHorizontal;

Метод не имеет параметров.


Метод FlipVertical

(одним файлом)
Метод FlipVertical

Метод интерфейса IRaster.

procedure IRaster.FlipVertical;

Метод не имеет параметров.


Метод Load

(одним файлом)
Метод Load

Метод интерфейса IRaster.

procedure IRaster.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |


Метод Overlay

(одним файлом)
Метод Overlay

Метод интерфейса IRaster.

1procedure IRaster.Overlay(Src: OleVariant; X: Integer; Y: Integer;
2  Width: Integer; Height: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |
X | Integer | Да |
Y | Integer | Да |
Width | Integer | Да |
Height | Integer | Да |


Метод Resize

(одним файлом)
Метод Resize

Метод интерфейса IRaster.

1procedure IRaster.Resize(NewWidth: Integer; NewHeight: Integer;
2  Center: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
NewWidth | Integer | Да |
NewHeight | Integer | Да |
Center | WordBool | Да |


Метод Rotate

(одним файлом)
Метод Rotate

Метод интерфейса IRaster.

procedure IRaster.Rotate;

Метод не имеет параметров.


Метод SaveBitmap

(одним файлом)
Метод SaveBitmap

Метод интерфейса IRaster.

procedure IRaster.SaveBitmap(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |


Метод SaveJPG

(одним файлом)
Метод SaveJPG

Метод интерфейса IRaster.

procedure IRaster.SaveJPG(Dst: OleVariant; Quality: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |
Quality | Integer | Да |


Метод SavePNG

(одним файлом)
Метод SavePNG

Метод интерфейса IRaster.

procedure IRaster.SavePNG(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |


Метод Stretch

(одним файлом)
Метод Stretch

Метод интерфейса IRaster.

procedure IRaster.Stretch(NewWidth: Integer; NewHeight: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
NewWidth | Integer | Да |
NewHeight | Integer | Да |


Метод StretchToSize

(одним файлом)
Метод StretchToSize

Метод интерфейса IRaster.

1procedure IRaster.StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
2  MaxSize: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
MaxWidth | OleVariant | Да |
MaxHeight | OleVariant | Да |
MaxSize | OleVariant | Да |


Интерфейс IScannerTools

(раздел целиком) (одним файлом)
Интерфейс IScannerTools

1type
2  IScannerTools = interface(IDispatch)
3    ['{FC1B3C9F-7DE9-4909-B57D-6D33E3B0A87A}']
4    function AcquireImage(Silent: WordBool): IDispatch; safecall;
5    function AcquirePDF: IDispatch; safecall;
6  end;
  • Метод AcquireImage
  • Метод AcquirePDF


Метод AcquireImage

(одним файлом)
Метод AcquireImage

Метод интерфейса IScannerTools.

function IScannerTools.AcquireImage(Silent: WordBool): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Silent | WordBool | Да |

Замечания:

Возвращает значение типа IDispatch.


Метод AcquirePDF

(одним файлом)
Метод AcquirePDF

Метод интерфейса IScannerTools.

function IScannerTools.AcquirePDF: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.


Интерфейс ISetOfObjectsEditor

(раздел целиком) (одним файлом)
Интерфейс ISetOfObjectsEditor

1type
2  ISetOfObjectsEditor = interface(IDispatch)
3    ['{6D3662A7-D9FF-4BD6-8D92-A4EA2058C74E}']
4    function Get_DomainName: WideString; safecall;
5    procedure Set_DomainName(Value: WideString); safecall;
6    function Get_SelectedCount: Integer; safecall;
7    property DomainName: WideString read Get_DomainName write Set_DomainName;
8    property SelectedCount: Integer read Get_SelectedCount;
9  end;
  • Свойства


Свойства

(одним файлом)
Свойства

Свойства интерфейса ISetOfObjectsEditor:

Имя | Тип | Доступ | Назначение
DomainName | WideString | Чтение/Запись |
SelectedCount | Integer | Только для чтения |


Интерфейс IZIPArchive

(раздел целиком) (одним файлом)
Интерфейс IZIPArchive

01type
02  IZIPArchive = interface(IDispatch)
03    ['{11C9400F-F262-4F72-882F-5AA5A4531591}']
04    procedure Load(Src: OleVariant); safecall;
05    procedure Save(Src: OleVariant); safecall;
06    function Get_FileCount: Integer; safecall;
07    function Get_FileName(Index: Integer): WideString; safecall;
08    function Get_FileData(Index: Integer): OleVariant; safecall;
09    procedure AddFile(const FileName: WideString; Data: OleVariant); safecall;
10    function Get_FileSize(Index: Integer): Int64; safecall;
11    function Get_FileDateTime(Index: Integer): TDateTime; safecall;
12    function Get_FileCRC(Index: Integer): WideString; safecall;
13    function Get_UTF8Support: WordBool; safecall;
14    procedure Set_UTF8Support(Value: WordBool); safecall;
15    property FileCount: Integer read Get_FileCount;
16    property FileName[Index: Integer]: WideString read Get_FileName;
17    property FileData[Index: Integer]: OleVariant read Get_FileData;
18    property FileSize[Index: Integer]: Int64 read Get_FileSize;
19    property FileDateTime[Index: Integer]: TDateTime read Get_FileDateTime;
20    property FileCRC[Index: Integer]: WideString read Get_FileCRC;
21    property UTF8Support: WordBool read Get_UTF8Support write Set_UTF8Support;
22  end;
  • Свойства
  • Метод AddFile
  • Метод Load
  • Метод Save


Свойства

(одним файлом)
Свойства

Свойства интерфейса IZIPArchive:

Имя | Тип | Доступ | Назначение
FileCRC[Index: Integer] | WideString | Только для чтения |
FileCount | Integer | Только для чтения |
FileData[Index: Integer] | OleVariant | Только для чтения |
FileDateTime[Index: Integer] | TDateTime | Только для чтения |
FileName[Index: Integer] | WideString | Только для чтения |
FileSize[Index: Integer] | Int64 | Только для чтения |
UTF8Support | WordBool | Чтение/Запись |


Метод AddFile

(одним файлом)
Метод AddFile

Метод интерфейса IZIPArchive.

procedure IZIPArchive.AddFile(const FileName: WideString; Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
FileName | WideString | Да |
Data | OleVariant | Да |


Метод Load

(одним файлом)
Метод Load

Метод интерфейса IZIPArchive.

procedure IZIPArchive.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |


Метод Save

(одним файлом)
Метод Save

Метод интерфейса IZIPArchive.

procedure IZIPArchive.Save(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |


Дополнительные интерфейсы

(раздел целиком) (одним файлом)
Дополнительные интерфейсы
  • Интерфейс IBinaryData


Интерфейс IBinaryData

(раздел целиком) (одним файлом)
Интерфейс IBinaryData

01type
02  IBinaryData = interface(IDispatch)
03    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
04    procedure Append(Src: OleVariant); safecall;
05    procedure Load(Src: OleVariant); safecall;
06    procedure Save(Dst: OleVariant); safecall;
07    function Size: LongWord; safecall;
08    procedure AppendData(Data: OleVariant; DataSize: LongWord); safecall;
09    procedure SetData(Data: OleVariant; DataSize: LongWord); safecall;
10    procedure GetData(Data: OleVariant); safecall;
11    function ToString(const Encoding: WideString): WideString; safecall;
12    procedure FromString(Data: OleVariant); safecall;
13    procedure AppendString(Data: OleVariant); safecall;
14    function ToBase64(Width: Integer): WideString; safecall;
15    procedure FromBase64(Data: OleVariant); safecall;
16    function ContentIsText: WordBool; safecall;
17  end;
  • Метод Append
  • Метод AppendData
  • Метод AppendString
  • Метод ContentIsText
  • Метод FromBase64
  • Метод FromString
  • Метод GetData
  • Метод Load
  • Метод Save
  • Метод SetData
  • Метод Size
  • Метод ToBase64
  • Метод ToString


Метод Append

(одним файлом)
Метод Append

Метод интерфейса IBinaryData.

procedure IBinaryData.Append(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |


Метод AppendData

(одним файлом)
Метод AppendData

Метод интерфейса IBinaryData.

procedure IBinaryData.AppendData(Data: OleVariant; DataSize: LongWord);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |
DataSize | LongWord | Да |


Метод AppendString

(одним файлом)
Метод AppendString

Метод интерфейса IBinaryData.

procedure IBinaryData.AppendString(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |


Метод ContentIsText

(одним файлом)
Метод ContentIsText

Метод интерфейса IBinaryData.

function IBinaryData.ContentIsText: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.


Метод FromBase64

(одним файлом)
Метод FromBase64

Метод интерфейса IBinaryData.

procedure IBinaryData.FromBase64(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |


Метод FromString

(одним файлом)
Метод FromString

Метод интерфейса IBinaryData.

procedure IBinaryData.FromString(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |


Метод GetData

(одним файлом)
Метод GetData

Метод интерфейса IBinaryData.

procedure IBinaryData.GetData(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |


Метод Load

(одним файлом)
Метод Load

Метод интерфейса IBinaryData.

procedure IBinaryData.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |


Метод Save

(одним файлом)
Метод Save

Метод интерфейса IBinaryData.

procedure IBinaryData.Save(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |


Метод SetData

(одним файлом)
Метод SetData

Метод интерфейса IBinaryData.

procedure IBinaryData.SetData(Data: OleVariant; DataSize: LongWord);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |
DataSize | LongWord | Да |


Метод Size

(одним файлом)
Метод Size

Метод интерфейса IBinaryData.

function IBinaryData.Size: LongWord;

Метод не имеет параметров.

Замечания:

Возвращает значение типа LongWord.


Метод ToBase64

(одним файлом)
Метод ToBase64

Метод интерфейса IBinaryData.

function IBinaryData.ToBase64(Width: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Width | Integer | Нет |

Замечания:

Возвращает значение типа WideString.


Метод ToString

(одним файлом)
Метод ToString

Метод интерфейса IBinaryData.

function IBinaryData.ToString(const Encoding: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Encoding | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Справочник по метаданным

(раздел целиком) (одним файлом)
Справочник по метаданным
  • Перечисление Resource strings (Ресурсные строки)
  • Перечисление TAggregateKind (Тип агрегата)
  • Перечисление TAsyncTaskStatus (Состояние задачи отложенного выполнения)
  • Перечисление TBlobSubtype (Подтип)
  • Перечисление TChangeAction (Действие при изменении)
  • Перечисление TComparisonType (Типы сравнения)
  • Перечисление TDateTimePart (Часть даты или времени)
  • Перечисление TDeleteRule (Правило удаления)
  • Перечисление TDuplicates (Дубликаты)
  • Перечисление TExcelOutputFormat (Формат результата отчета Excel)
  • Перечисление TExcelSheetKind (Тип листа Excel)
  • Перечисление TExternalDataProtocol (Протокол доступа к внешним данным)
  • Перечисление TFormViewLayout (Виды расположения)
  • Перечисление TInstantContactStatus (Статус контакта)
  • Перечисление TInstantMessageAttachmentType (Тип вложения мгновенного сообщения)
  • Перечисление TInstantMessageAttachmentType (None) (Тип вложения мгновенного сообщения (None))
  • Перечисление TNotificationType (Тип уведомления)
  • Перечисление TOutputColorMode (Режим цветопередачи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TRowColor (Цвет строки таблицы)
  • Перечисление TScope (Область видимости)
  • Перечисление TSecurityModel (Модели безопасности)
  • Перечисление TShowObjectInfoType (Тип представления объектов)
  • Перечисление TSortDirection (Направление сортировки)
  • Перечисление TTranslationStatus (Состояния перевода)
  • Перечисление TUserAccessMode (Режим доступа)
  • Перечисление TWordOutputFormat (Формат результата отчета Word)
  • Класс TAccessibleFile (Доступный файл)
  • Класс TAccessItem (Элементы доступа)
  • Класс TAccessProfile (Профили доступа)
  • Класс TAction (Действия)
  • Класс TActionContextProperty (Свойство контекста)
  • Класс TAsyncHandler (Обработчики отложенного выполнения)
  • Класс TAsyncHandlerAccess (Доступ к обработчикам отложенного выполнения)
  • Класс TAsyncTask (Задачи отложенного выполнения)
  • Класс TAsyncTaskParameterValue (Значения параметров задачи отложенного выполнения)
  • Класс TBanGroup (Группы запретов)
  • Класс TBanGroupAccess (Доступ к группам запретов)
  • Класс TBanGroupItem (Элементы группы запретов)
  • Класс TBlobDomain (Большие объекты)
  • Класс TBooleanDomain (Логические)
  • Класс TClass (Классы)
  • Класс TClassBan (Запрет на класс)
  • Класс TClassDomain (Ссылки на объекты)
  • Класс TClassMember (Члены класса)
  • Класс TCommandButton (Командные кнопки)
  • Класс TContextKey (Ключи контекстной помощи)
  • Класс TCustomButton (Кнопки)
  • Класс TCustomView (Абстрактное представление)
  • Класс TDataBase (Базы данных)
  • Класс TDateDomain (Даты)
  • Класс TDateTimeDomain (Даты со временем)
  • Класс TDependency (Зависимости)
  • Класс TDomain (Домены)
  • Класс TEnumerationDomain (Перечисления)
  • Класс TEnumerationItem (Элементы перечислений)
  • Класс TExcelAsyncTask (Задачи отложенного выполнения отчетов Excel)
  • Класс TExcelTemplate (Шаблоны отчетов Excel)
  • Класс TExternalDataDomain (Внешние данные)
  • Класс TExternalDataResource (Ресурсы внешних данных)
  • Класс TField (Поля)
  • Класс TFileNameDomain (Имена файлов)
  • Класс TFilmstripView (Представление-диафильм)
  • Класс TFloatDomain (Вещественные числа)
  • Класс TFolderNameDomain (Имена папок файловой системы)
  • Класс TForm (Формы)
  • Класс TFormAccess (Доступ к формам)
  • Класс TFormBan (Запрет на форму)
  • Класс TFormOption (Настройки формы)
  • Класс TFormView (Представления формы)
  • Класс TFormViewAction (Действие-форма)
  • Класс TImportedReplica (Импортированные реплики)
  • Класс TInlineExpression (Встраиваемое выражение)
  • Класс TInstantContact (Контакты)
  • Класс TInstantMessage (Сообщения)
  • Класс TInstantMessageAttachment (Сообщения с вложением)
  • Класс TIntegerDomain (Целые числа)
  • Класс TLanguage (Языки)
  • Класс TLanguageTranslation (Переводы)
  • Класс TMethod (Методы)
  • Класс TObject (Объекты)
  • Класс TObjectArchive (Архив объектов)
  • Класс TObjectCreator (Роли-создатели)
  • Класс TObjectHistory (История объектов)
  • Класс TObjectList (Списки)
  • Класс TObjectListItem (Элементы списков)
  • Класс TObjectSet (Множества объектов)
  • Класс TOleObjectMethod (Метод Ole-объекта)
  • Класс TOption (Настройки)
  • Класс TOptionValue (Значения настроек)
  • Класс TParameter (Параметры)
  • Класс TParameterHistory (Параметры вызовов)
  • Класс TParametersFormView (Представления формы параметров)
  • Класс TPDFTemplate (Шаблоны отчетов PDF)
  • Класс TProfile (Профили)
  • Класс TProfileEvent (События профиля)
  • Класс TProfileItem (Состав профиля)
  • Класс TProfileMethod (Методы профиля)
  • Класс TProfileStatistics (Статистика профиля)
  • Класс TProfileUser (Пользователи профиля)
  • Класс TProperty (Свойства)
  • Класс TPropertyBan (Запрет на свойство)
  • Класс TQueue (Очередь)
  • Класс TRole (Роли)
  • Класс TRoleMember (Пользователи в ролях)
  • Класс TRoutine (Подпрограмма)
  • Класс TRoutineAction (Программируемое действие)
  • Класс TRoutineBan (Запрет на подпрограмму)
  • Класс TRoutineHistory (Вызовы)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TSequence (Последовательности)
  • Класс TSessionHistory (Сессии)
  • Класс TStatement (Операторы)
  • Класс TStringBuilder (Шаблоны строк)
  • Класс TStringDomain (Строковые)
  • Класс TStringList (Список строк)
  • Класс TStringListItem (Элемент списка строк)
  • Класс TSystemMessage (Системные сообщения)
  • Класс TSystemMetadata (Системные метаданные)
  • Класс TTextIndex (Индекс текстового поиска)
  • Класс TTextIndexEntry (Вхождения индекса текстового поиска)
  • Класс TTimeDomain (Время)
  • Класс TTypedValue (Типизированные значения)
  • Класс TTypedValueButton (Кнопки на форме редактирования значений)
  • Класс TTypedValueView (Представления на форме редактирования значений)
  • Класс TUser (Пользователи)
  • Класс TUserNotification (Уведомления)
  • Класс TUserNotificationAddressee (Адресаты уведомлений)
  • Класс TUserNotificationShown (Показы уведомлений)
  • Класс TView (Представления)
  • Класс TViewAction (Действие-представление)
  • Класс TViewColumn (Колонки представлений)
  • Класс TViewCondition (Условия отбора)
  • Класс TViewPresentation (Виды)
  • Класс TViewPresentationAccess (Доступ к видам)
  • Класс TViewPresentationColumn (Колонки вида)
  • Класс TVisualGroup (Визуальные группы)
  • Класс TVisualGroupAccess (Доступ к визуальным группам)
  • Класс TVisualGroupForm (Форма визуальной группы)
  • Класс TVisualGroupItem (Элемент визуальной группы)
  • Класс TVisualGroupRoutine (Подпрограмма визуальной группы)
  • Класс TWordAsyncTask (Задачи отложенного выполнения отчетов Word)
  • Класс TWordTemplate (Шаблоны отчетов Word)
  • Класс TXSLTTemplate (Шаблоны отчетов XSLT)


Перечисление Resource strings (Ресурсные строки)

(одним файлом)
Перечисление Resource strings (Ресурсные строки)
01type
02  Resource strings = (rssRole, rssUser, rssIsMemberOf,
03    rssRoleCannotBeMemberOfItself, rssRoleCannotHavePrimaryRole, rssCanUse,
04    rssVirtualException, rssDataBaseIdentifierTooLong,
05    rssDefaultConstructorDescription, rssDefaultConstructorActionDescription,
06    rssDefaultDesctructorActionDescription, rssDefaultExcelActionDescription,
07    rssUsersActivityOn, rssHours, rssLocalCharacters, rssCannotLocalizeClass,
08    rssCannotLocalizeField, rssCannotTranslateUntranslatable,
09    rssCannotSendMessageToNotApprovedContact, rssCannotCreateContactForYourself,
10    rssCannotSendMessageForYourself, rssOverwriteFile, rssOverwriteAccessibleFile,
11    rssReplaceCurrentTemplate, rssReplaceAllImages, rssReplaceAllMethods,
12    rssReplaceAllTemplates, rssLoadingProcess, rssDoNotFogetMacroName,
13    rssCheckOleObjectMethodErrorMethodNotSpecified,
14    rssCheckOleObjectMethodErrorClassIDNotSpecified,
15    rssCheckOleObjectMethodErrorCodeLibraryNotSpecified,
16    rssCheckOleObjectMethodErrorCodeLibraryNotFound,
17    rssCheckOleObjectMethodErrorXMLIsNotValid,
18    rssCheckOleObjectMethodErrorProgIDNotImplemented,
19    rssCheckOleObjectMethodErrorMethodNotImplemented,
20    rssCheckOleObjectMethodErrorNoParameters,
21    rssCheckOleObjectMethodErrorNoIDParameter,
22    rssCheckOleObjectMethodErrorParameterNames,
23    rssCheckOleObjectMethodErrorParameterCount, rssLoadingResources, rssMethodCall,
24    rssDMLOperation, rssReplaceAllBlobsContent,
25    rssCheckXSLTTemplateErrorXMLIsNotValid,
26    rssCheckXSLTTemplateErrorNoTemplateData,
27    rssCheckXSLTTemplateErrorNoIDParameter, rssCheckXSLTTemplateErrorNoParameter,
28    rssCheckXSLTTemplateErrorExcessParameter,
29    rssCheckOleObjectMethodErrorNoFunctionFound,
30    rssCheckExcelTemplateErrorNoTemplateData, rssCheckExcelTemplateErrorNoMacro,
31    rssCheckExcelTemplateErrorNoFunctionFound,
32    rssCheckWordTemplateErrorNoTemplateData, rssCheckWordTemplateErrorNoMacro,
33    rssCheckWordTemplateErrorNoFunctionFound, rssCheckTemplates,
34    rssUnexpectedDatabase, rssCannotSaveDatabaseLanguage, rssDomainNotFound,
35    rssCheckOfficeTemplateErrorMissingParameters,
36    rssCheckOfficeTemplateErrorMissingImplementationParameter,
37    rssCheckOfficeTemplateErrorParametersCountMismatched,
38    rssCheckOfficeTemplateErrorNoFunctionFound,
39    rssCheckOfficeTemplateErrorProjectSyntaxIncorrect,
40    rssCheckOfficeTemplateErrorIncludedModuleNotFound,
41    rssCheckOfficeTemplateWarningMethodBodyTooLong,
42    rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped,
43    rssCheckOfficeTemplateWarningOptionValueIncorrect,
44    rssCannotPerformTaskAlreadyRunning, rssCannotPerformTaskDueToStatus,
45    rssAsyncMethodInstantSuccess, rssAsyncMethodInstantError,
46    rssAsyncReportInstantSuccess, rssAsyncReportInstantError,
47    rssViewCannotContainColumns, rssMasterNotDefined, rssAbstractDomain);

Или

01type
02  Resource strings = TOleEnum;
03const
04  rssRole = $00000000;
05  rssUser = $00000001;
06  rssIsMemberOf = $00000002;
07  rssRoleCannotBeMemberOfItself = $00000003;
08  rssRoleCannotHavePrimaryRole = $00000004;
09  rssCanUse = $00000005;
10  rssVirtualException = $00000006;
11  rssDataBaseIdentifierTooLong = $00000007;
12  rssDefaultConstructorDescription = $00000008;
13  rssDefaultConstructorActionDescription = $00000009;
14  rssDefaultDesctructorActionDescription = $0000000A;
15  rssDefaultExcelActionDescription = $0000000B;
16  rssUsersActivityOn = $0000000C;
17  rssHours = $0000000D;
18  rssLocalCharacters = $0000000E;
19  rssCannotLocalizeClass = $0000000F;
20  rssCannotLocalizeField = $00000010;
21  rssCannotTranslateUntranslatable = $00000011;
22  rssCannotSendMessageToNotApprovedContact = $00000012;
23  rssCannotCreateContactForYourself = $00000013;
24  rssCannotSendMessageForYourself = $00000014;
25  rssOverwriteFile = $00000015;
26  rssOverwriteAccessibleFile = $00000016;
27  rssReplaceCurrentTemplate = $00000017;
28  rssReplaceAllImages = $00000018;
29  rssReplaceAllMethods = $00000019;
30  rssReplaceAllTemplates = $0000001A;
31  rssLoadingProcess = $0000001B;
32  rssDoNotFogetMacroName = $0000001C;
33  rssCheckOleObjectMethodErrorMethodNotSpecified = $0000001D;
34  rssCheckOleObjectMethodErrorClassIDNotSpecified = $0000001E;
35  rssCheckOleObjectMethodErrorCodeLibraryNotSpecified = $0000001F;
36  rssCheckOleObjectMethodErrorCodeLibraryNotFound = $00000020;
37  rssCheckOleObjectMethodErrorXMLIsNotValid = $00000021;
38  rssCheckOleObjectMethodErrorProgIDNotImplemented = $00000022;
39  rssCheckOleObjectMethodErrorMethodNotImplemented = $00000023;
40  rssCheckOleObjectMethodErrorNoParameters = $00000024;
41  rssCheckOleObjectMethodErrorNoIDParameter = $00000025;
42  rssCheckOleObjectMethodErrorParameterNames = $00000026;
43  rssCheckOleObjectMethodErrorParameterCount = $00000027;
44  rssLoadingResources = $00000028;
45  rssMethodCall = $00000029;
46  rssDMLOperation = $0000002A;
47  rssReplaceAllBlobsContent = $0000002B;
48  rssCheckXSLTTemplateErrorXMLIsNotValid = $0000002C;
49  rssCheckXSLTTemplateErrorNoTemplateData = $0000002D;
50  rssCheckXSLTTemplateErrorNoIDParameter = $0000002E;
51  rssCheckXSLTTemplateErrorNoParameter = $0000002F;
52  rssCheckXSLTTemplateErrorExcessParameter = $00000030;
53  rssCheckOleObjectMethodErrorNoFunctionFound = $00000031;
54  rssCheckExcelTemplateErrorNoTemplateData = $00000032;
55  rssCheckExcelTemplateErrorNoMacro = $00000033;
56  rssCheckExcelTemplateErrorNoFunctionFound = $00000034;
57  rssCheckWordTemplateErrorNoTemplateData = $00000035;
58  rssCheckWordTemplateErrorNoMacro = $00000036;
59  rssCheckWordTemplateErrorNoFunctionFound = $00000037;
60  rssCheckTemplates = $00000038;
61  rssUnexpectedDatabase = $00000039;
62  rssCannotSaveDatabaseLanguage = $0000003A;
63  rssDomainNotFound = $0000003B;
64  rssCheckOfficeTemplateErrorMissingParameters = $0000003C;
65  rssCheckOfficeTemplateErrorMissingImplementationParameter = $0000003D;
66  rssCheckOfficeTemplateErrorParametersCountMismatched = $0000003E;
67  rssCheckOfficeTemplateErrorNoFunctionFound = $0000003F;
68  rssCheckOfficeTemplateErrorProjectSyntaxIncorrect = $00000040;
69  rssCheckOfficeTemplateErrorIncludedModuleNotFound = $00000041;
70  rssCheckOfficeTemplateWarningMethodBodyTooLong = $00000042;
71  rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped = $00000043;
72  rssCheckOfficeTemplateWarningOptionValueIncorrect = $00000044;
73  rssCannotPerformTaskAlreadyRunning = $00000045;
74  rssCannotPerformTaskDueToStatus = $00000046;
75  rssAsyncMethodInstantSuccess = $00000047;
76  rssAsyncMethodInstantError = $00000048;
77  rssAsyncReportInstantSuccess = $00000049;
78  rssAsyncReportInstantError = $0000004A;
79  rssViewCannotContainColumns = $0000004B;
80  rssMasterNotDefined = $0000004C;
81  rssAbstractDomain = $0000004D;

Элементы перечисления:

Имя | Значение | Назначение
rssRole | 0 | Роль
rssUser | 1 | Пользователь
rssIsMemberOf | 2 | является членом роли
rssRoleCannotBeMemberOfItself | 3 | Роль не может включать сама себя.
rssRoleCannotHavePrimaryRole | 4 | Роль не может иметь основную роль.
rssCanUse | 5 | использует(ют) объект
rssVirtualException | 6 | Ошибка вызова виртуального метода.
rssDataBaseIdentifierTooLong | 7 | Длина имени объекта, отображаемого на объект базы данных, не должна превышать 29 символов
rssDefaultConstructorDescription | 8 | создание
rssDefaultConstructorActionDescription | 9 | Создать
rssDefaultDesctructorActionDescription | 10 | Удалить
rssDefaultExcelActionDescription | 11 | Перенести в Excel
rssUsersActivityOn | 12 | Активность пользователей за
rssHours | 13 | Часы
rssLocalCharacters | 14 | АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯабвгдеёжзийклмнопрстуфхцчшщъыьэюя
rssCannotLocalizeClass | 15 | Нельзя локализовать класс
rssCannotLocalizeField | 16 | Нельзя локализовать поле
rssCannotTranslateUntranslatable | 17 | Нельзя перевести непереводимый элемент.
rssCannotSendMessageToNotApprovedContact | 18 | Нельзя отправить сообщение неодобренному контакту.
rssCannotCreateContactForYourself | 19 | Нельзя создать контакт для самого себя.
rssCannotSendMessageForYourself | 20 | Нельзя отправить сообщение самому себе.
rssOverwriteFile | 21 | Заменить содержимое файла "%FileName%"?
rssOverwriteAccessibleFile | 22 | Заменить содержимое доступного файла "%FileName%"?
rssReplaceCurrentTemplate | 23 | Заменить содержимое шаблона?
rssReplaceAllImages | 24 | Заменить содержимое всех изображений?
rssReplaceAllMethods | 25 | Заменить содержимое всех скриптов и тел методов?
rssReplaceAllTemplates | 26 | Заменить содержимое всех шаблонов всех отчетов?
rssLoadingProcess | 27 | Загрузка
rssDoNotFogetMacroName | 28 | Не забудьте установить имя макроса.
rssCheckOleObjectMethodErrorMethodNotSpecified | 29 | Имя метода не задано
rssCheckOleObjectMethodErrorClassIDNotSpecified | 30 | Идентификатор класса не задан
rssCheckOleObjectMethodErrorCodeLibraryNotSpecified | 31 | Библиотека кода не задана
rssCheckOleObjectMethodErrorCodeLibraryNotFound | 32 | Невозможно загрузить библиотеку кода "%CodeLibrary%"
rssCheckOleObjectMethodErrorXMLIsNotValid | 33 | Невалидный XML-документ
rssCheckOleObjectMethodErrorProgIDNotImplemented | 34 | Указанный ProgID "%ProgID%" не реализован в скриптлете
rssCheckOleObjectMethodErrorMethodNotImplemented | 35 | Метод не реализован
rssCheckOleObjectMethodErrorNoParameters | 36 | Метод должен объявлять хотя бы один параметр
rssCheckOleObjectMethodErrorNoIDParameter | 37 | Метод должен объявлять параметр с именем "ID"
rssCheckOleObjectMethodErrorParameterNames | 38 | Параметр с именем "%RealName%" не соответствует ожидаемому "%ExpectedName%"
rssCheckOleObjectMethodErrorParameterCount | 39 | Количество параметров "%RealCount%" в объявлении метода не совпадает с ожидаемым "%ExpectedCount%"
rssLoadingResources | 40 | Загрузка ресурсов
rssMethodCall | 41 | Вызов метода
rssDMLOperation | 42 | Операция с данными
rssReplaceAllBlobsContent | 43 | Заменить содержимое свойства %Class%.%Description% для всех объектов?
rssCheckXSLTTemplateErrorXMLIsNotValid | 44 | Невалидный XML-документ
rssCheckXSLTTemplateErrorNoTemplateData | 45 | Данные шаблона отсутствуют
rssCheckXSLTTemplateErrorNoIDParameter | 46 | Шаблон XSLT как метод экземпляра должен объявлять параметр "ID"
rssCheckXSLTTemplateErrorNoParameter | 47 | Параметр "%Name%" не найден в шаблоне
rssCheckXSLTTemplateErrorExcessParameter | 48 | Параметр шаблона "%Name%" не зарегистрирован в метаданных
rssCheckOleObjectMethodErrorNoFunctionFound | 49 | Подпрограмма, соответствующая макросу, отсутствует в скриптлете
rssCheckExcelTemplateErrorNoTemplateData | 50 | Данные шаблона отсутствуют
rssCheckExcelTemplateErrorNoMacro | 51 | Имя макроса не задано
rssCheckExcelTemplateErrorNoFunctionFound | 52 | Подпрограмма, соответствующая макросу, отсутствует в проекте VBA
rssCheckWordTemplateErrorNoTemplateData | 53 | Данные шаблона отсутствуют
rssCheckWordTemplateErrorNoMacro | 54 | Имя макроса не задано
rssCheckWordTemplateErrorNoFunctionFound | 55 | Подпрограмма, соответствующая макросу, отсутствует в проекте VBA
rssCheckTemplates | 56 | Проверка шаблонов
rssUnexpectedDatabase | 57 | Не поддерживается в этой БД
rssCannotSaveDatabaseLanguage | 58 | Язык базы данных не может быть сохранен в ресурсный файл.
rssDomainNotFound | 59 | Домен не найден
rssCheckOfficeTemplateErrorMissingParameters | 60 | Параметры, не найденные в реализации:
rssCheckOfficeTemplateErrorMissingImplementationParameter | 61 | Параметр %ParamName% не найден в реализации
rssCheckOfficeTemplateErrorParametersCountMismatched | 62 | Декларированное и реализованное количество параметров не соответствуют: %DeclaredCount% <> %ImplementedCount%
rssCheckOfficeTemplateErrorNoFunctionFound | 63 | Указанный макрос %MacroName% не найден
rssCheckOfficeTemplateErrorProjectSyntaxIncorrect | 64 | VBA проект синтаксически некорректный
rssCheckOfficeTemplateErrorIncludedModuleNotFound | 65 | Модуль кода %ModuleFileName% (в шаблоне %LinesCount% строк) не найден в Доступных файлах
rssCheckOfficeTemplateWarningMethodBodyTooLong | 66 | Возможно, тело метода %ProcName% (%ModuleFileName%) чрезмерно длинное (%ProcLineCount% строк)
rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped | 67 | Синтаксическая проверка проектов VBA не будет произведена, т.к. значение следующих настроек не удовлетворяют требуемым:
rssCheckOfficeTemplateWarningOptionValueIncorrect | 68 | Неверное значение VBA настройки "%OptionName%" - Включено
rssCannotPerformTaskAlreadyRunning | 69 | Выполнение невозможно, задача уже выполняется
rssCannotPerformTaskDueToStatus | 70 | Выполнение невозможно, задача имеет недопустимое состояние
rssAsyncMethodInstantSuccess | 71 | Метод выполнен
rssAsyncMethodInstantError | 72 | Ошибка выполнения метода
rssAsyncReportInstantSuccess | 73 | Отчет сформирован
rssAsyncReportInstantError | 74 | Ошибка выполнения отчета
rssViewCannotContainColumns | 75 | Это представление не может содержать колонки.
rssMasterNotDefined | 76 | Не задан мастер для объекта %Name% (%Description%) класса "%Class%".
rssAbstractDomain | 77 | Абстрактный домен


Перечисление TAggregateKind (Тип агрегата)

(одним файлом)
Перечисление TAggregateKind (Тип агрегата)
1type
2  TAggregateKind = (agCount = 1, agSumm = 2, agMax = 3, agMin = 4, agAverage = 5,
3    agCountDistinct = 6);

Или

1type
2  TAggregateKind = TOleEnum;
3const
4  agCount = $00000001;
5  agSumm = $00000002;
6  agMax = $00000003;
7  agMin = $00000004;
8  agAverage = $00000005;
9  agCountDistinct = $00000006;

Элементы перечисления:

Имя | Значение | Назначение
agCount | 1 | Количество
agSumm | 2 | Сумма
agMax | 3 | Максимальное значение
agMin | 4 | Минимальное значение
agAverage | 5 | Среднее значение
agCountDistinct | 6 | Количество уникальных


Перечисление TAsyncTaskStatus (Состояние задачи отложенного выполнения)

(одним файлом)
Перечисление TAsyncTaskStatus (Состояние задачи отложенного выполнения)
1type
2  TAsyncTaskStatus = (astCreated, astReady, astRunning, astSuccess, astError);

Или

1type
2  TAsyncTaskStatus = TOleEnum;
3const
4  astCreated = $00000000;
5  astReady = $00000001;
6  astRunning = $00000002;
7  astSuccess = $00000003;
8  astError = $00000004;

Элементы перечисления:

Имя | Значение | Назначение
astCreated | 0 | Создано
astReady | 1 | Готово к выполнению
astRunning | 2 | Выполняется
astSuccess | 3 | Завершено
astError | 4 | Прервано


Перечисление TBlobSubtype (Подтип)

(одним файлом)
Перечисление TBlobSubtype (Подтип)
1type
2  TBlobSubtype = (btBinaryData, btText, btImage, btSourceCode, btXML,
3    btNamedFile, btVisualBasicScript, btXHTML, btJavaScript, btHTML);

Или

01type
02  TBlobSubtype = TOleEnum;
03const
04  btBinaryData = $00000000;
05  btText = $00000001;
06  btImage = $00000002;
07  btSourceCode = $00000003;
08  btXML = $00000004;
09  btNamedFile = $00000005;
10  btVisualBasicScript = $00000006;
11  btXHTML = $00000007;
12  btJavaScript = $00000008;
13  btHTML = $00000009;

Элементы перечисления:

Имя | Значение | Назначение
btBinaryData | 0 | Двоичные данные
btText | 1 | Текст
btImage | 2 | Изображение
btSourceCode | 3 | Исходный код
btXML | 4 | XML-документ
btNamedFile | 5 | Именованный файл
btVisualBasicScript | 6 | Скрипт Visual Basic
btXHTML | 7 | XHTML-документ
btJavaScript | 8 | Скрипт JavaScript
btHTML | 9 | HTML-документ


Перечисление TChangeAction (Действие при изменении)

(одним файлом)
Перечисление TChangeAction (Действие при изменении)
1type
2  TChangeAction = (atCreated, atChanging, atChanged, atDestroying, atPasted);

Или

1type
2  TChangeAction = TOleEnum;
3const
4  atCreated = $00000000;
5  atChanging = $00000001;
6  atChanged = $00000002;
7  atDestroying = $00000003;
8  atPasted = $00000004;

Элементы перечисления:

Имя | Значение | Назначение
atCreated | 0 | Создан
atChanging | 1 | Изменится
atChanged | 2 | Изменен
atDestroying | 3 | Удаляется
atPasted | 4 | Вставлен из буфера


Перечисление TComparisonType (Типы сравнения)

(одним файлом)
Перечисление TComparisonType (Типы сравнения)
1type
2  TComparisonType = (ctEqual, ctNotEqual, ctGreater, ctGreaterOrEqual, ctLess,
3    ctLessOrEqual, ctLike, ctNotLike, ctRegexpLike, ctNotRegexpLike, ctIsParent,
4    ctIsChild);

Или

01type
02  TComparisonType = TOleEnum;
03const
04  ctEqual = $00000000;
05  ctNotEqual = $00000001;
06  ctGreater = $00000002;
07  ctGreaterOrEqual = $00000003;
08  ctLess = $00000004;
09  ctLessOrEqual = $00000005;
10  ctLike = $00000006;
11  ctNotLike = $00000007;
12  ctRegexpLike = $00000008;
13  ctNotRegexpLike = $00000009;
14  ctIsParent = $0000000A;
15  ctIsChild = $0000000B;

Элементы перечисления:

Имя | Значение | Назначение
ctEqual | 0 | Равно
ctNotEqual | 1 | Не равно
ctGreater | 2 | Больше
ctGreaterOrEqual | 3 | Больше или равно
ctLess | 4 | Меньше
ctLessOrEqual | 5 | Меньше или равно
ctLike | 6 | Подобно
ctNotLike | 7 | Не подобно
ctRegexpLike | 8 | Удовлетворяет регулярному выражению
ctNotRegexpLike | 9 | Не удовлетворяет регулярному выражению
ctIsParent | 10 | Является родителем
ctIsChild | 11 | Является потомком


Перечисление TDateTimePart (Часть даты или времени)

(одним файлом)
Перечисление TDateTimePart (Часть даты или времени)
1type
2  TDateTimePart = (dpYear, dpMonth, dpDay, dpHour, dpMinute, dpSecond,
3    dpDayOfWeek);

Или

01type
02  TDateTimePart = TOleEnum;
03const
04  dpYear = $00000000;
05  dpMonth = $00000001;
06  dpDay = $00000002;
07  dpHour = $00000003;
08  dpMinute = $00000004;
09  dpSecond = $00000005;
10  dpDayOfWeek = $00000006;

Элементы перечисления:

Имя | Значение | Назначение
dpYear | 0 | Год
dpMonth | 1 | Месяц
dpDay | 2 | День
dpHour | 3 | Час
dpMinute | 4 | Минута
dpSecond | 5 | Секунда
dpDayOfWeek | 6 | День недели


Перечисление TDeleteRule (Правило удаления)

(одним файлом)
Перечисление TDeleteRule (Правило удаления)
1type
2  TDeleteRule = (drRestrict, drCascade, drSetNull);

Или

1type
2  TDeleteRule = TOleEnum;
3const
4  drRestrict = $00000000;
5  drCascade = $00000001;
6  drSetNull = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
drRestrict | 0 | Нет правила
drCascade | 1 | Каскадное удаление
drSetNull | 2 | Очистить ссылку


Перечисление TDuplicates (Дубликаты)

(одним файлом)
Перечисление TDuplicates (Дубликаты)
1type
2  TDuplicates = (dupIgnore, dupAccept, dupError);

Или

1type
2  TDuplicates = TOleEnum;
3const
4  dupIgnore = $00000000;
5  dupAccept = $00000001;
6  dupError = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
dupIgnore | 0 | Игнорировать дубликаты
dupAccept | 1 | Разрешить дублирование
dupError | 2 | Генерировать ошибку дублирования


Перечисление TExcelOutputFormat (Формат результата отчета Excel)

(одним файлом)
Перечисление TExcelOutputFormat (Формат результата отчета Excel)
1type
2  TExcelOutputFormat = (eofDefault, eof2003, eofHTML, eofPDF, eofNativePDF,
3    eofXPS);

Или

1type
2  TExcelOutputFormat = TOleEnum;
3const
4  eofDefault = $00000000;
5  eof2003 = $00000001;
6  eofHTML = $00000002;
7  eofPDF = $00000003;
8  eofNativePDF = $00000004;
9  eofXPS = $00000005;

Элементы перечисления:

Имя | Значение | Назначение
eofDefault | 0 | По умолчанию
eof2003 | 1 | Рабочая книга Excel 97-2003
eofHTML | 2 | Документ HTML
eofPDF | 3 | Документ PDF
eofNativePDF | 4 | Документ PDF, сформированный Excel
eofXPS | 5 | Документ XPS


Перечисление TExcelSheetKind (Тип листа Excel)

(одним файлом)
Перечисление TExcelSheetKind (Тип листа Excel)
1type
2  TExcelSheetKind = (skNone, skFirst, skFirstHidden, skLast, skNew);

Или

1type
2  TExcelSheetKind = TOleEnum;
3const
4  skNone = $00000000;
5  skFirst = $00000001;
6  skFirstHidden = $00000002;
7  skLast = $00000003;
8  skNew = $00000004;

Элементы перечисления:

Имя | Значение | Назначение
skNone | 0 | Не переносить данные на лист
skFirst | 1 | На первый лист
skFirstHidden | 2 | На первый скрытый лист
skLast | 3 | На последний лист
skNew | 4 | На новый лист


Перечисление TExternalDataProtocol (Протокол доступа к внешним данным)

(одним файлом)
Перечисление TExternalDataProtocol (Протокол доступа к внешним данным)
1type
2  TExternalDataProtocol = (prLocal, prHTTP, prHTTPS, prFTP, prFTPS, prSMB);

Или

1type
2  TExternalDataProtocol = TOleEnum;
3const
4  prLocal = $00000000;
5  prHTTP = $00000001;
6  prHTTPS = $00000002;
7  prFTP = $00000003;
8  prFTPS = $00000004;
9  prSMB = $00000005;

Элементы перечисления:

Имя | Значение | Назначение
prLocal | 0 | Файл доступен локально
prHTTP | 1 | Протокол HTTP
prHTTPS | 2 | Протокол HTTPS
prFTP | 3 | Протокол FTP
prFTPS | 4 | Протокол FTPS
prSMB | 5 | Протокол SMB


Перечисление TFormViewLayout (Виды расположения)

(одним файлом)
Перечисление TFormViewLayout (Виды расположения)
1type
2  TFormViewLayout = (vlHorizontal, vlVertical);

Или

1type
2  TFormViewLayout = TOleEnum;
3const
4  vlHorizontal = $00000000;
5  vlVertical = $00000001;

Элементы перечисления:

Имя | Значение | Назначение
vlHorizontal | 0 | Горизонтальное
vlVertical | 1 | Вертикально


Перечисление TInstantContactStatus (Статус контакта)

(одним файлом)
Перечисление TInstantContactStatus (Статус контакта)
1type
2  TInstantContactStatus = (icsPending, icsRefused, icsApproved);

Или

1type
2  TInstantContactStatus = TOleEnum;
3const
4  icsPending = $00000000;
5  icsRefused = $00000001;
6  icsApproved = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
icsPending | 0 | Рассматривается
icsRefused | 1 | Отказано
icsApproved | 2 | Утвержденный


Перечисление TInstantMessageAttachmentType (Тип вложения мгновенного сообщения)

(одним файлом)
Перечисление TInstantMessageAttachmentType (Тип вложения мгновенного сообщения)
1type
2  TInstantMessageAttachmentType = (imaFile, imaImage, imaHyperLink, imaObject);

Или

1type
2  TInstantMessageAttachmentType = TOleEnum;
3const
4  imaFile = $00000000;
5  imaImage = $00000001;
6  imaHyperLink = $00000002;
7  imaObject = $00000003;

Элементы перечисления:

Имя | Значение | Назначение
imaFile | 0 | Файл
imaImage | 1 | Изображение
imaHyperLink | 2 | Гиперссылка
imaObject | 3 | Объект


Перечисление TInstantMessageAttachmentType (None) (Тип вложения мгновенного сообщения (None))

(одним файлом)
Перечисление TInstantMessageAttachmentType (None) (Тип вложения мгновенного сообщения (None))
1type
2  TInstantMessageAttachmentType (None) = (imaFile, imaImage, imaHyperLink,
3    imaObject, imaNone);

Или

1type
2  TInstantMessageAttachmentType (None) = TOleEnum;
3const
4  imaFile = $00000000;
5  imaImage = $00000001;
6  imaHyperLink = $00000002;
7  imaObject = $00000003;
8  imaNone = $00000004;

Это перечисление использует элементы TInstantMessageAttachmentType.

Элементы перечисления:

Имя | Значение | Назначение
imaFile | 0 | Определено в базовом перечислении TInstantMessageAttachmentType
imaImage | 1 | Определено в базовом перечислении TInstantMessageAttachmentType
imaHyperLink | 2 | Определено в базовом перечислении TInstantMessageAttachmentType
imaObject | 3 | Определено в базовом перечислении TInstantMessageAttachmentType
imaNone | 4 | Нет

См. также
  • Перечисление TInstantMessageAttachmentType (Тип вложения мгновенного сообщения)


Перечисление TNotificationType (Тип уведомления)

(одним файлом)
Перечисление TNotificationType (Тип уведомления)
1type
2  TNotificationType = (ntInformation, ntWarning, ntCaution);

Или

1type
2  TNotificationType = TOleEnum;
3const
4  ntInformation = $00000000;
5  ntWarning = $00000001;
6  ntCaution = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
ntInformation | 0 | Информация
ntWarning | 1 | Предупреждение
ntCaution | 2 | Проблема


Перечисление TOutputColorMode (Режим цветопередачи)

(одним файлом)
Перечисление TOutputColorMode (Режим цветопередачи)
1type
2  TOutputColorMode = (wcmNormal, wcmGrayscale, wcmMonochrome);

Или

1type
2  TOutputColorMode = TOleEnum;
3const
4  wcmNormal = $00000000;
5  wcmGrayscale = $00000001;
6  wcmMonochrome = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
wcmNormal | 0 | Цветной
wcmGrayscale | 1 | В градациях серого
wcmMonochrome | 2 | Монохромный


Перечисление TReplicationStatus (Статус репликации)

(одним файлом)
Перечисление TReplicationStatus (Статус репликации)
1type
2  TReplicationStatus = (rsNotReplicatable, rsReplicatableMetadata, rsReplicatable);

Или

1type
2  TReplicationStatus = TOleEnum;
3const
4  rsNotReplicatable = $00000000;
5  rsReplicatableMetadata = $00000001;
6  rsReplicatable = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
rsNotReplicatable | 0 | Не реплицировать
rsReplicatableMetadata | 1 | Вместе с метаданными
rsReplicatable | 2 | Вместе с бизнес-данными


Перечисление TRowColor (Цвет строки таблицы)

(одним файлом)
Перечисление TRowColor (Цвет строки таблицы)
1type
2  TRowColor = (rcDefault, rcRed, rcGreen, rcBlue, rcPale, rcCyan, rcMagenta,
3    rcYellow);

Или

01type
02  TRowColor = TOleEnum;
03const
04  rcDefault = $00000000;
05  rcRed = $00000001;
06  rcGreen = $00000002;
07  rcBlue = $00000003;
08  rcPale = $00000004;
09  rcCyan = $00000005;
10  rcMagenta = $00000006;
11  rcYellow = $00000007;

Элементы перечисления:

Имя | Значение | Назначение
rcDefault | 0 | По умолчанию
rcRed | 1 | Красная строка
rcGreen | 2 | Зеленая строка
rcBlue | 3 | Синяя строка
rcPale | 4 | Бледная строка
rcCyan | 5 | Голубая строка
rcMagenta | 6 | Пурпурная строка
rcYellow | 7 | Желтая строка


Перечисление TScope (Область видимости)

(одним файлом)
Перечисление TScope (Область видимости)
1type
2  TScope = (scPrivate, scPublic);

Или

1type
2  TScope = TOleEnum;
3const
4  scPrivate = $00000000;
5  scPublic = $00000001;

Элементы перечисления:

Имя | Значение | Назначение
scPrivate | 0 | Не видимо пользователям
scPublic | 1 | Видимо пользователям


Перечисление TSecurityModel (Модели безопасности)

(одним файлом)
Перечисление TSecurityModel (Модели безопасности)
1type
2  TSecurityModel = (smFullAccess, smPublic, smPrivate, smByAffiliation);

Или

1type
2  TSecurityModel = TOleEnum;
3const
4  smFullAccess = $00000000;
5  smPublic = $00000001;
6  smPrivate = $00000002;
7  smByAffiliation = $00000003;

Элементы перечисления:

Имя | Значение | Назначение
smFullAccess | 0 | Доступ не ограничен
smPublic | 1 | Публичный объект
smPrivate | 2 | Приватный объект
smByAffiliation | 3 | Доступ по принадлежности


Перечисление TShowObjectInfoType (Тип представления объектов)

(одним файлом)
Перечисление TShowObjectInfoType (Тип представления объектов)
1type
2  TShowObjectInfoType = (soName, soDescription);

Или

1type
2  TShowObjectInfoType = TOleEnum;
3const
4  soName = $00000000;
5  soDescription = $00000001;

Элементы перечисления:

Имя | Значение | Назначение
soName | 0 | Показывать имена
soDescription | 1 | Показывать наименования


Перечисление TSortDirection (Направление сортировки)

(одним файлом)
Перечисление TSortDirection (Направление сортировки)
1type
2  TSortDirection = (sdNone, sdAscending, sdDescending);

Или

1type
2  TSortDirection = TOleEnum;
3const
4  sdNone = $00000000;
5  sdAscending = $00000001;
6  sdDescending = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
sdNone | 0 | Нет
sdAscending | 1 | По возрастанию
sdDescending | 2 | По убыванию


Перечисление TTranslationStatus (Состояния перевода)

(одним файлом)
Перечисление TTranslationStatus (Состояния перевода)
1type
2  TTranslationStatus = (tsNotTranslated, tsTranslated, tsUntranslatable, tsDirty);

Или

1type
2  TTranslationStatus = TOleEnum;
3const
4  tsNotTranslated = $00000000;
5  tsTranslated = $00000001;
6  tsUntranslatable = $00000002;
7  tsDirty = $00000003;

Элементы перечисления:

Имя | Значение | Назначение
tsNotTranslated | 0 | Не переведено
tsTranslated | 1 | Переведено
tsUntranslatable | 2 | Не нуждается в переводе
tsDirty | 3 | Грязный


Перечисление TUserAccessMode (Режим доступа)

(одним файлом)
Перечисление TUserAccessMode (Режим доступа)
1type
2  TUserAccessMode = (uaFullAccess, uaReadOnly, uaAccessDenied);

Или

1type
2  TUserAccessMode = TOleEnum;
3const
4  uaFullAccess = $00000000;
5  uaReadOnly = $00000001;
6  uaAccessDenied = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
uaFullAccess | 0 | Полный доступ
uaReadOnly | 1 | Доступ только для чтения
uaAccessDenied | 2 | Доступ запрещен


Перечисление TWordOutputFormat (Формат результата отчета Word)

(одним файлом)
Перечисление TWordOutputFormat (Формат результата отчета Word)
1type
2  TWordOutputFormat = (wofDefault, wof2003, wofHTML, wofRTF, wofPDF);

Или

1type
2  TWordOutputFormat = TOleEnum;
3const
4  wofDefault = $00000000;
5  wof2003 = $00000001;
6  wofHTML = $00000002;
7  wofRTF = $00000003;
8  wofPDF = $00000004;

Элементы перечисления:

Имя | Значение | Назначение
wofDefault | 0 | По умолчанию
wof2003 | 1 | Документ Word 97-2003
wofHTML | 2 | Документ HTML
wofRTF | 3 | Документ RTF
wofPDF | 4 | Документ PDF


Класс TAccessibleFile (Доступный файл)

(раздел целиком) (одним файлом)
Класс TAccessibleFile (Доступный файл)

Диаграмма Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор доступного файла)
  • Метод SetData (Установить значение свойства "Данные файла")
  • Метод Ole-объекта CheckAllCRC (Обновить отсутствующие контрольные суммы)
  • Метод Ole-объекта CheckCRC (Обновить контрольную сумму)
  • Метод Ole-объекта LoadFromFolder (Загрузить из папки)
  • Метод Ole-объекта SaveToFolder (Сохранить в папку)
  • Метод Ole-объекта UpdateFromFolder (Обновить из папки)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TAccessibleFile:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
FileData | blob | Нет | Видимо пользователю | Чтение/Запись | Данные файла
CRC | string[8] | Нет | Видимо пользователю | Чтение/Запись | Контрольная сумма
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей
Category | string[128] | Нет | Видимо пользователю | Чтение/Запись | Категория

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор доступного файла)

(одним файлом)
Конструктор Create (Конструктор доступного файла)

Конструктор класса TAccessibleFile.

1constructor TAccessibleFile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  FileData: blob): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
FileData | blob | Нет | Данные файла

Замечания:

Создает новый объект класса TAccessibleFile.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод SetData (Установить значение свойства "Данные файла")

(одним файлом)
Метод SetData (Установить значение свойства "Данные файла")

Метод экземпляра класса TAccessibleFile.

procedure TAccessibleFile.SetData(FileData: blob);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
FileData | blob | Нет | Данные файла


Метод Ole-объекта CheckAllCRC (Обновить отсутствующие контрольные суммы)

(одним файлом)
Метод Ole-объекта CheckAllCRC (Обновить отсутствующие контрольные суммы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.


Метод Ole-объекта CheckCRC (Обновить контрольную сумму)

(одним файлом)
Метод Ole-объекта CheckCRC (Обновить контрольную сумму)

Метод Ole-объекта класса TAccessibleFile.

Метод Ole-объекта не имеет параметров.


Метод Ole-объекта LoadFromFolder (Загрузить из папки)

(одним файлом)
Метод Ole-объекта LoadFromFolder (Загрузить из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка


Метод Ole-объекта SaveToFolder (Сохранить в папку)

(одним файлом)
Метод Ole-объекта SaveToFolder (Сохранить в папку)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка


Метод Ole-объекта UpdateFromFolder (Обновить из папки)

(одним файлом)
Метод Ole-объекта UpdateFromFolder (Обновить из папки)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка


Класс TAccessItem (Элементы доступа)

(раздел целиком) (одним файлом)
Класс TAccessItem (Элементы доступа)

Класс TObject (Объекты)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор элемента доступа)
  • Метод GetIsAccessible (Проверка доступности)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TAccessItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Скрыто от пользователя | Чтение/Запись | Имя
Description | string[128] | Да | Скрыто от пользователя | Чтение/Запись | Наименование
Class | TClass | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения | Элемент
MasterName | string[64] | Да | Видимо пользователю | Только для чтения | Имя элемента
MasterDescription | string[128] | Да | Видимо пользователю | Только для чтения | Наименование элемента
MasterClass | TClass | Да | Видимо пользователю | Только для чтения | Класс элемента
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
SecurityAccount | TSecurityAccount | Да | Видимо пользователю | Чтение/Запись | Роль безопасности
SecurityAccountName | string[64] | Да | Видимо пользователю | Чтение/Запись | Имя роли безопасности
SecurityAccountDescription | string[128] | Да | Видимо пользователю | Чтение/Запись | Наименование роли безопасности
SecurityAccountClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс роли безопасности

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор элемента доступа)

(одним файлом)
Конструктор Create (Конструктор элемента доступа)

Конструктор класса TAccessItem.

1constructor TAccessItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
SecurityAccount | TSecurityAccount | Да | Роль безопасности

Замечания:

Создает новый объект класса TAccessItem.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetIsAccessible (Проверка доступности)

(одним файлом)
Метод GetIsAccessible (Проверка доступности)

Метод класса (статический метод) класса TAccessItem.

class function TAccessItem.GetIsAccessible(Master: TObject): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObject (Объекты)


Класс TAccessProfile (Профили доступа)

(раздел целиком) (одним файлом)
Класс TAccessProfile (Профили доступа)

Диаграмма Класс TProfile (Профили)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор профиля доступа)
См. также
  • Класс TProfile (Профили)


Свойства

(одним файлом)
Свойства

Свойства класса TAccessProfile:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TProfile
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
ComparisonType | TComparisonType | Да | Видимо пользователю | Чтение/Запись
BasedOnProfile | TProfile | Нет | Видимо пользователю | Чтение/Запись
Active | Boolean | Да | Видимо пользователю | Только для чтения
Access | Boolean | Да | Видимо пользователю | Чтение/Запись | Доступ

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TProfile (Профили)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TComparisonType (Типы сравнения)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор профиля доступа)

(одним файлом)
Конструктор Create (Конструктор профиля доступа)

Конструктор класса TAccessProfile.

1constructor TAccessProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType; BasedOnProfile: TProfile;
4  Access: Boolean): TObject;

Переопределяет метод в TProfile.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Унаследовано от TProfile.Create
ComparisonType | TComparisonType | Да
BasedOnProfile | TProfile | Нет
Access | Boolean | Да | Доступ

Замечания:

Создает новый объект класса TAccessProfile.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TProfile (Профили)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор профиля)
  • Перечисление TComparisonType (Типы сравнения)


Класс TAction (Действия)

(раздел целиком) (одним файлом)
Класс TAction (Действия)

Класс TObject (Объекты)Класс TCustomView (Абстрактное представление)Класс TActionContextProperty (Свойство контекста)

Объекты класса образуют иерархию.

  • Свойства
  • Конструктор Create (Конструктор действия)
  • Метод GetNextPos (Следующая позиция)
См. также
  • Класс TCustomView (Абстрактное представление)
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TAction:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Shortcut | string[20] | Нет | Видимо пользователю | Чтение/Запись | Горячая клавиша
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Separated | Boolean | Да | Видимо пользователю | Чтение/Запись | Отделено
Default | Boolean | Да | Видимо пользователю | Чтение/Запись | По умолчанию

См. также
  • Класс TClass (Классы)
  • Класс TCustomView (Абстрактное представление)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор действия)

(одним файлом)
Конструктор Create (Конструктор действия)

Конструктор класса TAction.

1constructor TAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean;
4  Default: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция
Shortcut | string[20] | Нет | Горячая клавиша
Separated | Boolean | Да | Отделено
Default | Boolean | Да | По умолчанию

Замечания:

Создает новый объект класса TAction.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TAction.

1class function TAction.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер
Parent | TObject | Нет | Родитель
Step | Integer | Да | Шаг

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Класс TActionContextProperty (Свойство контекста)

(раздел целиком) (одним файлом)
Класс TActionContextProperty (Свойство контекста)

Класс TObject (Объекты)Класс TAction (Действия)

Имена объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор контекстного свойства)
  • Метод GetNextPos (Следующая позиция)
См. также
  • Класс TAction (Действия)
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TActionContextProperty:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Property | TProperty | Да | Видимо пользователю | Чтение/Запись | Свойство
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция

См. также
  • Класс TAction (Действия)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор контекстного свойства)

(одним файлом)
Конструктор Create (Конструктор контекстного свойства)

Конструктор класса TActionContextProperty.

1constructor TActionContextProperty.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Property: TProperty; Position: Integer): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Property | TProperty | Да | Свойство
Position | Integer | Да | Позиция

Замечания:

Создает новый объект класса TActionContextProperty.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TActionContextProperty.

class function TActionContextProperty.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Класс TAsyncHandler (Обработчики отложенного выполнения)

(раздел целиком) (одним файлом)
Класс TAsyncHandler (Обработчики отложенного выполнения)

Диаграмма Класс TObject (Объекты)Класс TAsyncHandlerAccess (Доступ к обработчикам отложенного выполнения)

  • Свойства
  • Конструктор Create (Конструктор обработчика отложенного выполнения)
  • Метод GetIsAccessible (Доступен)
  • Метод ValidateInstantMessage (Доступен обработчик с уведомлением сообщением)
  • Метод ValidateWithoutNotification (Доступен обработчик без уведомления)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TAsyncHandler:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения | Доступен
Validator | TMethod | Нет | Видимо пользователю | Чтение/Запись | Процедура-валидатор
Handler | TRoutine | Нет | Видимо пользователю | Чтение/Запись | Процедура-обработчик

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TMethod (Методы)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор обработчика отложенного выполнения)

(одним файлом)
Конструктор Create (Конструктор обработчика отложенного выполнения)

Конструктор класса TAsyncHandler.

1constructor TAsyncHandler.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Validator: TMethod; Handler: TRoutine): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Validator | TMethod | Нет | Процедура-валидатор
Handler | TRoutine | Нет | Процедура-обработчик

Замечания:

Создает новый объект класса TAsyncHandler.

См. также
  • Класс TClass (Классы)
  • Класс TMethod (Методы)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetIsAccessible (Доступен)

(одним файлом)
Метод GetIsAccessible (Доступен)

Метод экземпляра класса TAsyncHandler.

function TAsyncHandler.GetIsAccessible: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод ValidateInstantMessage (Доступен обработчик с уведомлением сообщением)

(одним файлом)
Метод ValidateInstantMessage (Доступен обработчик с уведомлением сообщением)

Метод класса (статический метод) класса TAsyncHandler.

class function TAsyncHandler.ValidateInstantMessage(Routine: TRoutine): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Routine | TRoutine | Да | Подпрограмма

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TRoutine (Подпрограмма)


Метод ValidateWithoutNotification (Доступен обработчик без уведомления)

(одним файлом)
Метод ValidateWithoutNotification (Доступен обработчик без уведомления)

Метод класса (статический метод) класса TAsyncHandler.

class function TAsyncHandler.ValidateWithoutNotification(Routine: TRoutine): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Routine | TRoutine | Да | Подпрограмма

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TRoutine (Подпрограмма)


Класс TAsyncHandlerAccess (Доступ к обработчикам отложенного выполнения)

(раздел целиком) (одним файлом)
Класс TAsyncHandlerAccess (Доступ к обработчикам отложенного выполнения)

Класс TAccessItem (Элементы доступа)Класс TObject (Объекты)Класс TAsyncHandler (Обработчики отложенного выполнения)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Конструктор Create (Конструктор доступа к обработчикам отложенного выполнения)
См. также
  • Класс TAccessItem (Элементы доступа)
  • Класс TAsyncHandler (Обработчики отложенного выполнения)


Конструктор Create (Конструктор доступа к обработчикам отложенного выполнения)

(одним файлом)
Конструктор Create (Конструктор доступа к обработчикам отложенного выполнения)

Конструктор класса TAsyncHandlerAccess.

1constructor TAsyncHandlerAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
SecurityAccount | TSecurityAccount | Да | Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TAsyncHandlerAccess.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор элемента доступа)


Класс TAsyncTask (Задачи отложенного выполнения)

(раздел целиком) (одним файлом)
Класс TAsyncTask (Задачи отложенного выполнения)

Класс TObject (Объекты)Класс TAsyncTaskParameterValue (Значения параметров задачи отложенного выполнения)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор задачи отложенного выполнения)
  • Деструктор Destroy (Деструктор объекта)
  • Метод Archive (Отправить в архив)
  • Метод CreateGroup (Создать группу)
  • Метод Finish (Зафиксировать завершение выполнения)
  • Метод HandleInstantMessage (Обработчик с уведомлением сообщением)
  • Метод HasAsyncTasks (Имеются задачи отложенного выполнения)
  • Метод Start (Зафиксировать начало выполнения)
  • Метод Ole-объекта PerformImmediate (Выполнить немедленно)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TAsyncTask:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
Created | datetime | Да | Видимо пользователю | Только для чтения | Время создания
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Status | TAsyncTaskStatus | Да | Видимо пользователю | Чтение/Запись | Состояние
Routine | TRoutine | Да | Видимо пользователю | Чтение/Запись | Подпрограмма
RoutineClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс подпрограммы
Language | TLanguage | Да | Видимо пользователю | Чтение/Запись | Язык
Handler | TAsyncHandler | Да | Видимо пользователю | Чтение/Запись | Обработчик
FormView | TFormView | Нет | Видимо пользователю | Чтение/Запись | Представление формы
Object | TObject | Нет | Видимо пользователю | Чтение/Запись | Объект
Started | datetime | Нет | Видимо пользователю | Чтение/Запись | Время начала выполнения
Finished | datetime | Нет | Видимо пользователю | Чтение/Запись | Время завершения выполнения
Duration | time | Нет | Видимо пользователю | Только для чтения | Длительность
Bold | Boolean | Да | Скрыто от пользователя | Только для чтения | Выделено
RowColor | TRowColor | Нет | Скрыто от пользователя | Только для чтения | Цвет строки
Group | TAsyncTask | Нет | Видимо пользователю | Только для чтения | Группа
GroupContentReady | Boolean | Да | Скрыто от пользователя | Только для чтения | Содержимое группы готово

См. также
  • Класс TAsyncHandler (Обработчики отложенного выполнения)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TFormView (Представления формы)
  • Класс TLanguage (Языки)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TAsyncTaskStatus (Состояние задачи отложенного выполнения)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TRowColor (Цвет строки таблицы)


Конструктор Create (Конструктор задачи отложенного выполнения)

(одним файлом)
Конструктор Create (Конструктор задачи отложенного выполнения)

Конструктор класса TAsyncTask.

1constructor TAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Routine | TRoutine | Да | Подпрограмма
Object | TObject | Нет | Объект
FormView | TFormView | Нет | Представление формы
Handler | TAsyncHandler | Да | Обработчик
Language | TLanguage | Да | Язык

Замечания:

Создает новый объект класса TAsyncTask.

См. также
  • Класс TAsyncHandler (Обработчики отложенного выполнения)
  • Класс TClass (Классы)
  • Класс TFormView (Представления формы)
  • Класс TLanguage (Языки)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Деструктор Destroy (Деструктор объекта)

(одним файлом)
Деструктор Destroy (Деструктор объекта)

Деструктор класса TAsyncTask.

destructor TAsyncTask.Destroy;

Переопределяет метод в TObject.Destroy.

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TAsyncTask или его наследника.

См. также
  • Деструктор Destroy (Деструктор объекта)


Метод Archive (Отправить в архив)

(одним файлом)
Метод Archive (Отправить в архив)

Метод экземпляра класса TAsyncTask.

procedure TAsyncTask.Archive;

Метод не имеет параметров.


Метод CreateGroup (Создать группу)

(одним файлом)
Метод CreateGroup (Создать группу)

Метод экземпляра класса TAsyncTask.

procedure TAsyncTask.CreateGroup(Group: clob);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Group | clob | Нет | Группа


Метод Finish (Зафиксировать завершение выполнения)

(одним файлом)
Метод Finish (Зафиксировать завершение выполнения)

Метод экземпляра класса TAsyncTask.

procedure TAsyncTask.Finish(Success: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Success | Boolean | Да | Выполнено успешно


Метод HandleInstantMessage (Обработчик с уведомлением сообщением)

(одним файлом)
Метод HandleInstantMessage (Обработчик с уведомлением сообщением)

Метод экземпляра класса TAsyncTask.

1procedure TAsyncTask.HandleInstantMessage(Success: Boolean;
2  ErrorMessage: string[2000]; ExceptionClass: string[2000];
3  NativeMessage: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Success | Boolean | Да | Выполнено успешно
ErrorMessage | string[2000] | Нет | Сообщение об ошибке
ExceptionClass | string[2000] | Нет | Класс ошибки
NativeMessage | string[2000] | Нет | Системное сообщение об ошибке


Метод HasAsyncTasks (Имеются задачи отложенного выполнения)

(одним файлом)
Метод HasAsyncTasks (Имеются задачи отложенного выполнения)

Метод класса (статический метод) класса TAsyncTask.

class function TAsyncTask.HasAsyncTasks: Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод Start (Зафиксировать начало выполнения)

(одним файлом)
Метод Start (Зафиксировать начало выполнения)

Метод экземпляра класса TAsyncTask.

procedure TAsyncTask.Start;

Метод скрыт от пользователя.

Метод не имеет параметров.


Метод Ole-объекта PerformImmediate (Выполнить немедленно)

(одним файлом)
Метод Ole-объекта PerformImmediate (Выполнить немедленно)

Метод Ole-объекта класса TAsyncTask.

Метод Ole-объекта не имеет параметров.


Класс TAsyncTaskParameterValue (Значения параметров задачи отложенного выполнения)

(раздел целиком) (одним файлом)
Класс TAsyncTaskParameterValue (Значения параметров задачи отложенного выполнения)

Класс TTypedValue (Типизированные значения)Класс TObject (Объекты)Класс TAsyncTask (Задачи отложенного выполнения)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор значения параметров задачи отложенного выполнения)
  • Метод SuggestFileName (Предложить имя файла)
См. также
  • Класс TAsyncTask (Задачи отложенного выполнения)
  • Класс TTypedValue (Типизированные значения)


Свойства

(одним файлом)
Свойства

Свойства класса TAsyncTaskParameterValue:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Нет | Скрыто от пользователя | Только для чтения | Унаследовано от TTypedValue
MasterClass | TClass | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TTypedValue
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
StrValue | string[2000] | Нет | Скрыто от пользователя | Чтение/Запись
IntValue | Integer | Нет | Скрыто от пользователя | Чтение/Запись
FloatValue | float | Нет | Скрыто от пользователя | Чтение/Запись
DateValue | date | Нет | Скрыто от пользователя | Чтение/Запись
TimeValue | time | Нет | Скрыто от пользователя | Чтение/Запись
DateTimeValue | datetime | Нет | Скрыто от пользователя | Чтение/Запись
ObjectValue | TObject | Нет | Скрыто от пользователя | Чтение/Запись
BoolValue | Boolean | Нет | Скрыто от пользователя | Чтение/Запись
BlobValue | blob | Нет | Видимо пользователю | Чтение/Запись
ClobValue | clob | Нет | Видимо пользователю | Чтение/Запись
ExternalDataValue | <external data> | Нет | Видимо пользователю | Чтение/Запись
VisibleValue | string[2000] | Нет | Видимо пользователю | Только для чтения
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись
Temporary | Boolean | Да | Видимо пользователю | Чтение/Запись | Временный объект

См. также
  • Класс TAsyncTask (Задачи отложенного выполнения)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TTypedValue (Типизированные значения)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор значения параметров задачи отложенного выполнения)

(одним файлом)
Конструктор Create (Конструктор значения параметров задачи отложенного выполнения)

Конструктор класса TAsyncTaskParameterValue.

1constructor TAsyncTaskParameterValue.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Domain: TDomain; Position: Integer;
4  Group: string[128]; Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]; IntValue: Integer; FloatValue: float; DateValue: date;
6  TimeValue: time; DateTimeValue: datetime; ObjectValue: TObject;
7  BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
8  ExternalDataValue: <external data>; Temporary: Boolean): TObject;

Переопределяет метод в TTypedValue.Create, TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Унаследовано от TTypedValue.Create
Position | Integer | Да
Group | string[128] | Нет
Tab | string[128] | Нет
Scope | TScope | Да
OutOfTabs | Boolean | Да
StrValue | string[2000] | Нет
IntValue | Integer | Нет
FloatValue | float | Нет
DateValue | date | Нет
TimeValue | time | Нет
DateTimeValue | datetime | Нет
ObjectValue | TObject | Нет
BoolValue | Boolean | Нет
BlobValue | blob | Нет
ClobValue | clob | Нет
ExternalDataValue | <external data> | Нет
Temporary | Boolean | Да | Временный объект

Замечания:

Создает новый объект класса TAsyncTaskParameterValue.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор типизированного значения)
  • Перечисление TScope (Область видимости)


Метод SuggestFileName (Предложить имя файла)

(одним файлом)
Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TAsyncTaskParameterValue.

function TAsyncTaskParameterValue.SuggestFileName(Domain: TDomain): string[128];

Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя | Тип | Обязательно | Значение
Domain | TDomain | Нет | Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

См. также
  • Класс TDomain (Домены)
  • Метод SuggestFileName (Предложить имя файла)


Класс TBanGroup (Группы запретов)

(раздел целиком) (одним файлом)
Класс TBanGroup (Группы запретов)

Диаграмма Класс TObject (Объекты)Класс TBanGroupAccess (Доступ к группам запретов)Класс TBanGroupItem (Элементы группы запретов)Класс TClassBan (Запрет на класс)Класс TRoutineBan (Запрет на подпрограмму)Класс TPropertyBan (Запрет на свойство)Класс TFormBan (Запрет на форму)

  • Свойства
  • Конструктор Create (Конструктор группы запретов)
  • Метод CreateAllBans (Сгенерировать запреты для класса)
  • Метод GetIsAccessible (Доступна)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TBanGroup:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения | Доступна

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор группы запретов)

(одним файлом)
Конструктор Create (Конструктор группы запретов)

Конструктор класса TBanGroup.

1constructor TBanGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TBanGroup.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод CreateAllBans (Сгенерировать запреты для класса)

(одним файлом)
Метод CreateAllBans (Сгенерировать запреты для класса)

Метод экземпляра класса TBanGroup.

1procedure TBanGroup.CreateAllBans(BannedClass: TClass; BanClass: Boolean;
2  BanRoutines: Boolean; BanProperties: Boolean; AllowRead: Boolean);

Параметры:

Имя | Тип | Обязательно | Значение
BannedClass | TClass | Да | Запрещаемый класс
BanClass | Boolean | Да | Запретить доступ к объектам класса
BanRoutines | Boolean | Да | Запретить подпрограммы
BanProperties | Boolean | Да | Запретить свойства
AllowRead | Boolean | Да | Чтение свойств разрешено

См. также
  • Класс TClass (Классы)


Метод GetIsAccessible (Доступна)

(одним файлом)
Метод GetIsAccessible (Доступна)

Метод экземпляра класса TBanGroup.

function TBanGroup.GetIsAccessible: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Класс TBanGroupAccess (Доступ к группам запретов)

(раздел целиком) (одним файлом)
Класс TBanGroupAccess (Доступ к группам запретов)

Класс TAccessItem (Элементы доступа)Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Конструктор Create (Конструктор доступа к группе запретов)
См. также
  • Класс TAccessItem (Элементы доступа)
  • Класс TBanGroup (Группы запретов)


Конструктор Create (Конструктор доступа к группе запретов)

(одним файлом)
Конструктор Create (Конструктор доступа к группе запретов)

Конструктор класса TBanGroupAccess.

1constructor TBanGroupAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TBanGroup; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TBanGroup | Да | Группа запретов
Accessor | TSecurityAccount | Нет | Унаследовано от TObject.Create
SecurityAccount | TSecurityAccount | Да | Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TBanGroupAccess.

См. также
  • Класс TBanGroup (Группы запретов)
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор элемента доступа)


Класс TBanGroupItem (Элементы группы запретов)

(раздел целиком) (одним файлом)
Класс TBanGroupItem (Элементы группы запретов)

Диаграмма Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

  • Свойства
  • Конструктор Create (Конструктор элемента группы запретов)
См. также
  • Класс TBanGroup (Группы запретов)
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TBanGroupItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TBanGroup | Да | Видимо пользователю | Только для чтения | Мастер
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения | Доступен
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись

См. также
  • Класс TBanGroup (Группы запретов)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор элемента группы запретов)

(одним файлом)
Конструктор Create (Конструктор элемента группы запретов)

Конструктор класса TBanGroupItem.

1constructor TBanGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TBanGroupItem.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Класс TBlobDomain (Большие объекты)

(раздел целиком) (одним файлом)
Класс TBlobDomain (Большие объекты)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор домена больших объектов)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TDomain (Домены)


Свойства

(одним файлом)
Свойства

Свойства класса TBlobDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
BlobSubtype | TBlobSubtype | Да | Видимо пользователю | Чтение/Запись | Подтип
Extension | string[10] | Нет | Видимо пользователю | Чтение/Запись | Расширение
ShowInPlace | Boolean | Да | Видимо пользователю | Чтение/Запись | Редактировать по месту
EditorClassID | string[128] | Нет | Видимо пользователю | Чтение/Запись | Идентификатор класса-редактора
EditorCodeLibrary | TAccessibleFile | Нет | Видимо пользователю | Чтение/Запись | Библиотека кода редактора
SizeLimit | Integer | Нет | Видимо пользователю | Чтение/Запись | Ограничение на размер
IsBinary | Boolean | Да | Видимо пользователю | Только для чтения | Двоичные данные

См. также
  • Класс TAccessibleFile (Доступный файл)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TBlobSubtype (Подтип)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор домена больших объектов)

(одним файлом)
Конструктор Create (Конструктор домена больших объектов)

Конструктор класса TBlobDomain.

1constructor TBlobDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; BlobSubtype: TBlobSubtype; SizeLimit: Integer;
4  Extension: string[10]; ShowInPlace: Boolean; EditorClassID: string[128];
5  EditorCodeLibrary: TAccessibleFile): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
BlobSubtype | TBlobSubtype | Да | Подтип
SizeLimit | Integer | Нет | Ограничение на размер
Extension | string[10] | Нет | Расширение
ShowInPlace | Boolean | Да | Редактировать по месту
EditorClassID | string[128] | Нет | Идентификатор класса-редактора
EditorCodeLibrary | TAccessibleFile | Нет | Библиотека кода редактора

Замечания:

Создает новый объект класса TBlobDomain.

См. также
  • Класс TAccessibleFile (Доступный файл)
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TBlobSubtype (Подтип)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TBlobDomain.

function TBlobDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)


Класс TBooleanDomain (Логические)

(раздел целиком) (одним файлом)
Класс TBooleanDomain (Логические)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор логического домена)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TDomain (Домены)


Свойства

(одним файлом)
Свойства

Свойства класса TBooleanDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
TrueValue | string[64] | Да | Видимо пользователю | Чтение/Запись | Значение "Истина"
FalseValue | string[64] | Да | Видимо пользователю | Чтение/Запись | Значение "Ложь"

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор логического домена)

(одним файлом)
Конструктор Create (Конструктор логического домена)

Конструктор класса TBooleanDomain.

1constructor TBooleanDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; TrueValue: string[64]; FalseValue: string[64]): TDomain;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
TrueValue | string[64] | Да | Значение "Истина"
FalseValue | string[64] | Да | Значение "Ложь"

Замечания:

Создает новый объект класса TBooleanDomain.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TBooleanDomain.

function TBooleanDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)


Класс TClass (Классы)

(раздел целиком) (одним файлом)
Класс TClass (Классы)

Класс TObject (Объекты)Класс TClassMember (Члены класса)Класс TField (Поля)Класс TProperty (Свойства)Класс TMethod (Методы)Класс TXSLTTemplate (Шаблоны отчетов XSLT)Класс TExcelTemplate (Шаблоны отчетов Excel)Класс TRoutine (Подпрограмма)Класс TOleObjectMethod (Метод Ole-объекта)Класс TInlineExpression (Встраиваемое выражение)Класс TWordTemplate (Шаблоны отчетов Word)Класс TPDFTemplate (Шаблоны отчетов PDF)Класс TObjectCreator (Роли-создатели)

Объекты класса образуют иерархию.

  • Свойства
  • Конструктор Create (Конструктор класса)
  • Метод CreateContextKey (Создать ключ контекстной помощи)
  • Метод GenerateConstructor (Сгенерировать текст конструктора)
  • Метод GetApproxObjectsCount (Получить оценку количества объектов)
  • Метод GetDBMSName (Получить имя объекта СУБД)
  • Метод GetHasProfiles (Контролируется профилями)
  • Метод GetObjectCount (Количество объектов)
  • Метод ListChildProperties (Список дочерних свойств)
  • Метод ListProperties (Список свойств)
  • Метод ListRoutines (Список подпрограмм)
  • Метод MarkLocalizableMetadata (Установить поля метаданных как локализуемые)
  • Метод MemberByName (Член класса по имени)
  • Метод SetLocalizable (Установить значение свойства "Локализуемый")
  • Метод Ole-объекта CheckAllExcelTemplates (Проверить шаблоны отчетов Excel)
  • Метод Ole-объекта CheckAllOleObjectMethods (Проверить все методы Ole-объекта)
  • Метод Ole-объекта CheckAllTemplates (Проверить все шаблоны)
  • Метод Ole-объекта CheckAllWordTemplates (Проверить шаблоны отчетов Word)
  • Метод Ole-объекта CheckAllXSLTTemplates (Проверить шаблоны отчетов XSLT)
  • Метод Ole-объекта LoadImagesFromFolder (Загрузить изображения из папки)
  • Метод Ole-объекта LoadMethodsFromFolder (Загрузить методы из папки)
  • Метод Ole-объекта LoadResourceFile (Загрузить файл ресурсов)
  • Метод Ole-объекта LoadTemplatesFromFolder (Загрузить шаблоны из папки)
  • Метод Ole-объекта SaveImagesToFolder (Сохранить изображения в папку)
  • Метод Ole-объекта SaveMethodsToFolder (Сохранить методы в папку)
  • Метод Ole-объекта SaveTemplatesToFolder (Сохранить шаблоны в папку)
  • Шаблон XSLT-отчета ClassesDiagram (Диаграмма классов)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TClass:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Видимо пользователю | Чтение/Запись | Статус репликации
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись | Унаследовано от TObject
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
IsHierarhical | Boolean | Да | Видимо пользователю | Только для чтения | Является иерархическим
SecurityModel | TSecurityModel | Да | Видимо пользователю | Чтение/Запись | Модель безопасности
DefaultAccessor | TSecurityAccount | Нет | Видимо пользователю | Чтение/Запись | Роль доступа по умолчанию
UnNamed | Boolean | Да | Видимо пользователю | Чтение/Запись | Неименованный
NameExpression | clob | Нет | Видимо пользователю | Чтение/Запись | Выражение имени объекта
DescriptionExpression | clob | Нет | Видимо пользователю | Чтение/Запись | Выражение наименования объекта
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись | Протоколировать
ModelX | Integer | Нет | Скрыто от пользователя | Чтение/Запись | Положение в модели (абсцисса)
ModelY | Integer | Нет | Скрыто от пользователя | Чтение/Запись | Положение в модели (ордината)
Category | string[128] | Нет | Видимо пользователю | Чтение/Запись | Категория
Indexed | Boolean | Да | Видимо пользователю | Чтение/Запись | Индексируется
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей
Localizable | Boolean | Да | Видимо пользователю | Чтение/Запись | Локализуемый
DBMSName | string[64] | Да | Видимо пользователю | Только для чтения | Имя объекта СУБД
CreatorsCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество ролей-создателей
MasterClass | TClass | Нет | Видимо пользователю | Только для чтения | Класс-мастер
HasProfiles | Boolean | Да | Видимо пользователю | Только для чтения | Контролируется профилями
ApproxObjectCount | Integer | Нет | Видимо пользователю | Только для чтения | Оценка количества объектов

См. также
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TSecurityModel (Модели безопасности)


Конструктор Create (Конструктор класса)

(одним файлом)
Конструктор Create (Конструктор класса)

Конструктор класса TClass.

1constructor TClass.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  MasterClass: TClass; IsHierarhical: Boolean;
4  ReplicationStatus: TReplicationStatus; SecurityModel: TSecurityModel;
5  DefaultAccessor: TSecurityAccount; Logged: Boolean; UnNamed: Boolean;
6  NameExpression: clob; DescriptionExpression: clob; CreateConstructor: Boolean;
7  Category: string[128]; Indexed: Boolean; Localizable: Boolean): TClass;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Имя
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
MasterClass | TClass | Нет | Класс-мастер
IsHierarhical | Boolean | Да | Является иерархическим
ReplicationStatus | TReplicationStatus | Да | Статус репликации
SecurityModel | TSecurityModel | Да | Модель безопасности
DefaultAccessor | TSecurityAccount | Нет | Роль доступа по умолчанию
Logged | Boolean | Да | Протоколировать
UnNamed | Boolean | Да | Неименованный
NameExpression | clob | Нет | Выражение имени объекта
DescriptionExpression | clob | Нет | Выражение наименования объекта
CreateConstructor | Boolean | Да | Создать конструктор
Category | string[128] | Нет | Категория
Indexed | Boolean | Да | Индексируется
Localizable | Boolean | Да | Локализуемый

Замечания:

Создает новый объект класса TClass.

См. также
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TSecurityModel (Модели безопасности)


Метод CreateContextKey (Создать ключ контекстной помощи)

(одним файлом)
Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TClass.

procedure TClass.CreateContextKey(Storage: string[64]);

Параметры:

Имя | Тип | Обязательно | Значение
Storage | string[64] | Да | Хранилище


Метод GenerateConstructor (Сгенерировать текст конструктора)

(одним файлом)
Метод GenerateConstructor (Сгенерировать текст конструктора)

Метод экземпляра класса TClass.

procedure TClass.GenerateConstructor;

Метод не имеет параметров.


Метод GetApproxObjectsCount (Получить оценку количества объектов)

(одним файлом)
Метод GetApproxObjectsCount (Получить оценку количества объектов)

Метод экземпляра класса TClass.

function TClass.GetApproxObjectsCount: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод GetDBMSName (Получить имя объекта СУБД)

(одним файлом)
Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TClass.

function TClass.GetDBMSName: string[64];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].


Метод GetHasProfiles (Контролируется профилями)

(одним файлом)
Метод GetHasProfiles (Контролируется профилями)

Метод экземпляра класса TClass.

function TClass.GetHasProfiles: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод GetObjectCount (Количество объектов)

(одним файлом)
Метод GetObjectCount (Количество объектов)

Метод экземпляра класса TClass.

function TClass.GetObjectCount(Exact: Boolean): string[20];

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Exact | Boolean | Да | Строго

Замечания:

Возвращает значение типа string[20].


Метод ListChildProperties (Список дочерних свойств)

(одним файлом)
Метод ListChildProperties (Список дочерних свойств)

Метод класса (статический метод) класса TClass.

1class procedure TClass.ListChildProperties(ParentName: string[64];
2  TemporaryList: TObjectList; PersistentList: TObjectList);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ParentName | string[64] | Да | Имя свойства
TemporaryList | TObjectList | Нет | Временный список
PersistentList | TObjectList | Нет | Постоянный список

См. также
  • Класс TObjectList (Списки)


Метод ListProperties (Список свойств)

(одним файлом)
Метод ListProperties (Список свойств)

Метод экземпляра класса TClass.

function TClass.ListProperties(Scope: TScope): TObjectList;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Scope | TScope | Да | Область видимости

Замечания:

Возвращает значение типа TObjectList.

См. также
  • Класс TObjectList (Списки)
  • Перечисление TScope (Область видимости)


Метод ListRoutines (Список подпрограмм)

(одним файлом)
Метод ListRoutines (Список подпрограмм)

Метод экземпляра класса TClass.

function TClass.ListRoutines(Scope: TScope): TObjectList;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Scope | TScope | Да | Область видимости

Замечания:

Возвращает значение типа TObjectList.

См. также
  • Класс TObjectList (Списки)
  • Перечисление TScope (Область видимости)


Метод MarkLocalizableMetadata (Установить поля метаданных как локализуемые)

(одним файлом)
Метод MarkLocalizableMetadata (Установить поля метаданных как локализуемые)

Метод класса (статический метод) класса TClass.

class procedure TClass.MarkLocalizableMetadata;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.


Метод MemberByName (Член класса по имени)

(одним файлом)
Метод MemberByName (Член класса по имени)

Метод экземпляра класса TClass.

function TClass.MemberByName(Name: string[64]; Class: TClass): TClassMember;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Class | TClass | Да | Класс

Замечания:

Возвращает значение типа TClassMember.

См. также
  • Класс TClassMember (Члены класса)


Метод SetLocalizable (Установить значение свойства "Локализуемый")

(одним файлом)
Метод SetLocalizable (Установить значение свойства "Локализуемый")

Метод экземпляра класса TClass.

procedure TClass.SetLocalizable(Value: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение


Метод Ole-объекта CheckAllExcelTemplates (Проверить шаблоны отчетов Excel)

(одним файлом)
Метод Ole-объекта CheckAllExcelTemplates (Проверить шаблоны отчетов Excel)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.


Метод Ole-объекта CheckAllOleObjectMethods (Проверить все методы Ole-объекта)

(одним файлом)
Метод Ole-объекта CheckAllOleObjectMethods (Проверить все методы Ole-объекта)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.


Метод Ole-объекта CheckAllTemplates (Проверить все шаблоны)

(одним файлом)
Метод Ole-объекта CheckAllTemplates (Проверить все шаблоны)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.


Метод Ole-объекта CheckAllWordTemplates (Проверить шаблоны отчетов Word)

(одним файлом)
Метод Ole-объекта CheckAllWordTemplates (Проверить шаблоны отчетов Word)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.


Метод Ole-объекта CheckAllXSLTTemplates (Проверить шаблоны отчетов XSLT)

(одним файлом)
Метод Ole-объекта CheckAllXSLTTemplates (Проверить шаблоны отчетов XSLT)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.


Метод Ole-объекта LoadImagesFromFolder (Загрузить изображения из папки)

(одним файлом)
Метод Ole-объекта LoadImagesFromFolder (Загрузить изображения из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка
Prefix | string[128] | Нет | Префикс имени файла

Замечания:

Возвращает значение типа Integer.


Метод Ole-объекта LoadMethodsFromFolder (Загрузить методы из папки)

(одним файлом)
Метод Ole-объекта LoadMethodsFromFolder (Загрузить методы из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка

Замечания:

Возвращает значение типа Integer.


Метод Ole-объекта LoadResourceFile (Загрузить файл ресурсов)

(одним файлом)
Метод Ole-объекта LoadResourceFile (Загрузить файл ресурсов)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
XliffFileName | string[255] | Да | Файл ресурсов

Замечания:

Возвращает значение типа Integer.


Метод Ole-объекта LoadTemplatesFromFolder (Загрузить шаблоны из папки)

(одним файлом)
Метод Ole-объекта LoadTemplatesFromFolder (Загрузить шаблоны из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка

Замечания:

Возвращает значение типа Integer.


Метод Ole-объекта SaveImagesToFolder (Сохранить изображения в папку)

(одним файлом)
Метод Ole-объекта SaveImagesToFolder (Сохранить изображения в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка
Prefix | string[128] | Нет | Префикс имени файла

Замечания:

Возвращает значение типа Integer.


Метод Ole-объекта SaveMethodsToFolder (Сохранить методы в папку)

(одним файлом)
Метод Ole-объекта SaveMethodsToFolder (Сохранить методы в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка

Замечания:

Возвращает значение типа Integer.


Метод Ole-объекта SaveTemplatesToFolder (Сохранить шаблоны в папку)

(одним файлом)
Метод Ole-объекта SaveTemplatesToFolder (Сохранить шаблоны в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка
ExportCodeModules | Boolean | Да | Экспортировать программные модули

Замечания:

Возвращает значение типа Integer.


Шаблон XSLT-отчета ClassesDiagram (Диаграмма классов)

(одним файлом)
Шаблон XSLT-отчета ClassesDiagram (Диаграмма классов)

Шаблон XSLT-отчета класса (статический шаблон) класса TClass.

Шаблон отчета Word является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ShowFields | Boolean | Да | Показывать поля
ShowMethods | Boolean | Да | Показывать методы
ShowProperties | Boolean | Да | Показывать свойства
ShowParameters | Boolean | Да | Показывать параметры
ShowMetadata | Boolean | Да | Показывать метаданные
GroupByMaster | Boolean | Да | Группировать по принадлежности


Класс TClassBan (Запрет на класс)

(раздел целиком) (одним файлом)
Класс TClassBan (Запрет на класс)

Класс TBanGroupItem (Элементы группы запретов)Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор запрета на класс)
См. также
  • Класс TBanGroup (Группы запретов)
  • Класс TBanGroupItem (Элементы группы запретов)


Свойства

(одним файлом)
Свойства

Свойства класса TClassBan:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TBanGroup | Да | Видимо пользователю | Только для чтения | Унаследовано от TBanGroupItem
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
BannedClass | TClass | Да | Видимо пользователю | Только для чтения | Запрещаемый класс

См. также
  • Класс TBanGroup (Группы запретов)
  • Класс TBanGroupItem (Элементы группы запретов)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор запрета на класс)

(одним файлом)
Конструктор Create (Конструктор запрета на класс)

Конструктор класса TClassBan.

1constructor TClassBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass): TObject;

Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
BannedClass | TClass | Да | Запрещаемый класс

Замечания:

Создает новый объект класса TClassBan.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор элемента группы запретов)


Класс TClassDomain (Ссылки на объекты)

(раздел целиком) (одним файлом)
Класс TClassDomain (Ссылки на объекты)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор домена-ссылки)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TDomain (Домены)


Свойства

(одним файлом)
Свойства

Свойства класса TClassDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
ClassOfDomain | TClass | Нет | Видимо пользователю | Чтение/Запись | Класс домена
ClassReplicationStatus | TReplicationStatus | Да | Видимо пользователю | Чтение/Запись | Статус репликации класса
ShowObjectInfoType | TShowObjectInfoType | Да | Видимо пользователю | Чтение/Запись | Тип представления объектов
DeleteRule | TDeleteRule | Да | Видимо пользователю | Чтение/Запись | Правило удаления
FilterCondition | clob | Нет | Видимо пользователю | Чтение/Запись | Условие отбора
View | TCustomView | Нет | Видимо пользователю | Чтение/Запись | Представление
CaseInsensitiveSearch | Boolean | Да | Видимо пользователю | Чтение/Запись | Регистронезависимый поиск

См. также
  • Класс TClass (Классы)
  • Класс TCustomView (Абстрактное представление)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TDeleteRule (Правило удаления)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TShowObjectInfoType (Тип представления объектов)


Конструктор Create (Конструктор домена-ссылки)

(одним файлом)
Конструктор Create (Конструктор домена-ссылки)

Конструктор класса TClassDomain.

1constructor TClassDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; ClassOfDomain: TClass; View: TCustomView;
4  FilterCondition: clob; ShowObjectInfoType: TShowObjectInfoType;
5  DeleteRule: TDeleteRule; CaseInsensitiveSearch: Boolean): TDomain;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
ClassOfDomain | TClass | Да | Класс домена
View | TCustomView | Нет | Представление для выбора
FilterCondition | clob | Нет | Условие отбора
ShowObjectInfoType | TShowObjectInfoType | Да | Тип представления объектов
DeleteRule | TDeleteRule | Да | Правило удаления
CaseInsensitiveSearch | Boolean | Да | Регистронезависимый поиск

Замечания:

Создает новый объект класса TClassDomain.

См. также
  • Класс TClass (Классы)
  • Класс TCustomView (Абстрактное представление)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TDeleteRule (Правило удаления)
  • Перечисление TShowObjectInfoType (Тип представления объектов)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TClassDomain.

function TClassDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)


Класс TClassMember (Члены класса)

(раздел целиком) (одним файлом)
Класс TClassMember (Члены класса)

Диаграмма Класс TObject (Объекты)Класс TClass (Классы)

  • Свойства
  • Конструктор Create (Конструктор члена класса)
  • Метод GetOverride (Переопределен)
  • Метод SuggestFileName (Предложить имя файла)
См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TClassMember:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Переопределен

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор члена класса)

(одним файлом)
Конструктор Create (Конструктор члена класса)

Конструктор класса TClassMember.

1constructor TClassMember.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Имя
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TClassMember.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetOverride (Переопределен)

(одним файлом)
Метод GetOverride (Переопределен)

Метод экземпляра класса TClassMember.

function TClassMember.GetOverride: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод SuggestFileName (Предложить имя файла)

(одним файлом)
Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TClassMember.

function TClassMember.SuggestFileName(Domain: TDomain): string[128];

Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя | Тип | Обязательно | Значение
Domain | TDomain | Нет | Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

См. также
  • Класс TDomain (Домены)
  • Метод SuggestFileName (Предложить имя файла)


Класс TCommandButton (Командные кнопки)

(раздел целиком) (одним файлом)
Класс TCommandButton (Командные кнопки)

Диаграмма Класс TCustomButton (Кнопки)Класс TObject (Объекты)Класс TRoutine (Подпрограмма)

  • Свойства
  • Конструктор Create (Конструктор командной кнопки)
  • Метод GetNextPos (Следующая позиция)
  • Метод GetOverride (Переопределена)
См. также
  • Класс TCustomButton (Кнопки)
  • Класс TRoutine (Подпрограмма)


Свойства

(одним файлом)
Свойства

Свойства класса TCommandButton:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TRoutine | Да | Видимо пользователю | Только для чтения | Мастер
MasterClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс подпрограммы
MasterMaster | TObject | Да | Скрыто от пользователя | Только для чтения | Мастер подпрограммы
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TCustomButton
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Переопределена
Parameter | TParameter | Нет | Видимо пользователю | Чтение/Запись | Связанный параметр

См. также
  • Класс TClass (Классы)
  • Класс TCustomButton (Кнопки)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TParameter (Параметры)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор командной кнопки)

(одним файлом)
Конструктор Create (Конструктор командной кнопки)

Конструктор класса TCommandButton.

1constructor TCommandButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean; Parameter: TParameter): TObject;

Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция
Group | string[128] | Нет | Унаследовано от TCustomButton.Create
Tab | string[128] | Нет
Script | clob | Нет
Scope | TScope | Да
OutOfTabs | Boolean | Да
Parameter | TParameter | Нет | Связанный параметр

Замечания:

Создает новый объект класса TCommandButton.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TParameter (Параметры)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор кнопки)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TScope (Область видимости)


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TCommandButton.

class function TCommandButton.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Метод GetOverride (Переопределена)

(одним файлом)
Метод GetOverride (Переопределена)

Метод экземпляра класса TCommandButton.

function TCommandButton.GetOverride: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Класс TContextKey (Ключи контекстной помощи)

(раздел целиком) (одним файлом)
Класс TContextKey (Ключи контекстной помощи)

Класс TObject (Объекты)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор ключа)
  • Метод GenerateAllKeys (Сгенерировать ключи)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TContextKey:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Storage | string[64] | Да | Видимо пользователю | Чтение/Запись | Хранилище
LinkedObject | TObject | Нет | Видимо пользователю | Чтение/Запись | Связанный объект
LinkedObjectClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс связанного объекта
LinkedObjectMaster | TObject | Да | Скрыто от пользователя | Только для чтения | Мастер связанного объекта

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор ключа)

(одним файлом)
Конструктор Create (Конструктор ключа)

Конструктор класса TContextKey.

1constructor TContextKey.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Storage: string[64]; LinkedObject: TObject): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да | Ключевое словосочетание
Class | TClass | Нет | Унаследовано от TObject.Create
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Storage | string[64] | Да | Хранилище
LinkedObject | TObject | Нет | Связанный объект

Замечания:

Создает новый объект класса TContextKey.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GenerateAllKeys (Сгенерировать ключи)

(одним файлом)
Метод GenerateAllKeys (Сгенерировать ключи)

Метод класса (статический метод) класса TContextKey.

class procedure TContextKey.GenerateAllKeys(Storage: string[64]);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Storage | string[64] | Да | Хранилище


Класс TCustomButton (Кнопки)

(раздел целиком) (одним файлом)
Класс TCustomButton (Кнопки)

Диаграмма Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор кнопки)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TCustomButton:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок закладки
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок группы
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Script | clob | Нет | Видимо пользователю | Чтение/Запись | Скрипт
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись | За пределами закладок

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор кнопки)

(одним файлом)
Конструктор Create (Конструктор кнопки)

Конструктор класса TCustomButton.

1constructor TCustomButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Script | clob | Нет | Скрипт
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок

Замечания:

Создает новый объект класса TCustomButton.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TScope (Область видимости)


Класс TCustomView (Абстрактное представление)

(раздел целиком) (одним файлом)
Класс TCustomView (Абстрактное представление)

Диаграмма Класс TObject (Объекты)Класс TAction (Действия)Класс TRoutineAction (Программируемое действие)Класс TViewAction (Действие-представление)Класс TViewCondition (Условия отбора)Класс TFormViewAction (Действие-форма)

  • Свойства
  • Конструктор Create (Конструктор абстрактного представления)
  • Метод BuildDefaultActions (Создать действия по умолчанию)
  • Метод CreateContextKey (Создать ключ контекстной помощи)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TCustomView:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
ShownClass | TClass | Да | Видимо пользователю | Чтение/Запись | Класс
ShownClassMasterClass | TClass | Нет | Видимо пользователю | Только для чтения | Класс-мастер показываемого
ShownClassReplicationStatus | TReplicationStatus | Да | Видимо пользователю | Только для чтения | Статус репликации класса
ShownClassIsHierarhical | Boolean | Да | Видимо пользователю | Только для чтения | Иерархическое
Skimpy | Boolean | Да | Видимо пользователю | Чтение/Запись | Количество данных незначительно
BoldProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство выделенного шрифта
PreCompiled | Boolean | Да | Видимо пользователю | Чтение/Запись | Предсобранное
PreOpenRoutine | TRoutine | Нет | Видимо пользователю | Чтение/Запись | Вызывать перед открытием
ColorProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство цвета
OptimizationParameters | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Параметры оптимизации
HasConditions | Boolean | Да | Видимо пользователю | Только для чтения | Имеются условия отбора
HasSpecificalyNamedColumns | Boolean | Да | Видимо пользователю | Только для чтения | Имеет колонки со специфическими именами
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор абстрактного представления)

(одним файлом)
Конструктор Create (Конструктор абстрактного представления)

Конструктор класса TCustomView.

1constructor TCustomView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
ShownClass | TClass | Да | Класс
ColorProperty | TProperty | Нет | Свойство цвета
BoldProperty | TProperty | Нет | Свойство выделенного шрифта
Skimpy | Boolean | Да | Количество данных незначительно
PreCompiled | Boolean | Да | Предсобранное
PreOpenRoutine | TRoutine | Нет | Вызывать перед открытием

Замечания:

Создает новый объект класса TCustomView.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод BuildDefaultActions (Создать действия по умолчанию)

(одним файлом)
Метод BuildDefaultActions (Создать действия по умолчанию)

Метод экземпляра класса TCustomView.

1procedure TCustomView.BuildDefaultActions(AddConstructor: Boolean;
2  AddDestructor: Boolean; AddMethods: Boolean; AddReports: Boolean;
3  AddCopyPasteActions: Boolean; AddStandartActions: Boolean;
4  PositionStep: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
AddConstructor | Boolean | Да | Добавить конструктор
AddDestructor | Boolean | Да | Добавить деструктор
AddMethods | Boolean | Да | Добавить методы
AddReports | Boolean | Да | Добавить шаблоны отчетов
AddCopyPasteActions | Boolean | Да | Добавить работу с буфером обмена
AddStandartActions | Boolean | Да | Добавить стандартные действия
PositionStep | Integer | Да | Шаг


Метод CreateContextKey (Создать ключ контекстной помощи)

(одним файлом)
Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TCustomView.

procedure TCustomView.CreateContextKey(Storage: string[64]);

Параметры:

Имя | Тип | Обязательно | Значение
Storage | string[64] | Да | Хранилище


Класс TDataBase (Базы данных)

(раздел целиком) (одним файлом)
Класс TDataBase (Базы данных)

Диаграмма Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор базы данных)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TDataBase:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
GUID | string[38] | Да | Видимо пользователю | Только для чтения | Идентификатор
IsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Является текущей
Protected | Boolean | Да | Видимо пользователю | Чтение/Запись | Защищена от изменений

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор базы данных)

(одним файлом)
Конструктор Create (Конструктор базы данных)

Конструктор класса TDataBase.

1constructor TDataBase.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  GUID: string[38]; Protected: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
GUID | string[38] | Да | GUID
Protected | Boolean | Да | Защищена

Замечания:

Создает новый объект класса TDataBase.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Класс TDateDomain (Даты)

(раздел целиком) (одним файлом)
Класс TDateDomain (Даты)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

  • Конструктор Create (Конструктор домена даты)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TDomain (Домены)


Конструктор Create (Конструктор домена даты)

(одним файлом)
Конструктор Create (Конструктор домена даты)

Конструктор класса TDateDomain.

1constructor TDateDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create

Замечания:

Создает новый объект класса TDateDomain.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateDomain.

function TDateDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)


Класс TDateTimeDomain (Даты со временем)

(раздел целиком) (одним файлом)
Класс TDateTimeDomain (Даты со временем)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор домена даты со временем)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TDomain (Домены)


Свойства

(одним файлом)
Свойства

Свойства класса TDateTimeDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
HideSeconds | Boolean | Да | Видимо пользователю | Чтение/Запись | Не показывать секунды

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор домена даты со временем)

(одним файлом)
Конструктор Create (Конструктор домена даты со временем)

Конструктор класса TDateTimeDomain.

1constructor TDateTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
HideSeconds | Boolean | Да | Не показывать секунды

Замечания:

Создает новый объект класса TDateTimeDomain.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateTimeDomain.

function TDateTimeDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)


Класс TDependency (Зависимости)

(раздел целиком) (одним файлом)
Класс TDependency (Зависимости)

Класс TObject (Объекты)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор зависимости)
  • Метод Install (Установить)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TDependency:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Dependent | TObject | Нет | Видимо пользователю | Чтение/Запись | Зависимый объект
DependentClass | TClass | Да | Видимо пользователю | Только для чтения | Класс зависимого объекта
DependentMaster | TObject | Да | Видимо пользователю | Только для чтения | Мастер зависимого объекта
DependentExternal | string[256] | Нет | Видимо пользователю | Чтение/Запись | Внешний зависимый объект
DependedOn | TObject | Да | Видимо пользователю | Чтение/Запись | Зависит от
DependedOnClass | TClass | Да | Видимо пользователю | Только для чтения | Класс объекта, от которого зависит
DependedOnMaster | TObject | Да | Видимо пользователю | Только для чтения | Мастер объекта, от которого зависит

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор зависимости)

(одним файлом)
Конструктор Create (Конструктор зависимости)

Конструктор класса TDependency.

1constructor TDependency.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Dependent: TObject; DependentExternal: string[256];
4  DependedOn: TObject): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Dependent | TObject | Нет | Зависимый объект
DependentExternal | string[256] | Нет | Внешний зависимый объект
DependedOn | TObject | Да | Зависит от

Замечания:

Создает новый объект класса TDependency.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод Install (Установить)

(одним файлом)
Метод Install (Установить)

Метод класса (статический метод) класса TDependency.

1class procedure TDependency.Install(ADependent: TObject;
2  ADependentExternal: string[256]; ADependedOn: TObject);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ADependent | TObject | Нет | Зависимый объект
ADependentExternal | string[256] | Нет | Внешний зависимый объект
ADependedOn | TObject | Да | Зависит от

См. также
  • Класс TObject (Объекты)


Класс TDomain (Домены)

(раздел целиком) (одним файлом)
Класс TDomain (Домены)

Диаграмма Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор домена)
  • Метод GetDefinition (Определение домена)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Обязательно для заполнения
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество внешних зависимостей
Definition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения | Сводка

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор домена)

(одним файлом)
Конструктор Create (Конструктор домена)

Конструктор класса TDomain.

1constructor TDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TDomain;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Обязательно для заполнения

Замечания:

Создает новый объект класса TDomain.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetDefinition (Определение домена)

(одним файлом)
Метод GetDefinition (Определение домена)

Метод экземпляра класса TDomain.

function TDomain.GetDefinition: string[64];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TDomain.

function TDomain.GetSummary: string[2000];

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Класс TEnumerationDomain (Перечисления)

(раздел целиком) (одним файлом)
Класс TEnumerationDomain (Перечисления)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)Класс TEnumerationItem (Элементы перечислений)

  • Свойства
  • Конструктор Create (Конструктор перечисления)
  • Метод GetSummary (Получить сводку)
  • Метод ListItems (Список элементов)
См. также
  • Класс TDomain (Домены)


Свойства

(одним файлом)
Свойства

Свойства класса TEnumerationDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
ShowNames | Boolean | Да | Видимо пользователю | Чтение/Запись | Показывать имена
BasedOnDomain | TEnumerationDomain | Нет | Видимо пользователю | Чтение/Запись | Расширяет домен
ItemCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество элементов
CaseInsensitiveSearch | Boolean | Да | Видимо пользователю | Чтение/Запись | Регистронезависимый поиск

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор перечисления)

(одним файлом)
Конструктор Create (Конструктор перечисления)

Конструктор класса TEnumerationDomain.

1constructor TEnumerationDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; ShowNames: Boolean;
4  BasedOnDomain: TEnumerationDomain; CaseInsensitiveSearch: Boolean): TDomain;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
ShowNames | Boolean | Да | Показывать имена элементов
BasedOnDomain | TEnumerationDomain | Нет | Расширяет домен
CaseInsensitiveSearch | Boolean | Да | Регистронезависимый поиск

Замечания:

Создает новый объект класса TEnumerationDomain.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TEnumerationDomain.

function TEnumerationDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)


Метод ListItems (Список элементов)

(одним файлом)
Метод ListItems (Список элементов)

Метод экземпляра класса TEnumerationDomain.

function TEnumerationDomain.ListItems: TObjectList;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.

См. также
  • Класс TObjectList (Списки)


Класс TEnumerationItem (Элементы перечислений)

(раздел целиком) (одним файлом)
Класс TEnumerationItem (Элементы перечислений)

Диаграмма Класс TObject (Объекты)Класс TEnumerationDomain (Перечисления)

  • Свойства
  • Конструктор Create (Конструктор элемента перечисления)
  • Метод GetNextPos (Следующая позиция)
См. также
  • Класс TEnumerationDomain (Перечисления)
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TEnumerationItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TEnumerationDomain (Перечисления)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор элемента перечисления)

(одним файлом)
Конструктор Create (Конструктор элемента перечисления)

Конструктор класса TEnumerationItem.

1constructor TEnumerationItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция

Замечания:

Создает новый объект класса TEnumerationItem.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TEnumerationItem.

class function TEnumerationItem.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Класс TExcelAsyncTask (Задачи отложенного выполнения отчетов Excel)

(раздел целиком) (одним файлом)
Класс TExcelAsyncTask (Задачи отложенного выполнения отчетов Excel)

Класс TAsyncTask (Задачи отложенного выполнения)Класс TObject (Объекты)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор задачи отложенного выполнения отчетов Excel)
См. также
  • Класс TAsyncTask (Задачи отложенного выполнения)


Свойства

(одним файлом)
Свойства

Свойства класса TExcelAsyncTask:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Видимо пользователю | Только для чтения | Унаследовано от TAsyncTask
Created | datetime | Да | Видимо пользователю | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Status | TAsyncTaskStatus | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TAsyncTask
Routine | TRoutine | Да | Видимо пользователю | Чтение/Запись
RoutineClass | TClass | Да | Скрыто от пользователя | Только для чтения
Language | TLanguage | Да | Видимо пользователю | Чтение/Запись
Handler | TAsyncHandler | Да | Видимо пользователю | Чтение/Запись
FormView | TFormView | Нет | Видимо пользователю | Чтение/Запись
Object | TObject | Нет | Видимо пользователю | Чтение/Запись
Started | datetime | Нет | Видимо пользователю | Чтение/Запись
Finished | datetime | Нет | Видимо пользователю | Чтение/Запись
Duration | time | Нет | Видимо пользователю | Только для чтения
Bold | Boolean | Да | Скрыто от пользователя | Только для чтения
RowColor | TRowColor | Нет | Скрыто от пользователя | Только для чтения
Group | TAsyncTask | Нет | Видимо пользователю | Только для чтения
GroupContentReady | Boolean | Да | Скрыто от пользователя | Только для чтения
Format | TExcelOutputFormat | Да | Видимо пользователю | Чтение/Запись | Формат
ColorMode | TOutputColorMode | Да | Видимо пользователю | Чтение/Запись | Режим цветопередачи
EmbedFonts | Boolean | Да | Видимо пользователю | Чтение/Запись | Внедрять шрифты

См. также
  • Класс TAsyncHandler (Обработчики отложенного выполнения)
  • Класс TAsyncTask (Задачи отложенного выполнения)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TFormView (Представления формы)
  • Класс TLanguage (Языки)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TAsyncTaskStatus (Состояние задачи отложенного выполнения)
  • Перечисление TExcelOutputFormat (Формат результата отчета Excel)
  • Перечисление TOutputColorMode (Режим цветопередачи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TRowColor (Цвет строки таблицы)


Конструктор Create (Конструктор задачи отложенного выполнения отчетов Excel)

(одним файлом)
Конструктор Create (Конструктор задачи отложенного выполнения отчетов Excel)

Конструктор класса TExcelAsyncTask.

1constructor TExcelAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TExcelOutputFormat;
5  ColorMode: TOutputColorMode; EmbedFonts: Boolean): TObject;

Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Routine | TRoutine | Да | Унаследовано от TAsyncTask.Create
Object | TObject | Нет
FormView | TFormView | Нет
Handler | TAsyncHandler | Да
Language | TLanguage | Да
Format | TExcelOutputFormat | Да | Формат
ColorMode | TOutputColorMode | Да | Режим цветопередачи
EmbedFonts | Boolean | Да | Внедрять шрифты

Замечания:

Создает новый объект класса TExcelAsyncTask.

См. также
  • Класс TAsyncHandler (Обработчики отложенного выполнения)
  • Класс TClass (Классы)
  • Класс TFormView (Представления формы)
  • Класс TLanguage (Языки)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор задачи отложенного выполнения)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TExcelOutputFormat (Формат результата отчета Excel)
  • Перечисление TOutputColorMode (Режим цветопередачи)


Класс TExcelTemplate (Шаблоны отчетов Excel)

(раздел целиком) (одним файлом)
Класс TExcelTemplate (Шаблоны отчетов Excel)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

  • Свойства
  • Конструктор Create (Конструктор шаблона Excel)
  • Метод Ole-объекта CheckExcelTemplate (Проверить шаблон отчетов Excel)
См. также
  • Класс TClass (Классы)
  • Класс TRoutine (Подпрограмма)


Свойства

(одним файлом)
Свойства

Свойства класса TExcelTemplate:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
TemplateData | blob | Нет | Видимо пользователю | Чтение/Запись | Данные шаблона
PlaceDataOnSheet | TExcelSheetKind | Да | Видимо пользователю | Чтение/Запись | Лист для переноса данных
MacroName | string[128] | Нет | Видимо пользователю | Чтение/Запись | Имя макроса
IsInteractive | Boolean | Да | Видимо пользователю | Чтение/Запись | Интерактивный

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TExcelSheetKind (Тип листа Excel)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор шаблона Excel)

(одним файлом)
Конструктор Create (Конструктор шаблона Excel)

Конструктор класса TExcelTemplate.

1constructor TExcelTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  PlaceDataOnSheet: TExcelSheetKind; MacroName: string[128];
7  IsInteractive: Boolean): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
TemplateData | blob | Нет | Данные шаблона
PlaceDataOnSheet | TExcelSheetKind | Да | Лист для переноса данных
MacroName | string[128] | Нет | Имя макроса
IsInteractive | Boolean | Да | Интерактивный

Замечания:

Создает новый объект класса TExcelTemplate.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор подпрограммы)
  • Конструктор Create (Конструктор члена класса)
  • Перечисление TExcelSheetKind (Тип листа Excel)
  • Перечисление TScope (Область видимости)


Метод Ole-объекта CheckExcelTemplate (Проверить шаблон отчетов Excel)

(одним файлом)
Метод Ole-объекта CheckExcelTemplate (Проверить шаблон отчетов Excel)

Метод Ole-объекта класса TExcelTemplate.

Метод Ole-объекта не имеет параметров.


Класс TExternalDataDomain (Внешние данные)

(раздел целиком) (одним файлом)
Класс TExternalDataDomain (Внешние данные)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)Класс TExternalDataResource (Ресурсы внешних данных)

  • Свойства
  • Конструктор Create (Конструктор домена внешних данных)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TDomain (Домены)


Свойства

(одним файлом)
Свойства

Свойства класса TExternalDataDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
NamesSequence | TSequence | Нет | Видимо пользователю | Чтение/Запись | Последовательность для формирования имен
ContentDomain | TBlobDomain | Да | Видимо пользователю | Чтение/Запись | Домен содержимого
ContentDomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена содержимого
ContentDomainBlobSubtype | TBlobSubtype | Да | Видимо пользователю | Только для чтения | Подтип домена содержимого
ContentDomainExtension | string[10] | Нет | Видимо пользователю | Только для чтения | Расширение домена содержимого
ResourceCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество ресурсов
ContentDependentNames | Boolean | Да | Видимо пользователю | Чтение/Запись | Имя зависит от содержимого
Compress | Boolean | Да | Видимо пользователю | Чтение/Запись | Сжимать содержимое

См. также
  • Класс TBlobDomain (Большие объекты)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TSequence (Последовательности)
  • Класс TUser (Пользователи)
  • Перечисление TBlobSubtype (Подтип)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор домена внешних данных)

(одним файлом)
Конструктор Create (Конструктор домена внешних данных)

Конструктор класса TExternalDataDomain.

1constructor TExternalDataDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; NamesSequence: TSequence;
4  ContentDomain: TBlobDomain; ContentDependentNames: Boolean;
5  Compress: Boolean): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
NamesSequence | TSequence | Нет | Последовательность для формирования имен
ContentDomain | TBlobDomain | Да | Домен содержимого
ContentDependentNames | Boolean | Да | Имя зависит от содержимого
Compress | Boolean | Да | Сжимать содержимое

Замечания:

Создает новый объект класса TExternalDataDomain.

См. также
  • Класс TBlobDomain (Большие объекты)
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TSequence (Последовательности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TExternalDataDomain.

function TExternalDataDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)


Класс TExternalDataResource (Ресурсы внешних данных)

(раздел целиком) (одним файлом)
Класс TExternalDataResource (Ресурсы внешних данных)

Диаграмма Класс TObject (Объекты)Класс TExternalDataDomain (Внешние данные)

  • Свойства
  • Конструктор Create (Конструктор ресурса внешних данных)
  • Метод FileNameClause (Кляуза имени поля)
  • Метод FindUsedName (Найти использованное имя)
  • Метод GetUsedFileNames (Получить список использованных имен)
  • Метод Ole-объекта CheckExternalData (Проверить внешние данные)
  • Метод Ole-объекта SaveExternalData (Сохранить внешние данные)
См. также
  • Класс TExternalDataDomain (Внешние данные)
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TExternalDataResource:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
GUID | string[38] | Да | Видимо пользователю | Чтение/Запись | GUID
Protocol | TExternalDataProtocol | Да | Видимо пользователю | Чтение/Запись | Протокол доступа
Host | string[64] | Да | Видимо пользователю | Чтение/Запись | Хост
Port | Integer | Нет | Видимо пользователю | Чтение/Запись | Порт
Path | string[255] | Да | Видимо пользователю | Чтение/Запись | Папка
UserName | string[255] | Нет | Видимо пользователю | Чтение/Запись | Имя пользователя
Password | string[255] | Нет | Видимо пользователю | Чтение/Запись | Пароль
ReadOnly | Boolean | Да | Видимо пользователю | Чтение/Запись | Только для чтения

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TExternalDataDomain (Внешние данные)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TExternalDataProtocol (Протокол доступа к внешним данным)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор ресурса внешних данных)

(одним файлом)
Конструктор Create (Конструктор ресурса внешних данных)

Конструктор класса TExternalDataResource.

1constructor TExternalDataResource.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; GUID: string[38]; Protocol: TExternalDataProtocol;
4  Host: string[64]; Port: Integer; Path: string[255]; UserName: string[255];
5  Password: string[255]; ReadOnly: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
GUID | string[38] | Да | GUID
Protocol | TExternalDataProtocol | Да | Протокол доступа
Host | string[64] | Да | Хост
Port | Integer | Нет | Порт
Path | string[255] | Да | Папка
UserName | string[255] | Нет | Имя пользователя
Password | string[255] | Нет | Пароль
ReadOnly | Boolean | Да | Только для чтения

Замечания:

Создает новый объект класса TExternalDataResource.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TExternalDataProtocol (Протокол доступа к внешним данным)


Метод FileNameClause (Кляуза имени поля)

(одним файлом)
Метод FileNameClause (Кляуза имени поля)

Метод экземпляра класса TExternalDataResource.

function TExternalDataResource.FileNameClause(FieldName: string[64]): string[2000];

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
FieldName | string[64] | Да | Имя поля

Замечания:

Возвращает значение типа string[2000].


Метод FindUsedName (Найти использованное имя)

(одним файлом)
Метод FindUsedName (Найти использованное имя)

Метод экземпляра класса TExternalDataResource.

function TExternalDataResource.FindUsedName(Name: string[77]): clob;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[77] | Да | Имя

Замечания:

Возвращает значение типа clob.


Метод GetUsedFileNames (Получить список использованных имен)

(одним файлом)
Метод GetUsedFileNames (Получить список использованных имен)

Метод экземпляра класса TExternalDataResource.

function TExternalDataResource.GetUsedFileNames: clob;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.


Метод Ole-объекта CheckExternalData (Проверить внешние данные)

(одним файлом)
Метод Ole-объекта CheckExternalData (Проверить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя | Тип | Обязательно | Значение
FilesFolder | string[255] | Да | Файлы внешних данных
TrashFolder | string[255] | Да | Папка для неиспользуемых файлов


Метод Ole-объекта SaveExternalData (Сохранить внешние данные)

(одним файлом)
Метод Ole-объекта SaveExternalData (Сохранить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка для сохранения


Класс TField (Поля)

(раздел целиком) (одним файлом)
Класс TField (Поля)

Диаграмма Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

  • Свойства
  • Конструктор Create (Конструктор поля)
  • Метод SetLocalizable (Установить значение свойства "Локализуемое")
См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)


Свойства

(одним файлом)
Свойства

Свойства класса TField:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Видимо пользователю | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
Indexed | Boolean | Да | Видимо пользователю | Чтение/Запись | Индексируется
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись | Протоколировать
Localizable | Boolean | Да | Видимо пользователю | Чтение/Запись | Локализуемое

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор поля)

(одним файлом)
Конструктор Create (Конструктор поля)

Конструктор класса TField.

1constructor TField.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; CreateProperty: Boolean; CreateConstructorParameter: Boolean;
4  CreateViewColumns: Boolean; Logged: Boolean; Indexed: Boolean;
5  Localizable: Boolean): TObject;

Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
CreateProperty | Boolean | Да | Создать свойство
CreateConstructorParameter | Boolean | Да | Создать параметр конструктора
CreateViewColumns | Boolean | Да | Создать колонку во всех представлениях
Logged | Boolean | Да | Протоколировать
Indexed | Boolean | Да | Индексируется
Localizable | Boolean | Да | Локализуемое

Замечания:

Создает новый объект класса TField.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор члена класса)


Метод SetLocalizable (Установить значение свойства "Локализуемое")

(одним файлом)
Метод SetLocalizable (Установить значение свойства "Локализуемое")

Метод экземпляра класса TField.

procedure TField.SetLocalizable(Value: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение


Класс TFileNameDomain (Имена файлов)

(раздел целиком) (одним файлом)
Класс TFileNameDomain (Имена файлов)

Диаграмма Класс TStringDomain (Строковые)Класс TDomain (Домены)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор имени файла)
  • Метод Change (Изменение объекта)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TStringDomain (Строковые)


Свойства

(одним файлом)
Свойства

Свойства класса TFileNameDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
Length | Integer | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TStringDomain
AllowLeadingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись
AllowTrailingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись
AllowSpaceDuplication | Boolean | Да | Видимо пользователю | Чтение/Запись
CharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись
FirstCharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись
CaseMode | Boolean | Нет | Видимо пользователю | Чтение/Запись
Mask | string[2000] | Нет | Видимо пользователю | Чтение/Запись
CaseInsensitiveSearch | Boolean | Да | Видимо пользователю | Чтение/Запись
FileMustExist | Boolean | Да | Видимо пользователю | Чтение/Запись | Файл должен существовать
DefaultExtension | string[10] | Нет | Видимо пользователю | Чтение/Запись | Расширение по умолчанию
OverwritePrompt | Boolean | Да | Видимо пользователю | Чтение/Запись | Запрос перезаписи

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TStringDomain (Строковые)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор имени файла)

(одним файлом)
Конструктор Create (Конструктор имени файла)

Конструктор класса TFileNameDomain.

1constructor TFileNameDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean; FileMustExist: Boolean;
7  DefaultExtension: string[10]; OverwritePrompt: Boolean): TObject;

Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
Length | Integer | Да | Унаследовано от TStringDomain.Create
AllowLeadingSpaces | Boolean | Да
AllowTrailingSpaces | Boolean | Да
AllowSpaceDuplication | Boolean | Да
CharacterSet | string[2000] | Нет
FirstCharacterSet | string[2000] | Нет
CaseMode | Boolean | Нет
Mask | string[2000] | Нет
CaseInsensitiveSearch | Boolean | Да
FileMustExist | Boolean | Да | Файл должен существовать
DefaultExtension | string[10] | Нет | Расширение по умолчанию
OverwritePrompt | Boolean | Да | Запрос перезаписи

Замечания:

Создает новый объект класса TFileNameDomain.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор строкового домена)


Метод Change (Изменение объекта)

(одним файлом)
Метод Change (Изменение объекта)

Метод экземпляра класса TFileNameDomain.

procedure TFileNameDomain.Change(Action: TChangeAction);

Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Унаследовано от TObject.Change

См. также
  • Метод Change (Изменение объекта)
  • Перечисление TChangeAction (Действие при изменении)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TFileNameDomain.

function TFileNameDomain.GetSummary: string[2000];

Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)
  • Метод GetSummary (Получить сводку)


Класс TFilmstripView (Представление-диафильм)

(раздел целиком) (одним файлом)
Класс TFilmstripView (Представление-диафильм)

Диаграмма Класс TCustomView (Абстрактное представление)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор представления-диафильма)
См. также
  • Класс TCustomView (Абстрактное представление)


Свойства

(одним файлом)
Свойства

Свойства класса TFilmstripView:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
ShownClass | TClass | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TCustomView
ShownClassMasterClass | TClass | Нет | Видимо пользователю | Только для чтения
ShownClassReplicationStatus | TReplicationStatus | Да | Видимо пользователю | Только для чтения
ShownClassIsHierarhical | Boolean | Да | Видимо пользователю | Только для чтения
Skimpy | Boolean | Да | Видимо пользователю | Чтение/Запись
BoldProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
PreCompiled | Boolean | Да | Видимо пользователю | Чтение/Запись
PreOpenRoutine | TRoutine | Нет | Видимо пользователю | Чтение/Запись
ColorProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
OptimizationParameters | string[2000] | Нет | Видимо пользователю | Чтение/Запись
HasConditions | Boolean | Да | Видимо пользователю | Только для чтения
HasSpecificalyNamedColumns | Boolean | Да | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
LegendProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-подпись
ThumbnailProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-значок
ImageProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-изображение
ThumbnailSize | Integer | Да | Видимо пользователю | Чтение/Запись | Размер значка
OrderProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство, определяющее порядок

См. также
  • Класс TClass (Классы)
  • Класс TCustomView (Абстрактное представление)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор представления-диафильма)

(одним файлом)
Конструктор Create (Конструктор представления-диафильма)

Конструктор класса TFilmstripView.

1constructor TFilmstripView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  LegendProperty: TProperty; ThumbnailProperty: TProperty;
6  ImageProperty: TProperty; ThumbnailSize: Integer;
7  OrderProperty: TProperty): TObject;

Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
ShownClass | TClass | Да | Унаследовано от TCustomView.Create
ColorProperty | TProperty | Нет
BoldProperty | TProperty | Нет
Skimpy | Boolean | Да
PreCompiled | Boolean | Да
PreOpenRoutine | TRoutine | Нет
LegendProperty | TProperty | Нет | Свойство-подпись
ThumbnailProperty | TProperty | Нет | Свойство-значок
ImageProperty | TProperty | Нет | Свойство-изображение
ThumbnailSize | Integer | Да | Размер значка
OrderProperty | TProperty | Нет | Свойство, определяющее порядок

Замечания:

Создает новый объект класса TFilmstripView.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор абстрактного представления)
  • Конструктор Create (Конструктор объекта)


Класс TFloatDomain (Вещественные числа)

(раздел целиком) (одним файлом)
Класс TFloatDomain (Вещественные числа)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор вещественного домена)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TDomain (Домены)


Свойства

(одним файлом)
Свойства

Свойства класса TFloatDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
Length | Integer | Нет | Видимо пользователю | Чтение/Запись | Длина
DecimalPlaces | Integer | Нет | Видимо пользователю | Чтение/Запись | Количество десятичных знаков
MinValue | float | Нет | Видимо пользователю | Чтение/Запись | Минимальное значение
MaxValue | float | Нет | Видимо пользователю | Чтение/Запись | Максимальное значение
DigitGrouping | Boolean | Да | Видимо пользователю | Чтение/Запись | Разделять группы разрядов

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор вещественного домена)

(одним файлом)
Конструктор Create (Конструктор вещественного домена)

Конструктор класса TFloatDomain.

1constructor TFloatDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; DecimalPlaces: Integer; MinValue: float;
4  MaxValue: float; DigitGrouping: Boolean): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
Length | Integer | Нет | Длина
DecimalPlaces | Integer | Нет | Количество десятичных знаков
MinValue | float | Нет | Минимальное значение
MaxValue | float | Нет | Максимальное значение
DigitGrouping | Boolean | Да | Разделять группы разрядов

Замечания:

Создает новый объект класса TFloatDomain.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TFloatDomain.

function TFloatDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)


Класс TFolderNameDomain (Имена папок файловой системы)

(раздел целиком) (одним файлом)
Класс TFolderNameDomain (Имена папок файловой системы)

Диаграмма Класс TStringDomain (Строковые)Класс TDomain (Домены)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор имени папки)
  • Метод Change (Изменение объекта)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TStringDomain (Строковые)


Свойства

(одним файлом)
Свойства

Свойства класса TFolderNameDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
Length | Integer | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TStringDomain
AllowLeadingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись
AllowTrailingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись
AllowSpaceDuplication | Boolean | Да | Видимо пользователю | Чтение/Запись
CharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись
FirstCharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись
CaseMode | Boolean | Нет | Видимо пользователю | Чтение/Запись
Mask | string[2000] | Нет | Видимо пользователю | Чтение/Запись
CaseInsensitiveSearch | Boolean | Да | Видимо пользователю | Чтение/Запись
FolderMustExist | Boolean | Да | Видимо пользователю | Чтение/Запись | Папка должна существовать

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TStringDomain (Строковые)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор имени папки)

(одним файлом)
Конструктор Create (Конструктор имени папки)

Конструктор класса TFolderNameDomain.

1constructor TFolderNameDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; Length: Integer;
4  AllowLeadingSpaces: Boolean; AllowTrailingSpaces: Boolean;
5  AllowSpaceDuplication: Boolean; CharacterSet: string[2000];
6  FirstCharacterSet: string[2000]; CaseMode: Boolean; Mask: string[2000];
7  CaseInsensitiveSearch: Boolean; FolderMustExist: Boolean): TObject;

Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
Length | Integer | Да | Унаследовано от TStringDomain.Create
AllowLeadingSpaces | Boolean | Да
AllowTrailingSpaces | Boolean | Да
AllowSpaceDuplication | Boolean | Да
CharacterSet | string[2000] | Нет
FirstCharacterSet | string[2000] | Нет
CaseMode | Boolean | Нет
Mask | string[2000] | Нет
CaseInsensitiveSearch | Boolean | Да
FolderMustExist | Boolean | Да | Папка должна существовать

Замечания:

Создает новый объект класса TFolderNameDomain.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор строкового домена)


Метод Change (Изменение объекта)

(одним файлом)
Метод Change (Изменение объекта)

Метод экземпляра класса TFolderNameDomain.

procedure TFolderNameDomain.Change(Action: TChangeAction);

Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Унаследовано от TObject.Change

См. также
  • Метод Change (Изменение объекта)
  • Перечисление TChangeAction (Действие при изменении)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TFolderNameDomain.

function TFolderNameDomain.GetSummary: string[2000];

Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)
  • Метод GetSummary (Получить сводку)


Класс TForm (Формы)

(раздел целиком) (одним файлом)
Класс TForm (Формы)

Диаграмма Класс TObject (Объекты)Класс TFormAccess (Доступ к формам)Класс TFormView (Представления формы)Класс TFormOption (Настройки формы)

  • Свойства
  • Конструктор Create (Конструктор формы)
  • Метод CreateContextKey (Создать ключ контекстной помощи)
  • Метод GetIsAccessible (Доступна)
  • Метод GetNextPos (Следующая позиция)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TForm:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
AutoOpen | Boolean | Да | Видимо пользователю | Чтение/Запись | Открывать автоматически
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
Image | blob | Нет | Видимо пользователю | Чтение/Запись | Изображение-иконка
IsAccessible | Boolean | Да | Скрыто от пользователя | Только для чтения | Доступна
IsAlive | Boolean | Да | Видимо пользователю | Чтение/Запись | "Живая"
PreOpenRoutine | TRoutine | Нет | Видимо пользователю | Чтение/Запись | Вызывать перед открытием

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор формы)

(одним файлом)
Конструктор Create (Конструктор формы)

Конструктор класса TForm.

1constructor TForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  AutoOpen: Boolean; Position: Integer; Scope: TScope; Image: blob;
4  IsAlive: Boolean; PreOpenRoutine: TRoutine): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
AutoOpen | Boolean | Да | Открывать автоматически
Position | Integer | Да | Позиция
Scope | TScope | Да | Область видимости
Image | blob | Нет | Изображение-иконка
IsAlive | Boolean | Да | "Живая"
PreOpenRoutine | TRoutine | Нет | Вызывать перед открытием

Замечания:

Создает новый объект класса TForm.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TScope (Область видимости)


Метод CreateContextKey (Создать ключ контекстной помощи)

(одним файлом)
Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TForm.

procedure TForm.CreateContextKey(Storage: string[64]);

Параметры:

Имя | Тип | Обязательно | Значение
Storage | string[64] | Да | Хранилище


Метод GetIsAccessible (Доступна)

(одним файлом)
Метод GetIsAccessible (Доступна)

Метод экземпляра класса TForm.

function TForm.GetIsAccessible: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TForm.

class function TForm.GetNextPos: Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Класс TFormAccess (Доступ к формам)

(раздел целиком) (одним файлом)
Класс TFormAccess (Доступ к формам)

Класс TAccessItem (Элементы доступа)Класс TObject (Объекты)Класс TForm (Формы)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Конструктор Create (Конструктор доступа к форме)
См. также
  • Класс TAccessItem (Элементы доступа)
  • Класс TForm (Формы)


Конструктор Create (Конструктор доступа к форме)

(одним файлом)
Конструктор Create (Конструктор доступа к форме)

Конструктор класса TFormAccess.

1constructor TFormAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TForm; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TForm | Да | Форма
Accessor | TSecurityAccount | Нет | Унаследовано от TObject.Create
SecurityAccount | TSecurityAccount | Да | Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TFormAccess.

См. также
  • Класс TClass (Классы)
  • Класс TForm (Формы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор элемента доступа)


Класс TFormBan (Запрет на форму)

(раздел целиком) (одним файлом)
Класс TFormBan (Запрет на форму)

Класс TBanGroupItem (Элементы группы запретов)Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор запрета на форму)
См. также
  • Класс TBanGroup (Группы запретов)
  • Класс TBanGroupItem (Элементы группы запретов)


Свойства

(одним файлом)
Свойства

Свойства класса TFormBan:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TBanGroup | Да | Видимо пользователю | Только для чтения | Унаследовано от TBanGroupItem
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
BannedForm | TForm | Да | Видимо пользователю | Чтение/Запись | Запрещаемая форма

См. также
  • Класс TBanGroup (Группы запретов)
  • Класс TBanGroupItem (Элементы группы запретов)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TForm (Формы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор запрета на форму)

(одним файлом)
Конструктор Create (Конструктор запрета на форму)

Конструктор класса TFormBan.

1constructor TFormBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedForm: TForm): TObject;

Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
BannedForm | TForm | Да | Запрещаемая форма

Замечания:

Создает новый объект класса TFormBan.

См. также
  • Класс TClass (Классы)
  • Класс TForm (Формы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор элемента группы запретов)


Класс TFormOption (Настройки формы)

(раздел целиком) (одним файлом)
Класс TFormOption (Настройки формы)

Класс TObject (Объекты)Класс TForm (Формы)

Имена объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор настройки формы)
  • Метод GetNextPos (Следующая позиция)
См. также
  • Класс TForm (Формы)
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TFormOption:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Option | TOption | Да | Видимо пользователю | Чтение/Запись | Настройка
Position | Integer | Нет | Видимо пользователю | Чтение/Запись | Позиция
ShowEmptyValue | Boolean | Да | Видимо пользователю | Чтение/Запись | Показывать пустое значение

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TForm (Формы)
  • Класс TObject (Объекты)
  • Класс TOption (Настройки)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор настройки формы)

(одним файлом)
Конструктор Create (Конструктор настройки формы)

Конструктор класса TFormOption.

1constructor TFormOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Option: TOption; Position: Integer; ShowEmptyValue: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Option | TOption | Да | Настройка
Position | Integer | Нет | Позиция
ShowEmptyValue | Boolean | Да | Показывать пустое значение

Замечания:

Создает новый объект класса TFormOption.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TOption (Настройки)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormOption.

class function TFormOption.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Да | Мастер

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Класс TFormView (Представления формы)

(раздел целиком) (одним файлом)
Класс TFormView (Представления формы)

Класс TObject (Объекты)Класс TForm (Формы)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор представления формы)
  • Метод GetName (Сгенерировать имя объекта)
  • Метод GetNextPos (Следующая позиция)
См. также
  • Класс TForm (Формы)
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TFormView:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
ChildrenMinimized | Boolean | Да | Видимо пользователю | Чтение/Запись | Дочерние представления минимизированы
MasterProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-главное
DetailProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Свойство-подчиненное
View | TCustomView | Да | Видимо пользователю | Чтение/Запись | Представление
BoldProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство выделенного шрифта
ShownClass | TClass | Да | Видимо пользователю | Только для чтения | Показываемый класс
ColorProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство цвета
Layout | TFormViewLayout | Да | Видимо пользователю | Чтение/Запись | Расположение
ChildrenOnTabs | Boolean | Да | Видимо пользователю | Чтение/Запись | Дочерние представления на закладках
ExplicitQuery | Boolean | Да | Видимо пользователю | Чтение/Запись | Явный запрос
SpacePercentage | Integer | Нет | Видимо пользователю | Чтение/Запись | Площадь, %

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TCustomView (Абстрактное представление)
  • Класс TDataBase (Базы данных)
  • Класс TForm (Формы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TFormViewLayout (Виды расположения)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор представления формы)

(одним файлом)
Конструктор Create (Конструктор представления формы)

Конструктор класса TFormView.

1constructor TFormView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout;
6  ExplicitQuery: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
View | TCustomView | Да | Представление
ChildrenMinimized | Boolean | Да | Дочерние представления минимизированы
ChildrenOnTabs | Boolean | Да | Дочерние представления на закладках
MasterProperty | TProperty | Нет | Свойство-главное
DetailProperty | TClassMember | Нет | Свойство-подчиненное
Position | Integer | Да | Позиция
SpacePercentage | Integer | Нет | Площадь, %
Layout | TFormViewLayout | Да | Расположение
ExplicitQuery | Boolean | Да | Явный запрос

Замечания:

Создает новый объект класса TFormView.

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TCustomView (Абстрактное представление)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TFormViewLayout (Виды расположения)


Метод GetName (Сгенерировать имя объекта)

(одним файлом)
Метод GetName (Сгенерировать имя объекта)

Метод экземпляра класса TFormView.

function TFormView.GetName: string[64];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormView.

class function TFormView.GetNextPos(Parent: TObject; Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Parent | TObject | Нет | Родитель
Master | TObject | Да | Мастер

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Класс TFormViewAction (Действие-форма)

(раздел целиком) (одним файлом)
Класс TFormViewAction (Действие-форма)

Класс TAction (Действия)Класс TObject (Объекты)Класс TCustomView (Абстрактное представление)

Объекты класса образуют иерархию.

  • Свойства
  • Конструктор Create (Конструктор действия-формы)
См. также
  • Класс TAction (Действия)
  • Класс TCustomView (Абстрактное представление)


Свойства

(одним файлом)
Свойства

Свойства класса TFormViewAction:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Shortcut | string[20] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TAction
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Separated | Boolean | Да | Видимо пользователю | Чтение/Запись
Default | Boolean | Да | Видимо пользователю | Чтение/Запись
FormView | TFormView | Да | Видимо пользователю | Чтение/Запись | Представление формы
View | TCustomView | Да | Видимо пользователю | Чтение/Запись | Представление
ShownClass | TClass | Да | Видимо пользователю | Только для чтения | Показываемый класс
OverrideMasterProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Подменить свойство-главное
OverrideDetailProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Подменить свойство-подчиненное

См. также
  • Класс TAction (Действия)
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TCustomView (Абстрактное представление)
  • Класс TDataBase (Базы данных)
  • Класс TFormView (Представления формы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор действия-формы)

(одним файлом)
Конструктор Create (Конструктор действия-формы)

Конструктор класса TFormViewAction.

1constructor TFormViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  FormView: TFormView; OverrideMasterProperty: TProperty;
5  OverrideDetailProperty: TClassMember): TObject;

Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TAction.Create
Shortcut | string[20] | Нет
Separated | Boolean | Да
Default | Boolean | Да
FormView | TFormView | Да | Представление формы
OverrideMasterProperty | TProperty | Нет | Подменить свойство-главное свойством
OverrideDetailProperty | TClassMember | Нет | Подменить свойство-подчиненное свойством

Замечания:

Создает новый объект класса TFormViewAction.

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TFormView (Представления формы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор действия)
  • Конструктор Create (Конструктор объекта)


Класс TImportedReplica (Импортированные реплики)

(раздел целиком) (одним файлом)
Класс TImportedReplica (Импортированные реплики)

Класс TObject (Объекты)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор импортированной реплики)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TImportedReplica:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
CRC | string[8] | Нет | Видимо пользователю | Чтение/Запись | Контрольная сумма
MetadataCRC | string[8] | Нет | Видимо пользователю | Чтение/Запись | Контрольная сумма метаданных

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор импортированной реплики)

(одним файлом)
Конструктор Create (Конструктор импортированной реплики)

Конструктор класса TImportedReplica.

1constructor TImportedReplica.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CRC: string[8]): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
CRC | string[8] | Нет | Контрольная сумма

Замечания:

Создает новый объект класса TImportedReplica.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Класс TInlineExpression (Встраиваемое выражение)

(раздел целиком) (одним файлом)
Класс TInlineExpression (Встраиваемое выражение)

Диаграмма Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

  • Свойства
  • Конструктор Create (Конструктор встраиваемого выражения)
См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)


Свойства

(одним файлом)
Свойства

Свойства класса TInlineExpression:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Expression | clob | Нет | Видимо пользователю | Чтение/Запись | Выражение
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Видимо пользователю | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор встраиваемого выражения)

(одним файлом)
Конструктор Create (Конструктор встраиваемого выражения)

Конструктор класса TInlineExpression.

1constructor TInlineExpression.Create(Name: string[30];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Expression: clob; Domain: TDomain): TObject;

Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Expression | clob | Нет | Выражение
Domain | TDomain | Да | Домен

Замечания:

Создает новый объект класса TInlineExpression.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор члена класса)


Класс TInstantContact (Контакты)

(раздел целиком) (одним файлом)
Класс TInstantContact (Контакты)

Класс TObject (Объекты)Класс TUser (Пользователи)

Имена объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор контакта)
  • Метод AddContact (Добавить контакт)
  • Метод LastUsedContact (Получить последний использованный контакт)
См. также
  • Класс TObject (Объекты)
  • Класс TUser (Пользователи)


Свойства

(одним файлом)
Свойства

Свойства класса TInstantContact:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Owner | TUser | Да | Видимо пользователю | Только для чтения | Владелец
IsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Владелец - текущий пользователь
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
Status | TInstantContactStatus | Да | Видимо пользователю | Чтение/Запись | Статус
BackContact | TInstantContact | Нет | Видимо пользователю | Только для чтения | Ответный контакт
BackContactStatus | TInstantContactStatus | Да | Видимо пользователю | Только для чтения | Состояние ответного контакта

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TInstantContactStatus (Статус контакта)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор контакта)

(одним файлом)
Конструктор Create (Конструктор контакта)

Конструктор класса TInstantContact.

1constructor TInstantContact.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Status: TInstantContactStatus): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
User | TUser | Да | Пользователь
Status | TInstantContactStatus | Да | Статус

Замечания:

Создает новый объект класса TInstantContact.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TInstantContactStatus (Статус контакта)


Метод AddContact (Добавить контакт)

(одним файлом)
Метод AddContact (Добавить контакт)

Метод класса (статический метод) класса TInstantContact.

class function TInstantContact.AddContact(Master: TUser; User: TUser): TObject;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TUser | Да | Мастер
User | TUser | Да | Пользователь

Замечания:

Возвращает значение типа TObject.

См. также
  • Класс TObject (Объекты)
  • Класс TUser (Пользователи)


Метод LastUsedContact (Получить последний использованный контакт)

(одним файлом)
Метод LastUsedContact (Получить последний использованный контакт)

Метод класса (статический метод) класса TInstantContact.

class function TInstantContact.LastUsedContact(AUser: TUser): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AUser | TUser | Да | Пользователь

Замечания:

Возвращает значение типа TObject.

См. также
  • Класс TObject (Объекты)
  • Класс TUser (Пользователи)


Класс TInstantMessage (Сообщения)

(раздел целиком) (одним файлом)
Класс TInstantMessage (Сообщения)

Класс TObject (Объекты)Класс TUser (Пользователи)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор сообщения)
  • Метод Archive (Отправить в архив)
  • Метод Clear (Очистить)
См. также
  • Класс TObject (Объекты)
  • Класс TUser (Пользователи)


Свойства

(одним файлом)
Свойства

Свойства класса TInstantMessage:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Owner | TUser | Да | Видимо пользователю | Только для чтения | Владелец
User | TUser | Да | Видимо пользователю | Чтение/Запись | Пользователь
Message | string[255] | Да | Видимо пользователю | Только для чтения | Сообщение
DeliveryTime | datetime | Да | Видимо пользователю | Только для чтения | Время доставки
AttachmentType | TInstantMessageAttachmentType (None) | Да | Скрыто от пользователя | Только для чтения | Тип вложения

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TInstantMessageAttachmentType (None) (Тип вложения мгновенного сообщения (None))
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор сообщения)

(одним файлом)
Конструктор Create (Конструктор сообщения)

Конструктор класса TInstantMessage.

1constructor TInstantMessage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Message: string[255]; DeliveryTime: datetime): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
User | TUser | Да | Пользователь
Message | string[255] | Да | Сообщение
DeliveryTime | datetime | Нет | Время доставки

Замечания:

Создает новый объект класса TInstantMessage.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Конструктор Create (Конструктор объекта)


Метод Archive (Отправить в архив)

(одним файлом)
Метод Archive (Отправить в архив)

Метод класса (статический метод) класса TInstantMessage.

1class procedure TInstantMessage.Archive(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Метод Clear (Очистить)

(одним файлом)
Метод Clear (Очистить)

Метод класса (статический метод) класса TInstantMessage.

1class procedure TInstantMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Класс TInstantMessageAttachment (Сообщения с вложением)

(раздел целиком) (одним файлом)
Класс TInstantMessageAttachment (Сообщения с вложением)

Класс TInstantMessage (Сообщения)Класс TObject (Объекты)Класс TUser (Пользователи)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор сообщения с вложением)
См. также
  • Класс TInstantMessage (Сообщения)
  • Класс TUser (Пользователи)


Свойства

(одним файлом)
Свойства

Свойства класса TInstantMessageAttachment:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Owner | TUser | Да | Видимо пользователю | Только для чтения | Унаследовано от TInstantMessage
User | TUser | Да | Видимо пользователю | Чтение/Запись
Message | string[255] | Да | Видимо пользователю | Только для чтения
DeliveryTime | datetime | Да | Видимо пользователю | Только для чтения
AttachmentType | TInstantMessageAttachmentType | Да | Видимо пользователю | Только для чтения | Тип вложения
FileBody | blob | Нет | Видимо пользователю | Только для чтения | Содержимое файла
FormView | TFormView | Нет | Видимо пользователю | Только для чтения | Представление формы
Form | TForm | Да | Видимо пользователю | Только для чтения | Форма
FormIsAccessible | Boolean | Да | Скрыто от пользователя | Только для чтения | Форма доступна
Object | TObject | Нет | Видимо пользователю | Только для чтения | Объект
HyperLink | string[256] | Нет | Видимо пользователю | Только для чтения | Гиперссылка

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TForm (Формы)
  • Класс TFormView (Представления формы)
  • Класс TInstantMessage (Сообщения)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TInstantMessageAttachmentType (Тип вложения мгновенного сообщения)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор сообщения с вложением)

(одним файлом)
Конструктор Create (Конструктор сообщения с вложением)

Конструктор класса TInstantMessageAttachment.

1constructor TInstantMessageAttachment.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; User: TUser; Message: string[255];
4  DeliveryTime: datetime; FileName: string[255]; FileBaseName: string[128];
5  FileBody: blob; FormView: TFormView; Object: TObject; HyperLink: string[256];
6  AttachmentType: TInstantMessageAttachmentType): TObject;

Переопределяет метод в TInstantMessage.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
User | TUser | Да | Унаследовано от TInstantMessage.Create
Message | string[255] | Да
DeliveryTime | datetime | Нет
FileName | string[255] | Нет | Имя файла
FileBaseName | string[128] | Да | Базовое имя файла
FileBody | blob | Нет | Содержимое файла
FormView | TFormView | Нет | Представление
Object | TObject | Нет | Объект
HyperLink | string[256] | Нет | Гиперссылка
AttachmentType | TInstantMessageAttachmentType | Да | Тип приложения

Замечания:

Создает новый объект класса TInstantMessageAttachment.

См. также
  • Класс TClass (Классы)
  • Класс TFormView (Представления формы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор сообщения)
  • Перечисление TInstantMessageAttachmentType (Тип вложения мгновенного сообщения)


Класс TIntegerDomain (Целые числа)

(раздел целиком) (одним файлом)
Класс TIntegerDomain (Целые числа)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор целочисленного домена)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TDomain (Домены)


Свойства

(одним файлом)
Свойства

Свойства класса TIntegerDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
MinValue | Integer | Нет | Видимо пользователю | Чтение/Запись | Минимальное значение
MaxValue | Integer | Нет | Видимо пользователю | Чтение/Запись | Максимальное значение

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор целочисленного домена)

(одним файлом)
Конструктор Create (Конструктор целочисленного домена)

Конструктор класса TIntegerDomain.

1constructor TIntegerDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; MinValue: Integer; MaxValue: Integer): TDomain;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
MinValue | Integer | Нет | Минимальное значение
MaxValue | Integer | Нет | Максимальное значение

Замечания:

Создает новый объект класса TIntegerDomain.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TIntegerDomain.

function TIntegerDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)


Класс TLanguage (Языки)

(раздел целиком) (одним файлом)
Класс TLanguage (Языки)

Диаграмма Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор языка)
  • Метод GetCurrentLanguage (Получить текущий язык)
  • Метод GetIsCurrent (Является текущим)
  • Метод SetIsCurrent (Установить язык как текущий)
  • Метод Ole-объекта SaveResourceFile (Сохранить файл ресурсов)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TLanguage:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
DatabaseLanguage | Boolean | Да | Видимо пользователю | Только для чтения | По умолчанию
IsCurrent | Boolean | Да | Видимо пользователю | Чтение/Запись | Является текущим

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор языка)

(одним файлом)
Конструктор Create (Конструктор языка)

Конструктор класса TLanguage.

1constructor TLanguage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TLanguage.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetCurrentLanguage (Получить текущий язык)

(одним файлом)
Метод GetCurrentLanguage (Получить текущий язык)

Метод класса (статический метод) класса TLanguage.

class function TLanguage.GetCurrentLanguage: TLanguage;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TLanguage.


Метод GetIsCurrent (Является текущим)

(одним файлом)
Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TLanguage.

function TLanguage.GetIsCurrent: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод SetIsCurrent (Установить язык как текущий)

(одним файлом)
Метод SetIsCurrent (Установить язык как текущий)

Метод экземпляра класса TLanguage.

procedure TLanguage.SetIsCurrent(Value: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение


Метод Ole-объекта SaveResourceFile (Сохранить файл ресурсов)

(одним файлом)
Метод Ole-объекта SaveResourceFile (Сохранить файл ресурсов)

Метод Ole-объекта класса TLanguage.

Параметры:

Имя | Тип | Обязательно | Значение
XliffFileName | string[255] | Да | Файл ресурсов


Класс TLanguageTranslation (Переводы)

(раздел целиком) (одним файлом)
Класс TLanguageTranslation (Переводы)

Класс TObject (Объекты)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор перевода)
  • Метод Add (Создать набор переводов)
  • Метод Append (Добавить перевод)
  • Метод GetGlobalIdent (Получить глобальный идентификатор)
  • Метод GetIdent (Получить идентификатор)
  • Метод GetLanguageTranslation (Получить перевод на языке)
  • Метод GetOriginal (Получить оригинал)
  • Метод GetResource (Получить ресурсную строку)
  • Метод Load (Загрузить значение)
  • Метод MarkAsTranslatable (Отметить как переводимый)
  • Метод MarkAsUntranslatable (Отметить как непереводимый)
  • Метод SetLanguageTranslation (Установить перевод на языке)
  • Метод SetOriginal (Установить оригинал)
  • Метод SetOwnerSecurity (Установить атрибуты безопасности по владельцу-объекту)
  • Метод SetTranslation (Установить перевод)
  • Метод Validate (Актуализировать)
  • Метод ValidateAllObjects (Актуализировать все объекты)
  • Метод ValidateObject (Актуализировать объект)
  • Метод ValidateOwned (Актуализировать имеющих владельца)
  • Метод ValidateOwner (Актуализировать по владельцу)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TLanguageTranslation:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Language | TLanguage | Да | Видимо пользователю | Только для чтения | Язык
DatabaseLanguage | Boolean | Да | Видимо пользователю | Только для чтения | Язык используется по умолчанию
CurrentLanguage | Boolean | Да | Видимо пользователю | Только для чтения | Язык является текущим
Status | TTranslationStatus | Да | Видимо пользователю | Только для чтения | Состояние
OwnerObject | TObject | Нет | Скрыто от пользователя | Только для чтения | Владелец-объект
OwnerObjectClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс объекта-владельца
OwnerField | TField | Нет | Скрыто от пользователя | Только для чтения | Владелец-поле
Owner | string[64] | Нет | Скрыто от пользователя | Только для чтения | Владелец
Translation | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Перевод
Original | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Оригинал
Identifier | string[2000] | Нет | Видимо пользователю | Только для чтения | Идентификатор
GlobalIdentifier | string[2000] | Нет | Видимо пользователю | Только для чтения | Глобальный идентификатор

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TField (Поля)
  • Класс TLanguage (Языки)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TTranslationStatus (Состояния перевода)


Конструктор Create (Конструктор перевода)

(одним файлом)
Конструктор Create (Конструктор перевода)

Конструктор класса TLanguageTranslation.

1constructor TLanguageTranslation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Language: TLanguage; OwnerObject: TObject;
4  OwnerField: TField; Owner: string[64]; Translation: string[2000]): TObject;

Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Language | TLanguage | Да | Язык
OwnerObject | TObject | Нет | Владелец-объект
OwnerField | TField | Нет | Владелец-поле
Owner | string[64] | Нет | Владелец
Translation | string[2000] | Нет | Перевод

Замечания:

Создает новый объект класса TLanguageTranslation.

См. также
  • Класс TClass (Классы)
  • Класс TField (Поля)
  • Класс TLanguage (Языки)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод Add (Создать набор переводов)

(одним файлом)
Метод Add (Создать набор переводов)

Метод класса (статический метод) класса TLanguageTranslation.

1class function TLanguageTranslation.Add(Owner: string[64];
2  Original: string[2000]): TLanguageTranslation;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Owner | string[64] | Да | Идентификатор
Original | string[2000] | Нет | Оригинал

Замечания:

Возвращает значение типа TLanguageTranslation.


Метод Append (Добавить перевод)

(одним файлом)
Метод Append (Добавить перевод)

Метод класса (статический метод) класса TLanguageTranslation.

1class function TLanguageTranslation.Append(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]): TLanguageTranslation;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ALanguage | TLanguage | Да | Язык
AOwner | string[64] | Нет | Владелец
AOwnerObject | TObject | Нет | Владелец-объект
AOwnerField | TField | Нет | Владелец-поле
AValue | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа TLanguageTranslation.

См. также
  • Класс TField (Поля)
  • Класс TLanguage (Языки)
  • Класс TObject (Объекты)


Метод GetGlobalIdent (Получить глобальный идентификатор)

(одним файлом)
Метод GetGlobalIdent (Получить глобальный идентификатор)

Метод экземпляра класса TLanguageTranslation.

function TLanguageTranslation.GetGlobalIdent: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод GetIdent (Получить идентификатор)

(одним файлом)
Метод GetIdent (Получить идентификатор)

Метод экземпляра класса TLanguageTranslation.

function TLanguageTranslation.GetIdent: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод GetLanguageTranslation (Получить перевод на языке)

(одним файлом)
Метод GetLanguageTranslation (Получить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.

1class function TLanguageTranslation.GetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ALanguage | TLanguage | Да | Язык
AOwner | string[64] | Нет | Владелец
AOwnerObject | TObject | Нет | Владелец-объект
AOwnerField | TField | Нет | Владелец-поле

Замечания:

Возвращает значение типа string[2000].

См. также
  • Класс TField (Поля)
  • Класс TLanguage (Языки)
  • Класс TObject (Объекты)


Метод GetOriginal (Получить оригинал)

(одним файлом)
Метод GetOriginal (Получить оригинал)

Метод экземпляра класса TLanguageTranslation.

function TLanguageTranslation.GetOriginal: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод GetResource (Получить ресурсную строку)

(одним файлом)
Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TLanguageTranslation.

class function TLanguageTranslation.GetResource(AOwner: string[64]): string[2000];

Переопределяет метод в TObject.GetResource.

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwner | string[64] | Да | Владелец

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetResource (Получить ресурсную строку)


Метод Load (Загрузить значение)

(одним файлом)
Метод Load (Загрузить значение)

Метод экземпляра класса TLanguageTranslation.

procedure TLanguageTranslation.Load(Value: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение


Метод MarkAsTranslatable (Отметить как переводимый)

(одним файлом)
Метод MarkAsTranslatable (Отметить как переводимый)

Метод экземпляра класса TLanguageTranslation.

procedure TLanguageTranslation.MarkAsTranslatable;

Метод не имеет параметров.


Метод MarkAsUntranslatable (Отметить как непереводимый)

(одним файлом)
Метод MarkAsUntranslatable (Отметить как непереводимый)

Метод экземпляра класса TLanguageTranslation.

procedure TLanguageTranslation.MarkAsUntranslatable;

Метод не имеет параметров.


Метод SetLanguageTranslation (Установить перевод на языке)

(одним файлом)
Метод SetLanguageTranslation (Установить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.

1class procedure TLanguageTranslation.SetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ALanguage | TLanguage | Да | Язык
AOwner | string[64] | Нет | Владелец
AOwnerObject | TObject | Нет | Владелец-объект
AOwnerField | TField | Нет | Владелец-поле
AValue | string[2000] | Нет | Значение

См. также
  • Класс TField (Поля)
  • Класс TLanguage (Языки)
  • Класс TObject (Объекты)


Метод SetOriginal (Установить оригинал)

(одним файлом)
Метод SetOriginal (Установить оригинал)

Метод экземпляра класса TLanguageTranslation.

procedure TLanguageTranslation.SetOriginal(Value: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение


Метод SetOwnerSecurity (Установить атрибуты безопасности по владельцу-объекту)

(одним файлом)
Метод SetOwnerSecurity (Установить атрибуты безопасности по владельцу-объекту)

Метод класса (статический метод) класса TLanguageTranslation.

class procedure TLanguageTranslation.SetOwnerSecurity(AOwnerObject: TObject);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwnerObject | TObject | Нет | Владелец-объект

См. также
  • Класс TObject (Объекты)


Метод SetTranslation (Установить перевод)

(одним файлом)
Метод SetTranslation (Установить перевод)

Метод экземпляра класса TLanguageTranslation.

procedure TLanguageTranslation.SetTranslation(Value: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение


Метод Validate (Актуализировать)

(одним файлом)
Метод Validate (Актуализировать)

Метод класса (статический метод) класса TLanguageTranslation.

1class procedure TLanguageTranslation.Validate(ValidateResources: Boolean;
2  ValidateData: Boolean; ValidateClass: TClass; ValidateField: TField);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ValidateResources | Boolean | Да | Актуализировать ресурсы
ValidateData | Boolean | Да | Актуализировать данные
ValidateClass | TClass | Нет | Актуализировать объекты класса
ValidateField | TField | Нет | Актуализировать значения поля

См. также
  • Класс TClass (Классы)
  • Класс TField (Поля)


Метод ValidateAllObjects (Актуализировать все объекты)

(одним файлом)
Метод ValidateAllObjects (Актуализировать все объекты)

Метод класса (статический метод) класса TLanguageTranslation.

1class procedure TLanguageTranslation.ValidateAllObjects(ValidateClass: TClass;
2  ValidateField: TField);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ValidateClass | TClass | Нет | Актуализировать объекты класса
ValidateField | TField | Нет | Актуализировать значения поля

См. также
  • Класс TClass (Классы)
  • Класс TField (Поля)


Метод ValidateObject (Актуализировать объект)

(одним файлом)
Метод ValidateObject (Актуализировать объект)

Метод класса (статический метод) класса TLanguageTranslation.

1class procedure TLanguageTranslation.ValidateObject(AOwnerObject: TObject;
2  AOwnerField: TField);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwnerObject | TObject | Нет | Владелец-объект
AOwnerField | TField | Нет | Владелец-поле

См. также
  • Класс TField (Поля)
  • Класс TObject (Объекты)


Метод ValidateOwned (Актуализировать имеющих владельца)

(одним файлом)
Метод ValidateOwned (Актуализировать имеющих владельца)

Метод класса (статический метод) класса TLanguageTranslation.

class procedure TLanguageTranslation.ValidateOwned;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.


Метод ValidateOwner (Актуализировать по владельцу)

(одним файлом)
Метод ValidateOwner (Актуализировать по владельцу)

Метод класса (статический метод) класса TLanguageTranslation.

class procedure TLanguageTranslation.ValidateOwner(AOwner: string[64]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwner | string[64] | Да | Владелец


Класс TMethod (Методы)

(раздел целиком) (одним файлом)
Класс TMethod (Методы)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

  • Свойства
  • Конструктор Create (Конструктор метода)
  • Метод Call (Вызвать)
  • Метод CallTemplate (Шаблон вызова)
  • Метод GetDBMSName (Получить имя объекта СУБД)
  • Метод VirtualChainRoot (Корень виртуальной цепи)
См. также
  • Класс TClass (Классы)
  • Класс TRoutine (Подпрограмма)


Свойства

(одним файлом)
Свойства

Свойства класса TMethod:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Body | clob | Нет | Видимо пользователю | Чтение/Запись | Тело
CallTemplate | string[2000] | Нет | Видимо пользователю | Только для чтения | Шаблон вызова
Virtual | Boolean | Да | Видимо пользователю | Чтение/Запись | Виртуальный
DBMSName | string[64] | Да | Видимо пользователю | Только для чтения | Имя объекта СУБД

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор метода)

(одним файлом)
Конструктор Create (Конструктор метода)

Конструктор класса TMethod.

1constructor TMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; Body: clob;
6  Virtual: Boolean): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Имя
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
Body | clob | Нет | Тело
Virtual | Boolean | Да | Метод является виртуальным

Замечания:

Создает новый объект класса TMethod.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор подпрограммы)
  • Конструктор Create (Конструктор члена класса)
  • Перечисление TScope (Область видимости)


Метод Call (Вызвать)

(одним файлом)
Метод Call (Вызвать)

Метод экземпляра класса TMethod.

procedure TMethod.Call(Parameters: TObjectList);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Parameters | TObjectList | Нет | Параметры

См. также
  • Класс TObjectList (Списки)


Метод CallTemplate (Шаблон вызова)

(одним файлом)
Метод CallTemplate (Шаблон вызова)

Метод экземпляра класса TMethod.

function TMethod.CallTemplate: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод GetDBMSName (Получить имя объекта СУБД)

(одним файлом)
Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TMethod.

function TMethod.GetDBMSName: string[64];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].


Метод VirtualChainRoot (Корень виртуальной цепи)

(одним файлом)
Метод VirtualChainRoot (Корень виртуальной цепи)

Метод экземпляра класса TMethod.

function TMethod.VirtualChainRoot: TMethod;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TMethod.


Класс TObject (Объекты)

(раздел целиком) (одним файлом)
Класс TObject (Объекты)

Диаграмма Класс TAccessItem (Элементы доступа)Класс TQueue (Очередь)

  • Свойства
  • Конструктор Create (Конструктор объекта)
  • Деструктор Destroy (Деструктор объекта)
  • Метод ApplyStringBuilder (Применить шаблон)
  • Метод ApplyStringBuilderClob (Применить шаблон-большой текстовый объект)
  • Метод ASCII (ASCII-код)
  • Метод Assigned (Проверка пустоты значения)
  • Метод BlobToClob (Большой двоичный объект в большой текстовый объект)
  • Метод BoolToStr (Логическое значение в строку)
  • Метод Change (Изменение объекта)
  • Метод Char (Символ)
  • Метод ClobReplace (Заменить содержимое большого текстового объекта)
  • Метод ClobToBlob (Большой текстовый объект в большой двоичный объект)
  • Метод Concatenate (Управляемая конкатенация строк)
  • Метод Copy (Копировать)
  • Метод CopyClob (Копировать из большого текстового объекта)
  • Метод CreateGUID (Создать GUID)
  • Метод DateOf (Дату из даты со временем)
  • Метод DatePart (Часть даты)
  • Метод DateTimePart (Часть даты со временем)
  • Метод DateTimeToStr (Дату и время в строку)
  • Метод DateToStr (Дату в строку)
  • Метод Dequeue (Удалить из очереди)
  • Метод DescribeObject (Описание объекта для сообщений пользователю)
  • Метод DumpString (Строка в виде списка кодов символов)
  • Метод Ellipsis (Эллипсис)
  • Метод EncodeDate (Собрать дату)
  • Метод EncodeDateTime (Собрать дату со временем)
  • Метод EncodeTime (Собрать время)
  • Метод Enqueue (Поставить в очередь)
  • Метод Find (Поиск объекта)
  • Метод FindGlobal (Глобальный поиск объекта)
  • Метод FloatToStr (Вещественное в строку)
  • Метод FormatDate (Форматировать дату)
  • Метод FormatDateTime (Форматировать дату со временем)
  • Метод FormatFloat (Форматировать вещественное значение)
  • Метод FormatTime (Форматировать время)
  • Метод GenerateAllNames (Сгенерировать имена для всех объектов)
  • Метод GeneratedDescription (Сгенерированное наименование)
  • Метод GeneratedName (Сгенерированное имя)
  • Метод GetBlobSize (Размер большого двоичного объекта)
  • Метод GetChildCount (Получить количество дочерних объектов)
  • Метод GetClobSize (Размер большого текстового объекта)
  • Метод GetDescendantCount (Получить количество объектов-потомков)
  • Метод GetDetailCount (Получить количество подчиненных объектов)
  • Метод GetLevel (Уровень в иерархии)
  • Метод GetResource (Получить ресурсную строку)
  • Метод GetRoot (Получить корень иерархии)
  • Метод GetTop (Получить объект верхнего уровня)
  • Метод HasAsChild (Объект является ребенком данного)
  • Метод HasAsParent (Объект является родителем данного)
  • Метод HasChildren (Имеет детей)
  • Метод HasDetails (Имеет подчиненные объекты)
  • Метод Hash (Хеш-функция конца строки)
  • Метод HashReverse (Хеш-функция начала строки)
  • Метод HexToInt (Шестнадцатеричное представление в целое число)
  • Метод IfThenDate (Выбор из двух дат)
  • Метод IfThenDateTime (Выбор из двух дат со временем)
  • Метод IfThenExternalData (Выбор из двух значений - внешних данных)
  • Метод IfThenFloat (Выбор из двух вещественных)
  • Метод IfThenInt (Выбор из двух целых)
  • Метод IfThenObject (Выбор из двух объектов)
  • Метод IfThenStr (Выбор из двух строк)
  • Метод IfThenTime (Выбор из двух времен)
  • Метод InstanceObject (Объект по строковому представлению идентификатора (объект может не существовать))
  • Метод IntToHex (Целое число в шестнадцатеричное представление)
  • Метод IntToStr (Целое в строку)
  • Метод IsBadHierarchy (Ошибка в иерархии)
  • Метод IsBadPtr (Не указывает на существующий объект)
  • Метод IsCharAlpha (Символ является алфавитным)
  • Метод IsCharAlphaNumeric (Символ является алфавитно-числовым)
  • Метод IsInList (Объект входит в список)
  • Метод IsInSet (Объект входит в множество)
  • Метод IsInstanceOf (Является экземпляром класса)
  • Метод IsNotInList (Объект не входит в список)
  • Метод IsNotInSet (Объект не входит в множество)
  • Метод LineBreak (Разделитель строк)
  • Метод LinkClobs (Присоединить большой объект к другому)
  • Метод LinkToClob (Присоединить строки к большому объекту)
  • Метод Locate (Поиск объекта по локатору)
  • Метод Locator (Локатор объекта)
  • Метод LowerCase (Преобразовать к нижнему регистру)
  • Метод MatchRegExp (Проверка соответствия строки регулярному выражению)
  • Метод MergeIdentifiers (Объединенный идентификатор)
  • Метод MergeTo (Отождествить с)
  • Метод Modulus (Остаток деления)
  • Метод ObjectInstance (Текстовое представление идентификатора объекта (объект может не существовать))
  • Метод Pos (Поиск подстроки)
  • Метод PreprocessRegExp (Адаптировать регулярное выражение к требованиям СУБД)
  • Метод QualifiedName (Квалифицированное имя)
  • Метод QuotedStr (Строку в апострофы)
  • Метод RaiseException (Возбудить исключение)
  • Метод RaiseResource (Возбудить исключение по ресурсной строке)
  • Метод ReadFromClob (Считать строку из большого текстового объекта)
  • Метод ResourceByItem (Значение ресурсной строки)
  • Метод Round (Округление)
  • Метод SendInstantMessage (Отправить мгновенное сообщение)
  • Метод Sleep (Задержка выполнения)
  • Метод StringReplace (Заменить содержимое строки)
  • Метод StrLength (Длина строки)
  • Метод StrLike (Сопоставить строку с шаблоном)
  • Метод StrPad (Заполнить строку)
  • Метод StrToBool (Строку в логическое значение)
  • Метод StrToDate (Строку в дату)
  • Метод StrToDateTime (Строку в дату и время)
  • Метод StrToFloat (Строку в вещественное)
  • Метод StrToInt (Строку в целое)
  • Метод StrToTime (Строку во время)
  • Метод StrTranslate (Транслировать символы в строке)
  • Метод StrWrap (Выровнять строку)
  • Метод SuggestDescription (Предложить наименование)
  • Метод SuggestFileName (Предложить имя файла)
  • Метод TimeOf (Время из даты со временем)
  • Метод TimePart (Часть времени)
  • Метод TimeToStr (Время в строку)
  • Метод Touch (Модификация объекта)
  • Метод Trim (Убрать лишние пробелы)
  • Метод Trunc (Отсечение дробной части)
  • Метод UniqueValue (Уникальный идентификатор)
  • Метод UpperCase (Преобразовать к верхнему регистру)
  • Метод Ole-объекта CheckSGMLContent (Проверить SGML-содержимое)
  • Метод Ole-объекта ExportAfter (Экспортировать модифицированные)
  • Метод Ole-объекта FixSGMLContentErrors (Исправить ошибки SGML-содержимого)
  • Метод Ole-объекта LoadBlobsFromFolder (Загрузить данные из папки)
  • Метод Ole-объекта SaveBlobsToFolder (Сохранить данные в папку)
  • Метод Ole-объекта SplitExcelSheetsToFiles (Разделить Excel листы на файлы)
  • Шаблон отчета Excel Excel (Перенести в Excel)
  • Шаблон отчета Word SpellCheck (Проверка правописания)
  • Шаблон XSLT-отчета ObjectInformation (Информация об объекте)
  • Шаблон XSLT-отчета SelectDataToText (Выполнить запрос в текст)
  • Шаблон XSLT-отчета SelectDataToXML (Выполнить запрос в xml-документ)
  • Подпрограмма Column (Колонка)
  • Подпрограмма CopyToClipboard (Копировать)
  • Подпрограмма CurrentFormView (Текущее представление формы)
  • Подпрограмма CurrentlySelected (Список выбранных)
  • Подпрограмма CurrentlySelectedSet (Множество выбранных)
  • Подпрограмма CurrentlyVisible (Список видимых)
  • Подпрограмма CurrentlyVisibleSet (Множество видимых)
  • Подпрограмма Dependencies (Зависимости)
  • Подпрограмма Edit columns (Редактировать строку)
  • Подпрограмма Edit filters (Редактировать фильтры)
  • Подпрограмма Edit properties (Редактировать свойства)
  • Подпрограмма Export (Экспортировать)
  • Подпрограмма ExportReport (Выгрузить в отчет)
  • Подпрограмма FormOptions (Настройки формы)
  • Подпрограмма Import (Импортировать)
  • Подпрограмма Merge (Объединить)
  • Подпрограмма Messages (Проверить сообщения)
  • Подпрограмма Options (Настройки)
  • Подпрограмма Paste (Вставить)
  • Подпрограмма PasteSpecial (Специальная вставка)
  • Подпрограмма Presentations (Виды)
  • Подпрограмма Refresh (Обновить)
  • Подпрограмма Search (Поиск)
  • Подпрограмма Selection (Выбранные)
  • Подпрограмма Tree (Дерево)


Свойства

(одним файлом)
Свойства

Свойства класса TObject:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Имя
Description | string[128] | Да | Видимо пользователю | Чтение/Запись | Наименование
Class | TClass | Да | Скрыто от пользователя | Только для чтения | Класс
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения | Статус репликации
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись | Родитель
Master | TObject | Да | Скрыто от пользователя | Только для чтения | Мастер
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | База данных-источник
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения | GUID базы данных-источника
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения | База данных-источник является текущей
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения | Идентификатор при создании
Creator | TUser | Да | Скрыто от пользователя | Только для чтения | Создано пользователем
Created | datetime | Да | Скрыто от пользователя | Только для чтения | Создано
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения | Изменено пользователем
Modified | datetime | Да | Скрыто от пользователя | Только для чтения | Изменено
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись | Роль для чтения
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись | Роль для записи

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор объекта)

(одним файлом)
Конструктор Create (Конструктор объекта)

Конструктор класса TObject.

1constructor TObject.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Class | TClass | Нет | Класс
Parent | TObject | Нет | Родитель
Master | TObject | Да | Мастер
Accessor | TSecurityAccount | Нет | Роль доступа

Замечания:

Создает новый объект класса TObject.

См. также
  • Класс TClass (Классы)
  • Класс TSecurityAccount (Роли безопасности)


Деструктор Destroy (Деструктор объекта)

(одним файлом)
Деструктор Destroy (Деструктор объекта)

Деструктор класса TObject.

destructor TObject.Destroy;

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TObject или его наследника.


Метод ApplyStringBuilder (Применить шаблон)

(одним файлом)
Метод ApplyStringBuilder (Применить шаблон)

Метод экземпляра класса TObject.

function TObject.ApplyStringBuilder(Template: string[2000]): string[2000];

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Template | string[2000] | Нет | Шаблон

Замечания:

Возвращает значение типа string[2000].


Метод ApplyStringBuilderClob (Применить шаблон-большой текстовый объект)

(одним файлом)
Метод ApplyStringBuilderClob (Применить шаблон-большой текстовый объект)

Метод экземпляра класса TObject.

function TObject.ApplyStringBuilderClob(Template: string[2000]): clob;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Template | string[2000] | Нет | Шаблон

Замечания:

Возвращает значение типа clob.


Метод ASCII (ASCII-код)

(одним файлом)
Метод ASCII (ASCII-код)

Метод класса (статический метод) класса TObject.

class function TObject.ASCII(Value: string[2]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2] | Нет | Значение

Замечания:

Возвращает значение типа Integer.


Метод Assigned (Проверка пустоты значения)

(одним файлом)
Метод Assigned (Проверка пустоты значения)

Метод класса (статический метод) класса TObject.

class function TObject.Assigned(Value: TObject): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа Boolean.


Метод BlobToClob (Большой двоичный объект в большой текстовый объект)

(одним файлом)
Метод BlobToClob (Большой двоичный объект в большой текстовый объект)

Метод класса (статический метод) класса TObject.

class function TObject.BlobToClob(Value: blob): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | blob | Нет | Значение

Замечания:

Возвращает значение типа clob.


Метод BoolToStr (Логическое значение в строку)

(одним файлом)
Метод BoolToStr (Логическое значение в строку)

Метод класса (статический метод) класса TObject.

1class function TObject.BoolToStr(Value: Boolean;
2  Domain: TBooleanDomain): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
Domain | TBooleanDomain | Нет | Домен

Замечания:

Возвращает значение типа string[2000].

См. также
  • Класс TBooleanDomain (Логические)


Метод Change (Изменение объекта)

(одним файлом)
Метод Change (Изменение объекта)

Метод экземпляра класса TObject.

procedure TObject.Change(Action: TChangeAction);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Действие

См. также
  • Перечисление TChangeAction (Действие при изменении)


Метод Char (Символ)

(одним файлом)
Метод Char (Символ)

Метод класса (статический метод) класса TObject.

class function TObject.Char(Value: Integer): string[2];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Integer | Нет | Значение

Замечания:

Возвращает значение типа string[2].


Метод ClobReplace (Заменить содержимое большого текстового объекта)

(одним файлом)
Метод ClobReplace (Заменить содержимое большого текстового объекта)

Метод класса (статический метод) класса TObject.

1class function TObject.ClobReplace(Value: clob; OldPattern: string[2000];
2  NewPattern: string[2000]; ReplaceAll: Boolean): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение
OldPattern | string[2000] | Нет | Старый шаблон
NewPattern | string[2000] | Нет | Новый шаблон
ReplaceAll | Boolean | Да | Заменять все

Замечания:

Возвращает значение типа clob.


Метод ClobToBlob (Большой текстовый объект в большой двоичный объект)

(одним файлом)
Метод ClobToBlob (Большой текстовый объект в большой двоичный объект)

Метод класса (статический метод) класса TObject.

class function TObject.ClobToBlob(Value: clob): blob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа blob.


Метод Concatenate (Управляемая конкатенация строк)

(одним файлом)
Метод Concatenate (Управляемая конкатенация строк)

Метод класса (статический метод) класса TObject.

1class function TObject.Concatenate(Value: string[2000]; AddOn: string[2000];
2  MaxLength: Integer; Delimiter: string[2000]; Ellipsis: Boolean): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
AddOn | string[2000] | Нет | Присоединяемая строка
MaxLength | Integer | Да | Максимальная длина
Delimiter | string[2000] | Нет | Разделитель
Ellipsis | Boolean | Да | Эллипсис

Замечания:

Возвращает значение типа string[2000].


Метод Copy (Копировать)

(одним файлом)
Метод Copy (Копировать)

Метод класса (статический метод) класса TObject.

1class function TObject.Copy(String: string[2000]; StartPos: Integer;
2  Length: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
String | string[2000] | Нет | Строка
StartPos | Integer | Нет | Позиция
Length | Integer | Нет | Длина

Замечания:

Возвращает значение типа string[2000].


Метод CopyClob (Копировать из большого текстового объекта)

(одним файлом)
Метод CopyClob (Копировать из большого текстового объекта)

Метод класса (статический метод) класса TObject.

1class function TObject.CopyClob(Value: clob; StartPos: Integer;
2  Length: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение
StartPos | Integer | Нет | Позиция
Length | Integer | Нет | Длина

Замечания:

Возвращает значение типа string[2000].


Метод CreateGUID (Создать GUID)

(одним файлом)
Метод CreateGUID (Создать GUID)

Метод класса (статический метод) класса TObject.

class function TObject.CreateGUID: string[38];

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[38].


Метод DateOf (Дату из даты со временем)

(одним файлом)
Метод DateOf (Дату из даты со временем)

Метод класса (статический метод) класса TObject.

class function TObject.DateOf(Value: datetime): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Нет | Значение

Замечания:

Возвращает значение типа date.


Метод DatePart (Часть даты)

(одним файлом)
Метод DatePart (Часть даты)

Метод класса (статический метод) класса TObject.

class function TObject.DatePart(Value: date; Part: TDateTimePart): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | date | Нет | Значение
Part | TDateTimePart | Да | Часть

Замечания:

Возвращает значение типа Integer.

См. также
  • Перечисление TDateTimePart (Часть даты или времени)


Метод DateTimePart (Часть даты со временем)

(одним файлом)
Метод DateTimePart (Часть даты со временем)

Метод класса (статический метод) класса TObject.

1class function TObject.DateTimePart(Value: datetime;
2  Part: TDateTimePart): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Нет | Значение
Part | TDateTimePart | Да | Часть

Замечания:

Возвращает значение типа Integer.

См. также
  • Перечисление TDateTimePart (Часть даты или времени)


Метод DateTimeToStr (Дату и время в строку)

(одним файлом)
Метод DateTimeToStr (Дату и время в строку)

Метод класса (статический метод) класса TObject.

class function TObject.DateTimeToStr(Value: datetime): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Да | Значение

Замечания:

Возвращает значение типа string[2000].


Метод DateToStr (Дату в строку)

(одним файлом)
Метод DateToStr (Дату в строку)

Метод класса (статический метод) класса TObject.

class function TObject.DateToStr(Value: date): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | date | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод Dequeue (Удалить из очереди)

(одним файлом)
Метод Dequeue (Удалить из очереди)

Метод экземпляра класса TObject.

procedure TObject.Dequeue(Permanently: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Permanently | Boolean | Да | Удалить навсегда


Метод DescribeObject (Описание объекта для сообщений пользователю)

(одним файлом)
Метод DescribeObject (Описание объекта для сообщений пользователю)

Метод экземпляра класса TObject.

function TObject.DescribeObject: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод DumpString (Строка в виде списка кодов символов)

(одним файлом)
Метод DumpString (Строка в виде списка кодов символов)

Метод класса (статический метод) класса TObject.

1class function TObject.DumpString(Value: string[2000]; Delimiter: string[2000];
2  Hexadecimal: Boolean): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Delimiter | string[2000] | Нет | Разделитель
Hexadecimal | Boolean | Да | Использовать шестнадцатеричные значения

Замечания:

Возвращает значение типа string[2000].


Метод Ellipsis (Эллипсис)

(одним файлом)
Метод Ellipsis (Эллипсис)

Метод класса (статический метод) класса TObject.

1class function TObject.Ellipsis(Value: string[2000]; MaxLength: Integer;
2  WholeWords: Boolean): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
MaxLength | Integer | Да | Максимальная длина
WholeWords | Boolean | Да | По целым словам

Замечания:

Возвращает значение типа string[2000].


Метод EncodeDate (Собрать дату)

(одним файлом)
Метод EncodeDate (Собрать дату)

Метод класса (статический метод) класса TObject.

1class function TObject.EncodeDate(Year: Integer; Month: Integer;
2  Day: Integer): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Year | Integer | Нет | Год
Month | Integer | Нет | Месяц
Day | Integer | Нет | День

Замечания:

Возвращает значение типа date.


Метод EncodeDateTime (Собрать дату со временем)

(одним файлом)
Метод EncodeDateTime (Собрать дату со временем)

Метод класса (статический метод) класса TObject.

1class function TObject.EncodeDateTime(Year: Integer; Month: Integer;
2  Day: Integer; Hours: Integer; Minutes: Integer; Seconds: Integer): datetime;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Year | Integer | Нет | Год
Month | Integer | Нет | Месяц
Day | Integer | Нет | День
Hours | Integer | Нет | Часы
Minutes | Integer | Нет | Минуты
Seconds | Integer | Нет | Секунды

Замечания:

Возвращает значение типа datetime.


Метод EncodeTime (Собрать время)

(одним файлом)
Метод EncodeTime (Собрать время)

Метод класса (статический метод) класса TObject.

1class function TObject.EncodeTime(Hours: Integer; Minutes: Integer;
2  Seconds: Integer): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Hours | Integer | Нет | Часы
Minutes | Integer | Нет | Минуты
Seconds | Integer | Нет | Секунды

Замечания:

Возвращает значение типа time.


Метод Enqueue (Поставить в очередь)

(одним файлом)
Метод Enqueue (Поставить в очередь)

Метод экземпляра класса TObject.

function TObject.Enqueue(QueueName: string[64]): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
QueueName | string[64] | Да | Имя очереди

Замечания:

Возвращает значение типа Boolean.


Метод Find (Поиск объекта)

(одним файлом)
Метод Find (Поиск объекта)

Метод класса (статический метод) класса TObject.

1class function TObject.Find(Name: string[64]; Class: TClass; Parent: TObject;
2  Master: TObject): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Class | TClass | Нет | Класс объекта
Parent | TObject | Нет | Родительский объект
Master | TObject | Да | Мастер объекта

Замечания:

Возвращает значение типа TObject.

См. также
  • Класс TClass (Классы)


Метод FindGlobal (Глобальный поиск объекта)

(одним файлом)
Метод FindGlobal (Глобальный поиск объекта)

Метод класса (статический метод) класса TObject.

1class function TObject.FindGlobal(SourceDataBaseGUID: string[38];
2  OldID: string[38]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
SourceDataBaseGUID | string[38] | Да | GUID базы данных-источника
OldID | string[38] | Да | Идентификатор при создании

Замечания:

Возвращает значение типа TObject.


Метод FloatToStr (Вещественное в строку)

(одним файлом)
Метод FloatToStr (Вещественное в строку)

Метод класса (статический метод) класса TObject.

class function TObject.FloatToStr(Value: float): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | float | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод FormatDate (Форматировать дату)

(одним файлом)
Метод FormatDate (Форматировать дату)

Метод класса (статический метод) класса TObject.

1class function TObject.FormatDate(Value: date;
2  Format: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | date | Нет | Значение
Format | string[2000] | Нет | Формат

Замечания:

Возвращает значение типа string[2000].


Метод FormatDateTime (Форматировать дату со временем)

(одним файлом)
Метод FormatDateTime (Форматировать дату со временем)

Метод класса (статический метод) класса TObject.

1class function TObject.FormatDateTime(Value: datetime;
2  Format: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Нет | Значение
Format | string[2000] | Нет | Формат

Замечания:

Возвращает значение типа string[2000].


Метод FormatFloat (Форматировать вещественное значение)

(одним файлом)
Метод FormatFloat (Форматировать вещественное значение)

Метод класса (статический метод) класса TObject.

1class function TObject.FormatFloat(Value: float; DecimalPlaces: Integer;
2  DecimalSeparator: string[2]; GroupSeparator: string[2]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | float | Нет | Значение
DecimalPlaces | Integer | Нет | Количество десятичных знаков
DecimalSeparator | string[2] | Нет | Десятичный разделитель
GroupSeparator | string[2] | Нет | Разделитель групп разрядов

Замечания:

Возвращает значение типа string[2000].


Метод FormatTime (Форматировать время)

(одним файлом)
Метод FormatTime (Форматировать время)

Метод класса (статический метод) класса TObject.

1class function TObject.FormatTime(Value: time;
2  Format: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | time | Нет | Значение
Format | string[2000] | Нет | Формат

Замечания:

Возвращает значение типа string[2000].


Метод GenerateAllNames (Сгенерировать имена для всех объектов)

(одним файлом)
Метод GenerateAllNames (Сгенерировать имена для всех объектов)

Метод класса (статический метод) класса TObject.

class function TObject.GenerateAllNames: Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод GeneratedDescription (Сгенерированное наименование)

(одним файлом)
Метод GeneratedDescription (Сгенерированное наименование)

Метод экземпляра класса TObject.

function TObject.GeneratedDescription: string[128];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].


Метод GeneratedName (Сгенерированное имя)

(одним файлом)
Метод GeneratedName (Сгенерированное имя)

Метод экземпляра класса TObject.

function TObject.GeneratedName: string[64];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].


Метод GetBlobSize (Размер большого двоичного объекта)

(одним файлом)
Метод GetBlobSize (Размер большого двоичного объекта)

Метод класса (статический метод) класса TObject.

class function TObject.GetBlobSize(Value: blob): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | blob | Нет | Значение

Замечания:

Возвращает значение типа Integer.


Метод GetChildCount (Получить количество дочерних объектов)

(одним файлом)
Метод GetChildCount (Получить количество дочерних объектов)

Метод экземпляра класса TObject.

function TObject.GetChildCount: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод GetClobSize (Размер большого текстового объекта)

(одним файлом)
Метод GetClobSize (Размер большого текстового объекта)

Метод класса (статический метод) класса TObject.

class function TObject.GetClobSize(Value: clob): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа Integer.


Метод GetDescendantCount (Получить количество объектов-потомков)

(одним файлом)
Метод GetDescendantCount (Получить количество объектов-потомков)

Метод экземпляра класса TObject.

function TObject.GetDescendantCount: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод GetDetailCount (Получить количество подчиненных объектов)

(одним файлом)
Метод GetDetailCount (Получить количество подчиненных объектов)

Метод экземпляра класса TObject.

function TObject.GetDetailCount: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод GetLevel (Уровень в иерархии)

(одним файлом)
Метод GetLevel (Уровень в иерархии)

Метод экземпляра класса TObject.

function TObject.GetLevel: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод GetResource (Получить ресурсную строку)

(одним файлом)
Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TObject.

class function TObject.GetResource(AOwner: string[64]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwner | string[64] | Да | Владелец

Замечания:

Возвращает значение типа string[2000].


Метод GetRoot (Получить корень иерархии)

(одним файлом)
Метод GetRoot (Получить корень иерархии)

Метод экземпляра класса TObject.

function TObject.GetRoot: TObject;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.


Метод GetTop (Получить объект верхнего уровня)

(одним файлом)
Метод GetTop (Получить объект верхнего уровня)

Метод экземпляра класса TObject.

function TObject.GetTop: TObject;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.


Метод HasAsChild (Объект является ребенком данного)

(одним файлом)
Метод HasAsChild (Объект является ребенком данного)

Метод экземпляра класса TObject.

function TObject.HasAsChild(Child: TObject): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Child | TObject | Нет | Дочерний объект

Замечания:

Возвращает значение типа Boolean.


Метод HasAsParent (Объект является родителем данного)

(одним файлом)
Метод HasAsParent (Объект является родителем данного)

Метод экземпляра класса TObject.

function TObject.HasAsParent(Parent: TObject): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Parent | TObject | Нет | Родитель

Замечания:

Возвращает значение типа Boolean.


Метод HasChildren (Имеет детей)

(одним файлом)
Метод HasChildren (Имеет детей)

Метод экземпляра класса TObject.

function TObject.HasChildren: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод HasDetails (Имеет подчиненные объекты)

(одним файлом)
Метод HasDetails (Имеет подчиненные объекты)

Метод экземпляра класса TObject.

function TObject.HasDetails: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод Hash (Хеш-функция конца строки)

(одним файлом)
Метод Hash (Хеш-функция конца строки)

Метод класса (статический метод) класса TObject.

1class function TObject.Hash(Value: string[2000];
2  MaxLength: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
MaxLength | Integer | Да | Максимальная длина

Замечания:

Возвращает значение типа string[2000].


Метод HashReverse (Хеш-функция начала строки)

(одним файлом)
Метод HashReverse (Хеш-функция начала строки)

Метод класса (статический метод) класса TObject.

1class function TObject.HashReverse(Value: string[2000];
2  MaxLength: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
MaxLength | Integer | Да | Максимальная длина

Замечания:

Возвращает значение типа string[2000].


Метод HexToInt (Шестнадцатеричное представление в целое число)

(одним файлом)
Метод HexToInt (Шестнадцатеричное представление в целое число)

Метод класса (статический метод) класса TObject.

class function TObject.HexToInt(Hexadecimal: string[64]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Hexadecimal | string[64] | Да | Шестнадцатеричное значение

Замечания:

Возвращает значение типа Integer.


Метод IfThenDate (Выбор из двух дат)

(одним файлом)
Метод IfThenDate (Выбор из двух дат)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenDate(Value: Boolean; ATrue: date;
2  AFalse: date): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | date | Нет | Значение при выполнении условия
AFalse | date | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа date.


Метод IfThenDateTime (Выбор из двух дат со временем)

(одним файлом)
Метод IfThenDateTime (Выбор из двух дат со временем)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenDateTime(Value: Boolean; ATrue: datetime;
2  AFalse: datetime): datetime;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | datetime | Нет | Значение при выполнении условия
AFalse | datetime | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа datetime.


Метод IfThenExternalData (Выбор из двух значений - внешних данных)

(одним файлом)
Метод IfThenExternalData (Выбор из двух значений - внешних данных)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenExternalData(Value: Boolean; ATrue: <external
2  data>; AFalse: <external data>): <external data>;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | <external data> | Нет | Значение при выполнении условия
AFalse | <external data> | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа <external data>.


Метод IfThenFloat (Выбор из двух вещественных)

(одним файлом)
Метод IfThenFloat (Выбор из двух вещественных)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenFloat(Value: Boolean; ATrue: float;
2  AFalse: float): float;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | float | Нет | Значение при выполнении условия
AFalse | float | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа float.


Метод IfThenInt (Выбор из двух целых)

(одним файлом)
Метод IfThenInt (Выбор из двух целых)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenInt(Value: Boolean; ATrue: Integer;
2  AFalse: Integer): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | Integer | Нет | Значение при выполнении условия
AFalse | Integer | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа Integer.


Метод IfThenObject (Выбор из двух объектов)

(одним файлом)
Метод IfThenObject (Выбор из двух объектов)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenObject(Value: Boolean; ATrue: TObject;
2  AFalse: TObject): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | TObject | Нет | Значение при выполнении условия
AFalse | TObject | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа TObject.


Метод IfThenStr (Выбор из двух строк)

(одним файлом)
Метод IfThenStr (Выбор из двух строк)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenStr(Value: Boolean; ATrue: string[2000];
2  AFalse: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | string[2000] | Нет | Значение при выполнении условия
AFalse | string[2000] | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа string[2000].


Метод IfThenTime (Выбор из двух времен)

(одним файлом)
Метод IfThenTime (Выбор из двух времен)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenTime(Value: Boolean; ATrue: time;
2  AFalse: time): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | time | Нет | Значение при выполнении условия
AFalse | time | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа time.


Метод InstanceObject (Объект по строковому представлению идентификатора (объект может не существовать))

(одним файлом)
Метод InstanceObject (Объект по строковому представлению идентификатора (объект может не существовать))

Метод класса (статический метод) класса TObject.

class function TObject.InstanceObject(Value: string[38]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[38] | Да | Значение

Замечания:

Возвращает значение типа TObject.


Метод IntToHex (Целое число в шестнадцатеричное представление)

(одним файлом)
Метод IntToHex (Целое число в шестнадцатеричное представление)

Метод класса (статический метод) класса TObject.

class function TObject.IntToHex(IntValue: Integer): string[64];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
IntValue | Integer | Нет | Целое значение

Замечания:

Возвращает значение типа string[64].


Метод IntToStr (Целое в строку)

(одним файлом)
Метод IntToStr (Целое в строку)

Метод класса (статический метод) класса TObject.

class function TObject.IntToStr(Value: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Integer | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод IsBadHierarchy (Ошибка в иерархии)

(одним файлом)
Метод IsBadHierarchy (Ошибка в иерархии)

Метод экземпляра класса TObject.

function TObject.IsBadHierarchy: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод IsBadPtr (Не указывает на существующий объект)

(одним файлом)
Метод IsBadPtr (Не указывает на существующий объект)

Метод экземпляра класса TObject.

function TObject.IsBadPtr: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод IsCharAlpha (Символ является алфавитным)

(одним файлом)
Метод IsCharAlpha (Символ является алфавитным)

Метод класса (статический метод) класса TObject.

class function TObject.IsCharAlpha(Value: string[2]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2] | Нет | Значение

Замечания:

Возвращает значение типа Boolean.


Метод IsCharAlphaNumeric (Символ является алфавитно-числовым)

(одним файлом)
Метод IsCharAlphaNumeric (Символ является алфавитно-числовым)

Метод класса (статический метод) класса TObject.

class function TObject.IsCharAlphaNumeric(Value: string[2]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2] | Нет | Значение

Замечания:

Возвращает значение типа Boolean.


Метод IsInList (Объект входит в список)

(одним файлом)
Метод IsInList (Объект входит в список)

Метод экземпляра класса TObject.

function TObject.IsInList(Value: TObjectList): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectList | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObjectList (Списки)


Метод IsInSet (Объект входит в множество)

(одним файлом)
Метод IsInSet (Объект входит в множество)

Метод экземпляра класса TObject.

function TObject.IsInSet(Value: TObjectSet): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectSet | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObjectSet (Множества объектов)


Метод IsInstanceOf (Является экземпляром класса)

(одним файлом)
Метод IsInstanceOf (Является экземпляром класса)

Метод экземпляра класса TObject.

function TObject.IsInstanceOf(Class: TClass): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Class | TClass | Нет | Класс

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TClass (Классы)


Метод IsNotInList (Объект не входит в список)

(одним файлом)
Метод IsNotInList (Объект не входит в список)

Метод экземпляра класса TObject.

function TObject.IsNotInList(Value: TObjectList): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectList | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObjectList (Списки)


Метод IsNotInSet (Объект не входит в множество)

(одним файлом)
Метод IsNotInSet (Объект не входит в множество)

Метод экземпляра класса TObject.

function TObject.IsNotInSet(Value: TObjectSet): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectSet | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObjectSet (Множества объектов)


Метод LineBreak (Разделитель строк)

(одним файлом)
Метод LineBreak (Разделитель строк)

Метод класса (статический метод) класса TObject.

class function TObject.LineBreak: string[2];

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2].


Метод LinkClobs (Присоединить большой объект к другому)

(одним файлом)
Метод LinkClobs (Присоединить большой объект к другому)

Метод класса (статический метод) класса TObject.

class function TObject.LinkClobs(PrefData: clob; PostData: clob): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
PrefData | clob | Нет | Данные первого объекта
PostData | clob | Нет | Данные второго объекта

Замечания:

Возвращает значение типа clob.


Метод LinkToClob (Присоединить строки к большому объекту)

(одним файлом)
Метод LinkToClob (Присоединить строки к большому объекту)

Метод класса (статический метод) класса TObject.

1class function TObject.LinkToClob(Prefix: string[2000]; Data: clob;
2  Postfix: string[2000]): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Prefix | string[2000] | Нет | Префикс
Data | clob | Нет | Данные
Postfix | string[2000] | Нет | Постфикс

Замечания:

Возвращает значение типа clob.


Метод Locate (Поиск объекта по локатору)

(одним файлом)
Метод Locate (Поиск объекта по локатору)

Метод класса (статический метод) класса TObject.

class function TObject.Locate(Locator: string[2000]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Locator | string[2000] | Нет | Локатор

Замечания:

Возвращает значение типа TObject.


Метод Locator (Локатор объекта)

(одним файлом)
Метод Locator (Локатор объекта)

Метод экземпляра класса TObject.

function TObject.Locator: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод LowerCase (Преобразовать к нижнему регистру)

(одним файлом)
Метод LowerCase (Преобразовать к нижнему регистру)

Метод класса (статический метод) класса TObject.

class function TObject.LowerCase(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод MatchRegExp (Проверка соответствия строки регулярному выражению)

(одним файлом)
Метод MatchRegExp (Проверка соответствия строки регулярному выражению)

Метод класса (статический метод) класса TObject.

1class function TObject.MatchRegExp(Value: string[2000];
2  RegExp: string[2000]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
RegExp | string[2000] | Нет | Регулярное выражение

Замечания:

Возвращает значение типа Boolean.


Метод MergeIdentifiers (Объединенный идентификатор)

(одним файлом)
Метод MergeIdentifiers (Объединенный идентификатор)

Метод класса (статический метод) класса TObject.

1class function TObject.MergeIdentifiers(Identifier: string[64];
2  Modifier: string[64]; MaxLength: Integer): string[64];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Identifier | string[64] | Да | Идентификатор
Modifier | string[64] | Да | Модификатор
MaxLength | Integer | Да | Максимальная длина

Замечания:

Возвращает значение типа string[64].


Метод MergeTo (Отождествить с)

(одним файлом)
Метод MergeTo (Отождествить с)

Метод экземпляра класса TObject.

procedure TObject.MergeTo(PrimaryObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
PrimaryObject | TObject | Да | Первичный объект


Метод Modulus (Остаток деления)

(одним файлом)
Метод Modulus (Остаток деления)

Метод класса (статический метод) класса TObject.

class function TObject.Modulus(Value: Integer; Base: Integer): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Integer | Нет | Делимое
Base | Integer | Нет | Делитель

Замечания:

Возвращает значение типа Integer.


Метод ObjectInstance (Текстовое представление идентификатора объекта (объект может не существовать))

(одним файлом)
Метод ObjectInstance (Текстовое представление идентификатора объекта (объект может не существовать))

Метод класса (статический метод) класса TObject.

class function TObject.ObjectInstance(Value: TObject): string[38];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа string[38].


Метод Pos (Поиск подстроки)

(одним файлом)
Метод Pos (Поиск подстроки)

Метод класса (статический метод) класса TObject.

1class function TObject.Pos(Substring: string[2000];
2  Value: string[2000]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Substring | string[2000] | Нет | Подстрока
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа Integer.


Метод PreprocessRegExp (Адаптировать регулярное выражение к требованиям СУБД)

(одним файлом)
Метод PreprocessRegExp (Адаптировать регулярное выражение к требованиям СУБД)

Метод класса (статический метод) класса TObject.

class function TObject.PreprocessRegExp(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод QualifiedName (Квалифицированное имя)

(одним файлом)
Метод QualifiedName (Квалифицированное имя)

Метод экземпляра класса TObject.

function TObject.QualifiedName: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод QuotedStr (Строку в апострофы)

(одним файлом)
Метод QuotedStr (Строку в апострофы)

Метод класса (статический метод) класса TObject.

class function TObject.QuotedStr(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод RaiseException (Возбудить исключение)

(одним файлом)
Метод RaiseException (Возбудить исключение)

Метод класса (статический метод) класса TObject.

class procedure TObject.RaiseException(Message: string[2000]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Message | string[2000] | Нет | Сообщение


Метод RaiseResource (Возбудить исключение по ресурсной строке)

(одним файлом)
Метод RaiseResource (Возбудить исключение по ресурсной строке)

Метод класса (статический метод) класса TObject.

class procedure TObject.RaiseResource(AOwner: string[64]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwner | string[64] | Да | Владелец


Метод ReadFromClob (Считать строку из большого текстового объекта)

(одним файлом)
Метод ReadFromClob (Считать строку из большого текстового объекта)

Метод класса (статический метод) класса TObject.

class function TObject.ReadFromClob(Value: clob): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод ResourceByItem (Значение ресурсной строки)

(одним файлом)
Метод ResourceByItem (Значение ресурсной строки)

Метод класса (статический метод) класса TObject.

class function TObject.ResourceByItem(Resource: Resource strings): string[128];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Resource | Resource strings | Нет | Ресурс

Замечания:

Возвращает значение типа string[128].

См. также
  • Перечисление Resource strings (Ресурсные строки)


Метод Round (Округление)

(одним файлом)
Метод Round (Округление)

Метод класса (статический метод) класса TObject.

class function TObject.Round(Value: float; Decimals: Integer): float;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | float | Нет | Значение
Decimals | Integer | Нет | Количество десятичных знаков

Замечания:

Возвращает значение типа float.


Метод SendInstantMessage (Отправить мгновенное сообщение)

(одним файлом)
Метод SendInstantMessage (Отправить мгновенное сообщение)

Метод класса (статический метод) класса TObject.

1class procedure TObject.SendInstantMessage(Recipient: TUser;
2  MessageText: string[255]; DeliveryTime: datetime; AttachSelected: Boolean;
3  Selected: TObjectList; CurrentFormView: TFormView; HyperLink: string[256];
4  FileName: string[255]; FileBaseName: string[128]; FileBody: blob;
5  AttachmentType: TInstantMessageAttachmentType);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Recipient | TUser | Да | Получатель
MessageText | string[255] | Да | Сообщение
DeliveryTime | datetime | Нет | Время доставки
AttachSelected | Boolean | Да | Присоединить выбранные объекты
Selected | TObjectList | Нет | Список выбранных
CurrentFormView | TFormView | Нет | Текущее представление формы
HyperLink | string[256] | Нет | Гиперссылка
FileName | string[255] | Нет | Файл
FileBaseName | string[128] | Да | Имя файла (без пути)
FileBody | blob | Нет | Содержимое файла
AttachmentType | TInstantMessageAttachmentType | Да | Тип приложения

См. также
  • Класс TFormView (Представления формы)
  • Класс TObjectList (Списки)
  • Класс TUser (Пользователи)
  • Перечисление TInstantMessageAttachmentType (Тип вложения мгновенного сообщения)


Метод Sleep (Задержка выполнения)

(одним файлом)
Метод Sleep (Задержка выполнения)

Метод класса (статический метод) класса TObject.

class procedure TObject.Sleep(Seconds: Integer);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Seconds | Integer | Да | Количество секунд


Метод StringReplace (Заменить содержимое строки)

(одним файлом)
Метод StringReplace (Заменить содержимое строки)

Метод класса (статический метод) класса TObject.

1class function TObject.StringReplace(Value: string[2000];
2  OldPattern: string[2000]; NewPattern: string[2000];
3  ReplaceAll: Boolean): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
OldPattern | string[2000] | Нет | Старый шаблон
NewPattern | string[2000] | Нет | Новый шаблон
ReplaceAll | Boolean | Да | Заменять все

Замечания:

Возвращает значение типа string[2000].


Метод StrLength (Длина строки)

(одним файлом)
Метод StrLength (Длина строки)

Метод класса (статический метод) класса TObject.

class function TObject.StrLength(String: string[2000]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
String | string[2000] | Нет | Строка

Замечания:

Возвращает значение типа Integer.


Метод StrLike (Сопоставить строку с шаблоном)

(одним файлом)
Метод StrLike (Сопоставить строку с шаблоном)

Метод класса (статический метод) класса TObject.

1class function TObject.StrLike(Value: string[2000];
2  Pattern: string[2000]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Pattern | string[2000] | Нет | Шаблон

Замечания:

Возвращает значение типа Boolean.


Метод StrPad (Заполнить строку)

(одним файлом)
Метод StrPad (Заполнить строку)

Метод класса (статический метод) класса TObject.

1class function TObject.StrPad(Value: string[2000]; Padding: string[2000];
2  PadRight: Boolean; MaxLength: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Padding | string[2000] | Нет | Заполнитель
PadRight | Boolean | Да | Заполнять справа
MaxLength | Integer | Нет | Максимальная длина

Замечания:

Возвращает значение типа string[2000].


Метод StrToBool (Строку в логическое значение)

(одним файлом)
Метод StrToBool (Строку в логическое значение)

Метод класса (статический метод) класса TObject.

class function TObject.StrToBool(Value: string[2000]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа Boolean.


Метод StrToDate (Строку в дату)

(одним файлом)
Метод StrToDate (Строку в дату)

Метод класса (статический метод) класса TObject.

class function TObject.StrToDate(Value: string[2000]): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа date.


Метод StrToDateTime (Строку в дату и время)

(одним файлом)
Метод StrToDateTime (Строку в дату и время)

Метод класса (статический метод) класса TObject.

class function TObject.StrToDateTime(Value: string[2000]): datetime;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа datetime.


Метод StrToFloat (Строку в вещественное)

(одним файлом)
Метод StrToFloat (Строку в вещественное)

Метод класса (статический метод) класса TObject.

class function TObject.StrToFloat(Value: string[2000]): float;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа float.


Метод StrToInt (Строку в целое)

(одним файлом)
Метод StrToInt (Строку в целое)

Метод класса (статический метод) класса TObject.

class function TObject.StrToInt(Value: string[2000]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа Integer.


Метод StrToTime (Строку во время)

(одним файлом)
Метод StrToTime (Строку во время)

Метод класса (статический метод) класса TObject.

class function TObject.StrToTime(Value: string[2000]): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа time.


Метод StrTranslate (Транслировать символы в строке)

(одним файлом)
Метод StrTranslate (Транслировать символы в строке)

Метод класса (статический метод) класса TObject.

1class function TObject.StrTranslate(Value: string[2000];
2  OldChars: string[2000]; NewChars: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
OldChars | string[2000] | Нет | Старый набор символов
NewChars | string[2000] | Нет | Новый набор символов

Замечания:

Возвращает значение типа string[2000].


Метод StrWrap (Выровнять строку)

(одним файлом)
Метод StrWrap (Выровнять строку)

Метод класса (статический метод) класса TObject.

1class function TObject.StrWrap(Value: string[2000]; Delimiter: string[2000];
2  MaxCol: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Delimiter | string[2000] | Нет | Разделитель
MaxCol | Integer | Нет | Максимальное количество символов

Замечания:

Возвращает значение типа string[2000].


Метод SuggestDescription (Предложить наименование)

(одним файлом)
Метод SuggestDescription (Предложить наименование)

Метод экземпляра класса TObject.

procedure TObject.SuggestDescription(Description: string[128]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Description | string[128] | Да | Наименование


Метод SuggestFileName (Предложить имя файла)

(одним файлом)
Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TObject.

function TObject.SuggestFileName(Domain: TDomain): string[128];

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя | Тип | Обязательно | Значение
Domain | TDomain | Нет | Домен

Замечания:

Возвращает значение типа string[128].

См. также
  • Класс TDomain (Домены)


Метод TimeOf (Время из даты со временем)

(одним файлом)
Метод TimeOf (Время из даты со временем)

Метод класса (статический метод) класса TObject.

class function TObject.TimeOf(Value: datetime): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Нет | Значение

Замечания:

Возвращает значение типа time.


Метод TimePart (Часть времени)

(одним файлом)
Метод TimePart (Часть времени)

Метод класса (статический метод) класса TObject.

class function TObject.TimePart(Value: time; Part: TDateTimePart): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | time | Нет | Значение
Part | TDateTimePart | Да | Часть

Замечания:

Возвращает значение типа Integer.

См. также
  • Перечисление TDateTimePart (Часть даты или времени)


Метод TimeToStr (Время в строку)

(одним файлом)
Метод TimeToStr (Время в строку)

Метод класса (статический метод) класса TObject.

class function TObject.TimeToStr(Value: time): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | time | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод Touch (Модификация объекта)

(одним файлом)
Метод Touch (Модификация объекта)

Метод экземпляра класса TObject.

procedure TObject.Touch;

Метод скрыт от пользователя.

Метод не имеет параметров.


Метод Trim (Убрать лишние пробелы)

(одним файлом)
Метод Trim (Убрать лишние пробелы)

Метод класса (статический метод) класса TObject.

class function TObject.Trim(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод Trunc (Отсечение дробной части)

(одним файлом)
Метод Trunc (Отсечение дробной части)

Метод класса (статический метод) класса TObject.

class function TObject.Trunc(Value: float): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | float | Нет | Значение

Замечания:

Возвращает значение типа Integer.


Метод UniqueValue (Уникальный идентификатор)

(одним файлом)
Метод UniqueValue (Уникальный идентификатор)

Метод класса (статический метод) класса TObject.

class function TObject.UniqueValue: string[64];

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].


Метод UpperCase (Преобразовать к верхнему регистру)

(одним файлом)
Метод UpperCase (Преобразовать к верхнему регистру)

Метод класса (статический метод) класса TObject.

class function TObject.UpperCase(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод Ole-объекта CheckSGMLContent (Проверить SGML-содержимое)

(одним файлом)
Метод Ole-объекта CheckSGMLContent (Проверить SGML-содержимое)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Property | TProperty | Да | Свойство

Замечания:

Возвращает значение типа string[2000].

См. также
  • Класс TProperty (Свойства)


Метод Ole-объекта ExportAfter (Экспортировать модифицированные)

(одним файлом)
Метод Ole-объекта ExportAfter (Экспортировать модифицированные)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
FileName | string[255] | Да | Имя файла-реплики
FromDate | datetime | Нет | Модифицировано после


Метод Ole-объекта FixSGMLContentErrors (Исправить ошибки SGML-содержимого)

(одним файлом)
Метод Ole-объекта FixSGMLContentErrors (Исправить ошибки SGML-содержимого)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Property | TProperty | Да | Свойство

Замечания:

Возвращает значение типа string[2000].

См. также
  • Класс TProperty (Свойства)


Метод Ole-объекта LoadBlobsFromFolder (Загрузить данные из папки)

(одним файлом)
Метод Ole-объекта LoadBlobsFromFolder (Загрузить данные из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка
Property | TProperty | Да | Свойство
Template | string[128] | Да | Шаблон

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TProperty (Свойства)


Метод Ole-объекта SaveBlobsToFolder (Сохранить данные в папку)

(одним файлом)
Метод Ole-объекта SaveBlobsToFolder (Сохранить данные в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка
Property | TProperty | Да | Свойство
Template | string[128] | Да | Шаблон
List | TObjectList | Нет | Список объектов

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObjectList (Списки)
  • Класс TProperty (Свойства)


Метод Ole-объекта SplitExcelSheetsToFiles (Разделить Excel листы на файлы)

(одним файлом)
Метод Ole-объекта SplitExcelSheetsToFiles (Разделить Excel листы на файлы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта скрыт от пользователя.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
WorkBook | blob | Нет | Книга (объект)
FileName | string[255] | Нет | Имя Excel-файла
FileNameMappingSheetName | string[128] | Нет | Имя листа с сопоставлениями имен файлов (по умолчанию MapSheetNameToFileName)
Folder | string[255] | Да | Каталог


Шаблон отчета Excel Excel (Перенести в Excel)

(одним файлом)
Шаблон отчета Excel Excel (Перенести в Excel)

Шаблон отчета Excel класса (статический шаблон) класса TObject.

Шаблон отчета Excel является методом класса.

Шаблон отчета Excel не имеет параметров.


Шаблон отчета Word SpellCheck (Проверка правописания)

(одним файлом)
Шаблон отчета Word SpellCheck (Проверка правописания)

Шаблон отчета Word класса (статический шаблон) класса TObject.

Шаблон отчета Word скрыт от пользователя.

Шаблон отчета Word является методом класса.

Шаблон отчета Word не имеет параметров.


Шаблон XSLT-отчета ObjectInformation (Информация об объекте)

(одним файлом)
Шаблон XSLT-отчета ObjectInformation (Информация об объекте)

Шаблон XSLT-отчета класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ShowHiddenProps | Boolean | Да | Показывать скрытые свойства


Шаблон XSLT-отчета SelectDataToText (Выполнить запрос в текст)

(одним файлом)
Шаблон XSLT-отчета SelectDataToText (Выполнить запрос в текст)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | string[64] | Да | Имя класса
Query | clob | Нет | Запрос


Шаблон XSLT-отчета SelectDataToXML (Выполнить запрос в xml-документ)

(одним файлом)
Шаблон XSLT-отчета SelectDataToXML (Выполнить запрос в xml-документ)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | string[64] | Да | Имя класса
Query | clob | Нет | Запрос


Подпрограмма Column (Колонка)

(одним файлом)
Подпрограмма Column (Колонка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма CopyToClipboard (Копировать)

(одним файлом)
Подпрограмма CopyToClipboard (Копировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.


Подпрограмма CurrentFormView (Текущее представление формы)

(одним файлом)
Подпрограмма CurrentFormView (Текущее представление формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма CurrentlySelected (Список выбранных)

(одним файлом)
Подпрограмма CurrentlySelected (Список выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма CurrentlySelectedSet (Множество выбранных)

(одним файлом)
Подпрограмма CurrentlySelectedSet (Множество выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма CurrentlyVisible (Список видимых)

(одним файлом)
Подпрограмма CurrentlyVisible (Список видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма CurrentlyVisibleSet (Множество видимых)

(одним файлом)
Подпрограмма CurrentlyVisibleSet (Множество видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма Dependencies (Зависимости)

(одним файлом)
Подпрограмма Dependencies (Зависимости)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.


Подпрограмма Edit columns (Редактировать строку)

(одним файлом)
Подпрограмма Edit columns (Редактировать строку)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.


Подпрограмма Edit filters (Редактировать фильтры)

(одним файлом)
Подпрограмма Edit filters (Редактировать фильтры)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма Edit properties (Редактировать свойства)

(одним файлом)
Подпрограмма Edit properties (Редактировать свойства)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.


Подпрограмма Export (Экспортировать)

(одним файлом)
Подпрограмма Export (Экспортировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.


Подпрограмма ExportReport (Выгрузить в отчет)

(одним файлом)
Подпрограмма ExportReport (Выгрузить в отчет)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма FormOptions (Настройки формы)

(одним файлом)
Подпрограмма FormOptions (Настройки формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма Import (Импортировать)

(одним файлом)
Подпрограмма Import (Импортировать)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма Merge (Объединить)

(одним файлом)
Подпрограмма Merge (Объединить)

Подпрограмма класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма не имеет параметров.


Подпрограмма Messages (Проверить сообщения)

(одним файлом)
Подпрограмма Messages (Проверить сообщения)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма Options (Настройки)

(одним файлом)
Подпрограмма Options (Настройки)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма Paste (Вставить)

(одним файлом)
Подпрограмма Paste (Вставить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма PasteSpecial (Специальная вставка)

(одним файлом)
Подпрограмма PasteSpecial (Специальная вставка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма Presentations (Виды)

(одним файлом)
Подпрограмма Presentations (Виды)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма Refresh (Обновить)

(одним файлом)
Подпрограмма Refresh (Обновить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма Search (Поиск)

(одним файлом)
Подпрограмма Search (Поиск)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма Selection (Выбранные)

(одним файлом)
Подпрограмма Selection (Выбранные)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Подпрограмма Tree (Дерево)

(одним файлом)
Подпрограмма Tree (Дерево)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Класс TObjectArchive (Архив объектов)

(раздел целиком) (одним файлом)
Класс TObjectArchive (Архив объектов)

Диаграмма

  • Свойства
  • Метод Purge (Очистить архив)
  • Метод Put (Положить объект в архив)
  • Метод PutAutonomous (Положить объект в архив в автономной транзакции)
  • Метод Remove (Исключить объект из архива)


Свойства

(одним файлом)
Свойства

Свойства класса TObjectArchive:

Имя | Тип | Обязательно | Доступ | Назначение
Object | TObject | Да | Только для чтения | Объект
ObjectName | string[64] | Да | Только для чтения | Имя объекта
ObjectDescription | string[128] | Да | Только для чтения | Наименование объекта
ObjectClass | TClass | Да | Только для чтения | Класс объекта
ObjectParent | TObject | Нет | Только для чтения | Объект-родитель
ObjectMaster | TObject | Да | Только для чтения | Объект-мастер
ObjectSourceDataBase | TDataBase | Да | Только для чтения | База данных-источник
ObjectOldID | string[38] | Да | Только для чтения | Идентификатор объекта при создании
ObjectCreator | TUser | Да | Только для чтения | Объект создан пользователем
ObjectCreated | datetime | Да | Только для чтения | Объект создан
ObjectModifier | TUser | Да | Только для чтения | Объект изменен пользователем
ObjectModified | datetime | Да | Только для чтения | Объект изменен
User | TUser | Да | Только для чтения | Пользователь
UserName | string[64] | Да | Только для чтения | Имя пользователя

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TUser (Пользователи)


Метод Purge (Очистить архив)

(одним файлом)
Метод Purge (Очистить архив)

Метод класса (статический метод) класса TObjectArchive.

class procedure TObjectArchive.Purge(TimeLimit: time);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeLimit | time | Нет | Лимит времени выполнения


Метод Put (Положить объект в архив)

(одним файлом)
Метод Put (Положить объект в архив)

Метод класса (статический метод) класса TObjectArchive.

class procedure TObjectArchive.Put(Object: TObject);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Нет | Объект

См. также
  • Класс TObject (Объекты)


Метод PutAutonomous (Положить объект в архив в автономной транзакции)

(одним файлом)
Метод PutAutonomous (Положить объект в архив в автономной транзакции)

Метод класса (статический метод) класса TObjectArchive.

class procedure TObjectArchive.PutAutonomous(Object: TObject);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Нет | Объект

См. также
  • Класс TObject (Объекты)


Метод Remove (Исключить объект из архива)

(одним файлом)
Метод Remove (Исключить объект из архива)

Метод класса (статический метод) класса TObjectArchive.

class procedure TObjectArchive.Remove(Object: TObject);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Нет | Объект

См. также
  • Класс TObject (Объекты)


Класс TObjectCreator (Роли-создатели)

(раздел целиком) (одним файлом)
Класс TObjectCreator (Роли-создатели)

Класс TObject (Объекты)Класс TClass (Классы)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор роли-создателя)
См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TObjectCreator:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
SecurityAccount | TSecurityAccount | Да | Видимо пользователю | Чтение/Запись | Роль безопасности

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор роли-создателя)

(одним файлом)
Конструктор Create (Конструктор роли-создателя)

Конструктор класса TObjectCreator.

1constructor TObjectCreator.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
SecurityAccount | TSecurityAccount | Да | Роль безопасности

Замечания:

Создает новый объект класса TObjectCreator.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Класс TObjectHistory (История объектов)

(раздел целиком) (одним файлом)
Класс TObjectHistory (История объектов)

Диаграмма

  • Свойства
  • Метод Clear (Очистить историю)
  • Метод Log (Создать запись протокола)
  • Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)
  • Шаблон отчета Excel UserActivityReport (Отчет об активности пользователей)


Свойства

(одним файлом)
Свойства

Свойства класса TObjectHistory:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Только для чтения | Имя
Description | string[128] | Да | Видимо пользователю | Только для чтения | Наименование
Class | TClass | Да | Видимо пользователю | Только для чтения | Класс
Master | string[2000] | Нет | Видимо пользователю | Только для чтения | Мастер
Parent | string[2000] | Нет | Видимо пользователю | Только для чтения | Родитель
Data | string[2000] | Нет | Видимо пользователю | Только для чтения | Содержимое
Action | TChangeAction | Да | Видимо пользователю | Только для чтения | Действие
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
Login | string[64] | Да | Видимо пользователю | Только для чтения | Логин
ObjectOldID | string[38] | Да | Видимо пользователю | Только для чтения | Идентификатор при создании
ObjectDataBase | TDataBase | Да | Видимо пользователю | Только для чтения | База данных объекта
ObjectID | string[38] | Да | Видимо пользователю | Только для чтения | Идентификатор объекта
IntStamp | Integer | Нет | Видимо пользователю | Только для чтения | Целочисленный номер
Session | TSessionHistory | Нет | Скрыто от пользователя | Только для чтения | Сессия
SessionTimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время начала сессии
SessionCloseStamp | datetime | Нет | Видимо пользователю | Только для чтения | Время завершения сессии
FieldName | string[64] | Да | Видимо пользователю | Только для чтения | Поле
UserAgent | string[2000] | Нет | Видимо пользователю | Только для чтения | Пользовательский агент
IPAddress | string[16] | Нет | Видимо пользователю | Только для чтения | IP-адрес
ConnectionInfo | string[2000] | Нет | Видимо пользователю | Только для чтения | Информация о соединении

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TSessionHistory (Сессии)
  • Класс TUser (Пользователи)
  • Перечисление TChangeAction (Действие при изменении)


Метод Clear (Очистить историю)

(одним файлом)
Метод Clear (Очистить историю)

Метод класса (статический метод) класса TObjectHistory.

1class procedure TObjectHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Метод Log (Создать запись протокола)

(одним файлом)
Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TObjectHistory.

1class procedure TObjectHistory.Log(Object: TObject; Action: TChangeAction;
2  Field: TField; Data: string[2000]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Нет | Объект
Action | TChangeAction | Да | Действие
Field | TField | Нет | Поле
Data | string[2000] | Нет | Содержимое

См. также
  • Класс TField (Поля)
  • Класс TObject (Объекты)
  • Перечисление TChangeAction (Действие при изменении)


Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

(одним файлом)
Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObjectHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
FileName | string[255] | Да | Имя файла
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Шаблон отчета Excel UserActivityReport (Отчет об активности пользователей)

(одним файлом)
Шаблон отчета Excel UserActivityReport (Отчет об активности пользователей)

Шаблон отчета Excel класса (статический шаблон) класса TObjectHistory.

Шаблон отчета Excel является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
UDate | date | Нет | Дата


Класс TObjectList (Списки)

(раздел целиком) (одним файлом)
Класс TObjectList (Списки)

Класс TObject (Объекты)Класс TObjectListItem (Элементы списков)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор списка)
  • Метод Add (Добавить объект в список)
  • Метод Archive (Отправить список в архив)
  • Метод ArchiveAll (Отправить список в архив со всем содержимым)
  • Метод ByName (Поиск по имени)
  • Метод Clear (Очистить список)
  • Метод CreateFromClob (Создать список на основе большого текстового объекта)
  • Метод CreateFromOrderedClob (Создать упорядоченный список на основе большого текстового объекта)
  • Метод CreateFromOrderedString (Создать упорядоченный список на основе текстового представления)
  • Метод CreateFromString (Создать список на основе текстового представления)
  • Метод Delete (Удалить объект)
  • Метод DestroyAll (Удалить вместе с содержащимися в списке объектами)
  • Метод Force (Добавить, игнорируя ограничения)
  • Метод GetAsClob (Получить в виде большого текстового объекта)
  • Метод GetAsString (Список в текстовом представлении)
  • Метод GetItem (Получить объект из списка)
  • Метод IndexOf (Индекс объекта в списке)
  • Метод Insert (Вставить объект в список)
  • Метод IsExcluded (Объект не входит в список)
  • Метод IsIncluded (Объект входит в список)
  • Метод Length (Длина списка)
  • Метод LoadFromClob (Загрузить содержимое списка из большого текстового объекта)
  • Метод LoadFromString (Загрузить содержимое списка из текстового представления)
  • Метод Remove (Вычистить объект)
  • Метод Reorder (Перенумеровать объекты в списке)
  • Метод SetAsClob (Установить список в виде большого текстового объекта)
  • Метод SetAsString (Установить список в текстовом представлении)
  • Метод SetItem (Установить объект в списке)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TObjectList:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
AsString | string[2000] | Нет | Скрыто от пользователя | Чтение/Запись | Список в текстовом представлении
AsClob | clob | Нет | Скрыто от пользователя | Чтение/Запись | Список в виде большого текстового объекта

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор списка)

(одним файлом)
Конструктор Create (Конструктор списка)

Конструктор класса TObjectList.

1constructor TObjectList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TObjectList.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод Add (Добавить объект в список)

(одним файлом)
Метод Add (Добавить объект в список)

Метод экземпляра класса TObjectList.

procedure TObjectList.Add(ItemObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemObject | TObject | Да | Элемент

См. также
  • Класс TObject (Объекты)


Метод Archive (Отправить список в архив)

(одним файлом)
Метод Archive (Отправить список в архив)

Метод экземпляра класса TObjectList.

procedure TObjectList.Archive;

Метод не имеет параметров.


Метод ArchiveAll (Отправить список в архив со всем содержимым)

(одним файлом)
Метод ArchiveAll (Отправить список в архив со всем содержимым)

Метод экземпляра класса TObjectList.

procedure TObjectList.ArchiveAll;

Метод не имеет параметров.


Метод ByName (Поиск по имени)

(одним файлом)
Метод ByName (Поиск по имени)

Метод экземпляра класса TObjectList.

function TObjectList.ByName(Name: string[64]): Integer;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя

Замечания:

Возвращает значение типа Integer.


Метод Clear (Очистить список)

(одним файлом)
Метод Clear (Очистить список)

Метод экземпляра класса TObjectList.

procedure TObjectList.Clear;

Метод скрыт от пользователя.

Метод не имеет параметров.


Метод CreateFromClob (Создать список на основе большого текстового объекта)

(одним файлом)
Метод CreateFromClob (Создать список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.

class function TObjectList.CreateFromClob(Value: clob): TObjectList;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа TObjectList.


Метод CreateFromOrderedClob (Создать упорядоченный список на основе большого текстового объекта)

(одним файлом)
Метод CreateFromOrderedClob (Создать упорядоченный список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.

class function TObjectList.CreateFromOrderedClob(Value: clob): TObjectList;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа TObjectList.


Метод CreateFromOrderedString (Создать упорядоченный список на основе текстового представления)

(одним файлом)
Метод CreateFromOrderedString (Создать упорядоченный список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.

class function TObjectList.CreateFromOrderedString(Value: string[2000]): TObjectList;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа TObjectList.


Метод CreateFromString (Создать список на основе текстового представления)

(одним файлом)
Метод CreateFromString (Создать список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.

class function TObjectList.CreateFromString(Value: string[2000]): TObjectList;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа TObjectList.


Метод Delete (Удалить объект)

(одним файлом)
Метод Delete (Удалить объект)

Метод экземпляра класса TObjectList.

procedure TObjectList.Delete(ItemObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemObject | TObject | Да | Элемент

См. также
  • Класс TObject (Объекты)


Метод DestroyAll (Удалить вместе с содержащимися в списке объектами)

(одним файлом)
Метод DestroyAll (Удалить вместе с содержащимися в списке объектами)

Метод экземпляра класса TObjectList.

procedure TObjectList.DestroyAll;

Метод не имеет параметров.


Метод Force (Добавить, игнорируя ограничения)

(одним файлом)
Метод Force (Добавить, игнорируя ограничения)

Метод экземпляра класса TObjectList.

procedure TObjectList.Force(ItemObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemObject | TObject | Да | Элемент

См. также
  • Класс TObject (Объекты)


Метод GetAsClob (Получить в виде большого текстового объекта)

(одним файлом)
Метод GetAsClob (Получить в виде большого текстового объекта)

Метод экземпляра класса TObjectList.

function TObjectList.GetAsClob: clob;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.


Метод GetAsString (Список в текстовом представлении)

(одним файлом)
Метод GetAsString (Список в текстовом представлении)

Метод экземпляра класса TObjectList.

function TObjectList.GetAsString: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод GetItem (Получить объект из списка)

(одним файлом)
Метод GetItem (Получить объект из списка)

Метод экземпляра класса TObjectList.

function TObjectList.GetItem(ItemIndex: Integer): TObject;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс

Замечания:

Возвращает значение типа TObject.

См. также
  • Класс TObject (Объекты)


Метод IndexOf (Индекс объекта в списке)

(одним файлом)
Метод IndexOf (Индекс объекта в списке)

Метод экземпляра класса TObjectList.

function TObjectList.IndexOf(ItemObject: TObject): Integer;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemObject | TObject | Да | Элемент

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Метод Insert (Вставить объект в список)

(одним файлом)
Метод Insert (Вставить объект в список)

Метод экземпляра класса TObjectList.

procedure TObjectList.Insert(ItemIndex: Integer; ItemObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс
ItemObject | TObject | Да | Элемент

См. также
  • Класс TObject (Объекты)


Метод IsExcluded (Объект не входит в список)

(одним файлом)
Метод IsExcluded (Объект не входит в список)

Метод экземпляра класса TObjectList.

function TObjectList.IsExcluded(Value: TObject): Boolean;

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObject (Объекты)


Метод IsIncluded (Объект входит в список)

(одним файлом)
Метод IsIncluded (Объект входит в список)

Метод экземпляра класса TObjectList.

function TObjectList.IsIncluded(Value: TObject): Boolean;

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObject (Объекты)


Метод Length (Длина списка)

(одним файлом)
Метод Length (Длина списка)

Метод экземпляра класса TObjectList.

function TObjectList.Length: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод LoadFromClob (Загрузить содержимое списка из большого текстового объекта)

(одним файлом)
Метод LoadFromClob (Загрузить содержимое списка из большого текстового объекта)

Метод экземпляра класса TObjectList.

1procedure TObjectList.LoadFromClob(Value: clob; Ordered: Boolean;
2  Clear: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение
Ordered | Boolean | Да | Сохранить порядок объектов
Clear | Boolean | Да | Очистить перед загрузкой


Метод LoadFromString (Загрузить содержимое списка из текстового представления)

(одним файлом)
Метод LoadFromString (Загрузить содержимое списка из текстового представления)

Метод экземпляра класса TObjectList.

1procedure TObjectList.LoadFromString(Value: string[2000]; Ordered: Boolean;
2  Clear: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Ordered | Boolean | Да | Сохранить порядок объектов
Clear | Boolean | Да | Очистить перед загрузкой


Метод Remove (Вычистить объект)

(одним файлом)
Метод Remove (Вычистить объект)

Метод экземпляра класса TObjectList.

procedure TObjectList.Remove(ItemObject: TObject);

Параметры:

Имя | Тип | Обязательно | Значение
ItemObject | TObject | Да | Элемент

См. также
  • Класс TObject (Объекты)


Метод Reorder (Перенумеровать объекты в списке)

(одним файлом)
Метод Reorder (Перенумеровать объекты в списке)

Метод экземпляра класса TObjectList.

procedure TObjectList.Reorder;

Метод не имеет параметров.


Метод SetAsClob (Установить список в виде большого текстового объекта)

(одним файлом)
Метод SetAsClob (Установить список в виде большого текстового объекта)

Метод экземпляра класса TObjectList.

procedure TObjectList.SetAsClob(Value: clob);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение


Метод SetAsString (Установить список в текстовом представлении)

(одним файлом)
Метод SetAsString (Установить список в текстовом представлении)

Метод экземпляра класса TObjectList.

procedure TObjectList.SetAsString(Value: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение


Метод SetItem (Установить объект в списке)

(одним файлом)
Метод SetItem (Установить объект в списке)

Метод экземпляра класса TObjectList.

procedure TObjectList.SetItem(ItemIndex: Integer; ItemObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс
ItemObject | TObject | Да | Элемент

См. также
  • Класс TObject (Объекты)


Класс TObjectListItem (Элементы списков)

(раздел целиком) (одним файлом)
Класс TObjectListItem (Элементы списков)

Диаграмма Класс TObject (Объекты)Класс TObjectList (Списки)

  • Свойства
  • Конструктор Create (Конструктор элемента списка)
См. также
  • Класс TObject (Объекты)
  • Класс TObjectList (Списки)


Свойства

(одним файлом)
Свойства

Свойства класса TObjectListItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Object | TObject | Да | Видимо пользователю | Только для чтения | Объект
Position | Integer | Да | Видимо пользователю | Только для чтения | Позиция

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TObjectList (Списки)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор элемента списка)

(одним файлом)
Конструктор Create (Конструктор элемента списка)

Конструктор класса TObjectListItem.

1constructor TObjectListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ItemObject: TObject; Position: Integer): TObject;

Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
ItemObject | TObject | Да | Элемент
Position | Integer | Нет | Позиция

Замечания:

Создает новый объект класса TObjectListItem.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Класс TObjectSet (Множества объектов)

(раздел целиком) (одним файлом)
Класс TObjectSet (Множества объектов)

Диаграмма

  • Конструктор Create (Создать множество)
  • Метод Add (Добавить множество)
  • Метод Change (Изменение объекта)
  • Метод Clear (Очистить множество)
  • Метод Clone (Клонировать множество)
  • Метод CreateFromClob (Создать множество на основе большого текстового объекта)
  • Метод CreateFromString (Создать множество на основе строки)
  • Метод Exclude (Исключить объект из множества)
  • Метод ExcludeClob (Исключить содержимое большого текстового объекта из множества)
  • Метод ExcludeString (Исключить содержимое строки из множества)
  • Метод GetAsClob (Множество в виде большого текстового объекта)
  • Метод GetAsString (Множество в виде строки)
  • Метод Include (Включить объект в множество)
  • Метод IncludeClob (Включить содержимое большого текстового объекта в множество)
  • Метод IncludeString (Включить содержимое строки в множество)
  • Метод IsExcluded (Объект не входит в множество)
  • Метод IsIncluded (Объект входит в множество)
  • Метод Length (Количество элементов)
  • Метод Multiply (Умножить на множество)
  • Метод Subtract (Вычесть множество)


Конструктор Create (Создать множество)

(одним файлом)
Конструктор Create (Создать множество)

Конструктор класса TObjectSet.

constructor TObjectSet.Create: TObjectSet;

Метод не имеет параметров.

Замечания:

Создает новый объект класса TObjectSet.


Метод Add (Добавить множество)

(одним файлом)
Метод Add (Добавить множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Add(Value: TObjectSet);

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectSet | Нет | Значение


Метод Change (Изменение объекта)

(одним файлом)
Метод Change (Изменение объекта)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Change(Action: TChangeAction);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Действие

См. также
  • Перечисление TChangeAction (Действие при изменении)


Метод Clear (Очистить множество)

(одним файлом)
Метод Clear (Очистить множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Clear;

Метод не имеет параметров.


Метод Clone (Клонировать множество)

(одним файлом)
Метод Clone (Клонировать множество)

Метод экземпляра класса TObjectSet.

function TObjectSet.Clone: TObjectSet;

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectSet.


Метод CreateFromClob (Создать множество на основе большого текстового объекта)

(одним файлом)
Метод CreateFromClob (Создать множество на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectSet.

class function TObjectSet.CreateFromClob(Value: clob): TObjectSet;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа TObjectSet.


Метод CreateFromString (Создать множество на основе строки)

(одним файлом)
Метод CreateFromString (Создать множество на основе строки)

Метод класса (статический метод) класса TObjectSet.

class function TObjectSet.CreateFromString(Value: string[2000]): TObjectSet;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа TObjectSet.


Метод Exclude (Исключить объект из множества)

(одним файлом)
Метод Exclude (Исключить объект из множества)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Exclude(Value: TObject);

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

См. также
  • Класс TObject (Объекты)


Метод ExcludeClob (Исключить содержимое большого текстового объекта из множества)

(одним файлом)
Метод ExcludeClob (Исключить содержимое большого текстового объекта из множества)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.ExcludeClob(Value: clob);

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение


Метод ExcludeString (Исключить содержимое строки из множества)

(одним файлом)
Метод ExcludeString (Исключить содержимое строки из множества)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.ExcludeString(Value: string[2000]);

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение


Метод GetAsClob (Множество в виде большого текстового объекта)

(одним файлом)
Метод GetAsClob (Множество в виде большого текстового объекта)

Метод экземпляра класса TObjectSet.

function TObjectSet.GetAsClob: clob;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.


Метод GetAsString (Множество в виде строки)

(одним файлом)
Метод GetAsString (Множество в виде строки)

Метод экземпляра класса TObjectSet.

function TObjectSet.GetAsString: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод Include (Включить объект в множество)

(одним файлом)
Метод Include (Включить объект в множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Include(Value: TObject);

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

См. также
  • Класс TObject (Объекты)


Метод IncludeClob (Включить содержимое большого текстового объекта в множество)

(одним файлом)
Метод IncludeClob (Включить содержимое большого текстового объекта в множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.IncludeClob(Value: clob);

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение


Метод IncludeString (Включить содержимое строки в множество)

(одним файлом)
Метод IncludeString (Включить содержимое строки в множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.IncludeString(Value: string[2000]);

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение


Метод IsExcluded (Объект не входит в множество)

(одним файлом)
Метод IsExcluded (Объект не входит в множество)

Метод экземпляра класса TObjectSet.

function TObjectSet.IsExcluded(Value: TObject): Boolean;

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObject (Объекты)


Метод IsIncluded (Объект входит в множество)

(одним файлом)
Метод IsIncluded (Объект входит в множество)

Метод экземпляра класса TObjectSet.

function TObjectSet.IsIncluded(Value: TObject): Boolean;

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObject (Объекты)


Метод Length (Количество элементов)

(одним файлом)
Метод Length (Количество элементов)

Метод экземпляра класса TObjectSet.

function TObjectSet.Length: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод Multiply (Умножить на множество)

(одним файлом)
Метод Multiply (Умножить на множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Multiply(Value: TObjectSet);

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectSet | Нет | Значение


Метод Subtract (Вычесть множество)

(одним файлом)
Метод Subtract (Вычесть множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Subtract(Value: TObjectSet);

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectSet | Нет | Значение


Класс TOleObjectMethod (Метод Ole-объекта)

(раздел целиком) (одним файлом)
Класс TOleObjectMethod (Метод Ole-объекта)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

  • Свойства
  • Конструктор Create (Конструктор метода Ole-объекта)
  • Метод Ole-объекта CheckOleObjectMethod (Проверить метод Ole-объекта)
См. также
  • Класс TClass (Классы)
  • Класс TRoutine (Подпрограмма)


Свойства

(одним файлом)
Свойства

Свойства класса TOleObjectMethod:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
ClassID | string[128] | Нет | Видимо пользователю | Чтение/Запись | Идентификатор класса
Method | string[128] | Нет | Видимо пользователю | Чтение/Запись | Метод
CodeLibrary | TAccessibleFile | Нет | Видимо пользователю | Чтение/Запись | Библиотека кода
IsInteractive | Boolean | Да | Видимо пользователю | Чтение/Запись | Интерактивный

См. также
  • Класс TAccessibleFile (Доступный файл)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор метода Ole-объекта)

(одним файлом)
Конструктор Create (Конструктор метода Ole-объекта)

Конструктор класса TOleObjectMethod.

1constructor TOleObjectMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; CodeLibrary: TAccessibleFile;
6  ClassID: string[128]; Method: string[128]; IsInteractive: Boolean): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
CodeLibrary | TAccessibleFile | Нет | Библиотека кода
ClassID | string[128] | Нет | Идентификатор класса
Method | string[128] | Нет | Метод
IsInteractive | Boolean | Да | Интерактивный

Замечания:

Создает новый объект класса TOleObjectMethod.

См. также
  • Класс TAccessibleFile (Доступный файл)
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор подпрограммы)
  • Конструктор Create (Конструктор члена класса)
  • Перечисление TScope (Область видимости)


Метод Ole-объекта CheckOleObjectMethod (Проверить метод Ole-объекта)

(одним файлом)
Метод Ole-объекта CheckOleObjectMethod (Проверить метод Ole-объекта)

Метод Ole-объекта класса TOleObjectMethod.

Метод Ole-объекта не имеет параметров.


Класс TOption (Настройки)

(раздел целиком) (одним файлом)
Класс TOption (Настройки)

Диаграмма Класс TObject (Объекты)Класс TOptionValue (Значения настроек)

  • Свойства
  • Конструктор Create (Конструктор настройки)
  • Метод AreValid (Настройки действительны)
  • Метод GetBlobValue (Значение-большой объект)
  • Метод GetBoolValue (Логическое значение)
  • Метод GetClobValue (Значение-текст)
  • Метод GetDateTimeValue (Значение даты со временем)
  • Метод GetDateValue (Значение даты)
  • Метод GetExternalDataValue (Значение внешних данных)
  • Метод GetFloatValue (Вещественное значение)
  • Метод GetIntValue (Целое значение)
  • Метод GetNextPos (Следующая позиция)
  • Метод GetObjectValue (Значение-объект)
  • Метод GetStrValue (Строковое значение)
  • Метод GetTimeValue (Значение времени)
  • Метод GetValue (Значение)
  • Метод SetValue (Установка значения)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TOption:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Видимо пользователю | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок закладки
Global | Boolean | Да | Видимо пользователю | Чтение/Запись | Глобальная
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок группы
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Value | TOptionValue | Нет | Скрыто от пользователя | Только для чтения | Значение
User | TUser | Нет | Видимо пользователю | Чтение/Запись | Пользователь
VisibleValue | string[2000] | Нет | Видимо пользователю | Только для чтения | Видимое значение
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TOptionValue (Значения настроек)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор настройки)

(одним файлом)
Конструктор Create (Конструктор настройки)

Конструктор класса TOption.

1constructor TOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Global: Boolean; Group: string[128]; Tab: string[128];
4  Position: Integer; Scope: TScope): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
Global | Boolean | Да | Глобальная
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Position | Integer | Нет | Позиция
Scope | TScope | Да | Область видимости

Замечания:

Создает новый объект класса TOption.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TScope (Область видимости)


Метод AreValid (Настройки действительны)

(одним файлом)
Метод AreValid (Настройки действительны)

Метод класса (статический метод) класса TOption.

class function TOption.AreValid: Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод GetBlobValue (Значение-большой объект)

(одним файлом)
Метод GetBlobValue (Значение-большой объект)

Метод класса (статический метод) класса TOption.

class function TOption.GetBlobValue(OptionName: string[64]): blob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа blob.


Метод GetBoolValue (Логическое значение)

(одним файлом)
Метод GetBoolValue (Логическое значение)

Метод класса (статический метод) класса TOption.

class function TOption.GetBoolValue(OptionName: string[64]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа Boolean.


Метод GetClobValue (Значение-текст)

(одним файлом)
Метод GetClobValue (Значение-текст)

Метод класса (статический метод) класса TOption.

class function TOption.GetClobValue(OptionName: string[64]): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа clob.


Метод GetDateTimeValue (Значение даты со временем)

(одним файлом)
Метод GetDateTimeValue (Значение даты со временем)

Метод класса (статический метод) класса TOption.

class function TOption.GetDateTimeValue(OptionName: string[64]): datetime;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа datetime.


Метод GetDateValue (Значение даты)

(одним файлом)
Метод GetDateValue (Значение даты)

Метод класса (статический метод) класса TOption.

class function TOption.GetDateValue(OptionName: string[64]): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа date.


Метод GetExternalDataValue (Значение внешних данных)

(одним файлом)
Метод GetExternalDataValue (Значение внешних данных)

Метод класса (статический метод) класса TOption.

1class function TOption.GetExternalDataValue(OptionName: string[64]): <external
2  data>;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа <external data>.


Метод GetFloatValue (Вещественное значение)

(одним файлом)
Метод GetFloatValue (Вещественное значение)

Метод класса (статический метод) класса TOption.

class function TOption.GetFloatValue(OptionName: string[64]): float;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа float.


Метод GetIntValue (Целое значение)

(одним файлом)
Метод GetIntValue (Целое значение)

Метод класса (статический метод) класса TOption.

class function TOption.GetIntValue(OptionName: string[64]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа Integer.


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TOption.

class function TOption.GetNextPos: Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод GetObjectValue (Значение-объект)

(одним файлом)
Метод GetObjectValue (Значение-объект)

Метод класса (статический метод) класса TOption.

class function TOption.GetObjectValue(OptionName: string[64]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа TObject.

См. также
  • Класс TObject (Объекты)


Метод GetStrValue (Строковое значение)

(одним файлом)
Метод GetStrValue (Строковое значение)

Метод класса (статический метод) класса TOption.

class function TOption.GetStrValue(OptionName: string[64]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа string[2000].


Метод GetTimeValue (Значение времени)

(одним файлом)
Метод GetTimeValue (Значение времени)

Метод класса (статический метод) класса TOption.

class function TOption.GetTimeValue(OptionName: string[64]): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа time.


Метод GetValue (Значение)

(одним файлом)
Метод GetValue (Значение)

Метод экземпляра класса TOption.

function TOption.GetValue: TOptionValue;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TOptionValue.

См. также
  • Класс TOptionValue (Значения настроек)


Метод SetValue (Установка значения)

(одним файлом)
Метод SetValue (Установка значения)

Метод экземпляра класса TOption.

1procedure TOption.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>; Default: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
StrValue | string[2000] | Нет | Строковое значение
IntValue | Integer | Нет | Целое значение
FloatValue | float | Нет | Вещественное значение
DateValue | date | Нет | Значение даты
TimeValue | time | Нет | Значение времени
DateTimeValue | datetime | Нет | Значение даты со временем
ObjectValue | TObject | Нет | Значение-объект
BoolValue | Boolean | Нет | Логическое значение
BlobValue | blob | Нет | Значение-большой объект
ClobValue | clob | Нет | Значение-текст
ExternalDataValue | <external data> | Нет | Значение-внешние данные
Default | Boolean | Да | По умолчанию

См. также
  • Класс TObject (Объекты)


Класс TOptionValue (Значения настроек)

(раздел целиком) (одним файлом)
Класс TOptionValue (Значения настроек)

Класс TTypedValue (Типизированные значения)Класс TObject (Объекты)Класс TOption (Настройки)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор значения настройки)
См. также
  • Класс TOption (Настройки)
  • Класс TTypedValue (Типизированные значения)


Свойства

(одним файлом)
Свойства

Свойства класса TOptionValue:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Нет | Скрыто от пользователя | Только для чтения | Унаследовано от TTypedValue
MasterClass | TClass | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TTypedValue
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
StrValue | string[2000] | Нет | Скрыто от пользователя | Чтение/Запись
IntValue | Integer | Нет | Скрыто от пользователя | Чтение/Запись
FloatValue | float | Нет | Скрыто от пользователя | Чтение/Запись
DateValue | date | Нет | Скрыто от пользователя | Чтение/Запись
TimeValue | time | Нет | Скрыто от пользователя | Чтение/Запись
DateTimeValue | datetime | Нет | Скрыто от пользователя | Чтение/Запись
ObjectValue | TObject | Нет | Скрыто от пользователя | Чтение/Запись
BoolValue | Boolean | Нет | Скрыто от пользователя | Чтение/Запись
BlobValue | blob | Нет | Видимо пользователю | Чтение/Запись
ClobValue | clob | Нет | Видимо пользователю | Чтение/Запись
ExternalDataValue | <external data> | Нет | Видимо пользователю | Чтение/Запись
VisibleValue | string[2000] | Нет | Видимо пользователю | Только для чтения
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись
User | TUser | Нет | Видимо пользователю | Чтение/Запись | Пользователь
IsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Является текущим
Option | TOption | Да | Скрыто от пользователя | Только для чтения | Настройка
Domain | TDomain | Да | Видимо пользователю | Только для чтения | Домен
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TTypedValue
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
Global | Boolean | Да | Видимо пользователю | Только для чтения | Глобальная

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TOption (Настройки)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TTypedValue (Типизированные значения)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор значения настройки)

(одним файлом)
Конструктор Create (Конструктор значения настройки)

Конструктор класса TOptionValue.

1constructor TOptionValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;

Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
Position | Integer | Да | Позиция
Group | string[128] | Нет | Группа
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
StrValue | string[2000] | Нет | Унаследовано от TTypedValue.Create
IntValue | Integer | Нет
FloatValue | float | Нет
DateValue | date | Нет
TimeValue | time | Нет
DateTimeValue | datetime | Нет
ObjectValue | TObject | Нет
BoolValue | Boolean | Нет
BlobValue | blob | Нет
ClobValue | clob | Нет
ExternalDataValue | <external data> | Нет
User | TUser | Нет | Пользователь

Замечания:

Создает новый объект класса TOptionValue.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор типизированного значения)
  • Перечисление TScope (Область видимости)


Класс TParameter (Параметры)

(раздел целиком) (одним файлом)
Класс TParameter (Параметры)

Диаграмма Класс TObject (Объекты)Класс TRoutine (Подпрограмма)

  • Свойства
  • Конструктор Create (Конструктор параметра)
  • Метод GetNextPos (Следующая позиция)
  • Метод GetOverride (Переопределен)
См. также
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)


Свойства

(одним файлом)
Свойства

Свойства класса TParameter:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
RoutineClass | TClass | Нет | Видимо пользователю | Только для чтения | Класс подпрограммы
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Видимо пользователю | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок закладки
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок группы
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
InitializationMember | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Инициализируется членом класса
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись | За пределами закладок
Override | Boolean | Да | Видимо пользователю | Только для чтения | Переопределен
LinkedView | TParametersFormView | Нет | Видимо пользователю | Чтение/Запись | Связанное представление
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись | Протоколировать

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TParametersFormView (Представления формы параметров)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор параметра)

(одним файлом)
Конструктор Create (Конструктор параметра)

Конструктор класса TParameter.

1constructor TParameter.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; InitializationMember: TClassMember; OutOfTabs: Boolean;
5  LinkedView: TParametersFormView; Logged: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Имя
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
InitializationMember | TClassMember | Нет | Инициализируется членом класса
OutOfTabs | Boolean | Да | За пределами закладок
LinkedView | TParametersFormView | Нет | Связанное представление
Logged | Boolean | Да | Протоколировать

Замечания:

Создает новый объект класса TParameter.

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TParametersFormView (Представления формы параметров)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TScope (Область видимости)


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TParameter.

class function TParameter.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Метод GetOverride (Переопределен)

(одним файлом)
Метод GetOverride (Переопределен)

Метод экземпляра класса TParameter.

function TParameter.GetOverride: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Класс TParameterHistory (Параметры вызовов)

(раздел целиком) (одним файлом)
Класс TParameterHistory (Параметры вызовов)

Диаграмма Класс TRoutineHistory (Вызовы)

  • Свойства
  • Метод Log (Создать запись протокола)
См. также
  • Класс TRoutineHistory (Вызовы)


Свойства

(одним файлом)
Свойства

Свойства класса TParameterHistory:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Routine | TRoutineHistory | Да | Скрыто от пользователя | Только для чтения | Вызов подпрограммы
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время
ParameterName | string[64] | Да | Видимо пользователю | Только для чтения | Параметр
Data | string[2000] | Нет | Видимо пользователю | Только для чтения | Содержимое
ObjectID | string[38] | Нет | Видимо пользователю | Только для чтения | Идентификатор объекта
ObjectDataBase | TDataBase | Нет | Видимо пользователю | Только для чтения | База данных объекта
ObjectOldID | string[38] | Нет | Видимо пользователю | Только для чтения | Идентификатор при создании

См. также
  • Класс TDataBase (Базы данных)
  • Класс TRoutineHistory (Вызовы)


Метод Log (Создать запись протокола)

(одним файлом)
Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TParameterHistory.

1class procedure TParameterHistory.Log(Routine: TRoutineHistory;
2  Parameter: TParameter; Data: string[2000]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Routine | TRoutineHistory | Да | Вызов подпрограммы
Parameter | TParameter | Да | Параметр
Data | string[2000] | Нет | Содержимое

См. также
  • Класс TParameter (Параметры)
  • Класс TRoutineHistory (Вызовы)


Класс TParametersFormView (Представления формы параметров)

(раздел целиком) (одним файлом)
Класс TParametersFormView (Представления формы параметров)

Класс TFormView (Представления формы)Класс TObject (Объекты)Класс TRoutine (Подпрограмма)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

  • Конструктор Create (Конструктор представления формы параметров)
См. также
  • Класс TFormView (Представления формы)
  • Класс TRoutine (Подпрограмма)


Конструктор Create (Конструктор представления формы параметров)

(одним файлом)
Конструктор Create (Конструктор представления формы параметров)

Конструктор класса TParametersFormView.

1constructor TParametersFormView.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; View: TCustomView; ChildrenMinimized: Boolean;
4  ChildrenOnTabs: Boolean; MasterProperty: TProperty;
5  DetailProperty: TClassMember; Position: Integer; SpacePercentage: Integer;
6  Layout: TFormViewLayout; ExplicitQuery: Boolean): TObject;

Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
View | TCustomView | Да | Унаследовано от TFormView.Create
ChildrenMinimized | Boolean | Да
ChildrenOnTabs | Boolean | Да
MasterProperty | TProperty | Нет
DetailProperty | TClassMember | Нет
Position | Integer | Да
SpacePercentage | Integer | Нет
Layout | TFormViewLayout | Да
ExplicitQuery | Boolean | Да

Замечания:

Создает новый объект класса TParametersFormView.

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TCustomView (Абстрактное представление)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор представления формы)
  • Перечисление TFormViewLayout (Виды расположения)


Класс TPDFTemplate (Шаблоны отчетов PDF)

(раздел целиком) (одним файлом)
Класс TPDFTemplate (Шаблоны отчетов PDF)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

  • Свойства
  • Конструктор Create (Конструктор шаблона PDF)
См. также
  • Класс TClass (Классы)
  • Класс TRoutine (Подпрограмма)


Свойства

(одним файлом)
Свойства

Свойства класса TPDFTemplate:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
TemplateScript | clob | Нет | Видимо пользователю | Чтение/Запись | Скрипт шаблона

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор шаблона PDF)

(одним файлом)
Конструктор Create (Конструктор шаблона PDF)

Конструктор класса TPDFTemplate.

1constructor TPDFTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateScript: clob): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
TemplateScript | clob | Нет | Скрипт шаблона

Замечания:

Создает новый объект класса TPDFTemplate.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор подпрограммы)
  • Конструктор Create (Конструктор члена класса)
  • Перечисление TScope (Область видимости)


Класс TProfile (Профили)

(раздел целиком) (одним файлом)
Класс TProfile (Профили)

Диаграмма Класс TObject (Объекты)Класс TProfileItem (Состав профиля)Класс TProfileUser (Пользователи профиля)

  • Свойства
  • Конструктор Create (Конструктор профиля)
  • Метод Check (Проверка профиля)
  • Метод GetIsActive (Активен для текущего пользователя)
  • Метод GetValueDomain (Получить домен значения)
  • Метод Match (Проверка совпадения)
  • Метод MatchObject (Проверка совпадения объекта)
  • Метод TryCheck (Проверка профиля с возвратом результата)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TProfile:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
ComparisonType | TComparisonType | Да | Видимо пользователю | Чтение/Запись | Тип сравнения
BasedOnProfile | TProfile | Нет | Видимо пользователю | Чтение/Запись | Расширяет профиль пользователями
Active | Boolean | Да | Видимо пользователю | Только для чтения | Активен

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TComparisonType (Типы сравнения)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор профиля)

(одним файлом)
Конструктор Create (Конструктор профиля)

Конструктор класса TProfile.

1constructor TProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType;
4  BasedOnProfile: TProfile): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
ComparisonType | TComparisonType | Да | Тип сравнения
BasedOnProfile | TProfile | Нет | Расширяет профиль пользователями

Замечания:

Создает новый объект класса TProfile.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TComparisonType (Типы сравнения)


Метод Check (Проверка профиля)

(одним файлом)
Метод Check (Проверка профиля)

Метод класса (статический метод) класса TProfile.

class procedure TProfile.Check(Object: TObject; ObjectClass: TClass);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Да | Объект
ObjectClass | TClass | Нет | Класс объекта

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)


Метод GetIsActive (Активен для текущего пользователя)

(одним файлом)
Метод GetIsActive (Активен для текущего пользователя)

Метод экземпляра класса TProfile.

function TProfile.GetIsActive: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод GetValueDomain (Получить домен значения)

(одним файлом)
Метод GetValueDomain (Получить домен значения)

Метод экземпляра класса TProfile.

function TProfile.GetValueDomain: TDomain;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TDomain.

См. также
  • Класс TDomain (Домены)


Метод Match (Проверка совпадения)

(одним файлом)
Метод Match (Проверка совпадения)

Метод экземпляра класса TProfile.

1function TProfile.Match(Object: TObject; ObjectClass: TClass;
2  ValueGiven: Boolean; StrValue: string[2000]; IntValue: Integer;
3  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
4  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
5  ExternalDataValue: <external data>): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Да | Объект
ObjectClass | TClass | Нет | Класс объекта
ValueGiven | Boolean | Да | Значение задано
StrValue | string[2000] | Нет | Строковое значение
IntValue | Integer | Нет | Целое значение
FloatValue | float | Нет | Вещественное значение
DateValue | date | Нет | Значение даты
TimeValue | time | Нет | Значение времени
DateTimeValue | datetime | Нет | Значение даты со временем
ObjectValue | TObject | Нет | Значение-объект
BoolValue | Boolean | Нет | Логическое значение
BlobValue | blob | Нет | Значение-большой объект
ClobValue | clob | Нет | Значение-текст
ExternalDataValue | <external data> | Нет | Значение-внешние данные

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)


Метод MatchObject (Проверка совпадения объекта)

(одним файлом)
Метод MatchObject (Проверка совпадения объекта)

Метод экземпляра класса TProfile.

function TProfile.MatchObject(Object: TObject; ObjectClass: TClass): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Да | Объект
ObjectClass | TClass | Нет | Класс объекта

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)


Метод TryCheck (Проверка профиля с возвратом результата)

(одним файлом)
Метод TryCheck (Проверка профиля с возвратом результата)

Метод класса (статический метод) класса TProfile.

class function TProfile.TryCheck(Object: TObject; ObjectClass: TClass): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Да | Объект
ObjectClass | TClass | Нет | Класс объекта

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)


Класс TProfileEvent (События профиля)

(раздел целиком) (одним файлом)
Класс TProfileEvent (События профиля)

Диаграмма Класс TProfileMethod (Методы профиля)

  • Свойства
См. также
  • Класс TProfileMethod (Методы профиля)


Свойства

(одним файлом)
Свойства

Свойства класса TProfileEvent:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Method | TProfileMethod | Да | Скрыто от пользователя | Только для чтения | Метод профилировщика
Class | TClass | Да | Видимо пользователю | Только для чтения | Класс
ObjectID | string[38] | Да | Видимо пользователю | Только для чтения | Идентификатор объекта
ObjectQualifiedName | string[2000] | Нет | Видимо пользователю | Только для чтения | Квалифицированное имя объекта
ObjectDataBase | TDataBase | Нет | Видимо пользователю | Только для чтения | База данных объекта
ObjectOldID | string[38] | Нет | Видимо пользователю | Только для чтения | Идентификатор при создании
Action | TChangeAction | Да | Видимо пользователю | Только для чтения | Действия

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TProfileMethod (Методы профиля)
  • Перечисление TChangeAction (Действие при изменении)


Класс TProfileItem (Состав профиля)

(раздел целиком) (одним файлом)
Класс TProfileItem (Состав профиля)

Класс TProfile (Профили)Класс TObject (Объекты)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор элемента профиля)
  • Метод GetHasCrossConditions (Имеется пересечение условий)
См. также
  • Класс TObject (Объекты)
  • Класс TProfile (Профили)


Свойства

(одним файлом)
Свойства

Свойства класса TProfileItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
ProfileClass | TClass | Да | Видимо пользователю | Чтение/Запись | Профилируемый класс
ProfileProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Профилируемое свойство
Comparator | TMethod | Нет | Видимо пользователю | Чтение/Запись | Сравнивающая функция
Group | string[64] | Нет | Видимо пользователю | Чтение/Запись | Группа
AllowNulls | Boolean | Да | Видимо пользователю | Чтение/Запись | Пропускать пустые значения
HasCrossCondition | Boolean | Да | Видимо пользователю | Только для чтения | Имеется пересечение условий

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TMethod (Методы)
  • Класс TObject (Объекты)
  • Класс TProfile (Профили)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор элемента профиля)

(одним файлом)
Конструктор Create (Конструктор элемента профиля)

Конструктор класса TProfileItem.

1constructor TProfileItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ProfileClass: TClass; ProfileProperty: TProperty; Comparator: TMethod;
4  Group: string[64]; AllowNulls: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
ProfileClass | TClass | Да | Профилируемый класс
ProfileProperty | TProperty | Нет | Профилируемое свойство
Comparator | TMethod | Нет | Сравнивающая функция
Group | string[64] | Нет | Группа
AllowNulls | Boolean | Да | Пропускать пустые значения

Замечания:

Создает новый объект класса TProfileItem.

См. также
  • Класс TClass (Классы)
  • Класс TMethod (Методы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetHasCrossConditions (Имеется пересечение условий)

(одним файлом)
Метод GetHasCrossConditions (Имеется пересечение условий)

Метод экземпляра класса TProfileItem.

function TProfileItem.GetHasCrossConditions: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Класс TProfileMethod (Методы профиля)

(раздел целиком) (одним файлом)
Класс TProfileMethod (Методы профиля)

Класс TProfileEvent (События профиля)Класс TProfileStatistics (Статистика профиля)

Объекты класса образуют иерархию.

  • Свойства
  • Метод BuildReport (Перестроить отчет)
  • Метод Clear (Очистить статистику)
  • Метод Ole-объекта ExportProfilerReport (Экспортировать отчет)


Свойства

(одним файлом)
Свойства

Свойства класса TProfileMethod:

Имя | Тип | Обязательно | Доступ | Назначение
Parent | TProfileMethod | Нет | Только для чтения | Родитель
Method | TMethod | Да | Только для чтения | Метод профилировщика
MethodClass | TClass | Да | Только для чтения | Класс
Position | Integer | Да | Только для чтения | Позиция
Duration | Integer | Нет | Только для чтения | Общее время
CodeDuration | Integer | Нет | Только для чтения | Время собственного кода
Calls | Integer | Нет | Только для чтения | Количество непосредственных вызовов
Events | Integer | Нет | Только для чтения | Непосредственных операций с данными
CommonCalls | Integer | Нет | Только для чтения | Всего вызовов
CommonEvents | Integer | Нет | Только для чтения | Всего операций с данными
ObjectID | string[38] | Да | Только для чтения | Идентификатор объекта
ObjectQualifiedName | string[2000] | Нет | Только для чтения | Квалифицированное имя объекта
ObjectDataBase | TDataBase | Нет | Только для чтения | База данных объекта
ObjectOldID | string[38] | Нет | Только для чтения | Идентификатор при создании

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TMethod (Методы)


Метод BuildReport (Перестроить отчет)

(одним файлом)
Метод BuildReport (Перестроить отчет)

Метод класса (статический метод) класса TProfileMethod.

class procedure TProfileMethod.BuildReport(QualifyObjects: Boolean);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
QualifyObjects | Boolean | Да | Квалифицировать объекты


Метод Clear (Очистить статистику)

(одним файлом)
Метод Clear (Очистить статистику)

Метод класса (статический метод) класса TProfileMethod.

class procedure TProfileMethod.Clear;

Метод является методом класса.

Метод не имеет параметров.


Метод Ole-объекта ExportProfilerReport (Экспортировать отчет)

(одним файлом)
Метод Ole-объекта ExportProfilerReport (Экспортировать отчет)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TProfileMethod.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
FileName | string[255] | Да | Имя файла


Класс TProfileStatistics (Статистика профиля)

(раздел целиком) (одним файлом)
Класс TProfileStatistics (Статистика профиля)

Диаграмма Класс TProfileMethod (Методы профиля)

  • Свойства
См. также
  • Класс TProfileMethod (Методы профиля)


Свойства

(одним файлом)
Свойства

Свойства класса TProfileStatistics:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Method | TProfileMethod | Да | Скрыто от пользователя | Только для чтения | Метод профилировщика
CalledMethod | TMethod | Нет | Видимо пользователю | Только для чтения | Вызываемый метод
CalledMethodClass | TObject | Да | Видимо пользователю | Только для чтения | Класс
Calls | Integer | Нет | Видимо пользователю | Только для чтения | Количество вызовов
Class | TClass | Нет | Видимо пользователю | Только для чтения | Класс
Inserts | Integer | Нет | Видимо пользователю | Только для чтения | Количество добавлений
Updates | Integer | Нет | Видимо пользователю | Только для чтения | Количество изменений
Deletes | Integer | Нет | Видимо пользователю | Только для чтения | Количество удалений
Type | string[128] | Нет | Видимо пользователю | Только для чтения | Тип

См. также
  • Класс TClass (Классы)
  • Класс TMethod (Методы)
  • Класс TObject (Объекты)
  • Класс TProfileMethod (Методы профиля)


Класс TProfileUser (Пользователи профиля)

(раздел целиком) (одним файлом)
Класс TProfileUser (Пользователи профиля)

Класс TTypedValue (Типизированные значения)Класс TObject (Объекты)Класс TProfile (Профили)

Объекты класса не именованы.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор пользовательского профиля)
См. также
  • Класс TProfile (Профили)
  • Класс TTypedValue (Типизированные значения)


Свойства

(одним файлом)
Свойства

Свойства класса TProfileUser:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Нет | Скрыто от пользователя | Только для чтения | Унаследовано от TTypedValue
MasterClass | TClass | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TTypedValue
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
StrValue | string[2000] | Нет | Скрыто от пользователя | Чтение/Запись
IntValue | Integer | Нет | Скрыто от пользователя | Чтение/Запись
FloatValue | float | Нет | Скрыто от пользователя | Чтение/Запись
DateValue | date | Нет | Скрыто от пользователя | Чтение/Запись
TimeValue | time | Нет | Скрыто от пользователя | Чтение/Запись
DateTimeValue | datetime | Нет | Скрыто от пользователя | Чтение/Запись
ObjectValue | TObject | Нет | Скрыто от пользователя | Чтение/Запись
BoolValue | Boolean | Нет | Скрыто от пользователя | Чтение/Запись
BlobValue | blob | Нет | Видимо пользователю | Чтение/Запись
ClobValue | clob | Нет | Видимо пользователю | Чтение/Запись
ExternalDataValue | <external data> | Нет | Видимо пользователю | Чтение/Запись
VisibleValue | string[2000] | Нет | Видимо пользователю | Только для чтения
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
UserIsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Пользователь является текущим
Profile | TProfile | Да | Скрыто от пользователя | Только для чтения | Профиль
Domain | TDomain | Да | Скрыто от пользователя | Только для чтения | Домен
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TTypedValue
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TProfile (Профили)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TTypedValue (Типизированные значения)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор пользовательского профиля)

(одним файлом)
Конструктор Create (Конструктор пользовательского профиля)

Конструктор класса TProfileUser.

1constructor TProfileUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TProfile; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;

Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TProfile | Да | Профиль
Accessor | TSecurityAccount | Нет | Унаследовано от TObject.Create
Domain | TDomain | Да | Домен
Position | Integer | Да | Позиция
Group | string[128] | Нет | Группа
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
StrValue | string[2000] | Нет | Унаследовано от TTypedValue.Create
IntValue | Integer | Нет
FloatValue | float | Нет
DateValue | date | Нет
TimeValue | time | Нет
DateTimeValue | datetime | Нет
ObjectValue | TObject | Нет
BoolValue | Boolean | Нет
BlobValue | blob | Нет
ClobValue | clob | Нет
ExternalDataValue | <external data> | Нет
User | TUser | Да | Пользователь

Замечания:

Создает новый объект класса TProfileUser.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TProfile (Профили)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор типизированного значения)
  • Перечисление TScope (Область видимости)


Класс TProperty (Свойства)

(раздел целиком) (одним файлом)
Класс TProperty (Свойства)

Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

Объекты класса образуют иерархию.

  • Свойства
  • Конструктор Create (Конструктор свойства)
  • Метод Change (Изменение объекта)
  • Метод CreateChildren (Создать дочерние свойства)
  • Метод GetNextPos (Следующая позиция)
  • Метод LocalizableFieldName (Получить имя локализуемого поля)
  • Метод LocalizableProperty (Локализуемое свойство)
  • Метод SuggestFileName (Предложить имя файла)
См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)


Свойства

(одним файлом)
Свойства

Свойства класса TProperty:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Видимо пользователю | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
ReadMember | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Член класса для чтения
ReadMemberClass | TClass | Да | Видимо пользователю | Только для чтения | Класс члена класса для чтения
WriteMember | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Член класса для записи
WriteMemberClass | TClass | Да | Видимо пользователю | Только для чтения | Класс члена класса для записи
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Category | string[128] | Нет | Видимо пользователю | Чтение/Запись | Категория
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
IsExportable | Boolean | Да | Видимо пользователю | Чтение/Запись | Для экспорта
IsSuspended | Boolean | Да | Видимо пользователю | Чтение/Запись | Отложенное
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей
IsUnupdatable | Boolean | Да | Видимо пользователю | Чтение/Запись | Необновляемое при импорте
NullHandler | TMethod | Нет | Видимо пользователю | Чтение/Запись | Обработчик пустого значения
OnDemand | Boolean | Да | Видимо пользователю | Чтение/Запись | По требованию

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TMethod (Методы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор свойства)

(одним файлом)
Конструктор Create (Конструктор свойства)

Конструктор класса TProperty.

1constructor TProperty.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ReadMember: TClassMember; WriteMember: TClassMember;
4  Position: Integer; Scope: TScope; IsExportable: Boolean; IsSuspended: Boolean;
5  CreateViewColumns: Boolean; Category: string[128]): TObject;

Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
ReadMember | TClassMember | Нет | Член класса для чтения
WriteMember | TClassMember | Нет | Член класса для записи
Position | Integer | Да | Позиция
Scope | TScope | Да | Область видимости
IsExportable | Boolean | Да | Для экспорта
IsSuspended | Boolean | Да | Отложенное
CreateViewColumns | Boolean | Да | Создать колонку во всех представлениях
Category | string[128] | Нет | Категория

Замечания:

Создает новый объект класса TProperty.

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор члена класса)
  • Перечисление TScope (Область видимости)


Метод Change (Изменение объекта)

(одним файлом)
Метод Change (Изменение объекта)

Метод экземпляра класса TProperty.

procedure TProperty.Change(Action: TChangeAction);

Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Унаследовано от TObject.Change

См. также
  • Метод Change (Изменение объекта)
  • Перечисление TChangeAction (Действие при изменении)


Метод CreateChildren (Создать дочерние свойства)

(одним файлом)
Метод CreateChildren (Создать дочерние свойства)

Метод экземпляра класса TProperty.

1procedure TProperty.CreateChildren(ClearWriteMember: Boolean;
2  PublicOnly: Boolean; ExactName: Boolean);

Параметры:

Имя | Тип | Обязательно | Значение
ClearWriteMember | Boolean | Да | Создавать свойства только для чтения
PublicOnly | Boolean | Да | Создавать только видимые свойства
ExactName | Boolean | Да | Не изменять имя свойства


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TProperty.

class function TProperty.GetNextPos(Master: TObject; Parent: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер
Parent | TObject | Нет | Родитель

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Метод LocalizableFieldName (Получить имя локализуемого поля)

(одним файлом)
Метод LocalizableFieldName (Получить имя локализуемого поля)

Метод класса (статический метод) класса TProperty.

1class function TProperty.LocalizableFieldName(Class: TClass;
2  Name: string[64]): string[64];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Class | TClass | Нет | Класс
Name | string[64] | Да | Имя

Замечания:

Возвращает значение типа string[64].

См. также
  • Класс TClass (Классы)


Метод LocalizableProperty (Локализуемое свойство)

(одним файлом)
Метод LocalizableProperty (Локализуемое свойство)

Метод класса (статический метод) класса TProperty.

1class function TProperty.LocalizableProperty(ClassName: string[64];
2  PropertyName: string[64]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | string[64] | Да | Имя класса
PropertyName | string[64] | Да | Имя свойства

Замечания:

Возвращает значение типа Boolean.


Метод SuggestFileName (Предложить имя файла)

(одним файлом)
Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TProperty.

function TProperty.SuggestFileName(Domain: TDomain): string[128];

Переопределяет метод в TClassMember.SuggestFileName, TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя | Тип | Обязательно | Значение
Domain | TDomain | Нет | Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

См. также
  • Класс TDomain (Домены)
  • Метод SuggestFileName (Предложить имя файла)
  • Метод SuggestFileName (Предложить имя файла)


Класс TPropertyBan (Запрет на свойство)

(раздел целиком) (одним файлом)
Класс TPropertyBan (Запрет на свойство)

Класс TBanGroupItem (Элементы группы запретов)Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор запрета на свойство)
См. также
  • Класс TBanGroup (Группы запретов)
  • Класс TBanGroupItem (Элементы группы запретов)


Свойства

(одним файлом)
Свойства

Свойства класса TPropertyBan:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TBanGroup | Да | Видимо пользователю | Только для чтения | Унаследовано от TBanGroupItem
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
BannedClass | TClass | Да | Видимо пользователю | Только для чтения | Запрещаемый класс
BannedProperty | TProperty | Да | Видимо пользователю | Только для чтения | Запрещаемое свойство
AllowRead | Boolean | Да | Видимо пользователю | Чтение/Запись | Чтение разрешено

См. также
  • Класс TBanGroup (Группы запретов)
  • Класс TBanGroupItem (Элементы группы запретов)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор запрета на свойство)

(одним файлом)
Конструктор Create (Конструктор запрета на свойство)

Конструктор класса TPropertyBan.

1constructor TPropertyBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedProperty: TProperty; AllowRead: Boolean): TObject;

Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
BannedClass | TClass | Да | Запрещаемый класс
BannedProperty | TProperty | Да | Запрещаемое свойство
AllowRead | Boolean | Да | Чтение разрешено

Замечания:

Создает новый объект класса TPropertyBan.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор элемента группы запретов)


Класс TQueue (Очередь)

(раздел целиком) (одним файлом)
Класс TQueue (Очередь)

Диаграмма Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор объекта в очереди)
  • Деструктор Destroy (Деструктор объекта в очереди)
  • Метод Clear (Очистить очередь)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TQueue:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
QueueName | string[64] | Да | Видимо пользователю | Только для чтения | Имя очереди
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время входа в очередь
Object | TObject | Нет | Видимо пользователю | Только для чтения | Объект
ObjectName | string[64] | Да | Видимо пользователю | Только для чтения | Имя объекта
ObjectDescription | string[128] | Да | Видимо пользователю | Только для чтения | Наименование объекта
ObjectClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс объекта
ObjectParent | TObject | Нет | Скрыто от пользователя | Только для чтения | Объект-родитель
ObjectMaster | TObject | Да | Скрыто от пользователя | Только для чтения | Объект-мастер
ObjectSourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | База данных-источник
ObjectOldID | string[38] | Да | Скрыто от пользователя | Только для чтения | Идентификатор объекта при создании
ObjectCreator | TUser | Да | Скрыто от пользователя | Только для чтения | Объект создан пользователем
ObjectCreated | datetime | Да | Скрыто от пользователя | Только для чтения | Объект создан
ObjectModifier | TUser | Да | Скрыто от пользователя | Только для чтения | Объект изменен пользователем
ObjectModified | datetime | Да | Скрыто от пользователя | Только для чтения | Объект изменен
Processed | Boolean | Да | Видимо пользователю | Только для чтения | Обработан

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TUser (Пользователи)


Конструктор Create (Конструктор объекта в очереди)

(одним файлом)
Конструктор Create (Конструктор объекта в очереди)

Конструктор класса TQueue.

constructor TQueue.Create(Object: TObject; QueueName: string[64]): TObject;

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Да | Объект
QueueName | string[64] | Да | Имя очереди

Замечания:

Создает новый объект класса TQueue.

См. также
  • Класс TObject (Объекты)


Деструктор Destroy (Деструктор объекта в очереди)

(одним файлом)
Деструктор Destroy (Деструктор объекта в очереди)

Деструктор класса TQueue.

destructor TQueue.Destroy;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TQueue или его наследника.


Метод Clear (Очистить очередь)

(одним файлом)
Метод Clear (Очистить очередь)

Метод класса (статический метод) класса TQueue.

class procedure TQueue.Clear(QueueName: string[64]);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
QueueName | string[64] | Да | Имя очереди


Класс TRole (Роли)

(раздел целиком) (одним файлом)
Класс TRole (Роли)

Диаграмма Класс TSecurityAccount (Роли безопасности)Класс TObject (Объекты)Класс TRoleMember (Пользователи в ролях)

  • Свойства
  • Конструктор Create (Конструктор роли)
  • Метод GetIsCurrent (Является текущей)
См. также
  • Класс TSecurityAccount (Роли безопасности)


Свойства

(одним файлом)
Свойства

Свойства класса TRole:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
IsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Является текущей

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор роли)

(одним файлом)
Конструктор Create (Конструктор роли)

Конструктор класса TRole.

1constructor TRole.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TRole.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetIsCurrent (Является текущей)

(одним файлом)
Метод GetIsCurrent (Является текущей)

Метод экземпляра класса TRole.

function TRole.GetIsCurrent: Boolean;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Класс TRoleMember (Пользователи в ролях)

(раздел целиком) (одним файлом)
Класс TRoleMember (Пользователи в ролях)

Класс TObject (Объекты)Класс TRole (Роли)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор члена роли)
  • Метод SetIsPrimary (Установка значения свойства "Является основной")
См. также
  • Класс TObject (Объекты)
  • Класс TRole (Роли)


Свойства

(одним файлом)
Свойства

Свойства класса TRoleMember:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
User | TSecurityAccount | Да | Видимо пользователю | Только для чтения | Пользователь
UserClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс члена роли
IsPrimary | Boolean | Да | Видимо пользователю | Чтение/Запись | Основная роль

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TRole (Роли)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор члена роли)

(одним файлом)
Конструктор Create (Конструктор члена роли)

Конструктор класса TRoleMember.

1constructor TRoleMember.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TRole; Accessor: TSecurityAccount;
3  User: TSecurityAccount; IsPrimary: Boolean; AddLinked: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TRole | Да | Роль
Accessor | TSecurityAccount | Нет | Унаследовано от TObject.Create
User | TSecurityAccount | Да | Пользователь
IsPrimary | Boolean | Да | Основная роль
AddLinked | Boolean | Да | Добавить связанные роли

Замечания:

Создает новый объект класса TRoleMember.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TRole (Роли)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод SetIsPrimary (Установка значения свойства "Является основной")

(одним файлом)
Метод SetIsPrimary (Установка значения свойства "Является основной")

Метод экземпляра класса TRoleMember.

procedure TRoleMember.SetIsPrimary(Value: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение


Класс TRoutine (Подпрограмма)

(раздел целиком) (одним файлом)
Класс TRoutine (Подпрограмма)

Диаграмма Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)Класс TParameter (Параметры)Класс TCommandButton (Командные кнопки)Класс TParametersFormView (Представления формы параметров)

  • Свойства
  • Конструктор Create (Конструктор подпрограммы)
  • Метод CreateContextKey (Создать ключ контекстной помощи)
  • Метод GetParamCount (Количество параметров)
  • Метод ListParameters (Список параметров)
  • Метод ParameterByName (Получить параметр по имени)
  • Метод Ole-объекта CreateReportTemplate (Сгенерировать шаблон отчета)
См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)


Свойства

(одним файлом)
Свойства

Свойства класса TRoutine:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Домен результата
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс домена результата
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена результата
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись | Является методом класса
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись | Текст подтверждения
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись | Использовать закладки
Script | clob | Нет | Видимо пользователю | Чтение/Запись | Скрипт формы параметров
Image | blob | Нет | Видимо пользователю | Чтение/Запись | Изображение-иконка
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество параметров
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись | Протоколировать
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись | Сообщение о выполнении
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись | Вызывать только для одного объекта
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор подпрограммы)

(одним файлом)
Конструктор Create (Конструктор подпрограммы)

Конструктор класса TRoutine.

1constructor TRoutine.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean): TObject;

Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Является методом класса
SingleObject | Boolean | Да | Вызывать только для одного объекта
Domain | TDomain | Нет | Домен результата
Scope | TScope | Да | Область видимости
Confirmation | string[512] | Нет | Текст подтверждения
ReportMessage | string[512] | Нет | Сообщение о выполнении
UseTabs | Boolean | Да | Использовать закладки
Script | clob | Нет | Скрипт формы параметров
Image | blob | Нет | Изображение-иконка
Logged | Boolean | Да | Протоколировать

Замечания:

Создает новый объект класса TRoutine.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор члена класса)
  • Перечисление TScope (Область видимости)


Метод CreateContextKey (Создать ключ контекстной помощи)

(одним файлом)
Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TRoutine.

procedure TRoutine.CreateContextKey(Storage: string[64]);

Параметры:

Имя | Тип | Обязательно | Значение
Storage | string[64] | Да | Хранилище


Метод GetParamCount (Количество параметров)

(одним файлом)
Метод GetParamCount (Количество параметров)

Метод экземпляра класса TRoutine.

function TRoutine.GetParamCount: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод ListParameters (Список параметров)

(одним файлом)
Метод ListParameters (Список параметров)

Метод экземпляра класса TRoutine.

function TRoutine.ListParameters: TObjectList;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.

См. также
  • Класс TObjectList (Списки)


Метод ParameterByName (Получить параметр по имени)

(одним файлом)
Метод ParameterByName (Получить параметр по имени)

Метод экземпляра класса TRoutine.

function TRoutine.ParameterByName(AName: string[64]): TParameter;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
AName | string[64] | Да | Имя

Замечания:

Возвращает значение типа TParameter.

См. также
  • Класс TParameter (Параметры)


Метод Ole-объекта CreateReportTemplate (Сгенерировать шаблон отчета)

(одним файлом)
Метод Ole-объекта CreateReportTemplate (Сгенерировать шаблон отчета)

Метод Ole-объекта класса TRoutine.

Метод Ole-объекта не имеет параметров.


Класс TRoutineAction (Программируемое действие)

(раздел целиком) (одним файлом)
Класс TRoutineAction (Программируемое действие)

Класс TAction (Действия)Класс TObject (Объекты)Класс TCustomView (Абстрактное представление)

Объекты класса образуют иерархию.

  • Свойства
  • Конструктор Create (Конструктор программируемого действия)
  • Метод EnsureAction (Обеспечить наличие действия)
См. также
  • Класс TAction (Действия)
  • Класс TCustomView (Абстрактное представление)


Свойства

(одним файлом)
Свойства

Свойства класса TRoutineAction:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Shortcut | string[20] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TAction
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Separated | Boolean | Да | Видимо пользователю | Чтение/Запись
Default | Boolean | Да | Видимо пользователю | Чтение/Запись
Routine | TRoutine | Да | Видимо пользователю | Чтение/Запись | Подпрограмма
ContextProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Выполнять в контексте свойства
AllowNavigation | Boolean | Да | Видимо пользователю | Чтение/Запись | Доступна навигация

См. также
  • Класс TAction (Действия)
  • Класс TClass (Классы)
  • Класс TCustomView (Абстрактное представление)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор программируемого действия)

(одним файлом)
Конструктор Create (Конструктор программируемого действия)

Конструктор класса TRoutineAction.

1constructor TRoutineAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  Routine: TRoutine; ContextProperty: TProperty;
5  AllowNavigation: Boolean): TObject;

Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TAction.Create
Shortcut | string[20] | Нет
Separated | Boolean | Да
Default | Boolean | Да
Routine | TRoutine | Да | Реализовано посредством
ContextProperty | TProperty | Нет | выполнять в контексте
AllowNavigation | Boolean | Да | Доступна навигация

Замечания:

Создает новый объект класса TRoutineAction.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор действия)
  • Конструктор Create (Конструктор объекта)


Метод EnsureAction (Обеспечить наличие действия)

(одним файлом)
Метод EnsureAction (Обеспечить наличие действия)

Метод класса (статический метод) класса TRoutineAction.

1class function TRoutineAction.EnsureAction(AView: TObject; AName: string[64];
2  ADescription: string[128]; APosition: Integer; AShortcut: string[20];
3  ASeparated: Boolean; ARoutine: TRoutine): TObject;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AView | TObject | Да | Мастер
AName | string[64] | Да | Имя
ADescription | string[128] | Да | Наименование
APosition | Integer | Да | Позиция
AShortcut | string[20] | Нет | Горячая клавиша
ASeparated | Boolean | Да | Отделено
ARoutine | TRoutine | Да | Реализовано посредством

Замечания:

Возвращает значение типа TObject.

См. также
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)


Класс TRoutineBan (Запрет на подпрограмму)

(раздел целиком) (одним файлом)
Класс TRoutineBan (Запрет на подпрограмму)

Класс TBanGroupItem (Элементы группы запретов)Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор запрета на подпрограмму)
См. также
  • Класс TBanGroup (Группы запретов)
  • Класс TBanGroupItem (Элементы группы запретов)


Свойства

(одним файлом)
Свойства

Свойства класса TRoutineBan:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TBanGroup | Да | Видимо пользователю | Только для чтения | Унаследовано от TBanGroupItem
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
BannedClass | TClass | Да | Видимо пользователю | Только для чтения | Запрещаемый класс
BannedRoutine | TRoutine | Да | Видимо пользователю | Только для чтения | Запрещаемая подпрограмма

См. также
  • Класс TBanGroup (Группы запретов)
  • Класс TBanGroupItem (Элементы группы запретов)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор запрета на подпрограмму)

(одним файлом)
Конструктор Create (Конструктор запрета на подпрограмму)

Конструктор класса TRoutineBan.

1constructor TRoutineBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedRoutine: TRoutine): TObject;

Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
BannedClass | TClass | Да | Запрещаемый класс
BannedRoutine | TRoutine | Да | Запрещаемая подпрограмма

Замечания:

Создает новый объект класса TRoutineBan.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор элемента группы запретов)


Класс TRoutineHistory (Вызовы)

(раздел целиком) (одним файлом)
Класс TRoutineHistory (Вызовы)

Диаграмма Класс TParameterHistory (Параметры вызовов)

  • Свойства
  • Метод Clear (Очистить историю)
  • Метод Log (Создать запись протокола)
  • Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)


Свойства

(одним файлом)
Свойства

Свойства класса TRoutineHistory:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Session | TSessionHistory | Нет | Скрыто от пользователя | Только для чтения | Сессия
SessionTimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время начала сессии
SessionCloseStamp | datetime | Нет | Видимо пользователю | Только для чтения | Время завершения сессии
IntStamp | Integer | Нет | Видимо пользователю | Только для чтения | Целочисленный номер
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время
ObjectID | string[38] | Нет | Видимо пользователю | Только для чтения | Идентификатор объекта
ObjectQualifiedName | string[2000] | Нет | Видимо пользователю | Только для чтения | Квалифицированное имя объекта
ObjectDataBase | TDataBase | Нет | Видимо пользователю | Только для чтения | База данных объекта
ObjectOldID | string[38] | Нет | Видимо пользователю | Только для чтения | Идентификатор при создании
RoutineName | string[64] | Да | Видимо пользователю | Только для чтения | Подпрограмма
RoutineClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс подпрограммы
RoutineClassName | string[64] | Да | Видимо пользователю | Только для чтения | Имя класса подпрограммы
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
Login | string[64] | Да | Видимо пользователю | Только для чтения | Логин
UserAgent | string[2000] | Нет | Видимо пользователю | Только для чтения | Пользовательский агент
IPAddress | string[16] | Нет | Видимо пользователю | Только для чтения | IP-адрес
ConnectionInfo | string[2000] | Нет | Видимо пользователю | Только для чтения | Информация о соединении

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TSessionHistory (Сессии)
  • Класс TUser (Пользователи)


Метод Clear (Очистить историю)

(одним файлом)
Метод Clear (Очистить историю)

Метод класса (статический метод) класса TRoutineHistory.

1class procedure TRoutineHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Метод Log (Создать запись протокола)

(одним файлом)
Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TRoutineHistory.

1class function TRoutineHistory.Log(Routine: TRoutine;
2  Object: TObject): TRoutineHistory;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Routine | TRoutine | Да | Подпрограмма
Object | TObject | Нет | Объект

Замечания:

Возвращает значение типа TRoutineHistory.

См. также
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)


Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

(одним файлом)
Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TRoutineHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
FileName | string[255] | Да | Имя файла
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Класс TSecurityAccount (Роли безопасности)

(одним файлом)
Класс TSecurityAccount (Роли безопасности)

Диаграмма Класс TObject (Объекты)

См. также
  • Класс TObject (Объекты)


Класс TSequence (Последовательности)

(раздел целиком) (одним файлом)
Класс TSequence (Последовательности)

Диаграмма Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор последовательности)
  • Метод GetCache (Получить кеш)
  • Метод GetValue (Получить текущее значение)
  • Метод Promote (Получить следующее значение)
  • Метод SetCache (Установить кеш)
  • Метод SetValue (Установить текущее значение)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TSequence:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Value | string[20] | Да | Видимо пользователю | Чтение/Запись | Текущее значение
Cache | Integer | Нет | Видимо пользователю | Чтение/Запись | Кэш

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор последовательности)

(одним файлом)
Конструктор Create (Конструктор последовательности)

Конструктор класса TSequence.

1constructor TSequence.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TSequence.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetCache (Получить кеш)

(одним файлом)
Метод GetCache (Получить кеш)

Метод экземпляра класса TSequence.

function TSequence.GetCache: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод GetValue (Получить текущее значение)

(одним файлом)
Метод GetValue (Получить текущее значение)

Метод экземпляра класса TSequence.

function TSequence.GetValue: string[20];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].


Метод Promote (Получить следующее значение)

(одним файлом)
Метод Promote (Получить следующее значение)

Метод экземпляра класса TSequence.

function TSequence.Promote: string[20];

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].


Метод SetCache (Установить кеш)

(одним файлом)
Метод SetCache (Установить кеш)

Метод экземпляра класса TSequence.

procedure TSequence.SetCache(Value: Integer);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Integer | Нет | Значение


Метод SetValue (Установить текущее значение)

(одним файлом)
Метод SetValue (Установить текущее значение)

Метод экземпляра класса TSequence.

procedure TSequence.SetValue(Value: string[20]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[20] | Да | Значение


Класс TSessionHistory (Сессии)

(раздел целиком) (одним файлом)
Класс TSessionHistory (Сессии)

Диаграмма

  • Свойства
  • Метод Clear (Очистить историю)
  • Метод DBMSConnectionInfo (Информация о соединении от СУБД)
  • Метод DBMSGetIPAddress (IP-адрес клиента от СУБД)
  • Метод DBMSGetUserAgent (Пользовательский агент от СУБД)
  • Метод GetCurrentSession (Идентификатор текущей сессии)
  • Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)


Свойства

(одним файлом)
Свойства

Свойства класса TSessionHistory:

Имя | Тип | Обязательно | Доступ | Назначение
IntStamp | Integer | Нет | Только для чтения | Целочисленный номер
TimeStamp | datetime | Да | Только для чтения | Время
User | TUser | Нет | Только для чтения | Пользователь
Login | string[64] | Да | Только для чтения | Логин
CloseStamp | datetime | Нет | Только для чтения | Время закрытия
UserAgent | string[2000] | Нет | Только для чтения | Пользовательский агент
IPAddress | string[16] | Нет | Только для чтения | IP-адрес
ConnectionInfo | string[2000] | Нет | Только для чтения | Информация о соединении
Duration | time | Нет | Только для чтения | Продолжительность

См. также
  • Класс TUser (Пользователи)


Метод Clear (Очистить историю)

(одним файлом)
Метод Clear (Очистить историю)

Метод класса (статический метод) класса TSessionHistory.

1class procedure TSessionHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Метод DBMSConnectionInfo (Информация о соединении от СУБД)

(одним файлом)
Метод DBMSConnectionInfo (Информация о соединении от СУБД)

Метод класса (статический метод) класса TSessionHistory.

class function TSessionHistory.DBMSConnectionInfo: string[2000];

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод DBMSGetIPAddress (IP-адрес клиента от СУБД)

(одним файлом)
Метод DBMSGetIPAddress (IP-адрес клиента от СУБД)

Метод класса (статический метод) класса TSessionHistory.

class function TSessionHistory.DBMSGetIPAddress: string[16];

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[16].


Метод DBMSGetUserAgent (Пользовательский агент от СУБД)

(одним файлом)
Метод DBMSGetUserAgent (Пользовательский агент от СУБД)

Метод класса (статический метод) класса TSessionHistory.

class function TSessionHistory.DBMSGetUserAgent: string[2000];

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод GetCurrentSession (Идентификатор текущей сессии)

(одним файлом)
Метод GetCurrentSession (Идентификатор текущей сессии)

Метод класса (статический метод) класса TSessionHistory.

class function TSessionHistory.GetCurrentSession: TSessionHistory;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TSessionHistory.


Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

(одним файлом)
Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TSessionHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
FileName | string[255] | Да | Имя файла
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Класс TStatement (Операторы)

(раздел целиком) (одним файлом)
Класс TStatement (Операторы)

Диаграмма

  • Конструктор Create (Конструктор оператора)
  • Метод BoolLiteral (Логический литерал)
  • Метод BuildFunctionCall (Построить вызов функции)
  • Метод BuildInsertStatement (Построить скрипт добавления объекта)
  • Метод BuildProcedureCall (Построить вызов процедуры)
  • Метод BuildUpdateStatement (Построить скрипт изменения объекта)
  • Метод Change (Изменение объекта)
  • Метод DateLiteral (Литерал типа "дата")
  • Метод DateTimeLiteral (Литерал типа "дата со временем")
  • Метод Execute (Выполнить)
  • Метод ExecuteClob (Выполнить большой текстовый объект)
  • Метод ExecuteClobToBlobValue (Выполнить большой текстовый объект и вернуть значение-большой объект)
  • Метод ExecuteClobToBoolValue (Выполнить большой текстовый объект и вернуть логическое значение)
  • Метод ExecuteClobToClobValue (Выполнить большой текстовый объект и вернуть значение-большой текст)
  • Метод ExecuteClobToDateTimeValue (Выполнить большой текстовый объект и вернуть значение даты со временем)
  • Метод ExecuteClobToDateValue (Выполнить большой текстовый объект и вернуть значение даты)
  • Метод ExecuteClobToExternalDataValue (Выполнить большой текстовый объект и вернуть значение внешних данных)
  • Метод ExecuteClobToFloatValue (Выполнить большой текстовый объект и вернуть вещественное значение)
  • Метод ExecuteClobToIntValue (Выполнить большой текстовый объект и вернуть целое значение)
  • Метод ExecuteClobToObjectValue (Выполнить большой текстовый объект и вернуть значение-объект)
  • Метод ExecuteClobToStrValue (Выполнить большой текстовый объект и вернуть строковое значение)
  • Метод ExecuteClobToTimeValue (Выполнить большой текстовый объект и вернуть значение времени)
  • Метод ExecuteToBlobValue (Выполнить и вернуть значение-большой объект)
  • Метод ExecuteToBoolValue (Выполнить и вернуть логическое значение)
  • Метод ExecuteToClobValue (Выполнить и вернуть значение-большой текст)
  • Метод ExecuteToDateTimeValue (Выполнить и вернуть значение даты со временем)
  • Метод ExecuteToDateValue (Выполнить и вернуть значение даты)
  • Метод ExecuteToExternalDataValue (Выполнить и вернуть значение внешних данных)
  • Метод ExecuteToFloatValue (Выполнить и вернуть вещественное значение)
  • Метод ExecuteToIntValue (Выполнить и вернуть целое значение)
  • Метод ExecuteToObjectValue (Выполнить и вернуть значение-объект)
  • Метод ExecuteToStrValue (Выполнить и вернуть строковое значение)
  • Метод ExecuteToTimeValue (Выполнить и вернуть значение времени)
  • Метод FloatLiteral (Вещественный литерал)
  • Метод IntLiteral (Целочисленный литерал)
  • Метод ObjectLiteral (Литерал-объект)
  • Метод QualifyDBMSName (Квалифицировать имя объекта БД)
  • Метод SequenceLiteral (Литерал значения последовательности)
  • Метод StringAggregate (Агрегировать строки запроса)
  • Метод StringLiteral (Строковый литерал)
  • Метод TimeLiteral (Литерал типа "время")
  • Метод ToString (Приведение литерала к строке)


Конструктор Create (Конструктор оператора)

(одним файлом)
Конструктор Create (Конструктор оператора)

Конструктор класса TStatement.

constructor TStatement.Create: TObject;

Метод не имеет параметров.

Замечания:

Создает новый объект класса TStatement.


Метод BoolLiteral (Логический литерал)

(одним файлом)
Метод BoolLiteral (Логический литерал)

Метод класса (статический метод) класса TStatement.

class function TStatement.BoolLiteral(Value: Boolean): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение

Замечания:

Возвращает значение типа string[2000].


Метод BuildFunctionCall (Построить вызов функции)

(одним файлом)
Метод BuildFunctionCall (Построить вызов функции)

Метод класса (статический метод) класса TStatement.

1class function TStatement.BuildFunctionCall(Function: TMethod;
2  Parameters: string[2000]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Function | TMethod | Нет | Функция
Parameters | string[2000] | Нет | Параметры вызова

Замечания:

Возвращает значение типа string[2000].

См. также
  • Класс TMethod (Методы)


Метод BuildInsertStatement (Построить скрипт добавления объекта)

(одним файлом)
Метод BuildInsertStatement (Построить скрипт добавления объекта)

Метод класса (статический метод) класса TStatement.

1class function TStatement.BuildInsertStatement(AObject: TObject;
2  AClass: TClass): clob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AObject | TObject | Да | Объект
AClass | TClass | Нет | Класс

Замечания:

Возвращает значение типа clob.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)


Метод BuildProcedureCall (Построить вызов процедуры)

(одним файлом)
Метод BuildProcedureCall (Построить вызов процедуры)

Метод класса (статический метод) класса TStatement.

1class function TStatement.BuildProcedureCall(Procedure: TMethod;
2  Parameters: string[2000]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Procedure | TMethod | Нет | Процедура
Parameters | string[2000] | Нет | Параметры вызова

Замечания:

Возвращает значение типа string[2000].

См. также
  • Класс TMethod (Методы)


Метод BuildUpdateStatement (Построить скрипт изменения объекта)

(одним файлом)
Метод BuildUpdateStatement (Построить скрипт изменения объекта)

Метод класса (статический метод) класса TStatement.

1class function TStatement.BuildUpdateStatement(AObject: TObject;
2  AClass: TClass): clob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AObject | TObject | Да | Объект
AClass | TClass | Нет | Класс

Замечания:

Возвращает значение типа clob.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)


Метод Change (Изменение объекта)

(одним файлом)
Метод Change (Изменение объекта)

Метод экземпляра класса TStatement.

procedure TStatement.Change(Action: TChangeAction);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Действие

См. также
  • Перечисление TChangeAction (Действие при изменении)


Метод DateLiteral (Литерал типа "дата")

(одним файлом)
Метод DateLiteral (Литерал типа "дата")

Метод класса (статический метод) класса TStatement.

class function TStatement.DateLiteral(Value: date): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | date | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод DateTimeLiteral (Литерал типа "дата со временем")

(одним файлом)
Метод DateTimeLiteral (Литерал типа "дата со временем")

Метод класса (статический метод) класса TStatement.

class function TStatement.DateTimeLiteral(Value: datetime): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод Execute (Выполнить)

(одним файлом)
Метод Execute (Выполнить)

Метод класса (статический метод) класса TStatement.

class procedure TStatement.Execute(Statement: string[2000]);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор


Метод ExecuteClob (Выполнить большой текстовый объект)

(одним файлом)
Метод ExecuteClob (Выполнить большой текстовый объект)

Метод класса (статический метод) класса TStatement.

class procedure TStatement.ExecuteClob(Statement: clob);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор


Метод ExecuteClobToBlobValue (Выполнить большой текстовый объект и вернуть значение-большой объект)

(одним файлом)
Метод ExecuteClobToBlobValue (Выполнить большой текстовый объект и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToBlobValue(Statement: clob): blob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа blob.


Метод ExecuteClobToBoolValue (Выполнить большой текстовый объект и вернуть логическое значение)

(одним файлом)
Метод ExecuteClobToBoolValue (Выполнить большой текстовый объект и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToBoolValue(Statement: clob): Boolean;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа Boolean.


Метод ExecuteClobToClobValue (Выполнить большой текстовый объект и вернуть значение-большой текст)

(одним файлом)
Метод ExecuteClobToClobValue (Выполнить большой текстовый объект и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToClobValue(Statement: clob): clob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа clob.


Метод ExecuteClobToDateTimeValue (Выполнить большой текстовый объект и вернуть значение даты со временем)

(одним файлом)
Метод ExecuteClobToDateTimeValue (Выполнить большой текстовый объект и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToDateTimeValue(Statement: clob): datetime;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа datetime.


Метод ExecuteClobToDateValue (Выполнить большой текстовый объект и вернуть значение даты)

(одним файлом)
Метод ExecuteClobToDateValue (Выполнить большой текстовый объект и вернуть значение даты)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToDateValue(Statement: clob): date;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа date.


Метод ExecuteClobToExternalDataValue (Выполнить большой текстовый объект и вернуть значение внешних данных)

(одним файлом)
Метод ExecuteClobToExternalDataValue (Выполнить большой текстовый объект и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.

1class function TStatement.ExecuteClobToExternalDataValue(Statement: clob): <external
2  data>;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа <external data>.


Метод ExecuteClobToFloatValue (Выполнить большой текстовый объект и вернуть вещественное значение)

(одним файлом)
Метод ExecuteClobToFloatValue (Выполнить большой текстовый объект и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToFloatValue(Statement: clob): float;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа float.


Метод ExecuteClobToIntValue (Выполнить большой текстовый объект и вернуть целое значение)

(одним файлом)
Метод ExecuteClobToIntValue (Выполнить большой текстовый объект и вернуть целое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToIntValue(Statement: clob): Integer;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа Integer.


Метод ExecuteClobToObjectValue (Выполнить большой текстовый объект и вернуть значение-объект)

(одним файлом)
Метод ExecuteClobToObjectValue (Выполнить большой текстовый объект и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToObjectValue(Statement: clob): TObject;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа TObject.

См. также
  • Класс TObject (Объекты)


Метод ExecuteClobToStrValue (Выполнить большой текстовый объект и вернуть строковое значение)

(одним файлом)
Метод ExecuteClobToStrValue (Выполнить большой текстовый объект и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToStrValue(Statement: clob): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа string[2000].


Метод ExecuteClobToTimeValue (Выполнить большой текстовый объект и вернуть значение времени)

(одним файлом)
Метод ExecuteClobToTimeValue (Выполнить большой текстовый объект и вернуть значение времени)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToTimeValue(Statement: clob): time;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа time.


Метод ExecuteToBlobValue (Выполнить и вернуть значение-большой объект)

(одним файлом)
Метод ExecuteToBlobValue (Выполнить и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToBlobValue(Statement: string[2000]): blob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа blob.


Метод ExecuteToBoolValue (Выполнить и вернуть логическое значение)

(одним файлом)
Метод ExecuteToBoolValue (Выполнить и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToBoolValue(Statement: string[2000]): Boolean;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа Boolean.


Метод ExecuteToClobValue (Выполнить и вернуть значение-большой текст)

(одним файлом)
Метод ExecuteToClobValue (Выполнить и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToClobValue(Statement: string[2000]): clob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа clob.


Метод ExecuteToDateTimeValue (Выполнить и вернуть значение даты со временем)

(одним файлом)
Метод ExecuteToDateTimeValue (Выполнить и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToDateTimeValue(Statement: string[2000]): datetime;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа datetime.


Метод ExecuteToDateValue (Выполнить и вернуть значение даты)

(одним файлом)
Метод ExecuteToDateValue (Выполнить и вернуть значение даты)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToDateValue(Statement: string[2000]): date;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа date.


Метод ExecuteToExternalDataValue (Выполнить и вернуть значение внешних данных)

(одним файлом)
Метод ExecuteToExternalDataValue (Выполнить и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.

1class function TStatement.ExecuteToExternalDataValue(Statement: string[2000]): <external
2  data>;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа <external data>.


Метод ExecuteToFloatValue (Выполнить и вернуть вещественное значение)

(одним файлом)
Метод ExecuteToFloatValue (Выполнить и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToFloatValue(Statement: string[2000]): float;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа float.


Метод ExecuteToIntValue (Выполнить и вернуть целое значение)

(одним файлом)
Метод ExecuteToIntValue (Выполнить и вернуть целое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToIntValue(Statement: string[2000]): Integer;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа Integer.


Метод ExecuteToObjectValue (Выполнить и вернуть значение-объект)

(одним файлом)
Метод ExecuteToObjectValue (Выполнить и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToObjectValue(Statement: string[2000]): TObject;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа TObject.

См. также
  • Класс TObject (Объекты)


Метод ExecuteToStrValue (Выполнить и вернуть строковое значение)

(одним файлом)
Метод ExecuteToStrValue (Выполнить и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToStrValue(Statement: string[2000]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа string[2000].


Метод ExecuteToTimeValue (Выполнить и вернуть значение времени)

(одним файлом)
Метод ExecuteToTimeValue (Выполнить и вернуть значение времени)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToTimeValue(Statement: string[2000]): time;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа time.


Метод FloatLiteral (Вещественный литерал)

(одним файлом)
Метод FloatLiteral (Вещественный литерал)

Метод класса (статический метод) класса TStatement.

class function TStatement.FloatLiteral(Value: float): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | float | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод IntLiteral (Целочисленный литерал)

(одним файлом)
Метод IntLiteral (Целочисленный литерал)

Метод класса (статический метод) класса TStatement.

class function TStatement.IntLiteral(Value: Integer): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Integer | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод ObjectLiteral (Литерал-объект)

(одним файлом)
Метод ObjectLiteral (Литерал-объект)

Метод класса (статический метод) класса TStatement.

class function TStatement.ObjectLiteral(Value: TObject): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

См. также
  • Класс TObject (Объекты)


Метод QualifyDBMSName (Квалифицировать имя объекта БД)

(одним файлом)
Метод QualifyDBMSName (Квалифицировать имя объекта БД)

Метод класса (статический метод) класса TStatement.

class function TStatement.QualifyDBMSName(DBMSName: string[2000]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
DBMSName | string[2000] | Нет | Имя объекта БД

Замечания:

Возвращает значение типа string[2000].


Метод SequenceLiteral (Литерал значения последовательности)

(одним файлом)
Метод SequenceLiteral (Литерал значения последовательности)

Метод класса (статический метод) класса TStatement.

class function TStatement.SequenceLiteral(SequenceName: string[64]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
SequenceName | string[64] | Да | Имя последовательности

Замечания:

Возвращает значение типа string[2000].


Метод StringAggregate (Агрегировать строки запроса)

(одним файлом)
Метод StringAggregate (Агрегировать строки запроса)

Метод класса (статический метод) класса TStatement.

1class function TStatement.StringAggregate(Statement: string[2000];
2  Delimiter: string[2000]): clob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор
Delimiter | string[2000] | Нет | Разделитель

Замечания:

Возвращает значение типа clob.


Метод StringLiteral (Строковый литерал)

(одним файлом)
Метод StringLiteral (Строковый литерал)

Метод класса (статический метод) класса TStatement.

class function TStatement.StringLiteral(Value: string[2000]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод TimeLiteral (Литерал типа "время")

(одним файлом)
Метод TimeLiteral (Литерал типа "время")

Метод класса (статический метод) класса TStatement.

class function TStatement.TimeLiteral(Value: time): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | time | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод ToString (Приведение литерала к строке)

(одним файлом)
Метод ToString (Приведение литерала к строке)

Метод класса (статический метод) класса TStatement.

1class function TStatement.ToString(Literal: string[2000]; Domain: TDomain;
2  CanUseTables: Boolean): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Literal | string[2000] | Нет | Литерал
Domain | TDomain | Нет | Домен
CanUseTables | Boolean | Да | Использовать таблицы

Замечания:

Возвращает значение типа string[2000].

См. также
  • Класс TDomain (Домены)


Класс TStringBuilder (Шаблоны строк)

(раздел целиком) (одним файлом)
Класс TStringBuilder (Шаблоны строк)

Диаграмма

  • Свойства
  • Конструктор Create (Конструктор шаблона строк)
  • Метод Append (Добавить строку)
  • Метод AppendToClob (Добавить строку к большому текстовому объекту)
  • Метод Apply (Применить значение)
  • Метод ApplyClob (Применить значение - большой текстовый объект)
  • Метод ApplyObject (Применить свойства объекта)
  • Метод Build (Построить строку)
  • Метод BuildClob (Построить большой текстовый объект)
  • Метод ClearAll (Очистить все шаблоны строк)
  • Метод ClobApply (Применить значение к большому текстовому объекту)
  • Метод DebugTemplate (Отладить шаблон)
  • Метод StrApply (Применить значение к строке)


Свойства

(одним файлом)
Свойства

Свойства класса TStringBuilder:

Имя | Тип | Обязательно | Доступ | Назначение
Template | string[2000] | Нет | Чтение/Запись | Шаблон
TemplateClob | clob | Нет | Чтение/Запись | Шаблон - большой текстовый объект


Конструктор Create (Конструктор шаблона строк)

(одним файлом)
Конструктор Create (Конструктор шаблона строк)

Конструктор класса TStringBuilder.

1constructor TStringBuilder.Create(Template: string[2000];
2  TemplateClob: clob): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Template | string[2000] | Нет | Шаблон
TemplateClob | clob | Нет | Шаблон - большой текстовый объект

Замечания:

Создает новый объект класса TStringBuilder.


Метод Append (Добавить строку)

(одним файлом)
Метод Append (Добавить строку)

Метод экземпляра класса TStringBuilder.

1function TStringBuilder.Append(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Delimiter | string[2000] | Нет | Разделитель

Замечания:

Возвращает значение типа TStringBuilder.


Метод AppendToClob (Добавить строку к большому текстовому объекту)

(одним файлом)
Метод AppendToClob (Добавить строку к большому текстовому объекту)

Метод экземпляра класса TStringBuilder.

1function TStringBuilder.AppendToClob(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Delimiter | string[2000] | Нет | Разделитель

Замечания:

Возвращает значение типа TStringBuilder.


Метод Apply (Применить значение)

(одним файлом)
Метод Apply (Применить значение)

Метод экземпляра класса TStringBuilder.

1function TStringBuilder.Apply(Name: string[2000];
2  Value: string[2000]): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[2000] | Нет | Имя
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа TStringBuilder.


Метод ApplyClob (Применить значение - большой текстовый объект)

(одним файлом)
Метод ApplyClob (Применить значение - большой текстовый объект)

Метод экземпляра класса TStringBuilder.

1function TStringBuilder.ApplyClob(Name: string[2000];
2  Value: clob): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[2000] | Нет | Имя
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа TStringBuilder.


Метод ApplyObject (Применить свойства объекта)

(одним файлом)
Метод ApplyObject (Применить свойства объекта)

Метод экземпляра класса TStringBuilder.

function TStringBuilder.ApplyObject(Object: TObject): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Нет | Объект

Замечания:

Возвращает значение типа TStringBuilder.

См. также
  • Класс TObject (Объекты)


Метод Build (Построить строку)

(одним файлом)
Метод Build (Построить строку)

Метод экземпляра класса TStringBuilder.

function TStringBuilder.Build: string[2000];

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод BuildClob (Построить большой текстовый объект)

(одним файлом)
Метод BuildClob (Построить большой текстовый объект)

Метод экземпляра класса TStringBuilder.

function TStringBuilder.BuildClob: clob;

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.


Метод ClearAll (Очистить все шаблоны строк)

(одним файлом)
Метод ClearAll (Очистить все шаблоны строк)

Метод класса (статический метод) класса TStringBuilder.

class procedure TStringBuilder.ClearAll;

Метод является методом класса.

Метод не имеет параметров.


Метод ClobApply (Применить значение к большому текстовому объекту)

(одним файлом)
Метод ClobApply (Применить значение к большому текстовому объекту)

Метод класса (статический метод) класса TStringBuilder.

1class function TStringBuilder.ClobApply(Template: clob; Name: string[2000];
2  Value: string[2000]): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Template | clob | Нет | Шаблон
Name | string[2000] | Нет | Имя
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа clob.


Метод DebugTemplate (Отладить шаблон)

(одним файлом)
Метод DebugTemplate (Отладить шаблон)

Метод класса (статический метод) класса TStringBuilder.

1class procedure TStringBuilder.DebugTemplate(Template: clob; Names: clob;
2  ApplyResult: clob);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Template | clob | Нет | Шаблон
Names | clob | Нет | Имена
ApplyResult | clob | Нет | Результат применения


Метод StrApply (Применить значение к строке)

(одним файлом)
Метод StrApply (Применить значение к строке)

Метод класса (статический метод) класса TStringBuilder.

1class function TStringBuilder.StrApply(Template: string[2000];
2  Name: string[2000]; Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Template | string[2000] | Нет | Шаблон
Name | string[2000] | Нет | Имя
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Класс TStringDomain (Строковые)

(раздел целиком) (одним файлом)
Класс TStringDomain (Строковые)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор строкового домена)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TDomain (Домены)


Свойства

(одним файлом)
Свойства

Свойства класса TStringDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
Length | Integer | Да | Видимо пользователю | Чтение/Запись | Длина
AllowLeadingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись | Допустимы начальные пробелы
AllowTrailingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись | Допустимы конечные пробелы
AllowSpaceDuplication | Boolean | Да | Видимо пользователю | Чтение/Запись | Допустимо дублирование пробелов
CharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Набор символов
FirstCharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Набор символов первого символа
CaseMode | Boolean | Нет | Видимо пользователю | Чтение/Запись | Режим регистра
Mask | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Маска
CaseInsensitiveSearch | Boolean | Да | Видимо пользователю | Чтение/Запись | Регистронезависимый поиск

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор строкового домена)

(одним файлом)
Конструктор Create (Конструктор строкового домена)

Конструктор класса TStringDomain.

1constructor TStringDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean): TDomain;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
Length | Integer | Да | Максимальная длина
AllowLeadingSpaces | Boolean | Да | Допустимы начальные пробелы
AllowTrailingSpaces | Boolean | Да | Допустимы конечные пробелы
AllowSpaceDuplication | Boolean | Да | Допустимо дублирование пробелов
CharacterSet | string[2000] | Нет | Набор символов
FirstCharacterSet | string[2000] | Нет | Набор символов первого символа
CaseMode | Boolean | Нет | Режим регистра
Mask | string[2000] | Нет | Маска
CaseInsensitiveSearch | Boolean | Да | Регистронезависимый поиск

Замечания:

Создает новый объект класса TStringDomain.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TStringDomain.

function TStringDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)


Класс TStringList (Список строк)

(раздел целиком) (одним файлом)
Класс TStringList (Список строк)

Класс TObject (Объекты)Класс TStringListItem (Элемент списка строк)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор списка строк)
  • Метод Add (Добавить строку в список)
  • Метод Archive (Отправить список в архив)
  • Метод Clear (Очистить список)
  • Метод ClobField (Поле в составе большого текстового объекта)
  • Метод ClobFieldCount (Количество полей в составе большого текстового объекта)
  • Метод ClobFieldIndexOf (Индекс вхождения в состав большого текстового объекта)
  • Метод Delete (Удалить элемент из списка по индексу)
  • Метод GetDelimitedText (Получить в виде разделенного текста)
  • Метод GetDelimitedTextAsClob (Получить в виде разделенного большого текстового объекта)
  • Метод GetItem (Получить строку по индексу)
  • Метод IndexOf (Получить индекс строки в списке)
  • Метод Insert (Вставить строку в список)
  • Метод Length (Длина списка)
  • Метод Remove (Удалить строку из списка)
  • Метод SetDelimitedText (Создать элементы списка на основе разделенного текста)
  • Метод SetItem (Установить значение элемента)
  • Метод Sort (Сортировать)
  • Метод StrField (Поле в составе строки)
  • Метод StrFieldCount (Количество полей в составе строки)
  • Метод StrFieldIndexOf (Индекс вхождения в состав строки)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TStringList:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Duplicates | TDuplicates | Да | Видимо пользователю | Чтение/Запись | Дублирование
Sorted | Boolean | Да | Видимо пользователю | Чтение/Запись | Сортированный
Delimiter | string[2] | Нет | Видимо пользователю | Чтение/Запись | Разделитель
CaseSensitive | Boolean | Да | Видимо пользователю | Чтение/Запись | Регистрозависимый

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TDuplicates (Дубликаты)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор списка строк)

(одним файлом)
Конструктор Create (Конструктор списка строк)

Конструктор класса TStringList.

1constructor TStringList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TStringList.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод Add (Добавить строку в список)

(одним файлом)
Метод Add (Добавить строку в список)

Метод экземпляра класса TStringList.

function TStringList.Add(ItemString: string[2000]): Integer;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemString | string[2000] | Нет | Строка

Замечания:

Возвращает значение типа Integer.


Метод Archive (Отправить список в архив)

(одним файлом)
Метод Archive (Отправить список в архив)

Метод экземпляра класса TStringList.

procedure TStringList.Archive;

Метод не имеет параметров.


Метод Clear (Очистить список)

(одним файлом)
Метод Clear (Очистить список)

Метод экземпляра класса TStringList.

procedure TStringList.Clear;

Метод скрыт от пользователя.

Метод не имеет параметров.


Метод ClobField (Поле в составе большого текстового объекта)

(одним файлом)
Метод ClobField (Поле в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.

1class function TStringList.ClobField(Text: clob; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | clob | Нет | Текст
Delimiter | string[2] | Нет | Разделитель
FieldIndex | Integer | Нет | Номер поля

Замечания:

Возвращает значение типа string[2000].


Метод ClobFieldCount (Количество полей в составе большого текстового объекта)

(одним файлом)
Метод ClobFieldCount (Количество полей в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.

1class function TStringList.ClobFieldCount(Text: clob;
2  Delimiter: string[2]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | clob | Нет | Текст
Delimiter | string[2] | Нет | Разделитель

Замечания:

Возвращает значение типа Integer.


Метод ClobFieldIndexOf (Индекс вхождения в состав большого текстового объекта)

(одним файлом)
Метод ClobFieldIndexOf (Индекс вхождения в состав большого текстового объекта)

Метод класса (статический метод) класса TStringList.

1class function TStringList.ClobFieldIndexOf(Text: clob; Delimiter: string[2];
2  Value: string[2000]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | clob | Нет | Текст
Delimiter | string[2] | Нет | Разделитель
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа Integer.


Метод Delete (Удалить элемент из списка по индексу)

(одним файлом)
Метод Delete (Удалить элемент из списка по индексу)

Метод экземпляра класса TStringList.

procedure TStringList.Delete(ItemIndex: Integer);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс


Метод GetDelimitedText (Получить в виде разделенного текста)

(одним файлом)
Метод GetDelimitedText (Получить в виде разделенного текста)

Метод экземпляра класса TStringList.

function TStringList.GetDelimitedText: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод GetDelimitedTextAsClob (Получить в виде разделенного большого текстового объекта)

(одним файлом)
Метод GetDelimitedTextAsClob (Получить в виде разделенного большого текстового объекта)

Метод экземпляра класса TStringList.

function TStringList.GetDelimitedTextAsClob: clob;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.


Метод GetItem (Получить строку по индексу)

(одним файлом)
Метод GetItem (Получить строку по индексу)

Метод экземпляра класса TStringList.

function TStringList.GetItem(ItemIndex: Integer): string[2000];

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс

Замечания:

Возвращает значение типа string[2000].


Метод IndexOf (Получить индекс строки в списке)

(одним файлом)
Метод IndexOf (Получить индекс строки в списке)

Метод экземпляра класса TStringList.

function TStringList.IndexOf(ItemString: string[2000]): Integer;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemString | string[2000] | Нет | Строка

Замечания:

Возвращает значение типа Integer.


Метод Insert (Вставить строку в список)

(одним файлом)
Метод Insert (Вставить строку в список)

Метод экземпляра класса TStringList.

procedure TStringList.Insert(ItemIndex: Integer; ItemString: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс
ItemString | string[2000] | Нет | Строка


Метод Length (Длина списка)

(одним файлом)
Метод Length (Длина списка)

Метод экземпляра класса TStringList.

function TStringList.Length: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод Remove (Удалить строку из списка)

(одним файлом)
Метод Remove (Удалить строку из списка)

Метод экземпляра класса TStringList.

procedure TStringList.Remove(ItemString: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemString | string[2000] | Нет | Строка


Метод SetDelimitedText (Создать элементы списка на основе разделенного текста)

(одним файлом)
Метод SetDelimitedText (Создать элементы списка на основе разделенного текста)

Метод экземпляра класса TStringList.

procedure TStringList.SetDelimitedText(Text: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Text | string[2000] | Нет | Текст


Метод SetItem (Установить значение элемента)

(одним файлом)
Метод SetItem (Установить значение элемента)

Метод экземпляра класса TStringList.

procedure TStringList.SetItem(ItemIndex: Integer; ItemString: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс
ItemString | string[2000] | Нет | Строка


Метод Sort (Сортировать)

(одним файлом)
Метод Sort (Сортировать)

Метод экземпляра класса TStringList.

procedure TStringList.Sort;

Метод скрыт от пользователя.

Метод не имеет параметров.


Метод StrField (Поле в составе строки)

(одним файлом)
Метод StrField (Поле в составе строки)

Метод класса (статический метод) класса TStringList.

1class function TStringList.StrField(Text: string[2000]; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | string[2000] | Нет | Текст
Delimiter | string[2] | Нет | Разделитель
FieldIndex | Integer | Нет | Номер поля

Замечания:

Возвращает значение типа string[2000].


Метод StrFieldCount (Количество полей в составе строки)

(одним файлом)
Метод StrFieldCount (Количество полей в составе строки)

Метод класса (статический метод) класса TStringList.

1class function TStringList.StrFieldCount(Text: string[2000];
2  Delimiter: string[2]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | string[2000] | Нет | Текст
Delimiter | string[2] | Нет | Разделитель

Замечания:

Возвращает значение типа Integer.


Метод StrFieldIndexOf (Индекс вхождения в состав строки)

(одним файлом)
Метод StrFieldIndexOf (Индекс вхождения в состав строки)

Метод класса (статический метод) класса TStringList.

1class function TStringList.StrFieldIndexOf(Text: string[2000];
2  Delimiter: string[2]; Value: string[2000]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | string[2000] | Нет | Текст
Delimiter | string[2] | Нет | Разделитель
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа Integer.


Класс TStringListItem (Элемент списка строк)

(раздел целиком) (одним файлом)
Класс TStringListItem (Элемент списка строк)

Класс TObject (Объекты)Класс TStringList (Список строк)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор элемента списка строк)
См. также
  • Класс TObject (Объекты)
  • Класс TStringList (Список строк)


Свойства

(одним файлом)
Свойства

Свойства класса TStringListItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
StringItem | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Строка
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TStringList (Список строк)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор элемента списка строк)

(одним файлом)
Конструктор Create (Конструктор элемента списка строк)

Конструктор класса TStringListItem.

1constructor TStringListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  StringItem: string[2000]; Position: Integer): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
StringItem | string[2000] | Нет | Строка
Position | Integer | Да | Позиция

Замечания:

Создает новый объект класса TStringListItem.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Класс TSystemMessage (Системные сообщения)

(раздел целиком) (одним файлом)
Класс TSystemMessage (Системные сообщения)

Диаграмма

  • Свойства
  • Метод Allow (Системные сообщения разрешены)
  • Метод Clear (Очистить системные сообщения)
  • Метод Post (Отправить системное сообщение)


Свойства

(одним файлом)
Свойства

Свойства класса TSystemMessage:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Session | TSessionHistory | Нет | Скрыто от пользователя | Только для чтения | Сессия
SessionTimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время начала сессии
SessionCloseStamp | datetime | Нет | Видимо пользователю | Только для чтения | Время завершения сессии
IntStamp | Integer | Нет | Видимо пользователю | Только для чтения | Целочисленный номер
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
Login | string[64] | Да | Видимо пользователю | Только для чтения | Логин
UserAgent | string[2000] | Нет | Видимо пользователю | Только для чтения | Пользовательский агент
IPAddress | string[16] | Нет | Видимо пользователю | Только для чтения | IP-адрес
ConnectionInfo | string[2000] | Нет | Видимо пользователю | Только для чтения | Информация о соединении
Text | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Текст
Data | blob | Нет | Видимо пользователю | Чтение/Запись | Данные
DataAsText | clob | Нет | Видимо пользователю | Только для чтения | Данные как текст

См. также
  • Класс TSessionHistory (Сессии)
  • Класс TUser (Пользователи)


Метод Allow (Системные сообщения разрешены)

(одним файлом)
Метод Allow (Системные сообщения разрешены)

Метод класса (статический метод) класса TSystemMessage.

class function TSystemMessage.Allow: Boolean;

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод Clear (Очистить системные сообщения)

(одним файлом)
Метод Clear (Очистить системные сообщения)

Метод класса (статический метод) класса TSystemMessage.

1class procedure TSystemMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Метод Post (Отправить системное сообщение)

(одним файлом)
Метод Post (Отправить системное сообщение)

Метод класса (статический метод) класса TSystemMessage.

class procedure TSystemMessage.Post(Text: string[2000]; Data: blob);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | string[2000] | Нет | Текст
Data | blob | Нет | Данные


Класс TSystemMetadata (Системные метаданные)

(раздел целиком) (одним файлом)
Класс TSystemMetadata (Системные метаданные)

Класс TObject (Объекты)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Метод Change (Изменение объекта)
  • Метод InternalHash (Вычислить внутренний хеш)
  • Метод Store (Сохранить метаданные)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TSystemMetadata:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Data | clob | Нет | Видимо пользователю | Только для чтения | Данные
CRC | string[8] | Нет | Видимо пользователю | Только для чтения | Контрольная сумма

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Метод Change (Изменение объекта)

(одним файлом)
Метод Change (Изменение объекта)

Метод экземпляра класса TSystemMetadata.

procedure TSystemMetadata.Change(Action: TChangeAction);

Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Унаследовано от TObject.Change

См. также
  • Метод Change (Изменение объекта)
  • Перечисление TChangeAction (Действие при изменении)


Метод InternalHash (Вычислить внутренний хеш)

(одним файлом)
Метод InternalHash (Вычислить внутренний хеш)

Метод класса (статический метод) класса TSystemMetadata.

class function TSystemMetadata.InternalHash: string[128];

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].


Метод Store (Сохранить метаданные)

(одним файлом)
Метод Store (Сохранить метаданные)

Метод класса (статический метод) класса TSystemMetadata.

class procedure TSystemMetadata.Store(Data: clob; CRC: string[8]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Data | clob | Нет | Данные
CRC | string[8] | Нет | Контрольная сумма


Класс TTextIndex (Индекс текстового поиска)

(раздел целиком) (одним файлом)
Класс TTextIndex (Индекс текстового поиска)

Диаграмма

  • Свойства
  • Метод CleanUp (Очистить индекс)
  • Метод HashClob (Хэш индекса большого текстового объекта)
  • Метод HashIndex (Хэш индекса)
  • Метод HashValue (Хэш значения)
  • Метод IndexClob (Индексировать большой текстовый объект)
  • Метод IndexValue (Индексировать значение)
  • Метод LoadFromBuffer (Загрузить из буфера)
  • Метод PrepareBuffer (Подготовить буфер)
  • Метод Ole-объекта Rebuild (Перестроить индекс)


Свойства

(одним файлом)
Свойства

Свойства класса TTextIndex:

Имя | Тип | Обязательно | Доступ | Назначение
Field | TField | Да | Только для чтения | Поле
ObjectClass | TClass | Да | Только для чтения | Класс объекта
Object | TObject | Да | Только для чтения | Объект
ObjectName | string[64] | Да | Только для чтения | Имя объекта
ObjectDescription | string[128] | Да | Только для чтения | Наименование объекта
ObjectParent | TObject | Нет | Только для чтения | Родитель объекта
ObjectMaster | TObject | Да | Только для чтения | Мастер объекта
TopLevelObject | TObject | Нет | Только для чтения | Объект верхнего уровня
Entry | TTextIndexEntry | Да | Только для чтения | Вхождение
Word | string[64] | Да | Только для чтения | Слово
UpperWord | string[64] | Да | Только для чтения | Слово в верхнем регистре

См. также
  • Класс TClass (Классы)
  • Класс TField (Поля)
  • Класс TObject (Объекты)
  • Класс TTextIndexEntry (Вхождения индекса текстового поиска)


Метод CleanUp (Очистить индекс)

(одним файлом)
Метод CleanUp (Очистить индекс)

Метод класса (статический метод) класса TTextIndex.

class procedure TTextIndex.CleanUp(Field: TField; Object: TObject);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Field | TField | Нет | Поле
Object | TObject | Да | Объект

См. также
  • Класс TField (Поля)
  • Класс TObject (Объекты)


Метод HashClob (Хэш индекса большого текстового объекта)

(одним файлом)
Метод HashClob (Хэш индекса большого текстового объекта)

Метод класса (статический метод) класса TTextIndex.

class function TTextIndex.HashClob(Value: clob; IsXHTML: Boolean): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение
IsXHTML | Boolean | Да | Содержимое является XHTML

Замечания:

Возвращает значение типа string[2000].


Метод HashIndex (Хэш индекса)

(одним файлом)
Метод HashIndex (Хэш индекса)

Метод класса (статический метод) класса TTextIndex.

1class function TTextIndex.HashIndex(Field: TField;
2  Object: TObject): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Field | TField | Да | Поле
Object | TObject | Да | Объект

Замечания:

Возвращает значение типа string[2000].

См. также
  • Класс TField (Поля)
  • Класс TObject (Объекты)


Метод HashValue (Хэш значения)

(одним файлом)
Метод HashValue (Хэш значения)

Метод класса (статический метод) класса TTextIndex.

class function TTextIndex.HashValue(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Метод IndexClob (Индексировать большой текстовый объект)

(одним файлом)
Метод IndexClob (Индексировать большой текстовый объект)

Метод класса (статический метод) класса TTextIndex.

1class procedure TTextIndex.IndexClob(DeleteExistant: Boolean; Value: clob;
2  Field: TField; Object: TObject; ObjectClass: TClass);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
DeleteExistant | Boolean | Да | Удалять существующие
Value | clob | Нет | Значение
Field | TField | Да | Поле
Object | TObject | Да | Объект
ObjectClass | TClass | Да | Класс объекта

См. также
  • Класс TClass (Классы)
  • Класс TField (Поля)
  • Класс TObject (Объекты)


Метод IndexValue (Индексировать значение)

(одним файлом)
Метод IndexValue (Индексировать значение)

Метод класса (статический метод) класса TTextIndex.

1class procedure TTextIndex.IndexValue(DeleteExistant: Boolean;
2  Value: string[2000]; Field: TField; Object: TObject; ObjectClass: TClass);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
DeleteExistant | Boolean | Да | Удалять существующие
Value | string[2000] | Нет | Значение
Field | TField | Да | Поле
Object | TObject | Да | Объект
ObjectClass | TClass | Да | Класс объекта

См. также
  • Класс TClass (Классы)
  • Класс TField (Поля)
  • Класс TObject (Объекты)


Метод LoadFromBuffer (Загрузить из буфера)

(одним файлом)
Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndex.

class procedure TTextIndex.LoadFromBuffer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.


Метод PrepareBuffer (Подготовить буфер)

(одним файлом)
Метод PrepareBuffer (Подготовить буфер)

Метод класса (статический метод) класса TTextIndex.

class procedure TTextIndex.PrepareBuffer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.


Метод Ole-объекта Rebuild (Перестроить индекс)

(одним файлом)
Метод Ole-объекта Rebuild (Перестроить индекс)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TTextIndex.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AClass | TClass | Нет | Класс
AField | TField | Нет | Поле
ThreadCount | Integer | Нет | Количество потоков

См. также
  • Класс TClass (Классы)
  • Класс TField (Поля)


Класс TTextIndexEntry (Вхождения индекса текстового поиска)

(раздел целиком) (одним файлом)
Класс TTextIndexEntry (Вхождения индекса текстового поиска)

Диаграмма

  • Свойства
  • Метод LoadFromBuffer (Загрузить из буфера)


Свойства

(одним файлом)
Свойства

Свойства класса TTextIndexEntry:

Имя | Тип | Обязательно | Доступ | Назначение
Word | string[64] | Да | Только для чтения | Слово
UpperWord | string[64] | Да | Только для чтения | Слово в верхнем регистре


Метод LoadFromBuffer (Загрузить из буфера)

(одним файлом)
Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndexEntry.

class procedure TTextIndexEntry.LoadFromBuffer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.


Класс TTimeDomain (Время)

(раздел целиком) (одним файлом)
Класс TTimeDomain (Время)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор домена времени)
  • Метод GetSummary (Получить сводку)
См. также
  • Класс TDomain (Домены)


Свойства

(одним файлом)
Свойства

Свойства класса TTimeDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
HideSeconds | Boolean | Да | Видимо пользователю | Чтение/Запись | Не показывать секунды

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор домена времени)

(одним файлом)
Конструктор Create (Конструктор домена времени)

Конструктор класса TTimeDomain.

1constructor TTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
HideSeconds | Boolean | Да | Не показывать секунды

Замечания:

Создает новый объект класса TTimeDomain.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор домена)
  • Конструктор Create (Конструктор объекта)


Метод GetSummary (Получить сводку)

(одним файлом)
Метод GetSummary (Получить сводку)

Метод экземпляра класса TTimeDomain.

function TTimeDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

См. также
  • Метод GetSummary (Получить сводку)


Класс TTypedValue (Типизированные значения)

(раздел целиком) (одним файлом)
Класс TTypedValue (Типизированные значения)

Класс TObject (Объекты)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор типизированного значения)
  • Метод CompareBlob (Сравнить большие объекты)
  • Метод CompareBoolean (Сравнить логические значения)
  • Метод CompareClob (Сравнить тексты)
  • Метод CompareDate (Сравнить значения дат)
  • Метод CompareDateTime (Сравнить значения даты со временем)
  • Метод CompareFloat (Сравнить вещественные значения)
  • Метод CompareInt (Сравнить целые значения)
  • Метод CompareList (Сравнить со списком)
  • Метод CompareObject (Сравнить значения-объекты)
  • Метод CompareStr (Сравнить строковые значения)
  • Метод CompareTime (Сравнить значения времени)
  • Метод CreateBlobValue (Создать значение-большой объект)
  • Метод CreateBoolValue (Создать логическое значение)
  • Метод CreateClobValue (Создать значение-текст)
  • Метод CreateDateTimeValue (Создать значение даты со временем)
  • Метод CreateDateValue (Создать значение даты)
  • Метод CreateExternalDataValue (Создать значение внешних данных)
  • Метод CreateFloatValue (Создать вещественное значение)
  • Метод CreateIntValue (Создать целое значение)
  • Метод CreateObjectValue (Создать значение-объект)
  • Метод CreateStrValue (Создать строковое значение)
  • Метод CreateTimeValue (Создать значение времени)
  • Метод FindBlobValue (Поиск значения-большого объекта)
  • Метод FindBoolValue (Поиск логического значения)
  • Метод FindClobValue (Поиск значения-текста)
  • Метод FindDateTimeValue (Поиск значения даты со временем)
  • Метод FindDateValue (Поиск значения даты)
  • Метод FindExternalDataValue (Поиск значения внешних данных)
  • Метод FindFloatValue (Поиск вещественного значения)
  • Метод FindIntValue (Поиск целого значения)
  • Метод FindObjectValue (Поиск значения-объекта)
  • Метод FindStrValue (Поиск строкового значения)
  • Метод FindTimeValue (Поиск значения времени)
  • Метод FindValue (Поиск значения)
  • Метод GetNextPos (Следующая позиция)
  • Метод GetVisibleValue (Видимое значение)
  • Метод ReplaceWildcards (Заменить подстановочные символы)
  • Метод SetValue (Установить значение)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TTypedValue:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Нет | Скрыто от пользователя | Только для чтения | Мастер
MasterClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс мастера
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс домена
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок закладки
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок группы
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись | За пределами закладок
StrValue | string[2000] | Нет | Скрыто от пользователя | Чтение/Запись | Строковое значение
IntValue | Integer | Нет | Скрыто от пользователя | Чтение/Запись | Целое значение
FloatValue | float | Нет | Скрыто от пользователя | Чтение/Запись | Вещественное значение
DateValue | date | Нет | Скрыто от пользователя | Чтение/Запись | Значение даты
TimeValue | time | Нет | Скрыто от пользователя | Чтение/Запись | Значение времени
DateTimeValue | datetime | Нет | Скрыто от пользователя | Чтение/Запись | Значение даты со временем
ObjectValue | TObject | Нет | Скрыто от пользователя | Чтение/Запись | Значение-объект
BoolValue | Boolean | Нет | Скрыто от пользователя | Чтение/Запись | Логическое значение
BlobValue | blob | Нет | Видимо пользователю | Чтение/Запись | Значение-большой объект
ClobValue | clob | Нет | Видимо пользователю | Чтение/Запись | Значение-текст
ExternalDataValue | <external data> | Нет | Видимо пользователю | Чтение/Запись | Значение-внешние данные
VisibleValue | string[2000] | Нет | Видимо пользователю | Только для чтения | Видимое значение
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись | Идентификатор элемента управления

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор типизированного значения)

(одним файлом)
Конструктор Create (Конструктор типизированного значения)

Конструктор класса TTypedValue.

1constructor TTypedValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>): TTypedValue;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
StrValue | string[2000] | Нет | Строковое значение
IntValue | Integer | Нет | Целое значение
FloatValue | float | Нет | Вещественное значение
DateValue | date | Нет | Значение даты
TimeValue | time | Нет | Значение времени
DateTimeValue | datetime | Нет | Значение даты со временем
ObjectValue | TObject | Нет | Значение-объект
BoolValue | Boolean | Нет | Логическое значение
BlobValue | blob | Нет | Значение-большой объект
ClobValue | clob | Нет | Значение-текст
ExternalDataValue | <external data> | Нет | Значение-внешние данные

Замечания:

Создает новый объект класса TTypedValue.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TScope (Область видимости)


Метод CompareBlob (Сравнить большие объекты)

(одним файлом)
Метод CompareBlob (Сравнить большие объекты)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareBlob(ComparisonTypeName: string[64];
2  ValueA: blob; ValueB: blob): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | blob | Нет | Значение A
ValueB | blob | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.


Метод CompareBoolean (Сравнить логические значения)

(одним файлом)
Метод CompareBoolean (Сравнить логические значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareBoolean(ComparisonTypeName: string[64];
2  ValueA: Boolean; ValueB: Boolean): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | Boolean | Да | Значение A
ValueB | Boolean | Да | Значение B

Замечания:

Возвращает значение типа Boolean.


Метод CompareClob (Сравнить тексты)

(одним файлом)
Метод CompareClob (Сравнить тексты)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareClob(ComparisonTypeName: string[64];
2  ValueA: clob; ValueB: clob): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | clob | Нет | Значение A
ValueB | clob | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.


Метод CompareDate (Сравнить значения дат)

(одним файлом)
Метод CompareDate (Сравнить значения дат)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareDate(ComparisonTypeName: string[64];
2  ValueA: date; ValueB: date): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | date | Нет | Значение A
ValueB | date | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.


Метод CompareDateTime (Сравнить значения даты со временем)

(одним файлом)
Метод CompareDateTime (Сравнить значения даты со временем)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareDateTime(ComparisonTypeName: string[64];
2  ValueA: datetime; ValueB: datetime): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | datetime | Нет | Значение A
ValueB | datetime | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.


Метод CompareFloat (Сравнить вещественные значения)

(одним файлом)
Метод CompareFloat (Сравнить вещественные значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareFloat(ComparisonTypeName: string[64];
2  ValueA: float; ValueB: float): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | float | Нет | Значение A
ValueB | float | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.


Метод CompareInt (Сравнить целые значения)

(одним файлом)
Метод CompareInt (Сравнить целые значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareInt(ComparisonTypeName: string[64];
2  ValueA: Integer; ValueB: Integer): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | Integer | Нет | Значение A
ValueB | Integer | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.


Метод CompareList (Сравнить со списком)

(одним файлом)
Метод CompareList (Сравнить со списком)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareList(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: TObject): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | string[2000] | Нет | Значение A
ValueB | TObject | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObject (Объекты)


Метод CompareObject (Сравнить значения-объекты)

(одним файлом)
Метод CompareObject (Сравнить значения-объекты)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareObject(ComparisonTypeName: string[64];
2  ValueA: TObject; ValueB: TObject): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | TObject | Нет | Значение A
ValueB | TObject | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObject (Объекты)


Метод CompareStr (Сравнить строковые значения)

(одним файлом)
Метод CompareStr (Сравнить строковые значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareStr(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: string[2000]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | string[2000] | Нет | Значение A
ValueB | string[2000] | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.


Метод CompareTime (Сравнить значения времени)

(одним файлом)
Метод CompareTime (Сравнить значения времени)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareTime(ComparisonTypeName: string[64];
2  ValueA: time; ValueB: time): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | time | Нет | Значение A
ValueB | time | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.


Метод CreateBlobValue (Создать значение-большой объект)

(одним файлом)
Метод CreateBlobValue (Создать значение-большой объект)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateBlobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BlobValue: blob): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
BlobValue | blob | Нет | Значение-большой объект

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)
  • Перечисление TScope (Область видимости)


Метод CreateBoolValue (Создать логическое значение)

(одним файлом)
Метод CreateBoolValue (Создать логическое значение)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateBoolValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BoolValue: Boolean): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
BoolValue | Boolean | Нет | Логическое значение

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)
  • Перечисление TScope (Область видимости)


Метод CreateClobValue (Создать значение-текст)

(одним файлом)
Метод CreateClobValue (Создать значение-текст)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateClobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ClobValue: clob): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Группа
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
ClobValue | clob | Нет | Значение-текст

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)
  • Перечисление TScope (Область видимости)


Метод CreateDateTimeValue (Создать значение даты со временем)

(одним файлом)
Метод CreateDateTimeValue (Создать значение даты со временем)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateDateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateTimeValue: datetime): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
DateTimeValue | datetime | Нет | Значение даты со временем

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)
  • Перечисление TScope (Область видимости)


Метод CreateDateValue (Создать значение даты)

(одним файлом)
Метод CreateDateValue (Создать значение даты)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateDateValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateValue: date): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
DateValue | date | Нет | Значение даты

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)
  • Перечисление TScope (Область видимости)


Метод CreateExternalDataValue (Создать значение внешних данных)

(одним файлом)
Метод CreateExternalDataValue (Создать значение внешних данных)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateExternalDataValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ExternalDataValue: <external data>): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
ExternalDataValue | <external data> | Нет | Значение-внешние данные

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)
  • Перечисление TScope (Область видимости)


Метод CreateFloatValue (Создать вещественное значение)

(одним файлом)
Метод CreateFloatValue (Создать вещественное значение)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateFloatValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  FloatValue: float): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
FloatValue | float | Нет | Вещественное значение

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)
  • Перечисление TScope (Область видимости)


Метод CreateIntValue (Создать целое значение)

(одним файлом)
Метод CreateIntValue (Создать целое значение)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateIntValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  IntValue: Integer): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
IntValue | Integer | Нет | Целое значение

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)
  • Перечисление TScope (Область видимости)


Метод CreateObjectValue (Создать значение-объект)

(одним файлом)
Метод CreateObjectValue (Создать значение-объект)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateObjectValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ObjectValue: TObject): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
ObjectValue | TObject | Нет | Значение-объект

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)
  • Перечисление TScope (Область видимости)


Метод CreateStrValue (Создать строковое значение)

(одним файлом)
Метод CreateStrValue (Создать строковое значение)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateStrValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
StrValue | string[2000] | Нет | Строковое значение

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)
  • Перечисление TScope (Область видимости)


Метод CreateTimeValue (Создать значение времени)

(одним файлом)
Метод CreateTimeValue (Создать значение времени)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  TimeValue: time): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
TimeValue | time | Нет | Значение времени

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)
  • Перечисление TScope (Область видимости)


Метод FindBlobValue (Поиск значения-большого объекта)

(одним файлом)
Метод FindBlobValue (Поиск значения-большого объекта)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindBlobValue(Master: TObject;
2  ControlName: string[64]): blob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа blob.

См. также
  • Класс TObject (Объекты)


Метод FindBoolValue (Поиск логического значения)

(одним файлом)
Метод FindBoolValue (Поиск логического значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindBoolValue(Master: TObject;
2  ControlName: string[64]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TObject (Объекты)


Метод FindClobValue (Поиск значения-текста)

(одним файлом)
Метод FindClobValue (Поиск значения-текста)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindClobValue(Master: TObject;
2  ControlName: string[64]): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа clob.

См. также
  • Класс TObject (Объекты)


Метод FindDateTimeValue (Поиск значения даты со временем)

(одним файлом)
Метод FindDateTimeValue (Поиск значения даты со временем)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindDateTimeValue(Master: TObject;
2  ControlName: string[64]): datetime;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа datetime.

См. также
  • Класс TObject (Объекты)


Метод FindDateValue (Поиск значения даты)

(одним файлом)
Метод FindDateValue (Поиск значения даты)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindDateValue(Master: TObject;
2  ControlName: string[64]): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа date.

См. также
  • Класс TObject (Объекты)


Метод FindExternalDataValue (Поиск значения внешних данных)

(одним файлом)
Метод FindExternalDataValue (Поиск значения внешних данных)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindExternalDataValue(Master: TObject;
2  ControlName: string[64]): <external data>;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа <external data>.

См. также
  • Класс TObject (Объекты)


Метод FindFloatValue (Поиск вещественного значения)

(одним файлом)
Метод FindFloatValue (Поиск вещественного значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindFloatValue(Master: TObject;
2  ControlName: string[64]): float;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа float.

См. также
  • Класс TObject (Объекты)


Метод FindIntValue (Поиск целого значения)

(одним файлом)
Метод FindIntValue (Поиск целого значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindIntValue(Master: TObject;
2  ControlName: string[64]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Метод FindObjectValue (Поиск значения-объекта)

(одним файлом)
Метод FindObjectValue (Поиск значения-объекта)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindObjectValue(Master: TObject;
2  ControlName: string[64]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа TObject.

См. также
  • Класс TObject (Объекты)


Метод FindStrValue (Поиск строкового значения)

(одним файлом)
Метод FindStrValue (Поиск строкового значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindStrValue(Master: TObject;
2  ControlName: string[64]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа string[2000].

См. также
  • Класс TObject (Объекты)


Метод FindTimeValue (Поиск значения времени)

(одним файлом)
Метод FindTimeValue (Поиск значения времени)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindTimeValue(Master: TObject;
2  ControlName: string[64]): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа time.

См. также
  • Класс TObject (Объекты)


Метод FindValue (Поиск значения)

(одним файлом)
Метод FindValue (Поиск значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindValue(AMaster: TObject;
2  AControlName: string[64]): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AMaster | TObject | Нет | Объект-мастер
AControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа TTypedValue.

См. также
  • Класс TObject (Объекты)


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер объекта
Parent | TObject | Нет | Родитель
Step | Integer | Да | Шаг

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Метод GetVisibleValue (Видимое значение)

(одним файлом)
Метод GetVisibleValue (Видимое значение)

Метод экземпляра класса TTypedValue.

function TTypedValue.GetVisibleValue: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Метод ReplaceWildcards (Заменить подстановочные символы)

(одним файлом)
Метод ReplaceWildcards (Заменить подстановочные символы)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.ReplaceWildcards(Value: string[2000];
2  Escape: string[2]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Escape | string[2] | Нет | Экранирующий символ

Замечания:

Возвращает значение типа string[2000].


Метод SetValue (Установить значение)

(одним файлом)
Метод SetValue (Установить значение)

Метод экземпляра класса TTypedValue.

1procedure TTypedValue.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>);

Параметры:

Имя | Тип | Обязательно | Значение
StrValue | string[2000] | Нет | Строковое значение
IntValue | Integer | Нет | Целое значение
FloatValue | float | Нет | Вещественное значение
DateValue | date | Нет | Значение даты
TimeValue | time | Нет | Значение времени
DateTimeValue | datetime | Нет | Значение даты со временем
ObjectValue | TObject | Нет | Значение-объект
BoolValue | Boolean | Нет | Логическое значение
BlobValue | blob | Нет | Значение-большой объект
ClobValue | clob | Нет | Значение-текст
ExternalDataValue | <external data> | Нет | Значение-внешние данные

См. также
  • Класс TObject (Объекты)


Класс TTypedValueButton (Кнопки на форме редактирования значений)

(раздел целиком) (одним файлом)
Класс TTypedValueButton (Кнопки на форме редактирования значений)

Диаграмма Класс TCustomButton (Кнопки)Класс TObject (Объекты)

  • Свойства
  • Конструктор Create (Конструктор кнопки формы редактирования значений)
См. также
  • Класс TCustomButton (Кнопки)


Свойства

(одним файлом)
Свойства

Свойства класса TTypedValueButton:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TCustomButton
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
TypedValue | TTypedValue | Нет | Видимо пользователю | Чтение/Запись | Связанное типизированное значение
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись | Идентификатор элемента управления

См. также
  • Класс TClass (Классы)
  • Класс TCustomButton (Кнопки)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TTypedValue (Типизированные значения)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор кнопки формы редактирования значений)

(одним файлом)
Конструктор Create (Конструктор кнопки формы редактирования значений)

Конструктор класса TTypedValueButton.

1constructor TTypedValueButton.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Group: string[128];
4  Tab: string[128]; Script: clob; Scope: TScope; OutOfTabs: Boolean;
5  TypedValue: TTypedValue): TObject;

Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TCustomButton.Create
Group | string[128] | Нет
Tab | string[128] | Нет
Script | clob | Нет
Scope | TScope | Да
OutOfTabs | Boolean | Да
TypedValue | TTypedValue | Нет | Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueButton.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TTypedValue (Типизированные значения)
  • Конструктор Create (Конструктор кнопки)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TScope (Область видимости)


Класс TTypedValueView (Представления на форме редактирования значений)

(раздел целиком) (одним файлом)
Класс TTypedValueView (Представления на форме редактирования значений)

Класс TFormView (Представления формы)Класс TObject (Объекты)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор представления на форме редактирования значений)
См. также
  • Класс TFormView (Представления формы)


Свойства

(одним файлом)
Свойства

Свойства класса TTypedValueView:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TFormView
ChildrenMinimized | Boolean | Да | Видимо пользователю | Чтение/Запись
MasterProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
DetailProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись
View | TCustomView | Да | Видимо пользователю | Чтение/Запись
BoldProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
ShownClass | TClass | Да | Видимо пользователю | Только для чтения
ColorProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
Layout | TFormViewLayout | Да | Видимо пользователю | Чтение/Запись
ChildrenOnTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
ExplicitQuery | Boolean | Да | Видимо пользователю | Чтение/Запись
SpacePercentage | Integer | Нет | Видимо пользователю | Чтение/Запись
TypedValue | TTypedValue | Нет | Видимо пользователю | Чтение/Запись | Связанное типизированное значение
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись | Идентификатор связанного типизированного значения
ViewName | string[64] | Да | Видимо пользователю | Чтение/Запись | Идентификатор элемента управления

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TCustomView (Абстрактное представление)
  • Класс TDataBase (Базы данных)
  • Класс TFormView (Представления формы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TTypedValue (Типизированные значения)
  • Класс TUser (Пользователи)
  • Перечисление TFormViewLayout (Виды расположения)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор представления на форме редактирования значений)

(одним файлом)
Конструктор Create (Конструктор представления на форме редактирования значений)

Конструктор класса TTypedValueView.

1constructor TTypedValueView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout; ExplicitQuery: Boolean;
6  TypedValue: TTypedValue): TObject;

Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
View | TCustomView | Да | Унаследовано от TFormView.Create
ChildrenMinimized | Boolean | Да
ChildrenOnTabs | Boolean | Да
MasterProperty | TProperty | Нет
DetailProperty | TClassMember | Нет
Position | Integer | Да
SpacePercentage | Integer | Нет
Layout | TFormViewLayout | Да
ExplicitQuery | Boolean | Да
TypedValue | TTypedValue | Нет | Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueView.

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TCustomView (Абстрактное представление)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TTypedValue (Типизированные значения)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор представления формы)
  • Перечисление TFormViewLayout (Виды расположения)


Класс TUser (Пользователи)

(раздел целиком) (одним файлом)
Класс TUser (Пользователи)

Диаграмма Класс TSecurityAccount (Роли безопасности)Класс TObject (Объекты)Класс TInstantMessage (Сообщения)Класс TInstantContact (Контакты)Класс TInstantMessageAttachment (Сообщения с вложением)

  • Свойства
  • Конструктор Create (Конструктор пользователя)
  • Метод EffectiveMemberOf (Является эффективным членом)
  • Метод GetCurrentUser (Получить текущего пользователя)
  • Метод GetIsCurrent (Является текущим)
См. также
  • Класс TSecurityAccount (Роли безопасности)


Свойства

(одним файлом)
Свойства

Свойства класса TUser:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
IsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Является текущим
AccessMode | TUserAccessMode | Да | Видимо пользователю | Чтение/Запись | Режим доступа
CanRecieveMessages | Boolean | Да | Видимо пользователю | Чтение/Запись | Получает сообщения

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TUserAccessMode (Режим доступа)


Конструктор Create (Конструктор пользователя)

(одним файлом)
Конструктор Create (Конструктор пользователя)

Конструктор класса TUser.

1constructor TUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CanRecieveMessages: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
CanRecieveMessages | Boolean | Да | Получает сообщения

Замечания:

Создает новый объект класса TUser.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод EffectiveMemberOf (Является эффективным членом)

(одним файлом)
Метод EffectiveMemberOf (Является эффективным членом)

Метод экземпляра класса TUser.

function TUser.EffectiveMemberOf(Role: TRole): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Role | TRole | Да | Роль

Замечания:

Возвращает значение типа Boolean.

См. также
  • Класс TRole (Роли)


Метод GetCurrentUser (Получить текущего пользователя)

(одним файлом)
Метод GetCurrentUser (Получить текущего пользователя)

Метод класса (статический метод) класса TUser.

class function TUser.GetCurrentUser: TUser;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TUser.


Метод GetIsCurrent (Является текущим)

(одним файлом)
Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TUser.

function TUser.GetIsCurrent: Boolean;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Класс TUserNotification (Уведомления)

(раздел целиком) (одним файлом)
Класс TUserNotification (Уведомления)

Диаграмма Класс TObject (Объекты)Класс TUserNotificationAddressee (Адресаты уведомлений)Класс TUserNotificationShown (Показы уведомлений)

  • Свойства
  • Конструктор Create (Конструктор уведомления)
  • Метод GetShowNeeded (Необходимо показывать)
  • Метод Preview (Предпросмотр)
  • Метод Shown (Отметить как показанное)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TUserNotification:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Type | TNotificationType | Да | Видимо пользователю | Чтение/Запись | Тип
Text | clob | Нет | Видимо пользователю | Чтение/Запись | Текст
Active | Boolean | Да | Видимо пользователю | Чтение/Запись | Активно
ShowFrom | datetime | Нет | Видимо пользователю | Чтение/Запись | Показывать с
ShowTo | datetime | Нет | Видимо пользователю | Чтение/Запись | Показывать по
Bold | Boolean | Да | Скрыто от пользователя | Только для чтения | Выделено
ShowNeeded | Boolean | Да | Скрыто от пользователя | Только для чтения | Необходимо показывать

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TNotificationType (Тип уведомления)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор уведомления)

(одним файлом)
Конструктор Create (Конструктор уведомления)

Конструктор класса TUserNotification.

1constructor TUserNotification.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Type: TNotificationType; Text: clob;
4  Active: Boolean; ShowFrom: datetime; ShowTo: datetime): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Type | TNotificationType | Да | Тип
Text | clob | Нет | Текст
Active | Boolean | Да | Активно
ShowFrom | datetime | Нет | Показывать с
ShowTo | datetime | Нет | Показывать по

Замечания:

Создает новый объект класса TUserNotification.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TNotificationType (Тип уведомления)


Метод GetShowNeeded (Необходимо показывать)

(одним файлом)
Метод GetShowNeeded (Необходимо показывать)

Метод экземпляра класса TUserNotification.

function TUserNotification.GetShowNeeded: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод Preview (Предпросмотр)

(одним файлом)
Метод Preview (Предпросмотр)

Метод экземпляра класса TUserNotification.

procedure TUserNotification.Preview;

Метод не имеет параметров.


Метод Shown (Отметить как показанное)

(одним файлом)
Метод Shown (Отметить как показанное)

Метод экземпляра класса TUserNotification.

procedure TUserNotification.Shown;

Метод скрыт от пользователя.

Метод не имеет параметров.


Класс TUserNotificationAddressee (Адресаты уведомлений)

(раздел целиком) (одним файлом)
Класс TUserNotificationAddressee (Адресаты уведомлений)

Класс TObject (Объекты)Класс TUserNotification (Уведомления)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор адресата уведомления)
См. также
  • Класс TObject (Объекты)
  • Класс TUserNotification (Уведомления)


Свойства

(одним файлом)
Свойства

Свойства класса TUserNotificationAddressee:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
SecurityAccount | TSecurityAccount | Да | Видимо пользователю | Чтение/Запись | Роль безопасности

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Класс TUserNotification (Уведомления)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор адресата уведомления)

(одним файлом)
Конструктор Create (Конструктор адресата уведомления)

Конструктор класса TUserNotificationAddressee.

1constructor TUserNotificationAddressee.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
SecurityAccount | TSecurityAccount | Да | Роль безопасности

Замечания:

Создает новый объект класса TUserNotificationAddressee.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Класс TUserNotificationShown (Показы уведомлений)

(раздел целиком) (одним файлом)
Класс TUserNotificationShown (Показы уведомлений)

Класс TObject (Объекты)Класс TUserNotification (Уведомления)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор показа уведомления)
См. также
  • Класс TObject (Объекты)
  • Класс TUserNotification (Уведомления)


Свойства

(одним файлом)
Свойства

Свойства класса TUserNotificationShown:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TUserNotification | Да | Скрыто от пользователя | Только для чтения | Уведомление
Type | TNotificationType | Да | Видимо пользователю | Только для чтения | Тип уведомления
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Класс TUserNotification (Уведомления)
  • Перечисление TNotificationType (Тип уведомления)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор показа уведомления)

(одним файлом)
Конструктор Create (Конструктор показа уведомления)

Конструктор класса TUserNotificationShown.

1constructor TUserNotificationShown.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TUserNotificationShown.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Класс TView (Представления)

(раздел целиком) (одним файлом)
Класс TView (Представления)

Диаграмма Класс TCustomView (Абстрактное представление)Класс TObject (Объекты)Класс TViewColumn (Колонки представлений)Класс TViewPresentation (Виды)

  • Свойства
  • Конструктор Create (Конструктор представления)
  • Метод BuildDefaultColumns (Создать колонки по умолчанию)
  • Метод GetHasPresentations (Имеет виды)
  • Метод GetIsAggregated (Агрегировано)
  • Метод GetIsGrouped (Сгруппировано)
  • Метод GetIsSorted (Отсортировано)
См. также
  • Класс TCustomView (Абстрактное представление)


Свойства

(одним файлом)
Свойства

Свойства класса TView:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
ShownClass | TClass | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TCustomView
ShownClassMasterClass | TClass | Нет | Видимо пользователю | Только для чтения
ShownClassReplicationStatus | TReplicationStatus | Да | Видимо пользователю | Только для чтения
ShownClassIsHierarhical | Boolean | Да | Видимо пользователю | Только для чтения
Skimpy | Boolean | Да | Видимо пользователю | Чтение/Запись
BoldProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
PreCompiled | Boolean | Да | Видимо пользователю | Чтение/Запись
PreOpenRoutine | TRoutine | Нет | Видимо пользователю | Чтение/Запись
ColorProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
OptimizationParameters | string[2000] | Нет | Видимо пользователю | Чтение/Запись
HasConditions | Boolean | Да | Видимо пользователю | Только для чтения
HasSpecificalyNamedColumns | Boolean | Да | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
IsGrouped | Boolean | Да | Видимо пользователю | Только для чтения | Сгруппировано
LinesPerRow | Integer | Да | Видимо пользователю | Чтение/Запись | Строк на ячейку
Collapsed | Boolean | Да | Видимо пользователю | Чтение/Запись | Свернуть
HasPresentations | Boolean | Да | Видимо пользователю | Только для чтения | Имеет виды
IsSorted | Boolean | Да | Видимо пользователю | Только для чтения | Отсортировано
IsAggregated | Boolean | Да | Видимо пользователю | Только для чтения | Агрегировано

См. также
  • Класс TClass (Классы)
  • Класс TCustomView (Абстрактное представление)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор представления)

(одним файлом)
Конструктор Create (Конструктор представления)

Конструктор класса TView.

1constructor TView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  Collapsed: Boolean): TObject;

Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
ShownClass | TClass | Да | Унаследовано от TCustomView.Create
ColorProperty | TProperty | Нет
BoldProperty | TProperty | Нет
Skimpy | Boolean | Да
PreCompiled | Boolean | Да
PreOpenRoutine | TRoutine | Нет
Collapsed | Boolean | Да | Свернуто

Замечания:

Создает новый объект класса TView.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор абстрактного представления)
  • Конструктор Create (Конструктор объекта)


Метод BuildDefaultColumns (Создать колонки по умолчанию)

(одним файлом)
Метод BuildDefaultColumns (Создать колонки по умолчанию)

Метод экземпляра класса TView.

1procedure TView.BuildDefaultColumns(AddNameColumn: Boolean;
2  AddDescColumn: Boolean);

Параметры:

Имя | Тип | Обязательно | Значение
AddNameColumn | Boolean | Да | Создать колонку имени
AddDescColumn | Boolean | Да | Создать колонку наименования


Метод GetHasPresentations (Имеет виды)

(одним файлом)
Метод GetHasPresentations (Имеет виды)

Метод экземпляра класса TView.

function TView.GetHasPresentations: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод GetIsAggregated (Агрегировано)

(одним файлом)
Метод GetIsAggregated (Агрегировано)

Метод экземпляра класса TView.

function TView.GetIsAggregated: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод GetIsGrouped (Сгруппировано)

(одним файлом)
Метод GetIsGrouped (Сгруппировано)

Метод экземпляра класса TView.

function TView.GetIsGrouped: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод GetIsSorted (Отсортировано)

(одним файлом)
Метод GetIsSorted (Отсортировано)

Метод экземпляра класса TView.

function TView.GetIsSorted: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Класс TViewAction (Действие-представление)

(раздел целиком) (одним файлом)
Класс TViewAction (Действие-представление)

Класс TAction (Действия)Класс TObject (Объекты)Класс TCustomView (Абстрактное представление)

Объекты класса образуют иерархию.

  • Свойства
  • Конструктор Create (Конструктор действия-представления)
См. также
  • Класс TAction (Действия)
  • Класс TCustomView (Абстрактное представление)


Свойства

(одним файлом)
Свойства

Свойства класса TViewAction:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Shortcut | string[20] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TAction
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Separated | Boolean | Да | Видимо пользователю | Чтение/Запись
Default | Boolean | Да | Видимо пользователю | Чтение/Запись
View | TCustomView | Да | Видимо пользователю | Чтение/Запись | Представление
ShownClass | TClass | Да | Видимо пользователю | Только для чтения | Показываемый класс
DetailProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Свойство-подчиненное
MasterProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-главное

См. также
  • Класс TAction (Действия)
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TCustomView (Абстрактное представление)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор действия-представления)

(одним файлом)
Конструктор Create (Конструктор действия-представления)

Конструктор класса TViewAction.

1constructor TViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  View: TCustomView; MasterProperty: TProperty;
5  DetailProperty: TClassMember): TObject;

Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TAction.Create
Shortcut | string[20] | Нет
Separated | Boolean | Да
Default | Boolean | Да
View | TCustomView | Да | Представление
MasterProperty | TProperty | Нет | Свойство-главное
DetailProperty | TClassMember | Нет | Свойство-подчиненное

Замечания:

Создает новый объект класса TViewAction.

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TCustomView (Абстрактное представление)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор действия)
  • Конструктор Create (Конструктор объекта)


Класс TViewColumn (Колонки представлений)

(раздел целиком) (одним файлом)
Класс TViewColumn (Колонки представлений)

Диаграмма Класс TObject (Объекты)Класс TView (Представления)

  • Свойства
  • Конструктор Create (Конструктор колонки представления)
  • Метод Change (Изменение объекта)
  • Метод CreateByNames (Добавить по списку свойств)
  • Метод GetNextPos (Следующая позиция)
  • Метод NameAfterProperty (Дать имя свойства)
См. также
  • Класс TObject (Объекты)
  • Класс TView (Представления)


Свойства

(одним файлом)
Свойства

Свойства класса TViewColumn:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Property | TProperty | Да | Видимо пользователю | Чтение/Запись | Свойство
PropertyDomain | TDomain | Да | Видимо пользователю | Только для чтения | Домен
PropertyDomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
PropertyReadMember | TClassMember | Нет | Видимо пользователю | Только для чтения | Член класса для чтения
PropertyReadMemberClass | TClass | Да | Видимо пользователю | Только для чтения | Класс члена класса для чтения
PropertyWriteMember | TClassMember | Нет | Видимо пользователю | Только для чтения | Член класса для записи
PropertyName | string[64] | Да | Видимо пользователю | Только для чтения | Имя свойства
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Grouped | Boolean | Да | Видимо пользователю | Чтение/Запись | Группировать
Aggregate | TAggregateKind | Нет | Видимо пользователю | Чтение/Запись | Агрегат
SortDirection | TSortDirection | Да | Видимо пользователю | Чтение/Запись | Направление сортировки
Width | Integer | Да | Видимо пользователю | Чтение/Запись | Ширина
Filter | string[128] | Нет | Видимо пользователю | Чтение/Запись | Фильтр
ForceReadOnly | Boolean | Да | Видимо пользователю | Чтение/Запись | Только для чтения
Fixed | Boolean | Да | Видимо пользователю | Чтение/Запись | Зафиксирована
IsFilterHidden | Boolean | Да | Видимо пользователю | Чтение/Запись | Фильтр скрыт
Category | string[128] | Нет | Видимо пользователю | Чтение/Запись | Категория
Bold | Boolean | Да | Видимо пользователю | Чтение/Запись | Выделить шрифтом
DirectAction | TAction | Нет | Видимо пользователю | Чтение/Запись | Непосредственное действие
IsSpecificalyNamed | Boolean | Да | Видимо пользователю | Только для чтения | Специфическое имя

См. также
  • Класс TAction (Действия)
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Класс TView (Представления)
  • Перечисление TAggregateKind (Тип агрегата)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TSortDirection (Направление сортировки)


Конструктор Create (Конструктор колонки представления)

(одним файлом)
Конструктор Create (Конструктор колонки представления)

Конструктор класса TViewColumn.

1constructor TViewColumn.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Property: TProperty; Position: Integer; Grouped: Boolean;
4  Aggregate: TAggregateKind; SortDirection: TSortDirection; Fixed: Boolean;
5  Category: string[128]): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Property | TProperty | Да | Свойство
Position | Integer | Да | Позиция
Grouped | Boolean | Да | Группировать
Aggregate | TAggregateKind | Нет | Агрегат
SortDirection | TSortDirection | Да | Направление сортировки
Fixed | Boolean | Да | Зафиксирована
Category | string[128] | Нет | Категория

Замечания:

Создает новый объект класса TViewColumn.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TAggregateKind (Тип агрегата)
  • Перечисление TSortDirection (Направление сортировки)


Метод Change (Изменение объекта)

(одним файлом)
Метод Change (Изменение объекта)

Метод экземпляра класса TViewColumn.

procedure TViewColumn.Change(Action: TChangeAction);

Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Унаследовано от TObject.Change

См. также
  • Метод Change (Изменение объекта)
  • Перечисление TChangeAction (Действие при изменении)


Метод CreateByNames (Добавить по списку свойств)

(одним файлом)
Метод CreateByNames (Добавить по списку свойств)

Метод класса (статический метод) класса TViewColumn.

1class procedure TViewColumn.CreateByNames(Master: TCustomView;
2  Names: string[2000]);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TCustomView | Да | Мастер
Names | string[2000] | Нет | Имена свойств

См. также
  • Класс TCustomView (Абстрактное представление)


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TViewColumn.

class function TViewColumn.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Метод NameAfterProperty (Дать имя свойства)

(одним файлом)
Метод NameAfterProperty (Дать имя свойства)

Метод экземпляра класса TViewColumn.

procedure TViewColumn.NameAfterProperty;

Метод скрыт от пользователя.

Метод не имеет параметров.


Класс TViewCondition (Условия отбора)

(раздел целиком) (одним файлом)
Класс TViewCondition (Условия отбора)

Класс TObject (Объекты)Класс TCustomView (Абстрактное представление)

Объекты класса образуют иерархию.

  • Свойства
  • Конструктор Create (Конструктор условия отбора)
См. также
  • Класс TCustomView (Абстрактное представление)
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TViewCondition:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
LinkedClass | TClass | Нет | Видимо пользователю | Чтение/Запись | Присоединяемый класс
MasterProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-главное
DetailProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Свойство-подчиненное
LinkedOption | TOption | Нет | Видимо пользователю | Чтение/Запись | Присоединенная настройка
LinkedOptionName | string[64] | Да | Видимо пользователю | Только для чтения | Имя присоединяемой настройки
LinkedOptionProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Свойство присоединенной настройки
Expression | clob | Нет | Видимо пользователю | Чтение/Запись | Выражение условия
Negation | Boolean | Да | Видимо пользователю | Чтение/Запись | Отрицание
LinkNonRequired | Boolean | Да | Видимо пользователю | Чтение/Запись | Присоединять необязательное свойство
LinkedProfile | TProfile | Нет | Видимо пользователю | Чтение/Запись | Присоединенный профиль

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TCustomView (Абстрактное представление)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TOption (Настройки)
  • Класс TProfile (Профили)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор условия отбора)

(одним файлом)
Конструктор Create (Конструктор условия отбора)

Конструктор класса TViewCondition.

1constructor TViewCondition.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  LinkedClass: TClass; MasterProperty: TProperty; DetailProperty: TClassMember;
4  LinkedOption: TOption; LinkedOptionProperty: TClassMember; Expression: clob;
5  Negation: Boolean; LinkNonRequired: Boolean; LinkedProfile: TProfile): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
LinkedClass | TClass | Нет | Присоединяемый класс
MasterProperty | TProperty | Нет | Свойство-главное
DetailProperty | TClassMember | Нет | Свойство-подчиненное
LinkedOption | TOption | Нет | Присоединенная настройка
LinkedOptionProperty | TClassMember | Нет | Свойство присоединенной настройки
Expression | clob | Нет | Выражение условия отбора
Negation | Boolean | Да | Отрицание
LinkNonRequired | Boolean | Да | Присоединять необязательное свойство
LinkedProfile | TProfile | Нет | Присоединенный профиль

Замечания:

Создает новый объект класса TViewCondition.

См. также
  • Класс TClass (Классы)
  • Класс TClassMember (Члены класса)
  • Класс TObject (Объекты)
  • Класс TOption (Настройки)
  • Класс TProfile (Профили)
  • Класс TProperty (Свойства)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Класс TViewPresentation (Виды)

(раздел целиком) (одним файлом)
Класс TViewPresentation (Виды)

Класс TObject (Объекты)Класс TView (Представления)Класс TViewPresentationAccess (Доступ к видам)Класс TViewPresentationColumn (Колонки вида)

Имена объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор вида)
  • Метод GetIsAccessible (Проверка доступности)
  • Метод Save (Сохранить)
См. также
  • Класс TObject (Объекты)
  • Класс TView (Представления)


Свойства

(одним файлом)
Свойства

Свойства класса TViewPresentation:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
ChildrenMinimized | Boolean | Да | Видимо пользователю | Чтение/Запись | Дочерние представления минимизированы
Default | Boolean | Да | Видимо пользователю | Чтение/Запись | Использовать по умолчанию
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения | Доступен
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Класс TView (Представления)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор вида)

(одним файлом)
Конструктор Create (Конструктор вида)

Конструктор класса TViewPresentation.

1constructor TViewPresentation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer;
4  ChildrenMinimized: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция
ChildrenMinimized | Boolean | Да | Дочерние представления минимизированы

Замечания:

Создает новый объект класса TViewPresentation.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetIsAccessible (Проверка доступности)

(одним файлом)
Метод GetIsAccessible (Проверка доступности)

Метод экземпляра класса TViewPresentation.

function TViewPresentation.GetIsAccessible: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод Save (Сохранить)

(одним файлом)
Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentation.

1class function TViewPresentation.Save(Master: TObject;
2  Description: string[128]; ChildrenMinimized: Boolean): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Да | Мастер
Description | string[128] | Да | Наименование
ChildrenMinimized | Boolean | Да | Дочерние представления минимизированы

Замечания:

Возвращает значение типа TObject.

См. также
  • Класс TObject (Объекты)


Класс TViewPresentationAccess (Доступ к видам)

(раздел целиком) (одним файлом)
Класс TViewPresentationAccess (Доступ к видам)

Класс TAccessItem (Элементы доступа)Класс TObject (Объекты)Класс TViewPresentation (Виды)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Конструктор Create (Конструктор доступа к виду)
См. также
  • Класс TAccessItem (Элементы доступа)
  • Класс TViewPresentation (Виды)


Конструктор Create (Конструктор доступа к виду)

(одним файлом)
Конструктор Create (Конструктор доступа к виду)

Конструктор класса TViewPresentationAccess.

1constructor TViewPresentationAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
SecurityAccount | TSecurityAccount | Да | Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TViewPresentationAccess.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор элемента доступа)


Класс TViewPresentationColumn (Колонки вида)

(раздел целиком) (одним файлом)
Класс TViewPresentationColumn (Колонки вида)

Класс TObject (Объекты)Класс TViewPresentation (Виды)

Имена объектов класса генерируются.

  • Свойства
  • Конструктор Create (Конструктор колонки вида)
  • Метод AddColumns (Создать колонки)
  • Метод Save (Сохранить)
См. также
  • Класс TObject (Объекты)
  • Класс TViewPresentation (Виды)


Свойства

(одним файлом)
Свойства

Свойства класса TViewPresentationColumn:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Column | TViewColumn | Да | Видимо пользователю | Только для чтения | Колонка представления
Presentation | TViewPresentation | Да | Скрыто от пользователя | Только для чтения | Вид
View | TObject | Да | Скрыто от пользователя | Только для чтения | Представление
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения | Доступен
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Grouped | Boolean | Да | Видимо пользователю | Чтение/Запись | Сгруппирована
Aggregate | TAggregateKind | Нет | Видимо пользователю | Чтение/Запись | Агрегат
SortDirection | TSortDirection | Да | Видимо пользователю | Чтение/Запись | Направление сортировки
Width | Integer | Да | Видимо пользователю | Чтение/Запись | Ширина
Filter | string[128] | Нет | Видимо пользователю | Чтение/Запись | Фильтр
Fixed | Boolean | Да | Видимо пользователю | Чтение/Запись | Зафиксирована
Category | string[128] | Нет | Видимо пользователю | Чтение/Запись | Категория

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Класс TViewColumn (Колонки представлений)
  • Класс TViewPresentation (Виды)
  • Перечисление TAggregateKind (Тип агрегата)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TSortDirection (Направление сортировки)


Конструктор Create (Конструктор колонки вида)

(одним файлом)
Конструктор Create (Конструктор колонки вида)

Конструктор класса TViewPresentationColumn.

1constructor TViewPresentationColumn.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Column: TViewColumn; Position: Integer;
4  Grouped: Boolean; Aggregate: TAggregateKind; SortDirection: TSortDirection;
5  Width: Integer; Filter: string[128]; Fixed: Boolean;
6  Category: string[128]): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Column | TViewColumn | Да | Колонка
Position | Integer | Да | Позиция
Grouped | Boolean | Да | Группировать
Aggregate | TAggregateKind | Нет | Агрегат
SortDirection | TSortDirection | Да | Направление сортировки
Width | Integer | Да | Ширина
Filter | string[128] | Нет | Фильтр
Fixed | Boolean | Да | Зафиксирована
Category | string[128] | Нет | Категория

Замечания:

Создает новый объект класса TViewPresentationColumn.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TViewColumn (Колонки представлений)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TAggregateKind (Тип агрегата)
  • Перечисление TSortDirection (Направление сортировки)


Метод AddColumns (Создать колонки)

(одним файлом)
Метод AddColumns (Создать колонки)

Метод класса (статический метод) класса TViewPresentationColumn.

class procedure TViewPresentationColumn.AddColumns(Master: TViewPresentation);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TViewPresentation | Да | Мастер

См. также
  • Класс TViewPresentation (Виды)


Метод Save (Сохранить)

(одним файлом)
Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentationColumn.

1class function TViewPresentationColumn.Save(Master: TViewPresentation;
2  Column: TViewColumn; Position: Integer; Grouped: Boolean;
3  Aggregate: TAggregateKind; SortDirection: TSortDirection; Width: Integer;
4  Filter: string[128]; Fixed: Boolean; Category: string[128]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TViewPresentation | Да | Мастер
Column | TViewColumn | Да | Колонка
Position | Integer | Да | Позиция
Grouped | Boolean | Да | Группировать
Aggregate | TAggregateKind | Нет | Агрегат
SortDirection | TSortDirection | Да | Направление сортировки
Width | Integer | Да | Ширина
Filter | string[128] | Нет | Фильтр
Fixed | Boolean | Да | Зафиксирована
Category | string[128] | Нет | Категория

Замечания:

Возвращает значение типа TObject.

См. также
  • Класс TObject (Объекты)
  • Класс TViewColumn (Колонки представлений)
  • Класс TViewPresentation (Виды)
  • Перечисление TAggregateKind (Тип агрегата)
  • Перечисление TSortDirection (Направление сортировки)


Класс TVisualGroup (Визуальные группы)

(раздел целиком) (одним файлом)
Класс TVisualGroup (Визуальные группы)

Класс TObject (Объекты)Класс TVisualGroupItem (Элемент визуальной группы)Класс TVisualGroupForm (Форма визуальной группы)Класс TVisualGroupAccess (Доступ к визуальным группам)Класс TVisualGroupRoutine (Подпрограмма визуальной группы)

Объекты класса образуют иерархию.

  • Свойства
  • Конструктор Create (Конструктор визуальной группы)
  • Метод GetIsAccessible (Доступна)
  • Метод GetNextPos (Следующая позиция)
См. также
  • Класс TObject (Объекты)


Свойства

(одним файлом)
Свойства

Свойства класса TVisualGroup:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись | Изображение
IsAccessible | Boolean | Да | Скрыто от пользователя | Только для чтения | Доступна
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
Collapsed | Boolean | Да | Видимо пользователю | Чтение/Запись | Свернута

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор визуальной группы)

(одним файлом)
Конструктор Create (Конструктор визуальной группы)

Конструктор класса TVisualGroup.

1constructor TVisualGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Image: blob; Position: Integer; Scope: TScope; Collapsed: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Image | blob | Нет | Изображение
Position | Integer | Да | Позиция
Scope | TScope | Да | Область видимости
Collapsed | Boolean | Да | Свернута

Замечания:

Создает новый объект класса TVisualGroup.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TScope (Область видимости)


Метод GetIsAccessible (Доступна)

(одним файлом)
Метод GetIsAccessible (Доступна)

Метод экземпляра класса TVisualGroup.

function TVisualGroup.GetIsAccessible: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroup.

class function TVisualGroup.GetNextPos(Parent: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Parent | TObject | Нет | Родитель

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Класс TVisualGroupAccess (Доступ к визуальным группам)

(раздел целиком) (одним файлом)
Класс TVisualGroupAccess (Доступ к визуальным группам)

Класс TAccessItem (Элементы доступа)Класс TObject (Объекты)Класс TVisualGroup (Визуальные группы)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

  • Конструктор Create (Конструктор доступа к визуальной группе)
См. также
  • Класс TAccessItem (Элементы доступа)
  • Класс TVisualGroup (Визуальные группы)


Конструктор Create (Конструктор доступа к визуальной группе)

(одним файлом)
Конструктор Create (Конструктор доступа к визуальной группе)

Конструктор класса TVisualGroupAccess.

1constructor TVisualGroupAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TVisualGroup;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TVisualGroup | Да | Группа доступа
Accessor | TSecurityAccount | Нет | Унаследовано от TObject.Create
SecurityAccount | TSecurityAccount | Да | Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TVisualGroupAccess.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TVisualGroup (Визуальные группы)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор элемента доступа)


Класс TVisualGroupForm (Форма визуальной группы)

(раздел целиком) (одним файлом)
Класс TVisualGroupForm (Форма визуальной группы)

Диаграмма Класс TVisualGroupItem (Элемент визуальной группы)Класс TObject (Объекты)Класс TVisualGroup (Визуальные группы)

  • Свойства
  • Конструктор Create (Конструктор формы визуальной группы)
См. также
  • Класс TVisualGroup (Визуальные группы)
  • Класс TVisualGroupItem (Элемент визуальной группы)


Свойства

(одним файлом)
Свойства

Свойства класса TVisualGroupForm:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TVisualGroupItem
Comment | clob | Нет | Видимо пользователю | Чтение/Запись
Form | TForm | Да | Видимо пользователю | Чтение/Запись | Форма
Image | blob | Нет | Видимо пользователю | Чтение/Запись | Изображение

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TForm (Формы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Класс TVisualGroup (Визуальные группы)
  • Класс TVisualGroupItem (Элемент визуальной группы)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор формы визуальной группы)

(одним файлом)
Конструктор Create (Конструктор формы визуальной группы)

Конструктор класса TVisualGroupForm.

1constructor TVisualGroupForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob; Form: TForm): TObject;

Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TVisualGroupItem.Create
Comment | clob | Нет
Form | TForm | Да | Форма

Замечания:

Создает новый объект класса TVisualGroupForm.

См. также
  • Класс TClass (Классы)
  • Класс TForm (Формы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор элемента визуальной группы)


Класс TVisualGroupItem (Элемент визуальной группы)

(раздел целиком) (одним файлом)
Класс TVisualGroupItem (Элемент визуальной группы)

Диаграмма Класс TObject (Объекты)Класс TVisualGroup (Визуальные группы)

  • Свойства
  • Конструктор Create (Конструктор элемента визуальной группы)
  • Метод GetNextPos (Следующая позиция)
См. также
  • Класс TObject (Объекты)
  • Класс TVisualGroup (Визуальные группы)


Свойства

(одним файлом)
Свойства

Свойства класса TVisualGroupItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Comment | clob | Нет | Видимо пользователю | Чтение/Запись | Комментарий

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Класс TVisualGroup (Визуальные группы)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор элемента визуальной группы)

(одним файлом)
Конструктор Create (Конструктор элемента визуальной группы)

Конструктор класса TVisualGroupItem.

1constructor TVisualGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция
Comment | clob | Нет | Комментарий

Замечания:

Создает новый объект класса TVisualGroupItem.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)


Метод GetNextPos (Следующая позиция)

(одним файлом)
Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroupItem.

class function TVisualGroupItem.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.

См. также
  • Класс TObject (Объекты)


Класс TVisualGroupRoutine (Подпрограмма визуальной группы)

(раздел целиком) (одним файлом)
Класс TVisualGroupRoutine (Подпрограмма визуальной группы)

Диаграмма Класс TVisualGroupItem (Элемент визуальной группы)Класс TObject (Объекты)Класс TVisualGroup (Визуальные группы)

  • Свойства
  • Конструктор Create (Конструктор подпрограммы визуальной группы)
См. также
  • Класс TVisualGroup (Визуальные группы)
  • Класс TVisualGroupItem (Элемент визуальной группы)


Свойства

(одним файлом)
Свойства

Свойства класса TVisualGroupRoutine:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TVisualGroupItem
Comment | clob | Нет | Видимо пользователю | Чтение/Запись
Routine | TRoutine | Да | Видимо пользователю | Чтение/Запись | Подпрограмма

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Класс TVisualGroup (Визуальные группы)
  • Класс TVisualGroupItem (Элемент визуальной группы)
  • Перечисление TReplicationStatus (Статус репликации)


Конструктор Create (Конструктор подпрограммы визуальной группы)

(одним файлом)
Конструктор Create (Конструктор подпрограммы визуальной группы)

Конструктор класса TVisualGroupRoutine.

1constructor TVisualGroupRoutine.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Comment: clob;
4  Routine: TRoutine): TObject;

Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TVisualGroupItem.Create
Comment | clob | Нет
Routine | TRoutine | Да | Подпрограмма

Замечания:

Создает новый объект класса TVisualGroupRoutine.

См. также
  • Класс TClass (Классы)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор элемента визуальной группы)


Класс TWordAsyncTask (Задачи отложенного выполнения отчетов Word)

(раздел целиком) (одним файлом)
Класс TWordAsyncTask (Задачи отложенного выполнения отчетов Word)

Класс TAsyncTask (Задачи отложенного выполнения)Класс TObject (Объекты)

Объекты класса не именованы.

  • Свойства
  • Конструктор Create (Конструктор задачи отложенного выполнения отчетов Word)
См. также
  • Класс TAsyncTask (Задачи отложенного выполнения)


Свойства

(одним файлом)
Свойства

Свойства класса TWordAsyncTask:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Видимо пользователю | Только для чтения | Унаследовано от TAsyncTask
Created | datetime | Да | Видимо пользователю | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Status | TAsyncTaskStatus | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TAsyncTask
Routine | TRoutine | Да | Видимо пользователю | Чтение/Запись
RoutineClass | TClass | Да | Скрыто от пользователя | Только для чтения
Language | TLanguage | Да | Видимо пользователю | Чтение/Запись
Handler | TAsyncHandler | Да | Видимо пользователю | Чтение/Запись
FormView | TFormView | Нет | Видимо пользователю | Чтение/Запись
Object | TObject | Нет | Видимо пользователю | Чтение/Запись
Started | datetime | Нет | Видимо пользователю | Чтение/Запись
Finished | datetime | Нет | Видимо пользователю | Чтение/Запись
Duration | time | Нет | Видимо пользователю | Только для чтения
Bold | Boolean | Да | Скрыто от пользователя | Только для чтения
RowColor | TRowColor | Нет | Скрыто от пользователя | Только для чтения
Group | TAsyncTask | Нет | Видимо пользователю | Только для чтения
GroupContentReady | Boolean | Да | Скрыто от пользователя | Только для чтения
Format | TWordOutputFormat | Да | Видимо пользователю | Чтение/Запись | Формат

См. также
  • Класс TAsyncHandler (Обработчики отложенного выполнения)
  • Класс TAsyncTask (Задачи отложенного выполнения)
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TFormView (Представления формы)
  • Класс TLanguage (Языки)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TAsyncTaskStatus (Состояние задачи отложенного выполнения)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TRowColor (Цвет строки таблицы)
  • Перечисление TWordOutputFormat (Формат результата отчета Word)


Конструктор Create (Конструктор задачи отложенного выполнения отчетов Word)

(одним файлом)
Конструктор Create (Конструктор задачи отложенного выполнения отчетов Word)

Конструктор класса TWordAsyncTask.

1constructor TWordAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TWordOutputFormat): TObject;

Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Routine | TRoutine | Да | Унаследовано от TAsyncTask.Create
Object | TObject | Нет
FormView | TFormView | Нет
Handler | TAsyncHandler | Да
Language | TLanguage | Да
Format | TWordOutputFormat | Да | Формат

Замечания:

Создает новый объект класса TWordAsyncTask.

См. также
  • Класс TAsyncHandler (Обработчики отложенного выполнения)
  • Класс TClass (Классы)
  • Класс TFormView (Представления формы)
  • Класс TLanguage (Языки)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор задачи отложенного выполнения)
  • Конструктор Create (Конструктор объекта)
  • Перечисление TWordOutputFormat (Формат результата отчета Word)


Класс TWordTemplate (Шаблоны отчетов Word)

(раздел целиком) (одним файлом)
Класс TWordTemplate (Шаблоны отчетов Word)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

  • Свойства
  • Конструктор Create (Конструктор шаблона отчета Word)
  • Метод Ole-объекта CheckWordTemplate (Проверить шаблон отчетов Word)
См. также
  • Класс TClass (Классы)
  • Класс TRoutine (Подпрограмма)


Свойства

(одним файлом)
Свойства

Свойства класса TWordTemplate:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
TemplateData | blob | Нет | Видимо пользователю | Чтение/Запись | Данные шаблона
MacroName | string[128] | Нет | Видимо пользователю | Чтение/Запись | Имя макроса
IsInteractive | Boolean | Да | Видимо пользователю | Чтение/Запись | Интерактивный

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор шаблона отчета Word)

(одним файлом)
Конструктор Create (Конструктор шаблона отчета Word)

Конструктор класса TWordTemplate.

1constructor TWordTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  MacroName: string[128]; IsInteractive: Boolean): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
TemplateData | blob | Нет | Данные шаблона
MacroName | string[128] | Нет | Имя макроса
IsInteractive | Boolean | Да | Интерактивный

Замечания:

Создает новый объект класса TWordTemplate.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор подпрограммы)
  • Конструктор Create (Конструктор члена класса)
  • Перечисление TScope (Область видимости)


Метод Ole-объекта CheckWordTemplate (Проверить шаблон отчетов Word)

(одним файлом)
Метод Ole-объекта CheckWordTemplate (Проверить шаблон отчетов Word)

Метод Ole-объекта класса TWordTemplate.

Метод Ole-объекта не имеет параметров.


Класс TXSLTTemplate (Шаблоны отчетов XSLT)

(раздел целиком) (одним файлом)
Класс TXSLTTemplate (Шаблоны отчетов XSLT)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

  • Свойства
  • Конструктор Create (Конструктор шаблона отчета XSLT)
  • Метод Ole-объекта CheckXSLTTemplate (Проверить шаблон отчетов XSLT)
См. также
  • Класс TClass (Классы)
  • Класс TRoutine (Подпрограмма)


Свойства

(одним файлом)
Свойства

Свойства класса TXSLTTemplate:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
TemplateData | clob | Нет | Видимо пользователю | Чтение/Запись | Данные шаблона
FunctionName | string[128] | Нет | Видимо пользователю | Чтение/Запись | Имя функции

См. также
  • Класс TClass (Классы)
  • Класс TDataBase (Базы данных)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TRoutine (Подпрограмма)
  • Класс TSecurityAccount (Роли безопасности)
  • Класс TUser (Пользователи)
  • Перечисление TReplicationStatus (Статус репликации)
  • Перечисление TScope (Область видимости)


Конструктор Create (Конструктор шаблона отчета XSLT)

(одним файлом)
Конструктор Create (Конструктор шаблона отчета XSLT)

Конструктор класса TXSLTTemplate.

1constructor TXSLTTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: clob;
6  FunctionName: string[128]): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
TemplateData | clob | Нет | Данные шаблона
FunctionName | string[128] | Нет | Имя вызываемой функции

Замечания:

Создает новый объект класса TXSLTTemplate.

См. также
  • Класс TClass (Классы)
  • Класс TDomain (Домены)
  • Класс TObject (Объекты)
  • Класс TSecurityAccount (Роли безопасности)
  • Конструктор Create (Конструктор объекта)
  • Конструктор Create (Конструктор подпрограммы)
  • Конструктор Create (Конструктор члена класса)
  • Перечисление TScope (Область видимости)


Метод Ole-объекта CheckXSLTTemplate (Проверить шаблон отчетов XSLT)

(одним файлом)
Метод Ole-объекта CheckXSLTTemplate (Проверить шаблон отчетов XSLT)

Метод Ole-объекта класса TXSLTTemplate.

Метод Ole-объекта не имеет параметров.


Терминология

(одним файлом)
Терминология

Интеграция - комплекс работ по настройке механизмов взаимодействия между различными учетными системами, которые функционируют независимо друг от друга в одной организационной структуре ("лоскутная" автоматизация).

Реплика - копия объекта (например, базы данных), обновляемая автоматически при обновлении оригинала.

Модальная форма - подчиененная форма, вызываемая из процедуры, накладывающая ограничения на использование процедуры пока модальная форма не будет закрыта.


Облачные вычисления

(одним файлом)
Облачные вычисления

Под терминами "Облака", "Облачные вычисления" подразумеваются способы организации распределенных вычислений данных, функций, всего того, что требуется для автоматизации бизнес-процессов. Реализация подобной технологии иначе называется DNS (Domain Name System - система доменных имен). Упрощенно можно сказать, что существует база данных, где каждому зарегистрированному доменному имени соответствует некий IP-адрес. Также в записях этой базы данных предусмотрены настройки, указывающие на использование записей для различных действий (для электронной почты, для web и т.д.). База данных является распределенной, она хранится на множестве серверов в сети Internet одновременно, и каждый из этих серверов по стандартному описанному протоколу отдает записи этой базы данных. При необходимости можно осуществить сбор всей информации DNS, однако данные меняются настолько быстро, что в результате такой операции будут получены устаревшие значения, не соответствующие реальным.

В то же время с данными DNS вполне допустимо производить кэширование, периодическое обновление и т.п. Смысл "облачной" технологии в том, что данные заменяются на функции доступа к ним. Таким образом, нет необходимости хранить данные о соответствии DNS-имен IP-адресам. При этом всегда доступна информация о том как и куда необходимо обратиться с запросом данных и как использовать полученный ответ.

Одной из причин внедрения "облачных" технологий на предприятиях заказчика зачастую является имиджевый аспект, когда во главу угла ставится погоня за новыми технологиями на предприятии.

Для понимания, приведем пример одного из московских ВУЗов с широкой сетью филиалов.

В начале создания внутрикорпоративной системы ВУЗа ее построение происходило постепенно, по частям. Было создано централизованное хранилище всех данных, база данных с необходимыми данными и бизнес-функциями, которые выполнялись над этими данными. Все пользователи системы осуществляли свою работу из единой локальной сети с включенной в нее базой данных. Соединения осуществлялись по стандартному потоколу, предоставляемому СУБД. Этот протокол требовал низколатентных соединений и пользователи были удовлетворены, однако существловали достаточно критичные ограничения на доступ к базе данных. Данная технология представляла собой технологию "клиент-сервер".

В дальнейшем потребовалось распространение решения для удаленных филиалов ВУЗа. Было принято внутреннее решение IT-служб ВУЗа о разделении базы данных, то есть каждый филиал получил собственную базу данных (изначально пустую) и начал работать с ней. Попытка синхронизации справочников собственными усилиями не удалась. Синхронизация данных - удалась частично. Сопутствующие сопровождению системы задачи (например, распространение обновлений и др.) решались с переменным успехом.

В результате было принято решение о внедрении "облачных" технологий. Для реализации использовались сервера приложений Платформы "Мельница Данных". С их помощью были построены точки входа в единое хранилище данных. Все данные были объединены в одну централизованную базу данных и доступ к ней осуществляется каждым филиалом через собственный "обработчик", созданный для конкретного филиала. В итоге каждому филиалу достаточно знать только точку входа, через которую доступна соответствующая функция Системы. При этом пользователей филиала не должно интересовать, куда перенаправляются их запросы и какие действия осуществляются в базе данных. В следствии такого внедрения отпала необходимость в дополнительных администраторах Системы, в отслеживании вычислительных мощностей и т.д.

Вопросы по разграничению доступа, настроек и т.п. в данный момент решаются централизованно.

Простым и правильным способом организации корпоративных "облачных" SaaS-технологий будет поддержка такого решения в пределах одной организации.

Другой реальный пример внедрения "облачных" технологий - другой крупный ВУЗ:

При внедрении Системы не оказалось сил, способных осуществлять обслуживание серверных мощностей. В итоге компания "Мельница Технолгий" на собственных подконтрольных площадях самостоятельно развернула всю инфраструктуру, требующуюся для функционирования базы данных ВУЗа. Далее, на базе решения сервер приложений Платформы были созданы точки входа, через которые все функции Системы, а также все данные были доступны пользователям ВУЗа.

Основным аргументом представителей ВУЗа против подобного внедрения был тот факт, что данные хранятся не на собственных мощностях, а у стороннего поставщика услуг. Для разрешения спорного вопроса, каждую ночь на мощностях компании "Мельница Технологий" автоматически создается реплика с самыми актуальными данными. Таким образом ВУЗ всегда имеет в своем распоряжении ежедневный backup для оперативного развертывания в случае форс-мажора.

Из примера понятно, что компания "Мельница Технологий" имеет все возможности и ресурсы для подключения новых пользователей "облака", которые не желают или не имеют возможности заниматься обслуживанием Системы. При этом на заказчика не ложатся затраты на закупку и развертывание инфраструктуры и базы данных, на содержание администраторов Системы.

Второй частой причиной организации "облака" на предприятии является насущная необходимость. В этом случае Заказчик понимает технологию "облака", знает какие бизнес-функции могут быть реализованы, при этом предприятие имеет широкую разветвленную сеть удаленных филиалов, нуждающихся в доступе к централизованным данным.

Следует обратить внимание, что понятия "Облако", "Облачные вычисления" носят сугубо маркетинговый характер и не несут какой-то четкой логики построения решений. Технология заключается только в создании точек входа, за которыми функции распределяются по собственным алгоритмам, которые не должны интересовать конечного пользователя. Данные алгоритмы всегда могут быть изменены в зависимости от необходимости. Так, при возрастании нагрузки на "облако", она может быть перераспределена по тому количеству серверов, которое необходимо и удобно.


OLTP и OLAP

(одним файлом)
OLTP и OLAP

OLTP (OnLine Transaction Processing) - обработка транзакций онлайн.

Задача, которая решается с помощью OLTP-метода называется здесь и дальше "учет". Т.е. это в первую очередь учетные задачи. Характерным элементом управления решенной OLTP-задачи является так называемый "grid" - таблица, состоящая из колонок и строк.

Когда ставится и решается задача постановки учета чего бы то ни было, например, продаж мороженого, пользователь должен увидеть в результате "grid" (таблицу, табличное представление), где каждая строка соответствует одному объекту учета, в данном случае - продаже мороженого, а каждый столбец соответствует атрибуту этого самого элемента учета. В нашем случае, с продажами мороженого это точка, которая продала, сорт, количество, цена, сумма продажи и т.д.

Сорт мороженного | Точка продаж | Кол-во | Цена | Сумма
Пломбир | ул. Ленина | 50 | 20 | 1000
Ленинградское | ул. Ленина | 20 | 18 | 360
Эскимо | ул. Ленина | 100 | 23 | 2300
Лакомка | ул. Ленина | 30 | 25 | 750
В стаканчике | ул. Ленина | 150 | 12 | 1800

Эта таблица должна храниться в базе данных и пользователю не важно при помощи какой технологии построена база данных (на реляционных принципах, на объектных принципах или других). Важно то, что клиентское приложение, с которым пользователь непосредственно взаимодействует, может получить данные и показать их в виде таблицы.

Как правило, у пользователя есть несколько стандартных действий для управления данными в таблице - сортировка, группировка, отбор по колонкам, по дополнительным критериям. Все эти действия предназначены быстрого поиска ошибок в данных. Таким образом поиск ошибок учета осуществляется именно в таблицах. Для исправления ошибок используются следующие методы:

1. В таблице, соответствующая ячейка переводится в режим редактирования, данные изменяются непосредственно в ней, нажатием клавиши Enter подтверждается изменение, и, если новое значение удовлетворяет внутренним ограничениям Системы, то оно будет записано в базу данных.

2. Исправление может рассматриваться как операция, в этом случае: выделяется один или несколько объектов таблицы, т.е. одна или несколько строчек, вызывается действие (либо кнопкой в панели инструментов, либо через контекстное меню, либо каким-то более экзотическим способом). Будет показана модальная форма ввода значений и параметров. При этом пользователь не сможет продолжить работы с системой пока эта форма не будет закрыта после внесения изменений или без них. Только после закрытия модальной формы действие начинает выполняться.

3. Для Платформы "Мельница Данных" также разработан элемент управления, который называется "инспектор объектов". Он используется для установки одинаковых значений для выбранных в таблице однородных объектов. Также инспектор объектов используется, для удобного просмотра всех атрибутов объекта, так как зачастую таблица содержит такое большое количество колонок, что работа с ними в таблице.

После поиска ошибок какие-то из объектов таблицы участвуют в дальнейших бизнес-процессах, которые должны быть реализованы, какие-то не участвуют и просто хранятся.

Для конечного пользователя простой ввод бизнес-данных в систему учета не имеет никакого практического смысла без возможности дальнейшей обработки и формирования отчетности.

Первичные данные, полученные в результате решения OLTP-задачи, должны использоваться для решения бизнес-задач.

OLАP (Online Analisys Processing) - аналитическая обработка в реальном времени.

В результате решения задачи OLAP система может получить следующее:

1. Результаты обработки, готовые к публикации.

2. Информация для дальнейшего принятия управленческих решений.

Данные, полученные в результате решения OLTP-задачи, поступают на вход и рассматриваются в качестве входных данных для задачи OLАP. Такие данные принято называть "Фактами". Факты должны быть предварительно выверены, подготовлены. В зависимости от разработанных стандартов для Системы не все данные могут быть переданы в OLAP-задачу в качестве фактов. Для данных могут использоваться дополнительные признаки, такие как: "Выверено", "Обработано", "Проверено", "Утверждено". Соответственно на вход OLAP-задачи можно направить данные, для которых один, несколько или все признаки (определяется логикой при разработке) имеют значение "Истина". Факты, которые попали на вход OLAP-задачи, составляют таблицу фактов. В таблице фактов выделяются факты, которые являются "мерой" (measure) или "показателем" (index).

Для примера, самый простой показатель - это количество самих фактов, а также средняя сумма, дисперсия, любой агрегат над этим значением.

Далее выверяют измерение анализа - это, как правило, ссылки на справочные таблицы, и по этим справочным таблицам строится список соответствующий измерению (dimension). На основании таблицы фактов и информации о том, что у нас является показателем, что у нас является измерениями, строится так называемый "куб". Структура данных "куба" сложная. Для наглядности, ниже приведен "куб" для нашего простого примера продаж мороженного:

В качестве меры выбрано количество сумма продаж по деньгам, а в качестве измерения - сорт мороженого, дата и точка, которая эту продажу осуществила. По первой оси - дата. По этой оси выстраиваются все дни соответствующего периода, 01.01.2012, 02.01.2012 и так далее. За год - 365 точек. По другой оси выстраиваются все имеющиеся в продаже сорта. По третьей оси мы ставим точки, соответствующие точкам продаж. В получившемся кубе, в каждой ячейке пишем общую сумму продаж этого сорта мороженного в этой точке и за этот день. В каждой из ячеек может быть несколько различных значений измерений. В этом случае ячейка делится на несколько частей. Например, для примера с мороженным, ячейка также может содержать, кроме суммы продаж, количество проданных единиц данного сорта мороженного. В более сложных случаях, количество показателей может быть большим чем три, как в примере.

Для хранения описанной информации используется специализированное многомерное хранилище. Платформа "Мельница Данных" аккумулирует такие многомерные хранилища с помощью реляционных структур.

Второе требование для OLAP задачи - визуализация данных. Табличный вид описанного выше "куба" это сводная таблица, позволяющая группировать измерения, а также показывать факты, то есть значения показателей в ячейках. Для таблицы доступны различные варианты просмотра данных в различных разрезах.

Следующее требование - публикация данных. Здесь нужно отметить, что публикация одного единственного среза данных не несет большого смысла. С точки зрения конечного пользователя, оптимальным вариантом публикации будет являться такой вид на данные, при котором пользователь может "вживую" менять измерения, перетаскивать их и т.д. Такая публикация может быть полезна при принятии управленческих решений руководством предприятия, а также будет удобна для анализа конечными пользователями. Кроме того, для публикации активно используются всевозможные графики, диаграммы, построенные по актуальным данным.

Достаточно востребованным для конечных пользователей является также свойство Системы, называемое Drill Down (проваливание). Данное свойство подразумевает, что пользователь выбрав каким-либо образом значение показателя, имеет возможность посмотреть, каким образом этот показатель был посчитан, на основании чего, и собственно, на основании каких конкретно данных был сформирован этот показатель. Для этого OLАP-системе необходим доступ к первичным данным. Такое требование не является существенной проблемой, так как у хранилище одно и то же и для OLTP-задачи и для OLАP-задачи.


RESTful-service стандартного обработчика

(раздел целиком) (одним файлом)
RESTful-service стандартного обработчика

Функции стандартного обработчика сервера приложений доступны при обращении по следующим url:

Схема://хост/Имя обработчика/Функция сервиса.расширение
Url вызова RESTful-сервиса

Запрос к функциям сервиса может содержать один параметр с именем query, который может быть передан методом GET или методом POST.

Ниже рассмотрены конкретные функции, которые можно вызывать.

  • Функция accesslist
  • Функция batch
  • Функция bulkinsert
  • Функция closecursor
  • Функция commonproperties
  • Функция cursor
  • Функция excelreport
  • Функция execute
  • Функция executeoleobjectmethod
  • Функция getblob
  • Функция imagelist
  • Функция loadexternaldata
  • Функция partitions
  • Функция paste
  • Функция pdfreport
  • Функция postblob
  • Функция routinelog
  • Функция rtti
  • Функция selectblob
  • Функция selectedbuffer
  • Функция selectionchanged
  • Функция sessionlogoff
  • Функция setpropvalue
  • Функция storeexternaldata
  • Функция sysinfo
  • Функция timebias
  • Функция wordreport
  • Функция xsltreport


Функция accesslist

(одним файлом)
Функция accesslist

Функция accesslist позволяет получить список всех ролей безопасности, в которые включен текущий пользователь. В список войдут идентификаторы всех ролей и идентификатор пользователя. В случае, если вызов выполняется пользователем, являющимся администратором БД, то возвращаемый список будет пустым. Это означает, что для пользователя нет ограничений в доступе к данным и функциональности системы.

Допустимое расширение .xml.

Функция не имеет параметров.

Функция возвращает ответ в виде XML-документа с элементом data, имеющим набор подчиненных узлов row, соответствующих каждому объекту полученного списка. Каждый узел row содержит в качестве значения идентификатор (ID) роли или пользователя.

Пример запроса:
https://techmill.ru/demo/accesslist.xml
Пример ответа:
01<data eof="1">
02  <row>
03    <ID type="int64">460</ID>
04  </row>
05  <row>
06    <ID type="int64">70540</ID>
07  </row>
08  <row>
09    <ID type="int64">891142</ID>
10  </row>
11  <row>
12    <ID type="int64">2533983</ID>
13  </row>
14  <row>
15    <ID type="int64">741846296</ID>
16  </row>
17</data>


Функция batch

(одним файлом)
Функция batch

Функция batch дает возможность однократным ее вызовом отправить на выполнение несколько запросов на получение данных или на вызов методов и получить набор запрошенных данных и результаты выполнения методов.

Допустимые расширения:

  • .xml - для получения ответа в формате xml
  • .js/.json - для получения ответа в формате JSON

Функция осуществляет серию запросов и/или вызовов методов и возвращает данные, соответствующие структуре и условиям переданных запросов и вызовов. Запросы и вызовы передаются в виде параметра GET или POST-запроса с именем query. Значение параметра представляет собой xml-документ следующей структуры:

01<root>
02  <query  class="TRemoteUser">
03    <item part="0" name="FullName"/>
04    <item part="1" name="ID" value="1320218"/>
05  </query>
06  <query  class="TPerson">
07    <item part="0" name="LastName"/>
08    <item part="0" name="FirstName"/>
09    <item part="1" name="ID" value="5652545"/>
10  </query>
11  <execute class="TSchoolAbiturSt" method="RegCount">
12    <row>
13      <AdmissionYear>7427462</AdmissionYear>
14      <AdmStage>8608398</AdmStage>
15      <PrevAdmissionYear>6843737</PrevAdmissionYear>
16      <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
17    </row>
18  </execute>
19</root>

Элемент root может включать в себя набор элементов двух типов:

  • query - эти элементы позволяют выполнять запросы к данным; принципы формирования этих элементов совпадают с принципами, описанными для функции cursor: Функция cursor
  • execute - эти элементы позволяют выполнять вызовы методов; принципы формирования этих элементов совпадают с принципами, описанными для функции execute: Функция execute

При использовании функции batch при выполнении запросов к данным, соответствующим элементам query, всегда используется значение атрибута fetchall="1", даже если этот атрибут не передан, или для него передано значение "0". Подробнее об использовании атрибута fetchall="1": Использование возвращаемого ответа.
Желательно не включать в вызовы функции batch запросы, которые потенциально могут вернуть очень большой набор данных. Для таких запросов лучше использовать функцию cursor (Функция cursor).


Функция bulkinsert

(одним файлом)
Функция bulkinsert

Функция bulkinsert позволяет выполнить пакетное добавление данных в поля таблицы. Для использования данной функции подключение должно осуществлять под пользователем, имеющим права доступа на запись к полям таблиц.

Допустимые расширения: .xml, .js / .json.

Функция имеет параметр query, который должен представлять собой XML документ, содержащий информацию о таблице (имя таблицы совпадает с именем класса), в которую должно быть выполнено добавление записей, именах полей и их значениях. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML документ - значение параметра query должен иметь элемент data (можно использовать другое имя элемента, оно не анализируется) с атрибутом handle, в значении которого должно быть передано имя таблицы (имя класса). Корневой элемент должен иметь набор дочерних узлов row, каждый из которых должен иметь дочерние узлы, соответствующие каждой паре имя поля (имя узла) - значение (значение узла).

При успешном выполнении функции будет возвращен ответ в формате XML-документа или в формате JSON с элементом data, который будет включать в себя набор узлов с одним значением id. Значения id будут представлять собой идентификаторы созданных объектов.

01https://techmill.ru/demo/bulkinsert.xml?query=
02  <data handle="TTemporaryList">
03    <row>
04      <FName>Name1</FName>
05      <FDescription>Desc1</FDescription>
06      <FItemInfo>ItemInfo1</FItemInfo>
07    </row>
08    <row>
09      <FName>Name2</FName>
10      <FDescription>Desc2</FDescription>
11      <FItemInfo>ItemInfo2</FItemInfo>
12    </row>
13    <row>
14      <FName>Name3</FName>
15      <FDescription>Desc3</FDescription>
16      <FItemInfo>ItemInfo3</FItemInfo>
17    </row>
18    <row>
19      <FName>Name4</FName>
20      <FDescription>Desc4</FDescription>
21      <FItemInfo>ItemInfo4</FItemInfo>
22    </row>
23  </data>


Функция closecursor

(одним файлом)
Функция closecursor

Функция closecursor позволяет закрыть ранее открытый курсор, который был открыт при предшествующем вызове функции cursor (Функция cursor).

Допустимое расширение: .xml.

Значением параметра функции query должно быть значение handle, которое было возвращено при вызове функции cursor.

Ответом будет xml-документ с одним пустым элементом data.

Запрос:
https://techmill.ru/demo/closecursor.xml?query="{9197829A-AFA3-49D1-BD03-D860ECCB901F}"
Ответ:
<data/>

Открытые курсоры закрываются автоматически при завершении сессии. В рамках одной сессии желательно явно вызывать функцию closecursor при работе с большими объемами данных, когда данные были получены не полностью (при вызове функции cursor было получено eof="0") и результаты запроса более не нужны.


Функция commonproperties

(одним файлом)
Функция commonproperties

Функция commonproperties позволяет получить значения общих свойств списка объектов, включенных в ранее созданный буфер.

Принципы формирования списка общих свойств объектов и возврата их значений совпадают с принципами работы Инспектора объектов: Отображение свойств Инспектором объектов.

Возможности создания буфера и добавление в него объектов описаны в статьях Функция selectedbuffer, Функция selectionchanged.

Допустимое расширение .xml.

В значении параметра функции с именем query необходимо передать xml-документ, содержащий идентификатор буфера и указания о принципе отбора свойств. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML документ должен иметь элемент query со следующими атрибутами:

  • handle (обязательный) - идентификатор буфера
  • propid - идентификатор свойства; если данный атрибут не передан или для него передано пустое значение, то будет возвращен полный набор полученных свойств, если будет передан идентификатор одного свойства, то будет возвращено значение только этого одного свойства.
  • publiconly - значение "0" (по умолчанию) будет означать, что в ответ будут включены все общие свойства набора объектов, значение "1" будет означать что в ответ будут включены только свойства с областью видимости "Видимо пользователям" (Scope = scPublic).

Пример запроса:
https://techmill.ru/demo/commonproperties.xml?query=<query handle="221024" publiconly="1"/>
Запрос на общие свойства списка объектов, предварительно добавленных в буфер с идентификатором "221024". В ответ будет включены только свойство с областью видимости "Видимо пользователям".

В качестве ответа будет возвращен XML-документ с элементом data, который будет включать в себя набор узлов row, соответствующих каждому свойству из полученного набора свойств. Каждый узел row будет иметь подчиненные узлы:

  • ID - идентификатор свойства
  • Value - значение свойства
  • Value-N - для свойств с доменом ссылочного типа (объектов) будет возвращено Имя объекта; для свойств других доменов значение будет пустым
  • Value-D - для свойств с доменом ссылочного типа (объектов) будет возвращено Наименование объекта; для свойств других доменов значение будет пустым
  • Recieved - для свойств типа "Отложенное" (Suspended) будет возвращено значение "0", для прочих свойств будет возвращено значение "1"; в случае получения значение "0" значение такого свойства можно будет получить другим отдельным запросом именно на это свойство, например, при помощи функции cursor (Функция cursor).

Пример ответа:
01<data eof="1">
02  <row>
03    <ID type="int64">69174</ID>
04    <Value>76208</Value>
05    <Value-N>город Москва</Value-N>
06    <Value-D>Москва</Value-D>
07    <Recieved type="int">1</Recieved>
08  </row>
09  <row>
10    <ID type="int64">69175</ID>
11    <Value>67991</Value>
12    <Value-N>РФ</Value-N>
13    <Value-D>Российская Федерация</Value-D>
14    <Recieved type="int">1</Recieved>
15  </row>
16  <row>
17    <ID type="int64">69176</ID>
18    <Value/>
19    <Value-N/>
20    <Value-D/>
21    <Recieved type="int">0</Recieved>
22  </row>
23  <row>
24    <ID type="int64">4503868</ID>
25    <Value>77</Value>
26    <Value-N/>
27    <Value-D/>
28    <Recieved type="int">1</Recieved>
29  </row>
30</data>


Функция cursor

(раздел целиком) (одним файлом)
Функция cursor

Функция cursor позволяет отправлять запросы на получение данных, доступных через обработчик сервера приложений, получать ответ с запрошенными данными в форматах xml или JSON.

Допустимые расширения:

  • .xml - для получения ответа в формате XML
  • .js/.json - для получения ответа в формате JSON

Функция осуществляет запрос к указанному классу или представлению и возвращает данные, соответствующие структуре и условиям переданного запроса. Запрос к данным передается в виде параметра GET или POST-запроса с именем query. Значение параметра представляет собой xml-документ следующей структуры:

01<query class="TWorker">
02  <item part="what" name="LastName" />
03  <item part="what" name="FirstName"/>
04  <item part="what" name="MiddleName"/>
05  <item part="what" name="BirthDate"/>
06  <item part="what" name="ContactList" value="TPerson.GetContactList" special="function">
07    <parameters>
08      <ContactType>63474</ContactType>
09    </parameters>
10  </item>
11  <item part="where" name="LastName" value="А*"/>
12  <item part="order" name="LastName"/>
13  <item part="order" name="FirstName"/>
14</query>

Элемент query имеет обязательный атрибут class. Значением атрибута class должно быть имя класса или представления, к которому будет выполняться запрос. Также может использоваться необязательный атрибут fetchall, который может принимать значения "0" (значение по умолчанию) или "1". Использование атрибута fetchall подробнее описано ниже в разделе Использование возвращаемого ответа.

Элемент query может включать в себя элементы item, передающие структуру запроса, условия отбора, сортировки, группировки. Элементы item могут включать в себя необязательные элементы (context, parameters, и т.п.; имя этого элемента не анализируется).

Состав атрибутов элемента item (обязательным является только атрибут part, остальные атрибуты можно опускать, в зависимости от использования других атрибутов):

  • part (обязательный атрибут) - часть запроса (what, where, order,...)
  • name - в простом случае (без использования special) - имя свойства класса (или поля представления), которое будет использовано в запросе; при использовании special может быть как именем свойства класса, так и другой строкой (см. подробнее ниже).
  • value - значение, которое в зависимости от значения атрибутов part и special, будет использовано для сравнений или для других целей; в простом случае (если part = "where", special отсутствует) будет использовано для сравнения в условии отбора при выполнении запроса.
  • special - вводит дополнительные возможности формирования запроса (возможности описаны ниже); от использованного значения данного атрибута может зависеть трактовка значений других атрибутов.
  • subQuery
  • joinKey
  • joinLink
  • joinSource

Допустимые значения атрибута part (можно использовать как строковые, так и числовые значения):

Строковое
значение 		Числовое
значение 		Назначение и пример использования
what 0 Элементы со значением "what" (0) атрибута part используются для формирования what-кляузы запроса. В полученном ответе каждому такому элементу будет соответствовать один xml или json элемент с именем, переданным атрибутом name.
<item part="what" name="LastName"/>
Получить значение свойства "LastName".
where 1 Элементы со значением "where" (1) атрибута part используются для формирования условия отбора объектов (where-кляузы запроса).
Для условий допустимо использовать "маску" (*, ?), условия ">", "<", ">=", "<=";
использование значений через ";" будет трактовано как условие "или", использование "&" будет трактовано как условие "и";
для отрицания нужно использовать "!", для условия "not null" нужно использовать "*", для условия "is null" нужно использовать "!*".
Каждый следующий where-элемент добавляет к запросу одно условие "и".
1<item part="where" name="LastName" value="Петров"/>
2<item part="where" name="FirstName" value="А*"/>
Отобрать объекты класса со значением свойства "LastName", равным "Петров", и значениями "FirstName", начинающимися с символа "А".
order 2 Элементы со значением "order" (2) атрибута part используются для управления сортировкой данных в возвращаемом ответе. По умолчанию (без использования атрибута special) будет выполнена сортировка "по возрастанию". Задать сортировку "по убыванию" можно, использовав значение "desc" (7) для атрибута special. Если в запросе использовано несколько элементов "order", то возвращаемый результат будет отсортирован по нескольким полям в том порядке, в котором они указаны в запросе.
1<item part="order" name="LastName/>
2<item part="order" name="BirthDate" special="desc"/>
Отсортировать результат запроса по значению свойства "LastName" по возрастанию, затем по значению свойства "BirthDate" по убыванию.
group 3 Элементы со значением "group" (3) атрибута part используются для управления группировкой данных в возвращаемом ответе. Если в запросе использовано несколько элементов "group", то возвращаемый результат будет сгруппирован по нескольким полям в том порядке, в котором они указаны в запросе. Для свойств, не входящих в условия группировки, можно получать значения агрегатов (количество, наименьшее/наибольшее/среднее и т.п.), используя атрибут special.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="what" name="BirthDate" special="min"/>
4<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region", количество записей в группе и минимальное значение свойства "BirthDate" в этой группе.
having 4 Элементы со значением "having" (4) атрибута part позволяют накладывать условия отбора на группы в запросе с группировкой.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="what" name="BirthDate" special="min"/>
4<item part="group" name="Region"/>
5<item part="having" name="ID" value=">3" special="count"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region", количество записей в группе и минимальное значение свойства "BirthDate" в этой группе, отобрав при этом только такие группы, количество объектов в которых больше 3-х.
innerJoin | 5
outerJoin | 6

Допустимые значения атрибута special (можно использовать как строковые, так и числовые значения):

Строковое
значение 		Числовое
значение 		Части запроса Назначение и пример использования
ID 1 what
where 		Позволяет запрашивать идентификатор объекта или накладывать условия по идентификатору.
1<query class="TWorker">
2  <item part="what" special="ID"/>
3  <item part="what" name="LastName"/>
4  <item part="what" name="FirstName"/>
5  <item part="where" value="5500921" special="ID"/>
6</query>
Получить идентификатор объекта, значения свойств LastName, FirstName объекта с идентификатором, равным 5500921. Ответ на запрос будет содержать элемент с именем ID.
parent 2 what
where 		Позволяет использовать в запросах идентификатор "родителя" объекта.
1<query class="TCountry">
2  <item part="what" special="ID"/>
3  <item part="what" special="parent"/>
4  <item part="what" name="Name"/>
5  <item part="what" name="Description"/>
6</query>
Получить идентификатор объекта, идентификатор родительского объекта, значения свойств Name, Description всех объектов класса TCountry. Ответ на запрос будет содержать элемент с именем Parent.
haschildren 3 what
where 		Признак наличия дочерних объектов в иерархии. Ответ на запрос будет содержать элемент с именем HasChildren и значением "1" в случае наличия дочерних объектов и значением "0" в случае их отсутствия.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" special="haschildren"/>
5</query>
Получить значения свойств Name, Description, а также признак наличия дочерних объектов всех объектов класса TCountry.
filter 4 where Позволяет использовать для отбора условия, заданные доменами, использованными в решении на платформе. Имя или идентификатор домена указывается в атрибуте name. Условие отбора этого домена будет интерпретировано с учетом значений, переданных в дочернем элементе context. Для каждого из этих значений должны быть указаны его имя, домен и значение.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name = "TRegion of UnivCountry domain" special="filter>
5      <context>
6        <UnivCountry domain="4565848">67991</UnivCountry>
7      </context>
8  </item>
9</query>
Получить значения свойств Name, Description объектов класса TCountry, подходящих под условие отбора домена "TRegion of UnivCountry domain", используя значение "67991" вместо идентификатора UnivCountry.
Условие отбора домена "TRegion of UnivCountry domain":
((Self.Parent = UnivCountry) or (Self = UnivCountry))
uplink 5 what
where 		Используется для отбора данных в контексте выбранных родительских объектов. Связь отбираемых объектов с выборкой связанных родительских объектов будет установлена по свойству, переданному атрибутом name. В атрибуте value может быть передан идентификатор одного объекта, список идентификаторов объектов через ";" или идентификатор буфера, в который предварительного сохранен список объектов.
1<query class="TCountry">
2  <item part="where" name="Parent" value="14750" special="uplink"/>
3  <item part="what" name="Name"/>
4  <item part="what" name="Description"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, у которых значение свойства Parent равно "14750" (или входит в состав объектов, сохраненных в буфере с идентификатором "14750").
root 6 where Будут отобраны только объекты, не имеющие родителя, после наложения других условий отбора.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" special="root"/>
5</query>
Получить значения свойств Name, Description "корневых" (не имеющих родителя) объектов класса TCountry.
desc 7 order Используется для сортировки "по убыванию" для элементов с атрибутом part ="order". Без указания атрибута special будет выполнена сортировка "по возрастанию".
1<item part="order" name="LastName"/>
2<item part="order" name="BirthDate" special="desc"/>
Отсортировать результат запроса по значению свойства "LastName" по возрастанию, затем по значению свойства "BirthDate" по убыванию.
count 8 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения количества объектов в группе.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="group" name="Region"/>
4<item part="having" name="ID" value=">3" special="count"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и количество записей в группе, отобрав при этом только такие группы, количество объектов в которых больше 3-х.
sum 9 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения суммы значений свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="PayedSum" special="sum"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и сумму значений свойства "PayedSum" для всех объектов группы.
min 10 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения минимального значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="BirthDate" special="min"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и минимальное значение свойства "BirthDate" среди всех объектов группы.
max 11 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения максимального значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="BirthDate" special="max"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и максимальное значение свойства "BirthDate" среди всех объектов группы.
avg 12 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения среднего значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"
2<item part="what" name="PayedSum" special="avg"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и среднее значение свойства "PayedSum" среди всех объектов группы.
masterLink 13 where Позволят наложить отбор на объекты класса ("подчиненный" класс) в контексте выбранных объектов класса-мастера или класса, связанного с исходным по другому свойству ("главный" класс). В атрибуте name в этом случае передаются имена свойства "главного" класса и свойства "подчиненного" класса, по которым эти классы связаны. Имена свойств указываются следующим образом:
  • Если одним из этих свойств является идентификатор (ID), то имя этого свойства не указывается (это свойство используется по умолчанию)
  • Если оба свойства отличаются от ID, то их имена указываются через разделитель ";", например, "Master;Person"
  • Если только свойство "подчиненного" класса отличается от ID, то указывается только имя этого свойства, например, "Person"
  • Если только свойство "главного" отличается от ID, то вместо свойства-подчиненного указывается *, например, "Master;*"
В свойстве value передается идентификатор буфера, содержащего список выбранных объектов "главного" класса.
1<query class="TContact">
2  <item part="what" name="ContactInfo"/>
3  <item part="what" name="ContactType" special="name"/>
4  <item part="where" name="Person" value="246889" special="masterLink"/>
5</query>
Получить значения свойств ContactInfo, ContactType (Имя) объектов класса TContact, для объектов, список которых сохранен в буфере с идентификатором "246889", связанным с классом TContact по свойству Person.
selectedOnly 14 where Позволят наложить отбор по списку идентификаторов объектов класса, ранее сохраненных в буфере.
1<query class="TPerson">
2  <item part="what" name="LastName"/>
3  <item part="what" name="FirstName"/>
4  <item part="where" value="246889" special="selectedOnly"/>
5</query>
Получить значения свойств LastName, FirstName объектов класса TPerson, список которых сохранен в буфере с идентификатором "246889".
distinct 15 what Позволяет получить все уникальные значения определенного свойства или сочетания значений свойств класса.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" special="distinct"/>
4</query>
Получить набор уникальных значений свойства FirstName класса TPerson.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="MiddleName"/>
4  <item part="what" special="distinct"/>
5</query>
Получить набор уникальных сочетаний значений свойств FirstName и MiddleName класса TPerson.
view 16 where Позволяет при выполнении запроса наложить отбор, используемый для определенного представления. Имя (или идентификатор) представления указывается в атрибуте name.
1<query class="TPerson">
2  <item part="where" name="Persons older 25" special="view"/>
3  <item part="what" name="FirstName"/>
4  <item part="what" name="LastName"/>
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, соответствующих условиям отбора представления Persons older 25.
caseInsensitive 17 where Позволяет наложить отбор на значение свойства строкового типа без учета регистра. Без использования special поиск ведется с учетом регистра.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="LastName"/>
4  <item part="where" name="FirstName" value="АНДРЕЙ" special="caseInsensitive"/>
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, с отбором по значению свойства FirstName без учета регистра символов. TPerson.
string 18 where Позволят явно приводить к строковому типу значения свойства, переданного атрибутом name.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="Code" value="00002" special="string"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, со значением свойства Code, равным "00002".
listed 19 where Позволяет выполнять отбор по списку объектов, входящих в список, сохраненный в системе как объект класса TObjectList ("Списки"), идентификатор которого нужно передать в качестве значения атрибута value.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="ID" value="5245654" special="listed"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, входящих в список, сохраненный как объект класса TObjectList с идентификатором "5245654".
name 20 what
where 		Для свойств-ссылок на объекты позволяет получить Имя объекта, переданного атрибутом name. В полученном ответе соответствующий элемент будет иметь имя ИмяСвойства-N.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Parent"/>
5  <item part="what" name="Parent" special="name"/>
6</query>
Для всех объектов класса TCountry получить значения свойств Name, Description, Parent, а также Имя объекта Parent.
description 21 what
where 		Для свойств-ссылок на объекты позволяет получить Наименование объекта, переданного атрибутом name. В полученном ответе соответствующий элемент будет иметь имя ИмяСвойства-D.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Parent"/>
5  <item part="what" name="Parent" special="description"/>
6</query>
Для всех объектов класса TCountry получить значения свойств Name, Description, Parent, а также Наименование объекта Parent.
function 22 what
where 		Позволяет использовать значения, полученные в результате вызова функций, как в элементах с атрибутом part ="what", так и в элементах с атрибутом part ="where". Имя функции должно быть передано в атрибуте value в формате Имя класса.Имя функции. Если функция имеет параметры, то для их передачи необходимо добавить дочерний элемент context, со своими дочерними элементами для каждого из параметров в формате <ИмяПараметра>Значение параметра</ИмяПараметра>. Если функция является "методом объекта", параметр "ID" добавлять не нужно, он будет использован автоматически. В элементах с атрибутом part ="what" значение атрибута name может быть любым, оно не будет использовано при выполнении запроса, но станет именем элемента данных в получаемом ответе.
01<item part="what" name="InitAndLast" value="TPerson.GetInitAndLast" special="22"/>
02<item part="what" name="ContactList" value="TPerson.GetContactList" special="22">
03  <context>
04    <ContactType>63474</ContactType>
05  </context>
06</item>
07<item part="where" name="TWorker.IsSuperior" value="1" special = "function">
08  <context>
09    <OtherWorker>625186</OtherWorker>
10    <Department></Department>
11  </context>
12</item>
Получить результат выполнения функции GetInitAndLast класса TPerson (функция не имеет параметров), получить результат выполнения функции GetContactList класса TPerson с параметром ContactType = 625186. Отобрать только те объекты, для которых результат выполнения функции IsSuperior класса TWorker равен "1". Функция IsSuperior вызывается со значением 625186 параметра OtherWorker и пустым значением параметра Department.
countdistinct 23 what
having 		Позволяет получить количество уникальных значений свойства.
1<query class="TPerson">
2  <item part="what" name="FirstName" special="countdistinct"/>
3</query>
Получить количество уникальных значений свойства FirstName класса TPerson.
boolean 24 what
where 		Позволят приводить к "логическому" типу значения свойства, переданного атрибутом name. Приведение выполняется по следующему принципу:
  • значение Null преобразуется в пустое значение в ответе
  • значение "0" остается значением "0" в ответе
  • любое непустое значение преобразуется в значение "1" в ответе
Такая возможность позволяет, например, более эффективно (без получения самих значений) определять пустоту/непустоту значений типа "большой объект".
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Code" special="boolean"/>
5</query>
Получить значения свойств Name, Description, а также значение свойства Code, преобразованное к "логическому" всех объектов класса TCountry.
exact 25 where При использовании значения "exact" (25) атрибута special значение, переданное в атрибуте value, будет использовано "как есть" - без преобразования типов, без трактовки символов "*", "?" как маски и т.п.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="Code" value = "002*25?" special="exact"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry со значением свойства Code, равным "002*25?".
searchindex 26 where Позволяет использовать индексы полнотекстового поиска при отборах. Поиск по выполняться по всем полям класса, значение атрибута name будет проигнорировано.
1<query class="TMailMessage">
2  <item part="what" name="Theme"/>
3  <item part="what" name="Body"/>
4  <item part="what" name="Created"/>
5  <item part="where" value="приглашаем *на семинар *Современные" special="searchindex">
6</query>
Получить значения свойств Theme, Body, Created объектов класса TMailMessage, среди значений свойств которых будет найдена указанная строка, с использованием индекса полнотекстового поиска.
optimization 27 where Позволяет использовать имеющиеся подсказки оптимизатору при выполнении запроса.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="LastName"/>
4  <item part="what" value="ORARefreshOnFetch=true;APPRefreshOnFetch=true" special="optimization">
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, используя при выполнении запроса подсказки оптимизатору.

  • Использование возвращаемого ответа


Использование возвращаемого ответа

(одним файлом)
Использование возвращаемого ответа

При корректном выполнении запроса ответ будет представлять собой набор данных следующей структуры:

  • При использовании формата xml будет возвращен xml-документ с корневым элементом data, который будет иметь атрибуты handle (GUID) и eof ("1" или "0"). Элемент data будет иметь подчиненные элементы row, каждый из которых будет соответствовать одной записи, полученной при выполнении запроса. Каждый элемент row будет иметь подчиненные элементы, соответствующие what-элементам запроса.
  • При использовании формата JSON будет возвращен JSON-объект, содержащий пары ключ-значение handle (значение типа GUID), eof (значения "0" или "1") и data. Значением data будет массив пар ключ-значение, каждая из которых будет соответствовать одной записи, полученной при выполнении запроса.

Обработчик сервера приложений, обеспечивающий работу функций RESTfull-сервисов, в том числе функции cursor, имеет параметры, ограничивающие размер пакета возвращаемых данных, выраженные в количестве объектов в ответе и в объеме ответа в байтах. В случае, если размер ответа укладывается в оба этих ограничения, все полученные данные будут возвращены полностью, и в ответе будет передан атрибут (значение) eof="1". В случае, если размер ответа превысит одно из ограничений, и при этом в запросе атрибут fetchall не задан или равен "0", то в ответ войдет только такой набор записей, который позволит соблюсти ограничения, и при этом в ответе будет передан атрибут (значение) eof="0". Если в запросе был передан атрибут fetchall="1", то будет выполнена попытка вернуть весь ответ полностью, несмотря на установленные ограничения. При успешной передаче атрибут (значение) eof будет равен "1".

Пример запроса:
1  <query class="TWorker" fetchall="1">
2    <item part="0" name="LastName"/>
3    <item part="0" name="FirstName"/>
4    <item part="0" name="BirthDate"/>
5    <item part="0" name="AcademicStatus"/>
6    <item part="1" name="BirthDate" value=">12.05.2000"/>
7  </query>
Пример ответа в формате xml:
01  <data handle="{FDF9EE70-9948-4A99-8233-349C3ADD3CE8}" eof="1">
02    <row>
03      <LastName>Абишин</LastName>
04      <FirstName>Вячеслав</FirstName>
05      <BirthDate type="date">10.06.2014</BirthDate>
06      <AcademicStatus>к.э.н.</AcademicStatus>
07    </row>
08    <row>
09      <LastName>Агринская</LastName>
10      <FirstName>Ольга</FirstName>
11      <BirthDate type="date">24.08.2016</BirthDate>
12      <AcademicStatus>PhD</AcademicStatus>
13    </row>
14    <row>
15      <LastName>Абрамов</LastName>
16      <FirstName>Александр</FirstName>
17      <BirthDate type="date">05.09.2016</BirthDate>
18     <AcademicStatus/>
19    </row>
20  </data>
Пример ответа в формате JSON:
01  {
02      "handle": "{C57F629E-583C-4477-ACBF-E436F6D01628}",
03      "eof": true,
04      "data": [
05          {
06              "LastName": "Абишин",
07              "FirstName": "Вячеслав",
08              "BirthDate": {
09                  "year": 2014,
10                  "month": 5,
11                  "day": 10
12              },
13              "AcademicStatus": "к.э.н."
14          },
15          {
16              "LastName": "Агринская",
17              "FirstName": "Ольга",
18              "BirthDate": {
19                  "year": 2016,
20                  "month": 7,
21                  "day": 24
22              },
23              "AcademicStatus": "PhD"
24          },
25          {
26              "LastName": "Абрамов",
27              "FirstName": "Александр",
28              "BirthDate": {
29                  "year": 2016,
30                  "month": 8,
31                  "day": 5
32              },
33              "AcademicStatus": null
34          }
35      ]
36  }

Значение eof = "1" означает, что данные получены полностью. Если в ответе такого значения (атрибута) нет, или eof = "0", это означает, что получены не все данные. Дополучить эти данные можно, повторно выполнив вызов функции cursor, передав в качестве значения параметра query полученное при первом вызове значение handle.
https://techmill.ru/demo/cursor.xml?query={FDF9EE70-9948-4A99-8233-349C3ADD3CE8}
В ответе на запрос с использованием handle вернется то же самое значение handle. Таким образом, запрос можно повторять с одним и тем же значением handle до тех пор, пока в ответе не будет получено eof = "1", что позволит убедиться в том, что данные получены полностью.


Функция excelreport

(раздел целиком) (одним файлом)
Функция excelreport

Функция excelreport позволяет вызывать на выполнение отчеты класса TExcelTemplate и получать файлы, формируемые как результат выполнения отчетов. Файлы могут быть возвращены как в форматах Excel (.xls,.xlsx), так и с преобразованием в другие форматы. Исключением являются интерактивные отчеты (требующие при формировании диалога с пользователем). Такие отчеты не могут вызваться при помощи данной функции.

Допустимые расширения:

  • .xls - для получения файла отчета в формате XLS
  • .xlsx - для получения файла отчета в формате XSLX
  • .html - для получения файла отчета в формате HTML; поддерживается формирование html-документа в монохромном цветовом режиме, в режиме "в градациях серого"
  • .pdf - для получения файла отчета в формате PDF; поддерживаются способы преобразования.xls/.xslx-файла в pdf-документ как средствами платформы, так и средствами самого Excel; возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"
  • .xps - для получения файла отчета в формате XPS

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, отчет которого будет вызываться
  • "template" (обязательный) - имя отчета, который будет вызываться
  • "format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:
    • цветовой режим - допустимые значения "mono", "grey"; значение по умолчанию - "обычный" цветовой режим
    • внедрение шрифтов (для формата PDF) - допустимые значения "embed", "embedded"; значение по умолчанию - без внедрения шрифтов
    • способ преобразования (для случая преобразования в формат PDF) - допустимое значение "native"; значение по умолчанию - средствами платформы "Мельница данных" в случае, если такой способ реализован; иначе - средствами приложения MS Office.
    • тип файла результата - допустимые значения совпадают с возможными расширениями вызова функции (без дополнительной точки)
  • "filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="StatisticReport.embed.pdf", что будет говорить о том, что будет возвращен pdf-документ с внедренными шрифтами.
    Значение по умолчанию: "excelreport" с расширением, совпадающим с расширением вызываемой функции.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного атрибутами параметра query или расширением функции excelreport (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове Excel-отчета:
1  <execute class="TSchoolAbiturSt" template="RegStatistics" format="mono.embed.native.pdf" filename="StatisticReport.pdf">
2    <row>
3      <AdmissionYear>7427462</AdmissionYear>
4      <AdmStage>8608398</AdmStage>
5      <PrevAdmissionYear>6843737</PrevAdmissionYear>
6      <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
7    </row>
8  </execute>
При таком вызове будет выполнен Excel-отчет "RegStatistics" класса "TSchoolAbiturSt" с параметрами, переданными в элементе row. Данный отчет является "методом класса", поэтому параметр "ID" в состав параметров не добавлен. Полученный файл отчета будет преобразован в формат PDF с внедрением шрифтов в монохромном режиме. Преобразование будет выполнено средствами приложения MS Excel. В качестве ответа будет возвращен .pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("StatisticReport.pdf"), в содержимом ответа будет передано содержимое файла.
  • Принципы разбора информации о формате результирующего файла


Принципы разбора информации о формате результирующего файла

(одним файлом)
Принципы разбора информации о формате результирующего файла

Информация о формате файла, который будет сформирован и возвращен в качестве ответа, может быть извлечена из атрибутов xml-документа запроса, или из расширения функции. Порядок разбора переданной информации следующий:

  1. Значение атрибута format. Если данный атрибут указан, но в нем нет одной из составляющих формата, то для этой составляющей будет использовано значение по умолчанию (значение из атрибута filename использовано не будет).
  2. Значение атрибута filename. В этом атрибуте, кроме имени файла как такового и его расширения, может передаваться информация о цветовом режиме (.mono/.grey,...), внедрении шрифтов (.embed/.embedded), способе преобразования файла (.native). Значения для этих составляющих будут получены из атрибута filename только в случае, если атрибут format не указан при вызове.
  3. Расширение будет получено из расширения вызываемой функции. Для других составляющих формата будут использованы значения по умолчанию.

Строка, определяющая формат, разбирается как последовательность элементов, разделенных символом "." (точка). Элементы разбираются последовательно, независимо друг от друга, и имеют следующие значения:

mono | Формируется монохромный документ
grey | Формируется документ в градациях серого
embedded | Шрифты внедряются в выходной документ
native | Используется встроенный в MSOffice механизм формирования документов
PDF | Выгружается файл в формате PDF
HTML | Выгружается файл в формате HTML
BMP | Выгружается файл в формате BMP
RTF | Выгружается файл в формате RTF
DOC | Выгружается файл в формате DOC
XLS | Выгружается файл в формате XLS
DOCX | Выгружается файл в формате DOCX
XLSX | Выгружается файл в формате XLSX
XPS | Выгружается файл в формате XPS

Остальные элементы игнорируются. Порядок следования элементов не важен.

Строка формата "pdf.mono.embedded" указывает сформировать монохромный документ в формате PDF со встроенными шрифтами.


Функция execute

(раздел целиком) (одним файлом)
Функция execute

Функция execute позволяет вызывать методы, доступные для вызова через обработчик сервера приложений, получать результат выполнения методов.

Допустимо использовать любые расширения, в том числе не указывать расширение. Расширение повлияет на формат возвращаемого результата следующим образом:

  • .xml - для получения результата выполнения в формате xml
  • .js/.json - для получения результата выполнения в формате JSON
  • пустое расширение - результат выполнения будет возвращен в формате xml
  • другие расширения - имеет смысл использовать в случаях, когда результатом выполнения метода является "большой объект" (blob, clob) и его тип известен; это позволит получить результат в виде файла или структуры данных определенного типа (.xslt,.pdf, форматы изображений и т.п.)
    если результат выполнения не удастся привести к формату, заданному расширением, результат будет возвращен в формате xml

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый метод и значения его параметров. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, метод которого будет вызываться
  • "method" (обязательный) - имя метода, который будет вызываться

Корневой элемент xml-документа может содержать список узлов row, каждый из которых определяет набор параметров для вызова метода. Таким образом, при помощи одного вызова функции (одним обращением к url) можно вызывать один и тот же метод для набора объектов.

Принципы передачи параметров для вызова метода, включая использование параметров типа "большой объект", описаны в статье Принципы передачи параметров функциям RESTful-service.

Для вызова методов экземпляра необходимо указывать значение неявного параметра с именем "ID". Значением этого параметра должен быть идентификатор объекта, для которого вызывается метод.

01  <execute class="TPerson" method="GetContactList">
02    <row>
03      <ID>931669</ID>
04      <ContactType>63478</ContactType>
05    </row>
06    <row>
07      <ID>76443</ID>
08      <ContactType>63478</ContactType>
09    </row>
10  </execute>

Получить результат вызовов метода GetContactList класса TPerson для объектов с идентификаторами (ID), равными 931669 и 76443 и со значением параметра ContactType, равным 63478.

Пример ответа:

1  <data eof="1">
2    <row>
3      <Result>8-903-73-210-73</Result>
4    </row>
5    <row>
6      <Result>8-916-862-27-77; 8-916-862-2777</Result>
7    </row>
8  </data>

Если возвращаемый результат имеет домен класса "большой объект" (clob, clob, "внешний файл"), то возвращаемое значение может быто подвергнуто пост-обработке. Подробнее этот случай описан в разделе: Особенности передачи возвращаемых значений типа "большой объект"

  • Принципы передачи параметров функциям RESTful-service
  • Особенности передачи возвращаемых значений типа "большой объект"


Принципы передачи параметров функциям RESTful-service

(одним файлом)
Принципы передачи параметров функциям RESTful-service

При вызове функций RESTful-service стандартного обмена применяются следующие принципы передачи и связывания параметров:

  1. Параметры связываются по их именам. Порядок указания параметров при вызове функции не существенен.
  2. Если вызываемый метод или отчет является "методом класса", то дополнительно должен быть передан параметр "ID" со значением идентификатора объекта, для которого вызывается метод или отчет.
  3. Если параметр имеет clob-домен подтипов "btHTML" (HTML-документ), "btXHTML" (XHTML-документ), то содержимое такого документа будет "обезврежено" (будут удалены ссылки, скрипты и т.п.)
  4. Если вызываемый метод имеет параметр blob-домена, но при его вызове в xml-документе не найден узел с таким именем, то будет выполнен поиск параметра с тем же именем среди параметров сессии. Если такой параметр сессии будет найден, то его значение будет передано в качестве blob-значения одноименного параметра вызываемого метода. При этом в случае, если параметр имеет blob-домен подтипа "btNamedFile" (Именованный файл), то содержимое файла будет взято из одноименного параметра сессии (например, "param1"), а имя файла будет взято из параметра сессии с именем, дополненным постфиксом ".filename" (например, "param1.filename").
  5. Если вызываемый метод имеет параметр blob-домена с подтипом "btImage" (Изображение), то для переданного значения будет предпринята попытка его преобразования в формат, заданный свойством "Расширение" домена.
  6. В других случаях переданное или найденное в параметрах сессии blob/clob значение будет передано "как есть" в качестве значения параметра при вызове метода.
  7. Если для параметра было использовано значение параметра сессии, то такой параметр удаляется из сессии после вызова функции (повторное использование параметра сессии невозможно).


Особенности передачи возвращаемых значений типа "большой объект"

(одним файлом)
Особенности передачи возвращаемых значений типа "большой объект"
Если функция сервиса имеет возвращаемое значение, имеющее домен типа blob, clob или "внешний файл", то такое значение может быть подвергнуто пост-обработке по следующим принципам:
  1. Если задано расширение .js или .json, атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет clob-домен или домен "Внешние данные" подтипа "btJavaScript" (Скрипт JavaScript), то будет возвращено полученное из метода значение "как есть" (без каких-либо дополнительных преобразований)
  2. Если задано расширение .xml, атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет clob-домен или домен "Внешние данные" подтипа "btXML" (XML-документ) или "btXHTML" (XHTML-документ), то будет возвращено полученное из метода значение "как есть" (без каких-либо дополнительных преобразований)
  3. При использовании других расширений, если атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет blob-домен подтипа "btNamedFile" (Именованный файл), то в заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.
  4. Если для атрибута "noanalyze" будет передано значение "1", и при этом возвращаемое значение имеет blob-домен и его размер окажется большим, то возвращаемое значение будет сохранено в параметре сессии, а в xml-ответе будет представлен только его идентификатор.
  5. Во всех других случаях возвращаемое значение типа "большой объект" (blob) будет двоично закодировано и возвращено в разделе CDATA xml-документа.


Функция executeoleobjectmethod

(одним файлом)
Функция executeoleobjectmethod

Функция executeoleobjectmethod позволяет вызывать методы OLE-объекта, доступные для вызова через обработчик сервера приложений, получать результат выполнения методов. Исключением методы не могут вызваться при помощи данной функции.

Допустимо использовать любые расширения, в том числе не указывать расширение. Расширение повлияет на формат возвращаемого результата следующим образом:

  • .xml - для получения результата выполнения в формате xml
  • .js/.json - для получения результата выполнения в формате JSON
  • пустое расширение - результат выполнения будет возвращен в формате xml
  • другие расширения - имеет смысл использовать в случаях, когда результатом выполнения метода является "большой объект" (blob, clob) и его тип известен; это позволит получить результат в виде файла или структуры данных определенного типа (.xslt,.pdf, форматы изображений и т.п.)
    если результат выполнения не удастся привести к формату, заданному расширением, результат будет возвращен в формате xml

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый метод и значения его параметров. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, метод которого будет вызываться
  • "method" (обязательный) - имя метода OLE-объекта, который будет вызываться

Корневой элемент xml-документа может содержать список узлов row, каждый из которых определяет набор параметров для вызова метода. Таким образом, при помощи одного вызова функции (одним обращением к url) можно вызывать один и тот же метод для набора объектов.

Принципы передачи параметров для вызова метода, включая использование параметров типа "большой объект", описаны в статье Принципы передачи параметров функциям RESTful-service.

Для вызова методов экземпляра необходимо указывать значение неявного параметра с именем "ID". Значением этого параметра должен быть идентификатор объекта, для которого вызывается метод.

1  <execute class="TBachAbiturSt" method="AddComposition">
2    <row>
3      <ID>7927267</ID>
4      <AdmissionYear>6617171</AdmissionYear>
5      <CompYear>5639232</CompYear>
6      <Theme>742348353</Theme>
7    </row>
8  </execute>
Получить результат вызовов метода AddComposition класса TBachAbiturSt для объекта с идентификаторами (ID), равными 7927267 и с параметрами, заданными в элементе row.

Если возвращаемый результат имеет домен класса "большой объект" (clob, clob, "внешний файл"), то возвращаемое значение может быто подвергнуто пост-обработке. Подробнее этот случай описан в разделе: Особенности передачи возвращаемых значений типа "большой объект"


Функция getblob

(одним файлом)
Функция getblob

Функция getblob позволяет сторонним приложениям или веб-страницам формировать ссылки на содержимое, хранящееся как значение свойства объекта системы типа "большие данные" (изображения, файлы и т.п.).

При вызове функции допустимо указывать любые расширения. Расширение должно определяться содержимым, которое ожидается получить. В случае, если об этом нет достаточной информации, можно вызывать функцию с пустым расширением.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

  • class (обязательный) - имя класса, значение свойства которого нужно получить
  • propname (обязательный) - имя свойства, значение свойства которого нужно получить
  • id (обязательный) - идентификатор объекта, свойство которого нужно получить
  • filename - имя файла, которое будет использовано для полученного файла; если свойство имеет домен подтипа "Именованный файл", то имя файла будет получено из свойства, значение которого запрашивается, иначе будет использовано значение данного атрибута
  • disposition - если для данного атрибута будет указано значение "inline", то будет предпринята попытка открыть содержимое в браузере (на отдельной вкладке или встроить в страницу); если атрибут не указан, то будет выполняться скачивание файла; атрибут применим для изображений, PDF-документов
  • width, height - атрибуты применимы в случае, если функция вызывается с расширениями .jpg или .png, или если содержимое является изображением;
    в случае, если данные атрибут указаны, будет произведена попытка сжать/растянуть изображение под указанные размеры ширины и высоты
1https://techmill.ru/demo/getblob?query=
2<query class="TPersonalDocument" propname="DocFile" ID="4562944" filename="DocumentCopy1.pdf"/>
Будет выполнена попытка получения файла PDF-документа и его скачивание.


Функция imagelist

(одним файлом)
Функция imagelist

Функция imagelist позволяет получить набор изображений, хранящихся в системе как значения свойства определенного класса, в компактном виде, удобном для их дальнейшего использования.

Допустимые расширения:

  • .png - для получения ответа в виде PNG-файла
  • .js / .json - для получения ответа в формате JSON

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

  • class (обязательный) - имя или идентификатор класса, значение свойства которого содержит изображения
  • proprty (обязательный) - имя свойства, значения свойства которого содержат изображения
  • width, height - ширина и высота в пикселях, к которой будут приведены отдельные изображения; если эти значения не указаны, используются значения по умолчанию 32х32
  • perrow - количество изображений в одной строке при компоновке изображений; если это значение не указано, используются значение по умолчанию 12

Элемент query может иметь дочерние узлы item, за счет которых можно передать условия отбора, которые будут наложены на записи класса. Если узлы item не будут добавлены, то изображения будут получены из всех записей класса (без условий отбора).
Узлы item должны иметь атрибут part со значением where, в остальном набор атрибутов и принципы формирования узлов item совпадают с принципами использования узлов item part="where"... в функции cursor (Функция cursor) для задания условий отбора запроса.

При вызове функции с расширением .png в качестве результата будет возвращено содержимое.png-файла с набором изображений.

При вызове функции с расширением .js или .json результат будет представлять собой JSON-объект с набором полей id: index, где id - идентификатор объекта класса, index - порядковый номер изображения в структуре изображений, после которых будут следовать поля

  • .filename: "запрос на получение.png-файла"
  • .width: "32"
  • .height: "32"
  • .perrow: "12"

Вызов функции с расширением.png:
techmill.ru/sup/imagelist.png?query=<query class='TAvatar' property='Image' width='32' height='32'/>
Вызов функции с расширением.js:
techmill.ru/sup/imagelist.js?query=<query class='TAvatar' property='Image' width='32' height='32'/>
Результат, возвращаемый при вызове с расширением.js:
01{
02"12008":0,
03"12009":1,
04"12010":2,
05"13917":3,
06"27570":4,
07"68807":5,
08"1786530":6,
09"6574243":7,
10"9376694":8,
11"9376695":9,
12"38740400":10,
13"39019504":11,
14"39019505":12,
15"118496347":13,
16".filename":"/sup/imagelist.png?query=%3Cquery%20class%3D%27TAvatar%27%20property%3D%27Image%27%20width%3D%2732%27%20height%3D%2732%27%20perrow%3D%2712%27/%3E",
17".width":32,
18".height":32,
19".perrow":12}


Функция loadexternaldata

(одним файлом)
Функция loadexternaldata

Функция loadexternaldata позволяет получить файл из файлового хранилища по идентификатору файла в хранилище.

Допустимые расширения:

  • .xml
  • другие расширения, которые будут соответствовать типу и расширению запрашиваемого файла.

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент loadexternaldata с атрибутами

  • domain - имя или идентификатор домена "внешних данных"
  • value - идентификатор файла в файловом хранилище
Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

1https://techmill.ru/demo/loadexternaldata.xml?query=
2<loadexternaldata domain="TPhotoFile" value="{D4A74981-336D-474B-9585-11716BA4232B}">
3</loadexternaldata>

В качестве результата выполнения функции будут возвращены двоичные данные запрошенного файла.


Функция partitions

(одним файлом)
Функция partitions

Функция partitions позволяет получить информацию о количестве объектов, возвращаемых запросом с разбиением на группы определенного размера, по каждой группе получить минимальный и максимальный идентификатор объектов и количество объектов в группе.

Допустимое расширение: .xml.

Функция имеет параметр query, значением которого должен быть.xml-документ, содержащий информацию о запросе к данным, который должен быть выполнен, и о размере групп, на которые должен быть разделен результат. Структура xml-документа должна повторять структуру, используемую при вызове функции cursor (см. Функция cursor) со следующими отличиями:

  1. Элемент query, в дополнение к обязательному атрибуту class, должен иметь еще один обязательный атрибут chunksize - размер группы (целое число - количество записей в группе).
  2. Узлы item со значениями атрибута part, равными what, можно не добавлять, в запросе всегда будет использоваться только идентификатор объекта (свойство ID).
  3. Узлы item со значениями атрибута part, равными order, group, having использоваться не должны. При выполнении запроса группировка применяться не будет, а сортировка всегда будет выполняться по идентификаторам объектов (свойство ID) по убыванию.
  4. Результат, возвращаемый функцией, всегда будет возвращен полностью, независимого от переданного значения атрибута fetchall.

В качестве результата функция вернет XML-документ с элементом data с атрибутом eof="1", имеющий дочерние узлы row, соответствующие каждой полученной группе. Каждый узел row будет иметь следующий набор дочерних узлов:

  • min - минимальный ID в группе объектов;
  • max - максимальный ID в группе объектов;
  • count - количество объектов в группе; во всех узлах row, кроме последнего значение count будет равно значению атрибута chunksize, переданному в запросе.
Узлы row будут отсортированы по убыванию значений ID объектов.

Пример запроса:
1  https://techmill.ru/demo/partitions.xml?query=
2    <query class="TPerson" chunksize="1000">
3      <item part="0" name="ID"/>
4      <item part="1" name="TaxID" value="*"/>
5    </query>
Пример ответа:
01  <data eof="1">
02    <row>
03      <Min type="int64">76211</Min>
04      <Max type="int64">1158488</Max>
05      <Count type="int">1000</Count>
06    </row>
07    <row>
08      <Min type="int64">1158489</Min>
09      <Max type="int64">2112571</Max>
10      <Count type="int">1000</Count>
11    </row>
12    <row>
13      <Min type="int64">2112572</Min>
14      <Max type="int64">6605306</Max>
15      <Count type="int">1000</Count>
16    </row>
17    <row>
18      <Min type="int64">6605312</Min>
19      <Max type="int64">8424606</Max>
20      <Count type="int">1000</Count>
21    </row>
22    <row>
23      <Min type="int64">8424612</Min>
24      <Max type="int64">739895343</Max>
25      <Count type="int">1000</Count>
26    </row>
27    <row>
28      <Min type="int64">739895363</Min>
29      <Max type="int64">742336003</Max>
30      <Count type="int">121</Count>
31    </row>
32  </data>


Функция paste

(одним файлом)
Функция paste

Функция paste используется для вставки данных при выполнении операций Копировать/Вставить в приложении Обозреватель данных.

Функция имеет расширение .xml.

Значение параметра функции "query" должно представлять собой XML-документ с элементом paste, который должен включать в себя элемент root, представляющий собой стандартную XML-реплику со значениями свойств вставляемых объектов.

Элемент paste должен иметь атрибуты:

  • ClassID - идентификатор класса, объекты которого будут "вставлены"
  • ParentViewCurrentRecordID - идентификатор объекта, выбранного в "родительской" таблице данных в момент выполнения "вставки"
  • ParentClassID - идентификатор класса, отображаемого в "родительской" таблице данных в момент выполнения "вставки"
  • LinkMasterPropertyID, LinkDetailPropertyID - идентификаторы свойства-главного и свойства-подчиненного, по которым таблица данных, в которую выполняется вставка, связана с "родительской" таблицей данных

При удачном выполнении "вставки" функция вернет список идентификаторов добавленных объектов.

01https://techmill.ru/demo/paste.xml?query=
02  <paste ClassID="7291"
03       LinkDetailPropertyID="348"
04       LinkMasterPropertyID=""
05       ParentClassID="7291"
06       ParentViewCurrentRecordID="2559350">
07  <root Class="7291"
08        Connection="demo - techmill.ru/demo"
09        DBGUID="{C84A02C7-51EA-4068-A0BD-D6FB0BAD15F4}">
10    <object Class="7291" ID="1384201" IsMainObject="1" Parent="1384183">
11      <Description>сентябрь 2023/2024 учебный год</Description>
12      <LearnPeriodType IDREF="10849"/>
13      <BeginDate>2023-09-01</BeginDate>
14      <EndDate>2023-09-30</EndDate>
15      <PeriodNumber>9</PeriodNumber>
16      <LastMarkDate/>
17      <Name>сентябрь</Name>
18      <Creator IDREF="1276001"/>
19      <Created>2023-03-21 17:54:59</Created>
20      <Modifier IDREF="1276001"/>
21      <Modified>2023-05-06 00:00:42</Modified>
22      <Reader/>
23      <Writer IDREF="7001"/>
24    </object>
25    <object Class="7291" ID="1384203" IsMainObject="1" Parent="1384183">
26      <Description>октябрь 2023/2024 учебный год</Description>
27      <LearnPeriodType IDREF="10849"/>
28      <BeginDate>2023-10-01</BeginDate>
29      <EndDate>2023-10-31</EndDate>
30      <PeriodNumber>10</PeriodNumber>
31      <LastMarkDate/>
32      <Name>октябрь</Name>
33      <Creator IDREF="1276001"/>
34      <Created>2023-03-21 17:54:59</Created>
35      <Modifier IDREF="1276001"/>
36      <Modified>2023-05-06 00:00:42</Modified>
37      <Reader/>
38      <Writer IDREF="7001"/>
39    </object>
40  </root>
41</paste>


Функция pdfreport

(одним файлом)
Функция pdfreport

Функция pdfreport позволяет вызывать на выполнение отчеты класса TPDFTemplate и получать файлы, формируемые как результат выполнения отчетов.

Допустимые расширения:

  • .pdf - возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, отчет которого будет вызываться
  • "template" (обязательный) - имя отчета, который будет вызываться
  • "format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:
    • цветовой режим - допустимые значения "mono", "grey"; значение по умолчанию - "обычный" цветовой режим
    • внедрение шрифтов (для формата PDF) - допустимые значения "embed", "embedded"; значение по умолчанию - без внедрения шрифтов
  • "filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="Consent.mono.embed.pdf", что будет говорить о том, что будет возвращен pdf-документ, сформированный в монохромном режиме с внедренными шрифтами; значение по умолчанию: "pdfreport.pdf".

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата PDF, сформированный в режиме, определенном атрибутами параметра query (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове PDF-отчета:
1  <execute class="TBachAbiturSt" template="ConsEnrollment" format="grey.embedded.pdf" filename="Consent.pdf">
2    <row>
3      <ID>7926329</ID>
4      <BachCompetition>4327519</BachCompetition>
5      <PlaceType>7927327</PlaceType>
6    </row>
7  </execute>
При таком вызове будет выполнен PDF-отчет "ConsEnrollment" класса "TBachAbiturSt" с параметрами, переданными в элементе row. Данный отчет является "методом объекта", поэтому дополнительно использован параметр "ID". Полученный файл отчета будет сформирован с внедрением шрифтов в цветовом режиме "в градациях серого". В качестве ответа будет возвращен.pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("Consent.pdf"), в содержимом ответа будет передано содержимое файла.


Функция postblob

(одним файлом)
Функция postblob

Функция postblob позволяет установить значение поля таблицы, имеющее тип "большой объект". Функция может вызываться под пользователем, имеющим права доступа на запись к таблицам СУБД.

Функция имеет расширение .xml.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

  • id (обязательный) - идентификатор объекта, свойство которого нужно получить, или список идентификаторов объектов, разделенных ";" при передаче списка объектов для всех этих объектов будет установлено одинаковое значение поля
  • table (обязательный) - имя таблицы, содержащей поле, значение свойства которого нужно установить
  • field (обязательный) - имя поля таблицы, значение свойства которого нужно установить
  • subtype (обязательный) - порядковый номер элемента перечисления "TBlobSubtype" (Подтипы), определяющий подтип домена класса "большой объект", использованного для устанавливаемого значения

В качестве значения элемента query должно быть передано устанавливаемое значение в двоичном формате. При передаче этого значения функции могут быть выполнены преобразования, описанные в статье Принципы передачи параметров функциям RESTful-service.

1https://techmill.ru/demo/postblob.xml?query=
2    <query id="76328;5256545" table="TPersonPhoto" field="FPhotoFile" subtype="2">
3      <![CDATA[Q09NUFJFU1NFRAAABwAAADExMS5ibXBCTRYBAAAAAAAAPgAAACgAAAAiAAAAGwAAAAEAAQAAAAAA2AAAAMQOAADEDgAAAAAAAAAAAAAAAAAA////AP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/B/wf8AAAAD8H/B/wAAAAPwf8H/AAAAA/B/wf8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAA==]]>
4    </query>


Функция routinelog

(одним файлом)
Функция routinelog

Функция routinelog предназначена для создании записей истории вызова подпрограммы (метода, метода OLE-объекта, отчета) и набора значений параметров без вызова самой этой подпрограммы. Запись об истории вызова создается как объект класса "Вызовы" (TRoutineHistory) записи о значениях параметра создаются как объекты класса "Параметры вызовов" (TParameterHistory).

Допустимое расширение: .xml.

Функция имеет параметр query, который должен представлять собой XML документ, содержащий информацию о подпрограмме и значениях ее параметров. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент XML-документа должен иметь атрибут routine, значением которого должен быть идентификатор подпрограммы. Элемент должен иметь набор узлов, соответствующих параметрам подпрограммы и их значениям.

При передаче информации о параметрах необходимо учитывать Принципы передачи параметров функциям RESTful-service.

1https://techmill.ru/demo/routinelog.xml?query=
2<query routine="756584">
3  <AdmissionYear>7427462</AdmissionYear>
4  <AdmStage>8608398</AdmStage>
5  <PrevAdmissionYear>6843737</PrevAdmissionYear>
6  <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
7</query>

При успешном выполнении функции будет возвращен ответ с одним пустым элементом <data eof="1"/>.


Функция rtti

(одним файлом)
Функция rtti

Функция rtti позволяет получить информацию о типах (run-time type information, RTTI) в форматах XML или JSON.

Допустимые расширения:

  • .xml - для получения ответа в формате XML
  • .js/.json - для получения ответа в формате JSON

Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/rtti.xml

В качестве ответа будет возвращен XML-документ или JSON полученный рядом запросов к метаданных системы. Ответ будет состоять из элементов data, соответствующих каждому запросу, которые имеют узлы row на каждую запись возвращаемых данных. Для каждой записи будут узлы с именами, совпадающими со значениями свойств и значениями этих свойств.

Пример ответа:
01<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
02  ...
03</data>
04<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
05  <row>
06    <ID>1669</ID>
07    <Name>TFolder domain</Name>
08    <Description>Папка</Description>
09    <Required type="int">1</Required>
10    <Length type="int">255</Length>
11    <FolderMustExist type="int">1</FolderMustExist>
12  </row>
13</data>
14<data eof="1" handle="{06399069-7150-4087-8ACB-D14C809497C2}">
15  <row>
16    <ID>28</ID>
17    <Name>Boolean</Name>
18    <Description>Обычное логическое</Description>
19    <Required type="int">1</Required>
20    <TrueValue>Да</TrueValue>
21    <FalseValue>Нет</FalseValue>
22  </row>
23  <row>
24    <ID>170</ID>
25    <Name>Non-required boolean</Name>
26    <Description>Необязательное логическое</Description>
27    <Required type="int">0</Required>
28    <TrueValue>Да</TrueValue>
29    <FalseValue>Нет</FalseValue>
30  </row>
31  <row>
32    <ID>662765452</ID>
33    <Name>TProfileConditionAccess</Name>
34    <Description>Условия доступа профиля</Description>
35    <Required type="int">1</Required>
36    <TrueValue>Контролировать чтение и запись</TrueValue>
37    <FalseValue>Контролировать только запись</FalseValue>
38  </row>
39</data>
40<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
41  ...
42</data>
43<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
44  ...
45</data>


Функция selectblob

(одним файлом)
Функция selectblob

Функция selectblob позволяет получить значение свойства объекта имеющий тип "большие данные" (файл, изображение, и т.п.), а также позволяет сравнивать значения типа "большие данные" без получения самих этих данных.

При вызове функции допустимо указывать любые расширения. Расширение должно определяться содержимым, которое ожидается получить. В случае, если об этом нет достаточной информации, можно вызывать функцию с пустым расширением.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

  • class (обязательный) - имя класса, значение свойства которого нужно получить (или сравнить)
  • propname (обязательный) - имя свойства, значение свойства которого нужно получить (или сравнить)
  • id (обязательный) - в качестве значения этого параметрам может быть передано:
    • идентификатор объекта, значение свойства которого нужно получить
    • список идентификаторов объектов, разделенных ";"
    • идентификатор буфера, содержащего список объектов (подробнее о создании и наполнении буфера: Функция selectedbuffer, Функция selectionchanged)

Функция вернет следующий результат:

  • если в атрибуте ID был передан один объект или если содержимое (значение свойства) для всех переданных объектов одинаково, то вернется это одно значение
  • в других случаях вернется значение NULL

Таким образом, можно выполнять сравнение значений типа "большой объект" - если получено отличное от NULL значение, значит значения равны, иначе значения не равны. Получения самих значений во втором случае не происходит.

1https://techmill.ru/demo/selectblob?query=
2<query class="TPersonalDocument" propname="DocFile" ID="4562944;398621"/>


Функция selectedbuffer

(одним файлом)
Функция selectedbuffer

Функция selectedbuffer возвращает новый идентификатор буфера, в который далее можно добавлять объекты, что позволит выполнять различные операции с созданным таким образом набором объектов как с единым целым.
Для манипуляций списком объектов в буфере предназначена Функция selectionchanged.

Допустимое расширение: .xml

Функция возвращает XML-документ в узле которого с именем ID возвращается идентификатор созданного буфера.

Пример запроса:
  https://techmill.ru/demo/selectedbuffer.xml
Пример ответа:
1  <data eof="1">
2    <row>
3      <ID>1186174</ID>
4    </row>
5  </data>


Функция selectionchanged

(одним файлом)
Функция selectionchanged

Функция selectionchanged позволяет манипулировать списком объектов буфера. Для создания нового буфера предназначена функция Функция selectedbuffer.

Допустимое расширение: .xml

В значении параметра с именем "query" необходимо передать xml-документ, содержащий данные о существующем буфере и действиях, которые должны быть с ним проведены. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML-документ query должен иметь один элемент selectionchanged со следующим набором атрибутов:

  • handle (обязательный) - идентификатор буфера
  • ID - список идентификаторов объектов с разделителем ";", которые будут добавлены в буфер или исключены из него; значение может быть пустым только в случае, если выполняется полная очистка буфера, что предается значением атрибута cleanup
  • selected (обязательный) - указание о том, какое действие должно быть выполнено с переданным списком объектов; допустимые значения:
    • "0" - удалить объекты из буфера
    • "1" - добавить объекты в буфер
  • cleanup - указание о том, что нужно сделать перед добавлением или удалением объектов; допустимые значения:
    • "0" (значение по умолчанию) - не выполнять предварительных действий
    • "1" - очистить буфер перед выполнением действия

При успешном выполнении функция вернет XML-документ с одним элементом data и атрибутом eof="1".

1  https://techmill.ru/demo/selectionchanged.xml?query=
2    <selectionchanged handle="221024" ID="227222;76923;77312" selected="1" cleanup="1"/>
В буфер с идентификатором 1186175 будут добавлены объекты с идентификаторами 77222;76923;77312; перед добавлением буфер будет очищен.


Функция sessionlogoff

(одним файлом)
Функция sessionlogoff

Функция sessionlogoff позволяет удалить текущую сессию.

Допустимое расширение: .xml. Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/sessionlogoff.xml
Пример ответа:
  <data eof="1"/>


Функция setpropvalue

(одним файлом)
Функция setpropvalue

Функция setpropvalue позволяет изменять значения свойств объектов, доступные для изменения через обработчик сервера приложений.

Допустимое расширение: .xml.

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент setpropvalue с атрибутами, позволяющими идентифицировать объект и принадлежащее ему свойство, значение которого требуется изменить. Значение, которое должно быть установлено для свойства, передается как текст элемента setpropvalue Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Атрибуты элемента setpropvalue:

  • ID (обязательный) - идентификатор объекта, свойство которого должно быть изменено
  • class (обязательный, если не указан атрибут "propid") - имя класса, свойство которого должно быть изменено
  • propname (обязательный, если не указан атрибут "propid") - имя свойства, принадлежащего классу, переданному значением атрибута "class", значение которого должно быть изменено
  • propid (обязательный, если не указаны атрибуты "class" и "propname") - идентификатор свойства, значение которого должно быть изменено
  • noanalyze

Для передачи информации о свойстве, значение которого должно быть изменено, можно использовать атрибут "propid" или пару атрибутов "class" и "propname".

1  <setpropvalue ID="4912468" class="TPerson" propname="MiddleName">
2    "Алексеевич"
3  </setpropvalue>
Установить значение "Алексеевич" для свойства класса "TPerson" с именем "MiddleName" для объекта с идентификатором "4912468".

При успешном выполнении функция возвращает xml-документ с пустым набором данных:

<data eof="1"/>

При неуспешном выполнении функция возвращает xml-документ с текстом сообщения об ошибке, например:

1<error>
2  <message>Property not found.</message>
3  <className>Exception</className>
4</error>


Функция storeexternaldata

(одним файлом)
Функция storeexternaldata
Функция storeexternaldata позволяет выполнить сохранение файла как "внешних данных" определенного домена. Файл данных будет записан в файловое хранилище, в виде, определяемом доменом.

Допустимое расширение: .xml

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент storeexternaldata с атрибутом domain, значением которого должно быть имя или идентификатор домена класса "Внешние данные". Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Запрос:
1  https://techmill.ru/demo/storeexternaldata.xml?query=
2    <storeexternaldata domain="TPhotoFile">
3      <![CDATA[Q09NUFJFU1NFRAAABwAAADExMS5ibXBCTRYBAAAAAAAAPgAAACgAAAAiAAAAGwAAAAEAAQAAAAAA2AAAAMQOAADEDgAAAAAAAAAAAAAAAAAA////AP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/B/wf8AAAAD8H/B/wAAAAPwf8H/AAAAA/B/wf8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAA==]]>
4    </storeexternaldata>
Ответ:
1  <data eof="1">
2    <row>
3      <Result>{1B8C156B-76F6-4EC1-987D-F6C0000DB343}</Result>
4    </row>
5  </data>


Функция sysinfo

(одним файлом)
Функция sysinfo

Функция sysinfo позволяет получить информацию о системе в формате XML с набором атрибутов, соответствующих характеристикам системы.

Допустимое расширение: .xml. Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/sysinfo.xml
Пример ответа:
  <sysinfo major="3" minor="2" release="2" build="304" PerformExcelReports="0" PerformOleObjectMethods="0" PerformPDFReports="0" PerformWordReports="0" PerformXSLTReports="0" GroupMethods="0"/>


Функция timebias

(одним файлом)
Функция timebias

Допустимое расширение - .xml

Используется JavaScript-клиентом и "Обозревателем данных".

Параметр query содержит текст xml-документа, в котором в атрибутах корневого узла разложены компоненты текущей даты и текущего времени клиента:

<timebias Y="2024" M="03" D="22" H="12" Mi="30" S="00" Ms="100"/>

Имя корневого элемента не имеет значения. АтрибутY содержит год, M - месяц (нумеруются с 1, январь - "1", декабрь - "12"), D - число внутри месяца, H - часы, Mi - минуты, S - секунды, Ms - миллисекунды.

Ответ представляет собой xml-документ следующей структуры:

1  <data eof="1">
2    <row>
3      <Bias type="dbl">
4        0,19860191
5      </Bias>
6    </row>
7  </data>

здесь числовое значение в элементе Bias содержит количество суток (в данном примере - 0 целых, 1 десятая, 9 сотых, 8 тысячных и так далее), которые нужно прибавлять к датам, полученным с сервера приложений, чтобы получить даты в часовом поясе клиента. Атрибут type, атрибут eof (оба - вместе со значениями), и имена всех элементов ответа являются неизменными, и передаются для унификации процедуры разбора ответа.


Функция wordreport

(одним файлом)
Функция wordreport

Функция wordreport позволяет вызывать на выполнение отчеты класса TWordTemplate и получать файлы, формируемые как результат выполнения отчетов. Файлы могут быть возвращены как в форматах Word (.doc,.docx), так и с преобразованием в другие форматы. Исключением являются интерактивные отчеты (требующие при формировании диалога с пользователем). Такие отчеты не могут вызваться при помощи данной функции.

Допустимые расширения:

  • .doc - для получения файла отчета в формате DOC
  • .docx - для получения файла отчета в формате DOCX
  • .html - для получения файла отчета в формате HTML; формирование html-документа выполняется средствами MS Word;
  • .rtf - для получения файла отчета в формате RTF
  • .pdf - для получения файла отчета в формате PDF; преобразование.doc/.docx-файла в pdf-документ выполняется средствами самого Word; возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, отчет которого будет вызываться
  • "template" (обязательный) - имя отчета, который будет вызываться
  • "format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:
    • тип файла результата - допустимые значения совпадают с возможными расширениями вызова функции (без дополнительной точки)
  • "filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="ListenerCard.pdf", что будет говорить о том, что будет возвращен pdf-документ.
    Значение по умолчанию: "wordreport" с расширением, совпадающим с расширением вызываемой функции.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного атрибутами параметра query или расширением функции wordreport (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове Word-отчета:
1  <execute class="TDPOStatus" template="ListenerCard" format="grey.embed.pdf" filename="ListenerCard.pdf">
2    <row>
3      <ID>5201838</ID>
4      <DPOInstitute>4327519</DPOInstitute>
5      <SecondSigner>4469840</SecondSigner>
6    </row>
7  </execute>
При таком вызове будет выполнен Word-отчет "ListenerCard" класса "TDPOStatus" с параметрами, переданными в элементе row. Данный отчет является "методом объекта", поэтому дополнительно использован параметр "ID". Полученный файл отчета будет преобразован в формат PDF с внедрением шрифтов в цветовом режиме "в градациях серого". Преобразование будет выполнено средствами приложения MS Word. В качестве ответа будет возвращен.pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("ListenerCard.pdf"), в содержимом ответа будет передано содержимое файла.


Функция xsltreport

(одним файлом)
Функция xsltreport

Функция xsltreport позволяет вызывать на выполнение отчеты класса TXSLTTemplate и получать файлы, формируемые как результат выполнения отчетов.

Допустимые расширения:

  • .xml
  • .html
  • .txt
  • без расширения

Для данного вида отчета тип и расширение возвращаемого файла будут определены самим XSLT-отчетом (будут заданы в элементе "xsl:output" в шаблоне отчета). Вызов функции с тем или иным расширением не повлияет на тип и расширение файла-результата.

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, отчет которого будет вызываться
  • "template" (обязательный) - имя отчета, который будет вызываться
  • "filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition.
    Значение по умолчанию: имя вызываемого отчета с расширением, которое будет определено самим отчетом.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного самим отчетом. В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове XSLT-отчета:
1  <execute class="TObject" template="SelectDataToText" filename="QueryResult.txt">
2    <row>
3      <ClassName>TCountry</ClassName>
4      <Query></Query>
5    </row>
6  </execute>
При таком вызове будет выполнен XSLT-отчет "SelectDataToText" класса "TObject" с параметрами, переданными в элементе row. Данный отчет является "методом класса", поэтому параметр "ID" в состав параметров не добавлен. В качестве ответа будет возвращен текстовый файл. В заголовке ответа в поле Content-Disposition будет передано имя файла ("QueryResult.txt"), в содержимом ответа будет передано содержимое файла.


Руководство разработчика для построителя запросов

(раздел целиком) (одним файлом)
Руководство разработчика для построителя запросов
  • Информация о приложении
  • Требования к провайдеру
  • Использование провайдера БД Парус8
  • Разработка шаблонов
  • Интерфейс автоматизации
  • Справочник по интерфейсам


Информация о приложении

(одним файлом)
Информация о приложении
Приложение QueryBuilder представляет собой документ-ориентированное MDI-проиложение.
Документом является запрос. Запросы сохраняются в файле с расширением .MQR. Файлы запросов представляют собой xml-документы определенной структуры. Для доступа к данным БД приложение использует провайдеры данных - библиотеки объектов, реализующих опубликованные интерфейсы. Идентификатор использованного для построения запроса провайдера сохраняется в файле запроса. Если открыть файл с провайдером, не соответствующим текущему, будет выдано предупреждение.


Требования к провайдеру

(раздел целиком) (одним файлом)
Требования к провайдеру

Интерфейсы провайдера описаны в библиотеке типов файла QueryBuilder.exe и в файле QueryBuilder_TLB.pas. Собственно, объект-провайдер реализует Интерфейс IInfoProvider. Каждый CoClass, реализующий указанный интерфейс, прописывается в ветке реестра HKLM\Software\QueryBuilder\Providers добавлением параметра, имя которого определяет наименование провайдера, а значение - CLSID провайдера.

Метаданные (информация о таблицах, полях и типах данных) предоставляются в виде именованных элементов, то есть каждый из них реализует интерфейс INamedItemInfo

  • Интерфейс IInfoProvider
  • Интерфейс IDataSet
  • Интерфейс INamedItemInfo
  • Интерфейс ITableInfo
  • Интерфейс IFieldInfo
  • Интерфейс ITypeInfo
  • Интерфейс IEnumerationItem


Интерфейс IInfoProvider

(одним файлом)
Интерфейс IInfoProvider
Провайдер реализует интерфейс
01  IInfoProvider = interface(IUnknown)
02    ['{64F8072B-7250-4C57-BA8E-D018C7B72CC7}']
03    function Get_TableCount: Integer; safecall;
04    function Get_Table(Index: Integer): ITableInfo; safecall;
05    function Perform(const SQL: WideString): IDataSet; safecall;
06    procedure Connect(const DataBase: WideString;
07      const UserName: WideString;
08      const Password: WideString); safecall;
09    function Get_CLSID: TGUID; safecall;
10    function Get_DateLiteral: WideString; safecall;
11    function Get_TimeLiteral: WideString; safecall;
12    function Get_DateTimeLiteral: WideString; safecall;
13  end;
  • функция Get_CLSID возвращает GUID класса-провайдера.
  • процедура Connect осуществляет соединение с БД.
  • функция Get_TableCount возвращает количество таблиц, доступ к которым предоставляется провайдером.
  • функция Get_Table возвращает ссылку на информацию о таблице с номером Index. Ссылка на интерфейс ITableInfo или интерфейс ITableInfo2
  • функция Perform принимает текст сформированного SQL-запроса и возвращает ссылку на набор данных. Набор данных реализует интерфейс IDataSet.
  • функция Get_DateLiteral возвращает строку, определяющую способ включения в запрос литерала типа "Дата".
  • функция Get_TimeLiteral возвращает строку, определяющую способ включения в запрос литерала типа "Время".
  • функция Get_DateTimeLiteralвозвращает строку, определяющую способ включения в запрос литерала типа "Дата со временем".


Интерфейс IDataSet

(одним файлом)
Интерфейс IDataSet
Набор данных реализует интерфейс
1   IDataSet = interface(IUnknown)
2    ['{3CED7395-8482-4EF6-8A15-7744348063C2}']
3    function Get_FieldCount: Integer; safecall;
4    function Get_FieldName(Index: Integer): WideString; safecall;
5    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
6    procedure Next; safecall;
7    function Eof: WordBool; safecall;
8  end;
Набор данных представляет собой однонаправленный курсор, каждая строка которого является набором именованных и нумерованных полей.
  • процедура Next осуществляет переход к следующей записи курсора.
  • функция Eof возвращает True в случае достижения конца курсора.
  • функция Get_FieldCount возвращает количество полей в строке курсора.
  • функция Get_FieldName возвращает имя поля с номером Index.
  • функция Get_Field возвращает значение поля, имя или номер которого задан параметром (если строка, то имя, если число, то номер). Допустимо возвращать значение Null для пустых полей.


Интерфейс INamedItemInfo

(одним файлом)
Интерфейс INamedItemInfo
Каждый элемент метаданных (таблица, поле, тип) обязательно реализует интерфейс
1  INamedItemInfo = interface(IUnknown)
2    ['{14894363-28DA-4E71-B0BC-9C5CE811BC8F}']
3    function Get_Name: WideString; safecall;
4    function Get_Caption: WideString; safecall;
5    function Get_ID: WideString; safecall;
6  end;

Именованный элемент имеет имя, наименование и идентификатор. Имя используется для именования сущности в сформированном SQL-запросе, идентификатор необходим для идентификации сущности в рамках провайдера, таблицы и типы данных имеют глобальное пространство идентификаторов, поля имеют уникальные идентификаторы в пределах последовательности наследуемых таблиц. Никаких ограничений на значения идентификаторов, кроме уникальности, не накладывается.

  • функция Get_Name возвращает имя сущности.
  • функция Get_Caption возвращает наименование сущности.
  • функция Get_ID возвращает идентификатор сущности.


Интерфейс ITableInfo

(раздел целиком) (одним файлом)
Интерфейс ITableInfo
Информация о таблице представляется объектом через интерфейс (наследник INamedItemInfo )
1  ITableInfo = interface(INamedItemInfo)
2    ['{3FC1998A-9031-4936-82B5-8CAA2219085E}']
3    function Get_FieldCount: Integer; safecall;
4    function Get_Field(Index: Integer): IFieldInfo; safecall;
5    function Get_PrimaryKey: IFieldInfo; safecall;
6    function Get_Uplink: IFieldInfo; safecall;
7    function Get_Parent: ITableInfo; safecall;
8  end;
  • функция Get_FieldCount возвращает количество полей в таблице.
  • функция Get_Field возвращает ссылку на поле с номером Index. Ссылка на интерфейс IFieldInfo
  • функция Get_PrimaryKey возвращает ссылку на поле, являющееся первичным ключем. Это поле должно быть задано.
  • функция Get_Uplink возвращает ссылку на поле, осуществляющее иерархическую связь между записями таблицы. Если это поле задано, записи отображаются в виде иерархии.
  • функция Get_Parent возвращает ссылку на родительскую таблицу. Дочерняя таблица связана с родительской первичными ключами, т. е. соотношением 1:1. Если таблица не имеет родительской, возвращается nil.
  • Интерфейс ITableInfo2
  • Интерфейс ITableInfo3


Интерфейс ITableInfo2

(одним файлом)
Интерфейс ITableInfo2
Для таблиц, имеющих полиморфные ссылки, реализуется интерфейс (наследник ITableInfo )
1  ITableInfo2 = interface(ITableInfo)
2    ['{9DF4C8AC-1DA2-4E7B-BF44-7EDD7A269418}']
3    function Get_PolymorphCount: Integer; safecall;
4    function Get_PolymorphTable(Index: Integer): ITableInfo; safecall;
5    function Get_PolymorphField(Index: Integer): IFieldInfo; safecall;
6  end;
Полиморфной ссылкой является, например, ссылка, физически размещенная в родительской таблице, указывающая на свою запись. Реализация этого интерфейса не является обязательной.
  • функция Get_PolymorphCount возвращает количество полиморфных ссылок.
  • функция Get_PolymorphTable возвращает ссылку на таблицу, на которую указывает полиморфная ссылка номер Index.
  • функция Get_PolymorphTable возвращает ссылку на поле, реализующее полиморфную ссылку номер Index. Это поле должно иметь тип dtReference, информация о его типе должна реализовать интерфейс IReferenceInfo. Значение, возвращаемое функцией Get_TargetTable этого интерфейса в данном случае не имеет значения и игнорируется.
См. также
  • Интерфейс IReferenceInfo


Интерфейс ITableInfo3

(одним файлом)
Интерфейс ITableInfo3
Для таблиц, при запросах к которым требуется наложение дополнительных условий отбора, реализуется интерфейс (наследник ITableInfo )
01  ITableInfo3 = interface(ITableInfo)
02    ['{3FB73AA9-010C-48DA-81C7-E1DCFE2E6136}']
03    function GetPersistentClause(const Alias: WideString): WideString; safecall;
04    function GetPreConditionsCount: Integer; safecall;
05    function GetPreConditionCaption(Index: Integer): WideString; safecall;
06    function GetPreConditionCategory(Index: Integer): WideString; safecall;
07    function Get_ActivePreCondition(Index: Integer): WordBool; safecall;
08    procedure Set_ActivePreCondition(Index: Integer; Value: WordBool); safecall;
09    function GetPreConditionParamsCount(Index: Integer): Integer; safecall;
10    function GetPreConditionParam(Index: Integer; PreConditionIndex: Integer): IOptionInfo; safecall;
11  end;
  • функция GetPersistentClause возвращает выражение дополнительного условия отбора. Алиас таблицы передается в параметре Alias.


Интерфейс IFieldInfo

(одним файлом)
Интерфейс IFieldInfo
Информация о поле поставляется объектом, реализующим интерфейс (наследник INamedItemInfo )
1  IFieldInfo = interface(INamedItemInfo)
2    ['{19054DAD-8D35-4B39-8EB7-FD3254BD2934}']
3    function Get_TypeInfo: ITypeInfo; safecall;
4    function Get_DisplayMode: TDisplayMode; safecall;
5  end;
  • функция Get_DisplayMode возвращает роль поля при показе таблицы. Возможные значения (тип TDisplayMode):
    • dmAlways - поле является ключевым, всегда показывается
    • dmNever - поле является служебным (первичным ключем, например). Никогда не показывается.
    • dmOnDemand - поле является обычным информационным, показывается по требованию пользователя.
  • функция Get_TypeInfo возвращает ссылку на информацию о типе данных поля. Возвращаете ссылку на один из интерфейсов-наследников интерфейса ITypeInfo


Интерфейс ITypeInfo

(раздел целиком) (одним файлом)
Интерфейс ITypeInfo
Информация о типах полей поставляется в виде набора объектов, каждый из которых реализует интерфейс (наследник INamedItemInfo )
1  ITypeInfo = interface(INamedItemInfo)
2    ['{2B6A5E20-3C36-4574-89DB-7C873A5C4A00}']
3    function Get_Required: WordBool; safecall;
4    function Get_SimpleType: TSimpleType; safecall;
5  end;
Информация о конкретном типе передается при помощи реализации одного из наследников этого интерфейса.
  • функция Get_Required возвращает True, если значение поля обязательно для задания.
  • функция Get_SimpleType возвращает информацию о простом типе данных. В зависимости от возвращаемого значения объект должен также реализовывать один из интерфейсов конкретных типов (см. далее). Возможные значения (тип TSimpleType ):
    • dtString - строковый тип. Обязательно реализуется интерфейс IStringInfo
    • dtInteger - целочисленный тип. Обязательно реализуется интерфейс IIntegerInfo
    • dtFloat - вещественный тип. Обязательно реализуется интерфейс IFloatInfo
    • dtDate - тип "дата". Обязательно реализуется интерфейс IDateInfo
    • dtTime - тип "время". Обязательно реализуется интерфейс ITimeInfo
    • dtDateTime - тип "дата со временем". Обязательно реализуется интерфейс IDateTimeInfo
    • dtBoolean - логический тип. Обязательно реализуется интерфейс IBooleanInfo
    • dtEnumeration - перечисление. Обязательно реализуется интерфейс IEnumerationInfo
    • dtReference - ссылка. Обязательно реализуется интерфейс IReferenceInfo
    • dtBlob - Большой двоичный объект. Обязательно реализуется интерфейс IBlobInfo.
  • Интерфейс ITypeInfo2
  • Интерфейс IStringInfo
  • Интерфейс IIntegerInfo
  • Интерфейс IFloatInfo
  • Интерфейс IDateInfo
  • Интерфейс ITimeInfo
  • Интерфейс IDateTimeInfo
  • Интерфейс IBooleanInfo
  • Интерфейс IEnumerationInfo
  • Интерфейс IReferenceInfo
  • Интерфейс IBlobInfo


Интерфейс ITypeInfo2

(одним файлом)
Интерфейс ITypeInfo2
Информация о предоставляемых провайдером дополнительных возможностях фильтрации (наследник интерфейса ITypeInfo)
1  ITypeInfo2 = interface(ITypeInfo)
2    ['{77F58BDF-F01C-40F3-B193-1027AD8C4EDA}']
3    function GetSpecialFilterCount: Integer; safecall;
4    function GetSpecialFilterText(Index: Integer): WideString; safecall;
5    function EditSpecialFilter(Index: Integer; var Filter: WideString): WordBool; safecall;
6  end;
  • функция GetSpecialFilterCount возвращает количество дополнительных элементов списка, выпадающего при выборе фильтра по колонке.
  • функция GetSpecialFilterText возвращает текст дополнительного элемента списка, выпадающего при выборе фильтра по колонке, с номером Index.
  • функция EditSpecialFilter вызывается в момент выбора пользователем дополнительного элемента списка, выпадающего при выборе фильтра по колонке, с номером Index. Значение выражения фильтра передается и возвращается в параметре Filter. Функция возвращает True в случае, если выражение, возвращенное в параметре Filter нужно применить для фильтрации столбца запроса, False - в противном случае.


Интерфейс IStringInfo

(одним файлом)
Интерфейс IStringInfo
Информация о строковом типе (наследник интерфейса ITypeInfo)
1  IStringInfo = interface(ITypeInfo)
2    ['{74AC4C03-E803-421B-B30D-1A2D2C49827F}']
3    function Get_Length: Integer; safecall;
4  end;
  • функция Get_Length возвращает максимальную длину строки.


Интерфейс IIntegerInfo

(одним файлом)
Интерфейс IIntegerInfo
Информация о целочисленном типе (наследник интерфейса ITypeInfo)
1  IIntegerInfo = interface(ITypeInfo)
2    ['{9003B25E-926D-42AE-A907-813DF3A8343E}']
3    function Get_MaxValue: Integer; safecall;
4    function Get_MaxValueUsed: WordBool; safecall;
5    function Get_MinValue: Integer; safecall;
6    function Get_MinValueUsed: WordBool; safecall;
7  end;
  • функция Get_MaxValueUsed возвращает True, если значение имеет верхнюю границу.
  • функция Get_MaxValue возвращает верхнюю границу значения, если есть.
  • функция Get_MinValueUsed возвращает True, если значение имеет нижнюю границу.
  • функция Get_MinValue возвращает нижнюю границу значения, если есть.


Интерфейс IFloatInfo

(одним файлом)
Интерфейс IFloatInfo
Информация о вещественном типе (наследник интерфейса ITypeInfo )
1  IFloatInfo = interface(ITypeInfo)
2    ['{E9B56C6D-47DC-4AB9-9E80-6EEF77708704}']
3    function Get_MaxValue: Double; safecall;
4    function Get_MaxValueUsed: WordBool; safecall;
5    function Get_MinValue: Double; safecall;
6    function Get_MinValueUsed: WordBool; safecall;
7    function Get_Precision: Integer; safecall;
8    function Get_Scale: Integer; safecall;
9  end;
  • функция Get_MaxValueUsed возвращает True, если значение имеет верхнюю границу.
  • функция Get_MaxValue возвращает верхнюю границу значения, если есть.
  • функция Get_MinValueUsed возвращает True, если значение имеет нижнюю границу.
  • функция Get_MinValue возвращает нижнюю границу значения, если есть.
  • функция Get_Precision возвращает максимальное количество значащих десятичных цифр в значении.
  • функция Get_Scale возвращает максимальное количество десятичных цифр после запятой.


Интерфейс IDateInfo

(одним файлом)
Интерфейс IDateInfo
Информация о типе "Дата" (без времени) (наследник интерфейса ITypeInfo )
1  IDateInfo = interface(ITypeInfo)
2    ['{DA392510-105F-4655-9A38-18ECA2FBEB97}']
3  end;
Не имеет методов.


Интерфейс ITimeInfo

(одним файлом)
Интерфейс ITimeInfo
Информация о типе "Время" (без даты) (наследник интерфейса ITypeInfo )
1  ITimeInfo = interface(ITypeInfo)
2    ['{D7067CAC-67A5-41DB-8D95-40409D8658AB}']
3  end;
Не имеет методов.


Интерфейс IDateTimeInfo

(одним файлом)
Интерфейс IDateTimeInfo
Информация о типе "Дата со времемем" (наследник интерфейса ITypeInfo )
1  IDateTimeInfo = interface(ITypeInfo)
2    ['{7F5CC8F9-8CE1-4DB7-8932-884EF3BAB538}']
3  end;
Не имеет методов.


Интерфейс IBooleanInfo

(одним файлом)
Интерфейс IBooleanInfo
Информация о логическом типе (наследник интерфейса ITypeInfo )
1  IBooleanInfo = interface(ITypeInfo)
2    ['{8256EDF9-8613-4970-850C-50047839D6BF}']
3    function Get_TrueValue: WideString; safecall;
4    function Get_FalseValue: WideString; safecall;
5  end;
  • функция Get_TrueValue возвращает отображаемую строку для значения True (например, "Да").
  • функция Get_FalseValue возвращает отображаемую строку для значения False (например, "Нет").


Интерфейс IEnumerationInfo

(одним файлом)
Интерфейс IEnumerationInfo
Информация о перечислимом типе (наследник интерфейса ITypeInfo )
1  IEnumerationInfo = interface(ITypeInfo)
2    ['{B58A3F23-1AAC-4420-ADFF-B23B9938A994}']
3    function Get_ItemCount: Integer; safecall;
4    function Get_Item(Index: Integer): IEnumerationItem; safecall;
5  end;
Перечислимый тип определяет набор значений, которые может принимать поле. Значения в таблице трактуются как равные имени элемента перечисления.
  • функция Get_ItemCount возвращает количество элементов перечисления.
  • функция Get_Item возвращает ссылку на элемент перечисления с номером Index, реализующий интерфейс IEnumerationItem


Интерфейс IReferenceInfo

(одним файлом)
Интерфейс IReferenceInfo
Информация о типе "ссылка" (наследник интерфейса ITypeInfo )
1  IReferenceInfo = interface(ITypeInfo)
2    ['{309C8CB1-4A1C-4E58-BC3F-D1AF27861A8F}']
3    function Get_TargetTable: ITableInfo; safecall;
4  end;
  • функция Get_TargetTable возвращает ссылку на таблицу, с которой осуществляется связь. Возвращается ссылка на интерфейс ITableInfo


Интерфейс IBlobInfo

(одним файлом)
Интерфейс IBlobInfo
Информация о типе "больших двоичных объектов" (наследник интерфейса ITypeInfo )
1  IBlobInfo = interface(ITypeInfo)
2    ['{3905C9C4-EAEB-4844-BB55-3F524F1F3FAC}']
3    function Get_SubType: TBlobSubType; safecall;
4  end;
  • функция Get_SubType возвращает подтип большого двоичного объекта. Одно из следующих значений (тип TBlobSubType ):
    • bsText - текст
    • bsImage - изображение
    • bsBinary - двоичные данные


Интерфейс IEnumerationItem

(одним файлом)
Интерфейс IEnumerationItem
Информация об элементе перечисления (наследник INamedItemInfo )
1  IEnumerationItem = interface(INamedItemInfo)
2    ['{6953507C-D477-4B8D-9443-A9E5FE7137ED}']
3    function Get_Position: Integer; safecall;
4  end;
Значения в таблице трактуются как равные имени элемента перечисления.
  • функция Get_Position возвращает позицию элемента перечисления.
См. также
  • Интерфейс IEnumerationInfo


Использование провайдера БД Парус8

(раздел целиком) (одним файлом)
Использование провайдера БД Парус8
  • Использование пользовательских приложений.
  • Информация о базе данных


Использование пользовательских приложений.

(одним файлом)
Использование пользовательских приложений.
Библиотека ParusInfoProvider.dll содержит реализацию провайдера для БД Парус8. Провайдер реализует, в дополнение к обязательным, интерфейс, позволяющий управлять им посредством механизма "Пользовательских приложений":
1  IParusProvider = interface(IDispatch)
2    ['{4864AE99-80E6-4FC6-9DB0-EAB248F72362}']
3    procedure Connect(const Database: WideString;
4      const UserName: WideString;
5      const Password: WideString); safecall;
6    property QueryObject: OleVariant;
7    property StoredProcObject: OleVariant;
8  end;
Объект-провайдер может установить связь с БД либо самостоятельно с использованием переданных в метод Connect параметров соединения, либо с помощью объектов Query и StoredProc , предоставляемых системой Парус8 для использования в пользовательских приложениях. В свою очередь, созданный провайдер с установленным соединением может быть передан в метод Execute объекта QueryBuilder.Application . Вторым параметром может быть передано значение, представляющее структуру запроса. Это может быть либо строка с указанием имени файла, либо объект, реализующий интерфейс IStream (например, MSXML.DOMDocument ), либо строка, представляющая собой xml-документ. Все средства манипуляции структурой и поведением запроса предоставляются на уровне работы с xml-документом, описывающим запрос.
Пример скрипта пользовательского приложения на DelphiScript
01procedure QueryBuilderTest;
02var
03  LApplication: OleVarint;
04  LProvider: OleVarint;
05  LDocument: OleVariant;
06begin
07  //описание структуры запроса. Из BLOB, из файла, из строки - откуда угодно
08  LDocument := CreateOleObject('MSXML.DOMDocument');
09  //LDocument реализует IXMLDOMDocument и IStream
10  LDocument.loadXML('<Query Provider="{B3079C97-6EBC-43EB-880F-58F094B322B0}">' +
11    '<Item Type="Table" Table="AGNLIST" Alias="MAIN" TableAlias="MAIN">'  +
12      '<Item ColumnIndex="0" Type="Field" Field="AGNABBR" Table="AGNLIST" ' +
13        'Alias="MAIN_AGNABBR" TableAlias="MAIN"/>' +
14      '<Item ColumnIndex="1" Type="Field" Field="VERSION" Table="AGNLIST" ' +
15        'Alias="MAIN_VERSION" TableAlias="MAIN"/>' +
16    '</Item>' +
17  '</Query>');
18
19  //Скрытие дерева структуры
20  LDocument.documentElement.setAttribute('TreeWidth', 0);
21
22  //Наложение условий отбора на колонку
23  LDocument.selectSingleNode('/*/Item/Item[@Field="AGNABBR" and @Table="AGNLIST"]').
24    setAttribute('ColumnFilter', 'Б*');
25
26  //Переименование колонки
27  LDocument.selectSingleNode('/*/Item/Item[@Field="VERSION" and @Table="AGNLIST"]').
28    setAttribute('Caption', 'Версия');
29
30
31  //создание провайдера и передача ему объектов для соединения с БД
32  LProvider := CreateOleObject('ParusInfoProvider.ParusProvider');
33  LProvider.QueryObject := Query;
34  LProvider.StoredProcObject := StoredProc;
35
36  //создание и использование объекта-приложения QueryBuilder
37  LApplication := CreateOleObject('QueryBuilder.Application');
38
39  //В качестве второго параметра передается ОБЪЕКТ, через
40  //   IStream содержащий структуру запроса
41  LApplication.Execute(LProvider, LDocument);
42  LApplication.Visible := True;
43
44  //Ожидание завершения работы с приложением
45  repeat
46    Application.ProcessMessages;
47  until not LApplication.Visible;
48
49end;
50
Интерфейс автоматизации поддерживает также метод для автоматического применения шаблона для переноса в Excel.
Допустим, .MQR-файл, описывающий запрос, содержащий шаблон с именем "Простой Перенос" загружен в раздел "Модули пользовательских приложений" с мнемокодом "QueryData". Для этого необходимо создать модуль пользовательского приложения с типом "COM-сервер" или "Надстройка Excel" и загрузить из файла .MQR-файл. Проверки соответствия формата загружаемого файла заявленному типу модуля пользовательского приложения Парус не производит, что позволяет воспользоваться этим трюком. Тогда:
01procedure QueryBuilderTemplateTest;
02var
03  LApplication: OleVarint;
04  LProvider: OleVarint;
05  S: string;
06begin
07  Query.SQL.Text := 'select BMODULE from V_UAMODULES where SCODE = :CODE';
08  //мнемокод модуля пользовательского приложения, содержащего
09  //загруженный .MQR-файл
10  Query.ParamByName('CODE').Value := 'QueryData';
11  Query.Open;
12  S := Query.FieldByName('BMODULE').AsString;
13  Query.Close;
14
15 //создание провайдера и передача ему объектов для соединения с БД
16  LProvider := CreateOleObject('ParusInfoProvider.ParusProvider');
17  LProvider.QueryObject := Query;
18  LProvider.StoredProcObject := StoredProc;
19
20  //создание и использование объекта-приложения QueryBuilder
21  LApplication := CreateOleObject('QueryBuilder.Application');
22
23  //В качестве второго параметра передается СТРОКА, содержащая xml с описанием
24  //структуры запроса и шаблоны для переноса в Excel
25  LApplication.ExecuteTemplate(LProvider, S, 'Простой Перенос');
26end;


Информация о базе данных

(одним файлом)
Информация о базе данных
Провайдер Парус8 предоставляет информацию о четырех типах таблиц:
  1. Представление, описанное при помощи метаданных Парус8 как "вызываемое с клиента". В этом случае полями таблицы являются описанные атрибуты класса с соответствующими типами.
  2. Таблица, имеющая клиентский доступ и связанная с разделом, не имеющим ни одного описанного доступного представления, но имеющим описанные физические атрибуты. Информация о полях берется из метаданных Парус8
  3. Таблица, имеющая клиентский доступ и связанная с разделом, не имеющим ни одного описанного доступного представления, и не имеющим описанных атрибутов. Информация о полях берется из метаданных Oracle.
  4. Таблица, имеющая клиентский доступ и не связанная ни с каким разделом. Информация о полях берется из метаданных Oracle.


Разработка шаблонов

(раздел целиком) (одним файлом)
Разработка шаблонов

Шаблон представляет собой обычную рабочую книгу Excel.

Шаблоны для переноса данных в Excel физически интегрируются внутрь .MQR-файла и хранятся вместе с запросом. Разработку шаблона можно вести независимо, используя только Microsoft Excel (запуская его самостоятельно), а потом загрузить в файл запроса, а можно воспользоваться пунктом меню "Редактировать" на странице "Шаблоны".

Для взаимодействия с источником данных рабочая книга-шаблон должна содержать в любом модуле макрос с именем "Template" (без кавычек) с одним параметром. При выполнении переноса данных по этому шаблону QueryBuilder произведет вызов этого метода, передав в качестве фактического значения параметра объект, реализующий интерфейс IExternalQuery. Никаких других требований к рабочей книге-шаблону не выдвигается.
В примере показан запрос на таблицу AGNLIST (провайдер Oracle), показывающий как простой перенос данных, так и сводную таблицу со сводной диаграммой распределения записей таблицы по полю CRN.
Пример запроса с шаблонами
В примере показан запрос на таблицу "TField" (провайдер Мельницы Данных), показывающий как простой перенос данных, так и сводную таблицу со сводной диаграммой распределения записей таблицы.
Пример запроса с шаблонами для Мельницы Данных`

  • Интерфейс IExternalQuery
  • Интерфейс IExternalDataSet


Интерфейс IExternalQuery

(одним файлом)
Интерфейс IExternalQuery
Объект, реализующий этот интерфейс, передается в макрос генерации отчета Excel (Template). Все его свойства и методы доступны для испоьзования в процессе генерации отчета
01  IExternalQuery = interface(IDispatch)
02    ['{1A86D1DA-A56E-4D53-88F9-7A035D7D12B4}']
03    function Select(const SQL: WideString): IExternalDataSet; safecall;
04    function SelectedRecordsCount: Integer; safecall;
05    function SelectedRecord(Index: Integer): OleVariant; safecall;
06    procedure PlaceCurrentQuery(const Sheet: IDispatch;
07      CaptionsNeeded: WordBool = False; Row: Integer = 1;
08      Column: Integer = 1; ShiftRows: WordBool = True;
09      ShiftColumns: WordBool = False); safecall;
10    procedure PlaceQuery(const Sheet: IDispatch; const DataSet: ExternalDataSet;
11      Row: Integer = 1; Column: Integer = 1; ShiftRows: WordBool = True;
12      ShiftColumns: WordBool = False); safecall;
13    property CurrentQuery: WideString;
14  end;
  • функция Select возвращает объект, реализующий интерфейс IExternalDataSet с данными, полученными в результате запроса, заданного параметром SQL. Фактически метод является оберткой метода Perform объекта-провайдера IInfoProvider
  • функция SelectedRecordsCount возвращает количество записей, отмеченных пользователем в гриде в момент выгрузки в Excel
  • функция SelectedRecord возвращает первичный ключ отмеченной пользователем записи с номером Index
  • процедура PlaceCurrentQuery осуществляет перенос в указанное положение указанного рабочего листа данных текущего табличного представления. Параметр Sheet указывает на рабочий лист Excel, на который будет осуществляться перенос, параметр CaptionsNeeded определяет необходимость переноса заголовков колонок, параметры Row и Column определяют соответственно номер строки и столбца на рабочем листе Excel, начиная с которых будут расположены данные. Параметр ShiftRows определяет необходимость сдвига строк вниз при переносе данных (информация в ячейках, лежащих НИЖЕ строки, определенной параметром Row, будет либо затерта, либо сдвинута на требуемое число строк вниз. Параметр ShiftColumns определяет необходимость сдвига колонок вправо при переносе данных (информация в ячейках, лежащих ПРАВЕЕ столбца, определенного параметром Column, будет либо затерта, либо сдвинута на требуемое число строк вниз.
  • процедура PlaceQuery осуществляет перенос в указанное положение указанного рабочего листа данных заданного параметром DataSet набора данных. Параметр Sheet указывает на рабочий лист Excel, на который будет осуществляться перенос, параметр CaptionsNeeded определяет необходимость переноса заголовков колонок, параметры Row и Column определяют соответственно номер строки и столбца на рабочем листе Excel, начиная с которых будут расположены данные. Параметр ShiftRows определяет необходимость сдвига строк вниз при переносе данных (информация в ячейках, лежащих НИЖЕ строки, определенной параметром Row, будет либо затерта, либо сдвинута на требуемое число строк вниз. Параметр ShiftColumns определяет необходимость сдвига колонок вправо при переносе данных (информация в ячейках, лежащих ПРАВЕЕ столбца, определенного параметром Column, будет либо затерта, либо сдвинута на требуемое число строк вниз.
  • свойство CurrentQuery возвращает строку запроса, на основе которого постоено текущее табличное представление.
См. также
  • Интерфейс IInfoProvider


Интерфейс IExternalDataSet

(одним файлом)
Интерфейс IExternalDataSet
Фактически, обертка над интерфейсом IDataSet .
1  IExternalDataSet = interface(IDispatch)
2    ['{CDC7992C-BB30-431C-9F81-3215175AD5AB}']
3    procedure Next; safecall;
4    function Eof: WordBool; safecall;
5    property FieldCount: Integer;
6    property FieldName[Index: Integer]: WideString;
7    property Field[FieldIndex: OleVariant]: OleVariant;
8  end;
Набор данных представляет собой однонаправленный курсор, каждая строка которого является набором именованных и нумерованных полей.
  • процедура Next осуществляет переход к следующей записи курсора.
  • функция Eof возвращает True в случае достижения конца курсора.
  • свойство FieldCount возвращает количество полей в строке курсора.
  • свойство FieldName возвращает имя поля с номером Index.
  • свойство Field возвращает значение поля, имя или номер которого задан параметром (если строка, то имя, если число, то номер). Допустимо возвращать значение Null для пустых полей.
См. также
  • Интерфейс IDataSet


Интерфейс автоматизации

(одним файлом)
Интерфейс автоматизации
Взаимодействие внешних приложений с QueryBuilder'ом осуществляется при помощи интерфейса
1  IApplication = interface(IDispatch)
2    ['{0E59D500-7A6A-43CA-8007-B7BB7E393CD4}']
3    procedure Execute(const Provider: IUnknown; var Query: OleVariant); safecall;
4    procedure ExecuteTemplate(const Provider: IUnknown; var Query: OleVariant;
5      const TemplateName: WideString); safecall;
6    property Visible: WordBool;
7  end;
  • Свойство Visible определяет видимость приложения
  • Процедура Execute осуществляет выполнение запроса. Первым параметром является объект-провайдер (созданный заранее внешним образом и установивший соединение с БД также заранее). Вторым параметром может быть передано значение, представляющее структуру запроса. Это может быть либо строка с указанием имени файла, либо объект, реализующий интерфейс IStream (например, MSXML.DOMDocument ), либо строка, представляющая собой xml-документ. Все средства манипуляции структурой и поведением запроса предоставляются на уровне работы с xml-документом, описывающим запрос.
  • Процедура ExecuteTemplate осуществляет выполнение запроса и применяет к результатам шаблон с именем, переданным в параметре TemplateName. Первые два параметра аналогичны параметрам метода Execute
Интерфейс автоматизации может быть использован в тех случаях, когда необходима интергация QueryBuilder'a в третьестороннюю информационную систему.


Справочник по интерфейсам

(раздел целиком) (одним файлом)
Справочник по интерфейсам
  • Перечисление TAggregateType
  • Перечисление TBlobSubType
  • Перечисление TDisplayMode
  • Перечисление TSimpleType
  • Интерфейс IApplication
  • Интерфейс IBlobInfo
  • Интерфейс IBooleanInfo
  • Интерфейс IDataSet
  • Интерфейс IDateInfo
  • Интерфейс IDateTimeInfo
  • Интерфейс IEnumerationInfo
  • Интерфейс IEnumerationItem
  • Интерфейс IExternalDataSet
  • Интерфейс IExternalQuery
  • Интерфейс IFieldInfo
  • Интерфейс IFieldInfo2
  • Интерфейс IFloatInfo
  • Интерфейс IInfoProvider
  • Интерфейс IInfoProvider2
  • Интерфейс IInfoProvider3
  • Интерфейс IIntegerInfo
  • Интерфейс INamedItemInfo
  • Интерфейс IOptionInfo
  • Интерфейс IReferenceInfo
  • Интерфейс IStringInfo
  • Интерфейс ITableInfo
  • Интерфейс ITableInfo2
  • Интерфейс ITableInfo3
  • Интерфейс ITimeInfo
  • Интерфейс ITypeInfo
  • Интерфейс ITypeInfo2


Перечисление TAggregateType

(одним файлом)
Перечисление TAggregateType
1type
2  TAggregateType = (atCount, atSumm, atAverage, atMinimum, atMaximum, atAny,
3    atAll, atCountDistinct);

Или

01type
02  TAggregateType = TOleEnum;
03const
04  atCount = $00000000;
05  atSumm = $00000001;
06  atAverage = $00000002;
07  atMinimum = $00000003;
08  atMaximum = $00000004;
09  atAny = $00000005;
10  atAll = $00000006;
11  atCountDistinct = $00000007;

Элементы перечисления:

Имя | Значение | Назначение
atCount | 0 |
atSumm | 1 |
atAverage | 2 |
atMinimum | 3 |
atMaximum | 4 |
atAny | 5 |
atAll | 6 |
atCountDistinct | 7 |


Перечисление TBlobSubType

(одним файлом)
Перечисление TBlobSubType
1type
2  TBlobSubType = (bsText, bsImage, bsBinary);

Или

1type
2  TBlobSubType = TOleEnum;
3const
4  bsText = $00000000;
5  bsImage = $00000001;
6  bsBinary = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
bsText | 0 |
bsImage | 1 |
bsBinary | 2 |


Перечисление TDisplayMode

(одним файлом)
Перечисление TDisplayMode
1type
2  TDisplayMode = (dmAlways, dmNever, dmOnDemand);

Или

1type
2  TDisplayMode = TOleEnum;
3const
4  dmAlways = $00000000;
5  dmNever = $00000001;
6  dmOnDemand = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
dmAlways | 0 |
dmNever | 1 |
dmOnDemand | 2 |


Перечисление TSimpleType

(одним файлом)
Перечисление TSimpleType
1type
2  TSimpleType = (dtString, dtInteger, dtFloat, dtDate, dtTime, dtDateTime,
3    dtBoolean, dtEnumeration, dtReference, dtBlob);

Или

01type
02  TSimpleType = TOleEnum;
03const
04  dtString = $00000000;
05  dtInteger = $00000001;
06  dtFloat = $00000002;
07  dtDate = $00000003;
08  dtTime = $00000004;
09  dtDateTime = $00000005;
10  dtBoolean = $00000006;
11  dtEnumeration = $00000007;
12  dtReference = $00000008;
13  dtBlob = $00000009;

Элементы перечисления:

Имя | Значение | Назначение
dtString | 0 |
dtInteger | 1 |
dtFloat | 2 |
dtDate | 3 |
dtTime | 4 |
dtDateTime | 5 |
dtBoolean | 6 |
dtEnumeration | 7 |
dtReference | 8 |
dtBlob | 9 |


Интерфейс IApplication

(раздел целиком) (одним файлом)
Интерфейс IApplication

01type
02  IApplication = interface(IDispatch)
03    ['{0E59D500-7A6A-43CA-8007-B7BB7E393CD4}']
04    procedure Execute(const Provider: IUnknown; const Query: OleVariant); safecall;
05    function Get_Visible: WordBool; safecall;
06    procedure Set_Visible(Value: WordBool); safecall;
07    procedure ExecuteTemplate(const Provider: IUnknown; const Query: OleVariant;
08      const TemplateName: WideString); safecall;
09    property Visible: WordBool read Get_Visible write Set_Visible;
10  end;
  • Свойства
  • Метод Execute
  • Метод ExecuteTemplate


Свойства

(одним файлом)
Свойства

Свойства интерфейса IApplication:

Имя | Тип | Доступ | Назначение
Visible | WordBool | Чтение/Запись |


Метод Execute

(одним файлом)
Метод Execute

Метод интерфейса IApplication.

1procedure IApplication.Execute(const Provider: IUnknown;
2  const Query: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Provider | IUnknown | Да |
Query | OleVariant | Да |


Метод ExecuteTemplate

(одним файлом)
Метод ExecuteTemplate

Метод интерфейса IApplication.

1procedure IApplication.ExecuteTemplate(const Provider: IUnknown;
2  const Query: OleVariant; const TemplateName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Provider | IUnknown | Да |
Query | OleVariant | Да |
TemplateName | WideString | Да |


Интерфейс IBlobInfo

(раздел целиком) (одним файлом)
Интерфейс IBlobInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IBlobInfo = interface(ITypeInfo)
3    ['{3905C9C4-EAEB-4844-BB55-3F524F1F3FAC}']
4    function Get_SubType: TBlobSubType; safecall;
5    property SubType: TBlobSubType read Get_SubType;
6  end;
  • Свойства
См. также
  • Интерфейс ITypeInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса IBlobInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
SubType | TBlobSubType | Только для чтения |

См. также
  • Интерфейс ITypeInfo
  • Перечисление TBlobSubType
  • Перечисление TSimpleType


Интерфейс IBooleanInfo

(раздел целиком) (одним файлом)
Интерфейс IBooleanInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IBooleanInfo = interface(ITypeInfo)
3    ['{8256EDF9-8613-4970-850C-50047839D6BF}']
4    function Get_TrueValue: WideString; safecall;
5    function Get_FalseValue: WideString; safecall;
6    property TrueValue: WideString read Get_TrueValue;
7    property FalseValue: WideString read Get_FalseValue;
8  end;
  • Свойства
См. также
  • Интерфейс ITypeInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса IBooleanInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
FalseValue | WideString | Только для чтения |
TrueValue | WideString | Только для чтения |

См. также
  • Интерфейс ITypeInfo
  • Перечисление TSimpleType


Интерфейс IDataSet

(раздел целиком) (одним файлом)
Интерфейс IDataSet

01type
02  IDataSet = interface(IUnknown)
03    ['{3CED7395-8482-4EF6-8A15-7744348063C2}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_FieldName(Index: Integer): WideString; safecall;
06    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
07    procedure Next; safecall;
08    function Eof: WordBool; safecall;
09    property FieldCount: Integer read Get_FieldCount;
10    property FieldName[Index: Integer]: WideString read Get_FieldName;
11    property Field[FieldIndex: OleVariant]: OleVariant read Get_Field;
12  end;
  • Свойства
  • Метод Eof
  • Метод Next


Свойства

(одним файлом)
Свойства

Свойства интерфейса IDataSet:

Имя | Тип | Доступ | Назначение
Field[FieldIndex: OleVariant] | OleVariant | Только для чтения |
FieldCount | Integer | Только для чтения |
FieldName[Index: Integer] | WideString | Только для чтения |


Метод Eof

(одним файлом)
Метод Eof

Метод интерфейса IDataSet.

function IDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.


Метод Next

(одним файлом)
Метод Next

Метод интерфейса IDataSet.

procedure IDataSet.Next;

Метод не имеет параметров.


Интерфейс IDateInfo

(одним файлом)
Интерфейс IDateInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IDateInfo = interface(ITypeInfo)
3    ['{DA392510-105F-4655-9A38-18ECA2FBEB97}']
4  end;
См. также
  • Интерфейс ITypeInfo


Интерфейс IDateTimeInfo

(одним файлом)
Интерфейс IDateTimeInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IDateTimeInfo = interface(ITypeInfo)
3    ['{7F5CC8F9-8CE1-4DB7-8932-884EF3BAB538}']
4  end;
См. также
  • Интерфейс ITypeInfo


Интерфейс IEnumerationInfo

(раздел целиком) (одним файлом)
Интерфейс IEnumerationInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IEnumerationInfo = interface(ITypeInfo)
3    ['{B58A3F23-1AAC-4420-ADFF-B23B9938A994}']
4    function Get_ItemCount: Integer; safecall;
5    function Get_Item(Index: Integer): IEnumerationItem; safecall;
6    property ItemCount: Integer read Get_ItemCount;
7    property Item[Index: Integer]: IEnumerationItem read Get_Item;
8  end;
  • Свойства
См. также
  • Интерфейс ITypeInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса IEnumerationInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
Item[Index: Integer] | IEnumerationItem | Только для чтения |
ItemCount | Integer | Только для чтения |

См. также
  • Интерфейс IEnumerationItem
  • Интерфейс ITypeInfo
  • Перечисление TSimpleType


Интерфейс IEnumerationItem

(раздел целиком) (одним файлом)
Интерфейс IEnumerationItem

Интерфейс INamedItemInfo

1type
2  IEnumerationItem = interface(INamedItemInfo)
3    ['{6953507C-D477-4B8D-9443-A9E5FE7137ED}']
4    function Get_Position: Integer; safecall;
5    property Position: Integer read Get_Position;
6  end;
  • Свойства
См. также
  • Интерфейс INamedItemInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса IEnumerationItem:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Position | Integer | Только для чтения |

См. также
  • Интерфейс INamedItemInfo


Интерфейс IExternalDataSet

(раздел целиком) (одним файлом)
Интерфейс IExternalDataSet

01type
02  IExternalDataSet = interface(IDispatch)
03    ['{CDC7992C-BB30-431C-9F81-3215175AD5AB}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_FieldName(Index: Integer): WideString; safecall;
06    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
07    procedure Next; safecall;
08    function Eof: WordBool; safecall;
09    property FieldCount: Integer read Get_FieldCount;
10    property FieldName[Index: Integer]: WideString read Get_FieldName;
11    property Field[FieldIndex: OleVariant]: OleVariant read Get_Field;
12  end;
  • Свойства
  • Метод Eof
  • Метод Next


Свойства

(одним файлом)
Свойства

Свойства интерфейса IExternalDataSet:

Имя | Тип | Доступ | Назначение
Field[FieldIndex: OleVariant] | OleVariant | Только для чтения |
FieldCount | Integer | Только для чтения |
FieldName[Index: Integer] | WideString | Только для чтения |


Метод Eof

(одним файлом)
Метод Eof

Метод интерфейса IExternalDataSet.

function IExternalDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.


Метод Next

(одним файлом)
Метод Next

Метод интерфейса IExternalDataSet.

procedure IExternalDataSet.Next;

Метод не имеет параметров.


Интерфейс IExternalQuery

(раздел целиком) (одним файлом)
Интерфейс IExternalQuery

01type
02  IExternalQuery = interface(IDispatch)
03    ['{1A86D1DA-A56E-4D53-88F9-7A035D7D12B4}']
04    function Get_CurrentQuery: WideString; safecall;
05    function Select(const SQL: WideString): IExternalDataSet; safecall;
06    function SelectedRecordsCount: Integer; safecall;
07    function SelectedRecord(Index: Integer): OleVariant; safecall;
08    procedure PlaceCurrentQuery(const Sheet: IDispatch; CaptionsNeeded: WordBool;
09      Row: Integer; Column: Integer; ShiftRows: WordBool; ShiftColumns: WordBool); safecall;
10    procedure PlaceQuery(const Sheet: IDispatch; const DataSet: ExternalDataSet;
11      Row: Integer; Column: Integer; ShiftRows: WordBool; ShiftColumns: WordBool); safecall;
12    property CurrentQuery: WideString read Get_CurrentQuery;
13  end;
  • Свойства
  • Метод PlaceCurrentQuery
  • Метод PlaceQuery
  • Метод Select
  • Метод SelectedRecord
  • Метод SelectedRecordsCount


Свойства

(одним файлом)
Свойства

Свойства интерфейса IExternalQuery:

Имя | Тип | Доступ | Назначение
CurrentQuery | WideString | Только для чтения |


Метод PlaceCurrentQuery

(одним файлом)
Метод PlaceCurrentQuery

Метод интерфейса IExternalQuery.

1procedure IExternalQuery.PlaceCurrentQuery(const Sheet: IDispatch;
2  CaptionsNeeded: WordBool; Row: Integer; Column: Integer; ShiftRows: WordBool;
3  ShiftColumns: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Sheet | IDispatch | Да |
CaptionsNeeded | WordBool | Нет |
Row | Integer | Нет |
Column | Integer | Нет |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |


Метод PlaceQuery

(одним файлом)
Метод PlaceQuery

Метод интерфейса IExternalQuery.

1procedure IExternalQuery.PlaceQuery(const Sheet: IDispatch;
2  const DataSet: ExternalDataSet; Row: Integer; Column: Integer;
3  ShiftRows: WordBool; ShiftColumns: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Sheet | IDispatch | Да |
DataSet | ExternalDataSet | Да |
Row | Integer | Нет |
Column | Integer | Нет |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |


Метод Select

(одним файлом)
Метод Select

Метод интерфейса IExternalQuery.

function IExternalQuery.Select(const SQL: WideString): IExternalDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
SQL | WideString | Да |

Замечания:

Возвращает значение типа IExternalDataSet.

См. также
  • Интерфейс IExternalDataSet


Метод SelectedRecord

(одним файлом)
Метод SelectedRecord

Метод интерфейса IExternalQuery.

function IExternalQuery.SelectedRecord(Index: Integer): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа OleVariant.


Метод SelectedRecordsCount

(одним файлом)
Метод SelectedRecordsCount

Метод интерфейса IExternalQuery.

function IExternalQuery.SelectedRecordsCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Интерфейс IFieldInfo

(раздел целиком) (одним файлом)
Интерфейс IFieldInfo

Интерфейс INamedItemInfo

1type
2  IFieldInfo = interface(INamedItemInfo)
3    ['{19054DAD-8D35-4B39-8EB7-FD3254BD2934}']
4    function Get_TypeInfo: ITypeInfo; safecall;
5    function Get_DisplayMode: TDisplayMode; safecall;
6    property TypeInfo: ITypeInfo read Get_TypeInfo;
7    property DisplayMode: TDisplayMode read Get_DisplayMode;
8  end;
  • Свойства
См. также
  • Интерфейс INamedItemInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса IFieldInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
DisplayMode | TDisplayMode | Только для чтения |
TypeInfo | ITypeInfo | Только для чтения |

См. также
  • Интерфейс INamedItemInfo
  • Интерфейс ITypeInfo
  • Перечисление TDisplayMode


Интерфейс IFieldInfo2

(раздел целиком) (одним файлом)
Интерфейс IFieldInfo2

Интерфейс IFieldInfoИнтерфейс INamedItemInfo

1type
2  IFieldInfo2 = interface(IFieldInfo)
3    ['{82D93CF0-0E2F-4A85-AD74-9B1B9199B76B}']
4    function Get_Category: WideString; safecall;
5    property Category: WideString read Get_Category;
6  end;
  • Свойства
См. также
  • Интерфейс IFieldInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса IFieldInfo2:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
DisplayMode | TDisplayMode | Только для чтения | Унаследовано от IFieldInfo
TypeInfo | ITypeInfo | Только для чтения
Category | WideString | Только для чтения |

См. также
  • Интерфейс IFieldInfo
  • Интерфейс ITypeInfo
  • Перечисление TDisplayMode


Интерфейс IFloatInfo

(раздел целиком) (одним файлом)
Интерфейс IFloatInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

01type
02  IFloatInfo = interface(ITypeInfo)
03    ['{E9B56C6D-47DC-4AB9-9E80-6EEF77708704}']
04    function Get_MaxValue: Double; safecall;
05    function Get_MaxValueUsed: WordBool; safecall;
06    function Get_MinValue: Double; safecall;
07    function Get_MinValueUsed: WordBool; safecall;
08    function Get_Precision: Integer; safecall;
09    function Get_Scale: Integer; safecall;
10    property MaxValue: Double read Get_MaxValue;
11    property MaxValueUsed: WordBool read Get_MaxValueUsed;
12    property MinValue: Double read Get_MinValue;
13    property MinValueUsed: WordBool read Get_MinValueUsed;
14    property Precision: Integer read Get_Precision;
15    property Scale: Integer read Get_Scale;
16  end;
  • Свойства
См. также
  • Интерфейс ITypeInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса IFloatInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
MaxValue | Double | Только для чтения |
MaxValueUsed | WordBool | Только для чтения |
MinValue | Double | Только для чтения |
MinValueUsed | WordBool | Только для чтения |
Precision | Integer | Только для чтения |
Scale | Integer | Только для чтения |

См. также
  • Интерфейс ITypeInfo
  • Перечисление TSimpleType


Интерфейс IInfoProvider

(раздел целиком) (одним файлом)
Интерфейс IInfoProvider

01type
02  IInfoProvider = interface(IUnknown)
03    ['{64F8072B-7250-4C57-BA8E-D018C7B72CC7}']
04    function Get_TableCount: Integer; safecall;
05    function Get_Table(Index: Integer): ITableInfo; safecall;
06    function Perform(const SQL: WideString): IDataSet; safecall;
07    procedure Connect(const DataBase: WideString; const UserName: WideString;
08      const Password: WideString); safecall;
09    function Get_CLSID: GUID; safecall;
10    function Get_DateLiteral: WideString; safecall;
11    function Get_TimeLiteral: WideString; safecall;
12    function Get_DateTimeLiteral: WideString; safecall;
13    function Get_RegExpLiteral: WideString; safecall;
14    function Get_ToBooleanLiteral: WideString; safecall;
15    function Get_ToStringLiteral: WideString; safecall;
16    function Get_AllowStartingWith: WordBool; safecall;
17    function Get_AllowArrays: WordBool; safecall;
18    function Get_DisallowNullsSorting: WordBool; safecall;
19    function Get_DisallowSubqueries: WordBool; safecall;
20    function Get_DisallowBetween: WordBool; safecall;
21    function Get_LikeAlwaysEscaped: WordBool; safecall;
22    function Get_MaxIdentLength: Integer; safecall;
23    function Get_ReplaceRegExpDotsWithUnderscore: WordBool; safecall;
24    function Get_Epsilon: WideString; safecall;
25    property TableCount: Integer read Get_TableCount;
26    property Table[Index: Integer]: ITableInfo read Get_Table;
27    property CLSID: GUID read Get_CLSID;
28    property DateLiteral: WideString read Get_DateLiteral;
29    property TimeLiteral: WideString read Get_TimeLiteral;
30    property DateTimeLiteral: WideString read Get_DateTimeLiteral;
31    property RegExpLiteral: WideString read Get_RegExpLiteral;
32    property ToBooleanLiteral: WideString read Get_ToBooleanLiteral;
33    property ToStringLiteral: WideString read Get_ToStringLiteral;
34    property AllowStartingWith: WordBool read Get_AllowStartingWith;
35    property AllowArrays: WordBool read Get_AllowArrays;
36    property DisallowNullsSorting: WordBool read Get_DisallowNullsSorting;
37    property DisallowSubqueries: WordBool read Get_DisallowSubqueries;
38    property DisallowBetween: WordBool read Get_DisallowBetween;
39    property LikeAlwaysEscaped: WordBool read Get_LikeAlwaysEscaped;
40    property MaxIdentLength: Integer read Get_MaxIdentLength;
41    property ReplaceRegExpDotsWithUnderscore: WordBool
42      read Get_ReplaceRegExpDotsWithUnderscore;
43    property Epsilon: WideString read Get_Epsilon;
44  end;
  • Свойства
  • Метод Connect
  • Метод Perform


Свойства

(одним файлом)
Свойства

Свойства интерфейса IInfoProvider:

Имя | Тип | Доступ | Назначение
AllowArrays | WordBool | Только для чтения |
AllowStartingWith | WordBool | Только для чтения |
CLSID | GUID | Только для чтения |
DateLiteral | WideString | Только для чтения |
DateTimeLiteral | WideString | Только для чтения |
DisallowBetween | WordBool | Только для чтения |
DisallowNullsSorting | WordBool | Только для чтения |
DisallowSubqueries | WordBool | Только для чтения |
Epsilon | WideString | Только для чтения |
LikeAlwaysEscaped | WordBool | Только для чтения |
MaxIdentLength | Integer | Только для чтения |
RegExpLiteral | WideString | Только для чтения |
ReplaceRegExpDotsWithUnderscore | WordBool | Только для чтения |
Table[Index: Integer] | ITableInfo | Только для чтения |
TableCount | Integer | Только для чтения |
TimeLiteral | WideString | Только для чтения |
ToBooleanLiteral | WideString | Только для чтения |
ToStringLiteral | WideString | Только для чтения |

См. также
  • Интерфейс ITableInfo


Метод Connect

(одним файлом)
Метод Connect

Метод интерфейса IInfoProvider.

1procedure IInfoProvider.Connect(const DataBase: WideString;
2  const UserName: WideString; const Password: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
DataBase | WideString | Да |
UserName | WideString | Да |
Password | WideString | Да |


Метод Perform

(одним файлом)
Метод Perform

Метод интерфейса IInfoProvider.

function IInfoProvider.Perform(const SQL: WideString): IDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
SQL | WideString | Да |

Замечания:

Возвращает значение типа IDataSet.

См. также
  • Интерфейс IDataSet


Интерфейс IInfoProvider2

(раздел целиком) (одним файлом)
Интерфейс IInfoProvider2

01type
02  IInfoProvider2 = interface(IDispatch)
03    ['{BED44934-BCF9-4942-933D-591AB40D4CFE}']
04    function Get_AutoCheckKeys: WordBool; safecall;
05    function Get_OptionCount: Integer; safecall;
06    function Get_Option(Index: Integer): IOptionInfo; safecall;
07    property AutoCheckKeys: WordBool read Get_AutoCheckKeys;
08    property OptionCount: Integer read Get_OptionCount;
09    property Option[Index: Integer]: IOptionInfo read Get_Option;
10  end;
  • Свойства


Свойства

(одним файлом)
Свойства

Свойства интерфейса IInfoProvider2:

Имя | Тип | Доступ | Назначение
AutoCheckKeys | WordBool | Только для чтения |
Option[Index: Integer] | IOptionInfo | Только для чтения |
OptionCount | Integer | Только для чтения |

См. также
  • Интерфейс IOptionInfo


Интерфейс IInfoProvider3

(раздел целиком) (одним файлом)
Интерфейс IInfoProvider3

1type
2  IInfoProvider3 = interface(IDispatch)
3    ['{EF0E186A-4C72-4C40-B61C-72D7D03B2D10}']
4    procedure SetLogonInfo(const Login: WideString); safecall;
5  end;
  • Метод SetLogonInfo


Метод SetLogonInfo

(одним файлом)
Метод SetLogonInfo

Метод интерфейса IInfoProvider3.

procedure IInfoProvider3.SetLogonInfo(const Login: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Login | WideString | Да |


Интерфейс IIntegerInfo

(раздел целиком) (одним файлом)
Интерфейс IIntegerInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

01type
02  IIntegerInfo = interface(ITypeInfo)
03    ['{9003B25E-926D-42AE-A907-813DF3A8343E}']
04    function Get_MaxValue: Integer; safecall;
05    function Get_MaxValueUsed: WordBool; safecall;
06    function Get_MinValue: Integer; safecall;
07    function Get_MinValueUsed: WordBool; safecall;
08    property MaxValue: Integer read Get_MaxValue;
09    property MaxValueUsed: WordBool read Get_MaxValueUsed;
10    property MinValue: Integer read Get_MinValue;
11    property MinValueUsed: WordBool read Get_MinValueUsed;
12  end;
  • Свойства
См. также
  • Интерфейс ITypeInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса IIntegerInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
MaxValue | Integer | Только для чтения |
MaxValueUsed | WordBool | Только для чтения |
MinValue | Integer | Только для чтения |
MinValueUsed | WordBool | Только для чтения |

См. также
  • Интерфейс ITypeInfo
  • Перечисление TSimpleType


Интерфейс INamedItemInfo

(раздел целиком) (одним файлом)
Интерфейс INamedItemInfo

01type
02  INamedItemInfo = interface(IUnknown)
03    ['{14894363-28DA-4E71-B0BC-9C5CE811BC8F}']
04    function Get_Name: WideString; safecall;
05    function Get_Caption: WideString; safecall;
06    function Get_ID: WideString; safecall;
07    property Name: WideString read Get_Name;
08    property Caption: WideString read Get_Caption;
09    property ID: WideString read Get_ID;
10  end;
  • Свойства


Свойства

(одним файлом)
Свойства

Свойства интерфейса INamedItemInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения |
ID | WideString | Только для чтения |
Name | WideString | Только для чтения |


Интерфейс IOptionInfo

(раздел целиком) (одним файлом)
Интерфейс IOptionInfo

Интерфейс INamedItemInfo

01type
02  IOptionInfo = interface(INamedItemInfo)
03    ['{453E81A2-969D-49DC-B3C6-ACAD411D63FC}']
04    function Get_TypeInfo: ITypeInfo; safecall;
05    function Get_Group: WideString; safecall;
06    function Get_Tab: WideString; safecall;
07    function Get_Value: OleVariant; safecall;
08    procedure Set_Value(Value: OleVariant); safecall;
09    property TypeInfo: ITypeInfo read Get_TypeInfo;
10    property Group: WideString read Get_Group;
11    property Tab: WideString read Get_Tab;
12    property Value: OleVariant read Get_Value write Set_Value;
13  end;
  • Свойства
См. также
  • Интерфейс INamedItemInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса IOptionInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Group | WideString | Только для чтения |
Tab | WideString | Только для чтения |
TypeInfo | ITypeInfo | Только для чтения |
Value | OleVariant | Чтение/Запись |

См. также
  • Интерфейс INamedItemInfo
  • Интерфейс ITypeInfo


Интерфейс IReferenceInfo

(раздел целиком) (одним файлом)
Интерфейс IReferenceInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IReferenceInfo = interface(ITypeInfo)
3    ['{309C8CB1-4A1C-4E58-BC3F-D1AF27861A8F}']
4    function Get_TargetTable: ITableInfo; safecall;
5    property TargetTable: ITableInfo read Get_TargetTable;
6  end;
  • Свойства
См. также
  • Интерфейс ITypeInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса IReferenceInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
TargetTable | ITableInfo | Только для чтения |

См. также
  • Интерфейс ITableInfo
  • Интерфейс ITypeInfo
  • Перечисление TSimpleType


Интерфейс IStringInfo

(раздел целиком) (одним файлом)
Интерфейс IStringInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IStringInfo = interface(ITypeInfo)
3    ['{74AC4C03-E803-421B-B30D-1A2D2C49827F}']
4    function Get_Length: Integer; safecall;
5    property Length: Integer read Get_Length;
6  end;
  • Свойства
См. также
  • Интерфейс ITypeInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса IStringInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
Length | Integer | Только для чтения |

См. также
  • Интерфейс ITypeInfo
  • Перечисление TSimpleType


Интерфейс ITableInfo

(раздел целиком) (одним файлом)
Интерфейс ITableInfo

Интерфейс INamedItemInfo

01type
02  ITableInfo = interface(INamedItemInfo)
03    ['{3FC1998A-9031-4936-82B5-8CAA2219085E}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_Field(Index: Integer): IFieldInfo; safecall;
06    function Get_PrimaryKey: IFieldInfo; safecall;
07    function Get_Uplink: IFieldInfo; safecall;
08    function Get_Parent: ITableInfo; safecall;
09    function Get_RootAvailable: WordBool; safecall;
10    property FieldCount: Integer read Get_FieldCount;
11    property Field[Index: Integer]: IFieldInfo read Get_Field;
12    property PrimaryKey: IFieldInfo read Get_PrimaryKey;
13    property Uplink: IFieldInfo read Get_Uplink;
14    property Parent: ITableInfo read Get_Parent;
15    property RootAvailable: WordBool read Get_RootAvailable;
16  end;
  • Свойства
См. также
  • Интерфейс INamedItemInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса ITableInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения |
FieldCount | Integer | Только для чтения |
Parent | ITableInfo | Только для чтения |
PrimaryKey | IFieldInfo | Только для чтения |
RootAvailable | WordBool | Только для чтения |
Uplink | IFieldInfo | Только для чтения |

См. также
  • Интерфейс IFieldInfo
  • Интерфейс INamedItemInfo


Интерфейс ITableInfo2

(раздел целиком) (одним файлом)
Интерфейс ITableInfo2

Интерфейс ITableInfoИнтерфейс INamedItemInfo

01type
02  ITableInfo2 = interface(ITableInfo)
03    ['{9DF4C8AC-1DA2-4E7B-BF44-7EDD7A269418}']
04    function Get_PolymorphCount: Integer; safecall;
05    function Get_PolymorphTable(Index: Integer): ITableInfo; safecall;
06    function Get_PolymorphField(Index: Integer): IFieldInfo; safecall;
07    property PolymorphCount: Integer read Get_PolymorphCount;
08    property PolymorphTable[Index: Integer]: ITableInfo read Get_PolymorphTable;
09    property PolymorphField[Index: Integer]: IFieldInfo read Get_PolymorphField;
10  end;
  • Свойства
См. также
  • Интерфейс ITableInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса ITableInfo2:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения | Унаследовано от ITableInfo
FieldCount | Integer | Только для чтения
Parent | ITableInfo | Только для чтения
PrimaryKey | IFieldInfo | Только для чтения
RootAvailable | WordBool | Только для чтения
Uplink | IFieldInfo | Только для чтения
PolymorphCount | Integer | Только для чтения |
PolymorphField[Index: Integer] | IFieldInfo | Только для чтения |
PolymorphTable[Index: Integer] | ITableInfo | Только для чтения |

См. также
  • Интерфейс IFieldInfo
  • Интерфейс ITableInfo


Интерфейс ITableInfo3

(раздел целиком) (одним файлом)
Интерфейс ITableInfo3

Интерфейс ITableInfoИнтерфейс INamedItemInfo

01type
02  ITableInfo3 = interface(ITableInfo)
03    ['{3FB73AA9-010C-48DA-81C7-E1DCFE2E6136}']
04    function GetPersistentClause(const Alias: WideString): WideString; safecall;
05    function GetPreConditionsCount: Integer; safecall;
06    function GetPreConditionCaption(Index: Integer): WideString; safecall;
07    function Get_ActivePreCondition(Index: Integer): WordBool; safecall;
08    procedure Set_ActivePreCondition(Index: Integer; Value: WordBool); safecall;
09    function GetPreConditionParamsCount(Index: Integer): Integer; safecall;
10    function GetPreConditionParam(Index: Integer;
11      PreConditionIndex: Integer): IOptionInfo; safecall;
12    function GetPreConditionCategory(Index: Integer): WideString; safecall;
13    property ActivePreCondition[Index: Integer]: WordBool
14      read Get_ActivePreCondition write Set_ActivePreCondition;
15  end;
  • Свойства
  • Метод GetPersistentClause
  • Метод GetPreConditionCaption
  • Метод GetPreConditionCategory
  • Метод GetPreConditionParam
  • Метод GetPreConditionParamsCount
  • Метод GetPreConditionsCount
См. также
  • Интерфейс ITableInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса ITableInfo3:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения | Унаследовано от ITableInfo
FieldCount | Integer | Только для чтения
Parent | ITableInfo | Только для чтения
PrimaryKey | IFieldInfo | Только для чтения
RootAvailable | WordBool | Только для чтения
Uplink | IFieldInfo | Только для чтения
ActivePreCondition[Index: Integer] | WordBool | Чтение/Запись |

См. также
  • Интерфейс IFieldInfo
  • Интерфейс ITableInfo


Метод GetPersistentClause

(одним файлом)
Метод GetPersistentClause

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPersistentClause(const Alias: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Alias | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Метод GetPreConditionCaption

(одним файлом)
Метод GetPreConditionCaption

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionCaption(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.


Метод GetPreConditionCategory

(одним файлом)
Метод GetPreConditionCategory

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionCategory(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.


Метод GetPreConditionParam

(одним файлом)
Метод GetPreConditionParam

Метод интерфейса ITableInfo3.

1function ITableInfo3.GetPreConditionParam(Index: Integer;
2  PreConditionIndex: Integer): IOptionInfo;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |
PreConditionIndex | Integer | Да |

Замечания:

Возвращает значение типа IOptionInfo.

См. также
  • Интерфейс IOptionInfo


Метод GetPreConditionParamsCount

(одним файлом)
Метод GetPreConditionParamsCount

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionParamsCount(Index: Integer): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа Integer.


Метод GetPreConditionsCount

(одним файлом)
Метод GetPreConditionsCount

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionsCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Интерфейс ITimeInfo

(одним файлом)
Интерфейс ITimeInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  ITimeInfo = interface(ITypeInfo)
3    ['{D7067CAC-67A5-41DB-8D95-40409D8658AB}']
4  end;
См. также
  • Интерфейс ITypeInfo


Интерфейс ITypeInfo

(раздел целиком) (одним файлом)
Интерфейс ITypeInfo

Интерфейс INamedItemInfo

1type
2  ITypeInfo = interface(INamedItemInfo)
3    ['{2B6A5E20-3C36-4574-89DB-7C873A5C4A00}']
4    function Get_Required: WordBool; safecall;
5    function Get_SimpleType: TSimpleType; safecall;
6    property Required: WordBool read Get_Required;
7    property SimpleType: TSimpleType read Get_SimpleType;
8  end;
  • Свойства
См. также
  • Интерфейс INamedItemInfo


Свойства

(одним файлом)
Свойства

Свойства интерфейса ITypeInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения |
SimpleType | TSimpleType | Только для чтения |

См. также
  • Интерфейс INamedItemInfo
  • Перечисление TSimpleType


Интерфейс ITypeInfo2

(раздел целиком) (одним файлом)
Интерфейс ITypeInfo2

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  ITypeInfo2 = interface(ITypeInfo)
3    ['{77F58BDF-F01C-40F3-B193-1027AD8C4EDA}']
4    function GetSpecialFilterCount: Integer; safecall;
5    function GetSpecialFilterText(Index: Integer): WideString; safecall;
6    function EditSpecialFilter(Index: Integer; var Filter: WideString): WordBool; safecall;
7  end;
  • Метод EditSpecialFilter
  • Метод GetSpecialFilterCount
  • Метод GetSpecialFilterText
См. также
  • Интерфейс ITypeInfo


Метод EditSpecialFilter

(одним файлом)
Метод EditSpecialFilter

Метод интерфейса ITypeInfo2.

1function ITypeInfo2.EditSpecialFilter(Index: Integer;
2  var Filter: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |
Filter | WideString | Да |

Замечания:

Возвращает значение типа WordBool.


Метод GetSpecialFilterCount

(одним файлом)
Метод GetSpecialFilterCount

Метод интерфейса ITypeInfo2.

function ITypeInfo2.GetSpecialFilterCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Метод GetSpecialFilterText

(одним файлом)
Метод GetSpecialFilterText

Метод интерфейса ITypeInfo2.

function ITypeInfo2.GetSpecialFilterText(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.


Мельница данных ((раздел целиком))

Мельница данных- Класс TDomain (Домены) (раздел целиком) (22.10.2024) (одним файлом)
Класс TDomain (Домены)

Диаграмма Класс TObject (Объекты)

1. Свойства

Свойства класса TDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Обязательно для заполнения
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество внешних зависимостей
Definition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения | Сводка

2. Конструктор Create (Конструктор домена)

Конструктор класса TDomain.

1constructor TDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TDomain;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Обязательно для заполнения

Замечания:

Создает новый объект класса TDomain.

3. Метод GetDefinition (Определение домена)

Метод экземпляра класса TDomain.

function TDomain.GetDefinition: string[64];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDomain.

function TDomain.GetSummary: string[2000];

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Взаимодействие с разработчиком в случае ошибок, проблем, вопросов по работе системы (раздел целиком) (22.10.2024) (одним файлом)
Взаимодействие с разработчиком в случае ошибок, проблем, вопросов по работе системы

В ситуациях, когда в работе системы происходят ошибки, когда система ведет себя неожиданным для пользователя образом, наблюдаются проблемы с быстродействием или другими аспектами работы системы, если у пользователей возникают вопросы, не освещенные в Руководстве пользователя, возникает необходимость обратиться к разработчику. Для того, чтобы разработчик мог решить проблему или ответить на вопрос быстро, полно и компетентно, ему нужно предоставить информацию о среде работе системы, о решаемых пользователем задачах, последовательности действий пользователя, приведших к проблемной ситуации.

Общими принципами сбора информации для обращения к разработчику должны быть:

  1. Необходимо быть готовым изложить последовательность действий пользователя в системе, начиная с открытия системы до ситуации, приводящей к ошибке, проблемной ситуации или ситуации, вызывающей вопрос.
  2. Если ошибка или проблема имеет визуальное проявление, нужно сделать скриншот (снимок) экрана. Желательно предоставлять скриншот всего экрана компьютера, а не только активного окна приложения, это даст разработчику дополнительную полезную информацию. Скришот экрана при работе в операционной системе MS Windows можно получить путем одновременного нажатия клавиш Ctrl + Print Screen (PrtScr) и последующей вставки (сочетание клавиш Shift + Ins) в какое-либо графическое приложение, например, программу Paint.
  3. Если ошибка заключается не в отображении специального окна с сообщением об ошибке, а в том, что результат работы системы является, с точки зрения пользователя, некорректным, то нужно быть готовым изложить, каким должен быть корректный результат, и чем именно результат работы системы некорректен.
  4. Если ошибка, проблема или вопрос связаны с работой третьесторонних приложений (например, отчеты, формируемые в MS Excel или MS Word, работа web-приложений системы посредством интернет-браузеров), нужно быть готовым предоставить информацию о версии третьесторонних приложений.
  5. Нужно быть готовым предоставить информацию о конфигурации рабочего места пользователя, версии операционной системы, установленном программном обеспечении и его версии, включая средства анитивирусной защиты.

Для сбора информации, необходимой разработчику для решения проблем, система предоставляет ряд средств: Приложение Отладочный монитор, возможность получения файла, содержащего информацию об ошибке, также ниже приведены рекомендации по получению информации о третесторонних приложениях.

1. Приложение Отладочный монитор

Приложение Отладочный монитор (DebugView.exe) устанавливается при установке платформы в любой конфигурации, предусмотренной по умолчанию, включая конфигурацию "Рабочее место пользователя". Открыть приложение можно при помощи иконки:

Иконка Debug Monitor

Когда приложение Отладочный монитор запущено, приложение Обозреватель данных выводит в него поток сообщений о действиях и событиях, происходящих в системе. В Отладочный монитор попадают все sql-запросы, направляемые с рабочего места пользователя на сервер баз данных (в случае удаленного подключения - html-запросы, направляемые на сервер приложений), информационные сообщения, предупреждения, отладочная информация, сообщения об ошибках и прочие данные.

Для того, чтобы собрать и передать разработчику информацию об ошибке или проблемной ситуации при помощи Отладочного монитора, нужно выполнить следующие действия:

  1. Закрыть приложение Обозреватель данных, если оно было открыто.
  2. Запустить приложение Отладочный монитор. Если это приложение уже было открыто, то выполнить очитку всех имеющихся в нем сообщений при помощи кнопки Очистить.
  3. В приложение Обозреватель данных выполнить всю последовательность действий, приводящих в появлению ошибки или проблемной ситуации.
  4. После возникновения ошибки или проблемной ситуации в приложении Отладочный монитор нажать кнопку Сохранить в файл, выбрать место сохранения и задать имя файла. Файл будет сохранен в формате.txt.
  5. Отправить полученный.txt-файл разработчику в составе других информационных материалов, которыми должны быть:
    • Словесное описание проблемы и способа ее воспроизведения
    • Один или несколько скриншотов экрана, иллюстрирующих проблему

После получения информации, состав которой описан в пункте 5, разработчик может запросить дополнительную информацию о проблеме.

2. Получение файла, содержащего информацию об ошибке

В ходе работы с системой могут отображаться специальные окна с информацией об ошибках. Эти окна могут быть двух видов:

  1. Окно с информацией о недопустимом действии пользователя (окно с шапкой синего цвета):

    Окно ошибки. Синяя шапка.

    Как правило, отображение такого окна с информацией об ошибке свидетельствует не об ошибке в функциональности системы, а о том, что пользователем выполнено недопустимое действие. Информация о том, в чем именно действие не допустимо, содержится в тексте, отображаемом в окне. Например, на приведенном выше скриншоте мы видим окно с ошибкой, отображено после попытки пользователя создать в справочнике "Уровни образования и курсы" второй записи с именем "1 курс", подчиненной родительской записи "Бакалавриат", что недопустимо. Поэтому сообщение об ошибке говорит о дублировании объекта по полю Имя.

    Информация, отображаемая в окне данного вида, предназначена для пользователя. Вы можете направить информацию о такой ошибке разработчику в случае, если сообщение об ошибке непонятно, либо если считаете, что выполненное пользователем действие должно быть допустимым, и ошибка системы в том, что действие было расценено как недопустимое.

    При отображении окна данного вида пользователь может продолжить работу, нажав на кнопку Продолжить. При необходимости обратиться в данной ситуации к разработчику до нажатия кнопки Продолжить необходимо получить и сохранить информацию, необходимую разработчику для анализа ситуации, при помощи ссылок "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки". Подробнее о сохранении этой информации написано ниже.

  2. Окно с информацией об ошибке системы (окно с шапкой красного цвета).

    Окно ошибки. Красная шапка.

    При возникновении ситуации, сопровождающейся появлением такого окна, необходимо получить и сохранить информацию, необходимую разработчику для анализа ситуации, при помощи ссылок "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки". Подробнее о сохранении этой информации написано ниже.

    После сохранения информации об ошибке можно попытаться продолжить работу, нажав кнопку Продолжить. В некоторых случаях, в зависимости от характера произошедшей ошибки, продолжение работы может оказаться невозможным, в таких случаях нужно нажать кнопку Закрыть приложение. После того, как приложение будет закрыто, его можно будет открыть снова и продолжить работу.

Сохранение информации для направления разработчику.

Информация, которая поможет разработчику решить проблему, не отображается в самом окне, поэтому направлять разработчику скриншот именно этого окна не имеет смысла. Для получения необходимой для разработчика информации в окнах с сообщением об ошибке обоих видов расположены ссылки "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки".

По ссылке Показать информацию для службы поддержки информация отображается в том же окне. Весь текст изначально выделен, его можно сразу скопировать и вставить в текстовый файл, в тело письма и т.д. Данный текст содержит сам текст ошибки, а также информацию об операционной системе пользователя и ее версии, загруженных модулях, переменных окружения и проч.

Информация для службы поддержки

При помощи ссылки Сформировать файл для службы поддержки можно собрать в удобном виде наиболее полную и полезную для разработчика информацию. После нажатия на ссылку будет предложен диалог сохранения файла. По умолчанию файлу будет дано имя ExceptionInfo.err. Это имя можно изменить, но расширение необходимо файла сохранить. После выбора места сохранения и имени файла и нажатия кнопки Сохранить, система отобразить предупреждение:

Предупреждение при сохранении файла для службы поддержки

К данному предупреждению нужно отнестись ответственно - отправлять полученный файл только на адреса службы поддержки системы в вашей организации или на официальный контактный адрес разработчика (если вы взаимодействуете с разработчиком напрямую). После отправки этот файл необходимо удалить.

Предоставление разработчику информации в виде.err-файла - это самый удобный и надежный вариант взаимодействия, который даст возможность разработчику решить проблему или ответить на вопрос наиболее эффективным и быстрым образом. Данный файл содержит все виды информации, которые могут быть собраны другими способами:

  • Информацию об ошибке, которая отображается по ссылке "Показать информацию для службы поддержки"
  • Сообщения Отладочного монитора, собранные за некоторое время до возникновения ошибки
  • Скриншоты экрана пользователя, включая скриншот окна с информацией об ошибке.

При отправке файла разработчику дополнительно нужно описать последовательность действий, приведших к ошибке или ситуации, вызывающей вопросы. После получения файла и дополнительной информации, разработчик может попросить предоставить дополнительную информацию о проблемной ситуации, о конфигурации рабочего места пользователя, прочем установленном на рабочем месте ПО и проч.

Если вы хотите обратиться к разработчику по поводу ситуации, которая не сопровождается отображением окна с ошибкой, то.err-файл можно получить следующим образом: нужно кликнуть левой кнопкой мыши по иконке с мельницей в левом углу заголовка окна текущей формы и из выпадающего меню выбрать пункт Сохранить файл для службы поддержки.

Получение файла для службы поддержки

3. Получение информации о третесторонних приложениях

В случае, если ошибка произошла при взаимодействии системы с третьесторонним приложением, например, при выполнении отчета MS Excel, MS Word, pdf, при работе web-приложений системы через интернет-браузер, разработчику, в дополнение к файлу с информацией об ошибке, понадобится информация о версии третьестороннего приложения, при взаимодействии с которым произошла ошибка.

Получить информацию о версии приложения можно, как правило, в окне О программе ("About box"), которое в большинстве программных продуктов представлено в пункте меню Справка.

Разработчику в составе информационных материалов нужно отправить скриншот этого окна.

В продуктах семейства Microsoft Office вызвать окно О программе можно разными способами в зависимости от версии MS Office. В программных продуктах версий до 2003 включительно это окно доступно в меню Справка / О программе. В программных продуктах версий 2007 и выше вызвать это окно можно следующим образом:

  1. В меню Файл открыть выпадающий список доступных действий и нажать кнопку Параметры Excel :
    Параметры Excel
  2. В открывшемся окне выбрать раздел Ресурсы, в правой части окна нажать кнопку О программе :
    Вызов окна О программе Excel

Окно О программе в случае MS Excel выглядит следующим образом:

Окно О программе Excel

В программе Acrobat Reader окно О программе можно вызвать из меню Справка / О программе :

Вызов окна О программе Acrobat Reader

В интернет-браузерах окно "О программе" (О Google Chrome, О FireFox, О Internet Explorer) также можно вызвать из меню Справка. Строка меню в интернет-браузерах часто бывает по умолчанию скрыта. Для того, чтобы ее отобразить, нужно нажать клавишу Alt на клавиатуре.


Мельница данных ((раздел целиком))

Мельница данных- Установка программного обеспечения СУБД (раздел целиком) (22.10.2024) (одним файлом)
Установка программного обеспечения СУБД

Прежде, чем устанавливать программноге обеспечение "Мельница данных" необходимо установить и настроить программное обеспечение СУБД.

Для конфигурирования сервера БД необходимо последовать советам раздела "Конфигурирование сервера". В этом разделе описаны шаги, которые необходимо предпринять для установки сервера "с нуля". Если сервер БД у вас уже установлен и настроен, то использовать рекомендации этого раздела нет необходимости. Раздел описывает установку сервера БД минимальной поддерживаемой версии в минимально необходимой для работы "Мельницы данных" конфигурации. Если вы собираетесь использовать сервер БД для более широкого круга задач, то пользуйтесь руководствами по соответствующим СУБД.
Документация по СУБД, а также любая другая информация, полученная от производителей СУБД, имеет абсолютный приоритет перед утверждениями настоящего документа.

На каждой рабочей станции должно быть установлено и настроено программное обеспечение клиентской части СУБД. Это, как правило, некий набор библиотек и компонентов, наличие которых необходимо для соединения с сервером БД. Для обеспечения рабочей станции этими компонентами необходимо последовать советам раздела Конфигурирование клиента. В этом разделе описаны шаги, которые необходимо предпринять для установки клиентской части СУБД "с нуля". Если клиентская часть СУБД у вас уже установлена и настроена, то использовать рекомендации этого раздела нет необходимости. Раздел описывает установку клиентской части СУБД минимальной поддерживаемой версии в минимально необходимой для работы "Мельницы данных" конфигурации.

В настоящий момент поддерживаемые СУБД приведены в таблице:
СУБД Минимальная
требуемая версия 		Разработчик Сопровождение в России
Firebird
Open source
1.5.4.4910 http://www.firebirdsql.org
Страница загрузки 		http://www.ibase.ru
Oracle database
Коммерческое ПО
9.2.0.1 http://www.oracle.com
Страница загрузки 		http://www.oracle.com/global/ru/index.html

1. Конфигурирование сервера

Младшая тестированная на совместимость версия - 1.5.4.4910. Использование более младшей версии на сервере недопустимо. Шаги установки примерно следующие:

  1. Первая страница содержит логотип проекта Firebird
    Установка FireBird (первая страница)
  2. Вторая страница содержит лицензионное соглашение. Для продолжения установки необходимо установить кнопку "I accept the agreement".
    Установка FireBird (вторая страница)
  3. Третья страница содержит информацию, необходимую для установки.
    Установка FireBird (третья страница)
  4. Четвертая страница позволяет указать папку на диске, в которую будут установлены файлы Firebird.
    Установка FireBird (четвертая страница)
  5. На пятой странице определяется тип установки. Мы конфигурируем сервер БД, и, соответственно, выбираем из выпадающего списка пункт "Full installation of Server and development tools". Необходимо определиться с выбором между различными архитектурами сервера. Если вы затрудняетесь в выборе между вариантами архитектуры сервера, то помните, что для однопроцессорных систем предпочтительнее Super Server, для многопроцессорных используется только Classic Server. Подробности можно посмотреть на сайте сопровождающей компании или на сайте проекта. Особое внимание требуется обратить на работу сервера на процессоре в режиме HyperThreading.
    Установка серверной части FireBird - выбор типа установки
  6. На шестой странице предлагается выбрать имя папки меню "Пуск", в которой будут созданы полезные ярлыки. В нашем случае ярлыки будут созданы для файлов документации, бесполезной в конечном счете для конечного пользователя. Поэтому мы ставим флажок "Don't create any icons".
    Установка FireBird (шестая страница)
  7. На седьмой странице необходимо выбрать параметры установки. Настоятельно рекомендуется включить флажок "Use the Guardian to control the server" и запускать сервер в режиме службы, то есть выбрать кнопку "Run as a Service". Также настоятельно рекомендуется установить флажок "Start Firebird automatically everytime you boot up". Программное обеспечение "Мельница данных" использует в работе библиотеку gds32.dll , загружая ее из системного каталога Windows. Поэтому в целях обеспечения нормальной работы необходимо установить оба флажка - "Copy Firebird client library to <system> directory" и "Generate client library as GDS32.DLL for legacy app. support".
    Установка серверной части FireBird - параметры установки
  8. На восьмой странице необходимо подтвердить установку с выбранными параметрами.
    Установка серверной части FireBird - подтверждение установки
  9. После установки на девятой странице можно ознакомиться с информацией об установленной версии.
    Установка FireBird (девятая страница)
  10. Десятая страница информирует об успешном завершении установки и позволяет запустить сервер немедленно. Рекомендуется установить флажок "Start Firebird Service now".
    Установка серверной части FireBird - установка завершена

Убедиться в том, что сервер установлен и запущен, можно из окна служб (Start → Control Panel → Administrative Tools → Services):

Установленный FireBird в списке сервисов

Использование embedded-сервера вполне допустимо, с учетом ограничений, налагаемых разработчиком. Для использования embedded-сервера необходимо положить файлы (с полным путем) из архива embedded-сервера рядом с исполняемыми файлами нашей системы, и переименовать файл FBEMBED.DLL в GDS32.DLL , примерно следующим образом:

Использование FireBird Embedded

Для работы с embedded-сервером имя сервера в строке соединения указывать нельзя. Кроме того, необходимо соблюдать рекомендации и требования разработчиков сервера.

Младшая тестированная на совместимость версия - 9.2.0.1. Использование более младшей версии недопустимо.

Если вы устанавливаете Oracle не с компакт-дисков, то не пользуйтесь программой автозапуска, лежащей в корне первого установочного диска, а запустите setup.exe из каталога install\win32 на первом установочном диске.

Шаги установки примерно следующие:

  1. Первая страница содержит логотип Oracle и командные кнопки. Для продолжения установки нажмите кнопку "Next".
    Установка Oracle (первая страница)
  2. На второй странице необходимо определиться с путями установки и источника, а также с именем "дома". Настоятельно рекомендуется принять значения, предлагаемые по умолчанию.
    Установка Oracle (вторая страница)
  3. На третьей странице необходимо выбрать устанавливаемый продукт. Для сервера БД необходимо выбрать продукт "Oracle9i Database 9.2.0.1.0".
    Установка серверной части Oracle
  4. На четвертой странице необходимо выбрать тип установки. Для обеспечения требуемой функциональности выберите тип "Standard Edition".
    Установка серверной части Oracle - выбор типа установки
  5. На пятой странице необходимо выбрать параметры базы данных, создаваемой автоматически при установке сервера. Рекомендуется никакой базы данных при установке не создавать, для чего выбрать пункт "Software Only".
    Установка серверной части Oracle - отказ от автоматического создания БД
  6. На шестой странице необходимо выбрать порт TCP/IP, используемый Oracle Services for MTS. По умолчанию 2030.
    Установка серверной части Oracle - порт MTS
  7. На седьмой странице необходимо подтвердить правильность параметров установки.
    Установка серверной части Oracle - подтверждение установки
  8. После окончания процесса вы увидете сообщение об успешном завершении установки. Нажмите кнопку "Exit".
    Установка серверной части Oracle - завершено
  9. После завршения работы инсталлятора автоматически будет запущено приложение "Enterprise Manager Console". Если по каким-либо причинам этого не произошло, запустите это приложение самостоятельно через меню "Пуск". В окне "Add Databases To Tree" нажмите кнопку "Cancel".
    Установка серверной части Oracle - отказ от использования Enterprise Manager Console
  10. Из меню выберите пункт Tools → Service Management → Oracle Net Manager.
    Установка серверной части Oracle - вызов Oracle Net Manager
  11. В появивщемся окне приложения "Oracle Net Manager" раскройте узел дерева "Local", встаньте на узел дерева "Listener" и нажмите на кнопку с большим зеленым плюсом в панели инструменов (слева).
    Установка серверной части Oracle - Oracle Net Manager
  12. В появивщемся окне добавления Listener'a введите имя (по умолчанию - LISTENER). Настоятельно рекомендуется принять умолчание.
    Установка серверной части Oracle - создание Listener'a
  13. Нажмите на кнопку "Add Address" в нижней части окна.
    Установка серверной части Oracle - создание адреса Listener'a
  14. В появившемся окне отображена информация о том, каким образом клиенты будут осуществлять соединение с сервером БД. Настоятельно рекомендуется принять умолчания - протокол TCP/IP, порт 1521.
    Установка серверной части Oracle - адрес Listener'a создан
  15. Из меню выберите пункт File → Save Network Configuration
    Установка серверной части Oracle - сохранение конфигурации
  16. Служба Listener'a будет создана при первой попытке создать базу данных. Закройте приложения "Oracle Net Manager" и "Enterprise Manager Console".

2. Конфигурирование клиента

Младшая тестированная на совместимость версия - 1.5.4.4910. Использование более младшей версии на клиенте недопустимо. Шаги установки примерно следующие:

  1. Первая страница содержит логотип проекта Firebird
    Установка FireBird (первая страница)
  2. Вторая страница содержит лицензионное соглашение. Для продолжения установки необходимо установить кнопку "I accept the agreement".
    Установка FireBird (вторая страница)
  3. Третья страница содержит информацию, необходимую для установки.
    Установка FireBird (третья страница)
  4. Четвертая страница позволяет указать папку на диске, в которую будут установлены файлы Firebird.
    Установка FireBird (четвертая страница)
  5. На пятой странице определяется тип установки. Мы конфигурируем клиентскую часть, и, соответственно, выбираем из выпадающего списка пункт "Minimum client install - no server, no tools". Кнопки в списке устанавливаемых компонентов будут автоматически выставлены в правильное положение.
    Установка клиентской части FireBird - выбор типа установки
  6. На шестой странице предлагается выбрать имя папки меню "Пуск", в которой будут созданы полезные ярлыки. В нашем случае ярлыки будут созданы для файлов документации, бесполезной в конечном счете для конечного пользователя. Поэтому мы ставим флажок "Don't create any icons".
    Установка FireBird (шестая страница)
  7. На седьмой странице необходимо выбрать параметры установки. Программное обеспечение "Мельница данных" использует в работе библиотеку gds32.dll, загружая ее из системного каталога Windows. Поэтому в целях обеспечения нормальной работы необходимо установить оба флажка - "Copy Firebird client library to <system> directory" и "Generate client library as GDS32.DLL for legacy app. support".
    Установка клиентской части FireBird - параметры установки
  8. На восьмой странице необходимо подтвердить установку с выбранными параметрами.
    Установка клиентской части FireBird - подтверждение установки
  9. После установки на девятой странице можно ознакомиться с информацией об установленной версии.
    Установка FireBird (девятая страница)
  10. Десятая страница информирует об успешном завершении установки.
    Установка клиентской части FireBird - установка завершена

Младшая тестированная на совместимость версия - 9.2.0.1. Использование более младшей версии на клиенте недопустимо.

Если вы устанавливаете Oracle не с компакт-дисков, то не пользуйтесь программой автозапуска, лежащей в корне первого установочного диска, а запустите setup.exe из каталога install\win32 на первом установочном диске.

Шаги установки примерно следующие:

  1. Первая страница содержит логотип Oracle и командные кнопки. Для продолжения установки нажмите кнопку "Next".
    Установка Oracle (первая страница)
  2. На второй странице необходимо определиться с путями установки и источника, а также с именем "дома". Настоятельно рекомендуется принять значения, предлагаемые по умолчанию.
    Установка Oracle (вторая страница)
  3. На третьей странице необходимо выбрать устанавливаемый продукт. Для рабочей станции необходимо установить продукт "Oracle9i Client 9.2.0.1.0".
    Установка клиентской части Oracle
  4. На четвертой странице необходимо выбрать тип установки. Для обеспечения требуемой функциональности выберите тип "Runtime".
    Установка клиентской части Oracle - выбор типа установки
  5. На пятой странице необходимо подтвердить правильность параметров установки.
    Установка клиентской части Oracle - подтверждение установки
  6. В процессе установки инсталлятор потребует настроить параметры соединения с сервером БД. Для этого запустится отдельный мастер "Oracle Net Configuration Assistant", и процесс установки будет приостановлен на время работы этого мастера.
    Если этого по каким-либо причинам не произошло, то после завершнения установки необходимо запустить это приложение из меню "Пуск" и выполнить описанные в этом и следующих шагах действия.
    На этой (первой) странице мастера необходимо отказаться от использования службы каталогов, выбрав кнопку "No, I will create net service names myself...".
    Установка клиентской части Oracle - конфигурирование подключения к БД - не использовать directory service.
  7. На второй странице мастера необходимо выбрать версию базы данных. Базы данных версии Oracle8 в любом случае не поддерживаются "Мельницей данных", поэтому выберите кнопку "Oracle8i or later database or service".
    Установка клиентской части Oracle - конфигурирование подключения к БД - версия БД
  8. На третьей странице мастера необходимо ввести имя сервиса, идентифицирующего базу данных на сервере (в данном случае - "RTT"). Это имя устанавливается при создании базы данных.
    Установка клиентской части Oracle - конфигурирование подключения к БД - имя сервиса
  9. На четвертой странице мастера выберите из списка доступных для соединения с БД протоколов протокол "TCP".
    Установка клиентской части Oracle - конфигурирование подключения к БД - протокол
  10. На пятой странице мастера введите адрес сервера, на котором установлена БД. Можно вводить как символьное имя сервера, так и IP-адрес. На этой же странице выберите порт TCP/IP, по которому будет производиться соединение с сервером. Порт по умолчанию - 1521.
    Установка клиентской части Oracle - конфигурирование подключения к БД - сервер и порт
  11. На шестой странице мастер предлагает протестировать заданные на предыдущих шагах параметры. Выберите кнопку "Yes, perform a test".
    Установка клиентской части Oracle - конфигурирование подключения к БД - тестирование соединения
  12. Если введенные на предыдущих страницах параметры соединения с БД были заданы корректно, то мастер сообщит об этом:
    Установка клиентской части Oracle - конфигурирование подключения к БД - успешное соединение
  13. На восьмой странице введите имя псевдонима подключения, который будет использоваться в дальнейшем для установки соединения с БД приложениями "Мальницы данных". Во избежание путаницы настоятельно рекомендуется именовать псевдоним так же, как и службу на сервере (в данном случае - RTT). сообщит об этом:
    Установка клиентской части Oracle - конфигурирование подключения к БД - псевдоним соедиения
  14. На девятой странице мастера у вас есть возможность выбрать, настроить еще одно подключение или завершить работу с мастером. После завршения установки вы всегда сможете вернуться к процедуре создания псевдонима подключений, вызвав из меню "Пуск" приложение "Oracle Net Configuration Assistant".
    Установка клиентской части Oracle - конфигурирование подключения к БД - отказ от создания следующего соединения
  15. На десятой странице мастер сообщает об успешном создании псевдонима соединения с БД.
    Установка клиентской части Oracle - конфигурирование подключения к БД - завершено конфигурирование соединения
  16. На десятой странице мастер сообщает об успешном завершении своей работы.
    Установка клиентской части Oracle - конфигурирование подключения к БД - завершено
  17. После завршения работы мастера "Oracle Net Configuration Assistant" вы увидете сообщение об успешном завершении работы инсталлятора. Нажмите кнопку "Exit".
    Установка клиентской части Oracle - завершено


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IExceptionHandler (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IExceptionHandler

1type
2  IExceptionHandler = interface(IDispatch)
3    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
4    procedure HandleException(ContextObject: OleVariant; const Message: WideString;
5      const ExtentedInfo: WideString; SupportServiceData: OleVariant); safecall;
6  end;

1. Метод HandleException

Метод интерфейса IExceptionHandler.

1procedure IExceptionHandler.HandleException(ContextObject: OleVariant;
2  const Message: WideString; const ExtentedInfo: WideString;
3  SupportServiceData: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
ContextObject | OleVariant | Да |
Message | WideString | Да |
ExtentedInfo | WideString | Да |
SupportServiceData | OleVariant | Да |


Мельница данных ((раздел целиком))

Мельница данных- Класс TUserNotificationAddressee (Адресаты уведомлений) (раздел целиком) (22.10.2024) (одним файлом)
Класс TUserNotificationAddressee (Адресаты уведомлений)

Класс TObject (Объекты)Класс TUserNotification (Уведомления)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TUserNotificationAddressee:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
SecurityAccount | TSecurityAccount | Да | Видимо пользователю | Чтение/Запись | Роль безопасности

2. Конструктор Create (Конструктор адресата уведомления)

Конструктор класса TUserNotificationAddressee.

1constructor TUserNotificationAddressee.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
SecurityAccount | TSecurityAccount | Да | Роль безопасности

Замечания:

Создает новый объект класса TUserNotificationAddressee.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IContext (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IContext

001type
002  IContext = interface(IDispatch)
003    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
004    function Get_ContextObject: IDispatch; safecall;
005    function Get_UserName: WideString; safecall;
006    function Get_NegotiateAuth: WordBool; safecall;
007    function Get_Language: WideString; safecall;
008    procedure Set_Language(Value: WideString); safecall;
009    function Get_TimeBias: Double; safecall;
010    function getName(ID: OleVariant): WideString; safecall;
011    function getDescription(ID: OleVariant): WideString; safecall;
012    function getPropValue(const ClassName: WideString; const PropName: WideString;
013      ID: OleVariant): OleVariant; safecall;
014    procedure setPropValue(const ClassName: WideString; const PropName: WideString;
015      ID: OleVariant; Value: OleVariant); safecall;
016    procedure getPropValues(const ClassName: WideString;
017      const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
018      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
019    procedure setPropValues(const ClassName: WideString;
020      const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
021      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
022    function createDataSet(const TargetClassName: WideString): IContextDataSet; safecall;
023    function select(const ClassName: WideString; QueryItems: OleVariant): IDispatch; safecall;
024    function executeMethod(const ClassName: WideString;
025      const MethodName: WideString; Params: OleVariant): OleVariant; safecall;
026    function getClass(const ClassName: WideString): WideString; safecall;
027    function enumerationItem(ItemIdentifier: OleVariant): WideString; safecall;
028    function getResource(const Name: WideString): WideString; safecall;
029    function bulkInsert(const ClassName: WideString;
030      const Data: IDispatch): IContextDataSet; safecall;
031    function PreProcessScript(const Script: WideString; Indent: WordBool;
032      const CommentMark: WideString): WideString; safecall;
033    function executeReport(const ClassName: WideString;
034      const TemplateName: WideString; Params: OleVariant): IDispatch; safecall;
035    procedure saveReport(const ClassName: WideString;
036      const TemplateName: WideString; Params: OleVariant; const FileName: WideString); safecall;
037    function Get_Variable(const Name: WideString; Persistent: WordBool): OleVariant; safecall;
038    procedure Set_Variable(const Name: WideString; Persistent: WordBool;
039      Value: OleVariant); safecall;
040    function DebugString(const Message: WideString): WideString; safecall;
041    procedure raiseManagedException(const ExceptionMessage: WideString); safecall;
042    function createGUID: WideString; safecall;
043    function getTempFileName(const Extension: WideString): WideString; safecall;
044    function HasUI: WordBool; safecall;
045    function Handle: Integer; safecall;
046    procedure processStart(const Description: WideString; ItemCount: Integer;
047      CanAbort: WordBool); safecall;
048    function processStep: WordBool; safecall;
049    procedure processStop; safecall;
050    procedure Sleep(MSecs: Integer); safecall;
051    function executeConsoleProcess(const CommandLine: WideString;
052      MaxDuration: Integer; const OutputData: OleVariant): Integer; safecall;
053    function downloadData(const Host: WideString; const Url: WideString;
054      const UserName: WideString; const Password: WideString;
055      NegotiateAuth: WordBool; PostData: OleVariant;
056      const PostContentType: WideString; PostDataIsBinary: WordBool;
057      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant; safecall;
058    function LineBreak: WideString; safecall;
059    function Transliterate(const Value: WideString): WideString; safecall;
060    procedure CompareLists(var List1: OleVariant; var List2: OleVariant;
061      const Delimiter: WideString; CaseSensitive: WordBool); safecall;
062    function parseJSON(const JSON: WideString): WideString; safecall;
063    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch; safecall;
064    function createBinaryData: IDispatch; safecall;
065    function getCRC(Data: OleVariant): WideString; safecall;
066    function buildNamedFile(const Data: IDispatch;
067      const StoredFileName: WideString; Propmpt: WordBool;
068      Compress: WordBool): IDispatch; safecall;
069    procedure parseNamedFile(NamedFile: OleVariant; out FileName: OleVariant;
070      out Data: OleVariant); safecall;
071    function createRaster: IDispatch; safecall;
072    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
073    function getOleObject(const ClassID: WideString;
074      const AccessibleFileName: WideString): IDispatch; safecall;
075    function PlaceDataSet(const Range: IDispatch; const DataSet: IContextDataSet;
076      ShiftRows: WordBool; ShiftColumns: WordBool): Integer; safecall;
077    procedure ExportObject(var Document: OleVariant; const ID: WideString;
078      const ClassID: WideString); safecall;
079    function createZIPArchive: IDispatch; safecall;
080    function callRoutine(const ClassName: WideString;
081      const RoutineName: WideString; var RetValue: OleVariant;
082      const ScriptPart: OleVariant): WordBool; safecall;
083    function selectVaue(const ClassDomain: WideString;
084      const ExpressionContext: IUnknown; var Value: OleVariant): WordBool; safecall;
085    function editValues(const ValuesList: WideString; const Title: WideString;
086      UseTabs: WordBool; HideOKButton: WordBool;
087      const ScriptPart: OleVariant): WordBool; safecall;
088    function MsgBox(const Prompt: WideString; Buttons: LongWord;
089      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
090    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
091      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
092    procedure showView(const ViewName: WideString; Key: OleVariant;
093      const DetailPropertyName: WideString); safecall;
094    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
095      ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
096      TakeActionsFromView: OleVariant); safecall;
097    procedure SaveExternalDataToFolder(const Resource: WideString;
098      const Folder: WideString); safecall;
099    function PerformAsyncTask(ID: OleVariant): WordBool; safecall;
100    procedure RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
101      ThreadCount: Integer); safecall;
102    function MainHandle: Integer; safecall;
103    function IsHTMLDocumentSafe(const HTML: WideString): WordBool; safecall;
104    function EnsafeHTMLDocument(const HTML: WideString; RemoveHead: WordBool;
105      Format: WordBool; PureXML: WordBool): WideString; safecall;
106    property ContextObject: IDispatch read Get_ContextObject;
107    property UserName: WideString read Get_UserName;
108    property NegotiateAuth: WordBool read Get_NegotiateAuth;
109    property Language: WideString read Get_Language write Set_Language;
110    property TimeBias: Double read Get_TimeBias;
111    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant
112      read Get_Variable write Set_Variable;
113  end;

1. Свойства

Свойства интерфейса IContext:

Имя | Тип | Доступ | Назначение
ContextObject | IDispatch | Только для чтения |
Language | WideString | Чтение/Запись |
NegotiateAuth | WordBool | Только для чтения |
TimeBias | Double | Только для чтения |
UserName | WideString | Только для чтения |
Variable[const Name: WideString, Persistent: WordBool] | OleVariant | Чтение/Запись |

2. Метод BinaryToBitmap

Метод интерфейса IContext.

function IContext.BinaryToBitmap(const Data: IDispatch): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Data | IDispatch | Да |

Замечания:

Возвращает значение типа IDispatch.

3. Метод buildNamedFile

Метод интерфейса IContext.

1function IContext.buildNamedFile(const Data: IDispatch;
2  const StoredFileName: WideString; Propmpt: WordBool;
3  Compress: WordBool): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Data | IDispatch | Да |
StoredFileName | WideString | Да |
Propmpt | WordBool | Да |
Compress | WordBool | Да |

Замечания:

Возвращает значение типа IDispatch.

4. Метод bulkInsert

Метод интерфейса IContext.

1function IContext.bulkInsert(const ClassName: WideString;
2  const Data: IDispatch): IContextDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
Data | IDispatch | Да |

Замечания:

Возвращает значение типа IContextDataSet.

5. Метод callRoutine

Метод интерфейса IContext.

1function IContext.callRoutine(const ClassName: WideString;
2  const RoutineName: WideString; var RetValue: OleVariant;
3  const ScriptPart: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
RoutineName | WideString | Да |
RetValue | OleVariant | Нет |
ScriptPart | OleVariant | Нет |

Замечания:

Возвращает значение типа WordBool.

6. Метод CompareLists

Метод интерфейса IContext.

1procedure IContext.CompareLists(var List1: OleVariant; var List2: OleVariant;
2  const Delimiter: WideString; CaseSensitive: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
List1 | OleVariant | Да |
List2 | OleVariant | Да |
Delimiter | WideString | Да |
CaseSensitive | WordBool | Да |

7. Метод ConvertExcel

Метод интерфейса IContext.

1function IContext.ConvertExcel(Source: OleVariant;
2  const Format: WideString): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Source | OleVariant | Да |
Format | WideString | Да |

Замечания:

Возвращает значение типа IDispatch.

8. Метод createBinaryData

Метод интерфейса IContext.

function IContext.createBinaryData: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

9. Метод createDataSet

Метод интерфейса IContext.

function IContext.createDataSet(const TargetClassName: WideString): IContextDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
TargetClassName | WideString | Да |

Замечания:

Возвращает значение типа IContextDataSet.

10. Метод createGUID

Метод интерфейса IContext.

function IContext.createGUID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

11. Метод createRaster

Метод интерфейса IContext.

function IContext.createRaster: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

12. Метод createZIPArchive

Метод интерфейса IContext.

function IContext.createZIPArchive: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

13. Метод DebugString

Метод интерфейса IContext.

function IContext.DebugString(const Message: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Message | WideString | Да |

Замечания:

Возвращает значение типа WideString.

14. Метод downloadData

Метод интерфейса IContext.

1function IContext.downloadData(const Host: WideString; const Url: WideString;
2  const UserName: WideString; const Password: WideString;
3  NegotiateAuth: WordBool; PostData: OleVariant;
4  const PostContentType: WideString; PostDataIsBinary: WordBool;
5  CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Host | WideString | Да |
Url | WideString | Да |
UserName | WideString | Да |
Password | WideString | Да |
NegotiateAuth | WordBool | Да |
PostData | OleVariant | Да |
PostContentType | WideString | Да |
PostDataIsBinary | WordBool | Да |
CanCache | WordBool | Да |
NewSession | WordBool | Да |
TimeOut | Integer | Да |

Замечания:

Возвращает значение типа OleVariant.

15. Метод editValues

Метод интерфейса IContext.

1function IContext.editValues(const ValuesList: WideString;
2  const Title: WideString; UseTabs: WordBool; HideOKButton: WordBool;
3  const ScriptPart: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ValuesList | WideString | Да |
Title | WideString | Да |
UseTabs | WordBool | Да |
HideOKButton | WordBool | Да |
ScriptPart | OleVariant | Нет |

Замечания:

Возвращает значение типа WordBool.

16. Метод EnsafeHTMLDocument

Метод интерфейса IContext.

1function IContext.EnsafeHTMLDocument(const HTML: WideString;
2  RemoveHead: WordBool; Format: WordBool; PureXML: WordBool): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
HTML | WideString | Да |
RemoveHead | WordBool | Да |
Format | WordBool | Да |
PureXML | WordBool | Да |

Замечания:

Возвращает значение типа WideString.

17. Метод enumerationItem

Метод интерфейса IContext.

function IContext.enumerationItem(ItemIdentifier: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ItemIdentifier | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

18. Метод executeConsoleProcess

Метод интерфейса IContext.

1function IContext.executeConsoleProcess(const CommandLine: WideString;
2  MaxDuration: Integer; const OutputData: OleVariant): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
CommandLine | WideString | Да |
MaxDuration | Integer | Да |
OutputData | OleVariant | Да |

Замечания:

Возвращает значение типа Integer.

19. Метод executeMethod

Метод интерфейса IContext.

1function IContext.executeMethod(const ClassName: WideString;
2  const MethodName: WideString; Params: OleVariant): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
MethodName | WideString | Да |
Params | OleVariant | Да |

Замечания:

Возвращает значение типа OleVariant.

20. Метод executeReport

Метод интерфейса IContext.

1function IContext.executeReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
TemplateName | WideString | Да |
Params | OleVariant | Да |

Замечания:

Возвращает значение типа IDispatch.

21. Метод ExportObject

Метод интерфейса IContext.

1procedure IContext.ExportObject(var Document: OleVariant; const ID: WideString;
2  const ClassID: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Document | OleVariant | Да |
ID | WideString | Да |
ClassID | WideString | Да |

22. Метод getClass

Метод интерфейса IContext.

function IContext.getClass(const ClassName: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |

Замечания:

Возвращает значение типа WideString.

23. Метод getCRC

Метод интерфейса IContext.

function IContext.getCRC(Data: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

24. Метод getDescription

Метод интерфейса IContext.

function IContext.getDescription(ID: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

25. Метод getName

Метод интерфейса IContext.

function IContext.getName(ID: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

26. Метод getOleObject

Метод интерфейса IContext.

1function IContext.getOleObject(const ClassID: WideString;
2  const AccessibleFileName: WideString): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassID | WideString | Да |
AccessibleFileName | WideString | Да |

Замечания:

Возвращает значение типа IDispatch.

27. Метод getPropValue

Метод интерфейса IContext.

1function IContext.getPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
ID | OleVariant | Да |

Замечания:

Возвращает значение типа OleVariant.

28. Метод getPropValues

Метод интерфейса IContext.

1procedure IContext.getPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
IDS | OleVariant | Да |
OnValueEvent | OleVariant | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |

29. Метод getResource

Метод интерфейса IContext.

function IContext.getResource(const Name: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа WideString.

30. Метод getTempFileName

Метод интерфейса IContext.

function IContext.getTempFileName(const Extension: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Extension | WideString | Да |

Замечания:

Возвращает значение типа WideString.

31. Метод Handle

Метод интерфейса IContext.

function IContext.Handle: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

32. Метод HasUI

Метод интерфейса IContext.

function IContext.HasUI: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

33. Метод IsHTMLDocumentSafe

Метод интерфейса IContext.

function IContext.IsHTMLDocumentSafe(const HTML: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
HTML | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

34. Метод LineBreak

Метод интерфейса IContext.

function IContext.LineBreak: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

35. Метод MainHandle

Метод интерфейса IContext.

function IContext.MainHandle: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

36. Метод MsgBox

Метод интерфейса IContext.

1function IContext.MsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Prompt | WideString | Да |
Buttons | LongWord | Нет |
Title | WideString | Нет |
HelpFile | WideString | Нет |
Context | LongWord | Нет |

Замечания:

Возвращает значение типа Integer.

37. Метод parseJSON

Метод интерфейса IContext.

function IContext.parseJSON(const JSON: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
JSON | WideString | Да |

Замечания:

Возвращает значение типа WideString.

38. Метод parseNamedFile

Метод интерфейса IContext.

1procedure IContext.parseNamedFile(NamedFile: OleVariant;
2  out FileName: OleVariant; out Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
NamedFile | OleVariant | Да |
FileName | OleVariant | Да |
Data | OleVariant | Да |

39. Метод PerformAsyncTask

Метод интерфейса IContext.

function IContext.PerformAsyncTask(ID: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WordBool.

40. Метод PlaceDataSet

Метод интерфейса IContext.

1function IContext.PlaceDataSet(const Range: IDispatch;
2  const DataSet: IContextDataSet; ShiftRows: WordBool;
3  ShiftColumns: WordBool): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Range | IDispatch | Да |
DataSet | IContextDataSet | Да |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |

Замечания:

Возвращает значение типа Integer.

41. Метод PreProcessScript

Метод интерфейса IContext.

1function IContext.PreProcessScript(const Script: WideString; Indent: WordBool;
2  const CommentMark: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Script | WideString | Да |
Indent | WordBool | Да |
CommentMark | WideString | Да |

Замечания:

Возвращает значение типа WideString.

42. Метод processStart

Метод интерфейса IContext.

1procedure IContext.processStart(const Description: WideString;
2  ItemCount: Integer; CanAbort: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Description | WideString | Да |
ItemCount | Integer | Нет |
CanAbort | WordBool | Нет |

43. Метод processStep

Метод интерфейса IContext.

function IContext.processStep: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

44. Метод processStop

Метод интерфейса IContext.

procedure IContext.processStop;

Метод не имеет параметров.

45. Метод raiseManagedException

Метод интерфейса IContext.

procedure IContext.raiseManagedException(const ExceptionMessage: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ExceptionMessage | WideString | Да |

46. Метод RebuildTextIndex

Метод интерфейса IContext.

1procedure IContext.RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
2  ThreadCount: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
ClassID | OleVariant | Да |
FieldID | OleVariant | Да |
ThreadCount | Integer | Да |

47. Метод SaveExternalDataToFolder

Метод интерфейса IContext.

1procedure IContext.SaveExternalDataToFolder(const Resource: WideString;
2  const Folder: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Resource | WideString | Да |
Folder | WideString | Да |

48. Метод saveReport

Метод интерфейса IContext.

1procedure IContext.saveReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant; const FileName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
TemplateName | WideString | Да |
Params | OleVariant | Да |
FileName | WideString | Да |

49. Метод select

Метод интерфейса IContext.

1function IContext.select(const ClassName: WideString;
2  QueryItems: OleVariant): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
QueryItems | OleVariant | Да |

Замечания:

Возвращает значение типа IDispatch.

50. Метод selectVaue

Метод интерфейса IContext.

1function IContext.selectVaue(const ClassDomain: WideString;
2  const ExpressionContext: IUnknown; var Value: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ClassDomain | WideString | Да |
ExpressionContext | IUnknown | Да |
Value | OleVariant | Да |

Замечания:

Возвращает значение типа WordBool.

51. Метод setPropValue

Метод интерфейса IContext.

1procedure IContext.setPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant; Value: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
ID | OleVariant | Да |
Value | OleVariant | Да |

52. Метод setPropValues

Метод интерфейса IContext.

1procedure IContext.setPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
IDS | OleVariant | Да |
OnValueNeededEvent | OleVariant | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |

53. Метод showDataSet

Метод интерфейса IContext.

1procedure IContext.showDataSet(const DataSet: ContextDataSet;
2  const Caption: WideString; ColumnCaptions: OleVariant;
3  ColumnOnChangeHandlers: OleVariant; TakeActionsFromView: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
DataSet | ContextDataSet | Да |
Caption | WideString | Да |
ColumnCaptions | OleVariant | Да |
ColumnOnChangeHandlers | OleVariant | Да |
TakeActionsFromView | OleVariant | Да |

54. Метод ShowMsgBox

Метод интерфейса IContext.

1function IContext.ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Prompt | WideString | Да |
Buttons | LongWord | Нет |
Title | WideString | Нет |
HelpFile | WideString | Нет |
Context | LongWord | Нет |

Замечания:

Возвращает значение типа Integer.

55. Метод showView

Метод интерфейса IContext.

1procedure IContext.showView(const ViewName: WideString; Key: OleVariant;
2  const DetailPropertyName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ViewName | WideString | Да |
Key | OleVariant | Да |
DetailPropertyName | WideString | Да |

56. Метод Sleep

Метод интерфейса IContext.

procedure IContext.Sleep(MSecs: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
MSecs | Integer | Да |

57. Метод Transliterate

Метод интерфейса IContext.

function IContext.Transliterate(const Value: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Value | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Мельница данных ((раздел целиком))

Мельница данных- Класс TViewCondition (Условия отбора) (раздел целиком) (22.10.2024) (одним файлом)
Класс TViewCondition (Условия отбора)

Класс TObject (Объекты)Класс TCustomView (Абстрактное представление)

Объекты класса образуют иерархию.

1. Свойства

Свойства класса TViewCondition:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
LinkedClass | TClass | Нет | Видимо пользователю | Чтение/Запись | Присоединяемый класс
MasterProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-главное
DetailProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Свойство-подчиненное
LinkedOption | TOption | Нет | Видимо пользователю | Чтение/Запись | Присоединенная настройка
LinkedOptionName | string[64] | Да | Видимо пользователю | Только для чтения | Имя присоединяемой настройки
LinkedOptionProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Свойство присоединенной настройки
Expression | clob | Нет | Видимо пользователю | Чтение/Запись | Выражение условия
Negation | Boolean | Да | Видимо пользователю | Чтение/Запись | Отрицание
LinkNonRequired | Boolean | Да | Видимо пользователю | Чтение/Запись | Присоединять необязательное свойство
LinkedProfile | TProfile | Нет | Видимо пользователю | Чтение/Запись | Присоединенный профиль

2. Конструктор Create (Конструктор условия отбора)

Конструктор класса TViewCondition.

1constructor TViewCondition.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  LinkedClass: TClass; MasterProperty: TProperty; DetailProperty: TClassMember;
4  LinkedOption: TOption; LinkedOptionProperty: TClassMember; Expression: clob;
5  Negation: Boolean; LinkNonRequired: Boolean; LinkedProfile: TProfile): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
LinkedClass | TClass | Нет | Присоединяемый класс
MasterProperty | TProperty | Нет | Свойство-главное
DetailProperty | TClassMember | Нет | Свойство-подчиненное
LinkedOption | TOption | Нет | Присоединенная настройка
LinkedOptionProperty | TClassMember | Нет | Свойство присоединенной настройки
Expression | clob | Нет | Выражение условия отбора
Negation | Boolean | Да | Отрицание
LinkNonRequired | Boolean | Да | Присоединять необязательное свойство
LinkedProfile | TProfile | Нет | Присоединенный профиль

Замечания:

Создает новый объект класса TViewCondition.


Мельница данных ((раздел целиком))

Мельница данных- Класс TStringListItem (Элемент списка строк) (раздел целиком) (22.10.2024) (одним файлом)
Класс TStringListItem (Элемент списка строк)

Класс TObject (Объекты)Класс TStringList (Список строк)

Объекты класса не именованы.

1. Свойства

Свойства класса TStringListItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
StringItem | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Строка
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция

2. Конструктор Create (Конструктор элемента списка строк)

Конструктор класса TStringListItem.

1constructor TStringListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  StringItem: string[2000]; Position: Integer): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
StringItem | string[2000] | Нет | Строка
Position | Integer | Да | Позиция

Замечания:

Создает новый объект класса TStringListItem.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IOptionInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IOptionInfo

Интерфейс INamedItemInfo

01type
02  IOptionInfo = interface(INamedItemInfo)
03    ['{453E81A2-969D-49DC-B3C6-ACAD411D63FC}']
04    function Get_TypeInfo: ITypeInfo; safecall;
05    function Get_Group: WideString; safecall;
06    function Get_Tab: WideString; safecall;
07    function Get_Value: OleVariant; safecall;
08    procedure Set_Value(Value: OleVariant); safecall;
09    property TypeInfo: ITypeInfo read Get_TypeInfo;
10    property Group: WideString read Get_Group;
11    property Tab: WideString read Get_Tab;
12    property Value: OleVariant read Get_Value write Set_Value;
13  end;

1. Свойства

Свойства интерфейса IOptionInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Group | WideString | Только для чтения |
Tab | WideString | Только для чтения |
TypeInfo | ITypeInfo | Только для чтения |
Value | OleVariant | Чтение/Запись |


Мельница данных ((раздел целиком))

Мельница данных- Класс TPDFTemplate (Шаблоны отчетов PDF) (раздел целиком) (22.10.2024) (одним файлом)
Класс TPDFTemplate (Шаблоны отчетов PDF)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

1. Свойства

Свойства класса TPDFTemplate:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
TemplateScript | clob | Нет | Видимо пользователю | Чтение/Запись | Скрипт шаблона

2. Конструктор Create (Конструктор шаблона PDF)

Конструктор класса TPDFTemplate.

1constructor TPDFTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateScript: clob): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
TemplateScript | clob | Нет | Скрипт шаблона

Замечания:

Создает новый объект класса TPDFTemplate.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IButton (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IButton

1type
2  IButton = interface(IDispatch)
3    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
4    function Get_Enabled: WordBool; safecall;
5    procedure Set_Enabled(Value: WordBool); safecall;
6    function Name: WideString; safecall;
7    procedure Click; safecall;
8    property Enabled: WordBool read Get_Enabled write Set_Enabled;
9  end;

1. Свойства

Свойства интерфейса IButton:

Имя | Тип | Доступ | Назначение
Enabled | WordBool | Чтение/Запись |

2. Метод Click

Метод интерфейса IButton.

procedure IButton.Click;

Метод не имеет параметров.

3. Метод Name

Метод интерфейса IButton.

function IButton.Name: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IFloatInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IFloatInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

01type
02  IFloatInfo = interface(ITypeInfo)
03    ['{E9B56C6D-47DC-4AB9-9E80-6EEF77708704}']
04    function Get_MaxValue: Double; safecall;
05    function Get_MaxValueUsed: WordBool; safecall;
06    function Get_MinValue: Double; safecall;
07    function Get_MinValueUsed: WordBool; safecall;
08    function Get_Precision: Integer; safecall;
09    function Get_Scale: Integer; safecall;
10    property MaxValue: Double read Get_MaxValue;
11    property MaxValueUsed: WordBool read Get_MaxValueUsed;
12    property MinValue: Double read Get_MinValue;
13    property MinValueUsed: WordBool read Get_MinValueUsed;
14    property Precision: Integer read Get_Precision;
15    property Scale: Integer read Get_Scale;
16  end;

1. Свойства

Свойства интерфейса IFloatInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
MaxValue | Double | Только для чтения |
MaxValueUsed | WordBool | Только для чтения |
MinValue | Double | Только для чтения |
MinValueUsed | WordBool | Только для чтения |
Precision | Integer | Только для чтения |
Scale | Integer | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Руководство разработчика на платформе (раздел целиком) (22.10.2024)

(одним файлом)

Руководство разработчика на платформе

1. Решения, предлагаемые технологией "Мельница данных"

Технология "Мельница данных" предлагает решения традиционных проблем разработки и сопровождения учетных систем за счет следующих инноваций:

Объектная модель хранится в системе по тем же принципам, что и модель бизнес-данных, т.е. объекты классов, описывающих метаданные системы (классы, поля, методы, свойства, пользовательские формы) хранятся в базе данных и отображаются при помощи стандартного пользовательского интерфейса. Моделирование системного слоя метаданных системы произведено разработчиками платформы. Модель системного слоя документирована и доступна для просмотра и использования разработчикам прикладных систем.

Разработка прикладных учетных систем ведется в той же среде, что и работа конечных пользователей. Текущая модель прикладной системы доступна для просмотра и использования всеми разработчиками.

На основе заложенной объектной модели прикладной системы автоматически генерируется SQL-код (как DML, так и DDL составляющие), что полностью освобождает разработчика прикладной системы от SQL-программирования.

Пользовательские интерфейсы (формы, представления) также описываются при помощи объектной модели и хранятся в базе данных. Это позволяет автоматически генерировать формы просмотра данных и формы задания параметров методов, что освобождает разработчика прикладной системы от написания кода клиентского приложения. Для тонкого управления поведением форм задания параметров может использоваться язык VB-script.

При внесении изменений в объектную модель:

новое состояние модели отображается в пользовательском интерфейсе в доступной для всех разработчиков форме;

текущая объектная модель в виде диаграммы классов может быть выгружена в HTML-отчет, что является базовой возможностью платформы;

внесение изменений в структуру базы данных и пользовательские интерфейсы производится автоматически средствами платформы.

Основными элементами стандартизованного пользовательского интерфейса являются развитые элементы управления, работающие с данными:

Таблицы данных - отображают списки объектов в табличной форме, удобной для восприятия пользователя. Таблицы данных позволяют производить сортировку, группировку объектов, фильтрацию данных по ряду условий, подведение агрегатов (количества объектов, наибольшего, наименьшего значения, суммы, среднего и т.д.), отображение и скрытие групп, подведение итогов по группе. Таблицы данных имеют функционал, позволяющий отображать иерархические структуры, а также производить произвольный отбор отображаемых объектов пользователем. Используемые таблицы данных позволяют работать с большими объемами данных без потери производительности.

Инспектор объектов - отображает все свойства выбранных (одного или нескольких) объектов в двух колонках: имя свойства - значение свойства. Инспектор объектов позволяет просматривать все свойства объектов, а также изменять значения свойств как одного объекта, так и для всех выделенных объектов одним действием.

Форма задания параметров - отображается при вызове пользователем одного из методов. На форме расположены элементы управления Поле ввода, соответствующие описанным для метода параметрам. Внешний вид и поведение элементов управления зависят от типа описанных параметров. Поведением элементов управления на форме можно управлять при помощи скрипта формы, разрабатываемого на языке VB-script.

Поле ввода - используется для задания значений свойств и параметров как в Таблице данных, так и в Инспекторе объектов и на формах задания параметров. Имеет функционал, позволяющий редактировать значения различных типов. Использование стандартизованного пользовательского интерфейса позволяет снизить издержки как на его сопровождение, так и на обучение пользователей работе на новых участках.

Реализованы развитые возможности интеграции с третьесторонними системами. Они обеспечиваются следующими механизмами:

Возможность переноса в Microsoft Excel любого видимого представления "as-is" с сохранением всех группировок, сортировок, агрегатов и т. п.

Возможность вывода отчетов в виде документов Microsoft Office с передачей в среду функционирования Office соединения с БД, что позволяет строить отчеты любой степени сложности.

Возможность использования в системе любого внешнего Ole-объекта как метода любого класса без ограничений.

Возможность использования скриптлетов (фрагментов кода на скриптовом языке VBScript и/или JScript) как методов системы, фактически - возможность реализации на этих языках сколь угодно сложного поведения.

Возможность формирования отчетов непосредственно в виде html-документов для последующей публикации их в сети Internet.

2. Системный слой объектной модели "Мельница данных"

Технология разработки и сопровождения учетных систем "Мельница данных" требует для своего функционирования объектную модель бизнес-сущностей. Технология диктует ряд дополнительных требований к объектной модели.

Все классы наследуются от единого корня, класса TObject. Класс TObject вводит ряд элементов состояния, поведения и представления, которые наследуются всеми учитываемыми объектами в обязательном порядке.

Множественное наследование не поддерживается (т.е. у каждого класса может быть один и только один родитель).

Множественная инкапсуляция не поддерживается (т.е. у каждого объекта может быть один либо ни одного инкапсулирующего объекта).

Простые типы данных вводятся посредством доменов. Домены определяют обязательность своих значений, а также другие характеристики, зависящие от класса домена. Домены бывают:

строковые (определяют максимальную длину строки);

целочисленные (определяют максимальное и минимальное значение целого числа);

вещественные (определяют максимальное и минимальное значение числа, количество значащих цифр);

логические;

значения типа "дата";

значения типа "время";

значения типа "дата со временем";

перечисления (определяют список возможных значений);

ссылка (определяют класс-приемник ссылки);

большие двоичные объекты (текст, изображение, файл, и т.д.).

3. Наследование и переопределение членов класса и параметров подпрограмм

Все члены родительского класса наследуются дочерним классом следующим образом:
Поля
Все поля родительского класса доступны в дочернем классе. При создании в дочернем классе поля с тем же именем, что и в родительском классе, класс-наследник теряет возможность напрямую манипулировать полем родительского класса и получает поле с тем же именем. Можно сказать, что новое поле "закрывает" старое, но не "замещает" его.
Методы
Все методы родительского класса наследуются дочерним классом. При создании в дочернем классе метода с тем же именем, что и в родительском классе, метод переопределяется, т.е. вместо старого метода будет существовать новый. Единственный способом обратиться к старому (унаследованному) методу является использование в теле метода оператора унаследованного вызова inherited (см. раздел 5.3.14.). Переопределенный метод имеет все параметры родительского метода и может расширять список параметров, а также переопределять унаследованные параметры (создавая параметры с тем же именем и изменяя любой другой атрибут параметра по своему усмотрению). Скрипты форм задания параметров не наследуются и должны быть полностью заданы в переопределенном методе. Изображения-иконки методов наследуются и могут не переопределяться явно.
Свойства
Все свойства родительского класса доступны в дочернем классе. При создании в дочернем классе свойства с тем же именем, что и в родительском классе, класс-наследник теряет возможность напрямую манипулировать свойством родительского класса и получает свойство с тем же именем. Можно сказать, что новое свойство "закрывает" старое, но не "замещает" его. На практике часто бывает необходимо в унаследованном методе (особенно в конструкторе) скрыть часть параметров от пользователя, либо сузить область выбора значений для каких либо параметров. В этом случае необходимо переопределить параметры в унаследованном методе с новыми значениями свойства Scope ("Область видимости") или Domain ("Домен"). Это нормальная рекомендуемая практика. Необходимо понимать, что скрыв с формы элемент управления, соответствующий параметру, значение которого обязательно, необходимо предусмотреть, чтобы этот параметр получил значение до вызова унаследованного метода, либо из скрипта формы задания параметров, либо в теле самого метода.

В конструкторе класса, унаследованного от класса TObject, переопределен параметр Name, таким образом, что в свойстве "Область видимости" установлено значение "Не видимо пользователям". При этом тело метода конструктора должно выглядеть следующим образом:
1begin
2  Name := UniqueValue;                    (1)
3  inherited;                         (2)
4  // инициализация собственных полей
5end;
Параметр конструктора Description, унаследованный от конструктора класса TObject останется видимым и его значение будет в обязательном порядке установлено пользователем при помощи формы задания параметров. Значения параметров Parent и Master будут определены из контекста вызова или запрошены у пользователя. Параметр Name не будет отображен на форме задания параметров и в начале выполнения тела метода его значение будет пустым (nil). В связи с этим в строке (1) тела метода производится установка значения параметра Name при помощи функции UniqueValue. Если этого не сделать, то вызов унаследованного метода при помощи оператора inherited вернет ошибку, связанную с тем, что параметр Name имеет недопустимое значение.

4. Средства моделирования пользовательского интерфейса

4.1. Представления

4.2. Визуальные группы

4.3. Формы, связь представлений в формах

5. Объектно-реляционное отображение

6. Обзор возможностей Платформы

7. Этапы разработки прикладных решений

7.1. Формирование видения модели

7.2. Создание структур хранения и средств обработки данных

7.2.1. Класс TObject, члены класса TОbject

7.2.2. Создание классов

7.2.3. Создание полей

7.2.4. Создание свойств

7.2.5. Создание методов

7.3. Синхронизаци базы данных

7.4. Создание пользователей и ролей

7.5. Средства моделирования пользовательских интерфейсов

7.5.1. Представления

7.5.2. Формы. Включение представлений в формы

7.5.3. Визуальные группы. Включение форм в визуальные группы

7.5.4. Организация доступа пользователей к формам и визуальным группам

7.6. Разработка отчетов

7.6.1. Создание шаблонов PDF-отчетов

7.6.1.1. Описание

Portable Document Format (PDF) — кроссплатформенный формат электронных документов, созданный фирмой Adobe Systems с использованием ряда возможностей языка PostScript. В первую очередь предназначен для представления в электронном виде полиграфической продукции, — значительное количество современного профессионального печатного оборудования может обрабатывать PDF непосредственно. Для просмотра можно использовать официальную бесплатную программу Adobe Reader, а также программы сторонних разработчиков. Традиционным способом создания PDF-документов является виртуальный принтер, то есть документ как таковой готовится в своей специализированной программе — графической программе или текстовом редакторе, САПР и т. д., а затем экспортируется в формат PDF для распространения в электронном виде, передачи в типографию и т. п. Формат PDF позволяет внедрять необходимые шрифты (построчный текст), векторные и растровые изображения, формы и мультимедиа-вставки. Поддерживает RGB, CMYK, Grayscale, Lab, Duotone, Bitmap, несколько типов сжатия растровой информации. Имеет собственные технические форматы для полиграфии: PDF/X-1, PDF/X-3. Включает механизм электронных подписей для защиты и проверки подлинности документов. В этом формате распространяется большое количество сопутствующей документации. Чаще всего PDF-файл является комбинацией текста с растровой и векторной графикой, реже — текста с формами, JavaScript'ом, 3D-графикой и другими типами элементов.

В приложениях Платформы "Мельница данных" для создания PDF-документов используется собственная библиотека PDFCreator.dll. С помощью библиотеки возможно прямое создание документов версии 1.3 . Создание PDF-документов осуществляется путем ввода предопределенных в библиотеке команд, которые в дальнейшем интерпретируются на основе языка описания страниц POSTSCRIPT.

Все размеры графических объектов, размеры страниц, шрифтов и т.п. по умолчанию заданы в миллиметрах.

Для удобства построения шаблона PDF-документа создана функция DrawGrid. При ее включении при отладке при создании шаблона будет отображена визуальная сетка с шагом 5 миллиметров.

7.6.1.2. Методы

7.6.1.2.1. Свойства документа

Для создания и описания свойств PDF-документа в библиотеке PDFCreator.dll используется класс IPDFDocument, обладающий следующими свойствами:

Title (WideString) - заголовок документа. По умолчанию - пустая строка.
Title = "DOC1"
CanEmbedFonts (WordBool) - Признак возможности построения PDF- документа со встроенными шрифтами (Embedded Fonts). В случае включения признака, все объявленные в скрипте шрифты будут включены в сборку документа и будут передаваться целиком вместе с документом. По умолчанию - False.
CanEmbedFonts = True
CanEmbedFonts = False
CanCompress (WordBool) - признак сжатия документа при создании по собственным алгоритмам. По умолчанию - True.
CanCompress = False
CanCompress = True
Author (WideString) - автор документа. По умолчанию - текущий пользователь ОС.

Subject (WideString) - описание документа. По умолчанию - пустая строка.

Keywords (WideString) - ключевые слова для поиска по документу. По умолчанию - пустая строка.

Creator (WideString) - приложение-родитель документа. Указывается в том случае, если документ был сконвертирован из другого формата.

PageCount (Integer) - свойство, содержащее общее количество страниц в документе.

Pages[Index: Integer]: IPDFPage - свойство документа, предназначенное для перебора страниц документа для совершения над ними однотипных действий.

Пример использования:
1for I = 0 to PageCount - 1
2  Pages(I).rectangle 10,10,10,10, false
3next
Save "c:\pdf.pdf"
Результат: На всех страницах документа будут нарисованы квадраты 10х10 мм.

procedure Save(Target: OleVariant) - процедура для сохранения документа PDF на жесткий диск сразу после создания.
Save "c:\pdf.pdf"
- сохранит документ в файл c:\pdf.pdf

7.6.1.2.2. Свойства страницы

Для создания страницы используется функция
function CreatePage(Parent: OleVariant): IPDFPage;
Параметр Parent указывает страницу-родителя для данной страницы. Если страницы- родителя быть не должно - формат вызова функции примет вид:
set page = CreatePage(Null)
Параметры страницы:

Title - заголовок страницы.
page.Title = "Page name"
Width - ширина страницы, миллиметры
page.Width = 80
Height - высота страницы, миллиметры
page.Height = 80
DrawGrid - процедура, выводящая на страницу сетку с шагом 5 миллиметров для удобства отладки вида документа.

Perform - процедура, позволяющая выполнить дополнительные команды PostScript на странице.
page.perform "1 0.7 0 0 k"page.perform "0 0 m"
7.6.1.2.2.1. Объявление цвета

Для объявления цвета объектов на странице используется цветовая модель R:G:B (Red:Green:Blue). Объявление цвета для выполнения последующих операций (цвет шрифта, цвет линии/фигуры) осуществляется процедурой
procedure SetColor(R: Integer; G: Integer; B: Integer);
Где параметры R, G, B - значения базисных цветов для выбранного цвета (от 0 до 255).

Цвет

R

G

B

Белый

255

255

255

+++

Черный

0

0

0

+++

Серый

190

190

190

+++

Синий

0

0

255

+++

Красный

255

0

0

+++

Зеленый

0

255

0

+++

Если предварительно цвет не был объявлен, используется цвет по умолчанию - черный (0,0,0)

7.6.1.2.3. Графика

7.6.1.2.3.1. Линии

Для отрисовки линий используется процедура
procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double);
Здесь:

X1 - координата начала линии по горизонтали в миллиметрах от верхнего левого угла листа.

Y1 - координата начала линии по вертикали в миллиметрах от верхнего левого угла листа.

X2 - координата конца линии по горизонтали в миллиметрах от верхнего левого угла листа.

Y2 - координата Конца линии по вертикали в миллиметрах от верхнего левого угла листа.

Для задания толщины линии используется свойство
property LineWidth: Double
Значение толщины задается в миллиметрах. Значение по умолчанию - минимально возможная единица рисования для устройства. Так для монитора - 1 pixel, для принтера - 1 dot (точка)

Для задания стиля отрисовки начала/окончания линии используется свойство property LineCap: TPDFLineCap
Возможные стили:

Значение свойства:

Отображение:

Описание:

0

Прямой срез точно по точкам начала и окончания линии (по умолчанию)

1

С закруглением

2

Прямой срез с продолжением линии на половину толщины линии

Объявление цвета линии.

Две линии разной толщины, с разными окончаниями и цветами:
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineCap = 1
06
07page.LineWidth = 2
08
09page.Line 10, 10, 30, 30
10
11page.LineWidth = 4
12
13page.SetColor 255, 0, 0
14
15page.LineCap = 2
16
page.Line 10, 30, 30, 10."I
Результат:

При необходимости соединения линий под углом в определенной точке можно задать тип соединения. Для объявления типа соединения используется свойство property LineJoin: TPDFLineJoin;
Типы соединения двух линий:

Значение свойства

Отображение

Описание

0

С острым углом

1

С закруглением

2

С обрезанным углом

Пунктир

Для создания пунктира используется процедура отображения линии с предварительно объявленными дополнительными значениями.

Процедура procedure SetDash(DashArray: OleVariant; Phase: Integer); Здесь DashArray - массив значений в миллиметрах, указывающий последовательность чередования штрихов и пропусков на линии, Phase - смещение в миллиметрах по линии.

Пример 1. Штрих 10 мм, Промежуток 5 мм, Смещения нет
Пример 2. Штрих 10 мм, Промежуток 5 мм, Смещение 5 мм
Пример 3. Различные значения штрихов и промежутков, Смещения нет
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 3
06
07page.SetDash Array(10, 5), 0
08
09page.Line 10, 10, 100, 10
10
11page.SetDash Array(10, 5), 5
12
13page.Line 10, 20, 100, 20
14
15page.SetDash Array(10, 5, 3, 2, 12, 20), 0
16
page.Line 10, 30, 100, 30
Результат:

Ломанная линия - здесь непрерывная линия, состоящая из нескольких прямых. Для отображения ломанной используется процедура procedure Poly(Points: OleVariant; Fill: WordBool), где Points - массив координат точек соединяемых прямыми, а Fill - признак заливки полученной замкнутой фигуры (если замкнута).

Пример Звезда без заливки
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), false
Результат:

Пример Звезда с заливкой
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), true
Результат:

7.6.1.2.3.2. Прямоугольник

Rectangle (Прямоугольник) - для создания используется процедура:
procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double; Fill: WordBool);
Здесь:

X1 - координата верхнего левого угла прямоугольника по горизонтали в миллиметрах от верхнего левого угла листа шаблона.

Y1 - координата верхнего левого угла прямоугольника по вертикали в миллиметрах от верхнего левого угла листа шаблона.

Width - ширина прямоугольника с миллиметрах.

Height - высота прямоугольника с миллиметрах.

Fill - признак заливки прямоугольника (True/False). Если значение True то заливка производится объявленным заранее цветом (см. Объявление цвета). Если False - заливка не производится. Прямоугольник отрисовывается линиями с предварительно заданной толщиной. См. Линии

Пример 1. Создание красного прямоугольника:
1set page = CreatePage(Null)
2
3page.SetColor 255, 0, 0
4
5page.Rectangle 10, 15, 40, 20, True
6
page.DrawGrid
Результат:

Пример 2. Пустой прямоугольник без задания цвета:
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.Rectangle 12, 17, 42, 25, false
6
page.DrawGrid
Результат:

Также существует возможность изменения стиля отображения углов прямоугольника. Для этого нужно использовать свойство property LineJoin: TPDFLineJoin;

Значение свойства

Отображение

Описание

0

С острым углом

1

С закруглением

2

С обрезанным углом

Пример построения прямоугольников с различными типами соединения сторон:
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 4
06
07page.LineJoin = 0
08
09page.Rectangle 10, 10, 20, 10, false
10
11page.LineJoin = 1
12
13page.Rectangle 40, 10, 20, 10, false
14
15page.LineJoin = 2
16
page.Rectangle 70, 10, 20, 10, false
Результат:

7.6.1.2.3.3. Вставка готовых изображений

Для вставки на создаваемую страницу готового изображения используется процедура procedure Image(const FileName: WideString; X: Double; Y: Double; Width: Double; Height: Double)

Параметры:

const FileName - имя файла изображения и путь к нему на жестком диске. Задается в кавычках.

X - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по горизонтали в миллиметрах

Y - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по вертикали в миллиметрах

Width - ширина изображения в миллиметрах

Height - высота изображения в миллиметрах.
1set page = CreatePage(Null)
2page.drawgrid
page.Image "c:\mill.bmp", 10,10, 30, 30
Результат:

Вне зависимости от размера исходного изображения, при вставке изображения на создаваемую страницу оно будет растянуто по размерам, прописанным в процедуре.

7.6.1.2.3.4. Векторная графика

Язык PostScript, с помощью которого создаются векторные изображения для PDF-документа, поддерживает создание типичных примитивных объектов, таких как:

Прямые и ломанные линии

Многоугольники

Окружности и эллипсы

Кривые Безье

Текст

При создании векторного изображения на странице PDF-документа в приложениях Платформы, команды построения примитивных объектов PostScript передаются на исполнение при помощи процедуры Perform. Подробнее об операторах и командах PostScript для создания PDF-документов можно узнать на сайте Adobe

7.6.1.2.4. Шрифты

Шрифты, которые должны использоваться в создаваемом документе, должны быть предварительно объявлены. Для объявления используемых шрифтов используется функция
function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool; Italic: WordBool): IPDFFont; где:

const FontName - имя шрифта, аналогичное имени объявляемого шрифта в операционной системе. В Функции объявляется в кавычках.

Size - размер шрифта в пунктах

Bold - признак начертания шрифта "жирный". Значения - True или False

Italic - признак начертания шрифта "курсив". Значения - True или False

Примеры объявления шрифтов:
1set font = page.createFont("Arial", 20, False, False)
2set labelFont = page.createFont("Times New Roman", 16, False, True)
3set dataFont = page.createFont("Tahoma", 18, True, False)
Для вывода текстовой информации на страницу используются процедуры:

procedure WriteLine(const LineText: WideString; X: Double; Y: Double);
- используется для вывода текстовой строки

function WriteText(const AText: WideString; X: Double; Y: Double; Width: Double; Alignment: TPDFTextAlignment): Double;
- используется для вывода текстового блока.

Параметры для procedure WriteLine :

const LineText - текстовая строка для вывода. Прописывается в кавычках. Будет выведена на страницу одной строкой.

X - координата верхней левой точки текстовой строки по горизонтали в миллиметрах.

Y - координата верхней левой точки текстовой строки по вертикали в миллиметрах.

Примеры вывода текстов на страницу:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Times New Roman", 16, False, True)
05set dataFont = page.createFont("Tahoma", 18, True, False)
06Font.WriteLine "Фамилия", 5, 2
07Font.WriteLine "Имя", 5, 10
08Font.WriteLine "Отчество", 5, 18
09labelFont.WriteLine "Дата рождения", 5, 26
10dataFont.WriteLine "Национальность", 5, 34
Результат:

Параметры для function WriteText :

const AText - текст для вывода на страницу. Прописывается в кавычках. Будет выведена на страницу в виде текстового блока.

X - координата верхней левой точки текстового блока по горизонтали в миллиметрах.

Y - координата верхней левой точки текстового блока по вертикали в миллиметрах.

Width - ширина текстового блока в миллиметрах

Alignment - тип выравнивания текста в текстовом блоке.

Значение параметра

Тип выравнивания

0

По левому краю

1

По правому краю

2

По центру

3

Выравнивание по ширине

Примеры вывода текстовых блоков на страницу:
1set page = CreatePage(Null)
2page.DrawGrid
3set font = page.createFont("Arial", 14, False, False)
4set labelFont = page.createFont("Times New Roman", 12, False, True)
5set dataFont = page.createFont("Tahoma", 11, True, False)
6Q = font.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 5, 100, 0)
7Q = labelFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 35, 100, 1)
8Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 55, 100, 2)
9Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 80, 100, 3)
Результат:

Свойства шрифтов:

property Spacing: Double; - свойство, отвечающее за величину промежутка между буквами в слове. Задается в виде отклонения от промежутка между буквами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Spacing = 0
07labelFont.Spacing = 1
08dataFont.Spacing = 2
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (1 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 15
Результат:

property WordSpacing: Double; - свойство, отвечающее за величину промежутка между соседними словами. Задается в виде отклонения от промежутка между словами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.WordSpacing = 0
07labelFont.WordSpacing = 2
08dataFont.WordSpacing = 5
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (5 мм)", 5, 15
Результат:

property Scaling: Double; - свойство, отвечающее за горизонтальное масштабирование букв используемого шрифта. Устанавливается в процентах. Горизонтальный масштаб по умолчанию - 100%.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Scaling = 50
07labelFont.Scaling = 100
08dataFont.Scaling = 200
09font.WriteLine "Сжатие (50)", 5, 5
10labelFont.WriteLine "По умолчанию (100)", 5, 10
11dataFont.WriteLine "Растягивание (150)", 5, 15
Результат:

property RenderingMode: TPDFFontRenderingMode; - свойство, отвечающее за заливку букв используемого шрифта.
Типы заливки:

Значение параметра:

Отображение:

Описание:

0

Сплошная заливка (по умолчанию). Буква заливается сплошным цветом,
объявленным на данный момент.

1

Только граница. Прорисовывается граница буквы. Тело остается незалитым.

2

Сначала заливка, потом граница. Граница прорисовывается всегда черным цветом.
Заливка осуществляется сплошным цветом, объявленным на данный момент.

3

Невидимый шрифт.

Пример:
01set page = CreatePage(Null)
02set font = page.createFont("Arial", 20, False, False)
03set labelFont = page.createFont("Arial", 20, False, False)
04set dataFont = page.createFont("Arial", 20, False, False)
05font.RenderingMode = 0
06labelFont.RenderingMode = 1
07dataFont.RenderingMode = 2
08page.setColor 255, 0, 0
09Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
10Q = labelFont.WriteText ("Олимпиада", 5, 15, 50, 0)
11Q = dataFont.WriteText ("Олимпиада", 5, 25, 50, 0)
Результат:

property Rise: Double; - свойство, отвечающее за перемещение текста по вертикали.
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Arial", 7, False, False)
05set dataFont = page.createFont("Arial", 7, False, False)
06labelFont.rise = -17
07dataFont.rise = -2
08Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
09Q = labelFont.WriteText ("Олимпиада", 44, 5, 50, 0)
10Q = dataFont.WriteText ("Олимпиада", 44, 5, 50, 0)
Результат:

Для определения размеров текстовой строки используется процедура MeasureLine(const LineText: WideString; out Width: OleVariant; out Height: OleVariant);

Здесь:

LineText - исходный текст для размещения на странице

Width - возвращаемый параметр ширины текстового блока на странице

Height - возвращаемый параметр высоты текстового блока на странице
1S = "шифр"
2font.MeasureLine S, W, H
3Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2)
Здесь для текста "Шифр" замеряется ширина и высота получившегося текстового блока. Затем полученные данные используются для корректного размещения текста на странице.

Для определения высоты текстового блока используется функция MeasureText(const AText: WideString; Width: Double): Double; safecall;

Функция распределит текст по задаваемому значению ширины текстового блока и вернет значение высоты текстового блока в милиметрах.

Здесь:

AText - исходный текст для размещения на странице. Прописывается в кавычках.

Width - задаваемая ширина текстового блока на странице в милиметрах.
1S = "Текст для размещения на странице..."
2Q = font.MeasureText(S, 139)
Здесь для текста "Текст для размещения на странице..." замеряется высота получившегося текстового блока. Затем полученные данные могут использоваться для корректного размещения текста на странице.

7.6.1.3. Порядок создания

Для создания шаблона PDF-документа необходимо в системной форме Платформы выбрать класс, к которому будет строиться документ. В подменю "Подпрограммы" вызвать контекстное меню и выбрать пункт "Создать шаблон отчета PDF". Заполнить необходимые поля и приступить к созданию скрипта в окне "Скрипт шаблона".

Объявляем все переменные.

Создаем страницы

Устанавливаем все свойства документа и страниц

Рисуем простые графические объекты

Объявляем все используемые шрифты

Расставляем постоянный текст на странице

Расставляем переменный текст на странице

Вставляем или создаем сложные графические объекты

Пример документа PDF:
001set LDataSet = createDataSet("TRoundAbiturSt")
002'Объявление переменных
003LDataSet.AddQueryItem 1, "ID", ID
004LDataSet.AddQueryItem 0, "RoundComp$N"
005LDataSet.AddQueryItem 0, "BachRound$N"
006LDataSet.AddQueryItem 0, "LastName"
007LDataSet.AddQueryItem 0, "FirstName"
008LDataSet.AddQueryItem 0, "MiddleName"
009LDataSet.AddQueryItem 0, "BirthDate"
010LDataSet.AddQueryItem 0, "RegNumber"
011LDataSet.AddQueryItem 0, "SecondStageCity$D"
012LDataSet.AddQueryItem 0, "PhoneList"
013
014'Присваивание переменным значений
015OlympName = LDataSet.Field("RoundComp$N")
016OlympClass = LDataSet.Field("BachRound$N")
017LastName = LDataSet.Field("LastName")
018FirstName = LDataSet.Field("FirstName")
019MiddleName = LDataSet.Field("MiddleName")
020if not IsNull(LDataSet.Field("BirthDate")) then
021  BirthDate = LDataSet.Field("BirthDate")
022else
023  BirthDate = "(не задана)"
024end if
025RegNo = LDataSet.Field("RegNumber")
026if not IsNull(LDataSet.Field("SecondStageCity$D")) then
027  OlympCity = LDataSet.Field("SecondStageCity$D")
028else
029  OlympCity = "(не выбран город участия)"
030end if
031if not IsNull(LDataSet.Field("PhoneList")) then
032  Phone = LDataSet.Field("PhoneList")
033else
034  Phone = ""
035end if
036
037'CanCompress = False - признак сжатия файла
038set page = CreatePage(Null) ' создаем страницу
039'Объявляем используемые шрифты
040set font = page.createFont("Arial", 20, False, False)
041set labelFont = page.createFont("Arial", 16, False, False)
042set dataFont = page.createFont("Arial", 18, True, False)
043set bigFont = page.createFont("Arial", 24, False, False)
044
045'page.DrawGrid  - рисуем сетку для удобства отладки
046
047page.LineWidth = 0.5 ' Установка толщины линии
048
049' Рисуем прямоугольники
050page.Rectangle 8, 12, 4, 4, True
051page.Rectangle 190, 12, 4, 4, True
052
053page.Rectangle 8, 273, 4, 4, True
054page.Rectangle 105, 273, 4, 4, True
055page.Rectangle 190, 273, 4, 4, True
056
057'Выводим постоянный и переменный текст
058Q = font.WriteText ("Межрегиональная олимпиада школьников", 12, 20, 178, 2)
059Q = bigFont.WriteText (OlympName, 12, 45, 178, 2)
060Q = bigFont.WriteText (OlympClass, 12, 56, 178, 2)
061
062Q = font.WriteText ("Титульный лист", 12, 72, 178, 2)
063
064labelFont.WriteLine "Фамилия", 25, 115 - 23
065labelFont.WriteLine "Имя", 25, 123 - 23
066labelFont.WriteLine "Отчество", 25, 131 - 23
067labelFont.WriteLine "Дата", 25, 139 - 23
068labelFont.WriteLine "рождения", 25, 145 - 23
069
070labelFont.WriteLine "Регистрационный номер", 25, 169 - 30
071labelFont.WriteLine "Город проведения", 25, 177 - 30
072labelFont.WriteLine "Аудитория", 25, 185 - 30
073
074
075labelFont.WriteLine "Дата", 25, 211
076labelFont.WriteLine "Подпись", 25, 219
077labelFont.WriteLine "Телефон", 25, 227
078
079
080dataFont.WriteLine LastName, 63, 114 - 23
081dataFont.WriteLine FirstName, 63, 122 - 23
082dataFont.WriteLine MiddleName, 63, 130 - 23
083dataFont.WriteLine BirthDate, 63, 141 - 23
084
085dataFont.WriteLine RegNo, 100, 168 - 30
086dataFont.WriteLine OlympCity, 100, 176 - 30
087
088' Рисуем линии
089page.line 100, 192 - 30, 150, 192 - 30
090page.line 58, 218, 108, 218
091page.line 58, 226, 108, 226
092Q = dataFont.WriteText(Phone, 58, 226, 65, 0)
093
094
095
096' Устанавливаем новый цвет
097page.setColor 192, 192, 192
098
099S = "шифр"
100font.MeasureLine S, W, H  ' измеряем текстовый блок
101Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2) ' располагаем текстовый
102блок на странице
103
104' Устанавливаем новый цвет
105page.setColor 255, 0, 0
106' Устанавливаем толщину линий в 1 пиксель
107page.LineWidth = 0
108' Рисуем линии по координатам
109X = 139
110Y = 267
111
112page.line X, Y - 3, X, Y + 3
113page.line X - 3, Y, X + 3, Y
114
115X = X + 40
116page.line X, Y - 3, X, Y + 3
117page.line X - 3, Y, X + 3, Y
118
119
120Y = Y - 23
121page.line X, Y - 3, X, Y + 3
122page.line X - 3, Y, X + 3, Y
123
124X = X - 40
125page.line X, Y - 3, X, Y + 3
page.line X - 3, Y, X + 3, Y
Результат:

7.6.2. Справочник по интерфейсам

7.6.2.1. Перечисление TPDFFontRenderingMode
1type
2  TPDFFontRenderingMode = (frmFillText, frmStrokeText, frmFillThenStrokeText,
3    frmInvisible);
Или
1type
2  TPDFFontRenderingMode = TOleEnum;
3const
4  frmFillText = $00000000;
5  frmStrokeText = $00000001;
6  frmFillThenStrokeText = $00000002;
7  frmInvisible = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

frmFillText

0

frmStrokeText

1

frmFillThenStrokeText

2

frmInvisible

3

7.6.2.2. Перечисление TPDFLineCap
1type
2  TPDFLineCap = (lcBuss, lcRound, lcProtecting);
Или
1type
2  TPDFLineCap = TOleEnum;
3const
4  lcBuss = $00000000;
5  lcRound = $00000001;
6  lcProtecting = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

lcBuss

0

lcRound

1

lcProtecting

2

7.6.2.3. Перечисление TPDFLineJoin
1type
2  TPDFLineJoin = (ljMiter, ljRound, ljBevel);
Или
1type
2  TPDFLineJoin = TOleEnum;
3const
4  ljMiter = $00000000;
5  ljRound = $00000001;
6  ljBevel = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

ljMiter

0

ljRound

1

ljBevel

2

7.6.2.4. Перечисление TPDFTextAlignment
1type
2  TPDFTextAlignment = (ptaLeft, ptaRight, ptaCenter, ptaJustified);
Или
1type
2  TPDFTextAlignment = TOleEnum;
3const
4  ptaLeft = $00000000;
5  ptaRight = $00000001;
6  ptaCenter = $00000002;
7  ptaJustified = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

ptaLeft

0

ptaRight

1

ptaCenter

2

ptaJustified

3

7.6.2.5. Интерфейс IPDFDocument
01type
02  IPDFDocument = interface(IDispatch)
03    ['{E57FFE9D-6B85-45E6-A5D0-9DD17950A666}']
04    procedure Save(Target: OleVariant); safecall;
05    function CreatePage(Parent: OleVariant): IPDFPage; safecall;
06    function Get_Title: WideString; safecall;
07    procedure Set_Title(Value: WideString); safecall;
08    function Get_CanEmbedFonts: WordBool; safecall;
09    procedure Set_CanEmbedFonts(Value: WordBool); safecall;
10    function Get_CanCompress: WordBool; safecall;
11    procedure Set_CanCompress(Value: WordBool); safecall;
12    function Get_Author: WideString; safecall;
13    procedure Set_Author(Value: WideString); safecall;
14    function Get_Subject: WideString; safecall;
15    procedure Set_Subject(Value: WideString); safecall;
16    function Get_Keywords: WideString; safecall;
17    procedure Set_Keywords(Value: WideString); safecall;
18    function Get_Creator: WideString; safecall;
19    procedure Set_Creator(Value: WideString); safecall;
20    function Get_Pages(Index: Integer): IPDFPage; safecall;
21    function Get_PageCount: Integer; safecall;
22    procedure Close; safecall;
23    procedure Serialize(const Stream: IUnknown); safecall;
24    function Get_MinCompressSize: Integer; safecall;
25    procedure Set_MinCompressSize(Value: Integer); safecall;
26    function Get_MaxCompressSize: Integer; safecall;
27    procedure Set_MaxCompressSize(Value: Integer); safecall;
28    function CreatePageFromImage(Image: OleVariant; PageWidth: Double;
29      PageHeight: Double; Margin: Double): WordBool; safecall;
30    procedure SaveToXML(Target: OleVariant); safecall;
31    property Title: WideString read Get_Title write Set_Title;
32    property CanEmbedFonts: WordBool read Get_CanEmbedFonts write Set_CanEmbedFonts;
33    property CanCompress: WordBool read Get_CanCompress write Set_CanCompress;
34    property Author: WideString read Get_Author write Set_Author;
35    property Subject: WideString read Get_Subject write Set_Subject;
36    property Keywords: WideString read Get_Keywords write Set_Keywords;
37    property Creator: WideString read Get_Creator write Set_Creator;
38    property Pages[Index: Integer]: IPDFPage read Get_Pages;
39    property PageCount: Integer read Get_PageCount;
40    property MinCompressSize: Integer read Get_MinCompressSize
41      write Set_MinCompressSize;
42    property MaxCompressSize: Integer read Get_MaxCompressSize
43      write Set_MaxCompressSize;
44  end;
7.6.2.5.1. Свойства

Свойства интерфейса IPDFDocument:

Имя

Тип

Доступ

Назначение

Author

WideString

Чтение/Запись

CanCompress

WordBool

Чтение/Запись

CanEmbedFonts

WordBool

Чтение/Запись

Creator

WideString

Чтение/Запись

Keywords

WideString

Чтение/Запись

MaxCompressSize

Integer

Чтение/Запись

MinCompressSize

Integer

Чтение/Запись

PageCount

Integer

Только для чтения

Pages[Index: Integer]

IPDFPage

Только для чтения

Subject

WideString

Чтение/Запись

Title

WideString

Чтение/Запись

7.6.2.5.2. Метод Close

Метод интерфейса IPDFDocument.
procedure IPDFDocument.Close;
Метод не имеет параметров.

7.6.2.5.3. Метод CreatePage

Метод интерфейса IPDFDocument.
function IPDFDocument.CreatePage(Parent: OleVariant): IPDFPage;
Параметры:

Имя

Тип

Обязательно

Значение

Parent

OleVariant

Да

Замечания:

Возвращает значение типа IPDFPage.

7.6.2.5.4. Метод CreatePageFromImage

Метод интерфейса IPDFDocument.
1function IPDFDocument.CreatePageFromImage(Image: OleVariant; PageWidth: Double;
2  PageHeight: Double; Margin: Double): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

Image

OleVariant

Да

PageWidth

Double

Да

PageHeight

Double

Да

Margin

Double

Да

Замечания:

Возвращает значение типа WordBool.

7.6.2.5.5. Метод Save

Метод интерфейса IPDFDocument.
procedure IPDFDocument.Save(Target: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Target

OleVariant

Да

7.6.2.5.6. Метод SaveToXML

Метод интерфейса IPDFDocument.
procedure IPDFDocument.SaveToXML(Target: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Target

OleVariant

Да

7.6.2.5.7. Метод Serialize

Метод интерфейса IPDFDocument.
procedure IPDFDocument.Serialize(const Stream: IUnknown);
Параметры:

Имя

Тип

Обязательно

Значение

Stream

IUnknown

Да

7.6.2.6. Интерфейс IPDFFont
01type
02  IPDFFont = interface(IDispatch)
03    ['{43FE399A-A724-4076-BAFA-098639628385}']
04    function Get_Spacing: Double; safecall;
05    procedure Set_Spacing(Value: Double); safecall;
06    function Get_WordSpacing: Double; safecall;
07    procedure Set_WordSpacing(Value: Double); safecall;
08    function Get_Scaling: Double; safecall;
09    procedure Set_Scaling(Value: Double); safecall;
10    function Get_RenderingMode: TPDFFontRenderingMode; safecall;
11    procedure Set_RenderingMode(Value: TPDFFontRenderingMode); safecall;
12    function Get_Rise: Double; safecall;
13    procedure Set_Rise(Value: Double); safecall;
14    procedure WriteLine(const LineText: WideString; X: Double; Y: Double); safecall;
15    procedure MeasureLine(const LineText: WideString; out Width: OleVariant;
16      out Height: OleVariant); safecall;
17    function WriteText(const AText: WideString; X: Double; Y: Double;
18      Width: Double; Alignment: TPDFTextAlignment): Double; safecall;
19    function MeasureText(const AText: WideString; Width: Double): Double; safecall;
20    function Get_Angle: Double; safecall;
21    procedure Set_Angle(Value: Double); safecall;
22    function Get_LineSpacing: Double; safecall;
23    procedure Set_LineSpacing(Value: Double); safecall;
24    property Spacing: Double read Get_Spacing write Set_Spacing;
25    property WordSpacing: Double read Get_WordSpacing write Set_WordSpacing;
26    property Scaling: Double read Get_Scaling write Set_Scaling;
27    property RenderingMode: TPDFFontRenderingMode read Get_RenderingMode
28      write Set_RenderingMode;
29    property Rise: Double read Get_Rise write Set_Rise;
30    property Angle: Double read Get_Angle write Set_Angle;
31    property LineSpacing: Double read Get_LineSpacing write Set_LineSpacing;
32  end;
7.6.2.6.1. Свойства

Свойства интерфейса IPDFFont:

Имя

Тип

Доступ

Назначение

Angle

Double

Чтение/Запись

LineSpacing

Double

Чтение/Запись

RenderingMode

TPDFFontRenderingMode

Чтение/Запись

Rise

Double

Чтение/Запись

Scaling

Double

Чтение/Запись

Spacing

Double

Чтение/Запись

WordSpacing

Double

Чтение/Запись

7.6.2.6.2. Метод MeasureLine

Метод интерфейса IPDFFont.
1procedure IPDFFont.MeasureLine(const LineText: WideString;
2  out Width: OleVariant; out Height: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

LineText

WideString

Да

Width

OleVariant

Да

Height

OleVariant

Да

7.6.2.6.3. Метод MeasureText

Метод интерфейса IPDFFont.
function IPDFFont.MeasureText(const AText: WideString; Width: Double): Double;
Параметры:

Имя

Тип

Обязательно

Значение

AText

WideString

Да

Width

Double

Да

Замечания:

Возвращает значение типа Double.

7.6.2.6.4. Метод WriteLine

Метод интерфейса IPDFFont.
procedure IPDFFont.WriteLine(const LineText: WideString; X: Double; Y: Double);
Параметры:

Имя

Тип

Обязательно

Значение

LineText

WideString

Да

X

Double

Да

Y

Double

Да

7.6.2.6.5. Метод WriteText

Метод интерфейса IPDFFont.
1function IPDFFont.WriteText(const AText: WideString; X: Double; Y: Double;
2  Width: Double; Alignment: TPDFTextAlignment): Double;
Параметры:

Имя

Тип

Обязательно

Значение

AText

WideString

Да

X

Double

Да

Y

Double

Да

Width

Double

Да

Alignment

TPDFTextAlignment

Да

Замечания:

Возвращает значение типа Double.

7.6.2.7. Интерфейс IPDFPage
01type
02  IPDFPage = interface(IDispatch)
03    ['{749FB131-80FE-46E9-8330-22C1DC346FE7}']
04    function Get_Parent: IPDFPage; safecall;
05    function Get_Title: WideString; safecall;
06    procedure Set_Title(Value: WideString); safecall;
07    function Get_Width: Double; safecall;
08    procedure Set_Width(Value: Double); safecall;
09    function Get_Height: Double; safecall;
10    procedure Set_Height(Value: Double); safecall;
11    function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool;
12      Italic: WordBool): IPDFFont; safecall;
13    procedure Perform(const Command: WideString); safecall;
14    function Get_LineWidth: Double; safecall;
15    procedure Set_LineWidth(Value: Double); safecall;
16    procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double); safecall;
17    procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double;
18      Fill: WordBool); safecall;
19    function Get_LineCap: TPDFLineCap; safecall;
20    procedure Set_LineCap(Value: TPDFLineCap); safecall;
21    function Get_LineJoin: TPDFLineJoin; safecall;
22    procedure Set_LineJoin(Value: TPDFLineJoin); safecall;
23    procedure SetDash(DashArray: OleVariant; Phase: Integer); safecall;
24    procedure SetColor(R: Integer; G: Integer; B: Integer); safecall;
25    procedure PerformColor(const Command: WideString); safecall;
26    procedure Poly(Points: OleVariant; Fill: WordBool); safecall;
27    procedure Image(Image: OleVariant; X: Double; Y: Double; Width: Double;
28      Height: Double; Transparent: WordBool); safecall;
29    procedure DrawGrid; safecall;
30    procedure Arc(X: Double; Y: Double; Radius: Double; StartAngle: Double;
31      EndAngle: Double; FillSegment: WordBool; FillSector: WordBool); safecall;
32    procedure Curve(Points: OleVariant; Fill: WordBool); safecall;
33    procedure HyperLink(const URI: WideString; X: Double; Y: Double; Width: Double;
34      Height: Double); safecall;
35    procedure Pattern(X1: Double; Y1: Double; Width: Double; Height: Double;
36      PatternPointSize: Double; Percentage: Integer); safecall;
37    procedure Bezier(Points: OleVariant; Fill: WordBool); safecall;
38    procedure XObject(Data: OleVariant); safecall;
39    procedure SetColorCMYK(C: Double; M: Double; Y: Double; K: Double); safecall;
40    procedure LocalLink(const Page: IDispatch; DestinationX: Double;
41      DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
42      X: Double; Y: Double; Width: Double; Height: Double); safecall;
43    property Parent: IPDFPage read Get_Parent;
44    property Title: WideString read Get_Title write Set_Title;
45    property Width: Double read Get_Width write Set_Width;
46    property Height: Double read Get_Height write Set_Height;
47    property LineWidth: Double read Get_LineWidth write Set_LineWidth;
48    property LineCap: TPDFLineCap read Get_LineCap write Set_LineCap;
49    property LineJoin: TPDFLineJoin read Get_LineJoin write Set_LineJoin;
50  end;
7.6.2.7.1. Свойства

Свойства интерфейса IPDFPage:

Имя

Тип

Доступ

Назначение

Height

Double

Чтение/Запись

LineCap

TPDFLineCap

Чтение/Запись

LineJoin

TPDFLineJoin

Чтение/Запись

LineWidth

Double

Чтение/Запись

Parent

IPDFPage

Только для чтения

Title

WideString

Чтение/Запись

Width

Double

Чтение/Запись

7.6.2.7.2. Метод Arc

Метод интерфейса IPDFPage.
1procedure IPDFPage.Arc(X: Double; Y: Double; Radius: Double;
2  StartAngle: Double; EndAngle: Double; FillSegment: WordBool;
3  FillSector: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

X

Double

Да

Y

Double

Да

Radius

Double

Да

StartAngle

Double

Да

EndAngle

Double

Да

FillSegment

WordBool

Да

FillSector

WordBool

Да

7.6.2.7.3. Метод Bezier

Метод интерфейса IPDFPage.
procedure IPDFPage.Bezier(Points: OleVariant; Fill: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Points

OleVariant

Да

Fill

WordBool

Да

7.6.2.7.4. Метод CreateFont

Метод интерфейса IPDFPage.
1function IPDFPage.CreateFont(const FontName: WideString; Size: Double;
2  Bold: WordBool; Italic: WordBool): IPDFFont;
Параметры:

Имя

Тип

Обязательно

Значение

FontName

WideString

Да

Size

Double

Да

Bold

WordBool

Да

Italic

WordBool

Да

Замечания:

Возвращает значение типа IPDFFont.

7.6.2.7.5. Метод Curve

Метод интерфейса IPDFPage.
procedure IPDFPage.Curve(Points: OleVariant; Fill: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Points

OleVariant

Да

Fill

WordBool

Да

7.6.2.7.6. Метод DrawGrid

Метод интерфейса IPDFPage.
procedure IPDFPage.DrawGrid;
Метод не имеет параметров.

7.6.2.7.7. Метод HyperLink

Метод интерфейса IPDFPage.
1procedure IPDFPage.HyperLink(const URI: WideString; X: Double; Y: Double;
2  Width: Double; Height: Double);
Параметры:

Имя

Тип

Обязательно

Значение

URI

WideString

Да

X

Double

Да

Y

Double

Да

Width

Double

Да

Height

Double

Да

7.6.2.7.8. Метод Image

Метод интерфейса IPDFPage.
1procedure IPDFPage.Image(Image: OleVariant; X: Double; Y: Double;
2  Width: Double; Height: Double; Transparent: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Image

OleVariant

Да

X

Double

Да

Y

Double

Да

Width

Double

Да

Height

Double

Да

Transparent

WordBool

Нет

7.6.2.7.9. Метод Line

Метод интерфейса IPDFPage.
procedure IPDFPage.Line(X1: Double; Y1: Double; X2: Double; Y2: Double);
Параметры:

Имя

Тип

Обязательно

Значение

X1

Double

Да

Y1

Double

Да

X2

Double

Да

Y2

Double

Да

7.6.2.7.10. Метод LocalLink

Метод интерфейса IPDFPage.
1procedure IPDFPage.LocalLink(const Page: IDispatch; DestinationX: Double;
2  DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
3  X: Double; Y: Double; Width: Double; Height: Double);
Параметры:

Имя

Тип

Обязательно

Значение

Page

IDispatch

Да

DestinationX

Double

Да

DestinationY

Double

Да

DestinationWidth

Double

Да

DestinationHeight

Double

Да

X

Double

Да

Y

Double

Да

Width

Double

Да

Height

Double

Да

7.6.2.7.11. Метод Pattern

Метод интерфейса IPDFPage.
1procedure IPDFPage.Pattern(X1: Double; Y1: Double; Width: Double;
2  Height: Double; PatternPointSize: Double; Percentage: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

X1

Double

Да

Y1

Double

Да

Width

Double

Да

Height

Double

Да

PatternPointSize

Double

Да

Percentage

Integer

Да

7.6.2.7.12. Метод Perform

Метод интерфейса IPDFPage.
procedure IPDFPage.Perform(const Command: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Command

WideString

Да

7.6.2.7.13. Метод PerformColor

Метод интерфейса IPDFPage.
procedure IPDFPage.PerformColor(const Command: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Command

WideString

Да

7.6.2.7.14. Метод Poly

Метод интерфейса IPDFPage.
procedure IPDFPage.Poly(Points: OleVariant; Fill: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Points

OleVariant

Да

Fill

WordBool

Да

7.6.2.7.15. Метод Rectangle

Метод интерфейса IPDFPage.
1procedure IPDFPage.Rectangle(X1: Double; Y1: Double; Width: Double;
2  Height: Double; Fill: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

X1

Double

Да

Y1

Double

Да

Width

Double

Да

Height

Double

Да

Fill

WordBool

Да

7.6.2.7.16. Метод SetColor

Метод интерфейса IPDFPage.
procedure IPDFPage.SetColor(R: Integer; G: Integer; B: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

R

Integer

Да

G

Integer

Да

B

Integer

Да

7.6.2.7.17. Метод SetColorCMYK

Метод интерфейса IPDFPage.
procedure IPDFPage.SetColorCMYK(C: Double; M: Double; Y: Double; K: Double);
Параметры:

Имя

Тип

Обязательно

Значение

C

Double

Да

M

Double

Да

Y

Double

Да

K

Double

Да

7.6.2.7.18. Метод SetDash

Метод интерфейса IPDFPage.
procedure IPDFPage.SetDash(DashArray: OleVariant; Phase: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

DashArray

OleVariant

Да

Phase

Integer

Да

7.6.2.7.19. Метод XObject

Метод интерфейса IPDFPage.
procedure IPDFPage.XObject(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

7.7. Поставка решений

8. Интеграция

Интеграция - комплекс работ по настройке механизмов взаимодействия между различными учетными системами, которые функционируют независимо друг от друга в одной организационной структуре ("лоскутная" автоматизация).

Концептуально реализация интеграции может быть осуществлена двумя способами (рассмотрены более подробно далее):

Интеграция на базе интеграционной платформы (некоего ядра, которое осуществляет взаимодействие между учетными системами)

Интеграция без внедрения интеграционной платформы, с использованием связей между учетными системами только там где это необходимо.

Практически, реализация интеграции может быть осуществлена слежующими способами:

8.1. Интеграция данных

В свою очередь интеграцию данных можно разделить на два типа:

8.1.1. Репликативная интеграция

Репликативная интеграция - передающая сторона формирует реплику, передает ее принимающей стороне, которая в свою очередь загружает в себя реплику. В этом случае стандартами формата реплики являются двоичный формат и XML-схема. Платформа Мельница Данных имеет готовые механизмы для реализации обоих форматов.

Варианты реализации репликационной интеграции:

1. Данные должны быть переданы из сторонней учетной системы и загружены в Платформу Мельница данных:

В Платформе уже реализованы механизмы загрузки реплик в двоичном (бинарном) формате, а также в формате XML-схемы. В случае, если разработчики или сопровождающие сотрудники сторонней учетной системы имеют возможность выгрузки реплики в данных форматах, взаимодействие производится стандартными средствами Платформы. В противном случае создается конвертер для перевода данных реплики в один из стандартных форматов для дальнейшей загрузки реплики в Мельницу Данных.

2. Данные должны быть переданы из Платформы Мельница Данных и загружены в стороннюю учетную систему:

При необходимости выгрузки данных из Платформы Мельница Данных используются стандартные механизмы выгрузки реплики в двоичном (бинарном) формате или в формате XML-схемы. В случае, если эти варианты не являются приемлемыми для принимающей стороны (сторонней учетной системы), можно выполнить выгрузку данных через скриптлет, Microsoft Excel-файл, отчет или любыми механизмами просто выгрузить требуемый файл для дальнейшей обработки (загрузки) принимающей стороной. В этом случае необходимо четкое согласование протоколов и форматов обмена данными.

3. Данные должны быть переданы из одной сторонней учетной системы в другую. При этом Платформа Мельница Данных выступает в качестве интеграционной платформы:

Если Платформа выступает в качестве интеграционного ядра, в ней необходимо объявить структуры для хранения тех элементов данных, которые в Платформе по умолчанию не хранятся, но загружаются в нее из сторонних учетных систем и в дальнейшем подлежат какому-либо анализу. При этом нет необходимости обеспечивать функционирование бизнес-процессов над этими данными в рамках Платформы, данные просто хранятся.

Подобная интеграция осуществляется простыми готовыми средствами платформы в самые сжатые сроки.

8.1.2. On-Line доступ

Второй путь интеграции данных - Интеграция с использованием доступа к данным в режиме On-Line.

1. В том случае когда Платформа является серверной стороной, то есть стороной-поставщиком данных для других систем, возможны следующие варианты предоставления данных:

- СУБД, то есть база данных, которая хранит все данные Платформы. На данный момент поддерживаются Oracle, Firebird, MS SQL. Возможна реализация поддержки и других систем управления базами данных. Для указанных баз данных доступны стандартные протоколы доступа, с помощью которых осуществляются запросы к данным Платформы непосредственно. Запросы формируются при помощи стандартизированного языка запросов Structured Query Language (SQL).

- RESTful-сервис используется для реализации более сложной механики предоставления доступа к данным и входит в состав поставки сервера приложений Платформы. С его помощью, в частности, осуществляется удаленный доступ и доступ к данным через SOAP (Simple Object Access Protocol — простой протокол доступа к объектам) с автоматическим формированием по данным Платформы WSDL-документа, описывающего сервисы. Таким образом реализуется продвинутый функционал по отбору объекта по критериям, а также в части доступа ко всем данным Платформы по протоколу SOAP/

В случае если требуются какие-либо специфические протоколы для обмена данными, они реализовываются на уровне обработчика сервера-приложения. То есть осуществляется "надстройка" сервера приложений Платформы для работы с данными в том виде, в котором это необходимо и по тому протоколу, который требуется в каждом конкретном случае. Таким образом, Сервер приложений Платформы востребован в большинстве случаев организации взаимодействия между системами.

Практический пример реализации:

Компания "Мельница технологий" в одном из московских ВУЗов осуществяла интеграцию с тестирующей системой по проведению олимпиад. С использованием протокола SOAP в тестирующую систему из Платформы предоставлялась информация о реквизитах олимпиад, которые были выбраны каждым школьником-участником. Был реализован обработчик-"переходник", через который передавалсь информация.

Для системы LMS (Learning Management System) компании Asteros данные также предоставляются по протоколу SOAP.

2. В случае когда Платформе необходим доступ к данным сторонних систем, используется готовый RESTful-"обработчик". Частными случаями данной ситуции являются взаимодействия Платформы с различными собственными web-приложениями, а также с "Обозревателем данных", работающим через удаленный доступ.

Для получения данных в режиме On-Line от сторонних систем используются те же стандартные протоколы. При необходимости создаются "обработчики", которые отображают для конечного пользователя в визуальных формах Платформы данные, полученные из сторонних систем.

3. При использовании Платформы в качестве платформы интеграции различных сторонних систем, данные предварительно загруженные по описанным выше протоколам могут передаваться средствами Платформы. Однако, может быть реализован и механизм прозрачной передачи данных между сторонними системами.

8.2. Интеграция функций

Данный тип развития интеграции в свою очередь можно разделить на 2 пути:

8.2.1. Взаимные вызовы

В данном случае подразумевается, что какая-либо учетная система открывает возможность вызова своих встроенных функций из сторонних систем.

Доступ к функциям возможен с помощью выполнения хранимых процедур (каждое бизнес-действие, которое производит пользователь, обязательно оформляется в виде хранимой процедуры на уровне СУБД Платформы). Процедуру можно вызывать, получив доступ к СУБД. Аналогично тому, как создаются select-запросы, запросы к данным, можно делать запросы, вызывающие бизнес-функции. Все методы, отчеты, и все, что доступно пользователю, может быть вызвано и через RESTful-сервис. При этом методы будут выполняться, отчеты будут формироваться в виде Excel, Word, PDF, HTML, в соответствии с запросом вызывающей стороны. Данный функционал обеспечивается готовым "обработчиком", входящим в состав поставки Платформы.

С помощью протокола SOAP можно вызывать любой метод любого объекта, получать результаты его выполнения без ограничений.

В случае когда необходимо в Платформе использовать чужие функции, набор действий по вызову такой функции оформляется в виде скриптлета.

Пример реализации:

В ВУЗе при формировании приказа о зачислении студента в Платформе, также автоматически создается объект "Приказ" в системе документооборота ВУЗа. В дальнейшем, передвижение приказа по маршруту согласования в решении на Платформе аналогично отображается в системе документооборота.

Если для сторонней системы существуют какие-либо стандартные протоколы, по которым можно вызывать функцию, то средствами Платформы не составляет труда вызов данной функции.

8.2.2. Встраивание

Данный путь интеграции функций представляет собой ситуацию, когда сторонняя система непосредственно "встраивается" в решения на Платформе и код сторонней системы исполняется с использованием данных Платформы.

Существуют разные способы реализации данного пути:

- В open-source системах, как правило, слой доступа к данным вынесен в некий отдельный модуль. Характерный пример - это LMS eFront. Это Open-Source разработка, содержащая в себе большой объем php-кода, с развитым web-интерфейсом, и, в том числе, содержащая модуль доступа к данным. В процессе работы создается база MySQL база достаточно примитивной структуры. В этом случае можно изменить модуль доступа, так, чтобы вместо запросов к MySQL-базе механика делала бы запросы к базе данных Платформы. Тогда исполнение php-кода, его интерпретация происходит в рамках сервера приложений Платформы.

Пример реализации:

Так как в базе данных Платформы уже хранятся данные о студентах, преподавателях, курсах и т.д., то при взаимодействии с системой обучения LMS, естественным, удобным и надежным решением является хранение все этих данных в одной базе данных

- В тех случаях, когда решения Платформы сами являются частью какой-либо более общей системы, и должны предоставлять свои функции, то это решается на уровне СУБД. То есть, сгенерированный Платформой прикладной код (код на соответствующем диалекте SQL) может быть интегрирован в код более масштабного хранилища, функционировать там, исполняться там, если в этом есть необходимость.

Прикладные системы на базе СУБД Teradata позволяют использовать PL/SQL-код для каких-либо наборов данных, притом, что сама база гораздо имеет продвинутые возможности автоматического контроля версий, хроникальности, аналитики.

9. Положения и определения

9.1. Работа с типами данных

9.1.1. Домены

9.2. Язык PascalScript

На языке PascalScript на платформе "Мельница данных" описываются тела методов и выражения. Выражения используются в условиях отбора объектов определенного класса при их отображении в представлениях, а также как встраиваемые выражения, которые могут служить членами класса для чтения свойств.

Здесь и далее зарезервированные слова выделены жирным шрифтом.

9.2.1. Структура программного блока тела метода
1  [Описание переменных]
2  begin
3    //Операторы
  end;
Комментарии расположены между символами { и } либо от символов // до конца строки.

9.2.2. Описание переменных
1var
2    Имя переменной[, Имя переменной…]: Тип;
3    Имя переменной[, Имя переменной…]: Тип;
4    ...
Имя переменной должно быть идентификатором (последовательность символов a-z, A-Z, 0-9, _). "Тип" может быть одним из следующих:

integer - определяет переменные целочисленного типа;

string[целое_число] - определяет переменные строкового типа с заданной максимальной длиной; максимальная длина задается в квадратных скобках и обязательна для задания;

float - определяет переменные вещественного типа;

date - определяет переменные типа "дата";

time - определяет переменные типа "время";

datetime - определяет переменные типа "дата со временем";

boolean - определяет переменные логического типа;

blob - определяет переменные типа больших двоичных объектов;

Имя класса - определяет переменные-ссылки на экземпляры соответствующих классов;
1  var
2   I: integer;
3   LSomeObject: TObject;
4   LStart, LStop: datetime;
   LNewName: string[64];
9.2.3. Операторы PascalScript

Операторы разделяются точкой с запятой (;). Операторы могут быть одним из следующих:

9.2.3.1. Составной оператор
1begin
2  //Другие операторы
end
Операторы, размещенные внутри составного оператора, разделяются точкой с запятой. Никаких ограничений на состав операторов и количество уровней вложенности не накладывается.
1begin
2  Result := LCurrentValue;
3  Exit;
4end;
9.2.3.2. Оператор присваивания
Выражение1 := Выражение2
Присваивает значение выражения Выражение2 выражению Выражение1. Типы Выражения1 и Выражения2 должны быть совместимы (совпадать по классу домена либо оба быть числовыми). Для этого на Выражение1 (стоящее слева от знака равенства, lvalue) накладывается ряд ограничений. Это выражение должно быть:

Полем или свойством экземпляра класса

Локальной переменной

Параметром

Зарезервированной переменной Result
LObject.Name := 'Новое имя';
Result := 25;
LStartTime := StrToDateTime('01.01.2006 00:00:30');
01var
02  LObject: TObject;
03  LClass: TClass;
04  I: Integer;
05  F: Float;
06begin
07  I := F;  //неверно
08  F := I;  //верно
09  LObject := LClass; //верно
10  LClass := LObject; //неверно. Должно быть LClass := (LObject as TClass);
11end;
9.2.3.3. Оператор вызова
ИмяПроцедуры [(Параметр1, Параметр2 ...)]
"ИмяПроцедуры" должно быть:

Именем метода класса и вызываться с указанием класса либо экземпляра;

Именем метода экземпляра и вызываться с указанием экземпляра;

Именем метода своего класса либо предка и вызываться без указания спецификаторов.

Порядок и количество параметров в операторе вызова должны строго совпадать с описанием метода.
1  //метод класса, указан класс
2  LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3
4  //метод экземпляра, указан экземпляр. Метод не имеет параметров.
5  LList.Destroy;
6
7  //свой либо унаследованный метод
8  BuildDefaultActions(Name, True);
9.2.3.4. Оператор ветвления
1if Выражение then
2  //Оператор1
3[else
4  //Оператор2]
Выражение должно быть логического типа. В случае если значение Выражения истинно, выполняется Оператор1. Часть else является необязательной и относится к последнему оператору if, не имеющему таковой. В случае ее наличия Оператор2 выполняется, если значение Выражения ложно.
1if LIndex > 25 then
2  raise 'Индекс слишком большой.';
1if LMonth = 'январь' then
2  January
3else if LMonth = 'февраль' then
4  February
5else
6  OtherMonth;  //обратите внимание на точки с запятой.
9.2.3.5. Оператор выбора
1case Выражение of
2  Значение1: //Оператор1
3  Значение2: //Оператор2
4  ...
5[else
6  //Оператор ]
end
Заменяет каскад операторов if. Значение Выражения должно быть числового типа. Часть else выполняется в случае, если Выражение не равно ни одному из перечисленных вариантов. Эта часть не является обязательной.
1сase LIndex of
2  0: ZeroIndex;
3  1,2,3: SmallIndex;
4  4,5,6,7,8,9,10: BigIndex;
5else
6  raise 'Слишком большой или отрицательный индекс.';
7end;
9.2.3.6. Цикл с предусловием
1while Выражение do
2  //Оператор
Оператор выполняется до тех пор, пока значение Выражения истинно. Выражение должно быть логического типа. Если при входе в цикл Выражение не истинно, то тело цикла не будет выполнено ни одного раза.
01while LList.Count > 0 do
02  LList.GetItem(0).Destroy;
03
04while True do
05begin
06  LValue := LValue.NextValue;
07  if LValue.Value > 10 then
08  begin
09    Result := LValue.Value;
10    exit;
11  end;
12end;
9.2.3.7. Цикл с постусловием
1repeat
2  //Операторы
3until Выражение
Операторы выполняются до тех пор, пока значение Выражения ложно. Выражение должно быть логического типа. Обратите внимание, что внутри себя оператор может содержать несколько операторов, разделенных точкой с запятой. Тело цикла обязательно будет выполнено хотя бы один раз.
1repeat
2  Result := Result + 1;
3  LObject := LObject.Parent;
4until LObject = nil;
9.2.3.8. Цикл с параметром
1for Параметр := Выражение1 (to|downto) Выражение2 do
2  //Оператор
Параметр цикла обязан быть простой локальной переменной. Функционально цикл с параметром эквивалентен циклам:

Для формы to
1Параметр := Выражение1;
2while Параметр <= Выражение2 dobegin
3  Оператор;
4  Параметр :=  Параметр + 1;
end;
Для формы downto
1Параметр := Выражение1;
2while Параметр >= Выражение2 dobegin
3  Оператор;
4  Параметр :=  Параметр - 1;
end;
Если Выражение1 равно Выражению2, тело цикла будет выполнено один раз.
1for I := LList.Length - 1 downto 0 do
2// если LList.Length = 0, тело цикла ни разу не будет выполнено.
3begin
4  LClass := LList.GetItem(I);
5  LMethod := any(TMethod with (Name = LName) and (Master = LClass));
6  LParamList.Add(any(TMethod with (Name = LName) and (Master = LClass)));
7end;
9.2.3.9. Цикл по экземплярам
1for each Параметр of ИмяКласса [with Выражение]
2  [by [-] Выражение [, [-] Выражение]] do
3    //Оператор
Цикл осуществляется по выборке среди экземпляров класса ИмяКласса, для которых истинно Выражение. Если Выражение не задано, то по всем экземплярам. Ссылка на текущий в рамках цикла экземпляр присваивается в локальную переменную Параметр. Выражение должно определяться относительно переменной Параметр. Выраженния, следующие за ключевым словом by, определяют порядок обхода экземпляров. Знак "-" перед выражением (любого типа) определяет обратный порядок обхода.
1for each LOption of TOption with LOption.Domain.Required do
2    // для каждой настройки, домен которой обязателен
3  LOption.SetDefaultValue;
9.2.3.10. Оператор прекращения цикла
break
Происходит немедленный выход из цикла. Выполняется финализация операторов защиты завершения, которыми защищено тело цикла. Допустим только в теле цикла с предусловием, цикла с постусловием, цикла с параметром или цикла по экземплярам.

9.2.3.11. Оператор выхода из подпрограммы
exit
Происходит немедленный выход из программного блока. Выполняется финализация операторов защиты завершения.

9.2.3.12. Оператор защиты завершения
1try
2  //Операторы1
3finally
4  //Операторы2
end
Выполняются операторы Операторы1, разделенные точкой с запятой. В случае возникновения исключительной ситуации управление сразу передается на Операторы2, и после их выполнения исключение остается активным. Если исключения не произошло, выполняются Операторы2. Если среди Операторов1 встречается оператор exit, то Операторы2 все равно выполняются.
1//создание временного объекта-списка
2LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3try
4  LList.Add(LValue);
5  Exit;
6finally
7  //гарантированное уничтожение созданного объекта независимо от исключений.
8  LList.Destroy;
9end;
9.2.3.13. Оператор обработки исключительных ситуаций
1try
2  //Операторы1
3except
4  //Операторы2
end
Выполняются операторы Операторы1. В случае возникновения исключительной ситуации управление передается на Операторы2. Если исключительных ситуаций не возникло, Операторы2 не выполняются никогда. При передаче управления на Операторы2 исключительная ситуация деактивирована. Для ее повторного возбуждения можно воспользоваться оператором возбуждения исключения без указания текстовой строки сообщения.
1try
2  LObject.NeverTouch := True;
3  LObject.ExecuteCoolMethod; //если метод выполнен неудачно
4except
5  LObject.NeverTouch := True;  //установить флаг и ничего не сообщать пользователю.
6end;
1try
2   LObject.ExecuteCoolMethod; //если метод выполнен неудачно
3except
4   LObject.Destroy; //удалить неудачный объект
5   raise;           // продолжить обработку исключения.
6end;
9.2.3.14. Оператор возбуждения исключения
raise [Выражение]
Возбуждает исключение, которое, если не было обработано блоком except оператора обработки, дойдет до пользователя. Пользователь увидит сообщение, определяемое Выражением. Выражение должно иметь строковый тип и является обязательным для всех случаев, кроме части except оператора обработки исключений.

9.2.3.15. Оператор унаследованного вызова
inherited
Работает только в унаследованном переопределенном методе. Вызывается метод предка с параметрами, заданными в параметрах к моменту вызова. Если программный блок представляет собой тело функции, то в псевдопеременной Result будет результат выполнения метода предка.
1// в теле конструктора
2Name := 'Object name';
3Description := 'Object description';
4inherited; //вызов предка с параметрами Name и Description,
5           //заданными двумя предыдущими операторами. Ссылка на
6           //созданный объект лежит в
7           //псевдопеременной Result
8Result.Name := 'New name';
9.2.4. Выражения и операции

9.2.4.1. Состав выражения

Любое выражение имеет тип. Выражения состоят из следующих элементов:

Целая числовая константа (0 3 234);

Вещественная числовая константа. Дробная часть отделяется от целой точкой (".") (3.14 2.71);

Строковая константа. Заключается в апострофы. ('Some string' '10', '01.01.2006' 'now');

Логическая константа (True False);

Безтиповая (любого типа) константа nil;

Зарезервированное слово Self. Обозначает разный объект в зависимости от контекста:

В методах класса кроме конструктора - использование запрещено.

В методах экземпляра - всегда экземпляр, для которого вызван метод.

В конструкторе - до вызова унаследованного метода значение не определено. После вызова - ссылка на сконструированный объект.

В выражениях условий отбора - объект, для которого принимается решение о его вхождении в отбор.

Квалификатор.

Агрегат.

9.2.4.2. Квалификатор

Квалификатор обозначает объект, переменную, параметр, свойство, поле, вызов функции. Квалификатор состоит из идентификаторов, разделенных точкой.

Result

AName

Caption

LObject.Name

LObject.Parent.Name

LObject.ChildCount

LObject.HasAsParent(LOtherObject)

При интерпретации квалификатора используется следующий порядок разбора идентификатора:

Контекстная переменная (для выражений условий отбора доменов)

Локальная переменная

Параметр

Имя элемента перечисления

Имя класса. Вне контекста означает ссылку на соответствующий объект класса TClass

Имя поля

Имя метода

Имя свойства

При интерпретации квалификатора внутри выражения агрегата правила разбора идентификатора изменяются:

Контекстная переменная (для выражений условий отбора доменов)

Имя элемента перечисления

Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту

Имя поля

Имя метода

Имя свойства

Локальная переменная

Параметр

9.2.4.3. Агрегат

Агрегат определяет агрегированное значение над экземплярами определенного класса, удовлетворяющими условиям агрегации. Агрегаты бывают следующих типов:

any - первый попавшийся объект. Результат имеет тип ссылки на объект агрегируемого класса.
1any(TObject with Master = Self.Parent)
2//первый попавшийся объект, имеющий значение
3//свойства Master равным значению свойства
4//Parent текущего (контекстного) объекта.
count - количество объектов. Результат имеет целочисленный тип.
1count(TObject with Master = Self.Parent)
2//количество объектов, имеющих значение свойства
3//Master равным значению свойства Parent
4//текущего объекта.
sum - сумма значений свойства, поля или функции объектов. Результат имеет тип суммируемого поля, свойства или функции
1sum(TExam.Mark with Master = LStudent) //сумма
2//баллов студента по его испытаниям
max, min - соответственно максимальное и минимальное значений свойства, поля или функции объектов. Результат имеет тип агрегируемого поля, свойства или функции
1min(TObject.Created) // момент создания первого
2//объекта Системы.
Внутри выражения агрегата правила разбора идентификатора изменяются на следующие:

Контекстная переменная (для выражений условий отбора доменов)

Имя элемента перечисления

Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту

Имя поля

Имя метода

Имя свойства

Локальная переменная

Параметр

9.2.4.4. Операции

Операции связывают элементы выражений.

Таблица операций в порядке приоритета:

Левый
операнд

Правый операнд

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

not

Нет

Логи-
ческий

* (звездочка)

Целый

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

/ (слэш, дробь)

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

div

Целый

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

and

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Логи-
ческий

Строковый

Объект

nil

or

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Логи-
ческий

Строковый

Объект

nil

+ (плюс)

Целый

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Дата

Дата со временем

Дата со временем

Время

Время

Время

Дата со временем

Время

Дата со временем

Дата со временем

Дата со временем

Дата со временем

Дата со временем

Логи-
ческий

Строковый

Строковый

Объект

nil

- (минус)

Целый

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Дата

Дата со временем

Целый

Дата со временем

Вещест-
венный

Время

Время

Время

Дата со временем

Время

Дата со временем

Дата со временем

Дата со временем

Дата со временем

Вещест-
венный

Дата со временем

Вещест-
венный

Логи-
ческий

Строковый

Объект

nil

=, <> (равно, не равно)

Целый

Логи-
ческий

Логи-
ческий

Логи-
ческий

Вещест-
венный

Логи-
ческий

Логи-
ческий

Логи-
ческий

Дата

Логи-
ческий

Логи-
ческий

Логи-
ческий

Время

Логи-
ческий

Логи-
ческий

Дата со временем

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Строковый

Логи-
ческий

Логи-
ческий

Объект

Логи-
ческий

Логи-
ческий

nil

Логи-
ческий

<, >, <=, >= (меньше, больше, меньше либо равно, больше либо равно)

Целый

Логи-
ческий

Логи-
ческий

Вещест-
венный

Логи-
ческий

Логи-
ческий

Дата

Логи-
ческий

Логи-
ческий

Время

Логи-
ческий

Дата со временем

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Строковый

Логи-
ческий

Объект

nil

is

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

Логи-
ческий

nil

as

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

Объект

nil

9.2.4.4.1. Особенности применения операций

Приоритет сравнений ниже приоритета операций булевой логики. Поэтому выражение
LObject.Master = LMaster and LObject.Parent = LParent
будет интерпретироваться следующим образом:
LObject.Master = (LMaster  and LObject.Parent) = LParent
и вызовет ошибку компиляции из-за применения операции and к объектам. Необходимо писать:
(LObject.Master = LMaster) and (LObject.Parent = LParent)
Любое значение (выражение любого типа) сравнивается с безтиповой константой nil:
1      LObject := any(TObject with Name = 'Some name');
2      if LObject = nil then
3         .....
Операции "Унарный минус" не существует. Для задания отрицательных констант пользуйтесь конструкцией 0-Значение:
Result := 0-1;
9.2.5. Формальная грамматика
001Goal: MethodBody | Expression;
002
003MethodBody: [ConstantDeclaration] [VariableDeclaration] CompoundStatement ";";
004
005ConstantDeclaration: "const" Ident ":" DomainSpecification ";"
006  [{Ident ":" DomainSpecification ";"}];
007
008VariableDeclaration: "var" DomainDefinition [{DomainDefinition}];
009
010DomainDefinition: Ident ":" DomainSpecification ";";
011
012DomainSpecification: IntegerDomainDefinition
013  | StringDomainDefinition
014  | FloatDomainDefinition
015  | DateDomainDefinition
016  | TimeDomainDefinition
017  | DateTimeDomainDefinition
018  | BooleanDomainDefinition
019  | BlobDomainDefinition
020  | EnumerationDomainDefinition
021  | Ident;
022
023IntegerDomainDefinition: "integer";
024StringDomainDefinition: "string" "[" Number "]";
025FloatDomainDefinition: "float" ["(" Number ["." Number] ")"];
026DateDomainDefinition: "date";
027TimeDomainDefinition: "time";
028DateTimeDomainDefinition: "datetime";
029BooleanDomainDefinition: "boolean";
030BlobDomainDefinition: "blob" | "clob";
031EnumerationDomainDefinition: "(" Ident {"," Ident} ")";
032
033CompoundStatement: "begin" Statement [{";" Statement}] "end";
034
035Statement:
036  | CompoundStatement
037  | AssignmentStatement
038  | InheritedStatement
039  | CallStatement
040  | IfStatement
041  | CaseStatement
042  | ForStatement
043  | WhileStatement
044  | RepeatStatement
045  | TryFinallyStatement
046  | TryExceptStatement
047  | RaiseStatement
048  | ForEachStatement
049  | ExitStatement;
050
051AssignmentStatement:  Qualifier ":=" Expression;
052
053CallStatement: Qualifier;
054
055InheritedStatement: "inherited";
056
057IfStatement: "if" Expression "then" Statement ["else" Statement];
058
059CaseStatement: "case" Expression "of" {CaseBranch} ["else" Statement ";"] "end";
060
061CaseBranch: CaseLabel [{',' CaseLabel}] ":" Statement ";";
062
063CaseLabel: Number | Ident;
064
065ForStatement: "for" Ident ":=" Expression ("to"|"downto")
066  Expression "do" Statement;
067
068WhileStatement: "while" Expression "do" Statement;
069
070RepeatStatement: "repeat" Statement [{";" Statement}] "until" Expression;
071
072TryFinallyStatement: "try" Statement [{";" Statement}] "finally"
073  Statement [{";" Statement}] "end";
074
075TryExceptStatement: "try" Statement [{";" Statement}] "except"
076  Statement [{";" Statement}] "end";
077
078RaiseStatement: "raise" [Expression];
079
080ForEachStatement: "for" "each" Ident "of" Ident ["with" Expression]
081  ["by" Expression] "do" Statement;
082
083ExitStatement: "exit";
084
085Expression: ComparedExpression [{RelationOperation Expression}];
086
087ComparedExpression: Addon [{AdditionOperaton ComparedExpression}];
088
089Addon: Factor [{MultiplicativeOperation Addon}];
090
091Factor: "(" Expression ")"
092  | "not" Expression
093  | Number ["." Number]
094  | StringConstant
095  | Qualifier
096  | "nil"
097  | "True"
098  | "False"
099  | "(" Expression "is" Ident ")"
100  | "any" Aggregate
101  | "count" Aggregate
102  | "sum" Aggregate
103  | "max" Aggregate
104  | "min" Aggregate;
105
106Aggregate: "(" Ident ["." Ident] ["with" Expression] ")";
107
108Qualifier: QualifierPart [{"." QualifierPart}];
109
110QualifierPart: Ident ["(" Expression [{", " Expression}] ")"]
111  | "self"
112  | "(" Qualifier "as" Ident ")";
113
114RelationOperation: "<"
115  | ">"
116  | "<="
117  | ">="
118  | "="
119  | "<>";
120
121AdditionOperaton: "+"
122  | "-"
123  | "or";
124
125MultiplicativeOperation: "*"
126  | "/"
127  | "div"
128  | "and";
9.2.6. Соглашения

9.2.6.1. Соглашения о наименованиях

В качестве вводимых (объявляемых) идентификаторов необходимо использовать так называемую нотацию InfixCaps. Если при создании имени используется несколько слов, то необходимо использовать заглавную букву для каждого слова в имени. Для разделения слов нельзя использовать символ подчеркивания. Все сущности именуются на английском языке, при этом использование сокращений является оправданным только в случае, если длина образуемого имени не согласуется с внешними по отношению к соображениям бизнес-логики ограничениям.

Имя класса должно начинаться с латинской буквы 'T'.

Имя

Наименование

TObjectList

Список объектов

TLearnPlan

Учебный план

Имя поля должно начинаться с латинской буквы 'F'.

Имя

Наименование

FLearnPeriod

Период обучения

FExamMark

Оценка за экзамен

Имя свойства не имеет префикса.

Имя

Наименование

ExamKind

Вид рубежного испытания

ContactPhone

Контактный телефон

Если членом класса для чтения свойства является поля, то имя свойства должно повторять имя поля без префикса 'F'. Если членом класса для чтения свойства является метод, то имя поля должно повторять имя метода без слова 'Get'.

Имя параметра не имеет префикса.

Имя

Наименование

OrderNumber

Номер приказа

ExamDate

Дата проведения экзамена

Параметры, используемые для инициализации значений полей, должны иметь имя, повторяющее имя поля без префикса 'F'. При компиляции тела метода, написанного на языке PascalScript имена параметров и имена свойств будут распознаваться в соответствии с порядком разбора идентификаторов, как это описано здесь и здесь.

Имена методов должны представлять собой императивный глагол на английском языке, выражающий смысл того, что метод делает. Имена методов не имеют префикса. Имена методов, используемых для получения значений свойств должны (как члены класса для чтения), должны начинаться со слова Get. Имена методов, используемых для установки значений свойств должны (как члены класса для записи), должны начинаться со слова Set.

Имя

Наименование

CountMarkSumm

Вычислить сумму баллов

GetAge

Получить значение возраста

SetMark

Установить значение оценки

Имена локальных переменных должны начинаться с латинской буквы 'L'.

LMarkSumm (сумма баллов), LObjectCount (количество объектов).

Имена доменов должны начинаться с латинской буквы 'T'. В именах доменов допустимы пробелы. Рекомендуется к имени домена добавлять слово 'domain' (через пробел), а для обязательных доменов 'required domain' (через пробел) тогда, когда необходимо исключить возможность использования этих доменов в текстах на PascalScript. Первым словом в имени домена-ссылки должно быть имя класса домена. Исключением являются имена доменов, соответствующих простым типам данных без дополнительных ограничений. Имена таких доменов могут повторять имена типов языка PascalScript (Integer, Boolean, Float).

Имя

Класс домена

Наименование

TPrice domain

Вещественный

домен Цена

TWeight required domain

Целочисленный

домен Вес (обязательный)

Boolean

Логический

Логический

TClassMember required domain

Ссылка

домен Член класса

Имена элементов перечислений должны иметь префикс из двух или трех символов, идентифицирующий соответствующий домен-перечисление. Префикс записывается строчными буквами. Например,

Имя

Наименование

для домена TExamKind (вид испытания)

ekTest

зачет

ekExam

экзамен

ekDifTest

дифференцированный зачет

для домена TAggregateKind (вид агрегата)

agCount

количество

agSumm

сумма

agAverage

среднее значение

Настоятельно рекомендуется давать уникальные имена элементов перечислений в пределах всей системы.

9.2.6.2. Стилевое оформление исходного кода

Код на языке PascalScript, являющийся частью поставляемого решения, должен быть оформлен в соответствии с изложенными правилами.

9.2.6.2.1. Использование строк, пробелов и отступов

Пустые строки могут повысить читабельность путем группирования секций кода, которые логически связаны между собой.

Пробелы, запрещенные к использованию:

До или после точки "."

Между именем вызываемого метода и открывающей скобкой "("

После открывающей скобки "(" или перед закрывающей ")"

Перед точкой с запятой ";"

Перед двоеточием ":"

Перед запятой ","

Двоеточие для всех объявлений переменных не должно содержать перед собой пробелов и иметь один пробел после перед именем типа.

Всегда необходимо использовать два пробела для всех уровней отступа. Другими словами, первый уровень отступает на два пробела, второй на четыре и так далее. Никогда не используйте символы табуляции.

Существует несколько исключений из этого правила. Зарезервированные слова var, begin и end, относящиеся к программному блоку вцелом, всегда должны примыкать к левой границе. Код внутри блока begin..end должен иметь отступ два символа.

Все строки должны быть ограничены 80 столбцами. Строки, длиннее чем 80 столбцов должны быть разделены и перенесены. Все перенесенные строки должны быть выровнены по первой строке и иметь отступ в два символа. Зарезервированное слово begin всегда должно находиться на своей отдельной строке.

Нельзя переносить строки в тех местах, где не допускаются пробелы, например между именем метода и открывающей скобкой. Никогда нельзя помещать зарезервированное слово begin на строку, содержащую другой код.

9.2.6.2.2. Оформление объявлений и операторов

Все переменные с их типами должны быть объявлены на различных строках.

Простые операторы содержат одну точку с запятой. Если Вам необходимо разделить оператор, то перенесите продолжение оператора на следующую строку с отступом в два пробела.
  MyValue :=
    MyValue + (SomeVeryLongStatement / OtherLongStatement);
Составные операторы всегда заканчиваются точкой с запятой.
1begin
2  MyStatement;
3  MyNext Statement;
4  MyLastStatement;
end;
Каждое присвоение и каждое выражение должно располагаться на разных строках.

Оператор "if"
Оператор if всегда должен располагаться по крайней мере на двух строках
if A < B then DoSomething;
if A < B then
  DoSomething;
В случае составного оператора необходимо поместить каждый оператор на новую строку.
1  if A < B then begin
2    DoSomething;
3    DoSomethingElse;
4  end else begin
5    DoThis;
6    DoThat;
7  end;
1  if A < B then
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end
6  else
7  begin
8    DoThis;
9    DoThat;
  end;
Все остальные варианты расположения операторов не рекомендуются и не одобряются, хотя и являются синтаксически правильными.
Оператор "for"
1  for i := 0 to 10 do begin
2    DoSomething;
3    DoSomethingElse;
4  end;
1  for i := 0 to 10 do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  for I := 0 to 10 do
8    DoSomething;
Оператор "while"
1  while x < j  do begin
2    DoSomething;
3    DoSomethingElse;
  end;
1  while x < j do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  while x < j do
8    Something;
Оператор "repeat..until"
1  repeat
2    x := j;
3    j := UpdateValue;
4  until j > 25;
Оператор "case"
Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01  case LCode of
02    1, 3:
03      begin
04        Incr := FIncrement + 1;
05        FinalIncr := FIncrement div FLineDiv;
06        Count := FLineDiv;
07      end;
08    2, 4:
09      begin
10        Incr := FPageIncrement;
11        FinalIncr := Incr + 1;
12        Incr := Incr div FPageDiv;
13        Count := FPageDiv;
14      end;
15  else
16    begin
17      Count := 0;
18      Incr := 0;
19      FinalIncr := 0;
20    end;
  end;
Оператор "try"
Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01try
02  try
03    EnumItems(CurrentThreadID, LDisable, 0);
04    Result := TaskList;
05  except
06    EnableItems(TaskList);
07    raise;
08  end;
09finally
10  TaskList := SaveList;
11  TaskActive := SaveActive;
end;
9.3. Интерфейсы взаимодействия с внешними подсистемами

Системный слой платформы "Мельница данных" предоставляет сторонним системам ряд интерфейсов, дающих возможность обращаться к объектам базы данных и их свойствам, вызывать методы классов и объектов, осуществлять запросы к базе данных, управлять поведением элементов управления и проч.

9.3.1. Интерфейс IContext
01  IContext = interface(IDispatch)
02    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
03    function Handle: Integer;
04    function getName(ID: OleVariant): WideString;
05    function getDescription(ID: OleVariant): WideString;
06    function createDataSet(const TargetClassName: WideString):
07      IContextDataSet;
08    function executeMethod(const ClassName: WideString;
09      const MethodName: WideString;
10      Params: OleVariant): OleVariant;
11    function executeReport(const ClassName: WideString;
12      const TemplateName: WideString;
13      Params: OleVariant): IDispatch;
14    function getPropValue(const ClassName: WideString;
15      const PropName: WideString;
16      const ID: OleVariant): OleVariant;
17    procedure setPropValue(const ClassName: WideString;
18      const PropName: WideString;
19      const ID: OleVariant; Value: OleVariant);
20    function select(const ClassName: WideString;
21      QueryItems: OleVariant): IDispatch;
22    function enumerationItem(ItemIdentifier: OleVariant): WideString;
23    function getClass(const ClassName: WideString): WideString;
24    function createGUID: WideString;
25    procedure processStart(const Description: WideString;
26      ItemCount: Integer);
27    procedure processStep;
28    procedure processStop;
29    function PlaceDataSet(const Range: IDispatch;
30      const DataSet: IContextDataSet;
31      ShiftRows: WordBool; ShiftColumns: WordBool): Integer;
32    procedure DebugString(const Message: WideString);
33    procedure ExportObject(var Document: OleVariant; const ID: WideString;
34      const ClassID: WideString);
35    function callRoutine(const ClassName, RoutineName: WideString;
36      var RetValue: OleVariant; const ScriptPart: OleVariant): WordBool;
37    function getOleObject(const ClassID, AccessibleFileName: WideString): IDispatch;
38    function getResource(const Name: WideString): WideString;
39    function getTempFileName(const Extension: WideString): WideString;
40    function selectVaue(const ClassDomain: WideString;
41      const ExpressionContext: IContextExpressionInfo;
42      var Value: OleVariant): WordBool;
43    procedure raiseManagedException(const ExceptionMessage: WideString);
44    function getCRC(Data: OleVariant): WideString;
45    function downloadData(const Host: WideString; const Url: WideString;
46      const UserName: WideString; const Password: WideString;
47      NegotiateAuth: WordBool; PostData: OleVariant;
48      const PostContentType: WideString; PostDataIsBinary: WordBool;
49      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;
50    function createBinaryData: IDispatch;
51    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
52    function editValues(const ValuesList: WideString; const Title: WideString;
53      UseTabs: WordBool; HideOKButton: WordBool;
54      const ScriptPart: OleVariant): WordBool;
55    function MsgBox(const Prompt: WideString; Buttons: LongWord;
56      const Title: WideString;
57      const HelpFile: WideString; Context: LongWord): Integer;
58    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
59      const Title: WideString;
60      const HelpFile: WideString; Context: LongWord): Integer;
61    function buildNamedFile(const Data: IDispatch; const StoredFileName: WideString;
62                            Propmpt: WordBool; Compress: WordBool): IDispatch;
63    procedure parseNamedFile(const NamedFile: IDispatch; out FileName: OleVariant;
64                             out Data: OleVariant);
65    procedure showView(const ViewName: WideString; Key: OleVariant;
66                       const DetailPropertyName: WideString);
67    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
68                          ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
69                          TakeActionsFromView: OleVariant);
70    function executeConsoleProcess(const CommandLine: WideString; MaxDuration: Integer;
71                                   const OutputData: OleVariant): Integer;
72    function createRaster: IDispatch;
73    function createZIPArchive: IDispatch;
74    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch;
75    property ContextObject: IDispatch;
76    property Language: WideString;
77    property UserName: WideString;
78    property NegotiateAuth: WordBool;
79    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant;
80  end;
Члены интерфейса доступны для использования в скриптах форм задания параметров, а также в отчетах как члены класса передаваемого контекстного объекта.

Функция Handle возвращает дескриптор главного окна приложения.

Функция getName возвращает имя объекта по его идентификатору.

Функция getDescription возвращает наименование объекта по его идентификатору.

Функция createDataSet создает набор данных, основанный на экземплярах класса, имя которого передано как параметр. Возвращаемый объект реализует интерфейс IContextDataSet.

Функция executeMethod осуществляет вызов метода с параметрами. Имя класса передается в параметре ClassName, имя вызываемого метода - в параметре MethodName. Если вызываемый метод явяется функцией, то результат ее выполнения возвращается как результат вызова executeMethod. Параметры вызова метода передаются через параметр Params следующим образом:

Для методов класса без параметров можно передавать любое значение, например, Null.

Для методов класса, имеющих один параметр, значение Params есть значение этого единственного параметра.

Для методов класса, имеющих более одного параметра, значение Params есть массив значений параметров.

VBScript, VBA

LValue = executeMethod("TObject", "Round", Array(10.24, 1))

JScript

LValue = executeMethod("TObject", "Round", new Array(10.24, 1));

Object Pascal

LValue := executeMethod('TObject', 'Round', VarArrayOf([10.24, 1]));

Для методов экземпляра без параметров значение Params есть идентификатор объекта, для которого вызывается метод.

Для методов экземпляра, имеющих параметры, значение Params есть массив значений параметров. При этом первым элементом массива является идентификатор объекта, для которого вызывается метод.

VBScript, VBA

executeMethod "TObject", "MergeTo", Array(LOldObject, LNewObject)

JScript

executeMethod("TObject", "MergeTo", new Array(LOldObject, LNewObject));

Object Pascal

executeMethod('TObject', 'MergeTo', VarArrayOf([LOldObject, LNewObject]));

Функция executeReport осуществляет вызов отчета с параметрами. Имя класса передается в параметре ClassName, имя вызываемого метода - в параметре TemplateName. Параметры вызова передаются в параметре Params аналогично вызову executeMethod. В результате вызова функции возвращается ссылка на рабочую книгу Microsoft Excel, документ Microsoft Word и так далее. Судьба приложения, в рамках которого создан возвращенный объект, остается на усмотрение вызывающей стороны. Если вызывающая сторона предполагает взаимодействие объекта с пользователем, то необходимо обеспечить видимость объекта-приложения (Application.Visible := True;). В противном случае необходимо закрыть приложение после освобождения объекта документа (Application.Quit).

Функция getPropValue возвращает значение свойства объекта. Имя класса, имя свойства и идентификатор объекта задаются в параметрах.

Процедура setPropValue устанавливает значение свойства объекта в значение, заданное параметром Value. Для очистки значения можно использовать пустую строку или значение Null. Имя класса, имя свойства и идентификатор объекта задаются в параметрах.

Функция select возвращает ссылку на XML-документ, содержащий в корневом элементе элементы, представляющие собой записи набора данных на основе класса ClassName (с полями, разнесенными по элементам), определяемого структурой параметра QueryItems.

Функция enumerationItem возвращает идентификатор элемента перечисления по имени.

VBScript, VBA

LItemID = enumerationItem("rsReplicatableMetadata")

JScript

LItemID = enumerationItem("rsReplicatableMetadata");

Object Pascal

LItemID := enumerationItem('rsReplicatableMetadata');

Функция getClass возвращает идентификатор объекта типа Класс TClass (Классы) по имени.

VBScript, VBA

LClassID = getClass("TDocumentType")

JScript

LClassID = getClass("TDocumentType");

Object Pascal

LClassID := getClass('TDocumentType');

функция createGUID является оберткой над функцией Windows API CoCreateGuid. Возвращает сгенерированный глобально-уникальный идентификатор, преобразованный в строку.

процедура processStart информирует систему о необходимости показать окно выполнения длительного процесса. Текст, описывающий процесс (он появляется в показываемом окне) задается параметром Description. В случае, если есть возможность определить количество "шагов" процесса, то это количество необходимо передать в параметре ItemCount. В случае, если параметр ItemCount больше нуля, окно выполнения будет снабжено индикатором прогресса. Если значение ItemCount равно нулю, то окно появится без индикатора прогресса. Если значение ItemCount меньше нуля, то решение о появлении окна будет принято системой самостоятельно на основании загрузки процессора и окно процесса не появится, если процесс завершится достаточно быстро.

процедура processStep информирует систему о завершении очередного "шага" процесса, что найдет отражение в индикаторе прогресса окна выполнения длительного процесса, если таковые случатся.

процедура processStop информирует систему о завершении длительного процесса, что приведет к закрытию окна выполнения длительного процесса, если таковое случится.

функция PlaceDataSet осуществляет перенос данных из набора, задаваемого параметром DataSet в некоторое место документа Microsoft Office. Место назначения определяется параметром Range следующим образом:

Microsoft Word

Объект Range. По месту расположения этого объекта будет создана таблица (Table), в которой будут размещены данные из набора.

PlaceDataSet ThisDocument.Bookmarks("BookMarkName").Range, LDataSet

PlaceDataSet Selection.Range, LDataSet

Объект Document. В самом начале переданного документа будет создана таблица (Table), в которой будут размещены данные из набора.

PlaceDataSet ThisDocument, LDataSet

Microsoft Excel

Объект Range. По месту расположения этого объекта (диапазона) будут размещены данные из набора. Если параметр ShiftRows задан и равен True, то заданный диапазон будет расширен вниз на необходимое количество строк, и информация, лежащая ниже переданного диапазона, будет по-прежнему лежать ниже. Если нет, то она (скорее всего) будет затёрта данными набора. Если параметр ShiftColumns задан и равен True, то этот диапазон будет расширен вправо на необходимое количество столбцов, и информация, лежащая правее переданного диапазона, будет по-прежнему лежать правее. Если нет, то она (скорее всего) будет затёрта данными набора.

PlaceDataSet Range("C4"), LDataSet

Объект WorkSheet. На переданном листе будут размещены данные из набора.

PlaceDataSet WorkSheets("HiddenSheet"), LDataSet

Функция возвращает количество размещенных записей.

процедура DebugString выводит переданную в качестве аргумента строку в отладочный монитор.

процедура ExportObject осуществляет экспорт информации об объекте, задаваемом параметром ID в XML-документ, передаваемый в параметре Document. Если объект документа не был создан, то он создается автоматически. Если документ не имеет корневого узла, он будет создан автоматически.
01set LDataSet = CreateDataSet("TSecurityAccount")
02
03LDataSet.AddQueryItem qpWhat, "ID"
04
05set LDocument = CreateObject("Msxml2.DOMDocument.4.0") 'Не обязательно.
06
07while not LDataSet.Eof
08  ExportObject LDocument, LDataSet.Field("ID")
09  LDataSet.Next
10wend
11
12LDocument.save "c:\RolesAndUsers.xml"
Функция callRoutine осуществляет вызов подпрограммы. Параметры будут запрошены у пользователя обычным порядком (с показом формы задания параметров, отработки ее скрипта и т. д.). Имя класса передается в параметре ClassName, имя вызываемой подпрограммы - в параметре RoutineName. Если пользователь разрешил выполнение подпрограммы (либо для выполнения не требовалось разрешения пользователя), функция вернет True, иначе False. Значение, возвращаемое подпрограммой, может быть возвращено через необязательный параметр RetValue. Через значение необязательного параметра ScriptPart можно передать скрипт на языке VBScript, который будет "приклеен" сверху к скрипту формы параметров вызываемой подпрограммы.

Функция getOleObject возвращает ссылку на Ole-объект с идентификатором класса, переданном в параметре ClassID. Объект создается на основе библиотеки кода, сохраненной в доступном файле с именем, заданным параметром AccessibleFileName. Регистр символов имени доступного файла важен.

Функция getResource возвращает значение ресурсной строки по имени ресурса (элемента перечислимого домена Resource strings или перевода (объекта класса TLanguageTranslation).
MsgBox getResource("rssMyErrorMessage")
Функция getTempFileName возвращает сгенерированное системой имя временного файла с расширением, переданным в параметре Extension.

Функция selectVaue позволяет пользователю выбрать значение на основе ссылочного домена, имя которого передается в параметре ClassDomain. Вызывающая сторона может реализовать интерфейс IContextExpressionInfo, через который передается информация о контексте вызова для интерпретации выражений условий отбора, и передать ссылку на него через параметр ExpressionContext. Выбранное значение передается в обе стороны через параметр Value. Если пользователь подтвердил выбор значения, функция возвращает значение True, и устанавливает значение параметра Value, равное идентификатору выбранного пользователем объекта. Если пользователь отказался от выбора, функция возвращает значение False.

Процедура raiseManagedException возбуждает управляемую исключительную ситуацию с сообщением для пользователя, заданным параметром ExceptionMessage.

Функция getCRC возвращает шестнадцатиричное представление контрольной суммы переданных в параметре Data данных. Параметр может быть

Объектом, реализующим интерфейс IBinaryData

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Объектом, реализующим интерфейс IFile объектной модели FileSystemObject

Строкой данных. Строка будет преобразована в байты в соответствии с кодировкой UTF-8.

Функция downloadData осуществляет обращение к указанному ресурсу по протоколу http (https), и возвращает ответ сервера в виде объекта, реализующего интерфейс IBinaryData. Параметр Host определяет http-сервер, параметр Url - Url, к которому будет происходить обращение. Параметры UserName и Password определяют имя пользователя и пароль, если http-сервер требует авторизовать пользователя. Параметр NegotiateAuth устанавливает режим аутентификации. (Basic или Negotiate). Параметры PostData, PostContentType и PostDataIsBinary определяют содержимое тела POST-запроса (если не определено, функция отправит GET-запрос). Параметр CanCache позволяет использовать локальный кеш http-ответов. Параметр NewSession требует принудительного создания новой сессии при вызове функции. Параметр TimeOut определяет максимальное время ожидания ответа в секундах.

Функция createBinaryData создает пустой объект, реализующий интерфейс IBinaryData.

Функция BinaryToBitmap конвертирует переданный графический файл в формат BMP. Объекты во входном и выходном параметрах должны реализовывать интерфейс IBinaryData.

Функция editValues создает и показывает форму редактирования группы значений. Параметр ValuesList содержит идентификатор объекта класса TObjectList. Этот список содержит ссылки на редактируемые значения (объекты класса TTypedValue), и командные кнопки формы (объекты класса TTypedValueButton). Параметр Title определяет заголовок формы, параметр UseTabs определяет, будут ли показаны закладки на форме редактирования. Параметр HideOKButton позволяет скрыть кнопку "OK" на показываемой форме. Параметр ScriptPart определяет скрипт показываемой формы.
01  LValue1 = executeMethod ("TTypedValue", "CreateStrValue", _
02    Array("Value1", "Первый параметр", Null, Null, _
03    "TLongString", Null, Null, Null, Null, Null, "Значение по  умолчанию первого параметра"))
04  LValue2 = executeMethod ("TTypedValue", "CreateStrValue", _
05    Array("Value2", "Второй параметр", Null, Null, _
06    "TLongString", Null, Null, Null, Null, Null, "Значение по  умолчанию второго параметра"))
07
08  LValues = executeMethod("TObjectList", "CreateFromString", _
09    LValue1 & ";" & LValue2)
10
11  if editValues(LValues, "Введите два строковых значения, друзья", True, False, "") then
12    MsgBox getPropValue("TTypedValue", "StrValue", LValue1) & _
13      " " & _
14      getPropValue("TTypedValue", "StrValue", LValue2)
15  end if
16
17  executeMethod "TObject", "Destroy", LValues
18  executeMethod "TObject", "Destroy", LValue1
19  executeMethod "TObject", "Destroy", LValue2
01  LScriptPart =  "Buttons(""NextButton"").Enabled = ParentForm.NavigatorCanNext" & Chr(10) & _
02    "Buttons(""PrevButton"").Enabled = ParentForm.NavigatorCanPrevious"
03
04  LValue1 = executeMethod ("TTypedValue", "CreateStrValue", _
05    Array("Value1", "Первый параметр", Null, Null, "TLongString", Null, Null, Null, Null, Null, _
06    "Значение по  умолчанию первого параметра"))
07  LValue2 = executeMethod ("TTypedValue", "CreateStrValue", _
08    Array("Value2", "Второй параметр", Null, Null, "TLongString", Null, Null, Null, Null, Null, _
09    "Значение по  умолчанию второго параметра"))
10
11  LNextButton = executeMethod ("TTypedValueButton", "Create", Array("NextButton", "Вперед!", _
12    Null, Null, Null, Null, 0, Null, Null, _
13    "ParentForm.NavigatorNext"  & Chr(10) & LScriptPart, enumerationItem("scPublic"), 1, Null))
14
15  LPrevButton = executeMethod ("TTypedValueButton", "Create", Array("PrevButton", "Назад!", _
16    Null, Null, Null, Null, 1, Null, Null, _
17    "ParentForm.NavigatorPrevious" & Chr(10) & LScriptPart, enumerationItem("scPublic"), 1, Null))
18
19  LValues = executeMethod("TObjectList", "CreateFromString", _
20    LValue1 & ";" & LValue2 & ";" & LNextButton & ";" & LPrevButton)
21
22  if editValues(LValues, "Введите два строковых значения, друзья", True, True, LScriptPart) then
23    MsgBox getPropValue("TTypedValue", "StrValue", LValue1) & _
24      " " & _
25      getPropValue("TTypedValue", "StrValue", LValue2)
26  end if
27
28  executeMethod "TObject", "Destroy", LValues
29  executeMethod "TObject", "Destroy", LValue1
30  executeMethod "TObject", "Destroy", LValue2
31  executeMethod "TObject", "Destroy", LNextButton
32  executeMethod "TObject", "Destroy", LPrevButton
Функции MsgBox и ShowMsgBox (это синонимы одной точки входа) полностью аналогичны функции Basic MsgBox по поведению и набору параметров.

Функция buildNamedFile формирует значение типа "Именованный файл" на основе объекта, реализующего интерфейс IBinaryData (параметр Data) и информации об имени и параметрах именованного файла.

Процедура parseNamedFile разбирает значение типа "Именованный файл". Выходной параметр FileName будет содержать сохраненное имя файла, выходной параметр Data - объект, реализующего интерфейс IBinaryData и содержащий данные именованного файла.

Свойство ContextObject позволяет получить ссылку на этот же самый контекстный объект.

Свойство UserName позволяет получить логин текущего пользователя.

Свойство NegotiateAuth позволяет получить признак доменной аутентификации пользователя.

Свойство Language позволяет получать и устанавливать текущий языковой контекст, в котором будут выполняться обращения к БД. Значение свойства либо пустая строка (используется язык БД по умолчанию), либо имя объекта класса TLanguage

Свойство Variable позволяет сохранять и получать произвольные значения, которые могут хранится постоянно (в реестре) или только в текущем сеансе, в зависимости от параметра Persistent.
1'сохранить на время текущего сеанса значение в переменную с именем SameVariableName
2Variable("SameVariableName", False) = "Value"
3
4'получить значение переменной с именем SameVariableName хранимой в текущем сеансе
5LValue = Variable("SameVariableName", False)
Процедура showView осуществляет показ в модальном окне представления с именем ViewName. С помощью параметров DetailPropertyName и Key можно наложить на представление дополнительное условие отбора.

9.3.2. Интерфейс IContextDataSet
01  IContextDataSet = interface(IDispatch)
02    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
03    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
04      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant);
05    function Eof: WordBool;
06    function Field(const Name: WideString): OleVariant;
07    function FieldCount: Integer;
08    function FieldName(Index: Integer): WideString;
09    procedure Next;
10  end;
Интерфейс предоставляет возможности формирования и выполнения запросов к базе данных с целью получения свойств объектов определенного класса, предоставляет доступ к объекту набора данных. Работа с объектом, реализующим интерфейс IContextDataSet заключается в формировании структуры набора данных и последующих обращениях к ним.

Процедура AddQueryItem добавляет элемент набора данных. Элементы могут добавляться в любом порядке до первого обращения к данным набора. Символические имена всех предопределенных для параметров этого метода констант являются членами интерфейса IConstants.

часть запроса определяется параметром Part, который может принимать одно из следующих предопределенных значений:

Символическое имя

Числовое значение

Описание

qpWhat

0

Добавляет поле (столбец), определяемое параметром Name, к результирующему набору данных. Параметр Value игнорируется.

qpWhere

1

Определяет условие, налагаемое на свойства объектов класса, передаваемое остальными параметрами.

qpOrder

2

Определяет порядок сортировки записей результирующего набора данных. Параметр Value игнорируется.

qpGroup

3

Определяет, что записи результирующего набора данных будут сгруппированы по столбцу, переданному в параметре Name. Параметры Value и Special игнорируются.

параметр Name должен быть именем свойства класса, на котором основан набор данных, либо зарезервированным словом "ID" (без кавычек).

параметр Value (необязательный) определяет условия отбора, накладываемые на свойство, заданное параметром Name. Имеет смысл только если значение параметра Part равно qpWhere. Условие задается посредством строки, интерпретируемой следующим образом:

строка разделяется на части посредством системного разделителя

каждая часть интерпретируется самостоятельно, и эти части объединяются логическим "ИЛИ"

при интерпретации каждой части проверяются следующие условия:

*

проверка значения на непустоту (IS NOT NULL)

!*

проверка значения на пустоту (IS NULL)

начинается с символов
'<=', '<', '>=', '>'

проверка соответствующего отношения между значением свойства, переданного параметром Name и оставшейся частью строки

включает в себя символы '*' и/или '?'

проверка соответствия значения шаблону, в котором знак '?' соответствует одному любому символу, а знак '*' - любому количеству любых символов

начинается с символа '!'

символ '!' означает отрицание условия, переданного оставшейся частью строки

представляет собой строку в апострофах (одиночных кавычках)

содержание строки не анализируется по приведенным выше условиям

любая другая строка

проверка равенства значения свойства, переданного параметром Name значению, переданному строкой

параметр Special (необязательный) обеспечивает дополнительное поведение набора данных (если параметр Special используется, необходимо использовать и параметр Value, можно передавать пустую строку):

Символическое имя

Числовое значение

Описание

qsNone

0

Параметр не используется. Значение по умолчанию.

qsDescending

7

Используется при значении qpOrder параметра Part. В этом случае производится сортировка по убыванию.

qsCount

8

Используется при значении qpWhat параметра Part. Определяют тип агрегации по свойству, заданному параметром Name.

qsSum

9

qsMin

10

qsMax

11

qsAverage

12

qsFunction

22

Используется для включения в запрос вызова функции. Используется при значении qpWhat параметра Part.

параметр Context (необязательный) определяет дополнительные параметры элемента запроса.
01'включить в набор данных свойство Name
02LDataSet.AddQueryItem 0, "Name"
03'включить в набор данных среднее значение цены
04LDataSet.AddQueryItem 0, "Price", "", 12
05'включить в набор данных идентификатор объекта
06LDataSet.AddQueryItem 0, "ID"
07'включить в набор данных вызов функции. В поле IsCompany будет значение True, если объект является организацией
08LDataSet.AddQueryItem 0, "IsCompany", "TObject.IsInstanceOf", 22, Array(getClass("TCompany"))
09'наложить на набор данных условие
10LDataSet.AddQueryItem 1, "Organization", "фирма Елочка"
1LDataSet.AddQueryItem 0, "Organization"              '(1)
2LDataSet.AddQueryItem 0, "SalesCount", "", "9"       '(2)
3LDataSet.AddQueryItem 1, "SaleDate", ">10.09.2005"   '(3)
4LDataSet.AddQueryItem 2, "Organization"              '(4)
5LDataSet.AddQueryItem 3, "Organization"              '(5)
Производится отбор из класса, описывающего число продаж некоего продукта различными организациями. При этом в набор данных включаются колонки "Organization" (строка 1) и "SalesCount" (строка 2). При этом будет произведена группировка по свойству "Organization" (строка 5) (что гарантирует вхождение каждой организации в результирующий набор данных не более одного раза). Набор данных будет отсортирован по организации (строка 4). При этом в колонке "SalesCount" будет сумма (строка 2) всех продаж, осуществленных каждой организацией после 10.09.2005 (строка 3).

Функция FieldCount возвращает количество полей (столбцов) набора данных.

Функция FieldName возвращает имя поля (столбца) с номером, переданным в параметре Index.

Функция Field возвращает значение, содержащееся в поле с именем или индексом, заданным параметром Name (строкового типа) текущей записи набора данных. При первом обращении к набору данных текущей является первая запись. Если параметр определяет номер, то поиск поля производится по номеру. Если имя, то по имени.

Процедура Next осуществляет переход к следующей записи набора данных.

Функция Eof возвращает False, если текущая запись набора данных существует; в случаях, если набор данных пустой, или при помощи метода Next достигнут конец набора данных, возвращает True.
01If LDataSet.Eof then
02  'набор данных пуст. Ничего не отобрано.
03Else
04  While Not LDataSet.Eof
05    'работа с очередной отобранной записью
06    Cells(LRow, 1).Value = LDataSet.Field("Name")
07    Cells(LRow, 2).Value = LDataSet.Field("Description")
08    Cells(LRow, 2).Value = LDataSet.Field("Count")
09    'переход к следующей записи
10    LDataSet.Next
11    LRow = LRow + 1
12  Wend
13End If
9.3.3. Интерфейс IConstants
01  IConstants = interface(IDispatch)
02    ['{7E7B2D66-5E7C-496A-AE06-EFC485007500}']
03    property qpWhat: Integer;
04    property qpWhere: Integer;
05    property qpOrder: Integer;
06    property qpGroup: Integer;
07    property qpHaving: Integer;
08    property qsNone: Integer;
09    property qsObjectID: Integer;
10    property qsParentID: Integer;
11    property qsHasChildren: Integer;
12    property qsFilterCondition: Integer;
13    property qsUplink: Integer;
14    property qsRootOnly: Integer;
15    property qsDescending: Integer;
16    property qsCount: Integer;
17    property qsSum: Integer;
18    property qsMin: Integer;
19    property qsMax: Integer;
20    property qsAverage: Integer;
21    property qsMasterLink: Integer;
22    property qsSelectedOnly: Integer;
23  end;
Интерфейс предоставляет символические имена констант, необходимых для работы с объектом, реализующим интерфейс IContextDataSet.

Свойство

Значение

qpWhat

0

qpWhere

1

qpOrder

2

qpGroup

3

qpHaving

4

qsNone

0

qsObjectID

1

qsParentID

2

qsHasChildren

3

qsFilterCondition

4

qsUplink

5

qsRootOnly

6

qsDescending

7

qsCount

8

qsSum

9

qsMin

10

qsMax

11

qsAverage

12

qsMasterLink

13

qsSelectedOnly

14

9.3.4. Интерфейс IFormContext
01  IFormContext = interface(IDispatch)
02    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
03    function ChangedControl: OleVariant;
04    function ControlCount: Integer;
05    function ButtonCount: Integer;
06    function ID: WideString;
07    procedure Cancel;
08    function ControlExists(const Name: WideString): WordBool;
09    function ChangedControlName: WideString;
10    function ParentForm: OleVariant;
11    function RoutineID: WideString;
12    procedure PreInitControl(const Name: WideString; Value: OleVariant);
13    procedure NavigatorNext;
14    procedure NavigatorPrevious;
15    function NavigatorCanNext: WordBool;
16    function NavigatorCanPrevious: WordBool;
17    procedure RefreshView(RefreshAll: WordBool);
18    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
19    property Controls[Name: OleVariant]: IControl;
20    property Buttons[Name: OleVariant]: IButton;
21    property Enabled: WordBool;
22  end;
Представляет собой модель формы задания параметров. Члены интерфейса доступны для использования в скриптах форм задания параметров.

Функция ChangedControl возвращает объект, реализующий интерфейс IControl, соответствующий элементу управления, изменение которого вызвало исполнение скрипта формы параметров. Если выполнение скрипта вызвано инициализацией формы задания параметров, то значение функции - Empty. Пустоту значения можно проверить с помощью функции VBScript IsEmpty.

Функция ControlCount возвращает число элементов управления на форме параметров, как видимых так и невидимых.

Функция ButtonCount возвращает число командных кнопок на форме параметров, как видимых так и невидимых.

Функция ID возвращает значение идентификатора объекта, для которого вызван метод. Для методов класса возвращает пустое значение.

Функция ControlExists возвращает True, если элемент управления с именем Name существует на форме, и, соответственно, существует соответствующий параметр.

Функция ChangedControlName возвращает имя элемента управления, изменение которого вызвало исполнение скрипта формы параметров. Если выполнение скрипта вызвано инициализацией формы задания параметров, то значение функции - пустая строка.

Процедура Cancel прекращет работу формы задания параметров. Форма закрывается, выполнение действия блокируется.

Функция ParentForm возвращает ссылку на контекст родительской формы в цепочке вызовов. В контексте первой формы (вызванной с грида немодальной формы) возвращает пустое значение (Empty). Пустоту значения можно проверить с помощью функции VBScript IsEmpty.

Функция RoutineID возвращает идентификатор подпрограммы, для которой вызвана форма.

Процедура PreInitControl имитирует предварительную инициализацию элемента управления с именем Name значением, переданным в параметре Value. Сам элемент управления при этом будет скрыт, и не будет показан вплоть до следующего вызова формы пользователем.

Процедура NavigatorNext выполняет переход к следующему объекту набора данных, для которого показывается форма параметров.

Процедура NavigatorPrevious выполняет переход к предыдущему объекту набора данных, для которого показывается форма параметров.

Функция NavigatorCanNext возвращает True, если возможен переход к следующему объекту набора данных, для которого показывается форма параметров.

Функция NavigatorCanPrevious возвращает True, если возможен переход к предыдущему объекту набора данных, для которого показывается форма параметров.

Процедура RefreshView обновляет набор данных, для которого показывается форма параметров. Если значение параметра RefreshAll равно True, то будет обновлен весь набор, если False, то только выделенные записи.

Свойство Controls позволяет обращаться к элементам управления на форме задания параметров, их свойствам и методам. Каждый элемент управления реализует интерфейс IControl. В параметре Name (строкового типа)может быть передано как имя элемента управления, так и его индекс (в этом случае индекс должен быть передан как строка). Имена элементов управления на форме параметров соответствуют именам параметров подпрограммы (метода, отчета, etc).

Свойство Buttons позволяет обращаться к командным кнопкам на форме задания параметров, их свойствам и методам. Каждая командная кнопка реализует интерфейс IButton. В параметре Name (строкового типа)может быть передано как имя командной кнопки, так и ее индекс (в этом случае индекс должен быть передан как строка).

Свойство Enabled позволяет получать и устанавливать доступность кнопки OK на форме задания параметров. Если на форме есть невалидные (имеющие недопустимые значения) элементы управления, значение свойства всегда равно False и устанавливать его в явном виде в True не рекомендуется. Для учета дополнительного условия рекомендуется использовать следующую конструкцию: Enabled = Enabled and (Controls("SalesCount").Value > 10)

Функция ExpressionContextValue возвращает значение переменной контекста с именем Name, которая используется для интeрпретации выражений условий отбора на форме.

9.3.5. Интерфейс IControl
01  IControl = interface(IDispatch)
02    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
03    function Name: WideString;
04    procedure SetHint(const Value: WideString);
05    procedure RefreshLinkedView;
06    property Value: OleVariant;
07    property ReadOnly: WordBool;
08    property IsValid: WordBool;
09    property IsEmpty: WordBool;
10  end;
Моделирует элемент управления на форме задания параметров. Позволяет управлять поведением элементов управления на форме.

Функция Name возвращает имя элемента управления; имена элементов управления всегда совпадают с именамим соответствующих параметров подпрограммы.

Процедура SetHint устанавливает текст всплывающей подсказки элемента управления. Всплывыющая подсказка показывается только если значение элемента управления недопустимо (свойство IsValid равно False).

Процедура RefreshLinkedView обновит связанное с элементом управления представление.

Свойство Value позволяет получать и устанавливать значение, введенное в элемент управления.

Свойство ReadOnly позволяет получать и устанавливать доступность элемента управления для записи; при значении True элемент управления не доступен для записи и отображается неактивным.

Свойство IsValid позволяет получать и устанавливать "валидность" элемента управления; по умолчанию валидным элемент управления является в том случае, если введенное в него значение соответствует домену соответствующего параметра подпрограммы с учетом наложенного на него условия отбора.

Свойство IsEmpty имеет значение True в случае, если в элемент управления не введено никакого значения (элемент управления пустой), в противном случае имеет значение False.

9.3.6. Интерфейс IButton
1  IButton = interface(IDispatch)
2    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
3    function Name: WideString; safecall;
4    procedure Click; safecall;
5    property Enabled: WordBool;
6  end;
Моделирует командную кнопку на форме задания параметров. Позволяет управлять поведением кнопки на форме.

Функция Name возвращает имя кнопки.

Процедура Click эмулирует нажатие на кнопку.

Свойство Enabled позволяет получать и устанавливать доступность кнопки.

9.3.7. Интерфейс IBinaryData
01  IBinaryData = interface(IDispatch)
02    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
03    procedure Load(const Src: OleVariant);
04    procedure Append(const Src: OleVariant);
05    procedure Save(const Dst: OleVariant);
06    function Size: Cardinal;
07    function ToString(Encoding: WideString): WideString;
08    procedure FromString(Data: OleVariant);
09    procedure AppendString(Data: OleVariant);
10    function ToBase64: WideString;
11    procedure FromBase64(Data: OleVariant);
Представляет набор двоичных данных.

Процедура Load загружает двоичные данные из переданного источника. Источник может быть

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Строкой, содержащей имя файла

Процедура Append добавляет двоичные данные из переданного источника. Источник может быть

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Строкой, содержащей имя файла

Процедура Save сохраняет двоичные данные в переданный приемник. Приемник может быть

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Строкой, содержащей имя файла

Функция ToString переводит данные в строку. Байты, содержашиеся в объекте, будут рассматриваться как содержащие строку в кодировке, заданной параметром Encoding. По умолчанию используется кодировка UTF-8

Процедура FromString загружает данные из строки, переданной в параметре Data, перекодировав ее в кодировку UTF-8

Процедура AppendString добавляет данные из строки, переданной в параметре Data, перекодировав ее в кодировку UTF-8

Функция ToBase64 возвращает строку, полученную путем кодирования в формат Base64, данных содержащихся в объекте

Процедура FromBase64 загружает данные из строки, переданной в параметре Data, раскодировав ее из формата Base64

9.3.8. Интерфейс IContextExpressionInfo
1  IContextExpressionInfo = interface(IUnknown)
2    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
3    function Count: Integer;
4    function ItemName(Index: Integer): WideString;
5    function ItemValue(Index: Integer): OleVariant;
6    function ItemDomain(Index: Integer): OleVariant;
7  end;
Через реализацию этого интерфейса передаются значения контекстных переменных при обращении к функции selectValue интерфейса IContext.

Функция Count возвращает количество используемых контекстных переменных. Нумерация контекстных переменных начинается с нуля.

Функция ItemName возвращает имя контекстной переменной c номером, переданным в параметре Index.

Функция ItemValue возвращает значение контекстной переменной c номером, переданным в параметре Index.

Функция ItemDomain возвращает имя домена контекстной переменной c номером, переданным в параметре Index.

9.3.9. Интерфейс IExceptionHandler
1  IExceptionHandler = interface(IDispatch)
2    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
3    procedure HandleException(ContextObject: OleVariant;
4      const Message: WideString;
5      const ExtentedInfo: WideString);
6  end;
Реализовав интерфейс IExceptionHandler разработчик решений может получать уведомления о возникающих при работе исключительных ситуациях. При возникновении исключения объект, реализующий интерфейс, получит текст сообщения об ошибке и расширенную информацию.

Для реализации интерфеса используется библиотека hse.tlb, входящая в состав поставки решения. Перед началом работы с ней, необходимо зарегистрировать ее в операционной системе.

Для установки настроек интерфейса необходимо открыть Системную форму раздела АДМИНИСТРАТОРУ, перейти на вкладку Настройки и в столбце "Заголовок закладки" установить фильтр "Обработка ошибок".

После этого в качестве значения Идентификатора класса установить "IExceptionHandler" без кавычек.

Для Библиотеки кода указать значение HSE.tlb

9.3.10. Справочник по интерфейсам

9.3.10.1. Перечисление TQueryPart
1type
2  TQueryPart = (qpWhat, qpWhere, qpOrder, qpGroup, qpHaving, qpInnerJoin,
3    qpOuterJoin);
Или
01type
02  TQueryPart = TOleEnum;
03const
04  qpWhat = $00000000;
05  qpWhere = $00000001;
06  qpOrder = $00000002;
07  qpGroup = $00000003;
08  qpHaving = $00000004;
09  qpInnerJoin = $00000005;
10  qpOuterJoin = $00000006;
Элементы перечисления:

Имя

Значение

Назначение

qpWhat

0

qpWhere

1

qpOrder

2

qpGroup

3

qpHaving

4

qpInnerJoin

5

qpOuterJoin

6

9.3.10.2. Перечисление TQuerySpecial
1type
2  TQuerySpecial = (qsNone, qsObjectID, qsParentID, qsHasChildren,
3    qsFilterCondition, qsUplink, qsRootOnly, qsDescending, qsCount, qsSum, qsMin,
4    qsMax, qsAverage, qsMasterLink, qsSelectedOnly, qsDistinct, qsViewCondition,
5    qsCaseInsensitive, qsAsString, qsListed, qsName, qsDescription, qsFunction,
6    qsCountDistinct, qsBoolean, qsExact, qsSearchIndex, qsOptimizationParameters);
Или
01type
02  TQuerySpecial = TOleEnum;
03const
04  qsNone = $00000000;
05  qsObjectID = $00000001;
06  qsParentID = $00000002;
07  qsHasChildren = $00000003;
08  qsFilterCondition = $00000004;
09  qsUplink = $00000005;
10  qsRootOnly = $00000006;
11  qsDescending = $00000007;
12  qsCount = $00000008;
13  qsSum = $00000009;
14  qsMin = $0000000A;
15  qsMax = $0000000B;
16  qsAverage = $0000000C;
17  qsMasterLink = $0000000D;
18  qsSelectedOnly = $0000000E;
19  qsDistinct = $0000000F;
20  qsViewCondition = $00000010;
21  qsCaseInsensitive = $00000011;
22  qsAsString = $00000012;
23  qsListed = $00000013;
24  qsName = $00000014;
25  qsDescription = $00000015;
26  qsFunction = $00000016;
27  qsCountDistinct = $00000017;
28  qsBoolean = $00000018;
29  qsExact = $00000019;
30  qsSearchIndex = $0000001A;
31  qsOptimizationParameters = $0000001B;
Элементы перечисления:

Имя

Значение

Назначение

qsNone

0

qsObjectID

1

qsParentID

2

qsHasChildren

3

qsFilterCondition

4

qsUplink

5

qsRootOnly

6

qsDescending

7

qsCount

8

qsSum

9

qsMin

10

qsMax

11

qsAverage

12

qsMasterLink

13

qsSelectedOnly

14

qsDistinct

15

qsViewCondition

16

qsCaseInsensitive

17

qsAsString

18

qsListed

19

qsName

20

qsDescription

21

qsFunction

22

qsCountDistinct

23

qsBoolean

24

qsExact

25

qsSearchIndex

26

qsOptimizationParameters

27

9.3.10.3. Интерфейс IButton
1type
2  IButton = interface(IDispatch)
3    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
4    function Get_Enabled: WordBool; safecall;
5    procedure Set_Enabled(Value: WordBool); safecall;
6    function Name: WideString; safecall;
7    procedure Click; safecall;
8    property Enabled: WordBool read Get_Enabled write Set_Enabled;
9  end;
9.3.10.3.1. Свойства

Свойства интерфейса IButton:

Имя

Тип

Доступ

Назначение

Enabled

WordBool

Чтение/Запись

9.3.10.3.2. Метод Click

Метод интерфейса IButton.
procedure IButton.Click;
Метод не имеет параметров.

9.3.10.3.3. Метод Name

Метод интерфейса IButton.
function IButton.Name: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

9.3.10.4. Интерфейс IContext
001type
002  IContext = interface(IDispatch)
003    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
004    function Get_ContextObject: IDispatch; safecall;
005    function Get_UserName: WideString; safecall;
006    function Get_NegotiateAuth: WordBool; safecall;
007    function Get_Language: WideString; safecall;
008    procedure Set_Language(Value: WideString); safecall;
009    function Get_TimeBias: Double; safecall;
010    function getName(ID: OleVariant): WideString; safecall;
011    function getDescription(ID: OleVariant): WideString; safecall;
012    function getPropValue(const ClassName: WideString; const PropName: WideString;
013      ID: OleVariant): OleVariant; safecall;
014    procedure setPropValue(const ClassName: WideString; const PropName: WideString;
015      ID: OleVariant; Value: OleVariant); safecall;
016    procedure getPropValues(const ClassName: WideString;
017      const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
018      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
019    procedure setPropValues(const ClassName: WideString;
020      const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
021      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
022    function createDataSet(const TargetClassName: WideString): IContextDataSet; safecall;
023    function select(const ClassName: WideString; QueryItems: OleVariant): IDispatch; safecall;
024    function executeMethod(const ClassName: WideString;
025      const MethodName: WideString; Params: OleVariant): OleVariant; safecall;
026    function getClass(const ClassName: WideString): WideString; safecall;
027    function enumerationItem(ItemIdentifier: OleVariant): WideString; safecall;
028    function getResource(const Name: WideString): WideString; safecall;
029    function bulkInsert(const ClassName: WideString;
030      const Data: IDispatch): IContextDataSet; safecall;
031    function PreProcessScript(const Script: WideString; Indent: WordBool;
032      const CommentMark: WideString): WideString; safecall;
033    function executeReport(const ClassName: WideString;
034      const TemplateName: WideString; Params: OleVariant): IDispatch; safecall;
035    procedure saveReport(const ClassName: WideString;
036      const TemplateName: WideString; Params: OleVariant; const FileName: WideString); safecall;
037    function Get_Variable(const Name: WideString; Persistent: WordBool): OleVariant; safecall;
038    procedure Set_Variable(const Name: WideString; Persistent: WordBool;
039      Value: OleVariant); safecall;
040    function DebugString(const Message: WideString): WideString; safecall;
041    procedure raiseManagedException(const ExceptionMessage: WideString); safecall;
042    function createGUID: WideString; safecall;
043    function getTempFileName(const Extension: WideString): WideString; safecall;
044    function HasUI: WordBool; safecall;
045    function Handle: Integer; safecall;
046    procedure processStart(const Description: WideString; ItemCount: Integer;
047      CanAbort: WordBool); safecall;
048    function processStep: WordBool; safecall;
049    procedure processStop; safecall;
050    procedure Sleep(MSecs: Integer); safecall;
051    function executeConsoleProcess(const CommandLine: WideString;
052      MaxDuration: Integer; const OutputData: OleVariant): Integer; safecall;
053    function downloadData(const Host: WideString; const Url: WideString;
054      const UserName: WideString; const Password: WideString;
055      NegotiateAuth: WordBool; PostData: OleVariant;
056      const PostContentType: WideString; PostDataIsBinary: WordBool;
057      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant; safecall;
058    function LineBreak: WideString; safecall;
059    function Transliterate(const Value: WideString): WideString; safecall;
060    procedure CompareLists(var List1: OleVariant; var List2: OleVariant;
061      const Delimiter: WideString; CaseSensitive: WordBool); safecall;
062    function parseJSON(const JSON: WideString): WideString; safecall;
063    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch; safecall;
064    function createBinaryData: IDispatch; safecall;
065    function getCRC(Data: OleVariant): WideString; safecall;
066    function buildNamedFile(const Data: IDispatch;
067      const StoredFileName: WideString; Propmpt: WordBool;
068      Compress: WordBool): IDispatch; safecall;
069    procedure parseNamedFile(NamedFile: OleVariant; out FileName: OleVariant;
070      out Data: OleVariant); safecall;
071    function createRaster: IDispatch; safecall;
072    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
073    function getOleObject(const ClassID: WideString;
074      const AccessibleFileName: WideString): IDispatch; safecall;
075    function PlaceDataSet(const Range: IDispatch; const DataSet: IContextDataSet;
076      ShiftRows: WordBool; ShiftColumns: WordBool): Integer; safecall;
077    procedure ExportObject(var Document: OleVariant; const ID: WideString;
078      const ClassID: WideString); safecall;
079    function createZIPArchive: IDispatch; safecall;
080    function callRoutine(const ClassName: WideString;
081      const RoutineName: WideString; var RetValue: OleVariant;
082      const ScriptPart: OleVariant): WordBool; safecall;
083    function selectVaue(const ClassDomain: WideString;
084      const ExpressionContext: IUnknown; var Value: OleVariant): WordBool; safecall;
085    function editValues(const ValuesList: WideString; const Title: WideString;
086      UseTabs: WordBool; HideOKButton: WordBool;
087      const ScriptPart: OleVariant): WordBool; safecall;
088    function MsgBox(const Prompt: WideString; Buttons: LongWord;
089      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
090    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
091      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
092    procedure showView(const ViewName: WideString; Key: OleVariant;
093      const DetailPropertyName: WideString); safecall;
094    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
095      ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
096      TakeActionsFromView: OleVariant); safecall;
097    procedure SaveExternalDataToFolder(const Resource: WideString;
098      const Folder: WideString); safecall;
099    function PerformAsyncTask(ID: OleVariant): WordBool; safecall;
100    procedure RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
101      ThreadCount: Integer); safecall;
102    function MainHandle: Integer; safecall;
103    function IsHTMLDocumentSafe(const HTML: WideString): WordBool; safecall;
104    function EnsafeHTMLDocument(const HTML: WideString; RemoveHead: WordBool;
105      Format: WordBool; PureXML: WordBool): WideString; safecall;
106    property ContextObject: IDispatch read Get_ContextObject;
107    property UserName: WideString read Get_UserName;
108    property NegotiateAuth: WordBool read Get_NegotiateAuth;
109    property Language: WideString read Get_Language write Set_Language;
110    property TimeBias: Double read Get_TimeBias;
111    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant
112      read Get_Variable write Set_Variable;
113  end;
9.3.10.4.1. Свойства

Свойства интерфейса IContext:

Имя

Тип

Доступ

Назначение

ContextObject

IDispatch

Только для чтения

Language

WideString

Чтение/Запись

NegotiateAuth

WordBool

Только для чтения

TimeBias

Double

Только для чтения

UserName

WideString

Только для чтения

Variable[const Name: WideString, Persistent: WordBool]

OleVariant

Чтение/Запись

9.3.10.4.2. Метод BinaryToBitmap

Метод интерфейса IContext.
function IContext.BinaryToBitmap(const Data: IDispatch): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Data

IDispatch

Да

Замечания:

Возвращает значение типа IDispatch.

9.3.10.4.3. Метод buildNamedFile

Метод интерфейса IContext.
1function IContext.buildNamedFile(const Data: IDispatch;
2  const StoredFileName: WideString; Propmpt: WordBool;
3  Compress: WordBool): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Data

IDispatch

Да

StoredFileName

WideString

Да

Propmpt

WordBool

Да

Compress

WordBool

Да

Замечания:

Возвращает значение типа IDispatch.

9.3.10.4.4. Метод bulkInsert

Метод интерфейса IContext.
1function IContext.bulkInsert(const ClassName: WideString;
2  const Data: IDispatch): IContextDataSet;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

Data

IDispatch

Да

Замечания:

Возвращает значение типа IContextDataSet.

9.3.10.4.5. Метод callRoutine

Метод интерфейса IContext.
1function IContext.callRoutine(const ClassName: WideString;
2  const RoutineName: WideString; var RetValue: OleVariant;
3  const ScriptPart: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

RoutineName

WideString

Да

RetValue

OleVariant

Нет

ScriptPart

OleVariant

Нет

Замечания:

Возвращает значение типа WordBool.

9.3.10.4.6. Метод CompareLists

Метод интерфейса IContext.
1procedure IContext.CompareLists(var List1: OleVariant; var List2: OleVariant;
2  const Delimiter: WideString; CaseSensitive: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

List1

OleVariant

Да

List2

OleVariant

Да

Delimiter

WideString

Да

CaseSensitive

WordBool

Да

9.3.10.4.7. Метод ConvertExcel

Метод интерфейса IContext.
1function IContext.ConvertExcel(Source: OleVariant;
2  const Format: WideString): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Source

OleVariant

Да

Format

WideString

Да

Замечания:

Возвращает значение типа IDispatch.

9.3.10.4.8. Метод createBinaryData

Метод интерфейса IContext.
function IContext.createBinaryData: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

9.3.10.4.9. Метод createDataSet

Метод интерфейса IContext.
function IContext.createDataSet(const TargetClassName: WideString): IContextDataSet;
Параметры:

Имя

Тип

Обязательно

Значение

TargetClassName

WideString

Да

Замечания:

Возвращает значение типа IContextDataSet.

9.3.10.4.10. Метод createGUID

Метод интерфейса IContext.
function IContext.createGUID: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

9.3.10.4.11. Метод createRaster

Метод интерфейса IContext.
function IContext.createRaster: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

9.3.10.4.12. Метод createZIPArchive

Метод интерфейса IContext.
function IContext.createZIPArchive: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

9.3.10.4.13. Метод DebugString

Метод интерфейса IContext.
function IContext.DebugString(const Message: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Message

WideString

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.4.14. Метод downloadData

Метод интерфейса IContext.
1function IContext.downloadData(const Host: WideString; const Url: WideString;
2  const UserName: WideString; const Password: WideString;
3  NegotiateAuth: WordBool; PostData: OleVariant;
4  const PostContentType: WideString; PostDataIsBinary: WordBool;
5  CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

Host

WideString

Да

Url

WideString

Да

UserName

WideString

Да

Password

WideString

Да

NegotiateAuth

WordBool

Да

PostData

OleVariant

Да

PostContentType

WideString

Да

PostDataIsBinary

WordBool

Да

CanCache

WordBool

Да

NewSession

WordBool

Да

TimeOut

Integer

Да

Замечания:

Возвращает значение типа OleVariant.

9.3.10.4.15. Метод editValues

Метод интерфейса IContext.
1function IContext.editValues(const ValuesList: WideString;
2  const Title: WideString; UseTabs: WordBool; HideOKButton: WordBool;
3  const ScriptPart: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ValuesList

WideString

Да

Title

WideString

Да

UseTabs

WordBool

Да

HideOKButton

WordBool

Да

ScriptPart

OleVariant

Нет

Замечания:

Возвращает значение типа WordBool.

9.3.10.4.16. Метод EnsafeHTMLDocument

Метод интерфейса IContext.
1function IContext.EnsafeHTMLDocument(const HTML: WideString;
2  RemoveHead: WordBool; Format: WordBool; PureXML: WordBool): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

HTML

WideString

Да

RemoveHead

WordBool

Да

Format

WordBool

Да

PureXML

WordBool

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.4.17. Метод enumerationItem

Метод интерфейса IContext.
function IContext.enumerationItem(ItemIdentifier: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ItemIdentifier

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.4.18. Метод executeConsoleProcess

Метод интерфейса IContext.
1function IContext.executeConsoleProcess(const CommandLine: WideString;
2  MaxDuration: Integer; const OutputData: OleVariant): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

CommandLine

WideString

Да

MaxDuration

Integer

Да

OutputData

OleVariant

Да

Замечания:

Возвращает значение типа Integer.

9.3.10.4.19. Метод executeMethod

Метод интерфейса IContext.
1function IContext.executeMethod(const ClassName: WideString;
2  const MethodName: WideString; Params: OleVariant): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

MethodName

WideString

Да

Params

OleVariant

Да

Замечания:

Возвращает значение типа OleVariant.

9.3.10.4.20. Метод executeReport

Метод интерфейса IContext.
1function IContext.executeReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

TemplateName

WideString

Да

Params

OleVariant

Да

Замечания:

Возвращает значение типа IDispatch.

9.3.10.4.21. Метод ExportObject

Метод интерфейса IContext.
1procedure IContext.ExportObject(var Document: OleVariant; const ID: WideString;
2  const ClassID: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Document

OleVariant

Да

ID

WideString

Да

ClassID

WideString

Да

9.3.10.4.22. Метод getClass

Метод интерфейса IContext.
function IContext.getClass(const ClassName: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.4.23. Метод getCRC

Метод интерфейса IContext.
function IContext.getCRC(Data: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.4.24. Метод getDescription

Метод интерфейса IContext.
function IContext.getDescription(ID: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ID

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.4.25. Метод getName

Метод интерфейса IContext.
function IContext.getName(ID: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ID

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.4.26. Метод getOleObject

Метод интерфейса IContext.
1function IContext.getOleObject(const ClassID: WideString;
2  const AccessibleFileName: WideString): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

ClassID

WideString

Да

AccessibleFileName

WideString

Да

Замечания:

Возвращает значение типа IDispatch.

9.3.10.4.27. Метод getPropValue

Метод интерфейса IContext.
1function IContext.getPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

ID

OleVariant

Да

Замечания:

Возвращает значение типа OleVariant.

9.3.10.4.28. Метод getPropValues

Метод интерфейса IContext.
1procedure IContext.getPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

IDS

OleVariant

Да

OnValueEvent

OleVariant

Да

ThreadCount

Integer

Да

ThreadSafe

WordBool

Да

9.3.10.4.29. Метод getResource

Метод интерфейса IContext.
function IContext.getResource(const Name: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.4.30. Метод getTempFileName

Метод интерфейса IContext.
function IContext.getTempFileName(const Extension: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Extension

WideString

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.4.31. Метод Handle

Метод интерфейса IContext.
function IContext.Handle: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.3.10.4.32. Метод HasUI

Метод интерфейса IContext.
function IContext.HasUI: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

9.3.10.4.33. Метод IsHTMLDocumentSafe

Метод интерфейса IContext.
function IContext.IsHTMLDocumentSafe(const HTML: WideString): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

HTML

WideString

Да

Замечания:

Возвращает значение типа WordBool.

9.3.10.4.34. Метод LineBreak

Метод интерфейса IContext.
function IContext.LineBreak: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

9.3.10.4.35. Метод MainHandle

Метод интерфейса IContext.
function IContext.MainHandle: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.3.10.4.36. Метод MsgBox

Метод интерфейса IContext.
1function IContext.MsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

Prompt

WideString

Да

Buttons

LongWord

Нет

Title

WideString

Нет

HelpFile

WideString

Нет

Context

LongWord

Нет

Замечания:

Возвращает значение типа Integer.

9.3.10.4.37. Метод parseJSON

Метод интерфейса IContext.
function IContext.parseJSON(const JSON: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

JSON

WideString

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.4.38. Метод parseNamedFile

Метод интерфейса IContext.
1procedure IContext.parseNamedFile(NamedFile: OleVariant;
2  out FileName: OleVariant; out Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

NamedFile

OleVariant

Да

FileName

OleVariant

Да

Data

OleVariant

Да

9.3.10.4.39. Метод PerformAsyncTask

Метод интерфейса IContext.
function IContext.PerformAsyncTask(ID: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ID

OleVariant

Да

Замечания:

Возвращает значение типа WordBool.

9.3.10.4.40. Метод PlaceDataSet

Метод интерфейса IContext.
1function IContext.PlaceDataSet(const Range: IDispatch;
2  const DataSet: IContextDataSet; ShiftRows: WordBool;
3  ShiftColumns: WordBool): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

Range

IDispatch

Да

DataSet

IContextDataSet

Да

ShiftRows

WordBool

Нет

ShiftColumns

WordBool

Нет

Замечания:

Возвращает значение типа Integer.

9.3.10.4.41. Метод PreProcessScript

Метод интерфейса IContext.
1function IContext.PreProcessScript(const Script: WideString; Indent: WordBool;
2  const CommentMark: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Script

WideString

Да

Indent

WordBool

Да

CommentMark

WideString

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.4.42. Метод processStart

Метод интерфейса IContext.
1procedure IContext.processStart(const Description: WideString;
2  ItemCount: Integer; CanAbort: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Description

WideString

Да

ItemCount

Integer

Нет

CanAbort

WordBool

Нет

9.3.10.4.43. Метод processStep

Метод интерфейса IContext.
function IContext.processStep: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

9.3.10.4.44. Метод processStop

Метод интерфейса IContext.
procedure IContext.processStop;
Метод не имеет параметров.

9.3.10.4.45. Метод raiseManagedException

Метод интерфейса IContext.
procedure IContext.raiseManagedException(const ExceptionMessage: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

ExceptionMessage

WideString

Да

9.3.10.4.46. Метод RebuildTextIndex

Метод интерфейса IContext.
1procedure IContext.RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
2  ThreadCount: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

ClassID

OleVariant

Да

FieldID

OleVariant

Да

ThreadCount

Integer

Да

9.3.10.4.47. Метод SaveExternalDataToFolder

Метод интерфейса IContext.
1procedure IContext.SaveExternalDataToFolder(const Resource: WideString;
2  const Folder: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Resource

WideString

Да

Folder

WideString

Да

9.3.10.4.48. Метод saveReport

Метод интерфейса IContext.
1procedure IContext.saveReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant; const FileName: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

TemplateName

WideString

Да

Params

OleVariant

Да

FileName

WideString

Да

9.3.10.4.49. Метод select

Метод интерфейса IContext.
1function IContext.select(const ClassName: WideString;
2  QueryItems: OleVariant): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

QueryItems

OleVariant

Да

Замечания:

Возвращает значение типа IDispatch.

9.3.10.4.50. Метод selectVaue

Метод интерфейса IContext.
1function IContext.selectVaue(const ClassDomain: WideString;
2  const ExpressionContext: IUnknown; var Value: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ClassDomain

WideString

Да

ExpressionContext

IUnknown

Да

Value

OleVariant

Да

Замечания:

Возвращает значение типа WordBool.

9.3.10.4.51. Метод setPropValue

Метод интерфейса IContext.
1procedure IContext.setPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant; Value: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

ID

OleVariant

Да

Value

OleVariant

Да

9.3.10.4.52. Метод setPropValues

Метод интерфейса IContext.
1procedure IContext.setPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

IDS

OleVariant

Да

OnValueNeededEvent

OleVariant

Да

ThreadCount

Integer

Да

ThreadSafe

WordBool

Да

9.3.10.4.53. Метод showDataSet

Метод интерфейса IContext.
1procedure IContext.showDataSet(const DataSet: ContextDataSet;
2  const Caption: WideString; ColumnCaptions: OleVariant;
3  ColumnOnChangeHandlers: OleVariant; TakeActionsFromView: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

DataSet

ContextDataSet

Да

Caption

WideString

Да

ColumnCaptions

OleVariant

Да

ColumnOnChangeHandlers

OleVariant

Да

TakeActionsFromView

OleVariant

Да

9.3.10.4.54. Метод ShowMsgBox

Метод интерфейса IContext.
1function IContext.ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

Prompt

WideString

Да

Buttons

LongWord

Нет

Title

WideString

Нет

HelpFile

WideString

Нет

Context

LongWord

Нет

Замечания:

Возвращает значение типа Integer.

9.3.10.4.55. Метод showView

Метод интерфейса IContext.
1procedure IContext.showView(const ViewName: WideString; Key: OleVariant;
2  const DetailPropertyName: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

ViewName

WideString

Да

Key

OleVariant

Да

DetailPropertyName

WideString

Да

9.3.10.4.56. Метод Sleep

Метод интерфейса IContext.
procedure IContext.Sleep(MSecs: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

MSecs

Integer

Да

9.3.10.4.57. Метод Transliterate

Метод интерфейса IContext.
function IContext.Transliterate(const Value: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Value

WideString

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.5. Интерфейс IContextDataSet
01type
02  IContextDataSet = interface(IDispatch)
03    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
04    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
05      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant); safecall;
06    function Eof: WordBool; safecall;
07    function Field(const Name: WideString): OleVariant; safecall;
08    function FieldCount: Integer; safecall;
09    function FieldName(Index: Integer): WideString; safecall;
10    procedure Next; safecall;
11    procedure Split(OnRowEvent: OleVariant; ChunkSize: Integer;
12      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
13    function AsJSON: WideString; safecall;
14    function AsXML: WideString; safecall;
15    function AsBinaryData: IDispatch; safecall;
16  end;
9.3.10.5.1. Метод AddQueryItem

Метод интерфейса IContextDataSet.
1procedure IContextDataSet.AddQueryItem(Part: TQueryPart;
2  const Name: WideString; Value: OleVariant; Special: TQuerySpecial;
3  Context: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Part

TQueryPart

Да

Name

WideString

Да

Value

OleVariant

Нет

Special

TQuerySpecial

Нет

Context

OleVariant

Нет

9.3.10.5.2. Метод AsBinaryData

Метод интерфейса IContextDataSet.
function IContextDataSet.AsBinaryData: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

9.3.10.5.3. Метод AsJSON

Метод интерфейса IContextDataSet.
function IContextDataSet.AsJSON: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

9.3.10.5.4. Метод AsXML

Метод интерфейса IContextDataSet.
function IContextDataSet.AsXML: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

9.3.10.5.5. Метод Eof

Метод интерфейса IContextDataSet.
function IContextDataSet.Eof: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

9.3.10.5.6. Метод Field

Метод интерфейса IContextDataSet.
function IContextDataSet.Field(const Name: WideString): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа OleVariant.

9.3.10.5.7. Метод FieldCount

Метод интерфейса IContextDataSet.
function IContextDataSet.FieldCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.3.10.5.8. Метод FieldName

Метод интерфейса IContextDataSet.
function IContextDataSet.FieldName(Index: Integer): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Index

Integer

Да

Замечания:

Возвращает значение типа WideString.

9.3.10.5.9. Метод Next

Метод интерфейса IContextDataSet.
procedure IContextDataSet.Next;
Метод не имеет параметров.

9.3.10.5.10. Метод Split

Метод интерфейса IContextDataSet.
1procedure IContextDataSet.Split(OnRowEvent: OleVariant; ChunkSize: Integer;
2  ThreadCount: Integer; ThreadSafe: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

OnRowEvent

OleVariant

Да

ChunkSize

Integer

Да

ThreadCount

Integer

Да

ThreadSafe

WordBool

Да

9.3.10.6. Интерфейс IContextExpressionInfo
1type
2  IContextExpressionInfo = interface(IUnknown)
3    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
4    function LookupExpressionContext(const Identifier: WideString;
5      out DomainID: WideString; out Value: WideString): WordBool; safecall;
6    procedure SerializeExpressionContext(const RootNode: IDispatch); safecall;
7  end;
9.3.10.6.1. Метод LookupExpressionContext

Метод интерфейса IContextExpressionInfo.
1function IContextExpressionInfo.LookupExpressionContext(const Identifier: WideString;
2  out DomainID: WideString; out Value: WideString): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

Identifier

WideString

Да

DomainID

WideString

Да

Value

WideString

Да

Замечания:

Возвращает значение типа WordBool.

9.3.10.6.2. Метод SerializeExpressionContext

Метод интерфейса IContextExpressionInfo.
procedure IContextExpressionInfo.SerializeExpressionContext(const RootNode: IDispatch);
Параметры:

Имя

Тип

Обязательно

Значение

RootNode

IDispatch

Да

9.3.10.7. Интерфейс IControl
01type
02  IControl = interface(IDispatch)
03    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
04    function Name: WideString; safecall;
05    function Get_Value: OleVariant; safecall;
06    procedure Set_Value(Value: OleVariant); safecall;
07    function Get_ReadOnly: WordBool; safecall;
08    procedure Set_ReadOnly(Value: WordBool); safecall;
09    function Get_IsValid: WordBool; safecall;
10    procedure Set_IsValid(Value: WordBool); safecall;
11    function Get_IsEmpty: WordBool; safecall;
12    procedure SetHint(const Value: WideString); safecall;
13    procedure RefreshLinkedView; safecall;
14    function Get_Visible: WordBool; safecall;
15    property Value: OleVariant read Get_Value write Set_Value;
16    property ReadOnly: WordBool read Get_ReadOnly write Set_ReadOnly;
17    property IsValid: WordBool read Get_IsValid write Set_IsValid;
18    property IsEmpty: WordBool read Get_IsEmpty;
19    property Visible: WordBool read Get_Visible;
20  end;
9.3.10.7.1. Свойства

Свойства интерфейса IControl:

Имя

Тип

Доступ

Назначение

IsEmpty

WordBool

Только для чтения

IsValid

WordBool

Чтение/Запись

ReadOnly

WordBool

Чтение/Запись

Value

OleVariant

Чтение/Запись

Visible

WordBool

Только для чтения

9.3.10.7.2. Метод Name

Метод интерфейса IControl.
function IControl.Name: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

9.3.10.7.3. Метод RefreshLinkedView

Метод интерфейса IControl.
procedure IControl.RefreshLinkedView;
Метод не имеет параметров.

9.3.10.7.4. Метод SetHint

Метод интерфейса IControl.
procedure IControl.SetHint(const Value: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Value

WideString

Да

9.3.10.8. Интерфейс IExceptionHandler
1type
2  IExceptionHandler = interface(IDispatch)
3    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
4    procedure HandleException(ContextObject: OleVariant; const Message: WideString;
5      const ExtentedInfo: WideString; SupportServiceData: OleVariant); safecall;
6  end;
9.3.10.8.1. Метод HandleException

Метод интерфейса IExceptionHandler.
1procedure IExceptionHandler.HandleException(ContextObject: OleVariant;
2  const Message: WideString; const ExtentedInfo: WideString;
3  SupportServiceData: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

ContextObject

OleVariant

Да

Message

WideString

Да

ExtentedInfo

WideString

Да

SupportServiceData

OleVariant

Да

9.3.10.9. Интерфейс IExternalContext
1type
2  IExternalContext = interface(IDispatch)
3    ['{EA2F1CDA-53F6-40E9-A2B7-0A80AB84D177}']
4    procedure Connect(const Database: WideString); safecall;
5  end;
9.3.10.9.1. Метод Connect

Метод интерфейса IExternalContext.
procedure IExternalContext.Connect(const Database: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Database

WideString

Да

9.3.10.10. Интерфейс IFormContext
01type
02  IFormContext = interface(IDispatch)
03    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
04    function ID: WideString; safecall;
05    function RoutineID: WideString; safecall;
06    function ControlCount: Integer; safecall;
07    function Get_Controls(Name: OleVariant): IControl; safecall;
08    function ControlExists(const Name: WideString): WordBool; safecall;
09    function ButtonCount: Integer; safecall;
10    function Get_Buttons(Name: OleVariant): IButton; safecall;
11    function Get_Enabled: WordBool; safecall;
12    procedure Set_Enabled(Value: WordBool); safecall;
13    function ChangedControl: OleVariant; safecall;
14    function ChangedControlName: WideString; safecall;
15    procedure Cancel; safecall;
16    function ParentForm: OleVariant; safecall;
17    procedure PreInitControl(const Name: WideString; Value: OleVariant); safecall;
18    procedure NavigatorNext; safecall;
19    procedure NavigatorPrevious; safecall;
20    function NavigatorCanNext: WordBool; safecall;
21    function NavigatorCanPrevious: WordBool; safecall;
22    procedure RefreshView(RefreshAll: WordBool); safecall;
23    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
24    property Controls[Name: OleVariant]: IControl read Get_Controls;
25    property Buttons[Name: OleVariant]: IButton read Get_Buttons;
26    property Enabled: WordBool read Get_Enabled write Set_Enabled;
27  end;
9.3.10.10.1. Свойства

Свойства интерфейса IFormContext:

Имя

Тип

Доступ

Назначение

Buttons[Name: OleVariant]

IButton

Только для чтения

Controls[Name: OleVariant]

IControl

Только для чтения

Enabled

WordBool

Чтение/Запись

9.3.10.10.2. Метод ButtonCount

Метод интерфейса IFormContext.
function IFormContext.ButtonCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.3.10.10.3. Метод Cancel

Метод интерфейса IFormContext.
procedure IFormContext.Cancel;
Метод не имеет параметров.

9.3.10.10.4. Метод ChangedControl

Метод интерфейса IFormContext.
function IFormContext.ChangedControl: OleVariant;
Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

9.3.10.10.5. Метод ChangedControlName

Метод интерфейса IFormContext.
function IFormContext.ChangedControlName: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

9.3.10.10.6. Метод ControlCount

Метод интерфейса IFormContext.
function IFormContext.ControlCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.3.10.10.7. Метод ControlExists

Метод интерфейса IFormContext.
function IFormContext.ControlExists(const Name: WideString): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа WordBool.

9.3.10.10.8. Метод ExpressionContextValue

Метод интерфейса IFormContext.
function IFormContext.ExpressionContextValue(const Name: WideString): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа OleVariant.

9.3.10.10.9. Метод ID

Метод интерфейса IFormContext.
function IFormContext.ID: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

9.3.10.10.10. Метод NavigatorCanNext

Метод интерфейса IFormContext.
function IFormContext.NavigatorCanNext: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

9.3.10.10.11. Метод NavigatorCanPrevious

Метод интерфейса IFormContext.
function IFormContext.NavigatorCanPrevious: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

9.3.10.10.12. Метод NavigatorNext

Метод интерфейса IFormContext.
procedure IFormContext.NavigatorNext;
Метод не имеет параметров.

9.3.10.10.13. Метод NavigatorPrevious

Метод интерфейса IFormContext.
procedure IFormContext.NavigatorPrevious;
Метод не имеет параметров.

9.3.10.10.14. Метод ParentForm

Метод интерфейса IFormContext.
function IFormContext.ParentForm: OleVariant;
Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

9.3.10.10.15. Метод PreInitControl

Метод интерфейса IFormContext.
procedure IFormContext.PreInitControl(const Name: WideString; Value: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Value

OleVariant

Да

9.3.10.10.16. Метод RefreshView

Метод интерфейса IFormContext.
procedure IFormContext.RefreshView(RefreshAll: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

RefreshAll

WordBool

Да

9.3.10.10.17. Метод RoutineID

Метод интерфейса IFormContext.
function IFormContext.RoutineID: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

9.3.10.11. Интерфейс IRaster
01type
02  IRaster = interface(IDispatch)
03    ['{4F27D016-03C2-4D48-ABF7-FD547E859F79}']
04    function Get_Width: Integer; safecall;
05    procedure Set_Width(Value: Integer); safecall;
06    function Get_Height: Integer; safecall;
07    procedure Set_Height(Value: Integer); safecall;
08    function Get_DefaultColor: Integer; safecall;
09    procedure Set_DefaultColor(Value: Integer); safecall;
10    procedure Load(Src: OleVariant); safecall;
11    procedure SaveBitmap(Dst: OleVariant); safecall;
12    procedure SavePNG(Dst: OleVariant); safecall;
13    procedure SaveJPG(Dst: OleVariant; Quality: Integer); safecall;
14    procedure FlipVertical; safecall;
15    procedure FlipHorizontal; safecall;
16    procedure Rotate; safecall;
17    procedure Resize(NewWidth: Integer; NewHeight: Integer; Center: WordBool); safecall;
18    procedure Stretch(NewWidth: Integer; NewHeight: Integer); safecall;
19    procedure StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
20      MaxSize: OleVariant); safecall;
21    procedure Overlay(Src: OleVariant; X: Integer; Y: Integer; Width: Integer;
22      Height: Integer); safecall;
23    property Width: Integer read Get_Width write Set_Width;
24    property Height: Integer read Get_Height write Set_Height;
25    property DefaultColor: Integer read Get_DefaultColor write Set_DefaultColor;
26  end;
9.3.10.11.1. Свойства

Свойства интерфейса IRaster:

Имя

Тип

Доступ

Назначение

DefaultColor

Integer

Чтение/Запись

Height

Integer

Чтение/Запись

Width

Integer

Чтение/Запись

9.3.10.11.2. Метод FlipHorizontal

Метод интерфейса IRaster.
procedure IRaster.FlipHorizontal;
Метод не имеет параметров.

9.3.10.11.3. Метод FlipVertical

Метод интерфейса IRaster.
procedure IRaster.FlipVertical;
Метод не имеет параметров.

9.3.10.11.4. Метод Load

Метод интерфейса IRaster.
procedure IRaster.Load(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

9.3.10.11.5. Метод Overlay

Метод интерфейса IRaster.
1procedure IRaster.Overlay(Src: OleVariant; X: Integer; Y: Integer;
2  Width: Integer; Height: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

X

Integer

Да

Y

Integer

Да

Width

Integer

Да

Height

Integer

Да

9.3.10.11.6. Метод Resize

Метод интерфейса IRaster.
1procedure IRaster.Resize(NewWidth: Integer; NewHeight: Integer;
2  Center: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

NewWidth

Integer

Да

NewHeight

Integer

Да

Center

WordBool

Да

9.3.10.11.7. Метод Rotate

Метод интерфейса IRaster.
procedure IRaster.Rotate;
Метод не имеет параметров.

9.3.10.11.8. Метод SaveBitmap

Метод интерфейса IRaster.
procedure IRaster.SaveBitmap(Dst: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

9.3.10.11.9. Метод SaveJPG

Метод интерфейса IRaster.
procedure IRaster.SaveJPG(Dst: OleVariant; Quality: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

Quality

Integer

Да

9.3.10.11.10. Метод SavePNG

Метод интерфейса IRaster.
procedure IRaster.SavePNG(Dst: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

9.3.10.11.11. Метод Stretch

Метод интерфейса IRaster.
procedure IRaster.Stretch(NewWidth: Integer; NewHeight: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

NewWidth

Integer

Да

NewHeight

Integer

Да

9.3.10.11.12. Метод StretchToSize

Метод интерфейса IRaster.
1procedure IRaster.StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
2  MaxSize: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

MaxWidth

OleVariant

Да

MaxHeight

OleVariant

Да

MaxSize

OleVariant

Да

9.3.10.12. Интерфейс IScannerTools
1type
2  IScannerTools = interface(IDispatch)
3    ['{FC1B3C9F-7DE9-4909-B57D-6D33E3B0A87A}']
4    function AcquireImage(Silent: WordBool): IDispatch; safecall;
5    function AcquirePDF: IDispatch; safecall;
6  end;
9.3.10.12.1. Метод AcquireImage

Метод интерфейса IScannerTools.
function IScannerTools.AcquireImage(Silent: WordBool): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Silent

WordBool

Да

Замечания:

Возвращает значение типа IDispatch.

9.3.10.12.2. Метод AcquirePDF

Метод интерфейса IScannerTools.
function IScannerTools.AcquirePDF: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

9.3.10.13. Интерфейс ISetOfObjectsEditor
1type
2  ISetOfObjectsEditor = interface(IDispatch)
3    ['{6D3662A7-D9FF-4BD6-8D92-A4EA2058C74E}']
4    function Get_DomainName: WideString; safecall;
5    procedure Set_DomainName(Value: WideString); safecall;
6    function Get_SelectedCount: Integer; safecall;
7    property DomainName: WideString read Get_DomainName write Set_DomainName;
8    property SelectedCount: Integer read Get_SelectedCount;
9  end;
9.3.10.13.1. Свойства

Свойства интерфейса ISetOfObjectsEditor:

Имя

Тип

Доступ

Назначение

DomainName

WideString

Чтение/Запись

SelectedCount

Integer

Только для чтения

9.3.10.14. Интерфейс IZIPArchive
01type
02  IZIPArchive = interface(IDispatch)
03    ['{11C9400F-F262-4F72-882F-5AA5A4531591}']
04    procedure Load(Src: OleVariant); safecall;
05    procedure Save(Src: OleVariant); safecall;
06    function Get_FileCount: Integer; safecall;
07    function Get_FileName(Index: Integer): WideString; safecall;
08    function Get_FileData(Index: Integer): OleVariant; safecall;
09    procedure AddFile(const FileName: WideString; Data: OleVariant); safecall;
10    function Get_FileSize(Index: Integer): Int64; safecall;
11    function Get_FileDateTime(Index: Integer): TDateTime; safecall;
12    function Get_FileCRC(Index: Integer): WideString; safecall;
13    function Get_UTF8Support: WordBool; safecall;
14    procedure Set_UTF8Support(Value: WordBool); safecall;
15    property FileCount: Integer read Get_FileCount;
16    property FileName[Index: Integer]: WideString read Get_FileName;
17    property FileData[Index: Integer]: OleVariant read Get_FileData;
18    property FileSize[Index: Integer]: Int64 read Get_FileSize;
19    property FileDateTime[Index: Integer]: TDateTime read Get_FileDateTime;
20    property FileCRC[Index: Integer]: WideString read Get_FileCRC;
21    property UTF8Support: WordBool read Get_UTF8Support write Set_UTF8Support;
22  end;
9.3.10.14.1. Свойства

Свойства интерфейса IZIPArchive:

Имя

Тип

Доступ

Назначение

FileCRC[Index: Integer]

WideString

Только для чтения

FileCount

Integer

Только для чтения

FileData[Index: Integer]

OleVariant

Только для чтения

FileDateTime[Index: Integer]

TDateTime

Только для чтения

FileName[Index: Integer]

WideString

Только для чтения

FileSize[Index: Integer]

Int64

Только для чтения

UTF8Support

WordBool

Чтение/Запись

9.3.10.14.2. Метод AddFile

Метод интерфейса IZIPArchive.
procedure IZIPArchive.AddFile(const FileName: WideString; Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

FileName

WideString

Да

Data

OleVariant

Да

9.3.10.14.3. Метод Load

Метод интерфейса IZIPArchive.
procedure IZIPArchive.Load(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

9.3.10.14.4. Метод Save

Метод интерфейса IZIPArchive.
procedure IZIPArchive.Save(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

9.3.11. Дополнительные интерфейсы

9.3.11.1. Интерфейс IBinaryData
01type
02  IBinaryData = interface(IDispatch)
03    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
04    procedure Append(Src: OleVariant); safecall;
05    procedure Load(Src: OleVariant); safecall;
06    procedure Save(Dst: OleVariant); safecall;
07    function Size: LongWord; safecall;
08    procedure AppendData(Data: OleVariant; DataSize: LongWord); safecall;
09    procedure SetData(Data: OleVariant; DataSize: LongWord); safecall;
10    procedure GetData(Data: OleVariant); safecall;
11    function ToString(const Encoding: WideString): WideString; safecall;
12    procedure FromString(Data: OleVariant); safecall;
13    procedure AppendString(Data: OleVariant); safecall;
14    function ToBase64(Width: Integer): WideString; safecall;
15    procedure FromBase64(Data: OleVariant); safecall;
16    function ContentIsText: WordBool; safecall;
17  end;
9.3.11.1.1. Метод Append

Метод интерфейса IBinaryData.
procedure IBinaryData.Append(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

9.3.11.1.2. Метод AppendData

Метод интерфейса IBinaryData.
procedure IBinaryData.AppendData(Data: OleVariant; DataSize: LongWord);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

DataSize

LongWord

Да

9.3.11.1.3. Метод AppendString

Метод интерфейса IBinaryData.
procedure IBinaryData.AppendString(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

9.3.11.1.4. Метод ContentIsText

Метод интерфейса IBinaryData.
function IBinaryData.ContentIsText: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

9.3.11.1.5. Метод FromBase64

Метод интерфейса IBinaryData.
procedure IBinaryData.FromBase64(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

9.3.11.1.6. Метод FromString

Метод интерфейса IBinaryData.
procedure IBinaryData.FromString(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

9.3.11.1.7. Метод GetData

Метод интерфейса IBinaryData.
procedure IBinaryData.GetData(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

9.3.11.1.8. Метод Load

Метод интерфейса IBinaryData.
procedure IBinaryData.Load(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

9.3.11.1.9. Метод Save

Метод интерфейса IBinaryData.
procedure IBinaryData.Save(Dst: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

9.3.11.1.10. Метод SetData

Метод интерфейса IBinaryData.
procedure IBinaryData.SetData(Data: OleVariant; DataSize: LongWord);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

DataSize

LongWord

Да

9.3.11.1.11. Метод Size

Метод интерфейса IBinaryData.
function IBinaryData.Size: LongWord;
Метод не имеет параметров.

Замечания:

Возвращает значение типа LongWord.

9.3.11.1.12. Метод ToBase64

Метод интерфейса IBinaryData.
function IBinaryData.ToBase64(Width: Integer): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Width

Integer

Нет

Замечания:

Возвращает значение типа WideString.

9.3.11.1.13. Метод ToString

Метод интерфейса IBinaryData.
function IBinaryData.ToString(const Encoding: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Encoding

WideString

Да

Замечания:

Возвращает значение типа WideString.

9.4. Справочник по метаданным

9.4.1. Перечисление Resource strings (Ресурсные строки)
01type
02  Resource strings = (rssRole, rssUser, rssIsMemberOf,
03    rssRoleCannotBeMemberOfItself, rssRoleCannotHavePrimaryRole, rssCanUse,
04    rssVirtualException, rssDataBaseIdentifierTooLong,
05    rssDefaultConstructorDescription, rssDefaultConstructorActionDescription,
06    rssDefaultDesctructorActionDescription, rssDefaultExcelActionDescription,
07    rssUsersActivityOn, rssHours, rssLocalCharacters, rssCannotLocalizeClass,
08    rssCannotLocalizeField, rssCannotTranslateUntranslatable,
09    rssCannotSendMessageToNotApprovedContact, rssCannotCreateContactForYourself,
10    rssCannotSendMessageForYourself, rssOverwriteFile, rssOverwriteAccessibleFile,
11    rssReplaceCurrentTemplate, rssReplaceAllImages, rssReplaceAllMethods,
12    rssReplaceAllTemplates, rssLoadingProcess, rssDoNotFogetMacroName,
13    rssCheckOleObjectMethodErrorMethodNotSpecified,
14    rssCheckOleObjectMethodErrorClassIDNotSpecified,
15    rssCheckOleObjectMethodErrorCodeLibraryNotSpecified,
16    rssCheckOleObjectMethodErrorCodeLibraryNotFound,
17    rssCheckOleObjectMethodErrorXMLIsNotValid,
18    rssCheckOleObjectMethodErrorProgIDNotImplemented,
19    rssCheckOleObjectMethodErrorMethodNotImplemented,
20    rssCheckOleObjectMethodErrorNoParameters,
21    rssCheckOleObjectMethodErrorNoIDParameter,
22    rssCheckOleObjectMethodErrorParameterNames,
23    rssCheckOleObjectMethodErrorParameterCount, rssLoadingResources, rssMethodCall,
24    rssDMLOperation, rssReplaceAllBlobsContent,
25    rssCheckXSLTTemplateErrorXMLIsNotValid,
26    rssCheckXSLTTemplateErrorNoTemplateData,
27    rssCheckXSLTTemplateErrorNoIDParameter, rssCheckXSLTTemplateErrorNoParameter,
28    rssCheckXSLTTemplateErrorExcessParameter,
29    rssCheckOleObjectMethodErrorNoFunctionFound,
30    rssCheckExcelTemplateErrorNoTemplateData, rssCheckExcelTemplateErrorNoMacro,
31    rssCheckExcelTemplateErrorNoFunctionFound,
32    rssCheckWordTemplateErrorNoTemplateData, rssCheckWordTemplateErrorNoMacro,
33    rssCheckWordTemplateErrorNoFunctionFound, rssCheckTemplates,
34    rssUnexpectedDatabase, rssCannotSaveDatabaseLanguage, rssDomainNotFound,
35    rssCheckOfficeTemplateErrorMissingParameters,
36    rssCheckOfficeTemplateErrorMissingImplementationParameter,
37    rssCheckOfficeTemplateErrorParametersCountMismatched,
38    rssCheckOfficeTemplateErrorNoFunctionFound,
39    rssCheckOfficeTemplateErrorProjectSyntaxIncorrect,
40    rssCheckOfficeTemplateErrorIncludedModuleNotFound,
41    rssCheckOfficeTemplateWarningMethodBodyTooLong,
42    rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped,
43    rssCheckOfficeTemplateWarningOptionValueIncorrect,
44    rssCannotPerformTaskAlreadyRunning, rssCannotPerformTaskDueToStatus,
45    rssAsyncMethodInstantSuccess, rssAsyncMethodInstantError,
46    rssAsyncReportInstantSuccess, rssAsyncReportInstantError,
47    rssViewCannotContainColumns, rssMasterNotDefined, rssAbstractDomain);
Или
01type
02  Resource strings = TOleEnum;
03const
04  rssRole = $00000000;
05  rssUser = $00000001;
06  rssIsMemberOf = $00000002;
07  rssRoleCannotBeMemberOfItself = $00000003;
08  rssRoleCannotHavePrimaryRole = $00000004;
09  rssCanUse = $00000005;
10  rssVirtualException = $00000006;
11  rssDataBaseIdentifierTooLong = $00000007;
12  rssDefaultConstructorDescription = $00000008;
13  rssDefaultConstructorActionDescription = $00000009;
14  rssDefaultDesctructorActionDescription = $0000000A;
15  rssDefaultExcelActionDescription = $0000000B;
16  rssUsersActivityOn = $0000000C;
17  rssHours = $0000000D;
18  rssLocalCharacters = $0000000E;
19  rssCannotLocalizeClass = $0000000F;
20  rssCannotLocalizeField = $00000010;
21  rssCannotTranslateUntranslatable = $00000011;
22  rssCannotSendMessageToNotApprovedContact = $00000012;
23  rssCannotCreateContactForYourself = $00000013;
24  rssCannotSendMessageForYourself = $00000014;
25  rssOverwriteFile = $00000015;
26  rssOverwriteAccessibleFile = $00000016;
27  rssReplaceCurrentTemplate = $00000017;
28  rssReplaceAllImages = $00000018;
29  rssReplaceAllMethods = $00000019;
30  rssReplaceAllTemplates = $0000001A;
31  rssLoadingProcess = $0000001B;
32  rssDoNotFogetMacroName = $0000001C;
33  rssCheckOleObjectMethodErrorMethodNotSpecified = $0000001D;
34  rssCheckOleObjectMethodErrorClassIDNotSpecified = $0000001E;
35  rssCheckOleObjectMethodErrorCodeLibraryNotSpecified = $0000001F;
36  rssCheckOleObjectMethodErrorCodeLibraryNotFound = $00000020;
37  rssCheckOleObjectMethodErrorXMLIsNotValid = $00000021;
38  rssCheckOleObjectMethodErrorProgIDNotImplemented = $00000022;
39  rssCheckOleObjectMethodErrorMethodNotImplemented = $00000023;
40  rssCheckOleObjectMethodErrorNoParameters = $00000024;
41  rssCheckOleObjectMethodErrorNoIDParameter = $00000025;
42  rssCheckOleObjectMethodErrorParameterNames = $00000026;
43  rssCheckOleObjectMethodErrorParameterCount = $00000027;
44  rssLoadingResources = $00000028;
45  rssMethodCall = $00000029;
46  rssDMLOperation = $0000002A;
47  rssReplaceAllBlobsContent = $0000002B;
48  rssCheckXSLTTemplateErrorXMLIsNotValid = $0000002C;
49  rssCheckXSLTTemplateErrorNoTemplateData = $0000002D;
50  rssCheckXSLTTemplateErrorNoIDParameter = $0000002E;
51  rssCheckXSLTTemplateErrorNoParameter = $0000002F;
52  rssCheckXSLTTemplateErrorExcessParameter = $00000030;
53  rssCheckOleObjectMethodErrorNoFunctionFound = $00000031;
54  rssCheckExcelTemplateErrorNoTemplateData = $00000032;
55  rssCheckExcelTemplateErrorNoMacro = $00000033;
56  rssCheckExcelTemplateErrorNoFunctionFound = $00000034;
57  rssCheckWordTemplateErrorNoTemplateData = $00000035;
58  rssCheckWordTemplateErrorNoMacro = $00000036;
59  rssCheckWordTemplateErrorNoFunctionFound = $00000037;
60  rssCheckTemplates = $00000038;
61  rssUnexpectedDatabase = $00000039;
62  rssCannotSaveDatabaseLanguage = $0000003A;
63  rssDomainNotFound = $0000003B;
64  rssCheckOfficeTemplateErrorMissingParameters = $0000003C;
65  rssCheckOfficeTemplateErrorMissingImplementationParameter = $0000003D;
66  rssCheckOfficeTemplateErrorParametersCountMismatched = $0000003E;
67  rssCheckOfficeTemplateErrorNoFunctionFound = $0000003F;
68  rssCheckOfficeTemplateErrorProjectSyntaxIncorrect = $00000040;
69  rssCheckOfficeTemplateErrorIncludedModuleNotFound = $00000041;
70  rssCheckOfficeTemplateWarningMethodBodyTooLong = $00000042;
71  rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped = $00000043;
72  rssCheckOfficeTemplateWarningOptionValueIncorrect = $00000044;
73  rssCannotPerformTaskAlreadyRunning = $00000045;
74  rssCannotPerformTaskDueToStatus = $00000046;
75  rssAsyncMethodInstantSuccess = $00000047;
76  rssAsyncMethodInstantError = $00000048;
77  rssAsyncReportInstantSuccess = $00000049;
78  rssAsyncReportInstantError = $0000004A;
79  rssViewCannotContainColumns = $0000004B;
80  rssMasterNotDefined = $0000004C;
81  rssAbstractDomain = $0000004D;
Элементы перечисления:

Имя

Значение

Назначение

rssRole

0

Роль

rssUser

1

Пользователь

rssIsMemberOf

2

является членом роли

rssRoleCannotBeMemberOfItself

3

Роль не может включать сама себя.

rssRoleCannotHavePrimaryRole

4

Роль не может иметь основную роль.

rssCanUse

5

использует(ют) объект

rssVirtualException

6

Ошибка вызова виртуального метода.

rssDataBaseIdentifierTooLong

7

Длина имени объекта, отображаемого на объект базы данных, не должна превышать 29 символов

rssDefaultConstructorDescription

8

создание

rssDefaultConstructorActionDescription

9

Создать

rssDefaultDesctructorActionDescription

10

Удалить

rssDefaultExcelActionDescription

11

Перенести в Excel

rssUsersActivityOn

12

Активность пользователей за

rssHours

13

Часы

rssLocalCharacters

14

АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯабвгдеёжзийклмнопрстуфхцчшщъыьэюя

rssCannotLocalizeClass

15

Нельзя локализовать класс

rssCannotLocalizeField

16

Нельзя локализовать поле

rssCannotTranslateUntranslatable

17

Нельзя перевести непереводимый элемент.

rssCannotSendMessageToNotApprovedContact

18

Нельзя отправить сообщение неодобренному контакту.

rssCannotCreateContactForYourself

19

Нельзя создать контакт для самого себя.

rssCannotSendMessageForYourself

20

Нельзя отправить сообщение самому себе.

rssOverwriteFile

21

Заменить содержимое файла "%FileName%"?

rssOverwriteAccessibleFile

22

Заменить содержимое доступного файла "%FileName%"?

rssReplaceCurrentTemplate

23

Заменить содержимое шаблона?

rssReplaceAllImages

24

Заменить содержимое всех изображений?

rssReplaceAllMethods

25

Заменить содержимое всех скриптов и тел методов?

rssReplaceAllTemplates

26

Заменить содержимое всех шаблонов всех отчетов?

rssLoadingProcess

27

Загрузка

rssDoNotFogetMacroName

28

Не забудьте установить имя макроса.

rssCheckOleObjectMethodErrorMethodNotSpecified

29

Имя метода не задано

rssCheckOleObjectMethodErrorClassIDNotSpecified

30

Идентификатор класса не задан

rssCheckOleObjectMethodErrorCodeLibraryNotSpecified

31

Библиотека кода не задана

rssCheckOleObjectMethodErrorCodeLibraryNotFound

32

Невозможно загрузить библиотеку кода "%CodeLibrary%"

rssCheckOleObjectMethodErrorXMLIsNotValid

33

Невалидный XML-документ

rssCheckOleObjectMethodErrorProgIDNotImplemented

34

Указанный ProgID "%ProgID%" не реализован в скриптлете

rssCheckOleObjectMethodErrorMethodNotImplemented

35

Метод не реализован

rssCheckOleObjectMethodErrorNoParameters

36

Метод должен объявлять хотя бы один параметр

rssCheckOleObjectMethodErrorNoIDParameter

37

Метод должен объявлять параметр с именем "ID"

rssCheckOleObjectMethodErrorParameterNames

38

Параметр с именем "%RealName%" не соответствует ожидаемому "%ExpectedName%"

rssCheckOleObjectMethodErrorParameterCount

39

Количество параметров "%RealCount%" в объявлении метода не совпадает с ожидаемым "%ExpectedCount%"

rssLoadingResources

40

Загрузка ресурсов

rssMethodCall

41

Вызов метода

rssDMLOperation

42

Операция с данными

rssReplaceAllBlobsContent

43

Заменить содержимое свойства %Class%.%Description% для всех объектов?

rssCheckXSLTTemplateErrorXMLIsNotValid

44

Невалидный XML-документ

rssCheckXSLTTemplateErrorNoTemplateData

45

Данные шаблона отсутствуют

rssCheckXSLTTemplateErrorNoIDParameter

46

Шаблон XSLT как метод экземпляра должен объявлять параметр "ID"

rssCheckXSLTTemplateErrorNoParameter

47

Параметр "%Name%" не найден в шаблоне

rssCheckXSLTTemplateErrorExcessParameter

48

Параметр шаблона "%Name%" не зарегистрирован в метаданных

rssCheckOleObjectMethodErrorNoFunctionFound

49

Подпрограмма, соответствующая макросу, отсутствует в скриптлете

rssCheckExcelTemplateErrorNoTemplateData

50

Данные шаблона отсутствуют

rssCheckExcelTemplateErrorNoMacro

51

Имя макроса не задано

rssCheckExcelTemplateErrorNoFunctionFound

52

Подпрограмма, соответствующая макросу, отсутствует в проекте VBA

rssCheckWordTemplateErrorNoTemplateData

53

Данные шаблона отсутствуют

rssCheckWordTemplateErrorNoMacro

54

Имя макроса не задано

rssCheckWordTemplateErrorNoFunctionFound

55

Подпрограмма, соответствующая макросу, отсутствует в проекте VBA

rssCheckTemplates

56

Проверка шаблонов

rssUnexpectedDatabase

57

Не поддерживается в этой БД

rssCannotSaveDatabaseLanguage

58

Язык базы данных не может быть сохранен в ресурсный файл.

rssDomainNotFound

59

Домен не найден

rssCheckOfficeTemplateErrorMissingParameters

60

Параметры, не найденные в реализации:

rssCheckOfficeTemplateErrorMissingImplementationParameter

61

Параметр %ParamName% не найден в реализации

rssCheckOfficeTemplateErrorParametersCountMismatched

62

Декларированное и реализованное количество параметров не соответствуют: %DeclaredCount% <> %ImplementedCount%

rssCheckOfficeTemplateErrorNoFunctionFound

63

Указанный макрос %MacroName% не найден

rssCheckOfficeTemplateErrorProjectSyntaxIncorrect

64

VBA проект синтаксически некорректный

rssCheckOfficeTemplateErrorIncludedModuleNotFound

65

Модуль кода %ModuleFileName% (в шаблоне %LinesCount% строк) не найден в Доступных файлах

rssCheckOfficeTemplateWarningMethodBodyTooLong

66

Возможно, тело метода %ProcName% (%ModuleFileName%) чрезмерно длинное (%ProcLineCount% строк)

rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped

67

Синтаксическая проверка проектов VBA не будет произведена, т.к. значение следующих настроек не удовлетворяют требуемым:

rssCheckOfficeTemplateWarningOptionValueIncorrect

68

Неверное значение VBA настройки "%OptionName%" - Включено

rssCannotPerformTaskAlreadyRunning

69

Выполнение невозможно, задача уже выполняется

rssCannotPerformTaskDueToStatus

70

Выполнение невозможно, задача имеет недопустимое состояние

rssAsyncMethodInstantSuccess

71

Метод выполнен

rssAsyncMethodInstantError

72

Ошибка выполнения метода

rssAsyncReportInstantSuccess

73

Отчет сформирован

rssAsyncReportInstantError

74

Ошибка выполнения отчета

rssViewCannotContainColumns

75

Это представление не может содержать колонки.

rssMasterNotDefined

76

Не задан мастер для объекта %Name% (%Description%) класса "%Class%".

rssAbstractDomain

77

Абстрактный домен

9.4.2. Перечисление TAggregateKind (Тип агрегата)
1type
2  TAggregateKind = (agCount = 1, agSumm = 2, agMax = 3, agMin = 4, agAverage = 5,
3    agCountDistinct = 6);
Или
1type
2  TAggregateKind = TOleEnum;
3const
4  agCount = $00000001;
5  agSumm = $00000002;
6  agMax = $00000003;
7  agMin = $00000004;
8  agAverage = $00000005;
9  agCountDistinct = $00000006;
Элементы перечисления:

Имя

Значение

Назначение

agCount

1

Количество

agSumm

2

Сумма

agMax

3

Максимальное значение

agMin

4

Минимальное значение

agAverage

5

Среднее значение

agCountDistinct

6

Количество уникальных

9.4.3. Перечисление TAsyncTaskStatus (Состояние задачи отложенного выполнения)
1type
2  TAsyncTaskStatus = (astCreated, astReady, astRunning, astSuccess, astError);
Или
1type
2  TAsyncTaskStatus = TOleEnum;
3const
4  astCreated = $00000000;
5  astReady = $00000001;
6  astRunning = $00000002;
7  astSuccess = $00000003;
8  astError = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

astCreated

0

Создано

astReady

1

Готово к выполнению

astRunning

2

Выполняется

astSuccess

3

Завершено

astError

4

Прервано

9.4.4. Перечисление TBlobSubtype (Подтип)
1type
2  TBlobSubtype = (btBinaryData, btText, btImage, btSourceCode, btXML,
3    btNamedFile, btVisualBasicScript, btXHTML, btJavaScript, btHTML);
Или
01type
02  TBlobSubtype = TOleEnum;
03const
04  btBinaryData = $00000000;
05  btText = $00000001;
06  btImage = $00000002;
07  btSourceCode = $00000003;
08  btXML = $00000004;
09  btNamedFile = $00000005;
10  btVisualBasicScript = $00000006;
11  btXHTML = $00000007;
12  btJavaScript = $00000008;
13  btHTML = $00000009;
Элементы перечисления:

Имя

Значение

Назначение

btBinaryData

0

Двоичные данные

btText

1

Текст

btImage

2

Изображение

btSourceCode

3

Исходный код

btXML

4

XML-документ

btNamedFile

5

Именованный файл

btVisualBasicScript

6

Скрипт Visual Basic

btXHTML

7

XHTML-документ

btJavaScript

8

Скрипт JavaScript

btHTML

9

HTML-документ

9.4.5. Перечисление TChangeAction (Действие при изменении)
1type
2  TChangeAction = (atCreated, atChanging, atChanged, atDestroying, atPasted);
Или
1type
2  TChangeAction = TOleEnum;
3const
4  atCreated = $00000000;
5  atChanging = $00000001;
6  atChanged = $00000002;
7  atDestroying = $00000003;
8  atPasted = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

atCreated

0

Создан

atChanging

1

Изменится

atChanged

2

Изменен

atDestroying

3

Удаляется

atPasted

4

Вставлен из буфера

9.4.6. Перечисление TComparisonType (Типы сравнения)
1type
2  TComparisonType = (ctEqual, ctNotEqual, ctGreater, ctGreaterOrEqual, ctLess,
3    ctLessOrEqual, ctLike, ctNotLike, ctRegexpLike, ctNotRegexpLike, ctIsParent,
4    ctIsChild);
Или
01type
02  TComparisonType = TOleEnum;
03const
04  ctEqual = $00000000;
05  ctNotEqual = $00000001;
06  ctGreater = $00000002;
07  ctGreaterOrEqual = $00000003;
08  ctLess = $00000004;
09  ctLessOrEqual = $00000005;
10  ctLike = $00000006;
11  ctNotLike = $00000007;
12  ctRegexpLike = $00000008;
13  ctNotRegexpLike = $00000009;
14  ctIsParent = $0000000A;
15  ctIsChild = $0000000B;
Элементы перечисления:

Имя

Значение

Назначение

ctEqual

0

Равно

ctNotEqual

1

Не равно

ctGreater

2

Больше

ctGreaterOrEqual

3

Больше или равно

ctLess

4

Меньше

ctLessOrEqual

5

Меньше или равно

ctLike

6

Подобно

ctNotLike

7

Не подобно

ctRegexpLike

8

Удовлетворяет регулярному выражению

ctNotRegexpLike

9

Не удовлетворяет регулярному выражению

ctIsParent

10

Является родителем

ctIsChild

11

Является потомком

9.4.7. Перечисление TDateTimePart (Часть даты или времени)
1type
2  TDateTimePart = (dpYear, dpMonth, dpDay, dpHour, dpMinute, dpSecond,
3    dpDayOfWeek);
Или
01type
02  TDateTimePart = TOleEnum;
03const
04  dpYear = $00000000;
05  dpMonth = $00000001;
06  dpDay = $00000002;
07  dpHour = $00000003;
08  dpMinute = $00000004;
09  dpSecond = $00000005;
10  dpDayOfWeek = $00000006;
Элементы перечисления:

Имя

Значение

Назначение

dpYear

0

Год

dpMonth

1

Месяц

dpDay

2

День

dpHour

3

Час

dpMinute

4

Минута

dpSecond

5

Секунда

dpDayOfWeek

6

День недели

9.4.8. Перечисление TDeleteRule (Правило удаления)
1type
2  TDeleteRule = (drRestrict, drCascade, drSetNull);
Или
1type
2  TDeleteRule = TOleEnum;
3const
4  drRestrict = $00000000;
5  drCascade = $00000001;
6  drSetNull = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

drRestrict

0

Нет правила

drCascade

1

Каскадное удаление

drSetNull

2

Очистить ссылку

9.4.9. Перечисление TDuplicates (Дубликаты)
1type
2  TDuplicates = (dupIgnore, dupAccept, dupError);
Или
1type
2  TDuplicates = TOleEnum;
3const
4  dupIgnore = $00000000;
5  dupAccept = $00000001;
6  dupError = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

dupIgnore

0

Игнорировать дубликаты

dupAccept

1

Разрешить дублирование

dupError

2

Генерировать ошибку дублирования

9.4.10. Перечисление TExcelOutputFormat (Формат результата отчета Excel)
1type
2  TExcelOutputFormat = (eofDefault, eof2003, eofHTML, eofPDF, eofNativePDF,
3    eofXPS);
Или
1type
2  TExcelOutputFormat = TOleEnum;
3const
4  eofDefault = $00000000;
5  eof2003 = $00000001;
6  eofHTML = $00000002;
7  eofPDF = $00000003;
8  eofNativePDF = $00000004;
9  eofXPS = $00000005;
Элементы перечисления:

Имя

Значение

Назначение

eofDefault

0

По умолчанию

eof2003

1

Рабочая книга Excel 97-2003

eofHTML

2

Документ HTML

eofPDF

3

Документ PDF

eofNativePDF

4

Документ PDF, сформированный Excel

eofXPS

5

Документ XPS

9.4.11. Перечисление TExcelSheetKind (Тип листа Excel)
1type
2  TExcelSheetKind = (skNone, skFirst, skFirstHidden, skLast, skNew);
Или
1type
2  TExcelSheetKind = TOleEnum;
3const
4  skNone = $00000000;
5  skFirst = $00000001;
6  skFirstHidden = $00000002;
7  skLast = $00000003;
8  skNew = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

skNone

0

Не переносить данные на лист

skFirst

1

На первый лист

skFirstHidden

2

На первый скрытый лист

skLast

3

На последний лист

skNew

4

На новый лист

9.4.12. Перечисление TExternalDataProtocol (Протокол доступа к внешним данным)
1type
2  TExternalDataProtocol = (prLocal, prHTTP, prHTTPS, prFTP, prFTPS, prSMB);
Или
1type
2  TExternalDataProtocol = TOleEnum;
3const
4  prLocal = $00000000;
5  prHTTP = $00000001;
6  prHTTPS = $00000002;
7  prFTP = $00000003;
8  prFTPS = $00000004;
9  prSMB = $00000005;
Элементы перечисления:

Имя

Значение

Назначение

prLocal

0

Файл доступен локально

prHTTP

1

Протокол HTTP

prHTTPS

2

Протокол HTTPS

prFTP

3

Протокол FTP

prFTPS

4

Протокол FTPS

prSMB

5

Протокол SMB

9.4.13. Перечисление TFormViewLayout (Виды расположения)
1type
2  TFormViewLayout = (vlHorizontal, vlVertical);
Или
1type
2  TFormViewLayout = TOleEnum;
3const
4  vlHorizontal = $00000000;
5  vlVertical = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

vlHorizontal

0

Горизонтальное

vlVertical

1

Вертикально

9.4.14. Перечисление TInstantContactStatus (Статус контакта)
1type
2  TInstantContactStatus = (icsPending, icsRefused, icsApproved);
Или
1type
2  TInstantContactStatus = TOleEnum;
3const
4  icsPending = $00000000;
5  icsRefused = $00000001;
6  icsApproved = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

icsPending

0

Рассматривается

icsRefused

1

Отказано

icsApproved

2

Утвержденный

9.4.15. Перечисление TInstantMessageAttachmentType (Тип вложения мгновенного сообщения)
1type
2  TInstantMessageAttachmentType = (imaFile, imaImage, imaHyperLink, imaObject);
Или
1type
2  TInstantMessageAttachmentType = TOleEnum;
3const
4  imaFile = $00000000;
5  imaImage = $00000001;
6  imaHyperLink = $00000002;
7  imaObject = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

imaFile

0

Файл

imaImage

1

Изображение

imaHyperLink

2

Гиперссылка

imaObject

3

Объект

9.4.16. Перечисление TInstantMessageAttachmentType (None) (Тип вложения мгновенного сообщения (None))
1type
2  TInstantMessageAttachmentType (None) = (imaFile, imaImage, imaHyperLink,
3    imaObject, imaNone);
Или
1type
2  TInstantMessageAttachmentType (None) = TOleEnum;
3const
4  imaFile = $00000000;
5  imaImage = $00000001;
6  imaHyperLink = $00000002;
7  imaObject = $00000003;
8  imaNone = $00000004;
Это перечисление использует элементы TInstantMessageAttachmentType.

Элементы перечисления:

Имя

Значение

Назначение

imaFile

0

Определено в базовом перечислении TInstantMessageAttachmentType

imaImage

1

Определено в базовом перечислении TInstantMessageAttachmentType

imaHyperLink

2

Определено в базовом перечислении TInstantMessageAttachmentType

imaObject

3

Определено в базовом перечислении TInstantMessageAttachmentType

imaNone

4

Нет

9.4.17. Перечисление TNotificationType (Тип уведомления)
1type
2  TNotificationType = (ntInformation, ntWarning, ntCaution);
Или
1type
2  TNotificationType = TOleEnum;
3const
4  ntInformation = $00000000;
5  ntWarning = $00000001;
6  ntCaution = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

ntInformation

0

Информация

ntWarning

1

Предупреждение

ntCaution

2

Проблема

9.4.18. Перечисление TOutputColorMode (Режим цветопередачи)
1type
2  TOutputColorMode = (wcmNormal, wcmGrayscale, wcmMonochrome);
Или
1type
2  TOutputColorMode = TOleEnum;
3const
4  wcmNormal = $00000000;
5  wcmGrayscale = $00000001;
6  wcmMonochrome = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

wcmNormal

0

Цветной

wcmGrayscale

1

В градациях серого

wcmMonochrome

2

Монохромный

9.4.19. Перечисление TReplicationStatus (Статус репликации)
1type
2  TReplicationStatus = (rsNotReplicatable, rsReplicatableMetadata, rsReplicatable);
Или
1type
2  TReplicationStatus = TOleEnum;
3const
4  rsNotReplicatable = $00000000;
5  rsReplicatableMetadata = $00000001;
6  rsReplicatable = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

rsNotReplicatable

0

Не реплицировать

rsReplicatableMetadata

1

Вместе с метаданными

rsReplicatable

2

Вместе с бизнес-данными

9.4.20. Перечисление TRowColor (Цвет строки таблицы)
1type
2  TRowColor = (rcDefault, rcRed, rcGreen, rcBlue, rcPale, rcCyan, rcMagenta,
3    rcYellow);
Или
01type
02  TRowColor = TOleEnum;
03const
04  rcDefault = $00000000;
05  rcRed = $00000001;
06  rcGreen = $00000002;
07  rcBlue = $00000003;
08  rcPale = $00000004;
09  rcCyan = $00000005;
10  rcMagenta = $00000006;
11  rcYellow = $00000007;
Элементы перечисления:

Имя

Значение

Назначение

rcDefault

0

По умолчанию

rcRed

1

Красная строка

rcGreen

2

Зеленая строка

rcBlue

3

Синяя строка

rcPale

4

Бледная строка

rcCyan

5

Голубая строка

rcMagenta

6

Пурпурная строка

rcYellow

7

Желтая строка

9.4.21. Перечисление TScope (Область видимости)
1type
2  TScope = (scPrivate, scPublic);
Или
1type
2  TScope = TOleEnum;
3const
4  scPrivate = $00000000;
5  scPublic = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

scPrivate

0

Не видимо пользователям

scPublic

1

Видимо пользователям

9.4.22. Перечисление TSecurityModel (Модели безопасности)
1type
2  TSecurityModel = (smFullAccess, smPublic, smPrivate, smByAffiliation);
Или
1type
2  TSecurityModel = TOleEnum;
3const
4  smFullAccess = $00000000;
5  smPublic = $00000001;
6  smPrivate = $00000002;
7  smByAffiliation = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

smFullAccess

0

Доступ не ограничен

smPublic

1

Публичный объект

smPrivate

2

Приватный объект

smByAffiliation

3

Доступ по принадлежности

9.4.23. Перечисление TShowObjectInfoType (Тип представления объектов)
1type
2  TShowObjectInfoType = (soName, soDescription);
Или
1type
2  TShowObjectInfoType = TOleEnum;
3const
4  soName = $00000000;
5  soDescription = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

soName

0

Показывать имена

soDescription

1

Показывать наименования

9.4.24. Перечисление TSortDirection (Направление сортировки)
1type
2  TSortDirection = (sdNone, sdAscending, sdDescending);
Или
1type
2  TSortDirection = TOleEnum;
3const
4  sdNone = $00000000;
5  sdAscending = $00000001;
6  sdDescending = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

sdNone

0

Нет

sdAscending

1

По возрастанию

sdDescending

2

По убыванию

9.4.25. Перечисление TTranslationStatus (Состояния перевода)
1type
2  TTranslationStatus = (tsNotTranslated, tsTranslated, tsUntranslatable, tsDirty);
Или
1type
2  TTranslationStatus = TOleEnum;
3const
4  tsNotTranslated = $00000000;
5  tsTranslated = $00000001;
6  tsUntranslatable = $00000002;
7  tsDirty = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

tsNotTranslated

0

Не переведено

tsTranslated

1

Переведено

tsUntranslatable

2

Не нуждается в переводе

tsDirty

3

Грязный

9.4.26. Перечисление TUserAccessMode (Режим доступа)
1type
2  TUserAccessMode = (uaFullAccess, uaReadOnly, uaAccessDenied);
Или
1type
2  TUserAccessMode = TOleEnum;
3const
4  uaFullAccess = $00000000;
5  uaReadOnly = $00000001;
6  uaAccessDenied = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

uaFullAccess

0

Полный доступ

uaReadOnly

1

Доступ только для чтения

uaAccessDenied

2

Доступ запрещен

9.4.27. Перечисление TWordOutputFormat (Формат результата отчета Word)
1type
2  TWordOutputFormat = (wofDefault, wof2003, wofHTML, wofRTF, wofPDF);
Или
1type
2  TWordOutputFormat = TOleEnum;
3const
4  wofDefault = $00000000;
5  wof2003 = $00000001;
6  wofHTML = $00000002;
7  wofRTF = $00000003;
8  wofPDF = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

wofDefault

0

По умолчанию

wof2003

1

Документ Word 97-2003

wofHTML

2

Документ HTML

wofRTF

3

Документ RTF

wofPDF

4

Документ PDF

9.4.28. Класс TAccessibleFile (Доступный файл)

9.4.28.1. Свойства

Свойства класса TAccessibleFile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

FileData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные файла

CRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

9.4.28.2. Конструктор Create (Конструктор доступного файла)

Конструктор класса TAccessibleFile.
1constructor TAccessibleFile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  FileData: blob): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

FileData

blob

Нет

Данные файла

Замечания:

Создает новый объект класса TAccessibleFile.

9.4.28.3. Метод SetData (Установить значение свойства "Данные файла")

Метод экземпляра класса TAccessibleFile.
procedure TAccessibleFile.SetData(FileData: blob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

FileData

blob

Нет

Данные файла

9.4.28.4. Метод Ole-объекта CheckAllCRC (Обновить отсутствующие контрольные суммы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

9.4.28.5. Метод Ole-объекта CheckCRC (Обновить контрольную сумму)

Метод Ole-объекта класса TAccessibleFile.

Метод Ole-объекта не имеет параметров.

9.4.28.6. Метод Ole-объекта LoadFromFolder (Загрузить из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

9.4.28.7. Метод Ole-объекта SaveToFolder (Сохранить в папку)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

9.4.28.8. Метод Ole-объекта UpdateFromFolder (Обновить из папки)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

9.4.29. Класс TAccessItem (Элементы доступа)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.29.1. Свойства

Свойства класса TAccessItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Скрыто от пользователя

Чтение/Запись

Имя

Description

string[128]

Да

Скрыто от пользователя

Чтение/Запись

Наименование

Class

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

Элемент

MasterName

string[64]

Да

Видимо пользователю

Только для чтения

Имя элемента

MasterDescription

string[128]

Да

Видимо пользователю

Только для чтения

Наименование элемента

MasterClass

TClass

Да

Видимо пользователю

Только для чтения

Класс элемента

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

SecurityAccountName

string[64]

Да

Видимо пользователю

Чтение/Запись

Имя роли безопасности

SecurityAccountDescription

string[128]

Да

Видимо пользователю

Чтение/Запись

Наименование роли безопасности

SecurityAccountClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс роли безопасности

9.4.29.2. Конструктор Create (Конструктор элемента доступа)

Конструктор класса TAccessItem.
1constructor TAccessItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TAccessItem.

9.4.29.3. Метод GetIsAccessible (Проверка доступности)

Метод класса (статический метод) класса TAccessItem.
class function TAccessItem.GetIsAccessible(Master: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Boolean.

9.4.30. Класс TAccessProfile (Профили доступа)

9.4.30.1. Свойства

Свойства класса TAccessProfile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TProfile

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

ComparisonType

TComparisonType

Да

Видимо пользователю

Чтение/Запись

BasedOnProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Active

Boolean

Да

Видимо пользователю

Только для чтения

Access

Boolean

Да

Видимо пользователю

Чтение/Запись

Доступ

9.4.30.2. Конструктор Create (Конструктор профиля доступа)

Конструктор класса TAccessProfile.
1constructor TAccessProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType; BasedOnProfile: TProfile;
4  Access: Boolean): TObject;
Переопределяет метод в TProfile.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Унаследовано от TProfile.Create

ComparisonType

TComparisonType

Да

BasedOnProfile

TProfile

Нет

Access

Boolean

Да

Доступ

Замечания:

Создает новый объект класса TAccessProfile.

9.4.31. Класс TAction (Действия)

Объекты класса образуют иерархию.

9.4.31.1. Свойства

Свойства класса TAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Горячая клавиша

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Отделено

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

По умолчанию

9.4.31.2. Конструктор Create (Конструктор действия)

Конструктор класса TAction.
1constructor TAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean;
4  Default: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Shortcut

string[20]

Нет

Горячая клавиша

Separated

Boolean

Да

Отделено

Default

Boolean

Да

По умолчанию

Замечания:

Создает новый объект класса TAction.

9.4.31.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TAction.
1class function TAction.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Parent

TObject

Нет

Родитель

Step

Integer

Да

Шаг

Замечания:

Возвращает значение типа Integer.

9.4.32. Класс TActionContextProperty (Свойство контекста)

Имена объектов класса генерируются.

9.4.32.1. Свойства

Свойства класса TActionContextProperty:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Property

TProperty

Да

Видимо пользователю

Чтение/Запись

Свойство

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

9.4.32.2. Конструктор Create (Конструктор контекстного свойства)

Конструктор класса TActionContextProperty.
1constructor TActionContextProperty.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Property: TProperty; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Property

TProperty

Да

Свойство

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TActionContextProperty.

9.4.32.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TActionContextProperty.
class function TActionContextProperty.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

9.4.33. Класс TAsyncHandler (Обработчики отложенного выполнения)

9.4.33.1. Свойства

Свойства класса TAsyncHandler:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Validator

TMethod

Нет

Видимо пользователю

Чтение/Запись

Процедура-валидатор

Handler

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Процедура-обработчик

9.4.33.2. Конструктор Create (Конструктор обработчика отложенного выполнения)

Конструктор класса TAsyncHandler.
1constructor TAsyncHandler.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Validator: TMethod; Handler: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Validator

TMethod

Нет

Процедура-валидатор

Handler

TRoutine

Нет

Процедура-обработчик

Замечания:

Создает новый объект класса TAsyncHandler.

9.4.33.3. Метод GetIsAccessible (Доступен)

Метод экземпляра класса TAsyncHandler.
function TAsyncHandler.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.33.4. Метод ValidateInstantMessage (Доступен обработчик с уведомлением сообщением)

Метод класса (статический метод) класса TAsyncHandler.
class function TAsyncHandler.ValidateInstantMessage(Routine: TRoutine): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Замечания:

Возвращает значение типа Boolean.

9.4.33.5. Метод ValidateWithoutNotification (Доступен обработчик без уведомления)

Метод класса (статический метод) класса TAsyncHandler.
class function TAsyncHandler.ValidateWithoutNotification(Routine: TRoutine): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Замечания:

Возвращает значение типа Boolean.

9.4.34. Класс TAsyncHandlerAccess (Доступ к обработчикам отложенного выполнения)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.34.1. Конструктор Create (Конструктор доступа к обработчикам отложенного выполнения)

Конструктор класса TAsyncHandlerAccess.
1constructor TAsyncHandlerAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TAsyncHandlerAccess.

9.4.35. Класс TAsyncTask (Задачи отложенного выполнения)

Объекты класса не именованы.

9.4.35.1. Свойства

Свойства класса TAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Created

datetime

Да

Видимо пользователю

Только для чтения

Время создания

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Состояние

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Язык

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

Обработчик

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Представление формы

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Объект

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Время начала выполнения

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Время завершения выполнения

Duration

time

Нет

Видимо пользователю

Только для чтения

Длительность

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

Выделено

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Цвет строки

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

Группа

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Содержимое группы готово

9.4.35.2. Конструктор Create (Конструктор задачи отложенного выполнения)

Конструктор класса TAsyncTask.
1constructor TAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Подпрограмма

Object

TObject

Нет

Объект

FormView

TFormView

Нет

Представление формы

Handler

TAsyncHandler

Да

Обработчик

Language

TLanguage

Да

Язык

Замечания:

Создает новый объект класса TAsyncTask.

9.4.35.3. Деструктор Destroy (Деструктор объекта)

Деструктор класса TAsyncTask.
destructor TAsyncTask.Destroy;
Переопределяет метод в TObject.Destroy.

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TAsyncTask или его наследника.

9.4.35.4. Метод Archive (Отправить в архив)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Archive;
Метод не имеет параметров.

9.4.35.5. Метод CreateGroup (Создать группу)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.CreateGroup(Group: clob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Group

clob

Нет

Группа

9.4.35.6. Метод Finish (Зафиксировать завершение выполнения)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Finish(Success: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Success

Boolean

Да

Выполнено успешно

9.4.35.7. Метод HandleInstantMessage (Обработчик с уведомлением сообщением)

Метод экземпляра класса TAsyncTask.
1procedure TAsyncTask.HandleInstantMessage(Success: Boolean;
2  ErrorMessage: string[2000]; ExceptionClass: string[2000];
3  NativeMessage: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Success

Boolean

Да

Выполнено успешно

ErrorMessage

string[2000]

Нет

Сообщение об ошибке

ExceptionClass

string[2000]

Нет

Класс ошибки

NativeMessage

string[2000]

Нет

Системное сообщение об ошибке

9.4.35.8. Метод HasAsyncTasks (Имеются задачи отложенного выполнения)

Метод класса (статический метод) класса TAsyncTask.
class function TAsyncTask.HasAsyncTasks: Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.35.9. Метод Start (Зафиксировать начало выполнения)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Start;
Метод скрыт от пользователя.

Метод не имеет параметров.

9.4.35.10. Метод Ole-объекта PerformImmediate (Выполнить немедленно)

Метод Ole-объекта класса TAsyncTask.

Метод Ole-объекта не имеет параметров.

9.4.36. Класс TAsyncTaskParameterValue (Значения параметров задачи отложенного выполнения)

Объекты класса не именованы.

9.4.36.1. Свойства

Свойства класса TAsyncTaskParameterValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Temporary

Boolean

Да

Видимо пользователю

Чтение/Запись

Временный объект

9.4.36.2. Конструктор Create (Конструктор значения параметров задачи отложенного выполнения)

Конструктор класса TAsyncTaskParameterValue.
1constructor TAsyncTaskParameterValue.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Domain: TDomain; Position: Integer;
4  Group: string[128]; Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]; IntValue: Integer; FloatValue: float; DateValue: date;
6  TimeValue: time; DateTimeValue: datetime; ObjectValue: TObject;
7  BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
8  ExternalDataValue: <external data>; Temporary: Boolean): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Унаследовано от TTypedValue.Create

Position

Integer

Да

Group

string[128]

Нет

Tab

string[128]

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

StrValue

string[2000]

Нет

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

Temporary

Boolean

Да

Временный объект

Замечания:

Создает новый объект класса TAsyncTaskParameterValue.

9.4.36.3. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TAsyncTaskParameterValue.
function TAsyncTaskParameterValue.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

9.4.37. Класс TBanGroup (Группы запретов)

9.4.37.1. Свойства

Свойства класса TBanGroup:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступна

9.4.37.2. Конструктор Create (Конструктор группы запретов)

Конструктор класса TBanGroup.
1constructor TBanGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TBanGroup.

9.4.37.3. Метод CreateAllBans (Сгенерировать запреты для класса)

Метод экземпляра класса TBanGroup.
1procedure TBanGroup.CreateAllBans(BannedClass: TClass; BanClass: Boolean;
2  BanRoutines: Boolean; BanProperties: Boolean; AllowRead: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

BannedClass

TClass

Да

Запрещаемый класс

BanClass

Boolean

Да

Запретить доступ к объектам класса

BanRoutines

Boolean

Да

Запретить подпрограммы

BanProperties

Boolean

Да

Запретить свойства

AllowRead

Boolean

Да

Чтение свойств разрешено

9.4.37.4. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TBanGroup.
function TBanGroup.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.38. Класс TBanGroupAccess (Доступ к группам запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.38.1. Конструктор Create (Конструктор доступа к группе запретов)

Конструктор класса TBanGroupAccess.
1constructor TBanGroupAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TBanGroup; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TBanGroup

Да

Группа запретов

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TBanGroupAccess.

9.4.39. Класс TBanGroupItem (Элементы группы запретов)

9.4.39.1. Свойства

Свойства класса TBanGroupItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Мастер

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

9.4.39.2. Конструктор Create (Конструктор элемента группы запретов)

Конструктор класса TBanGroupItem.
1constructor TBanGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TBanGroupItem.

9.4.40. Класс TBlobDomain (Большие объекты)

9.4.40.1. Свойства

Свойства класса TBlobDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

BlobSubtype

TBlobSubtype

Да

Видимо пользователю

Чтение/Запись

Подтип

Extension

string[10]

Нет

Видимо пользователю

Чтение/Запись

Расширение

ShowInPlace

Boolean

Да

Видимо пользователю

Чтение/Запись

Редактировать по месту

EditorClassID

string[128]

Нет

Видимо пользователю

Чтение/Запись

Идентификатор класса-редактора

EditorCodeLibrary

TAccessibleFile

Нет

Видимо пользователю

Чтение/Запись

Библиотека кода редактора

SizeLimit

Integer

Нет

Видимо пользователю

Чтение/Запись

Ограничение на размер

IsBinary

Boolean

Да

Видимо пользователю

Только для чтения

Двоичные данные

9.4.40.2. Конструктор Create (Конструктор домена больших объектов)

Конструктор класса TBlobDomain.
1constructor TBlobDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; BlobSubtype: TBlobSubtype; SizeLimit: Integer;
4  Extension: string[10]; ShowInPlace: Boolean; EditorClassID: string[128];
5  EditorCodeLibrary: TAccessibleFile): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

BlobSubtype

TBlobSubtype

Да

Подтип

SizeLimit

Integer

Нет

Ограничение на размер

Extension

string[10]

Нет

Расширение

ShowInPlace

Boolean

Да

Редактировать по месту

EditorClassID

string[128]

Нет

Идентификатор класса-редактора

EditorCodeLibrary

TAccessibleFile

Нет

Библиотека кода редактора

Замечания:

Создает новый объект класса TBlobDomain.

9.4.40.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TBlobDomain.
function TBlobDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.41. Класс TBooleanDomain (Логические)

9.4.41.1. Свойства

Свойства класса TBooleanDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

TrueValue

string[64]

Да

Видимо пользователю

Чтение/Запись

Значение "Истина"

FalseValue

string[64]

Да

Видимо пользователю

Чтение/Запись

Значение "Ложь"

9.4.41.2. Конструктор Create (Конструктор логического домена)

Конструктор класса TBooleanDomain.
1constructor TBooleanDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; TrueValue: string[64]; FalseValue: string[64]): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

TrueValue

string[64]

Да

Значение "Истина"

FalseValue

string[64]

Да

Значение "Ложь"

Замечания:

Создает новый объект класса TBooleanDomain.

9.4.41.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TBooleanDomain.
function TBooleanDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.42. Класс TClass (Классы)

Объекты класса образуют иерархию.

9.4.42.1. Свойства

Свойства класса TClass:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Чтение/Запись

Статус репликации

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Унаследовано от TObject

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Является иерархическим

SecurityModel

TSecurityModel

Да

Видимо пользователю

Чтение/Запись

Модель безопасности

DefaultAccessor

TSecurityAccount

Нет

Видимо пользователю

Чтение/Запись

Роль доступа по умолчанию

UnNamed

Boolean

Да

Видимо пользователю

Чтение/Запись

Неименованный

NameExpression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение имени объекта

DescriptionExpression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение наименования объекта

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

ModelX

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Положение в модели (абсцисса)

ModelY

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Положение в модели (ордината)

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Indexed

Boolean

Да

Видимо пользователю

Чтение/Запись

Индексируется

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

Localizable

Boolean

Да

Видимо пользователю

Чтение/Запись

Локализуемый

DBMSName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта СУБД

CreatorsCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество ролей-создателей

MasterClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс-мастер

HasProfiles

Boolean

Да

Видимо пользователю

Только для чтения

Контролируется профилями

ApproxObjectCount

Integer

Нет

Видимо пользователю

Только для чтения

Оценка количества объектов

9.4.42.2. Конструктор Create (Конструктор класса)

Конструктор класса TClass.
1constructor TClass.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  MasterClass: TClass; IsHierarhical: Boolean;
4  ReplicationStatus: TReplicationStatus; SecurityModel: TSecurityModel;
5  DefaultAccessor: TSecurityAccount; Logged: Boolean; UnNamed: Boolean;
6  NameExpression: clob; DescriptionExpression: clob; CreateConstructor: Boolean;
7  Category: string[128]; Indexed: Boolean; Localizable: Boolean): TClass;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

MasterClass

TClass

Нет

Класс-мастер

IsHierarhical

Boolean

Да

Является иерархическим

ReplicationStatus

TReplicationStatus

Да

Статус репликации

SecurityModel

TSecurityModel

Да

Модель безопасности

DefaultAccessor

TSecurityAccount

Нет

Роль доступа по умолчанию

Logged

Boolean

Да

Протоколировать

UnNamed

Boolean

Да

Неименованный

NameExpression

clob

Нет

Выражение имени объекта

DescriptionExpression

clob

Нет

Выражение наименования объекта

CreateConstructor

Boolean

Да

Создать конструктор

Category

string[128]

Нет

Категория

Indexed

Boolean

Да

Индексируется

Localizable

Boolean

Да

Локализуемый

Замечания:

Создает новый объект класса TClass.

9.4.42.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TClass.
procedure TClass.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

9.4.42.4. Метод GenerateConstructor (Сгенерировать текст конструктора)

Метод экземпляра класса TClass.
procedure TClass.GenerateConstructor;
Метод не имеет параметров.

9.4.42.5. Метод GetApproxObjectsCount (Получить оценку количества объектов)

Метод экземпляра класса TClass.
function TClass.GetApproxObjectsCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.42.6. Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TClass.
function TClass.GetDBMSName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

9.4.42.7. Метод GetHasProfiles (Контролируется профилями)

Метод экземпляра класса TClass.
function TClass.GetHasProfiles: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.42.8. Метод GetObjectCount (Количество объектов)

Метод экземпляра класса TClass.
function TClass.GetObjectCount(Exact: Boolean): string[20];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Exact

Boolean

Да

Строго

Замечания:

Возвращает значение типа string[20].

9.4.42.9. Метод ListChildProperties (Список дочерних свойств)

Метод класса (статический метод) класса TClass.
1class procedure TClass.ListChildProperties(ParentName: string[64];
2  TemporaryList: TObjectList; PersistentList: TObjectList);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ParentName

string[64]

Да

Имя свойства

TemporaryList

TObjectList

Нет

Временный список

PersistentList

TObjectList

Нет

Постоянный список

9.4.42.10. Метод ListProperties (Список свойств)

Метод экземпляра класса TClass.
function TClass.ListProperties(Scope: TScope): TObjectList;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Scope

TScope

Да

Область видимости

Замечания:

Возвращает значение типа TObjectList.

9.4.42.11. Метод ListRoutines (Список подпрограмм)

Метод экземпляра класса TClass.
function TClass.ListRoutines(Scope: TScope): TObjectList;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Scope

TScope

Да

Область видимости

Замечания:

Возвращает значение типа TObjectList.

9.4.42.12. Метод MarkLocalizableMetadata (Установить поля метаданных как локализуемые)

Метод класса (статический метод) класса TClass.
class procedure TClass.MarkLocalizableMetadata;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

9.4.42.13. Метод MemberByName (Член класса по имени)

Метод экземпляра класса TClass.
function TClass.MemberByName(Name: string[64]; Class: TClass): TClassMember;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Class

TClass

Да

Класс

Замечания:

Возвращает значение типа TClassMember.

9.4.42.14. Метод SetLocalizable (Установить значение свойства "Локализуемый")

Метод экземпляра класса TClass.
procedure TClass.SetLocalizable(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

9.4.42.15. Метод Ole-объекта CheckAllExcelTemplates (Проверить шаблоны отчетов Excel)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

9.4.42.16. Метод Ole-объекта CheckAllOleObjectMethods (Проверить все методы Ole-объекта)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

9.4.42.17. Метод Ole-объекта CheckAllTemplates (Проверить все шаблоны)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

9.4.42.18. Метод Ole-объекта CheckAllWordTemplates (Проверить шаблоны отчетов Word)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

9.4.42.19. Метод Ole-объекта CheckAllXSLTTemplates (Проверить шаблоны отчетов XSLT)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

9.4.42.20. Метод Ole-объекта LoadImagesFromFolder (Загрузить изображения из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Prefix

string[128]

Нет

Префикс имени файла

Замечания:

Возвращает значение типа Integer.

9.4.42.21. Метод Ole-объекта LoadMethodsFromFolder (Загрузить методы из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

9.4.42.22. Метод Ole-объекта LoadResourceFile (Загрузить файл ресурсов)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

XliffFileName

string[255]

Да

Файл ресурсов

Замечания:

Возвращает значение типа Integer.

9.4.42.23. Метод Ole-объекта LoadTemplatesFromFolder (Загрузить шаблоны из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

9.4.42.24. Метод Ole-объекта SaveImagesToFolder (Сохранить изображения в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Prefix

string[128]

Нет

Префикс имени файла

Замечания:

Возвращает значение типа Integer.

9.4.42.25. Метод Ole-объекта SaveMethodsToFolder (Сохранить методы в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

9.4.42.26. Метод Ole-объекта SaveTemplatesToFolder (Сохранить шаблоны в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

ExportCodeModules

Boolean

Да

Экспортировать программные модули

Замечания:

Возвращает значение типа Integer.

9.4.42.27. Шаблон XSLT-отчета ClassesDiagram (Диаграмма классов)

Шаблон XSLT-отчета класса (статический шаблон) класса TClass.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ShowFields

Boolean

Да

Показывать поля

ShowMethods

Boolean

Да

Показывать методы

ShowProperties

Boolean

Да

Показывать свойства

ShowParameters

Boolean

Да

Показывать параметры

ShowMetadata

Boolean

Да

Показывать метаданные

GroupByMaster

Boolean

Да

Группировать по принадлежности

9.4.43. Класс TClassBan (Запрет на класс)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.43.1. Свойства

Свойства класса TClassBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

9.4.43.2. Конструктор Create (Конструктор запрета на класс)

Конструктор класса TClassBan.
1constructor TClassBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

Замечания:

Создает новый объект класса TClassBan.

9.4.44. Класс TClassDomain (Ссылки на объекты)

9.4.44.1. Свойства

Свойства класса TClassDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

ClassOfDomain

TClass

Нет

Видимо пользователю

Чтение/Запись

Класс домена

ClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Чтение/Запись

Статус репликации класса

ShowObjectInfoType

TShowObjectInfoType

Да

Видимо пользователю

Чтение/Запись

Тип представления объектов

DeleteRule

TDeleteRule

Да

Видимо пользователю

Чтение/Запись

Правило удаления

FilterCondition

clob

Нет

Видимо пользователю

Чтение/Запись

Условие отбора

View

TCustomView

Нет

Видимо пользователю

Чтение/Запись

Представление

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

9.4.44.2. Конструктор Create (Конструктор домена-ссылки)

Конструктор класса TClassDomain.
1constructor TClassDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; ClassOfDomain: TClass; View: TCustomView;
4  FilterCondition: clob; ShowObjectInfoType: TShowObjectInfoType;
5  DeleteRule: TDeleteRule; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

ClassOfDomain

TClass

Да

Класс домена

View

TCustomView

Нет

Представление для выбора

FilterCondition

clob

Нет

Условие отбора

ShowObjectInfoType

TShowObjectInfoType

Да

Тип представления объектов

DeleteRule

TDeleteRule

Да

Правило удаления

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TClassDomain.

9.4.44.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TClassDomain.
function TClassDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.45. Класс TClassMember (Члены класса)

9.4.45.1. Свойства

Свойства класса TClassMember:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределен

9.4.45.2. Конструктор Create (Конструктор члена класса)

Конструктор класса TClassMember.
1constructor TClassMember.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TClassMember.

9.4.45.3. Метод GetOverride (Переопределен)

Метод экземпляра класса TClassMember.
function TClassMember.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.45.4. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TClassMember.
function TClassMember.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

9.4.46. Класс TCommandButton (Командные кнопки)

9.4.46.1. Свойства

Свойства класса TCommandButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TRoutine

Да

Видимо пользователю

Только для чтения

Мастер

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

MasterMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер подпрограммы

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomButton

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределена

Parameter

TParameter

Нет

Видимо пользователю

Чтение/Запись

Связанный параметр

9.4.46.2. Конструктор Create (Конструктор командной кнопки)

Конструктор класса TCommandButton.
1constructor TCommandButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean; Parameter: TParameter): TObject;
Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Group

string[128]

Нет

Унаследовано от TCustomButton.Create

Tab

string[128]

Нет

Script

clob

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

Parameter

TParameter

Нет

Связанный параметр

Замечания:

Создает новый объект класса TCommandButton.

9.4.46.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TCommandButton.
class function TCommandButton.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

9.4.46.4. Метод GetOverride (Переопределена)

Метод экземпляра класса TCommandButton.
function TCommandButton.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.47. Класс TContextKey (Ключи контекстной помощи)

Объекты класса не именованы.

9.4.47.1. Свойства

Свойства класса TContextKey:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Storage

string[64]

Да

Видимо пользователю

Чтение/Запись

Хранилище

LinkedObject

TObject

Нет

Видимо пользователю

Чтение/Запись

Связанный объект

LinkedObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс связанного объекта

LinkedObjectMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер связанного объекта

9.4.47.2. Конструктор Create (Конструктор ключа)

Конструктор класса TContextKey.
1constructor TContextKey.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Storage: string[64]; LinkedObject: TObject): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Ключевое словосочетание

Class

TClass

Нет

Унаследовано от TObject.Create

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Storage

string[64]

Да

Хранилище

LinkedObject

TObject

Нет

Связанный объект

Замечания:

Создает новый объект класса TContextKey.

9.4.47.3. Метод GenerateAllKeys (Сгенерировать ключи)

Метод класса (статический метод) класса TContextKey.
class procedure TContextKey.GenerateAllKeys(Storage: string[64]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

9.4.48. Класс TCustomButton (Кнопки)

9.4.48.1. Свойства

Свойства класса TCustomButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

9.4.48.2. Конструктор Create (Конструктор кнопки)

Конструктор класса TCustomButton.
1constructor TCustomButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Script

clob

Нет

Скрипт

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

Замечания:

Создает новый объект класса TCustomButton.

9.4.49. Класс TCustomView (Абстрактное представление)

9.4.49.1. Свойства

Свойства класса TCustomView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Класс

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс-мастер показываемого

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

Статус репликации класса

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Иерархическое

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

Количество данных незначительно

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство выделенного шрифта

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

Предсобранное

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Вызывать перед открытием

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство цвета

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Параметры оптимизации

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

Имеются условия отбора

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

Имеет колонки со специфическими именами

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

9.4.49.2. Конструктор Create (Конструктор абстрактного представления)

Конструктор класса TCustomView.
1constructor TCustomView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Класс

ColorProperty

TProperty

Нет

Свойство цвета

BoldProperty

TProperty

Нет

Свойство выделенного шрифта

Skimpy

Boolean

Да

Количество данных незначительно

PreCompiled

Boolean

Да

Предсобранное

PreOpenRoutine

TRoutine

Нет

Вызывать перед открытием

Замечания:

Создает новый объект класса TCustomView.

9.4.49.3. Метод BuildDefaultActions (Создать действия по умолчанию)

Метод экземпляра класса TCustomView.
1procedure TCustomView.BuildDefaultActions(AddConstructor: Boolean;
2  AddDestructor: Boolean; AddMethods: Boolean; AddReports: Boolean;
3  AddCopyPasteActions: Boolean; AddStandartActions: Boolean;
4  PositionStep: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

AddConstructor

Boolean

Да

Добавить конструктор

AddDestructor

Boolean

Да

Добавить деструктор

AddMethods

Boolean

Да

Добавить методы

AddReports

Boolean

Да

Добавить шаблоны отчетов

AddCopyPasteActions

Boolean

Да

Добавить работу с буфером обмена

AddStandartActions

Boolean

Да

Добавить стандартные действия

PositionStep

Integer

Да

Шаг

9.4.49.4. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TCustomView.
procedure TCustomView.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

9.4.50. Класс TDataBase (Базы данных)

9.4.50.1. Свойства

Свойства класса TDataBase:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

GUID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущей

Protected

Boolean

Да

Видимо пользователю

Чтение/Запись

Защищена от изменений

9.4.50.2. Конструктор Create (Конструктор базы данных)

Конструктор класса TDataBase.
1constructor TDataBase.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  GUID: string[38]; Protected: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

GUID

string[38]

Да

GUID

Protected

Boolean

Да

Защищена

Замечания:

Создает новый объект класса TDataBase.

9.4.51. Класс TDateDomain (Даты)

9.4.51.1. Конструктор Create (Конструктор домена даты)

Конструктор класса TDateDomain.
1constructor TDateDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Замечания:

Создает новый объект класса TDateDomain.

9.4.51.2. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateDomain.
function TDateDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.52. Класс TDateTimeDomain (Даты со временем)

9.4.52.1. Свойства

Свойства класса TDateTimeDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

HideSeconds

Boolean

Да

Видимо пользователю

Чтение/Запись

Не показывать секунды

9.4.52.2. Конструктор Create (Конструктор домена даты со временем)

Конструктор класса TDateTimeDomain.
1constructor TDateTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

HideSeconds

Boolean

Да

Не показывать секунды

Замечания:

Создает новый объект класса TDateTimeDomain.

9.4.52.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateTimeDomain.
function TDateTimeDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.53. Класс TDependency (Зависимости)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.53.1. Свойства

Свойства класса TDependency:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Dependent

TObject

Нет

Видимо пользователю

Чтение/Запись

Зависимый объект

DependentClass

TClass

Да

Видимо пользователю

Только для чтения

Класс зависимого объекта

DependentMaster

TObject

Да

Видимо пользователю

Только для чтения

Мастер зависимого объекта

DependentExternal

string[256]

Нет

Видимо пользователю

Чтение/Запись

Внешний зависимый объект

DependedOn

TObject

Да

Видимо пользователю

Чтение/Запись

Зависит от

DependedOnClass

TClass

Да

Видимо пользователю

Только для чтения

Класс объекта, от которого зависит

DependedOnMaster

TObject

Да

Видимо пользователю

Только для чтения

Мастер объекта, от которого зависит

9.4.53.2. Конструктор Create (Конструктор зависимости)

Конструктор класса TDependency.
1constructor TDependency.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Dependent: TObject; DependentExternal: string[256];
4  DependedOn: TObject): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Dependent

TObject

Нет

Зависимый объект

DependentExternal

string[256]

Нет

Внешний зависимый объект

DependedOn

TObject

Да

Зависит от

Замечания:

Создает новый объект класса TDependency.

9.4.53.3. Метод Install (Установить)

Метод класса (статический метод) класса TDependency.
1class procedure TDependency.Install(ADependent: TObject;
2  ADependentExternal: string[256]; ADependedOn: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ADependent

TObject

Нет

Зависимый объект

ADependentExternal

string[256]

Нет

Внешний зависимый объект

ADependedOn

TObject

Да

Зависит от

9.4.54. Класс TDomain (Домены)

9.4.54.1. Свойства

Свойства класса TDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Обязательно для заполнения

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество внешних зависимостей

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Сводка

9.4.54.2. Конструктор Create (Конструктор домена)

Конструктор класса TDomain.
1constructor TDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TDomain;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Обязательно для заполнения

Замечания:

Создает новый объект класса TDomain.

9.4.54.3. Метод GetDefinition (Определение домена)

Метод экземпляра класса TDomain.
function TDomain.GetDefinition: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

9.4.54.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDomain.
function TDomain.GetSummary: string[2000];
Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.55. Класс TEnumerationDomain (Перечисления)

9.4.55.1. Свойства

Свойства класса TEnumerationDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

ShowNames

Boolean

Да

Видимо пользователю

Чтение/Запись

Показывать имена

BasedOnDomain

TEnumerationDomain

Нет

Видимо пользователю

Чтение/Запись

Расширяет домен

ItemCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество элементов

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

9.4.55.2. Конструктор Create (Конструктор перечисления)

Конструктор класса TEnumerationDomain.
1constructor TEnumerationDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; ShowNames: Boolean;
4  BasedOnDomain: TEnumerationDomain; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

ShowNames

Boolean

Да

Показывать имена элементов

BasedOnDomain

TEnumerationDomain

Нет

Расширяет домен

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TEnumerationDomain.

9.4.55.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TEnumerationDomain.
function TEnumerationDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.55.4. Метод ListItems (Список элементов)

Метод экземпляра класса TEnumerationDomain.
function TEnumerationDomain.ListItems: TObjectList;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.

9.4.56. Класс TEnumerationItem (Элементы перечислений)

9.4.56.1. Свойства

Свойства класса TEnumerationItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

9.4.56.2. Конструктор Create (Конструктор элемента перечисления)

Конструктор класса TEnumerationItem.
1constructor TEnumerationItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TEnumerationItem.

9.4.56.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TEnumerationItem.
class function TEnumerationItem.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

9.4.57. Класс TExcelAsyncTask (Задачи отложенного выполнения отчетов Excel)

Объекты класса не именованы.

9.4.57.1. Свойства

Свойства класса TExcelAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TAsyncTask

Created

datetime

Да

Видимо пользователю

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TAsyncTask

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Duration

time

Нет

Видимо пользователю

Только для чтения

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Format

TExcelOutputFormat

Да

Видимо пользователю

Чтение/Запись

Формат

ColorMode

TOutputColorMode

Да

Видимо пользователю

Чтение/Запись

Режим цветопередачи

EmbedFonts

Boolean

Да

Видимо пользователю

Чтение/Запись

Внедрять шрифты

9.4.57.2. Конструктор Create (Конструктор задачи отложенного выполнения отчетов Excel)

Конструктор класса TExcelAsyncTask.
1constructor TExcelAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TExcelOutputFormat;
5  ColorMode: TOutputColorMode; EmbedFonts: Boolean): TObject;
Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Унаследовано от TAsyncTask.Create

Object

TObject

Нет

FormView

TFormView

Нет

Handler

TAsyncHandler

Да

Language

TLanguage

Да

Format

TExcelOutputFormat

Да

Формат

ColorMode

TOutputColorMode

Да

Режим цветопередачи

EmbedFonts

Boolean

Да

Внедрять шрифты

Замечания:

Создает новый объект класса TExcelAsyncTask.

9.4.58. Класс TExcelTemplate (Шаблоны отчетов Excel)

9.4.58.1. Свойства

Свойства класса TExcelTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

PlaceDataOnSheet

TExcelSheetKind

Да

Видимо пользователю

Чтение/Запись

Лист для переноса данных

MacroName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя макроса

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

9.4.58.2. Конструктор Create (Конструктор шаблона Excel)

Конструктор класса TExcelTemplate.
1constructor TExcelTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  PlaceDataOnSheet: TExcelSheetKind; MacroName: string[128];
7  IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

blob

Нет

Данные шаблона

PlaceDataOnSheet

TExcelSheetKind

Да

Лист для переноса данных

MacroName

string[128]

Нет

Имя макроса

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TExcelTemplate.

9.4.58.3. Метод Ole-объекта CheckExcelTemplate (Проверить шаблон отчетов Excel)

Метод Ole-объекта класса TExcelTemplate.

Метод Ole-объекта не имеет параметров.

9.4.59. Класс TExternalDataDomain (Внешние данные)

9.4.59.1. Свойства

Свойства класса TExternalDataDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

NamesSequence

TSequence

Нет

Видимо пользователю

Чтение/Запись

Последовательность для формирования имен

ContentDomain

TBlobDomain

Да

Видимо пользователю

Чтение/Запись

Домен содержимого

ContentDomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена содержимого

ContentDomainBlobSubtype

TBlobSubtype

Да

Видимо пользователю

Только для чтения

Подтип домена содержимого

ContentDomainExtension

string[10]

Нет

Видимо пользователю

Только для чтения

Расширение домена содержимого

ResourceCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество ресурсов

ContentDependentNames

Boolean

Да

Видимо пользователю

Чтение/Запись

Имя зависит от содержимого

Compress

Boolean

Да

Видимо пользователю

Чтение/Запись

Сжимать содержимое

9.4.59.2. Конструктор Create (Конструктор домена внешних данных)

Конструктор класса TExternalDataDomain.
1constructor TExternalDataDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; NamesSequence: TSequence;
4  ContentDomain: TBlobDomain; ContentDependentNames: Boolean;
5  Compress: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

NamesSequence

TSequence

Нет

Последовательность для формирования имен

ContentDomain

TBlobDomain

Да

Домен содержимого

ContentDependentNames

Boolean

Да

Имя зависит от содержимого

Compress

Boolean

Да

Сжимать содержимое

Замечания:

Создает новый объект класса TExternalDataDomain.

9.4.59.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TExternalDataDomain.
function TExternalDataDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.60. Класс TExternalDataResource (Ресурсы внешних данных)

9.4.60.1. Свойства

Свойства класса TExternalDataResource:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

GUID

string[38]

Да

Видимо пользователю

Чтение/Запись

GUID

Protocol

TExternalDataProtocol

Да

Видимо пользователю

Чтение/Запись

Протокол доступа

Host

string[64]

Да

Видимо пользователю

Чтение/Запись

Хост

Port

Integer

Нет

Видимо пользователю

Чтение/Запись

Порт

Path

string[255]

Да

Видимо пользователю

Чтение/Запись

Папка

UserName

string[255]

Нет

Видимо пользователю

Чтение/Запись

Имя пользователя

Password

string[255]

Нет

Видимо пользователю

Чтение/Запись

Пароль

ReadOnly

Boolean

Да

Видимо пользователю

Чтение/Запись

Только для чтения

9.4.60.2. Конструктор Create (Конструктор ресурса внешних данных)

Конструктор класса TExternalDataResource.
1constructor TExternalDataResource.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; GUID: string[38]; Protocol: TExternalDataProtocol;
4  Host: string[64]; Port: Integer; Path: string[255]; UserName: string[255];
5  Password: string[255]; ReadOnly: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

GUID

string[38]

Да

GUID

Protocol

TExternalDataProtocol

Да

Протокол доступа

Host

string[64]

Да

Хост

Port

Integer

Нет

Порт

Path

string[255]

Да

Папка

UserName

string[255]

Нет

Имя пользователя

Password

string[255]

Нет

Пароль

ReadOnly

Boolean

Да

Только для чтения

Замечания:

Создает новый объект класса TExternalDataResource.

9.4.60.3. Метод FileNameClause (Кляуза имени поля)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.FileNameClause(FieldName: string[64]): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

FieldName

string[64]

Да

Имя поля

Замечания:

Возвращает значение типа string[2000].

9.4.60.4. Метод FindUsedName (Найти использованное имя)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.FindUsedName(Name: string[77]): clob;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[77]

Да

Имя

Замечания:

Возвращает значение типа clob.

9.4.60.5. Метод GetUsedFileNames (Получить список использованных имен)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.GetUsedFileNames: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

9.4.60.6. Метод Ole-объекта CheckExternalData (Проверить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя

Тип

Обязательно

Значение

FilesFolder

string[255]

Да

Файлы внешних данных

TrashFolder

string[255]

Да

Папка для неиспользуемых файлов

9.4.60.7. Метод Ole-объекта SaveExternalData (Сохранить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка для сохранения

9.4.61. Класс TField (Поля)

9.4.61.1. Свойства

Свойства класса TField:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Indexed

Boolean

Да

Видимо пользователю

Чтение/Запись

Индексируется

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

Localizable

Boolean

Да

Видимо пользователю

Чтение/Запись

Локализуемое

9.4.61.2. Конструктор Create (Конструктор поля)

Конструктор класса TField.
1constructor TField.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; CreateProperty: Boolean; CreateConstructorParameter: Boolean;
4  CreateViewColumns: Boolean; Logged: Boolean; Indexed: Boolean;
5  Localizable: Boolean): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

CreateProperty

Boolean

Да

Создать свойство

CreateConstructorParameter

Boolean

Да

Создать параметр конструктора

CreateViewColumns

Boolean

Да

Создать колонку во всех представлениях

Logged

Boolean

Да

Протоколировать

Indexed

Boolean

Да

Индексируется

Localizable

Boolean

Да

Локализуемое

Замечания:

Создает новый объект класса TField.

9.4.61.3. Метод SetLocalizable (Установить значение свойства "Локализуемое")

Метод экземпляра класса TField.
procedure TField.SetLocalizable(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

9.4.62. Класс TFileNameDomain (Имена файлов)

9.4.62.1. Свойства

Свойства класса TFileNameDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TStringDomain

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

FileMustExist

Boolean

Да

Видимо пользователю

Чтение/Запись

Файл должен существовать

DefaultExtension

string[10]

Нет

Видимо пользователю

Чтение/Запись

Расширение по умолчанию

OverwritePrompt

Boolean

Да

Видимо пользователю

Чтение/Запись

Запрос перезаписи

9.4.62.2. Конструктор Create (Конструктор имени файла)

Конструктор класса TFileNameDomain.
1constructor TFileNameDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean; FileMustExist: Boolean;
7  DefaultExtension: string[10]; OverwritePrompt: Boolean): TObject;
Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Унаследовано от TStringDomain.Create

AllowLeadingSpaces

Boolean

Да

AllowTrailingSpaces

Boolean

Да

AllowSpaceDuplication

Boolean

Да

CharacterSet

string[2000]

Нет

FirstCharacterSet

string[2000]

Нет

CaseMode

Boolean

Нет

Mask

string[2000]

Нет

CaseInsensitiveSearch

Boolean

Да

FileMustExist

Boolean

Да

Файл должен существовать

DefaultExtension

string[10]

Нет

Расширение по умолчанию

OverwritePrompt

Boolean

Да

Запрос перезаписи

Замечания:

Создает новый объект класса TFileNameDomain.

9.4.62.3. Метод Change (Изменение объекта)

Метод экземпляра класса TFileNameDomain.
procedure TFileNameDomain.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

9.4.62.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFileNameDomain.
function TFileNameDomain.GetSummary: string[2000];
Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.63. Класс TFilmstripView (Представление-диафильм)

9.4.63.1. Свойства

Свойства класса TFilmstripView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomView

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

LegendProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-подпись

ThumbnailProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-значок

ImageProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-изображение

ThumbnailSize

Integer

Да

Видимо пользователю

Чтение/Запись

Размер значка

OrderProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство, определяющее порядок

9.4.63.2. Конструктор Create (Конструктор представления-диафильма)

Конструктор класса TFilmstripView.
1constructor TFilmstripView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  LegendProperty: TProperty; ThumbnailProperty: TProperty;
6  ImageProperty: TProperty; ThumbnailSize: Integer;
7  OrderProperty: TProperty): TObject;
Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Унаследовано от TCustomView.Create

ColorProperty

TProperty

Нет

BoldProperty

TProperty

Нет

Skimpy

Boolean

Да

PreCompiled

Boolean

Да

PreOpenRoutine

TRoutine

Нет

LegendProperty

TProperty

Нет

Свойство-подпись

ThumbnailProperty

TProperty

Нет

Свойство-значок

ImageProperty

TProperty

Нет

Свойство-изображение

ThumbnailSize

Integer

Да

Размер значка

OrderProperty

TProperty

Нет

Свойство, определяющее порядок

Замечания:

Создает новый объект класса TFilmstripView.

9.4.64. Класс TFloatDomain (Вещественные числа)

9.4.64.1. Свойства

Свойства класса TFloatDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Нет

Видимо пользователю

Чтение/Запись

Длина

DecimalPlaces

Integer

Нет

Видимо пользователю

Чтение/Запись

Количество десятичных знаков

MinValue

float

Нет

Видимо пользователю

Чтение/Запись

Минимальное значение

MaxValue

float

Нет

Видимо пользователю

Чтение/Запись

Максимальное значение

DigitGrouping

Boolean

Да

Видимо пользователю

Чтение/Запись

Разделять группы разрядов

9.4.64.2. Конструктор Create (Конструктор вещественного домена)

Конструктор класса TFloatDomain.
1constructor TFloatDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; DecimalPlaces: Integer; MinValue: float;
4  MaxValue: float; DigitGrouping: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Нет

Длина

DecimalPlaces

Integer

Нет

Количество десятичных знаков

MinValue

float

Нет

Минимальное значение

MaxValue

float

Нет

Максимальное значение

DigitGrouping

Boolean

Да

Разделять группы разрядов

Замечания:

Создает новый объект класса TFloatDomain.

9.4.64.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFloatDomain.
function TFloatDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.65. Класс TFolderNameDomain (Имена папок файловой системы)

9.4.65.1. Свойства

Свойства класса TFolderNameDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TStringDomain

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

FolderMustExist

Boolean

Да

Видимо пользователю

Чтение/Запись

Папка должна существовать

9.4.65.2. Конструктор Create (Конструктор имени папки)

Конструктор класса TFolderNameDomain.
1constructor TFolderNameDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; Length: Integer;
4  AllowLeadingSpaces: Boolean; AllowTrailingSpaces: Boolean;
5  AllowSpaceDuplication: Boolean; CharacterSet: string[2000];
6  FirstCharacterSet: string[2000]; CaseMode: Boolean; Mask: string[2000];
7  CaseInsensitiveSearch: Boolean; FolderMustExist: Boolean): TObject;
Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Унаследовано от TStringDomain.Create

AllowLeadingSpaces

Boolean

Да

AllowTrailingSpaces

Boolean

Да

AllowSpaceDuplication

Boolean

Да

CharacterSet

string[2000]

Нет

FirstCharacterSet

string[2000]

Нет

CaseMode

Boolean

Нет

Mask

string[2000]

Нет

CaseInsensitiveSearch

Boolean

Да

FolderMustExist

Boolean

Да

Папка должна существовать

Замечания:

Создает новый объект класса TFolderNameDomain.

9.4.65.3. Метод Change (Изменение объекта)

Метод экземпляра класса TFolderNameDomain.
procedure TFolderNameDomain.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

9.4.65.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFolderNameDomain.
function TFolderNameDomain.GetSummary: string[2000];
Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.66. Класс TForm (Формы)

9.4.66.1. Свойства

Свойства класса TForm:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

AutoOpen

Boolean

Да

Видимо пользователю

Чтение/Запись

Открывать автоматически

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение-иконка

IsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Доступна

IsAlive

Boolean

Да

Видимо пользователю

Чтение/Запись

"Живая"

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Вызывать перед открытием

9.4.66.2. Конструктор Create (Конструктор формы)

Конструктор класса TForm.
1constructor TForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  AutoOpen: Boolean; Position: Integer; Scope: TScope; Image: blob;
4  IsAlive: Boolean; PreOpenRoutine: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

AutoOpen

Boolean

Да

Открывать автоматически

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

Image

blob

Нет

Изображение-иконка

IsAlive

Boolean

Да

"Живая"

PreOpenRoutine

TRoutine

Нет

Вызывать перед открытием

Замечания:

Создает новый объект класса TForm.

9.4.66.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TForm.
procedure TForm.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

9.4.66.4. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TForm.
function TForm.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.66.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TForm.
class function TForm.GetNextPos: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.67. Класс TFormAccess (Доступ к формам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.67.1. Конструктор Create (Конструктор доступа к форме)

Конструктор класса TFormAccess.
1constructor TFormAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TForm; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TForm

Да

Форма

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TFormAccess.

9.4.68. Класс TFormBan (Запрет на форму)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.68.1. Свойства

Свойства класса TFormBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedForm

TForm

Да

Видимо пользователю

Чтение/Запись

Запрещаемая форма

9.4.68.2. Конструктор Create (Конструктор запрета на форму)

Конструктор класса TFormBan.
1constructor TFormBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedForm: TForm): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedForm

TForm

Да

Запрещаемая форма

Замечания:

Создает новый объект класса TFormBan.

9.4.69. Класс TFormOption (Настройки формы)

Имена объектов класса генерируются.

9.4.69.1. Свойства

Свойства класса TFormOption:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Option

TOption

Да

Видимо пользователю

Чтение/Запись

Настройка

Position

Integer

Нет

Видимо пользователю

Чтение/Запись

Позиция

ShowEmptyValue

Boolean

Да

Видимо пользователю

Чтение/Запись

Показывать пустое значение

9.4.69.2. Конструктор Create (Конструктор настройки формы)

Конструктор класса TFormOption.
1constructor TFormOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Option: TOption; Position: Integer; ShowEmptyValue: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Option

TOption

Да

Настройка

Position

Integer

Нет

Позиция

ShowEmptyValue

Boolean

Да

Показывать пустое значение

Замечания:

Создает новый объект класса TFormOption.

9.4.69.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormOption.
class function TFormOption.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Да

Мастер

Замечания:

Возвращает значение типа Integer.

9.4.70. Класс TFormView (Представления формы)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

9.4.70.1. Свойства

Свойства класса TFormView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления минимизированы

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство выделенного шрифта

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство цвета

Layout

TFormViewLayout

Да

Видимо пользователю

Чтение/Запись

Расположение

ChildrenOnTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления на закладках

ExplicitQuery

Boolean

Да

Видимо пользователю

Чтение/Запись

Явный запрос

SpacePercentage

Integer

Нет

Видимо пользователю

Чтение/Запись

Площадь, %

9.4.70.2. Конструктор Create (Конструктор представления формы)

Конструктор класса TFormView.
1constructor TFormView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout;
6  ExplicitQuery: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Представление

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

ChildrenOnTabs

Boolean

Да

Дочерние представления на закладках

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

Position

Integer

Да

Позиция

SpacePercentage

Integer

Нет

Площадь, %

Layout

TFormViewLayout

Да

Расположение

ExplicitQuery

Boolean

Да

Явный запрос

Замечания:

Создает новый объект класса TFormView.

9.4.70.3. Метод GetName (Сгенерировать имя объекта)

Метод экземпляра класса TFormView.
function TFormView.GetName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

9.4.70.4. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormView.
class function TFormView.GetNextPos(Parent: TObject; Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Master

TObject

Да

Мастер

Замечания:

Возвращает значение типа Integer.

9.4.71. Класс TFormViewAction (Действие-форма)

Объекты класса образуют иерархию.

9.4.71.1. Свойства

Свойства класса TFormViewAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Да

Видимо пользователю

Чтение/Запись

Представление формы

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

OverrideMasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Подменить свойство-главное

OverrideDetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Подменить свойство-подчиненное

9.4.71.2. Конструктор Create (Конструктор действия-формы)

Конструктор класса TFormViewAction.
1constructor TFormViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  FormView: TFormView; OverrideMasterProperty: TProperty;
5  OverrideDetailProperty: TClassMember): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

FormView

TFormView

Да

Представление формы

OverrideMasterProperty

TProperty

Нет

Подменить свойство-главное свойством

OverrideDetailProperty

TClassMember

Нет

Подменить свойство-подчиненное свойством

Замечания:

Создает новый объект класса TFormViewAction.

9.4.72. Класс TImportedReplica (Импортированные реплики)

Объекты класса не именованы.

9.4.72.1. Свойства

Свойства класса TImportedReplica:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

CRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма

MetadataCRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма метаданных

9.4.72.2. Конструктор Create (Конструктор импортированной реплики)

Конструктор класса TImportedReplica.
1constructor TImportedReplica.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CRC: string[8]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

CRC

string[8]

Нет

Контрольная сумма

Замечания:

Создает новый объект класса TImportedReplica.

9.4.73. Класс TInlineExpression (Встраиваемое выражение)

9.4.73.1. Свойства

Свойства класса TInlineExpression:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Expression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

9.4.73.2. Конструктор Create (Конструктор встраиваемого выражения)

Конструктор класса TInlineExpression.
1constructor TInlineExpression.Create(Name: string[30];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Expression: clob; Domain: TDomain): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Expression

clob

Нет

Выражение

Domain

TDomain

Да

Домен

Замечания:

Создает новый объект класса TInlineExpression.

9.4.74. Класс TInstantContact (Контакты)

Имена объектов класса генерируются.

9.4.74.1. Свойства

Свойства класса TInstantContact:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Владелец

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Владелец - текущий пользователь

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Status

TInstantContactStatus

Да

Видимо пользователю

Чтение/Запись

Статус

BackContact

TInstantContact

Нет

Видимо пользователю

Только для чтения

Ответный контакт

BackContactStatus

TInstantContactStatus

Да

Видимо пользователю

Только для чтения

Состояние ответного контакта

9.4.74.2. Конструктор Create (Конструктор контакта)

Конструктор класса TInstantContact.
1constructor TInstantContact.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Status: TInstantContactStatus): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Пользователь

Status

TInstantContactStatus

Да

Статус

Замечания:

Создает новый объект класса TInstantContact.

9.4.74.3. Метод AddContact (Добавить контакт)

Метод класса (статический метод) класса TInstantContact.
class function TInstantContact.AddContact(Master: TUser; User: TUser): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TUser

Да

Мастер

User

TUser

Да

Пользователь

Замечания:

Возвращает значение типа TObject.

9.4.74.4. Метод LastUsedContact (Получить последний использованный контакт)

Метод класса (статический метод) класса TInstantContact.
class function TInstantContact.LastUsedContact(AUser: TUser): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AUser

TUser

Да

Пользователь

Замечания:

Возвращает значение типа TObject.

9.4.75. Класс TInstantMessage (Сообщения)

Объекты класса не именованы.

9.4.75.1. Свойства

Свойства класса TInstantMessage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Владелец

User

TUser

Да

Видимо пользователю

Чтение/Запись

Пользователь

Message

string[255]

Да

Видимо пользователю

Только для чтения

Сообщение

DeliveryTime

datetime

Да

Видимо пользователю

Только для чтения

Время доставки

AttachmentType

TInstantMessageAttachmentType (None)

Да

Скрыто от пользователя

Только для чтения

Тип вложения

9.4.75.2. Конструктор Create (Конструктор сообщения)

Конструктор класса TInstantMessage.
1constructor TInstantMessage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Message: string[255]; DeliveryTime: datetime): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Пользователь

Message

string[255]

Да

Сообщение

DeliveryTime

datetime

Нет

Время доставки

Замечания:

Создает новый объект класса TInstantMessage.

9.4.75.3. Метод Archive (Отправить в архив)

Метод класса (статический метод) класса TInstantMessage.
1class procedure TInstantMessage.Archive(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

9.4.75.4. Метод Clear (Очистить)

Метод класса (статический метод) класса TInstantMessage.
1class procedure TInstantMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

9.4.76. Класс TInstantMessageAttachment (Сообщения с вложением)

Объекты класса не именованы.

9.4.76.1. Свойства

Свойства класса TInstantMessageAttachment:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TInstantMessage

User

TUser

Да

Видимо пользователю

Чтение/Запись

Message

string[255]

Да

Видимо пользователю

Только для чтения

DeliveryTime

datetime

Да

Видимо пользователю

Только для чтения

AttachmentType

TInstantMessageAttachmentType

Да

Видимо пользователю

Только для чтения

Тип вложения

FileBody

blob

Нет

Видимо пользователю

Только для чтения

Содержимое файла

FormView

TFormView

Нет

Видимо пользователю

Только для чтения

Представление формы

Form

TForm

Да

Видимо пользователю

Только для чтения

Форма

FormIsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Форма доступна

Object

TObject

Нет

Видимо пользователю

Только для чтения

Объект

HyperLink

string[256]

Нет

Видимо пользователю

Только для чтения

Гиперссылка

9.4.76.2. Конструктор Create (Конструктор сообщения с вложением)

Конструктор класса TInstantMessageAttachment.
1constructor TInstantMessageAttachment.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; User: TUser; Message: string[255];
4  DeliveryTime: datetime; FileName: string[255]; FileBaseName: string[128];
5  FileBody: blob; FormView: TFormView; Object: TObject; HyperLink: string[256];
6  AttachmentType: TInstantMessageAttachmentType): TObject;
Переопределяет метод в TInstantMessage.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Унаследовано от TInstantMessage.Create

Message

string[255]

Да

DeliveryTime

datetime

Нет

FileName

string[255]

Нет

Имя файла

FileBaseName

string[128]

Да

Базовое имя файла

FileBody

blob

Нет

Содержимое файла

FormView

TFormView

Нет

Представление

Object

TObject

Нет

Объект

HyperLink

string[256]

Нет

Гиперссылка

AttachmentType

TInstantMessageAttachmentType

Да

Тип приложения

Замечания:

Создает новый объект класса TInstantMessageAttachment.

9.4.77. Класс TIntegerDomain (Целые числа)

9.4.77.1. Свойства

Свойства класса TIntegerDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

MinValue

Integer

Нет

Видимо пользователю

Чтение/Запись

Минимальное значение

MaxValue

Integer

Нет

Видимо пользователю

Чтение/Запись

Максимальное значение

9.4.77.2. Конструктор Create (Конструктор целочисленного домена)

Конструктор класса TIntegerDomain.
1constructor TIntegerDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; MinValue: Integer; MaxValue: Integer): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

MinValue

Integer

Нет

Минимальное значение

MaxValue

Integer

Нет

Максимальное значение

Замечания:

Создает новый объект класса TIntegerDomain.

9.4.77.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TIntegerDomain.
function TIntegerDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.78. Класс TLanguage (Языки)

9.4.78.1. Свойства

Свойства класса TLanguage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

DatabaseLanguage

Boolean

Да

Видимо пользователю

Только для чтения

По умолчанию

IsCurrent

Boolean

Да

Видимо пользователю

Чтение/Запись

Является текущим

9.4.78.2. Конструктор Create (Конструктор языка)

Конструктор класса TLanguage.
1constructor TLanguage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TLanguage.

9.4.78.3. Метод GetCurrentLanguage (Получить текущий язык)

Метод класса (статический метод) класса TLanguage.
class function TLanguage.GetCurrentLanguage: TLanguage;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TLanguage.

9.4.78.4. Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TLanguage.
function TLanguage.GetIsCurrent: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.78.5. Метод SetIsCurrent (Установить язык как текущий)

Метод экземпляра класса TLanguage.
procedure TLanguage.SetIsCurrent(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

9.4.78.6. Метод Ole-объекта SaveResourceFile (Сохранить файл ресурсов)

Метод Ole-объекта класса TLanguage.

Параметры:

Имя

Тип

Обязательно

Значение

XliffFileName

string[255]

Да

Файл ресурсов

9.4.79. Класс TLanguageTranslation (Переводы)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.79.1. Свойства

Свойства класса TLanguageTranslation:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Language

TLanguage

Да

Видимо пользователю

Только для чтения

Язык

DatabaseLanguage

Boolean

Да

Видимо пользователю

Только для чтения

Язык используется по умолчанию

CurrentLanguage

Boolean

Да

Видимо пользователю

Только для чтения

Язык является текущим

Status

TTranslationStatus

Да

Видимо пользователю

Только для чтения

Состояние

OwnerObject

TObject

Нет

Скрыто от пользователя

Только для чтения

Владелец-объект

OwnerObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс объекта-владельца

OwnerField

TField

Нет

Скрыто от пользователя

Только для чтения

Владелец-поле

Owner

string[64]

Нет

Скрыто от пользователя

Только для чтения

Владелец

Translation

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Перевод

Original

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Оригинал

Identifier

string[2000]

Нет

Видимо пользователю

Только для чтения

Идентификатор

GlobalIdentifier

string[2000]

Нет

Видимо пользователю

Только для чтения

Глобальный идентификатор

9.4.79.2. Конструктор Create (Конструктор перевода)

Конструктор класса TLanguageTranslation.
1constructor TLanguageTranslation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Language: TLanguage; OwnerObject: TObject;
4  OwnerField: TField; Owner: string[64]; Translation: string[2000]): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Language

TLanguage

Да

Язык

OwnerObject

TObject

Нет

Владелец-объект

OwnerField

TField

Нет

Владелец-поле

Owner

string[64]

Нет

Владелец

Translation

string[2000]

Нет

Перевод

Замечания:

Создает новый объект класса TLanguageTranslation.

9.4.79.3. Метод Add (Создать набор переводов)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.Add(Owner: string[64];
2  Original: string[2000]): TLanguageTranslation;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Owner

string[64]

Да

Идентификатор

Original

string[2000]

Нет

Оригинал

Замечания:

Возвращает значение типа TLanguageTranslation.

9.4.79.4. Метод Append (Добавить перевод)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.Append(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]): TLanguageTranslation;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

AValue

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TLanguageTranslation.

9.4.79.5. Метод GetGlobalIdent (Получить глобальный идентификатор)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetGlobalIdent: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.79.6. Метод GetIdent (Получить идентификатор)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetIdent: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.79.7. Метод GetLanguageTranslation (Получить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.GetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

Замечания:

Возвращает значение типа string[2000].

9.4.79.8. Метод GetOriginal (Получить оригинал)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetOriginal: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.79.9. Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TLanguageTranslation.
class function TLanguageTranslation.GetResource(AOwner: string[64]): string[2000];
Переопределяет метод в TObject.GetResource.

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

Замечания:

Возвращает значение типа string[2000].

9.4.79.10. Метод Load (Загрузить значение)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.Load(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

9.4.79.11. Метод MarkAsTranslatable (Отметить как переводимый)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.MarkAsTranslatable;
Метод не имеет параметров.

9.4.79.12. Метод MarkAsUntranslatable (Отметить как непереводимый)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.MarkAsUntranslatable;
Метод не имеет параметров.

9.4.79.13. Метод SetLanguageTranslation (Установить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.SetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

AValue

string[2000]

Нет

Значение

9.4.79.14. Метод SetOriginal (Установить оригинал)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.SetOriginal(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

9.4.79.15. Метод SetOwnerSecurity (Установить атрибуты безопасности по владельцу-объекту)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.SetOwnerSecurity(AOwnerObject: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwnerObject

TObject

Нет

Владелец-объект

9.4.79.16. Метод SetTranslation (Установить перевод)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.SetTranslation(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

9.4.79.17. Метод Validate (Актуализировать)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.Validate(ValidateResources: Boolean;
2  ValidateData: Boolean; ValidateClass: TClass; ValidateField: TField);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ValidateResources

Boolean

Да

Актуализировать ресурсы

ValidateData

Boolean

Да

Актуализировать данные

ValidateClass

TClass

Нет

Актуализировать объекты класса

ValidateField

TField

Нет

Актуализировать значения поля

9.4.79.18. Метод ValidateAllObjects (Актуализировать все объекты)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.ValidateAllObjects(ValidateClass: TClass;
2  ValidateField: TField);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ValidateClass

TClass

Нет

Актуализировать объекты класса

ValidateField

TField

Нет

Актуализировать значения поля

9.4.79.19. Метод ValidateObject (Актуализировать объект)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.ValidateObject(AOwnerObject: TObject;
2  AOwnerField: TField);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

9.4.79.20. Метод ValidateOwned (Актуализировать имеющих владельца)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.ValidateOwned;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

9.4.79.21. Метод ValidateOwner (Актуализировать по владельцу)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.ValidateOwner(AOwner: string[64]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

9.4.80. Класс TMethod (Методы)

9.4.80.1. Свойства

Свойства класса TMethod:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Body

clob

Нет

Видимо пользователю

Чтение/Запись

Тело

CallTemplate

string[2000]

Нет

Видимо пользователю

Только для чтения

Шаблон вызова

Virtual

Boolean

Да

Видимо пользователю

Чтение/Запись

Виртуальный

DBMSName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта СУБД

9.4.80.2. Конструктор Create (Конструктор метода)

Конструктор класса TMethod.
1constructor TMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; Body: clob;
6  Virtual: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

Body

clob

Нет

Тело

Virtual

Boolean

Да

Метод является виртуальным

Замечания:

Создает новый объект класса TMethod.

9.4.80.3. Метод Call (Вызвать)

Метод экземпляра класса TMethod.
procedure TMethod.Call(Parameters: TObjectList);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Parameters

TObjectList

Нет

Параметры

9.4.80.4. Метод CallTemplate (Шаблон вызова)

Метод экземпляра класса TMethod.
function TMethod.CallTemplate: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.80.5. Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TMethod.
function TMethod.GetDBMSName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

9.4.80.6. Метод VirtualChainRoot (Корень виртуальной цепи)

Метод экземпляра класса TMethod.
function TMethod.VirtualChainRoot: TMethod;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TMethod.

9.4.81. Класс TObject (Объекты)

9.4.81.1. Свойства

Свойства класса TObject:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Имя

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Наименование

Class

TClass

Да

Скрыто от пользователя

Только для чтения

Класс

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Статус репликации

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Родитель

Master

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

База данных-источник

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

GUID базы данных-источника

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

База данных-источник является текущей

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Идентификатор при создании

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Создано пользователем

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Создано

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Изменено пользователем

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Изменено

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Роль для чтения

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Роль для записи

9.4.81.2. Конструктор Create (Конструктор объекта)

Конструктор класса TObject.
1constructor TObject.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Class

TClass

Нет

Класс

Parent

TObject

Нет

Родитель

Master

TObject

Да

Мастер

Accessor

TSecurityAccount

Нет

Роль доступа

Замечания:

Создает новый объект класса TObject.

9.4.81.3. Деструктор Destroy (Деструктор объекта)

Деструктор класса TObject.
destructor TObject.Destroy;
Метод не имеет параметров.

Замечания:

Уничтожает объект класса TObject или его наследника.

9.4.81.4. Метод ApplyStringBuilder (Применить шаблон)

Метод экземпляра класса TObject.
function TObject.ApplyStringBuilder(Template: string[2000]): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа string[2000].

9.4.81.5. Метод ApplyStringBuilderClob (Применить шаблон-большой текстовый объект)

Метод экземпляра класса TObject.
function TObject.ApplyStringBuilderClob(Template: string[2000]): clob;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа clob.

9.4.81.6. Метод ASCII (ASCII-код)

Метод класса (статический метод) класса TObject.
class function TObject.ASCII(Value: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

9.4.81.7. Метод Assigned (Проверка пустоты значения)

Метод класса (статический метод) класса TObject.
class function TObject.Assigned(Value: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.81.8. Метод BlobToClob (Большой двоичный объект в большой текстовый объект)

Метод класса (статический метод) класса TObject.
class function TObject.BlobToClob(Value: blob): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

blob

Нет

Значение

Замечания:

Возвращает значение типа clob.

9.4.81.9. Метод BoolToStr (Логическое значение в строку)

Метод класса (статический метод) класса TObject.
1class function TObject.BoolToStr(Value: Boolean;
2  Domain: TBooleanDomain): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

Domain

TBooleanDomain

Нет

Домен

Замечания:

Возвращает значение типа string[2000].

9.4.81.10. Метод Change (Изменение объекта)

Метод экземпляра класса TObject.
procedure TObject.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

9.4.81.11. Метод Char (Символ)

Метод класса (статический метод) класса TObject.
class function TObject.Char(Value: Integer): string[2];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2].

9.4.81.12. Метод ClobReplace (Заменить содержимое большого текстового объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.ClobReplace(Value: clob; OldPattern: string[2000];
2  NewPattern: string[2000]; ReplaceAll: Boolean): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

OldPattern

string[2000]

Нет

Старый шаблон

NewPattern

string[2000]

Нет

Новый шаблон

ReplaceAll

Boolean

Да

Заменять все

Замечания:

Возвращает значение типа clob.

9.4.81.13. Метод ClobToBlob (Большой текстовый объект в большой двоичный объект)

Метод класса (статический метод) класса TObject.
class function TObject.ClobToBlob(Value: clob): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа blob.

9.4.81.14. Метод Concatenate (Управляемая конкатенация строк)

Метод класса (статический метод) класса TObject.
1class function TObject.Concatenate(Value: string[2000]; AddOn: string[2000];
2  MaxLength: Integer; Delimiter: string[2000]; Ellipsis: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

AddOn

string[2000]

Нет

Присоединяемая строка

MaxLength

Integer

Да

Максимальная длина

Delimiter

string[2000]

Нет

Разделитель

Ellipsis

Boolean

Да

Эллипсис

Замечания:

Возвращает значение типа string[2000].

9.4.81.15. Метод Copy (Копировать)

Метод класса (статический метод) класса TObject.
1class function TObject.Copy(String: string[2000]; StartPos: Integer;
2  Length: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

String

string[2000]

Нет

Строка

StartPos

Integer

Нет

Позиция

Length

Integer

Нет

Длина

Замечания:

Возвращает значение типа string[2000].

9.4.81.16. Метод CopyClob (Копировать из большого текстового объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.CopyClob(Value: clob; StartPos: Integer;
2  Length: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

StartPos

Integer

Нет

Позиция

Length

Integer

Нет

Длина

Замечания:

Возвращает значение типа string[2000].

9.4.81.17. Метод CreateGUID (Создать GUID)

Метод класса (статический метод) класса TObject.
class function TObject.CreateGUID: string[38];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[38].

9.4.81.18. Метод DateOf (Дату из даты со временем)

Метод класса (статический метод) класса TObject.
class function TObject.DateOf(Value: datetime): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа date.

9.4.81.19. Метод DatePart (Часть даты)

Метод класса (статический метод) класса TObject.
class function TObject.DatePart(Value: date; Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

9.4.81.20. Метод DateTimePart (Часть даты со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.DateTimePart(Value: datetime;
2  Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

9.4.81.21. Метод DateTimeToStr (Дату и время в строку)

Метод класса (статический метод) класса TObject.
class function TObject.DateTimeToStr(Value: datetime): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Да

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.81.22. Метод DateToStr (Дату в строку)

Метод класса (статический метод) класса TObject.
class function TObject.DateToStr(Value: date): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.81.23. Метод Dequeue (Удалить из очереди)

Метод экземпляра класса TObject.
procedure TObject.Dequeue(Permanently: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Permanently

Boolean

Да

Удалить навсегда

9.4.81.24. Метод DescribeObject (Описание объекта для сообщений пользователю)

Метод экземпляра класса TObject.
function TObject.DescribeObject: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.81.25. Метод DumpString (Строка в виде списка кодов символов)

Метод класса (статический метод) класса TObject.
1class function TObject.DumpString(Value: string[2000]; Delimiter: string[2000];
2  Hexadecimal: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Hexadecimal

Boolean

Да

Использовать шестнадцатеричные значения

Замечания:

Возвращает значение типа string[2000].

9.4.81.26. Метод Ellipsis (Эллипсис)

Метод класса (статический метод) класса TObject.
1class function TObject.Ellipsis(Value: string[2000]; MaxLength: Integer;
2  WholeWords: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

WholeWords

Boolean

Да

По целым словам

Замечания:

Возвращает значение типа string[2000].

9.4.81.27. Метод EncodeDate (Собрать дату)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeDate(Year: Integer; Month: Integer;
2  Day: Integer): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Year

Integer

Нет

Год

Month

Integer

Нет

Месяц

Day

Integer

Нет

День

Замечания:

Возвращает значение типа date.

9.4.81.28. Метод EncodeDateTime (Собрать дату со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeDateTime(Year: Integer; Month: Integer;
2  Day: Integer; Hours: Integer; Minutes: Integer; Seconds: Integer): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Year

Integer

Нет

Год

Month

Integer

Нет

Месяц

Day

Integer

Нет

День

Hours

Integer

Нет

Часы

Minutes

Integer

Нет

Минуты

Seconds

Integer

Нет

Секунды

Замечания:

Возвращает значение типа datetime.

9.4.81.29. Метод EncodeTime (Собрать время)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeTime(Hours: Integer; Minutes: Integer;
2  Seconds: Integer): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Hours

Integer

Нет

Часы

Minutes

Integer

Нет

Минуты

Seconds

Integer

Нет

Секунды

Замечания:

Возвращает значение типа time.

9.4.81.30. Метод Enqueue (Поставить в очередь)

Метод экземпляра класса TObject.
function TObject.Enqueue(QueueName: string[64]): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

QueueName

string[64]

Да

Имя очереди

Замечания:

Возвращает значение типа Boolean.

9.4.81.31. Метод Find (Поиск объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.Find(Name: string[64]; Class: TClass; Parent: TObject;
2  Master: TObject): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Class

TClass

Нет

Класс объекта

Parent

TObject

Нет

Родительский объект

Master

TObject

Да

Мастер объекта

Замечания:

Возвращает значение типа TObject.

9.4.81.32. Метод FindGlobal (Глобальный поиск объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.FindGlobal(SourceDataBaseGUID: string[38];
2  OldID: string[38]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

SourceDataBaseGUID

string[38]

Да

GUID базы данных-источника

OldID

string[38]

Да

Идентификатор при создании

Замечания:

Возвращает значение типа TObject.

9.4.81.33. Метод FloatToStr (Вещественное в строку)

Метод класса (статический метод) класса TObject.
class function TObject.FloatToStr(Value: float): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.81.34. Метод FormatDate (Форматировать дату)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatDate(Value: date;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

9.4.81.35. Метод FormatDateTime (Форматировать дату со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatDateTime(Value: datetime;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

9.4.81.36. Метод FormatFloat (Форматировать вещественное значение)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatFloat(Value: float; DecimalPlaces: Integer;
2  DecimalSeparator: string[2]; GroupSeparator: string[2]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

DecimalPlaces

Integer

Нет

Количество десятичных знаков

DecimalSeparator

string[2]

Нет

Десятичный разделитель

GroupSeparator

string[2]

Нет

Разделитель групп разрядов

Замечания:

Возвращает значение типа string[2000].

9.4.81.37. Метод FormatTime (Форматировать время)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatTime(Value: time;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

9.4.81.38. Метод GenerateAllNames (Сгенерировать имена для всех объектов)

Метод класса (статический метод) класса TObject.
class function TObject.GenerateAllNames: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.81.39. Метод GeneratedDescription (Сгенерированное наименование)

Метод экземпляра класса TObject.
function TObject.GeneratedDescription: string[128];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].

9.4.81.40. Метод GeneratedName (Сгенерированное имя)

Метод экземпляра класса TObject.
function TObject.GeneratedName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

9.4.81.41. Метод GetBlobSize (Размер большого двоичного объекта)

Метод класса (статический метод) класса TObject.
class function TObject.GetBlobSize(Value: blob): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

blob

Нет

Значение

Замечания:

Возвращает значение типа Integer.

9.4.81.42. Метод GetChildCount (Получить количество дочерних объектов)

Метод экземпляра класса TObject.
function TObject.GetChildCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.81.43. Метод GetClobSize (Размер большого текстового объекта)

Метод класса (статический метод) класса TObject.
class function TObject.GetClobSize(Value: clob): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа Integer.

9.4.81.44. Метод GetDescendantCount (Получить количество объектов-потомков)

Метод экземпляра класса TObject.
function TObject.GetDescendantCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.81.45. Метод GetDetailCount (Получить количество подчиненных объектов)

Метод экземпляра класса TObject.
function TObject.GetDetailCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.81.46. Метод GetLevel (Уровень в иерархии)

Метод экземпляра класса TObject.
function TObject.GetLevel: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.81.47. Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TObject.
class function TObject.GetResource(AOwner: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

Замечания:

Возвращает значение типа string[2000].

9.4.81.48. Метод GetRoot (Получить корень иерархии)

Метод экземпляра класса TObject.
function TObject.GetRoot: TObject;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.

9.4.81.49. Метод GetTop (Получить объект верхнего уровня)

Метод экземпляра класса TObject.
function TObject.GetTop: TObject;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.

9.4.81.50. Метод HasAsChild (Объект является ребенком данного)

Метод экземпляра класса TObject.
function TObject.HasAsChild(Child: TObject): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Child

TObject

Нет

Дочерний объект

Замечания:

Возвращает значение типа Boolean.

9.4.81.51. Метод HasAsParent (Объект является родителем данного)

Метод экземпляра класса TObject.
function TObject.HasAsParent(Parent: TObject): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Boolean.

9.4.81.52. Метод HasChildren (Имеет детей)

Метод экземпляра класса TObject.
function TObject.HasChildren: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.81.53. Метод HasDetails (Имеет подчиненные объекты)

Метод экземпляра класса TObject.
function TObject.HasDetails: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.81.54. Метод Hash (Хеш-функция конца строки)

Метод класса (статический метод) класса TObject.
1class function TObject.Hash(Value: string[2000];
2  MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

9.4.81.55. Метод HashReverse (Хеш-функция начала строки)

Метод класса (статический метод) класса TObject.
1class function TObject.HashReverse(Value: string[2000];
2  MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

9.4.81.56. Метод HexToInt (Шестнадцатеричное представление в целое число)

Метод класса (статический метод) класса TObject.
class function TObject.HexToInt(Hexadecimal: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Hexadecimal

string[64]

Да

Шестнадцатеричное значение

Замечания:

Возвращает значение типа Integer.

9.4.81.57. Метод IfThenDate (Выбор из двух дат)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenDate(Value: Boolean; ATrue: date;
2  AFalse: date): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

date

Нет

Значение при выполнении условия

AFalse

date

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа date.

9.4.81.58. Метод IfThenDateTime (Выбор из двух дат со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenDateTime(Value: Boolean; ATrue: datetime;
2  AFalse: datetime): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

datetime

Нет

Значение при выполнении условия

AFalse

datetime

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа datetime.

9.4.81.59. Метод IfThenExternalData (Выбор из двух значений - внешних данных)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenExternalData(Value: Boolean; ATrue: <external
2  data>; AFalse: <external data>): <external data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

<external data>

Нет

Значение при выполнении условия

AFalse

<external data>

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа <external data>.

9.4.81.60. Метод IfThenFloat (Выбор из двух вещественных)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenFloat(Value: Boolean; ATrue: float;
2  AFalse: float): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

float

Нет

Значение при выполнении условия

AFalse

float

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа float.

9.4.81.61. Метод IfThenInt (Выбор из двух целых)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenInt(Value: Boolean; ATrue: Integer;
2  AFalse: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

Integer

Нет

Значение при выполнении условия

AFalse

Integer

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа Integer.

9.4.81.62. Метод IfThenObject (Выбор из двух объектов)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenObject(Value: Boolean; ATrue: TObject;
2  AFalse: TObject): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

TObject

Нет

Значение при выполнении условия

AFalse

TObject

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа TObject.

9.4.81.63. Метод IfThenStr (Выбор из двух строк)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenStr(Value: Boolean; ATrue: string[2000];
2  AFalse: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

string[2000]

Нет

Значение при выполнении условия

AFalse

string[2000]

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа string[2000].

9.4.81.64. Метод IfThenTime (Выбор из двух времен)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenTime(Value: Boolean; ATrue: time;
2  AFalse: time): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

time

Нет

Значение при выполнении условия

AFalse

time

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа time.

9.4.81.65. Метод InstanceObject (Объект по строковому представлению идентификатора (объект может не существовать))

Метод класса (статический метод) класса TObject.
class function TObject.InstanceObject(Value: string[38]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[38]

Да

Значение

Замечания:

Возвращает значение типа TObject.

9.4.81.66. Метод IntToHex (Целое число в шестнадцатеричное представление)

Метод класса (статический метод) класса TObject.
class function TObject.IntToHex(IntValue: Integer): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

IntValue

Integer

Нет

Целое значение

Замечания:

Возвращает значение типа string[64].

9.4.81.67. Метод IntToStr (Целое в строку)

Метод класса (статический метод) класса TObject.
class function TObject.IntToStr(Value: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.81.68. Метод IsBadHierarchy (Ошибка в иерархии)

Метод экземпляра класса TObject.
function TObject.IsBadHierarchy: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.81.69. Метод IsBadPtr (Не указывает на существующий объект)

Метод экземпляра класса TObject.
function TObject.IsBadPtr: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.81.70. Метод IsCharAlpha (Символ является алфавитным)

Метод класса (статический метод) класса TObject.
class function TObject.IsCharAlpha(Value: string[2]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.81.71. Метод IsCharAlphaNumeric (Символ является алфавитно-числовым)

Метод класса (статический метод) класса TObject.
class function TObject.IsCharAlphaNumeric(Value: string[2]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.81.72. Метод IsInList (Объект входит в список)

Метод экземпляра класса TObject.
function TObject.IsInList(Value: TObjectList): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectList

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.81.73. Метод IsInSet (Объект входит в множество)

Метод экземпляра класса TObject.
function TObject.IsInSet(Value: TObjectSet): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.81.74. Метод IsInstanceOf (Является экземпляром класса)

Метод экземпляра класса TObject.
function TObject.IsInstanceOf(Class: TClass): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Class

TClass

Нет

Класс

Замечания:

Возвращает значение типа Boolean.

9.4.81.75. Метод IsNotInList (Объект не входит в список)

Метод экземпляра класса TObject.
function TObject.IsNotInList(Value: TObjectList): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectList

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.81.76. Метод IsNotInSet (Объект не входит в множество)

Метод экземпляра класса TObject.
function TObject.IsNotInSet(Value: TObjectSet): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.81.77. Метод LineBreak (Разделитель строк)

Метод класса (статический метод) класса TObject.
class function TObject.LineBreak: string[2];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2].

9.4.81.78. Метод LinkClobs (Присоединить большой объект к другому)

Метод класса (статический метод) класса TObject.
class function TObject.LinkClobs(PrefData: clob; PostData: clob): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

PrefData

clob

Нет

Данные первого объекта

PostData

clob

Нет

Данные второго объекта

Замечания:

Возвращает значение типа clob.

9.4.81.79. Метод LinkToClob (Присоединить строки к большому объекту)

Метод класса (статический метод) класса TObject.
1class function TObject.LinkToClob(Prefix: string[2000]; Data: clob;
2  Postfix: string[2000]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Prefix

string[2000]

Нет

Префикс

Data

clob

Нет

Данные

Postfix

string[2000]

Нет

Постфикс

Замечания:

Возвращает значение типа clob.

9.4.81.80. Метод Locate (Поиск объекта по локатору)

Метод класса (статический метод) класса TObject.
class function TObject.Locate(Locator: string[2000]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Locator

string[2000]

Нет

Локатор

Замечания:

Возвращает значение типа TObject.

9.4.81.81. Метод Locator (Локатор объекта)

Метод экземпляра класса TObject.
function TObject.Locator: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.81.82. Метод LowerCase (Преобразовать к нижнему регистру)

Метод класса (статический метод) класса TObject.
class function TObject.LowerCase(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.81.83. Метод MatchRegExp (Проверка соответствия строки регулярному выражению)

Метод класса (статический метод) класса TObject.
1class function TObject.MatchRegExp(Value: string[2000];
2  RegExp: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

RegExp

string[2000]

Нет

Регулярное выражение

Замечания:

Возвращает значение типа Boolean.

9.4.81.84. Метод MergeIdentifiers (Объединенный идентификатор)

Метод класса (статический метод) класса TObject.
1class function TObject.MergeIdentifiers(Identifier: string[64];
2  Modifier: string[64]; MaxLength: Integer): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Identifier

string[64]

Да

Идентификатор

Modifier

string[64]

Да

Модификатор

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[64].

9.4.81.85. Метод MergeTo (Отождествить с)

Метод экземпляра класса TObject.
procedure TObject.MergeTo(PrimaryObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

PrimaryObject

TObject

Да

Первичный объект

9.4.81.86. Метод Modulus (Остаток деления)

Метод класса (статический метод) класса TObject.
class function TObject.Modulus(Value: Integer; Base: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Делимое

Base

Integer

Нет

Делитель

Замечания:

Возвращает значение типа Integer.

9.4.81.87. Метод ObjectInstance (Текстовое представление идентификатора объекта (объект может не существовать))

Метод класса (статический метод) класса TObject.
class function TObject.ObjectInstance(Value: TObject): string[38];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа string[38].

9.4.81.88. Метод Pos (Поиск подстроки)

Метод класса (статический метод) класса TObject.
1class function TObject.Pos(Substring: string[2000];
2  Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Substring

string[2000]

Нет

Подстрока

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

9.4.81.89. Метод PreprocessRegExp (Адаптировать регулярное выражение к требованиям СУБД)

Метод класса (статический метод) класса TObject.
class function TObject.PreprocessRegExp(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.81.90. Метод QualifiedName (Квалифицированное имя)

Метод экземпляра класса TObject.
function TObject.QualifiedName: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.81.91. Метод QuotedStr (Строку в апострофы)

Метод класса (статический метод) класса TObject.
class function TObject.QuotedStr(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.81.92. Метод RaiseException (Возбудить исключение)

Метод класса (статический метод) класса TObject.
class procedure TObject.RaiseException(Message: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Message

string[2000]

Нет

Сообщение

9.4.81.93. Метод RaiseResource (Возбудить исключение по ресурсной строке)

Метод класса (статический метод) класса TObject.
class procedure TObject.RaiseResource(AOwner: string[64]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

9.4.81.94. Метод ReadFromClob (Считать строку из большого текстового объекта)

Метод класса (статический метод) класса TObject.
class function TObject.ReadFromClob(Value: clob): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.81.95. Метод ResourceByItem (Значение ресурсной строки)

Метод класса (статический метод) класса TObject.
class function TObject.ResourceByItem(Resource: Resource strings): string[128];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Resource

Resource strings

Нет

Ресурс

Замечания:

Возвращает значение типа string[128].

9.4.81.96. Метод Round (Округление)

Метод класса (статический метод) класса TObject.
class function TObject.Round(Value: float; Decimals: Integer): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Decimals

Integer

Нет

Количество десятичных знаков

Замечания:

Возвращает значение типа float.

9.4.81.97. Метод SendInstantMessage (Отправить мгновенное сообщение)

Метод класса (статический метод) класса TObject.
1class procedure TObject.SendInstantMessage(Recipient: TUser;
2  MessageText: string[255]; DeliveryTime: datetime; AttachSelected: Boolean;
3  Selected: TObjectList; CurrentFormView: TFormView; HyperLink: string[256];
4  FileName: string[255]; FileBaseName: string[128]; FileBody: blob;
5  AttachmentType: TInstantMessageAttachmentType);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Recipient

TUser

Да

Получатель

MessageText

string[255]

Да

Сообщение

DeliveryTime

datetime

Нет

Время доставки

AttachSelected

Boolean

Да

Присоединить выбранные объекты

Selected

TObjectList

Нет

Список выбранных

CurrentFormView

TFormView

Нет

Текущее представление формы

HyperLink

string[256]

Нет

Гиперссылка

FileName

string[255]

Нет

Файл

FileBaseName

string[128]

Да

Имя файла (без пути)

FileBody

blob

Нет

Содержимое файла

AttachmentType

TInstantMessageAttachmentType

Да

Тип приложения

9.4.81.98. Метод Sleep (Задержка выполнения)

Метод класса (статический метод) класса TObject.
class procedure TObject.Sleep(Seconds: Integer);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Seconds

Integer

Да

Количество секунд

9.4.81.99. Метод StringReplace (Заменить содержимое строки)

Метод класса (статический метод) класса TObject.
1class function TObject.StringReplace(Value: string[2000];
2  OldPattern: string[2000]; NewPattern: string[2000];
3  ReplaceAll: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

OldPattern

string[2000]

Нет

Старый шаблон

NewPattern

string[2000]

Нет

Новый шаблон

ReplaceAll

Boolean

Да

Заменять все

Замечания:

Возвращает значение типа string[2000].

9.4.81.100. Метод StrLength (Длина строки)

Метод класса (статический метод) класса TObject.
class function TObject.StrLength(String: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

String

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

9.4.81.101. Метод StrLike (Сопоставить строку с шаблоном)

Метод класса (статический метод) класса TObject.
1class function TObject.StrLike(Value: string[2000];
2  Pattern: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Pattern

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа Boolean.

9.4.81.102. Метод StrPad (Заполнить строку)

Метод класса (статический метод) класса TObject.
1class function TObject.StrPad(Value: string[2000]; Padding: string[2000];
2  PadRight: Boolean; MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Padding

string[2000]

Нет

Заполнитель

PadRight

Boolean

Да

Заполнять справа

MaxLength

Integer

Нет

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

9.4.81.103. Метод StrToBool (Строку в логическое значение)

Метод класса (статический метод) класса TObject.
class function TObject.StrToBool(Value: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.81.104. Метод StrToDate (Строку в дату)

Метод класса (статический метод) класса TObject.
class function TObject.StrToDate(Value: string[2000]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа date.

9.4.81.105. Метод StrToDateTime (Строку в дату и время)

Метод класса (статический метод) класса TObject.
class function TObject.StrToDateTime(Value: string[2000]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа datetime.

9.4.81.106. Метод StrToFloat (Строку в вещественное)

Метод класса (статический метод) класса TObject.
class function TObject.StrToFloat(Value: string[2000]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа float.

9.4.81.107. Метод StrToInt (Строку в целое)

Метод класса (статический метод) класса TObject.
class function TObject.StrToInt(Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

9.4.81.108. Метод StrToTime (Строку во время)

Метод класса (статический метод) класса TObject.
class function TObject.StrToTime(Value: string[2000]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа time.

9.4.81.109. Метод StrTranslate (Транслировать символы в строке)

Метод класса (статический метод) класса TObject.
1class function TObject.StrTranslate(Value: string[2000];
2  OldChars: string[2000]; NewChars: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

OldChars

string[2000]

Нет

Старый набор символов

NewChars

string[2000]

Нет

Новый набор символов

Замечания:

Возвращает значение типа string[2000].

9.4.81.110. Метод StrWrap (Выровнять строку)

Метод класса (статический метод) класса TObject.
1class function TObject.StrWrap(Value: string[2000]; Delimiter: string[2000];
2  MaxCol: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

MaxCol

Integer

Нет

Максимальное количество символов

Замечания:

Возвращает значение типа string[2000].

9.4.81.111. Метод SuggestDescription (Предложить наименование)

Метод экземпляра класса TObject.
procedure TObject.SuggestDescription(Description: string[128]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Description

string[128]

Да

Наименование

9.4.81.112. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TObject.
function TObject.SuggestFileName(Domain: TDomain): string[128];
Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Домен

Замечания:

Возвращает значение типа string[128].

9.4.81.113. Метод TimeOf (Время из даты со временем)

Метод класса (статический метод) класса TObject.
class function TObject.TimeOf(Value: datetime): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа time.

9.4.81.114. Метод TimePart (Часть времени)

Метод класса (статический метод) класса TObject.
class function TObject.TimePart(Value: time; Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

9.4.81.115. Метод TimeToStr (Время в строку)

Метод класса (статический метод) класса TObject.
class function TObject.TimeToStr(Value: time): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.81.116. Метод Touch (Модификация объекта)

Метод экземпляра класса TObject.
procedure TObject.Touch;
Метод скрыт от пользователя.

Метод не имеет параметров.

9.4.81.117. Метод Trim (Убрать лишние пробелы)

Метод класса (статический метод) класса TObject.
class function TObject.Trim(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.81.118. Метод Trunc (Отсечение дробной части)

Метод класса (статический метод) класса TObject.
class function TObject.Trunc(Value: float): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа Integer.

9.4.81.119. Метод UniqueValue (Уникальный идентификатор)

Метод класса (статический метод) класса TObject.
class function TObject.UniqueValue: string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

9.4.81.120. Метод UpperCase (Преобразовать к верхнему регистру)

Метод класса (статический метод) класса TObject.
class function TObject.UpperCase(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.81.121. Метод Ole-объекта CheckSGMLContent (Проверить SGML-содержимое)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Property

TProperty

Да

Свойство

Замечания:

Возвращает значение типа string[2000].

9.4.81.122. Метод Ole-объекта ExportAfter (Экспортировать модифицированные)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла-реплики

FromDate

datetime

Нет

Модифицировано после

9.4.81.123. Метод Ole-объекта FixSGMLContentErrors (Исправить ошибки SGML-содержимого)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Property

TProperty

Да

Свойство

Замечания:

Возвращает значение типа string[2000].

9.4.81.124. Метод Ole-объекта LoadBlobsFromFolder (Загрузить данные из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Property

TProperty

Да

Свойство

Template

string[128]

Да

Шаблон

Замечания:

Возвращает значение типа Integer.

9.4.81.125. Метод Ole-объекта SaveBlobsToFolder (Сохранить данные в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Property

TProperty

Да

Свойство

Template

string[128]

Да

Шаблон

List

TObjectList

Нет

Список объектов

Замечания:

Возвращает значение типа Integer.

9.4.81.126. Метод Ole-объекта SplitExcelSheetsToFiles (Разделить Excel листы на файлы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта скрыт от пользователя.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

WorkBook

blob

Нет

Книга (объект)

FileName

string[255]

Нет

Имя Excel-файла

FileNameMappingSheetName

string[128]

Нет

Имя листа с сопоставлениями имен файлов (по умолчанию MapSheetNameToFileName)

Folder

string[255]

Да

Каталог

9.4.81.127. Шаблон отчета Excel Excel (Перенести в Excel)

Шаблон отчета Excel класса (статический шаблон) класса TObject.

Шаблон отчета Excel является методом класса.

Шаблон отчета Excel не имеет параметров.

9.4.81.128. Шаблон отчета Word SpellCheck (Проверка правописания)

Шаблон отчета Word класса (статический шаблон) класса TObject.

Шаблон отчета Word скрыт от пользователя.

Шаблон отчета Word является методом класса.

Шаблон отчета Word не имеет параметров.

9.4.81.129. Шаблон XSLT-отчета ObjectInformation (Информация об объекте)

Шаблон XSLT-отчета класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ShowHiddenProps

Boolean

Да

Показывать скрытые свойства

9.4.81.130. Шаблон XSLT-отчета SelectDataToText (Выполнить запрос в текст)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

Query

clob

Нет

Запрос

9.4.81.131. Шаблон XSLT-отчета SelectDataToXML (Выполнить запрос в xml-документ)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

Query

clob

Нет

Запрос

9.4.81.132. Подпрограмма Column (Колонка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.133. Подпрограмма CopyToClipboard (Копировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

9.4.81.134. Подпрограмма CurrentFormView (Текущее представление формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.135. Подпрограмма CurrentlySelected (Список выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.136. Подпрограмма CurrentlySelectedSet (Множество выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.137. Подпрограмма CurrentlyVisible (Список видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.138. Подпрограмма CurrentlyVisibleSet (Множество видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.139. Подпрограмма Dependencies (Зависимости)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

9.4.81.140. Подпрограмма Edit columns (Редактировать строку)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

9.4.81.141. Подпрограмма Edit filters (Редактировать фильтры)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.142. Подпрограмма Edit properties (Редактировать свойства)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

9.4.81.143. Подпрограмма Export (Экспортировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

9.4.81.144. Подпрограмма ExportReport (Выгрузить в отчет)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.145. Подпрограмма FormOptions (Настройки формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.146. Подпрограмма Import (Импортировать)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.147. Подпрограмма Merge (Объединить)

Подпрограмма класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма не имеет параметров.

9.4.81.148. Подпрограмма Messages (Проверить сообщения)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.149. Подпрограмма Options (Настройки)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.150. Подпрограмма Paste (Вставить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.151. Подпрограмма PasteSpecial (Специальная вставка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.152. Подпрограмма Presentations (Виды)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.153. Подпрограмма Refresh (Обновить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.154. Подпрограмма Search (Поиск)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.155. Подпрограмма Selection (Выбранные)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.81.156. Подпрограмма Tree (Дерево)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

9.4.82. Класс TObjectArchive (Архив объектов)

9.4.82.1. Свойства

Свойства класса TObjectArchive:

Имя

Тип

Обязательно

Доступ

Назначение

Object

TObject

Да

Только для чтения

Объект

ObjectName

string[64]

Да

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Только для чтения

Наименование объекта

ObjectClass

TClass

Да

Только для чтения

Класс объекта

ObjectParent

TObject

Нет

Только для чтения

Объект-родитель

ObjectMaster

TObject

Да

Только для чтения

Объект-мастер

ObjectSourceDataBase

TDataBase

Да

Только для чтения

База данных-источник

ObjectOldID

string[38]

Да

Только для чтения

Идентификатор объекта при создании

ObjectCreator

TUser

Да

Только для чтения

Объект создан пользователем

ObjectCreated

datetime

Да

Только для чтения

Объект создан

ObjectModifier

TUser

Да

Только для чтения

Объект изменен пользователем

ObjectModified

datetime

Да

Только для чтения

Объект изменен

User

TUser

Да

Только для чтения

Пользователь

UserName

string[64]

Да

Только для чтения

Имя пользователя

9.4.82.2. Метод Purge (Очистить архив)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Purge(TimeLimit: time);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeLimit

time

Нет

Лимит времени выполнения

9.4.82.3. Метод Put (Положить объект в архив)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Put(Object: TObject);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

9.4.82.4. Метод PutAutonomous (Положить объект в архив в автономной транзакции)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.PutAutonomous(Object: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

9.4.82.5. Метод Remove (Исключить объект из архива)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Remove(Object: TObject);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

9.4.83. Класс TObjectCreator (Роли-создатели)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.83.1. Свойства

Свойства класса TObjectCreator:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

9.4.83.2. Конструктор Create (Конструктор роли-создателя)

Конструктор класса TObjectCreator.
1constructor TObjectCreator.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TObjectCreator.

9.4.84. Класс TObjectHistory (История объектов)

9.4.84.1. Свойства

Свойства класса TObjectHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Только для чтения

Имя

Description

string[128]

Да

Видимо пользователю

Только для чтения

Наименование

Class

TClass

Да

Видимо пользователю

Только для чтения

Класс

Master

string[2000]

Нет

Видимо пользователю

Только для чтения

Мастер

Parent

string[2000]

Нет

Видимо пользователю

Только для чтения

Родитель

Data

string[2000]

Нет

Видимо пользователю

Только для чтения

Содержимое

Action

TChangeAction

Да

Видимо пользователю

Только для чтения

Действие

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

ObjectOldID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор при создании

ObjectDataBase

TDataBase

Да

Видимо пользователю

Только для чтения

База данных объекта

ObjectID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор объекта

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

FieldName

string[64]

Да

Видимо пользователю

Только для чтения

Поле

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

9.4.84.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TObjectHistory.
1class procedure TObjectHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

9.4.84.3. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TObjectHistory.
1class procedure TObjectHistory.Log(Object: TObject; Action: TChangeAction;
2  Field: TField; Data: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

Action

TChangeAction

Да

Действие

Field

TField

Нет

Поле

Data

string[2000]

Нет

Содержимое

9.4.84.4. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObjectHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

9.4.84.5. Шаблон отчета Excel UserActivityReport (Отчет об активности пользователей)

Шаблон отчета Excel класса (статический шаблон) класса TObjectHistory.

Шаблон отчета Excel является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

UDate

date

Нет

Дата

9.4.85. Класс TObjectList (Списки)

Объекты класса не именованы.

9.4.85.1. Свойства

Свойства класса TObjectList:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

AsString

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

Список в текстовом представлении

AsClob

clob

Нет

Скрыто от пользователя

Чтение/Запись

Список в виде большого текстового объекта

9.4.85.2. Конструктор Create (Конструктор списка)

Конструктор класса TObjectList.
1constructor TObjectList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TObjectList.

9.4.85.3. Метод Add (Добавить объект в список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Add(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

9.4.85.4. Метод Archive (Отправить список в архив)

Метод экземпляра класса TObjectList.
procedure TObjectList.Archive;
Метод не имеет параметров.

9.4.85.5. Метод ArchiveAll (Отправить список в архив со всем содержимым)

Метод экземпляра класса TObjectList.
procedure TObjectList.ArchiveAll;
Метод не имеет параметров.

9.4.85.6. Метод ByName (Поиск по имени)

Метод экземпляра класса TObjectList.
function TObjectList.ByName(Name: string[64]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Замечания:

Возвращает значение типа Integer.

9.4.85.7. Метод Clear (Очистить список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Clear;
Метод скрыт от пользователя.

Метод не имеет параметров.

9.4.85.8. Метод CreateFromClob (Создать список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromClob(Value: clob): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

9.4.85.9. Метод CreateFromOrderedClob (Создать упорядоченный список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromOrderedClob(Value: clob): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

9.4.85.10. Метод CreateFromOrderedString (Создать упорядоченный список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromOrderedString(Value: string[2000]): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

9.4.85.11. Метод CreateFromString (Создать список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromString(Value: string[2000]): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

9.4.85.12. Метод Delete (Удалить объект)

Метод экземпляра класса TObjectList.
procedure TObjectList.Delete(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

9.4.85.13. Метод DestroyAll (Удалить вместе с содержащимися в списке объектами)

Метод экземпляра класса TObjectList.
procedure TObjectList.DestroyAll;
Метод не имеет параметров.

9.4.85.14. Метод Force (Добавить, игнорируя ограничения)

Метод экземпляра класса TObjectList.
procedure TObjectList.Force(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

9.4.85.15. Метод GetAsClob (Получить в виде большого текстового объекта)

Метод экземпляра класса TObjectList.
function TObjectList.GetAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

9.4.85.16. Метод GetAsString (Список в текстовом представлении)

Метод экземпляра класса TObjectList.
function TObjectList.GetAsString: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.85.17. Метод GetItem (Получить объект из списка)

Метод экземпляра класса TObjectList.
function TObjectList.GetItem(ItemIndex: Integer): TObject;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

Замечания:

Возвращает значение типа TObject.

9.4.85.18. Метод IndexOf (Индекс объекта в списке)

Метод экземпляра класса TObjectList.
function TObjectList.IndexOf(ItemObject: TObject): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

Замечания:

Возвращает значение типа Integer.

9.4.85.19. Метод Insert (Вставить объект в список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Insert(ItemIndex: Integer; ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemObject

TObject

Да

Элемент

9.4.85.20. Метод IsExcluded (Объект не входит в список)

Метод экземпляра класса TObjectList.
function TObjectList.IsExcluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.85.21. Метод IsIncluded (Объект входит в список)

Метод экземпляра класса TObjectList.
function TObjectList.IsIncluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.85.22. Метод Length (Длина списка)

Метод экземпляра класса TObjectList.
function TObjectList.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.85.23. Метод LoadFromClob (Загрузить содержимое списка из большого текстового объекта)

Метод экземпляра класса TObjectList.
1procedure TObjectList.LoadFromClob(Value: clob; Ordered: Boolean;
2  Clear: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Ordered

Boolean

Да

Сохранить порядок объектов

Clear

Boolean

Да

Очистить перед загрузкой

9.4.85.24. Метод LoadFromString (Загрузить содержимое списка из текстового представления)

Метод экземпляра класса TObjectList.
1procedure TObjectList.LoadFromString(Value: string[2000]; Ordered: Boolean;
2  Clear: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Ordered

Boolean

Да

Сохранить порядок объектов

Clear

Boolean

Да

Очистить перед загрузкой

9.4.85.25. Метод Remove (Вычистить объект)

Метод экземпляра класса TObjectList.
procedure TObjectList.Remove(ItemObject: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

9.4.85.26. Метод Reorder (Перенумеровать объекты в списке)

Метод экземпляра класса TObjectList.
procedure TObjectList.Reorder;
Метод не имеет параметров.

9.4.85.27. Метод SetAsClob (Установить список в виде большого текстового объекта)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetAsClob(Value: clob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

9.4.85.28. Метод SetAsString (Установить список в текстовом представлении)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetAsString(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

9.4.85.29. Метод SetItem (Установить объект в списке)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetItem(ItemIndex: Integer; ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemObject

TObject

Да

Элемент

9.4.86. Класс TObjectListItem (Элементы списков)

9.4.86.1. Свойства

Свойства класса TObjectListItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Object

TObject

Да

Видимо пользователю

Только для чтения

Объект

Position

Integer

Да

Видимо пользователю

Только для чтения

Позиция

9.4.86.2. Конструктор Create (Конструктор элемента списка)

Конструктор класса TObjectListItem.
1constructor TObjectListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ItemObject: TObject; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ItemObject

TObject

Да

Элемент

Position

Integer

Нет

Позиция

Замечания:

Создает новый объект класса TObjectListItem.

9.4.87. Класс TObjectSet (Множества объектов)

9.4.87.1. Конструктор Create (Создать множество)

Конструктор класса TObjectSet.
constructor TObjectSet.Create: TObjectSet;
Метод не имеет параметров.

Замечания:

Создает новый объект класса TObjectSet.

9.4.87.2. Метод Add (Добавить множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Add(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

9.4.87.3. Метод Change (Изменение объекта)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

9.4.87.4. Метод Clear (Очистить множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Clear;
Метод не имеет параметров.

9.4.87.5. Метод Clone (Клонировать множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.Clone: TObjectSet;
Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectSet.

9.4.87.6. Метод CreateFromClob (Создать множество на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectSet.
class function TObjectSet.CreateFromClob(Value: clob): TObjectSet;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectSet.

9.4.87.7. Метод CreateFromString (Создать множество на основе строки)

Метод класса (статический метод) класса TObjectSet.
class function TObjectSet.CreateFromString(Value: string[2000]): TObjectSet;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectSet.

9.4.87.8. Метод Exclude (Исключить объект из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Exclude(Value: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

9.4.87.9. Метод ExcludeClob (Исключить содержимое большого текстового объекта из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.ExcludeClob(Value: clob);
Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

9.4.87.10. Метод ExcludeString (Исключить содержимое строки из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.ExcludeString(Value: string[2000]);
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

9.4.87.11. Метод GetAsClob (Множество в виде большого текстового объекта)

Метод экземпляра класса TObjectSet.
function TObjectSet.GetAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

9.4.87.12. Метод GetAsString (Множество в виде строки)

Метод экземпляра класса TObjectSet.
function TObjectSet.GetAsString: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.87.13. Метод Include (Включить объект в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Include(Value: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

9.4.87.14. Метод IncludeClob (Включить содержимое большого текстового объекта в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.IncludeClob(Value: clob);
Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

9.4.87.15. Метод IncludeString (Включить содержимое строки в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.IncludeString(Value: string[2000]);
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

9.4.87.16. Метод IsExcluded (Объект не входит в множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.IsExcluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.87.17. Метод IsIncluded (Объект входит в множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.IsIncluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

9.4.87.18. Метод Length (Количество элементов)

Метод экземпляра класса TObjectSet.
function TObjectSet.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.87.19. Метод Multiply (Умножить на множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Multiply(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

9.4.87.20. Метод Subtract (Вычесть множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Subtract(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

9.4.88. Класс TOleObjectMethod (Метод Ole-объекта)

9.4.88.1. Свойства

Свойства класса TOleObjectMethod:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

ClassID

string[128]

Нет

Видимо пользователю

Чтение/Запись

Идентификатор класса

Method

string[128]

Нет

Видимо пользователю

Чтение/Запись

Метод

CodeLibrary

TAccessibleFile

Нет

Видимо пользователю

Чтение/Запись

Библиотека кода

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

9.4.88.2. Конструктор Create (Конструктор метода Ole-объекта)

Конструктор класса TOleObjectMethod.
1constructor TOleObjectMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; CodeLibrary: TAccessibleFile;
6  ClassID: string[128]; Method: string[128]; IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

CodeLibrary

TAccessibleFile

Нет

Библиотека кода

ClassID

string[128]

Нет

Идентификатор класса

Method

string[128]

Нет

Метод

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TOleObjectMethod.

9.4.88.3. Метод Ole-объекта CheckOleObjectMethod (Проверить метод Ole-объекта)

Метод Ole-объекта класса TOleObjectMethod.

Метод Ole-объекта не имеет параметров.

9.4.89. Класс TOption (Настройки)

9.4.89.1. Свойства

Свойства класса TOption:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Global

Boolean

Да

Видимо пользователю

Чтение/Запись

Глобальная

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Value

TOptionValue

Нет

Скрыто от пользователя

Только для чтения

Значение

User

TUser

Нет

Видимо пользователю

Чтение/Запись

Пользователь

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

Видимое значение

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

9.4.89.2. Конструктор Create (Конструктор настройки)

Конструктор класса TOption.
1constructor TOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Global: Boolean; Group: string[128]; Tab: string[128];
4  Position: Integer; Scope: TScope): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Global

Boolean

Да

Глобальная

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Position

Integer

Нет

Позиция

Scope

TScope

Да

Область видимости

Замечания:

Создает новый объект класса TOption.

9.4.89.3. Метод AreValid (Настройки действительны)

Метод класса (статический метод) класса TOption.
class function TOption.AreValid: Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.89.4. Метод GetBlobValue (Значение-большой объект)

Метод класса (статический метод) класса TOption.
class function TOption.GetBlobValue(OptionName: string[64]): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа blob.

9.4.89.5. Метод GetBoolValue (Логическое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetBoolValue(OptionName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа Boolean.

9.4.89.6. Метод GetClobValue (Значение-текст)

Метод класса (статический метод) класса TOption.
class function TOption.GetClobValue(OptionName: string[64]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа clob.

9.4.89.7. Метод GetDateTimeValue (Значение даты со временем)

Метод класса (статический метод) класса TOption.
class function TOption.GetDateTimeValue(OptionName: string[64]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа datetime.

9.4.89.8. Метод GetDateValue (Значение даты)

Метод класса (статический метод) класса TOption.
class function TOption.GetDateValue(OptionName: string[64]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа date.

9.4.89.9. Метод GetExternalDataValue (Значение внешних данных)

Метод класса (статический метод) класса TOption.
1class function TOption.GetExternalDataValue(OptionName: string[64]): <external
2  data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа <external data>.

9.4.89.10. Метод GetFloatValue (Вещественное значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetFloatValue(OptionName: string[64]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа float.

9.4.89.11. Метод GetIntValue (Целое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetIntValue(OptionName: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа Integer.

9.4.89.12. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TOption.
class function TOption.GetNextPos: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.89.13. Метод GetObjectValue (Значение-объект)

Метод класса (статический метод) класса TOption.
class function TOption.GetObjectValue(OptionName: string[64]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа TObject.

9.4.89.14. Метод GetStrValue (Строковое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetStrValue(OptionName: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа string[2000].

9.4.89.15. Метод GetTimeValue (Значение времени)

Метод класса (статический метод) класса TOption.
class function TOption.GetTimeValue(OptionName: string[64]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа time.

9.4.89.16. Метод GetValue (Значение)

Метод экземпляра класса TOption.
function TOption.GetValue: TOptionValue;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TOptionValue.

9.4.89.17. Метод SetValue (Установка значения)

Метод экземпляра класса TOption.
1procedure TOption.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>; Default: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Default

Boolean

Да

По умолчанию

9.4.90. Класс TOptionValue (Значения настроек)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.90.1. Свойства

Свойства класса TOptionValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

User

TUser

Нет

Видимо пользователю

Чтение/Запись

Пользователь

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущим

Option

TOption

Да

Скрыто от пользователя

Только для чтения

Настройка

Domain

TDomain

Да

Видимо пользователю

Только для чтения

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Global

Boolean

Да

Видимо пользователю

Только для чтения

Глобальная

9.4.90.2. Конструктор Create (Конструктор значения настройки)

Конструктор класса TOptionValue.
1constructor TOptionValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Унаследовано от TTypedValue.Create

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

User

TUser

Нет

Пользователь

Замечания:

Создает новый объект класса TOptionValue.

9.4.91. Класс TParameter (Параметры)

9.4.91.1. Свойства

Свойства класса TParameter:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

RoutineClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс подпрограммы

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

InitializationMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Инициализируется членом класса

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределен

LinkedView

TParametersFormView

Нет

Видимо пользователю

Чтение/Запись

Связанное представление

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

9.4.91.2. Конструктор Create (Конструктор параметра)

Конструктор класса TParameter.
1constructor TParameter.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; InitializationMember: TClassMember; OutOfTabs: Boolean;
5  LinkedView: TParametersFormView; Logged: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

InitializationMember

TClassMember

Нет

Инициализируется членом класса

OutOfTabs

Boolean

Да

За пределами закладок

LinkedView

TParametersFormView

Нет

Связанное представление

Logged

Boolean

Да

Протоколировать

Замечания:

Создает новый объект класса TParameter.

9.4.91.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TParameter.
class function TParameter.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

9.4.91.4. Метод GetOverride (Переопределен)

Метод экземпляра класса TParameter.
function TParameter.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.92. Класс TParameterHistory (Параметры вызовов)

9.4.92.1. Свойства

Свойства класса TParameterHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Routine

TRoutineHistory

Да

Скрыто от пользователя

Только для чтения

Вызов подпрограммы

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

ParameterName

string[64]

Да

Видимо пользователю

Только для чтения

Параметр

Data

string[2000]

Нет

Видимо пользователю

Только для чтения

Содержимое

ObjectID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

9.4.92.2. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TParameterHistory.
1class procedure TParameterHistory.Log(Routine: TRoutineHistory;
2  Parameter: TParameter; Data: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutineHistory

Да

Вызов подпрограммы

Parameter

TParameter

Да

Параметр

Data

string[2000]

Нет

Содержимое

9.4.93. Класс TParametersFormView (Представления формы параметров)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

9.4.93.1. Конструктор Create (Конструктор представления формы параметров)

Конструктор класса TParametersFormView.
1constructor TParametersFormView.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; View: TCustomView; ChildrenMinimized: Boolean;
4  ChildrenOnTabs: Boolean; MasterProperty: TProperty;
5  DetailProperty: TClassMember; Position: Integer; SpacePercentage: Integer;
6  Layout: TFormViewLayout; ExplicitQuery: Boolean): TObject;
Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Унаследовано от TFormView.Create

ChildrenMinimized

Boolean

Да

ChildrenOnTabs

Boolean

Да

MasterProperty

TProperty

Нет

DetailProperty

TClassMember

Нет

Position

Integer

Да

SpacePercentage

Integer

Нет

Layout

TFormViewLayout

Да

ExplicitQuery

Boolean

Да

Замечания:

Создает новый объект класса TParametersFormView.

9.4.94. Класс TPDFTemplate (Шаблоны отчетов PDF)

9.4.94.1. Свойства

Свойства класса TPDFTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateScript

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт шаблона

9.4.94.2. Конструктор Create (Конструктор шаблона PDF)

Конструктор класса TPDFTemplate.
1constructor TPDFTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateScript: clob): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateScript

clob

Нет

Скрипт шаблона

Замечания:

Создает новый объект класса TPDFTemplate.

9.4.95. Класс TProfile (Профили)

9.4.95.1. Свойства

Свойства класса TProfile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

ComparisonType

TComparisonType

Да

Видимо пользователю

Чтение/Запись

Тип сравнения

BasedOnProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Расширяет профиль пользователями

Active

Boolean

Да

Видимо пользователю

Только для чтения

Активен

9.4.95.2. Конструктор Create (Конструктор профиля)

Конструктор класса TProfile.
1constructor TProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType;
4  BasedOnProfile: TProfile): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

ComparisonType

TComparisonType

Да

Тип сравнения

BasedOnProfile

TProfile

Нет

Расширяет профиль пользователями

Замечания:

Создает новый объект класса TProfile.

9.4.95.3. Метод Check (Проверка профиля)

Метод класса (статический метод) класса TProfile.
class procedure TProfile.Check(Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

9.4.95.4. Метод GetIsActive (Активен для текущего пользователя)

Метод экземпляра класса TProfile.
function TProfile.GetIsActive: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.95.5. Метод GetValueDomain (Получить домен значения)

Метод экземпляра класса TProfile.
function TProfile.GetValueDomain: TDomain;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TDomain.

9.4.95.6. Метод Match (Проверка совпадения)

Метод экземпляра класса TProfile.
1function TProfile.Match(Object: TObject; ObjectClass: TClass;
2  ValueGiven: Boolean; StrValue: string[2000]; IntValue: Integer;
3  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
4  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
5  ExternalDataValue: <external data>): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

ValueGiven

Boolean

Да

Значение задано

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Возвращает значение типа Boolean.

9.4.95.7. Метод MatchObject (Проверка совпадения объекта)

Метод экземпляра класса TProfile.
function TProfile.MatchObject(Object: TObject; ObjectClass: TClass): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

Замечания:

Возвращает значение типа Boolean.

9.4.95.8. Метод TryCheck (Проверка профиля с возвратом результата)

Метод класса (статический метод) класса TProfile.
class function TProfile.TryCheck(Object: TObject; ObjectClass: TClass): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

Замечания:

Возвращает значение типа Boolean.

9.4.96. Класс TProfileEvent (События профиля)

9.4.96.1. Свойства

Свойства класса TProfileEvent:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Method

TProfileMethod

Да

Скрыто от пользователя

Только для чтения

Метод профилировщика

Class

TClass

Да

Видимо пользователю

Только для чтения

Класс

ObjectID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Видимо пользователю

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

Action

TChangeAction

Да

Видимо пользователю

Только для чтения

Действия

9.4.97. Класс TProfileItem (Состав профиля)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.97.1. Свойства

Свойства класса TProfileItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ProfileClass

TClass

Да

Видимо пользователю

Чтение/Запись

Профилируемый класс

ProfileProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Профилируемое свойство

Comparator

TMethod

Нет

Видимо пользователю

Чтение/Запись

Сравнивающая функция

Group

string[64]

Нет

Видимо пользователю

Чтение/Запись

Группа

AllowNulls

Boolean

Да

Видимо пользователю

Чтение/Запись

Пропускать пустые значения

HasCrossCondition

Boolean

Да

Видимо пользователю

Только для чтения

Имеется пересечение условий

9.4.97.2. Конструктор Create (Конструктор элемента профиля)

Конструктор класса TProfileItem.
1constructor TProfileItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ProfileClass: TClass; ProfileProperty: TProperty; Comparator: TMethod;
4  Group: string[64]; AllowNulls: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ProfileClass

TClass

Да

Профилируемый класс

ProfileProperty

TProperty

Нет

Профилируемое свойство

Comparator

TMethod

Нет

Сравнивающая функция

Group

string[64]

Нет

Группа

AllowNulls

Boolean

Да

Пропускать пустые значения

Замечания:

Создает новый объект класса TProfileItem.

9.4.97.3. Метод GetHasCrossConditions (Имеется пересечение условий)

Метод экземпляра класса TProfileItem.
function TProfileItem.GetHasCrossConditions: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.98. Класс TProfileMethod (Методы профиля)

Объекты класса образуют иерархию.

9.4.98.1. Свойства

Свойства класса TProfileMethod:

Имя

Тип

Обязательно

Доступ

Назначение

Parent

TProfileMethod

Нет

Только для чтения

Родитель

Method

TMethod

Да

Только для чтения

Метод профилировщика

MethodClass

TClass

Да

Только для чтения

Класс

Position

Integer

Да

Только для чтения

Позиция

Duration

Integer

Нет

Только для чтения

Общее время

CodeDuration

Integer

Нет

Только для чтения

Время собственного кода

Calls

Integer

Нет

Только для чтения

Количество непосредственных вызовов

Events

Integer

Нет

Только для чтения

Непосредственных операций с данными

CommonCalls

Integer

Нет

Только для чтения

Всего вызовов

CommonEvents

Integer

Нет

Только для чтения

Всего операций с данными

ObjectID

string[38]

Да

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Только для чтения

Идентификатор при создании

9.4.98.2. Метод BuildReport (Перестроить отчет)

Метод класса (статический метод) класса TProfileMethod.
class procedure TProfileMethod.BuildReport(QualifyObjects: Boolean);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

QualifyObjects

Boolean

Да

Квалифицировать объекты

9.4.98.3. Метод Clear (Очистить статистику)

Метод класса (статический метод) класса TProfileMethod.
class procedure TProfileMethod.Clear;
Метод является методом класса.

Метод не имеет параметров.

9.4.98.4. Метод Ole-объекта ExportProfilerReport (Экспортировать отчет)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TProfileMethod.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

9.4.99. Класс TProfileStatistics (Статистика профиля)

9.4.99.1. Свойства

Свойства класса TProfileStatistics:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Method

TProfileMethod

Да

Скрыто от пользователя

Только для чтения

Метод профилировщика

CalledMethod

TMethod

Нет

Видимо пользователю

Только для чтения

Вызываемый метод

CalledMethodClass

TObject

Да

Видимо пользователю

Только для чтения

Класс

Calls

Integer

Нет

Видимо пользователю

Только для чтения

Количество вызовов

Class

TClass

Нет

Видимо пользователю

Только для чтения

Класс

Inserts

Integer

Нет

Видимо пользователю

Только для чтения

Количество добавлений

Updates

Integer

Нет

Видимо пользователю

Только для чтения

Количество изменений

Deletes

Integer

Нет

Видимо пользователю

Только для чтения

Количество удалений

Type

string[128]

Нет

Видимо пользователю

Только для чтения

Тип

9.4.100. Класс TProfileUser (Пользователи профиля)

Объекты класса не именованы.

Наименования объектов класса генерируются.

9.4.100.1. Свойства

Свойства класса TProfileUser:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

UserIsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Пользователь является текущим

Profile

TProfile

Да

Скрыто от пользователя

Только для чтения

Профиль

Domain

TDomain

Да

Скрыто от пользователя

Только для чтения

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

9.4.100.2. Конструктор Create (Конструктор пользовательского профиля)

Конструктор класса TProfileUser.
1constructor TProfileUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TProfile; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TProfile

Да

Профиль

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Унаследовано от TTypedValue.Create

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

User

TUser

Да

Пользователь

Замечания:

Создает новый объект класса TProfileUser.

9.4.101. Класс TProperty (Свойства)

Объекты класса образуют иерархию.

9.4.101.1. Свойства

Свойства класса TProperty:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

ReadMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Член класса для чтения

ReadMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для чтения

WriteMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Член класса для записи

WriteMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для записи

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

IsExportable

Boolean

Да

Видимо пользователю

Чтение/Запись

Для экспорта

IsSuspended

Boolean

Да

Видимо пользователю

Чтение/Запись

Отложенное

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

IsUnupdatable

Boolean

Да

Видимо пользователю

Чтение/Запись

Необновляемое при импорте

NullHandler

TMethod

Нет

Видимо пользователю

Чтение/Запись

Обработчик пустого значения

OnDemand

Boolean

Да

Видимо пользователю

Чтение/Запись

По требованию

9.4.101.2. Конструктор Create (Конструктор свойства)

Конструктор класса TProperty.
1constructor TProperty.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ReadMember: TClassMember; WriteMember: TClassMember;
4  Position: Integer; Scope: TScope; IsExportable: Boolean; IsSuspended: Boolean;
5  CreateViewColumns: Boolean; Category: string[128]): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

ReadMember

TClassMember

Нет

Член класса для чтения

WriteMember

TClassMember

Нет

Член класса для записи

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

IsExportable

Boolean

Да

Для экспорта

IsSuspended

Boolean

Да

Отложенное

CreateViewColumns

Boolean

Да

Создать колонку во всех представлениях

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TProperty.

9.4.101.3. Метод Change (Изменение объекта)

Метод экземпляра класса TProperty.
procedure TProperty.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

9.4.101.4. Метод CreateChildren (Создать дочерние свойства)

Метод экземпляра класса TProperty.
1procedure TProperty.CreateChildren(ClearWriteMember: Boolean;
2  PublicOnly: Boolean; ExactName: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

ClearWriteMember

Boolean

Да

Создавать свойства только для чтения

PublicOnly

Boolean

Да

Создавать только видимые свойства

ExactName

Boolean

Да

Не изменять имя свойства

9.4.101.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TProperty.
class function TProperty.GetNextPos(Master: TObject; Parent: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Integer.

9.4.101.6. Метод LocalizableFieldName (Получить имя локализуемого поля)

Метод класса (статический метод) класса TProperty.
1class function TProperty.LocalizableFieldName(Class: TClass;
2  Name: string[64]): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Class

TClass

Нет

Класс

Name

string[64]

Да

Имя

Замечания:

Возвращает значение типа string[64].

9.4.101.7. Метод LocalizableProperty (Локализуемое свойство)

Метод класса (статический метод) класса TProperty.
1class function TProperty.LocalizableProperty(ClassName: string[64];
2  PropertyName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

PropertyName

string[64]

Да

Имя свойства

Замечания:

Возвращает значение типа Boolean.

9.4.101.8. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TProperty.
function TProperty.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TClassMember.SuggestFileName, TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

9.4.102. Класс TPropertyBan (Запрет на свойство)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.102.1. Свойства

Свойства класса TPropertyBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

BannedProperty

TProperty

Да

Видимо пользователю

Только для чтения

Запрещаемое свойство

AllowRead

Boolean

Да

Видимо пользователю

Чтение/Запись

Чтение разрешено

9.4.102.2. Конструктор Create (Конструктор запрета на свойство)

Конструктор класса TPropertyBan.
1constructor TPropertyBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedProperty: TProperty; AllowRead: Boolean): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

BannedProperty

TProperty

Да

Запрещаемое свойство

AllowRead

Boolean

Да

Чтение разрешено

Замечания:

Создает новый объект класса TPropertyBan.

9.4.103. Класс TQueue (Очередь)

9.4.103.1. Свойства

Свойства класса TQueue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

QueueName

string[64]

Да

Видимо пользователю

Только для чтения

Имя очереди

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время входа в очередь

Object

TObject

Нет

Видимо пользователю

Только для чтения

Объект

ObjectName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Видимо пользователю

Только для чтения

Наименование объекта

ObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс объекта

ObjectParent

TObject

Нет

Скрыто от пользователя

Только для чтения

Объект-родитель

ObjectMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Объект-мастер

ObjectSourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

База данных-источник

ObjectOldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Идентификатор объекта при создании

ObjectCreator

TUser

Да

Скрыто от пользователя

Только для чтения

Объект создан пользователем

ObjectCreated

datetime

Да

Скрыто от пользователя

Только для чтения

Объект создан

ObjectModifier

TUser

Да

Скрыто от пользователя

Только для чтения

Объект изменен пользователем

ObjectModified

datetime

Да

Скрыто от пользователя

Только для чтения

Объект изменен

Processed

Boolean

Да

Видимо пользователю

Только для чтения

Обработан

9.4.103.2. Конструктор Create (Конструктор объекта в очереди)

Конструктор класса TQueue.
constructor TQueue.Create(Object: TObject; QueueName: string[64]): TObject;
Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

QueueName

string[64]

Да

Имя очереди

Замечания:

Создает новый объект класса TQueue.

9.4.103.3. Деструктор Destroy (Деструктор объекта в очереди)

Деструктор класса TQueue.
destructor TQueue.Destroy;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TQueue или его наследника.

9.4.103.4. Метод Clear (Очистить очередь)

Метод класса (статический метод) класса TQueue.
class procedure TQueue.Clear(QueueName: string[64]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

QueueName

string[64]

Да

Имя очереди

9.4.104. Класс TRole (Роли)

9.4.104.1. Свойства

Свойства класса TRole:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущей

9.4.104.2. Конструктор Create (Конструктор роли)

Конструктор класса TRole.
1constructor TRole.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TRole.

9.4.104.3. Метод GetIsCurrent (Является текущей)

Метод экземпляра класса TRole.
function TRole.GetIsCurrent: Boolean;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.105. Класс TRoleMember (Пользователи в ролях)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.105.1. Свойства

Свойства класса TRoleMember:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

User

TSecurityAccount

Да

Видимо пользователю

Только для чтения

Пользователь

UserClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс члена роли

IsPrimary

Boolean

Да

Видимо пользователю

Чтение/Запись

Основная роль

9.4.105.2. Конструктор Create (Конструктор члена роли)

Конструктор класса TRoleMember.
1constructor TRoleMember.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TRole; Accessor: TSecurityAccount;
3  User: TSecurityAccount; IsPrimary: Boolean; AddLinked: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TRole

Да

Роль

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

User

TSecurityAccount

Да

Пользователь

IsPrimary

Boolean

Да

Основная роль

AddLinked

Boolean

Да

Добавить связанные роли

Замечания:

Создает новый объект класса TRoleMember.

9.4.105.3. Метод SetIsPrimary (Установка значения свойства "Является основной")

Метод экземпляра класса TRoleMember.
procedure TRoleMember.SetIsPrimary(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

9.4.106. Класс TRoutine (Подпрограмма)

9.4.106.1. Свойства

Свойства класса TRoutine:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Домен результата

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена результата

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена результата

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Является методом класса

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Текст подтверждения

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Использовать закладки

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт формы параметров

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение-иконка

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество параметров

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

Сообщение о выполнении

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

Вызывать только для одного объекта

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

9.4.106.2. Конструктор Create (Конструктор подпрограммы)

Конструктор класса TRoutine.
1constructor TRoutine.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Является методом класса

SingleObject

Boolean

Да

Вызывать только для одного объекта

Domain

TDomain

Нет

Домен результата

Scope

TScope

Да

Область видимости

Confirmation

string[512]

Нет

Текст подтверждения

ReportMessage

string[512]

Нет

Сообщение о выполнении

UseTabs

Boolean

Да

Использовать закладки

Script

clob

Нет

Скрипт формы параметров

Image

blob

Нет

Изображение-иконка

Logged

Boolean

Да

Протоколировать

Замечания:

Создает новый объект класса TRoutine.

9.4.106.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TRoutine.
procedure TRoutine.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

9.4.106.4. Метод GetParamCount (Количество параметров)

Метод экземпляра класса TRoutine.
function TRoutine.GetParamCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.106.5. Метод ListParameters (Список параметров)

Метод экземпляра класса TRoutine.
function TRoutine.ListParameters: TObjectList;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.

9.4.106.6. Метод ParameterByName (Получить параметр по имени)

Метод экземпляра класса TRoutine.
function TRoutine.ParameterByName(AName: string[64]): TParameter;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

AName

string[64]

Да

Имя

Замечания:

Возвращает значение типа TParameter.

9.4.106.7. Метод Ole-объекта CreateReportTemplate (Сгенерировать шаблон отчета)

Метод Ole-объекта класса TRoutine.

Метод Ole-объекта не имеет параметров.

9.4.107. Класс TRoutineAction (Программируемое действие)

Объекты класса образуют иерархию.

9.4.107.1. Свойства

Свойства класса TRoutineAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

ContextProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Выполнять в контексте свойства

AllowNavigation

Boolean

Да

Видимо пользователю

Чтение/Запись

Доступна навигация

9.4.107.2. Конструктор Create (Конструктор программируемого действия)

Конструктор класса TRoutineAction.
1constructor TRoutineAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  Routine: TRoutine; ContextProperty: TProperty;
5  AllowNavigation: Boolean): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

Routine

TRoutine

Да

Реализовано посредством

ContextProperty

TProperty

Нет

выполнять в контексте

AllowNavigation

Boolean

Да

Доступна навигация

Замечания:

Создает новый объект класса TRoutineAction.

9.4.107.3. Метод EnsureAction (Обеспечить наличие действия)

Метод класса (статический метод) класса TRoutineAction.
1class function TRoutineAction.EnsureAction(AView: TObject; AName: string[64];
2  ADescription: string[128]; APosition: Integer; AShortcut: string[20];
3  ASeparated: Boolean; ARoutine: TRoutine): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AView

TObject

Да

Мастер

AName

string[64]

Да

Имя

ADescription

string[128]

Да

Наименование

APosition

Integer

Да

Позиция

AShortcut

string[20]

Нет

Горячая клавиша

ASeparated

Boolean

Да

Отделено

ARoutine

TRoutine

Да

Реализовано посредством

Замечания:

Возвращает значение типа TObject.

9.4.108. Класс TRoutineBan (Запрет на подпрограмму)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.108.1. Свойства

Свойства класса TRoutineBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

BannedRoutine

TRoutine

Да

Видимо пользователю

Только для чтения

Запрещаемая подпрограмма

9.4.108.2. Конструктор Create (Конструктор запрета на подпрограмму)

Конструктор класса TRoutineBan.
1constructor TRoutineBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedRoutine: TRoutine): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

BannedRoutine

TRoutine

Да

Запрещаемая подпрограмма

Замечания:

Создает новый объект класса TRoutineBan.

9.4.109. Класс TRoutineHistory (Вызовы)

9.4.109.1. Свойства

Свойства класса TRoutineHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

ObjectID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Видимо пользователю

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

RoutineName

string[64]

Да

Видимо пользователю

Только для чтения

Подпрограмма

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

RoutineClassName

string[64]

Да

Видимо пользователю

Только для чтения

Имя класса подпрограммы

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

9.4.109.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TRoutineHistory.
1class procedure TRoutineHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

9.4.109.3. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TRoutineHistory.
1class function TRoutineHistory.Log(Routine: TRoutine;
2  Object: TObject): TRoutineHistory;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Object

TObject

Нет

Объект

Замечания:

Возвращает значение типа TRoutineHistory.

9.4.109.4. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TRoutineHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

9.4.110. Класс TSecurityAccount (Роли безопасности)

9.4.111. Класс TSequence (Последовательности)

9.4.111.1. Свойства

Свойства класса TSequence:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Value

string[20]

Да

Видимо пользователю

Чтение/Запись

Текущее значение

Cache

Integer

Нет

Видимо пользователю

Чтение/Запись

Кэш

9.4.111.2. Конструктор Create (Конструктор последовательности)

Конструктор класса TSequence.
1constructor TSequence.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TSequence.

9.4.111.3. Метод GetCache (Получить кеш)

Метод экземпляра класса TSequence.
function TSequence.GetCache: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.111.4. Метод GetValue (Получить текущее значение)

Метод экземпляра класса TSequence.
function TSequence.GetValue: string[20];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].

9.4.111.5. Метод Promote (Получить следующее значение)

Метод экземпляра класса TSequence.
function TSequence.Promote: string[20];
Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].

9.4.111.6. Метод SetCache (Установить кеш)

Метод экземпляра класса TSequence.
procedure TSequence.SetCache(Value: Integer);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

9.4.111.7. Метод SetValue (Установить текущее значение)

Метод экземпляра класса TSequence.
procedure TSequence.SetValue(Value: string[20]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[20]

Да

Значение

9.4.112. Класс TSessionHistory (Сессии)

9.4.112.1. Свойства

Свойства класса TSessionHistory:

Имя

Тип

Обязательно

Доступ

Назначение

IntStamp

Integer

Нет

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Только для чтения

Время

User

TUser

Нет

Только для чтения

Пользователь

Login

string[64]

Да

Только для чтения

Логин

CloseStamp

datetime

Нет

Только для чтения

Время закрытия

UserAgent

string[2000]

Нет

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Только для чтения

Информация о соединении

Duration

time

Нет

Только для чтения

Продолжительность

9.4.112.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TSessionHistory.
1class procedure TSessionHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

9.4.112.3. Метод DBMSConnectionInfo (Информация о соединении от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSConnectionInfo: string[2000];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.112.4. Метод DBMSGetIPAddress (IP-адрес клиента от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSGetIPAddress: string[16];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[16].

9.4.112.5. Метод DBMSGetUserAgent (Пользовательский агент от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSGetUserAgent: string[2000];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.112.6. Метод GetCurrentSession (Идентификатор текущей сессии)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.GetCurrentSession: TSessionHistory;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TSessionHistory.

9.4.112.7. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TSessionHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

9.4.113. Класс TStatement (Операторы)

9.4.113.1. Конструктор Create (Конструктор оператора)

Конструктор класса TStatement.
constructor TStatement.Create: TObject;
Метод не имеет параметров.

Замечания:

Создает новый объект класса TStatement.

9.4.113.2. Метод BoolLiteral (Логический литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.BoolLiteral(Value: Boolean): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.113.3. Метод BuildFunctionCall (Построить вызов функции)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildFunctionCall(Function: TMethod;
2  Parameters: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Function

TMethod

Нет

Функция

Parameters

string[2000]

Нет

Параметры вызова

Замечания:

Возвращает значение типа string[2000].

9.4.113.4. Метод BuildInsertStatement (Построить скрипт добавления объекта)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildInsertStatement(AObject: TObject;
2  AClass: TClass): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AObject

TObject

Да

Объект

AClass

TClass

Нет

Класс

Замечания:

Возвращает значение типа clob.

9.4.113.5. Метод BuildProcedureCall (Построить вызов процедуры)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildProcedureCall(Procedure: TMethod;
2  Parameters: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Procedure

TMethod

Нет

Процедура

Parameters

string[2000]

Нет

Параметры вызова

Замечания:

Возвращает значение типа string[2000].

9.4.113.6. Метод BuildUpdateStatement (Построить скрипт изменения объекта)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildUpdateStatement(AObject: TObject;
2  AClass: TClass): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AObject

TObject

Да

Объект

AClass

TClass

Нет

Класс

Замечания:

Возвращает значение типа clob.

9.4.113.7. Метод Change (Изменение объекта)

Метод экземпляра класса TStatement.
procedure TStatement.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

9.4.113.8. Метод DateLiteral (Литерал типа "дата")

Метод класса (статический метод) класса TStatement.
class function TStatement.DateLiteral(Value: date): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.113.9. Метод DateTimeLiteral (Литерал типа "дата со временем")

Метод класса (статический метод) класса TStatement.
class function TStatement.DateTimeLiteral(Value: datetime): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.113.10. Метод Execute (Выполнить)

Метод класса (статический метод) класса TStatement.
class procedure TStatement.Execute(Statement: string[2000]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

9.4.113.11. Метод ExecuteClob (Выполнить большой текстовый объект)

Метод класса (статический метод) класса TStatement.
class procedure TStatement.ExecuteClob(Statement: clob);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

9.4.113.12. Метод ExecuteClobToBlobValue (Выполнить большой текстовый объект и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToBlobValue(Statement: clob): blob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа blob.

9.4.113.13. Метод ExecuteClobToBoolValue (Выполнить большой текстовый объект и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToBoolValue(Statement: clob): Boolean;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа Boolean.

9.4.113.14. Метод ExecuteClobToClobValue (Выполнить большой текстовый объект и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToClobValue(Statement: clob): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа clob.

9.4.113.15. Метод ExecuteClobToDateTimeValue (Выполнить большой текстовый объект и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToDateTimeValue(Statement: clob): datetime;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа datetime.

9.4.113.16. Метод ExecuteClobToDateValue (Выполнить большой текстовый объект и вернуть значение даты)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToDateValue(Statement: clob): date;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа date.

9.4.113.17. Метод ExecuteClobToExternalDataValue (Выполнить большой текстовый объект и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ExecuteClobToExternalDataValue(Statement: clob): <external
2  data>;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа <external data>.

9.4.113.18. Метод ExecuteClobToFloatValue (Выполнить большой текстовый объект и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToFloatValue(Statement: clob): float;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа float.

9.4.113.19. Метод ExecuteClobToIntValue (Выполнить большой текстовый объект и вернуть целое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToIntValue(Statement: clob): Integer;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа Integer.

9.4.113.20. Метод ExecuteClobToObjectValue (Выполнить большой текстовый объект и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToObjectValue(Statement: clob): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа TObject.

9.4.113.21. Метод ExecuteClobToStrValue (Выполнить большой текстовый объект и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToStrValue(Statement: clob): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа string[2000].

9.4.113.22. Метод ExecuteClobToTimeValue (Выполнить большой текстовый объект и вернуть значение времени)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToTimeValue(Statement: clob): time;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа time.

9.4.113.23. Метод ExecuteToBlobValue (Выполнить и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToBlobValue(Statement: string[2000]): blob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа blob.

9.4.113.24. Метод ExecuteToBoolValue (Выполнить и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToBoolValue(Statement: string[2000]): Boolean;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа Boolean.

9.4.113.25. Метод ExecuteToClobValue (Выполнить и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToClobValue(Statement: string[2000]): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа clob.

9.4.113.26. Метод ExecuteToDateTimeValue (Выполнить и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToDateTimeValue(Statement: string[2000]): datetime;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа datetime.

9.4.113.27. Метод ExecuteToDateValue (Выполнить и вернуть значение даты)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToDateValue(Statement: string[2000]): date;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа date.

9.4.113.28. Метод ExecuteToExternalDataValue (Выполнить и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ExecuteToExternalDataValue(Statement: string[2000]): <external
2  data>;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа <external data>.

9.4.113.29. Метод ExecuteToFloatValue (Выполнить и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToFloatValue(Statement: string[2000]): float;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа float.

9.4.113.30. Метод ExecuteToIntValue (Выполнить и вернуть целое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToIntValue(Statement: string[2000]): Integer;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа Integer.

9.4.113.31. Метод ExecuteToObjectValue (Выполнить и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToObjectValue(Statement: string[2000]): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа TObject.

9.4.113.32. Метод ExecuteToStrValue (Выполнить и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToStrValue(Statement: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа string[2000].

9.4.113.33. Метод ExecuteToTimeValue (Выполнить и вернуть значение времени)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToTimeValue(Statement: string[2000]): time;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа time.

9.4.113.34. Метод FloatLiteral (Вещественный литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.FloatLiteral(Value: float): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.113.35. Метод IntLiteral (Целочисленный литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.IntLiteral(Value: Integer): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.113.36. Метод ObjectLiteral (Литерал-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ObjectLiteral(Value: TObject): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.113.37. Метод QualifyDBMSName (Квалифицировать имя объекта БД)

Метод класса (статический метод) класса TStatement.
class function TStatement.QualifyDBMSName(DBMSName: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DBMSName

string[2000]

Нет

Имя объекта БД

Замечания:

Возвращает значение типа string[2000].

9.4.113.38. Метод SequenceLiteral (Литерал значения последовательности)

Метод класса (статический метод) класса TStatement.
class function TStatement.SequenceLiteral(SequenceName: string[64]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

SequenceName

string[64]

Да

Имя последовательности

Замечания:

Возвращает значение типа string[2000].

9.4.113.39. Метод StringAggregate (Агрегировать строки запроса)

Метод класса (статический метод) класса TStatement.
1class function TStatement.StringAggregate(Statement: string[2000];
2  Delimiter: string[2000]): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа clob.

9.4.113.40. Метод StringLiteral (Строковый литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.StringLiteral(Value: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.113.41. Метод TimeLiteral (Литерал типа "время")

Метод класса (статический метод) класса TStatement.
class function TStatement.TimeLiteral(Value: time): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.113.42. Метод ToString (Приведение литерала к строке)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ToString(Literal: string[2000]; Domain: TDomain;
2  CanUseTables: Boolean): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Literal

string[2000]

Нет

Литерал

Domain

TDomain

Нет

Домен

CanUseTables

Boolean

Да

Использовать таблицы

Замечания:

Возвращает значение типа string[2000].

9.4.114. Класс TStringBuilder (Шаблоны строк)

9.4.114.1. Свойства

Свойства класса TStringBuilder:

Имя

Тип

Обязательно

Доступ

Назначение

Template

string[2000]

Нет

Чтение/Запись

Шаблон

TemplateClob

clob

Нет

Чтение/Запись

Шаблон - большой текстовый объект

9.4.114.2. Конструктор Create (Конструктор шаблона строк)

Конструктор класса TStringBuilder.
1constructor TStringBuilder.Create(Template: string[2000];
2  TemplateClob: clob): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

TemplateClob

clob

Нет

Шаблон - большой текстовый объект

Замечания:

Создает новый объект класса TStringBuilder.

9.4.114.3. Метод Append (Добавить строку)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.Append(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа TStringBuilder.

9.4.114.4. Метод AppendToClob (Добавить строку к большому текстовому объекту)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.AppendToClob(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа TStringBuilder.

9.4.114.5. Метод Apply (Применить значение)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.Apply(Name: string[2000];
2  Value: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TStringBuilder.

9.4.114.6. Метод ApplyClob (Применить значение - большой текстовый объект)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.ApplyClob(Name: string[2000];
2  Value: clob): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Name

string[2000]

Нет

Имя

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TStringBuilder.

9.4.114.7. Метод ApplyObject (Применить свойства объекта)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.ApplyObject(Object: TObject): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

Замечания:

Возвращает значение типа TStringBuilder.

9.4.114.8. Метод Build (Построить строку)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.Build: string[2000];
Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.114.9. Метод BuildClob (Построить большой текстовый объект)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.BuildClob: clob;
Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

9.4.114.10. Метод ClearAll (Очистить все шаблоны строк)

Метод класса (статический метод) класса TStringBuilder.
class procedure TStringBuilder.ClearAll;
Метод является методом класса.

Метод не имеет параметров.

9.4.114.11. Метод ClobApply (Применить значение к большому текстовому объекту)

Метод класса (статический метод) класса TStringBuilder.
1class function TStringBuilder.ClobApply(Template: clob; Name: string[2000];
2  Value: string[2000]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

clob

Нет

Шаблон

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа clob.

9.4.114.12. Метод DebugTemplate (Отладить шаблон)

Метод класса (статический метод) класса TStringBuilder.
1class procedure TStringBuilder.DebugTemplate(Template: clob; Names: clob;
2  ApplyResult: clob);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

clob

Нет

Шаблон

Names

clob

Нет

Имена

ApplyResult

clob

Нет

Результат применения

9.4.114.13. Метод StrApply (Применить значение к строке)

Метод класса (статический метод) класса TStringBuilder.
1class function TStringBuilder.StrApply(Template: string[2000];
2  Name: string[2000]; Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.115. Класс TStringDomain (Строковые)

9.4.115.1. Свойства

Свойства класса TStringDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Длина

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимы начальные пробелы

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимы конечные пробелы

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимо дублирование пробелов

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Набор символов

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Набор символов первого символа

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Режим регистра

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Маска

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

9.4.115.2. Конструктор Create (Конструктор строкового домена)

Конструктор класса TStringDomain.
1constructor TStringDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Максимальная длина

AllowLeadingSpaces

Boolean

Да

Допустимы начальные пробелы

AllowTrailingSpaces

Boolean

Да

Допустимы конечные пробелы

AllowSpaceDuplication

Boolean

Да

Допустимо дублирование пробелов

CharacterSet

string[2000]

Нет

Набор символов

FirstCharacterSet

string[2000]

Нет

Набор символов первого символа

CaseMode

Boolean

Нет

Режим регистра

Mask

string[2000]

Нет

Маска

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TStringDomain.

9.4.115.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TStringDomain.
function TStringDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.116. Класс TStringList (Список строк)

Объекты класса не именованы.

9.4.116.1. Свойства

Свойства класса TStringList:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Duplicates

TDuplicates

Да

Видимо пользователю

Чтение/Запись

Дублирование

Sorted

Boolean

Да

Видимо пользователю

Чтение/Запись

Сортированный

Delimiter

string[2]

Нет

Видимо пользователю

Чтение/Запись

Разделитель

CaseSensitive

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистрозависимый

9.4.116.2. Конструктор Create (Конструктор списка строк)

Конструктор класса TStringList.
1constructor TStringList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TStringList.

9.4.116.3. Метод Add (Добавить строку в список)

Метод экземпляра класса TStringList.
function TStringList.Add(ItemString: string[2000]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

9.4.116.4. Метод Archive (Отправить список в архив)

Метод экземпляра класса TStringList.
procedure TStringList.Archive;
Метод не имеет параметров.

9.4.116.5. Метод Clear (Очистить список)

Метод экземпляра класса TStringList.
procedure TStringList.Clear;
Метод скрыт от пользователя.

Метод не имеет параметров.

9.4.116.6. Метод ClobField (Поле в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobField(Text: clob; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

FieldIndex

Integer

Нет

Номер поля

Замечания:

Возвращает значение типа string[2000].

9.4.116.7. Метод ClobFieldCount (Количество полей в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobFieldCount(Text: clob;
2  Delimiter: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Замечания:

Возвращает значение типа Integer.

9.4.116.8. Метод ClobFieldIndexOf (Индекс вхождения в состав большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobFieldIndexOf(Text: clob; Delimiter: string[2];
2  Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

9.4.116.9. Метод Delete (Удалить элемент из списка по индексу)

Метод экземпляра класса TStringList.
procedure TStringList.Delete(ItemIndex: Integer);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

9.4.116.10. Метод GetDelimitedText (Получить в виде разделенного текста)

Метод экземпляра класса TStringList.
function TStringList.GetDelimitedText: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.116.11. Метод GetDelimitedTextAsClob (Получить в виде разделенного большого текстового объекта)

Метод экземпляра класса TStringList.
function TStringList.GetDelimitedTextAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

9.4.116.12. Метод GetItem (Получить строку по индексу)

Метод экземпляра класса TStringList.
function TStringList.GetItem(ItemIndex: Integer): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

Замечания:

Возвращает значение типа string[2000].

9.4.116.13. Метод IndexOf (Получить индекс строки в списке)

Метод экземпляра класса TStringList.
function TStringList.IndexOf(ItemString: string[2000]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

9.4.116.14. Метод Insert (Вставить строку в список)

Метод экземпляра класса TStringList.
procedure TStringList.Insert(ItemIndex: Integer; ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemString

string[2000]

Нет

Строка

9.4.116.15. Метод Length (Длина списка)

Метод экземпляра класса TStringList.
function TStringList.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

9.4.116.16. Метод Remove (Удалить строку из списка)

Метод экземпляра класса TStringList.
procedure TStringList.Remove(ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

9.4.116.17. Метод SetDelimitedText (Создать элементы списка на основе разделенного текста)

Метод экземпляра класса TStringList.
procedure TStringList.SetDelimitedText(Text: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

9.4.116.18. Метод SetItem (Установить значение элемента)

Метод экземпляра класса TStringList.
procedure TStringList.SetItem(ItemIndex: Integer; ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemString

string[2000]

Нет

Строка

9.4.116.19. Метод Sort (Сортировать)

Метод экземпляра класса TStringList.
procedure TStringList.Sort;
Метод скрыт от пользователя.

Метод не имеет параметров.

9.4.116.20. Метод StrField (Поле в составе строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrField(Text: string[2000]; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

FieldIndex

Integer

Нет

Номер поля

Замечания:

Возвращает значение типа string[2000].

9.4.116.21. Метод StrFieldCount (Количество полей в составе строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrFieldCount(Text: string[2000];
2  Delimiter: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Замечания:

Возвращает значение типа Integer.

9.4.116.22. Метод StrFieldIndexOf (Индекс вхождения в состав строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrFieldIndexOf(Text: string[2000];
2  Delimiter: string[2]; Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

9.4.117. Класс TStringListItem (Элемент списка строк)

Объекты класса не именованы.

9.4.117.1. Свойства

Свойства класса TStringListItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

StringItem

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Строка

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

9.4.117.2. Конструктор Create (Конструктор элемента списка строк)

Конструктор класса TStringListItem.
1constructor TStringListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  StringItem: string[2000]; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

StringItem

string[2000]

Нет

Строка

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TStringListItem.

9.4.118. Класс TSystemMessage (Системные сообщения)

9.4.118.1. Свойства

Свойства класса TSystemMessage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

Text

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Текст

Data

blob

Нет

Видимо пользователю

Чтение/Запись

Данные

DataAsText

clob

Нет

Видимо пользователю

Только для чтения

Данные как текст

9.4.118.2. Метод Allow (Системные сообщения разрешены)

Метод класса (статический метод) класса TSystemMessage.
class function TSystemMessage.Allow: Boolean;
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.118.3. Метод Clear (Очистить системные сообщения)

Метод класса (статический метод) класса TSystemMessage.
1class procedure TSystemMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

9.4.118.4. Метод Post (Отправить системное сообщение)

Метод класса (статический метод) класса TSystemMessage.
class procedure TSystemMessage.Post(Text: string[2000]; Data: blob);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Data

blob

Нет

Данные

9.4.119. Класс TSystemMetadata (Системные метаданные)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.119.1. Свойства

Свойства класса TSystemMetadata:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Data

clob

Нет

Видимо пользователю

Только для чтения

Данные

CRC

string[8]

Нет

Видимо пользователю

Только для чтения

Контрольная сумма

9.4.119.2. Метод Change (Изменение объекта)

Метод экземпляра класса TSystemMetadata.
procedure TSystemMetadata.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

9.4.119.3. Метод InternalHash (Вычислить внутренний хеш)

Метод класса (статический метод) класса TSystemMetadata.
class function TSystemMetadata.InternalHash: string[128];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].

9.4.119.4. Метод Store (Сохранить метаданные)

Метод класса (статический метод) класса TSystemMetadata.
class procedure TSystemMetadata.Store(Data: clob; CRC: string[8]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Data

clob

Нет

Данные

CRC

string[8]

Нет

Контрольная сумма

9.4.120. Класс TTextIndex (Индекс текстового поиска)

9.4.120.1. Свойства

Свойства класса TTextIndex:

Имя

Тип

Обязательно

Доступ

Назначение

Field

TField

Да

Только для чтения

Поле

ObjectClass

TClass

Да

Только для чтения

Класс объекта

Object

TObject

Да

Только для чтения

Объект

ObjectName

string[64]

Да

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Только для чтения

Наименование объекта

ObjectParent

TObject

Нет

Только для чтения

Родитель объекта

ObjectMaster

TObject

Да

Только для чтения

Мастер объекта

TopLevelObject

TObject

Нет

Только для чтения

Объект верхнего уровня

Entry

TTextIndexEntry

Да

Только для чтения

Вхождение

Word

string[64]

Да

Только для чтения

Слово

UpperWord

string[64]

Да

Только для чтения

Слово в верхнем регистре

9.4.120.2. Метод CleanUp (Очистить индекс)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.CleanUp(Field: TField; Object: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Field

TField

Нет

Поле

Object

TObject

Да

Объект

9.4.120.3. Метод HashClob (Хэш индекса большого текстового объекта)

Метод класса (статический метод) класса TTextIndex.
class function TTextIndex.HashClob(Value: clob; IsXHTML: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

IsXHTML

Boolean

Да

Содержимое является XHTML

Замечания:

Возвращает значение типа string[2000].

9.4.120.4. Метод HashIndex (Хэш индекса)

Метод класса (статический метод) класса TTextIndex.
1class function TTextIndex.HashIndex(Field: TField;
2  Object: TObject): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

Замечания:

Возвращает значение типа string[2000].

9.4.120.5. Метод HashValue (Хэш значения)

Метод класса (статический метод) класса TTextIndex.
class function TTextIndex.HashValue(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

9.4.120.6. Метод IndexClob (Индексировать большой текстовый объект)

Метод класса (статический метод) класса TTextIndex.
1class procedure TTextIndex.IndexClob(DeleteExistant: Boolean; Value: clob;
2  Field: TField; Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DeleteExistant

Boolean

Да

Удалять существующие

Value

clob

Нет

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

ObjectClass

TClass

Да

Класс объекта

9.4.120.7. Метод IndexValue (Индексировать значение)

Метод класса (статический метод) класса TTextIndex.
1class procedure TTextIndex.IndexValue(DeleteExistant: Boolean;
2  Value: string[2000]; Field: TField; Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DeleteExistant

Boolean

Да

Удалять существующие

Value

string[2000]

Нет

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

ObjectClass

TClass

Да

Класс объекта

9.4.120.8. Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.LoadFromBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

9.4.120.9. Метод PrepareBuffer (Подготовить буфер)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.PrepareBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

9.4.120.10. Метод Ole-объекта Rebuild (Перестроить индекс)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TTextIndex.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AClass

TClass

Нет

Класс

AField

TField

Нет

Поле

ThreadCount

Integer

Нет

Количество потоков

9.4.121. Класс TTextIndexEntry (Вхождения индекса текстового поиска)

9.4.121.1. Свойства

Свойства класса TTextIndexEntry:

Имя

Тип

Обязательно

Доступ

Назначение

Word

string[64]

Да

Только для чтения

Слово

UpperWord

string[64]

Да

Только для чтения

Слово в верхнем регистре

9.4.121.2. Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndexEntry.
class procedure TTextIndexEntry.LoadFromBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

9.4.122. Класс TTimeDomain (Время)

9.4.122.1. Свойства

Свойства класса TTimeDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

HideSeconds

Boolean

Да

Видимо пользователю

Чтение/Запись

Не показывать секунды

9.4.122.2. Конструктор Create (Конструктор домена времени)

Конструктор класса TTimeDomain.
1constructor TTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

HideSeconds

Boolean

Да

Не показывать секунды

Замечания:

Создает новый объект класса TTimeDomain.

9.4.122.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TTimeDomain.
function TTimeDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.123. Класс TTypedValue (Типизированные значения)

Объекты класса не именованы.

9.4.123.1. Свойства

Свойства класса TTypedValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Мастер

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс мастера

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

Строковое значение

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Целое значение

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

Вещественное значение

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

Значение даты

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

Значение времени

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

Значение даты со временем

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Значение-объект

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

Логическое значение

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

Значение-большой объект

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

Значение-текст

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

Значение-внешние данные

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

Видимое значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

9.4.123.2. Конструктор Create (Конструктор типизированного значения)

Конструктор класса TTypedValue.
1constructor TTypedValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>): TTypedValue;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Создает новый объект класса TTypedValue.

9.4.123.3. Метод CompareBlob (Сравнить большие объекты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareBlob(ComparisonTypeName: string[64];
2  ValueA: blob; ValueB: blob): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

blob

Нет

Значение A

ValueB

blob

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

9.4.123.4. Метод CompareBoolean (Сравнить логические значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareBoolean(ComparisonTypeName: string[64];
2  ValueA: Boolean; ValueB: Boolean): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

Boolean

Да

Значение A

ValueB

Boolean

Да

Значение B

Замечания:

Возвращает значение типа Boolean.

9.4.123.5. Метод CompareClob (Сравнить тексты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareClob(ComparisonTypeName: string[64];
2  ValueA: clob; ValueB: clob): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

clob

Нет

Значение A

ValueB

clob

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

9.4.123.6. Метод CompareDate (Сравнить значения дат)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareDate(ComparisonTypeName: string[64];
2  ValueA: date; ValueB: date): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

date

Нет

Значение A

ValueB

date

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

9.4.123.7. Метод CompareDateTime (Сравнить значения даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareDateTime(ComparisonTypeName: string[64];
2  ValueA: datetime; ValueB: datetime): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

datetime

Нет

Значение A

ValueB

datetime

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

9.4.123.8. Метод CompareFloat (Сравнить вещественные значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareFloat(ComparisonTypeName: string[64];
2  ValueA: float; ValueB: float): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

float

Нет

Значение A

ValueB

float

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

9.4.123.9. Метод CompareInt (Сравнить целые значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareInt(ComparisonTypeName: string[64];
2  ValueA: Integer; ValueB: Integer): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

Integer

Нет

Значение A

ValueB

Integer

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

9.4.123.10. Метод CompareList (Сравнить со списком)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareList(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

string[2000]

Нет

Значение A

ValueB

TObject

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

9.4.123.11. Метод CompareObject (Сравнить значения-объекты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareObject(ComparisonTypeName: string[64];
2  ValueA: TObject; ValueB: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

TObject

Нет

Значение A

ValueB

TObject

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

9.4.123.12. Метод CompareStr (Сравнить строковые значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareStr(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

string[2000]

Нет

Значение A

ValueB

string[2000]

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

9.4.123.13. Метод CompareTime (Сравнить значения времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareTime(ComparisonTypeName: string[64];
2  ValueA: time; ValueB: time): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

time

Нет

Значение A

ValueB

time

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

9.4.123.14. Метод CreateBlobValue (Создать значение-большой объект)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateBlobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BlobValue: blob): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

BlobValue

blob

Нет

Значение-большой объект

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.15. Метод CreateBoolValue (Создать логическое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateBoolValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BoolValue: Boolean): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

BoolValue

Boolean

Нет

Логическое значение

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.16. Метод CreateClobValue (Создать значение-текст)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateClobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ClobValue: clob): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ClobValue

clob

Нет

Значение-текст

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.17. Метод CreateDateTimeValue (Создать значение даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateDateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateTimeValue: datetime): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

DateTimeValue

datetime

Нет

Значение даты со временем

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.18. Метод CreateDateValue (Создать значение даты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateDateValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateValue: date): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

DateValue

date

Нет

Значение даты

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.19. Метод CreateExternalDataValue (Создать значение внешних данных)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateExternalDataValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ExternalDataValue: <external data>): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.20. Метод CreateFloatValue (Создать вещественное значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateFloatValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  FloatValue: float): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

FloatValue

float

Нет

Вещественное значение

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.21. Метод CreateIntValue (Создать целое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateIntValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  IntValue: Integer): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

IntValue

Integer

Нет

Целое значение

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.22. Метод CreateObjectValue (Создать значение-объект)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateObjectValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ObjectValue: TObject): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ObjectValue

TObject

Нет

Значение-объект

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.23. Метод CreateStrValue (Создать строковое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateStrValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Строковое значение

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.24. Метод CreateTimeValue (Создать значение времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  TimeValue: time): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

TimeValue

time

Нет

Значение времени

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.25. Метод FindBlobValue (Поиск значения-большого объекта)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindBlobValue(Master: TObject;
2  ControlName: string[64]): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа blob.

9.4.123.26. Метод FindBoolValue (Поиск логического значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindBoolValue(Master: TObject;
2  ControlName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа Boolean.

9.4.123.27. Метод FindClobValue (Поиск значения-текста)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindClobValue(Master: TObject;
2  ControlName: string[64]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа clob.

9.4.123.28. Метод FindDateTimeValue (Поиск значения даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindDateTimeValue(Master: TObject;
2  ControlName: string[64]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа datetime.

9.4.123.29. Метод FindDateValue (Поиск значения даты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindDateValue(Master: TObject;
2  ControlName: string[64]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа date.

9.4.123.30. Метод FindExternalDataValue (Поиск значения внешних данных)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindExternalDataValue(Master: TObject;
2  ControlName: string[64]): <external data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа <external data>.

9.4.123.31. Метод FindFloatValue (Поиск вещественного значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindFloatValue(Master: TObject;
2  ControlName: string[64]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа float.

9.4.123.32. Метод FindIntValue (Поиск целого значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindIntValue(Master: TObject;
2  ControlName: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа Integer.

9.4.123.33. Метод FindObjectValue (Поиск значения-объекта)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindObjectValue(Master: TObject;
2  ControlName: string[64]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа TObject.

9.4.123.34. Метод FindStrValue (Поиск строкового значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindStrValue(Master: TObject;
2  ControlName: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа string[2000].

9.4.123.35. Метод FindTimeValue (Поиск значения времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindTimeValue(Master: TObject;
2  ControlName: string[64]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа time.

9.4.123.36. Метод FindValue (Поиск значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindValue(AMaster: TObject;
2  AControlName: string[64]): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AMaster

TObject

Нет

Объект-мастер

AControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа TTypedValue.

9.4.123.37. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер объекта

Parent

TObject

Нет

Родитель

Step

Integer

Да

Шаг

Замечания:

Возвращает значение типа Integer.

9.4.123.38. Метод GetVisibleValue (Видимое значение)

Метод экземпляра класса TTypedValue.
function TTypedValue.GetVisibleValue: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9.4.123.39. Метод ReplaceWildcards (Заменить подстановочные символы)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.ReplaceWildcards(Value: string[2000];
2  Escape: string[2]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Escape

string[2]

Нет

Экранирующий символ

Замечания:

Возвращает значение типа string[2000].

9.4.123.40. Метод SetValue (Установить значение)

Метод экземпляра класса TTypedValue.
1procedure TTypedValue.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>);
Параметры:

Имя

Тип

Обязательно

Значение

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

9.4.124. Класс TTypedValueButton (Кнопки на форме редактирования значений)

9.4.124.1. Свойства

Свойства класса TTypedValueButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomButton

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

TypedValue

TTypedValue

Нет

Видимо пользователю

Чтение/Запись

Связанное типизированное значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

9.4.124.2. Конструктор Create (Конструктор кнопки формы редактирования значений)

Конструктор класса TTypedValueButton.
1constructor TTypedValueButton.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Group: string[128];
4  Tab: string[128]; Script: clob; Scope: TScope; OutOfTabs: Boolean;
5  TypedValue: TTypedValue): TObject;
Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TCustomButton.Create

Group

string[128]

Нет

Tab

string[128]

Нет

Script

clob

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

TypedValue

TTypedValue

Нет

Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueButton.

9.4.125. Класс TTypedValueView (Представления на форме редактирования значений)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

9.4.125.1. Свойства

Свойства класса TTypedValueView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TFormView

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Layout

TFormViewLayout

Да

Видимо пользователю

Чтение/Запись

ChildrenOnTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

ExplicitQuery

Boolean

Да

Видимо пользователю

Чтение/Запись

SpacePercentage

Integer

Нет

Видимо пользователю

Чтение/Запись

TypedValue

TTypedValue

Нет

Видимо пользователю

Чтение/Запись

Связанное типизированное значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор связанного типизированного значения

ViewName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

9.4.125.2. Конструктор Create (Конструктор представления на форме редактирования значений)

Конструктор класса TTypedValueView.
1constructor TTypedValueView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout; ExplicitQuery: Boolean;
6  TypedValue: TTypedValue): TObject;
Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Унаследовано от TFormView.Create

ChildrenMinimized

Boolean

Да

ChildrenOnTabs

Boolean

Да

MasterProperty

TProperty

Нет

DetailProperty

TClassMember

Нет

Position

Integer

Да

SpacePercentage

Integer

Нет

Layout

TFormViewLayout

Да

ExplicitQuery

Boolean

Да

TypedValue

TTypedValue

Нет

Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueView.

9.4.126. Класс TUser (Пользователи)

9.4.126.1. Свойства

Свойства класса TUser:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущим

AccessMode

TUserAccessMode

Да

Видимо пользователю

Чтение/Запись

Режим доступа

CanRecieveMessages

Boolean

Да

Видимо пользователю

Чтение/Запись

Получает сообщения

9.4.126.2. Конструктор Create (Конструктор пользователя)

Конструктор класса TUser.
1constructor TUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CanRecieveMessages: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

CanRecieveMessages

Boolean

Да

Получает сообщения

Замечания:

Создает новый объект класса TUser.

9.4.126.3. Метод EffectiveMemberOf (Является эффективным членом)

Метод экземпляра класса TUser.
function TUser.EffectiveMemberOf(Role: TRole): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Role

TRole

Да

Роль

Замечания:

Возвращает значение типа Boolean.

9.4.126.4. Метод GetCurrentUser (Получить текущего пользователя)

Метод класса (статический метод) класса TUser.
class function TUser.GetCurrentUser: TUser;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TUser.

9.4.126.5. Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TUser.
function TUser.GetIsCurrent: Boolean;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.127. Класс TUserNotification (Уведомления)

9.4.127.1. Свойства

Свойства класса TUserNotification:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Type

TNotificationType

Да

Видимо пользователю

Чтение/Запись

Тип

Text

clob

Нет

Видимо пользователю

Чтение/Запись

Текст

Active

Boolean

Да

Видимо пользователю

Чтение/Запись

Активно

ShowFrom

datetime

Нет

Видимо пользователю

Чтение/Запись

Показывать с

ShowTo

datetime

Нет

Видимо пользователю

Чтение/Запись

Показывать по

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

Выделено

ShowNeeded

Boolean

Да

Скрыто от пользователя

Только для чтения

Необходимо показывать

9.4.127.2. Конструктор Create (Конструктор уведомления)

Конструктор класса TUserNotification.
1constructor TUserNotification.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Type: TNotificationType; Text: clob;
4  Active: Boolean; ShowFrom: datetime; ShowTo: datetime): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Type

TNotificationType

Да

Тип

Text

clob

Нет

Текст

Active

Boolean

Да

Активно

ShowFrom

datetime

Нет

Показывать с

ShowTo

datetime

Нет

Показывать по

Замечания:

Создает новый объект класса TUserNotification.

9.4.127.3. Метод GetShowNeeded (Необходимо показывать)

Метод экземпляра класса TUserNotification.
function TUserNotification.GetShowNeeded: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.127.4. Метод Preview (Предпросмотр)

Метод экземпляра класса TUserNotification.
procedure TUserNotification.Preview;
Метод не имеет параметров.

9.4.127.5. Метод Shown (Отметить как показанное)

Метод экземпляра класса TUserNotification.
procedure TUserNotification.Shown;
Метод скрыт от пользователя.

Метод не имеет параметров.

9.4.128. Класс TUserNotificationAddressee (Адресаты уведомлений)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.128.1. Свойства

Свойства класса TUserNotificationAddressee:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

9.4.128.2. Конструктор Create (Конструктор адресата уведомления)

Конструктор класса TUserNotificationAddressee.
1constructor TUserNotificationAddressee.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TUserNotificationAddressee.

9.4.129. Класс TUserNotificationShown (Показы уведомлений)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.129.1. Свойства

Свойства класса TUserNotificationShown:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TUserNotification

Да

Скрыто от пользователя

Только для чтения

Уведомление

Type

TNotificationType

Да

Видимо пользователю

Только для чтения

Тип уведомления

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

9.4.129.2. Конструктор Create (Конструктор показа уведомления)

Конструктор класса TUserNotificationShown.
1constructor TUserNotificationShown.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TUserNotificationShown.

9.4.130. Класс TView (Представления)

9.4.130.1. Свойства

Свойства класса TView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomView

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

IsGrouped

Boolean

Да

Видимо пользователю

Только для чтения

Сгруппировано

LinesPerRow

Integer

Да

Видимо пользователю

Чтение/Запись

Строк на ячейку

Collapsed

Boolean

Да

Видимо пользователю

Чтение/Запись

Свернуть

HasPresentations

Boolean

Да

Видимо пользователю

Только для чтения

Имеет виды

IsSorted

Boolean

Да

Видимо пользователю

Только для чтения

Отсортировано

IsAggregated

Boolean

Да

Видимо пользователю

Только для чтения

Агрегировано

9.4.130.2. Конструктор Create (Конструктор представления)

Конструктор класса TView.
1constructor TView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  Collapsed: Boolean): TObject;
Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Унаследовано от TCustomView.Create

ColorProperty

TProperty

Нет

BoldProperty

TProperty

Нет

Skimpy

Boolean

Да

PreCompiled

Boolean

Да

PreOpenRoutine

TRoutine

Нет

Collapsed

Boolean

Да

Свернуто

Замечания:

Создает новый объект класса TView.

9.4.130.3. Метод BuildDefaultColumns (Создать колонки по умолчанию)

Метод экземпляра класса TView.
1procedure TView.BuildDefaultColumns(AddNameColumn: Boolean;
2  AddDescColumn: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

AddNameColumn

Boolean

Да

Создать колонку имени

AddDescColumn

Boolean

Да

Создать колонку наименования

9.4.130.4. Метод GetHasPresentations (Имеет виды)

Метод экземпляра класса TView.
function TView.GetHasPresentations: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.130.5. Метод GetIsAggregated (Агрегировано)

Метод экземпляра класса TView.
function TView.GetIsAggregated: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.130.6. Метод GetIsGrouped (Сгруппировано)

Метод экземпляра класса TView.
function TView.GetIsGrouped: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.130.7. Метод GetIsSorted (Отсортировано)

Метод экземпляра класса TView.
function TView.GetIsSorted: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.131. Класс TViewAction (Действие-представление)

Объекты класса образуют иерархию.

9.4.131.1. Свойства

Свойства класса TViewAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

9.4.131.2. Конструктор Create (Конструктор действия-представления)

Конструктор класса TViewAction.
1constructor TViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  View: TCustomView; MasterProperty: TProperty;
5  DetailProperty: TClassMember): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

View

TCustomView

Да

Представление

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

Замечания:

Создает новый объект класса TViewAction.

9.4.132. Класс TViewColumn (Колонки представлений)

9.4.132.1. Свойства

Свойства класса TViewColumn:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Property

TProperty

Да

Видимо пользователю

Чтение/Запись

Свойство

PropertyDomain

TDomain

Да

Видимо пользователю

Только для чтения

Домен

PropertyDomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

PropertyReadMember

TClassMember

Нет

Видимо пользователю

Только для чтения

Член класса для чтения

PropertyReadMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для чтения

PropertyWriteMember

TClassMember

Нет

Видимо пользователю

Только для чтения

Член класса для записи

PropertyName

string[64]

Да

Видимо пользователю

Только для чтения

Имя свойства

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Grouped

Boolean

Да

Видимо пользователю

Чтение/Запись

Группировать

Aggregate

TAggregateKind

Нет

Видимо пользователю

Чтение/Запись

Агрегат

SortDirection

TSortDirection

Да

Видимо пользователю

Чтение/Запись

Направление сортировки

Width

Integer

Да

Видимо пользователю

Чтение/Запись

Ширина

Filter

string[128]

Нет

Видимо пользователю

Чтение/Запись

Фильтр

ForceReadOnly

Boolean

Да

Видимо пользователю

Чтение/Запись

Только для чтения

Fixed

Boolean

Да

Видимо пользователю

Чтение/Запись

Зафиксирована

IsFilterHidden

Boolean

Да

Видимо пользователю

Чтение/Запись

Фильтр скрыт

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Bold

Boolean

Да

Видимо пользователю

Чтение/Запись

Выделить шрифтом

DirectAction

TAction

Нет

Видимо пользователю

Чтение/Запись

Непосредственное действие

IsSpecificalyNamed

Boolean

Да

Видимо пользователю

Только для чтения

Специфическое имя

9.4.132.2. Конструктор Create (Конструктор колонки представления)

Конструктор класса TViewColumn.
1constructor TViewColumn.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Property: TProperty; Position: Integer; Grouped: Boolean;
4  Aggregate: TAggregateKind; SortDirection: TSortDirection; Fixed: Boolean;
5  Category: string[128]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Property

TProperty

Да

Свойство

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TViewColumn.

9.4.132.3. Метод Change (Изменение объекта)

Метод экземпляра класса TViewColumn.
procedure TViewColumn.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

9.4.132.4. Метод CreateByNames (Добавить по списку свойств)

Метод класса (статический метод) класса TViewColumn.
1class procedure TViewColumn.CreateByNames(Master: TCustomView;
2  Names: string[2000]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TCustomView

Да

Мастер

Names

string[2000]

Нет

Имена свойств

9.4.132.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TViewColumn.
class function TViewColumn.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

9.4.132.6. Метод NameAfterProperty (Дать имя свойства)

Метод экземпляра класса TViewColumn.
procedure TViewColumn.NameAfterProperty;
Метод скрыт от пользователя.

Метод не имеет параметров.

9.4.133. Класс TViewCondition (Условия отбора)

Объекты класса образуют иерархию.

9.4.133.1. Свойства

Свойства класса TViewCondition:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

LinkedClass

TClass

Нет

Видимо пользователю

Чтение/Запись

Присоединяемый класс

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

LinkedOption

TOption

Нет

Видимо пользователю

Чтение/Запись

Присоединенная настройка

LinkedOptionName

string[64]

Да

Видимо пользователю

Только для чтения

Имя присоединяемой настройки

LinkedOptionProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство присоединенной настройки

Expression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение условия

Negation

Boolean

Да

Видимо пользователю

Чтение/Запись

Отрицание

LinkNonRequired

Boolean

Да

Видимо пользователю

Чтение/Запись

Присоединять необязательное свойство

LinkedProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Присоединенный профиль

9.4.133.2. Конструктор Create (Конструктор условия отбора)

Конструктор класса TViewCondition.
1constructor TViewCondition.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  LinkedClass: TClass; MasterProperty: TProperty; DetailProperty: TClassMember;
4  LinkedOption: TOption; LinkedOptionProperty: TClassMember; Expression: clob;
5  Negation: Boolean; LinkNonRequired: Boolean; LinkedProfile: TProfile): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

LinkedClass

TClass

Нет

Присоединяемый класс

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

LinkedOption

TOption

Нет

Присоединенная настройка

LinkedOptionProperty

TClassMember

Нет

Свойство присоединенной настройки

Expression

clob

Нет

Выражение условия отбора

Negation

Boolean

Да

Отрицание

LinkNonRequired

Boolean

Да

Присоединять необязательное свойство

LinkedProfile

TProfile

Нет

Присоединенный профиль

Замечания:

Создает новый объект класса TViewCondition.

9.4.134. Класс TViewPresentation (Виды)

Имена объектов класса генерируются.

9.4.134.1. Свойства

Свойства класса TViewPresentation:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления минимизированы

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

Использовать по умолчанию

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

9.4.134.2. Конструктор Create (Конструктор вида)

Конструктор класса TViewPresentation.
1constructor TViewPresentation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer;
4  ChildrenMinimized: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

Замечания:

Создает новый объект класса TViewPresentation.

9.4.134.3. Метод GetIsAccessible (Проверка доступности)

Метод экземпляра класса TViewPresentation.
function TViewPresentation.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.134.4. Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentation.
1class function TViewPresentation.Save(Master: TObject;
2  Description: string[128]; ChildrenMinimized: Boolean): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Да

Мастер

Description

string[128]

Да

Наименование

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

Замечания:

Возвращает значение типа TObject.

9.4.135. Класс TViewPresentationAccess (Доступ к видам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.135.1. Конструктор Create (Конструктор доступа к виду)

Конструктор класса TViewPresentationAccess.
1constructor TViewPresentationAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TViewPresentationAccess.

9.4.136. Класс TViewPresentationColumn (Колонки вида)

Имена объектов класса генерируются.

9.4.136.1. Свойства

Свойства класса TViewPresentationColumn:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Column

TViewColumn

Да

Видимо пользователю

Только для чтения

Колонка представления

Presentation

TViewPresentation

Да

Скрыто от пользователя

Только для чтения

Вид

View

TObject

Да

Скрыто от пользователя

Только для чтения

Представление

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Grouped

Boolean

Да

Видимо пользователю

Чтение/Запись

Сгруппирована

Aggregate

TAggregateKind

Нет

Видимо пользователю

Чтение/Запись

Агрегат

SortDirection

TSortDirection

Да

Видимо пользователю

Чтение/Запись

Направление сортировки

Width

Integer

Да

Видимо пользователю

Чтение/Запись

Ширина

Filter

string[128]

Нет

Видимо пользователю

Чтение/Запись

Фильтр

Fixed

Boolean

Да

Видимо пользователю

Чтение/Запись

Зафиксирована

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

9.4.136.2. Конструктор Create (Конструктор колонки вида)

Конструктор класса TViewPresentationColumn.
1constructor TViewPresentationColumn.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Column: TViewColumn; Position: Integer;
4  Grouped: Boolean; Aggregate: TAggregateKind; SortDirection: TSortDirection;
5  Width: Integer; Filter: string[128]; Fixed: Boolean;
6  Category: string[128]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Column

TViewColumn

Да

Колонка

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Width

Integer

Да

Ширина

Filter

string[128]

Нет

Фильтр

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TViewPresentationColumn.

9.4.136.3. Метод AddColumns (Создать колонки)

Метод класса (статический метод) класса TViewPresentationColumn.
class procedure TViewPresentationColumn.AddColumns(Master: TViewPresentation);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TViewPresentation

Да

Мастер

9.4.136.4. Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentationColumn.
1class function TViewPresentationColumn.Save(Master: TViewPresentation;
2  Column: TViewColumn; Position: Integer; Grouped: Boolean;
3  Aggregate: TAggregateKind; SortDirection: TSortDirection; Width: Integer;
4  Filter: string[128]; Fixed: Boolean; Category: string[128]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TViewPresentation

Да

Мастер

Column

TViewColumn

Да

Колонка

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Width

Integer

Да

Ширина

Filter

string[128]

Нет

Фильтр

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Возвращает значение типа TObject.

9.4.137. Класс TVisualGroup (Визуальные группы)

Объекты класса образуют иерархию.

9.4.137.1. Свойства

Свойства класса TVisualGroup:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение

IsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Доступна

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

Collapsed

Boolean

Да

Видимо пользователю

Чтение/Запись

Свернута

9.4.137.2. Конструктор Create (Конструктор визуальной группы)

Конструктор класса TVisualGroup.
1constructor TVisualGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Image: blob; Position: Integer; Scope: TScope; Collapsed: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Image

blob

Нет

Изображение

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

Collapsed

Boolean

Да

Свернута

Замечания:

Создает новый объект класса TVisualGroup.

9.4.137.3. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TVisualGroup.
function TVisualGroup.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9.4.137.4. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroup.
class function TVisualGroup.GetNextPos(Parent: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Integer.

9.4.138. Класс TVisualGroupAccess (Доступ к визуальным группам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

9.4.138.1. Конструктор Create (Конструктор доступа к визуальной группе)

Конструктор класса TVisualGroupAccess.
1constructor TVisualGroupAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TVisualGroup;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TVisualGroup

Да

Группа доступа

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TVisualGroupAccess.

9.4.139. Класс TVisualGroupForm (Форма визуальной группы)

9.4.139.1. Свойства

Свойства класса TVisualGroupForm:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TVisualGroupItem

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Form

TForm

Да

Видимо пользователю

Чтение/Запись

Форма

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение

9.4.139.2. Конструктор Create (Конструктор формы визуальной группы)

Конструктор класса TVisualGroupForm.
1constructor TVisualGroupForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob; Form: TForm): TObject;
Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TVisualGroupItem.Create

Comment

clob

Нет

Form

TForm

Да

Форма

Замечания:

Создает новый объект класса TVisualGroupForm.

9.4.140. Класс TVisualGroupItem (Элемент визуальной группы)

9.4.140.1. Свойства

Свойства класса TVisualGroupItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Комментарий

9.4.140.2. Конструктор Create (Конструктор элемента визуальной группы)

Конструктор класса TVisualGroupItem.
1constructor TVisualGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Comment

clob

Нет

Комментарий

Замечания:

Создает новый объект класса TVisualGroupItem.

9.4.140.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroupItem.
class function TVisualGroupItem.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

9.4.141. Класс TVisualGroupRoutine (Подпрограмма визуальной группы)

9.4.141.1. Свойства

Свойства класса TVisualGroupRoutine:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TVisualGroupItem

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

9.4.141.2. Конструктор Create (Конструктор подпрограммы визуальной группы)

Конструктор класса TVisualGroupRoutine.
1constructor TVisualGroupRoutine.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Comment: clob;
4  Routine: TRoutine): TObject;
Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TVisualGroupItem.Create

Comment

clob

Нет

Routine

TRoutine

Да

Подпрограмма

Замечания:

Создает новый объект класса TVisualGroupRoutine.

9.4.142. Класс TWordAsyncTask (Задачи отложенного выполнения отчетов Word)

Объекты класса не именованы.

9.4.142.1. Свойства

Свойства класса TWordAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TAsyncTask

Created

datetime

Да

Видимо пользователю

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TAsyncTask

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Duration

time

Нет

Видимо пользователю

Только для чтения

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Format

TWordOutputFormat

Да

Видимо пользователю

Чтение/Запись

Формат

9.4.142.2. Конструктор Create (Конструктор задачи отложенного выполнения отчетов Word)

Конструктор класса TWordAsyncTask.
1constructor TWordAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TWordOutputFormat): TObject;
Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Унаследовано от TAsyncTask.Create

Object

TObject

Нет

FormView

TFormView

Нет

Handler

TAsyncHandler

Да

Language

TLanguage

Да

Format

TWordOutputFormat

Да

Формат

Замечания:

Создает новый объект класса TWordAsyncTask.

9.4.143. Класс TWordTemplate (Шаблоны отчетов Word)

9.4.143.1. Свойства

Свойства класса TWordTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

MacroName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя макроса

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

9.4.143.2. Конструктор Create (Конструктор шаблона отчета Word)

Конструктор класса TWordTemplate.
1constructor TWordTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  MacroName: string[128]; IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

blob

Нет

Данные шаблона

MacroName

string[128]

Нет

Имя макроса

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TWordTemplate.

9.4.143.3. Метод Ole-объекта CheckWordTemplate (Проверить шаблон отчетов Word)

Метод Ole-объекта класса TWordTemplate.

Метод Ole-объекта не имеет параметров.

9.4.144. Класс TXSLTTemplate (Шаблоны отчетов XSLT)

9.4.144.1. Свойства

Свойства класса TXSLTTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

clob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

FunctionName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя функции

9.4.144.2. Конструктор Create (Конструктор шаблона отчета XSLT)

Конструктор класса TXSLTTemplate.
1constructor TXSLTTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: clob;
6  FunctionName: string[128]): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

clob

Нет

Данные шаблона

FunctionName

string[128]

Нет

Имя вызываемой функции

Замечания:

Создает новый объект класса TXSLTTemplate.

9.4.144.3. Метод Ole-объекта CheckXSLTTemplate (Проверить шаблон отчетов XSLT)

Метод Ole-объекта класса TXSLTTemplate.

Метод Ole-объекта не имеет параметров.

9.5. Терминология

Интеграция - комплекс работ по настройке механизмов взаимодействия между различными учетными системами, которые функционируют независимо друг от друга в одной организационной структуре ("лоскутная" автоматизация).

Реплика - копия объекта (например, базы данных), обновляемая автоматически при обновлении оригинала.

Модальная форма - подчиененная форма, вызываемая из процедуры, накладывающая ограничения на использование процедуры пока модальная форма не будет закрыта.

10. Облачные вычисления

Под терминами "Облака", "Облачные вычисления" подразумеваются способы организации распределенных вычислений данных, функций, всего того, что требуется для автоматизации бизнес-процессов. Реализация подобной технологии иначе называется DNS (Domain Name System - система доменных имен). Упрощенно можно сказать, что существует база данных, где каждому зарегистрированному доменному имени соответствует некий IP-адрес. Также в записях этой базы данных предусмотрены настройки, указывающие на использование записей для различных действий (для электронной почты, для web и т.д.). База данных является распределенной, она хранится на множестве серверов в сети Internet одновременно, и каждый из этих серверов по стандартному описанному протоколу отдает записи этой базы данных. При необходимости можно осуществить сбор всей информации DNS, однако данные меняются настолько быстро, что в результате такой операции будут получены устаревшие значения, не соответствующие реальным.

В то же время с данными DNS вполне допустимо производить кэширование, периодическое обновление и т.п. Смысл "облачной" технологии в том, что данные заменяются на функции доступа к ним. Таким образом, нет необходимости хранить данные о соответствии DNS-имен IP-адресам. При этом всегда доступна информация о том как и куда необходимо обратиться с запросом данных и как использовать полученный ответ.

Одной из причин внедрения "облачных" технологий на предприятиях заказчика зачастую является имиджевый аспект, когда во главу угла ставится погоня за новыми технологиями на предприятии.

Для понимания, приведем пример одного из московских ВУЗов с широкой сетью филиалов.

В начале создания внутрикорпоративной системы ВУЗа ее построение происходило постепенно, по частям. Было создано централизованное хранилище всех данных, база данных с необходимыми данными и бизнес-функциями, которые выполнялись над этими данными. Все пользователи системы осуществляли свою работу из единой локальной сети с включенной в нее базой данных. Соединения осуществлялись по стандартному потоколу, предоставляемому СУБД. Этот протокол требовал низколатентных соединений и пользователи были удовлетворены, однако существловали достаточно критичные ограничения на доступ к базе данных. Данная технология представляла собой технологию "клиент-сервер".

В дальнейшем потребовалось распространение решения для удаленных филиалов ВУЗа. Было принято внутреннее решение IT-служб ВУЗа о разделении базы данных, то есть каждый филиал получил собственную базу данных (изначально пустую) и начал работать с ней. Попытка синхронизации справочников собственными усилиями не удалась. Синхронизация данных - удалась частично. Сопутствующие сопровождению системы задачи (например, распространение обновлений и др.) решались с переменным успехом.

В результате было принято решение о внедрении "облачных" технологий. Для реализации использовались сервера приложений Платформы "Мельница Данных". С их помощью были построены точки входа в единое хранилище данных. Все данные были объединены в одну централизованную базу данных и доступ к ней осуществляется каждым филиалом через собственный "обработчик", созданный для конкретного филиала. В итоге каждому филиалу достаточно знать только точку входа, через которую доступна соответствующая функция Системы. При этом пользователей филиала не должно интересовать, куда перенаправляются их запросы и какие действия осуществляются в базе данных. В следствии такого внедрения отпала необходимость в дополнительных администраторах Системы, в отслеживании вычислительных мощностей и т.д.

Вопросы по разграничению доступа, настроек и т.п. в данный момент решаются централизованно.

Простым и правильным способом организации корпоративных "облачных" SaaS-технологий будет поддержка такого решения в пределах одной организации.

Другой реальный пример внедрения "облачных" технологий - другой крупный ВУЗ:

При внедрении Системы не оказалось сил, способных осуществлять обслуживание серверных мощностей. В итоге компания "Мельница Технолгий" на собственных подконтрольных площадях самостоятельно развернула всю инфраструктуру, требующуюся для функционирования базы данных ВУЗа. Далее, на базе решения сервер приложений Платформы были созданы точки входа, через которые все функции Системы, а также все данные были доступны пользователям ВУЗа.

Основным аргументом представителей ВУЗа против подобного внедрения был тот факт, что данные хранятся не на собственных мощностях, а у стороннего поставщика услуг. Для разрешения спорного вопроса, каждую ночь на мощностях компании "Мельница Технологий" автоматически создается реплика с самыми актуальными данными. Таким образом ВУЗ всегда имеет в своем распоряжении ежедневный backup для оперативного развертывания в случае форс-мажора.

Из примера понятно, что компания "Мельница Технологий" имеет все возможности и ресурсы для подключения новых пользователей "облака", которые не желают или не имеют возможности заниматься обслуживанием Системы. При этом на заказчика не ложатся затраты на закупку и развертывание инфраструктуры и базы данных, на содержание администраторов Системы.

Второй частой причиной организации "облака" на предприятии является насущная необходимость. В этом случае Заказчик понимает технологию "облака", знает какие бизнес-функции могут быть реализованы, при этом предприятие имеет широкую разветвленную сеть удаленных филиалов, нуждающихся в доступе к централизованным данным.

Следует обратить внимание, что понятия "Облако", "Облачные вычисления" носят сугубо маркетинговый характер и не несут какой-то четкой логики построения решений. Технология заключается только в создании точек входа, за которыми функции распределяются по собственным алгоритмам, которые не должны интересовать конечного пользователя. Данные алгоритмы всегда могут быть изменены в зависимости от необходимости. Так, при возрастании нагрузки на "облако", она может быть перераспределена по тому количеству серверов, которое необходимо и удобно.

11. OLTP и OLAP

OLTP (OnLine Transaction Processing) - обработка транзакций онлайн.

Задача, которая решается с помощью OLTP-метода называется здесь и дальше "учет". Т.е. это в первую очередь учетные задачи. Характерным элементом управления решенной OLTP-задачи является так называемый "grid" - таблица, состоящая из колонок и строк.

Когда ставится и решается задача постановки учета чего бы то ни было, например, продаж мороженого, пользователь должен увидеть в результате "grid" (таблицу, табличное представление), где каждая строка соответствует одному объекту учета, в данном случае - продаже мороженого, а каждый столбец соответствует атрибуту этого самого элемента учета. В нашем случае, с продажами мороженого это точка, которая продала, сорт, количество, цена, сумма продажи и т.д.

Сорт мороженного

Точка продаж

Кол-во

Цена

Сумма

Пломбир

ул. Ленина

50

20

1000

Ленинградское

ул. Ленина

20

18

360

Эскимо

ул. Ленина

100

23

2300

Лакомка

ул. Ленина

30

25

750

В стаканчике

ул. Ленина

150

12

1800

Эта таблица должна храниться в базе данных и пользователю не важно при помощи какой технологии построена база данных (на реляционных принципах, на объектных принципах или других). Важно то, что клиентское приложение, с которым пользователь непосредственно взаимодействует, может получить данные и показать их в виде таблицы.

Как правило, у пользователя есть несколько стандартных действий для управления данными в таблице - сортировка, группировка, отбор по колонкам, по дополнительным критериям. Все эти действия предназначены быстрого поиска ошибок в данных. Таким образом поиск ошибок учета осуществляется именно в таблицах. Для исправления ошибок используются следующие методы:

1. В таблице, соответствующая ячейка переводится в режим редактирования, данные изменяются непосредственно в ней, нажатием клавиши Enter подтверждается изменение, и, если новое значение удовлетворяет внутренним ограничениям Системы, то оно будет записано в базу данных.

2. Исправление может рассматриваться как операция, в этом случае: выделяется один или несколько объектов таблицы, т.е. одна или несколько строчек, вызывается действие (либо кнопкой в панели инструментов, либо через контекстное меню, либо каким-то более экзотическим способом). Будет показана модальная форма ввода значений и параметров. При этом пользователь не сможет продолжить работы с системой пока эта форма не будет закрыта после внесения изменений или без них. Только после закрытия модальной формы действие начинает выполняться.

3. Для Платформы "Мельница Данных" также разработан элемент управления, который называется "инспектор объектов". Он используется для установки одинаковых значений для выбранных в таблице однородных объектов. Также инспектор объектов используется, для удобного просмотра всех атрибутов объекта, так как зачастую таблица содержит такое большое количество колонок, что работа с ними в таблице.

После поиска ошибок какие-то из объектов таблицы участвуют в дальнейших бизнес-процессах, которые должны быть реализованы, какие-то не участвуют и просто хранятся.

Для конечного пользователя простой ввод бизнес-данных в систему учета не имеет никакого практического смысла без возможности дальнейшей обработки и формирования отчетности.

Первичные данные, полученные в результате решения OLTP-задачи, должны использоваться для решения бизнес-задач.

OLАP (Online Analisys Processing) - аналитическая обработка в реальном времени.

В результате решения задачи OLAP система может получить следующее:

1. Результаты обработки, готовые к публикации.

2. Информация для дальнейшего принятия управленческих решений.

Данные, полученные в результате решения OLTP-задачи, поступают на вход и рассматриваются в качестве входных данных для задачи OLАP. Такие данные принято называть "Фактами". Факты должны быть предварительно выверены, подготовлены. В зависимости от разработанных стандартов для Системы не все данные могут быть переданы в OLAP-задачу в качестве фактов. Для данных могут использоваться дополнительные признаки, такие как: "Выверено", "Обработано", "Проверено", "Утверждено". Соответственно на вход OLAP-задачи можно направить данные, для которых один, несколько или все признаки (определяется логикой при разработке) имеют значение "Истина". Факты, которые попали на вход OLAP-задачи, составляют таблицу фактов. В таблице фактов выделяются факты, которые являются "мерой" (measure) или "показателем" (index).

Для примера, самый простой показатель - это количество самих фактов, а также средняя сумма, дисперсия, любой агрегат над этим значением.

Далее выверяют измерение анализа - это, как правило, ссылки на справочные таблицы, и по этим справочным таблицам строится список соответствующий измерению (dimension). На основании таблицы фактов и информации о том, что у нас является показателем, что у нас является измерениями, строится так называемый "куб". Структура данных "куба" сложная. Для наглядности, ниже приведен "куб" для нашего простого примера продаж мороженного:

В качестве меры выбрано количество сумма продаж по деньгам, а в качестве измерения - сорт мороженого, дата и точка, которая эту продажу осуществила. По первой оси - дата. По этой оси выстраиваются все дни соответствующего периода, 01.01.2012, 02.01.2012 и так далее. За год - 365 точек. По другой оси выстраиваются все имеющиеся в продаже сорта. По третьей оси мы ставим точки, соответствующие точкам продаж. В получившемся кубе, в каждой ячейке пишем общую сумму продаж этого сорта мороженного в этой точке и за этот день. В каждой из ячеек может быть несколько различных значений измерений. В этом случае ячейка делится на несколько частей. Например, для примера с мороженным, ячейка также может содержать, кроме суммы продаж, количество проданных единиц данного сорта мороженного. В более сложных случаях, количество показателей может быть большим чем три, как в примере.

Для хранения описанной информации используется специализированное многомерное хранилище. Платформа "Мельница Данных" аккумулирует такие многомерные хранилища с помощью реляционных структур.

Второе требование для OLAP задачи - визуализация данных. Табличный вид описанного выше "куба" это сводная таблица, позволяющая группировать измерения, а также показывать факты, то есть значения показателей в ячейках. Для таблицы доступны различные варианты просмотра данных в различных разрезах.

Следующее требование - публикация данных. Здесь нужно отметить, что публикация одного единственного среза данных не несет большого смысла. С точки зрения конечного пользователя, оптимальным вариантом публикации будет являться такой вид на данные, при котором пользователь может "вживую" менять измерения, перетаскивать их и т.д. Такая публикация может быть полезна при принятии управленческих решений руководством предприятия, а также будет удобна для анализа конечными пользователями. Кроме того, для публикации активно используются всевозможные графики, диаграммы, построенные по актуальным данным.

Достаточно востребованным для конечных пользователей является также свойство Системы, называемое Drill Down (проваливание). Данное свойство подразумевает, что пользователь выбрав каким-либо образом значение показателя, имеет возможность посмотреть, каким образом этот показатель был посчитан, на основании чего, и собственно, на основании каких конкретно данных был сформирован этот показатель. Для этого OLАP-системе необходим доступ к первичным данным. Такое требование не является существенной проблемой, так как у хранилище одно и то же и для OLTP-задачи и для OLАP-задачи.

12. RESTful-service стандартного обработчика

Функции стандартного обработчика сервера приложений доступны при обращении по следующим url:
Схема://хост/Имя обработчика/Функция сервиса.расширение
Запрос к функциям сервиса может содержать один параметр с именем query, который может быть передан методом GET или методом POST.

Ниже рассмотрены конкретные функции, которые можно вызывать.

12.1. Функция accesslist

Функция accesslist позволяет получить список всех ролей безопасности, в которые включен текущий пользователь. В список войдут идентификаторы всех ролей и идентификатор пользователя. В случае, если вызов выполняется пользователем, являющимся администратором БД, то возвращаемый список будет пустым. Это означает, что для пользователя нет ограничений в доступе к данным и функциональности системы.

Допустимое расширение .xml.

Функция не имеет параметров.

Функция возвращает ответ в виде XML-документа с элементом data, имеющим набор подчиненных узлов row, соответствующих каждому объекту полученного списка. Каждый узел row содержит в качестве значения идентификатор (ID) роли или пользователя.

Пример запроса:
https://techmill.ru/demo/accesslist.xml
Пример ответа:
01<data eof="1">
02  <row>
03    <ID type="int64">460</ID>
04  </row>
05  <row>
06    <ID type="int64">70540</ID>
07  </row>
08  <row>
09    <ID type="int64">891142</ID>
10  </row>
11  <row>
12    <ID type="int64">2533983</ID>
13  </row>
14  <row>
15    <ID type="int64">741846296</ID>
16  </row>
17</data>
12.2. Функция batch

Функция batch дает возможность однократным ее вызовом отправить на выполнение несколько запросов на получение данных или на вызов методов и получить набор запрошенных данных и результаты выполнения методов.

Допустимые расширения:

.xml - для получения ответа в формате xml

.js/.json - для получения ответа в формате JSON

Функция осуществляет серию запросов и/или вызовов методов и возвращает данные, соответствующие структуре и условиям переданных запросов и вызовов. Запросы и вызовы передаются в виде параметра GET или POST-запроса с именем query. Значение параметра представляет собой xml-документ следующей структуры:
01<root>
02  <query  class="TRemoteUser">
03    <item part="0" name="FullName"/>
04    <item part="1" name="ID" value="1320218"/>
05  </query>
06  <query  class="TPerson">
07    <item part="0" name="LastName"/>
08    <item part="0" name="FirstName"/>
09    <item part="1" name="ID" value="5652545"/>
10  </query>
11  <execute class="TSchoolAbiturSt" method="RegCount">
12    <row>
13      <AdmissionYear>7427462</AdmissionYear>
14      <AdmStage>8608398</AdmStage>
15      <PrevAdmissionYear>6843737</PrevAdmissionYear>
16      <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
17    </row>
18  </execute>
19</root>
Элемент root может включать в себя набор элементов двух типов:

query - эти элементы позволяют выполнять запросы к данным; принципы формирования этих элементов совпадают с принципами, описанными для функции cursor: Функция cursor

execute - эти элементы позволяют выполнять вызовы методов; принципы формирования этих элементов совпадают с принципами, описанными для функции execute: Функция execute

При использовании функции batch при выполнении запросов к данным, соответствующим элементам query, всегда используется значение атрибута fetchall="1", даже если этот атрибут не передан, или для него передано значение "0". Подробнее об использовании атрибута fetchall="1": Использование возвращаемого ответа.

Желательно не включать в вызовы функции batch запросы, которые потенциально могут вернуть очень большой набор данных. Для таких запросов лучше использовать функцию cursor (Функция cursor).

12.3. Функция bulkinsert

Функция bulkinsert позволяет выполнить пакетное добавление данных в поля таблицы. Для использования данной функции подключение должно осуществлять под пользователем, имеющим права доступа на запись к полям таблиц.

Допустимые расширения: .xml, .js / .json.

Функция имеет параметр query, который должен представлять собой XML документ, содержащий информацию о таблице (имя таблицы совпадает с именем класса), в которую должно быть выполнено добавление записей, именах полей и их значениях. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML документ - значение параметра query должен иметь элемент data (можно использовать другое имя элемента, оно не анализируется) с атрибутом handle, в значении которого должно быть передано имя таблицы (имя класса). Корневой элемент должен иметь набор дочерних узлов row, каждый из которых должен иметь дочерние узлы, соответствующие каждой паре имя поля (имя узла) - значение (значение узла).

При успешном выполнении функции будет возвращен ответ в формате XML-документа или в формате JSON с элементом data, который будет включать в себя набор узлов с одним значением id. Значения id будут представлять собой идентификаторы созданных объектов.
01https://techmill.ru/demo/bulkinsert.xml?query=
02  <data handle="TTemporaryList">
03    <row>
04      <FName>Name1</FName>
05      <FDescription>Desc1</FDescription>
06      <FItemInfo>ItemInfo1</FItemInfo>
07    </row>
08    <row>
09      <FName>Name2</FName>
10      <FDescription>Desc2</FDescription>
11      <FItemInfo>ItemInfo2</FItemInfo>
12    </row>
13    <row>
14      <FName>Name3</FName>
15      <FDescription>Desc3</FDescription>
16      <FItemInfo>ItemInfo3</FItemInfo>
17    </row>
18    <row>
19      <FName>Name4</FName>
20      <FDescription>Desc4</FDescription>
21      <FItemInfo>ItemInfo4</FItemInfo>
22    </row>
23  </data>
12.4. Функция closecursor

Функция closecursor позволяет закрыть ранее открытый курсор, который был открыт при предшествующем вызове функции cursor (Функция cursor).

Допустимое расширение: .xml.

Значением параметра функции query должно быть значение handle, которое было возвращено при вызове функции cursor.

Ответом будет xml-документ с одним пустым элементом data.

Запрос:
https://techmill.ru/demo/closecursor.xml?query="{9197829A-AFA3-49D1-BD03-D860ECCB901F}"
Ответ:
<data/>
Открытые курсоры закрываются автоматически при завершении сессии. В рамках одной сессии желательно явно вызывать функцию closecursor при работе с большими объемами данных, когда данные были получены не полностью (при вызове функции cursor было получено eof="0") и результаты запроса более не нужны.

12.5. Функция commonproperties

Функция commonproperties позволяет получить значения общих свойств списка объектов, включенных в ранее созданный буфер.

Принципы формирования списка общих свойств объектов и возврата их значений совпадают с принципами работы Инспектора объектов: Отображение свойств Инспектором объектов.

Возможности создания буфера и добавление в него объектов описаны в статьях Функция selectedbuffer, Функция selectionchanged.

Допустимое расширение .xml.

В значении параметра функции с именем query необходимо передать xml-документ, содержащий идентификатор буфера и указания о принципе отбора свойств. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML документ должен иметь элемент query со следующими атрибутами:

handle (обязательный) - идентификатор буфера

propid - идентификатор свойства; если данный атрибут не передан или для него передано пустое значение, то будет возвращен полный набор полученных свойств, если будет передан идентификатор одного свойства, то будет возвращено значение только этого одного свойства.

publiconly - значение "0" (по умолчанию) будет означать, что в ответ будут включены все общие свойства набора объектов, значение "1" будет означать что в ответ будут включены только свойства с областью видимости "Видимо пользователям" (Scope = scPublic).

Пример запроса:
https://techmill.ru/demo/commonproperties.xml?query=<query handle="221024" publiconly="1"/>
Запрос на общие свойства списка объектов, предварительно добавленных в буфер с идентификатором "221024". В ответ будет включены только свойство с областью видимости "Видимо пользователям".

В качестве ответа будет возвращен XML-документ с элементом data, который будет включать в себя набор узлов row, соответствующих каждому свойству из полученного набора свойств. Каждый узел row будет иметь подчиненные узлы:

ID - идентификатор свойства

Value - значение свойства

Value-N - для свойств с доменом ссылочного типа (объектов) будет возвращено Имя объекта; для свойств других доменов значение будет пустым

Value-D - для свойств с доменом ссылочного типа (объектов) будет возвращено Наименование объекта; для свойств других доменов значение будет пустым

Recieved - для свойств типа "Отложенное" (Suspended) будет возвращено значение "0", для прочих свойств будет возвращено значение "1"; в случае получения значение "0" значение такого свойства можно будет получить другим отдельным запросом именно на это свойство, например, при помощи функции cursor (Функция cursor).

Пример ответа:
01<data eof="1">
02  <row>
03    <ID type="int64">69174</ID>
04    <Value>76208</Value>
05    <Value-N>город Москва</Value-N>
06    <Value-D>Москва</Value-D>
07    <Recieved type="int">1</Recieved>
08  </row>
09  <row>
10    <ID type="int64">69175</ID>
11    <Value>67991</Value>
12    <Value-N>РФ</Value-N>
13    <Value-D>Российская Федерация</Value-D>
14    <Recieved type="int">1</Recieved>
15  </row>
16  <row>
17    <ID type="int64">69176</ID>
18    <Value/>
19    <Value-N/>
20    <Value-D/>
21    <Recieved type="int">0</Recieved>
22  </row>
23  <row>
24    <ID type="int64">4503868</ID>
25    <Value>77</Value>
26    <Value-N/>
27    <Value-D/>
28    <Recieved type="int">1</Recieved>
29  </row>
30</data>
12.6. Функция cursor

Функция cursor позволяет отправлять запросы на получение данных, доступных через обработчик сервера приложений, получать ответ с запрошенными данными в форматах xml или JSON.

Допустимые расширения:

.xml - для получения ответа в формате XML

.js/.json - для получения ответа в формате JSON

Функция осуществляет запрос к указанному классу или представлению и возвращает данные, соответствующие структуре и условиям переданного запроса. Запрос к данным передается в виде параметра GET или POST-запроса с именем query. Значение параметра представляет собой xml-документ следующей структуры:
01<query class="TWorker">
02  <item part="what" name="LastName" />
03  <item part="what" name="FirstName"/>
04  <item part="what" name="MiddleName"/>
05  <item part="what" name="BirthDate"/>
06  <item part="what" name="ContactList" value="TPerson.GetContactList" special="function">
07    <parameters>
08      <ContactType>63474</ContactType>
09    </parameters>
10  </item>
11  <item part="where" name="LastName" value="А*"/>
12  <item part="order" name="LastName"/>
13  <item part="order" name="FirstName"/>
14</query>
Элемент query имеет обязательный атрибут class. Значением атрибута class должно быть имя класса или представления, к которому будет выполняться запрос. Также может использоваться необязательный атрибут fetchall, который может принимать значения "0" (значение по умолчанию) или "1". Использование атрибута fetchall подробнее описано ниже в разделе Использование возвращаемого ответа.

Элемент query может включать в себя элементы item, передающие структуру запроса, условия отбора, сортировки, группировки. Элементы item могут включать в себя необязательные элементы (context, parameters, и т.п.; имя этого элемента не анализируется).

Состав атрибутов элемента item (обязательным является только атрибут part, остальные атрибуты можно опускать, в зависимости от использования других атрибутов):

part (обязательный атрибут) - часть запроса (what, where, order,...)

name - в простом случае (без использования special) - имя свойства класса (или поля представления), которое будет использовано в запросе; при использовании special может быть как именем свойства класса, так и другой строкой (см. подробнее ниже).

value - значение, которое в зависимости от значения атрибутов part и special, будет использовано для сравнений или для других целей; в простом случае (если part = "where", special отсутствует) будет использовано для сравнения в условии отбора при выполнении запроса.

special - вводит дополнительные возможности формирования запроса (возможности описаны ниже); от использованного значения данного атрибута может зависеть трактовка значений других атрибутов.

subQuery

joinKey

joinLink

joinSource

Допустимые значения атрибута part (можно использовать как строковые, так и числовые значения):

Строковое
значение

Числовое
значение

Назначение и пример использования

what

0

Элементы со значением "what" (0) атрибута part используются для формирования what-кляузы запроса. В полученном ответе каждому такому элементу будет соответствовать один xml или json элемент с именем, переданным атрибутом name.
<item part="what" name="LastName"/>
Получить значение свойства "LastName".

where

1

Элементы со значением "where" (1) атрибута part используются для формирования условия отбора объектов (where-кляузы запроса).
Для условий допустимо использовать "маску" (*, ?), условия ">", "<", ">=", "<=";
использование значений через ";" будет трактовано как условие "или", использование "&" будет трактовано как условие "и";
для отрицания нужно использовать "!", для условия "not null" нужно использовать "*", для условия "is null" нужно использовать "!*".
Каждый следующий where-элемент добавляет к запросу одно условие "и".
1<item part="where" name="LastName" value="Петров"/>
2<item part="where" name="FirstName" value="А*"/>
Отобрать объекты класса со значением свойства "LastName", равным "Петров", и значениями "FirstName", начинающимися с символа "А".

order

2

Элементы со значением "order" (2) атрибута part используются для управления сортировкой данных в возвращаемом ответе. По умолчанию (без использования атрибута special) будет выполнена сортировка "по возрастанию". Задать сортировку "по убыванию" можно, использовав значение "desc" (7) для атрибута special. Если в запросе использовано несколько элементов "order", то возвращаемый результат будет отсортирован по нескольким полям в том порядке, в котором они указаны в запросе.
1<item part="order" name="LastName/>
2<item part="order" name="BirthDate" special="desc"/>
Отсортировать результат запроса по значению свойства "LastName" по возрастанию, затем по значению свойства "BirthDate" по убыванию.

group

3

Элементы со значением "group" (3) атрибута part используются для управления группировкой данных в возвращаемом ответе. Если в запросе использовано несколько элементов "group", то возвращаемый результат будет сгруппирован по нескольким полям в том порядке, в котором они указаны в запросе. Для свойств, не входящих в условия группировки, можно получать значения агрегатов (количество, наименьшее/наибольшее/среднее и т.п.), используя атрибут special.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="what" name="BirthDate" special="min"/>
4<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region", количество записей в группе и минимальное значение свойства "BirthDate" в этой группе.

having

4

Элементы со значением "having" (4) атрибута part позволяют накладывать условия отбора на группы в запросе с группировкой.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="what" name="BirthDate" special="min"/>
4<item part="group" name="Region"/>
5<item part="having" name="ID" value=">3" special="count"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region", количество записей в группе и минимальное значение свойства "BirthDate" в этой группе, отобрав при этом только такие группы, количество объектов в которых больше 3-х.

innerJoin

5

outerJoin

6

Допустимые значения атрибута special (можно использовать как строковые, так и числовые значения):

Строковое
значение

Числовое
значение

Части запроса

Назначение и пример использования

ID

1

what
where

Позволяет запрашивать идентификатор объекта или накладывать условия по идентификатору.
1<query class="TWorker">
2  <item part="what" special="ID"/>
3  <item part="what" name="LastName"/>
4  <item part="what" name="FirstName"/>
5  <item part="where" value="5500921" special="ID"/>
6</query>
Получить идентификатор объекта, значения свойств LastName, FirstName объекта с идентификатором, равным 5500921. Ответ на запрос будет содержать элемент с именем ID.

parent

2

what
where

Позволяет использовать в запросах идентификатор "родителя" объекта.
1<query class="TCountry">
2  <item part="what" special="ID"/>
3  <item part="what" special="parent"/>
4  <item part="what" name="Name"/>
5  <item part="what" name="Description"/>
6</query>
Получить идентификатор объекта, идентификатор родительского объекта, значения свойств Name, Description всех объектов класса TCountry. Ответ на запрос будет содержать элемент с именем Parent.

haschildren

3

what
where

Признак наличия дочерних объектов в иерархии. Ответ на запрос будет содержать элемент с именем HasChildren и значением "1" в случае наличия дочерних объектов и значением "0" в случае их отсутствия.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" special="haschildren"/>
5</query>
Получить значения свойств Name, Description, а также признак наличия дочерних объектов всех объектов класса TCountry.

filter

4

where

Позволяет использовать для отбора условия, заданные доменами, использованными в решении на платформе. Имя или идентификатор домена указывается в атрибуте name. Условие отбора этого домена будет интерпретировано с учетом значений, переданных в дочернем элементе context. Для каждого из этих значений должны быть указаны его имя, домен и значение.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name = "TRegion of UnivCountry domain" special="filter>
5      <context>
6        <UnivCountry domain="4565848">67991</UnivCountry>
7      </context>
8  </item>
9</query>
Получить значения свойств Name, Description объектов класса TCountry, подходящих под условие отбора домена "TRegion of UnivCountry domain", используя значение "67991" вместо идентификатора UnivCountry.
Условие отбора домена "TRegion of UnivCountry domain":
((Self.Parent = UnivCountry) or (Self = UnivCountry))

uplink

5

what
where

Используется для отбора данных в контексте выбранных родительских объектов. Связь отбираемых объектов с выборкой связанных родительских объектов будет установлена по свойству, переданному атрибутом name. В атрибуте value может быть передан идентификатор одного объекта, список идентификаторов объектов через ";" или идентификатор буфера, в который предварительного сохранен список объектов.
1<query class="TCountry">
2  <item part="where" name="Parent" value="14750" special="uplink"/>
3  <item part="what" name="Name"/>
4  <item part="what" name="Description"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, у которых значение свойства Parent равно "14750" (или входит в состав объектов, сохраненных в буфере с идентификатором "14750").

root

6

where

Будут отобраны только объекты, не имеющие родителя, после наложения других условий отбора.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" special="root"/>
5</query>
Получить значения свойств Name, Description "корневых" (не имеющих родителя) объектов класса TCountry.

desc

7

order

Используется для сортировки "по убыванию" для элементов с атрибутом part ="order". Без указания атрибута special будет выполнена сортировка "по возрастанию".
1<item part="order" name="LastName"/>
2<item part="order" name="BirthDate" special="desc"/>
Отсортировать результат запроса по значению свойства "LastName" по возрастанию, затем по значению свойства "BirthDate" по убыванию.

count

8

what
having

Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения количества объектов в группе.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="group" name="Region"/>
4<item part="having" name="ID" value=">3" special="count"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и количество записей в группе, отобрав при этом только такие группы, количество объектов в которых больше 3-х.

sum

9

what
having

Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения суммы значений свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="PayedSum" special="sum"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и сумму значений свойства "PayedSum" для всех объектов группы.

min

10

what
having

Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения минимального значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="BirthDate" special="min"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и минимальное значение свойства "BirthDate" среди всех объектов группы.

max

11

what
having

Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения максимального значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="BirthDate" special="max"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и максимальное значение свойства "BirthDate" среди всех объектов группы.

avg

12

what
having

Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения среднего значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"
2<item part="what" name="PayedSum" special="avg"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и среднее значение свойства "PayedSum" среди всех объектов группы.

masterLink

13

where

Позволят наложить отбор на объекты класса ("подчиненный" класс) в контексте выбранных объектов класса-мастера или класса, связанного с исходным по другому свойству ("главный" класс). В атрибуте name в этом случае передаются имена свойства "главного" класса и свойства "подчиненного" класса, по которым эти классы связаны. Имена свойств указываются следующим образом:

Если одним из этих свойств является идентификатор (ID), то имя этого свойства не указывается (это свойство используется по умолчанию)

Если оба свойства отличаются от ID, то их имена указываются через разделитель ";", например, "Master;Person"

Если только свойство "подчиненного" класса отличается от ID, то указывается только имя этого свойства, например, "Person"

Если только свойство "главного" отличается от ID, то вместо свойства-подчиненного указывается *, например, "Master;*"

В свойстве value передается идентификатор буфера, содержащего список выбранных объектов "главного" класса.
1<query class="TContact">
2  <item part="what" name="ContactInfo"/>
3  <item part="what" name="ContactType" special="name"/>
4  <item part="where" name="Person" value="246889" special="masterLink"/>
5</query>
Получить значения свойств ContactInfo, ContactType (Имя) объектов класса TContact, для объектов, список которых сохранен в буфере с идентификатором "246889", связанным с классом TContact по свойству Person.

selectedOnly

14

where

Позволят наложить отбор по списку идентификаторов объектов класса, ранее сохраненных в буфере.
1<query class="TPerson">
2  <item part="what" name="LastName"/>
3  <item part="what" name="FirstName"/>
4  <item part="where" value="246889" special="selectedOnly"/>
5</query>
Получить значения свойств LastName, FirstName объектов класса TPerson, список которых сохранен в буфере с идентификатором "246889".

distinct

15

what

Позволяет получить все уникальные значения определенного свойства или сочетания значений свойств класса.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" special="distinct"/>
4</query>
Получить набор уникальных значений свойства FirstName класса TPerson.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="MiddleName"/>
4  <item part="what" special="distinct"/>
5</query>
Получить набор уникальных сочетаний значений свойств FirstName и MiddleName класса TPerson.

view

16

where

Позволяет при выполнении запроса наложить отбор, используемый для определенного представления. Имя (или идентификатор) представления указывается в атрибуте name.
1<query class="TPerson">
2  <item part="where" name="Persons older 25" special="view"/>
3  <item part="what" name="FirstName"/>
4  <item part="what" name="LastName"/>
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, соответствующих условиям отбора представления Persons older 25.

caseInsensitive

17

where

Позволяет наложить отбор на значение свойства строкового типа без учета регистра. Без использования special поиск ведется с учетом регистра.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="LastName"/>
4  <item part="where" name="FirstName" value="АНДРЕЙ" special="caseInsensitive"/>
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, с отбором по значению свойства FirstName без учета регистра символов. TPerson.

string

18

where

Позволят явно приводить к строковому типу значения свойства, переданного атрибутом name.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="Code" value="00002" special="string"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, со значением свойства Code, равным "00002".

listed

19

where

Позволяет выполнять отбор по списку объектов, входящих в список, сохраненный в системе как объект класса TObjectList ("Списки"), идентификатор которого нужно передать в качестве значения атрибута value.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="ID" value="5245654" special="listed"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, входящих в список, сохраненный как объект класса TObjectList с идентификатором "5245654".

name

20

what
where

Для свойств-ссылок на объекты позволяет получить Имя объекта, переданного атрибутом name. В полученном ответе соответствующий элемент будет иметь имя ИмяСвойства-N.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Parent"/>
5  <item part="what" name="Parent" special="name"/>
6</query>
Для всех объектов класса TCountry получить значения свойств Name, Description, Parent, а также Имя объекта Parent.

description

21

what
where

Для свойств-ссылок на объекты позволяет получить Наименование объекта, переданного атрибутом name. В полученном ответе соответствующий элемент будет иметь имя ИмяСвойства-D.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Parent"/>
5  <item part="what" name="Parent" special="description"/>
6</query>
Для всех объектов класса TCountry получить значения свойств Name, Description, Parent, а также Наименование объекта Parent.

function

22

what
where

Позволяет использовать значения, полученные в результате вызова функций, как в элементах с атрибутом part ="what", так и в элементах с атрибутом part ="where". Имя функции должно быть передано в атрибуте value в формате Имя класса.Имя функции. Если функция имеет параметры, то для их передачи необходимо добавить дочерний элемент context, со своими дочерними элементами для каждого из параметров в формате <ИмяПараметра>Значение параметра</ИмяПараметра>. Если функция является "методом объекта", параметр "ID" добавлять не нужно, он будет использован автоматически. В элементах с атрибутом part ="what" значение атрибута name может быть любым, оно не будет использовано при выполнении запроса, но станет именем элемента данных в получаемом ответе.
01<item part="what" name="InitAndLast" value="TPerson.GetInitAndLast" special="22"/>
02<item part="what" name="ContactList" value="TPerson.GetContactList" special="22">
03  <context>
04    <ContactType>63474</ContactType>
05  </context>
06</item>
07<item part="where" name="TWorker.IsSuperior" value="1" special = "function">
08  <context>
09    <OtherWorker>625186</OtherWorker>
10    <Department></Department>
11  </context>
12</item>
Получить результат выполнения функции GetInitAndLast класса TPerson (функция не имеет параметров), получить результат выполнения функции GetContactList класса TPerson с параметром ContactType = 625186. Отобрать только те объекты, для которых результат выполнения функции IsSuperior класса TWorker равен "1". Функция IsSuperior вызывается со значением 625186 параметра OtherWorker и пустым значением параметра Department.

countdistinct

23

what
having

Позволяет получить количество уникальных значений свойства.
1<query class="TPerson">
2  <item part="what" name="FirstName" special="countdistinct"/>
3</query>
Получить количество уникальных значений свойства FirstName класса TPerson.

boolean

24

what
where

Позволят приводить к "логическому" типу значения свойства, переданного атрибутом name. Приведение выполняется по следующему принципу:

значение Null преобразуется в пустое значение в ответе

значение "0" остается значением "0" в ответе

любое непустое значение преобразуется в значение "1" в ответе

Такая возможность позволяет, например, более эффективно (без получения самих значений) определять пустоту/непустоту значений типа "большой объект".
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Code" special="boolean"/>
5</query>
Получить значения свойств Name, Description, а также значение свойства Code, преобразованное к "логическому" всех объектов класса TCountry.

exact

25

where

При использовании значения "exact" (25) атрибута special значение, переданное в атрибуте value, будет использовано "как есть" - без преобразования типов, без трактовки символов "*", "?" как маски и т.п.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="Code" value = "002*25?" special="exact"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry со значением свойства Code, равным "002*25?".

searchindex

26

where

Позволяет использовать индексы полнотекстового поиска при отборах. Поиск по выполняться по всем полям класса, значение атрибута name будет проигнорировано.
1<query class="TMailMessage">
2  <item part="what" name="Theme"/>
3  <item part="what" name="Body"/>
4  <item part="what" name="Created"/>
5  <item part="where" value="приглашаем *на семинар *Современные" special="searchindex">
6</query>
Получить значения свойств Theme, Body, Created объектов класса TMailMessage, среди значений свойств которых будет найдена указанная строка, с использованием индекса полнотекстового поиска.

optimization

27

where

Позволяет использовать имеющиеся подсказки оптимизатору при выполнении запроса.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="LastName"/>
4  <item part="what" value="ORARefreshOnFetch=true;APPRefreshOnFetch=true" special="optimization">
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, используя при выполнении запроса подсказки оптимизатору.

12.6.1. Использование возвращаемого ответа

При корректном выполнении запроса ответ будет представлять собой набор данных следующей структуры:

При использовании формата xml будет возвращен xml-документ с корневым элементом data, который будет иметь атрибуты handle (GUID) и eof ("1" или "0"). Элемент data будет иметь подчиненные элементы row, каждый из которых будет соответствовать одной записи, полученной при выполнении запроса. Каждый элемент row будет иметь подчиненные элементы, соответствующие what-элементам запроса.

При использовании формата JSON будет возвращен JSON-объект, содержащий пары ключ-значение handle (значение типа GUID), eof (значения "0" или "1") и data. Значением data будет массив пар ключ-значение, каждая из которых будет соответствовать одной записи, полученной при выполнении запроса.

Обработчик сервера приложений, обеспечивающий работу функций RESTfull-сервисов, в том числе функции cursor, имеет параметры, ограничивающие размер пакета возвращаемых данных, выраженные в количестве объектов в ответе и в объеме ответа в байтах. В случае, если размер ответа укладывается в оба этих ограничения, все полученные данные будут возвращены полностью, и в ответе будет передан атрибут (значение) eof="1". В случае, если размер ответа превысит одно из ограничений, и при этом в запросе атрибут fetchall не задан или равен "0", то в ответ войдет только такой набор записей, который позволит соблюсти ограничения, и при этом в ответе будет передан атрибут (значение) eof="0". Если в запросе был передан атрибут fetchall="1", то будет выполнена попытка вернуть весь ответ полностью, несмотря на установленные ограничения. При успешной передаче атрибут (значение) eof будет равен "1".

Пример запроса:
1  <query class="TWorker" fetchall="1">
2    <item part="0" name="LastName"/>
3    <item part="0" name="FirstName"/>
4    <item part="0" name="BirthDate"/>
5    <item part="0" name="AcademicStatus"/>
6    <item part="1" name="BirthDate" value=">12.05.2000"/>
7  </query>
Пример ответа в формате xml:
01  <data handle="{FDF9EE70-9948-4A99-8233-349C3ADD3CE8}" eof="1">
02    <row>
03      <LastName>Абишин</LastName>
04      <FirstName>Вячеслав</FirstName>
05      <BirthDate type="date">10.06.2014</BirthDate>
06      <AcademicStatus>к.э.н.</AcademicStatus>
07    </row>
08    <row>
09      <LastName>Агринская</LastName>
10      <FirstName>Ольга</FirstName>
11      <BirthDate type="date">24.08.2016</BirthDate>
12      <AcademicStatus>PhD</AcademicStatus>
13    </row>
14    <row>
15      <LastName>Абрамов</LastName>
16      <FirstName>Александр</FirstName>
17      <BirthDate type="date">05.09.2016</BirthDate>
18     <AcademicStatus/>
19    </row>
20  </data>
Пример ответа в формате JSON:
01  {
02      "handle": "{C57F629E-583C-4477-ACBF-E436F6D01628}",
03      "eof": true,
04      "data": [
05          {
06              "LastName": "Абишин",
07              "FirstName": "Вячеслав",
08              "BirthDate": {
09                  "year": 2014,
10                  "month": 5,
11                  "day": 10
12              },
13              "AcademicStatus": "к.э.н."
14          },
15          {
16              "LastName": "Агринская",
17              "FirstName": "Ольга",
18              "BirthDate": {
19                  "year": 2016,
20                  "month": 7,
21                  "day": 24
22              },
23              "AcademicStatus": "PhD"
24          },
25          {
26              "LastName": "Абрамов",
27              "FirstName": "Александр",
28              "BirthDate": {
29                  "year": 2016,
30                  "month": 8,
31                  "day": 5
32              },
33              "AcademicStatus": null
34          }
35      ]
36  }
Значение eof = "1" означает, что данные получены полностью. Если в ответе такого значения (атрибута) нет, или eof = "0", это означает, что получены не все данные. Дополучить эти данные можно, повторно выполнив вызов функции cursor, передав в качестве значения параметра query полученное при первом вызове значение handle.
https://techmill.ru/demo/cursor.xml?query={FDF9EE70-9948-4A99-8233-349C3ADD3CE8}
В ответе на запрос с использованием handle вернется то же самое значение handle. Таким образом, запрос можно повторять с одним и тем же значением handle до тех пор, пока в ответе не будет получено eof = "1", что позволит убедиться в том, что данные получены полностью.

12.7. Функция excelreport

Функция excelreport позволяет вызывать на выполнение отчеты класса TExcelTemplate и получать файлы, формируемые как результат выполнения отчетов. Файлы могут быть возвращены как в форматах Excel (.xls,.xlsx), так и с преобразованием в другие форматы. Исключением являются интерактивные отчеты (требующие при формировании диалога с пользователем). Такие отчеты не могут вызваться при помощи данной функции.

Допустимые расширения:

.xls - для получения файла отчета в формате XLS

.xlsx - для получения файла отчета в формате XSLX

.html - для получения файла отчета в формате HTML; поддерживается формирование html-документа в монохромном цветовом режиме, в режиме "в градациях серого"

.pdf - для получения файла отчета в формате PDF; поддерживаются способы преобразования.xls/.xslx-файла в pdf-документ как средствами платформы, так и средствами самого Excel; возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"

.xps - для получения файла отчета в формате XPS

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, отчет которого будет вызываться

"template" (обязательный) - имя отчета, который будет вызываться

"format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:

цветовой режим - допустимые значения "mono", "grey"; значение по умолчанию - "обычный" цветовой режим

внедрение шрифтов (для формата PDF) - допустимые значения "embed", "embedded"; значение по умолчанию - без внедрения шрифтов

способ преобразования (для случая преобразования в формат PDF) - допустимое значение "native"; значение по умолчанию - средствами платформы "Мельница данных" в случае, если такой способ реализован; иначе - средствами приложения MS Office.

тип файла результата - допустимые значения совпадают с возможными расширениями вызова функции (без дополнительной точки)

"filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="StatisticReport.embed.pdf", что будет говорить о том, что будет возвращен pdf-документ с внедренными шрифтами.
Значение по умолчанию: "excelreport" с расширением, совпадающим с расширением вызываемой функции.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного атрибутами параметра query или расширением функции excelreport (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове Excel-отчета:
1  <execute class="TSchoolAbiturSt" template="RegStatistics" format="mono.embed.native.pdf" filename="StatisticReport.pdf">
2    <row>
3      <AdmissionYear>7427462</AdmissionYear>
4      <AdmStage>8608398</AdmStage>
5      <PrevAdmissionYear>6843737</PrevAdmissionYear>
6      <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
7    </row>
8  </execute>
При таком вызове будет выполнен Excel-отчет "RegStatistics" класса "TSchoolAbiturSt" с параметрами, переданными в элементе row. Данный отчет является "методом класса", поэтому параметр "ID" в состав параметров не добавлен. Полученный файл отчета будет преобразован в формат PDF с внедрением шрифтов в монохромном режиме. Преобразование будет выполнено средствами приложения MS Excel. В качестве ответа будет возвращен .pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("StatisticReport.pdf"), в содержимом ответа будет передано содержимое файла.

12.7.1. Принципы разбора информации о формате результирующего файла

Информация о формате файла, который будет сформирован и возвращен в качестве ответа, может быть извлечена из атрибутов xml-документа запроса, или из расширения функции. Порядок разбора переданной информации следующий:

Значение атрибута format. Если данный атрибут указан, но в нем нет одной из составляющих формата, то для этой составляющей будет использовано значение по умолчанию (значение из атрибута filename использовано не будет).

Значение атрибута filename. В этом атрибуте, кроме имени файла как такового и его расширения, может передаваться информация о цветовом режиме (.mono/.grey,...), внедрении шрифтов (.embed/.embedded), способе преобразования файла (.native). Значения для этих составляющих будут получены из атрибута filename только в случае, если атрибут format не указан при вызове.

Расширение будет получено из расширения вызываемой функции. Для других составляющих формата будут использованы значения по умолчанию.

Строка, определяющая формат, разбирается как последовательность элементов, разделенных символом "." (точка). Элементы разбираются последовательно, независимо друг от друга, и имеют следующие значения:

mono

Формируется монохромный документ

grey

Формируется документ в градациях серого

embedded

Шрифты внедряются в выходной документ

native

Используется встроенный в MSOffice механизм формирования документов

PDF

Выгружается файл в формате PDF

HTML

Выгружается файл в формате HTML

BMP

Выгружается файл в формате BMP

RTF

Выгружается файл в формате RTF

DOC

Выгружается файл в формате DOC

XLS

Выгружается файл в формате XLS

DOCX

Выгружается файл в формате DOCX

XLSX

Выгружается файл в формате XLSX

XPS

Выгружается файл в формате XPS

Остальные элементы игнорируются. Порядок следования элементов не важен.

Строка формата "pdf.mono.embedded" указывает сформировать монохромный документ в формате PDF со встроенными шрифтами.

12.8. Функция execute

Функция execute позволяет вызывать методы, доступные для вызова через обработчик сервера приложений, получать результат выполнения методов.

Допустимо использовать любые расширения, в том числе не указывать расширение. Расширение повлияет на формат возвращаемого результата следующим образом:

.xml - для получения результата выполнения в формате xml

.js/.json - для получения результата выполнения в формате JSON

пустое расширение - результат выполнения будет возвращен в формате xml

другие расширения - имеет смысл использовать в случаях, когда результатом выполнения метода является "большой объект" (blob, clob) и его тип известен; это позволит получить результат в виде файла или структуры данных определенного типа (.xslt,.pdf, форматы изображений и т.п.)
если результат выполнения не удастся привести к формату, заданному расширением, результат будет возвращен в формате xml

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый метод и значения его параметров. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, метод которого будет вызываться

"method" (обязательный) - имя метода, который будет вызываться

Корневой элемент xml-документа может содержать список узлов row, каждый из которых определяет набор параметров для вызова метода. Таким образом, при помощи одного вызова функции (одним обращением к url) можно вызывать один и тот же метод для набора объектов.

Принципы передачи параметров для вызова метода, включая использование параметров типа "большой объект", описаны в статье Принципы передачи параметров функциям RESTful-service.

Для вызова методов экземпляра необходимо указывать значение неявного параметра с именем "ID". Значением этого параметра должен быть идентификатор объекта, для которого вызывается метод.
01  <execute class="TPerson" method="GetContactList">
02    <row>
03      <ID>931669</ID>
04      <ContactType>63478</ContactType>
05    </row>
06    <row>
07      <ID>76443</ID>
08      <ContactType>63478</ContactType>
09    </row>
10  </execute>
Получить результат вызовов метода GetContactList класса TPerson для объектов с идентификаторами (ID), равными 931669 и 76443 и со значением параметра ContactType, равным 63478.

Пример ответа:
1  <data eof="1">
2    <row>
3      <Result>8-903-73-210-73</Result>
4    </row>
5    <row>
6      <Result>8-916-862-27-77; 8-916-862-2777</Result>
7    </row>
8  </data>
Если возвращаемый результат имеет домен класса "большой объект" (clob, clob, "внешний файл"), то возвращаемое значение может быто подвергнуто пост-обработке. Подробнее этот случай описан в разделе: Особенности передачи возвращаемых значений типа "большой объект"

12.8.1. Принципы передачи параметров функциям RESTful-service

При вызове функций RESTful-service стандартного обмена применяются следующие принципы передачи и связывания параметров:

Параметры связываются по их именам. Порядок указания параметров при вызове функции не существенен.

Если вызываемый метод или отчет является "методом класса", то дополнительно должен быть передан параметр "ID" со значением идентификатора объекта, для которого вызывается метод или отчет.

Если параметр имеет clob-домен подтипов "btHTML" (HTML-документ), "btXHTML" (XHTML-документ), то содержимое такого документа будет "обезврежено" (будут удалены ссылки, скрипты и т.п.)

Если вызываемый метод имеет параметр blob-домена, но при его вызове в xml-документе не найден узел с таким именем, то будет выполнен поиск параметра с тем же именем среди параметров сессии. Если такой параметр сессии будет найден, то его значение будет передано в качестве blob-значения одноименного параметра вызываемого метода. При этом в случае, если параметр имеет blob-домен подтипа "btNamedFile" (Именованный файл), то содержимое файла будет взято из одноименного параметра сессии (например, "param1"), а имя файла будет взято из параметра сессии с именем, дополненным постфиксом ".filename" (например, "param1.filename").

Если вызываемый метод имеет параметр blob-домена с подтипом "btImage" (Изображение), то для переданного значения будет предпринята попытка его преобразования в формат, заданный свойством "Расширение" домена.

В других случаях переданное или найденное в параметрах сессии blob/clob значение будет передано "как есть" в качестве значения параметра при вызове метода.

Если для параметра было использовано значение параметра сессии, то такой параметр удаляется из сессии после вызова функции (повторное использование параметра сессии невозможно).

12.8.2. Особенности передачи возвращаемых значений типа "большой объект"

Если функция сервиса имеет возвращаемое значение, имеющее домен типа blob, clob или "внешний файл", то такое значение может быть подвергнуто пост-обработке по следующим принципам:

Если задано расширение .js или .json, атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет clob-домен или домен "Внешние данные" подтипа "btJavaScript" (Скрипт JavaScript), то будет возвращено полученное из метода значение "как есть" (без каких-либо дополнительных преобразований)

Если задано расширение .xml, атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет clob-домен или домен "Внешние данные" подтипа "btXML" (XML-документ) или "btXHTML" (XHTML-документ), то будет возвращено полученное из метода значение "как есть" (без каких-либо дополнительных преобразований)

При использовании других расширений, если атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет blob-домен подтипа "btNamedFile" (Именованный файл), то в заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Если для атрибута "noanalyze" будет передано значение "1", и при этом возвращаемое значение имеет blob-домен и его размер окажется большим, то возвращаемое значение будет сохранено в параметре сессии, а в xml-ответе будет представлен только его идентификатор.

Во всех других случаях возвращаемое значение типа "большой объект" (blob) будет двоично закодировано и возвращено в разделе CDATA xml-документа.

12.9. Функция executeoleobjectmethod

Функция executeoleobjectmethod позволяет вызывать методы OLE-объекта, доступные для вызова через обработчик сервера приложений, получать результат выполнения методов. Исключением методы не могут вызваться при помощи данной функции.

Допустимо использовать любые расширения, в том числе не указывать расширение. Расширение повлияет на формат возвращаемого результата следующим образом:

.xml - для получения результата выполнения в формате xml

.js/.json - для получения результата выполнения в формате JSON

пустое расширение - результат выполнения будет возвращен в формате xml

другие расширения - имеет смысл использовать в случаях, когда результатом выполнения метода является "большой объект" (blob, clob) и его тип известен; это позволит получить результат в виде файла или структуры данных определенного типа (.xslt,.pdf, форматы изображений и т.п.)
если результат выполнения не удастся привести к формату, заданному расширением, результат будет возвращен в формате xml

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый метод и значения его параметров. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, метод которого будет вызываться

"method" (обязательный) - имя метода OLE-объекта, который будет вызываться

Корневой элемент xml-документа может содержать список узлов row, каждый из которых определяет набор параметров для вызова метода. Таким образом, при помощи одного вызова функции (одним обращением к url) можно вызывать один и тот же метод для набора объектов.

Принципы передачи параметров для вызова метода, включая использование параметров типа "большой объект", описаны в статье Принципы передачи параметров функциям RESTful-service.

Для вызова методов экземпляра необходимо указывать значение неявного параметра с именем "ID". Значением этого параметра должен быть идентификатор объекта, для которого вызывается метод.
1  <execute class="TBachAbiturSt" method="AddComposition">
2    <row>
3      <ID>7927267</ID>
4      <AdmissionYear>6617171</AdmissionYear>
5      <CompYear>5639232</CompYear>
6      <Theme>742348353</Theme>
7    </row>
8  </execute>
Получить результат вызовов метода AddComposition класса TBachAbiturSt для объекта с идентификаторами (ID), равными 7927267 и с параметрами, заданными в элементе row.

Если возвращаемый результат имеет домен класса "большой объект" (clob, clob, "внешний файл"), то возвращаемое значение может быто подвергнуто пост-обработке. Подробнее этот случай описан в разделе: Особенности передачи возвращаемых значений типа "большой объект"

12.10. Функция getblob

Функция getblob позволяет сторонним приложениям или веб-страницам формировать ссылки на содержимое, хранящееся как значение свойства объекта системы типа "большие данные" (изображения, файлы и т.п.).

При вызове функции допустимо указывать любые расширения. Расширение должно определяться содержимым, которое ожидается получить. В случае, если об этом нет достаточной информации, можно вызывать функцию с пустым расширением.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

class (обязательный) - имя класса, значение свойства которого нужно получить

propname (обязательный) - имя свойства, значение свойства которого нужно получить

id (обязательный) - идентификатор объекта, свойство которого нужно получить

filename - имя файла, которое будет использовано для полученного файла; если свойство имеет домен подтипа "Именованный файл", то имя файла будет получено из свойства, значение которого запрашивается, иначе будет использовано значение данного атрибута

disposition - если для данного атрибута будет указано значение "inline", то будет предпринята попытка открыть содержимое в браузере (на отдельной вкладке или встроить в страницу); если атрибут не указан, то будет выполняться скачивание файла; атрибут применим для изображений, PDF-документов

width, height - атрибуты применимы в случае, если функция вызывается с расширениями .jpg или .png, или если содержимое является изображением;
в случае, если данные атрибут указаны, будет произведена попытка сжать/растянуть изображение под указанные размеры ширины и высоты
1https://techmill.ru/demo/getblob?query=
2<query class="TPersonalDocument" propname="DocFile" ID="4562944" filename="DocumentCopy1.pdf"/>
Будет выполнена попытка получения файла PDF-документа и его скачивание.

12.11. Функция imagelist

Функция imagelist позволяет получить набор изображений, хранящихся в системе как значения свойства определенного класса, в компактном виде, удобном для их дальнейшего использования.

Допустимые расширения:

.png - для получения ответа в виде PNG-файла

.js / .json - для получения ответа в формате JSON

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

class (обязательный) - имя или идентификатор класса, значение свойства которого содержит изображения

proprty (обязательный) - имя свойства, значения свойства которого содержат изображения

width, height - ширина и высота в пикселях, к которой будут приведены отдельные изображения; если эти значения не указаны, используются значения по умолчанию 32х32

perrow - количество изображений в одной строке при компоновке изображений; если это значение не указано, используются значение по умолчанию 12

Элемент query может иметь дочерние узлы item, за счет которых можно передать условия отбора, которые будут наложены на записи класса. Если узлы item не будут добавлены, то изображения будут получены из всех записей класса (без условий отбора).
Узлы item должны иметь атрибут part со значением where, в остальном набор атрибутов и принципы формирования узлов item совпадают с принципами использования узлов item part="where"... в функции cursor (Функция cursor) для задания условий отбора запроса.

При вызове функции с расширением .png в качестве результата будет возвращено содержимое.png-файла с набором изображений.

При вызове функции с расширением .js или .json результат будет представлять собой JSON-объект с набором полей id: index, где id - идентификатор объекта класса, index - порядковый номер изображения в структуре изображений, после которых будут следовать поля

.filename: "запрос на получение.png-файла"

.width: "32"

.height: "32"

.perrow: "12"

Вызов функции с расширением.png:
techmill.ru/sup/imagelist.png?query=<query class='TAvatar' property='Image' width='32' height='32'/>
Вызов функции с расширением.js:
techmill.ru/sup/imagelist.js?query=<query class='TAvatar' property='Image' width='32' height='32'/>
Результат, возвращаемый при вызове с расширением.js:
01{
02"12008":0,
03"12009":1,
04"12010":2,
05"13917":3,
06"27570":4,
07"68807":5,
08"1786530":6,
09"6574243":7,
10"9376694":8,
11"9376695":9,
12"38740400":10,
13"39019504":11,
14"39019505":12,
15"118496347":13,
16".filename":"/sup/imagelist.png?query=%3Cquery%20class%3D%27TAvatar%27%20property%3D%27Image%27%20width%3D%2732%27%20height%3D%2732%27%20perrow%3D%2712%27/%3E",
17".width":32,
18".height":32,
19".perrow":12}
12.12. Функция loadexternaldata

Функция loadexternaldata позволяет получить файл из файлового хранилища по идентификатору файла в хранилище.

Допустимые расширения:

.xml

другие расширения, которые будут соответствовать типу и расширению запрашиваемого файла.

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент loadexternaldata с атрибутами

domain - имя или идентификатор домена "внешних данных"

value - идентификатор файла в файловом хранилище

Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.
1https://techmill.ru/demo/loadexternaldata.xml?query=
2<loadexternaldata domain="TPhotoFile" value="{D4A74981-336D-474B-9585-11716BA4232B}">
3</loadexternaldata>
В качестве результата выполнения функции будут возвращены двоичные данные запрошенного файла.

12.13. Функция partitions

Функция partitions позволяет получить информацию о количестве объектов, возвращаемых запросом с разбиением на группы определенного размера, по каждой группе получить минимальный и максимальный идентификатор объектов и количество объектов в группе.

Допустимое расширение: .xml.

Функция имеет параметр query, значением которого должен быть.xml-документ, содержащий информацию о запросе к данным, который должен быть выполнен, и о размере групп, на которые должен быть разделен результат. Структура xml-документа должна повторять структуру, используемую при вызове функции cursor (см. Функция cursor) со следующими отличиями:

Элемент query, в дополнение к обязательному атрибуту class, должен иметь еще один обязательный атрибут chunksize - размер группы (целое число - количество записей в группе).

Узлы item со значениями атрибута part, равными what, можно не добавлять, в запросе всегда будет использоваться только идентификатор объекта (свойство ID).

Узлы item со значениями атрибута part, равными order, group, having использоваться не должны. При выполнении запроса группировка применяться не будет, а сортировка всегда будет выполняться по идентификаторам объектов (свойство ID) по убыванию.

Результат, возвращаемый функцией, всегда будет возвращен полностью, независимого от переданного значения атрибута fetchall.

В качестве результата функция вернет XML-документ с элементом data с атрибутом eof="1", имеющий дочерние узлы row, соответствующие каждой полученной группе. Каждый узел row будет иметь следующий набор дочерних узлов:

min - минимальный ID в группе объектов;

max - максимальный ID в группе объектов;

count - количество объектов в группе; во всех узлах row, кроме последнего значение count будет равно значению атрибута chunksize, переданному в запросе.

Узлы row будут отсортированы по убыванию значений ID объектов.

Пример запроса:
1  https://techmill.ru/demo/partitions.xml?query=
2    <query class="TPerson" chunksize="1000">
3      <item part="0" name="ID"/>
4      <item part="1" name="TaxID" value="*"/>
5    </query>
Пример ответа:
01  <data eof="1">
02    <row>
03      <Min type="int64">76211</Min>
04      <Max type="int64">1158488</Max>
05      <Count type="int">1000</Count>
06    </row>
07    <row>
08      <Min type="int64">1158489</Min>
09      <Max type="int64">2112571</Max>
10      <Count type="int">1000</Count>
11    </row>
12    <row>
13      <Min type="int64">2112572</Min>
14      <Max type="int64">6605306</Max>
15      <Count type="int">1000</Count>
16    </row>
17    <row>
18      <Min type="int64">6605312</Min>
19      <Max type="int64">8424606</Max>
20      <Count type="int">1000</Count>
21    </row>
22    <row>
23      <Min type="int64">8424612</Min>
24      <Max type="int64">739895343</Max>
25      <Count type="int">1000</Count>
26    </row>
27    <row>
28      <Min type="int64">739895363</Min>
29      <Max type="int64">742336003</Max>
30      <Count type="int">121</Count>
31    </row>
32  </data>
12.14. Функция paste

Функция paste используется для вставки данных при выполнении операций Копировать/Вставить в приложении Обозреватель данных.

Функция имеет расширение .xml.

Значение параметра функции "query" должно представлять собой XML-документ с элементом paste, который должен включать в себя элемент root, представляющий собой стандартную XML-реплику со значениями свойств вставляемых объектов.

Элемент paste должен иметь атрибуты:

ClassID - идентификатор класса, объекты которого будут "вставлены"

ParentViewCurrentRecordID - идентификатор объекта, выбранного в "родительской" таблице данных в момент выполнения "вставки"

ParentClassID - идентификатор класса, отображаемого в "родительской" таблице данных в момент выполнения "вставки"

LinkMasterPropertyID, LinkDetailPropertyID - идентификаторы свойства-главного и свойства-подчиненного, по которым таблица данных, в которую выполняется вставка, связана с "родительской" таблицей данных

При удачном выполнении "вставки" функция вернет список идентификаторов добавленных объектов.
01https://techmill.ru/demo/paste.xml?query=
02  <paste ClassID="7291"
03       LinkDetailPropertyID="348"
04       LinkMasterPropertyID=""
05       ParentClassID="7291"
06       ParentViewCurrentRecordID="2559350">
07  <root Class="7291"
08        Connection="demo - techmill.ru/demo"
09        DBGUID="{C84A02C7-51EA-4068-A0BD-D6FB0BAD15F4}">
10    <object Class="7291" ID="1384201" IsMainObject="1" Parent="1384183">
11      <Description>сентябрь 2023/2024 учебный год</Description>
12      <LearnPeriodType IDREF="10849"/>
13      <BeginDate>2023-09-01</BeginDate>
14      <EndDate>2023-09-30</EndDate>
15      <PeriodNumber>9</PeriodNumber>
16      <LastMarkDate/>
17      <Name>сентябрь</Name>
18      <Creator IDREF="1276001"/>
19      <Created>2023-03-21 17:54:59</Created>
20      <Modifier IDREF="1276001"/>
21      <Modified>2023-05-06 00:00:42</Modified>
22      <Reader/>
23      <Writer IDREF="7001"/>
24    </object>
25    <object Class="7291" ID="1384203" IsMainObject="1" Parent="1384183">
26      <Description>октябрь 2023/2024 учебный год</Description>
27      <LearnPeriodType IDREF="10849"/>
28      <BeginDate>2023-10-01</BeginDate>
29      <EndDate>2023-10-31</EndDate>
30      <PeriodNumber>10</PeriodNumber>
31      <LastMarkDate/>
32      <Name>октябрь</Name>
33      <Creator IDREF="1276001"/>
34      <Created>2023-03-21 17:54:59</Created>
35      <Modifier IDREF="1276001"/>
36      <Modified>2023-05-06 00:00:42</Modified>
37      <Reader/>
38      <Writer IDREF="7001"/>
39    </object>
40  </root>
41</paste>
12.15. Функция pdfreport

Функция pdfreport позволяет вызывать на выполнение отчеты класса TPDFTemplate и получать файлы, формируемые как результат выполнения отчетов.

Допустимые расширения:

.pdf - возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, отчет которого будет вызываться

"template" (обязательный) - имя отчета, который будет вызываться

"format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:

цветовой режим - допустимые значения "mono", "grey"; значение по умолчанию - "обычный" цветовой режим

внедрение шрифтов (для формата PDF) - допустимые значения "embed", "embedded"; значение по умолчанию - без внедрения шрифтов

"filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="Consent.mono.embed.pdf", что будет говорить о том, что будет возвращен pdf-документ, сформированный в монохромном режиме с внедренными шрифтами; значение по умолчанию: "pdfreport.pdf".

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата PDF, сформированный в режиме, определенном атрибутами параметра query (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове PDF-отчета:
1  <execute class="TBachAbiturSt" template="ConsEnrollment" format="grey.embedded.pdf" filename="Consent.pdf">
2    <row>
3      <ID>7926329</ID>
4      <BachCompetition>4327519</BachCompetition>
5      <PlaceType>7927327</PlaceType>
6    </row>
7  </execute>
При таком вызове будет выполнен PDF-отчет "ConsEnrollment" класса "TBachAbiturSt" с параметрами, переданными в элементе row. Данный отчет является "методом объекта", поэтому дополнительно использован параметр "ID". Полученный файл отчета будет сформирован с внедрением шрифтов в цветовом режиме "в градациях серого". В качестве ответа будет возвращен.pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("Consent.pdf"), в содержимом ответа будет передано содержимое файла.

12.16. Функция postblob

Функция postblob позволяет установить значение поля таблицы, имеющее тип "большой объект". Функция может вызываться под пользователем, имеющим права доступа на запись к таблицам СУБД.

Функция имеет расширение .xml.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

id (обязательный) - идентификатор объекта, свойство которого нужно получить, или список идентификаторов объектов, разделенных ";" при передаче списка объектов для всех этих объектов будет установлено одинаковое значение поля

table (обязательный) - имя таблицы, содержащей поле, значение свойства которого нужно установить

field (обязательный) - имя поля таблицы, значение свойства которого нужно установить

subtype (обязательный) - порядковый номер элемента перечисления "TBlobSubtype" (Подтипы), определяющий подтип домена класса "большой объект", использованного для устанавливаемого значения

В качестве значения элемента query должно быть передано устанавливаемое значение в двоичном формате. При передаче этого значения функции могут быть выполнены преобразования, описанные в статье Принципы передачи параметров функциям RESTful-service.
1https://techmill.ru/demo/postblob.xml?query=
2    <query id="76328;5256545" table="TPersonPhoto" field="FPhotoFile" subtype="2">
3      <![CDATA[Q09NUFJFU1NFRAAABwAAADExMS5ibXBCTRYBAAAAAAAAPgAAACgAAAAiAAAAGwAAAAEAAQAAAAAA2AAAAMQOAADEDgAAAAAAAAAAAAAAAAAA////AP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/B/wf8AAAAD8H/B/wAAAAPwf8H/AAAAA/B/wf8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAA==]]>
4    </query>
12.17. Функция routinelog

Функция routinelog предназначена для создании записей истории вызова подпрограммы (метода, метода OLE-объекта, отчета) и набора значений параметров без вызова самой этой подпрограммы. Запись об истории вызова создается как объект класса "Вызовы" (TRoutineHistory) записи о значениях параметра создаются как объекты класса "Параметры вызовов" (TParameterHistory).

Допустимое расширение: .xml.

Функция имеет параметр query, который должен представлять собой XML документ, содержащий информацию о подпрограмме и значениях ее параметров. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент XML-документа должен иметь атрибут routine, значением которого должен быть идентификатор подпрограммы. Элемент должен иметь набор узлов, соответствующих параметрам подпрограммы и их значениям.

При передаче информации о параметрах необходимо учитывать Принципы передачи параметров функциям RESTful-service.
1https://techmill.ru/demo/routinelog.xml?query=
2<query routine="756584">
3  <AdmissionYear>7427462</AdmissionYear>
4  <AdmStage>8608398</AdmStage>
5  <PrevAdmissionYear>6843737</PrevAdmissionYear>
6  <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
7</query>
При успешном выполнении функции будет возвращен ответ с одним пустым элементом <data eof="1"/>.

12.18. Функция rtti

Функция rtti позволяет получить информацию о типах (run-time type information, RTTI) в форматах XML или JSON.

Допустимые расширения:

.xml - для получения ответа в формате XML

.js/.json - для получения ответа в формате JSON

Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/rtti.xml
В качестве ответа будет возвращен XML-документ или JSON полученный рядом запросов к метаданных системы. Ответ будет состоять из элементов data, соответствующих каждому запросу, которые имеют узлы row на каждую запись возвращаемых данных. Для каждой записи будут узлы с именами, совпадающими со значениями свойств и значениями этих свойств.

Пример ответа:
01<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
02  ...
03</data>
04<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
05  <row>
06    <ID>1669</ID>
07    <Name>TFolder domain</Name>
08    <Description>Папка</Description>
09    <Required type="int">1</Required>
10    <Length type="int">255</Length>
11    <FolderMustExist type="int">1</FolderMustExist>
12  </row>
13</data>
14<data eof="1" handle="{06399069-7150-4087-8ACB-D14C809497C2}">
15  <row>
16    <ID>28</ID>
17    <Name>Boolean</Name>
18    <Description>Обычное логическое</Description>
19    <Required type="int">1</Required>
20    <TrueValue>Да</TrueValue>
21    <FalseValue>Нет</FalseValue>
22  </row>
23  <row>
24    <ID>170</ID>
25    <Name>Non-required boolean</Name>
26    <Description>Необязательное логическое</Description>
27    <Required type="int">0</Required>
28    <TrueValue>Да</TrueValue>
29    <FalseValue>Нет</FalseValue>
30  </row>
31  <row>
32    <ID>662765452</ID>
33    <Name>TProfileConditionAccess</Name>
34    <Description>Условия доступа профиля</Description>
35    <Required type="int">1</Required>
36    <TrueValue>Контролировать чтение и запись</TrueValue>
37    <FalseValue>Контролировать только запись</FalseValue>
38  </row>
39</data>
40<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
41  ...
42</data>
43<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
44  ...
45</data>
12.19. Функция selectblob

Функция selectblob позволяет получить значение свойства объекта имеющий тип "большие данные" (файл, изображение, и т.п.), а также позволяет сравнивать значения типа "большие данные" без получения самих этих данных.

При вызове функции допустимо указывать любые расширения. Расширение должно определяться содержимым, которое ожидается получить. В случае, если об этом нет достаточной информации, можно вызывать функцию с пустым расширением.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

class (обязательный) - имя класса, значение свойства которого нужно получить (или сравнить)

propname (обязательный) - имя свойства, значение свойства которого нужно получить (или сравнить)

id (обязательный) - в качестве значения этого параметрам может быть передано:

идентификатор объекта, значение свойства которого нужно получить

список идентификаторов объектов, разделенных ";"

идентификатор буфера, содержащего список объектов (подробнее о создании и наполнении буфера: Функция selectedbuffer, Функция selectionchanged)

Функция вернет следующий результат:

если в атрибуте ID был передан один объект или если содержимое (значение свойства) для всех переданных объектов одинаково, то вернется это одно значение

в других случаях вернется значение NULL

Таким образом, можно выполнять сравнение значений типа "большой объект" - если получено отличное от NULL значение, значит значения равны, иначе значения не равны. Получения самих значений во втором случае не происходит.
1https://techmill.ru/demo/selectblob?query=
2<query class="TPersonalDocument" propname="DocFile" ID="4562944;398621"/>
12.20. Функция selectedbuffer

Функция selectedbuffer возвращает новый идентификатор буфера, в который далее можно добавлять объекты, что позволит выполнять различные операции с созданным таким образом набором объектов как с единым целым.
Для манипуляций списком объектов в буфере предназначена Функция selectionchanged.

Допустимое расширение: .xml

Функция возвращает XML-документ в узле которого с именем ID возвращается идентификатор созданного буфера.

Пример запроса:
  https://techmill.ru/demo/selectedbuffer.xml
Пример ответа:
1  <data eof="1">
2    <row>
3      <ID>1186174</ID>
4    </row>
5  </data>
12.21. Функция selectionchanged

Функция selectionchanged позволяет манипулировать списком объектов буфера. Для создания нового буфера предназначена функция Функция selectedbuffer.

Допустимое расширение: .xml

В значении параметра с именем "query" необходимо передать xml-документ, содержащий данные о существующем буфере и действиях, которые должны быть с ним проведены. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML-документ query должен иметь один элемент selectionchanged со следующим набором атрибутов:

handle (обязательный) - идентификатор буфера

ID - список идентификаторов объектов с разделителем ";", которые будут добавлены в буфер или исключены из него; значение может быть пустым только в случае, если выполняется полная очистка буфера, что предается значением атрибута cleanup

selected (обязательный) - указание о том, какое действие должно быть выполнено с переданным списком объектов; допустимые значения:

"0" - удалить объекты из буфера

"1" - добавить объекты в буфер

cleanup - указание о том, что нужно сделать перед добавлением или удалением объектов; допустимые значения:

"0" (значение по умолчанию) - не выполнять предварительных действий

"1" - очистить буфер перед выполнением действия

При успешном выполнении функция вернет XML-документ с одним элементом data и атрибутом eof="1".
1  https://techmill.ru/demo/selectionchanged.xml?query=
2    <selectionchanged handle="221024" ID="227222;76923;77312" selected="1" cleanup="1"/>
В буфер с идентификатором 1186175 будут добавлены объекты с идентификаторами 77222;76923;77312; перед добавлением буфер будет очищен.

12.22. Функция sessionlogoff

Функция sessionlogoff позволяет удалить текущую сессию.

Допустимое расширение: .xml. Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/sessionlogoff.xml
Пример ответа:
  <data eof="1"/>
12.23. Функция setpropvalue

Функция setpropvalue позволяет изменять значения свойств объектов, доступные для изменения через обработчик сервера приложений.

Допустимое расширение: .xml.

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент setpropvalue с атрибутами, позволяющими идентифицировать объект и принадлежащее ему свойство, значение которого требуется изменить. Значение, которое должно быть установлено для свойства, передается как текст элемента setpropvalue Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Атрибуты элемента setpropvalue:

ID (обязательный) - идентификатор объекта, свойство которого должно быть изменено

class (обязательный, если не указан атрибут "propid") - имя класса, свойство которого должно быть изменено

propname (обязательный, если не указан атрибут "propid") - имя свойства, принадлежащего классу, переданному значением атрибута "class", значение которого должно быть изменено

propid (обязательный, если не указаны атрибуты "class" и "propname") - идентификатор свойства, значение которого должно быть изменено

noanalyze

Для передачи информации о свойстве, значение которого должно быть изменено, можно использовать атрибут "propid" или пару атрибутов "class" и "propname".
1  <setpropvalue ID="4912468" class="TPerson" propname="MiddleName">
2    "Алексеевич"
3  </setpropvalue>
Установить значение "Алексеевич" для свойства класса "TPerson" с именем "MiddleName" для объекта с идентификатором "4912468".

При успешном выполнении функция возвращает xml-документ с пустым набором данных:
<data eof="1"/>
При неуспешном выполнении функция возвращает xml-документ с текстом сообщения об ошибке, например:
1<error>
2  <message>Property not found.</message>
3  <className>Exception</className>
4</error>
12.24. Функция storeexternaldata

Функция storeexternaldata позволяет выполнить сохранение файла как "внешних данных" определенного домена. Файл данных будет записан в файловое хранилище, в виде, определяемом доменом.

Допустимое расширение: .xml

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент storeexternaldata с атрибутом domain, значением которого должно быть имя или идентификатор домена класса "Внешние данные". Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Запрос:
1  https://techmill.ru/demo/storeexternaldata.xml?query=
2    <storeexternaldata domain="TPhotoFile">
3      <![CDATA[Q09NUFJFU1NFRAAABwAAADExMS5ibXBCTRYBAAAAAAAAPgAAACgAAAAiAAAAGwAAAAEAAQAAAAAA2AAAAMQOAADEDgAAAAAAAAAAAAAAAAAA////AP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/B/wf8AAAAD8H/B/wAAAAPwf8H/AAAAA/B/wf8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAA==]]>
4    </storeexternaldata>
Ответ:
1  <data eof="1">
2    <row>
3      <Result>{1B8C156B-76F6-4EC1-987D-F6C0000DB343}</Result>
4    </row>
5  </data>
12.25. Функция sysinfo

Функция sysinfo позволяет получить информацию о системе в формате XML с набором атрибутов, соответствующих характеристикам системы.

Допустимое расширение: .xml. Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/sysinfo.xml
Пример ответа:
  <sysinfo major="3" minor="2" release="2" build="304" PerformExcelReports="0" PerformOleObjectMethods="0" PerformPDFReports="0" PerformWordReports="0" PerformXSLTReports="0" GroupMethods="0"/>
12.26. Функция timebias

Допустимое расширение - .xml

Используется JavaScript-клиентом и "Обозревателем данных".

Параметр query содержит текст xml-документа, в котором в атрибутах корневого узла разложены компоненты текущей даты и текущего времени клиента:
<timebias Y="2024" M="03" D="22" H="12" Mi="30" S="00" Ms="100"/>
Имя корневого элемента не имеет значения. АтрибутY содержит год, M - месяц (нумеруются с 1, январь - "1", декабрь - "12"), D - число внутри месяца, H - часы, Mi - минуты, S - секунды, Ms - миллисекунды.

Ответ представляет собой xml-документ следующей структуры:
1  <data eof="1">
2    <row>
3      <Bias type="dbl">
4        0,19860191
5      </Bias>
6    </row>
7  </data>
здесь числовое значение в элементе Bias содержит количество суток (в данном примере - 0 целых, 1 десятая, 9 сотых, 8 тысячных и так далее), которые нужно прибавлять к датам, полученным с сервера приложений, чтобы получить даты в часовом поясе клиента. Атрибут type, атрибут eof (оба - вместе со значениями), и имена всех элементов ответа являются неизменными, и передаются для унификации процедуры разбора ответа.

12.27. Функция wordreport

Функция wordreport позволяет вызывать на выполнение отчеты класса TWordTemplate и получать файлы, формируемые как результат выполнения отчетов. Файлы могут быть возвращены как в форматах Word (.doc,.docx), так и с преобразованием в другие форматы. Исключением являются интерактивные отчеты (требующие при формировании диалога с пользователем). Такие отчеты не могут вызваться при помощи данной функции.

Допустимые расширения:

.doc - для получения файла отчета в формате DOC

.docx - для получения файла отчета в формате DOCX

.html - для получения файла отчета в формате HTML; формирование html-документа выполняется средствами MS Word;

.rtf - для получения файла отчета в формате RTF

.pdf - для получения файла отчета в формате PDF; преобразование.doc/.docx-файла в pdf-документ выполняется средствами самого Word; возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, отчет которого будет вызываться

"template" (обязательный) - имя отчета, который будет вызываться

"format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:

тип файла результата - допустимые значения совпадают с возможными расширениями вызова функции (без дополнительной точки)

"filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="ListenerCard.pdf", что будет говорить о том, что будет возвращен pdf-документ.
Значение по умолчанию: "wordreport" с расширением, совпадающим с расширением вызываемой функции.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного атрибутами параметра query или расширением функции wordreport (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове Word-отчета:
1  <execute class="TDPOStatus" template="ListenerCard" format="grey.embed.pdf" filename="ListenerCard.pdf">
2    <row>
3      <ID>5201838</ID>
4      <DPOInstitute>4327519</DPOInstitute>
5      <SecondSigner>4469840</SecondSigner>
6    </row>
7  </execute>
При таком вызове будет выполнен Word-отчет "ListenerCard" класса "TDPOStatus" с параметрами, переданными в элементе row. Данный отчет является "методом объекта", поэтому дополнительно использован параметр "ID". Полученный файл отчета будет преобразован в формат PDF с внедрением шрифтов в цветовом режиме "в градациях серого". Преобразование будет выполнено средствами приложения MS Word. В качестве ответа будет возвращен.pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("ListenerCard.pdf"), в содержимом ответа будет передано содержимое файла.

12.28. Функция xsltreport

Функция xsltreport позволяет вызывать на выполнение отчеты класса TXSLTTemplate и получать файлы, формируемые как результат выполнения отчетов.

Допустимые расширения:

.xml

.html

.txt

без расширения

Для данного вида отчета тип и расширение возвращаемого файла будут определены самим XSLT-отчетом (будут заданы в элементе "xsl:output" в шаблоне отчета). Вызов функции с тем или иным расширением не повлияет на тип и расширение файла-результата.

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, отчет которого будет вызываться

"template" (обязательный) - имя отчета, который будет вызываться

"filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition.
Значение по умолчанию: имя вызываемого отчета с расширением, которое будет определено самим отчетом.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного самим отчетом. В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове XSLT-отчета:
1  <execute class="TObject" template="SelectDataToText" filename="QueryResult.txt">
2    <row>
3      <ClassName>TCountry</ClassName>
4      <Query></Query>
5    </row>
6  </execute>
При таком вызове будет выполнен XSLT-отчет "SelectDataToText" класса "TObject" с параметрами, переданными в элементе row. Данный отчет является "методом класса", поэтому параметр "ID" в состав параметров не добавлен. В качестве ответа будет возвращен текстовый файл. В заголовке ответа в поле Content-Disposition будет передано имя файла ("QueryResult.txt"), в содержимом ответа будет передано содержимое файла.


Мельница данных ((раздел целиком))

Мельница данных- Класс TOptionValue (Значения настроек) (раздел целиком) (22.10.2024) (одним файлом)
Класс TOptionValue (Значения настроек)

Класс TTypedValue (Типизированные значения)Класс TObject (Объекты)Класс TOption (Настройки)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TOptionValue:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Нет | Скрыто от пользователя | Только для чтения | Унаследовано от TTypedValue
MasterClass | TClass | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TTypedValue
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
StrValue | string[2000] | Нет | Скрыто от пользователя | Чтение/Запись
IntValue | Integer | Нет | Скрыто от пользователя | Чтение/Запись
FloatValue | float | Нет | Скрыто от пользователя | Чтение/Запись
DateValue | date | Нет | Скрыто от пользователя | Чтение/Запись
TimeValue | time | Нет | Скрыто от пользователя | Чтение/Запись
DateTimeValue | datetime | Нет | Скрыто от пользователя | Чтение/Запись
ObjectValue | TObject | Нет | Скрыто от пользователя | Чтение/Запись
BoolValue | Boolean | Нет | Скрыто от пользователя | Чтение/Запись
BlobValue | blob | Нет | Видимо пользователю | Чтение/Запись
ClobValue | clob | Нет | Видимо пользователю | Чтение/Запись
ExternalDataValue | <external data> | Нет | Видимо пользователю | Чтение/Запись
VisibleValue | string[2000] | Нет | Видимо пользователю | Только для чтения
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись
User | TUser | Нет | Видимо пользователю | Чтение/Запись | Пользователь
IsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Является текущим
Option | TOption | Да | Скрыто от пользователя | Только для чтения | Настройка
Domain | TDomain | Да | Видимо пользователю | Только для чтения | Домен
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TTypedValue
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
Global | Boolean | Да | Видимо пользователю | Только для чтения | Глобальная

2. Конструктор Create (Конструктор значения настройки)

Конструктор класса TOptionValue.

1constructor TOptionValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;

Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
Position | Integer | Да | Позиция
Group | string[128] | Нет | Группа
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
StrValue | string[2000] | Нет | Унаследовано от TTypedValue.Create
IntValue | Integer | Нет
FloatValue | float | Нет
DateValue | date | Нет
TimeValue | time | Нет
DateTimeValue | datetime | Нет
ObjectValue | TObject | Нет
BoolValue | Boolean | Нет
BlobValue | blob | Нет
ClobValue | clob | Нет
ExternalDataValue | <external data> | Нет
User | TUser | Нет | Пользователь

Замечания:

Создает новый объект класса TOptionValue.


Мельница данных ((раздел целиком))

Мельница данных- Класс TExternalDataResource (Ресурсы внешних данных) (раздел целиком) (22.10.2024) (одним файлом)
Класс TExternalDataResource (Ресурсы внешних данных)

Диаграмма Класс TObject (Объекты)Класс TExternalDataDomain (Внешние данные)

1. Свойства

Свойства класса TExternalDataResource:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
GUID | string[38] | Да | Видимо пользователю | Чтение/Запись | GUID
Protocol | TExternalDataProtocol | Да | Видимо пользователю | Чтение/Запись | Протокол доступа
Host | string[64] | Да | Видимо пользователю | Чтение/Запись | Хост
Port | Integer | Нет | Видимо пользователю | Чтение/Запись | Порт
Path | string[255] | Да | Видимо пользователю | Чтение/Запись | Папка
UserName | string[255] | Нет | Видимо пользователю | Чтение/Запись | Имя пользователя
Password | string[255] | Нет | Видимо пользователю | Чтение/Запись | Пароль
ReadOnly | Boolean | Да | Видимо пользователю | Чтение/Запись | Только для чтения

2. Конструктор Create (Конструктор ресурса внешних данных)

Конструктор класса TExternalDataResource.

1constructor TExternalDataResource.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; GUID: string[38]; Protocol: TExternalDataProtocol;
4  Host: string[64]; Port: Integer; Path: string[255]; UserName: string[255];
5  Password: string[255]; ReadOnly: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
GUID | string[38] | Да | GUID
Protocol | TExternalDataProtocol | Да | Протокол доступа
Host | string[64] | Да | Хост
Port | Integer | Нет | Порт
Path | string[255] | Да | Папка
UserName | string[255] | Нет | Имя пользователя
Password | string[255] | Нет | Пароль
ReadOnly | Boolean | Да | Только для чтения

Замечания:

Создает новый объект класса TExternalDataResource.

3. Метод FileNameClause (Кляуза имени поля)

Метод экземпляра класса TExternalDataResource.

function TExternalDataResource.FileNameClause(FieldName: string[64]): string[2000];

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
FieldName | string[64] | Да | Имя поля

Замечания:

Возвращает значение типа string[2000].

4. Метод FindUsedName (Найти использованное имя)

Метод экземпляра класса TExternalDataResource.

function TExternalDataResource.FindUsedName(Name: string[77]): clob;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[77] | Да | Имя

Замечания:

Возвращает значение типа clob.

5. Метод GetUsedFileNames (Получить список использованных имен)

Метод экземпляра класса TExternalDataResource.

function TExternalDataResource.GetUsedFileNames: clob;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

6. Метод Ole-объекта CheckExternalData (Проверить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя | Тип | Обязательно | Значение
FilesFolder | string[255] | Да | Файлы внешних данных
TrashFolder | string[255] | Да | Папка для неиспользуемых файлов

7. Метод Ole-объекта SaveExternalData (Сохранить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка для сохранения


Мельница данных ((раздел целиком))

Мельница данных- Класс TVisualGroupAccess (Доступ к визуальным группам) (раздел целиком) (22.10.2024) (одним файлом)
Класс TVisualGroupAccess (Доступ к визуальным группам)

Класс TAccessItem (Элементы доступа)Класс TObject (Объекты)Класс TVisualGroup (Визуальные группы)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Конструктор Create (Конструктор доступа к визуальной группе)

Конструктор класса TVisualGroupAccess.

1constructor TVisualGroupAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TVisualGroup;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TVisualGroup | Да | Группа доступа
Accessor | TSecurityAccount | Нет | Унаследовано от TObject.Create
SecurityAccount | TSecurityAccount | Да | Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TVisualGroupAccess.


Мельница данных ((раздел целиком))

Мельница данных- Класс TFormOption (Настройки формы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TFormOption (Настройки формы)

Класс TObject (Объекты)Класс TForm (Формы)

Имена объектов класса генерируются.

1. Свойства

Свойства класса TFormOption:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Option | TOption | Да | Видимо пользователю | Чтение/Запись | Настройка
Position | Integer | Нет | Видимо пользователю | Чтение/Запись | Позиция
ShowEmptyValue | Boolean | Да | Видимо пользователю | Чтение/Запись | Показывать пустое значение

2. Конструктор Create (Конструктор настройки формы)

Конструктор класса TFormOption.

1constructor TFormOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Option: TOption; Position: Integer; ShowEmptyValue: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Option | TOption | Да | Настройка
Position | Integer | Нет | Позиция
ShowEmptyValue | Boolean | Да | Показывать пустое значение

Замечания:

Создает новый объект класса TFormOption.

3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormOption.

class function TFormOption.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Да | Мастер

Замечания:

Возвращает значение типа Integer.


Мельница данных ((раздел целиком))

Мельница данных- Класс TObjectHistory (История объектов) (раздел целиком) (22.10.2024) (одним файлом)
Класс TObjectHistory (История объектов)

Диаграмма

1. Свойства

Свойства класса TObjectHistory:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Только для чтения | Имя
Description | string[128] | Да | Видимо пользователю | Только для чтения | Наименование
Class | TClass | Да | Видимо пользователю | Только для чтения | Класс
Master | string[2000] | Нет | Видимо пользователю | Только для чтения | Мастер
Parent | string[2000] | Нет | Видимо пользователю | Только для чтения | Родитель
Data | string[2000] | Нет | Видимо пользователю | Только для чтения | Содержимое
Action | TChangeAction | Да | Видимо пользователю | Только для чтения | Действие
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
Login | string[64] | Да | Видимо пользователю | Только для чтения | Логин
ObjectOldID | string[38] | Да | Видимо пользователю | Только для чтения | Идентификатор при создании
ObjectDataBase | TDataBase | Да | Видимо пользователю | Только для чтения | База данных объекта
ObjectID | string[38] | Да | Видимо пользователю | Только для чтения | Идентификатор объекта
IntStamp | Integer | Нет | Видимо пользователю | Только для чтения | Целочисленный номер
Session | TSessionHistory | Нет | Скрыто от пользователя | Только для чтения | Сессия
SessionTimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время начала сессии
SessionCloseStamp | datetime | Нет | Видимо пользователю | Только для чтения | Время завершения сессии
FieldName | string[64] | Да | Видимо пользователю | Только для чтения | Поле
UserAgent | string[2000] | Нет | Видимо пользователю | Только для чтения | Пользовательский агент
IPAddress | string[16] | Нет | Видимо пользователю | Только для чтения | IP-адрес
ConnectionInfo | string[2000] | Нет | Видимо пользователю | Только для чтения | Информация о соединении

2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TObjectHistory.

1class procedure TObjectHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По

3. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TObjectHistory.

1class procedure TObjectHistory.Log(Object: TObject; Action: TChangeAction;
2  Field: TField; Data: string[2000]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Нет | Объект
Action | TChangeAction | Да | Действие
Field | TField | Нет | Поле
Data | string[2000] | Нет | Содержимое

4. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObjectHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
FileName | string[255] | Да | Имя файла
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По

5. Шаблон отчета Excel UserActivityReport (Отчет об активности пользователей)

Шаблон отчета Excel класса (статический шаблон) класса TObjectHistory.

Шаблон отчета Excel является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
UDate | date | Нет | Дата


Мельница данных ((раздел целиком))

Мельница данных- Класс TTimeDomain (Время) (раздел целиком) (22.10.2024) (одним файлом)
Класс TTimeDomain (Время)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

1. Свойства

Свойства класса TTimeDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
HideSeconds | Boolean | Да | Видимо пользователю | Чтение/Запись | Не показывать секунды

2. Конструктор Create (Конструктор домена времени)

Конструктор класса TTimeDomain.

1constructor TTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
HideSeconds | Boolean | Да | Не показывать секунды

Замечания:

Создает новый объект класса TTimeDomain.

3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TTimeDomain.

function TTimeDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Класс TRoutineHistory (Вызовы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TRoutineHistory (Вызовы)

Диаграмма Класс TParameterHistory (Параметры вызовов)

1. Свойства

Свойства класса TRoutineHistory:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Session | TSessionHistory | Нет | Скрыто от пользователя | Только для чтения | Сессия
SessionTimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время начала сессии
SessionCloseStamp | datetime | Нет | Видимо пользователю | Только для чтения | Время завершения сессии
IntStamp | Integer | Нет | Видимо пользователю | Только для чтения | Целочисленный номер
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время
ObjectID | string[38] | Нет | Видимо пользователю | Только для чтения | Идентификатор объекта
ObjectQualifiedName | string[2000] | Нет | Видимо пользователю | Только для чтения | Квалифицированное имя объекта
ObjectDataBase | TDataBase | Нет | Видимо пользователю | Только для чтения | База данных объекта
ObjectOldID | string[38] | Нет | Видимо пользователю | Только для чтения | Идентификатор при создании
RoutineName | string[64] | Да | Видимо пользователю | Только для чтения | Подпрограмма
RoutineClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс подпрограммы
RoutineClassName | string[64] | Да | Видимо пользователю | Только для чтения | Имя класса подпрограммы
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
Login | string[64] | Да | Видимо пользователю | Только для чтения | Логин
UserAgent | string[2000] | Нет | Видимо пользователю | Только для чтения | Пользовательский агент
IPAddress | string[16] | Нет | Видимо пользователю | Только для чтения | IP-адрес
ConnectionInfo | string[2000] | Нет | Видимо пользователю | Только для чтения | Информация о соединении

2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TRoutineHistory.

1class procedure TRoutineHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По

3. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TRoutineHistory.

1class function TRoutineHistory.Log(Routine: TRoutine;
2  Object: TObject): TRoutineHistory;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Routine | TRoutine | Да | Подпрограмма
Object | TObject | Нет | Объект

Замечания:

Возвращает значение типа TRoutineHistory.

4. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TRoutineHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
FileName | string[255] | Да | Имя файла
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Мельница данных ((раздел целиком))

Мельница данных- Соглашения (раздел целиком) (22.10.2024) (одним файлом)
Соглашения

1. Соглашения о наименованиях

В качестве вводимых (объявляемых) идентификаторов необходимо использовать так называемую нотацию InfixCaps. Если при создании имени используется несколько слов, то необходимо использовать заглавную букву для каждого слова в имени. Для разделения слов нельзя использовать символ подчеркивания. Все сущности именуются на английском языке, при этом использование сокращений является оправданным только в случае, если длина образуемого имени не согласуется с внешними по отношению к соображениям бизнес-логики ограничениям.

  • Имя класса должно начинаться с латинской буквы 'T'.
    Имя | Наименование
    TObjectList | Список объектов
    TLearnPlan | Учебный план
  • Имя поля должно начинаться с латинской буквы 'F'.
    Имя | Наименование
    FLearnPeriod | Период обучения
    FExamMark | Оценка за экзамен
  • Имя свойства не имеет префикса.
    Имя | Наименование
    ExamKind | Вид рубежного испытания
    ContactPhone | Контактный телефон
    Если членом класса для чтения свойства является поля, то имя свойства должно повторять имя поля без префикса 'F'. Если членом класса для чтения свойства является метод, то имя поля должно повторять имя метода без слова 'Get'.
  • Имя параметра не имеет префикса.
    Имя | Наименование
    OrderNumber | Номер приказа
    ExamDate | Дата проведения экзамена
    Параметры, используемые для инициализации значений полей, должны иметь имя, повторяющее имя поля без префикса 'F'. При компиляции тела метода, написанного на языке PascalScript имена параметров и имена свойств будут распознаваться в соответствии с порядком разбора идентификаторов, как это описано здесь и здесь.
  • Имена методов должны представлять собой императивный глагол на английском языке, выражающий смысл того, что метод делает. Имена методов не имеют префикса. Имена методов, используемых для получения значений свойств должны (как члены класса для чтения), должны начинаться со слова Get. Имена методов, используемых для установки значений свойств должны (как члены класса для записи), должны начинаться со слова Set.
    Имя | Наименование
    CountMarkSumm | Вычислить сумму баллов
    GetAge | Получить значение возраста
    SetMark | Установить значение оценки
  • Имена локальных переменных должны начинаться с латинской буквы 'L'.
    LMarkSumm (сумма баллов), LObjectCount (количество объектов).
  • Имена доменов должны начинаться с латинской буквы 'T'. В именах доменов допустимы пробелы. Рекомендуется к имени домена добавлять слово 'domain' (через пробел), а для обязательных доменов 'required domain' (через пробел) тогда, когда необходимо исключить возможность использования этих доменов в текстах на PascalScript. Первым словом в имени домена-ссылки должно быть имя класса домена. Исключением являются имена доменов, соответствующих простым типам данных без дополнительных ограничений. Имена таких доменов могут повторять имена типов языка PascalScript (Integer, Boolean, Float).
    Имя | Класс домена | Наименование
    TPrice domain | Вещественный | домен Цена
    TWeight required domain | Целочисленный | домен Вес (обязательный)
    Boolean | Логический | Логический
    TClassMember required domain | Ссылка | домен Член класса
  • Имена элементов перечислений должны иметь префикс из двух или трех символов, идентифицирующий соответствующий домен-перечисление. Префикс записывается строчными буквами. Например,
    Имя | Наименование
    для домена TExamKind (вид испытания)
    ekTest | зачет
    ekExam | экзамен
    ekDifTest | дифференцированный зачет
    для домена TAggregateKind (вид агрегата)
    agCount | количество
    agSumm | сумма
    agAverage | среднее значение
    Настоятельно рекомендуется давать уникальные имена элементов перечислений в пределах всей системы.

2. Стилевое оформление исходного кода

Код на языке PascalScript, являющийся частью поставляемого решения, должен быть оформлен в соответствии с изложенными правилами.

2.1. Использование строк, пробелов и отступов

Пустые строки могут повысить читабельность путем группирования секций кода, которые логически связаны между собой.

Пробелы, запрещенные к использованию:

  • До или после точки "."
  • Между именем вызываемого метода и открывающей скобкой "("
  • После открывающей скобки "(" или перед закрывающей ")"
  • Перед точкой с запятой ";"
  • Перед двоеточием ":"
  • Перед запятой ","

Двоеточие для всех объявлений переменных не должно содержать перед собой пробелов и иметь один пробел после перед именем типа.

Всегда необходимо использовать два пробела для всех уровней отступа. Другими словами, первый уровень отступает на два пробела, второй на четыре и так далее. Никогда не используйте символы табуляции.

Существует несколько исключений из этого правила. Зарезервированные слова var, begin и end, относящиеся к программному блоку вцелом, всегда должны примыкать к левой границе. Код внутри блока begin..end должен иметь отступ два символа.

Все строки должны быть ограничены 80 столбцами. Строки, длиннее чем 80 столбцов должны быть разделены и перенесены. Все перенесенные строки должны быть выровнены по первой строке и иметь отступ в два символа. Зарезервированное слово begin всегда должно находиться на своей отдельной строке.

Нельзя переносить строки в тех местах, где не допускаются пробелы, например между именем метода и открывающей скобкой. Никогда нельзя помещать зарезервированное слово begin на строку, содержащую другой код.

2.2. Оформление объявлений и операторов

Все переменные с их типами должны быть объявлены на различных строках.

Простые операторы содержат одну точку с запятой. Если Вам необходимо разделить оператор, то перенесите продолжение оператора на следующую строку с отступом в два пробела.
  MyValue :=
    MyValue + (SomeVeryLongStatement / OtherLongStatement);

Составные операторы всегда заканчиваются точкой с запятой.
1begin
2  MyStatement;
3  MyNext Statement;
4  MyLastStatement;
end;

Каждое присвоение и каждое выражение должно располагаться на разных строках.

Оператор "if"

Оператор if всегда должен располагаться по крайней мере на двух строках
if A < B then DoSomething;
if A < B then
  DoSomething;
В случае составного оператора необходимо поместить каждый оператор на новую строку.
1  if A < B then begin
2    DoSomething;
3    DoSomethingElse;
4  end else begin
5    DoThis;
6    DoThat;
7  end;

1  if A < B then
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end
6  else
7  begin
8    DoThis;
9    DoThat;
  end;
Все остальные варианты расположения операторов не рекомендуются и не одобряются, хотя и являются синтаксически правильными.

Оператор "for"

1  for i := 0 to 10 do begin
2    DoSomething;
3    DoSomethingElse;
4  end;

1  for i := 0 to 10 do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  for I := 0 to 10 do
8    DoSomething;

Оператор "while"

1  while x < j  do begin
2    DoSomething;
3    DoSomethingElse;
  end;
1  while x < j do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  while x < j do
8    Something;

Оператор "repeat..until"

1  repeat
2    x := j;
3    j := UpdateValue;
4  until j > 25;

Оператор "case"

Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01  case LCode of
02    1, 3:
03      begin
04        Incr := FIncrement + 1;
05        FinalIncr := FIncrement div FLineDiv;
06        Count := FLineDiv;
07      end;
08    2, 4:
09      begin
10        Incr := FPageIncrement;
11        FinalIncr := Incr + 1;
12        Incr := Incr div FPageDiv;
13        Count := FPageDiv;
14      end;
15  else
16    begin
17      Count := 0;
18      Incr := 0;
19      FinalIncr := 0;
20    end;
  end;

Оператор "try"

Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01try
02  try
03    EnumItems(CurrentThreadID, LDisable, 0);
04    Result := TaskList;
05  except
06    EnableItems(TaskList);
07    raise;
08  end;
09finally
10  TaskList := SaveList;
11  TaskActive := SaveActive;
end;


Мельница данных ((раздел целиком))

Мельница данных- Разработка шаблонов (раздел целиком) (22.10.2024) (одним файлом)
Разработка шаблонов

Шаблон представляет собой обычную рабочую книгу Excel.

Шаблоны для переноса данных в Excel физически интегрируются внутрь .MQR-файла и хранятся вместе с запросом. Разработку шаблона можно вести независимо, используя только Microsoft Excel (запуская его самостоятельно), а потом загрузить в файл запроса, а можно воспользоваться пунктом меню "Редактировать" на странице "Шаблоны".

Для взаимодействия с источником данных рабочая книга-шаблон должна содержать в любом модуле макрос с именем "Template" (без кавычек) с одним параметром. При выполнении переноса данных по этому шаблону QueryBuilder произведет вызов этого метода, передав в качестве фактического значения параметра объект, реализующий интерфейс IExternalQuery. Никаких других требований к рабочей книге-шаблону не выдвигается.
В примере показан запрос на таблицу AGNLIST (провайдер Oracle), показывающий как простой перенос данных, так и сводную таблицу со сводной диаграммой распределения записей таблицы по полю CRN.
Пример запроса с шаблонами
В примере показан запрос на таблицу "TField" (провайдер Мельницы Данных), показывающий как простой перенос данных, так и сводную таблицу со сводной диаграммой распределения записей таблицы.
Пример запроса с шаблонами для Мельницы Данных`

1. Интерфейс IExternalQuery
Объект, реализующий этот интерфейс, передается в макрос генерации отчета Excel (Template). Все его свойства и методы доступны для испоьзования в процессе генерации отчета
01  IExternalQuery = interface(IDispatch)
02    ['{1A86D1DA-A56E-4D53-88F9-7A035D7D12B4}']
03    function Select(const SQL: WideString): IExternalDataSet; safecall;
04    function SelectedRecordsCount: Integer; safecall;
05    function SelectedRecord(Index: Integer): OleVariant; safecall;
06    procedure PlaceCurrentQuery(const Sheet: IDispatch;
07      CaptionsNeeded: WordBool = False; Row: Integer = 1;
08      Column: Integer = 1; ShiftRows: WordBool = True;
09      ShiftColumns: WordBool = False); safecall;
10    procedure PlaceQuery(const Sheet: IDispatch; const DataSet: ExternalDataSet;
11      Row: Integer = 1; Column: Integer = 1; ShiftRows: WordBool = True;
12      ShiftColumns: WordBool = False); safecall;
13    property CurrentQuery: WideString;
14  end;
  • функция Select возвращает объект, реализующий интерфейс IExternalDataSet с данными, полученными в результате запроса, заданного параметром SQL. Фактически метод является оберткой метода Perform объекта-провайдера IInfoProvider
  • функция SelectedRecordsCount возвращает количество записей, отмеченных пользователем в гриде в момент выгрузки в Excel
  • функция SelectedRecord возвращает первичный ключ отмеченной пользователем записи с номером Index
  • процедура PlaceCurrentQuery осуществляет перенос в указанное положение указанного рабочего листа данных текущего табличного представления. Параметр Sheet указывает на рабочий лист Excel, на который будет осуществляться перенос, параметр CaptionsNeeded определяет необходимость переноса заголовков колонок, параметры Row и Column определяют соответственно номер строки и столбца на рабочем листе Excel, начиная с которых будут расположены данные. Параметр ShiftRows определяет необходимость сдвига строк вниз при переносе данных (информация в ячейках, лежащих НИЖЕ строки, определенной параметром Row, будет либо затерта, либо сдвинута на требуемое число строк вниз. Параметр ShiftColumns определяет необходимость сдвига колонок вправо при переносе данных (информация в ячейках, лежащих ПРАВЕЕ столбца, определенного параметром Column, будет либо затерта, либо сдвинута на требуемое число строк вниз.
  • процедура PlaceQuery осуществляет перенос в указанное положение указанного рабочего листа данных заданного параметром DataSet набора данных. Параметр Sheet указывает на рабочий лист Excel, на который будет осуществляться перенос, параметр CaptionsNeeded определяет необходимость переноса заголовков колонок, параметры Row и Column определяют соответственно номер строки и столбца на рабочем листе Excel, начиная с которых будут расположены данные. Параметр ShiftRows определяет необходимость сдвига строк вниз при переносе данных (информация в ячейках, лежащих НИЖЕ строки, определенной параметром Row, будет либо затерта, либо сдвинута на требуемое число строк вниз. Параметр ShiftColumns определяет необходимость сдвига колонок вправо при переносе данных (информация в ячейках, лежащих ПРАВЕЕ столбца, определенного параметром Column, будет либо затерта, либо сдвинута на требуемое число строк вниз.
  • свойство CurrentQuery возвращает строку запроса, на основе которого постоено текущее табличное представление.

2. Интерфейс IExternalDataSet
Фактически, обертка над интерфейсом IDataSet .
1  IExternalDataSet = interface(IDispatch)
2    ['{CDC7992C-BB30-431C-9F81-3215175AD5AB}']
3    procedure Next; safecall;
4    function Eof: WordBool; safecall;
5    property FieldCount: Integer;
6    property FieldName[Index: Integer]: WideString;
7    property Field[FieldIndex: OleVariant]: OleVariant;
8  end;
Набор данных представляет собой однонаправленный курсор, каждая строка которого является набором именованных и нумерованных полей.
  • процедура Next осуществляет переход к следующей записи курсора.
  • функция Eof возвращает True в случае достижения конца курсора.
  • свойство FieldCount возвращает количество полей в строке курсора.
  • свойство FieldName возвращает имя поля с номером Index.
  • свойство Field возвращает значение поля, имя или номер которого задан параметром (если строка, то имя, если число, то номер). Допустимо возвращать значение Null для пустых полей.


Мельница данных ((раздел целиком))

Мельница данных- Интеграция (раздел целиком) (22.10.2024) (одним файлом)
Интеграция

Интеграция - комплекс работ по настройке механизмов взаимодействия между различными учетными системами, которые функционируют независимо друг от друга в одной организационной структуре ("лоскутная" автоматизация).

Концептуально реализация интеграции может быть осуществлена двумя способами (рассмотрены более подробно далее):

  • Интеграция на базе интеграционной платформы (некоего ядра, которое осуществляет взаимодействие между учетными системами)
  • Интеграция без внедрения интеграционной платформы, с использованием связей между учетными системами только там где это необходимо.

Практически, реализация интеграции может быть осуществлена слежующими способами:

1. Интеграция данных

В свою очередь интеграцию данных можно разделить на два типа:

1.1. Репликативная интеграция

Репликативная интеграция - передающая сторона формирует реплику, передает ее принимающей стороне, которая в свою очередь загружает в себя реплику. В этом случае стандартами формата реплики являются двоичный формат и XML-схема. Платформа Мельница Данных имеет готовые механизмы для реализации обоих форматов.

Варианты реализации репликационной интеграции:

1. Данные должны быть переданы из сторонней учетной системы и загружены в Платформу Мельница данных:

В Платформе уже реализованы механизмы загрузки реплик в двоичном (бинарном) формате, а также в формате XML-схемы. В случае, если разработчики или сопровождающие сотрудники сторонней учетной системы имеют возможность выгрузки реплики в данных форматах, взаимодействие производится стандартными средствами Платформы. В противном случае создается конвертер для перевода данных реплики в один из стандартных форматов для дальнейшей загрузки реплики в Мельницу Данных.

2. Данные должны быть переданы из Платформы Мельница Данных и загружены в стороннюю учетную систему:

При необходимости выгрузки данных из Платформы Мельница Данных используются стандартные механизмы выгрузки реплики в двоичном (бинарном) формате или в формате XML-схемы. В случае, если эти варианты не являются приемлемыми для принимающей стороны (сторонней учетной системы), можно выполнить выгрузку данных через скриптлет, Microsoft Excel-файл, отчет или любыми механизмами просто выгрузить требуемый файл для дальнейшей обработки (загрузки) принимающей стороной. В этом случае необходимо четкое согласование протоколов и форматов обмена данными.

3. Данные должны быть переданы из одной сторонней учетной системы в другую. При этом Платформа Мельница Данных выступает в качестве интеграционной платформы:

МД - интеграционное ядро

Если Платформа выступает в качестве интеграционного ядра, в ней необходимо объявить структуры для хранения тех элементов данных, которые в Платформе по умолчанию не хранятся, но загружаются в нее из сторонних учетных систем и в дальнейшем подлежат какому-либо анализу. При этом нет необходимости обеспечивать функционирование бизнес-процессов над этими данными в рамках Платформы, данные просто хранятся.

Подобная интеграция осуществляется простыми готовыми средствами платформы в самые сжатые сроки.

1.2. On-Line доступ

Второй путь интеграции данных - Интеграция с использованием доступа к данным в режиме On-Line.

1. В том случае когда Платформа является серверной стороной, то есть стороной-поставщиком данных для других систем, возможны следующие варианты предоставления данных:

- СУБД, то есть база данных, которая хранит все данные Платформы. На данный момент поддерживаются Oracle, Firebird, MS SQL. Возможна реализация поддержки и других систем управления базами данных. Для указанных баз данных доступны стандартные протоколы доступа, с помощью которых осуществляются запросы к данным Платформы непосредственно. Запросы формируются при помощи стандартизированного языка запросов Structured Query Language (SQL).

- RESTful-сервис используется для реализации более сложной механики предоставления доступа к данным и входит в состав поставки сервера приложений Платформы. С его помощью, в частности, осуществляется удаленный доступ и доступ к данным через SOAP (Simple Object Access Protocol — простой протокол доступа к объектам) с автоматическим формированием по данным Платформы WSDL-документа, описывающего сервисы. Таким образом реализуется продвинутый функционал по отбору объекта по критериям, а также в части доступа ко всем данным Платформы по протоколу SOAP/

В случае если требуются какие-либо специфические протоколы для обмена данными, они реализовываются на уровне обработчика сервера-приложения. То есть осуществляется "надстройка" сервера приложений Платформы для работы с данными в том виде, в котором это необходимо и по тому протоколу, который требуется в каждом конкретном случае. Таким образом, Сервер приложений Платформы востребован в большинстве случаев организации взаимодействия между системами.

Практический пример реализации:

Компания "Мельница технологий" в одном из московских ВУЗов осуществяла интеграцию с тестирующей системой по проведению олимпиад. С использованием протокола SOAP в тестирующую систему из Платформы предоставлялась информация о реквизитах олимпиад, которые были выбраны каждым школьником-участником. Был реализован обработчик-"переходник", через который передавалсь информация.

Для системы LMS (Learning Management System) компании Asteros данные также предоставляются по протоколу SOAP.

2. В случае когда Платформе необходим доступ к данным сторонних систем, используется готовый RESTful-"обработчик". Частными случаями данной ситуции являются взаимодействия Платформы с различными собственными web-приложениями, а также с "Обозревателем данных", работающим через удаленный доступ.

Для получения данных в режиме On-Line от сторонних систем используются те же стандартные протоколы. При необходимости создаются "обработчики", которые отображают для конечного пользователя в визуальных формах Платформы данные, полученные из сторонних систем.

3. При использовании Платформы в качестве платформы интеграции различных сторонних систем, данные предварительно загруженные по описанным выше протоколам могут передаваться средствами Платформы. Однако, может быть реализован и механизм прозрачной передачи данных между сторонними системами.

2. Интеграция функций
Данный тип развития интеграции в свою очередь можно разделить на 2 пути:

2.1. Взаимные вызовы

В данном случае подразумевается, что какая-либо учетная система открывает возможность вызова своих встроенных функций из сторонних систем.

Доступ к функциям возможен с помощью выполнения хранимых процедур (каждое бизнес-действие, которое производит пользователь, обязательно оформляется в виде хранимой процедуры на уровне СУБД Платформы). Процедуру можно вызывать, получив доступ к СУБД. Аналогично тому, как создаются select-запросы, запросы к данным, можно делать запросы, вызывающие бизнес-функции. Все методы, отчеты, и все, что доступно пользователю, может быть вызвано и через RESTful-сервис. При этом методы будут выполняться, отчеты будут формироваться в виде Excel, Word, PDF, HTML, в соответствии с запросом вызывающей стороны. Данный функционал обеспечивается готовым "обработчиком", входящим в состав поставки Платформы.

С помощью протокола SOAP можно вызывать любой метод любого объекта, получать результаты его выполнения без ограничений.

В случае когда необходимо в Платформе использовать чужие функции, набор действий по вызову такой функции оформляется в виде скриптлета.

Пример реализации:

В ВУЗе при формировании приказа о зачислении студента в Платформе, также автоматически создается объект "Приказ" в системе документооборота ВУЗа. В дальнейшем, передвижение приказа по маршруту согласования в решении на Платформе аналогично отображается в системе документооборота.

Если для сторонней системы существуют какие-либо стандартные протоколы, по которым можно вызывать функцию, то средствами Платформы не составляет труда вызов данной функции.

2.2. Встраивание

Данный путь интеграции функций представляет собой ситуацию, когда сторонняя система непосредственно "встраивается" в решения на Платформе и код сторонней системы исполняется с использованием данных Платформы.

Существуют разные способы реализации данного пути:

- В open-source системах, как правило, слой доступа к данным вынесен в некий отдельный модуль. Характерный пример - это LMS eFront. Это Open-Source разработка, содержащая в себе большой объем php-кода, с развитым web-интерфейсом, и, в том числе, содержащая модуль доступа к данным. В процессе работы создается база MySQL база достаточно примитивной структуры. В этом случае можно изменить модуль доступа, так, чтобы вместо запросов к MySQL-базе механика делала бы запросы к базе данных Платформы. Тогда исполнение php-кода, его интерпретация происходит в рамках сервера приложений Платформы.

Пример реализации:

Так как в базе данных Платформы уже хранятся данные о студентах, преподавателях, курсах и т.д., то при взаимодействии с системой обучения LMS, естественным, удобным и надежным решением является хранение все этих данных в одной базе данных

- В тех случаях, когда решения Платформы сами являются частью какой-либо более общей системы, и должны предоставлять свои функции, то это решается на уровне СУБД. То есть, сгенерированный Платформой прикладной код (код на соответствующем диалекте SQL) может быть интегрирован в код более масштабного хранилища, функционировать там, исполняться там, если в этом есть необходимость.

Прикладные системы на базе СУБД Teradata позволяют использовать PL/SQL-код для каких-либо наборов данных, притом, что сама база гораздо имеет продвинутые возможности автоматического контроля версий, хроникальности, аналитики.


Мельница данных ((раздел целиком))

Мельница данных- Класс TEnumerationDomain (Перечисления) (раздел целиком) (22.10.2024) (одним файлом)
Класс TEnumerationDomain (Перечисления)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)Класс TEnumerationItem (Элементы перечислений)

1. Свойства

Свойства класса TEnumerationDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
ShowNames | Boolean | Да | Видимо пользователю | Чтение/Запись | Показывать имена
BasedOnDomain | TEnumerationDomain | Нет | Видимо пользователю | Чтение/Запись | Расширяет домен
ItemCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество элементов
CaseInsensitiveSearch | Boolean | Да | Видимо пользователю | Чтение/Запись | Регистронезависимый поиск

2. Конструктор Create (Конструктор перечисления)

Конструктор класса TEnumerationDomain.

1constructor TEnumerationDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; ShowNames: Boolean;
4  BasedOnDomain: TEnumerationDomain; CaseInsensitiveSearch: Boolean): TDomain;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
ShowNames | Boolean | Да | Показывать имена элементов
BasedOnDomain | TEnumerationDomain | Нет | Расширяет домен
CaseInsensitiveSearch | Boolean | Да | Регистронезависимый поиск

Замечания:

Создает новый объект класса TEnumerationDomain.

3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TEnumerationDomain.

function TEnumerationDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4. Метод ListItems (Список элементов)

Метод экземпляра класса TEnumerationDomain.

function TEnumerationDomain.ListItems: TObjectList;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс ITableInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс ITableInfo
Информация о таблице представляется объектом через интерфейс (наследник INamedItemInfo )
1  ITableInfo = interface(INamedItemInfo)
2    ['{3FC1998A-9031-4936-82B5-8CAA2219085E}']
3    function Get_FieldCount: Integer; safecall;
4    function Get_Field(Index: Integer): IFieldInfo; safecall;
5    function Get_PrimaryKey: IFieldInfo; safecall;
6    function Get_Uplink: IFieldInfo; safecall;
7    function Get_Parent: ITableInfo; safecall;
8  end;
  • функция Get_FieldCount возвращает количество полей в таблице.
  • функция Get_Field возвращает ссылку на поле с номером Index. Ссылка на интерфейс IFieldInfo
  • функция Get_PrimaryKey возвращает ссылку на поле, являющееся первичным ключем. Это поле должно быть задано.
  • функция Get_Uplink возвращает ссылку на поле, осуществляющее иерархическую связь между записями таблицы. Если это поле задано, записи отображаются в виде иерархии.
  • функция Get_Parent возвращает ссылку на родительскую таблицу. Дочерняя таблица связана с родительской первичными ключами, т. е. соотношением 1:1. Если таблица не имеет родительской, возвращается nil.

1. Интерфейс ITableInfo2
Для таблиц, имеющих полиморфные ссылки, реализуется интерфейс (наследник ITableInfo )
1  ITableInfo2 = interface(ITableInfo)
2    ['{9DF4C8AC-1DA2-4E7B-BF44-7EDD7A269418}']
3    function Get_PolymorphCount: Integer; safecall;
4    function Get_PolymorphTable(Index: Integer): ITableInfo; safecall;
5    function Get_PolymorphField(Index: Integer): IFieldInfo; safecall;
6  end;
Полиморфной ссылкой является, например, ссылка, физически размещенная в родительской таблице, указывающая на свою запись. Реализация этого интерфейса не является обязательной.
  • функция Get_PolymorphCount возвращает количество полиморфных ссылок.
  • функция Get_PolymorphTable возвращает ссылку на таблицу, на которую указывает полиморфная ссылка номер Index.
  • функция Get_PolymorphTable возвращает ссылку на поле, реализующее полиморфную ссылку номер Index. Это поле должно иметь тип dtReference, информация о его типе должна реализовать интерфейс IReferenceInfo. Значение, возвращаемое функцией Get_TargetTable этого интерфейса в данном случае не имеет значения и игнорируется.

2. Интерфейс ITableInfo3
Для таблиц, при запросах к которым требуется наложение дополнительных условий отбора, реализуется интерфейс (наследник ITableInfo )
01  ITableInfo3 = interface(ITableInfo)
02    ['{3FB73AA9-010C-48DA-81C7-E1DCFE2E6136}']
03    function GetPersistentClause(const Alias: WideString): WideString; safecall;
04    function GetPreConditionsCount: Integer; safecall;
05    function GetPreConditionCaption(Index: Integer): WideString; safecall;
06    function GetPreConditionCategory(Index: Integer): WideString; safecall;
07    function Get_ActivePreCondition(Index: Integer): WordBool; safecall;
08    procedure Set_ActivePreCondition(Index: Integer; Value: WordBool); safecall;
09    function GetPreConditionParamsCount(Index: Integer): Integer; safecall;
10    function GetPreConditionParam(Index: Integer; PreConditionIndex: Integer): IOptionInfo; safecall;
11  end;
  • функция GetPersistentClause возвращает выражение дополнительного условия отбора. Алиас таблицы передается в параметре Alias.


Мельница данных ((раздел целиком))

Мельница данных- Класс TObjectListItem (Элементы списков) (раздел целиком) (22.10.2024) (одним файлом)
Класс TObjectListItem (Элементы списков)

Диаграмма Класс TObject (Объекты)Класс TObjectList (Списки)

1. Свойства

Свойства класса TObjectListItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Object | TObject | Да | Видимо пользователю | Только для чтения | Объект
Position | Integer | Да | Видимо пользователю | Только для чтения | Позиция

2. Конструктор Create (Конструктор элемента списка)

Конструктор класса TObjectListItem.

1constructor TObjectListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ItemObject: TObject; Position: Integer): TObject;

Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
ItemObject | TObject | Да | Элемент
Position | Integer | Нет | Позиция

Замечания:

Создает новый объект класса TObjectListItem.


Мельница данных ((раздел целиком))

Мельница данных- Использование провайдера БД Парус8 (раздел целиком) (22.10.2024) (одним файлом)
Использование провайдера БД Парус8

1. Использование пользовательских приложений.
Библиотека ParusInfoProvider.dll содержит реализацию провайдера для БД Парус8. Провайдер реализует, в дополнение к обязательным, интерфейс, позволяющий управлять им посредством механизма "Пользовательских приложений":
1  IParusProvider = interface(IDispatch)
2    ['{4864AE99-80E6-4FC6-9DB0-EAB248F72362}']
3    procedure Connect(const Database: WideString;
4      const UserName: WideString;
5      const Password: WideString); safecall;
6    property QueryObject: OleVariant;
7    property StoredProcObject: OleVariant;
8  end;
Объект-провайдер может установить связь с БД либо самостоятельно с использованием переданных в метод Connect параметров соединения, либо с помощью объектов Query и StoredProc , предоставляемых системой Парус8 для использования в пользовательских приложениях. В свою очередь, созданный провайдер с установленным соединением может быть передан в метод Execute объекта QueryBuilder.Application . Вторым параметром может быть передано значение, представляющее структуру запроса. Это может быть либо строка с указанием имени файла, либо объект, реализующий интерфейс IStream (например, MSXML.DOMDocument ), либо строка, представляющая собой xml-документ. Все средства манипуляции структурой и поведением запроса предоставляются на уровне работы с xml-документом, описывающим запрос.
Пример скрипта пользовательского приложения на DelphiScript
01procedure QueryBuilderTest;
02var
03  LApplication: OleVarint;
04  LProvider: OleVarint;
05  LDocument: OleVariant;
06begin
07  //описание структуры запроса. Из BLOB, из файла, из строки - откуда угодно
08  LDocument := CreateOleObject('MSXML.DOMDocument');
09  //LDocument реализует IXMLDOMDocument и IStream
10  LDocument.loadXML('<Query Provider="{B3079C97-6EBC-43EB-880F-58F094B322B0}">' +
11    '<Item Type="Table" Table="AGNLIST" Alias="MAIN" TableAlias="MAIN">'  +
12      '<Item ColumnIndex="0" Type="Field" Field="AGNABBR" Table="AGNLIST" ' +
13        'Alias="MAIN_AGNABBR" TableAlias="MAIN"/>' +
14      '<Item ColumnIndex="1" Type="Field" Field="VERSION" Table="AGNLIST" ' +
15        'Alias="MAIN_VERSION" TableAlias="MAIN"/>' +
16    '</Item>' +
17  '</Query>');
18
19  //Скрытие дерева структуры
20  LDocument.documentElement.setAttribute('TreeWidth', 0);
21
22  //Наложение условий отбора на колонку
23  LDocument.selectSingleNode('/*/Item/Item[@Field="AGNABBR" and @Table="AGNLIST"]').
24    setAttribute('ColumnFilter', 'Б*');
25
26  //Переименование колонки
27  LDocument.selectSingleNode('/*/Item/Item[@Field="VERSION" and @Table="AGNLIST"]').
28    setAttribute('Caption', 'Версия');
29
30
31  //создание провайдера и передача ему объектов для соединения с БД
32  LProvider := CreateOleObject('ParusInfoProvider.ParusProvider');
33  LProvider.QueryObject := Query;
34  LProvider.StoredProcObject := StoredProc;
35
36  //создание и использование объекта-приложения QueryBuilder
37  LApplication := CreateOleObject('QueryBuilder.Application');
38
39  //В качестве второго параметра передается ОБЪЕКТ, через
40  //   IStream содержащий структуру запроса
41  LApplication.Execute(LProvider, LDocument);
42  LApplication.Visible := True;
43
44  //Ожидание завершения работы с приложением
45  repeat
46    Application.ProcessMessages;
47  until not LApplication.Visible;
48
49end;
50
Интерфейс автоматизации поддерживает также метод для автоматического применения шаблона для переноса в Excel.
Допустим, .MQR-файл, описывающий запрос, содержащий шаблон с именем "Простой Перенос" загружен в раздел "Модули пользовательских приложений" с мнемокодом "QueryData". Для этого необходимо создать модуль пользовательского приложения с типом "COM-сервер" или "Надстройка Excel" и загрузить из файла .MQR-файл. Проверки соответствия формата загружаемого файла заявленному типу модуля пользовательского приложения Парус не производит, что позволяет воспользоваться этим трюком. Тогда:
01procedure QueryBuilderTemplateTest;
02var
03  LApplication: OleVarint;
04  LProvider: OleVarint;
05  S: string;
06begin
07  Query.SQL.Text := 'select BMODULE from V_UAMODULES where SCODE = :CODE';
08  //мнемокод модуля пользовательского приложения, содержащего
09  //загруженный .MQR-файл
10  Query.ParamByName('CODE').Value := 'QueryData';
11  Query.Open;
12  S := Query.FieldByName('BMODULE').AsString;
13  Query.Close;
14
15 //создание провайдера и передача ему объектов для соединения с БД
16  LProvider := CreateOleObject('ParusInfoProvider.ParusProvider');
17  LProvider.QueryObject := Query;
18  LProvider.StoredProcObject := StoredProc;
19
20  //создание и использование объекта-приложения QueryBuilder
21  LApplication := CreateOleObject('QueryBuilder.Application');
22
23  //В качестве второго параметра передается СТРОКА, содержащая xml с описанием
24  //структуры запроса и шаблоны для переноса в Excel
25  LApplication.ExecuteTemplate(LProvider, S, 'Простой Перенос');
26end;

2. Информация о базе данных
Провайдер Парус8 предоставляет информацию о четырех типах таблиц:
  1. Представление, описанное при помощи метаданных Парус8 как "вызываемое с клиента". В этом случае полями таблицы являются описанные атрибуты класса с соответствующими типами.
  2. Таблица, имеющая клиентский доступ и связанная с разделом, не имеющим ни одного описанного доступного представления, но имеющим описанные физические атрибуты. Информация о полях берется из метаданных Парус8
  3. Таблица, имеющая клиентский доступ и связанная с разделом, не имеющим ни одного описанного доступного представления, и не имеющим описанных атрибутов. Информация о полях берется из метаданных Oracle.
  4. Таблица, имеющая клиентский доступ и не связанная ни с каким разделом. Информация о полях берется из метаданных Oracle.


Мельница данных ((раздел целиком))

Мельница данных- Класс TFileNameDomain (Имена файлов) (раздел целиком) (22.10.2024) (одним файлом)
Класс TFileNameDomain (Имена файлов)

Диаграмма Класс TStringDomain (Строковые)Класс TDomain (Домены)Класс TObject (Объекты)

1. Свойства

Свойства класса TFileNameDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
Length | Integer | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TStringDomain
AllowLeadingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись
AllowTrailingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись
AllowSpaceDuplication | Boolean | Да | Видимо пользователю | Чтение/Запись
CharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись
FirstCharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись
CaseMode | Boolean | Нет | Видимо пользователю | Чтение/Запись
Mask | string[2000] | Нет | Видимо пользователю | Чтение/Запись
CaseInsensitiveSearch | Boolean | Да | Видимо пользователю | Чтение/Запись
FileMustExist | Boolean | Да | Видимо пользователю | Чтение/Запись | Файл должен существовать
DefaultExtension | string[10] | Нет | Видимо пользователю | Чтение/Запись | Расширение по умолчанию
OverwritePrompt | Boolean | Да | Видимо пользователю | Чтение/Запись | Запрос перезаписи

2. Конструктор Create (Конструктор имени файла)

Конструктор класса TFileNameDomain.

1constructor TFileNameDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean; FileMustExist: Boolean;
7  DefaultExtension: string[10]; OverwritePrompt: Boolean): TObject;

Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
Length | Integer | Да | Унаследовано от TStringDomain.Create
AllowLeadingSpaces | Boolean | Да
AllowTrailingSpaces | Boolean | Да
AllowSpaceDuplication | Boolean | Да
CharacterSet | string[2000] | Нет
FirstCharacterSet | string[2000] | Нет
CaseMode | Boolean | Нет
Mask | string[2000] | Нет
CaseInsensitiveSearch | Boolean | Да
FileMustExist | Boolean | Да | Файл должен существовать
DefaultExtension | string[10] | Нет | Расширение по умолчанию
OverwritePrompt | Boolean | Да | Запрос перезаписи

Замечания:

Создает новый объект класса TFileNameDomain.

3. Метод Change (Изменение объекта)

Метод экземпляра класса TFileNameDomain.

procedure TFileNameDomain.Change(Action: TChangeAction);

Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Унаследовано от TObject.Change

4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFileNameDomain.

function TFileNameDomain.GetSummary: string[2000];

Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Класс TParametersFormView (Представления формы параметров) (раздел целиком) (22.10.2024) (одним файлом)
Класс TParametersFormView (Представления формы параметров)

Класс TFormView (Представления формы)Класс TObject (Объекты)Класс TRoutine (Подпрограмма)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

1. Конструктор Create (Конструктор представления формы параметров)

Конструктор класса TParametersFormView.

1constructor TParametersFormView.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; View: TCustomView; ChildrenMinimized: Boolean;
4  ChildrenOnTabs: Boolean; MasterProperty: TProperty;
5  DetailProperty: TClassMember; Position: Integer; SpacePercentage: Integer;
6  Layout: TFormViewLayout; ExplicitQuery: Boolean): TObject;

Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
View | TCustomView | Да | Унаследовано от TFormView.Create
ChildrenMinimized | Boolean | Да
ChildrenOnTabs | Boolean | Да
MasterProperty | TProperty | Нет
DetailProperty | TClassMember | Нет
Position | Integer | Да
SpacePercentage | Integer | Нет
Layout | TFormViewLayout | Да
ExplicitQuery | Boolean | Да

Замечания:

Создает новый объект класса TParametersFormView.


Мельница данных ((раздел целиком))

Мельница данных- Интеграция данных (раздел целиком) (22.10.2024) (одним файлом)
Интеграция данных

В свою очередь интеграцию данных можно разделить на два типа:

1. Репликативная интеграция

Репликативная интеграция - передающая сторона формирует реплику, передает ее принимающей стороне, которая в свою очередь загружает в себя реплику. В этом случае стандартами формата реплики являются двоичный формат и XML-схема. Платформа Мельница Данных имеет готовые механизмы для реализации обоих форматов.

Варианты реализации репликационной интеграции:

1. Данные должны быть переданы из сторонней учетной системы и загружены в Платформу Мельница данных:

В Платформе уже реализованы механизмы загрузки реплик в двоичном (бинарном) формате, а также в формате XML-схемы. В случае, если разработчики или сопровождающие сотрудники сторонней учетной системы имеют возможность выгрузки реплики в данных форматах, взаимодействие производится стандартными средствами Платформы. В противном случае создается конвертер для перевода данных реплики в один из стандартных форматов для дальнейшей загрузки реплики в Мельницу Данных.

2. Данные должны быть переданы из Платформы Мельница Данных и загружены в стороннюю учетную систему:

При необходимости выгрузки данных из Платформы Мельница Данных используются стандартные механизмы выгрузки реплики в двоичном (бинарном) формате или в формате XML-схемы. В случае, если эти варианты не являются приемлемыми для принимающей стороны (сторонней учетной системы), можно выполнить выгрузку данных через скриптлет, Microsoft Excel-файл, отчет или любыми механизмами просто выгрузить требуемый файл для дальнейшей обработки (загрузки) принимающей стороной. В этом случае необходимо четкое согласование протоколов и форматов обмена данными.

3. Данные должны быть переданы из одной сторонней учетной системы в другую. При этом Платформа Мельница Данных выступает в качестве интеграционной платформы:

МД - интеграционное ядро

Если Платформа выступает в качестве интеграционного ядра, в ней необходимо объявить структуры для хранения тех элементов данных, которые в Платформе по умолчанию не хранятся, но загружаются в нее из сторонних учетных систем и в дальнейшем подлежат какому-либо анализу. При этом нет необходимости обеспечивать функционирование бизнес-процессов над этими данными в рамках Платформы, данные просто хранятся.

Подобная интеграция осуществляется простыми готовыми средствами платформы в самые сжатые сроки.

2. On-Line доступ

Второй путь интеграции данных - Интеграция с использованием доступа к данным в режиме On-Line.

1. В том случае когда Платформа является серверной стороной, то есть стороной-поставщиком данных для других систем, возможны следующие варианты предоставления данных:

- СУБД, то есть база данных, которая хранит все данные Платформы. На данный момент поддерживаются Oracle, Firebird, MS SQL. Возможна реализация поддержки и других систем управления базами данных. Для указанных баз данных доступны стандартные протоколы доступа, с помощью которых осуществляются запросы к данным Платформы непосредственно. Запросы формируются при помощи стандартизированного языка запросов Structured Query Language (SQL).

- RESTful-сервис используется для реализации более сложной механики предоставления доступа к данным и входит в состав поставки сервера приложений Платформы. С его помощью, в частности, осуществляется удаленный доступ и доступ к данным через SOAP (Simple Object Access Protocol — простой протокол доступа к объектам) с автоматическим формированием по данным Платформы WSDL-документа, описывающего сервисы. Таким образом реализуется продвинутый функционал по отбору объекта по критериям, а также в части доступа ко всем данным Платформы по протоколу SOAP/

В случае если требуются какие-либо специфические протоколы для обмена данными, они реализовываются на уровне обработчика сервера-приложения. То есть осуществляется "надстройка" сервера приложений Платформы для работы с данными в том виде, в котором это необходимо и по тому протоколу, который требуется в каждом конкретном случае. Таким образом, Сервер приложений Платформы востребован в большинстве случаев организации взаимодействия между системами.

Практический пример реализации:

Компания "Мельница технологий" в одном из московских ВУЗов осуществяла интеграцию с тестирующей системой по проведению олимпиад. С использованием протокола SOAP в тестирующую систему из Платформы предоставлялась информация о реквизитах олимпиад, которые были выбраны каждым школьником-участником. Был реализован обработчик-"переходник", через который передавалсь информация.

Для системы LMS (Learning Management System) компании Asteros данные также предоставляются по протоколу SOAP.

2. В случае когда Платформе необходим доступ к данным сторонних систем, используется готовый RESTful-"обработчик". Частными случаями данной ситуции являются взаимодействия Платформы с различными собственными web-приложениями, а также с "Обозревателем данных", работающим через удаленный доступ.

Для получения данных в режиме On-Line от сторонних систем используются те же стандартные протоколы. При необходимости создаются "обработчики", которые отображают для конечного пользователя в визуальных формах Платформы данные, полученные из сторонних систем.

3. При использовании Платформы в качестве платформы интеграции различных сторонних систем, данные предварительно загруженные по описанным выше протоколам могут передаваться средствами Платформы. Однако, может быть реализован и механизм прозрачной передачи данных между сторонними системами.


Мельница данных ((раздел целиком))

Мельница данных- Операторы PascalScript (раздел целиком) (22.10.2024) (одним файлом)
Операторы PascalScript

Операторы разделяются точкой с запятой (;). Операторы могут быть одним из следующих:

1. Составной оператор
1begin
2  //Другие операторы
end
Операторы, размещенные внутри составного оператора, разделяются точкой с запятой. Никаких ограничений на состав операторов и количество уровней вложенности не накладывается.
1begin
2  Result := LCurrentValue;
3  Exit;
4end;

2. Оператор присваивания
Выражение1 := Выражение2

Присваивает значение выражения Выражение2 выражению Выражение1. Типы Выражения1 и Выражения2 должны быть совместимы (совпадать по классу домена либо оба быть числовыми). Для этого на Выражение1 (стоящее слева от знака равенства, lvalue) накладывается ряд ограничений. Это выражение должно быть:

  • Полем или свойством экземпляра класса
  • Локальной переменной
  • Параметром
  • Зарезервированной переменной Result
LObject.Name := 'Новое имя';
Result := 25;
LStartTime := StrToDateTime('01.01.2006 00:00:30');
01var
02  LObject: TObject;
03  LClass: TClass;
04  I: Integer;
05  F: Float;
06begin
07  I := F;  //неверно
08  F := I;  //верно
09  LObject := LClass; //верно
10  LClass := LObject; //неверно. Должно быть LClass := (LObject as TClass);
11end;

3. Оператор вызова
ИмяПроцедуры [(Параметр1, Параметр2 ...)]

"ИмяПроцедуры" должно быть:

  • Именем метода класса и вызываться с указанием класса либо экземпляра;
  • Именем метода экземпляра и вызываться с указанием экземпляра;
  • Именем метода своего класса либо предка и вызываться без указания спецификаторов.
Порядок и количество параметров в операторе вызова должны строго совпадать с описанием метода.

1  //метод класса, указан класс
2  LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3
4  //метод экземпляра, указан экземпляр. Метод не имеет параметров.
5  LList.Destroy;
6
7  //свой либо унаследованный метод
8  BuildDefaultActions(Name, True);

4. Оператор ветвления
1if Выражение then
2  //Оператор1
3[else
4  //Оператор2]

Выражение должно быть логического типа. В случае если значение Выражения истинно, выполняется Оператор1. Часть else является необязательной и относится к последнему оператору if, не имеющему таковой. В случае ее наличия Оператор2 выполняется, если значение Выражения ложно.

1if LIndex > 25 then
2  raise 'Индекс слишком большой.';

1if LMonth = 'январь' then
2  January
3else if LMonth = 'февраль' then
4  February
5else
6  OtherMonth;  //обратите внимание на точки с запятой.

5. Оператор выбора
1case Выражение of
2  Значение1: //Оператор1
3  Значение2: //Оператор2
4  ...
5[else
6  //Оператор ]
end

Заменяет каскад операторов if. Значение Выражения должно быть числового типа. Часть else выполняется в случае, если Выражение не равно ни одному из перечисленных вариантов. Эта часть не является обязательной.

1сase LIndex of
2  0: ZeroIndex;
3  1,2,3: SmallIndex;
4  4,5,6,7,8,9,10: BigIndex;
5else
6  raise 'Слишком большой или отрицательный индекс.';
7end;

6. Цикл с предусловием
1while Выражение do
2  //Оператор

Оператор выполняется до тех пор, пока значение Выражения истинно. Выражение должно быть логического типа. Если при входе в цикл Выражение не истинно, то тело цикла не будет выполнено ни одного раза.

01while LList.Count > 0 do
02  LList.GetItem(0).Destroy;
03
04while True do
05begin
06  LValue := LValue.NextValue;
07  if LValue.Value > 10 then
08  begin
09    Result := LValue.Value;
10    exit;
11  end;
12end;

7. Цикл с постусловием
1repeat
2  //Операторы
3until Выражение

Операторы выполняются до тех пор, пока значение Выражения ложно. Выражение должно быть логического типа. Обратите внимание, что внутри себя оператор может содержать несколько операторов, разделенных точкой с запятой. Тело цикла обязательно будет выполнено хотя бы один раз.

1repeat
2  Result := Result + 1;
3  LObject := LObject.Parent;
4until LObject = nil;

8. Цикл с параметром
1for Параметр := Выражение1 (to|downto) Выражение2 do
2  //Оператор

Параметр цикла обязан быть простой локальной переменной. Функционально цикл с параметром эквивалентен циклам:

  • Для формы to
    1Параметр := Выражение1;
2while Параметр <= Выражение2 dobegin
3  Оператор;
4  Параметр :=  Параметр + 1;
end;
  • Для формы downto
    1Параметр := Выражение1;
2while Параметр >= Выражение2 dobegin
3  Оператор;
4  Параметр :=  Параметр - 1;
end;
Если Выражение1 равно Выражению2, тело цикла будет выполнено один раз.

1for I := LList.Length - 1 downto 0 do
2// если LList.Length = 0, тело цикла ни разу не будет выполнено.
3begin
4  LClass := LList.GetItem(I);
5  LMethod := any(TMethod with (Name = LName) and (Master = LClass));
6  LParamList.Add(any(TMethod with (Name = LName) and (Master = LClass)));
7end;

9. Цикл по экземплярам
1for each Параметр of ИмяКласса [with Выражение]
2  [by [-] Выражение [, [-] Выражение]] do
3    //Оператор

Цикл осуществляется по выборке среди экземпляров класса ИмяКласса, для которых истинно Выражение. Если Выражение не задано, то по всем экземплярам. Ссылка на текущий в рамках цикла экземпляр присваивается в локальную переменную Параметр. Выражение должно определяться относительно переменной Параметр. Выраженния, следующие за ключевым словом by, определяют порядок обхода экземпляров. Знак "-" перед выражением (любого типа) определяет обратный порядок обхода.

1for each LOption of TOption with LOption.Domain.Required do
2    // для каждой настройки, домен которой обязателен
3  LOption.SetDefaultValue;

10. Оператор прекращения цикла
break

Происходит немедленный выход из цикла. Выполняется финализация операторов защиты завершения, которыми защищено тело цикла. Допустим только в теле цикла с предусловием, цикла с постусловием, цикла с параметром или цикла по экземплярам.

11. Оператор выхода из подпрограммы
exit

Происходит немедленный выход из программного блока. Выполняется финализация операторов защиты завершения.

12. Оператор защиты завершения
1try
2  //Операторы1
3finally
4  //Операторы2
end

Выполняются операторы Операторы1, разделенные точкой с запятой. В случае возникновения исключительной ситуации управление сразу передается на Операторы2, и после их выполнения исключение остается активным. Если исключения не произошло, выполняются Операторы2. Если среди Операторов1 встречается оператор exit, то Операторы2 все равно выполняются.

1//создание временного объекта-списка
2LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3try
4  LList.Add(LValue);
5  Exit;
6finally
7  //гарантированное уничтожение созданного объекта независимо от исключений.
8  LList.Destroy;
9end;

13. Оператор обработки исключительных ситуаций
1try
2  //Операторы1
3except
4  //Операторы2
end

Выполняются операторы Операторы1. В случае возникновения исключительной ситуации управление передается на Операторы2. Если исключительных ситуаций не возникло, Операторы2 не выполняются никогда. При передаче управления на Операторы2 исключительная ситуация деактивирована. Для ее повторного возбуждения можно воспользоваться оператором возбуждения исключения без указания текстовой строки сообщения.

1try
2  LObject.NeverTouch := True;
3  LObject.ExecuteCoolMethod; //если метод выполнен неудачно
4except
5  LObject.NeverTouch := True;  //установить флаг и ничего не сообщать пользователю.
6end;

1try
2   LObject.ExecuteCoolMethod; //если метод выполнен неудачно
3except
4   LObject.Destroy; //удалить неудачный объект
5   raise;           // продолжить обработку исключения.
6end;

14. Оператор возбуждения исключения
raise [Выражение]
Возбуждает исключение, которое, если не было обработано блоком except оператора обработки, дойдет до пользователя. Пользователь увидит сообщение, определяемое Выражением. Выражение должно иметь строковый тип и является обязательным для всех случаев, кроме части except оператора обработки исключений.

15. Оператор унаследованного вызова
inherited

Работает только в унаследованном переопределенном методе. Вызывается метод предка с параметрами, заданными в параметрах к моменту вызова. Если программный блок представляет собой тело функции, то в псевдопеременной Result будет результат выполнения метода предка.

1// в теле конструктора
2Name := 'Object name';
3Description := 'Object description';
4inherited; //вызов предка с параметрами Name и Description,
5           //заданными двумя предыдущими операторами. Ссылка на
6           //созданный объект лежит в
7           //псевдопеременной Result
8Result.Name := 'New name';


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IExternalDataSet (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IExternalDataSet

01type
02  IExternalDataSet = interface(IDispatch)
03    ['{CDC7992C-BB30-431C-9F81-3215175AD5AB}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_FieldName(Index: Integer): WideString; safecall;
06    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
07    procedure Next; safecall;
08    function Eof: WordBool; safecall;
09    property FieldCount: Integer read Get_FieldCount;
10    property FieldName[Index: Integer]: WideString read Get_FieldName;
11    property Field[FieldIndex: OleVariant]: OleVariant read Get_Field;
12  end;

1. Свойства

Свойства интерфейса IExternalDataSet:

Имя | Тип | Доступ | Назначение
Field[FieldIndex: OleVariant] | OleVariant | Только для чтения |
FieldCount | Integer | Только для чтения |
FieldName[Index: Integer] | WideString | Только для чтения |

2. Метод Eof

Метод интерфейса IExternalDataSet.

function IExternalDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

3. Метод Next

Метод интерфейса IExternalDataSet.

procedure IExternalDataSet.Next;

Метод не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Класс TCustomButton (Кнопки) (раздел целиком) (22.10.2024) (одним файлом)
Класс TCustomButton (Кнопки)

Диаграмма Класс TObject (Объекты)

1. Свойства

Свойства класса TCustomButton:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок закладки
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок группы
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Script | clob | Нет | Видимо пользователю | Чтение/Запись | Скрипт
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись | За пределами закладок

2. Конструктор Create (Конструктор кнопки)

Конструктор класса TCustomButton.

1constructor TCustomButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Script | clob | Нет | Скрипт
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок

Замечания:

Создает новый объект класса TCustomButton.


Мельница данных ((раздел целиком))

Мельница данных- Класс TProfileItem (Состав профиля) (раздел целиком) (22.10.2024) (одним файлом)
Класс TProfileItem (Состав профиля)

Класс TProfile (Профили)Класс TObject (Объекты)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TProfileItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
ProfileClass | TClass | Да | Видимо пользователю | Чтение/Запись | Профилируемый класс
ProfileProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Профилируемое свойство
Comparator | TMethod | Нет | Видимо пользователю | Чтение/Запись | Сравнивающая функция
Group | string[64] | Нет | Видимо пользователю | Чтение/Запись | Группа
AllowNulls | Boolean | Да | Видимо пользователю | Чтение/Запись | Пропускать пустые значения
HasCrossCondition | Boolean | Да | Видимо пользователю | Только для чтения | Имеется пересечение условий

2. Конструктор Create (Конструктор элемента профиля)

Конструктор класса TProfileItem.

1constructor TProfileItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ProfileClass: TClass; ProfileProperty: TProperty; Comparator: TMethod;
4  Group: string[64]; AllowNulls: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
ProfileClass | TClass | Да | Профилируемый класс
ProfileProperty | TProperty | Нет | Профилируемое свойство
Comparator | TMethod | Нет | Сравнивающая функция
Group | string[64] | Нет | Группа
AllowNulls | Boolean | Да | Пропускать пустые значения

Замечания:

Создает новый объект класса TProfileItem.

3. Метод GetHasCrossConditions (Имеется пересечение условий)

Метод экземпляра класса TProfileItem.

function TProfileItem.GetHasCrossConditions: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Мельница данных ((раздел целиком))

Мельница данных- Класс TTextIndex (Индекс текстового поиска) (раздел целиком) (22.10.2024) (одним файлом)
Класс TTextIndex (Индекс текстового поиска)

Диаграмма

1. Свойства

Свойства класса TTextIndex:

Имя | Тип | Обязательно | Доступ | Назначение
Field | TField | Да | Только для чтения | Поле
ObjectClass | TClass | Да | Только для чтения | Класс объекта
Object | TObject | Да | Только для чтения | Объект
ObjectName | string[64] | Да | Только для чтения | Имя объекта
ObjectDescription | string[128] | Да | Только для чтения | Наименование объекта
ObjectParent | TObject | Нет | Только для чтения | Родитель объекта
ObjectMaster | TObject | Да | Только для чтения | Мастер объекта
TopLevelObject | TObject | Нет | Только для чтения | Объект верхнего уровня
Entry | TTextIndexEntry | Да | Только для чтения | Вхождение
Word | string[64] | Да | Только для чтения | Слово
UpperWord | string[64] | Да | Только для чтения | Слово в верхнем регистре

2. Метод CleanUp (Очистить индекс)

Метод класса (статический метод) класса TTextIndex.

class procedure TTextIndex.CleanUp(Field: TField; Object: TObject);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Field | TField | Нет | Поле
Object | TObject | Да | Объект

3. Метод HashClob (Хэш индекса большого текстового объекта)

Метод класса (статический метод) класса TTextIndex.

class function TTextIndex.HashClob(Value: clob; IsXHTML: Boolean): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение
IsXHTML | Boolean | Да | Содержимое является XHTML

Замечания:

Возвращает значение типа string[2000].

4. Метод HashIndex (Хэш индекса)

Метод класса (статический метод) класса TTextIndex.

1class function TTextIndex.HashIndex(Field: TField;
2  Object: TObject): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Field | TField | Да | Поле
Object | TObject | Да | Объект

Замечания:

Возвращает значение типа string[2000].

5. Метод HashValue (Хэш значения)

Метод класса (статический метод) класса TTextIndex.

class function TTextIndex.HashValue(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

6. Метод IndexClob (Индексировать большой текстовый объект)

Метод класса (статический метод) класса TTextIndex.

1class procedure TTextIndex.IndexClob(DeleteExistant: Boolean; Value: clob;
2  Field: TField; Object: TObject; ObjectClass: TClass);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
DeleteExistant | Boolean | Да | Удалять существующие
Value | clob | Нет | Значение
Field | TField | Да | Поле
Object | TObject | Да | Объект
ObjectClass | TClass | Да | Класс объекта

7. Метод IndexValue (Индексировать значение)

Метод класса (статический метод) класса TTextIndex.

1class procedure TTextIndex.IndexValue(DeleteExistant: Boolean;
2  Value: string[2000]; Field: TField; Object: TObject; ObjectClass: TClass);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
DeleteExistant | Boolean | Да | Удалять существующие
Value | string[2000] | Нет | Значение
Field | TField | Да | Поле
Object | TObject | Да | Объект
ObjectClass | TClass | Да | Класс объекта

8. Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndex.

class procedure TTextIndex.LoadFromBuffer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

9. Метод PrepareBuffer (Подготовить буфер)

Метод класса (статический метод) класса TTextIndex.

class procedure TTextIndex.PrepareBuffer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

10. Метод Ole-объекта Rebuild (Перестроить индекс)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TTextIndex.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AClass | TClass | Нет | Класс
AField | TField | Нет | Поле
ThreadCount | Integer | Нет | Количество потоков


Мельница данных ((раздел целиком))

Мельница данных- Класс TExternalDataDomain (Внешние данные) (раздел целиком) (22.10.2024) (одним файлом)
Класс TExternalDataDomain (Внешние данные)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)Класс TExternalDataResource (Ресурсы внешних данных)

1. Свойства

Свойства класса TExternalDataDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
NamesSequence | TSequence | Нет | Видимо пользователю | Чтение/Запись | Последовательность для формирования имен
ContentDomain | TBlobDomain | Да | Видимо пользователю | Чтение/Запись | Домен содержимого
ContentDomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена содержимого
ContentDomainBlobSubtype | TBlobSubtype | Да | Видимо пользователю | Только для чтения | Подтип домена содержимого
ContentDomainExtension | string[10] | Нет | Видимо пользователю | Только для чтения | Расширение домена содержимого
ResourceCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество ресурсов
ContentDependentNames | Boolean | Да | Видимо пользователю | Чтение/Запись | Имя зависит от содержимого
Compress | Boolean | Да | Видимо пользователю | Чтение/Запись | Сжимать содержимое

2. Конструктор Create (Конструктор домена внешних данных)

Конструктор класса TExternalDataDomain.

1constructor TExternalDataDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; NamesSequence: TSequence;
4  ContentDomain: TBlobDomain; ContentDependentNames: Boolean;
5  Compress: Boolean): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
NamesSequence | TSequence | Нет | Последовательность для формирования имен
ContentDomain | TBlobDomain | Да | Домен содержимого
ContentDependentNames | Boolean | Да | Имя зависит от содержимого
Compress | Boolean | Да | Сжимать содержимое

Замечания:

Создает новый объект класса TExternalDataDomain.

3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TExternalDataDomain.

function TExternalDataDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- RESTful-service стандартного обработчика (раздел целиком) (22.10.2024) (одним файлом)
RESTful-service стандартного обработчика

Функции стандартного обработчика сервера приложений доступны при обращении по следующим url:

Схема://хост/Имя обработчика/Функция сервиса.расширение
Url вызова RESTful-сервиса

Запрос к функциям сервиса может содержать один параметр с именем query, который может быть передан методом GET или методом POST.

Ниже рассмотрены конкретные функции, которые можно вызывать.

1. Функция accesslist

Функция accesslist позволяет получить список всех ролей безопасности, в которые включен текущий пользователь. В список войдут идентификаторы всех ролей и идентификатор пользователя. В случае, если вызов выполняется пользователем, являющимся администратором БД, то возвращаемый список будет пустым. Это означает, что для пользователя нет ограничений в доступе к данным и функциональности системы.

Допустимое расширение .xml.

Функция не имеет параметров.

Функция возвращает ответ в виде XML-документа с элементом data, имеющим набор подчиненных узлов row, соответствующих каждому объекту полученного списка. Каждый узел row содержит в качестве значения идентификатор (ID) роли или пользователя.

Пример запроса:
https://techmill.ru/demo/accesslist.xml
Пример ответа:
01<data eof="1">
02  <row>
03    <ID type="int64">460</ID>
04  </row>
05  <row>
06    <ID type="int64">70540</ID>
07  </row>
08  <row>
09    <ID type="int64">891142</ID>
10  </row>
11  <row>
12    <ID type="int64">2533983</ID>
13  </row>
14  <row>
15    <ID type="int64">741846296</ID>
16  </row>
17</data>

2. Функция batch

Функция batch дает возможность однократным ее вызовом отправить на выполнение несколько запросов на получение данных или на вызов методов и получить набор запрошенных данных и результаты выполнения методов.

Допустимые расширения:

  • .xml - для получения ответа в формате xml
  • .js/.json - для получения ответа в формате JSON

Функция осуществляет серию запросов и/или вызовов методов и возвращает данные, соответствующие структуре и условиям переданных запросов и вызовов. Запросы и вызовы передаются в виде параметра GET или POST-запроса с именем query. Значение параметра представляет собой xml-документ следующей структуры:

01<root>
02  <query  class="TRemoteUser">
03    <item part="0" name="FullName"/>
04    <item part="1" name="ID" value="1320218"/>
05  </query>
06  <query  class="TPerson">
07    <item part="0" name="LastName"/>
08    <item part="0" name="FirstName"/>
09    <item part="1" name="ID" value="5652545"/>
10  </query>
11  <execute class="TSchoolAbiturSt" method="RegCount">
12    <row>
13      <AdmissionYear>7427462</AdmissionYear>
14      <AdmStage>8608398</AdmStage>
15      <PrevAdmissionYear>6843737</PrevAdmissionYear>
16      <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
17    </row>
18  </execute>
19</root>

Элемент root может включать в себя набор элементов двух типов:

  • query - эти элементы позволяют выполнять запросы к данным; принципы формирования этих элементов совпадают с принципами, описанными для функции cursor: Функция cursor
  • execute - эти элементы позволяют выполнять вызовы методов; принципы формирования этих элементов совпадают с принципами, описанными для функции execute: Функция execute

При использовании функции batch при выполнении запросов к данным, соответствующим элементам query, всегда используется значение атрибута fetchall="1", даже если этот атрибут не передан, или для него передано значение "0". Подробнее об использовании атрибута fetchall="1": Использование возвращаемого ответа.
Желательно не включать в вызовы функции batch запросы, которые потенциально могут вернуть очень большой набор данных. Для таких запросов лучше использовать функцию cursor (Функция cursor).

3. Функция bulkinsert

Функция bulkinsert позволяет выполнить пакетное добавление данных в поля таблицы. Для использования данной функции подключение должно осуществлять под пользователем, имеющим права доступа на запись к полям таблиц.

Допустимые расширения: .xml, .js / .json.

Функция имеет параметр query, который должен представлять собой XML документ, содержащий информацию о таблице (имя таблицы совпадает с именем класса), в которую должно быть выполнено добавление записей, именах полей и их значениях. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML документ - значение параметра query должен иметь элемент data (можно использовать другое имя элемента, оно не анализируется) с атрибутом handle, в значении которого должно быть передано имя таблицы (имя класса). Корневой элемент должен иметь набор дочерних узлов row, каждый из которых должен иметь дочерние узлы, соответствующие каждой паре имя поля (имя узла) - значение (значение узла).

При успешном выполнении функции будет возвращен ответ в формате XML-документа или в формате JSON с элементом data, который будет включать в себя набор узлов с одним значением id. Значения id будут представлять собой идентификаторы созданных объектов.

01https://techmill.ru/demo/bulkinsert.xml?query=
02  <data handle="TTemporaryList">
03    <row>
04      <FName>Name1</FName>
05      <FDescription>Desc1</FDescription>
06      <FItemInfo>ItemInfo1</FItemInfo>
07    </row>
08    <row>
09      <FName>Name2</FName>
10      <FDescription>Desc2</FDescription>
11      <FItemInfo>ItemInfo2</FItemInfo>
12    </row>
13    <row>
14      <FName>Name3</FName>
15      <FDescription>Desc3</FDescription>
16      <FItemInfo>ItemInfo3</FItemInfo>
17    </row>
18    <row>
19      <FName>Name4</FName>
20      <FDescription>Desc4</FDescription>
21      <FItemInfo>ItemInfo4</FItemInfo>
22    </row>
23  </data>

4. Функция closecursor

Функция closecursor позволяет закрыть ранее открытый курсор, который был открыт при предшествующем вызове функции cursor (Функция cursor).

Допустимое расширение: .xml.

Значением параметра функции query должно быть значение handle, которое было возвращено при вызове функции cursor.

Ответом будет xml-документ с одним пустым элементом data.

Запрос:
https://techmill.ru/demo/closecursor.xml?query="{9197829A-AFA3-49D1-BD03-D860ECCB901F}"
Ответ:
<data/>

Открытые курсоры закрываются автоматически при завершении сессии. В рамках одной сессии желательно явно вызывать функцию closecursor при работе с большими объемами данных, когда данные были получены не полностью (при вызове функции cursor было получено eof="0") и результаты запроса более не нужны.

5. Функция commonproperties

Функция commonproperties позволяет получить значения общих свойств списка объектов, включенных в ранее созданный буфер.

Принципы формирования списка общих свойств объектов и возврата их значений совпадают с принципами работы Инспектора объектов: Отображение свойств Инспектором объектов.

Возможности создания буфера и добавление в него объектов описаны в статьях Функция selectedbuffer, Функция selectionchanged.

Допустимое расширение .xml.

В значении параметра функции с именем query необходимо передать xml-документ, содержащий идентификатор буфера и указания о принципе отбора свойств. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML документ должен иметь элемент query со следующими атрибутами:

  • handle (обязательный) - идентификатор буфера
  • propid - идентификатор свойства; если данный атрибут не передан или для него передано пустое значение, то будет возвращен полный набор полученных свойств, если будет передан идентификатор одного свойства, то будет возвращено значение только этого одного свойства.
  • publiconly - значение "0" (по умолчанию) будет означать, что в ответ будут включены все общие свойства набора объектов, значение "1" будет означать что в ответ будут включены только свойства с областью видимости "Видимо пользователям" (Scope = scPublic).

Пример запроса:
https://techmill.ru/demo/commonproperties.xml?query=<query handle="221024" publiconly="1"/>
Запрос на общие свойства списка объектов, предварительно добавленных в буфер с идентификатором "221024". В ответ будет включены только свойство с областью видимости "Видимо пользователям".

В качестве ответа будет возвращен XML-документ с элементом data, который будет включать в себя набор узлов row, соответствующих каждому свойству из полученного набора свойств. Каждый узел row будет иметь подчиненные узлы:

  • ID - идентификатор свойства
  • Value - значение свойства
  • Value-N - для свойств с доменом ссылочного типа (объектов) будет возвращено Имя объекта; для свойств других доменов значение будет пустым
  • Value-D - для свойств с доменом ссылочного типа (объектов) будет возвращено Наименование объекта; для свойств других доменов значение будет пустым
  • Recieved - для свойств типа "Отложенное" (Suspended) будет возвращено значение "0", для прочих свойств будет возвращено значение "1"; в случае получения значение "0" значение такого свойства можно будет получить другим отдельным запросом именно на это свойство, например, при помощи функции cursor (Функция cursor).

Пример ответа:
01<data eof="1">
02  <row>
03    <ID type="int64">69174</ID>
04    <Value>76208</Value>
05    <Value-N>город Москва</Value-N>
06    <Value-D>Москва</Value-D>
07    <Recieved type="int">1</Recieved>
08  </row>
09  <row>
10    <ID type="int64">69175</ID>
11    <Value>67991</Value>
12    <Value-N>РФ</Value-N>
13    <Value-D>Российская Федерация</Value-D>
14    <Recieved type="int">1</Recieved>
15  </row>
16  <row>
17    <ID type="int64">69176</ID>
18    <Value/>
19    <Value-N/>
20    <Value-D/>
21    <Recieved type="int">0</Recieved>
22  </row>
23  <row>
24    <ID type="int64">4503868</ID>
25    <Value>77</Value>
26    <Value-N/>
27    <Value-D/>
28    <Recieved type="int">1</Recieved>
29  </row>
30</data>

6. Функция cursor

Функция cursor позволяет отправлять запросы на получение данных, доступных через обработчик сервера приложений, получать ответ с запрошенными данными в форматах xml или JSON.

Допустимые расширения:

  • .xml - для получения ответа в формате XML
  • .js/.json - для получения ответа в формате JSON

Функция осуществляет запрос к указанному классу или представлению и возвращает данные, соответствующие структуре и условиям переданного запроса. Запрос к данным передается в виде параметра GET или POST-запроса с именем query. Значение параметра представляет собой xml-документ следующей структуры:

01<query class="TWorker">
02  <item part="what" name="LastName" />
03  <item part="what" name="FirstName"/>
04  <item part="what" name="MiddleName"/>
05  <item part="what" name="BirthDate"/>
06  <item part="what" name="ContactList" value="TPerson.GetContactList" special="function">
07    <parameters>
08      <ContactType>63474</ContactType>
09    </parameters>
10  </item>
11  <item part="where" name="LastName" value="А*"/>
12  <item part="order" name="LastName"/>
13  <item part="order" name="FirstName"/>
14</query>

Элемент query имеет обязательный атрибут class. Значением атрибута class должно быть имя класса или представления, к которому будет выполняться запрос. Также может использоваться необязательный атрибут fetchall, который может принимать значения "0" (значение по умолчанию) или "1". Использование атрибута fetchall подробнее описано ниже в разделе Использование возвращаемого ответа.

Элемент query может включать в себя элементы item, передающие структуру запроса, условия отбора, сортировки, группировки. Элементы item могут включать в себя необязательные элементы (context, parameters, и т.п.; имя этого элемента не анализируется).

Состав атрибутов элемента item (обязательным является только атрибут part, остальные атрибуты можно опускать, в зависимости от использования других атрибутов):

  • part (обязательный атрибут) - часть запроса (what, where, order,...)
  • name - в простом случае (без использования special) - имя свойства класса (или поля представления), которое будет использовано в запросе; при использовании special может быть как именем свойства класса, так и другой строкой (см. подробнее ниже).
  • value - значение, которое в зависимости от значения атрибутов part и special, будет использовано для сравнений или для других целей; в простом случае (если part = "where", special отсутствует) будет использовано для сравнения в условии отбора при выполнении запроса.
  • special - вводит дополнительные возможности формирования запроса (возможности описаны ниже); от использованного значения данного атрибута может зависеть трактовка значений других атрибутов.
  • subQuery
  • joinKey
  • joinLink
  • joinSource

Допустимые значения атрибута part (можно использовать как строковые, так и числовые значения):

Строковое
значение 		Числовое
значение 		Назначение и пример использования
what 0 Элементы со значением "what" (0) атрибута part используются для формирования what-кляузы запроса. В полученном ответе каждому такому элементу будет соответствовать один xml или json элемент с именем, переданным атрибутом name.
<item part="what" name="LastName"/>
Получить значение свойства "LastName".
where 1 Элементы со значением "where" (1) атрибута part используются для формирования условия отбора объектов (where-кляузы запроса).
Для условий допустимо использовать "маску" (*, ?), условия ">", "<", ">=", "<=";
использование значений через ";" будет трактовано как условие "или", использование "&" будет трактовано как условие "и";
для отрицания нужно использовать "!", для условия "not null" нужно использовать "*", для условия "is null" нужно использовать "!*".
Каждый следующий where-элемент добавляет к запросу одно условие "и".
1<item part="where" name="LastName" value="Петров"/>
2<item part="where" name="FirstName" value="А*"/>
Отобрать объекты класса со значением свойства "LastName", равным "Петров", и значениями "FirstName", начинающимися с символа "А".
order 2 Элементы со значением "order" (2) атрибута part используются для управления сортировкой данных в возвращаемом ответе. По умолчанию (без использования атрибута special) будет выполнена сортировка "по возрастанию". Задать сортировку "по убыванию" можно, использовав значение "desc" (7) для атрибута special. Если в запросе использовано несколько элементов "order", то возвращаемый результат будет отсортирован по нескольким полям в том порядке, в котором они указаны в запросе.
1<item part="order" name="LastName/>
2<item part="order" name="BirthDate" special="desc"/>
Отсортировать результат запроса по значению свойства "LastName" по возрастанию, затем по значению свойства "BirthDate" по убыванию.
group 3 Элементы со значением "group" (3) атрибута part используются для управления группировкой данных в возвращаемом ответе. Если в запросе использовано несколько элементов "group", то возвращаемый результат будет сгруппирован по нескольким полям в том порядке, в котором они указаны в запросе. Для свойств, не входящих в условия группировки, можно получать значения агрегатов (количество, наименьшее/наибольшее/среднее и т.п.), используя атрибут special.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="what" name="BirthDate" special="min"/>
4<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region", количество записей в группе и минимальное значение свойства "BirthDate" в этой группе.
having 4 Элементы со значением "having" (4) атрибута part позволяют накладывать условия отбора на группы в запросе с группировкой.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="what" name="BirthDate" special="min"/>
4<item part="group" name="Region"/>
5<item part="having" name="ID" value=">3" special="count"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region", количество записей в группе и минимальное значение свойства "BirthDate" в этой группе, отобрав при этом только такие группы, количество объектов в которых больше 3-х.
innerJoin | 5
outerJoin | 6

Допустимые значения атрибута special (можно использовать как строковые, так и числовые значения):

Строковое
значение 		Числовое
значение 		Части запроса Назначение и пример использования
ID 1 what
where 		Позволяет запрашивать идентификатор объекта или накладывать условия по идентификатору.
1<query class="TWorker">
2  <item part="what" special="ID"/>
3  <item part="what" name="LastName"/>
4  <item part="what" name="FirstName"/>
5  <item part="where" value="5500921" special="ID"/>
6</query>
Получить идентификатор объекта, значения свойств LastName, FirstName объекта с идентификатором, равным 5500921. Ответ на запрос будет содержать элемент с именем ID.
parent 2 what
where 		Позволяет использовать в запросах идентификатор "родителя" объекта.
1<query class="TCountry">
2  <item part="what" special="ID"/>
3  <item part="what" special="parent"/>
4  <item part="what" name="Name"/>
5  <item part="what" name="Description"/>
6</query>
Получить идентификатор объекта, идентификатор родительского объекта, значения свойств Name, Description всех объектов класса TCountry. Ответ на запрос будет содержать элемент с именем Parent.
haschildren 3 what
where 		Признак наличия дочерних объектов в иерархии. Ответ на запрос будет содержать элемент с именем HasChildren и значением "1" в случае наличия дочерних объектов и значением "0" в случае их отсутствия.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" special="haschildren"/>
5</query>
Получить значения свойств Name, Description, а также признак наличия дочерних объектов всех объектов класса TCountry.
filter 4 where Позволяет использовать для отбора условия, заданные доменами, использованными в решении на платформе. Имя или идентификатор домена указывается в атрибуте name. Условие отбора этого домена будет интерпретировано с учетом значений, переданных в дочернем элементе context. Для каждого из этих значений должны быть указаны его имя, домен и значение.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name = "TRegion of UnivCountry domain" special="filter>
5      <context>
6        <UnivCountry domain="4565848">67991</UnivCountry>
7      </context>
8  </item>
9</query>
Получить значения свойств Name, Description объектов класса TCountry, подходящих под условие отбора домена "TRegion of UnivCountry domain", используя значение "67991" вместо идентификатора UnivCountry.
Условие отбора домена "TRegion of UnivCountry domain":
((Self.Parent = UnivCountry) or (Self = UnivCountry))
uplink 5 what
where 		Используется для отбора данных в контексте выбранных родительских объектов. Связь отбираемых объектов с выборкой связанных родительских объектов будет установлена по свойству, переданному атрибутом name. В атрибуте value может быть передан идентификатор одного объекта, список идентификаторов объектов через ";" или идентификатор буфера, в который предварительного сохранен список объектов.
1<query class="TCountry">
2  <item part="where" name="Parent" value="14750" special="uplink"/>
3  <item part="what" name="Name"/>
4  <item part="what" name="Description"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, у которых значение свойства Parent равно "14750" (или входит в состав объектов, сохраненных в буфере с идентификатором "14750").
root 6 where Будут отобраны только объекты, не имеющие родителя, после наложения других условий отбора.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" special="root"/>
5</query>
Получить значения свойств Name, Description "корневых" (не имеющих родителя) объектов класса TCountry.
desc 7 order Используется для сортировки "по убыванию" для элементов с атрибутом part ="order". Без указания атрибута special будет выполнена сортировка "по возрастанию".
1<item part="order" name="LastName"/>
2<item part="order" name="BirthDate" special="desc"/>
Отсортировать результат запроса по значению свойства "LastName" по возрастанию, затем по значению свойства "BirthDate" по убыванию.
count 8 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения количества объектов в группе.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="group" name="Region"/>
4<item part="having" name="ID" value=">3" special="count"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и количество записей в группе, отобрав при этом только такие группы, количество объектов в которых больше 3-х.
sum 9 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения суммы значений свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="PayedSum" special="sum"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и сумму значений свойства "PayedSum" для всех объектов группы.
min 10 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения минимального значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="BirthDate" special="min"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и минимальное значение свойства "BirthDate" среди всех объектов группы.
max 11 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения максимального значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="BirthDate" special="max"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и максимальное значение свойства "BirthDate" среди всех объектов группы.
avg 12 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения среднего значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"
2<item part="what" name="PayedSum" special="avg"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и среднее значение свойства "PayedSum" среди всех объектов группы.
masterLink 13 where Позволят наложить отбор на объекты класса ("подчиненный" класс) в контексте выбранных объектов класса-мастера или класса, связанного с исходным по другому свойству ("главный" класс). В атрибуте name в этом случае передаются имена свойства "главного" класса и свойства "подчиненного" класса, по которым эти классы связаны. Имена свойств указываются следующим образом:
  • Если одним из этих свойств является идентификатор (ID), то имя этого свойства не указывается (это свойство используется по умолчанию)
  • Если оба свойства отличаются от ID, то их имена указываются через разделитель ";", например, "Master;Person"
  • Если только свойство "подчиненного" класса отличается от ID, то указывается только имя этого свойства, например, "Person"
  • Если только свойство "главного" отличается от ID, то вместо свойства-подчиненного указывается *, например, "Master;*"
В свойстве value передается идентификатор буфера, содержащего список выбранных объектов "главного" класса.
1<query class="TContact">
2  <item part="what" name="ContactInfo"/>
3  <item part="what" name="ContactType" special="name"/>
4  <item part="where" name="Person" value="246889" special="masterLink"/>
5</query>
Получить значения свойств ContactInfo, ContactType (Имя) объектов класса TContact, для объектов, список которых сохранен в буфере с идентификатором "246889", связанным с классом TContact по свойству Person.
selectedOnly 14 where Позволят наложить отбор по списку идентификаторов объектов класса, ранее сохраненных в буфере.
1<query class="TPerson">
2  <item part="what" name="LastName"/>
3  <item part="what" name="FirstName"/>
4  <item part="where" value="246889" special="selectedOnly"/>
5</query>
Получить значения свойств LastName, FirstName объектов класса TPerson, список которых сохранен в буфере с идентификатором "246889".
distinct 15 what Позволяет получить все уникальные значения определенного свойства или сочетания значений свойств класса.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" special="distinct"/>
4</query>
Получить набор уникальных значений свойства FirstName класса TPerson.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="MiddleName"/>
4  <item part="what" special="distinct"/>
5</query>
Получить набор уникальных сочетаний значений свойств FirstName и MiddleName класса TPerson.
view 16 where Позволяет при выполнении запроса наложить отбор, используемый для определенного представления. Имя (или идентификатор) представления указывается в атрибуте name.
1<query class="TPerson">
2  <item part="where" name="Persons older 25" special="view"/>
3  <item part="what" name="FirstName"/>
4  <item part="what" name="LastName"/>
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, соответствующих условиям отбора представления Persons older 25.
caseInsensitive 17 where Позволяет наложить отбор на значение свойства строкового типа без учета регистра. Без использования special поиск ведется с учетом регистра.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="LastName"/>
4  <item part="where" name="FirstName" value="АНДРЕЙ" special="caseInsensitive"/>
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, с отбором по значению свойства FirstName без учета регистра символов. TPerson.
string 18 where Позволят явно приводить к строковому типу значения свойства, переданного атрибутом name.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="Code" value="00002" special="string"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, со значением свойства Code, равным "00002".
listed 19 where Позволяет выполнять отбор по списку объектов, входящих в список, сохраненный в системе как объект класса TObjectList ("Списки"), идентификатор которого нужно передать в качестве значения атрибута value.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="ID" value="5245654" special="listed"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, входящих в список, сохраненный как объект класса TObjectList с идентификатором "5245654".
name 20 what
where 		Для свойств-ссылок на объекты позволяет получить Имя объекта, переданного атрибутом name. В полученном ответе соответствующий элемент будет иметь имя ИмяСвойства-N.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Parent"/>
5  <item part="what" name="Parent" special="name"/>
6</query>
Для всех объектов класса TCountry получить значения свойств Name, Description, Parent, а также Имя объекта Parent.
description 21 what
where 		Для свойств-ссылок на объекты позволяет получить Наименование объекта, переданного атрибутом name. В полученном ответе соответствующий элемент будет иметь имя ИмяСвойства-D.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Parent"/>
5  <item part="what" name="Parent" special="description"/>
6</query>
Для всех объектов класса TCountry получить значения свойств Name, Description, Parent, а также Наименование объекта Parent.
function 22 what
where 		Позволяет использовать значения, полученные в результате вызова функций, как в элементах с атрибутом part ="what", так и в элементах с атрибутом part ="where". Имя функции должно быть передано в атрибуте value в формате Имя класса.Имя функции. Если функция имеет параметры, то для их передачи необходимо добавить дочерний элемент context, со своими дочерними элементами для каждого из параметров в формате <ИмяПараметра>Значение параметра</ИмяПараметра>. Если функция является "методом объекта", параметр "ID" добавлять не нужно, он будет использован автоматически. В элементах с атрибутом part ="what" значение атрибута name может быть любым, оно не будет использовано при выполнении запроса, но станет именем элемента данных в получаемом ответе.
01<item part="what" name="InitAndLast" value="TPerson.GetInitAndLast" special="22"/>
02<item part="what" name="ContactList" value="TPerson.GetContactList" special="22">
03  <context>
04    <ContactType>63474</ContactType>
05  </context>
06</item>
07<item part="where" name="TWorker.IsSuperior" value="1" special = "function">
08  <context>
09    <OtherWorker>625186</OtherWorker>
10    <Department></Department>
11  </context>
12</item>
Получить результат выполнения функции GetInitAndLast класса TPerson (функция не имеет параметров), получить результат выполнения функции GetContactList класса TPerson с параметром ContactType = 625186. Отобрать только те объекты, для которых результат выполнения функции IsSuperior класса TWorker равен "1". Функция IsSuperior вызывается со значением 625186 параметра OtherWorker и пустым значением параметра Department.
countdistinct 23 what
having 		Позволяет получить количество уникальных значений свойства.
1<query class="TPerson">
2  <item part="what" name="FirstName" special="countdistinct"/>
3</query>
Получить количество уникальных значений свойства FirstName класса TPerson.
boolean 24 what
where 		Позволят приводить к "логическому" типу значения свойства, переданного атрибутом name. Приведение выполняется по следующему принципу:
  • значение Null преобразуется в пустое значение в ответе
  • значение "0" остается значением "0" в ответе
  • любое непустое значение преобразуется в значение "1" в ответе
Такая возможность позволяет, например, более эффективно (без получения самих значений) определять пустоту/непустоту значений типа "большой объект".
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Code" special="boolean"/>
5</query>
Получить значения свойств Name, Description, а также значение свойства Code, преобразованное к "логическому" всех объектов класса TCountry.
exact 25 where При использовании значения "exact" (25) атрибута special значение, переданное в атрибуте value, будет использовано "как есть" - без преобразования типов, без трактовки символов "*", "?" как маски и т.п.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="Code" value = "002*25?" special="exact"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry со значением свойства Code, равным "002*25?".
searchindex 26 where Позволяет использовать индексы полнотекстового поиска при отборах. Поиск по выполняться по всем полям класса, значение атрибута name будет проигнорировано.
1<query class="TMailMessage">
2  <item part="what" name="Theme"/>
3  <item part="what" name="Body"/>
4  <item part="what" name="Created"/>
5  <item part="where" value="приглашаем *на семинар *Современные" special="searchindex">
6</query>
Получить значения свойств Theme, Body, Created объектов класса TMailMessage, среди значений свойств которых будет найдена указанная строка, с использованием индекса полнотекстового поиска.
optimization 27 where Позволяет использовать имеющиеся подсказки оптимизатору при выполнении запроса.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="LastName"/>
4  <item part="what" value="ORARefreshOnFetch=true;APPRefreshOnFetch=true" special="optimization">
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, используя при выполнении запроса подсказки оптимизатору.

6.1. Использование возвращаемого ответа

При корректном выполнении запроса ответ будет представлять собой набор данных следующей структуры:

  • При использовании формата xml будет возвращен xml-документ с корневым элементом data, который будет иметь атрибуты handle (GUID) и eof ("1" или "0"). Элемент data будет иметь подчиненные элементы row, каждый из которых будет соответствовать одной записи, полученной при выполнении запроса. Каждый элемент row будет иметь подчиненные элементы, соответствующие what-элементам запроса.
  • При использовании формата JSON будет возвращен JSON-объект, содержащий пары ключ-значение handle (значение типа GUID), eof (значения "0" или "1") и data. Значением data будет массив пар ключ-значение, каждая из которых будет соответствовать одной записи, полученной при выполнении запроса.

Обработчик сервера приложений, обеспечивающий работу функций RESTfull-сервисов, в том числе функции cursor, имеет параметры, ограничивающие размер пакета возвращаемых данных, выраженные в количестве объектов в ответе и в объеме ответа в байтах. В случае, если размер ответа укладывается в оба этих ограничения, все полученные данные будут возвращены полностью, и в ответе будет передан атрибут (значение) eof="1". В случае, если размер ответа превысит одно из ограничений, и при этом в запросе атрибут fetchall не задан или равен "0", то в ответ войдет только такой набор записей, который позволит соблюсти ограничения, и при этом в ответе будет передан атрибут (значение) eof="0". Если в запросе был передан атрибут fetchall="1", то будет выполнена попытка вернуть весь ответ полностью, несмотря на установленные ограничения. При успешной передаче атрибут (значение) eof будет равен "1".

Пример запроса:
1  <query class="TWorker" fetchall="1">
2    <item part="0" name="LastName"/>
3    <item part="0" name="FirstName"/>
4    <item part="0" name="BirthDate"/>
5    <item part="0" name="AcademicStatus"/>
6    <item part="1" name="BirthDate" value=">12.05.2000"/>
7  </query>
Пример ответа в формате xml:
01  <data handle="{FDF9EE70-9948-4A99-8233-349C3ADD3CE8}" eof="1">
02    <row>
03      <LastName>Абишин</LastName>
04      <FirstName>Вячеслав</FirstName>
05      <BirthDate type="date">10.06.2014</BirthDate>
06      <AcademicStatus>к.э.н.</AcademicStatus>
07    </row>
08    <row>
09      <LastName>Агринская</LastName>
10      <FirstName>Ольга</FirstName>
11      <BirthDate type="date">24.08.2016</BirthDate>
12      <AcademicStatus>PhD</AcademicStatus>
13    </row>
14    <row>
15      <LastName>Абрамов</LastName>
16      <FirstName>Александр</FirstName>
17      <BirthDate type="date">05.09.2016</BirthDate>
18     <AcademicStatus/>
19    </row>
20  </data>
Пример ответа в формате JSON:
01  {
02      "handle": "{C57F629E-583C-4477-ACBF-E436F6D01628}",
03      "eof": true,
04      "data": [
05          {
06              "LastName": "Абишин",
07              "FirstName": "Вячеслав",
08              "BirthDate": {
09                  "year": 2014,
10                  "month": 5,
11                  "day": 10
12              },
13              "AcademicStatus": "к.э.н."
14          },
15          {
16              "LastName": "Агринская",
17              "FirstName": "Ольга",
18              "BirthDate": {
19                  "year": 2016,
20                  "month": 7,
21                  "day": 24
22              },
23              "AcademicStatus": "PhD"
24          },
25          {
26              "LastName": "Абрамов",
27              "FirstName": "Александр",
28              "BirthDate": {
29                  "year": 2016,
30                  "month": 8,
31                  "day": 5
32              },
33              "AcademicStatus": null
34          }
35      ]
36  }

Значение eof = "1" означает, что данные получены полностью. Если в ответе такого значения (атрибута) нет, или eof = "0", это означает, что получены не все данные. Дополучить эти данные можно, повторно выполнив вызов функции cursor, передав в качестве значения параметра query полученное при первом вызове значение handle.
https://techmill.ru/demo/cursor.xml?query={FDF9EE70-9948-4A99-8233-349C3ADD3CE8}
В ответе на запрос с использованием handle вернется то же самое значение handle. Таким образом, запрос можно повторять с одним и тем же значением handle до тех пор, пока в ответе не будет получено eof = "1", что позволит убедиться в том, что данные получены полностью.

7. Функция excelreport

Функция excelreport позволяет вызывать на выполнение отчеты класса TExcelTemplate и получать файлы, формируемые как результат выполнения отчетов. Файлы могут быть возвращены как в форматах Excel (.xls,.xlsx), так и с преобразованием в другие форматы. Исключением являются интерактивные отчеты (требующие при формировании диалога с пользователем). Такие отчеты не могут вызваться при помощи данной функции.

Допустимые расширения:

  • .xls - для получения файла отчета в формате XLS
  • .xlsx - для получения файла отчета в формате XSLX
  • .html - для получения файла отчета в формате HTML; поддерживается формирование html-документа в монохромном цветовом режиме, в режиме "в градациях серого"
  • .pdf - для получения файла отчета в формате PDF; поддерживаются способы преобразования.xls/.xslx-файла в pdf-документ как средствами платформы, так и средствами самого Excel; возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"
  • .xps - для получения файла отчета в формате XPS

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, отчет которого будет вызываться
  • "template" (обязательный) - имя отчета, который будет вызываться
  • "format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:
    • цветовой режим - допустимые значения "mono", "grey"; значение по умолчанию - "обычный" цветовой режим
    • внедрение шрифтов (для формата PDF) - допустимые значения "embed", "embedded"; значение по умолчанию - без внедрения шрифтов
    • способ преобразования (для случая преобразования в формат PDF) - допустимое значение "native"; значение по умолчанию - средствами платформы "Мельница данных" в случае, если такой способ реализован; иначе - средствами приложения MS Office.
    • тип файла результата - допустимые значения совпадают с возможными расширениями вызова функции (без дополнительной точки)
  • "filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="StatisticReport.embed.pdf", что будет говорить о том, что будет возвращен pdf-документ с внедренными шрифтами.
    Значение по умолчанию: "excelreport" с расширением, совпадающим с расширением вызываемой функции.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного атрибутами параметра query или расширением функции excelreport (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове Excel-отчета:
1  <execute class="TSchoolAbiturSt" template="RegStatistics" format="mono.embed.native.pdf" filename="StatisticReport.pdf">
2    <row>
3      <AdmissionYear>7427462</AdmissionYear>
4      <AdmStage>8608398</AdmStage>
5      <PrevAdmissionYear>6843737</PrevAdmissionYear>
6      <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
7    </row>
8  </execute>
При таком вызове будет выполнен Excel-отчет "RegStatistics" класса "TSchoolAbiturSt" с параметрами, переданными в элементе row. Данный отчет является "методом класса", поэтому параметр "ID" в состав параметров не добавлен. Полученный файл отчета будет преобразован в формат PDF с внедрением шрифтов в монохромном режиме. Преобразование будет выполнено средствами приложения MS Excel. В качестве ответа будет возвращен .pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("StatisticReport.pdf"), в содержимом ответа будет передано содержимое файла.

7.1. Принципы разбора информации о формате результирующего файла

Информация о формате файла, который будет сформирован и возвращен в качестве ответа, может быть извлечена из атрибутов xml-документа запроса, или из расширения функции. Порядок разбора переданной информации следующий:

  1. Значение атрибута format. Если данный атрибут указан, но в нем нет одной из составляющих формата, то для этой составляющей будет использовано значение по умолчанию (значение из атрибута filename использовано не будет).
  2. Значение атрибута filename. В этом атрибуте, кроме имени файла как такового и его расширения, может передаваться информация о цветовом режиме (.mono/.grey,...), внедрении шрифтов (.embed/.embedded), способе преобразования файла (.native). Значения для этих составляющих будут получены из атрибута filename только в случае, если атрибут format не указан при вызове.
  3. Расширение будет получено из расширения вызываемой функции. Для других составляющих формата будут использованы значения по умолчанию.

Строка, определяющая формат, разбирается как последовательность элементов, разделенных символом "." (точка). Элементы разбираются последовательно, независимо друг от друга, и имеют следующие значения:

mono | Формируется монохромный документ
grey | Формируется документ в градациях серого
embedded | Шрифты внедряются в выходной документ
native | Используется встроенный в MSOffice механизм формирования документов
PDF | Выгружается файл в формате PDF
HTML | Выгружается файл в формате HTML
BMP | Выгружается файл в формате BMP
RTF | Выгружается файл в формате RTF
DOC | Выгружается файл в формате DOC
XLS | Выгружается файл в формате XLS
DOCX | Выгружается файл в формате DOCX
XLSX | Выгружается файл в формате XLSX
XPS | Выгружается файл в формате XPS

Остальные элементы игнорируются. Порядок следования элементов не важен.

Строка формата "pdf.mono.embedded" указывает сформировать монохромный документ в формате PDF со встроенными шрифтами.

8. Функция execute

Функция execute позволяет вызывать методы, доступные для вызова через обработчик сервера приложений, получать результат выполнения методов.

Допустимо использовать любые расширения, в том числе не указывать расширение. Расширение повлияет на формат возвращаемого результата следующим образом:

  • .xml - для получения результата выполнения в формате xml
  • .js/.json - для получения результата выполнения в формате JSON
  • пустое расширение - результат выполнения будет возвращен в формате xml
  • другие расширения - имеет смысл использовать в случаях, когда результатом выполнения метода является "большой объект" (blob, clob) и его тип известен; это позволит получить результат в виде файла или структуры данных определенного типа (.xslt,.pdf, форматы изображений и т.п.)
    если результат выполнения не удастся привести к формату, заданному расширением, результат будет возвращен в формате xml

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый метод и значения его параметров. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, метод которого будет вызываться
  • "method" (обязательный) - имя метода, который будет вызываться

Корневой элемент xml-документа может содержать список узлов row, каждый из которых определяет набор параметров для вызова метода. Таким образом, при помощи одного вызова функции (одним обращением к url) можно вызывать один и тот же метод для набора объектов.

Принципы передачи параметров для вызова метода, включая использование параметров типа "большой объект", описаны в статье Принципы передачи параметров функциям RESTful-service.

Для вызова методов экземпляра необходимо указывать значение неявного параметра с именем "ID". Значением этого параметра должен быть идентификатор объекта, для которого вызывается метод.

01  <execute class="TPerson" method="GetContactList">
02    <row>
03      <ID>931669</ID>
04      <ContactType>63478</ContactType>
05    </row>
06    <row>
07      <ID>76443</ID>
08      <ContactType>63478</ContactType>
09    </row>
10  </execute>

Получить результат вызовов метода GetContactList класса TPerson для объектов с идентификаторами (ID), равными 931669 и 76443 и со значением параметра ContactType, равным 63478.

Пример ответа:

1  <data eof="1">
2    <row>
3      <Result>8-903-73-210-73</Result>
4    </row>
5    <row>
6      <Result>8-916-862-27-77; 8-916-862-2777</Result>
7    </row>
8  </data>

Если возвращаемый результат имеет домен класса "большой объект" (clob, clob, "внешний файл"), то возвращаемое значение может быто подвергнуто пост-обработке. Подробнее этот случай описан в разделе: Особенности передачи возвращаемых значений типа "большой объект"

8.1. Принципы передачи параметров функциям RESTful-service

При вызове функций RESTful-service стандартного обмена применяются следующие принципы передачи и связывания параметров:

  1. Параметры связываются по их именам. Порядок указания параметров при вызове функции не существенен.
  2. Если вызываемый метод или отчет является "методом класса", то дополнительно должен быть передан параметр "ID" со значением идентификатора объекта, для которого вызывается метод или отчет.
  3. Если параметр имеет clob-домен подтипов "btHTML" (HTML-документ), "btXHTML" (XHTML-документ), то содержимое такого документа будет "обезврежено" (будут удалены ссылки, скрипты и т.п.)
  4. Если вызываемый метод имеет параметр blob-домена, но при его вызове в xml-документе не найден узел с таким именем, то будет выполнен поиск параметра с тем же именем среди параметров сессии. Если такой параметр сессии будет найден, то его значение будет передано в качестве blob-значения одноименного параметра вызываемого метода. При этом в случае, если параметр имеет blob-домен подтипа "btNamedFile" (Именованный файл), то содержимое файла будет взято из одноименного параметра сессии (например, "param1"), а имя файла будет взято из параметра сессии с именем, дополненным постфиксом ".filename" (например, "param1.filename").
  5. Если вызываемый метод имеет параметр blob-домена с подтипом "btImage" (Изображение), то для переданного значения будет предпринята попытка его преобразования в формат, заданный свойством "Расширение" домена.
  6. В других случаях переданное или найденное в параметрах сессии blob/clob значение будет передано "как есть" в качестве значения параметра при вызове метода.
  7. Если для параметра было использовано значение параметра сессии, то такой параметр удаляется из сессии после вызова функции (повторное использование параметра сессии невозможно).

8.2. Особенности передачи возвращаемых значений типа "большой объект"
Если функция сервиса имеет возвращаемое значение, имеющее домен типа blob, clob или "внешний файл", то такое значение может быть подвергнуто пост-обработке по следующим принципам:
  1. Если задано расширение .js или .json, атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет clob-домен или домен "Внешние данные" подтипа "btJavaScript" (Скрипт JavaScript), то будет возвращено полученное из метода значение "как есть" (без каких-либо дополнительных преобразований)
  2. Если задано расширение .xml, атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет clob-домен или домен "Внешние данные" подтипа "btXML" (XML-документ) или "btXHTML" (XHTML-документ), то будет возвращено полученное из метода значение "как есть" (без каких-либо дополнительных преобразований)
  3. При использовании других расширений, если атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет blob-домен подтипа "btNamedFile" (Именованный файл), то в заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.
  4. Если для атрибута "noanalyze" будет передано значение "1", и при этом возвращаемое значение имеет blob-домен и его размер окажется большим, то возвращаемое значение будет сохранено в параметре сессии, а в xml-ответе будет представлен только его идентификатор.
  5. Во всех других случаях возвращаемое значение типа "большой объект" (blob) будет двоично закодировано и возвращено в разделе CDATA xml-документа.

9. Функция executeoleobjectmethod

Функция executeoleobjectmethod позволяет вызывать методы OLE-объекта, доступные для вызова через обработчик сервера приложений, получать результат выполнения методов. Исключением методы не могут вызваться при помощи данной функции.

Допустимо использовать любые расширения, в том числе не указывать расширение. Расширение повлияет на формат возвращаемого результата следующим образом:

  • .xml - для получения результата выполнения в формате xml
  • .js/.json - для получения результата выполнения в формате JSON
  • пустое расширение - результат выполнения будет возвращен в формате xml
  • другие расширения - имеет смысл использовать в случаях, когда результатом выполнения метода является "большой объект" (blob, clob) и его тип известен; это позволит получить результат в виде файла или структуры данных определенного типа (.xslt,.pdf, форматы изображений и т.п.)
    если результат выполнения не удастся привести к формату, заданному расширением, результат будет возвращен в формате xml

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый метод и значения его параметров. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, метод которого будет вызываться
  • "method" (обязательный) - имя метода OLE-объекта, который будет вызываться

Корневой элемент xml-документа может содержать список узлов row, каждый из которых определяет набор параметров для вызова метода. Таким образом, при помощи одного вызова функции (одним обращением к url) можно вызывать один и тот же метод для набора объектов.

Принципы передачи параметров для вызова метода, включая использование параметров типа "большой объект", описаны в статье Принципы передачи параметров функциям RESTful-service.

Для вызова методов экземпляра необходимо указывать значение неявного параметра с именем "ID". Значением этого параметра должен быть идентификатор объекта, для которого вызывается метод.

1  <execute class="TBachAbiturSt" method="AddComposition">
2    <row>
3      <ID>7927267</ID>
4      <AdmissionYear>6617171</AdmissionYear>
5      <CompYear>5639232</CompYear>
6      <Theme>742348353</Theme>
7    </row>
8  </execute>
Получить результат вызовов метода AddComposition класса TBachAbiturSt для объекта с идентификаторами (ID), равными 7927267 и с параметрами, заданными в элементе row.

Если возвращаемый результат имеет домен класса "большой объект" (clob, clob, "внешний файл"), то возвращаемое значение может быто подвергнуто пост-обработке. Подробнее этот случай описан в разделе: Особенности передачи возвращаемых значений типа "большой объект"

10. Функция getblob

Функция getblob позволяет сторонним приложениям или веб-страницам формировать ссылки на содержимое, хранящееся как значение свойства объекта системы типа "большие данные" (изображения, файлы и т.п.).

При вызове функции допустимо указывать любые расширения. Расширение должно определяться содержимым, которое ожидается получить. В случае, если об этом нет достаточной информации, можно вызывать функцию с пустым расширением.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

  • class (обязательный) - имя класса, значение свойства которого нужно получить
  • propname (обязательный) - имя свойства, значение свойства которого нужно получить
  • id (обязательный) - идентификатор объекта, свойство которого нужно получить
  • filename - имя файла, которое будет использовано для полученного файла; если свойство имеет домен подтипа "Именованный файл", то имя файла будет получено из свойства, значение которого запрашивается, иначе будет использовано значение данного атрибута
  • disposition - если для данного атрибута будет указано значение "inline", то будет предпринята попытка открыть содержимое в браузере (на отдельной вкладке или встроить в страницу); если атрибут не указан, то будет выполняться скачивание файла; атрибут применим для изображений, PDF-документов
  • width, height - атрибуты применимы в случае, если функция вызывается с расширениями .jpg или .png, или если содержимое является изображением;
    в случае, если данные атрибут указаны, будет произведена попытка сжать/растянуть изображение под указанные размеры ширины и высоты
1https://techmill.ru/demo/getblob?query=
2<query class="TPersonalDocument" propname="DocFile" ID="4562944" filename="DocumentCopy1.pdf"/>
Будет выполнена попытка получения файла PDF-документа и его скачивание.

11. Функция imagelist

Функция imagelist позволяет получить набор изображений, хранящихся в системе как значения свойства определенного класса, в компактном виде, удобном для их дальнейшего использования.

Допустимые расширения:

  • .png - для получения ответа в виде PNG-файла
  • .js / .json - для получения ответа в формате JSON

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

  • class (обязательный) - имя или идентификатор класса, значение свойства которого содержит изображения
  • proprty (обязательный) - имя свойства, значения свойства которого содержат изображения
  • width, height - ширина и высота в пикселях, к которой будут приведены отдельные изображения; если эти значения не указаны, используются значения по умолчанию 32х32
  • perrow - количество изображений в одной строке при компоновке изображений; если это значение не указано, используются значение по умолчанию 12

Элемент query может иметь дочерние узлы item, за счет которых можно передать условия отбора, которые будут наложены на записи класса. Если узлы item не будут добавлены, то изображения будут получены из всех записей класса (без условий отбора).
Узлы item должны иметь атрибут part со значением where, в остальном набор атрибутов и принципы формирования узлов item совпадают с принципами использования узлов item part="where"... в функции cursor (Функция cursor) для задания условий отбора запроса.

При вызове функции с расширением .png в качестве результата будет возвращено содержимое.png-файла с набором изображений.

При вызове функции с расширением .js или .json результат будет представлять собой JSON-объект с набором полей id: index, где id - идентификатор объекта класса, index - порядковый номер изображения в структуре изображений, после которых будут следовать поля

  • .filename: "запрос на получение.png-файла"
  • .width: "32"
  • .height: "32"
  • .perrow: "12"

Вызов функции с расширением.png:
techmill.ru/sup/imagelist.png?query=<query class='TAvatar' property='Image' width='32' height='32'/>
Вызов функции с расширением.js:
techmill.ru/sup/imagelist.js?query=<query class='TAvatar' property='Image' width='32' height='32'/>
Результат, возвращаемый при вызове с расширением.js:
01{
02"12008":0,
03"12009":1,
04"12010":2,
05"13917":3,
06"27570":4,
07"68807":5,
08"1786530":6,
09"6574243":7,
10"9376694":8,
11"9376695":9,
12"38740400":10,
13"39019504":11,
14"39019505":12,
15"118496347":13,
16".filename":"/sup/imagelist.png?query=%3Cquery%20class%3D%27TAvatar%27%20property%3D%27Image%27%20width%3D%2732%27%20height%3D%2732%27%20perrow%3D%2712%27/%3E",
17".width":32,
18".height":32,
19".perrow":12}

12. Функция loadexternaldata

Функция loadexternaldata позволяет получить файл из файлового хранилища по идентификатору файла в хранилище.

Допустимые расширения:

  • .xml
  • другие расширения, которые будут соответствовать типу и расширению запрашиваемого файла.

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент loadexternaldata с атрибутами

  • domain - имя или идентификатор домена "внешних данных"
  • value - идентификатор файла в файловом хранилище
Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

1https://techmill.ru/demo/loadexternaldata.xml?query=
2<loadexternaldata domain="TPhotoFile" value="{D4A74981-336D-474B-9585-11716BA4232B}">
3</loadexternaldata>

В качестве результата выполнения функции будут возвращены двоичные данные запрошенного файла.

13. Функция partitions

Функция partitions позволяет получить информацию о количестве объектов, возвращаемых запросом с разбиением на группы определенного размера, по каждой группе получить минимальный и максимальный идентификатор объектов и количество объектов в группе.

Допустимое расширение: .xml.

Функция имеет параметр query, значением которого должен быть.xml-документ, содержащий информацию о запросе к данным, который должен быть выполнен, и о размере групп, на которые должен быть разделен результат. Структура xml-документа должна повторять структуру, используемую при вызове функции cursor (см. Функция cursor) со следующими отличиями:

  1. Элемент query, в дополнение к обязательному атрибуту class, должен иметь еще один обязательный атрибут chunksize - размер группы (целое число - количество записей в группе).
  2. Узлы item со значениями атрибута part, равными what, можно не добавлять, в запросе всегда будет использоваться только идентификатор объекта (свойство ID).
  3. Узлы item со значениями атрибута part, равными order, group, having использоваться не должны. При выполнении запроса группировка применяться не будет, а сортировка всегда будет выполняться по идентификаторам объектов (свойство ID) по убыванию.
  4. Результат, возвращаемый функцией, всегда будет возвращен полностью, независимого от переданного значения атрибута fetchall.

В качестве результата функция вернет XML-документ с элементом data с атрибутом eof="1", имеющий дочерние узлы row, соответствующие каждой полученной группе. Каждый узел row будет иметь следующий набор дочерних узлов:

  • min - минимальный ID в группе объектов;
  • max - максимальный ID в группе объектов;
  • count - количество объектов в группе; во всех узлах row, кроме последнего значение count будет равно значению атрибута chunksize, переданному в запросе.
Узлы row будут отсортированы по убыванию значений ID объектов.

Пример запроса:
1  https://techmill.ru/demo/partitions.xml?query=
2    <query class="TPerson" chunksize="1000">
3      <item part="0" name="ID"/>
4      <item part="1" name="TaxID" value="*"/>
5    </query>
Пример ответа:
01  <data eof="1">
02    <row>
03      <Min type="int64">76211</Min>
04      <Max type="int64">1158488</Max>
05      <Count type="int">1000</Count>
06    </row>
07    <row>
08      <Min type="int64">1158489</Min>
09      <Max type="int64">2112571</Max>
10      <Count type="int">1000</Count>
11    </row>
12    <row>
13      <Min type="int64">2112572</Min>
14      <Max type="int64">6605306</Max>
15      <Count type="int">1000</Count>
16    </row>
17    <row>
18      <Min type="int64">6605312</Min>
19      <Max type="int64">8424606</Max>
20      <Count type="int">1000</Count>
21    </row>
22    <row>
23      <Min type="int64">8424612</Min>
24      <Max type="int64">739895343</Max>
25      <Count type="int">1000</Count>
26    </row>
27    <row>
28      <Min type="int64">739895363</Min>
29      <Max type="int64">742336003</Max>
30      <Count type="int">121</Count>
31    </row>
32  </data>

14. Функция paste

Функция paste используется для вставки данных при выполнении операций Копировать/Вставить в приложении Обозреватель данных.

Функция имеет расширение .xml.

Значение параметра функции "query" должно представлять собой XML-документ с элементом paste, который должен включать в себя элемент root, представляющий собой стандартную XML-реплику со значениями свойств вставляемых объектов.

Элемент paste должен иметь атрибуты:

  • ClassID - идентификатор класса, объекты которого будут "вставлены"
  • ParentViewCurrentRecordID - идентификатор объекта, выбранного в "родительской" таблице данных в момент выполнения "вставки"
  • ParentClassID - идентификатор класса, отображаемого в "родительской" таблице данных в момент выполнения "вставки"
  • LinkMasterPropertyID, LinkDetailPropertyID - идентификаторы свойства-главного и свойства-подчиненного, по которым таблица данных, в которую выполняется вставка, связана с "родительской" таблицей данных

При удачном выполнении "вставки" функция вернет список идентификаторов добавленных объектов.

01https://techmill.ru/demo/paste.xml?query=
02  <paste ClassID="7291"
03       LinkDetailPropertyID="348"
04       LinkMasterPropertyID=""
05       ParentClassID="7291"
06       ParentViewCurrentRecordID="2559350">
07  <root Class="7291"
08        Connection="demo - techmill.ru/demo"
09        DBGUID="{C84A02C7-51EA-4068-A0BD-D6FB0BAD15F4}">
10    <object Class="7291" ID="1384201" IsMainObject="1" Parent="1384183">
11      <Description>сентябрь 2023/2024 учебный год</Description>
12      <LearnPeriodType IDREF="10849"/>
13      <BeginDate>2023-09-01</BeginDate>
14      <EndDate>2023-09-30</EndDate>
15      <PeriodNumber>9</PeriodNumber>
16      <LastMarkDate/>
17      <Name>сентябрь</Name>
18      <Creator IDREF="1276001"/>
19      <Created>2023-03-21 17:54:59</Created>
20      <Modifier IDREF="1276001"/>
21      <Modified>2023-05-06 00:00:42</Modified>
22      <Reader/>
23      <Writer IDREF="7001"/>
24    </object>
25    <object Class="7291" ID="1384203" IsMainObject="1" Parent="1384183">
26      <Description>октябрь 2023/2024 учебный год</Description>
27      <LearnPeriodType IDREF="10849"/>
28      <BeginDate>2023-10-01</BeginDate>
29      <EndDate>2023-10-31</EndDate>
30      <PeriodNumber>10</PeriodNumber>
31      <LastMarkDate/>
32      <Name>октябрь</Name>
33      <Creator IDREF="1276001"/>
34      <Created>2023-03-21 17:54:59</Created>
35      <Modifier IDREF="1276001"/>
36      <Modified>2023-05-06 00:00:42</Modified>
37      <Reader/>
38      <Writer IDREF="7001"/>
39    </object>
40  </root>
41</paste>

15. Функция pdfreport

Функция pdfreport позволяет вызывать на выполнение отчеты класса TPDFTemplate и получать файлы, формируемые как результат выполнения отчетов.

Допустимые расширения:

  • .pdf - возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, отчет которого будет вызываться
  • "template" (обязательный) - имя отчета, который будет вызываться
  • "format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:
    • цветовой режим - допустимые значения "mono", "grey"; значение по умолчанию - "обычный" цветовой режим
    • внедрение шрифтов (для формата PDF) - допустимые значения "embed", "embedded"; значение по умолчанию - без внедрения шрифтов
  • "filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="Consent.mono.embed.pdf", что будет говорить о том, что будет возвращен pdf-документ, сформированный в монохромном режиме с внедренными шрифтами; значение по умолчанию: "pdfreport.pdf".

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата PDF, сформированный в режиме, определенном атрибутами параметра query (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове PDF-отчета:
1  <execute class="TBachAbiturSt" template="ConsEnrollment" format="grey.embedded.pdf" filename="Consent.pdf">
2    <row>
3      <ID>7926329</ID>
4      <BachCompetition>4327519</BachCompetition>
5      <PlaceType>7927327</PlaceType>
6    </row>
7  </execute>
При таком вызове будет выполнен PDF-отчет "ConsEnrollment" класса "TBachAbiturSt" с параметрами, переданными в элементе row. Данный отчет является "методом объекта", поэтому дополнительно использован параметр "ID". Полученный файл отчета будет сформирован с внедрением шрифтов в цветовом режиме "в градациях серого". В качестве ответа будет возвращен.pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("Consent.pdf"), в содержимом ответа будет передано содержимое файла.

16. Функция postblob

Функция postblob позволяет установить значение поля таблицы, имеющее тип "большой объект". Функция может вызываться под пользователем, имеющим права доступа на запись к таблицам СУБД.

Функция имеет расширение .xml.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

  • id (обязательный) - идентификатор объекта, свойство которого нужно получить, или список идентификаторов объектов, разделенных ";" при передаче списка объектов для всех этих объектов будет установлено одинаковое значение поля
  • table (обязательный) - имя таблицы, содержащей поле, значение свойства которого нужно установить
  • field (обязательный) - имя поля таблицы, значение свойства которого нужно установить
  • subtype (обязательный) - порядковый номер элемента перечисления "TBlobSubtype" (Подтипы), определяющий подтип домена класса "большой объект", использованного для устанавливаемого значения

В качестве значения элемента query должно быть передано устанавливаемое значение в двоичном формате. При передаче этого значения функции могут быть выполнены преобразования, описанные в статье Принципы передачи параметров функциям RESTful-service.

1https://techmill.ru/demo/postblob.xml?query=
2    <query id="76328;5256545" table="TPersonPhoto" field="FPhotoFile" subtype="2">
3      <![CDATA[Q09NUFJFU1NFRAAABwAAADExMS5ibXBCTRYBAAAAAAAAPgAAACgAAAAiAAAAGwAAAAEAAQAAAAAA2AAAAMQOAADEDgAAAAAAAAAAAAAAAAAA////AP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/B/wf8AAAAD8H/B/wAAAAPwf8H/AAAAA/B/wf8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAA==]]>
4    </query>

17. Функция routinelog

Функция routinelog предназначена для создании записей истории вызова подпрограммы (метода, метода OLE-объекта, отчета) и набора значений параметров без вызова самой этой подпрограммы. Запись об истории вызова создается как объект класса "Вызовы" (TRoutineHistory) записи о значениях параметра создаются как объекты класса "Параметры вызовов" (TParameterHistory).

Допустимое расширение: .xml.

Функция имеет параметр query, который должен представлять собой XML документ, содержащий информацию о подпрограмме и значениях ее параметров. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент XML-документа должен иметь атрибут routine, значением которого должен быть идентификатор подпрограммы. Элемент должен иметь набор узлов, соответствующих параметрам подпрограммы и их значениям.

При передаче информации о параметрах необходимо учитывать Принципы передачи параметров функциям RESTful-service.

1https://techmill.ru/demo/routinelog.xml?query=
2<query routine="756584">
3  <AdmissionYear>7427462</AdmissionYear>
4  <AdmStage>8608398</AdmStage>
5  <PrevAdmissionYear>6843737</PrevAdmissionYear>
6  <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
7</query>

При успешном выполнении функции будет возвращен ответ с одним пустым элементом <data eof="1"/>.

18. Функция rtti

Функция rtti позволяет получить информацию о типах (run-time type information, RTTI) в форматах XML или JSON.

Допустимые расширения:

  • .xml - для получения ответа в формате XML
  • .js/.json - для получения ответа в формате JSON

Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/rtti.xml

В качестве ответа будет возвращен XML-документ или JSON полученный рядом запросов к метаданных системы. Ответ будет состоять из элементов data, соответствующих каждому запросу, которые имеют узлы row на каждую запись возвращаемых данных. Для каждой записи будут узлы с именами, совпадающими со значениями свойств и значениями этих свойств.

Пример ответа:
01<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
02  ...
03</data>
04<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
05  <row>
06    <ID>1669</ID>
07    <Name>TFolder domain</Name>
08    <Description>Папка</Description>
09    <Required type="int">1</Required>
10    <Length type="int">255</Length>
11    <FolderMustExist type="int">1</FolderMustExist>
12  </row>
13</data>
14<data eof="1" handle="{06399069-7150-4087-8ACB-D14C809497C2}">
15  <row>
16    <ID>28</ID>
17    <Name>Boolean</Name>
18    <Description>Обычное логическое</Description>
19    <Required type="int">1</Required>
20    <TrueValue>Да</TrueValue>
21    <FalseValue>Нет</FalseValue>
22  </row>
23  <row>
24    <ID>170</ID>
25    <Name>Non-required boolean</Name>
26    <Description>Необязательное логическое</Description>
27    <Required type="int">0</Required>
28    <TrueValue>Да</TrueValue>
29    <FalseValue>Нет</FalseValue>
30  </row>
31  <row>
32    <ID>662765452</ID>
33    <Name>TProfileConditionAccess</Name>
34    <Description>Условия доступа профиля</Description>
35    <Required type="int">1</Required>
36    <TrueValue>Контролировать чтение и запись</TrueValue>
37    <FalseValue>Контролировать только запись</FalseValue>
38  </row>
39</data>
40<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
41  ...
42</data>
43<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
44  ...
45</data>

19. Функция selectblob

Функция selectblob позволяет получить значение свойства объекта имеющий тип "большие данные" (файл, изображение, и т.п.), а также позволяет сравнивать значения типа "большие данные" без получения самих этих данных.

При вызове функции допустимо указывать любые расширения. Расширение должно определяться содержимым, которое ожидается получить. В случае, если об этом нет достаточной информации, можно вызывать функцию с пустым расширением.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

  • class (обязательный) - имя класса, значение свойства которого нужно получить (или сравнить)
  • propname (обязательный) - имя свойства, значение свойства которого нужно получить (или сравнить)
  • id (обязательный) - в качестве значения этого параметрам может быть передано:
    • идентификатор объекта, значение свойства которого нужно получить
    • список идентификаторов объектов, разделенных ";"
    • идентификатор буфера, содержащего список объектов (подробнее о создании и наполнении буфера: Функция selectedbuffer, Функция selectionchanged)

Функция вернет следующий результат:

  • если в атрибуте ID был передан один объект или если содержимое (значение свойства) для всех переданных объектов одинаково, то вернется это одно значение
  • в других случаях вернется значение NULL

Таким образом, можно выполнять сравнение значений типа "большой объект" - если получено отличное от NULL значение, значит значения равны, иначе значения не равны. Получения самих значений во втором случае не происходит.

1https://techmill.ru/demo/selectblob?query=
2<query class="TPersonalDocument" propname="DocFile" ID="4562944;398621"/>

20. Функция selectedbuffer

Функция selectedbuffer возвращает новый идентификатор буфера, в который далее можно добавлять объекты, что позволит выполнять различные операции с созданным таким образом набором объектов как с единым целым.
Для манипуляций списком объектов в буфере предназначена Функция selectionchanged.

Допустимое расширение: .xml

Функция возвращает XML-документ в узле которого с именем ID возвращается идентификатор созданного буфера.

Пример запроса:
  https://techmill.ru/demo/selectedbuffer.xml
Пример ответа:
1  <data eof="1">
2    <row>
3      <ID>1186174</ID>
4    </row>
5  </data>

21. Функция selectionchanged

Функция selectionchanged позволяет манипулировать списком объектов буфера. Для создания нового буфера предназначена функция Функция selectedbuffer.

Допустимое расширение: .xml

В значении параметра с именем "query" необходимо передать xml-документ, содержащий данные о существующем буфере и действиях, которые должны быть с ним проведены. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML-документ query должен иметь один элемент selectionchanged со следующим набором атрибутов:

  • handle (обязательный) - идентификатор буфера
  • ID - список идентификаторов объектов с разделителем ";", которые будут добавлены в буфер или исключены из него; значение может быть пустым только в случае, если выполняется полная очистка буфера, что предается значением атрибута cleanup
  • selected (обязательный) - указание о том, какое действие должно быть выполнено с переданным списком объектов; допустимые значения:
    • "0" - удалить объекты из буфера
    • "1" - добавить объекты в буфер
  • cleanup - указание о том, что нужно сделать перед добавлением или удалением объектов; допустимые значения:
    • "0" (значение по умолчанию) - не выполнять предварительных действий
    • "1" - очистить буфер перед выполнением действия

При успешном выполнении функция вернет XML-документ с одним элементом data и атрибутом eof="1".

1  https://techmill.ru/demo/selectionchanged.xml?query=
2    <selectionchanged handle="221024" ID="227222;76923;77312" selected="1" cleanup="1"/>
В буфер с идентификатором 1186175 будут добавлены объекты с идентификаторами 77222;76923;77312; перед добавлением буфер будет очищен.

22. Функция sessionlogoff

Функция sessionlogoff позволяет удалить текущую сессию.

Допустимое расширение: .xml. Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/sessionlogoff.xml
Пример ответа:
  <data eof="1"/>

23. Функция setpropvalue

Функция setpropvalue позволяет изменять значения свойств объектов, доступные для изменения через обработчик сервера приложений.

Допустимое расширение: .xml.

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент setpropvalue с атрибутами, позволяющими идентифицировать объект и принадлежащее ему свойство, значение которого требуется изменить. Значение, которое должно быть установлено для свойства, передается как текст элемента setpropvalue Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Атрибуты элемента setpropvalue:

  • ID (обязательный) - идентификатор объекта, свойство которого должно быть изменено
  • class (обязательный, если не указан атрибут "propid") - имя класса, свойство которого должно быть изменено
  • propname (обязательный, если не указан атрибут "propid") - имя свойства, принадлежащего классу, переданному значением атрибута "class", значение которого должно быть изменено
  • propid (обязательный, если не указаны атрибуты "class" и "propname") - идентификатор свойства, значение которого должно быть изменено
  • noanalyze

Для передачи информации о свойстве, значение которого должно быть изменено, можно использовать атрибут "propid" или пару атрибутов "class" и "propname".

1  <setpropvalue ID="4912468" class="TPerson" propname="MiddleName">
2    "Алексеевич"
3  </setpropvalue>
Установить значение "Алексеевич" для свойства класса "TPerson" с именем "MiddleName" для объекта с идентификатором "4912468".

При успешном выполнении функция возвращает xml-документ с пустым набором данных:

<data eof="1"/>

При неуспешном выполнении функция возвращает xml-документ с текстом сообщения об ошибке, например:

1<error>
2  <message>Property not found.</message>
3  <className>Exception</className>
4</error>

24. Функция storeexternaldata
Функция storeexternaldata позволяет выполнить сохранение файла как "внешних данных" определенного домена. Файл данных будет записан в файловое хранилище, в виде, определяемом доменом.

Допустимое расширение: .xml

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент storeexternaldata с атрибутом domain, значением которого должно быть имя или идентификатор домена класса "Внешние данные". Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Запрос:
1  https://techmill.ru/demo/storeexternaldata.xml?query=
2    <storeexternaldata domain="TPhotoFile">
3      <![CDATA[Q09NUFJFU1NFRAAABwAAADExMS5ibXBCTRYBAAAAAAAAPgAAACgAAAAiAAAAGwAAAAEAAQAAAAAA2AAAAMQOAADEDgAAAAAAAAAAAAAAAAAA////AP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/B/wf8AAAAD8H/B/wAAAAPwf8H/AAAAA/B/wf8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAA==]]>
4    </storeexternaldata>
Ответ:
1  <data eof="1">
2    <row>
3      <Result>{1B8C156B-76F6-4EC1-987D-F6C0000DB343}</Result>
4    </row>
5  </data>

25. Функция sysinfo

Функция sysinfo позволяет получить информацию о системе в формате XML с набором атрибутов, соответствующих характеристикам системы.

Допустимое расширение: .xml. Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/sysinfo.xml
Пример ответа:
  <sysinfo major="3" minor="2" release="2" build="304" PerformExcelReports="0" PerformOleObjectMethods="0" PerformPDFReports="0" PerformWordReports="0" PerformXSLTReports="0" GroupMethods="0"/>

26. Функция timebias

Допустимое расширение - .xml

Используется JavaScript-клиентом и "Обозревателем данных".

Параметр query содержит текст xml-документа, в котором в атрибутах корневого узла разложены компоненты текущей даты и текущего времени клиента:

<timebias Y="2024" M="03" D="22" H="12" Mi="30" S="00" Ms="100"/>

Имя корневого элемента не имеет значения. АтрибутY содержит год, M - месяц (нумеруются с 1, январь - "1", декабрь - "12"), D - число внутри месяца, H - часы, Mi - минуты, S - секунды, Ms - миллисекунды.

Ответ представляет собой xml-документ следующей структуры:

1  <data eof="1">
2    <row>
3      <Bias type="dbl">
4        0,19860191
5      </Bias>
6    </row>
7  </data>

здесь числовое значение в элементе Bias содержит количество суток (в данном примере - 0 целых, 1 десятая, 9 сотых, 8 тысячных и так далее), которые нужно прибавлять к датам, полученным с сервера приложений, чтобы получить даты в часовом поясе клиента. Атрибут type, атрибут eof (оба - вместе со значениями), и имена всех элементов ответа являются неизменными, и передаются для унификации процедуры разбора ответа.

27. Функция wordreport

Функция wordreport позволяет вызывать на выполнение отчеты класса TWordTemplate и получать файлы, формируемые как результат выполнения отчетов. Файлы могут быть возвращены как в форматах Word (.doc,.docx), так и с преобразованием в другие форматы. Исключением являются интерактивные отчеты (требующие при формировании диалога с пользователем). Такие отчеты не могут вызваться при помощи данной функции.

Допустимые расширения:

  • .doc - для получения файла отчета в формате DOC
  • .docx - для получения файла отчета в формате DOCX
  • .html - для получения файла отчета в формате HTML; формирование html-документа выполняется средствами MS Word;
  • .rtf - для получения файла отчета в формате RTF
  • .pdf - для получения файла отчета в формате PDF; преобразование.doc/.docx-файла в pdf-документ выполняется средствами самого Word; возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, отчет которого будет вызываться
  • "template" (обязательный) - имя отчета, который будет вызываться
  • "format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:
    • тип файла результата - допустимые значения совпадают с возможными расширениями вызова функции (без дополнительной точки)
  • "filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="ListenerCard.pdf", что будет говорить о том, что будет возвращен pdf-документ.
    Значение по умолчанию: "wordreport" с расширением, совпадающим с расширением вызываемой функции.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного атрибутами параметра query или расширением функции wordreport (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове Word-отчета:
1  <execute class="TDPOStatus" template="ListenerCard" format="grey.embed.pdf" filename="ListenerCard.pdf">
2    <row>
3      <ID>5201838</ID>
4      <DPOInstitute>4327519</DPOInstitute>
5      <SecondSigner>4469840</SecondSigner>
6    </row>
7  </execute>
При таком вызове будет выполнен Word-отчет "ListenerCard" класса "TDPOStatus" с параметрами, переданными в элементе row. Данный отчет является "методом объекта", поэтому дополнительно использован параметр "ID". Полученный файл отчета будет преобразован в формат PDF с внедрением шрифтов в цветовом режиме "в градациях серого". Преобразование будет выполнено средствами приложения MS Word. В качестве ответа будет возвращен.pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("ListenerCard.pdf"), в содержимом ответа будет передано содержимое файла.

28. Функция xsltreport

Функция xsltreport позволяет вызывать на выполнение отчеты класса TXSLTTemplate и получать файлы, формируемые как результат выполнения отчетов.

Допустимые расширения:

  • .xml
  • .html
  • .txt
  • без расширения

Для данного вида отчета тип и расширение возвращаемого файла будут определены самим XSLT-отчетом (будут заданы в элементе "xsl:output" в шаблоне отчета). Вызов функции с тем или иным расширением не повлияет на тип и расширение файла-результата.

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, отчет которого будет вызываться
  • "template" (обязательный) - имя отчета, который будет вызываться
  • "filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition.
    Значение по умолчанию: имя вызываемого отчета с расширением, которое будет определено самим отчетом.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного самим отчетом. В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове XSLT-отчета:
1  <execute class="TObject" template="SelectDataToText" filename="QueryResult.txt">
2    <row>
3      <ClassName>TCountry</ClassName>
4      <Query></Query>
5    </row>
6  </execute>
При таком вызове будет выполнен XSLT-отчет "SelectDataToText" класса "TObject" с параметрами, переданными в элементе row. Данный отчет является "методом класса", поэтому параметр "ID" в состав параметров не добавлен. В качестве ответа будет возвращен текстовый файл. В заголовке ответа в поле Content-Disposition будет передано имя файла ("QueryResult.txt"), в содержимом ответа будет передано содержимое файла.


Мельница данных ((раздел целиком))

Мельница данных- Создание шаблонов PDF-отчетов (раздел целиком) (22.10.2024) (одним файлом)
Создание шаблонов PDF-отчетов

1. Описание

Portable Document Format (PDF) — кроссплатформенный формат электронных документов, созданный фирмой Adobe Systems с использованием ряда возможностей языка PostScript. В первую очередь предназначен для представления в электронном виде полиграфической продукции, — значительное количество современного профессионального печатного оборудования может обрабатывать PDF непосредственно. Для просмотра можно использовать официальную бесплатную программу Adobe Reader, а также программы сторонних разработчиков. Традиционным способом создания PDF-документов является виртуальный принтер, то есть документ как таковой готовится в своей специализированной программе — графической программе или текстовом редакторе, САПР и т. д., а затем экспортируется в формат PDF для распространения в электронном виде, передачи в типографию и т. п. Формат PDF позволяет внедрять необходимые шрифты (построчный текст), векторные и растровые изображения, формы и мультимедиа-вставки. Поддерживает RGB, CMYK, Grayscale, Lab, Duotone, Bitmap, несколько типов сжатия растровой информации. Имеет собственные технические форматы для полиграфии: PDF/X-1, PDF/X-3. Включает механизм электронных подписей для защиты и проверки подлинности документов. В этом формате распространяется большое количество сопутствующей документации. Чаще всего PDF-файл является комбинацией текста с растровой и векторной графикой, реже — текста с формами, JavaScript'ом, 3D-графикой и другими типами элементов.

В приложениях Платформы "Мельница данных" для создания PDF-документов используется собственная библиотека PDFCreator.dll. С помощью библиотеки возможно прямое создание документов версии 1.3 . Создание PDF-документов осуществляется путем ввода предопределенных в библиотеке команд, которые в дальнейшем интерпретируются на основе языка описания страниц POSTSCRIPT.

Все размеры графических объектов, размеры страниц, шрифтов и т.п. по умолчанию заданы в миллиметрах.
Для удобства построения шаблона PDF-документа создана функция DrawGrid. При ее включении при отладке при создании шаблона будет отображена визуальная сетка с шагом 5 миллиметров.

2. Методы

2.1. Свойства документа

Для создания и описания свойств PDF-документа в библиотеке PDFCreator.dll используется класс IPDFDocument, обладающий следующими свойствами:

  • Title (WideString) - заголовок документа. По умолчанию - пустая строка.
    Title = "DOC1"
  • CanEmbedFonts (WordBool) - Признак возможности построения PDF- документа со встроенными шрифтами (Embedded Fonts). В случае включения признака, все объявленные в скрипте шрифты будут включены в сборку документа и будут передаваться целиком вместе с документом. По умолчанию - False.
    CanEmbedFonts = True
CanEmbedFonts = False
  • CanCompress (WordBool) - признак сжатия документа при создании по собственным алгоритмам. По умолчанию - True.
    CanCompress = False
CanCompress = True
  • Author (WideString) - автор документа. По умолчанию - текущий пользователь ОС.
  • Subject (WideString) - описание документа. По умолчанию - пустая строка.
  • Keywords (WideString) - ключевые слова для поиска по документу. По умолчанию - пустая строка.
  • Creator (WideString) - приложение-родитель документа. Указывается в том случае, если документ был сконвертирован из другого формата.
  • PageCount (Integer) - свойство, содержащее общее количество страниц в документе.
  • Pages[Index: Integer]: IPDFPage - свойство документа, предназначенное для перебора страниц документа для совершения над ними однотипных действий.

    Пример использования:

    1for I = 0 to PageCount - 1
2  Pages(I).rectangle 10,10,10,10, false
3next
Save "c:\pdf.pdf"

    Результат: На всех страницах документа будут нарисованы квадраты 10х10 мм.
  • procedure Save(Target: OleVariant) - процедура для сохранения документа PDF на жесткий диск сразу после создания.
    Save "c:\pdf.pdf"
    - сохранит документ в файл c:\pdf.pdf

2.2. Свойства страницы

Для создания страницы используется функция

function CreatePage(Parent: OleVariant): IPDFPage;

Параметр Parent указывает страницу-родителя для данной страницы. Если страницы- родителя быть не должно - формат вызова функции примет вид:

set page = CreatePage(Null)

Параметры страницы:

  • Title - заголовок страницы.
    page.Title = "Page name"
  • Width - ширина страницы, миллиметры
    page.Width = 80
  • Height - высота страницы, миллиметры
    page.Height = 80
  • DrawGrid - процедура, выводящая на страницу сетку с шагом 5 миллиметров для удобства отладки вида документа.
  • Perform - процедура, позволяющая выполнить дополнительные команды PostScript на странице.
    page.perform "1 0.7 0 0 k"page.perform "0 0 m"

2.2.1. Объявление цвета

Для объявления цвета объектов на странице используется цветовая модель R:G:B (Red:Green:Blue). Объявление цвета для выполнения последующих операций (цвет шрифта, цвет линии/фигуры) осуществляется процедурой

procedure SetColor(R: Integer; G: Integer; B: Integer);
Где параметры R, G, B - значения базисных цветов для выбранного цвета (от 0 до 255).

Цвет | R | G | B |
Белый | 255 | 255 | 255 | +++
Черный | 0 | 0 | 0 | +++
Серый | 190 | 190 | 190 | +++
Синий | 0 | 0 | 255 | +++
Красный | 255 | 0 | 0 | +++
Зеленый | 0 | 255 | 0 | +++

Если предварительно цвет не был объявлен, используется цвет по умолчанию - черный (0,0,0)

2.3. Графика

2.3.1. Линии

Для отрисовки линий используется процедура

procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double);
Здесь:

  • X1 - координата начала линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y1 - координата начала линии по вертикали в миллиметрах от верхнего левого угла листа.
  • X2 - координата конца линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y2 - координата Конца линии по вертикали в миллиметрах от верхнего левого угла листа.

Для задания толщины линии используется свойство

property LineWidth: Double
Значение толщины задается в миллиметрах. Значение по умолчанию - минимально возможная единица рисования для устройства. Так для монитора - 1 pixel, для принтера - 1 dot (точка)

Для задания стиля отрисовки начала/окончания линии используется свойство property LineCap: TPDFLineCap
Возможные стили:
Значение свойства: | Отображение: | Описание:
0 | Линия 0 | Прямой срез точно по точкам начала и окончания линии (по умолчанию)
1 | Линия 1 | С закруглением
2 | Линия 2 | Прямой срез с продолжением линии на половину толщины линии

Объявление цвета линии.

Две линии разной толщины, с разными окончаниями и цветами:
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineCap = 1
06
07page.LineWidth = 2
08
09page.Line 10, 10, 30, 30
10
11page.LineWidth = 4
12
13page.SetColor 255, 0, 0
14
15page.LineCap = 2
16
page.Line 10, 30, 30, 10."I

Результат:
2 линии

При необходимости соединения линий под углом в определенной точке можно задать тип соединения. Для объявления типа соединения используется свойство property LineJoin: TPDFLineJoin;
Типы соединения двух линий:
Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пунктир

Для создания пунктира используется процедура отображения линии с предварительно объявленными дополнительными значениями.

Процедура procedure SetDash(DashArray: OleVariant; Phase: Integer); Здесь DashArray - массив значений в миллиметрах, указывающий последовательность чередования штрихов и пропусков на линии, Phase - смещение в миллиметрах по линии.

Пример 1. Штрих 10 мм, Промежуток 5 мм, Смещения нет
Пример 2. Штрих 10 мм, Промежуток 5 мм, Смещение 5 мм
Пример 3. Различные значения штрихов и промежутков, Смещения нет
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 3
06
07page.SetDash Array(10, 5), 0
08
09page.Line 10, 10, 100, 10
10
11page.SetDash Array(10, 5), 5
12
13page.Line 10, 20, 100, 20
14
15page.SetDash Array(10, 5, 3, 2, 12, 20), 0
16
page.Line 10, 30, 100, 30

Результат:
Пунктир 1

Ломанная линия - здесь непрерывная линия, состоящая из нескольких прямых. Для отображения ломанной используется процедура procedure Poly(Points: OleVariant; Fill: WordBool), где Points - массив координат точек соединяемых прямыми, а Fill - признак заливки полученной замкнутой фигуры (если замкнута).

Пример Звезда без заливки
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), false

Результат:
Звезда
Пример Звезда с заливкой
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), true

Результат:
Звезда заливка

2.3.2. Прямоугольник

Rectangle (Прямоугольник) - для создания используется процедура:

procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double; Fill: WordBool);
Здесь:

  • X1 - координата верхнего левого угла прямоугольника по горизонтали в миллиметрах от верхнего левого угла листа шаблона.
  • Y1 - координата верхнего левого угла прямоугольника по вертикали в миллиметрах от верхнего левого угла листа шаблона.
  • Width - ширина прямоугольника с миллиметрах.
  • Height - высота прямоугольника с миллиметрах.
  • Fill - признак заливки прямоугольника (True/False). Если значение True то заливка производится объявленным заранее цветом (см. Объявление цвета). Если False - заливка не производится. Прямоугольник отрисовывается линиями с предварительно заданной толщиной. См. Линии
Пример 1. Создание красного прямоугольника:
1set page = CreatePage(Null)
2
3page.SetColor 255, 0, 0
4
5page.Rectangle 10, 15, 40, 20, True
6
page.DrawGrid
Результат:
Прямоугольник
Пример 2. Пустой прямоугольник без задания цвета:
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.Rectangle 12, 17, 42, 25, false
6
page.DrawGrid

Результат:
Прямоугольник false

Также существует возможность изменения стиля отображения углов прямоугольника. Для этого нужно использовать свойство property LineJoin: TPDFLineJoin;

Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пример построения прямоугольников с различными типами соединения сторон:

01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 4
06
07page.LineJoin = 0
08
09page.Rectangle 10, 10, 20, 10, false
10
11page.LineJoin = 1
12
13page.Rectangle 40, 10, 20, 10, false
14
15page.LineJoin = 2
16
page.Rectangle 70, 10, 20, 10, false

Результат:
3 прямоугольника

2.3.3. Вставка готовых изображений

Для вставки на создаваемую страницу готового изображения используется процедура procedure Image(const FileName: WideString; X: Double; Y: Double; Width: Double; Height: Double)

Параметры:

  • const FileName - имя файла изображения и путь к нему на жестком диске. Задается в кавычках.
  • X - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по горизонтали в миллиметрах
  • Y - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по вертикали в миллиметрах
  • Width - ширина изображения в миллиметрах
  • Height - высота изображения в миллиметрах.
1set page = CreatePage(Null)
2page.drawgrid
page.Image "c:\mill.bmp", 10,10, 30, 30

Результат:
Картинка

Вне зависимости от размера исходного изображения, при вставке изображения на создаваемую страницу оно будет растянуто по размерам, прописанным в процедуре.

2.3.4. Векторная графика

Язык PostScript, с помощью которого создаются векторные изображения для PDF-документа, поддерживает создание типичных примитивных объектов, таких как:

  • Прямые и ломанные линии
  • Многоугольники
  • Окружности и эллипсы
  • Кривые Безье
  • Текст

При создании векторного изображения на странице PDF-документа в приложениях Платформы, команды построения примитивных объектов PostScript передаются на исполнение при помощи процедуры Perform. Подробнее об операторах и командах PostScript для создания PDF-документов можно узнать на сайте Adobe

2.4. Шрифты

Шрифты, которые должны использоваться в создаваемом документе, должны быть предварительно объявлены. Для объявления используемых шрифтов используется функция
function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool; Italic: WordBool): IPDFFont; где:

  • const FontName - имя шрифта, аналогичное имени объявляемого шрифта в операционной системе. В Функции объявляется в кавычках.
  • Size - размер шрифта в пунктах
  • Bold - признак начертания шрифта "жирный". Значения - True или False
  • Italic - признак начертания шрифта "курсив". Значения - True или False
Примеры объявления шрифтов:
1set font = page.createFont("Arial", 20, False, False)
2set labelFont = page.createFont("Times New Roman", 16, False, True)
3set dataFont = page.createFont("Tahoma", 18, True, False)

Для вывода текстовой информации на страницу используются процедуры:

  • procedure WriteLine(const LineText: WideString; X: Double; Y: Double);
    - используется для вывода текстовой строки
  • function WriteText(const AText: WideString; X: Double; Y: Double; Width: Double; Alignment: TPDFTextAlignment): Double;
    - используется для вывода текстового блока.

Параметры для procedure WriteLine :

  • const LineText - текстовая строка для вывода. Прописывается в кавычках. Будет выведена на страницу одной строкой.
  • X - координата верхней левой точки текстовой строки по горизонтали в миллиметрах.
  • Y - координата верхней левой точки текстовой строки по вертикали в миллиметрах.
Примеры вывода текстов на страницу:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Times New Roman", 16, False, True)
05set dataFont = page.createFont("Tahoma", 18, True, False)
06Font.WriteLine "Фамилия", 5, 2
07Font.WriteLine "Имя", 5, 10
08Font.WriteLine "Отчество", 5, 18
09labelFont.WriteLine "Дата рождения", 5, 26
10dataFont.WriteLine "Национальность", 5, 34

Результат:
Разные шрифты

Параметры для function WriteText :

  • const AText - текст для вывода на страницу. Прописывается в кавычках. Будет выведена на страницу в виде текстового блока.
  • X - координата верхней левой точки текстового блока по горизонтали в миллиметрах.
  • Y - координата верхней левой точки текстового блока по вертикали в миллиметрах.
  • Width - ширина текстового блока в миллиметрах
  • Alignment - тип выравнивания текста в текстовом блоке.
    Значение параметра | Тип выравнивания
    0 | По левому краю
    1 | По правому краю
    2 | По центру
    3 | Выравнивание по ширине
Примеры вывода текстовых блоков на страницу:
1set page = CreatePage(Null)
2page.DrawGrid
3set font = page.createFont("Arial", 14, False, False)
4set labelFont = page.createFont("Times New Roman", 12, False, True)
5set dataFont = page.createFont("Tahoma", 11, True, False)
6Q = font.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 5, 100, 0)
7Q = labelFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 35, 100, 1)
8Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 55, 100, 2)
9Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 80, 100, 3)

Результат:
Выравнивание

Свойства шрифтов:

property Spacing: Double; - свойство, отвечающее за величину промежутка между буквами в слове. Задается в виде отклонения от промежутка между буквами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Spacing = 0
07labelFont.Spacing = 1
08dataFont.Spacing = 2
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (1 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 15

Результат:
Промежуток букв

property WordSpacing: Double; - свойство, отвечающее за величину промежутка между соседними словами. Задается в виде отклонения от промежутка между словами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.WordSpacing = 0
07labelFont.WordSpacing = 2
08dataFont.WordSpacing = 5
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (5 мм)", 5, 15

Результат:
Промежуток слов

property Scaling: Double; - свойство, отвечающее за горизонтальное масштабирование букв используемого шрифта. Устанавливается в процентах. Горизонтальный масштаб по умолчанию - 100%.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Scaling = 50
07labelFont.Scaling = 100
08dataFont.Scaling = 200
09font.WriteLine "Сжатие (50)", 5, 5
10labelFont.WriteLine "По умолчанию (100)", 5, 10
11dataFont.WriteLine "Растягивание (150)", 5, 15

Результат:
Scaling

property RenderingMode: TPDFFontRenderingMode; - свойство, отвечающее за заливку букв используемого шрифта.
Типы заливки:
Значение параметра: | Отображение: | Описание:
0 | Font Fill | Сплошная заливка (по умолчанию). Буква заливается сплошным цветом, объявленным на данный момент.
1 | Font Stroke | Только граница. Прорисовывается граница буквы. Тело остается незалитым.
2 | Font FillStroke | Сначала заливка, потом граница. Граница прорисовывается всегда черным цветом. Заливка осуществляется сплошным цветом, объявленным на данный момент.
3 | Inv | Невидимый шрифт.

Пример:
01set page = CreatePage(Null)
02set font = page.createFont("Arial", 20, False, False)
03set labelFont = page.createFont("Arial", 20, False, False)
04set dataFont = page.createFont("Arial", 20, False, False)
05font.RenderingMode = 0
06labelFont.RenderingMode = 1
07dataFont.RenderingMode = 2
08page.setColor 255, 0, 0
09Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
10Q = labelFont.WriteText ("Олимпиада", 5, 15, 50, 0)
11Q = dataFont.WriteText ("Олимпиада", 5, 25, 50, 0)

Результат:
Заливка букв

property Rise: Double; - свойство, отвечающее за перемещение текста по вертикали.

01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Arial", 7, False, False)
05set dataFont = page.createFont("Arial", 7, False, False)
06labelFont.rise = -17
07dataFont.rise = -2
08Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
09Q = labelFont.WriteText ("Олимпиада", 44, 5, 50, 0)
10Q = dataFont.WriteText ("Олимпиада", 44, 5, 50, 0)

Результат:
Rise

Для определения размеров текстовой строки используется процедура MeasureLine(const LineText: WideString; out Width: OleVariant; out Height: OleVariant);

Здесь:

  • LineText - исходный текст для размещения на странице
  • Width - возвращаемый параметр ширины текстового блока на странице
  • Height - возвращаемый параметр высоты текстового блока на странице
1S = "шифр"
2font.MeasureLine S, W, H
3Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2)

Здесь для текста "Шифр" замеряется ширина и высота получившегося текстового блока. Затем полученные данные используются для корректного размещения текста на странице.

Для определения высоты текстового блока используется функция MeasureText(const AText: WideString; Width: Double): Double; safecall;

Функция распределит текст по задаваемому значению ширины текстового блока и вернет значение высоты текстового блока в милиметрах.

Здесь:

  • AText - исходный текст для размещения на странице. Прописывается в кавычках.
  • Width - задаваемая ширина текстового блока на странице в милиметрах.
1S = "Текст для размещения на странице..."
2Q = font.MeasureText(S, 139)
Здесь для текста "Текст для размещения на странице..." замеряется высота получившегося текстового блока. Затем полученные данные могут использоваться для корректного размещения текста на странице.

3. Порядок создания

Для создания шаблона PDF-документа необходимо в системной форме Платформы выбрать класс, к которому будет строиться документ. В подменю "Подпрограммы" вызвать контекстное меню и выбрать пункт "Создать шаблон отчета PDF". Заполнить необходимые поля и приступить к созданию скрипта в окне "Скрипт шаблона".

  1. Объявляем все переменные.
  2. Создаем страницы
  3. Устанавливаем все свойства документа и страниц
  4. Рисуем простые графические объекты
  5. Объявляем все используемые шрифты
  6. Расставляем постоянный текст на странице
  7. Расставляем переменный текст на странице
  8. Вставляем или создаем сложные графические объекты
Пример документа PDF:
001set LDataSet = createDataSet("TRoundAbiturSt")
002'Объявление переменных
003LDataSet.AddQueryItem 1, "ID", ID
004LDataSet.AddQueryItem 0, "RoundComp$N"
005LDataSet.AddQueryItem 0, "BachRound$N"
006LDataSet.AddQueryItem 0, "LastName"
007LDataSet.AddQueryItem 0, "FirstName"
008LDataSet.AddQueryItem 0, "MiddleName"
009LDataSet.AddQueryItem 0, "BirthDate"
010LDataSet.AddQueryItem 0, "RegNumber"
011LDataSet.AddQueryItem 0, "SecondStageCity$D"
012LDataSet.AddQueryItem 0, "PhoneList"
013
014'Присваивание переменным значений
015OlympName = LDataSet.Field("RoundComp$N")
016OlympClass = LDataSet.Field("BachRound$N")
017LastName = LDataSet.Field("LastName")
018FirstName = LDataSet.Field("FirstName")
019MiddleName = LDataSet.Field("MiddleName")
020if not IsNull(LDataSet.Field("BirthDate")) then
021  BirthDate = LDataSet.Field("BirthDate")
022else
023  BirthDate = "(не задана)"
024end if
025RegNo = LDataSet.Field("RegNumber")
026if not IsNull(LDataSet.Field("SecondStageCity$D")) then
027  OlympCity = LDataSet.Field("SecondStageCity$D")
028else
029  OlympCity = "(не выбран город участия)"
030end if
031if not IsNull(LDataSet.Field("PhoneList")) then
032  Phone = LDataSet.Field("PhoneList")
033else
034  Phone = ""
035end if
036
037'CanCompress = False - признак сжатия файла
038set page = CreatePage(Null) ' создаем страницу
039'Объявляем используемые шрифты
040set font = page.createFont("Arial", 20, False, False)
041set labelFont = page.createFont("Arial", 16, False, False)
042set dataFont = page.createFont("Arial", 18, True, False)
043set bigFont = page.createFont("Arial", 24, False, False)
044
045'page.DrawGrid  - рисуем сетку для удобства отладки
046
047page.LineWidth = 0.5 ' Установка толщины линии
048
049' Рисуем прямоугольники
050page.Rectangle 8, 12, 4, 4, True
051page.Rectangle 190, 12, 4, 4, True
052
053page.Rectangle 8, 273, 4, 4, True
054page.Rectangle 105, 273, 4, 4, True
055page.Rectangle 190, 273, 4, 4, True
056
057'Выводим постоянный и переменный текст
058Q = font.WriteText ("Межрегиональная олимпиада школьников", 12, 20, 178, 2)
059Q = bigFont.WriteText (OlympName, 12, 45, 178, 2)
060Q = bigFont.WriteText (OlympClass, 12, 56, 178, 2)
061
062Q = font.WriteText ("Титульный лист", 12, 72, 178, 2)
063
064labelFont.WriteLine "Фамилия", 25, 115 - 23
065labelFont.WriteLine "Имя", 25, 123 - 23
066labelFont.WriteLine "Отчество", 25, 131 - 23
067labelFont.WriteLine "Дата", 25, 139 - 23
068labelFont.WriteLine "рождения", 25, 145 - 23
069
070labelFont.WriteLine "Регистрационный номер", 25, 169 - 30
071labelFont.WriteLine "Город проведения", 25, 177 - 30
072labelFont.WriteLine "Аудитория", 25, 185 - 30
073
074
075labelFont.WriteLine "Дата", 25, 211
076labelFont.WriteLine "Подпись", 25, 219
077labelFont.WriteLine "Телефон", 25, 227
078
079
080dataFont.WriteLine LastName, 63, 114 - 23
081dataFont.WriteLine FirstName, 63, 122 - 23
082dataFont.WriteLine MiddleName, 63, 130 - 23
083dataFont.WriteLine BirthDate, 63, 141 - 23
084
085dataFont.WriteLine RegNo, 100, 168 - 30
086dataFont.WriteLine OlympCity, 100, 176 - 30
087
088' Рисуем линии
089page.line 100, 192 - 30, 150, 192 - 30
090page.line 58, 218, 108, 218
091page.line 58, 226, 108, 226
092Q = dataFont.WriteText(Phone, 58, 226, 65, 0)
093
094
095
096' Устанавливаем новый цвет
097page.setColor 192, 192, 192
098
099S = "шифр"
100font.MeasureLine S, W, H  ' измеряем текстовый блок
101Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2) ' располагаем текстовый
102блок на странице
103
104' Устанавливаем новый цвет
105page.setColor 255, 0, 0
106' Устанавливаем толщину линий в 1 пиксель
107page.LineWidth = 0
108' Рисуем линии по координатам
109X = 139
110Y = 267
111
112page.line X, Y - 3, X, Y + 3
113page.line X - 3, Y, X + 3, Y
114
115X = X + 40
116page.line X, Y - 3, X, Y + 3
117page.line X - 3, Y, X + 3, Y
118
119
120Y = Y - 23
121page.line X, Y - 3, X, Y + 3
122page.line X - 3, Y, X + 3, Y
123
124X = X - 40
125page.line X, Y - 3, X, Y + 3
page.line X - 3, Y, X + 3, Y

Результат:


Мельница данных ((раздел целиком))

Мельница данных- Перекачка данных (раздел целиком) (22.10.2024) (одним файлом)
Перекачка данных

Для осуществления перекачки данных необходимо:

  1. Иметь права владельца схемы в БД - приемнике.
  2. Иметь права владельца схемы в БД - источнике.
  3. Если не задан ключ /M, то БД - приемник должен быть пустой схемой, не содержащей никаких объектов.
Эти условия контролируются утилитой dbsetup.exe.

Перекачка данных осуществляется в любом направлении. Ниже представлены варианты сочетания источников и приемников данных. В случае, если попытка использовать тот или иной оптимизационный механизм оказалась неудачной, производится стандартная перекачка.

Приемник | Источник
 | БД MSSQL | БД Firebird | БД Oracle | БД PostgreSQL | Папка, файл, zip-архив
БД MSSQL | Стандартная перекачка данных
БД Firebird | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("external table"). | Предпринимается попытка использовать механизм "внешний источник данных" ("external data source"). | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("external table").
БД Oracle | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("table organization external"). |  | Предпринимается попытка использовать механизм "связи БД" ("database link"). | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("table organization external").
БД PostgreSQL | Предпринимается попытка использовать механизм загрузки данных из внешнего текстового файла оператором COPY. |  |  | Предпринимается попытка использовать расширение "dblink". | Предпринимается попытка использовать механизм загрузки данных из внешнего текстового файла оператором COPY.
Папка, файл, zip-архив | Стандартная перекачка данных | Предпринимается попытка собрать на сервере blob, содержащий целевой xml-документ. |  |  | Не имеет смысла. Просто скопируйте файлы.

Используемые параметры и ключи командной строки:

Для перекачки данных используюется команда pump. В строке соединения указывается БД-приемник, кроме случая перекачки данных из БД в папку, файл или zip-архив. Для всех случаев кроме случая перекачки данных из БД в папку, файл или zip-архив командная строка содержит кляузу pump from. Для случая перекачки данных из БД в папку, файл или zip-архив командная строка содержит кляузу pump to.
Перекача данных из БД Oracle в БД Firebird:
dbsetup.exe fb#sysdba/masterkey@host:database pump from ora#dataowner/password@host/sid.dataowner
Перекача данных из zip-архива в БД Firebird:
dbsetup.exe fb#sysdba/masterkey@host:database pump from c:\dbbackup.zip
Перекача данных из БД Firebird в zip-архив:
dbsetup.exe fb#sysdba/masterkey@host:database pump to c:\dbbackup.zip

Ключ | Назначение
/J <Целое число> | Определяет число потоков, осуществляющих перекачку данных. По умолчанию соответствует количеству ядер процессора.
/H <Целое число> | Определяет базовое количество записей в блоке перекачки. По умолчанию - 1 млн. записей. Для таблиц, содержащих большие объекты (blob и/или clob) размер блока перекачки определяется как базовый размер блока, деленный на 100. Если источником является папка, файл или zip-архив - ключ игнорируется.
/M | Пропустить этап создания таблиц и последовательностей в БД (таблицы и последовательности должны быть созданы заранее).
/G | Пропустить этап заливки данных, произвести только создание таблиц и последовательностей в БД.
/K <Список таблиц> | Не перекачивать данные указанных таблиц. Список таблиц разделяется символом ";" (точка с запятой).
/NODBLINK | Принудительно отключает механизмы связи между БД на сервере.
/NOCSV | Принудительно отключает механизмы загрузки данных из внешнего файла.
/NOXML | Принудительно отключает механизмы cборки xml-документа на сервере.

Информация о значениях типа "внешние данные" будет перенесена из источника в приемник, сами внешние данные при этом перенесены в хранилище не будут.

При перекачке данных учитыватся табличное пространство ("группа файлов") каждой таблицы в случае, если это понятие релевантно для источника и приемника. При использовании папки, файла или zip-архива имя табличного пространства каждой таблицы сохраняется в файле RTTI, и будет использовано, если окажется релевантным. Если в приемнике имеется возможность разместить таблицу в табличное пространство с тем же именем, которое указано в источнике, то это будет сделано.

При перекачке данных таже осуществляется перенос последовательностей. При этом переносится текущее значение каждой из последовательностей. Значение кеша последовательности переносится только в том случае, если это понятие релевантно для источника и для приемника. При использовании папки, файла или zip-архива значение кеша сохраняется в файле Sequences, и будет использовано, если окажется релевантным.

После завершения перекачки данных в схеме-приемнике остаются следующие объекты:

  • Таблицы данных.
  • Первичные ключи таблиц данных.
  • Последовательности.
  • Заголовки системных объектов платформы.

Этот набор минимально достаточен, чтобы с помощью синхронизации (загрузив метаданные из таблиц, с ключем /T) восстановить метаданные БД в соответствующей схеме, и работать с ней средствами платформы.

Особенности перекачки данных в папку, файл или zip-архив:

При использовании папки она рассматривается как хранилище файлов перекачки. При использовании файла он рассматривается как хранилище файлов перекачки в формате Microsoft Compound File. При использовании zip-архива он рассматривается как хранилище файлов перекачки. Хранилище файлов перекачки содержит следующие файлы:

  • FormatSettings - xml-файл с информацией о региональных настройках процесса, сформировавшего хранилище.
  • Sequences - xml-файл с информацией о текущих значениях последовательностей.
  • RTTI - xml-файл с информацией о таблицах и полях. Также содержит информацию о табличных пространствах.
  • <Имя Таблицы> с возможным числовым постфиксом в скобках - xml-файл с данными таблицы в стандартном xml-представлении.
  • #<Длина файла в 16-ричном представлении, 16 символов><CRC файла в 16-ричном представлении, 8 символов> - двоичный файл с содержимым blob/clob. Такие файлы формируются для объектов, чей размер превышает 1MB.

Остальные файлы в хранилище будут проигнорированы (если хранилище используется как источник) или удалены (если хранилище используется как приемник).

Если в качестве приемника используется zip-архив, то механизм перекачки данных будет использовать информацию об уже содержащихся в архиве файлах, и не будет повторно "пересжимать" уже имеющиеся файлы. Таким образом, можно удобно релизовать "инкрементальное резервное копирование", указывая в качестве приемника перекачки данных один и тот же zip-архив.

1. Стандартная перекачка данных

Стандартная процедура перекачки блока данных заключается в открытии однонаправленного курсора на основании запроса типа select... from "..." к таблице-источнику, подготовке запроса insert into "..."("ID",.....) values (:Param1, :Param2....) к приемнику, и многократному выполнению этого единожды подготовленного запроса по мере продвижения вперед по курсору-источнику. Все значения полей при этом проходят через клиентскую сторону, и заливка данных осуществляется по одной записи за одно выполнение запроса. Характерная скорость такой заливки - порядка 5000 записей в секунду.

Оператор INSERT в процессах перекачки данных всегда формируется с подсказкой /*+ APPEND */.

Описанные далее механизмы оптимизации не могут использоваться одновременно. Если какой-либо из них может быть использован в вашей ситуации - постарайтесь обеспечить условия, необходимые для их работы. Вы получите значительное ускорение перекачки.

2. Механизмы связи между БД на сервере

Будут формироваться и выполняться блоки вида
01execute block as
02  declare "ID" BIGINT;
03  declare "P0" SMALLINT;
04  .....
05begin
06  for execute statement 'select "ID", .... from "...."'
07    on external data source '....' as user '...' password '....'
08    into :"ID",:"P0",..... do
09      insert into "...."("ID",....)
10      values (:"ID",:"P0",.....);
11end

Механизм может быть использован, если пользователь-владелец схемы имеет право CREATE DATABASE LINK, и оператор create database link будет выполнен без ошибок. При этом будет создан link с именем "SYS$PUMP". После завершения процедуры перекачки данных link будет удален. Таким образом, можно в целях безопасности выдавать право CREATE DATABASE LINK владельцу схемы данных только на время перекачки данных. При этом генерируются и выполняются операторы вида
1INSERT /*+ APPEND */ INTO "..."("ID", ....)
2SELECT "ID", ....
3  FROM "..."@"SYS$PUMP"
4...

Механизм может быть использован, если в БД установлено стандартное расширение "dblink", и оператор select public.dblink_connect('user=... password=.......') будет выполнен без ошибок. При этом генерируются и выполняются операторы вида
01do $$
02declare
03  cnt int;
04begin
05  perform public.dblink_connect('user=... password=... ....');
06  perform public.dblink_open('SYS$....', 'select T."ID", ..... from "...." T');
07  loop
08    insert into "...." ("ID", .....)
09    select T."ID" from public.dblink_fetch('SYS$.....', 1000000)
10    as T("ID" bigint, .....);
11    get diagnostics cnt = row_count;
12    exit when cnt = 0;
13  end loop;
14end; $$

Механизм может быть принудительно заблокирован ключем /NODBLINK.

3. Загрузка данных из внешнего файла

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Временная папка процесса dbsetup.exe (переменная окружения %TMP%) доступна сервису Firebird как источник внешних данных (в конфигурации FireBird - параметр ExternalFileAccess).
  • Таблица не содержит полей типа BLOB.
  • Таблица не содержит обнуляемых полей, все поля таблицы обязательные.
  • Загружаемый блок содержит как минимум 1000 записей.
В этом случае во временной папке будет создан временный файл, содержащий загружаемые данные в требуемом Firebird формате, и выполнены операторы:
1create table "DML..." external '.....'
2  ("ID" BIGINT,
3  ....);
4insert into "..."("ID", ...)
5  select "ID", ....
6  from "DML....";
7drop table "DML....";
После чего временный файл будет удален.

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Владельцу данных доступна на чтение и запись хотя бы одна папка (directory). Этого можно достичь, например, такими операторами:
    1CREATE DIRECTORY dir_name AS 'D:\TEMP';
2GRANT READ,WRITE ON DIRECTORY dir_name TO user_name;
    При этом папка (на диске) должна быть доступна на запись процессу dbsetup.exe.
  • Оператор
    01create table "DML...."
02(
03 ....
04) ORGANIZATION EXTERNAL (
05  DEFAULT DIRECTORY ....
06  ACCESS PARAMETERS (
07    RECORDS DELIMITED BY NEWLINE
08    FIELDS TERMINATED BY '....'
09  )
10  LOCATION ('DML.....')
11)
    выполняется без ошибок. Созданная при этом таблица доступна для чтения.
  • Таблица не содержит полей типа BLOB.
  • Загружаемый блок содержит как минимум 1000 записей.
В этом случае в папке, которая доступна, будет создан временный файл, содержащий загружаемые данные в требуемом Oracle формате, и выполнены операторы:
1create table "DML....."
2(
3 ....
4) ORGANIZATION EXTERNAL (
5....);
6insert into "..."("ID", ...)
7  select "ID", ....
8  from "DML....";
9drop table "DML....";
После чего временный файл будет удален.

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Временная папка процесса dbsetup.exe (переменная окружения %TMP%) доступна сервису PostgreSQL как источник внешних данных.
В этом случае в папке, которая доступна, будет создан временный файл, содержащий загружаемые данные в требуемом Postgres формате. В случае, когда размер файла превысит 1GB, а также по исчерпании источника, будет выполнен оператор
  copy "..."(...) from %TEMP%\DML....CSV with (format csv, encoding UTF8)
После чего временный файл будет удален.

Механизм может быть принудительно заблокирован ключем /NOCSV.

4. Сборка xml-документа на сервере

Механизм создает большую нагрузку на сервер БД, но в то же время позволяет существенно ускорить перекачку данных.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующие условия:
  • Таблица не содержит полей типа BLOB.
  • Таблица не содержит строковых полей, которые могут содержать не-xml-compaint символы (определяется по свойствам соответствующего строкового домена.
В этом случае будут формироваться и выполняться запросы вида
1with T as (select T.* from "...." T order by T."ID")
2select cast(cast(
3  '<data handle="' || count(1) ||  '" eof="1">' || list('<row>' ||
4    '<ID type="int64">' || T."ID" || '</ID>' ||
5      case when T."..." is null then '<.../>' else '<... type="int">' || T."..." || '</...>' end ||
6      ......
7    || '</row>' , '') || '</data>' as blob sub_type 1 character set utf8) as blob sub_type 0), count(1)
8  from T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующие условия:
  • Используется Oracle версии не ниже 11.
  • Таблица не содержит полей типа BLOB.
В этом случае будут формироваться и выполняться запросы вида
1with T as (select T.* from "..." T )
2select "SYS$HELPER"."ClobToBlob"('<data handle="' || count(1) || '" eof="1">' ||
3  xmlagg(xmlelement("row", xmlelement("ID", xmlattributes('int64' as "type"), T."ID"),
4    case when "..." is null then xmltype('<..../>') else
5      xmlelement("....", xmlattributes('ascii' as "type"), "SYS$HELPER"."XMLEscape"(asciistr(T."...."), 0)) end,
6    ....
7 order by T."ID").getclobval() || '</data>'), count(1) from T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующее условие:
  • Таблица не содержит полей типа BLOB.
В этом случае будут формироваться и выполняться запросы вида
1select convert_to( '<data handle="' || count(1) ||  '" eof="1">' || string_agg(
2  '<row>' ||
3    '<ID type="int64">' || T."ID" || '</ID>' ||
4    case when T."...." is null then '<..../>' else '<.... type="int64">' || T."...." || '</....>' end ||
5    .....
6  '</row>', '' order by T."ID") || '</data>', 'UTF8'), count(1) from "..." T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Механизм может быть принудительно заблокирован ключем /NOXML.


Мельница данных ((раздел целиком))

Мельница данных- Класс TStringDomain (Строковые) (раздел целиком) (22.10.2024) (одним файлом)
Класс TStringDomain (Строковые)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

1. Свойства

Свойства класса TStringDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
Length | Integer | Да | Видимо пользователю | Чтение/Запись | Длина
AllowLeadingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись | Допустимы начальные пробелы
AllowTrailingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись | Допустимы конечные пробелы
AllowSpaceDuplication | Boolean | Да | Видимо пользователю | Чтение/Запись | Допустимо дублирование пробелов
CharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Набор символов
FirstCharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Набор символов первого символа
CaseMode | Boolean | Нет | Видимо пользователю | Чтение/Запись | Режим регистра
Mask | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Маска
CaseInsensitiveSearch | Boolean | Да | Видимо пользователю | Чтение/Запись | Регистронезависимый поиск

2. Конструктор Create (Конструктор строкового домена)

Конструктор класса TStringDomain.

1constructor TStringDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean): TDomain;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
Length | Integer | Да | Максимальная длина
AllowLeadingSpaces | Boolean | Да | Допустимы начальные пробелы
AllowTrailingSpaces | Boolean | Да | Допустимы конечные пробелы
AllowSpaceDuplication | Boolean | Да | Допустимо дублирование пробелов
CharacterSet | string[2000] | Нет | Набор символов
FirstCharacterSet | string[2000] | Нет | Набор символов первого символа
CaseMode | Boolean | Нет | Режим регистра
Mask | string[2000] | Нет | Маска
CaseInsensitiveSearch | Boolean | Да | Регистронезависимый поиск

Замечания:

Создает новый объект класса TStringDomain.

3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TStringDomain.

function TStringDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Класс TDateTimeDomain (Даты со временем) (раздел целиком) (22.10.2024) (одним файлом)
Класс TDateTimeDomain (Даты со временем)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

1. Свойства

Свойства класса TDateTimeDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
HideSeconds | Boolean | Да | Видимо пользователю | Чтение/Запись | Не показывать секунды

2. Конструктор Create (Конструктор домена даты со временем)

Конструктор класса TDateTimeDomain.

1constructor TDateTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
HideSeconds | Boolean | Да | Не показывать секунды

Замечания:

Создает новый объект класса TDateTimeDomain.

3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateTimeDomain.

function TDateTimeDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Класс TObjectSet (Множества объектов) (раздел целиком) (22.10.2024) (одним файлом)
Класс TObjectSet (Множества объектов)

Диаграмма

1. Конструктор Create (Создать множество)

Конструктор класса TObjectSet.

constructor TObjectSet.Create: TObjectSet;

Метод не имеет параметров.

Замечания:

Создает новый объект класса TObjectSet.

2. Метод Add (Добавить множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Add(Value: TObjectSet);

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectSet | Нет | Значение

3. Метод Change (Изменение объекта)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Change(Action: TChangeAction);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Действие

4. Метод Clear (Очистить множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Clear;

Метод не имеет параметров.

5. Метод Clone (Клонировать множество)

Метод экземпляра класса TObjectSet.

function TObjectSet.Clone: TObjectSet;

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectSet.

6. Метод CreateFromClob (Создать множество на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectSet.

class function TObjectSet.CreateFromClob(Value: clob): TObjectSet;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа TObjectSet.

7. Метод CreateFromString (Создать множество на основе строки)

Метод класса (статический метод) класса TObjectSet.

class function TObjectSet.CreateFromString(Value: string[2000]): TObjectSet;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа TObjectSet.

8. Метод Exclude (Исключить объект из множества)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Exclude(Value: TObject);

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

9. Метод ExcludeClob (Исключить содержимое большого текстового объекта из множества)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.ExcludeClob(Value: clob);

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

10. Метод ExcludeString (Исключить содержимое строки из множества)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.ExcludeString(Value: string[2000]);

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

11. Метод GetAsClob (Множество в виде большого текстового объекта)

Метод экземпляра класса TObjectSet.

function TObjectSet.GetAsClob: clob;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

12. Метод GetAsString (Множество в виде строки)

Метод экземпляра класса TObjectSet.

function TObjectSet.GetAsString: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

13. Метод Include (Включить объект в множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Include(Value: TObject);

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

14. Метод IncludeClob (Включить содержимое большого текстового объекта в множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.IncludeClob(Value: clob);

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

15. Метод IncludeString (Включить содержимое строки в множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.IncludeString(Value: string[2000]);

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

16. Метод IsExcluded (Объект не входит в множество)

Метод экземпляра класса TObjectSet.

function TObjectSet.IsExcluded(Value: TObject): Boolean;

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

17. Метод IsIncluded (Объект входит в множество)

Метод экземпляра класса TObjectSet.

function TObjectSet.IsIncluded(Value: TObject): Boolean;

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

18. Метод Length (Количество элементов)

Метод экземпляра класса TObjectSet.

function TObjectSet.Length: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

19. Метод Multiply (Умножить на множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Multiply(Value: TObjectSet);

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectSet | Нет | Значение

20. Метод Subtract (Вычесть множество)

Метод экземпляра класса TObjectSet.

procedure TObjectSet.Subtract(Value: TObjectSet);

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectSet | Нет | Значение


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IEnumerationInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IEnumerationInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IEnumerationInfo = interface(ITypeInfo)
3    ['{B58A3F23-1AAC-4420-ADFF-B23B9938A994}']
4    function Get_ItemCount: Integer; safecall;
5    function Get_Item(Index: Integer): IEnumerationItem; safecall;
6    property ItemCount: Integer read Get_ItemCount;
7    property Item[Index: Integer]: IEnumerationItem read Get_Item;
8  end;

1. Свойства

Свойства интерфейса IEnumerationInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
Item[Index: Integer] | IEnumerationItem | Только для чтения |
ItemCount | Integer | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IStringInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IStringInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IStringInfo = interface(ITypeInfo)
3    ['{74AC4C03-E803-421B-B30D-1A2D2C49827F}']
4    function Get_Length: Integer; safecall;
5    property Length: Integer read Get_Length;
6  end;

1. Свойства

Свойства интерфейса IStringInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
Length | Integer | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IBinaryData (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IBinaryData

01type
02  IBinaryData = interface(IDispatch)
03    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
04    procedure Append(Src: OleVariant); safecall;
05    procedure Load(Src: OleVariant); safecall;
06    procedure Save(Dst: OleVariant); safecall;
07    function Size: LongWord; safecall;
08    procedure AppendData(Data: OleVariant; DataSize: LongWord); safecall;
09    procedure SetData(Data: OleVariant; DataSize: LongWord); safecall;
10    procedure GetData(Data: OleVariant); safecall;
11    function ToString(const Encoding: WideString): WideString; safecall;
12    procedure FromString(Data: OleVariant); safecall;
13    procedure AppendString(Data: OleVariant); safecall;
14    function ToBase64(Width: Integer): WideString; safecall;
15    procedure FromBase64(Data: OleVariant); safecall;
16    function ContentIsText: WordBool; safecall;
17  end;

1. Метод Append

Метод интерфейса IBinaryData.

procedure IBinaryData.Append(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

2. Метод AppendData

Метод интерфейса IBinaryData.

procedure IBinaryData.AppendData(Data: OleVariant; DataSize: LongWord);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |
DataSize | LongWord | Да |

3. Метод AppendString

Метод интерфейса IBinaryData.

procedure IBinaryData.AppendString(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

4. Метод ContentIsText

Метод интерфейса IBinaryData.

function IBinaryData.ContentIsText: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

5. Метод FromBase64

Метод интерфейса IBinaryData.

procedure IBinaryData.FromBase64(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

6. Метод FromString

Метод интерфейса IBinaryData.

procedure IBinaryData.FromString(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

7. Метод GetData

Метод интерфейса IBinaryData.

procedure IBinaryData.GetData(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

8. Метод Load

Метод интерфейса IBinaryData.

procedure IBinaryData.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

9. Метод Save

Метод интерфейса IBinaryData.

procedure IBinaryData.Save(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |

10. Метод SetData

Метод интерфейса IBinaryData.

procedure IBinaryData.SetData(Data: OleVariant; DataSize: LongWord);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |
DataSize | LongWord | Да |

11. Метод Size

Метод интерфейса IBinaryData.

function IBinaryData.Size: LongWord;

Метод не имеет параметров.

Замечания:

Возвращает значение типа LongWord.

12. Метод ToBase64

Метод интерфейса IBinaryData.

function IBinaryData.ToBase64(Width: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Width | Integer | Нет |

Замечания:

Возвращает значение типа WideString.

13. Метод ToString

Метод интерфейса IBinaryData.

function IBinaryData.ToString(const Encoding: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Encoding | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Мельница данных ((раздел целиком))

Мельница данных- Справочник по интерфейсам (раздел целиком) (22.10.2024) (одним файлом)
Справочник по интерфейсам

1. Перечисление TAggregateType
1type
2  TAggregateType = (atCount, atSumm, atAverage, atMinimum, atMaximum, atAny,
3    atAll, atCountDistinct);

Или

01type
02  TAggregateType = TOleEnum;
03const
04  atCount = $00000000;
05  atSumm = $00000001;
06  atAverage = $00000002;
07  atMinimum = $00000003;
08  atMaximum = $00000004;
09  atAny = $00000005;
10  atAll = $00000006;
11  atCountDistinct = $00000007;

Элементы перечисления:

Имя | Значение | Назначение
atCount | 0 |
atSumm | 1 |
atAverage | 2 |
atMinimum | 3 |
atMaximum | 4 |
atAny | 5 |
atAll | 6 |
atCountDistinct | 7 |

2. Перечисление TBlobSubType
1type
2  TBlobSubType = (bsText, bsImage, bsBinary);

Или

1type
2  TBlobSubType = TOleEnum;
3const
4  bsText = $00000000;
5  bsImage = $00000001;
6  bsBinary = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
bsText | 0 |
bsImage | 1 |
bsBinary | 2 |

3. Перечисление TDisplayMode
1type
2  TDisplayMode = (dmAlways, dmNever, dmOnDemand);

Или

1type
2  TDisplayMode = TOleEnum;
3const
4  dmAlways = $00000000;
5  dmNever = $00000001;
6  dmOnDemand = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
dmAlways | 0 |
dmNever | 1 |
dmOnDemand | 2 |

4. Перечисление TSimpleType
1type
2  TSimpleType = (dtString, dtInteger, dtFloat, dtDate, dtTime, dtDateTime,
3    dtBoolean, dtEnumeration, dtReference, dtBlob);

Или

01type
02  TSimpleType = TOleEnum;
03const
04  dtString = $00000000;
05  dtInteger = $00000001;
06  dtFloat = $00000002;
07  dtDate = $00000003;
08  dtTime = $00000004;
09  dtDateTime = $00000005;
10  dtBoolean = $00000006;
11  dtEnumeration = $00000007;
12  dtReference = $00000008;
13  dtBlob = $00000009;

Элементы перечисления:

Имя | Значение | Назначение
dtString | 0 |
dtInteger | 1 |
dtFloat | 2 |
dtDate | 3 |
dtTime | 4 |
dtDateTime | 5 |
dtBoolean | 6 |
dtEnumeration | 7 |
dtReference | 8 |
dtBlob | 9 |

5. Интерфейс IApplication

01type
02  IApplication = interface(IDispatch)
03    ['{0E59D500-7A6A-43CA-8007-B7BB7E393CD4}']
04    procedure Execute(const Provider: IUnknown; const Query: OleVariant); safecall;
05    function Get_Visible: WordBool; safecall;
06    procedure Set_Visible(Value: WordBool); safecall;
07    procedure ExecuteTemplate(const Provider: IUnknown; const Query: OleVariant;
08      const TemplateName: WideString); safecall;
09    property Visible: WordBool read Get_Visible write Set_Visible;
10  end;

5.1. Свойства

Свойства интерфейса IApplication:

Имя | Тип | Доступ | Назначение
Visible | WordBool | Чтение/Запись |

5.2. Метод Execute

Метод интерфейса IApplication.

1procedure IApplication.Execute(const Provider: IUnknown;
2  const Query: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Provider | IUnknown | Да |
Query | OleVariant | Да |

5.3. Метод ExecuteTemplate

Метод интерфейса IApplication.

1procedure IApplication.ExecuteTemplate(const Provider: IUnknown;
2  const Query: OleVariant; const TemplateName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Provider | IUnknown | Да |
Query | OleVariant | Да |
TemplateName | WideString | Да |

6. Интерфейс IBlobInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IBlobInfo = interface(ITypeInfo)
3    ['{3905C9C4-EAEB-4844-BB55-3F524F1F3FAC}']
4    function Get_SubType: TBlobSubType; safecall;
5    property SubType: TBlobSubType read Get_SubType;
6  end;

6.1. Свойства

Свойства интерфейса IBlobInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
SubType | TBlobSubType | Только для чтения |

7. Интерфейс IBooleanInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IBooleanInfo = interface(ITypeInfo)
3    ['{8256EDF9-8613-4970-850C-50047839D6BF}']
4    function Get_TrueValue: WideString; safecall;
5    function Get_FalseValue: WideString; safecall;
6    property TrueValue: WideString read Get_TrueValue;
7    property FalseValue: WideString read Get_FalseValue;
8  end;

7.1. Свойства

Свойства интерфейса IBooleanInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
FalseValue | WideString | Только для чтения |
TrueValue | WideString | Только для чтения |

8. Интерфейс IDataSet

01type
02  IDataSet = interface(IUnknown)
03    ['{3CED7395-8482-4EF6-8A15-7744348063C2}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_FieldName(Index: Integer): WideString; safecall;
06    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
07    procedure Next; safecall;
08    function Eof: WordBool; safecall;
09    property FieldCount: Integer read Get_FieldCount;
10    property FieldName[Index: Integer]: WideString read Get_FieldName;
11    property Field[FieldIndex: OleVariant]: OleVariant read Get_Field;
12  end;

8.1. Свойства

Свойства интерфейса IDataSet:

Имя | Тип | Доступ | Назначение
Field[FieldIndex: OleVariant] | OleVariant | Только для чтения |
FieldCount | Integer | Только для чтения |
FieldName[Index: Integer] | WideString | Только для чтения |

8.2. Метод Eof

Метод интерфейса IDataSet.

function IDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

8.3. Метод Next

Метод интерфейса IDataSet.

procedure IDataSet.Next;

Метод не имеет параметров.

9. Интерфейс IDateInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IDateInfo = interface(ITypeInfo)
3    ['{DA392510-105F-4655-9A38-18ECA2FBEB97}']
4  end;

10. Интерфейс IDateTimeInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IDateTimeInfo = interface(ITypeInfo)
3    ['{7F5CC8F9-8CE1-4DB7-8932-884EF3BAB538}']
4  end;

11. Интерфейс IEnumerationInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IEnumerationInfo = interface(ITypeInfo)
3    ['{B58A3F23-1AAC-4420-ADFF-B23B9938A994}']
4    function Get_ItemCount: Integer; safecall;
5    function Get_Item(Index: Integer): IEnumerationItem; safecall;
6    property ItemCount: Integer read Get_ItemCount;
7    property Item[Index: Integer]: IEnumerationItem read Get_Item;
8  end;

11.1. Свойства

Свойства интерфейса IEnumerationInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
Item[Index: Integer] | IEnumerationItem | Только для чтения |
ItemCount | Integer | Только для чтения |

12. Интерфейс IEnumerationItem

Интерфейс INamedItemInfo

1type
2  IEnumerationItem = interface(INamedItemInfo)
3    ['{6953507C-D477-4B8D-9443-A9E5FE7137ED}']
4    function Get_Position: Integer; safecall;
5    property Position: Integer read Get_Position;
6  end;

12.1. Свойства

Свойства интерфейса IEnumerationItem:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Position | Integer | Только для чтения |

13. Интерфейс IExternalDataSet

01type
02  IExternalDataSet = interface(IDispatch)
03    ['{CDC7992C-BB30-431C-9F81-3215175AD5AB}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_FieldName(Index: Integer): WideString; safecall;
06    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
07    procedure Next; safecall;
08    function Eof: WordBool; safecall;
09    property FieldCount: Integer read Get_FieldCount;
10    property FieldName[Index: Integer]: WideString read Get_FieldName;
11    property Field[FieldIndex: OleVariant]: OleVariant read Get_Field;
12  end;

13.1. Свойства

Свойства интерфейса IExternalDataSet:

Имя | Тип | Доступ | Назначение
Field[FieldIndex: OleVariant] | OleVariant | Только для чтения |
FieldCount | Integer | Только для чтения |
FieldName[Index: Integer] | WideString | Только для чтения |

13.2. Метод Eof

Метод интерфейса IExternalDataSet.

function IExternalDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

13.3. Метод Next

Метод интерфейса IExternalDataSet.

procedure IExternalDataSet.Next;

Метод не имеет параметров.

14. Интерфейс IExternalQuery

01type
02  IExternalQuery = interface(IDispatch)
03    ['{1A86D1DA-A56E-4D53-88F9-7A035D7D12B4}']
04    function Get_CurrentQuery: WideString; safecall;
05    function Select(const SQL: WideString): IExternalDataSet; safecall;
06    function SelectedRecordsCount: Integer; safecall;
07    function SelectedRecord(Index: Integer): OleVariant; safecall;
08    procedure PlaceCurrentQuery(const Sheet: IDispatch; CaptionsNeeded: WordBool;
09      Row: Integer; Column: Integer; ShiftRows: WordBool; ShiftColumns: WordBool); safecall;
10    procedure PlaceQuery(const Sheet: IDispatch; const DataSet: ExternalDataSet;
11      Row: Integer; Column: Integer; ShiftRows: WordBool; ShiftColumns: WordBool); safecall;
12    property CurrentQuery: WideString read Get_CurrentQuery;
13  end;

14.1. Свойства

Свойства интерфейса IExternalQuery:

Имя | Тип | Доступ | Назначение
CurrentQuery | WideString | Только для чтения |

14.2. Метод PlaceCurrentQuery

Метод интерфейса IExternalQuery.

1procedure IExternalQuery.PlaceCurrentQuery(const Sheet: IDispatch;
2  CaptionsNeeded: WordBool; Row: Integer; Column: Integer; ShiftRows: WordBool;
3  ShiftColumns: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Sheet | IDispatch | Да |
CaptionsNeeded | WordBool | Нет |
Row | Integer | Нет |
Column | Integer | Нет |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |

14.3. Метод PlaceQuery

Метод интерфейса IExternalQuery.

1procedure IExternalQuery.PlaceQuery(const Sheet: IDispatch;
2  const DataSet: ExternalDataSet; Row: Integer; Column: Integer;
3  ShiftRows: WordBool; ShiftColumns: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Sheet | IDispatch | Да |
DataSet | ExternalDataSet | Да |
Row | Integer | Нет |
Column | Integer | Нет |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |

14.4. Метод Select

Метод интерфейса IExternalQuery.

function IExternalQuery.Select(const SQL: WideString): IExternalDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
SQL | WideString | Да |

Замечания:

Возвращает значение типа IExternalDataSet.

14.5. Метод SelectedRecord

Метод интерфейса IExternalQuery.

function IExternalQuery.SelectedRecord(Index: Integer): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа OleVariant.

14.6. Метод SelectedRecordsCount

Метод интерфейса IExternalQuery.

function IExternalQuery.SelectedRecordsCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

15. Интерфейс IFieldInfo

Интерфейс INamedItemInfo

1type
2  IFieldInfo = interface(INamedItemInfo)
3    ['{19054DAD-8D35-4B39-8EB7-FD3254BD2934}']
4    function Get_TypeInfo: ITypeInfo; safecall;
5    function Get_DisplayMode: TDisplayMode; safecall;
6    property TypeInfo: ITypeInfo read Get_TypeInfo;
7    property DisplayMode: TDisplayMode read Get_DisplayMode;
8  end;

15.1. Свойства

Свойства интерфейса IFieldInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
DisplayMode | TDisplayMode | Только для чтения |
TypeInfo | ITypeInfo | Только для чтения |

16. Интерфейс IFieldInfo2

Интерфейс IFieldInfoИнтерфейс INamedItemInfo

1type
2  IFieldInfo2 = interface(IFieldInfo)
3    ['{82D93CF0-0E2F-4A85-AD74-9B1B9199B76B}']
4    function Get_Category: WideString; safecall;
5    property Category: WideString read Get_Category;
6  end;

16.1. Свойства

Свойства интерфейса IFieldInfo2:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
DisplayMode | TDisplayMode | Только для чтения | Унаследовано от IFieldInfo
TypeInfo | ITypeInfo | Только для чтения
Category | WideString | Только для чтения |

17. Интерфейс IFloatInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

01type
02  IFloatInfo = interface(ITypeInfo)
03    ['{E9B56C6D-47DC-4AB9-9E80-6EEF77708704}']
04    function Get_MaxValue: Double; safecall;
05    function Get_MaxValueUsed: WordBool; safecall;
06    function Get_MinValue: Double; safecall;
07    function Get_MinValueUsed: WordBool; safecall;
08    function Get_Precision: Integer; safecall;
09    function Get_Scale: Integer; safecall;
10    property MaxValue: Double read Get_MaxValue;
11    property MaxValueUsed: WordBool read Get_MaxValueUsed;
12    property MinValue: Double read Get_MinValue;
13    property MinValueUsed: WordBool read Get_MinValueUsed;
14    property Precision: Integer read Get_Precision;
15    property Scale: Integer read Get_Scale;
16  end;

17.1. Свойства

Свойства интерфейса IFloatInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
MaxValue | Double | Только для чтения |
MaxValueUsed | WordBool | Только для чтения |
MinValue | Double | Только для чтения |
MinValueUsed | WordBool | Только для чтения |
Precision | Integer | Только для чтения |
Scale | Integer | Только для чтения |

18. Интерфейс IInfoProvider

01type
02  IInfoProvider = interface(IUnknown)
03    ['{64F8072B-7250-4C57-BA8E-D018C7B72CC7}']
04    function Get_TableCount: Integer; safecall;
05    function Get_Table(Index: Integer): ITableInfo; safecall;
06    function Perform(const SQL: WideString): IDataSet; safecall;
07    procedure Connect(const DataBase: WideString; const UserName: WideString;
08      const Password: WideString); safecall;
09    function Get_CLSID: GUID; safecall;
10    function Get_DateLiteral: WideString; safecall;
11    function Get_TimeLiteral: WideString; safecall;
12    function Get_DateTimeLiteral: WideString; safecall;
13    function Get_RegExpLiteral: WideString; safecall;
14    function Get_ToBooleanLiteral: WideString; safecall;
15    function Get_ToStringLiteral: WideString; safecall;
16    function Get_AllowStartingWith: WordBool; safecall;
17    function Get_AllowArrays: WordBool; safecall;
18    function Get_DisallowNullsSorting: WordBool; safecall;
19    function Get_DisallowSubqueries: WordBool; safecall;
20    function Get_DisallowBetween: WordBool; safecall;
21    function Get_LikeAlwaysEscaped: WordBool; safecall;
22    function Get_MaxIdentLength: Integer; safecall;
23    function Get_ReplaceRegExpDotsWithUnderscore: WordBool; safecall;
24    function Get_Epsilon: WideString; safecall;
25    property TableCount: Integer read Get_TableCount;
26    property Table[Index: Integer]: ITableInfo read Get_Table;
27    property CLSID: GUID read Get_CLSID;
28    property DateLiteral: WideString read Get_DateLiteral;
29    property TimeLiteral: WideString read Get_TimeLiteral;
30    property DateTimeLiteral: WideString read Get_DateTimeLiteral;
31    property RegExpLiteral: WideString read Get_RegExpLiteral;
32    property ToBooleanLiteral: WideString read Get_ToBooleanLiteral;
33    property ToStringLiteral: WideString read Get_ToStringLiteral;
34    property AllowStartingWith: WordBool read Get_AllowStartingWith;
35    property AllowArrays: WordBool read Get_AllowArrays;
36    property DisallowNullsSorting: WordBool read Get_DisallowNullsSorting;
37    property DisallowSubqueries: WordBool read Get_DisallowSubqueries;
38    property DisallowBetween: WordBool read Get_DisallowBetween;
39    property LikeAlwaysEscaped: WordBool read Get_LikeAlwaysEscaped;
40    property MaxIdentLength: Integer read Get_MaxIdentLength;
41    property ReplaceRegExpDotsWithUnderscore: WordBool
42      read Get_ReplaceRegExpDotsWithUnderscore;
43    property Epsilon: WideString read Get_Epsilon;
44  end;

18.1. Свойства

Свойства интерфейса IInfoProvider:

Имя | Тип | Доступ | Назначение
AllowArrays | WordBool | Только для чтения |
AllowStartingWith | WordBool | Только для чтения |
CLSID | GUID | Только для чтения |
DateLiteral | WideString | Только для чтения |
DateTimeLiteral | WideString | Только для чтения |
DisallowBetween | WordBool | Только для чтения |
DisallowNullsSorting | WordBool | Только для чтения |
DisallowSubqueries | WordBool | Только для чтения |
Epsilon | WideString | Только для чтения |
LikeAlwaysEscaped | WordBool | Только для чтения |
MaxIdentLength | Integer | Только для чтения |
RegExpLiteral | WideString | Только для чтения |
ReplaceRegExpDotsWithUnderscore | WordBool | Только для чтения |
Table[Index: Integer] | ITableInfo | Только для чтения |
TableCount | Integer | Только для чтения |
TimeLiteral | WideString | Только для чтения |
ToBooleanLiteral | WideString | Только для чтения |
ToStringLiteral | WideString | Только для чтения |

18.2. Метод Connect

Метод интерфейса IInfoProvider.

1procedure IInfoProvider.Connect(const DataBase: WideString;
2  const UserName: WideString; const Password: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
DataBase | WideString | Да |
UserName | WideString | Да |
Password | WideString | Да |

18.3. Метод Perform

Метод интерфейса IInfoProvider.

function IInfoProvider.Perform(const SQL: WideString): IDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
SQL | WideString | Да |

Замечания:

Возвращает значение типа IDataSet.

19. Интерфейс IInfoProvider2

01type
02  IInfoProvider2 = interface(IDispatch)
03    ['{BED44934-BCF9-4942-933D-591AB40D4CFE}']
04    function Get_AutoCheckKeys: WordBool; safecall;
05    function Get_OptionCount: Integer; safecall;
06    function Get_Option(Index: Integer): IOptionInfo; safecall;
07    property AutoCheckKeys: WordBool read Get_AutoCheckKeys;
08    property OptionCount: Integer read Get_OptionCount;
09    property Option[Index: Integer]: IOptionInfo read Get_Option;
10  end;

19.1. Свойства

Свойства интерфейса IInfoProvider2:

Имя | Тип | Доступ | Назначение
AutoCheckKeys | WordBool | Только для чтения |
Option[Index: Integer] | IOptionInfo | Только для чтения |
OptionCount | Integer | Только для чтения |

20. Интерфейс IInfoProvider3

1type
2  IInfoProvider3 = interface(IDispatch)
3    ['{EF0E186A-4C72-4C40-B61C-72D7D03B2D10}']
4    procedure SetLogonInfo(const Login: WideString); safecall;
5  end;

20.1. Метод SetLogonInfo

Метод интерфейса IInfoProvider3.

procedure IInfoProvider3.SetLogonInfo(const Login: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Login | WideString | Да |

21. Интерфейс IIntegerInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

01type
02  IIntegerInfo = interface(ITypeInfo)
03    ['{9003B25E-926D-42AE-A907-813DF3A8343E}']
04    function Get_MaxValue: Integer; safecall;
05    function Get_MaxValueUsed: WordBool; safecall;
06    function Get_MinValue: Integer; safecall;
07    function Get_MinValueUsed: WordBool; safecall;
08    property MaxValue: Integer read Get_MaxValue;
09    property MaxValueUsed: WordBool read Get_MaxValueUsed;
10    property MinValue: Integer read Get_MinValue;
11    property MinValueUsed: WordBool read Get_MinValueUsed;
12  end;

21.1. Свойства

Свойства интерфейса IIntegerInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
MaxValue | Integer | Только для чтения |
MaxValueUsed | WordBool | Только для чтения |
MinValue | Integer | Только для чтения |
MinValueUsed | WordBool | Только для чтения |

22. Интерфейс INamedItemInfo

01type
02  INamedItemInfo = interface(IUnknown)
03    ['{14894363-28DA-4E71-B0BC-9C5CE811BC8F}']
04    function Get_Name: WideString; safecall;
05    function Get_Caption: WideString; safecall;
06    function Get_ID: WideString; safecall;
07    property Name: WideString read Get_Name;
08    property Caption: WideString read Get_Caption;
09    property ID: WideString read Get_ID;
10  end;

22.1. Свойства

Свойства интерфейса INamedItemInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения |
ID | WideString | Только для чтения |
Name | WideString | Только для чтения |

23. Интерфейс IOptionInfo

Интерфейс INamedItemInfo

01type
02  IOptionInfo = interface(INamedItemInfo)
03    ['{453E81A2-969D-49DC-B3C6-ACAD411D63FC}']
04    function Get_TypeInfo: ITypeInfo; safecall;
05    function Get_Group: WideString; safecall;
06    function Get_Tab: WideString; safecall;
07    function Get_Value: OleVariant; safecall;
08    procedure Set_Value(Value: OleVariant); safecall;
09    property TypeInfo: ITypeInfo read Get_TypeInfo;
10    property Group: WideString read Get_Group;
11    property Tab: WideString read Get_Tab;
12    property Value: OleVariant read Get_Value write Set_Value;
13  end;

23.1. Свойства

Свойства интерфейса IOptionInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Group | WideString | Только для чтения |
Tab | WideString | Только для чтения |
TypeInfo | ITypeInfo | Только для чтения |
Value | OleVariant | Чтение/Запись |

24. Интерфейс IReferenceInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IReferenceInfo = interface(ITypeInfo)
3    ['{309C8CB1-4A1C-4E58-BC3F-D1AF27861A8F}']
4    function Get_TargetTable: ITableInfo; safecall;
5    property TargetTable: ITableInfo read Get_TargetTable;
6  end;

24.1. Свойства

Свойства интерфейса IReferenceInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
TargetTable | ITableInfo | Только для чтения |

25. Интерфейс IStringInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IStringInfo = interface(ITypeInfo)
3    ['{74AC4C03-E803-421B-B30D-1A2D2C49827F}']
4    function Get_Length: Integer; safecall;
5    property Length: Integer read Get_Length;
6  end;

25.1. Свойства

Свойства интерфейса IStringInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
Length | Integer | Только для чтения |

26. Интерфейс ITableInfo

Интерфейс INamedItemInfo

01type
02  ITableInfo = interface(INamedItemInfo)
03    ['{3FC1998A-9031-4936-82B5-8CAA2219085E}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_Field(Index: Integer): IFieldInfo; safecall;
06    function Get_PrimaryKey: IFieldInfo; safecall;
07    function Get_Uplink: IFieldInfo; safecall;
08    function Get_Parent: ITableInfo; safecall;
09    function Get_RootAvailable: WordBool; safecall;
10    property FieldCount: Integer read Get_FieldCount;
11    property Field[Index: Integer]: IFieldInfo read Get_Field;
12    property PrimaryKey: IFieldInfo read Get_PrimaryKey;
13    property Uplink: IFieldInfo read Get_Uplink;
14    property Parent: ITableInfo read Get_Parent;
15    property RootAvailable: WordBool read Get_RootAvailable;
16  end;

26.1. Свойства

Свойства интерфейса ITableInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения |
FieldCount | Integer | Только для чтения |
Parent | ITableInfo | Только для чтения |
PrimaryKey | IFieldInfo | Только для чтения |
RootAvailable | WordBool | Только для чтения |
Uplink | IFieldInfo | Только для чтения |

27. Интерфейс ITableInfo2

Интерфейс ITableInfoИнтерфейс INamedItemInfo

01type
02  ITableInfo2 = interface(ITableInfo)
03    ['{9DF4C8AC-1DA2-4E7B-BF44-7EDD7A269418}']
04    function Get_PolymorphCount: Integer; safecall;
05    function Get_PolymorphTable(Index: Integer): ITableInfo; safecall;
06    function Get_PolymorphField(Index: Integer): IFieldInfo; safecall;
07    property PolymorphCount: Integer read Get_PolymorphCount;
08    property PolymorphTable[Index: Integer]: ITableInfo read Get_PolymorphTable;
09    property PolymorphField[Index: Integer]: IFieldInfo read Get_PolymorphField;
10  end;

27.1. Свойства

Свойства интерфейса ITableInfo2:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения | Унаследовано от ITableInfo
FieldCount | Integer | Только для чтения
Parent | ITableInfo | Только для чтения
PrimaryKey | IFieldInfo | Только для чтения
RootAvailable | WordBool | Только для чтения
Uplink | IFieldInfo | Только для чтения
PolymorphCount | Integer | Только для чтения |
PolymorphField[Index: Integer] | IFieldInfo | Только для чтения |
PolymorphTable[Index: Integer] | ITableInfo | Только для чтения |

28. Интерфейс ITableInfo3

Интерфейс ITableInfoИнтерфейс INamedItemInfo

01type
02  ITableInfo3 = interface(ITableInfo)
03    ['{3FB73AA9-010C-48DA-81C7-E1DCFE2E6136}']
04    function GetPersistentClause(const Alias: WideString): WideString; safecall;
05    function GetPreConditionsCount: Integer; safecall;
06    function GetPreConditionCaption(Index: Integer): WideString; safecall;
07    function Get_ActivePreCondition(Index: Integer): WordBool; safecall;
08    procedure Set_ActivePreCondition(Index: Integer; Value: WordBool); safecall;
09    function GetPreConditionParamsCount(Index: Integer): Integer; safecall;
10    function GetPreConditionParam(Index: Integer;
11      PreConditionIndex: Integer): IOptionInfo; safecall;
12    function GetPreConditionCategory(Index: Integer): WideString; safecall;
13    property ActivePreCondition[Index: Integer]: WordBool
14      read Get_ActivePreCondition write Set_ActivePreCondition;
15  end;

28.1. Свойства

Свойства интерфейса ITableInfo3:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения | Унаследовано от ITableInfo
FieldCount | Integer | Только для чтения
Parent | ITableInfo | Только для чтения
PrimaryKey | IFieldInfo | Только для чтения
RootAvailable | WordBool | Только для чтения
Uplink | IFieldInfo | Только для чтения
ActivePreCondition[Index: Integer] | WordBool | Чтение/Запись |

28.2. Метод GetPersistentClause

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPersistentClause(const Alias: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Alias | WideString | Да |

Замечания:

Возвращает значение типа WideString.

28.3. Метод GetPreConditionCaption

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionCaption(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.

28.4. Метод GetPreConditionCategory

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionCategory(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.

28.5. Метод GetPreConditionParam

Метод интерфейса ITableInfo3.

1function ITableInfo3.GetPreConditionParam(Index: Integer;
2  PreConditionIndex: Integer): IOptionInfo;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |
PreConditionIndex | Integer | Да |

Замечания:

Возвращает значение типа IOptionInfo.

28.6. Метод GetPreConditionParamsCount

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionParamsCount(Index: Integer): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа Integer.

28.7. Метод GetPreConditionsCount

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionsCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

29. Интерфейс ITimeInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  ITimeInfo = interface(ITypeInfo)
3    ['{D7067CAC-67A5-41DB-8D95-40409D8658AB}']
4  end;

30. Интерфейс ITypeInfo

Интерфейс INamedItemInfo

1type
2  ITypeInfo = interface(INamedItemInfo)
3    ['{2B6A5E20-3C36-4574-89DB-7C873A5C4A00}']
4    function Get_Required: WordBool; safecall;
5    function Get_SimpleType: TSimpleType; safecall;
6    property Required: WordBool read Get_Required;
7    property SimpleType: TSimpleType read Get_SimpleType;
8  end;

30.1. Свойства

Свойства интерфейса ITypeInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения |
SimpleType | TSimpleType | Только для чтения |

31. Интерфейс ITypeInfo2

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  ITypeInfo2 = interface(ITypeInfo)
3    ['{77F58BDF-F01C-40F3-B193-1027AD8C4EDA}']
4    function GetSpecialFilterCount: Integer; safecall;
5    function GetSpecialFilterText(Index: Integer): WideString; safecall;
6    function EditSpecialFilter(Index: Integer; var Filter: WideString): WordBool; safecall;
7  end;

31.1. Метод EditSpecialFilter

Метод интерфейса ITypeInfo2.

1function ITypeInfo2.EditSpecialFilter(Index: Integer;
2  var Filter: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |
Filter | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

31.2. Метод GetSpecialFilterCount

Метод интерфейса ITypeInfo2.

function ITypeInfo2.GetSpecialFilterCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

31.3. Метод GetSpecialFilterText

Метод интерфейса ITypeInfo2.

function ITypeInfo2.GetSpecialFilterText(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.


Мельница данных ((раздел целиком))

Мельница данных- Класс TWordTemplate (Шаблоны отчетов Word) (раздел целиком) (22.10.2024) (одним файлом)
Класс TWordTemplate (Шаблоны отчетов Word)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

1. Свойства

Свойства класса TWordTemplate:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
TemplateData | blob | Нет | Видимо пользователю | Чтение/Запись | Данные шаблона
MacroName | string[128] | Нет | Видимо пользователю | Чтение/Запись | Имя макроса
IsInteractive | Boolean | Да | Видимо пользователю | Чтение/Запись | Интерактивный

2. Конструктор Create (Конструктор шаблона отчета Word)

Конструктор класса TWordTemplate.

1constructor TWordTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  MacroName: string[128]; IsInteractive: Boolean): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
TemplateData | blob | Нет | Данные шаблона
MacroName | string[128] | Нет | Имя макроса
IsInteractive | Boolean | Да | Интерактивный

Замечания:

Создает новый объект класса TWordTemplate.

3. Метод Ole-объекта CheckWordTemplate (Проверить шаблон отчетов Word)

Метод Ole-объекта класса TWordTemplate.

Метод Ole-объекта не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Этапы разработки прикладных решений (раздел целиком) (22.10.2024) (одним файлом)
Этапы разработки прикладных решений

1. Формирование видения модели

2. Создание структур хранения и средств обработки данных

2.1. Класс TObject, члены класса TОbject

2.2. Создание классов

2.3. Создание полей

2.4. Создание свойств

2.5. Создание методов

3. Синхронизаци базы данных

4. Создание пользователей и ролей

5. Средства моделирования пользовательских интерфейсов

5.1. Представления

5.2. Формы. Включение представлений в формы

5.3. Визуальные группы. Включение форм в визуальные группы

5.4. Организация доступа пользователей к формам и визуальным группам

6. Разработка отчетов

6.1. Создание шаблонов PDF-отчетов

6.1.1. Описание

Portable Document Format (PDF) — кроссплатформенный формат электронных документов, созданный фирмой Adobe Systems с использованием ряда возможностей языка PostScript. В первую очередь предназначен для представления в электронном виде полиграфической продукции, — значительное количество современного профессионального печатного оборудования может обрабатывать PDF непосредственно. Для просмотра можно использовать официальную бесплатную программу Adobe Reader, а также программы сторонних разработчиков. Традиционным способом создания PDF-документов является виртуальный принтер, то есть документ как таковой готовится в своей специализированной программе — графической программе или текстовом редакторе, САПР и т. д., а затем экспортируется в формат PDF для распространения в электронном виде, передачи в типографию и т. п. Формат PDF позволяет внедрять необходимые шрифты (построчный текст), векторные и растровые изображения, формы и мультимедиа-вставки. Поддерживает RGB, CMYK, Grayscale, Lab, Duotone, Bitmap, несколько типов сжатия растровой информации. Имеет собственные технические форматы для полиграфии: PDF/X-1, PDF/X-3. Включает механизм электронных подписей для защиты и проверки подлинности документов. В этом формате распространяется большое количество сопутствующей документации. Чаще всего PDF-файл является комбинацией текста с растровой и векторной графикой, реже — текста с формами, JavaScript'ом, 3D-графикой и другими типами элементов.

В приложениях Платформы "Мельница данных" для создания PDF-документов используется собственная библиотека PDFCreator.dll. С помощью библиотеки возможно прямое создание документов версии 1.3 . Создание PDF-документов осуществляется путем ввода предопределенных в библиотеке команд, которые в дальнейшем интерпретируются на основе языка описания страниц POSTSCRIPT.

Все размеры графических объектов, размеры страниц, шрифтов и т.п. по умолчанию заданы в миллиметрах.
Для удобства построения шаблона PDF-документа создана функция DrawGrid. При ее включении при отладке при создании шаблона будет отображена визуальная сетка с шагом 5 миллиметров.

6.1.2. Методы

6.1.2.1. Свойства документа

Для создания и описания свойств PDF-документа в библиотеке PDFCreator.dll используется класс IPDFDocument, обладающий следующими свойствами:

  • Title (WideString) - заголовок документа. По умолчанию - пустая строка.
    Title = "DOC1"
  • CanEmbedFonts (WordBool) - Признак возможности построения PDF- документа со встроенными шрифтами (Embedded Fonts). В случае включения признака, все объявленные в скрипте шрифты будут включены в сборку документа и будут передаваться целиком вместе с документом. По умолчанию - False.
    CanEmbedFonts = True
CanEmbedFonts = False
  • CanCompress (WordBool) - признак сжатия документа при создании по собственным алгоритмам. По умолчанию - True.
    CanCompress = False
CanCompress = True
  • Author (WideString) - автор документа. По умолчанию - текущий пользователь ОС.
  • Subject (WideString) - описание документа. По умолчанию - пустая строка.
  • Keywords (WideString) - ключевые слова для поиска по документу. По умолчанию - пустая строка.
  • Creator (WideString) - приложение-родитель документа. Указывается в том случае, если документ был сконвертирован из другого формата.
  • PageCount (Integer) - свойство, содержащее общее количество страниц в документе.
  • Pages[Index: Integer]: IPDFPage - свойство документа, предназначенное для перебора страниц документа для совершения над ними однотипных действий.

    Пример использования:

    1for I = 0 to PageCount - 1
2  Pages(I).rectangle 10,10,10,10, false
3next
Save "c:\pdf.pdf"

    Результат: На всех страницах документа будут нарисованы квадраты 10х10 мм.
  • procedure Save(Target: OleVariant) - процедура для сохранения документа PDF на жесткий диск сразу после создания.
    Save "c:\pdf.pdf"
    - сохранит документ в файл c:\pdf.pdf

6.1.2.2. Свойства страницы

Для создания страницы используется функция

function CreatePage(Parent: OleVariant): IPDFPage;

Параметр Parent указывает страницу-родителя для данной страницы. Если страницы- родителя быть не должно - формат вызова функции примет вид:

set page = CreatePage(Null)

Параметры страницы:

  • Title - заголовок страницы.
    page.Title = "Page name"
  • Width - ширина страницы, миллиметры
    page.Width = 80
  • Height - высота страницы, миллиметры
    page.Height = 80
  • DrawGrid - процедура, выводящая на страницу сетку с шагом 5 миллиметров для удобства отладки вида документа.
  • Perform - процедура, позволяющая выполнить дополнительные команды PostScript на странице.
    page.perform "1 0.7 0 0 k"page.perform "0 0 m"

6.1.2.2.1. Объявление цвета

Для объявления цвета объектов на странице используется цветовая модель R:G:B (Red:Green:Blue). Объявление цвета для выполнения последующих операций (цвет шрифта, цвет линии/фигуры) осуществляется процедурой

procedure SetColor(R: Integer; G: Integer; B: Integer);
Где параметры R, G, B - значения базисных цветов для выбранного цвета (от 0 до 255).

Цвет | R | G | B |
Белый | 255 | 255 | 255 | +++
Черный | 0 | 0 | 0 | +++
Серый | 190 | 190 | 190 | +++
Синий | 0 | 0 | 255 | +++
Красный | 255 | 0 | 0 | +++
Зеленый | 0 | 255 | 0 | +++

Если предварительно цвет не был объявлен, используется цвет по умолчанию - черный (0,0,0)

6.1.2.3. Графика

6.1.2.3.1. Линии

Для отрисовки линий используется процедура

procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double);
Здесь:

  • X1 - координата начала линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y1 - координата начала линии по вертикали в миллиметрах от верхнего левого угла листа.
  • X2 - координата конца линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y2 - координата Конца линии по вертикали в миллиметрах от верхнего левого угла листа.

Для задания толщины линии используется свойство

property LineWidth: Double
Значение толщины задается в миллиметрах. Значение по умолчанию - минимально возможная единица рисования для устройства. Так для монитора - 1 pixel, для принтера - 1 dot (точка)

Для задания стиля отрисовки начала/окончания линии используется свойство property LineCap: TPDFLineCap
Возможные стили:
Значение свойства: | Отображение: | Описание:
0 | Линия 0 | Прямой срез точно по точкам начала и окончания линии (по умолчанию)
1 | Линия 1 | С закруглением
2 | Линия 2 | Прямой срез с продолжением линии на половину толщины линии

Объявление цвета линии.

Две линии разной толщины, с разными окончаниями и цветами:
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineCap = 1
06
07page.LineWidth = 2
08
09page.Line 10, 10, 30, 30
10
11page.LineWidth = 4
12
13page.SetColor 255, 0, 0
14
15page.LineCap = 2
16
page.Line 10, 30, 30, 10."I

Результат:
2 линии

При необходимости соединения линий под углом в определенной точке можно задать тип соединения. Для объявления типа соединения используется свойство property LineJoin: TPDFLineJoin;
Типы соединения двух линий:
Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пунктир

Для создания пунктира используется процедура отображения линии с предварительно объявленными дополнительными значениями.

Процедура procedure SetDash(DashArray: OleVariant; Phase: Integer); Здесь DashArray - массив значений в миллиметрах, указывающий последовательность чередования штрихов и пропусков на линии, Phase - смещение в миллиметрах по линии.

Пример 1. Штрих 10 мм, Промежуток 5 мм, Смещения нет
Пример 2. Штрих 10 мм, Промежуток 5 мм, Смещение 5 мм
Пример 3. Различные значения штрихов и промежутков, Смещения нет
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 3
06
07page.SetDash Array(10, 5), 0
08
09page.Line 10, 10, 100, 10
10
11page.SetDash Array(10, 5), 5
12
13page.Line 10, 20, 100, 20
14
15page.SetDash Array(10, 5, 3, 2, 12, 20), 0
16
page.Line 10, 30, 100, 30

Результат:
Пунктир 1

Ломанная линия - здесь непрерывная линия, состоящая из нескольких прямых. Для отображения ломанной используется процедура procedure Poly(Points: OleVariant; Fill: WordBool), где Points - массив координат точек соединяемых прямыми, а Fill - признак заливки полученной замкнутой фигуры (если замкнута).

Пример Звезда без заливки
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), false

Результат:
Звезда
Пример Звезда с заливкой
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), true

Результат:
Звезда заливка

6.1.2.3.2. Прямоугольник

Rectangle (Прямоугольник) - для создания используется процедура:

procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double; Fill: WordBool);
Здесь:

  • X1 - координата верхнего левого угла прямоугольника по горизонтали в миллиметрах от верхнего левого угла листа шаблона.
  • Y1 - координата верхнего левого угла прямоугольника по вертикали в миллиметрах от верхнего левого угла листа шаблона.
  • Width - ширина прямоугольника с миллиметрах.
  • Height - высота прямоугольника с миллиметрах.
  • Fill - признак заливки прямоугольника (True/False). Если значение True то заливка производится объявленным заранее цветом (см. Объявление цвета). Если False - заливка не производится. Прямоугольник отрисовывается линиями с предварительно заданной толщиной. См. Линии
Пример 1. Создание красного прямоугольника:
1set page = CreatePage(Null)
2
3page.SetColor 255, 0, 0
4
5page.Rectangle 10, 15, 40, 20, True
6
page.DrawGrid
Результат:
Прямоугольник
Пример 2. Пустой прямоугольник без задания цвета:
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.Rectangle 12, 17, 42, 25, false
6
page.DrawGrid

Результат:
Прямоугольник false

Также существует возможность изменения стиля отображения углов прямоугольника. Для этого нужно использовать свойство property LineJoin: TPDFLineJoin;

Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пример построения прямоугольников с различными типами соединения сторон:

01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 4
06
07page.LineJoin = 0
08
09page.Rectangle 10, 10, 20, 10, false
10
11page.LineJoin = 1
12
13page.Rectangle 40, 10, 20, 10, false
14
15page.LineJoin = 2
16
page.Rectangle 70, 10, 20, 10, false

Результат:
3 прямоугольника

6.1.2.3.3. Вставка готовых изображений

Для вставки на создаваемую страницу готового изображения используется процедура procedure Image(const FileName: WideString; X: Double; Y: Double; Width: Double; Height: Double)

Параметры:

  • const FileName - имя файла изображения и путь к нему на жестком диске. Задается в кавычках.
  • X - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по горизонтали в миллиметрах
  • Y - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по вертикали в миллиметрах
  • Width - ширина изображения в миллиметрах
  • Height - высота изображения в миллиметрах.
1set page = CreatePage(Null)
2page.drawgrid
page.Image "c:\mill.bmp", 10,10, 30, 30

Результат:
Картинка

Вне зависимости от размера исходного изображения, при вставке изображения на создаваемую страницу оно будет растянуто по размерам, прописанным в процедуре.

6.1.2.3.4. Векторная графика

Язык PostScript, с помощью которого создаются векторные изображения для PDF-документа, поддерживает создание типичных примитивных объектов, таких как:

  • Прямые и ломанные линии
  • Многоугольники
  • Окружности и эллипсы
  • Кривые Безье
  • Текст

При создании векторного изображения на странице PDF-документа в приложениях Платформы, команды построения примитивных объектов PostScript передаются на исполнение при помощи процедуры Perform. Подробнее об операторах и командах PostScript для создания PDF-документов можно узнать на сайте Adobe

6.1.2.4. Шрифты

Шрифты, которые должны использоваться в создаваемом документе, должны быть предварительно объявлены. Для объявления используемых шрифтов используется функция
function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool; Italic: WordBool): IPDFFont; где:

  • const FontName - имя шрифта, аналогичное имени объявляемого шрифта в операционной системе. В Функции объявляется в кавычках.
  • Size - размер шрифта в пунктах
  • Bold - признак начертания шрифта "жирный". Значения - True или False
  • Italic - признак начертания шрифта "курсив". Значения - True или False
Примеры объявления шрифтов:
1set font = page.createFont("Arial", 20, False, False)
2set labelFont = page.createFont("Times New Roman", 16, False, True)
3set dataFont = page.createFont("Tahoma", 18, True, False)

Для вывода текстовой информации на страницу используются процедуры:

  • procedure WriteLine(const LineText: WideString; X: Double; Y: Double);
    - используется для вывода текстовой строки
  • function WriteText(const AText: WideString; X: Double; Y: Double; Width: Double; Alignment: TPDFTextAlignment): Double;
    - используется для вывода текстового блока.

Параметры для procedure WriteLine :

  • const LineText - текстовая строка для вывода. Прописывается в кавычках. Будет выведена на страницу одной строкой.
  • X - координата верхней левой точки текстовой строки по горизонтали в миллиметрах.
  • Y - координата верхней левой точки текстовой строки по вертикали в миллиметрах.
Примеры вывода текстов на страницу:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Times New Roman", 16, False, True)
05set dataFont = page.createFont("Tahoma", 18, True, False)
06Font.WriteLine "Фамилия", 5, 2
07Font.WriteLine "Имя", 5, 10
08Font.WriteLine "Отчество", 5, 18
09labelFont.WriteLine "Дата рождения", 5, 26
10dataFont.WriteLine "Национальность", 5, 34

Результат:
Разные шрифты

Параметры для function WriteText :

  • const AText - текст для вывода на страницу. Прописывается в кавычках. Будет выведена на страницу в виде текстового блока.
  • X - координата верхней левой точки текстового блока по горизонтали в миллиметрах.
  • Y - координата верхней левой точки текстового блока по вертикали в миллиметрах.
  • Width - ширина текстового блока в миллиметрах
  • Alignment - тип выравнивания текста в текстовом блоке.
    Значение параметра | Тип выравнивания
    0 | По левому краю
    1 | По правому краю
    2 | По центру
    3 | Выравнивание по ширине
Примеры вывода текстовых блоков на страницу:
1set page = CreatePage(Null)
2page.DrawGrid
3set font = page.createFont("Arial", 14, False, False)
4set labelFont = page.createFont("Times New Roman", 12, False, True)
5set dataFont = page.createFont("Tahoma", 11, True, False)
6Q = font.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 5, 100, 0)
7Q = labelFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 35, 100, 1)
8Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 55, 100, 2)
9Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 80, 100, 3)

Результат:
Выравнивание

Свойства шрифтов:

property Spacing: Double; - свойство, отвечающее за величину промежутка между буквами в слове. Задается в виде отклонения от промежутка между буквами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Spacing = 0
07labelFont.Spacing = 1
08dataFont.Spacing = 2
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (1 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 15

Результат:
Промежуток букв

property WordSpacing: Double; - свойство, отвечающее за величину промежутка между соседними словами. Задается в виде отклонения от промежутка между словами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.WordSpacing = 0
07labelFont.WordSpacing = 2
08dataFont.WordSpacing = 5
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (5 мм)", 5, 15

Результат:
Промежуток слов

property Scaling: Double; - свойство, отвечающее за горизонтальное масштабирование букв используемого шрифта. Устанавливается в процентах. Горизонтальный масштаб по умолчанию - 100%.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Scaling = 50
07labelFont.Scaling = 100
08dataFont.Scaling = 200
09font.WriteLine "Сжатие (50)", 5, 5
10labelFont.WriteLine "По умолчанию (100)", 5, 10
11dataFont.WriteLine "Растягивание (150)", 5, 15

Результат:
Scaling

property RenderingMode: TPDFFontRenderingMode; - свойство, отвечающее за заливку букв используемого шрифта.
Типы заливки:
Значение параметра: | Отображение: | Описание:
0 | Font Fill | Сплошная заливка (по умолчанию). Буква заливается сплошным цветом, объявленным на данный момент.
1 | Font Stroke | Только граница. Прорисовывается граница буквы. Тело остается незалитым.
2 | Font FillStroke | Сначала заливка, потом граница. Граница прорисовывается всегда черным цветом. Заливка осуществляется сплошным цветом, объявленным на данный момент.
3 | Inv | Невидимый шрифт.

Пример:
01set page = CreatePage(Null)
02set font = page.createFont("Arial", 20, False, False)
03set labelFont = page.createFont("Arial", 20, False, False)
04set dataFont = page.createFont("Arial", 20, False, False)
05font.RenderingMode = 0
06labelFont.RenderingMode = 1
07dataFont.RenderingMode = 2
08page.setColor 255, 0, 0
09Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
10Q = labelFont.WriteText ("Олимпиада", 5, 15, 50, 0)
11Q = dataFont.WriteText ("Олимпиада", 5, 25, 50, 0)

Результат:
Заливка букв

property Rise: Double; - свойство, отвечающее за перемещение текста по вертикали.

01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Arial", 7, False, False)
05set dataFont = page.createFont("Arial", 7, False, False)
06labelFont.rise = -17
07dataFont.rise = -2
08Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
09Q = labelFont.WriteText ("Олимпиада", 44, 5, 50, 0)
10Q = dataFont.WriteText ("Олимпиада", 44, 5, 50, 0)

Результат:
Rise

Для определения размеров текстовой строки используется процедура MeasureLine(const LineText: WideString; out Width: OleVariant; out Height: OleVariant);

Здесь:

  • LineText - исходный текст для размещения на странице
  • Width - возвращаемый параметр ширины текстового блока на странице
  • Height - возвращаемый параметр высоты текстового блока на странице
1S = "шифр"
2font.MeasureLine S, W, H
3Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2)

Здесь для текста "Шифр" замеряется ширина и высота получившегося текстового блока. Затем полученные данные используются для корректного размещения текста на странице.

Для определения высоты текстового блока используется функция MeasureText(const AText: WideString; Width: Double): Double; safecall;

Функция распределит текст по задаваемому значению ширины текстового блока и вернет значение высоты текстового блока в милиметрах.

Здесь:

  • AText - исходный текст для размещения на странице. Прописывается в кавычках.
  • Width - задаваемая ширина текстового блока на странице в милиметрах.
1S = "Текст для размещения на странице..."
2Q = font.MeasureText(S, 139)
Здесь для текста "Текст для размещения на странице..." замеряется высота получившегося текстового блока. Затем полученные данные могут использоваться для корректного размещения текста на странице.

6.1.3. Порядок создания

Для создания шаблона PDF-документа необходимо в системной форме Платформы выбрать класс, к которому будет строиться документ. В подменю "Подпрограммы" вызвать контекстное меню и выбрать пункт "Создать шаблон отчета PDF". Заполнить необходимые поля и приступить к созданию скрипта в окне "Скрипт шаблона".

  1. Объявляем все переменные.
  2. Создаем страницы
  3. Устанавливаем все свойства документа и страниц
  4. Рисуем простые графические объекты
  5. Объявляем все используемые шрифты
  6. Расставляем постоянный текст на странице
  7. Расставляем переменный текст на странице
  8. Вставляем или создаем сложные графические объекты
Пример документа PDF:
001set LDataSet = createDataSet("TRoundAbiturSt")
002'Объявление переменных
003LDataSet.AddQueryItem 1, "ID", ID
004LDataSet.AddQueryItem 0, "RoundComp$N"
005LDataSet.AddQueryItem 0, "BachRound$N"
006LDataSet.AddQueryItem 0, "LastName"
007LDataSet.AddQueryItem 0, "FirstName"
008LDataSet.AddQueryItem 0, "MiddleName"
009LDataSet.AddQueryItem 0, "BirthDate"
010LDataSet.AddQueryItem 0, "RegNumber"
011LDataSet.AddQueryItem 0, "SecondStageCity$D"
012LDataSet.AddQueryItem 0, "PhoneList"
013
014'Присваивание переменным значений
015OlympName = LDataSet.Field("RoundComp$N")
016OlympClass = LDataSet.Field("BachRound$N")
017LastName = LDataSet.Field("LastName")
018FirstName = LDataSet.Field("FirstName")
019MiddleName = LDataSet.Field("MiddleName")
020if not IsNull(LDataSet.Field("BirthDate")) then
021  BirthDate = LDataSet.Field("BirthDate")
022else
023  BirthDate = "(не задана)"
024end if
025RegNo = LDataSet.Field("RegNumber")
026if not IsNull(LDataSet.Field("SecondStageCity$D")) then
027  OlympCity = LDataSet.Field("SecondStageCity$D")
028else
029  OlympCity = "(не выбран город участия)"
030end if
031if not IsNull(LDataSet.Field("PhoneList")) then
032  Phone = LDataSet.Field("PhoneList")
033else
034  Phone = ""
035end if
036
037'CanCompress = False - признак сжатия файла
038set page = CreatePage(Null) ' создаем страницу
039'Объявляем используемые шрифты
040set font = page.createFont("Arial", 20, False, False)
041set labelFont = page.createFont("Arial", 16, False, False)
042set dataFont = page.createFont("Arial", 18, True, False)
043set bigFont = page.createFont("Arial", 24, False, False)
044
045'page.DrawGrid  - рисуем сетку для удобства отладки
046
047page.LineWidth = 0.5 ' Установка толщины линии
048
049' Рисуем прямоугольники
050page.Rectangle 8, 12, 4, 4, True
051page.Rectangle 190, 12, 4, 4, True
052
053page.Rectangle 8, 273, 4, 4, True
054page.Rectangle 105, 273, 4, 4, True
055page.Rectangle 190, 273, 4, 4, True
056
057'Выводим постоянный и переменный текст
058Q = font.WriteText ("Межрегиональная олимпиада школьников", 12, 20, 178, 2)
059Q = bigFont.WriteText (OlympName, 12, 45, 178, 2)
060Q = bigFont.WriteText (OlympClass, 12, 56, 178, 2)
061
062Q = font.WriteText ("Титульный лист", 12, 72, 178, 2)
063
064labelFont.WriteLine "Фамилия", 25, 115 - 23
065labelFont.WriteLine "Имя", 25, 123 - 23
066labelFont.WriteLine "Отчество", 25, 131 - 23
067labelFont.WriteLine "Дата", 25, 139 - 23
068labelFont.WriteLine "рождения", 25, 145 - 23
069
070labelFont.WriteLine "Регистрационный номер", 25, 169 - 30
071labelFont.WriteLine "Город проведения", 25, 177 - 30
072labelFont.WriteLine "Аудитория", 25, 185 - 30
073
074
075labelFont.WriteLine "Дата", 25, 211
076labelFont.WriteLine "Подпись", 25, 219
077labelFont.WriteLine "Телефон", 25, 227
078
079
080dataFont.WriteLine LastName, 63, 114 - 23
081dataFont.WriteLine FirstName, 63, 122 - 23
082dataFont.WriteLine MiddleName, 63, 130 - 23
083dataFont.WriteLine BirthDate, 63, 141 - 23
084
085dataFont.WriteLine RegNo, 100, 168 - 30
086dataFont.WriteLine OlympCity, 100, 176 - 30
087
088' Рисуем линии
089page.line 100, 192 - 30, 150, 192 - 30
090page.line 58, 218, 108, 218
091page.line 58, 226, 108, 226
092Q = dataFont.WriteText(Phone, 58, 226, 65, 0)
093
094
095
096' Устанавливаем новый цвет
097page.setColor 192, 192, 192
098
099S = "шифр"
100font.MeasureLine S, W, H  ' измеряем текстовый блок
101Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2) ' располагаем текстовый
102блок на странице
103
104' Устанавливаем новый цвет
105page.setColor 255, 0, 0
106' Устанавливаем толщину линий в 1 пиксель
107page.LineWidth = 0
108' Рисуем линии по координатам
109X = 139
110Y = 267
111
112page.line X, Y - 3, X, Y + 3
113page.line X - 3, Y, X + 3, Y
114
115X = X + 40
116page.line X, Y - 3, X, Y + 3
117page.line X - 3, Y, X + 3, Y
118
119
120Y = Y - 23
121page.line X, Y - 3, X, Y + 3
122page.line X - 3, Y, X + 3, Y
123
124X = X - 40
125page.line X, Y - 3, X, Y + 3
page.line X - 3, Y, X + 3, Y

Результат:

6.2. Справочник по интерфейсам

6.2.1. Перечисление TPDFFontRenderingMode
1type
2  TPDFFontRenderingMode = (frmFillText, frmStrokeText, frmFillThenStrokeText,
3    frmInvisible);

Или

1type
2  TPDFFontRenderingMode = TOleEnum;
3const
4  frmFillText = $00000000;
5  frmStrokeText = $00000001;
6  frmFillThenStrokeText = $00000002;
7  frmInvisible = $00000003;

Элементы перечисления:

Имя | Значение | Назначение
frmFillText | 0 |
frmStrokeText | 1 |
frmFillThenStrokeText | 2 |
frmInvisible | 3 |

6.2.2. Перечисление TPDFLineCap
1type
2  TPDFLineCap = (lcBuss, lcRound, lcProtecting);

Или

1type
2  TPDFLineCap = TOleEnum;
3const
4  lcBuss = $00000000;
5  lcRound = $00000001;
6  lcProtecting = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
lcBuss | 0 |
lcRound | 1 |
lcProtecting | 2 |

6.2.3. Перечисление TPDFLineJoin
1type
2  TPDFLineJoin = (ljMiter, ljRound, ljBevel);

Или

1type
2  TPDFLineJoin = TOleEnum;
3const
4  ljMiter = $00000000;
5  ljRound = $00000001;
6  ljBevel = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
ljMiter | 0 |
ljRound | 1 |
ljBevel | 2 |

6.2.4. Перечисление TPDFTextAlignment
1type
2  TPDFTextAlignment = (ptaLeft, ptaRight, ptaCenter, ptaJustified);

Или

1type
2  TPDFTextAlignment = TOleEnum;
3const
4  ptaLeft = $00000000;
5  ptaRight = $00000001;
6  ptaCenter = $00000002;
7  ptaJustified = $00000003;

Элементы перечисления:

Имя | Значение | Назначение
ptaLeft | 0 |
ptaRight | 1 |
ptaCenter | 2 |
ptaJustified | 3 |

6.2.5. Интерфейс IPDFDocument

01type
02  IPDFDocument = interface(IDispatch)
03    ['{E57FFE9D-6B85-45E6-A5D0-9DD17950A666}']
04    procedure Save(Target: OleVariant); safecall;
05    function CreatePage(Parent: OleVariant): IPDFPage; safecall;
06    function Get_Title: WideString; safecall;
07    procedure Set_Title(Value: WideString); safecall;
08    function Get_CanEmbedFonts: WordBool; safecall;
09    procedure Set_CanEmbedFonts(Value: WordBool); safecall;
10    function Get_CanCompress: WordBool; safecall;
11    procedure Set_CanCompress(Value: WordBool); safecall;
12    function Get_Author: WideString; safecall;
13    procedure Set_Author(Value: WideString); safecall;
14    function Get_Subject: WideString; safecall;
15    procedure Set_Subject(Value: WideString); safecall;
16    function Get_Keywords: WideString; safecall;
17    procedure Set_Keywords(Value: WideString); safecall;
18    function Get_Creator: WideString; safecall;
19    procedure Set_Creator(Value: WideString); safecall;
20    function Get_Pages(Index: Integer): IPDFPage; safecall;
21    function Get_PageCount: Integer; safecall;
22    procedure Close; safecall;
23    procedure Serialize(const Stream: IUnknown); safecall;
24    function Get_MinCompressSize: Integer; safecall;
25    procedure Set_MinCompressSize(Value: Integer); safecall;
26    function Get_MaxCompressSize: Integer; safecall;
27    procedure Set_MaxCompressSize(Value: Integer); safecall;
28    function CreatePageFromImage(Image: OleVariant; PageWidth: Double;
29      PageHeight: Double; Margin: Double): WordBool; safecall;
30    procedure SaveToXML(Target: OleVariant); safecall;
31    property Title: WideString read Get_Title write Set_Title;
32    property CanEmbedFonts: WordBool read Get_CanEmbedFonts write Set_CanEmbedFonts;
33    property CanCompress: WordBool read Get_CanCompress write Set_CanCompress;
34    property Author: WideString read Get_Author write Set_Author;
35    property Subject: WideString read Get_Subject write Set_Subject;
36    property Keywords: WideString read Get_Keywords write Set_Keywords;
37    property Creator: WideString read Get_Creator write Set_Creator;
38    property Pages[Index: Integer]: IPDFPage read Get_Pages;
39    property PageCount: Integer read Get_PageCount;
40    property MinCompressSize: Integer read Get_MinCompressSize
41      write Set_MinCompressSize;
42    property MaxCompressSize: Integer read Get_MaxCompressSize
43      write Set_MaxCompressSize;
44  end;

6.2.5.1. Свойства

Свойства интерфейса IPDFDocument:

Имя | Тип | Доступ | Назначение
Author | WideString | Чтение/Запись |
CanCompress | WordBool | Чтение/Запись |
CanEmbedFonts | WordBool | Чтение/Запись |
Creator | WideString | Чтение/Запись |
Keywords | WideString | Чтение/Запись |
MaxCompressSize | Integer | Чтение/Запись |
MinCompressSize | Integer | Чтение/Запись |
PageCount | Integer | Только для чтения |
Pages[Index: Integer] | IPDFPage | Только для чтения |
Subject | WideString | Чтение/Запись |
Title | WideString | Чтение/Запись |

6.2.5.2. Метод Close

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Close;

Метод не имеет параметров.

6.2.5.3. Метод CreatePage

Метод интерфейса IPDFDocument.

function IPDFDocument.CreatePage(Parent: OleVariant): IPDFPage;

Параметры:

Имя | Тип | Обязательно | Значение
Parent | OleVariant | Да |

Замечания:

Возвращает значение типа IPDFPage.

6.2.5.4. Метод CreatePageFromImage

Метод интерфейса IPDFDocument.

1function IPDFDocument.CreatePageFromImage(Image: OleVariant; PageWidth: Double;
2  PageHeight: Double; Margin: Double): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Image | OleVariant | Да |
PageWidth | Double | Да |
PageHeight | Double | Да |
Margin | Double | Да |

Замечания:

Возвращает значение типа WordBool.

6.2.5.5. Метод Save

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Save(Target: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Target | OleVariant | Да |

6.2.5.6. Метод SaveToXML

Метод интерфейса IPDFDocument.

procedure IPDFDocument.SaveToXML(Target: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Target | OleVariant | Да |

6.2.5.7. Метод Serialize

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Serialize(const Stream: IUnknown);

Параметры:

Имя | Тип | Обязательно | Значение
Stream | IUnknown | Да |

6.2.6. Интерфейс IPDFFont

01type
02  IPDFFont = interface(IDispatch)
03    ['{43FE399A-A724-4076-BAFA-098639628385}']
04    function Get_Spacing: Double; safecall;
05    procedure Set_Spacing(Value: Double); safecall;
06    function Get_WordSpacing: Double; safecall;
07    procedure Set_WordSpacing(Value: Double); safecall;
08    function Get_Scaling: Double; safecall;
09    procedure Set_Scaling(Value: Double); safecall;
10    function Get_RenderingMode: TPDFFontRenderingMode; safecall;
11    procedure Set_RenderingMode(Value: TPDFFontRenderingMode); safecall;
12    function Get_Rise: Double; safecall;
13    procedure Set_Rise(Value: Double); safecall;
14    procedure WriteLine(const LineText: WideString; X: Double; Y: Double); safecall;
15    procedure MeasureLine(const LineText: WideString; out Width: OleVariant;
16      out Height: OleVariant); safecall;
17    function WriteText(const AText: WideString; X: Double; Y: Double;
18      Width: Double; Alignment: TPDFTextAlignment): Double; safecall;
19    function MeasureText(const AText: WideString; Width: Double): Double; safecall;
20    function Get_Angle: Double; safecall;
21    procedure Set_Angle(Value: Double); safecall;
22    function Get_LineSpacing: Double; safecall;
23    procedure Set_LineSpacing(Value: Double); safecall;
24    property Spacing: Double read Get_Spacing write Set_Spacing;
25    property WordSpacing: Double read Get_WordSpacing write Set_WordSpacing;
26    property Scaling: Double read Get_Scaling write Set_Scaling;
27    property RenderingMode: TPDFFontRenderingMode read Get_RenderingMode
28      write Set_RenderingMode;
29    property Rise: Double read Get_Rise write Set_Rise;
30    property Angle: Double read Get_Angle write Set_Angle;
31    property LineSpacing: Double read Get_LineSpacing write Set_LineSpacing;
32  end;

6.2.6.1. Свойства

Свойства интерфейса IPDFFont:

Имя | Тип | Доступ | Назначение
Angle | Double | Чтение/Запись |
LineSpacing | Double | Чтение/Запись |
RenderingMode | TPDFFontRenderingMode | Чтение/Запись |
Rise | Double | Чтение/Запись |
Scaling | Double | Чтение/Запись |
Spacing | Double | Чтение/Запись |
WordSpacing | Double | Чтение/Запись |

6.2.6.2. Метод MeasureLine

Метод интерфейса IPDFFont.

1procedure IPDFFont.MeasureLine(const LineText: WideString;
2  out Width: OleVariant; out Height: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
LineText | WideString | Да |
Width | OleVariant | Да |
Height | OleVariant | Да |

6.2.6.3. Метод MeasureText

Метод интерфейса IPDFFont.

function IPDFFont.MeasureText(const AText: WideString; Width: Double): Double;

Параметры:

Имя | Тип | Обязательно | Значение
AText | WideString | Да |
Width | Double | Да |

Замечания:

Возвращает значение типа Double.

6.2.6.4. Метод WriteLine

Метод интерфейса IPDFFont.

procedure IPDFFont.WriteLine(const LineText: WideString; X: Double; Y: Double);

Параметры:

Имя | Тип | Обязательно | Значение
LineText | WideString | Да |
X | Double | Да |
Y | Double | Да |

6.2.6.5. Метод WriteText

Метод интерфейса IPDFFont.

1function IPDFFont.WriteText(const AText: WideString; X: Double; Y: Double;
2  Width: Double; Alignment: TPDFTextAlignment): Double;

Параметры:

Имя | Тип | Обязательно | Значение
AText | WideString | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Alignment | TPDFTextAlignment | Да |

Замечания:

Возвращает значение типа Double.

6.2.7. Интерфейс IPDFPage

01type
02  IPDFPage = interface(IDispatch)
03    ['{749FB131-80FE-46E9-8330-22C1DC346FE7}']
04    function Get_Parent: IPDFPage; safecall;
05    function Get_Title: WideString; safecall;
06    procedure Set_Title(Value: WideString); safecall;
07    function Get_Width: Double; safecall;
08    procedure Set_Width(Value: Double); safecall;
09    function Get_Height: Double; safecall;
10    procedure Set_Height(Value: Double); safecall;
11    function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool;
12      Italic: WordBool): IPDFFont; safecall;
13    procedure Perform(const Command: WideString); safecall;
14    function Get_LineWidth: Double; safecall;
15    procedure Set_LineWidth(Value: Double); safecall;
16    procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double); safecall;
17    procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double;
18      Fill: WordBool); safecall;
19    function Get_LineCap: TPDFLineCap; safecall;
20    procedure Set_LineCap(Value: TPDFLineCap); safecall;
21    function Get_LineJoin: TPDFLineJoin; safecall;
22    procedure Set_LineJoin(Value: TPDFLineJoin); safecall;
23    procedure SetDash(DashArray: OleVariant; Phase: Integer); safecall;
24    procedure SetColor(R: Integer; G: Integer; B: Integer); safecall;
25    procedure PerformColor(const Command: WideString); safecall;
26    procedure Poly(Points: OleVariant; Fill: WordBool); safecall;
27    procedure Image(Image: OleVariant; X: Double; Y: Double; Width: Double;
28      Height: Double; Transparent: WordBool); safecall;
29    procedure DrawGrid; safecall;
30    procedure Arc(X: Double; Y: Double; Radius: Double; StartAngle: Double;
31      EndAngle: Double; FillSegment: WordBool; FillSector: WordBool); safecall;
32    procedure Curve(Points: OleVariant; Fill: WordBool); safecall;
33    procedure HyperLink(const URI: WideString; X: Double; Y: Double; Width: Double;
34      Height: Double); safecall;
35    procedure Pattern(X1: Double; Y1: Double; Width: Double; Height: Double;
36      PatternPointSize: Double; Percentage: Integer); safecall;
37    procedure Bezier(Points: OleVariant; Fill: WordBool); safecall;
38    procedure XObject(Data: OleVariant); safecall;
39    procedure SetColorCMYK(C: Double; M: Double; Y: Double; K: Double); safecall;
40    procedure LocalLink(const Page: IDispatch; DestinationX: Double;
41      DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
42      X: Double; Y: Double; Width: Double; Height: Double); safecall;
43    property Parent: IPDFPage read Get_Parent;
44    property Title: WideString read Get_Title write Set_Title;
45    property Width: Double read Get_Width write Set_Width;
46    property Height: Double read Get_Height write Set_Height;
47    property LineWidth: Double read Get_LineWidth write Set_LineWidth;
48    property LineCap: TPDFLineCap read Get_LineCap write Set_LineCap;
49    property LineJoin: TPDFLineJoin read Get_LineJoin write Set_LineJoin;
50  end;

6.2.7.1. Свойства

Свойства интерфейса IPDFPage:

Имя | Тип | Доступ | Назначение
Height | Double | Чтение/Запись |
LineCap | TPDFLineCap | Чтение/Запись |
LineJoin | TPDFLineJoin | Чтение/Запись |
LineWidth | Double | Чтение/Запись |
Parent | IPDFPage | Только для чтения |
Title | WideString | Чтение/Запись |
Width | Double | Чтение/Запись |

6.2.7.2. Метод Arc

Метод интерфейса IPDFPage.

1procedure IPDFPage.Arc(X: Double; Y: Double; Radius: Double;
2  StartAngle: Double; EndAngle: Double; FillSegment: WordBool;
3  FillSector: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
X | Double | Да |
Y | Double | Да |
Radius | Double | Да |
StartAngle | Double | Да |
EndAngle | Double | Да |
FillSegment | WordBool | Да |
FillSector | WordBool | Да |

6.2.7.3. Метод Bezier

Метод интерфейса IPDFPage.

procedure IPDFPage.Bezier(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

6.2.7.4. Метод CreateFont

Метод интерфейса IPDFPage.

1function IPDFPage.CreateFont(const FontName: WideString; Size: Double;
2  Bold: WordBool; Italic: WordBool): IPDFFont;

Параметры:

Имя | Тип | Обязательно | Значение
FontName | WideString | Да |
Size | Double | Да |
Bold | WordBool | Да |
Italic | WordBool | Да |

Замечания:

Возвращает значение типа IPDFFont.

6.2.7.5. Метод Curve

Метод интерфейса IPDFPage.

procedure IPDFPage.Curve(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

6.2.7.6. Метод DrawGrid

Метод интерфейса IPDFPage.

procedure IPDFPage.DrawGrid;

Метод не имеет параметров.

6.2.7.7. Метод HyperLink

Метод интерфейса IPDFPage.

1procedure IPDFPage.HyperLink(const URI: WideString; X: Double; Y: Double;
2  Width: Double; Height: Double);

Параметры:

Имя | Тип | Обязательно | Значение
URI | WideString | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |

6.2.7.8. Метод Image

Метод интерфейса IPDFPage.

1procedure IPDFPage.Image(Image: OleVariant; X: Double; Y: Double;
2  Width: Double; Height: Double; Transparent: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Image | OleVariant | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |
Transparent | WordBool | Нет |

6.2.7.9. Метод Line

Метод интерфейса IPDFPage.

procedure IPDFPage.Line(X1: Double; Y1: Double; X2: Double; Y2: Double);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
X2 | Double | Да |
Y2 | Double | Да |

6.2.7.10. Метод LocalLink

Метод интерфейса IPDFPage.

1procedure IPDFPage.LocalLink(const Page: IDispatch; DestinationX: Double;
2  DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
3  X: Double; Y: Double; Width: Double; Height: Double);

Параметры:

Имя | Тип | Обязательно | Значение
Page | IDispatch | Да |
DestinationX | Double | Да |
DestinationY | Double | Да |
DestinationWidth | Double | Да |
DestinationHeight | Double | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |

6.2.7.11. Метод Pattern

Метод интерфейса IPDFPage.

1procedure IPDFPage.Pattern(X1: Double; Y1: Double; Width: Double;
2  Height: Double; PatternPointSize: Double; Percentage: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
Width | Double | Да |
Height | Double | Да |
PatternPointSize | Double | Да |
Percentage | Integer | Да |

6.2.7.12. Метод Perform

Метод интерфейса IPDFPage.

procedure IPDFPage.Perform(const Command: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Command | WideString | Да |

6.2.7.13. Метод PerformColor

Метод интерфейса IPDFPage.

procedure IPDFPage.PerformColor(const Command: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Command | WideString | Да |

6.2.7.14. Метод Poly

Метод интерфейса IPDFPage.

procedure IPDFPage.Poly(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

6.2.7.15. Метод Rectangle

Метод интерфейса IPDFPage.

1procedure IPDFPage.Rectangle(X1: Double; Y1: Double; Width: Double;
2  Height: Double; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
Width | Double | Да |
Height | Double | Да |
Fill | WordBool | Да |

6.2.7.16. Метод SetColor

Метод интерфейса IPDFPage.

procedure IPDFPage.SetColor(R: Integer; G: Integer; B: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
R | Integer | Да |
G | Integer | Да |
B | Integer | Да |

6.2.7.17. Метод SetColorCMYK

Метод интерфейса IPDFPage.

procedure IPDFPage.SetColorCMYK(C: Double; M: Double; Y: Double; K: Double);

Параметры:

Имя | Тип | Обязательно | Значение
C | Double | Да |
M | Double | Да |
Y | Double | Да |
K | Double | Да |

6.2.7.18. Метод SetDash

Метод интерфейса IPDFPage.

procedure IPDFPage.SetDash(DashArray: OleVariant; Phase: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
DashArray | OleVariant | Да |
Phase | Integer | Да |

6.2.7.19. Метод XObject

Метод интерфейса IPDFPage.

procedure IPDFPage.XObject(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

7. Поставка решений


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IPDFFont (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IPDFFont

01type
02  IPDFFont = interface(IDispatch)
03    ['{43FE399A-A724-4076-BAFA-098639628385}']
04    function Get_Spacing: Double; safecall;
05    procedure Set_Spacing(Value: Double); safecall;
06    function Get_WordSpacing: Double; safecall;
07    procedure Set_WordSpacing(Value: Double); safecall;
08    function Get_Scaling: Double; safecall;
09    procedure Set_Scaling(Value: Double); safecall;
10    function Get_RenderingMode: TPDFFontRenderingMode; safecall;
11    procedure Set_RenderingMode(Value: TPDFFontRenderingMode); safecall;
12    function Get_Rise: Double; safecall;
13    procedure Set_Rise(Value: Double); safecall;
14    procedure WriteLine(const LineText: WideString; X: Double; Y: Double); safecall;
15    procedure MeasureLine(const LineText: WideString; out Width: OleVariant;
16      out Height: OleVariant); safecall;
17    function WriteText(const AText: WideString; X: Double; Y: Double;
18      Width: Double; Alignment: TPDFTextAlignment): Double; safecall;
19    function MeasureText(const AText: WideString; Width: Double): Double; safecall;
20    function Get_Angle: Double; safecall;
21    procedure Set_Angle(Value: Double); safecall;
22    function Get_LineSpacing: Double; safecall;
23    procedure Set_LineSpacing(Value: Double); safecall;
24    property Spacing: Double read Get_Spacing write Set_Spacing;
25    property WordSpacing: Double read Get_WordSpacing write Set_WordSpacing;
26    property Scaling: Double read Get_Scaling write Set_Scaling;
27    property RenderingMode: TPDFFontRenderingMode read Get_RenderingMode
28      write Set_RenderingMode;
29    property Rise: Double read Get_Rise write Set_Rise;
30    property Angle: Double read Get_Angle write Set_Angle;
31    property LineSpacing: Double read Get_LineSpacing write Set_LineSpacing;
32  end;

1. Свойства

Свойства интерфейса IPDFFont:

Имя | Тип | Доступ | Назначение
Angle | Double | Чтение/Запись |
LineSpacing | Double | Чтение/Запись |
RenderingMode | TPDFFontRenderingMode | Чтение/Запись |
Rise | Double | Чтение/Запись |
Scaling | Double | Чтение/Запись |
Spacing | Double | Чтение/Запись |
WordSpacing | Double | Чтение/Запись |

2. Метод MeasureLine

Метод интерфейса IPDFFont.

1procedure IPDFFont.MeasureLine(const LineText: WideString;
2  out Width: OleVariant; out Height: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
LineText | WideString | Да |
Width | OleVariant | Да |
Height | OleVariant | Да |

3. Метод MeasureText

Метод интерфейса IPDFFont.

function IPDFFont.MeasureText(const AText: WideString; Width: Double): Double;

Параметры:

Имя | Тип | Обязательно | Значение
AText | WideString | Да |
Width | Double | Да |

Замечания:

Возвращает значение типа Double.

4. Метод WriteLine

Метод интерфейса IPDFFont.

procedure IPDFFont.WriteLine(const LineText: WideString; X: Double; Y: Double);

Параметры:

Имя | Тип | Обязательно | Значение
LineText | WideString | Да |
X | Double | Да |
Y | Double | Да |

5. Метод WriteText

Метод интерфейса IPDFFont.

1function IPDFFont.WriteText(const AText: WideString; X: Double; Y: Double;
2  Width: Double; Alignment: TPDFTextAlignment): Double;

Параметры:

Имя | Тип | Обязательно | Значение
AText | WideString | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Alignment | TPDFTextAlignment | Да |

Замечания:

Возвращает значение типа Double.


Мельница данных ((раздел целиком))

Мельница данных- Класс TLanguageTranslation (Переводы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TLanguageTranslation (Переводы)

Класс TObject (Объекты)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TLanguageTranslation:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Language | TLanguage | Да | Видимо пользователю | Только для чтения | Язык
DatabaseLanguage | Boolean | Да | Видимо пользователю | Только для чтения | Язык используется по умолчанию
CurrentLanguage | Boolean | Да | Видимо пользователю | Только для чтения | Язык является текущим
Status | TTranslationStatus | Да | Видимо пользователю | Только для чтения | Состояние
OwnerObject | TObject | Нет | Скрыто от пользователя | Только для чтения | Владелец-объект
OwnerObjectClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс объекта-владельца
OwnerField | TField | Нет | Скрыто от пользователя | Только для чтения | Владелец-поле
Owner | string[64] | Нет | Скрыто от пользователя | Только для чтения | Владелец
Translation | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Перевод
Original | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Оригинал
Identifier | string[2000] | Нет | Видимо пользователю | Только для чтения | Идентификатор
GlobalIdentifier | string[2000] | Нет | Видимо пользователю | Только для чтения | Глобальный идентификатор

2. Конструктор Create (Конструктор перевода)

Конструктор класса TLanguageTranslation.

1constructor TLanguageTranslation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Language: TLanguage; OwnerObject: TObject;
4  OwnerField: TField; Owner: string[64]; Translation: string[2000]): TObject;

Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Language | TLanguage | Да | Язык
OwnerObject | TObject | Нет | Владелец-объект
OwnerField | TField | Нет | Владелец-поле
Owner | string[64] | Нет | Владелец
Translation | string[2000] | Нет | Перевод

Замечания:

Создает новый объект класса TLanguageTranslation.

3. Метод Add (Создать набор переводов)

Метод класса (статический метод) класса TLanguageTranslation.

1class function TLanguageTranslation.Add(Owner: string[64];
2  Original: string[2000]): TLanguageTranslation;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Owner | string[64] | Да | Идентификатор
Original | string[2000] | Нет | Оригинал

Замечания:

Возвращает значение типа TLanguageTranslation.

4. Метод Append (Добавить перевод)

Метод класса (статический метод) класса TLanguageTranslation.

1class function TLanguageTranslation.Append(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]): TLanguageTranslation;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ALanguage | TLanguage | Да | Язык
AOwner | string[64] | Нет | Владелец
AOwnerObject | TObject | Нет | Владелец-объект
AOwnerField | TField | Нет | Владелец-поле
AValue | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа TLanguageTranslation.

5. Метод GetGlobalIdent (Получить глобальный идентификатор)

Метод экземпляра класса TLanguageTranslation.

function TLanguageTranslation.GetGlobalIdent: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

6. Метод GetIdent (Получить идентификатор)

Метод экземпляра класса TLanguageTranslation.

function TLanguageTranslation.GetIdent: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

7. Метод GetLanguageTranslation (Получить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.

1class function TLanguageTranslation.GetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ALanguage | TLanguage | Да | Язык
AOwner | string[64] | Нет | Владелец
AOwnerObject | TObject | Нет | Владелец-объект
AOwnerField | TField | Нет | Владелец-поле

Замечания:

Возвращает значение типа string[2000].

8. Метод GetOriginal (Получить оригинал)

Метод экземпляра класса TLanguageTranslation.

function TLanguageTranslation.GetOriginal: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9. Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TLanguageTranslation.

class function TLanguageTranslation.GetResource(AOwner: string[64]): string[2000];

Переопределяет метод в TObject.GetResource.

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwner | string[64] | Да | Владелец

Замечания:

Возвращает значение типа string[2000].

10. Метод Load (Загрузить значение)

Метод экземпляра класса TLanguageTranslation.

procedure TLanguageTranslation.Load(Value: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

11. Метод MarkAsTranslatable (Отметить как переводимый)

Метод экземпляра класса TLanguageTranslation.

procedure TLanguageTranslation.MarkAsTranslatable;

Метод не имеет параметров.

12. Метод MarkAsUntranslatable (Отметить как непереводимый)

Метод экземпляра класса TLanguageTranslation.

procedure TLanguageTranslation.MarkAsUntranslatable;

Метод не имеет параметров.

13. Метод SetLanguageTranslation (Установить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.

1class procedure TLanguageTranslation.SetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ALanguage | TLanguage | Да | Язык
AOwner | string[64] | Нет | Владелец
AOwnerObject | TObject | Нет | Владелец-объект
AOwnerField | TField | Нет | Владелец-поле
AValue | string[2000] | Нет | Значение

14. Метод SetOriginal (Установить оригинал)

Метод экземпляра класса TLanguageTranslation.

procedure TLanguageTranslation.SetOriginal(Value: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

15. Метод SetOwnerSecurity (Установить атрибуты безопасности по владельцу-объекту)

Метод класса (статический метод) класса TLanguageTranslation.

class procedure TLanguageTranslation.SetOwnerSecurity(AOwnerObject: TObject);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwnerObject | TObject | Нет | Владелец-объект

16. Метод SetTranslation (Установить перевод)

Метод экземпляра класса TLanguageTranslation.

procedure TLanguageTranslation.SetTranslation(Value: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

17. Метод Validate (Актуализировать)

Метод класса (статический метод) класса TLanguageTranslation.

1class procedure TLanguageTranslation.Validate(ValidateResources: Boolean;
2  ValidateData: Boolean; ValidateClass: TClass; ValidateField: TField);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ValidateResources | Boolean | Да | Актуализировать ресурсы
ValidateData | Boolean | Да | Актуализировать данные
ValidateClass | TClass | Нет | Актуализировать объекты класса
ValidateField | TField | Нет | Актуализировать значения поля

18. Метод ValidateAllObjects (Актуализировать все объекты)

Метод класса (статический метод) класса TLanguageTranslation.

1class procedure TLanguageTranslation.ValidateAllObjects(ValidateClass: TClass;
2  ValidateField: TField);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ValidateClass | TClass | Нет | Актуализировать объекты класса
ValidateField | TField | Нет | Актуализировать значения поля

19. Метод ValidateObject (Актуализировать объект)

Метод класса (статический метод) класса TLanguageTranslation.

1class procedure TLanguageTranslation.ValidateObject(AOwnerObject: TObject;
2  AOwnerField: TField);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwnerObject | TObject | Нет | Владелец-объект
AOwnerField | TField | Нет | Владелец-поле

20. Метод ValidateOwned (Актуализировать имеющих владельца)

Метод класса (статический метод) класса TLanguageTranslation.

class procedure TLanguageTranslation.ValidateOwned;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

21. Метод ValidateOwner (Актуализировать по владельцу)

Метод класса (статический метод) класса TLanguageTranslation.

class procedure TLanguageTranslation.ValidateOwner(AOwner: string[64]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwner | string[64] | Да | Владелец


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IFormContext (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IFormContext

01type
02  IFormContext = interface(IDispatch)
03    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
04    function ID: WideString; safecall;
05    function RoutineID: WideString; safecall;
06    function ControlCount: Integer; safecall;
07    function Get_Controls(Name: OleVariant): IControl; safecall;
08    function ControlExists(const Name: WideString): WordBool; safecall;
09    function ButtonCount: Integer; safecall;
10    function Get_Buttons(Name: OleVariant): IButton; safecall;
11    function Get_Enabled: WordBool; safecall;
12    procedure Set_Enabled(Value: WordBool); safecall;
13    function ChangedControl: OleVariant; safecall;
14    function ChangedControlName: WideString; safecall;
15    procedure Cancel; safecall;
16    function ParentForm: OleVariant; safecall;
17    procedure PreInitControl(const Name: WideString; Value: OleVariant); safecall;
18    procedure NavigatorNext; safecall;
19    procedure NavigatorPrevious; safecall;
20    function NavigatorCanNext: WordBool; safecall;
21    function NavigatorCanPrevious: WordBool; safecall;
22    procedure RefreshView(RefreshAll: WordBool); safecall;
23    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
24    property Controls[Name: OleVariant]: IControl read Get_Controls;
25    property Buttons[Name: OleVariant]: IButton read Get_Buttons;
26    property Enabled: WordBool read Get_Enabled write Set_Enabled;
27  end;

1. Свойства

Свойства интерфейса IFormContext:

Имя | Тип | Доступ | Назначение
Buttons[Name: OleVariant] | IButton | Только для чтения |
Controls[Name: OleVariant] | IControl | Только для чтения |
Enabled | WordBool | Чтение/Запись |

2. Метод ButtonCount

Метод интерфейса IFormContext.

function IFormContext.ButtonCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

3. Метод Cancel

Метод интерфейса IFormContext.

procedure IFormContext.Cancel;

Метод не имеет параметров.

4. Метод ChangedControl

Метод интерфейса IFormContext.

function IFormContext.ChangedControl: OleVariant;

Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

5. Метод ChangedControlName

Метод интерфейса IFormContext.

function IFormContext.ChangedControlName: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

6. Метод ControlCount

Метод интерфейса IFormContext.

function IFormContext.ControlCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

7. Метод ControlExists

Метод интерфейса IFormContext.

function IFormContext.ControlExists(const Name: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

8. Метод ExpressionContextValue

Метод интерфейса IFormContext.

function IFormContext.ExpressionContextValue(const Name: WideString): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа OleVariant.

9. Метод ID

Метод интерфейса IFormContext.

function IFormContext.ID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10. Метод NavigatorCanNext

Метод интерфейса IFormContext.

function IFormContext.NavigatorCanNext: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

11. Метод NavigatorCanPrevious

Метод интерфейса IFormContext.

function IFormContext.NavigatorCanPrevious: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

12. Метод NavigatorNext

Метод интерфейса IFormContext.

procedure IFormContext.NavigatorNext;

Метод не имеет параметров.

13. Метод NavigatorPrevious

Метод интерфейса IFormContext.

procedure IFormContext.NavigatorPrevious;

Метод не имеет параметров.

14. Метод ParentForm

Метод интерфейса IFormContext.

function IFormContext.ParentForm: OleVariant;

Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

15. Метод PreInitControl

Метод интерфейса IFormContext.

procedure IFormContext.PreInitControl(const Name: WideString; Value: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |
Value | OleVariant | Да |

16. Метод RefreshView

Метод интерфейса IFormContext.

procedure IFormContext.RefreshView(RefreshAll: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
RefreshAll | WordBool | Да |

17. Метод RoutineID

Метод интерфейса IFormContext.

function IFormContext.RoutineID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.


Мельница данных ((раздел целиком))

Мельница данных- Класс TStatement (Операторы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TStatement (Операторы)

Диаграмма

1. Конструктор Create (Конструктор оператора)

Конструктор класса TStatement.

constructor TStatement.Create: TObject;

Метод не имеет параметров.

Замечания:

Создает новый объект класса TStatement.

2. Метод BoolLiteral (Логический литерал)

Метод класса (статический метод) класса TStatement.

class function TStatement.BoolLiteral(Value: Boolean): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение

Замечания:

Возвращает значение типа string[2000].

3. Метод BuildFunctionCall (Построить вызов функции)

Метод класса (статический метод) класса TStatement.

1class function TStatement.BuildFunctionCall(Function: TMethod;
2  Parameters: string[2000]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Function | TMethod | Нет | Функция
Parameters | string[2000] | Нет | Параметры вызова

Замечания:

Возвращает значение типа string[2000].

4. Метод BuildInsertStatement (Построить скрипт добавления объекта)

Метод класса (статический метод) класса TStatement.

1class function TStatement.BuildInsertStatement(AObject: TObject;
2  AClass: TClass): clob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AObject | TObject | Да | Объект
AClass | TClass | Нет | Класс

Замечания:

Возвращает значение типа clob.

5. Метод BuildProcedureCall (Построить вызов процедуры)

Метод класса (статический метод) класса TStatement.

1class function TStatement.BuildProcedureCall(Procedure: TMethod;
2  Parameters: string[2000]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Procedure | TMethod | Нет | Процедура
Parameters | string[2000] | Нет | Параметры вызова

Замечания:

Возвращает значение типа string[2000].

6. Метод BuildUpdateStatement (Построить скрипт изменения объекта)

Метод класса (статический метод) класса TStatement.

1class function TStatement.BuildUpdateStatement(AObject: TObject;
2  AClass: TClass): clob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AObject | TObject | Да | Объект
AClass | TClass | Нет | Класс

Замечания:

Возвращает значение типа clob.

7. Метод Change (Изменение объекта)

Метод экземпляра класса TStatement.

procedure TStatement.Change(Action: TChangeAction);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Действие

8. Метод DateLiteral (Литерал типа "дата")

Метод класса (статический метод) класса TStatement.

class function TStatement.DateLiteral(Value: date): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | date | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

9. Метод DateTimeLiteral (Литерал типа "дата со временем")

Метод класса (статический метод) класса TStatement.

class function TStatement.DateTimeLiteral(Value: datetime): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

10. Метод Execute (Выполнить)

Метод класса (статический метод) класса TStatement.

class procedure TStatement.Execute(Statement: string[2000]);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

11. Метод ExecuteClob (Выполнить большой текстовый объект)

Метод класса (статический метод) класса TStatement.

class procedure TStatement.ExecuteClob(Statement: clob);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

12. Метод ExecuteClobToBlobValue (Выполнить большой текстовый объект и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToBlobValue(Statement: clob): blob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа blob.

13. Метод ExecuteClobToBoolValue (Выполнить большой текстовый объект и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToBoolValue(Statement: clob): Boolean;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа Boolean.

14. Метод ExecuteClobToClobValue (Выполнить большой текстовый объект и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToClobValue(Statement: clob): clob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа clob.

15. Метод ExecuteClobToDateTimeValue (Выполнить большой текстовый объект и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToDateTimeValue(Statement: clob): datetime;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа datetime.

16. Метод ExecuteClobToDateValue (Выполнить большой текстовый объект и вернуть значение даты)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToDateValue(Statement: clob): date;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа date.

17. Метод ExecuteClobToExternalDataValue (Выполнить большой текстовый объект и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.

1class function TStatement.ExecuteClobToExternalDataValue(Statement: clob): <external
2  data>;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа <external data>.

18. Метод ExecuteClobToFloatValue (Выполнить большой текстовый объект и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToFloatValue(Statement: clob): float;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа float.

19. Метод ExecuteClobToIntValue (Выполнить большой текстовый объект и вернуть целое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToIntValue(Statement: clob): Integer;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа Integer.

20. Метод ExecuteClobToObjectValue (Выполнить большой текстовый объект и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToObjectValue(Statement: clob): TObject;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа TObject.

21. Метод ExecuteClobToStrValue (Выполнить большой текстовый объект и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToStrValue(Statement: clob): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа string[2000].

22. Метод ExecuteClobToTimeValue (Выполнить большой текстовый объект и вернуть значение времени)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteClobToTimeValue(Statement: clob): time;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | clob | Нет | Оператор

Замечания:

Возвращает значение типа time.

23. Метод ExecuteToBlobValue (Выполнить и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToBlobValue(Statement: string[2000]): blob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа blob.

24. Метод ExecuteToBoolValue (Выполнить и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToBoolValue(Statement: string[2000]): Boolean;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа Boolean.

25. Метод ExecuteToClobValue (Выполнить и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToClobValue(Statement: string[2000]): clob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа clob.

26. Метод ExecuteToDateTimeValue (Выполнить и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToDateTimeValue(Statement: string[2000]): datetime;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа datetime.

27. Метод ExecuteToDateValue (Выполнить и вернуть значение даты)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToDateValue(Statement: string[2000]): date;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа date.

28. Метод ExecuteToExternalDataValue (Выполнить и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.

1class function TStatement.ExecuteToExternalDataValue(Statement: string[2000]): <external
2  data>;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа <external data>.

29. Метод ExecuteToFloatValue (Выполнить и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToFloatValue(Statement: string[2000]): float;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа float.

30. Метод ExecuteToIntValue (Выполнить и вернуть целое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToIntValue(Statement: string[2000]): Integer;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа Integer.

31. Метод ExecuteToObjectValue (Выполнить и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToObjectValue(Statement: string[2000]): TObject;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа TObject.

32. Метод ExecuteToStrValue (Выполнить и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToStrValue(Statement: string[2000]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа string[2000].

33. Метод ExecuteToTimeValue (Выполнить и вернуть значение времени)

Метод класса (статический метод) класса TStatement.

class function TStatement.ExecuteToTimeValue(Statement: string[2000]): time;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор

Замечания:

Возвращает значение типа time.

34. Метод FloatLiteral (Вещественный литерал)

Метод класса (статический метод) класса TStatement.

class function TStatement.FloatLiteral(Value: float): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | float | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

35. Метод IntLiteral (Целочисленный литерал)

Метод класса (статический метод) класса TStatement.

class function TStatement.IntLiteral(Value: Integer): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Integer | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

36. Метод ObjectLiteral (Литерал-объект)

Метод класса (статический метод) класса TStatement.

class function TStatement.ObjectLiteral(Value: TObject): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

37. Метод QualifyDBMSName (Квалифицировать имя объекта БД)

Метод класса (статический метод) класса TStatement.

class function TStatement.QualifyDBMSName(DBMSName: string[2000]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
DBMSName | string[2000] | Нет | Имя объекта БД

Замечания:

Возвращает значение типа string[2000].

38. Метод SequenceLiteral (Литерал значения последовательности)

Метод класса (статический метод) класса TStatement.

class function TStatement.SequenceLiteral(SequenceName: string[64]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
SequenceName | string[64] | Да | Имя последовательности

Замечания:

Возвращает значение типа string[2000].

39. Метод StringAggregate (Агрегировать строки запроса)

Метод класса (статический метод) класса TStatement.

1class function TStatement.StringAggregate(Statement: string[2000];
2  Delimiter: string[2000]): clob;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Statement | string[2000] | Нет | Оператор
Delimiter | string[2000] | Нет | Разделитель

Замечания:

Возвращает значение типа clob.

40. Метод StringLiteral (Строковый литерал)

Метод класса (статический метод) класса TStatement.

class function TStatement.StringLiteral(Value: string[2000]): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

41. Метод TimeLiteral (Литерал типа "время")

Метод класса (статический метод) класса TStatement.

class function TStatement.TimeLiteral(Value: time): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | time | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

42. Метод ToString (Приведение литерала к строке)

Метод класса (статический метод) класса TStatement.

1class function TStatement.ToString(Literal: string[2000]; Domain: TDomain;
2  CanUseTables: Boolean): string[2000];

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Literal | string[2000] | Нет | Литерал
Domain | TDomain | Нет | Домен
CanUseTables | Boolean | Да | Использовать таблицы

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Класс TVisualGroup (Визуальные группы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TVisualGroup (Визуальные группы)

Класс TObject (Объекты)Класс TVisualGroupItem (Элемент визуальной группы)Класс TVisualGroupForm (Форма визуальной группы)Класс TVisualGroupAccess (Доступ к визуальным группам)Класс TVisualGroupRoutine (Подпрограмма визуальной группы)

Объекты класса образуют иерархию.

1. Свойства

Свойства класса TVisualGroup:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись | Изображение
IsAccessible | Boolean | Да | Скрыто от пользователя | Только для чтения | Доступна
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
Collapsed | Boolean | Да | Видимо пользователю | Чтение/Запись | Свернута

2. Конструктор Create (Конструктор визуальной группы)

Конструктор класса TVisualGroup.

1constructor TVisualGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Image: blob; Position: Integer; Scope: TScope; Collapsed: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Image | blob | Нет | Изображение
Position | Integer | Да | Позиция
Scope | TScope | Да | Область видимости
Collapsed | Boolean | Да | Свернута

Замечания:

Создает новый объект класса TVisualGroup.

3. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TVisualGroup.

function TVisualGroup.GetIsAccessible: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroup.

class function TVisualGroup.GetNextPos(Parent: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Parent | TObject | Нет | Родитель

Замечания:

Возвращает значение типа Integer.


Мельница данных ((раздел целиком))

Мельница данных- Класс TBanGroup (Группы запретов) (раздел целиком) (22.10.2024) (одним файлом)
Класс TBanGroup (Группы запретов)

Диаграмма Класс TObject (Объекты)Класс TBanGroupAccess (Доступ к группам запретов)Класс TBanGroupItem (Элементы группы запретов)Класс TClassBan (Запрет на класс)Класс TRoutineBan (Запрет на подпрограмму)Класс TPropertyBan (Запрет на свойство)Класс TFormBan (Запрет на форму)

1. Свойства

Свойства класса TBanGroup:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения | Доступна

2. Конструктор Create (Конструктор группы запретов)

Конструктор класса TBanGroup.

1constructor TBanGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TBanGroup.

3. Метод CreateAllBans (Сгенерировать запреты для класса)

Метод экземпляра класса TBanGroup.

1procedure TBanGroup.CreateAllBans(BannedClass: TClass; BanClass: Boolean;
2  BanRoutines: Boolean; BanProperties: Boolean; AllowRead: Boolean);

Параметры:

Имя | Тип | Обязательно | Значение
BannedClass | TClass | Да | Запрещаемый класс
BanClass | Boolean | Да | Запретить доступ к объектам класса
BanRoutines | Boolean | Да | Запретить подпрограммы
BanProperties | Boolean | Да | Запретить свойства
AllowRead | Boolean | Да | Чтение свойств разрешено

4. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TBanGroup.

function TBanGroup.GetIsAccessible: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IBooleanInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IBooleanInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IBooleanInfo = interface(ITypeInfo)
3    ['{8256EDF9-8613-4970-850C-50047839D6BF}']
4    function Get_TrueValue: WideString; safecall;
5    function Get_FalseValue: WideString; safecall;
6    property TrueValue: WideString read Get_TrueValue;
7    property FalseValue: WideString read Get_FalseValue;
8  end;

1. Свойства

Свойства интерфейса IBooleanInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
FalseValue | WideString | Только для чтения |
TrueValue | WideString | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Создание структур хранения и средств обработки данных (раздел целиком) (22.10.2024) (одним файлом)
Создание структур хранения и средств обработки данных

1. Класс TObject, члены класса TОbject

2. Создание классов

3. Создание полей

4. Создание свойств

5. Создание методов


Мельница данных ((раздел целиком))

Мельница данных- Класс TAccessibleFile (Доступный файл) (раздел целиком) (22.10.2024) (одним файлом)
Класс TAccessibleFile (Доступный файл)

Диаграмма Класс TObject (Объекты)

1. Свойства

Свойства класса TAccessibleFile:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
FileData | blob | Нет | Видимо пользователю | Чтение/Запись | Данные файла
CRC | string[8] | Нет | Видимо пользователю | Чтение/Запись | Контрольная сумма
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей
Category | string[128] | Нет | Видимо пользователю | Чтение/Запись | Категория

2. Конструктор Create (Конструктор доступного файла)

Конструктор класса TAccessibleFile.

1constructor TAccessibleFile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  FileData: blob): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
FileData | blob | Нет | Данные файла

Замечания:

Создает новый объект класса TAccessibleFile.

3. Метод SetData (Установить значение свойства "Данные файла")

Метод экземпляра класса TAccessibleFile.

procedure TAccessibleFile.SetData(FileData: blob);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
FileData | blob | Нет | Данные файла

4. Метод Ole-объекта CheckAllCRC (Обновить отсутствующие контрольные суммы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

5. Метод Ole-объекта CheckCRC (Обновить контрольную сумму)

Метод Ole-объекта класса TAccessibleFile.

Метод Ole-объекта не имеет параметров.

6. Метод Ole-объекта LoadFromFolder (Загрузить из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка

7. Метод Ole-объекта SaveToFolder (Сохранить в папку)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка

8. Метод Ole-объекта UpdateFromFolder (Обновить из папки)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка


Мельница данных ((раздел целиком))

Мельница данных- Класс TXSLTTemplate (Шаблоны отчетов XSLT) (раздел целиком) (22.10.2024) (одним файлом)
Класс TXSLTTemplate (Шаблоны отчетов XSLT)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

1. Свойства

Свойства класса TXSLTTemplate:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
TemplateData | clob | Нет | Видимо пользователю | Чтение/Запись | Данные шаблона
FunctionName | string[128] | Нет | Видимо пользователю | Чтение/Запись | Имя функции

2. Конструктор Create (Конструктор шаблона отчета XSLT)

Конструктор класса TXSLTTemplate.

1constructor TXSLTTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: clob;
6  FunctionName: string[128]): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
TemplateData | clob | Нет | Данные шаблона
FunctionName | string[128] | Нет | Имя вызываемой функции

Замечания:

Создает новый объект класса TXSLTTemplate.

3. Метод Ole-объекта CheckXSLTTemplate (Проверить шаблон отчетов XSLT)

Метод Ole-объекта класса TXSLTTemplate.

Метод Ole-объекта не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Отображение учитываемых объектов в таблице данных (раздел целиком) (22.10.2024) (одним файлом)
Отображение учитываемых объектов в таблице данных

Таблица данных имеет строки и колонки. Строки таблицы (или записи) соответствуют учитываемым объектам. Колонки таблицы соответствуют свойствам объектов.

Макет таблицы данных

На рисунке представлен макет таблицы данных, в которой отображаются объекты, соответствующие сортам фруктового мороженого. Таблица данных имеет наименование "Сорта фруктового мороженого", которое отображается на соответствующей закладке (1). Таблица имеет пять строк (2), соответствующих пяти сортам фруктового мороженого. Выделенной в настоящее время является первая строка. Таблица имеет пять колонок, соответствующих свойствам учитываемых сортов мороженого. Каждая колонка имеет заголовок (4), отражающий отображаемое в этой колонке свойство. Активной в настоящее время является первая колонка. Активным элементом данных (3) является ячейка, расположенная в первой строке в первом столбце.

На рисунке активная строка и активный элемент данных выделяются оттенками синего цвета. Цвета, применяемые для выделения элементов данных, зависят от локальных настроек операционной системы Windows (стилей) на компьютере пользователя.

Под заголовком каждой колонки расположена строка фильтра (5). При помощи ввода в этой строке условия отбора или выбора значений из выпадающего списка можно осуществлять фильтрацию отображаемых в таблице данных.

Если отображаемые данные не помещаются в окно по ширине, то активной становится горизонтальная полоса прокрутки (7). С ее помощью можно пролистывать колонки таблицы вправо и влево. Если данные не помещаются в окно по вертикали, то активной становится вертикальная полоса прокрутки (8). С ее помощью можно пролистывать записи об объектах вверх и вниз. При щелчке правой кнопкой мыши на полосе прокрутки (если она активна) доступны действия по быстрой прокрутке содержимого таблицы.

При щелчке правой кнопкой мыши в области таблицы данных отображается контекстное меню. Контекстное меню отображает список действий, доступных над объектами, отображаемыми в таблице данных. Вызываемые действия выполняются для тех объектов, которые являются выделенными в таблице данных. Если ни одного объекта не выделено, некоторые действия контекстного меню могут быть недоступны. Набор действий, отображаемых в контекстном меню различен в разных таблицах данных.

  1. Заголовок закладки с именем таблицы данных.
  2. Выделенный объект.
  3. Выделенный элемент данных.
  4. Заголовок колонки.
  5. Строка фильтра.
  6. Флажок для выбора объектов.
  7. Горизонтальная полоса прокрутки.
  8. Вертикальная полоса прокрутки

1. Иерархические таблицы данных

Если отображаемые в таблице данные имеют иерархическую структуру (т.е. присутствует "вхождение" одних объектов в другие), то в таблице данных объекты могут отображаться в виде "дерева".

Иерархическая таблица данных

На рисунке представлена таблица данных, отображающая периоды обучения студентов. Эти данные имеют иерархическую структуру, которая отражает вхождение учебных модулей в состав семестров, а семестров в состав учебных годов. В первой колонке иерархической таблицы данных слева от элементов данных, имеющих подчиненные элементы, отображаются значки Свернутый узел дерева или Развернутый узел дерева. При щелчке мышью по значку Свернутый узел дерева отображаются подчиненные объекты. Значок Свернутый узел дерева при этом превращается в значок Развернутый узел дерева. При щелчке мышью по значку Развернутый узел дерева подчиненные объекты скрываются и значок Развернутый узел дерева превращается в Свернутый узел дерева. На рисунке для объектов "Учебный год 2005-2006" и его подчиненных объектов "I семестр" и "II семестр" подчиненные объекты отображены. Щелчком по значку Развернутый узел дерева подчиненные объекты можно скрыть. Для объектов "I семестр" и "II семестр" учебного года 2006-2007 подчиненные объекты скрыты. Щелчком по значку Свернутый узел дерева их можно отобразить. При горизонтальном пролистывании таблицы данных вправо или влево "дерево" объектов всегда отображается слева от самого левого столбца.

В иерархических таблицах данных доступны дополнительные действия по управлению отображением и выбору объектов, которые описаны в разделе 4.7.1.


Мельница данных ((раздел целиком))

Мельница данных- Средства моделирования пользовательских интерфейсов (раздел целиком) (22.10.2024) (одним файлом)
Средства моделирования пользовательских интерфейсов

1. Представления

2. Формы. Включение представлений в формы

3. Визуальные группы. Включение форм в визуальные группы

4. Организация доступа пользователей к формам и визуальным группам


Мельница данных ((раздел целиком))

Мельница данных- Функция cursor (раздел целиком) (22.10.2024) (одним файлом)
Функция cursor

Функция cursor позволяет отправлять запросы на получение данных, доступных через обработчик сервера приложений, получать ответ с запрошенными данными в форматах xml или JSON.

Допустимые расширения:

  • .xml - для получения ответа в формате XML
  • .js/.json - для получения ответа в формате JSON

Функция осуществляет запрос к указанному классу или представлению и возвращает данные, соответствующие структуре и условиям переданного запроса. Запрос к данным передается в виде параметра GET или POST-запроса с именем query. Значение параметра представляет собой xml-документ следующей структуры:

01<query class="TWorker">
02  <item part="what" name="LastName" />
03  <item part="what" name="FirstName"/>
04  <item part="what" name="MiddleName"/>
05  <item part="what" name="BirthDate"/>
06  <item part="what" name="ContactList" value="TPerson.GetContactList" special="function">
07    <parameters>
08      <ContactType>63474</ContactType>
09    </parameters>
10  </item>
11  <item part="where" name="LastName" value="А*"/>
12  <item part="order" name="LastName"/>
13  <item part="order" name="FirstName"/>
14</query>

Элемент query имеет обязательный атрибут class. Значением атрибута class должно быть имя класса или представления, к которому будет выполняться запрос. Также может использоваться необязательный атрибут fetchall, который может принимать значения "0" (значение по умолчанию) или "1". Использование атрибута fetchall подробнее описано ниже в разделе Использование возвращаемого ответа.

Элемент query может включать в себя элементы item, передающие структуру запроса, условия отбора, сортировки, группировки. Элементы item могут включать в себя необязательные элементы (context, parameters, и т.п.; имя этого элемента не анализируется).

Состав атрибутов элемента item (обязательным является только атрибут part, остальные атрибуты можно опускать, в зависимости от использования других атрибутов):

  • part (обязательный атрибут) - часть запроса (what, where, order,...)
  • name - в простом случае (без использования special) - имя свойства класса (или поля представления), которое будет использовано в запросе; при использовании special может быть как именем свойства класса, так и другой строкой (см. подробнее ниже).
  • value - значение, которое в зависимости от значения атрибутов part и special, будет использовано для сравнений или для других целей; в простом случае (если part = "where", special отсутствует) будет использовано для сравнения в условии отбора при выполнении запроса.
  • special - вводит дополнительные возможности формирования запроса (возможности описаны ниже); от использованного значения данного атрибута может зависеть трактовка значений других атрибутов.
  • subQuery
  • joinKey
  • joinLink
  • joinSource

Допустимые значения атрибута part (можно использовать как строковые, так и числовые значения):

Строковое
значение 		Числовое
значение 		Назначение и пример использования
what 0 Элементы со значением "what" (0) атрибута part используются для формирования what-кляузы запроса. В полученном ответе каждому такому элементу будет соответствовать один xml или json элемент с именем, переданным атрибутом name.
<item part="what" name="LastName"/>
Получить значение свойства "LastName".
where 1 Элементы со значением "where" (1) атрибута part используются для формирования условия отбора объектов (where-кляузы запроса).
Для условий допустимо использовать "маску" (*, ?), условия ">", "<", ">=", "<=";
использование значений через ";" будет трактовано как условие "или", использование "&" будет трактовано как условие "и";
для отрицания нужно использовать "!", для условия "not null" нужно использовать "*", для условия "is null" нужно использовать "!*".
Каждый следующий where-элемент добавляет к запросу одно условие "и".
1<item part="where" name="LastName" value="Петров"/>
2<item part="where" name="FirstName" value="А*"/>
Отобрать объекты класса со значением свойства "LastName", равным "Петров", и значениями "FirstName", начинающимися с символа "А".
order 2 Элементы со значением "order" (2) атрибута part используются для управления сортировкой данных в возвращаемом ответе. По умолчанию (без использования атрибута special) будет выполнена сортировка "по возрастанию". Задать сортировку "по убыванию" можно, использовав значение "desc" (7) для атрибута special. Если в запросе использовано несколько элементов "order", то возвращаемый результат будет отсортирован по нескольким полям в том порядке, в котором они указаны в запросе.
1<item part="order" name="LastName/>
2<item part="order" name="BirthDate" special="desc"/>
Отсортировать результат запроса по значению свойства "LastName" по возрастанию, затем по значению свойства "BirthDate" по убыванию.
group 3 Элементы со значением "group" (3) атрибута part используются для управления группировкой данных в возвращаемом ответе. Если в запросе использовано несколько элементов "group", то возвращаемый результат будет сгруппирован по нескольким полям в том порядке, в котором они указаны в запросе. Для свойств, не входящих в условия группировки, можно получать значения агрегатов (количество, наименьшее/наибольшее/среднее и т.п.), используя атрибут special.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="what" name="BirthDate" special="min"/>
4<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region", количество записей в группе и минимальное значение свойства "BirthDate" в этой группе.
having 4 Элементы со значением "having" (4) атрибута part позволяют накладывать условия отбора на группы в запросе с группировкой.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="what" name="BirthDate" special="min"/>
4<item part="group" name="Region"/>
5<item part="having" name="ID" value=">3" special="count"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region", количество записей в группе и минимальное значение свойства "BirthDate" в этой группе, отобрав при этом только такие группы, количество объектов в которых больше 3-х.
innerJoin | 5
outerJoin | 6

Допустимые значения атрибута special (можно использовать как строковые, так и числовые значения):

Строковое
значение 		Числовое
значение 		Части запроса Назначение и пример использования
ID 1 what
where 		Позволяет запрашивать идентификатор объекта или накладывать условия по идентификатору.
1<query class="TWorker">
2  <item part="what" special="ID"/>
3  <item part="what" name="LastName"/>
4  <item part="what" name="FirstName"/>
5  <item part="where" value="5500921" special="ID"/>
6</query>
Получить идентификатор объекта, значения свойств LastName, FirstName объекта с идентификатором, равным 5500921. Ответ на запрос будет содержать элемент с именем ID.
parent 2 what
where 		Позволяет использовать в запросах идентификатор "родителя" объекта.
1<query class="TCountry">
2  <item part="what" special="ID"/>
3  <item part="what" special="parent"/>
4  <item part="what" name="Name"/>
5  <item part="what" name="Description"/>
6</query>
Получить идентификатор объекта, идентификатор родительского объекта, значения свойств Name, Description всех объектов класса TCountry. Ответ на запрос будет содержать элемент с именем Parent.
haschildren 3 what
where 		Признак наличия дочерних объектов в иерархии. Ответ на запрос будет содержать элемент с именем HasChildren и значением "1" в случае наличия дочерних объектов и значением "0" в случае их отсутствия.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" special="haschildren"/>
5</query>
Получить значения свойств Name, Description, а также признак наличия дочерних объектов всех объектов класса TCountry.
filter 4 where Позволяет использовать для отбора условия, заданные доменами, использованными в решении на платформе. Имя или идентификатор домена указывается в атрибуте name. Условие отбора этого домена будет интерпретировано с учетом значений, переданных в дочернем элементе context. Для каждого из этих значений должны быть указаны его имя, домен и значение.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name = "TRegion of UnivCountry domain" special="filter>
5      <context>
6        <UnivCountry domain="4565848">67991</UnivCountry>
7      </context>
8  </item>
9</query>
Получить значения свойств Name, Description объектов класса TCountry, подходящих под условие отбора домена "TRegion of UnivCountry domain", используя значение "67991" вместо идентификатора UnivCountry.
Условие отбора домена "TRegion of UnivCountry domain":
((Self.Parent = UnivCountry) or (Self = UnivCountry))
uplink 5 what
where 		Используется для отбора данных в контексте выбранных родительских объектов. Связь отбираемых объектов с выборкой связанных родительских объектов будет установлена по свойству, переданному атрибутом name. В атрибуте value может быть передан идентификатор одного объекта, список идентификаторов объектов через ";" или идентификатор буфера, в который предварительного сохранен список объектов.
1<query class="TCountry">
2  <item part="where" name="Parent" value="14750" special="uplink"/>
3  <item part="what" name="Name"/>
4  <item part="what" name="Description"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, у которых значение свойства Parent равно "14750" (или входит в состав объектов, сохраненных в буфере с идентификатором "14750").
root 6 where Будут отобраны только объекты, не имеющие родителя, после наложения других условий отбора.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" special="root"/>
5</query>
Получить значения свойств Name, Description "корневых" (не имеющих родителя) объектов класса TCountry.
desc 7 order Используется для сортировки "по убыванию" для элементов с атрибутом part ="order". Без указания атрибута special будет выполнена сортировка "по возрастанию".
1<item part="order" name="LastName"/>
2<item part="order" name="BirthDate" special="desc"/>
Отсортировать результат запроса по значению свойства "LastName" по возрастанию, затем по значению свойства "BirthDate" по убыванию.
count 8 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения количества объектов в группе.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="group" name="Region"/>
4<item part="having" name="ID" value=">3" special="count"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и количество записей в группе, отобрав при этом только такие группы, количество объектов в которых больше 3-х.
sum 9 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения суммы значений свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="PayedSum" special="sum"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и сумму значений свойства "PayedSum" для всех объектов группы.
min 10 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения минимального значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="BirthDate" special="min"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и минимальное значение свойства "BirthDate" среди всех объектов группы.
max 11 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения максимального значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="BirthDate" special="max"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и максимальное значение свойства "BirthDate" среди всех объектов группы.
avg 12 what
having 		Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения среднего значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"
2<item part="what" name="PayedSum" special="avg"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и среднее значение свойства "PayedSum" среди всех объектов группы.
masterLink 13 where Позволят наложить отбор на объекты класса ("подчиненный" класс) в контексте выбранных объектов класса-мастера или класса, связанного с исходным по другому свойству ("главный" класс). В атрибуте name в этом случае передаются имена свойства "главного" класса и свойства "подчиненного" класса, по которым эти классы связаны. Имена свойств указываются следующим образом:
  • Если одним из этих свойств является идентификатор (ID), то имя этого свойства не указывается (это свойство используется по умолчанию)
  • Если оба свойства отличаются от ID, то их имена указываются через разделитель ";", например, "Master;Person"
  • Если только свойство "подчиненного" класса отличается от ID, то указывается только имя этого свойства, например, "Person"
  • Если только свойство "главного" отличается от ID, то вместо свойства-подчиненного указывается *, например, "Master;*"
В свойстве value передается идентификатор буфера, содержащего список выбранных объектов "главного" класса.
1<query class="TContact">
2  <item part="what" name="ContactInfo"/>
3  <item part="what" name="ContactType" special="name"/>
4  <item part="where" name="Person" value="246889" special="masterLink"/>
5</query>
Получить значения свойств ContactInfo, ContactType (Имя) объектов класса TContact, для объектов, список которых сохранен в буфере с идентификатором "246889", связанным с классом TContact по свойству Person.
selectedOnly 14 where Позволят наложить отбор по списку идентификаторов объектов класса, ранее сохраненных в буфере.
1<query class="TPerson">
2  <item part="what" name="LastName"/>
3  <item part="what" name="FirstName"/>
4  <item part="where" value="246889" special="selectedOnly"/>
5</query>
Получить значения свойств LastName, FirstName объектов класса TPerson, список которых сохранен в буфере с идентификатором "246889".
distinct 15 what Позволяет получить все уникальные значения определенного свойства или сочетания значений свойств класса.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" special="distinct"/>
4</query>
Получить набор уникальных значений свойства FirstName класса TPerson.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="MiddleName"/>
4  <item part="what" special="distinct"/>
5</query>
Получить набор уникальных сочетаний значений свойств FirstName и MiddleName класса TPerson.
view 16 where Позволяет при выполнении запроса наложить отбор, используемый для определенного представления. Имя (или идентификатор) представления указывается в атрибуте name.
1<query class="TPerson">
2  <item part="where" name="Persons older 25" special="view"/>
3  <item part="what" name="FirstName"/>
4  <item part="what" name="LastName"/>
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, соответствующих условиям отбора представления Persons older 25.
caseInsensitive 17 where Позволяет наложить отбор на значение свойства строкового типа без учета регистра. Без использования special поиск ведется с учетом регистра.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="LastName"/>
4  <item part="where" name="FirstName" value="АНДРЕЙ" special="caseInsensitive"/>
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, с отбором по значению свойства FirstName без учета регистра символов. TPerson.
string 18 where Позволят явно приводить к строковому типу значения свойства, переданного атрибутом name.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="Code" value="00002" special="string"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, со значением свойства Code, равным "00002".
listed 19 where Позволяет выполнять отбор по списку объектов, входящих в список, сохраненный в системе как объект класса TObjectList ("Списки"), идентификатор которого нужно передать в качестве значения атрибута value.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="ID" value="5245654" special="listed"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, входящих в список, сохраненный как объект класса TObjectList с идентификатором "5245654".
name 20 what
where 		Для свойств-ссылок на объекты позволяет получить Имя объекта, переданного атрибутом name. В полученном ответе соответствующий элемент будет иметь имя ИмяСвойства-N.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Parent"/>
5  <item part="what" name="Parent" special="name"/>
6</query>
Для всех объектов класса TCountry получить значения свойств Name, Description, Parent, а также Имя объекта Parent.
description 21 what
where 		Для свойств-ссылок на объекты позволяет получить Наименование объекта, переданного атрибутом name. В полученном ответе соответствующий элемент будет иметь имя ИмяСвойства-D.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Parent"/>
5  <item part="what" name="Parent" special="description"/>
6</query>
Для всех объектов класса TCountry получить значения свойств Name, Description, Parent, а также Наименование объекта Parent.
function 22 what
where 		Позволяет использовать значения, полученные в результате вызова функций, как в элементах с атрибутом part ="what", так и в элементах с атрибутом part ="where". Имя функции должно быть передано в атрибуте value в формате Имя класса.Имя функции. Если функция имеет параметры, то для их передачи необходимо добавить дочерний элемент context, со своими дочерними элементами для каждого из параметров в формате <ИмяПараметра>Значение параметра</ИмяПараметра>. Если функция является "методом объекта", параметр "ID" добавлять не нужно, он будет использован автоматически. В элементах с атрибутом part ="what" значение атрибута name может быть любым, оно не будет использовано при выполнении запроса, но станет именем элемента данных в получаемом ответе.
01<item part="what" name="InitAndLast" value="TPerson.GetInitAndLast" special="22"/>
02<item part="what" name="ContactList" value="TPerson.GetContactList" special="22">
03  <context>
04    <ContactType>63474</ContactType>
05  </context>
06</item>
07<item part="where" name="TWorker.IsSuperior" value="1" special = "function">
08  <context>
09    <OtherWorker>625186</OtherWorker>
10    <Department></Department>
11  </context>
12</item>
Получить результат выполнения функции GetInitAndLast класса TPerson (функция не имеет параметров), получить результат выполнения функции GetContactList класса TPerson с параметром ContactType = 625186. Отобрать только те объекты, для которых результат выполнения функции IsSuperior класса TWorker равен "1". Функция IsSuperior вызывается со значением 625186 параметра OtherWorker и пустым значением параметра Department.
countdistinct 23 what
having 		Позволяет получить количество уникальных значений свойства.
1<query class="TPerson">
2  <item part="what" name="FirstName" special="countdistinct"/>
3</query>
Получить количество уникальных значений свойства FirstName класса TPerson.
boolean 24 what
where 		Позволят приводить к "логическому" типу значения свойства, переданного атрибутом name. Приведение выполняется по следующему принципу:
  • значение Null преобразуется в пустое значение в ответе
  • значение "0" остается значением "0" в ответе
  • любое непустое значение преобразуется в значение "1" в ответе
Такая возможность позволяет, например, более эффективно (без получения самих значений) определять пустоту/непустоту значений типа "большой объект".
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Code" special="boolean"/>
5</query>
Получить значения свойств Name, Description, а также значение свойства Code, преобразованное к "логическому" всех объектов класса TCountry.
exact 25 where При использовании значения "exact" (25) атрибута special значение, переданное в атрибуте value, будет использовано "как есть" - без преобразования типов, без трактовки символов "*", "?" как маски и т.п.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="Code" value = "002*25?" special="exact"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry со значением свойства Code, равным "002*25?".
searchindex 26 where Позволяет использовать индексы полнотекстового поиска при отборах. Поиск по выполняться по всем полям класса, значение атрибута name будет проигнорировано.
1<query class="TMailMessage">
2  <item part="what" name="Theme"/>
3  <item part="what" name="Body"/>
4  <item part="what" name="Created"/>
5  <item part="where" value="приглашаем *на семинар *Современные" special="searchindex">
6</query>
Получить значения свойств Theme, Body, Created объектов класса TMailMessage, среди значений свойств которых будет найдена указанная строка, с использованием индекса полнотекстового поиска.
optimization 27 where Позволяет использовать имеющиеся подсказки оптимизатору при выполнении запроса.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="LastName"/>
4  <item part="what" value="ORARefreshOnFetch=true;APPRefreshOnFetch=true" special="optimization">
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, используя при выполнении запроса подсказки оптимизатору.

1. Использование возвращаемого ответа

При корректном выполнении запроса ответ будет представлять собой набор данных следующей структуры:

  • При использовании формата xml будет возвращен xml-документ с корневым элементом data, который будет иметь атрибуты handle (GUID) и eof ("1" или "0"). Элемент data будет иметь подчиненные элементы row, каждый из которых будет соответствовать одной записи, полученной при выполнении запроса. Каждый элемент row будет иметь подчиненные элементы, соответствующие what-элементам запроса.
  • При использовании формата JSON будет возвращен JSON-объект, содержащий пары ключ-значение handle (значение типа GUID), eof (значения "0" или "1") и data. Значением data будет массив пар ключ-значение, каждая из которых будет соответствовать одной записи, полученной при выполнении запроса.

Обработчик сервера приложений, обеспечивающий работу функций RESTfull-сервисов, в том числе функции cursor, имеет параметры, ограничивающие размер пакета возвращаемых данных, выраженные в количестве объектов в ответе и в объеме ответа в байтах. В случае, если размер ответа укладывается в оба этих ограничения, все полученные данные будут возвращены полностью, и в ответе будет передан атрибут (значение) eof="1". В случае, если размер ответа превысит одно из ограничений, и при этом в запросе атрибут fetchall не задан или равен "0", то в ответ войдет только такой набор записей, который позволит соблюсти ограничения, и при этом в ответе будет передан атрибут (значение) eof="0". Если в запросе был передан атрибут fetchall="1", то будет выполнена попытка вернуть весь ответ полностью, несмотря на установленные ограничения. При успешной передаче атрибут (значение) eof будет равен "1".

Пример запроса:
1  <query class="TWorker" fetchall="1">
2    <item part="0" name="LastName"/>
3    <item part="0" name="FirstName"/>
4    <item part="0" name="BirthDate"/>
5    <item part="0" name="AcademicStatus"/>
6    <item part="1" name="BirthDate" value=">12.05.2000"/>
7  </query>
Пример ответа в формате xml:
01  <data handle="{FDF9EE70-9948-4A99-8233-349C3ADD3CE8}" eof="1">
02    <row>
03      <LastName>Абишин</LastName>
04      <FirstName>Вячеслав</FirstName>
05      <BirthDate type="date">10.06.2014</BirthDate>
06      <AcademicStatus>к.э.н.</AcademicStatus>
07    </row>
08    <row>
09      <LastName>Агринская</LastName>
10      <FirstName>Ольга</FirstName>
11      <BirthDate type="date">24.08.2016</BirthDate>
12      <AcademicStatus>PhD</AcademicStatus>
13    </row>
14    <row>
15      <LastName>Абрамов</LastName>
16      <FirstName>Александр</FirstName>
17      <BirthDate type="date">05.09.2016</BirthDate>
18     <AcademicStatus/>
19    </row>
20  </data>
Пример ответа в формате JSON:
01  {
02      "handle": "{C57F629E-583C-4477-ACBF-E436F6D01628}",
03      "eof": true,
04      "data": [
05          {
06              "LastName": "Абишин",
07              "FirstName": "Вячеслав",
08              "BirthDate": {
09                  "year": 2014,
10                  "month": 5,
11                  "day": 10
12              },
13              "AcademicStatus": "к.э.н."
14          },
15          {
16              "LastName": "Агринская",
17              "FirstName": "Ольга",
18              "BirthDate": {
19                  "year": 2016,
20                  "month": 7,
21                  "day": 24
22              },
23              "AcademicStatus": "PhD"
24          },
25          {
26              "LastName": "Абрамов",
27              "FirstName": "Александр",
28              "BirthDate": {
29                  "year": 2016,
30                  "month": 8,
31                  "day": 5
32              },
33              "AcademicStatus": null
34          }
35      ]
36  }

Значение eof = "1" означает, что данные получены полностью. Если в ответе такого значения (атрибута) нет, или eof = "0", это означает, что получены не все данные. Дополучить эти данные можно, повторно выполнив вызов функции cursor, передав в качестве значения параметра query полученное при первом вызове значение handle.
https://techmill.ru/demo/cursor.xml?query={FDF9EE70-9948-4A99-8233-349C3ADD3CE8}
В ответе на запрос с использованием handle вернется то же самое значение handle. Таким образом, запрос можно повторять с одним и тем же значением handle до тех пор, пока в ответе не будет получено eof = "1", что позволит убедиться в том, что данные получены полностью.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IFieldInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IFieldInfo

Интерфейс INamedItemInfo

1type
2  IFieldInfo = interface(INamedItemInfo)
3    ['{19054DAD-8D35-4B39-8EB7-FD3254BD2934}']
4    function Get_TypeInfo: ITypeInfo; safecall;
5    function Get_DisplayMode: TDisplayMode; safecall;
6    property TypeInfo: ITypeInfo read Get_TypeInfo;
7    property DisplayMode: TDisplayMode read Get_DisplayMode;
8  end;

1. Свойства

Свойства интерфейса IFieldInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
DisplayMode | TDisplayMode | Только для чтения |
TypeInfo | ITypeInfo | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс INamedItemInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс INamedItemInfo

01type
02  INamedItemInfo = interface(IUnknown)
03    ['{14894363-28DA-4E71-B0BC-9C5CE811BC8F}']
04    function Get_Name: WideString; safecall;
05    function Get_Caption: WideString; safecall;
06    function Get_ID: WideString; safecall;
07    property Name: WideString read Get_Name;
08    property Caption: WideString read Get_Caption;
09    property ID: WideString read Get_ID;
10  end;

1. Свойства

Свойства интерфейса INamedItemInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения |
ID | WideString | Только для чтения |
Name | WideString | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Средства моделирования пользовательского интерфейса (раздел целиком) (22.10.2024) (одним файлом)
Средства моделирования пользовательского интерфейса

1. Представления

2. Визуальные группы

3. Формы, связь представлений в формах


Мельница данных ((раздел целиком))

Мельница данных- Дополнительные интерфейсы (раздел целиком) (22.10.2024) (одним файлом)
Дополнительные интерфейсы

1. Интерфейс IBinaryData

01type
02  IBinaryData = interface(IDispatch)
03    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
04    procedure Append(Src: OleVariant); safecall;
05    procedure Load(Src: OleVariant); safecall;
06    procedure Save(Dst: OleVariant); safecall;
07    function Size: LongWord; safecall;
08    procedure AppendData(Data: OleVariant; DataSize: LongWord); safecall;
09    procedure SetData(Data: OleVariant; DataSize: LongWord); safecall;
10    procedure GetData(Data: OleVariant); safecall;
11    function ToString(const Encoding: WideString): WideString; safecall;
12    procedure FromString(Data: OleVariant); safecall;
13    procedure AppendString(Data: OleVariant); safecall;
14    function ToBase64(Width: Integer): WideString; safecall;
15    procedure FromBase64(Data: OleVariant); safecall;
16    function ContentIsText: WordBool; safecall;
17  end;

1.1. Метод Append

Метод интерфейса IBinaryData.

procedure IBinaryData.Append(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

1.2. Метод AppendData

Метод интерфейса IBinaryData.

procedure IBinaryData.AppendData(Data: OleVariant; DataSize: LongWord);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |
DataSize | LongWord | Да |

1.3. Метод AppendString

Метод интерфейса IBinaryData.

procedure IBinaryData.AppendString(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

1.4. Метод ContentIsText

Метод интерфейса IBinaryData.

function IBinaryData.ContentIsText: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

1.5. Метод FromBase64

Метод интерфейса IBinaryData.

procedure IBinaryData.FromBase64(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

1.6. Метод FromString

Метод интерфейса IBinaryData.

procedure IBinaryData.FromString(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

1.7. Метод GetData

Метод интерфейса IBinaryData.

procedure IBinaryData.GetData(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

1.8. Метод Load

Метод интерфейса IBinaryData.

procedure IBinaryData.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

1.9. Метод Save

Метод интерфейса IBinaryData.

procedure IBinaryData.Save(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |

1.10. Метод SetData

Метод интерфейса IBinaryData.

procedure IBinaryData.SetData(Data: OleVariant; DataSize: LongWord);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |
DataSize | LongWord | Да |

1.11. Метод Size

Метод интерфейса IBinaryData.

function IBinaryData.Size: LongWord;

Метод не имеет параметров.

Замечания:

Возвращает значение типа LongWord.

1.12. Метод ToBase64

Метод интерфейса IBinaryData.

function IBinaryData.ToBase64(Width: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Width | Integer | Нет |

Замечания:

Возвращает значение типа WideString.

1.13. Метод ToString

Метод интерфейса IBinaryData.

function IBinaryData.ToString(const Encoding: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Encoding | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Мельница данных ((раздел целиком))

Мельница данных- Класс TView (Представления) (раздел целиком) (22.10.2024) (одним файлом)
Класс TView (Представления)

Диаграмма Класс TCustomView (Абстрактное представление)Класс TObject (Объекты)Класс TViewColumn (Колонки представлений)Класс TViewPresentation (Виды)

1. Свойства

Свойства класса TView:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
ShownClass | TClass | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TCustomView
ShownClassMasterClass | TClass | Нет | Видимо пользователю | Только для чтения
ShownClassReplicationStatus | TReplicationStatus | Да | Видимо пользователю | Только для чтения
ShownClassIsHierarhical | Boolean | Да | Видимо пользователю | Только для чтения
Skimpy | Boolean | Да | Видимо пользователю | Чтение/Запись
BoldProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
PreCompiled | Boolean | Да | Видимо пользователю | Чтение/Запись
PreOpenRoutine | TRoutine | Нет | Видимо пользователю | Чтение/Запись
ColorProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
OptimizationParameters | string[2000] | Нет | Видимо пользователю | Чтение/Запись
HasConditions | Boolean | Да | Видимо пользователю | Только для чтения
HasSpecificalyNamedColumns | Boolean | Да | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
IsGrouped | Boolean | Да | Видимо пользователю | Только для чтения | Сгруппировано
LinesPerRow | Integer | Да | Видимо пользователю | Чтение/Запись | Строк на ячейку
Collapsed | Boolean | Да | Видимо пользователю | Чтение/Запись | Свернуть
HasPresentations | Boolean | Да | Видимо пользователю | Только для чтения | Имеет виды
IsSorted | Boolean | Да | Видимо пользователю | Только для чтения | Отсортировано
IsAggregated | Boolean | Да | Видимо пользователю | Только для чтения | Агрегировано

2. Конструктор Create (Конструктор представления)

Конструктор класса TView.

1constructor TView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  Collapsed: Boolean): TObject;

Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
ShownClass | TClass | Да | Унаследовано от TCustomView.Create
ColorProperty | TProperty | Нет
BoldProperty | TProperty | Нет
Skimpy | Boolean | Да
PreCompiled | Boolean | Да
PreOpenRoutine | TRoutine | Нет
Collapsed | Boolean | Да | Свернуто

Замечания:

Создает новый объект класса TView.

3. Метод BuildDefaultColumns (Создать колонки по умолчанию)

Метод экземпляра класса TView.

1procedure TView.BuildDefaultColumns(AddNameColumn: Boolean;
2  AddDescColumn: Boolean);

Параметры:

Имя | Тип | Обязательно | Значение
AddNameColumn | Boolean | Да | Создать колонку имени
AddDescColumn | Boolean | Да | Создать колонку наименования

4. Метод GetHasPresentations (Имеет виды)

Метод экземпляра класса TView.

function TView.GetHasPresentations: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5. Метод GetIsAggregated (Агрегировано)

Метод экземпляра класса TView.

function TView.GetIsAggregated: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

6. Метод GetIsGrouped (Сгруппировано)

Метод экземпляра класса TView.

function TView.GetIsGrouped: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

7. Метод GetIsSorted (Отсортировано)

Метод экземпляра класса TView.

function TView.GetIsSorted: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Мельница данных ((раздел целиком))

Мельница данных- Класс TInstantContact (Контакты) (раздел целиком) (22.10.2024) (одним файлом)
Класс TInstantContact (Контакты)

Класс TObject (Объекты)Класс TUser (Пользователи)

Имена объектов класса генерируются.

1. Свойства

Свойства класса TInstantContact:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Owner | TUser | Да | Видимо пользователю | Только для чтения | Владелец
IsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Владелец - текущий пользователь
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
Status | TInstantContactStatus | Да | Видимо пользователю | Чтение/Запись | Статус
BackContact | TInstantContact | Нет | Видимо пользователю | Только для чтения | Ответный контакт
BackContactStatus | TInstantContactStatus | Да | Видимо пользователю | Только для чтения | Состояние ответного контакта

2. Конструктор Create (Конструктор контакта)

Конструктор класса TInstantContact.

1constructor TInstantContact.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Status: TInstantContactStatus): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
User | TUser | Да | Пользователь
Status | TInstantContactStatus | Да | Статус

Замечания:

Создает новый объект класса TInstantContact.

3. Метод AddContact (Добавить контакт)

Метод класса (статический метод) класса TInstantContact.

class function TInstantContact.AddContact(Master: TUser; User: TUser): TObject;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TUser | Да | Мастер
User | TUser | Да | Пользователь

Замечания:

Возвращает значение типа TObject.

4. Метод LastUsedContact (Получить последний использованный контакт)

Метод класса (статический метод) класса TInstantContact.

class function TInstantContact.LastUsedContact(AUser: TUser): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AUser | TUser | Да | Пользователь

Замечания:

Возвращает значение типа TObject.


Мельница данных ((раздел целиком))

Мельница данных- Класс TProfileMethod (Методы профиля) (раздел целиком) (22.10.2024) (одним файлом)
Класс TProfileMethod (Методы профиля)

Класс TProfileEvent (События профиля)Класс TProfileStatistics (Статистика профиля)

Объекты класса образуют иерархию.

1. Свойства

Свойства класса TProfileMethod:

Имя | Тип | Обязательно | Доступ | Назначение
Parent | TProfileMethod | Нет | Только для чтения | Родитель
Method | TMethod | Да | Только для чтения | Метод профилировщика
MethodClass | TClass | Да | Только для чтения | Класс
Position | Integer | Да | Только для чтения | Позиция
Duration | Integer | Нет | Только для чтения | Общее время
CodeDuration | Integer | Нет | Только для чтения | Время собственного кода
Calls | Integer | Нет | Только для чтения | Количество непосредственных вызовов
Events | Integer | Нет | Только для чтения | Непосредственных операций с данными
CommonCalls | Integer | Нет | Только для чтения | Всего вызовов
CommonEvents | Integer | Нет | Только для чтения | Всего операций с данными
ObjectID | string[38] | Да | Только для чтения | Идентификатор объекта
ObjectQualifiedName | string[2000] | Нет | Только для чтения | Квалифицированное имя объекта
ObjectDataBase | TDataBase | Нет | Только для чтения | База данных объекта
ObjectOldID | string[38] | Нет | Только для чтения | Идентификатор при создании

2. Метод BuildReport (Перестроить отчет)

Метод класса (статический метод) класса TProfileMethod.

class procedure TProfileMethod.BuildReport(QualifyObjects: Boolean);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
QualifyObjects | Boolean | Да | Квалифицировать объекты

3. Метод Clear (Очистить статистику)

Метод класса (статический метод) класса TProfileMethod.

class procedure TProfileMethod.Clear;

Метод является методом класса.

Метод не имеет параметров.

4. Метод Ole-объекта ExportProfilerReport (Экспортировать отчет)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TProfileMethod.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
FileName | string[255] | Да | Имя файла


Мельница данных ((раздел целиком))

Мельница данных- Интерфейсы взаимодействия с внешними подсистемами (раздел целиком) (22.10.2024) (одним файлом)
Интерфейсы взаимодействия с внешними подсистемами

Системный слой платформы "Мельница данных" предоставляет сторонним системам ряд интерфейсов, дающих возможность обращаться к объектам базы данных и их свойствам, вызывать методы классов и объектов, осуществлять запросы к базе данных, управлять поведением элементов управления и проч.

1. Интерфейс IContext
01  IContext = interface(IDispatch)
02    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
03    function Handle: Integer;
04    function getName(ID: OleVariant): WideString;
05    function getDescription(ID: OleVariant): WideString;
06    function createDataSet(const TargetClassName: WideString):
07      IContextDataSet;
08    function executeMethod(const ClassName: WideString;
09      const MethodName: WideString;
10      Params: OleVariant): OleVariant;
11    function executeReport(const ClassName: WideString;
12      const TemplateName: WideString;
13      Params: OleVariant): IDispatch;
14    function getPropValue(const ClassName: WideString;
15      const PropName: WideString;
16      const ID: OleVariant): OleVariant;
17    procedure setPropValue(const ClassName: WideString;
18      const PropName: WideString;
19      const ID: OleVariant; Value: OleVariant);
20    function select(const ClassName: WideString;
21      QueryItems: OleVariant): IDispatch;
22    function enumerationItem(ItemIdentifier: OleVariant): WideString;
23    function getClass(const ClassName: WideString): WideString;
24    function createGUID: WideString;
25    procedure processStart(const Description: WideString;
26      ItemCount: Integer);
27    procedure processStep;
28    procedure processStop;
29    function PlaceDataSet(const Range: IDispatch;
30      const DataSet: IContextDataSet;
31      ShiftRows: WordBool; ShiftColumns: WordBool): Integer;
32    procedure DebugString(const Message: WideString);
33    procedure ExportObject(var Document: OleVariant; const ID: WideString;
34      const ClassID: WideString);
35    function callRoutine(const ClassName, RoutineName: WideString;
36      var RetValue: OleVariant; const ScriptPart: OleVariant): WordBool;
37    function getOleObject(const ClassID, AccessibleFileName: WideString): IDispatch;
38    function getResource(const Name: WideString): WideString;
39    function getTempFileName(const Extension: WideString): WideString;
40    function selectVaue(const ClassDomain: WideString;
41      const ExpressionContext: IContextExpressionInfo;
42      var Value: OleVariant): WordBool;
43    procedure raiseManagedException(const ExceptionMessage: WideString);
44    function getCRC(Data: OleVariant): WideString;
45    function downloadData(const Host: WideString; const Url: WideString;
46      const UserName: WideString; const Password: WideString;
47      NegotiateAuth: WordBool; PostData: OleVariant;
48      const PostContentType: WideString; PostDataIsBinary: WordBool;
49      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;
50    function createBinaryData: IDispatch;
51    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
52    function editValues(const ValuesList: WideString; const Title: WideString;
53      UseTabs: WordBool; HideOKButton: WordBool;
54      const ScriptPart: OleVariant): WordBool;
55    function MsgBox(const Prompt: WideString; Buttons: LongWord;
56      const Title: WideString;
57      const HelpFile: WideString; Context: LongWord): Integer;
58    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
59      const Title: WideString;
60      const HelpFile: WideString; Context: LongWord): Integer;
61    function buildNamedFile(const Data: IDispatch; const StoredFileName: WideString;
62                            Propmpt: WordBool; Compress: WordBool): IDispatch;
63    procedure parseNamedFile(const NamedFile: IDispatch; out FileName: OleVariant;
64                             out Data: OleVariant);
65    procedure showView(const ViewName: WideString; Key: OleVariant;
66                       const DetailPropertyName: WideString);
67    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
68                          ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
69                          TakeActionsFromView: OleVariant);
70    function executeConsoleProcess(const CommandLine: WideString; MaxDuration: Integer;
71                                   const OutputData: OleVariant): Integer;
72    function createRaster: IDispatch;
73    function createZIPArchive: IDispatch;
74    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch;
75    property ContextObject: IDispatch;
76    property Language: WideString;
77    property UserName: WideString;
78    property NegotiateAuth: WordBool;
79    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant;
80  end;

Члены интерфейса доступны для использования в скриптах форм задания параметров, а также в отчетах как члены класса передаваемого контекстного объекта.

  • Функция Handle возвращает дескриптор главного окна приложения.
  • Функция getName возвращает имя объекта по его идентификатору.
  • Функция getDescription возвращает наименование объекта по его идентификатору.
  • Функция createDataSet создает набор данных, основанный на экземплярах класса, имя которого передано как параметр. Возвращаемый объект реализует интерфейс IContextDataSet.
  • Функция executeMethod осуществляет вызов метода с параметрами. Имя класса передается в параметре ClassName, имя вызываемого метода - в параметре MethodName. Если вызываемый метод явяется функцией, то результат ее выполнения возвращается как результат вызова executeMethod. Параметры вызова метода передаются через параметр Params следующим образом:
    • Для методов класса без параметров можно передавать любое значение, например, Null.
    • Для методов класса, имеющих один параметр, значение Params есть значение этого единственного параметра.
    • Для методов класса, имеющих более одного параметра, значение Params есть массив значений параметров.
      VBScript, VBA | LValue = executeMethod("TObject", "Round", Array(10.24, 1))
      JScript | LValue = executeMethod("TObject", "Round", new Array(10.24, 1));
      Object Pascal | LValue := executeMethod('TObject', 'Round', VarArrayOf([10.24, 1]));
    • Для методов экземпляра без параметров значение Params есть идентификатор объекта, для которого вызывается метод.
    • Для методов экземпляра, имеющих параметры, значение Params есть массив значений параметров. При этом первым элементом массива является идентификатор объекта, для которого вызывается метод.
      VBScript, VBA | executeMethod "TObject", "MergeTo", Array(LOldObject, LNewObject)
      JScript | executeMethod("TObject", "MergeTo", new Array(LOldObject, LNewObject));
      Object Pascal | executeMethod('TObject', 'MergeTo', VarArrayOf([LOldObject, LNewObject]));
  • Функция executeReport осуществляет вызов отчета с параметрами. Имя класса передается в параметре ClassName, имя вызываемого метода - в параметре TemplateName. Параметры вызова передаются в параметре Params аналогично вызову executeMethod. В результате вызова функции возвращается ссылка на рабочую книгу Microsoft Excel, документ Microsoft Word и так далее. Судьба приложения, в рамках которого создан возвращенный объект, остается на усмотрение вызывающей стороны. Если вызывающая сторона предполагает взаимодействие объекта с пользователем, то необходимо обеспечить видимость объекта-приложения (Application.Visible := True;). В противном случае необходимо закрыть приложение после освобождения объекта документа (Application.Quit).
  • Функция getPropValue возвращает значение свойства объекта. Имя класса, имя свойства и идентификатор объекта задаются в параметрах.
  • Процедура setPropValue устанавливает значение свойства объекта в значение, заданное параметром Value. Для очистки значения можно использовать пустую строку или значение Null. Имя класса, имя свойства и идентификатор объекта задаются в параметрах.
  • Функция select возвращает ссылку на XML-документ, содержащий в корневом элементе элементы, представляющие собой записи набора данных на основе класса ClassName (с полями, разнесенными по элементам), определяемого структурой параметра QueryItems.
  • Функция enumerationItem возвращает идентификатор элемента перечисления по имени.
    VBScript, VBA | LItemID = enumerationItem("rsReplicatableMetadata")
    JScript | LItemID = enumerationItem("rsReplicatableMetadata");
    Object Pascal | LItemID := enumerationItem('rsReplicatableMetadata');
  • Функция getClass возвращает идентификатор объекта типа Класс TClass (Классы) по имени.
    VBScript, VBA | LClassID = getClass("TDocumentType")
    JScript | LClassID = getClass("TDocumentType");
    Object Pascal | LClassID := getClass('TDocumentType');
  • функция createGUID является оберткой над функцией Windows API CoCreateGuid. Возвращает сгенерированный глобально-уникальный идентификатор, преобразованный в строку.
  • процедура processStart информирует систему о необходимости показать окно выполнения длительного процесса. Текст, описывающий процесс (он появляется в показываемом окне) задается параметром Description. В случае, если есть возможность определить количество "шагов" процесса, то это количество необходимо передать в параметре ItemCount. В случае, если параметр ItemCount больше нуля, окно выполнения будет снабжено индикатором прогресса. Если значение ItemCount равно нулю, то окно появится без индикатора прогресса. Если значение ItemCount меньше нуля, то решение о появлении окна будет принято системой самостоятельно на основании загрузки процессора и окно процесса не появится, если процесс завершится достаточно быстро.
  • процедура processStep информирует систему о завершении очередного "шага" процесса, что найдет отражение в индикаторе прогресса окна выполнения длительного процесса, если таковые случатся.
  • процедура processStop информирует систему о завершении длительного процесса, что приведет к закрытию окна выполнения длительного процесса, если таковое случится.
  • функция PlaceDataSet осуществляет перенос данных из набора, задаваемого параметром DataSet в некоторое место документа Microsoft Office. Место назначения определяется параметром Range следующим образом:
    Microsoft Word
    • Объект Range. По месту расположения этого объекта будет создана таблица (Table), в которой будут размещены данные из набора.
      PlaceDataSet ThisDocument.Bookmarks("BookMarkName").Range, LDataSet
      PlaceDataSet Selection.Range, LDataSet
    • Объект Document. В самом начале переданного документа будет создана таблица (Table), в которой будут размещены данные из набора.
      PlaceDataSet ThisDocument, LDataSet
    Microsoft Excel
    • Объект Range. По месту расположения этого объекта (диапазона) будут размещены данные из набора. Если параметр ShiftRows задан и равен True, то заданный диапазон будет расширен вниз на необходимое количество строк, и информация, лежащая ниже переданного диапазона, будет по-прежнему лежать ниже. Если нет, то она (скорее всего) будет затёрта данными набора. Если параметр ShiftColumns задан и равен True, то этот диапазон будет расширен вправо на необходимое количество столбцов, и информация, лежащая правее переданного диапазона, будет по-прежнему лежать правее. Если нет, то она (скорее всего) будет затёрта данными набора.
      PlaceDataSet Range("C4"), LDataSet
    • Объект WorkSheet. На переданном листе будут размещены данные из набора.
      PlaceDataSet WorkSheets("HiddenSheet"), LDataSet
    Функция возвращает количество размещенных записей.
  • процедура DebugString выводит переданную в качестве аргумента строку в отладочный монитор.
  • процедура ExportObject осуществляет экспорт информации об объекте, задаваемом параметром ID в XML-документ, передаваемый в параметре Document. Если объект документа не был создан, то он создается автоматически. Если документ не имеет корневого узла, он будет создан автоматически.
    01set LDataSet = CreateDataSet("TSecurityAccount")
02
03LDataSet.AddQueryItem qpWhat, "ID"
04
05set LDocument = CreateObject("Msxml2.DOMDocument.4.0") 'Не обязательно.
06
07while not LDataSet.Eof
08  ExportObject LDocument, LDataSet.Field("ID")
09  LDataSet.Next
10wend
11
12LDocument.save "c:\RolesAndUsers.xml"
  • Функция callRoutine осуществляет вызов подпрограммы. Параметры будут запрошены у пользователя обычным порядком (с показом формы задания параметров, отработки ее скрипта и т. д.). Имя класса передается в параметре ClassName, имя вызываемой подпрограммы - в параметре RoutineName. Если пользователь разрешил выполнение подпрограммы (либо для выполнения не требовалось разрешения пользователя), функция вернет True, иначе False. Значение, возвращаемое подпрограммой, может быть возвращено через необязательный параметр RetValue. Через значение необязательного параметра ScriptPart можно передать скрипт на языке VBScript, который будет "приклеен" сверху к скрипту формы параметров вызываемой подпрограммы.
  • Функция getOleObject возвращает ссылку на Ole-объект с идентификатором класса, переданном в параметре ClassID. Объект создается на основе библиотеки кода, сохраненной в доступном файле с именем, заданным параметром AccessibleFileName. Регистр символов имени доступного файла важен.
  • Функция getResource возвращает значение ресурсной строки по имени ресурса (элемента перечислимого домена Resource strings или перевода (объекта класса TLanguageTranslation).
    MsgBox getResource("rssMyErrorMessage")
  • Функция getTempFileName возвращает сгенерированное системой имя временного файла с расширением, переданным в параметре Extension.
  • Функция selectVaue позволяет пользователю выбрать значение на основе ссылочного домена, имя которого передается в параметре ClassDomain. Вызывающая сторона может реализовать интерфейс IContextExpressionInfo, через который передается информация о контексте вызова для интерпретации выражений условий отбора, и передать ссылку на него через параметр ExpressionContext. Выбранное значение передается в обе стороны через параметр Value. Если пользователь подтвердил выбор значения, функция возвращает значение True, и устанавливает значение параметра Value, равное идентификатору выбранного пользователем объекта. Если пользователь отказался от выбора, функция возвращает значение False.
  • Процедура raiseManagedException возбуждает управляемую исключительную ситуацию с сообщением для пользователя, заданным параметром ExceptionMessage.
  • Функция getCRC возвращает шестнадцатиричное представление контрольной суммы переданных в параметре Data данных. Параметр может быть
    • Объектом, реализующим интерфейс IBinaryData
    • Объектом, реализующим интерфейс IStream
    • Объектом, реализующим интерфейс ISequentialStream
    • Объектом, реализующим интерфейс IFile объектной модели FileSystemObject
    • Строкой данных. Строка будет преобразована в байты в соответствии с кодировкой UTF-8.
  • Функция downloadData осуществляет обращение к указанному ресурсу по протоколу http (https), и возвращает ответ сервера в виде объекта, реализующего интерфейс IBinaryData. Параметр Host определяет http-сервер, параметр Url - Url, к которому будет происходить обращение. Параметры UserName и Password определяют имя пользователя и пароль, если http-сервер требует авторизовать пользователя. Параметр NegotiateAuth устанавливает режим аутентификации. (Basic или Negotiate). Параметры PostData, PostContentType и PostDataIsBinary определяют содержимое тела POST-запроса (если не определено, функция отправит GET-запрос). Параметр CanCache позволяет использовать локальный кеш http-ответов. Параметр NewSession требует принудительного создания новой сессии при вызове функции. Параметр TimeOut определяет максимальное время ожидания ответа в секундах.
  • Функция createBinaryData создает пустой объект, реализующий интерфейс IBinaryData.
  • Функция BinaryToBitmap конвертирует переданный графический файл в формат BMP. Объекты во входном и выходном параметрах должны реализовывать интерфейс IBinaryData.
  • Функция editValues создает и показывает форму редактирования группы значений. Параметр ValuesList содержит идентификатор объекта класса TObjectList. Этот список содержит ссылки на редактируемые значения (объекты класса TTypedValue), и командные кнопки формы (объекты класса TTypedValueButton). Параметр Title определяет заголовок формы, параметр UseTabs определяет, будут ли показаны закладки на форме редактирования. Параметр HideOKButton позволяет скрыть кнопку "OK" на показываемой форме. Параметр ScriptPart определяет скрипт показываемой формы.

    01  LValue1 = executeMethod ("TTypedValue", "CreateStrValue", _
02    Array("Value1", "Первый параметр", Null, Null, _
03    "TLongString", Null, Null, Null, Null, Null, "Значение по  умолчанию первого параметра"))
04  LValue2 = executeMethod ("TTypedValue", "CreateStrValue", _
05    Array("Value2", "Второй параметр", Null, Null, _
06    "TLongString", Null, Null, Null, Null, Null, "Значение по  умолчанию второго параметра"))
07
08  LValues = executeMethod("TObjectList", "CreateFromString", _
09    LValue1 & ";" & LValue2)
10
11  if editValues(LValues, "Введите два строковых значения, друзья", True, False, "") then
12    MsgBox getPropValue("TTypedValue", "StrValue", LValue1) & _
13      " " & _
14      getPropValue("TTypedValue", "StrValue", LValue2)
15  end if
16
17  executeMethod "TObject", "Destroy", LValues
18  executeMethod "TObject", "Destroy", LValue1
19  executeMethod "TObject", "Destroy", LValue2

    01  LScriptPart =  "Buttons(""NextButton"").Enabled = ParentForm.NavigatorCanNext" & Chr(10) & _
02    "Buttons(""PrevButton"").Enabled = ParentForm.NavigatorCanPrevious"
03
04  LValue1 = executeMethod ("TTypedValue", "CreateStrValue", _
05    Array("Value1", "Первый параметр", Null, Null, "TLongString", Null, Null, Null, Null, Null, _
06    "Значение по  умолчанию первого параметра"))
07  LValue2 = executeMethod ("TTypedValue", "CreateStrValue", _
08    Array("Value2", "Второй параметр", Null, Null, "TLongString", Null, Null, Null, Null, Null, _
09    "Значение по  умолчанию второго параметра"))
10
11  LNextButton = executeMethod ("TTypedValueButton", "Create", Array("NextButton", "Вперед!", _
12    Null, Null, Null, Null, 0, Null, Null, _
13    "ParentForm.NavigatorNext"  & Chr(10) & LScriptPart, enumerationItem("scPublic"), 1, Null))
14
15  LPrevButton = executeMethod ("TTypedValueButton", "Create", Array("PrevButton", "Назад!", _
16    Null, Null, Null, Null, 1, Null, Null, _
17    "ParentForm.NavigatorPrevious" & Chr(10) & LScriptPart, enumerationItem("scPublic"), 1, Null))
18
19  LValues = executeMethod("TObjectList", "CreateFromString", _
20    LValue1 & ";" & LValue2 & ";" & LNextButton & ";" & LPrevButton)
21
22  if editValues(LValues, "Введите два строковых значения, друзья", True, True, LScriptPart) then
23    MsgBox getPropValue("TTypedValue", "StrValue", LValue1) & _
24      " " & _
25      getPropValue("TTypedValue", "StrValue", LValue2)
26  end if
27
28  executeMethod "TObject", "Destroy", LValues
29  executeMethod "TObject", "Destroy", LValue1
30  executeMethod "TObject", "Destroy", LValue2
31  executeMethod "TObject", "Destroy", LNextButton
32  executeMethod "TObject", "Destroy", LPrevButton

  • Функции MsgBox и ShowMsgBox (это синонимы одной точки входа) полностью аналогичны функции Basic MsgBox по поведению и набору параметров.
  • Функция buildNamedFile формирует значение типа "Именованный файл" на основе объекта, реализующего интерфейс IBinaryData (параметр Data) и информации об имени и параметрах именованного файла.
  • Процедура parseNamedFile разбирает значение типа "Именованный файл". Выходной параметр FileName будет содержать сохраненное имя файла, выходной параметр Data - объект, реализующего интерфейс IBinaryData и содержащий данные именованного файла.
  • Свойство ContextObject позволяет получить ссылку на этот же самый контекстный объект.
  • Свойство UserName позволяет получить логин текущего пользователя.
  • Свойство NegotiateAuth позволяет получить признак доменной аутентификации пользователя.
  • Свойство Language позволяет получать и устанавливать текущий языковой контекст, в котором будут выполняться обращения к БД. Значение свойства либо пустая строка (используется язык БД по умолчанию), либо имя объекта класса TLanguage
  • Свойство Variable позволяет сохранять и получать произвольные значения, которые могут хранится постоянно (в реестре) или только в текущем сеансе, в зависимости от параметра Persistent.
    1'сохранить на время текущего сеанса значение в переменную с именем SameVariableName
2Variable("SameVariableName", False) = "Value"
3
4'получить значение переменной с именем SameVariableName хранимой в текущем сеансе
5LValue = Variable("SameVariableName", False)
  • Процедура showView осуществляет показ в модальном окне представления с именем ViewName. С помощью параметров DetailPropertyName и Key можно наложить на представление дополнительное условие отбора.

2. Интерфейс IContextDataSet
01  IContextDataSet = interface(IDispatch)
02    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
03    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
04      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant);
05    function Eof: WordBool;
06    function Field(const Name: WideString): OleVariant;
07    function FieldCount: Integer;
08    function FieldName(Index: Integer): WideString;
09    procedure Next;
10  end;

Интерфейс предоставляет возможности формирования и выполнения запросов к базе данных с целью получения свойств объектов определенного класса, предоставляет доступ к объекту набора данных. Работа с объектом, реализующим интерфейс IContextDataSet заключается в формировании структуры набора данных и последующих обращениях к ним.

  • Процедура AddQueryItem добавляет элемент набора данных. Элементы могут добавляться в любом порядке до первого обращения к данным набора. Символические имена всех предопределенных для параметров этого метода констант являются членами интерфейса IConstants.
    • часть запроса определяется параметром Part, который может принимать одно из следующих предопределенных значений:
      Символическое имя | Числовое значение | Описание
      qpWhat | 0 | Добавляет поле (столбец), определяемое параметром Name, к результирующему набору данных. Параметр Value игнорируется.
      qpWhere | 1 | Определяет условие, налагаемое на свойства объектов класса, передаваемое остальными параметрами.
      qpOrder | 2 | Определяет порядок сортировки записей результирующего набора данных. Параметр Value игнорируется.
      qpGroup | 3 | Определяет, что записи результирующего набора данных будут сгруппированы по столбцу, переданному в параметре Name. Параметры Value и Special игнорируются.
    • параметр Name должен быть именем свойства класса, на котором основан набор данных, либо зарезервированным словом "ID" (без кавычек).
    • параметр Value (необязательный) определяет условия отбора, накладываемые на свойство, заданное параметром Name. Имеет смысл только если значение параметра Part равно qpWhere. Условие задается посредством строки, интерпретируемой следующим образом:
      • строка разделяется на части посредством системного разделителя
      • каждая часть интерпретируется самостоятельно, и эти части объединяются логическим "ИЛИ"
      • при интерпретации каждой части проверяются следующие условия:
        * проверка значения на непустоту (IS NOT NULL)
        !* проверка значения на пустоту (IS NULL)
        начинается с символов
        '<=', '<', '>=', '>'         		проверка соответствующего отношения между значением свойства, переданного параметром Name и оставшейся частью строки
        включает в себя символы '*' и/или '?' | проверка соответствия значения шаблону, в котором знак '?' соответствует одному любому символу, а знак '*' - любому количеству любых символов
        начинается с символа '!' | символ '!' означает отрицание условия, переданного оставшейся частью строки
        представляет собой строку в апострофах (одиночных кавычках) | содержание строки не анализируется по приведенным выше условиям
        любая другая строка | проверка равенства значения свойства, переданного параметром Name значению, переданному строкой
    • параметр Special (необязательный) обеспечивает дополнительное поведение набора данных (если параметр Special используется, необходимо использовать и параметр Value, можно передавать пустую строку):
      Символическое имя | Числовое значение | Описание
      qsNone | 0 | Параметр не используется. Значение по умолчанию.
      qsDescending | 7 | Используется при значении qpOrder параметра Part. В этом случае производится сортировка по убыванию.
      qsCount | 8 | Используется при значении qpWhat параметра Part. Определяют тип агрегации по свойству, заданному параметром Name.
      qsSum | 9
      qsMin | 10
      qsMax | 11
      qsAverage | 12
      qsFunction | 22 | Используется для включения в запрос вызова функции. Используется при значении qpWhat параметра Part.
    • параметр Context (необязательный) определяет дополнительные параметры элемента запроса.
    01'включить в набор данных свойство Name
02LDataSet.AddQueryItem 0, "Name"
03'включить в набор данных среднее значение цены
04LDataSet.AddQueryItem 0, "Price", "", 12
05'включить в набор данных идентификатор объекта
06LDataSet.AddQueryItem 0, "ID"
07'включить в набор данных вызов функции. В поле IsCompany будет значение True, если объект является организацией
08LDataSet.AddQueryItem 0, "IsCompany", "TObject.IsInstanceOf", 22, Array(getClass("TCompany"))
09'наложить на набор данных условие
10LDataSet.AddQueryItem 1, "Organization", "фирма Елочка"

    1LDataSet.AddQueryItem 0, "Organization"              '(1)
2LDataSet.AddQueryItem 0, "SalesCount", "", "9"       '(2)
3LDataSet.AddQueryItem 1, "SaleDate", ">10.09.2005"   '(3)
4LDataSet.AddQueryItem 2, "Organization"              '(4)
5LDataSet.AddQueryItem 3, "Organization"              '(5)
    Производится отбор из класса, описывающего число продаж некоего продукта различными организациями. При этом в набор данных включаются колонки "Organization" (строка 1) и "SalesCount" (строка 2). При этом будет произведена группировка по свойству "Organization" (строка 5) (что гарантирует вхождение каждой организации в результирующий набор данных не более одного раза). Набор данных будет отсортирован по организации (строка 4). При этом в колонке "SalesCount" будет сумма (строка 2) всех продаж, осуществленных каждой организацией после 10.09.2005 (строка 3).
  • Функция FieldCount возвращает количество полей (столбцов) набора данных.
  • Функция FieldName возвращает имя поля (столбца) с номером, переданным в параметре Index.
  • Функция Field возвращает значение, содержащееся в поле с именем или индексом, заданным параметром Name (строкового типа) текущей записи набора данных. При первом обращении к набору данных текущей является первая запись. Если параметр определяет номер, то поиск поля производится по номеру. Если имя, то по имени.
  • Процедура Next осуществляет переход к следующей записи набора данных.
  • Функция Eof возвращает False, если текущая запись набора данных существует; в случаях, если набор данных пустой, или при помощи метода Next достигнут конец набора данных, возвращает True.
    01If LDataSet.Eof then
02  'набор данных пуст. Ничего не отобрано.
03Else
04  While Not LDataSet.Eof
05    'работа с очередной отобранной записью
06    Cells(LRow, 1).Value = LDataSet.Field("Name")
07    Cells(LRow, 2).Value = LDataSet.Field("Description")
08    Cells(LRow, 2).Value = LDataSet.Field("Count")
09    'переход к следующей записи
10    LDataSet.Next
11    LRow = LRow + 1
12  Wend
13End If

3. Интерфейс IConstants
01  IConstants = interface(IDispatch)
02    ['{7E7B2D66-5E7C-496A-AE06-EFC485007500}']
03    property qpWhat: Integer;
04    property qpWhere: Integer;
05    property qpOrder: Integer;
06    property qpGroup: Integer;
07    property qpHaving: Integer;
08    property qsNone: Integer;
09    property qsObjectID: Integer;
10    property qsParentID: Integer;
11    property qsHasChildren: Integer;
12    property qsFilterCondition: Integer;
13    property qsUplink: Integer;
14    property qsRootOnly: Integer;
15    property qsDescending: Integer;
16    property qsCount: Integer;
17    property qsSum: Integer;
18    property qsMin: Integer;
19    property qsMax: Integer;
20    property qsAverage: Integer;
21    property qsMasterLink: Integer;
22    property qsSelectedOnly: Integer;
23  end;

Интерфейс предоставляет символические имена констант, необходимых для работы с объектом, реализующим интерфейс IContextDataSet.

Свойство | Значение
qpWhat | 0
qpWhere | 1
qpOrder | 2
qpGroup | 3
qpHaving | 4
qsNone | 0
qsObjectID | 1
qsParentID | 2
qsHasChildren | 3
qsFilterCondition | 4
qsUplink | 5
qsRootOnly | 6
qsDescending | 7
qsCount | 8
qsSum | 9
qsMin | 10
qsMax | 11
qsAverage | 12
qsMasterLink | 13
qsSelectedOnly | 14

4. Интерфейс IFormContext
01  IFormContext = interface(IDispatch)
02    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
03    function ChangedControl: OleVariant;
04    function ControlCount: Integer;
05    function ButtonCount: Integer;
06    function ID: WideString;
07    procedure Cancel;
08    function ControlExists(const Name: WideString): WordBool;
09    function ChangedControlName: WideString;
10    function ParentForm: OleVariant;
11    function RoutineID: WideString;
12    procedure PreInitControl(const Name: WideString; Value: OleVariant);
13    procedure NavigatorNext;
14    procedure NavigatorPrevious;
15    function NavigatorCanNext: WordBool;
16    function NavigatorCanPrevious: WordBool;
17    procedure RefreshView(RefreshAll: WordBool);
18    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
19    property Controls[Name: OleVariant]: IControl;
20    property Buttons[Name: OleVariant]: IButton;
21    property Enabled: WordBool;
22  end;

Представляет собой модель формы задания параметров. Члены интерфейса доступны для использования в скриптах форм задания параметров.

  • Функция ChangedControl возвращает объект, реализующий интерфейс IControl, соответствующий элементу управления, изменение которого вызвало исполнение скрипта формы параметров. Если выполнение скрипта вызвано инициализацией формы задания параметров, то значение функции - Empty. Пустоту значения можно проверить с помощью функции VBScript IsEmpty.
  • Функция ControlCount возвращает число элементов управления на форме параметров, как видимых так и невидимых.
  • Функция ButtonCount возвращает число командных кнопок на форме параметров, как видимых так и невидимых.
  • Функция ID возвращает значение идентификатора объекта, для которого вызван метод. Для методов класса возвращает пустое значение.
  • Функция ControlExists возвращает True, если элемент управления с именем Name существует на форме, и, соответственно, существует соответствующий параметр.
  • Функция ChangedControlName возвращает имя элемента управления, изменение которого вызвало исполнение скрипта формы параметров. Если выполнение скрипта вызвано инициализацией формы задания параметров, то значение функции - пустая строка.
  • Процедура Cancel прекращет работу формы задания параметров. Форма закрывается, выполнение действия блокируется.
  • Функция ParentForm возвращает ссылку на контекст родительской формы в цепочке вызовов. В контексте первой формы (вызванной с грида немодальной формы) возвращает пустое значение (Empty). Пустоту значения можно проверить с помощью функции VBScript IsEmpty.
  • Функция RoutineID возвращает идентификатор подпрограммы, для которой вызвана форма.
  • Процедура PreInitControl имитирует предварительную инициализацию элемента управления с именем Name значением, переданным в параметре Value. Сам элемент управления при этом будет скрыт, и не будет показан вплоть до следующего вызова формы пользователем.
  • Процедура NavigatorNext выполняет переход к следующему объекту набора данных, для которого показывается форма параметров.
  • Процедура NavigatorPrevious выполняет переход к предыдущему объекту набора данных, для которого показывается форма параметров.
  • Функция NavigatorCanNext возвращает True, если возможен переход к следующему объекту набора данных, для которого показывается форма параметров.
  • Функция NavigatorCanPrevious возвращает True, если возможен переход к предыдущему объекту набора данных, для которого показывается форма параметров.
  • Процедура RefreshView обновляет набор данных, для которого показывается форма параметров. Если значение параметра RefreshAll равно True, то будет обновлен весь набор, если False, то только выделенные записи.
  • Свойство Controls позволяет обращаться к элементам управления на форме задания параметров, их свойствам и методам. Каждый элемент управления реализует интерфейс IControl. В параметре Name (строкового типа)может быть передано как имя элемента управления, так и его индекс (в этом случае индекс должен быть передан как строка). Имена элементов управления на форме параметров соответствуют именам параметров подпрограммы (метода, отчета, etc).
  • Свойство Buttons позволяет обращаться к командным кнопкам на форме задания параметров, их свойствам и методам. Каждая командная кнопка реализует интерфейс IButton. В параметре Name (строкового типа)может быть передано как имя командной кнопки, так и ее индекс (в этом случае индекс должен быть передан как строка).
  • Свойство Enabled позволяет получать и устанавливать доступность кнопки OK на форме задания параметров. Если на форме есть невалидные (имеющие недопустимые значения) элементы управления, значение свойства всегда равно False и устанавливать его в явном виде в True не рекомендуется. Для учета дополнительного условия рекомендуется использовать следующую конструкцию: Enabled = Enabled and (Controls("SalesCount").Value > 10)
  • Функция ExpressionContextValue возвращает значение переменной контекста с именем Name, которая используется для интeрпретации выражений условий отбора на форме.

5. Интерфейс IControl
01  IControl = interface(IDispatch)
02    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
03    function Name: WideString;
04    procedure SetHint(const Value: WideString);
05    procedure RefreshLinkedView;
06    property Value: OleVariant;
07    property ReadOnly: WordBool;
08    property IsValid: WordBool;
09    property IsEmpty: WordBool;
10  end;

Моделирует элемент управления на форме задания параметров. Позволяет управлять поведением элементов управления на форме.

  • Функция Name возвращает имя элемента управления; имена элементов управления всегда совпадают с именамим соответствующих параметров подпрограммы.
  • Процедура SetHint устанавливает текст всплывающей подсказки элемента управления. Всплывыющая подсказка показывается только если значение элемента управления недопустимо (свойство IsValid равно False).
  • Процедура RefreshLinkedView обновит связанное с элементом управления представление.
  • Свойство Value позволяет получать и устанавливать значение, введенное в элемент управления.
  • Свойство ReadOnly позволяет получать и устанавливать доступность элемента управления для записи; при значении True элемент управления не доступен для записи и отображается неактивным.
  • Свойство IsValid позволяет получать и устанавливать "валидность" элемента управления; по умолчанию валидным элемент управления является в том случае, если введенное в него значение соответствует домену соответствующего параметра подпрограммы с учетом наложенного на него условия отбора.
  • Свойство IsEmpty имеет значение True в случае, если в элемент управления не введено никакого значения (элемент управления пустой), в противном случае имеет значение False.

6. Интерфейс IButton
1  IButton = interface(IDispatch)
2    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
3    function Name: WideString; safecall;
4    procedure Click; safecall;
5    property Enabled: WordBool;
6  end;

Моделирует командную кнопку на форме задания параметров. Позволяет управлять поведением кнопки на форме.

  • Функция Name возвращает имя кнопки.
  • Процедура Click эмулирует нажатие на кнопку.
  • Свойство Enabled позволяет получать и устанавливать доступность кнопки.

7. Интерфейс IBinaryData
01  IBinaryData = interface(IDispatch)
02    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
03    procedure Load(const Src: OleVariant);
04    procedure Append(const Src: OleVariant);
05    procedure Save(const Dst: OleVariant);
06    function Size: Cardinal;
07    function ToString(Encoding: WideString): WideString;
08    procedure FromString(Data: OleVariant);
09    procedure AppendString(Data: OleVariant);
10    function ToBase64: WideString;
11    procedure FromBase64(Data: OleVariant);

Представляет набор двоичных данных.

  • Процедура Load загружает двоичные данные из переданного источника. Источник может быть
    • Объектом, реализующим интерфейс IStream
    • Объектом, реализующим интерфейс ISequentialStream
    • Строкой, содержащей имя файла
  • Процедура Append добавляет двоичные данные из переданного источника. Источник может быть
    • Объектом, реализующим интерфейс IStream
    • Объектом, реализующим интерфейс ISequentialStream
    • Строкой, содержащей имя файла
  • Процедура Save сохраняет двоичные данные в переданный приемник. Приемник может быть
    • Объектом, реализующим интерфейс IStream
    • Объектом, реализующим интерфейс ISequentialStream
    • Строкой, содержащей имя файла
  • Функция ToString переводит данные в строку. Байты, содержашиеся в объекте, будут рассматриваться как содержащие строку в кодировке, заданной параметром Encoding. По умолчанию используется кодировка UTF-8
  • Процедура FromString загружает данные из строки, переданной в параметре Data, перекодировав ее в кодировку UTF-8
  • Процедура AppendString добавляет данные из строки, переданной в параметре Data, перекодировав ее в кодировку UTF-8
  • Функция ToBase64 возвращает строку, полученную путем кодирования в формат Base64, данных содержащихся в объекте
  • Процедура FromBase64 загружает данные из строки, переданной в параметре Data, раскодировав ее из формата Base64

8. Интерфейс IContextExpressionInfo
1  IContextExpressionInfo = interface(IUnknown)
2    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
3    function Count: Integer;
4    function ItemName(Index: Integer): WideString;
5    function ItemValue(Index: Integer): OleVariant;
6    function ItemDomain(Index: Integer): OleVariant;
7  end;

Через реализацию этого интерфейса передаются значения контекстных переменных при обращении к функции selectValue интерфейса IContext.

  • Функция Count возвращает количество используемых контекстных переменных. Нумерация контекстных переменных начинается с нуля.
  • Функция ItemName возвращает имя контекстной переменной c номером, переданным в параметре Index.
  • Функция ItemValue возвращает значение контекстной переменной c номером, переданным в параметре Index.
  • Функция ItemDomain возвращает имя домена контекстной переменной c номером, переданным в параметре Index.

9. Интерфейс IExceptionHandler
1  IExceptionHandler = interface(IDispatch)
2    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
3    procedure HandleException(ContextObject: OleVariant;
4      const Message: WideString;
5      const ExtentedInfo: WideString);
6  end;

Реализовав интерфейс IExceptionHandler разработчик решений может получать уведомления о возникающих при работе исключительных ситуациях. При возникновении исключения объект, реализующий интерфейс, получит текст сообщения об ошибке и расширенную информацию.

Для реализации интерфеса используется библиотека hse.tlb, входящая в состав поставки решения. Перед началом работы с ней, необходимо зарегистрировать ее в операционной системе.

Для установки настроек интерфейса необходимо открыть Системную форму раздела АДМИНИСТРАТОРУ, перейти на вкладку Настройки и в столбце "Заголовок закладки" установить фильтр "Обработка ошибок".

После этого в качестве значения Идентификатора класса установить "IExceptionHandler" без кавычек.

Для Библиотеки кода указать значение HSE.tlb

10. Справочник по интерфейсам

10.1. Перечисление TQueryPart
1type
2  TQueryPart = (qpWhat, qpWhere, qpOrder, qpGroup, qpHaving, qpInnerJoin,
3    qpOuterJoin);

Или

01type
02  TQueryPart = TOleEnum;
03const
04  qpWhat = $00000000;
05  qpWhere = $00000001;
06  qpOrder = $00000002;
07  qpGroup = $00000003;
08  qpHaving = $00000004;
09  qpInnerJoin = $00000005;
10  qpOuterJoin = $00000006;

Элементы перечисления:

Имя | Значение | Назначение
qpWhat | 0 |
qpWhere | 1 |
qpOrder | 2 |
qpGroup | 3 |
qpHaving | 4 |
qpInnerJoin | 5 |
qpOuterJoin | 6 |

10.2. Перечисление TQuerySpecial
1type
2  TQuerySpecial = (qsNone, qsObjectID, qsParentID, qsHasChildren,
3    qsFilterCondition, qsUplink, qsRootOnly, qsDescending, qsCount, qsSum, qsMin,
4    qsMax, qsAverage, qsMasterLink, qsSelectedOnly, qsDistinct, qsViewCondition,
5    qsCaseInsensitive, qsAsString, qsListed, qsName, qsDescription, qsFunction,
6    qsCountDistinct, qsBoolean, qsExact, qsSearchIndex, qsOptimizationParameters);

Или

01type
02  TQuerySpecial = TOleEnum;
03const
04  qsNone = $00000000;
05  qsObjectID = $00000001;
06  qsParentID = $00000002;
07  qsHasChildren = $00000003;
08  qsFilterCondition = $00000004;
09  qsUplink = $00000005;
10  qsRootOnly = $00000006;
11  qsDescending = $00000007;
12  qsCount = $00000008;
13  qsSum = $00000009;
14  qsMin = $0000000A;
15  qsMax = $0000000B;
16  qsAverage = $0000000C;
17  qsMasterLink = $0000000D;
18  qsSelectedOnly = $0000000E;
19  qsDistinct = $0000000F;
20  qsViewCondition = $00000010;
21  qsCaseInsensitive = $00000011;
22  qsAsString = $00000012;
23  qsListed = $00000013;
24  qsName = $00000014;
25  qsDescription = $00000015;
26  qsFunction = $00000016;
27  qsCountDistinct = $00000017;
28  qsBoolean = $00000018;
29  qsExact = $00000019;
30  qsSearchIndex = $0000001A;
31  qsOptimizationParameters = $0000001B;

Элементы перечисления:

Имя | Значение | Назначение
qsNone | 0 |
qsObjectID | 1 |
qsParentID | 2 |
qsHasChildren | 3 |
qsFilterCondition | 4 |
qsUplink | 5 |
qsRootOnly | 6 |
qsDescending | 7 |
qsCount | 8 |
qsSum | 9 |
qsMin | 10 |
qsMax | 11 |
qsAverage | 12 |
qsMasterLink | 13 |
qsSelectedOnly | 14 |
qsDistinct | 15 |
qsViewCondition | 16 |
qsCaseInsensitive | 17 |
qsAsString | 18 |
qsListed | 19 |
qsName | 20 |
qsDescription | 21 |
qsFunction | 22 |
qsCountDistinct | 23 |
qsBoolean | 24 |
qsExact | 25 |
qsSearchIndex | 26 |
qsOptimizationParameters | 27 |

10.3. Интерфейс IButton

1type
2  IButton = interface(IDispatch)
3    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
4    function Get_Enabled: WordBool; safecall;
5    procedure Set_Enabled(Value: WordBool); safecall;
6    function Name: WideString; safecall;
7    procedure Click; safecall;
8    property Enabled: WordBool read Get_Enabled write Set_Enabled;
9  end;

10.3.1. Свойства

Свойства интерфейса IButton:

Имя | Тип | Доступ | Назначение
Enabled | WordBool | Чтение/Запись |

10.3.2. Метод Click

Метод интерфейса IButton.

procedure IButton.Click;

Метод не имеет параметров.

10.3.3. Метод Name

Метод интерфейса IButton.

function IButton.Name: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10.4. Интерфейс IContext

001type
002  IContext = interface(IDispatch)
003    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
004    function Get_ContextObject: IDispatch; safecall;
005    function Get_UserName: WideString; safecall;
006    function Get_NegotiateAuth: WordBool; safecall;
007    function Get_Language: WideString; safecall;
008    procedure Set_Language(Value: WideString); safecall;
009    function Get_TimeBias: Double; safecall;
010    function getName(ID: OleVariant): WideString; safecall;
011    function getDescription(ID: OleVariant): WideString; safecall;
012    function getPropValue(const ClassName: WideString; const PropName: WideString;
013      ID: OleVariant): OleVariant; safecall;
014    procedure setPropValue(const ClassName: WideString; const PropName: WideString;
015      ID: OleVariant; Value: OleVariant); safecall;
016    procedure getPropValues(const ClassName: WideString;
017      const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
018      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
019    procedure setPropValues(const ClassName: WideString;
020      const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
021      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
022    function createDataSet(const TargetClassName: WideString): IContextDataSet; safecall;
023    function select(const ClassName: WideString; QueryItems: OleVariant): IDispatch; safecall;
024    function executeMethod(const ClassName: WideString;
025      const MethodName: WideString; Params: OleVariant): OleVariant; safecall;
026    function getClass(const ClassName: WideString): WideString; safecall;
027    function enumerationItem(ItemIdentifier: OleVariant): WideString; safecall;
028    function getResource(const Name: WideString): WideString; safecall;
029    function bulkInsert(const ClassName: WideString;
030      const Data: IDispatch): IContextDataSet; safecall;
031    function PreProcessScript(const Script: WideString; Indent: WordBool;
032      const CommentMark: WideString): WideString; safecall;
033    function executeReport(const ClassName: WideString;
034      const TemplateName: WideString; Params: OleVariant): IDispatch; safecall;
035    procedure saveReport(const ClassName: WideString;
036      const TemplateName: WideString; Params: OleVariant; const FileName: WideString); safecall;
037    function Get_Variable(const Name: WideString; Persistent: WordBool): OleVariant; safecall;
038    procedure Set_Variable(const Name: WideString; Persistent: WordBool;
039      Value: OleVariant); safecall;
040    function DebugString(const Message: WideString): WideString; safecall;
041    procedure raiseManagedException(const ExceptionMessage: WideString); safecall;
042    function createGUID: WideString; safecall;
043    function getTempFileName(const Extension: WideString): WideString; safecall;
044    function HasUI: WordBool; safecall;
045    function Handle: Integer; safecall;
046    procedure processStart(const Description: WideString; ItemCount: Integer;
047      CanAbort: WordBool); safecall;
048    function processStep: WordBool; safecall;
049    procedure processStop; safecall;
050    procedure Sleep(MSecs: Integer); safecall;
051    function executeConsoleProcess(const CommandLine: WideString;
052      MaxDuration: Integer; const OutputData: OleVariant): Integer; safecall;
053    function downloadData(const Host: WideString; const Url: WideString;
054      const UserName: WideString; const Password: WideString;
055      NegotiateAuth: WordBool; PostData: OleVariant;
056      const PostContentType: WideString; PostDataIsBinary: WordBool;
057      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant; safecall;
058    function LineBreak: WideString; safecall;
059    function Transliterate(const Value: WideString): WideString; safecall;
060    procedure CompareLists(var List1: OleVariant; var List2: OleVariant;
061      const Delimiter: WideString; CaseSensitive: WordBool); safecall;
062    function parseJSON(const JSON: WideString): WideString; safecall;
063    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch; safecall;
064    function createBinaryData: IDispatch; safecall;
065    function getCRC(Data: OleVariant): WideString; safecall;
066    function buildNamedFile(const Data: IDispatch;
067      const StoredFileName: WideString; Propmpt: WordBool;
068      Compress: WordBool): IDispatch; safecall;
069    procedure parseNamedFile(NamedFile: OleVariant; out FileName: OleVariant;
070      out Data: OleVariant); safecall;
071    function createRaster: IDispatch; safecall;
072    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
073    function getOleObject(const ClassID: WideString;
074      const AccessibleFileName: WideString): IDispatch; safecall;
075    function PlaceDataSet(const Range: IDispatch; const DataSet: IContextDataSet;
076      ShiftRows: WordBool; ShiftColumns: WordBool): Integer; safecall;
077    procedure ExportObject(var Document: OleVariant; const ID: WideString;
078      const ClassID: WideString); safecall;
079    function createZIPArchive: IDispatch; safecall;
080    function callRoutine(const ClassName: WideString;
081      const RoutineName: WideString; var RetValue: OleVariant;
082      const ScriptPart: OleVariant): WordBool; safecall;
083    function selectVaue(const ClassDomain: WideString;
084      const ExpressionContext: IUnknown; var Value: OleVariant): WordBool; safecall;
085    function editValues(const ValuesList: WideString; const Title: WideString;
086      UseTabs: WordBool; HideOKButton: WordBool;
087      const ScriptPart: OleVariant): WordBool; safecall;
088    function MsgBox(const Prompt: WideString; Buttons: LongWord;
089      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
090    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
091      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
092    procedure showView(const ViewName: WideString; Key: OleVariant;
093      const DetailPropertyName: WideString); safecall;
094    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
095      ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
096      TakeActionsFromView: OleVariant); safecall;
097    procedure SaveExternalDataToFolder(const Resource: WideString;
098      const Folder: WideString); safecall;
099    function PerformAsyncTask(ID: OleVariant): WordBool; safecall;
100    procedure RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
101      ThreadCount: Integer); safecall;
102    function MainHandle: Integer; safecall;
103    function IsHTMLDocumentSafe(const HTML: WideString): WordBool; safecall;
104    function EnsafeHTMLDocument(const HTML: WideString; RemoveHead: WordBool;
105      Format: WordBool; PureXML: WordBool): WideString; safecall;
106    property ContextObject: IDispatch read Get_ContextObject;
107    property UserName: WideString read Get_UserName;
108    property NegotiateAuth: WordBool read Get_NegotiateAuth;
109    property Language: WideString read Get_Language write Set_Language;
110    property TimeBias: Double read Get_TimeBias;
111    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant
112      read Get_Variable write Set_Variable;
113  end;

10.4.1. Свойства

Свойства интерфейса IContext:

Имя | Тип | Доступ | Назначение
ContextObject | IDispatch | Только для чтения |
Language | WideString | Чтение/Запись |
NegotiateAuth | WordBool | Только для чтения |
TimeBias | Double | Только для чтения |
UserName | WideString | Только для чтения |
Variable[const Name: WideString, Persistent: WordBool] | OleVariant | Чтение/Запись |

10.4.2. Метод BinaryToBitmap

Метод интерфейса IContext.

function IContext.BinaryToBitmap(const Data: IDispatch): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Data | IDispatch | Да |

Замечания:

Возвращает значение типа IDispatch.

10.4.3. Метод buildNamedFile

Метод интерфейса IContext.

1function IContext.buildNamedFile(const Data: IDispatch;
2  const StoredFileName: WideString; Propmpt: WordBool;
3  Compress: WordBool): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Data | IDispatch | Да |
StoredFileName | WideString | Да |
Propmpt | WordBool | Да |
Compress | WordBool | Да |

Замечания:

Возвращает значение типа IDispatch.

10.4.4. Метод bulkInsert

Метод интерфейса IContext.

1function IContext.bulkInsert(const ClassName: WideString;
2  const Data: IDispatch): IContextDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
Data | IDispatch | Да |

Замечания:

Возвращает значение типа IContextDataSet.

10.4.5. Метод callRoutine

Метод интерфейса IContext.

1function IContext.callRoutine(const ClassName: WideString;
2  const RoutineName: WideString; var RetValue: OleVariant;
3  const ScriptPart: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
RoutineName | WideString | Да |
RetValue | OleVariant | Нет |
ScriptPart | OleVariant | Нет |

Замечания:

Возвращает значение типа WordBool.

10.4.6. Метод CompareLists

Метод интерфейса IContext.

1procedure IContext.CompareLists(var List1: OleVariant; var List2: OleVariant;
2  const Delimiter: WideString; CaseSensitive: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
List1 | OleVariant | Да |
List2 | OleVariant | Да |
Delimiter | WideString | Да |
CaseSensitive | WordBool | Да |

10.4.7. Метод ConvertExcel

Метод интерфейса IContext.

1function IContext.ConvertExcel(Source: OleVariant;
2  const Format: WideString): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Source | OleVariant | Да |
Format | WideString | Да |

Замечания:

Возвращает значение типа IDispatch.

10.4.8. Метод createBinaryData

Метод интерфейса IContext.

function IContext.createBinaryData: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

10.4.9. Метод createDataSet

Метод интерфейса IContext.

function IContext.createDataSet(const TargetClassName: WideString): IContextDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
TargetClassName | WideString | Да |

Замечания:

Возвращает значение типа IContextDataSet.

10.4.10. Метод createGUID

Метод интерфейса IContext.

function IContext.createGUID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10.4.11. Метод createRaster

Метод интерфейса IContext.

function IContext.createRaster: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

10.4.12. Метод createZIPArchive

Метод интерфейса IContext.

function IContext.createZIPArchive: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

10.4.13. Метод DebugString

Метод интерфейса IContext.

function IContext.DebugString(const Message: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Message | WideString | Да |

Замечания:

Возвращает значение типа WideString.

10.4.14. Метод downloadData

Метод интерфейса IContext.

1function IContext.downloadData(const Host: WideString; const Url: WideString;
2  const UserName: WideString; const Password: WideString;
3  NegotiateAuth: WordBool; PostData: OleVariant;
4  const PostContentType: WideString; PostDataIsBinary: WordBool;
5  CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Host | WideString | Да |
Url | WideString | Да |
UserName | WideString | Да |
Password | WideString | Да |
NegotiateAuth | WordBool | Да |
PostData | OleVariant | Да |
PostContentType | WideString | Да |
PostDataIsBinary | WordBool | Да |
CanCache | WordBool | Да |
NewSession | WordBool | Да |
TimeOut | Integer | Да |

Замечания:

Возвращает значение типа OleVariant.

10.4.15. Метод editValues

Метод интерфейса IContext.

1function IContext.editValues(const ValuesList: WideString;
2  const Title: WideString; UseTabs: WordBool; HideOKButton: WordBool;
3  const ScriptPart: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ValuesList | WideString | Да |
Title | WideString | Да |
UseTabs | WordBool | Да |
HideOKButton | WordBool | Да |
ScriptPart | OleVariant | Нет |

Замечания:

Возвращает значение типа WordBool.

10.4.16. Метод EnsafeHTMLDocument

Метод интерфейса IContext.

1function IContext.EnsafeHTMLDocument(const HTML: WideString;
2  RemoveHead: WordBool; Format: WordBool; PureXML: WordBool): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
HTML | WideString | Да |
RemoveHead | WordBool | Да |
Format | WordBool | Да |
PureXML | WordBool | Да |

Замечания:

Возвращает значение типа WideString.

10.4.17. Метод enumerationItem

Метод интерфейса IContext.

function IContext.enumerationItem(ItemIdentifier: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ItemIdentifier | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

10.4.18. Метод executeConsoleProcess

Метод интерфейса IContext.

1function IContext.executeConsoleProcess(const CommandLine: WideString;
2  MaxDuration: Integer; const OutputData: OleVariant): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
CommandLine | WideString | Да |
MaxDuration | Integer | Да |
OutputData | OleVariant | Да |

Замечания:

Возвращает значение типа Integer.

10.4.19. Метод executeMethod

Метод интерфейса IContext.

1function IContext.executeMethod(const ClassName: WideString;
2  const MethodName: WideString; Params: OleVariant): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
MethodName | WideString | Да |
Params | OleVariant | Да |

Замечания:

Возвращает значение типа OleVariant.

10.4.20. Метод executeReport

Метод интерфейса IContext.

1function IContext.executeReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
TemplateName | WideString | Да |
Params | OleVariant | Да |

Замечания:

Возвращает значение типа IDispatch.

10.4.21. Метод ExportObject

Метод интерфейса IContext.

1procedure IContext.ExportObject(var Document: OleVariant; const ID: WideString;
2  const ClassID: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Document | OleVariant | Да |
ID | WideString | Да |
ClassID | WideString | Да |

10.4.22. Метод getClass

Метод интерфейса IContext.

function IContext.getClass(const ClassName: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |

Замечания:

Возвращает значение типа WideString.

10.4.23. Метод getCRC

Метод интерфейса IContext.

function IContext.getCRC(Data: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

10.4.24. Метод getDescription

Метод интерфейса IContext.

function IContext.getDescription(ID: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

10.4.25. Метод getName

Метод интерфейса IContext.

function IContext.getName(ID: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

10.4.26. Метод getOleObject

Метод интерфейса IContext.

1function IContext.getOleObject(const ClassID: WideString;
2  const AccessibleFileName: WideString): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassID | WideString | Да |
AccessibleFileName | WideString | Да |

Замечания:

Возвращает значение типа IDispatch.

10.4.27. Метод getPropValue

Метод интерфейса IContext.

1function IContext.getPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
ID | OleVariant | Да |

Замечания:

Возвращает значение типа OleVariant.

10.4.28. Метод getPropValues

Метод интерфейса IContext.

1procedure IContext.getPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
IDS | OleVariant | Да |
OnValueEvent | OleVariant | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |

10.4.29. Метод getResource

Метод интерфейса IContext.

function IContext.getResource(const Name: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа WideString.

10.4.30. Метод getTempFileName

Метод интерфейса IContext.

function IContext.getTempFileName(const Extension: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Extension | WideString | Да |

Замечания:

Возвращает значение типа WideString.

10.4.31. Метод Handle

Метод интерфейса IContext.

function IContext.Handle: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

10.4.32. Метод HasUI

Метод интерфейса IContext.

function IContext.HasUI: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

10.4.33. Метод IsHTMLDocumentSafe

Метод интерфейса IContext.

function IContext.IsHTMLDocumentSafe(const HTML: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
HTML | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

10.4.34. Метод LineBreak

Метод интерфейса IContext.

function IContext.LineBreak: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10.4.35. Метод MainHandle

Метод интерфейса IContext.

function IContext.MainHandle: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

10.4.36. Метод MsgBox

Метод интерфейса IContext.

1function IContext.MsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Prompt | WideString | Да |
Buttons | LongWord | Нет |
Title | WideString | Нет |
HelpFile | WideString | Нет |
Context | LongWord | Нет |

Замечания:

Возвращает значение типа Integer.

10.4.37. Метод parseJSON

Метод интерфейса IContext.

function IContext.parseJSON(const JSON: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
JSON | WideString | Да |

Замечания:

Возвращает значение типа WideString.

10.4.38. Метод parseNamedFile

Метод интерфейса IContext.

1procedure IContext.parseNamedFile(NamedFile: OleVariant;
2  out FileName: OleVariant; out Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
NamedFile | OleVariant | Да |
FileName | OleVariant | Да |
Data | OleVariant | Да |

10.4.39. Метод PerformAsyncTask

Метод интерфейса IContext.

function IContext.PerformAsyncTask(ID: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WordBool.

10.4.40. Метод PlaceDataSet

Метод интерфейса IContext.

1function IContext.PlaceDataSet(const Range: IDispatch;
2  const DataSet: IContextDataSet; ShiftRows: WordBool;
3  ShiftColumns: WordBool): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Range | IDispatch | Да |
DataSet | IContextDataSet | Да |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |

Замечания:

Возвращает значение типа Integer.

10.4.41. Метод PreProcessScript

Метод интерфейса IContext.

1function IContext.PreProcessScript(const Script: WideString; Indent: WordBool;
2  const CommentMark: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Script | WideString | Да |
Indent | WordBool | Да |
CommentMark | WideString | Да |

Замечания:

Возвращает значение типа WideString.

10.4.42. Метод processStart

Метод интерфейса IContext.

1procedure IContext.processStart(const Description: WideString;
2  ItemCount: Integer; CanAbort: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Description | WideString | Да |
ItemCount | Integer | Нет |
CanAbort | WordBool | Нет |

10.4.43. Метод processStep

Метод интерфейса IContext.

function IContext.processStep: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

10.4.44. Метод processStop

Метод интерфейса IContext.

procedure IContext.processStop;

Метод не имеет параметров.

10.4.45. Метод raiseManagedException

Метод интерфейса IContext.

procedure IContext.raiseManagedException(const ExceptionMessage: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ExceptionMessage | WideString | Да |

10.4.46. Метод RebuildTextIndex

Метод интерфейса IContext.

1procedure IContext.RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
2  ThreadCount: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
ClassID | OleVariant | Да |
FieldID | OleVariant | Да |
ThreadCount | Integer | Да |

10.4.47. Метод SaveExternalDataToFolder

Метод интерфейса IContext.

1procedure IContext.SaveExternalDataToFolder(const Resource: WideString;
2  const Folder: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Resource | WideString | Да |
Folder | WideString | Да |

10.4.48. Метод saveReport

Метод интерфейса IContext.

1procedure IContext.saveReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant; const FileName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
TemplateName | WideString | Да |
Params | OleVariant | Да |
FileName | WideString | Да |

10.4.49. Метод select

Метод интерфейса IContext.

1function IContext.select(const ClassName: WideString;
2  QueryItems: OleVariant): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
QueryItems | OleVariant | Да |

Замечания:

Возвращает значение типа IDispatch.

10.4.50. Метод selectVaue

Метод интерфейса IContext.

1function IContext.selectVaue(const ClassDomain: WideString;
2  const ExpressionContext: IUnknown; var Value: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ClassDomain | WideString | Да |
ExpressionContext | IUnknown | Да |
Value | OleVariant | Да |

Замечания:

Возвращает значение типа WordBool.

10.4.51. Метод setPropValue

Метод интерфейса IContext.

1procedure IContext.setPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant; Value: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
ID | OleVariant | Да |
Value | OleVariant | Да |

10.4.52. Метод setPropValues

Метод интерфейса IContext.

1procedure IContext.setPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
IDS | OleVariant | Да |
OnValueNeededEvent | OleVariant | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |

10.4.53. Метод showDataSet

Метод интерфейса IContext.

1procedure IContext.showDataSet(const DataSet: ContextDataSet;
2  const Caption: WideString; ColumnCaptions: OleVariant;
3  ColumnOnChangeHandlers: OleVariant; TakeActionsFromView: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
DataSet | ContextDataSet | Да |
Caption | WideString | Да |
ColumnCaptions | OleVariant | Да |
ColumnOnChangeHandlers | OleVariant | Да |
TakeActionsFromView | OleVariant | Да |

10.4.54. Метод ShowMsgBox

Метод интерфейса IContext.

1function IContext.ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Prompt | WideString | Да |
Buttons | LongWord | Нет |
Title | WideString | Нет |
HelpFile | WideString | Нет |
Context | LongWord | Нет |

Замечания:

Возвращает значение типа Integer.

10.4.55. Метод showView

Метод интерфейса IContext.

1procedure IContext.showView(const ViewName: WideString; Key: OleVariant;
2  const DetailPropertyName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ViewName | WideString | Да |
Key | OleVariant | Да |
DetailPropertyName | WideString | Да |

10.4.56. Метод Sleep

Метод интерфейса IContext.

procedure IContext.Sleep(MSecs: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
MSecs | Integer | Да |

10.4.57. Метод Transliterate

Метод интерфейса IContext.

function IContext.Transliterate(const Value: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Value | WideString | Да |

Замечания:

Возвращает значение типа WideString.

10.5. Интерфейс IContextDataSet

01type
02  IContextDataSet = interface(IDispatch)
03    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
04    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
05      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant); safecall;
06    function Eof: WordBool; safecall;
07    function Field(const Name: WideString): OleVariant; safecall;
08    function FieldCount: Integer; safecall;
09    function FieldName(Index: Integer): WideString; safecall;
10    procedure Next; safecall;
11    procedure Split(OnRowEvent: OleVariant; ChunkSize: Integer;
12      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
13    function AsJSON: WideString; safecall;
14    function AsXML: WideString; safecall;
15    function AsBinaryData: IDispatch; safecall;
16  end;

10.5.1. Метод AddQueryItem

Метод интерфейса IContextDataSet.

1procedure IContextDataSet.AddQueryItem(Part: TQueryPart;
2  const Name: WideString; Value: OleVariant; Special: TQuerySpecial;
3  Context: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Part | TQueryPart | Да |
Name | WideString | Да |
Value | OleVariant | Нет |
Special | TQuerySpecial | Нет |
Context | OleVariant | Нет |

10.5.2. Метод AsBinaryData

Метод интерфейса IContextDataSet.

function IContextDataSet.AsBinaryData: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

10.5.3. Метод AsJSON

Метод интерфейса IContextDataSet.

function IContextDataSet.AsJSON: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10.5.4. Метод AsXML

Метод интерфейса IContextDataSet.

function IContextDataSet.AsXML: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10.5.5. Метод Eof

Метод интерфейса IContextDataSet.

function IContextDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

10.5.6. Метод Field

Метод интерфейса IContextDataSet.

function IContextDataSet.Field(const Name: WideString): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа OleVariant.

10.5.7. Метод FieldCount

Метод интерфейса IContextDataSet.

function IContextDataSet.FieldCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

10.5.8. Метод FieldName

Метод интерфейса IContextDataSet.

function IContextDataSet.FieldName(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.

10.5.9. Метод Next

Метод интерфейса IContextDataSet.

procedure IContextDataSet.Next;

Метод не имеет параметров.

10.5.10. Метод Split

Метод интерфейса IContextDataSet.

1procedure IContextDataSet.Split(OnRowEvent: OleVariant; ChunkSize: Integer;
2  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
OnRowEvent | OleVariant | Да |
ChunkSize | Integer | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |

10.6. Интерфейс IContextExpressionInfo

1type
2  IContextExpressionInfo = interface(IUnknown)
3    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
4    function LookupExpressionContext(const Identifier: WideString;
5      out DomainID: WideString; out Value: WideString): WordBool; safecall;
6    procedure SerializeExpressionContext(const RootNode: IDispatch); safecall;
7  end;

10.6.1. Метод LookupExpressionContext

Метод интерфейса IContextExpressionInfo.

1function IContextExpressionInfo.LookupExpressionContext(const Identifier: WideString;
2  out DomainID: WideString; out Value: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Identifier | WideString | Да |
DomainID | WideString | Да |
Value | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

10.6.2. Метод SerializeExpressionContext

Метод интерфейса IContextExpressionInfo.

procedure IContextExpressionInfo.SerializeExpressionContext(const RootNode: IDispatch);

Параметры:

Имя | Тип | Обязательно | Значение
RootNode | IDispatch | Да |

10.7. Интерфейс IControl

01type
02  IControl = interface(IDispatch)
03    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
04    function Name: WideString; safecall;
05    function Get_Value: OleVariant; safecall;
06    procedure Set_Value(Value: OleVariant); safecall;
07    function Get_ReadOnly: WordBool; safecall;
08    procedure Set_ReadOnly(Value: WordBool); safecall;
09    function Get_IsValid: WordBool; safecall;
10    procedure Set_IsValid(Value: WordBool); safecall;
11    function Get_IsEmpty: WordBool; safecall;
12    procedure SetHint(const Value: WideString); safecall;
13    procedure RefreshLinkedView; safecall;
14    function Get_Visible: WordBool; safecall;
15    property Value: OleVariant read Get_Value write Set_Value;
16    property ReadOnly: WordBool read Get_ReadOnly write Set_ReadOnly;
17    property IsValid: WordBool read Get_IsValid write Set_IsValid;
18    property IsEmpty: WordBool read Get_IsEmpty;
19    property Visible: WordBool read Get_Visible;
20  end;

10.7.1. Свойства

Свойства интерфейса IControl:

Имя | Тип | Доступ | Назначение
IsEmpty | WordBool | Только для чтения |
IsValid | WordBool | Чтение/Запись |
ReadOnly | WordBool | Чтение/Запись |
Value | OleVariant | Чтение/Запись |
Visible | WordBool | Только для чтения |

10.7.2. Метод Name

Метод интерфейса IControl.

function IControl.Name: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10.7.3. Метод RefreshLinkedView

Метод интерфейса IControl.

procedure IControl.RefreshLinkedView;

Метод не имеет параметров.

10.7.4. Метод SetHint

Метод интерфейса IControl.

procedure IControl.SetHint(const Value: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Value | WideString | Да |

10.8. Интерфейс IExceptionHandler

1type
2  IExceptionHandler = interface(IDispatch)
3    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
4    procedure HandleException(ContextObject: OleVariant; const Message: WideString;
5      const ExtentedInfo: WideString; SupportServiceData: OleVariant); safecall;
6  end;

10.8.1. Метод HandleException

Метод интерфейса IExceptionHandler.

1procedure IExceptionHandler.HandleException(ContextObject: OleVariant;
2  const Message: WideString; const ExtentedInfo: WideString;
3  SupportServiceData: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
ContextObject | OleVariant | Да |
Message | WideString | Да |
ExtentedInfo | WideString | Да |
SupportServiceData | OleVariant | Да |

10.9. Интерфейс IExternalContext

1type
2  IExternalContext = interface(IDispatch)
3    ['{EA2F1CDA-53F6-40E9-A2B7-0A80AB84D177}']
4    procedure Connect(const Database: WideString); safecall;
5  end;

10.9.1. Метод Connect

Метод интерфейса IExternalContext.

procedure IExternalContext.Connect(const Database: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Database | WideString | Да |

10.10. Интерфейс IFormContext

01type
02  IFormContext = interface(IDispatch)
03    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
04    function ID: WideString; safecall;
05    function RoutineID: WideString; safecall;
06    function ControlCount: Integer; safecall;
07    function Get_Controls(Name: OleVariant): IControl; safecall;
08    function ControlExists(const Name: WideString): WordBool; safecall;
09    function ButtonCount: Integer; safecall;
10    function Get_Buttons(Name: OleVariant): IButton; safecall;
11    function Get_Enabled: WordBool; safecall;
12    procedure Set_Enabled(Value: WordBool); safecall;
13    function ChangedControl: OleVariant; safecall;
14    function ChangedControlName: WideString; safecall;
15    procedure Cancel; safecall;
16    function ParentForm: OleVariant; safecall;
17    procedure PreInitControl(const Name: WideString; Value: OleVariant); safecall;
18    procedure NavigatorNext; safecall;
19    procedure NavigatorPrevious; safecall;
20    function NavigatorCanNext: WordBool; safecall;
21    function NavigatorCanPrevious: WordBool; safecall;
22    procedure RefreshView(RefreshAll: WordBool); safecall;
23    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
24    property Controls[Name: OleVariant]: IControl read Get_Controls;
25    property Buttons[Name: OleVariant]: IButton read Get_Buttons;
26    property Enabled: WordBool read Get_Enabled write Set_Enabled;
27  end;

10.10.1. Свойства

Свойства интерфейса IFormContext:

Имя | Тип | Доступ | Назначение
Buttons[Name: OleVariant] | IButton | Только для чтения |
Controls[Name: OleVariant] | IControl | Только для чтения |
Enabled | WordBool | Чтение/Запись |

10.10.2. Метод ButtonCount

Метод интерфейса IFormContext.

function IFormContext.ButtonCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

10.10.3. Метод Cancel

Метод интерфейса IFormContext.

procedure IFormContext.Cancel;

Метод не имеет параметров.

10.10.4. Метод ChangedControl

Метод интерфейса IFormContext.

function IFormContext.ChangedControl: OleVariant;

Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

10.10.5. Метод ChangedControlName

Метод интерфейса IFormContext.

function IFormContext.ChangedControlName: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10.10.6. Метод ControlCount

Метод интерфейса IFormContext.

function IFormContext.ControlCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

10.10.7. Метод ControlExists

Метод интерфейса IFormContext.

function IFormContext.ControlExists(const Name: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

10.10.8. Метод ExpressionContextValue

Метод интерфейса IFormContext.

function IFormContext.ExpressionContextValue(const Name: WideString): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа OleVariant.

10.10.9. Метод ID

Метод интерфейса IFormContext.

function IFormContext.ID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10.10.10. Метод NavigatorCanNext

Метод интерфейса IFormContext.

function IFormContext.NavigatorCanNext: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

10.10.11. Метод NavigatorCanPrevious

Метод интерфейса IFormContext.

function IFormContext.NavigatorCanPrevious: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

10.10.12. Метод NavigatorNext

Метод интерфейса IFormContext.

procedure IFormContext.NavigatorNext;

Метод не имеет параметров.

10.10.13. Метод NavigatorPrevious

Метод интерфейса IFormContext.

procedure IFormContext.NavigatorPrevious;

Метод не имеет параметров.

10.10.14. Метод ParentForm

Метод интерфейса IFormContext.

function IFormContext.ParentForm: OleVariant;

Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

10.10.15. Метод PreInitControl

Метод интерфейса IFormContext.

procedure IFormContext.PreInitControl(const Name: WideString; Value: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |
Value | OleVariant | Да |

10.10.16. Метод RefreshView

Метод интерфейса IFormContext.

procedure IFormContext.RefreshView(RefreshAll: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
RefreshAll | WordBool | Да |

10.10.17. Метод RoutineID

Метод интерфейса IFormContext.

function IFormContext.RoutineID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10.11. Интерфейс IRaster

01type
02  IRaster = interface(IDispatch)
03    ['{4F27D016-03C2-4D48-ABF7-FD547E859F79}']
04    function Get_Width: Integer; safecall;
05    procedure Set_Width(Value: Integer); safecall;
06    function Get_Height: Integer; safecall;
07    procedure Set_Height(Value: Integer); safecall;
08    function Get_DefaultColor: Integer; safecall;
09    procedure Set_DefaultColor(Value: Integer); safecall;
10    procedure Load(Src: OleVariant); safecall;
11    procedure SaveBitmap(Dst: OleVariant); safecall;
12    procedure SavePNG(Dst: OleVariant); safecall;
13    procedure SaveJPG(Dst: OleVariant; Quality: Integer); safecall;
14    procedure FlipVertical; safecall;
15    procedure FlipHorizontal; safecall;
16    procedure Rotate; safecall;
17    procedure Resize(NewWidth: Integer; NewHeight: Integer; Center: WordBool); safecall;
18    procedure Stretch(NewWidth: Integer; NewHeight: Integer); safecall;
19    procedure StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
20      MaxSize: OleVariant); safecall;
21    procedure Overlay(Src: OleVariant; X: Integer; Y: Integer; Width: Integer;
22      Height: Integer); safecall;
23    property Width: Integer read Get_Width write Set_Width;
24    property Height: Integer read Get_Height write Set_Height;
25    property DefaultColor: Integer read Get_DefaultColor write Set_DefaultColor;
26  end;

10.11.1. Свойства

Свойства интерфейса IRaster:

Имя | Тип | Доступ | Назначение
DefaultColor | Integer | Чтение/Запись |
Height | Integer | Чтение/Запись |
Width | Integer | Чтение/Запись |

10.11.2. Метод FlipHorizontal

Метод интерфейса IRaster.

procedure IRaster.FlipHorizontal;

Метод не имеет параметров.

10.11.3. Метод FlipVertical

Метод интерфейса IRaster.

procedure IRaster.FlipVertical;

Метод не имеет параметров.

10.11.4. Метод Load

Метод интерфейса IRaster.

procedure IRaster.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

10.11.5. Метод Overlay

Метод интерфейса IRaster.

1procedure IRaster.Overlay(Src: OleVariant; X: Integer; Y: Integer;
2  Width: Integer; Height: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |
X | Integer | Да |
Y | Integer | Да |
Width | Integer | Да |
Height | Integer | Да |

10.11.6. Метод Resize

Метод интерфейса IRaster.

1procedure IRaster.Resize(NewWidth: Integer; NewHeight: Integer;
2  Center: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
NewWidth | Integer | Да |
NewHeight | Integer | Да |
Center | WordBool | Да |

10.11.7. Метод Rotate

Метод интерфейса IRaster.

procedure IRaster.Rotate;

Метод не имеет параметров.

10.11.8. Метод SaveBitmap

Метод интерфейса IRaster.

procedure IRaster.SaveBitmap(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |

10.11.9. Метод SaveJPG

Метод интерфейса IRaster.

procedure IRaster.SaveJPG(Dst: OleVariant; Quality: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |
Quality | Integer | Да |

10.11.10. Метод SavePNG

Метод интерфейса IRaster.

procedure IRaster.SavePNG(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |

10.11.11. Метод Stretch

Метод интерфейса IRaster.

procedure IRaster.Stretch(NewWidth: Integer; NewHeight: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
NewWidth | Integer | Да |
NewHeight | Integer | Да |

10.11.12. Метод StretchToSize

Метод интерфейса IRaster.

1procedure IRaster.StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
2  MaxSize: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
MaxWidth | OleVariant | Да |
MaxHeight | OleVariant | Да |
MaxSize | OleVariant | Да |

10.12. Интерфейс IScannerTools

1type
2  IScannerTools = interface(IDispatch)
3    ['{FC1B3C9F-7DE9-4909-B57D-6D33E3B0A87A}']
4    function AcquireImage(Silent: WordBool): IDispatch; safecall;
5    function AcquirePDF: IDispatch; safecall;
6  end;

10.12.1. Метод AcquireImage

Метод интерфейса IScannerTools.

function IScannerTools.AcquireImage(Silent: WordBool): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Silent | WordBool | Да |

Замечания:

Возвращает значение типа IDispatch.

10.12.2. Метод AcquirePDF

Метод интерфейса IScannerTools.

function IScannerTools.AcquirePDF: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

10.13. Интерфейс ISetOfObjectsEditor

1type
2  ISetOfObjectsEditor = interface(IDispatch)
3    ['{6D3662A7-D9FF-4BD6-8D92-A4EA2058C74E}']
4    function Get_DomainName: WideString; safecall;
5    procedure Set_DomainName(Value: WideString); safecall;
6    function Get_SelectedCount: Integer; safecall;
7    property DomainName: WideString read Get_DomainName write Set_DomainName;
8    property SelectedCount: Integer read Get_SelectedCount;
9  end;

10.13.1. Свойства

Свойства интерфейса ISetOfObjectsEditor:

Имя | Тип | Доступ | Назначение
DomainName | WideString | Чтение/Запись |
SelectedCount | Integer | Только для чтения |

10.14. Интерфейс IZIPArchive

01type
02  IZIPArchive = interface(IDispatch)
03    ['{11C9400F-F262-4F72-882F-5AA5A4531591}']
04    procedure Load(Src: OleVariant); safecall;
05    procedure Save(Src: OleVariant); safecall;
06    function Get_FileCount: Integer; safecall;
07    function Get_FileName(Index: Integer): WideString; safecall;
08    function Get_FileData(Index: Integer): OleVariant; safecall;
09    procedure AddFile(const FileName: WideString; Data: OleVariant); safecall;
10    function Get_FileSize(Index: Integer): Int64; safecall;
11    function Get_FileDateTime(Index: Integer): TDateTime; safecall;
12    function Get_FileCRC(Index: Integer): WideString; safecall;
13    function Get_UTF8Support: WordBool; safecall;
14    procedure Set_UTF8Support(Value: WordBool); safecall;
15    property FileCount: Integer read Get_FileCount;
16    property FileName[Index: Integer]: WideString read Get_FileName;
17    property FileData[Index: Integer]: OleVariant read Get_FileData;
18    property FileSize[Index: Integer]: Int64 read Get_FileSize;
19    property FileDateTime[Index: Integer]: TDateTime read Get_FileDateTime;
20    property FileCRC[Index: Integer]: WideString read Get_FileCRC;
21    property UTF8Support: WordBool read Get_UTF8Support write Set_UTF8Support;
22  end;

10.14.1. Свойства

Свойства интерфейса IZIPArchive:

Имя | Тип | Доступ | Назначение
FileCRC[Index: Integer] | WideString | Только для чтения |
FileCount | Integer | Только для чтения |
FileData[Index: Integer] | OleVariant | Только для чтения |
FileDateTime[Index: Integer] | TDateTime | Только для чтения |
FileName[Index: Integer] | WideString | Только для чтения |
FileSize[Index: Integer] | Int64 | Только для чтения |
UTF8Support | WordBool | Чтение/Запись |

10.14.2. Метод AddFile

Метод интерфейса IZIPArchive.

procedure IZIPArchive.AddFile(const FileName: WideString; Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
FileName | WideString | Да |
Data | OleVariant | Да |

10.14.3. Метод Load

Метод интерфейса IZIPArchive.

procedure IZIPArchive.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

10.14.4. Метод Save

Метод интерфейса IZIPArchive.

procedure IZIPArchive.Save(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

11. Дополнительные интерфейсы

11.1. Интерфейс IBinaryData

01type
02  IBinaryData = interface(IDispatch)
03    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
04    procedure Append(Src: OleVariant); safecall;
05    procedure Load(Src: OleVariant); safecall;
06    procedure Save(Dst: OleVariant); safecall;
07    function Size: LongWord; safecall;
08    procedure AppendData(Data: OleVariant; DataSize: LongWord); safecall;
09    procedure SetData(Data: OleVariant; DataSize: LongWord); safecall;
10    procedure GetData(Data: OleVariant); safecall;
11    function ToString(const Encoding: WideString): WideString; safecall;
12    procedure FromString(Data: OleVariant); safecall;
13    procedure AppendString(Data: OleVariant); safecall;
14    function ToBase64(Width: Integer): WideString; safecall;
15    procedure FromBase64(Data: OleVariant); safecall;
16    function ContentIsText: WordBool; safecall;
17  end;

11.1.1. Метод Append

Метод интерфейса IBinaryData.

procedure IBinaryData.Append(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

11.1.2. Метод AppendData

Метод интерфейса IBinaryData.

procedure IBinaryData.AppendData(Data: OleVariant; DataSize: LongWord);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |
DataSize | LongWord | Да |

11.1.3. Метод AppendString

Метод интерфейса IBinaryData.

procedure IBinaryData.AppendString(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

11.1.4. Метод ContentIsText

Метод интерфейса IBinaryData.

function IBinaryData.ContentIsText: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

11.1.5. Метод FromBase64

Метод интерфейса IBinaryData.

procedure IBinaryData.FromBase64(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

11.1.6. Метод FromString

Метод интерфейса IBinaryData.

procedure IBinaryData.FromString(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

11.1.7. Метод GetData

Метод интерфейса IBinaryData.

procedure IBinaryData.GetData(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

11.1.8. Метод Load

Метод интерфейса IBinaryData.

procedure IBinaryData.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

11.1.9. Метод Save

Метод интерфейса IBinaryData.

procedure IBinaryData.Save(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |

11.1.10. Метод SetData

Метод интерфейса IBinaryData.

procedure IBinaryData.SetData(Data: OleVariant; DataSize: LongWord);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |
DataSize | LongWord | Да |

11.1.11. Метод Size

Метод интерфейса IBinaryData.

function IBinaryData.Size: LongWord;

Метод не имеет параметров.

Замечания:

Возвращает значение типа LongWord.

11.1.12. Метод ToBase64

Метод интерфейса IBinaryData.

function IBinaryData.ToBase64(Width: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Width | Integer | Нет |

Замечания:

Возвращает значение типа WideString.

11.1.13. Метод ToString

Метод интерфейса IBinaryData.

function IBinaryData.ToString(const Encoding: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Encoding | WideString | Да |

Замечания:

Возвращает значение типа WideString.


Мельница данных ((раздел целиком))

Мельница данных- Класс TViewPresentationAccess (Доступ к видам) (раздел целиком) (22.10.2024) (одним файлом)
Класс TViewPresentationAccess (Доступ к видам)

Класс TAccessItem (Элементы доступа)Класс TObject (Объекты)Класс TViewPresentation (Виды)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Конструктор Create (Конструктор доступа к виду)

Конструктор класса TViewPresentationAccess.

1constructor TViewPresentationAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
SecurityAccount | TSecurityAccount | Да | Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TViewPresentationAccess.


Мельница данных ((раздел целиком))

Мельница данных- Класс TExcelTemplate (Шаблоны отчетов Excel) (раздел целиком) (22.10.2024) (одним файлом)
Класс TExcelTemplate (Шаблоны отчетов Excel)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

1. Свойства

Свойства класса TExcelTemplate:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
TemplateData | blob | Нет | Видимо пользователю | Чтение/Запись | Данные шаблона
PlaceDataOnSheet | TExcelSheetKind | Да | Видимо пользователю | Чтение/Запись | Лист для переноса данных
MacroName | string[128] | Нет | Видимо пользователю | Чтение/Запись | Имя макроса
IsInteractive | Boolean | Да | Видимо пользователю | Чтение/Запись | Интерактивный

2. Конструктор Create (Конструктор шаблона Excel)

Конструктор класса TExcelTemplate.

1constructor TExcelTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  PlaceDataOnSheet: TExcelSheetKind; MacroName: string[128];
7  IsInteractive: Boolean): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
TemplateData | blob | Нет | Данные шаблона
PlaceDataOnSheet | TExcelSheetKind | Да | Лист для переноса данных
MacroName | string[128] | Нет | Имя макроса
IsInteractive | Boolean | Да | Интерактивный

Замечания:

Создает новый объект класса TExcelTemplate.

3. Метод Ole-объекта CheckExcelTemplate (Проверить шаблон отчетов Excel)

Метод Ole-объекта класса TExcelTemplate.

Метод Ole-объекта не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Требования к провайдеру (раздел целиком) (22.10.2024) (одним файлом)
Требования к провайдеру

Интерфейсы провайдера описаны в библиотеке типов файла QueryBuilder.exe и в файле QueryBuilder_TLB.pas. Собственно, объект-провайдер реализует Интерфейс IInfoProvider. Каждый CoClass, реализующий указанный интерфейс, прописывается в ветке реестра HKLM\Software\QueryBuilder\Providers добавлением параметра, имя которого определяет наименование провайдера, а значение - CLSID провайдера.

Метаданные (информация о таблицах, полях и типах данных) предоставляются в виде именованных элементов, то есть каждый из них реализует интерфейс INamedItemInfo

1. Интерфейс IInfoProvider
Провайдер реализует интерфейс
01  IInfoProvider = interface(IUnknown)
02    ['{64F8072B-7250-4C57-BA8E-D018C7B72CC7}']
03    function Get_TableCount: Integer; safecall;
04    function Get_Table(Index: Integer): ITableInfo; safecall;
05    function Perform(const SQL: WideString): IDataSet; safecall;
06    procedure Connect(const DataBase: WideString;
07      const UserName: WideString;
08      const Password: WideString); safecall;
09    function Get_CLSID: TGUID; safecall;
10    function Get_DateLiteral: WideString; safecall;
11    function Get_TimeLiteral: WideString; safecall;
12    function Get_DateTimeLiteral: WideString; safecall;
13  end;
  • функция Get_CLSID возвращает GUID класса-провайдера.
  • процедура Connect осуществляет соединение с БД.
  • функция Get_TableCount возвращает количество таблиц, доступ к которым предоставляется провайдером.
  • функция Get_Table возвращает ссылку на информацию о таблице с номером Index. Ссылка на интерфейс ITableInfo или интерфейс ITableInfo2
  • функция Perform принимает текст сформированного SQL-запроса и возвращает ссылку на набор данных. Набор данных реализует интерфейс IDataSet.
  • функция Get_DateLiteral возвращает строку, определяющую способ включения в запрос литерала типа "Дата".
  • функция Get_TimeLiteral возвращает строку, определяющую способ включения в запрос литерала типа "Время".
  • функция Get_DateTimeLiteralвозвращает строку, определяющую способ включения в запрос литерала типа "Дата со временем".

2. Интерфейс IDataSet
Набор данных реализует интерфейс
1   IDataSet = interface(IUnknown)
2    ['{3CED7395-8482-4EF6-8A15-7744348063C2}']
3    function Get_FieldCount: Integer; safecall;
4    function Get_FieldName(Index: Integer): WideString; safecall;
5    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
6    procedure Next; safecall;
7    function Eof: WordBool; safecall;
8  end;
Набор данных представляет собой однонаправленный курсор, каждая строка которого является набором именованных и нумерованных полей.
  • процедура Next осуществляет переход к следующей записи курсора.
  • функция Eof возвращает True в случае достижения конца курсора.
  • функция Get_FieldCount возвращает количество полей в строке курсора.
  • функция Get_FieldName возвращает имя поля с номером Index.
  • функция Get_Field возвращает значение поля, имя или номер которого задан параметром (если строка, то имя, если число, то номер). Допустимо возвращать значение Null для пустых полей.

3. Интерфейс INamedItemInfo
Каждый элемент метаданных (таблица, поле, тип) обязательно реализует интерфейс
1  INamedItemInfo = interface(IUnknown)
2    ['{14894363-28DA-4E71-B0BC-9C5CE811BC8F}']
3    function Get_Name: WideString; safecall;
4    function Get_Caption: WideString; safecall;
5    function Get_ID: WideString; safecall;
6  end;

Именованный элемент имеет имя, наименование и идентификатор. Имя используется для именования сущности в сформированном SQL-запросе, идентификатор необходим для идентификации сущности в рамках провайдера, таблицы и типы данных имеют глобальное пространство идентификаторов, поля имеют уникальные идентификаторы в пределах последовательности наследуемых таблиц. Никаких ограничений на значения идентификаторов, кроме уникальности, не накладывается.

  • функция Get_Name возвращает имя сущности.
  • функция Get_Caption возвращает наименование сущности.
  • функция Get_ID возвращает идентификатор сущности.

4. Интерфейс ITableInfo
Информация о таблице представляется объектом через интерфейс (наследник INamedItemInfo )
1  ITableInfo = interface(INamedItemInfo)
2    ['{3FC1998A-9031-4936-82B5-8CAA2219085E}']
3    function Get_FieldCount: Integer; safecall;
4    function Get_Field(Index: Integer): IFieldInfo; safecall;
5    function Get_PrimaryKey: IFieldInfo; safecall;
6    function Get_Uplink: IFieldInfo; safecall;
7    function Get_Parent: ITableInfo; safecall;
8  end;
  • функция Get_FieldCount возвращает количество полей в таблице.
  • функция Get_Field возвращает ссылку на поле с номером Index. Ссылка на интерфейс IFieldInfo
  • функция Get_PrimaryKey возвращает ссылку на поле, являющееся первичным ключем. Это поле должно быть задано.
  • функция Get_Uplink возвращает ссылку на поле, осуществляющее иерархическую связь между записями таблицы. Если это поле задано, записи отображаются в виде иерархии.
  • функция Get_Parent возвращает ссылку на родительскую таблицу. Дочерняя таблица связана с родительской первичными ключами, т. е. соотношением 1:1. Если таблица не имеет родительской, возвращается nil.

4.1. Интерфейс ITableInfo2
Для таблиц, имеющих полиморфные ссылки, реализуется интерфейс (наследник ITableInfo )
1  ITableInfo2 = interface(ITableInfo)
2    ['{9DF4C8AC-1DA2-4E7B-BF44-7EDD7A269418}']
3    function Get_PolymorphCount: Integer; safecall;
4    function Get_PolymorphTable(Index: Integer): ITableInfo; safecall;
5    function Get_PolymorphField(Index: Integer): IFieldInfo; safecall;
6  end;
Полиморфной ссылкой является, например, ссылка, физически размещенная в родительской таблице, указывающая на свою запись. Реализация этого интерфейса не является обязательной.
  • функция Get_PolymorphCount возвращает количество полиморфных ссылок.
  • функция Get_PolymorphTable возвращает ссылку на таблицу, на которую указывает полиморфная ссылка номер Index.
  • функция Get_PolymorphTable возвращает ссылку на поле, реализующее полиморфную ссылку номер Index. Это поле должно иметь тип dtReference, информация о его типе должна реализовать интерфейс IReferenceInfo. Значение, возвращаемое функцией Get_TargetTable этого интерфейса в данном случае не имеет значения и игнорируется.

4.2. Интерфейс ITableInfo3
Для таблиц, при запросах к которым требуется наложение дополнительных условий отбора, реализуется интерфейс (наследник ITableInfo )
01  ITableInfo3 = interface(ITableInfo)
02    ['{3FB73AA9-010C-48DA-81C7-E1DCFE2E6136}']
03    function GetPersistentClause(const Alias: WideString): WideString; safecall;
04    function GetPreConditionsCount: Integer; safecall;
05    function GetPreConditionCaption(Index: Integer): WideString; safecall;
06    function GetPreConditionCategory(Index: Integer): WideString; safecall;
07    function Get_ActivePreCondition(Index: Integer): WordBool; safecall;
08    procedure Set_ActivePreCondition(Index: Integer; Value: WordBool); safecall;
09    function GetPreConditionParamsCount(Index: Integer): Integer; safecall;
10    function GetPreConditionParam(Index: Integer; PreConditionIndex: Integer): IOptionInfo; safecall;
11  end;
  • функция GetPersistentClause возвращает выражение дополнительного условия отбора. Алиас таблицы передается в параметре Alias.

5. Интерфейс IFieldInfo
Информация о поле поставляется объектом, реализующим интерфейс (наследник INamedItemInfo )
1  IFieldInfo = interface(INamedItemInfo)
2    ['{19054DAD-8D35-4B39-8EB7-FD3254BD2934}']
3    function Get_TypeInfo: ITypeInfo; safecall;
4    function Get_DisplayMode: TDisplayMode; safecall;
5  end;
  • функция Get_DisplayMode возвращает роль поля при показе таблицы. Возможные значения (тип TDisplayMode):
    • dmAlways - поле является ключевым, всегда показывается
    • dmNever - поле является служебным (первичным ключем, например). Никогда не показывается.
    • dmOnDemand - поле является обычным информационным, показывается по требованию пользователя.
  • функция Get_TypeInfo возвращает ссылку на информацию о типе данных поля. Возвращаете ссылку на один из интерфейсов-наследников интерфейса ITypeInfo

6. Интерфейс ITypeInfo
Информация о типах полей поставляется в виде набора объектов, каждый из которых реализует интерфейс (наследник INamedItemInfo )
1  ITypeInfo = interface(INamedItemInfo)
2    ['{2B6A5E20-3C36-4574-89DB-7C873A5C4A00}']
3    function Get_Required: WordBool; safecall;
4    function Get_SimpleType: TSimpleType; safecall;
5  end;
Информация о конкретном типе передается при помощи реализации одного из наследников этого интерфейса.
  • функция Get_Required возвращает True, если значение поля обязательно для задания.
  • функция Get_SimpleType возвращает информацию о простом типе данных. В зависимости от возвращаемого значения объект должен также реализовывать один из интерфейсов конкретных типов (см. далее). Возможные значения (тип TSimpleType ):
    • dtString - строковый тип. Обязательно реализуется интерфейс IStringInfo
    • dtInteger - целочисленный тип. Обязательно реализуется интерфейс IIntegerInfo
    • dtFloat - вещественный тип. Обязательно реализуется интерфейс IFloatInfo
    • dtDate - тип "дата". Обязательно реализуется интерфейс IDateInfo
    • dtTime - тип "время". Обязательно реализуется интерфейс ITimeInfo
    • dtDateTime - тип "дата со временем". Обязательно реализуется интерфейс IDateTimeInfo
    • dtBoolean - логический тип. Обязательно реализуется интерфейс IBooleanInfo
    • dtEnumeration - перечисление. Обязательно реализуется интерфейс IEnumerationInfo
    • dtReference - ссылка. Обязательно реализуется интерфейс IReferenceInfo
    • dtBlob - Большой двоичный объект. Обязательно реализуется интерфейс IBlobInfo.

6.1. Интерфейс ITypeInfo2
Информация о предоставляемых провайдером дополнительных возможностях фильтрации (наследник интерфейса ITypeInfo)
1  ITypeInfo2 = interface(ITypeInfo)
2    ['{77F58BDF-F01C-40F3-B193-1027AD8C4EDA}']
3    function GetSpecialFilterCount: Integer; safecall;
4    function GetSpecialFilterText(Index: Integer): WideString; safecall;
5    function EditSpecialFilter(Index: Integer; var Filter: WideString): WordBool; safecall;
6  end;
  • функция GetSpecialFilterCount возвращает количество дополнительных элементов списка, выпадающего при выборе фильтра по колонке.
  • функция GetSpecialFilterText возвращает текст дополнительного элемента списка, выпадающего при выборе фильтра по колонке, с номером Index.
  • функция EditSpecialFilter вызывается в момент выбора пользователем дополнительного элемента списка, выпадающего при выборе фильтра по колонке, с номером Index. Значение выражения фильтра передается и возвращается в параметре Filter. Функция возвращает True в случае, если выражение, возвращенное в параметре Filter нужно применить для фильтрации столбца запроса, False - в противном случае.

6.2. Интерфейс IStringInfo
Информация о строковом типе (наследник интерфейса ITypeInfo)
1  IStringInfo = interface(ITypeInfo)
2    ['{74AC4C03-E803-421B-B30D-1A2D2C49827F}']
3    function Get_Length: Integer; safecall;
4  end;
  • функция Get_Length возвращает максимальную длину строки.

6.3. Интерфейс IIntegerInfo
Информация о целочисленном типе (наследник интерфейса ITypeInfo)
1  IIntegerInfo = interface(ITypeInfo)
2    ['{9003B25E-926D-42AE-A907-813DF3A8343E}']
3    function Get_MaxValue: Integer; safecall;
4    function Get_MaxValueUsed: WordBool; safecall;
5    function Get_MinValue: Integer; safecall;
6    function Get_MinValueUsed: WordBool; safecall;
7  end;
  • функция Get_MaxValueUsed возвращает True, если значение имеет верхнюю границу.
  • функция Get_MaxValue возвращает верхнюю границу значения, если есть.
  • функция Get_MinValueUsed возвращает True, если значение имеет нижнюю границу.
  • функция Get_MinValue возвращает нижнюю границу значения, если есть.

6.4. Интерфейс IFloatInfo
Информация о вещественном типе (наследник интерфейса ITypeInfo )
1  IFloatInfo = interface(ITypeInfo)
2    ['{E9B56C6D-47DC-4AB9-9E80-6EEF77708704}']
3    function Get_MaxValue: Double; safecall;
4    function Get_MaxValueUsed: WordBool; safecall;
5    function Get_MinValue: Double; safecall;
6    function Get_MinValueUsed: WordBool; safecall;
7    function Get_Precision: Integer; safecall;
8    function Get_Scale: Integer; safecall;
9  end;
  • функция Get_MaxValueUsed возвращает True, если значение имеет верхнюю границу.
  • функция Get_MaxValue возвращает верхнюю границу значения, если есть.
  • функция Get_MinValueUsed возвращает True, если значение имеет нижнюю границу.
  • функция Get_MinValue возвращает нижнюю границу значения, если есть.
  • функция Get_Precision возвращает максимальное количество значащих десятичных цифр в значении.
  • функция Get_Scale возвращает максимальное количество десятичных цифр после запятой.

6.5. Интерфейс IDateInfo
Информация о типе "Дата" (без времени) (наследник интерфейса ITypeInfo )
1  IDateInfo = interface(ITypeInfo)
2    ['{DA392510-105F-4655-9A38-18ECA2FBEB97}']
3  end;
Не имеет методов.

6.6. Интерфейс ITimeInfo
Информация о типе "Время" (без даты) (наследник интерфейса ITypeInfo )
1  ITimeInfo = interface(ITypeInfo)
2    ['{D7067CAC-67A5-41DB-8D95-40409D8658AB}']
3  end;
Не имеет методов.

6.7. Интерфейс IDateTimeInfo
Информация о типе "Дата со времемем" (наследник интерфейса ITypeInfo )
1  IDateTimeInfo = interface(ITypeInfo)
2    ['{7F5CC8F9-8CE1-4DB7-8932-884EF3BAB538}']
3  end;
Не имеет методов.

6.8. Интерфейс IBooleanInfo
Информация о логическом типе (наследник интерфейса ITypeInfo )
1  IBooleanInfo = interface(ITypeInfo)
2    ['{8256EDF9-8613-4970-850C-50047839D6BF}']
3    function Get_TrueValue: WideString; safecall;
4    function Get_FalseValue: WideString; safecall;
5  end;
  • функция Get_TrueValue возвращает отображаемую строку для значения True (например, "Да").
  • функция Get_FalseValue возвращает отображаемую строку для значения False (например, "Нет").

6.9. Интерфейс IEnumerationInfo
Информация о перечислимом типе (наследник интерфейса ITypeInfo )
1  IEnumerationInfo = interface(ITypeInfo)
2    ['{B58A3F23-1AAC-4420-ADFF-B23B9938A994}']
3    function Get_ItemCount: Integer; safecall;
4    function Get_Item(Index: Integer): IEnumerationItem; safecall;
5  end;
Перечислимый тип определяет набор значений, которые может принимать поле. Значения в таблице трактуются как равные имени элемента перечисления.
  • функция Get_ItemCount возвращает количество элементов перечисления.
  • функция Get_Item возвращает ссылку на элемент перечисления с номером Index, реализующий интерфейс IEnumerationItem

6.10. Интерфейс IReferenceInfo
Информация о типе "ссылка" (наследник интерфейса ITypeInfo )
1  IReferenceInfo = interface(ITypeInfo)
2    ['{309C8CB1-4A1C-4E58-BC3F-D1AF27861A8F}']
3    function Get_TargetTable: ITableInfo; safecall;
4  end;
  • функция Get_TargetTable возвращает ссылку на таблицу, с которой осуществляется связь. Возвращается ссылка на интерфейс ITableInfo

6.11. Интерфейс IBlobInfo
Информация о типе "больших двоичных объектов" (наследник интерфейса ITypeInfo )
1  IBlobInfo = interface(ITypeInfo)
2    ['{3905C9C4-EAEB-4844-BB55-3F524F1F3FAC}']
3    function Get_SubType: TBlobSubType; safecall;
4  end;
  • функция Get_SubType возвращает подтип большого двоичного объекта. Одно из следующих значений (тип TBlobSubType ):
    • bsText - текст
    • bsImage - изображение
    • bsBinary - двоичные данные

7. Интерфейс IEnumerationItem
Информация об элементе перечисления (наследник INamedItemInfo )
1  IEnumerationItem = interface(INamedItemInfo)
2    ['{6953507C-D477-4B8D-9443-A9E5FE7137ED}']
3    function Get_Position: Integer; safecall;
4  end;
Значения в таблице трактуются как равные имени элемента перечисления.
  • функция Get_Position возвращает позицию элемента перечисления.


Мельница данных ((раздел целиком))

Мельница данных- Свойства страницы (раздел целиком) (22.10.2024) (одним файлом)
Свойства страницы

Для создания страницы используется функция

function CreatePage(Parent: OleVariant): IPDFPage;

Параметр Parent указывает страницу-родителя для данной страницы. Если страницы- родителя быть не должно - формат вызова функции примет вид:

set page = CreatePage(Null)

Параметры страницы:

  • Title - заголовок страницы.
    page.Title = "Page name"
  • Width - ширина страницы, миллиметры
    page.Width = 80
  • Height - высота страницы, миллиметры
    page.Height = 80
  • DrawGrid - процедура, выводящая на страницу сетку с шагом 5 миллиметров для удобства отладки вида документа.
  • Perform - процедура, позволяющая выполнить дополнительные команды PostScript на странице.
    page.perform "1 0.7 0 0 k"page.perform "0 0 m"

1. Объявление цвета

Для объявления цвета объектов на странице используется цветовая модель R:G:B (Red:Green:Blue). Объявление цвета для выполнения последующих операций (цвет шрифта, цвет линии/фигуры) осуществляется процедурой

procedure SetColor(R: Integer; G: Integer; B: Integer);
Где параметры R, G, B - значения базисных цветов для выбранного цвета (от 0 до 255).

Цвет | R | G | B |
Белый | 255 | 255 | 255 | +++
Черный | 0 | 0 | 0 | +++
Серый | 190 | 190 | 190 | +++
Синий | 0 | 0 | 255 | +++
Красный | 255 | 0 | 0 | +++
Зеленый | 0 | 255 | 0 | +++

Если предварительно цвет не был объявлен, используется цвет по умолчанию - черный (0,0,0)


Мельница данных ((раздел целиком))

Мельница данных- Класс TVisualGroupRoutine (Подпрограмма визуальной группы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TVisualGroupRoutine (Подпрограмма визуальной группы)

Диаграмма Класс TVisualGroupItem (Элемент визуальной группы)Класс TObject (Объекты)Класс TVisualGroup (Визуальные группы)

1. Свойства

Свойства класса TVisualGroupRoutine:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TVisualGroupItem
Comment | clob | Нет | Видимо пользователю | Чтение/Запись
Routine | TRoutine | Да | Видимо пользователю | Чтение/Запись | Подпрограмма

2. Конструктор Create (Конструктор подпрограммы визуальной группы)

Конструктор класса TVisualGroupRoutine.

1constructor TVisualGroupRoutine.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Comment: clob;
4  Routine: TRoutine): TObject;

Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TVisualGroupItem.Create
Comment | clob | Нет
Routine | TRoutine | Да | Подпрограмма

Замечания:

Создает новый объект класса TVisualGroupRoutine.


Мельница данных ((раздел целиком))

Мельница данных- Класс TInlineExpression (Встраиваемое выражение) (раздел целиком) (22.10.2024) (одним файлом)
Класс TInlineExpression (Встраиваемое выражение)

Диаграмма Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

1. Свойства

Свойства класса TInlineExpression:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Expression | clob | Нет | Видимо пользователю | Чтение/Запись | Выражение
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Видимо пользователю | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена

2. Конструктор Create (Конструктор встраиваемого выражения)

Конструктор класса TInlineExpression.

1constructor TInlineExpression.Create(Name: string[30];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Expression: clob; Domain: TDomain): TObject;

Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Expression | clob | Нет | Выражение
Domain | TDomain | Да | Домен

Замечания:

Создает новый объект класса TInlineExpression.


Мельница данных ((раздел целиком))

Мельница данных- Класс TUserNotification (Уведомления) (раздел целиком) (22.10.2024) (одним файлом)
Класс TUserNotification (Уведомления)

Диаграмма Класс TObject (Объекты)Класс TUserNotificationAddressee (Адресаты уведомлений)Класс TUserNotificationShown (Показы уведомлений)

1. Свойства

Свойства класса TUserNotification:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Type | TNotificationType | Да | Видимо пользователю | Чтение/Запись | Тип
Text | clob | Нет | Видимо пользователю | Чтение/Запись | Текст
Active | Boolean | Да | Видимо пользователю | Чтение/Запись | Активно
ShowFrom | datetime | Нет | Видимо пользователю | Чтение/Запись | Показывать с
ShowTo | datetime | Нет | Видимо пользователю | Чтение/Запись | Показывать по
Bold | Boolean | Да | Скрыто от пользователя | Только для чтения | Выделено
ShowNeeded | Boolean | Да | Скрыто от пользователя | Только для чтения | Необходимо показывать

2. Конструктор Create (Конструктор уведомления)

Конструктор класса TUserNotification.

1constructor TUserNotification.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Type: TNotificationType; Text: clob;
4  Active: Boolean; ShowFrom: datetime; ShowTo: datetime): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Type | TNotificationType | Да | Тип
Text | clob | Нет | Текст
Active | Boolean | Да | Активно
ShowFrom | datetime | Нет | Показывать с
ShowTo | datetime | Нет | Показывать по

Замечания:

Создает новый объект класса TUserNotification.

3. Метод GetShowNeeded (Необходимо показывать)

Метод экземпляра класса TUserNotification.

function TUserNotification.GetShowNeeded: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4. Метод Preview (Предпросмотр)

Метод экземпляра класса TUserNotification.

procedure TUserNotification.Preview;

Метод не имеет параметров.

5. Метод Shown (Отметить как показанное)

Метод экземпляра класса TUserNotification.

procedure TUserNotification.Shown;

Метод скрыт от пользователя.

Метод не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Класс TCustomView (Абстрактное представление) (раздел целиком) (22.10.2024) (одним файлом)
Класс TCustomView (Абстрактное представление)

Диаграмма Класс TObject (Объекты)Класс TAction (Действия)Класс TRoutineAction (Программируемое действие)Класс TViewAction (Действие-представление)Класс TViewCondition (Условия отбора)Класс TFormViewAction (Действие-форма)

1. Свойства

Свойства класса TCustomView:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
ShownClass | TClass | Да | Видимо пользователю | Чтение/Запись | Класс
ShownClassMasterClass | TClass | Нет | Видимо пользователю | Только для чтения | Класс-мастер показываемого
ShownClassReplicationStatus | TReplicationStatus | Да | Видимо пользователю | Только для чтения | Статус репликации класса
ShownClassIsHierarhical | Boolean | Да | Видимо пользователю | Только для чтения | Иерархическое
Skimpy | Boolean | Да | Видимо пользователю | Чтение/Запись | Количество данных незначительно
BoldProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство выделенного шрифта
PreCompiled | Boolean | Да | Видимо пользователю | Чтение/Запись | Предсобранное
PreOpenRoutine | TRoutine | Нет | Видимо пользователю | Чтение/Запись | Вызывать перед открытием
ColorProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство цвета
OptimizationParameters | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Параметры оптимизации
HasConditions | Boolean | Да | Видимо пользователю | Только для чтения | Имеются условия отбора
HasSpecificalyNamedColumns | Boolean | Да | Видимо пользователю | Только для чтения | Имеет колонки со специфическими именами
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей

2. Конструктор Create (Конструктор абстрактного представления)

Конструктор класса TCustomView.

1constructor TCustomView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
ShownClass | TClass | Да | Класс
ColorProperty | TProperty | Нет | Свойство цвета
BoldProperty | TProperty | Нет | Свойство выделенного шрифта
Skimpy | Boolean | Да | Количество данных незначительно
PreCompiled | Boolean | Да | Предсобранное
PreOpenRoutine | TRoutine | Нет | Вызывать перед открытием

Замечания:

Создает новый объект класса TCustomView.

3. Метод BuildDefaultActions (Создать действия по умолчанию)

Метод экземпляра класса TCustomView.

1procedure TCustomView.BuildDefaultActions(AddConstructor: Boolean;
2  AddDestructor: Boolean; AddMethods: Boolean; AddReports: Boolean;
3  AddCopyPasteActions: Boolean; AddStandartActions: Boolean;
4  PositionStep: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
AddConstructor | Boolean | Да | Добавить конструктор
AddDestructor | Boolean | Да | Добавить деструктор
AddMethods | Boolean | Да | Добавить методы
AddReports | Boolean | Да | Добавить шаблоны отчетов
AddCopyPasteActions | Boolean | Да | Добавить работу с буфером обмена
AddStandartActions | Boolean | Да | Добавить стандартные действия
PositionStep | Integer | Да | Шаг

4. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TCustomView.

procedure TCustomView.CreateContextKey(Storage: string[64]);

Параметры:

Имя | Тип | Обязательно | Значение
Storage | string[64] | Да | Хранилище


Мельница данных ((раздел целиком))

Мельница данных- Класс TOption (Настройки) (раздел целиком) (22.10.2024) (одним файлом)
Класс TOption (Настройки)

Диаграмма Класс TObject (Объекты)Класс TOptionValue (Значения настроек)

1. Свойства

Свойства класса TOption:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Видимо пользователю | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок закладки
Global | Boolean | Да | Видимо пользователю | Чтение/Запись | Глобальная
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок группы
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Value | TOptionValue | Нет | Скрыто от пользователя | Только для чтения | Значение
User | TUser | Нет | Видимо пользователю | Чтение/Запись | Пользователь
VisibleValue | string[2000] | Нет | Видимо пользователю | Только для чтения | Видимое значение
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости

2. Конструктор Create (Конструктор настройки)

Конструктор класса TOption.

1constructor TOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Global: Boolean; Group: string[128]; Tab: string[128];
4  Position: Integer; Scope: TScope): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
Global | Boolean | Да | Глобальная
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Position | Integer | Нет | Позиция
Scope | TScope | Да | Область видимости

Замечания:

Создает новый объект класса TOption.

3. Метод AreValid (Настройки действительны)

Метод класса (статический метод) класса TOption.

class function TOption.AreValid: Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4. Метод GetBlobValue (Значение-большой объект)

Метод класса (статический метод) класса TOption.

class function TOption.GetBlobValue(OptionName: string[64]): blob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа blob.

5. Метод GetBoolValue (Логическое значение)

Метод класса (статический метод) класса TOption.

class function TOption.GetBoolValue(OptionName: string[64]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа Boolean.

6. Метод GetClobValue (Значение-текст)

Метод класса (статический метод) класса TOption.

class function TOption.GetClobValue(OptionName: string[64]): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа clob.

7. Метод GetDateTimeValue (Значение даты со временем)

Метод класса (статический метод) класса TOption.

class function TOption.GetDateTimeValue(OptionName: string[64]): datetime;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа datetime.

8. Метод GetDateValue (Значение даты)

Метод класса (статический метод) класса TOption.

class function TOption.GetDateValue(OptionName: string[64]): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа date.

9. Метод GetExternalDataValue (Значение внешних данных)

Метод класса (статический метод) класса TOption.

1class function TOption.GetExternalDataValue(OptionName: string[64]): <external
2  data>;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа <external data>.

10. Метод GetFloatValue (Вещественное значение)

Метод класса (статический метод) класса TOption.

class function TOption.GetFloatValue(OptionName: string[64]): float;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа float.

11. Метод GetIntValue (Целое значение)

Метод класса (статический метод) класса TOption.

class function TOption.GetIntValue(OptionName: string[64]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа Integer.

12. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TOption.

class function TOption.GetNextPos: Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

13. Метод GetObjectValue (Значение-объект)

Метод класса (статический метод) класса TOption.

class function TOption.GetObjectValue(OptionName: string[64]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа TObject.

14. Метод GetStrValue (Строковое значение)

Метод класса (статический метод) класса TOption.

class function TOption.GetStrValue(OptionName: string[64]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа string[2000].

15. Метод GetTimeValue (Значение времени)

Метод класса (статический метод) класса TOption.

class function TOption.GetTimeValue(OptionName: string[64]): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
OptionName | string[64] | Да | Имя настройки

Замечания:

Возвращает значение типа time.

16. Метод GetValue (Значение)

Метод экземпляра класса TOption.

function TOption.GetValue: TOptionValue;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TOptionValue.

17. Метод SetValue (Установка значения)

Метод экземпляра класса TOption.

1procedure TOption.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>; Default: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
StrValue | string[2000] | Нет | Строковое значение
IntValue | Integer | Нет | Целое значение
FloatValue | float | Нет | Вещественное значение
DateValue | date | Нет | Значение даты
TimeValue | time | Нет | Значение времени
DateTimeValue | datetime | Нет | Значение даты со временем
ObjectValue | TObject | Нет | Значение-объект
BoolValue | Boolean | Нет | Логическое значение
BlobValue | blob | Нет | Значение-большой объект
ClobValue | clob | Нет | Значение-текст
ExternalDataValue | <external data> | Нет | Значение-внешние данные
Default | Boolean | Да | По умолчанию


Мельница данных ((раздел целиком))

Мельница данных- Класс TStringBuilder (Шаблоны строк) (раздел целиком) (22.10.2024) (одним файлом)
Класс TStringBuilder (Шаблоны строк)

Диаграмма

1. Свойства

Свойства класса TStringBuilder:

Имя | Тип | Обязательно | Доступ | Назначение
Template | string[2000] | Нет | Чтение/Запись | Шаблон
TemplateClob | clob | Нет | Чтение/Запись | Шаблон - большой текстовый объект

2. Конструктор Create (Конструктор шаблона строк)

Конструктор класса TStringBuilder.

1constructor TStringBuilder.Create(Template: string[2000];
2  TemplateClob: clob): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Template | string[2000] | Нет | Шаблон
TemplateClob | clob | Нет | Шаблон - большой текстовый объект

Замечания:

Создает новый объект класса TStringBuilder.

3. Метод Append (Добавить строку)

Метод экземпляра класса TStringBuilder.

1function TStringBuilder.Append(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Delimiter | string[2000] | Нет | Разделитель

Замечания:

Возвращает значение типа TStringBuilder.

4. Метод AppendToClob (Добавить строку к большому текстовому объекту)

Метод экземпляра класса TStringBuilder.

1function TStringBuilder.AppendToClob(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Delimiter | string[2000] | Нет | Разделитель

Замечания:

Возвращает значение типа TStringBuilder.

5. Метод Apply (Применить значение)

Метод экземпляра класса TStringBuilder.

1function TStringBuilder.Apply(Name: string[2000];
2  Value: string[2000]): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[2000] | Нет | Имя
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа TStringBuilder.

6. Метод ApplyClob (Применить значение - большой текстовый объект)

Метод экземпляра класса TStringBuilder.

1function TStringBuilder.ApplyClob(Name: string[2000];
2  Value: clob): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[2000] | Нет | Имя
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа TStringBuilder.

7. Метод ApplyObject (Применить свойства объекта)

Метод экземпляра класса TStringBuilder.

function TStringBuilder.ApplyObject(Object: TObject): TStringBuilder;

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Нет | Объект

Замечания:

Возвращает значение типа TStringBuilder.

8. Метод Build (Построить строку)

Метод экземпляра класса TStringBuilder.

function TStringBuilder.Build: string[2000];

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

9. Метод BuildClob (Построить большой текстовый объект)

Метод экземпляра класса TStringBuilder.

function TStringBuilder.BuildClob: clob;

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

10. Метод ClearAll (Очистить все шаблоны строк)

Метод класса (статический метод) класса TStringBuilder.

class procedure TStringBuilder.ClearAll;

Метод является методом класса.

Метод не имеет параметров.

11. Метод ClobApply (Применить значение к большому текстовому объекту)

Метод класса (статический метод) класса TStringBuilder.

1class function TStringBuilder.ClobApply(Template: clob; Name: string[2000];
2  Value: string[2000]): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Template | clob | Нет | Шаблон
Name | string[2000] | Нет | Имя
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа clob.

12. Метод DebugTemplate (Отладить шаблон)

Метод класса (статический метод) класса TStringBuilder.

1class procedure TStringBuilder.DebugTemplate(Template: clob; Names: clob;
2  ApplyResult: clob);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Template | clob | Нет | Шаблон
Names | clob | Нет | Имена
ApplyResult | clob | Нет | Результат применения

13. Метод StrApply (Применить значение к строке)

Метод класса (статический метод) класса TStringBuilder.

1class function TStringBuilder.StrApply(Template: string[2000];
2  Name: string[2000]; Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Template | string[2000] | Нет | Шаблон
Name | string[2000] | Нет | Имя
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Класс TBanGroupAccess (Доступ к группам запретов) (раздел целиком) (22.10.2024) (одним файлом)
Класс TBanGroupAccess (Доступ к группам запретов)

Класс TAccessItem (Элементы доступа)Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Конструктор Create (Конструктор доступа к группе запретов)

Конструктор класса TBanGroupAccess.

1constructor TBanGroupAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TBanGroup; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TBanGroup | Да | Группа запретов
Accessor | TSecurityAccount | Нет | Унаследовано от TObject.Create
SecurityAccount | TSecurityAccount | Да | Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TBanGroupAccess.


Мельница данных ((раздел целиком))

Мельница данных- Класс TViewAction (Действие-представление) (раздел целиком) (22.10.2024) (одним файлом)
Класс TViewAction (Действие-представление)

Класс TAction (Действия)Класс TObject (Объекты)Класс TCustomView (Абстрактное представление)

Объекты класса образуют иерархию.

1. Свойства

Свойства класса TViewAction:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Shortcut | string[20] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TAction
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Separated | Boolean | Да | Видимо пользователю | Чтение/Запись
Default | Boolean | Да | Видимо пользователю | Чтение/Запись
View | TCustomView | Да | Видимо пользователю | Чтение/Запись | Представление
ShownClass | TClass | Да | Видимо пользователю | Только для чтения | Показываемый класс
DetailProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Свойство-подчиненное
MasterProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-главное

2. Конструктор Create (Конструктор действия-представления)

Конструктор класса TViewAction.

1constructor TViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  View: TCustomView; MasterProperty: TProperty;
5  DetailProperty: TClassMember): TObject;

Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TAction.Create
Shortcut | string[20] | Нет
Separated | Boolean | Да
Default | Boolean | Да
View | TCustomView | Да | Представление
MasterProperty | TProperty | Нет | Свойство-главное
DetailProperty | TClassMember | Нет | Свойство-подчиненное

Замечания:

Создает новый объект класса TViewAction.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IIntegerInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IIntegerInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

01type
02  IIntegerInfo = interface(ITypeInfo)
03    ['{9003B25E-926D-42AE-A907-813DF3A8343E}']
04    function Get_MaxValue: Integer; safecall;
05    function Get_MaxValueUsed: WordBool; safecall;
06    function Get_MinValue: Integer; safecall;
07    function Get_MinValueUsed: WordBool; safecall;
08    property MaxValue: Integer read Get_MaxValue;
09    property MaxValueUsed: WordBool read Get_MaxValueUsed;
10    property MinValue: Integer read Get_MinValue;
11    property MinValueUsed: WordBool read Get_MinValueUsed;
12  end;

1. Свойства

Свойства интерфейса IIntegerInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
MaxValue | Integer | Только для чтения |
MaxValueUsed | WordBool | Только для чтения |
MinValue | Integer | Только для чтения |
MinValueUsed | WordBool | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Класс TTypedValueView (Представления на форме редактирования значений) (раздел целиком) (22.10.2024) (одним файлом)
Класс TTypedValueView (Представления на форме редактирования значений)

Класс TFormView (Представления формы)Класс TObject (Объекты)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

1. Свойства

Свойства класса TTypedValueView:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TFormView
ChildrenMinimized | Boolean | Да | Видимо пользователю | Чтение/Запись
MasterProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
DetailProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись
View | TCustomView | Да | Видимо пользователю | Чтение/Запись
BoldProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
ShownClass | TClass | Да | Видимо пользователю | Только для чтения
ColorProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
Layout | TFormViewLayout | Да | Видимо пользователю | Чтение/Запись
ChildrenOnTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
ExplicitQuery | Boolean | Да | Видимо пользователю | Чтение/Запись
SpacePercentage | Integer | Нет | Видимо пользователю | Чтение/Запись
TypedValue | TTypedValue | Нет | Видимо пользователю | Чтение/Запись | Связанное типизированное значение
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись | Идентификатор связанного типизированного значения
ViewName | string[64] | Да | Видимо пользователю | Чтение/Запись | Идентификатор элемента управления

2. Конструктор Create (Конструктор представления на форме редактирования значений)

Конструктор класса TTypedValueView.

1constructor TTypedValueView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout; ExplicitQuery: Boolean;
6  TypedValue: TTypedValue): TObject;

Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
View | TCustomView | Да | Унаследовано от TFormView.Create
ChildrenMinimized | Boolean | Да
ChildrenOnTabs | Boolean | Да
MasterProperty | TProperty | Нет
DetailProperty | TClassMember | Нет
Position | Integer | Да
SpacePercentage | Integer | Нет
Layout | TFormViewLayout | Да
ExplicitQuery | Boolean | Да
TypedValue | TTypedValue | Нет | Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueView.


Мельница данных ((раздел целиком))

Мельница данных- Класс TParameter (Параметры) (раздел целиком) (22.10.2024) (одним файлом)
Класс TParameter (Параметры)

Диаграмма Класс TObject (Объекты)Класс TRoutine (Подпрограмма)

1. Свойства

Свойства класса TParameter:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
RoutineClass | TClass | Нет | Видимо пользователю | Только для чтения | Класс подпрограммы
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Видимо пользователю | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок закладки
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок группы
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
InitializationMember | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Инициализируется членом класса
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись | За пределами закладок
Override | Boolean | Да | Видимо пользователю | Только для чтения | Переопределен
LinkedView | TParametersFormView | Нет | Видимо пользователю | Чтение/Запись | Связанное представление
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись | Протоколировать

2. Конструктор Create (Конструктор параметра)

Конструктор класса TParameter.

1constructor TParameter.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; InitializationMember: TClassMember; OutOfTabs: Boolean;
5  LinkedView: TParametersFormView; Logged: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Имя
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
InitializationMember | TClassMember | Нет | Инициализируется членом класса
OutOfTabs | Boolean | Да | За пределами закладок
LinkedView | TParametersFormView | Нет | Связанное представление
Logged | Boolean | Да | Протоколировать

Замечания:

Создает новый объект класса TParameter.

3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TParameter.

class function TParameter.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.

4. Метод GetOverride (Переопределен)

Метод экземпляра класса TParameter.

function TParameter.GetOverride: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Мельница данных ((раздел целиком))

Мельница данных- Положения и определения (раздел целиком) (22.10.2024)

(одним файлом)

Положения и определения

1. Работа с типами данных

1.1. Домены

2. Язык PascalScript

На языке PascalScript на платформе "Мельница данных" описываются тела методов и выражения. Выражения используются в условиях отбора объектов определенного класса при их отображении в представлениях, а также как встраиваемые выражения, которые могут служить членами класса для чтения свойств.

Здесь и далее зарезервированные слова выделены жирным шрифтом.

2.1. Структура программного блока тела метода
1  [Описание переменных]
2  begin
3    //Операторы
  end;
Комментарии расположены между символами { и } либо от символов // до конца строки.

2.2. Описание переменных
1var
2    Имя переменной[, Имя переменной…]: Тип;
3    Имя переменной[, Имя переменной…]: Тип;
4    ...
Имя переменной должно быть идентификатором (последовательность символов a-z, A-Z, 0-9, _). "Тип" может быть одним из следующих:

integer - определяет переменные целочисленного типа;

string[целое_число] - определяет переменные строкового типа с заданной максимальной длиной; максимальная длина задается в квадратных скобках и обязательна для задания;

float - определяет переменные вещественного типа;

date - определяет переменные типа "дата";

time - определяет переменные типа "время";

datetime - определяет переменные типа "дата со временем";

boolean - определяет переменные логического типа;

blob - определяет переменные типа больших двоичных объектов;

Имя класса - определяет переменные-ссылки на экземпляры соответствующих классов;
1  var
2   I: integer;
3   LSomeObject: TObject;
4   LStart, LStop: datetime;
   LNewName: string[64];
2.3. Операторы PascalScript

Операторы разделяются точкой с запятой (;). Операторы могут быть одним из следующих:

2.3.1. Составной оператор
1begin
2  //Другие операторы
end
Операторы, размещенные внутри составного оператора, разделяются точкой с запятой. Никаких ограничений на состав операторов и количество уровней вложенности не накладывается.
1begin
2  Result := LCurrentValue;
3  Exit;
4end;
2.3.2. Оператор присваивания
Выражение1 := Выражение2
Присваивает значение выражения Выражение2 выражению Выражение1. Типы Выражения1 и Выражения2 должны быть совместимы (совпадать по классу домена либо оба быть числовыми). Для этого на Выражение1 (стоящее слева от знака равенства, lvalue) накладывается ряд ограничений. Это выражение должно быть:

Полем или свойством экземпляра класса

Локальной переменной

Параметром

Зарезервированной переменной Result
LObject.Name := 'Новое имя';
Result := 25;
LStartTime := StrToDateTime('01.01.2006 00:00:30');
01var
02  LObject: TObject;
03  LClass: TClass;
04  I: Integer;
05  F: Float;
06begin
07  I := F;  //неверно
08  F := I;  //верно
09  LObject := LClass; //верно
10  LClass := LObject; //неверно. Должно быть LClass := (LObject as TClass);
11end;
2.3.3. Оператор вызова
ИмяПроцедуры [(Параметр1, Параметр2 ...)]
"ИмяПроцедуры" должно быть:

Именем метода класса и вызываться с указанием класса либо экземпляра;

Именем метода экземпляра и вызываться с указанием экземпляра;

Именем метода своего класса либо предка и вызываться без указания спецификаторов.

Порядок и количество параметров в операторе вызова должны строго совпадать с описанием метода.
1  //метод класса, указан класс
2  LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3
4  //метод экземпляра, указан экземпляр. Метод не имеет параметров.
5  LList.Destroy;
6
7  //свой либо унаследованный метод
8  BuildDefaultActions(Name, True);
2.3.4. Оператор ветвления
1if Выражение then
2  //Оператор1
3[else
4  //Оператор2]
Выражение должно быть логического типа. В случае если значение Выражения истинно, выполняется Оператор1. Часть else является необязательной и относится к последнему оператору if, не имеющему таковой. В случае ее наличия Оператор2 выполняется, если значение Выражения ложно.
1if LIndex > 25 then
2  raise 'Индекс слишком большой.';
1if LMonth = 'январь' then
2  January
3else if LMonth = 'февраль' then
4  February
5else
6  OtherMonth;  //обратите внимание на точки с запятой.
2.3.5. Оператор выбора
1case Выражение of
2  Значение1: //Оператор1
3  Значение2: //Оператор2
4  ...
5[else
6  //Оператор ]
end
Заменяет каскад операторов if. Значение Выражения должно быть числового типа. Часть else выполняется в случае, если Выражение не равно ни одному из перечисленных вариантов. Эта часть не является обязательной.
1сase LIndex of
2  0: ZeroIndex;
3  1,2,3: SmallIndex;
4  4,5,6,7,8,9,10: BigIndex;
5else
6  raise 'Слишком большой или отрицательный индекс.';
7end;
2.3.6. Цикл с предусловием
1while Выражение do
2  //Оператор
Оператор выполняется до тех пор, пока значение Выражения истинно. Выражение должно быть логического типа. Если при входе в цикл Выражение не истинно, то тело цикла не будет выполнено ни одного раза.
01while LList.Count > 0 do
02  LList.GetItem(0).Destroy;
03
04while True do
05begin
06  LValue := LValue.NextValue;
07  if LValue.Value > 10 then
08  begin
09    Result := LValue.Value;
10    exit;
11  end;
12end;
2.3.7. Цикл с постусловием
1repeat
2  //Операторы
3until Выражение
Операторы выполняются до тех пор, пока значение Выражения ложно. Выражение должно быть логического типа. Обратите внимание, что внутри себя оператор может содержать несколько операторов, разделенных точкой с запятой. Тело цикла обязательно будет выполнено хотя бы один раз.
1repeat
2  Result := Result + 1;
3  LObject := LObject.Parent;
4until LObject = nil;
2.3.8. Цикл с параметром
1for Параметр := Выражение1 (to|downto) Выражение2 do
2  //Оператор
Параметр цикла обязан быть простой локальной переменной. Функционально цикл с параметром эквивалентен циклам:

Для формы to
1Параметр := Выражение1;
2while Параметр <= Выражение2 dobegin
3  Оператор;
4  Параметр :=  Параметр + 1;
end;
Для формы downto
1Параметр := Выражение1;
2while Параметр >= Выражение2 dobegin
3  Оператор;
4  Параметр :=  Параметр - 1;
end;
Если Выражение1 равно Выражению2, тело цикла будет выполнено один раз.
1for I := LList.Length - 1 downto 0 do
2// если LList.Length = 0, тело цикла ни разу не будет выполнено.
3begin
4  LClass := LList.GetItem(I);
5  LMethod := any(TMethod with (Name = LName) and (Master = LClass));
6  LParamList.Add(any(TMethod with (Name = LName) and (Master = LClass)));
7end;
2.3.9. Цикл по экземплярам
1for each Параметр of ИмяКласса [with Выражение]
2  [by [-] Выражение [, [-] Выражение]] do
3    //Оператор
Цикл осуществляется по выборке среди экземпляров класса ИмяКласса, для которых истинно Выражение. Если Выражение не задано, то по всем экземплярам. Ссылка на текущий в рамках цикла экземпляр присваивается в локальную переменную Параметр. Выражение должно определяться относительно переменной Параметр. Выраженния, следующие за ключевым словом by, определяют порядок обхода экземпляров. Знак "-" перед выражением (любого типа) определяет обратный порядок обхода.
1for each LOption of TOption with LOption.Domain.Required do
2    // для каждой настройки, домен которой обязателен
3  LOption.SetDefaultValue;
2.3.10. Оператор прекращения цикла
break
Происходит немедленный выход из цикла. Выполняется финализация операторов защиты завершения, которыми защищено тело цикла. Допустим только в теле цикла с предусловием, цикла с постусловием, цикла с параметром или цикла по экземплярам.

2.3.11. Оператор выхода из подпрограммы
exit
Происходит немедленный выход из программного блока. Выполняется финализация операторов защиты завершения.

2.3.12. Оператор защиты завершения
1try
2  //Операторы1
3finally
4  //Операторы2
end
Выполняются операторы Операторы1, разделенные точкой с запятой. В случае возникновения исключительной ситуации управление сразу передается на Операторы2, и после их выполнения исключение остается активным. Если исключения не произошло, выполняются Операторы2. Если среди Операторов1 встречается оператор exit, то Операторы2 все равно выполняются.
1//создание временного объекта-списка
2LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3try
4  LList.Add(LValue);
5  Exit;
6finally
7  //гарантированное уничтожение созданного объекта независимо от исключений.
8  LList.Destroy;
9end;
2.3.13. Оператор обработки исключительных ситуаций
1try
2  //Операторы1
3except
4  //Операторы2
end
Выполняются операторы Операторы1. В случае возникновения исключительной ситуации управление передается на Операторы2. Если исключительных ситуаций не возникло, Операторы2 не выполняются никогда. При передаче управления на Операторы2 исключительная ситуация деактивирована. Для ее повторного возбуждения можно воспользоваться оператором возбуждения исключения без указания текстовой строки сообщения.
1try
2  LObject.NeverTouch := True;
3  LObject.ExecuteCoolMethod; //если метод выполнен неудачно
4except
5  LObject.NeverTouch := True;  //установить флаг и ничего не сообщать пользователю.
6end;
1try
2   LObject.ExecuteCoolMethod; //если метод выполнен неудачно
3except
4   LObject.Destroy; //удалить неудачный объект
5   raise;           // продолжить обработку исключения.
6end;
2.3.14. Оператор возбуждения исключения
raise [Выражение]
Возбуждает исключение, которое, если не было обработано блоком except оператора обработки, дойдет до пользователя. Пользователь увидит сообщение, определяемое Выражением. Выражение должно иметь строковый тип и является обязательным для всех случаев, кроме части except оператора обработки исключений.

2.3.15. Оператор унаследованного вызова
inherited
Работает только в унаследованном переопределенном методе. Вызывается метод предка с параметрами, заданными в параметрах к моменту вызова. Если программный блок представляет собой тело функции, то в псевдопеременной Result будет результат выполнения метода предка.
1// в теле конструктора
2Name := 'Object name';
3Description := 'Object description';
4inherited; //вызов предка с параметрами Name и Description,
5           //заданными двумя предыдущими операторами. Ссылка на
6           //созданный объект лежит в
7           //псевдопеременной Result
8Result.Name := 'New name';
2.4. Выражения и операции

2.4.1. Состав выражения

Любое выражение имеет тип. Выражения состоят из следующих элементов:

Целая числовая константа (0 3 234);

Вещественная числовая константа. Дробная часть отделяется от целой точкой (".") (3.14 2.71);

Строковая константа. Заключается в апострофы. ('Some string' '10', '01.01.2006' 'now');

Логическая константа (True False);

Безтиповая (любого типа) константа nil;

Зарезервированное слово Self. Обозначает разный объект в зависимости от контекста:

В методах класса кроме конструктора - использование запрещено.

В методах экземпляра - всегда экземпляр, для которого вызван метод.

В конструкторе - до вызова унаследованного метода значение не определено. После вызова - ссылка на сконструированный объект.

В выражениях условий отбора - объект, для которого принимается решение о его вхождении в отбор.

Квалификатор.

Агрегат.

2.4.2. Квалификатор

Квалификатор обозначает объект, переменную, параметр, свойство, поле, вызов функции. Квалификатор состоит из идентификаторов, разделенных точкой.

Result

AName

Caption

LObject.Name

LObject.Parent.Name

LObject.ChildCount

LObject.HasAsParent(LOtherObject)

При интерпретации квалификатора используется следующий порядок разбора идентификатора:

Контекстная переменная (для выражений условий отбора доменов)

Локальная переменная

Параметр

Имя элемента перечисления

Имя класса. Вне контекста означает ссылку на соответствующий объект класса TClass

Имя поля

Имя метода

Имя свойства

При интерпретации квалификатора внутри выражения агрегата правила разбора идентификатора изменяются:

Контекстная переменная (для выражений условий отбора доменов)

Имя элемента перечисления

Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту

Имя поля

Имя метода

Имя свойства

Локальная переменная

Параметр

2.4.3. Агрегат

Агрегат определяет агрегированное значение над экземплярами определенного класса, удовлетворяющими условиям агрегации. Агрегаты бывают следующих типов:

any - первый попавшийся объект. Результат имеет тип ссылки на объект агрегируемого класса.
1any(TObject with Master = Self.Parent)
2//первый попавшийся объект, имеющий значение
3//свойства Master равным значению свойства
4//Parent текущего (контекстного) объекта.
count - количество объектов. Результат имеет целочисленный тип.
1count(TObject with Master = Self.Parent)
2//количество объектов, имеющих значение свойства
3//Master равным значению свойства Parent
4//текущего объекта.
sum - сумма значений свойства, поля или функции объектов. Результат имеет тип суммируемого поля, свойства или функции
1sum(TExam.Mark with Master = LStudent) //сумма
2//баллов студента по его испытаниям
max, min - соответственно максимальное и минимальное значений свойства, поля или функции объектов. Результат имеет тип агрегируемого поля, свойства или функции
1min(TObject.Created) // момент создания первого
2//объекта Системы.
Внутри выражения агрегата правила разбора идентификатора изменяются на следующие:

Контекстная переменная (для выражений условий отбора доменов)

Имя элемента перечисления

Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту

Имя поля

Имя метода

Имя свойства

Локальная переменная

Параметр

2.4.4. Операции

Операции связывают элементы выражений.

Таблица операций в порядке приоритета:

Левый
операнд

Правый операнд

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

not

Нет

Логи-
ческий

* (звездочка)

Целый

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

/ (слэш, дробь)

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

div

Целый

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

and

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Логи-
ческий

Строковый

Объект

nil

or

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Логи-
ческий

Строковый

Объект

nil

+ (плюс)

Целый

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Дата

Дата со временем

Дата со временем

Время

Время

Время

Дата со временем

Время

Дата со временем

Дата со временем

Дата со временем

Дата со временем

Дата со временем

Логи-
ческий

Строковый

Строковый

Объект

nil

- (минус)

Целый

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Дата

Дата со временем

Целый

Дата со временем

Вещест-
венный

Время

Время

Время

Дата со временем

Время

Дата со временем

Дата со временем

Дата со временем

Дата со временем

Вещест-
венный

Дата со временем

Вещест-
венный

Логи-
ческий

Строковый

Объект

nil

=, <> (равно, не равно)

Целый

Логи-
ческий

Логи-
ческий

Логи-
ческий

Вещест-
венный

Логи-
ческий

Логи-
ческий

Логи-
ческий

Дата

Логи-
ческий

Логи-
ческий

Логи-
ческий

Время

Логи-
ческий

Логи-
ческий

Дата со временем

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Строковый

Логи-
ческий

Логи-
ческий

Объект

Логи-
ческий

Логи-
ческий

nil

Логи-
ческий

<, >, <=, >= (меньше, больше, меньше либо равно, больше либо равно)

Целый

Логи-
ческий

Логи-
ческий

Вещест-
венный

Логи-
ческий

Логи-
ческий

Дата

Логи-
ческий

Логи-
ческий

Время

Логи-
ческий

Дата со временем

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Строковый

Логи-
ческий

Объект

nil

is

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

Логи-
ческий

nil

as

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

Объект

nil

2.4.4.1. Особенности применения операций

Приоритет сравнений ниже приоритета операций булевой логики. Поэтому выражение
LObject.Master = LMaster and LObject.Parent = LParent
будет интерпретироваться следующим образом:
LObject.Master = (LMaster  and LObject.Parent) = LParent
и вызовет ошибку компиляции из-за применения операции and к объектам. Необходимо писать:
(LObject.Master = LMaster) and (LObject.Parent = LParent)
Любое значение (выражение любого типа) сравнивается с безтиповой константой nil:
1      LObject := any(TObject with Name = 'Some name');
2      if LObject = nil then
3         .....
Операции "Унарный минус" не существует. Для задания отрицательных констант пользуйтесь конструкцией 0-Значение:
Result := 0-1;
2.5. Формальная грамматика
001Goal: MethodBody | Expression;
002
003MethodBody: [ConstantDeclaration] [VariableDeclaration] CompoundStatement ";";
004
005ConstantDeclaration: "const" Ident ":" DomainSpecification ";"
006  [{Ident ":" DomainSpecification ";"}];
007
008VariableDeclaration: "var" DomainDefinition [{DomainDefinition}];
009
010DomainDefinition: Ident ":" DomainSpecification ";";
011
012DomainSpecification: IntegerDomainDefinition
013  | StringDomainDefinition
014  | FloatDomainDefinition
015  | DateDomainDefinition
016  | TimeDomainDefinition
017  | DateTimeDomainDefinition
018  | BooleanDomainDefinition
019  | BlobDomainDefinition
020  | EnumerationDomainDefinition
021  | Ident;
022
023IntegerDomainDefinition: "integer";
024StringDomainDefinition: "string" "[" Number "]";
025FloatDomainDefinition: "float" ["(" Number ["." Number] ")"];
026DateDomainDefinition: "date";
027TimeDomainDefinition: "time";
028DateTimeDomainDefinition: "datetime";
029BooleanDomainDefinition: "boolean";
030BlobDomainDefinition: "blob" | "clob";
031EnumerationDomainDefinition: "(" Ident {"," Ident} ")";
032
033CompoundStatement: "begin" Statement [{";" Statement}] "end";
034
035Statement:
036  | CompoundStatement
037  | AssignmentStatement
038  | InheritedStatement
039  | CallStatement
040  | IfStatement
041  | CaseStatement
042  | ForStatement
043  | WhileStatement
044  | RepeatStatement
045  | TryFinallyStatement
046  | TryExceptStatement
047  | RaiseStatement
048  | ForEachStatement
049  | ExitStatement;
050
051AssignmentStatement:  Qualifier ":=" Expression;
052
053CallStatement: Qualifier;
054
055InheritedStatement: "inherited";
056
057IfStatement: "if" Expression "then" Statement ["else" Statement];
058
059CaseStatement: "case" Expression "of" {CaseBranch} ["else" Statement ";"] "end";
060
061CaseBranch: CaseLabel [{',' CaseLabel}] ":" Statement ";";
062
063CaseLabel: Number | Ident;
064
065ForStatement: "for" Ident ":=" Expression ("to"|"downto")
066  Expression "do" Statement;
067
068WhileStatement: "while" Expression "do" Statement;
069
070RepeatStatement: "repeat" Statement [{";" Statement}] "until" Expression;
071
072TryFinallyStatement: "try" Statement [{";" Statement}] "finally"
073  Statement [{";" Statement}] "end";
074
075TryExceptStatement: "try" Statement [{";" Statement}] "except"
076  Statement [{";" Statement}] "end";
077
078RaiseStatement: "raise" [Expression];
079
080ForEachStatement: "for" "each" Ident "of" Ident ["with" Expression]
081  ["by" Expression] "do" Statement;
082
083ExitStatement: "exit";
084
085Expression: ComparedExpression [{RelationOperation Expression}];
086
087ComparedExpression: Addon [{AdditionOperaton ComparedExpression}];
088
089Addon: Factor [{MultiplicativeOperation Addon}];
090
091Factor: "(" Expression ")"
092  | "not" Expression
093  | Number ["." Number]
094  | StringConstant
095  | Qualifier
096  | "nil"
097  | "True"
098  | "False"
099  | "(" Expression "is" Ident ")"
100  | "any" Aggregate
101  | "count" Aggregate
102  | "sum" Aggregate
103  | "max" Aggregate
104  | "min" Aggregate;
105
106Aggregate: "(" Ident ["." Ident] ["with" Expression] ")";
107
108Qualifier: QualifierPart [{"." QualifierPart}];
109
110QualifierPart: Ident ["(" Expression [{", " Expression}] ")"]
111  | "self"
112  | "(" Qualifier "as" Ident ")";
113
114RelationOperation: "<"
115  | ">"
116  | "<="
117  | ">="
118  | "="
119  | "<>";
120
121AdditionOperaton: "+"
122  | "-"
123  | "or";
124
125MultiplicativeOperation: "*"
126  | "/"
127  | "div"
128  | "and";
2.6. Соглашения

2.6.1. Соглашения о наименованиях

В качестве вводимых (объявляемых) идентификаторов необходимо использовать так называемую нотацию InfixCaps. Если при создании имени используется несколько слов, то необходимо использовать заглавную букву для каждого слова в имени. Для разделения слов нельзя использовать символ подчеркивания. Все сущности именуются на английском языке, при этом использование сокращений является оправданным только в случае, если длина образуемого имени не согласуется с внешними по отношению к соображениям бизнес-логики ограничениям.

Имя класса должно начинаться с латинской буквы 'T'.

Имя

Наименование

TObjectList

Список объектов

TLearnPlan

Учебный план

Имя поля должно начинаться с латинской буквы 'F'.

Имя

Наименование

FLearnPeriod

Период обучения

FExamMark

Оценка за экзамен

Имя свойства не имеет префикса.

Имя

Наименование

ExamKind

Вид рубежного испытания

ContactPhone

Контактный телефон

Если членом класса для чтения свойства является поля, то имя свойства должно повторять имя поля без префикса 'F'. Если членом класса для чтения свойства является метод, то имя поля должно повторять имя метода без слова 'Get'.

Имя параметра не имеет префикса.

Имя

Наименование

OrderNumber

Номер приказа

ExamDate

Дата проведения экзамена

Параметры, используемые для инициализации значений полей, должны иметь имя, повторяющее имя поля без префикса 'F'. При компиляции тела метода, написанного на языке PascalScript имена параметров и имена свойств будут распознаваться в соответствии с порядком разбора идентификаторов, как это описано здесь и здесь.

Имена методов должны представлять собой императивный глагол на английском языке, выражающий смысл того, что метод делает. Имена методов не имеют префикса. Имена методов, используемых для получения значений свойств должны (как члены класса для чтения), должны начинаться со слова Get. Имена методов, используемых для установки значений свойств должны (как члены класса для записи), должны начинаться со слова Set.

Имя

Наименование

CountMarkSumm

Вычислить сумму баллов

GetAge

Получить значение возраста

SetMark

Установить значение оценки

Имена локальных переменных должны начинаться с латинской буквы 'L'.

LMarkSumm (сумма баллов), LObjectCount (количество объектов).

Имена доменов должны начинаться с латинской буквы 'T'. В именах доменов допустимы пробелы. Рекомендуется к имени домена добавлять слово 'domain' (через пробел), а для обязательных доменов 'required domain' (через пробел) тогда, когда необходимо исключить возможность использования этих доменов в текстах на PascalScript. Первым словом в имени домена-ссылки должно быть имя класса домена. Исключением являются имена доменов, соответствующих простым типам данных без дополнительных ограничений. Имена таких доменов могут повторять имена типов языка PascalScript (Integer, Boolean, Float).

Имя

Класс домена

Наименование

TPrice domain

Вещественный

домен Цена

TWeight required domain

Целочисленный

домен Вес (обязательный)

Boolean

Логический

Логический

TClassMember required domain

Ссылка

домен Член класса

Имена элементов перечислений должны иметь префикс из двух или трех символов, идентифицирующий соответствующий домен-перечисление. Префикс записывается строчными буквами. Например,

Имя

Наименование

для домена TExamKind (вид испытания)

ekTest

зачет

ekExam

экзамен

ekDifTest

дифференцированный зачет

для домена TAggregateKind (вид агрегата)

agCount

количество

agSumm

сумма

agAverage

среднее значение

Настоятельно рекомендуется давать уникальные имена элементов перечислений в пределах всей системы.

2.6.2. Стилевое оформление исходного кода

Код на языке PascalScript, являющийся частью поставляемого решения, должен быть оформлен в соответствии с изложенными правилами.

2.6.2.1. Использование строк, пробелов и отступов

Пустые строки могут повысить читабельность путем группирования секций кода, которые логически связаны между собой.

Пробелы, запрещенные к использованию:

До или после точки "."

Между именем вызываемого метода и открывающей скобкой "("

После открывающей скобки "(" или перед закрывающей ")"

Перед точкой с запятой ";"

Перед двоеточием ":"

Перед запятой ","

Двоеточие для всех объявлений переменных не должно содержать перед собой пробелов и иметь один пробел после перед именем типа.

Всегда необходимо использовать два пробела для всех уровней отступа. Другими словами, первый уровень отступает на два пробела, второй на четыре и так далее. Никогда не используйте символы табуляции.

Существует несколько исключений из этого правила. Зарезервированные слова var, begin и end, относящиеся к программному блоку вцелом, всегда должны примыкать к левой границе. Код внутри блока begin..end должен иметь отступ два символа.

Все строки должны быть ограничены 80 столбцами. Строки, длиннее чем 80 столбцов должны быть разделены и перенесены. Все перенесенные строки должны быть выровнены по первой строке и иметь отступ в два символа. Зарезервированное слово begin всегда должно находиться на своей отдельной строке.

Нельзя переносить строки в тех местах, где не допускаются пробелы, например между именем метода и открывающей скобкой. Никогда нельзя помещать зарезервированное слово begin на строку, содержащую другой код.

2.6.2.2. Оформление объявлений и операторов

Все переменные с их типами должны быть объявлены на различных строках.

Простые операторы содержат одну точку с запятой. Если Вам необходимо разделить оператор, то перенесите продолжение оператора на следующую строку с отступом в два пробела.
  MyValue :=
    MyValue + (SomeVeryLongStatement / OtherLongStatement);
Составные операторы всегда заканчиваются точкой с запятой.
1begin
2  MyStatement;
3  MyNext Statement;
4  MyLastStatement;
end;
Каждое присвоение и каждое выражение должно располагаться на разных строках.

Оператор "if"
Оператор if всегда должен располагаться по крайней мере на двух строках
if A < B then DoSomething;
if A < B then
  DoSomething;
В случае составного оператора необходимо поместить каждый оператор на новую строку.
1  if A < B then begin
2    DoSomething;
3    DoSomethingElse;
4  end else begin
5    DoThis;
6    DoThat;
7  end;
1  if A < B then
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end
6  else
7  begin
8    DoThis;
9    DoThat;
  end;
Все остальные варианты расположения операторов не рекомендуются и не одобряются, хотя и являются синтаксически правильными.
Оператор "for"
1  for i := 0 to 10 do begin
2    DoSomething;
3    DoSomethingElse;
4  end;
1  for i := 0 to 10 do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  for I := 0 to 10 do
8    DoSomething;
Оператор "while"
1  while x < j  do begin
2    DoSomething;
3    DoSomethingElse;
  end;
1  while x < j do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  while x < j do
8    Something;
Оператор "repeat..until"
1  repeat
2    x := j;
3    j := UpdateValue;
4  until j > 25;
Оператор "case"
Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01  case LCode of
02    1, 3:
03      begin
04        Incr := FIncrement + 1;
05        FinalIncr := FIncrement div FLineDiv;
06        Count := FLineDiv;
07      end;
08    2, 4:
09      begin
10        Incr := FPageIncrement;
11        FinalIncr := Incr + 1;
12        Incr := Incr div FPageDiv;
13        Count := FPageDiv;
14      end;
15  else
16    begin
17      Count := 0;
18      Incr := 0;
19      FinalIncr := 0;
20    end;
  end;
Оператор "try"
Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01try
02  try
03    EnumItems(CurrentThreadID, LDisable, 0);
04    Result := TaskList;
05  except
06    EnableItems(TaskList);
07    raise;
08  end;
09finally
10  TaskList := SaveList;
11  TaskActive := SaveActive;
end;
3. Интерфейсы взаимодействия с внешними подсистемами

Системный слой платформы "Мельница данных" предоставляет сторонним системам ряд интерфейсов, дающих возможность обращаться к объектам базы данных и их свойствам, вызывать методы классов и объектов, осуществлять запросы к базе данных, управлять поведением элементов управления и проч.

3.1. Интерфейс IContext
01  IContext = interface(IDispatch)
02    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
03    function Handle: Integer;
04    function getName(ID: OleVariant): WideString;
05    function getDescription(ID: OleVariant): WideString;
06    function createDataSet(const TargetClassName: WideString):
07      IContextDataSet;
08    function executeMethod(const ClassName: WideString;
09      const MethodName: WideString;
10      Params: OleVariant): OleVariant;
11    function executeReport(const ClassName: WideString;
12      const TemplateName: WideString;
13      Params: OleVariant): IDispatch;
14    function getPropValue(const ClassName: WideString;
15      const PropName: WideString;
16      const ID: OleVariant): OleVariant;
17    procedure setPropValue(const ClassName: WideString;
18      const PropName: WideString;
19      const ID: OleVariant; Value: OleVariant);
20    function select(const ClassName: WideString;
21      QueryItems: OleVariant): IDispatch;
22    function enumerationItem(ItemIdentifier: OleVariant): WideString;
23    function getClass(const ClassName: WideString): WideString;
24    function createGUID: WideString;
25    procedure processStart(const Description: WideString;
26      ItemCount: Integer);
27    procedure processStep;
28    procedure processStop;
29    function PlaceDataSet(const Range: IDispatch;
30      const DataSet: IContextDataSet;
31      ShiftRows: WordBool; ShiftColumns: WordBool): Integer;
32    procedure DebugString(const Message: WideString);
33    procedure ExportObject(var Document: OleVariant; const ID: WideString;
34      const ClassID: WideString);
35    function callRoutine(const ClassName, RoutineName: WideString;
36      var RetValue: OleVariant; const ScriptPart: OleVariant): WordBool;
37    function getOleObject(const ClassID, AccessibleFileName: WideString): IDispatch;
38    function getResource(const Name: WideString): WideString;
39    function getTempFileName(const Extension: WideString): WideString;
40    function selectVaue(const ClassDomain: WideString;
41      const ExpressionContext: IContextExpressionInfo;
42      var Value: OleVariant): WordBool;
43    procedure raiseManagedException(const ExceptionMessage: WideString);
44    function getCRC(Data: OleVariant): WideString;
45    function downloadData(const Host: WideString; const Url: WideString;
46      const UserName: WideString; const Password: WideString;
47      NegotiateAuth: WordBool; PostData: OleVariant;
48      const PostContentType: WideString; PostDataIsBinary: WordBool;
49      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;
50    function createBinaryData: IDispatch;
51    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
52    function editValues(const ValuesList: WideString; const Title: WideString;
53      UseTabs: WordBool; HideOKButton: WordBool;
54      const ScriptPart: OleVariant): WordBool;
55    function MsgBox(const Prompt: WideString; Buttons: LongWord;
56      const Title: WideString;
57      const HelpFile: WideString; Context: LongWord): Integer;
58    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
59      const Title: WideString;
60      const HelpFile: WideString; Context: LongWord): Integer;
61    function buildNamedFile(const Data: IDispatch; const StoredFileName: WideString;
62                            Propmpt: WordBool; Compress: WordBool): IDispatch;
63    procedure parseNamedFile(const NamedFile: IDispatch; out FileName: OleVariant;
64                             out Data: OleVariant);
65    procedure showView(const ViewName: WideString; Key: OleVariant;
66                       const DetailPropertyName: WideString);
67    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
68                          ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
69                          TakeActionsFromView: OleVariant);
70    function executeConsoleProcess(const CommandLine: WideString; MaxDuration: Integer;
71                                   const OutputData: OleVariant): Integer;
72    function createRaster: IDispatch;
73    function createZIPArchive: IDispatch;
74    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch;
75    property ContextObject: IDispatch;
76    property Language: WideString;
77    property UserName: WideString;
78    property NegotiateAuth: WordBool;
79    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant;
80  end;
Члены интерфейса доступны для использования в скриптах форм задания параметров, а также в отчетах как члены класса передаваемого контекстного объекта.

Функция Handle возвращает дескриптор главного окна приложения.

Функция getName возвращает имя объекта по его идентификатору.

Функция getDescription возвращает наименование объекта по его идентификатору.

Функция createDataSet создает набор данных, основанный на экземплярах класса, имя которого передано как параметр. Возвращаемый объект реализует интерфейс IContextDataSet.

Функция executeMethod осуществляет вызов метода с параметрами. Имя класса передается в параметре ClassName, имя вызываемого метода - в параметре MethodName. Если вызываемый метод явяется функцией, то результат ее выполнения возвращается как результат вызова executeMethod. Параметры вызова метода передаются через параметр Params следующим образом:

Для методов класса без параметров можно передавать любое значение, например, Null.

Для методов класса, имеющих один параметр, значение Params есть значение этого единственного параметра.

Для методов класса, имеющих более одного параметра, значение Params есть массив значений параметров.

VBScript, VBA

LValue = executeMethod("TObject", "Round", Array(10.24, 1))

JScript

LValue = executeMethod("TObject", "Round", new Array(10.24, 1));

Object Pascal

LValue := executeMethod('TObject', 'Round', VarArrayOf([10.24, 1]));

Для методов экземпляра без параметров значение Params есть идентификатор объекта, для которого вызывается метод.

Для методов экземпляра, имеющих параметры, значение Params есть массив значений параметров. При этом первым элементом массива является идентификатор объекта, для которого вызывается метод.

VBScript, VBA

executeMethod "TObject", "MergeTo", Array(LOldObject, LNewObject)

JScript

executeMethod("TObject", "MergeTo", new Array(LOldObject, LNewObject));

Object Pascal

executeMethod('TObject', 'MergeTo', VarArrayOf([LOldObject, LNewObject]));

Функция executeReport осуществляет вызов отчета с параметрами. Имя класса передается в параметре ClassName, имя вызываемого метода - в параметре TemplateName. Параметры вызова передаются в параметре Params аналогично вызову executeMethod. В результате вызова функции возвращается ссылка на рабочую книгу Microsoft Excel, документ Microsoft Word и так далее. Судьба приложения, в рамках которого создан возвращенный объект, остается на усмотрение вызывающей стороны. Если вызывающая сторона предполагает взаимодействие объекта с пользователем, то необходимо обеспечить видимость объекта-приложения (Application.Visible := True;). В противном случае необходимо закрыть приложение после освобождения объекта документа (Application.Quit).

Функция getPropValue возвращает значение свойства объекта. Имя класса, имя свойства и идентификатор объекта задаются в параметрах.

Процедура setPropValue устанавливает значение свойства объекта в значение, заданное параметром Value. Для очистки значения можно использовать пустую строку или значение Null. Имя класса, имя свойства и идентификатор объекта задаются в параметрах.

Функция select возвращает ссылку на XML-документ, содержащий в корневом элементе элементы, представляющие собой записи набора данных на основе класса ClassName (с полями, разнесенными по элементам), определяемого структурой параметра QueryItems.

Функция enumerationItem возвращает идентификатор элемента перечисления по имени.

VBScript, VBA

LItemID = enumerationItem("rsReplicatableMetadata")

JScript

LItemID = enumerationItem("rsReplicatableMetadata");

Object Pascal

LItemID := enumerationItem('rsReplicatableMetadata');

Функция getClass возвращает идентификатор объекта типа Класс TClass (Классы) по имени.

VBScript, VBA

LClassID = getClass("TDocumentType")

JScript

LClassID = getClass("TDocumentType");

Object Pascal

LClassID := getClass('TDocumentType');

функция createGUID является оберткой над функцией Windows API CoCreateGuid. Возвращает сгенерированный глобально-уникальный идентификатор, преобразованный в строку.

процедура processStart информирует систему о необходимости показать окно выполнения длительного процесса. Текст, описывающий процесс (он появляется в показываемом окне) задается параметром Description. В случае, если есть возможность определить количество "шагов" процесса, то это количество необходимо передать в параметре ItemCount. В случае, если параметр ItemCount больше нуля, окно выполнения будет снабжено индикатором прогресса. Если значение ItemCount равно нулю, то окно появится без индикатора прогресса. Если значение ItemCount меньше нуля, то решение о появлении окна будет принято системой самостоятельно на основании загрузки процессора и окно процесса не появится, если процесс завершится достаточно быстро.

процедура processStep информирует систему о завершении очередного "шага" процесса, что найдет отражение в индикаторе прогресса окна выполнения длительного процесса, если таковые случатся.

процедура processStop информирует систему о завершении длительного процесса, что приведет к закрытию окна выполнения длительного процесса, если таковое случится.

функция PlaceDataSet осуществляет перенос данных из набора, задаваемого параметром DataSet в некоторое место документа Microsoft Office. Место назначения определяется параметром Range следующим образом:

Microsoft Word

Объект Range. По месту расположения этого объекта будет создана таблица (Table), в которой будут размещены данные из набора.

PlaceDataSet ThisDocument.Bookmarks("BookMarkName").Range, LDataSet

PlaceDataSet Selection.Range, LDataSet

Объект Document. В самом начале переданного документа будет создана таблица (Table), в которой будут размещены данные из набора.

PlaceDataSet ThisDocument, LDataSet

Microsoft Excel

Объект Range. По месту расположения этого объекта (диапазона) будут размещены данные из набора. Если параметр ShiftRows задан и равен True, то заданный диапазон будет расширен вниз на необходимое количество строк, и информация, лежащая ниже переданного диапазона, будет по-прежнему лежать ниже. Если нет, то она (скорее всего) будет затёрта данными набора. Если параметр ShiftColumns задан и равен True, то этот диапазон будет расширен вправо на необходимое количество столбцов, и информация, лежащая правее переданного диапазона, будет по-прежнему лежать правее. Если нет, то она (скорее всего) будет затёрта данными набора.

PlaceDataSet Range("C4"), LDataSet

Объект WorkSheet. На переданном листе будут размещены данные из набора.

PlaceDataSet WorkSheets("HiddenSheet"), LDataSet

Функция возвращает количество размещенных записей.

процедура DebugString выводит переданную в качестве аргумента строку в отладочный монитор.

процедура ExportObject осуществляет экспорт информации об объекте, задаваемом параметром ID в XML-документ, передаваемый в параметре Document. Если объект документа не был создан, то он создается автоматически. Если документ не имеет корневого узла, он будет создан автоматически.
01set LDataSet = CreateDataSet("TSecurityAccount")
02
03LDataSet.AddQueryItem qpWhat, "ID"
04
05set LDocument = CreateObject("Msxml2.DOMDocument.4.0") 'Не обязательно.
06
07while not LDataSet.Eof
08  ExportObject LDocument, LDataSet.Field("ID")
09  LDataSet.Next
10wend
11
12LDocument.save "c:\RolesAndUsers.xml"
Функция callRoutine осуществляет вызов подпрограммы. Параметры будут запрошены у пользователя обычным порядком (с показом формы задания параметров, отработки ее скрипта и т. д.). Имя класса передается в параметре ClassName, имя вызываемой подпрограммы - в параметре RoutineName. Если пользователь разрешил выполнение подпрограммы (либо для выполнения не требовалось разрешения пользователя), функция вернет True, иначе False. Значение, возвращаемое подпрограммой, может быть возвращено через необязательный параметр RetValue. Через значение необязательного параметра ScriptPart можно передать скрипт на языке VBScript, который будет "приклеен" сверху к скрипту формы параметров вызываемой подпрограммы.

Функция getOleObject возвращает ссылку на Ole-объект с идентификатором класса, переданном в параметре ClassID. Объект создается на основе библиотеки кода, сохраненной в доступном файле с именем, заданным параметром AccessibleFileName. Регистр символов имени доступного файла важен.

Функция getResource возвращает значение ресурсной строки по имени ресурса (элемента перечислимого домена Resource strings или перевода (объекта класса TLanguageTranslation).
MsgBox getResource("rssMyErrorMessage")
Функция getTempFileName возвращает сгенерированное системой имя временного файла с расширением, переданным в параметре Extension.

Функция selectVaue позволяет пользователю выбрать значение на основе ссылочного домена, имя которого передается в параметре ClassDomain. Вызывающая сторона может реализовать интерфейс IContextExpressionInfo, через который передается информация о контексте вызова для интерпретации выражений условий отбора, и передать ссылку на него через параметр ExpressionContext. Выбранное значение передается в обе стороны через параметр Value. Если пользователь подтвердил выбор значения, функция возвращает значение True, и устанавливает значение параметра Value, равное идентификатору выбранного пользователем объекта. Если пользователь отказался от выбора, функция возвращает значение False.

Процедура raiseManagedException возбуждает управляемую исключительную ситуацию с сообщением для пользователя, заданным параметром ExceptionMessage.

Функция getCRC возвращает шестнадцатиричное представление контрольной суммы переданных в параметре Data данных. Параметр может быть

Объектом, реализующим интерфейс IBinaryData

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Объектом, реализующим интерфейс IFile объектной модели FileSystemObject

Строкой данных. Строка будет преобразована в байты в соответствии с кодировкой UTF-8.

Функция downloadData осуществляет обращение к указанному ресурсу по протоколу http (https), и возвращает ответ сервера в виде объекта, реализующего интерфейс IBinaryData. Параметр Host определяет http-сервер, параметр Url - Url, к которому будет происходить обращение. Параметры UserName и Password определяют имя пользователя и пароль, если http-сервер требует авторизовать пользователя. Параметр NegotiateAuth устанавливает режим аутентификации. (Basic или Negotiate). Параметры PostData, PostContentType и PostDataIsBinary определяют содержимое тела POST-запроса (если не определено, функция отправит GET-запрос). Параметр CanCache позволяет использовать локальный кеш http-ответов. Параметр NewSession требует принудительного создания новой сессии при вызове функции. Параметр TimeOut определяет максимальное время ожидания ответа в секундах.

Функция createBinaryData создает пустой объект, реализующий интерфейс IBinaryData.

Функция BinaryToBitmap конвертирует переданный графический файл в формат BMP. Объекты во входном и выходном параметрах должны реализовывать интерфейс IBinaryData.

Функция editValues создает и показывает форму редактирования группы значений. Параметр ValuesList содержит идентификатор объекта класса TObjectList. Этот список содержит ссылки на редактируемые значения (объекты класса TTypedValue), и командные кнопки формы (объекты класса TTypedValueButton). Параметр Title определяет заголовок формы, параметр UseTabs определяет, будут ли показаны закладки на форме редактирования. Параметр HideOKButton позволяет скрыть кнопку "OK" на показываемой форме. Параметр ScriptPart определяет скрипт показываемой формы.
01  LValue1 = executeMethod ("TTypedValue", "CreateStrValue", _
02    Array("Value1", "Первый параметр", Null, Null, _
03    "TLongString", Null, Null, Null, Null, Null, "Значение по  умолчанию первого параметра"))
04  LValue2 = executeMethod ("TTypedValue", "CreateStrValue", _
05    Array("Value2", "Второй параметр", Null, Null, _
06    "TLongString", Null, Null, Null, Null, Null, "Значение по  умолчанию второго параметра"))
07
08  LValues = executeMethod("TObjectList", "CreateFromString", _
09    LValue1 & ";" & LValue2)
10
11  if editValues(LValues, "Введите два строковых значения, друзья", True, False, "") then
12    MsgBox getPropValue("TTypedValue", "StrValue", LValue1) & _
13      " " & _
14      getPropValue("TTypedValue", "StrValue", LValue2)
15  end if
16
17  executeMethod "TObject", "Destroy", LValues
18  executeMethod "TObject", "Destroy", LValue1
19  executeMethod "TObject", "Destroy", LValue2
01  LScriptPart =  "Buttons(""NextButton"").Enabled = ParentForm.NavigatorCanNext" & Chr(10) & _
02    "Buttons(""PrevButton"").Enabled = ParentForm.NavigatorCanPrevious"
03
04  LValue1 = executeMethod ("TTypedValue", "CreateStrValue", _
05    Array("Value1", "Первый параметр", Null, Null, "TLongString", Null, Null, Null, Null, Null, _
06    "Значение по  умолчанию первого параметра"))
07  LValue2 = executeMethod ("TTypedValue", "CreateStrValue", _
08    Array("Value2", "Второй параметр", Null, Null, "TLongString", Null, Null, Null, Null, Null, _
09    "Значение по  умолчанию второго параметра"))
10
11  LNextButton = executeMethod ("TTypedValueButton", "Create", Array("NextButton", "Вперед!", _
12    Null, Null, Null, Null, 0, Null, Null, _
13    "ParentForm.NavigatorNext"  & Chr(10) & LScriptPart, enumerationItem("scPublic"), 1, Null))
14
15  LPrevButton = executeMethod ("TTypedValueButton", "Create", Array("PrevButton", "Назад!", _
16    Null, Null, Null, Null, 1, Null, Null, _
17    "ParentForm.NavigatorPrevious" & Chr(10) & LScriptPart, enumerationItem("scPublic"), 1, Null))
18
19  LValues = executeMethod("TObjectList", "CreateFromString", _
20    LValue1 & ";" & LValue2 & ";" & LNextButton & ";" & LPrevButton)
21
22  if editValues(LValues, "Введите два строковых значения, друзья", True, True, LScriptPart) then
23    MsgBox getPropValue("TTypedValue", "StrValue", LValue1) & _
24      " " & _
25      getPropValue("TTypedValue", "StrValue", LValue2)
26  end if
27
28  executeMethod "TObject", "Destroy", LValues
29  executeMethod "TObject", "Destroy", LValue1
30  executeMethod "TObject", "Destroy", LValue2
31  executeMethod "TObject", "Destroy", LNextButton
32  executeMethod "TObject", "Destroy", LPrevButton
Функции MsgBox и ShowMsgBox (это синонимы одной точки входа) полностью аналогичны функции Basic MsgBox по поведению и набору параметров.

Функция buildNamedFile формирует значение типа "Именованный файл" на основе объекта, реализующего интерфейс IBinaryData (параметр Data) и информации об имени и параметрах именованного файла.

Процедура parseNamedFile разбирает значение типа "Именованный файл". Выходной параметр FileName будет содержать сохраненное имя файла, выходной параметр Data - объект, реализующего интерфейс IBinaryData и содержащий данные именованного файла.

Свойство ContextObject позволяет получить ссылку на этот же самый контекстный объект.

Свойство UserName позволяет получить логин текущего пользователя.

Свойство NegotiateAuth позволяет получить признак доменной аутентификации пользователя.

Свойство Language позволяет получать и устанавливать текущий языковой контекст, в котором будут выполняться обращения к БД. Значение свойства либо пустая строка (используется язык БД по умолчанию), либо имя объекта класса TLanguage

Свойство Variable позволяет сохранять и получать произвольные значения, которые могут хранится постоянно (в реестре) или только в текущем сеансе, в зависимости от параметра Persistent.
1'сохранить на время текущего сеанса значение в переменную с именем SameVariableName
2Variable("SameVariableName", False) = "Value"
3
4'получить значение переменной с именем SameVariableName хранимой в текущем сеансе
5LValue = Variable("SameVariableName", False)
Процедура showView осуществляет показ в модальном окне представления с именем ViewName. С помощью параметров DetailPropertyName и Key можно наложить на представление дополнительное условие отбора.

3.2. Интерфейс IContextDataSet
01  IContextDataSet = interface(IDispatch)
02    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
03    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
04      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant);
05    function Eof: WordBool;
06    function Field(const Name: WideString): OleVariant;
07    function FieldCount: Integer;
08    function FieldName(Index: Integer): WideString;
09    procedure Next;
10  end;
Интерфейс предоставляет возможности формирования и выполнения запросов к базе данных с целью получения свойств объектов определенного класса, предоставляет доступ к объекту набора данных. Работа с объектом, реализующим интерфейс IContextDataSet заключается в формировании структуры набора данных и последующих обращениях к ним.

Процедура AddQueryItem добавляет элемент набора данных. Элементы могут добавляться в любом порядке до первого обращения к данным набора. Символические имена всех предопределенных для параметров этого метода констант являются членами интерфейса IConstants.

часть запроса определяется параметром Part, который может принимать одно из следующих предопределенных значений:

Символическое имя

Числовое значение

Описание

qpWhat

0

Добавляет поле (столбец), определяемое параметром Name, к результирующему набору данных. Параметр Value игнорируется.

qpWhere

1

Определяет условие, налагаемое на свойства объектов класса, передаваемое остальными параметрами.

qpOrder

2

Определяет порядок сортировки записей результирующего набора данных. Параметр Value игнорируется.

qpGroup

3

Определяет, что записи результирующего набора данных будут сгруппированы по столбцу, переданному в параметре Name. Параметры Value и Special игнорируются.

параметр Name должен быть именем свойства класса, на котором основан набор данных, либо зарезервированным словом "ID" (без кавычек).

параметр Value (необязательный) определяет условия отбора, накладываемые на свойство, заданное параметром Name. Имеет смысл только если значение параметра Part равно qpWhere. Условие задается посредством строки, интерпретируемой следующим образом:

строка разделяется на части посредством системного разделителя

каждая часть интерпретируется самостоятельно, и эти части объединяются логическим "ИЛИ"

при интерпретации каждой части проверяются следующие условия:

*

проверка значения на непустоту (IS NOT NULL)

!*

проверка значения на пустоту (IS NULL)

начинается с символов
'<=', '<', '>=', '>'

проверка соответствующего отношения между значением свойства, переданного параметром Name и оставшейся частью строки

включает в себя символы '*' и/или '?'

проверка соответствия значения шаблону, в котором знак '?' соответствует одному любому символу, а знак '*' - любому количеству любых символов

начинается с символа '!'

символ '!' означает отрицание условия, переданного оставшейся частью строки

представляет собой строку в апострофах (одиночных кавычках)

содержание строки не анализируется по приведенным выше условиям

любая другая строка

проверка равенства значения свойства, переданного параметром Name значению, переданному строкой

параметр Special (необязательный) обеспечивает дополнительное поведение набора данных (если параметр Special используется, необходимо использовать и параметр Value, можно передавать пустую строку):

Символическое имя

Числовое значение

Описание

qsNone

0

Параметр не используется. Значение по умолчанию.

qsDescending

7

Используется при значении qpOrder параметра Part. В этом случае производится сортировка по убыванию.

qsCount

8

Используется при значении qpWhat параметра Part. Определяют тип агрегации по свойству, заданному параметром Name.

qsSum

9

qsMin

10

qsMax

11

qsAverage

12

qsFunction

22

Используется для включения в запрос вызова функции. Используется при значении qpWhat параметра Part.

параметр Context (необязательный) определяет дополнительные параметры элемента запроса.
01'включить в набор данных свойство Name
02LDataSet.AddQueryItem 0, "Name"
03'включить в набор данных среднее значение цены
04LDataSet.AddQueryItem 0, "Price", "", 12
05'включить в набор данных идентификатор объекта
06LDataSet.AddQueryItem 0, "ID"
07'включить в набор данных вызов функции. В поле IsCompany будет значение True, если объект является организацией
08LDataSet.AddQueryItem 0, "IsCompany", "TObject.IsInstanceOf", 22, Array(getClass("TCompany"))
09'наложить на набор данных условие
10LDataSet.AddQueryItem 1, "Organization", "фирма Елочка"
1LDataSet.AddQueryItem 0, "Organization"              '(1)
2LDataSet.AddQueryItem 0, "SalesCount", "", "9"       '(2)
3LDataSet.AddQueryItem 1, "SaleDate", ">10.09.2005"   '(3)
4LDataSet.AddQueryItem 2, "Organization"              '(4)
5LDataSet.AddQueryItem 3, "Organization"              '(5)
Производится отбор из класса, описывающего число продаж некоего продукта различными организациями. При этом в набор данных включаются колонки "Organization" (строка 1) и "SalesCount" (строка 2). При этом будет произведена группировка по свойству "Organization" (строка 5) (что гарантирует вхождение каждой организации в результирующий набор данных не более одного раза). Набор данных будет отсортирован по организации (строка 4). При этом в колонке "SalesCount" будет сумма (строка 2) всех продаж, осуществленных каждой организацией после 10.09.2005 (строка 3).

Функция FieldCount возвращает количество полей (столбцов) набора данных.

Функция FieldName возвращает имя поля (столбца) с номером, переданным в параметре Index.

Функция Field возвращает значение, содержащееся в поле с именем или индексом, заданным параметром Name (строкового типа) текущей записи набора данных. При первом обращении к набору данных текущей является первая запись. Если параметр определяет номер, то поиск поля производится по номеру. Если имя, то по имени.

Процедура Next осуществляет переход к следующей записи набора данных.

Функция Eof возвращает False, если текущая запись набора данных существует; в случаях, если набор данных пустой, или при помощи метода Next достигнут конец набора данных, возвращает True.
01If LDataSet.Eof then
02  'набор данных пуст. Ничего не отобрано.
03Else
04  While Not LDataSet.Eof
05    'работа с очередной отобранной записью
06    Cells(LRow, 1).Value = LDataSet.Field("Name")
07    Cells(LRow, 2).Value = LDataSet.Field("Description")
08    Cells(LRow, 2).Value = LDataSet.Field("Count")
09    'переход к следующей записи
10    LDataSet.Next
11    LRow = LRow + 1
12  Wend
13End If
3.3. Интерфейс IConstants
01  IConstants = interface(IDispatch)
02    ['{7E7B2D66-5E7C-496A-AE06-EFC485007500}']
03    property qpWhat: Integer;
04    property qpWhere: Integer;
05    property qpOrder: Integer;
06    property qpGroup: Integer;
07    property qpHaving: Integer;
08    property qsNone: Integer;
09    property qsObjectID: Integer;
10    property qsParentID: Integer;
11    property qsHasChildren: Integer;
12    property qsFilterCondition: Integer;
13    property qsUplink: Integer;
14    property qsRootOnly: Integer;
15    property qsDescending: Integer;
16    property qsCount: Integer;
17    property qsSum: Integer;
18    property qsMin: Integer;
19    property qsMax: Integer;
20    property qsAverage: Integer;
21    property qsMasterLink: Integer;
22    property qsSelectedOnly: Integer;
23  end;
Интерфейс предоставляет символические имена констант, необходимых для работы с объектом, реализующим интерфейс IContextDataSet.

Свойство

Значение

qpWhat

0

qpWhere

1

qpOrder

2

qpGroup

3

qpHaving

4

qsNone

0

qsObjectID

1

qsParentID

2

qsHasChildren

3

qsFilterCondition

4

qsUplink

5

qsRootOnly

6

qsDescending

7

qsCount

8

qsSum

9

qsMin

10

qsMax

11

qsAverage

12

qsMasterLink

13

qsSelectedOnly

14

3.4. Интерфейс IFormContext
01  IFormContext = interface(IDispatch)
02    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
03    function ChangedControl: OleVariant;
04    function ControlCount: Integer;
05    function ButtonCount: Integer;
06    function ID: WideString;
07    procedure Cancel;
08    function ControlExists(const Name: WideString): WordBool;
09    function ChangedControlName: WideString;
10    function ParentForm: OleVariant;
11    function RoutineID: WideString;
12    procedure PreInitControl(const Name: WideString; Value: OleVariant);
13    procedure NavigatorNext;
14    procedure NavigatorPrevious;
15    function NavigatorCanNext: WordBool;
16    function NavigatorCanPrevious: WordBool;
17    procedure RefreshView(RefreshAll: WordBool);
18    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
19    property Controls[Name: OleVariant]: IControl;
20    property Buttons[Name: OleVariant]: IButton;
21    property Enabled: WordBool;
22  end;
Представляет собой модель формы задания параметров. Члены интерфейса доступны для использования в скриптах форм задания параметров.

Функция ChangedControl возвращает объект, реализующий интерфейс IControl, соответствующий элементу управления, изменение которого вызвало исполнение скрипта формы параметров. Если выполнение скрипта вызвано инициализацией формы задания параметров, то значение функции - Empty. Пустоту значения можно проверить с помощью функции VBScript IsEmpty.

Функция ControlCount возвращает число элементов управления на форме параметров, как видимых так и невидимых.

Функция ButtonCount возвращает число командных кнопок на форме параметров, как видимых так и невидимых.

Функция ID возвращает значение идентификатора объекта, для которого вызван метод. Для методов класса возвращает пустое значение.

Функция ControlExists возвращает True, если элемент управления с именем Name существует на форме, и, соответственно, существует соответствующий параметр.

Функция ChangedControlName возвращает имя элемента управления, изменение которого вызвало исполнение скрипта формы параметров. Если выполнение скрипта вызвано инициализацией формы задания параметров, то значение функции - пустая строка.

Процедура Cancel прекращет работу формы задания параметров. Форма закрывается, выполнение действия блокируется.

Функция ParentForm возвращает ссылку на контекст родительской формы в цепочке вызовов. В контексте первой формы (вызванной с грида немодальной формы) возвращает пустое значение (Empty). Пустоту значения можно проверить с помощью функции VBScript IsEmpty.

Функция RoutineID возвращает идентификатор подпрограммы, для которой вызвана форма.

Процедура PreInitControl имитирует предварительную инициализацию элемента управления с именем Name значением, переданным в параметре Value. Сам элемент управления при этом будет скрыт, и не будет показан вплоть до следующего вызова формы пользователем.

Процедура NavigatorNext выполняет переход к следующему объекту набора данных, для которого показывается форма параметров.

Процедура NavigatorPrevious выполняет переход к предыдущему объекту набора данных, для которого показывается форма параметров.

Функция NavigatorCanNext возвращает True, если возможен переход к следующему объекту набора данных, для которого показывается форма параметров.

Функция NavigatorCanPrevious возвращает True, если возможен переход к предыдущему объекту набора данных, для которого показывается форма параметров.

Процедура RefreshView обновляет набор данных, для которого показывается форма параметров. Если значение параметра RefreshAll равно True, то будет обновлен весь набор, если False, то только выделенные записи.

Свойство Controls позволяет обращаться к элементам управления на форме задания параметров, их свойствам и методам. Каждый элемент управления реализует интерфейс IControl. В параметре Name (строкового типа)может быть передано как имя элемента управления, так и его индекс (в этом случае индекс должен быть передан как строка). Имена элементов управления на форме параметров соответствуют именам параметров подпрограммы (метода, отчета, etc).

Свойство Buttons позволяет обращаться к командным кнопкам на форме задания параметров, их свойствам и методам. Каждая командная кнопка реализует интерфейс IButton. В параметре Name (строкового типа)может быть передано как имя командной кнопки, так и ее индекс (в этом случае индекс должен быть передан как строка).

Свойство Enabled позволяет получать и устанавливать доступность кнопки OK на форме задания параметров. Если на форме есть невалидные (имеющие недопустимые значения) элементы управления, значение свойства всегда равно False и устанавливать его в явном виде в True не рекомендуется. Для учета дополнительного условия рекомендуется использовать следующую конструкцию: Enabled = Enabled and (Controls("SalesCount").Value > 10)

Функция ExpressionContextValue возвращает значение переменной контекста с именем Name, которая используется для интeрпретации выражений условий отбора на форме.

3.5. Интерфейс IControl
01  IControl = interface(IDispatch)
02    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
03    function Name: WideString;
04    procedure SetHint(const Value: WideString);
05    procedure RefreshLinkedView;
06    property Value: OleVariant;
07    property ReadOnly: WordBool;
08    property IsValid: WordBool;
09    property IsEmpty: WordBool;
10  end;
Моделирует элемент управления на форме задания параметров. Позволяет управлять поведением элементов управления на форме.

Функция Name возвращает имя элемента управления; имена элементов управления всегда совпадают с именамим соответствующих параметров подпрограммы.

Процедура SetHint устанавливает текст всплывающей подсказки элемента управления. Всплывыющая подсказка показывается только если значение элемента управления недопустимо (свойство IsValid равно False).

Процедура RefreshLinkedView обновит связанное с элементом управления представление.

Свойство Value позволяет получать и устанавливать значение, введенное в элемент управления.

Свойство ReadOnly позволяет получать и устанавливать доступность элемента управления для записи; при значении True элемент управления не доступен для записи и отображается неактивным.

Свойство IsValid позволяет получать и устанавливать "валидность" элемента управления; по умолчанию валидным элемент управления является в том случае, если введенное в него значение соответствует домену соответствующего параметра подпрограммы с учетом наложенного на него условия отбора.

Свойство IsEmpty имеет значение True в случае, если в элемент управления не введено никакого значения (элемент управления пустой), в противном случае имеет значение False.

3.6. Интерфейс IButton
1  IButton = interface(IDispatch)
2    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
3    function Name: WideString; safecall;
4    procedure Click; safecall;
5    property Enabled: WordBool;
6  end;
Моделирует командную кнопку на форме задания параметров. Позволяет управлять поведением кнопки на форме.

Функция Name возвращает имя кнопки.

Процедура Click эмулирует нажатие на кнопку.

Свойство Enabled позволяет получать и устанавливать доступность кнопки.

3.7. Интерфейс IBinaryData
01  IBinaryData = interface(IDispatch)
02    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
03    procedure Load(const Src: OleVariant);
04    procedure Append(const Src: OleVariant);
05    procedure Save(const Dst: OleVariant);
06    function Size: Cardinal;
07    function ToString(Encoding: WideString): WideString;
08    procedure FromString(Data: OleVariant);
09    procedure AppendString(Data: OleVariant);
10    function ToBase64: WideString;
11    procedure FromBase64(Data: OleVariant);
Представляет набор двоичных данных.

Процедура Load загружает двоичные данные из переданного источника. Источник может быть

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Строкой, содержащей имя файла

Процедура Append добавляет двоичные данные из переданного источника. Источник может быть

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Строкой, содержащей имя файла

Процедура Save сохраняет двоичные данные в переданный приемник. Приемник может быть

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Строкой, содержащей имя файла

Функция ToString переводит данные в строку. Байты, содержашиеся в объекте, будут рассматриваться как содержащие строку в кодировке, заданной параметром Encoding. По умолчанию используется кодировка UTF-8

Процедура FromString загружает данные из строки, переданной в параметре Data, перекодировав ее в кодировку UTF-8

Процедура AppendString добавляет данные из строки, переданной в параметре Data, перекодировав ее в кодировку UTF-8

Функция ToBase64 возвращает строку, полученную путем кодирования в формат Base64, данных содержащихся в объекте

Процедура FromBase64 загружает данные из строки, переданной в параметре Data, раскодировав ее из формата Base64

3.8. Интерфейс IContextExpressionInfo
1  IContextExpressionInfo = interface(IUnknown)
2    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
3    function Count: Integer;
4    function ItemName(Index: Integer): WideString;
5    function ItemValue(Index: Integer): OleVariant;
6    function ItemDomain(Index: Integer): OleVariant;
7  end;
Через реализацию этого интерфейса передаются значения контекстных переменных при обращении к функции selectValue интерфейса IContext.

Функция Count возвращает количество используемых контекстных переменных. Нумерация контекстных переменных начинается с нуля.

Функция ItemName возвращает имя контекстной переменной c номером, переданным в параметре Index.

Функция ItemValue возвращает значение контекстной переменной c номером, переданным в параметре Index.

Функция ItemDomain возвращает имя домена контекстной переменной c номером, переданным в параметре Index.

3.9. Интерфейс IExceptionHandler
1  IExceptionHandler = interface(IDispatch)
2    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
3    procedure HandleException(ContextObject: OleVariant;
4      const Message: WideString;
5      const ExtentedInfo: WideString);
6  end;
Реализовав интерфейс IExceptionHandler разработчик решений может получать уведомления о возникающих при работе исключительных ситуациях. При возникновении исключения объект, реализующий интерфейс, получит текст сообщения об ошибке и расширенную информацию.

Для реализации интерфеса используется библиотека hse.tlb, входящая в состав поставки решения. Перед началом работы с ней, необходимо зарегистрировать ее в операционной системе.

Для установки настроек интерфейса необходимо открыть Системную форму раздела АДМИНИСТРАТОРУ, перейти на вкладку Настройки и в столбце "Заголовок закладки" установить фильтр "Обработка ошибок".

После этого в качестве значения Идентификатора класса установить "IExceptionHandler" без кавычек.

Для Библиотеки кода указать значение HSE.tlb

3.10. Справочник по интерфейсам

3.10.1. Перечисление TQueryPart
1type
2  TQueryPart = (qpWhat, qpWhere, qpOrder, qpGroup, qpHaving, qpInnerJoin,
3    qpOuterJoin);
Или
01type
02  TQueryPart = TOleEnum;
03const
04  qpWhat = $00000000;
05  qpWhere = $00000001;
06  qpOrder = $00000002;
07  qpGroup = $00000003;
08  qpHaving = $00000004;
09  qpInnerJoin = $00000005;
10  qpOuterJoin = $00000006;
Элементы перечисления:

Имя

Значение

Назначение

qpWhat

0

qpWhere

1

qpOrder

2

qpGroup

3

qpHaving

4

qpInnerJoin

5

qpOuterJoin

6

3.10.2. Перечисление TQuerySpecial
1type
2  TQuerySpecial = (qsNone, qsObjectID, qsParentID, qsHasChildren,
3    qsFilterCondition, qsUplink, qsRootOnly, qsDescending, qsCount, qsSum, qsMin,
4    qsMax, qsAverage, qsMasterLink, qsSelectedOnly, qsDistinct, qsViewCondition,
5    qsCaseInsensitive, qsAsString, qsListed, qsName, qsDescription, qsFunction,
6    qsCountDistinct, qsBoolean, qsExact, qsSearchIndex, qsOptimizationParameters);
Или
01type
02  TQuerySpecial = TOleEnum;
03const
04  qsNone = $00000000;
05  qsObjectID = $00000001;
06  qsParentID = $00000002;
07  qsHasChildren = $00000003;
08  qsFilterCondition = $00000004;
09  qsUplink = $00000005;
10  qsRootOnly = $00000006;
11  qsDescending = $00000007;
12  qsCount = $00000008;
13  qsSum = $00000009;
14  qsMin = $0000000A;
15  qsMax = $0000000B;
16  qsAverage = $0000000C;
17  qsMasterLink = $0000000D;
18  qsSelectedOnly = $0000000E;
19  qsDistinct = $0000000F;
20  qsViewCondition = $00000010;
21  qsCaseInsensitive = $00000011;
22  qsAsString = $00000012;
23  qsListed = $00000013;
24  qsName = $00000014;
25  qsDescription = $00000015;
26  qsFunction = $00000016;
27  qsCountDistinct = $00000017;
28  qsBoolean = $00000018;
29  qsExact = $00000019;
30  qsSearchIndex = $0000001A;
31  qsOptimizationParameters = $0000001B;
Элементы перечисления:

Имя

Значение

Назначение

qsNone

0

qsObjectID

1

qsParentID

2

qsHasChildren

3

qsFilterCondition

4

qsUplink

5

qsRootOnly

6

qsDescending

7

qsCount

8

qsSum

9

qsMin

10

qsMax

11

qsAverage

12

qsMasterLink

13

qsSelectedOnly

14

qsDistinct

15

qsViewCondition

16

qsCaseInsensitive

17

qsAsString

18

qsListed

19

qsName

20

qsDescription

21

qsFunction

22

qsCountDistinct

23

qsBoolean

24

qsExact

25

qsSearchIndex

26

qsOptimizationParameters

27

3.10.3. Интерфейс IButton
1type
2  IButton = interface(IDispatch)
3    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
4    function Get_Enabled: WordBool; safecall;
5    procedure Set_Enabled(Value: WordBool); safecall;
6    function Name: WideString; safecall;
7    procedure Click; safecall;
8    property Enabled: WordBool read Get_Enabled write Set_Enabled;
9  end;
3.10.3.1. Свойства

Свойства интерфейса IButton:

Имя

Тип

Доступ

Назначение

Enabled

WordBool

Чтение/Запись

3.10.3.2. Метод Click

Метод интерфейса IButton.
procedure IButton.Click;
Метод не имеет параметров.

3.10.3.3. Метод Name

Метод интерфейса IButton.
function IButton.Name: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

3.10.4. Интерфейс IContext
001type
002  IContext = interface(IDispatch)
003    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
004    function Get_ContextObject: IDispatch; safecall;
005    function Get_UserName: WideString; safecall;
006    function Get_NegotiateAuth: WordBool; safecall;
007    function Get_Language: WideString; safecall;
008    procedure Set_Language(Value: WideString); safecall;
009    function Get_TimeBias: Double; safecall;
010    function getName(ID: OleVariant): WideString; safecall;
011    function getDescription(ID: OleVariant): WideString; safecall;
012    function getPropValue(const ClassName: WideString; const PropName: WideString;
013      ID: OleVariant): OleVariant; safecall;
014    procedure setPropValue(const ClassName: WideString; const PropName: WideString;
015      ID: OleVariant; Value: OleVariant); safecall;
016    procedure getPropValues(const ClassName: WideString;
017      const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
018      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
019    procedure setPropValues(const ClassName: WideString;
020      const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
021      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
022    function createDataSet(const TargetClassName: WideString): IContextDataSet; safecall;
023    function select(const ClassName: WideString; QueryItems: OleVariant): IDispatch; safecall;
024    function executeMethod(const ClassName: WideString;
025      const MethodName: WideString; Params: OleVariant): OleVariant; safecall;
026    function getClass(const ClassName: WideString): WideString; safecall;
027    function enumerationItem(ItemIdentifier: OleVariant): WideString; safecall;
028    function getResource(const Name: WideString): WideString; safecall;
029    function bulkInsert(const ClassName: WideString;
030      const Data: IDispatch): IContextDataSet; safecall;
031    function PreProcessScript(const Script: WideString; Indent: WordBool;
032      const CommentMark: WideString): WideString; safecall;
033    function executeReport(const ClassName: WideString;
034      const TemplateName: WideString; Params: OleVariant): IDispatch; safecall;
035    procedure saveReport(const ClassName: WideString;
036      const TemplateName: WideString; Params: OleVariant; const FileName: WideString); safecall;
037    function Get_Variable(const Name: WideString; Persistent: WordBool): OleVariant; safecall;
038    procedure Set_Variable(const Name: WideString; Persistent: WordBool;
039      Value: OleVariant); safecall;
040    function DebugString(const Message: WideString): WideString; safecall;
041    procedure raiseManagedException(const ExceptionMessage: WideString); safecall;
042    function createGUID: WideString; safecall;
043    function getTempFileName(const Extension: WideString): WideString; safecall;
044    function HasUI: WordBool; safecall;
045    function Handle: Integer; safecall;
046    procedure processStart(const Description: WideString; ItemCount: Integer;
047      CanAbort: WordBool); safecall;
048    function processStep: WordBool; safecall;
049    procedure processStop; safecall;
050    procedure Sleep(MSecs: Integer); safecall;
051    function executeConsoleProcess(const CommandLine: WideString;
052      MaxDuration: Integer; const OutputData: OleVariant): Integer; safecall;
053    function downloadData(const Host: WideString; const Url: WideString;
054      const UserName: WideString; const Password: WideString;
055      NegotiateAuth: WordBool; PostData: OleVariant;
056      const PostContentType: WideString; PostDataIsBinary: WordBool;
057      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant; safecall;
058    function LineBreak: WideString; safecall;
059    function Transliterate(const Value: WideString): WideString; safecall;
060    procedure CompareLists(var List1: OleVariant; var List2: OleVariant;
061      const Delimiter: WideString; CaseSensitive: WordBool); safecall;
062    function parseJSON(const JSON: WideString): WideString; safecall;
063    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch; safecall;
064    function createBinaryData: IDispatch; safecall;
065    function getCRC(Data: OleVariant): WideString; safecall;
066    function buildNamedFile(const Data: IDispatch;
067      const StoredFileName: WideString; Propmpt: WordBool;
068      Compress: WordBool): IDispatch; safecall;
069    procedure parseNamedFile(NamedFile: OleVariant; out FileName: OleVariant;
070      out Data: OleVariant); safecall;
071    function createRaster: IDispatch; safecall;
072    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
073    function getOleObject(const ClassID: WideString;
074      const AccessibleFileName: WideString): IDispatch; safecall;
075    function PlaceDataSet(const Range: IDispatch; const DataSet: IContextDataSet;
076      ShiftRows: WordBool; ShiftColumns: WordBool): Integer; safecall;
077    procedure ExportObject(var Document: OleVariant; const ID: WideString;
078      const ClassID: WideString); safecall;
079    function createZIPArchive: IDispatch; safecall;
080    function callRoutine(const ClassName: WideString;
081      const RoutineName: WideString; var RetValue: OleVariant;
082      const ScriptPart: OleVariant): WordBool; safecall;
083    function selectVaue(const ClassDomain: WideString;
084      const ExpressionContext: IUnknown; var Value: OleVariant): WordBool; safecall;
085    function editValues(const ValuesList: WideString; const Title: WideString;
086      UseTabs: WordBool; HideOKButton: WordBool;
087      const ScriptPart: OleVariant): WordBool; safecall;
088    function MsgBox(const Prompt: WideString; Buttons: LongWord;
089      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
090    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
091      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
092    procedure showView(const ViewName: WideString; Key: OleVariant;
093      const DetailPropertyName: WideString); safecall;
094    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
095      ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
096      TakeActionsFromView: OleVariant); safecall;
097    procedure SaveExternalDataToFolder(const Resource: WideString;
098      const Folder: WideString); safecall;
099    function PerformAsyncTask(ID: OleVariant): WordBool; safecall;
100    procedure RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
101      ThreadCount: Integer); safecall;
102    function MainHandle: Integer; safecall;
103    function IsHTMLDocumentSafe(const HTML: WideString): WordBool; safecall;
104    function EnsafeHTMLDocument(const HTML: WideString; RemoveHead: WordBool;
105      Format: WordBool; PureXML: WordBool): WideString; safecall;
106    property ContextObject: IDispatch read Get_ContextObject;
107    property UserName: WideString read Get_UserName;
108    property NegotiateAuth: WordBool read Get_NegotiateAuth;
109    property Language: WideString read Get_Language write Set_Language;
110    property TimeBias: Double read Get_TimeBias;
111    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant
112      read Get_Variable write Set_Variable;
113  end;
3.10.4.1. Свойства

Свойства интерфейса IContext:

Имя

Тип

Доступ

Назначение

ContextObject

IDispatch

Только для чтения

Language

WideString

Чтение/Запись

NegotiateAuth

WordBool

Только для чтения

TimeBias

Double

Только для чтения

UserName

WideString

Только для чтения

Variable[const Name: WideString, Persistent: WordBool]

OleVariant

Чтение/Запись

3.10.4.2. Метод BinaryToBitmap

Метод интерфейса IContext.
function IContext.BinaryToBitmap(const Data: IDispatch): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Data

IDispatch

Да

Замечания:

Возвращает значение типа IDispatch.

3.10.4.3. Метод buildNamedFile

Метод интерфейса IContext.
1function IContext.buildNamedFile(const Data: IDispatch;
2  const StoredFileName: WideString; Propmpt: WordBool;
3  Compress: WordBool): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Data

IDispatch

Да

StoredFileName

WideString

Да

Propmpt

WordBool

Да

Compress

WordBool

Да

Замечания:

Возвращает значение типа IDispatch.

3.10.4.4. Метод bulkInsert

Метод интерфейса IContext.
1function IContext.bulkInsert(const ClassName: WideString;
2  const Data: IDispatch): IContextDataSet;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

Data

IDispatch

Да

Замечания:

Возвращает значение типа IContextDataSet.

3.10.4.5. Метод callRoutine

Метод интерфейса IContext.
1function IContext.callRoutine(const ClassName: WideString;
2  const RoutineName: WideString; var RetValue: OleVariant;
3  const ScriptPart: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

RoutineName

WideString

Да

RetValue

OleVariant

Нет

ScriptPart

OleVariant

Нет

Замечания:

Возвращает значение типа WordBool.

3.10.4.6. Метод CompareLists

Метод интерфейса IContext.
1procedure IContext.CompareLists(var List1: OleVariant; var List2: OleVariant;
2  const Delimiter: WideString; CaseSensitive: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

List1

OleVariant

Да

List2

OleVariant

Да

Delimiter

WideString

Да

CaseSensitive

WordBool

Да

3.10.4.7. Метод ConvertExcel

Метод интерфейса IContext.
1function IContext.ConvertExcel(Source: OleVariant;
2  const Format: WideString): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Source

OleVariant

Да

Format

WideString

Да

Замечания:

Возвращает значение типа IDispatch.

3.10.4.8. Метод createBinaryData

Метод интерфейса IContext.
function IContext.createBinaryData: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

3.10.4.9. Метод createDataSet

Метод интерфейса IContext.
function IContext.createDataSet(const TargetClassName: WideString): IContextDataSet;
Параметры:

Имя

Тип

Обязательно

Значение

TargetClassName

WideString

Да

Замечания:

Возвращает значение типа IContextDataSet.

3.10.4.10. Метод createGUID

Метод интерфейса IContext.
function IContext.createGUID: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

3.10.4.11. Метод createRaster

Метод интерфейса IContext.
function IContext.createRaster: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

3.10.4.12. Метод createZIPArchive

Метод интерфейса IContext.
function IContext.createZIPArchive: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

3.10.4.13. Метод DebugString

Метод интерфейса IContext.
function IContext.DebugString(const Message: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Message

WideString

Да

Замечания:

Возвращает значение типа WideString.

3.10.4.14. Метод downloadData

Метод интерфейса IContext.
1function IContext.downloadData(const Host: WideString; const Url: WideString;
2  const UserName: WideString; const Password: WideString;
3  NegotiateAuth: WordBool; PostData: OleVariant;
4  const PostContentType: WideString; PostDataIsBinary: WordBool;
5  CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

Host

WideString

Да

Url

WideString

Да

UserName

WideString

Да

Password

WideString

Да

NegotiateAuth

WordBool

Да

PostData

OleVariant

Да

PostContentType

WideString

Да

PostDataIsBinary

WordBool

Да

CanCache

WordBool

Да

NewSession

WordBool

Да

TimeOut

Integer

Да

Замечания:

Возвращает значение типа OleVariant.

3.10.4.15. Метод editValues

Метод интерфейса IContext.
1function IContext.editValues(const ValuesList: WideString;
2  const Title: WideString; UseTabs: WordBool; HideOKButton: WordBool;
3  const ScriptPart: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ValuesList

WideString

Да

Title

WideString

Да

UseTabs

WordBool

Да

HideOKButton

WordBool

Да

ScriptPart

OleVariant

Нет

Замечания:

Возвращает значение типа WordBool.

3.10.4.16. Метод EnsafeHTMLDocument

Метод интерфейса IContext.
1function IContext.EnsafeHTMLDocument(const HTML: WideString;
2  RemoveHead: WordBool; Format: WordBool; PureXML: WordBool): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

HTML

WideString

Да

RemoveHead

WordBool

Да

Format

WordBool

Да

PureXML

WordBool

Да

Замечания:

Возвращает значение типа WideString.

3.10.4.17. Метод enumerationItem

Метод интерфейса IContext.
function IContext.enumerationItem(ItemIdentifier: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ItemIdentifier

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

3.10.4.18. Метод executeConsoleProcess

Метод интерфейса IContext.
1function IContext.executeConsoleProcess(const CommandLine: WideString;
2  MaxDuration: Integer; const OutputData: OleVariant): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

CommandLine

WideString

Да

MaxDuration

Integer

Да

OutputData

OleVariant

Да

Замечания:

Возвращает значение типа Integer.

3.10.4.19. Метод executeMethod

Метод интерфейса IContext.
1function IContext.executeMethod(const ClassName: WideString;
2  const MethodName: WideString; Params: OleVariant): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

MethodName

WideString

Да

Params

OleVariant

Да

Замечания:

Возвращает значение типа OleVariant.

3.10.4.20. Метод executeReport

Метод интерфейса IContext.
1function IContext.executeReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

TemplateName

WideString

Да

Params

OleVariant

Да

Замечания:

Возвращает значение типа IDispatch.

3.10.4.21. Метод ExportObject

Метод интерфейса IContext.
1procedure IContext.ExportObject(var Document: OleVariant; const ID: WideString;
2  const ClassID: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Document

OleVariant

Да

ID

WideString

Да

ClassID

WideString

Да

3.10.4.22. Метод getClass

Метод интерфейса IContext.
function IContext.getClass(const ClassName: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

Замечания:

Возвращает значение типа WideString.

3.10.4.23. Метод getCRC

Метод интерфейса IContext.
function IContext.getCRC(Data: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

3.10.4.24. Метод getDescription

Метод интерфейса IContext.
function IContext.getDescription(ID: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ID

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

3.10.4.25. Метод getName

Метод интерфейса IContext.
function IContext.getName(ID: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ID

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

3.10.4.26. Метод getOleObject

Метод интерфейса IContext.
1function IContext.getOleObject(const ClassID: WideString;
2  const AccessibleFileName: WideString): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

ClassID

WideString

Да

AccessibleFileName

WideString

Да

Замечания:

Возвращает значение типа IDispatch.

3.10.4.27. Метод getPropValue

Метод интерфейса IContext.
1function IContext.getPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

ID

OleVariant

Да

Замечания:

Возвращает значение типа OleVariant.

3.10.4.28. Метод getPropValues

Метод интерфейса IContext.
1procedure IContext.getPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

IDS

OleVariant

Да

OnValueEvent

OleVariant

Да

ThreadCount

Integer

Да

ThreadSafe

WordBool

Да

3.10.4.29. Метод getResource

Метод интерфейса IContext.
function IContext.getResource(const Name: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа WideString.

3.10.4.30. Метод getTempFileName

Метод интерфейса IContext.
function IContext.getTempFileName(const Extension: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Extension

WideString

Да

Замечания:

Возвращает значение типа WideString.

3.10.4.31. Метод Handle

Метод интерфейса IContext.
function IContext.Handle: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

3.10.4.32. Метод HasUI

Метод интерфейса IContext.
function IContext.HasUI: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

3.10.4.33. Метод IsHTMLDocumentSafe

Метод интерфейса IContext.
function IContext.IsHTMLDocumentSafe(const HTML: WideString): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

HTML

WideString

Да

Замечания:

Возвращает значение типа WordBool.

3.10.4.34. Метод LineBreak

Метод интерфейса IContext.
function IContext.LineBreak: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

3.10.4.35. Метод MainHandle

Метод интерфейса IContext.
function IContext.MainHandle: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

3.10.4.36. Метод MsgBox

Метод интерфейса IContext.
1function IContext.MsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

Prompt

WideString

Да

Buttons

LongWord

Нет

Title

WideString

Нет

HelpFile

WideString

Нет

Context

LongWord

Нет

Замечания:

Возвращает значение типа Integer.

3.10.4.37. Метод parseJSON

Метод интерфейса IContext.
function IContext.parseJSON(const JSON: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

JSON

WideString

Да

Замечания:

Возвращает значение типа WideString.

3.10.4.38. Метод parseNamedFile

Метод интерфейса IContext.
1procedure IContext.parseNamedFile(NamedFile: OleVariant;
2  out FileName: OleVariant; out Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

NamedFile

OleVariant

Да

FileName

OleVariant

Да

Data

OleVariant

Да

3.10.4.39. Метод PerformAsyncTask

Метод интерфейса IContext.
function IContext.PerformAsyncTask(ID: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ID

OleVariant

Да

Замечания:

Возвращает значение типа WordBool.

3.10.4.40. Метод PlaceDataSet

Метод интерфейса IContext.
1function IContext.PlaceDataSet(const Range: IDispatch;
2  const DataSet: IContextDataSet; ShiftRows: WordBool;
3  ShiftColumns: WordBool): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

Range

IDispatch

Да

DataSet

IContextDataSet

Да

ShiftRows

WordBool

Нет

ShiftColumns

WordBool

Нет

Замечания:

Возвращает значение типа Integer.

3.10.4.41. Метод PreProcessScript

Метод интерфейса IContext.
1function IContext.PreProcessScript(const Script: WideString; Indent: WordBool;
2  const CommentMark: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Script

WideString

Да

Indent

WordBool

Да

CommentMark

WideString

Да

Замечания:

Возвращает значение типа WideString.

3.10.4.42. Метод processStart

Метод интерфейса IContext.
1procedure IContext.processStart(const Description: WideString;
2  ItemCount: Integer; CanAbort: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Description

WideString

Да

ItemCount

Integer

Нет

CanAbort

WordBool

Нет

3.10.4.43. Метод processStep

Метод интерфейса IContext.
function IContext.processStep: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

3.10.4.44. Метод processStop

Метод интерфейса IContext.
procedure IContext.processStop;
Метод не имеет параметров.

3.10.4.45. Метод raiseManagedException

Метод интерфейса IContext.
procedure IContext.raiseManagedException(const ExceptionMessage: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

ExceptionMessage

WideString

Да

3.10.4.46. Метод RebuildTextIndex

Метод интерфейса IContext.
1procedure IContext.RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
2  ThreadCount: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

ClassID

OleVariant

Да

FieldID

OleVariant

Да

ThreadCount

Integer

Да

3.10.4.47. Метод SaveExternalDataToFolder

Метод интерфейса IContext.
1procedure IContext.SaveExternalDataToFolder(const Resource: WideString;
2  const Folder: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Resource

WideString

Да

Folder

WideString

Да

3.10.4.48. Метод saveReport

Метод интерфейса IContext.
1procedure IContext.saveReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant; const FileName: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

TemplateName

WideString

Да

Params

OleVariant

Да

FileName

WideString

Да

3.10.4.49. Метод select

Метод интерфейса IContext.
1function IContext.select(const ClassName: WideString;
2  QueryItems: OleVariant): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

QueryItems

OleVariant

Да

Замечания:

Возвращает значение типа IDispatch.

3.10.4.50. Метод selectVaue

Метод интерфейса IContext.
1function IContext.selectVaue(const ClassDomain: WideString;
2  const ExpressionContext: IUnknown; var Value: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ClassDomain

WideString

Да

ExpressionContext

IUnknown

Да

Value

OleVariant

Да

Замечания:

Возвращает значение типа WordBool.

3.10.4.51. Метод setPropValue

Метод интерфейса IContext.
1procedure IContext.setPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant; Value: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

ID

OleVariant

Да

Value

OleVariant

Да

3.10.4.52. Метод setPropValues

Метод интерфейса IContext.
1procedure IContext.setPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

IDS

OleVariant

Да

OnValueNeededEvent

OleVariant

Да

ThreadCount

Integer

Да

ThreadSafe

WordBool

Да

3.10.4.53. Метод showDataSet

Метод интерфейса IContext.
1procedure IContext.showDataSet(const DataSet: ContextDataSet;
2  const Caption: WideString; ColumnCaptions: OleVariant;
3  ColumnOnChangeHandlers: OleVariant; TakeActionsFromView: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

DataSet

ContextDataSet

Да

Caption

WideString

Да

ColumnCaptions

OleVariant

Да

ColumnOnChangeHandlers

OleVariant

Да

TakeActionsFromView

OleVariant

Да

3.10.4.54. Метод ShowMsgBox

Метод интерфейса IContext.
1function IContext.ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

Prompt

WideString

Да

Buttons

LongWord

Нет

Title

WideString

Нет

HelpFile

WideString

Нет

Context

LongWord

Нет

Замечания:

Возвращает значение типа Integer.

3.10.4.55. Метод showView

Метод интерфейса IContext.
1procedure IContext.showView(const ViewName: WideString; Key: OleVariant;
2  const DetailPropertyName: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

ViewName

WideString

Да

Key

OleVariant

Да

DetailPropertyName

WideString

Да

3.10.4.56. Метод Sleep

Метод интерфейса IContext.
procedure IContext.Sleep(MSecs: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

MSecs

Integer

Да

3.10.4.57. Метод Transliterate

Метод интерфейса IContext.
function IContext.Transliterate(const Value: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Value

WideString

Да

Замечания:

Возвращает значение типа WideString.

3.10.5. Интерфейс IContextDataSet
01type
02  IContextDataSet = interface(IDispatch)
03    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
04    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
05      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant); safecall;
06    function Eof: WordBool; safecall;
07    function Field(const Name: WideString): OleVariant; safecall;
08    function FieldCount: Integer; safecall;
09    function FieldName(Index: Integer): WideString; safecall;
10    procedure Next; safecall;
11    procedure Split(OnRowEvent: OleVariant; ChunkSize: Integer;
12      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
13    function AsJSON: WideString; safecall;
14    function AsXML: WideString; safecall;
15    function AsBinaryData: IDispatch; safecall;
16  end;
3.10.5.1. Метод AddQueryItem

Метод интерфейса IContextDataSet.
1procedure IContextDataSet.AddQueryItem(Part: TQueryPart;
2  const Name: WideString; Value: OleVariant; Special: TQuerySpecial;
3  Context: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Part

TQueryPart

Да

Name

WideString

Да

Value

OleVariant

Нет

Special

TQuerySpecial

Нет

Context

OleVariant

Нет

3.10.5.2. Метод AsBinaryData

Метод интерфейса IContextDataSet.
function IContextDataSet.AsBinaryData: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

3.10.5.3. Метод AsJSON

Метод интерфейса IContextDataSet.
function IContextDataSet.AsJSON: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

3.10.5.4. Метод AsXML

Метод интерфейса IContextDataSet.
function IContextDataSet.AsXML: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

3.10.5.5. Метод Eof

Метод интерфейса IContextDataSet.
function IContextDataSet.Eof: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

3.10.5.6. Метод Field

Метод интерфейса IContextDataSet.
function IContextDataSet.Field(const Name: WideString): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа OleVariant.

3.10.5.7. Метод FieldCount

Метод интерфейса IContextDataSet.
function IContextDataSet.FieldCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

3.10.5.8. Метод FieldName

Метод интерфейса IContextDataSet.
function IContextDataSet.FieldName(Index: Integer): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Index

Integer

Да

Замечания:

Возвращает значение типа WideString.

3.10.5.9. Метод Next

Метод интерфейса IContextDataSet.
procedure IContextDataSet.Next;
Метод не имеет параметров.

3.10.5.10. Метод Split

Метод интерфейса IContextDataSet.
1procedure IContextDataSet.Split(OnRowEvent: OleVariant; ChunkSize: Integer;
2  ThreadCount: Integer; ThreadSafe: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

OnRowEvent

OleVariant

Да

ChunkSize

Integer

Да

ThreadCount

Integer

Да

ThreadSafe

WordBool

Да

3.10.6. Интерфейс IContextExpressionInfo
1type
2  IContextExpressionInfo = interface(IUnknown)
3    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
4    function LookupExpressionContext(const Identifier: WideString;
5      out DomainID: WideString; out Value: WideString): WordBool; safecall;
6    procedure SerializeExpressionContext(const RootNode: IDispatch); safecall;
7  end;
3.10.6.1. Метод LookupExpressionContext

Метод интерфейса IContextExpressionInfo.
1function IContextExpressionInfo.LookupExpressionContext(const Identifier: WideString;
2  out DomainID: WideString; out Value: WideString): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

Identifier

WideString

Да

DomainID

WideString

Да

Value

WideString

Да

Замечания:

Возвращает значение типа WordBool.

3.10.6.2. Метод SerializeExpressionContext

Метод интерфейса IContextExpressionInfo.
procedure IContextExpressionInfo.SerializeExpressionContext(const RootNode: IDispatch);
Параметры:

Имя

Тип

Обязательно

Значение

RootNode

IDispatch

Да

3.10.7. Интерфейс IControl
01type
02  IControl = interface(IDispatch)
03    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
04    function Name: WideString; safecall;
05    function Get_Value: OleVariant; safecall;
06    procedure Set_Value(Value: OleVariant); safecall;
07    function Get_ReadOnly: WordBool; safecall;
08    procedure Set_ReadOnly(Value: WordBool); safecall;
09    function Get_IsValid: WordBool; safecall;
10    procedure Set_IsValid(Value: WordBool); safecall;
11    function Get_IsEmpty: WordBool; safecall;
12    procedure SetHint(const Value: WideString); safecall;
13    procedure RefreshLinkedView; safecall;
14    function Get_Visible: WordBool; safecall;
15    property Value: OleVariant read Get_Value write Set_Value;
16    property ReadOnly: WordBool read Get_ReadOnly write Set_ReadOnly;
17    property IsValid: WordBool read Get_IsValid write Set_IsValid;
18    property IsEmpty: WordBool read Get_IsEmpty;
19    property Visible: WordBool read Get_Visible;
20  end;
3.10.7.1. Свойства

Свойства интерфейса IControl:

Имя

Тип

Доступ

Назначение

IsEmpty

WordBool

Только для чтения

IsValid

WordBool

Чтение/Запись

ReadOnly

WordBool

Чтение/Запись

Value

OleVariant

Чтение/Запись

Visible

WordBool

Только для чтения

3.10.7.2. Метод Name

Метод интерфейса IControl.
function IControl.Name: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

3.10.7.3. Метод RefreshLinkedView

Метод интерфейса IControl.
procedure IControl.RefreshLinkedView;
Метод не имеет параметров.

3.10.7.4. Метод SetHint

Метод интерфейса IControl.
procedure IControl.SetHint(const Value: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Value

WideString

Да

3.10.8. Интерфейс IExceptionHandler
1type
2  IExceptionHandler = interface(IDispatch)
3    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
4    procedure HandleException(ContextObject: OleVariant; const Message: WideString;
5      const ExtentedInfo: WideString; SupportServiceData: OleVariant); safecall;
6  end;
3.10.8.1. Метод HandleException

Метод интерфейса IExceptionHandler.
1procedure IExceptionHandler.HandleException(ContextObject: OleVariant;
2  const Message: WideString; const ExtentedInfo: WideString;
3  SupportServiceData: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

ContextObject

OleVariant

Да

Message

WideString

Да

ExtentedInfo

WideString

Да

SupportServiceData

OleVariant

Да

3.10.9. Интерфейс IExternalContext
1type
2  IExternalContext = interface(IDispatch)
3    ['{EA2F1CDA-53F6-40E9-A2B7-0A80AB84D177}']
4    procedure Connect(const Database: WideString); safecall;
5  end;
3.10.9.1. Метод Connect

Метод интерфейса IExternalContext.
procedure IExternalContext.Connect(const Database: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Database

WideString

Да

3.10.10. Интерфейс IFormContext
01type
02  IFormContext = interface(IDispatch)
03    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
04    function ID: WideString; safecall;
05    function RoutineID: WideString; safecall;
06    function ControlCount: Integer; safecall;
07    function Get_Controls(Name: OleVariant): IControl; safecall;
08    function ControlExists(const Name: WideString): WordBool; safecall;
09    function ButtonCount: Integer; safecall;
10    function Get_Buttons(Name: OleVariant): IButton; safecall;
11    function Get_Enabled: WordBool; safecall;
12    procedure Set_Enabled(Value: WordBool); safecall;
13    function ChangedControl: OleVariant; safecall;
14    function ChangedControlName: WideString; safecall;
15    procedure Cancel; safecall;
16    function ParentForm: OleVariant; safecall;
17    procedure PreInitControl(const Name: WideString; Value: OleVariant); safecall;
18    procedure NavigatorNext; safecall;
19    procedure NavigatorPrevious; safecall;
20    function NavigatorCanNext: WordBool; safecall;
21    function NavigatorCanPrevious: WordBool; safecall;
22    procedure RefreshView(RefreshAll: WordBool); safecall;
23    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
24    property Controls[Name: OleVariant]: IControl read Get_Controls;
25    property Buttons[Name: OleVariant]: IButton read Get_Buttons;
26    property Enabled: WordBool read Get_Enabled write Set_Enabled;
27  end;
3.10.10.1. Свойства

Свойства интерфейса IFormContext:

Имя

Тип

Доступ

Назначение

Buttons[Name: OleVariant]

IButton

Только для чтения

Controls[Name: OleVariant]

IControl

Только для чтения

Enabled

WordBool

Чтение/Запись

3.10.10.2. Метод ButtonCount

Метод интерфейса IFormContext.
function IFormContext.ButtonCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

3.10.10.3. Метод Cancel

Метод интерфейса IFormContext.
procedure IFormContext.Cancel;
Метод не имеет параметров.

3.10.10.4. Метод ChangedControl

Метод интерфейса IFormContext.
function IFormContext.ChangedControl: OleVariant;
Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

3.10.10.5. Метод ChangedControlName

Метод интерфейса IFormContext.
function IFormContext.ChangedControlName: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

3.10.10.6. Метод ControlCount

Метод интерфейса IFormContext.
function IFormContext.ControlCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

3.10.10.7. Метод ControlExists

Метод интерфейса IFormContext.
function IFormContext.ControlExists(const Name: WideString): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа WordBool.

3.10.10.8. Метод ExpressionContextValue

Метод интерфейса IFormContext.
function IFormContext.ExpressionContextValue(const Name: WideString): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа OleVariant.

3.10.10.9. Метод ID

Метод интерфейса IFormContext.
function IFormContext.ID: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

3.10.10.10. Метод NavigatorCanNext

Метод интерфейса IFormContext.
function IFormContext.NavigatorCanNext: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

3.10.10.11. Метод NavigatorCanPrevious

Метод интерфейса IFormContext.
function IFormContext.NavigatorCanPrevious: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

3.10.10.12. Метод NavigatorNext

Метод интерфейса IFormContext.
procedure IFormContext.NavigatorNext;
Метод не имеет параметров.

3.10.10.13. Метод NavigatorPrevious

Метод интерфейса IFormContext.
procedure IFormContext.NavigatorPrevious;
Метод не имеет параметров.

3.10.10.14. Метод ParentForm

Метод интерфейса IFormContext.
function IFormContext.ParentForm: OleVariant;
Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

3.10.10.15. Метод PreInitControl

Метод интерфейса IFormContext.
procedure IFormContext.PreInitControl(const Name: WideString; Value: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Value

OleVariant

Да

3.10.10.16. Метод RefreshView

Метод интерфейса IFormContext.
procedure IFormContext.RefreshView(RefreshAll: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

RefreshAll

WordBool

Да

3.10.10.17. Метод RoutineID

Метод интерфейса IFormContext.
function IFormContext.RoutineID: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

3.10.11. Интерфейс IRaster
01type
02  IRaster = interface(IDispatch)
03    ['{4F27D016-03C2-4D48-ABF7-FD547E859F79}']
04    function Get_Width: Integer; safecall;
05    procedure Set_Width(Value: Integer); safecall;
06    function Get_Height: Integer; safecall;
07    procedure Set_Height(Value: Integer); safecall;
08    function Get_DefaultColor: Integer; safecall;
09    procedure Set_DefaultColor(Value: Integer); safecall;
10    procedure Load(Src: OleVariant); safecall;
11    procedure SaveBitmap(Dst: OleVariant); safecall;
12    procedure SavePNG(Dst: OleVariant); safecall;
13    procedure SaveJPG(Dst: OleVariant; Quality: Integer); safecall;
14    procedure FlipVertical; safecall;
15    procedure FlipHorizontal; safecall;
16    procedure Rotate; safecall;
17    procedure Resize(NewWidth: Integer; NewHeight: Integer; Center: WordBool); safecall;
18    procedure Stretch(NewWidth: Integer; NewHeight: Integer); safecall;
19    procedure StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
20      MaxSize: OleVariant); safecall;
21    procedure Overlay(Src: OleVariant; X: Integer; Y: Integer; Width: Integer;
22      Height: Integer); safecall;
23    property Width: Integer read Get_Width write Set_Width;
24    property Height: Integer read Get_Height write Set_Height;
25    property DefaultColor: Integer read Get_DefaultColor write Set_DefaultColor;
26  end;
3.10.11.1. Свойства

Свойства интерфейса IRaster:

Имя

Тип

Доступ

Назначение

DefaultColor

Integer

Чтение/Запись

Height

Integer

Чтение/Запись

Width

Integer

Чтение/Запись

3.10.11.2. Метод FlipHorizontal

Метод интерфейса IRaster.
procedure IRaster.FlipHorizontal;
Метод не имеет параметров.

3.10.11.3. Метод FlipVertical

Метод интерфейса IRaster.
procedure IRaster.FlipVertical;
Метод не имеет параметров.

3.10.11.4. Метод Load

Метод интерфейса IRaster.
procedure IRaster.Load(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

3.10.11.5. Метод Overlay

Метод интерфейса IRaster.
1procedure IRaster.Overlay(Src: OleVariant; X: Integer; Y: Integer;
2  Width: Integer; Height: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

X

Integer

Да

Y

Integer

Да

Width

Integer

Да

Height

Integer

Да

3.10.11.6. Метод Resize

Метод интерфейса IRaster.
1procedure IRaster.Resize(NewWidth: Integer; NewHeight: Integer;
2  Center: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

NewWidth

Integer

Да

NewHeight

Integer

Да

Center

WordBool

Да

3.10.11.7. Метод Rotate

Метод интерфейса IRaster.
procedure IRaster.Rotate;
Метод не имеет параметров.

3.10.11.8. Метод SaveBitmap

Метод интерфейса IRaster.
procedure IRaster.SaveBitmap(Dst: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

3.10.11.9. Метод SaveJPG

Метод интерфейса IRaster.
procedure IRaster.SaveJPG(Dst: OleVariant; Quality: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

Quality

Integer

Да

3.10.11.10. Метод SavePNG

Метод интерфейса IRaster.
procedure IRaster.SavePNG(Dst: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

3.10.11.11. Метод Stretch

Метод интерфейса IRaster.
procedure IRaster.Stretch(NewWidth: Integer; NewHeight: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

NewWidth

Integer

Да

NewHeight

Integer

Да

3.10.11.12. Метод StretchToSize

Метод интерфейса IRaster.
1procedure IRaster.StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
2  MaxSize: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

MaxWidth

OleVariant

Да

MaxHeight

OleVariant

Да

MaxSize

OleVariant

Да

3.10.12. Интерфейс IScannerTools
1type
2  IScannerTools = interface(IDispatch)
3    ['{FC1B3C9F-7DE9-4909-B57D-6D33E3B0A87A}']
4    function AcquireImage(Silent: WordBool): IDispatch; safecall;
5    function AcquirePDF: IDispatch; safecall;
6  end;
3.10.12.1. Метод AcquireImage

Метод интерфейса IScannerTools.
function IScannerTools.AcquireImage(Silent: WordBool): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Silent

WordBool

Да

Замечания:

Возвращает значение типа IDispatch.

3.10.12.2. Метод AcquirePDF

Метод интерфейса IScannerTools.
function IScannerTools.AcquirePDF: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

3.10.13. Интерфейс ISetOfObjectsEditor
1type
2  ISetOfObjectsEditor = interface(IDispatch)
3    ['{6D3662A7-D9FF-4BD6-8D92-A4EA2058C74E}']
4    function Get_DomainName: WideString; safecall;
5    procedure Set_DomainName(Value: WideString); safecall;
6    function Get_SelectedCount: Integer; safecall;
7    property DomainName: WideString read Get_DomainName write Set_DomainName;
8    property SelectedCount: Integer read Get_SelectedCount;
9  end;
3.10.13.1. Свойства

Свойства интерфейса ISetOfObjectsEditor:

Имя

Тип

Доступ

Назначение

DomainName

WideString

Чтение/Запись

SelectedCount

Integer

Только для чтения

3.10.14. Интерфейс IZIPArchive
01type
02  IZIPArchive = interface(IDispatch)
03    ['{11C9400F-F262-4F72-882F-5AA5A4531591}']
04    procedure Load(Src: OleVariant); safecall;
05    procedure Save(Src: OleVariant); safecall;
06    function Get_FileCount: Integer; safecall;
07    function Get_FileName(Index: Integer): WideString; safecall;
08    function Get_FileData(Index: Integer): OleVariant; safecall;
09    procedure AddFile(const FileName: WideString; Data: OleVariant); safecall;
10    function Get_FileSize(Index: Integer): Int64; safecall;
11    function Get_FileDateTime(Index: Integer): TDateTime; safecall;
12    function Get_FileCRC(Index: Integer): WideString; safecall;
13    function Get_UTF8Support: WordBool; safecall;
14    procedure Set_UTF8Support(Value: WordBool); safecall;
15    property FileCount: Integer read Get_FileCount;
16    property FileName[Index: Integer]: WideString read Get_FileName;
17    property FileData[Index: Integer]: OleVariant read Get_FileData;
18    property FileSize[Index: Integer]: Int64 read Get_FileSize;
19    property FileDateTime[Index: Integer]: TDateTime read Get_FileDateTime;
20    property FileCRC[Index: Integer]: WideString read Get_FileCRC;
21    property UTF8Support: WordBool read Get_UTF8Support write Set_UTF8Support;
22  end;
3.10.14.1. Свойства

Свойства интерфейса IZIPArchive:

Имя

Тип

Доступ

Назначение

FileCRC[Index: Integer]

WideString

Только для чтения

FileCount

Integer

Только для чтения

FileData[Index: Integer]

OleVariant

Только для чтения

FileDateTime[Index: Integer]

TDateTime

Только для чтения

FileName[Index: Integer]

WideString

Только для чтения

FileSize[Index: Integer]

Int64

Только для чтения

UTF8Support

WordBool

Чтение/Запись

3.10.14.2. Метод AddFile

Метод интерфейса IZIPArchive.
procedure IZIPArchive.AddFile(const FileName: WideString; Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

FileName

WideString

Да

Data

OleVariant

Да

3.10.14.3. Метод Load

Метод интерфейса IZIPArchive.
procedure IZIPArchive.Load(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

3.10.14.4. Метод Save

Метод интерфейса IZIPArchive.
procedure IZIPArchive.Save(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

3.11. Дополнительные интерфейсы

3.11.1. Интерфейс IBinaryData
01type
02  IBinaryData = interface(IDispatch)
03    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
04    procedure Append(Src: OleVariant); safecall;
05    procedure Load(Src: OleVariant); safecall;
06    procedure Save(Dst: OleVariant); safecall;
07    function Size: LongWord; safecall;
08    procedure AppendData(Data: OleVariant; DataSize: LongWord); safecall;
09    procedure SetData(Data: OleVariant; DataSize: LongWord); safecall;
10    procedure GetData(Data: OleVariant); safecall;
11    function ToString(const Encoding: WideString): WideString; safecall;
12    procedure FromString(Data: OleVariant); safecall;
13    procedure AppendString(Data: OleVariant); safecall;
14    function ToBase64(Width: Integer): WideString; safecall;
15    procedure FromBase64(Data: OleVariant); safecall;
16    function ContentIsText: WordBool; safecall;
17  end;
3.11.1.1. Метод Append

Метод интерфейса IBinaryData.
procedure IBinaryData.Append(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

3.11.1.2. Метод AppendData

Метод интерфейса IBinaryData.
procedure IBinaryData.AppendData(Data: OleVariant; DataSize: LongWord);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

DataSize

LongWord

Да

3.11.1.3. Метод AppendString

Метод интерфейса IBinaryData.
procedure IBinaryData.AppendString(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

3.11.1.4. Метод ContentIsText

Метод интерфейса IBinaryData.
function IBinaryData.ContentIsText: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

3.11.1.5. Метод FromBase64

Метод интерфейса IBinaryData.
procedure IBinaryData.FromBase64(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

3.11.1.6. Метод FromString

Метод интерфейса IBinaryData.
procedure IBinaryData.FromString(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

3.11.1.7. Метод GetData

Метод интерфейса IBinaryData.
procedure IBinaryData.GetData(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

3.11.1.8. Метод Load

Метод интерфейса IBinaryData.
procedure IBinaryData.Load(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

3.11.1.9. Метод Save

Метод интерфейса IBinaryData.
procedure IBinaryData.Save(Dst: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

3.11.1.10. Метод SetData

Метод интерфейса IBinaryData.
procedure IBinaryData.SetData(Data: OleVariant; DataSize: LongWord);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

DataSize

LongWord

Да

3.11.1.11. Метод Size

Метод интерфейса IBinaryData.
function IBinaryData.Size: LongWord;
Метод не имеет параметров.

Замечания:

Возвращает значение типа LongWord.

3.11.1.12. Метод ToBase64

Метод интерфейса IBinaryData.
function IBinaryData.ToBase64(Width: Integer): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Width

Integer

Нет

Замечания:

Возвращает значение типа WideString.

3.11.1.13. Метод ToString

Метод интерфейса IBinaryData.
function IBinaryData.ToString(const Encoding: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Encoding

WideString

Да

Замечания:

Возвращает значение типа WideString.

4. Справочник по метаданным

4.1. Перечисление Resource strings (Ресурсные строки)
01type
02  Resource strings = (rssRole, rssUser, rssIsMemberOf,
03    rssRoleCannotBeMemberOfItself, rssRoleCannotHavePrimaryRole, rssCanUse,
04    rssVirtualException, rssDataBaseIdentifierTooLong,
05    rssDefaultConstructorDescription, rssDefaultConstructorActionDescription,
06    rssDefaultDesctructorActionDescription, rssDefaultExcelActionDescription,
07    rssUsersActivityOn, rssHours, rssLocalCharacters, rssCannotLocalizeClass,
08    rssCannotLocalizeField, rssCannotTranslateUntranslatable,
09    rssCannotSendMessageToNotApprovedContact, rssCannotCreateContactForYourself,
10    rssCannotSendMessageForYourself, rssOverwriteFile, rssOverwriteAccessibleFile,
11    rssReplaceCurrentTemplate, rssReplaceAllImages, rssReplaceAllMethods,
12    rssReplaceAllTemplates, rssLoadingProcess, rssDoNotFogetMacroName,
13    rssCheckOleObjectMethodErrorMethodNotSpecified,
14    rssCheckOleObjectMethodErrorClassIDNotSpecified,
15    rssCheckOleObjectMethodErrorCodeLibraryNotSpecified,
16    rssCheckOleObjectMethodErrorCodeLibraryNotFound,
17    rssCheckOleObjectMethodErrorXMLIsNotValid,
18    rssCheckOleObjectMethodErrorProgIDNotImplemented,
19    rssCheckOleObjectMethodErrorMethodNotImplemented,
20    rssCheckOleObjectMethodErrorNoParameters,
21    rssCheckOleObjectMethodErrorNoIDParameter,
22    rssCheckOleObjectMethodErrorParameterNames,
23    rssCheckOleObjectMethodErrorParameterCount, rssLoadingResources, rssMethodCall,
24    rssDMLOperation, rssReplaceAllBlobsContent,
25    rssCheckXSLTTemplateErrorXMLIsNotValid,
26    rssCheckXSLTTemplateErrorNoTemplateData,
27    rssCheckXSLTTemplateErrorNoIDParameter, rssCheckXSLTTemplateErrorNoParameter,
28    rssCheckXSLTTemplateErrorExcessParameter,
29    rssCheckOleObjectMethodErrorNoFunctionFound,
30    rssCheckExcelTemplateErrorNoTemplateData, rssCheckExcelTemplateErrorNoMacro,
31    rssCheckExcelTemplateErrorNoFunctionFound,
32    rssCheckWordTemplateErrorNoTemplateData, rssCheckWordTemplateErrorNoMacro,
33    rssCheckWordTemplateErrorNoFunctionFound, rssCheckTemplates,
34    rssUnexpectedDatabase, rssCannotSaveDatabaseLanguage, rssDomainNotFound,
35    rssCheckOfficeTemplateErrorMissingParameters,
36    rssCheckOfficeTemplateErrorMissingImplementationParameter,
37    rssCheckOfficeTemplateErrorParametersCountMismatched,
38    rssCheckOfficeTemplateErrorNoFunctionFound,
39    rssCheckOfficeTemplateErrorProjectSyntaxIncorrect,
40    rssCheckOfficeTemplateErrorIncludedModuleNotFound,
41    rssCheckOfficeTemplateWarningMethodBodyTooLong,
42    rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped,
43    rssCheckOfficeTemplateWarningOptionValueIncorrect,
44    rssCannotPerformTaskAlreadyRunning, rssCannotPerformTaskDueToStatus,
45    rssAsyncMethodInstantSuccess, rssAsyncMethodInstantError,
46    rssAsyncReportInstantSuccess, rssAsyncReportInstantError,
47    rssViewCannotContainColumns, rssMasterNotDefined, rssAbstractDomain);
Или
01type
02  Resource strings = TOleEnum;
03const
04  rssRole = $00000000;
05  rssUser = $00000001;
06  rssIsMemberOf = $00000002;
07  rssRoleCannotBeMemberOfItself = $00000003;
08  rssRoleCannotHavePrimaryRole = $00000004;
09  rssCanUse = $00000005;
10  rssVirtualException = $00000006;
11  rssDataBaseIdentifierTooLong = $00000007;
12  rssDefaultConstructorDescription = $00000008;
13  rssDefaultConstructorActionDescription = $00000009;
14  rssDefaultDesctructorActionDescription = $0000000A;
15  rssDefaultExcelActionDescription = $0000000B;
16  rssUsersActivityOn = $0000000C;
17  rssHours = $0000000D;
18  rssLocalCharacters = $0000000E;
19  rssCannotLocalizeClass = $0000000F;
20  rssCannotLocalizeField = $00000010;
21  rssCannotTranslateUntranslatable = $00000011;
22  rssCannotSendMessageToNotApprovedContact = $00000012;
23  rssCannotCreateContactForYourself = $00000013;
24  rssCannotSendMessageForYourself = $00000014;
25  rssOverwriteFile = $00000015;
26  rssOverwriteAccessibleFile = $00000016;
27  rssReplaceCurrentTemplate = $00000017;
28  rssReplaceAllImages = $00000018;
29  rssReplaceAllMethods = $00000019;
30  rssReplaceAllTemplates = $0000001A;
31  rssLoadingProcess = $0000001B;
32  rssDoNotFogetMacroName = $0000001C;
33  rssCheckOleObjectMethodErrorMethodNotSpecified = $0000001D;
34  rssCheckOleObjectMethodErrorClassIDNotSpecified = $0000001E;
35  rssCheckOleObjectMethodErrorCodeLibraryNotSpecified = $0000001F;
36  rssCheckOleObjectMethodErrorCodeLibraryNotFound = $00000020;
37  rssCheckOleObjectMethodErrorXMLIsNotValid = $00000021;
38  rssCheckOleObjectMethodErrorProgIDNotImplemented = $00000022;
39  rssCheckOleObjectMethodErrorMethodNotImplemented = $00000023;
40  rssCheckOleObjectMethodErrorNoParameters = $00000024;
41  rssCheckOleObjectMethodErrorNoIDParameter = $00000025;
42  rssCheckOleObjectMethodErrorParameterNames = $00000026;
43  rssCheckOleObjectMethodErrorParameterCount = $00000027;
44  rssLoadingResources = $00000028;
45  rssMethodCall = $00000029;
46  rssDMLOperation = $0000002A;
47  rssReplaceAllBlobsContent = $0000002B;
48  rssCheckXSLTTemplateErrorXMLIsNotValid = $0000002C;
49  rssCheckXSLTTemplateErrorNoTemplateData = $0000002D;
50  rssCheckXSLTTemplateErrorNoIDParameter = $0000002E;
51  rssCheckXSLTTemplateErrorNoParameter = $0000002F;
52  rssCheckXSLTTemplateErrorExcessParameter = $00000030;
53  rssCheckOleObjectMethodErrorNoFunctionFound = $00000031;
54  rssCheckExcelTemplateErrorNoTemplateData = $00000032;
55  rssCheckExcelTemplateErrorNoMacro = $00000033;
56  rssCheckExcelTemplateErrorNoFunctionFound = $00000034;
57  rssCheckWordTemplateErrorNoTemplateData = $00000035;
58  rssCheckWordTemplateErrorNoMacro = $00000036;
59  rssCheckWordTemplateErrorNoFunctionFound = $00000037;
60  rssCheckTemplates = $00000038;
61  rssUnexpectedDatabase = $00000039;
62  rssCannotSaveDatabaseLanguage = $0000003A;
63  rssDomainNotFound = $0000003B;
64  rssCheckOfficeTemplateErrorMissingParameters = $0000003C;
65  rssCheckOfficeTemplateErrorMissingImplementationParameter = $0000003D;
66  rssCheckOfficeTemplateErrorParametersCountMismatched = $0000003E;
67  rssCheckOfficeTemplateErrorNoFunctionFound = $0000003F;
68  rssCheckOfficeTemplateErrorProjectSyntaxIncorrect = $00000040;
69  rssCheckOfficeTemplateErrorIncludedModuleNotFound = $00000041;
70  rssCheckOfficeTemplateWarningMethodBodyTooLong = $00000042;
71  rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped = $00000043;
72  rssCheckOfficeTemplateWarningOptionValueIncorrect = $00000044;
73  rssCannotPerformTaskAlreadyRunning = $00000045;
74  rssCannotPerformTaskDueToStatus = $00000046;
75  rssAsyncMethodInstantSuccess = $00000047;
76  rssAsyncMethodInstantError = $00000048;
77  rssAsyncReportInstantSuccess = $00000049;
78  rssAsyncReportInstantError = $0000004A;
79  rssViewCannotContainColumns = $0000004B;
80  rssMasterNotDefined = $0000004C;
81  rssAbstractDomain = $0000004D;
Элементы перечисления:

Имя

Значение

Назначение

rssRole

0

Роль

rssUser

1

Пользователь

rssIsMemberOf

2

является членом роли

rssRoleCannotBeMemberOfItself

3

Роль не может включать сама себя.

rssRoleCannotHavePrimaryRole

4

Роль не может иметь основную роль.

rssCanUse

5

использует(ют) объект

rssVirtualException

6

Ошибка вызова виртуального метода.

rssDataBaseIdentifierTooLong

7

Длина имени объекта, отображаемого на объект базы данных, не должна превышать 29 символов

rssDefaultConstructorDescription

8

создание

rssDefaultConstructorActionDescription

9

Создать

rssDefaultDesctructorActionDescription

10

Удалить

rssDefaultExcelActionDescription

11

Перенести в Excel

rssUsersActivityOn

12

Активность пользователей за

rssHours

13

Часы

rssLocalCharacters

14

АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯабвгдеёжзийклмнопрстуфхцчшщъыьэюя

rssCannotLocalizeClass

15

Нельзя локализовать класс

rssCannotLocalizeField

16

Нельзя локализовать поле

rssCannotTranslateUntranslatable

17

Нельзя перевести непереводимый элемент.

rssCannotSendMessageToNotApprovedContact

18

Нельзя отправить сообщение неодобренному контакту.

rssCannotCreateContactForYourself

19

Нельзя создать контакт для самого себя.

rssCannotSendMessageForYourself

20

Нельзя отправить сообщение самому себе.

rssOverwriteFile

21

Заменить содержимое файла "%FileName%"?

rssOverwriteAccessibleFile

22

Заменить содержимое доступного файла "%FileName%"?

rssReplaceCurrentTemplate

23

Заменить содержимое шаблона?

rssReplaceAllImages

24

Заменить содержимое всех изображений?

rssReplaceAllMethods

25

Заменить содержимое всех скриптов и тел методов?

rssReplaceAllTemplates

26

Заменить содержимое всех шаблонов всех отчетов?

rssLoadingProcess

27

Загрузка

rssDoNotFogetMacroName

28

Не забудьте установить имя макроса.

rssCheckOleObjectMethodErrorMethodNotSpecified

29

Имя метода не задано

rssCheckOleObjectMethodErrorClassIDNotSpecified

30

Идентификатор класса не задан

rssCheckOleObjectMethodErrorCodeLibraryNotSpecified

31

Библиотека кода не задана

rssCheckOleObjectMethodErrorCodeLibraryNotFound

32

Невозможно загрузить библиотеку кода "%CodeLibrary%"

rssCheckOleObjectMethodErrorXMLIsNotValid

33

Невалидный XML-документ

rssCheckOleObjectMethodErrorProgIDNotImplemented

34

Указанный ProgID "%ProgID%" не реализован в скриптлете

rssCheckOleObjectMethodErrorMethodNotImplemented

35

Метод не реализован

rssCheckOleObjectMethodErrorNoParameters

36

Метод должен объявлять хотя бы один параметр

rssCheckOleObjectMethodErrorNoIDParameter

37

Метод должен объявлять параметр с именем "ID"

rssCheckOleObjectMethodErrorParameterNames

38

Параметр с именем "%RealName%" не соответствует ожидаемому "%ExpectedName%"

rssCheckOleObjectMethodErrorParameterCount

39

Количество параметров "%RealCount%" в объявлении метода не совпадает с ожидаемым "%ExpectedCount%"

rssLoadingResources

40

Загрузка ресурсов

rssMethodCall

41

Вызов метода

rssDMLOperation

42

Операция с данными

rssReplaceAllBlobsContent

43

Заменить содержимое свойства %Class%.%Description% для всех объектов?

rssCheckXSLTTemplateErrorXMLIsNotValid

44

Невалидный XML-документ

rssCheckXSLTTemplateErrorNoTemplateData

45

Данные шаблона отсутствуют

rssCheckXSLTTemplateErrorNoIDParameter

46

Шаблон XSLT как метод экземпляра должен объявлять параметр "ID"

rssCheckXSLTTemplateErrorNoParameter

47

Параметр "%Name%" не найден в шаблоне

rssCheckXSLTTemplateErrorExcessParameter

48

Параметр шаблона "%Name%" не зарегистрирован в метаданных

rssCheckOleObjectMethodErrorNoFunctionFound

49

Подпрограмма, соответствующая макросу, отсутствует в скриптлете

rssCheckExcelTemplateErrorNoTemplateData

50

Данные шаблона отсутствуют

rssCheckExcelTemplateErrorNoMacro

51

Имя макроса не задано

rssCheckExcelTemplateErrorNoFunctionFound

52

Подпрограмма, соответствующая макросу, отсутствует в проекте VBA

rssCheckWordTemplateErrorNoTemplateData

53

Данные шаблона отсутствуют

rssCheckWordTemplateErrorNoMacro

54

Имя макроса не задано

rssCheckWordTemplateErrorNoFunctionFound

55

Подпрограмма, соответствующая макросу, отсутствует в проекте VBA

rssCheckTemplates

56

Проверка шаблонов

rssUnexpectedDatabase

57

Не поддерживается в этой БД

rssCannotSaveDatabaseLanguage

58

Язык базы данных не может быть сохранен в ресурсный файл.

rssDomainNotFound

59

Домен не найден

rssCheckOfficeTemplateErrorMissingParameters

60

Параметры, не найденные в реализации:

rssCheckOfficeTemplateErrorMissingImplementationParameter

61

Параметр %ParamName% не найден в реализации

rssCheckOfficeTemplateErrorParametersCountMismatched

62

Декларированное и реализованное количество параметров не соответствуют: %DeclaredCount% <> %ImplementedCount%

rssCheckOfficeTemplateErrorNoFunctionFound

63

Указанный макрос %MacroName% не найден

rssCheckOfficeTemplateErrorProjectSyntaxIncorrect

64

VBA проект синтаксически некорректный

rssCheckOfficeTemplateErrorIncludedModuleNotFound

65

Модуль кода %ModuleFileName% (в шаблоне %LinesCount% строк) не найден в Доступных файлах

rssCheckOfficeTemplateWarningMethodBodyTooLong

66

Возможно, тело метода %ProcName% (%ModuleFileName%) чрезмерно длинное (%ProcLineCount% строк)

rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped

67

Синтаксическая проверка проектов VBA не будет произведена, т.к. значение следующих настроек не удовлетворяют требуемым:

rssCheckOfficeTemplateWarningOptionValueIncorrect

68

Неверное значение VBA настройки "%OptionName%" - Включено

rssCannotPerformTaskAlreadyRunning

69

Выполнение невозможно, задача уже выполняется

rssCannotPerformTaskDueToStatus

70

Выполнение невозможно, задача имеет недопустимое состояние

rssAsyncMethodInstantSuccess

71

Метод выполнен

rssAsyncMethodInstantError

72

Ошибка выполнения метода

rssAsyncReportInstantSuccess

73

Отчет сформирован

rssAsyncReportInstantError

74

Ошибка выполнения отчета

rssViewCannotContainColumns

75

Это представление не может содержать колонки.

rssMasterNotDefined

76

Не задан мастер для объекта %Name% (%Description%) класса "%Class%".

rssAbstractDomain

77

Абстрактный домен

4.2. Перечисление TAggregateKind (Тип агрегата)
1type
2  TAggregateKind = (agCount = 1, agSumm = 2, agMax = 3, agMin = 4, agAverage = 5,
3    agCountDistinct = 6);
Или
1type
2  TAggregateKind = TOleEnum;
3const
4  agCount = $00000001;
5  agSumm = $00000002;
6  agMax = $00000003;
7  agMin = $00000004;
8  agAverage = $00000005;
9  agCountDistinct = $00000006;
Элементы перечисления:

Имя

Значение

Назначение

agCount

1

Количество

agSumm

2

Сумма

agMax

3

Максимальное значение

agMin

4

Минимальное значение

agAverage

5

Среднее значение

agCountDistinct

6

Количество уникальных

4.3. Перечисление TAsyncTaskStatus (Состояние задачи отложенного выполнения)
1type
2  TAsyncTaskStatus = (astCreated, astReady, astRunning, astSuccess, astError);
Или
1type
2  TAsyncTaskStatus = TOleEnum;
3const
4  astCreated = $00000000;
5  astReady = $00000001;
6  astRunning = $00000002;
7  astSuccess = $00000003;
8  astError = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

astCreated

0

Создано

astReady

1

Готово к выполнению

astRunning

2

Выполняется

astSuccess

3

Завершено

astError

4

Прервано

4.4. Перечисление TBlobSubtype (Подтип)
1type
2  TBlobSubtype = (btBinaryData, btText, btImage, btSourceCode, btXML,
3    btNamedFile, btVisualBasicScript, btXHTML, btJavaScript, btHTML);
Или
01type
02  TBlobSubtype = TOleEnum;
03const
04  btBinaryData = $00000000;
05  btText = $00000001;
06  btImage = $00000002;
07  btSourceCode = $00000003;
08  btXML = $00000004;
09  btNamedFile = $00000005;
10  btVisualBasicScript = $00000006;
11  btXHTML = $00000007;
12  btJavaScript = $00000008;
13  btHTML = $00000009;
Элементы перечисления:

Имя

Значение

Назначение

btBinaryData

0

Двоичные данные

btText

1

Текст

btImage

2

Изображение

btSourceCode

3

Исходный код

btXML

4

XML-документ

btNamedFile

5

Именованный файл

btVisualBasicScript

6

Скрипт Visual Basic

btXHTML

7

XHTML-документ

btJavaScript

8

Скрипт JavaScript

btHTML

9

HTML-документ

4.5. Перечисление TChangeAction (Действие при изменении)
1type
2  TChangeAction = (atCreated, atChanging, atChanged, atDestroying, atPasted);
Или
1type
2  TChangeAction = TOleEnum;
3const
4  atCreated = $00000000;
5  atChanging = $00000001;
6  atChanged = $00000002;
7  atDestroying = $00000003;
8  atPasted = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

atCreated

0

Создан

atChanging

1

Изменится

atChanged

2

Изменен

atDestroying

3

Удаляется

atPasted

4

Вставлен из буфера

4.6. Перечисление TComparisonType (Типы сравнения)
1type
2  TComparisonType = (ctEqual, ctNotEqual, ctGreater, ctGreaterOrEqual, ctLess,
3    ctLessOrEqual, ctLike, ctNotLike, ctRegexpLike, ctNotRegexpLike, ctIsParent,
4    ctIsChild);
Или
01type
02  TComparisonType = TOleEnum;
03const
04  ctEqual = $00000000;
05  ctNotEqual = $00000001;
06  ctGreater = $00000002;
07  ctGreaterOrEqual = $00000003;
08  ctLess = $00000004;
09  ctLessOrEqual = $00000005;
10  ctLike = $00000006;
11  ctNotLike = $00000007;
12  ctRegexpLike = $00000008;
13  ctNotRegexpLike = $00000009;
14  ctIsParent = $0000000A;
15  ctIsChild = $0000000B;
Элементы перечисления:

Имя

Значение

Назначение

ctEqual

0

Равно

ctNotEqual

1

Не равно

ctGreater

2

Больше

ctGreaterOrEqual

3

Больше или равно

ctLess

4

Меньше

ctLessOrEqual

5

Меньше или равно

ctLike

6

Подобно

ctNotLike

7

Не подобно

ctRegexpLike

8

Удовлетворяет регулярному выражению

ctNotRegexpLike

9

Не удовлетворяет регулярному выражению

ctIsParent

10

Является родителем

ctIsChild

11

Является потомком

4.7. Перечисление TDateTimePart (Часть даты или времени)
1type
2  TDateTimePart = (dpYear, dpMonth, dpDay, dpHour, dpMinute, dpSecond,
3    dpDayOfWeek);
Или
01type
02  TDateTimePart = TOleEnum;
03const
04  dpYear = $00000000;
05  dpMonth = $00000001;
06  dpDay = $00000002;
07  dpHour = $00000003;
08  dpMinute = $00000004;
09  dpSecond = $00000005;
10  dpDayOfWeek = $00000006;
Элементы перечисления:

Имя

Значение

Назначение

dpYear

0

Год

dpMonth

1

Месяц

dpDay

2

День

dpHour

3

Час

dpMinute

4

Минута

dpSecond

5

Секунда

dpDayOfWeek

6

День недели

4.8. Перечисление TDeleteRule (Правило удаления)
1type
2  TDeleteRule = (drRestrict, drCascade, drSetNull);
Или
1type
2  TDeleteRule = TOleEnum;
3const
4  drRestrict = $00000000;
5  drCascade = $00000001;
6  drSetNull = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

drRestrict

0

Нет правила

drCascade

1

Каскадное удаление

drSetNull

2

Очистить ссылку

4.9. Перечисление TDuplicates (Дубликаты)
1type
2  TDuplicates = (dupIgnore, dupAccept, dupError);
Или
1type
2  TDuplicates = TOleEnum;
3const
4  dupIgnore = $00000000;
5  dupAccept = $00000001;
6  dupError = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

dupIgnore

0

Игнорировать дубликаты

dupAccept

1

Разрешить дублирование

dupError

2

Генерировать ошибку дублирования

4.10. Перечисление TExcelOutputFormat (Формат результата отчета Excel)
1type
2  TExcelOutputFormat = (eofDefault, eof2003, eofHTML, eofPDF, eofNativePDF,
3    eofXPS);
Или
1type
2  TExcelOutputFormat = TOleEnum;
3const
4  eofDefault = $00000000;
5  eof2003 = $00000001;
6  eofHTML = $00000002;
7  eofPDF = $00000003;
8  eofNativePDF = $00000004;
9  eofXPS = $00000005;
Элементы перечисления:

Имя

Значение

Назначение

eofDefault

0

По умолчанию

eof2003

1

Рабочая книга Excel 97-2003

eofHTML

2

Документ HTML

eofPDF

3

Документ PDF

eofNativePDF

4

Документ PDF, сформированный Excel

eofXPS

5

Документ XPS

4.11. Перечисление TExcelSheetKind (Тип листа Excel)
1type
2  TExcelSheetKind = (skNone, skFirst, skFirstHidden, skLast, skNew);
Или
1type
2  TExcelSheetKind = TOleEnum;
3const
4  skNone = $00000000;
5  skFirst = $00000001;
6  skFirstHidden = $00000002;
7  skLast = $00000003;
8  skNew = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

skNone

0

Не переносить данные на лист

skFirst

1

На первый лист

skFirstHidden

2

На первый скрытый лист

skLast

3

На последний лист

skNew

4

На новый лист

4.12. Перечисление TExternalDataProtocol (Протокол доступа к внешним данным)
1type
2  TExternalDataProtocol = (prLocal, prHTTP, prHTTPS, prFTP, prFTPS, prSMB);
Или
1type
2  TExternalDataProtocol = TOleEnum;
3const
4  prLocal = $00000000;
5  prHTTP = $00000001;
6  prHTTPS = $00000002;
7  prFTP = $00000003;
8  prFTPS = $00000004;
9  prSMB = $00000005;
Элементы перечисления:

Имя

Значение

Назначение

prLocal

0

Файл доступен локально

prHTTP

1

Протокол HTTP

prHTTPS

2

Протокол HTTPS

prFTP

3

Протокол FTP

prFTPS

4

Протокол FTPS

prSMB

5

Протокол SMB

4.13. Перечисление TFormViewLayout (Виды расположения)
1type
2  TFormViewLayout = (vlHorizontal, vlVertical);
Или
1type
2  TFormViewLayout = TOleEnum;
3const
4  vlHorizontal = $00000000;
5  vlVertical = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

vlHorizontal

0

Горизонтальное

vlVertical

1

Вертикально

4.14. Перечисление TInstantContactStatus (Статус контакта)
1type
2  TInstantContactStatus = (icsPending, icsRefused, icsApproved);
Или
1type
2  TInstantContactStatus = TOleEnum;
3const
4  icsPending = $00000000;
5  icsRefused = $00000001;
6  icsApproved = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

icsPending

0

Рассматривается

icsRefused

1

Отказано

icsApproved

2

Утвержденный

4.15. Перечисление TInstantMessageAttachmentType (Тип вложения мгновенного сообщения)
1type
2  TInstantMessageAttachmentType = (imaFile, imaImage, imaHyperLink, imaObject);
Или
1type
2  TInstantMessageAttachmentType = TOleEnum;
3const
4  imaFile = $00000000;
5  imaImage = $00000001;
6  imaHyperLink = $00000002;
7  imaObject = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

imaFile

0

Файл

imaImage

1

Изображение

imaHyperLink

2

Гиперссылка

imaObject

3

Объект

4.16. Перечисление TInstantMessageAttachmentType (None) (Тип вложения мгновенного сообщения (None))
1type
2  TInstantMessageAttachmentType (None) = (imaFile, imaImage, imaHyperLink,
3    imaObject, imaNone);
Или
1type
2  TInstantMessageAttachmentType (None) = TOleEnum;
3const
4  imaFile = $00000000;
5  imaImage = $00000001;
6  imaHyperLink = $00000002;
7  imaObject = $00000003;
8  imaNone = $00000004;
Это перечисление использует элементы TInstantMessageAttachmentType.

Элементы перечисления:

Имя

Значение

Назначение

imaFile

0

Определено в базовом перечислении TInstantMessageAttachmentType

imaImage

1

Определено в базовом перечислении TInstantMessageAttachmentType

imaHyperLink

2

Определено в базовом перечислении TInstantMessageAttachmentType

imaObject

3

Определено в базовом перечислении TInstantMessageAttachmentType

imaNone

4

Нет

4.17. Перечисление TNotificationType (Тип уведомления)
1type
2  TNotificationType = (ntInformation, ntWarning, ntCaution);
Или
1type
2  TNotificationType = TOleEnum;
3const
4  ntInformation = $00000000;
5  ntWarning = $00000001;
6  ntCaution = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

ntInformation

0

Информация

ntWarning

1

Предупреждение

ntCaution

2

Проблема

4.18. Перечисление TOutputColorMode (Режим цветопередачи)
1type
2  TOutputColorMode = (wcmNormal, wcmGrayscale, wcmMonochrome);
Или
1type
2  TOutputColorMode = TOleEnum;
3const
4  wcmNormal = $00000000;
5  wcmGrayscale = $00000001;
6  wcmMonochrome = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

wcmNormal

0

Цветной

wcmGrayscale

1

В градациях серого

wcmMonochrome

2

Монохромный

4.19. Перечисление TReplicationStatus (Статус репликации)
1type
2  TReplicationStatus = (rsNotReplicatable, rsReplicatableMetadata, rsReplicatable);
Или
1type
2  TReplicationStatus = TOleEnum;
3const
4  rsNotReplicatable = $00000000;
5  rsReplicatableMetadata = $00000001;
6  rsReplicatable = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

rsNotReplicatable

0

Не реплицировать

rsReplicatableMetadata

1

Вместе с метаданными

rsReplicatable

2

Вместе с бизнес-данными

4.20. Перечисление TRowColor (Цвет строки таблицы)
1type
2  TRowColor = (rcDefault, rcRed, rcGreen, rcBlue, rcPale, rcCyan, rcMagenta,
3    rcYellow);
Или
01type
02  TRowColor = TOleEnum;
03const
04  rcDefault = $00000000;
05  rcRed = $00000001;
06  rcGreen = $00000002;
07  rcBlue = $00000003;
08  rcPale = $00000004;
09  rcCyan = $00000005;
10  rcMagenta = $00000006;
11  rcYellow = $00000007;
Элементы перечисления:

Имя

Значение

Назначение

rcDefault

0

По умолчанию

rcRed

1

Красная строка

rcGreen

2

Зеленая строка

rcBlue

3

Синяя строка

rcPale

4

Бледная строка

rcCyan

5

Голубая строка

rcMagenta

6

Пурпурная строка

rcYellow

7

Желтая строка

4.21. Перечисление TScope (Область видимости)
1type
2  TScope = (scPrivate, scPublic);
Или
1type
2  TScope = TOleEnum;
3const
4  scPrivate = $00000000;
5  scPublic = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

scPrivate

0

Не видимо пользователям

scPublic

1

Видимо пользователям

4.22. Перечисление TSecurityModel (Модели безопасности)
1type
2  TSecurityModel = (smFullAccess, smPublic, smPrivate, smByAffiliation);
Или
1type
2  TSecurityModel = TOleEnum;
3const
4  smFullAccess = $00000000;
5  smPublic = $00000001;
6  smPrivate = $00000002;
7  smByAffiliation = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

smFullAccess

0

Доступ не ограничен

smPublic

1

Публичный объект

smPrivate

2

Приватный объект

smByAffiliation

3

Доступ по принадлежности

4.23. Перечисление TShowObjectInfoType (Тип представления объектов)
1type
2  TShowObjectInfoType = (soName, soDescription);
Или
1type
2  TShowObjectInfoType = TOleEnum;
3const
4  soName = $00000000;
5  soDescription = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

soName

0

Показывать имена

soDescription

1

Показывать наименования

4.24. Перечисление TSortDirection (Направление сортировки)
1type
2  TSortDirection = (sdNone, sdAscending, sdDescending);
Или
1type
2  TSortDirection = TOleEnum;
3const
4  sdNone = $00000000;
5  sdAscending = $00000001;
6  sdDescending = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

sdNone

0

Нет

sdAscending

1

По возрастанию

sdDescending

2

По убыванию

4.25. Перечисление TTranslationStatus (Состояния перевода)
1type
2  TTranslationStatus = (tsNotTranslated, tsTranslated, tsUntranslatable, tsDirty);
Или
1type
2  TTranslationStatus = TOleEnum;
3const
4  tsNotTranslated = $00000000;
5  tsTranslated = $00000001;
6  tsUntranslatable = $00000002;
7  tsDirty = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

tsNotTranslated

0

Не переведено

tsTranslated

1

Переведено

tsUntranslatable

2

Не нуждается в переводе

tsDirty

3

Грязный

4.26. Перечисление TUserAccessMode (Режим доступа)
1type
2  TUserAccessMode = (uaFullAccess, uaReadOnly, uaAccessDenied);
Или
1type
2  TUserAccessMode = TOleEnum;
3const
4  uaFullAccess = $00000000;
5  uaReadOnly = $00000001;
6  uaAccessDenied = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

uaFullAccess

0

Полный доступ

uaReadOnly

1

Доступ только для чтения

uaAccessDenied

2

Доступ запрещен

4.27. Перечисление TWordOutputFormat (Формат результата отчета Word)
1type
2  TWordOutputFormat = (wofDefault, wof2003, wofHTML, wofRTF, wofPDF);
Или
1type
2  TWordOutputFormat = TOleEnum;
3const
4  wofDefault = $00000000;
5  wof2003 = $00000001;
6  wofHTML = $00000002;
7  wofRTF = $00000003;
8  wofPDF = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

wofDefault

0

По умолчанию

wof2003

1

Документ Word 97-2003

wofHTML

2

Документ HTML

wofRTF

3

Документ RTF

wofPDF

4

Документ PDF

4.28. Класс TAccessibleFile (Доступный файл)

4.28.1. Свойства

Свойства класса TAccessibleFile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

FileData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные файла

CRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

4.28.2. Конструктор Create (Конструктор доступного файла)

Конструктор класса TAccessibleFile.
1constructor TAccessibleFile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  FileData: blob): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

FileData

blob

Нет

Данные файла

Замечания:

Создает новый объект класса TAccessibleFile.

4.28.3. Метод SetData (Установить значение свойства "Данные файла")

Метод экземпляра класса TAccessibleFile.
procedure TAccessibleFile.SetData(FileData: blob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

FileData

blob

Нет

Данные файла

4.28.4. Метод Ole-объекта CheckAllCRC (Обновить отсутствующие контрольные суммы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

4.28.5. Метод Ole-объекта CheckCRC (Обновить контрольную сумму)

Метод Ole-объекта класса TAccessibleFile.

Метод Ole-объекта не имеет параметров.

4.28.6. Метод Ole-объекта LoadFromFolder (Загрузить из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

4.28.7. Метод Ole-объекта SaveToFolder (Сохранить в папку)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

4.28.8. Метод Ole-объекта UpdateFromFolder (Обновить из папки)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

4.29. Класс TAccessItem (Элементы доступа)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.29.1. Свойства

Свойства класса TAccessItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Скрыто от пользователя

Чтение/Запись

Имя

Description

string[128]

Да

Скрыто от пользователя

Чтение/Запись

Наименование

Class

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

Элемент

MasterName

string[64]

Да

Видимо пользователю

Только для чтения

Имя элемента

MasterDescription

string[128]

Да

Видимо пользователю

Только для чтения

Наименование элемента

MasterClass

TClass

Да

Видимо пользователю

Только для чтения

Класс элемента

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

SecurityAccountName

string[64]

Да

Видимо пользователю

Чтение/Запись

Имя роли безопасности

SecurityAccountDescription

string[128]

Да

Видимо пользователю

Чтение/Запись

Наименование роли безопасности

SecurityAccountClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс роли безопасности

4.29.2. Конструктор Create (Конструктор элемента доступа)

Конструктор класса TAccessItem.
1constructor TAccessItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TAccessItem.

4.29.3. Метод GetIsAccessible (Проверка доступности)

Метод класса (статический метод) класса TAccessItem.
class function TAccessItem.GetIsAccessible(Master: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Boolean.

4.30. Класс TAccessProfile (Профили доступа)

4.30.1. Свойства

Свойства класса TAccessProfile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TProfile

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

ComparisonType

TComparisonType

Да

Видимо пользователю

Чтение/Запись

BasedOnProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Active

Boolean

Да

Видимо пользователю

Только для чтения

Access

Boolean

Да

Видимо пользователю

Чтение/Запись

Доступ

4.30.2. Конструктор Create (Конструктор профиля доступа)

Конструктор класса TAccessProfile.
1constructor TAccessProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType; BasedOnProfile: TProfile;
4  Access: Boolean): TObject;
Переопределяет метод в TProfile.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Унаследовано от TProfile.Create

ComparisonType

TComparisonType

Да

BasedOnProfile

TProfile

Нет

Access

Boolean

Да

Доступ

Замечания:

Создает новый объект класса TAccessProfile.

4.31. Класс TAction (Действия)

Объекты класса образуют иерархию.

4.31.1. Свойства

Свойства класса TAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Горячая клавиша

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Отделено

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

По умолчанию

4.31.2. Конструктор Create (Конструктор действия)

Конструктор класса TAction.
1constructor TAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean;
4  Default: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Shortcut

string[20]

Нет

Горячая клавиша

Separated

Boolean

Да

Отделено

Default

Boolean

Да

По умолчанию

Замечания:

Создает новый объект класса TAction.

4.31.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TAction.
1class function TAction.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Parent

TObject

Нет

Родитель

Step

Integer

Да

Шаг

Замечания:

Возвращает значение типа Integer.

4.32. Класс TActionContextProperty (Свойство контекста)

Имена объектов класса генерируются.

4.32.1. Свойства

Свойства класса TActionContextProperty:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Property

TProperty

Да

Видимо пользователю

Чтение/Запись

Свойство

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

4.32.2. Конструктор Create (Конструктор контекстного свойства)

Конструктор класса TActionContextProperty.
1constructor TActionContextProperty.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Property: TProperty; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Property

TProperty

Да

Свойство

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TActionContextProperty.

4.32.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TActionContextProperty.
class function TActionContextProperty.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

4.33. Класс TAsyncHandler (Обработчики отложенного выполнения)

4.33.1. Свойства

Свойства класса TAsyncHandler:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Validator

TMethod

Нет

Видимо пользователю

Чтение/Запись

Процедура-валидатор

Handler

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Процедура-обработчик

4.33.2. Конструктор Create (Конструктор обработчика отложенного выполнения)

Конструктор класса TAsyncHandler.
1constructor TAsyncHandler.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Validator: TMethod; Handler: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Validator

TMethod

Нет

Процедура-валидатор

Handler

TRoutine

Нет

Процедура-обработчик

Замечания:

Создает новый объект класса TAsyncHandler.

4.33.3. Метод GetIsAccessible (Доступен)

Метод экземпляра класса TAsyncHandler.
function TAsyncHandler.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.33.4. Метод ValidateInstantMessage (Доступен обработчик с уведомлением сообщением)

Метод класса (статический метод) класса TAsyncHandler.
class function TAsyncHandler.ValidateInstantMessage(Routine: TRoutine): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Замечания:

Возвращает значение типа Boolean.

4.33.5. Метод ValidateWithoutNotification (Доступен обработчик без уведомления)

Метод класса (статический метод) класса TAsyncHandler.
class function TAsyncHandler.ValidateWithoutNotification(Routine: TRoutine): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Замечания:

Возвращает значение типа Boolean.

4.34. Класс TAsyncHandlerAccess (Доступ к обработчикам отложенного выполнения)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.34.1. Конструктор Create (Конструктор доступа к обработчикам отложенного выполнения)

Конструктор класса TAsyncHandlerAccess.
1constructor TAsyncHandlerAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TAsyncHandlerAccess.

4.35. Класс TAsyncTask (Задачи отложенного выполнения)

Объекты класса не именованы.

4.35.1. Свойства

Свойства класса TAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Created

datetime

Да

Видимо пользователю

Только для чтения

Время создания

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Состояние

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Язык

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

Обработчик

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Представление формы

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Объект

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Время начала выполнения

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Время завершения выполнения

Duration

time

Нет

Видимо пользователю

Только для чтения

Длительность

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

Выделено

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Цвет строки

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

Группа

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Содержимое группы готово

4.35.2. Конструктор Create (Конструктор задачи отложенного выполнения)

Конструктор класса TAsyncTask.
1constructor TAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Подпрограмма

Object

TObject

Нет

Объект

FormView

TFormView

Нет

Представление формы

Handler

TAsyncHandler

Да

Обработчик

Language

TLanguage

Да

Язык

Замечания:

Создает новый объект класса TAsyncTask.

4.35.3. Деструктор Destroy (Деструктор объекта)

Деструктор класса TAsyncTask.
destructor TAsyncTask.Destroy;
Переопределяет метод в TObject.Destroy.

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TAsyncTask или его наследника.

4.35.4. Метод Archive (Отправить в архив)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Archive;
Метод не имеет параметров.

4.35.5. Метод CreateGroup (Создать группу)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.CreateGroup(Group: clob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Group

clob

Нет

Группа

4.35.6. Метод Finish (Зафиксировать завершение выполнения)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Finish(Success: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Success

Boolean

Да

Выполнено успешно

4.35.7. Метод HandleInstantMessage (Обработчик с уведомлением сообщением)

Метод экземпляра класса TAsyncTask.
1procedure TAsyncTask.HandleInstantMessage(Success: Boolean;
2  ErrorMessage: string[2000]; ExceptionClass: string[2000];
3  NativeMessage: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Success

Boolean

Да

Выполнено успешно

ErrorMessage

string[2000]

Нет

Сообщение об ошибке

ExceptionClass

string[2000]

Нет

Класс ошибки

NativeMessage

string[2000]

Нет

Системное сообщение об ошибке

4.35.8. Метод HasAsyncTasks (Имеются задачи отложенного выполнения)

Метод класса (статический метод) класса TAsyncTask.
class function TAsyncTask.HasAsyncTasks: Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.35.9. Метод Start (Зафиксировать начало выполнения)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Start;
Метод скрыт от пользователя.

Метод не имеет параметров.

4.35.10. Метод Ole-объекта PerformImmediate (Выполнить немедленно)

Метод Ole-объекта класса TAsyncTask.

Метод Ole-объекта не имеет параметров.

4.36. Класс TAsyncTaskParameterValue (Значения параметров задачи отложенного выполнения)

Объекты класса не именованы.

4.36.1. Свойства

Свойства класса TAsyncTaskParameterValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Temporary

Boolean

Да

Видимо пользователю

Чтение/Запись

Временный объект

4.36.2. Конструктор Create (Конструктор значения параметров задачи отложенного выполнения)

Конструктор класса TAsyncTaskParameterValue.
1constructor TAsyncTaskParameterValue.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Domain: TDomain; Position: Integer;
4  Group: string[128]; Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]; IntValue: Integer; FloatValue: float; DateValue: date;
6  TimeValue: time; DateTimeValue: datetime; ObjectValue: TObject;
7  BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
8  ExternalDataValue: <external data>; Temporary: Boolean): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Унаследовано от TTypedValue.Create

Position

Integer

Да

Group

string[128]

Нет

Tab

string[128]

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

StrValue

string[2000]

Нет

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

Temporary

Boolean

Да

Временный объект

Замечания:

Создает новый объект класса TAsyncTaskParameterValue.

4.36.3. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TAsyncTaskParameterValue.
function TAsyncTaskParameterValue.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

4.37. Класс TBanGroup (Группы запретов)

4.37.1. Свойства

Свойства класса TBanGroup:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступна

4.37.2. Конструктор Create (Конструктор группы запретов)

Конструктор класса TBanGroup.
1constructor TBanGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TBanGroup.

4.37.3. Метод CreateAllBans (Сгенерировать запреты для класса)

Метод экземпляра класса TBanGroup.
1procedure TBanGroup.CreateAllBans(BannedClass: TClass; BanClass: Boolean;
2  BanRoutines: Boolean; BanProperties: Boolean; AllowRead: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

BannedClass

TClass

Да

Запрещаемый класс

BanClass

Boolean

Да

Запретить доступ к объектам класса

BanRoutines

Boolean

Да

Запретить подпрограммы

BanProperties

Boolean

Да

Запретить свойства

AllowRead

Boolean

Да

Чтение свойств разрешено

4.37.4. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TBanGroup.
function TBanGroup.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.38. Класс TBanGroupAccess (Доступ к группам запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.38.1. Конструктор Create (Конструктор доступа к группе запретов)

Конструктор класса TBanGroupAccess.
1constructor TBanGroupAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TBanGroup; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TBanGroup

Да

Группа запретов

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TBanGroupAccess.

4.39. Класс TBanGroupItem (Элементы группы запретов)

4.39.1. Свойства

Свойства класса TBanGroupItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Мастер

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

4.39.2. Конструктор Create (Конструктор элемента группы запретов)

Конструктор класса TBanGroupItem.
1constructor TBanGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TBanGroupItem.

4.40. Класс TBlobDomain (Большие объекты)

4.40.1. Свойства

Свойства класса TBlobDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

BlobSubtype

TBlobSubtype

Да

Видимо пользователю

Чтение/Запись

Подтип

Extension

string[10]

Нет

Видимо пользователю

Чтение/Запись

Расширение

ShowInPlace

Boolean

Да

Видимо пользователю

Чтение/Запись

Редактировать по месту

EditorClassID

string[128]

Нет

Видимо пользователю

Чтение/Запись

Идентификатор класса-редактора

EditorCodeLibrary

TAccessibleFile

Нет

Видимо пользователю

Чтение/Запись

Библиотека кода редактора

SizeLimit

Integer

Нет

Видимо пользователю

Чтение/Запись

Ограничение на размер

IsBinary

Boolean

Да

Видимо пользователю

Только для чтения

Двоичные данные

4.40.2. Конструктор Create (Конструктор домена больших объектов)

Конструктор класса TBlobDomain.
1constructor TBlobDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; BlobSubtype: TBlobSubtype; SizeLimit: Integer;
4  Extension: string[10]; ShowInPlace: Boolean; EditorClassID: string[128];
5  EditorCodeLibrary: TAccessibleFile): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

BlobSubtype

TBlobSubtype

Да

Подтип

SizeLimit

Integer

Нет

Ограничение на размер

Extension

string[10]

Нет

Расширение

ShowInPlace

Boolean

Да

Редактировать по месту

EditorClassID

string[128]

Нет

Идентификатор класса-редактора

EditorCodeLibrary

TAccessibleFile

Нет

Библиотека кода редактора

Замечания:

Создает новый объект класса TBlobDomain.

4.40.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TBlobDomain.
function TBlobDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.41. Класс TBooleanDomain (Логические)

4.41.1. Свойства

Свойства класса TBooleanDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

TrueValue

string[64]

Да

Видимо пользователю

Чтение/Запись

Значение "Истина"

FalseValue

string[64]

Да

Видимо пользователю

Чтение/Запись

Значение "Ложь"

4.41.2. Конструктор Create (Конструктор логического домена)

Конструктор класса TBooleanDomain.
1constructor TBooleanDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; TrueValue: string[64]; FalseValue: string[64]): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

TrueValue

string[64]

Да

Значение "Истина"

FalseValue

string[64]

Да

Значение "Ложь"

Замечания:

Создает новый объект класса TBooleanDomain.

4.41.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TBooleanDomain.
function TBooleanDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.42. Класс TClass (Классы)

Объекты класса образуют иерархию.

4.42.1. Свойства

Свойства класса TClass:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Чтение/Запись

Статус репликации

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Унаследовано от TObject

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Является иерархическим

SecurityModel

TSecurityModel

Да

Видимо пользователю

Чтение/Запись

Модель безопасности

DefaultAccessor

TSecurityAccount

Нет

Видимо пользователю

Чтение/Запись

Роль доступа по умолчанию

UnNamed

Boolean

Да

Видимо пользователю

Чтение/Запись

Неименованный

NameExpression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение имени объекта

DescriptionExpression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение наименования объекта

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

ModelX

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Положение в модели (абсцисса)

ModelY

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Положение в модели (ордината)

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Indexed

Boolean

Да

Видимо пользователю

Чтение/Запись

Индексируется

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

Localizable

Boolean

Да

Видимо пользователю

Чтение/Запись

Локализуемый

DBMSName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта СУБД

CreatorsCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество ролей-создателей

MasterClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс-мастер

HasProfiles

Boolean

Да

Видимо пользователю

Только для чтения

Контролируется профилями

ApproxObjectCount

Integer

Нет

Видимо пользователю

Только для чтения

Оценка количества объектов

4.42.2. Конструктор Create (Конструктор класса)

Конструктор класса TClass.
1constructor TClass.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  MasterClass: TClass; IsHierarhical: Boolean;
4  ReplicationStatus: TReplicationStatus; SecurityModel: TSecurityModel;
5  DefaultAccessor: TSecurityAccount; Logged: Boolean; UnNamed: Boolean;
6  NameExpression: clob; DescriptionExpression: clob; CreateConstructor: Boolean;
7  Category: string[128]; Indexed: Boolean; Localizable: Boolean): TClass;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

MasterClass

TClass

Нет

Класс-мастер

IsHierarhical

Boolean

Да

Является иерархическим

ReplicationStatus

TReplicationStatus

Да

Статус репликации

SecurityModel

TSecurityModel

Да

Модель безопасности

DefaultAccessor

TSecurityAccount

Нет

Роль доступа по умолчанию

Logged

Boolean

Да

Протоколировать

UnNamed

Boolean

Да

Неименованный

NameExpression

clob

Нет

Выражение имени объекта

DescriptionExpression

clob

Нет

Выражение наименования объекта

CreateConstructor

Boolean

Да

Создать конструктор

Category

string[128]

Нет

Категория

Indexed

Boolean

Да

Индексируется

Localizable

Boolean

Да

Локализуемый

Замечания:

Создает новый объект класса TClass.

4.42.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TClass.
procedure TClass.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

4.42.4. Метод GenerateConstructor (Сгенерировать текст конструктора)

Метод экземпляра класса TClass.
procedure TClass.GenerateConstructor;
Метод не имеет параметров.

4.42.5. Метод GetApproxObjectsCount (Получить оценку количества объектов)

Метод экземпляра класса TClass.
function TClass.GetApproxObjectsCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.42.6. Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TClass.
function TClass.GetDBMSName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

4.42.7. Метод GetHasProfiles (Контролируется профилями)

Метод экземпляра класса TClass.
function TClass.GetHasProfiles: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.42.8. Метод GetObjectCount (Количество объектов)

Метод экземпляра класса TClass.
function TClass.GetObjectCount(Exact: Boolean): string[20];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Exact

Boolean

Да

Строго

Замечания:

Возвращает значение типа string[20].

4.42.9. Метод ListChildProperties (Список дочерних свойств)

Метод класса (статический метод) класса TClass.
1class procedure TClass.ListChildProperties(ParentName: string[64];
2  TemporaryList: TObjectList; PersistentList: TObjectList);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ParentName

string[64]

Да

Имя свойства

TemporaryList

TObjectList

Нет

Временный список

PersistentList

TObjectList

Нет

Постоянный список

4.42.10. Метод ListProperties (Список свойств)

Метод экземпляра класса TClass.
function TClass.ListProperties(Scope: TScope): TObjectList;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Scope

TScope

Да

Область видимости

Замечания:

Возвращает значение типа TObjectList.

4.42.11. Метод ListRoutines (Список подпрограмм)

Метод экземпляра класса TClass.
function TClass.ListRoutines(Scope: TScope): TObjectList;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Scope

TScope

Да

Область видимости

Замечания:

Возвращает значение типа TObjectList.

4.42.12. Метод MarkLocalizableMetadata (Установить поля метаданных как локализуемые)

Метод класса (статический метод) класса TClass.
class procedure TClass.MarkLocalizableMetadata;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

4.42.13. Метод MemberByName (Член класса по имени)

Метод экземпляра класса TClass.
function TClass.MemberByName(Name: string[64]; Class: TClass): TClassMember;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Class

TClass

Да

Класс

Замечания:

Возвращает значение типа TClassMember.

4.42.14. Метод SetLocalizable (Установить значение свойства "Локализуемый")

Метод экземпляра класса TClass.
procedure TClass.SetLocalizable(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

4.42.15. Метод Ole-объекта CheckAllExcelTemplates (Проверить шаблоны отчетов Excel)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

4.42.16. Метод Ole-объекта CheckAllOleObjectMethods (Проверить все методы Ole-объекта)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

4.42.17. Метод Ole-объекта CheckAllTemplates (Проверить все шаблоны)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

4.42.18. Метод Ole-объекта CheckAllWordTemplates (Проверить шаблоны отчетов Word)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

4.42.19. Метод Ole-объекта CheckAllXSLTTemplates (Проверить шаблоны отчетов XSLT)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

4.42.20. Метод Ole-объекта LoadImagesFromFolder (Загрузить изображения из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Prefix

string[128]

Нет

Префикс имени файла

Замечания:

Возвращает значение типа Integer.

4.42.21. Метод Ole-объекта LoadMethodsFromFolder (Загрузить методы из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

4.42.22. Метод Ole-объекта LoadResourceFile (Загрузить файл ресурсов)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

XliffFileName

string[255]

Да

Файл ресурсов

Замечания:

Возвращает значение типа Integer.

4.42.23. Метод Ole-объекта LoadTemplatesFromFolder (Загрузить шаблоны из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

4.42.24. Метод Ole-объекта SaveImagesToFolder (Сохранить изображения в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Prefix

string[128]

Нет

Префикс имени файла

Замечания:

Возвращает значение типа Integer.

4.42.25. Метод Ole-объекта SaveMethodsToFolder (Сохранить методы в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

4.42.26. Метод Ole-объекта SaveTemplatesToFolder (Сохранить шаблоны в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

ExportCodeModules

Boolean

Да

Экспортировать программные модули

Замечания:

Возвращает значение типа Integer.

4.42.27. Шаблон XSLT-отчета ClassesDiagram (Диаграмма классов)

Шаблон XSLT-отчета класса (статический шаблон) класса TClass.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ShowFields

Boolean

Да

Показывать поля

ShowMethods

Boolean

Да

Показывать методы

ShowProperties

Boolean

Да

Показывать свойства

ShowParameters

Boolean

Да

Показывать параметры

ShowMetadata

Boolean

Да

Показывать метаданные

GroupByMaster

Boolean

Да

Группировать по принадлежности

4.43. Класс TClassBan (Запрет на класс)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.43.1. Свойства

Свойства класса TClassBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

4.43.2. Конструктор Create (Конструктор запрета на класс)

Конструктор класса TClassBan.
1constructor TClassBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

Замечания:

Создает новый объект класса TClassBan.

4.44. Класс TClassDomain (Ссылки на объекты)

4.44.1. Свойства

Свойства класса TClassDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

ClassOfDomain

TClass

Нет

Видимо пользователю

Чтение/Запись

Класс домена

ClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Чтение/Запись

Статус репликации класса

ShowObjectInfoType

TShowObjectInfoType

Да

Видимо пользователю

Чтение/Запись

Тип представления объектов

DeleteRule

TDeleteRule

Да

Видимо пользователю

Чтение/Запись

Правило удаления

FilterCondition

clob

Нет

Видимо пользователю

Чтение/Запись

Условие отбора

View

TCustomView

Нет

Видимо пользователю

Чтение/Запись

Представление

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

4.44.2. Конструктор Create (Конструктор домена-ссылки)

Конструктор класса TClassDomain.
1constructor TClassDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; ClassOfDomain: TClass; View: TCustomView;
4  FilterCondition: clob; ShowObjectInfoType: TShowObjectInfoType;
5  DeleteRule: TDeleteRule; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

ClassOfDomain

TClass

Да

Класс домена

View

TCustomView

Нет

Представление для выбора

FilterCondition

clob

Нет

Условие отбора

ShowObjectInfoType

TShowObjectInfoType

Да

Тип представления объектов

DeleteRule

TDeleteRule

Да

Правило удаления

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TClassDomain.

4.44.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TClassDomain.
function TClassDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.45. Класс TClassMember (Члены класса)

4.45.1. Свойства

Свойства класса TClassMember:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределен

4.45.2. Конструктор Create (Конструктор члена класса)

Конструктор класса TClassMember.
1constructor TClassMember.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TClassMember.

4.45.3. Метод GetOverride (Переопределен)

Метод экземпляра класса TClassMember.
function TClassMember.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.45.4. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TClassMember.
function TClassMember.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

4.46. Класс TCommandButton (Командные кнопки)

4.46.1. Свойства

Свойства класса TCommandButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TRoutine

Да

Видимо пользователю

Только для чтения

Мастер

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

MasterMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер подпрограммы

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomButton

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределена

Parameter

TParameter

Нет

Видимо пользователю

Чтение/Запись

Связанный параметр

4.46.2. Конструктор Create (Конструктор командной кнопки)

Конструктор класса TCommandButton.
1constructor TCommandButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean; Parameter: TParameter): TObject;
Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Group

string[128]

Нет

Унаследовано от TCustomButton.Create

Tab

string[128]

Нет

Script

clob

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

Parameter

TParameter

Нет

Связанный параметр

Замечания:

Создает новый объект класса TCommandButton.

4.46.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TCommandButton.
class function TCommandButton.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

4.46.4. Метод GetOverride (Переопределена)

Метод экземпляра класса TCommandButton.
function TCommandButton.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.47. Класс TContextKey (Ключи контекстной помощи)

Объекты класса не именованы.

4.47.1. Свойства

Свойства класса TContextKey:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Storage

string[64]

Да

Видимо пользователю

Чтение/Запись

Хранилище

LinkedObject

TObject

Нет

Видимо пользователю

Чтение/Запись

Связанный объект

LinkedObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс связанного объекта

LinkedObjectMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер связанного объекта

4.47.2. Конструктор Create (Конструктор ключа)

Конструктор класса TContextKey.
1constructor TContextKey.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Storage: string[64]; LinkedObject: TObject): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Ключевое словосочетание

Class

TClass

Нет

Унаследовано от TObject.Create

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Storage

string[64]

Да

Хранилище

LinkedObject

TObject

Нет

Связанный объект

Замечания:

Создает новый объект класса TContextKey.

4.47.3. Метод GenerateAllKeys (Сгенерировать ключи)

Метод класса (статический метод) класса TContextKey.
class procedure TContextKey.GenerateAllKeys(Storage: string[64]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

4.48. Класс TCustomButton (Кнопки)

4.48.1. Свойства

Свойства класса TCustomButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

4.48.2. Конструктор Create (Конструктор кнопки)

Конструктор класса TCustomButton.
1constructor TCustomButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Script

clob

Нет

Скрипт

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

Замечания:

Создает новый объект класса TCustomButton.

4.49. Класс TCustomView (Абстрактное представление)

4.49.1. Свойства

Свойства класса TCustomView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Класс

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс-мастер показываемого

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

Статус репликации класса

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Иерархическое

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

Количество данных незначительно

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство выделенного шрифта

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

Предсобранное

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Вызывать перед открытием

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство цвета

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Параметры оптимизации

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

Имеются условия отбора

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

Имеет колонки со специфическими именами

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

4.49.2. Конструктор Create (Конструктор абстрактного представления)

Конструктор класса TCustomView.
1constructor TCustomView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Класс

ColorProperty

TProperty

Нет

Свойство цвета

BoldProperty

TProperty

Нет

Свойство выделенного шрифта

Skimpy

Boolean

Да

Количество данных незначительно

PreCompiled

Boolean

Да

Предсобранное

PreOpenRoutine

TRoutine

Нет

Вызывать перед открытием

Замечания:

Создает новый объект класса TCustomView.

4.49.3. Метод BuildDefaultActions (Создать действия по умолчанию)

Метод экземпляра класса TCustomView.
1procedure TCustomView.BuildDefaultActions(AddConstructor: Boolean;
2  AddDestructor: Boolean; AddMethods: Boolean; AddReports: Boolean;
3  AddCopyPasteActions: Boolean; AddStandartActions: Boolean;
4  PositionStep: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

AddConstructor

Boolean

Да

Добавить конструктор

AddDestructor

Boolean

Да

Добавить деструктор

AddMethods

Boolean

Да

Добавить методы

AddReports

Boolean

Да

Добавить шаблоны отчетов

AddCopyPasteActions

Boolean

Да

Добавить работу с буфером обмена

AddStandartActions

Boolean

Да

Добавить стандартные действия

PositionStep

Integer

Да

Шаг

4.49.4. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TCustomView.
procedure TCustomView.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

4.50. Класс TDataBase (Базы данных)

4.50.1. Свойства

Свойства класса TDataBase:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

GUID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущей

Protected

Boolean

Да

Видимо пользователю

Чтение/Запись

Защищена от изменений

4.50.2. Конструктор Create (Конструктор базы данных)

Конструктор класса TDataBase.
1constructor TDataBase.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  GUID: string[38]; Protected: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

GUID

string[38]

Да

GUID

Protected

Boolean

Да

Защищена

Замечания:

Создает новый объект класса TDataBase.

4.51. Класс TDateDomain (Даты)

4.51.1. Конструктор Create (Конструктор домена даты)

Конструктор класса TDateDomain.
1constructor TDateDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Замечания:

Создает новый объект класса TDateDomain.

4.51.2. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateDomain.
function TDateDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.52. Класс TDateTimeDomain (Даты со временем)

4.52.1. Свойства

Свойства класса TDateTimeDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

HideSeconds

Boolean

Да

Видимо пользователю

Чтение/Запись

Не показывать секунды

4.52.2. Конструктор Create (Конструктор домена даты со временем)

Конструктор класса TDateTimeDomain.
1constructor TDateTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

HideSeconds

Boolean

Да

Не показывать секунды

Замечания:

Создает новый объект класса TDateTimeDomain.

4.52.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateTimeDomain.
function TDateTimeDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.53. Класс TDependency (Зависимости)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.53.1. Свойства

Свойства класса TDependency:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Dependent

TObject

Нет

Видимо пользователю

Чтение/Запись

Зависимый объект

DependentClass

TClass

Да

Видимо пользователю

Только для чтения

Класс зависимого объекта

DependentMaster

TObject

Да

Видимо пользователю

Только для чтения

Мастер зависимого объекта

DependentExternal

string[256]

Нет

Видимо пользователю

Чтение/Запись

Внешний зависимый объект

DependedOn

TObject

Да

Видимо пользователю

Чтение/Запись

Зависит от

DependedOnClass

TClass

Да

Видимо пользователю

Только для чтения

Класс объекта, от которого зависит

DependedOnMaster

TObject

Да

Видимо пользователю

Только для чтения

Мастер объекта, от которого зависит

4.53.2. Конструктор Create (Конструктор зависимости)

Конструктор класса TDependency.
1constructor TDependency.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Dependent: TObject; DependentExternal: string[256];
4  DependedOn: TObject): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Dependent

TObject

Нет

Зависимый объект

DependentExternal

string[256]

Нет

Внешний зависимый объект

DependedOn

TObject

Да

Зависит от

Замечания:

Создает новый объект класса TDependency.

4.53.3. Метод Install (Установить)

Метод класса (статический метод) класса TDependency.
1class procedure TDependency.Install(ADependent: TObject;
2  ADependentExternal: string[256]; ADependedOn: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ADependent

TObject

Нет

Зависимый объект

ADependentExternal

string[256]

Нет

Внешний зависимый объект

ADependedOn

TObject

Да

Зависит от

4.54. Класс TDomain (Домены)

4.54.1. Свойства

Свойства класса TDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Обязательно для заполнения

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество внешних зависимостей

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Сводка

4.54.2. Конструктор Create (Конструктор домена)

Конструктор класса TDomain.
1constructor TDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TDomain;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Обязательно для заполнения

Замечания:

Создает новый объект класса TDomain.

4.54.3. Метод GetDefinition (Определение домена)

Метод экземпляра класса TDomain.
function TDomain.GetDefinition: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

4.54.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDomain.
function TDomain.GetSummary: string[2000];
Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.55. Класс TEnumerationDomain (Перечисления)

4.55.1. Свойства

Свойства класса TEnumerationDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

ShowNames

Boolean

Да

Видимо пользователю

Чтение/Запись

Показывать имена

BasedOnDomain

TEnumerationDomain

Нет

Видимо пользователю

Чтение/Запись

Расширяет домен

ItemCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество элементов

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

4.55.2. Конструктор Create (Конструктор перечисления)

Конструктор класса TEnumerationDomain.
1constructor TEnumerationDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; ShowNames: Boolean;
4  BasedOnDomain: TEnumerationDomain; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

ShowNames

Boolean

Да

Показывать имена элементов

BasedOnDomain

TEnumerationDomain

Нет

Расширяет домен

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TEnumerationDomain.

4.55.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TEnumerationDomain.
function TEnumerationDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.55.4. Метод ListItems (Список элементов)

Метод экземпляра класса TEnumerationDomain.
function TEnumerationDomain.ListItems: TObjectList;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.

4.56. Класс TEnumerationItem (Элементы перечислений)

4.56.1. Свойства

Свойства класса TEnumerationItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

4.56.2. Конструктор Create (Конструктор элемента перечисления)

Конструктор класса TEnumerationItem.
1constructor TEnumerationItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TEnumerationItem.

4.56.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TEnumerationItem.
class function TEnumerationItem.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

4.57. Класс TExcelAsyncTask (Задачи отложенного выполнения отчетов Excel)

Объекты класса не именованы.

4.57.1. Свойства

Свойства класса TExcelAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TAsyncTask

Created

datetime

Да

Видимо пользователю

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TAsyncTask

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Duration

time

Нет

Видимо пользователю

Только для чтения

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Format

TExcelOutputFormat

Да

Видимо пользователю

Чтение/Запись

Формат

ColorMode

TOutputColorMode

Да

Видимо пользователю

Чтение/Запись

Режим цветопередачи

EmbedFonts

Boolean

Да

Видимо пользователю

Чтение/Запись

Внедрять шрифты

4.57.2. Конструктор Create (Конструктор задачи отложенного выполнения отчетов Excel)

Конструктор класса TExcelAsyncTask.
1constructor TExcelAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TExcelOutputFormat;
5  ColorMode: TOutputColorMode; EmbedFonts: Boolean): TObject;
Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Унаследовано от TAsyncTask.Create

Object

TObject

Нет

FormView

TFormView

Нет

Handler

TAsyncHandler

Да

Language

TLanguage

Да

Format

TExcelOutputFormat

Да

Формат

ColorMode

TOutputColorMode

Да

Режим цветопередачи

EmbedFonts

Boolean

Да

Внедрять шрифты

Замечания:

Создает новый объект класса TExcelAsyncTask.

4.58. Класс TExcelTemplate (Шаблоны отчетов Excel)

4.58.1. Свойства

Свойства класса TExcelTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

PlaceDataOnSheet

TExcelSheetKind

Да

Видимо пользователю

Чтение/Запись

Лист для переноса данных

MacroName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя макроса

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

4.58.2. Конструктор Create (Конструктор шаблона Excel)

Конструктор класса TExcelTemplate.
1constructor TExcelTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  PlaceDataOnSheet: TExcelSheetKind; MacroName: string[128];
7  IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

blob

Нет

Данные шаблона

PlaceDataOnSheet

TExcelSheetKind

Да

Лист для переноса данных

MacroName

string[128]

Нет

Имя макроса

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TExcelTemplate.

4.58.3. Метод Ole-объекта CheckExcelTemplate (Проверить шаблон отчетов Excel)

Метод Ole-объекта класса TExcelTemplate.

Метод Ole-объекта не имеет параметров.

4.59. Класс TExternalDataDomain (Внешние данные)

4.59.1. Свойства

Свойства класса TExternalDataDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

NamesSequence

TSequence

Нет

Видимо пользователю

Чтение/Запись

Последовательность для формирования имен

ContentDomain

TBlobDomain

Да

Видимо пользователю

Чтение/Запись

Домен содержимого

ContentDomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена содержимого

ContentDomainBlobSubtype

TBlobSubtype

Да

Видимо пользователю

Только для чтения

Подтип домена содержимого

ContentDomainExtension

string[10]

Нет

Видимо пользователю

Только для чтения

Расширение домена содержимого

ResourceCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество ресурсов

ContentDependentNames

Boolean

Да

Видимо пользователю

Чтение/Запись

Имя зависит от содержимого

Compress

Boolean

Да

Видимо пользователю

Чтение/Запись

Сжимать содержимое

4.59.2. Конструктор Create (Конструктор домена внешних данных)

Конструктор класса TExternalDataDomain.
1constructor TExternalDataDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; NamesSequence: TSequence;
4  ContentDomain: TBlobDomain; ContentDependentNames: Boolean;
5  Compress: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

NamesSequence

TSequence

Нет

Последовательность для формирования имен

ContentDomain

TBlobDomain

Да

Домен содержимого

ContentDependentNames

Boolean

Да

Имя зависит от содержимого

Compress

Boolean

Да

Сжимать содержимое

Замечания:

Создает новый объект класса TExternalDataDomain.

4.59.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TExternalDataDomain.
function TExternalDataDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.60. Класс TExternalDataResource (Ресурсы внешних данных)

4.60.1. Свойства

Свойства класса TExternalDataResource:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

GUID

string[38]

Да

Видимо пользователю

Чтение/Запись

GUID

Protocol

TExternalDataProtocol

Да

Видимо пользователю

Чтение/Запись

Протокол доступа

Host

string[64]

Да

Видимо пользователю

Чтение/Запись

Хост

Port

Integer

Нет

Видимо пользователю

Чтение/Запись

Порт

Path

string[255]

Да

Видимо пользователю

Чтение/Запись

Папка

UserName

string[255]

Нет

Видимо пользователю

Чтение/Запись

Имя пользователя

Password

string[255]

Нет

Видимо пользователю

Чтение/Запись

Пароль

ReadOnly

Boolean

Да

Видимо пользователю

Чтение/Запись

Только для чтения

4.60.2. Конструктор Create (Конструктор ресурса внешних данных)

Конструктор класса TExternalDataResource.
1constructor TExternalDataResource.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; GUID: string[38]; Protocol: TExternalDataProtocol;
4  Host: string[64]; Port: Integer; Path: string[255]; UserName: string[255];
5  Password: string[255]; ReadOnly: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

GUID

string[38]

Да

GUID

Protocol

TExternalDataProtocol

Да

Протокол доступа

Host

string[64]

Да

Хост

Port

Integer

Нет

Порт

Path

string[255]

Да

Папка

UserName

string[255]

Нет

Имя пользователя

Password

string[255]

Нет

Пароль

ReadOnly

Boolean

Да

Только для чтения

Замечания:

Создает новый объект класса TExternalDataResource.

4.60.3. Метод FileNameClause (Кляуза имени поля)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.FileNameClause(FieldName: string[64]): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

FieldName

string[64]

Да

Имя поля

Замечания:

Возвращает значение типа string[2000].

4.60.4. Метод FindUsedName (Найти использованное имя)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.FindUsedName(Name: string[77]): clob;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[77]

Да

Имя

Замечания:

Возвращает значение типа clob.

4.60.5. Метод GetUsedFileNames (Получить список использованных имен)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.GetUsedFileNames: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

4.60.6. Метод Ole-объекта CheckExternalData (Проверить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя

Тип

Обязательно

Значение

FilesFolder

string[255]

Да

Файлы внешних данных

TrashFolder

string[255]

Да

Папка для неиспользуемых файлов

4.60.7. Метод Ole-объекта SaveExternalData (Сохранить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка для сохранения

4.61. Класс TField (Поля)

4.61.1. Свойства

Свойства класса TField:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Indexed

Boolean

Да

Видимо пользователю

Чтение/Запись

Индексируется

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

Localizable

Boolean

Да

Видимо пользователю

Чтение/Запись

Локализуемое

4.61.2. Конструктор Create (Конструктор поля)

Конструктор класса TField.
1constructor TField.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; CreateProperty: Boolean; CreateConstructorParameter: Boolean;
4  CreateViewColumns: Boolean; Logged: Boolean; Indexed: Boolean;
5  Localizable: Boolean): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

CreateProperty

Boolean

Да

Создать свойство

CreateConstructorParameter

Boolean

Да

Создать параметр конструктора

CreateViewColumns

Boolean

Да

Создать колонку во всех представлениях

Logged

Boolean

Да

Протоколировать

Indexed

Boolean

Да

Индексируется

Localizable

Boolean

Да

Локализуемое

Замечания:

Создает новый объект класса TField.

4.61.3. Метод SetLocalizable (Установить значение свойства "Локализуемое")

Метод экземпляра класса TField.
procedure TField.SetLocalizable(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

4.62. Класс TFileNameDomain (Имена файлов)

4.62.1. Свойства

Свойства класса TFileNameDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TStringDomain

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

FileMustExist

Boolean

Да

Видимо пользователю

Чтение/Запись

Файл должен существовать

DefaultExtension

string[10]

Нет

Видимо пользователю

Чтение/Запись

Расширение по умолчанию

OverwritePrompt

Boolean

Да

Видимо пользователю

Чтение/Запись

Запрос перезаписи

4.62.2. Конструктор Create (Конструктор имени файла)

Конструктор класса TFileNameDomain.
1constructor TFileNameDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean; FileMustExist: Boolean;
7  DefaultExtension: string[10]; OverwritePrompt: Boolean): TObject;
Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Унаследовано от TStringDomain.Create

AllowLeadingSpaces

Boolean

Да

AllowTrailingSpaces

Boolean

Да

AllowSpaceDuplication

Boolean

Да

CharacterSet

string[2000]

Нет

FirstCharacterSet

string[2000]

Нет

CaseMode

Boolean

Нет

Mask

string[2000]

Нет

CaseInsensitiveSearch

Boolean

Да

FileMustExist

Boolean

Да

Файл должен существовать

DefaultExtension

string[10]

Нет

Расширение по умолчанию

OverwritePrompt

Boolean

Да

Запрос перезаписи

Замечания:

Создает новый объект класса TFileNameDomain.

4.62.3. Метод Change (Изменение объекта)

Метод экземпляра класса TFileNameDomain.
procedure TFileNameDomain.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

4.62.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFileNameDomain.
function TFileNameDomain.GetSummary: string[2000];
Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.63. Класс TFilmstripView (Представление-диафильм)

4.63.1. Свойства

Свойства класса TFilmstripView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomView

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

LegendProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-подпись

ThumbnailProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-значок

ImageProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-изображение

ThumbnailSize

Integer

Да

Видимо пользователю

Чтение/Запись

Размер значка

OrderProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство, определяющее порядок

4.63.2. Конструктор Create (Конструктор представления-диафильма)

Конструктор класса TFilmstripView.
1constructor TFilmstripView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  LegendProperty: TProperty; ThumbnailProperty: TProperty;
6  ImageProperty: TProperty; ThumbnailSize: Integer;
7  OrderProperty: TProperty): TObject;
Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Унаследовано от TCustomView.Create

ColorProperty

TProperty

Нет

BoldProperty

TProperty

Нет

Skimpy

Boolean

Да

PreCompiled

Boolean

Да

PreOpenRoutine

TRoutine

Нет

LegendProperty

TProperty

Нет

Свойство-подпись

ThumbnailProperty

TProperty

Нет

Свойство-значок

ImageProperty

TProperty

Нет

Свойство-изображение

ThumbnailSize

Integer

Да

Размер значка

OrderProperty

TProperty

Нет

Свойство, определяющее порядок

Замечания:

Создает новый объект класса TFilmstripView.

4.64. Класс TFloatDomain (Вещественные числа)

4.64.1. Свойства

Свойства класса TFloatDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Нет

Видимо пользователю

Чтение/Запись

Длина

DecimalPlaces

Integer

Нет

Видимо пользователю

Чтение/Запись

Количество десятичных знаков

MinValue

float

Нет

Видимо пользователю

Чтение/Запись

Минимальное значение

MaxValue

float

Нет

Видимо пользователю

Чтение/Запись

Максимальное значение

DigitGrouping

Boolean

Да

Видимо пользователю

Чтение/Запись

Разделять группы разрядов

4.64.2. Конструктор Create (Конструктор вещественного домена)

Конструктор класса TFloatDomain.
1constructor TFloatDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; DecimalPlaces: Integer; MinValue: float;
4  MaxValue: float; DigitGrouping: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Нет

Длина

DecimalPlaces

Integer

Нет

Количество десятичных знаков

MinValue

float

Нет

Минимальное значение

MaxValue

float

Нет

Максимальное значение

DigitGrouping

Boolean

Да

Разделять группы разрядов

Замечания:

Создает новый объект класса TFloatDomain.

4.64.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFloatDomain.
function TFloatDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.65. Класс TFolderNameDomain (Имена папок файловой системы)

4.65.1. Свойства

Свойства класса TFolderNameDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TStringDomain

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

FolderMustExist

Boolean

Да

Видимо пользователю

Чтение/Запись

Папка должна существовать

4.65.2. Конструктор Create (Конструктор имени папки)

Конструктор класса TFolderNameDomain.
1constructor TFolderNameDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; Length: Integer;
4  AllowLeadingSpaces: Boolean; AllowTrailingSpaces: Boolean;
5  AllowSpaceDuplication: Boolean; CharacterSet: string[2000];
6  FirstCharacterSet: string[2000]; CaseMode: Boolean; Mask: string[2000];
7  CaseInsensitiveSearch: Boolean; FolderMustExist: Boolean): TObject;
Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Унаследовано от TStringDomain.Create

AllowLeadingSpaces

Boolean

Да

AllowTrailingSpaces

Boolean

Да

AllowSpaceDuplication

Boolean

Да

CharacterSet

string[2000]

Нет

FirstCharacterSet

string[2000]

Нет

CaseMode

Boolean

Нет

Mask

string[2000]

Нет

CaseInsensitiveSearch

Boolean

Да

FolderMustExist

Boolean

Да

Папка должна существовать

Замечания:

Создает новый объект класса TFolderNameDomain.

4.65.3. Метод Change (Изменение объекта)

Метод экземпляра класса TFolderNameDomain.
procedure TFolderNameDomain.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

4.65.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFolderNameDomain.
function TFolderNameDomain.GetSummary: string[2000];
Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.66. Класс TForm (Формы)

4.66.1. Свойства

Свойства класса TForm:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

AutoOpen

Boolean

Да

Видимо пользователю

Чтение/Запись

Открывать автоматически

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение-иконка

IsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Доступна

IsAlive

Boolean

Да

Видимо пользователю

Чтение/Запись

"Живая"

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Вызывать перед открытием

4.66.2. Конструктор Create (Конструктор формы)

Конструктор класса TForm.
1constructor TForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  AutoOpen: Boolean; Position: Integer; Scope: TScope; Image: blob;
4  IsAlive: Boolean; PreOpenRoutine: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

AutoOpen

Boolean

Да

Открывать автоматически

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

Image

blob

Нет

Изображение-иконка

IsAlive

Boolean

Да

"Живая"

PreOpenRoutine

TRoutine

Нет

Вызывать перед открытием

Замечания:

Создает новый объект класса TForm.

4.66.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TForm.
procedure TForm.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

4.66.4. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TForm.
function TForm.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.66.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TForm.
class function TForm.GetNextPos: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.67. Класс TFormAccess (Доступ к формам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.67.1. Конструктор Create (Конструктор доступа к форме)

Конструктор класса TFormAccess.
1constructor TFormAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TForm; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TForm

Да

Форма

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TFormAccess.

4.68. Класс TFormBan (Запрет на форму)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.68.1. Свойства

Свойства класса TFormBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedForm

TForm

Да

Видимо пользователю

Чтение/Запись

Запрещаемая форма

4.68.2. Конструктор Create (Конструктор запрета на форму)

Конструктор класса TFormBan.
1constructor TFormBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedForm: TForm): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedForm

TForm

Да

Запрещаемая форма

Замечания:

Создает новый объект класса TFormBan.

4.69. Класс TFormOption (Настройки формы)

Имена объектов класса генерируются.

4.69.1. Свойства

Свойства класса TFormOption:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Option

TOption

Да

Видимо пользователю

Чтение/Запись

Настройка

Position

Integer

Нет

Видимо пользователю

Чтение/Запись

Позиция

ShowEmptyValue

Boolean

Да

Видимо пользователю

Чтение/Запись

Показывать пустое значение

4.69.2. Конструктор Create (Конструктор настройки формы)

Конструктор класса TFormOption.
1constructor TFormOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Option: TOption; Position: Integer; ShowEmptyValue: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Option

TOption

Да

Настройка

Position

Integer

Нет

Позиция

ShowEmptyValue

Boolean

Да

Показывать пустое значение

Замечания:

Создает новый объект класса TFormOption.

4.69.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormOption.
class function TFormOption.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Да

Мастер

Замечания:

Возвращает значение типа Integer.

4.70. Класс TFormView (Представления формы)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

4.70.1. Свойства

Свойства класса TFormView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления минимизированы

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство выделенного шрифта

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство цвета

Layout

TFormViewLayout

Да

Видимо пользователю

Чтение/Запись

Расположение

ChildrenOnTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления на закладках

ExplicitQuery

Boolean

Да

Видимо пользователю

Чтение/Запись

Явный запрос

SpacePercentage

Integer

Нет

Видимо пользователю

Чтение/Запись

Площадь, %

4.70.2. Конструктор Create (Конструктор представления формы)

Конструктор класса TFormView.
1constructor TFormView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout;
6  ExplicitQuery: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Представление

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

ChildrenOnTabs

Boolean

Да

Дочерние представления на закладках

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

Position

Integer

Да

Позиция

SpacePercentage

Integer

Нет

Площадь, %

Layout

TFormViewLayout

Да

Расположение

ExplicitQuery

Boolean

Да

Явный запрос

Замечания:

Создает новый объект класса TFormView.

4.70.3. Метод GetName (Сгенерировать имя объекта)

Метод экземпляра класса TFormView.
function TFormView.GetName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

4.70.4. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormView.
class function TFormView.GetNextPos(Parent: TObject; Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Master

TObject

Да

Мастер

Замечания:

Возвращает значение типа Integer.

4.71. Класс TFormViewAction (Действие-форма)

Объекты класса образуют иерархию.

4.71.1. Свойства

Свойства класса TFormViewAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Да

Видимо пользователю

Чтение/Запись

Представление формы

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

OverrideMasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Подменить свойство-главное

OverrideDetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Подменить свойство-подчиненное

4.71.2. Конструктор Create (Конструктор действия-формы)

Конструктор класса TFormViewAction.
1constructor TFormViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  FormView: TFormView; OverrideMasterProperty: TProperty;
5  OverrideDetailProperty: TClassMember): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

FormView

TFormView

Да

Представление формы

OverrideMasterProperty

TProperty

Нет

Подменить свойство-главное свойством

OverrideDetailProperty

TClassMember

Нет

Подменить свойство-подчиненное свойством

Замечания:

Создает новый объект класса TFormViewAction.

4.72. Класс TImportedReplica (Импортированные реплики)

Объекты класса не именованы.

4.72.1. Свойства

Свойства класса TImportedReplica:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

CRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма

MetadataCRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма метаданных

4.72.2. Конструктор Create (Конструктор импортированной реплики)

Конструктор класса TImportedReplica.
1constructor TImportedReplica.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CRC: string[8]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

CRC

string[8]

Нет

Контрольная сумма

Замечания:

Создает новый объект класса TImportedReplica.

4.73. Класс TInlineExpression (Встраиваемое выражение)

4.73.1. Свойства

Свойства класса TInlineExpression:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Expression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

4.73.2. Конструктор Create (Конструктор встраиваемого выражения)

Конструктор класса TInlineExpression.
1constructor TInlineExpression.Create(Name: string[30];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Expression: clob; Domain: TDomain): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Expression

clob

Нет

Выражение

Domain

TDomain

Да

Домен

Замечания:

Создает новый объект класса TInlineExpression.

4.74. Класс TInstantContact (Контакты)

Имена объектов класса генерируются.

4.74.1. Свойства

Свойства класса TInstantContact:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Владелец

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Владелец - текущий пользователь

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Status

TInstantContactStatus

Да

Видимо пользователю

Чтение/Запись

Статус

BackContact

TInstantContact

Нет

Видимо пользователю

Только для чтения

Ответный контакт

BackContactStatus

TInstantContactStatus

Да

Видимо пользователю

Только для чтения

Состояние ответного контакта

4.74.2. Конструктор Create (Конструктор контакта)

Конструктор класса TInstantContact.
1constructor TInstantContact.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Status: TInstantContactStatus): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Пользователь

Status

TInstantContactStatus

Да

Статус

Замечания:

Создает новый объект класса TInstantContact.

4.74.3. Метод AddContact (Добавить контакт)

Метод класса (статический метод) класса TInstantContact.
class function TInstantContact.AddContact(Master: TUser; User: TUser): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TUser

Да

Мастер

User

TUser

Да

Пользователь

Замечания:

Возвращает значение типа TObject.

4.74.4. Метод LastUsedContact (Получить последний использованный контакт)

Метод класса (статический метод) класса TInstantContact.
class function TInstantContact.LastUsedContact(AUser: TUser): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AUser

TUser

Да

Пользователь

Замечания:

Возвращает значение типа TObject.

4.75. Класс TInstantMessage (Сообщения)

Объекты класса не именованы.

4.75.1. Свойства

Свойства класса TInstantMessage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Владелец

User

TUser

Да

Видимо пользователю

Чтение/Запись

Пользователь

Message

string[255]

Да

Видимо пользователю

Только для чтения

Сообщение

DeliveryTime

datetime

Да

Видимо пользователю

Только для чтения

Время доставки

AttachmentType

TInstantMessageAttachmentType (None)

Да

Скрыто от пользователя

Только для чтения

Тип вложения

4.75.2. Конструктор Create (Конструктор сообщения)

Конструктор класса TInstantMessage.
1constructor TInstantMessage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Message: string[255]; DeliveryTime: datetime): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Пользователь

Message

string[255]

Да

Сообщение

DeliveryTime

datetime

Нет

Время доставки

Замечания:

Создает новый объект класса TInstantMessage.

4.75.3. Метод Archive (Отправить в архив)

Метод класса (статический метод) класса TInstantMessage.
1class procedure TInstantMessage.Archive(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

4.75.4. Метод Clear (Очистить)

Метод класса (статический метод) класса TInstantMessage.
1class procedure TInstantMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

4.76. Класс TInstantMessageAttachment (Сообщения с вложением)

Объекты класса не именованы.

4.76.1. Свойства

Свойства класса TInstantMessageAttachment:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TInstantMessage

User

TUser

Да

Видимо пользователю

Чтение/Запись

Message

string[255]

Да

Видимо пользователю

Только для чтения

DeliveryTime

datetime

Да

Видимо пользователю

Только для чтения

AttachmentType

TInstantMessageAttachmentType

Да

Видимо пользователю

Только для чтения

Тип вложения

FileBody

blob

Нет

Видимо пользователю

Только для чтения

Содержимое файла

FormView

TFormView

Нет

Видимо пользователю

Только для чтения

Представление формы

Form

TForm

Да

Видимо пользователю

Только для чтения

Форма

FormIsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Форма доступна

Object

TObject

Нет

Видимо пользователю

Только для чтения

Объект

HyperLink

string[256]

Нет

Видимо пользователю

Только для чтения

Гиперссылка

4.76.2. Конструктор Create (Конструктор сообщения с вложением)

Конструктор класса TInstantMessageAttachment.
1constructor TInstantMessageAttachment.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; User: TUser; Message: string[255];
4  DeliveryTime: datetime; FileName: string[255]; FileBaseName: string[128];
5  FileBody: blob; FormView: TFormView; Object: TObject; HyperLink: string[256];
6  AttachmentType: TInstantMessageAttachmentType): TObject;
Переопределяет метод в TInstantMessage.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Унаследовано от TInstantMessage.Create

Message

string[255]

Да

DeliveryTime

datetime

Нет

FileName

string[255]

Нет

Имя файла

FileBaseName

string[128]

Да

Базовое имя файла

FileBody

blob

Нет

Содержимое файла

FormView

TFormView

Нет

Представление

Object

TObject

Нет

Объект

HyperLink

string[256]

Нет

Гиперссылка

AttachmentType

TInstantMessageAttachmentType

Да

Тип приложения

Замечания:

Создает новый объект класса TInstantMessageAttachment.

4.77. Класс TIntegerDomain (Целые числа)

4.77.1. Свойства

Свойства класса TIntegerDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

MinValue

Integer

Нет

Видимо пользователю

Чтение/Запись

Минимальное значение

MaxValue

Integer

Нет

Видимо пользователю

Чтение/Запись

Максимальное значение

4.77.2. Конструктор Create (Конструктор целочисленного домена)

Конструктор класса TIntegerDomain.
1constructor TIntegerDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; MinValue: Integer; MaxValue: Integer): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

MinValue

Integer

Нет

Минимальное значение

MaxValue

Integer

Нет

Максимальное значение

Замечания:

Создает новый объект класса TIntegerDomain.

4.77.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TIntegerDomain.
function TIntegerDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.78. Класс TLanguage (Языки)

4.78.1. Свойства

Свойства класса TLanguage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

DatabaseLanguage

Boolean

Да

Видимо пользователю

Только для чтения

По умолчанию

IsCurrent

Boolean

Да

Видимо пользователю

Чтение/Запись

Является текущим

4.78.2. Конструктор Create (Конструктор языка)

Конструктор класса TLanguage.
1constructor TLanguage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TLanguage.

4.78.3. Метод GetCurrentLanguage (Получить текущий язык)

Метод класса (статический метод) класса TLanguage.
class function TLanguage.GetCurrentLanguage: TLanguage;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TLanguage.

4.78.4. Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TLanguage.
function TLanguage.GetIsCurrent: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.78.5. Метод SetIsCurrent (Установить язык как текущий)

Метод экземпляра класса TLanguage.
procedure TLanguage.SetIsCurrent(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

4.78.6. Метод Ole-объекта SaveResourceFile (Сохранить файл ресурсов)

Метод Ole-объекта класса TLanguage.

Параметры:

Имя

Тип

Обязательно

Значение

XliffFileName

string[255]

Да

Файл ресурсов

4.79. Класс TLanguageTranslation (Переводы)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.79.1. Свойства

Свойства класса TLanguageTranslation:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Language

TLanguage

Да

Видимо пользователю

Только для чтения

Язык

DatabaseLanguage

Boolean

Да

Видимо пользователю

Только для чтения

Язык используется по умолчанию

CurrentLanguage

Boolean

Да

Видимо пользователю

Только для чтения

Язык является текущим

Status

TTranslationStatus

Да

Видимо пользователю

Только для чтения

Состояние

OwnerObject

TObject

Нет

Скрыто от пользователя

Только для чтения

Владелец-объект

OwnerObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс объекта-владельца

OwnerField

TField

Нет

Скрыто от пользователя

Только для чтения

Владелец-поле

Owner

string[64]

Нет

Скрыто от пользователя

Только для чтения

Владелец

Translation

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Перевод

Original

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Оригинал

Identifier

string[2000]

Нет

Видимо пользователю

Только для чтения

Идентификатор

GlobalIdentifier

string[2000]

Нет

Видимо пользователю

Только для чтения

Глобальный идентификатор

4.79.2. Конструктор Create (Конструктор перевода)

Конструктор класса TLanguageTranslation.
1constructor TLanguageTranslation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Language: TLanguage; OwnerObject: TObject;
4  OwnerField: TField; Owner: string[64]; Translation: string[2000]): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Language

TLanguage

Да

Язык

OwnerObject

TObject

Нет

Владелец-объект

OwnerField

TField

Нет

Владелец-поле

Owner

string[64]

Нет

Владелец

Translation

string[2000]

Нет

Перевод

Замечания:

Создает новый объект класса TLanguageTranslation.

4.79.3. Метод Add (Создать набор переводов)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.Add(Owner: string[64];
2  Original: string[2000]): TLanguageTranslation;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Owner

string[64]

Да

Идентификатор

Original

string[2000]

Нет

Оригинал

Замечания:

Возвращает значение типа TLanguageTranslation.

4.79.4. Метод Append (Добавить перевод)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.Append(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]): TLanguageTranslation;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

AValue

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TLanguageTranslation.

4.79.5. Метод GetGlobalIdent (Получить глобальный идентификатор)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetGlobalIdent: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.79.6. Метод GetIdent (Получить идентификатор)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetIdent: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.79.7. Метод GetLanguageTranslation (Получить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.GetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

Замечания:

Возвращает значение типа string[2000].

4.79.8. Метод GetOriginal (Получить оригинал)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetOriginal: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.79.9. Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TLanguageTranslation.
class function TLanguageTranslation.GetResource(AOwner: string[64]): string[2000];
Переопределяет метод в TObject.GetResource.

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

Замечания:

Возвращает значение типа string[2000].

4.79.10. Метод Load (Загрузить значение)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.Load(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

4.79.11. Метод MarkAsTranslatable (Отметить как переводимый)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.MarkAsTranslatable;
Метод не имеет параметров.

4.79.12. Метод MarkAsUntranslatable (Отметить как непереводимый)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.MarkAsUntranslatable;
Метод не имеет параметров.

4.79.13. Метод SetLanguageTranslation (Установить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.SetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

AValue

string[2000]

Нет

Значение

4.79.14. Метод SetOriginal (Установить оригинал)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.SetOriginal(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

4.79.15. Метод SetOwnerSecurity (Установить атрибуты безопасности по владельцу-объекту)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.SetOwnerSecurity(AOwnerObject: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwnerObject

TObject

Нет

Владелец-объект

4.79.16. Метод SetTranslation (Установить перевод)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.SetTranslation(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

4.79.17. Метод Validate (Актуализировать)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.Validate(ValidateResources: Boolean;
2  ValidateData: Boolean; ValidateClass: TClass; ValidateField: TField);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ValidateResources

Boolean

Да

Актуализировать ресурсы

ValidateData

Boolean

Да

Актуализировать данные

ValidateClass

TClass

Нет

Актуализировать объекты класса

ValidateField

TField

Нет

Актуализировать значения поля

4.79.18. Метод ValidateAllObjects (Актуализировать все объекты)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.ValidateAllObjects(ValidateClass: TClass;
2  ValidateField: TField);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ValidateClass

TClass

Нет

Актуализировать объекты класса

ValidateField

TField

Нет

Актуализировать значения поля

4.79.19. Метод ValidateObject (Актуализировать объект)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.ValidateObject(AOwnerObject: TObject;
2  AOwnerField: TField);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

4.79.20. Метод ValidateOwned (Актуализировать имеющих владельца)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.ValidateOwned;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

4.79.21. Метод ValidateOwner (Актуализировать по владельцу)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.ValidateOwner(AOwner: string[64]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

4.80. Класс TMethod (Методы)

4.80.1. Свойства

Свойства класса TMethod:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Body

clob

Нет

Видимо пользователю

Чтение/Запись

Тело

CallTemplate

string[2000]

Нет

Видимо пользователю

Только для чтения

Шаблон вызова

Virtual

Boolean

Да

Видимо пользователю

Чтение/Запись

Виртуальный

DBMSName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта СУБД

4.80.2. Конструктор Create (Конструктор метода)

Конструктор класса TMethod.
1constructor TMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; Body: clob;
6  Virtual: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

Body

clob

Нет

Тело

Virtual

Boolean

Да

Метод является виртуальным

Замечания:

Создает новый объект класса TMethod.

4.80.3. Метод Call (Вызвать)

Метод экземпляра класса TMethod.
procedure TMethod.Call(Parameters: TObjectList);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Parameters

TObjectList

Нет

Параметры

4.80.4. Метод CallTemplate (Шаблон вызова)

Метод экземпляра класса TMethod.
function TMethod.CallTemplate: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.80.5. Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TMethod.
function TMethod.GetDBMSName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

4.80.6. Метод VirtualChainRoot (Корень виртуальной цепи)

Метод экземпляра класса TMethod.
function TMethod.VirtualChainRoot: TMethod;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TMethod.

4.81. Класс TObject (Объекты)

4.81.1. Свойства

Свойства класса TObject:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Имя

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Наименование

Class

TClass

Да

Скрыто от пользователя

Только для чтения

Класс

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Статус репликации

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Родитель

Master

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

База данных-источник

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

GUID базы данных-источника

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

База данных-источник является текущей

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Идентификатор при создании

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Создано пользователем

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Создано

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Изменено пользователем

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Изменено

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Роль для чтения

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Роль для записи

4.81.2. Конструктор Create (Конструктор объекта)

Конструктор класса TObject.
1constructor TObject.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Class

TClass

Нет

Класс

Parent

TObject

Нет

Родитель

Master

TObject

Да

Мастер

Accessor

TSecurityAccount

Нет

Роль доступа

Замечания:

Создает новый объект класса TObject.

4.81.3. Деструктор Destroy (Деструктор объекта)

Деструктор класса TObject.
destructor TObject.Destroy;
Метод не имеет параметров.

Замечания:

Уничтожает объект класса TObject или его наследника.

4.81.4. Метод ApplyStringBuilder (Применить шаблон)

Метод экземпляра класса TObject.
function TObject.ApplyStringBuilder(Template: string[2000]): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа string[2000].

4.81.5. Метод ApplyStringBuilderClob (Применить шаблон-большой текстовый объект)

Метод экземпляра класса TObject.
function TObject.ApplyStringBuilderClob(Template: string[2000]): clob;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа clob.

4.81.6. Метод ASCII (ASCII-код)

Метод класса (статический метод) класса TObject.
class function TObject.ASCII(Value: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

4.81.7. Метод Assigned (Проверка пустоты значения)

Метод класса (статический метод) класса TObject.
class function TObject.Assigned(Value: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.81.8. Метод BlobToClob (Большой двоичный объект в большой текстовый объект)

Метод класса (статический метод) класса TObject.
class function TObject.BlobToClob(Value: blob): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

blob

Нет

Значение

Замечания:

Возвращает значение типа clob.

4.81.9. Метод BoolToStr (Логическое значение в строку)

Метод класса (статический метод) класса TObject.
1class function TObject.BoolToStr(Value: Boolean;
2  Domain: TBooleanDomain): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

Domain

TBooleanDomain

Нет

Домен

Замечания:

Возвращает значение типа string[2000].

4.81.10. Метод Change (Изменение объекта)

Метод экземпляра класса TObject.
procedure TObject.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

4.81.11. Метод Char (Символ)

Метод класса (статический метод) класса TObject.
class function TObject.Char(Value: Integer): string[2];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2].

4.81.12. Метод ClobReplace (Заменить содержимое большого текстового объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.ClobReplace(Value: clob; OldPattern: string[2000];
2  NewPattern: string[2000]; ReplaceAll: Boolean): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

OldPattern

string[2000]

Нет

Старый шаблон

NewPattern

string[2000]

Нет

Новый шаблон

ReplaceAll

Boolean

Да

Заменять все

Замечания:

Возвращает значение типа clob.

4.81.13. Метод ClobToBlob (Большой текстовый объект в большой двоичный объект)

Метод класса (статический метод) класса TObject.
class function TObject.ClobToBlob(Value: clob): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа blob.

4.81.14. Метод Concatenate (Управляемая конкатенация строк)

Метод класса (статический метод) класса TObject.
1class function TObject.Concatenate(Value: string[2000]; AddOn: string[2000];
2  MaxLength: Integer; Delimiter: string[2000]; Ellipsis: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

AddOn

string[2000]

Нет

Присоединяемая строка

MaxLength

Integer

Да

Максимальная длина

Delimiter

string[2000]

Нет

Разделитель

Ellipsis

Boolean

Да

Эллипсис

Замечания:

Возвращает значение типа string[2000].

4.81.15. Метод Copy (Копировать)

Метод класса (статический метод) класса TObject.
1class function TObject.Copy(String: string[2000]; StartPos: Integer;
2  Length: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

String

string[2000]

Нет

Строка

StartPos

Integer

Нет

Позиция

Length

Integer

Нет

Длина

Замечания:

Возвращает значение типа string[2000].

4.81.16. Метод CopyClob (Копировать из большого текстового объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.CopyClob(Value: clob; StartPos: Integer;
2  Length: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

StartPos

Integer

Нет

Позиция

Length

Integer

Нет

Длина

Замечания:

Возвращает значение типа string[2000].

4.81.17. Метод CreateGUID (Создать GUID)

Метод класса (статический метод) класса TObject.
class function TObject.CreateGUID: string[38];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[38].

4.81.18. Метод DateOf (Дату из даты со временем)

Метод класса (статический метод) класса TObject.
class function TObject.DateOf(Value: datetime): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа date.

4.81.19. Метод DatePart (Часть даты)

Метод класса (статический метод) класса TObject.
class function TObject.DatePart(Value: date; Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

4.81.20. Метод DateTimePart (Часть даты со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.DateTimePart(Value: datetime;
2  Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

4.81.21. Метод DateTimeToStr (Дату и время в строку)

Метод класса (статический метод) класса TObject.
class function TObject.DateTimeToStr(Value: datetime): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Да

Значение

Замечания:

Возвращает значение типа string[2000].

4.81.22. Метод DateToStr (Дату в строку)

Метод класса (статический метод) класса TObject.
class function TObject.DateToStr(Value: date): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.81.23. Метод Dequeue (Удалить из очереди)

Метод экземпляра класса TObject.
procedure TObject.Dequeue(Permanently: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Permanently

Boolean

Да

Удалить навсегда

4.81.24. Метод DescribeObject (Описание объекта для сообщений пользователю)

Метод экземпляра класса TObject.
function TObject.DescribeObject: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.81.25. Метод DumpString (Строка в виде списка кодов символов)

Метод класса (статический метод) класса TObject.
1class function TObject.DumpString(Value: string[2000]; Delimiter: string[2000];
2  Hexadecimal: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Hexadecimal

Boolean

Да

Использовать шестнадцатеричные значения

Замечания:

Возвращает значение типа string[2000].

4.81.26. Метод Ellipsis (Эллипсис)

Метод класса (статический метод) класса TObject.
1class function TObject.Ellipsis(Value: string[2000]; MaxLength: Integer;
2  WholeWords: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

WholeWords

Boolean

Да

По целым словам

Замечания:

Возвращает значение типа string[2000].

4.81.27. Метод EncodeDate (Собрать дату)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeDate(Year: Integer; Month: Integer;
2  Day: Integer): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Year

Integer

Нет

Год

Month

Integer

Нет

Месяц

Day

Integer

Нет

День

Замечания:

Возвращает значение типа date.

4.81.28. Метод EncodeDateTime (Собрать дату со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeDateTime(Year: Integer; Month: Integer;
2  Day: Integer; Hours: Integer; Minutes: Integer; Seconds: Integer): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Year

Integer

Нет

Год

Month

Integer

Нет

Месяц

Day

Integer

Нет

День

Hours

Integer

Нет

Часы

Minutes

Integer

Нет

Минуты

Seconds

Integer

Нет

Секунды

Замечания:

Возвращает значение типа datetime.

4.81.29. Метод EncodeTime (Собрать время)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeTime(Hours: Integer; Minutes: Integer;
2  Seconds: Integer): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Hours

Integer

Нет

Часы

Minutes

Integer

Нет

Минуты

Seconds

Integer

Нет

Секунды

Замечания:

Возвращает значение типа time.

4.81.30. Метод Enqueue (Поставить в очередь)

Метод экземпляра класса TObject.
function TObject.Enqueue(QueueName: string[64]): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

QueueName

string[64]

Да

Имя очереди

Замечания:

Возвращает значение типа Boolean.

4.81.31. Метод Find (Поиск объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.Find(Name: string[64]; Class: TClass; Parent: TObject;
2  Master: TObject): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Class

TClass

Нет

Класс объекта

Parent

TObject

Нет

Родительский объект

Master

TObject

Да

Мастер объекта

Замечания:

Возвращает значение типа TObject.

4.81.32. Метод FindGlobal (Глобальный поиск объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.FindGlobal(SourceDataBaseGUID: string[38];
2  OldID: string[38]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

SourceDataBaseGUID

string[38]

Да

GUID базы данных-источника

OldID

string[38]

Да

Идентификатор при создании

Замечания:

Возвращает значение типа TObject.

4.81.33. Метод FloatToStr (Вещественное в строку)

Метод класса (статический метод) класса TObject.
class function TObject.FloatToStr(Value: float): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.81.34. Метод FormatDate (Форматировать дату)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatDate(Value: date;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

4.81.35. Метод FormatDateTime (Форматировать дату со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatDateTime(Value: datetime;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

4.81.36. Метод FormatFloat (Форматировать вещественное значение)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatFloat(Value: float; DecimalPlaces: Integer;
2  DecimalSeparator: string[2]; GroupSeparator: string[2]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

DecimalPlaces

Integer

Нет

Количество десятичных знаков

DecimalSeparator

string[2]

Нет

Десятичный разделитель

GroupSeparator

string[2]

Нет

Разделитель групп разрядов

Замечания:

Возвращает значение типа string[2000].

4.81.37. Метод FormatTime (Форматировать время)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatTime(Value: time;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

4.81.38. Метод GenerateAllNames (Сгенерировать имена для всех объектов)

Метод класса (статический метод) класса TObject.
class function TObject.GenerateAllNames: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.81.39. Метод GeneratedDescription (Сгенерированное наименование)

Метод экземпляра класса TObject.
function TObject.GeneratedDescription: string[128];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].

4.81.40. Метод GeneratedName (Сгенерированное имя)

Метод экземпляра класса TObject.
function TObject.GeneratedName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

4.81.41. Метод GetBlobSize (Размер большого двоичного объекта)

Метод класса (статический метод) класса TObject.
class function TObject.GetBlobSize(Value: blob): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

blob

Нет

Значение

Замечания:

Возвращает значение типа Integer.

4.81.42. Метод GetChildCount (Получить количество дочерних объектов)

Метод экземпляра класса TObject.
function TObject.GetChildCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.81.43. Метод GetClobSize (Размер большого текстового объекта)

Метод класса (статический метод) класса TObject.
class function TObject.GetClobSize(Value: clob): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа Integer.

4.81.44. Метод GetDescendantCount (Получить количество объектов-потомков)

Метод экземпляра класса TObject.
function TObject.GetDescendantCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.81.45. Метод GetDetailCount (Получить количество подчиненных объектов)

Метод экземпляра класса TObject.
function TObject.GetDetailCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.81.46. Метод GetLevel (Уровень в иерархии)

Метод экземпляра класса TObject.
function TObject.GetLevel: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.81.47. Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TObject.
class function TObject.GetResource(AOwner: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

Замечания:

Возвращает значение типа string[2000].

4.81.48. Метод GetRoot (Получить корень иерархии)

Метод экземпляра класса TObject.
function TObject.GetRoot: TObject;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.

4.81.49. Метод GetTop (Получить объект верхнего уровня)

Метод экземпляра класса TObject.
function TObject.GetTop: TObject;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.

4.81.50. Метод HasAsChild (Объект является ребенком данного)

Метод экземпляра класса TObject.
function TObject.HasAsChild(Child: TObject): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Child

TObject

Нет

Дочерний объект

Замечания:

Возвращает значение типа Boolean.

4.81.51. Метод HasAsParent (Объект является родителем данного)

Метод экземпляра класса TObject.
function TObject.HasAsParent(Parent: TObject): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Boolean.

4.81.52. Метод HasChildren (Имеет детей)

Метод экземпляра класса TObject.
function TObject.HasChildren: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.81.53. Метод HasDetails (Имеет подчиненные объекты)

Метод экземпляра класса TObject.
function TObject.HasDetails: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.81.54. Метод Hash (Хеш-функция конца строки)

Метод класса (статический метод) класса TObject.
1class function TObject.Hash(Value: string[2000];
2  MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

4.81.55. Метод HashReverse (Хеш-функция начала строки)

Метод класса (статический метод) класса TObject.
1class function TObject.HashReverse(Value: string[2000];
2  MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

4.81.56. Метод HexToInt (Шестнадцатеричное представление в целое число)

Метод класса (статический метод) класса TObject.
class function TObject.HexToInt(Hexadecimal: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Hexadecimal

string[64]

Да

Шестнадцатеричное значение

Замечания:

Возвращает значение типа Integer.

4.81.57. Метод IfThenDate (Выбор из двух дат)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenDate(Value: Boolean; ATrue: date;
2  AFalse: date): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

date

Нет

Значение при выполнении условия

AFalse

date

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа date.

4.81.58. Метод IfThenDateTime (Выбор из двух дат со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenDateTime(Value: Boolean; ATrue: datetime;
2  AFalse: datetime): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

datetime

Нет

Значение при выполнении условия

AFalse

datetime

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа datetime.

4.81.59. Метод IfThenExternalData (Выбор из двух значений - внешних данных)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenExternalData(Value: Boolean; ATrue: <external
2  data>; AFalse: <external data>): <external data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

<external data>

Нет

Значение при выполнении условия

AFalse

<external data>

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа <external data>.

4.81.60. Метод IfThenFloat (Выбор из двух вещественных)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenFloat(Value: Boolean; ATrue: float;
2  AFalse: float): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

float

Нет

Значение при выполнении условия

AFalse

float

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа float.

4.81.61. Метод IfThenInt (Выбор из двух целых)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenInt(Value: Boolean; ATrue: Integer;
2  AFalse: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

Integer

Нет

Значение при выполнении условия

AFalse

Integer

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа Integer.

4.81.62. Метод IfThenObject (Выбор из двух объектов)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenObject(Value: Boolean; ATrue: TObject;
2  AFalse: TObject): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

TObject

Нет

Значение при выполнении условия

AFalse

TObject

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа TObject.

4.81.63. Метод IfThenStr (Выбор из двух строк)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenStr(Value: Boolean; ATrue: string[2000];
2  AFalse: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

string[2000]

Нет

Значение при выполнении условия

AFalse

string[2000]

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа string[2000].

4.81.64. Метод IfThenTime (Выбор из двух времен)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenTime(Value: Boolean; ATrue: time;
2  AFalse: time): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

time

Нет

Значение при выполнении условия

AFalse

time

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа time.

4.81.65. Метод InstanceObject (Объект по строковому представлению идентификатора (объект может не существовать))

Метод класса (статический метод) класса TObject.
class function TObject.InstanceObject(Value: string[38]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[38]

Да

Значение

Замечания:

Возвращает значение типа TObject.

4.81.66. Метод IntToHex (Целое число в шестнадцатеричное представление)

Метод класса (статический метод) класса TObject.
class function TObject.IntToHex(IntValue: Integer): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

IntValue

Integer

Нет

Целое значение

Замечания:

Возвращает значение типа string[64].

4.81.67. Метод IntToStr (Целое в строку)

Метод класса (статический метод) класса TObject.
class function TObject.IntToStr(Value: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.81.68. Метод IsBadHierarchy (Ошибка в иерархии)

Метод экземпляра класса TObject.
function TObject.IsBadHierarchy: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.81.69. Метод IsBadPtr (Не указывает на существующий объект)

Метод экземпляра класса TObject.
function TObject.IsBadPtr: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.81.70. Метод IsCharAlpha (Символ является алфавитным)

Метод класса (статический метод) класса TObject.
class function TObject.IsCharAlpha(Value: string[2]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.81.71. Метод IsCharAlphaNumeric (Символ является алфавитно-числовым)

Метод класса (статический метод) класса TObject.
class function TObject.IsCharAlphaNumeric(Value: string[2]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.81.72. Метод IsInList (Объект входит в список)

Метод экземпляра класса TObject.
function TObject.IsInList(Value: TObjectList): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectList

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.81.73. Метод IsInSet (Объект входит в множество)

Метод экземпляра класса TObject.
function TObject.IsInSet(Value: TObjectSet): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.81.74. Метод IsInstanceOf (Является экземпляром класса)

Метод экземпляра класса TObject.
function TObject.IsInstanceOf(Class: TClass): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Class

TClass

Нет

Класс

Замечания:

Возвращает значение типа Boolean.

4.81.75. Метод IsNotInList (Объект не входит в список)

Метод экземпляра класса TObject.
function TObject.IsNotInList(Value: TObjectList): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectList

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.81.76. Метод IsNotInSet (Объект не входит в множество)

Метод экземпляра класса TObject.
function TObject.IsNotInSet(Value: TObjectSet): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.81.77. Метод LineBreak (Разделитель строк)

Метод класса (статический метод) класса TObject.
class function TObject.LineBreak: string[2];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2].

4.81.78. Метод LinkClobs (Присоединить большой объект к другому)

Метод класса (статический метод) класса TObject.
class function TObject.LinkClobs(PrefData: clob; PostData: clob): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

PrefData

clob

Нет

Данные первого объекта

PostData

clob

Нет

Данные второго объекта

Замечания:

Возвращает значение типа clob.

4.81.79. Метод LinkToClob (Присоединить строки к большому объекту)

Метод класса (статический метод) класса TObject.
1class function TObject.LinkToClob(Prefix: string[2000]; Data: clob;
2  Postfix: string[2000]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Prefix

string[2000]

Нет

Префикс

Data

clob

Нет

Данные

Postfix

string[2000]

Нет

Постфикс

Замечания:

Возвращает значение типа clob.

4.81.80. Метод Locate (Поиск объекта по локатору)

Метод класса (статический метод) класса TObject.
class function TObject.Locate(Locator: string[2000]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Locator

string[2000]

Нет

Локатор

Замечания:

Возвращает значение типа TObject.

4.81.81. Метод Locator (Локатор объекта)

Метод экземпляра класса TObject.
function TObject.Locator: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.81.82. Метод LowerCase (Преобразовать к нижнему регистру)

Метод класса (статический метод) класса TObject.
class function TObject.LowerCase(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.81.83. Метод MatchRegExp (Проверка соответствия строки регулярному выражению)

Метод класса (статический метод) класса TObject.
1class function TObject.MatchRegExp(Value: string[2000];
2  RegExp: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

RegExp

string[2000]

Нет

Регулярное выражение

Замечания:

Возвращает значение типа Boolean.

4.81.84. Метод MergeIdentifiers (Объединенный идентификатор)

Метод класса (статический метод) класса TObject.
1class function TObject.MergeIdentifiers(Identifier: string[64];
2  Modifier: string[64]; MaxLength: Integer): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Identifier

string[64]

Да

Идентификатор

Modifier

string[64]

Да

Модификатор

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[64].

4.81.85. Метод MergeTo (Отождествить с)

Метод экземпляра класса TObject.
procedure TObject.MergeTo(PrimaryObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

PrimaryObject

TObject

Да

Первичный объект

4.81.86. Метод Modulus (Остаток деления)

Метод класса (статический метод) класса TObject.
class function TObject.Modulus(Value: Integer; Base: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Делимое

Base

Integer

Нет

Делитель

Замечания:

Возвращает значение типа Integer.

4.81.87. Метод ObjectInstance (Текстовое представление идентификатора объекта (объект может не существовать))

Метод класса (статический метод) класса TObject.
class function TObject.ObjectInstance(Value: TObject): string[38];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа string[38].

4.81.88. Метод Pos (Поиск подстроки)

Метод класса (статический метод) класса TObject.
1class function TObject.Pos(Substring: string[2000];
2  Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Substring

string[2000]

Нет

Подстрока

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

4.81.89. Метод PreprocessRegExp (Адаптировать регулярное выражение к требованиям СУБД)

Метод класса (статический метод) класса TObject.
class function TObject.PreprocessRegExp(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.81.90. Метод QualifiedName (Квалифицированное имя)

Метод экземпляра класса TObject.
function TObject.QualifiedName: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.81.91. Метод QuotedStr (Строку в апострофы)

Метод класса (статический метод) класса TObject.
class function TObject.QuotedStr(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.81.92. Метод RaiseException (Возбудить исключение)

Метод класса (статический метод) класса TObject.
class procedure TObject.RaiseException(Message: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Message

string[2000]

Нет

Сообщение

4.81.93. Метод RaiseResource (Возбудить исключение по ресурсной строке)

Метод класса (статический метод) класса TObject.
class procedure TObject.RaiseResource(AOwner: string[64]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

4.81.94. Метод ReadFromClob (Считать строку из большого текстового объекта)

Метод класса (статический метод) класса TObject.
class function TObject.ReadFromClob(Value: clob): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.81.95. Метод ResourceByItem (Значение ресурсной строки)

Метод класса (статический метод) класса TObject.
class function TObject.ResourceByItem(Resource: Resource strings): string[128];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Resource

Resource strings

Нет

Ресурс

Замечания:

Возвращает значение типа string[128].

4.81.96. Метод Round (Округление)

Метод класса (статический метод) класса TObject.
class function TObject.Round(Value: float; Decimals: Integer): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Decimals

Integer

Нет

Количество десятичных знаков

Замечания:

Возвращает значение типа float.

4.81.97. Метод SendInstantMessage (Отправить мгновенное сообщение)

Метод класса (статический метод) класса TObject.
1class procedure TObject.SendInstantMessage(Recipient: TUser;
2  MessageText: string[255]; DeliveryTime: datetime; AttachSelected: Boolean;
3  Selected: TObjectList; CurrentFormView: TFormView; HyperLink: string[256];
4  FileName: string[255]; FileBaseName: string[128]; FileBody: blob;
5  AttachmentType: TInstantMessageAttachmentType);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Recipient

TUser

Да

Получатель

MessageText

string[255]

Да

Сообщение

DeliveryTime

datetime

Нет

Время доставки

AttachSelected

Boolean

Да

Присоединить выбранные объекты

Selected

TObjectList

Нет

Список выбранных

CurrentFormView

TFormView

Нет

Текущее представление формы

HyperLink

string[256]

Нет

Гиперссылка

FileName

string[255]

Нет

Файл

FileBaseName

string[128]

Да

Имя файла (без пути)

FileBody

blob

Нет

Содержимое файла

AttachmentType

TInstantMessageAttachmentType

Да

Тип приложения

4.81.98. Метод Sleep (Задержка выполнения)

Метод класса (статический метод) класса TObject.
class procedure TObject.Sleep(Seconds: Integer);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Seconds

Integer

Да

Количество секунд

4.81.99. Метод StringReplace (Заменить содержимое строки)

Метод класса (статический метод) класса TObject.
1class function TObject.StringReplace(Value: string[2000];
2  OldPattern: string[2000]; NewPattern: string[2000];
3  ReplaceAll: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

OldPattern

string[2000]

Нет

Старый шаблон

NewPattern

string[2000]

Нет

Новый шаблон

ReplaceAll

Boolean

Да

Заменять все

Замечания:

Возвращает значение типа string[2000].

4.81.100. Метод StrLength (Длина строки)

Метод класса (статический метод) класса TObject.
class function TObject.StrLength(String: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

String

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

4.81.101. Метод StrLike (Сопоставить строку с шаблоном)

Метод класса (статический метод) класса TObject.
1class function TObject.StrLike(Value: string[2000];
2  Pattern: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Pattern

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа Boolean.

4.81.102. Метод StrPad (Заполнить строку)

Метод класса (статический метод) класса TObject.
1class function TObject.StrPad(Value: string[2000]; Padding: string[2000];
2  PadRight: Boolean; MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Padding

string[2000]

Нет

Заполнитель

PadRight

Boolean

Да

Заполнять справа

MaxLength

Integer

Нет

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

4.81.103. Метод StrToBool (Строку в логическое значение)

Метод класса (статический метод) класса TObject.
class function TObject.StrToBool(Value: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.81.104. Метод StrToDate (Строку в дату)

Метод класса (статический метод) класса TObject.
class function TObject.StrToDate(Value: string[2000]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа date.

4.81.105. Метод StrToDateTime (Строку в дату и время)

Метод класса (статический метод) класса TObject.
class function TObject.StrToDateTime(Value: string[2000]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа datetime.

4.81.106. Метод StrToFloat (Строку в вещественное)

Метод класса (статический метод) класса TObject.
class function TObject.StrToFloat(Value: string[2000]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа float.

4.81.107. Метод StrToInt (Строку в целое)

Метод класса (статический метод) класса TObject.
class function TObject.StrToInt(Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

4.81.108. Метод StrToTime (Строку во время)

Метод класса (статический метод) класса TObject.
class function TObject.StrToTime(Value: string[2000]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа time.

4.81.109. Метод StrTranslate (Транслировать символы в строке)

Метод класса (статический метод) класса TObject.
1class function TObject.StrTranslate(Value: string[2000];
2  OldChars: string[2000]; NewChars: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

OldChars

string[2000]

Нет

Старый набор символов

NewChars

string[2000]

Нет

Новый набор символов

Замечания:

Возвращает значение типа string[2000].

4.81.110. Метод StrWrap (Выровнять строку)

Метод класса (статический метод) класса TObject.
1class function TObject.StrWrap(Value: string[2000]; Delimiter: string[2000];
2  MaxCol: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

MaxCol

Integer

Нет

Максимальное количество символов

Замечания:

Возвращает значение типа string[2000].

4.81.111. Метод SuggestDescription (Предложить наименование)

Метод экземпляра класса TObject.
procedure TObject.SuggestDescription(Description: string[128]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Description

string[128]

Да

Наименование

4.81.112. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TObject.
function TObject.SuggestFileName(Domain: TDomain): string[128];
Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Домен

Замечания:

Возвращает значение типа string[128].

4.81.113. Метод TimeOf (Время из даты со временем)

Метод класса (статический метод) класса TObject.
class function TObject.TimeOf(Value: datetime): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа time.

4.81.114. Метод TimePart (Часть времени)

Метод класса (статический метод) класса TObject.
class function TObject.TimePart(Value: time; Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

4.81.115. Метод TimeToStr (Время в строку)

Метод класса (статический метод) класса TObject.
class function TObject.TimeToStr(Value: time): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.81.116. Метод Touch (Модификация объекта)

Метод экземпляра класса TObject.
procedure TObject.Touch;
Метод скрыт от пользователя.

Метод не имеет параметров.

4.81.117. Метод Trim (Убрать лишние пробелы)

Метод класса (статический метод) класса TObject.
class function TObject.Trim(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.81.118. Метод Trunc (Отсечение дробной части)

Метод класса (статический метод) класса TObject.
class function TObject.Trunc(Value: float): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа Integer.

4.81.119. Метод UniqueValue (Уникальный идентификатор)

Метод класса (статический метод) класса TObject.
class function TObject.UniqueValue: string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

4.81.120. Метод UpperCase (Преобразовать к верхнему регистру)

Метод класса (статический метод) класса TObject.
class function TObject.UpperCase(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.81.121. Метод Ole-объекта CheckSGMLContent (Проверить SGML-содержимое)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Property

TProperty

Да

Свойство

Замечания:

Возвращает значение типа string[2000].

4.81.122. Метод Ole-объекта ExportAfter (Экспортировать модифицированные)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла-реплики

FromDate

datetime

Нет

Модифицировано после

4.81.123. Метод Ole-объекта FixSGMLContentErrors (Исправить ошибки SGML-содержимого)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Property

TProperty

Да

Свойство

Замечания:

Возвращает значение типа string[2000].

4.81.124. Метод Ole-объекта LoadBlobsFromFolder (Загрузить данные из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Property

TProperty

Да

Свойство

Template

string[128]

Да

Шаблон

Замечания:

Возвращает значение типа Integer.

4.81.125. Метод Ole-объекта SaveBlobsToFolder (Сохранить данные в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Property

TProperty

Да

Свойство

Template

string[128]

Да

Шаблон

List

TObjectList

Нет

Список объектов

Замечания:

Возвращает значение типа Integer.

4.81.126. Метод Ole-объекта SplitExcelSheetsToFiles (Разделить Excel листы на файлы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта скрыт от пользователя.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

WorkBook

blob

Нет

Книга (объект)

FileName

string[255]

Нет

Имя Excel-файла

FileNameMappingSheetName

string[128]

Нет

Имя листа с сопоставлениями имен файлов (по умолчанию MapSheetNameToFileName)

Folder

string[255]

Да

Каталог

4.81.127. Шаблон отчета Excel Excel (Перенести в Excel)

Шаблон отчета Excel класса (статический шаблон) класса TObject.

Шаблон отчета Excel является методом класса.

Шаблон отчета Excel не имеет параметров.

4.81.128. Шаблон отчета Word SpellCheck (Проверка правописания)

Шаблон отчета Word класса (статический шаблон) класса TObject.

Шаблон отчета Word скрыт от пользователя.

Шаблон отчета Word является методом класса.

Шаблон отчета Word не имеет параметров.

4.81.129. Шаблон XSLT-отчета ObjectInformation (Информация об объекте)

Шаблон XSLT-отчета класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ShowHiddenProps

Boolean

Да

Показывать скрытые свойства

4.81.130. Шаблон XSLT-отчета SelectDataToText (Выполнить запрос в текст)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

Query

clob

Нет

Запрос

4.81.131. Шаблон XSLT-отчета SelectDataToXML (Выполнить запрос в xml-документ)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

Query

clob

Нет

Запрос

4.81.132. Подпрограмма Column (Колонка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.133. Подпрограмма CopyToClipboard (Копировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

4.81.134. Подпрограмма CurrentFormView (Текущее представление формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.135. Подпрограмма CurrentlySelected (Список выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.136. Подпрограмма CurrentlySelectedSet (Множество выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.137. Подпрограмма CurrentlyVisible (Список видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.138. Подпрограмма CurrentlyVisibleSet (Множество видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.139. Подпрограмма Dependencies (Зависимости)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

4.81.140. Подпрограмма Edit columns (Редактировать строку)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

4.81.141. Подпрограмма Edit filters (Редактировать фильтры)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.142. Подпрограмма Edit properties (Редактировать свойства)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

4.81.143. Подпрограмма Export (Экспортировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

4.81.144. Подпрограмма ExportReport (Выгрузить в отчет)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.145. Подпрограмма FormOptions (Настройки формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.146. Подпрограмма Import (Импортировать)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.147. Подпрограмма Merge (Объединить)

Подпрограмма класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма не имеет параметров.

4.81.148. Подпрограмма Messages (Проверить сообщения)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.149. Подпрограмма Options (Настройки)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.150. Подпрограмма Paste (Вставить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.151. Подпрограмма PasteSpecial (Специальная вставка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.152. Подпрограмма Presentations (Виды)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.153. Подпрограмма Refresh (Обновить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.154. Подпрограмма Search (Поиск)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.155. Подпрограмма Selection (Выбранные)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.81.156. Подпрограмма Tree (Дерево)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

4.82. Класс TObjectArchive (Архив объектов)

4.82.1. Свойства

Свойства класса TObjectArchive:

Имя

Тип

Обязательно

Доступ

Назначение

Object

TObject

Да

Только для чтения

Объект

ObjectName

string[64]

Да

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Только для чтения

Наименование объекта

ObjectClass

TClass

Да

Только для чтения

Класс объекта

ObjectParent

TObject

Нет

Только для чтения

Объект-родитель

ObjectMaster

TObject

Да

Только для чтения

Объект-мастер

ObjectSourceDataBase

TDataBase

Да

Только для чтения

База данных-источник

ObjectOldID

string[38]

Да

Только для чтения

Идентификатор объекта при создании

ObjectCreator

TUser

Да

Только для чтения

Объект создан пользователем

ObjectCreated

datetime

Да

Только для чтения

Объект создан

ObjectModifier

TUser

Да

Только для чтения

Объект изменен пользователем

ObjectModified

datetime

Да

Только для чтения

Объект изменен

User

TUser

Да

Только для чтения

Пользователь

UserName

string[64]

Да

Только для чтения

Имя пользователя

4.82.2. Метод Purge (Очистить архив)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Purge(TimeLimit: time);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeLimit

time

Нет

Лимит времени выполнения

4.82.3. Метод Put (Положить объект в архив)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Put(Object: TObject);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

4.82.4. Метод PutAutonomous (Положить объект в архив в автономной транзакции)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.PutAutonomous(Object: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

4.82.5. Метод Remove (Исключить объект из архива)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Remove(Object: TObject);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

4.83. Класс TObjectCreator (Роли-создатели)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.83.1. Свойства

Свойства класса TObjectCreator:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

4.83.2. Конструктор Create (Конструктор роли-создателя)

Конструктор класса TObjectCreator.
1constructor TObjectCreator.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TObjectCreator.

4.84. Класс TObjectHistory (История объектов)

4.84.1. Свойства

Свойства класса TObjectHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Только для чтения

Имя

Description

string[128]

Да

Видимо пользователю

Только для чтения

Наименование

Class

TClass

Да

Видимо пользователю

Только для чтения

Класс

Master

string[2000]

Нет

Видимо пользователю

Только для чтения

Мастер

Parent

string[2000]

Нет

Видимо пользователю

Только для чтения

Родитель

Data

string[2000]

Нет

Видимо пользователю

Только для чтения

Содержимое

Action

TChangeAction

Да

Видимо пользователю

Только для чтения

Действие

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

ObjectOldID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор при создании

ObjectDataBase

TDataBase

Да

Видимо пользователю

Только для чтения

База данных объекта

ObjectID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор объекта

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

FieldName

string[64]

Да

Видимо пользователю

Только для чтения

Поле

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

4.84.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TObjectHistory.
1class procedure TObjectHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

4.84.3. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TObjectHistory.
1class procedure TObjectHistory.Log(Object: TObject; Action: TChangeAction;
2  Field: TField; Data: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

Action

TChangeAction

Да

Действие

Field

TField

Нет

Поле

Data

string[2000]

Нет

Содержимое

4.84.4. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObjectHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

4.84.5. Шаблон отчета Excel UserActivityReport (Отчет об активности пользователей)

Шаблон отчета Excel класса (статический шаблон) класса TObjectHistory.

Шаблон отчета Excel является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

UDate

date

Нет

Дата

4.85. Класс TObjectList (Списки)

Объекты класса не именованы.

4.85.1. Свойства

Свойства класса TObjectList:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

AsString

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

Список в текстовом представлении

AsClob

clob

Нет

Скрыто от пользователя

Чтение/Запись

Список в виде большого текстового объекта

4.85.2. Конструктор Create (Конструктор списка)

Конструктор класса TObjectList.
1constructor TObjectList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TObjectList.

4.85.3. Метод Add (Добавить объект в список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Add(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

4.85.4. Метод Archive (Отправить список в архив)

Метод экземпляра класса TObjectList.
procedure TObjectList.Archive;
Метод не имеет параметров.

4.85.5. Метод ArchiveAll (Отправить список в архив со всем содержимым)

Метод экземпляра класса TObjectList.
procedure TObjectList.ArchiveAll;
Метод не имеет параметров.

4.85.6. Метод ByName (Поиск по имени)

Метод экземпляра класса TObjectList.
function TObjectList.ByName(Name: string[64]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Замечания:

Возвращает значение типа Integer.

4.85.7. Метод Clear (Очистить список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Clear;
Метод скрыт от пользователя.

Метод не имеет параметров.

4.85.8. Метод CreateFromClob (Создать список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromClob(Value: clob): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

4.85.9. Метод CreateFromOrderedClob (Создать упорядоченный список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromOrderedClob(Value: clob): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

4.85.10. Метод CreateFromOrderedString (Создать упорядоченный список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromOrderedString(Value: string[2000]): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

4.85.11. Метод CreateFromString (Создать список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromString(Value: string[2000]): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

4.85.12. Метод Delete (Удалить объект)

Метод экземпляра класса TObjectList.
procedure TObjectList.Delete(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

4.85.13. Метод DestroyAll (Удалить вместе с содержащимися в списке объектами)

Метод экземпляра класса TObjectList.
procedure TObjectList.DestroyAll;
Метод не имеет параметров.

4.85.14. Метод Force (Добавить, игнорируя ограничения)

Метод экземпляра класса TObjectList.
procedure TObjectList.Force(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

4.85.15. Метод GetAsClob (Получить в виде большого текстового объекта)

Метод экземпляра класса TObjectList.
function TObjectList.GetAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

4.85.16. Метод GetAsString (Список в текстовом представлении)

Метод экземпляра класса TObjectList.
function TObjectList.GetAsString: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.85.17. Метод GetItem (Получить объект из списка)

Метод экземпляра класса TObjectList.
function TObjectList.GetItem(ItemIndex: Integer): TObject;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

Замечания:

Возвращает значение типа TObject.

4.85.18. Метод IndexOf (Индекс объекта в списке)

Метод экземпляра класса TObjectList.
function TObjectList.IndexOf(ItemObject: TObject): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

Замечания:

Возвращает значение типа Integer.

4.85.19. Метод Insert (Вставить объект в список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Insert(ItemIndex: Integer; ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemObject

TObject

Да

Элемент

4.85.20. Метод IsExcluded (Объект не входит в список)

Метод экземпляра класса TObjectList.
function TObjectList.IsExcluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.85.21. Метод IsIncluded (Объект входит в список)

Метод экземпляра класса TObjectList.
function TObjectList.IsIncluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.85.22. Метод Length (Длина списка)

Метод экземпляра класса TObjectList.
function TObjectList.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.85.23. Метод LoadFromClob (Загрузить содержимое списка из большого текстового объекта)

Метод экземпляра класса TObjectList.
1procedure TObjectList.LoadFromClob(Value: clob; Ordered: Boolean;
2  Clear: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Ordered

Boolean

Да

Сохранить порядок объектов

Clear

Boolean

Да

Очистить перед загрузкой

4.85.24. Метод LoadFromString (Загрузить содержимое списка из текстового представления)

Метод экземпляра класса TObjectList.
1procedure TObjectList.LoadFromString(Value: string[2000]; Ordered: Boolean;
2  Clear: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Ordered

Boolean

Да

Сохранить порядок объектов

Clear

Boolean

Да

Очистить перед загрузкой

4.85.25. Метод Remove (Вычистить объект)

Метод экземпляра класса TObjectList.
procedure TObjectList.Remove(ItemObject: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

4.85.26. Метод Reorder (Перенумеровать объекты в списке)

Метод экземпляра класса TObjectList.
procedure TObjectList.Reorder;
Метод не имеет параметров.

4.85.27. Метод SetAsClob (Установить список в виде большого текстового объекта)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetAsClob(Value: clob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

4.85.28. Метод SetAsString (Установить список в текстовом представлении)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetAsString(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

4.85.29. Метод SetItem (Установить объект в списке)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetItem(ItemIndex: Integer; ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemObject

TObject

Да

Элемент

4.86. Класс TObjectListItem (Элементы списков)

4.86.1. Свойства

Свойства класса TObjectListItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Object

TObject

Да

Видимо пользователю

Только для чтения

Объект

Position

Integer

Да

Видимо пользователю

Только для чтения

Позиция

4.86.2. Конструктор Create (Конструктор элемента списка)

Конструктор класса TObjectListItem.
1constructor TObjectListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ItemObject: TObject; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ItemObject

TObject

Да

Элемент

Position

Integer

Нет

Позиция

Замечания:

Создает новый объект класса TObjectListItem.

4.87. Класс TObjectSet (Множества объектов)

4.87.1. Конструктор Create (Создать множество)

Конструктор класса TObjectSet.
constructor TObjectSet.Create: TObjectSet;
Метод не имеет параметров.

Замечания:

Создает новый объект класса TObjectSet.

4.87.2. Метод Add (Добавить множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Add(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

4.87.3. Метод Change (Изменение объекта)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

4.87.4. Метод Clear (Очистить множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Clear;
Метод не имеет параметров.

4.87.5. Метод Clone (Клонировать множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.Clone: TObjectSet;
Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectSet.

4.87.6. Метод CreateFromClob (Создать множество на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectSet.
class function TObjectSet.CreateFromClob(Value: clob): TObjectSet;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectSet.

4.87.7. Метод CreateFromString (Создать множество на основе строки)

Метод класса (статический метод) класса TObjectSet.
class function TObjectSet.CreateFromString(Value: string[2000]): TObjectSet;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectSet.

4.87.8. Метод Exclude (Исключить объект из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Exclude(Value: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

4.87.9. Метод ExcludeClob (Исключить содержимое большого текстового объекта из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.ExcludeClob(Value: clob);
Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

4.87.10. Метод ExcludeString (Исключить содержимое строки из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.ExcludeString(Value: string[2000]);
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

4.87.11. Метод GetAsClob (Множество в виде большого текстового объекта)

Метод экземпляра класса TObjectSet.
function TObjectSet.GetAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

4.87.12. Метод GetAsString (Множество в виде строки)

Метод экземпляра класса TObjectSet.
function TObjectSet.GetAsString: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.87.13. Метод Include (Включить объект в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Include(Value: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

4.87.14. Метод IncludeClob (Включить содержимое большого текстового объекта в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.IncludeClob(Value: clob);
Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

4.87.15. Метод IncludeString (Включить содержимое строки в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.IncludeString(Value: string[2000]);
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

4.87.16. Метод IsExcluded (Объект не входит в множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.IsExcluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.87.17. Метод IsIncluded (Объект входит в множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.IsIncluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

4.87.18. Метод Length (Количество элементов)

Метод экземпляра класса TObjectSet.
function TObjectSet.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.87.19. Метод Multiply (Умножить на множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Multiply(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

4.87.20. Метод Subtract (Вычесть множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Subtract(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

4.88. Класс TOleObjectMethod (Метод Ole-объекта)

4.88.1. Свойства

Свойства класса TOleObjectMethod:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

ClassID

string[128]

Нет

Видимо пользователю

Чтение/Запись

Идентификатор класса

Method

string[128]

Нет

Видимо пользователю

Чтение/Запись

Метод

CodeLibrary

TAccessibleFile

Нет

Видимо пользователю

Чтение/Запись

Библиотека кода

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

4.88.2. Конструктор Create (Конструктор метода Ole-объекта)

Конструктор класса TOleObjectMethod.
1constructor TOleObjectMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; CodeLibrary: TAccessibleFile;
6  ClassID: string[128]; Method: string[128]; IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

CodeLibrary

TAccessibleFile

Нет

Библиотека кода

ClassID

string[128]

Нет

Идентификатор класса

Method

string[128]

Нет

Метод

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TOleObjectMethod.

4.88.3. Метод Ole-объекта CheckOleObjectMethod (Проверить метод Ole-объекта)

Метод Ole-объекта класса TOleObjectMethod.

Метод Ole-объекта не имеет параметров.

4.89. Класс TOption (Настройки)

4.89.1. Свойства

Свойства класса TOption:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Global

Boolean

Да

Видимо пользователю

Чтение/Запись

Глобальная

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Value

TOptionValue

Нет

Скрыто от пользователя

Только для чтения

Значение

User

TUser

Нет

Видимо пользователю

Чтение/Запись

Пользователь

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

Видимое значение

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

4.89.2. Конструктор Create (Конструктор настройки)

Конструктор класса TOption.
1constructor TOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Global: Boolean; Group: string[128]; Tab: string[128];
4  Position: Integer; Scope: TScope): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Global

Boolean

Да

Глобальная

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Position

Integer

Нет

Позиция

Scope

TScope

Да

Область видимости

Замечания:

Создает новый объект класса TOption.

4.89.3. Метод AreValid (Настройки действительны)

Метод класса (статический метод) класса TOption.
class function TOption.AreValid: Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.89.4. Метод GetBlobValue (Значение-большой объект)

Метод класса (статический метод) класса TOption.
class function TOption.GetBlobValue(OptionName: string[64]): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа blob.

4.89.5. Метод GetBoolValue (Логическое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetBoolValue(OptionName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа Boolean.

4.89.6. Метод GetClobValue (Значение-текст)

Метод класса (статический метод) класса TOption.
class function TOption.GetClobValue(OptionName: string[64]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа clob.

4.89.7. Метод GetDateTimeValue (Значение даты со временем)

Метод класса (статический метод) класса TOption.
class function TOption.GetDateTimeValue(OptionName: string[64]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа datetime.

4.89.8. Метод GetDateValue (Значение даты)

Метод класса (статический метод) класса TOption.
class function TOption.GetDateValue(OptionName: string[64]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа date.

4.89.9. Метод GetExternalDataValue (Значение внешних данных)

Метод класса (статический метод) класса TOption.
1class function TOption.GetExternalDataValue(OptionName: string[64]): <external
2  data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа <external data>.

4.89.10. Метод GetFloatValue (Вещественное значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetFloatValue(OptionName: string[64]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа float.

4.89.11. Метод GetIntValue (Целое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetIntValue(OptionName: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа Integer.

4.89.12. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TOption.
class function TOption.GetNextPos: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.89.13. Метод GetObjectValue (Значение-объект)

Метод класса (статический метод) класса TOption.
class function TOption.GetObjectValue(OptionName: string[64]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа TObject.

4.89.14. Метод GetStrValue (Строковое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetStrValue(OptionName: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа string[2000].

4.89.15. Метод GetTimeValue (Значение времени)

Метод класса (статический метод) класса TOption.
class function TOption.GetTimeValue(OptionName: string[64]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа time.

4.89.16. Метод GetValue (Значение)

Метод экземпляра класса TOption.
function TOption.GetValue: TOptionValue;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TOptionValue.

4.89.17. Метод SetValue (Установка значения)

Метод экземпляра класса TOption.
1procedure TOption.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>; Default: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Default

Boolean

Да

По умолчанию

4.90. Класс TOptionValue (Значения настроек)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.90.1. Свойства

Свойства класса TOptionValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

User

TUser

Нет

Видимо пользователю

Чтение/Запись

Пользователь

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущим

Option

TOption

Да

Скрыто от пользователя

Только для чтения

Настройка

Domain

TDomain

Да

Видимо пользователю

Только для чтения

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Global

Boolean

Да

Видимо пользователю

Только для чтения

Глобальная

4.90.2. Конструктор Create (Конструктор значения настройки)

Конструктор класса TOptionValue.
1constructor TOptionValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Унаследовано от TTypedValue.Create

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

User

TUser

Нет

Пользователь

Замечания:

Создает новый объект класса TOptionValue.

4.91. Класс TParameter (Параметры)

4.91.1. Свойства

Свойства класса TParameter:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

RoutineClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс подпрограммы

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

InitializationMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Инициализируется членом класса

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределен

LinkedView

TParametersFormView

Нет

Видимо пользователю

Чтение/Запись

Связанное представление

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

4.91.2. Конструктор Create (Конструктор параметра)

Конструктор класса TParameter.
1constructor TParameter.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; InitializationMember: TClassMember; OutOfTabs: Boolean;
5  LinkedView: TParametersFormView; Logged: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

InitializationMember

TClassMember

Нет

Инициализируется членом класса

OutOfTabs

Boolean

Да

За пределами закладок

LinkedView

TParametersFormView

Нет

Связанное представление

Logged

Boolean

Да

Протоколировать

Замечания:

Создает новый объект класса TParameter.

4.91.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TParameter.
class function TParameter.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

4.91.4. Метод GetOverride (Переопределен)

Метод экземпляра класса TParameter.
function TParameter.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.92. Класс TParameterHistory (Параметры вызовов)

4.92.1. Свойства

Свойства класса TParameterHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Routine

TRoutineHistory

Да

Скрыто от пользователя

Только для чтения

Вызов подпрограммы

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

ParameterName

string[64]

Да

Видимо пользователю

Только для чтения

Параметр

Data

string[2000]

Нет

Видимо пользователю

Только для чтения

Содержимое

ObjectID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

4.92.2. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TParameterHistory.
1class procedure TParameterHistory.Log(Routine: TRoutineHistory;
2  Parameter: TParameter; Data: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutineHistory

Да

Вызов подпрограммы

Parameter

TParameter

Да

Параметр

Data

string[2000]

Нет

Содержимое

4.93. Класс TParametersFormView (Представления формы параметров)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

4.93.1. Конструктор Create (Конструктор представления формы параметров)

Конструктор класса TParametersFormView.
1constructor TParametersFormView.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; View: TCustomView; ChildrenMinimized: Boolean;
4  ChildrenOnTabs: Boolean; MasterProperty: TProperty;
5  DetailProperty: TClassMember; Position: Integer; SpacePercentage: Integer;
6  Layout: TFormViewLayout; ExplicitQuery: Boolean): TObject;
Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Унаследовано от TFormView.Create

ChildrenMinimized

Boolean

Да

ChildrenOnTabs

Boolean

Да

MasterProperty

TProperty

Нет

DetailProperty

TClassMember

Нет

Position

Integer

Да

SpacePercentage

Integer

Нет

Layout

TFormViewLayout

Да

ExplicitQuery

Boolean

Да

Замечания:

Создает новый объект класса TParametersFormView.

4.94. Класс TPDFTemplate (Шаблоны отчетов PDF)

4.94.1. Свойства

Свойства класса TPDFTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateScript

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт шаблона

4.94.2. Конструктор Create (Конструктор шаблона PDF)

Конструктор класса TPDFTemplate.
1constructor TPDFTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateScript: clob): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateScript

clob

Нет

Скрипт шаблона

Замечания:

Создает новый объект класса TPDFTemplate.

4.95. Класс TProfile (Профили)

4.95.1. Свойства

Свойства класса TProfile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

ComparisonType

TComparisonType

Да

Видимо пользователю

Чтение/Запись

Тип сравнения

BasedOnProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Расширяет профиль пользователями

Active

Boolean

Да

Видимо пользователю

Только для чтения

Активен

4.95.2. Конструктор Create (Конструктор профиля)

Конструктор класса TProfile.
1constructor TProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType;
4  BasedOnProfile: TProfile): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

ComparisonType

TComparisonType

Да

Тип сравнения

BasedOnProfile

TProfile

Нет

Расширяет профиль пользователями

Замечания:

Создает новый объект класса TProfile.

4.95.3. Метод Check (Проверка профиля)

Метод класса (статический метод) класса TProfile.
class procedure TProfile.Check(Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

4.95.4. Метод GetIsActive (Активен для текущего пользователя)

Метод экземпляра класса TProfile.
function TProfile.GetIsActive: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.95.5. Метод GetValueDomain (Получить домен значения)

Метод экземпляра класса TProfile.
function TProfile.GetValueDomain: TDomain;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TDomain.

4.95.6. Метод Match (Проверка совпадения)

Метод экземпляра класса TProfile.
1function TProfile.Match(Object: TObject; ObjectClass: TClass;
2  ValueGiven: Boolean; StrValue: string[2000]; IntValue: Integer;
3  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
4  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
5  ExternalDataValue: <external data>): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

ValueGiven

Boolean

Да

Значение задано

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Возвращает значение типа Boolean.

4.95.7. Метод MatchObject (Проверка совпадения объекта)

Метод экземпляра класса TProfile.
function TProfile.MatchObject(Object: TObject; ObjectClass: TClass): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

Замечания:

Возвращает значение типа Boolean.

4.95.8. Метод TryCheck (Проверка профиля с возвратом результата)

Метод класса (статический метод) класса TProfile.
class function TProfile.TryCheck(Object: TObject; ObjectClass: TClass): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

Замечания:

Возвращает значение типа Boolean.

4.96. Класс TProfileEvent (События профиля)

4.96.1. Свойства

Свойства класса TProfileEvent:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Method

TProfileMethod

Да

Скрыто от пользователя

Только для чтения

Метод профилировщика

Class

TClass

Да

Видимо пользователю

Только для чтения

Класс

ObjectID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Видимо пользователю

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

Action

TChangeAction

Да

Видимо пользователю

Только для чтения

Действия

4.97. Класс TProfileItem (Состав профиля)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.97.1. Свойства

Свойства класса TProfileItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ProfileClass

TClass

Да

Видимо пользователю

Чтение/Запись

Профилируемый класс

ProfileProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Профилируемое свойство

Comparator

TMethod

Нет

Видимо пользователю

Чтение/Запись

Сравнивающая функция

Group

string[64]

Нет

Видимо пользователю

Чтение/Запись

Группа

AllowNulls

Boolean

Да

Видимо пользователю

Чтение/Запись

Пропускать пустые значения

HasCrossCondition

Boolean

Да

Видимо пользователю

Только для чтения

Имеется пересечение условий

4.97.2. Конструктор Create (Конструктор элемента профиля)

Конструктор класса TProfileItem.
1constructor TProfileItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ProfileClass: TClass; ProfileProperty: TProperty; Comparator: TMethod;
4  Group: string[64]; AllowNulls: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ProfileClass

TClass

Да

Профилируемый класс

ProfileProperty

TProperty

Нет

Профилируемое свойство

Comparator

TMethod

Нет

Сравнивающая функция

Group

string[64]

Нет

Группа

AllowNulls

Boolean

Да

Пропускать пустые значения

Замечания:

Создает новый объект класса TProfileItem.

4.97.3. Метод GetHasCrossConditions (Имеется пересечение условий)

Метод экземпляра класса TProfileItem.
function TProfileItem.GetHasCrossConditions: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.98. Класс TProfileMethod (Методы профиля)

Объекты класса образуют иерархию.

4.98.1. Свойства

Свойства класса TProfileMethod:

Имя

Тип

Обязательно

Доступ

Назначение

Parent

TProfileMethod

Нет

Только для чтения

Родитель

Method

TMethod

Да

Только для чтения

Метод профилировщика

MethodClass

TClass

Да

Только для чтения

Класс

Position

Integer

Да

Только для чтения

Позиция

Duration

Integer

Нет

Только для чтения

Общее время

CodeDuration

Integer

Нет

Только для чтения

Время собственного кода

Calls

Integer

Нет

Только для чтения

Количество непосредственных вызовов

Events

Integer

Нет

Только для чтения

Непосредственных операций с данными

CommonCalls

Integer

Нет

Только для чтения

Всего вызовов

CommonEvents

Integer

Нет

Только для чтения

Всего операций с данными

ObjectID

string[38]

Да

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Только для чтения

Идентификатор при создании

4.98.2. Метод BuildReport (Перестроить отчет)

Метод класса (статический метод) класса TProfileMethod.
class procedure TProfileMethod.BuildReport(QualifyObjects: Boolean);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

QualifyObjects

Boolean

Да

Квалифицировать объекты

4.98.3. Метод Clear (Очистить статистику)

Метод класса (статический метод) класса TProfileMethod.
class procedure TProfileMethod.Clear;
Метод является методом класса.

Метод не имеет параметров.

4.98.4. Метод Ole-объекта ExportProfilerReport (Экспортировать отчет)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TProfileMethod.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

4.99. Класс TProfileStatistics (Статистика профиля)

4.99.1. Свойства

Свойства класса TProfileStatistics:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Method

TProfileMethod

Да

Скрыто от пользователя

Только для чтения

Метод профилировщика

CalledMethod

TMethod

Нет

Видимо пользователю

Только для чтения

Вызываемый метод

CalledMethodClass

TObject

Да

Видимо пользователю

Только для чтения

Класс

Calls

Integer

Нет

Видимо пользователю

Только для чтения

Количество вызовов

Class

TClass

Нет

Видимо пользователю

Только для чтения

Класс

Inserts

Integer

Нет

Видимо пользователю

Только для чтения

Количество добавлений

Updates

Integer

Нет

Видимо пользователю

Только для чтения

Количество изменений

Deletes

Integer

Нет

Видимо пользователю

Только для чтения

Количество удалений

Type

string[128]

Нет

Видимо пользователю

Только для чтения

Тип

4.100. Класс TProfileUser (Пользователи профиля)

Объекты класса не именованы.

Наименования объектов класса генерируются.

4.100.1. Свойства

Свойства класса TProfileUser:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

UserIsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Пользователь является текущим

Profile

TProfile

Да

Скрыто от пользователя

Только для чтения

Профиль

Domain

TDomain

Да

Скрыто от пользователя

Только для чтения

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

4.100.2. Конструктор Create (Конструктор пользовательского профиля)

Конструктор класса TProfileUser.
1constructor TProfileUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TProfile; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TProfile

Да

Профиль

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Унаследовано от TTypedValue.Create

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

User

TUser

Да

Пользователь

Замечания:

Создает новый объект класса TProfileUser.

4.101. Класс TProperty (Свойства)

Объекты класса образуют иерархию.

4.101.1. Свойства

Свойства класса TProperty:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

ReadMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Член класса для чтения

ReadMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для чтения

WriteMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Член класса для записи

WriteMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для записи

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

IsExportable

Boolean

Да

Видимо пользователю

Чтение/Запись

Для экспорта

IsSuspended

Boolean

Да

Видимо пользователю

Чтение/Запись

Отложенное

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

IsUnupdatable

Boolean

Да

Видимо пользователю

Чтение/Запись

Необновляемое при импорте

NullHandler

TMethod

Нет

Видимо пользователю

Чтение/Запись

Обработчик пустого значения

OnDemand

Boolean

Да

Видимо пользователю

Чтение/Запись

По требованию

4.101.2. Конструктор Create (Конструктор свойства)

Конструктор класса TProperty.
1constructor TProperty.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ReadMember: TClassMember; WriteMember: TClassMember;
4  Position: Integer; Scope: TScope; IsExportable: Boolean; IsSuspended: Boolean;
5  CreateViewColumns: Boolean; Category: string[128]): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

ReadMember

TClassMember

Нет

Член класса для чтения

WriteMember

TClassMember

Нет

Член класса для записи

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

IsExportable

Boolean

Да

Для экспорта

IsSuspended

Boolean

Да

Отложенное

CreateViewColumns

Boolean

Да

Создать колонку во всех представлениях

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TProperty.

4.101.3. Метод Change (Изменение объекта)

Метод экземпляра класса TProperty.
procedure TProperty.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

4.101.4. Метод CreateChildren (Создать дочерние свойства)

Метод экземпляра класса TProperty.
1procedure TProperty.CreateChildren(ClearWriteMember: Boolean;
2  PublicOnly: Boolean; ExactName: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

ClearWriteMember

Boolean

Да

Создавать свойства только для чтения

PublicOnly

Boolean

Да

Создавать только видимые свойства

ExactName

Boolean

Да

Не изменять имя свойства

4.101.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TProperty.
class function TProperty.GetNextPos(Master: TObject; Parent: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Integer.

4.101.6. Метод LocalizableFieldName (Получить имя локализуемого поля)

Метод класса (статический метод) класса TProperty.
1class function TProperty.LocalizableFieldName(Class: TClass;
2  Name: string[64]): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Class

TClass

Нет

Класс

Name

string[64]

Да

Имя

Замечания:

Возвращает значение типа string[64].

4.101.7. Метод LocalizableProperty (Локализуемое свойство)

Метод класса (статический метод) класса TProperty.
1class function TProperty.LocalizableProperty(ClassName: string[64];
2  PropertyName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

PropertyName

string[64]

Да

Имя свойства

Замечания:

Возвращает значение типа Boolean.

4.101.8. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TProperty.
function TProperty.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TClassMember.SuggestFileName, TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

4.102. Класс TPropertyBan (Запрет на свойство)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.102.1. Свойства

Свойства класса TPropertyBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

BannedProperty

TProperty

Да

Видимо пользователю

Только для чтения

Запрещаемое свойство

AllowRead

Boolean

Да

Видимо пользователю

Чтение/Запись

Чтение разрешено

4.102.2. Конструктор Create (Конструктор запрета на свойство)

Конструктор класса TPropertyBan.
1constructor TPropertyBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedProperty: TProperty; AllowRead: Boolean): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

BannedProperty

TProperty

Да

Запрещаемое свойство

AllowRead

Boolean

Да

Чтение разрешено

Замечания:

Создает новый объект класса TPropertyBan.

4.103. Класс TQueue (Очередь)

4.103.1. Свойства

Свойства класса TQueue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

QueueName

string[64]

Да

Видимо пользователю

Только для чтения

Имя очереди

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время входа в очередь

Object

TObject

Нет

Видимо пользователю

Только для чтения

Объект

ObjectName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Видимо пользователю

Только для чтения

Наименование объекта

ObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс объекта

ObjectParent

TObject

Нет

Скрыто от пользователя

Только для чтения

Объект-родитель

ObjectMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Объект-мастер

ObjectSourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

База данных-источник

ObjectOldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Идентификатор объекта при создании

ObjectCreator

TUser

Да

Скрыто от пользователя

Только для чтения

Объект создан пользователем

ObjectCreated

datetime

Да

Скрыто от пользователя

Только для чтения

Объект создан

ObjectModifier

TUser

Да

Скрыто от пользователя

Только для чтения

Объект изменен пользователем

ObjectModified

datetime

Да

Скрыто от пользователя

Только для чтения

Объект изменен

Processed

Boolean

Да

Видимо пользователю

Только для чтения

Обработан

4.103.2. Конструктор Create (Конструктор объекта в очереди)

Конструктор класса TQueue.
constructor TQueue.Create(Object: TObject; QueueName: string[64]): TObject;
Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

QueueName

string[64]

Да

Имя очереди

Замечания:

Создает новый объект класса TQueue.

4.103.3. Деструктор Destroy (Деструктор объекта в очереди)

Деструктор класса TQueue.
destructor TQueue.Destroy;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TQueue или его наследника.

4.103.4. Метод Clear (Очистить очередь)

Метод класса (статический метод) класса TQueue.
class procedure TQueue.Clear(QueueName: string[64]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

QueueName

string[64]

Да

Имя очереди

4.104. Класс TRole (Роли)

4.104.1. Свойства

Свойства класса TRole:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущей

4.104.2. Конструктор Create (Конструктор роли)

Конструктор класса TRole.
1constructor TRole.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TRole.

4.104.3. Метод GetIsCurrent (Является текущей)

Метод экземпляра класса TRole.
function TRole.GetIsCurrent: Boolean;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.105. Класс TRoleMember (Пользователи в ролях)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.105.1. Свойства

Свойства класса TRoleMember:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

User

TSecurityAccount

Да

Видимо пользователю

Только для чтения

Пользователь

UserClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс члена роли

IsPrimary

Boolean

Да

Видимо пользователю

Чтение/Запись

Основная роль

4.105.2. Конструктор Create (Конструктор члена роли)

Конструктор класса TRoleMember.
1constructor TRoleMember.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TRole; Accessor: TSecurityAccount;
3  User: TSecurityAccount; IsPrimary: Boolean; AddLinked: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TRole

Да

Роль

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

User

TSecurityAccount

Да

Пользователь

IsPrimary

Boolean

Да

Основная роль

AddLinked

Boolean

Да

Добавить связанные роли

Замечания:

Создает новый объект класса TRoleMember.

4.105.3. Метод SetIsPrimary (Установка значения свойства "Является основной")

Метод экземпляра класса TRoleMember.
procedure TRoleMember.SetIsPrimary(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

4.106. Класс TRoutine (Подпрограмма)

4.106.1. Свойства

Свойства класса TRoutine:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Домен результата

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена результата

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена результата

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Является методом класса

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Текст подтверждения

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Использовать закладки

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт формы параметров

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение-иконка

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество параметров

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

Сообщение о выполнении

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

Вызывать только для одного объекта

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

4.106.2. Конструктор Create (Конструктор подпрограммы)

Конструктор класса TRoutine.
1constructor TRoutine.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Является методом класса

SingleObject

Boolean

Да

Вызывать только для одного объекта

Domain

TDomain

Нет

Домен результата

Scope

TScope

Да

Область видимости

Confirmation

string[512]

Нет

Текст подтверждения

ReportMessage

string[512]

Нет

Сообщение о выполнении

UseTabs

Boolean

Да

Использовать закладки

Script

clob

Нет

Скрипт формы параметров

Image

blob

Нет

Изображение-иконка

Logged

Boolean

Да

Протоколировать

Замечания:

Создает новый объект класса TRoutine.

4.106.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TRoutine.
procedure TRoutine.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

4.106.4. Метод GetParamCount (Количество параметров)

Метод экземпляра класса TRoutine.
function TRoutine.GetParamCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.106.5. Метод ListParameters (Список параметров)

Метод экземпляра класса TRoutine.
function TRoutine.ListParameters: TObjectList;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.

4.106.6. Метод ParameterByName (Получить параметр по имени)

Метод экземпляра класса TRoutine.
function TRoutine.ParameterByName(AName: string[64]): TParameter;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

AName

string[64]

Да

Имя

Замечания:

Возвращает значение типа TParameter.

4.106.7. Метод Ole-объекта CreateReportTemplate (Сгенерировать шаблон отчета)

Метод Ole-объекта класса TRoutine.

Метод Ole-объекта не имеет параметров.

4.107. Класс TRoutineAction (Программируемое действие)

Объекты класса образуют иерархию.

4.107.1. Свойства

Свойства класса TRoutineAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

ContextProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Выполнять в контексте свойства

AllowNavigation

Boolean

Да

Видимо пользователю

Чтение/Запись

Доступна навигация

4.107.2. Конструктор Create (Конструктор программируемого действия)

Конструктор класса TRoutineAction.
1constructor TRoutineAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  Routine: TRoutine; ContextProperty: TProperty;
5  AllowNavigation: Boolean): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

Routine

TRoutine

Да

Реализовано посредством

ContextProperty

TProperty

Нет

выполнять в контексте

AllowNavigation

Boolean

Да

Доступна навигация

Замечания:

Создает новый объект класса TRoutineAction.

4.107.3. Метод EnsureAction (Обеспечить наличие действия)

Метод класса (статический метод) класса TRoutineAction.
1class function TRoutineAction.EnsureAction(AView: TObject; AName: string[64];
2  ADescription: string[128]; APosition: Integer; AShortcut: string[20];
3  ASeparated: Boolean; ARoutine: TRoutine): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AView

TObject

Да

Мастер

AName

string[64]

Да

Имя

ADescription

string[128]

Да

Наименование

APosition

Integer

Да

Позиция

AShortcut

string[20]

Нет

Горячая клавиша

ASeparated

Boolean

Да

Отделено

ARoutine

TRoutine

Да

Реализовано посредством

Замечания:

Возвращает значение типа TObject.

4.108. Класс TRoutineBan (Запрет на подпрограмму)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.108.1. Свойства

Свойства класса TRoutineBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

BannedRoutine

TRoutine

Да

Видимо пользователю

Только для чтения

Запрещаемая подпрограмма

4.108.2. Конструктор Create (Конструктор запрета на подпрограмму)

Конструктор класса TRoutineBan.
1constructor TRoutineBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedRoutine: TRoutine): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

BannedRoutine

TRoutine

Да

Запрещаемая подпрограмма

Замечания:

Создает новый объект класса TRoutineBan.

4.109. Класс TRoutineHistory (Вызовы)

4.109.1. Свойства

Свойства класса TRoutineHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

ObjectID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Видимо пользователю

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

RoutineName

string[64]

Да

Видимо пользователю

Только для чтения

Подпрограмма

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

RoutineClassName

string[64]

Да

Видимо пользователю

Только для чтения

Имя класса подпрограммы

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

4.109.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TRoutineHistory.
1class procedure TRoutineHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

4.109.3. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TRoutineHistory.
1class function TRoutineHistory.Log(Routine: TRoutine;
2  Object: TObject): TRoutineHistory;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Object

TObject

Нет

Объект

Замечания:

Возвращает значение типа TRoutineHistory.

4.109.4. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TRoutineHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

4.110. Класс TSecurityAccount (Роли безопасности)

4.111. Класс TSequence (Последовательности)

4.111.1. Свойства

Свойства класса TSequence:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Value

string[20]

Да

Видимо пользователю

Чтение/Запись

Текущее значение

Cache

Integer

Нет

Видимо пользователю

Чтение/Запись

Кэш

4.111.2. Конструктор Create (Конструктор последовательности)

Конструктор класса TSequence.
1constructor TSequence.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TSequence.

4.111.3. Метод GetCache (Получить кеш)

Метод экземпляра класса TSequence.
function TSequence.GetCache: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.111.4. Метод GetValue (Получить текущее значение)

Метод экземпляра класса TSequence.
function TSequence.GetValue: string[20];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].

4.111.5. Метод Promote (Получить следующее значение)

Метод экземпляра класса TSequence.
function TSequence.Promote: string[20];
Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].

4.111.6. Метод SetCache (Установить кеш)

Метод экземпляра класса TSequence.
procedure TSequence.SetCache(Value: Integer);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

4.111.7. Метод SetValue (Установить текущее значение)

Метод экземпляра класса TSequence.
procedure TSequence.SetValue(Value: string[20]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[20]

Да

Значение

4.112. Класс TSessionHistory (Сессии)

4.112.1. Свойства

Свойства класса TSessionHistory:

Имя

Тип

Обязательно

Доступ

Назначение

IntStamp

Integer

Нет

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Только для чтения

Время

User

TUser

Нет

Только для чтения

Пользователь

Login

string[64]

Да

Только для чтения

Логин

CloseStamp

datetime

Нет

Только для чтения

Время закрытия

UserAgent

string[2000]

Нет

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Только для чтения

Информация о соединении

Duration

time

Нет

Только для чтения

Продолжительность

4.112.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TSessionHistory.
1class procedure TSessionHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

4.112.3. Метод DBMSConnectionInfo (Информация о соединении от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSConnectionInfo: string[2000];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.112.4. Метод DBMSGetIPAddress (IP-адрес клиента от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSGetIPAddress: string[16];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[16].

4.112.5. Метод DBMSGetUserAgent (Пользовательский агент от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSGetUserAgent: string[2000];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.112.6. Метод GetCurrentSession (Идентификатор текущей сессии)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.GetCurrentSession: TSessionHistory;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TSessionHistory.

4.112.7. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TSessionHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

4.113. Класс TStatement (Операторы)

4.113.1. Конструктор Create (Конструктор оператора)

Конструктор класса TStatement.
constructor TStatement.Create: TObject;
Метод не имеет параметров.

Замечания:

Создает новый объект класса TStatement.

4.113.2. Метод BoolLiteral (Логический литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.BoolLiteral(Value: Boolean): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

Замечания:

Возвращает значение типа string[2000].

4.113.3. Метод BuildFunctionCall (Построить вызов функции)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildFunctionCall(Function: TMethod;
2  Parameters: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Function

TMethod

Нет

Функция

Parameters

string[2000]

Нет

Параметры вызова

Замечания:

Возвращает значение типа string[2000].

4.113.4. Метод BuildInsertStatement (Построить скрипт добавления объекта)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildInsertStatement(AObject: TObject;
2  AClass: TClass): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AObject

TObject

Да

Объект

AClass

TClass

Нет

Класс

Замечания:

Возвращает значение типа clob.

4.113.5. Метод BuildProcedureCall (Построить вызов процедуры)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildProcedureCall(Procedure: TMethod;
2  Parameters: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Procedure

TMethod

Нет

Процедура

Parameters

string[2000]

Нет

Параметры вызова

Замечания:

Возвращает значение типа string[2000].

4.113.6. Метод BuildUpdateStatement (Построить скрипт изменения объекта)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildUpdateStatement(AObject: TObject;
2  AClass: TClass): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AObject

TObject

Да

Объект

AClass

TClass

Нет

Класс

Замечания:

Возвращает значение типа clob.

4.113.7. Метод Change (Изменение объекта)

Метод экземпляра класса TStatement.
procedure TStatement.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

4.113.8. Метод DateLiteral (Литерал типа "дата")

Метод класса (статический метод) класса TStatement.
class function TStatement.DateLiteral(Value: date): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.113.9. Метод DateTimeLiteral (Литерал типа "дата со временем")

Метод класса (статический метод) класса TStatement.
class function TStatement.DateTimeLiteral(Value: datetime): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.113.10. Метод Execute (Выполнить)

Метод класса (статический метод) класса TStatement.
class procedure TStatement.Execute(Statement: string[2000]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

4.113.11. Метод ExecuteClob (Выполнить большой текстовый объект)

Метод класса (статический метод) класса TStatement.
class procedure TStatement.ExecuteClob(Statement: clob);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

4.113.12. Метод ExecuteClobToBlobValue (Выполнить большой текстовый объект и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToBlobValue(Statement: clob): blob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа blob.

4.113.13. Метод ExecuteClobToBoolValue (Выполнить большой текстовый объект и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToBoolValue(Statement: clob): Boolean;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа Boolean.

4.113.14. Метод ExecuteClobToClobValue (Выполнить большой текстовый объект и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToClobValue(Statement: clob): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа clob.

4.113.15. Метод ExecuteClobToDateTimeValue (Выполнить большой текстовый объект и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToDateTimeValue(Statement: clob): datetime;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа datetime.

4.113.16. Метод ExecuteClobToDateValue (Выполнить большой текстовый объект и вернуть значение даты)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToDateValue(Statement: clob): date;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа date.

4.113.17. Метод ExecuteClobToExternalDataValue (Выполнить большой текстовый объект и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ExecuteClobToExternalDataValue(Statement: clob): <external
2  data>;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа <external data>.

4.113.18. Метод ExecuteClobToFloatValue (Выполнить большой текстовый объект и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToFloatValue(Statement: clob): float;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа float.

4.113.19. Метод ExecuteClobToIntValue (Выполнить большой текстовый объект и вернуть целое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToIntValue(Statement: clob): Integer;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа Integer.

4.113.20. Метод ExecuteClobToObjectValue (Выполнить большой текстовый объект и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToObjectValue(Statement: clob): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа TObject.

4.113.21. Метод ExecuteClobToStrValue (Выполнить большой текстовый объект и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToStrValue(Statement: clob): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа string[2000].

4.113.22. Метод ExecuteClobToTimeValue (Выполнить большой текстовый объект и вернуть значение времени)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToTimeValue(Statement: clob): time;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа time.

4.113.23. Метод ExecuteToBlobValue (Выполнить и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToBlobValue(Statement: string[2000]): blob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа blob.

4.113.24. Метод ExecuteToBoolValue (Выполнить и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToBoolValue(Statement: string[2000]): Boolean;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа Boolean.

4.113.25. Метод ExecuteToClobValue (Выполнить и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToClobValue(Statement: string[2000]): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа clob.

4.113.26. Метод ExecuteToDateTimeValue (Выполнить и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToDateTimeValue(Statement: string[2000]): datetime;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа datetime.

4.113.27. Метод ExecuteToDateValue (Выполнить и вернуть значение даты)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToDateValue(Statement: string[2000]): date;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа date.

4.113.28. Метод ExecuteToExternalDataValue (Выполнить и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ExecuteToExternalDataValue(Statement: string[2000]): <external
2  data>;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа <external data>.

4.113.29. Метод ExecuteToFloatValue (Выполнить и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToFloatValue(Statement: string[2000]): float;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа float.

4.113.30. Метод ExecuteToIntValue (Выполнить и вернуть целое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToIntValue(Statement: string[2000]): Integer;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа Integer.

4.113.31. Метод ExecuteToObjectValue (Выполнить и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToObjectValue(Statement: string[2000]): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа TObject.

4.113.32. Метод ExecuteToStrValue (Выполнить и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToStrValue(Statement: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа string[2000].

4.113.33. Метод ExecuteToTimeValue (Выполнить и вернуть значение времени)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToTimeValue(Statement: string[2000]): time;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа time.

4.113.34. Метод FloatLiteral (Вещественный литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.FloatLiteral(Value: float): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.113.35. Метод IntLiteral (Целочисленный литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.IntLiteral(Value: Integer): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.113.36. Метод ObjectLiteral (Литерал-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ObjectLiteral(Value: TObject): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.113.37. Метод QualifyDBMSName (Квалифицировать имя объекта БД)

Метод класса (статический метод) класса TStatement.
class function TStatement.QualifyDBMSName(DBMSName: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DBMSName

string[2000]

Нет

Имя объекта БД

Замечания:

Возвращает значение типа string[2000].

4.113.38. Метод SequenceLiteral (Литерал значения последовательности)

Метод класса (статический метод) класса TStatement.
class function TStatement.SequenceLiteral(SequenceName: string[64]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

SequenceName

string[64]

Да

Имя последовательности

Замечания:

Возвращает значение типа string[2000].

4.113.39. Метод StringAggregate (Агрегировать строки запроса)

Метод класса (статический метод) класса TStatement.
1class function TStatement.StringAggregate(Statement: string[2000];
2  Delimiter: string[2000]): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа clob.

4.113.40. Метод StringLiteral (Строковый литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.StringLiteral(Value: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.113.41. Метод TimeLiteral (Литерал типа "время")

Метод класса (статический метод) класса TStatement.
class function TStatement.TimeLiteral(Value: time): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.113.42. Метод ToString (Приведение литерала к строке)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ToString(Literal: string[2000]; Domain: TDomain;
2  CanUseTables: Boolean): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Literal

string[2000]

Нет

Литерал

Domain

TDomain

Нет

Домен

CanUseTables

Boolean

Да

Использовать таблицы

Замечания:

Возвращает значение типа string[2000].

4.114. Класс TStringBuilder (Шаблоны строк)

4.114.1. Свойства

Свойства класса TStringBuilder:

Имя

Тип

Обязательно

Доступ

Назначение

Template

string[2000]

Нет

Чтение/Запись

Шаблон

TemplateClob

clob

Нет

Чтение/Запись

Шаблон - большой текстовый объект

4.114.2. Конструктор Create (Конструктор шаблона строк)

Конструктор класса TStringBuilder.
1constructor TStringBuilder.Create(Template: string[2000];
2  TemplateClob: clob): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

TemplateClob

clob

Нет

Шаблон - большой текстовый объект

Замечания:

Создает новый объект класса TStringBuilder.

4.114.3. Метод Append (Добавить строку)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.Append(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа TStringBuilder.

4.114.4. Метод AppendToClob (Добавить строку к большому текстовому объекту)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.AppendToClob(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа TStringBuilder.

4.114.5. Метод Apply (Применить значение)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.Apply(Name: string[2000];
2  Value: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TStringBuilder.

4.114.6. Метод ApplyClob (Применить значение - большой текстовый объект)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.ApplyClob(Name: string[2000];
2  Value: clob): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Name

string[2000]

Нет

Имя

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TStringBuilder.

4.114.7. Метод ApplyObject (Применить свойства объекта)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.ApplyObject(Object: TObject): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

Замечания:

Возвращает значение типа TStringBuilder.

4.114.8. Метод Build (Построить строку)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.Build: string[2000];
Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.114.9. Метод BuildClob (Построить большой текстовый объект)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.BuildClob: clob;
Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

4.114.10. Метод ClearAll (Очистить все шаблоны строк)

Метод класса (статический метод) класса TStringBuilder.
class procedure TStringBuilder.ClearAll;
Метод является методом класса.

Метод не имеет параметров.

4.114.11. Метод ClobApply (Применить значение к большому текстовому объекту)

Метод класса (статический метод) класса TStringBuilder.
1class function TStringBuilder.ClobApply(Template: clob; Name: string[2000];
2  Value: string[2000]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

clob

Нет

Шаблон

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа clob.

4.114.12. Метод DebugTemplate (Отладить шаблон)

Метод класса (статический метод) класса TStringBuilder.
1class procedure TStringBuilder.DebugTemplate(Template: clob; Names: clob;
2  ApplyResult: clob);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

clob

Нет

Шаблон

Names

clob

Нет

Имена

ApplyResult

clob

Нет

Результат применения

4.114.13. Метод StrApply (Применить значение к строке)

Метод класса (статический метод) класса TStringBuilder.
1class function TStringBuilder.StrApply(Template: string[2000];
2  Name: string[2000]; Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.115. Класс TStringDomain (Строковые)

4.115.1. Свойства

Свойства класса TStringDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Длина

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимы начальные пробелы

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимы конечные пробелы

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимо дублирование пробелов

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Набор символов

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Набор символов первого символа

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Режим регистра

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Маска

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

4.115.2. Конструктор Create (Конструктор строкового домена)

Конструктор класса TStringDomain.
1constructor TStringDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Максимальная длина

AllowLeadingSpaces

Boolean

Да

Допустимы начальные пробелы

AllowTrailingSpaces

Boolean

Да

Допустимы конечные пробелы

AllowSpaceDuplication

Boolean

Да

Допустимо дублирование пробелов

CharacterSet

string[2000]

Нет

Набор символов

FirstCharacterSet

string[2000]

Нет

Набор символов первого символа

CaseMode

Boolean

Нет

Режим регистра

Mask

string[2000]

Нет

Маска

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TStringDomain.

4.115.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TStringDomain.
function TStringDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.116. Класс TStringList (Список строк)

Объекты класса не именованы.

4.116.1. Свойства

Свойства класса TStringList:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Duplicates

TDuplicates

Да

Видимо пользователю

Чтение/Запись

Дублирование

Sorted

Boolean

Да

Видимо пользователю

Чтение/Запись

Сортированный

Delimiter

string[2]

Нет

Видимо пользователю

Чтение/Запись

Разделитель

CaseSensitive

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистрозависимый

4.116.2. Конструктор Create (Конструктор списка строк)

Конструктор класса TStringList.
1constructor TStringList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TStringList.

4.116.3. Метод Add (Добавить строку в список)

Метод экземпляра класса TStringList.
function TStringList.Add(ItemString: string[2000]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

4.116.4. Метод Archive (Отправить список в архив)

Метод экземпляра класса TStringList.
procedure TStringList.Archive;
Метод не имеет параметров.

4.116.5. Метод Clear (Очистить список)

Метод экземпляра класса TStringList.
procedure TStringList.Clear;
Метод скрыт от пользователя.

Метод не имеет параметров.

4.116.6. Метод ClobField (Поле в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobField(Text: clob; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

FieldIndex

Integer

Нет

Номер поля

Замечания:

Возвращает значение типа string[2000].

4.116.7. Метод ClobFieldCount (Количество полей в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobFieldCount(Text: clob;
2  Delimiter: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Замечания:

Возвращает значение типа Integer.

4.116.8. Метод ClobFieldIndexOf (Индекс вхождения в состав большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobFieldIndexOf(Text: clob; Delimiter: string[2];
2  Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

4.116.9. Метод Delete (Удалить элемент из списка по индексу)

Метод экземпляра класса TStringList.
procedure TStringList.Delete(ItemIndex: Integer);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

4.116.10. Метод GetDelimitedText (Получить в виде разделенного текста)

Метод экземпляра класса TStringList.
function TStringList.GetDelimitedText: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.116.11. Метод GetDelimitedTextAsClob (Получить в виде разделенного большого текстового объекта)

Метод экземпляра класса TStringList.
function TStringList.GetDelimitedTextAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

4.116.12. Метод GetItem (Получить строку по индексу)

Метод экземпляра класса TStringList.
function TStringList.GetItem(ItemIndex: Integer): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

Замечания:

Возвращает значение типа string[2000].

4.116.13. Метод IndexOf (Получить индекс строки в списке)

Метод экземпляра класса TStringList.
function TStringList.IndexOf(ItemString: string[2000]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

4.116.14. Метод Insert (Вставить строку в список)

Метод экземпляра класса TStringList.
procedure TStringList.Insert(ItemIndex: Integer; ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemString

string[2000]

Нет

Строка

4.116.15. Метод Length (Длина списка)

Метод экземпляра класса TStringList.
function TStringList.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.116.16. Метод Remove (Удалить строку из списка)

Метод экземпляра класса TStringList.
procedure TStringList.Remove(ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

4.116.17. Метод SetDelimitedText (Создать элементы списка на основе разделенного текста)

Метод экземпляра класса TStringList.
procedure TStringList.SetDelimitedText(Text: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

4.116.18. Метод SetItem (Установить значение элемента)

Метод экземпляра класса TStringList.
procedure TStringList.SetItem(ItemIndex: Integer; ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemString

string[2000]

Нет

Строка

4.116.19. Метод Sort (Сортировать)

Метод экземпляра класса TStringList.
procedure TStringList.Sort;
Метод скрыт от пользователя.

Метод не имеет параметров.

4.116.20. Метод StrField (Поле в составе строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrField(Text: string[2000]; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

FieldIndex

Integer

Нет

Номер поля

Замечания:

Возвращает значение типа string[2000].

4.116.21. Метод StrFieldCount (Количество полей в составе строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrFieldCount(Text: string[2000];
2  Delimiter: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Замечания:

Возвращает значение типа Integer.

4.116.22. Метод StrFieldIndexOf (Индекс вхождения в состав строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrFieldIndexOf(Text: string[2000];
2  Delimiter: string[2]; Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

4.117. Класс TStringListItem (Элемент списка строк)

Объекты класса не именованы.

4.117.1. Свойства

Свойства класса TStringListItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

StringItem

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Строка

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

4.117.2. Конструктор Create (Конструктор элемента списка строк)

Конструктор класса TStringListItem.
1constructor TStringListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  StringItem: string[2000]; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

StringItem

string[2000]

Нет

Строка

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TStringListItem.

4.118. Класс TSystemMessage (Системные сообщения)

4.118.1. Свойства

Свойства класса TSystemMessage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

Text

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Текст

Data

blob

Нет

Видимо пользователю

Чтение/Запись

Данные

DataAsText

clob

Нет

Видимо пользователю

Только для чтения

Данные как текст

4.118.2. Метод Allow (Системные сообщения разрешены)

Метод класса (статический метод) класса TSystemMessage.
class function TSystemMessage.Allow: Boolean;
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.118.3. Метод Clear (Очистить системные сообщения)

Метод класса (статический метод) класса TSystemMessage.
1class procedure TSystemMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

4.118.4. Метод Post (Отправить системное сообщение)

Метод класса (статический метод) класса TSystemMessage.
class procedure TSystemMessage.Post(Text: string[2000]; Data: blob);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Data

blob

Нет

Данные

4.119. Класс TSystemMetadata (Системные метаданные)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.119.1. Свойства

Свойства класса TSystemMetadata:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Data

clob

Нет

Видимо пользователю

Только для чтения

Данные

CRC

string[8]

Нет

Видимо пользователю

Только для чтения

Контрольная сумма

4.119.2. Метод Change (Изменение объекта)

Метод экземпляра класса TSystemMetadata.
procedure TSystemMetadata.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

4.119.3. Метод InternalHash (Вычислить внутренний хеш)

Метод класса (статический метод) класса TSystemMetadata.
class function TSystemMetadata.InternalHash: string[128];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].

4.119.4. Метод Store (Сохранить метаданные)

Метод класса (статический метод) класса TSystemMetadata.
class procedure TSystemMetadata.Store(Data: clob; CRC: string[8]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Data

clob

Нет

Данные

CRC

string[8]

Нет

Контрольная сумма

4.120. Класс TTextIndex (Индекс текстового поиска)

4.120.1. Свойства

Свойства класса TTextIndex:

Имя

Тип

Обязательно

Доступ

Назначение

Field

TField

Да

Только для чтения

Поле

ObjectClass

TClass

Да

Только для чтения

Класс объекта

Object

TObject

Да

Только для чтения

Объект

ObjectName

string[64]

Да

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Только для чтения

Наименование объекта

ObjectParent

TObject

Нет

Только для чтения

Родитель объекта

ObjectMaster

TObject

Да

Только для чтения

Мастер объекта

TopLevelObject

TObject

Нет

Только для чтения

Объект верхнего уровня

Entry

TTextIndexEntry

Да

Только для чтения

Вхождение

Word

string[64]

Да

Только для чтения

Слово

UpperWord

string[64]

Да

Только для чтения

Слово в верхнем регистре

4.120.2. Метод CleanUp (Очистить индекс)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.CleanUp(Field: TField; Object: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Field

TField

Нет

Поле

Object

TObject

Да

Объект

4.120.3. Метод HashClob (Хэш индекса большого текстового объекта)

Метод класса (статический метод) класса TTextIndex.
class function TTextIndex.HashClob(Value: clob; IsXHTML: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

IsXHTML

Boolean

Да

Содержимое является XHTML

Замечания:

Возвращает значение типа string[2000].

4.120.4. Метод HashIndex (Хэш индекса)

Метод класса (статический метод) класса TTextIndex.
1class function TTextIndex.HashIndex(Field: TField;
2  Object: TObject): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

Замечания:

Возвращает значение типа string[2000].

4.120.5. Метод HashValue (Хэш значения)

Метод класса (статический метод) класса TTextIndex.
class function TTextIndex.HashValue(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

4.120.6. Метод IndexClob (Индексировать большой текстовый объект)

Метод класса (статический метод) класса TTextIndex.
1class procedure TTextIndex.IndexClob(DeleteExistant: Boolean; Value: clob;
2  Field: TField; Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DeleteExistant

Boolean

Да

Удалять существующие

Value

clob

Нет

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

ObjectClass

TClass

Да

Класс объекта

4.120.7. Метод IndexValue (Индексировать значение)

Метод класса (статический метод) класса TTextIndex.
1class procedure TTextIndex.IndexValue(DeleteExistant: Boolean;
2  Value: string[2000]; Field: TField; Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DeleteExistant

Boolean

Да

Удалять существующие

Value

string[2000]

Нет

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

ObjectClass

TClass

Да

Класс объекта

4.120.8. Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.LoadFromBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

4.120.9. Метод PrepareBuffer (Подготовить буфер)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.PrepareBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

4.120.10. Метод Ole-объекта Rebuild (Перестроить индекс)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TTextIndex.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AClass

TClass

Нет

Класс

AField

TField

Нет

Поле

ThreadCount

Integer

Нет

Количество потоков

4.121. Класс TTextIndexEntry (Вхождения индекса текстового поиска)

4.121.1. Свойства

Свойства класса TTextIndexEntry:

Имя

Тип

Обязательно

Доступ

Назначение

Word

string[64]

Да

Только для чтения

Слово

UpperWord

string[64]

Да

Только для чтения

Слово в верхнем регистре

4.121.2. Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndexEntry.
class procedure TTextIndexEntry.LoadFromBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

4.122. Класс TTimeDomain (Время)

4.122.1. Свойства

Свойства класса TTimeDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

HideSeconds

Boolean

Да

Видимо пользователю

Чтение/Запись

Не показывать секунды

4.122.2. Конструктор Create (Конструктор домена времени)

Конструктор класса TTimeDomain.
1constructor TTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

HideSeconds

Boolean

Да

Не показывать секунды

Замечания:

Создает новый объект класса TTimeDomain.

4.122.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TTimeDomain.
function TTimeDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.123. Класс TTypedValue (Типизированные значения)

Объекты класса не именованы.

4.123.1. Свойства

Свойства класса TTypedValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Мастер

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс мастера

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

Строковое значение

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Целое значение

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

Вещественное значение

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

Значение даты

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

Значение времени

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

Значение даты со временем

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Значение-объект

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

Логическое значение

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

Значение-большой объект

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

Значение-текст

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

Значение-внешние данные

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

Видимое значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

4.123.2. Конструктор Create (Конструктор типизированного значения)

Конструктор класса TTypedValue.
1constructor TTypedValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>): TTypedValue;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Создает новый объект класса TTypedValue.

4.123.3. Метод CompareBlob (Сравнить большие объекты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareBlob(ComparisonTypeName: string[64];
2  ValueA: blob; ValueB: blob): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

blob

Нет

Значение A

ValueB

blob

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

4.123.4. Метод CompareBoolean (Сравнить логические значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareBoolean(ComparisonTypeName: string[64];
2  ValueA: Boolean; ValueB: Boolean): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

Boolean

Да

Значение A

ValueB

Boolean

Да

Значение B

Замечания:

Возвращает значение типа Boolean.

4.123.5. Метод CompareClob (Сравнить тексты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareClob(ComparisonTypeName: string[64];
2  ValueA: clob; ValueB: clob): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

clob

Нет

Значение A

ValueB

clob

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

4.123.6. Метод CompareDate (Сравнить значения дат)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareDate(ComparisonTypeName: string[64];
2  ValueA: date; ValueB: date): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

date

Нет

Значение A

ValueB

date

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

4.123.7. Метод CompareDateTime (Сравнить значения даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareDateTime(ComparisonTypeName: string[64];
2  ValueA: datetime; ValueB: datetime): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

datetime

Нет

Значение A

ValueB

datetime

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

4.123.8. Метод CompareFloat (Сравнить вещественные значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareFloat(ComparisonTypeName: string[64];
2  ValueA: float; ValueB: float): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

float

Нет

Значение A

ValueB

float

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

4.123.9. Метод CompareInt (Сравнить целые значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareInt(ComparisonTypeName: string[64];
2  ValueA: Integer; ValueB: Integer): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

Integer

Нет

Значение A

ValueB

Integer

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

4.123.10. Метод CompareList (Сравнить со списком)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareList(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

string[2000]

Нет

Значение A

ValueB

TObject

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

4.123.11. Метод CompareObject (Сравнить значения-объекты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareObject(ComparisonTypeName: string[64];
2  ValueA: TObject; ValueB: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

TObject

Нет

Значение A

ValueB

TObject

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

4.123.12. Метод CompareStr (Сравнить строковые значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareStr(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

string[2000]

Нет

Значение A

ValueB

string[2000]

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

4.123.13. Метод CompareTime (Сравнить значения времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareTime(ComparisonTypeName: string[64];
2  ValueA: time; ValueB: time): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

time

Нет

Значение A

ValueB

time

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

4.123.14. Метод CreateBlobValue (Создать значение-большой объект)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateBlobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BlobValue: blob): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

BlobValue

blob

Нет

Значение-большой объект

Замечания:

Возвращает значение типа TTypedValue.

4.123.15. Метод CreateBoolValue (Создать логическое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateBoolValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BoolValue: Boolean): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

BoolValue

Boolean

Нет

Логическое значение

Замечания:

Возвращает значение типа TTypedValue.

4.123.16. Метод CreateClobValue (Создать значение-текст)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateClobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ClobValue: clob): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ClobValue

clob

Нет

Значение-текст

Замечания:

Возвращает значение типа TTypedValue.

4.123.17. Метод CreateDateTimeValue (Создать значение даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateDateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateTimeValue: datetime): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

DateTimeValue

datetime

Нет

Значение даты со временем

Замечания:

Возвращает значение типа TTypedValue.

4.123.18. Метод CreateDateValue (Создать значение даты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateDateValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateValue: date): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

DateValue

date

Нет

Значение даты

Замечания:

Возвращает значение типа TTypedValue.

4.123.19. Метод CreateExternalDataValue (Создать значение внешних данных)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateExternalDataValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ExternalDataValue: <external data>): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Возвращает значение типа TTypedValue.

4.123.20. Метод CreateFloatValue (Создать вещественное значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateFloatValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  FloatValue: float): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

FloatValue

float

Нет

Вещественное значение

Замечания:

Возвращает значение типа TTypedValue.

4.123.21. Метод CreateIntValue (Создать целое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateIntValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  IntValue: Integer): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

IntValue

Integer

Нет

Целое значение

Замечания:

Возвращает значение типа TTypedValue.

4.123.22. Метод CreateObjectValue (Создать значение-объект)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateObjectValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ObjectValue: TObject): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ObjectValue

TObject

Нет

Значение-объект

Замечания:

Возвращает значение типа TTypedValue.

4.123.23. Метод CreateStrValue (Создать строковое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateStrValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Строковое значение

Замечания:

Возвращает значение типа TTypedValue.

4.123.24. Метод CreateTimeValue (Создать значение времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  TimeValue: time): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

TimeValue

time

Нет

Значение времени

Замечания:

Возвращает значение типа TTypedValue.

4.123.25. Метод FindBlobValue (Поиск значения-большого объекта)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindBlobValue(Master: TObject;
2  ControlName: string[64]): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа blob.

4.123.26. Метод FindBoolValue (Поиск логического значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindBoolValue(Master: TObject;
2  ControlName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа Boolean.

4.123.27. Метод FindClobValue (Поиск значения-текста)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindClobValue(Master: TObject;
2  ControlName: string[64]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа clob.

4.123.28. Метод FindDateTimeValue (Поиск значения даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindDateTimeValue(Master: TObject;
2  ControlName: string[64]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа datetime.

4.123.29. Метод FindDateValue (Поиск значения даты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindDateValue(Master: TObject;
2  ControlName: string[64]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа date.

4.123.30. Метод FindExternalDataValue (Поиск значения внешних данных)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindExternalDataValue(Master: TObject;
2  ControlName: string[64]): <external data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа <external data>.

4.123.31. Метод FindFloatValue (Поиск вещественного значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindFloatValue(Master: TObject;
2  ControlName: string[64]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа float.

4.123.32. Метод FindIntValue (Поиск целого значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindIntValue(Master: TObject;
2  ControlName: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа Integer.

4.123.33. Метод FindObjectValue (Поиск значения-объекта)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindObjectValue(Master: TObject;
2  ControlName: string[64]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа TObject.

4.123.34. Метод FindStrValue (Поиск строкового значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindStrValue(Master: TObject;
2  ControlName: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа string[2000].

4.123.35. Метод FindTimeValue (Поиск значения времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindTimeValue(Master: TObject;
2  ControlName: string[64]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа time.

4.123.36. Метод FindValue (Поиск значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindValue(AMaster: TObject;
2  AControlName: string[64]): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AMaster

TObject

Нет

Объект-мастер

AControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа TTypedValue.

4.123.37. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер объекта

Parent

TObject

Нет

Родитель

Step

Integer

Да

Шаг

Замечания:

Возвращает значение типа Integer.

4.123.38. Метод GetVisibleValue (Видимое значение)

Метод экземпляра класса TTypedValue.
function TTypedValue.GetVisibleValue: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4.123.39. Метод ReplaceWildcards (Заменить подстановочные символы)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.ReplaceWildcards(Value: string[2000];
2  Escape: string[2]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Escape

string[2]

Нет

Экранирующий символ

Замечания:

Возвращает значение типа string[2000].

4.123.40. Метод SetValue (Установить значение)

Метод экземпляра класса TTypedValue.
1procedure TTypedValue.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>);
Параметры:

Имя

Тип

Обязательно

Значение

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

4.124. Класс TTypedValueButton (Кнопки на форме редактирования значений)

4.124.1. Свойства

Свойства класса TTypedValueButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomButton

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

TypedValue

TTypedValue

Нет

Видимо пользователю

Чтение/Запись

Связанное типизированное значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

4.124.2. Конструктор Create (Конструктор кнопки формы редактирования значений)

Конструктор класса TTypedValueButton.
1constructor TTypedValueButton.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Group: string[128];
4  Tab: string[128]; Script: clob; Scope: TScope; OutOfTabs: Boolean;
5  TypedValue: TTypedValue): TObject;
Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TCustomButton.Create

Group

string[128]

Нет

Tab

string[128]

Нет

Script

clob

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

TypedValue

TTypedValue

Нет

Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueButton.

4.125. Класс TTypedValueView (Представления на форме редактирования значений)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

4.125.1. Свойства

Свойства класса TTypedValueView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TFormView

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Layout

TFormViewLayout

Да

Видимо пользователю

Чтение/Запись

ChildrenOnTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

ExplicitQuery

Boolean

Да

Видимо пользователю

Чтение/Запись

SpacePercentage

Integer

Нет

Видимо пользователю

Чтение/Запись

TypedValue

TTypedValue

Нет

Видимо пользователю

Чтение/Запись

Связанное типизированное значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор связанного типизированного значения

ViewName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

4.125.2. Конструктор Create (Конструктор представления на форме редактирования значений)

Конструктор класса TTypedValueView.
1constructor TTypedValueView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout; ExplicitQuery: Boolean;
6  TypedValue: TTypedValue): TObject;
Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Унаследовано от TFormView.Create

ChildrenMinimized

Boolean

Да

ChildrenOnTabs

Boolean

Да

MasterProperty

TProperty

Нет

DetailProperty

TClassMember

Нет

Position

Integer

Да

SpacePercentage

Integer

Нет

Layout

TFormViewLayout

Да

ExplicitQuery

Boolean

Да

TypedValue

TTypedValue

Нет

Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueView.

4.126. Класс TUser (Пользователи)

4.126.1. Свойства

Свойства класса TUser:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущим

AccessMode

TUserAccessMode

Да

Видимо пользователю

Чтение/Запись

Режим доступа

CanRecieveMessages

Boolean

Да

Видимо пользователю

Чтение/Запись

Получает сообщения

4.126.2. Конструктор Create (Конструктор пользователя)

Конструктор класса TUser.
1constructor TUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CanRecieveMessages: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

CanRecieveMessages

Boolean

Да

Получает сообщения

Замечания:

Создает новый объект класса TUser.

4.126.3. Метод EffectiveMemberOf (Является эффективным членом)

Метод экземпляра класса TUser.
function TUser.EffectiveMemberOf(Role: TRole): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Role

TRole

Да

Роль

Замечания:

Возвращает значение типа Boolean.

4.126.4. Метод GetCurrentUser (Получить текущего пользователя)

Метод класса (статический метод) класса TUser.
class function TUser.GetCurrentUser: TUser;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TUser.

4.126.5. Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TUser.
function TUser.GetIsCurrent: Boolean;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.127. Класс TUserNotification (Уведомления)

4.127.1. Свойства

Свойства класса TUserNotification:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Type

TNotificationType

Да

Видимо пользователю

Чтение/Запись

Тип

Text

clob

Нет

Видимо пользователю

Чтение/Запись

Текст

Active

Boolean

Да

Видимо пользователю

Чтение/Запись

Активно

ShowFrom

datetime

Нет

Видимо пользователю

Чтение/Запись

Показывать с

ShowTo

datetime

Нет

Видимо пользователю

Чтение/Запись

Показывать по

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

Выделено

ShowNeeded

Boolean

Да

Скрыто от пользователя

Только для чтения

Необходимо показывать

4.127.2. Конструктор Create (Конструктор уведомления)

Конструктор класса TUserNotification.
1constructor TUserNotification.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Type: TNotificationType; Text: clob;
4  Active: Boolean; ShowFrom: datetime; ShowTo: datetime): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Type

TNotificationType

Да

Тип

Text

clob

Нет

Текст

Active

Boolean

Да

Активно

ShowFrom

datetime

Нет

Показывать с

ShowTo

datetime

Нет

Показывать по

Замечания:

Создает новый объект класса TUserNotification.

4.127.3. Метод GetShowNeeded (Необходимо показывать)

Метод экземпляра класса TUserNotification.
function TUserNotification.GetShowNeeded: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.127.4. Метод Preview (Предпросмотр)

Метод экземпляра класса TUserNotification.
procedure TUserNotification.Preview;
Метод не имеет параметров.

4.127.5. Метод Shown (Отметить как показанное)

Метод экземпляра класса TUserNotification.
procedure TUserNotification.Shown;
Метод скрыт от пользователя.

Метод не имеет параметров.

4.128. Класс TUserNotificationAddressee (Адресаты уведомлений)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.128.1. Свойства

Свойства класса TUserNotificationAddressee:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

4.128.2. Конструктор Create (Конструктор адресата уведомления)

Конструктор класса TUserNotificationAddressee.
1constructor TUserNotificationAddressee.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TUserNotificationAddressee.

4.129. Класс TUserNotificationShown (Показы уведомлений)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.129.1. Свойства

Свойства класса TUserNotificationShown:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TUserNotification

Да

Скрыто от пользователя

Только для чтения

Уведомление

Type

TNotificationType

Да

Видимо пользователю

Только для чтения

Тип уведомления

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

4.129.2. Конструктор Create (Конструктор показа уведомления)

Конструктор класса TUserNotificationShown.
1constructor TUserNotificationShown.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TUserNotificationShown.

4.130. Класс TView (Представления)

4.130.1. Свойства

Свойства класса TView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomView

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

IsGrouped

Boolean

Да

Видимо пользователю

Только для чтения

Сгруппировано

LinesPerRow

Integer

Да

Видимо пользователю

Чтение/Запись

Строк на ячейку

Collapsed

Boolean

Да

Видимо пользователю

Чтение/Запись

Свернуть

HasPresentations

Boolean

Да

Видимо пользователю

Только для чтения

Имеет виды

IsSorted

Boolean

Да

Видимо пользователю

Только для чтения

Отсортировано

IsAggregated

Boolean

Да

Видимо пользователю

Только для чтения

Агрегировано

4.130.2. Конструктор Create (Конструктор представления)

Конструктор класса TView.
1constructor TView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  Collapsed: Boolean): TObject;
Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Унаследовано от TCustomView.Create

ColorProperty

TProperty

Нет

BoldProperty

TProperty

Нет

Skimpy

Boolean

Да

PreCompiled

Boolean

Да

PreOpenRoutine

TRoutine

Нет

Collapsed

Boolean

Да

Свернуто

Замечания:

Создает новый объект класса TView.

4.130.3. Метод BuildDefaultColumns (Создать колонки по умолчанию)

Метод экземпляра класса TView.
1procedure TView.BuildDefaultColumns(AddNameColumn: Boolean;
2  AddDescColumn: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

AddNameColumn

Boolean

Да

Создать колонку имени

AddDescColumn

Boolean

Да

Создать колонку наименования

4.130.4. Метод GetHasPresentations (Имеет виды)

Метод экземпляра класса TView.
function TView.GetHasPresentations: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.130.5. Метод GetIsAggregated (Агрегировано)

Метод экземпляра класса TView.
function TView.GetIsAggregated: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.130.6. Метод GetIsGrouped (Сгруппировано)

Метод экземпляра класса TView.
function TView.GetIsGrouped: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.130.7. Метод GetIsSorted (Отсортировано)

Метод экземпляра класса TView.
function TView.GetIsSorted: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.131. Класс TViewAction (Действие-представление)

Объекты класса образуют иерархию.

4.131.1. Свойства

Свойства класса TViewAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

4.131.2. Конструктор Create (Конструктор действия-представления)

Конструктор класса TViewAction.
1constructor TViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  View: TCustomView; MasterProperty: TProperty;
5  DetailProperty: TClassMember): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

View

TCustomView

Да

Представление

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

Замечания:

Создает новый объект класса TViewAction.

4.132. Класс TViewColumn (Колонки представлений)

4.132.1. Свойства

Свойства класса TViewColumn:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Property

TProperty

Да

Видимо пользователю

Чтение/Запись

Свойство

PropertyDomain

TDomain

Да

Видимо пользователю

Только для чтения

Домен

PropertyDomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

PropertyReadMember

TClassMember

Нет

Видимо пользователю

Только для чтения

Член класса для чтения

PropertyReadMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для чтения

PropertyWriteMember

TClassMember

Нет

Видимо пользователю

Только для чтения

Член класса для записи

PropertyName

string[64]

Да

Видимо пользователю

Только для чтения

Имя свойства

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Grouped

Boolean

Да

Видимо пользователю

Чтение/Запись

Группировать

Aggregate

TAggregateKind

Нет

Видимо пользователю

Чтение/Запись

Агрегат

SortDirection

TSortDirection

Да

Видимо пользователю

Чтение/Запись

Направление сортировки

Width

Integer

Да

Видимо пользователю

Чтение/Запись

Ширина

Filter

string[128]

Нет

Видимо пользователю

Чтение/Запись

Фильтр

ForceReadOnly

Boolean

Да

Видимо пользователю

Чтение/Запись

Только для чтения

Fixed

Boolean

Да

Видимо пользователю

Чтение/Запись

Зафиксирована

IsFilterHidden

Boolean

Да

Видимо пользователю

Чтение/Запись

Фильтр скрыт

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Bold

Boolean

Да

Видимо пользователю

Чтение/Запись

Выделить шрифтом

DirectAction

TAction

Нет

Видимо пользователю

Чтение/Запись

Непосредственное действие

IsSpecificalyNamed

Boolean

Да

Видимо пользователю

Только для чтения

Специфическое имя

4.132.2. Конструктор Create (Конструктор колонки представления)

Конструктор класса TViewColumn.
1constructor TViewColumn.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Property: TProperty; Position: Integer; Grouped: Boolean;
4  Aggregate: TAggregateKind; SortDirection: TSortDirection; Fixed: Boolean;
5  Category: string[128]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Property

TProperty

Да

Свойство

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TViewColumn.

4.132.3. Метод Change (Изменение объекта)

Метод экземпляра класса TViewColumn.
procedure TViewColumn.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

4.132.4. Метод CreateByNames (Добавить по списку свойств)

Метод класса (статический метод) класса TViewColumn.
1class procedure TViewColumn.CreateByNames(Master: TCustomView;
2  Names: string[2000]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TCustomView

Да

Мастер

Names

string[2000]

Нет

Имена свойств

4.132.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TViewColumn.
class function TViewColumn.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

4.132.6. Метод NameAfterProperty (Дать имя свойства)

Метод экземпляра класса TViewColumn.
procedure TViewColumn.NameAfterProperty;
Метод скрыт от пользователя.

Метод не имеет параметров.

4.133. Класс TViewCondition (Условия отбора)

Объекты класса образуют иерархию.

4.133.1. Свойства

Свойства класса TViewCondition:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

LinkedClass

TClass

Нет

Видимо пользователю

Чтение/Запись

Присоединяемый класс

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

LinkedOption

TOption

Нет

Видимо пользователю

Чтение/Запись

Присоединенная настройка

LinkedOptionName

string[64]

Да

Видимо пользователю

Только для чтения

Имя присоединяемой настройки

LinkedOptionProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство присоединенной настройки

Expression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение условия

Negation

Boolean

Да

Видимо пользователю

Чтение/Запись

Отрицание

LinkNonRequired

Boolean

Да

Видимо пользователю

Чтение/Запись

Присоединять необязательное свойство

LinkedProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Присоединенный профиль

4.133.2. Конструктор Create (Конструктор условия отбора)

Конструктор класса TViewCondition.
1constructor TViewCondition.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  LinkedClass: TClass; MasterProperty: TProperty; DetailProperty: TClassMember;
4  LinkedOption: TOption; LinkedOptionProperty: TClassMember; Expression: clob;
5  Negation: Boolean; LinkNonRequired: Boolean; LinkedProfile: TProfile): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

LinkedClass

TClass

Нет

Присоединяемый класс

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

LinkedOption

TOption

Нет

Присоединенная настройка

LinkedOptionProperty

TClassMember

Нет

Свойство присоединенной настройки

Expression

clob

Нет

Выражение условия отбора

Negation

Boolean

Да

Отрицание

LinkNonRequired

Boolean

Да

Присоединять необязательное свойство

LinkedProfile

TProfile

Нет

Присоединенный профиль

Замечания:

Создает новый объект класса TViewCondition.

4.134. Класс TViewPresentation (Виды)

Имена объектов класса генерируются.

4.134.1. Свойства

Свойства класса TViewPresentation:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления минимизированы

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

Использовать по умолчанию

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

4.134.2. Конструктор Create (Конструктор вида)

Конструктор класса TViewPresentation.
1constructor TViewPresentation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer;
4  ChildrenMinimized: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

Замечания:

Создает новый объект класса TViewPresentation.

4.134.3. Метод GetIsAccessible (Проверка доступности)

Метод экземпляра класса TViewPresentation.
function TViewPresentation.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.134.4. Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentation.
1class function TViewPresentation.Save(Master: TObject;
2  Description: string[128]; ChildrenMinimized: Boolean): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Да

Мастер

Description

string[128]

Да

Наименование

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

Замечания:

Возвращает значение типа TObject.

4.135. Класс TViewPresentationAccess (Доступ к видам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.135.1. Конструктор Create (Конструктор доступа к виду)

Конструктор класса TViewPresentationAccess.
1constructor TViewPresentationAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TViewPresentationAccess.

4.136. Класс TViewPresentationColumn (Колонки вида)

Имена объектов класса генерируются.

4.136.1. Свойства

Свойства класса TViewPresentationColumn:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Column

TViewColumn

Да

Видимо пользователю

Только для чтения

Колонка представления

Presentation

TViewPresentation

Да

Скрыто от пользователя

Только для чтения

Вид

View

TObject

Да

Скрыто от пользователя

Только для чтения

Представление

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Grouped

Boolean

Да

Видимо пользователю

Чтение/Запись

Сгруппирована

Aggregate

TAggregateKind

Нет

Видимо пользователю

Чтение/Запись

Агрегат

SortDirection

TSortDirection

Да

Видимо пользователю

Чтение/Запись

Направление сортировки

Width

Integer

Да

Видимо пользователю

Чтение/Запись

Ширина

Filter

string[128]

Нет

Видимо пользователю

Чтение/Запись

Фильтр

Fixed

Boolean

Да

Видимо пользователю

Чтение/Запись

Зафиксирована

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

4.136.2. Конструктор Create (Конструктор колонки вида)

Конструктор класса TViewPresentationColumn.
1constructor TViewPresentationColumn.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Column: TViewColumn; Position: Integer;
4  Grouped: Boolean; Aggregate: TAggregateKind; SortDirection: TSortDirection;
5  Width: Integer; Filter: string[128]; Fixed: Boolean;
6  Category: string[128]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Column

TViewColumn

Да

Колонка

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Width

Integer

Да

Ширина

Filter

string[128]

Нет

Фильтр

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TViewPresentationColumn.

4.136.3. Метод AddColumns (Создать колонки)

Метод класса (статический метод) класса TViewPresentationColumn.
class procedure TViewPresentationColumn.AddColumns(Master: TViewPresentation);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TViewPresentation

Да

Мастер

4.136.4. Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentationColumn.
1class function TViewPresentationColumn.Save(Master: TViewPresentation;
2  Column: TViewColumn; Position: Integer; Grouped: Boolean;
3  Aggregate: TAggregateKind; SortDirection: TSortDirection; Width: Integer;
4  Filter: string[128]; Fixed: Boolean; Category: string[128]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TViewPresentation

Да

Мастер

Column

TViewColumn

Да

Колонка

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Width

Integer

Да

Ширина

Filter

string[128]

Нет

Фильтр

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Возвращает значение типа TObject.

4.137. Класс TVisualGroup (Визуальные группы)

Объекты класса образуют иерархию.

4.137.1. Свойства

Свойства класса TVisualGroup:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение

IsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Доступна

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

Collapsed

Boolean

Да

Видимо пользователю

Чтение/Запись

Свернута

4.137.2. Конструктор Create (Конструктор визуальной группы)

Конструктор класса TVisualGroup.
1constructor TVisualGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Image: blob; Position: Integer; Scope: TScope; Collapsed: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Image

blob

Нет

Изображение

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

Collapsed

Boolean

Да

Свернута

Замечания:

Создает новый объект класса TVisualGroup.

4.137.3. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TVisualGroup.
function TVisualGroup.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4.137.4. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroup.
class function TVisualGroup.GetNextPos(Parent: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Integer.

4.138. Класс TVisualGroupAccess (Доступ к визуальным группам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

4.138.1. Конструктор Create (Конструктор доступа к визуальной группе)

Конструктор класса TVisualGroupAccess.
1constructor TVisualGroupAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TVisualGroup;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TVisualGroup

Да

Группа доступа

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TVisualGroupAccess.

4.139. Класс TVisualGroupForm (Форма визуальной группы)

4.139.1. Свойства

Свойства класса TVisualGroupForm:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TVisualGroupItem

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Form

TForm

Да

Видимо пользователю

Чтение/Запись

Форма

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение

4.139.2. Конструктор Create (Конструктор формы визуальной группы)

Конструктор класса TVisualGroupForm.
1constructor TVisualGroupForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob; Form: TForm): TObject;
Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TVisualGroupItem.Create

Comment

clob

Нет

Form

TForm

Да

Форма

Замечания:

Создает новый объект класса TVisualGroupForm.

4.140. Класс TVisualGroupItem (Элемент визуальной группы)

4.140.1. Свойства

Свойства класса TVisualGroupItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Комментарий

4.140.2. Конструктор Create (Конструктор элемента визуальной группы)

Конструктор класса TVisualGroupItem.
1constructor TVisualGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Comment

clob

Нет

Комментарий

Замечания:

Создает новый объект класса TVisualGroupItem.

4.140.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroupItem.
class function TVisualGroupItem.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

4.141. Класс TVisualGroupRoutine (Подпрограмма визуальной группы)

4.141.1. Свойства

Свойства класса TVisualGroupRoutine:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TVisualGroupItem

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

4.141.2. Конструктор Create (Конструктор подпрограммы визуальной группы)

Конструктор класса TVisualGroupRoutine.
1constructor TVisualGroupRoutine.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Comment: clob;
4  Routine: TRoutine): TObject;
Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TVisualGroupItem.Create

Comment

clob

Нет

Routine

TRoutine

Да

Подпрограмма

Замечания:

Создает новый объект класса TVisualGroupRoutine.

4.142. Класс TWordAsyncTask (Задачи отложенного выполнения отчетов Word)

Объекты класса не именованы.

4.142.1. Свойства

Свойства класса TWordAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TAsyncTask

Created

datetime

Да

Видимо пользователю

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TAsyncTask

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Duration

time

Нет

Видимо пользователю

Только для чтения

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Format

TWordOutputFormat

Да

Видимо пользователю

Чтение/Запись

Формат

4.142.2. Конструктор Create (Конструктор задачи отложенного выполнения отчетов Word)

Конструктор класса TWordAsyncTask.
1constructor TWordAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TWordOutputFormat): TObject;
Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Унаследовано от TAsyncTask.Create

Object

TObject

Нет

FormView

TFormView

Нет

Handler

TAsyncHandler

Да

Language

TLanguage

Да

Format

TWordOutputFormat

Да

Формат

Замечания:

Создает новый объект класса TWordAsyncTask.

4.143. Класс TWordTemplate (Шаблоны отчетов Word)

4.143.1. Свойства

Свойства класса TWordTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

MacroName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя макроса

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

4.143.2. Конструктор Create (Конструктор шаблона отчета Word)

Конструктор класса TWordTemplate.
1constructor TWordTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  MacroName: string[128]; IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

blob

Нет

Данные шаблона

MacroName

string[128]

Нет

Имя макроса

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TWordTemplate.

4.143.3. Метод Ole-объекта CheckWordTemplate (Проверить шаблон отчетов Word)

Метод Ole-объекта класса TWordTemplate.

Метод Ole-объекта не имеет параметров.

4.144. Класс TXSLTTemplate (Шаблоны отчетов XSLT)

4.144.1. Свойства

Свойства класса TXSLTTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

clob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

FunctionName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя функции

4.144.2. Конструктор Create (Конструктор шаблона отчета XSLT)

Конструктор класса TXSLTTemplate.
1constructor TXSLTTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: clob;
6  FunctionName: string[128]): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

clob

Нет

Данные шаблона

FunctionName

string[128]

Нет

Имя вызываемой функции

Замечания:

Создает новый объект класса TXSLTTemplate.

4.144.3. Метод Ole-объекта CheckXSLTTemplate (Проверить шаблон отчетов XSLT)

Метод Ole-объекта класса TXSLTTemplate.

Метод Ole-объекта не имеет параметров.

5. Терминология

Интеграция - комплекс работ по настройке механизмов взаимодействия между различными учетными системами, которые функционируют независимо друг от друга в одной организационной структуре ("лоскутная" автоматизация).

Реплика - копия объекта (например, базы данных), обновляемая автоматически при обновлении оригинала.

Модальная форма - подчиененная форма, вызываемая из процедуры, накладывающая ограничения на использование процедуры пока модальная форма не будет закрыта.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс ITableInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс ITableInfo

Интерфейс INamedItemInfo

01type
02  ITableInfo = interface(INamedItemInfo)
03    ['{3FC1998A-9031-4936-82B5-8CAA2219085E}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_Field(Index: Integer): IFieldInfo; safecall;
06    function Get_PrimaryKey: IFieldInfo; safecall;
07    function Get_Uplink: IFieldInfo; safecall;
08    function Get_Parent: ITableInfo; safecall;
09    function Get_RootAvailable: WordBool; safecall;
10    property FieldCount: Integer read Get_FieldCount;
11    property Field[Index: Integer]: IFieldInfo read Get_Field;
12    property PrimaryKey: IFieldInfo read Get_PrimaryKey;
13    property Uplink: IFieldInfo read Get_Uplink;
14    property Parent: ITableInfo read Get_Parent;
15    property RootAvailable: WordBool read Get_RootAvailable;
16  end;

1. Свойства

Свойства интерфейса ITableInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения |
FieldCount | Integer | Только для чтения |
Parent | ITableInfo | Только для чтения |
PrimaryKey | IFieldInfo | Только для чтения |
RootAvailable | WordBool | Только для чтения |
Uplink | IFieldInfo | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Класс TProfileUser (Пользователи профиля) (раздел целиком) (22.10.2024) (одним файлом)
Класс TProfileUser (Пользователи профиля)

Класс TTypedValue (Типизированные значения)Класс TObject (Объекты)Класс TProfile (Профили)

Объекты класса не именованы.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TProfileUser:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Нет | Скрыто от пользователя | Только для чтения | Унаследовано от TTypedValue
MasterClass | TClass | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TTypedValue
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
StrValue | string[2000] | Нет | Скрыто от пользователя | Чтение/Запись
IntValue | Integer | Нет | Скрыто от пользователя | Чтение/Запись
FloatValue | float | Нет | Скрыто от пользователя | Чтение/Запись
DateValue | date | Нет | Скрыто от пользователя | Чтение/Запись
TimeValue | time | Нет | Скрыто от пользователя | Чтение/Запись
DateTimeValue | datetime | Нет | Скрыто от пользователя | Чтение/Запись
ObjectValue | TObject | Нет | Скрыто от пользователя | Чтение/Запись
BoolValue | Boolean | Нет | Скрыто от пользователя | Чтение/Запись
BlobValue | blob | Нет | Видимо пользователю | Чтение/Запись
ClobValue | clob | Нет | Видимо пользователю | Чтение/Запись
ExternalDataValue | <external data> | Нет | Видимо пользователю | Чтение/Запись
VisibleValue | string[2000] | Нет | Видимо пользователю | Только для чтения
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
UserIsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Пользователь является текущим
Profile | TProfile | Да | Скрыто от пользователя | Только для чтения | Профиль
Domain | TDomain | Да | Скрыто от пользователя | Только для чтения | Домен
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TTypedValue
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения

2. Конструктор Create (Конструктор пользовательского профиля)

Конструктор класса TProfileUser.

1constructor TProfileUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TProfile; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;

Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TProfile | Да | Профиль
Accessor | TSecurityAccount | Нет | Унаследовано от TObject.Create
Domain | TDomain | Да | Домен
Position | Integer | Да | Позиция
Group | string[128] | Нет | Группа
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
StrValue | string[2000] | Нет | Унаследовано от TTypedValue.Create
IntValue | Integer | Нет
FloatValue | float | Нет
DateValue | date | Нет
TimeValue | time | Нет
DateTimeValue | datetime | Нет
ObjectValue | TObject | Нет
BoolValue | Boolean | Нет
BlobValue | blob | Нет
ClobValue | clob | Нет
ExternalDataValue | <external data> | Нет
User | TUser | Да | Пользователь

Замечания:

Создает новый объект класса TProfileUser.


Мельница данных ((раздел целиком))

Мельница данных- Класс TSequence (Последовательности) (раздел целиком) (22.10.2024) (одним файлом)
Класс TSequence (Последовательности)

Диаграмма Класс TObject (Объекты)

1. Свойства

Свойства класса TSequence:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Value | string[20] | Да | Видимо пользователю | Чтение/Запись | Текущее значение
Cache | Integer | Нет | Видимо пользователю | Чтение/Запись | Кэш

2. Конструктор Create (Конструктор последовательности)

Конструктор класса TSequence.

1constructor TSequence.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TSequence.

3. Метод GetCache (Получить кеш)

Метод экземпляра класса TSequence.

function TSequence.GetCache: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4. Метод GetValue (Получить текущее значение)

Метод экземпляра класса TSequence.

function TSequence.GetValue: string[20];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].

5. Метод Promote (Получить следующее значение)

Метод экземпляра класса TSequence.

function TSequence.Promote: string[20];

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].

6. Метод SetCache (Установить кеш)

Метод экземпляра класса TSequence.

procedure TSequence.SetCache(Value: Integer);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Integer | Нет | Значение

7. Метод SetValue (Установить текущее значение)

Метод экземпляра класса TSequence.

procedure TSequence.SetValue(Value: string[20]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[20] | Да | Значение


Мельница данных ((раздел целиком))

Мельница данных- Класс TVisualGroupForm (Форма визуальной группы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TVisualGroupForm (Форма визуальной группы)

Диаграмма Класс TVisualGroupItem (Элемент визуальной группы)Класс TObject (Объекты)Класс TVisualGroup (Визуальные группы)

1. Свойства

Свойства класса TVisualGroupForm:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TVisualGroupItem
Comment | clob | Нет | Видимо пользователю | Чтение/Запись
Form | TForm | Да | Видимо пользователю | Чтение/Запись | Форма
Image | blob | Нет | Видимо пользователю | Чтение/Запись | Изображение

2. Конструктор Create (Конструктор формы визуальной группы)

Конструктор класса TVisualGroupForm.

1constructor TVisualGroupForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob; Form: TForm): TObject;

Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TVisualGroupItem.Create
Comment | clob | Нет
Form | TForm | Да | Форма

Замечания:

Создает новый объект класса TVisualGroupForm.


Мельница данных ((раздел целиком))

Мельница данных- Класс TDateDomain (Даты) (раздел целиком) (22.10.2024) (одним файлом)
Класс TDateDomain (Даты)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

1. Конструктор Create (Конструктор домена даты)

Конструктор класса TDateDomain.

1constructor TDateDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create

Замечания:

Создает новый объект класса TDateDomain.

2. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateDomain.

function TDateDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Класс TLanguage (Языки) (раздел целиком) (22.10.2024) (одним файлом)
Класс TLanguage (Языки)

Диаграмма Класс TObject (Объекты)

1. Свойства

Свойства класса TLanguage:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
DatabaseLanguage | Boolean | Да | Видимо пользователю | Только для чтения | По умолчанию
IsCurrent | Boolean | Да | Видимо пользователю | Чтение/Запись | Является текущим

2. Конструктор Create (Конструктор языка)

Конструктор класса TLanguage.

1constructor TLanguage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TLanguage.

3. Метод GetCurrentLanguage (Получить текущий язык)

Метод класса (статический метод) класса TLanguage.

class function TLanguage.GetCurrentLanguage: TLanguage;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TLanguage.

4. Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TLanguage.

function TLanguage.GetIsCurrent: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5. Метод SetIsCurrent (Установить язык как текущий)

Метод экземпляра класса TLanguage.

procedure TLanguage.SetIsCurrent(Value: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение

6. Метод Ole-объекта SaveResourceFile (Сохранить файл ресурсов)

Метод Ole-объекта класса TLanguage.

Параметры:

Имя | Тип | Обязательно | Значение
XliffFileName | string[255] | Да | Файл ресурсов


Мельница данных ((раздел целиком))

Мельница данных- Класс TProfileStatistics (Статистика профиля) (раздел целиком) (22.10.2024) (одним файлом)
Класс TProfileStatistics (Статистика профиля)

Диаграмма Класс TProfileMethod (Методы профиля)

1. Свойства

Свойства класса TProfileStatistics:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Method | TProfileMethod | Да | Скрыто от пользователя | Только для чтения | Метод профилировщика
CalledMethod | TMethod | Нет | Видимо пользователю | Только для чтения | Вызываемый метод
CalledMethodClass | TObject | Да | Видимо пользователю | Только для чтения | Класс
Calls | Integer | Нет | Видимо пользователю | Только для чтения | Количество вызовов
Class | TClass | Нет | Видимо пользователю | Только для чтения | Класс
Inserts | Integer | Нет | Видимо пользователю | Только для чтения | Количество добавлений
Updates | Integer | Нет | Видимо пользователю | Только для чтения | Количество изменений
Deletes | Integer | Нет | Видимо пользователю | Только для чтения | Количество удалений
Type | string[128] | Нет | Видимо пользователю | Только для чтения | Тип


Мельница данных ((раздел целиком))

Мельница данных- Класс TViewColumn (Колонки представлений) (раздел целиком) (22.10.2024) (одним файлом)
Класс TViewColumn (Колонки представлений)

Диаграмма Класс TObject (Объекты)Класс TView (Представления)

1. Свойства

Свойства класса TViewColumn:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Property | TProperty | Да | Видимо пользователю | Чтение/Запись | Свойство
PropertyDomain | TDomain | Да | Видимо пользователю | Только для чтения | Домен
PropertyDomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
PropertyReadMember | TClassMember | Нет | Видимо пользователю | Только для чтения | Член класса для чтения
PropertyReadMemberClass | TClass | Да | Видимо пользователю | Только для чтения | Класс члена класса для чтения
PropertyWriteMember | TClassMember | Нет | Видимо пользователю | Только для чтения | Член класса для записи
PropertyName | string[64] | Да | Видимо пользователю | Только для чтения | Имя свойства
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Grouped | Boolean | Да | Видимо пользователю | Чтение/Запись | Группировать
Aggregate | TAggregateKind | Нет | Видимо пользователю | Чтение/Запись | Агрегат
SortDirection | TSortDirection | Да | Видимо пользователю | Чтение/Запись | Направление сортировки
Width | Integer | Да | Видимо пользователю | Чтение/Запись | Ширина
Filter | string[128] | Нет | Видимо пользователю | Чтение/Запись | Фильтр
ForceReadOnly | Boolean | Да | Видимо пользователю | Чтение/Запись | Только для чтения
Fixed | Boolean | Да | Видимо пользователю | Чтение/Запись | Зафиксирована
IsFilterHidden | Boolean | Да | Видимо пользователю | Чтение/Запись | Фильтр скрыт
Category | string[128] | Нет | Видимо пользователю | Чтение/Запись | Категория
Bold | Boolean | Да | Видимо пользователю | Чтение/Запись | Выделить шрифтом
DirectAction | TAction | Нет | Видимо пользователю | Чтение/Запись | Непосредственное действие
IsSpecificalyNamed | Boolean | Да | Видимо пользователю | Только для чтения | Специфическое имя

2. Конструктор Create (Конструктор колонки представления)

Конструктор класса TViewColumn.

1constructor TViewColumn.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Property: TProperty; Position: Integer; Grouped: Boolean;
4  Aggregate: TAggregateKind; SortDirection: TSortDirection; Fixed: Boolean;
5  Category: string[128]): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Property | TProperty | Да | Свойство
Position | Integer | Да | Позиция
Grouped | Boolean | Да | Группировать
Aggregate | TAggregateKind | Нет | Агрегат
SortDirection | TSortDirection | Да | Направление сортировки
Fixed | Boolean | Да | Зафиксирована
Category | string[128] | Нет | Категория

Замечания:

Создает новый объект класса TViewColumn.

3. Метод Change (Изменение объекта)

Метод экземпляра класса TViewColumn.

procedure TViewColumn.Change(Action: TChangeAction);

Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Унаследовано от TObject.Change

4. Метод CreateByNames (Добавить по списку свойств)

Метод класса (статический метод) класса TViewColumn.

1class procedure TViewColumn.CreateByNames(Master: TCustomView;
2  Names: string[2000]);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TCustomView | Да | Мастер
Names | string[2000] | Нет | Имена свойств

5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TViewColumn.

class function TViewColumn.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.

6. Метод NameAfterProperty (Дать имя свойства)

Метод экземпляра класса TViewColumn.

procedure TViewColumn.NameAfterProperty;

Метод скрыт от пользователя.

Метод не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Функция execute (раздел целиком) (22.10.2024) (одним файлом)
Функция execute

Функция execute позволяет вызывать методы, доступные для вызова через обработчик сервера приложений, получать результат выполнения методов.

Допустимо использовать любые расширения, в том числе не указывать расширение. Расширение повлияет на формат возвращаемого результата следующим образом:

  • .xml - для получения результата выполнения в формате xml
  • .js/.json - для получения результата выполнения в формате JSON
  • пустое расширение - результат выполнения будет возвращен в формате xml
  • другие расширения - имеет смысл использовать в случаях, когда результатом выполнения метода является "большой объект" (blob, clob) и его тип известен; это позволит получить результат в виде файла или структуры данных определенного типа (.xslt,.pdf, форматы изображений и т.п.)
    если результат выполнения не удастся привести к формату, заданному расширением, результат будет возвращен в формате xml

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый метод и значения его параметров. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, метод которого будет вызываться
  • "method" (обязательный) - имя метода, который будет вызываться

Корневой элемент xml-документа может содержать список узлов row, каждый из которых определяет набор параметров для вызова метода. Таким образом, при помощи одного вызова функции (одним обращением к url) можно вызывать один и тот же метод для набора объектов.

Принципы передачи параметров для вызова метода, включая использование параметров типа "большой объект", описаны в статье Принципы передачи параметров функциям RESTful-service.

Для вызова методов экземпляра необходимо указывать значение неявного параметра с именем "ID". Значением этого параметра должен быть идентификатор объекта, для которого вызывается метод.

01  <execute class="TPerson" method="GetContactList">
02    <row>
03      <ID>931669</ID>
04      <ContactType>63478</ContactType>
05    </row>
06    <row>
07      <ID>76443</ID>
08      <ContactType>63478</ContactType>
09    </row>
10  </execute>

Получить результат вызовов метода GetContactList класса TPerson для объектов с идентификаторами (ID), равными 931669 и 76443 и со значением параметра ContactType, равным 63478.

Пример ответа:

1  <data eof="1">
2    <row>
3      <Result>8-903-73-210-73</Result>
4    </row>
5    <row>
6      <Result>8-916-862-27-77; 8-916-862-2777</Result>
7    </row>
8  </data>

Если возвращаемый результат имеет домен класса "большой объект" (clob, clob, "внешний файл"), то возвращаемое значение может быто подвергнуто пост-обработке. Подробнее этот случай описан в разделе: Особенности передачи возвращаемых значений типа "большой объект"

1. Принципы передачи параметров функциям RESTful-service

При вызове функций RESTful-service стандартного обмена применяются следующие принципы передачи и связывания параметров:

  1. Параметры связываются по их именам. Порядок указания параметров при вызове функции не существенен.
  2. Если вызываемый метод или отчет является "методом класса", то дополнительно должен быть передан параметр "ID" со значением идентификатора объекта, для которого вызывается метод или отчет.
  3. Если параметр имеет clob-домен подтипов "btHTML" (HTML-документ), "btXHTML" (XHTML-документ), то содержимое такого документа будет "обезврежено" (будут удалены ссылки, скрипты и т.п.)
  4. Если вызываемый метод имеет параметр blob-домена, но при его вызове в xml-документе не найден узел с таким именем, то будет выполнен поиск параметра с тем же именем среди параметров сессии. Если такой параметр сессии будет найден, то его значение будет передано в качестве blob-значения одноименного параметра вызываемого метода. При этом в случае, если параметр имеет blob-домен подтипа "btNamedFile" (Именованный файл), то содержимое файла будет взято из одноименного параметра сессии (например, "param1"), а имя файла будет взято из параметра сессии с именем, дополненным постфиксом ".filename" (например, "param1.filename").
  5. Если вызываемый метод имеет параметр blob-домена с подтипом "btImage" (Изображение), то для переданного значения будет предпринята попытка его преобразования в формат, заданный свойством "Расширение" домена.
  6. В других случаях переданное или найденное в параметрах сессии blob/clob значение будет передано "как есть" в качестве значения параметра при вызове метода.
  7. Если для параметра было использовано значение параметра сессии, то такой параметр удаляется из сессии после вызова функции (повторное использование параметра сессии невозможно).

2. Особенности передачи возвращаемых значений типа "большой объект"
Если функция сервиса имеет возвращаемое значение, имеющее домен типа blob, clob или "внешний файл", то такое значение может быть подвергнуто пост-обработке по следующим принципам:
  1. Если задано расширение .js или .json, атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет clob-домен или домен "Внешние данные" подтипа "btJavaScript" (Скрипт JavaScript), то будет возвращено полученное из метода значение "как есть" (без каких-либо дополнительных преобразований)
  2. Если задано расширение .xml, атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет clob-домен или домен "Внешние данные" подтипа "btXML" (XML-документ) или "btXHTML" (XHTML-документ), то будет возвращено полученное из метода значение "как есть" (без каких-либо дополнительных преобразований)
  3. При использовании других расширений, если атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет blob-домен подтипа "btNamedFile" (Именованный файл), то в заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.
  4. Если для атрибута "noanalyze" будет передано значение "1", и при этом возвращаемое значение имеет blob-домен и его размер окажется большим, то возвращаемое значение будет сохранено в параметре сессии, а в xml-ответе будет представлен только его идентификатор.
  5. Во всех других случаях возвращаемое значение типа "большой объект" (blob) будет двоично закодировано и возвращено в разделе CDATA xml-документа.


Мельница данных ((раздел целиком))

Мельница данных- Класс TFloatDomain (Вещественные числа) (раздел целиком) (22.10.2024) (одним файлом)
Класс TFloatDomain (Вещественные числа)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

1. Свойства

Свойства класса TFloatDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
Length | Integer | Нет | Видимо пользователю | Чтение/Запись | Длина
DecimalPlaces | Integer | Нет | Видимо пользователю | Чтение/Запись | Количество десятичных знаков
MinValue | float | Нет | Видимо пользователю | Чтение/Запись | Минимальное значение
MaxValue | float | Нет | Видимо пользователю | Чтение/Запись | Максимальное значение
DigitGrouping | Boolean | Да | Видимо пользователю | Чтение/Запись | Разделять группы разрядов

2. Конструктор Create (Конструктор вещественного домена)

Конструктор класса TFloatDomain.

1constructor TFloatDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; DecimalPlaces: Integer; MinValue: float;
4  MaxValue: float; DigitGrouping: Boolean): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
Length | Integer | Нет | Длина
DecimalPlaces | Integer | Нет | Количество десятичных знаков
MinValue | float | Нет | Минимальное значение
MaxValue | float | Нет | Максимальное значение
DigitGrouping | Boolean | Да | Разделять группы разрядов

Замечания:

Создает новый объект класса TFloatDomain.

3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFloatDomain.

function TFloatDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IContextExpressionInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IContextExpressionInfo

1type
2  IContextExpressionInfo = interface(IUnknown)
3    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
4    function LookupExpressionContext(const Identifier: WideString;
5      out DomainID: WideString; out Value: WideString): WordBool; safecall;
6    procedure SerializeExpressionContext(const RootNode: IDispatch); safecall;
7  end;

1. Метод LookupExpressionContext

Метод интерфейса IContextExpressionInfo.

1function IContextExpressionInfo.LookupExpressionContext(const Identifier: WideString;
2  out DomainID: WideString; out Value: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Identifier | WideString | Да |
DomainID | WideString | Да |
Value | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

2. Метод SerializeExpressionContext

Метод интерфейса IContextExpressionInfo.

procedure IContextExpressionInfo.SerializeExpressionContext(const RootNode: IDispatch);

Параметры:

Имя | Тип | Обязательно | Значение
RootNode | IDispatch | Да |


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс ITypeInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс ITypeInfo
Информация о типах полей поставляется в виде набора объектов, каждый из которых реализует интерфейс (наследник INamedItemInfo )
1  ITypeInfo = interface(INamedItemInfo)
2    ['{2B6A5E20-3C36-4574-89DB-7C873A5C4A00}']
3    function Get_Required: WordBool; safecall;
4    function Get_SimpleType: TSimpleType; safecall;
5  end;
Информация о конкретном типе передается при помощи реализации одного из наследников этого интерфейса.
  • функция Get_Required возвращает True, если значение поля обязательно для задания.
  • функция Get_SimpleType возвращает информацию о простом типе данных. В зависимости от возвращаемого значения объект должен также реализовывать один из интерфейсов конкретных типов (см. далее). Возможные значения (тип TSimpleType ):
    • dtString - строковый тип. Обязательно реализуется интерфейс IStringInfo
    • dtInteger - целочисленный тип. Обязательно реализуется интерфейс IIntegerInfo
    • dtFloat - вещественный тип. Обязательно реализуется интерфейс IFloatInfo
    • dtDate - тип "дата". Обязательно реализуется интерфейс IDateInfo
    • dtTime - тип "время". Обязательно реализуется интерфейс ITimeInfo
    • dtDateTime - тип "дата со временем". Обязательно реализуется интерфейс IDateTimeInfo
    • dtBoolean - логический тип. Обязательно реализуется интерфейс IBooleanInfo
    • dtEnumeration - перечисление. Обязательно реализуется интерфейс IEnumerationInfo
    • dtReference - ссылка. Обязательно реализуется интерфейс IReferenceInfo
    • dtBlob - Большой двоичный объект. Обязательно реализуется интерфейс IBlobInfo.

1. Интерфейс ITypeInfo2
Информация о предоставляемых провайдером дополнительных возможностях фильтрации (наследник интерфейса ITypeInfo)
1  ITypeInfo2 = interface(ITypeInfo)
2    ['{77F58BDF-F01C-40F3-B193-1027AD8C4EDA}']
3    function GetSpecialFilterCount: Integer; safecall;
4    function GetSpecialFilterText(Index: Integer): WideString; safecall;
5    function EditSpecialFilter(Index: Integer; var Filter: WideString): WordBool; safecall;
6  end;
  • функция GetSpecialFilterCount возвращает количество дополнительных элементов списка, выпадающего при выборе фильтра по колонке.
  • функция GetSpecialFilterText возвращает текст дополнительного элемента списка, выпадающего при выборе фильтра по колонке, с номером Index.
  • функция EditSpecialFilter вызывается в момент выбора пользователем дополнительного элемента списка, выпадающего при выборе фильтра по колонке, с номером Index. Значение выражения фильтра передается и возвращается в параметре Filter. Функция возвращает True в случае, если выражение, возвращенное в параметре Filter нужно применить для фильтрации столбца запроса, False - в противном случае.

2. Интерфейс IStringInfo
Информация о строковом типе (наследник интерфейса ITypeInfo)
1  IStringInfo = interface(ITypeInfo)
2    ['{74AC4C03-E803-421B-B30D-1A2D2C49827F}']
3    function Get_Length: Integer; safecall;
4  end;
  • функция Get_Length возвращает максимальную длину строки.

3. Интерфейс IIntegerInfo
Информация о целочисленном типе (наследник интерфейса ITypeInfo)
1  IIntegerInfo = interface(ITypeInfo)
2    ['{9003B25E-926D-42AE-A907-813DF3A8343E}']
3    function Get_MaxValue: Integer; safecall;
4    function Get_MaxValueUsed: WordBool; safecall;
5    function Get_MinValue: Integer; safecall;
6    function Get_MinValueUsed: WordBool; safecall;
7  end;
  • функция Get_MaxValueUsed возвращает True, если значение имеет верхнюю границу.
  • функция Get_MaxValue возвращает верхнюю границу значения, если есть.
  • функция Get_MinValueUsed возвращает True, если значение имеет нижнюю границу.
  • функция Get_MinValue возвращает нижнюю границу значения, если есть.

4. Интерфейс IFloatInfo
Информация о вещественном типе (наследник интерфейса ITypeInfo )
1  IFloatInfo = interface(ITypeInfo)
2    ['{E9B56C6D-47DC-4AB9-9E80-6EEF77708704}']
3    function Get_MaxValue: Double; safecall;
4    function Get_MaxValueUsed: WordBool; safecall;
5    function Get_MinValue: Double; safecall;
6    function Get_MinValueUsed: WordBool; safecall;
7    function Get_Precision: Integer; safecall;
8    function Get_Scale: Integer; safecall;
9  end;
  • функция Get_MaxValueUsed возвращает True, если значение имеет верхнюю границу.
  • функция Get_MaxValue возвращает верхнюю границу значения, если есть.
  • функция Get_MinValueUsed возвращает True, если значение имеет нижнюю границу.
  • функция Get_MinValue возвращает нижнюю границу значения, если есть.
  • функция Get_Precision возвращает максимальное количество значащих десятичных цифр в значении.
  • функция Get_Scale возвращает максимальное количество десятичных цифр после запятой.

5. Интерфейс IDateInfo
Информация о типе "Дата" (без времени) (наследник интерфейса ITypeInfo )
1  IDateInfo = interface(ITypeInfo)
2    ['{DA392510-105F-4655-9A38-18ECA2FBEB97}']
3  end;
Не имеет методов.

6. Интерфейс ITimeInfo
Информация о типе "Время" (без даты) (наследник интерфейса ITypeInfo )
1  ITimeInfo = interface(ITypeInfo)
2    ['{D7067CAC-67A5-41DB-8D95-40409D8658AB}']
3  end;
Не имеет методов.

7. Интерфейс IDateTimeInfo
Информация о типе "Дата со времемем" (наследник интерфейса ITypeInfo )
1  IDateTimeInfo = interface(ITypeInfo)
2    ['{7F5CC8F9-8CE1-4DB7-8932-884EF3BAB538}']
3  end;
Не имеет методов.

8. Интерфейс IBooleanInfo
Информация о логическом типе (наследник интерфейса ITypeInfo )
1  IBooleanInfo = interface(ITypeInfo)
2    ['{8256EDF9-8613-4970-850C-50047839D6BF}']
3    function Get_TrueValue: WideString; safecall;
4    function Get_FalseValue: WideString; safecall;
5  end;
  • функция Get_TrueValue возвращает отображаемую строку для значения True (например, "Да").
  • функция Get_FalseValue возвращает отображаемую строку для значения False (например, "Нет").

9. Интерфейс IEnumerationInfo
Информация о перечислимом типе (наследник интерфейса ITypeInfo )
1  IEnumerationInfo = interface(ITypeInfo)
2    ['{B58A3F23-1AAC-4420-ADFF-B23B9938A994}']
3    function Get_ItemCount: Integer; safecall;
4    function Get_Item(Index: Integer): IEnumerationItem; safecall;
5  end;
Перечислимый тип определяет набор значений, которые может принимать поле. Значения в таблице трактуются как равные имени элемента перечисления.
  • функция Get_ItemCount возвращает количество элементов перечисления.
  • функция Get_Item возвращает ссылку на элемент перечисления с номером Index, реализующий интерфейс IEnumerationItem

10. Интерфейс IReferenceInfo
Информация о типе "ссылка" (наследник интерфейса ITypeInfo )
1  IReferenceInfo = interface(ITypeInfo)
2    ['{309C8CB1-4A1C-4E58-BC3F-D1AF27861A8F}']
3    function Get_TargetTable: ITableInfo; safecall;
4  end;
  • функция Get_TargetTable возвращает ссылку на таблицу, с которой осуществляется связь. Возвращается ссылка на интерфейс ITableInfo

11. Интерфейс IBlobInfo
Информация о типе "больших двоичных объектов" (наследник интерфейса ITypeInfo )
1  IBlobInfo = interface(ITypeInfo)
2    ['{3905C9C4-EAEB-4844-BB55-3F524F1F3FAC}']
3    function Get_SubType: TBlobSubType; safecall;
4  end;
  • функция Get_SubType возвращает подтип большого двоичного объекта. Одно из следующих значений (тип TBlobSubType ):
    • bsText - текст
    • bsImage - изображение
    • bsBinary - двоичные данные


Мельница данных ((раздел целиком))

Мельница данных- Класс TObjectCreator (Роли-создатели) (раздел целиком) (22.10.2024) (одним файлом)
Класс TObjectCreator (Роли-создатели)

Класс TObject (Объекты)Класс TClass (Классы)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TObjectCreator:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
SecurityAccount | TSecurityAccount | Да | Видимо пользователю | Чтение/Запись | Роль безопасности

2. Конструктор Create (Конструктор роли-создателя)

Конструктор класса TObjectCreator.

1constructor TObjectCreator.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
SecurityAccount | TSecurityAccount | Да | Роль безопасности

Замечания:

Создает новый объект класса TObjectCreator.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IInfoProvider (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IInfoProvider

01type
02  IInfoProvider = interface(IUnknown)
03    ['{64F8072B-7250-4C57-BA8E-D018C7B72CC7}']
04    function Get_TableCount: Integer; safecall;
05    function Get_Table(Index: Integer): ITableInfo; safecall;
06    function Perform(const SQL: WideString): IDataSet; safecall;
07    procedure Connect(const DataBase: WideString; const UserName: WideString;
08      const Password: WideString); safecall;
09    function Get_CLSID: GUID; safecall;
10    function Get_DateLiteral: WideString; safecall;
11    function Get_TimeLiteral: WideString; safecall;
12    function Get_DateTimeLiteral: WideString; safecall;
13    function Get_RegExpLiteral: WideString; safecall;
14    function Get_ToBooleanLiteral: WideString; safecall;
15    function Get_ToStringLiteral: WideString; safecall;
16    function Get_AllowStartingWith: WordBool; safecall;
17    function Get_AllowArrays: WordBool; safecall;
18    function Get_DisallowNullsSorting: WordBool; safecall;
19    function Get_DisallowSubqueries: WordBool; safecall;
20    function Get_DisallowBetween: WordBool; safecall;
21    function Get_LikeAlwaysEscaped: WordBool; safecall;
22    function Get_MaxIdentLength: Integer; safecall;
23    function Get_ReplaceRegExpDotsWithUnderscore: WordBool; safecall;
24    function Get_Epsilon: WideString; safecall;
25    property TableCount: Integer read Get_TableCount;
26    property Table[Index: Integer]: ITableInfo read Get_Table;
27    property CLSID: GUID read Get_CLSID;
28    property DateLiteral: WideString read Get_DateLiteral;
29    property TimeLiteral: WideString read Get_TimeLiteral;
30    property DateTimeLiteral: WideString read Get_DateTimeLiteral;
31    property RegExpLiteral: WideString read Get_RegExpLiteral;
32    property ToBooleanLiteral: WideString read Get_ToBooleanLiteral;
33    property ToStringLiteral: WideString read Get_ToStringLiteral;
34    property AllowStartingWith: WordBool read Get_AllowStartingWith;
35    property AllowArrays: WordBool read Get_AllowArrays;
36    property DisallowNullsSorting: WordBool read Get_DisallowNullsSorting;
37    property DisallowSubqueries: WordBool read Get_DisallowSubqueries;
38    property DisallowBetween: WordBool read Get_DisallowBetween;
39    property LikeAlwaysEscaped: WordBool read Get_LikeAlwaysEscaped;
40    property MaxIdentLength: Integer read Get_MaxIdentLength;
41    property ReplaceRegExpDotsWithUnderscore: WordBool
42      read Get_ReplaceRegExpDotsWithUnderscore;
43    property Epsilon: WideString read Get_Epsilon;
44  end;

1. Свойства

Свойства интерфейса IInfoProvider:

Имя | Тип | Доступ | Назначение
AllowArrays | WordBool | Только для чтения |
AllowStartingWith | WordBool | Только для чтения |
CLSID | GUID | Только для чтения |
DateLiteral | WideString | Только для чтения |
DateTimeLiteral | WideString | Только для чтения |
DisallowBetween | WordBool | Только для чтения |
DisallowNullsSorting | WordBool | Только для чтения |
DisallowSubqueries | WordBool | Только для чтения |
Epsilon | WideString | Только для чтения |
LikeAlwaysEscaped | WordBool | Только для чтения |
MaxIdentLength | Integer | Только для чтения |
RegExpLiteral | WideString | Только для чтения |
ReplaceRegExpDotsWithUnderscore | WordBool | Только для чтения |
Table[Index: Integer] | ITableInfo | Только для чтения |
TableCount | Integer | Только для чтения |
TimeLiteral | WideString | Только для чтения |
ToBooleanLiteral | WideString | Только для чтения |
ToStringLiteral | WideString | Только для чтения |

2. Метод Connect

Метод интерфейса IInfoProvider.

1procedure IInfoProvider.Connect(const DataBase: WideString;
2  const UserName: WideString; const Password: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
DataBase | WideString | Да |
UserName | WideString | Да |
Password | WideString | Да |

3. Метод Perform

Метод интерфейса IInfoProvider.

function IInfoProvider.Perform(const SQL: WideString): IDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
SQL | WideString | Да |

Замечания:

Возвращает значение типа IDataSet.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс ITypeInfo2 (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс ITypeInfo2

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  ITypeInfo2 = interface(ITypeInfo)
3    ['{77F58BDF-F01C-40F3-B193-1027AD8C4EDA}']
4    function GetSpecialFilterCount: Integer; safecall;
5    function GetSpecialFilterText(Index: Integer): WideString; safecall;
6    function EditSpecialFilter(Index: Integer; var Filter: WideString): WordBool; safecall;
7  end;

1. Метод EditSpecialFilter

Метод интерфейса ITypeInfo2.

1function ITypeInfo2.EditSpecialFilter(Index: Integer;
2  var Filter: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |
Filter | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

2. Метод GetSpecialFilterCount

Метод интерфейса ITypeInfo2.

function ITypeInfo2.GetSpecialFilterCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

3. Метод GetSpecialFilterText

Метод интерфейса ITypeInfo2.

function ITypeInfo2.GetSpecialFilterText(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IControl (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IControl

01type
02  IControl = interface(IDispatch)
03    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
04    function Name: WideString; safecall;
05    function Get_Value: OleVariant; safecall;
06    procedure Set_Value(Value: OleVariant); safecall;
07    function Get_ReadOnly: WordBool; safecall;
08    procedure Set_ReadOnly(Value: WordBool); safecall;
09    function Get_IsValid: WordBool; safecall;
10    procedure Set_IsValid(Value: WordBool); safecall;
11    function Get_IsEmpty: WordBool; safecall;
12    procedure SetHint(const Value: WideString); safecall;
13    procedure RefreshLinkedView; safecall;
14    function Get_Visible: WordBool; safecall;
15    property Value: OleVariant read Get_Value write Set_Value;
16    property ReadOnly: WordBool read Get_ReadOnly write Set_ReadOnly;
17    property IsValid: WordBool read Get_IsValid write Set_IsValid;
18    property IsEmpty: WordBool read Get_IsEmpty;
19    property Visible: WordBool read Get_Visible;
20  end;

1. Свойства

Свойства интерфейса IControl:

Имя | Тип | Доступ | Назначение
IsEmpty | WordBool | Только для чтения |
IsValid | WordBool | Чтение/Запись |
ReadOnly | WordBool | Чтение/Запись |
Value | OleVariant | Чтение/Запись |
Visible | WordBool | Только для чтения |

2. Метод Name

Метод интерфейса IControl.

function IControl.Name: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

3. Метод RefreshLinkedView

Метод интерфейса IControl.

procedure IControl.RefreshLinkedView;

Метод не имеет параметров.

4. Метод SetHint

Метод интерфейса IControl.

procedure IControl.SetHint(const Value: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Value | WideString | Да |


Мельница данных ((раздел целиком))

Мельница данных- Справочник по метаданным (раздел целиком) (22.10.2024)

(одним файлом)

Справочник по метаданным

1. Перечисление Resource strings (Ресурсные строки)
01type
02  Resource strings = (rssRole, rssUser, rssIsMemberOf,
03    rssRoleCannotBeMemberOfItself, rssRoleCannotHavePrimaryRole, rssCanUse,
04    rssVirtualException, rssDataBaseIdentifierTooLong,
05    rssDefaultConstructorDescription, rssDefaultConstructorActionDescription,
06    rssDefaultDesctructorActionDescription, rssDefaultExcelActionDescription,
07    rssUsersActivityOn, rssHours, rssLocalCharacters, rssCannotLocalizeClass,
08    rssCannotLocalizeField, rssCannotTranslateUntranslatable,
09    rssCannotSendMessageToNotApprovedContact, rssCannotCreateContactForYourself,
10    rssCannotSendMessageForYourself, rssOverwriteFile, rssOverwriteAccessibleFile,
11    rssReplaceCurrentTemplate, rssReplaceAllImages, rssReplaceAllMethods,
12    rssReplaceAllTemplates, rssLoadingProcess, rssDoNotFogetMacroName,
13    rssCheckOleObjectMethodErrorMethodNotSpecified,
14    rssCheckOleObjectMethodErrorClassIDNotSpecified,
15    rssCheckOleObjectMethodErrorCodeLibraryNotSpecified,
16    rssCheckOleObjectMethodErrorCodeLibraryNotFound,
17    rssCheckOleObjectMethodErrorXMLIsNotValid,
18    rssCheckOleObjectMethodErrorProgIDNotImplemented,
19    rssCheckOleObjectMethodErrorMethodNotImplemented,
20    rssCheckOleObjectMethodErrorNoParameters,
21    rssCheckOleObjectMethodErrorNoIDParameter,
22    rssCheckOleObjectMethodErrorParameterNames,
23    rssCheckOleObjectMethodErrorParameterCount, rssLoadingResources, rssMethodCall,
24    rssDMLOperation, rssReplaceAllBlobsContent,
25    rssCheckXSLTTemplateErrorXMLIsNotValid,
26    rssCheckXSLTTemplateErrorNoTemplateData,
27    rssCheckXSLTTemplateErrorNoIDParameter, rssCheckXSLTTemplateErrorNoParameter,
28    rssCheckXSLTTemplateErrorExcessParameter,
29    rssCheckOleObjectMethodErrorNoFunctionFound,
30    rssCheckExcelTemplateErrorNoTemplateData, rssCheckExcelTemplateErrorNoMacro,
31    rssCheckExcelTemplateErrorNoFunctionFound,
32    rssCheckWordTemplateErrorNoTemplateData, rssCheckWordTemplateErrorNoMacro,
33    rssCheckWordTemplateErrorNoFunctionFound, rssCheckTemplates,
34    rssUnexpectedDatabase, rssCannotSaveDatabaseLanguage, rssDomainNotFound,
35    rssCheckOfficeTemplateErrorMissingParameters,
36    rssCheckOfficeTemplateErrorMissingImplementationParameter,
37    rssCheckOfficeTemplateErrorParametersCountMismatched,
38    rssCheckOfficeTemplateErrorNoFunctionFound,
39    rssCheckOfficeTemplateErrorProjectSyntaxIncorrect,
40    rssCheckOfficeTemplateErrorIncludedModuleNotFound,
41    rssCheckOfficeTemplateWarningMethodBodyTooLong,
42    rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped,
43    rssCheckOfficeTemplateWarningOptionValueIncorrect,
44    rssCannotPerformTaskAlreadyRunning, rssCannotPerformTaskDueToStatus,
45    rssAsyncMethodInstantSuccess, rssAsyncMethodInstantError,
46    rssAsyncReportInstantSuccess, rssAsyncReportInstantError,
47    rssViewCannotContainColumns, rssMasterNotDefined, rssAbstractDomain);
Или
01type
02  Resource strings = TOleEnum;
03const
04  rssRole = $00000000;
05  rssUser = $00000001;
06  rssIsMemberOf = $00000002;
07  rssRoleCannotBeMemberOfItself = $00000003;
08  rssRoleCannotHavePrimaryRole = $00000004;
09  rssCanUse = $00000005;
10  rssVirtualException = $00000006;
11  rssDataBaseIdentifierTooLong = $00000007;
12  rssDefaultConstructorDescription = $00000008;
13  rssDefaultConstructorActionDescription = $00000009;
14  rssDefaultDesctructorActionDescription = $0000000A;
15  rssDefaultExcelActionDescription = $0000000B;
16  rssUsersActivityOn = $0000000C;
17  rssHours = $0000000D;
18  rssLocalCharacters = $0000000E;
19  rssCannotLocalizeClass = $0000000F;
20  rssCannotLocalizeField = $00000010;
21  rssCannotTranslateUntranslatable = $00000011;
22  rssCannotSendMessageToNotApprovedContact = $00000012;
23  rssCannotCreateContactForYourself = $00000013;
24  rssCannotSendMessageForYourself = $00000014;
25  rssOverwriteFile = $00000015;
26  rssOverwriteAccessibleFile = $00000016;
27  rssReplaceCurrentTemplate = $00000017;
28  rssReplaceAllImages = $00000018;
29  rssReplaceAllMethods = $00000019;
30  rssReplaceAllTemplates = $0000001A;
31  rssLoadingProcess = $0000001B;
32  rssDoNotFogetMacroName = $0000001C;
33  rssCheckOleObjectMethodErrorMethodNotSpecified = $0000001D;
34  rssCheckOleObjectMethodErrorClassIDNotSpecified = $0000001E;
35  rssCheckOleObjectMethodErrorCodeLibraryNotSpecified = $0000001F;
36  rssCheckOleObjectMethodErrorCodeLibraryNotFound = $00000020;
37  rssCheckOleObjectMethodErrorXMLIsNotValid = $00000021;
38  rssCheckOleObjectMethodErrorProgIDNotImplemented = $00000022;
39  rssCheckOleObjectMethodErrorMethodNotImplemented = $00000023;
40  rssCheckOleObjectMethodErrorNoParameters = $00000024;
41  rssCheckOleObjectMethodErrorNoIDParameter = $00000025;
42  rssCheckOleObjectMethodErrorParameterNames = $00000026;
43  rssCheckOleObjectMethodErrorParameterCount = $00000027;
44  rssLoadingResources = $00000028;
45  rssMethodCall = $00000029;
46  rssDMLOperation = $0000002A;
47  rssReplaceAllBlobsContent = $0000002B;
48  rssCheckXSLTTemplateErrorXMLIsNotValid = $0000002C;
49  rssCheckXSLTTemplateErrorNoTemplateData = $0000002D;
50  rssCheckXSLTTemplateErrorNoIDParameter = $0000002E;
51  rssCheckXSLTTemplateErrorNoParameter = $0000002F;
52  rssCheckXSLTTemplateErrorExcessParameter = $00000030;
53  rssCheckOleObjectMethodErrorNoFunctionFound = $00000031;
54  rssCheckExcelTemplateErrorNoTemplateData = $00000032;
55  rssCheckExcelTemplateErrorNoMacro = $00000033;
56  rssCheckExcelTemplateErrorNoFunctionFound = $00000034;
57  rssCheckWordTemplateErrorNoTemplateData = $00000035;
58  rssCheckWordTemplateErrorNoMacro = $00000036;
59  rssCheckWordTemplateErrorNoFunctionFound = $00000037;
60  rssCheckTemplates = $00000038;
61  rssUnexpectedDatabase = $00000039;
62  rssCannotSaveDatabaseLanguage = $0000003A;
63  rssDomainNotFound = $0000003B;
64  rssCheckOfficeTemplateErrorMissingParameters = $0000003C;
65  rssCheckOfficeTemplateErrorMissingImplementationParameter = $0000003D;
66  rssCheckOfficeTemplateErrorParametersCountMismatched = $0000003E;
67  rssCheckOfficeTemplateErrorNoFunctionFound = $0000003F;
68  rssCheckOfficeTemplateErrorProjectSyntaxIncorrect = $00000040;
69  rssCheckOfficeTemplateErrorIncludedModuleNotFound = $00000041;
70  rssCheckOfficeTemplateWarningMethodBodyTooLong = $00000042;
71  rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped = $00000043;
72  rssCheckOfficeTemplateWarningOptionValueIncorrect = $00000044;
73  rssCannotPerformTaskAlreadyRunning = $00000045;
74  rssCannotPerformTaskDueToStatus = $00000046;
75  rssAsyncMethodInstantSuccess = $00000047;
76  rssAsyncMethodInstantError = $00000048;
77  rssAsyncReportInstantSuccess = $00000049;
78  rssAsyncReportInstantError = $0000004A;
79  rssViewCannotContainColumns = $0000004B;
80  rssMasterNotDefined = $0000004C;
81  rssAbstractDomain = $0000004D;
Элементы перечисления:

Имя

Значение

Назначение

rssRole

0

Роль

rssUser

1

Пользователь

rssIsMemberOf

2

является членом роли

rssRoleCannotBeMemberOfItself

3

Роль не может включать сама себя.

rssRoleCannotHavePrimaryRole

4

Роль не может иметь основную роль.

rssCanUse

5

использует(ют) объект

rssVirtualException

6

Ошибка вызова виртуального метода.

rssDataBaseIdentifierTooLong

7

Длина имени объекта, отображаемого на объект базы данных, не должна превышать 29 символов

rssDefaultConstructorDescription

8

создание

rssDefaultConstructorActionDescription

9

Создать

rssDefaultDesctructorActionDescription

10

Удалить

rssDefaultExcelActionDescription

11

Перенести в Excel

rssUsersActivityOn

12

Активность пользователей за

rssHours

13

Часы

rssLocalCharacters

14

АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯабвгдеёжзийклмнопрстуфхцчшщъыьэюя

rssCannotLocalizeClass

15

Нельзя локализовать класс

rssCannotLocalizeField

16

Нельзя локализовать поле

rssCannotTranslateUntranslatable

17

Нельзя перевести непереводимый элемент.

rssCannotSendMessageToNotApprovedContact

18

Нельзя отправить сообщение неодобренному контакту.

rssCannotCreateContactForYourself

19

Нельзя создать контакт для самого себя.

rssCannotSendMessageForYourself

20

Нельзя отправить сообщение самому себе.

rssOverwriteFile

21

Заменить содержимое файла "%FileName%"?

rssOverwriteAccessibleFile

22

Заменить содержимое доступного файла "%FileName%"?

rssReplaceCurrentTemplate

23

Заменить содержимое шаблона?

rssReplaceAllImages

24

Заменить содержимое всех изображений?

rssReplaceAllMethods

25

Заменить содержимое всех скриптов и тел методов?

rssReplaceAllTemplates

26

Заменить содержимое всех шаблонов всех отчетов?

rssLoadingProcess

27

Загрузка

rssDoNotFogetMacroName

28

Не забудьте установить имя макроса.

rssCheckOleObjectMethodErrorMethodNotSpecified

29

Имя метода не задано

rssCheckOleObjectMethodErrorClassIDNotSpecified

30

Идентификатор класса не задан

rssCheckOleObjectMethodErrorCodeLibraryNotSpecified

31

Библиотека кода не задана

rssCheckOleObjectMethodErrorCodeLibraryNotFound

32

Невозможно загрузить библиотеку кода "%CodeLibrary%"

rssCheckOleObjectMethodErrorXMLIsNotValid

33

Невалидный XML-документ

rssCheckOleObjectMethodErrorProgIDNotImplemented

34

Указанный ProgID "%ProgID%" не реализован в скриптлете

rssCheckOleObjectMethodErrorMethodNotImplemented

35

Метод не реализован

rssCheckOleObjectMethodErrorNoParameters

36

Метод должен объявлять хотя бы один параметр

rssCheckOleObjectMethodErrorNoIDParameter

37

Метод должен объявлять параметр с именем "ID"

rssCheckOleObjectMethodErrorParameterNames

38

Параметр с именем "%RealName%" не соответствует ожидаемому "%ExpectedName%"

rssCheckOleObjectMethodErrorParameterCount

39

Количество параметров "%RealCount%" в объявлении метода не совпадает с ожидаемым "%ExpectedCount%"

rssLoadingResources

40

Загрузка ресурсов

rssMethodCall

41

Вызов метода

rssDMLOperation

42

Операция с данными

rssReplaceAllBlobsContent

43

Заменить содержимое свойства %Class%.%Description% для всех объектов?

rssCheckXSLTTemplateErrorXMLIsNotValid

44

Невалидный XML-документ

rssCheckXSLTTemplateErrorNoTemplateData

45

Данные шаблона отсутствуют

rssCheckXSLTTemplateErrorNoIDParameter

46

Шаблон XSLT как метод экземпляра должен объявлять параметр "ID"

rssCheckXSLTTemplateErrorNoParameter

47

Параметр "%Name%" не найден в шаблоне

rssCheckXSLTTemplateErrorExcessParameter

48

Параметр шаблона "%Name%" не зарегистрирован в метаданных

rssCheckOleObjectMethodErrorNoFunctionFound

49

Подпрограмма, соответствующая макросу, отсутствует в скриптлете

rssCheckExcelTemplateErrorNoTemplateData

50

Данные шаблона отсутствуют

rssCheckExcelTemplateErrorNoMacro

51

Имя макроса не задано

rssCheckExcelTemplateErrorNoFunctionFound

52

Подпрограмма, соответствующая макросу, отсутствует в проекте VBA

rssCheckWordTemplateErrorNoTemplateData

53

Данные шаблона отсутствуют

rssCheckWordTemplateErrorNoMacro

54

Имя макроса не задано

rssCheckWordTemplateErrorNoFunctionFound

55

Подпрограмма, соответствующая макросу, отсутствует в проекте VBA

rssCheckTemplates

56

Проверка шаблонов

rssUnexpectedDatabase

57

Не поддерживается в этой БД

rssCannotSaveDatabaseLanguage

58

Язык базы данных не может быть сохранен в ресурсный файл.

rssDomainNotFound

59

Домен не найден

rssCheckOfficeTemplateErrorMissingParameters

60

Параметры, не найденные в реализации:

rssCheckOfficeTemplateErrorMissingImplementationParameter

61

Параметр %ParamName% не найден в реализации

rssCheckOfficeTemplateErrorParametersCountMismatched

62

Декларированное и реализованное количество параметров не соответствуют: %DeclaredCount% <> %ImplementedCount%

rssCheckOfficeTemplateErrorNoFunctionFound

63

Указанный макрос %MacroName% не найден

rssCheckOfficeTemplateErrorProjectSyntaxIncorrect

64

VBA проект синтаксически некорректный

rssCheckOfficeTemplateErrorIncludedModuleNotFound

65

Модуль кода %ModuleFileName% (в шаблоне %LinesCount% строк) не найден в Доступных файлах

rssCheckOfficeTemplateWarningMethodBodyTooLong

66

Возможно, тело метода %ProcName% (%ModuleFileName%) чрезмерно длинное (%ProcLineCount% строк)

rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped

67

Синтаксическая проверка проектов VBA не будет произведена, т.к. значение следующих настроек не удовлетворяют требуемым:

rssCheckOfficeTemplateWarningOptionValueIncorrect

68

Неверное значение VBA настройки "%OptionName%" - Включено

rssCannotPerformTaskAlreadyRunning

69

Выполнение невозможно, задача уже выполняется

rssCannotPerformTaskDueToStatus

70

Выполнение невозможно, задача имеет недопустимое состояние

rssAsyncMethodInstantSuccess

71

Метод выполнен

rssAsyncMethodInstantError

72

Ошибка выполнения метода

rssAsyncReportInstantSuccess

73

Отчет сформирован

rssAsyncReportInstantError

74

Ошибка выполнения отчета

rssViewCannotContainColumns

75

Это представление не может содержать колонки.

rssMasterNotDefined

76

Не задан мастер для объекта %Name% (%Description%) класса "%Class%".

rssAbstractDomain

77

Абстрактный домен

2. Перечисление TAggregateKind (Тип агрегата)
1type
2  TAggregateKind = (agCount = 1, agSumm = 2, agMax = 3, agMin = 4, agAverage = 5,
3    agCountDistinct = 6);
Или
1type
2  TAggregateKind = TOleEnum;
3const
4  agCount = $00000001;
5  agSumm = $00000002;
6  agMax = $00000003;
7  agMin = $00000004;
8  agAverage = $00000005;
9  agCountDistinct = $00000006;
Элементы перечисления:

Имя

Значение

Назначение

agCount

1

Количество

agSumm

2

Сумма

agMax

3

Максимальное значение

agMin

4

Минимальное значение

agAverage

5

Среднее значение

agCountDistinct

6

Количество уникальных

3. Перечисление TAsyncTaskStatus (Состояние задачи отложенного выполнения)
1type
2  TAsyncTaskStatus = (astCreated, astReady, astRunning, astSuccess, astError);
Или
1type
2  TAsyncTaskStatus = TOleEnum;
3const
4  astCreated = $00000000;
5  astReady = $00000001;
6  astRunning = $00000002;
7  astSuccess = $00000003;
8  astError = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

astCreated

0

Создано

astReady

1

Готово к выполнению

astRunning

2

Выполняется

astSuccess

3

Завершено

astError

4

Прервано

4. Перечисление TBlobSubtype (Подтип)
1type
2  TBlobSubtype = (btBinaryData, btText, btImage, btSourceCode, btXML,
3    btNamedFile, btVisualBasicScript, btXHTML, btJavaScript, btHTML);
Или
01type
02  TBlobSubtype = TOleEnum;
03const
04  btBinaryData = $00000000;
05  btText = $00000001;
06  btImage = $00000002;
07  btSourceCode = $00000003;
08  btXML = $00000004;
09  btNamedFile = $00000005;
10  btVisualBasicScript = $00000006;
11  btXHTML = $00000007;
12  btJavaScript = $00000008;
13  btHTML = $00000009;
Элементы перечисления:

Имя

Значение

Назначение

btBinaryData

0

Двоичные данные

btText

1

Текст

btImage

2

Изображение

btSourceCode

3

Исходный код

btXML

4

XML-документ

btNamedFile

5

Именованный файл

btVisualBasicScript

6

Скрипт Visual Basic

btXHTML

7

XHTML-документ

btJavaScript

8

Скрипт JavaScript

btHTML

9

HTML-документ

5. Перечисление TChangeAction (Действие при изменении)
1type
2  TChangeAction = (atCreated, atChanging, atChanged, atDestroying, atPasted);
Или
1type
2  TChangeAction = TOleEnum;
3const
4  atCreated = $00000000;
5  atChanging = $00000001;
6  atChanged = $00000002;
7  atDestroying = $00000003;
8  atPasted = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

atCreated

0

Создан

atChanging

1

Изменится

atChanged

2

Изменен

atDestroying

3

Удаляется

atPasted

4

Вставлен из буфера

6. Перечисление TComparisonType (Типы сравнения)
1type
2  TComparisonType = (ctEqual, ctNotEqual, ctGreater, ctGreaterOrEqual, ctLess,
3    ctLessOrEqual, ctLike, ctNotLike, ctRegexpLike, ctNotRegexpLike, ctIsParent,
4    ctIsChild);
Или
01type
02  TComparisonType = TOleEnum;
03const
04  ctEqual = $00000000;
05  ctNotEqual = $00000001;
06  ctGreater = $00000002;
07  ctGreaterOrEqual = $00000003;
08  ctLess = $00000004;
09  ctLessOrEqual = $00000005;
10  ctLike = $00000006;
11  ctNotLike = $00000007;
12  ctRegexpLike = $00000008;
13  ctNotRegexpLike = $00000009;
14  ctIsParent = $0000000A;
15  ctIsChild = $0000000B;
Элементы перечисления:

Имя

Значение

Назначение

ctEqual

0

Равно

ctNotEqual

1

Не равно

ctGreater

2

Больше

ctGreaterOrEqual

3

Больше или равно

ctLess

4

Меньше

ctLessOrEqual

5

Меньше или равно

ctLike

6

Подобно

ctNotLike

7

Не подобно

ctRegexpLike

8

Удовлетворяет регулярному выражению

ctNotRegexpLike

9

Не удовлетворяет регулярному выражению

ctIsParent

10

Является родителем

ctIsChild

11

Является потомком

7. Перечисление TDateTimePart (Часть даты или времени)
1type
2  TDateTimePart = (dpYear, dpMonth, dpDay, dpHour, dpMinute, dpSecond,
3    dpDayOfWeek);
Или
01type
02  TDateTimePart = TOleEnum;
03const
04  dpYear = $00000000;
05  dpMonth = $00000001;
06  dpDay = $00000002;
07  dpHour = $00000003;
08  dpMinute = $00000004;
09  dpSecond = $00000005;
10  dpDayOfWeek = $00000006;
Элементы перечисления:

Имя

Значение

Назначение

dpYear

0

Год

dpMonth

1

Месяц

dpDay

2

День

dpHour

3

Час

dpMinute

4

Минута

dpSecond

5

Секунда

dpDayOfWeek

6

День недели

8. Перечисление TDeleteRule (Правило удаления)
1type
2  TDeleteRule = (drRestrict, drCascade, drSetNull);
Или
1type
2  TDeleteRule = TOleEnum;
3const
4  drRestrict = $00000000;
5  drCascade = $00000001;
6  drSetNull = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

drRestrict

0

Нет правила

drCascade

1

Каскадное удаление

drSetNull

2

Очистить ссылку

9. Перечисление TDuplicates (Дубликаты)
1type
2  TDuplicates = (dupIgnore, dupAccept, dupError);
Или
1type
2  TDuplicates = TOleEnum;
3const
4  dupIgnore = $00000000;
5  dupAccept = $00000001;
6  dupError = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

dupIgnore

0

Игнорировать дубликаты

dupAccept

1

Разрешить дублирование

dupError

2

Генерировать ошибку дублирования

10. Перечисление TExcelOutputFormat (Формат результата отчета Excel)
1type
2  TExcelOutputFormat = (eofDefault, eof2003, eofHTML, eofPDF, eofNativePDF,
3    eofXPS);
Или
1type
2  TExcelOutputFormat = TOleEnum;
3const
4  eofDefault = $00000000;
5  eof2003 = $00000001;
6  eofHTML = $00000002;
7  eofPDF = $00000003;
8  eofNativePDF = $00000004;
9  eofXPS = $00000005;
Элементы перечисления:

Имя

Значение

Назначение

eofDefault

0

По умолчанию

eof2003

1

Рабочая книга Excel 97-2003

eofHTML

2

Документ HTML

eofPDF

3

Документ PDF

eofNativePDF

4

Документ PDF, сформированный Excel

eofXPS

5

Документ XPS

11. Перечисление TExcelSheetKind (Тип листа Excel)
1type
2  TExcelSheetKind = (skNone, skFirst, skFirstHidden, skLast, skNew);
Или
1type
2  TExcelSheetKind = TOleEnum;
3const
4  skNone = $00000000;
5  skFirst = $00000001;
6  skFirstHidden = $00000002;
7  skLast = $00000003;
8  skNew = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

skNone

0

Не переносить данные на лист

skFirst

1

На первый лист

skFirstHidden

2

На первый скрытый лист

skLast

3

На последний лист

skNew

4

На новый лист

12. Перечисление TExternalDataProtocol (Протокол доступа к внешним данным)
1type
2  TExternalDataProtocol = (prLocal, prHTTP, prHTTPS, prFTP, prFTPS, prSMB);
Или
1type
2  TExternalDataProtocol = TOleEnum;
3const
4  prLocal = $00000000;
5  prHTTP = $00000001;
6  prHTTPS = $00000002;
7  prFTP = $00000003;
8  prFTPS = $00000004;
9  prSMB = $00000005;
Элементы перечисления:

Имя

Значение

Назначение

prLocal

0

Файл доступен локально

prHTTP

1

Протокол HTTP

prHTTPS

2

Протокол HTTPS

prFTP

3

Протокол FTP

prFTPS

4

Протокол FTPS

prSMB

5

Протокол SMB

13. Перечисление TFormViewLayout (Виды расположения)
1type
2  TFormViewLayout = (vlHorizontal, vlVertical);
Или
1type
2  TFormViewLayout = TOleEnum;
3const
4  vlHorizontal = $00000000;
5  vlVertical = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

vlHorizontal

0

Горизонтальное

vlVertical

1

Вертикально

14. Перечисление TInstantContactStatus (Статус контакта)
1type
2  TInstantContactStatus = (icsPending, icsRefused, icsApproved);
Или
1type
2  TInstantContactStatus = TOleEnum;
3const
4  icsPending = $00000000;
5  icsRefused = $00000001;
6  icsApproved = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

icsPending

0

Рассматривается

icsRefused

1

Отказано

icsApproved

2

Утвержденный

15. Перечисление TInstantMessageAttachmentType (Тип вложения мгновенного сообщения)
1type
2  TInstantMessageAttachmentType = (imaFile, imaImage, imaHyperLink, imaObject);
Или
1type
2  TInstantMessageAttachmentType = TOleEnum;
3const
4  imaFile = $00000000;
5  imaImage = $00000001;
6  imaHyperLink = $00000002;
7  imaObject = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

imaFile

0

Файл

imaImage

1

Изображение

imaHyperLink

2

Гиперссылка

imaObject

3

Объект

16. Перечисление TInstantMessageAttachmentType (None) (Тип вложения мгновенного сообщения (None))
1type
2  TInstantMessageAttachmentType (None) = (imaFile, imaImage, imaHyperLink,
3    imaObject, imaNone);
Или
1type
2  TInstantMessageAttachmentType (None) = TOleEnum;
3const
4  imaFile = $00000000;
5  imaImage = $00000001;
6  imaHyperLink = $00000002;
7  imaObject = $00000003;
8  imaNone = $00000004;
Это перечисление использует элементы TInstantMessageAttachmentType.

Элементы перечисления:

Имя

Значение

Назначение

imaFile

0

Определено в базовом перечислении TInstantMessageAttachmentType

imaImage

1

Определено в базовом перечислении TInstantMessageAttachmentType

imaHyperLink

2

Определено в базовом перечислении TInstantMessageAttachmentType

imaObject

3

Определено в базовом перечислении TInstantMessageAttachmentType

imaNone

4

Нет

17. Перечисление TNotificationType (Тип уведомления)
1type
2  TNotificationType = (ntInformation, ntWarning, ntCaution);
Или
1type
2  TNotificationType = TOleEnum;
3const
4  ntInformation = $00000000;
5  ntWarning = $00000001;
6  ntCaution = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

ntInformation

0

Информация

ntWarning

1

Предупреждение

ntCaution

2

Проблема

18. Перечисление TOutputColorMode (Режим цветопередачи)
1type
2  TOutputColorMode = (wcmNormal, wcmGrayscale, wcmMonochrome);
Или
1type
2  TOutputColorMode = TOleEnum;
3const
4  wcmNormal = $00000000;
5  wcmGrayscale = $00000001;
6  wcmMonochrome = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

wcmNormal

0

Цветной

wcmGrayscale

1

В градациях серого

wcmMonochrome

2

Монохромный

19. Перечисление TReplicationStatus (Статус репликации)
1type
2  TReplicationStatus = (rsNotReplicatable, rsReplicatableMetadata, rsReplicatable);
Или
1type
2  TReplicationStatus = TOleEnum;
3const
4  rsNotReplicatable = $00000000;
5  rsReplicatableMetadata = $00000001;
6  rsReplicatable = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

rsNotReplicatable

0

Не реплицировать

rsReplicatableMetadata

1

Вместе с метаданными

rsReplicatable

2

Вместе с бизнес-данными

20. Перечисление TRowColor (Цвет строки таблицы)
1type
2  TRowColor = (rcDefault, rcRed, rcGreen, rcBlue, rcPale, rcCyan, rcMagenta,
3    rcYellow);
Или
01type
02  TRowColor = TOleEnum;
03const
04  rcDefault = $00000000;
05  rcRed = $00000001;
06  rcGreen = $00000002;
07  rcBlue = $00000003;
08  rcPale = $00000004;
09  rcCyan = $00000005;
10  rcMagenta = $00000006;
11  rcYellow = $00000007;
Элементы перечисления:

Имя

Значение

Назначение

rcDefault

0

По умолчанию

rcRed

1

Красная строка

rcGreen

2

Зеленая строка

rcBlue

3

Синяя строка

rcPale

4

Бледная строка

rcCyan

5

Голубая строка

rcMagenta

6

Пурпурная строка

rcYellow

7

Желтая строка

21. Перечисление TScope (Область видимости)
1type
2  TScope = (scPrivate, scPublic);
Или
1type
2  TScope = TOleEnum;
3const
4  scPrivate = $00000000;
5  scPublic = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

scPrivate

0

Не видимо пользователям

scPublic

1

Видимо пользователям

22. Перечисление TSecurityModel (Модели безопасности)
1type
2  TSecurityModel = (smFullAccess, smPublic, smPrivate, smByAffiliation);
Или
1type
2  TSecurityModel = TOleEnum;
3const
4  smFullAccess = $00000000;
5  smPublic = $00000001;
6  smPrivate = $00000002;
7  smByAffiliation = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

smFullAccess

0

Доступ не ограничен

smPublic

1

Публичный объект

smPrivate

2

Приватный объект

smByAffiliation

3

Доступ по принадлежности

23. Перечисление TShowObjectInfoType (Тип представления объектов)
1type
2  TShowObjectInfoType = (soName, soDescription);
Или
1type
2  TShowObjectInfoType = TOleEnum;
3const
4  soName = $00000000;
5  soDescription = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

soName

0

Показывать имена

soDescription

1

Показывать наименования

24. Перечисление TSortDirection (Направление сортировки)
1type
2  TSortDirection = (sdNone, sdAscending, sdDescending);
Или
1type
2  TSortDirection = TOleEnum;
3const
4  sdNone = $00000000;
5  sdAscending = $00000001;
6  sdDescending = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

sdNone

0

Нет

sdAscending

1

По возрастанию

sdDescending

2

По убыванию

25. Перечисление TTranslationStatus (Состояния перевода)
1type
2  TTranslationStatus = (tsNotTranslated, tsTranslated, tsUntranslatable, tsDirty);
Или
1type
2  TTranslationStatus = TOleEnum;
3const
4  tsNotTranslated = $00000000;
5  tsTranslated = $00000001;
6  tsUntranslatable = $00000002;
7  tsDirty = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

tsNotTranslated

0

Не переведено

tsTranslated

1

Переведено

tsUntranslatable

2

Не нуждается в переводе

tsDirty

3

Грязный

26. Перечисление TUserAccessMode (Режим доступа)
1type
2  TUserAccessMode = (uaFullAccess, uaReadOnly, uaAccessDenied);
Или
1type
2  TUserAccessMode = TOleEnum;
3const
4  uaFullAccess = $00000000;
5  uaReadOnly = $00000001;
6  uaAccessDenied = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

uaFullAccess

0

Полный доступ

uaReadOnly

1

Доступ только для чтения

uaAccessDenied

2

Доступ запрещен

27. Перечисление TWordOutputFormat (Формат результата отчета Word)
1type
2  TWordOutputFormat = (wofDefault, wof2003, wofHTML, wofRTF, wofPDF);
Или
1type
2  TWordOutputFormat = TOleEnum;
3const
4  wofDefault = $00000000;
5  wof2003 = $00000001;
6  wofHTML = $00000002;
7  wofRTF = $00000003;
8  wofPDF = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

wofDefault

0

По умолчанию

wof2003

1

Документ Word 97-2003

wofHTML

2

Документ HTML

wofRTF

3

Документ RTF

wofPDF

4

Документ PDF

28. Класс TAccessibleFile (Доступный файл)

28.1. Свойства

Свойства класса TAccessibleFile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

FileData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные файла

CRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

28.2. Конструктор Create (Конструктор доступного файла)

Конструктор класса TAccessibleFile.
1constructor TAccessibleFile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  FileData: blob): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

FileData

blob

Нет

Данные файла

Замечания:

Создает новый объект класса TAccessibleFile.

28.3. Метод SetData (Установить значение свойства "Данные файла")

Метод экземпляра класса TAccessibleFile.
procedure TAccessibleFile.SetData(FileData: blob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

FileData

blob

Нет

Данные файла

28.4. Метод Ole-объекта CheckAllCRC (Обновить отсутствующие контрольные суммы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

28.5. Метод Ole-объекта CheckCRC (Обновить контрольную сумму)

Метод Ole-объекта класса TAccessibleFile.

Метод Ole-объекта не имеет параметров.

28.6. Метод Ole-объекта LoadFromFolder (Загрузить из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

28.7. Метод Ole-объекта SaveToFolder (Сохранить в папку)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

28.8. Метод Ole-объекта UpdateFromFolder (Обновить из папки)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

29. Класс TAccessItem (Элементы доступа)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

29.1. Свойства

Свойства класса TAccessItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Скрыто от пользователя

Чтение/Запись

Имя

Description

string[128]

Да

Скрыто от пользователя

Чтение/Запись

Наименование

Class

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

Элемент

MasterName

string[64]

Да

Видимо пользователю

Только для чтения

Имя элемента

MasterDescription

string[128]

Да

Видимо пользователю

Только для чтения

Наименование элемента

MasterClass

TClass

Да

Видимо пользователю

Только для чтения

Класс элемента

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

SecurityAccountName

string[64]

Да

Видимо пользователю

Чтение/Запись

Имя роли безопасности

SecurityAccountDescription

string[128]

Да

Видимо пользователю

Чтение/Запись

Наименование роли безопасности

SecurityAccountClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс роли безопасности

29.2. Конструктор Create (Конструктор элемента доступа)

Конструктор класса TAccessItem.
1constructor TAccessItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TAccessItem.

29.3. Метод GetIsAccessible (Проверка доступности)

Метод класса (статический метод) класса TAccessItem.
class function TAccessItem.GetIsAccessible(Master: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Boolean.

30. Класс TAccessProfile (Профили доступа)

30.1. Свойства

Свойства класса TAccessProfile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TProfile

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

ComparisonType

TComparisonType

Да

Видимо пользователю

Чтение/Запись

BasedOnProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Active

Boolean

Да

Видимо пользователю

Только для чтения

Access

Boolean

Да

Видимо пользователю

Чтение/Запись

Доступ

30.2. Конструктор Create (Конструктор профиля доступа)

Конструктор класса TAccessProfile.
1constructor TAccessProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType; BasedOnProfile: TProfile;
4  Access: Boolean): TObject;
Переопределяет метод в TProfile.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Унаследовано от TProfile.Create

ComparisonType

TComparisonType

Да

BasedOnProfile

TProfile

Нет

Access

Boolean

Да

Доступ

Замечания:

Создает новый объект класса TAccessProfile.

31. Класс TAction (Действия)

Объекты класса образуют иерархию.

31.1. Свойства

Свойства класса TAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Горячая клавиша

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Отделено

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

По умолчанию

31.2. Конструктор Create (Конструктор действия)

Конструктор класса TAction.
1constructor TAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean;
4  Default: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Shortcut

string[20]

Нет

Горячая клавиша

Separated

Boolean

Да

Отделено

Default

Boolean

Да

По умолчанию

Замечания:

Создает новый объект класса TAction.

31.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TAction.
1class function TAction.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Parent

TObject

Нет

Родитель

Step

Integer

Да

Шаг

Замечания:

Возвращает значение типа Integer.

32. Класс TActionContextProperty (Свойство контекста)

Имена объектов класса генерируются.

32.1. Свойства

Свойства класса TActionContextProperty:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Property

TProperty

Да

Видимо пользователю

Чтение/Запись

Свойство

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

32.2. Конструктор Create (Конструктор контекстного свойства)

Конструктор класса TActionContextProperty.
1constructor TActionContextProperty.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Property: TProperty; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Property

TProperty

Да

Свойство

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TActionContextProperty.

32.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TActionContextProperty.
class function TActionContextProperty.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

33. Класс TAsyncHandler (Обработчики отложенного выполнения)

33.1. Свойства

Свойства класса TAsyncHandler:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Validator

TMethod

Нет

Видимо пользователю

Чтение/Запись

Процедура-валидатор

Handler

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Процедура-обработчик

33.2. Конструктор Create (Конструктор обработчика отложенного выполнения)

Конструктор класса TAsyncHandler.
1constructor TAsyncHandler.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Validator: TMethod; Handler: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Validator

TMethod

Нет

Процедура-валидатор

Handler

TRoutine

Нет

Процедура-обработчик

Замечания:

Создает новый объект класса TAsyncHandler.

33.3. Метод GetIsAccessible (Доступен)

Метод экземпляра класса TAsyncHandler.
function TAsyncHandler.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

33.4. Метод ValidateInstantMessage (Доступен обработчик с уведомлением сообщением)

Метод класса (статический метод) класса TAsyncHandler.
class function TAsyncHandler.ValidateInstantMessage(Routine: TRoutine): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Замечания:

Возвращает значение типа Boolean.

33.5. Метод ValidateWithoutNotification (Доступен обработчик без уведомления)

Метод класса (статический метод) класса TAsyncHandler.
class function TAsyncHandler.ValidateWithoutNotification(Routine: TRoutine): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Замечания:

Возвращает значение типа Boolean.

34. Класс TAsyncHandlerAccess (Доступ к обработчикам отложенного выполнения)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

34.1. Конструктор Create (Конструктор доступа к обработчикам отложенного выполнения)

Конструктор класса TAsyncHandlerAccess.
1constructor TAsyncHandlerAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TAsyncHandlerAccess.

35. Класс TAsyncTask (Задачи отложенного выполнения)

Объекты класса не именованы.

35.1. Свойства

Свойства класса TAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Created

datetime

Да

Видимо пользователю

Только для чтения

Время создания

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Состояние

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Язык

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

Обработчик

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Представление формы

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Объект

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Время начала выполнения

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Время завершения выполнения

Duration

time

Нет

Видимо пользователю

Только для чтения

Длительность

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

Выделено

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Цвет строки

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

Группа

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Содержимое группы готово

35.2. Конструктор Create (Конструктор задачи отложенного выполнения)

Конструктор класса TAsyncTask.
1constructor TAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Подпрограмма

Object

TObject

Нет

Объект

FormView

TFormView

Нет

Представление формы

Handler

TAsyncHandler

Да

Обработчик

Language

TLanguage

Да

Язык

Замечания:

Создает новый объект класса TAsyncTask.

35.3. Деструктор Destroy (Деструктор объекта)

Деструктор класса TAsyncTask.
destructor TAsyncTask.Destroy;
Переопределяет метод в TObject.Destroy.

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TAsyncTask или его наследника.

35.4. Метод Archive (Отправить в архив)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Archive;
Метод не имеет параметров.

35.5. Метод CreateGroup (Создать группу)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.CreateGroup(Group: clob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Group

clob

Нет

Группа

35.6. Метод Finish (Зафиксировать завершение выполнения)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Finish(Success: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Success

Boolean

Да

Выполнено успешно

35.7. Метод HandleInstantMessage (Обработчик с уведомлением сообщением)

Метод экземпляра класса TAsyncTask.
1procedure TAsyncTask.HandleInstantMessage(Success: Boolean;
2  ErrorMessage: string[2000]; ExceptionClass: string[2000];
3  NativeMessage: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Success

Boolean

Да

Выполнено успешно

ErrorMessage

string[2000]

Нет

Сообщение об ошибке

ExceptionClass

string[2000]

Нет

Класс ошибки

NativeMessage

string[2000]

Нет

Системное сообщение об ошибке

35.8. Метод HasAsyncTasks (Имеются задачи отложенного выполнения)

Метод класса (статический метод) класса TAsyncTask.
class function TAsyncTask.HasAsyncTasks: Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

35.9. Метод Start (Зафиксировать начало выполнения)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Start;
Метод скрыт от пользователя.

Метод не имеет параметров.

35.10. Метод Ole-объекта PerformImmediate (Выполнить немедленно)

Метод Ole-объекта класса TAsyncTask.

Метод Ole-объекта не имеет параметров.

36. Класс TAsyncTaskParameterValue (Значения параметров задачи отложенного выполнения)

Объекты класса не именованы.

36.1. Свойства

Свойства класса TAsyncTaskParameterValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Temporary

Boolean

Да

Видимо пользователю

Чтение/Запись

Временный объект

36.2. Конструктор Create (Конструктор значения параметров задачи отложенного выполнения)

Конструктор класса TAsyncTaskParameterValue.
1constructor TAsyncTaskParameterValue.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Domain: TDomain; Position: Integer;
4  Group: string[128]; Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]; IntValue: Integer; FloatValue: float; DateValue: date;
6  TimeValue: time; DateTimeValue: datetime; ObjectValue: TObject;
7  BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
8  ExternalDataValue: <external data>; Temporary: Boolean): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Унаследовано от TTypedValue.Create

Position

Integer

Да

Group

string[128]

Нет

Tab

string[128]

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

StrValue

string[2000]

Нет

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

Temporary

Boolean

Да

Временный объект

Замечания:

Создает новый объект класса TAsyncTaskParameterValue.

36.3. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TAsyncTaskParameterValue.
function TAsyncTaskParameterValue.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

37. Класс TBanGroup (Группы запретов)

37.1. Свойства

Свойства класса TBanGroup:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступна

37.2. Конструктор Create (Конструктор группы запретов)

Конструктор класса TBanGroup.
1constructor TBanGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TBanGroup.

37.3. Метод CreateAllBans (Сгенерировать запреты для класса)

Метод экземпляра класса TBanGroup.
1procedure TBanGroup.CreateAllBans(BannedClass: TClass; BanClass: Boolean;
2  BanRoutines: Boolean; BanProperties: Boolean; AllowRead: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

BannedClass

TClass

Да

Запрещаемый класс

BanClass

Boolean

Да

Запретить доступ к объектам класса

BanRoutines

Boolean

Да

Запретить подпрограммы

BanProperties

Boolean

Да

Запретить свойства

AllowRead

Boolean

Да

Чтение свойств разрешено

37.4. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TBanGroup.
function TBanGroup.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

38. Класс TBanGroupAccess (Доступ к группам запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

38.1. Конструктор Create (Конструктор доступа к группе запретов)

Конструктор класса TBanGroupAccess.
1constructor TBanGroupAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TBanGroup; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TBanGroup

Да

Группа запретов

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TBanGroupAccess.

39. Класс TBanGroupItem (Элементы группы запретов)

39.1. Свойства

Свойства класса TBanGroupItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Мастер

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

39.2. Конструктор Create (Конструктор элемента группы запретов)

Конструктор класса TBanGroupItem.
1constructor TBanGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TBanGroupItem.

40. Класс TBlobDomain (Большие объекты)

40.1. Свойства

Свойства класса TBlobDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

BlobSubtype

TBlobSubtype

Да

Видимо пользователю

Чтение/Запись

Подтип

Extension

string[10]

Нет

Видимо пользователю

Чтение/Запись

Расширение

ShowInPlace

Boolean

Да

Видимо пользователю

Чтение/Запись

Редактировать по месту

EditorClassID

string[128]

Нет

Видимо пользователю

Чтение/Запись

Идентификатор класса-редактора

EditorCodeLibrary

TAccessibleFile

Нет

Видимо пользователю

Чтение/Запись

Библиотека кода редактора

SizeLimit

Integer

Нет

Видимо пользователю

Чтение/Запись

Ограничение на размер

IsBinary

Boolean

Да

Видимо пользователю

Только для чтения

Двоичные данные

40.2. Конструктор Create (Конструктор домена больших объектов)

Конструктор класса TBlobDomain.
1constructor TBlobDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; BlobSubtype: TBlobSubtype; SizeLimit: Integer;
4  Extension: string[10]; ShowInPlace: Boolean; EditorClassID: string[128];
5  EditorCodeLibrary: TAccessibleFile): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

BlobSubtype

TBlobSubtype

Да

Подтип

SizeLimit

Integer

Нет

Ограничение на размер

Extension

string[10]

Нет

Расширение

ShowInPlace

Boolean

Да

Редактировать по месту

EditorClassID

string[128]

Нет

Идентификатор класса-редактора

EditorCodeLibrary

TAccessibleFile

Нет

Библиотека кода редактора

Замечания:

Создает новый объект класса TBlobDomain.

40.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TBlobDomain.
function TBlobDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

41. Класс TBooleanDomain (Логические)

41.1. Свойства

Свойства класса TBooleanDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

TrueValue

string[64]

Да

Видимо пользователю

Чтение/Запись

Значение "Истина"

FalseValue

string[64]

Да

Видимо пользователю

Чтение/Запись

Значение "Ложь"

41.2. Конструктор Create (Конструктор логического домена)

Конструктор класса TBooleanDomain.
1constructor TBooleanDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; TrueValue: string[64]; FalseValue: string[64]): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

TrueValue

string[64]

Да

Значение "Истина"

FalseValue

string[64]

Да

Значение "Ложь"

Замечания:

Создает новый объект класса TBooleanDomain.

41.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TBooleanDomain.
function TBooleanDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

42. Класс TClass (Классы)

Объекты класса образуют иерархию.

42.1. Свойства

Свойства класса TClass:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Чтение/Запись

Статус репликации

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Унаследовано от TObject

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Является иерархическим

SecurityModel

TSecurityModel

Да

Видимо пользователю

Чтение/Запись

Модель безопасности

DefaultAccessor

TSecurityAccount

Нет

Видимо пользователю

Чтение/Запись

Роль доступа по умолчанию

UnNamed

Boolean

Да

Видимо пользователю

Чтение/Запись

Неименованный

NameExpression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение имени объекта

DescriptionExpression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение наименования объекта

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

ModelX

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Положение в модели (абсцисса)

ModelY

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Положение в модели (ордината)

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Indexed

Boolean

Да

Видимо пользователю

Чтение/Запись

Индексируется

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

Localizable

Boolean

Да

Видимо пользователю

Чтение/Запись

Локализуемый

DBMSName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта СУБД

CreatorsCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество ролей-создателей

MasterClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс-мастер

HasProfiles

Boolean

Да

Видимо пользователю

Только для чтения

Контролируется профилями

ApproxObjectCount

Integer

Нет

Видимо пользователю

Только для чтения

Оценка количества объектов

42.2. Конструктор Create (Конструктор класса)

Конструктор класса TClass.
1constructor TClass.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  MasterClass: TClass; IsHierarhical: Boolean;
4  ReplicationStatus: TReplicationStatus; SecurityModel: TSecurityModel;
5  DefaultAccessor: TSecurityAccount; Logged: Boolean; UnNamed: Boolean;
6  NameExpression: clob; DescriptionExpression: clob; CreateConstructor: Boolean;
7  Category: string[128]; Indexed: Boolean; Localizable: Boolean): TClass;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

MasterClass

TClass

Нет

Класс-мастер

IsHierarhical

Boolean

Да

Является иерархическим

ReplicationStatus

TReplicationStatus

Да

Статус репликации

SecurityModel

TSecurityModel

Да

Модель безопасности

DefaultAccessor

TSecurityAccount

Нет

Роль доступа по умолчанию

Logged

Boolean

Да

Протоколировать

UnNamed

Boolean

Да

Неименованный

NameExpression

clob

Нет

Выражение имени объекта

DescriptionExpression

clob

Нет

Выражение наименования объекта

CreateConstructor

Boolean

Да

Создать конструктор

Category

string[128]

Нет

Категория

Indexed

Boolean

Да

Индексируется

Localizable

Boolean

Да

Локализуемый

Замечания:

Создает новый объект класса TClass.

42.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TClass.
procedure TClass.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

42.4. Метод GenerateConstructor (Сгенерировать текст конструктора)

Метод экземпляра класса TClass.
procedure TClass.GenerateConstructor;
Метод не имеет параметров.

42.5. Метод GetApproxObjectsCount (Получить оценку количества объектов)

Метод экземпляра класса TClass.
function TClass.GetApproxObjectsCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

42.6. Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TClass.
function TClass.GetDBMSName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

42.7. Метод GetHasProfiles (Контролируется профилями)

Метод экземпляра класса TClass.
function TClass.GetHasProfiles: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

42.8. Метод GetObjectCount (Количество объектов)

Метод экземпляра класса TClass.
function TClass.GetObjectCount(Exact: Boolean): string[20];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Exact

Boolean

Да

Строго

Замечания:

Возвращает значение типа string[20].

42.9. Метод ListChildProperties (Список дочерних свойств)

Метод класса (статический метод) класса TClass.
1class procedure TClass.ListChildProperties(ParentName: string[64];
2  TemporaryList: TObjectList; PersistentList: TObjectList);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ParentName

string[64]

Да

Имя свойства

TemporaryList

TObjectList

Нет

Временный список

PersistentList

TObjectList

Нет

Постоянный список

42.10. Метод ListProperties (Список свойств)

Метод экземпляра класса TClass.
function TClass.ListProperties(Scope: TScope): TObjectList;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Scope

TScope

Да

Область видимости

Замечания:

Возвращает значение типа TObjectList.

42.11. Метод ListRoutines (Список подпрограмм)

Метод экземпляра класса TClass.
function TClass.ListRoutines(Scope: TScope): TObjectList;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Scope

TScope

Да

Область видимости

Замечания:

Возвращает значение типа TObjectList.

42.12. Метод MarkLocalizableMetadata (Установить поля метаданных как локализуемые)

Метод класса (статический метод) класса TClass.
class procedure TClass.MarkLocalizableMetadata;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

42.13. Метод MemberByName (Член класса по имени)

Метод экземпляра класса TClass.
function TClass.MemberByName(Name: string[64]; Class: TClass): TClassMember;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Class

TClass

Да

Класс

Замечания:

Возвращает значение типа TClassMember.

42.14. Метод SetLocalizable (Установить значение свойства "Локализуемый")

Метод экземпляра класса TClass.
procedure TClass.SetLocalizable(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

42.15. Метод Ole-объекта CheckAllExcelTemplates (Проверить шаблоны отчетов Excel)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

42.16. Метод Ole-объекта CheckAllOleObjectMethods (Проверить все методы Ole-объекта)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

42.17. Метод Ole-объекта CheckAllTemplates (Проверить все шаблоны)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

42.18. Метод Ole-объекта CheckAllWordTemplates (Проверить шаблоны отчетов Word)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

42.19. Метод Ole-объекта CheckAllXSLTTemplates (Проверить шаблоны отчетов XSLT)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

42.20. Метод Ole-объекта LoadImagesFromFolder (Загрузить изображения из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Prefix

string[128]

Нет

Префикс имени файла

Замечания:

Возвращает значение типа Integer.

42.21. Метод Ole-объекта LoadMethodsFromFolder (Загрузить методы из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

42.22. Метод Ole-объекта LoadResourceFile (Загрузить файл ресурсов)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

XliffFileName

string[255]

Да

Файл ресурсов

Замечания:

Возвращает значение типа Integer.

42.23. Метод Ole-объекта LoadTemplatesFromFolder (Загрузить шаблоны из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

42.24. Метод Ole-объекта SaveImagesToFolder (Сохранить изображения в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Prefix

string[128]

Нет

Префикс имени файла

Замечания:

Возвращает значение типа Integer.

42.25. Метод Ole-объекта SaveMethodsToFolder (Сохранить методы в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

42.26. Метод Ole-объекта SaveTemplatesToFolder (Сохранить шаблоны в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

ExportCodeModules

Boolean

Да

Экспортировать программные модули

Замечания:

Возвращает значение типа Integer.

42.27. Шаблон XSLT-отчета ClassesDiagram (Диаграмма классов)

Шаблон XSLT-отчета класса (статический шаблон) класса TClass.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ShowFields

Boolean

Да

Показывать поля

ShowMethods

Boolean

Да

Показывать методы

ShowProperties

Boolean

Да

Показывать свойства

ShowParameters

Boolean

Да

Показывать параметры

ShowMetadata

Boolean

Да

Показывать метаданные

GroupByMaster

Boolean

Да

Группировать по принадлежности

43. Класс TClassBan (Запрет на класс)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

43.1. Свойства

Свойства класса TClassBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

43.2. Конструктор Create (Конструктор запрета на класс)

Конструктор класса TClassBan.
1constructor TClassBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

Замечания:

Создает новый объект класса TClassBan.

44. Класс TClassDomain (Ссылки на объекты)

44.1. Свойства

Свойства класса TClassDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

ClassOfDomain

TClass

Нет

Видимо пользователю

Чтение/Запись

Класс домена

ClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Чтение/Запись

Статус репликации класса

ShowObjectInfoType

TShowObjectInfoType

Да

Видимо пользователю

Чтение/Запись

Тип представления объектов

DeleteRule

TDeleteRule

Да

Видимо пользователю

Чтение/Запись

Правило удаления

FilterCondition

clob

Нет

Видимо пользователю

Чтение/Запись

Условие отбора

View

TCustomView

Нет

Видимо пользователю

Чтение/Запись

Представление

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

44.2. Конструктор Create (Конструктор домена-ссылки)

Конструктор класса TClassDomain.
1constructor TClassDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; ClassOfDomain: TClass; View: TCustomView;
4  FilterCondition: clob; ShowObjectInfoType: TShowObjectInfoType;
5  DeleteRule: TDeleteRule; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

ClassOfDomain

TClass

Да

Класс домена

View

TCustomView

Нет

Представление для выбора

FilterCondition

clob

Нет

Условие отбора

ShowObjectInfoType

TShowObjectInfoType

Да

Тип представления объектов

DeleteRule

TDeleteRule

Да

Правило удаления

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TClassDomain.

44.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TClassDomain.
function TClassDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

45. Класс TClassMember (Члены класса)

45.1. Свойства

Свойства класса TClassMember:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределен

45.2. Конструктор Create (Конструктор члена класса)

Конструктор класса TClassMember.
1constructor TClassMember.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TClassMember.

45.3. Метод GetOverride (Переопределен)

Метод экземпляра класса TClassMember.
function TClassMember.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

45.4. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TClassMember.
function TClassMember.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

46. Класс TCommandButton (Командные кнопки)

46.1. Свойства

Свойства класса TCommandButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TRoutine

Да

Видимо пользователю

Только для чтения

Мастер

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

MasterMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер подпрограммы

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomButton

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределена

Parameter

TParameter

Нет

Видимо пользователю

Чтение/Запись

Связанный параметр

46.2. Конструктор Create (Конструктор командной кнопки)

Конструктор класса TCommandButton.
1constructor TCommandButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean; Parameter: TParameter): TObject;
Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Group

string[128]

Нет

Унаследовано от TCustomButton.Create

Tab

string[128]

Нет

Script

clob

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

Parameter

TParameter

Нет

Связанный параметр

Замечания:

Создает новый объект класса TCommandButton.

46.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TCommandButton.
class function TCommandButton.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

46.4. Метод GetOverride (Переопределена)

Метод экземпляра класса TCommandButton.
function TCommandButton.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

47. Класс TContextKey (Ключи контекстной помощи)

Объекты класса не именованы.

47.1. Свойства

Свойства класса TContextKey:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Storage

string[64]

Да

Видимо пользователю

Чтение/Запись

Хранилище

LinkedObject

TObject

Нет

Видимо пользователю

Чтение/Запись

Связанный объект

LinkedObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс связанного объекта

LinkedObjectMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер связанного объекта

47.2. Конструктор Create (Конструктор ключа)

Конструктор класса TContextKey.
1constructor TContextKey.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Storage: string[64]; LinkedObject: TObject): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Ключевое словосочетание

Class

TClass

Нет

Унаследовано от TObject.Create

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Storage

string[64]

Да

Хранилище

LinkedObject

TObject

Нет

Связанный объект

Замечания:

Создает новый объект класса TContextKey.

47.3. Метод GenerateAllKeys (Сгенерировать ключи)

Метод класса (статический метод) класса TContextKey.
class procedure TContextKey.GenerateAllKeys(Storage: string[64]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

48. Класс TCustomButton (Кнопки)

48.1. Свойства

Свойства класса TCustomButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

48.2. Конструктор Create (Конструктор кнопки)

Конструктор класса TCustomButton.
1constructor TCustomButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Script

clob

Нет

Скрипт

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

Замечания:

Создает новый объект класса TCustomButton.

49. Класс TCustomView (Абстрактное представление)

49.1. Свойства

Свойства класса TCustomView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Класс

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс-мастер показываемого

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

Статус репликации класса

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Иерархическое

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

Количество данных незначительно

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство выделенного шрифта

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

Предсобранное

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Вызывать перед открытием

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство цвета

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Параметры оптимизации

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

Имеются условия отбора

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

Имеет колонки со специфическими именами

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

49.2. Конструктор Create (Конструктор абстрактного представления)

Конструктор класса TCustomView.
1constructor TCustomView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Класс

ColorProperty

TProperty

Нет

Свойство цвета

BoldProperty

TProperty

Нет

Свойство выделенного шрифта

Skimpy

Boolean

Да

Количество данных незначительно

PreCompiled

Boolean

Да

Предсобранное

PreOpenRoutine

TRoutine

Нет

Вызывать перед открытием

Замечания:

Создает новый объект класса TCustomView.

49.3. Метод BuildDefaultActions (Создать действия по умолчанию)

Метод экземпляра класса TCustomView.
1procedure TCustomView.BuildDefaultActions(AddConstructor: Boolean;
2  AddDestructor: Boolean; AddMethods: Boolean; AddReports: Boolean;
3  AddCopyPasteActions: Boolean; AddStandartActions: Boolean;
4  PositionStep: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

AddConstructor

Boolean

Да

Добавить конструктор

AddDestructor

Boolean

Да

Добавить деструктор

AddMethods

Boolean

Да

Добавить методы

AddReports

Boolean

Да

Добавить шаблоны отчетов

AddCopyPasteActions

Boolean

Да

Добавить работу с буфером обмена

AddStandartActions

Boolean

Да

Добавить стандартные действия

PositionStep

Integer

Да

Шаг

49.4. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TCustomView.
procedure TCustomView.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

50. Класс TDataBase (Базы данных)

50.1. Свойства

Свойства класса TDataBase:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

GUID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущей

Protected

Boolean

Да

Видимо пользователю

Чтение/Запись

Защищена от изменений

50.2. Конструктор Create (Конструктор базы данных)

Конструктор класса TDataBase.
1constructor TDataBase.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  GUID: string[38]; Protected: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

GUID

string[38]

Да

GUID

Protected

Boolean

Да

Защищена

Замечания:

Создает новый объект класса TDataBase.

51. Класс TDateDomain (Даты)

51.1. Конструктор Create (Конструктор домена даты)

Конструктор класса TDateDomain.
1constructor TDateDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Замечания:

Создает новый объект класса TDateDomain.

51.2. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateDomain.
function TDateDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

52. Класс TDateTimeDomain (Даты со временем)

52.1. Свойства

Свойства класса TDateTimeDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

HideSeconds

Boolean

Да

Видимо пользователю

Чтение/Запись

Не показывать секунды

52.2. Конструктор Create (Конструктор домена даты со временем)

Конструктор класса TDateTimeDomain.
1constructor TDateTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

HideSeconds

Boolean

Да

Не показывать секунды

Замечания:

Создает новый объект класса TDateTimeDomain.

52.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateTimeDomain.
function TDateTimeDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

53. Класс TDependency (Зависимости)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

53.1. Свойства

Свойства класса TDependency:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Dependent

TObject

Нет

Видимо пользователю

Чтение/Запись

Зависимый объект

DependentClass

TClass

Да

Видимо пользователю

Только для чтения

Класс зависимого объекта

DependentMaster

TObject

Да

Видимо пользователю

Только для чтения

Мастер зависимого объекта

DependentExternal

string[256]

Нет

Видимо пользователю

Чтение/Запись

Внешний зависимый объект

DependedOn

TObject

Да

Видимо пользователю

Чтение/Запись

Зависит от

DependedOnClass

TClass

Да

Видимо пользователю

Только для чтения

Класс объекта, от которого зависит

DependedOnMaster

TObject

Да

Видимо пользователю

Только для чтения

Мастер объекта, от которого зависит

53.2. Конструктор Create (Конструктор зависимости)

Конструктор класса TDependency.
1constructor TDependency.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Dependent: TObject; DependentExternal: string[256];
4  DependedOn: TObject): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Dependent

TObject

Нет

Зависимый объект

DependentExternal

string[256]

Нет

Внешний зависимый объект

DependedOn

TObject

Да

Зависит от

Замечания:

Создает новый объект класса TDependency.

53.3. Метод Install (Установить)

Метод класса (статический метод) класса TDependency.
1class procedure TDependency.Install(ADependent: TObject;
2  ADependentExternal: string[256]; ADependedOn: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ADependent

TObject

Нет

Зависимый объект

ADependentExternal

string[256]

Нет

Внешний зависимый объект

ADependedOn

TObject

Да

Зависит от

54. Класс TDomain (Домены)

54.1. Свойства

Свойства класса TDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Обязательно для заполнения

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество внешних зависимостей

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Сводка

54.2. Конструктор Create (Конструктор домена)

Конструктор класса TDomain.
1constructor TDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TDomain;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Обязательно для заполнения

Замечания:

Создает новый объект класса TDomain.

54.3. Метод GetDefinition (Определение домена)

Метод экземпляра класса TDomain.
function TDomain.GetDefinition: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

54.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDomain.
function TDomain.GetSummary: string[2000];
Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

55. Класс TEnumerationDomain (Перечисления)

55.1. Свойства

Свойства класса TEnumerationDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

ShowNames

Boolean

Да

Видимо пользователю

Чтение/Запись

Показывать имена

BasedOnDomain

TEnumerationDomain

Нет

Видимо пользователю

Чтение/Запись

Расширяет домен

ItemCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество элементов

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

55.2. Конструктор Create (Конструктор перечисления)

Конструктор класса TEnumerationDomain.
1constructor TEnumerationDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; ShowNames: Boolean;
4  BasedOnDomain: TEnumerationDomain; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

ShowNames

Boolean

Да

Показывать имена элементов

BasedOnDomain

TEnumerationDomain

Нет

Расширяет домен

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TEnumerationDomain.

55.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TEnumerationDomain.
function TEnumerationDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

55.4. Метод ListItems (Список элементов)

Метод экземпляра класса TEnumerationDomain.
function TEnumerationDomain.ListItems: TObjectList;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.

56. Класс TEnumerationItem (Элементы перечислений)

56.1. Свойства

Свойства класса TEnumerationItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

56.2. Конструктор Create (Конструктор элемента перечисления)

Конструктор класса TEnumerationItem.
1constructor TEnumerationItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TEnumerationItem.

56.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TEnumerationItem.
class function TEnumerationItem.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

57. Класс TExcelAsyncTask (Задачи отложенного выполнения отчетов Excel)

Объекты класса не именованы.

57.1. Свойства

Свойства класса TExcelAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TAsyncTask

Created

datetime

Да

Видимо пользователю

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TAsyncTask

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Duration

time

Нет

Видимо пользователю

Только для чтения

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Format

TExcelOutputFormat

Да

Видимо пользователю

Чтение/Запись

Формат

ColorMode

TOutputColorMode

Да

Видимо пользователю

Чтение/Запись

Режим цветопередачи

EmbedFonts

Boolean

Да

Видимо пользователю

Чтение/Запись

Внедрять шрифты

57.2. Конструктор Create (Конструктор задачи отложенного выполнения отчетов Excel)

Конструктор класса TExcelAsyncTask.
1constructor TExcelAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TExcelOutputFormat;
5  ColorMode: TOutputColorMode; EmbedFonts: Boolean): TObject;
Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Унаследовано от TAsyncTask.Create

Object

TObject

Нет

FormView

TFormView

Нет

Handler

TAsyncHandler

Да

Language

TLanguage

Да

Format

TExcelOutputFormat

Да

Формат

ColorMode

TOutputColorMode

Да

Режим цветопередачи

EmbedFonts

Boolean

Да

Внедрять шрифты

Замечания:

Создает новый объект класса TExcelAsyncTask.

58. Класс TExcelTemplate (Шаблоны отчетов Excel)

58.1. Свойства

Свойства класса TExcelTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

PlaceDataOnSheet

TExcelSheetKind

Да

Видимо пользователю

Чтение/Запись

Лист для переноса данных

MacroName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя макроса

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

58.2. Конструктор Create (Конструктор шаблона Excel)

Конструктор класса TExcelTemplate.
1constructor TExcelTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  PlaceDataOnSheet: TExcelSheetKind; MacroName: string[128];
7  IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

blob

Нет

Данные шаблона

PlaceDataOnSheet

TExcelSheetKind

Да

Лист для переноса данных

MacroName

string[128]

Нет

Имя макроса

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TExcelTemplate.

58.3. Метод Ole-объекта CheckExcelTemplate (Проверить шаблон отчетов Excel)

Метод Ole-объекта класса TExcelTemplate.

Метод Ole-объекта не имеет параметров.

59. Класс TExternalDataDomain (Внешние данные)

59.1. Свойства

Свойства класса TExternalDataDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

NamesSequence

TSequence

Нет

Видимо пользователю

Чтение/Запись

Последовательность для формирования имен

ContentDomain

TBlobDomain

Да

Видимо пользователю

Чтение/Запись

Домен содержимого

ContentDomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена содержимого

ContentDomainBlobSubtype

TBlobSubtype

Да

Видимо пользователю

Только для чтения

Подтип домена содержимого

ContentDomainExtension

string[10]

Нет

Видимо пользователю

Только для чтения

Расширение домена содержимого

ResourceCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество ресурсов

ContentDependentNames

Boolean

Да

Видимо пользователю

Чтение/Запись

Имя зависит от содержимого

Compress

Boolean

Да

Видимо пользователю

Чтение/Запись

Сжимать содержимое

59.2. Конструктор Create (Конструктор домена внешних данных)

Конструктор класса TExternalDataDomain.
1constructor TExternalDataDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; NamesSequence: TSequence;
4  ContentDomain: TBlobDomain; ContentDependentNames: Boolean;
5  Compress: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

NamesSequence

TSequence

Нет

Последовательность для формирования имен

ContentDomain

TBlobDomain

Да

Домен содержимого

ContentDependentNames

Boolean

Да

Имя зависит от содержимого

Compress

Boolean

Да

Сжимать содержимое

Замечания:

Создает новый объект класса TExternalDataDomain.

59.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TExternalDataDomain.
function TExternalDataDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

60. Класс TExternalDataResource (Ресурсы внешних данных)

60.1. Свойства

Свойства класса TExternalDataResource:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

GUID

string[38]

Да

Видимо пользователю

Чтение/Запись

GUID

Protocol

TExternalDataProtocol

Да

Видимо пользователю

Чтение/Запись

Протокол доступа

Host

string[64]

Да

Видимо пользователю

Чтение/Запись

Хост

Port

Integer

Нет

Видимо пользователю

Чтение/Запись

Порт

Path

string[255]

Да

Видимо пользователю

Чтение/Запись

Папка

UserName

string[255]

Нет

Видимо пользователю

Чтение/Запись

Имя пользователя

Password

string[255]

Нет

Видимо пользователю

Чтение/Запись

Пароль

ReadOnly

Boolean

Да

Видимо пользователю

Чтение/Запись

Только для чтения

60.2. Конструктор Create (Конструктор ресурса внешних данных)

Конструктор класса TExternalDataResource.
1constructor TExternalDataResource.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; GUID: string[38]; Protocol: TExternalDataProtocol;
4  Host: string[64]; Port: Integer; Path: string[255]; UserName: string[255];
5  Password: string[255]; ReadOnly: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

GUID

string[38]

Да

GUID

Protocol

TExternalDataProtocol

Да

Протокол доступа

Host

string[64]

Да

Хост

Port

Integer

Нет

Порт

Path

string[255]

Да

Папка

UserName

string[255]

Нет

Имя пользователя

Password

string[255]

Нет

Пароль

ReadOnly

Boolean

Да

Только для чтения

Замечания:

Создает новый объект класса TExternalDataResource.

60.3. Метод FileNameClause (Кляуза имени поля)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.FileNameClause(FieldName: string[64]): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

FieldName

string[64]

Да

Имя поля

Замечания:

Возвращает значение типа string[2000].

60.4. Метод FindUsedName (Найти использованное имя)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.FindUsedName(Name: string[77]): clob;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[77]

Да

Имя

Замечания:

Возвращает значение типа clob.

60.5. Метод GetUsedFileNames (Получить список использованных имен)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.GetUsedFileNames: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

60.6. Метод Ole-объекта CheckExternalData (Проверить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя

Тип

Обязательно

Значение

FilesFolder

string[255]

Да

Файлы внешних данных

TrashFolder

string[255]

Да

Папка для неиспользуемых файлов

60.7. Метод Ole-объекта SaveExternalData (Сохранить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка для сохранения

61. Класс TField (Поля)

61.1. Свойства

Свойства класса TField:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Indexed

Boolean

Да

Видимо пользователю

Чтение/Запись

Индексируется

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

Localizable

Boolean

Да

Видимо пользователю

Чтение/Запись

Локализуемое

61.2. Конструктор Create (Конструктор поля)

Конструктор класса TField.
1constructor TField.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; CreateProperty: Boolean; CreateConstructorParameter: Boolean;
4  CreateViewColumns: Boolean; Logged: Boolean; Indexed: Boolean;
5  Localizable: Boolean): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

CreateProperty

Boolean

Да

Создать свойство

CreateConstructorParameter

Boolean

Да

Создать параметр конструктора

CreateViewColumns

Boolean

Да

Создать колонку во всех представлениях

Logged

Boolean

Да

Протоколировать

Indexed

Boolean

Да

Индексируется

Localizable

Boolean

Да

Локализуемое

Замечания:

Создает новый объект класса TField.

61.3. Метод SetLocalizable (Установить значение свойства "Локализуемое")

Метод экземпляра класса TField.
procedure TField.SetLocalizable(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

62. Класс TFileNameDomain (Имена файлов)

62.1. Свойства

Свойства класса TFileNameDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TStringDomain

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

FileMustExist

Boolean

Да

Видимо пользователю

Чтение/Запись

Файл должен существовать

DefaultExtension

string[10]

Нет

Видимо пользователю

Чтение/Запись

Расширение по умолчанию

OverwritePrompt

Boolean

Да

Видимо пользователю

Чтение/Запись

Запрос перезаписи

62.2. Конструктор Create (Конструктор имени файла)

Конструктор класса TFileNameDomain.
1constructor TFileNameDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean; FileMustExist: Boolean;
7  DefaultExtension: string[10]; OverwritePrompt: Boolean): TObject;
Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Унаследовано от TStringDomain.Create

AllowLeadingSpaces

Boolean

Да

AllowTrailingSpaces

Boolean

Да

AllowSpaceDuplication

Boolean

Да

CharacterSet

string[2000]

Нет

FirstCharacterSet

string[2000]

Нет

CaseMode

Boolean

Нет

Mask

string[2000]

Нет

CaseInsensitiveSearch

Boolean

Да

FileMustExist

Boolean

Да

Файл должен существовать

DefaultExtension

string[10]

Нет

Расширение по умолчанию

OverwritePrompt

Boolean

Да

Запрос перезаписи

Замечания:

Создает новый объект класса TFileNameDomain.

62.3. Метод Change (Изменение объекта)

Метод экземпляра класса TFileNameDomain.
procedure TFileNameDomain.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

62.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFileNameDomain.
function TFileNameDomain.GetSummary: string[2000];
Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

63. Класс TFilmstripView (Представление-диафильм)

63.1. Свойства

Свойства класса TFilmstripView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomView

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

LegendProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-подпись

ThumbnailProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-значок

ImageProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-изображение

ThumbnailSize

Integer

Да

Видимо пользователю

Чтение/Запись

Размер значка

OrderProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство, определяющее порядок

63.2. Конструктор Create (Конструктор представления-диафильма)

Конструктор класса TFilmstripView.
1constructor TFilmstripView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  LegendProperty: TProperty; ThumbnailProperty: TProperty;
6  ImageProperty: TProperty; ThumbnailSize: Integer;
7  OrderProperty: TProperty): TObject;
Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Унаследовано от TCustomView.Create

ColorProperty

TProperty

Нет

BoldProperty

TProperty

Нет

Skimpy

Boolean

Да

PreCompiled

Boolean

Да

PreOpenRoutine

TRoutine

Нет

LegendProperty

TProperty

Нет

Свойство-подпись

ThumbnailProperty

TProperty

Нет

Свойство-значок

ImageProperty

TProperty

Нет

Свойство-изображение

ThumbnailSize

Integer

Да

Размер значка

OrderProperty

TProperty

Нет

Свойство, определяющее порядок

Замечания:

Создает новый объект класса TFilmstripView.

64. Класс TFloatDomain (Вещественные числа)

64.1. Свойства

Свойства класса TFloatDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Нет

Видимо пользователю

Чтение/Запись

Длина

DecimalPlaces

Integer

Нет

Видимо пользователю

Чтение/Запись

Количество десятичных знаков

MinValue

float

Нет

Видимо пользователю

Чтение/Запись

Минимальное значение

MaxValue

float

Нет

Видимо пользователю

Чтение/Запись

Максимальное значение

DigitGrouping

Boolean

Да

Видимо пользователю

Чтение/Запись

Разделять группы разрядов

64.2. Конструктор Create (Конструктор вещественного домена)

Конструктор класса TFloatDomain.
1constructor TFloatDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; DecimalPlaces: Integer; MinValue: float;
4  MaxValue: float; DigitGrouping: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Нет

Длина

DecimalPlaces

Integer

Нет

Количество десятичных знаков

MinValue

float

Нет

Минимальное значение

MaxValue

float

Нет

Максимальное значение

DigitGrouping

Boolean

Да

Разделять группы разрядов

Замечания:

Создает новый объект класса TFloatDomain.

64.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFloatDomain.
function TFloatDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

65. Класс TFolderNameDomain (Имена папок файловой системы)

65.1. Свойства

Свойства класса TFolderNameDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TStringDomain

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

FolderMustExist

Boolean

Да

Видимо пользователю

Чтение/Запись

Папка должна существовать

65.2. Конструктор Create (Конструктор имени папки)

Конструктор класса TFolderNameDomain.
1constructor TFolderNameDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; Length: Integer;
4  AllowLeadingSpaces: Boolean; AllowTrailingSpaces: Boolean;
5  AllowSpaceDuplication: Boolean; CharacterSet: string[2000];
6  FirstCharacterSet: string[2000]; CaseMode: Boolean; Mask: string[2000];
7  CaseInsensitiveSearch: Boolean; FolderMustExist: Boolean): TObject;
Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Унаследовано от TStringDomain.Create

AllowLeadingSpaces

Boolean

Да

AllowTrailingSpaces

Boolean

Да

AllowSpaceDuplication

Boolean

Да

CharacterSet

string[2000]

Нет

FirstCharacterSet

string[2000]

Нет

CaseMode

Boolean

Нет

Mask

string[2000]

Нет

CaseInsensitiveSearch

Boolean

Да

FolderMustExist

Boolean

Да

Папка должна существовать

Замечания:

Создает новый объект класса TFolderNameDomain.

65.3. Метод Change (Изменение объекта)

Метод экземпляра класса TFolderNameDomain.
procedure TFolderNameDomain.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

65.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFolderNameDomain.
function TFolderNameDomain.GetSummary: string[2000];
Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

66. Класс TForm (Формы)

66.1. Свойства

Свойства класса TForm:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

AutoOpen

Boolean

Да

Видимо пользователю

Чтение/Запись

Открывать автоматически

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение-иконка

IsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Доступна

IsAlive

Boolean

Да

Видимо пользователю

Чтение/Запись

"Живая"

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Вызывать перед открытием

66.2. Конструктор Create (Конструктор формы)

Конструктор класса TForm.
1constructor TForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  AutoOpen: Boolean; Position: Integer; Scope: TScope; Image: blob;
4  IsAlive: Boolean; PreOpenRoutine: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

AutoOpen

Boolean

Да

Открывать автоматически

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

Image

blob

Нет

Изображение-иконка

IsAlive

Boolean

Да

"Живая"

PreOpenRoutine

TRoutine

Нет

Вызывать перед открытием

Замечания:

Создает новый объект класса TForm.

66.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TForm.
procedure TForm.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

66.4. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TForm.
function TForm.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

66.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TForm.
class function TForm.GetNextPos: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

67. Класс TFormAccess (Доступ к формам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

67.1. Конструктор Create (Конструктор доступа к форме)

Конструктор класса TFormAccess.
1constructor TFormAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TForm; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TForm

Да

Форма

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TFormAccess.

68. Класс TFormBan (Запрет на форму)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

68.1. Свойства

Свойства класса TFormBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedForm

TForm

Да

Видимо пользователю

Чтение/Запись

Запрещаемая форма

68.2. Конструктор Create (Конструктор запрета на форму)

Конструктор класса TFormBan.
1constructor TFormBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedForm: TForm): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedForm

TForm

Да

Запрещаемая форма

Замечания:

Создает новый объект класса TFormBan.

69. Класс TFormOption (Настройки формы)

Имена объектов класса генерируются.

69.1. Свойства

Свойства класса TFormOption:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Option

TOption

Да

Видимо пользователю

Чтение/Запись

Настройка

Position

Integer

Нет

Видимо пользователю

Чтение/Запись

Позиция

ShowEmptyValue

Boolean

Да

Видимо пользователю

Чтение/Запись

Показывать пустое значение

69.2. Конструктор Create (Конструктор настройки формы)

Конструктор класса TFormOption.
1constructor TFormOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Option: TOption; Position: Integer; ShowEmptyValue: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Option

TOption

Да

Настройка

Position

Integer

Нет

Позиция

ShowEmptyValue

Boolean

Да

Показывать пустое значение

Замечания:

Создает новый объект класса TFormOption.

69.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormOption.
class function TFormOption.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Да

Мастер

Замечания:

Возвращает значение типа Integer.

70. Класс TFormView (Представления формы)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

70.1. Свойства

Свойства класса TFormView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления минимизированы

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство выделенного шрифта

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство цвета

Layout

TFormViewLayout

Да

Видимо пользователю

Чтение/Запись

Расположение

ChildrenOnTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления на закладках

ExplicitQuery

Boolean

Да

Видимо пользователю

Чтение/Запись

Явный запрос

SpacePercentage

Integer

Нет

Видимо пользователю

Чтение/Запись

Площадь, %

70.2. Конструктор Create (Конструктор представления формы)

Конструктор класса TFormView.
1constructor TFormView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout;
6  ExplicitQuery: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Представление

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

ChildrenOnTabs

Boolean

Да

Дочерние представления на закладках

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

Position

Integer

Да

Позиция

SpacePercentage

Integer

Нет

Площадь, %

Layout

TFormViewLayout

Да

Расположение

ExplicitQuery

Boolean

Да

Явный запрос

Замечания:

Создает новый объект класса TFormView.

70.3. Метод GetName (Сгенерировать имя объекта)

Метод экземпляра класса TFormView.
function TFormView.GetName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

70.4. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormView.
class function TFormView.GetNextPos(Parent: TObject; Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Master

TObject

Да

Мастер

Замечания:

Возвращает значение типа Integer.

71. Класс TFormViewAction (Действие-форма)

Объекты класса образуют иерархию.

71.1. Свойства

Свойства класса TFormViewAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Да

Видимо пользователю

Чтение/Запись

Представление формы

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

OverrideMasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Подменить свойство-главное

OverrideDetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Подменить свойство-подчиненное

71.2. Конструктор Create (Конструктор действия-формы)

Конструктор класса TFormViewAction.
1constructor TFormViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  FormView: TFormView; OverrideMasterProperty: TProperty;
5  OverrideDetailProperty: TClassMember): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

FormView

TFormView

Да

Представление формы

OverrideMasterProperty

TProperty

Нет

Подменить свойство-главное свойством

OverrideDetailProperty

TClassMember

Нет

Подменить свойство-подчиненное свойством

Замечания:

Создает новый объект класса TFormViewAction.

72. Класс TImportedReplica (Импортированные реплики)

Объекты класса не именованы.

72.1. Свойства

Свойства класса TImportedReplica:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

CRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма

MetadataCRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма метаданных

72.2. Конструктор Create (Конструктор импортированной реплики)

Конструктор класса TImportedReplica.
1constructor TImportedReplica.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CRC: string[8]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

CRC

string[8]

Нет

Контрольная сумма

Замечания:

Создает новый объект класса TImportedReplica.

73. Класс TInlineExpression (Встраиваемое выражение)

73.1. Свойства

Свойства класса TInlineExpression:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Expression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

73.2. Конструктор Create (Конструктор встраиваемого выражения)

Конструктор класса TInlineExpression.
1constructor TInlineExpression.Create(Name: string[30];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Expression: clob; Domain: TDomain): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Expression

clob

Нет

Выражение

Domain

TDomain

Да

Домен

Замечания:

Создает новый объект класса TInlineExpression.

74. Класс TInstantContact (Контакты)

Имена объектов класса генерируются.

74.1. Свойства

Свойства класса TInstantContact:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Владелец

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Владелец - текущий пользователь

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Status

TInstantContactStatus

Да

Видимо пользователю

Чтение/Запись

Статус

BackContact

TInstantContact

Нет

Видимо пользователю

Только для чтения

Ответный контакт

BackContactStatus

TInstantContactStatus

Да

Видимо пользователю

Только для чтения

Состояние ответного контакта

74.2. Конструктор Create (Конструктор контакта)

Конструктор класса TInstantContact.
1constructor TInstantContact.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Status: TInstantContactStatus): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Пользователь

Status

TInstantContactStatus

Да

Статус

Замечания:

Создает новый объект класса TInstantContact.

74.3. Метод AddContact (Добавить контакт)

Метод класса (статический метод) класса TInstantContact.
class function TInstantContact.AddContact(Master: TUser; User: TUser): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TUser

Да

Мастер

User

TUser

Да

Пользователь

Замечания:

Возвращает значение типа TObject.

74.4. Метод LastUsedContact (Получить последний использованный контакт)

Метод класса (статический метод) класса TInstantContact.
class function TInstantContact.LastUsedContact(AUser: TUser): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AUser

TUser

Да

Пользователь

Замечания:

Возвращает значение типа TObject.

75. Класс TInstantMessage (Сообщения)

Объекты класса не именованы.

75.1. Свойства

Свойства класса TInstantMessage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Владелец

User

TUser

Да

Видимо пользователю

Чтение/Запись

Пользователь

Message

string[255]

Да

Видимо пользователю

Только для чтения

Сообщение

DeliveryTime

datetime

Да

Видимо пользователю

Только для чтения

Время доставки

AttachmentType

TInstantMessageAttachmentType (None)

Да

Скрыто от пользователя

Только для чтения

Тип вложения

75.2. Конструктор Create (Конструктор сообщения)

Конструктор класса TInstantMessage.
1constructor TInstantMessage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Message: string[255]; DeliveryTime: datetime): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Пользователь

Message

string[255]

Да

Сообщение

DeliveryTime

datetime

Нет

Время доставки

Замечания:

Создает новый объект класса TInstantMessage.

75.3. Метод Archive (Отправить в архив)

Метод класса (статический метод) класса TInstantMessage.
1class procedure TInstantMessage.Archive(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

75.4. Метод Clear (Очистить)

Метод класса (статический метод) класса TInstantMessage.
1class procedure TInstantMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

76. Класс TInstantMessageAttachment (Сообщения с вложением)

Объекты класса не именованы.

76.1. Свойства

Свойства класса TInstantMessageAttachment:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TInstantMessage

User

TUser

Да

Видимо пользователю

Чтение/Запись

Message

string[255]

Да

Видимо пользователю

Только для чтения

DeliveryTime

datetime

Да

Видимо пользователю

Только для чтения

AttachmentType

TInstantMessageAttachmentType

Да

Видимо пользователю

Только для чтения

Тип вложения

FileBody

blob

Нет

Видимо пользователю

Только для чтения

Содержимое файла

FormView

TFormView

Нет

Видимо пользователю

Только для чтения

Представление формы

Form

TForm

Да

Видимо пользователю

Только для чтения

Форма

FormIsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Форма доступна

Object

TObject

Нет

Видимо пользователю

Только для чтения

Объект

HyperLink

string[256]

Нет

Видимо пользователю

Только для чтения

Гиперссылка

76.2. Конструктор Create (Конструктор сообщения с вложением)

Конструктор класса TInstantMessageAttachment.
1constructor TInstantMessageAttachment.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; User: TUser; Message: string[255];
4  DeliveryTime: datetime; FileName: string[255]; FileBaseName: string[128];
5  FileBody: blob; FormView: TFormView; Object: TObject; HyperLink: string[256];
6  AttachmentType: TInstantMessageAttachmentType): TObject;
Переопределяет метод в TInstantMessage.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Унаследовано от TInstantMessage.Create

Message

string[255]

Да

DeliveryTime

datetime

Нет

FileName

string[255]

Нет

Имя файла

FileBaseName

string[128]

Да

Базовое имя файла

FileBody

blob

Нет

Содержимое файла

FormView

TFormView

Нет

Представление

Object

TObject

Нет

Объект

HyperLink

string[256]

Нет

Гиперссылка

AttachmentType

TInstantMessageAttachmentType

Да

Тип приложения

Замечания:

Создает новый объект класса TInstantMessageAttachment.

77. Класс TIntegerDomain (Целые числа)

77.1. Свойства

Свойства класса TIntegerDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

MinValue

Integer

Нет

Видимо пользователю

Чтение/Запись

Минимальное значение

MaxValue

Integer

Нет

Видимо пользователю

Чтение/Запись

Максимальное значение

77.2. Конструктор Create (Конструктор целочисленного домена)

Конструктор класса TIntegerDomain.
1constructor TIntegerDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; MinValue: Integer; MaxValue: Integer): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

MinValue

Integer

Нет

Минимальное значение

MaxValue

Integer

Нет

Максимальное значение

Замечания:

Создает новый объект класса TIntegerDomain.

77.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TIntegerDomain.
function TIntegerDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

78. Класс TLanguage (Языки)

78.1. Свойства

Свойства класса TLanguage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

DatabaseLanguage

Boolean

Да

Видимо пользователю

Только для чтения

По умолчанию

IsCurrent

Boolean

Да

Видимо пользователю

Чтение/Запись

Является текущим

78.2. Конструктор Create (Конструктор языка)

Конструктор класса TLanguage.
1constructor TLanguage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TLanguage.

78.3. Метод GetCurrentLanguage (Получить текущий язык)

Метод класса (статический метод) класса TLanguage.
class function TLanguage.GetCurrentLanguage: TLanguage;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TLanguage.

78.4. Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TLanguage.
function TLanguage.GetIsCurrent: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

78.5. Метод SetIsCurrent (Установить язык как текущий)

Метод экземпляра класса TLanguage.
procedure TLanguage.SetIsCurrent(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

78.6. Метод Ole-объекта SaveResourceFile (Сохранить файл ресурсов)

Метод Ole-объекта класса TLanguage.

Параметры:

Имя

Тип

Обязательно

Значение

XliffFileName

string[255]

Да

Файл ресурсов

79. Класс TLanguageTranslation (Переводы)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

79.1. Свойства

Свойства класса TLanguageTranslation:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Language

TLanguage

Да

Видимо пользователю

Только для чтения

Язык

DatabaseLanguage

Boolean

Да

Видимо пользователю

Только для чтения

Язык используется по умолчанию

CurrentLanguage

Boolean

Да

Видимо пользователю

Только для чтения

Язык является текущим

Status

TTranslationStatus

Да

Видимо пользователю

Только для чтения

Состояние

OwnerObject

TObject

Нет

Скрыто от пользователя

Только для чтения

Владелец-объект

OwnerObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс объекта-владельца

OwnerField

TField

Нет

Скрыто от пользователя

Только для чтения

Владелец-поле

Owner

string[64]

Нет

Скрыто от пользователя

Только для чтения

Владелец

Translation

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Перевод

Original

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Оригинал

Identifier

string[2000]

Нет

Видимо пользователю

Только для чтения

Идентификатор

GlobalIdentifier

string[2000]

Нет

Видимо пользователю

Только для чтения

Глобальный идентификатор

79.2. Конструктор Create (Конструктор перевода)

Конструктор класса TLanguageTranslation.
1constructor TLanguageTranslation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Language: TLanguage; OwnerObject: TObject;
4  OwnerField: TField; Owner: string[64]; Translation: string[2000]): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Language

TLanguage

Да

Язык

OwnerObject

TObject

Нет

Владелец-объект

OwnerField

TField

Нет

Владелец-поле

Owner

string[64]

Нет

Владелец

Translation

string[2000]

Нет

Перевод

Замечания:

Создает новый объект класса TLanguageTranslation.

79.3. Метод Add (Создать набор переводов)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.Add(Owner: string[64];
2  Original: string[2000]): TLanguageTranslation;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Owner

string[64]

Да

Идентификатор

Original

string[2000]

Нет

Оригинал

Замечания:

Возвращает значение типа TLanguageTranslation.

79.4. Метод Append (Добавить перевод)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.Append(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]): TLanguageTranslation;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

AValue

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TLanguageTranslation.

79.5. Метод GetGlobalIdent (Получить глобальный идентификатор)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetGlobalIdent: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

79.6. Метод GetIdent (Получить идентификатор)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetIdent: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

79.7. Метод GetLanguageTranslation (Получить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.GetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

Замечания:

Возвращает значение типа string[2000].

79.8. Метод GetOriginal (Получить оригинал)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetOriginal: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

79.9. Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TLanguageTranslation.
class function TLanguageTranslation.GetResource(AOwner: string[64]): string[2000];
Переопределяет метод в TObject.GetResource.

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

Замечания:

Возвращает значение типа string[2000].

79.10. Метод Load (Загрузить значение)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.Load(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

79.11. Метод MarkAsTranslatable (Отметить как переводимый)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.MarkAsTranslatable;
Метод не имеет параметров.

79.12. Метод MarkAsUntranslatable (Отметить как непереводимый)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.MarkAsUntranslatable;
Метод не имеет параметров.

79.13. Метод SetLanguageTranslation (Установить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.SetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

AValue

string[2000]

Нет

Значение

79.14. Метод SetOriginal (Установить оригинал)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.SetOriginal(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

79.15. Метод SetOwnerSecurity (Установить атрибуты безопасности по владельцу-объекту)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.SetOwnerSecurity(AOwnerObject: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwnerObject

TObject

Нет

Владелец-объект

79.16. Метод SetTranslation (Установить перевод)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.SetTranslation(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

79.17. Метод Validate (Актуализировать)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.Validate(ValidateResources: Boolean;
2  ValidateData: Boolean; ValidateClass: TClass; ValidateField: TField);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ValidateResources

Boolean

Да

Актуализировать ресурсы

ValidateData

Boolean

Да

Актуализировать данные

ValidateClass

TClass

Нет

Актуализировать объекты класса

ValidateField

TField

Нет

Актуализировать значения поля

79.18. Метод ValidateAllObjects (Актуализировать все объекты)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.ValidateAllObjects(ValidateClass: TClass;
2  ValidateField: TField);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ValidateClass

TClass

Нет

Актуализировать объекты класса

ValidateField

TField

Нет

Актуализировать значения поля

79.19. Метод ValidateObject (Актуализировать объект)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.ValidateObject(AOwnerObject: TObject;
2  AOwnerField: TField);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

79.20. Метод ValidateOwned (Актуализировать имеющих владельца)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.ValidateOwned;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

79.21. Метод ValidateOwner (Актуализировать по владельцу)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.ValidateOwner(AOwner: string[64]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

80. Класс TMethod (Методы)

80.1. Свойства

Свойства класса TMethod:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Body

clob

Нет

Видимо пользователю

Чтение/Запись

Тело

CallTemplate

string[2000]

Нет

Видимо пользователю

Только для чтения

Шаблон вызова

Virtual

Boolean

Да

Видимо пользователю

Чтение/Запись

Виртуальный

DBMSName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта СУБД

80.2. Конструктор Create (Конструктор метода)

Конструктор класса TMethod.
1constructor TMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; Body: clob;
6  Virtual: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

Body

clob

Нет

Тело

Virtual

Boolean

Да

Метод является виртуальным

Замечания:

Создает новый объект класса TMethod.

80.3. Метод Call (Вызвать)

Метод экземпляра класса TMethod.
procedure TMethod.Call(Parameters: TObjectList);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Parameters

TObjectList

Нет

Параметры

80.4. Метод CallTemplate (Шаблон вызова)

Метод экземпляра класса TMethod.
function TMethod.CallTemplate: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

80.5. Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TMethod.
function TMethod.GetDBMSName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

80.6. Метод VirtualChainRoot (Корень виртуальной цепи)

Метод экземпляра класса TMethod.
function TMethod.VirtualChainRoot: TMethod;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TMethod.

81. Класс TObject (Объекты)

81.1. Свойства

Свойства класса TObject:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Имя

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Наименование

Class

TClass

Да

Скрыто от пользователя

Только для чтения

Класс

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Статус репликации

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Родитель

Master

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

База данных-источник

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

GUID базы данных-источника

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

База данных-источник является текущей

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Идентификатор при создании

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Создано пользователем

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Создано

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Изменено пользователем

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Изменено

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Роль для чтения

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Роль для записи

81.2. Конструктор Create (Конструктор объекта)

Конструктор класса TObject.
1constructor TObject.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Class

TClass

Нет

Класс

Parent

TObject

Нет

Родитель

Master

TObject

Да

Мастер

Accessor

TSecurityAccount

Нет

Роль доступа

Замечания:

Создает новый объект класса TObject.

81.3. Деструктор Destroy (Деструктор объекта)

Деструктор класса TObject.
destructor TObject.Destroy;
Метод не имеет параметров.

Замечания:

Уничтожает объект класса TObject или его наследника.

81.4. Метод ApplyStringBuilder (Применить шаблон)

Метод экземпляра класса TObject.
function TObject.ApplyStringBuilder(Template: string[2000]): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа string[2000].

81.5. Метод ApplyStringBuilderClob (Применить шаблон-большой текстовый объект)

Метод экземпляра класса TObject.
function TObject.ApplyStringBuilderClob(Template: string[2000]): clob;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа clob.

81.6. Метод ASCII (ASCII-код)

Метод класса (статический метод) класса TObject.
class function TObject.ASCII(Value: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

81.7. Метод Assigned (Проверка пустоты значения)

Метод класса (статический метод) класса TObject.
class function TObject.Assigned(Value: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

81.8. Метод BlobToClob (Большой двоичный объект в большой текстовый объект)

Метод класса (статический метод) класса TObject.
class function TObject.BlobToClob(Value: blob): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

blob

Нет

Значение

Замечания:

Возвращает значение типа clob.

81.9. Метод BoolToStr (Логическое значение в строку)

Метод класса (статический метод) класса TObject.
1class function TObject.BoolToStr(Value: Boolean;
2  Domain: TBooleanDomain): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

Domain

TBooleanDomain

Нет

Домен

Замечания:

Возвращает значение типа string[2000].

81.10. Метод Change (Изменение объекта)

Метод экземпляра класса TObject.
procedure TObject.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

81.11. Метод Char (Символ)

Метод класса (статический метод) класса TObject.
class function TObject.Char(Value: Integer): string[2];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2].

81.12. Метод ClobReplace (Заменить содержимое большого текстового объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.ClobReplace(Value: clob; OldPattern: string[2000];
2  NewPattern: string[2000]; ReplaceAll: Boolean): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

OldPattern

string[2000]

Нет

Старый шаблон

NewPattern

string[2000]

Нет

Новый шаблон

ReplaceAll

Boolean

Да

Заменять все

Замечания:

Возвращает значение типа clob.

81.13. Метод ClobToBlob (Большой текстовый объект в большой двоичный объект)

Метод класса (статический метод) класса TObject.
class function TObject.ClobToBlob(Value: clob): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа blob.

81.14. Метод Concatenate (Управляемая конкатенация строк)

Метод класса (статический метод) класса TObject.
1class function TObject.Concatenate(Value: string[2000]; AddOn: string[2000];
2  MaxLength: Integer; Delimiter: string[2000]; Ellipsis: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

AddOn

string[2000]

Нет

Присоединяемая строка

MaxLength

Integer

Да

Максимальная длина

Delimiter

string[2000]

Нет

Разделитель

Ellipsis

Boolean

Да

Эллипсис

Замечания:

Возвращает значение типа string[2000].

81.15. Метод Copy (Копировать)

Метод класса (статический метод) класса TObject.
1class function TObject.Copy(String: string[2000]; StartPos: Integer;
2  Length: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

String

string[2000]

Нет

Строка

StartPos

Integer

Нет

Позиция

Length

Integer

Нет

Длина

Замечания:

Возвращает значение типа string[2000].

81.16. Метод CopyClob (Копировать из большого текстового объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.CopyClob(Value: clob; StartPos: Integer;
2  Length: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

StartPos

Integer

Нет

Позиция

Length

Integer

Нет

Длина

Замечания:

Возвращает значение типа string[2000].

81.17. Метод CreateGUID (Создать GUID)

Метод класса (статический метод) класса TObject.
class function TObject.CreateGUID: string[38];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[38].

81.18. Метод DateOf (Дату из даты со временем)

Метод класса (статический метод) класса TObject.
class function TObject.DateOf(Value: datetime): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа date.

81.19. Метод DatePart (Часть даты)

Метод класса (статический метод) класса TObject.
class function TObject.DatePart(Value: date; Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

81.20. Метод DateTimePart (Часть даты со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.DateTimePart(Value: datetime;
2  Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

81.21. Метод DateTimeToStr (Дату и время в строку)

Метод класса (статический метод) класса TObject.
class function TObject.DateTimeToStr(Value: datetime): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Да

Значение

Замечания:

Возвращает значение типа string[2000].

81.22. Метод DateToStr (Дату в строку)

Метод класса (статический метод) класса TObject.
class function TObject.DateToStr(Value: date): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

81.23. Метод Dequeue (Удалить из очереди)

Метод экземпляра класса TObject.
procedure TObject.Dequeue(Permanently: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Permanently

Boolean

Да

Удалить навсегда

81.24. Метод DescribeObject (Описание объекта для сообщений пользователю)

Метод экземпляра класса TObject.
function TObject.DescribeObject: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

81.25. Метод DumpString (Строка в виде списка кодов символов)

Метод класса (статический метод) класса TObject.
1class function TObject.DumpString(Value: string[2000]; Delimiter: string[2000];
2  Hexadecimal: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Hexadecimal

Boolean

Да

Использовать шестнадцатеричные значения

Замечания:

Возвращает значение типа string[2000].

81.26. Метод Ellipsis (Эллипсис)

Метод класса (статический метод) класса TObject.
1class function TObject.Ellipsis(Value: string[2000]; MaxLength: Integer;
2  WholeWords: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

WholeWords

Boolean

Да

По целым словам

Замечания:

Возвращает значение типа string[2000].

81.27. Метод EncodeDate (Собрать дату)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeDate(Year: Integer; Month: Integer;
2  Day: Integer): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Year

Integer

Нет

Год

Month

Integer

Нет

Месяц

Day

Integer

Нет

День

Замечания:

Возвращает значение типа date.

81.28. Метод EncodeDateTime (Собрать дату со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeDateTime(Year: Integer; Month: Integer;
2  Day: Integer; Hours: Integer; Minutes: Integer; Seconds: Integer): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Year

Integer

Нет

Год

Month

Integer

Нет

Месяц

Day

Integer

Нет

День

Hours

Integer

Нет

Часы

Minutes

Integer

Нет

Минуты

Seconds

Integer

Нет

Секунды

Замечания:

Возвращает значение типа datetime.

81.29. Метод EncodeTime (Собрать время)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeTime(Hours: Integer; Minutes: Integer;
2  Seconds: Integer): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Hours

Integer

Нет

Часы

Minutes

Integer

Нет

Минуты

Seconds

Integer

Нет

Секунды

Замечания:

Возвращает значение типа time.

81.30. Метод Enqueue (Поставить в очередь)

Метод экземпляра класса TObject.
function TObject.Enqueue(QueueName: string[64]): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

QueueName

string[64]

Да

Имя очереди

Замечания:

Возвращает значение типа Boolean.

81.31. Метод Find (Поиск объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.Find(Name: string[64]; Class: TClass; Parent: TObject;
2  Master: TObject): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Class

TClass

Нет

Класс объекта

Parent

TObject

Нет

Родительский объект

Master

TObject

Да

Мастер объекта

Замечания:

Возвращает значение типа TObject.

81.32. Метод FindGlobal (Глобальный поиск объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.FindGlobal(SourceDataBaseGUID: string[38];
2  OldID: string[38]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

SourceDataBaseGUID

string[38]

Да

GUID базы данных-источника

OldID

string[38]

Да

Идентификатор при создании

Замечания:

Возвращает значение типа TObject.

81.33. Метод FloatToStr (Вещественное в строку)

Метод класса (статический метод) класса TObject.
class function TObject.FloatToStr(Value: float): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

81.34. Метод FormatDate (Форматировать дату)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatDate(Value: date;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

81.35. Метод FormatDateTime (Форматировать дату со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatDateTime(Value: datetime;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

81.36. Метод FormatFloat (Форматировать вещественное значение)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatFloat(Value: float; DecimalPlaces: Integer;
2  DecimalSeparator: string[2]; GroupSeparator: string[2]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

DecimalPlaces

Integer

Нет

Количество десятичных знаков

DecimalSeparator

string[2]

Нет

Десятичный разделитель

GroupSeparator

string[2]

Нет

Разделитель групп разрядов

Замечания:

Возвращает значение типа string[2000].

81.37. Метод FormatTime (Форматировать время)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatTime(Value: time;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

81.38. Метод GenerateAllNames (Сгенерировать имена для всех объектов)

Метод класса (статический метод) класса TObject.
class function TObject.GenerateAllNames: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

81.39. Метод GeneratedDescription (Сгенерированное наименование)

Метод экземпляра класса TObject.
function TObject.GeneratedDescription: string[128];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].

81.40. Метод GeneratedName (Сгенерированное имя)

Метод экземпляра класса TObject.
function TObject.GeneratedName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

81.41. Метод GetBlobSize (Размер большого двоичного объекта)

Метод класса (статический метод) класса TObject.
class function TObject.GetBlobSize(Value: blob): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

blob

Нет

Значение

Замечания:

Возвращает значение типа Integer.

81.42. Метод GetChildCount (Получить количество дочерних объектов)

Метод экземпляра класса TObject.
function TObject.GetChildCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

81.43. Метод GetClobSize (Размер большого текстового объекта)

Метод класса (статический метод) класса TObject.
class function TObject.GetClobSize(Value: clob): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа Integer.

81.44. Метод GetDescendantCount (Получить количество объектов-потомков)

Метод экземпляра класса TObject.
function TObject.GetDescendantCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

81.45. Метод GetDetailCount (Получить количество подчиненных объектов)

Метод экземпляра класса TObject.
function TObject.GetDetailCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

81.46. Метод GetLevel (Уровень в иерархии)

Метод экземпляра класса TObject.
function TObject.GetLevel: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

81.47. Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TObject.
class function TObject.GetResource(AOwner: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

Замечания:

Возвращает значение типа string[2000].

81.48. Метод GetRoot (Получить корень иерархии)

Метод экземпляра класса TObject.
function TObject.GetRoot: TObject;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.

81.49. Метод GetTop (Получить объект верхнего уровня)

Метод экземпляра класса TObject.
function TObject.GetTop: TObject;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.

81.50. Метод HasAsChild (Объект является ребенком данного)

Метод экземпляра класса TObject.
function TObject.HasAsChild(Child: TObject): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Child

TObject

Нет

Дочерний объект

Замечания:

Возвращает значение типа Boolean.

81.51. Метод HasAsParent (Объект является родителем данного)

Метод экземпляра класса TObject.
function TObject.HasAsParent(Parent: TObject): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Boolean.

81.52. Метод HasChildren (Имеет детей)

Метод экземпляра класса TObject.
function TObject.HasChildren: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

81.53. Метод HasDetails (Имеет подчиненные объекты)

Метод экземпляра класса TObject.
function TObject.HasDetails: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

81.54. Метод Hash (Хеш-функция конца строки)

Метод класса (статический метод) класса TObject.
1class function TObject.Hash(Value: string[2000];
2  MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

81.55. Метод HashReverse (Хеш-функция начала строки)

Метод класса (статический метод) класса TObject.
1class function TObject.HashReverse(Value: string[2000];
2  MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

81.56. Метод HexToInt (Шестнадцатеричное представление в целое число)

Метод класса (статический метод) класса TObject.
class function TObject.HexToInt(Hexadecimal: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Hexadecimal

string[64]

Да

Шестнадцатеричное значение

Замечания:

Возвращает значение типа Integer.

81.57. Метод IfThenDate (Выбор из двух дат)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenDate(Value: Boolean; ATrue: date;
2  AFalse: date): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

date

Нет

Значение при выполнении условия

AFalse

date

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа date.

81.58. Метод IfThenDateTime (Выбор из двух дат со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenDateTime(Value: Boolean; ATrue: datetime;
2  AFalse: datetime): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

datetime

Нет

Значение при выполнении условия

AFalse

datetime

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа datetime.

81.59. Метод IfThenExternalData (Выбор из двух значений - внешних данных)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenExternalData(Value: Boolean; ATrue: <external
2  data>; AFalse: <external data>): <external data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

<external data>

Нет

Значение при выполнении условия

AFalse

<external data>

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа <external data>.

81.60. Метод IfThenFloat (Выбор из двух вещественных)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenFloat(Value: Boolean; ATrue: float;
2  AFalse: float): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

float

Нет

Значение при выполнении условия

AFalse

float

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа float.

81.61. Метод IfThenInt (Выбор из двух целых)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenInt(Value: Boolean; ATrue: Integer;
2  AFalse: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

Integer

Нет

Значение при выполнении условия

AFalse

Integer

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа Integer.

81.62. Метод IfThenObject (Выбор из двух объектов)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenObject(Value: Boolean; ATrue: TObject;
2  AFalse: TObject): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

TObject

Нет

Значение при выполнении условия

AFalse

TObject

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа TObject.

81.63. Метод IfThenStr (Выбор из двух строк)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenStr(Value: Boolean; ATrue: string[2000];
2  AFalse: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

string[2000]

Нет

Значение при выполнении условия

AFalse

string[2000]

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа string[2000].

81.64. Метод IfThenTime (Выбор из двух времен)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenTime(Value: Boolean; ATrue: time;
2  AFalse: time): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

time

Нет

Значение при выполнении условия

AFalse

time

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа time.

81.65. Метод InstanceObject (Объект по строковому представлению идентификатора (объект может не существовать))

Метод класса (статический метод) класса TObject.
class function TObject.InstanceObject(Value: string[38]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[38]

Да

Значение

Замечания:

Возвращает значение типа TObject.

81.66. Метод IntToHex (Целое число в шестнадцатеричное представление)

Метод класса (статический метод) класса TObject.
class function TObject.IntToHex(IntValue: Integer): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

IntValue

Integer

Нет

Целое значение

Замечания:

Возвращает значение типа string[64].

81.67. Метод IntToStr (Целое в строку)

Метод класса (статический метод) класса TObject.
class function TObject.IntToStr(Value: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

81.68. Метод IsBadHierarchy (Ошибка в иерархии)

Метод экземпляра класса TObject.
function TObject.IsBadHierarchy: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

81.69. Метод IsBadPtr (Не указывает на существующий объект)

Метод экземпляра класса TObject.
function TObject.IsBadPtr: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

81.70. Метод IsCharAlpha (Символ является алфавитным)

Метод класса (статический метод) класса TObject.
class function TObject.IsCharAlpha(Value: string[2]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

81.71. Метод IsCharAlphaNumeric (Символ является алфавитно-числовым)

Метод класса (статический метод) класса TObject.
class function TObject.IsCharAlphaNumeric(Value: string[2]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

81.72. Метод IsInList (Объект входит в список)

Метод экземпляра класса TObject.
function TObject.IsInList(Value: TObjectList): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectList

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

81.73. Метод IsInSet (Объект входит в множество)

Метод экземпляра класса TObject.
function TObject.IsInSet(Value: TObjectSet): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

81.74. Метод IsInstanceOf (Является экземпляром класса)

Метод экземпляра класса TObject.
function TObject.IsInstanceOf(Class: TClass): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Class

TClass

Нет

Класс

Замечания:

Возвращает значение типа Boolean.

81.75. Метод IsNotInList (Объект не входит в список)

Метод экземпляра класса TObject.
function TObject.IsNotInList(Value: TObjectList): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectList

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

81.76. Метод IsNotInSet (Объект не входит в множество)

Метод экземпляра класса TObject.
function TObject.IsNotInSet(Value: TObjectSet): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

81.77. Метод LineBreak (Разделитель строк)

Метод класса (статический метод) класса TObject.
class function TObject.LineBreak: string[2];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2].

81.78. Метод LinkClobs (Присоединить большой объект к другому)

Метод класса (статический метод) класса TObject.
class function TObject.LinkClobs(PrefData: clob; PostData: clob): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

PrefData

clob

Нет

Данные первого объекта

PostData

clob

Нет

Данные второго объекта

Замечания:

Возвращает значение типа clob.

81.79. Метод LinkToClob (Присоединить строки к большому объекту)

Метод класса (статический метод) класса TObject.
1class function TObject.LinkToClob(Prefix: string[2000]; Data: clob;
2  Postfix: string[2000]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Prefix

string[2000]

Нет

Префикс

Data

clob

Нет

Данные

Postfix

string[2000]

Нет

Постфикс

Замечания:

Возвращает значение типа clob.

81.80. Метод Locate (Поиск объекта по локатору)

Метод класса (статический метод) класса TObject.
class function TObject.Locate(Locator: string[2000]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Locator

string[2000]

Нет

Локатор

Замечания:

Возвращает значение типа TObject.

81.81. Метод Locator (Локатор объекта)

Метод экземпляра класса TObject.
function TObject.Locator: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

81.82. Метод LowerCase (Преобразовать к нижнему регистру)

Метод класса (статический метод) класса TObject.
class function TObject.LowerCase(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

81.83. Метод MatchRegExp (Проверка соответствия строки регулярному выражению)

Метод класса (статический метод) класса TObject.
1class function TObject.MatchRegExp(Value: string[2000];
2  RegExp: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

RegExp

string[2000]

Нет

Регулярное выражение

Замечания:

Возвращает значение типа Boolean.

81.84. Метод MergeIdentifiers (Объединенный идентификатор)

Метод класса (статический метод) класса TObject.
1class function TObject.MergeIdentifiers(Identifier: string[64];
2  Modifier: string[64]; MaxLength: Integer): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Identifier

string[64]

Да

Идентификатор

Modifier

string[64]

Да

Модификатор

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[64].

81.85. Метод MergeTo (Отождествить с)

Метод экземпляра класса TObject.
procedure TObject.MergeTo(PrimaryObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

PrimaryObject

TObject

Да

Первичный объект

81.86. Метод Modulus (Остаток деления)

Метод класса (статический метод) класса TObject.
class function TObject.Modulus(Value: Integer; Base: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Делимое

Base

Integer

Нет

Делитель

Замечания:

Возвращает значение типа Integer.

81.87. Метод ObjectInstance (Текстовое представление идентификатора объекта (объект может не существовать))

Метод класса (статический метод) класса TObject.
class function TObject.ObjectInstance(Value: TObject): string[38];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа string[38].

81.88. Метод Pos (Поиск подстроки)

Метод класса (статический метод) класса TObject.
1class function TObject.Pos(Substring: string[2000];
2  Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Substring

string[2000]

Нет

Подстрока

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

81.89. Метод PreprocessRegExp (Адаптировать регулярное выражение к требованиям СУБД)

Метод класса (статический метод) класса TObject.
class function TObject.PreprocessRegExp(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

81.90. Метод QualifiedName (Квалифицированное имя)

Метод экземпляра класса TObject.
function TObject.QualifiedName: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

81.91. Метод QuotedStr (Строку в апострофы)

Метод класса (статический метод) класса TObject.
class function TObject.QuotedStr(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

81.92. Метод RaiseException (Возбудить исключение)

Метод класса (статический метод) класса TObject.
class procedure TObject.RaiseException(Message: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Message

string[2000]

Нет

Сообщение

81.93. Метод RaiseResource (Возбудить исключение по ресурсной строке)

Метод класса (статический метод) класса TObject.
class procedure TObject.RaiseResource(AOwner: string[64]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

81.94. Метод ReadFromClob (Считать строку из большого текстового объекта)

Метод класса (статический метод) класса TObject.
class function TObject.ReadFromClob(Value: clob): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

81.95. Метод ResourceByItem (Значение ресурсной строки)

Метод класса (статический метод) класса TObject.
class function TObject.ResourceByItem(Resource: Resource strings): string[128];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Resource

Resource strings

Нет

Ресурс

Замечания:

Возвращает значение типа string[128].

81.96. Метод Round (Округление)

Метод класса (статический метод) класса TObject.
class function TObject.Round(Value: float; Decimals: Integer): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Decimals

Integer

Нет

Количество десятичных знаков

Замечания:

Возвращает значение типа float.

81.97. Метод SendInstantMessage (Отправить мгновенное сообщение)

Метод класса (статический метод) класса TObject.
1class procedure TObject.SendInstantMessage(Recipient: TUser;
2  MessageText: string[255]; DeliveryTime: datetime; AttachSelected: Boolean;
3  Selected: TObjectList; CurrentFormView: TFormView; HyperLink: string[256];
4  FileName: string[255]; FileBaseName: string[128]; FileBody: blob;
5  AttachmentType: TInstantMessageAttachmentType);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Recipient

TUser

Да

Получатель

MessageText

string[255]

Да

Сообщение

DeliveryTime

datetime

Нет

Время доставки

AttachSelected

Boolean

Да

Присоединить выбранные объекты

Selected

TObjectList

Нет

Список выбранных

CurrentFormView

TFormView

Нет

Текущее представление формы

HyperLink

string[256]

Нет

Гиперссылка

FileName

string[255]

Нет

Файл

FileBaseName

string[128]

Да

Имя файла (без пути)

FileBody

blob

Нет

Содержимое файла

AttachmentType

TInstantMessageAttachmentType

Да

Тип приложения

81.98. Метод Sleep (Задержка выполнения)

Метод класса (статический метод) класса TObject.
class procedure TObject.Sleep(Seconds: Integer);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Seconds

Integer

Да

Количество секунд

81.99. Метод StringReplace (Заменить содержимое строки)

Метод класса (статический метод) класса TObject.
1class function TObject.StringReplace(Value: string[2000];
2  OldPattern: string[2000]; NewPattern: string[2000];
3  ReplaceAll: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

OldPattern

string[2000]

Нет

Старый шаблон

NewPattern

string[2000]

Нет

Новый шаблон

ReplaceAll

Boolean

Да

Заменять все

Замечания:

Возвращает значение типа string[2000].

81.100. Метод StrLength (Длина строки)

Метод класса (статический метод) класса TObject.
class function TObject.StrLength(String: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

String

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

81.101. Метод StrLike (Сопоставить строку с шаблоном)

Метод класса (статический метод) класса TObject.
1class function TObject.StrLike(Value: string[2000];
2  Pattern: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Pattern

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа Boolean.

81.102. Метод StrPad (Заполнить строку)

Метод класса (статический метод) класса TObject.
1class function TObject.StrPad(Value: string[2000]; Padding: string[2000];
2  PadRight: Boolean; MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Padding

string[2000]

Нет

Заполнитель

PadRight

Boolean

Да

Заполнять справа

MaxLength

Integer

Нет

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

81.103. Метод StrToBool (Строку в логическое значение)

Метод класса (статический метод) класса TObject.
class function TObject.StrToBool(Value: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

81.104. Метод StrToDate (Строку в дату)

Метод класса (статический метод) класса TObject.
class function TObject.StrToDate(Value: string[2000]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа date.

81.105. Метод StrToDateTime (Строку в дату и время)

Метод класса (статический метод) класса TObject.
class function TObject.StrToDateTime(Value: string[2000]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа datetime.

81.106. Метод StrToFloat (Строку в вещественное)

Метод класса (статический метод) класса TObject.
class function TObject.StrToFloat(Value: string[2000]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа float.

81.107. Метод StrToInt (Строку в целое)

Метод класса (статический метод) класса TObject.
class function TObject.StrToInt(Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

81.108. Метод StrToTime (Строку во время)

Метод класса (статический метод) класса TObject.
class function TObject.StrToTime(Value: string[2000]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа time.

81.109. Метод StrTranslate (Транслировать символы в строке)

Метод класса (статический метод) класса TObject.
1class function TObject.StrTranslate(Value: string[2000];
2  OldChars: string[2000]; NewChars: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

OldChars

string[2000]

Нет

Старый набор символов

NewChars

string[2000]

Нет

Новый набор символов

Замечания:

Возвращает значение типа string[2000].

81.110. Метод StrWrap (Выровнять строку)

Метод класса (статический метод) класса TObject.
1class function TObject.StrWrap(Value: string[2000]; Delimiter: string[2000];
2  MaxCol: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

MaxCol

Integer

Нет

Максимальное количество символов

Замечания:

Возвращает значение типа string[2000].

81.111. Метод SuggestDescription (Предложить наименование)

Метод экземпляра класса TObject.
procedure TObject.SuggestDescription(Description: string[128]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Description

string[128]

Да

Наименование

81.112. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TObject.
function TObject.SuggestFileName(Domain: TDomain): string[128];
Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Домен

Замечания:

Возвращает значение типа string[128].

81.113. Метод TimeOf (Время из даты со временем)

Метод класса (статический метод) класса TObject.
class function TObject.TimeOf(Value: datetime): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа time.

81.114. Метод TimePart (Часть времени)

Метод класса (статический метод) класса TObject.
class function TObject.TimePart(Value: time; Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

81.115. Метод TimeToStr (Время в строку)

Метод класса (статический метод) класса TObject.
class function TObject.TimeToStr(Value: time): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

81.116. Метод Touch (Модификация объекта)

Метод экземпляра класса TObject.
procedure TObject.Touch;
Метод скрыт от пользователя.

Метод не имеет параметров.

81.117. Метод Trim (Убрать лишние пробелы)

Метод класса (статический метод) класса TObject.
class function TObject.Trim(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

81.118. Метод Trunc (Отсечение дробной части)

Метод класса (статический метод) класса TObject.
class function TObject.Trunc(Value: float): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа Integer.

81.119. Метод UniqueValue (Уникальный идентификатор)

Метод класса (статический метод) класса TObject.
class function TObject.UniqueValue: string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

81.120. Метод UpperCase (Преобразовать к верхнему регистру)

Метод класса (статический метод) класса TObject.
class function TObject.UpperCase(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

81.121. Метод Ole-объекта CheckSGMLContent (Проверить SGML-содержимое)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Property

TProperty

Да

Свойство

Замечания:

Возвращает значение типа string[2000].

81.122. Метод Ole-объекта ExportAfter (Экспортировать модифицированные)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла-реплики

FromDate

datetime

Нет

Модифицировано после

81.123. Метод Ole-объекта FixSGMLContentErrors (Исправить ошибки SGML-содержимого)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Property

TProperty

Да

Свойство

Замечания:

Возвращает значение типа string[2000].

81.124. Метод Ole-объекта LoadBlobsFromFolder (Загрузить данные из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Property

TProperty

Да

Свойство

Template

string[128]

Да

Шаблон

Замечания:

Возвращает значение типа Integer.

81.125. Метод Ole-объекта SaveBlobsToFolder (Сохранить данные в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Property

TProperty

Да

Свойство

Template

string[128]

Да

Шаблон

List

TObjectList

Нет

Список объектов

Замечания:

Возвращает значение типа Integer.

81.126. Метод Ole-объекта SplitExcelSheetsToFiles (Разделить Excel листы на файлы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта скрыт от пользователя.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

WorkBook

blob

Нет

Книга (объект)

FileName

string[255]

Нет

Имя Excel-файла

FileNameMappingSheetName

string[128]

Нет

Имя листа с сопоставлениями имен файлов (по умолчанию MapSheetNameToFileName)

Folder

string[255]

Да

Каталог

81.127. Шаблон отчета Excel Excel (Перенести в Excel)

Шаблон отчета Excel класса (статический шаблон) класса TObject.

Шаблон отчета Excel является методом класса.

Шаблон отчета Excel не имеет параметров.

81.128. Шаблон отчета Word SpellCheck (Проверка правописания)

Шаблон отчета Word класса (статический шаблон) класса TObject.

Шаблон отчета Word скрыт от пользователя.

Шаблон отчета Word является методом класса.

Шаблон отчета Word не имеет параметров.

81.129. Шаблон XSLT-отчета ObjectInformation (Информация об объекте)

Шаблон XSLT-отчета класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ShowHiddenProps

Boolean

Да

Показывать скрытые свойства

81.130. Шаблон XSLT-отчета SelectDataToText (Выполнить запрос в текст)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

Query

clob

Нет

Запрос

81.131. Шаблон XSLT-отчета SelectDataToXML (Выполнить запрос в xml-документ)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

Query

clob

Нет

Запрос

81.132. Подпрограмма Column (Колонка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.133. Подпрограмма CopyToClipboard (Копировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

81.134. Подпрограмма CurrentFormView (Текущее представление формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.135. Подпрограмма CurrentlySelected (Список выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.136. Подпрограмма CurrentlySelectedSet (Множество выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.137. Подпрограмма CurrentlyVisible (Список видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.138. Подпрограмма CurrentlyVisibleSet (Множество видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.139. Подпрограмма Dependencies (Зависимости)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

81.140. Подпрограмма Edit columns (Редактировать строку)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

81.141. Подпрограмма Edit filters (Редактировать фильтры)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.142. Подпрограмма Edit properties (Редактировать свойства)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

81.143. Подпрограмма Export (Экспортировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

81.144. Подпрограмма ExportReport (Выгрузить в отчет)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.145. Подпрограмма FormOptions (Настройки формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.146. Подпрограмма Import (Импортировать)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.147. Подпрограмма Merge (Объединить)

Подпрограмма класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма не имеет параметров.

81.148. Подпрограмма Messages (Проверить сообщения)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.149. Подпрограмма Options (Настройки)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.150. Подпрограмма Paste (Вставить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.151. Подпрограмма PasteSpecial (Специальная вставка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.152. Подпрограмма Presentations (Виды)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.153. Подпрограмма Refresh (Обновить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.154. Подпрограмма Search (Поиск)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.155. Подпрограмма Selection (Выбранные)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

81.156. Подпрограмма Tree (Дерево)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

82. Класс TObjectArchive (Архив объектов)

82.1. Свойства

Свойства класса TObjectArchive:

Имя

Тип

Обязательно

Доступ

Назначение

Object

TObject

Да

Только для чтения

Объект

ObjectName

string[64]

Да

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Только для чтения

Наименование объекта

ObjectClass

TClass

Да

Только для чтения

Класс объекта

ObjectParent

TObject

Нет

Только для чтения

Объект-родитель

ObjectMaster

TObject

Да

Только для чтения

Объект-мастер

ObjectSourceDataBase

TDataBase

Да

Только для чтения

База данных-источник

ObjectOldID

string[38]

Да

Только для чтения

Идентификатор объекта при создании

ObjectCreator

TUser

Да

Только для чтения

Объект создан пользователем

ObjectCreated

datetime

Да

Только для чтения

Объект создан

ObjectModifier

TUser

Да

Только для чтения

Объект изменен пользователем

ObjectModified

datetime

Да

Только для чтения

Объект изменен

User

TUser

Да

Только для чтения

Пользователь

UserName

string[64]

Да

Только для чтения

Имя пользователя

82.2. Метод Purge (Очистить архив)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Purge(TimeLimit: time);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeLimit

time

Нет

Лимит времени выполнения

82.3. Метод Put (Положить объект в архив)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Put(Object: TObject);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

82.4. Метод PutAutonomous (Положить объект в архив в автономной транзакции)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.PutAutonomous(Object: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

82.5. Метод Remove (Исключить объект из архива)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Remove(Object: TObject);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

83. Класс TObjectCreator (Роли-создатели)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

83.1. Свойства

Свойства класса TObjectCreator:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

83.2. Конструктор Create (Конструктор роли-создателя)

Конструктор класса TObjectCreator.
1constructor TObjectCreator.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TObjectCreator.

84. Класс TObjectHistory (История объектов)

84.1. Свойства

Свойства класса TObjectHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Только для чтения

Имя

Description

string[128]

Да

Видимо пользователю

Только для чтения

Наименование

Class

TClass

Да

Видимо пользователю

Только для чтения

Класс

Master

string[2000]

Нет

Видимо пользователю

Только для чтения

Мастер

Parent

string[2000]

Нет

Видимо пользователю

Только для чтения

Родитель

Data

string[2000]

Нет

Видимо пользователю

Только для чтения

Содержимое

Action

TChangeAction

Да

Видимо пользователю

Только для чтения

Действие

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

ObjectOldID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор при создании

ObjectDataBase

TDataBase

Да

Видимо пользователю

Только для чтения

База данных объекта

ObjectID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор объекта

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

FieldName

string[64]

Да

Видимо пользователю

Только для чтения

Поле

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

84.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TObjectHistory.
1class procedure TObjectHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

84.3. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TObjectHistory.
1class procedure TObjectHistory.Log(Object: TObject; Action: TChangeAction;
2  Field: TField; Data: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

Action

TChangeAction

Да

Действие

Field

TField

Нет

Поле

Data

string[2000]

Нет

Содержимое

84.4. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObjectHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

84.5. Шаблон отчета Excel UserActivityReport (Отчет об активности пользователей)

Шаблон отчета Excel класса (статический шаблон) класса TObjectHistory.

Шаблон отчета Excel является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

UDate

date

Нет

Дата

85. Класс TObjectList (Списки)

Объекты класса не именованы.

85.1. Свойства

Свойства класса TObjectList:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

AsString

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

Список в текстовом представлении

AsClob

clob

Нет

Скрыто от пользователя

Чтение/Запись

Список в виде большого текстового объекта

85.2. Конструктор Create (Конструктор списка)

Конструктор класса TObjectList.
1constructor TObjectList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TObjectList.

85.3. Метод Add (Добавить объект в список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Add(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

85.4. Метод Archive (Отправить список в архив)

Метод экземпляра класса TObjectList.
procedure TObjectList.Archive;
Метод не имеет параметров.

85.5. Метод ArchiveAll (Отправить список в архив со всем содержимым)

Метод экземпляра класса TObjectList.
procedure TObjectList.ArchiveAll;
Метод не имеет параметров.

85.6. Метод ByName (Поиск по имени)

Метод экземпляра класса TObjectList.
function TObjectList.ByName(Name: string[64]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Замечания:

Возвращает значение типа Integer.

85.7. Метод Clear (Очистить список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Clear;
Метод скрыт от пользователя.

Метод не имеет параметров.

85.8. Метод CreateFromClob (Создать список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromClob(Value: clob): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

85.9. Метод CreateFromOrderedClob (Создать упорядоченный список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromOrderedClob(Value: clob): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

85.10. Метод CreateFromOrderedString (Создать упорядоченный список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromOrderedString(Value: string[2000]): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

85.11. Метод CreateFromString (Создать список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromString(Value: string[2000]): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

85.12. Метод Delete (Удалить объект)

Метод экземпляра класса TObjectList.
procedure TObjectList.Delete(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

85.13. Метод DestroyAll (Удалить вместе с содержащимися в списке объектами)

Метод экземпляра класса TObjectList.
procedure TObjectList.DestroyAll;
Метод не имеет параметров.

85.14. Метод Force (Добавить, игнорируя ограничения)

Метод экземпляра класса TObjectList.
procedure TObjectList.Force(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

85.15. Метод GetAsClob (Получить в виде большого текстового объекта)

Метод экземпляра класса TObjectList.
function TObjectList.GetAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

85.16. Метод GetAsString (Список в текстовом представлении)

Метод экземпляра класса TObjectList.
function TObjectList.GetAsString: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

85.17. Метод GetItem (Получить объект из списка)

Метод экземпляра класса TObjectList.
function TObjectList.GetItem(ItemIndex: Integer): TObject;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

Замечания:

Возвращает значение типа TObject.

85.18. Метод IndexOf (Индекс объекта в списке)

Метод экземпляра класса TObjectList.
function TObjectList.IndexOf(ItemObject: TObject): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

Замечания:

Возвращает значение типа Integer.

85.19. Метод Insert (Вставить объект в список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Insert(ItemIndex: Integer; ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemObject

TObject

Да

Элемент

85.20. Метод IsExcluded (Объект не входит в список)

Метод экземпляра класса TObjectList.
function TObjectList.IsExcluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

85.21. Метод IsIncluded (Объект входит в список)

Метод экземпляра класса TObjectList.
function TObjectList.IsIncluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

85.22. Метод Length (Длина списка)

Метод экземпляра класса TObjectList.
function TObjectList.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

85.23. Метод LoadFromClob (Загрузить содержимое списка из большого текстового объекта)

Метод экземпляра класса TObjectList.
1procedure TObjectList.LoadFromClob(Value: clob; Ordered: Boolean;
2  Clear: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Ordered

Boolean

Да

Сохранить порядок объектов

Clear

Boolean

Да

Очистить перед загрузкой

85.24. Метод LoadFromString (Загрузить содержимое списка из текстового представления)

Метод экземпляра класса TObjectList.
1procedure TObjectList.LoadFromString(Value: string[2000]; Ordered: Boolean;
2  Clear: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Ordered

Boolean

Да

Сохранить порядок объектов

Clear

Boolean

Да

Очистить перед загрузкой

85.25. Метод Remove (Вычистить объект)

Метод экземпляра класса TObjectList.
procedure TObjectList.Remove(ItemObject: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

85.26. Метод Reorder (Перенумеровать объекты в списке)

Метод экземпляра класса TObjectList.
procedure TObjectList.Reorder;
Метод не имеет параметров.

85.27. Метод SetAsClob (Установить список в виде большого текстового объекта)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetAsClob(Value: clob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

85.28. Метод SetAsString (Установить список в текстовом представлении)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetAsString(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

85.29. Метод SetItem (Установить объект в списке)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetItem(ItemIndex: Integer; ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemObject

TObject

Да

Элемент

86. Класс TObjectListItem (Элементы списков)

86.1. Свойства

Свойства класса TObjectListItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Object

TObject

Да

Видимо пользователю

Только для чтения

Объект

Position

Integer

Да

Видимо пользователю

Только для чтения

Позиция

86.2. Конструктор Create (Конструктор элемента списка)

Конструктор класса TObjectListItem.
1constructor TObjectListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ItemObject: TObject; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ItemObject

TObject

Да

Элемент

Position

Integer

Нет

Позиция

Замечания:

Создает новый объект класса TObjectListItem.

87. Класс TObjectSet (Множества объектов)

87.1. Конструктор Create (Создать множество)

Конструктор класса TObjectSet.
constructor TObjectSet.Create: TObjectSet;
Метод не имеет параметров.

Замечания:

Создает новый объект класса TObjectSet.

87.2. Метод Add (Добавить множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Add(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

87.3. Метод Change (Изменение объекта)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

87.4. Метод Clear (Очистить множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Clear;
Метод не имеет параметров.

87.5. Метод Clone (Клонировать множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.Clone: TObjectSet;
Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectSet.

87.6. Метод CreateFromClob (Создать множество на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectSet.
class function TObjectSet.CreateFromClob(Value: clob): TObjectSet;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectSet.

87.7. Метод CreateFromString (Создать множество на основе строки)

Метод класса (статический метод) класса TObjectSet.
class function TObjectSet.CreateFromString(Value: string[2000]): TObjectSet;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectSet.

87.8. Метод Exclude (Исключить объект из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Exclude(Value: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

87.9. Метод ExcludeClob (Исключить содержимое большого текстового объекта из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.ExcludeClob(Value: clob);
Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

87.10. Метод ExcludeString (Исключить содержимое строки из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.ExcludeString(Value: string[2000]);
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

87.11. Метод GetAsClob (Множество в виде большого текстового объекта)

Метод экземпляра класса TObjectSet.
function TObjectSet.GetAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

87.12. Метод GetAsString (Множество в виде строки)

Метод экземпляра класса TObjectSet.
function TObjectSet.GetAsString: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

87.13. Метод Include (Включить объект в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Include(Value: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

87.14. Метод IncludeClob (Включить содержимое большого текстового объекта в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.IncludeClob(Value: clob);
Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

87.15. Метод IncludeString (Включить содержимое строки в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.IncludeString(Value: string[2000]);
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

87.16. Метод IsExcluded (Объект не входит в множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.IsExcluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

87.17. Метод IsIncluded (Объект входит в множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.IsIncluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

87.18. Метод Length (Количество элементов)

Метод экземпляра класса TObjectSet.
function TObjectSet.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

87.19. Метод Multiply (Умножить на множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Multiply(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

87.20. Метод Subtract (Вычесть множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Subtract(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

88. Класс TOleObjectMethod (Метод Ole-объекта)

88.1. Свойства

Свойства класса TOleObjectMethod:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

ClassID

string[128]

Нет

Видимо пользователю

Чтение/Запись

Идентификатор класса

Method

string[128]

Нет

Видимо пользователю

Чтение/Запись

Метод

CodeLibrary

TAccessibleFile

Нет

Видимо пользователю

Чтение/Запись

Библиотека кода

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

88.2. Конструктор Create (Конструктор метода Ole-объекта)

Конструктор класса TOleObjectMethod.
1constructor TOleObjectMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; CodeLibrary: TAccessibleFile;
6  ClassID: string[128]; Method: string[128]; IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

CodeLibrary

TAccessibleFile

Нет

Библиотека кода

ClassID

string[128]

Нет

Идентификатор класса

Method

string[128]

Нет

Метод

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TOleObjectMethod.

88.3. Метод Ole-объекта CheckOleObjectMethod (Проверить метод Ole-объекта)

Метод Ole-объекта класса TOleObjectMethod.

Метод Ole-объекта не имеет параметров.

89. Класс TOption (Настройки)

89.1. Свойства

Свойства класса TOption:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Global

Boolean

Да

Видимо пользователю

Чтение/Запись

Глобальная

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Value

TOptionValue

Нет

Скрыто от пользователя

Только для чтения

Значение

User

TUser

Нет

Видимо пользователю

Чтение/Запись

Пользователь

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

Видимое значение

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

89.2. Конструктор Create (Конструктор настройки)

Конструктор класса TOption.
1constructor TOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Global: Boolean; Group: string[128]; Tab: string[128];
4  Position: Integer; Scope: TScope): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Global

Boolean

Да

Глобальная

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Position

Integer

Нет

Позиция

Scope

TScope

Да

Область видимости

Замечания:

Создает новый объект класса TOption.

89.3. Метод AreValid (Настройки действительны)

Метод класса (статический метод) класса TOption.
class function TOption.AreValid: Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

89.4. Метод GetBlobValue (Значение-большой объект)

Метод класса (статический метод) класса TOption.
class function TOption.GetBlobValue(OptionName: string[64]): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа blob.

89.5. Метод GetBoolValue (Логическое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetBoolValue(OptionName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа Boolean.

89.6. Метод GetClobValue (Значение-текст)

Метод класса (статический метод) класса TOption.
class function TOption.GetClobValue(OptionName: string[64]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа clob.

89.7. Метод GetDateTimeValue (Значение даты со временем)

Метод класса (статический метод) класса TOption.
class function TOption.GetDateTimeValue(OptionName: string[64]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа datetime.

89.8. Метод GetDateValue (Значение даты)

Метод класса (статический метод) класса TOption.
class function TOption.GetDateValue(OptionName: string[64]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа date.

89.9. Метод GetExternalDataValue (Значение внешних данных)

Метод класса (статический метод) класса TOption.
1class function TOption.GetExternalDataValue(OptionName: string[64]): <external
2  data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа <external data>.

89.10. Метод GetFloatValue (Вещественное значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetFloatValue(OptionName: string[64]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа float.

89.11. Метод GetIntValue (Целое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetIntValue(OptionName: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа Integer.

89.12. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TOption.
class function TOption.GetNextPos: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

89.13. Метод GetObjectValue (Значение-объект)

Метод класса (статический метод) класса TOption.
class function TOption.GetObjectValue(OptionName: string[64]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа TObject.

89.14. Метод GetStrValue (Строковое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetStrValue(OptionName: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа string[2000].

89.15. Метод GetTimeValue (Значение времени)

Метод класса (статический метод) класса TOption.
class function TOption.GetTimeValue(OptionName: string[64]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа time.

89.16. Метод GetValue (Значение)

Метод экземпляра класса TOption.
function TOption.GetValue: TOptionValue;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TOptionValue.

89.17. Метод SetValue (Установка значения)

Метод экземпляра класса TOption.
1procedure TOption.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>; Default: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Default

Boolean

Да

По умолчанию

90. Класс TOptionValue (Значения настроек)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

90.1. Свойства

Свойства класса TOptionValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

User

TUser

Нет

Видимо пользователю

Чтение/Запись

Пользователь

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущим

Option

TOption

Да

Скрыто от пользователя

Только для чтения

Настройка

Domain

TDomain

Да

Видимо пользователю

Только для чтения

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Global

Boolean

Да

Видимо пользователю

Только для чтения

Глобальная

90.2. Конструктор Create (Конструктор значения настройки)

Конструктор класса TOptionValue.
1constructor TOptionValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Унаследовано от TTypedValue.Create

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

User

TUser

Нет

Пользователь

Замечания:

Создает новый объект класса TOptionValue.

91. Класс TParameter (Параметры)

91.1. Свойства

Свойства класса TParameter:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

RoutineClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс подпрограммы

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

InitializationMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Инициализируется членом класса

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределен

LinkedView

TParametersFormView

Нет

Видимо пользователю

Чтение/Запись

Связанное представление

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

91.2. Конструктор Create (Конструктор параметра)

Конструктор класса TParameter.
1constructor TParameter.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; InitializationMember: TClassMember; OutOfTabs: Boolean;
5  LinkedView: TParametersFormView; Logged: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

InitializationMember

TClassMember

Нет

Инициализируется членом класса

OutOfTabs

Boolean

Да

За пределами закладок

LinkedView

TParametersFormView

Нет

Связанное представление

Logged

Boolean

Да

Протоколировать

Замечания:

Создает новый объект класса TParameter.

91.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TParameter.
class function TParameter.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

91.4. Метод GetOverride (Переопределен)

Метод экземпляра класса TParameter.
function TParameter.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

92. Класс TParameterHistory (Параметры вызовов)

92.1. Свойства

Свойства класса TParameterHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Routine

TRoutineHistory

Да

Скрыто от пользователя

Только для чтения

Вызов подпрограммы

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

ParameterName

string[64]

Да

Видимо пользователю

Только для чтения

Параметр

Data

string[2000]

Нет

Видимо пользователю

Только для чтения

Содержимое

ObjectID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

92.2. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TParameterHistory.
1class procedure TParameterHistory.Log(Routine: TRoutineHistory;
2  Parameter: TParameter; Data: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutineHistory

Да

Вызов подпрограммы

Parameter

TParameter

Да

Параметр

Data

string[2000]

Нет

Содержимое

93. Класс TParametersFormView (Представления формы параметров)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

93.1. Конструктор Create (Конструктор представления формы параметров)

Конструктор класса TParametersFormView.
1constructor TParametersFormView.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; View: TCustomView; ChildrenMinimized: Boolean;
4  ChildrenOnTabs: Boolean; MasterProperty: TProperty;
5  DetailProperty: TClassMember; Position: Integer; SpacePercentage: Integer;
6  Layout: TFormViewLayout; ExplicitQuery: Boolean): TObject;
Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Унаследовано от TFormView.Create

ChildrenMinimized

Boolean

Да

ChildrenOnTabs

Boolean

Да

MasterProperty

TProperty

Нет

DetailProperty

TClassMember

Нет

Position

Integer

Да

SpacePercentage

Integer

Нет

Layout

TFormViewLayout

Да

ExplicitQuery

Boolean

Да

Замечания:

Создает новый объект класса TParametersFormView.

94. Класс TPDFTemplate (Шаблоны отчетов PDF)

94.1. Свойства

Свойства класса TPDFTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateScript

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт шаблона

94.2. Конструктор Create (Конструктор шаблона PDF)

Конструктор класса TPDFTemplate.
1constructor TPDFTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateScript: clob): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateScript

clob

Нет

Скрипт шаблона

Замечания:

Создает новый объект класса TPDFTemplate.

95. Класс TProfile (Профили)

95.1. Свойства

Свойства класса TProfile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

ComparisonType

TComparisonType

Да

Видимо пользователю

Чтение/Запись

Тип сравнения

BasedOnProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Расширяет профиль пользователями

Active

Boolean

Да

Видимо пользователю

Только для чтения

Активен

95.2. Конструктор Create (Конструктор профиля)

Конструктор класса TProfile.
1constructor TProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType;
4  BasedOnProfile: TProfile): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

ComparisonType

TComparisonType

Да

Тип сравнения

BasedOnProfile

TProfile

Нет

Расширяет профиль пользователями

Замечания:

Создает новый объект класса TProfile.

95.3. Метод Check (Проверка профиля)

Метод класса (статический метод) класса TProfile.
class procedure TProfile.Check(Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

95.4. Метод GetIsActive (Активен для текущего пользователя)

Метод экземпляра класса TProfile.
function TProfile.GetIsActive: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

95.5. Метод GetValueDomain (Получить домен значения)

Метод экземпляра класса TProfile.
function TProfile.GetValueDomain: TDomain;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TDomain.

95.6. Метод Match (Проверка совпадения)

Метод экземпляра класса TProfile.
1function TProfile.Match(Object: TObject; ObjectClass: TClass;
2  ValueGiven: Boolean; StrValue: string[2000]; IntValue: Integer;
3  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
4  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
5  ExternalDataValue: <external data>): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

ValueGiven

Boolean

Да

Значение задано

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Возвращает значение типа Boolean.

95.7. Метод MatchObject (Проверка совпадения объекта)

Метод экземпляра класса TProfile.
function TProfile.MatchObject(Object: TObject; ObjectClass: TClass): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

Замечания:

Возвращает значение типа Boolean.

95.8. Метод TryCheck (Проверка профиля с возвратом результата)

Метод класса (статический метод) класса TProfile.
class function TProfile.TryCheck(Object: TObject; ObjectClass: TClass): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

Замечания:

Возвращает значение типа Boolean.

96. Класс TProfileEvent (События профиля)

96.1. Свойства

Свойства класса TProfileEvent:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Method

TProfileMethod

Да

Скрыто от пользователя

Только для чтения

Метод профилировщика

Class

TClass

Да

Видимо пользователю

Только для чтения

Класс

ObjectID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Видимо пользователю

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

Action

TChangeAction

Да

Видимо пользователю

Только для чтения

Действия

97. Класс TProfileItem (Состав профиля)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

97.1. Свойства

Свойства класса TProfileItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ProfileClass

TClass

Да

Видимо пользователю

Чтение/Запись

Профилируемый класс

ProfileProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Профилируемое свойство

Comparator

TMethod

Нет

Видимо пользователю

Чтение/Запись

Сравнивающая функция

Group

string[64]

Нет

Видимо пользователю

Чтение/Запись

Группа

AllowNulls

Boolean

Да

Видимо пользователю

Чтение/Запись

Пропускать пустые значения

HasCrossCondition

Boolean

Да

Видимо пользователю

Только для чтения

Имеется пересечение условий

97.2. Конструктор Create (Конструктор элемента профиля)

Конструктор класса TProfileItem.
1constructor TProfileItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ProfileClass: TClass; ProfileProperty: TProperty; Comparator: TMethod;
4  Group: string[64]; AllowNulls: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ProfileClass

TClass

Да

Профилируемый класс

ProfileProperty

TProperty

Нет

Профилируемое свойство

Comparator

TMethod

Нет

Сравнивающая функция

Group

string[64]

Нет

Группа

AllowNulls

Boolean

Да

Пропускать пустые значения

Замечания:

Создает новый объект класса TProfileItem.

97.3. Метод GetHasCrossConditions (Имеется пересечение условий)

Метод экземпляра класса TProfileItem.
function TProfileItem.GetHasCrossConditions: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

98. Класс TProfileMethod (Методы профиля)

Объекты класса образуют иерархию.

98.1. Свойства

Свойства класса TProfileMethod:

Имя

Тип

Обязательно

Доступ

Назначение

Parent

TProfileMethod

Нет

Только для чтения

Родитель

Method

TMethod

Да

Только для чтения

Метод профилировщика

MethodClass

TClass

Да

Только для чтения

Класс

Position

Integer

Да

Только для чтения

Позиция

Duration

Integer

Нет

Только для чтения

Общее время

CodeDuration

Integer

Нет

Только для чтения

Время собственного кода

Calls

Integer

Нет

Только для чтения

Количество непосредственных вызовов

Events

Integer

Нет

Только для чтения

Непосредственных операций с данными

CommonCalls

Integer

Нет

Только для чтения

Всего вызовов

CommonEvents

Integer

Нет

Только для чтения

Всего операций с данными

ObjectID

string[38]

Да

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Только для чтения

Идентификатор при создании

98.2. Метод BuildReport (Перестроить отчет)

Метод класса (статический метод) класса TProfileMethod.
class procedure TProfileMethod.BuildReport(QualifyObjects: Boolean);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

QualifyObjects

Boolean

Да

Квалифицировать объекты

98.3. Метод Clear (Очистить статистику)

Метод класса (статический метод) класса TProfileMethod.
class procedure TProfileMethod.Clear;
Метод является методом класса.

Метод не имеет параметров.

98.4. Метод Ole-объекта ExportProfilerReport (Экспортировать отчет)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TProfileMethod.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

99. Класс TProfileStatistics (Статистика профиля)

99.1. Свойства

Свойства класса TProfileStatistics:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Method

TProfileMethod

Да

Скрыто от пользователя

Только для чтения

Метод профилировщика

CalledMethod

TMethod

Нет

Видимо пользователю

Только для чтения

Вызываемый метод

CalledMethodClass

TObject

Да

Видимо пользователю

Только для чтения

Класс

Calls

Integer

Нет

Видимо пользователю

Только для чтения

Количество вызовов

Class

TClass

Нет

Видимо пользователю

Только для чтения

Класс

Inserts

Integer

Нет

Видимо пользователю

Только для чтения

Количество добавлений

Updates

Integer

Нет

Видимо пользователю

Только для чтения

Количество изменений

Deletes

Integer

Нет

Видимо пользователю

Только для чтения

Количество удалений

Type

string[128]

Нет

Видимо пользователю

Только для чтения

Тип

100. Класс TProfileUser (Пользователи профиля)

Объекты класса не именованы.

Наименования объектов класса генерируются.

100.1. Свойства

Свойства класса TProfileUser:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

UserIsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Пользователь является текущим

Profile

TProfile

Да

Скрыто от пользователя

Только для чтения

Профиль

Domain

TDomain

Да

Скрыто от пользователя

Только для чтения

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

100.2. Конструктор Create (Конструктор пользовательского профиля)

Конструктор класса TProfileUser.
1constructor TProfileUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TProfile; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TProfile

Да

Профиль

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Унаследовано от TTypedValue.Create

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

User

TUser

Да

Пользователь

Замечания:

Создает новый объект класса TProfileUser.

101. Класс TProperty (Свойства)

Объекты класса образуют иерархию.

101.1. Свойства

Свойства класса TProperty:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

ReadMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Член класса для чтения

ReadMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для чтения

WriteMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Член класса для записи

WriteMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для записи

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

IsExportable

Boolean

Да

Видимо пользователю

Чтение/Запись

Для экспорта

IsSuspended

Boolean

Да

Видимо пользователю

Чтение/Запись

Отложенное

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

IsUnupdatable

Boolean

Да

Видимо пользователю

Чтение/Запись

Необновляемое при импорте

NullHandler

TMethod

Нет

Видимо пользователю

Чтение/Запись

Обработчик пустого значения

OnDemand

Boolean

Да

Видимо пользователю

Чтение/Запись

По требованию

101.2. Конструктор Create (Конструктор свойства)

Конструктор класса TProperty.
1constructor TProperty.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ReadMember: TClassMember; WriteMember: TClassMember;
4  Position: Integer; Scope: TScope; IsExportable: Boolean; IsSuspended: Boolean;
5  CreateViewColumns: Boolean; Category: string[128]): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

ReadMember

TClassMember

Нет

Член класса для чтения

WriteMember

TClassMember

Нет

Член класса для записи

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

IsExportable

Boolean

Да

Для экспорта

IsSuspended

Boolean

Да

Отложенное

CreateViewColumns

Boolean

Да

Создать колонку во всех представлениях

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TProperty.

101.3. Метод Change (Изменение объекта)

Метод экземпляра класса TProperty.
procedure TProperty.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

101.4. Метод CreateChildren (Создать дочерние свойства)

Метод экземпляра класса TProperty.
1procedure TProperty.CreateChildren(ClearWriteMember: Boolean;
2  PublicOnly: Boolean; ExactName: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

ClearWriteMember

Boolean

Да

Создавать свойства только для чтения

PublicOnly

Boolean

Да

Создавать только видимые свойства

ExactName

Boolean

Да

Не изменять имя свойства

101.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TProperty.
class function TProperty.GetNextPos(Master: TObject; Parent: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Integer.

101.6. Метод LocalizableFieldName (Получить имя локализуемого поля)

Метод класса (статический метод) класса TProperty.
1class function TProperty.LocalizableFieldName(Class: TClass;
2  Name: string[64]): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Class

TClass

Нет

Класс

Name

string[64]

Да

Имя

Замечания:

Возвращает значение типа string[64].

101.7. Метод LocalizableProperty (Локализуемое свойство)

Метод класса (статический метод) класса TProperty.
1class function TProperty.LocalizableProperty(ClassName: string[64];
2  PropertyName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

PropertyName

string[64]

Да

Имя свойства

Замечания:

Возвращает значение типа Boolean.

101.8. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TProperty.
function TProperty.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TClassMember.SuggestFileName, TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

102. Класс TPropertyBan (Запрет на свойство)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

102.1. Свойства

Свойства класса TPropertyBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

BannedProperty

TProperty

Да

Видимо пользователю

Только для чтения

Запрещаемое свойство

AllowRead

Boolean

Да

Видимо пользователю

Чтение/Запись

Чтение разрешено

102.2. Конструктор Create (Конструктор запрета на свойство)

Конструктор класса TPropertyBan.
1constructor TPropertyBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedProperty: TProperty; AllowRead: Boolean): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

BannedProperty

TProperty

Да

Запрещаемое свойство

AllowRead

Boolean

Да

Чтение разрешено

Замечания:

Создает новый объект класса TPropertyBan.

103. Класс TQueue (Очередь)

103.1. Свойства

Свойства класса TQueue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

QueueName

string[64]

Да

Видимо пользователю

Только для чтения

Имя очереди

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время входа в очередь

Object

TObject

Нет

Видимо пользователю

Только для чтения

Объект

ObjectName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Видимо пользователю

Только для чтения

Наименование объекта

ObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс объекта

ObjectParent

TObject

Нет

Скрыто от пользователя

Только для чтения

Объект-родитель

ObjectMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Объект-мастер

ObjectSourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

База данных-источник

ObjectOldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Идентификатор объекта при создании

ObjectCreator

TUser

Да

Скрыто от пользователя

Только для чтения

Объект создан пользователем

ObjectCreated

datetime

Да

Скрыто от пользователя

Только для чтения

Объект создан

ObjectModifier

TUser

Да

Скрыто от пользователя

Только для чтения

Объект изменен пользователем

ObjectModified

datetime

Да

Скрыто от пользователя

Только для чтения

Объект изменен

Processed

Boolean

Да

Видимо пользователю

Только для чтения

Обработан

103.2. Конструктор Create (Конструктор объекта в очереди)

Конструктор класса TQueue.
constructor TQueue.Create(Object: TObject; QueueName: string[64]): TObject;
Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

QueueName

string[64]

Да

Имя очереди

Замечания:

Создает новый объект класса TQueue.

103.3. Деструктор Destroy (Деструктор объекта в очереди)

Деструктор класса TQueue.
destructor TQueue.Destroy;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TQueue или его наследника.

103.4. Метод Clear (Очистить очередь)

Метод класса (статический метод) класса TQueue.
class procedure TQueue.Clear(QueueName: string[64]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

QueueName

string[64]

Да

Имя очереди

104. Класс TRole (Роли)

104.1. Свойства

Свойства класса TRole:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущей

104.2. Конструктор Create (Конструктор роли)

Конструктор класса TRole.
1constructor TRole.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TRole.

104.3. Метод GetIsCurrent (Является текущей)

Метод экземпляра класса TRole.
function TRole.GetIsCurrent: Boolean;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

105. Класс TRoleMember (Пользователи в ролях)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

105.1. Свойства

Свойства класса TRoleMember:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

User

TSecurityAccount

Да

Видимо пользователю

Только для чтения

Пользователь

UserClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс члена роли

IsPrimary

Boolean

Да

Видимо пользователю

Чтение/Запись

Основная роль

105.2. Конструктор Create (Конструктор члена роли)

Конструктор класса TRoleMember.
1constructor TRoleMember.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TRole; Accessor: TSecurityAccount;
3  User: TSecurityAccount; IsPrimary: Boolean; AddLinked: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TRole

Да

Роль

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

User

TSecurityAccount

Да

Пользователь

IsPrimary

Boolean

Да

Основная роль

AddLinked

Boolean

Да

Добавить связанные роли

Замечания:

Создает новый объект класса TRoleMember.

105.3. Метод SetIsPrimary (Установка значения свойства "Является основной")

Метод экземпляра класса TRoleMember.
procedure TRoleMember.SetIsPrimary(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

106. Класс TRoutine (Подпрограмма)

106.1. Свойства

Свойства класса TRoutine:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Домен результата

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена результата

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена результата

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Является методом класса

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Текст подтверждения

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Использовать закладки

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт формы параметров

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение-иконка

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество параметров

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

Сообщение о выполнении

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

Вызывать только для одного объекта

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

106.2. Конструктор Create (Конструктор подпрограммы)

Конструктор класса TRoutine.
1constructor TRoutine.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Является методом класса

SingleObject

Boolean

Да

Вызывать только для одного объекта

Domain

TDomain

Нет

Домен результата

Scope

TScope

Да

Область видимости

Confirmation

string[512]

Нет

Текст подтверждения

ReportMessage

string[512]

Нет

Сообщение о выполнении

UseTabs

Boolean

Да

Использовать закладки

Script

clob

Нет

Скрипт формы параметров

Image

blob

Нет

Изображение-иконка

Logged

Boolean

Да

Протоколировать

Замечания:

Создает новый объект класса TRoutine.

106.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TRoutine.
procedure TRoutine.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

106.4. Метод GetParamCount (Количество параметров)

Метод экземпляра класса TRoutine.
function TRoutine.GetParamCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

106.5. Метод ListParameters (Список параметров)

Метод экземпляра класса TRoutine.
function TRoutine.ListParameters: TObjectList;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.

106.6. Метод ParameterByName (Получить параметр по имени)

Метод экземпляра класса TRoutine.
function TRoutine.ParameterByName(AName: string[64]): TParameter;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

AName

string[64]

Да

Имя

Замечания:

Возвращает значение типа TParameter.

106.7. Метод Ole-объекта CreateReportTemplate (Сгенерировать шаблон отчета)

Метод Ole-объекта класса TRoutine.

Метод Ole-объекта не имеет параметров.

107. Класс TRoutineAction (Программируемое действие)

Объекты класса образуют иерархию.

107.1. Свойства

Свойства класса TRoutineAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

ContextProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Выполнять в контексте свойства

AllowNavigation

Boolean

Да

Видимо пользователю

Чтение/Запись

Доступна навигация

107.2. Конструктор Create (Конструктор программируемого действия)

Конструктор класса TRoutineAction.
1constructor TRoutineAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  Routine: TRoutine; ContextProperty: TProperty;
5  AllowNavigation: Boolean): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

Routine

TRoutine

Да

Реализовано посредством

ContextProperty

TProperty

Нет

выполнять в контексте

AllowNavigation

Boolean

Да

Доступна навигация

Замечания:

Создает новый объект класса TRoutineAction.

107.3. Метод EnsureAction (Обеспечить наличие действия)

Метод класса (статический метод) класса TRoutineAction.
1class function TRoutineAction.EnsureAction(AView: TObject; AName: string[64];
2  ADescription: string[128]; APosition: Integer; AShortcut: string[20];
3  ASeparated: Boolean; ARoutine: TRoutine): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AView

TObject

Да

Мастер

AName

string[64]

Да

Имя

ADescription

string[128]

Да

Наименование

APosition

Integer

Да

Позиция

AShortcut

string[20]

Нет

Горячая клавиша

ASeparated

Boolean

Да

Отделено

ARoutine

TRoutine

Да

Реализовано посредством

Замечания:

Возвращает значение типа TObject.

108. Класс TRoutineBan (Запрет на подпрограмму)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

108.1. Свойства

Свойства класса TRoutineBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

BannedRoutine

TRoutine

Да

Видимо пользователю

Только для чтения

Запрещаемая подпрограмма

108.2. Конструктор Create (Конструктор запрета на подпрограмму)

Конструктор класса TRoutineBan.
1constructor TRoutineBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedRoutine: TRoutine): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

BannedRoutine

TRoutine

Да

Запрещаемая подпрограмма

Замечания:

Создает новый объект класса TRoutineBan.

109. Класс TRoutineHistory (Вызовы)

109.1. Свойства

Свойства класса TRoutineHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

ObjectID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Видимо пользователю

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

RoutineName

string[64]

Да

Видимо пользователю

Только для чтения

Подпрограмма

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

RoutineClassName

string[64]

Да

Видимо пользователю

Только для чтения

Имя класса подпрограммы

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

109.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TRoutineHistory.
1class procedure TRoutineHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

109.3. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TRoutineHistory.
1class function TRoutineHistory.Log(Routine: TRoutine;
2  Object: TObject): TRoutineHistory;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Object

TObject

Нет

Объект

Замечания:

Возвращает значение типа TRoutineHistory.

109.4. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TRoutineHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

110. Класс TSecurityAccount (Роли безопасности)

111. Класс TSequence (Последовательности)

111.1. Свойства

Свойства класса TSequence:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Value

string[20]

Да

Видимо пользователю

Чтение/Запись

Текущее значение

Cache

Integer

Нет

Видимо пользователю

Чтение/Запись

Кэш

111.2. Конструктор Create (Конструктор последовательности)

Конструктор класса TSequence.
1constructor TSequence.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TSequence.

111.3. Метод GetCache (Получить кеш)

Метод экземпляра класса TSequence.
function TSequence.GetCache: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

111.4. Метод GetValue (Получить текущее значение)

Метод экземпляра класса TSequence.
function TSequence.GetValue: string[20];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].

111.5. Метод Promote (Получить следующее значение)

Метод экземпляра класса TSequence.
function TSequence.Promote: string[20];
Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].

111.6. Метод SetCache (Установить кеш)

Метод экземпляра класса TSequence.
procedure TSequence.SetCache(Value: Integer);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

111.7. Метод SetValue (Установить текущее значение)

Метод экземпляра класса TSequence.
procedure TSequence.SetValue(Value: string[20]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[20]

Да

Значение

112. Класс TSessionHistory (Сессии)

112.1. Свойства

Свойства класса TSessionHistory:

Имя

Тип

Обязательно

Доступ

Назначение

IntStamp

Integer

Нет

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Только для чтения

Время

User

TUser

Нет

Только для чтения

Пользователь

Login

string[64]

Да

Только для чтения

Логин

CloseStamp

datetime

Нет

Только для чтения

Время закрытия

UserAgent

string[2000]

Нет

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Только для чтения

Информация о соединении

Duration

time

Нет

Только для чтения

Продолжительность

112.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TSessionHistory.
1class procedure TSessionHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

112.3. Метод DBMSConnectionInfo (Информация о соединении от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSConnectionInfo: string[2000];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

112.4. Метод DBMSGetIPAddress (IP-адрес клиента от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSGetIPAddress: string[16];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[16].

112.5. Метод DBMSGetUserAgent (Пользовательский агент от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSGetUserAgent: string[2000];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

112.6. Метод GetCurrentSession (Идентификатор текущей сессии)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.GetCurrentSession: TSessionHistory;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TSessionHistory.

112.7. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TSessionHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

113. Класс TStatement (Операторы)

113.1. Конструктор Create (Конструктор оператора)

Конструктор класса TStatement.
constructor TStatement.Create: TObject;
Метод не имеет параметров.

Замечания:

Создает новый объект класса TStatement.

113.2. Метод BoolLiteral (Логический литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.BoolLiteral(Value: Boolean): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

Замечания:

Возвращает значение типа string[2000].

113.3. Метод BuildFunctionCall (Построить вызов функции)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildFunctionCall(Function: TMethod;
2  Parameters: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Function

TMethod

Нет

Функция

Parameters

string[2000]

Нет

Параметры вызова

Замечания:

Возвращает значение типа string[2000].

113.4. Метод BuildInsertStatement (Построить скрипт добавления объекта)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildInsertStatement(AObject: TObject;
2  AClass: TClass): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AObject

TObject

Да

Объект

AClass

TClass

Нет

Класс

Замечания:

Возвращает значение типа clob.

113.5. Метод BuildProcedureCall (Построить вызов процедуры)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildProcedureCall(Procedure: TMethod;
2  Parameters: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Procedure

TMethod

Нет

Процедура

Parameters

string[2000]

Нет

Параметры вызова

Замечания:

Возвращает значение типа string[2000].

113.6. Метод BuildUpdateStatement (Построить скрипт изменения объекта)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildUpdateStatement(AObject: TObject;
2  AClass: TClass): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AObject

TObject

Да

Объект

AClass

TClass

Нет

Класс

Замечания:

Возвращает значение типа clob.

113.7. Метод Change (Изменение объекта)

Метод экземпляра класса TStatement.
procedure TStatement.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

113.8. Метод DateLiteral (Литерал типа "дата")

Метод класса (статический метод) класса TStatement.
class function TStatement.DateLiteral(Value: date): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

113.9. Метод DateTimeLiteral (Литерал типа "дата со временем")

Метод класса (статический метод) класса TStatement.
class function TStatement.DateTimeLiteral(Value: datetime): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

113.10. Метод Execute (Выполнить)

Метод класса (статический метод) класса TStatement.
class procedure TStatement.Execute(Statement: string[2000]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

113.11. Метод ExecuteClob (Выполнить большой текстовый объект)

Метод класса (статический метод) класса TStatement.
class procedure TStatement.ExecuteClob(Statement: clob);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

113.12. Метод ExecuteClobToBlobValue (Выполнить большой текстовый объект и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToBlobValue(Statement: clob): blob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа blob.

113.13. Метод ExecuteClobToBoolValue (Выполнить большой текстовый объект и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToBoolValue(Statement: clob): Boolean;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа Boolean.

113.14. Метод ExecuteClobToClobValue (Выполнить большой текстовый объект и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToClobValue(Statement: clob): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа clob.

113.15. Метод ExecuteClobToDateTimeValue (Выполнить большой текстовый объект и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToDateTimeValue(Statement: clob): datetime;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа datetime.

113.16. Метод ExecuteClobToDateValue (Выполнить большой текстовый объект и вернуть значение даты)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToDateValue(Statement: clob): date;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа date.

113.17. Метод ExecuteClobToExternalDataValue (Выполнить большой текстовый объект и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ExecuteClobToExternalDataValue(Statement: clob): <external
2  data>;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа <external data>.

113.18. Метод ExecuteClobToFloatValue (Выполнить большой текстовый объект и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToFloatValue(Statement: clob): float;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа float.

113.19. Метод ExecuteClobToIntValue (Выполнить большой текстовый объект и вернуть целое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToIntValue(Statement: clob): Integer;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа Integer.

113.20. Метод ExecuteClobToObjectValue (Выполнить большой текстовый объект и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToObjectValue(Statement: clob): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа TObject.

113.21. Метод ExecuteClobToStrValue (Выполнить большой текстовый объект и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToStrValue(Statement: clob): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа string[2000].

113.22. Метод ExecuteClobToTimeValue (Выполнить большой текстовый объект и вернуть значение времени)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToTimeValue(Statement: clob): time;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа time.

113.23. Метод ExecuteToBlobValue (Выполнить и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToBlobValue(Statement: string[2000]): blob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа blob.

113.24. Метод ExecuteToBoolValue (Выполнить и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToBoolValue(Statement: string[2000]): Boolean;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа Boolean.

113.25. Метод ExecuteToClobValue (Выполнить и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToClobValue(Statement: string[2000]): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа clob.

113.26. Метод ExecuteToDateTimeValue (Выполнить и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToDateTimeValue(Statement: string[2000]): datetime;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа datetime.

113.27. Метод ExecuteToDateValue (Выполнить и вернуть значение даты)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToDateValue(Statement: string[2000]): date;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа date.

113.28. Метод ExecuteToExternalDataValue (Выполнить и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ExecuteToExternalDataValue(Statement: string[2000]): <external
2  data>;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа <external data>.

113.29. Метод ExecuteToFloatValue (Выполнить и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToFloatValue(Statement: string[2000]): float;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа float.

113.30. Метод ExecuteToIntValue (Выполнить и вернуть целое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToIntValue(Statement: string[2000]): Integer;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа Integer.

113.31. Метод ExecuteToObjectValue (Выполнить и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToObjectValue(Statement: string[2000]): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа TObject.

113.32. Метод ExecuteToStrValue (Выполнить и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToStrValue(Statement: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа string[2000].

113.33. Метод ExecuteToTimeValue (Выполнить и вернуть значение времени)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToTimeValue(Statement: string[2000]): time;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа time.

113.34. Метод FloatLiteral (Вещественный литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.FloatLiteral(Value: float): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

113.35. Метод IntLiteral (Целочисленный литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.IntLiteral(Value: Integer): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

113.36. Метод ObjectLiteral (Литерал-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ObjectLiteral(Value: TObject): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

113.37. Метод QualifyDBMSName (Квалифицировать имя объекта БД)

Метод класса (статический метод) класса TStatement.
class function TStatement.QualifyDBMSName(DBMSName: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DBMSName

string[2000]

Нет

Имя объекта БД

Замечания:

Возвращает значение типа string[2000].

113.38. Метод SequenceLiteral (Литерал значения последовательности)

Метод класса (статический метод) класса TStatement.
class function TStatement.SequenceLiteral(SequenceName: string[64]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

SequenceName

string[64]

Да

Имя последовательности

Замечания:

Возвращает значение типа string[2000].

113.39. Метод StringAggregate (Агрегировать строки запроса)

Метод класса (статический метод) класса TStatement.
1class function TStatement.StringAggregate(Statement: string[2000];
2  Delimiter: string[2000]): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа clob.

113.40. Метод StringLiteral (Строковый литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.StringLiteral(Value: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

113.41. Метод TimeLiteral (Литерал типа "время")

Метод класса (статический метод) класса TStatement.
class function TStatement.TimeLiteral(Value: time): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

113.42. Метод ToString (Приведение литерала к строке)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ToString(Literal: string[2000]; Domain: TDomain;
2  CanUseTables: Boolean): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Literal

string[2000]

Нет

Литерал

Domain

TDomain

Нет

Домен

CanUseTables

Boolean

Да

Использовать таблицы

Замечания:

Возвращает значение типа string[2000].

114. Класс TStringBuilder (Шаблоны строк)

114.1. Свойства

Свойства класса TStringBuilder:

Имя

Тип

Обязательно

Доступ

Назначение

Template

string[2000]

Нет

Чтение/Запись

Шаблон

TemplateClob

clob

Нет

Чтение/Запись

Шаблон - большой текстовый объект

114.2. Конструктор Create (Конструктор шаблона строк)

Конструктор класса TStringBuilder.
1constructor TStringBuilder.Create(Template: string[2000];
2  TemplateClob: clob): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

TemplateClob

clob

Нет

Шаблон - большой текстовый объект

Замечания:

Создает новый объект класса TStringBuilder.

114.3. Метод Append (Добавить строку)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.Append(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа TStringBuilder.

114.4. Метод AppendToClob (Добавить строку к большому текстовому объекту)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.AppendToClob(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа TStringBuilder.

114.5. Метод Apply (Применить значение)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.Apply(Name: string[2000];
2  Value: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TStringBuilder.

114.6. Метод ApplyClob (Применить значение - большой текстовый объект)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.ApplyClob(Name: string[2000];
2  Value: clob): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Name

string[2000]

Нет

Имя

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TStringBuilder.

114.7. Метод ApplyObject (Применить свойства объекта)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.ApplyObject(Object: TObject): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

Замечания:

Возвращает значение типа TStringBuilder.

114.8. Метод Build (Построить строку)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.Build: string[2000];
Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

114.9. Метод BuildClob (Построить большой текстовый объект)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.BuildClob: clob;
Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

114.10. Метод ClearAll (Очистить все шаблоны строк)

Метод класса (статический метод) класса TStringBuilder.
class procedure TStringBuilder.ClearAll;
Метод является методом класса.

Метод не имеет параметров.

114.11. Метод ClobApply (Применить значение к большому текстовому объекту)

Метод класса (статический метод) класса TStringBuilder.
1class function TStringBuilder.ClobApply(Template: clob; Name: string[2000];
2  Value: string[2000]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

clob

Нет

Шаблон

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа clob.

114.12. Метод DebugTemplate (Отладить шаблон)

Метод класса (статический метод) класса TStringBuilder.
1class procedure TStringBuilder.DebugTemplate(Template: clob; Names: clob;
2  ApplyResult: clob);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

clob

Нет

Шаблон

Names

clob

Нет

Имена

ApplyResult

clob

Нет

Результат применения

114.13. Метод StrApply (Применить значение к строке)

Метод класса (статический метод) класса TStringBuilder.
1class function TStringBuilder.StrApply(Template: string[2000];
2  Name: string[2000]; Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

115. Класс TStringDomain (Строковые)

115.1. Свойства

Свойства класса TStringDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Длина

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимы начальные пробелы

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимы конечные пробелы

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимо дублирование пробелов

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Набор символов

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Набор символов первого символа

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Режим регистра

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Маска

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

115.2. Конструктор Create (Конструктор строкового домена)

Конструктор класса TStringDomain.
1constructor TStringDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Максимальная длина

AllowLeadingSpaces

Boolean

Да

Допустимы начальные пробелы

AllowTrailingSpaces

Boolean

Да

Допустимы конечные пробелы

AllowSpaceDuplication

Boolean

Да

Допустимо дублирование пробелов

CharacterSet

string[2000]

Нет

Набор символов

FirstCharacterSet

string[2000]

Нет

Набор символов первого символа

CaseMode

Boolean

Нет

Режим регистра

Mask

string[2000]

Нет

Маска

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TStringDomain.

115.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TStringDomain.
function TStringDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

116. Класс TStringList (Список строк)

Объекты класса не именованы.

116.1. Свойства

Свойства класса TStringList:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Duplicates

TDuplicates

Да

Видимо пользователю

Чтение/Запись

Дублирование

Sorted

Boolean

Да

Видимо пользователю

Чтение/Запись

Сортированный

Delimiter

string[2]

Нет

Видимо пользователю

Чтение/Запись

Разделитель

CaseSensitive

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистрозависимый

116.2. Конструктор Create (Конструктор списка строк)

Конструктор класса TStringList.
1constructor TStringList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TStringList.

116.3. Метод Add (Добавить строку в список)

Метод экземпляра класса TStringList.
function TStringList.Add(ItemString: string[2000]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

116.4. Метод Archive (Отправить список в архив)

Метод экземпляра класса TStringList.
procedure TStringList.Archive;
Метод не имеет параметров.

116.5. Метод Clear (Очистить список)

Метод экземпляра класса TStringList.
procedure TStringList.Clear;
Метод скрыт от пользователя.

Метод не имеет параметров.

116.6. Метод ClobField (Поле в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobField(Text: clob; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

FieldIndex

Integer

Нет

Номер поля

Замечания:

Возвращает значение типа string[2000].

116.7. Метод ClobFieldCount (Количество полей в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobFieldCount(Text: clob;
2  Delimiter: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Замечания:

Возвращает значение типа Integer.

116.8. Метод ClobFieldIndexOf (Индекс вхождения в состав большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobFieldIndexOf(Text: clob; Delimiter: string[2];
2  Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

116.9. Метод Delete (Удалить элемент из списка по индексу)

Метод экземпляра класса TStringList.
procedure TStringList.Delete(ItemIndex: Integer);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

116.10. Метод GetDelimitedText (Получить в виде разделенного текста)

Метод экземпляра класса TStringList.
function TStringList.GetDelimitedText: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

116.11. Метод GetDelimitedTextAsClob (Получить в виде разделенного большого текстового объекта)

Метод экземпляра класса TStringList.
function TStringList.GetDelimitedTextAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

116.12. Метод GetItem (Получить строку по индексу)

Метод экземпляра класса TStringList.
function TStringList.GetItem(ItemIndex: Integer): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

Замечания:

Возвращает значение типа string[2000].

116.13. Метод IndexOf (Получить индекс строки в списке)

Метод экземпляра класса TStringList.
function TStringList.IndexOf(ItemString: string[2000]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

116.14. Метод Insert (Вставить строку в список)

Метод экземпляра класса TStringList.
procedure TStringList.Insert(ItemIndex: Integer; ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemString

string[2000]

Нет

Строка

116.15. Метод Length (Длина списка)

Метод экземпляра класса TStringList.
function TStringList.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

116.16. Метод Remove (Удалить строку из списка)

Метод экземпляра класса TStringList.
procedure TStringList.Remove(ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

116.17. Метод SetDelimitedText (Создать элементы списка на основе разделенного текста)

Метод экземпляра класса TStringList.
procedure TStringList.SetDelimitedText(Text: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

116.18. Метод SetItem (Установить значение элемента)

Метод экземпляра класса TStringList.
procedure TStringList.SetItem(ItemIndex: Integer; ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemString

string[2000]

Нет

Строка

116.19. Метод Sort (Сортировать)

Метод экземпляра класса TStringList.
procedure TStringList.Sort;
Метод скрыт от пользователя.

Метод не имеет параметров.

116.20. Метод StrField (Поле в составе строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrField(Text: string[2000]; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

FieldIndex

Integer

Нет

Номер поля

Замечания:

Возвращает значение типа string[2000].

116.21. Метод StrFieldCount (Количество полей в составе строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrFieldCount(Text: string[2000];
2  Delimiter: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Замечания:

Возвращает значение типа Integer.

116.22. Метод StrFieldIndexOf (Индекс вхождения в состав строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrFieldIndexOf(Text: string[2000];
2  Delimiter: string[2]; Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

117. Класс TStringListItem (Элемент списка строк)

Объекты класса не именованы.

117.1. Свойства

Свойства класса TStringListItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

StringItem

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Строка

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

117.2. Конструктор Create (Конструктор элемента списка строк)

Конструктор класса TStringListItem.
1constructor TStringListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  StringItem: string[2000]; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

StringItem

string[2000]

Нет

Строка

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TStringListItem.

118. Класс TSystemMessage (Системные сообщения)

118.1. Свойства

Свойства класса TSystemMessage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

Text

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Текст

Data

blob

Нет

Видимо пользователю

Чтение/Запись

Данные

DataAsText

clob

Нет

Видимо пользователю

Только для чтения

Данные как текст

118.2. Метод Allow (Системные сообщения разрешены)

Метод класса (статический метод) класса TSystemMessage.
class function TSystemMessage.Allow: Boolean;
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

118.3. Метод Clear (Очистить системные сообщения)

Метод класса (статический метод) класса TSystemMessage.
1class procedure TSystemMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

118.4. Метод Post (Отправить системное сообщение)

Метод класса (статический метод) класса TSystemMessage.
class procedure TSystemMessage.Post(Text: string[2000]; Data: blob);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Data

blob

Нет

Данные

119. Класс TSystemMetadata (Системные метаданные)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

119.1. Свойства

Свойства класса TSystemMetadata:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Data

clob

Нет

Видимо пользователю

Только для чтения

Данные

CRC

string[8]

Нет

Видимо пользователю

Только для чтения

Контрольная сумма

119.2. Метод Change (Изменение объекта)

Метод экземпляра класса TSystemMetadata.
procedure TSystemMetadata.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

119.3. Метод InternalHash (Вычислить внутренний хеш)

Метод класса (статический метод) класса TSystemMetadata.
class function TSystemMetadata.InternalHash: string[128];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].

119.4. Метод Store (Сохранить метаданные)

Метод класса (статический метод) класса TSystemMetadata.
class procedure TSystemMetadata.Store(Data: clob; CRC: string[8]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Data

clob

Нет

Данные

CRC

string[8]

Нет

Контрольная сумма

120. Класс TTextIndex (Индекс текстового поиска)

120.1. Свойства

Свойства класса TTextIndex:

Имя

Тип

Обязательно

Доступ

Назначение

Field

TField

Да

Только для чтения

Поле

ObjectClass

TClass

Да

Только для чтения

Класс объекта

Object

TObject

Да

Только для чтения

Объект

ObjectName

string[64]

Да

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Только для чтения

Наименование объекта

ObjectParent

TObject

Нет

Только для чтения

Родитель объекта

ObjectMaster

TObject

Да

Только для чтения

Мастер объекта

TopLevelObject

TObject

Нет

Только для чтения

Объект верхнего уровня

Entry

TTextIndexEntry

Да

Только для чтения

Вхождение

Word

string[64]

Да

Только для чтения

Слово

UpperWord

string[64]

Да

Только для чтения

Слово в верхнем регистре

120.2. Метод CleanUp (Очистить индекс)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.CleanUp(Field: TField; Object: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Field

TField

Нет

Поле

Object

TObject

Да

Объект

120.3. Метод HashClob (Хэш индекса большого текстового объекта)

Метод класса (статический метод) класса TTextIndex.
class function TTextIndex.HashClob(Value: clob; IsXHTML: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

IsXHTML

Boolean

Да

Содержимое является XHTML

Замечания:

Возвращает значение типа string[2000].

120.4. Метод HashIndex (Хэш индекса)

Метод класса (статический метод) класса TTextIndex.
1class function TTextIndex.HashIndex(Field: TField;
2  Object: TObject): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

Замечания:

Возвращает значение типа string[2000].

120.5. Метод HashValue (Хэш значения)

Метод класса (статический метод) класса TTextIndex.
class function TTextIndex.HashValue(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

120.6. Метод IndexClob (Индексировать большой текстовый объект)

Метод класса (статический метод) класса TTextIndex.
1class procedure TTextIndex.IndexClob(DeleteExistant: Boolean; Value: clob;
2  Field: TField; Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DeleteExistant

Boolean

Да

Удалять существующие

Value

clob

Нет

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

ObjectClass

TClass

Да

Класс объекта

120.7. Метод IndexValue (Индексировать значение)

Метод класса (статический метод) класса TTextIndex.
1class procedure TTextIndex.IndexValue(DeleteExistant: Boolean;
2  Value: string[2000]; Field: TField; Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DeleteExistant

Boolean

Да

Удалять существующие

Value

string[2000]

Нет

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

ObjectClass

TClass

Да

Класс объекта

120.8. Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.LoadFromBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

120.9. Метод PrepareBuffer (Подготовить буфер)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.PrepareBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

120.10. Метод Ole-объекта Rebuild (Перестроить индекс)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TTextIndex.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AClass

TClass

Нет

Класс

AField

TField

Нет

Поле

ThreadCount

Integer

Нет

Количество потоков

121. Класс TTextIndexEntry (Вхождения индекса текстового поиска)

121.1. Свойства

Свойства класса TTextIndexEntry:

Имя

Тип

Обязательно

Доступ

Назначение

Word

string[64]

Да

Только для чтения

Слово

UpperWord

string[64]

Да

Только для чтения

Слово в верхнем регистре

121.2. Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndexEntry.
class procedure TTextIndexEntry.LoadFromBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

122. Класс TTimeDomain (Время)

122.1. Свойства

Свойства класса TTimeDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

HideSeconds

Boolean

Да

Видимо пользователю

Чтение/Запись

Не показывать секунды

122.2. Конструктор Create (Конструктор домена времени)

Конструктор класса TTimeDomain.
1constructor TTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

HideSeconds

Boolean

Да

Не показывать секунды

Замечания:

Создает новый объект класса TTimeDomain.

122.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TTimeDomain.
function TTimeDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

123. Класс TTypedValue (Типизированные значения)

Объекты класса не именованы.

123.1. Свойства

Свойства класса TTypedValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Мастер

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс мастера

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

Строковое значение

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Целое значение

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

Вещественное значение

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

Значение даты

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

Значение времени

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

Значение даты со временем

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Значение-объект

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

Логическое значение

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

Значение-большой объект

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

Значение-текст

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

Значение-внешние данные

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

Видимое значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

123.2. Конструктор Create (Конструктор типизированного значения)

Конструктор класса TTypedValue.
1constructor TTypedValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>): TTypedValue;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Создает новый объект класса TTypedValue.

123.3. Метод CompareBlob (Сравнить большие объекты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareBlob(ComparisonTypeName: string[64];
2  ValueA: blob; ValueB: blob): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

blob

Нет

Значение A

ValueB

blob

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

123.4. Метод CompareBoolean (Сравнить логические значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareBoolean(ComparisonTypeName: string[64];
2  ValueA: Boolean; ValueB: Boolean): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

Boolean

Да

Значение A

ValueB

Boolean

Да

Значение B

Замечания:

Возвращает значение типа Boolean.

123.5. Метод CompareClob (Сравнить тексты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareClob(ComparisonTypeName: string[64];
2  ValueA: clob; ValueB: clob): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

clob

Нет

Значение A

ValueB

clob

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

123.6. Метод CompareDate (Сравнить значения дат)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareDate(ComparisonTypeName: string[64];
2  ValueA: date; ValueB: date): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

date

Нет

Значение A

ValueB

date

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

123.7. Метод CompareDateTime (Сравнить значения даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareDateTime(ComparisonTypeName: string[64];
2  ValueA: datetime; ValueB: datetime): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

datetime

Нет

Значение A

ValueB

datetime

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

123.8. Метод CompareFloat (Сравнить вещественные значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareFloat(ComparisonTypeName: string[64];
2  ValueA: float; ValueB: float): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

float

Нет

Значение A

ValueB

float

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

123.9. Метод CompareInt (Сравнить целые значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareInt(ComparisonTypeName: string[64];
2  ValueA: Integer; ValueB: Integer): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

Integer

Нет

Значение A

ValueB

Integer

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

123.10. Метод CompareList (Сравнить со списком)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareList(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

string[2000]

Нет

Значение A

ValueB

TObject

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

123.11. Метод CompareObject (Сравнить значения-объекты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareObject(ComparisonTypeName: string[64];
2  ValueA: TObject; ValueB: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

TObject

Нет

Значение A

ValueB

TObject

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

123.12. Метод CompareStr (Сравнить строковые значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareStr(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

string[2000]

Нет

Значение A

ValueB

string[2000]

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

123.13. Метод CompareTime (Сравнить значения времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareTime(ComparisonTypeName: string[64];
2  ValueA: time; ValueB: time): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

time

Нет

Значение A

ValueB

time

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

123.14. Метод CreateBlobValue (Создать значение-большой объект)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateBlobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BlobValue: blob): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

BlobValue

blob

Нет

Значение-большой объект

Замечания:

Возвращает значение типа TTypedValue.

123.15. Метод CreateBoolValue (Создать логическое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateBoolValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BoolValue: Boolean): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

BoolValue

Boolean

Нет

Логическое значение

Замечания:

Возвращает значение типа TTypedValue.

123.16. Метод CreateClobValue (Создать значение-текст)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateClobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ClobValue: clob): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ClobValue

clob

Нет

Значение-текст

Замечания:

Возвращает значение типа TTypedValue.

123.17. Метод CreateDateTimeValue (Создать значение даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateDateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateTimeValue: datetime): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

DateTimeValue

datetime

Нет

Значение даты со временем

Замечания:

Возвращает значение типа TTypedValue.

123.18. Метод CreateDateValue (Создать значение даты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateDateValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateValue: date): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

DateValue

date

Нет

Значение даты

Замечания:

Возвращает значение типа TTypedValue.

123.19. Метод CreateExternalDataValue (Создать значение внешних данных)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateExternalDataValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ExternalDataValue: <external data>): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Возвращает значение типа TTypedValue.

123.20. Метод CreateFloatValue (Создать вещественное значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateFloatValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  FloatValue: float): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

FloatValue

float

Нет

Вещественное значение

Замечания:

Возвращает значение типа TTypedValue.

123.21. Метод CreateIntValue (Создать целое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateIntValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  IntValue: Integer): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

IntValue

Integer

Нет

Целое значение

Замечания:

Возвращает значение типа TTypedValue.

123.22. Метод CreateObjectValue (Создать значение-объект)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateObjectValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ObjectValue: TObject): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ObjectValue

TObject

Нет

Значение-объект

Замечания:

Возвращает значение типа TTypedValue.

123.23. Метод CreateStrValue (Создать строковое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateStrValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Строковое значение

Замечания:

Возвращает значение типа TTypedValue.

123.24. Метод CreateTimeValue (Создать значение времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  TimeValue: time): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

TimeValue

time

Нет

Значение времени

Замечания:

Возвращает значение типа TTypedValue.

123.25. Метод FindBlobValue (Поиск значения-большого объекта)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindBlobValue(Master: TObject;
2  ControlName: string[64]): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа blob.

123.26. Метод FindBoolValue (Поиск логического значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindBoolValue(Master: TObject;
2  ControlName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа Boolean.

123.27. Метод FindClobValue (Поиск значения-текста)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindClobValue(Master: TObject;
2  ControlName: string[64]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа clob.

123.28. Метод FindDateTimeValue (Поиск значения даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindDateTimeValue(Master: TObject;
2  ControlName: string[64]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа datetime.

123.29. Метод FindDateValue (Поиск значения даты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindDateValue(Master: TObject;
2  ControlName: string[64]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа date.

123.30. Метод FindExternalDataValue (Поиск значения внешних данных)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindExternalDataValue(Master: TObject;
2  ControlName: string[64]): <external data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа <external data>.

123.31. Метод FindFloatValue (Поиск вещественного значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindFloatValue(Master: TObject;
2  ControlName: string[64]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа float.

123.32. Метод FindIntValue (Поиск целого значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindIntValue(Master: TObject;
2  ControlName: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа Integer.

123.33. Метод FindObjectValue (Поиск значения-объекта)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindObjectValue(Master: TObject;
2  ControlName: string[64]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа TObject.

123.34. Метод FindStrValue (Поиск строкового значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindStrValue(Master: TObject;
2  ControlName: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа string[2000].

123.35. Метод FindTimeValue (Поиск значения времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindTimeValue(Master: TObject;
2  ControlName: string[64]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа time.

123.36. Метод FindValue (Поиск значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindValue(AMaster: TObject;
2  AControlName: string[64]): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AMaster

TObject

Нет

Объект-мастер

AControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа TTypedValue.

123.37. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер объекта

Parent

TObject

Нет

Родитель

Step

Integer

Да

Шаг

Замечания:

Возвращает значение типа Integer.

123.38. Метод GetVisibleValue (Видимое значение)

Метод экземпляра класса TTypedValue.
function TTypedValue.GetVisibleValue: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

123.39. Метод ReplaceWildcards (Заменить подстановочные символы)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.ReplaceWildcards(Value: string[2000];
2  Escape: string[2]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Escape

string[2]

Нет

Экранирующий символ

Замечания:

Возвращает значение типа string[2000].

123.40. Метод SetValue (Установить значение)

Метод экземпляра класса TTypedValue.
1procedure TTypedValue.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>);
Параметры:

Имя

Тип

Обязательно

Значение

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

124. Класс TTypedValueButton (Кнопки на форме редактирования значений)

124.1. Свойства

Свойства класса TTypedValueButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomButton

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

TypedValue

TTypedValue

Нет

Видимо пользователю

Чтение/Запись

Связанное типизированное значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

124.2. Конструктор Create (Конструктор кнопки формы редактирования значений)

Конструктор класса TTypedValueButton.
1constructor TTypedValueButton.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Group: string[128];
4  Tab: string[128]; Script: clob; Scope: TScope; OutOfTabs: Boolean;
5  TypedValue: TTypedValue): TObject;
Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TCustomButton.Create

Group

string[128]

Нет

Tab

string[128]

Нет

Script

clob

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

TypedValue

TTypedValue

Нет

Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueButton.

125. Класс TTypedValueView (Представления на форме редактирования значений)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

125.1. Свойства

Свойства класса TTypedValueView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TFormView

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Layout

TFormViewLayout

Да

Видимо пользователю

Чтение/Запись

ChildrenOnTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

ExplicitQuery

Boolean

Да

Видимо пользователю

Чтение/Запись

SpacePercentage

Integer

Нет

Видимо пользователю

Чтение/Запись

TypedValue

TTypedValue

Нет

Видимо пользователю

Чтение/Запись

Связанное типизированное значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор связанного типизированного значения

ViewName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

125.2. Конструктор Create (Конструктор представления на форме редактирования значений)

Конструктор класса TTypedValueView.
1constructor TTypedValueView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout; ExplicitQuery: Boolean;
6  TypedValue: TTypedValue): TObject;
Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Унаследовано от TFormView.Create

ChildrenMinimized

Boolean

Да

ChildrenOnTabs

Boolean

Да

MasterProperty

TProperty

Нет

DetailProperty

TClassMember

Нет

Position

Integer

Да

SpacePercentage

Integer

Нет

Layout

TFormViewLayout

Да

ExplicitQuery

Boolean

Да

TypedValue

TTypedValue

Нет

Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueView.

126. Класс TUser (Пользователи)

126.1. Свойства

Свойства класса TUser:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущим

AccessMode

TUserAccessMode

Да

Видимо пользователю

Чтение/Запись

Режим доступа

CanRecieveMessages

Boolean

Да

Видимо пользователю

Чтение/Запись

Получает сообщения

126.2. Конструктор Create (Конструктор пользователя)

Конструктор класса TUser.
1constructor TUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CanRecieveMessages: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

CanRecieveMessages

Boolean

Да

Получает сообщения

Замечания:

Создает новый объект класса TUser.

126.3. Метод EffectiveMemberOf (Является эффективным членом)

Метод экземпляра класса TUser.
function TUser.EffectiveMemberOf(Role: TRole): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Role

TRole

Да

Роль

Замечания:

Возвращает значение типа Boolean.

126.4. Метод GetCurrentUser (Получить текущего пользователя)

Метод класса (статический метод) класса TUser.
class function TUser.GetCurrentUser: TUser;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TUser.

126.5. Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TUser.
function TUser.GetIsCurrent: Boolean;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

127. Класс TUserNotification (Уведомления)

127.1. Свойства

Свойства класса TUserNotification:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Type

TNotificationType

Да

Видимо пользователю

Чтение/Запись

Тип

Text

clob

Нет

Видимо пользователю

Чтение/Запись

Текст

Active

Boolean

Да

Видимо пользователю

Чтение/Запись

Активно

ShowFrom

datetime

Нет

Видимо пользователю

Чтение/Запись

Показывать с

ShowTo

datetime

Нет

Видимо пользователю

Чтение/Запись

Показывать по

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

Выделено

ShowNeeded

Boolean

Да

Скрыто от пользователя

Только для чтения

Необходимо показывать

127.2. Конструктор Create (Конструктор уведомления)

Конструктор класса TUserNotification.
1constructor TUserNotification.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Type: TNotificationType; Text: clob;
4  Active: Boolean; ShowFrom: datetime; ShowTo: datetime): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Type

TNotificationType

Да

Тип

Text

clob

Нет

Текст

Active

Boolean

Да

Активно

ShowFrom

datetime

Нет

Показывать с

ShowTo

datetime

Нет

Показывать по

Замечания:

Создает новый объект класса TUserNotification.

127.3. Метод GetShowNeeded (Необходимо показывать)

Метод экземпляра класса TUserNotification.
function TUserNotification.GetShowNeeded: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

127.4. Метод Preview (Предпросмотр)

Метод экземпляра класса TUserNotification.
procedure TUserNotification.Preview;
Метод не имеет параметров.

127.5. Метод Shown (Отметить как показанное)

Метод экземпляра класса TUserNotification.
procedure TUserNotification.Shown;
Метод скрыт от пользователя.

Метод не имеет параметров.

128. Класс TUserNotificationAddressee (Адресаты уведомлений)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

128.1. Свойства

Свойства класса TUserNotificationAddressee:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

128.2. Конструктор Create (Конструктор адресата уведомления)

Конструктор класса TUserNotificationAddressee.
1constructor TUserNotificationAddressee.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TUserNotificationAddressee.

129. Класс TUserNotificationShown (Показы уведомлений)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

129.1. Свойства

Свойства класса TUserNotificationShown:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TUserNotification

Да

Скрыто от пользователя

Только для чтения

Уведомление

Type

TNotificationType

Да

Видимо пользователю

Только для чтения

Тип уведомления

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

129.2. Конструктор Create (Конструктор показа уведомления)

Конструктор класса TUserNotificationShown.
1constructor TUserNotificationShown.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TUserNotificationShown.

130. Класс TView (Представления)

130.1. Свойства

Свойства класса TView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomView

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

IsGrouped

Boolean

Да

Видимо пользователю

Только для чтения

Сгруппировано

LinesPerRow

Integer

Да

Видимо пользователю

Чтение/Запись

Строк на ячейку

Collapsed

Boolean

Да

Видимо пользователю

Чтение/Запись

Свернуть

HasPresentations

Boolean

Да

Видимо пользователю

Только для чтения

Имеет виды

IsSorted

Boolean

Да

Видимо пользователю

Только для чтения

Отсортировано

IsAggregated

Boolean

Да

Видимо пользователю

Только для чтения

Агрегировано

130.2. Конструктор Create (Конструктор представления)

Конструктор класса TView.
1constructor TView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  Collapsed: Boolean): TObject;
Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Унаследовано от TCustomView.Create

ColorProperty

TProperty

Нет

BoldProperty

TProperty

Нет

Skimpy

Boolean

Да

PreCompiled

Boolean

Да

PreOpenRoutine

TRoutine

Нет

Collapsed

Boolean

Да

Свернуто

Замечания:

Создает новый объект класса TView.

130.3. Метод BuildDefaultColumns (Создать колонки по умолчанию)

Метод экземпляра класса TView.
1procedure TView.BuildDefaultColumns(AddNameColumn: Boolean;
2  AddDescColumn: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

AddNameColumn

Boolean

Да

Создать колонку имени

AddDescColumn

Boolean

Да

Создать колонку наименования

130.4. Метод GetHasPresentations (Имеет виды)

Метод экземпляра класса TView.
function TView.GetHasPresentations: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

130.5. Метод GetIsAggregated (Агрегировано)

Метод экземпляра класса TView.
function TView.GetIsAggregated: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

130.6. Метод GetIsGrouped (Сгруппировано)

Метод экземпляра класса TView.
function TView.GetIsGrouped: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

130.7. Метод GetIsSorted (Отсортировано)

Метод экземпляра класса TView.
function TView.GetIsSorted: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

131. Класс TViewAction (Действие-представление)

Объекты класса образуют иерархию.

131.1. Свойства

Свойства класса TViewAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

131.2. Конструктор Create (Конструктор действия-представления)

Конструктор класса TViewAction.
1constructor TViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  View: TCustomView; MasterProperty: TProperty;
5  DetailProperty: TClassMember): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

View

TCustomView

Да

Представление

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

Замечания:

Создает новый объект класса TViewAction.

132. Класс TViewColumn (Колонки представлений)

132.1. Свойства

Свойства класса TViewColumn:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Property

TProperty

Да

Видимо пользователю

Чтение/Запись

Свойство

PropertyDomain

TDomain

Да

Видимо пользователю

Только для чтения

Домен

PropertyDomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

PropertyReadMember

TClassMember

Нет

Видимо пользователю

Только для чтения

Член класса для чтения

PropertyReadMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для чтения

PropertyWriteMember

TClassMember

Нет

Видимо пользователю

Только для чтения

Член класса для записи

PropertyName

string[64]

Да

Видимо пользователю

Только для чтения

Имя свойства

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Grouped

Boolean

Да

Видимо пользователю

Чтение/Запись

Группировать

Aggregate

TAggregateKind

Нет

Видимо пользователю

Чтение/Запись

Агрегат

SortDirection

TSortDirection

Да

Видимо пользователю

Чтение/Запись

Направление сортировки

Width

Integer

Да

Видимо пользователю

Чтение/Запись

Ширина

Filter

string[128]

Нет

Видимо пользователю

Чтение/Запись

Фильтр

ForceReadOnly

Boolean

Да

Видимо пользователю

Чтение/Запись

Только для чтения

Fixed

Boolean

Да

Видимо пользователю

Чтение/Запись

Зафиксирована

IsFilterHidden

Boolean

Да

Видимо пользователю

Чтение/Запись

Фильтр скрыт

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Bold

Boolean

Да

Видимо пользователю

Чтение/Запись

Выделить шрифтом

DirectAction

TAction

Нет

Видимо пользователю

Чтение/Запись

Непосредственное действие

IsSpecificalyNamed

Boolean

Да

Видимо пользователю

Только для чтения

Специфическое имя

132.2. Конструктор Create (Конструктор колонки представления)

Конструктор класса TViewColumn.
1constructor TViewColumn.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Property: TProperty; Position: Integer; Grouped: Boolean;
4  Aggregate: TAggregateKind; SortDirection: TSortDirection; Fixed: Boolean;
5  Category: string[128]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Property

TProperty

Да

Свойство

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TViewColumn.

132.3. Метод Change (Изменение объекта)

Метод экземпляра класса TViewColumn.
procedure TViewColumn.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

132.4. Метод CreateByNames (Добавить по списку свойств)

Метод класса (статический метод) класса TViewColumn.
1class procedure TViewColumn.CreateByNames(Master: TCustomView;
2  Names: string[2000]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TCustomView

Да

Мастер

Names

string[2000]

Нет

Имена свойств

132.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TViewColumn.
class function TViewColumn.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

132.6. Метод NameAfterProperty (Дать имя свойства)

Метод экземпляра класса TViewColumn.
procedure TViewColumn.NameAfterProperty;
Метод скрыт от пользователя.

Метод не имеет параметров.

133. Класс TViewCondition (Условия отбора)

Объекты класса образуют иерархию.

133.1. Свойства

Свойства класса TViewCondition:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

LinkedClass

TClass

Нет

Видимо пользователю

Чтение/Запись

Присоединяемый класс

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

LinkedOption

TOption

Нет

Видимо пользователю

Чтение/Запись

Присоединенная настройка

LinkedOptionName

string[64]

Да

Видимо пользователю

Только для чтения

Имя присоединяемой настройки

LinkedOptionProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство присоединенной настройки

Expression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение условия

Negation

Boolean

Да

Видимо пользователю

Чтение/Запись

Отрицание

LinkNonRequired

Boolean

Да

Видимо пользователю

Чтение/Запись

Присоединять необязательное свойство

LinkedProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Присоединенный профиль

133.2. Конструктор Create (Конструктор условия отбора)

Конструктор класса TViewCondition.
1constructor TViewCondition.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  LinkedClass: TClass; MasterProperty: TProperty; DetailProperty: TClassMember;
4  LinkedOption: TOption; LinkedOptionProperty: TClassMember; Expression: clob;
5  Negation: Boolean; LinkNonRequired: Boolean; LinkedProfile: TProfile): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

LinkedClass

TClass

Нет

Присоединяемый класс

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

LinkedOption

TOption

Нет

Присоединенная настройка

LinkedOptionProperty

TClassMember

Нет

Свойство присоединенной настройки

Expression

clob

Нет

Выражение условия отбора

Negation

Boolean

Да

Отрицание

LinkNonRequired

Boolean

Да

Присоединять необязательное свойство

LinkedProfile

TProfile

Нет

Присоединенный профиль

Замечания:

Создает новый объект класса TViewCondition.

134. Класс TViewPresentation (Виды)

Имена объектов класса генерируются.

134.1. Свойства

Свойства класса TViewPresentation:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления минимизированы

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

Использовать по умолчанию

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

134.2. Конструктор Create (Конструктор вида)

Конструктор класса TViewPresentation.
1constructor TViewPresentation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer;
4  ChildrenMinimized: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

Замечания:

Создает новый объект класса TViewPresentation.

134.3. Метод GetIsAccessible (Проверка доступности)

Метод экземпляра класса TViewPresentation.
function TViewPresentation.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

134.4. Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentation.
1class function TViewPresentation.Save(Master: TObject;
2  Description: string[128]; ChildrenMinimized: Boolean): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Да

Мастер

Description

string[128]

Да

Наименование

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

Замечания:

Возвращает значение типа TObject.

135. Класс TViewPresentationAccess (Доступ к видам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

135.1. Конструктор Create (Конструктор доступа к виду)

Конструктор класса TViewPresentationAccess.
1constructor TViewPresentationAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TViewPresentationAccess.

136. Класс TViewPresentationColumn (Колонки вида)

Имена объектов класса генерируются.

136.1. Свойства

Свойства класса TViewPresentationColumn:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Column

TViewColumn

Да

Видимо пользователю

Только для чтения

Колонка представления

Presentation

TViewPresentation

Да

Скрыто от пользователя

Только для чтения

Вид

View

TObject

Да

Скрыто от пользователя

Только для чтения

Представление

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Grouped

Boolean

Да

Видимо пользователю

Чтение/Запись

Сгруппирована

Aggregate

TAggregateKind

Нет

Видимо пользователю

Чтение/Запись

Агрегат

SortDirection

TSortDirection

Да

Видимо пользователю

Чтение/Запись

Направление сортировки

Width

Integer

Да

Видимо пользователю

Чтение/Запись

Ширина

Filter

string[128]

Нет

Видимо пользователю

Чтение/Запись

Фильтр

Fixed

Boolean

Да

Видимо пользователю

Чтение/Запись

Зафиксирована

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

136.2. Конструктор Create (Конструктор колонки вида)

Конструктор класса TViewPresentationColumn.
1constructor TViewPresentationColumn.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Column: TViewColumn; Position: Integer;
4  Grouped: Boolean; Aggregate: TAggregateKind; SortDirection: TSortDirection;
5  Width: Integer; Filter: string[128]; Fixed: Boolean;
6  Category: string[128]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Column

TViewColumn

Да

Колонка

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Width

Integer

Да

Ширина

Filter

string[128]

Нет

Фильтр

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TViewPresentationColumn.

136.3. Метод AddColumns (Создать колонки)

Метод класса (статический метод) класса TViewPresentationColumn.
class procedure TViewPresentationColumn.AddColumns(Master: TViewPresentation);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TViewPresentation

Да

Мастер

136.4. Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentationColumn.
1class function TViewPresentationColumn.Save(Master: TViewPresentation;
2  Column: TViewColumn; Position: Integer; Grouped: Boolean;
3  Aggregate: TAggregateKind; SortDirection: TSortDirection; Width: Integer;
4  Filter: string[128]; Fixed: Boolean; Category: string[128]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TViewPresentation

Да

Мастер

Column

TViewColumn

Да

Колонка

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Width

Integer

Да

Ширина

Filter

string[128]

Нет

Фильтр

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Возвращает значение типа TObject.

137. Класс TVisualGroup (Визуальные группы)

Объекты класса образуют иерархию.

137.1. Свойства

Свойства класса TVisualGroup:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение

IsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Доступна

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

Collapsed

Boolean

Да

Видимо пользователю

Чтение/Запись

Свернута

137.2. Конструктор Create (Конструктор визуальной группы)

Конструктор класса TVisualGroup.
1constructor TVisualGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Image: blob; Position: Integer; Scope: TScope; Collapsed: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Image

blob

Нет

Изображение

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

Collapsed

Boolean

Да

Свернута

Замечания:

Создает новый объект класса TVisualGroup.

137.3. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TVisualGroup.
function TVisualGroup.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

137.4. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroup.
class function TVisualGroup.GetNextPos(Parent: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Integer.

138. Класс TVisualGroupAccess (Доступ к визуальным группам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

138.1. Конструктор Create (Конструктор доступа к визуальной группе)

Конструктор класса TVisualGroupAccess.
1constructor TVisualGroupAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TVisualGroup;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TVisualGroup

Да

Группа доступа

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TVisualGroupAccess.

139. Класс TVisualGroupForm (Форма визуальной группы)

139.1. Свойства

Свойства класса TVisualGroupForm:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TVisualGroupItem

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Form

TForm

Да

Видимо пользователю

Чтение/Запись

Форма

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение

139.2. Конструктор Create (Конструктор формы визуальной группы)

Конструктор класса TVisualGroupForm.
1constructor TVisualGroupForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob; Form: TForm): TObject;
Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TVisualGroupItem.Create

Comment

clob

Нет

Form

TForm

Да

Форма

Замечания:

Создает новый объект класса TVisualGroupForm.

140. Класс TVisualGroupItem (Элемент визуальной группы)

140.1. Свойства

Свойства класса TVisualGroupItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Комментарий

140.2. Конструктор Create (Конструктор элемента визуальной группы)

Конструктор класса TVisualGroupItem.
1constructor TVisualGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Comment

clob

Нет

Комментарий

Замечания:

Создает новый объект класса TVisualGroupItem.

140.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroupItem.
class function TVisualGroupItem.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

141. Класс TVisualGroupRoutine (Подпрограмма визуальной группы)

141.1. Свойства

Свойства класса TVisualGroupRoutine:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TVisualGroupItem

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

141.2. Конструктор Create (Конструктор подпрограммы визуальной группы)

Конструктор класса TVisualGroupRoutine.
1constructor TVisualGroupRoutine.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Comment: clob;
4  Routine: TRoutine): TObject;
Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TVisualGroupItem.Create

Comment

clob

Нет

Routine

TRoutine

Да

Подпрограмма

Замечания:

Создает новый объект класса TVisualGroupRoutine.

142. Класс TWordAsyncTask (Задачи отложенного выполнения отчетов Word)

Объекты класса не именованы.

142.1. Свойства

Свойства класса TWordAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TAsyncTask

Created

datetime

Да

Видимо пользователю

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TAsyncTask

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Duration

time

Нет

Видимо пользователю

Только для чтения

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Format

TWordOutputFormat

Да

Видимо пользователю

Чтение/Запись

Формат

142.2. Конструктор Create (Конструктор задачи отложенного выполнения отчетов Word)

Конструктор класса TWordAsyncTask.
1constructor TWordAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TWordOutputFormat): TObject;
Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Унаследовано от TAsyncTask.Create

Object

TObject

Нет

FormView

TFormView

Нет

Handler

TAsyncHandler

Да

Language

TLanguage

Да

Format

TWordOutputFormat

Да

Формат

Замечания:

Создает новый объект класса TWordAsyncTask.

143. Класс TWordTemplate (Шаблоны отчетов Word)

143.1. Свойства

Свойства класса TWordTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

MacroName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя макроса

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

143.2. Конструктор Create (Конструктор шаблона отчета Word)

Конструктор класса TWordTemplate.
1constructor TWordTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  MacroName: string[128]; IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

blob

Нет

Данные шаблона

MacroName

string[128]

Нет

Имя макроса

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TWordTemplate.

143.3. Метод Ole-объекта CheckWordTemplate (Проверить шаблон отчетов Word)

Метод Ole-объекта класса TWordTemplate.

Метод Ole-объекта не имеет параметров.

144. Класс TXSLTTemplate (Шаблоны отчетов XSLT)

144.1. Свойства

Свойства класса TXSLTTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

clob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

FunctionName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя функции

144.2. Конструктор Create (Конструктор шаблона отчета XSLT)

Конструктор класса TXSLTTemplate.
1constructor TXSLTTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: clob;
6  FunctionName: string[128]): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

clob

Нет

Данные шаблона

FunctionName

string[128]

Нет

Имя вызываемой функции

Замечания:

Создает новый объект класса TXSLTTemplate.

144.3. Метод Ole-объекта CheckXSLTTemplate (Проверить шаблон отчетов XSLT)

Метод Ole-объекта класса TXSLTTemplate.

Метод Ole-объекта не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Методы (раздел целиком) (22.10.2024) (одним файлом)
Методы

1. Свойства документа

Для создания и описания свойств PDF-документа в библиотеке PDFCreator.dll используется класс IPDFDocument, обладающий следующими свойствами:

  • Title (WideString) - заголовок документа. По умолчанию - пустая строка.
    Title = "DOC1"
  • CanEmbedFonts (WordBool) - Признак возможности построения PDF- документа со встроенными шрифтами (Embedded Fonts). В случае включения признака, все объявленные в скрипте шрифты будут включены в сборку документа и будут передаваться целиком вместе с документом. По умолчанию - False.
    CanEmbedFonts = True
CanEmbedFonts = False
  • CanCompress (WordBool) - признак сжатия документа при создании по собственным алгоритмам. По умолчанию - True.
    CanCompress = False
CanCompress = True
  • Author (WideString) - автор документа. По умолчанию - текущий пользователь ОС.
  • Subject (WideString) - описание документа. По умолчанию - пустая строка.
  • Keywords (WideString) - ключевые слова для поиска по документу. По умолчанию - пустая строка.
  • Creator (WideString) - приложение-родитель документа. Указывается в том случае, если документ был сконвертирован из другого формата.
  • PageCount (Integer) - свойство, содержащее общее количество страниц в документе.
  • Pages[Index: Integer]: IPDFPage - свойство документа, предназначенное для перебора страниц документа для совершения над ними однотипных действий.

    Пример использования:

    1for I = 0 to PageCount - 1
2  Pages(I).rectangle 10,10,10,10, false
3next
Save "c:\pdf.pdf"

    Результат: На всех страницах документа будут нарисованы квадраты 10х10 мм.
  • procedure Save(Target: OleVariant) - процедура для сохранения документа PDF на жесткий диск сразу после создания.
    Save "c:\pdf.pdf"
    - сохранит документ в файл c:\pdf.pdf

2. Свойства страницы

Для создания страницы используется функция

function CreatePage(Parent: OleVariant): IPDFPage;

Параметр Parent указывает страницу-родителя для данной страницы. Если страницы- родителя быть не должно - формат вызова функции примет вид:

set page = CreatePage(Null)

Параметры страницы:

  • Title - заголовок страницы.
    page.Title = "Page name"
  • Width - ширина страницы, миллиметры
    page.Width = 80
  • Height - высота страницы, миллиметры
    page.Height = 80
  • DrawGrid - процедура, выводящая на страницу сетку с шагом 5 миллиметров для удобства отладки вида документа.
  • Perform - процедура, позволяющая выполнить дополнительные команды PostScript на странице.
    page.perform "1 0.7 0 0 k"page.perform "0 0 m"

2.1. Объявление цвета

Для объявления цвета объектов на странице используется цветовая модель R:G:B (Red:Green:Blue). Объявление цвета для выполнения последующих операций (цвет шрифта, цвет линии/фигуры) осуществляется процедурой

procedure SetColor(R: Integer; G: Integer; B: Integer);
Где параметры R, G, B - значения базисных цветов для выбранного цвета (от 0 до 255).

Цвет | R | G | B |
Белый | 255 | 255 | 255 | +++
Черный | 0 | 0 | 0 | +++
Серый | 190 | 190 | 190 | +++
Синий | 0 | 0 | 255 | +++
Красный | 255 | 0 | 0 | +++
Зеленый | 0 | 255 | 0 | +++

Если предварительно цвет не был объявлен, используется цвет по умолчанию - черный (0,0,0)

3. Графика

3.1. Линии

Для отрисовки линий используется процедура

procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double);
Здесь:

  • X1 - координата начала линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y1 - координата начала линии по вертикали в миллиметрах от верхнего левого угла листа.
  • X2 - координата конца линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y2 - координата Конца линии по вертикали в миллиметрах от верхнего левого угла листа.

Для задания толщины линии используется свойство

property LineWidth: Double
Значение толщины задается в миллиметрах. Значение по умолчанию - минимально возможная единица рисования для устройства. Так для монитора - 1 pixel, для принтера - 1 dot (точка)

Для задания стиля отрисовки начала/окончания линии используется свойство property LineCap: TPDFLineCap
Возможные стили:
Значение свойства: | Отображение: | Описание:
0 | Линия 0 | Прямой срез точно по точкам начала и окончания линии (по умолчанию)
1 | Линия 1 | С закруглением
2 | Линия 2 | Прямой срез с продолжением линии на половину толщины линии

Объявление цвета линии.

Две линии разной толщины, с разными окончаниями и цветами:
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineCap = 1
06
07page.LineWidth = 2
08
09page.Line 10, 10, 30, 30
10
11page.LineWidth = 4
12
13page.SetColor 255, 0, 0
14
15page.LineCap = 2
16
page.Line 10, 30, 30, 10."I

Результат:
2 линии

При необходимости соединения линий под углом в определенной точке можно задать тип соединения. Для объявления типа соединения используется свойство property LineJoin: TPDFLineJoin;
Типы соединения двух линий:
Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пунктир

Для создания пунктира используется процедура отображения линии с предварительно объявленными дополнительными значениями.

Процедура procedure SetDash(DashArray: OleVariant; Phase: Integer); Здесь DashArray - массив значений в миллиметрах, указывающий последовательность чередования штрихов и пропусков на линии, Phase - смещение в миллиметрах по линии.

Пример 1. Штрих 10 мм, Промежуток 5 мм, Смещения нет
Пример 2. Штрих 10 мм, Промежуток 5 мм, Смещение 5 мм
Пример 3. Различные значения штрихов и промежутков, Смещения нет
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 3
06
07page.SetDash Array(10, 5), 0
08
09page.Line 10, 10, 100, 10
10
11page.SetDash Array(10, 5), 5
12
13page.Line 10, 20, 100, 20
14
15page.SetDash Array(10, 5, 3, 2, 12, 20), 0
16
page.Line 10, 30, 100, 30

Результат:
Пунктир 1

Ломанная линия - здесь непрерывная линия, состоящая из нескольких прямых. Для отображения ломанной используется процедура procedure Poly(Points: OleVariant; Fill: WordBool), где Points - массив координат точек соединяемых прямыми, а Fill - признак заливки полученной замкнутой фигуры (если замкнута).

Пример Звезда без заливки
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), false

Результат:
Звезда
Пример Звезда с заливкой
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), true

Результат:
Звезда заливка

3.2. Прямоугольник

Rectangle (Прямоугольник) - для создания используется процедура:

procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double; Fill: WordBool);
Здесь:

  • X1 - координата верхнего левого угла прямоугольника по горизонтали в миллиметрах от верхнего левого угла листа шаблона.
  • Y1 - координата верхнего левого угла прямоугольника по вертикали в миллиметрах от верхнего левого угла листа шаблона.
  • Width - ширина прямоугольника с миллиметрах.
  • Height - высота прямоугольника с миллиметрах.
  • Fill - признак заливки прямоугольника (True/False). Если значение True то заливка производится объявленным заранее цветом (см. Объявление цвета). Если False - заливка не производится. Прямоугольник отрисовывается линиями с предварительно заданной толщиной. См. Линии
Пример 1. Создание красного прямоугольника:
1set page = CreatePage(Null)
2
3page.SetColor 255, 0, 0
4
5page.Rectangle 10, 15, 40, 20, True
6
page.DrawGrid
Результат:
Прямоугольник
Пример 2. Пустой прямоугольник без задания цвета:
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.Rectangle 12, 17, 42, 25, false
6
page.DrawGrid

Результат:
Прямоугольник false

Также существует возможность изменения стиля отображения углов прямоугольника. Для этого нужно использовать свойство property LineJoin: TPDFLineJoin;

Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пример построения прямоугольников с различными типами соединения сторон:

01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 4
06
07page.LineJoin = 0
08
09page.Rectangle 10, 10, 20, 10, false
10
11page.LineJoin = 1
12
13page.Rectangle 40, 10, 20, 10, false
14
15page.LineJoin = 2
16
page.Rectangle 70, 10, 20, 10, false

Результат:
3 прямоугольника

3.3. Вставка готовых изображений

Для вставки на создаваемую страницу готового изображения используется процедура procedure Image(const FileName: WideString; X: Double; Y: Double; Width: Double; Height: Double)

Параметры:

  • const FileName - имя файла изображения и путь к нему на жестком диске. Задается в кавычках.
  • X - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по горизонтали в миллиметрах
  • Y - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по вертикали в миллиметрах
  • Width - ширина изображения в миллиметрах
  • Height - высота изображения в миллиметрах.
1set page = CreatePage(Null)
2page.drawgrid
page.Image "c:\mill.bmp", 10,10, 30, 30

Результат:
Картинка

Вне зависимости от размера исходного изображения, при вставке изображения на создаваемую страницу оно будет растянуто по размерам, прописанным в процедуре.

3.4. Векторная графика

Язык PostScript, с помощью которого создаются векторные изображения для PDF-документа, поддерживает создание типичных примитивных объектов, таких как:

  • Прямые и ломанные линии
  • Многоугольники
  • Окружности и эллипсы
  • Кривые Безье
  • Текст

При создании векторного изображения на странице PDF-документа в приложениях Платформы, команды построения примитивных объектов PostScript передаются на исполнение при помощи процедуры Perform. Подробнее об операторах и командах PostScript для создания PDF-документов можно узнать на сайте Adobe

4. Шрифты

Шрифты, которые должны использоваться в создаваемом документе, должны быть предварительно объявлены. Для объявления используемых шрифтов используется функция
function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool; Italic: WordBool): IPDFFont; где:

  • const FontName - имя шрифта, аналогичное имени объявляемого шрифта в операционной системе. В Функции объявляется в кавычках.
  • Size - размер шрифта в пунктах
  • Bold - признак начертания шрифта "жирный". Значения - True или False
  • Italic - признак начертания шрифта "курсив". Значения - True или False
Примеры объявления шрифтов:
1set font = page.createFont("Arial", 20, False, False)
2set labelFont = page.createFont("Times New Roman", 16, False, True)
3set dataFont = page.createFont("Tahoma", 18, True, False)

Для вывода текстовой информации на страницу используются процедуры:

  • procedure WriteLine(const LineText: WideString; X: Double; Y: Double);
    - используется для вывода текстовой строки
  • function WriteText(const AText: WideString; X: Double; Y: Double; Width: Double; Alignment: TPDFTextAlignment): Double;
    - используется для вывода текстового блока.

Параметры для procedure WriteLine :

  • const LineText - текстовая строка для вывода. Прописывается в кавычках. Будет выведена на страницу одной строкой.
  • X - координата верхней левой точки текстовой строки по горизонтали в миллиметрах.
  • Y - координата верхней левой точки текстовой строки по вертикали в миллиметрах.
Примеры вывода текстов на страницу:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Times New Roman", 16, False, True)
05set dataFont = page.createFont("Tahoma", 18, True, False)
06Font.WriteLine "Фамилия", 5, 2
07Font.WriteLine "Имя", 5, 10
08Font.WriteLine "Отчество", 5, 18
09labelFont.WriteLine "Дата рождения", 5, 26
10dataFont.WriteLine "Национальность", 5, 34

Результат:
Разные шрифты

Параметры для function WriteText :

  • const AText - текст для вывода на страницу. Прописывается в кавычках. Будет выведена на страницу в виде текстового блока.
  • X - координата верхней левой точки текстового блока по горизонтали в миллиметрах.
  • Y - координата верхней левой точки текстового блока по вертикали в миллиметрах.
  • Width - ширина текстового блока в миллиметрах
  • Alignment - тип выравнивания текста в текстовом блоке.
    Значение параметра | Тип выравнивания
    0 | По левому краю
    1 | По правому краю
    2 | По центру
    3 | Выравнивание по ширине
Примеры вывода текстовых блоков на страницу:
1set page = CreatePage(Null)
2page.DrawGrid
3set font = page.createFont("Arial", 14, False, False)
4set labelFont = page.createFont("Times New Roman", 12, False, True)
5set dataFont = page.createFont("Tahoma", 11, True, False)
6Q = font.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 5, 100, 0)
7Q = labelFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 35, 100, 1)
8Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 55, 100, 2)
9Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 80, 100, 3)

Результат:
Выравнивание

Свойства шрифтов:

property Spacing: Double; - свойство, отвечающее за величину промежутка между буквами в слове. Задается в виде отклонения от промежутка между буквами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Spacing = 0
07labelFont.Spacing = 1
08dataFont.Spacing = 2
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (1 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 15

Результат:
Промежуток букв

property WordSpacing: Double; - свойство, отвечающее за величину промежутка между соседними словами. Задается в виде отклонения от промежутка между словами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.WordSpacing = 0
07labelFont.WordSpacing = 2
08dataFont.WordSpacing = 5
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (5 мм)", 5, 15

Результат:
Промежуток слов

property Scaling: Double; - свойство, отвечающее за горизонтальное масштабирование букв используемого шрифта. Устанавливается в процентах. Горизонтальный масштаб по умолчанию - 100%.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Scaling = 50
07labelFont.Scaling = 100
08dataFont.Scaling = 200
09font.WriteLine "Сжатие (50)", 5, 5
10labelFont.WriteLine "По умолчанию (100)", 5, 10
11dataFont.WriteLine "Растягивание (150)", 5, 15

Результат:
Scaling

property RenderingMode: TPDFFontRenderingMode; - свойство, отвечающее за заливку букв используемого шрифта.
Типы заливки:
Значение параметра: | Отображение: | Описание:
0 | Font Fill | Сплошная заливка (по умолчанию). Буква заливается сплошным цветом, объявленным на данный момент.
1 | Font Stroke | Только граница. Прорисовывается граница буквы. Тело остается незалитым.
2 | Font FillStroke | Сначала заливка, потом граница. Граница прорисовывается всегда черным цветом. Заливка осуществляется сплошным цветом, объявленным на данный момент.
3 | Inv | Невидимый шрифт.

Пример:
01set page = CreatePage(Null)
02set font = page.createFont("Arial", 20, False, False)
03set labelFont = page.createFont("Arial", 20, False, False)
04set dataFont = page.createFont("Arial", 20, False, False)
05font.RenderingMode = 0
06labelFont.RenderingMode = 1
07dataFont.RenderingMode = 2
08page.setColor 255, 0, 0
09Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
10Q = labelFont.WriteText ("Олимпиада", 5, 15, 50, 0)
11Q = dataFont.WriteText ("Олимпиада", 5, 25, 50, 0)

Результат:
Заливка букв

property Rise: Double; - свойство, отвечающее за перемещение текста по вертикали.

01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Arial", 7, False, False)
05set dataFont = page.createFont("Arial", 7, False, False)
06labelFont.rise = -17
07dataFont.rise = -2
08Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
09Q = labelFont.WriteText ("Олимпиада", 44, 5, 50, 0)
10Q = dataFont.WriteText ("Олимпиада", 44, 5, 50, 0)

Результат:
Rise

Для определения размеров текстовой строки используется процедура MeasureLine(const LineText: WideString; out Width: OleVariant; out Height: OleVariant);

Здесь:

  • LineText - исходный текст для размещения на странице
  • Width - возвращаемый параметр ширины текстового блока на странице
  • Height - возвращаемый параметр высоты текстового блока на странице
1S = "шифр"
2font.MeasureLine S, W, H
3Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2)

Здесь для текста "Шифр" замеряется ширина и высота получившегося текстового блока. Затем полученные данные используются для корректного размещения текста на странице.

Для определения высоты текстового блока используется функция MeasureText(const AText: WideString; Width: Double): Double; safecall;

Функция распределит текст по задаваемому значению ширины текстового блока и вернет значение высоты текстового блока в милиметрах.

Здесь:

  • AText - исходный текст для размещения на странице. Прописывается в кавычках.
  • Width - задаваемая ширина текстового блока на странице в милиметрах.
1S = "Текст для размещения на странице..."
2Q = font.MeasureText(S, 139)
Здесь для текста "Текст для размещения на странице..." замеряется высота получившегося текстового блока. Затем полученные данные могут использоваться для корректного размещения текста на странице.


Мельница данных ((раздел целиком))

Мельница данных- Класс TObjectArchive (Архив объектов) (раздел целиком) (22.10.2024) (одним файлом)
Класс TObjectArchive (Архив объектов)

Диаграмма

1. Свойства

Свойства класса TObjectArchive:

Имя | Тип | Обязательно | Доступ | Назначение
Object | TObject | Да | Только для чтения | Объект
ObjectName | string[64] | Да | Только для чтения | Имя объекта
ObjectDescription | string[128] | Да | Только для чтения | Наименование объекта
ObjectClass | TClass | Да | Только для чтения | Класс объекта
ObjectParent | TObject | Нет | Только для чтения | Объект-родитель
ObjectMaster | TObject | Да | Только для чтения | Объект-мастер
ObjectSourceDataBase | TDataBase | Да | Только для чтения | База данных-источник
ObjectOldID | string[38] | Да | Только для чтения | Идентификатор объекта при создании
ObjectCreator | TUser | Да | Только для чтения | Объект создан пользователем
ObjectCreated | datetime | Да | Только для чтения | Объект создан
ObjectModifier | TUser | Да | Только для чтения | Объект изменен пользователем
ObjectModified | datetime | Да | Только для чтения | Объект изменен
User | TUser | Да | Только для чтения | Пользователь
UserName | string[64] | Да | Только для чтения | Имя пользователя

2. Метод Purge (Очистить архив)

Метод класса (статический метод) класса TObjectArchive.

class procedure TObjectArchive.Purge(TimeLimit: time);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeLimit | time | Нет | Лимит времени выполнения

3. Метод Put (Положить объект в архив)

Метод класса (статический метод) класса TObjectArchive.

class procedure TObjectArchive.Put(Object: TObject);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Нет | Объект

4. Метод PutAutonomous (Положить объект в архив в автономной транзакции)

Метод класса (статический метод) класса TObjectArchive.

class procedure TObjectArchive.PutAutonomous(Object: TObject);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Нет | Объект

5. Метод Remove (Исключить объект из архива)

Метод класса (статический метод) класса TObjectArchive.

class procedure TObjectArchive.Remove(Object: TObject);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Нет | Объект


Мельница данных ((раздел целиком))

Мельница данных- Класс TRoleMember (Пользователи в ролях) (раздел целиком) (22.10.2024) (одним файлом)
Класс TRoleMember (Пользователи в ролях)

Класс TObject (Объекты)Класс TRole (Роли)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TRoleMember:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
User | TSecurityAccount | Да | Видимо пользователю | Только для чтения | Пользователь
UserClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс члена роли
IsPrimary | Boolean | Да | Видимо пользователю | Чтение/Запись | Основная роль

2. Конструктор Create (Конструктор члена роли)

Конструктор класса TRoleMember.

1constructor TRoleMember.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TRole; Accessor: TSecurityAccount;
3  User: TSecurityAccount; IsPrimary: Boolean; AddLinked: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TRole | Да | Роль
Accessor | TSecurityAccount | Нет | Унаследовано от TObject.Create
User | TSecurityAccount | Да | Пользователь
IsPrimary | Boolean | Да | Основная роль
AddLinked | Boolean | Да | Добавить связанные роли

Замечания:

Создает новый объект класса TRoleMember.

3. Метод SetIsPrimary (Установка значения свойства "Является основной")

Метод экземпляра класса TRoleMember.

procedure TRoleMember.SetIsPrimary(Value: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение


Мельница данных ((раздел целиком))

Мельница данных- Класс TObjectList (Списки) (раздел целиком) (22.10.2024) (одним файлом)
Класс TObjectList (Списки)

Класс TObject (Объекты)Класс TObjectListItem (Элементы списков)

Объекты класса не именованы.

1. Свойства

Свойства класса TObjectList:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
AsString | string[2000] | Нет | Скрыто от пользователя | Чтение/Запись | Список в текстовом представлении
AsClob | clob | Нет | Скрыто от пользователя | Чтение/Запись | Список в виде большого текстового объекта

2. Конструктор Create (Конструктор списка)

Конструктор класса TObjectList.

1constructor TObjectList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TObjectList.

3. Метод Add (Добавить объект в список)

Метод экземпляра класса TObjectList.

procedure TObjectList.Add(ItemObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemObject | TObject | Да | Элемент

4. Метод Archive (Отправить список в архив)

Метод экземпляра класса TObjectList.

procedure TObjectList.Archive;

Метод не имеет параметров.

5. Метод ArchiveAll (Отправить список в архив со всем содержимым)

Метод экземпляра класса TObjectList.

procedure TObjectList.ArchiveAll;

Метод не имеет параметров.

6. Метод ByName (Поиск по имени)

Метод экземпляра класса TObjectList.

function TObjectList.ByName(Name: string[64]): Integer;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя

Замечания:

Возвращает значение типа Integer.

7. Метод Clear (Очистить список)

Метод экземпляра класса TObjectList.

procedure TObjectList.Clear;

Метод скрыт от пользователя.

Метод не имеет параметров.

8. Метод CreateFromClob (Создать список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.

class function TObjectList.CreateFromClob(Value: clob): TObjectList;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа TObjectList.

9. Метод CreateFromOrderedClob (Создать упорядоченный список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.

class function TObjectList.CreateFromOrderedClob(Value: clob): TObjectList;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа TObjectList.

10. Метод CreateFromOrderedString (Создать упорядоченный список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.

class function TObjectList.CreateFromOrderedString(Value: string[2000]): TObjectList;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа TObjectList.

11. Метод CreateFromString (Создать список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.

class function TObjectList.CreateFromString(Value: string[2000]): TObjectList;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа TObjectList.

12. Метод Delete (Удалить объект)

Метод экземпляра класса TObjectList.

procedure TObjectList.Delete(ItemObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemObject | TObject | Да | Элемент

13. Метод DestroyAll (Удалить вместе с содержащимися в списке объектами)

Метод экземпляра класса TObjectList.

procedure TObjectList.DestroyAll;

Метод не имеет параметров.

14. Метод Force (Добавить, игнорируя ограничения)

Метод экземпляра класса TObjectList.

procedure TObjectList.Force(ItemObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemObject | TObject | Да | Элемент

15. Метод GetAsClob (Получить в виде большого текстового объекта)

Метод экземпляра класса TObjectList.

function TObjectList.GetAsClob: clob;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

16. Метод GetAsString (Список в текстовом представлении)

Метод экземпляра класса TObjectList.

function TObjectList.GetAsString: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

17. Метод GetItem (Получить объект из списка)

Метод экземпляра класса TObjectList.

function TObjectList.GetItem(ItemIndex: Integer): TObject;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс

Замечания:

Возвращает значение типа TObject.

18. Метод IndexOf (Индекс объекта в списке)

Метод экземпляра класса TObjectList.

function TObjectList.IndexOf(ItemObject: TObject): Integer;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemObject | TObject | Да | Элемент

Замечания:

Возвращает значение типа Integer.

19. Метод Insert (Вставить объект в список)

Метод экземпляра класса TObjectList.

procedure TObjectList.Insert(ItemIndex: Integer; ItemObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс
ItemObject | TObject | Да | Элемент

20. Метод IsExcluded (Объект не входит в список)

Метод экземпляра класса TObjectList.

function TObjectList.IsExcluded(Value: TObject): Boolean;

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

21. Метод IsIncluded (Объект входит в список)

Метод экземпляра класса TObjectList.

function TObjectList.IsIncluded(Value: TObject): Boolean;

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

22. Метод Length (Длина списка)

Метод экземпляра класса TObjectList.

function TObjectList.Length: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

23. Метод LoadFromClob (Загрузить содержимое списка из большого текстового объекта)

Метод экземпляра класса TObjectList.

1procedure TObjectList.LoadFromClob(Value: clob; Ordered: Boolean;
2  Clear: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение
Ordered | Boolean | Да | Сохранить порядок объектов
Clear | Boolean | Да | Очистить перед загрузкой

24. Метод LoadFromString (Загрузить содержимое списка из текстового представления)

Метод экземпляра класса TObjectList.

1procedure TObjectList.LoadFromString(Value: string[2000]; Ordered: Boolean;
2  Clear: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Ordered | Boolean | Да | Сохранить порядок объектов
Clear | Boolean | Да | Очистить перед загрузкой

25. Метод Remove (Вычистить объект)

Метод экземпляра класса TObjectList.

procedure TObjectList.Remove(ItemObject: TObject);

Параметры:

Имя | Тип | Обязательно | Значение
ItemObject | TObject | Да | Элемент

26. Метод Reorder (Перенумеровать объекты в списке)

Метод экземпляра класса TObjectList.

procedure TObjectList.Reorder;

Метод не имеет параметров.

27. Метод SetAsClob (Установить список в виде большого текстового объекта)

Метод экземпляра класса TObjectList.

procedure TObjectList.SetAsClob(Value: clob);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

28. Метод SetAsString (Установить список в текстовом представлении)

Метод экземпляра класса TObjectList.

procedure TObjectList.SetAsString(Value: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

29. Метод SetItem (Установить объект в списке)

Метод экземпляра класса TObjectList.

procedure TObjectList.SetItem(ItemIndex: Integer; ItemObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс
ItemObject | TObject | Да | Элемент


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IDataSet (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IDataSet

01type
02  IDataSet = interface(IUnknown)
03    ['{3CED7395-8482-4EF6-8A15-7744348063C2}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_FieldName(Index: Integer): WideString; safecall;
06    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
07    procedure Next; safecall;
08    function Eof: WordBool; safecall;
09    property FieldCount: Integer read Get_FieldCount;
10    property FieldName[Index: Integer]: WideString read Get_FieldName;
11    property Field[FieldIndex: OleVariant]: OleVariant read Get_Field;
12  end;

1. Свойства

Свойства интерфейса IDataSet:

Имя | Тип | Доступ | Назначение
Field[FieldIndex: OleVariant] | OleVariant | Только для чтения |
FieldCount | Integer | Только для чтения |
FieldName[Index: Integer] | WideString | Только для чтения |

2. Метод Eof

Метод интерфейса IDataSet.

function IDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

3. Метод Next

Метод интерфейса IDataSet.

procedure IDataSet.Next;

Метод не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Класс TTypedValue (Типизированные значения) (раздел целиком) (22.10.2024) (одним файлом)
Класс TTypedValue (Типизированные значения)

Класс TObject (Объекты)

Объекты класса не именованы.

1. Свойства

Свойства класса TTypedValue:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Нет | Скрыто от пользователя | Только для чтения | Мастер
MasterClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс мастера
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс домена
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок закладки
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись | Заголовок группы
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись | За пределами закладок
StrValue | string[2000] | Нет | Скрыто от пользователя | Чтение/Запись | Строковое значение
IntValue | Integer | Нет | Скрыто от пользователя | Чтение/Запись | Целое значение
FloatValue | float | Нет | Скрыто от пользователя | Чтение/Запись | Вещественное значение
DateValue | date | Нет | Скрыто от пользователя | Чтение/Запись | Значение даты
TimeValue | time | Нет | Скрыто от пользователя | Чтение/Запись | Значение времени
DateTimeValue | datetime | Нет | Скрыто от пользователя | Чтение/Запись | Значение даты со временем
ObjectValue | TObject | Нет | Скрыто от пользователя | Чтение/Запись | Значение-объект
BoolValue | Boolean | Нет | Скрыто от пользователя | Чтение/Запись | Логическое значение
BlobValue | blob | Нет | Видимо пользователю | Чтение/Запись | Значение-большой объект
ClobValue | clob | Нет | Видимо пользователю | Чтение/Запись | Значение-текст
ExternalDataValue | <external data> | Нет | Видимо пользователю | Чтение/Запись | Значение-внешние данные
VisibleValue | string[2000] | Нет | Видимо пользователю | Только для чтения | Видимое значение
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись | Идентификатор элемента управления

2. Конструктор Create (Конструктор типизированного значения)

Конструктор класса TTypedValue.

1constructor TTypedValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>): TTypedValue;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
StrValue | string[2000] | Нет | Строковое значение
IntValue | Integer | Нет | Целое значение
FloatValue | float | Нет | Вещественное значение
DateValue | date | Нет | Значение даты
TimeValue | time | Нет | Значение времени
DateTimeValue | datetime | Нет | Значение даты со временем
ObjectValue | TObject | Нет | Значение-объект
BoolValue | Boolean | Нет | Логическое значение
BlobValue | blob | Нет | Значение-большой объект
ClobValue | clob | Нет | Значение-текст
ExternalDataValue | <external data> | Нет | Значение-внешние данные

Замечания:

Создает новый объект класса TTypedValue.

3. Метод CompareBlob (Сравнить большие объекты)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareBlob(ComparisonTypeName: string[64];
2  ValueA: blob; ValueB: blob): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | blob | Нет | Значение A
ValueB | blob | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

4. Метод CompareBoolean (Сравнить логические значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareBoolean(ComparisonTypeName: string[64];
2  ValueA: Boolean; ValueB: Boolean): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | Boolean | Да | Значение A
ValueB | Boolean | Да | Значение B

Замечания:

Возвращает значение типа Boolean.

5. Метод CompareClob (Сравнить тексты)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareClob(ComparisonTypeName: string[64];
2  ValueA: clob; ValueB: clob): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | clob | Нет | Значение A
ValueB | clob | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

6. Метод CompareDate (Сравнить значения дат)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareDate(ComparisonTypeName: string[64];
2  ValueA: date; ValueB: date): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | date | Нет | Значение A
ValueB | date | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

7. Метод CompareDateTime (Сравнить значения даты со временем)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareDateTime(ComparisonTypeName: string[64];
2  ValueA: datetime; ValueB: datetime): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | datetime | Нет | Значение A
ValueB | datetime | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

8. Метод CompareFloat (Сравнить вещественные значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareFloat(ComparisonTypeName: string[64];
2  ValueA: float; ValueB: float): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | float | Нет | Значение A
ValueB | float | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

9. Метод CompareInt (Сравнить целые значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareInt(ComparisonTypeName: string[64];
2  ValueA: Integer; ValueB: Integer): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | Integer | Нет | Значение A
ValueB | Integer | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

10. Метод CompareList (Сравнить со списком)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareList(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: TObject): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | string[2000] | Нет | Значение A
ValueB | TObject | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

11. Метод CompareObject (Сравнить значения-объекты)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareObject(ComparisonTypeName: string[64];
2  ValueA: TObject; ValueB: TObject): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | TObject | Нет | Значение A
ValueB | TObject | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

12. Метод CompareStr (Сравнить строковые значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareStr(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: string[2000]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | string[2000] | Нет | Значение A
ValueB | string[2000] | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

13. Метод CompareTime (Сравнить значения времени)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CompareTime(ComparisonTypeName: string[64];
2  ValueA: time; ValueB: time): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ComparisonTypeName | string[64] | Да | Имя типа сравнения
ValueA | time | Нет | Значение A
ValueB | time | Нет | Значение B

Замечания:

Возвращает значение типа Boolean.

14. Метод CreateBlobValue (Создать значение-большой объект)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateBlobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BlobValue: blob): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
BlobValue | blob | Нет | Значение-большой объект

Замечания:

Возвращает значение типа TTypedValue.

15. Метод CreateBoolValue (Создать логическое значение)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateBoolValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BoolValue: Boolean): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
BoolValue | Boolean | Нет | Логическое значение

Замечания:

Возвращает значение типа TTypedValue.

16. Метод CreateClobValue (Создать значение-текст)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateClobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ClobValue: clob): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Группа
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
ClobValue | clob | Нет | Значение-текст

Замечания:

Возвращает значение типа TTypedValue.

17. Метод CreateDateTimeValue (Создать значение даты со временем)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateDateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateTimeValue: datetime): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
DateTimeValue | datetime | Нет | Значение даты со временем

Замечания:

Возвращает значение типа TTypedValue.

18. Метод CreateDateValue (Создать значение даты)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateDateValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateValue: date): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
DateValue | date | Нет | Значение даты

Замечания:

Возвращает значение типа TTypedValue.

19. Метод CreateExternalDataValue (Создать значение внешних данных)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateExternalDataValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ExternalDataValue: <external data>): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
ExternalDataValue | <external data> | Нет | Значение-внешние данные

Замечания:

Возвращает значение типа TTypedValue.

20. Метод CreateFloatValue (Создать вещественное значение)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateFloatValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  FloatValue: float): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
FloatValue | float | Нет | Вещественное значение

Замечания:

Возвращает значение типа TTypedValue.

21. Метод CreateIntValue (Создать целое значение)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateIntValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  IntValue: Integer): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
IntValue | Integer | Нет | Целое значение

Замечания:

Возвращает значение типа TTypedValue.

22. Метод CreateObjectValue (Создать значение-объект)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateObjectValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ObjectValue: TObject): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
ObjectValue | TObject | Нет | Значение-объект

Замечания:

Возвращает значение типа TTypedValue.

23. Метод CreateStrValue (Создать строковое значение)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateStrValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
StrValue | string[2000] | Нет | Строковое значение

Замечания:

Возвращает значение типа TTypedValue.

24. Метод CreateTimeValue (Создать значение времени)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.CreateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  TimeValue: time): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Master | TObject | Да | Мастер
Parent | TObject | Нет | Родитель
DomainName | string[64] | Да | Имя домена
Position | Integer | Да | Позиция
Group | string[128] | Нет | Заголовок группы
Tab | string[128] | Нет | Заголовок закладки
Scope | TScope | Да | Область видимости
OutOfTabs | Boolean | Да | За пределами закладок
TimeValue | time | Нет | Значение времени

Замечания:

Возвращает значение типа TTypedValue.

25. Метод FindBlobValue (Поиск значения-большого объекта)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindBlobValue(Master: TObject;
2  ControlName: string[64]): blob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа blob.

26. Метод FindBoolValue (Поиск логического значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindBoolValue(Master: TObject;
2  ControlName: string[64]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа Boolean.

27. Метод FindClobValue (Поиск значения-текста)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindClobValue(Master: TObject;
2  ControlName: string[64]): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа clob.

28. Метод FindDateTimeValue (Поиск значения даты со временем)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindDateTimeValue(Master: TObject;
2  ControlName: string[64]): datetime;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа datetime.

29. Метод FindDateValue (Поиск значения даты)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindDateValue(Master: TObject;
2  ControlName: string[64]): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа date.

30. Метод FindExternalDataValue (Поиск значения внешних данных)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindExternalDataValue(Master: TObject;
2  ControlName: string[64]): <external data>;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа <external data>.

31. Метод FindFloatValue (Поиск вещественного значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindFloatValue(Master: TObject;
2  ControlName: string[64]): float;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа float.

32. Метод FindIntValue (Поиск целого значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindIntValue(Master: TObject;
2  ControlName: string[64]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа Integer.

33. Метод FindObjectValue (Поиск значения-объекта)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindObjectValue(Master: TObject;
2  ControlName: string[64]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа TObject.

34. Метод FindStrValue (Поиск строкового значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindStrValue(Master: TObject;
2  ControlName: string[64]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа string[2000].

35. Метод FindTimeValue (Поиск значения времени)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindTimeValue(Master: TObject;
2  ControlName: string[64]): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Объект-мастер
ControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа time.

36. Метод FindValue (Поиск значения)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.FindValue(AMaster: TObject;
2  AControlName: string[64]): TTypedValue;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AMaster | TObject | Нет | Объект-мастер
AControlName | string[64] | Да | Имя элемента управления

Замечания:

Возвращает значение типа TTypedValue.

37. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер объекта
Parent | TObject | Нет | Родитель
Step | Integer | Да | Шаг

Замечания:

Возвращает значение типа Integer.

38. Метод GetVisibleValue (Видимое значение)

Метод экземпляра класса TTypedValue.

function TTypedValue.GetVisibleValue: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

39. Метод ReplaceWildcards (Заменить подстановочные символы)

Метод класса (статический метод) класса TTypedValue.

1class function TTypedValue.ReplaceWildcards(Value: string[2000];
2  Escape: string[2]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Escape | string[2] | Нет | Экранирующий символ

Замечания:

Возвращает значение типа string[2000].

40. Метод SetValue (Установить значение)

Метод экземпляра класса TTypedValue.

1procedure TTypedValue.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>);

Параметры:

Имя | Тип | Обязательно | Значение
StrValue | string[2000] | Нет | Строковое значение
IntValue | Integer | Нет | Целое значение
FloatValue | float | Нет | Вещественное значение
DateValue | date | Нет | Значение даты
TimeValue | time | Нет | Значение времени
DateTimeValue | datetime | Нет | Значение даты со временем
ObjectValue | TObject | Нет | Значение-объект
BoolValue | Boolean | Нет | Логическое значение
BlobValue | blob | Нет | Значение-большой объект
ClobValue | clob | Нет | Значение-текст
ExternalDataValue | <external data> | Нет | Значение-внешние данные


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IInfoProvider3 (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IInfoProvider3

1type
2  IInfoProvider3 = interface(IDispatch)
3    ['{EF0E186A-4C72-4C40-B61C-72D7D03B2D10}']
4    procedure SetLogonInfo(const Login: WideString); safecall;
5  end;

1. Метод SetLogonInfo

Метод интерфейса IInfoProvider3.

procedure IInfoProvider3.SetLogonInfo(const Login: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Login | WideString | Да |


Мельница данных ((раздел целиком))

Мельница данных- Класс TObject (Объекты) (раздел целиком) (22.10.2024) (одним файлом)
Класс TObject (Объекты)

Диаграмма Класс TAccessItem (Элементы доступа)Класс TQueue (Очередь)

1. Свойства

Свойства класса TObject:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Имя
Description | string[128] | Да | Видимо пользователю | Чтение/Запись | Наименование
Class | TClass | Да | Скрыто от пользователя | Только для чтения | Класс
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения | Статус репликации
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись | Родитель
Master | TObject | Да | Скрыто от пользователя | Только для чтения | Мастер
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | База данных-источник
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения | GUID базы данных-источника
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения | База данных-источник является текущей
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения | Идентификатор при создании
Creator | TUser | Да | Скрыто от пользователя | Только для чтения | Создано пользователем
Created | datetime | Да | Скрыто от пользователя | Только для чтения | Создано
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения | Изменено пользователем
Modified | datetime | Да | Скрыто от пользователя | Только для чтения | Изменено
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись | Роль для чтения
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись | Роль для записи

2. Конструктор Create (Конструктор объекта)

Конструктор класса TObject.

1constructor TObject.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Description | string[128] | Да | Наименование
Class | TClass | Нет | Класс
Parent | TObject | Нет | Родитель
Master | TObject | Да | Мастер
Accessor | TSecurityAccount | Нет | Роль доступа

Замечания:

Создает новый объект класса TObject.

3. Деструктор Destroy (Деструктор объекта)

Деструктор класса TObject.

destructor TObject.Destroy;

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TObject или его наследника.

4. Метод ApplyStringBuilder (Применить шаблон)

Метод экземпляра класса TObject.

function TObject.ApplyStringBuilder(Template: string[2000]): string[2000];

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Template | string[2000] | Нет | Шаблон

Замечания:

Возвращает значение типа string[2000].

5. Метод ApplyStringBuilderClob (Применить шаблон-большой текстовый объект)

Метод экземпляра класса TObject.

function TObject.ApplyStringBuilderClob(Template: string[2000]): clob;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Template | string[2000] | Нет | Шаблон

Замечания:

Возвращает значение типа clob.

6. Метод ASCII (ASCII-код)

Метод класса (статический метод) класса TObject.

class function TObject.ASCII(Value: string[2]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2] | Нет | Значение

Замечания:

Возвращает значение типа Integer.

7. Метод Assigned (Проверка пустоты значения)

Метод класса (статический метод) класса TObject.

class function TObject.Assigned(Value: TObject): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

8. Метод BlobToClob (Большой двоичный объект в большой текстовый объект)

Метод класса (статический метод) класса TObject.

class function TObject.BlobToClob(Value: blob): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | blob | Нет | Значение

Замечания:

Возвращает значение типа clob.

9. Метод BoolToStr (Логическое значение в строку)

Метод класса (статический метод) класса TObject.

1class function TObject.BoolToStr(Value: Boolean;
2  Domain: TBooleanDomain): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
Domain | TBooleanDomain | Нет | Домен

Замечания:

Возвращает значение типа string[2000].

10. Метод Change (Изменение объекта)

Метод экземпляра класса TObject.

procedure TObject.Change(Action: TChangeAction);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Действие

11. Метод Char (Символ)

Метод класса (статический метод) класса TObject.

class function TObject.Char(Value: Integer): string[2];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Integer | Нет | Значение

Замечания:

Возвращает значение типа string[2].

12. Метод ClobReplace (Заменить содержимое большого текстового объекта)

Метод класса (статический метод) класса TObject.

1class function TObject.ClobReplace(Value: clob; OldPattern: string[2000];
2  NewPattern: string[2000]; ReplaceAll: Boolean): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение
OldPattern | string[2000] | Нет | Старый шаблон
NewPattern | string[2000] | Нет | Новый шаблон
ReplaceAll | Boolean | Да | Заменять все

Замечания:

Возвращает значение типа clob.

13. Метод ClobToBlob (Большой текстовый объект в большой двоичный объект)

Метод класса (статический метод) класса TObject.

class function TObject.ClobToBlob(Value: clob): blob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа blob.

14. Метод Concatenate (Управляемая конкатенация строк)

Метод класса (статический метод) класса TObject.

1class function TObject.Concatenate(Value: string[2000]; AddOn: string[2000];
2  MaxLength: Integer; Delimiter: string[2000]; Ellipsis: Boolean): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
AddOn | string[2000] | Нет | Присоединяемая строка
MaxLength | Integer | Да | Максимальная длина
Delimiter | string[2000] | Нет | Разделитель
Ellipsis | Boolean | Да | Эллипсис

Замечания:

Возвращает значение типа string[2000].

15. Метод Copy (Копировать)

Метод класса (статический метод) класса TObject.

1class function TObject.Copy(String: string[2000]; StartPos: Integer;
2  Length: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
String | string[2000] | Нет | Строка
StartPos | Integer | Нет | Позиция
Length | Integer | Нет | Длина

Замечания:

Возвращает значение типа string[2000].

16. Метод CopyClob (Копировать из большого текстового объекта)

Метод класса (статический метод) класса TObject.

1class function TObject.CopyClob(Value: clob; StartPos: Integer;
2  Length: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение
StartPos | Integer | Нет | Позиция
Length | Integer | Нет | Длина

Замечания:

Возвращает значение типа string[2000].

17. Метод CreateGUID (Создать GUID)

Метод класса (статический метод) класса TObject.

class function TObject.CreateGUID: string[38];

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[38].

18. Метод DateOf (Дату из даты со временем)

Метод класса (статический метод) класса TObject.

class function TObject.DateOf(Value: datetime): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Нет | Значение

Замечания:

Возвращает значение типа date.

19. Метод DatePart (Часть даты)

Метод класса (статический метод) класса TObject.

class function TObject.DatePart(Value: date; Part: TDateTimePart): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | date | Нет | Значение
Part | TDateTimePart | Да | Часть

Замечания:

Возвращает значение типа Integer.

20. Метод DateTimePart (Часть даты со временем)

Метод класса (статический метод) класса TObject.

1class function TObject.DateTimePart(Value: datetime;
2  Part: TDateTimePart): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Нет | Значение
Part | TDateTimePart | Да | Часть

Замечания:

Возвращает значение типа Integer.

21. Метод DateTimeToStr (Дату и время в строку)

Метод класса (статический метод) класса TObject.

class function TObject.DateTimeToStr(Value: datetime): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Да | Значение

Замечания:

Возвращает значение типа string[2000].

22. Метод DateToStr (Дату в строку)

Метод класса (статический метод) класса TObject.

class function TObject.DateToStr(Value: date): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | date | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

23. Метод Dequeue (Удалить из очереди)

Метод экземпляра класса TObject.

procedure TObject.Dequeue(Permanently: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Permanently | Boolean | Да | Удалить навсегда

24. Метод DescribeObject (Описание объекта для сообщений пользователю)

Метод экземпляра класса TObject.

function TObject.DescribeObject: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

25. Метод DumpString (Строка в виде списка кодов символов)

Метод класса (статический метод) класса TObject.

1class function TObject.DumpString(Value: string[2000]; Delimiter: string[2000];
2  Hexadecimal: Boolean): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Delimiter | string[2000] | Нет | Разделитель
Hexadecimal | Boolean | Да | Использовать шестнадцатеричные значения

Замечания:

Возвращает значение типа string[2000].

26. Метод Ellipsis (Эллипсис)

Метод класса (статический метод) класса TObject.

1class function TObject.Ellipsis(Value: string[2000]; MaxLength: Integer;
2  WholeWords: Boolean): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
MaxLength | Integer | Да | Максимальная длина
WholeWords | Boolean | Да | По целым словам

Замечания:

Возвращает значение типа string[2000].

27. Метод EncodeDate (Собрать дату)

Метод класса (статический метод) класса TObject.

1class function TObject.EncodeDate(Year: Integer; Month: Integer;
2  Day: Integer): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Year | Integer | Нет | Год
Month | Integer | Нет | Месяц
Day | Integer | Нет | День

Замечания:

Возвращает значение типа date.

28. Метод EncodeDateTime (Собрать дату со временем)

Метод класса (статический метод) класса TObject.

1class function TObject.EncodeDateTime(Year: Integer; Month: Integer;
2  Day: Integer; Hours: Integer; Minutes: Integer; Seconds: Integer): datetime;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Year | Integer | Нет | Год
Month | Integer | Нет | Месяц
Day | Integer | Нет | День
Hours | Integer | Нет | Часы
Minutes | Integer | Нет | Минуты
Seconds | Integer | Нет | Секунды

Замечания:

Возвращает значение типа datetime.

29. Метод EncodeTime (Собрать время)

Метод класса (статический метод) класса TObject.

1class function TObject.EncodeTime(Hours: Integer; Minutes: Integer;
2  Seconds: Integer): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Hours | Integer | Нет | Часы
Minutes | Integer | Нет | Минуты
Seconds | Integer | Нет | Секунды

Замечания:

Возвращает значение типа time.

30. Метод Enqueue (Поставить в очередь)

Метод экземпляра класса TObject.

function TObject.Enqueue(QueueName: string[64]): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
QueueName | string[64] | Да | Имя очереди

Замечания:

Возвращает значение типа Boolean.

31. Метод Find (Поиск объекта)

Метод класса (статический метод) класса TObject.

1class function TObject.Find(Name: string[64]; Class: TClass; Parent: TObject;
2  Master: TObject): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Class | TClass | Нет | Класс объекта
Parent | TObject | Нет | Родительский объект
Master | TObject | Да | Мастер объекта

Замечания:

Возвращает значение типа TObject.

32. Метод FindGlobal (Глобальный поиск объекта)

Метод класса (статический метод) класса TObject.

1class function TObject.FindGlobal(SourceDataBaseGUID: string[38];
2  OldID: string[38]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
SourceDataBaseGUID | string[38] | Да | GUID базы данных-источника
OldID | string[38] | Да | Идентификатор при создании

Замечания:

Возвращает значение типа TObject.

33. Метод FloatToStr (Вещественное в строку)

Метод класса (статический метод) класса TObject.

class function TObject.FloatToStr(Value: float): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | float | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

34. Метод FormatDate (Форматировать дату)

Метод класса (статический метод) класса TObject.

1class function TObject.FormatDate(Value: date;
2  Format: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | date | Нет | Значение
Format | string[2000] | Нет | Формат

Замечания:

Возвращает значение типа string[2000].

35. Метод FormatDateTime (Форматировать дату со временем)

Метод класса (статический метод) класса TObject.

1class function TObject.FormatDateTime(Value: datetime;
2  Format: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Нет | Значение
Format | string[2000] | Нет | Формат

Замечания:

Возвращает значение типа string[2000].

36. Метод FormatFloat (Форматировать вещественное значение)

Метод класса (статический метод) класса TObject.

1class function TObject.FormatFloat(Value: float; DecimalPlaces: Integer;
2  DecimalSeparator: string[2]; GroupSeparator: string[2]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | float | Нет | Значение
DecimalPlaces | Integer | Нет | Количество десятичных знаков
DecimalSeparator | string[2] | Нет | Десятичный разделитель
GroupSeparator | string[2] | Нет | Разделитель групп разрядов

Замечания:

Возвращает значение типа string[2000].

37. Метод FormatTime (Форматировать время)

Метод класса (статический метод) класса TObject.

1class function TObject.FormatTime(Value: time;
2  Format: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | time | Нет | Значение
Format | string[2000] | Нет | Формат

Замечания:

Возвращает значение типа string[2000].

38. Метод GenerateAllNames (Сгенерировать имена для всех объектов)

Метод класса (статический метод) класса TObject.

class function TObject.GenerateAllNames: Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

39. Метод GeneratedDescription (Сгенерированное наименование)

Метод экземпляра класса TObject.

function TObject.GeneratedDescription: string[128];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].

40. Метод GeneratedName (Сгенерированное имя)

Метод экземпляра класса TObject.

function TObject.GeneratedName: string[64];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

41. Метод GetBlobSize (Размер большого двоичного объекта)

Метод класса (статический метод) класса TObject.

class function TObject.GetBlobSize(Value: blob): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | blob | Нет | Значение

Замечания:

Возвращает значение типа Integer.

42. Метод GetChildCount (Получить количество дочерних объектов)

Метод экземпляра класса TObject.

function TObject.GetChildCount: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

43. Метод GetClobSize (Размер большого текстового объекта)

Метод класса (статический метод) класса TObject.

class function TObject.GetClobSize(Value: clob): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа Integer.

44. Метод GetDescendantCount (Получить количество объектов-потомков)

Метод экземпляра класса TObject.

function TObject.GetDescendantCount: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

45. Метод GetDetailCount (Получить количество подчиненных объектов)

Метод экземпляра класса TObject.

function TObject.GetDetailCount: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

46. Метод GetLevel (Уровень в иерархии)

Метод экземпляра класса TObject.

function TObject.GetLevel: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

47. Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TObject.

class function TObject.GetResource(AOwner: string[64]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwner | string[64] | Да | Владелец

Замечания:

Возвращает значение типа string[2000].

48. Метод GetRoot (Получить корень иерархии)

Метод экземпляра класса TObject.

function TObject.GetRoot: TObject;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.

49. Метод GetTop (Получить объект верхнего уровня)

Метод экземпляра класса TObject.

function TObject.GetTop: TObject;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.

50. Метод HasAsChild (Объект является ребенком данного)

Метод экземпляра класса TObject.

function TObject.HasAsChild(Child: TObject): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Child | TObject | Нет | Дочерний объект

Замечания:

Возвращает значение типа Boolean.

51. Метод HasAsParent (Объект является родителем данного)

Метод экземпляра класса TObject.

function TObject.HasAsParent(Parent: TObject): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Parent | TObject | Нет | Родитель

Замечания:

Возвращает значение типа Boolean.

52. Метод HasChildren (Имеет детей)

Метод экземпляра класса TObject.

function TObject.HasChildren: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

53. Метод HasDetails (Имеет подчиненные объекты)

Метод экземпляра класса TObject.

function TObject.HasDetails: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

54. Метод Hash (Хеш-функция конца строки)

Метод класса (статический метод) класса TObject.

1class function TObject.Hash(Value: string[2000];
2  MaxLength: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
MaxLength | Integer | Да | Максимальная длина

Замечания:

Возвращает значение типа string[2000].

55. Метод HashReverse (Хеш-функция начала строки)

Метод класса (статический метод) класса TObject.

1class function TObject.HashReverse(Value: string[2000];
2  MaxLength: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
MaxLength | Integer | Да | Максимальная длина

Замечания:

Возвращает значение типа string[2000].

56. Метод HexToInt (Шестнадцатеричное представление в целое число)

Метод класса (статический метод) класса TObject.

class function TObject.HexToInt(Hexadecimal: string[64]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Hexadecimal | string[64] | Да | Шестнадцатеричное значение

Замечания:

Возвращает значение типа Integer.

57. Метод IfThenDate (Выбор из двух дат)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenDate(Value: Boolean; ATrue: date;
2  AFalse: date): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | date | Нет | Значение при выполнении условия
AFalse | date | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа date.

58. Метод IfThenDateTime (Выбор из двух дат со временем)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenDateTime(Value: Boolean; ATrue: datetime;
2  AFalse: datetime): datetime;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | datetime | Нет | Значение при выполнении условия
AFalse | datetime | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа datetime.

59. Метод IfThenExternalData (Выбор из двух значений - внешних данных)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenExternalData(Value: Boolean; ATrue: <external
2  data>; AFalse: <external data>): <external data>;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | <external data> | Нет | Значение при выполнении условия
AFalse | <external data> | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа <external data>.

60. Метод IfThenFloat (Выбор из двух вещественных)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenFloat(Value: Boolean; ATrue: float;
2  AFalse: float): float;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | float | Нет | Значение при выполнении условия
AFalse | float | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа float.

61. Метод IfThenInt (Выбор из двух целых)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenInt(Value: Boolean; ATrue: Integer;
2  AFalse: Integer): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | Integer | Нет | Значение при выполнении условия
AFalse | Integer | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа Integer.

62. Метод IfThenObject (Выбор из двух объектов)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenObject(Value: Boolean; ATrue: TObject;
2  AFalse: TObject): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | TObject | Нет | Значение при выполнении условия
AFalse | TObject | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа TObject.

63. Метод IfThenStr (Выбор из двух строк)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenStr(Value: Boolean; ATrue: string[2000];
2  AFalse: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | string[2000] | Нет | Значение при выполнении условия
AFalse | string[2000] | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа string[2000].

64. Метод IfThenTime (Выбор из двух времен)

Метод класса (статический метод) класса TObject.

1class function TObject.IfThenTime(Value: Boolean; ATrue: time;
2  AFalse: time): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение
ATrue | time | Нет | Значение при выполнении условия
AFalse | time | Нет | Значение при невыполнении условия

Замечания:

Возвращает значение типа time.

65. Метод InstanceObject (Объект по строковому представлению идентификатора (объект может не существовать))

Метод класса (статический метод) класса TObject.

class function TObject.InstanceObject(Value: string[38]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[38] | Да | Значение

Замечания:

Возвращает значение типа TObject.

66. Метод IntToHex (Целое число в шестнадцатеричное представление)

Метод класса (статический метод) класса TObject.

class function TObject.IntToHex(IntValue: Integer): string[64];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
IntValue | Integer | Нет | Целое значение

Замечания:

Возвращает значение типа string[64].

67. Метод IntToStr (Целое в строку)

Метод класса (статический метод) класса TObject.

class function TObject.IntToStr(Value: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Integer | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

68. Метод IsBadHierarchy (Ошибка в иерархии)

Метод экземпляра класса TObject.

function TObject.IsBadHierarchy: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

69. Метод IsBadPtr (Не указывает на существующий объект)

Метод экземпляра класса TObject.

function TObject.IsBadPtr: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

70. Метод IsCharAlpha (Символ является алфавитным)

Метод класса (статический метод) класса TObject.

class function TObject.IsCharAlpha(Value: string[2]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2] | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

71. Метод IsCharAlphaNumeric (Символ является алфавитно-числовым)

Метод класса (статический метод) класса TObject.

class function TObject.IsCharAlphaNumeric(Value: string[2]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2] | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

72. Метод IsInList (Объект входит в список)

Метод экземпляра класса TObject.

function TObject.IsInList(Value: TObjectList): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectList | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

73. Метод IsInSet (Объект входит в множество)

Метод экземпляра класса TObject.

function TObject.IsInSet(Value: TObjectSet): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectSet | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

74. Метод IsInstanceOf (Является экземпляром класса)

Метод экземпляра класса TObject.

function TObject.IsInstanceOf(Class: TClass): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Class | TClass | Нет | Класс

Замечания:

Возвращает значение типа Boolean.

75. Метод IsNotInList (Объект не входит в список)

Метод экземпляра класса TObject.

function TObject.IsNotInList(Value: TObjectList): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectList | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

76. Метод IsNotInSet (Объект не входит в множество)

Метод экземпляра класса TObject.

function TObject.IsNotInSet(Value: TObjectSet): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObjectSet | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

77. Метод LineBreak (Разделитель строк)

Метод класса (статический метод) класса TObject.

class function TObject.LineBreak: string[2];

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2].

78. Метод LinkClobs (Присоединить большой объект к другому)

Метод класса (статический метод) класса TObject.

class function TObject.LinkClobs(PrefData: clob; PostData: clob): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
PrefData | clob | Нет | Данные первого объекта
PostData | clob | Нет | Данные второго объекта

Замечания:

Возвращает значение типа clob.

79. Метод LinkToClob (Присоединить строки к большому объекту)

Метод класса (статический метод) класса TObject.

1class function TObject.LinkToClob(Prefix: string[2000]; Data: clob;
2  Postfix: string[2000]): clob;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Prefix | string[2000] | Нет | Префикс
Data | clob | Нет | Данные
Postfix | string[2000] | Нет | Постфикс

Замечания:

Возвращает значение типа clob.

80. Метод Locate (Поиск объекта по локатору)

Метод класса (статический метод) класса TObject.

class function TObject.Locate(Locator: string[2000]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Locator | string[2000] | Нет | Локатор

Замечания:

Возвращает значение типа TObject.

81. Метод Locator (Локатор объекта)

Метод экземпляра класса TObject.

function TObject.Locator: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

82. Метод LowerCase (Преобразовать к нижнему регистру)

Метод класса (статический метод) класса TObject.

class function TObject.LowerCase(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

83. Метод MatchRegExp (Проверка соответствия строки регулярному выражению)

Метод класса (статический метод) класса TObject.

1class function TObject.MatchRegExp(Value: string[2000];
2  RegExp: string[2000]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
RegExp | string[2000] | Нет | Регулярное выражение

Замечания:

Возвращает значение типа Boolean.

84. Метод MergeIdentifiers (Объединенный идентификатор)

Метод класса (статический метод) класса TObject.

1class function TObject.MergeIdentifiers(Identifier: string[64];
2  Modifier: string[64]; MaxLength: Integer): string[64];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Identifier | string[64] | Да | Идентификатор
Modifier | string[64] | Да | Модификатор
MaxLength | Integer | Да | Максимальная длина

Замечания:

Возвращает значение типа string[64].

85. Метод MergeTo (Отождествить с)

Метод экземпляра класса TObject.

procedure TObject.MergeTo(PrimaryObject: TObject);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
PrimaryObject | TObject | Да | Первичный объект

86. Метод Modulus (Остаток деления)

Метод класса (статический метод) класса TObject.

class function TObject.Modulus(Value: Integer; Base: Integer): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Integer | Нет | Делимое
Base | Integer | Нет | Делитель

Замечания:

Возвращает значение типа Integer.

87. Метод ObjectInstance (Текстовое представление идентификатора объекта (объект может не существовать))

Метод класса (статический метод) класса TObject.

class function TObject.ObjectInstance(Value: TObject): string[38];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | TObject | Нет | Значение

Замечания:

Возвращает значение типа string[38].

88. Метод Pos (Поиск подстроки)

Метод класса (статический метод) класса TObject.

1class function TObject.Pos(Substring: string[2000];
2  Value: string[2000]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Substring | string[2000] | Нет | Подстрока
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа Integer.

89. Метод PreprocessRegExp (Адаптировать регулярное выражение к требованиям СУБД)

Метод класса (статический метод) класса TObject.

class function TObject.PreprocessRegExp(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

90. Метод QualifiedName (Квалифицированное имя)

Метод экземпляра класса TObject.

function TObject.QualifiedName: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

91. Метод QuotedStr (Строку в апострофы)

Метод класса (статический метод) класса TObject.

class function TObject.QuotedStr(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

92. Метод RaiseException (Возбудить исключение)

Метод класса (статический метод) класса TObject.

class procedure TObject.RaiseException(Message: string[2000]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Message | string[2000] | Нет | Сообщение

93. Метод RaiseResource (Возбудить исключение по ресурсной строке)

Метод класса (статический метод) класса TObject.

class procedure TObject.RaiseResource(AOwner: string[64]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AOwner | string[64] | Да | Владелец

94. Метод ReadFromClob (Считать строку из большого текстового объекта)

Метод класса (статический метод) класса TObject.

class function TObject.ReadFromClob(Value: clob): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | clob | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

95. Метод ResourceByItem (Значение ресурсной строки)

Метод класса (статический метод) класса TObject.

class function TObject.ResourceByItem(Resource: Resource strings): string[128];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Resource | Resource strings | Нет | Ресурс

Замечания:

Возвращает значение типа string[128].

96. Метод Round (Округление)

Метод класса (статический метод) класса TObject.

class function TObject.Round(Value: float; Decimals: Integer): float;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | float | Нет | Значение
Decimals | Integer | Нет | Количество десятичных знаков

Замечания:

Возвращает значение типа float.

97. Метод SendInstantMessage (Отправить мгновенное сообщение)

Метод класса (статический метод) класса TObject.

1class procedure TObject.SendInstantMessage(Recipient: TUser;
2  MessageText: string[255]; DeliveryTime: datetime; AttachSelected: Boolean;
3  Selected: TObjectList; CurrentFormView: TFormView; HyperLink: string[256];
4  FileName: string[255]; FileBaseName: string[128]; FileBody: blob;
5  AttachmentType: TInstantMessageAttachmentType);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Recipient | TUser | Да | Получатель
MessageText | string[255] | Да | Сообщение
DeliveryTime | datetime | Нет | Время доставки
AttachSelected | Boolean | Да | Присоединить выбранные объекты
Selected | TObjectList | Нет | Список выбранных
CurrentFormView | TFormView | Нет | Текущее представление формы
HyperLink | string[256] | Нет | Гиперссылка
FileName | string[255] | Нет | Файл
FileBaseName | string[128] | Да | Имя файла (без пути)
FileBody | blob | Нет | Содержимое файла
AttachmentType | TInstantMessageAttachmentType | Да | Тип приложения

98. Метод Sleep (Задержка выполнения)

Метод класса (статический метод) класса TObject.

class procedure TObject.Sleep(Seconds: Integer);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Seconds | Integer | Да | Количество секунд

99. Метод StringReplace (Заменить содержимое строки)

Метод класса (статический метод) класса TObject.

1class function TObject.StringReplace(Value: string[2000];
2  OldPattern: string[2000]; NewPattern: string[2000];
3  ReplaceAll: Boolean): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
OldPattern | string[2000] | Нет | Старый шаблон
NewPattern | string[2000] | Нет | Новый шаблон
ReplaceAll | Boolean | Да | Заменять все

Замечания:

Возвращает значение типа string[2000].

100. Метод StrLength (Длина строки)

Метод класса (статический метод) класса TObject.

class function TObject.StrLength(String: string[2000]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
String | string[2000] | Нет | Строка

Замечания:

Возвращает значение типа Integer.

101. Метод StrLike (Сопоставить строку с шаблоном)

Метод класса (статический метод) класса TObject.

1class function TObject.StrLike(Value: string[2000];
2  Pattern: string[2000]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Pattern | string[2000] | Нет | Шаблон

Замечания:

Возвращает значение типа Boolean.

102. Метод StrPad (Заполнить строку)

Метод класса (статический метод) класса TObject.

1class function TObject.StrPad(Value: string[2000]; Padding: string[2000];
2  PadRight: Boolean; MaxLength: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Padding | string[2000] | Нет | Заполнитель
PadRight | Boolean | Да | Заполнять справа
MaxLength | Integer | Нет | Максимальная длина

Замечания:

Возвращает значение типа string[2000].

103. Метод StrToBool (Строку в логическое значение)

Метод класса (статический метод) класса TObject.

class function TObject.StrToBool(Value: string[2000]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа Boolean.

104. Метод StrToDate (Строку в дату)

Метод класса (статический метод) класса TObject.

class function TObject.StrToDate(Value: string[2000]): date;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа date.

105. Метод StrToDateTime (Строку в дату и время)

Метод класса (статический метод) класса TObject.

class function TObject.StrToDateTime(Value: string[2000]): datetime;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа datetime.

106. Метод StrToFloat (Строку в вещественное)

Метод класса (статический метод) класса TObject.

class function TObject.StrToFloat(Value: string[2000]): float;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа float.

107. Метод StrToInt (Строку в целое)

Метод класса (статический метод) класса TObject.

class function TObject.StrToInt(Value: string[2000]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа Integer.

108. Метод StrToTime (Строку во время)

Метод класса (статический метод) класса TObject.

class function TObject.StrToTime(Value: string[2000]): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа time.

109. Метод StrTranslate (Транслировать символы в строке)

Метод класса (статический метод) класса TObject.

1class function TObject.StrTranslate(Value: string[2000];
2  OldChars: string[2000]; NewChars: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
OldChars | string[2000] | Нет | Старый набор символов
NewChars | string[2000] | Нет | Новый набор символов

Замечания:

Возвращает значение типа string[2000].

110. Метод StrWrap (Выровнять строку)

Метод класса (статический метод) класса TObject.

1class function TObject.StrWrap(Value: string[2000]; Delimiter: string[2000];
2  MaxCol: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение
Delimiter | string[2000] | Нет | Разделитель
MaxCol | Integer | Нет | Максимальное количество символов

Замечания:

Возвращает значение типа string[2000].

111. Метод SuggestDescription (Предложить наименование)

Метод экземпляра класса TObject.

procedure TObject.SuggestDescription(Description: string[128]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Description | string[128] | Да | Наименование

112. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TObject.

function TObject.SuggestFileName(Domain: TDomain): string[128];

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя | Тип | Обязательно | Значение
Domain | TDomain | Нет | Домен

Замечания:

Возвращает значение типа string[128].

113. Метод TimeOf (Время из даты со временем)

Метод класса (статический метод) класса TObject.

class function TObject.TimeOf(Value: datetime): time;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | datetime | Нет | Значение

Замечания:

Возвращает значение типа time.

114. Метод TimePart (Часть времени)

Метод класса (статический метод) класса TObject.

class function TObject.TimePart(Value: time; Part: TDateTimePart): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | time | Нет | Значение
Part | TDateTimePart | Да | Часть

Замечания:

Возвращает значение типа Integer.

115. Метод TimeToStr (Время в строку)

Метод класса (статический метод) класса TObject.

class function TObject.TimeToStr(Value: time): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | time | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

116. Метод Touch (Модификация объекта)

Метод экземпляра класса TObject.

procedure TObject.Touch;

Метод скрыт от пользователя.

Метод не имеет параметров.

117. Метод Trim (Убрать лишние пробелы)

Метод класса (статический метод) класса TObject.

class function TObject.Trim(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

118. Метод Trunc (Отсечение дробной части)

Метод класса (статический метод) класса TObject.

class function TObject.Trunc(Value: float): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | float | Нет | Значение

Замечания:

Возвращает значение типа Integer.

119. Метод UniqueValue (Уникальный идентификатор)

Метод класса (статический метод) класса TObject.

class function TObject.UniqueValue: string[64];

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

120. Метод UpperCase (Преобразовать к верхнему регистру)

Метод класса (статический метод) класса TObject.

class function TObject.UpperCase(Value: string[2000]): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа string[2000].

121. Метод Ole-объекта CheckSGMLContent (Проверить SGML-содержимое)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Property | TProperty | Да | Свойство

Замечания:

Возвращает значение типа string[2000].

122. Метод Ole-объекта ExportAfter (Экспортировать модифицированные)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
FileName | string[255] | Да | Имя файла-реплики
FromDate | datetime | Нет | Модифицировано после

123. Метод Ole-объекта FixSGMLContentErrors (Исправить ошибки SGML-содержимого)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Property | TProperty | Да | Свойство

Замечания:

Возвращает значение типа string[2000].

124. Метод Ole-объекта LoadBlobsFromFolder (Загрузить данные из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка
Property | TProperty | Да | Свойство
Template | string[128] | Да | Шаблон

Замечания:

Возвращает значение типа Integer.

125. Метод Ole-объекта SaveBlobsToFolder (Сохранить данные в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка
Property | TProperty | Да | Свойство
Template | string[128] | Да | Шаблон
List | TObjectList | Нет | Список объектов

Замечания:

Возвращает значение типа Integer.

126. Метод Ole-объекта SplitExcelSheetsToFiles (Разделить Excel листы на файлы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта скрыт от пользователя.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
WorkBook | blob | Нет | Книга (объект)
FileName | string[255] | Нет | Имя Excel-файла
FileNameMappingSheetName | string[128] | Нет | Имя листа с сопоставлениями имен файлов (по умолчанию MapSheetNameToFileName)
Folder | string[255] | Да | Каталог

127. Шаблон отчета Excel Excel (Перенести в Excel)

Шаблон отчета Excel класса (статический шаблон) класса TObject.

Шаблон отчета Excel является методом класса.

Шаблон отчета Excel не имеет параметров.

128. Шаблон отчета Word SpellCheck (Проверка правописания)

Шаблон отчета Word класса (статический шаблон) класса TObject.

Шаблон отчета Word скрыт от пользователя.

Шаблон отчета Word является методом класса.

Шаблон отчета Word не имеет параметров.

129. Шаблон XSLT-отчета ObjectInformation (Информация об объекте)

Шаблон XSLT-отчета класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ShowHiddenProps | Boolean | Да | Показывать скрытые свойства

130. Шаблон XSLT-отчета SelectDataToText (Выполнить запрос в текст)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | string[64] | Да | Имя класса
Query | clob | Нет | Запрос

131. Шаблон XSLT-отчета SelectDataToXML (Выполнить запрос в xml-документ)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | string[64] | Да | Имя класса
Query | clob | Нет | Запрос

132. Подпрограмма Column (Колонка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

133. Подпрограмма CopyToClipboard (Копировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

134. Подпрограмма CurrentFormView (Текущее представление формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

135. Подпрограмма CurrentlySelected (Список выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

136. Подпрограмма CurrentlySelectedSet (Множество выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

137. Подпрограмма CurrentlyVisible (Список видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

138. Подпрограмма CurrentlyVisibleSet (Множество видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

139. Подпрограмма Dependencies (Зависимости)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

140. Подпрограмма Edit columns (Редактировать строку)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

141. Подпрограмма Edit filters (Редактировать фильтры)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

142. Подпрограмма Edit properties (Редактировать свойства)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

143. Подпрограмма Export (Экспортировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

144. Подпрограмма ExportReport (Выгрузить в отчет)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

145. Подпрограмма FormOptions (Настройки формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

146. Подпрограмма Import (Импортировать)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

147. Подпрограмма Merge (Объединить)

Подпрограмма класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма не имеет параметров.

148. Подпрограмма Messages (Проверить сообщения)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

149. Подпрограмма Options (Настройки)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

150. Подпрограмма Paste (Вставить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

151. Подпрограмма PasteSpecial (Специальная вставка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

152. Подпрограмма Presentations (Виды)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

153. Подпрограмма Refresh (Обновить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

154. Подпрограмма Search (Поиск)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

155. Подпрограмма Selection (Выбранные)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

156. Подпрограмма Tree (Дерево)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IExternalQuery (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IExternalQuery

01type
02  IExternalQuery = interface(IDispatch)
03    ['{1A86D1DA-A56E-4D53-88F9-7A035D7D12B4}']
04    function Get_CurrentQuery: WideString; safecall;
05    function Select(const SQL: WideString): IExternalDataSet; safecall;
06    function SelectedRecordsCount: Integer; safecall;
07    function SelectedRecord(Index: Integer): OleVariant; safecall;
08    procedure PlaceCurrentQuery(const Sheet: IDispatch; CaptionsNeeded: WordBool;
09      Row: Integer; Column: Integer; ShiftRows: WordBool; ShiftColumns: WordBool); safecall;
10    procedure PlaceQuery(const Sheet: IDispatch; const DataSet: ExternalDataSet;
11      Row: Integer; Column: Integer; ShiftRows: WordBool; ShiftColumns: WordBool); safecall;
12    property CurrentQuery: WideString read Get_CurrentQuery;
13  end;

1. Свойства

Свойства интерфейса IExternalQuery:

Имя | Тип | Доступ | Назначение
CurrentQuery | WideString | Только для чтения |

2. Метод PlaceCurrentQuery

Метод интерфейса IExternalQuery.

1procedure IExternalQuery.PlaceCurrentQuery(const Sheet: IDispatch;
2  CaptionsNeeded: WordBool; Row: Integer; Column: Integer; ShiftRows: WordBool;
3  ShiftColumns: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Sheet | IDispatch | Да |
CaptionsNeeded | WordBool | Нет |
Row | Integer | Нет |
Column | Integer | Нет |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |

3. Метод PlaceQuery

Метод интерфейса IExternalQuery.

1procedure IExternalQuery.PlaceQuery(const Sheet: IDispatch;
2  const DataSet: ExternalDataSet; Row: Integer; Column: Integer;
3  ShiftRows: WordBool; ShiftColumns: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Sheet | IDispatch | Да |
DataSet | ExternalDataSet | Да |
Row | Integer | Нет |
Column | Integer | Нет |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |

4. Метод Select

Метод интерфейса IExternalQuery.

function IExternalQuery.Select(const SQL: WideString): IExternalDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
SQL | WideString | Да |

Замечания:

Возвращает значение типа IExternalDataSet.

5. Метод SelectedRecord

Метод интерфейса IExternalQuery.

function IExternalQuery.SelectedRecord(Index: Integer): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа OleVariant.

6. Метод SelectedRecordsCount

Метод интерфейса IExternalQuery.

function IExternalQuery.SelectedRecordsCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Мельница данных ((раздел целиком))

Мельница данных- Класс TClassMember (Члены класса) (раздел целиком) (22.10.2024) (одним файлом)
Класс TClassMember (Члены класса)

Диаграмма Класс TObject (Объекты)Класс TClass (Классы)

1. Свойства

Свойства класса TClassMember:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Переопределен

2. Конструктор Create (Конструктор члена класса)

Конструктор класса TClassMember.

1constructor TClassMember.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Имя
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TClassMember.

3. Метод GetOverride (Переопределен)

Метод экземпляра класса TClassMember.

function TClassMember.GetOverride: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TClassMember.

function TClassMember.SuggestFileName(Domain: TDomain): string[128];

Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя | Тип | Обязательно | Значение
Domain | TDomain | Нет | Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].


Мельница данных ((раздел целиком))

Мельница данных- Класс TProperty (Свойства) (раздел целиком) (22.10.2024) (одним файлом)
Класс TProperty (Свойства)

Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

Объекты класса образуют иерархию.

1. Свойства

Свойства класса TProperty:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Видимо пользователю | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
ReadMember | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Член класса для чтения
ReadMemberClass | TClass | Да | Видимо пользователю | Только для чтения | Класс члена класса для чтения
WriteMember | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Член класса для записи
WriteMemberClass | TClass | Да | Видимо пользователю | Только для чтения | Класс члена класса для записи
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Category | string[128] | Нет | Видимо пользователю | Чтение/Запись | Категория
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
IsExportable | Boolean | Да | Видимо пользователю | Чтение/Запись | Для экспорта
IsSuspended | Boolean | Да | Видимо пользователю | Чтение/Запись | Отложенное
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей
IsUnupdatable | Boolean | Да | Видимо пользователю | Чтение/Запись | Необновляемое при импорте
NullHandler | TMethod | Нет | Видимо пользователю | Чтение/Запись | Обработчик пустого значения
OnDemand | Boolean | Да | Видимо пользователю | Чтение/Запись | По требованию

2. Конструктор Create (Конструктор свойства)

Конструктор класса TProperty.

1constructor TProperty.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ReadMember: TClassMember; WriteMember: TClassMember;
4  Position: Integer; Scope: TScope; IsExportable: Boolean; IsSuspended: Boolean;
5  CreateViewColumns: Boolean; Category: string[128]): TObject;

Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
ReadMember | TClassMember | Нет | Член класса для чтения
WriteMember | TClassMember | Нет | Член класса для записи
Position | Integer | Да | Позиция
Scope | TScope | Да | Область видимости
IsExportable | Boolean | Да | Для экспорта
IsSuspended | Boolean | Да | Отложенное
CreateViewColumns | Boolean | Да | Создать колонку во всех представлениях
Category | string[128] | Нет | Категория

Замечания:

Создает новый объект класса TProperty.

3. Метод Change (Изменение объекта)

Метод экземпляра класса TProperty.

procedure TProperty.Change(Action: TChangeAction);

Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Унаследовано от TObject.Change

4. Метод CreateChildren (Создать дочерние свойства)

Метод экземпляра класса TProperty.

1procedure TProperty.CreateChildren(ClearWriteMember: Boolean;
2  PublicOnly: Boolean; ExactName: Boolean);

Параметры:

Имя | Тип | Обязательно | Значение
ClearWriteMember | Boolean | Да | Создавать свойства только для чтения
PublicOnly | Boolean | Да | Создавать только видимые свойства
ExactName | Boolean | Да | Не изменять имя свойства

5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TProperty.

class function TProperty.GetNextPos(Master: TObject; Parent: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер
Parent | TObject | Нет | Родитель

Замечания:

Возвращает значение типа Integer.

6. Метод LocalizableFieldName (Получить имя локализуемого поля)

Метод класса (статический метод) класса TProperty.

1class function TProperty.LocalizableFieldName(Class: TClass;
2  Name: string[64]): string[64];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Class | TClass | Нет | Класс
Name | string[64] | Да | Имя

Замечания:

Возвращает значение типа string[64].

7. Метод LocalizableProperty (Локализуемое свойство)

Метод класса (статический метод) класса TProperty.

1class function TProperty.LocalizableProperty(ClassName: string[64];
2  PropertyName: string[64]): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | string[64] | Да | Имя класса
PropertyName | string[64] | Да | Имя свойства

Замечания:

Возвращает значение типа Boolean.

8. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TProperty.

function TProperty.SuggestFileName(Domain: TDomain): string[128];

Переопределяет метод в TClassMember.SuggestFileName, TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя | Тип | Обязательно | Значение
Domain | TDomain | Нет | Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].


Мельница данных ((раздел целиком))

Мельница данных- Класс TTextIndexEntry (Вхождения индекса текстового поиска) (раздел целиком) (22.10.2024) (одним файлом)
Класс TTextIndexEntry (Вхождения индекса текстового поиска)

Диаграмма

1. Свойства

Свойства класса TTextIndexEntry:

Имя | Тип | Обязательно | Доступ | Назначение
Word | string[64] | Да | Только для чтения | Слово
UpperWord | string[64] | Да | Только для чтения | Слово в верхнем регистре

2. Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndexEntry.

class procedure TTextIndexEntry.LoadFromBuffer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Класс TStringList (Список строк) (раздел целиком) (22.10.2024) (одним файлом)
Класс TStringList (Список строк)

Класс TObject (Объекты)Класс TStringListItem (Элемент списка строк)

Объекты класса не именованы.

1. Свойства

Свойства класса TStringList:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Duplicates | TDuplicates | Да | Видимо пользователю | Чтение/Запись | Дублирование
Sorted | Boolean | Да | Видимо пользователю | Чтение/Запись | Сортированный
Delimiter | string[2] | Нет | Видимо пользователю | Чтение/Запись | Разделитель
CaseSensitive | Boolean | Да | Видимо пользователю | Чтение/Запись | Регистрозависимый

2. Конструктор Create (Конструктор списка строк)

Конструктор класса TStringList.

1constructor TStringList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TStringList.

3. Метод Add (Добавить строку в список)

Метод экземпляра класса TStringList.

function TStringList.Add(ItemString: string[2000]): Integer;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemString | string[2000] | Нет | Строка

Замечания:

Возвращает значение типа Integer.

4. Метод Archive (Отправить список в архив)

Метод экземпляра класса TStringList.

procedure TStringList.Archive;

Метод не имеет параметров.

5. Метод Clear (Очистить список)

Метод экземпляра класса TStringList.

procedure TStringList.Clear;

Метод скрыт от пользователя.

Метод не имеет параметров.

6. Метод ClobField (Поле в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.

1class function TStringList.ClobField(Text: clob; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | clob | Нет | Текст
Delimiter | string[2] | Нет | Разделитель
FieldIndex | Integer | Нет | Номер поля

Замечания:

Возвращает значение типа string[2000].

7. Метод ClobFieldCount (Количество полей в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.

1class function TStringList.ClobFieldCount(Text: clob;
2  Delimiter: string[2]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | clob | Нет | Текст
Delimiter | string[2] | Нет | Разделитель

Замечания:

Возвращает значение типа Integer.

8. Метод ClobFieldIndexOf (Индекс вхождения в состав большого текстового объекта)

Метод класса (статический метод) класса TStringList.

1class function TStringList.ClobFieldIndexOf(Text: clob; Delimiter: string[2];
2  Value: string[2000]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | clob | Нет | Текст
Delimiter | string[2] | Нет | Разделитель
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа Integer.

9. Метод Delete (Удалить элемент из списка по индексу)

Метод экземпляра класса TStringList.

procedure TStringList.Delete(ItemIndex: Integer);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс

10. Метод GetDelimitedText (Получить в виде разделенного текста)

Метод экземпляра класса TStringList.

function TStringList.GetDelimitedText: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

11. Метод GetDelimitedTextAsClob (Получить в виде разделенного большого текстового объекта)

Метод экземпляра класса TStringList.

function TStringList.GetDelimitedTextAsClob: clob;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

12. Метод GetItem (Получить строку по индексу)

Метод экземпляра класса TStringList.

function TStringList.GetItem(ItemIndex: Integer): string[2000];

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс

Замечания:

Возвращает значение типа string[2000].

13. Метод IndexOf (Получить индекс строки в списке)

Метод экземпляра класса TStringList.

function TStringList.IndexOf(ItemString: string[2000]): Integer;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemString | string[2000] | Нет | Строка

Замечания:

Возвращает значение типа Integer.

14. Метод Insert (Вставить строку в список)

Метод экземпляра класса TStringList.

procedure TStringList.Insert(ItemIndex: Integer; ItemString: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс
ItemString | string[2000] | Нет | Строка

15. Метод Length (Длина списка)

Метод экземпляра класса TStringList.

function TStringList.Length: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

16. Метод Remove (Удалить строку из списка)

Метод экземпляра класса TStringList.

procedure TStringList.Remove(ItemString: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemString | string[2000] | Нет | Строка

17. Метод SetDelimitedText (Создать элементы списка на основе разделенного текста)

Метод экземпляра класса TStringList.

procedure TStringList.SetDelimitedText(Text: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Text | string[2000] | Нет | Текст

18. Метод SetItem (Установить значение элемента)

Метод экземпляра класса TStringList.

procedure TStringList.SetItem(ItemIndex: Integer; ItemString: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
ItemIndex | Integer | Да | Индекс
ItemString | string[2000] | Нет | Строка

19. Метод Sort (Сортировать)

Метод экземпляра класса TStringList.

procedure TStringList.Sort;

Метод скрыт от пользователя.

Метод не имеет параметров.

20. Метод StrField (Поле в составе строки)

Метод класса (статический метод) класса TStringList.

1class function TStringList.StrField(Text: string[2000]; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | string[2000] | Нет | Текст
Delimiter | string[2] | Нет | Разделитель
FieldIndex | Integer | Нет | Номер поля

Замечания:

Возвращает значение типа string[2000].

21. Метод StrFieldCount (Количество полей в составе строки)

Метод класса (статический метод) класса TStringList.

1class function TStringList.StrFieldCount(Text: string[2000];
2  Delimiter: string[2]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | string[2000] | Нет | Текст
Delimiter | string[2] | Нет | Разделитель

Замечания:

Возвращает значение типа Integer.

22. Метод StrFieldIndexOf (Индекс вхождения в состав строки)

Метод класса (статический метод) класса TStringList.

1class function TStringList.StrFieldIndexOf(Text: string[2000];
2  Delimiter: string[2]; Value: string[2000]): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | string[2000] | Нет | Текст
Delimiter | string[2] | Нет | Разделитель
Value | string[2000] | Нет | Значение

Замечания:

Возвращает значение типа Integer.


Мельница данных ((раздел целиком))

Мельница данных- Класс TIntegerDomain (Целые числа) (раздел целиком) (22.10.2024) (одним файлом)
Класс TIntegerDomain (Целые числа)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

1. Свойства

Свойства класса TIntegerDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
MinValue | Integer | Нет | Видимо пользователю | Чтение/Запись | Минимальное значение
MaxValue | Integer | Нет | Видимо пользователю | Чтение/Запись | Максимальное значение

2. Конструктор Create (Конструктор целочисленного домена)

Конструктор класса TIntegerDomain.

1constructor TIntegerDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; MinValue: Integer; MaxValue: Integer): TDomain;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
MinValue | Integer | Нет | Минимальное значение
MaxValue | Integer | Нет | Максимальное значение

Замечания:

Создает новый объект класса TIntegerDomain.

3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TIntegerDomain.

function TIntegerDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Класс TAsyncHandlerAccess (Доступ к обработчикам отложенного выполнения) (раздел целиком) (22.10.2024) (одним файлом)
Класс TAsyncHandlerAccess (Доступ к обработчикам отложенного выполнения)

Класс TAccessItem (Элементы доступа)Класс TObject (Объекты)Класс TAsyncHandler (Обработчики отложенного выполнения)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Конструктор Create (Конструктор доступа к обработчикам отложенного выполнения)

Конструктор класса TAsyncHandlerAccess.

1constructor TAsyncHandlerAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
SecurityAccount | TSecurityAccount | Да | Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TAsyncHandlerAccess.


Мельница данных ((раздел целиком))

Мельница данных- Класс TFormAccess (Доступ к формам) (раздел целиком) (22.10.2024) (одним файлом)
Класс TFormAccess (Доступ к формам)

Класс TAccessItem (Элементы доступа)Класс TObject (Объекты)Класс TForm (Формы)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Конструктор Create (Конструктор доступа к форме)

Конструктор класса TFormAccess.

1constructor TFormAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TForm; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TForm | Да | Форма
Accessor | TSecurityAccount | Нет | Унаследовано от TObject.Create
SecurityAccount | TSecurityAccount | Да | Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TFormAccess.


Мельница данных ((раздел целиком))

Мельница данных- Класс TSystemMessage (Системные сообщения) (раздел целиком) (22.10.2024) (одним файлом)
Класс TSystemMessage (Системные сообщения)

Диаграмма

1. Свойства

Свойства класса TSystemMessage:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Session | TSessionHistory | Нет | Скрыто от пользователя | Только для чтения | Сессия
SessionTimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время начала сессии
SessionCloseStamp | datetime | Нет | Видимо пользователю | Только для чтения | Время завершения сессии
IntStamp | Integer | Нет | Видимо пользователю | Только для чтения | Целочисленный номер
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
Login | string[64] | Да | Видимо пользователю | Только для чтения | Логин
UserAgent | string[2000] | Нет | Видимо пользователю | Только для чтения | Пользовательский агент
IPAddress | string[16] | Нет | Видимо пользователю | Только для чтения | IP-адрес
ConnectionInfo | string[2000] | Нет | Видимо пользователю | Только для чтения | Информация о соединении
Text | string[2000] | Нет | Видимо пользователю | Чтение/Запись | Текст
Data | blob | Нет | Видимо пользователю | Чтение/Запись | Данные
DataAsText | clob | Нет | Видимо пользователю | Только для чтения | Данные как текст

2. Метод Allow (Системные сообщения разрешены)

Метод класса (статический метод) класса TSystemMessage.

class function TSystemMessage.Allow: Boolean;

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

3. Метод Clear (Очистить системные сообщения)

Метод класса (статический метод) класса TSystemMessage.

1class procedure TSystemMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По

4. Метод Post (Отправить системное сообщение)

Метод класса (статический метод) класса TSystemMessage.

class procedure TSystemMessage.Post(Text: string[2000]; Data: blob);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Text | string[2000] | Нет | Текст
Data | blob | Нет | Данные


Мельница данных ((раздел целиком))

Мельница данных- Класс TQueue (Очередь) (раздел целиком) (22.10.2024) (одним файлом)
Класс TQueue (Очередь)

Диаграмма Класс TObject (Объекты)

1. Свойства

Свойства класса TQueue:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
QueueName | string[64] | Да | Видимо пользователю | Только для чтения | Имя очереди
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время входа в очередь
Object | TObject | Нет | Видимо пользователю | Только для чтения | Объект
ObjectName | string[64] | Да | Видимо пользователю | Только для чтения | Имя объекта
ObjectDescription | string[128] | Да | Видимо пользователю | Только для чтения | Наименование объекта
ObjectClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс объекта
ObjectParent | TObject | Нет | Скрыто от пользователя | Только для чтения | Объект-родитель
ObjectMaster | TObject | Да | Скрыто от пользователя | Только для чтения | Объект-мастер
ObjectSourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | База данных-источник
ObjectOldID | string[38] | Да | Скрыто от пользователя | Только для чтения | Идентификатор объекта при создании
ObjectCreator | TUser | Да | Скрыто от пользователя | Только для чтения | Объект создан пользователем
ObjectCreated | datetime | Да | Скрыто от пользователя | Только для чтения | Объект создан
ObjectModifier | TUser | Да | Скрыто от пользователя | Только для чтения | Объект изменен пользователем
ObjectModified | datetime | Да | Скрыто от пользователя | Только для чтения | Объект изменен
Processed | Boolean | Да | Видимо пользователю | Только для чтения | Обработан

2. Конструктор Create (Конструктор объекта в очереди)

Конструктор класса TQueue.

constructor TQueue.Create(Object: TObject; QueueName: string[64]): TObject;

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Да | Объект
QueueName | string[64] | Да | Имя очереди

Замечания:

Создает новый объект класса TQueue.

3. Деструктор Destroy (Деструктор объекта в очереди)

Деструктор класса TQueue.

destructor TQueue.Destroy;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TQueue или его наследника.

4. Метод Clear (Очистить очередь)

Метод класса (статический метод) класса TQueue.

class procedure TQueue.Clear(QueueName: string[64]);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
QueueName | string[64] | Да | Имя очереди


Мельница данных ((раздел целиком))

Мельница данных- Графика (раздел целиком) (22.10.2024) (одним файлом)
Графика

1. Линии

Для отрисовки линий используется процедура

procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double);
Здесь:

  • X1 - координата начала линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y1 - координата начала линии по вертикали в миллиметрах от верхнего левого угла листа.
  • X2 - координата конца линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y2 - координата Конца линии по вертикали в миллиметрах от верхнего левого угла листа.

Для задания толщины линии используется свойство

property LineWidth: Double
Значение толщины задается в миллиметрах. Значение по умолчанию - минимально возможная единица рисования для устройства. Так для монитора - 1 pixel, для принтера - 1 dot (точка)

Для задания стиля отрисовки начала/окончания линии используется свойство property LineCap: TPDFLineCap
Возможные стили:
Значение свойства: | Отображение: | Описание:
0 | Линия 0 | Прямой срез точно по точкам начала и окончания линии (по умолчанию)
1 | Линия 1 | С закруглением
2 | Линия 2 | Прямой срез с продолжением линии на половину толщины линии

Объявление цвета линии.

Две линии разной толщины, с разными окончаниями и цветами:
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineCap = 1
06
07page.LineWidth = 2
08
09page.Line 10, 10, 30, 30
10
11page.LineWidth = 4
12
13page.SetColor 255, 0, 0
14
15page.LineCap = 2
16
page.Line 10, 30, 30, 10."I

Результат:
2 линии

При необходимости соединения линий под углом в определенной точке можно задать тип соединения. Для объявления типа соединения используется свойство property LineJoin: TPDFLineJoin;
Типы соединения двух линий:
Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пунктир

Для создания пунктира используется процедура отображения линии с предварительно объявленными дополнительными значениями.

Процедура procedure SetDash(DashArray: OleVariant; Phase: Integer); Здесь DashArray - массив значений в миллиметрах, указывающий последовательность чередования штрихов и пропусков на линии, Phase - смещение в миллиметрах по линии.

Пример 1. Штрих 10 мм, Промежуток 5 мм, Смещения нет
Пример 2. Штрих 10 мм, Промежуток 5 мм, Смещение 5 мм
Пример 3. Различные значения штрихов и промежутков, Смещения нет
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 3
06
07page.SetDash Array(10, 5), 0
08
09page.Line 10, 10, 100, 10
10
11page.SetDash Array(10, 5), 5
12
13page.Line 10, 20, 100, 20
14
15page.SetDash Array(10, 5, 3, 2, 12, 20), 0
16
page.Line 10, 30, 100, 30

Результат:
Пунктир 1

Ломанная линия - здесь непрерывная линия, состоящая из нескольких прямых. Для отображения ломанной используется процедура procedure Poly(Points: OleVariant; Fill: WordBool), где Points - массив координат точек соединяемых прямыми, а Fill - признак заливки полученной замкнутой фигуры (если замкнута).

Пример Звезда без заливки
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), false

Результат:
Звезда
Пример Звезда с заливкой
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), true

Результат:
Звезда заливка

2. Прямоугольник

Rectangle (Прямоугольник) - для создания используется процедура:

procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double; Fill: WordBool);
Здесь:

  • X1 - координата верхнего левого угла прямоугольника по горизонтали в миллиметрах от верхнего левого угла листа шаблона.
  • Y1 - координата верхнего левого угла прямоугольника по вертикали в миллиметрах от верхнего левого угла листа шаблона.
  • Width - ширина прямоугольника с миллиметрах.
  • Height - высота прямоугольника с миллиметрах.
  • Fill - признак заливки прямоугольника (True/False). Если значение True то заливка производится объявленным заранее цветом (см. Объявление цвета). Если False - заливка не производится. Прямоугольник отрисовывается линиями с предварительно заданной толщиной. См. Линии
Пример 1. Создание красного прямоугольника:
1set page = CreatePage(Null)
2
3page.SetColor 255, 0, 0
4
5page.Rectangle 10, 15, 40, 20, True
6
page.DrawGrid
Результат:
Прямоугольник
Пример 2. Пустой прямоугольник без задания цвета:
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.Rectangle 12, 17, 42, 25, false
6
page.DrawGrid

Результат:
Прямоугольник false

Также существует возможность изменения стиля отображения углов прямоугольника. Для этого нужно использовать свойство property LineJoin: TPDFLineJoin;

Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пример построения прямоугольников с различными типами соединения сторон:

01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 4
06
07page.LineJoin = 0
08
09page.Rectangle 10, 10, 20, 10, false
10
11page.LineJoin = 1
12
13page.Rectangle 40, 10, 20, 10, false
14
15page.LineJoin = 2
16
page.Rectangle 70, 10, 20, 10, false

Результат:
3 прямоугольника

3. Вставка готовых изображений

Для вставки на создаваемую страницу готового изображения используется процедура procedure Image(const FileName: WideString; X: Double; Y: Double; Width: Double; Height: Double)

Параметры:

  • const FileName - имя файла изображения и путь к нему на жестком диске. Задается в кавычках.
  • X - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по горизонтали в миллиметрах
  • Y - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по вертикали в миллиметрах
  • Width - ширина изображения в миллиметрах
  • Height - высота изображения в миллиметрах.
1set page = CreatePage(Null)
2page.drawgrid
page.Image "c:\mill.bmp", 10,10, 30, 30

Результат:
Картинка

Вне зависимости от размера исходного изображения, при вставке изображения на создаваемую страницу оно будет растянуто по размерам, прописанным в процедуре.

4. Векторная графика

Язык PostScript, с помощью которого создаются векторные изображения для PDF-документа, поддерживает создание типичных примитивных объектов, таких как:

  • Прямые и ломанные линии
  • Многоугольники
  • Окружности и эллипсы
  • Кривые Безье
  • Текст

При создании векторного изображения на странице PDF-документа в приложениях Платформы, команды построения примитивных объектов PostScript передаются на исполнение при помощи процедуры Perform. Подробнее об операторах и командах PostScript для создания PDF-документов можно узнать на сайте Adobe


Мельница данных ((раздел целиком))

Мельница данных- Ключи командной строки утилиты обслуживания БД (раздел целиком) (22.10.2024) (одним файлом)
Ключи командной строки утилиты обслуживания БД

Утилита обслуживания БД - консольное приложение. При запуске приложения оно сообщает о поддерживаемых режимах и ключах командной строки. Ключи указываются через пробел. Ключ должен начинаться символом "/". Для ключей, содержащих значения параметров, между ключем и значением должен быть пробел. Имена файлов и папок, содержащие пробелы, в командной строке должны быть заключены в кавычки.

При работе с утилитой общее правило состоит в том, что первым параметром передается строка соединения с БД, вторым параметром необязательная команда. Остальные параметры и ключи указываются в зависимости от выбранной команды.

Если работа утилиты завершилась успешно, то она возвращает код завершения 0. Если в процессе работы утилиты произошли ошибки, то код завершения будет равен 1. Если работа утилиты завершилась успешно, но были выданы предупреждения, то она возвращает код завершения 2.

Поддерживаемые команды:

<Команда не указана> | Инициализация/cинхронизация БД
ping | Проверка доступности БД
pump | Перекачка данных
check | Проверка целостности БД
build | Перестройка всех метаданных
load | Загрузка доступных файлов
export | Экспорт реплики данных
import | Импорт реплики данных

Далее будут рассмотрены подробности работы каждого из режимов.

1. Перекачка данных

Для осуществления перекачки данных необходимо:

  1. Иметь права владельца схемы в БД - приемнике.
  2. Иметь права владельца схемы в БД - источнике.
  3. Если не задан ключ /M, то БД - приемник должен быть пустой схемой, не содержащей никаких объектов.
Эти условия контролируются утилитой dbsetup.exe.

Перекачка данных осуществляется в любом направлении. Ниже представлены варианты сочетания источников и приемников данных. В случае, если попытка использовать тот или иной оптимизационный механизм оказалась неудачной, производится стандартная перекачка.

Приемник | Источник
 | БД MSSQL | БД Firebird | БД Oracle | БД PostgreSQL | Папка, файл, zip-архив
БД MSSQL | Стандартная перекачка данных
БД Firebird | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("external table"). | Предпринимается попытка использовать механизм "внешний источник данных" ("external data source"). | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("external table").
БД Oracle | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("table organization external"). |  | Предпринимается попытка использовать механизм "связи БД" ("database link"). | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("table organization external").
БД PostgreSQL | Предпринимается попытка использовать механизм загрузки данных из внешнего текстового файла оператором COPY. |  |  | Предпринимается попытка использовать расширение "dblink". | Предпринимается попытка использовать механизм загрузки данных из внешнего текстового файла оператором COPY.
Папка, файл, zip-архив | Стандартная перекачка данных | Предпринимается попытка собрать на сервере blob, содержащий целевой xml-документ. |  |  | Не имеет смысла. Просто скопируйте файлы.

Используемые параметры и ключи командной строки:

Для перекачки данных используюется команда pump. В строке соединения указывается БД-приемник, кроме случая перекачки данных из БД в папку, файл или zip-архив. Для всех случаев кроме случая перекачки данных из БД в папку, файл или zip-архив командная строка содержит кляузу pump from. Для случая перекачки данных из БД в папку, файл или zip-архив командная строка содержит кляузу pump to.
Перекача данных из БД Oracle в БД Firebird:
dbsetup.exe fb#sysdba/masterkey@host:database pump from ora#dataowner/password@host/sid.dataowner
Перекача данных из zip-архива в БД Firebird:
dbsetup.exe fb#sysdba/masterkey@host:database pump from c:\dbbackup.zip
Перекача данных из БД Firebird в zip-архив:
dbsetup.exe fb#sysdba/masterkey@host:database pump to c:\dbbackup.zip

Ключ | Назначение
/J <Целое число> | Определяет число потоков, осуществляющих перекачку данных. По умолчанию соответствует количеству ядер процессора.
/H <Целое число> | Определяет базовое количество записей в блоке перекачки. По умолчанию - 1 млн. записей. Для таблиц, содержащих большие объекты (blob и/или clob) размер блока перекачки определяется как базовый размер блока, деленный на 100. Если источником является папка, файл или zip-архив - ключ игнорируется.
/M | Пропустить этап создания таблиц и последовательностей в БД (таблицы и последовательности должны быть созданы заранее).
/G | Пропустить этап заливки данных, произвести только создание таблиц и последовательностей в БД.
/K <Список таблиц> | Не перекачивать данные указанных таблиц. Список таблиц разделяется символом ";" (точка с запятой).
/NODBLINK | Принудительно отключает механизмы связи между БД на сервере.
/NOCSV | Принудительно отключает механизмы загрузки данных из внешнего файла.
/NOXML | Принудительно отключает механизмы cборки xml-документа на сервере.

Информация о значениях типа "внешние данные" будет перенесена из источника в приемник, сами внешние данные при этом перенесены в хранилище не будут.

При перекачке данных учитыватся табличное пространство ("группа файлов") каждой таблицы в случае, если это понятие релевантно для источника и приемника. При использовании папки, файла или zip-архива имя табличного пространства каждой таблицы сохраняется в файле RTTI, и будет использовано, если окажется релевантным. Если в приемнике имеется возможность разместить таблицу в табличное пространство с тем же именем, которое указано в источнике, то это будет сделано.

При перекачке данных таже осуществляется перенос последовательностей. При этом переносится текущее значение каждой из последовательностей. Значение кеша последовательности переносится только в том случае, если это понятие релевантно для источника и для приемника. При использовании папки, файла или zip-архива значение кеша сохраняется в файле Sequences, и будет использовано, если окажется релевантным.

После завершения перекачки данных в схеме-приемнике остаются следующие объекты:

  • Таблицы данных.
  • Первичные ключи таблиц данных.
  • Последовательности.
  • Заголовки системных объектов платформы.

Этот набор минимально достаточен, чтобы с помощью синхронизации (загрузив метаданные из таблиц, с ключем /T) восстановить метаданные БД в соответствующей схеме, и работать с ней средствами платформы.

Особенности перекачки данных в папку, файл или zip-архив:

При использовании папки она рассматривается как хранилище файлов перекачки. При использовании файла он рассматривается как хранилище файлов перекачки в формате Microsoft Compound File. При использовании zip-архива он рассматривается как хранилище файлов перекачки. Хранилище файлов перекачки содержит следующие файлы:

  • FormatSettings - xml-файл с информацией о региональных настройках процесса, сформировавшего хранилище.
  • Sequences - xml-файл с информацией о текущих значениях последовательностей.
  • RTTI - xml-файл с информацией о таблицах и полях. Также содержит информацию о табличных пространствах.
  • <Имя Таблицы> с возможным числовым постфиксом в скобках - xml-файл с данными таблицы в стандартном xml-представлении.
  • #<Длина файла в 16-ричном представлении, 16 символов><CRC файла в 16-ричном представлении, 8 символов> - двоичный файл с содержимым blob/clob. Такие файлы формируются для объектов, чей размер превышает 1MB.

Остальные файлы в хранилище будут проигнорированы (если хранилище используется как источник) или удалены (если хранилище используется как приемник).

Если в качестве приемника используется zip-архив, то механизм перекачки данных будет использовать информацию об уже содержащихся в архиве файлах, и не будет повторно "пересжимать" уже имеющиеся файлы. Таким образом, можно удобно релизовать "инкрементальное резервное копирование", указывая в качестве приемника перекачки данных один и тот же zip-архив.

1.1. Стандартная перекачка данных

Стандартная процедура перекачки блока данных заключается в открытии однонаправленного курсора на основании запроса типа select... from "..." к таблице-источнику, подготовке запроса insert into "..."("ID",.....) values (:Param1, :Param2....) к приемнику, и многократному выполнению этого единожды подготовленного запроса по мере продвижения вперед по курсору-источнику. Все значения полей при этом проходят через клиентскую сторону, и заливка данных осуществляется по одной записи за одно выполнение запроса. Характерная скорость такой заливки - порядка 5000 записей в секунду.

Оператор INSERT в процессах перекачки данных всегда формируется с подсказкой /*+ APPEND */.

Описанные далее механизмы оптимизации не могут использоваться одновременно. Если какой-либо из них может быть использован в вашей ситуации - постарайтесь обеспечить условия, необходимые для их работы. Вы получите значительное ускорение перекачки.

1.2. Механизмы связи между БД на сервере

Будут формироваться и выполняться блоки вида
01execute block as
02  declare "ID" BIGINT;
03  declare "P0" SMALLINT;
04  .....
05begin
06  for execute statement 'select "ID", .... from "...."'
07    on external data source '....' as user '...' password '....'
08    into :"ID",:"P0",..... do
09      insert into "...."("ID",....)
10      values (:"ID",:"P0",.....);
11end

Механизм может быть использован, если пользователь-владелец схемы имеет право CREATE DATABASE LINK, и оператор create database link будет выполнен без ошибок. При этом будет создан link с именем "SYS$PUMP". После завершения процедуры перекачки данных link будет удален. Таким образом, можно в целях безопасности выдавать право CREATE DATABASE LINK владельцу схемы данных только на время перекачки данных. При этом генерируются и выполняются операторы вида
1INSERT /*+ APPEND */ INTO "..."("ID", ....)
2SELECT "ID", ....
3  FROM "..."@"SYS$PUMP"
4...

Механизм может быть использован, если в БД установлено стандартное расширение "dblink", и оператор select public.dblink_connect('user=... password=.......') будет выполнен без ошибок. При этом генерируются и выполняются операторы вида
01do $$
02declare
03  cnt int;
04begin
05  perform public.dblink_connect('user=... password=... ....');
06  perform public.dblink_open('SYS$....', 'select T."ID", ..... from "...." T');
07  loop
08    insert into "...." ("ID", .....)
09    select T."ID" from public.dblink_fetch('SYS$.....', 1000000)
10    as T("ID" bigint, .....);
11    get diagnostics cnt = row_count;
12    exit when cnt = 0;
13  end loop;
14end; $$

Механизм может быть принудительно заблокирован ключем /NODBLINK.

1.3. Загрузка данных из внешнего файла

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Временная папка процесса dbsetup.exe (переменная окружения %TMP%) доступна сервису Firebird как источник внешних данных (в конфигурации FireBird - параметр ExternalFileAccess).
  • Таблица не содержит полей типа BLOB.
  • Таблица не содержит обнуляемых полей, все поля таблицы обязательные.
  • Загружаемый блок содержит как минимум 1000 записей.
В этом случае во временной папке будет создан временный файл, содержащий загружаемые данные в требуемом Firebird формате, и выполнены операторы:
1create table "DML..." external '.....'
2  ("ID" BIGINT,
3  ....);
4insert into "..."("ID", ...)
5  select "ID", ....
6  from "DML....";
7drop table "DML....";
После чего временный файл будет удален.

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Владельцу данных доступна на чтение и запись хотя бы одна папка (directory). Этого можно достичь, например, такими операторами:
    1CREATE DIRECTORY dir_name AS 'D:\TEMP';
2GRANT READ,WRITE ON DIRECTORY dir_name TO user_name;
    При этом папка (на диске) должна быть доступна на запись процессу dbsetup.exe.
  • Оператор
    01create table "DML...."
02(
03 ....
04) ORGANIZATION EXTERNAL (
05  DEFAULT DIRECTORY ....
06  ACCESS PARAMETERS (
07    RECORDS DELIMITED BY NEWLINE
08    FIELDS TERMINATED BY '....'
09  )
10  LOCATION ('DML.....')
11)
    выполняется без ошибок. Созданная при этом таблица доступна для чтения.
  • Таблица не содержит полей типа BLOB.
  • Загружаемый блок содержит как минимум 1000 записей.
В этом случае в папке, которая доступна, будет создан временный файл, содержащий загружаемые данные в требуемом Oracle формате, и выполнены операторы:
1create table "DML....."
2(
3 ....
4) ORGANIZATION EXTERNAL (
5....);
6insert into "..."("ID", ...)
7  select "ID", ....
8  from "DML....";
9drop table "DML....";
После чего временный файл будет удален.

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Временная папка процесса dbsetup.exe (переменная окружения %TMP%) доступна сервису PostgreSQL как источник внешних данных.
В этом случае в папке, которая доступна, будет создан временный файл, содержащий загружаемые данные в требуемом Postgres формате. В случае, когда размер файла превысит 1GB, а также по исчерпании источника, будет выполнен оператор
  copy "..."(...) from %TEMP%\DML....CSV with (format csv, encoding UTF8)
После чего временный файл будет удален.

Механизм может быть принудительно заблокирован ключем /NOCSV.

1.4. Сборка xml-документа на сервере

Механизм создает большую нагрузку на сервер БД, но в то же время позволяет существенно ускорить перекачку данных.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующие условия:
  • Таблица не содержит полей типа BLOB.
  • Таблица не содержит строковых полей, которые могут содержать не-xml-compaint символы (определяется по свойствам соответствующего строкового домена.
В этом случае будут формироваться и выполняться запросы вида
1with T as (select T.* from "...." T order by T."ID")
2select cast(cast(
3  '<data handle="' || count(1) ||  '" eof="1">' || list('<row>' ||
4    '<ID type="int64">' || T."ID" || '</ID>' ||
5      case when T."..." is null then '<.../>' else '<... type="int">' || T."..." || '</...>' end ||
6      ......
7    || '</row>' , '') || '</data>' as blob sub_type 1 character set utf8) as blob sub_type 0), count(1)
8  from T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующие условия:
  • Используется Oracle версии не ниже 11.
  • Таблица не содержит полей типа BLOB.
В этом случае будут формироваться и выполняться запросы вида
1with T as (select T.* from "..." T )
2select "SYS$HELPER"."ClobToBlob"('<data handle="' || count(1) || '" eof="1">' ||
3  xmlagg(xmlelement("row", xmlelement("ID", xmlattributes('int64' as "type"), T."ID"),
4    case when "..." is null then xmltype('<..../>') else
5      xmlelement("....", xmlattributes('ascii' as "type"), "SYS$HELPER"."XMLEscape"(asciistr(T."...."), 0)) end,
6    ....
7 order by T."ID").getclobval() || '</data>'), count(1) from T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующее условие:
  • Таблица не содержит полей типа BLOB.
В этом случае будут формироваться и выполняться запросы вида
1select convert_to( '<data handle="' || count(1) ||  '" eof="1">' || string_agg(
2  '<row>' ||
3    '<ID type="int64">' || T."ID" || '</ID>' ||
4    case when T."...." is null then '<..../>' else '<.... type="int64">' || T."...." || '</....>' end ||
5    .....
6  '</row>', '' order by T."ID") || '</data>', 'UTF8'), count(1) from "..." T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Механизм может быть принудительно заблокирован ключем /NOXML.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IRaster (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IRaster

01type
02  IRaster = interface(IDispatch)
03    ['{4F27D016-03C2-4D48-ABF7-FD547E859F79}']
04    function Get_Width: Integer; safecall;
05    procedure Set_Width(Value: Integer); safecall;
06    function Get_Height: Integer; safecall;
07    procedure Set_Height(Value: Integer); safecall;
08    function Get_DefaultColor: Integer; safecall;
09    procedure Set_DefaultColor(Value: Integer); safecall;
10    procedure Load(Src: OleVariant); safecall;
11    procedure SaveBitmap(Dst: OleVariant); safecall;
12    procedure SavePNG(Dst: OleVariant); safecall;
13    procedure SaveJPG(Dst: OleVariant; Quality: Integer); safecall;
14    procedure FlipVertical; safecall;
15    procedure FlipHorizontal; safecall;
16    procedure Rotate; safecall;
17    procedure Resize(NewWidth: Integer; NewHeight: Integer; Center: WordBool); safecall;
18    procedure Stretch(NewWidth: Integer; NewHeight: Integer); safecall;
19    procedure StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
20      MaxSize: OleVariant); safecall;
21    procedure Overlay(Src: OleVariant; X: Integer; Y: Integer; Width: Integer;
22      Height: Integer); safecall;
23    property Width: Integer read Get_Width write Set_Width;
24    property Height: Integer read Get_Height write Set_Height;
25    property DefaultColor: Integer read Get_DefaultColor write Set_DefaultColor;
26  end;

1. Свойства

Свойства интерфейса IRaster:

Имя | Тип | Доступ | Назначение
DefaultColor | Integer | Чтение/Запись |
Height | Integer | Чтение/Запись |
Width | Integer | Чтение/Запись |

2. Метод FlipHorizontal

Метод интерфейса IRaster.

procedure IRaster.FlipHorizontal;

Метод не имеет параметров.

3. Метод FlipVertical

Метод интерфейса IRaster.

procedure IRaster.FlipVertical;

Метод не имеет параметров.

4. Метод Load

Метод интерфейса IRaster.

procedure IRaster.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

5. Метод Overlay

Метод интерфейса IRaster.

1procedure IRaster.Overlay(Src: OleVariant; X: Integer; Y: Integer;
2  Width: Integer; Height: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |
X | Integer | Да |
Y | Integer | Да |
Width | Integer | Да |
Height | Integer | Да |

6. Метод Resize

Метод интерфейса IRaster.

1procedure IRaster.Resize(NewWidth: Integer; NewHeight: Integer;
2  Center: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
NewWidth | Integer | Да |
NewHeight | Integer | Да |
Center | WordBool | Да |

7. Метод Rotate

Метод интерфейса IRaster.

procedure IRaster.Rotate;

Метод не имеет параметров.

8. Метод SaveBitmap

Метод интерфейса IRaster.

procedure IRaster.SaveBitmap(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |

9. Метод SaveJPG

Метод интерфейса IRaster.

procedure IRaster.SaveJPG(Dst: OleVariant; Quality: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |
Quality | Integer | Да |

10. Метод SavePNG

Метод интерфейса IRaster.

procedure IRaster.SavePNG(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |

11. Метод Stretch

Метод интерфейса IRaster.

procedure IRaster.Stretch(NewWidth: Integer; NewHeight: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
NewWidth | Integer | Да |
NewHeight | Integer | Да |

12. Метод StretchToSize

Метод интерфейса IRaster.

1procedure IRaster.StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
2  MaxSize: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
MaxWidth | OleVariant | Да |
MaxHeight | OleVariant | Да |
MaxSize | OleVariant | Да |


Мельница данных ((раздел целиком))

Мельница данных- Работа с формами и таблицами данных (раздел целиком) (22.10.2024) (одним файлом)
Работа с формами и таблицами данных

Для отображения записей об учитываемых в системе объектах используются формы с таблицами данных. Каждая форма представляет собой отдельное окно с заголовком, на котором отображается ее наименование. Основную часть окна формы занимают таблицы данных. Переключаться между доступными формами можно либо при помощи щелчка мышью по иконке, соответствующей форме на Панели инструментов, либо при щелчке мышью на самом окне формы (если форма видна). В каждый момент времени активной является одна из форм (или ни одной). Окно формы можно "перетаскивать" (здесь и далее "перетащить" объект означает подвести к нему указатель мыши, нажать левую кнопку, удерживая кнопку переместить объект на новое место, после чего отпустить кнопку мыши) по экрану за заголовок, изменять его размеры, минимизировать, восстановить, раскрывать на весь экран или закрывать. Эти действия осуществляются стандартным для среды Windows образом. При закрытии формы соответствующая ей иконка на панели инструментов будет отображена неактивной. При щелчке мышью по такой иконке форма откроется, и иконка станет активной.

Таблицы данных в форме расположены на закладках с заголовками, соответствующими наименованиям таблиц данных. Например, на предыдущем рисунке активна форма "Продажи мороженого". В этой форме на первом уровне расположены таблицы данных "Регионы", "Сорта мороженого", "Сорта фруктового мороженого", "Представительства", "Все продажи". Активной в настоящее время является таблица данных "Представительства".

1. Подчиненные таблицы данных и взаимное расположение главной и подчиненных таблиц

Таблицы данных могут иметь подчиненные таблицы. Подчиненные таблицы по умолчанию отображаются в нижней части главной таблицы. Набор записей, отображаемых в подчиненной таблице, зависит от того, какие записи выбраны в главной таблице.

Например, на рисунке в главной таблице "Представительства" выбрано представительство ООО "Холод плюс". При этом в подчиненной таблице "Продажи представительства" отображаются только те продажи, которые осуществлены данным представительством.

Подчиненные таблицы могут располагаться двумя способами:

  • на закладках - в этом случае в нижней части главной таблицы отображаются закладки с наименованиями подчиненных таблиц; переключаться между подчиненными таблицами можно путем щелчка мышью по соответствующей закладке;
    Отображение подчиненных таблиц на закладках
  • в отдельных окнах - в этом случае каждая из подчиненных таблиц располагается в своем окне; окна имеют заголовки, соответствующие наименованиям таблиц; окна, в которых отображаются подчиненные таблицы, можно перетаскивать за заголовок в любое другое место экрана, минимизировать, восстанавливать, закрывать и т.д.
    Отображение подчиненных представлений в отдельных окнах

Изменять соотношение размера главной и подчиненных таблиц можно путем перетаскивания горизонтального разделителя мышью. Для этого необходимо подвести указатель мыши к границе раздела зон главной и подчиненных таблиц и когда курсор примет форму горизонтального разделителя ( Горизонтальный разделитель) перетащить разделитель выше или ниже. При отображении подчиненных таблиц в отдельных окнах можно изменять соотношение ширины подчиненных таблиц. Для этого нужно подвести указатель мыши к вертикальной границе таблиц и когда указатель примет форму вертикального разделителя ( Вертикальный разделитель), перетащить разделитель вправо или влево.

При отображении подчиненных таблиц на закладках занимаемая ими область также может быть минимизирована. Для этого необходимо подвести курсор к границе раздела зон главной и подчиненной таблиц и когда он примет форму горизонтального разделителя ( Горизонтальный разделитель) выполнить двойной щелчок мышью.

Минимизация зоны подчиненных таблиц

Восстановить отображение подчиненных таблиц можно либо путем нажатия кнопки "Восстановить" ( Кнопка восстановления размеров зоны подчиненных таблиц) в заголовке минимизированного окна, либо при помощи двойного щелчка мышью на этом заголовке.

2. Отображение учитываемых объектов в таблице данных

Таблица данных имеет строки и колонки. Строки таблицы (или записи) соответствуют учитываемым объектам. Колонки таблицы соответствуют свойствам объектов.

Макет таблицы данных

На рисунке представлен макет таблицы данных, в которой отображаются объекты, соответствующие сортам фруктового мороженого. Таблица данных имеет наименование "Сорта фруктового мороженого", которое отображается на соответствующей закладке (1). Таблица имеет пять строк (2), соответствующих пяти сортам фруктового мороженого. Выделенной в настоящее время является первая строка. Таблица имеет пять колонок, соответствующих свойствам учитываемых сортов мороженого. Каждая колонка имеет заголовок (4), отражающий отображаемое в этой колонке свойство. Активной в настоящее время является первая колонка. Активным элементом данных (3) является ячейка, расположенная в первой строке в первом столбце.

На рисунке активная строка и активный элемент данных выделяются оттенками синего цвета. Цвета, применяемые для выделения элементов данных, зависят от локальных настроек операционной системы Windows (стилей) на компьютере пользователя.

Под заголовком каждой колонки расположена строка фильтра (5). При помощи ввода в этой строке условия отбора или выбора значений из выпадающего списка можно осуществлять фильтрацию отображаемых в таблице данных.

Если отображаемые данные не помещаются в окно по ширине, то активной становится горизонтальная полоса прокрутки (7). С ее помощью можно пролистывать колонки таблицы вправо и влево. Если данные не помещаются в окно по вертикали, то активной становится вертикальная полоса прокрутки (8). С ее помощью можно пролистывать записи об объектах вверх и вниз. При щелчке правой кнопкой мыши на полосе прокрутки (если она активна) доступны действия по быстрой прокрутке содержимого таблицы.

При щелчке правой кнопкой мыши в области таблицы данных отображается контекстное меню. Контекстное меню отображает список действий, доступных над объектами, отображаемыми в таблице данных. Вызываемые действия выполняются для тех объектов, которые являются выделенными в таблице данных. Если ни одного объекта не выделено, некоторые действия контекстного меню могут быть недоступны. Набор действий, отображаемых в контекстном меню различен в разных таблицах данных.

  1. Заголовок закладки с именем таблицы данных.
  2. Выделенный объект.
  3. Выделенный элемент данных.
  4. Заголовок колонки.
  5. Строка фильтра.
  6. Флажок для выбора объектов.
  7. Горизонтальная полоса прокрутки.
  8. Вертикальная полоса прокрутки

2.1. Иерархические таблицы данных

Если отображаемые в таблице данные имеют иерархическую структуру (т.е. присутствует "вхождение" одних объектов в другие), то в таблице данных объекты могут отображаться в виде "дерева".

Иерархическая таблица данных

На рисунке представлена таблица данных, отображающая периоды обучения студентов. Эти данные имеют иерархическую структуру, которая отражает вхождение учебных модулей в состав семестров, а семестров в состав учебных годов. В первой колонке иерархической таблицы данных слева от элементов данных, имеющих подчиненные элементы, отображаются значки Свернутый узел дерева или Развернутый узел дерева. При щелчке мышью по значку Свернутый узел дерева отображаются подчиненные объекты. Значок Свернутый узел дерева при этом превращается в значок Развернутый узел дерева. При щелчке мышью по значку Развернутый узел дерева подчиненные объекты скрываются и значок Развернутый узел дерева превращается в Свернутый узел дерева. На рисунке для объектов "Учебный год 2005-2006" и его подчиненных объектов "I семестр" и "II семестр" подчиненные объекты отображены. Щелчком по значку Развернутый узел дерева подчиненные объекты можно скрыть. Для объектов "I семестр" и "II семестр" учебного года 2006-2007 подчиненные объекты скрыты. Щелчком по значку Свернутый узел дерева их можно отобразить. При горизонтальном пролистывании таблицы данных вправо или влево "дерево" объектов всегда отображается слева от самого левого столбца.

В иерархических таблицах данных доступны дополнительные действия по управлению отображением и выбору объектов, которые описаны в разделе 4.7.1.

3. Выбор объектов в таблице данных

Выбор одного объекта в таблице данных может осуществляться либо щелчком мышью в соответствующей строке, либо при помощи стрелок ("вверх" и "вниз") на клавиатуре. Выбор активной колонки и активного элемента данных также может производиться щелчком мышью или при помощи стрелок ("вправо" и "влево") на клавиатуре.

В таблице данных можно также осуществлять произвольный выбор нескольких объектов путем установки флажка в строке, отображающей объект. Установка или снятие флажка производится при помощи щелчка мышью.

При выборе нескольких объектов в главной таблице в подчиненной таблице будут отображены записи, соответствующие подчиненным объектам, отобранным для ВСЕХ объектов, выбранных в главной таблице.

Произвольный выбор объектов

На рисунке представлена таблица данных "Учащиеся", имеющая ряд подчиненных таблиц. На рисунке открыта подчиненная таблица "Родственники и контактные лица". В таблице данных "Учащиеся" путем установки флажка произвольным образом выбраны три учащихся с фамилиями Матвеева, Зимогляд и Анчевский. При этом в подчиненной таблице "Родственники и контактные лица" отображены родители всех троих учащихся.

При выборе объектов путем простановки флажков необходимо осуществлять щелчок мышью именно на флажке. Если выполнить щелчок мышью в любой другом месте записи, ранее установленные флажки будут сняты, и выбранной станет одна эта запись.

Для быстроты и удобства выбора объектов доступны дополнительные возможности:

  • для выделения нескольких объектов подряд можно щелкнуть мышью в любом месте записи, соответствующей первому объекту, а затем, удерживая клавишу Shift, щелкнуть по записи, соответствующей последнему объекту; все объекты между первым и последним, включая их, будут выделены;
  • осуществлять произвольный выбор объектов можно щелчком мышью в любом месте записи, удерживая клавишу Ctrl ;
  • можно воспользоваться действиями, доступными в подменю "Выбранные" на панели инструментов или в контекстном меню:
    • Выбрать все - все отображаемые в настоящий момент в таблице данных объекты будут выбраны;
    • Показать только выбранные - в таблице данных будут отображены только те объекты, которые помечены как выбранные; остальные объекты будут скрыты;
    • Показать все - если ранее было установлен отбор только выбранных объектов, этот отбор будет снят, и снова будут отображены все доступные в таблице объекты.

При выборе объектов изменяется информация, отображаемая Инспектором объектов. Если выбран один объект, то Инспектор объектов отображает и позволяет редактировать все доступные пользователю свойства этого объекта. Если выбрано несколько объектов, отображение и редактирование свойств Инспектором объектов происходит по правилам, описанным в разделе 5 "Работа с Инспектором объектов".

При выполнении действий над объектами выбранное действие будет выполнено для всех выбранных объектов. Если не выбрано ни одного объекта, некоторые действия могут быть недоступны.

При одновременном выборе большого числа объектов быстродействие системы может снижаться. При необходимости работы с большой выборкой объектов лучше воспользоваться возможностью фильтрации данных.

4. Изменение порядка отображения колонок

Порядок отображения колонок может быть изменен путем "перетаскивания" их заголовков. Для того чтобы переместить колонку правее или левее, подведите указатель мыши к заголовку колонки, нажмите левую кнопку мыши и, не отпуская ее, перетащите заголовок колонки вправо или влево. После того, как Вы отпустите кнопку мыши, порядок отображения колонок изменится.

Изменение порядка отображения колонок

На рисунке изображено перетаскивание заголовка колонки "Вид упаковки" в таблице данных "Сорта мороженого". После того, как кнопка мыши будет отпущена, колонка "Вид упаковки" станет третьей слева, а колонка "Число продаж" второй.

5. Скрытие и отображение колонок

Любая из видимых в таблице данных колонок может быть скрыта. Для этого необходимо выделить любой элемент данных в колонке, щелчком правой кнопкой мыши открыть контекстное меню и в нем в подменю "колонка" выбрать действие "Скрыть эту колонку".

На рисунке показано как скрыть колонку "Вид упаковки" в таблице данных "Сорта мороженого". Описанным выше образом можно скрыть любое число колонок таблицы данных кроме последней. Если в таблице данных осталась одна колонка, то действие "Скрыть эту колонку" будет недоступно. Для отображения скрытых ранее колонок таблицы данных необходимо воспользоваться действием "Показать скрытые колонки" в подменю "колонка" контекстного меню. (На рис. 12. действие располагается ниже действия "Скрыть эту колонку"). Если ни одной колонки таблицы данных не скрыто, то действие "Показать скрытые колонки" будет недоступно. Действия, расположенные в подменю "колонка" доступны также на панели инструментов.

6. Сортировка данных в таблицах

Отображаемые в таблице данные могут быть отсортированы по возрастанию или по убыванию значений свойств, отображаемых в одной или нескольких колонках. Для сортировки данных по одной колонке необходимо выполнить щелчок мышью не ее заголовке. Данные будут отсортированы по возрастанию значения в этой колонке. Если щелкнуть мышью по заголовку колонки еще раз, то данные будут отсортированы по убыванию значения в этой колонке. В заголовке конке появится стрелочка, отображающая порядок сортировки (направленная вверх в случае сортировки по возрастанию и вниз в случае сортировки по убыванию). Если выполнить щелчок мышью по заголовку другой колонки, то данные будут отсортированы по значению в новой колонке.

Сортировка данных по одной колонке

На рисунке данные в таблице данных "Учащиеся" отсортированы по значению в колонке "Фамилия" по возрастанию. В заголовке колонки "Фамилия" отображается направленная вверх стрелочка. Для сортировки данных по значениям в нескольких колонках необходимо выполнить щелчок мышью на заголовке первой колонки, затем, удерживая клавишу Ctrl, выполнить щелчок по заголовку второй колонки и т.д. При этом в заголовках колонок будут отображаться стрелочки, соответствующие направлению сортировки и цифры, соответствующие порядку колонок в сортировке.

Сортировка данных по нескольким колонкам

На рисунке представлен пример сортировки данных таблицы данных "Учащиеся" по региону (по возрастанию), затем по полу (по убыванию) и затем по фамилии (по возрастанию). В заголовках колонок отображены соответствующие стрелочки с цифрами 1, 2 и 3.

В иерархических таблицах данные сортируются в пределах каждого уровня иерархии.

Сортировка данных в иерархической таблице

На рисунке данные в иерархической таблице данных "Направления и специальности" отсортированы по колонке "Наименование" по возрастанию.

7. Группировка данных в таблицах

Данные в таблице данных могут быть сгруппированы по значениям свойств, отображаемым в одной или в нескольких колонках.

Для осуществления группировки по значению в одной из колонок необходимо выделить любой элемент данных в этой колонке. Затем щелчком правой кнопки мыши открыть контекстное меню и в нем в подменю "колонка" выбрать действие "Группировать по этой колонке".

Осуществление группировки данных

На рисунке показано, как при помощи действия в контекстном меню осуществляется группировка данных в таблице данных "Все продажи" по значению в колонке "Представительство".

При отображении данных в сгруппированном виде для каждой группы будет отображен заголовок на более темном фоне. В заголовке группы будут отображены наименование и значение свойства, по которому осуществлена группировка, а слева от наименования будет расположен значок Развернутый узел дерева или Свернутый узел дерева. При нажатии на значок Развернутый узел дерева можно скрывать объекты группы (для группы будет отображен только ее заголовок). Значок Развернутый узел дерева при этом изменится на Свернутый узел дерева. При нажатии на значок Свернутый узел дерева объекты, входящие в группу, будут снова отображены.

Отображение данных в сгруппированном виде

На рисунке данные в таблице данных "Все продажи" сгруппированы по значению в колонке "Представительство". Группы объектов, соответствующие представительствам ЗАО "Айс девелопмент", ЗАО "Фрост интернешнл" и ООО "Заморозь соседа", раскрыты. Группы, соответствующие ОАО "Красный нос" и ООО "Дед мороз и лето", свернуты.

Данные могут группироваться и по нескольким колонкам. Для этого необходимо повторить описанные выше действия для всех колонок, которые должны быть включены в группировку.

Группировка данных по нескольким колонкам

На рисунке представлен пример группировки данных, отображаемых в таблице данных "Все продажи" по колонкам "Регион" и "Сорт мороженого".

Для снятия группировки и отображения данных в стандартном виде необходимо воспользоваться действием "Очистить группировку", которое также доступно в контекстном меню в подменю "колонка" (на рисунке расположено в выпадающем меню ниже действия "Группировать по этой колонке").

Действия, расположенные в подменю "колонка", доступны также на панели инструментов.

8. Фильтрация данных в таблицах

Фильтрация данных (отображение только тех данных, которые удовлетворяют некоторому условию) осуществляется по значениям, отображаемым в колонках, при помощи строки фильтра. Строка фильтра расположена ниже заголовка колонки. Фильтрация данных может осуществляться двумя способами:

  • путем выбора значения из выпадающего списка, доступного при нажатии кнопки Кнопка выпадающего списка в строке фильтра
  • путем записи условия фильтрации в строке фильтра

При нажатии кнопки Кнопка выпадающего списка в строке фильтра отображается выпадающий список значений, которые могут быть выбраны. Перечень отображаемых значений зависит от типа данных, отображаемых в колонке. В первой строке списка расположен пункт "(Все)". При выборе этого пункта фильтрация данных по этой колонке не осуществляется. При выборе одного из доступных значений в таблице данных будут отображены только те объекты, для которых значение свойства, отображаемого в данной колонке, равно выбранному. После осуществления фильтрации в строке фильтра будет отображено выбранное значение. Выбор значений можно осуществить в нескольких колонках. В этом случае условия отбора по каждой колонке будут объединены логическим "И".

Фильтрация данных путем выбора значения в строке фильтра

На рисунке показано, как осуществить фильтрацию данных по значению "эскимо" в колонке "Вид упаковки". После выполнения фильтрации эта таблица данных будет выглядеть следующим образом:

Отображение данных в отфильтрованном виде

В таблице данных на рисунке отображены записи только о тех сортах мороженого, которые продаются в виде эскимо. Значение "эскимо" отображено в строке фильтра в колонке "Вид упаковки".

Для фильтрации данных по более сложному условию можно воспользоваться вторым способом - записью условия фильтрации в строке фильтра. Условие фильтрации записывается по следующим правилам:

  1. Строка разделяется на части посредством системного разделителя (системный разделитель устанавливается в настройках операционной системы Windows). Обычно - точка с запятой, ";"
  2. Каждая часть строки интерпретируется самостоятельно, и эти части объединяются логическим "ИЛИ"
  3. При интерпретации каждой части проверяются следующие условия:
    Часть строки | Правило отбора объектов
    * Будут отобраны только те объекты, у которых значение в колонке не является пустым (установлено).
    !* Будут отобраны только те объекты, у которых значение в колонке является пустым (не установлено).
    начинается с символов '<=', '<', '>=', '>' | Будут отобраны только те объекты, у которых значение в колонке удовлетворяет условию.
    включает в себя символы '*' и/или '?' | Будут отобраны только те объекты, у которых значение в колонке удовлетворяет шаблону, в котором знак '?' соответствует одному любому символу, а знак '*' - любому количеству любых символов.
    начинается с символа '!' | Будут отобраны только те объекты, у которых значение в колонке не удовлетворяет условию, переданному оставшейся частью строки (знак '!' означает отрицание).
    представляет собой строку в апострофах (одиночных кавычках) | Содержание строки не анализируется по приведенным выше правилам. Будут отобраны только те объекты, у которых значение данного свойства соответствует строке, заключенной в апострофы.
    любая другая строка | Будут отобраны только те объекты, у которых значение данного свойства соответствует введенной строке (строки чувствительны к регистру).
  4. Условия, указанные в разных колонках, объединяются логическим "И"

После ввода в строке фильтр требуемого условия необходимо нажать клавишу Enter.

Фильтрация данных по сложному условию

В таблице данных "Все продажи" на рисунке отобраны только те записи, для которых верно следующее: Продажи осуществлены в регионе "Москва" или "Тверская область"; при этом наименование проданного сорта мороженого начинается с "Б"; при этом число продаж данного сорта больше 100.

Сделать заключение о том, что отображаемые в таблице данные отфильтрованы, можно по наличию в строке фильтра записи отличной от "(Все)". Снять фильтрацию данных можно одним из двух способов:

  • выбрать в строке фильтра из выпадающего списка пункт "(Все)"
  • удалить все символы, записанные в строке фильтра и нажать клавишу Enter

9. Отображение итоговых значений (агрегатов) по колонкам

По любой из колонок таблицы данных может быть рассчитано и отображено итоговое значение (агрегат). В зависимости от типа отображаемого в колонке свойства могут быть вычислены следующие агрегаты:

  • количество объектов (для свойств любых типов)
  • сумма значений (для числовых значений)
  • наименьшее (минимальное) значение (для строковых, числовых, логических значений, перечислений, значений типа даты, времени, даты со временем)
  • наибольшее (максимальное) значение (аналогично наименьшему значению)
  • среднее значение (для числовых значений)

Для отображения агрегата по одной из колонок необходимо выделить элемент данных в этой колонке, при помощи щелчка правой кнопкой мыши отобразить контекстное меню и в нем в подменю "колонка" выбрать действие, соответствующее нужному агрегату. После выполнения этого действия таблица данных будет выглядеть следующим образом:

Таблица данных с агрегатом по одной из колонок

На рисунке в нижней части таблицы данных отображена строка на светло-желтом фоне, в которой в колонке "Число продаж" показана сумма числа всех продаж, отображаемых в таблице.

Агрегат может быть вычислен и показан по любой из колонок.

Если данные в таблице отфильтрованы, то агрегат будет рассчитан только по тем записям, которые отобраны по условию фильтрации.

Если данные в таблице сгруппированы, то агрегаты будут рассчитаны как для всех отображаемых в таблице данных, так и отдельно для каждой группы.

Отображение агрегатов для сгруппированных данных

На рисунке данные о продажах сгруппированы по региону. Суммы числа продаж и среднее значение выручки отображены как для каждого региона (в строках на ярко-желтом фоне), так и для всех продаж в целом (в строке на светло-желтом фоне внизу таблицы).

Если свернуть группы, то можно просматривать только итоговые значения агрегатов для групп и для всех объектов в целом. Агрегаты при этом будут видны только в случае, если они отображаются правее надписи с именем и значением параметра группировки.

Режим отображения только агрегатов для групп

10. Редактирование данных в таблице

В таблице данных может редактироваться значение одного свойства одного объекта. Для того чтобы изменить отображаемое в таблице данных значение необходимо выделить требуемый элемент данных щелчком мышью или клавишами со стрелками на клавиатуре, после чего перевести элемент данных в режим редактирования. Это можно сделать одним из двух способов:

  • выполнить двойной щелчок мышью на элементе данных
  • при выделенном активном элементе данных нажать клавишу Enter на клавиатуре

После перевода элемента данных в режим редактирования отображаемый в нем текст будет выделен. Текст может быть отображен на белом или на сером фоне. Справа от текста могут появиться кнопки.

Перевод элемента данных в режим редактирования

На рисунке элемент данных в пятой сверху строке в первой колонке (текст "Белоснежка") переведен в режим редактирования.

Отображение элемента данных в режиме редактирования зависит от типа отображаемого свойства, доступности свойства для изменения и допустимости установленного значения.

  1. Редактирование значения "только для чтения"
    Если текст отображается на сером фоне, это означает, что свойство доступно только для чтения. У Вас нет возможности изменять его значение. Такое значение (или его часть) можно выделить и скопировать при помощи сочетания клавиш Ctrl+Ins или Ctrl+C и затем вставить в доступном для ввода значений месте в этом или в любом другом приложении.

  2. Редактирование недопустимого значения
    Если текст отображается на зеленом фоне, это означает, что установленное в данный момент значение недопустимо. Значение считается недопустимым, в одном из следующих случаев:
    • значение, обязательное для заполнения, не установлено
    • для свойства установлено значение, не удовлетворяющее его типу (например, на приведенном выше рисунке для числового свойства установлено значение, включающее буквы). Форматы, допустимые для значений различных типов, соответствуют локальным настройкам операционной системы Windows
    • длина текста для свойства строкового типа превышает максимально допустимую длину
    • введенное значение больше максимально допустимого или меньше минимально допустимого
    • для свойства, предполагающего выбор из списка или из справочника, установлено значение, не соответствующее ни одному из допустимых значений из списка или справочника
    Пока для свойства не будет установлено допустимое значение, применить выполненное изменение не удастся.

  3. Редактирование значения
    Если в режиме редактирования в ячейке отображается обычный текст на белом фоне, то значение свойства доступно для изменения. Редактирование значения производится при помощи клавиш клавиатуры. Выделенное значение или его часть может быть скопирована и вставлена стандартным образом. При редактировании текста обращайте внимание на тип свойства (строковое, числовое, дата и т.п.). Если введенное значение не будет удовлетворять типу, то оно будет считаться недопустимым и станет отображаться на зеленом фоне. Форматы, допустимые для значений различных типов, соответствуют локальным настройкам операционной системы Windows. После изменения значения необходимо нажать клавишу Enter для того, чтобы применить сделанные изменения.
  4. Если слева от текста в ячейке отображается флажок, это означает, что свойство может иметь одно из двух возможных значений. Одно из значений соответствует установленному флажку, другое - снятому. Если для свойства допустимо пустое значение, то в случае его установки флажок будет отображен на сером фоне и справа от него будет отображен текст "(Нет)".
    Редактирование логического значения "истина" Редактирование логического значения "ложь"
    Изменение значения такого свойства производится либо щелчком мыши по флажку, либо путем нажатия клавиши Пробел на клавиатуре.
  5. Редактирование значения в выпадающем списке
    Если справа от текста отображается кнопка с направленной вниз стрелкой, это означает, что значение свойства должно быть выбрано из списка допустимых значений. Изменять такое значение можно двумя способами:

    • Нажать на кнопку Кнопка выпадающего списка, расположенную справа от текста, в открывшемся выпадающем списке выбрать новое значение.

      Выбор значения из таблицы данных

      На рисунке показан выбор значения из выпадающего списка. Если Вы выбираете значение при помощи мыши, то достаточно выполнить щелчок мышью на нужном значении. Для выбора значения при помощи клавиатуры необходимо воспользоваться клавишами-стрелками "вверх" и "вниз", и когда нужное значение будет выделено, нажать клавишу Enter. Если для свойства допустимо пустое значение, то первым элементом выпадающего списка будет элемент "(Нет)". Если список включает больше восьми элементов, то в нем будет доступна вертикальная полоса прокрутки.

    • Ввести текст, соответствующий нужному элементу списка, с клавиатуры. В процессе ввода будут предлагаться допустимые для выбора значения. Если введенный с клавиатуры текст не будет удовлетворять ни одному из элементов списка, он будет отображен на зеленом фоне, и установить новое значение не удастся. При вводе значения с клавиатуры следите за регистром символов. После ввода нового значения необходимо нажать клавишу Enter.

  6. Редактирование значения с выбором
    Если справа от текста отображается кнопка с тремя точками, это означает, что данное свойство предполагает выбор значения из другой таблицы данных. Изменять такое значение можно двумя способами:

    • Нажать на кнопку Кнопка выбора, расположенную справа от текста; при этом откроется таблица данных, в которой нужно будет выбрать новое значение. В правом нижнем углу этой таблицы данных будут расположены кнопки OK и Отмена. Для выбора значения можно щелкнуть мышью по нужной записи или воспользоваться стрелками на клавиатуре. После выбора нужного значения нажмите кнопку OK. Если Вы не хотите менять ранее установленное значение, нажмите кнопку Отмена.

      Выбор значения из таблицы данных

      На рисунке представлена таблица данных, которая будет отображена для выбора значения свойства, представляющего собой сорт мороженого.

    • Ввести текст, соответствующий нужному значению, с клавиатуры. В процессе ввода будут предлагаться допустимые для выбора значения. Если введенный с клавиатуры текст не будет совпадать ни с одним из допустимых значений, он будет отображен на зеленом фоне, и установить новое значение не удастся. При вводе значения с клавиатуры следите за регистром символов. После ввода нового значения необходимо нажать клавишу Enter.

  7. Редактирование значения с выбором и выпадающим списком
    Если справа от текста отображаются две кнопки - кнопка со стрелкой и кнопка с тремя точками, то можно как выбирать значение из выпадающего списка, так и выбирать значение из таблицы данных (описано выше). В этом случае так же можно вводить текст, соответствующий допустимому значению с клавиатуры. После ввода значения с клавиатуры необходимо нажать клавишу Enter.

  8. Редактирование большого значения

    Если справа от текста отображены три кнопки, а сам текст представляет собой строку "(Данные)" или строку "(Нет)" это означает, что данное свойство представляет собой большой объект. Большой объект может быть текстом, файлом, содержащим изображение, xml-документ, исходный текст программных модулей или просто любые бинарные данные.

    При нажатии на кнопку Кнопка выбора отобразится окно, отображающее и позволяющее редактировать данные, представляющие собой большой объект.

    Окно для редактирования большого объекта

    На рисунке изображено окно, в котором может редактироваться исходный текст метода. После внесения изменений в текст окно редактирования нужно закрыть. Если в тексте действительно произошли изменения, то будет отображено предупреждение:

    Предупреждение окна редактирования большого объекта

    При нажатии кнопки Да окно редактирования будет закрыто, и изменения будут сохранены. При нажатии кнопки Нет окно редактирования будет закрыто, но произведенные изменения сохранены не будут. При нажатии кнопки Отмена окно редактирования останется открытым и работу с текстом можно будет продолжить.

    Копка Кнопка загрузки из файла позволяет загрузить содержимое большого объекта из файла. При нажатии этой кнопки отобразится стандартный диалог открытия файла Windows, в котором можно выбрать нужный файл, после чего нажать кнопку Открыть. При замене содержимого большого объекта новым будет отображено предупреждение:

    Предупреждение при загрузке из файла большого объекта

    Если нажать кнопку Да, то содержание большого объекта будет заменено новым, загруженным из указанного файла. Если нажать кнопку Нет, то содержание большого объекта не изменится

    Кнопка Кнопка сохранения в файл позволяет сохранить содержимое большого объекта в файл. При нажатии этой кнопки отобразится стандартный диалог сохранения файла Windows, в котором необходимо задать расположение и имя файла и нажать кнопку Сохранить. При сохранении файла необходимо явно указать его расширение. При сохранении файла никаких предупреждений не отображается.

    После изменения содержания большого объекта необходимо нажать клавишу Enter.

11. Выполнение действий над объектами

Все действия, которые могут быть произведены над объектами, могут быть выполнены одним из трех способов:

  • выбор действия в контекстном меню
  • вызов действия при помощи клавиш клавиатуры - "горячих клавиш" (доступно не для всех действий)
  • вызов действия при помощи иконки на панели инструментов (доступно не для всех действий)

При помощи действий производится добавление, удаление объектов, запуск различных процедур, выполняемых над данными, формирование отчетов.

Перечень всех действий, доступных в текущей таблице данных расположен в контекстном меню, которое отображается при нажатии правой кнопки мыши в зоне таблицы данных. Некоторые из действий выполняются для выбранных объектов (одного или нескольких), например, действие "Удалить". Для выполнения других действий выбор конкретного объекта не нужен, например, для действия "Добавить". Выбор действия в контекстном меню может производиться как при помощи мыши, так и при помощи стрелок на клавиатуре.

Если для действия установлены " горячие клавиши ", то из обозначения можно будет увидеть в правой части пункта контекстного меню. Действия могут вызываться как при нажатии одной клавиши, так и при помощи сочетания клавиш.

В некоторых пунктах контекстного меню может быть расположена стрелка Стрелка раскрытия контекстного меню. При выборе такого пункта никакого действия не выполняется, а открывается " подменю ", содержащее другие действия.

Выполнение действий над объектами при помощи контекстного меню

На рисунке изображено контекстное меню, отображающее все действия, доступные над объектом, соответствующим студенту Алехиной Елене Михайловне. Действиям "Добавить студента-специалиста", "Удалить" и "Обновить" соответствуют "горячие клавиши". Пункты меню "Перемещения", "Колонка", "Выбранные" имеют подменю. На рисунке открыто подменю пункта "Перемещения".

Для некоторых действий могут быть установлены изображения-иконки. В этом случае иконки отображаются на панели инструментов (подробнее в разделе 4.13. "Работа с панелью инструментов").

Если выполнение процедуры или отчета требует задания параметров, то при вызове действия отобразится форма задания параметров. Для выполнения действия необходимо заполнить поля формы и нажать кнопку OK (подробнее в разделе 6 "Работа с формой задания параметров").

Перед выполнением некоторых действий может быть отображено предупреждение. Например, перед удалением объекта может отображаться следующее окно:

Предупреждение при выполнении действия

Если в таком окне нажать кнопку Да, то действие будет выполнено. Если нажать кнопку Нет, то действие будет отменено.

12. Работа с панелью инструментов

На панели инструментов отображаются иконки, соответствующие доступным пользователю действиям и формам. Иконки могут иметь подписи, соответствующие наименованием действий или форм. Вызов действий или переключение между активными формами осуществляется при помощи щелчка мышью на одной из иконок. Если иконок много и они не помещаются на панели инструментов по ширине, то слева или справа отображаются кнопки прокрутки. Для прокрутки содержимого панели инструментов достаточно подвести указатель мыши к кнопке прокрутки.

На рисунке представлен пример панели инструментов. Иконки с подписями "Создать", "Удалить", "Колонка", "Выбранные", "Перенос в Excel" соответствуют доступным в текущей таблице данных действиям. Иконки с надписями "Системная форма" и "Продажи мороженого" соответствуют доступным пользователю формам. Справа от иконки "Продажи мороженого" расположена кнопка прокрутки. Подведя указатель мыши к этой кнопке, можно увидеть иконки, расположенные правее и не поместившиеся на панели инструментов.

Некоторые кнопки панели инструментов могут иметь выпадающие кнопки. Выпадающие кнопки соответствуют пунктам подменю контекстного меню. Справа от кнопок, имеющих выпадающие кнопки, расположена направленная вниз стрелочка. Если нажать мышью на эту стрелочку, то отобразится панель с выпадающими кнопками. На рисунке кнопки "Колонка" и "Выбранные" имеют выпадающие кнопки.

Панель выпадающих кнопок

Как и в контекстном меню, на панели инструментов некоторые кнопки могут быть недоступны. Доступность кнопки зависит от того, какие объекты в настоящий момент выделены, и от применимости действия к выделенным объектам.

13. Стандартные действия, доступные в любых таблицах данных

Ряд стандартных действий, доступных объектов любого типа, может быть вызван из любой таблицы данных. Разработчиком конкретной прикладной системы некоторые из перечисленных в данном разделе действий могут быть скрыты. Также перечень доступных стандартных действий зависит от прав доступа конкретного пользователя.

Взаимное расположение, наименования и доступность стандартных действий могут зависеть от реализации прикладной системы. В следующих разделах описаны все стандартные действия, реализованные средствами платформы.

13.1. Копирование и вставка объектов

Объекты, отображаемые в таблице данных, можно копировать и вставлять. Вставлять объекты можно как в ту же таблицу данных, из которой они были скопированы, так и в другую таблицу данных, отображающую объекты того же типа. Для этого необходимо выполнить следующие действия:

  1. Выбрать один или несколько объектов, которые Вы хотите скопировать (см. раздел 4.3. "Выбор объектов в таблице данных").
  2. Вызвать действие "Копировать" из контекстного меню или при помощи иконки на панели инструментов.
  3. Перейти в таблицу данных, в которую Вы хотите вставить скопированные объекты.
  4. Вызвать действие "Вставить" из контекстного меню или при помощи иконки на панели инструментов.

При копировании и вставке происходит создание копии объекта. Все свойства нового объекта, кроме свойства "Имя" (или замещающего его свойства), будут такими же, как у первичного объекта. Свойство имя будет равно строке, составленной из слова "Копия " и имени первичного объекта. После вставки объекта значение свойства "Имя" можно изменить.

Действия "Копировать" и "Вставить" имеют соответствующие иконки на панели инструментов:
Кнопка "копировать" Кнопка "вставить"

13.2. Подменю "Колонка" - работа с колонкой

Действия, доступные в подменю "Колонка" в контекстном меню или на панели инструментов могут быть применены к колонкам любой таблицы данных. Доступность тех или иных действий над колонкой зависит от типа данных, отображаемых в колонке, и от того, какие действия над колонкой уже совершены (например, нельзя вычислить сумму значений строкового типа, или нельзя очистить группировку, если данные не сгруппированы).

Иконка "Колонка" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с колонкой

Действия, доступные в подменю "Колонка", описаны в разделах 4.6. "Скрытие и отображение колонок", 4.8. "Группировка данных в таблицах", 4.10. "Отображение итоговых значений (агрегатов) по колонкам".

13.3. Подменю "Выбранные" - работа с выбранными объектами

Действия, доступные в подменю "Выбранные" позволяют быстро отбирать и снимать отбор с объектов, а также устанавливать режим отображения в таблице данных только тех объектов, которые помечены как выбранные.

Иконка "Выбранные" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с выбранными объектами

Назначение этих действий описано в разделе 4.3. "Выбор объектов в таблице данных".

13.4. Перенос в Excel

Данные, отображаемые в любой из таблиц данных, могут быть перенесены в MS Excel. При этом в MS Excel будут сохранены все настройки отображения данных (сортировка по одной или нескольким колонкам, группировка, отображение итоговых значений). Действие "Перенос в Excel" может быть вызвано из контекстного меню или при помощи иконки на панели инструментов. С данными, перенесенными в MS Excel, далее могут производиться любые манипуляции средствами этого приложения.

Если в таблице много записей, то перенос данных в Excel может занять некоторое время. Если это время превышает 10 сек., то отобразится окно, сообщающая, что система находится в работе. В этом окне будет отображен индикатор процесса переноса данных:
Индикатор прогресса переноса данных в Excel

Действие "Перенос в Excel" имеет соответствующую иконку на панели инструментов:
Кнопка переноса в Excel

13.5. Экспорт данных

Отображаемые в таблицах данных объекты могут быть экспортированы в виде xml-документа. Для того, чтобы осуществить экспорт объектов, необходимо выполнить следующее:

  1. Выбрать объекты, подлежащие экспорту (см. раздел 4.3. "Выбор объектов в таблице данных").
  2. Вызвать действие "Экспортировать" из контекстного меню или при помощи иконки на панели инструментов.
  3. В открывшемся окне сохранения файла указать местоположение и имя файла. Дать файлу расширение .xml.

13.6. Обновление данных таблицы

После выполнения действий над различными объектами, хранящимися в системе, их новое состояние может сразу не отобразиться в таблице данных. Для того чтобы получить из базы данных последние актуальные данные необходимо воспользоваться действием "Обновить", которое доступно в контекстном меню, при помощи иконки на панели инструментов, а также может быть доступно при нажатии клавиши F5.

Действие "Обновить" имеет соответствующую иконку на панели инструментов:
Кнопка обновления набора данных

13.7. Доступ к настройкам системы

При наличии соответствующих прав доступа Вы можете просматривать и изменять настройки системы. Доступ к меню настроек осуществляется при помощи действия "Настройки", которое может быть вызвано из контекстного меню или при помощи иконки на панели инструментов. При вызове этого действия отобразится форма задания настроек. Эта форма аналогична форме задания параметров (см. раздел 6 "Работа с формой задания параметров"). Если Вы имеете права администратора системы, то форма задания настроек, кроме кнопок OK и Отмена, будет иметь кнопку "По умолчанию". При нажатии этой кнопки значения, установленные в полях формы станут значениями настроек по умолчанию.

Форма задания настроек системы

Если в системе нет доступных для текущего пользователя настроек, то при вызове действия "Настройки" отобразится окно:
Сообщение об отсутствии доступных настроек

Действие "Настройки" имеет соответствующую иконку на панели инструментов:
Кнопка формы настроек

13.8. Дополнительные действия, доступные в иерархических таблицах данных

В иерархических таблицах данных дополнительно доступны действия, позволяющие управлять раскрытием и свертыванием элементов иерархии. Эти действия расположены в подменю "Дерево". Иконка "Дерево" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с иерархией

При помощи этих действий можно управлять отображением дерева иерархически организованных объектов следующим образом:

  • Развернуть все - все элементы дерева будут раскрыты.
  • Свернуть все - все дочерние элементы будут свернуты. Отображенными останутся только элементы первого уровня (не имеющие родительских элементов).
  • Развернуть от выбранного - узел дерева, соответствующий выбранному объекту и все его дочерние узлы будут раскрыты.
  • Свернуть к выбранному - узел дерева, соответствующий выбранному объекту у все его дочерние узлы будут свернуты.
  • Свернуть к этому уровню - все узлы дерева, лежащие на том же уровне, что и выбранный объект или на более низких уровнях будут свернуты.
  • Выделить дочерние - все объекты, дочерние по отношению к выбранному, будут выделены.


Мельница данных ((раздел целиком))

Мельница данных- Класс TBanGroupItem (Элементы группы запретов) (раздел целиком) (22.10.2024) (одним файлом)
Класс TBanGroupItem (Элементы группы запретов)

Диаграмма Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

1. Свойства

Свойства класса TBanGroupItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TBanGroup | Да | Видимо пользователю | Только для чтения | Мастер
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения | Доступен
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись

2. Конструктор Create (Конструктор элемента группы запретов)

Конструктор класса TBanGroupItem.

1constructor TBanGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TBanGroupItem.


Мельница данных ((раздел целиком))

Мельница данных- Класс TFolderNameDomain (Имена папок файловой системы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TFolderNameDomain (Имена папок файловой системы)

Диаграмма Класс TStringDomain (Строковые)Класс TDomain (Домены)Класс TObject (Объекты)

1. Свойства

Свойства класса TFolderNameDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
Length | Integer | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TStringDomain
AllowLeadingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись
AllowTrailingSpaces | Boolean | Да | Видимо пользователю | Чтение/Запись
AllowSpaceDuplication | Boolean | Да | Видимо пользователю | Чтение/Запись
CharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись
FirstCharacterSet | string[2000] | Нет | Видимо пользователю | Чтение/Запись
CaseMode | Boolean | Нет | Видимо пользователю | Чтение/Запись
Mask | string[2000] | Нет | Видимо пользователю | Чтение/Запись
CaseInsensitiveSearch | Boolean | Да | Видимо пользователю | Чтение/Запись
FolderMustExist | Boolean | Да | Видимо пользователю | Чтение/Запись | Папка должна существовать

2. Конструктор Create (Конструктор имени папки)

Конструктор класса TFolderNameDomain.

1constructor TFolderNameDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; Length: Integer;
4  AllowLeadingSpaces: Boolean; AllowTrailingSpaces: Boolean;
5  AllowSpaceDuplication: Boolean; CharacterSet: string[2000];
6  FirstCharacterSet: string[2000]; CaseMode: Boolean; Mask: string[2000];
7  CaseInsensitiveSearch: Boolean; FolderMustExist: Boolean): TObject;

Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
Length | Integer | Да | Унаследовано от TStringDomain.Create
AllowLeadingSpaces | Boolean | Да
AllowTrailingSpaces | Boolean | Да
AllowSpaceDuplication | Boolean | Да
CharacterSet | string[2000] | Нет
FirstCharacterSet | string[2000] | Нет
CaseMode | Boolean | Нет
Mask | string[2000] | Нет
CaseInsensitiveSearch | Boolean | Да
FolderMustExist | Boolean | Да | Папка должна существовать

Замечания:

Создает новый объект класса TFolderNameDomain.

3. Метод Change (Изменение объекта)

Метод экземпляра класса TFolderNameDomain.

procedure TFolderNameDomain.Change(Action: TChangeAction);

Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Унаследовано от TObject.Change

4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFolderNameDomain.

function TFolderNameDomain.GetSummary: string[2000];

Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IPDFPage (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IPDFPage

01type
02  IPDFPage = interface(IDispatch)
03    ['{749FB131-80FE-46E9-8330-22C1DC346FE7}']
04    function Get_Parent: IPDFPage; safecall;
05    function Get_Title: WideString; safecall;
06    procedure Set_Title(Value: WideString); safecall;
07    function Get_Width: Double; safecall;
08    procedure Set_Width(Value: Double); safecall;
09    function Get_Height: Double; safecall;
10    procedure Set_Height(Value: Double); safecall;
11    function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool;
12      Italic: WordBool): IPDFFont; safecall;
13    procedure Perform(const Command: WideString); safecall;
14    function Get_LineWidth: Double; safecall;
15    procedure Set_LineWidth(Value: Double); safecall;
16    procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double); safecall;
17    procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double;
18      Fill: WordBool); safecall;
19    function Get_LineCap: TPDFLineCap; safecall;
20    procedure Set_LineCap(Value: TPDFLineCap); safecall;
21    function Get_LineJoin: TPDFLineJoin; safecall;
22    procedure Set_LineJoin(Value: TPDFLineJoin); safecall;
23    procedure SetDash(DashArray: OleVariant; Phase: Integer); safecall;
24    procedure SetColor(R: Integer; G: Integer; B: Integer); safecall;
25    procedure PerformColor(const Command: WideString); safecall;
26    procedure Poly(Points: OleVariant; Fill: WordBool); safecall;
27    procedure Image(Image: OleVariant; X: Double; Y: Double; Width: Double;
28      Height: Double; Transparent: WordBool); safecall;
29    procedure DrawGrid; safecall;
30    procedure Arc(X: Double; Y: Double; Radius: Double; StartAngle: Double;
31      EndAngle: Double; FillSegment: WordBool; FillSector: WordBool); safecall;
32    procedure Curve(Points: OleVariant; Fill: WordBool); safecall;
33    procedure HyperLink(const URI: WideString; X: Double; Y: Double; Width: Double;
34      Height: Double); safecall;
35    procedure Pattern(X1: Double; Y1: Double; Width: Double; Height: Double;
36      PatternPointSize: Double; Percentage: Integer); safecall;
37    procedure Bezier(Points: OleVariant; Fill: WordBool); safecall;
38    procedure XObject(Data: OleVariant); safecall;
39    procedure SetColorCMYK(C: Double; M: Double; Y: Double; K: Double); safecall;
40    procedure LocalLink(const Page: IDispatch; DestinationX: Double;
41      DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
42      X: Double; Y: Double; Width: Double; Height: Double); safecall;
43    property Parent: IPDFPage read Get_Parent;
44    property Title: WideString read Get_Title write Set_Title;
45    property Width: Double read Get_Width write Set_Width;
46    property Height: Double read Get_Height write Set_Height;
47    property LineWidth: Double read Get_LineWidth write Set_LineWidth;
48    property LineCap: TPDFLineCap read Get_LineCap write Set_LineCap;
49    property LineJoin: TPDFLineJoin read Get_LineJoin write Set_LineJoin;
50  end;

1. Свойства

Свойства интерфейса IPDFPage:

Имя | Тип | Доступ | Назначение
Height | Double | Чтение/Запись |
LineCap | TPDFLineCap | Чтение/Запись |
LineJoin | TPDFLineJoin | Чтение/Запись |
LineWidth | Double | Чтение/Запись |
Parent | IPDFPage | Только для чтения |
Title | WideString | Чтение/Запись |
Width | Double | Чтение/Запись |

2. Метод Arc

Метод интерфейса IPDFPage.

1procedure IPDFPage.Arc(X: Double; Y: Double; Radius: Double;
2  StartAngle: Double; EndAngle: Double; FillSegment: WordBool;
3  FillSector: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
X | Double | Да |
Y | Double | Да |
Radius | Double | Да |
StartAngle | Double | Да |
EndAngle | Double | Да |
FillSegment | WordBool | Да |
FillSector | WordBool | Да |

3. Метод Bezier

Метод интерфейса IPDFPage.

procedure IPDFPage.Bezier(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

4. Метод CreateFont

Метод интерфейса IPDFPage.

1function IPDFPage.CreateFont(const FontName: WideString; Size: Double;
2  Bold: WordBool; Italic: WordBool): IPDFFont;

Параметры:

Имя | Тип | Обязательно | Значение
FontName | WideString | Да |
Size | Double | Да |
Bold | WordBool | Да |
Italic | WordBool | Да |

Замечания:

Возвращает значение типа IPDFFont.

5. Метод Curve

Метод интерфейса IPDFPage.

procedure IPDFPage.Curve(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

6. Метод DrawGrid

Метод интерфейса IPDFPage.

procedure IPDFPage.DrawGrid;

Метод не имеет параметров.

7. Метод HyperLink

Метод интерфейса IPDFPage.

1procedure IPDFPage.HyperLink(const URI: WideString; X: Double; Y: Double;
2  Width: Double; Height: Double);

Параметры:

Имя | Тип | Обязательно | Значение
URI | WideString | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |

8. Метод Image

Метод интерфейса IPDFPage.

1procedure IPDFPage.Image(Image: OleVariant; X: Double; Y: Double;
2  Width: Double; Height: Double; Transparent: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Image | OleVariant | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |
Transparent | WordBool | Нет |

9. Метод Line

Метод интерфейса IPDFPage.

procedure IPDFPage.Line(X1: Double; Y1: Double; X2: Double; Y2: Double);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
X2 | Double | Да |
Y2 | Double | Да |

10. Метод LocalLink

Метод интерфейса IPDFPage.

1procedure IPDFPage.LocalLink(const Page: IDispatch; DestinationX: Double;
2  DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
3  X: Double; Y: Double; Width: Double; Height: Double);

Параметры:

Имя | Тип | Обязательно | Значение
Page | IDispatch | Да |
DestinationX | Double | Да |
DestinationY | Double | Да |
DestinationWidth | Double | Да |
DestinationHeight | Double | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |

11. Метод Pattern

Метод интерфейса IPDFPage.

1procedure IPDFPage.Pattern(X1: Double; Y1: Double; Width: Double;
2  Height: Double; PatternPointSize: Double; Percentage: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
Width | Double | Да |
Height | Double | Да |
PatternPointSize | Double | Да |
Percentage | Integer | Да |

12. Метод Perform

Метод интерфейса IPDFPage.

procedure IPDFPage.Perform(const Command: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Command | WideString | Да |

13. Метод PerformColor

Метод интерфейса IPDFPage.

procedure IPDFPage.PerformColor(const Command: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Command | WideString | Да |

14. Метод Poly

Метод интерфейса IPDFPage.

procedure IPDFPage.Poly(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

15. Метод Rectangle

Метод интерфейса IPDFPage.

1procedure IPDFPage.Rectangle(X1: Double; Y1: Double; Width: Double;
2  Height: Double; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
Width | Double | Да |
Height | Double | Да |
Fill | WordBool | Да |

16. Метод SetColor

Метод интерфейса IPDFPage.

procedure IPDFPage.SetColor(R: Integer; G: Integer; B: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
R | Integer | Да |
G | Integer | Да |
B | Integer | Да |

17. Метод SetColorCMYK

Метод интерфейса IPDFPage.

procedure IPDFPage.SetColorCMYK(C: Double; M: Double; Y: Double; K: Double);

Параметры:

Имя | Тип | Обязательно | Значение
C | Double | Да |
M | Double | Да |
Y | Double | Да |
K | Double | Да |

18. Метод SetDash

Метод интерфейса IPDFPage.

procedure IPDFPage.SetDash(DashArray: OleVariant; Phase: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
DashArray | OleVariant | Да |
Phase | Integer | Да |

19. Метод XObject

Метод интерфейса IPDFPage.

procedure IPDFPage.XObject(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |


Мельница данных ((раздел целиком))

Мельница данных- Класс TWordAsyncTask (Задачи отложенного выполнения отчетов Word) (раздел целиком) (22.10.2024) (одним файлом)
Класс TWordAsyncTask (Задачи отложенного выполнения отчетов Word)

Класс TAsyncTask (Задачи отложенного выполнения)Класс TObject (Объекты)

Объекты класса не именованы.

1. Свойства

Свойства класса TWordAsyncTask:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Видимо пользователю | Только для чтения | Унаследовано от TAsyncTask
Created | datetime | Да | Видимо пользователю | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Status | TAsyncTaskStatus | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TAsyncTask
Routine | TRoutine | Да | Видимо пользователю | Чтение/Запись
RoutineClass | TClass | Да | Скрыто от пользователя | Только для чтения
Language | TLanguage | Да | Видимо пользователю | Чтение/Запись
Handler | TAsyncHandler | Да | Видимо пользователю | Чтение/Запись
FormView | TFormView | Нет | Видимо пользователю | Чтение/Запись
Object | TObject | Нет | Видимо пользователю | Чтение/Запись
Started | datetime | Нет | Видимо пользователю | Чтение/Запись
Finished | datetime | Нет | Видимо пользователю | Чтение/Запись
Duration | time | Нет | Видимо пользователю | Только для чтения
Bold | Boolean | Да | Скрыто от пользователя | Только для чтения
RowColor | TRowColor | Нет | Скрыто от пользователя | Только для чтения
Group | TAsyncTask | Нет | Видимо пользователю | Только для чтения
GroupContentReady | Boolean | Да | Скрыто от пользователя | Только для чтения
Format | TWordOutputFormat | Да | Видимо пользователю | Чтение/Запись | Формат

2. Конструктор Create (Конструктор задачи отложенного выполнения отчетов Word)

Конструктор класса TWordAsyncTask.

1constructor TWordAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TWordOutputFormat): TObject;

Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Routine | TRoutine | Да | Унаследовано от TAsyncTask.Create
Object | TObject | Нет
FormView | TFormView | Нет
Handler | TAsyncHandler | Да
Language | TLanguage | Да
Format | TWordOutputFormat | Да | Формат

Замечания:

Создает новый объект класса TWordAsyncTask.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс ISetOfObjectsEditor (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс ISetOfObjectsEditor

1type
2  ISetOfObjectsEditor = interface(IDispatch)
3    ['{6D3662A7-D9FF-4BD6-8D92-A4EA2058C74E}']
4    function Get_DomainName: WideString; safecall;
5    procedure Set_DomainName(Value: WideString); safecall;
6    function Get_SelectedCount: Integer; safecall;
7    property DomainName: WideString read Get_DomainName write Set_DomainName;
8    property SelectedCount: Integer read Get_SelectedCount;
9  end;

1. Свойства

Свойства интерфейса ISetOfObjectsEditor:

Имя | Тип | Доступ | Назначение
DomainName | WideString | Чтение/Запись |
SelectedCount | Integer | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Класс TInstantMessageAttachment (Сообщения с вложением) (раздел целиком) (22.10.2024) (одним файлом)
Класс TInstantMessageAttachment (Сообщения с вложением)

Класс TInstantMessage (Сообщения)Класс TObject (Объекты)Класс TUser (Пользователи)

Объекты класса не именованы.

1. Свойства

Свойства класса TInstantMessageAttachment:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Owner | TUser | Да | Видимо пользователю | Только для чтения | Унаследовано от TInstantMessage
User | TUser | Да | Видимо пользователю | Чтение/Запись
Message | string[255] | Да | Видимо пользователю | Только для чтения
DeliveryTime | datetime | Да | Видимо пользователю | Только для чтения
AttachmentType | TInstantMessageAttachmentType | Да | Видимо пользователю | Только для чтения | Тип вложения
FileBody | blob | Нет | Видимо пользователю | Только для чтения | Содержимое файла
FormView | TFormView | Нет | Видимо пользователю | Только для чтения | Представление формы
Form | TForm | Да | Видимо пользователю | Только для чтения | Форма
FormIsAccessible | Boolean | Да | Скрыто от пользователя | Только для чтения | Форма доступна
Object | TObject | Нет | Видимо пользователю | Только для чтения | Объект
HyperLink | string[256] | Нет | Видимо пользователю | Только для чтения | Гиперссылка

2. Конструктор Create (Конструктор сообщения с вложением)

Конструктор класса TInstantMessageAttachment.

1constructor TInstantMessageAttachment.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; User: TUser; Message: string[255];
4  DeliveryTime: datetime; FileName: string[255]; FileBaseName: string[128];
5  FileBody: blob; FormView: TFormView; Object: TObject; HyperLink: string[256];
6  AttachmentType: TInstantMessageAttachmentType): TObject;

Переопределяет метод в TInstantMessage.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
User | TUser | Да | Унаследовано от TInstantMessage.Create
Message | string[255] | Да
DeliveryTime | datetime | Нет
FileName | string[255] | Нет | Имя файла
FileBaseName | string[128] | Да | Базовое имя файла
FileBody | blob | Нет | Содержимое файла
FormView | TFormView | Нет | Представление
Object | TObject | Нет | Объект
HyperLink | string[256] | Нет | Гиперссылка
AttachmentType | TInstantMessageAttachmentType | Да | Тип приложения

Замечания:

Создает новый объект класса TInstantMessageAttachment.


Мельница данных ((раздел целиком))

Мельница данных- Работа с типами данных (раздел целиком) (22.10.2024) (одним файлом)
Работа с типами данных

1. Домены


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IInfoProvider2 (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IInfoProvider2

01type
02  IInfoProvider2 = interface(IDispatch)
03    ['{BED44934-BCF9-4942-933D-591AB40D4CFE}']
04    function Get_AutoCheckKeys: WordBool; safecall;
05    function Get_OptionCount: Integer; safecall;
06    function Get_Option(Index: Integer): IOptionInfo; safecall;
07    property AutoCheckKeys: WordBool read Get_AutoCheckKeys;
08    property OptionCount: Integer read Get_OptionCount;
09    property Option[Index: Integer]: IOptionInfo read Get_Option;
10  end;

1. Свойства

Свойства интерфейса IInfoProvider2:

Имя | Тип | Доступ | Назначение
AutoCheckKeys | WordBool | Только для чтения |
Option[Index: Integer] | IOptionInfo | Только для чтения |
OptionCount | Integer | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Класс TClass (Классы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TClass (Классы)

Класс TObject (Объекты)Класс TClassMember (Члены класса)Класс TField (Поля)Класс TProperty (Свойства)Класс TMethod (Методы)Класс TXSLTTemplate (Шаблоны отчетов XSLT)Класс TExcelTemplate (Шаблоны отчетов Excel)Класс TRoutine (Подпрограмма)Класс TOleObjectMethod (Метод Ole-объекта)Класс TInlineExpression (Встраиваемое выражение)Класс TWordTemplate (Шаблоны отчетов Word)Класс TPDFTemplate (Шаблоны отчетов PDF)Класс TObjectCreator (Роли-создатели)

Объекты класса образуют иерархию.

1. Свойства

Свойства класса TClass:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Видимо пользователю | Чтение/Запись | Статус репликации
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись | Унаследовано от TObject
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
IsHierarhical | Boolean | Да | Видимо пользователю | Только для чтения | Является иерархическим
SecurityModel | TSecurityModel | Да | Видимо пользователю | Чтение/Запись | Модель безопасности
DefaultAccessor | TSecurityAccount | Нет | Видимо пользователю | Чтение/Запись | Роль доступа по умолчанию
UnNamed | Boolean | Да | Видимо пользователю | Чтение/Запись | Неименованный
NameExpression | clob | Нет | Видимо пользователю | Чтение/Запись | Выражение имени объекта
DescriptionExpression | clob | Нет | Видимо пользователю | Чтение/Запись | Выражение наименования объекта
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись | Протоколировать
ModelX | Integer | Нет | Скрыто от пользователя | Чтение/Запись | Положение в модели (абсцисса)
ModelY | Integer | Нет | Скрыто от пользователя | Чтение/Запись | Положение в модели (ордината)
Category | string[128] | Нет | Видимо пользователю | Чтение/Запись | Категория
Indexed | Boolean | Да | Видимо пользователю | Чтение/Запись | Индексируется
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей
Localizable | Boolean | Да | Видимо пользователю | Чтение/Запись | Локализуемый
DBMSName | string[64] | Да | Видимо пользователю | Только для чтения | Имя объекта СУБД
CreatorsCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество ролей-создателей
MasterClass | TClass | Нет | Видимо пользователю | Только для чтения | Класс-мастер
HasProfiles | Boolean | Да | Видимо пользователю | Только для чтения | Контролируется профилями
ApproxObjectCount | Integer | Нет | Видимо пользователю | Только для чтения | Оценка количества объектов

2. Конструктор Create (Конструктор класса)

Конструктор класса TClass.

1constructor TClass.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  MasterClass: TClass; IsHierarhical: Boolean;
4  ReplicationStatus: TReplicationStatus; SecurityModel: TSecurityModel;
5  DefaultAccessor: TSecurityAccount; Logged: Boolean; UnNamed: Boolean;
6  NameExpression: clob; DescriptionExpression: clob; CreateConstructor: Boolean;
7  Category: string[128]; Indexed: Boolean; Localizable: Boolean): TClass;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Имя
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
MasterClass | TClass | Нет | Класс-мастер
IsHierarhical | Boolean | Да | Является иерархическим
ReplicationStatus | TReplicationStatus | Да | Статус репликации
SecurityModel | TSecurityModel | Да | Модель безопасности
DefaultAccessor | TSecurityAccount | Нет | Роль доступа по умолчанию
Logged | Boolean | Да | Протоколировать
UnNamed | Boolean | Да | Неименованный
NameExpression | clob | Нет | Выражение имени объекта
DescriptionExpression | clob | Нет | Выражение наименования объекта
CreateConstructor | Boolean | Да | Создать конструктор
Category | string[128] | Нет | Категория
Indexed | Boolean | Да | Индексируется
Localizable | Boolean | Да | Локализуемый

Замечания:

Создает новый объект класса TClass.

3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TClass.

procedure TClass.CreateContextKey(Storage: string[64]);

Параметры:

Имя | Тип | Обязательно | Значение
Storage | string[64] | Да | Хранилище

4. Метод GenerateConstructor (Сгенерировать текст конструктора)

Метод экземпляра класса TClass.

procedure TClass.GenerateConstructor;

Метод не имеет параметров.

5. Метод GetApproxObjectsCount (Получить оценку количества объектов)

Метод экземпляра класса TClass.

function TClass.GetApproxObjectsCount: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

6. Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TClass.

function TClass.GetDBMSName: string[64];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

7. Метод GetHasProfiles (Контролируется профилями)

Метод экземпляра класса TClass.

function TClass.GetHasProfiles: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

8. Метод GetObjectCount (Количество объектов)

Метод экземпляра класса TClass.

function TClass.GetObjectCount(Exact: Boolean): string[20];

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Exact | Boolean | Да | Строго

Замечания:

Возвращает значение типа string[20].

9. Метод ListChildProperties (Список дочерних свойств)

Метод класса (статический метод) класса TClass.

1class procedure TClass.ListChildProperties(ParentName: string[64];
2  TemporaryList: TObjectList; PersistentList: TObjectList);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ParentName | string[64] | Да | Имя свойства
TemporaryList | TObjectList | Нет | Временный список
PersistentList | TObjectList | Нет | Постоянный список

10. Метод ListProperties (Список свойств)

Метод экземпляра класса TClass.

function TClass.ListProperties(Scope: TScope): TObjectList;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Scope | TScope | Да | Область видимости

Замечания:

Возвращает значение типа TObjectList.

11. Метод ListRoutines (Список подпрограмм)

Метод экземпляра класса TClass.

function TClass.ListRoutines(Scope: TScope): TObjectList;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Scope | TScope | Да | Область видимости

Замечания:

Возвращает значение типа TObjectList.

12. Метод MarkLocalizableMetadata (Установить поля метаданных как локализуемые)

Метод класса (статический метод) класса TClass.

class procedure TClass.MarkLocalizableMetadata;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

13. Метод MemberByName (Член класса по имени)

Метод экземпляра класса TClass.

function TClass.MemberByName(Name: string[64]; Class: TClass): TClassMember;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Имя
Class | TClass | Да | Класс

Замечания:

Возвращает значение типа TClassMember.

14. Метод SetLocalizable (Установить значение свойства "Локализуемый")

Метод экземпляра класса TClass.

procedure TClass.SetLocalizable(Value: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение

15. Метод Ole-объекта CheckAllExcelTemplates (Проверить шаблоны отчетов Excel)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

16. Метод Ole-объекта CheckAllOleObjectMethods (Проверить все методы Ole-объекта)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

17. Метод Ole-объекта CheckAllTemplates (Проверить все шаблоны)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

18. Метод Ole-объекта CheckAllWordTemplates (Проверить шаблоны отчетов Word)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

19. Метод Ole-объекта CheckAllXSLTTemplates (Проверить шаблоны отчетов XSLT)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

20. Метод Ole-объекта LoadImagesFromFolder (Загрузить изображения из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка
Prefix | string[128] | Нет | Префикс имени файла

Замечания:

Возвращает значение типа Integer.

21. Метод Ole-объекта LoadMethodsFromFolder (Загрузить методы из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка

Замечания:

Возвращает значение типа Integer.

22. Метод Ole-объекта LoadResourceFile (Загрузить файл ресурсов)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
XliffFileName | string[255] | Да | Файл ресурсов

Замечания:

Возвращает значение типа Integer.

23. Метод Ole-объекта LoadTemplatesFromFolder (Загрузить шаблоны из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка

Замечания:

Возвращает значение типа Integer.

24. Метод Ole-объекта SaveImagesToFolder (Сохранить изображения в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка
Prefix | string[128] | Нет | Префикс имени файла

Замечания:

Возвращает значение типа Integer.

25. Метод Ole-объекта SaveMethodsToFolder (Сохранить методы в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка

Замечания:

Возвращает значение типа Integer.

26. Метод Ole-объекта SaveTemplatesToFolder (Сохранить шаблоны в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Folder | string[255] | Да | Папка
ExportCodeModules | Boolean | Да | Экспортировать программные модули

Замечания:

Возвращает значение типа Integer.

27. Шаблон XSLT-отчета ClassesDiagram (Диаграмма классов)

Шаблон XSLT-отчета класса (статический шаблон) класса TClass.

Шаблон отчета Word является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ShowFields | Boolean | Да | Показывать поля
ShowMethods | Boolean | Да | Показывать методы
ShowProperties | Boolean | Да | Показывать свойства
ShowParameters | Boolean | Да | Показывать параметры
ShowMetadata | Boolean | Да | Показывать метаданные
GroupByMaster | Boolean | Да | Группировать по принадлежности


Мельница данных ((раздел целиком))

Мельница данных- Класс TProfileEvent (События профиля) (раздел целиком) (22.10.2024) (одним файлом)
Класс TProfileEvent (События профиля)

Диаграмма Класс TProfileMethod (Методы профиля)

1. Свойства

Свойства класса TProfileEvent:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Method | TProfileMethod | Да | Скрыто от пользователя | Только для чтения | Метод профилировщика
Class | TClass | Да | Видимо пользователю | Только для чтения | Класс
ObjectID | string[38] | Да | Видимо пользователю | Только для чтения | Идентификатор объекта
ObjectQualifiedName | string[2000] | Нет | Видимо пользователю | Только для чтения | Квалифицированное имя объекта
ObjectDataBase | TDataBase | Нет | Видимо пользователю | Только для чтения | База данных объекта
ObjectOldID | string[38] | Нет | Видимо пользователю | Только для чтения | Идентификатор при создании
Action | TChangeAction | Да | Видимо пользователю | Только для чтения | Действия


Мельница данных ((раздел целиком))

Мельница данных- Класс TViewPresentationColumn (Колонки вида) (раздел целиком) (22.10.2024) (одним файлом)
Класс TViewPresentationColumn (Колонки вида)

Класс TObject (Объекты)Класс TViewPresentation (Виды)

Имена объектов класса генерируются.

1. Свойства

Свойства класса TViewPresentationColumn:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Column | TViewColumn | Да | Видимо пользователю | Только для чтения | Колонка представления
Presentation | TViewPresentation | Да | Скрыто от пользователя | Только для чтения | Вид
View | TObject | Да | Скрыто от пользователя | Только для чтения | Представление
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения | Доступен
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Grouped | Boolean | Да | Видимо пользователю | Чтение/Запись | Сгруппирована
Aggregate | TAggregateKind | Нет | Видимо пользователю | Чтение/Запись | Агрегат
SortDirection | TSortDirection | Да | Видимо пользователю | Чтение/Запись | Направление сортировки
Width | Integer | Да | Видимо пользователю | Чтение/Запись | Ширина
Filter | string[128] | Нет | Видимо пользователю | Чтение/Запись | Фильтр
Fixed | Boolean | Да | Видимо пользователю | Чтение/Запись | Зафиксирована
Category | string[128] | Нет | Видимо пользователю | Чтение/Запись | Категория

2. Конструктор Create (Конструктор колонки вида)

Конструктор класса TViewPresentationColumn.

1constructor TViewPresentationColumn.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Column: TViewColumn; Position: Integer;
4  Grouped: Boolean; Aggregate: TAggregateKind; SortDirection: TSortDirection;
5  Width: Integer; Filter: string[128]; Fixed: Boolean;
6  Category: string[128]): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Column | TViewColumn | Да | Колонка
Position | Integer | Да | Позиция
Grouped | Boolean | Да | Группировать
Aggregate | TAggregateKind | Нет | Агрегат
SortDirection | TSortDirection | Да | Направление сортировки
Width | Integer | Да | Ширина
Filter | string[128] | Нет | Фильтр
Fixed | Boolean | Да | Зафиксирована
Category | string[128] | Нет | Категория

Замечания:

Создает новый объект класса TViewPresentationColumn.

3. Метод AddColumns (Создать колонки)

Метод класса (статический метод) класса TViewPresentationColumn.

class procedure TViewPresentationColumn.AddColumns(Master: TViewPresentation);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TViewPresentation | Да | Мастер

4. Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentationColumn.

1class function TViewPresentationColumn.Save(Master: TViewPresentation;
2  Column: TViewColumn; Position: Integer; Grouped: Boolean;
3  Aggregate: TAggregateKind; SortDirection: TSortDirection; Width: Integer;
4  Filter: string[128]; Fixed: Boolean; Category: string[128]): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TViewPresentation | Да | Мастер
Column | TViewColumn | Да | Колонка
Position | Integer | Да | Позиция
Grouped | Boolean | Да | Группировать
Aggregate | TAggregateKind | Нет | Агрегат
SortDirection | TSortDirection | Да | Направление сортировки
Width | Integer | Да | Ширина
Filter | string[128] | Нет | Фильтр
Fixed | Boolean | Да | Зафиксирована
Category | string[128] | Нет | Категория

Замечания:

Возвращает значение типа TObject.


Мельница данных ((раздел целиком))

Мельница данных- Класс TDataBase (Базы данных) (раздел целиком) (22.10.2024) (одним файлом)
Класс TDataBase (Базы данных)

Диаграмма Класс TObject (Объекты)

1. Свойства

Свойства класса TDataBase:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
GUID | string[38] | Да | Видимо пользователю | Только для чтения | Идентификатор
IsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Является текущей
Protected | Boolean | Да | Видимо пользователю | Чтение/Запись | Защищена от изменений

2. Конструктор Create (Конструктор базы данных)

Конструктор класса TDataBase.

1constructor TDataBase.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  GUID: string[38]; Protected: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
GUID | string[38] | Да | GUID
Protected | Boolean | Да | Защищена

Замечания:

Создает новый объект класса TDataBase.


Мельница данных ((раздел целиком))

Мельница данных- Класс TAccessItem (Элементы доступа) (раздел целиком) (22.10.2024) (одним файлом)
Класс TAccessItem (Элементы доступа)

Класс TObject (Объекты)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TAccessItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Скрыто от пользователя | Чтение/Запись | Имя
Description | string[128] | Да | Скрыто от пользователя | Чтение/Запись | Наименование
Class | TClass | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения | Элемент
MasterName | string[64] | Да | Видимо пользователю | Только для чтения | Имя элемента
MasterDescription | string[128] | Да | Видимо пользователю | Только для чтения | Наименование элемента
MasterClass | TClass | Да | Видимо пользователю | Только для чтения | Класс элемента
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
SecurityAccount | TSecurityAccount | Да | Видимо пользователю | Чтение/Запись | Роль безопасности
SecurityAccountName | string[64] | Да | Видимо пользователю | Чтение/Запись | Имя роли безопасности
SecurityAccountDescription | string[128] | Да | Видимо пользователю | Чтение/Запись | Наименование роли безопасности
SecurityAccountClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс роли безопасности

2. Конструктор Create (Конструктор элемента доступа)

Конструктор класса TAccessItem.

1constructor TAccessItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
SecurityAccount | TSecurityAccount | Да | Роль безопасности

Замечания:

Создает новый объект класса TAccessItem.

3. Метод GetIsAccessible (Проверка доступности)

Метод класса (статический метод) класса TAccessItem.

class function TAccessItem.GetIsAccessible(Master: TObject): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Boolean.


Мельница данных ((раздел целиком))

Мельница данных- Класс TFormBan (Запрет на форму) (раздел целиком) (22.10.2024) (одним файлом)
Класс TFormBan (Запрет на форму)

Класс TBanGroupItem (Элементы группы запретов)Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TFormBan:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TBanGroup | Да | Видимо пользователю | Только для чтения | Унаследовано от TBanGroupItem
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
BannedForm | TForm | Да | Видимо пользователю | Чтение/Запись | Запрещаемая форма

2. Конструктор Create (Конструктор запрета на форму)

Конструктор класса TFormBan.

1constructor TFormBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedForm: TForm): TObject;

Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
BannedForm | TForm | Да | Запрещаемая форма

Замечания:

Создает новый объект класса TFormBan.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс ITypeInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс ITypeInfo

Интерфейс INamedItemInfo

1type
2  ITypeInfo = interface(INamedItemInfo)
3    ['{2B6A5E20-3C36-4574-89DB-7C873A5C4A00}']
4    function Get_Required: WordBool; safecall;
5    function Get_SimpleType: TSimpleType; safecall;
6    property Required: WordBool read Get_Required;
7    property SimpleType: TSimpleType read Get_SimpleType;
8  end;

1. Свойства

Свойства интерфейса ITypeInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения |
SimpleType | TSimpleType | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Класс TFormView (Представления формы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TFormView (Представления формы)

Класс TObject (Объекты)Класс TForm (Формы)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

1. Свойства

Свойства класса TFormView:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
ChildrenMinimized | Boolean | Да | Видимо пользователю | Чтение/Запись | Дочерние представления минимизированы
MasterProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-главное
DetailProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Свойство-подчиненное
View | TCustomView | Да | Видимо пользователю | Чтение/Запись | Представление
BoldProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство выделенного шрифта
ShownClass | TClass | Да | Видимо пользователю | Только для чтения | Показываемый класс
ColorProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство цвета
Layout | TFormViewLayout | Да | Видимо пользователю | Чтение/Запись | Расположение
ChildrenOnTabs | Boolean | Да | Видимо пользователю | Чтение/Запись | Дочерние представления на закладках
ExplicitQuery | Boolean | Да | Видимо пользователю | Чтение/Запись | Явный запрос
SpacePercentage | Integer | Нет | Видимо пользователю | Чтение/Запись | Площадь, %

2. Конструктор Create (Конструктор представления формы)

Конструктор класса TFormView.

1constructor TFormView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout;
6  ExplicitQuery: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
View | TCustomView | Да | Представление
ChildrenMinimized | Boolean | Да | Дочерние представления минимизированы
ChildrenOnTabs | Boolean | Да | Дочерние представления на закладках
MasterProperty | TProperty | Нет | Свойство-главное
DetailProperty | TClassMember | Нет | Свойство-подчиненное
Position | Integer | Да | Позиция
SpacePercentage | Integer | Нет | Площадь, %
Layout | TFormViewLayout | Да | Расположение
ExplicitQuery | Boolean | Да | Явный запрос

Замечания:

Создает новый объект класса TFormView.

3. Метод GetName (Сгенерировать имя объекта)

Метод экземпляра класса TFormView.

function TFormView.GetName: string[64];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

4. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormView.

class function TFormView.GetNextPos(Parent: TObject; Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Parent | TObject | Нет | Родитель
Master | TObject | Да | Мастер

Замечания:

Возвращает значение типа Integer.


Мельница данных ((раздел целиком))

Мельница данных- Установка программного обеспечения платформы "Мельница данных" (раздел целиком) (22.10.2024) (одним файлом)
Установка программного обеспечения платформы "Мельница данных"

Для установки ПП "Мельница данных" необходимо запустить файл setup.exe, расположенный на поставляемом компакт диске. После запуска программы установки необходимо следовать указаниям мастера установки.

Шаг 1: Выбор языка

Установка Мельницы Выбор языка

Шаг 2: Информация о версии устанавливаемого ПП

Установка Мельницы. Версия ПП

Шаг3: Выбор каталога установки файлов ПП

Установка Мельницы. Папка установки.

Шаг 4: Выбор файла лицензии

Установка Мельницы. Выбор лицензии.

Файл лицензии также расположен на поставляемом компакт-диске или высылается по электронной почте. В случае если не выбран никакой файл лицензий, то программа будет установлена в демонстрационном режиме. В последующем после получения файла лицензий необходимо будет переустановить ПП. Подробнее с лицензионным соглашением можно ознакомится в одноименном разделе настоящей документации.

Шаг 5: Выбор компонентов для установки

Установка Мельницы. Выбор компонентов.

На данном шаге вам необходимо выбрать набор компонентов для установки на локальный компьютер. В зависимости от специфики использования рабочего места, на которое устанавливается ПО, необходимо выбрать тип установки. Предлагаемые типы установок:

  • Рабочее место пользователя
  • Рабочее место администратора
  • Рабочее место разработчика
  • Только построитель запросов
  • По выбору

Для каждого из типов установки по умолчанию устанавливается свой набор компонентов. Вы можете дополнительно отметить тот или иной необходимый вам компонент для установки. Для выбора будут отображены только те компоненты, которые влачены в указанном вами лицензионном файле.

Полный перечень компонентов для установки:

  1. Обозреватель данных
  2. Построитель запросов
  3. Утилита обслуживания баз данных
  4. Утилита слияния баз данных
  5. Инструменты разработчика / Инструмент поставки решений
  6. Отладочный монитор
  7. Документация

Для некоторых из вышеперечисленных компонентов также можно выбрать состав устанавливаемого компонента. Описание назначений поставляемых компонент описано в разделе "Поставляемые компоненты ПП" настоящей документации.

После указания всех параметров мастер установки скопирует файлы на локальный компьютер и создаст в меню программ папку с ярлыками к установленным компонентам:

Установка Мельницы. Ярлыки после установки.

1. Поставляемые компоненты ПП "Мельница данных"
Обозреватель данных | Обозреватель данных (DataBrowser) - Основное приложение позволяющее просматривать и модифицировать данные. Приложение используется для разработки прикладных решений. Позволяет описывать объекты БД, их свойства, методы, пользовательские формы и отчеты. Это же приложение используется для работы с разработанными прикладными решения пользователями на локальных рабочих местах.
Утилита обслуживания БД | Утилита обслуживания базы данных (DBSetupShell) - Приложение, позволяющее создавать и обслуживать выбранную базу данных любой из поддерживаемых СУБД. Также при помощи данной утилиты можно создавать и удалять пользователей БД, создавать и восстанавливать резервные копии БД, импортировать и экспортировать данные из/в БД, а также выполнять процедуры по контролю целостности БД.
Построитель запросов | Построитель запросов (QueryBuilder) - Приложение, позволяющее визуальными средствами создавать интерактивные запросы на основе данных хранящихся в используемой БД. Созданные запросы сохраняются в стандартный формате SQL и полностью удовлетворяют архитектуре клиент-сервер. Сохраненные в виде файла запросы могут быть открыты пользователем по необходимости. Полученная таким образом информация будет актуальна в любой момент времени. Также существует возможность создания статистического отчета на основе Excel шаблона.
Отладочный монитор | Отладочный монитор (DebugView) - Средство позволяющее отслеживать все запросы к БД генерируемые "клиентской частью" прикладного решения, а также результат их исполнения сервером СУБД. Используется для отладки в процессе разработки прикладного решения.
Утилита слияния баз данных | Утилита слияния баз данных (Merger) - Данная утилита позволяет сравнивать данные и метаданные 2х различных БД. При помощи данного приложения можно с легкостью перенести, например данные из резервной копии в рабочую БД в случае не преднамеренного удаления большого числа объектов, тем самым избежать необходимости восстановления резервной копии недельной давности. Также используется для обновления версии ПП.
Редактор файлов документации | Редактор файлов документации (HelpEditor) - Незаменимое средство создания электронной справки и файлов документации в стандартном формате chm.


Мельница данных ((раздел целиком))

Мельница данных- Функция excelreport (раздел целиком) (22.10.2024) (одним файлом)
Функция excelreport

Функция excelreport позволяет вызывать на выполнение отчеты класса TExcelTemplate и получать файлы, формируемые как результат выполнения отчетов. Файлы могут быть возвращены как в форматах Excel (.xls,.xlsx), так и с преобразованием в другие форматы. Исключением являются интерактивные отчеты (требующие при формировании диалога с пользователем). Такие отчеты не могут вызваться при помощи данной функции.

Допустимые расширения:

  • .xls - для получения файла отчета в формате XLS
  • .xlsx - для получения файла отчета в формате XSLX
  • .html - для получения файла отчета в формате HTML; поддерживается формирование html-документа в монохромном цветовом режиме, в режиме "в градациях серого"
  • .pdf - для получения файла отчета в формате PDF; поддерживаются способы преобразования.xls/.xslx-файла в pdf-документ как средствами платформы, так и средствами самого Excel; возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"
  • .xps - для получения файла отчета в формате XPS

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

  • "class" (обязательный) - имя класса, отчет которого будет вызываться
  • "template" (обязательный) - имя отчета, который будет вызываться
  • "format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:
    • цветовой режим - допустимые значения "mono", "grey"; значение по умолчанию - "обычный" цветовой режим
    • внедрение шрифтов (для формата PDF) - допустимые значения "embed", "embedded"; значение по умолчанию - без внедрения шрифтов
    • способ преобразования (для случая преобразования в формат PDF) - допустимое значение "native"; значение по умолчанию - средствами платформы "Мельница данных" в случае, если такой способ реализован; иначе - средствами приложения MS Office.
    • тип файла результата - допустимые значения совпадают с возможными расширениями вызова функции (без дополнительной точки)
  • "filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="StatisticReport.embed.pdf", что будет говорить о том, что будет возвращен pdf-документ с внедренными шрифтами.
    Значение по умолчанию: "excelreport" с расширением, совпадающим с расширением вызываемой функции.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного атрибутами параметра query или расширением функции excelreport (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове Excel-отчета:
1  <execute class="TSchoolAbiturSt" template="RegStatistics" format="mono.embed.native.pdf" filename="StatisticReport.pdf">
2    <row>
3      <AdmissionYear>7427462</AdmissionYear>
4      <AdmStage>8608398</AdmStage>
5      <PrevAdmissionYear>6843737</PrevAdmissionYear>
6      <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
7    </row>
8  </execute>
При таком вызове будет выполнен Excel-отчет "RegStatistics" класса "TSchoolAbiturSt" с параметрами, переданными в элементе row. Данный отчет является "методом класса", поэтому параметр "ID" в состав параметров не добавлен. Полученный файл отчета будет преобразован в формат PDF с внедрением шрифтов в монохромном режиме. Преобразование будет выполнено средствами приложения MS Excel. В качестве ответа будет возвращен .pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("StatisticReport.pdf"), в содержимом ответа будет передано содержимое файла.

1. Принципы разбора информации о формате результирующего файла

Информация о формате файла, который будет сформирован и возвращен в качестве ответа, может быть извлечена из атрибутов xml-документа запроса, или из расширения функции. Порядок разбора переданной информации следующий:

  1. Значение атрибута format. Если данный атрибут указан, но в нем нет одной из составляющих формата, то для этой составляющей будет использовано значение по умолчанию (значение из атрибута filename использовано не будет).
  2. Значение атрибута filename. В этом атрибуте, кроме имени файла как такового и его расширения, может передаваться информация о цветовом режиме (.mono/.grey,...), внедрении шрифтов (.embed/.embedded), способе преобразования файла (.native). Значения для этих составляющих будут получены из атрибута filename только в случае, если атрибут format не указан при вызове.
  3. Расширение будет получено из расширения вызываемой функции. Для других составляющих формата будут использованы значения по умолчанию.

Строка, определяющая формат, разбирается как последовательность элементов, разделенных символом "." (точка). Элементы разбираются последовательно, независимо друг от друга, и имеют следующие значения:

mono | Формируется монохромный документ
grey | Формируется документ в градациях серого
embedded | Шрифты внедряются в выходной документ
native | Используется встроенный в MSOffice механизм формирования документов
PDF | Выгружается файл в формате PDF
HTML | Выгружается файл в формате HTML
BMP | Выгружается файл в формате BMP
RTF | Выгружается файл в формате RTF
DOC | Выгружается файл в формате DOC
XLS | Выгружается файл в формате XLS
DOCX | Выгружается файл в формате DOCX
XLSX | Выгружается файл в формате XLSX
XPS | Выгружается файл в формате XPS

Остальные элементы игнорируются. Порядок следования элементов не важен.

Строка формата "pdf.mono.embedded" указывает сформировать монохромный документ в формате PDF со встроенными шрифтами.


Мельница данных ((раздел целиком))

Мельница данных- Класс TPropertyBan (Запрет на свойство) (раздел целиком) (22.10.2024) (одним файлом)
Класс TPropertyBan (Запрет на свойство)

Класс TBanGroupItem (Элементы группы запретов)Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TPropertyBan:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TBanGroup | Да | Видимо пользователю | Только для чтения | Унаследовано от TBanGroupItem
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
BannedClass | TClass | Да | Видимо пользователю | Только для чтения | Запрещаемый класс
BannedProperty | TProperty | Да | Видимо пользователю | Только для чтения | Запрещаемое свойство
AllowRead | Boolean | Да | Видимо пользователю | Чтение/Запись | Чтение разрешено

2. Конструктор Create (Конструктор запрета на свойство)

Конструктор класса TPropertyBan.

1constructor TPropertyBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedProperty: TProperty; AllowRead: Boolean): TObject;

Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
BannedClass | TClass | Да | Запрещаемый класс
BannedProperty | TProperty | Да | Запрещаемое свойство
AllowRead | Boolean | Да | Чтение разрешено

Замечания:

Создает новый объект класса TPropertyBan.


Мельница данных ((раздел целиком))

Мельница данных- Стилевое оформление исходного кода (раздел целиком) (22.10.2024) (одним файлом)
Стилевое оформление исходного кода

Код на языке PascalScript, являющийся частью поставляемого решения, должен быть оформлен в соответствии с изложенными правилами.

1. Использование строк, пробелов и отступов

Пустые строки могут повысить читабельность путем группирования секций кода, которые логически связаны между собой.

Пробелы, запрещенные к использованию:

  • До или после точки "."
  • Между именем вызываемого метода и открывающей скобкой "("
  • После открывающей скобки "(" или перед закрывающей ")"
  • Перед точкой с запятой ";"
  • Перед двоеточием ":"
  • Перед запятой ","

Двоеточие для всех объявлений переменных не должно содержать перед собой пробелов и иметь один пробел после перед именем типа.

Всегда необходимо использовать два пробела для всех уровней отступа. Другими словами, первый уровень отступает на два пробела, второй на четыре и так далее. Никогда не используйте символы табуляции.

Существует несколько исключений из этого правила. Зарезервированные слова var, begin и end, относящиеся к программному блоку вцелом, всегда должны примыкать к левой границе. Код внутри блока begin..end должен иметь отступ два символа.

Все строки должны быть ограничены 80 столбцами. Строки, длиннее чем 80 столбцов должны быть разделены и перенесены. Все перенесенные строки должны быть выровнены по первой строке и иметь отступ в два символа. Зарезервированное слово begin всегда должно находиться на своей отдельной строке.

Нельзя переносить строки в тех местах, где не допускаются пробелы, например между именем метода и открывающей скобкой. Никогда нельзя помещать зарезервированное слово begin на строку, содержащую другой код.

2. Оформление объявлений и операторов

Все переменные с их типами должны быть объявлены на различных строках.

Простые операторы содержат одну точку с запятой. Если Вам необходимо разделить оператор, то перенесите продолжение оператора на следующую строку с отступом в два пробела.
  MyValue :=
    MyValue + (SomeVeryLongStatement / OtherLongStatement);

Составные операторы всегда заканчиваются точкой с запятой.
1begin
2  MyStatement;
3  MyNext Statement;
4  MyLastStatement;
end;

Каждое присвоение и каждое выражение должно располагаться на разных строках.

Оператор "if"

Оператор if всегда должен располагаться по крайней мере на двух строках
if A < B then DoSomething;
if A < B then
  DoSomething;
В случае составного оператора необходимо поместить каждый оператор на новую строку.
1  if A < B then begin
2    DoSomething;
3    DoSomethingElse;
4  end else begin
5    DoThis;
6    DoThat;
7  end;

1  if A < B then
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end
6  else
7  begin
8    DoThis;
9    DoThat;
  end;
Все остальные варианты расположения операторов не рекомендуются и не одобряются, хотя и являются синтаксически правильными.

Оператор "for"

1  for i := 0 to 10 do begin
2    DoSomething;
3    DoSomethingElse;
4  end;

1  for i := 0 to 10 do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  for I := 0 to 10 do
8    DoSomething;

Оператор "while"

1  while x < j  do begin
2    DoSomething;
3    DoSomethingElse;
  end;
1  while x < j do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  while x < j do
8    Something;

Оператор "repeat..until"

1  repeat
2    x := j;
3    j := UpdateValue;
4  until j > 25;

Оператор "case"

Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01  case LCode of
02    1, 3:
03      begin
04        Incr := FIncrement + 1;
05        FinalIncr := FIncrement div FLineDiv;
06        Count := FLineDiv;
07      end;
08    2, 4:
09      begin
10        Incr := FPageIncrement;
11        FinalIncr := Incr + 1;
12        Incr := Incr div FPageDiv;
13        Count := FPageDiv;
14      end;
15  else
16    begin
17      Count := 0;
18      Incr := 0;
19      FinalIncr := 0;
20    end;
  end;

Оператор "try"

Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01try
02  try
03    EnumItems(CurrentThreadID, LDisable, 0);
04    Result := TaskList;
05  except
06    EnableItems(TaskList);
07    raise;
08  end;
09finally
10  TaskList := SaveList;
11  TaskActive := SaveActive;
end;


Мельница данных ((раздел целиком))

Мельница данных- Класс TFormViewAction (Действие-форма) (раздел целиком) (22.10.2024) (одним файлом)
Класс TFormViewAction (Действие-форма)

Класс TAction (Действия)Класс TObject (Объекты)Класс TCustomView (Абстрактное представление)

Объекты класса образуют иерархию.

1. Свойства

Свойства класса TFormViewAction:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Shortcut | string[20] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TAction
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Separated | Boolean | Да | Видимо пользователю | Чтение/Запись
Default | Boolean | Да | Видимо пользователю | Чтение/Запись
FormView | TFormView | Да | Видимо пользователю | Чтение/Запись | Представление формы
View | TCustomView | Да | Видимо пользователю | Чтение/Запись | Представление
ShownClass | TClass | Да | Видимо пользователю | Только для чтения | Показываемый класс
OverrideMasterProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Подменить свойство-главное
OverrideDetailProperty | TClassMember | Нет | Видимо пользователю | Чтение/Запись | Подменить свойство-подчиненное

2. Конструктор Create (Конструктор действия-формы)

Конструктор класса TFormViewAction.

1constructor TFormViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  FormView: TFormView; OverrideMasterProperty: TProperty;
5  OverrideDetailProperty: TClassMember): TObject;

Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TAction.Create
Shortcut | string[20] | Нет
Separated | Boolean | Да
Default | Boolean | Да
FormView | TFormView | Да | Представление формы
OverrideMasterProperty | TProperty | Нет | Подменить свойство-главное свойством
OverrideDetailProperty | TClassMember | Нет | Подменить свойство-подчиненное свойством

Замечания:

Создает новый объект класса TFormViewAction.


Мельница данных ((раздел целиком))

Мельница данных- Класс TAsyncHandler (Обработчики отложенного выполнения) (раздел целиком) (22.10.2024) (одним файлом)
Класс TAsyncHandler (Обработчики отложенного выполнения)

Диаграмма Класс TObject (Объекты)Класс TAsyncHandlerAccess (Доступ к обработчикам отложенного выполнения)

1. Свойства

Свойства класса TAsyncHandler:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения | Доступен
Validator | TMethod | Нет | Видимо пользователю | Чтение/Запись | Процедура-валидатор
Handler | TRoutine | Нет | Видимо пользователю | Чтение/Запись | Процедура-обработчик

2. Конструктор Create (Конструктор обработчика отложенного выполнения)

Конструктор класса TAsyncHandler.

1constructor TAsyncHandler.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Validator: TMethod; Handler: TRoutine): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Validator | TMethod | Нет | Процедура-валидатор
Handler | TRoutine | Нет | Процедура-обработчик

Замечания:

Создает новый объект класса TAsyncHandler.

3. Метод GetIsAccessible (Доступен)

Метод экземпляра класса TAsyncHandler.

function TAsyncHandler.GetIsAccessible: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4. Метод ValidateInstantMessage (Доступен обработчик с уведомлением сообщением)

Метод класса (статический метод) класса TAsyncHandler.

class function TAsyncHandler.ValidateInstantMessage(Routine: TRoutine): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Routine | TRoutine | Да | Подпрограмма

Замечания:

Возвращает значение типа Boolean.

5. Метод ValidateWithoutNotification (Доступен обработчик без уведомления)

Метод класса (статический метод) класса TAsyncHandler.

class function TAsyncHandler.ValidateWithoutNotification(Routine: TRoutine): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Routine | TRoutine | Да | Подпрограмма

Замечания:

Возвращает значение типа Boolean.


Мельница данных ((раздел целиком))

Мельница данных- Класс TAsyncTaskParameterValue (Значения параметров задачи отложенного выполнения) (раздел целиком) (22.10.2024) (одним файлом)
Класс TAsyncTaskParameterValue (Значения параметров задачи отложенного выполнения)

Класс TTypedValue (Типизированные значения)Класс TObject (Объекты)Класс TAsyncTask (Задачи отложенного выполнения)

Объекты класса не именованы.

1. Свойства

Свойства класса TAsyncTaskParameterValue:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Нет | Скрыто от пользователя | Только для чтения | Унаследовано от TTypedValue
MasterClass | TClass | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TTypedValue
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
StrValue | string[2000] | Нет | Скрыто от пользователя | Чтение/Запись
IntValue | Integer | Нет | Скрыто от пользователя | Чтение/Запись
FloatValue | float | Нет | Скрыто от пользователя | Чтение/Запись
DateValue | date | Нет | Скрыто от пользователя | Чтение/Запись
TimeValue | time | Нет | Скрыто от пользователя | Чтение/Запись
DateTimeValue | datetime | Нет | Скрыто от пользователя | Чтение/Запись
ObjectValue | TObject | Нет | Скрыто от пользователя | Чтение/Запись
BoolValue | Boolean | Нет | Скрыто от пользователя | Чтение/Запись
BlobValue | blob | Нет | Видимо пользователю | Чтение/Запись
ClobValue | clob | Нет | Видимо пользователю | Чтение/Запись
ExternalDataValue | <external data> | Нет | Видимо пользователю | Чтение/Запись
VisibleValue | string[2000] | Нет | Видимо пользователю | Только для чтения
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись
Temporary | Boolean | Да | Видимо пользователю | Чтение/Запись | Временный объект

2. Конструктор Create (Конструктор значения параметров задачи отложенного выполнения)

Конструктор класса TAsyncTaskParameterValue.

1constructor TAsyncTaskParameterValue.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Domain: TDomain; Position: Integer;
4  Group: string[128]; Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]; IntValue: Integer; FloatValue: float; DateValue: date;
6  TimeValue: time; DateTimeValue: datetime; ObjectValue: TObject;
7  BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
8  ExternalDataValue: <external data>; Temporary: Boolean): TObject;

Переопределяет метод в TTypedValue.Create, TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Унаследовано от TTypedValue.Create
Position | Integer | Да
Group | string[128] | Нет
Tab | string[128] | Нет
Scope | TScope | Да
OutOfTabs | Boolean | Да
StrValue | string[2000] | Нет
IntValue | Integer | Нет
FloatValue | float | Нет
DateValue | date | Нет
TimeValue | time | Нет
DateTimeValue | datetime | Нет
ObjectValue | TObject | Нет
BoolValue | Boolean | Нет
BlobValue | blob | Нет
ClobValue | clob | Нет
ExternalDataValue | <external data> | Нет
Temporary | Boolean | Да | Временный объект

Замечания:

Создает новый объект класса TAsyncTaskParameterValue.

3. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TAsyncTaskParameterValue.

function TAsyncTaskParameterValue.SuggestFileName(Domain: TDomain): string[128];

Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя | Тип | Обязательно | Значение
Domain | TDomain | Нет | Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс ITableInfo2 (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс ITableInfo2

Интерфейс ITableInfoИнтерфейс INamedItemInfo

01type
02  ITableInfo2 = interface(ITableInfo)
03    ['{9DF4C8AC-1DA2-4E7B-BF44-7EDD7A269418}']
04    function Get_PolymorphCount: Integer; safecall;
05    function Get_PolymorphTable(Index: Integer): ITableInfo; safecall;
06    function Get_PolymorphField(Index: Integer): IFieldInfo; safecall;
07    property PolymorphCount: Integer read Get_PolymorphCount;
08    property PolymorphTable[Index: Integer]: ITableInfo read Get_PolymorphTable;
09    property PolymorphField[Index: Integer]: IFieldInfo read Get_PolymorphField;
10  end;

1. Свойства

Свойства интерфейса ITableInfo2:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения | Унаследовано от ITableInfo
FieldCount | Integer | Только для чтения
Parent | ITableInfo | Только для чтения
PrimaryKey | IFieldInfo | Только для чтения
RootAvailable | WordBool | Только для чтения
Uplink | IFieldInfo | Только для чтения
PolymorphCount | Integer | Только для чтения |
PolymorphField[Index: Integer] | IFieldInfo | Только для чтения |
PolymorphTable[Index: Integer] | ITableInfo | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Операции (раздел целиком) (22.10.2024) (одним файлом)
Операции

Операции связывают элементы выражений.

Таблица операций в порядке приоритета:
Левый операнд | Правый операнд
 | Целый | Вещест- венный | Дата | Время | Дата со временем | Логи- ческий | Строковый | Объект | nil
not
Нет | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
* (звездочка)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
/ (слэш, дробь)
Целый | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
div
Целый | Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
and
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
or
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
+ (плюс)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Дата | Дата со временем | Запрещено | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Время | Время | Дата со временем | Время | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Дата со временем | Дата со временем | Запрещено | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Строковый | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
- (минус)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Дата | Дата со временем | Целый | Дата со временем | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено
Время | Время | Время | Дата со временем | Время | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Дата со временем | Дата со временем | Вещест- венный | Дата со временем | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
=, <> (равно, не равно)
Целый | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Вещест- венный | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Дата | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Логи- ческий
Время | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Дата со временем | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Логи- ческий
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Логи- ческий
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Логи- ческий
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
<, >, <=, >= (меньше, больше, меньше либо равно, больше либо равно)
Целый | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
is
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
as
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Объект | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено

1. Особенности применения операций
  1. Приоритет сравнений ниже приоритета операций булевой логики. Поэтому выражение
    LObject.Master = LMaster and LObject.Parent = LParent
    будет интерпретироваться следующим образом:
    LObject.Master = (LMaster  and LObject.Parent) = LParent
    и вызовет ошибку компиляции из-за применения операции and к объектам. Необходимо писать:
    (LObject.Master = LMaster) and (LObject.Parent = LParent)
  2. Любое значение (выражение любого типа) сравнивается с безтиповой константой nil:
    1      LObject := any(TObject with Name = 'Some name');
2      if LObject = nil then
3         .....
  3. Операции "Унарный минус" не существует. Для задания отрицательных констант пользуйтесь конструкцией 0-Значение:
    Result := 0-1;


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IExternalContext (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IExternalContext

1type
2  IExternalContext = interface(IDispatch)
3    ['{EA2F1CDA-53F6-40E9-A2B7-0A80AB84D177}']
4    procedure Connect(const Database: WideString); safecall;
5  end;

1. Метод Connect

Метод интерфейса IExternalContext.

procedure IExternalContext.Connect(const Database: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Database | WideString | Да |


Мельница данных ((раздел целиком))

Мельница данных- Управление доступом пользователей (раздел целиком) (22.10.2024) (одним файлом)
Управление доступом пользователей

После того, как база данных создана и инициализирована метаданными платформы, доступ к системе будет иметь один пользователь - администратор созданной БД. Добавление других пользователей, ролей пользователей и включение пользователей в роли выполняется в представлениях Пользователи и Роли в Системной форме. После начальной инициализации БД на вкладке Пользователи можно увидеть одного пользователя с именем, соответствующим логину администратора БД (Например, для FireBird пользователь SYSDBA), на вкладке Роли можно увидеть одну роль с наименованием Администраторы. На подчиненных вкладках этих представлений можно увидеть, что пользователь - администратор включен в роль Администраторы.

Профиль пользователя формируется путем определения для него:

  1. Перечня доступных форм
  2. Перечня доступных визуальных групп
  3. Перечня групп запретов

Формирование профиля происходит одинаково как для роли, так и для отдельного пользователя. Однако рекомендуется формировать профили для ролей, а не для отдельных пользователей. В этом случае при подключении к системе новых пользователей, изменении параметров доступа для существующего пользователя достаточно будет включить пользователя в одну из ролей, или исключить его из роли. Роли рекомендуется формировать содержательным образом на основе распределения обязанностей реальных пользователей, работающих с прикладным решением.

1. Создание пользователей

Создание пользователя системы включает в себя два этапа:

  1. Создание пользователя БД средствами используемой СУБД. Для этого наряду с возможностями каждой из СУБД Утилитой обслуживания БД предлагается действие Создать пользователя. Предлагаемые Утилитой по умолчанию пути к БД и параметры доступа требуют уточнения в зависимости от условий функционирования реальной БД. Задавать права доступа пользователя к объектам БД на данном этапе не надо.
  2. В Системной форме на вкладке Пользователи создать нового пользователя при помощи соответствующего действия контекстного меню.
    В поле Имя нужно вветси строку, строго соответствующую логину пользователя БД в вернем регистре.
    Особых требований к полю Наименование не предъявляется. Однако рекомендуется вводить в это поле фамилию и имя реального пользователя системы, например, Смирнов Иван Николаевич, что позволить в последующем получать информативные данных об активности пользователей системы.

2. Создание ролей

Создание ролей производится на вкладке Роли Системной формы при помощи действия Создать, вызываемого из контекстного меню. Имя и наименование роли могут быть любыми строками. Однако именовать роли по названиям соответствющих функциональных участков системы, например,

  • Начальник отдела кадров
  • Инспектора по работе с личными данными персонала
  • Инспектора по социальным вопросам
В случаях, когда реальные пользователи совмещают несколько ролей, роли лучше формировать отдельно, после чего одного пользователя можно влючить одновременно в несколько ролей.

3. Включение пользователей в роли

В роль могут включаться как пользователи, так и другие роли. Для добавления в роль нового члена роли нужно выбрать роль на вкладке Роли, отрыть подчиненную вкладку Члены роли и вызвать на ней действие Создать. Поля формы параметров заполняются следующим образом:

  • Пользователь - в этом поле необходимо выбрать либо одного из пользователей, либо одну из ролей. В зависимости от того, выбран ли пользователь или роль, будет меняться доступность следующих ниже полей.
  • Основная роль - в этом поле можно установить значение Да или Нет. Если пользователь включен в нескольно ролей, то среди них можно выделить одну основную. Разработчик прикладного решения на платформе сможет использовать это значение для управления доступом к объектам системы. Поле доступно для выбора значения только в том случае, если в поле Пользователь выбран именно пользователь, а не роль.
  • Добавить связанные роли - в этом поле можно установить значение Да или Нет. Поле доступно для выбора значения только в том случае, если в поле Пользователь выбрана роль. При установке значения Да в роль будут включены также все роли, входящие в выбранную. при установке значения Нет будет включена только одна роль без подчиненных ролей.

После включения пользователя в роль он получает права доступа ко всем визуальным группам и формам, а также к группам запретов, заданным для роли.

4. Формирование перечня доступных визуальных групп

Визуальные группы создаются разработчиком прикладного решения. Работа с визуальными группами ведется в Системной форме на вкладке Визуальные группы. Каждая визуальная группа содержит набор форм и также может быть снабжена иконкой. Визуальные группы отображаются на Консоли управления, которая показывается при запуске системы.

Для каждой роли (или для отдельного пользователя) формируется перечень визуальных групп, которые будут ему доступны на Консоли управления. Если визуальных групп в прикладном решение не создано, или если пользователю не доступно ни одной визуальной группы, консоль управления не будет отображена. В этом случае при открытии системы пользователь увидит первую из доступных ему форм, которая открывается автоматически.

Для добавления новой визуальной группы, доступной роли или пользователю, необходимо выбрать роль или пользователя на соответствующей вкладке (Роли или Пользователи), отрыть подчиненное представление Доступные визуальные группы и выполнить в нем действие Создать. В форме параметров нужно выбрать одну из существующих визуальных групп. Если необходимо дать доступ к нескольким визуальным группам, действие создания нужно повторить.

Если пользователь включен в несколько ролей, то достаточно наличия доступа к визуальной группе в одной из этих ролей.

5. Формирование перечня доступных форм

Формы создаются разработчиком прикладного решения. Работа с визуальными группами ведется в Системной форме на вкладке Формы. Каждая форма представляет собой набор представлений, связанных друг с другом определенным образом. Иконки всех форм, доступных пользователю, отображаются на Панели инструментов в верхней части экрана. Нажимая на одну из иконок форм, пользователь может переключаться между ними. Если форма входит в одну из доступных пользователю визуальных групп, она отобразится на консоли управления. В этом случае переключаться между формами пользователь сможет как на Панели инструментов, так и на Консоли управления.

Для каждой роли (или для отдельного пользователя) формируется перечень форм, которые будут ему доступны на Консоли управления. При открытии системы пользователь видит первую из доступных ему форм, открываемую автоматически.

Для добавления новой формы, доступной роли или пользователю, необходимо выбрать роль или пользователя на соответствующей вкладке (Роли или Пользователи), отрыть подчиненное представление Доступные формы и выполнить в нем действие Создать. В форме параметров нужно выбрать одну из существующих форм. Если необходимо дать доступ к нескольким формам, действие создания нужно повторить.

Если пользователь включен в несколько ролей, то достаточно наличия доступа к форме в одной из этих ролей.

6. Формирование перечня групп запретов

Группы запретов могут формироваться как разработчиком прикладного решения, так и администратором системы. Работа с группами запретов ведется на соответствующей вкладке Системной формы. В каждую группу запретов включаются запреты трех видов:

  • Запрет на класс
  • Запрет на свойство
  • Запрет на подпрограмму

Запреты на класс и свойство могут даваться как только на запись, так и на чтение и запись объектов. Наличие запретов для определенной роли или пользователя приводит к тому, что пользователь не видит или не имеет прав на модификацю объетов определенных классов или отдельных их свойств. Запреты на подпрограммы выражаются в том, что для пользователя не отображаются действия, вызывающие ряд подпрограмм.


Мельница данных ((раздел целиком))

Мельница данных- Класс TTypedValueButton (Кнопки на форме редактирования значений) (раздел целиком) (22.10.2024) (одним файлом)
Класс TTypedValueButton (Кнопки на форме редактирования значений)

Диаграмма Класс TCustomButton (Кнопки)Класс TObject (Объекты)

1. Свойства

Свойства класса TTypedValueButton:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TCustomButton
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
TypedValue | TTypedValue | Нет | Видимо пользователю | Чтение/Запись | Связанное типизированное значение
ControlName | string[64] | Да | Видимо пользователю | Чтение/Запись | Идентификатор элемента управления

2. Конструктор Create (Конструктор кнопки формы редактирования значений)

Конструктор класса TTypedValueButton.

1constructor TTypedValueButton.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Group: string[128];
4  Tab: string[128]; Script: clob; Scope: TScope; OutOfTabs: Boolean;
5  TypedValue: TTypedValue): TObject;

Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TCustomButton.Create
Group | string[128] | Нет
Tab | string[128] | Нет
Script | clob | Нет
Scope | TScope | Да
OutOfTabs | Boolean | Да
TypedValue | TTypedValue | Нет | Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueButton.


Мельница данных ((раздел целиком))

Мельница данных- Класс TDependency (Зависимости) (раздел целиком) (22.10.2024) (одним файлом)
Класс TDependency (Зависимости)

Класс TObject (Объекты)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TDependency:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Dependent | TObject | Нет | Видимо пользователю | Чтение/Запись | Зависимый объект
DependentClass | TClass | Да | Видимо пользователю | Только для чтения | Класс зависимого объекта
DependentMaster | TObject | Да | Видимо пользователю | Только для чтения | Мастер зависимого объекта
DependentExternal | string[256] | Нет | Видимо пользователю | Чтение/Запись | Внешний зависимый объект
DependedOn | TObject | Да | Видимо пользователю | Чтение/Запись | Зависит от
DependedOnClass | TClass | Да | Видимо пользователю | Только для чтения | Класс объекта, от которого зависит
DependedOnMaster | TObject | Да | Видимо пользователю | Только для чтения | Мастер объекта, от которого зависит

2. Конструктор Create (Конструктор зависимости)

Конструктор класса TDependency.

1constructor TDependency.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Dependent: TObject; DependentExternal: string[256];
4  DependedOn: TObject): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Dependent | TObject | Нет | Зависимый объект
DependentExternal | string[256] | Нет | Внешний зависимый объект
DependedOn | TObject | Да | Зависит от

Замечания:

Создает новый объект класса TDependency.

3. Метод Install (Установить)

Метод класса (статический метод) класса TDependency.

1class procedure TDependency.Install(ADependent: TObject;
2  ADependentExternal: string[256]; ADependedOn: TObject);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
ADependent | TObject | Нет | Зависимый объект
ADependentExternal | string[256] | Нет | Внешний зависимый объект
ADependedOn | TObject | Да | Зависит от


Мельница данных ((раздел целиком))

Мельница данных- Класс TInstantMessage (Сообщения) (раздел целиком) (22.10.2024) (одним файлом)
Класс TInstantMessage (Сообщения)

Класс TObject (Объекты)Класс TUser (Пользователи)

Объекты класса не именованы.

1. Свойства

Свойства класса TInstantMessage:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Owner | TUser | Да | Видимо пользователю | Только для чтения | Владелец
User | TUser | Да | Видимо пользователю | Чтение/Запись | Пользователь
Message | string[255] | Да | Видимо пользователю | Только для чтения | Сообщение
DeliveryTime | datetime | Да | Видимо пользователю | Только для чтения | Время доставки
AttachmentType | TInstantMessageAttachmentType (None) | Да | Скрыто от пользователя | Только для чтения | Тип вложения

2. Конструктор Create (Конструктор сообщения)

Конструктор класса TInstantMessage.

1constructor TInstantMessage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Message: string[255]; DeliveryTime: datetime): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
User | TUser | Да | Пользователь
Message | string[255] | Да | Сообщение
DeliveryTime | datetime | Нет | Время доставки

Замечания:

Создает новый объект класса TInstantMessage.

3. Метод Archive (Отправить в архив)

Метод класса (статический метод) класса TInstantMessage.

1class procedure TInstantMessage.Archive(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По

4. Метод Clear (Очистить)

Метод класса (статический метод) класса TInstantMessage.

1class procedure TInstantMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Мельница данных ((раздел целиком))

Мельница данных- Класс TSystemMetadata (Системные метаданные) (раздел целиком) (22.10.2024) (одним файлом)
Класс TSystemMetadata (Системные метаданные)

Класс TObject (Объекты)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TSystemMetadata:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Data | clob | Нет | Видимо пользователю | Только для чтения | Данные
CRC | string[8] | Нет | Видимо пользователю | Только для чтения | Контрольная сумма

2. Метод Change (Изменение объекта)

Метод экземпляра класса TSystemMetadata.

procedure TSystemMetadata.Change(Action: TChangeAction);

Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Action | TChangeAction | Да | Унаследовано от TObject.Change

3. Метод InternalHash (Вычислить внутренний хеш)

Метод класса (статический метод) класса TSystemMetadata.

class function TSystemMetadata.InternalHash: string[128];

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].

4. Метод Store (Сохранить метаданные)

Метод класса (статический метод) класса TSystemMetadata.

class procedure TSystemMetadata.Store(Data: clob; CRC: string[8]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Data | clob | Нет | Данные
CRC | string[8] | Нет | Контрольная сумма


Мельница данных ((раздел целиком))

Мельница данных- Руководство разработчика для построителя запросов (раздел целиком) (22.10.2024) (одним файлом)
Руководство разработчика для построителя запросов

1. Информация о приложении
Приложение QueryBuilder представляет собой документ-ориентированное MDI-проиложение.
Документом является запрос. Запросы сохраняются в файле с расширением .MQR. Файлы запросов представляют собой xml-документы определенной структуры. Для доступа к данным БД приложение использует провайдеры данных - библиотеки объектов, реализующих опубликованные интерфейсы. Идентификатор использованного для построения запроса провайдера сохраняется в файле запроса. Если открыть файл с провайдером, не соответствующим текущему, будет выдано предупреждение.

2. Требования к провайдеру

Интерфейсы провайдера описаны в библиотеке типов файла QueryBuilder.exe и в файле QueryBuilder_TLB.pas. Собственно, объект-провайдер реализует Интерфейс IInfoProvider. Каждый CoClass, реализующий указанный интерфейс, прописывается в ветке реестра HKLM\Software\QueryBuilder\Providers добавлением параметра, имя которого определяет наименование провайдера, а значение - CLSID провайдера.

Метаданные (информация о таблицах, полях и типах данных) предоставляются в виде именованных элементов, то есть каждый из них реализует интерфейс INamedItemInfo

2.1. Интерфейс IInfoProvider
Провайдер реализует интерфейс
01  IInfoProvider = interface(IUnknown)
02    ['{64F8072B-7250-4C57-BA8E-D018C7B72CC7}']
03    function Get_TableCount: Integer; safecall;
04    function Get_Table(Index: Integer): ITableInfo; safecall;
05    function Perform(const SQL: WideString): IDataSet; safecall;
06    procedure Connect(const DataBase: WideString;
07      const UserName: WideString;
08      const Password: WideString); safecall;
09    function Get_CLSID: TGUID; safecall;
10    function Get_DateLiteral: WideString; safecall;
11    function Get_TimeLiteral: WideString; safecall;
12    function Get_DateTimeLiteral: WideString; safecall;
13  end;
  • функция Get_CLSID возвращает GUID класса-провайдера.
  • процедура Connect осуществляет соединение с БД.
  • функция Get_TableCount возвращает количество таблиц, доступ к которым предоставляется провайдером.
  • функция Get_Table возвращает ссылку на информацию о таблице с номером Index. Ссылка на интерфейс ITableInfo или интерфейс ITableInfo2
  • функция Perform принимает текст сформированного SQL-запроса и возвращает ссылку на набор данных. Набор данных реализует интерфейс IDataSet.
  • функция Get_DateLiteral возвращает строку, определяющую способ включения в запрос литерала типа "Дата".
  • функция Get_TimeLiteral возвращает строку, определяющую способ включения в запрос литерала типа "Время".
  • функция Get_DateTimeLiteralвозвращает строку, определяющую способ включения в запрос литерала типа "Дата со временем".

2.2. Интерфейс IDataSet
Набор данных реализует интерфейс
1   IDataSet = interface(IUnknown)
2    ['{3CED7395-8482-4EF6-8A15-7744348063C2}']
3    function Get_FieldCount: Integer; safecall;
4    function Get_FieldName(Index: Integer): WideString; safecall;
5    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
6    procedure Next; safecall;
7    function Eof: WordBool; safecall;
8  end;
Набор данных представляет собой однонаправленный курсор, каждая строка которого является набором именованных и нумерованных полей.
  • процедура Next осуществляет переход к следующей записи курсора.
  • функция Eof возвращает True в случае достижения конца курсора.
  • функция Get_FieldCount возвращает количество полей в строке курсора.
  • функция Get_FieldName возвращает имя поля с номером Index.
  • функция Get_Field возвращает значение поля, имя или номер которого задан параметром (если строка, то имя, если число, то номер). Допустимо возвращать значение Null для пустых полей.

2.3. Интерфейс INamedItemInfo
Каждый элемент метаданных (таблица, поле, тип) обязательно реализует интерфейс
1  INamedItemInfo = interface(IUnknown)
2    ['{14894363-28DA-4E71-B0BC-9C5CE811BC8F}']
3    function Get_Name: WideString; safecall;
4    function Get_Caption: WideString; safecall;
5    function Get_ID: WideString; safecall;
6  end;

Именованный элемент имеет имя, наименование и идентификатор. Имя используется для именования сущности в сформированном SQL-запросе, идентификатор необходим для идентификации сущности в рамках провайдера, таблицы и типы данных имеют глобальное пространство идентификаторов, поля имеют уникальные идентификаторы в пределах последовательности наследуемых таблиц. Никаких ограничений на значения идентификаторов, кроме уникальности, не накладывается.

  • функция Get_Name возвращает имя сущности.
  • функция Get_Caption возвращает наименование сущности.
  • функция Get_ID возвращает идентификатор сущности.

2.4. Интерфейс ITableInfo
Информация о таблице представляется объектом через интерфейс (наследник INamedItemInfo )
1  ITableInfo = interface(INamedItemInfo)
2    ['{3FC1998A-9031-4936-82B5-8CAA2219085E}']
3    function Get_FieldCount: Integer; safecall;
4    function Get_Field(Index: Integer): IFieldInfo; safecall;
5    function Get_PrimaryKey: IFieldInfo; safecall;
6    function Get_Uplink: IFieldInfo; safecall;
7    function Get_Parent: ITableInfo; safecall;
8  end;
  • функция Get_FieldCount возвращает количество полей в таблице.
  • функция Get_Field возвращает ссылку на поле с номером Index. Ссылка на интерфейс IFieldInfo
  • функция Get_PrimaryKey возвращает ссылку на поле, являющееся первичным ключем. Это поле должно быть задано.
  • функция Get_Uplink возвращает ссылку на поле, осуществляющее иерархическую связь между записями таблицы. Если это поле задано, записи отображаются в виде иерархии.
  • функция Get_Parent возвращает ссылку на родительскую таблицу. Дочерняя таблица связана с родительской первичными ключами, т. е. соотношением 1:1. Если таблица не имеет родительской, возвращается nil.

2.4.1. Интерфейс ITableInfo2
Для таблиц, имеющих полиморфные ссылки, реализуется интерфейс (наследник ITableInfo )
1  ITableInfo2 = interface(ITableInfo)
2    ['{9DF4C8AC-1DA2-4E7B-BF44-7EDD7A269418}']
3    function Get_PolymorphCount: Integer; safecall;
4    function Get_PolymorphTable(Index: Integer): ITableInfo; safecall;
5    function Get_PolymorphField(Index: Integer): IFieldInfo; safecall;
6  end;
Полиморфной ссылкой является, например, ссылка, физически размещенная в родительской таблице, указывающая на свою запись. Реализация этого интерфейса не является обязательной.
  • функция Get_PolymorphCount возвращает количество полиморфных ссылок.
  • функция Get_PolymorphTable возвращает ссылку на таблицу, на которую указывает полиморфная ссылка номер Index.
  • функция Get_PolymorphTable возвращает ссылку на поле, реализующее полиморфную ссылку номер Index. Это поле должно иметь тип dtReference, информация о его типе должна реализовать интерфейс IReferenceInfo. Значение, возвращаемое функцией Get_TargetTable этого интерфейса в данном случае не имеет значения и игнорируется.

2.4.2. Интерфейс ITableInfo3
Для таблиц, при запросах к которым требуется наложение дополнительных условий отбора, реализуется интерфейс (наследник ITableInfo )
01  ITableInfo3 = interface(ITableInfo)
02    ['{3FB73AA9-010C-48DA-81C7-E1DCFE2E6136}']
03    function GetPersistentClause(const Alias: WideString): WideString; safecall;
04    function GetPreConditionsCount: Integer; safecall;
05    function GetPreConditionCaption(Index: Integer): WideString; safecall;
06    function GetPreConditionCategory(Index: Integer): WideString; safecall;
07    function Get_ActivePreCondition(Index: Integer): WordBool; safecall;
08    procedure Set_ActivePreCondition(Index: Integer; Value: WordBool); safecall;
09    function GetPreConditionParamsCount(Index: Integer): Integer; safecall;
10    function GetPreConditionParam(Index: Integer; PreConditionIndex: Integer): IOptionInfo; safecall;
11  end;
  • функция GetPersistentClause возвращает выражение дополнительного условия отбора. Алиас таблицы передается в параметре Alias.

2.5. Интерфейс IFieldInfo
Информация о поле поставляется объектом, реализующим интерфейс (наследник INamedItemInfo )
1  IFieldInfo = interface(INamedItemInfo)
2    ['{19054DAD-8D35-4B39-8EB7-FD3254BD2934}']
3    function Get_TypeInfo: ITypeInfo; safecall;
4    function Get_DisplayMode: TDisplayMode; safecall;
5  end;
  • функция Get_DisplayMode возвращает роль поля при показе таблицы. Возможные значения (тип TDisplayMode):
    • dmAlways - поле является ключевым, всегда показывается
    • dmNever - поле является служебным (первичным ключем, например). Никогда не показывается.
    • dmOnDemand - поле является обычным информационным, показывается по требованию пользователя.
  • функция Get_TypeInfo возвращает ссылку на информацию о типе данных поля. Возвращаете ссылку на один из интерфейсов-наследников интерфейса ITypeInfo

2.6. Интерфейс ITypeInfo
Информация о типах полей поставляется в виде набора объектов, каждый из которых реализует интерфейс (наследник INamedItemInfo )
1  ITypeInfo = interface(INamedItemInfo)
2    ['{2B6A5E20-3C36-4574-89DB-7C873A5C4A00}']
3    function Get_Required: WordBool; safecall;
4    function Get_SimpleType: TSimpleType; safecall;
5  end;
Информация о конкретном типе передается при помощи реализации одного из наследников этого интерфейса.
  • функция Get_Required возвращает True, если значение поля обязательно для задания.
  • функция Get_SimpleType возвращает информацию о простом типе данных. В зависимости от возвращаемого значения объект должен также реализовывать один из интерфейсов конкретных типов (см. далее). Возможные значения (тип TSimpleType ):
    • dtString - строковый тип. Обязательно реализуется интерфейс IStringInfo
    • dtInteger - целочисленный тип. Обязательно реализуется интерфейс IIntegerInfo
    • dtFloat - вещественный тип. Обязательно реализуется интерфейс IFloatInfo
    • dtDate - тип "дата". Обязательно реализуется интерфейс IDateInfo
    • dtTime - тип "время". Обязательно реализуется интерфейс ITimeInfo
    • dtDateTime - тип "дата со временем". Обязательно реализуется интерфейс IDateTimeInfo
    • dtBoolean - логический тип. Обязательно реализуется интерфейс IBooleanInfo
    • dtEnumeration - перечисление. Обязательно реализуется интерфейс IEnumerationInfo
    • dtReference - ссылка. Обязательно реализуется интерфейс IReferenceInfo
    • dtBlob - Большой двоичный объект. Обязательно реализуется интерфейс IBlobInfo.

2.6.1. Интерфейс ITypeInfo2
Информация о предоставляемых провайдером дополнительных возможностях фильтрации (наследник интерфейса ITypeInfo)
1  ITypeInfo2 = interface(ITypeInfo)
2    ['{77F58BDF-F01C-40F3-B193-1027AD8C4EDA}']
3    function GetSpecialFilterCount: Integer; safecall;
4    function GetSpecialFilterText(Index: Integer): WideString; safecall;
5    function EditSpecialFilter(Index: Integer; var Filter: WideString): WordBool; safecall;
6  end;
  • функция GetSpecialFilterCount возвращает количество дополнительных элементов списка, выпадающего при выборе фильтра по колонке.
  • функция GetSpecialFilterText возвращает текст дополнительного элемента списка, выпадающего при выборе фильтра по колонке, с номером Index.
  • функция EditSpecialFilter вызывается в момент выбора пользователем дополнительного элемента списка, выпадающего при выборе фильтра по колонке, с номером Index. Значение выражения фильтра передается и возвращается в параметре Filter. Функция возвращает True в случае, если выражение, возвращенное в параметре Filter нужно применить для фильтрации столбца запроса, False - в противном случае.

2.6.2. Интерфейс IStringInfo
Информация о строковом типе (наследник интерфейса ITypeInfo)
1  IStringInfo = interface(ITypeInfo)
2    ['{74AC4C03-E803-421B-B30D-1A2D2C49827F}']
3    function Get_Length: Integer; safecall;
4  end;
  • функция Get_Length возвращает максимальную длину строки.

2.6.3. Интерфейс IIntegerInfo
Информация о целочисленном типе (наследник интерфейса ITypeInfo)
1  IIntegerInfo = interface(ITypeInfo)
2    ['{9003B25E-926D-42AE-A907-813DF3A8343E}']
3    function Get_MaxValue: Integer; safecall;
4    function Get_MaxValueUsed: WordBool; safecall;
5    function Get_MinValue: Integer; safecall;
6    function Get_MinValueUsed: WordBool; safecall;
7  end;
  • функция Get_MaxValueUsed возвращает True, если значение имеет верхнюю границу.
  • функция Get_MaxValue возвращает верхнюю границу значения, если есть.
  • функция Get_MinValueUsed возвращает True, если значение имеет нижнюю границу.
  • функция Get_MinValue возвращает нижнюю границу значения, если есть.

2.6.4. Интерфейс IFloatInfo
Информация о вещественном типе (наследник интерфейса ITypeInfo )
1  IFloatInfo = interface(ITypeInfo)
2    ['{E9B56C6D-47DC-4AB9-9E80-6EEF77708704}']
3    function Get_MaxValue: Double; safecall;
4    function Get_MaxValueUsed: WordBool; safecall;
5    function Get_MinValue: Double; safecall;
6    function Get_MinValueUsed: WordBool; safecall;
7    function Get_Precision: Integer; safecall;
8    function Get_Scale: Integer; safecall;
9  end;
  • функция Get_MaxValueUsed возвращает True, если значение имеет верхнюю границу.
  • функция Get_MaxValue возвращает верхнюю границу значения, если есть.
  • функция Get_MinValueUsed возвращает True, если значение имеет нижнюю границу.
  • функция Get_MinValue возвращает нижнюю границу значения, если есть.
  • функция Get_Precision возвращает максимальное количество значащих десятичных цифр в значении.
  • функция Get_Scale возвращает максимальное количество десятичных цифр после запятой.

2.6.5. Интерфейс IDateInfo
Информация о типе "Дата" (без времени) (наследник интерфейса ITypeInfo )
1  IDateInfo = interface(ITypeInfo)
2    ['{DA392510-105F-4655-9A38-18ECA2FBEB97}']
3  end;
Не имеет методов.

2.6.6. Интерфейс ITimeInfo
Информация о типе "Время" (без даты) (наследник интерфейса ITypeInfo )
1  ITimeInfo = interface(ITypeInfo)
2    ['{D7067CAC-67A5-41DB-8D95-40409D8658AB}']
3  end;
Не имеет методов.

2.6.7. Интерфейс IDateTimeInfo
Информация о типе "Дата со времемем" (наследник интерфейса ITypeInfo )
1  IDateTimeInfo = interface(ITypeInfo)
2    ['{7F5CC8F9-8CE1-4DB7-8932-884EF3BAB538}']
3  end;
Не имеет методов.

2.6.8. Интерфейс IBooleanInfo
Информация о логическом типе (наследник интерфейса ITypeInfo )
1  IBooleanInfo = interface(ITypeInfo)
2    ['{8256EDF9-8613-4970-850C-50047839D6BF}']
3    function Get_TrueValue: WideString; safecall;
4    function Get_FalseValue: WideString; safecall;
5  end;
  • функция Get_TrueValue возвращает отображаемую строку для значения True (например, "Да").
  • функция Get_FalseValue возвращает отображаемую строку для значения False (например, "Нет").

2.6.9. Интерфейс IEnumerationInfo
Информация о перечислимом типе (наследник интерфейса ITypeInfo )
1  IEnumerationInfo = interface(ITypeInfo)
2    ['{B58A3F23-1AAC-4420-ADFF-B23B9938A994}']
3    function Get_ItemCount: Integer; safecall;
4    function Get_Item(Index: Integer): IEnumerationItem; safecall;
5  end;
Перечислимый тип определяет набор значений, которые может принимать поле. Значения в таблице трактуются как равные имени элемента перечисления.
  • функция Get_ItemCount возвращает количество элементов перечисления.
  • функция Get_Item возвращает ссылку на элемент перечисления с номером Index, реализующий интерфейс IEnumerationItem

2.6.10. Интерфейс IReferenceInfo
Информация о типе "ссылка" (наследник интерфейса ITypeInfo )
1  IReferenceInfo = interface(ITypeInfo)
2    ['{309C8CB1-4A1C-4E58-BC3F-D1AF27861A8F}']
3    function Get_TargetTable: ITableInfo; safecall;
4  end;
  • функция Get_TargetTable возвращает ссылку на таблицу, с которой осуществляется связь. Возвращается ссылка на интерфейс ITableInfo

2.6.11. Интерфейс IBlobInfo
Информация о типе "больших двоичных объектов" (наследник интерфейса ITypeInfo )
1  IBlobInfo = interface(ITypeInfo)
2    ['{3905C9C4-EAEB-4844-BB55-3F524F1F3FAC}']
3    function Get_SubType: TBlobSubType; safecall;
4  end;
  • функция Get_SubType возвращает подтип большого двоичного объекта. Одно из следующих значений (тип TBlobSubType ):
    • bsText - текст
    • bsImage - изображение
    • bsBinary - двоичные данные

2.7. Интерфейс IEnumerationItem
Информация об элементе перечисления (наследник INamedItemInfo )
1  IEnumerationItem = interface(INamedItemInfo)
2    ['{6953507C-D477-4B8D-9443-A9E5FE7137ED}']
3    function Get_Position: Integer; safecall;
4  end;
Значения в таблице трактуются как равные имени элемента перечисления.
  • функция Get_Position возвращает позицию элемента перечисления.

3. Использование провайдера БД Парус8

3.1. Использование пользовательских приложений.
Библиотека ParusInfoProvider.dll содержит реализацию провайдера для БД Парус8. Провайдер реализует, в дополнение к обязательным, интерфейс, позволяющий управлять им посредством механизма "Пользовательских приложений":
1  IParusProvider = interface(IDispatch)
2    ['{4864AE99-80E6-4FC6-9DB0-EAB248F72362}']
3    procedure Connect(const Database: WideString;
4      const UserName: WideString;
5      const Password: WideString); safecall;
6    property QueryObject: OleVariant;
7    property StoredProcObject: OleVariant;
8  end;
Объект-провайдер может установить связь с БД либо самостоятельно с использованием переданных в метод Connect параметров соединения, либо с помощью объектов Query и StoredProc , предоставляемых системой Парус8 для использования в пользовательских приложениях. В свою очередь, созданный провайдер с установленным соединением может быть передан в метод Execute объекта QueryBuilder.Application . Вторым параметром может быть передано значение, представляющее структуру запроса. Это может быть либо строка с указанием имени файла, либо объект, реализующий интерфейс IStream (например, MSXML.DOMDocument ), либо строка, представляющая собой xml-документ. Все средства манипуляции структурой и поведением запроса предоставляются на уровне работы с xml-документом, описывающим запрос.
Пример скрипта пользовательского приложения на DelphiScript
01procedure QueryBuilderTest;
02var
03  LApplication: OleVarint;
04  LProvider: OleVarint;
05  LDocument: OleVariant;
06begin
07  //описание структуры запроса. Из BLOB, из файла, из строки - откуда угодно
08  LDocument := CreateOleObject('MSXML.DOMDocument');
09  //LDocument реализует IXMLDOMDocument и IStream
10  LDocument.loadXML('<Query Provider="{B3079C97-6EBC-43EB-880F-58F094B322B0}">' +
11    '<Item Type="Table" Table="AGNLIST" Alias="MAIN" TableAlias="MAIN">'  +
12      '<Item ColumnIndex="0" Type="Field" Field="AGNABBR" Table="AGNLIST" ' +
13        'Alias="MAIN_AGNABBR" TableAlias="MAIN"/>' +
14      '<Item ColumnIndex="1" Type="Field" Field="VERSION" Table="AGNLIST" ' +
15        'Alias="MAIN_VERSION" TableAlias="MAIN"/>' +
16    '</Item>' +
17  '</Query>');
18
19  //Скрытие дерева структуры
20  LDocument.documentElement.setAttribute('TreeWidth', 0);
21
22  //Наложение условий отбора на колонку
23  LDocument.selectSingleNode('/*/Item/Item[@Field="AGNABBR" and @Table="AGNLIST"]').
24    setAttribute('ColumnFilter', 'Б*');
25
26  //Переименование колонки
27  LDocument.selectSingleNode('/*/Item/Item[@Field="VERSION" and @Table="AGNLIST"]').
28    setAttribute('Caption', 'Версия');
29
30
31  //создание провайдера и передача ему объектов для соединения с БД
32  LProvider := CreateOleObject('ParusInfoProvider.ParusProvider');
33  LProvider.QueryObject := Query;
34  LProvider.StoredProcObject := StoredProc;
35
36  //создание и использование объекта-приложения QueryBuilder
37  LApplication := CreateOleObject('QueryBuilder.Application');
38
39  //В качестве второго параметра передается ОБЪЕКТ, через
40  //   IStream содержащий структуру запроса
41  LApplication.Execute(LProvider, LDocument);
42  LApplication.Visible := True;
43
44  //Ожидание завершения работы с приложением
45  repeat
46    Application.ProcessMessages;
47  until not LApplication.Visible;
48
49end;
50
Интерфейс автоматизации поддерживает также метод для автоматического применения шаблона для переноса в Excel.
Допустим, .MQR-файл, описывающий запрос, содержащий шаблон с именем "Простой Перенос" загружен в раздел "Модули пользовательских приложений" с мнемокодом "QueryData". Для этого необходимо создать модуль пользовательского приложения с типом "COM-сервер" или "Надстройка Excel" и загрузить из файла .MQR-файл. Проверки соответствия формата загружаемого файла заявленному типу модуля пользовательского приложения Парус не производит, что позволяет воспользоваться этим трюком. Тогда:
01procedure QueryBuilderTemplateTest;
02var
03  LApplication: OleVarint;
04  LProvider: OleVarint;
05  S: string;
06begin
07  Query.SQL.Text := 'select BMODULE from V_UAMODULES where SCODE = :CODE';
08  //мнемокод модуля пользовательского приложения, содержащего
09  //загруженный .MQR-файл
10  Query.ParamByName('CODE').Value := 'QueryData';
11  Query.Open;
12  S := Query.FieldByName('BMODULE').AsString;
13  Query.Close;
14
15 //создание провайдера и передача ему объектов для соединения с БД
16  LProvider := CreateOleObject('ParusInfoProvider.ParusProvider');
17  LProvider.QueryObject := Query;
18  LProvider.StoredProcObject := StoredProc;
19
20  //создание и использование объекта-приложения QueryBuilder
21  LApplication := CreateOleObject('QueryBuilder.Application');
22
23  //В качестве второго параметра передается СТРОКА, содержащая xml с описанием
24  //структуры запроса и шаблоны для переноса в Excel
25  LApplication.ExecuteTemplate(LProvider, S, 'Простой Перенос');
26end;

3.2. Информация о базе данных
Провайдер Парус8 предоставляет информацию о четырех типах таблиц:
  1. Представление, описанное при помощи метаданных Парус8 как "вызываемое с клиента". В этом случае полями таблицы являются описанные атрибуты класса с соответствующими типами.
  2. Таблица, имеющая клиентский доступ и связанная с разделом, не имеющим ни одного описанного доступного представления, но имеющим описанные физические атрибуты. Информация о полях берется из метаданных Парус8
  3. Таблица, имеющая клиентский доступ и связанная с разделом, не имеющим ни одного описанного доступного представления, и не имеющим описанных атрибутов. Информация о полях берется из метаданных Oracle.
  4. Таблица, имеющая клиентский доступ и не связанная ни с каким разделом. Информация о полях берется из метаданных Oracle.

4. Разработка шаблонов

Шаблон представляет собой обычную рабочую книгу Excel.

Шаблоны для переноса данных в Excel физически интегрируются внутрь .MQR-файла и хранятся вместе с запросом. Разработку шаблона можно вести независимо, используя только Microsoft Excel (запуская его самостоятельно), а потом загрузить в файл запроса, а можно воспользоваться пунктом меню "Редактировать" на странице "Шаблоны".

Для взаимодействия с источником данных рабочая книга-шаблон должна содержать в любом модуле макрос с именем "Template" (без кавычек) с одним параметром. При выполнении переноса данных по этому шаблону QueryBuilder произведет вызов этого метода, передав в качестве фактического значения параметра объект, реализующий интерфейс IExternalQuery. Никаких других требований к рабочей книге-шаблону не выдвигается.
В примере показан запрос на таблицу AGNLIST (провайдер Oracle), показывающий как простой перенос данных, так и сводную таблицу со сводной диаграммой распределения записей таблицы по полю CRN.
Пример запроса с шаблонами
В примере показан запрос на таблицу "TField" (провайдер Мельницы Данных), показывающий как простой перенос данных, так и сводную таблицу со сводной диаграммой распределения записей таблицы.
Пример запроса с шаблонами для Мельницы Данных`

4.1. Интерфейс IExternalQuery
Объект, реализующий этот интерфейс, передается в макрос генерации отчета Excel (Template). Все его свойства и методы доступны для испоьзования в процессе генерации отчета
01  IExternalQuery = interface(IDispatch)
02    ['{1A86D1DA-A56E-4D53-88F9-7A035D7D12B4}']
03    function Select(const SQL: WideString): IExternalDataSet; safecall;
04    function SelectedRecordsCount: Integer; safecall;
05    function SelectedRecord(Index: Integer): OleVariant; safecall;
06    procedure PlaceCurrentQuery(const Sheet: IDispatch;
07      CaptionsNeeded: WordBool = False; Row: Integer = 1;
08      Column: Integer = 1; ShiftRows: WordBool = True;
09      ShiftColumns: WordBool = False); safecall;
10    procedure PlaceQuery(const Sheet: IDispatch; const DataSet: ExternalDataSet;
11      Row: Integer = 1; Column: Integer = 1; ShiftRows: WordBool = True;
12      ShiftColumns: WordBool = False); safecall;
13    property CurrentQuery: WideString;
14  end;
  • функция Select возвращает объект, реализующий интерфейс IExternalDataSet с данными, полученными в результате запроса, заданного параметром SQL. Фактически метод является оберткой метода Perform объекта-провайдера IInfoProvider
  • функция SelectedRecordsCount возвращает количество записей, отмеченных пользователем в гриде в момент выгрузки в Excel
  • функция SelectedRecord возвращает первичный ключ отмеченной пользователем записи с номером Index
  • процедура PlaceCurrentQuery осуществляет перенос в указанное положение указанного рабочего листа данных текущего табличного представления. Параметр Sheet указывает на рабочий лист Excel, на который будет осуществляться перенос, параметр CaptionsNeeded определяет необходимость переноса заголовков колонок, параметры Row и Column определяют соответственно номер строки и столбца на рабочем листе Excel, начиная с которых будут расположены данные. Параметр ShiftRows определяет необходимость сдвига строк вниз при переносе данных (информация в ячейках, лежащих НИЖЕ строки, определенной параметром Row, будет либо затерта, либо сдвинута на требуемое число строк вниз. Параметр ShiftColumns определяет необходимость сдвига колонок вправо при переносе данных (информация в ячейках, лежащих ПРАВЕЕ столбца, определенного параметром Column, будет либо затерта, либо сдвинута на требуемое число строк вниз.
  • процедура PlaceQuery осуществляет перенос в указанное положение указанного рабочего листа данных заданного параметром DataSet набора данных. Параметр Sheet указывает на рабочий лист Excel, на который будет осуществляться перенос, параметр CaptionsNeeded определяет необходимость переноса заголовков колонок, параметры Row и Column определяют соответственно номер строки и столбца на рабочем листе Excel, начиная с которых будут расположены данные. Параметр ShiftRows определяет необходимость сдвига строк вниз при переносе данных (информация в ячейках, лежащих НИЖЕ строки, определенной параметром Row, будет либо затерта, либо сдвинута на требуемое число строк вниз. Параметр ShiftColumns определяет необходимость сдвига колонок вправо при переносе данных (информация в ячейках, лежащих ПРАВЕЕ столбца, определенного параметром Column, будет либо затерта, либо сдвинута на требуемое число строк вниз.
  • свойство CurrentQuery возвращает строку запроса, на основе которого постоено текущее табличное представление.

4.2. Интерфейс IExternalDataSet
Фактически, обертка над интерфейсом IDataSet .
1  IExternalDataSet = interface(IDispatch)
2    ['{CDC7992C-BB30-431C-9F81-3215175AD5AB}']
3    procedure Next; safecall;
4    function Eof: WordBool; safecall;
5    property FieldCount: Integer;
6    property FieldName[Index: Integer]: WideString;
7    property Field[FieldIndex: OleVariant]: OleVariant;
8  end;
Набор данных представляет собой однонаправленный курсор, каждая строка которого является набором именованных и нумерованных полей.
  • процедура Next осуществляет переход к следующей записи курсора.
  • функция Eof возвращает True в случае достижения конца курсора.
  • свойство FieldCount возвращает количество полей в строке курсора.
  • свойство FieldName возвращает имя поля с номером Index.
  • свойство Field возвращает значение поля, имя или номер которого задан параметром (если строка, то имя, если число, то номер). Допустимо возвращать значение Null для пустых полей.

5. Интерфейс автоматизации
Взаимодействие внешних приложений с QueryBuilder'ом осуществляется при помощи интерфейса
1  IApplication = interface(IDispatch)
2    ['{0E59D500-7A6A-43CA-8007-B7BB7E393CD4}']
3    procedure Execute(const Provider: IUnknown; var Query: OleVariant); safecall;
4    procedure ExecuteTemplate(const Provider: IUnknown; var Query: OleVariant;
5      const TemplateName: WideString); safecall;
6    property Visible: WordBool;
7  end;
  • Свойство Visible определяет видимость приложения
  • Процедура Execute осуществляет выполнение запроса. Первым параметром является объект-провайдер (созданный заранее внешним образом и установивший соединение с БД также заранее). Вторым параметром может быть передано значение, представляющее структуру запроса. Это может быть либо строка с указанием имени файла, либо объект, реализующий интерфейс IStream (например, MSXML.DOMDocument ), либо строка, представляющая собой xml-документ. Все средства манипуляции структурой и поведением запроса предоставляются на уровне работы с xml-документом, описывающим запрос.
  • Процедура ExecuteTemplate осуществляет выполнение запроса и применяет к результатам шаблон с именем, переданным в параметре TemplateName. Первые два параметра аналогичны параметрам метода Execute
Интерфейс автоматизации может быть использован в тех случаях, когда необходима интергация QueryBuilder'a в третьестороннюю информационную систему.

6. Справочник по интерфейсам

6.1. Перечисление TAggregateType
1type
2  TAggregateType = (atCount, atSumm, atAverage, atMinimum, atMaximum, atAny,
3    atAll, atCountDistinct);

Или

01type
02  TAggregateType = TOleEnum;
03const
04  atCount = $00000000;
05  atSumm = $00000001;
06  atAverage = $00000002;
07  atMinimum = $00000003;
08  atMaximum = $00000004;
09  atAny = $00000005;
10  atAll = $00000006;
11  atCountDistinct = $00000007;

Элементы перечисления:

Имя | Значение | Назначение
atCount | 0 |
atSumm | 1 |
atAverage | 2 |
atMinimum | 3 |
atMaximum | 4 |
atAny | 5 |
atAll | 6 |
atCountDistinct | 7 |

6.2. Перечисление TBlobSubType
1type
2  TBlobSubType = (bsText, bsImage, bsBinary);

Или

1type
2  TBlobSubType = TOleEnum;
3const
4  bsText = $00000000;
5  bsImage = $00000001;
6  bsBinary = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
bsText | 0 |
bsImage | 1 |
bsBinary | 2 |

6.3. Перечисление TDisplayMode
1type
2  TDisplayMode = (dmAlways, dmNever, dmOnDemand);

Или

1type
2  TDisplayMode = TOleEnum;
3const
4  dmAlways = $00000000;
5  dmNever = $00000001;
6  dmOnDemand = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
dmAlways | 0 |
dmNever | 1 |
dmOnDemand | 2 |

6.4. Перечисление TSimpleType
1type
2  TSimpleType = (dtString, dtInteger, dtFloat, dtDate, dtTime, dtDateTime,
3    dtBoolean, dtEnumeration, dtReference, dtBlob);

Или

01type
02  TSimpleType = TOleEnum;
03const
04  dtString = $00000000;
05  dtInteger = $00000001;
06  dtFloat = $00000002;
07  dtDate = $00000003;
08  dtTime = $00000004;
09  dtDateTime = $00000005;
10  dtBoolean = $00000006;
11  dtEnumeration = $00000007;
12  dtReference = $00000008;
13  dtBlob = $00000009;

Элементы перечисления:

Имя | Значение | Назначение
dtString | 0 |
dtInteger | 1 |
dtFloat | 2 |
dtDate | 3 |
dtTime | 4 |
dtDateTime | 5 |
dtBoolean | 6 |
dtEnumeration | 7 |
dtReference | 8 |
dtBlob | 9 |

6.5. Интерфейс IApplication

01type
02  IApplication = interface(IDispatch)
03    ['{0E59D500-7A6A-43CA-8007-B7BB7E393CD4}']
04    procedure Execute(const Provider: IUnknown; const Query: OleVariant); safecall;
05    function Get_Visible: WordBool; safecall;
06    procedure Set_Visible(Value: WordBool); safecall;
07    procedure ExecuteTemplate(const Provider: IUnknown; const Query: OleVariant;
08      const TemplateName: WideString); safecall;
09    property Visible: WordBool read Get_Visible write Set_Visible;
10  end;

6.5.1. Свойства

Свойства интерфейса IApplication:

Имя | Тип | Доступ | Назначение
Visible | WordBool | Чтение/Запись |

6.5.2. Метод Execute

Метод интерфейса IApplication.

1procedure IApplication.Execute(const Provider: IUnknown;
2  const Query: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Provider | IUnknown | Да |
Query | OleVariant | Да |

6.5.3. Метод ExecuteTemplate

Метод интерфейса IApplication.

1procedure IApplication.ExecuteTemplate(const Provider: IUnknown;
2  const Query: OleVariant; const TemplateName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Provider | IUnknown | Да |
Query | OleVariant | Да |
TemplateName | WideString | Да |

6.6. Интерфейс IBlobInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IBlobInfo = interface(ITypeInfo)
3    ['{3905C9C4-EAEB-4844-BB55-3F524F1F3FAC}']
4    function Get_SubType: TBlobSubType; safecall;
5    property SubType: TBlobSubType read Get_SubType;
6  end;

6.6.1. Свойства

Свойства интерфейса IBlobInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
SubType | TBlobSubType | Только для чтения |

6.7. Интерфейс IBooleanInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IBooleanInfo = interface(ITypeInfo)
3    ['{8256EDF9-8613-4970-850C-50047839D6BF}']
4    function Get_TrueValue: WideString; safecall;
5    function Get_FalseValue: WideString; safecall;
6    property TrueValue: WideString read Get_TrueValue;
7    property FalseValue: WideString read Get_FalseValue;
8  end;

6.7.1. Свойства

Свойства интерфейса IBooleanInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
FalseValue | WideString | Только для чтения |
TrueValue | WideString | Только для чтения |

6.8. Интерфейс IDataSet

01type
02  IDataSet = interface(IUnknown)
03    ['{3CED7395-8482-4EF6-8A15-7744348063C2}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_FieldName(Index: Integer): WideString; safecall;
06    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
07    procedure Next; safecall;
08    function Eof: WordBool; safecall;
09    property FieldCount: Integer read Get_FieldCount;
10    property FieldName[Index: Integer]: WideString read Get_FieldName;
11    property Field[FieldIndex: OleVariant]: OleVariant read Get_Field;
12  end;

6.8.1. Свойства

Свойства интерфейса IDataSet:

Имя | Тип | Доступ | Назначение
Field[FieldIndex: OleVariant] | OleVariant | Только для чтения |
FieldCount | Integer | Только для чтения |
FieldName[Index: Integer] | WideString | Только для чтения |

6.8.2. Метод Eof

Метод интерфейса IDataSet.

function IDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

6.8.3. Метод Next

Метод интерфейса IDataSet.

procedure IDataSet.Next;

Метод не имеет параметров.

6.9. Интерфейс IDateInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IDateInfo = interface(ITypeInfo)
3    ['{DA392510-105F-4655-9A38-18ECA2FBEB97}']
4  end;

6.10. Интерфейс IDateTimeInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IDateTimeInfo = interface(ITypeInfo)
3    ['{7F5CC8F9-8CE1-4DB7-8932-884EF3BAB538}']
4  end;

6.11. Интерфейс IEnumerationInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IEnumerationInfo = interface(ITypeInfo)
3    ['{B58A3F23-1AAC-4420-ADFF-B23B9938A994}']
4    function Get_ItemCount: Integer; safecall;
5    function Get_Item(Index: Integer): IEnumerationItem; safecall;
6    property ItemCount: Integer read Get_ItemCount;
7    property Item[Index: Integer]: IEnumerationItem read Get_Item;
8  end;

6.11.1. Свойства

Свойства интерфейса IEnumerationInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
Item[Index: Integer] | IEnumerationItem | Только для чтения |
ItemCount | Integer | Только для чтения |

6.12. Интерфейс IEnumerationItem

Интерфейс INamedItemInfo

1type
2  IEnumerationItem = interface(INamedItemInfo)
3    ['{6953507C-D477-4B8D-9443-A9E5FE7137ED}']
4    function Get_Position: Integer; safecall;
5    property Position: Integer read Get_Position;
6  end;

6.12.1. Свойства

Свойства интерфейса IEnumerationItem:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Position | Integer | Только для чтения |

6.13. Интерфейс IExternalDataSet

01type
02  IExternalDataSet = interface(IDispatch)
03    ['{CDC7992C-BB30-431C-9F81-3215175AD5AB}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_FieldName(Index: Integer): WideString; safecall;
06    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
07    procedure Next; safecall;
08    function Eof: WordBool; safecall;
09    property FieldCount: Integer read Get_FieldCount;
10    property FieldName[Index: Integer]: WideString read Get_FieldName;
11    property Field[FieldIndex: OleVariant]: OleVariant read Get_Field;
12  end;

6.13.1. Свойства

Свойства интерфейса IExternalDataSet:

Имя | Тип | Доступ | Назначение
Field[FieldIndex: OleVariant] | OleVariant | Только для чтения |
FieldCount | Integer | Только для чтения |
FieldName[Index: Integer] | WideString | Только для чтения |

6.13.2. Метод Eof

Метод интерфейса IExternalDataSet.

function IExternalDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

6.13.3. Метод Next

Метод интерфейса IExternalDataSet.

procedure IExternalDataSet.Next;

Метод не имеет параметров.

6.14. Интерфейс IExternalQuery

01type
02  IExternalQuery = interface(IDispatch)
03    ['{1A86D1DA-A56E-4D53-88F9-7A035D7D12B4}']
04    function Get_CurrentQuery: WideString; safecall;
05    function Select(const SQL: WideString): IExternalDataSet; safecall;
06    function SelectedRecordsCount: Integer; safecall;
07    function SelectedRecord(Index: Integer): OleVariant; safecall;
08    procedure PlaceCurrentQuery(const Sheet: IDispatch; CaptionsNeeded: WordBool;
09      Row: Integer; Column: Integer; ShiftRows: WordBool; ShiftColumns: WordBool); safecall;
10    procedure PlaceQuery(const Sheet: IDispatch; const DataSet: ExternalDataSet;
11      Row: Integer; Column: Integer; ShiftRows: WordBool; ShiftColumns: WordBool); safecall;
12    property CurrentQuery: WideString read Get_CurrentQuery;
13  end;

6.14.1. Свойства

Свойства интерфейса IExternalQuery:

Имя | Тип | Доступ | Назначение
CurrentQuery | WideString | Только для чтения |

6.14.2. Метод PlaceCurrentQuery

Метод интерфейса IExternalQuery.

1procedure IExternalQuery.PlaceCurrentQuery(const Sheet: IDispatch;
2  CaptionsNeeded: WordBool; Row: Integer; Column: Integer; ShiftRows: WordBool;
3  ShiftColumns: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Sheet | IDispatch | Да |
CaptionsNeeded | WordBool | Нет |
Row | Integer | Нет |
Column | Integer | Нет |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |

6.14.3. Метод PlaceQuery

Метод интерфейса IExternalQuery.

1procedure IExternalQuery.PlaceQuery(const Sheet: IDispatch;
2  const DataSet: ExternalDataSet; Row: Integer; Column: Integer;
3  ShiftRows: WordBool; ShiftColumns: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Sheet | IDispatch | Да |
DataSet | ExternalDataSet | Да |
Row | Integer | Нет |
Column | Integer | Нет |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |

6.14.4. Метод Select

Метод интерфейса IExternalQuery.

function IExternalQuery.Select(const SQL: WideString): IExternalDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
SQL | WideString | Да |

Замечания:

Возвращает значение типа IExternalDataSet.

6.14.5. Метод SelectedRecord

Метод интерфейса IExternalQuery.

function IExternalQuery.SelectedRecord(Index: Integer): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа OleVariant.

6.14.6. Метод SelectedRecordsCount

Метод интерфейса IExternalQuery.

function IExternalQuery.SelectedRecordsCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

6.15. Интерфейс IFieldInfo

Интерфейс INamedItemInfo

1type
2  IFieldInfo = interface(INamedItemInfo)
3    ['{19054DAD-8D35-4B39-8EB7-FD3254BD2934}']
4    function Get_TypeInfo: ITypeInfo; safecall;
5    function Get_DisplayMode: TDisplayMode; safecall;
6    property TypeInfo: ITypeInfo read Get_TypeInfo;
7    property DisplayMode: TDisplayMode read Get_DisplayMode;
8  end;

6.15.1. Свойства

Свойства интерфейса IFieldInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
DisplayMode | TDisplayMode | Только для чтения |
TypeInfo | ITypeInfo | Только для чтения |

6.16. Интерфейс IFieldInfo2

Интерфейс IFieldInfoИнтерфейс INamedItemInfo

1type
2  IFieldInfo2 = interface(IFieldInfo)
3    ['{82D93CF0-0E2F-4A85-AD74-9B1B9199B76B}']
4    function Get_Category: WideString; safecall;
5    property Category: WideString read Get_Category;
6  end;

6.16.1. Свойства

Свойства интерфейса IFieldInfo2:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
DisplayMode | TDisplayMode | Только для чтения | Унаследовано от IFieldInfo
TypeInfo | ITypeInfo | Только для чтения
Category | WideString | Только для чтения |

6.17. Интерфейс IFloatInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

01type
02  IFloatInfo = interface(ITypeInfo)
03    ['{E9B56C6D-47DC-4AB9-9E80-6EEF77708704}']
04    function Get_MaxValue: Double; safecall;
05    function Get_MaxValueUsed: WordBool; safecall;
06    function Get_MinValue: Double; safecall;
07    function Get_MinValueUsed: WordBool; safecall;
08    function Get_Precision: Integer; safecall;
09    function Get_Scale: Integer; safecall;
10    property MaxValue: Double read Get_MaxValue;
11    property MaxValueUsed: WordBool read Get_MaxValueUsed;
12    property MinValue: Double read Get_MinValue;
13    property MinValueUsed: WordBool read Get_MinValueUsed;
14    property Precision: Integer read Get_Precision;
15    property Scale: Integer read Get_Scale;
16  end;

6.17.1. Свойства

Свойства интерфейса IFloatInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
MaxValue | Double | Только для чтения |
MaxValueUsed | WordBool | Только для чтения |
MinValue | Double | Только для чтения |
MinValueUsed | WordBool | Только для чтения |
Precision | Integer | Только для чтения |
Scale | Integer | Только для чтения |

6.18. Интерфейс IInfoProvider

01type
02  IInfoProvider = interface(IUnknown)
03    ['{64F8072B-7250-4C57-BA8E-D018C7B72CC7}']
04    function Get_TableCount: Integer; safecall;
05    function Get_Table(Index: Integer): ITableInfo; safecall;
06    function Perform(const SQL: WideString): IDataSet; safecall;
07    procedure Connect(const DataBase: WideString; const UserName: WideString;
08      const Password: WideString); safecall;
09    function Get_CLSID: GUID; safecall;
10    function Get_DateLiteral: WideString; safecall;
11    function Get_TimeLiteral: WideString; safecall;
12    function Get_DateTimeLiteral: WideString; safecall;
13    function Get_RegExpLiteral: WideString; safecall;
14    function Get_ToBooleanLiteral: WideString; safecall;
15    function Get_ToStringLiteral: WideString; safecall;
16    function Get_AllowStartingWith: WordBool; safecall;
17    function Get_AllowArrays: WordBool; safecall;
18    function Get_DisallowNullsSorting: WordBool; safecall;
19    function Get_DisallowSubqueries: WordBool; safecall;
20    function Get_DisallowBetween: WordBool; safecall;
21    function Get_LikeAlwaysEscaped: WordBool; safecall;
22    function Get_MaxIdentLength: Integer; safecall;
23    function Get_ReplaceRegExpDotsWithUnderscore: WordBool; safecall;
24    function Get_Epsilon: WideString; safecall;
25    property TableCount: Integer read Get_TableCount;
26    property Table[Index: Integer]: ITableInfo read Get_Table;
27    property CLSID: GUID read Get_CLSID;
28    property DateLiteral: WideString read Get_DateLiteral;
29    property TimeLiteral: WideString read Get_TimeLiteral;
30    property DateTimeLiteral: WideString read Get_DateTimeLiteral;
31    property RegExpLiteral: WideString read Get_RegExpLiteral;
32    property ToBooleanLiteral: WideString read Get_ToBooleanLiteral;
33    property ToStringLiteral: WideString read Get_ToStringLiteral;
34    property AllowStartingWith: WordBool read Get_AllowStartingWith;
35    property AllowArrays: WordBool read Get_AllowArrays;
36    property DisallowNullsSorting: WordBool read Get_DisallowNullsSorting;
37    property DisallowSubqueries: WordBool read Get_DisallowSubqueries;
38    property DisallowBetween: WordBool read Get_DisallowBetween;
39    property LikeAlwaysEscaped: WordBool read Get_LikeAlwaysEscaped;
40    property MaxIdentLength: Integer read Get_MaxIdentLength;
41    property ReplaceRegExpDotsWithUnderscore: WordBool
42      read Get_ReplaceRegExpDotsWithUnderscore;
43    property Epsilon: WideString read Get_Epsilon;
44  end;

6.18.1. Свойства

Свойства интерфейса IInfoProvider:

Имя | Тип | Доступ | Назначение
AllowArrays | WordBool | Только для чтения |
AllowStartingWith | WordBool | Только для чтения |
CLSID | GUID | Только для чтения |
DateLiteral | WideString | Только для чтения |
DateTimeLiteral | WideString | Только для чтения |
DisallowBetween | WordBool | Только для чтения |
DisallowNullsSorting | WordBool | Только для чтения |
DisallowSubqueries | WordBool | Только для чтения |
Epsilon | WideString | Только для чтения |
LikeAlwaysEscaped | WordBool | Только для чтения |
MaxIdentLength | Integer | Только для чтения |
RegExpLiteral | WideString | Только для чтения |
ReplaceRegExpDotsWithUnderscore | WordBool | Только для чтения |
Table[Index: Integer] | ITableInfo | Только для чтения |
TableCount | Integer | Только для чтения |
TimeLiteral | WideString | Только для чтения |
ToBooleanLiteral | WideString | Только для чтения |
ToStringLiteral | WideString | Только для чтения |

6.18.2. Метод Connect

Метод интерфейса IInfoProvider.

1procedure IInfoProvider.Connect(const DataBase: WideString;
2  const UserName: WideString; const Password: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
DataBase | WideString | Да |
UserName | WideString | Да |
Password | WideString | Да |

6.18.3. Метод Perform

Метод интерфейса IInfoProvider.

function IInfoProvider.Perform(const SQL: WideString): IDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
SQL | WideString | Да |

Замечания:

Возвращает значение типа IDataSet.

6.19. Интерфейс IInfoProvider2

01type
02  IInfoProvider2 = interface(IDispatch)
03    ['{BED44934-BCF9-4942-933D-591AB40D4CFE}']
04    function Get_AutoCheckKeys: WordBool; safecall;
05    function Get_OptionCount: Integer; safecall;
06    function Get_Option(Index: Integer): IOptionInfo; safecall;
07    property AutoCheckKeys: WordBool read Get_AutoCheckKeys;
08    property OptionCount: Integer read Get_OptionCount;
09    property Option[Index: Integer]: IOptionInfo read Get_Option;
10  end;

6.19.1. Свойства

Свойства интерфейса IInfoProvider2:

Имя | Тип | Доступ | Назначение
AutoCheckKeys | WordBool | Только для чтения |
Option[Index: Integer] | IOptionInfo | Только для чтения |
OptionCount | Integer | Только для чтения |

6.20. Интерфейс IInfoProvider3

1type
2  IInfoProvider3 = interface(IDispatch)
3    ['{EF0E186A-4C72-4C40-B61C-72D7D03B2D10}']
4    procedure SetLogonInfo(const Login: WideString); safecall;
5  end;

6.20.1. Метод SetLogonInfo

Метод интерфейса IInfoProvider3.

procedure IInfoProvider3.SetLogonInfo(const Login: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Login | WideString | Да |

6.21. Интерфейс IIntegerInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

01type
02  IIntegerInfo = interface(ITypeInfo)
03    ['{9003B25E-926D-42AE-A907-813DF3A8343E}']
04    function Get_MaxValue: Integer; safecall;
05    function Get_MaxValueUsed: WordBool; safecall;
06    function Get_MinValue: Integer; safecall;
07    function Get_MinValueUsed: WordBool; safecall;
08    property MaxValue: Integer read Get_MaxValue;
09    property MaxValueUsed: WordBool read Get_MaxValueUsed;
10    property MinValue: Integer read Get_MinValue;
11    property MinValueUsed: WordBool read Get_MinValueUsed;
12  end;

6.21.1. Свойства

Свойства интерфейса IIntegerInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
MaxValue | Integer | Только для чтения |
MaxValueUsed | WordBool | Только для чтения |
MinValue | Integer | Только для чтения |
MinValueUsed | WordBool | Только для чтения |

6.22. Интерфейс INamedItemInfo

01type
02  INamedItemInfo = interface(IUnknown)
03    ['{14894363-28DA-4E71-B0BC-9C5CE811BC8F}']
04    function Get_Name: WideString; safecall;
05    function Get_Caption: WideString; safecall;
06    function Get_ID: WideString; safecall;
07    property Name: WideString read Get_Name;
08    property Caption: WideString read Get_Caption;
09    property ID: WideString read Get_ID;
10  end;

6.22.1. Свойства

Свойства интерфейса INamedItemInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения |
ID | WideString | Только для чтения |
Name | WideString | Только для чтения |

6.23. Интерфейс IOptionInfo

Интерфейс INamedItemInfo

01type
02  IOptionInfo = interface(INamedItemInfo)
03    ['{453E81A2-969D-49DC-B3C6-ACAD411D63FC}']
04    function Get_TypeInfo: ITypeInfo; safecall;
05    function Get_Group: WideString; safecall;
06    function Get_Tab: WideString; safecall;
07    function Get_Value: OleVariant; safecall;
08    procedure Set_Value(Value: OleVariant); safecall;
09    property TypeInfo: ITypeInfo read Get_TypeInfo;
10    property Group: WideString read Get_Group;
11    property Tab: WideString read Get_Tab;
12    property Value: OleVariant read Get_Value write Set_Value;
13  end;

6.23.1. Свойства

Свойства интерфейса IOptionInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Group | WideString | Только для чтения |
Tab | WideString | Только для чтения |
TypeInfo | ITypeInfo | Только для чтения |
Value | OleVariant | Чтение/Запись |

6.24. Интерфейс IReferenceInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IReferenceInfo = interface(ITypeInfo)
3    ['{309C8CB1-4A1C-4E58-BC3F-D1AF27861A8F}']
4    function Get_TargetTable: ITableInfo; safecall;
5    property TargetTable: ITableInfo read Get_TargetTable;
6  end;

6.24.1. Свойства

Свойства интерфейса IReferenceInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
TargetTable | ITableInfo | Только для чтения |

6.25. Интерфейс IStringInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IStringInfo = interface(ITypeInfo)
3    ['{74AC4C03-E803-421B-B30D-1A2D2C49827F}']
4    function Get_Length: Integer; safecall;
5    property Length: Integer read Get_Length;
6  end;

6.25.1. Свойства

Свойства интерфейса IStringInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
Length | Integer | Только для чтения |

6.26. Интерфейс ITableInfo

Интерфейс INamedItemInfo

01type
02  ITableInfo = interface(INamedItemInfo)
03    ['{3FC1998A-9031-4936-82B5-8CAA2219085E}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_Field(Index: Integer): IFieldInfo; safecall;
06    function Get_PrimaryKey: IFieldInfo; safecall;
07    function Get_Uplink: IFieldInfo; safecall;
08    function Get_Parent: ITableInfo; safecall;
09    function Get_RootAvailable: WordBool; safecall;
10    property FieldCount: Integer read Get_FieldCount;
11    property Field[Index: Integer]: IFieldInfo read Get_Field;
12    property PrimaryKey: IFieldInfo read Get_PrimaryKey;
13    property Uplink: IFieldInfo read Get_Uplink;
14    property Parent: ITableInfo read Get_Parent;
15    property RootAvailable: WordBool read Get_RootAvailable;
16  end;

6.26.1. Свойства

Свойства интерфейса ITableInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения |
FieldCount | Integer | Только для чтения |
Parent | ITableInfo | Только для чтения |
PrimaryKey | IFieldInfo | Только для чтения |
RootAvailable | WordBool | Только для чтения |
Uplink | IFieldInfo | Только для чтения |

6.27. Интерфейс ITableInfo2

Интерфейс ITableInfoИнтерфейс INamedItemInfo

01type
02  ITableInfo2 = interface(ITableInfo)
03    ['{9DF4C8AC-1DA2-4E7B-BF44-7EDD7A269418}']
04    function Get_PolymorphCount: Integer; safecall;
05    function Get_PolymorphTable(Index: Integer): ITableInfo; safecall;
06    function Get_PolymorphField(Index: Integer): IFieldInfo; safecall;
07    property PolymorphCount: Integer read Get_PolymorphCount;
08    property PolymorphTable[Index: Integer]: ITableInfo read Get_PolymorphTable;
09    property PolymorphField[Index: Integer]: IFieldInfo read Get_PolymorphField;
10  end;

6.27.1. Свойства

Свойства интерфейса ITableInfo2:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения | Унаследовано от ITableInfo
FieldCount | Integer | Только для чтения
Parent | ITableInfo | Только для чтения
PrimaryKey | IFieldInfo | Только для чтения
RootAvailable | WordBool | Только для чтения
Uplink | IFieldInfo | Только для чтения
PolymorphCount | Integer | Только для чтения |
PolymorphField[Index: Integer] | IFieldInfo | Только для чтения |
PolymorphTable[Index: Integer] | ITableInfo | Только для чтения |

6.28. Интерфейс ITableInfo3

Интерфейс ITableInfoИнтерфейс INamedItemInfo

01type
02  ITableInfo3 = interface(ITableInfo)
03    ['{3FB73AA9-010C-48DA-81C7-E1DCFE2E6136}']
04    function GetPersistentClause(const Alias: WideString): WideString; safecall;
05    function GetPreConditionsCount: Integer; safecall;
06    function GetPreConditionCaption(Index: Integer): WideString; safecall;
07    function Get_ActivePreCondition(Index: Integer): WordBool; safecall;
08    procedure Set_ActivePreCondition(Index: Integer; Value: WordBool); safecall;
09    function GetPreConditionParamsCount(Index: Integer): Integer; safecall;
10    function GetPreConditionParam(Index: Integer;
11      PreConditionIndex: Integer): IOptionInfo; safecall;
12    function GetPreConditionCategory(Index: Integer): WideString; safecall;
13    property ActivePreCondition[Index: Integer]: WordBool
14      read Get_ActivePreCondition write Set_ActivePreCondition;
15  end;

6.28.1. Свойства

Свойства интерфейса ITableInfo3:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения | Унаследовано от ITableInfo
FieldCount | Integer | Только для чтения
Parent | ITableInfo | Только для чтения
PrimaryKey | IFieldInfo | Только для чтения
RootAvailable | WordBool | Только для чтения
Uplink | IFieldInfo | Только для чтения
ActivePreCondition[Index: Integer] | WordBool | Чтение/Запись |

6.28.2. Метод GetPersistentClause

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPersistentClause(const Alias: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Alias | WideString | Да |

Замечания:

Возвращает значение типа WideString.

6.28.3. Метод GetPreConditionCaption

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionCaption(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.

6.28.4. Метод GetPreConditionCategory

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionCategory(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.

6.28.5. Метод GetPreConditionParam

Метод интерфейса ITableInfo3.

1function ITableInfo3.GetPreConditionParam(Index: Integer;
2  PreConditionIndex: Integer): IOptionInfo;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |
PreConditionIndex | Integer | Да |

Замечания:

Возвращает значение типа IOptionInfo.

6.28.6. Метод GetPreConditionParamsCount

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionParamsCount(Index: Integer): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа Integer.

6.28.7. Метод GetPreConditionsCount

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionsCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

6.29. Интерфейс ITimeInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  ITimeInfo = interface(ITypeInfo)
3    ['{D7067CAC-67A5-41DB-8D95-40409D8658AB}']
4  end;

6.30. Интерфейс ITypeInfo

Интерфейс INamedItemInfo

1type
2  ITypeInfo = interface(INamedItemInfo)
3    ['{2B6A5E20-3C36-4574-89DB-7C873A5C4A00}']
4    function Get_Required: WordBool; safecall;
5    function Get_SimpleType: TSimpleType; safecall;
6    property Required: WordBool read Get_Required;
7    property SimpleType: TSimpleType read Get_SimpleType;
8  end;

6.30.1. Свойства

Свойства интерфейса ITypeInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения |
SimpleType | TSimpleType | Только для чтения |

6.31. Интерфейс ITypeInfo2

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  ITypeInfo2 = interface(ITypeInfo)
3    ['{77F58BDF-F01C-40F3-B193-1027AD8C4EDA}']
4    function GetSpecialFilterCount: Integer; safecall;
5    function GetSpecialFilterText(Index: Integer): WideString; safecall;
6    function EditSpecialFilter(Index: Integer; var Filter: WideString): WordBool; safecall;
7  end;

6.31.1. Метод EditSpecialFilter

Метод интерфейса ITypeInfo2.

1function ITypeInfo2.EditSpecialFilter(Index: Integer;
2  var Filter: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |
Filter | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

6.31.2. Метод GetSpecialFilterCount

Метод интерфейса ITypeInfo2.

function ITypeInfo2.GetSpecialFilterCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

6.31.3. Метод GetSpecialFilterText

Метод интерфейса ITypeInfo2.

function ITypeInfo2.GetSpecialFilterText(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IZIPArchive (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IZIPArchive

01type
02  IZIPArchive = interface(IDispatch)
03    ['{11C9400F-F262-4F72-882F-5AA5A4531591}']
04    procedure Load(Src: OleVariant); safecall;
05    procedure Save(Src: OleVariant); safecall;
06    function Get_FileCount: Integer; safecall;
07    function Get_FileName(Index: Integer): WideString; safecall;
08    function Get_FileData(Index: Integer): OleVariant; safecall;
09    procedure AddFile(const FileName: WideString; Data: OleVariant); safecall;
10    function Get_FileSize(Index: Integer): Int64; safecall;
11    function Get_FileDateTime(Index: Integer): TDateTime; safecall;
12    function Get_FileCRC(Index: Integer): WideString; safecall;
13    function Get_UTF8Support: WordBool; safecall;
14    procedure Set_UTF8Support(Value: WordBool); safecall;
15    property FileCount: Integer read Get_FileCount;
16    property FileName[Index: Integer]: WideString read Get_FileName;
17    property FileData[Index: Integer]: OleVariant read Get_FileData;
18    property FileSize[Index: Integer]: Int64 read Get_FileSize;
19    property FileDateTime[Index: Integer]: TDateTime read Get_FileDateTime;
20    property FileCRC[Index: Integer]: WideString read Get_FileCRC;
21    property UTF8Support: WordBool read Get_UTF8Support write Set_UTF8Support;
22  end;

1. Свойства

Свойства интерфейса IZIPArchive:

Имя | Тип | Доступ | Назначение
FileCRC[Index: Integer] | WideString | Только для чтения |
FileCount | Integer | Только для чтения |
FileData[Index: Integer] | OleVariant | Только для чтения |
FileDateTime[Index: Integer] | TDateTime | Только для чтения |
FileName[Index: Integer] | WideString | Только для чтения |
FileSize[Index: Integer] | Int64 | Только для чтения |
UTF8Support | WordBool | Чтение/Запись |

2. Метод AddFile

Метод интерфейса IZIPArchive.

procedure IZIPArchive.AddFile(const FileName: WideString; Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
FileName | WideString | Да |
Data | OleVariant | Да |

3. Метод Load

Метод интерфейса IZIPArchive.

procedure IZIPArchive.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

4. Метод Save

Метод интерфейса IZIPArchive.

procedure IZIPArchive.Save(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |


Мельница данных ((раздел целиком))

Мельница данных- Класс TForm (Формы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TForm (Формы)

Диаграмма Класс TObject (Объекты)Класс TFormAccess (Доступ к формам)Класс TFormView (Представления формы)Класс TFormOption (Настройки формы)

1. Свойства

Свойства класса TForm:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
AutoOpen | Boolean | Да | Видимо пользователю | Чтение/Запись | Открывать автоматически
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
Image | blob | Нет | Видимо пользователю | Чтение/Запись | Изображение-иконка
IsAccessible | Boolean | Да | Скрыто от пользователя | Только для чтения | Доступна
IsAlive | Boolean | Да | Видимо пользователю | Чтение/Запись | "Живая"
PreOpenRoutine | TRoutine | Нет | Видимо пользователю | Чтение/Запись | Вызывать перед открытием

2. Конструктор Create (Конструктор формы)

Конструктор класса TForm.

1constructor TForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  AutoOpen: Boolean; Position: Integer; Scope: TScope; Image: blob;
4  IsAlive: Boolean; PreOpenRoutine: TRoutine): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
AutoOpen | Boolean | Да | Открывать автоматически
Position | Integer | Да | Позиция
Scope | TScope | Да | Область видимости
Image | blob | Нет | Изображение-иконка
IsAlive | Boolean | Да | "Живая"
PreOpenRoutine | TRoutine | Нет | Вызывать перед открытием

Замечания:

Создает новый объект класса TForm.

3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TForm.

procedure TForm.CreateContextKey(Storage: string[64]);

Параметры:

Имя | Тип | Обязательно | Значение
Storage | string[64] | Да | Хранилище

4. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TForm.

function TForm.GetIsAccessible: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TForm.

class function TForm.GetNextPos: Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Мельница данных ((раздел целиком))

Мельница данных- Справочник по интерфейсам (раздел целиком) (22.10.2024) (одним файлом)
Справочник по интерфейсам

1. Перечисление TPDFFontRenderingMode
1type
2  TPDFFontRenderingMode = (frmFillText, frmStrokeText, frmFillThenStrokeText,
3    frmInvisible);

Или

1type
2  TPDFFontRenderingMode = TOleEnum;
3const
4  frmFillText = $00000000;
5  frmStrokeText = $00000001;
6  frmFillThenStrokeText = $00000002;
7  frmInvisible = $00000003;

Элементы перечисления:

Имя | Значение | Назначение
frmFillText | 0 |
frmStrokeText | 1 |
frmFillThenStrokeText | 2 |
frmInvisible | 3 |

2. Перечисление TPDFLineCap
1type
2  TPDFLineCap = (lcBuss, lcRound, lcProtecting);

Или

1type
2  TPDFLineCap = TOleEnum;
3const
4  lcBuss = $00000000;
5  lcRound = $00000001;
6  lcProtecting = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
lcBuss | 0 |
lcRound | 1 |
lcProtecting | 2 |

3. Перечисление TPDFLineJoin
1type
2  TPDFLineJoin = (ljMiter, ljRound, ljBevel);

Или

1type
2  TPDFLineJoin = TOleEnum;
3const
4  ljMiter = $00000000;
5  ljRound = $00000001;
6  ljBevel = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
ljMiter | 0 |
ljRound | 1 |
ljBevel | 2 |

4. Перечисление TPDFTextAlignment
1type
2  TPDFTextAlignment = (ptaLeft, ptaRight, ptaCenter, ptaJustified);

Или

1type
2  TPDFTextAlignment = TOleEnum;
3const
4  ptaLeft = $00000000;
5  ptaRight = $00000001;
6  ptaCenter = $00000002;
7  ptaJustified = $00000003;

Элементы перечисления:

Имя | Значение | Назначение
ptaLeft | 0 |
ptaRight | 1 |
ptaCenter | 2 |
ptaJustified | 3 |

5. Интерфейс IPDFDocument

01type
02  IPDFDocument = interface(IDispatch)
03    ['{E57FFE9D-6B85-45E6-A5D0-9DD17950A666}']
04    procedure Save(Target: OleVariant); safecall;
05    function CreatePage(Parent: OleVariant): IPDFPage; safecall;
06    function Get_Title: WideString; safecall;
07    procedure Set_Title(Value: WideString); safecall;
08    function Get_CanEmbedFonts: WordBool; safecall;
09    procedure Set_CanEmbedFonts(Value: WordBool); safecall;
10    function Get_CanCompress: WordBool; safecall;
11    procedure Set_CanCompress(Value: WordBool); safecall;
12    function Get_Author: WideString; safecall;
13    procedure Set_Author(Value: WideString); safecall;
14    function Get_Subject: WideString; safecall;
15    procedure Set_Subject(Value: WideString); safecall;
16    function Get_Keywords: WideString; safecall;
17    procedure Set_Keywords(Value: WideString); safecall;
18    function Get_Creator: WideString; safecall;
19    procedure Set_Creator(Value: WideString); safecall;
20    function Get_Pages(Index: Integer): IPDFPage; safecall;
21    function Get_PageCount: Integer; safecall;
22    procedure Close; safecall;
23    procedure Serialize(const Stream: IUnknown); safecall;
24    function Get_MinCompressSize: Integer; safecall;
25    procedure Set_MinCompressSize(Value: Integer); safecall;
26    function Get_MaxCompressSize: Integer; safecall;
27    procedure Set_MaxCompressSize(Value: Integer); safecall;
28    function CreatePageFromImage(Image: OleVariant; PageWidth: Double;
29      PageHeight: Double; Margin: Double): WordBool; safecall;
30    procedure SaveToXML(Target: OleVariant); safecall;
31    property Title: WideString read Get_Title write Set_Title;
32    property CanEmbedFonts: WordBool read Get_CanEmbedFonts write Set_CanEmbedFonts;
33    property CanCompress: WordBool read Get_CanCompress write Set_CanCompress;
34    property Author: WideString read Get_Author write Set_Author;
35    property Subject: WideString read Get_Subject write Set_Subject;
36    property Keywords: WideString read Get_Keywords write Set_Keywords;
37    property Creator: WideString read Get_Creator write Set_Creator;
38    property Pages[Index: Integer]: IPDFPage read Get_Pages;
39    property PageCount: Integer read Get_PageCount;
40    property MinCompressSize: Integer read Get_MinCompressSize
41      write Set_MinCompressSize;
42    property MaxCompressSize: Integer read Get_MaxCompressSize
43      write Set_MaxCompressSize;
44  end;

5.1. Свойства

Свойства интерфейса IPDFDocument:

Имя | Тип | Доступ | Назначение
Author | WideString | Чтение/Запись |
CanCompress | WordBool | Чтение/Запись |
CanEmbedFonts | WordBool | Чтение/Запись |
Creator | WideString | Чтение/Запись |
Keywords | WideString | Чтение/Запись |
MaxCompressSize | Integer | Чтение/Запись |
MinCompressSize | Integer | Чтение/Запись |
PageCount | Integer | Только для чтения |
Pages[Index: Integer] | IPDFPage | Только для чтения |
Subject | WideString | Чтение/Запись |
Title | WideString | Чтение/Запись |

5.2. Метод Close

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Close;

Метод не имеет параметров.

5.3. Метод CreatePage

Метод интерфейса IPDFDocument.

function IPDFDocument.CreatePage(Parent: OleVariant): IPDFPage;

Параметры:

Имя | Тип | Обязательно | Значение
Parent | OleVariant | Да |

Замечания:

Возвращает значение типа IPDFPage.

5.4. Метод CreatePageFromImage

Метод интерфейса IPDFDocument.

1function IPDFDocument.CreatePageFromImage(Image: OleVariant; PageWidth: Double;
2  PageHeight: Double; Margin: Double): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Image | OleVariant | Да |
PageWidth | Double | Да |
PageHeight | Double | Да |
Margin | Double | Да |

Замечания:

Возвращает значение типа WordBool.

5.5. Метод Save

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Save(Target: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Target | OleVariant | Да |

5.6. Метод SaveToXML

Метод интерфейса IPDFDocument.

procedure IPDFDocument.SaveToXML(Target: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Target | OleVariant | Да |

5.7. Метод Serialize

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Serialize(const Stream: IUnknown);

Параметры:

Имя | Тип | Обязательно | Значение
Stream | IUnknown | Да |

6. Интерфейс IPDFFont

01type
02  IPDFFont = interface(IDispatch)
03    ['{43FE399A-A724-4076-BAFA-098639628385}']
04    function Get_Spacing: Double; safecall;
05    procedure Set_Spacing(Value: Double); safecall;
06    function Get_WordSpacing: Double; safecall;
07    procedure Set_WordSpacing(Value: Double); safecall;
08    function Get_Scaling: Double; safecall;
09    procedure Set_Scaling(Value: Double); safecall;
10    function Get_RenderingMode: TPDFFontRenderingMode; safecall;
11    procedure Set_RenderingMode(Value: TPDFFontRenderingMode); safecall;
12    function Get_Rise: Double; safecall;
13    procedure Set_Rise(Value: Double); safecall;
14    procedure WriteLine(const LineText: WideString; X: Double; Y: Double); safecall;
15    procedure MeasureLine(const LineText: WideString; out Width: OleVariant;
16      out Height: OleVariant); safecall;
17    function WriteText(const AText: WideString; X: Double; Y: Double;
18      Width: Double; Alignment: TPDFTextAlignment): Double; safecall;
19    function MeasureText(const AText: WideString; Width: Double): Double; safecall;
20    function Get_Angle: Double; safecall;
21    procedure Set_Angle(Value: Double); safecall;
22    function Get_LineSpacing: Double; safecall;
23    procedure Set_LineSpacing(Value: Double); safecall;
24    property Spacing: Double read Get_Spacing write Set_Spacing;
25    property WordSpacing: Double read Get_WordSpacing write Set_WordSpacing;
26    property Scaling: Double read Get_Scaling write Set_Scaling;
27    property RenderingMode: TPDFFontRenderingMode read Get_RenderingMode
28      write Set_RenderingMode;
29    property Rise: Double read Get_Rise write Set_Rise;
30    property Angle: Double read Get_Angle write Set_Angle;
31    property LineSpacing: Double read Get_LineSpacing write Set_LineSpacing;
32  end;

6.1. Свойства

Свойства интерфейса IPDFFont:

Имя | Тип | Доступ | Назначение
Angle | Double | Чтение/Запись |
LineSpacing | Double | Чтение/Запись |
RenderingMode | TPDFFontRenderingMode | Чтение/Запись |
Rise | Double | Чтение/Запись |
Scaling | Double | Чтение/Запись |
Spacing | Double | Чтение/Запись |
WordSpacing | Double | Чтение/Запись |

6.2. Метод MeasureLine

Метод интерфейса IPDFFont.

1procedure IPDFFont.MeasureLine(const LineText: WideString;
2  out Width: OleVariant; out Height: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
LineText | WideString | Да |
Width | OleVariant | Да |
Height | OleVariant | Да |

6.3. Метод MeasureText

Метод интерфейса IPDFFont.

function IPDFFont.MeasureText(const AText: WideString; Width: Double): Double;

Параметры:

Имя | Тип | Обязательно | Значение
AText | WideString | Да |
Width | Double | Да |

Замечания:

Возвращает значение типа Double.

6.4. Метод WriteLine

Метод интерфейса IPDFFont.

procedure IPDFFont.WriteLine(const LineText: WideString; X: Double; Y: Double);

Параметры:

Имя | Тип | Обязательно | Значение
LineText | WideString | Да |
X | Double | Да |
Y | Double | Да |

6.5. Метод WriteText

Метод интерфейса IPDFFont.

1function IPDFFont.WriteText(const AText: WideString; X: Double; Y: Double;
2  Width: Double; Alignment: TPDFTextAlignment): Double;

Параметры:

Имя | Тип | Обязательно | Значение
AText | WideString | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Alignment | TPDFTextAlignment | Да |

Замечания:

Возвращает значение типа Double.

7. Интерфейс IPDFPage

01type
02  IPDFPage = interface(IDispatch)
03    ['{749FB131-80FE-46E9-8330-22C1DC346FE7}']
04    function Get_Parent: IPDFPage; safecall;
05    function Get_Title: WideString; safecall;
06    procedure Set_Title(Value: WideString); safecall;
07    function Get_Width: Double; safecall;
08    procedure Set_Width(Value: Double); safecall;
09    function Get_Height: Double; safecall;
10    procedure Set_Height(Value: Double); safecall;
11    function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool;
12      Italic: WordBool): IPDFFont; safecall;
13    procedure Perform(const Command: WideString); safecall;
14    function Get_LineWidth: Double; safecall;
15    procedure Set_LineWidth(Value: Double); safecall;
16    procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double); safecall;
17    procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double;
18      Fill: WordBool); safecall;
19    function Get_LineCap: TPDFLineCap; safecall;
20    procedure Set_LineCap(Value: TPDFLineCap); safecall;
21    function Get_LineJoin: TPDFLineJoin; safecall;
22    procedure Set_LineJoin(Value: TPDFLineJoin); safecall;
23    procedure SetDash(DashArray: OleVariant; Phase: Integer); safecall;
24    procedure SetColor(R: Integer; G: Integer; B: Integer); safecall;
25    procedure PerformColor(const Command: WideString); safecall;
26    procedure Poly(Points: OleVariant; Fill: WordBool); safecall;
27    procedure Image(Image: OleVariant; X: Double; Y: Double; Width: Double;
28      Height: Double; Transparent: WordBool); safecall;
29    procedure DrawGrid; safecall;
30    procedure Arc(X: Double; Y: Double; Radius: Double; StartAngle: Double;
31      EndAngle: Double; FillSegment: WordBool; FillSector: WordBool); safecall;
32    procedure Curve(Points: OleVariant; Fill: WordBool); safecall;
33    procedure HyperLink(const URI: WideString; X: Double; Y: Double; Width: Double;
34      Height: Double); safecall;
35    procedure Pattern(X1: Double; Y1: Double; Width: Double; Height: Double;
36      PatternPointSize: Double; Percentage: Integer); safecall;
37    procedure Bezier(Points: OleVariant; Fill: WordBool); safecall;
38    procedure XObject(Data: OleVariant); safecall;
39    procedure SetColorCMYK(C: Double; M: Double; Y: Double; K: Double); safecall;
40    procedure LocalLink(const Page: IDispatch; DestinationX: Double;
41      DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
42      X: Double; Y: Double; Width: Double; Height: Double); safecall;
43    property Parent: IPDFPage read Get_Parent;
44    property Title: WideString read Get_Title write Set_Title;
45    property Width: Double read Get_Width write Set_Width;
46    property Height: Double read Get_Height write Set_Height;
47    property LineWidth: Double read Get_LineWidth write Set_LineWidth;
48    property LineCap: TPDFLineCap read Get_LineCap write Set_LineCap;
49    property LineJoin: TPDFLineJoin read Get_LineJoin write Set_LineJoin;
50  end;

7.1. Свойства

Свойства интерфейса IPDFPage:

Имя | Тип | Доступ | Назначение
Height | Double | Чтение/Запись |
LineCap | TPDFLineCap | Чтение/Запись |
LineJoin | TPDFLineJoin | Чтение/Запись |
LineWidth | Double | Чтение/Запись |
Parent | IPDFPage | Только для чтения |
Title | WideString | Чтение/Запись |
Width | Double | Чтение/Запись |

7.2. Метод Arc

Метод интерфейса IPDFPage.

1procedure IPDFPage.Arc(X: Double; Y: Double; Radius: Double;
2  StartAngle: Double; EndAngle: Double; FillSegment: WordBool;
3  FillSector: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
X | Double | Да |
Y | Double | Да |
Radius | Double | Да |
StartAngle | Double | Да |
EndAngle | Double | Да |
FillSegment | WordBool | Да |
FillSector | WordBool | Да |

7.3. Метод Bezier

Метод интерфейса IPDFPage.

procedure IPDFPage.Bezier(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

7.4. Метод CreateFont

Метод интерфейса IPDFPage.

1function IPDFPage.CreateFont(const FontName: WideString; Size: Double;
2  Bold: WordBool; Italic: WordBool): IPDFFont;

Параметры:

Имя | Тип | Обязательно | Значение
FontName | WideString | Да |
Size | Double | Да |
Bold | WordBool | Да |
Italic | WordBool | Да |

Замечания:

Возвращает значение типа IPDFFont.

7.5. Метод Curve

Метод интерфейса IPDFPage.

procedure IPDFPage.Curve(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

7.6. Метод DrawGrid

Метод интерфейса IPDFPage.

procedure IPDFPage.DrawGrid;

Метод не имеет параметров.

7.7. Метод HyperLink

Метод интерфейса IPDFPage.

1procedure IPDFPage.HyperLink(const URI: WideString; X: Double; Y: Double;
2  Width: Double; Height: Double);

Параметры:

Имя | Тип | Обязательно | Значение
URI | WideString | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |

7.8. Метод Image

Метод интерфейса IPDFPage.

1procedure IPDFPage.Image(Image: OleVariant; X: Double; Y: Double;
2  Width: Double; Height: Double; Transparent: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Image | OleVariant | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |
Transparent | WordBool | Нет |

7.9. Метод Line

Метод интерфейса IPDFPage.

procedure IPDFPage.Line(X1: Double; Y1: Double; X2: Double; Y2: Double);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
X2 | Double | Да |
Y2 | Double | Да |

7.10. Метод LocalLink

Метод интерфейса IPDFPage.

1procedure IPDFPage.LocalLink(const Page: IDispatch; DestinationX: Double;
2  DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
3  X: Double; Y: Double; Width: Double; Height: Double);

Параметры:

Имя | Тип | Обязательно | Значение
Page | IDispatch | Да |
DestinationX | Double | Да |
DestinationY | Double | Да |
DestinationWidth | Double | Да |
DestinationHeight | Double | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |

7.11. Метод Pattern

Метод интерфейса IPDFPage.

1procedure IPDFPage.Pattern(X1: Double; Y1: Double; Width: Double;
2  Height: Double; PatternPointSize: Double; Percentage: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
Width | Double | Да |
Height | Double | Да |
PatternPointSize | Double | Да |
Percentage | Integer | Да |

7.12. Метод Perform

Метод интерфейса IPDFPage.

procedure IPDFPage.Perform(const Command: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Command | WideString | Да |

7.13. Метод PerformColor

Метод интерфейса IPDFPage.

procedure IPDFPage.PerformColor(const Command: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Command | WideString | Да |

7.14. Метод Poly

Метод интерфейса IPDFPage.

procedure IPDFPage.Poly(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

7.15. Метод Rectangle

Метод интерфейса IPDFPage.

1procedure IPDFPage.Rectangle(X1: Double; Y1: Double; Width: Double;
2  Height: Double; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
Width | Double | Да |
Height | Double | Да |
Fill | WordBool | Да |

7.16. Метод SetColor

Метод интерфейса IPDFPage.

procedure IPDFPage.SetColor(R: Integer; G: Integer; B: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
R | Integer | Да |
G | Integer | Да |
B | Integer | Да |

7.17. Метод SetColorCMYK

Метод интерфейса IPDFPage.

procedure IPDFPage.SetColorCMYK(C: Double; M: Double; Y: Double; K: Double);

Параметры:

Имя | Тип | Обязательно | Значение
C | Double | Да |
M | Double | Да |
Y | Double | Да |
K | Double | Да |

7.18. Метод SetDash

Метод интерфейса IPDFPage.

procedure IPDFPage.SetDash(DashArray: OleVariant; Phase: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
DashArray | OleVariant | Да |
Phase | Integer | Да |

7.19. Метод XObject

Метод интерфейса IPDFPage.

procedure IPDFPage.XObject(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |


Мельница данных ((раздел целиком))

Мельница данных- Класс TImportedReplica (Импортированные реплики) (раздел целиком) (22.10.2024) (одним файлом)
Класс TImportedReplica (Импортированные реплики)

Класс TObject (Объекты)

Объекты класса не именованы.

1. Свойства

Свойства класса TImportedReplica:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
CRC | string[8] | Нет | Видимо пользователю | Чтение/Запись | Контрольная сумма
MetadataCRC | string[8] | Нет | Видимо пользователю | Чтение/Запись | Контрольная сумма метаданных

2. Конструктор Create (Конструктор импортированной реплики)

Конструктор класса TImportedReplica.

1constructor TImportedReplica.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CRC: string[8]): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
CRC | string[8] | Нет | Контрольная сумма

Замечания:

Создает новый объект класса TImportedReplica.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IReferenceInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IReferenceInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IReferenceInfo = interface(ITypeInfo)
3    ['{309C8CB1-4A1C-4E58-BC3F-D1AF27861A8F}']
4    function Get_TargetTable: ITableInfo; safecall;
5    property TargetTable: ITableInfo read Get_TargetTable;
6  end;

1. Свойства

Свойства интерфейса IReferenceInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
TargetTable | ITableInfo | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IContextDataSet (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IContextDataSet

01type
02  IContextDataSet = interface(IDispatch)
03    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
04    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
05      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant); safecall;
06    function Eof: WordBool; safecall;
07    function Field(const Name: WideString): OleVariant; safecall;
08    function FieldCount: Integer; safecall;
09    function FieldName(Index: Integer): WideString; safecall;
10    procedure Next; safecall;
11    procedure Split(OnRowEvent: OleVariant; ChunkSize: Integer;
12      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
13    function AsJSON: WideString; safecall;
14    function AsXML: WideString; safecall;
15    function AsBinaryData: IDispatch; safecall;
16  end;

1. Метод AddQueryItem

Метод интерфейса IContextDataSet.

1procedure IContextDataSet.AddQueryItem(Part: TQueryPart;
2  const Name: WideString; Value: OleVariant; Special: TQuerySpecial;
3  Context: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Part | TQueryPart | Да |
Name | WideString | Да |
Value | OleVariant | Нет |
Special | TQuerySpecial | Нет |
Context | OleVariant | Нет |

2. Метод AsBinaryData

Метод интерфейса IContextDataSet.

function IContextDataSet.AsBinaryData: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

3. Метод AsJSON

Метод интерфейса IContextDataSet.

function IContextDataSet.AsJSON: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

4. Метод AsXML

Метод интерфейса IContextDataSet.

function IContextDataSet.AsXML: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5. Метод Eof

Метод интерфейса IContextDataSet.

function IContextDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

6. Метод Field

Метод интерфейса IContextDataSet.

function IContextDataSet.Field(const Name: WideString): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа OleVariant.

7. Метод FieldCount

Метод интерфейса IContextDataSet.

function IContextDataSet.FieldCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

8. Метод FieldName

Метод интерфейса IContextDataSet.

function IContextDataSet.FieldName(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.

9. Метод Next

Метод интерфейса IContextDataSet.

procedure IContextDataSet.Next;

Метод не имеет параметров.

10. Метод Split

Метод интерфейса IContextDataSet.

1procedure IContextDataSet.Split(OnRowEvent: OleVariant; ChunkSize: Integer;
2  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
OnRowEvent | OleVariant | Да |
ChunkSize | Integer | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |


Мельница данных ((раздел целиком))

Мельница данных- Руководство администратора (раздел целиком) (22.10.2024) (одним файлом)
Руководство администратора

1. Установка программного обеспечения СУБД

Прежде, чем устанавливать программноге обеспечение "Мельница данных" необходимо установить и настроить программное обеспечение СУБД.

Для конфигурирования сервера БД необходимо последовать советам раздела "Конфигурирование сервера". В этом разделе описаны шаги, которые необходимо предпринять для установки сервера "с нуля". Если сервер БД у вас уже установлен и настроен, то использовать рекомендации этого раздела нет необходимости. Раздел описывает установку сервера БД минимальной поддерживаемой версии в минимально необходимой для работы "Мельницы данных" конфигурации. Если вы собираетесь использовать сервер БД для более широкого круга задач, то пользуйтесь руководствами по соответствующим СУБД.
Документация по СУБД, а также любая другая информация, полученная от производителей СУБД, имеет абсолютный приоритет перед утверждениями настоящего документа.

На каждой рабочей станции должно быть установлено и настроено программное обеспечение клиентской части СУБД. Это, как правило, некий набор библиотек и компонентов, наличие которых необходимо для соединения с сервером БД. Для обеспечения рабочей станции этими компонентами необходимо последовать советам раздела Конфигурирование клиента. В этом разделе описаны шаги, которые необходимо предпринять для установки клиентской части СУБД "с нуля". Если клиентская часть СУБД у вас уже установлена и настроена, то использовать рекомендации этого раздела нет необходимости. Раздел описывает установку клиентской части СУБД минимальной поддерживаемой версии в минимально необходимой для работы "Мельницы данных" конфигурации.

В настоящий момент поддерживаемые СУБД приведены в таблице:
СУБД Минимальная
требуемая версия 		Разработчик Сопровождение в России
Firebird
Open source
1.5.4.4910 http://www.firebirdsql.org
Страница загрузки 		http://www.ibase.ru
Oracle database
Коммерческое ПО
9.2.0.1 http://www.oracle.com
Страница загрузки 		http://www.oracle.com/global/ru/index.html

1.1. Конфигурирование сервера

Младшая тестированная на совместимость версия - 1.5.4.4910. Использование более младшей версии на сервере недопустимо. Шаги установки примерно следующие:

  1. Первая страница содержит логотип проекта Firebird
    Установка FireBird (первая страница)
  2. Вторая страница содержит лицензионное соглашение. Для продолжения установки необходимо установить кнопку "I accept the agreement".
    Установка FireBird (вторая страница)
  3. Третья страница содержит информацию, необходимую для установки.
    Установка FireBird (третья страница)
  4. Четвертая страница позволяет указать папку на диске, в которую будут установлены файлы Firebird.
    Установка FireBird (четвертая страница)
  5. На пятой странице определяется тип установки. Мы конфигурируем сервер БД, и, соответственно, выбираем из выпадающего списка пункт "Full installation of Server and development tools". Необходимо определиться с выбором между различными архитектурами сервера. Если вы затрудняетесь в выборе между вариантами архитектуры сервера, то помните, что для однопроцессорных систем предпочтительнее Super Server, для многопроцессорных используется только Classic Server. Подробности можно посмотреть на сайте сопровождающей компании или на сайте проекта. Особое внимание требуется обратить на работу сервера на процессоре в режиме HyperThreading.
    Установка серверной части FireBird - выбор типа установки
  6. На шестой странице предлагается выбрать имя папки меню "Пуск", в которой будут созданы полезные ярлыки. В нашем случае ярлыки будут созданы для файлов документации, бесполезной в конечном счете для конечного пользователя. Поэтому мы ставим флажок "Don't create any icons".
    Установка FireBird (шестая страница)
  7. На седьмой странице необходимо выбрать параметры установки. Настоятельно рекомендуется включить флажок "Use the Guardian to control the server" и запускать сервер в режиме службы, то есть выбрать кнопку "Run as a Service". Также настоятельно рекомендуется установить флажок "Start Firebird automatically everytime you boot up". Программное обеспечение "Мельница данных" использует в работе библиотеку gds32.dll , загружая ее из системного каталога Windows. Поэтому в целях обеспечения нормальной работы необходимо установить оба флажка - "Copy Firebird client library to <system> directory" и "Generate client library as GDS32.DLL for legacy app. support".
    Установка серверной части FireBird - параметры установки
  8. На восьмой странице необходимо подтвердить установку с выбранными параметрами.
    Установка серверной части FireBird - подтверждение установки
  9. После установки на девятой странице можно ознакомиться с информацией об установленной версии.
    Установка FireBird (девятая страница)
  10. Десятая страница информирует об успешном завершении установки и позволяет запустить сервер немедленно. Рекомендуется установить флажок "Start Firebird Service now".
    Установка серверной части FireBird - установка завершена

Убедиться в том, что сервер установлен и запущен, можно из окна служб (Start → Control Panel → Administrative Tools → Services):

Установленный FireBird в списке сервисов

Использование embedded-сервера вполне допустимо, с учетом ограничений, налагаемых разработчиком. Для использования embedded-сервера необходимо положить файлы (с полным путем) из архива embedded-сервера рядом с исполняемыми файлами нашей системы, и переименовать файл FBEMBED.DLL в GDS32.DLL , примерно следующим образом:

Использование FireBird Embedded

Для работы с embedded-сервером имя сервера в строке соединения указывать нельзя. Кроме того, необходимо соблюдать рекомендации и требования разработчиков сервера.

Младшая тестированная на совместимость версия - 9.2.0.1. Использование более младшей версии недопустимо.

Если вы устанавливаете Oracle не с компакт-дисков, то не пользуйтесь программой автозапуска, лежащей в корне первого установочного диска, а запустите setup.exe из каталога install\win32 на первом установочном диске.

Шаги установки примерно следующие:

  1. Первая страница содержит логотип Oracle и командные кнопки. Для продолжения установки нажмите кнопку "Next".
    Установка Oracle (первая страница)
  2. На второй странице необходимо определиться с путями установки и источника, а также с именем "дома". Настоятельно рекомендуется принять значения, предлагаемые по умолчанию.
    Установка Oracle (вторая страница)
  3. На третьей странице необходимо выбрать устанавливаемый продукт. Для сервера БД необходимо выбрать продукт "Oracle9i Database 9.2.0.1.0".
    Установка серверной части Oracle
  4. На четвертой странице необходимо выбрать тип установки. Для обеспечения требуемой функциональности выберите тип "Standard Edition".
    Установка серверной части Oracle - выбор типа установки
  5. На пятой странице необходимо выбрать параметры базы данных, создаваемой автоматически при установке сервера. Рекомендуется никакой базы данных при установке не создавать, для чего выбрать пункт "Software Only".
    Установка серверной части Oracle - отказ от автоматического создания БД
  6. На шестой странице необходимо выбрать порт TCP/IP, используемый Oracle Services for MTS. По умолчанию 2030.
    Установка серверной части Oracle - порт MTS
  7. На седьмой странице необходимо подтвердить правильность параметров установки.
    Установка серверной части Oracle - подтверждение установки
  8. После окончания процесса вы увидете сообщение об успешном завершении установки. Нажмите кнопку "Exit".
    Установка серверной части Oracle - завершено
  9. После завршения работы инсталлятора автоматически будет запущено приложение "Enterprise Manager Console". Если по каким-либо причинам этого не произошло, запустите это приложение самостоятельно через меню "Пуск". В окне "Add Databases To Tree" нажмите кнопку "Cancel".
    Установка серверной части Oracle - отказ от использования Enterprise Manager Console
  10. Из меню выберите пункт Tools → Service Management → Oracle Net Manager.
    Установка серверной части Oracle - вызов Oracle Net Manager
  11. В появивщемся окне приложения "Oracle Net Manager" раскройте узел дерева "Local", встаньте на узел дерева "Listener" и нажмите на кнопку с большим зеленым плюсом в панели инструменов (слева).
    Установка серверной части Oracle - Oracle Net Manager
  12. В появивщемся окне добавления Listener'a введите имя (по умолчанию - LISTENER). Настоятельно рекомендуется принять умолчание.
    Установка серверной части Oracle - создание Listener'a
  13. Нажмите на кнопку "Add Address" в нижней части окна.
    Установка серверной части Oracle - создание адреса Listener'a
  14. В появившемся окне отображена информация о том, каким образом клиенты будут осуществлять соединение с сервером БД. Настоятельно рекомендуется принять умолчания - протокол TCP/IP, порт 1521.
    Установка серверной части Oracle - адрес Listener'a создан
  15. Из меню выберите пункт File → Save Network Configuration
    Установка серверной части Oracle - сохранение конфигурации
  16. Служба Listener'a будет создана при первой попытке создать базу данных. Закройте приложения "Oracle Net Manager" и "Enterprise Manager Console".

1.2. Конфигурирование клиента

Младшая тестированная на совместимость версия - 1.5.4.4910. Использование более младшей версии на клиенте недопустимо. Шаги установки примерно следующие:

  1. Первая страница содержит логотип проекта Firebird
    Установка FireBird (первая страница)
  2. Вторая страница содержит лицензионное соглашение. Для продолжения установки необходимо установить кнопку "I accept the agreement".
    Установка FireBird (вторая страница)
  3. Третья страница содержит информацию, необходимую для установки.
    Установка FireBird (третья страница)
  4. Четвертая страница позволяет указать папку на диске, в которую будут установлены файлы Firebird.
    Установка FireBird (четвертая страница)
  5. На пятой странице определяется тип установки. Мы конфигурируем клиентскую часть, и, соответственно, выбираем из выпадающего списка пункт "Minimum client install - no server, no tools". Кнопки в списке устанавливаемых компонентов будут автоматически выставлены в правильное положение.
    Установка клиентской части FireBird - выбор типа установки
  6. На шестой странице предлагается выбрать имя папки меню "Пуск", в которой будут созданы полезные ярлыки. В нашем случае ярлыки будут созданы для файлов документации, бесполезной в конечном счете для конечного пользователя. Поэтому мы ставим флажок "Don't create any icons".
    Установка FireBird (шестая страница)
  7. На седьмой странице необходимо выбрать параметры установки. Программное обеспечение "Мельница данных" использует в работе библиотеку gds32.dll, загружая ее из системного каталога Windows. Поэтому в целях обеспечения нормальной работы необходимо установить оба флажка - "Copy Firebird client library to <system> directory" и "Generate client library as GDS32.DLL for legacy app. support".
    Установка клиентской части FireBird - параметры установки
  8. На восьмой странице необходимо подтвердить установку с выбранными параметрами.
    Установка клиентской части FireBird - подтверждение установки
  9. После установки на девятой странице можно ознакомиться с информацией об установленной версии.
    Установка FireBird (девятая страница)
  10. Десятая страница информирует об успешном завершении установки.
    Установка клиентской части FireBird - установка завершена

Младшая тестированная на совместимость версия - 9.2.0.1. Использование более младшей версии на клиенте недопустимо.

Если вы устанавливаете Oracle не с компакт-дисков, то не пользуйтесь программой автозапуска, лежащей в корне первого установочного диска, а запустите setup.exe из каталога install\win32 на первом установочном диске.

Шаги установки примерно следующие:

  1. Первая страница содержит логотип Oracle и командные кнопки. Для продолжения установки нажмите кнопку "Next".
    Установка Oracle (первая страница)
  2. На второй странице необходимо определиться с путями установки и источника, а также с именем "дома". Настоятельно рекомендуется принять значения, предлагаемые по умолчанию.
    Установка Oracle (вторая страница)
  3. На третьей странице необходимо выбрать устанавливаемый продукт. Для рабочей станции необходимо установить продукт "Oracle9i Client 9.2.0.1.0".
    Установка клиентской части Oracle
  4. На четвертой странице необходимо выбрать тип установки. Для обеспечения требуемой функциональности выберите тип "Runtime".
    Установка клиентской части Oracle - выбор типа установки
  5. На пятой странице необходимо подтвердить правильность параметров установки.
    Установка клиентской части Oracle - подтверждение установки
  6. В процессе установки инсталлятор потребует настроить параметры соединения с сервером БД. Для этого запустится отдельный мастер "Oracle Net Configuration Assistant", и процесс установки будет приостановлен на время работы этого мастера.
    Если этого по каким-либо причинам не произошло, то после завершнения установки необходимо запустить это приложение из меню "Пуск" и выполнить описанные в этом и следующих шагах действия.
    На этой (первой) странице мастера необходимо отказаться от использования службы каталогов, выбрав кнопку "No, I will create net service names myself...".
    Установка клиентской части Oracle - конфигурирование подключения к БД - не использовать directory service.
  7. На второй странице мастера необходимо выбрать версию базы данных. Базы данных версии Oracle8 в любом случае не поддерживаются "Мельницей данных", поэтому выберите кнопку "Oracle8i or later database or service".
    Установка клиентской части Oracle - конфигурирование подключения к БД - версия БД
  8. На третьей странице мастера необходимо ввести имя сервиса, идентифицирующего базу данных на сервере (в данном случае - "RTT"). Это имя устанавливается при создании базы данных.
    Установка клиентской части Oracle - конфигурирование подключения к БД - имя сервиса
  9. На четвертой странице мастера выберите из списка доступных для соединения с БД протоколов протокол "TCP".
    Установка клиентской части Oracle - конфигурирование подключения к БД - протокол
  10. На пятой странице мастера введите адрес сервера, на котором установлена БД. Можно вводить как символьное имя сервера, так и IP-адрес. На этой же странице выберите порт TCP/IP, по которому будет производиться соединение с сервером. Порт по умолчанию - 1521.
    Установка клиентской части Oracle - конфигурирование подключения к БД - сервер и порт
  11. На шестой странице мастер предлагает протестировать заданные на предыдущих шагах параметры. Выберите кнопку "Yes, perform a test".
    Установка клиентской части Oracle - конфигурирование подключения к БД - тестирование соединения
  12. Если введенные на предыдущих страницах параметры соединения с БД были заданы корректно, то мастер сообщит об этом:
    Установка клиентской части Oracle - конфигурирование подключения к БД - успешное соединение
  13. На восьмой странице введите имя псевдонима подключения, который будет использоваться в дальнейшем для установки соединения с БД приложениями "Мальницы данных". Во избежание путаницы настоятельно рекомендуется именовать псевдоним так же, как и службу на сервере (в данном случае - RTT). сообщит об этом:
    Установка клиентской части Oracle - конфигурирование подключения к БД - псевдоним соедиения
  14. На девятой странице мастера у вас есть возможность выбрать, настроить еще одно подключение или завершить работу с мастером. После завршения установки вы всегда сможете вернуться к процедуре создания псевдонима подключений, вызвав из меню "Пуск" приложение "Oracle Net Configuration Assistant".
    Установка клиентской части Oracle - конфигурирование подключения к БД - отказ от создания следующего соединения
  15. На десятой странице мастер сообщает об успешном создании псевдонима соединения с БД.
    Установка клиентской части Oracle - конфигурирование подключения к БД - завершено конфигурирование соединения
  16. На десятой странице мастер сообщает об успешном завершении своей работы.
    Установка клиентской части Oracle - конфигурирование подключения к БД - завершено
  17. После завршения работы мастера "Oracle Net Configuration Assistant" вы увидете сообщение об успешном завершении работы инсталлятора. Нажмите кнопку "Exit".
    Установка клиентской части Oracle - завершено

2. Установка программного обеспечения платформы "Мельница данных"

Для установки ПП "Мельница данных" необходимо запустить файл setup.exe, расположенный на поставляемом компакт диске. После запуска программы установки необходимо следовать указаниям мастера установки.

Шаг 1: Выбор языка

Установка Мельницы Выбор языка

Шаг 2: Информация о версии устанавливаемого ПП

Установка Мельницы. Версия ПП

Шаг3: Выбор каталога установки файлов ПП

Установка Мельницы. Папка установки.

Шаг 4: Выбор файла лицензии

Установка Мельницы. Выбор лицензии.

Файл лицензии также расположен на поставляемом компакт-диске или высылается по электронной почте. В случае если не выбран никакой файл лицензий, то программа будет установлена в демонстрационном режиме. В последующем после получения файла лицензий необходимо будет переустановить ПП. Подробнее с лицензионным соглашением можно ознакомится в одноименном разделе настоящей документации.

Шаг 5: Выбор компонентов для установки

Установка Мельницы. Выбор компонентов.

На данном шаге вам необходимо выбрать набор компонентов для установки на локальный компьютер. В зависимости от специфики использования рабочего места, на которое устанавливается ПО, необходимо выбрать тип установки. Предлагаемые типы установок:

  • Рабочее место пользователя
  • Рабочее место администратора
  • Рабочее место разработчика
  • Только построитель запросов
  • По выбору

Для каждого из типов установки по умолчанию устанавливается свой набор компонентов. Вы можете дополнительно отметить тот или иной необходимый вам компонент для установки. Для выбора будут отображены только те компоненты, которые влачены в указанном вами лицензионном файле.

Полный перечень компонентов для установки:

  1. Обозреватель данных
  2. Построитель запросов
  3. Утилита обслуживания баз данных
  4. Утилита слияния баз данных
  5. Инструменты разработчика / Инструмент поставки решений
  6. Отладочный монитор
  7. Документация

Для некоторых из вышеперечисленных компонентов также можно выбрать состав устанавливаемого компонента. Описание назначений поставляемых компонент описано в разделе "Поставляемые компоненты ПП" настоящей документации.

После указания всех параметров мастер установки скопирует файлы на локальный компьютер и создаст в меню программ папку с ярлыками к установленным компонентам:

Установка Мельницы. Ярлыки после установки.

2.1. Поставляемые компоненты ПП "Мельница данных"
Обозреватель данных | Обозреватель данных (DataBrowser) - Основное приложение позволяющее просматривать и модифицировать данные. Приложение используется для разработки прикладных решений. Позволяет описывать объекты БД, их свойства, методы, пользовательские формы и отчеты. Это же приложение используется для работы с разработанными прикладными решения пользователями на локальных рабочих местах.
Утилита обслуживания БД | Утилита обслуживания базы данных (DBSetupShell) - Приложение, позволяющее создавать и обслуживать выбранную базу данных любой из поддерживаемых СУБД. Также при помощи данной утилиты можно создавать и удалять пользователей БД, создавать и восстанавливать резервные копии БД, импортировать и экспортировать данные из/в БД, а также выполнять процедуры по контролю целостности БД.
Построитель запросов | Построитель запросов (QueryBuilder) - Приложение, позволяющее визуальными средствами создавать интерактивные запросы на основе данных хранящихся в используемой БД. Созданные запросы сохраняются в стандартный формате SQL и полностью удовлетворяют архитектуре клиент-сервер. Сохраненные в виде файла запросы могут быть открыты пользователем по необходимости. Полученная таким образом информация будет актуальна в любой момент времени. Также существует возможность создания статистического отчета на основе Excel шаблона.
Отладочный монитор | Отладочный монитор (DebugView) - Средство позволяющее отслеживать все запросы к БД генерируемые "клиентской частью" прикладного решения, а также результат их исполнения сервером СУБД. Используется для отладки в процессе разработки прикладного решения.
Утилита слияния баз данных | Утилита слияния баз данных (Merger) - Данная утилита позволяет сравнивать данные и метаданные 2х различных БД. При помощи данного приложения можно с легкостью перенести, например данные из резервной копии в рабочую БД в случае не преднамеренного удаления большого числа объектов, тем самым избежать необходимости восстановления резервной копии недельной давности. Также используется для обновления версии ПП.
Редактор файлов документации | Редактор файлов документации (HelpEditor) - Незаменимое средство создания электронной справки и файлов документации в стандартном формате chm.

3. Создание и начальная инициализация базы данных

Для создания БД необходимо вопрользоваться утилитой обслуживания базы данных, поставляемой в комплекте ПП. После запуска одноименного приложения откроется окно панели управления утилиты:

После запуска одноименного приложения откроется окно панели управления утилиты:

Создание БД. Утилита обслуживания БД.

Для доступа к задачам необходимо заполнить параметры работы с базой данных:

  1. Источник данных : Необходимо указать используемую СУБД.
  2. База данных : Необходимо указать наименование создаваемого файла БД и его месторасположение. (Пример: c:\databases\base.fdb)
  3. Пользователь : Указать имя пользователя (Администратора) для используемой СУБД. Для Interbase/FireBird - SYSDBA, для Oracle - SYS.
  4. Пароль : Указать пароль пользователя (Администратора) для используемой СУБД. Для Interbase/FireBird - masterkey, для Oracle - SYS.

После заполнения полей параметров можно приступать к созданию БД. Для создания новой базы данных необходимо воспользоваться задачей "Создать новую БД". После нажатия кнопки "Выполнить" будут выполнены команды отображенные в окне "Командная строка".

Днные команды можно выполнить самостоятельно из командной строки операционой системы или из любого другого приложения. Также создать пустую БД можно средствами входящими в комплекты поставок соответствуеющих СУБД.
Создание БД. Вывод консольного приложения.

В окне "Вывод консольного приложения" будет отображен результат выполнения команд по созданию БД. В случае успешного выполнения всех необходимых команд, БД будет создана по указанному в параметрах месторасположению.

После создания пустой БД необходимо наполнить ее системными объектами (метаданными) для последующей работы с ПП "Мельница данных". Для этого необходимо выполнить задачу "Синхронизировать базу данных". После нажатия кнопки "Выполнить" будет автоматически запущен отладочный монитор отображающий процесс наполнения БД необходимыми метаданными. Данный процесс может занять от одной до нескольких минут в зависимости от используемой СУБД и производительности сервера. (Обычно около минуты) По окончании процесса в окне "Вывод консольного приложения" будет отображен результат выполнения инициализации базы данных.

Инициализация БД. Вывод консольного приложения.

Все действия по созданию и инициализации БД выполнены. БД готова к эксплуатации.

4. Управление доступом пользователей

После того, как база данных создана и инициализирована метаданными платформы, доступ к системе будет иметь один пользователь - администратор созданной БД. Добавление других пользователей, ролей пользователей и включение пользователей в роли выполняется в представлениях Пользователи и Роли в Системной форме. После начальной инициализации БД на вкладке Пользователи можно увидеть одного пользователя с именем, соответствующим логину администратора БД (Например, для FireBird пользователь SYSDBA), на вкладке Роли можно увидеть одну роль с наименованием Администраторы. На подчиненных вкладках этих представлений можно увидеть, что пользователь - администратор включен в роль Администраторы.

Профиль пользователя формируется путем определения для него:

  1. Перечня доступных форм
  2. Перечня доступных визуальных групп
  3. Перечня групп запретов

Формирование профиля происходит одинаково как для роли, так и для отдельного пользователя. Однако рекомендуется формировать профили для ролей, а не для отдельных пользователей. В этом случае при подключении к системе новых пользователей, изменении параметров доступа для существующего пользователя достаточно будет включить пользователя в одну из ролей, или исключить его из роли. Роли рекомендуется формировать содержательным образом на основе распределения обязанностей реальных пользователей, работающих с прикладным решением.

4.1. Создание пользователей

Создание пользователя системы включает в себя два этапа:

  1. Создание пользователя БД средствами используемой СУБД. Для этого наряду с возможностями каждой из СУБД Утилитой обслуживания БД предлагается действие Создать пользователя. Предлагаемые Утилитой по умолчанию пути к БД и параметры доступа требуют уточнения в зависимости от условий функционирования реальной БД. Задавать права доступа пользователя к объектам БД на данном этапе не надо.
  2. В Системной форме на вкладке Пользователи создать нового пользователя при помощи соответствующего действия контекстного меню.
    В поле Имя нужно вветси строку, строго соответствующую логину пользователя БД в вернем регистре.
    Особых требований к полю Наименование не предъявляется. Однако рекомендуется вводить в это поле фамилию и имя реального пользователя системы, например, Смирнов Иван Николаевич, что позволить в последующем получать информативные данных об активности пользователей системы.

4.2. Создание ролей

Создание ролей производится на вкладке Роли Системной формы при помощи действия Создать, вызываемого из контекстного меню. Имя и наименование роли могут быть любыми строками. Однако именовать роли по названиям соответствющих функциональных участков системы, например,

  • Начальник отдела кадров
  • Инспектора по работе с личными данными персонала
  • Инспектора по социальным вопросам
В случаях, когда реальные пользователи совмещают несколько ролей, роли лучше формировать отдельно, после чего одного пользователя можно влючить одновременно в несколько ролей.

4.3. Включение пользователей в роли

В роль могут включаться как пользователи, так и другие роли. Для добавления в роль нового члена роли нужно выбрать роль на вкладке Роли, отрыть подчиненную вкладку Члены роли и вызвать на ней действие Создать. Поля формы параметров заполняются следующим образом:

  • Пользователь - в этом поле необходимо выбрать либо одного из пользователей, либо одну из ролей. В зависимости от того, выбран ли пользователь или роль, будет меняться доступность следующих ниже полей.
  • Основная роль - в этом поле можно установить значение Да или Нет. Если пользователь включен в нескольно ролей, то среди них можно выделить одну основную. Разработчик прикладного решения на платформе сможет использовать это значение для управления доступом к объектам системы. Поле доступно для выбора значения только в том случае, если в поле Пользователь выбран именно пользователь, а не роль.
  • Добавить связанные роли - в этом поле можно установить значение Да или Нет. Поле доступно для выбора значения только в том случае, если в поле Пользователь выбрана роль. При установке значения Да в роль будут включены также все роли, входящие в выбранную. при установке значения Нет будет включена только одна роль без подчиненных ролей.

После включения пользователя в роль он получает права доступа ко всем визуальным группам и формам, а также к группам запретов, заданным для роли.

4.4. Формирование перечня доступных визуальных групп

Визуальные группы создаются разработчиком прикладного решения. Работа с визуальными группами ведется в Системной форме на вкладке Визуальные группы. Каждая визуальная группа содержит набор форм и также может быть снабжена иконкой. Визуальные группы отображаются на Консоли управления, которая показывается при запуске системы.

Для каждой роли (или для отдельного пользователя) формируется перечень визуальных групп, которые будут ему доступны на Консоли управления. Если визуальных групп в прикладном решение не создано, или если пользователю не доступно ни одной визуальной группы, консоль управления не будет отображена. В этом случае при открытии системы пользователь увидит первую из доступных ему форм, которая открывается автоматически.

Для добавления новой визуальной группы, доступной роли или пользователю, необходимо выбрать роль или пользователя на соответствующей вкладке (Роли или Пользователи), отрыть подчиненное представление Доступные визуальные группы и выполнить в нем действие Создать. В форме параметров нужно выбрать одну из существующих визуальных групп. Если необходимо дать доступ к нескольким визуальным группам, действие создания нужно повторить.

Если пользователь включен в несколько ролей, то достаточно наличия доступа к визуальной группе в одной из этих ролей.

4.5. Формирование перечня доступных форм

Формы создаются разработчиком прикладного решения. Работа с визуальными группами ведется в Системной форме на вкладке Формы. Каждая форма представляет собой набор представлений, связанных друг с другом определенным образом. Иконки всех форм, доступных пользователю, отображаются на Панели инструментов в верхней части экрана. Нажимая на одну из иконок форм, пользователь может переключаться между ними. Если форма входит в одну из доступных пользователю визуальных групп, она отобразится на консоли управления. В этом случае переключаться между формами пользователь сможет как на Панели инструментов, так и на Консоли управления.

Для каждой роли (или для отдельного пользователя) формируется перечень форм, которые будут ему доступны на Консоли управления. При открытии системы пользователь видит первую из доступных ему форм, открываемую автоматически.

Для добавления новой формы, доступной роли или пользователю, необходимо выбрать роль или пользователя на соответствующей вкладке (Роли или Пользователи), отрыть подчиненное представление Доступные формы и выполнить в нем действие Создать. В форме параметров нужно выбрать одну из существующих форм. Если необходимо дать доступ к нескольким формам, действие создания нужно повторить.

Если пользователь включен в несколько ролей, то достаточно наличия доступа к форме в одной из этих ролей.

4.6. Формирование перечня групп запретов

Группы запретов могут формироваться как разработчиком прикладного решения, так и администратором системы. Работа с группами запретов ведется на соответствующей вкладке Системной формы. В каждую группу запретов включаются запреты трех видов:

  • Запрет на класс
  • Запрет на свойство
  • Запрет на подпрограмму

Запреты на класс и свойство могут даваться как только на запись, так и на чтение и запись объектов. Наличие запретов для определенной роли или пользователя приводит к тому, что пользователь не видит или не имеет прав на модификацю объетов определенных классов или отдельных их свойств. Запреты на подпрограммы выражаются в том, что для пользователя не отображаются действия, вызывающие ряд подпрограмм.

5. Ключи командной строки утилиты обслуживания БД

Утилита обслуживания БД - консольное приложение. При запуске приложения оно сообщает о поддерживаемых режимах и ключах командной строки. Ключи указываются через пробел. Ключ должен начинаться символом "/". Для ключей, содержащих значения параметров, между ключем и значением должен быть пробел. Имена файлов и папок, содержащие пробелы, в командной строке должны быть заключены в кавычки.

При работе с утилитой общее правило состоит в том, что первым параметром передается строка соединения с БД, вторым параметром необязательная команда. Остальные параметры и ключи указываются в зависимости от выбранной команды.

Если работа утилиты завершилась успешно, то она возвращает код завершения 0. Если в процессе работы утилиты произошли ошибки, то код завершения будет равен 1. Если работа утилиты завершилась успешно, но были выданы предупреждения, то она возвращает код завершения 2.

Поддерживаемые команды:

<Команда не указана> | Инициализация/cинхронизация БД
ping | Проверка доступности БД
pump | Перекачка данных
check | Проверка целостности БД
build | Перестройка всех метаданных
load | Загрузка доступных файлов
export | Экспорт реплики данных
import | Импорт реплики данных

Далее будут рассмотрены подробности работы каждого из режимов.

5.1. Перекачка данных

Для осуществления перекачки данных необходимо:

  1. Иметь права владельца схемы в БД - приемнике.
  2. Иметь права владельца схемы в БД - источнике.
  3. Если не задан ключ /M, то БД - приемник должен быть пустой схемой, не содержащей никаких объектов.
Эти условия контролируются утилитой dbsetup.exe.

Перекачка данных осуществляется в любом направлении. Ниже представлены варианты сочетания источников и приемников данных. В случае, если попытка использовать тот или иной оптимизационный механизм оказалась неудачной, производится стандартная перекачка.

Приемник | Источник
 | БД MSSQL | БД Firebird | БД Oracle | БД PostgreSQL | Папка, файл, zip-архив
БД MSSQL | Стандартная перекачка данных
БД Firebird | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("external table"). | Предпринимается попытка использовать механизм "внешний источник данных" ("external data source"). | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("external table").
БД Oracle | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("table organization external"). |  | Предпринимается попытка использовать механизм "связи БД" ("database link"). | Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("table organization external").
БД PostgreSQL | Предпринимается попытка использовать механизм загрузки данных из внешнего текстового файла оператором COPY. |  |  | Предпринимается попытка использовать расширение "dblink". | Предпринимается попытка использовать механизм загрузки данных из внешнего текстового файла оператором COPY.
Папка, файл, zip-архив | Стандартная перекачка данных | Предпринимается попытка собрать на сервере blob, содержащий целевой xml-документ. |  |  | Не имеет смысла. Просто скопируйте файлы.

Используемые параметры и ключи командной строки:

Для перекачки данных используюется команда pump. В строке соединения указывается БД-приемник, кроме случая перекачки данных из БД в папку, файл или zip-архив. Для всех случаев кроме случая перекачки данных из БД в папку, файл или zip-архив командная строка содержит кляузу pump from. Для случая перекачки данных из БД в папку, файл или zip-архив командная строка содержит кляузу pump to.
Перекача данных из БД Oracle в БД Firebird:
dbsetup.exe fb#sysdba/masterkey@host:database pump from ora#dataowner/password@host/sid.dataowner
Перекача данных из zip-архива в БД Firebird:
dbsetup.exe fb#sysdba/masterkey@host:database pump from c:\dbbackup.zip
Перекача данных из БД Firebird в zip-архив:
dbsetup.exe fb#sysdba/masterkey@host:database pump to c:\dbbackup.zip

Ключ | Назначение
/J <Целое число> | Определяет число потоков, осуществляющих перекачку данных. По умолчанию соответствует количеству ядер процессора.
/H <Целое число> | Определяет базовое количество записей в блоке перекачки. По умолчанию - 1 млн. записей. Для таблиц, содержащих большие объекты (blob и/или clob) размер блока перекачки определяется как базовый размер блока, деленный на 100. Если источником является папка, файл или zip-архив - ключ игнорируется.
/M | Пропустить этап создания таблиц и последовательностей в БД (таблицы и последовательности должны быть созданы заранее).
/G | Пропустить этап заливки данных, произвести только создание таблиц и последовательностей в БД.
/K <Список таблиц> | Не перекачивать данные указанных таблиц. Список таблиц разделяется символом ";" (точка с запятой).
/NODBLINK | Принудительно отключает механизмы связи между БД на сервере.
/NOCSV | Принудительно отключает механизмы загрузки данных из внешнего файла.
/NOXML | Принудительно отключает механизмы cборки xml-документа на сервере.

Информация о значениях типа "внешние данные" будет перенесена из источника в приемник, сами внешние данные при этом перенесены в хранилище не будут.

При перекачке данных учитыватся табличное пространство ("группа файлов") каждой таблицы в случае, если это понятие релевантно для источника и приемника. При использовании папки, файла или zip-архива имя табличного пространства каждой таблицы сохраняется в файле RTTI, и будет использовано, если окажется релевантным. Если в приемнике имеется возможность разместить таблицу в табличное пространство с тем же именем, которое указано в источнике, то это будет сделано.

При перекачке данных таже осуществляется перенос последовательностей. При этом переносится текущее значение каждой из последовательностей. Значение кеша последовательности переносится только в том случае, если это понятие релевантно для источника и для приемника. При использовании папки, файла или zip-архива значение кеша сохраняется в файле Sequences, и будет использовано, если окажется релевантным.

После завершения перекачки данных в схеме-приемнике остаются следующие объекты:

  • Таблицы данных.
  • Первичные ключи таблиц данных.
  • Последовательности.
  • Заголовки системных объектов платформы.

Этот набор минимально достаточен, чтобы с помощью синхронизации (загрузив метаданные из таблиц, с ключем /T) восстановить метаданные БД в соответствующей схеме, и работать с ней средствами платформы.

Особенности перекачки данных в папку, файл или zip-архив:

При использовании папки она рассматривается как хранилище файлов перекачки. При использовании файла он рассматривается как хранилище файлов перекачки в формате Microsoft Compound File. При использовании zip-архива он рассматривается как хранилище файлов перекачки. Хранилище файлов перекачки содержит следующие файлы:

  • FormatSettings - xml-файл с информацией о региональных настройках процесса, сформировавшего хранилище.
  • Sequences - xml-файл с информацией о текущих значениях последовательностей.
  • RTTI - xml-файл с информацией о таблицах и полях. Также содержит информацию о табличных пространствах.
  • <Имя Таблицы> с возможным числовым постфиксом в скобках - xml-файл с данными таблицы в стандартном xml-представлении.
  • #<Длина файла в 16-ричном представлении, 16 символов><CRC файла в 16-ричном представлении, 8 символов> - двоичный файл с содержимым blob/clob. Такие файлы формируются для объектов, чей размер превышает 1MB.

Остальные файлы в хранилище будут проигнорированы (если хранилище используется как источник) или удалены (если хранилище используется как приемник).

Если в качестве приемника используется zip-архив, то механизм перекачки данных будет использовать информацию об уже содержащихся в архиве файлах, и не будет повторно "пересжимать" уже имеющиеся файлы. Таким образом, можно удобно релизовать "инкрементальное резервное копирование", указывая в качестве приемника перекачки данных один и тот же zip-архив.

5.1.1. Стандартная перекачка данных

Стандартная процедура перекачки блока данных заключается в открытии однонаправленного курсора на основании запроса типа select... from "..." к таблице-источнику, подготовке запроса insert into "..."("ID",.....) values (:Param1, :Param2....) к приемнику, и многократному выполнению этого единожды подготовленного запроса по мере продвижения вперед по курсору-источнику. Все значения полей при этом проходят через клиентскую сторону, и заливка данных осуществляется по одной записи за одно выполнение запроса. Характерная скорость такой заливки - порядка 5000 записей в секунду.

Оператор INSERT в процессах перекачки данных всегда формируется с подсказкой /*+ APPEND */.

Описанные далее механизмы оптимизации не могут использоваться одновременно. Если какой-либо из них может быть использован в вашей ситуации - постарайтесь обеспечить условия, необходимые для их работы. Вы получите значительное ускорение перекачки.

5.1.2. Механизмы связи между БД на сервере

Будут формироваться и выполняться блоки вида
01execute block as
02  declare "ID" BIGINT;
03  declare "P0" SMALLINT;
04  .....
05begin
06  for execute statement 'select "ID", .... from "...."'
07    on external data source '....' as user '...' password '....'
08    into :"ID",:"P0",..... do
09      insert into "...."("ID",....)
10      values (:"ID",:"P0",.....);
11end

Механизм может быть использован, если пользователь-владелец схемы имеет право CREATE DATABASE LINK, и оператор create database link будет выполнен без ошибок. При этом будет создан link с именем "SYS$PUMP". После завершения процедуры перекачки данных link будет удален. Таким образом, можно в целях безопасности выдавать право CREATE DATABASE LINK владельцу схемы данных только на время перекачки данных. При этом генерируются и выполняются операторы вида
1INSERT /*+ APPEND */ INTO "..."("ID", ....)
2SELECT "ID", ....
3  FROM "..."@"SYS$PUMP"
4...

Механизм может быть использован, если в БД установлено стандартное расширение "dblink", и оператор select public.dblink_connect('user=... password=.......') будет выполнен без ошибок. При этом генерируются и выполняются операторы вида
01do $$
02declare
03  cnt int;
04begin
05  perform public.dblink_connect('user=... password=... ....');
06  perform public.dblink_open('SYS$....', 'select T."ID", ..... from "...." T');
07  loop
08    insert into "...." ("ID", .....)
09    select T."ID" from public.dblink_fetch('SYS$.....', 1000000)
10    as T("ID" bigint, .....);
11    get diagnostics cnt = row_count;
12    exit when cnt = 0;
13  end loop;
14end; $$

Механизм может быть принудительно заблокирован ключем /NODBLINK.

5.1.3. Загрузка данных из внешнего файла

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Временная папка процесса dbsetup.exe (переменная окружения %TMP%) доступна сервису Firebird как источник внешних данных (в конфигурации FireBird - параметр ExternalFileAccess).
  • Таблица не содержит полей типа BLOB.
  • Таблица не содержит обнуляемых полей, все поля таблицы обязательные.
  • Загружаемый блок содержит как минимум 1000 записей.
В этом случае во временной папке будет создан временный файл, содержащий загружаемые данные в требуемом Firebird формате, и выполнены операторы:
1create table "DML..." external '.....'
2  ("ID" BIGINT,
3  ....);
4insert into "..."("ID", ...)
5  select "ID", ....
6  from "DML....";
7drop table "DML....";
После чего временный файл будет удален.

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Владельцу данных доступна на чтение и запись хотя бы одна папка (directory). Этого можно достичь, например, такими операторами:
    1CREATE DIRECTORY dir_name AS 'D:\TEMP';
2GRANT READ,WRITE ON DIRECTORY dir_name TO user_name;
    При этом папка (на диске) должна быть доступна на запись процессу dbsetup.exe.
  • Оператор
    01create table "DML...."
02(
03 ....
04) ORGANIZATION EXTERNAL (
05  DEFAULT DIRECTORY ....
06  ACCESS PARAMETERS (
07    RECORDS DELIMITED BY NEWLINE
08    FIELDS TERMINATED BY '....'
09  )
10  LOCATION ('DML.....')
11)
    выполняется без ошибок. Созданная при этом таблица доступна для чтения.
  • Таблица не содержит полей типа BLOB.
  • Загружаемый блок содержит как минимум 1000 записей.
В этом случае в папке, которая доступна, будет создан временный файл, содержащий загружаемые данные в требуемом Oracle формате, и выполнены операторы:
1create table "DML....."
2(
3 ....
4) ORGANIZATION EXTERNAL (
5....);
6insert into "..."("ID", ...)
7  select "ID", ....
8  from "DML....";
9drop table "DML....";
После чего временный файл будет удален.

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:
  • Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).
  • Временная папка процесса dbsetup.exe (переменная окружения %TMP%) доступна сервису PostgreSQL как источник внешних данных.
В этом случае в папке, которая доступна, будет создан временный файл, содержащий загружаемые данные в требуемом Postgres формате. В случае, когда размер файла превысит 1GB, а также по исчерпании источника, будет выполнен оператор
  copy "..."(...) from %TEMP%\DML....CSV with (format csv, encoding UTF8)
После чего временный файл будет удален.

Механизм может быть принудительно заблокирован ключем /NOCSV.

5.1.4. Сборка xml-документа на сервере

Механизм создает большую нагрузку на сервер БД, но в то же время позволяет существенно ускорить перекачку данных.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующие условия:
  • Таблица не содержит полей типа BLOB.
  • Таблица не содержит строковых полей, которые могут содержать не-xml-compaint символы (определяется по свойствам соответствующего строкового домена.
В этом случае будут формироваться и выполняться запросы вида
1with T as (select T.* from "...." T order by T."ID")
2select cast(cast(
3  '<data handle="' || count(1) ||  '" eof="1">' || list('<row>' ||
4    '<ID type="int64">' || T."ID" || '</ID>' ||
5      case when T."..." is null then '<.../>' else '<... type="int">' || T."..." || '</...>' end ||
6      ......
7    || '</row>' , '') || '</data>' as blob sub_type 1 character set utf8) as blob sub_type 0), count(1)
8  from T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующие условия:
  • Используется Oracle версии не ниже 11.
  • Таблица не содержит полей типа BLOB.
В этом случае будут формироваться и выполняться запросы вида
1with T as (select T.* from "..." T )
2select "SYS$HELPER"."ClobToBlob"('<data handle="' || count(1) || '" eof="1">' ||
3  xmlagg(xmlelement("row", xmlelement("ID", xmlattributes('int64' as "type"), T."ID"),
4    case when "..." is null then xmltype('<..../>') else
5      xmlelement("....", xmlattributes('ascii' as "type"), "SYS$HELPER"."XMLEscape"(asciistr(T."...."), 0)) end,
6    ....
7 order by T."ID").getclobval() || '</data>'), count(1) from T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующее условие:
  • Таблица не содержит полей типа BLOB.
В этом случае будут формироваться и выполняться запросы вида
1select convert_to( '<data handle="' || count(1) ||  '" eof="1">' || string_agg(
2  '<row>' ||
3    '<ID type="int64">' || T."ID" || '</ID>' ||
4    case when T."...." is null then '<..../>' else '<.... type="int64">' || T."...." || '</....>' end ||
5    .....
6  '</row>', '' order by T."ID") || '</data>', 'UTF8'), count(1) from "..." T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Механизм может быть принудительно заблокирован ключем /NOXML.

6. Ключи командной строки инсталлятора платформы

Для автоматизации установки или обновления платформы инсталлятор платфромы setup.exe поддерживает ключи командной строки.
Указание ключей командной строки не превращет инсталлятор платфромы setup.exe в консольное приложение. Поэтому если вы включаете запуск инсталлятора в файл пакетной обработки, вам, возможно, потребуется дождаться завершения процесса установки. Для этого рекомендуется использовать команду start (с ключем /w или /wait. Рекомендуется ознакомиться со справкой по команде start перед ее использованием) :
start /w "SOME_TITLE" "...\SOME_FOLDER\setup.exe" /N /S /P /F .....

Ключи указываются через пробел. Ключ должен начинаться символом "/". Для ключей, содержащих значения параметров, между ключем, символом "=" и значением параметра пробелов быть не должно.

Ключи командной строки:

Ключ | Назначение
/S | Запускает инсталлятор в режиме "без пользовательского интерфейса". Никакого взаимодействия с пользоваетелем не предусматривается. Если ключ /S не указан, то режимы, устанавливаемые остальными ключами, будут являться умолчаниями, и пользователь сможет их изменить в процессе взаимодействия с инсталлятором.
/NCRC | Отключает проверку целостности инсталлятора перед запуском.
/x64 | Устанавливает компоненты 64-разрядной редакции. См. замечание 1.
/L="<Файл лицензии>" | Позволяет указать файл лицензии. Необходимо использовать полный путь к файлу. Если имя файла лицензии содержит пробелы, то его необходимо заключать в кавычки. См. замечание 2.
/T=<Число от 0 до 7> Выбирает тип установки (состав устанавливаемых компонент).
  • 0 - Рабочее место пользователя
  • 1 - Рабочее место администратора
  • 2 - Рабочее место разработчика
  • 3 - Только построитель запросов
  • 4 - Сервер приложений
  • 5 - Только сервер приложений
  • 6 - Только отладочный монитор
  • 7 - Только системные файлы
Точно установить, какие конкретно компоненты входят в тот или иной тип установки можно, запустив инсталлятор, на странице "Параметры установки". Там указано соответствие между типами установки и устанавливаемыми компонентами.
/LANG=<Идентификатор языка> Поддерживаемые языки:
  • 1033 - Английский
  • 1049 - Русский
  • 1034 - Испанский
/N | Без регистрации компонентов в реестре и создания ярлыков. Только копирование файлов.
/NOREGISTER
/U | Без создания ярлыков. Только копирование файлов и регистрация компонентов.
/UPDATE
/NOSERVICE | Не регистрировать сервисы в системе.
/P | Не проверять возможность обновления файлов.
/NOPROCLIST
/F | Не устанавливать третьесторонние распространяемые файлы.
/NOINSTALLREDIST
/NODISABLEOFFICECLIPBOARD | Не устанавливать библиотеку поддержки приложений Microsoft Office.
/NO_DISABLE_OFFICE_CLIPBOARD
/D=<Папка установки> Указывает папку установки. Необходимо указывать полный путь к папке.
Этот ключ может быть указан только последним в командной строке, либо не указан вообще.
Даже если имя папки установки содержит пробелы, то заключать в кавычки значение ключа /D не нужно.
setup.exe /NCRC /S /D=C:\Program Files\Data Mill

Замечания:

  1. Если ключ /x64 не задан, но в папке установки уже содержится папка WIN64, то все равно будет устанавливаться (в данном случае - обновляться) 64-битная редакция.
  2. Если ключ /L=... не задан, но рядом с инсталлятором пллатформы setup.exe находится хотя бы один файл с расширением .license, то в качестве файла лицензии будет использоваться один из этих файлов (первый найденный).

7. Форматы и соглашения

7.1. Стандартная адресация базы данных платформы

Строка адресации БД платформы "Мельница данных" состоит из следующих элементов:
Сервер#Пользователь:Роль/Пароль@БазаДанных

Сервер - один из следующих вариантов:

  • MS - БД MSSQL
  • FB - БД Firebird
  • ORA - БД Oracle Database
  • PG - БД PostgreSQL
  • MY - БД MySQL
  • APP - Удаленное подключение к БД через сервер приложений

Пользователь - имя пользователя, используемого для соедиения.

Роль - роль, ассоциированная с соединением.
Роль, заданная в строке адресации БД, используется для установки соединения с БД (передается через параметр isc_dpb_sql_role_name)
Для всех СУБД, кроме Firebird, указание роли имеет смысл только для утилиты обслуживания БД.

Пароль - пароль пользователя, используемый для соедиения. Пароль также может быть не задан в строке соединения (после символа "/" сразу следует символ "@"). В этом случае пароль будет запрошен у пользователя (если будет такая возможность), или будет использоваться Negotiate-аутентификация.

БазаДанных - адресует собственно базу или схему данных.
При использовании удаленного подключения к БД через сервер приложений используется нотация
protocol://Host:Port/handler
Протокол (protocol) может быть http или https. По умолчанию используется протокол http. Порт (Port) по умолчанию 80 для протокол http и 443 для протокола https может быть опущен.
Host:Port\\InstanceName.Database
Порт (Port) по умолчанию 1433 может быть опущен вместе с двоеточнием. Хост (Host) может быть опущен, если используется локально. Имя экземпляра (InstanceName) может быть опущено, если используется имя "MSSQLSERVER". Следующие строки эквивалентны:
1localhost:1433\\MSSQLSERVER.MillDatabase
2localhost\\MSSQLSERVER.MillDatabase
3localhost.MillDatabase
4MillDatabase

Host/Port:DBPath
Порт (Port) по умолчанию 3050 может быть опущен. Если опущен хост (Host), то используется локальный протокол доступа к БД. Файл базы данных (DBPath) может быть задан как полное имя файла в файловой системе сервера, так и быть псевдонимом, настроенным на сервере.
Host:Port/SID.schema
Порт (Port) по умолчанию 1521 может быть опущен. Если опущен хост (Host), то используется имя из файа TNSNAMES.ORA в используемой клиентской части СУБД. Указание SID и имени схемы (schema) обязательно.
Host:Port/DataBase.schema
Порт (Port) по умолчанию 5432 может быть опущен. Если опущен хост (Host), то используется локальное соединение. Указание имени базы данных (DataBase) и имени схемы (schema) обязательно.
Host:Port/schema
Порт (Port) по умолчанию 3306 может быть опущен. Если опущен хост (Host), то используется локальное соединение. Указание имени схемы (schema) обязательно.

Прямое подключение к БД от имени владельца схемы данных является административным.
Владельцем схемы данных является пользователь, имя которого совпадает с именем схемы.
Никакое подключения к БД через сервер приложений не является административным.


Мельница данных ((раздел целиком))

Мельница данных- Класс TField (Поля) (раздел целиком) (22.10.2024) (одним файлом)
Класс TField (Поля)

Диаграмма Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

1. Свойства

Свойства класса TField:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Видимо пользователю | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
Indexed | Boolean | Да | Видимо пользователю | Чтение/Запись | Индексируется
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись | Протоколировать
Localizable | Boolean | Да | Видимо пользователю | Чтение/Запись | Локализуемое

2. Конструктор Create (Конструктор поля)

Конструктор класса TField.

1constructor TField.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; CreateProperty: Boolean; CreateConstructorParameter: Boolean;
4  CreateViewColumns: Boolean; Logged: Boolean; Indexed: Boolean;
5  Localizable: Boolean): TObject;

Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
CreateProperty | Boolean | Да | Создать свойство
CreateConstructorParameter | Boolean | Да | Создать параметр конструктора
CreateViewColumns | Boolean | Да | Создать колонку во всех представлениях
Logged | Boolean | Да | Протоколировать
Indexed | Boolean | Да | Индексируется
Localizable | Boolean | Да | Локализуемое

Замечания:

Создает новый объект класса TField.

3. Метод SetLocalizable (Установить значение свойства "Локализуемое")

Метод экземпляра класса TField.

procedure TField.SetLocalizable(Value: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Value | Boolean | Да | Значение


Мельница данных ((раздел целиком))

Мельница данных- Класс TActionContextProperty (Свойство контекста) (раздел целиком) (22.10.2024) (одним файлом)
Класс TActionContextProperty (Свойство контекста)

Класс TObject (Объекты)Класс TAction (Действия)

Имена объектов класса генерируются.

1. Свойства

Свойства класса TActionContextProperty:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Property | TProperty | Да | Видимо пользователю | Чтение/Запись | Свойство
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция

2. Конструктор Create (Конструктор контекстного свойства)

Конструктор класса TActionContextProperty.

1constructor TActionContextProperty.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Property: TProperty; Position: Integer): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Property | TProperty | Да | Свойство
Position | Integer | Да | Позиция

Замечания:

Создает новый объект класса TActionContextProperty.

3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TActionContextProperty.

class function TActionContextProperty.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.


Мельница данных ((раздел целиком))

Мельница данных- Класс TClassBan (Запрет на класс) (раздел целиком) (22.10.2024) (одним файлом)
Класс TClassBan (Запрет на класс)

Класс TBanGroupItem (Элементы группы запретов)Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TClassBan:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TBanGroup | Да | Видимо пользователю | Только для чтения | Унаследовано от TBanGroupItem
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
BannedClass | TClass | Да | Видимо пользователю | Только для чтения | Запрещаемый класс

2. Конструктор Create (Конструктор запрета на класс)

Конструктор класса TClassBan.

1constructor TClassBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass): TObject;

Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
BannedClass | TClass | Да | Запрещаемый класс

Замечания:

Создает новый объект класса TClassBan.


Мельница данных ((раздел целиком))

Мельница данных- Справочник по интерфейсам (раздел целиком) (22.10.2024) (одним файлом)
Справочник по интерфейсам

1. Перечисление TQueryPart
1type
2  TQueryPart = (qpWhat, qpWhere, qpOrder, qpGroup, qpHaving, qpInnerJoin,
3    qpOuterJoin);

Или

01type
02  TQueryPart = TOleEnum;
03const
04  qpWhat = $00000000;
05  qpWhere = $00000001;
06  qpOrder = $00000002;
07  qpGroup = $00000003;
08  qpHaving = $00000004;
09  qpInnerJoin = $00000005;
10  qpOuterJoin = $00000006;

Элементы перечисления:

Имя | Значение | Назначение
qpWhat | 0 |
qpWhere | 1 |
qpOrder | 2 |
qpGroup | 3 |
qpHaving | 4 |
qpInnerJoin | 5 |
qpOuterJoin | 6 |

2. Перечисление TQuerySpecial
1type
2  TQuerySpecial = (qsNone, qsObjectID, qsParentID, qsHasChildren,
3    qsFilterCondition, qsUplink, qsRootOnly, qsDescending, qsCount, qsSum, qsMin,
4    qsMax, qsAverage, qsMasterLink, qsSelectedOnly, qsDistinct, qsViewCondition,
5    qsCaseInsensitive, qsAsString, qsListed, qsName, qsDescription, qsFunction,
6    qsCountDistinct, qsBoolean, qsExact, qsSearchIndex, qsOptimizationParameters);

Или

01type
02  TQuerySpecial = TOleEnum;
03const
04  qsNone = $00000000;
05  qsObjectID = $00000001;
06  qsParentID = $00000002;
07  qsHasChildren = $00000003;
08  qsFilterCondition = $00000004;
09  qsUplink = $00000005;
10  qsRootOnly = $00000006;
11  qsDescending = $00000007;
12  qsCount = $00000008;
13  qsSum = $00000009;
14  qsMin = $0000000A;
15  qsMax = $0000000B;
16  qsAverage = $0000000C;
17  qsMasterLink = $0000000D;
18  qsSelectedOnly = $0000000E;
19  qsDistinct = $0000000F;
20  qsViewCondition = $00000010;
21  qsCaseInsensitive = $00000011;
22  qsAsString = $00000012;
23  qsListed = $00000013;
24  qsName = $00000014;
25  qsDescription = $00000015;
26  qsFunction = $00000016;
27  qsCountDistinct = $00000017;
28  qsBoolean = $00000018;
29  qsExact = $00000019;
30  qsSearchIndex = $0000001A;
31  qsOptimizationParameters = $0000001B;

Элементы перечисления:

Имя | Значение | Назначение
qsNone | 0 |
qsObjectID | 1 |
qsParentID | 2 |
qsHasChildren | 3 |
qsFilterCondition | 4 |
qsUplink | 5 |
qsRootOnly | 6 |
qsDescending | 7 |
qsCount | 8 |
qsSum | 9 |
qsMin | 10 |
qsMax | 11 |
qsAverage | 12 |
qsMasterLink | 13 |
qsSelectedOnly | 14 |
qsDistinct | 15 |
qsViewCondition | 16 |
qsCaseInsensitive | 17 |
qsAsString | 18 |
qsListed | 19 |
qsName | 20 |
qsDescription | 21 |
qsFunction | 22 |
qsCountDistinct | 23 |
qsBoolean | 24 |
qsExact | 25 |
qsSearchIndex | 26 |
qsOptimizationParameters | 27 |

3. Интерфейс IButton

1type
2  IButton = interface(IDispatch)
3    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
4    function Get_Enabled: WordBool; safecall;
5    procedure Set_Enabled(Value: WordBool); safecall;
6    function Name: WideString; safecall;
7    procedure Click; safecall;
8    property Enabled: WordBool read Get_Enabled write Set_Enabled;
9  end;

3.1. Свойства

Свойства интерфейса IButton:

Имя | Тип | Доступ | Назначение
Enabled | WordBool | Чтение/Запись |

3.2. Метод Click

Метод интерфейса IButton.

procedure IButton.Click;

Метод не имеет параметров.

3.3. Метод Name

Метод интерфейса IButton.

function IButton.Name: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

4. Интерфейс IContext

001type
002  IContext = interface(IDispatch)
003    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
004    function Get_ContextObject: IDispatch; safecall;
005    function Get_UserName: WideString; safecall;
006    function Get_NegotiateAuth: WordBool; safecall;
007    function Get_Language: WideString; safecall;
008    procedure Set_Language(Value: WideString); safecall;
009    function Get_TimeBias: Double; safecall;
010    function getName(ID: OleVariant): WideString; safecall;
011    function getDescription(ID: OleVariant): WideString; safecall;
012    function getPropValue(const ClassName: WideString; const PropName: WideString;
013      ID: OleVariant): OleVariant; safecall;
014    procedure setPropValue(const ClassName: WideString; const PropName: WideString;
015      ID: OleVariant; Value: OleVariant); safecall;
016    procedure getPropValues(const ClassName: WideString;
017      const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
018      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
019    procedure setPropValues(const ClassName: WideString;
020      const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
021      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
022    function createDataSet(const TargetClassName: WideString): IContextDataSet; safecall;
023    function select(const ClassName: WideString; QueryItems: OleVariant): IDispatch; safecall;
024    function executeMethod(const ClassName: WideString;
025      const MethodName: WideString; Params: OleVariant): OleVariant; safecall;
026    function getClass(const ClassName: WideString): WideString; safecall;
027    function enumerationItem(ItemIdentifier: OleVariant): WideString; safecall;
028    function getResource(const Name: WideString): WideString; safecall;
029    function bulkInsert(const ClassName: WideString;
030      const Data: IDispatch): IContextDataSet; safecall;
031    function PreProcessScript(const Script: WideString; Indent: WordBool;
032      const CommentMark: WideString): WideString; safecall;
033    function executeReport(const ClassName: WideString;
034      const TemplateName: WideString; Params: OleVariant): IDispatch; safecall;
035    procedure saveReport(const ClassName: WideString;
036      const TemplateName: WideString; Params: OleVariant; const FileName: WideString); safecall;
037    function Get_Variable(const Name: WideString; Persistent: WordBool): OleVariant; safecall;
038    procedure Set_Variable(const Name: WideString; Persistent: WordBool;
039      Value: OleVariant); safecall;
040    function DebugString(const Message: WideString): WideString; safecall;
041    procedure raiseManagedException(const ExceptionMessage: WideString); safecall;
042    function createGUID: WideString; safecall;
043    function getTempFileName(const Extension: WideString): WideString; safecall;
044    function HasUI: WordBool; safecall;
045    function Handle: Integer; safecall;
046    procedure processStart(const Description: WideString; ItemCount: Integer;
047      CanAbort: WordBool); safecall;
048    function processStep: WordBool; safecall;
049    procedure processStop; safecall;
050    procedure Sleep(MSecs: Integer); safecall;
051    function executeConsoleProcess(const CommandLine: WideString;
052      MaxDuration: Integer; const OutputData: OleVariant): Integer; safecall;
053    function downloadData(const Host: WideString; const Url: WideString;
054      const UserName: WideString; const Password: WideString;
055      NegotiateAuth: WordBool; PostData: OleVariant;
056      const PostContentType: WideString; PostDataIsBinary: WordBool;
057      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant; safecall;
058    function LineBreak: WideString; safecall;
059    function Transliterate(const Value: WideString): WideString; safecall;
060    procedure CompareLists(var List1: OleVariant; var List2: OleVariant;
061      const Delimiter: WideString; CaseSensitive: WordBool); safecall;
062    function parseJSON(const JSON: WideString): WideString; safecall;
063    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch; safecall;
064    function createBinaryData: IDispatch; safecall;
065    function getCRC(Data: OleVariant): WideString; safecall;
066    function buildNamedFile(const Data: IDispatch;
067      const StoredFileName: WideString; Propmpt: WordBool;
068      Compress: WordBool): IDispatch; safecall;
069    procedure parseNamedFile(NamedFile: OleVariant; out FileName: OleVariant;
070      out Data: OleVariant); safecall;
071    function createRaster: IDispatch; safecall;
072    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
073    function getOleObject(const ClassID: WideString;
074      const AccessibleFileName: WideString): IDispatch; safecall;
075    function PlaceDataSet(const Range: IDispatch; const DataSet: IContextDataSet;
076      ShiftRows: WordBool; ShiftColumns: WordBool): Integer; safecall;
077    procedure ExportObject(var Document: OleVariant; const ID: WideString;
078      const ClassID: WideString); safecall;
079    function createZIPArchive: IDispatch; safecall;
080    function callRoutine(const ClassName: WideString;
081      const RoutineName: WideString; var RetValue: OleVariant;
082      const ScriptPart: OleVariant): WordBool; safecall;
083    function selectVaue(const ClassDomain: WideString;
084      const ExpressionContext: IUnknown; var Value: OleVariant): WordBool; safecall;
085    function editValues(const ValuesList: WideString; const Title: WideString;
086      UseTabs: WordBool; HideOKButton: WordBool;
087      const ScriptPart: OleVariant): WordBool; safecall;
088    function MsgBox(const Prompt: WideString; Buttons: LongWord;
089      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
090    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
091      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
092    procedure showView(const ViewName: WideString; Key: OleVariant;
093      const DetailPropertyName: WideString); safecall;
094    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
095      ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
096      TakeActionsFromView: OleVariant); safecall;
097    procedure SaveExternalDataToFolder(const Resource: WideString;
098      const Folder: WideString); safecall;
099    function PerformAsyncTask(ID: OleVariant): WordBool; safecall;
100    procedure RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
101      ThreadCount: Integer); safecall;
102    function MainHandle: Integer; safecall;
103    function IsHTMLDocumentSafe(const HTML: WideString): WordBool; safecall;
104    function EnsafeHTMLDocument(const HTML: WideString; RemoveHead: WordBool;
105      Format: WordBool; PureXML: WordBool): WideString; safecall;
106    property ContextObject: IDispatch read Get_ContextObject;
107    property UserName: WideString read Get_UserName;
108    property NegotiateAuth: WordBool read Get_NegotiateAuth;
109    property Language: WideString read Get_Language write Set_Language;
110    property TimeBias: Double read Get_TimeBias;
111    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant
112      read Get_Variable write Set_Variable;
113  end;

4.1. Свойства

Свойства интерфейса IContext:

Имя | Тип | Доступ | Назначение
ContextObject | IDispatch | Только для чтения |
Language | WideString | Чтение/Запись |
NegotiateAuth | WordBool | Только для чтения |
TimeBias | Double | Только для чтения |
UserName | WideString | Только для чтения |
Variable[const Name: WideString, Persistent: WordBool] | OleVariant | Чтение/Запись |

4.2. Метод BinaryToBitmap

Метод интерфейса IContext.

function IContext.BinaryToBitmap(const Data: IDispatch): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Data | IDispatch | Да |

Замечания:

Возвращает значение типа IDispatch.

4.3. Метод buildNamedFile

Метод интерфейса IContext.

1function IContext.buildNamedFile(const Data: IDispatch;
2  const StoredFileName: WideString; Propmpt: WordBool;
3  Compress: WordBool): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Data | IDispatch | Да |
StoredFileName | WideString | Да |
Propmpt | WordBool | Да |
Compress | WordBool | Да |

Замечания:

Возвращает значение типа IDispatch.

4.4. Метод bulkInsert

Метод интерфейса IContext.

1function IContext.bulkInsert(const ClassName: WideString;
2  const Data: IDispatch): IContextDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
Data | IDispatch | Да |

Замечания:

Возвращает значение типа IContextDataSet.

4.5. Метод callRoutine

Метод интерфейса IContext.

1function IContext.callRoutine(const ClassName: WideString;
2  const RoutineName: WideString; var RetValue: OleVariant;
3  const ScriptPart: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
RoutineName | WideString | Да |
RetValue | OleVariant | Нет |
ScriptPart | OleVariant | Нет |

Замечания:

Возвращает значение типа WordBool.

4.6. Метод CompareLists

Метод интерфейса IContext.

1procedure IContext.CompareLists(var List1: OleVariant; var List2: OleVariant;
2  const Delimiter: WideString; CaseSensitive: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
List1 | OleVariant | Да |
List2 | OleVariant | Да |
Delimiter | WideString | Да |
CaseSensitive | WordBool | Да |

4.7. Метод ConvertExcel

Метод интерфейса IContext.

1function IContext.ConvertExcel(Source: OleVariant;
2  const Format: WideString): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Source | OleVariant | Да |
Format | WideString | Да |

Замечания:

Возвращает значение типа IDispatch.

4.8. Метод createBinaryData

Метод интерфейса IContext.

function IContext.createBinaryData: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

4.9. Метод createDataSet

Метод интерфейса IContext.

function IContext.createDataSet(const TargetClassName: WideString): IContextDataSet;

Параметры:

Имя | Тип | Обязательно | Значение
TargetClassName | WideString | Да |

Замечания:

Возвращает значение типа IContextDataSet.

4.10. Метод createGUID

Метод интерфейса IContext.

function IContext.createGUID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

4.11. Метод createRaster

Метод интерфейса IContext.

function IContext.createRaster: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

4.12. Метод createZIPArchive

Метод интерфейса IContext.

function IContext.createZIPArchive: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

4.13. Метод DebugString

Метод интерфейса IContext.

function IContext.DebugString(const Message: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Message | WideString | Да |

Замечания:

Возвращает значение типа WideString.

4.14. Метод downloadData

Метод интерфейса IContext.

1function IContext.downloadData(const Host: WideString; const Url: WideString;
2  const UserName: WideString; const Password: WideString;
3  NegotiateAuth: WordBool; PostData: OleVariant;
4  const PostContentType: WideString; PostDataIsBinary: WordBool;
5  CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Host | WideString | Да |
Url | WideString | Да |
UserName | WideString | Да |
Password | WideString | Да |
NegotiateAuth | WordBool | Да |
PostData | OleVariant | Да |
PostContentType | WideString | Да |
PostDataIsBinary | WordBool | Да |
CanCache | WordBool | Да |
NewSession | WordBool | Да |
TimeOut | Integer | Да |

Замечания:

Возвращает значение типа OleVariant.

4.15. Метод editValues

Метод интерфейса IContext.

1function IContext.editValues(const ValuesList: WideString;
2  const Title: WideString; UseTabs: WordBool; HideOKButton: WordBool;
3  const ScriptPart: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ValuesList | WideString | Да |
Title | WideString | Да |
UseTabs | WordBool | Да |
HideOKButton | WordBool | Да |
ScriptPart | OleVariant | Нет |

Замечания:

Возвращает значение типа WordBool.

4.16. Метод EnsafeHTMLDocument

Метод интерфейса IContext.

1function IContext.EnsafeHTMLDocument(const HTML: WideString;
2  RemoveHead: WordBool; Format: WordBool; PureXML: WordBool): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
HTML | WideString | Да |
RemoveHead | WordBool | Да |
Format | WordBool | Да |
PureXML | WordBool | Да |

Замечания:

Возвращает значение типа WideString.

4.17. Метод enumerationItem

Метод интерфейса IContext.

function IContext.enumerationItem(ItemIdentifier: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ItemIdentifier | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

4.18. Метод executeConsoleProcess

Метод интерфейса IContext.

1function IContext.executeConsoleProcess(const CommandLine: WideString;
2  MaxDuration: Integer; const OutputData: OleVariant): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
CommandLine | WideString | Да |
MaxDuration | Integer | Да |
OutputData | OleVariant | Да |

Замечания:

Возвращает значение типа Integer.

4.19. Метод executeMethod

Метод интерфейса IContext.

1function IContext.executeMethod(const ClassName: WideString;
2  const MethodName: WideString; Params: OleVariant): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
MethodName | WideString | Да |
Params | OleVariant | Да |

Замечания:

Возвращает значение типа OleVariant.

4.20. Метод executeReport

Метод интерфейса IContext.

1function IContext.executeReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
TemplateName | WideString | Да |
Params | OleVariant | Да |

Замечания:

Возвращает значение типа IDispatch.

4.21. Метод ExportObject

Метод интерфейса IContext.

1procedure IContext.ExportObject(var Document: OleVariant; const ID: WideString;
2  const ClassID: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Document | OleVariant | Да |
ID | WideString | Да |
ClassID | WideString | Да |

4.22. Метод getClass

Метод интерфейса IContext.

function IContext.getClass(const ClassName: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |

Замечания:

Возвращает значение типа WideString.

4.23. Метод getCRC

Метод интерфейса IContext.

function IContext.getCRC(Data: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

4.24. Метод getDescription

Метод интерфейса IContext.

function IContext.getDescription(ID: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

4.25. Метод getName

Метод интерфейса IContext.

function IContext.getName(ID: OleVariant): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WideString.

4.26. Метод getOleObject

Метод интерфейса IContext.

1function IContext.getOleObject(const ClassID: WideString;
2  const AccessibleFileName: WideString): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassID | WideString | Да |
AccessibleFileName | WideString | Да |

Замечания:

Возвращает значение типа IDispatch.

4.27. Метод getPropValue

Метод интерфейса IContext.

1function IContext.getPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
ID | OleVariant | Да |

Замечания:

Возвращает значение типа OleVariant.

4.28. Метод getPropValues

Метод интерфейса IContext.

1procedure IContext.getPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
IDS | OleVariant | Да |
OnValueEvent | OleVariant | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |

4.29. Метод getResource

Метод интерфейса IContext.

function IContext.getResource(const Name: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа WideString.

4.30. Метод getTempFileName

Метод интерфейса IContext.

function IContext.getTempFileName(const Extension: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Extension | WideString | Да |

Замечания:

Возвращает значение типа WideString.

4.31. Метод Handle

Метод интерфейса IContext.

function IContext.Handle: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.32. Метод HasUI

Метод интерфейса IContext.

function IContext.HasUI: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

4.33. Метод IsHTMLDocumentSafe

Метод интерфейса IContext.

function IContext.IsHTMLDocumentSafe(const HTML: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
HTML | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

4.34. Метод LineBreak

Метод интерфейса IContext.

function IContext.LineBreak: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

4.35. Метод MainHandle

Метод интерфейса IContext.

function IContext.MainHandle: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

4.36. Метод MsgBox

Метод интерфейса IContext.

1function IContext.MsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Prompt | WideString | Да |
Buttons | LongWord | Нет |
Title | WideString | Нет |
HelpFile | WideString | Нет |
Context | LongWord | Нет |

Замечания:

Возвращает значение типа Integer.

4.37. Метод parseJSON

Метод интерфейса IContext.

function IContext.parseJSON(const JSON: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
JSON | WideString | Да |

Замечания:

Возвращает значение типа WideString.

4.38. Метод parseNamedFile

Метод интерфейса IContext.

1procedure IContext.parseNamedFile(NamedFile: OleVariant;
2  out FileName: OleVariant; out Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
NamedFile | OleVariant | Да |
FileName | OleVariant | Да |
Data | OleVariant | Да |

4.39. Метод PerformAsyncTask

Метод интерфейса IContext.

function IContext.PerformAsyncTask(ID: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ID | OleVariant | Да |

Замечания:

Возвращает значение типа WordBool.

4.40. Метод PlaceDataSet

Метод интерфейса IContext.

1function IContext.PlaceDataSet(const Range: IDispatch;
2  const DataSet: IContextDataSet; ShiftRows: WordBool;
3  ShiftColumns: WordBool): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Range | IDispatch | Да |
DataSet | IContextDataSet | Да |
ShiftRows | WordBool | Нет |
ShiftColumns | WordBool | Нет |

Замечания:

Возвращает значение типа Integer.

4.41. Метод PreProcessScript

Метод интерфейса IContext.

1function IContext.PreProcessScript(const Script: WideString; Indent: WordBool;
2  const CommentMark: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Script | WideString | Да |
Indent | WordBool | Да |
CommentMark | WideString | Да |

Замечания:

Возвращает значение типа WideString.

4.42. Метод processStart

Метод интерфейса IContext.

1procedure IContext.processStart(const Description: WideString;
2  ItemCount: Integer; CanAbort: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Description | WideString | Да |
ItemCount | Integer | Нет |
CanAbort | WordBool | Нет |

4.43. Метод processStep

Метод интерфейса IContext.

function IContext.processStep: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

4.44. Метод processStop

Метод интерфейса IContext.

procedure IContext.processStop;

Метод не имеет параметров.

4.45. Метод raiseManagedException

Метод интерфейса IContext.

procedure IContext.raiseManagedException(const ExceptionMessage: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ExceptionMessage | WideString | Да |

4.46. Метод RebuildTextIndex

Метод интерфейса IContext.

1procedure IContext.RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
2  ThreadCount: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
ClassID | OleVariant | Да |
FieldID | OleVariant | Да |
ThreadCount | Integer | Да |

4.47. Метод SaveExternalDataToFolder

Метод интерфейса IContext.

1procedure IContext.SaveExternalDataToFolder(const Resource: WideString;
2  const Folder: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Resource | WideString | Да |
Folder | WideString | Да |

4.48. Метод saveReport

Метод интерфейса IContext.

1procedure IContext.saveReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant; const FileName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
TemplateName | WideString | Да |
Params | OleVariant | Да |
FileName | WideString | Да |

4.49. Метод select

Метод интерфейса IContext.

1function IContext.select(const ClassName: WideString;
2  QueryItems: OleVariant): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
QueryItems | OleVariant | Да |

Замечания:

Возвращает значение типа IDispatch.

4.50. Метод selectVaue

Метод интерфейса IContext.

1function IContext.selectVaue(const ClassDomain: WideString;
2  const ExpressionContext: IUnknown; var Value: OleVariant): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
ClassDomain | WideString | Да |
ExpressionContext | IUnknown | Да |
Value | OleVariant | Да |

Замечания:

Возвращает значение типа WordBool.

4.51. Метод setPropValue

Метод интерфейса IContext.

1procedure IContext.setPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant; Value: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
ID | OleVariant | Да |
Value | OleVariant | Да |

4.52. Метод setPropValues

Метод интерфейса IContext.

1procedure IContext.setPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
ClassName | WideString | Да |
PropName | WideString | Да |
IDS | OleVariant | Да |
OnValueNeededEvent | OleVariant | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |

4.53. Метод showDataSet

Метод интерфейса IContext.

1procedure IContext.showDataSet(const DataSet: ContextDataSet;
2  const Caption: WideString; ColumnCaptions: OleVariant;
3  ColumnOnChangeHandlers: OleVariant; TakeActionsFromView: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
DataSet | ContextDataSet | Да |
Caption | WideString | Да |
ColumnCaptions | OleVariant | Да |
ColumnOnChangeHandlers | OleVariant | Да |
TakeActionsFromView | OleVariant | Да |

4.54. Метод ShowMsgBox

Метод интерфейса IContext.

1function IContext.ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Prompt | WideString | Да |
Buttons | LongWord | Нет |
Title | WideString | Нет |
HelpFile | WideString | Нет |
Context | LongWord | Нет |

Замечания:

Возвращает значение типа Integer.

4.55. Метод showView

Метод интерфейса IContext.

1procedure IContext.showView(const ViewName: WideString; Key: OleVariant;
2  const DetailPropertyName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
ViewName | WideString | Да |
Key | OleVariant | Да |
DetailPropertyName | WideString | Да |

4.56. Метод Sleep

Метод интерфейса IContext.

procedure IContext.Sleep(MSecs: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
MSecs | Integer | Да |

4.57. Метод Transliterate

Метод интерфейса IContext.

function IContext.Transliterate(const Value: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Value | WideString | Да |

Замечания:

Возвращает значение типа WideString.

5. Интерфейс IContextDataSet

01type
02  IContextDataSet = interface(IDispatch)
03    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
04    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
05      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant); safecall;
06    function Eof: WordBool; safecall;
07    function Field(const Name: WideString): OleVariant; safecall;
08    function FieldCount: Integer; safecall;
09    function FieldName(Index: Integer): WideString; safecall;
10    procedure Next; safecall;
11    procedure Split(OnRowEvent: OleVariant; ChunkSize: Integer;
12      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
13    function AsJSON: WideString; safecall;
14    function AsXML: WideString; safecall;
15    function AsBinaryData: IDispatch; safecall;
16  end;

5.1. Метод AddQueryItem

Метод интерфейса IContextDataSet.

1procedure IContextDataSet.AddQueryItem(Part: TQueryPart;
2  const Name: WideString; Value: OleVariant; Special: TQuerySpecial;
3  Context: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Part | TQueryPart | Да |
Name | WideString | Да |
Value | OleVariant | Нет |
Special | TQuerySpecial | Нет |
Context | OleVariant | Нет |

5.2. Метод AsBinaryData

Метод интерфейса IContextDataSet.

function IContextDataSet.AsBinaryData: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

5.3. Метод AsJSON

Метод интерфейса IContextDataSet.

function IContextDataSet.AsJSON: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5.4. Метод AsXML

Метод интерфейса IContextDataSet.

function IContextDataSet.AsXML: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5.5. Метод Eof

Метод интерфейса IContextDataSet.

function IContextDataSet.Eof: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

5.6. Метод Field

Метод интерфейса IContextDataSet.

function IContextDataSet.Field(const Name: WideString): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа OleVariant.

5.7. Метод FieldCount

Метод интерфейса IContextDataSet.

function IContextDataSet.FieldCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.8. Метод FieldName

Метод интерфейса IContextDataSet.

function IContextDataSet.FieldName(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.

5.9. Метод Next

Метод интерфейса IContextDataSet.

procedure IContextDataSet.Next;

Метод не имеет параметров.

5.10. Метод Split

Метод интерфейса IContextDataSet.

1procedure IContextDataSet.Split(OnRowEvent: OleVariant; ChunkSize: Integer;
2  ThreadCount: Integer; ThreadSafe: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
OnRowEvent | OleVariant | Да |
ChunkSize | Integer | Да |
ThreadCount | Integer | Да |
ThreadSafe | WordBool | Да |

6. Интерфейс IContextExpressionInfo

1type
2  IContextExpressionInfo = interface(IUnknown)
3    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
4    function LookupExpressionContext(const Identifier: WideString;
5      out DomainID: WideString; out Value: WideString): WordBool; safecall;
6    procedure SerializeExpressionContext(const RootNode: IDispatch); safecall;
7  end;

6.1. Метод LookupExpressionContext

Метод интерфейса IContextExpressionInfo.

1function IContextExpressionInfo.LookupExpressionContext(const Identifier: WideString;
2  out DomainID: WideString; out Value: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Identifier | WideString | Да |
DomainID | WideString | Да |
Value | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

6.2. Метод SerializeExpressionContext

Метод интерфейса IContextExpressionInfo.

procedure IContextExpressionInfo.SerializeExpressionContext(const RootNode: IDispatch);

Параметры:

Имя | Тип | Обязательно | Значение
RootNode | IDispatch | Да |

7. Интерфейс IControl

01type
02  IControl = interface(IDispatch)
03    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
04    function Name: WideString; safecall;
05    function Get_Value: OleVariant; safecall;
06    procedure Set_Value(Value: OleVariant); safecall;
07    function Get_ReadOnly: WordBool; safecall;
08    procedure Set_ReadOnly(Value: WordBool); safecall;
09    function Get_IsValid: WordBool; safecall;
10    procedure Set_IsValid(Value: WordBool); safecall;
11    function Get_IsEmpty: WordBool; safecall;
12    procedure SetHint(const Value: WideString); safecall;
13    procedure RefreshLinkedView; safecall;
14    function Get_Visible: WordBool; safecall;
15    property Value: OleVariant read Get_Value write Set_Value;
16    property ReadOnly: WordBool read Get_ReadOnly write Set_ReadOnly;
17    property IsValid: WordBool read Get_IsValid write Set_IsValid;
18    property IsEmpty: WordBool read Get_IsEmpty;
19    property Visible: WordBool read Get_Visible;
20  end;

7.1. Свойства

Свойства интерфейса IControl:

Имя | Тип | Доступ | Назначение
IsEmpty | WordBool | Только для чтения |
IsValid | WordBool | Чтение/Запись |
ReadOnly | WordBool | Чтение/Запись |
Value | OleVariant | Чтение/Запись |
Visible | WordBool | Только для чтения |

7.2. Метод Name

Метод интерфейса IControl.

function IControl.Name: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

7.3. Метод RefreshLinkedView

Метод интерфейса IControl.

procedure IControl.RefreshLinkedView;

Метод не имеет параметров.

7.4. Метод SetHint

Метод интерфейса IControl.

procedure IControl.SetHint(const Value: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Value | WideString | Да |

8. Интерфейс IExceptionHandler

1type
2  IExceptionHandler = interface(IDispatch)
3    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
4    procedure HandleException(ContextObject: OleVariant; const Message: WideString;
5      const ExtentedInfo: WideString; SupportServiceData: OleVariant); safecall;
6  end;

8.1. Метод HandleException

Метод интерфейса IExceptionHandler.

1procedure IExceptionHandler.HandleException(ContextObject: OleVariant;
2  const Message: WideString; const ExtentedInfo: WideString;
3  SupportServiceData: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
ContextObject | OleVariant | Да |
Message | WideString | Да |
ExtentedInfo | WideString | Да |
SupportServiceData | OleVariant | Да |

9. Интерфейс IExternalContext

1type
2  IExternalContext = interface(IDispatch)
3    ['{EA2F1CDA-53F6-40E9-A2B7-0A80AB84D177}']
4    procedure Connect(const Database: WideString); safecall;
5  end;

9.1. Метод Connect

Метод интерфейса IExternalContext.

procedure IExternalContext.Connect(const Database: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Database | WideString | Да |

10. Интерфейс IFormContext

01type
02  IFormContext = interface(IDispatch)
03    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
04    function ID: WideString; safecall;
05    function RoutineID: WideString; safecall;
06    function ControlCount: Integer; safecall;
07    function Get_Controls(Name: OleVariant): IControl; safecall;
08    function ControlExists(const Name: WideString): WordBool; safecall;
09    function ButtonCount: Integer; safecall;
10    function Get_Buttons(Name: OleVariant): IButton; safecall;
11    function Get_Enabled: WordBool; safecall;
12    procedure Set_Enabled(Value: WordBool); safecall;
13    function ChangedControl: OleVariant; safecall;
14    function ChangedControlName: WideString; safecall;
15    procedure Cancel; safecall;
16    function ParentForm: OleVariant; safecall;
17    procedure PreInitControl(const Name: WideString; Value: OleVariant); safecall;
18    procedure NavigatorNext; safecall;
19    procedure NavigatorPrevious; safecall;
20    function NavigatorCanNext: WordBool; safecall;
21    function NavigatorCanPrevious: WordBool; safecall;
22    procedure RefreshView(RefreshAll: WordBool); safecall;
23    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
24    property Controls[Name: OleVariant]: IControl read Get_Controls;
25    property Buttons[Name: OleVariant]: IButton read Get_Buttons;
26    property Enabled: WordBool read Get_Enabled write Set_Enabled;
27  end;

10.1. Свойства

Свойства интерфейса IFormContext:

Имя | Тип | Доступ | Назначение
Buttons[Name: OleVariant] | IButton | Только для чтения |
Controls[Name: OleVariant] | IControl | Только для чтения |
Enabled | WordBool | Чтение/Запись |

10.2. Метод ButtonCount

Метод интерфейса IFormContext.

function IFormContext.ButtonCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

10.3. Метод Cancel

Метод интерфейса IFormContext.

procedure IFormContext.Cancel;

Метод не имеет параметров.

10.4. Метод ChangedControl

Метод интерфейса IFormContext.

function IFormContext.ChangedControl: OleVariant;

Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

10.5. Метод ChangedControlName

Метод интерфейса IFormContext.

function IFormContext.ChangedControlName: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10.6. Метод ControlCount

Метод интерфейса IFormContext.

function IFormContext.ControlCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

10.7. Метод ControlExists

Метод интерфейса IFormContext.

function IFormContext.ControlExists(const Name: WideString): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа WordBool.

10.8. Метод ExpressionContextValue

Метод интерфейса IFormContext.

function IFormContext.ExpressionContextValue(const Name: WideString): OleVariant;

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |

Замечания:

Возвращает значение типа OleVariant.

10.9. Метод ID

Метод интерфейса IFormContext.

function IFormContext.ID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

10.10. Метод NavigatorCanNext

Метод интерфейса IFormContext.

function IFormContext.NavigatorCanNext: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

10.11. Метод NavigatorCanPrevious

Метод интерфейса IFormContext.

function IFormContext.NavigatorCanPrevious: WordBool;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

10.12. Метод NavigatorNext

Метод интерфейса IFormContext.

procedure IFormContext.NavigatorNext;

Метод не имеет параметров.

10.13. Метод NavigatorPrevious

Метод интерфейса IFormContext.

procedure IFormContext.NavigatorPrevious;

Метод не имеет параметров.

10.14. Метод ParentForm

Метод интерфейса IFormContext.

function IFormContext.ParentForm: OleVariant;

Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

10.15. Метод PreInitControl

Метод интерфейса IFormContext.

procedure IFormContext.PreInitControl(const Name: WideString; Value: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Name | WideString | Да |
Value | OleVariant | Да |

10.16. Метод RefreshView

Метод интерфейса IFormContext.

procedure IFormContext.RefreshView(RefreshAll: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
RefreshAll | WordBool | Да |

10.17. Метод RoutineID

Метод интерфейса IFormContext.

function IFormContext.RoutineID: WideString;

Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

11. Интерфейс IRaster

01type
02  IRaster = interface(IDispatch)
03    ['{4F27D016-03C2-4D48-ABF7-FD547E859F79}']
04    function Get_Width: Integer; safecall;
05    procedure Set_Width(Value: Integer); safecall;
06    function Get_Height: Integer; safecall;
07    procedure Set_Height(Value: Integer); safecall;
08    function Get_DefaultColor: Integer; safecall;
09    procedure Set_DefaultColor(Value: Integer); safecall;
10    procedure Load(Src: OleVariant); safecall;
11    procedure SaveBitmap(Dst: OleVariant); safecall;
12    procedure SavePNG(Dst: OleVariant); safecall;
13    procedure SaveJPG(Dst: OleVariant; Quality: Integer); safecall;
14    procedure FlipVertical; safecall;
15    procedure FlipHorizontal; safecall;
16    procedure Rotate; safecall;
17    procedure Resize(NewWidth: Integer; NewHeight: Integer; Center: WordBool); safecall;
18    procedure Stretch(NewWidth: Integer; NewHeight: Integer); safecall;
19    procedure StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
20      MaxSize: OleVariant); safecall;
21    procedure Overlay(Src: OleVariant; X: Integer; Y: Integer; Width: Integer;
22      Height: Integer); safecall;
23    property Width: Integer read Get_Width write Set_Width;
24    property Height: Integer read Get_Height write Set_Height;
25    property DefaultColor: Integer read Get_DefaultColor write Set_DefaultColor;
26  end;

11.1. Свойства

Свойства интерфейса IRaster:

Имя | Тип | Доступ | Назначение
DefaultColor | Integer | Чтение/Запись |
Height | Integer | Чтение/Запись |
Width | Integer | Чтение/Запись |

11.2. Метод FlipHorizontal

Метод интерфейса IRaster.

procedure IRaster.FlipHorizontal;

Метод не имеет параметров.

11.3. Метод FlipVertical

Метод интерфейса IRaster.

procedure IRaster.FlipVertical;

Метод не имеет параметров.

11.4. Метод Load

Метод интерфейса IRaster.

procedure IRaster.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

11.5. Метод Overlay

Метод интерфейса IRaster.

1procedure IRaster.Overlay(Src: OleVariant; X: Integer; Y: Integer;
2  Width: Integer; Height: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |
X | Integer | Да |
Y | Integer | Да |
Width | Integer | Да |
Height | Integer | Да |

11.6. Метод Resize

Метод интерфейса IRaster.

1procedure IRaster.Resize(NewWidth: Integer; NewHeight: Integer;
2  Center: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
NewWidth | Integer | Да |
NewHeight | Integer | Да |
Center | WordBool | Да |

11.7. Метод Rotate

Метод интерфейса IRaster.

procedure IRaster.Rotate;

Метод не имеет параметров.

11.8. Метод SaveBitmap

Метод интерфейса IRaster.

procedure IRaster.SaveBitmap(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |

11.9. Метод SaveJPG

Метод интерфейса IRaster.

procedure IRaster.SaveJPG(Dst: OleVariant; Quality: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |
Quality | Integer | Да |

11.10. Метод SavePNG

Метод интерфейса IRaster.

procedure IRaster.SavePNG(Dst: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Dst | OleVariant | Да |

11.11. Метод Stretch

Метод интерфейса IRaster.

procedure IRaster.Stretch(NewWidth: Integer; NewHeight: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
NewWidth | Integer | Да |
NewHeight | Integer | Да |

11.12. Метод StretchToSize

Метод интерфейса IRaster.

1procedure IRaster.StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
2  MaxSize: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
MaxWidth | OleVariant | Да |
MaxHeight | OleVariant | Да |
MaxSize | OleVariant | Да |

12. Интерфейс IScannerTools

1type
2  IScannerTools = interface(IDispatch)
3    ['{FC1B3C9F-7DE9-4909-B57D-6D33E3B0A87A}']
4    function AcquireImage(Silent: WordBool): IDispatch; safecall;
5    function AcquirePDF: IDispatch; safecall;
6  end;

12.1. Метод AcquireImage

Метод интерфейса IScannerTools.

function IScannerTools.AcquireImage(Silent: WordBool): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Silent | WordBool | Да |

Замечания:

Возвращает значение типа IDispatch.

12.2. Метод AcquirePDF

Метод интерфейса IScannerTools.

function IScannerTools.AcquirePDF: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

13. Интерфейс ISetOfObjectsEditor

1type
2  ISetOfObjectsEditor = interface(IDispatch)
3    ['{6D3662A7-D9FF-4BD6-8D92-A4EA2058C74E}']
4    function Get_DomainName: WideString; safecall;
5    procedure Set_DomainName(Value: WideString); safecall;
6    function Get_SelectedCount: Integer; safecall;
7    property DomainName: WideString read Get_DomainName write Set_DomainName;
8    property SelectedCount: Integer read Get_SelectedCount;
9  end;

13.1. Свойства

Свойства интерфейса ISetOfObjectsEditor:

Имя | Тип | Доступ | Назначение
DomainName | WideString | Чтение/Запись |
SelectedCount | Integer | Только для чтения |

14. Интерфейс IZIPArchive

01type
02  IZIPArchive = interface(IDispatch)
03    ['{11C9400F-F262-4F72-882F-5AA5A4531591}']
04    procedure Load(Src: OleVariant); safecall;
05    procedure Save(Src: OleVariant); safecall;
06    function Get_FileCount: Integer; safecall;
07    function Get_FileName(Index: Integer): WideString; safecall;
08    function Get_FileData(Index: Integer): OleVariant; safecall;
09    procedure AddFile(const FileName: WideString; Data: OleVariant); safecall;
10    function Get_FileSize(Index: Integer): Int64; safecall;
11    function Get_FileDateTime(Index: Integer): TDateTime; safecall;
12    function Get_FileCRC(Index: Integer): WideString; safecall;
13    function Get_UTF8Support: WordBool; safecall;
14    procedure Set_UTF8Support(Value: WordBool); safecall;
15    property FileCount: Integer read Get_FileCount;
16    property FileName[Index: Integer]: WideString read Get_FileName;
17    property FileData[Index: Integer]: OleVariant read Get_FileData;
18    property FileSize[Index: Integer]: Int64 read Get_FileSize;
19    property FileDateTime[Index: Integer]: TDateTime read Get_FileDateTime;
20    property FileCRC[Index: Integer]: WideString read Get_FileCRC;
21    property UTF8Support: WordBool read Get_UTF8Support write Set_UTF8Support;
22  end;

14.1. Свойства

Свойства интерфейса IZIPArchive:

Имя | Тип | Доступ | Назначение
FileCRC[Index: Integer] | WideString | Только для чтения |
FileCount | Integer | Только для чтения |
FileData[Index: Integer] | OleVariant | Только для чтения |
FileDateTime[Index: Integer] | TDateTime | Только для чтения |
FileName[Index: Integer] | WideString | Только для чтения |
FileSize[Index: Integer] | Int64 | Только для чтения |
UTF8Support | WordBool | Чтение/Запись |

14.2. Метод AddFile

Метод интерфейса IZIPArchive.

procedure IZIPArchive.AddFile(const FileName: WideString; Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
FileName | WideString | Да |
Data | OleVariant | Да |

14.3. Метод Load

Метод интерфейса IZIPArchive.

procedure IZIPArchive.Load(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |

14.4. Метод Save

Метод интерфейса IZIPArchive.

procedure IZIPArchive.Save(Src: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Src | OleVariant | Да |


Мельница данных ((раздел целиком))

Мельница данных- Класс TAccessProfile (Профили доступа) (раздел целиком) (22.10.2024) (одним файлом)
Класс TAccessProfile (Профили доступа)

Диаграмма Класс TProfile (Профили)Класс TObject (Объекты)

1. Свойства

Свойства класса TAccessProfile:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TProfile
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
ComparisonType | TComparisonType | Да | Видимо пользователю | Чтение/Запись
BasedOnProfile | TProfile | Нет | Видимо пользователю | Чтение/Запись
Active | Boolean | Да | Видимо пользователю | Только для чтения
Access | Boolean | Да | Видимо пользователю | Чтение/Запись | Доступ

2. Конструктор Create (Конструктор профиля доступа)

Конструктор класса TAccessProfile.

1constructor TAccessProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType; BasedOnProfile: TProfile;
4  Access: Boolean): TObject;

Переопределяет метод в TProfile.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Унаследовано от TProfile.Create
ComparisonType | TComparisonType | Да
BasedOnProfile | TProfile | Нет
Access | Boolean | Да | Доступ

Замечания:

Создает новый объект класса TAccessProfile.


Мельница данных ((раздел целиком))

Мельница данных- Стандартные действия, доступные в любых таблицах данных (раздел целиком) (22.10.2024) (одним файлом)
Стандартные действия, доступные в любых таблицах данных

Ряд стандартных действий, доступных объектов любого типа, может быть вызван из любой таблицы данных. Разработчиком конкретной прикладной системы некоторые из перечисленных в данном разделе действий могут быть скрыты. Также перечень доступных стандартных действий зависит от прав доступа конкретного пользователя.

Взаимное расположение, наименования и доступность стандартных действий могут зависеть от реализации прикладной системы. В следующих разделах описаны все стандартные действия, реализованные средствами платформы.

1. Копирование и вставка объектов

Объекты, отображаемые в таблице данных, можно копировать и вставлять. Вставлять объекты можно как в ту же таблицу данных, из которой они были скопированы, так и в другую таблицу данных, отображающую объекты того же типа. Для этого необходимо выполнить следующие действия:

  1. Выбрать один или несколько объектов, которые Вы хотите скопировать (см. раздел 4.3. "Выбор объектов в таблице данных").
  2. Вызвать действие "Копировать" из контекстного меню или при помощи иконки на панели инструментов.
  3. Перейти в таблицу данных, в которую Вы хотите вставить скопированные объекты.
  4. Вызвать действие "Вставить" из контекстного меню или при помощи иконки на панели инструментов.

При копировании и вставке происходит создание копии объекта. Все свойства нового объекта, кроме свойства "Имя" (или замещающего его свойства), будут такими же, как у первичного объекта. Свойство имя будет равно строке, составленной из слова "Копия " и имени первичного объекта. После вставки объекта значение свойства "Имя" можно изменить.

Действия "Копировать" и "Вставить" имеют соответствующие иконки на панели инструментов:
Кнопка "копировать" Кнопка "вставить"

2. Подменю "Колонка" - работа с колонкой

Действия, доступные в подменю "Колонка" в контекстном меню или на панели инструментов могут быть применены к колонкам любой таблицы данных. Доступность тех или иных действий над колонкой зависит от типа данных, отображаемых в колонке, и от того, какие действия над колонкой уже совершены (например, нельзя вычислить сумму значений строкового типа, или нельзя очистить группировку, если данные не сгруппированы).

Иконка "Колонка" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с колонкой

Действия, доступные в подменю "Колонка", описаны в разделах 4.6. "Скрытие и отображение колонок", 4.8. "Группировка данных в таблицах", 4.10. "Отображение итоговых значений (агрегатов) по колонкам".

3. Подменю "Выбранные" - работа с выбранными объектами

Действия, доступные в подменю "Выбранные" позволяют быстро отбирать и снимать отбор с объектов, а также устанавливать режим отображения в таблице данных только тех объектов, которые помечены как выбранные.

Иконка "Выбранные" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с выбранными объектами

Назначение этих действий описано в разделе 4.3. "Выбор объектов в таблице данных".

4. Перенос в Excel

Данные, отображаемые в любой из таблиц данных, могут быть перенесены в MS Excel. При этом в MS Excel будут сохранены все настройки отображения данных (сортировка по одной или нескольким колонкам, группировка, отображение итоговых значений). Действие "Перенос в Excel" может быть вызвано из контекстного меню или при помощи иконки на панели инструментов. С данными, перенесенными в MS Excel, далее могут производиться любые манипуляции средствами этого приложения.

Если в таблице много записей, то перенос данных в Excel может занять некоторое время. Если это время превышает 10 сек., то отобразится окно, сообщающая, что система находится в работе. В этом окне будет отображен индикатор процесса переноса данных:
Индикатор прогресса переноса данных в Excel

Действие "Перенос в Excel" имеет соответствующую иконку на панели инструментов:
Кнопка переноса в Excel

5. Экспорт данных

Отображаемые в таблицах данных объекты могут быть экспортированы в виде xml-документа. Для того, чтобы осуществить экспорт объектов, необходимо выполнить следующее:

  1. Выбрать объекты, подлежащие экспорту (см. раздел 4.3. "Выбор объектов в таблице данных").
  2. Вызвать действие "Экспортировать" из контекстного меню или при помощи иконки на панели инструментов.
  3. В открывшемся окне сохранения файла указать местоположение и имя файла. Дать файлу расширение .xml.

6. Обновление данных таблицы

После выполнения действий над различными объектами, хранящимися в системе, их новое состояние может сразу не отобразиться в таблице данных. Для того чтобы получить из базы данных последние актуальные данные необходимо воспользоваться действием "Обновить", которое доступно в контекстном меню, при помощи иконки на панели инструментов, а также может быть доступно при нажатии клавиши F5.

Действие "Обновить" имеет соответствующую иконку на панели инструментов:
Кнопка обновления набора данных

7. Доступ к настройкам системы

При наличии соответствующих прав доступа Вы можете просматривать и изменять настройки системы. Доступ к меню настроек осуществляется при помощи действия "Настройки", которое может быть вызвано из контекстного меню или при помощи иконки на панели инструментов. При вызове этого действия отобразится форма задания настроек. Эта форма аналогична форме задания параметров (см. раздел 6 "Работа с формой задания параметров"). Если Вы имеете права администратора системы, то форма задания настроек, кроме кнопок OK и Отмена, будет иметь кнопку "По умолчанию". При нажатии этой кнопки значения, установленные в полях формы станут значениями настроек по умолчанию.

Форма задания настроек системы

Если в системе нет доступных для текущего пользователя настроек, то при вызове действия "Настройки" отобразится окно:
Сообщение об отсутствии доступных настроек

Действие "Настройки" имеет соответствующую иконку на панели инструментов:
Кнопка формы настроек

8. Дополнительные действия, доступные в иерархических таблицах данных

В иерархических таблицах данных дополнительно доступны действия, позволяющие управлять раскрытием и свертыванием элементов иерархии. Эти действия расположены в подменю "Дерево". Иконка "Дерево" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с иерархией

При помощи этих действий можно управлять отображением дерева иерархически организованных объектов следующим образом:

  • Развернуть все - все элементы дерева будут раскрыты.
  • Свернуть все - все дочерние элементы будут свернуты. Отображенными останутся только элементы первого уровня (не имеющие родительских элементов).
  • Развернуть от выбранного - узел дерева, соответствующий выбранному объекту и все его дочерние узлы будут раскрыты.
  • Свернуть к выбранному - узел дерева, соответствующий выбранному объекту у все его дочерние узлы будут свернуты.
  • Свернуть к этому уровню - все узлы дерева, лежащие на том же уровне, что и выбранный объект или на более низких уровнях будут свернуты.
  • Выделить дочерние - все объекты, дочерние по отношению к выбранному, будут выделены.


Мельница данных ((раздел целиком))

Мельница данных- Класс TRoutine (Подпрограмма) (раздел целиком) (22.10.2024) (одним файлом)
Класс TRoutine (Подпрограмма)

Диаграмма Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)Класс TParameter (Параметры)Класс TCommandButton (Командные кнопки)Класс TParametersFormView (Представления формы параметров)

1. Свойства

Свойства класса TRoutine:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Домен результата
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс домена результата
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена результата
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись | Является методом класса
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись | Текст подтверждения
Scope | TScope | Да | Видимо пользователю | Чтение/Запись | Область видимости
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись | Использовать закладки
Script | clob | Нет | Видимо пользователю | Чтение/Запись | Скрипт формы параметров
Image | blob | Нет | Видимо пользователю | Чтение/Запись | Изображение-иконка
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество параметров
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись | Протоколировать
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись | Сообщение о выполнении
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись | Вызывать только для одного объекта
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей

2. Конструктор Create (Конструктор подпрограммы)

Конструктор класса TRoutine.

1constructor TRoutine.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean): TObject;

Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Является методом класса
SingleObject | Boolean | Да | Вызывать только для одного объекта
Domain | TDomain | Нет | Домен результата
Scope | TScope | Да | Область видимости
Confirmation | string[512] | Нет | Текст подтверждения
ReportMessage | string[512] | Нет | Сообщение о выполнении
UseTabs | Boolean | Да | Использовать закладки
Script | clob | Нет | Скрипт формы параметров
Image | blob | Нет | Изображение-иконка
Logged | Boolean | Да | Протоколировать

Замечания:

Создает новый объект класса TRoutine.

3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TRoutine.

procedure TRoutine.CreateContextKey(Storage: string[64]);

Параметры:

Имя | Тип | Обязательно | Значение
Storage | string[64] | Да | Хранилище

4. Метод GetParamCount (Количество параметров)

Метод экземпляра класса TRoutine.

function TRoutine.GetParamCount: Integer;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5. Метод ListParameters (Список параметров)

Метод экземпляра класса TRoutine.

function TRoutine.ListParameters: TObjectList;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.

6. Метод ParameterByName (Получить параметр по имени)

Метод экземпляра класса TRoutine.

function TRoutine.ParameterByName(AName: string[64]): TParameter;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
AName | string[64] | Да | Имя

Замечания:

Возвращает значение типа TParameter.

7. Метод Ole-объекта CreateReportTemplate (Сгенерировать шаблон отчета)

Метод Ole-объекта класса TRoutine.

Метод Ole-объекта не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Разработка отчетов (раздел целиком) (22.10.2024) (одним файлом)
Разработка отчетов

1. Создание шаблонов PDF-отчетов

1.1. Описание

Portable Document Format (PDF) — кроссплатформенный формат электронных документов, созданный фирмой Adobe Systems с использованием ряда возможностей языка PostScript. В первую очередь предназначен для представления в электронном виде полиграфической продукции, — значительное количество современного профессионального печатного оборудования может обрабатывать PDF непосредственно. Для просмотра можно использовать официальную бесплатную программу Adobe Reader, а также программы сторонних разработчиков. Традиционным способом создания PDF-документов является виртуальный принтер, то есть документ как таковой готовится в своей специализированной программе — графической программе или текстовом редакторе, САПР и т. д., а затем экспортируется в формат PDF для распространения в электронном виде, передачи в типографию и т. п. Формат PDF позволяет внедрять необходимые шрифты (построчный текст), векторные и растровые изображения, формы и мультимедиа-вставки. Поддерживает RGB, CMYK, Grayscale, Lab, Duotone, Bitmap, несколько типов сжатия растровой информации. Имеет собственные технические форматы для полиграфии: PDF/X-1, PDF/X-3. Включает механизм электронных подписей для защиты и проверки подлинности документов. В этом формате распространяется большое количество сопутствующей документации. Чаще всего PDF-файл является комбинацией текста с растровой и векторной графикой, реже — текста с формами, JavaScript'ом, 3D-графикой и другими типами элементов.

В приложениях Платформы "Мельница данных" для создания PDF-документов используется собственная библиотека PDFCreator.dll. С помощью библиотеки возможно прямое создание документов версии 1.3 . Создание PDF-документов осуществляется путем ввода предопределенных в библиотеке команд, которые в дальнейшем интерпретируются на основе языка описания страниц POSTSCRIPT.

Все размеры графических объектов, размеры страниц, шрифтов и т.п. по умолчанию заданы в миллиметрах.
Для удобства построения шаблона PDF-документа создана функция DrawGrid. При ее включении при отладке при создании шаблона будет отображена визуальная сетка с шагом 5 миллиметров.

1.2. Методы

1.2.1. Свойства документа

Для создания и описания свойств PDF-документа в библиотеке PDFCreator.dll используется класс IPDFDocument, обладающий следующими свойствами:

  • Title (WideString) - заголовок документа. По умолчанию - пустая строка.
    Title = "DOC1"
  • CanEmbedFonts (WordBool) - Признак возможности построения PDF- документа со встроенными шрифтами (Embedded Fonts). В случае включения признака, все объявленные в скрипте шрифты будут включены в сборку документа и будут передаваться целиком вместе с документом. По умолчанию - False.
    CanEmbedFonts = True
CanEmbedFonts = False
  • CanCompress (WordBool) - признак сжатия документа при создании по собственным алгоритмам. По умолчанию - True.
    CanCompress = False
CanCompress = True
  • Author (WideString) - автор документа. По умолчанию - текущий пользователь ОС.
  • Subject (WideString) - описание документа. По умолчанию - пустая строка.
  • Keywords (WideString) - ключевые слова для поиска по документу. По умолчанию - пустая строка.
  • Creator (WideString) - приложение-родитель документа. Указывается в том случае, если документ был сконвертирован из другого формата.
  • PageCount (Integer) - свойство, содержащее общее количество страниц в документе.
  • Pages[Index: Integer]: IPDFPage - свойство документа, предназначенное для перебора страниц документа для совершения над ними однотипных действий.

    Пример использования:

    1for I = 0 to PageCount - 1
2  Pages(I).rectangle 10,10,10,10, false
3next
Save "c:\pdf.pdf"

    Результат: На всех страницах документа будут нарисованы квадраты 10х10 мм.
  • procedure Save(Target: OleVariant) - процедура для сохранения документа PDF на жесткий диск сразу после создания.
    Save "c:\pdf.pdf"
    - сохранит документ в файл c:\pdf.pdf

1.2.2. Свойства страницы

Для создания страницы используется функция

function CreatePage(Parent: OleVariant): IPDFPage;

Параметр Parent указывает страницу-родителя для данной страницы. Если страницы- родителя быть не должно - формат вызова функции примет вид:

set page = CreatePage(Null)

Параметры страницы:

  • Title - заголовок страницы.
    page.Title = "Page name"
  • Width - ширина страницы, миллиметры
    page.Width = 80
  • Height - высота страницы, миллиметры
    page.Height = 80
  • DrawGrid - процедура, выводящая на страницу сетку с шагом 5 миллиметров для удобства отладки вида документа.
  • Perform - процедура, позволяющая выполнить дополнительные команды PostScript на странице.
    page.perform "1 0.7 0 0 k"page.perform "0 0 m"

1.2.2.1. Объявление цвета

Для объявления цвета объектов на странице используется цветовая модель R:G:B (Red:Green:Blue). Объявление цвета для выполнения последующих операций (цвет шрифта, цвет линии/фигуры) осуществляется процедурой

procedure SetColor(R: Integer; G: Integer; B: Integer);
Где параметры R, G, B - значения базисных цветов для выбранного цвета (от 0 до 255).

Цвет | R | G | B |
Белый | 255 | 255 | 255 | +++
Черный | 0 | 0 | 0 | +++
Серый | 190 | 190 | 190 | +++
Синий | 0 | 0 | 255 | +++
Красный | 255 | 0 | 0 | +++
Зеленый | 0 | 255 | 0 | +++

Если предварительно цвет не был объявлен, используется цвет по умолчанию - черный (0,0,0)

1.2.3. Графика

1.2.3.1. Линии

Для отрисовки линий используется процедура

procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double);
Здесь:

  • X1 - координата начала линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y1 - координата начала линии по вертикали в миллиметрах от верхнего левого угла листа.
  • X2 - координата конца линии по горизонтали в миллиметрах от верхнего левого угла листа.
  • Y2 - координата Конца линии по вертикали в миллиметрах от верхнего левого угла листа.

Для задания толщины линии используется свойство

property LineWidth: Double
Значение толщины задается в миллиметрах. Значение по умолчанию - минимально возможная единица рисования для устройства. Так для монитора - 1 pixel, для принтера - 1 dot (точка)

Для задания стиля отрисовки начала/окончания линии используется свойство property LineCap: TPDFLineCap
Возможные стили:
Значение свойства: | Отображение: | Описание:
0 | Линия 0 | Прямой срез точно по точкам начала и окончания линии (по умолчанию)
1 | Линия 1 | С закруглением
2 | Линия 2 | Прямой срез с продолжением линии на половину толщины линии

Объявление цвета линии.

Две линии разной толщины, с разными окончаниями и цветами:
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineCap = 1
06
07page.LineWidth = 2
08
09page.Line 10, 10, 30, 30
10
11page.LineWidth = 4
12
13page.SetColor 255, 0, 0
14
15page.LineCap = 2
16
page.Line 10, 30, 30, 10."I

Результат:
2 линии

При необходимости соединения линий под углом в определенной точке можно задать тип соединения. Для объявления типа соединения используется свойство property LineJoin: TPDFLineJoin;
Типы соединения двух линий:
Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пунктир

Для создания пунктира используется процедура отображения линии с предварительно объявленными дополнительными значениями.

Процедура procedure SetDash(DashArray: OleVariant; Phase: Integer); Здесь DashArray - массив значений в миллиметрах, указывающий последовательность чередования штрихов и пропусков на линии, Phase - смещение в миллиметрах по линии.

Пример 1. Штрих 10 мм, Промежуток 5 мм, Смещения нет
Пример 2. Штрих 10 мм, Промежуток 5 мм, Смещение 5 мм
Пример 3. Различные значения штрихов и промежутков, Смещения нет
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 3
06
07page.SetDash Array(10, 5), 0
08
09page.Line 10, 10, 100, 10
10
11page.SetDash Array(10, 5), 5
12
13page.Line 10, 20, 100, 20
14
15page.SetDash Array(10, 5, 3, 2, 12, 20), 0
16
page.Line 10, 30, 100, 30

Результат:
Пунктир 1

Ломанная линия - здесь непрерывная линия, состоящая из нескольких прямых. Для отображения ломанной используется процедура procedure Poly(Points: OleVariant; Fill: WordBool), где Points - массив координат точек соединяемых прямыми, а Fill - признак заливки полученной замкнутой фигуры (если замкнута).

Пример Звезда без заливки
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), false

Результат:
Звезда
Пример Звезда с заливкой
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), true

Результат:
Звезда заливка

1.2.3.2. Прямоугольник

Rectangle (Прямоугольник) - для создания используется процедура:

procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double; Fill: WordBool);
Здесь:

  • X1 - координата верхнего левого угла прямоугольника по горизонтали в миллиметрах от верхнего левого угла листа шаблона.
  • Y1 - координата верхнего левого угла прямоугольника по вертикали в миллиметрах от верхнего левого угла листа шаблона.
  • Width - ширина прямоугольника с миллиметрах.
  • Height - высота прямоугольника с миллиметрах.
  • Fill - признак заливки прямоугольника (True/False). Если значение True то заливка производится объявленным заранее цветом (см. Объявление цвета). Если False - заливка не производится. Прямоугольник отрисовывается линиями с предварительно заданной толщиной. См. Линии
Пример 1. Создание красного прямоугольника:
1set page = CreatePage(Null)
2
3page.SetColor 255, 0, 0
4
5page.Rectangle 10, 15, 40, 20, True
6
page.DrawGrid
Результат:
Прямоугольник
Пример 2. Пустой прямоугольник без задания цвета:
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.Rectangle 12, 17, 42, 25, false
6
page.DrawGrid

Результат:
Прямоугольник false

Также существует возможность изменения стиля отображения углов прямоугольника. Для этого нужно использовать свойство property LineJoin: TPDFLineJoin;

Значение свойства | Отображение | Описание
0 | 2 линии 0 | С острым углом
1 | 2 линии 1 | С закруглением
2 | 2 линии 2 | С обрезанным углом

Пример построения прямоугольников с различными типами соединения сторон:

01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 4
06
07page.LineJoin = 0
08
09page.Rectangle 10, 10, 20, 10, false
10
11page.LineJoin = 1
12
13page.Rectangle 40, 10, 20, 10, false
14
15page.LineJoin = 2
16
page.Rectangle 70, 10, 20, 10, false

Результат:
3 прямоугольника

1.2.3.3. Вставка готовых изображений

Для вставки на создаваемую страницу готового изображения используется процедура procedure Image(const FileName: WideString; X: Double; Y: Double; Width: Double; Height: Double)

Параметры:

  • const FileName - имя файла изображения и путь к нему на жестком диске. Задается в кавычках.
  • X - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по горизонтали в миллиметрах
  • Y - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по вертикали в миллиметрах
  • Width - ширина изображения в миллиметрах
  • Height - высота изображения в миллиметрах.
1set page = CreatePage(Null)
2page.drawgrid
page.Image "c:\mill.bmp", 10,10, 30, 30

Результат:
Картинка

Вне зависимости от размера исходного изображения, при вставке изображения на создаваемую страницу оно будет растянуто по размерам, прописанным в процедуре.

1.2.3.4. Векторная графика

Язык PostScript, с помощью которого создаются векторные изображения для PDF-документа, поддерживает создание типичных примитивных объектов, таких как:

  • Прямые и ломанные линии
  • Многоугольники
  • Окружности и эллипсы
  • Кривые Безье
  • Текст

При создании векторного изображения на странице PDF-документа в приложениях Платформы, команды построения примитивных объектов PostScript передаются на исполнение при помощи процедуры Perform. Подробнее об операторах и командах PostScript для создания PDF-документов можно узнать на сайте Adobe

1.2.4. Шрифты

Шрифты, которые должны использоваться в создаваемом документе, должны быть предварительно объявлены. Для объявления используемых шрифтов используется функция
function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool; Italic: WordBool): IPDFFont; где:

  • const FontName - имя шрифта, аналогичное имени объявляемого шрифта в операционной системе. В Функции объявляется в кавычках.
  • Size - размер шрифта в пунктах
  • Bold - признак начертания шрифта "жирный". Значения - True или False
  • Italic - признак начертания шрифта "курсив". Значения - True или False
Примеры объявления шрифтов:
1set font = page.createFont("Arial", 20, False, False)
2set labelFont = page.createFont("Times New Roman", 16, False, True)
3set dataFont = page.createFont("Tahoma", 18, True, False)

Для вывода текстовой информации на страницу используются процедуры:

  • procedure WriteLine(const LineText: WideString; X: Double; Y: Double);
    - используется для вывода текстовой строки
  • function WriteText(const AText: WideString; X: Double; Y: Double; Width: Double; Alignment: TPDFTextAlignment): Double;
    - используется для вывода текстового блока.

Параметры для procedure WriteLine :

  • const LineText - текстовая строка для вывода. Прописывается в кавычках. Будет выведена на страницу одной строкой.
  • X - координата верхней левой точки текстовой строки по горизонтали в миллиметрах.
  • Y - координата верхней левой точки текстовой строки по вертикали в миллиметрах.
Примеры вывода текстов на страницу:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Times New Roman", 16, False, True)
05set dataFont = page.createFont("Tahoma", 18, True, False)
06Font.WriteLine "Фамилия", 5, 2
07Font.WriteLine "Имя", 5, 10
08Font.WriteLine "Отчество", 5, 18
09labelFont.WriteLine "Дата рождения", 5, 26
10dataFont.WriteLine "Национальность", 5, 34

Результат:
Разные шрифты

Параметры для function WriteText :

  • const AText - текст для вывода на страницу. Прописывается в кавычках. Будет выведена на страницу в виде текстового блока.
  • X - координата верхней левой точки текстового блока по горизонтали в миллиметрах.
  • Y - координата верхней левой точки текстового блока по вертикали в миллиметрах.
  • Width - ширина текстового блока в миллиметрах
  • Alignment - тип выравнивания текста в текстовом блоке.
    Значение параметра | Тип выравнивания
    0 | По левому краю
    1 | По правому краю
    2 | По центру
    3 | Выравнивание по ширине
Примеры вывода текстовых блоков на страницу:
1set page = CreatePage(Null)
2page.DrawGrid
3set font = page.createFont("Arial", 14, False, False)
4set labelFont = page.createFont("Times New Roman", 12, False, True)
5set dataFont = page.createFont("Tahoma", 11, True, False)
6Q = font.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 5, 100, 0)
7Q = labelFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 35, 100, 1)
8Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 55, 100, 2)
9Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 80, 100, 3)

Результат:
Выравнивание

Свойства шрифтов:

property Spacing: Double; - свойство, отвечающее за величину промежутка между буквами в слове. Задается в виде отклонения от промежутка между буквами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Spacing = 0
07labelFont.Spacing = 1
08dataFont.Spacing = 2
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (1 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 15

Результат:
Промежуток букв

property WordSpacing: Double; - свойство, отвечающее за величину промежутка между соседними словами. Задается в виде отклонения от промежутка между словами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.WordSpacing = 0
07labelFont.WordSpacing = 2
08dataFont.WordSpacing = 5
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (5 мм)", 5, 15

Результат:
Промежуток слов

property Scaling: Double; - свойство, отвечающее за горизонтальное масштабирование букв используемого шрифта. Устанавливается в процентах. Горизонтальный масштаб по умолчанию - 100%.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Scaling = 50
07labelFont.Scaling = 100
08dataFont.Scaling = 200
09font.WriteLine "Сжатие (50)", 5, 5
10labelFont.WriteLine "По умолчанию (100)", 5, 10
11dataFont.WriteLine "Растягивание (150)", 5, 15

Результат:
Scaling

property RenderingMode: TPDFFontRenderingMode; - свойство, отвечающее за заливку букв используемого шрифта.
Типы заливки:
Значение параметра: | Отображение: | Описание:
0 | Font Fill | Сплошная заливка (по умолчанию). Буква заливается сплошным цветом, объявленным на данный момент.
1 | Font Stroke | Только граница. Прорисовывается граница буквы. Тело остается незалитым.
2 | Font FillStroke | Сначала заливка, потом граница. Граница прорисовывается всегда черным цветом. Заливка осуществляется сплошным цветом, объявленным на данный момент.
3 | Inv | Невидимый шрифт.

Пример:
01set page = CreatePage(Null)
02set font = page.createFont("Arial", 20, False, False)
03set labelFont = page.createFont("Arial", 20, False, False)
04set dataFont = page.createFont("Arial", 20, False, False)
05font.RenderingMode = 0
06labelFont.RenderingMode = 1
07dataFont.RenderingMode = 2
08page.setColor 255, 0, 0
09Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
10Q = labelFont.WriteText ("Олимпиада", 5, 15, 50, 0)
11Q = dataFont.WriteText ("Олимпиада", 5, 25, 50, 0)

Результат:
Заливка букв

property Rise: Double; - свойство, отвечающее за перемещение текста по вертикали.

01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Arial", 7, False, False)
05set dataFont = page.createFont("Arial", 7, False, False)
06labelFont.rise = -17
07dataFont.rise = -2
08Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
09Q = labelFont.WriteText ("Олимпиада", 44, 5, 50, 0)
10Q = dataFont.WriteText ("Олимпиада", 44, 5, 50, 0)

Результат:
Rise

Для определения размеров текстовой строки используется процедура MeasureLine(const LineText: WideString; out Width: OleVariant; out Height: OleVariant);

Здесь:

  • LineText - исходный текст для размещения на странице
  • Width - возвращаемый параметр ширины текстового блока на странице
  • Height - возвращаемый параметр высоты текстового блока на странице
1S = "шифр"
2font.MeasureLine S, W, H
3Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2)

Здесь для текста "Шифр" замеряется ширина и высота получившегося текстового блока. Затем полученные данные используются для корректного размещения текста на странице.

Для определения высоты текстового блока используется функция MeasureText(const AText: WideString; Width: Double): Double; safecall;

Функция распределит текст по задаваемому значению ширины текстового блока и вернет значение высоты текстового блока в милиметрах.

Здесь:

  • AText - исходный текст для размещения на странице. Прописывается в кавычках.
  • Width - задаваемая ширина текстового блока на странице в милиметрах.
1S = "Текст для размещения на странице..."
2Q = font.MeasureText(S, 139)
Здесь для текста "Текст для размещения на странице..." замеряется высота получившегося текстового блока. Затем полученные данные могут использоваться для корректного размещения текста на странице.

1.3. Порядок создания

Для создания шаблона PDF-документа необходимо в системной форме Платформы выбрать класс, к которому будет строиться документ. В подменю "Подпрограммы" вызвать контекстное меню и выбрать пункт "Создать шаблон отчета PDF". Заполнить необходимые поля и приступить к созданию скрипта в окне "Скрипт шаблона".

  1. Объявляем все переменные.
  2. Создаем страницы
  3. Устанавливаем все свойства документа и страниц
  4. Рисуем простые графические объекты
  5. Объявляем все используемые шрифты
  6. Расставляем постоянный текст на странице
  7. Расставляем переменный текст на странице
  8. Вставляем или создаем сложные графические объекты
Пример документа PDF:
001set LDataSet = createDataSet("TRoundAbiturSt")
002'Объявление переменных
003LDataSet.AddQueryItem 1, "ID", ID
004LDataSet.AddQueryItem 0, "RoundComp$N"
005LDataSet.AddQueryItem 0, "BachRound$N"
006LDataSet.AddQueryItem 0, "LastName"
007LDataSet.AddQueryItem 0, "FirstName"
008LDataSet.AddQueryItem 0, "MiddleName"
009LDataSet.AddQueryItem 0, "BirthDate"
010LDataSet.AddQueryItem 0, "RegNumber"
011LDataSet.AddQueryItem 0, "SecondStageCity$D"
012LDataSet.AddQueryItem 0, "PhoneList"
013
014'Присваивание переменным значений
015OlympName = LDataSet.Field("RoundComp$N")
016OlympClass = LDataSet.Field("BachRound$N")
017LastName = LDataSet.Field("LastName")
018FirstName = LDataSet.Field("FirstName")
019MiddleName = LDataSet.Field("MiddleName")
020if not IsNull(LDataSet.Field("BirthDate")) then
021  BirthDate = LDataSet.Field("BirthDate")
022else
023  BirthDate = "(не задана)"
024end if
025RegNo = LDataSet.Field("RegNumber")
026if not IsNull(LDataSet.Field("SecondStageCity$D")) then
027  OlympCity = LDataSet.Field("SecondStageCity$D")
028else
029  OlympCity = "(не выбран город участия)"
030end if
031if not IsNull(LDataSet.Field("PhoneList")) then
032  Phone = LDataSet.Field("PhoneList")
033else
034  Phone = ""
035end if
036
037'CanCompress = False - признак сжатия файла
038set page = CreatePage(Null) ' создаем страницу
039'Объявляем используемые шрифты
040set font = page.createFont("Arial", 20, False, False)
041set labelFont = page.createFont("Arial", 16, False, False)
042set dataFont = page.createFont("Arial", 18, True, False)
043set bigFont = page.createFont("Arial", 24, False, False)
044
045'page.DrawGrid  - рисуем сетку для удобства отладки
046
047page.LineWidth = 0.5 ' Установка толщины линии
048
049' Рисуем прямоугольники
050page.Rectangle 8, 12, 4, 4, True
051page.Rectangle 190, 12, 4, 4, True
052
053page.Rectangle 8, 273, 4, 4, True
054page.Rectangle 105, 273, 4, 4, True
055page.Rectangle 190, 273, 4, 4, True
056
057'Выводим постоянный и переменный текст
058Q = font.WriteText ("Межрегиональная олимпиада школьников", 12, 20, 178, 2)
059Q = bigFont.WriteText (OlympName, 12, 45, 178, 2)
060Q = bigFont.WriteText (OlympClass, 12, 56, 178, 2)
061
062Q = font.WriteText ("Титульный лист", 12, 72, 178, 2)
063
064labelFont.WriteLine "Фамилия", 25, 115 - 23
065labelFont.WriteLine "Имя", 25, 123 - 23
066labelFont.WriteLine "Отчество", 25, 131 - 23
067labelFont.WriteLine "Дата", 25, 139 - 23
068labelFont.WriteLine "рождения", 25, 145 - 23
069
070labelFont.WriteLine "Регистрационный номер", 25, 169 - 30
071labelFont.WriteLine "Город проведения", 25, 177 - 30
072labelFont.WriteLine "Аудитория", 25, 185 - 30
073
074
075labelFont.WriteLine "Дата", 25, 211
076labelFont.WriteLine "Подпись", 25, 219
077labelFont.WriteLine "Телефон", 25, 227
078
079
080dataFont.WriteLine LastName, 63, 114 - 23
081dataFont.WriteLine FirstName, 63, 122 - 23
082dataFont.WriteLine MiddleName, 63, 130 - 23
083dataFont.WriteLine BirthDate, 63, 141 - 23
084
085dataFont.WriteLine RegNo, 100, 168 - 30
086dataFont.WriteLine OlympCity, 100, 176 - 30
087
088' Рисуем линии
089page.line 100, 192 - 30, 150, 192 - 30
090page.line 58, 218, 108, 218
091page.line 58, 226, 108, 226
092Q = dataFont.WriteText(Phone, 58, 226, 65, 0)
093
094
095
096' Устанавливаем новый цвет
097page.setColor 192, 192, 192
098
099S = "шифр"
100font.MeasureLine S, W, H  ' измеряем текстовый блок
101Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2) ' располагаем текстовый
102блок на странице
103
104' Устанавливаем новый цвет
105page.setColor 255, 0, 0
106' Устанавливаем толщину линий в 1 пиксель
107page.LineWidth = 0
108' Рисуем линии по координатам
109X = 139
110Y = 267
111
112page.line X, Y - 3, X, Y + 3
113page.line X - 3, Y, X + 3, Y
114
115X = X + 40
116page.line X, Y - 3, X, Y + 3
117page.line X - 3, Y, X + 3, Y
118
119
120Y = Y - 23
121page.line X, Y - 3, X, Y + 3
122page.line X - 3, Y, X + 3, Y
123
124X = X - 40
125page.line X, Y - 3, X, Y + 3
page.line X - 3, Y, X + 3, Y

Результат:

2. Справочник по интерфейсам

2.1. Перечисление TPDFFontRenderingMode
1type
2  TPDFFontRenderingMode = (frmFillText, frmStrokeText, frmFillThenStrokeText,
3    frmInvisible);

Или

1type
2  TPDFFontRenderingMode = TOleEnum;
3const
4  frmFillText = $00000000;
5  frmStrokeText = $00000001;
6  frmFillThenStrokeText = $00000002;
7  frmInvisible = $00000003;

Элементы перечисления:

Имя | Значение | Назначение
frmFillText | 0 |
frmStrokeText | 1 |
frmFillThenStrokeText | 2 |
frmInvisible | 3 |

2.2. Перечисление TPDFLineCap
1type
2  TPDFLineCap = (lcBuss, lcRound, lcProtecting);

Или

1type
2  TPDFLineCap = TOleEnum;
3const
4  lcBuss = $00000000;
5  lcRound = $00000001;
6  lcProtecting = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
lcBuss | 0 |
lcRound | 1 |
lcProtecting | 2 |

2.3. Перечисление TPDFLineJoin
1type
2  TPDFLineJoin = (ljMiter, ljRound, ljBevel);

Или

1type
2  TPDFLineJoin = TOleEnum;
3const
4  ljMiter = $00000000;
5  ljRound = $00000001;
6  ljBevel = $00000002;

Элементы перечисления:

Имя | Значение | Назначение
ljMiter | 0 |
ljRound | 1 |
ljBevel | 2 |

2.4. Перечисление TPDFTextAlignment
1type
2  TPDFTextAlignment = (ptaLeft, ptaRight, ptaCenter, ptaJustified);

Или

1type
2  TPDFTextAlignment = TOleEnum;
3const
4  ptaLeft = $00000000;
5  ptaRight = $00000001;
6  ptaCenter = $00000002;
7  ptaJustified = $00000003;

Элементы перечисления:

Имя | Значение | Назначение
ptaLeft | 0 |
ptaRight | 1 |
ptaCenter | 2 |
ptaJustified | 3 |

2.5. Интерфейс IPDFDocument

01type
02  IPDFDocument = interface(IDispatch)
03    ['{E57FFE9D-6B85-45E6-A5D0-9DD17950A666}']
04    procedure Save(Target: OleVariant); safecall;
05    function CreatePage(Parent: OleVariant): IPDFPage; safecall;
06    function Get_Title: WideString; safecall;
07    procedure Set_Title(Value: WideString); safecall;
08    function Get_CanEmbedFonts: WordBool; safecall;
09    procedure Set_CanEmbedFonts(Value: WordBool); safecall;
10    function Get_CanCompress: WordBool; safecall;
11    procedure Set_CanCompress(Value: WordBool); safecall;
12    function Get_Author: WideString; safecall;
13    procedure Set_Author(Value: WideString); safecall;
14    function Get_Subject: WideString; safecall;
15    procedure Set_Subject(Value: WideString); safecall;
16    function Get_Keywords: WideString; safecall;
17    procedure Set_Keywords(Value: WideString); safecall;
18    function Get_Creator: WideString; safecall;
19    procedure Set_Creator(Value: WideString); safecall;
20    function Get_Pages(Index: Integer): IPDFPage; safecall;
21    function Get_PageCount: Integer; safecall;
22    procedure Close; safecall;
23    procedure Serialize(const Stream: IUnknown); safecall;
24    function Get_MinCompressSize: Integer; safecall;
25    procedure Set_MinCompressSize(Value: Integer); safecall;
26    function Get_MaxCompressSize: Integer; safecall;
27    procedure Set_MaxCompressSize(Value: Integer); safecall;
28    function CreatePageFromImage(Image: OleVariant; PageWidth: Double;
29      PageHeight: Double; Margin: Double): WordBool; safecall;
30    procedure SaveToXML(Target: OleVariant); safecall;
31    property Title: WideString read Get_Title write Set_Title;
32    property CanEmbedFonts: WordBool read Get_CanEmbedFonts write Set_CanEmbedFonts;
33    property CanCompress: WordBool read Get_CanCompress write Set_CanCompress;
34    property Author: WideString read Get_Author write Set_Author;
35    property Subject: WideString read Get_Subject write Set_Subject;
36    property Keywords: WideString read Get_Keywords write Set_Keywords;
37    property Creator: WideString read Get_Creator write Set_Creator;
38    property Pages[Index: Integer]: IPDFPage read Get_Pages;
39    property PageCount: Integer read Get_PageCount;
40    property MinCompressSize: Integer read Get_MinCompressSize
41      write Set_MinCompressSize;
42    property MaxCompressSize: Integer read Get_MaxCompressSize
43      write Set_MaxCompressSize;
44  end;

2.5.1. Свойства

Свойства интерфейса IPDFDocument:

Имя | Тип | Доступ | Назначение
Author | WideString | Чтение/Запись |
CanCompress | WordBool | Чтение/Запись |
CanEmbedFonts | WordBool | Чтение/Запись |
Creator | WideString | Чтение/Запись |
Keywords | WideString | Чтение/Запись |
MaxCompressSize | Integer | Чтение/Запись |
MinCompressSize | Integer | Чтение/Запись |
PageCount | Integer | Только для чтения |
Pages[Index: Integer] | IPDFPage | Только для чтения |
Subject | WideString | Чтение/Запись |
Title | WideString | Чтение/Запись |

2.5.2. Метод Close

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Close;

Метод не имеет параметров.

2.5.3. Метод CreatePage

Метод интерфейса IPDFDocument.

function IPDFDocument.CreatePage(Parent: OleVariant): IPDFPage;

Параметры:

Имя | Тип | Обязательно | Значение
Parent | OleVariant | Да |

Замечания:

Возвращает значение типа IPDFPage.

2.5.4. Метод CreatePageFromImage

Метод интерфейса IPDFDocument.

1function IPDFDocument.CreatePageFromImage(Image: OleVariant; PageWidth: Double;
2  PageHeight: Double; Margin: Double): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Image | OleVariant | Да |
PageWidth | Double | Да |
PageHeight | Double | Да |
Margin | Double | Да |

Замечания:

Возвращает значение типа WordBool.

2.5.5. Метод Save

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Save(Target: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Target | OleVariant | Да |

2.5.6. Метод SaveToXML

Метод интерфейса IPDFDocument.

procedure IPDFDocument.SaveToXML(Target: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Target | OleVariant | Да |

2.5.7. Метод Serialize

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Serialize(const Stream: IUnknown);

Параметры:

Имя | Тип | Обязательно | Значение
Stream | IUnknown | Да |

2.6. Интерфейс IPDFFont

01type
02  IPDFFont = interface(IDispatch)
03    ['{43FE399A-A724-4076-BAFA-098639628385}']
04    function Get_Spacing: Double; safecall;
05    procedure Set_Spacing(Value: Double); safecall;
06    function Get_WordSpacing: Double; safecall;
07    procedure Set_WordSpacing(Value: Double); safecall;
08    function Get_Scaling: Double; safecall;
09    procedure Set_Scaling(Value: Double); safecall;
10    function Get_RenderingMode: TPDFFontRenderingMode; safecall;
11    procedure Set_RenderingMode(Value: TPDFFontRenderingMode); safecall;
12    function Get_Rise: Double; safecall;
13    procedure Set_Rise(Value: Double); safecall;
14    procedure WriteLine(const LineText: WideString; X: Double; Y: Double); safecall;
15    procedure MeasureLine(const LineText: WideString; out Width: OleVariant;
16      out Height: OleVariant); safecall;
17    function WriteText(const AText: WideString; X: Double; Y: Double;
18      Width: Double; Alignment: TPDFTextAlignment): Double; safecall;
19    function MeasureText(const AText: WideString; Width: Double): Double; safecall;
20    function Get_Angle: Double; safecall;
21    procedure Set_Angle(Value: Double); safecall;
22    function Get_LineSpacing: Double; safecall;
23    procedure Set_LineSpacing(Value: Double); safecall;
24    property Spacing: Double read Get_Spacing write Set_Spacing;
25    property WordSpacing: Double read Get_WordSpacing write Set_WordSpacing;
26    property Scaling: Double read Get_Scaling write Set_Scaling;
27    property RenderingMode: TPDFFontRenderingMode read Get_RenderingMode
28      write Set_RenderingMode;
29    property Rise: Double read Get_Rise write Set_Rise;
30    property Angle: Double read Get_Angle write Set_Angle;
31    property LineSpacing: Double read Get_LineSpacing write Set_LineSpacing;
32  end;

2.6.1. Свойства

Свойства интерфейса IPDFFont:

Имя | Тип | Доступ | Назначение
Angle | Double | Чтение/Запись |
LineSpacing | Double | Чтение/Запись |
RenderingMode | TPDFFontRenderingMode | Чтение/Запись |
Rise | Double | Чтение/Запись |
Scaling | Double | Чтение/Запись |
Spacing | Double | Чтение/Запись |
WordSpacing | Double | Чтение/Запись |

2.6.2. Метод MeasureLine

Метод интерфейса IPDFFont.

1procedure IPDFFont.MeasureLine(const LineText: WideString;
2  out Width: OleVariant; out Height: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
LineText | WideString | Да |
Width | OleVariant | Да |
Height | OleVariant | Да |

2.6.3. Метод MeasureText

Метод интерфейса IPDFFont.

function IPDFFont.MeasureText(const AText: WideString; Width: Double): Double;

Параметры:

Имя | Тип | Обязательно | Значение
AText | WideString | Да |
Width | Double | Да |

Замечания:

Возвращает значение типа Double.

2.6.4. Метод WriteLine

Метод интерфейса IPDFFont.

procedure IPDFFont.WriteLine(const LineText: WideString; X: Double; Y: Double);

Параметры:

Имя | Тип | Обязательно | Значение
LineText | WideString | Да |
X | Double | Да |
Y | Double | Да |

2.6.5. Метод WriteText

Метод интерфейса IPDFFont.

1function IPDFFont.WriteText(const AText: WideString; X: Double; Y: Double;
2  Width: Double; Alignment: TPDFTextAlignment): Double;

Параметры:

Имя | Тип | Обязательно | Значение
AText | WideString | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Alignment | TPDFTextAlignment | Да |

Замечания:

Возвращает значение типа Double.

2.7. Интерфейс IPDFPage

01type
02  IPDFPage = interface(IDispatch)
03    ['{749FB131-80FE-46E9-8330-22C1DC346FE7}']
04    function Get_Parent: IPDFPage; safecall;
05    function Get_Title: WideString; safecall;
06    procedure Set_Title(Value: WideString); safecall;
07    function Get_Width: Double; safecall;
08    procedure Set_Width(Value: Double); safecall;
09    function Get_Height: Double; safecall;
10    procedure Set_Height(Value: Double); safecall;
11    function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool;
12      Italic: WordBool): IPDFFont; safecall;
13    procedure Perform(const Command: WideString); safecall;
14    function Get_LineWidth: Double; safecall;
15    procedure Set_LineWidth(Value: Double); safecall;
16    procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double); safecall;
17    procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double;
18      Fill: WordBool); safecall;
19    function Get_LineCap: TPDFLineCap; safecall;
20    procedure Set_LineCap(Value: TPDFLineCap); safecall;
21    function Get_LineJoin: TPDFLineJoin; safecall;
22    procedure Set_LineJoin(Value: TPDFLineJoin); safecall;
23    procedure SetDash(DashArray: OleVariant; Phase: Integer); safecall;
24    procedure SetColor(R: Integer; G: Integer; B: Integer); safecall;
25    procedure PerformColor(const Command: WideString); safecall;
26    procedure Poly(Points: OleVariant; Fill: WordBool); safecall;
27    procedure Image(Image: OleVariant; X: Double; Y: Double; Width: Double;
28      Height: Double; Transparent: WordBool); safecall;
29    procedure DrawGrid; safecall;
30    procedure Arc(X: Double; Y: Double; Radius: Double; StartAngle: Double;
31      EndAngle: Double; FillSegment: WordBool; FillSector: WordBool); safecall;
32    procedure Curve(Points: OleVariant; Fill: WordBool); safecall;
33    procedure HyperLink(const URI: WideString; X: Double; Y: Double; Width: Double;
34      Height: Double); safecall;
35    procedure Pattern(X1: Double; Y1: Double; Width: Double; Height: Double;
36      PatternPointSize: Double; Percentage: Integer); safecall;
37    procedure Bezier(Points: OleVariant; Fill: WordBool); safecall;
38    procedure XObject(Data: OleVariant); safecall;
39    procedure SetColorCMYK(C: Double; M: Double; Y: Double; K: Double); safecall;
40    procedure LocalLink(const Page: IDispatch; DestinationX: Double;
41      DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
42      X: Double; Y: Double; Width: Double; Height: Double); safecall;
43    property Parent: IPDFPage read Get_Parent;
44    property Title: WideString read Get_Title write Set_Title;
45    property Width: Double read Get_Width write Set_Width;
46    property Height: Double read Get_Height write Set_Height;
47    property LineWidth: Double read Get_LineWidth write Set_LineWidth;
48    property LineCap: TPDFLineCap read Get_LineCap write Set_LineCap;
49    property LineJoin: TPDFLineJoin read Get_LineJoin write Set_LineJoin;
50  end;

2.7.1. Свойства

Свойства интерфейса IPDFPage:

Имя | Тип | Доступ | Назначение
Height | Double | Чтение/Запись |
LineCap | TPDFLineCap | Чтение/Запись |
LineJoin | TPDFLineJoin | Чтение/Запись |
LineWidth | Double | Чтение/Запись |
Parent | IPDFPage | Только для чтения |
Title | WideString | Чтение/Запись |
Width | Double | Чтение/Запись |

2.7.2. Метод Arc

Метод интерфейса IPDFPage.

1procedure IPDFPage.Arc(X: Double; Y: Double; Radius: Double;
2  StartAngle: Double; EndAngle: Double; FillSegment: WordBool;
3  FillSector: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
X | Double | Да |
Y | Double | Да |
Radius | Double | Да |
StartAngle | Double | Да |
EndAngle | Double | Да |
FillSegment | WordBool | Да |
FillSector | WordBool | Да |

2.7.3. Метод Bezier

Метод интерфейса IPDFPage.

procedure IPDFPage.Bezier(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

2.7.4. Метод CreateFont

Метод интерфейса IPDFPage.

1function IPDFPage.CreateFont(const FontName: WideString; Size: Double;
2  Bold: WordBool; Italic: WordBool): IPDFFont;

Параметры:

Имя | Тип | Обязательно | Значение
FontName | WideString | Да |
Size | Double | Да |
Bold | WordBool | Да |
Italic | WordBool | Да |

Замечания:

Возвращает значение типа IPDFFont.

2.7.5. Метод Curve

Метод интерфейса IPDFPage.

procedure IPDFPage.Curve(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

2.7.6. Метод DrawGrid

Метод интерфейса IPDFPage.

procedure IPDFPage.DrawGrid;

Метод не имеет параметров.

2.7.7. Метод HyperLink

Метод интерфейса IPDFPage.

1procedure IPDFPage.HyperLink(const URI: WideString; X: Double; Y: Double;
2  Width: Double; Height: Double);

Параметры:

Имя | Тип | Обязательно | Значение
URI | WideString | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |

2.7.8. Метод Image

Метод интерфейса IPDFPage.

1procedure IPDFPage.Image(Image: OleVariant; X: Double; Y: Double;
2  Width: Double; Height: Double; Transparent: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Image | OleVariant | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |
Transparent | WordBool | Нет |

2.7.9. Метод Line

Метод интерфейса IPDFPage.

procedure IPDFPage.Line(X1: Double; Y1: Double; X2: Double; Y2: Double);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
X2 | Double | Да |
Y2 | Double | Да |

2.7.10. Метод LocalLink

Метод интерфейса IPDFPage.

1procedure IPDFPage.LocalLink(const Page: IDispatch; DestinationX: Double;
2  DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
3  X: Double; Y: Double; Width: Double; Height: Double);

Параметры:

Имя | Тип | Обязательно | Значение
Page | IDispatch | Да |
DestinationX | Double | Да |
DestinationY | Double | Да |
DestinationWidth | Double | Да |
DestinationHeight | Double | Да |
X | Double | Да |
Y | Double | Да |
Width | Double | Да |
Height | Double | Да |

2.7.11. Метод Pattern

Метод интерфейса IPDFPage.

1procedure IPDFPage.Pattern(X1: Double; Y1: Double; Width: Double;
2  Height: Double; PatternPointSize: Double; Percentage: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
Width | Double | Да |
Height | Double | Да |
PatternPointSize | Double | Да |
Percentage | Integer | Да |

2.7.12. Метод Perform

Метод интерфейса IPDFPage.

procedure IPDFPage.Perform(const Command: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Command | WideString | Да |

2.7.13. Метод PerformColor

Метод интерфейса IPDFPage.

procedure IPDFPage.PerformColor(const Command: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Command | WideString | Да |

2.7.14. Метод Poly

Метод интерфейса IPDFPage.

procedure IPDFPage.Poly(Points: OleVariant; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
Points | OleVariant | Да |
Fill | WordBool | Да |

2.7.15. Метод Rectangle

Метод интерфейса IPDFPage.

1procedure IPDFPage.Rectangle(X1: Double; Y1: Double; Width: Double;
2  Height: Double; Fill: WordBool);

Параметры:

Имя | Тип | Обязательно | Значение
X1 | Double | Да |
Y1 | Double | Да |
Width | Double | Да |
Height | Double | Да |
Fill | WordBool | Да |

2.7.16. Метод SetColor

Метод интерфейса IPDFPage.

procedure IPDFPage.SetColor(R: Integer; G: Integer; B: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
R | Integer | Да |
G | Integer | Да |
B | Integer | Да |

2.7.17. Метод SetColorCMYK

Метод интерфейса IPDFPage.

procedure IPDFPage.SetColorCMYK(C: Double; M: Double; Y: Double; K: Double);

Параметры:

Имя | Тип | Обязательно | Значение
C | Double | Да |
M | Double | Да |
Y | Double | Да |
K | Double | Да |

2.7.18. Метод SetDash

Метод интерфейса IPDFPage.

procedure IPDFPage.SetDash(DashArray: OleVariant; Phase: Integer);

Параметры:

Имя | Тип | Обязательно | Значение
DashArray | OleVariant | Да |
Phase | Integer | Да |

2.7.19. Метод XObject

Метод интерфейса IPDFPage.

procedure IPDFPage.XObject(Data: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Data | OleVariant | Да |


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IFieldInfo2 (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IFieldInfo2

Интерфейс IFieldInfoИнтерфейс INamedItemInfo

1type
2  IFieldInfo2 = interface(IFieldInfo)
3    ['{82D93CF0-0E2F-4A85-AD74-9B1B9199B76B}']
4    function Get_Category: WideString; safecall;
5    property Category: WideString read Get_Category;
6  end;

1. Свойства

Свойства интерфейса IFieldInfo2:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
DisplayMode | TDisplayMode | Только для чтения | Унаследовано от IFieldInfo
TypeInfo | ITypeInfo | Только для чтения
Category | WideString | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Класс TExcelAsyncTask (Задачи отложенного выполнения отчетов Excel) (раздел целиком) (22.10.2024) (одним файлом)
Класс TExcelAsyncTask (Задачи отложенного выполнения отчетов Excel)

Класс TAsyncTask (Задачи отложенного выполнения)Класс TObject (Объекты)

Объекты класса не именованы.

1. Свойства

Свойства класса TExcelAsyncTask:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Видимо пользователю | Только для чтения | Унаследовано от TAsyncTask
Created | datetime | Да | Видимо пользователю | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Status | TAsyncTaskStatus | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TAsyncTask
Routine | TRoutine | Да | Видимо пользователю | Чтение/Запись
RoutineClass | TClass | Да | Скрыто от пользователя | Только для чтения
Language | TLanguage | Да | Видимо пользователю | Чтение/Запись
Handler | TAsyncHandler | Да | Видимо пользователю | Чтение/Запись
FormView | TFormView | Нет | Видимо пользователю | Чтение/Запись
Object | TObject | Нет | Видимо пользователю | Чтение/Запись
Started | datetime | Нет | Видимо пользователю | Чтение/Запись
Finished | datetime | Нет | Видимо пользователю | Чтение/Запись
Duration | time | Нет | Видимо пользователю | Только для чтения
Bold | Boolean | Да | Скрыто от пользователя | Только для чтения
RowColor | TRowColor | Нет | Скрыто от пользователя | Только для чтения
Group | TAsyncTask | Нет | Видимо пользователю | Только для чтения
GroupContentReady | Boolean | Да | Скрыто от пользователя | Только для чтения
Format | TExcelOutputFormat | Да | Видимо пользователю | Чтение/Запись | Формат
ColorMode | TOutputColorMode | Да | Видимо пользователю | Чтение/Запись | Режим цветопередачи
EmbedFonts | Boolean | Да | Видимо пользователю | Чтение/Запись | Внедрять шрифты

2. Конструктор Create (Конструктор задачи отложенного выполнения отчетов Excel)

Конструктор класса TExcelAsyncTask.

1constructor TExcelAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TExcelOutputFormat;
5  ColorMode: TOutputColorMode; EmbedFonts: Boolean): TObject;

Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Routine | TRoutine | Да | Унаследовано от TAsyncTask.Create
Object | TObject | Нет
FormView | TFormView | Нет
Handler | TAsyncHandler | Да
Language | TLanguage | Да
Format | TExcelOutputFormat | Да | Формат
ColorMode | TOutputColorMode | Да | Режим цветопередачи
EmbedFonts | Boolean | Да | Внедрять шрифты

Замечания:

Создает новый объект класса TExcelAsyncTask.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IBlobInfo (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IBlobInfo

Интерфейс ITypeInfoИнтерфейс INamedItemInfo

1type
2  IBlobInfo = interface(ITypeInfo)
3    ['{3905C9C4-EAEB-4844-BB55-3F524F1F3FAC}']
4    function Get_SubType: TBlobSubType; safecall;
5    property SubType: TBlobSubType read Get_SubType;
6  end;

1. Свойства

Свойства интерфейса IBlobInfo:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Required | WordBool | Только для чтения | Унаследовано от ITypeInfo
SimpleType | TSimpleType | Только для чтения
SubType | TBlobSubType | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IEnumerationItem (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IEnumerationItem

Интерфейс INamedItemInfo

1type
2  IEnumerationItem = interface(INamedItemInfo)
3    ['{6953507C-D477-4B8D-9443-A9E5FE7137ED}']
4    function Get_Position: Integer; safecall;
5    property Position: Integer read Get_Position;
6  end;

1. Свойства

Свойства интерфейса IEnumerationItem:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Position | Integer | Только для чтения |


Мельница данных ((раздел целиком))

Мельница данных- Класс TCommandButton (Командные кнопки) (раздел целиком) (22.10.2024) (одним файлом)
Класс TCommandButton (Командные кнопки)

Диаграмма Класс TCustomButton (Кнопки)Класс TObject (Объекты)Класс TRoutine (Подпрограмма)

1. Свойства

Свойства класса TCommandButton:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TRoutine | Да | Видимо пользователю | Только для чтения | Мастер
MasterClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс подпрограммы
MasterMaster | TObject | Да | Скрыто от пользователя | Только для чтения | Мастер подпрограммы
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Tab | string[128] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TCustomButton
Group | string[128] | Нет | Видимо пользователю | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
OutOfTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Переопределена
Parameter | TParameter | Нет | Видимо пользователю | Чтение/Запись | Связанный параметр

2. Конструктор Create (Конструктор командной кнопки)

Конструктор класса TCommandButton.

1constructor TCommandButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean; Parameter: TParameter): TObject;

Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция
Group | string[128] | Нет | Унаследовано от TCustomButton.Create
Tab | string[128] | Нет
Script | clob | Нет
Scope | TScope | Да
OutOfTabs | Boolean | Да
Parameter | TParameter | Нет | Связанный параметр

Замечания:

Создает новый объект класса TCommandButton.

3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TCommandButton.

class function TCommandButton.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.

4. Метод GetOverride (Переопределена)

Метод экземпляра класса TCommandButton.

function TCommandButton.GetOverride: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Мельница данных ((раздел целиком))

Мельница данных- Класс TVisualGroupItem (Элемент визуальной группы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TVisualGroupItem (Элемент визуальной группы)

Диаграмма Класс TObject (Объекты)Класс TVisualGroup (Визуальные группы)

1. Свойства

Свойства класса TVisualGroupItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Comment | clob | Нет | Видимо пользователю | Чтение/Запись | Комментарий

2. Конструктор Create (Конструктор элемента визуальной группы)

Конструктор класса TVisualGroupItem.

1constructor TVisualGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция
Comment | clob | Нет | Комментарий

Замечания:

Создает новый объект класса TVisualGroupItem.

3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroupItem.

class function TVisualGroupItem.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IScannerTools (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IScannerTools

1type
2  IScannerTools = interface(IDispatch)
3    ['{FC1B3C9F-7DE9-4909-B57D-6D33E3B0A87A}']
4    function AcquireImage(Silent: WordBool): IDispatch; safecall;
5    function AcquirePDF: IDispatch; safecall;
6  end;

1. Метод AcquireImage

Метод интерфейса IScannerTools.

function IScannerTools.AcquireImage(Silent: WordBool): IDispatch;

Параметры:

Имя | Тип | Обязательно | Значение
Silent | WordBool | Да |

Замечания:

Возвращает значение типа IDispatch.

2. Метод AcquirePDF

Метод интерфейса IScannerTools.

function IScannerTools.AcquirePDF: IDispatch;

Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.


Мельница данных ((раздел целиком))

Мельница данных- Класс TRole (Роли) (раздел целиком) (22.10.2024) (одним файлом)
Класс TRole (Роли)

Диаграмма Класс TSecurityAccount (Роли безопасности)Класс TObject (Объекты)Класс TRoleMember (Пользователи в ролях)

1. Свойства

Свойства класса TRole:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
IsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Является текущей

2. Конструктор Create (Конструктор роли)

Конструктор класса TRole.

1constructor TRole.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TRole.

3. Метод GetIsCurrent (Является текущей)

Метод экземпляра класса TRole.

function TRole.GetIsCurrent: Boolean;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Мельница данных ((раздел целиком))

Мельница данных- Класс TUser (Пользователи) (раздел целиком) (22.10.2024) (одним файлом)
Класс TUser (Пользователи)

Диаграмма Класс TSecurityAccount (Роли безопасности)Класс TObject (Объекты)Класс TInstantMessage (Сообщения)Класс TInstantContact (Контакты)Класс TInstantMessageAttachment (Сообщения с вложением)

1. Свойства

Свойства класса TUser:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
IsCurrent | Boolean | Да | Видимо пользователю | Только для чтения | Является текущим
AccessMode | TUserAccessMode | Да | Видимо пользователю | Чтение/Запись | Режим доступа
CanRecieveMessages | Boolean | Да | Видимо пользователю | Чтение/Запись | Получает сообщения

2. Конструктор Create (Конструктор пользователя)

Конструктор класса TUser.

1constructor TUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CanRecieveMessages: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
CanRecieveMessages | Boolean | Да | Получает сообщения

Замечания:

Создает новый объект класса TUser.

3. Метод EffectiveMemberOf (Является эффективным членом)

Метод экземпляра класса TUser.

function TUser.EffectiveMemberOf(Role: TRole): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Role | TRole | Да | Роль

Замечания:

Возвращает значение типа Boolean.

4. Метод GetCurrentUser (Получить текущего пользователя)

Метод класса (статический метод) класса TUser.

class function TUser.GetCurrentUser: TUser;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TUser.

5. Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TUser.

function TUser.GetIsCurrent: Boolean;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IApplication (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IApplication

01type
02  IApplication = interface(IDispatch)
03    ['{0E59D500-7A6A-43CA-8007-B7BB7E393CD4}']
04    procedure Execute(const Provider: IUnknown; const Query: OleVariant); safecall;
05    function Get_Visible: WordBool; safecall;
06    procedure Set_Visible(Value: WordBool); safecall;
07    procedure ExecuteTemplate(const Provider: IUnknown; const Query: OleVariant;
08      const TemplateName: WideString); safecall;
09    property Visible: WordBool read Get_Visible write Set_Visible;
10  end;

1. Свойства

Свойства интерфейса IApplication:

Имя | Тип | Доступ | Назначение
Visible | WordBool | Чтение/Запись |

2. Метод Execute

Метод интерфейса IApplication.

1procedure IApplication.Execute(const Provider: IUnknown;
2  const Query: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Provider | IUnknown | Да |
Query | OleVariant | Да |

3. Метод ExecuteTemplate

Метод интерфейса IApplication.

1procedure IApplication.ExecuteTemplate(const Provider: IUnknown;
2  const Query: OleVariant; const TemplateName: WideString);

Параметры:

Имя | Тип | Обязательно | Значение
Provider | IUnknown | Да |
Query | OleVariant | Да |
TemplateName | WideString | Да |


Мельница данных ((раздел целиком))

Мельница данных- Класс TEnumerationItem (Элементы перечислений) (раздел целиком) (22.10.2024) (одним файлом)
Класс TEnumerationItem (Элементы перечислений)

Диаграмма Класс TObject (Объекты)Класс TEnumerationDomain (Перечисления)

1. Свойства

Свойства класса TEnumerationItem:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения | Количество зависимостей

2. Конструктор Create (Конструктор элемента перечисления)

Конструктор класса TEnumerationItem.

1constructor TEnumerationItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция

Замечания:

Создает новый объект класса TEnumerationItem.

3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TEnumerationItem.

class function TEnumerationItem.GetNextPos(Master: TObject): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер

Замечания:

Возвращает значение типа Integer.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс IPDFDocument (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс IPDFDocument

01type
02  IPDFDocument = interface(IDispatch)
03    ['{E57FFE9D-6B85-45E6-A5D0-9DD17950A666}']
04    procedure Save(Target: OleVariant); safecall;
05    function CreatePage(Parent: OleVariant): IPDFPage; safecall;
06    function Get_Title: WideString; safecall;
07    procedure Set_Title(Value: WideString); safecall;
08    function Get_CanEmbedFonts: WordBool; safecall;
09    procedure Set_CanEmbedFonts(Value: WordBool); safecall;
10    function Get_CanCompress: WordBool; safecall;
11    procedure Set_CanCompress(Value: WordBool); safecall;
12    function Get_Author: WideString; safecall;
13    procedure Set_Author(Value: WideString); safecall;
14    function Get_Subject: WideString; safecall;
15    procedure Set_Subject(Value: WideString); safecall;
16    function Get_Keywords: WideString; safecall;
17    procedure Set_Keywords(Value: WideString); safecall;
18    function Get_Creator: WideString; safecall;
19    procedure Set_Creator(Value: WideString); safecall;
20    function Get_Pages(Index: Integer): IPDFPage; safecall;
21    function Get_PageCount: Integer; safecall;
22    procedure Close; safecall;
23    procedure Serialize(const Stream: IUnknown); safecall;
24    function Get_MinCompressSize: Integer; safecall;
25    procedure Set_MinCompressSize(Value: Integer); safecall;
26    function Get_MaxCompressSize: Integer; safecall;
27    procedure Set_MaxCompressSize(Value: Integer); safecall;
28    function CreatePageFromImage(Image: OleVariant; PageWidth: Double;
29      PageHeight: Double; Margin: Double): WordBool; safecall;
30    procedure SaveToXML(Target: OleVariant); safecall;
31    property Title: WideString read Get_Title write Set_Title;
32    property CanEmbedFonts: WordBool read Get_CanEmbedFonts write Set_CanEmbedFonts;
33    property CanCompress: WordBool read Get_CanCompress write Set_CanCompress;
34    property Author: WideString read Get_Author write Set_Author;
35    property Subject: WideString read Get_Subject write Set_Subject;
36    property Keywords: WideString read Get_Keywords write Set_Keywords;
37    property Creator: WideString read Get_Creator write Set_Creator;
38    property Pages[Index: Integer]: IPDFPage read Get_Pages;
39    property PageCount: Integer read Get_PageCount;
40    property MinCompressSize: Integer read Get_MinCompressSize
41      write Set_MinCompressSize;
42    property MaxCompressSize: Integer read Get_MaxCompressSize
43      write Set_MaxCompressSize;
44  end;

1. Свойства

Свойства интерфейса IPDFDocument:

Имя | Тип | Доступ | Назначение
Author | WideString | Чтение/Запись |
CanCompress | WordBool | Чтение/Запись |
CanEmbedFonts | WordBool | Чтение/Запись |
Creator | WideString | Чтение/Запись |
Keywords | WideString | Чтение/Запись |
MaxCompressSize | Integer | Чтение/Запись |
MinCompressSize | Integer | Чтение/Запись |
PageCount | Integer | Только для чтения |
Pages[Index: Integer] | IPDFPage | Только для чтения |
Subject | WideString | Чтение/Запись |
Title | WideString | Чтение/Запись |

2. Метод Close

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Close;

Метод не имеет параметров.

3. Метод CreatePage

Метод интерфейса IPDFDocument.

function IPDFDocument.CreatePage(Parent: OleVariant): IPDFPage;

Параметры:

Имя | Тип | Обязательно | Значение
Parent | OleVariant | Да |

Замечания:

Возвращает значение типа IPDFPage.

4. Метод CreatePageFromImage

Метод интерфейса IPDFDocument.

1function IPDFDocument.CreatePageFromImage(Image: OleVariant; PageWidth: Double;
2  PageHeight: Double; Margin: Double): WordBool;

Параметры:

Имя | Тип | Обязательно | Значение
Image | OleVariant | Да |
PageWidth | Double | Да |
PageHeight | Double | Да |
Margin | Double | Да |

Замечания:

Возвращает значение типа WordBool.

5. Метод Save

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Save(Target: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Target | OleVariant | Да |

6. Метод SaveToXML

Метод интерфейса IPDFDocument.

procedure IPDFDocument.SaveToXML(Target: OleVariant);

Параметры:

Имя | Тип | Обязательно | Значение
Target | OleVariant | Да |

7. Метод Serialize

Метод интерфейса IPDFDocument.

procedure IPDFDocument.Serialize(const Stream: IUnknown);

Параметры:

Имя | Тип | Обязательно | Значение
Stream | IUnknown | Да |


Мельница данных ((раздел целиком))

Мельница данных- Выражения и операции (раздел целиком) (22.10.2024) (одним файлом)
Выражения и операции

1. Состав выражения
Любое выражение имеет тип. Выражения состоят из следующих элементов:
  • Целая числовая константа (0 3 234);
  • Вещественная числовая константа. Дробная часть отделяется от целой точкой (".") (3.14 2.71);
  • Строковая константа. Заключается в апострофы. ('Some string' '10', '01.01.2006' 'now');
  • Логическая константа (True False);
  • Безтиповая (любого типа) константа nil;
  • Зарезервированное слово Self. Обозначает разный объект в зависимости от контекста:
    • В методах класса кроме конструктора - использование запрещено.
    • В методах экземпляра - всегда экземпляр, для которого вызван метод.
    • В конструкторе - до вызова унаследованного метода значение не определено. После вызова - ссылка на сконструированный объект.
    • В выражениях условий отбора - объект, для которого принимается решение о его вхождении в отбор.
  • Квалификатор.
  • Агрегат.

2. Квалификатор

Квалификатор обозначает объект, переменную, параметр, свойство, поле, вызов функции. Квалификатор состоит из идентификаторов, разделенных точкой.

Result
AName
Caption
LObject.Name
LObject.Parent.Name
LObject.ChildCount
LObject.HasAsParent(LOtherObject)

При интерпретации квалификатора используется следующий порядок разбора идентификатора:

  1. Контекстная переменная (для выражений условий отбора доменов)
  2. Локальная переменная
  3. Параметр
  4. Имя элемента перечисления
  5. Имя класса. Вне контекста означает ссылку на соответствующий объект класса TClass
  6. Имя поля
  7. Имя метода
  8. Имя свойства

При интерпретации квалификатора внутри выражения агрегата правила разбора идентификатора изменяются:

  1. Контекстная переменная (для выражений условий отбора доменов)
  2. Имя элемента перечисления
  3. Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту
  4. Имя поля
  5. Имя метода
  6. Имя свойства
  7. Локальная переменная
  8. Параметр

3. Агрегат

Агрегат определяет агрегированное значение над экземплярами определенного класса, удовлетворяющими условиям агрегации. Агрегаты бывают следующих типов:

  • any - первый попавшийся объект. Результат имеет тип ссылки на объект агрегируемого класса.
    1any(TObject with Master = Self.Parent)
2//первый попавшийся объект, имеющий значение
3//свойства Master равным значению свойства
4//Parent текущего (контекстного) объекта.
  • count - количество объектов. Результат имеет целочисленный тип.
    1count(TObject with Master = Self.Parent)
2//количество объектов, имеющих значение свойства
3//Master равным значению свойства Parent
4//текущего объекта.
  • sum - сумма значений свойства, поля или функции объектов. Результат имеет тип суммируемого поля, свойства или функции
    1sum(TExam.Mark with Master = LStudent) //сумма
2//баллов студента по его испытаниям
  • max, min - соответственно максимальное и минимальное значений свойства, поля или функции объектов. Результат имеет тип агрегируемого поля, свойства или функции
    1min(TObject.Created) // момент создания первого
2//объекта Системы.

Внутри выражения агрегата правила разбора идентификатора изменяются на следующие:

  1. Контекстная переменная (для выражений условий отбора доменов)
  2. Имя элемента перечисления
  3. Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту
  4. Имя поля
  5. Имя метода
  6. Имя свойства
  7. Локальная переменная
  8. Параметр

4. Операции

Операции связывают элементы выражений.

Таблица операций в порядке приоритета:
Левый операнд | Правый операнд
 | Целый | Вещест- венный | Дата | Время | Дата со временем | Логи- ческий | Строковый | Объект | nil
not
Нет | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
* (звездочка)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
/ (слэш, дробь)
Целый | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
div
Целый | Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
and
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
or
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
+ (плюс)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Дата | Дата со временем | Запрещено | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Время | Время | Дата со временем | Время | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Дата со временем | Дата со временем | Запрещено | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Строковый | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
- (минус)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Дата | Дата со временем | Целый | Дата со временем | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено
Время | Время | Время | Дата со временем | Время | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Дата со временем | Дата со временем | Вещест- венный | Дата со временем | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
=, <> (равно, не равно)
Целый | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Вещест- венный | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Дата | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Логи- ческий
Время | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Дата со временем | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Логи- ческий
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Логи- ческий
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Логи- ческий
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
<, >, <=, >= (меньше, больше, меньше либо равно, больше либо равно)
Целый | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
is
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
as
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Объект | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено

4.1. Особенности применения операций
  1. Приоритет сравнений ниже приоритета операций булевой логики. Поэтому выражение
    LObject.Master = LMaster and LObject.Parent = LParent
    будет интерпретироваться следующим образом:
    LObject.Master = (LMaster  and LObject.Parent) = LParent
    и вызовет ошибку компиляции из-за применения операции and к объектам. Необходимо писать:
    (LObject.Master = LMaster) and (LObject.Parent = LParent)
  2. Любое значение (выражение любого типа) сравнивается с безтиповой константой nil:
    1      LObject := any(TObject with Name = 'Some name');
2      if LObject = nil then
3         .....
  3. Операции "Унарный минус" не существует. Для задания отрицательных констант пользуйтесь конструкцией 0-Значение:
    Result := 0-1;


Мельница данных ((раздел целиком))

Мельница данных- Класс TAction (Действия) (раздел целиком) (22.10.2024) (одним файлом)
Класс TAction (Действия)

Класс TObject (Объекты)Класс TCustomView (Абстрактное представление)Класс TActionContextProperty (Свойство контекста)

Объекты класса образуют иерархию.

1. Свойства

Свойства класса TAction:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Shortcut | string[20] | Нет | Видимо пользователю | Чтение/Запись | Горячая клавиша
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция
Separated | Boolean | Да | Видимо пользователю | Чтение/Запись | Отделено
Default | Boolean | Да | Видимо пользователю | Чтение/Запись | По умолчанию

2. Конструктор Create (Конструктор действия)

Конструктор класса TAction.

1constructor TAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean;
4  Default: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция
Shortcut | string[20] | Нет | Горячая клавиша
Separated | Boolean | Да | Отделено
Default | Boolean | Да | По умолчанию

Замечания:

Создает новый объект класса TAction.

3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TAction.

1class function TAction.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Нет | Мастер
Parent | TObject | Нет | Родитель
Step | Integer | Да | Шаг

Замечания:

Возвращает значение типа Integer.


Мельница данных ((раздел целиком))

Мельница данных- Класс TRoutineAction (Программируемое действие) (раздел целиком) (22.10.2024) (одним файлом)
Класс TRoutineAction (Программируемое действие)

Класс TAction (Действия)Класс TObject (Объекты)Класс TCustomView (Абстрактное представление)

Объекты класса образуют иерархию.

1. Свойства

Свойства класса TRoutineAction:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Shortcut | string[20] | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TAction
Position | Integer | Да | Видимо пользователю | Чтение/Запись
Separated | Boolean | Да | Видимо пользователю | Чтение/Запись
Default | Boolean | Да | Видимо пользователю | Чтение/Запись
Routine | TRoutine | Да | Видимо пользователю | Чтение/Запись | Подпрограмма
ContextProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Выполнять в контексте свойства
AllowNavigation | Boolean | Да | Видимо пользователю | Чтение/Запись | Доступна навигация

2. Конструктор Create (Конструктор программируемого действия)

Конструктор класса TRoutineAction.

1constructor TRoutineAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  Routine: TRoutine; ContextProperty: TProperty;
5  AllowNavigation: Boolean): TObject;

Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Унаследовано от TAction.Create
Shortcut | string[20] | Нет
Separated | Boolean | Да
Default | Boolean | Да
Routine | TRoutine | Да | Реализовано посредством
ContextProperty | TProperty | Нет | выполнять в контексте
AllowNavigation | Boolean | Да | Доступна навигация

Замечания:

Создает новый объект класса TRoutineAction.

3. Метод EnsureAction (Обеспечить наличие действия)

Метод класса (статический метод) класса TRoutineAction.

1class function TRoutineAction.EnsureAction(AView: TObject; AName: string[64];
2  ADescription: string[128]; APosition: Integer; AShortcut: string[20];
3  ASeparated: Boolean; ARoutine: TRoutine): TObject;

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
AView | TObject | Да | Мастер
AName | string[64] | Да | Имя
ADescription | string[128] | Да | Наименование
APosition | Integer | Да | Позиция
AShortcut | string[20] | Нет | Горячая клавиша
ASeparated | Boolean | Да | Отделено
ARoutine | TRoutine | Да | Реализовано посредством

Замечания:

Возвращает значение типа TObject.


Мельница данных ((раздел целиком))

Мельница данных- Работа с Инспектором объектов (раздел целиком) (22.10.2024) (одним файлом)
Работа с Инспектором объектов

1. Отображение свойств Инспектором объектов

Инспектор объектов предназначен для просмотра и редактирования свойств одного или нескольких объектов, выбранных в активной таблице данных. Инспектор объектов имеет две колонки. В левой колонке отображаются наименования свойств, в правой колонке отображаются значения свойств. Набор отображаемых свойств и их значений зависит от того, сколько объектов каких типов выбрано в текущей таблице данных (подробнее о выборе объектов см. раздел 4.3. "Выбор объектов в таблице данных"). Свойства выбранных объектов отображаются Инспектором объектов по следующим правилам:

  1. Если в таблице данных выбран один объект, то в Инспекторе объектов отображаются все свойства этого объекта, видимые пользователю.
  2. Если в таблице данных выбрано несколько объектов, то
    • Инспектор объектов будет иметь строки, соответствующие только тем свойствам, которые есть у всех выделенных объектов;
    • если у всех выделенных объектов значение свойства одинаково, то это значение будет отображено в правой колонке; в противном случае в правой колонке будет отображено пустое значение.
  3. При изменении значения свойства в Инспекторе объектов новое значение будет установлено для всех выделенных объектов.

Выбран один объект - вид на инспектор объектов
Выбран один объект - вид на таблицу

На рисунке представлен пример таблицы данных, отображающей учитываемые в системе сорта мороженого. Среди сортов мороженого есть как обычные сорта, так и сорта фруктового мороженого, дополнительно обладающие свойством "Фрукт". В таблице данных выделен один объект, соответствующий сорту фруктового мороженого "Тропический рай". При этом Инспектор объектов отображает все свойства данного объекта (в том числе свойство "Фрукт").

Выбрано несколько объектов - вид на инспектор объектов

Выбрано несколько объектов - вид на таблицу

На рисунке в той же таблице данных выбрано два объекта: сорт мороженого "Тропический рай" (фруктовое мороженое) и сорт "Белый Бим черное ухо" (обычное мороженое). При этом в Инспекторе объектов отображаются только те свойства, которые являются общими для выделенных объектов (свойство "Фрукт" не отображается). Значения свойств "Вид упаковки" и "Вес" для выбранных объектов одинаковы, поэтому их значения отображены в правой колонке Инспектора объектов. Значения остальных свойств для данных объектов различны, поэтому для этих свойств отображаются пустые значения. Если изменить одно из свойств в Инспекторе объектов, то новое значение будет установлено как для сорта мороженого "Тропический рай", так и для сорта мороженого "Белый Бим черное ухо".

Порядок отображения свойств в Инспекторе объектов устанавливается разработчиком прикладной системы. Также разработчиком прикладной системы может быть установлено отнесение свойств к категориям. В этом случае свойства могут отображаться сгруппированными по категориям. Слева от наименования каждой категории будет отображен значок Свернутый узел дерева или Развернутый узел дерева. Нажатием мышью на значок Развернутый узел дерева свойства, входящие в категорию, можно свернуть, нажатием на значок Свернутый узел дерева их можно снова отобразить.

Отображение Инспектором объектов свойств, сгруппированных по категориям

На рисунке представлен пример отображения Инспектором объектов свойств объекта, соответствующего дисциплине учебного плана студентов. Свойства, отнесенные к категориям "Формы текущего контроля" и "Распределение аудиторных часов по модулям", свернуты. Свойства, отнесенные к категории "Учебные часы" раскрыты.

В связи с тем, что выбор свойств объектов для отображения, получение и сравнение их значений происходит по специальному алгоритму, в случае одновременного выбора большого числа объектов скорость работы Инспектора объектов может снижаться. Если на вычисление значения общего свойства группы объектов требуется значительное время, то такое свойство может отображаться как свойство с отложенным вычислением. Для такого свойства в правой колонке вместо значения может отображаться строка (...). При активизации этого свойства справа отобразится кнопка со знаком вопроса Кнопка вычисления отложенного свойства. Если нажать на эту кнопку, то значение свойства будет определено и отображено.

Свойство с отложенным вычислением

2. Управление положением Инспектора объектов на экране и порядком отображения свойств

Инспектор объектов отображается в отдельном окне. Это окно можно перетаскивать по экрану за заголовок, изменять его размеры стандартным для операционной системы Windows образом. На панели инструментов всегда присутствует иконка Инспектора объектов, при нажатии которой можно отобразить окно Инспектора (если оно не видимо) и сделать его активным:
Кнопка инспектора объектов

При нажатии правой кнопки мыши в левом столбце Инспектора объектов или в свободном нижнем поле доступно контекстное меню Инспектора объектов. При помощи действий, расположенных в этом меню можно управлять режимом работы окна Инспектора и порядком отображения свойств.

Контекстное меню инспектора объектов

Выбор одного из пунктов контекстного меню переводит Инспектор объектов в новый режим работы. После этого рядом с пунктом меню отображается галочка Флажок в контекстном меню или точка Радиокнопка в контекстном меню. При повторном выборе помеченного пункта меню соответствующий режим работы отменяется и отметка снимается. Доступные пункты контекстного меню позволяют устанавливать следующие режимы работы Инспектора объектов.

  • При выборе пункта меню Всегда наверху окно Инспектора объектов будет всегда отображаться на переднем плане независимо от переключения между активными таблицами данных.
  • Если выбрать пункт меню Прозрачное окно, то окно Инспектора объектов станет полупрозрачным.
  • Если выбрать пункт меню Показать скрытые свойства, то кроме свойств, отображаемых в обычном режиме (свойства, созданные разработчиком прикладной системы как " видимые ") будут отображены свойства объектов, " невидимые " пользователю.
  • Пункт меню Сортировать по алфавиту позволяет отображать свойства не в порядке, установленном разработчиком прикладной системы, а в алфавитном порядке их наименований. Такой режим работы удобен в случае, если необходимо найти свойство по его наименованию.
  • Пункты подменю Группировка позволяют:
    • Группировать по категории - свойства будут отображены сгруппированными по категориям (показано на рисунке);
    • Группировать по классу - свойства будут отображены сгруппированными по классу объектов, членами которого они являются;
    • Не группировать - свойства будут отображены без группировки.

3. Редактирование значений свойств при помощи Инспектора объектов

При помощи Инспектора объектов удобно изменять значения свойств одного или одновременно нескольких выбранных объектов (о выборе объектов см. раздел 4.3. "Выбор объектов в таблице данных"). Одно из свойств, отображаемых в Инспекторе объектов, всегда является активным. Активное значение выделяется в Инспекторе объектов рамкой, его значение отображается в режиме редактирования.

Отображение свойств в режиме редактирования и способы изменения значений свойств аналогичны редактированию данных в таблице данных (см. раздел 4.11. "Редактирование данных в таблицах"). Отличие работы Инспектора объектов заключается в том, что с его помощью можно изменять значение свойства сразу нескольких выбранных объектов.


Мельница данных ((раздел целиком))

Мельница данных- Класс TProfile (Профили) (раздел целиком) (22.10.2024) (одним файлом)
Класс TProfile (Профили)

Диаграмма Класс TObject (Объекты)Класс TProfileItem (Состав профиля)Класс TProfileUser (Пользователи профиля)

1. Свойства

Свойства класса TProfile:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Domain | TDomain | Да | Видимо пользователю | Чтение/Запись | Домен
DomainRequired | Boolean | Да | Видимо пользователю | Только для чтения | Обязательно для заполнения
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс домена
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения | Определение домена
ComparisonType | TComparisonType | Да | Видимо пользователю | Чтение/Запись | Тип сравнения
BasedOnProfile | TProfile | Нет | Видимо пользователю | Чтение/Запись | Расширяет профиль пользователями
Active | Boolean | Да | Видимо пользователю | Только для чтения | Активен

2. Конструктор Create (Конструктор профиля)

Конструктор класса TProfile.

1constructor TProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType;
4  BasedOnProfile: TProfile): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Domain | TDomain | Да | Домен
ComparisonType | TComparisonType | Да | Тип сравнения
BasedOnProfile | TProfile | Нет | Расширяет профиль пользователями

Замечания:

Создает новый объект класса TProfile.

3. Метод Check (Проверка профиля)

Метод класса (статический метод) класса TProfile.

class procedure TProfile.Check(Object: TObject; ObjectClass: TClass);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Да | Объект
ObjectClass | TClass | Нет | Класс объекта

4. Метод GetIsActive (Активен для текущего пользователя)

Метод экземпляра класса TProfile.

function TProfile.GetIsActive: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5. Метод GetValueDomain (Получить домен значения)

Метод экземпляра класса TProfile.

function TProfile.GetValueDomain: TDomain;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TDomain.

6. Метод Match (Проверка совпадения)

Метод экземпляра класса TProfile.

1function TProfile.Match(Object: TObject; ObjectClass: TClass;
2  ValueGiven: Boolean; StrValue: string[2000]; IntValue: Integer;
3  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
4  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
5  ExternalDataValue: <external data>): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Да | Объект
ObjectClass | TClass | Нет | Класс объекта
ValueGiven | Boolean | Да | Значение задано
StrValue | string[2000] | Нет | Строковое значение
IntValue | Integer | Нет | Целое значение
FloatValue | float | Нет | Вещественное значение
DateValue | date | Нет | Значение даты
TimeValue | time | Нет | Значение времени
DateTimeValue | datetime | Нет | Значение даты со временем
ObjectValue | TObject | Нет | Значение-объект
BoolValue | Boolean | Нет | Логическое значение
BlobValue | blob | Нет | Значение-большой объект
ClobValue | clob | Нет | Значение-текст
ExternalDataValue | <external data> | Нет | Значение-внешние данные

Замечания:

Возвращает значение типа Boolean.

7. Метод MatchObject (Проверка совпадения объекта)

Метод экземпляра класса TProfile.

function TProfile.MatchObject(Object: TObject; ObjectClass: TClass): Boolean;

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Да | Объект
ObjectClass | TClass | Нет | Класс объекта

Замечания:

Возвращает значение типа Boolean.

8. Метод TryCheck (Проверка профиля с возвратом результата)

Метод класса (статический метод) класса TProfile.

class function TProfile.TryCheck(Object: TObject; ObjectClass: TClass): Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Object | TObject | Да | Объект
ObjectClass | TClass | Нет | Класс объекта

Замечания:

Возвращает значение типа Boolean.


Мельница данных ((раздел целиком))

Мельница данных- Класс TAsyncTask (Задачи отложенного выполнения) (раздел целиком) (22.10.2024) (одним файлом)
Класс TAsyncTask (Задачи отложенного выполнения)

Класс TObject (Объекты)Класс TAsyncTaskParameterValue (Значения параметров задачи отложенного выполнения)

Объекты класса не именованы.

1. Свойства

Свойства класса TAsyncTask:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
Created | datetime | Да | Видимо пользователю | Только для чтения | Время создания
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Status | TAsyncTaskStatus | Да | Видимо пользователю | Чтение/Запись | Состояние
Routine | TRoutine | Да | Видимо пользователю | Чтение/Запись | Подпрограмма
RoutineClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс подпрограммы
Language | TLanguage | Да | Видимо пользователю | Чтение/Запись | Язык
Handler | TAsyncHandler | Да | Видимо пользователю | Чтение/Запись | Обработчик
FormView | TFormView | Нет | Видимо пользователю | Чтение/Запись | Представление формы
Object | TObject | Нет | Видимо пользователю | Чтение/Запись | Объект
Started | datetime | Нет | Видимо пользователю | Чтение/Запись | Время начала выполнения
Finished | datetime | Нет | Видимо пользователю | Чтение/Запись | Время завершения выполнения
Duration | time | Нет | Видимо пользователю | Только для чтения | Длительность
Bold | Boolean | Да | Скрыто от пользователя | Только для чтения | Выделено
RowColor | TRowColor | Нет | Скрыто от пользователя | Только для чтения | Цвет строки
Group | TAsyncTask | Нет | Видимо пользователю | Только для чтения | Группа
GroupContentReady | Boolean | Да | Скрыто от пользователя | Только для чтения | Содержимое группы готово

2. Конструктор Create (Конструктор задачи отложенного выполнения)

Конструктор класса TAsyncTask.

1constructor TAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Routine | TRoutine | Да | Подпрограмма
Object | TObject | Нет | Объект
FormView | TFormView | Нет | Представление формы
Handler | TAsyncHandler | Да | Обработчик
Language | TLanguage | Да | Язык

Замечания:

Создает новый объект класса TAsyncTask.

3. Деструктор Destroy (Деструктор объекта)

Деструктор класса TAsyncTask.

destructor TAsyncTask.Destroy;

Переопределяет метод в TObject.Destroy.

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TAsyncTask или его наследника.

4. Метод Archive (Отправить в архив)

Метод экземпляра класса TAsyncTask.

procedure TAsyncTask.Archive;

Метод не имеет параметров.

5. Метод CreateGroup (Создать группу)

Метод экземпляра класса TAsyncTask.

procedure TAsyncTask.CreateGroup(Group: clob);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Group | clob | Нет | Группа

6. Метод Finish (Зафиксировать завершение выполнения)

Метод экземпляра класса TAsyncTask.

procedure TAsyncTask.Finish(Success: Boolean);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Success | Boolean | Да | Выполнено успешно

7. Метод HandleInstantMessage (Обработчик с уведомлением сообщением)

Метод экземпляра класса TAsyncTask.

1procedure TAsyncTask.HandleInstantMessage(Success: Boolean;
2  ErrorMessage: string[2000]; ExceptionClass: string[2000];
3  NativeMessage: string[2000]);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Success | Boolean | Да | Выполнено успешно
ErrorMessage | string[2000] | Нет | Сообщение об ошибке
ExceptionClass | string[2000] | Нет | Класс ошибки
NativeMessage | string[2000] | Нет | Системное сообщение об ошибке

8. Метод HasAsyncTasks (Имеются задачи отложенного выполнения)

Метод класса (статический метод) класса TAsyncTask.

class function TAsyncTask.HasAsyncTasks: Boolean;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

9. Метод Start (Зафиксировать начало выполнения)

Метод экземпляра класса TAsyncTask.

procedure TAsyncTask.Start;

Метод скрыт от пользователя.

Метод не имеет параметров.

10. Метод Ole-объекта PerformImmediate (Выполнить немедленно)

Метод Ole-объекта класса TAsyncTask.

Метод Ole-объекта не имеет параметров.


Мельница данных ((раздел целиком))

Мельница данных- Язык PascalScript (раздел целиком) (22.10.2024) (одним файлом)
Язык PascalScript

На языке PascalScript на платформе "Мельница данных" описываются тела методов и выражения. Выражения используются в условиях отбора объектов определенного класса при их отображении в представлениях, а также как встраиваемые выражения, которые могут служить членами класса для чтения свойств.

Здесь и далее зарезервированные слова выделены жирным шрифтом.

1. Структура программного блока тела метода
1  [Описание переменных]
2  begin
3    //Операторы
  end;

Комментарии расположены между символами { и } либо от символов // до конца строки.

2. Описание переменных
1var
2    Имя переменной[, Имя переменной…]: Тип;
3    Имя переменной[, Имя переменной…]: Тип;
4    ...
Имя переменной должно быть идентификатором (последовательность символов a-z, A-Z, 0-9, _). "Тип" может быть одним из следующих:
  • integer - определяет переменные целочисленного типа;
  • string[целое_число] - определяет переменные строкового типа с заданной максимальной длиной; максимальная длина задается в квадратных скобках и обязательна для задания;
  • float - определяет переменные вещественного типа;
  • date - определяет переменные типа "дата";
  • time - определяет переменные типа "время";
  • datetime - определяет переменные типа "дата со временем";
  • boolean - определяет переменные логического типа;
  • blob - определяет переменные типа больших двоичных объектов;
  • Имя класса - определяет переменные-ссылки на экземпляры соответствующих классов;
1  var
2   I: integer;
3   LSomeObject: TObject;
4   LStart, LStop: datetime;
   LNewName: string[64];

3. Операторы PascalScript

Операторы разделяются точкой с запятой (;). Операторы могут быть одним из следующих:

3.1. Составной оператор
1begin
2  //Другие операторы
end
Операторы, размещенные внутри составного оператора, разделяются точкой с запятой. Никаких ограничений на состав операторов и количество уровней вложенности не накладывается.
1begin
2  Result := LCurrentValue;
3  Exit;
4end;

3.2. Оператор присваивания
Выражение1 := Выражение2

Присваивает значение выражения Выражение2 выражению Выражение1. Типы Выражения1 и Выражения2 должны быть совместимы (совпадать по классу домена либо оба быть числовыми). Для этого на Выражение1 (стоящее слева от знака равенства, lvalue) накладывается ряд ограничений. Это выражение должно быть:

  • Полем или свойством экземпляра класса
  • Локальной переменной
  • Параметром
  • Зарезервированной переменной Result
LObject.Name := 'Новое имя';
Result := 25;
LStartTime := StrToDateTime('01.01.2006 00:00:30');
01var
02  LObject: TObject;
03  LClass: TClass;
04  I: Integer;
05  F: Float;
06begin
07  I := F;  //неверно
08  F := I;  //верно
09  LObject := LClass; //верно
10  LClass := LObject; //неверно. Должно быть LClass := (LObject as TClass);
11end;

3.3. Оператор вызова
ИмяПроцедуры [(Параметр1, Параметр2 ...)]

"ИмяПроцедуры" должно быть:

  • Именем метода класса и вызываться с указанием класса либо экземпляра;
  • Именем метода экземпляра и вызываться с указанием экземпляра;
  • Именем метода своего класса либо предка и вызываться без указания спецификаторов.
Порядок и количество параметров в операторе вызова должны строго совпадать с описанием метода.

1  //метод класса, указан класс
2  LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3
4  //метод экземпляра, указан экземпляр. Метод не имеет параметров.
5  LList.Destroy;
6
7  //свой либо унаследованный метод
8  BuildDefaultActions(Name, True);

3.4. Оператор ветвления
1if Выражение then
2  //Оператор1
3[else
4  //Оператор2]

Выражение должно быть логического типа. В случае если значение Выражения истинно, выполняется Оператор1. Часть else является необязательной и относится к последнему оператору if, не имеющему таковой. В случае ее наличия Оператор2 выполняется, если значение Выражения ложно.

1if LIndex > 25 then
2  raise 'Индекс слишком большой.';

1if LMonth = 'январь' then
2  January
3else if LMonth = 'февраль' then
4  February
5else
6  OtherMonth;  //обратите внимание на точки с запятой.

3.5. Оператор выбора
1case Выражение of
2  Значение1: //Оператор1
3  Значение2: //Оператор2
4  ...
5[else
6  //Оператор ]
end

Заменяет каскад операторов if. Значение Выражения должно быть числового типа. Часть else выполняется в случае, если Выражение не равно ни одному из перечисленных вариантов. Эта часть не является обязательной.

1сase LIndex of
2  0: ZeroIndex;
3  1,2,3: SmallIndex;
4  4,5,6,7,8,9,10: BigIndex;
5else
6  raise 'Слишком большой или отрицательный индекс.';
7end;

3.6. Цикл с предусловием
1while Выражение do
2  //Оператор

Оператор выполняется до тех пор, пока значение Выражения истинно. Выражение должно быть логического типа. Если при входе в цикл Выражение не истинно, то тело цикла не будет выполнено ни одного раза.

01while LList.Count > 0 do
02  LList.GetItem(0).Destroy;
03
04while True do
05begin
06  LValue := LValue.NextValue;
07  if LValue.Value > 10 then
08  begin
09    Result := LValue.Value;
10    exit;
11  end;
12end;

3.7. Цикл с постусловием
1repeat
2  //Операторы
3until Выражение

Операторы выполняются до тех пор, пока значение Выражения ложно. Выражение должно быть логического типа. Обратите внимание, что внутри себя оператор может содержать несколько операторов, разделенных точкой с запятой. Тело цикла обязательно будет выполнено хотя бы один раз.

1repeat
2  Result := Result + 1;
3  LObject := LObject.Parent;
4until LObject = nil;

3.8. Цикл с параметром
1for Параметр := Выражение1 (to|downto) Выражение2 do
2  //Оператор

Параметр цикла обязан быть простой локальной переменной. Функционально цикл с параметром эквивалентен циклам:

  • Для формы to
    1Параметр := Выражение1;
2while Параметр <= Выражение2 dobegin
3  Оператор;
4  Параметр :=  Параметр + 1;
end;
  • Для формы downto
    1Параметр := Выражение1;
2while Параметр >= Выражение2 dobegin
3  Оператор;
4  Параметр :=  Параметр - 1;
end;
Если Выражение1 равно Выражению2, тело цикла будет выполнено один раз.

1for I := LList.Length - 1 downto 0 do
2// если LList.Length = 0, тело цикла ни разу не будет выполнено.
3begin
4  LClass := LList.GetItem(I);
5  LMethod := any(TMethod with (Name = LName) and (Master = LClass));
6  LParamList.Add(any(TMethod with (Name = LName) and (Master = LClass)));
7end;

3.9. Цикл по экземплярам
1for each Параметр of ИмяКласса [with Выражение]
2  [by [-] Выражение [, [-] Выражение]] do
3    //Оператор

Цикл осуществляется по выборке среди экземпляров класса ИмяКласса, для которых истинно Выражение. Если Выражение не задано, то по всем экземплярам. Ссылка на текущий в рамках цикла экземпляр присваивается в локальную переменную Параметр. Выражение должно определяться относительно переменной Параметр. Выраженния, следующие за ключевым словом by, определяют порядок обхода экземпляров. Знак "-" перед выражением (любого типа) определяет обратный порядок обхода.

1for each LOption of TOption with LOption.Domain.Required do
2    // для каждой настройки, домен которой обязателен
3  LOption.SetDefaultValue;

3.10. Оператор прекращения цикла
break

Происходит немедленный выход из цикла. Выполняется финализация операторов защиты завершения, которыми защищено тело цикла. Допустим только в теле цикла с предусловием, цикла с постусловием, цикла с параметром или цикла по экземплярам.

3.11. Оператор выхода из подпрограммы
exit

Происходит немедленный выход из программного блока. Выполняется финализация операторов защиты завершения.

3.12. Оператор защиты завершения
1try
2  //Операторы1
3finally
4  //Операторы2
end

Выполняются операторы Операторы1, разделенные точкой с запятой. В случае возникновения исключительной ситуации управление сразу передается на Операторы2, и после их выполнения исключение остается активным. Если исключения не произошло, выполняются Операторы2. Если среди Операторов1 встречается оператор exit, то Операторы2 все равно выполняются.

1//создание временного объекта-списка
2LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3try
4  LList.Add(LValue);
5  Exit;
6finally
7  //гарантированное уничтожение созданного объекта независимо от исключений.
8  LList.Destroy;
9end;

3.13. Оператор обработки исключительных ситуаций
1try
2  //Операторы1
3except
4  //Операторы2
end

Выполняются операторы Операторы1. В случае возникновения исключительной ситуации управление передается на Операторы2. Если исключительных ситуаций не возникло, Операторы2 не выполняются никогда. При передаче управления на Операторы2 исключительная ситуация деактивирована. Для ее повторного возбуждения можно воспользоваться оператором возбуждения исключения без указания текстовой строки сообщения.

1try
2  LObject.NeverTouch := True;
3  LObject.ExecuteCoolMethod; //если метод выполнен неудачно
4except
5  LObject.NeverTouch := True;  //установить флаг и ничего не сообщать пользователю.
6end;

1try
2   LObject.ExecuteCoolMethod; //если метод выполнен неудачно
3except
4   LObject.Destroy; //удалить неудачный объект
5   raise;           // продолжить обработку исключения.
6end;

3.14. Оператор возбуждения исключения
raise [Выражение]
Возбуждает исключение, которое, если не было обработано блоком except оператора обработки, дойдет до пользователя. Пользователь увидит сообщение, определяемое Выражением. Выражение должно иметь строковый тип и является обязательным для всех случаев, кроме части except оператора обработки исключений.

3.15. Оператор унаследованного вызова
inherited

Работает только в унаследованном переопределенном методе. Вызывается метод предка с параметрами, заданными в параметрах к моменту вызова. Если программный блок представляет собой тело функции, то в псевдопеременной Result будет результат выполнения метода предка.

1// в теле конструктора
2Name := 'Object name';
3Description := 'Object description';
4inherited; //вызов предка с параметрами Name и Description,
5           //заданными двумя предыдущими операторами. Ссылка на
6           //созданный объект лежит в
7           //псевдопеременной Result
8Result.Name := 'New name';

4. Выражения и операции

4.1. Состав выражения
Любое выражение имеет тип. Выражения состоят из следующих элементов:
  • Целая числовая константа (0 3 234);
  • Вещественная числовая константа. Дробная часть отделяется от целой точкой (".") (3.14 2.71);
  • Строковая константа. Заключается в апострофы. ('Some string' '10', '01.01.2006' 'now');
  • Логическая константа (True False);
  • Безтиповая (любого типа) константа nil;
  • Зарезервированное слово Self. Обозначает разный объект в зависимости от контекста:
    • В методах класса кроме конструктора - использование запрещено.
    • В методах экземпляра - всегда экземпляр, для которого вызван метод.
    • В конструкторе - до вызова унаследованного метода значение не определено. После вызова - ссылка на сконструированный объект.
    • В выражениях условий отбора - объект, для которого принимается решение о его вхождении в отбор.
  • Квалификатор.
  • Агрегат.

4.2. Квалификатор

Квалификатор обозначает объект, переменную, параметр, свойство, поле, вызов функции. Квалификатор состоит из идентификаторов, разделенных точкой.

Result
AName
Caption
LObject.Name
LObject.Parent.Name
LObject.ChildCount
LObject.HasAsParent(LOtherObject)

При интерпретации квалификатора используется следующий порядок разбора идентификатора:

  1. Контекстная переменная (для выражений условий отбора доменов)
  2. Локальная переменная
  3. Параметр
  4. Имя элемента перечисления
  5. Имя класса. Вне контекста означает ссылку на соответствующий объект класса TClass
  6. Имя поля
  7. Имя метода
  8. Имя свойства

При интерпретации квалификатора внутри выражения агрегата правила разбора идентификатора изменяются:

  1. Контекстная переменная (для выражений условий отбора доменов)
  2. Имя элемента перечисления
  3. Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту
  4. Имя поля
  5. Имя метода
  6. Имя свойства
  7. Локальная переменная
  8. Параметр

4.3. Агрегат

Агрегат определяет агрегированное значение над экземплярами определенного класса, удовлетворяющими условиям агрегации. Агрегаты бывают следующих типов:

  • any - первый попавшийся объект. Результат имеет тип ссылки на объект агрегируемого класса.
    1any(TObject with Master = Self.Parent)
2//первый попавшийся объект, имеющий значение
3//свойства Master равным значению свойства
4//Parent текущего (контекстного) объекта.
  • count - количество объектов. Результат имеет целочисленный тип.
    1count(TObject with Master = Self.Parent)
2//количество объектов, имеющих значение свойства
3//Master равным значению свойства Parent
4//текущего объекта.
  • sum - сумма значений свойства, поля или функции объектов. Результат имеет тип суммируемого поля, свойства или функции
    1sum(TExam.Mark with Master = LStudent) //сумма
2//баллов студента по его испытаниям
  • max, min - соответственно максимальное и минимальное значений свойства, поля или функции объектов. Результат имеет тип агрегируемого поля, свойства или функции
    1min(TObject.Created) // момент создания первого
2//объекта Системы.

Внутри выражения агрегата правила разбора идентификатора изменяются на следующие:

  1. Контекстная переменная (для выражений условий отбора доменов)
  2. Имя элемента перечисления
  3. Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту
  4. Имя поля
  5. Имя метода
  6. Имя свойства
  7. Локальная переменная
  8. Параметр

4.4. Операции

Операции связывают элементы выражений.

Таблица операций в порядке приоритета:
Левый операнд | Правый операнд
 | Целый | Вещест- венный | Дата | Время | Дата со временем | Логи- ческий | Строковый | Объект | nil
not
Нет | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
* (звездочка)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
/ (слэш, дробь)
Целый | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
div
Целый | Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
and
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
or
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
+ (плюс)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Дата | Дата со временем | Запрещено | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Время | Время | Дата со временем | Время | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Дата со временем | Дата со временем | Запрещено | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Строковый | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
- (минус)
Целый | Целый | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Вещест- венный | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Дата | Дата со временем | Целый | Дата со временем | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено
Время | Время | Время | Дата со временем | Время | Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Дата со временем | Дата со временем | Вещест- венный | Дата со временем | Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
=, <> (равно, не равно)
Целый | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Вещест- венный | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Дата | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Логи- ческий
Время | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
Дата со временем | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Логи- ческий
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Логи- ческий
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Логи- ческий
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий
<, >, <=, >= (меньше, больше, меньше либо равно, больше либо равно)
Целый | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Логи- ческий | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Логи- ческий | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
is
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Логи- ческий | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
as
Целый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Вещест- венный | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Время | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Дата со временем | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Логи- ческий | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Строковый | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено
Объект | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Объект | Запрещено
nil | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено | Запрещено

4.4.1. Особенности применения операций
  1. Приоритет сравнений ниже приоритета операций булевой логики. Поэтому выражение
    LObject.Master = LMaster and LObject.Parent = LParent
    будет интерпретироваться следующим образом:
    LObject.Master = (LMaster  and LObject.Parent) = LParent
    и вызовет ошибку компиляции из-за применения операции and к объектам. Необходимо писать:
    (LObject.Master = LMaster) and (LObject.Parent = LParent)
  2. Любое значение (выражение любого типа) сравнивается с безтиповой константой nil:
    1      LObject := any(TObject with Name = 'Some name');
2      if LObject = nil then
3         .....
  3. Операции "Унарный минус" не существует. Для задания отрицательных констант пользуйтесь конструкцией 0-Значение:
    Result := 0-1;

5. Формальная грамматика
001Goal: MethodBody | Expression;
002
003MethodBody: [ConstantDeclaration] [VariableDeclaration] CompoundStatement ";";
004
005ConstantDeclaration: "const" Ident ":" DomainSpecification ";"
006  [{Ident ":" DomainSpecification ";"}];
007
008VariableDeclaration: "var" DomainDefinition [{DomainDefinition}];
009
010DomainDefinition: Ident ":" DomainSpecification ";";
011
012DomainSpecification: IntegerDomainDefinition
013  | StringDomainDefinition
014  | FloatDomainDefinition
015  | DateDomainDefinition
016  | TimeDomainDefinition
017  | DateTimeDomainDefinition
018  | BooleanDomainDefinition
019  | BlobDomainDefinition
020  | EnumerationDomainDefinition
021  | Ident;
022
023IntegerDomainDefinition: "integer";
024StringDomainDefinition: "string" "[" Number "]";
025FloatDomainDefinition: "float" ["(" Number ["." Number] ")"];
026DateDomainDefinition: "date";
027TimeDomainDefinition: "time";
028DateTimeDomainDefinition: "datetime";
029BooleanDomainDefinition: "boolean";
030BlobDomainDefinition: "blob" | "clob";
031EnumerationDomainDefinition: "(" Ident {"," Ident} ")";
032
033CompoundStatement: "begin" Statement [{";" Statement}] "end";
034
035Statement:
036  | CompoundStatement
037  | AssignmentStatement
038  | InheritedStatement
039  | CallStatement
040  | IfStatement
041  | CaseStatement
042  | ForStatement
043  | WhileStatement
044  | RepeatStatement
045  | TryFinallyStatement
046  | TryExceptStatement
047  | RaiseStatement
048  | ForEachStatement
049  | ExitStatement;
050
051AssignmentStatement:  Qualifier ":=" Expression;
052
053CallStatement: Qualifier;
054
055InheritedStatement: "inherited";
056
057IfStatement: "if" Expression "then" Statement ["else" Statement];
058
059CaseStatement: "case" Expression "of" {CaseBranch} ["else" Statement ";"] "end";
060
061CaseBranch: CaseLabel [{',' CaseLabel}] ":" Statement ";";
062
063CaseLabel: Number | Ident;
064
065ForStatement: "for" Ident ":=" Expression ("to"|"downto")
066  Expression "do" Statement;
067
068WhileStatement: "while" Expression "do" Statement;
069
070RepeatStatement: "repeat" Statement [{";" Statement}] "until" Expression;
071
072TryFinallyStatement: "try" Statement [{";" Statement}] "finally"
073  Statement [{";" Statement}] "end";
074
075TryExceptStatement: "try" Statement [{";" Statement}] "except"
076  Statement [{";" Statement}] "end";
077
078RaiseStatement: "raise" [Expression];
079
080ForEachStatement: "for" "each" Ident "of" Ident ["with" Expression]
081  ["by" Expression] "do" Statement;
082
083ExitStatement: "exit";
084
085Expression: ComparedExpression [{RelationOperation Expression}];
086
087ComparedExpression: Addon [{AdditionOperaton ComparedExpression}];
088
089Addon: Factor [{MultiplicativeOperation Addon}];
090
091Factor: "(" Expression ")"
092  | "not" Expression
093  | Number ["." Number]
094  | StringConstant
095  | Qualifier
096  | "nil"
097  | "True"
098  | "False"
099  | "(" Expression "is" Ident ")"
100  | "any" Aggregate
101  | "count" Aggregate
102  | "sum" Aggregate
103  | "max" Aggregate
104  | "min" Aggregate;
105
106Aggregate: "(" Ident ["." Ident] ["with" Expression] ")";
107
108Qualifier: QualifierPart [{"." QualifierPart}];
109
110QualifierPart: Ident ["(" Expression [{", " Expression}] ")"]
111  | "self"
112  | "(" Qualifier "as" Ident ")";
113
114RelationOperation: "<"
115  | ">"
116  | "<="
117  | ">="
118  | "="
119  | "<>";
120
121AdditionOperaton: "+"
122  | "-"
123  | "or";
124
125MultiplicativeOperation: "*"
126  | "/"
127  | "div"
128  | "and";

6. Соглашения

6.1. Соглашения о наименованиях

В качестве вводимых (объявляемых) идентификаторов необходимо использовать так называемую нотацию InfixCaps. Если при создании имени используется несколько слов, то необходимо использовать заглавную букву для каждого слова в имени. Для разделения слов нельзя использовать символ подчеркивания. Все сущности именуются на английском языке, при этом использование сокращений является оправданным только в случае, если длина образуемого имени не согласуется с внешними по отношению к соображениям бизнес-логики ограничениям.

  • Имя класса должно начинаться с латинской буквы 'T'.
    Имя | Наименование
    TObjectList | Список объектов
    TLearnPlan | Учебный план
  • Имя поля должно начинаться с латинской буквы 'F'.
    Имя | Наименование
    FLearnPeriod | Период обучения
    FExamMark | Оценка за экзамен
  • Имя свойства не имеет префикса.
    Имя | Наименование
    ExamKind | Вид рубежного испытания
    ContactPhone | Контактный телефон
    Если членом класса для чтения свойства является поля, то имя свойства должно повторять имя поля без префикса 'F'. Если членом класса для чтения свойства является метод, то имя поля должно повторять имя метода без слова 'Get'.
  • Имя параметра не имеет префикса.
    Имя | Наименование
    OrderNumber | Номер приказа
    ExamDate | Дата проведения экзамена
    Параметры, используемые для инициализации значений полей, должны иметь имя, повторяющее имя поля без префикса 'F'. При компиляции тела метода, написанного на языке PascalScript имена параметров и имена свойств будут распознаваться в соответствии с порядком разбора идентификаторов, как это описано здесь и здесь.
  • Имена методов должны представлять собой императивный глагол на английском языке, выражающий смысл того, что метод делает. Имена методов не имеют префикса. Имена методов, используемых для получения значений свойств должны (как члены класса для чтения), должны начинаться со слова Get. Имена методов, используемых для установки значений свойств должны (как члены класса для записи), должны начинаться со слова Set.
    Имя | Наименование
    CountMarkSumm | Вычислить сумму баллов
    GetAge | Получить значение возраста
    SetMark | Установить значение оценки
  • Имена локальных переменных должны начинаться с латинской буквы 'L'.
    LMarkSumm (сумма баллов), LObjectCount (количество объектов).
  • Имена доменов должны начинаться с латинской буквы 'T'. В именах доменов допустимы пробелы. Рекомендуется к имени домена добавлять слово 'domain' (через пробел), а для обязательных доменов 'required domain' (через пробел) тогда, когда необходимо исключить возможность использования этих доменов в текстах на PascalScript. Первым словом в имени домена-ссылки должно быть имя класса домена. Исключением являются имена доменов, соответствующих простым типам данных без дополнительных ограничений. Имена таких доменов могут повторять имена типов языка PascalScript (Integer, Boolean, Float).
    Имя | Класс домена | Наименование
    TPrice domain | Вещественный | домен Цена
    TWeight required domain | Целочисленный | домен Вес (обязательный)
    Boolean | Логический | Логический
    TClassMember required domain | Ссылка | домен Член класса
  • Имена элементов перечислений должны иметь префикс из двух или трех символов, идентифицирующий соответствующий домен-перечисление. Префикс записывается строчными буквами. Например,
    Имя | Наименование
    для домена TExamKind (вид испытания)
    ekTest | зачет
    ekExam | экзамен
    ekDifTest | дифференцированный зачет
    для домена TAggregateKind (вид агрегата)
    agCount | количество
    agSumm | сумма
    agAverage | среднее значение
    Настоятельно рекомендуется давать уникальные имена элементов перечислений в пределах всей системы.

6.2. Стилевое оформление исходного кода

Код на языке PascalScript, являющийся частью поставляемого решения, должен быть оформлен в соответствии с изложенными правилами.

6.2.1. Использование строк, пробелов и отступов

Пустые строки могут повысить читабельность путем группирования секций кода, которые логически связаны между собой.

Пробелы, запрещенные к использованию:

  • До или после точки "."
  • Между именем вызываемого метода и открывающей скобкой "("
  • После открывающей скобки "(" или перед закрывающей ")"
  • Перед точкой с запятой ";"
  • Перед двоеточием ":"
  • Перед запятой ","

Двоеточие для всех объявлений переменных не должно содержать перед собой пробелов и иметь один пробел после перед именем типа.

Всегда необходимо использовать два пробела для всех уровней отступа. Другими словами, первый уровень отступает на два пробела, второй на четыре и так далее. Никогда не используйте символы табуляции.

Существует несколько исключений из этого правила. Зарезервированные слова var, begin и end, относящиеся к программному блоку вцелом, всегда должны примыкать к левой границе. Код внутри блока begin..end должен иметь отступ два символа.

Все строки должны быть ограничены 80 столбцами. Строки, длиннее чем 80 столбцов должны быть разделены и перенесены. Все перенесенные строки должны быть выровнены по первой строке и иметь отступ в два символа. Зарезервированное слово begin всегда должно находиться на своей отдельной строке.

Нельзя переносить строки в тех местах, где не допускаются пробелы, например между именем метода и открывающей скобкой. Никогда нельзя помещать зарезервированное слово begin на строку, содержащую другой код.

6.2.2. Оформление объявлений и операторов

Все переменные с их типами должны быть объявлены на различных строках.

Простые операторы содержат одну точку с запятой. Если Вам необходимо разделить оператор, то перенесите продолжение оператора на следующую строку с отступом в два пробела.
  MyValue :=
    MyValue + (SomeVeryLongStatement / OtherLongStatement);

Составные операторы всегда заканчиваются точкой с запятой.
1begin
2  MyStatement;
3  MyNext Statement;
4  MyLastStatement;
end;

Каждое присвоение и каждое выражение должно располагаться на разных строках.

Оператор "if"

Оператор if всегда должен располагаться по крайней мере на двух строках
if A < B then DoSomething;
if A < B then
  DoSomething;
В случае составного оператора необходимо поместить каждый оператор на новую строку.
1  if A < B then begin
2    DoSomething;
3    DoSomethingElse;
4  end else begin
5    DoThis;
6    DoThat;
7  end;

1  if A < B then
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end
6  else
7  begin
8    DoThis;
9    DoThat;
  end;
Все остальные варианты расположения операторов не рекомендуются и не одобряются, хотя и являются синтаксически правильными.

Оператор "for"

1  for i := 0 to 10 do begin
2    DoSomething;
3    DoSomethingElse;
4  end;

1  for i := 0 to 10 do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  for I := 0 to 10 do
8    DoSomething;

Оператор "while"

1  while x < j  do begin
2    DoSomething;
3    DoSomethingElse;
  end;
1  while x < j do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  while x < j do
8    Something;

Оператор "repeat..until"

1  repeat
2    x := j;
3    j := UpdateValue;
4  until j > 25;

Оператор "case"

Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01  case LCode of
02    1, 3:
03      begin
04        Incr := FIncrement + 1;
05        FinalIncr := FIncrement div FLineDiv;
06        Count := FLineDiv;
07      end;
08    2, 4:
09      begin
10        Incr := FPageIncrement;
11        FinalIncr := Incr + 1;
12        Incr := Incr div FPageDiv;
13        Count := FPageDiv;
14      end;
15  else
16    begin
17      Count := 0;
18      Incr := 0;
19      FinalIncr := 0;
20    end;
  end;

Оператор "try"

Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01try
02  try
03    EnumItems(CurrentThreadID, LDisable, 0);
04    Result := TaskList;
05  except
06    EnableItems(TaskList);
07    raise;
08  end;
09finally
10  TaskList := SaveList;
11  TaskActive := SaveActive;
end;


Мельница данных ((раздел целиком))

Мельница данных- Класс TSessionHistory (Сессии) (раздел целиком) (22.10.2024) (одним файлом)
Класс TSessionHistory (Сессии)

Диаграмма

1. Свойства

Свойства класса TSessionHistory:

Имя | Тип | Обязательно | Доступ | Назначение
IntStamp | Integer | Нет | Только для чтения | Целочисленный номер
TimeStamp | datetime | Да | Только для чтения | Время
User | TUser | Нет | Только для чтения | Пользователь
Login | string[64] | Да | Только для чтения | Логин
CloseStamp | datetime | Нет | Только для чтения | Время закрытия
UserAgent | string[2000] | Нет | Только для чтения | Пользовательский агент
IPAddress | string[16] | Нет | Только для чтения | IP-адрес
ConnectionInfo | string[2000] | Нет | Только для чтения | Информация о соединении
Duration | time | Нет | Только для чтения | Продолжительность

2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TSessionHistory.

1class procedure TSessionHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По

3. Метод DBMSConnectionInfo (Информация о соединении от СУБД)

Метод класса (статический метод) класса TSessionHistory.

class function TSessionHistory.DBMSConnectionInfo: string[2000];

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

4. Метод DBMSGetIPAddress (IP-адрес клиента от СУБД)

Метод класса (статический метод) класса TSessionHistory.

class function TSessionHistory.DBMSGetIPAddress: string[16];

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[16].

5. Метод DBMSGetUserAgent (Пользовательский агент от СУБД)

Метод класса (статический метод) класса TSessionHistory.

class function TSessionHistory.DBMSGetUserAgent: string[2000];

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

6. Метод GetCurrentSession (Идентификатор текущей сессии)

Метод класса (статический метод) класса TSessionHistory.

class function TSessionHistory.GetCurrentSession: TSessionHistory;

Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TSessionHistory.

7. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TSessionHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
FileName | string[255] | Да | Имя файла
TimeStampFrom | datetime | Нет | С
TimeStampTo | datetime | Нет | По


Мельница данных ((раздел целиком))

Мельница данных- Форматы и соглашения (раздел целиком) (22.10.2024) (одним файлом)
Форматы и соглашения

1. Стандартная адресация базы данных платформы

Строка адресации БД платформы "Мельница данных" состоит из следующих элементов:
Сервер#Пользователь:Роль/Пароль@БазаДанных

Сервер - один из следующих вариантов:

  • MS - БД MSSQL
  • FB - БД Firebird
  • ORA - БД Oracle Database
  • PG - БД PostgreSQL
  • MY - БД MySQL
  • APP - Удаленное подключение к БД через сервер приложений

Пользователь - имя пользователя, используемого для соедиения.

Роль - роль, ассоциированная с соединением.
Роль, заданная в строке адресации БД, используется для установки соединения с БД (передается через параметр isc_dpb_sql_role_name)
Для всех СУБД, кроме Firebird, указание роли имеет смысл только для утилиты обслуживания БД.

Пароль - пароль пользователя, используемый для соедиения. Пароль также может быть не задан в строке соединения (после символа "/" сразу следует символ "@"). В этом случае пароль будет запрошен у пользователя (если будет такая возможность), или будет использоваться Negotiate-аутентификация.

БазаДанных - адресует собственно базу или схему данных.
При использовании удаленного подключения к БД через сервер приложений используется нотация
protocol://Host:Port/handler
Протокол (protocol) может быть http или https. По умолчанию используется протокол http. Порт (Port) по умолчанию 80 для протокол http и 443 для протокола https может быть опущен.
Host:Port\\InstanceName.Database
Порт (Port) по умолчанию 1433 может быть опущен вместе с двоеточнием. Хост (Host) может быть опущен, если используется локально. Имя экземпляра (InstanceName) может быть опущено, если используется имя "MSSQLSERVER". Следующие строки эквивалентны:
1localhost:1433\\MSSQLSERVER.MillDatabase
2localhost\\MSSQLSERVER.MillDatabase
3localhost.MillDatabase
4MillDatabase

Host/Port:DBPath
Порт (Port) по умолчанию 3050 может быть опущен. Если опущен хост (Host), то используется локальный протокол доступа к БД. Файл базы данных (DBPath) может быть задан как полное имя файла в файловой системе сервера, так и быть псевдонимом, настроенным на сервере.
Host:Port/SID.schema
Порт (Port) по умолчанию 1521 может быть опущен. Если опущен хост (Host), то используется имя из файа TNSNAMES.ORA в используемой клиентской части СУБД. Указание SID и имени схемы (schema) обязательно.
Host:Port/DataBase.schema
Порт (Port) по умолчанию 5432 может быть опущен. Если опущен хост (Host), то используется локальное соединение. Указание имени базы данных (DataBase) и имени схемы (schema) обязательно.
Host:Port/schema
Порт (Port) по умолчанию 3306 может быть опущен. Если опущен хост (Host), то используется локальное соединение. Указание имени схемы (schema) обязательно.

Прямое подключение к БД от имени владельца схемы данных является административным.
Владельцем схемы данных является пользователь, имя которого совпадает с именем схемы.
Никакое подключения к БД через сервер приложений не является административным.


Мельница данных ((раздел целиком))

Мельница данных- Интерфейс ITableInfo3 (раздел целиком) (22.10.2024) (одним файлом)
Интерфейс ITableInfo3

Интерфейс ITableInfoИнтерфейс INamedItemInfo

01type
02  ITableInfo3 = interface(ITableInfo)
03    ['{3FB73AA9-010C-48DA-81C7-E1DCFE2E6136}']
04    function GetPersistentClause(const Alias: WideString): WideString; safecall;
05    function GetPreConditionsCount: Integer; safecall;
06    function GetPreConditionCaption(Index: Integer): WideString; safecall;
07    function Get_ActivePreCondition(Index: Integer): WordBool; safecall;
08    procedure Set_ActivePreCondition(Index: Integer; Value: WordBool); safecall;
09    function GetPreConditionParamsCount(Index: Integer): Integer; safecall;
10    function GetPreConditionParam(Index: Integer;
11      PreConditionIndex: Integer): IOptionInfo; safecall;
12    function GetPreConditionCategory(Index: Integer): WideString; safecall;
13    property ActivePreCondition[Index: Integer]: WordBool
14      read Get_ActivePreCondition write Set_ActivePreCondition;
15  end;

1. Свойства

Свойства интерфейса ITableInfo3:

Имя | Тип | Доступ | Назначение
Caption | WideString | Только для чтения | Унаследовано от INamedItemInfo
ID | WideString | Только для чтения
Name | WideString | Только для чтения
Field[Index: Integer] | IFieldInfo | Только для чтения | Унаследовано от ITableInfo
FieldCount | Integer | Только для чтения
Parent | ITableInfo | Только для чтения
PrimaryKey | IFieldInfo | Только для чтения
RootAvailable | WordBool | Только для чтения
Uplink | IFieldInfo | Только для чтения
ActivePreCondition[Index: Integer] | WordBool | Чтение/Запись |

2. Метод GetPersistentClause

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPersistentClause(const Alias: WideString): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Alias | WideString | Да |

Замечания:

Возвращает значение типа WideString.

3. Метод GetPreConditionCaption

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionCaption(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.

4. Метод GetPreConditionCategory

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionCategory(Index: Integer): WideString;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа WideString.

5. Метод GetPreConditionParam

Метод интерфейса ITableInfo3.

1function ITableInfo3.GetPreConditionParam(Index: Integer;
2  PreConditionIndex: Integer): IOptionInfo;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |
PreConditionIndex | Integer | Да |

Замечания:

Возвращает значение типа IOptionInfo.

6. Метод GetPreConditionParamsCount

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionParamsCount(Index: Integer): Integer;

Параметры:

Имя | Тип | Обязательно | Значение
Index | Integer | Да |

Замечания:

Возвращает значение типа Integer.

7. Метод GetPreConditionsCount

Метод интерфейса ITableInfo3.

function ITableInfo3.GetPreConditionsCount: Integer;

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.


Мельница данных ((раздел целиком))

Мельница данных- Класс TMethod (Методы) (раздел целиком) (22.10.2024) (одним файлом)
Класс TMethod (Методы)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

1. Свойства

Свойства класса TMethod:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Body | clob | Нет | Видимо пользователю | Чтение/Запись | Тело
CallTemplate | string[2000] | Нет | Видимо пользователю | Только для чтения | Шаблон вызова
Virtual | Boolean | Да | Видимо пользователю | Чтение/Запись | Виртуальный
DBMSName | string[64] | Да | Видимо пользователю | Только для чтения | Имя объекта СУБД

2. Конструктор Create (Конструктор метода)

Конструктор класса TMethod.

1constructor TMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; Body: clob;
6  Virtual: Boolean): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Имя
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
Body | clob | Нет | Тело
Virtual | Boolean | Да | Метод является виртуальным

Замечания:

Создает новый объект класса TMethod.

3. Метод Call (Вызвать)

Метод экземпляра класса TMethod.

procedure TMethod.Call(Parameters: TObjectList);

Метод скрыт от пользователя.

Параметры:

Имя | Тип | Обязательно | Значение
Parameters | TObjectList | Нет | Параметры

4. Метод CallTemplate (Шаблон вызова)

Метод экземпляра класса TMethod.

function TMethod.CallTemplate: string[2000];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5. Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TMethod.

function TMethod.GetDBMSName: string[64];

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

6. Метод VirtualChainRoot (Корень виртуальной цепи)

Метод экземпляра класса TMethod.

function TMethod.VirtualChainRoot: TMethod;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TMethod.


Мельница данных ((раздел целиком))

Мельница данных- Руководство пользователя обозревателя данных (раздел целиком) (22.10.2024) (одним файлом)
Руководство пользователя обозревателя данных

1. Запуск обозревателя данных

Для начала работы необходимо запустить исполняемый файл DataBrowser.exe. Это можно сделать посредством ярлыка, создаваемого инсталлятором Системы:

Ярлык обозревателя данных

При его запуске отобразится окно входа в систему:

Окно логина обозревателя данных

Для запуска системы необходимо заполнить поля формы входа в систему, после чего нажать кнопку ОК или клавишу Enter на клавиатуре. Если система ранее запускалась на Вашем локальном компьютере, то поля формы (за исключением поля Пароль) будут заполнены данными, введенными в прошлый раз. Если система на компьютере запускается впервые, то при открытии формы ее поля будут пустыми. Для заполнения полей формы необходимо знать, на каком типе сервера БД работает система, имя базы данных, с которой предстоит работать, имя пользователя и пароль. Если Вы не располагаете такой информацией, узнайте ее у администратора системы.

  • Источник данных - в этом поле из выпадающего списка выберите тип сервера баз данных, на котором функционирует система; возможен выбор из трех вариантов:
    • если система работает на сервере Interbase (Firebird), выберите пункт Interbase/FireBird Server;
    • если система работает на сервере Oracle, выберите пункт Oracle Database Server;
    • если система работает на сервере MSSQL, выберите пункт Microsoft SQL Server.
  • База данных - в этом поле необходимо указать имя базы данных.
  • Имя пользователя - в этом поле введите Ваше имя пользователя (логин).
  • Пароль - в это поле введите Ваш пароль.
Для удобства последующего запуска системы Вы можете воспользоваться флажками "Сохранить пароль" и "Входить автоматически".
  • Сохранить пароль - если установить этот флажок, то Ваш пароль будет запомнен и подставлен в поле Пароль при следующем запуске системы. В связи с тем, что информация о вводимом Вами пароле будет сохранена на Вашем локальном компьютере, пользоваться этим флажком рекомендуется только в том случае, если возможность несанкционированного доступа к Вашему компьютеру исключена.
  • Входить автоматически - этот флажок доступен только при установленном флажке "Сохранить пароль". Если установить этот флажок, то при следующем входе в систему Вам не придется заполнять поля формы и нажимать кнопку OK или клавишу Enter. Форма покажется на некоторое время, после чего произойдет автоматический вход в систему.

Если Вы установили флажок "Входить автоматически", но хотите изменить ранее введенную в поля информацию, необходимо выполнить щелчок мышью (здесь и далее "щелчок мышью" означает щелчок ЛЕВОЙ кнопкой мыши. Если необходим щелчок ПРАВОЙ кнопкой мыши, то будет указано "щелчок правой кнопкой мыши") на форме во время ее показа. После этого можно будет изменить ранее установленные в полях значения.

2. Элементы интерфейса пользователя

При входе в систему на экране отобразиться ее главное окно. Макет главного окна системы:

Макет главного окна обозревателя данных

В заголовке главного окна системы отображается имя запущенного приложения (Databrowser.exe), имя пользователя (sysdba) и имя базы данных (C:\project\databases\icecream.fdb). Интерфейс состоит из трех основных элементов:

  1. В верхней части экрана расположена Панель инструментов. На ней расположены иконки, соответствующие доступным в настоящее время действиям, а также доступным для текущего пользователя формам.
  2. В левой части экрана расположен Инспектор объектов, позволяющий просматривать и редактировать свойства объектов, выбранных в таблицах данных.
  3. Основную часть экрана занимают Формы с Таблицами данных. Таблицы данных используются для просмотра и редактирования объектов, учитываемых в системе.

3. Работа с формами и таблицами данных

Для отображения записей об учитываемых в системе объектах используются формы с таблицами данных. Каждая форма представляет собой отдельное окно с заголовком, на котором отображается ее наименование. Основную часть окна формы занимают таблицы данных. Переключаться между доступными формами можно либо при помощи щелчка мышью по иконке, соответствующей форме на Панели инструментов, либо при щелчке мышью на самом окне формы (если форма видна). В каждый момент времени активной является одна из форм (или ни одной). Окно формы можно "перетаскивать" (здесь и далее "перетащить" объект означает подвести к нему указатель мыши, нажать левую кнопку, удерживая кнопку переместить объект на новое место, после чего отпустить кнопку мыши) по экрану за заголовок, изменять его размеры, минимизировать, восстановить, раскрывать на весь экран или закрывать. Эти действия осуществляются стандартным для среды Windows образом. При закрытии формы соответствующая ей иконка на панели инструментов будет отображена неактивной. При щелчке мышью по такой иконке форма откроется, и иконка станет активной.

Таблицы данных в форме расположены на закладках с заголовками, соответствующими наименованиям таблиц данных. Например, на предыдущем рисунке активна форма "Продажи мороженого". В этой форме на первом уровне расположены таблицы данных "Регионы", "Сорта мороженого", "Сорта фруктового мороженого", "Представительства", "Все продажи". Активной в настоящее время является таблица данных "Представительства".

3.1. Подчиненные таблицы данных и взаимное расположение главной и подчиненных таблиц

Таблицы данных могут иметь подчиненные таблицы. Подчиненные таблицы по умолчанию отображаются в нижней части главной таблицы. Набор записей, отображаемых в подчиненной таблице, зависит от того, какие записи выбраны в главной таблице.

Например, на рисунке в главной таблице "Представительства" выбрано представительство ООО "Холод плюс". При этом в подчиненной таблице "Продажи представительства" отображаются только те продажи, которые осуществлены данным представительством.

Подчиненные таблицы могут располагаться двумя способами:

  • на закладках - в этом случае в нижней части главной таблицы отображаются закладки с наименованиями подчиненных таблиц; переключаться между подчиненными таблицами можно путем щелчка мышью по соответствующей закладке;
    Отображение подчиненных таблиц на закладках
  • в отдельных окнах - в этом случае каждая из подчиненных таблиц располагается в своем окне; окна имеют заголовки, соответствующие наименованиям таблиц; окна, в которых отображаются подчиненные таблицы, можно перетаскивать за заголовок в любое другое место экрана, минимизировать, восстанавливать, закрывать и т.д.
    Отображение подчиненных представлений в отдельных окнах

Изменять соотношение размера главной и подчиненных таблиц можно путем перетаскивания горизонтального разделителя мышью. Для этого необходимо подвести указатель мыши к границе раздела зон главной и подчиненных таблиц и когда курсор примет форму горизонтального разделителя ( Горизонтальный разделитель) перетащить разделитель выше или ниже. При отображении подчиненных таблиц в отдельных окнах можно изменять соотношение ширины подчиненных таблиц. Для этого нужно подвести указатель мыши к вертикальной границе таблиц и когда указатель примет форму вертикального разделителя ( Вертикальный разделитель), перетащить разделитель вправо или влево.

При отображении подчиненных таблиц на закладках занимаемая ими область также может быть минимизирована. Для этого необходимо подвести курсор к границе раздела зон главной и подчиненной таблиц и когда он примет форму горизонтального разделителя ( Горизонтальный разделитель) выполнить двойной щелчок мышью.

Минимизация зоны подчиненных таблиц

Восстановить отображение подчиненных таблиц можно либо путем нажатия кнопки "Восстановить" ( Кнопка восстановления размеров зоны подчиненных таблиц) в заголовке минимизированного окна, либо при помощи двойного щелчка мышью на этом заголовке.

3.2. Отображение учитываемых объектов в таблице данных

Таблица данных имеет строки и колонки. Строки таблицы (или записи) соответствуют учитываемым объектам. Колонки таблицы соответствуют свойствам объектов.

Макет таблицы данных

На рисунке представлен макет таблицы данных, в которой отображаются объекты, соответствующие сортам фруктового мороженого. Таблица данных имеет наименование "Сорта фруктового мороженого", которое отображается на соответствующей закладке (1). Таблица имеет пять строк (2), соответствующих пяти сортам фруктового мороженого. Выделенной в настоящее время является первая строка. Таблица имеет пять колонок, соответствующих свойствам учитываемых сортов мороженого. Каждая колонка имеет заголовок (4), отражающий отображаемое в этой колонке свойство. Активной в настоящее время является первая колонка. Активным элементом данных (3) является ячейка, расположенная в первой строке в первом столбце.

На рисунке активная строка и активный элемент данных выделяются оттенками синего цвета. Цвета, применяемые для выделения элементов данных, зависят от локальных настроек операционной системы Windows (стилей) на компьютере пользователя.

Под заголовком каждой колонки расположена строка фильтра (5). При помощи ввода в этой строке условия отбора или выбора значений из выпадающего списка можно осуществлять фильтрацию отображаемых в таблице данных.

Если отображаемые данные не помещаются в окно по ширине, то активной становится горизонтальная полоса прокрутки (7). С ее помощью можно пролистывать колонки таблицы вправо и влево. Если данные не помещаются в окно по вертикали, то активной становится вертикальная полоса прокрутки (8). С ее помощью можно пролистывать записи об объектах вверх и вниз. При щелчке правой кнопкой мыши на полосе прокрутки (если она активна) доступны действия по быстрой прокрутке содержимого таблицы.

При щелчке правой кнопкой мыши в области таблицы данных отображается контекстное меню. Контекстное меню отображает список действий, доступных над объектами, отображаемыми в таблице данных. Вызываемые действия выполняются для тех объектов, которые являются выделенными в таблице данных. Если ни одного объекта не выделено, некоторые действия контекстного меню могут быть недоступны. Набор действий, отображаемых в контекстном меню различен в разных таблицах данных.

  1. Заголовок закладки с именем таблицы данных.
  2. Выделенный объект.
  3. Выделенный элемент данных.
  4. Заголовок колонки.
  5. Строка фильтра.
  6. Флажок для выбора объектов.
  7. Горизонтальная полоса прокрутки.
  8. Вертикальная полоса прокрутки

3.2.1. Иерархические таблицы данных

Если отображаемые в таблице данные имеют иерархическую структуру (т.е. присутствует "вхождение" одних объектов в другие), то в таблице данных объекты могут отображаться в виде "дерева".

Иерархическая таблица данных

На рисунке представлена таблица данных, отображающая периоды обучения студентов. Эти данные имеют иерархическую структуру, которая отражает вхождение учебных модулей в состав семестров, а семестров в состав учебных годов. В первой колонке иерархической таблицы данных слева от элементов данных, имеющих подчиненные элементы, отображаются значки Свернутый узел дерева или Развернутый узел дерева. При щелчке мышью по значку Свернутый узел дерева отображаются подчиненные объекты. Значок Свернутый узел дерева при этом превращается в значок Развернутый узел дерева. При щелчке мышью по значку Развернутый узел дерева подчиненные объекты скрываются и значок Развернутый узел дерева превращается в Свернутый узел дерева. На рисунке для объектов "Учебный год 2005-2006" и его подчиненных объектов "I семестр" и "II семестр" подчиненные объекты отображены. Щелчком по значку Развернутый узел дерева подчиненные объекты можно скрыть. Для объектов "I семестр" и "II семестр" учебного года 2006-2007 подчиненные объекты скрыты. Щелчком по значку Свернутый узел дерева их можно отобразить. При горизонтальном пролистывании таблицы данных вправо или влево "дерево" объектов всегда отображается слева от самого левого столбца.

В иерархических таблицах данных доступны дополнительные действия по управлению отображением и выбору объектов, которые описаны в разделе 4.7.1.

3.3. Выбор объектов в таблице данных

Выбор одного объекта в таблице данных может осуществляться либо щелчком мышью в соответствующей строке, либо при помощи стрелок ("вверх" и "вниз") на клавиатуре. Выбор активной колонки и активного элемента данных также может производиться щелчком мышью или при помощи стрелок ("вправо" и "влево") на клавиатуре.

В таблице данных можно также осуществлять произвольный выбор нескольких объектов путем установки флажка в строке, отображающей объект. Установка или снятие флажка производится при помощи щелчка мышью.

При выборе нескольких объектов в главной таблице в подчиненной таблице будут отображены записи, соответствующие подчиненным объектам, отобранным для ВСЕХ объектов, выбранных в главной таблице.

Произвольный выбор объектов

На рисунке представлена таблица данных "Учащиеся", имеющая ряд подчиненных таблиц. На рисунке открыта подчиненная таблица "Родственники и контактные лица". В таблице данных "Учащиеся" путем установки флажка произвольным образом выбраны три учащихся с фамилиями Матвеева, Зимогляд и Анчевский. При этом в подчиненной таблице "Родственники и контактные лица" отображены родители всех троих учащихся.

При выборе объектов путем простановки флажков необходимо осуществлять щелчок мышью именно на флажке. Если выполнить щелчок мышью в любой другом месте записи, ранее установленные флажки будут сняты, и выбранной станет одна эта запись.

Для быстроты и удобства выбора объектов доступны дополнительные возможности:

  • для выделения нескольких объектов подряд можно щелкнуть мышью в любом месте записи, соответствующей первому объекту, а затем, удерживая клавишу Shift, щелкнуть по записи, соответствующей последнему объекту; все объекты между первым и последним, включая их, будут выделены;
  • осуществлять произвольный выбор объектов можно щелчком мышью в любом месте записи, удерживая клавишу Ctrl ;
  • можно воспользоваться действиями, доступными в подменю "Выбранные" на панели инструментов или в контекстном меню:
    • Выбрать все - все отображаемые в настоящий момент в таблице данных объекты будут выбраны;
    • Показать только выбранные - в таблице данных будут отображены только те объекты, которые помечены как выбранные; остальные объекты будут скрыты;
    • Показать все - если ранее было установлен отбор только выбранных объектов, этот отбор будет снят, и снова будут отображены все доступные в таблице объекты.

При выборе объектов изменяется информация, отображаемая Инспектором объектов. Если выбран один объект, то Инспектор объектов отображает и позволяет редактировать все доступные пользователю свойства этого объекта. Если выбрано несколько объектов, отображение и редактирование свойств Инспектором объектов происходит по правилам, описанным в разделе 5 "Работа с Инспектором объектов".

При выполнении действий над объектами выбранное действие будет выполнено для всех выбранных объектов. Если не выбрано ни одного объекта, некоторые действия могут быть недоступны.

При одновременном выборе большого числа объектов быстродействие системы может снижаться. При необходимости работы с большой выборкой объектов лучше воспользоваться возможностью фильтрации данных.

3.4. Изменение порядка отображения колонок

Порядок отображения колонок может быть изменен путем "перетаскивания" их заголовков. Для того чтобы переместить колонку правее или левее, подведите указатель мыши к заголовку колонки, нажмите левую кнопку мыши и, не отпуская ее, перетащите заголовок колонки вправо или влево. После того, как Вы отпустите кнопку мыши, порядок отображения колонок изменится.

Изменение порядка отображения колонок

На рисунке изображено перетаскивание заголовка колонки "Вид упаковки" в таблице данных "Сорта мороженого". После того, как кнопка мыши будет отпущена, колонка "Вид упаковки" станет третьей слева, а колонка "Число продаж" второй.

3.5. Скрытие и отображение колонок

Любая из видимых в таблице данных колонок может быть скрыта. Для этого необходимо выделить любой элемент данных в колонке, щелчком правой кнопкой мыши открыть контекстное меню и в нем в подменю "колонка" выбрать действие "Скрыть эту колонку".

На рисунке показано как скрыть колонку "Вид упаковки" в таблице данных "Сорта мороженого". Описанным выше образом можно скрыть любое число колонок таблицы данных кроме последней. Если в таблице данных осталась одна колонка, то действие "Скрыть эту колонку" будет недоступно. Для отображения скрытых ранее колонок таблицы данных необходимо воспользоваться действием "Показать скрытые колонки" в подменю "колонка" контекстного меню. (На рис. 12. действие располагается ниже действия "Скрыть эту колонку"). Если ни одной колонки таблицы данных не скрыто, то действие "Показать скрытые колонки" будет недоступно. Действия, расположенные в подменю "колонка" доступны также на панели инструментов.

3.6. Сортировка данных в таблицах

Отображаемые в таблице данные могут быть отсортированы по возрастанию или по убыванию значений свойств, отображаемых в одной или нескольких колонках. Для сортировки данных по одной колонке необходимо выполнить щелчок мышью не ее заголовке. Данные будут отсортированы по возрастанию значения в этой колонке. Если щелкнуть мышью по заголовку колонки еще раз, то данные будут отсортированы по убыванию значения в этой колонке. В заголовке конке появится стрелочка, отображающая порядок сортировки (направленная вверх в случае сортировки по возрастанию и вниз в случае сортировки по убыванию). Если выполнить щелчок мышью по заголовку другой колонки, то данные будут отсортированы по значению в новой колонке.

Сортировка данных по одной колонке

На рисунке данные в таблице данных "Учащиеся" отсортированы по значению в колонке "Фамилия" по возрастанию. В заголовке колонки "Фамилия" отображается направленная вверх стрелочка. Для сортировки данных по значениям в нескольких колонках необходимо выполнить щелчок мышью на заголовке первой колонки, затем, удерживая клавишу Ctrl, выполнить щелчок по заголовку второй колонки и т.д. При этом в заголовках колонок будут отображаться стрелочки, соответствующие направлению сортировки и цифры, соответствующие порядку колонок в сортировке.

Сортировка данных по нескольким колонкам

На рисунке представлен пример сортировки данных таблицы данных "Учащиеся" по региону (по возрастанию), затем по полу (по убыванию) и затем по фамилии (по возрастанию). В заголовках колонок отображены соответствующие стрелочки с цифрами 1, 2 и 3.

В иерархических таблицах данные сортируются в пределах каждого уровня иерархии.

Сортировка данных в иерархической таблице

На рисунке данные в иерархической таблице данных "Направления и специальности" отсортированы по колонке "Наименование" по возрастанию.

3.7. Группировка данных в таблицах

Данные в таблице данных могут быть сгруппированы по значениям свойств, отображаемым в одной или в нескольких колонках.

Для осуществления группировки по значению в одной из колонок необходимо выделить любой элемент данных в этой колонке. Затем щелчком правой кнопки мыши открыть контекстное меню и в нем в подменю "колонка" выбрать действие "Группировать по этой колонке".

Осуществление группировки данных

На рисунке показано, как при помощи действия в контекстном меню осуществляется группировка данных в таблице данных "Все продажи" по значению в колонке "Представительство".

При отображении данных в сгруппированном виде для каждой группы будет отображен заголовок на более темном фоне. В заголовке группы будут отображены наименование и значение свойства, по которому осуществлена группировка, а слева от наименования будет расположен значок Развернутый узел дерева или Свернутый узел дерева. При нажатии на значок Развернутый узел дерева можно скрывать объекты группы (для группы будет отображен только ее заголовок). Значок Развернутый узел дерева при этом изменится на Свернутый узел дерева. При нажатии на значок Свернутый узел дерева объекты, входящие в группу, будут снова отображены.

Отображение данных в сгруппированном виде

На рисунке данные в таблице данных "Все продажи" сгруппированы по значению в колонке "Представительство". Группы объектов, соответствующие представительствам ЗАО "Айс девелопмент", ЗАО "Фрост интернешнл" и ООО "Заморозь соседа", раскрыты. Группы, соответствующие ОАО "Красный нос" и ООО "Дед мороз и лето", свернуты.

Данные могут группироваться и по нескольким колонкам. Для этого необходимо повторить описанные выше действия для всех колонок, которые должны быть включены в группировку.

Группировка данных по нескольким колонкам

На рисунке представлен пример группировки данных, отображаемых в таблице данных "Все продажи" по колонкам "Регион" и "Сорт мороженого".

Для снятия группировки и отображения данных в стандартном виде необходимо воспользоваться действием "Очистить группировку", которое также доступно в контекстном меню в подменю "колонка" (на рисунке расположено в выпадающем меню ниже действия "Группировать по этой колонке").

Действия, расположенные в подменю "колонка", доступны также на панели инструментов.

3.8. Фильтрация данных в таблицах

Фильтрация данных (отображение только тех данных, которые удовлетворяют некоторому условию) осуществляется по значениям, отображаемым в колонках, при помощи строки фильтра. Строка фильтра расположена ниже заголовка колонки. Фильтрация данных может осуществляться двумя способами:

  • путем выбора значения из выпадающего списка, доступного при нажатии кнопки Кнопка выпадающего списка в строке фильтра
  • путем записи условия фильтрации в строке фильтра

При нажатии кнопки Кнопка выпадающего списка в строке фильтра отображается выпадающий список значений, которые могут быть выбраны. Перечень отображаемых значений зависит от типа данных, отображаемых в колонке. В первой строке списка расположен пункт "(Все)". При выборе этого пункта фильтрация данных по этой колонке не осуществляется. При выборе одного из доступных значений в таблице данных будут отображены только те объекты, для которых значение свойства, отображаемого в данной колонке, равно выбранному. После осуществления фильтрации в строке фильтра будет отображено выбранное значение. Выбор значений можно осуществить в нескольких колонках. В этом случае условия отбора по каждой колонке будут объединены логическим "И".

Фильтрация данных путем выбора значения в строке фильтра

На рисунке показано, как осуществить фильтрацию данных по значению "эскимо" в колонке "Вид упаковки". После выполнения фильтрации эта таблица данных будет выглядеть следующим образом:

Отображение данных в отфильтрованном виде

В таблице данных на рисунке отображены записи только о тех сортах мороженого, которые продаются в виде эскимо. Значение "эскимо" отображено в строке фильтра в колонке "Вид упаковки".

Для фильтрации данных по более сложному условию можно воспользоваться вторым способом - записью условия фильтрации в строке фильтра. Условие фильтрации записывается по следующим правилам:

  1. Строка разделяется на части посредством системного разделителя (системный разделитель устанавливается в настройках операционной системы Windows). Обычно - точка с запятой, ";"
  2. Каждая часть строки интерпретируется самостоятельно, и эти части объединяются логическим "ИЛИ"
  3. При интерпретации каждой части проверяются следующие условия:
    Часть строки | Правило отбора объектов
    * Будут отобраны только те объекты, у которых значение в колонке не является пустым (установлено).
    !* Будут отобраны только те объекты, у которых значение в колонке является пустым (не установлено).
    начинается с символов '<=', '<', '>=', '>' | Будут отобраны только те объекты, у которых значение в колонке удовлетворяет условию.
    включает в себя символы '*' и/или '?' | Будут отобраны только те объекты, у которых значение в колонке удовлетворяет шаблону, в котором знак '?' соответствует одному любому символу, а знак '*' - любому количеству любых символов.
    начинается с символа '!' | Будут отобраны только те объекты, у которых значение в колонке не удовлетворяет условию, переданному оставшейся частью строки (знак '!' означает отрицание).
    представляет собой строку в апострофах (одиночных кавычках) | Содержание строки не анализируется по приведенным выше правилам. Будут отобраны только те объекты, у которых значение данного свойства соответствует строке, заключенной в апострофы.
    любая другая строка | Будут отобраны только те объекты, у которых значение данного свойства соответствует введенной строке (строки чувствительны к регистру).
  4. Условия, указанные в разных колонках, объединяются логическим "И"

После ввода в строке фильтр требуемого условия необходимо нажать клавишу Enter.

Фильтрация данных по сложному условию

В таблице данных "Все продажи" на рисунке отобраны только те записи, для которых верно следующее: Продажи осуществлены в регионе "Москва" или "Тверская область"; при этом наименование проданного сорта мороженого начинается с "Б"; при этом число продаж данного сорта больше 100.

Сделать заключение о том, что отображаемые в таблице данные отфильтрованы, можно по наличию в строке фильтра записи отличной от "(Все)". Снять фильтрацию данных можно одним из двух способов:

  • выбрать в строке фильтра из выпадающего списка пункт "(Все)"
  • удалить все символы, записанные в строке фильтра и нажать клавишу Enter

3.9. Отображение итоговых значений (агрегатов) по колонкам

По любой из колонок таблицы данных может быть рассчитано и отображено итоговое значение (агрегат). В зависимости от типа отображаемого в колонке свойства могут быть вычислены следующие агрегаты:

  • количество объектов (для свойств любых типов)
  • сумма значений (для числовых значений)
  • наименьшее (минимальное) значение (для строковых, числовых, логических значений, перечислений, значений типа даты, времени, даты со временем)
  • наибольшее (максимальное) значение (аналогично наименьшему значению)
  • среднее значение (для числовых значений)

Для отображения агрегата по одной из колонок необходимо выделить элемент данных в этой колонке, при помощи щелчка правой кнопкой мыши отобразить контекстное меню и в нем в подменю "колонка" выбрать действие, соответствующее нужному агрегату. После выполнения этого действия таблица данных будет выглядеть следующим образом:

Таблица данных с агрегатом по одной из колонок

На рисунке в нижней части таблицы данных отображена строка на светло-желтом фоне, в которой в колонке "Число продаж" показана сумма числа всех продаж, отображаемых в таблице.

Агрегат может быть вычислен и показан по любой из колонок.

Если данные в таблице отфильтрованы, то агрегат будет рассчитан только по тем записям, которые отобраны по условию фильтрации.

Если данные в таблице сгруппированы, то агрегаты будут рассчитаны как для всех отображаемых в таблице данных, так и отдельно для каждой группы.

Отображение агрегатов для сгруппированных данных

На рисунке данные о продажах сгруппированы по региону. Суммы числа продаж и среднее значение выручки отображены как для каждого региона (в строках на ярко-желтом фоне), так и для всех продаж в целом (в строке на светло-желтом фоне внизу таблицы).

Если свернуть группы, то можно просматривать только итоговые значения агрегатов для групп и для всех объектов в целом. Агрегаты при этом будут видны только в случае, если они отображаются правее надписи с именем и значением параметра группировки.

Режим отображения только агрегатов для групп

3.10. Редактирование данных в таблице

В таблице данных может редактироваться значение одного свойства одного объекта. Для того чтобы изменить отображаемое в таблице данных значение необходимо выделить требуемый элемент данных щелчком мышью или клавишами со стрелками на клавиатуре, после чего перевести элемент данных в режим редактирования. Это можно сделать одним из двух способов:

  • выполнить двойной щелчок мышью на элементе данных
  • при выделенном активном элементе данных нажать клавишу Enter на клавиатуре

После перевода элемента данных в режим редактирования отображаемый в нем текст будет выделен. Текст может быть отображен на белом или на сером фоне. Справа от текста могут появиться кнопки.

Перевод элемента данных в режим редактирования

На рисунке элемент данных в пятой сверху строке в первой колонке (текст "Белоснежка") переведен в режим редактирования.

Отображение элемента данных в режиме редактирования зависит от типа отображаемого свойства, доступности свойства для изменения и допустимости установленного значения.

  1. Редактирование значения "только для чтения"
    Если текст отображается на сером фоне, это означает, что свойство доступно только для чтения. У Вас нет возможности изменять его значение. Такое значение (или его часть) можно выделить и скопировать при помощи сочетания клавиш Ctrl+Ins или Ctrl+C и затем вставить в доступном для ввода значений месте в этом или в любом другом приложении.

  2. Редактирование недопустимого значения
    Если текст отображается на зеленом фоне, это означает, что установленное в данный момент значение недопустимо. Значение считается недопустимым, в одном из следующих случаев:
    • значение, обязательное для заполнения, не установлено
    • для свойства установлено значение, не удовлетворяющее его типу (например, на приведенном выше рисунке для числового свойства установлено значение, включающее буквы). Форматы, допустимые для значений различных типов, соответствуют локальным настройкам операционной системы Windows
    • длина текста для свойства строкового типа превышает максимально допустимую длину
    • введенное значение больше максимально допустимого или меньше минимально допустимого
    • для свойства, предполагающего выбор из списка или из справочника, установлено значение, не соответствующее ни одному из допустимых значений из списка или справочника
    Пока для свойства не будет установлено допустимое значение, применить выполненное изменение не удастся.

  3. Редактирование значения
    Если в режиме редактирования в ячейке отображается обычный текст на белом фоне, то значение свойства доступно для изменения. Редактирование значения производится при помощи клавиш клавиатуры. Выделенное значение или его часть может быть скопирована и вставлена стандартным образом. При редактировании текста обращайте внимание на тип свойства (строковое, числовое, дата и т.п.). Если введенное значение не будет удовлетворять типу, то оно будет считаться недопустимым и станет отображаться на зеленом фоне. Форматы, допустимые для значений различных типов, соответствуют локальным настройкам операционной системы Windows. После изменения значения необходимо нажать клавишу Enter для того, чтобы применить сделанные изменения.
  4. Если слева от текста в ячейке отображается флажок, это означает, что свойство может иметь одно из двух возможных значений. Одно из значений соответствует установленному флажку, другое - снятому. Если для свойства допустимо пустое значение, то в случае его установки флажок будет отображен на сером фоне и справа от него будет отображен текст "(Нет)".
    Редактирование логического значения "истина" Редактирование логического значения "ложь"
    Изменение значения такого свойства производится либо щелчком мыши по флажку, либо путем нажатия клавиши Пробел на клавиатуре.
  5. Редактирование значения в выпадающем списке
    Если справа от текста отображается кнопка с направленной вниз стрелкой, это означает, что значение свойства должно быть выбрано из списка допустимых значений. Изменять такое значение можно двумя способами:

    • Нажать на кнопку Кнопка выпадающего списка, расположенную справа от текста, в открывшемся выпадающем списке выбрать новое значение.

      Выбор значения из таблицы данных

      На рисунке показан выбор значения из выпадающего списка. Если Вы выбираете значение при помощи мыши, то достаточно выполнить щелчок мышью на нужном значении. Для выбора значения при помощи клавиатуры необходимо воспользоваться клавишами-стрелками "вверх" и "вниз", и когда нужное значение будет выделено, нажать клавишу Enter. Если для свойства допустимо пустое значение, то первым элементом выпадающего списка будет элемент "(Нет)". Если список включает больше восьми элементов, то в нем будет доступна вертикальная полоса прокрутки.

    • Ввести текст, соответствующий нужному элементу списка, с клавиатуры. В процессе ввода будут предлагаться допустимые для выбора значения. Если введенный с клавиатуры текст не будет удовлетворять ни одному из элементов списка, он будет отображен на зеленом фоне, и установить новое значение не удастся. При вводе значения с клавиатуры следите за регистром символов. После ввода нового значения необходимо нажать клавишу Enter.

  6. Редактирование значения с выбором
    Если справа от текста отображается кнопка с тремя точками, это означает, что данное свойство предполагает выбор значения из другой таблицы данных. Изменять такое значение можно двумя способами:

    • Нажать на кнопку Кнопка выбора, расположенную справа от текста; при этом откроется таблица данных, в которой нужно будет выбрать новое значение. В правом нижнем углу этой таблицы данных будут расположены кнопки OK и Отмена. Для выбора значения можно щелкнуть мышью по нужной записи или воспользоваться стрелками на клавиатуре. После выбора нужного значения нажмите кнопку OK. Если Вы не хотите менять ранее установленное значение, нажмите кнопку Отмена.

      Выбор значения из таблицы данных

      На рисунке представлена таблица данных, которая будет отображена для выбора значения свойства, представляющего собой сорт мороженого.

    • Ввести текст, соответствующий нужному значению, с клавиатуры. В процессе ввода будут предлагаться допустимые для выбора значения. Если введенный с клавиатуры текст не будет совпадать ни с одним из допустимых значений, он будет отображен на зеленом фоне, и установить новое значение не удастся. При вводе значения с клавиатуры следите за регистром символов. После ввода нового значения необходимо нажать клавишу Enter.

  7. Редактирование значения с выбором и выпадающим списком
    Если справа от текста отображаются две кнопки - кнопка со стрелкой и кнопка с тремя точками, то можно как выбирать значение из выпадающего списка, так и выбирать значение из таблицы данных (описано выше). В этом случае так же можно вводить текст, соответствующий допустимому значению с клавиатуры. После ввода значения с клавиатуры необходимо нажать клавишу Enter.

  8. Редактирование большого значения

    Если справа от текста отображены три кнопки, а сам текст представляет собой строку "(Данные)" или строку "(Нет)" это означает, что данное свойство представляет собой большой объект. Большой объект может быть текстом, файлом, содержащим изображение, xml-документ, исходный текст программных модулей или просто любые бинарные данные.

    При нажатии на кнопку Кнопка выбора отобразится окно, отображающее и позволяющее редактировать данные, представляющие собой большой объект.

    Окно для редактирования большого объекта

    На рисунке изображено окно, в котором может редактироваться исходный текст метода. После внесения изменений в текст окно редактирования нужно закрыть. Если в тексте действительно произошли изменения, то будет отображено предупреждение:

    Предупреждение окна редактирования большого объекта

    При нажатии кнопки Да окно редактирования будет закрыто, и изменения будут сохранены. При нажатии кнопки Нет окно редактирования будет закрыто, но произведенные изменения сохранены не будут. При нажатии кнопки Отмена окно редактирования останется открытым и работу с текстом можно будет продолжить.

    Копка Кнопка загрузки из файла позволяет загрузить содержимое большого объекта из файла. При нажатии этой кнопки отобразится стандартный диалог открытия файла Windows, в котором можно выбрать нужный файл, после чего нажать кнопку Открыть. При замене содержимого большого объекта новым будет отображено предупреждение:

    Предупреждение при загрузке из файла большого объекта

    Если нажать кнопку Да, то содержание большого объекта будет заменено новым, загруженным из указанного файла. Если нажать кнопку Нет, то содержание большого объекта не изменится

    Кнопка Кнопка сохранения в файл позволяет сохранить содержимое большого объекта в файл. При нажатии этой кнопки отобразится стандартный диалог сохранения файла Windows, в котором необходимо задать расположение и имя файла и нажать кнопку Сохранить. При сохранении файла необходимо явно указать его расширение. При сохранении файла никаких предупреждений не отображается.

    После изменения содержания большого объекта необходимо нажать клавишу Enter.

3.11. Выполнение действий над объектами

Все действия, которые могут быть произведены над объектами, могут быть выполнены одним из трех способов:

  • выбор действия в контекстном меню
  • вызов действия при помощи клавиш клавиатуры - "горячих клавиш" (доступно не для всех действий)
  • вызов действия при помощи иконки на панели инструментов (доступно не для всех действий)

При помощи действий производится добавление, удаление объектов, запуск различных процедур, выполняемых над данными, формирование отчетов.

Перечень всех действий, доступных в текущей таблице данных расположен в контекстном меню, которое отображается при нажатии правой кнопки мыши в зоне таблицы данных. Некоторые из действий выполняются для выбранных объектов (одного или нескольких), например, действие "Удалить". Для выполнения других действий выбор конкретного объекта не нужен, например, для действия "Добавить". Выбор действия в контекстном меню может производиться как при помощи мыши, так и при помощи стрелок на клавиатуре.

Если для действия установлены " горячие клавиши ", то из обозначения можно будет увидеть в правой части пункта контекстного меню. Действия могут вызываться как при нажатии одной клавиши, так и при помощи сочетания клавиш.

В некоторых пунктах контекстного меню может быть расположена стрелка Стрелка раскрытия контекстного меню. При выборе такого пункта никакого действия не выполняется, а открывается " подменю ", содержащее другие действия.

Выполнение действий над объектами при помощи контекстного меню

На рисунке изображено контекстное меню, отображающее все действия, доступные над объектом, соответствующим студенту Алехиной Елене Михайловне. Действиям "Добавить студента-специалиста", "Удалить" и "Обновить" соответствуют "горячие клавиши". Пункты меню "Перемещения", "Колонка", "Выбранные" имеют подменю. На рисунке открыто подменю пункта "Перемещения".

Для некоторых действий могут быть установлены изображения-иконки. В этом случае иконки отображаются на панели инструментов (подробнее в разделе 4.13. "Работа с панелью инструментов").

Если выполнение процедуры или отчета требует задания параметров, то при вызове действия отобразится форма задания параметров. Для выполнения действия необходимо заполнить поля формы и нажать кнопку OK (подробнее в разделе 6 "Работа с формой задания параметров").

Перед выполнением некоторых действий может быть отображено предупреждение. Например, перед удалением объекта может отображаться следующее окно:

Предупреждение при выполнении действия

Если в таком окне нажать кнопку Да, то действие будет выполнено. Если нажать кнопку Нет, то действие будет отменено.

3.12. Работа с панелью инструментов

На панели инструментов отображаются иконки, соответствующие доступным пользователю действиям и формам. Иконки могут иметь подписи, соответствующие наименованием действий или форм. Вызов действий или переключение между активными формами осуществляется при помощи щелчка мышью на одной из иконок. Если иконок много и они не помещаются на панели инструментов по ширине, то слева или справа отображаются кнопки прокрутки. Для прокрутки содержимого панели инструментов достаточно подвести указатель мыши к кнопке прокрутки.

На рисунке представлен пример панели инструментов. Иконки с подписями "Создать", "Удалить", "Колонка", "Выбранные", "Перенос в Excel" соответствуют доступным в текущей таблице данных действиям. Иконки с надписями "Системная форма" и "Продажи мороженого" соответствуют доступным пользователю формам. Справа от иконки "Продажи мороженого" расположена кнопка прокрутки. Подведя указатель мыши к этой кнопке, можно увидеть иконки, расположенные правее и не поместившиеся на панели инструментов.

Некоторые кнопки панели инструментов могут иметь выпадающие кнопки. Выпадающие кнопки соответствуют пунктам подменю контекстного меню. Справа от кнопок, имеющих выпадающие кнопки, расположена направленная вниз стрелочка. Если нажать мышью на эту стрелочку, то отобразится панель с выпадающими кнопками. На рисунке кнопки "Колонка" и "Выбранные" имеют выпадающие кнопки.

Панель выпадающих кнопок

Как и в контекстном меню, на панели инструментов некоторые кнопки могут быть недоступны. Доступность кнопки зависит от того, какие объекты в настоящий момент выделены, и от применимости действия к выделенным объектам.

3.13. Стандартные действия, доступные в любых таблицах данных

Ряд стандартных действий, доступных объектов любого типа, может быть вызван из любой таблицы данных. Разработчиком конкретной прикладной системы некоторые из перечисленных в данном разделе действий могут быть скрыты. Также перечень доступных стандартных действий зависит от прав доступа конкретного пользователя.

Взаимное расположение, наименования и доступность стандартных действий могут зависеть от реализации прикладной системы. В следующих разделах описаны все стандартные действия, реализованные средствами платформы.

3.13.1. Копирование и вставка объектов

Объекты, отображаемые в таблице данных, можно копировать и вставлять. Вставлять объекты можно как в ту же таблицу данных, из которой они были скопированы, так и в другую таблицу данных, отображающую объекты того же типа. Для этого необходимо выполнить следующие действия:

  1. Выбрать один или несколько объектов, которые Вы хотите скопировать (см. раздел 4.3. "Выбор объектов в таблице данных").
  2. Вызвать действие "Копировать" из контекстного меню или при помощи иконки на панели инструментов.
  3. Перейти в таблицу данных, в которую Вы хотите вставить скопированные объекты.
  4. Вызвать действие "Вставить" из контекстного меню или при помощи иконки на панели инструментов.

При копировании и вставке происходит создание копии объекта. Все свойства нового объекта, кроме свойства "Имя" (или замещающего его свойства), будут такими же, как у первичного объекта. Свойство имя будет равно строке, составленной из слова "Копия " и имени первичного объекта. После вставки объекта значение свойства "Имя" можно изменить.

Действия "Копировать" и "Вставить" имеют соответствующие иконки на панели инструментов:
Кнопка "копировать" Кнопка "вставить"

3.13.2. Подменю "Колонка" - работа с колонкой

Действия, доступные в подменю "Колонка" в контекстном меню или на панели инструментов могут быть применены к колонкам любой таблицы данных. Доступность тех или иных действий над колонкой зависит от типа данных, отображаемых в колонке, и от того, какие действия над колонкой уже совершены (например, нельзя вычислить сумму значений строкового типа, или нельзя очистить группировку, если данные не сгруппированы).

Иконка "Колонка" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с колонкой

Действия, доступные в подменю "Колонка", описаны в разделах 4.6. "Скрытие и отображение колонок", 4.8. "Группировка данных в таблицах", 4.10. "Отображение итоговых значений (агрегатов) по колонкам".

3.13.3. Подменю "Выбранные" - работа с выбранными объектами

Действия, доступные в подменю "Выбранные" позволяют быстро отбирать и снимать отбор с объектов, а также устанавливать режим отображения в таблице данных только тех объектов, которые помечены как выбранные.

Иконка "Выбранные" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с выбранными объектами

Назначение этих действий описано в разделе 4.3. "Выбор объектов в таблице данных".

3.13.4. Перенос в Excel

Данные, отображаемые в любой из таблиц данных, могут быть перенесены в MS Excel. При этом в MS Excel будут сохранены все настройки отображения данных (сортировка по одной или нескольким колонкам, группировка, отображение итоговых значений). Действие "Перенос в Excel" может быть вызвано из контекстного меню или при помощи иконки на панели инструментов. С данными, перенесенными в MS Excel, далее могут производиться любые манипуляции средствами этого приложения.

Если в таблице много записей, то перенос данных в Excel может занять некоторое время. Если это время превышает 10 сек., то отобразится окно, сообщающая, что система находится в работе. В этом окне будет отображен индикатор процесса переноса данных:
Индикатор прогресса переноса данных в Excel

Действие "Перенос в Excel" имеет соответствующую иконку на панели инструментов:
Кнопка переноса в Excel

3.13.5. Экспорт данных

Отображаемые в таблицах данных объекты могут быть экспортированы в виде xml-документа. Для того, чтобы осуществить экспорт объектов, необходимо выполнить следующее:

  1. Выбрать объекты, подлежащие экспорту (см. раздел 4.3. "Выбор объектов в таблице данных").
  2. Вызвать действие "Экспортировать" из контекстного меню или при помощи иконки на панели инструментов.
  3. В открывшемся окне сохранения файла указать местоположение и имя файла. Дать файлу расширение .xml.

3.13.6. Обновление данных таблицы

После выполнения действий над различными объектами, хранящимися в системе, их новое состояние может сразу не отобразиться в таблице данных. Для того чтобы получить из базы данных последние актуальные данные необходимо воспользоваться действием "Обновить", которое доступно в контекстном меню, при помощи иконки на панели инструментов, а также может быть доступно при нажатии клавиши F5.

Действие "Обновить" имеет соответствующую иконку на панели инструментов:
Кнопка обновления набора данных

3.13.7. Доступ к настройкам системы

При наличии соответствующих прав доступа Вы можете просматривать и изменять настройки системы. Доступ к меню настроек осуществляется при помощи действия "Настройки", которое может быть вызвано из контекстного меню или при помощи иконки на панели инструментов. При вызове этого действия отобразится форма задания настроек. Эта форма аналогична форме задания параметров (см. раздел 6 "Работа с формой задания параметров"). Если Вы имеете права администратора системы, то форма задания настроек, кроме кнопок OK и Отмена, будет иметь кнопку "По умолчанию". При нажатии этой кнопки значения, установленные в полях формы станут значениями настроек по умолчанию.

Форма задания настроек системы

Если в системе нет доступных для текущего пользователя настроек, то при вызове действия "Настройки" отобразится окно:
Сообщение об отсутствии доступных настроек

Действие "Настройки" имеет соответствующую иконку на панели инструментов:
Кнопка формы настроек

3.13.8. Дополнительные действия, доступные в иерархических таблицах данных

В иерархических таблицах данных дополнительно доступны действия, позволяющие управлять раскрытием и свертыванием элементов иерархии. Эти действия расположены в подменю "Дерево". Иконка "Дерево" на панели инструментов имеет выпадающие кнопки:
Кнопки подменю работы с иерархией

При помощи этих действий можно управлять отображением дерева иерархически организованных объектов следующим образом:

  • Развернуть все - все элементы дерева будут раскрыты.
  • Свернуть все - все дочерние элементы будут свернуты. Отображенными останутся только элементы первого уровня (не имеющие родительских элементов).
  • Развернуть от выбранного - узел дерева, соответствующий выбранному объекту и все его дочерние узлы будут раскрыты.
  • Свернуть к выбранному - узел дерева, соответствующий выбранному объекту у все его дочерние узлы будут свернуты.
  • Свернуть к этому уровню - все узлы дерева, лежащие на том же уровне, что и выбранный объект или на более низких уровнях будут свернуты.
  • Выделить дочерние - все объекты, дочерние по отношению к выбранному, будут выделены.

4. Работа с Инспектором объектов

4.1. Отображение свойств Инспектором объектов

Инспектор объектов предназначен для просмотра и редактирования свойств одного или нескольких объектов, выбранных в активной таблице данных. Инспектор объектов имеет две колонки. В левой колонке отображаются наименования свойств, в правой колонке отображаются значения свойств. Набор отображаемых свойств и их значений зависит от того, сколько объектов каких типов выбрано в текущей таблице данных (подробнее о выборе объектов см. раздел 4.3. "Выбор объектов в таблице данных"). Свойства выбранных объектов отображаются Инспектором объектов по следующим правилам:

  1. Если в таблице данных выбран один объект, то в Инспекторе объектов отображаются все свойства этого объекта, видимые пользователю.
  2. Если в таблице данных выбрано несколько объектов, то
    • Инспектор объектов будет иметь строки, соответствующие только тем свойствам, которые есть у всех выделенных объектов;
    • если у всех выделенных объектов значение свойства одинаково, то это значение будет отображено в правой колонке; в противном случае в правой колонке будет отображено пустое значение.
  3. При изменении значения свойства в Инспекторе объектов новое значение будет установлено для всех выделенных объектов.

Выбран один объект - вид на инспектор объектов
Выбран один объект - вид на таблицу

На рисунке представлен пример таблицы данных, отображающей учитываемые в системе сорта мороженого. Среди сортов мороженого есть как обычные сорта, так и сорта фруктового мороженого, дополнительно обладающие свойством "Фрукт". В таблице данных выделен один объект, соответствующий сорту фруктового мороженого "Тропический рай". При этом Инспектор объектов отображает все свойства данного объекта (в том числе свойство "Фрукт").

Выбрано несколько объектов - вид на инспектор объектов

Выбрано несколько объектов - вид на таблицу

На рисунке в той же таблице данных выбрано два объекта: сорт мороженого "Тропический рай" (фруктовое мороженое) и сорт "Белый Бим черное ухо" (обычное мороженое). При этом в Инспекторе объектов отображаются только те свойства, которые являются общими для выделенных объектов (свойство "Фрукт" не отображается). Значения свойств "Вид упаковки" и "Вес" для выбранных объектов одинаковы, поэтому их значения отображены в правой колонке Инспектора объектов. Значения остальных свойств для данных объектов различны, поэтому для этих свойств отображаются пустые значения. Если изменить одно из свойств в Инспекторе объектов, то новое значение будет установлено как для сорта мороженого "Тропический рай", так и для сорта мороженого "Белый Бим черное ухо".

Порядок отображения свойств в Инспекторе объектов устанавливается разработчиком прикладной системы. Также разработчиком прикладной системы может быть установлено отнесение свойств к категориям. В этом случае свойства могут отображаться сгруппированными по категориям. Слева от наименования каждой категории будет отображен значок Свернутый узел дерева или Развернутый узел дерева. Нажатием мышью на значок Развернутый узел дерева свойства, входящие в категорию, можно свернуть, нажатием на значок Свернутый узел дерева их можно снова отобразить.

Отображение Инспектором объектов свойств, сгруппированных по категориям

На рисунке представлен пример отображения Инспектором объектов свойств объекта, соответствующего дисциплине учебного плана студентов. Свойства, отнесенные к категориям "Формы текущего контроля" и "Распределение аудиторных часов по модулям", свернуты. Свойства, отнесенные к категории "Учебные часы" раскрыты.

В связи с тем, что выбор свойств объектов для отображения, получение и сравнение их значений происходит по специальному алгоритму, в случае одновременного выбора большого числа объектов скорость работы Инспектора объектов может снижаться. Если на вычисление значения общего свойства группы объектов требуется значительное время, то такое свойство может отображаться как свойство с отложенным вычислением. Для такого свойства в правой колонке вместо значения может отображаться строка (...). При активизации этого свойства справа отобразится кнопка со знаком вопроса Кнопка вычисления отложенного свойства. Если нажать на эту кнопку, то значение свойства будет определено и отображено.

Свойство с отложенным вычислением

4.2. Управление положением Инспектора объектов на экране и порядком отображения свойств

Инспектор объектов отображается в отдельном окне. Это окно можно перетаскивать по экрану за заголовок, изменять его размеры стандартным для операционной системы Windows образом. На панели инструментов всегда присутствует иконка Инспектора объектов, при нажатии которой можно отобразить окно Инспектора (если оно не видимо) и сделать его активным:
Кнопка инспектора объектов

При нажатии правой кнопки мыши в левом столбце Инспектора объектов или в свободном нижнем поле доступно контекстное меню Инспектора объектов. При помощи действий, расположенных в этом меню можно управлять режимом работы окна Инспектора и порядком отображения свойств.

Контекстное меню инспектора объектов

Выбор одного из пунктов контекстного меню переводит Инспектор объектов в новый режим работы. После этого рядом с пунктом меню отображается галочка Флажок в контекстном меню или точка Радиокнопка в контекстном меню. При повторном выборе помеченного пункта меню соответствующий режим работы отменяется и отметка снимается. Доступные пункты контекстного меню позволяют устанавливать следующие режимы работы Инспектора объектов.

  • При выборе пункта меню Всегда наверху окно Инспектора объектов будет всегда отображаться на переднем плане независимо от переключения между активными таблицами данных.
  • Если выбрать пункт меню Прозрачное окно, то окно Инспектора объектов станет полупрозрачным.
  • Если выбрать пункт меню Показать скрытые свойства, то кроме свойств, отображаемых в обычном режиме (свойства, созданные разработчиком прикладной системы как " видимые ") будут отображены свойства объектов, " невидимые " пользователю.
  • Пункт меню Сортировать по алфавиту позволяет отображать свойства не в порядке, установленном разработчиком прикладной системы, а в алфавитном порядке их наименований. Такой режим работы удобен в случае, если необходимо найти свойство по его наименованию.
  • Пункты подменю Группировка позволяют:
    • Группировать по категории - свойства будут отображены сгруппированными по категориям (показано на рисунке);
    • Группировать по классу - свойства будут отображены сгруппированными по классу объектов, членами которого они являются;
    • Не группировать - свойства будут отображены без группировки.

4.3. Редактирование значений свойств при помощи Инспектора объектов

При помощи Инспектора объектов удобно изменять значения свойств одного или одновременно нескольких выбранных объектов (о выборе объектов см. раздел 4.3. "Выбор объектов в таблице данных"). Одно из свойств, отображаемых в Инспекторе объектов, всегда является активным. Активное значение выделяется в Инспекторе объектов рамкой, его значение отображается в режиме редактирования.

Отображение свойств в режиме редактирования и способы изменения значений свойств аналогичны редактированию данных в таблице данных (см. раздел 4.11. "Редактирование данных в таблицах"). Отличие работы Инспектора объектов заключается в том, что с его помощью можно изменять значение свойства сразу нескольких выбранных объектов.

5. Работа с формой задания параметров

Форма задания параметров используется для организации диалога с пользователем по заданию параметров, необходимых для выполнения метода или формирования отчета. Форма задания параметров открывается при вызове действия, для выполнения которого необходимо задать параметры.

Форма задания параметров представляет собой форму, содержащую поля различного вида. В правом нижнем углу формы расположены кнопки ОК и Отмена.

Форма задания параметров

Слева или сверху от каждого поля расположено его наименование. Наименования поля отражает, какие данные должны быть в него введены. Поля формы объединяются в группы. Группы полей могут располагаться в столбцах или на закладках. На рисунке выше поля формы расположены в двух столбцах. Если поля расположены на закладках, то в верхней части формы отображаются заголовки закладок с их наименованиями.

Расположение полей формы на закладках

На рисунке представлена та же форма, что и на рисунке выше, но с расположением параметров на закладках.

Порядок отображения полей на форме, а также способ их отображения (в столбцах или на закладках) задается разработчиком прикладной системы. Переход от одного поля к другому может осуществляться либо щелчком мышью на новом поле, либо при помощи клавиши Tab на клавиатуре. Переключаться между закладками можно путем нажатия мышью ни их заголовок.

Для выполнения действия, требующего задания параметров, необходимо заполнить все обязательные поля формы. После установления допустимых значений все поля формы должны приобрести белый фон. При этом условии кнопка OK станет доступной. После нажатия кнопки OK будет выполнен вызываемый метод или сформирован отчет. Если Вы хотите отменить выполнение действия, нажмите кнопку Отмена.

Поля формы могут иметь белый, зеленый или серый фон, а также могут иметь различный внешний вид. Цвет фона зависит от доступности для изменения и допустимости введенного в поле значения. Внешний вид поля зависит от типа данных, которые должны быть в него введены. Возможны следующие варианты внешнего вида полей и способ установления в них значений:

  1. Если поле имеет серый фон, то его значение недоступно для изменения. Такие поля используются для отображения дополнительной информации. Значения в таких полях могут изменяться автоматически при установке новых значений в других полях формы.
    Редактирование значения "только для чтения" на форме
  2. Обычное поле отображается в случае, когда в него должно быть введено строковое значение длиной до 128 символов, целочисленное, вещественное (с целой и дробной частью) значение, значение типа даты, времени, или даты со временем
    Редактирование недопустимого значения на форме
    В таком поле можно вводить текст с клавиатуры, копировать и вставлять его. Введенные в такое поле символы проверяются на соответствие типу данным (на основе локальных настроек компьютера) и на удовлетворение значения дополнительным условиям, которые могут быть установлены разработчиком прикладной системы. В случае если введенный набор символов соответствует недопустимому для данного поля значению, поле приобретет зеленый фон.
    Редактирование значения на форме - установлено допустимое значение
    Редактирование недопустимого значения даты на форме - установлено недопустимое значение.
  3. Для ввода строковых значений, длина которых может превышать 128 символов, отображаются расширенные поля ввода:
    Редактирование длинной строки на форме
    В таком поле можно вводить текст с клавиатуры, копировать его и вставлять. Также в таком поле может вводится многострочный текст. Перенос строки осуществляется нажатием клавиш Ctrl+Enter. Если текст имеет большое число строк, для его просмотра используется вертикальная полоса прокрутки.
  4. Для выбора значения из двух возможных вариантов используется поля, в котором отображается флажок и текстовое значение.
    Редактирование логического значения на форме
    Изменение значения в таком поле может производиться либо щелчком мыши по флажку, либо при помощи клавиши Пробел на клавиатуре. Если в данном поле пустое значение недопустимо, то переключение происходит между двумя возможными значениями (например, для поля "Пол" между значениями "Муж." и "Жен."). Если пустое значение допустимо, то переключение происходит между тремя вариантами: двумя значениями и пустым значением, для которого отображается строка "(Нет)".
  5. Если значение поля должно быть установлено путем выбора из списка допустимых значений, то в правой части поля отображается кнопка с направленной вниз стрелкой.
    Редактирование значения из выпадающего списка на форме
    Установление значения в таком поле может производиться либо при помощи выбора из выпадающего списка, открывающегося при нажатии на кнопку Кнопка выпадающего списка, либо путем ввода с клавиатуры текста, соответствующего выбираемому значению. В процессе ввода будут предлагаться допустимые варианты.
  6. Если поле предполагает ввод большого объекта, то оно отображается следующим образом:
    Редактирование большого значения на форме
    Если в поле значение не установлено, то отображается текст "(Нет)". Если значение установлено, то отображается текст "(Данные)". В правой части поля ввода расположено три кнопки:
    • Кнопка выбора при нажатии этой кнопки будет отображено окно редактирования текста большого объекта;
    • Кнопка загрузки из файла при нажатии этой кнопки большой объект можно загрузить из файла при помощи стандартного диалога открытия файла Windows;
    • Кнопка сохранения в файл при нажатии этой кнопки большой объект можно сохранить в файл при помощи стандартного диалога сохранения файла Windows.
  7. Если поле предполагает выбор объекта из другой таблицы данных, то в правой части поля отображается кнопка с тремя точками или кнопка со стрелкой и кнопка с тремя точками.
    Редактирование значения с выбором на форме
    Выбор значений в таком поле производится путем нажатия на одну из кнопок:
    • Кнопка выпадающего списка при нажатии данной кнопки отображается выпадающий список объектов которые могут быть выбраны в данном поле;
    • Кнопка выбора - при нажатии данной кнопки будет открыта таблица данных, и в ее правом нижнем углу будут расположены кнопки OK и Отмена. В открывшейся таблице нужно выбрать один объект, после чего нажать кнопку ОК.

При работе с формой задания параметров рекомендуется устанавливать в полях значения в порядке их следования на форме. Разработчиком прикладной системы может быть установлена зависимость между значениями полей. В этом случае при изменении значения в одном из полей, в других полях значения также могут автоматически измениться. Допустимость значений в одних полях может зависеть от того, какие значения установлены в других полях.

Также необходимо помнить о том, что кнопка ОК на форме задания параметров станет доступной только тогда, когда во всех полях будут установлены допустимые значения.

6. Формирование отчетов Microsoft Excel

Формирование отчетов, выгружаемых в MS Excel происходит при помощи вызова действий в таблицах данных (подробнее о вызове действий см. раздел 4.12 "Выполнение действий над объектами"). При вызове отчета на выполнение может отобразиться форма задания параметров отчета. Поля этой формы необходимо заполнить, после чего нажать кнопку ОК (подробнее о работе с формой задания параметров см. раздел 6. "Работа с формой задания параметров").

Отчеты, выгружаемые в MS Excel, как правило, имеют иконки на панели инструментов, характерные для рабочих книг Excel:
Кнопка формирования отчета Microsoft Excel

При запуске отчета на исполнение происходит создание рабочей книги Excel, в которую передаются данные, хранящиеся в базе данных. Рабочая книга может содержать данные, диаграммы, интерактивные элементы управления, и проч.. Далее средствами MS Excel могут осуществляться любые доступные действия с рабочей книгой.

Отчеты в MS Excel используются для вывода на печать документов и стандартных форм отчетности. Шаблоны отчетов создаются разработчиками прикладной системы.

Полученный в результате формирования отчета файл MS Excel может далее использоваться для дальнейшей работы с данными, может быть распечатан, сохранен, отправлен по электронной почте и т.п.

7. Формирование отчетов в виде HTML-документов

В целях публикации отчетной информации в Internet средствами системы могут формироваться отчеты в виде HTML-документов. Формирование таких отчетов происходит путем вызова действий в таблицах данных (подробнее о вызове действий см. раздел 4.12 "Выполнение действий над объектами"). При вызове отчета на выполнение может отобразиться форма задания параметров отчета. Поля этой формы необходимо заполнить, после чего нажать кнопку ОК (подробнее о работе с формой задания параметров см. раздел 6. "Работа с формой задания параметров").

Отчеты, формируемые в виде HTML-документов, как правило имеют иконки на панели инструментов, характерные для приложения MS Internet Explorer:
Кнопка формирования XSLT-отчета

В результате работы отчета создается HTML-документ, который может содержать таблицы с данными, рисунки, ссылки и проч. Сформированный документ показывается при помощи приложения Internet Explorer. Полученный html-файл может быть опубликован в Internet, сохранен, распечатан и т.д.

Сформированный html-документ сохраняет связь в базой данных. Если в ранее открытом документе выполнить процедуру обновления, по документ отобразит последнюю версию хранящихся на сервере БД данных.

8. Взаимодействие с разработчиком в случае ошибок, проблем, вопросов по работе системы

В ситуациях, когда в работе системы происходят ошибки, когда система ведет себя неожиданным для пользователя образом, наблюдаются проблемы с быстродействием или другими аспектами работы системы, если у пользователей возникают вопросы, не освещенные в Руководстве пользователя, возникает необходимость обратиться к разработчику. Для того, чтобы разработчик мог решить проблему или ответить на вопрос быстро, полно и компетентно, ему нужно предоставить информацию о среде работе системы, о решаемых пользователем задачах, последовательности действий пользователя, приведших к проблемной ситуации.

Общими принципами сбора информации для обращения к разработчику должны быть:

  1. Необходимо быть готовым изложить последовательность действий пользователя в системе, начиная с открытия системы до ситуации, приводящей к ошибке, проблемной ситуации или ситуации, вызывающей вопрос.
  2. Если ошибка или проблема имеет визуальное проявление, нужно сделать скриншот (снимок) экрана. Желательно предоставлять скриншот всего экрана компьютера, а не только активного окна приложения, это даст разработчику дополнительную полезную информацию. Скришот экрана при работе в операционной системе MS Windows можно получить путем одновременного нажатия клавиш Ctrl + Print Screen (PrtScr) и последующей вставки (сочетание клавиш Shift + Ins) в какое-либо графическое приложение, например, программу Paint.
  3. Если ошибка заключается не в отображении специального окна с сообщением об ошибке, а в том, что результат работы системы является, с точки зрения пользователя, некорректным, то нужно быть готовым изложить, каким должен быть корректный результат, и чем именно результат работы системы некорректен.
  4. Если ошибка, проблема или вопрос связаны с работой третьесторонних приложений (например, отчеты, формируемые в MS Excel или MS Word, работа web-приложений системы посредством интернет-браузеров), нужно быть готовым предоставить информацию о версии третьесторонних приложений.
  5. Нужно быть готовым предоставить информацию о конфигурации рабочего места пользователя, версии операционной системы, установленном программном обеспечении и его версии, включая средства анитивирусной защиты.

Для сбора информации, необходимой разработчику для решения проблем, система предоставляет ряд средств: Приложение Отладочный монитор, возможность получения файла, содержащего информацию об ошибке, также ниже приведены рекомендации по получению информации о третесторонних приложениях.

8.1. Приложение Отладочный монитор

Приложение Отладочный монитор (DebugView.exe) устанавливается при установке платформы в любой конфигурации, предусмотренной по умолчанию, включая конфигурацию "Рабочее место пользователя". Открыть приложение можно при помощи иконки:

Иконка Debug Monitor

Когда приложение Отладочный монитор запущено, приложение Обозреватель данных выводит в него поток сообщений о действиях и событиях, происходящих в системе. В Отладочный монитор попадают все sql-запросы, направляемые с рабочего места пользователя на сервер баз данных (в случае удаленного подключения - html-запросы, направляемые на сервер приложений), информационные сообщения, предупреждения, отладочная информация, сообщения об ошибках и прочие данные.

Для того, чтобы собрать и передать разработчику информацию об ошибке или проблемной ситуации при помощи Отладочного монитора, нужно выполнить следующие действия:

  1. Закрыть приложение Обозреватель данных, если оно было открыто.
  2. Запустить приложение Отладочный монитор. Если это приложение уже было открыто, то выполнить очитку всех имеющихся в нем сообщений при помощи кнопки Очистить.
  3. В приложение Обозреватель данных выполнить всю последовательность действий, приводящих в появлению ошибки или проблемной ситуации.
  4. После возникновения ошибки или проблемной ситуации в приложении Отладочный монитор нажать кнопку Сохранить в файл, выбрать место сохранения и задать имя файла. Файл будет сохранен в формате.txt.
  5. Отправить полученный.txt-файл разработчику в составе других информационных материалов, которыми должны быть:
    • Словесное описание проблемы и способа ее воспроизведения
    • Один или несколько скриншотов экрана, иллюстрирующих проблему

После получения информации, состав которой описан в пункте 5, разработчик может запросить дополнительную информацию о проблеме.

8.2. Получение файла, содержащего информацию об ошибке

В ходе работы с системой могут отображаться специальные окна с информацией об ошибках. Эти окна могут быть двух видов:

  1. Окно с информацией о недопустимом действии пользователя (окно с шапкой синего цвета):

    Окно ошибки. Синяя шапка.

    Как правило, отображение такого окна с информацией об ошибке свидетельствует не об ошибке в функциональности системы, а о том, что пользователем выполнено недопустимое действие. Информация о том, в чем именно действие не допустимо, содержится в тексте, отображаемом в окне. Например, на приведенном выше скриншоте мы видим окно с ошибкой, отображено после попытки пользователя создать в справочнике "Уровни образования и курсы" второй записи с именем "1 курс", подчиненной родительской записи "Бакалавриат", что недопустимо. Поэтому сообщение об ошибке говорит о дублировании объекта по полю Имя.

    Информация, отображаемая в окне данного вида, предназначена для пользователя. Вы можете направить информацию о такой ошибке разработчику в случае, если сообщение об ошибке непонятно, либо если считаете, что выполненное пользователем действие должно быть допустимым, и ошибка системы в том, что действие было расценено как недопустимое.

    При отображении окна данного вида пользователь может продолжить работу, нажав на кнопку Продолжить. При необходимости обратиться в данной ситуации к разработчику до нажатия кнопки Продолжить необходимо получить и сохранить информацию, необходимую разработчику для анализа ситуации, при помощи ссылок "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки". Подробнее о сохранении этой информации написано ниже.

  2. Окно с информацией об ошибке системы (окно с шапкой красного цвета).

    Окно ошибки. Красная шапка.

    При возникновении ситуации, сопровождающейся появлением такого окна, необходимо получить и сохранить информацию, необходимую разработчику для анализа ситуации, при помощи ссылок "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки". Подробнее о сохранении этой информации написано ниже.

    После сохранения информации об ошибке можно попытаться продолжить работу, нажав кнопку Продолжить. В некоторых случаях, в зависимости от характера произошедшей ошибки, продолжение работы может оказаться невозможным, в таких случаях нужно нажать кнопку Закрыть приложение. После того, как приложение будет закрыто, его можно будет открыть снова и продолжить работу.

Сохранение информации для направления разработчику.

Информация, которая поможет разработчику решить проблему, не отображается в самом окне, поэтому направлять разработчику скриншот именно этого окна не имеет смысла. Для получения необходимой для разработчика информации в окнах с сообщением об ошибке обоих видов расположены ссылки "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки".

По ссылке Показать информацию для службы поддержки информация отображается в том же окне. Весь текст изначально выделен, его можно сразу скопировать и вставить в текстовый файл, в тело письма и т.д. Данный текст содержит сам текст ошибки, а также информацию об операционной системе пользователя и ее версии, загруженных модулях, переменных окружения и проч.

Информация для службы поддержки

При помощи ссылки Сформировать файл для службы поддержки можно собрать в удобном виде наиболее полную и полезную для разработчика информацию. После нажатия на ссылку будет предложен диалог сохранения файла. По умолчанию файлу будет дано имя ExceptionInfo.err. Это имя можно изменить, но расширение необходимо файла сохранить. После выбора места сохранения и имени файла и нажатия кнопки Сохранить, система отобразить предупреждение:

Предупреждение при сохранении файла для службы поддержки

К данному предупреждению нужно отнестись ответственно - отправлять полученный файл только на адреса службы поддержки системы в вашей организации или на официальный контактный адрес разработчика (если вы взаимодействуете с разработчиком напрямую). После отправки этот файл необходимо удалить.

Предоставление разработчику информации в виде.err-файла - это самый удобный и надежный вариант взаимодействия, который даст возможность разработчику решить проблему или ответить на вопрос наиболее эффективным и быстрым образом. Данный файл содержит все виды информации, которые могут быть собраны другими способами:

  • Информацию об ошибке, которая отображается по ссылке "Показать информацию для службы поддержки"
  • Сообщения Отладочного монитора, собранные за некоторое время до возникновения ошибки
  • Скриншоты экрана пользователя, включая скриншот окна с информацией об ошибке.

При отправке файла разработчику дополнительно нужно описать последовательность действий, приведших к ошибке или ситуации, вызывающей вопросы. После получения файла и дополнительной информации, разработчик может попросить предоставить дополнительную информацию о проблемной ситуации, о конфигурации рабочего места пользователя, прочем установленном на рабочем месте ПО и проч.

Если вы хотите обратиться к разработчику по поводу ситуации, которая не сопровождается отображением окна с ошибкой, то.err-файл можно получить следующим образом: нужно кликнуть левой кнопкой мыши по иконке с мельницей в левом углу заголовка окна текущей формы и из выпадающего меню выбрать пункт Сохранить файл для службы поддержки.

Получение файла для службы поддержки

8.3. Получение информации о третесторонних приложениях

В случае, если ошибка произошла при взаимодействии системы с третьесторонним приложением, например, при выполнении отчета MS Excel, MS Word, pdf, при работе web-приложений системы через интернет-браузер, разработчику, в дополнение к файлу с информацией об ошибке, понадобится информация о версии третьестороннего приложения, при взаимодействии с которым произошла ошибка.

Получить информацию о версии приложения можно, как правило, в окне О программе ("About box"), которое в большинстве программных продуктов представлено в пункте меню Справка.

Разработчику в составе информационных материалов нужно отправить скриншот этого окна.

В продуктах семейства Microsoft Office вызвать окно О программе можно разными способами в зависимости от версии MS Office. В программных продуктах версий до 2003 включительно это окно доступно в меню Справка / О программе. В программных продуктах версий 2007 и выше вызвать это окно можно следующим образом:

  1. В меню Файл открыть выпадающий список доступных действий и нажать кнопку Параметры Excel :
    Параметры Excel
  2. В открывшемся окне выбрать раздел Ресурсы, в правой части окна нажать кнопку О программе :
    Вызов окна О программе Excel

Окно О программе в случае MS Excel выглядит следующим образом:

Окно О программе Excel

В программе Acrobat Reader окно О программе можно вызвать из меню Справка / О программе :

Вызов окна О программе Acrobat Reader

В интернет-браузерах окно "О программе" (О Google Chrome, О FireFox, О Internet Explorer) также можно вызвать из меню Справка. Строка меню в интернет-браузерах часто бывает по умолчанию скрыта. Для того, чтобы ее отобразить, нужно нажать клавишу Alt на клавиатуре.


Мельница данных ((раздел целиком))

Мельница данных- Класс TContextKey (Ключи контекстной помощи) (раздел целиком) (22.10.2024) (одним файлом)
Класс TContextKey (Ключи контекстной помощи)

Класс TObject (Объекты)

Объекты класса не именованы.

1. Свойства

Свойства класса TContextKey:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Storage | string[64] | Да | Видимо пользователю | Чтение/Запись | Хранилище
LinkedObject | TObject | Нет | Видимо пользователю | Чтение/Запись | Связанный объект
LinkedObjectClass | TClass | Да | Скрыто от пользователя | Только для чтения | Класс связанного объекта
LinkedObjectMaster | TObject | Да | Скрыто от пользователя | Только для чтения | Мастер связанного объекта

2. Конструктор Create (Конструктор ключа)

Конструктор класса TContextKey.

1constructor TContextKey.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Storage: string[64]; LinkedObject: TObject): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да | Ключевое словосочетание
Class | TClass | Нет | Унаследовано от TObject.Create
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Storage | string[64] | Да | Хранилище
LinkedObject | TObject | Нет | Связанный объект

Замечания:

Создает новый объект класса TContextKey.

3. Метод GenerateAllKeys (Сгенерировать ключи)

Метод класса (статический метод) класса TContextKey.

class procedure TContextKey.GenerateAllKeys(Storage: string[64]);

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Storage | string[64] | Да | Хранилище


Мельница данных ((раздел целиком))

Мельница данных- Класс TUserNotificationShown (Показы уведомлений) (раздел целиком) (22.10.2024) (одним файлом)
Класс TUserNotificationShown (Показы уведомлений)

Класс TObject (Объекты)Класс TUserNotification (Уведомления)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TUserNotificationShown:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TUserNotification | Да | Скрыто от пользователя | Только для чтения | Уведомление
Type | TNotificationType | Да | Видимо пользователю | Только для чтения | Тип уведомления
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
User | TUser | Да | Видимо пользователю | Только для чтения | Пользователь
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время

2. Конструктор Create (Конструктор показа уведомления)

Конструктор класса TUserNotificationShown.

1constructor TUserNotificationShown.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет

Замечания:

Создает новый объект класса TUserNotificationShown.


Мельница данных ((раздел целиком))

Мельница данных- Класс TBlobDomain (Большие объекты) (раздел целиком) (22.10.2024) (одним файлом)
Класс TBlobDomain (Большие объекты)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

1. Свойства

Свойства класса TBlobDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
BlobSubtype | TBlobSubtype | Да | Видимо пользователю | Чтение/Запись | Подтип
Extension | string[10] | Нет | Видимо пользователю | Чтение/Запись | Расширение
ShowInPlace | Boolean | Да | Видимо пользователю | Чтение/Запись | Редактировать по месту
EditorClassID | string[128] | Нет | Видимо пользователю | Чтение/Запись | Идентификатор класса-редактора
EditorCodeLibrary | TAccessibleFile | Нет | Видимо пользователю | Чтение/Запись | Библиотека кода редактора
SizeLimit | Integer | Нет | Видимо пользователю | Чтение/Запись | Ограничение на размер
IsBinary | Boolean | Да | Видимо пользователю | Только для чтения | Двоичные данные

2. Конструктор Create (Конструктор домена больших объектов)

Конструктор класса TBlobDomain.

1constructor TBlobDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; BlobSubtype: TBlobSubtype; SizeLimit: Integer;
4  Extension: string[10]; ShowInPlace: Boolean; EditorClassID: string[128];
5  EditorCodeLibrary: TAccessibleFile): TObject;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
BlobSubtype | TBlobSubtype | Да | Подтип
SizeLimit | Integer | Нет | Ограничение на размер
Extension | string[10] | Нет | Расширение
ShowInPlace | Boolean | Да | Редактировать по месту
EditorClassID | string[128] | Нет | Идентификатор класса-редактора
EditorCodeLibrary | TAccessibleFile | Нет | Библиотека кода редактора

Замечания:

Создает новый объект класса TBlobDomain.

3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TBlobDomain.

function TBlobDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Класс TParameterHistory (Параметры вызовов) (раздел целиком) (22.10.2024) (одним файлом)
Класс TParameterHistory (Параметры вызовов)

Диаграмма Класс TRoutineHistory (Вызовы)

1. Свойства

Свойства класса TParameterHistory:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Routine | TRoutineHistory | Да | Скрыто от пользователя | Только для чтения | Вызов подпрограммы
TimeStamp | datetime | Да | Видимо пользователю | Только для чтения | Время
ParameterName | string[64] | Да | Видимо пользователю | Только для чтения | Параметр
Data | string[2000] | Нет | Видимо пользователю | Только для чтения | Содержимое
ObjectID | string[38] | Нет | Видимо пользователю | Только для чтения | Идентификатор объекта
ObjectDataBase | TDataBase | Нет | Видимо пользователю | Только для чтения | База данных объекта
ObjectOldID | string[38] | Нет | Видимо пользователю | Только для чтения | Идентификатор при создании

2. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TParameterHistory.

1class procedure TParameterHistory.Log(Routine: TRoutineHistory;
2  Parameter: TParameter; Data: string[2000]);

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Routine | TRoutineHistory | Да | Вызов подпрограммы
Parameter | TParameter | Да | Параметр
Data | string[2000] | Нет | Содержимое


Мельница данных ((раздел целиком))

Мельница данных- Класс TRoutineBan (Запрет на подпрограмму) (раздел целиком) (22.10.2024) (одним файлом)
Класс TRoutineBan (Запрет на подпрограмму)

Класс TBanGroupItem (Элементы группы запретов)Класс TObject (Объекты)Класс TBanGroup (Группы запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

1. Свойства

Свойства класса TRoutineBan:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TBanGroup | Да | Видимо пользователю | Только для чтения | Унаследовано от TBanGroupItem
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения | Унаследовано от TObject
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
BannedClass | TClass | Да | Видимо пользователю | Только для чтения | Запрещаемый класс
BannedRoutine | TRoutine | Да | Видимо пользователю | Только для чтения | Запрещаемая подпрограмма

2. Конструктор Create (Конструктор запрета на подпрограмму)

Конструктор класса TRoutineBan.

1constructor TRoutineBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedRoutine: TRoutine): TObject;

Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
BannedClass | TClass | Да | Запрещаемый класс
BannedRoutine | TRoutine | Да | Запрещаемая подпрограмма

Замечания:

Создает новый объект класса TRoutineBan.


Мельница данных ((раздел целиком))

Мельница данных- Интеграция функций (раздел целиком) (22.10.2024) (одним файлом)
Интеграция функций
Данный тип развития интеграции в свою очередь можно разделить на 2 пути:

1. Взаимные вызовы

В данном случае подразумевается, что какая-либо учетная система открывает возможность вызова своих встроенных функций из сторонних систем.

Доступ к функциям возможен с помощью выполнения хранимых процедур (каждое бизнес-действие, которое производит пользователь, обязательно оформляется в виде хранимой процедуры на уровне СУБД Платформы). Процедуру можно вызывать, получив доступ к СУБД. Аналогично тому, как создаются select-запросы, запросы к данным, можно делать запросы, вызывающие бизнес-функции. Все методы, отчеты, и все, что доступно пользователю, может быть вызвано и через RESTful-сервис. При этом методы будут выполняться, отчеты будут формироваться в виде Excel, Word, PDF, HTML, в соответствии с запросом вызывающей стороны. Данный функционал обеспечивается готовым "обработчиком", входящим в состав поставки Платформы.

С помощью протокола SOAP можно вызывать любой метод любого объекта, получать результаты его выполнения без ограничений.

В случае когда необходимо в Платформе использовать чужие функции, набор действий по вызову такой функции оформляется в виде скриптлета.

Пример реализации:

В ВУЗе при формировании приказа о зачислении студента в Платформе, также автоматически создается объект "Приказ" в системе документооборота ВУЗа. В дальнейшем, передвижение приказа по маршруту согласования в решении на Платформе аналогично отображается в системе документооборота.

Если для сторонней системы существуют какие-либо стандартные протоколы, по которым можно вызывать функцию, то средствами Платформы не составляет труда вызов данной функции.

2. Встраивание

Данный путь интеграции функций представляет собой ситуацию, когда сторонняя система непосредственно "встраивается" в решения на Платформе и код сторонней системы исполняется с использованием данных Платформы.

Существуют разные способы реализации данного пути:

- В open-source системах, как правило, слой доступа к данным вынесен в некий отдельный модуль. Характерный пример - это LMS eFront. Это Open-Source разработка, содержащая в себе большой объем php-кода, с развитым web-интерфейсом, и, в том числе, содержащая модуль доступа к данным. В процессе работы создается база MySQL база достаточно примитивной структуры. В этом случае можно изменить модуль доступа, так, чтобы вместо запросов к MySQL-базе механика делала бы запросы к базе данных Платформы. Тогда исполнение php-кода, его интерпретация происходит в рамках сервера приложений Платформы.

Пример реализации:

Так как в базе данных Платформы уже хранятся данные о студентах, преподавателях, курсах и т.д., то при взаимодействии с системой обучения LMS, естественным, удобным и надежным решением является хранение все этих данных в одной базе данных

- В тех случаях, когда решения Платформы сами являются частью какой-либо более общей системы, и должны предоставлять свои функции, то это решается на уровне СУБД. То есть, сгенерированный Платформой прикладной код (код на соответствующем диалекте SQL) может быть интегрирован в код более масштабного хранилища, функционировать там, исполняться там, если в этом есть необходимость.

Прикладные системы на базе СУБД Teradata позволяют использовать PL/SQL-код для каких-либо наборов данных, притом, что сама база гораздо имеет продвинутые возможности автоматического контроля версий, хроникальности, аналитики.


Мельница данных ((раздел целиком))

Мельница данных- Класс TBooleanDomain (Логические) (раздел целиком) (22.10.2024) (одним файлом)
Класс TBooleanDomain (Логические)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

1. Свойства

Свойства класса TBooleanDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
TrueValue | string[64] | Да | Видимо пользователю | Чтение/Запись | Значение "Истина"
FalseValue | string[64] | Да | Видимо пользователю | Чтение/Запись | Значение "Ложь"

2. Конструктор Create (Конструктор логического домена)

Конструктор класса TBooleanDomain.

1constructor TBooleanDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; TrueValue: string[64]; FalseValue: string[64]): TDomain;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
TrueValue | string[64] | Да | Значение "Истина"
FalseValue | string[64] | Да | Значение "Ложь"

Замечания:

Создает новый объект класса TBooleanDomain.

3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TBooleanDomain.

function TBooleanDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Класс TFilmstripView (Представление-диафильм) (раздел целиком) (22.10.2024) (одним файлом)
Класс TFilmstripView (Представление-диафильм)

Диаграмма Класс TCustomView (Абстрактное представление)Класс TObject (Объекты)

1. Свойства

Свойства класса TFilmstripView:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
ShownClass | TClass | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TCustomView
ShownClassMasterClass | TClass | Нет | Видимо пользователю | Только для чтения
ShownClassReplicationStatus | TReplicationStatus | Да | Видимо пользователю | Только для чтения
ShownClassIsHierarhical | Boolean | Да | Видимо пользователю | Только для чтения
Skimpy | Boolean | Да | Видимо пользователю | Чтение/Запись
BoldProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
PreCompiled | Boolean | Да | Видимо пользователю | Чтение/Запись
PreOpenRoutine | TRoutine | Нет | Видимо пользователю | Чтение/Запись
ColorProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись
OptimizationParameters | string[2000] | Нет | Видимо пользователю | Чтение/Запись
HasConditions | Boolean | Да | Видимо пользователю | Только для чтения
HasSpecificalyNamedColumns | Boolean | Да | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
LegendProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-подпись
ThumbnailProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-значок
ImageProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство-изображение
ThumbnailSize | Integer | Да | Видимо пользователю | Чтение/Запись | Размер значка
OrderProperty | TProperty | Нет | Видимо пользователю | Чтение/Запись | Свойство, определяющее порядок

2. Конструктор Create (Конструктор представления-диафильма)

Конструктор класса TFilmstripView.

1constructor TFilmstripView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  LegendProperty: TProperty; ThumbnailProperty: TProperty;
6  ImageProperty: TProperty; ThumbnailSize: Integer;
7  OrderProperty: TProperty): TObject;

Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
ShownClass | TClass | Да | Унаследовано от TCustomView.Create
ColorProperty | TProperty | Нет
BoldProperty | TProperty | Нет
Skimpy | Boolean | Да
PreCompiled | Boolean | Да
PreOpenRoutine | TRoutine | Нет
LegendProperty | TProperty | Нет | Свойство-подпись
ThumbnailProperty | TProperty | Нет | Свойство-значок
ImageProperty | TProperty | Нет | Свойство-изображение
ThumbnailSize | Integer | Да | Размер значка
OrderProperty | TProperty | Нет | Свойство, определяющее порядок

Замечания:

Создает новый объект класса TFilmstripView.


Мельница данных ((раздел целиком))

Мельница данных- Класс TViewPresentation (Виды) (раздел целиком) (22.10.2024) (одним файлом)
Класс TViewPresentation (Виды)

Класс TObject (Объекты)Класс TView (Представления)Класс TViewPresentationAccess (Доступ к видам)Класс TViewPresentationColumn (Колонки вида)

Имена объектов класса генерируются.

1. Свойства

Свойства класса TViewPresentation:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
ChildrenMinimized | Boolean | Да | Видимо пользователю | Чтение/Запись | Дочерние представления минимизированы
Default | Boolean | Да | Видимо пользователю | Чтение/Запись | Использовать по умолчанию
IsAccessible | Boolean | Да | Видимо пользователю | Только для чтения | Доступен
Position | Integer | Да | Видимо пользователю | Чтение/Запись | Позиция

2. Конструктор Create (Конструктор вида)

Конструктор класса TViewPresentation.

1constructor TViewPresentation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer;
4  ChildrenMinimized: Boolean): TObject;

Переопределяет метод в TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Position | Integer | Да | Позиция
ChildrenMinimized | Boolean | Да | Дочерние представления минимизированы

Замечания:

Создает новый объект класса TViewPresentation.

3. Метод GetIsAccessible (Проверка доступности)

Метод экземпляра класса TViewPresentation.

function TViewPresentation.GetIsAccessible: Boolean;

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

4. Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentation.

1class function TViewPresentation.Save(Master: TObject;
2  Description: string[128]; ChildrenMinimized: Boolean): TObject;

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя | Тип | Обязательно | Значение
Master | TObject | Да | Мастер
Description | string[128] | Да | Наименование
ChildrenMinimized | Boolean | Да | Дочерние представления минимизированы

Замечания:

Возвращает значение типа TObject.


Мельница данных ((раздел целиком))

Мельница данных- Класс TClassDomain (Ссылки на объекты) (раздел целиком) (22.10.2024) (одним файлом)
Класс TClassDomain (Ссылки на объекты)

Диаграмма Класс TDomain (Домены)Класс TObject (Объекты)

1. Свойства

Свойства класса TClassDomain:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Required | Boolean | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TDomain
DependencyCount | Integer | Нет | Видимо пользователю | Только для чтения
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
Definition | string[64] | Да | Видимо пользователю | Только для чтения
Summary | string[2000] | Нет | Видимо пользователю | Только для чтения
ClassOfDomain | TClass | Нет | Видимо пользователю | Чтение/Запись | Класс домена
ClassReplicationStatus | TReplicationStatus | Да | Видимо пользователю | Чтение/Запись | Статус репликации класса
ShowObjectInfoType | TShowObjectInfoType | Да | Видимо пользователю | Чтение/Запись | Тип представления объектов
DeleteRule | TDeleteRule | Да | Видимо пользователю | Чтение/Запись | Правило удаления
FilterCondition | clob | Нет | Видимо пользователю | Чтение/Запись | Условие отбора
View | TCustomView | Нет | Видимо пользователю | Чтение/Запись | Представление
CaseInsensitiveSearch | Boolean | Да | Видимо пользователю | Чтение/Запись | Регистронезависимый поиск

2. Конструктор Create (Конструктор домена-ссылки)

Конструктор класса TClassDomain.

1constructor TClassDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; ClassOfDomain: TClass; View: TCustomView;
4  FilterCondition: clob; ShowObjectInfoType: TShowObjectInfoType;
5  DeleteRule: TDeleteRule; CaseInsensitiveSearch: Boolean): TDomain;

Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[64] | Да | Унаследовано от TObject.Create
Description | string[128] | Да
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
Required | Boolean | Да | Унаследовано от TDomain.Create
ClassOfDomain | TClass | Да | Класс домена
View | TCustomView | Нет | Представление для выбора
FilterCondition | clob | Нет | Условие отбора
ShowObjectInfoType | TShowObjectInfoType | Да | Тип представления объектов
DeleteRule | TDeleteRule | Да | Правило удаления
CaseInsensitiveSearch | Boolean | Да | Регистронезависимый поиск

Замечания:

Создает новый объект класса TClassDomain.

3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TClassDomain.

function TClassDomain.GetSummary: string[2000];

Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].


Мельница данных ((раздел целиком))

Мельница данных- Класс TOleObjectMethod (Метод Ole-объекта) (раздел целиком) (22.10.2024) (одним файлом)
Класс TOleObjectMethod (Метод Ole-объекта)

Диаграмма Класс TRoutine (Подпрограмма)Класс TClassMember (Члены класса)Класс TObject (Объекты)Класс TClass (Классы)

1. Свойства

Свойства класса TOleObjectMethod:

Имя | Тип | Обязательно | Видимость | Доступ | Назначение
Name | string[64] | Да | Видимо пользователю | Чтение/Запись | Унаследовано от TObject
Description | string[128] | Да | Видимо пользователю | Чтение/Запись
Class | TClass | Да | Скрыто от пользователя | Только для чтения
ReplicationStatus | TReplicationStatus | Да | Скрыто от пользователя | Только для чтения
Parent | TObject | Нет | Скрыто от пользователя | Чтение/Запись
Master | TObject | Да | Скрыто от пользователя | Только для чтения
SourceDataBase | TDataBase | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseGUID | string[38] | Да | Скрыто от пользователя | Только для чтения
SourceDataBaseIsCurrent | Boolean | Да | Скрыто от пользователя | Только для чтения
OldID | string[38] | Да | Скрыто от пользователя | Только для чтения
Creator | TUser | Да | Скрыто от пользователя | Только для чтения
Created | datetime | Да | Скрыто от пользователя | Только для чтения
Modifier | TUser | Да | Скрыто от пользователя | Только для чтения
Modified | datetime | Да | Скрыто от пользователя | Только для чтения
Reader | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Writer | TSecurityAccount | Нет | Скрыто от пользователя | Чтение/Запись
Override | Boolean | Да | Видимо пользователю | Только для чтения | Унаследовано от TClassMember
Domain | TDomain | Нет | Видимо пользователю | Чтение/Запись | Унаследовано от TRoutine
DomainClass | TClass | Да | Скрыто от пользователя | Только для чтения
DomainDefinition | string[64] | Да | Видимо пользователю | Только для чтения
IsClassMethod | Boolean | Да | Видимо пользователю | Чтение/Запись
Confirmation | string[512] | Нет | Видимо пользователю | Чтение/Запись
Scope | TScope | Да | Видимо пользователю | Чтение/Запись
UseTabs | Boolean | Да | Видимо пользователю | Чтение/Запись
Script | clob | Нет | Видимо пользователю | Чтение/Запись
Image | blob | Нет | Видимо пользователю | Чтение/Запись
ParamCount | Integer | Нет | Видимо пользователю | Только для чтения
Logged | Boolean | Да | Видимо пользователю | Чтение/Запись
ReportMessage | string[512] | Нет | Видимо пользователю | Чтение/Запись
SingleObject | Boolean | Да | Видимо пользователю | Чтение/Запись
DependenciesCount | Integer | Нет | Видимо пользователю | Только для чтения
ClassID | string[128] | Нет | Видимо пользователю | Чтение/Запись | Идентификатор класса
Method | string[128] | Нет | Видимо пользователю | Чтение/Запись | Метод
CodeLibrary | TAccessibleFile | Нет | Видимо пользователю | Чтение/Запись | Библиотека кода
IsInteractive | Boolean | Да | Видимо пользователю | Чтение/Запись | Интерактивный

2. Конструктор Create (Конструктор метода Ole-объекта)

Конструктор класса TOleObjectMethod.

1constructor TOleObjectMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; CodeLibrary: TAccessibleFile;
6  ClassID: string[128]; Method: string[128]; IsInteractive: Boolean): TObject;

Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя | Тип | Обязательно | Значение
Name | string[30] | Да | Унаследовано от TClassMember.Create
Description | string[128] | Да | Унаследовано от TObject.Create
Class | TClass | Нет
Parent | TObject | Нет
Master | TObject | Да
Accessor | TSecurityAccount | Нет
IsClassMethod | Boolean | Да | Унаследовано от TRoutine.Create
SingleObject | Boolean | Да
Domain | TDomain | Нет
Scope | TScope | Да
Confirmation | string[512] | Нет
ReportMessage | string[512] | Нет
UseTabs | Boolean | Да
Script | clob | Нет
Image | blob | Нет
Logged | Boolean | Да
CodeLibrary | TAccessibleFile | Нет | Библиотека кода
ClassID | string[128] | Нет | Идентификатор класса
Method | string[128] | Нет | Метод
IsInteractive | Boolean | Да | Интерактивный

Замечания:

Создает новый объект класса TOleObjectMethod.

3. Метод Ole-объекта CheckOleObjectMethod (Проверить метод Ole-объекта)

Метод Ole-объекта класса TOleObjectMethod.

Метод Ole-объекта не имеет параметров.


Мельница данных (одним файлом)

Мельница данных (одним файлом) (22.10.2024)

1. Технологическая платформа "Мельница Данных"

Документация online
Мельница Данных

Документация по технологической платформе.

Руководство пользователя обозревателя данных

Руководство пользователя построителя запросов

Руководство администратора

Руководство разработчика на платформе

Руководство разработчика для построителя запросов

2. Руководство пользователя обозревателя данных

2.1. Запуск обозревателя данных

Для начала работы необходимо запустить исполняемый файл DataBrowser.exe. Это можно сделать посредством ярлыка, создаваемого инсталлятором Системы:

При его запуске отобразится окно входа в систему:

Для запуска системы необходимо заполнить поля формы входа в систему, после чего нажать кнопку ОК или клавишу Enter на клавиатуре. Если система ранее запускалась на Вашем локальном компьютере, то поля формы (за исключением поля Пароль) будут заполнены данными, введенными в прошлый раз. Если система на компьютере запускается впервые, то при открытии формы ее поля будут пустыми. Для заполнения полей формы необходимо знать, на каком типе сервера БД работает система, имя базы данных, с которой предстоит работать, имя пользователя и пароль. Если Вы не располагаете такой информацией, узнайте ее у администратора системы.

Источник данных - в этом поле из выпадающего списка выберите тип сервера баз данных, на котором функционирует система; возможен выбор из трех вариантов:

если система работает на сервере Interbase (Firebird), выберите пункт Interbase/FireBird Server;

если система работает на сервере Oracle, выберите пункт Oracle Database Server;

если система работает на сервере MSSQL, выберите пункт Microsoft SQL Server.

База данных - в этом поле необходимо указать имя базы данных.

Имя пользователя - в этом поле введите Ваше имя пользователя (логин).

Пароль - в это поле введите Ваш пароль.

Для удобства последующего запуска системы Вы можете воспользоваться флажками "Сохранить пароль" и "Входить автоматически".

Сохранить пароль - если установить этот флажок, то Ваш пароль будет запомнен и подставлен в поле Пароль при следующем запуске системы. В связи с тем, что информация о вводимом Вами пароле будет сохранена на Вашем локальном компьютере, пользоваться этим флажком рекомендуется только в том случае, если возможность несанкционированного доступа к Вашему компьютеру исключена.

Входить автоматически - этот флажок доступен только при установленном флажке "Сохранить пароль". Если установить этот флажок, то при следующем входе в систему Вам не придется заполнять поля формы и нажимать кнопку OK или клавишу Enter. Форма покажется на некоторое время, после чего произойдет автоматический вход в систему.

Если Вы установили флажок "Входить автоматически", но хотите изменить ранее введенную в поля информацию, необходимо выполнить щелчок мышью (здесь и далее "щелчок мышью" означает щелчок ЛЕВОЙ кнопкой мыши. Если необходим щелчок ПРАВОЙ кнопкой мыши, то будет указано "щелчок правой кнопкой мыши") на форме во время ее показа. После этого можно будет изменить ранее установленные в полях значения.

2.2. Элементы интерфейса пользователя

При входе в систему на экране отобразиться ее главное окно. Макет главного окна системы:

В заголовке главного окна системы отображается имя запущенного приложения (Databrowser.exe), имя пользователя (sysdba) и имя базы данных (C:\project\databases\icecream.fdb). Интерфейс состоит из трех основных элементов:

В верхней части экрана расположена Панель инструментов. На ней расположены иконки, соответствующие доступным в настоящее время действиям, а также доступным для текущего пользователя формам.

В левой части экрана расположен Инспектор объектов, позволяющий просматривать и редактировать свойства объектов, выбранных в таблицах данных.

Основную часть экрана занимают Формы с Таблицами данных. Таблицы данных используются для просмотра и редактирования объектов, учитываемых в системе.

2.3. Работа с формами и таблицами данных

Для отображения записей об учитываемых в системе объектах используются формы с таблицами данных. Каждая форма представляет собой отдельное окно с заголовком, на котором отображается ее наименование. Основную часть окна формы занимают таблицы данных. Переключаться между доступными формами можно либо при помощи щелчка мышью по иконке, соответствующей форме на Панели инструментов, либо при щелчке мышью на самом окне формы (если форма видна). В каждый момент времени активной является одна из форм (или ни одной). Окно формы можно "перетаскивать" (здесь и далее "перетащить" объект означает подвести к нему указатель мыши, нажать левую кнопку, удерживая кнопку переместить объект на новое место, после чего отпустить кнопку мыши) по экрану за заголовок, изменять его размеры, минимизировать, восстановить, раскрывать на весь экран или закрывать. Эти действия осуществляются стандартным для среды Windows образом. При закрытии формы соответствующая ей иконка на панели инструментов будет отображена неактивной. При щелчке мышью по такой иконке форма откроется, и иконка станет активной.

Таблицы данных в форме расположены на закладках с заголовками, соответствующими наименованиям таблиц данных. Например, на предыдущем рисунке активна форма "Продажи мороженого". В этой форме на первом уровне расположены таблицы данных "Регионы", "Сорта мороженого", "Сорта фруктового мороженого", "Представительства", "Все продажи". Активной в настоящее время является таблица данных "Представительства".

2.3.1. Подчиненные таблицы данных и взаимное расположение главной и подчиненных таблиц

Таблицы данных могут иметь подчиненные таблицы. Подчиненные таблицы по умолчанию отображаются в нижней части главной таблицы. Набор записей, отображаемых в подчиненной таблице, зависит от того, какие записи выбраны в главной таблице.

Например, на рисунке в главной таблице "Представительства" выбрано представительство ООО "Холод плюс". При этом в подчиненной таблице "Продажи представительства" отображаются только те продажи, которые осуществлены данным представительством.

Подчиненные таблицы могут располагаться двумя способами:

на закладках - в этом случае в нижней части главной таблицы отображаются закладки с наименованиями подчиненных таблиц; переключаться между подчиненными таблицами можно путем щелчка мышью по соответствующей закладке;

в отдельных окнах - в этом случае каждая из подчиненных таблиц располагается в своем окне; окна имеют заголовки, соответствующие наименованиям таблиц; окна, в которых отображаются подчиненные таблицы, можно перетаскивать за заголовок в любое другое место экрана, минимизировать, восстанавливать, закрывать и т.д.

Изменять соотношение размера главной и подчиненных таблиц можно путем перетаскивания горизонтального разделителя мышью. Для этого необходимо подвести указатель мыши к границе раздела зон главной и подчиненных таблиц и когда курсор примет форму горизонтального разделителя ( ) перетащить разделитель выше или ниже. При отображении подчиненных таблиц в отдельных окнах можно изменять соотношение ширины подчиненных таблиц. Для этого нужно подвести указатель мыши к вертикальной границе таблиц и когда указатель примет форму вертикального разделителя ( ), перетащить разделитель вправо или влево.

При отображении подчиненных таблиц на закладках занимаемая ими область также может быть минимизирована. Для этого необходимо подвести курсор к границе раздела зон главной и подчиненной таблиц и когда он примет форму горизонтального разделителя ( ) выполнить двойной щелчок мышью.

Восстановить отображение подчиненных таблиц можно либо путем нажатия кнопки "Восстановить" ( ) в заголовке минимизированного окна, либо при помощи двойного щелчка мышью на этом заголовке.

2.3.2. Отображение учитываемых объектов в таблице данных

Таблица данных имеет строки и колонки. Строки таблицы (или записи) соответствуют учитываемым объектам. Колонки таблицы соответствуют свойствам объектов.

На рисунке представлен макет таблицы данных, в которой отображаются объекты, соответствующие сортам фруктового мороженого. Таблица данных имеет наименование "Сорта фруктового мороженого", которое отображается на соответствующей закладке (1). Таблица имеет пять строк (2), соответствующих пяти сортам фруктового мороженого. Выделенной в настоящее время является первая строка. Таблица имеет пять колонок, соответствующих свойствам учитываемых сортов мороженого. Каждая колонка имеет заголовок (4), отражающий отображаемое в этой колонке свойство. Активной в настоящее время является первая колонка. Активным элементом данных (3) является ячейка, расположенная в первой строке в первом столбце.

На рисунке активная строка и активный элемент данных выделяются оттенками синего цвета. Цвета, применяемые для выделения элементов данных, зависят от локальных настроек операционной системы Windows (стилей) на компьютере пользователя.

Под заголовком каждой колонки расположена строка фильтра (5). При помощи ввода в этой строке условия отбора или выбора значений из выпадающего списка можно осуществлять фильтрацию отображаемых в таблице данных.

Если отображаемые данные не помещаются в окно по ширине, то активной становится горизонтальная полоса прокрутки (7). С ее помощью можно пролистывать колонки таблицы вправо и влево. Если данные не помещаются в окно по вертикали, то активной становится вертикальная полоса прокрутки (8). С ее помощью можно пролистывать записи об объектах вверх и вниз. При щелчке правой кнопкой мыши на полосе прокрутки (если она активна) доступны действия по быстрой прокрутке содержимого таблицы.

При щелчке правой кнопкой мыши в области таблицы данных отображается контекстное меню. Контекстное меню отображает список действий, доступных над объектами, отображаемыми в таблице данных. Вызываемые действия выполняются для тех объектов, которые являются выделенными в таблице данных. Если ни одного объекта не выделено, некоторые действия контекстного меню могут быть недоступны. Набор действий, отображаемых в контекстном меню различен в разных таблицах данных.

Заголовок закладки с именем таблицы данных.

Выделенный объект.

Выделенный элемент данных.

Заголовок колонки.

Строка фильтра.

Флажок для выбора объектов.

Горизонтальная полоса прокрутки.

Вертикальная полоса прокрутки

2.3.2.1. Иерархические таблицы данных

Если отображаемые в таблице данные имеют иерархическую структуру (т.е. присутствует "вхождение" одних объектов в другие), то в таблице данных объекты могут отображаться в виде "дерева".

На рисунке представлена таблица данных, отображающая периоды обучения студентов. Эти данные имеют иерархическую структуру, которая отражает вхождение учебных модулей в состав семестров, а семестров в состав учебных годов. В первой колонке иерархической таблицы данных слева от элементов данных, имеющих подчиненные элементы, отображаются значки или . При щелчке мышью по значку отображаются подчиненные объекты. Значок при этом превращается в значок . При щелчке мышью по значку подчиненные объекты скрываются и значок превращается в . На рисунке для объектов "Учебный год 2005-2006" и его подчиненных объектов "I семестр" и "II семестр" подчиненные объекты отображены. Щелчком по значку подчиненные объекты можно скрыть. Для объектов "I семестр" и "II семестр" учебного года 2006-2007 подчиненные объекты скрыты. Щелчком по значку их можно отобразить. При горизонтальном пролистывании таблицы данных вправо или влево "дерево" объектов всегда отображается слева от самого левого столбца.

В иерархических таблицах данных доступны дополнительные действия по управлению отображением и выбору объектов, которые описаны в разделе 4.7.1.

2.3.3. Выбор объектов в таблице данных

Выбор одного объекта в таблице данных может осуществляться либо щелчком мышью в соответствующей строке, либо при помощи стрелок ("вверх" и "вниз") на клавиатуре. Выбор активной колонки и активного элемента данных также может производиться щелчком мышью или при помощи стрелок ("вправо" и "влево") на клавиатуре.

В таблице данных можно также осуществлять произвольный выбор нескольких объектов путем установки флажка в строке, отображающей объект. Установка или снятие флажка производится при помощи щелчка мышью.

При выборе нескольких объектов в главной таблице в подчиненной таблице будут отображены записи, соответствующие подчиненным объектам, отобранным для ВСЕХ объектов, выбранных в главной таблице.

На рисунке представлена таблица данных "Учащиеся", имеющая ряд подчиненных таблиц. На рисунке открыта подчиненная таблица "Родственники и контактные лица". В таблице данных "Учащиеся" путем установки флажка произвольным образом выбраны три учащихся с фамилиями Матвеева, Зимогляд и Анчевский. При этом в подчиненной таблице "Родственники и контактные лица" отображены родители всех троих учащихся.

При выборе объектов путем простановки флажков необходимо осуществлять щелчок мышью именно на флажке. Если выполнить щелчок мышью в любой другом месте записи, ранее установленные флажки будут сняты, и выбранной станет одна эта запись.

Для быстроты и удобства выбора объектов доступны дополнительные возможности:

для выделения нескольких объектов подряд можно щелкнуть мышью в любом месте записи, соответствующей первому объекту, а затем, удерживая клавишу Shift, щелкнуть по записи, соответствующей последнему объекту; все объекты между первым и последним, включая их, будут выделены;

осуществлять произвольный выбор объектов можно щелчком мышью в любом месте записи, удерживая клавишу Ctrl ;

можно воспользоваться действиями, доступными в подменю "Выбранные" на панели инструментов или в контекстном меню:

Выбрать все - все отображаемые в настоящий момент в таблице данных объекты будут выбраны;

Показать только выбранные - в таблице данных будут отображены только те объекты, которые помечены как выбранные; остальные объекты будут скрыты;

Показать все - если ранее было установлен отбор только выбранных объектов, этот отбор будет снят, и снова будут отображены все доступные в таблице объекты.

При выборе объектов изменяется информация, отображаемая Инспектором объектов. Если выбран один объект, то Инспектор объектов отображает и позволяет редактировать все доступные пользователю свойства этого объекта. Если выбрано несколько объектов, отображение и редактирование свойств Инспектором объектов происходит по правилам, описанным в разделе 5 "Работа с Инспектором объектов".

При выполнении действий над объектами выбранное действие будет выполнено для всех выбранных объектов. Если не выбрано ни одного объекта, некоторые действия могут быть недоступны.

При одновременном выборе большого числа объектов быстродействие системы может снижаться. При необходимости работы с большой выборкой объектов лучше воспользоваться возможностью фильтрации данных.

2.3.4. Изменение порядка отображения колонок

Порядок отображения колонок может быть изменен путем "перетаскивания" их заголовков. Для того чтобы переместить колонку правее или левее, подведите указатель мыши к заголовку колонки, нажмите левую кнопку мыши и, не отпуская ее, перетащите заголовок колонки вправо или влево. После того, как Вы отпустите кнопку мыши, порядок отображения колонок изменится.

На рисунке изображено перетаскивание заголовка колонки "Вид упаковки" в таблице данных "Сорта мороженого". После того, как кнопка мыши будет отпущена, колонка "Вид упаковки" станет третьей слева, а колонка "Число продаж" второй.

2.3.5. Скрытие и отображение колонок

Любая из видимых в таблице данных колонок может быть скрыта. Для этого необходимо выделить любой элемент данных в колонке, щелчком правой кнопкой мыши открыть контекстное меню и в нем в подменю "колонка" выбрать действие "Скрыть эту колонку".

На рисунке показано как скрыть колонку "Вид упаковки" в таблице данных "Сорта мороженого". Описанным выше образом можно скрыть любое число колонок таблицы данных кроме последней. Если в таблице данных осталась одна колонка, то действие "Скрыть эту колонку" будет недоступно. Для отображения скрытых ранее колонок таблицы данных необходимо воспользоваться действием "Показать скрытые колонки" в подменю "колонка" контекстного меню. (На рис. 12. действие располагается ниже действия "Скрыть эту колонку"). Если ни одной колонки таблицы данных не скрыто, то действие "Показать скрытые колонки" будет недоступно. Действия, расположенные в подменю "колонка" доступны также на панели инструментов.

2.3.6. Сортировка данных в таблицах

Отображаемые в таблице данные могут быть отсортированы по возрастанию или по убыванию значений свойств, отображаемых в одной или нескольких колонках. Для сортировки данных по одной колонке необходимо выполнить щелчок мышью не ее заголовке. Данные будут отсортированы по возрастанию значения в этой колонке. Если щелкнуть мышью по заголовку колонки еще раз, то данные будут отсортированы по убыванию значения в этой колонке. В заголовке конке появится стрелочка, отображающая порядок сортировки (направленная вверх в случае сортировки по возрастанию и вниз в случае сортировки по убыванию). Если выполнить щелчок мышью по заголовку другой колонки, то данные будут отсортированы по значению в новой колонке.

На рисунке данные в таблице данных "Учащиеся" отсортированы по значению в колонке "Фамилия" по возрастанию. В заголовке колонки "Фамилия" отображается направленная вверх стрелочка. Для сортировки данных по значениям в нескольких колонках необходимо выполнить щелчок мышью на заголовке первой колонки, затем, удерживая клавишу Ctrl, выполнить щелчок по заголовку второй колонки и т.д. При этом в заголовках колонок будут отображаться стрелочки, соответствующие направлению сортировки и цифры, соответствующие порядку колонок в сортировке.

На рисунке представлен пример сортировки данных таблицы данных "Учащиеся" по региону (по возрастанию), затем по полу (по убыванию) и затем по фамилии (по возрастанию). В заголовках колонок отображены соответствующие стрелочки с цифрами 1, 2 и 3.

В иерархических таблицах данные сортируются в пределах каждого уровня иерархии.

На рисунке данные в иерархической таблице данных "Направления и специальности" отсортированы по колонке "Наименование" по возрастанию.

2.3.7. Группировка данных в таблицах

Данные в таблице данных могут быть сгруппированы по значениям свойств, отображаемым в одной или в нескольких колонках.

Для осуществления группировки по значению в одной из колонок необходимо выделить любой элемент данных в этой колонке. Затем щелчком правой кнопки мыши открыть контекстное меню и в нем в подменю "колонка" выбрать действие "Группировать по этой колонке".

На рисунке показано, как при помощи действия в контекстном меню осуществляется группировка данных в таблице данных "Все продажи" по значению в колонке "Представительство".

При отображении данных в сгруппированном виде для каждой группы будет отображен заголовок на более темном фоне. В заголовке группы будут отображены наименование и значение свойства, по которому осуществлена группировка, а слева от наименования будет расположен значок или . При нажатии на значок можно скрывать объекты группы (для группы будет отображен только ее заголовок). Значок при этом изменится на . При нажатии на значок объекты, входящие в группу, будут снова отображены.

На рисунке данные в таблице данных "Все продажи" сгруппированы по значению в колонке "Представительство". Группы объектов, соответствующие представительствам ЗАО "Айс девелопмент", ЗАО "Фрост интернешнл" и ООО "Заморозь соседа", раскрыты. Группы, соответствующие ОАО "Красный нос" и ООО "Дед мороз и лето", свернуты.

Данные могут группироваться и по нескольким колонкам. Для этого необходимо повторить описанные выше действия для всех колонок, которые должны быть включены в группировку.

На рисунке представлен пример группировки данных, отображаемых в таблице данных "Все продажи" по колонкам "Регион" и "Сорт мороженого".

Для снятия группировки и отображения данных в стандартном виде необходимо воспользоваться действием "Очистить группировку", которое также доступно в контекстном меню в подменю "колонка" (на рисунке расположено в выпадающем меню ниже действия "Группировать по этой колонке").

Действия, расположенные в подменю "колонка", доступны также на панели инструментов.

2.3.8. Фильтрация данных в таблицах

Фильтрация данных (отображение только тех данных, которые удовлетворяют некоторому условию) осуществляется по значениям, отображаемым в колонках, при помощи строки фильтра. Строка фильтра расположена ниже заголовка колонки. Фильтрация данных может осуществляться двумя способами:

путем выбора значения из выпадающего списка, доступного при нажатии кнопки в строке фильтра

путем записи условия фильтрации в строке фильтра

При нажатии кнопки в строке фильтра отображается выпадающий список значений, которые могут быть выбраны. Перечень отображаемых значений зависит от типа данных, отображаемых в колонке. В первой строке списка расположен пункт "(Все)". При выборе этого пункта фильтрация данных по этой колонке не осуществляется. При выборе одного из доступных значений в таблице данных будут отображены только те объекты, для которых значение свойства, отображаемого в данной колонке, равно выбранному. После осуществления фильтрации в строке фильтра будет отображено выбранное значение. Выбор значений можно осуществить в нескольких колонках. В этом случае условия отбора по каждой колонке будут объединены логическим "И".

На рисунке показано, как осуществить фильтрацию данных по значению "эскимо" в колонке "Вид упаковки". После выполнения фильтрации эта таблица данных будет выглядеть следующим образом:

В таблице данных на рисунке отображены записи только о тех сортах мороженого, которые продаются в виде эскимо. Значение "эскимо" отображено в строке фильтра в колонке "Вид упаковки".

Для фильтрации данных по более сложному условию можно воспользоваться вторым способом - записью условия фильтрации в строке фильтра. Условие фильтрации записывается по следующим правилам:

Строка разделяется на части посредством системного разделителя (системный разделитель устанавливается в настройках операционной системы Windows). Обычно - точка с запятой, ";"

Каждая часть строки интерпретируется самостоятельно, и эти части объединяются логическим "ИЛИ"

При интерпретации каждой части проверяются следующие условия:

Часть строки

Правило отбора объектов

*

Будут отобраны только те объекты, у которых значение в колонке не является пустым (установлено).

!*

Будут отобраны только те объекты, у которых значение в колонке является пустым (не установлено).

начинается с символов '<=', '<', '>=', '>'

Будут отобраны только те объекты, у которых значение в колонке удовлетворяет условию.

включает в себя символы '*' и/или '?'

Будут отобраны только те объекты, у которых значение в колонке удовлетворяет шаблону, в котором знак '?' соответствует одному любому символу, а знак '*' - любому количеству любых символов.

начинается с символа '!'

Будут отобраны только те объекты, у которых значение в колонке не удовлетворяет условию, переданному оставшейся частью строки (знак '!' означает отрицание).

представляет собой строку в апострофах (одиночных кавычках)

Содержание строки не анализируется по приведенным выше правилам. Будут отобраны только те объекты, у которых значение данного свойства соответствует строке, заключенной в апострофы.

любая другая строка

Будут отобраны только те объекты, у которых значение данного свойства соответствует введенной строке (строки чувствительны к регистру).

Условия, указанные в разных колонках, объединяются логическим "И"

После ввода в строке фильтр требуемого условия необходимо нажать клавишу Enter.

В таблице данных "Все продажи" на рисунке отобраны только те записи, для которых верно следующее: Продажи осуществлены в регионе "Москва" или "Тверская область"; при этом наименование проданного сорта мороженого начинается с "Б"; при этом число продаж данного сорта больше 100.

Сделать заключение о том, что отображаемые в таблице данные отфильтрованы, можно по наличию в строке фильтра записи отличной от "(Все)". Снять фильтрацию данных можно одним из двух способов:

выбрать в строке фильтра из выпадающего списка пункт "(Все)"

удалить все символы, записанные в строке фильтра и нажать клавишу Enter

2.3.9. Отображение итоговых значений (агрегатов) по колонкам

По любой из колонок таблицы данных может быть рассчитано и отображено итоговое значение (агрегат). В зависимости от типа отображаемого в колонке свойства могут быть вычислены следующие агрегаты:

количество объектов (для свойств любых типов)

сумма значений (для числовых значений)

наименьшее (минимальное) значение (для строковых, числовых, логических значений, перечислений, значений типа даты, времени, даты со временем)

наибольшее (максимальное) значение (аналогично наименьшему значению)

среднее значение (для числовых значений)

Для отображения агрегата по одной из колонок необходимо выделить элемент данных в этой колонке, при помощи щелчка правой кнопкой мыши отобразить контекстное меню и в нем в подменю "колонка" выбрать действие, соответствующее нужному агрегату. После выполнения этого действия таблица данных будет выглядеть следующим образом:

На рисунке в нижней части таблицы данных отображена строка на светло-желтом фоне, в которой в колонке "Число продаж" показана сумма числа всех продаж, отображаемых в таблице.

Агрегат может быть вычислен и показан по любой из колонок.

Если данные в таблице отфильтрованы, то агрегат будет рассчитан только по тем записям, которые отобраны по условию фильтрации.

Если данные в таблице сгруппированы, то агрегаты будут рассчитаны как для всех отображаемых в таблице данных, так и отдельно для каждой группы.

На рисунке данные о продажах сгруппированы по региону. Суммы числа продаж и среднее значение выручки отображены как для каждого региона (в строках на ярко-желтом фоне), так и для всех продаж в целом (в строке на светло-желтом фоне внизу таблицы).

Если свернуть группы, то можно просматривать только итоговые значения агрегатов для групп и для всех объектов в целом. Агрегаты при этом будут видны только в случае, если они отображаются правее надписи с именем и значением параметра группировки.

2.3.10. Редактирование данных в таблице

В таблице данных может редактироваться значение одного свойства одного объекта. Для того чтобы изменить отображаемое в таблице данных значение необходимо выделить требуемый элемент данных щелчком мышью или клавишами со стрелками на клавиатуре, после чего перевести элемент данных в режим редактирования. Это можно сделать одним из двух способов:

выполнить двойной щелчок мышью на элементе данных

при выделенном активном элементе данных нажать клавишу Enter на клавиатуре

После перевода элемента данных в режим редактирования отображаемый в нем текст будет выделен. Текст может быть отображен на белом или на сером фоне. Справа от текста могут появиться кнопки.

На рисунке элемент данных в пятой сверху строке в первой колонке (текст "Белоснежка") переведен в режим редактирования.

Отображение элемента данных в режиме редактирования зависит от типа отображаемого свойства, доступности свойства для изменения и допустимости установленного значения.

Если текст отображается на сером фоне, это означает, что свойство доступно только для чтения. У Вас нет возможности изменять его значение. Такое значение (или его часть) можно выделить и скопировать при помощи сочетания клавиш Ctrl+Ins или Ctrl+C и затем вставить в доступном для ввода значений месте в этом или в любом другом приложении.

Если текст отображается на зеленом фоне, это означает, что установленное в данный момент значение недопустимо. Значение считается недопустимым, в одном из следующих случаев:

значение, обязательное для заполнения, не установлено

для свойства установлено значение, не удовлетворяющее его типу (например, на приведенном выше рисунке для числового свойства установлено значение, включающее буквы). Форматы, допустимые для значений различных типов, соответствуют локальным настройкам операционной системы Windows

длина текста для свойства строкового типа превышает максимально допустимую длину

введенное значение больше максимально допустимого или меньше минимально допустимого

для свойства, предполагающего выбор из списка или из справочника, установлено значение, не соответствующее ни одному из допустимых значений из списка или справочника

Пока для свойства не будет установлено допустимое значение, применить выполненное изменение не удастся.

Если в режиме редактирования в ячейке отображается обычный текст на белом фоне, то значение свойства доступно для изменения. Редактирование значения производится при помощи клавиш клавиатуры. Выделенное значение или его часть может быть скопирована и вставлена стандартным образом. При редактировании текста обращайте внимание на тип свойства (строковое, числовое, дата и т.п.). Если введенное значение не будет удовлетворять типу, то оно будет считаться недопустимым и станет отображаться на зеленом фоне. Форматы, допустимые для значений различных типов, соответствуют локальным настройкам операционной системы Windows. После изменения значения необходимо нажать клавишу Enter для того, чтобы применить сделанные изменения.

Если слева от текста в ячейке отображается флажок, это означает, что свойство может иметь одно из двух возможных значений. Одно из значений соответствует установленному флажку, другое - снятому. Если для свойства допустимо пустое значение, то в случае его установки флажок будет отображен на сером фоне и справа от него будет отображен текст "(Нет)".

Изменение значения такого свойства производится либо щелчком мыши по флажку, либо путем нажатия клавиши Пробел на клавиатуре.

Если справа от текста отображается кнопка с направленной вниз стрелкой, это означает, что значение свойства должно быть выбрано из списка допустимых значений. Изменять такое значение можно двумя способами:

Нажать на кнопку , расположенную справа от текста, в открывшемся выпадающем списке выбрать новое значение.

На рисунке показан выбор значения из выпадающего списка. Если Вы выбираете значение при помощи мыши, то достаточно выполнить щелчок мышью на нужном значении. Для выбора значения при помощи клавиатуры необходимо воспользоваться клавишами-стрелками "вверх" и "вниз", и когда нужное значение будет выделено, нажать клавишу Enter. Если для свойства допустимо пустое значение, то первым элементом выпадающего списка будет элемент "(Нет)". Если список включает больше восьми элементов, то в нем будет доступна вертикальная полоса прокрутки.

Ввести текст, соответствующий нужному элементу списка, с клавиатуры. В процессе ввода будут предлагаться допустимые для выбора значения. Если введенный с клавиатуры текст не будет удовлетворять ни одному из элементов списка, он будет отображен на зеленом фоне, и установить новое значение не удастся. При вводе значения с клавиатуры следите за регистром символов. После ввода нового значения необходимо нажать клавишу Enter.

Если справа от текста отображается кнопка с тремя точками, это означает, что данное свойство предполагает выбор значения из другой таблицы данных. Изменять такое значение можно двумя способами:

Нажать на кнопку , расположенную справа от текста; при этом откроется таблица данных, в которой нужно будет выбрать новое значение. В правом нижнем углу этой таблицы данных будут расположены кнопки OK и Отмена. Для выбора значения можно щелкнуть мышью по нужной записи или воспользоваться стрелками на клавиатуре. После выбора нужного значения нажмите кнопку OK. Если Вы не хотите менять ранее установленное значение, нажмите кнопку Отмена.

На рисунке представлена таблица данных, которая будет отображена для выбора значения свойства, представляющего собой сорт мороженого.

Ввести текст, соответствующий нужному значению, с клавиатуры. В процессе ввода будут предлагаться допустимые для выбора значения. Если введенный с клавиатуры текст не будет совпадать ни с одним из допустимых значений, он будет отображен на зеленом фоне, и установить новое значение не удастся. При вводе значения с клавиатуры следите за регистром символов. После ввода нового значения необходимо нажать клавишу Enter.

Если справа от текста отображаются две кнопки - кнопка со стрелкой и кнопка с тремя точками, то можно как выбирать значение из выпадающего списка, так и выбирать значение из таблицы данных (описано выше). В этом случае так же можно вводить текст, соответствующий допустимому значению с клавиатуры. После ввода значения с клавиатуры необходимо нажать клавишу Enter.

Если справа от текста отображены три кнопки, а сам текст представляет собой строку "(Данные)" или строку "(Нет)" это означает, что данное свойство представляет собой большой объект. Большой объект может быть текстом, файлом, содержащим изображение, xml-документ, исходный текст программных модулей или просто любые бинарные данные.

При нажатии на кнопку отобразится окно, отображающее и позволяющее редактировать данные, представляющие собой большой объект.

На рисунке изображено окно, в котором может редактироваться исходный текст метода. После внесения изменений в текст окно редактирования нужно закрыть. Если в тексте действительно произошли изменения, то будет отображено предупреждение:

При нажатии кнопки Да окно редактирования будет закрыто, и изменения будут сохранены. При нажатии кнопки Нет окно редактирования будет закрыто, но произведенные изменения сохранены не будут. При нажатии кнопки Отмена окно редактирования останется открытым и работу с текстом можно будет продолжить.

Копка позволяет загрузить содержимое большого объекта из файла. При нажатии этой кнопки отобразится стандартный диалог открытия файла Windows, в котором можно выбрать нужный файл, после чего нажать кнопку Открыть. При замене содержимого большого объекта новым будет отображено предупреждение:

Если нажать кнопку Да, то содержание большого объекта будет заменено новым, загруженным из указанного файла. Если нажать кнопку Нет, то содержание большого объекта не изменится

Кнопка позволяет сохранить содержимое большого объекта в файл. При нажатии этой кнопки отобразится стандартный диалог сохранения файла Windows, в котором необходимо задать расположение и имя файла и нажать кнопку Сохранить. При сохранении файла необходимо явно указать его расширение. При сохранении файла никаких предупреждений не отображается.

После изменения содержания большого объекта необходимо нажать клавишу Enter.

2.3.11. Выполнение действий над объектами

Все действия, которые могут быть произведены над объектами, могут быть выполнены одним из трех способов:

выбор действия в контекстном меню

вызов действия при помощи клавиш клавиатуры - "горячих клавиш" (доступно не для всех действий)

вызов действия при помощи иконки на панели инструментов (доступно не для всех действий)

При помощи действий производится добавление, удаление объектов, запуск различных процедур, выполняемых над данными, формирование отчетов.

Перечень всех действий, доступных в текущей таблице данных расположен в контекстном меню, которое отображается при нажатии правой кнопки мыши в зоне таблицы данных. Некоторые из действий выполняются для выбранных объектов (одного или нескольких), например, действие "Удалить". Для выполнения других действий выбор конкретного объекта не нужен, например, для действия "Добавить". Выбор действия в контекстном меню может производиться как при помощи мыши, так и при помощи стрелок на клавиатуре.

Если для действия установлены " горячие клавиши ", то из обозначения можно будет увидеть в правой части пункта контекстного меню. Действия могут вызываться как при нажатии одной клавиши, так и при помощи сочетания клавиш.

В некоторых пунктах контекстного меню может быть расположена стрелка . При выборе такого пункта никакого действия не выполняется, а открывается " подменю ", содержащее другие действия.

На рисунке изображено контекстное меню, отображающее все действия, доступные над объектом, соответствующим студенту Алехиной Елене Михайловне. Действиям "Добавить студента-специалиста", "Удалить" и "Обновить" соответствуют "горячие клавиши". Пункты меню "Перемещения", "Колонка", "Выбранные" имеют подменю. На рисунке открыто подменю пункта "Перемещения".

Для некоторых действий могут быть установлены изображения-иконки. В этом случае иконки отображаются на панели инструментов (подробнее в разделе 4.13. "Работа с панелью инструментов").

Если выполнение процедуры или отчета требует задания параметров, то при вызове действия отобразится форма задания параметров. Для выполнения действия необходимо заполнить поля формы и нажать кнопку OK (подробнее в разделе 6 "Работа с формой задания параметров").

Перед выполнением некоторых действий может быть отображено предупреждение. Например, перед удалением объекта может отображаться следующее окно:

Если в таком окне нажать кнопку Да, то действие будет выполнено. Если нажать кнопку Нет, то действие будет отменено.

2.3.12. Работа с панелью инструментов

На панели инструментов отображаются иконки, соответствующие доступным пользователю действиям и формам. Иконки могут иметь подписи, соответствующие наименованием действий или форм. Вызов действий или переключение между активными формами осуществляется при помощи щелчка мышью на одной из иконок. Если иконок много и они не помещаются на панели инструментов по ширине, то слева или справа отображаются кнопки прокрутки. Для прокрутки содержимого панели инструментов достаточно подвести указатель мыши к кнопке прокрутки.

На рисунке представлен пример панели инструментов. Иконки с подписями "Создать", "Удалить", "Колонка", "Выбранные", "Перенос в Excel" соответствуют доступным в текущей таблице данных действиям. Иконки с надписями "Системная форма" и "Продажи мороженого" соответствуют доступным пользователю формам. Справа от иконки "Продажи мороженого" расположена кнопка прокрутки. Подведя указатель мыши к этой кнопке, можно увидеть иконки, расположенные правее и не поместившиеся на панели инструментов.

Некоторые кнопки панели инструментов могут иметь выпадающие кнопки. Выпадающие кнопки соответствуют пунктам подменю контекстного меню. Справа от кнопок, имеющих выпадающие кнопки, расположена направленная вниз стрелочка. Если нажать мышью на эту стрелочку, то отобразится панель с выпадающими кнопками. На рисунке кнопки "Колонка" и "Выбранные" имеют выпадающие кнопки.

Как и в контекстном меню, на панели инструментов некоторые кнопки могут быть недоступны. Доступность кнопки зависит от того, какие объекты в настоящий момент выделены, и от применимости действия к выделенным объектам.

2.3.13. Стандартные действия, доступные в любых таблицах данных

Ряд стандартных действий, доступных объектов любого типа, может быть вызван из любой таблицы данных. Разработчиком конкретной прикладной системы некоторые из перечисленных в данном разделе действий могут быть скрыты. Также перечень доступных стандартных действий зависит от прав доступа конкретного пользователя.

Взаимное расположение, наименования и доступность стандартных действий могут зависеть от реализации прикладной системы. В следующих разделах описаны все стандартные действия, реализованные средствами платформы.

2.3.13.1. Копирование и вставка объектов

Объекты, отображаемые в таблице данных, можно копировать и вставлять. Вставлять объекты можно как в ту же таблицу данных, из которой они были скопированы, так и в другую таблицу данных, отображающую объекты того же типа. Для этого необходимо выполнить следующие действия:

Выбрать один или несколько объектов, которые Вы хотите скопировать (см. раздел 4.3. "Выбор объектов в таблице данных").

Вызвать действие "Копировать" из контекстного меню или при помощи иконки на панели инструментов.

Перейти в таблицу данных, в которую Вы хотите вставить скопированные объекты.

Вызвать действие "Вставить" из контекстного меню или при помощи иконки на панели инструментов.

При копировании и вставке происходит создание копии объекта. Все свойства нового объекта, кроме свойства "Имя" (или замещающего его свойства), будут такими же, как у первичного объекта. Свойство имя будет равно строке, составленной из слова "Копия " и имени первичного объекта. После вставки объекта значение свойства "Имя" можно изменить.

Действия "Копировать" и "Вставить" имеют соответствующие иконки на панели инструментов:

2.3.13.2. Подменю "Колонка" - работа с колонкой

Действия, доступные в подменю "Колонка" в контекстном меню или на панели инструментов могут быть применены к колонкам любой таблицы данных. Доступность тех или иных действий над колонкой зависит от типа данных, отображаемых в колонке, и от того, какие действия над колонкой уже совершены (например, нельзя вычислить сумму значений строкового типа, или нельзя очистить группировку, если данные не сгруппированы).

Иконка "Колонка" на панели инструментов имеет выпадающие кнопки:

Действия, доступные в подменю "Колонка", описаны в разделах 4.6. "Скрытие и отображение колонок", 4.8. "Группировка данных в таблицах", 4.10. "Отображение итоговых значений (агрегатов) по колонкам".

2.3.13.3. Подменю "Выбранные" - работа с выбранными объектами

Действия, доступные в подменю "Выбранные" позволяют быстро отбирать и снимать отбор с объектов, а также устанавливать режим отображения в таблице данных только тех объектов, которые помечены как выбранные.

Иконка "Выбранные" на панели инструментов имеет выпадающие кнопки:

Назначение этих действий описано в разделе 4.3. "Выбор объектов в таблице данных".

2.3.13.4. Перенос в Excel

Данные, отображаемые в любой из таблиц данных, могут быть перенесены в MS Excel. При этом в MS Excel будут сохранены все настройки отображения данных (сортировка по одной или нескольким колонкам, группировка, отображение итоговых значений). Действие "Перенос в Excel" может быть вызвано из контекстного меню или при помощи иконки на панели инструментов. С данными, перенесенными в MS Excel, далее могут производиться любые манипуляции средствами этого приложения.

Если в таблице много записей, то перенос данных в Excel может занять некоторое время. Если это время превышает 10 сек., то отобразится окно, сообщающая, что система находится в работе. В этом окне будет отображен индикатор процесса переноса данных:

Действие "Перенос в Excel" имеет соответствующую иконку на панели инструментов:

2.3.13.5. Экспорт данных

Отображаемые в таблицах данных объекты могут быть экспортированы в виде xml-документа. Для того, чтобы осуществить экспорт объектов, необходимо выполнить следующее:

Выбрать объекты, подлежащие экспорту (см. раздел 4.3. "Выбор объектов в таблице данных").

Вызвать действие "Экспортировать" из контекстного меню или при помощи иконки на панели инструментов.

В открывшемся окне сохранения файла указать местоположение и имя файла. Дать файлу расширение .xml.

2.3.13.6. Обновление данных таблицы

После выполнения действий над различными объектами, хранящимися в системе, их новое состояние может сразу не отобразиться в таблице данных. Для того чтобы получить из базы данных последние актуальные данные необходимо воспользоваться действием "Обновить", которое доступно в контекстном меню, при помощи иконки на панели инструментов, а также может быть доступно при нажатии клавиши F5.

Действие "Обновить" имеет соответствующую иконку на панели инструментов:

2.3.13.7. Доступ к настройкам системы

При наличии соответствующих прав доступа Вы можете просматривать и изменять настройки системы. Доступ к меню настроек осуществляется при помощи действия "Настройки", которое может быть вызвано из контекстного меню или при помощи иконки на панели инструментов. При вызове этого действия отобразится форма задания настроек. Эта форма аналогична форме задания параметров (см. раздел 6 "Работа с формой задания параметров"). Если Вы имеете права администратора системы, то форма задания настроек, кроме кнопок OK и Отмена, будет иметь кнопку "По умолчанию". При нажатии этой кнопки значения, установленные в полях формы станут значениями настроек по умолчанию.

Если в системе нет доступных для текущего пользователя настроек, то при вызове действия "Настройки" отобразится окно:

Действие "Настройки" имеет соответствующую иконку на панели инструментов:

2.3.13.8. Дополнительные действия, доступные в иерархических таблицах данных

В иерархических таблицах данных дополнительно доступны действия, позволяющие управлять раскрытием и свертыванием элементов иерархии. Эти действия расположены в подменю "Дерево". Иконка "Дерево" на панели инструментов имеет выпадающие кнопки:

При помощи этих действий можно управлять отображением дерева иерархически организованных объектов следующим образом:

Развернуть все - все элементы дерева будут раскрыты.

Свернуть все - все дочерние элементы будут свернуты. Отображенными останутся только элементы первого уровня (не имеющие родительских элементов).

Развернуть от выбранного - узел дерева, соответствующий выбранному объекту и все его дочерние узлы будут раскрыты.

Свернуть к выбранному - узел дерева, соответствующий выбранному объекту у все его дочерние узлы будут свернуты.

Свернуть к этому уровню - все узлы дерева, лежащие на том же уровне, что и выбранный объект или на более низких уровнях будут свернуты.

Выделить дочерние - все объекты, дочерние по отношению к выбранному, будут выделены.

2.4. Работа с Инспектором объектов

2.4.1. Отображение свойств Инспектором объектов

Инспектор объектов предназначен для просмотра и редактирования свойств одного или нескольких объектов, выбранных в активной таблице данных. Инспектор объектов имеет две колонки. В левой колонке отображаются наименования свойств, в правой колонке отображаются значения свойств. Набор отображаемых свойств и их значений зависит от того, сколько объектов каких типов выбрано в текущей таблице данных (подробнее о выборе объектов см. раздел 4.3. "Выбор объектов в таблице данных"). Свойства выбранных объектов отображаются Инспектором объектов по следующим правилам:

Если в таблице данных выбран один объект, то в Инспекторе объектов отображаются все свойства этого объекта, видимые пользователю.

Если в таблице данных выбрано несколько объектов, то

Инспектор объектов будет иметь строки, соответствующие только тем свойствам, которые есть у всех выделенных объектов;

если у всех выделенных объектов значение свойства одинаково, то это значение будет отображено в правой колонке; в противном случае в правой колонке будет отображено пустое значение.

При изменении значения свойства в Инспекторе объектов новое значение будет установлено для всех выделенных объектов.

На рисунке представлен пример таблицы данных, отображающей учитываемые в системе сорта мороженого. Среди сортов мороженого есть как обычные сорта, так и сорта фруктового мороженого, дополнительно обладающие свойством "Фрукт". В таблице данных выделен один объект, соответствующий сорту фруктового мороженого "Тропический рай". При этом Инспектор объектов отображает все свойства данного объекта (в том числе свойство "Фрукт").

На рисунке в той же таблице данных выбрано два объекта: сорт мороженого "Тропический рай" (фруктовое мороженое) и сорт "Белый Бим черное ухо" (обычное мороженое). При этом в Инспекторе объектов отображаются только те свойства, которые являются общими для выделенных объектов (свойство "Фрукт" не отображается). Значения свойств "Вид упаковки" и "Вес" для выбранных объектов одинаковы, поэтому их значения отображены в правой колонке Инспектора объектов. Значения остальных свойств для данных объектов различны, поэтому для этих свойств отображаются пустые значения. Если изменить одно из свойств в Инспекторе объектов, то новое значение будет установлено как для сорта мороженого "Тропический рай", так и для сорта мороженого "Белый Бим черное ухо".

Порядок отображения свойств в Инспекторе объектов устанавливается разработчиком прикладной системы. Также разработчиком прикладной системы может быть установлено отнесение свойств к категориям. В этом случае свойства могут отображаться сгруппированными по категориям. Слева от наименования каждой категории будет отображен значок или . Нажатием мышью на значок свойства, входящие в категорию, можно свернуть, нажатием на значок их можно снова отобразить.

На рисунке представлен пример отображения Инспектором объектов свойств объекта, соответствующего дисциплине учебного плана студентов. Свойства, отнесенные к категориям "Формы текущего контроля" и "Распределение аудиторных часов по модулям", свернуты. Свойства, отнесенные к категории "Учебные часы" раскрыты.

В связи с тем, что выбор свойств объектов для отображения, получение и сравнение их значений происходит по специальному алгоритму, в случае одновременного выбора большого числа объектов скорость работы Инспектора объектов может снижаться. Если на вычисление значения общего свойства группы объектов требуется значительное время, то такое свойство может отображаться как свойство с отложенным вычислением. Для такого свойства в правой колонке вместо значения может отображаться строка (...). При активизации этого свойства справа отобразится кнопка со знаком вопроса . Если нажать на эту кнопку, то значение свойства будет определено и отображено.

2.4.2. Управление положением Инспектора объектов на экране и порядком отображения свойств

Инспектор объектов отображается в отдельном окне. Это окно можно перетаскивать по экрану за заголовок, изменять его размеры стандартным для операционной системы Windows образом. На панели инструментов всегда присутствует иконка Инспектора объектов, при нажатии которой можно отобразить окно Инспектора (если оно не видимо) и сделать его активным:

При нажатии правой кнопки мыши в левом столбце Инспектора объектов или в свободном нижнем поле доступно контекстное меню Инспектора объектов. При помощи действий, расположенных в этом меню можно управлять режимом работы окна Инспектора и порядком отображения свойств.

Выбор одного из пунктов контекстного меню переводит Инспектор объектов в новый режим работы. После этого рядом с пунктом меню отображается галочка или точка . При повторном выборе помеченного пункта меню соответствующий режим работы отменяется и отметка снимается. Доступные пункты контекстного меню позволяют устанавливать следующие режимы работы Инспектора объектов.

При выборе пункта меню Всегда наверху окно Инспектора объектов будет всегда отображаться на переднем плане независимо от переключения между активными таблицами данных.

Если выбрать пункт меню Прозрачное окно, то окно Инспектора объектов станет полупрозрачным.

Если выбрать пункт меню Показать скрытые свойства, то кроме свойств, отображаемых в обычном режиме (свойства, созданные разработчиком прикладной системы как " видимые ") будут отображены свойства объектов, " невидимые " пользователю.

Пункт меню Сортировать по алфавиту позволяет отображать свойства не в порядке, установленном разработчиком прикладной системы, а в алфавитном порядке их наименований. Такой режим работы удобен в случае, если необходимо найти свойство по его наименованию.

Пункты подменю Группировка позволяют:

Группировать по категории - свойства будут отображены сгруппированными по категориям (показано на рисунке);

Группировать по классу - свойства будут отображены сгруппированными по классу объектов, членами которого они являются;

Не группировать - свойства будут отображены без группировки.

2.4.3. Редактирование значений свойств при помощи Инспектора объектов

При помощи Инспектора объектов удобно изменять значения свойств одного или одновременно нескольких выбранных объектов (о выборе объектов см. раздел 4.3. "Выбор объектов в таблице данных"). Одно из свойств, отображаемых в Инспекторе объектов, всегда является активным. Активное значение выделяется в Инспекторе объектов рамкой, его значение отображается в режиме редактирования.

Отображение свойств в режиме редактирования и способы изменения значений свойств аналогичны редактированию данных в таблице данных (см. раздел 4.11. "Редактирование данных в таблицах"). Отличие работы Инспектора объектов заключается в том, что с его помощью можно изменять значение свойства сразу нескольких выбранных объектов.

2.5. Работа с формой задания параметров

Форма задания параметров используется для организации диалога с пользователем по заданию параметров, необходимых для выполнения метода или формирования отчета. Форма задания параметров открывается при вызове действия, для выполнения которого необходимо задать параметры.

Форма задания параметров представляет собой форму, содержащую поля различного вида. В правом нижнем углу формы расположены кнопки ОК и Отмена.

Слева или сверху от каждого поля расположено его наименование. Наименования поля отражает, какие данные должны быть в него введены. Поля формы объединяются в группы. Группы полей могут располагаться в столбцах или на закладках. На рисунке выше поля формы расположены в двух столбцах. Если поля расположены на закладках, то в верхней части формы отображаются заголовки закладок с их наименованиями.

На рисунке представлена та же форма, что и на рисунке выше, но с расположением параметров на закладках.

Порядок отображения полей на форме, а также способ их отображения (в столбцах или на закладках) задается разработчиком прикладной системы. Переход от одного поля к другому может осуществляться либо щелчком мышью на новом поле, либо при помощи клавиши Tab на клавиатуре. Переключаться между закладками можно путем нажатия мышью ни их заголовок.

Для выполнения действия, требующего задания параметров, необходимо заполнить все обязательные поля формы. После установления допустимых значений все поля формы должны приобрести белый фон. При этом условии кнопка OK станет доступной. После нажатия кнопки OK будет выполнен вызываемый метод или сформирован отчет. Если Вы хотите отменить выполнение действия, нажмите кнопку Отмена.

Поля формы могут иметь белый, зеленый или серый фон, а также могут иметь различный внешний вид. Цвет фона зависит от доступности для изменения и допустимости введенного в поле значения. Внешний вид поля зависит от типа данных, которые должны быть в него введены. Возможны следующие варианты внешнего вида полей и способ установления в них значений:

Если поле имеет серый фон, то его значение недоступно для изменения. Такие поля используются для отображения дополнительной информации. Значения в таких полях могут изменяться автоматически при установке новых значений в других полях формы.

Обычное поле отображается в случае, когда в него должно быть введено строковое значение длиной до 128 символов, целочисленное, вещественное (с целой и дробной частью) значение, значение типа даты, времени, или даты со временем

В таком поле можно вводить текст с клавиатуры, копировать и вставлять его. Введенные в такое поле символы проверяются на соответствие типу данным (на основе локальных настроек компьютера) и на удовлетворение значения дополнительным условиям, которые могут быть установлены разработчиком прикладной системы. В случае если введенный набор символов соответствует недопустимому для данного поля значению, поле приобретет зеленый фон.
- установлено допустимое значение
- установлено недопустимое значение.

Для ввода строковых значений, длина которых может превышать 128 символов, отображаются расширенные поля ввода:

В таком поле можно вводить текст с клавиатуры, копировать его и вставлять. Также в таком поле может вводится многострочный текст. Перенос строки осуществляется нажатием клавиш Ctrl+Enter. Если текст имеет большое число строк, для его просмотра используется вертикальная полоса прокрутки.

Для выбора значения из двух возможных вариантов используется поля, в котором отображается флажок и текстовое значение.

Изменение значения в таком поле может производиться либо щелчком мыши по флажку, либо при помощи клавиши Пробел на клавиатуре. Если в данном поле пустое значение недопустимо, то переключение происходит между двумя возможными значениями (например, для поля "Пол" между значениями "Муж." и "Жен."). Если пустое значение допустимо, то переключение происходит между тремя вариантами: двумя значениями и пустым значением, для которого отображается строка "(Нет)".

Если значение поля должно быть установлено путем выбора из списка допустимых значений, то в правой части поля отображается кнопка с направленной вниз стрелкой.

Установление значения в таком поле может производиться либо при помощи выбора из выпадающего списка, открывающегося при нажатии на кнопку , либо путем ввода с клавиатуры текста, соответствующего выбираемому значению. В процессе ввода будут предлагаться допустимые варианты.

Если поле предполагает ввод большого объекта, то оно отображается следующим образом:

Если в поле значение не установлено, то отображается текст "(Нет)". Если значение установлено, то отображается текст "(Данные)". В правой части поля ввода расположено три кнопки:

при нажатии этой кнопки будет отображено окно редактирования текста большого объекта;

при нажатии этой кнопки большой объект можно загрузить из файла при помощи стандартного диалога открытия файла Windows;

при нажатии этой кнопки большой объект можно сохранить в файл при помощи стандартного диалога сохранения файла Windows.

Если поле предполагает выбор объекта из другой таблицы данных, то в правой части поля отображается кнопка с тремя точками или кнопка со стрелкой и кнопка с тремя точками.

Выбор значений в таком поле производится путем нажатия на одну из кнопок:

при нажатии данной кнопки отображается выпадающий список объектов которые могут быть выбраны в данном поле;

- при нажатии данной кнопки будет открыта таблица данных, и в ее правом нижнем углу будут расположены кнопки OK и Отмена. В открывшейся таблице нужно выбрать один объект, после чего нажать кнопку ОК.

При работе с формой задания параметров рекомендуется устанавливать в полях значения в порядке их следования на форме. Разработчиком прикладной системы может быть установлена зависимость между значениями полей. В этом случае при изменении значения в одном из полей, в других полях значения также могут автоматически измениться. Допустимость значений в одних полях может зависеть от того, какие значения установлены в других полях.

Также необходимо помнить о том, что кнопка ОК на форме задания параметров станет доступной только тогда, когда во всех полях будут установлены допустимые значения.

2.6. Формирование отчетов Microsoft Excel

Формирование отчетов, выгружаемых в MS Excel происходит при помощи вызова действий в таблицах данных (подробнее о вызове действий см. раздел 4.12 "Выполнение действий над объектами"). При вызове отчета на выполнение может отобразиться форма задания параметров отчета. Поля этой формы необходимо заполнить, после чего нажать кнопку ОК (подробнее о работе с формой задания параметров см. раздел 6. "Работа с формой задания параметров").

Отчеты, выгружаемые в MS Excel, как правило, имеют иконки на панели инструментов, характерные для рабочих книг Excel:

При запуске отчета на исполнение происходит создание рабочей книги Excel, в которую передаются данные, хранящиеся в базе данных. Рабочая книга может содержать данные, диаграммы, интерактивные элементы управления, и проч.. Далее средствами MS Excel могут осуществляться любые доступные действия с рабочей книгой.

Отчеты в MS Excel используются для вывода на печать документов и стандартных форм отчетности. Шаблоны отчетов создаются разработчиками прикладной системы.

Полученный в результате формирования отчета файл MS Excel может далее использоваться для дальнейшей работы с данными, может быть распечатан, сохранен, отправлен по электронной почте и т.п.

2.7. Формирование отчетов в виде HTML-документов

В целях публикации отчетной информации в Internet средствами системы могут формироваться отчеты в виде HTML-документов. Формирование таких отчетов происходит путем вызова действий в таблицах данных (подробнее о вызове действий см. раздел 4.12 "Выполнение действий над объектами"). При вызове отчета на выполнение может отобразиться форма задания параметров отчета. Поля этой формы необходимо заполнить, после чего нажать кнопку ОК (подробнее о работе с формой задания параметров см. раздел 6. "Работа с формой задания параметров").

Отчеты, формируемые в виде HTML-документов, как правило имеют иконки на панели инструментов, характерные для приложения MS Internet Explorer:

В результате работы отчета создается HTML-документ, который может содержать таблицы с данными, рисунки, ссылки и проч. Сформированный документ показывается при помощи приложения Internet Explorer. Полученный html-файл может быть опубликован в Internet, сохранен, распечатан и т.д.

Сформированный html-документ сохраняет связь в базой данных. Если в ранее открытом документе выполнить процедуру обновления, по документ отобразит последнюю версию хранящихся на сервере БД данных.

2.8. Взаимодействие с разработчиком в случае ошибок, проблем, вопросов по работе системы

В ситуациях, когда в работе системы происходят ошибки, когда система ведет себя неожиданным для пользователя образом, наблюдаются проблемы с быстродействием или другими аспектами работы системы, если у пользователей возникают вопросы, не освещенные в Руководстве пользователя, возникает необходимость обратиться к разработчику. Для того, чтобы разработчик мог решить проблему или ответить на вопрос быстро, полно и компетентно, ему нужно предоставить информацию о среде работе системы, о решаемых пользователем задачах, последовательности действий пользователя, приведших к проблемной ситуации.

Общими принципами сбора информации для обращения к разработчику должны быть:

Необходимо быть готовым изложить последовательность действий пользователя в системе, начиная с открытия системы до ситуации, приводящей к ошибке, проблемной ситуации или ситуации, вызывающей вопрос.

Если ошибка или проблема имеет визуальное проявление, нужно сделать скриншот (снимок) экрана. Желательно предоставлять скриншот всего экрана компьютера, а не только активного окна приложения, это даст разработчику дополнительную полезную информацию. Скришот экрана при работе в операционной системе MS Windows можно получить путем одновременного нажатия клавиш Ctrl + Print Screen (PrtScr) и последующей вставки (сочетание клавиш Shift + Ins) в какое-либо графическое приложение, например, программу Paint.

Если ошибка заключается не в отображении специального окна с сообщением об ошибке, а в том, что результат работы системы является, с точки зрения пользователя, некорректным, то нужно быть готовым изложить, каким должен быть корректный результат, и чем именно результат работы системы некорректен.

Если ошибка, проблема или вопрос связаны с работой третьесторонних приложений (например, отчеты, формируемые в MS Excel или MS Word, работа web-приложений системы посредством интернет-браузеров), нужно быть готовым предоставить информацию о версии третьесторонних приложений.

Нужно быть готовым предоставить информацию о конфигурации рабочего места пользователя, версии операционной системы, установленном программном обеспечении и его версии, включая средства анитивирусной защиты.

Для сбора информации, необходимой разработчику для решения проблем, система предоставляет ряд средств: Приложение Отладочный монитор, возможность получения файла, содержащего информацию об ошибке, также ниже приведены рекомендации по получению информации о третесторонних приложениях.

2.8.1. Приложение Отладочный монитор

Приложение Отладочный монитор (DebugView.exe) устанавливается при установке платформы в любой конфигурации, предусмотренной по умолчанию, включая конфигурацию "Рабочее место пользователя". Открыть приложение можно при помощи иконки:

Когда приложение Отладочный монитор запущено, приложение Обозреватель данных выводит в него поток сообщений о действиях и событиях, происходящих в системе. В Отладочный монитор попадают все sql-запросы, направляемые с рабочего места пользователя на сервер баз данных (в случае удаленного подключения - html-запросы, направляемые на сервер приложений), информационные сообщения, предупреждения, отладочная информация, сообщения об ошибках и прочие данные.

Для того, чтобы собрать и передать разработчику информацию об ошибке или проблемной ситуации при помощи Отладочного монитора, нужно выполнить следующие действия:

Закрыть приложение Обозреватель данных, если оно было открыто.

Запустить приложение Отладочный монитор. Если это приложение уже было открыто, то выполнить очитку всех имеющихся в нем сообщений при помощи кнопки Очистить.

В приложение Обозреватель данных выполнить всю последовательность действий, приводящих в появлению ошибки или проблемной ситуации.

После возникновения ошибки или проблемной ситуации в приложении Отладочный монитор нажать кнопку Сохранить в файл, выбрать место сохранения и задать имя файла. Файл будет сохранен в формате.txt.

Отправить полученный.txt-файл разработчику в составе других информационных материалов, которыми должны быть:

Словесное описание проблемы и способа ее воспроизведения

Один или несколько скриншотов экрана, иллюстрирующих проблему

После получения информации, состав которой описан в пункте 5, разработчик может запросить дополнительную информацию о проблеме.

2.8.2. Получение файла, содержащего информацию об ошибке

В ходе работы с системой могут отображаться специальные окна с информацией об ошибках. Эти окна могут быть двух видов:

Окно с информацией о недопустимом действии пользователя (окно с шапкой синего цвета):

Как правило, отображение такого окна с информацией об ошибке свидетельствует не об ошибке в функциональности системы, а о том, что пользователем выполнено недопустимое действие. Информация о том, в чем именно действие не допустимо, содержится в тексте, отображаемом в окне. Например, на приведенном выше скриншоте мы видим окно с ошибкой, отображено после попытки пользователя создать в справочнике "Уровни образования и курсы" второй записи с именем "1 курс", подчиненной родительской записи "Бакалавриат", что недопустимо. Поэтому сообщение об ошибке говорит о дублировании объекта по полю Имя.

Информация, отображаемая в окне данного вида, предназначена для пользователя. Вы можете направить информацию о такой ошибке разработчику в случае, если сообщение об ошибке непонятно, либо если считаете, что выполненное пользователем действие должно быть допустимым, и ошибка системы в том, что действие было расценено как недопустимое.

При отображении окна данного вида пользователь может продолжить работу, нажав на кнопку Продолжить. При необходимости обратиться в данной ситуации к разработчику до нажатия кнопки Продолжить необходимо получить и сохранить информацию, необходимую разработчику для анализа ситуации, при помощи ссылок "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки". Подробнее о сохранении этой информации написано ниже.

Окно с информацией об ошибке системы (окно с шапкой красного цвета).

При возникновении ситуации, сопровождающейся появлением такого окна, необходимо получить и сохранить информацию, необходимую разработчику для анализа ситуации, при помощи ссылок "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки". Подробнее о сохранении этой информации написано ниже.

После сохранения информации об ошибке можно попытаться продолжить работу, нажав кнопку Продолжить. В некоторых случаях, в зависимости от характера произошедшей ошибки, продолжение работы может оказаться невозможным, в таких случаях нужно нажать кнопку Закрыть приложение. После того, как приложение будет закрыто, его можно будет открыть снова и продолжить работу.

Сохранение информации для направления разработчику.

Информация, которая поможет разработчику решить проблему, не отображается в самом окне, поэтому направлять разработчику скриншот именно этого окна не имеет смысла. Для получения необходимой для разработчика информации в окнах с сообщением об ошибке обоих видов расположены ссылки "Показать информацию для службы поддержки" или "Сформировать файл для службы поддержки".

По ссылке Показать информацию для службы поддержки информация отображается в том же окне. Весь текст изначально выделен, его можно сразу скопировать и вставить в текстовый файл, в тело письма и т.д. Данный текст содержит сам текст ошибки, а также информацию об операционной системе пользователя и ее версии, загруженных модулях, переменных окружения и проч.

При помощи ссылки Сформировать файл для службы поддержки можно собрать в удобном виде наиболее полную и полезную для разработчика информацию. После нажатия на ссылку будет предложен диалог сохранения файла. По умолчанию файлу будет дано имя ExceptionInfo.err. Это имя можно изменить, но расширение необходимо файла сохранить. После выбора места сохранения и имени файла и нажатия кнопки Сохранить, система отобразить предупреждение:

К данному предупреждению нужно отнестись ответственно - отправлять полученный файл только на адреса службы поддержки системы в вашей организации или на официальный контактный адрес разработчика (если вы взаимодействуете с разработчиком напрямую). После отправки этот файл необходимо удалить.

Предоставление разработчику информации в виде.err-файла - это самый удобный и надежный вариант взаимодействия, который даст возможность разработчику решить проблему или ответить на вопрос наиболее эффективным и быстрым образом. Данный файл содержит все виды информации, которые могут быть собраны другими способами:

Информацию об ошибке, которая отображается по ссылке "Показать информацию для службы поддержки"

Сообщения Отладочного монитора, собранные за некоторое время до возникновения ошибки

Скриншоты экрана пользователя, включая скриншот окна с информацией об ошибке.

При отправке файла разработчику дополнительно нужно описать последовательность действий, приведших к ошибке или ситуации, вызывающей вопросы. После получения файла и дополнительной информации, разработчик может попросить предоставить дополнительную информацию о проблемной ситуации, о конфигурации рабочего места пользователя, прочем установленном на рабочем месте ПО и проч.

Если вы хотите обратиться к разработчику по поводу ситуации, которая не сопровождается отображением окна с ошибкой, то.err-файл можно получить следующим образом: нужно кликнуть левой кнопкой мыши по иконке с мельницей в левом углу заголовка окна текущей формы и из выпадающего меню выбрать пункт Сохранить файл для службы поддержки.

2.8.3. Получение информации о третесторонних приложениях

В случае, если ошибка произошла при взаимодействии системы с третьесторонним приложением, например, при выполнении отчета MS Excel, MS Word, pdf, при работе web-приложений системы через интернет-браузер, разработчику, в дополнение к файлу с информацией об ошибке, понадобится информация о версии третьестороннего приложения, при взаимодействии с которым произошла ошибка.

Получить информацию о версии приложения можно, как правило, в окне О программе ("About box"), которое в большинстве программных продуктов представлено в пункте меню Справка.

Разработчику в составе информационных материалов нужно отправить скриншот этого окна.

В продуктах семейства Microsoft Office вызвать окно О программе можно разными способами в зависимости от версии MS Office. В программных продуктах версий до 2003 включительно это окно доступно в меню Справка / О программе. В программных продуктах версий 2007 и выше вызвать это окно можно следующим образом:

В меню Файл открыть выпадающий список доступных действий и нажать кнопку Параметры Excel :

В открывшемся окне выбрать раздел Ресурсы, в правой части окна нажать кнопку О программе :

Окно О программе в случае MS Excel выглядит следующим образом:

В программе Acrobat Reader окно О программе можно вызвать из меню Справка / О программе :

В интернет-браузерах окно "О программе" (О Google Chrome, О FireFox, О Internet Explorer) также можно вызвать из меню Справка. Строка меню в интернет-браузерах часто бывает по умолчанию скрыта. Для того, чтобы ее отобразить, нужно нажать клавишу Alt на клавиатуре.

3. Руководство пользователя построителя запросов

4. Руководство администратора

4.1. Установка программного обеспечения СУБД

Прежде, чем устанавливать программноге обеспечение "Мельница данных" необходимо установить и настроить программное обеспечение СУБД.

Для конфигурирования сервера БД необходимо последовать советам раздела "Конфигурирование сервера". В этом разделе описаны шаги, которые необходимо предпринять для установки сервера "с нуля". Если сервер БД у вас уже установлен и настроен, то использовать рекомендации этого раздела нет необходимости. Раздел описывает установку сервера БД минимальной поддерживаемой версии в минимально необходимой для работы "Мельницы данных" конфигурации. Если вы собираетесь использовать сервер БД для более широкого круга задач, то пользуйтесь руководствами по соответствующим СУБД.

Документация по СУБД, а также любая другая информация, полученная от производителей СУБД, имеет абсолютный приоритет перед утверждениями настоящего документа.

На каждой рабочей станции должно быть установлено и настроено программное обеспечение клиентской части СУБД. Это, как правило, некий набор библиотек и компонентов, наличие которых необходимо для соединения с сервером БД. Для обеспечения рабочей станции этими компонентами необходимо последовать советам раздела Конфигурирование клиента. В этом разделе описаны шаги, которые необходимо предпринять для установки клиентской части СУБД "с нуля". Если клиентская часть СУБД у вас уже установлена и настроена, то использовать рекомендации этого раздела нет необходимости. Раздел описывает установку клиентской части СУБД минимальной поддерживаемой версии в минимально необходимой для работы "Мельницы данных" конфигурации.

В настоящий момент поддерживаемые СУБД приведены в таблице:

СУБД

Минимальная
требуемая версия

Разработчик

Сопровождение в России

Firebird
Open source

1.5.4.4910

http://www.firebirdsql.org
Страница загрузки

http://www.ibase.ru

Oracle database
Коммерческое ПО

9.2.0.1

http://www.oracle.com
Страница загрузки

http://www.oracle.com/global/ru/index.html

4.1.1. Конфигурирование сервера

Младшая тестированная на совместимость версия - 1.5.4.4910. Использование более младшей версии на сервере недопустимо. Шаги установки примерно следующие:

Первая страница содержит логотип проекта Firebird

Вторая страница содержит лицензионное соглашение. Для продолжения установки необходимо установить кнопку "I accept the agreement".

Третья страница содержит информацию, необходимую для установки.

Четвертая страница позволяет указать папку на диске, в которую будут установлены файлы Firebird.

На пятой странице определяется тип установки. Мы конфигурируем сервер БД, и, соответственно, выбираем из выпадающего списка пункт "Full installation of Server and development tools". Необходимо определиться с выбором между различными архитектурами сервера. Если вы затрудняетесь в выборе между вариантами архитектуры сервера, то помните, что для однопроцессорных систем предпочтительнее Super Server, для многопроцессорных используется только Classic Server. Подробности можно посмотреть на сайте сопровождающей компании или на сайте проекта. Особое внимание требуется обратить на работу сервера на процессоре в режиме HyperThreading.

На шестой странице предлагается выбрать имя папки меню "Пуск", в которой будут созданы полезные ярлыки. В нашем случае ярлыки будут созданы для файлов документации, бесполезной в конечном счете для конечного пользователя. Поэтому мы ставим флажок "Don't create any icons".

На седьмой странице необходимо выбрать параметры установки. Настоятельно рекомендуется включить флажок "Use the Guardian to control the server" и запускать сервер в режиме службы, то есть выбрать кнопку "Run as a Service". Также настоятельно рекомендуется установить флажок "Start Firebird automatically everytime you boot up". Программное обеспечение "Мельница данных" использует в работе библиотеку gds32.dll , загружая ее из системного каталога Windows. Поэтому в целях обеспечения нормальной работы необходимо установить оба флажка - "Copy Firebird client library to <system> directory" и "Generate client library as GDS32.DLL for legacy app. support".

На восьмой странице необходимо подтвердить установку с выбранными параметрами.

После установки на девятой странице можно ознакомиться с информацией об установленной версии.

Десятая страница информирует об успешном завершении установки и позволяет запустить сервер немедленно. Рекомендуется установить флажок "Start Firebird Service now".

Убедиться в том, что сервер установлен и запущен, можно из окна служб (Start → Control Panel → Administrative Tools → Services):

Использование embedded-сервера вполне допустимо, с учетом ограничений, налагаемых разработчиком. Для использования embedded-сервера необходимо положить файлы (с полным путем) из архива embedded-сервера рядом с исполняемыми файлами нашей системы, и переименовать файл FBEMBED.DLL в GDS32.DLL , примерно следующим образом:

Для работы с embedded-сервером имя сервера в строке соединения указывать нельзя. Кроме того, необходимо соблюдать рекомендации и требования разработчиков сервера.

Младшая тестированная на совместимость версия - 9.2.0.1. Использование более младшей версии недопустимо.

Если вы устанавливаете Oracle не с компакт-дисков, то не пользуйтесь программой автозапуска, лежащей в корне первого установочного диска, а запустите setup.exe из каталога install\win32 на первом установочном диске.

Шаги установки примерно следующие:

Первая страница содержит логотип Oracle и командные кнопки. Для продолжения установки нажмите кнопку "Next".

На второй странице необходимо определиться с путями установки и источника, а также с именем "дома". Настоятельно рекомендуется принять значения, предлагаемые по умолчанию.

На третьей странице необходимо выбрать устанавливаемый продукт. Для сервера БД необходимо выбрать продукт "Oracle9i Database 9.2.0.1.0".

На четвертой странице необходимо выбрать тип установки. Для обеспечения требуемой функциональности выберите тип "Standard Edition".

На пятой странице необходимо выбрать параметры базы данных, создаваемой автоматически при установке сервера. Рекомендуется никакой базы данных при установке не создавать, для чего выбрать пункт "Software Only".

На шестой странице необходимо выбрать порт TCP/IP, используемый Oracle Services for MTS. По умолчанию 2030.

На седьмой странице необходимо подтвердить правильность параметров установки.

После окончания процесса вы увидете сообщение об успешном завершении установки. Нажмите кнопку "Exit".

После завршения работы инсталлятора автоматически будет запущено приложение "Enterprise Manager Console". Если по каким-либо причинам этого не произошло, запустите это приложение самостоятельно через меню "Пуск". В окне "Add Databases To Tree" нажмите кнопку "Cancel".

Из меню выберите пункт Tools → Service Management → Oracle Net Manager.

В появивщемся окне приложения "Oracle Net Manager" раскройте узел дерева "Local", встаньте на узел дерева "Listener" и нажмите на кнопку с большим зеленым плюсом в панели инструменов (слева).

В появивщемся окне добавления Listener'a введите имя (по умолчанию - LISTENER). Настоятельно рекомендуется принять умолчание.

Нажмите на кнопку "Add Address" в нижней части окна.

В появившемся окне отображена информация о том, каким образом клиенты будут осуществлять соединение с сервером БД. Настоятельно рекомендуется принять умолчания - протокол TCP/IP, порт 1521.

Из меню выберите пункт File → Save Network Configuration

Служба Listener'a будет создана при первой попытке создать базу данных. Закройте приложения "Oracle Net Manager" и "Enterprise Manager Console".

4.1.2. Конфигурирование клиента

Младшая тестированная на совместимость версия - 1.5.4.4910. Использование более младшей версии на клиенте недопустимо. Шаги установки примерно следующие:

Первая страница содержит логотип проекта Firebird

Вторая страница содержит лицензионное соглашение. Для продолжения установки необходимо установить кнопку "I accept the agreement".

Третья страница содержит информацию, необходимую для установки.

Четвертая страница позволяет указать папку на диске, в которую будут установлены файлы Firebird.

На пятой странице определяется тип установки. Мы конфигурируем клиентскую часть, и, соответственно, выбираем из выпадающего списка пункт "Minimum client install - no server, no tools". Кнопки в списке устанавливаемых компонентов будут автоматически выставлены в правильное положение.

На шестой странице предлагается выбрать имя папки меню "Пуск", в которой будут созданы полезные ярлыки. В нашем случае ярлыки будут созданы для файлов документации, бесполезной в конечном счете для конечного пользователя. Поэтому мы ставим флажок "Don't create any icons".

На седьмой странице необходимо выбрать параметры установки. Программное обеспечение "Мельница данных" использует в работе библиотеку gds32.dll, загружая ее из системного каталога Windows. Поэтому в целях обеспечения нормальной работы необходимо установить оба флажка - "Copy Firebird client library to <system> directory" и "Generate client library as GDS32.DLL for legacy app. support".

На восьмой странице необходимо подтвердить установку с выбранными параметрами.

После установки на девятой странице можно ознакомиться с информацией об установленной версии.

Десятая страница информирует об успешном завершении установки.

Младшая тестированная на совместимость версия - 9.2.0.1. Использование более младшей версии на клиенте недопустимо.

Если вы устанавливаете Oracle не с компакт-дисков, то не пользуйтесь программой автозапуска, лежащей в корне первого установочного диска, а запустите setup.exe из каталога install\win32 на первом установочном диске.

Шаги установки примерно следующие:

Первая страница содержит логотип Oracle и командные кнопки. Для продолжения установки нажмите кнопку "Next".

На второй странице необходимо определиться с путями установки и источника, а также с именем "дома". Настоятельно рекомендуется принять значения, предлагаемые по умолчанию.

На третьей странице необходимо выбрать устанавливаемый продукт. Для рабочей станции необходимо установить продукт "Oracle9i Client 9.2.0.1.0".

На четвертой странице необходимо выбрать тип установки. Для обеспечения требуемой функциональности выберите тип "Runtime".

На пятой странице необходимо подтвердить правильность параметров установки.

В процессе установки инсталлятор потребует настроить параметры соединения с сервером БД. Для этого запустится отдельный мастер "Oracle Net Configuration Assistant", и процесс установки будет приостановлен на время работы этого мастера.
Если этого по каким-либо причинам не произошло, то после завершнения установки необходимо запустить это приложение из меню "Пуск" и выполнить описанные в этом и следующих шагах действия.
На этой (первой) странице мастера необходимо отказаться от использования службы каталогов, выбрав кнопку "No, I will create net service names myself...".

На второй странице мастера необходимо выбрать версию базы данных. Базы данных версии Oracle8 в любом случае не поддерживаются "Мельницей данных", поэтому выберите кнопку "Oracle8i or later database or service".

На третьей странице мастера необходимо ввести имя сервиса, идентифицирующего базу данных на сервере (в данном случае - "RTT"). Это имя устанавливается при создании базы данных.

На четвертой странице мастера выберите из списка доступных для соединения с БД протоколов протокол "TCP".

На пятой странице мастера введите адрес сервера, на котором установлена БД. Можно вводить как символьное имя сервера, так и IP-адрес. На этой же странице выберите порт TCP/IP, по которому будет производиться соединение с сервером. Порт по умолчанию - 1521.

На шестой странице мастер предлагает протестировать заданные на предыдущих шагах параметры. Выберите кнопку "Yes, perform a test".

Если введенные на предыдущих страницах параметры соединения с БД были заданы корректно, то мастер сообщит об этом:

На восьмой странице введите имя псевдонима подключения, который будет использоваться в дальнейшем для установки соединения с БД приложениями "Мальницы данных". Во избежание путаницы настоятельно рекомендуется именовать псевдоним так же, как и службу на сервере (в данном случае - RTT). сообщит об этом:

На девятой странице мастера у вас есть возможность выбрать, настроить еще одно подключение или завершить работу с мастером. После завршения установки вы всегда сможете вернуться к процедуре создания псевдонима подключений, вызвав из меню "Пуск" приложение "Oracle Net Configuration Assistant".

На десятой странице мастер сообщает об успешном создании псевдонима соединения с БД.

На десятой странице мастер сообщает об успешном завершении своей работы.

После завршения работы мастера "Oracle Net Configuration Assistant" вы увидете сообщение об успешном завершении работы инсталлятора. Нажмите кнопку "Exit".

4.2. Установка программного обеспечения платформы "Мельница данных"

Для установки ПП "Мельница данных" необходимо запустить файл setup.exe, расположенный на поставляемом компакт диске. После запуска программы установки необходимо следовать указаниям мастера установки.

Шаг 1: Выбор языка

Шаг 2: Информация о версии устанавливаемого ПП

Шаг3: Выбор каталога установки файлов ПП

Шаг 4: Выбор файла лицензии

Файл лицензии также расположен на поставляемом компакт-диске или высылается по электронной почте. В случае если не выбран никакой файл лицензий, то программа будет установлена в демонстрационном режиме. В последующем после получения файла лицензий необходимо будет переустановить ПП. Подробнее с лицензионным соглашением можно ознакомится в одноименном разделе настоящей документации.

Шаг 5: Выбор компонентов для установки

На данном шаге вам необходимо выбрать набор компонентов для установки на локальный компьютер. В зависимости от специфики использования рабочего места, на которое устанавливается ПО, необходимо выбрать тип установки. Предлагаемые типы установок:

Рабочее место пользователя

Рабочее место администратора

Рабочее место разработчика

Только построитель запросов

По выбору

Для каждого из типов установки по умолчанию устанавливается свой набор компонентов. Вы можете дополнительно отметить тот или иной необходимый вам компонент для установки. Для выбора будут отображены только те компоненты, которые влачены в указанном вами лицензионном файле.

Полный перечень компонентов для установки:

Обозреватель данных

Построитель запросов

Утилита обслуживания баз данных

Утилита слияния баз данных

Инструменты разработчика / Инструмент поставки решений

Отладочный монитор

Документация

Для некоторых из вышеперечисленных компонентов также можно выбрать состав устанавливаемого компонента. Описание назначений поставляемых компонент описано в разделе "Поставляемые компоненты ПП" настоящей документации.

После указания всех параметров мастер установки скопирует файлы на локальный компьютер и создаст в меню программ папку с ярлыками к установленным компонентам:

4.2.1. Поставляемые компоненты ПП "Мельница данных"

Обозреватель данных (DataBrowser) - Основное приложение позволяющее просматривать и модифицировать данные. Приложение используется для разработки прикладных решений. Позволяет описывать объекты БД, их свойства, методы, пользовательские формы и отчеты. Это же приложение используется для работы с разработанными прикладными решения пользователями на локальных рабочих местах.

Утилита обслуживания базы данных (DBSetupShell) - Приложение, позволяющее создавать и обслуживать выбранную базу данных любой из поддерживаемых СУБД. Также при помощи данной утилиты можно создавать и удалять пользователей БД, создавать и восстанавливать резервные копии БД, импортировать и экспортировать данные из/в БД, а также выполнять процедуры по контролю целостности БД.

Построитель запросов (QueryBuilder) - Приложение, позволяющее визуальными средствами создавать интерактивные запросы на основе данных хранящихся в используемой БД. Созданные запросы сохраняются в стандартный формате SQL и полностью удовлетворяют архитектуре клиент-сервер. Сохраненные в виде файла запросы могут быть открыты пользователем по необходимости. Полученная таким образом информация будет актуальна в любой момент времени. Также существует возможность создания статистического отчета на основе Excel шаблона.

Отладочный монитор (DebugView) - Средство позволяющее отслеживать все запросы к БД генерируемые "клиентской частью" прикладного решения, а также результат их исполнения сервером СУБД. Используется для отладки в процессе разработки прикладного решения.

Утилита слияния баз данных (Merger) - Данная утилита позволяет сравнивать данные и метаданные 2х различных БД. При помощи данного приложения можно с легкостью перенести, например данные из резервной копии в рабочую БД в случае не преднамеренного удаления большого числа объектов, тем самым избежать необходимости восстановления резервной копии недельной давности. Также используется для обновления версии ПП.

Редактор файлов документации (HelpEditor) - Незаменимое средство создания электронной справки и файлов документации в стандартном формате chm.

4.3. Создание и начальная инициализация базы данных

Для создания БД необходимо вопрользоваться утилитой обслуживания базы данных, поставляемой в комплекте ПП. После запуска одноименного приложения откроется окно панели управления утилиты:

После запуска одноименного приложения откроется окно панели управления утилиты:

Для доступа к задачам необходимо заполнить параметры работы с базой данных:

Источник данных : Необходимо указать используемую СУБД.

База данных : Необходимо указать наименование создаваемого файла БД и его месторасположение. (Пример: c:\databases\base.fdb)

Пользователь : Указать имя пользователя (Администратора) для используемой СУБД. Для Interbase/FireBird - SYSDBA, для Oracle - SYS.

Пароль : Указать пароль пользователя (Администратора) для используемой СУБД. Для Interbase/FireBird - masterkey, для Oracle - SYS.

После заполнения полей параметров можно приступать к созданию БД. Для создания новой базы данных необходимо воспользоваться задачей "Создать новую БД". После нажатия кнопки "Выполнить" будут выполнены команды отображенные в окне "Командная строка".

Днные команды можно выполнить самостоятельно из командной строки операционой системы или из любого другого приложения. Также создать пустую БД можно средствами входящими в комплекты поставок соответствуеющих СУБД.

В окне "Вывод консольного приложения" будет отображен результат выполнения команд по созданию БД. В случае успешного выполнения всех необходимых команд, БД будет создана по указанному в параметрах месторасположению.

После создания пустой БД необходимо наполнить ее системными объектами (метаданными) для последующей работы с ПП "Мельница данных". Для этого необходимо выполнить задачу "Синхронизировать базу данных". После нажатия кнопки "Выполнить" будет автоматически запущен отладочный монитор отображающий процесс наполнения БД необходимыми метаданными. Данный процесс может занять от одной до нескольких минут в зависимости от используемой СУБД и производительности сервера. (Обычно около минуты) По окончании процесса в окне "Вывод консольного приложения" будет отображен результат выполнения инициализации базы данных.

Все действия по созданию и инициализации БД выполнены. БД готова к эксплуатации.

4.4. Управление доступом пользователей

После того, как база данных создана и инициализирована метаданными платформы, доступ к системе будет иметь один пользователь - администратор созданной БД. Добавление других пользователей, ролей пользователей и включение пользователей в роли выполняется в представлениях Пользователи и Роли в Системной форме. После начальной инициализации БД на вкладке Пользователи можно увидеть одного пользователя с именем, соответствующим логину администратора БД (Например, для FireBird пользователь SYSDBA), на вкладке Роли можно увидеть одну роль с наименованием Администраторы. На подчиненных вкладках этих представлений можно увидеть, что пользователь - администратор включен в роль Администраторы.

Профиль пользователя формируется путем определения для него:

Перечня доступных форм

Перечня доступных визуальных групп

Перечня групп запретов

Формирование профиля происходит одинаково как для роли, так и для отдельного пользователя. Однако рекомендуется формировать профили для ролей, а не для отдельных пользователей. В этом случае при подключении к системе новых пользователей, изменении параметров доступа для существующего пользователя достаточно будет включить пользователя в одну из ролей, или исключить его из роли. Роли рекомендуется формировать содержательным образом на основе распределения обязанностей реальных пользователей, работающих с прикладным решением.

4.4.1. Создание пользователей

Создание пользователя системы включает в себя два этапа:

Создание пользователя БД средствами используемой СУБД. Для этого наряду с возможностями каждой из СУБД Утилитой обслуживания БД предлагается действие Создать пользователя. Предлагаемые Утилитой по умолчанию пути к БД и параметры доступа требуют уточнения в зависимости от условий функционирования реальной БД. Задавать права доступа пользователя к объектам БД на данном этапе не надо.

В Системной форме на вкладке Пользователи создать нового пользователя при помощи соответствующего действия контекстного меню.

В поле Имя нужно вветси строку, строго соответствующую логину пользователя БД в вернем регистре.

Особых требований к полю Наименование не предъявляется. Однако рекомендуется вводить в это поле фамилию и имя реального пользователя системы, например, Смирнов Иван Николаевич, что позволить в последующем получать информативные данных об активности пользователей системы.

4.4.2. Создание ролей

Создание ролей производится на вкладке Роли Системной формы при помощи действия Создать, вызываемого из контекстного меню. Имя и наименование роли могут быть любыми строками. Однако именовать роли по названиям соответствющих функциональных участков системы, например,

Начальник отдела кадров

Инспектора по работе с личными данными персонала

Инспектора по социальным вопросам

В случаях, когда реальные пользователи совмещают несколько ролей, роли лучше формировать отдельно, после чего одного пользователя можно влючить одновременно в несколько ролей.

4.4.3. Включение пользователей в роли

В роль могут включаться как пользователи, так и другие роли. Для добавления в роль нового члена роли нужно выбрать роль на вкладке Роли, отрыть подчиненную вкладку Члены роли и вызвать на ней действие Создать. Поля формы параметров заполняются следующим образом:

Пользователь - в этом поле необходимо выбрать либо одного из пользователей, либо одну из ролей. В зависимости от того, выбран ли пользователь или роль, будет меняться доступность следующих ниже полей.

Основная роль - в этом поле можно установить значение Да или Нет. Если пользователь включен в нескольно ролей, то среди них можно выделить одну основную. Разработчик прикладного решения на платформе сможет использовать это значение для управления доступом к объектам системы. Поле доступно для выбора значения только в том случае, если в поле Пользователь выбран именно пользователь, а не роль.

Добавить связанные роли - в этом поле можно установить значение Да или Нет. Поле доступно для выбора значения только в том случае, если в поле Пользователь выбрана роль. При установке значения Да в роль будут включены также все роли, входящие в выбранную. при установке значения Нет будет включена только одна роль без подчиненных ролей.

После включения пользователя в роль он получает права доступа ко всем визуальным группам и формам, а также к группам запретов, заданным для роли.

4.4.4. Формирование перечня доступных визуальных групп

Визуальные группы создаются разработчиком прикладного решения. Работа с визуальными группами ведется в Системной форме на вкладке Визуальные группы. Каждая визуальная группа содержит набор форм и также может быть снабжена иконкой. Визуальные группы отображаются на Консоли управления, которая показывается при запуске системы.

Для каждой роли (или для отдельного пользователя) формируется перечень визуальных групп, которые будут ему доступны на Консоли управления. Если визуальных групп в прикладном решение не создано, или если пользователю не доступно ни одной визуальной группы, консоль управления не будет отображена. В этом случае при открытии системы пользователь увидит первую из доступных ему форм, которая открывается автоматически.

Для добавления новой визуальной группы, доступной роли или пользователю, необходимо выбрать роль или пользователя на соответствующей вкладке (Роли или Пользователи), отрыть подчиненное представление Доступные визуальные группы и выполнить в нем действие Создать. В форме параметров нужно выбрать одну из существующих визуальных групп. Если необходимо дать доступ к нескольким визуальным группам, действие создания нужно повторить.

Если пользователь включен в несколько ролей, то достаточно наличия доступа к визуальной группе в одной из этих ролей.

4.4.5. Формирование перечня доступных форм

Формы создаются разработчиком прикладного решения. Работа с визуальными группами ведется в Системной форме на вкладке Формы. Каждая форма представляет собой набор представлений, связанных друг с другом определенным образом. Иконки всех форм, доступных пользователю, отображаются на Панели инструментов в верхней части экрана. Нажимая на одну из иконок форм, пользователь может переключаться между ними. Если форма входит в одну из доступных пользователю визуальных групп, она отобразится на консоли управления. В этом случае переключаться между формами пользователь сможет как на Панели инструментов, так и на Консоли управления.

Для каждой роли (или для отдельного пользователя) формируется перечень форм, которые будут ему доступны на Консоли управления. При открытии системы пользователь видит первую из доступных ему форм, открываемую автоматически.

Для добавления новой формы, доступной роли или пользователю, необходимо выбрать роль или пользователя на соответствующей вкладке (Роли или Пользователи), отрыть подчиненное представление Доступные формы и выполнить в нем действие Создать. В форме параметров нужно выбрать одну из существующих форм. Если необходимо дать доступ к нескольким формам, действие создания нужно повторить.

Если пользователь включен в несколько ролей, то достаточно наличия доступа к форме в одной из этих ролей.

4.4.6. Формирование перечня групп запретов

Группы запретов могут формироваться как разработчиком прикладного решения, так и администратором системы. Работа с группами запретов ведется на соответствующей вкладке Системной формы. В каждую группу запретов включаются запреты трех видов:

Запрет на класс

Запрет на свойство

Запрет на подпрограмму

Запреты на класс и свойство могут даваться как только на запись, так и на чтение и запись объектов. Наличие запретов для определенной роли или пользователя приводит к тому, что пользователь не видит или не имеет прав на модификацю объетов определенных классов или отдельных их свойств. Запреты на подпрограммы выражаются в том, что для пользователя не отображаются действия, вызывающие ряд подпрограмм.

4.5. Ключи командной строки утилиты обслуживания БД

Утилита обслуживания БД - консольное приложение. При запуске приложения оно сообщает о поддерживаемых режимах и ключах командной строки. Ключи указываются через пробел. Ключ должен начинаться символом "/". Для ключей, содержащих значения параметров, между ключем и значением должен быть пробел. Имена файлов и папок, содержащие пробелы, в командной строке должны быть заключены в кавычки.

При работе с утилитой общее правило состоит в том, что первым параметром передается строка соединения с БД, вторым параметром необязательная команда. Остальные параметры и ключи указываются в зависимости от выбранной команды.

Если работа утилиты завершилась успешно, то она возвращает код завершения 0. Если в процессе работы утилиты произошли ошибки, то код завершения будет равен 1. Если работа утилиты завершилась успешно, но были выданы предупреждения, то она возвращает код завершения 2.

Поддерживаемые команды:

<Команда не указана>

Инициализация/cинхронизация БД

ping

Проверка доступности БД

pump

Перекачка данных

check

Проверка целостности БД

build

Перестройка всех метаданных

load

Загрузка доступных файлов

export

Экспорт реплики данных

import

Импорт реплики данных

Далее будут рассмотрены подробности работы каждого из режимов.

4.5.1. Перекачка данных

Для осуществления перекачки данных необходимо:

Иметь права владельца схемы в БД - приемнике.

Иметь права владельца схемы в БД - источнике.

Если не задан ключ /M, то БД - приемник должен быть пустой схемой, не содержащей никаких объектов.

Эти условия контролируются утилитой dbsetup.exe.

Перекачка данных осуществляется в любом направлении. Ниже представлены варианты сочетания источников и приемников данных. В случае, если попытка использовать тот или иной оптимизационный механизм оказалась неудачной, производится стандартная перекачка.

Приемник

Источник

БД MSSQL

БД Firebird

БД Oracle

БД PostgreSQL

Папка, файл, zip-архив

БД MSSQL

Стандартная перекачка данных

БД Firebird

Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("external table").

Предпринимается попытка использовать механизм "внешний источник данных" ("external data source").

Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("external table").

БД Oracle

Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("table organization external").

Предпринимается попытка использовать механизм "связи БД" ("database link").

Предпринимается попытка использовать механизм загрузки данных из внешних таблиц ("table organization external").

БД PostgreSQL

Предпринимается попытка использовать механизм загрузки данных из внешнего текстового файла оператором COPY.

Предпринимается попытка использовать расширение "dblink".

Предпринимается попытка использовать механизм загрузки данных из внешнего текстового файла оператором COPY.

Папка, файл, zip-архив

Стандартная перекачка данных

Предпринимается попытка собрать на сервере blob, содержащий целевой xml-документ.

Не имеет смысла.
Просто скопируйте файлы.

Используемые параметры и ключи командной строки:

Для перекачки данных используюется команда pump. В строке соединения указывается БД-приемник, кроме случая перекачки данных из БД в папку, файл или zip-архив. Для всех случаев кроме случая перекачки данных из БД в папку, файл или zip-архив командная строка содержит кляузу pump from. Для случая перекачки данных из БД в папку, файл или zip-архив командная строка содержит кляузу pump to.

Перекача данных из БД Oracle в БД Firebird:
dbsetup.exe fb#sysdba/masterkey@host:database pump from ora#dataowner/password@host/sid.dataowner
Перекача данных из zip-архива в БД Firebird:
dbsetup.exe fb#sysdba/masterkey@host:database pump from c:\dbbackup.zip
Перекача данных из БД Firebird в zip-архив:
dbsetup.exe fb#sysdba/masterkey@host:database pump to c:\dbbackup.zip
Ключ

Назначение

/J <Целое число>

Определяет число потоков, осуществляющих перекачку данных. По умолчанию соответствует количеству ядер процессора.

/H <Целое число>

Определяет базовое количество записей в блоке перекачки. По умолчанию - 1 млн. записей. Для таблиц, содержащих большие объекты (blob и/или clob) размер блока перекачки определяется как базовый размер блока, деленный на 100. Если источником является папка, файл или zip-архив - ключ игнорируется.

/M

Пропустить этап создания таблиц и последовательностей в БД (таблицы и последовательности должны быть созданы заранее).

/G

Пропустить этап заливки данных, произвести только создание таблиц и последовательностей в БД.

/K <Список таблиц>

Не перекачивать данные указанных таблиц. Список таблиц разделяется символом ";" (точка с запятой).

/NODBLINK

Принудительно отключает механизмы связи между БД на сервере.

/NOCSV

Принудительно отключает механизмы загрузки данных из внешнего файла.

/NOXML

Принудительно отключает механизмы cборки xml-документа на сервере.

Информация о значениях типа "внешние данные" будет перенесена из источника в приемник, сами внешние данные при этом перенесены в хранилище не будут.

При перекачке данных учитыватся табличное пространство ("группа файлов") каждой таблицы в случае, если это понятие релевантно для источника и приемника. При использовании папки, файла или zip-архива имя табличного пространства каждой таблицы сохраняется в файле RTTI, и будет использовано, если окажется релевантным. Если в приемнике имеется возможность разместить таблицу в табличное пространство с тем же именем, которое указано в источнике, то это будет сделано.

При перекачке данных таже осуществляется перенос последовательностей. При этом переносится текущее значение каждой из последовательностей. Значение кеша последовательности переносится только в том случае, если это понятие релевантно для источника и для приемника. При использовании папки, файла или zip-архива значение кеша сохраняется в файле Sequences, и будет использовано, если окажется релевантным.

После завершения перекачки данных в схеме-приемнике остаются следующие объекты:

Таблицы данных.

Первичные ключи таблиц данных.

Последовательности.

Заголовки системных объектов платформы.

Этот набор минимально достаточен, чтобы с помощью синхронизации (загрузив метаданные из таблиц, с ключем /T) восстановить метаданные БД в соответствующей схеме, и работать с ней средствами платформы.

Особенности перекачки данных в папку, файл или zip-архив:

При использовании папки она рассматривается как хранилище файлов перекачки. При использовании файла он рассматривается как хранилище файлов перекачки в формате Microsoft Compound File. При использовании zip-архива он рассматривается как хранилище файлов перекачки. Хранилище файлов перекачки содержит следующие файлы:

FormatSettings - xml-файл с информацией о региональных настройках процесса, сформировавшего хранилище.

Sequences - xml-файл с информацией о текущих значениях последовательностей.

RTTI - xml-файл с информацией о таблицах и полях. Также содержит информацию о табличных пространствах.

<Имя Таблицы> с возможным числовым постфиксом в скобках - xml-файл с данными таблицы в стандартном xml-представлении.

#<Длина файла в 16-ричном представлении, 16 символов><CRC файла в 16-ричном представлении, 8 символов> - двоичный файл с содержимым blob/clob. Такие файлы формируются для объектов, чей размер превышает 1MB.

Остальные файлы в хранилище будут проигнорированы (если хранилище используется как источник) или удалены (если хранилище используется как приемник).

Если в качестве приемника используется zip-архив, то механизм перекачки данных будет использовать информацию об уже содержащихся в архиве файлах, и не будет повторно "пересжимать" уже имеющиеся файлы. Таким образом, можно удобно релизовать "инкрементальное резервное копирование", указывая в качестве приемника перекачки данных один и тот же zip-архив.

4.5.1.1. Стандартная перекачка данных

Стандартная процедура перекачки блока данных заключается в открытии однонаправленного курсора на основании запроса типа select... from "..." к таблице-источнику, подготовке запроса insert into "..."("ID",.....) values (:Param1, :Param2....) к приемнику, и многократному выполнению этого единожды подготовленного запроса по мере продвижения вперед по курсору-источнику. Все значения полей при этом проходят через клиентскую сторону, и заливка данных осуществляется по одной записи за одно выполнение запроса. Характерная скорость такой заливки - порядка 5000 записей в секунду.

Оператор INSERT в процессах перекачки данных всегда формируется с подсказкой /*+ APPEND */.

Описанные далее механизмы оптимизации не могут использоваться одновременно. Если какой-либо из них может быть использован в вашей ситуации - постарайтесь обеспечить условия, необходимые для их работы. Вы получите значительное ускорение перекачки.

4.5.1.2. Механизмы связи между БД на сервере

Будут формироваться и выполняться блоки вида
01execute block as
02  declare "ID" BIGINT;
03  declare "P0" SMALLINT;
04  .....
05begin
06  for execute statement 'select "ID", .... from "...."'
07    on external data source '....' as user '...' password '....'
08    into :"ID",:"P0",..... do
09      insert into "...."("ID",....)
10      values (:"ID",:"P0",.....);
11end
Механизм может быть использован, если пользователь-владелец схемы имеет право CREATE DATABASE LINK, и оператор create database link будет выполнен без ошибок. При этом будет создан link с именем "SYS$PUMP". После завершения процедуры перекачки данных link будет удален. Таким образом, можно в целях безопасности выдавать право CREATE DATABASE LINK владельцу схемы данных только на время перекачки данных. При этом генерируются и выполняются операторы вида
1INSERT /*+ APPEND */ INTO "..."("ID", ....)
2SELECT "ID", ....
3  FROM "..."@"SYS$PUMP"
4...
Механизм может быть использован, если в БД установлено стандартное расширение "dblink", и оператор select public.dblink_connect('user=... password=.......') будет выполнен без ошибок. При этом генерируются и выполняются операторы вида
01do $$
02declare
03  cnt int;
04begin
05  perform public.dblink_connect('user=... password=... ....');
06  perform public.dblink_open('SYS$....', 'select T."ID", ..... from "...." T');
07  loop
08    insert into "...." ("ID", .....)
09    select T."ID" from public.dblink_fetch('SYS$.....', 1000000)
10    as T("ID" bigint, .....);
11    get diagnostics cnt = row_count;
12    exit when cnt = 0;
13  end loop;
14end; $$
Механизм может быть принудительно заблокирован ключем /NODBLINK.

4.5.1.3. Загрузка данных из внешнего файла

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:

Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).

Временная папка процесса dbsetup.exe (переменная окружения %TMP%) доступна сервису Firebird как источник внешних данных (в конфигурации FireBird - параметр ExternalFileAccess).

Таблица не содержит полей типа BLOB.

Таблица не содержит обнуляемых полей, все поля таблицы обязательные.

Загружаемый блок содержит как минимум 1000 записей.

В этом случае во временной папке будет создан временный файл, содержащий загружаемые данные в требуемом Firebird формате, и выполнены операторы:
1create table "DML..." external '.....'
2  ("ID" BIGINT,
3  ....);
4insert into "..."("ID", ...)
5  select "ID", ....
6  from "DML....";
7drop table "DML....";
После чего временный файл будет удален.

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:

Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).

Владельцу данных доступна на чтение и запись хотя бы одна папка (directory). Этого можно достичь, например, такими операторами:
1CREATE DIRECTORY dir_name AS 'D:\TEMP';
2GRANT READ,WRITE ON DIRECTORY dir_name TO user_name;
При этом папка (на диске) должна быть доступна на запись процессу dbsetup.exe.

Оператор
01create table "DML...."
02(
03 ....
04) ORGANIZATION EXTERNAL (
05  DEFAULT DIRECTORY ....
06  ACCESS PARAMETERS (
07    RECORDS DELIMITED BY NEWLINE
08    FIELDS TERMINATED BY '....'
09  )
10  LOCATION ('DML.....')
11)
выполняется без ошибок. Созданная при этом таблица доступна для чтения.

Таблица не содержит полей типа BLOB.

Загружаемый блок содержит как минимум 1000 записей.

В этом случае в папке, которая доступна, будет создан временный файл, содержащий загружаемые данные в требуемом Oracle формате, и выполнены операторы:
1create table "DML....."
2(
3 ....
4) ORGANIZATION EXTERNAL (
5....);
6insert into "..."("ID", ...)
7  select "ID", ....
8  from "DML....";
9drop table "DML....";
После чего временный файл будет удален.

Чтобы использовать загрузку из внешнего файла, необходимо, чтобы одновременно выполнялись следующие условия:

Сервер БД выполняется на том же хосте, на котором происходит запуск dbsetup.exe (в строке соединения хост не указан, указан как localhost, указан как 127.0.0.1, указан так, чтобы совпадать с результатом вызова функции gethostname).

Временная папка процесса dbsetup.exe (переменная окружения %TMP%) доступна сервису PostgreSQL как источник внешних данных.

В этом случае в папке, которая доступна, будет создан временный файл, содержащий загружаемые данные в требуемом Postgres формате. В случае, когда размер файла превысит 1GB, а также по исчерпании источника, будет выполнен оператор
  copy "..."(...) from %TEMP%\DML....CSV with (format csv, encoding UTF8)
После чего временный файл будет удален.

Механизм может быть принудительно заблокирован ключем /NOCSV.

4.5.1.4. Сборка xml-документа на сервере

Механизм создает большую нагрузку на сервер БД, но в то же время позволяет существенно ускорить перекачку данных.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующие условия:

Таблица не содержит полей типа BLOB.

Таблица не содержит строковых полей, которые могут содержать не-xml-compaint символы (определяется по свойствам соответствующего строкового домена.

В этом случае будут формироваться и выполняться запросы вида
1with T as (select T.* from "...." T order by T."ID")
2select cast(cast(
3  '<data handle="' || count(1) ||  '" eof="1">' || list('<row>' ||
4    '<ID type="int64">' || T."ID" || '</ID>' ||
5      case when T."..." is null then '<.../>' else '<... type="int">' || T."..." || '</...>' end ||
6      ......
7    || '</row>' , '') || '</data>' as blob sub_type 1 character set utf8) as blob sub_type 0), count(1)
8  from T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующие условия:

Используется Oracle версии не ниже 11.

Таблица не содержит полей типа BLOB.

В этом случае будут формироваться и выполняться запросы вида
1with T as (select T.* from "..." T )
2select "SYS$HELPER"."ClobToBlob"('<data handle="' || count(1) || '" eof="1">' ||
3  xmlagg(xmlelement("row", xmlelement("ID", xmlattributes('int64' as "type"), T."ID"),
4    case when "..." is null then xmltype('<..../>') else
5      xmlelement("....", xmlattributes('ascii' as "type"), "SYS$HELPER"."XMLEscape"(asciistr(T."...."), 0)) end,
6    ....
7 order by T."ID").getclobval() || '</data>'), count(1) from T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Чтобы использовать формирование xml-документов на сервере, необходимо, чтобы одновременно выполнялись следующее условие:

Таблица не содержит полей типа BLOB.

В этом случае будут формироваться и выполняться запросы вида
1select convert_to( '<data handle="' || count(1) ||  '" eof="1">' || string_agg(
2  '<row>' ||
3    '<ID type="int64">' || T."ID" || '</ID>' ||
4    case when T."...." is null then '<..../>' else '<.... type="int64">' || T."...." || '</....>' end ||
5    .....
6  '</row>', '' order by T."ID") || '</data>', 'UTF8'), count(1) from "..." T
При выполнении такого запроса клиент получит blob, содержащий требуемый xml-документ в требуемой кодировке.

Механизм может быть принудительно заблокирован ключем /NOXML.

4.6. Ключи командной строки инсталлятора платформы

Для автоматизации установки или обновления платформы инсталлятор платфромы setup.exe поддерживает ключи командной строки.

Указание ключей командной строки не превращет инсталлятор платфромы setup.exe в консольное приложение. Поэтому если вы включаете запуск инсталлятора в файл пакетной обработки, вам, возможно, потребуется дождаться завершения процесса установки. Для этого рекомендуется использовать команду start (с ключем /w или /wait. Рекомендуется ознакомиться со справкой по команде start перед ее использованием) :
start /w "SOME_TITLE" "...\SOME_FOLDER\setup.exe" /N /S /P /F .....
Ключи указываются через пробел. Ключ должен начинаться символом "/". Для ключей, содержащих значения параметров, между ключем, символом "=" и значением параметра пробелов быть не должно.

Ключи командной строки:

Ключ

Назначение

/S

Запускает инсталлятор в режиме "без пользовательского интерфейса". Никакого взаимодействия с пользоваетелем не предусматривается. Если ключ /S не указан, то режимы, устанавливаемые остальными ключами, будут являться умолчаниями, и пользователь сможет их изменить в процессе взаимодействия с инсталлятором.

/NCRC

Отключает проверку целостности инсталлятора перед запуском.

/x64

Устанавливает компоненты 64-разрядной редакции. См. замечание 1.

/L="<Файл лицензии>"

Позволяет указать файл лицензии. Необходимо использовать полный путь к файлу. Если имя файла лицензии содержит пробелы, то его необходимо заключать в кавычки. См. замечание 2.

/T=<Число от 0 до 7>

Выбирает тип установки (состав устанавливаемых компонент).

0 - Рабочее место пользователя

1 - Рабочее место администратора

2 - Рабочее место разработчика

3 - Только построитель запросов

4 - Сервер приложений

5 - Только сервер приложений

6 - Только отладочный монитор

7 - Только системные файлы

Точно установить, какие конкретно компоненты входят в тот или иной тип установки можно, запустив инсталлятор, на странице "Параметры установки". Там указано соответствие между типами установки и устанавливаемыми компонентами.

/LANG=<Идентификатор языка>

Поддерживаемые языки:

1033 - Английский

1049 - Русский

1034 - Испанский

/N

Без регистрации компонентов в реестре и создания ярлыков. Только копирование файлов.

/NOREGISTER

/U

Без создания ярлыков. Только копирование файлов и регистрация компонентов.

/UPDATE

/NOSERVICE

Не регистрировать сервисы в системе.

/P

Не проверять возможность обновления файлов.

/NOPROCLIST

/F

Не устанавливать третьесторонние распространяемые файлы.

/NOINSTALLREDIST

/NODISABLEOFFICECLIPBOARD

Не устанавливать библиотеку поддержки приложений Microsoft Office.

/NO_DISABLE_OFFICE_CLIPBOARD

/D=<Папка установки>

Указывает папку установки. Необходимо указывать полный путь к папке.

Этот ключ может быть указан только последним в командной строке, либо не указан вообще.

Даже если имя папки установки содержит пробелы, то заключать в кавычки значение ключа /D не нужно.
setup.exe /NCRC /S /D=C:\Program Files\Data Mill
Замечания:

Если ключ /x64 не задан, но в папке установки уже содержится папка WIN64, то все равно будет устанавливаться (в данном случае - обновляться) 64-битная редакция.

Если ключ /L=... не задан, но рядом с инсталлятором пллатформы setup.exe находится хотя бы один файл с расширением .license, то в качестве файла лицензии будет использоваться один из этих файлов (первый найденный).

4.7. Форматы и соглашения

4.7.1. Стандартная адресация базы данных платформы

Строка адресации БД платформы "Мельница данных" состоит из следующих элементов:
Сервер#Пользователь:Роль/Пароль@БазаДанных

Сервер - один из следующих вариантов:

MS - БД MSSQL

FB - БД Firebird

ORA - БД Oracle Database

PG - БД PostgreSQL

MY - БД MySQL

APP - Удаленное подключение к БД через сервер приложений

Пользователь - имя пользователя, используемого для соедиения.

Роль - роль, ассоциированная с соединением.

Роль, заданная в строке адресации БД, используется для установки соединения с БД (передается через параметр isc_dpb_sql_role_name)

Для всех СУБД, кроме Firebird, указание роли имеет смысл только для утилиты обслуживания БД.

Пароль - пароль пользователя, используемый для соедиения. Пароль также может быть не задан в строке соединения (после символа "/" сразу следует символ "@"). В этом случае пароль будет запрошен у пользователя (если будет такая возможность), или будет использоваться Negotiate-аутентификация.

БазаДанных - адресует собственно базу или схему данных.
При использовании удаленного подключения к БД через сервер приложений используется нотация
protocol://Host:Port/handler
Протокол (protocol) может быть http или https. По умолчанию используется протокол http. Порт (Port) по умолчанию 80 для протокол http и 443 для протокола https может быть опущен.

Host:Port\\InstanceName.Database
Порт (Port) по умолчанию 1433 может быть опущен вместе с двоеточнием. Хост (Host) может быть опущен, если используется локально. Имя экземпляра (InstanceName) может быть опущено, если используется имя "MSSQLSERVER". Следующие строки эквивалентны:
1localhost:1433\\MSSQLSERVER.MillDatabase
2localhost\\MSSQLSERVER.MillDatabase
3localhost.MillDatabase
4MillDatabase
Host/Port:DBPath
Порт (Port) по умолчанию 3050 может быть опущен. Если опущен хост (Host), то используется локальный протокол доступа к БД. Файл базы данных (DBPath) может быть задан как полное имя файла в файловой системе сервера, так и быть псевдонимом, настроенным на сервере.

Host:Port/SID.schema
Порт (Port) по умолчанию 1521 может быть опущен. Если опущен хост (Host), то используется имя из файа TNSNAMES.ORA в используемой клиентской части СУБД. Указание SID и имени схемы (schema) обязательно.

Host:Port/DataBase.schema
Порт (Port) по умолчанию 5432 может быть опущен. Если опущен хост (Host), то используется локальное соединение. Указание имени базы данных (DataBase) и имени схемы (schema) обязательно.

Host:Port/schema
Порт (Port) по умолчанию 3306 может быть опущен. Если опущен хост (Host), то используется локальное соединение. Указание имени схемы (schema) обязательно.

Прямое подключение к БД от имени владельца схемы данных является административным.

Владельцем схемы данных является пользователь, имя которого совпадает с именем схемы.

Никакое подключения к БД через сервер приложений не является административным.

5. Руководство разработчика на платформе

5.1. Решения, предлагаемые технологией "Мельница данных"

Технология "Мельница данных" предлагает решения традиционных проблем разработки и сопровождения учетных систем за счет следующих инноваций:

Объектная модель хранится в системе по тем же принципам, что и модель бизнес-данных, т.е. объекты классов, описывающих метаданные системы (классы, поля, методы, свойства, пользовательские формы) хранятся в базе данных и отображаются при помощи стандартного пользовательского интерфейса. Моделирование системного слоя метаданных системы произведено разработчиками платформы. Модель системного слоя документирована и доступна для просмотра и использования разработчикам прикладных систем.

Разработка прикладных учетных систем ведется в той же среде, что и работа конечных пользователей. Текущая модель прикладной системы доступна для просмотра и использования всеми разработчиками.

На основе заложенной объектной модели прикладной системы автоматически генерируется SQL-код (как DML, так и DDL составляющие), что полностью освобождает разработчика прикладной системы от SQL-программирования.

Пользовательские интерфейсы (формы, представления) также описываются при помощи объектной модели и хранятся в базе данных. Это позволяет автоматически генерировать формы просмотра данных и формы задания параметров методов, что освобождает разработчика прикладной системы от написания кода клиентского приложения. Для тонкого управления поведением форм задания параметров может использоваться язык VB-script.

При внесении изменений в объектную модель:

новое состояние модели отображается в пользовательском интерфейсе в доступной для всех разработчиков форме;

текущая объектная модель в виде диаграммы классов может быть выгружена в HTML-отчет, что является базовой возможностью платформы;

внесение изменений в структуру базы данных и пользовательские интерфейсы производится автоматически средствами платформы.

Основными элементами стандартизованного пользовательского интерфейса являются развитые элементы управления, работающие с данными:

Таблицы данных - отображают списки объектов в табличной форме, удобной для восприятия пользователя. Таблицы данных позволяют производить сортировку, группировку объектов, фильтрацию данных по ряду условий, подведение агрегатов (количества объектов, наибольшего, наименьшего значения, суммы, среднего и т.д.), отображение и скрытие групп, подведение итогов по группе. Таблицы данных имеют функционал, позволяющий отображать иерархические структуры, а также производить произвольный отбор отображаемых объектов пользователем. Используемые таблицы данных позволяют работать с большими объемами данных без потери производительности.

Инспектор объектов - отображает все свойства выбранных (одного или нескольких) объектов в двух колонках: имя свойства - значение свойства. Инспектор объектов позволяет просматривать все свойства объектов, а также изменять значения свойств как одного объекта, так и для всех выделенных объектов одним действием.

Форма задания параметров - отображается при вызове пользователем одного из методов. На форме расположены элементы управления Поле ввода, соответствующие описанным для метода параметрам. Внешний вид и поведение элементов управления зависят от типа описанных параметров. Поведением элементов управления на форме можно управлять при помощи скрипта формы, разрабатываемого на языке VB-script.

Поле ввода - используется для задания значений свойств и параметров как в Таблице данных, так и в Инспекторе объектов и на формах задания параметров. Имеет функционал, позволяющий редактировать значения различных типов. Использование стандартизованного пользовательского интерфейса позволяет снизить издержки как на его сопровождение, так и на обучение пользователей работе на новых участках.

Реализованы развитые возможности интеграции с третьесторонними системами. Они обеспечиваются следующими механизмами:

Возможность переноса в Microsoft Excel любого видимого представления "as-is" с сохранением всех группировок, сортировок, агрегатов и т. п.

Возможность вывода отчетов в виде документов Microsoft Office с передачей в среду функционирования Office соединения с БД, что позволяет строить отчеты любой степени сложности.

Возможность использования в системе любого внешнего Ole-объекта как метода любого класса без ограничений.

Возможность использования скриптлетов (фрагментов кода на скриптовом языке VBScript и/или JScript) как методов системы, фактически - возможность реализации на этих языках сколь угодно сложного поведения.

Возможность формирования отчетов непосредственно в виде html-документов для последующей публикации их в сети Internet.

5.2. Системный слой объектной модели "Мельница данных"

Технология разработки и сопровождения учетных систем "Мельница данных" требует для своего функционирования объектную модель бизнес-сущностей. Технология диктует ряд дополнительных требований к объектной модели.

Все классы наследуются от единого корня, класса TObject. Класс TObject вводит ряд элементов состояния, поведения и представления, которые наследуются всеми учитываемыми объектами в обязательном порядке.

Множественное наследование не поддерживается (т.е. у каждого класса может быть один и только один родитель).

Множественная инкапсуляция не поддерживается (т.е. у каждого объекта может быть один либо ни одного инкапсулирующего объекта).

Простые типы данных вводятся посредством доменов. Домены определяют обязательность своих значений, а также другие характеристики, зависящие от класса домена. Домены бывают:

строковые (определяют максимальную длину строки);

целочисленные (определяют максимальное и минимальное значение целого числа);

вещественные (определяют максимальное и минимальное значение числа, количество значащих цифр);

логические;

значения типа "дата";

значения типа "время";

значения типа "дата со временем";

перечисления (определяют список возможных значений);

ссылка (определяют класс-приемник ссылки);

большие двоичные объекты (текст, изображение, файл, и т.д.).

5.3. Наследование и переопределение членов класса и параметров подпрограмм

Все члены родительского класса наследуются дочерним классом следующим образом:
Поля
Все поля родительского класса доступны в дочернем классе. При создании в дочернем классе поля с тем же именем, что и в родительском классе, класс-наследник теряет возможность напрямую манипулировать полем родительского класса и получает поле с тем же именем. Можно сказать, что новое поле "закрывает" старое, но не "замещает" его.
Методы
Все методы родительского класса наследуются дочерним классом. При создании в дочернем классе метода с тем же именем, что и в родительском классе, метод переопределяется, т.е. вместо старого метода будет существовать новый. Единственный способом обратиться к старому (унаследованному) методу является использование в теле метода оператора унаследованного вызова inherited (см. раздел 5.3.14.). Переопределенный метод имеет все параметры родительского метода и может расширять список параметров, а также переопределять унаследованные параметры (создавая параметры с тем же именем и изменяя любой другой атрибут параметра по своему усмотрению). Скрипты форм задания параметров не наследуются и должны быть полностью заданы в переопределенном методе. Изображения-иконки методов наследуются и могут не переопределяться явно.
Свойства
Все свойства родительского класса доступны в дочернем классе. При создании в дочернем классе свойства с тем же именем, что и в родительском классе, класс-наследник теряет возможность напрямую манипулировать свойством родительского класса и получает свойство с тем же именем. Можно сказать, что новое свойство "закрывает" старое, но не "замещает" его. На практике часто бывает необходимо в унаследованном методе (особенно в конструкторе) скрыть часть параметров от пользователя, либо сузить область выбора значений для каких либо параметров. В этом случае необходимо переопределить параметры в унаследованном методе с новыми значениями свойства Scope ("Область видимости") или Domain ("Домен"). Это нормальная рекомендуемая практика. Необходимо понимать, что скрыв с формы элемент управления, соответствующий параметру, значение которого обязательно, необходимо предусмотреть, чтобы этот параметр получил значение до вызова унаследованного метода, либо из скрипта формы задания параметров, либо в теле самого метода.

В конструкторе класса, унаследованного от класса TObject, переопределен параметр Name, таким образом, что в свойстве "Область видимости" установлено значение "Не видимо пользователям". При этом тело метода конструктора должно выглядеть следующим образом:
1begin
2  Name := UniqueValue;                    (1)
3  inherited;                         (2)
4  // инициализация собственных полей
5end;
Параметр конструктора Description, унаследованный от конструктора класса TObject останется видимым и его значение будет в обязательном порядке установлено пользователем при помощи формы задания параметров. Значения параметров Parent и Master будут определены из контекста вызова или запрошены у пользователя. Параметр Name не будет отображен на форме задания параметров и в начале выполнения тела метода его значение будет пустым (nil). В связи с этим в строке (1) тела метода производится установка значения параметра Name при помощи функции UniqueValue. Если этого не сделать, то вызов унаследованного метода при помощи оператора inherited вернет ошибку, связанную с тем, что параметр Name имеет недопустимое значение.

5.4. Средства моделирования пользовательского интерфейса

5.4.1. Представления

5.4.2. Визуальные группы

5.4.3. Формы, связь представлений в формах

5.5. Объектно-реляционное отображение

5.6. Обзор возможностей Платформы

5.7. Этапы разработки прикладных решений

5.7.1. Формирование видения модели

5.7.2. Создание структур хранения и средств обработки данных

5.7.2.1. Класс TObject, члены класса TОbject

5.7.2.2. Создание классов

5.7.2.3. Создание полей

5.7.2.4. Создание свойств

5.7.2.5. Создание методов

5.7.3. Синхронизаци базы данных

5.7.4. Создание пользователей и ролей

5.7.5. Средства моделирования пользовательских интерфейсов

5.7.5.1. Представления

5.7.5.2. Формы. Включение представлений в формы

5.7.5.3. Визуальные группы. Включение форм в визуальные группы

5.7.5.4. Организация доступа пользователей к формам и визуальным группам

5.7.6. Разработка отчетов

5.7.6.1. Создание шаблонов PDF-отчетов

5.7.6.1.1. Описание

Portable Document Format (PDF) — кроссплатформенный формат электронных документов, созданный фирмой Adobe Systems с использованием ряда возможностей языка PostScript. В первую очередь предназначен для представления в электронном виде полиграфической продукции, — значительное количество современного профессионального печатного оборудования может обрабатывать PDF непосредственно. Для просмотра можно использовать официальную бесплатную программу Adobe Reader, а также программы сторонних разработчиков. Традиционным способом создания PDF-документов является виртуальный принтер, то есть документ как таковой готовится в своей специализированной программе — графической программе или текстовом редакторе, САПР и т. д., а затем экспортируется в формат PDF для распространения в электронном виде, передачи в типографию и т. п. Формат PDF позволяет внедрять необходимые шрифты (построчный текст), векторные и растровые изображения, формы и мультимедиа-вставки. Поддерживает RGB, CMYK, Grayscale, Lab, Duotone, Bitmap, несколько типов сжатия растровой информации. Имеет собственные технические форматы для полиграфии: PDF/X-1, PDF/X-3. Включает механизм электронных подписей для защиты и проверки подлинности документов. В этом формате распространяется большое количество сопутствующей документации. Чаще всего PDF-файл является комбинацией текста с растровой и векторной графикой, реже — текста с формами, JavaScript'ом, 3D-графикой и другими типами элементов.

В приложениях Платформы "Мельница данных" для создания PDF-документов используется собственная библиотека PDFCreator.dll. С помощью библиотеки возможно прямое создание документов версии 1.3 . Создание PDF-документов осуществляется путем ввода предопределенных в библиотеке команд, которые в дальнейшем интерпретируются на основе языка описания страниц POSTSCRIPT.

Все размеры графических объектов, размеры страниц, шрифтов и т.п. по умолчанию заданы в миллиметрах.

Для удобства построения шаблона PDF-документа создана функция DrawGrid. При ее включении при отладке при создании шаблона будет отображена визуальная сетка с шагом 5 миллиметров.

5.7.6.1.2. Методы

5.7.6.1.2.1. Свойства документа

Для создания и описания свойств PDF-документа в библиотеке PDFCreator.dll используется класс IPDFDocument, обладающий следующими свойствами:

Title (WideString) - заголовок документа. По умолчанию - пустая строка.
Title = "DOC1"
CanEmbedFonts (WordBool) - Признак возможности построения PDF- документа со встроенными шрифтами (Embedded Fonts). В случае включения признака, все объявленные в скрипте шрифты будут включены в сборку документа и будут передаваться целиком вместе с документом. По умолчанию - False.
CanEmbedFonts = True
CanEmbedFonts = False
CanCompress (WordBool) - признак сжатия документа при создании по собственным алгоритмам. По умолчанию - True.
CanCompress = False
CanCompress = True
Author (WideString) - автор документа. По умолчанию - текущий пользователь ОС.

Subject (WideString) - описание документа. По умолчанию - пустая строка.

Keywords (WideString) - ключевые слова для поиска по документу. По умолчанию - пустая строка.

Creator (WideString) - приложение-родитель документа. Указывается в том случае, если документ был сконвертирован из другого формата.

PageCount (Integer) - свойство, содержащее общее количество страниц в документе.

Pages[Index: Integer]: IPDFPage - свойство документа, предназначенное для перебора страниц документа для совершения над ними однотипных действий.

Пример использования:
1for I = 0 to PageCount - 1
2  Pages(I).rectangle 10,10,10,10, false
3next
Save "c:\pdf.pdf"
Результат: На всех страницах документа будут нарисованы квадраты 10х10 мм.

procedure Save(Target: OleVariant) - процедура для сохранения документа PDF на жесткий диск сразу после создания.
Save "c:\pdf.pdf"
- сохранит документ в файл c:\pdf.pdf

5.7.6.1.2.2. Свойства страницы

Для создания страницы используется функция
function CreatePage(Parent: OleVariant): IPDFPage;
Параметр Parent указывает страницу-родителя для данной страницы. Если страницы- родителя быть не должно - формат вызова функции примет вид:
set page = CreatePage(Null)
Параметры страницы:

Title - заголовок страницы.
page.Title = "Page name"
Width - ширина страницы, миллиметры
page.Width = 80
Height - высота страницы, миллиметры
page.Height = 80
DrawGrid - процедура, выводящая на страницу сетку с шагом 5 миллиметров для удобства отладки вида документа.

Perform - процедура, позволяющая выполнить дополнительные команды PostScript на странице.
page.perform "1 0.7 0 0 k"page.perform "0 0 m"
5.7.6.1.2.2.1. Объявление цвета

Для объявления цвета объектов на странице используется цветовая модель R:G:B (Red:Green:Blue). Объявление цвета для выполнения последующих операций (цвет шрифта, цвет линии/фигуры) осуществляется процедурой
procedure SetColor(R: Integer; G: Integer; B: Integer);
Где параметры R, G, B - значения базисных цветов для выбранного цвета (от 0 до 255).

Цвет

R

G

B

Белый

255

255

255

+++

Черный

0

0

0

+++

Серый

190

190

190

+++

Синий

0

0

255

+++

Красный

255

0

0

+++

Зеленый

0

255

0

+++

Если предварительно цвет не был объявлен, используется цвет по умолчанию - черный (0,0,0)

5.7.6.1.2.3. Графика

5.7.6.1.2.3.1. Линии

Для отрисовки линий используется процедура
procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double);
Здесь:

X1 - координата начала линии по горизонтали в миллиметрах от верхнего левого угла листа.

Y1 - координата начала линии по вертикали в миллиметрах от верхнего левого угла листа.

X2 - координата конца линии по горизонтали в миллиметрах от верхнего левого угла листа.

Y2 - координата Конца линии по вертикали в миллиметрах от верхнего левого угла листа.

Для задания толщины линии используется свойство
property LineWidth: Double
Значение толщины задается в миллиметрах. Значение по умолчанию - минимально возможная единица рисования для устройства. Так для монитора - 1 pixel, для принтера - 1 dot (точка)

Для задания стиля отрисовки начала/окончания линии используется свойство property LineCap: TPDFLineCap
Возможные стили:

Значение свойства:

Отображение:

Описание:

0

Прямой срез точно по точкам начала и окончания линии (по умолчанию)

1

С закруглением

2

Прямой срез с продолжением линии на половину толщины линии

Объявление цвета линии.

Две линии разной толщины, с разными окончаниями и цветами:
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineCap = 1
06
07page.LineWidth = 2
08
09page.Line 10, 10, 30, 30
10
11page.LineWidth = 4
12
13page.SetColor 255, 0, 0
14
15page.LineCap = 2
16
page.Line 10, 30, 30, 10."I
Результат:

При необходимости соединения линий под углом в определенной точке можно задать тип соединения. Для объявления типа соединения используется свойство property LineJoin: TPDFLineJoin;
Типы соединения двух линий:

Значение свойства

Отображение

Описание

0

С острым углом

1

С закруглением

2

С обрезанным углом

Пунктир

Для создания пунктира используется процедура отображения линии с предварительно объявленными дополнительными значениями.

Процедура procedure SetDash(DashArray: OleVariant; Phase: Integer); Здесь DashArray - массив значений в миллиметрах, указывающий последовательность чередования штрихов и пропусков на линии, Phase - смещение в миллиметрах по линии.

Пример 1. Штрих 10 мм, Промежуток 5 мм, Смещения нет
Пример 2. Штрих 10 мм, Промежуток 5 мм, Смещение 5 мм
Пример 3. Различные значения штрихов и промежутков, Смещения нет
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 3
06
07page.SetDash Array(10, 5), 0
08
09page.Line 10, 10, 100, 10
10
11page.SetDash Array(10, 5), 5
12
13page.Line 10, 20, 100, 20
14
15page.SetDash Array(10, 5, 3, 2, 12, 20), 0
16
page.Line 10, 30, 100, 30
Результат:

Ломанная линия - здесь непрерывная линия, состоящая из нескольких прямых. Для отображения ломанной используется процедура procedure Poly(Points: OleVariant; Fill: WordBool), где Points - массив координат точек соединяемых прямыми, а Fill - признак заливки полученной замкнутой фигуры (если замкнута).

Пример Звезда без заливки
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), false
Результат:

Пример Звезда с заливкой
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.LineWidth = 3
6
page.Poly  Array(10, 45, 100, 45, 27, 103, 55, 10, 82, 103, 10, 45), true
Результат:

5.7.6.1.2.3.2. Прямоугольник

Rectangle (Прямоугольник) - для создания используется процедура:
procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double; Fill: WordBool);
Здесь:

X1 - координата верхнего левого угла прямоугольника по горизонтали в миллиметрах от верхнего левого угла листа шаблона.

Y1 - координата верхнего левого угла прямоугольника по вертикали в миллиметрах от верхнего левого угла листа шаблона.

Width - ширина прямоугольника с миллиметрах.

Height - высота прямоугольника с миллиметрах.

Fill - признак заливки прямоугольника (True/False). Если значение True то заливка производится объявленным заранее цветом (см. Объявление цвета). Если False - заливка не производится. Прямоугольник отрисовывается линиями с предварительно заданной толщиной. См. Линии

Пример 1. Создание красного прямоугольника:
1set page = CreatePage(Null)
2
3page.SetColor 255, 0, 0
4
5page.Rectangle 10, 15, 40, 20, True
6
page.DrawGrid
Результат:

Пример 2. Пустой прямоугольник без задания цвета:
1set page = CreatePage(Null)
2
3page.DrawGrid
4
5page.Rectangle 12, 17, 42, 25, false
6
page.DrawGrid
Результат:

Также существует возможность изменения стиля отображения углов прямоугольника. Для этого нужно использовать свойство property LineJoin: TPDFLineJoin;

Значение свойства

Отображение

Описание

0

С острым углом

1

С закруглением

2

С обрезанным углом

Пример построения прямоугольников с различными типами соединения сторон:
01set page = CreatePage(Null)
02
03page.DrawGrid
04
05page.LineWidth = 4
06
07page.LineJoin = 0
08
09page.Rectangle 10, 10, 20, 10, false
10
11page.LineJoin = 1
12
13page.Rectangle 40, 10, 20, 10, false
14
15page.LineJoin = 2
16
page.Rectangle 70, 10, 20, 10, false
Результат:

5.7.6.1.2.3.3. Вставка готовых изображений

Для вставки на создаваемую страницу готового изображения используется процедура procedure Image(const FileName: WideString; X: Double; Y: Double; Width: Double; Height: Double)

Параметры:

const FileName - имя файла изображения и путь к нему на жестком диске. Задается в кавычках.

X - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по горизонтали в миллиметрах

Y - координата левой верхней точки изображения по отношению к верхнему левому углу страницы по вертикали в миллиметрах

Width - ширина изображения в миллиметрах

Height - высота изображения в миллиметрах.
1set page = CreatePage(Null)
2page.drawgrid
page.Image "c:\mill.bmp", 10,10, 30, 30
Результат:

Вне зависимости от размера исходного изображения, при вставке изображения на создаваемую страницу оно будет растянуто по размерам, прописанным в процедуре.

5.7.6.1.2.3.4. Векторная графика

Язык PostScript, с помощью которого создаются векторные изображения для PDF-документа, поддерживает создание типичных примитивных объектов, таких как:

Прямые и ломанные линии

Многоугольники

Окружности и эллипсы

Кривые Безье

Текст

При создании векторного изображения на странице PDF-документа в приложениях Платформы, команды построения примитивных объектов PostScript передаются на исполнение при помощи процедуры Perform. Подробнее об операторах и командах PostScript для создания PDF-документов можно узнать на сайте Adobe

5.7.6.1.2.4. Шрифты

Шрифты, которые должны использоваться в создаваемом документе, должны быть предварительно объявлены. Для объявления используемых шрифтов используется функция
function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool; Italic: WordBool): IPDFFont; где:

const FontName - имя шрифта, аналогичное имени объявляемого шрифта в операционной системе. В Функции объявляется в кавычках.

Size - размер шрифта в пунктах

Bold - признак начертания шрифта "жирный". Значения - True или False

Italic - признак начертания шрифта "курсив". Значения - True или False

Примеры объявления шрифтов:
1set font = page.createFont("Arial", 20, False, False)
2set labelFont = page.createFont("Times New Roman", 16, False, True)
3set dataFont = page.createFont("Tahoma", 18, True, False)
Для вывода текстовой информации на страницу используются процедуры:

procedure WriteLine(const LineText: WideString; X: Double; Y: Double);
- используется для вывода текстовой строки

function WriteText(const AText: WideString; X: Double; Y: Double; Width: Double; Alignment: TPDFTextAlignment): Double;
- используется для вывода текстового блока.

Параметры для procedure WriteLine :

const LineText - текстовая строка для вывода. Прописывается в кавычках. Будет выведена на страницу одной строкой.

X - координата верхней левой точки текстовой строки по горизонтали в миллиметрах.

Y - координата верхней левой точки текстовой строки по вертикали в миллиметрах.

Примеры вывода текстов на страницу:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Times New Roman", 16, False, True)
05set dataFont = page.createFont("Tahoma", 18, True, False)
06Font.WriteLine "Фамилия", 5, 2
07Font.WriteLine "Имя", 5, 10
08Font.WriteLine "Отчество", 5, 18
09labelFont.WriteLine "Дата рождения", 5, 26
10dataFont.WriteLine "Национальность", 5, 34
Результат:

Параметры для function WriteText :

const AText - текст для вывода на страницу. Прописывается в кавычках. Будет выведена на страницу в виде текстового блока.

X - координата верхней левой точки текстового блока по горизонтали в миллиметрах.

Y - координата верхней левой точки текстового блока по вертикали в миллиметрах.

Width - ширина текстового блока в миллиметрах

Alignment - тип выравнивания текста в текстовом блоке.

Значение параметра

Тип выравнивания

0

По левому краю

1

По правому краю

2

По центру

3

Выравнивание по ширине

Примеры вывода текстовых блоков на страницу:
1set page = CreatePage(Null)
2page.DrawGrid
3set font = page.createFont("Arial", 14, False, False)
4set labelFont = page.createFont("Times New Roman", 12, False, True)
5set dataFont = page.createFont("Tahoma", 11, True, False)
6Q = font.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 5, 100, 0)
7Q = labelFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 35, 100, 1)
8Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 55, 100, 2)
9Q = dataFont.WriteText ("Тест работы свойства для выравнивания текста в текстовом блоке для документа PDF, создаваемого на Платформе Мельница Данных", 5, 80, 100, 3)
Результат:

Свойства шрифтов:

property Spacing: Double; - свойство, отвечающее за величину промежутка между буквами в слове. Задается в виде отклонения от промежутка между буквами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Spacing = 0
07labelFont.Spacing = 1
08dataFont.Spacing = 2
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (1 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 15
Результат:

property WordSpacing: Double; - свойство, отвечающее за величину промежутка между соседними словами. Задается в виде отклонения от промежутка между словами по умолчанию для выбранного шрифта по горизонтальной оси в миллиметрах. Значение свойства равное "0" соответствует значению по умолчанию.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.WordSpacing = 0
07labelFont.WordSpacing = 2
08dataFont.WordSpacing = 5
09font.WriteLine "Промежуток по умолчанию (0)", 5, 5
10labelFont.WriteLine "Промежуток с отклонением (2 мм)", 5, 10
11dataFont.WriteLine "Промежуток с отклонением (5 мм)", 5, 15
Результат:

property Scaling: Double; - свойство, отвечающее за горизонтальное масштабирование букв используемого шрифта. Устанавливается в процентах. Горизонтальный масштаб по умолчанию - 100%.

Пример:
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 14, False, False)
04set labelFont = page.createFont("Arial", 14, False, False)
05set dataFont = page.createFont("Arial", 14, False, False)
06font.Scaling = 50
07labelFont.Scaling = 100
08dataFont.Scaling = 200
09font.WriteLine "Сжатие (50)", 5, 5
10labelFont.WriteLine "По умолчанию (100)", 5, 10
11dataFont.WriteLine "Растягивание (150)", 5, 15
Результат:

property RenderingMode: TPDFFontRenderingMode; - свойство, отвечающее за заливку букв используемого шрифта.
Типы заливки:

Значение параметра:

Отображение:

Описание:

0

Сплошная заливка (по умолчанию). Буква заливается сплошным цветом,
объявленным на данный момент.

1

Только граница. Прорисовывается граница буквы. Тело остается незалитым.

2

Сначала заливка, потом граница. Граница прорисовывается всегда черным цветом.
Заливка осуществляется сплошным цветом, объявленным на данный момент.

3

Невидимый шрифт.

Пример:
01set page = CreatePage(Null)
02set font = page.createFont("Arial", 20, False, False)
03set labelFont = page.createFont("Arial", 20, False, False)
04set dataFont = page.createFont("Arial", 20, False, False)
05font.RenderingMode = 0
06labelFont.RenderingMode = 1
07dataFont.RenderingMode = 2
08page.setColor 255, 0, 0
09Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
10Q = labelFont.WriteText ("Олимпиада", 5, 15, 50, 0)
11Q = dataFont.WriteText ("Олимпиада", 5, 25, 50, 0)
Результат:

property Rise: Double; - свойство, отвечающее за перемещение текста по вертикали.
01set page = CreatePage(Null)
02page.DrawGrid
03set font = page.createFont("Arial", 20, False, False)
04set labelFont = page.createFont("Arial", 7, False, False)
05set dataFont = page.createFont("Arial", 7, False, False)
06labelFont.rise = -17
07dataFont.rise = -2
08Q = font.WriteText ("Олимпиада", 5, 5, 50, 0)
09Q = labelFont.WriteText ("Олимпиада", 44, 5, 50, 0)
10Q = dataFont.WriteText ("Олимпиада", 44, 5, 50, 0)
Результат:

Для определения размеров текстовой строки используется процедура MeasureLine(const LineText: WideString; out Width: OleVariant; out Height: OleVariant);

Здесь:

LineText - исходный текст для размещения на странице

Width - возвращаемый параметр ширины текстового блока на странице

Height - возвращаемый параметр высоты текстового блока на странице
1S = "шифр"
2font.MeasureLine S, W, H
3Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2)
Здесь для текста "Шифр" замеряется ширина и высота получившегося текстового блока. Затем полученные данные используются для корректного размещения текста на странице.

Для определения высоты текстового блока используется функция MeasureText(const AText: WideString; Width: Double): Double; safecall;

Функция распределит текст по задаваемому значению ширины текстового блока и вернет значение высоты текстового блока в милиметрах.

Здесь:

AText - исходный текст для размещения на странице. Прописывается в кавычках.

Width - задаваемая ширина текстового блока на странице в милиметрах.
1S = "Текст для размещения на странице..."
2Q = font.MeasureText(S, 139)
Здесь для текста "Текст для размещения на странице..." замеряется высота получившегося текстового блока. Затем полученные данные могут использоваться для корректного размещения текста на странице.

5.7.6.1.3. Порядок создания

Для создания шаблона PDF-документа необходимо в системной форме Платформы выбрать класс, к которому будет строиться документ. В подменю "Подпрограммы" вызвать контекстное меню и выбрать пункт "Создать шаблон отчета PDF". Заполнить необходимые поля и приступить к созданию скрипта в окне "Скрипт шаблона".

Объявляем все переменные.

Создаем страницы

Устанавливаем все свойства документа и страниц

Рисуем простые графические объекты

Объявляем все используемые шрифты

Расставляем постоянный текст на странице

Расставляем переменный текст на странице

Вставляем или создаем сложные графические объекты

Пример документа PDF:
001set LDataSet = createDataSet("TRoundAbiturSt")
002'Объявление переменных
003LDataSet.AddQueryItem 1, "ID", ID
004LDataSet.AddQueryItem 0, "RoundComp$N"
005LDataSet.AddQueryItem 0, "BachRound$N"
006LDataSet.AddQueryItem 0, "LastName"
007LDataSet.AddQueryItem 0, "FirstName"
008LDataSet.AddQueryItem 0, "MiddleName"
009LDataSet.AddQueryItem 0, "BirthDate"
010LDataSet.AddQueryItem 0, "RegNumber"
011LDataSet.AddQueryItem 0, "SecondStageCity$D"
012LDataSet.AddQueryItem 0, "PhoneList"
013
014'Присваивание переменным значений
015OlympName = LDataSet.Field("RoundComp$N")
016OlympClass = LDataSet.Field("BachRound$N")
017LastName = LDataSet.Field("LastName")
018FirstName = LDataSet.Field("FirstName")
019MiddleName = LDataSet.Field("MiddleName")
020if not IsNull(LDataSet.Field("BirthDate")) then
021  BirthDate = LDataSet.Field("BirthDate")
022else
023  BirthDate = "(не задана)"
024end if
025RegNo = LDataSet.Field("RegNumber")
026if not IsNull(LDataSet.Field("SecondStageCity$D")) then
027  OlympCity = LDataSet.Field("SecondStageCity$D")
028else
029  OlympCity = "(не выбран город участия)"
030end if
031if not IsNull(LDataSet.Field("PhoneList")) then
032  Phone = LDataSet.Field("PhoneList")
033else
034  Phone = ""
035end if
036
037'CanCompress = False - признак сжатия файла
038set page = CreatePage(Null) ' создаем страницу
039'Объявляем используемые шрифты
040set font = page.createFont("Arial", 20, False, False)
041set labelFont = page.createFont("Arial", 16, False, False)
042set dataFont = page.createFont("Arial", 18, True, False)
043set bigFont = page.createFont("Arial", 24, False, False)
044
045'page.DrawGrid  - рисуем сетку для удобства отладки
046
047page.LineWidth = 0.5 ' Установка толщины линии
048
049' Рисуем прямоугольники
050page.Rectangle 8, 12, 4, 4, True
051page.Rectangle 190, 12, 4, 4, True
052
053page.Rectangle 8, 273, 4, 4, True
054page.Rectangle 105, 273, 4, 4, True
055page.Rectangle 190, 273, 4, 4, True
056
057'Выводим постоянный и переменный текст
058Q = font.WriteText ("Межрегиональная олимпиада школьников", 12, 20, 178, 2)
059Q = bigFont.WriteText (OlympName, 12, 45, 178, 2)
060Q = bigFont.WriteText (OlympClass, 12, 56, 178, 2)
061
062Q = font.WriteText ("Титульный лист", 12, 72, 178, 2)
063
064labelFont.WriteLine "Фамилия", 25, 115 - 23
065labelFont.WriteLine "Имя", 25, 123 - 23
066labelFont.WriteLine "Отчество", 25, 131 - 23
067labelFont.WriteLine "Дата", 25, 139 - 23
068labelFont.WriteLine "рождения", 25, 145 - 23
069
070labelFont.WriteLine "Регистрационный номер", 25, 169 - 30
071labelFont.WriteLine "Город проведения", 25, 177 - 30
072labelFont.WriteLine "Аудитория", 25, 185 - 30
073
074
075labelFont.WriteLine "Дата", 25, 211
076labelFont.WriteLine "Подпись", 25, 219
077labelFont.WriteLine "Телефон", 25, 227
078
079
080dataFont.WriteLine LastName, 63, 114 - 23
081dataFont.WriteLine FirstName, 63, 122 - 23
082dataFont.WriteLine MiddleName, 63, 130 - 23
083dataFont.WriteLine BirthDate, 63, 141 - 23
084
085dataFont.WriteLine RegNo, 100, 168 - 30
086dataFont.WriteLine OlympCity, 100, 176 - 30
087
088' Рисуем линии
089page.line 100, 192 - 30, 150, 192 - 30
090page.line 58, 218, 108, 218
091page.line 58, 226, 108, 226
092Q = dataFont.WriteText(Phone, 58, 226, 65, 0)
093
094
095
096' Устанавливаем новый цвет
097page.setColor 192, 192, 192
098
099S = "шифр"
100font.MeasureLine S, W, H  ' измеряем текстовый блок
101Q = font.WriteText(S, 139, 244 + ((23 - H) / 2), 40, 2) ' располагаем текстовый
102блок на странице
103
104' Устанавливаем новый цвет
105page.setColor 255, 0, 0
106' Устанавливаем толщину линий в 1 пиксель
107page.LineWidth = 0
108' Рисуем линии по координатам
109X = 139
110Y = 267
111
112page.line X, Y - 3, X, Y + 3
113page.line X - 3, Y, X + 3, Y
114
115X = X + 40
116page.line X, Y - 3, X, Y + 3
117page.line X - 3, Y, X + 3, Y
118
119
120Y = Y - 23
121page.line X, Y - 3, X, Y + 3
122page.line X - 3, Y, X + 3, Y
123
124X = X - 40
125page.line X, Y - 3, X, Y + 3
page.line X - 3, Y, X + 3, Y
Результат:

5.7.6.2. Справочник по интерфейсам

5.7.6.2.1. Перечисление TPDFFontRenderingMode
1type
2  TPDFFontRenderingMode = (frmFillText, frmStrokeText, frmFillThenStrokeText,
3    frmInvisible);
Или
1type
2  TPDFFontRenderingMode = TOleEnum;
3const
4  frmFillText = $00000000;
5  frmStrokeText = $00000001;
6  frmFillThenStrokeText = $00000002;
7  frmInvisible = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

frmFillText

0

frmStrokeText

1

frmFillThenStrokeText

2

frmInvisible

3

5.7.6.2.2. Перечисление TPDFLineCap
1type
2  TPDFLineCap = (lcBuss, lcRound, lcProtecting);
Или
1type
2  TPDFLineCap = TOleEnum;
3const
4  lcBuss = $00000000;
5  lcRound = $00000001;
6  lcProtecting = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

lcBuss

0

lcRound

1

lcProtecting

2

5.7.6.2.3. Перечисление TPDFLineJoin
1type
2  TPDFLineJoin = (ljMiter, ljRound, ljBevel);
Или
1type
2  TPDFLineJoin = TOleEnum;
3const
4  ljMiter = $00000000;
5  ljRound = $00000001;
6  ljBevel = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

ljMiter

0

ljRound

1

ljBevel

2

5.7.6.2.4. Перечисление TPDFTextAlignment
1type
2  TPDFTextAlignment = (ptaLeft, ptaRight, ptaCenter, ptaJustified);
Или
1type
2  TPDFTextAlignment = TOleEnum;
3const
4  ptaLeft = $00000000;
5  ptaRight = $00000001;
6  ptaCenter = $00000002;
7  ptaJustified = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

ptaLeft

0

ptaRight

1

ptaCenter

2

ptaJustified

3

5.7.6.2.5. Интерфейс IPDFDocument
01type
02  IPDFDocument = interface(IDispatch)
03    ['{E57FFE9D-6B85-45E6-A5D0-9DD17950A666}']
04    procedure Save(Target: OleVariant); safecall;
05    function CreatePage(Parent: OleVariant): IPDFPage; safecall;
06    function Get_Title: WideString; safecall;
07    procedure Set_Title(Value: WideString); safecall;
08    function Get_CanEmbedFonts: WordBool; safecall;
09    procedure Set_CanEmbedFonts(Value: WordBool); safecall;
10    function Get_CanCompress: WordBool; safecall;
11    procedure Set_CanCompress(Value: WordBool); safecall;
12    function Get_Author: WideString; safecall;
13    procedure Set_Author(Value: WideString); safecall;
14    function Get_Subject: WideString; safecall;
15    procedure Set_Subject(Value: WideString); safecall;
16    function Get_Keywords: WideString; safecall;
17    procedure Set_Keywords(Value: WideString); safecall;
18    function Get_Creator: WideString; safecall;
19    procedure Set_Creator(Value: WideString); safecall;
20    function Get_Pages(Index: Integer): IPDFPage; safecall;
21    function Get_PageCount: Integer; safecall;
22    procedure Close; safecall;
23    procedure Serialize(const Stream: IUnknown); safecall;
24    function Get_MinCompressSize: Integer; safecall;
25    procedure Set_MinCompressSize(Value: Integer); safecall;
26    function Get_MaxCompressSize: Integer; safecall;
27    procedure Set_MaxCompressSize(Value: Integer); safecall;
28    function CreatePageFromImage(Image: OleVariant; PageWidth: Double;
29      PageHeight: Double; Margin: Double): WordBool; safecall;
30    procedure SaveToXML(Target: OleVariant); safecall;
31    property Title: WideString read Get_Title write Set_Title;
32    property CanEmbedFonts: WordBool read Get_CanEmbedFonts write Set_CanEmbedFonts;
33    property CanCompress: WordBool read Get_CanCompress write Set_CanCompress;
34    property Author: WideString read Get_Author write Set_Author;
35    property Subject: WideString read Get_Subject write Set_Subject;
36    property Keywords: WideString read Get_Keywords write Set_Keywords;
37    property Creator: WideString read Get_Creator write Set_Creator;
38    property Pages[Index: Integer]: IPDFPage read Get_Pages;
39    property PageCount: Integer read Get_PageCount;
40    property MinCompressSize: Integer read Get_MinCompressSize
41      write Set_MinCompressSize;
42    property MaxCompressSize: Integer read Get_MaxCompressSize
43      write Set_MaxCompressSize;
44  end;
5.7.6.2.5.1. Свойства

Свойства интерфейса IPDFDocument:

Имя

Тип

Доступ

Назначение

Author

WideString

Чтение/Запись

CanCompress

WordBool

Чтение/Запись

CanEmbedFonts

WordBool

Чтение/Запись

Creator

WideString

Чтение/Запись

Keywords

WideString

Чтение/Запись

MaxCompressSize

Integer

Чтение/Запись

MinCompressSize

Integer

Чтение/Запись

PageCount

Integer

Только для чтения

Pages[Index: Integer]

IPDFPage

Только для чтения

Subject

WideString

Чтение/Запись

Title

WideString

Чтение/Запись

5.7.6.2.5.2. Метод Close

Метод интерфейса IPDFDocument.
procedure IPDFDocument.Close;
Метод не имеет параметров.

5.7.6.2.5.3. Метод CreatePage

Метод интерфейса IPDFDocument.
function IPDFDocument.CreatePage(Parent: OleVariant): IPDFPage;
Параметры:

Имя

Тип

Обязательно

Значение

Parent

OleVariant

Да

Замечания:

Возвращает значение типа IPDFPage.

5.7.6.2.5.4. Метод CreatePageFromImage

Метод интерфейса IPDFDocument.
1function IPDFDocument.CreatePageFromImage(Image: OleVariant; PageWidth: Double;
2  PageHeight: Double; Margin: Double): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

Image

OleVariant

Да

PageWidth

Double

Да

PageHeight

Double

Да

Margin

Double

Да

Замечания:

Возвращает значение типа WordBool.

5.7.6.2.5.5. Метод Save

Метод интерфейса IPDFDocument.
procedure IPDFDocument.Save(Target: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Target

OleVariant

Да

5.7.6.2.5.6. Метод SaveToXML

Метод интерфейса IPDFDocument.
procedure IPDFDocument.SaveToXML(Target: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Target

OleVariant

Да

5.7.6.2.5.7. Метод Serialize

Метод интерфейса IPDFDocument.
procedure IPDFDocument.Serialize(const Stream: IUnknown);
Параметры:

Имя

Тип

Обязательно

Значение

Stream

IUnknown

Да

5.7.6.2.6. Интерфейс IPDFFont
01type
02  IPDFFont = interface(IDispatch)
03    ['{43FE399A-A724-4076-BAFA-098639628385}']
04    function Get_Spacing: Double; safecall;
05    procedure Set_Spacing(Value: Double); safecall;
06    function Get_WordSpacing: Double; safecall;
07    procedure Set_WordSpacing(Value: Double); safecall;
08    function Get_Scaling: Double; safecall;
09    procedure Set_Scaling(Value: Double); safecall;
10    function Get_RenderingMode: TPDFFontRenderingMode; safecall;
11    procedure Set_RenderingMode(Value: TPDFFontRenderingMode); safecall;
12    function Get_Rise: Double; safecall;
13    procedure Set_Rise(Value: Double); safecall;
14    procedure WriteLine(const LineText: WideString; X: Double; Y: Double); safecall;
15    procedure MeasureLine(const LineText: WideString; out Width: OleVariant;
16      out Height: OleVariant); safecall;
17    function WriteText(const AText: WideString; X: Double; Y: Double;
18      Width: Double; Alignment: TPDFTextAlignment): Double; safecall;
19    function MeasureText(const AText: WideString; Width: Double): Double; safecall;
20    function Get_Angle: Double; safecall;
21    procedure Set_Angle(Value: Double); safecall;
22    function Get_LineSpacing: Double; safecall;
23    procedure Set_LineSpacing(Value: Double); safecall;
24    property Spacing: Double read Get_Spacing write Set_Spacing;
25    property WordSpacing: Double read Get_WordSpacing write Set_WordSpacing;
26    property Scaling: Double read Get_Scaling write Set_Scaling;
27    property RenderingMode: TPDFFontRenderingMode read Get_RenderingMode
28      write Set_RenderingMode;
29    property Rise: Double read Get_Rise write Set_Rise;
30    property Angle: Double read Get_Angle write Set_Angle;
31    property LineSpacing: Double read Get_LineSpacing write Set_LineSpacing;
32  end;
5.7.6.2.6.1. Свойства

Свойства интерфейса IPDFFont:

Имя

Тип

Доступ

Назначение

Angle

Double

Чтение/Запись

LineSpacing

Double

Чтение/Запись

RenderingMode

TPDFFontRenderingMode

Чтение/Запись

Rise

Double

Чтение/Запись

Scaling

Double

Чтение/Запись

Spacing

Double

Чтение/Запись

WordSpacing

Double

Чтение/Запись

5.7.6.2.6.2. Метод MeasureLine

Метод интерфейса IPDFFont.
1procedure IPDFFont.MeasureLine(const LineText: WideString;
2  out Width: OleVariant; out Height: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

LineText

WideString

Да

Width

OleVariant

Да

Height

OleVariant

Да

5.7.6.2.6.3. Метод MeasureText

Метод интерфейса IPDFFont.
function IPDFFont.MeasureText(const AText: WideString; Width: Double): Double;
Параметры:

Имя

Тип

Обязательно

Значение

AText

WideString

Да

Width

Double

Да

Замечания:

Возвращает значение типа Double.

5.7.6.2.6.4. Метод WriteLine

Метод интерфейса IPDFFont.
procedure IPDFFont.WriteLine(const LineText: WideString; X: Double; Y: Double);
Параметры:

Имя

Тип

Обязательно

Значение

LineText

WideString

Да

X

Double

Да

Y

Double

Да

5.7.6.2.6.5. Метод WriteText

Метод интерфейса IPDFFont.
1function IPDFFont.WriteText(const AText: WideString; X: Double; Y: Double;
2  Width: Double; Alignment: TPDFTextAlignment): Double;
Параметры:

Имя

Тип

Обязательно

Значение

AText

WideString

Да

X

Double

Да

Y

Double

Да

Width

Double

Да

Alignment

TPDFTextAlignment

Да

Замечания:

Возвращает значение типа Double.

5.7.6.2.7. Интерфейс IPDFPage
01type
02  IPDFPage = interface(IDispatch)
03    ['{749FB131-80FE-46E9-8330-22C1DC346FE7}']
04    function Get_Parent: IPDFPage; safecall;
05    function Get_Title: WideString; safecall;
06    procedure Set_Title(Value: WideString); safecall;
07    function Get_Width: Double; safecall;
08    procedure Set_Width(Value: Double); safecall;
09    function Get_Height: Double; safecall;
10    procedure Set_Height(Value: Double); safecall;
11    function CreateFont(const FontName: WideString; Size: Double; Bold: WordBool;
12      Italic: WordBool): IPDFFont; safecall;
13    procedure Perform(const Command: WideString); safecall;
14    function Get_LineWidth: Double; safecall;
15    procedure Set_LineWidth(Value: Double); safecall;
16    procedure Line(X1: Double; Y1: Double; X2: Double; Y2: Double); safecall;
17    procedure Rectangle(X1: Double; Y1: Double; Width: Double; Height: Double;
18      Fill: WordBool); safecall;
19    function Get_LineCap: TPDFLineCap; safecall;
20    procedure Set_LineCap(Value: TPDFLineCap); safecall;
21    function Get_LineJoin: TPDFLineJoin; safecall;
22    procedure Set_LineJoin(Value: TPDFLineJoin); safecall;
23    procedure SetDash(DashArray: OleVariant; Phase: Integer); safecall;
24    procedure SetColor(R: Integer; G: Integer; B: Integer); safecall;
25    procedure PerformColor(const Command: WideString); safecall;
26    procedure Poly(Points: OleVariant; Fill: WordBool); safecall;
27    procedure Image(Image: OleVariant; X: Double; Y: Double; Width: Double;
28      Height: Double; Transparent: WordBool); safecall;
29    procedure DrawGrid; safecall;
30    procedure Arc(X: Double; Y: Double; Radius: Double; StartAngle: Double;
31      EndAngle: Double; FillSegment: WordBool; FillSector: WordBool); safecall;
32    procedure Curve(Points: OleVariant; Fill: WordBool); safecall;
33    procedure HyperLink(const URI: WideString; X: Double; Y: Double; Width: Double;
34      Height: Double); safecall;
35    procedure Pattern(X1: Double; Y1: Double; Width: Double; Height: Double;
36      PatternPointSize: Double; Percentage: Integer); safecall;
37    procedure Bezier(Points: OleVariant; Fill: WordBool); safecall;
38    procedure XObject(Data: OleVariant); safecall;
39    procedure SetColorCMYK(C: Double; M: Double; Y: Double; K: Double); safecall;
40    procedure LocalLink(const Page: IDispatch; DestinationX: Double;
41      DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
42      X: Double; Y: Double; Width: Double; Height: Double); safecall;
43    property Parent: IPDFPage read Get_Parent;
44    property Title: WideString read Get_Title write Set_Title;
45    property Width: Double read Get_Width write Set_Width;
46    property Height: Double read Get_Height write Set_Height;
47    property LineWidth: Double read Get_LineWidth write Set_LineWidth;
48    property LineCap: TPDFLineCap read Get_LineCap write Set_LineCap;
49    property LineJoin: TPDFLineJoin read Get_LineJoin write Set_LineJoin;
50  end;
5.7.6.2.7.1. Свойства

Свойства интерфейса IPDFPage:

Имя

Тип

Доступ

Назначение

Height

Double

Чтение/Запись

LineCap

TPDFLineCap

Чтение/Запись

LineJoin

TPDFLineJoin

Чтение/Запись

LineWidth

Double

Чтение/Запись

Parent

IPDFPage

Только для чтения

Title

WideString

Чтение/Запись

Width

Double

Чтение/Запись

5.7.6.2.7.2. Метод Arc

Метод интерфейса IPDFPage.
1procedure IPDFPage.Arc(X: Double; Y: Double; Radius: Double;
2  StartAngle: Double; EndAngle: Double; FillSegment: WordBool;
3  FillSector: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

X

Double

Да

Y

Double

Да

Radius

Double

Да

StartAngle

Double

Да

EndAngle

Double

Да

FillSegment

WordBool

Да

FillSector

WordBool

Да

5.7.6.2.7.3. Метод Bezier

Метод интерфейса IPDFPage.
procedure IPDFPage.Bezier(Points: OleVariant; Fill: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Points

OleVariant

Да

Fill

WordBool

Да

5.7.6.2.7.4. Метод CreateFont

Метод интерфейса IPDFPage.
1function IPDFPage.CreateFont(const FontName: WideString; Size: Double;
2  Bold: WordBool; Italic: WordBool): IPDFFont;
Параметры:

Имя

Тип

Обязательно

Значение

FontName

WideString

Да

Size

Double

Да

Bold

WordBool

Да

Italic

WordBool

Да

Замечания:

Возвращает значение типа IPDFFont.

5.7.6.2.7.5. Метод Curve

Метод интерфейса IPDFPage.
procedure IPDFPage.Curve(Points: OleVariant; Fill: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Points

OleVariant

Да

Fill

WordBool

Да

5.7.6.2.7.6. Метод DrawGrid

Метод интерфейса IPDFPage.
procedure IPDFPage.DrawGrid;
Метод не имеет параметров.

5.7.6.2.7.7. Метод HyperLink

Метод интерфейса IPDFPage.
1procedure IPDFPage.HyperLink(const URI: WideString; X: Double; Y: Double;
2  Width: Double; Height: Double);
Параметры:

Имя

Тип

Обязательно

Значение

URI

WideString

Да

X

Double

Да

Y

Double

Да

Width

Double

Да

Height

Double

Да

5.7.6.2.7.8. Метод Image

Метод интерфейса IPDFPage.
1procedure IPDFPage.Image(Image: OleVariant; X: Double; Y: Double;
2  Width: Double; Height: Double; Transparent: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Image

OleVariant

Да

X

Double

Да

Y

Double

Да

Width

Double

Да

Height

Double

Да

Transparent

WordBool

Нет

5.7.6.2.7.9. Метод Line

Метод интерфейса IPDFPage.
procedure IPDFPage.Line(X1: Double; Y1: Double; X2: Double; Y2: Double);
Параметры:

Имя

Тип

Обязательно

Значение

X1

Double

Да

Y1

Double

Да

X2

Double

Да

Y2

Double

Да

5.7.6.2.7.10. Метод LocalLink

Метод интерфейса IPDFPage.
1procedure IPDFPage.LocalLink(const Page: IDispatch; DestinationX: Double;
2  DestinationY: Double; DestinationWidth: Double; DestinationHeight: Double;
3  X: Double; Y: Double; Width: Double; Height: Double);
Параметры:

Имя

Тип

Обязательно

Значение

Page

IDispatch

Да

DestinationX

Double

Да

DestinationY

Double

Да

DestinationWidth

Double

Да

DestinationHeight

Double

Да

X

Double

Да

Y

Double

Да

Width

Double

Да

Height

Double

Да

5.7.6.2.7.11. Метод Pattern

Метод интерфейса IPDFPage.
1procedure IPDFPage.Pattern(X1: Double; Y1: Double; Width: Double;
2  Height: Double; PatternPointSize: Double; Percentage: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

X1

Double

Да

Y1

Double

Да

Width

Double

Да

Height

Double

Да

PatternPointSize

Double

Да

Percentage

Integer

Да

5.7.6.2.7.12. Метод Perform

Метод интерфейса IPDFPage.
procedure IPDFPage.Perform(const Command: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Command

WideString

Да

5.7.6.2.7.13. Метод PerformColor

Метод интерфейса IPDFPage.
procedure IPDFPage.PerformColor(const Command: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Command

WideString

Да

5.7.6.2.7.14. Метод Poly

Метод интерфейса IPDFPage.
procedure IPDFPage.Poly(Points: OleVariant; Fill: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Points

OleVariant

Да

Fill

WordBool

Да

5.7.6.2.7.15. Метод Rectangle

Метод интерфейса IPDFPage.
1procedure IPDFPage.Rectangle(X1: Double; Y1: Double; Width: Double;
2  Height: Double; Fill: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

X1

Double

Да

Y1

Double

Да

Width

Double

Да

Height

Double

Да

Fill

WordBool

Да

5.7.6.2.7.16. Метод SetColor

Метод интерфейса IPDFPage.
procedure IPDFPage.SetColor(R: Integer; G: Integer; B: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

R

Integer

Да

G

Integer

Да

B

Integer

Да

5.7.6.2.7.17. Метод SetColorCMYK

Метод интерфейса IPDFPage.
procedure IPDFPage.SetColorCMYK(C: Double; M: Double; Y: Double; K: Double);
Параметры:

Имя

Тип

Обязательно

Значение

C

Double

Да

M

Double

Да

Y

Double

Да

K

Double

Да

5.7.6.2.7.18. Метод SetDash

Метод интерфейса IPDFPage.
procedure IPDFPage.SetDash(DashArray: OleVariant; Phase: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

DashArray

OleVariant

Да

Phase

Integer

Да

5.7.6.2.7.19. Метод XObject

Метод интерфейса IPDFPage.
procedure IPDFPage.XObject(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

5.7.7. Поставка решений

5.8. Интеграция

Интеграция - комплекс работ по настройке механизмов взаимодействия между различными учетными системами, которые функционируют независимо друг от друга в одной организационной структуре ("лоскутная" автоматизация).

Концептуально реализация интеграции может быть осуществлена двумя способами (рассмотрены более подробно далее):

Интеграция на базе интеграционной платформы (некоего ядра, которое осуществляет взаимодействие между учетными системами)

Интеграция без внедрения интеграционной платформы, с использованием связей между учетными системами только там где это необходимо.

Практически, реализация интеграции может быть осуществлена слежующими способами:

5.8.1. Интеграция данных

В свою очередь интеграцию данных можно разделить на два типа:

5.8.1.1. Репликативная интеграция

Репликативная интеграция - передающая сторона формирует реплику, передает ее принимающей стороне, которая в свою очередь загружает в себя реплику. В этом случае стандартами формата реплики являются двоичный формат и XML-схема. Платформа Мельница Данных имеет готовые механизмы для реализации обоих форматов.

Варианты реализации репликационной интеграции:

1. Данные должны быть переданы из сторонней учетной системы и загружены в Платформу Мельница данных:

В Платформе уже реализованы механизмы загрузки реплик в двоичном (бинарном) формате, а также в формате XML-схемы. В случае, если разработчики или сопровождающие сотрудники сторонней учетной системы имеют возможность выгрузки реплики в данных форматах, взаимодействие производится стандартными средствами Платформы. В противном случае создается конвертер для перевода данных реплики в один из стандартных форматов для дальнейшей загрузки реплики в Мельницу Данных.

2. Данные должны быть переданы из Платформы Мельница Данных и загружены в стороннюю учетную систему:

При необходимости выгрузки данных из Платформы Мельница Данных используются стандартные механизмы выгрузки реплики в двоичном (бинарном) формате или в формате XML-схемы. В случае, если эти варианты не являются приемлемыми для принимающей стороны (сторонней учетной системы), можно выполнить выгрузку данных через скриптлет, Microsoft Excel-файл, отчет или любыми механизмами просто выгрузить требуемый файл для дальнейшей обработки (загрузки) принимающей стороной. В этом случае необходимо четкое согласование протоколов и форматов обмена данными.

3. Данные должны быть переданы из одной сторонней учетной системы в другую. При этом Платформа Мельница Данных выступает в качестве интеграционной платформы:

Если Платформа выступает в качестве интеграционного ядра, в ней необходимо объявить структуры для хранения тех элементов данных, которые в Платформе по умолчанию не хранятся, но загружаются в нее из сторонних учетных систем и в дальнейшем подлежат какому-либо анализу. При этом нет необходимости обеспечивать функционирование бизнес-процессов над этими данными в рамках Платформы, данные просто хранятся.

Подобная интеграция осуществляется простыми готовыми средствами платформы в самые сжатые сроки.

5.8.1.2. On-Line доступ

Второй путь интеграции данных - Интеграция с использованием доступа к данным в режиме On-Line.

1. В том случае когда Платформа является серверной стороной, то есть стороной-поставщиком данных для других систем, возможны следующие варианты предоставления данных:

- СУБД, то есть база данных, которая хранит все данные Платформы. На данный момент поддерживаются Oracle, Firebird, MS SQL. Возможна реализация поддержки и других систем управления базами данных. Для указанных баз данных доступны стандартные протоколы доступа, с помощью которых осуществляются запросы к данным Платформы непосредственно. Запросы формируются при помощи стандартизированного языка запросов Structured Query Language (SQL).

- RESTful-сервис используется для реализации более сложной механики предоставления доступа к данным и входит в состав поставки сервера приложений Платформы. С его помощью, в частности, осуществляется удаленный доступ и доступ к данным через SOAP (Simple Object Access Protocol — простой протокол доступа к объектам) с автоматическим формированием по данным Платформы WSDL-документа, описывающего сервисы. Таким образом реализуется продвинутый функционал по отбору объекта по критериям, а также в части доступа ко всем данным Платформы по протоколу SOAP/

В случае если требуются какие-либо специфические протоколы для обмена данными, они реализовываются на уровне обработчика сервера-приложения. То есть осуществляется "надстройка" сервера приложений Платформы для работы с данными в том виде, в котором это необходимо и по тому протоколу, который требуется в каждом конкретном случае. Таким образом, Сервер приложений Платформы востребован в большинстве случаев организации взаимодействия между системами.

Практический пример реализации:

Компания "Мельница технологий" в одном из московских ВУЗов осуществяла интеграцию с тестирующей системой по проведению олимпиад. С использованием протокола SOAP в тестирующую систему из Платформы предоставлялась информация о реквизитах олимпиад, которые были выбраны каждым школьником-участником. Был реализован обработчик-"переходник", через который передавалсь информация.

Для системы LMS (Learning Management System) компании Asteros данные также предоставляются по протоколу SOAP.

2. В случае когда Платформе необходим доступ к данным сторонних систем, используется готовый RESTful-"обработчик". Частными случаями данной ситуции являются взаимодействия Платформы с различными собственными web-приложениями, а также с "Обозревателем данных", работающим через удаленный доступ.

Для получения данных в режиме On-Line от сторонних систем используются те же стандартные протоколы. При необходимости создаются "обработчики", которые отображают для конечного пользователя в визуальных формах Платформы данные, полученные из сторонних систем.

3. При использовании Платформы в качестве платформы интеграции различных сторонних систем, данные предварительно загруженные по описанным выше протоколам могут передаваться средствами Платформы. Однако, может быть реализован и механизм прозрачной передачи данных между сторонними системами.

5.8.2. Интеграция функций

Данный тип развития интеграции в свою очередь можно разделить на 2 пути:

5.8.2.1. Взаимные вызовы

В данном случае подразумевается, что какая-либо учетная система открывает возможность вызова своих встроенных функций из сторонних систем.

Доступ к функциям возможен с помощью выполнения хранимых процедур (каждое бизнес-действие, которое производит пользователь, обязательно оформляется в виде хранимой процедуры на уровне СУБД Платформы). Процедуру можно вызывать, получив доступ к СУБД. Аналогично тому, как создаются select-запросы, запросы к данным, можно делать запросы, вызывающие бизнес-функции. Все методы, отчеты, и все, что доступно пользователю, может быть вызвано и через RESTful-сервис. При этом методы будут выполняться, отчеты будут формироваться в виде Excel, Word, PDF, HTML, в соответствии с запросом вызывающей стороны. Данный функционал обеспечивается готовым "обработчиком", входящим в состав поставки Платформы.

С помощью протокола SOAP можно вызывать любой метод любого объекта, получать результаты его выполнения без ограничений.

В случае когда необходимо в Платформе использовать чужие функции, набор действий по вызову такой функции оформляется в виде скриптлета.

Пример реализации:

В ВУЗе при формировании приказа о зачислении студента в Платформе, также автоматически создается объект "Приказ" в системе документооборота ВУЗа. В дальнейшем, передвижение приказа по маршруту согласования в решении на Платформе аналогично отображается в системе документооборота.

Если для сторонней системы существуют какие-либо стандартные протоколы, по которым можно вызывать функцию, то средствами Платформы не составляет труда вызов данной функции.

5.8.2.2. Встраивание

Данный путь интеграции функций представляет собой ситуацию, когда сторонняя система непосредственно "встраивается" в решения на Платформе и код сторонней системы исполняется с использованием данных Платформы.

Существуют разные способы реализации данного пути:

- В open-source системах, как правило, слой доступа к данным вынесен в некий отдельный модуль. Характерный пример - это LMS eFront. Это Open-Source разработка, содержащая в себе большой объем php-кода, с развитым web-интерфейсом, и, в том числе, содержащая модуль доступа к данным. В процессе работы создается база MySQL база достаточно примитивной структуры. В этом случае можно изменить модуль доступа, так, чтобы вместо запросов к MySQL-базе механика делала бы запросы к базе данных Платформы. Тогда исполнение php-кода, его интерпретация происходит в рамках сервера приложений Платформы.

Пример реализации:

Так как в базе данных Платформы уже хранятся данные о студентах, преподавателях, курсах и т.д., то при взаимодействии с системой обучения LMS, естественным, удобным и надежным решением является хранение все этих данных в одной базе данных

- В тех случаях, когда решения Платформы сами являются частью какой-либо более общей системы, и должны предоставлять свои функции, то это решается на уровне СУБД. То есть, сгенерированный Платформой прикладной код (код на соответствующем диалекте SQL) может быть интегрирован в код более масштабного хранилища, функционировать там, исполняться там, если в этом есть необходимость.

Прикладные системы на базе СУБД Teradata позволяют использовать PL/SQL-код для каких-либо наборов данных, притом, что сама база гораздо имеет продвинутые возможности автоматического контроля версий, хроникальности, аналитики.

5.9. Положения и определения

5.9.1. Работа с типами данных

5.9.1.1. Домены

5.9.2. Язык PascalScript

На языке PascalScript на платформе "Мельница данных" описываются тела методов и выражения. Выражения используются в условиях отбора объектов определенного класса при их отображении в представлениях, а также как встраиваемые выражения, которые могут служить членами класса для чтения свойств.

Здесь и далее зарезервированные слова выделены жирным шрифтом.

5.9.2.1. Структура программного блока тела метода
1  [Описание переменных]
2  begin
3    //Операторы
  end;
Комментарии расположены между символами { и } либо от символов // до конца строки.

5.9.2.2. Описание переменных
1var
2    Имя переменной[, Имя переменной…]: Тип;
3    Имя переменной[, Имя переменной…]: Тип;
4    ...
Имя переменной должно быть идентификатором (последовательность символов a-z, A-Z, 0-9, _). "Тип" может быть одним из следующих:

integer - определяет переменные целочисленного типа;

string[целое_число] - определяет переменные строкового типа с заданной максимальной длиной; максимальная длина задается в квадратных скобках и обязательна для задания;

float - определяет переменные вещественного типа;

date - определяет переменные типа "дата";

time - определяет переменные типа "время";

datetime - определяет переменные типа "дата со временем";

boolean - определяет переменные логического типа;

blob - определяет переменные типа больших двоичных объектов;

Имя класса - определяет переменные-ссылки на экземпляры соответствующих классов;
1  var
2   I: integer;
3   LSomeObject: TObject;
4   LStart, LStop: datetime;
   LNewName: string[64];
5.9.2.3. Операторы PascalScript

Операторы разделяются точкой с запятой (;). Операторы могут быть одним из следующих:

5.9.2.3.1. Составной оператор
1begin
2  //Другие операторы
end
Операторы, размещенные внутри составного оператора, разделяются точкой с запятой. Никаких ограничений на состав операторов и количество уровней вложенности не накладывается.
1begin
2  Result := LCurrentValue;
3  Exit;
4end;
5.9.2.3.2. Оператор присваивания
Выражение1 := Выражение2
Присваивает значение выражения Выражение2 выражению Выражение1. Типы Выражения1 и Выражения2 должны быть совместимы (совпадать по классу домена либо оба быть числовыми). Для этого на Выражение1 (стоящее слева от знака равенства, lvalue) накладывается ряд ограничений. Это выражение должно быть:

Полем или свойством экземпляра класса

Локальной переменной

Параметром

Зарезервированной переменной Result
LObject.Name := 'Новое имя';
Result := 25;
LStartTime := StrToDateTime('01.01.2006 00:00:30');
01var
02  LObject: TObject;
03  LClass: TClass;
04  I: Integer;
05  F: Float;
06begin
07  I := F;  //неверно
08  F := I;  //верно
09  LObject := LClass; //верно
10  LClass := LObject; //неверно. Должно быть LClass := (LObject as TClass);
11end;
5.9.2.3.3. Оператор вызова
ИмяПроцедуры [(Параметр1, Параметр2 ...)]
"ИмяПроцедуры" должно быть:

Именем метода класса и вызываться с указанием класса либо экземпляра;

Именем метода экземпляра и вызываться с указанием экземпляра;

Именем метода своего класса либо предка и вызываться без указания спецификаторов.

Порядок и количество параметров в операторе вызова должны строго совпадать с описанием метода.
1  //метод класса, указан класс
2  LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3
4  //метод экземпляра, указан экземпляр. Метод не имеет параметров.
5  LList.Destroy;
6
7  //свой либо унаследованный метод
8  BuildDefaultActions(Name, True);
5.9.2.3.4. Оператор ветвления
1if Выражение then
2  //Оператор1
3[else
4  //Оператор2]
Выражение должно быть логического типа. В случае если значение Выражения истинно, выполняется Оператор1. Часть else является необязательной и относится к последнему оператору if, не имеющему таковой. В случае ее наличия Оператор2 выполняется, если значение Выражения ложно.
1if LIndex > 25 then
2  raise 'Индекс слишком большой.';
1if LMonth = 'январь' then
2  January
3else if LMonth = 'февраль' then
4  February
5else
6  OtherMonth;  //обратите внимание на точки с запятой.
5.9.2.3.5. Оператор выбора
1case Выражение of
2  Значение1: //Оператор1
3  Значение2: //Оператор2
4  ...
5[else
6  //Оператор ]
end
Заменяет каскад операторов if. Значение Выражения должно быть числового типа. Часть else выполняется в случае, если Выражение не равно ни одному из перечисленных вариантов. Эта часть не является обязательной.
1сase LIndex of
2  0: ZeroIndex;
3  1,2,3: SmallIndex;
4  4,5,6,7,8,9,10: BigIndex;
5else
6  raise 'Слишком большой или отрицательный индекс.';
7end;
5.9.2.3.6. Цикл с предусловием
1while Выражение do
2  //Оператор
Оператор выполняется до тех пор, пока значение Выражения истинно. Выражение должно быть логического типа. Если при входе в цикл Выражение не истинно, то тело цикла не будет выполнено ни одного раза.
01while LList.Count > 0 do
02  LList.GetItem(0).Destroy;
03
04while True do
05begin
06  LValue := LValue.NextValue;
07  if LValue.Value > 10 then
08  begin
09    Result := LValue.Value;
10    exit;
11  end;
12end;
5.9.2.3.7. Цикл с постусловием
1repeat
2  //Операторы
3until Выражение
Операторы выполняются до тех пор, пока значение Выражения ложно. Выражение должно быть логического типа. Обратите внимание, что внутри себя оператор может содержать несколько операторов, разделенных точкой с запятой. Тело цикла обязательно будет выполнено хотя бы один раз.
1repeat
2  Result := Result + 1;
3  LObject := LObject.Parent;
4until LObject = nil;
5.9.2.3.8. Цикл с параметром
1for Параметр := Выражение1 (to|downto) Выражение2 do
2  //Оператор
Параметр цикла обязан быть простой локальной переменной. Функционально цикл с параметром эквивалентен циклам:

Для формы to
1Параметр := Выражение1;
2while Параметр <= Выражение2 dobegin
3  Оператор;
4  Параметр :=  Параметр + 1;
end;
Для формы downto
1Параметр := Выражение1;
2while Параметр >= Выражение2 dobegin
3  Оператор;
4  Параметр :=  Параметр - 1;
end;
Если Выражение1 равно Выражению2, тело цикла будет выполнено один раз.
1for I := LList.Length - 1 downto 0 do
2// если LList.Length = 0, тело цикла ни разу не будет выполнено.
3begin
4  LClass := LList.GetItem(I);
5  LMethod := any(TMethod with (Name = LName) and (Master = LClass));
6  LParamList.Add(any(TMethod with (Name = LName) and (Master = LClass)));
7end;
5.9.2.3.9. Цикл по экземплярам
1for each Параметр of ИмяКласса [with Выражение]
2  [by [-] Выражение [, [-] Выражение]] do
3    //Оператор
Цикл осуществляется по выборке среди экземпляров класса ИмяКласса, для которых истинно Выражение. Если Выражение не задано, то по всем экземплярам. Ссылка на текущий в рамках цикла экземпляр присваивается в локальную переменную Параметр. Выражение должно определяться относительно переменной Параметр. Выраженния, следующие за ключевым словом by, определяют порядок обхода экземпляров. Знак "-" перед выражением (любого типа) определяет обратный порядок обхода.
1for each LOption of TOption with LOption.Domain.Required do
2    // для каждой настройки, домен которой обязателен
3  LOption.SetDefaultValue;
5.9.2.3.10. Оператор прекращения цикла
break
Происходит немедленный выход из цикла. Выполняется финализация операторов защиты завершения, которыми защищено тело цикла. Допустим только в теле цикла с предусловием, цикла с постусловием, цикла с параметром или цикла по экземплярам.

5.9.2.3.11. Оператор выхода из подпрограммы
exit
Происходит немедленный выход из программного блока. Выполняется финализация операторов защиты завершения.

5.9.2.3.12. Оператор защиты завершения
1try
2  //Операторы1
3finally
4  //Операторы2
end
Выполняются операторы Операторы1, разделенные точкой с запятой. В случае возникновения исключительной ситуации управление сразу передается на Операторы2, и после их выполнения исключение остается активным. Если исключения не произошло, выполняются Операторы2. Если среди Операторов1 встречается оператор exit, то Операторы2 все равно выполняются.
1//создание временного объекта-списка
2LList := TObjectList.Create(Name, Description, TObjectList, nil, nil, Folder);
3try
4  LList.Add(LValue);
5  Exit;
6finally
7  //гарантированное уничтожение созданного объекта независимо от исключений.
8  LList.Destroy;
9end;
5.9.2.3.13. Оператор обработки исключительных ситуаций
1try
2  //Операторы1
3except
4  //Операторы2
end
Выполняются операторы Операторы1. В случае возникновения исключительной ситуации управление передается на Операторы2. Если исключительных ситуаций не возникло, Операторы2 не выполняются никогда. При передаче управления на Операторы2 исключительная ситуация деактивирована. Для ее повторного возбуждения можно воспользоваться оператором возбуждения исключения без указания текстовой строки сообщения.
1try
2  LObject.NeverTouch := True;
3  LObject.ExecuteCoolMethod; //если метод выполнен неудачно
4except
5  LObject.NeverTouch := True;  //установить флаг и ничего не сообщать пользователю.
6end;
1try
2   LObject.ExecuteCoolMethod; //если метод выполнен неудачно
3except
4   LObject.Destroy; //удалить неудачный объект
5   raise;           // продолжить обработку исключения.
6end;
5.9.2.3.14. Оператор возбуждения исключения
raise [Выражение]
Возбуждает исключение, которое, если не было обработано блоком except оператора обработки, дойдет до пользователя. Пользователь увидит сообщение, определяемое Выражением. Выражение должно иметь строковый тип и является обязательным для всех случаев, кроме части except оператора обработки исключений.

5.9.2.3.15. Оператор унаследованного вызова
inherited
Работает только в унаследованном переопределенном методе. Вызывается метод предка с параметрами, заданными в параметрах к моменту вызова. Если программный блок представляет собой тело функции, то в псевдопеременной Result будет результат выполнения метода предка.
1// в теле конструктора
2Name := 'Object name';
3Description := 'Object description';
4inherited; //вызов предка с параметрами Name и Description,
5           //заданными двумя предыдущими операторами. Ссылка на
6           //созданный объект лежит в
7           //псевдопеременной Result
8Result.Name := 'New name';
5.9.2.4. Выражения и операции

5.9.2.4.1. Состав выражения

Любое выражение имеет тип. Выражения состоят из следующих элементов:

Целая числовая константа (0 3 234);

Вещественная числовая константа. Дробная часть отделяется от целой точкой (".") (3.14 2.71);

Строковая константа. Заключается в апострофы. ('Some string' '10', '01.01.2006' 'now');

Логическая константа (True False);

Безтиповая (любого типа) константа nil;

Зарезервированное слово Self. Обозначает разный объект в зависимости от контекста:

В методах класса кроме конструктора - использование запрещено.

В методах экземпляра - всегда экземпляр, для которого вызван метод.

В конструкторе - до вызова унаследованного метода значение не определено. После вызова - ссылка на сконструированный объект.

В выражениях условий отбора - объект, для которого принимается решение о его вхождении в отбор.

Квалификатор.

Агрегат.

5.9.2.4.2. Квалификатор

Квалификатор обозначает объект, переменную, параметр, свойство, поле, вызов функции. Квалификатор состоит из идентификаторов, разделенных точкой.

Result

AName

Caption

LObject.Name

LObject.Parent.Name

LObject.ChildCount

LObject.HasAsParent(LOtherObject)

При интерпретации квалификатора используется следующий порядок разбора идентификатора:

Контекстная переменная (для выражений условий отбора доменов)

Локальная переменная

Параметр

Имя элемента перечисления

Имя класса. Вне контекста означает ссылку на соответствующий объект класса TClass

Имя поля

Имя метода

Имя свойства

При интерпретации квалификатора внутри выражения агрегата правила разбора идентификатора изменяются:

Контекстная переменная (для выражений условий отбора доменов)

Имя элемента перечисления

Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту

Имя поля

Имя метода

Имя свойства

Локальная переменная

Параметр

5.9.2.4.3. Агрегат

Агрегат определяет агрегированное значение над экземплярами определенного класса, удовлетворяющими условиям агрегации. Агрегаты бывают следующих типов:

any - первый попавшийся объект. Результат имеет тип ссылки на объект агрегируемого класса.
1any(TObject with Master = Self.Parent)
2//первый попавшийся объект, имеющий значение
3//свойства Master равным значению свойства
4//Parent текущего (контекстного) объекта.
count - количество объектов. Результат имеет целочисленный тип.
1count(TObject with Master = Self.Parent)
2//количество объектов, имеющих значение свойства
3//Master равным значению свойства Parent
4//текущего объекта.
sum - сумма значений свойства, поля или функции объектов. Результат имеет тип суммируемого поля, свойства или функции
1sum(TExam.Mark with Master = LStudent) //сумма
2//баллов студента по его испытаниям
max, min - соответственно максимальное и минимальное значений свойства, поля или функции объектов. Результат имеет тип агрегируемого поля, свойства или функции
1min(TObject.Created) // момент создания первого
2//объекта Системы.
Внутри выражения агрегата правила разбора идентификатора изменяются на следующие:

Контекстная переменная (для выражений условий отбора доменов)

Имя элемента перечисления

Имя класса. Если это имя агрегируемого класса, то дальнейшие разыменования относятся к агрегируемому объекту

Имя поля

Имя метода

Имя свойства

Локальная переменная

Параметр

5.9.2.4.4. Операции

Операции связывают элементы выражений.

Таблица операций в порядке приоритета:

Левый
операнд

Правый операнд

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

not

Нет

Логи-
ческий

* (звездочка)

Целый

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

/ (слэш, дробь)

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

div

Целый

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

nil

and

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Логи-
ческий

Строковый

Объект

nil

or

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Логи-
ческий

Строковый

Объект

nil

+ (плюс)

Целый

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Дата

Дата со временем

Дата со временем

Время

Время

Время

Дата со временем

Время

Дата со временем

Дата со временем

Дата со временем

Дата со временем

Дата со временем

Логи-
ческий

Строковый

Строковый

Объект

nil

- (минус)

Целый

Целый

Вещест-
венный

Вещест-
венный

Вещест-
венный

Вещест-
венный

Дата

Дата

Дата со временем

Целый

Дата со временем

Вещест-
венный

Время

Время

Время

Дата со временем

Время

Дата со временем

Дата со временем

Дата со временем

Дата со временем

Вещест-
венный

Дата со временем

Вещест-
венный

Логи-
ческий

Строковый

Объект

nil

=, <> (равно, не равно)

Целый

Логи-
ческий

Логи-
ческий

Логи-
ческий

Вещест-
венный

Логи-
ческий

Логи-
ческий

Логи-
ческий

Дата

Логи-
ческий

Логи-
ческий

Логи-
ческий

Время

Логи-
ческий

Логи-
ческий

Дата со временем

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Строковый

Логи-
ческий

Логи-
ческий

Объект

Логи-
ческий

Логи-
ческий

nil

Логи-
ческий

<, >, <=, >= (меньше, больше, меньше либо равно, больше либо равно)

Целый

Логи-
ческий

Логи-
ческий

Вещест-
венный

Логи-
ческий

Логи-
ческий

Дата

Логи-
ческий

Логи-
ческий

Время

Логи-
ческий

Дата со временем

Логи-
ческий

Логи-
ческий

Логи-
ческий

Логи-
ческий

Строковый

Логи-
ческий

Объект

nil

is

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

Логи-
ческий

nil

as

Целый

Вещест-
венный

Дата

Время

Дата со временем

Логи-
ческий

Строковый

Объект

Объект

nil

5.9.2.4.4.1. Особенности применения операций

Приоритет сравнений ниже приоритета операций булевой логики. Поэтому выражение
LObject.Master = LMaster and LObject.Parent = LParent
будет интерпретироваться следующим образом:
LObject.Master = (LMaster  and LObject.Parent) = LParent
и вызовет ошибку компиляции из-за применения операции and к объектам. Необходимо писать:
(LObject.Master = LMaster) and (LObject.Parent = LParent)
Любое значение (выражение любого типа) сравнивается с безтиповой константой nil:
1      LObject := any(TObject with Name = 'Some name');
2      if LObject = nil then
3         .....
Операции "Унарный минус" не существует. Для задания отрицательных констант пользуйтесь конструкцией 0-Значение:
Result := 0-1;
5.9.2.5. Формальная грамматика
001Goal: MethodBody | Expression;
002
003MethodBody: [ConstantDeclaration] [VariableDeclaration] CompoundStatement ";";
004
005ConstantDeclaration: "const" Ident ":" DomainSpecification ";"
006  [{Ident ":" DomainSpecification ";"}];
007
008VariableDeclaration: "var" DomainDefinition [{DomainDefinition}];
009
010DomainDefinition: Ident ":" DomainSpecification ";";
011
012DomainSpecification: IntegerDomainDefinition
013  | StringDomainDefinition
014  | FloatDomainDefinition
015  | DateDomainDefinition
016  | TimeDomainDefinition
017  | DateTimeDomainDefinition
018  | BooleanDomainDefinition
019  | BlobDomainDefinition
020  | EnumerationDomainDefinition
021  | Ident;
022
023IntegerDomainDefinition: "integer";
024StringDomainDefinition: "string" "[" Number "]";
025FloatDomainDefinition: "float" ["(" Number ["." Number] ")"];
026DateDomainDefinition: "date";
027TimeDomainDefinition: "time";
028DateTimeDomainDefinition: "datetime";
029BooleanDomainDefinition: "boolean";
030BlobDomainDefinition: "blob" | "clob";
031EnumerationDomainDefinition: "(" Ident {"," Ident} ")";
032
033CompoundStatement: "begin" Statement [{";" Statement}] "end";
034
035Statement:
036  | CompoundStatement
037  | AssignmentStatement
038  | InheritedStatement
039  | CallStatement
040  | IfStatement
041  | CaseStatement
042  | ForStatement
043  | WhileStatement
044  | RepeatStatement
045  | TryFinallyStatement
046  | TryExceptStatement
047  | RaiseStatement
048  | ForEachStatement
049  | ExitStatement;
050
051AssignmentStatement:  Qualifier ":=" Expression;
052
053CallStatement: Qualifier;
054
055InheritedStatement: "inherited";
056
057IfStatement: "if" Expression "then" Statement ["else" Statement];
058
059CaseStatement: "case" Expression "of" {CaseBranch} ["else" Statement ";"] "end";
060
061CaseBranch: CaseLabel [{',' CaseLabel}] ":" Statement ";";
062
063CaseLabel: Number | Ident;
064
065ForStatement: "for" Ident ":=" Expression ("to"|"downto")
066  Expression "do" Statement;
067
068WhileStatement: "while" Expression "do" Statement;
069
070RepeatStatement: "repeat" Statement [{";" Statement}] "until" Expression;
071
072TryFinallyStatement: "try" Statement [{";" Statement}] "finally"
073  Statement [{";" Statement}] "end";
074
075TryExceptStatement: "try" Statement [{";" Statement}] "except"
076  Statement [{";" Statement}] "end";
077
078RaiseStatement: "raise" [Expression];
079
080ForEachStatement: "for" "each" Ident "of" Ident ["with" Expression]
081  ["by" Expression] "do" Statement;
082
083ExitStatement: "exit";
084
085Expression: ComparedExpression [{RelationOperation Expression}];
086
087ComparedExpression: Addon [{AdditionOperaton ComparedExpression}];
088
089Addon: Factor [{MultiplicativeOperation Addon}];
090
091Factor: "(" Expression ")"
092  | "not" Expression
093  | Number ["." Number]
094  | StringConstant
095  | Qualifier
096  | "nil"
097  | "True"
098  | "False"
099  | "(" Expression "is" Ident ")"
100  | "any" Aggregate
101  | "count" Aggregate
102  | "sum" Aggregate
103  | "max" Aggregate
104  | "min" Aggregate;
105
106Aggregate: "(" Ident ["." Ident] ["with" Expression] ")";
107
108Qualifier: QualifierPart [{"." QualifierPart}];
109
110QualifierPart: Ident ["(" Expression [{", " Expression}] ")"]
111  | "self"
112  | "(" Qualifier "as" Ident ")";
113
114RelationOperation: "<"
115  | ">"
116  | "<="
117  | ">="
118  | "="
119  | "<>";
120
121AdditionOperaton: "+"
122  | "-"
123  | "or";
124
125MultiplicativeOperation: "*"
126  | "/"
127  | "div"
128  | "and";
5.9.2.6. Соглашения

5.9.2.6.1. Соглашения о наименованиях

В качестве вводимых (объявляемых) идентификаторов необходимо использовать так называемую нотацию InfixCaps. Если при создании имени используется несколько слов, то необходимо использовать заглавную букву для каждого слова в имени. Для разделения слов нельзя использовать символ подчеркивания. Все сущности именуются на английском языке, при этом использование сокращений является оправданным только в случае, если длина образуемого имени не согласуется с внешними по отношению к соображениям бизнес-логики ограничениям.

Имя класса должно начинаться с латинской буквы 'T'.

Имя

Наименование

TObjectList

Список объектов

TLearnPlan

Учебный план

Имя поля должно начинаться с латинской буквы 'F'.

Имя

Наименование

FLearnPeriod

Период обучения

FExamMark

Оценка за экзамен

Имя свойства не имеет префикса.

Имя

Наименование

ExamKind

Вид рубежного испытания

ContactPhone

Контактный телефон

Если членом класса для чтения свойства является поля, то имя свойства должно повторять имя поля без префикса 'F'. Если членом класса для чтения свойства является метод, то имя поля должно повторять имя метода без слова 'Get'.

Имя параметра не имеет префикса.

Имя

Наименование

OrderNumber

Номер приказа

ExamDate

Дата проведения экзамена

Параметры, используемые для инициализации значений полей, должны иметь имя, повторяющее имя поля без префикса 'F'. При компиляции тела метода, написанного на языке PascalScript имена параметров и имена свойств будут распознаваться в соответствии с порядком разбора идентификаторов, как это описано здесь и здесь.

Имена методов должны представлять собой императивный глагол на английском языке, выражающий смысл того, что метод делает. Имена методов не имеют префикса. Имена методов, используемых для получения значений свойств должны (как члены класса для чтения), должны начинаться со слова Get. Имена методов, используемых для установки значений свойств должны (как члены класса для записи), должны начинаться со слова Set.

Имя

Наименование

CountMarkSumm

Вычислить сумму баллов

GetAge

Получить значение возраста

SetMark

Установить значение оценки

Имена локальных переменных должны начинаться с латинской буквы 'L'.

LMarkSumm (сумма баллов), LObjectCount (количество объектов).

Имена доменов должны начинаться с латинской буквы 'T'. В именах доменов допустимы пробелы. Рекомендуется к имени домена добавлять слово 'domain' (через пробел), а для обязательных доменов 'required domain' (через пробел) тогда, когда необходимо исключить возможность использования этих доменов в текстах на PascalScript. Первым словом в имени домена-ссылки должно быть имя класса домена. Исключением являются имена доменов, соответствующих простым типам данных без дополнительных ограничений. Имена таких доменов могут повторять имена типов языка PascalScript (Integer, Boolean, Float).

Имя

Класс домена

Наименование

TPrice domain

Вещественный

домен Цена

TWeight required domain

Целочисленный

домен Вес (обязательный)

Boolean

Логический

Логический

TClassMember required domain

Ссылка

домен Член класса

Имена элементов перечислений должны иметь префикс из двух или трех символов, идентифицирующий соответствующий домен-перечисление. Префикс записывается строчными буквами. Например,

Имя

Наименование

для домена TExamKind (вид испытания)

ekTest

зачет

ekExam

экзамен

ekDifTest

дифференцированный зачет

для домена TAggregateKind (вид агрегата)

agCount

количество

agSumm

сумма

agAverage

среднее значение

Настоятельно рекомендуется давать уникальные имена элементов перечислений в пределах всей системы.

5.9.2.6.2. Стилевое оформление исходного кода

Код на языке PascalScript, являющийся частью поставляемого решения, должен быть оформлен в соответствии с изложенными правилами.

5.9.2.6.2.1. Использование строк, пробелов и отступов

Пустые строки могут повысить читабельность путем группирования секций кода, которые логически связаны между собой.

Пробелы, запрещенные к использованию:

До или после точки "."

Между именем вызываемого метода и открывающей скобкой "("

После открывающей скобки "(" или перед закрывающей ")"

Перед точкой с запятой ";"

Перед двоеточием ":"

Перед запятой ","

Двоеточие для всех объявлений переменных не должно содержать перед собой пробелов и иметь один пробел после перед именем типа.

Всегда необходимо использовать два пробела для всех уровней отступа. Другими словами, первый уровень отступает на два пробела, второй на четыре и так далее. Никогда не используйте символы табуляции.

Существует несколько исключений из этого правила. Зарезервированные слова var, begin и end, относящиеся к программному блоку вцелом, всегда должны примыкать к левой границе. Код внутри блока begin..end должен иметь отступ два символа.

Все строки должны быть ограничены 80 столбцами. Строки, длиннее чем 80 столбцов должны быть разделены и перенесены. Все перенесенные строки должны быть выровнены по первой строке и иметь отступ в два символа. Зарезервированное слово begin всегда должно находиться на своей отдельной строке.

Нельзя переносить строки в тех местах, где не допускаются пробелы, например между именем метода и открывающей скобкой. Никогда нельзя помещать зарезервированное слово begin на строку, содержащую другой код.

5.9.2.6.2.2. Оформление объявлений и операторов

Все переменные с их типами должны быть объявлены на различных строках.

Простые операторы содержат одну точку с запятой. Если Вам необходимо разделить оператор, то перенесите продолжение оператора на следующую строку с отступом в два пробела.
  MyValue :=
    MyValue + (SomeVeryLongStatement / OtherLongStatement);
Составные операторы всегда заканчиваются точкой с запятой.
1begin
2  MyStatement;
3  MyNext Statement;
4  MyLastStatement;
end;
Каждое присвоение и каждое выражение должно располагаться на разных строках.

Оператор "if"
Оператор if всегда должен располагаться по крайней мере на двух строках
if A < B then DoSomething;
if A < B then
  DoSomething;
В случае составного оператора необходимо поместить каждый оператор на новую строку.
1  if A < B then begin
2    DoSomething;
3    DoSomethingElse;
4  end else begin
5    DoThis;
6    DoThat;
7  end;
1  if A < B then
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end
6  else
7  begin
8    DoThis;
9    DoThat;
  end;
Все остальные варианты расположения операторов не рекомендуются и не одобряются, хотя и являются синтаксически правильными.
Оператор "for"
1  for i := 0 to 10 do begin
2    DoSomething;
3    DoSomethingElse;
4  end;
1  for i := 0 to 10 do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  for I := 0 to 10 do
8    DoSomething;
Оператор "while"
1  while x < j  do begin
2    DoSomething;
3    DoSomethingElse;
  end;
1  while x < j do
2  begin
3    DoSomething;
4    DoSomethingElse;
5  end;
6
7  while x < j do
8    Something;
Оператор "repeat..until"
1  repeat
2    x := j;
3    j := UpdateValue;
4  until j > 25;
Оператор "case"
Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01  case LCode of
02    1, 3:
03      begin
04        Incr := FIncrement + 1;
05        FinalIncr := FIncrement div FLineDiv;
06        Count := FLineDiv;
07      end;
08    2, 4:
09      begin
10        Incr := FPageIncrement;
11        FinalIncr := Incr + 1;
12        Incr := Incr div FPageDiv;
13        Count := FPageDiv;
14      end;
15  else
16    begin
17      Count := 0;
18      Incr := 0;
19      FinalIncr := 0;
20    end;
  end;
Оператор "try"
Несмотря на то, что существует множество синтаксически правильных конструкций, одобренной и рекомендованной считается следующая:
01try
02  try
03    EnumItems(CurrentThreadID, LDisable, 0);
04    Result := TaskList;
05  except
06    EnableItems(TaskList);
07    raise;
08  end;
09finally
10  TaskList := SaveList;
11  TaskActive := SaveActive;
end;
5.9.3. Интерфейсы взаимодействия с внешними подсистемами

Системный слой платформы "Мельница данных" предоставляет сторонним системам ряд интерфейсов, дающих возможность обращаться к объектам базы данных и их свойствам, вызывать методы классов и объектов, осуществлять запросы к базе данных, управлять поведением элементов управления и проч.

5.9.3.1. Интерфейс IContext
01  IContext = interface(IDispatch)
02    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
03    function Handle: Integer;
04    function getName(ID: OleVariant): WideString;
05    function getDescription(ID: OleVariant): WideString;
06    function createDataSet(const TargetClassName: WideString):
07      IContextDataSet;
08    function executeMethod(const ClassName: WideString;
09      const MethodName: WideString;
10      Params: OleVariant): OleVariant;
11    function executeReport(const ClassName: WideString;
12      const TemplateName: WideString;
13      Params: OleVariant): IDispatch;
14    function getPropValue(const ClassName: WideString;
15      const PropName: WideString;
16      const ID: OleVariant): OleVariant;
17    procedure setPropValue(const ClassName: WideString;
18      const PropName: WideString;
19      const ID: OleVariant; Value: OleVariant);
20    function select(const ClassName: WideString;
21      QueryItems: OleVariant): IDispatch;
22    function enumerationItem(ItemIdentifier: OleVariant): WideString;
23    function getClass(const ClassName: WideString): WideString;
24    function createGUID: WideString;
25    procedure processStart(const Description: WideString;
26      ItemCount: Integer);
27    procedure processStep;
28    procedure processStop;
29    function PlaceDataSet(const Range: IDispatch;
30      const DataSet: IContextDataSet;
31      ShiftRows: WordBool; ShiftColumns: WordBool): Integer;
32    procedure DebugString(const Message: WideString);
33    procedure ExportObject(var Document: OleVariant; const ID: WideString;
34      const ClassID: WideString);
35    function callRoutine(const ClassName, RoutineName: WideString;
36      var RetValue: OleVariant; const ScriptPart: OleVariant): WordBool;
37    function getOleObject(const ClassID, AccessibleFileName: WideString): IDispatch;
38    function getResource(const Name: WideString): WideString;
39    function getTempFileName(const Extension: WideString): WideString;
40    function selectVaue(const ClassDomain: WideString;
41      const ExpressionContext: IContextExpressionInfo;
42      var Value: OleVariant): WordBool;
43    procedure raiseManagedException(const ExceptionMessage: WideString);
44    function getCRC(Data: OleVariant): WideString;
45    function downloadData(const Host: WideString; const Url: WideString;
46      const UserName: WideString; const Password: WideString;
47      NegotiateAuth: WordBool; PostData: OleVariant;
48      const PostContentType: WideString; PostDataIsBinary: WordBool;
49      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;
50    function createBinaryData: IDispatch;
51    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
52    function editValues(const ValuesList: WideString; const Title: WideString;
53      UseTabs: WordBool; HideOKButton: WordBool;
54      const ScriptPart: OleVariant): WordBool;
55    function MsgBox(const Prompt: WideString; Buttons: LongWord;
56      const Title: WideString;
57      const HelpFile: WideString; Context: LongWord): Integer;
58    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
59      const Title: WideString;
60      const HelpFile: WideString; Context: LongWord): Integer;
61    function buildNamedFile(const Data: IDispatch; const StoredFileName: WideString;
62                            Propmpt: WordBool; Compress: WordBool): IDispatch;
63    procedure parseNamedFile(const NamedFile: IDispatch; out FileName: OleVariant;
64                             out Data: OleVariant);
65    procedure showView(const ViewName: WideString; Key: OleVariant;
66                       const DetailPropertyName: WideString);
67    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
68                          ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
69                          TakeActionsFromView: OleVariant);
70    function executeConsoleProcess(const CommandLine: WideString; MaxDuration: Integer;
71                                   const OutputData: OleVariant): Integer;
72    function createRaster: IDispatch;
73    function createZIPArchive: IDispatch;
74    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch;
75    property ContextObject: IDispatch;
76    property Language: WideString;
77    property UserName: WideString;
78    property NegotiateAuth: WordBool;
79    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant;
80  end;
Члены интерфейса доступны для использования в скриптах форм задания параметров, а также в отчетах как члены класса передаваемого контекстного объекта.

Функция Handle возвращает дескриптор главного окна приложения.

Функция getName возвращает имя объекта по его идентификатору.

Функция getDescription возвращает наименование объекта по его идентификатору.

Функция createDataSet создает набор данных, основанный на экземплярах класса, имя которого передано как параметр. Возвращаемый объект реализует интерфейс IContextDataSet.

Функция executeMethod осуществляет вызов метода с параметрами. Имя класса передается в параметре ClassName, имя вызываемого метода - в параметре MethodName. Если вызываемый метод явяется функцией, то результат ее выполнения возвращается как результат вызова executeMethod. Параметры вызова метода передаются через параметр Params следующим образом:

Для методов класса без параметров можно передавать любое значение, например, Null.

Для методов класса, имеющих один параметр, значение Params есть значение этого единственного параметра.

Для методов класса, имеющих более одного параметра, значение Params есть массив значений параметров.

VBScript, VBA

LValue = executeMethod("TObject", "Round", Array(10.24, 1))

JScript

LValue = executeMethod("TObject", "Round", new Array(10.24, 1));

Object Pascal

LValue := executeMethod('TObject', 'Round', VarArrayOf([10.24, 1]));

Для методов экземпляра без параметров значение Params есть идентификатор объекта, для которого вызывается метод.

Для методов экземпляра, имеющих параметры, значение Params есть массив значений параметров. При этом первым элементом массива является идентификатор объекта, для которого вызывается метод.

VBScript, VBA

executeMethod "TObject", "MergeTo", Array(LOldObject, LNewObject)

JScript

executeMethod("TObject", "MergeTo", new Array(LOldObject, LNewObject));

Object Pascal

executeMethod('TObject', 'MergeTo', VarArrayOf([LOldObject, LNewObject]));

Функция executeReport осуществляет вызов отчета с параметрами. Имя класса передается в параметре ClassName, имя вызываемого метода - в параметре TemplateName. Параметры вызова передаются в параметре Params аналогично вызову executeMethod. В результате вызова функции возвращается ссылка на рабочую книгу Microsoft Excel, документ Microsoft Word и так далее. Судьба приложения, в рамках которого создан возвращенный объект, остается на усмотрение вызывающей стороны. Если вызывающая сторона предполагает взаимодействие объекта с пользователем, то необходимо обеспечить видимость объекта-приложения (Application.Visible := True;). В противном случае необходимо закрыть приложение после освобождения объекта документа (Application.Quit).

Функция getPropValue возвращает значение свойства объекта. Имя класса, имя свойства и идентификатор объекта задаются в параметрах.

Процедура setPropValue устанавливает значение свойства объекта в значение, заданное параметром Value. Для очистки значения можно использовать пустую строку или значение Null. Имя класса, имя свойства и идентификатор объекта задаются в параметрах.

Функция select возвращает ссылку на XML-документ, содержащий в корневом элементе элементы, представляющие собой записи набора данных на основе класса ClassName (с полями, разнесенными по элементам), определяемого структурой параметра QueryItems.

Функция enumerationItem возвращает идентификатор элемента перечисления по имени.

VBScript, VBA

LItemID = enumerationItem("rsReplicatableMetadata")

JScript

LItemID = enumerationItem("rsReplicatableMetadata");

Object Pascal

LItemID := enumerationItem('rsReplicatableMetadata');

Функция getClass возвращает идентификатор объекта типа Класс TClass (Классы) по имени.

VBScript, VBA

LClassID = getClass("TDocumentType")

JScript

LClassID = getClass("TDocumentType");

Object Pascal

LClassID := getClass('TDocumentType');

функция createGUID является оберткой над функцией Windows API CoCreateGuid. Возвращает сгенерированный глобально-уникальный идентификатор, преобразованный в строку.

процедура processStart информирует систему о необходимости показать окно выполнения длительного процесса. Текст, описывающий процесс (он появляется в показываемом окне) задается параметром Description. В случае, если есть возможность определить количество "шагов" процесса, то это количество необходимо передать в параметре ItemCount. В случае, если параметр ItemCount больше нуля, окно выполнения будет снабжено индикатором прогресса. Если значение ItemCount равно нулю, то окно появится без индикатора прогресса. Если значение ItemCount меньше нуля, то решение о появлении окна будет принято системой самостоятельно на основании загрузки процессора и окно процесса не появится, если процесс завершится достаточно быстро.

процедура processStep информирует систему о завершении очередного "шага" процесса, что найдет отражение в индикаторе прогресса окна выполнения длительного процесса, если таковые случатся.

процедура processStop информирует систему о завершении длительного процесса, что приведет к закрытию окна выполнения длительного процесса, если таковое случится.

функция PlaceDataSet осуществляет перенос данных из набора, задаваемого параметром DataSet в некоторое место документа Microsoft Office. Место назначения определяется параметром Range следующим образом:

Microsoft Word

Объект Range. По месту расположения этого объекта будет создана таблица (Table), в которой будут размещены данные из набора.

PlaceDataSet ThisDocument.Bookmarks("BookMarkName").Range, LDataSet

PlaceDataSet Selection.Range, LDataSet

Объект Document. В самом начале переданного документа будет создана таблица (Table), в которой будут размещены данные из набора.

PlaceDataSet ThisDocument, LDataSet

Microsoft Excel

Объект Range. По месту расположения этого объекта (диапазона) будут размещены данные из набора. Если параметр ShiftRows задан и равен True, то заданный диапазон будет расширен вниз на необходимое количество строк, и информация, лежащая ниже переданного диапазона, будет по-прежнему лежать ниже. Если нет, то она (скорее всего) будет затёрта данными набора. Если параметр ShiftColumns задан и равен True, то этот диапазон будет расширен вправо на необходимое количество столбцов, и информация, лежащая правее переданного диапазона, будет по-прежнему лежать правее. Если нет, то она (скорее всего) будет затёрта данными набора.

PlaceDataSet Range("C4"), LDataSet

Объект WorkSheet. На переданном листе будут размещены данные из набора.

PlaceDataSet WorkSheets("HiddenSheet"), LDataSet

Функция возвращает количество размещенных записей.

процедура DebugString выводит переданную в качестве аргумента строку в отладочный монитор.

процедура ExportObject осуществляет экспорт информации об объекте, задаваемом параметром ID в XML-документ, передаваемый в параметре Document. Если объект документа не был создан, то он создается автоматически. Если документ не имеет корневого узла, он будет создан автоматически.
01set LDataSet = CreateDataSet("TSecurityAccount")
02
03LDataSet.AddQueryItem qpWhat, "ID"
04
05set LDocument = CreateObject("Msxml2.DOMDocument.4.0") 'Не обязательно.
06
07while not LDataSet.Eof
08  ExportObject LDocument, LDataSet.Field("ID")
09  LDataSet.Next
10wend
11
12LDocument.save "c:\RolesAndUsers.xml"
Функция callRoutine осуществляет вызов подпрограммы. Параметры будут запрошены у пользователя обычным порядком (с показом формы задания параметров, отработки ее скрипта и т. д.). Имя класса передается в параметре ClassName, имя вызываемой подпрограммы - в параметре RoutineName. Если пользователь разрешил выполнение подпрограммы (либо для выполнения не требовалось разрешения пользователя), функция вернет True, иначе False. Значение, возвращаемое подпрограммой, может быть возвращено через необязательный параметр RetValue. Через значение необязательного параметра ScriptPart можно передать скрипт на языке VBScript, который будет "приклеен" сверху к скрипту формы параметров вызываемой подпрограммы.

Функция getOleObject возвращает ссылку на Ole-объект с идентификатором класса, переданном в параметре ClassID. Объект создается на основе библиотеки кода, сохраненной в доступном файле с именем, заданным параметром AccessibleFileName. Регистр символов имени доступного файла важен.

Функция getResource возвращает значение ресурсной строки по имени ресурса (элемента перечислимого домена Resource strings или перевода (объекта класса TLanguageTranslation).
MsgBox getResource("rssMyErrorMessage")
Функция getTempFileName возвращает сгенерированное системой имя временного файла с расширением, переданным в параметре Extension.

Функция selectVaue позволяет пользователю выбрать значение на основе ссылочного домена, имя которого передается в параметре ClassDomain. Вызывающая сторона может реализовать интерфейс IContextExpressionInfo, через который передается информация о контексте вызова для интерпретации выражений условий отбора, и передать ссылку на него через параметр ExpressionContext. Выбранное значение передается в обе стороны через параметр Value. Если пользователь подтвердил выбор значения, функция возвращает значение True, и устанавливает значение параметра Value, равное идентификатору выбранного пользователем объекта. Если пользователь отказался от выбора, функция возвращает значение False.

Процедура raiseManagedException возбуждает управляемую исключительную ситуацию с сообщением для пользователя, заданным параметром ExceptionMessage.

Функция getCRC возвращает шестнадцатиричное представление контрольной суммы переданных в параметре Data данных. Параметр может быть

Объектом, реализующим интерфейс IBinaryData

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Объектом, реализующим интерфейс IFile объектной модели FileSystemObject

Строкой данных. Строка будет преобразована в байты в соответствии с кодировкой UTF-8.

Функция downloadData осуществляет обращение к указанному ресурсу по протоколу http (https), и возвращает ответ сервера в виде объекта, реализующего интерфейс IBinaryData. Параметр Host определяет http-сервер, параметр Url - Url, к которому будет происходить обращение. Параметры UserName и Password определяют имя пользователя и пароль, если http-сервер требует авторизовать пользователя. Параметр NegotiateAuth устанавливает режим аутентификации. (Basic или Negotiate). Параметры PostData, PostContentType и PostDataIsBinary определяют содержимое тела POST-запроса (если не определено, функция отправит GET-запрос). Параметр CanCache позволяет использовать локальный кеш http-ответов. Параметр NewSession требует принудительного создания новой сессии при вызове функции. Параметр TimeOut определяет максимальное время ожидания ответа в секундах.

Функция createBinaryData создает пустой объект, реализующий интерфейс IBinaryData.

Функция BinaryToBitmap конвертирует переданный графический файл в формат BMP. Объекты во входном и выходном параметрах должны реализовывать интерфейс IBinaryData.

Функция editValues создает и показывает форму редактирования группы значений. Параметр ValuesList содержит идентификатор объекта класса TObjectList. Этот список содержит ссылки на редактируемые значения (объекты класса TTypedValue), и командные кнопки формы (объекты класса TTypedValueButton). Параметр Title определяет заголовок формы, параметр UseTabs определяет, будут ли показаны закладки на форме редактирования. Параметр HideOKButton позволяет скрыть кнопку "OK" на показываемой форме. Параметр ScriptPart определяет скрипт показываемой формы.
01  LValue1 = executeMethod ("TTypedValue", "CreateStrValue", _
02    Array("Value1", "Первый параметр", Null, Null, _
03    "TLongString", Null, Null, Null, Null, Null, "Значение по  умолчанию первого параметра"))
04  LValue2 = executeMethod ("TTypedValue", "CreateStrValue", _
05    Array("Value2", "Второй параметр", Null, Null, _
06    "TLongString", Null, Null, Null, Null, Null, "Значение по  умолчанию второго параметра"))
07
08  LValues = executeMethod("TObjectList", "CreateFromString", _
09    LValue1 & ";" & LValue2)
10
11  if editValues(LValues, "Введите два строковых значения, друзья", True, False, "") then
12    MsgBox getPropValue("TTypedValue", "StrValue", LValue1) & _
13      " " & _
14      getPropValue("TTypedValue", "StrValue", LValue2)
15  end if
16
17  executeMethod "TObject", "Destroy", LValues
18  executeMethod "TObject", "Destroy", LValue1
19  executeMethod "TObject", "Destroy", LValue2
01  LScriptPart =  "Buttons(""NextButton"").Enabled = ParentForm.NavigatorCanNext" & Chr(10) & _
02    "Buttons(""PrevButton"").Enabled = ParentForm.NavigatorCanPrevious"
03
04  LValue1 = executeMethod ("TTypedValue", "CreateStrValue", _
05    Array("Value1", "Первый параметр", Null, Null, "TLongString", Null, Null, Null, Null, Null, _
06    "Значение по  умолчанию первого параметра"))
07  LValue2 = executeMethod ("TTypedValue", "CreateStrValue", _
08    Array("Value2", "Второй параметр", Null, Null, "TLongString", Null, Null, Null, Null, Null, _
09    "Значение по  умолчанию второго параметра"))
10
11  LNextButton = executeMethod ("TTypedValueButton", "Create", Array("NextButton", "Вперед!", _
12    Null, Null, Null, Null, 0, Null, Null, _
13    "ParentForm.NavigatorNext"  & Chr(10) & LScriptPart, enumerationItem("scPublic"), 1, Null))
14
15  LPrevButton = executeMethod ("TTypedValueButton", "Create", Array("PrevButton", "Назад!", _
16    Null, Null, Null, Null, 1, Null, Null, _
17    "ParentForm.NavigatorPrevious" & Chr(10) & LScriptPart, enumerationItem("scPublic"), 1, Null))
18
19  LValues = executeMethod("TObjectList", "CreateFromString", _
20    LValue1 & ";" & LValue2 & ";" & LNextButton & ";" & LPrevButton)
21
22  if editValues(LValues, "Введите два строковых значения, друзья", True, True, LScriptPart) then
23    MsgBox getPropValue("TTypedValue", "StrValue", LValue1) & _
24      " " & _
25      getPropValue("TTypedValue", "StrValue", LValue2)
26  end if
27
28  executeMethod "TObject", "Destroy", LValues
29  executeMethod "TObject", "Destroy", LValue1
30  executeMethod "TObject", "Destroy", LValue2
31  executeMethod "TObject", "Destroy", LNextButton
32  executeMethod "TObject", "Destroy", LPrevButton
Функции MsgBox и ShowMsgBox (это синонимы одной точки входа) полностью аналогичны функции Basic MsgBox по поведению и набору параметров.

Функция buildNamedFile формирует значение типа "Именованный файл" на основе объекта, реализующего интерфейс IBinaryData (параметр Data) и информации об имени и параметрах именованного файла.

Процедура parseNamedFile разбирает значение типа "Именованный файл". Выходной параметр FileName будет содержать сохраненное имя файла, выходной параметр Data - объект, реализующего интерфейс IBinaryData и содержащий данные именованного файла.

Свойство ContextObject позволяет получить ссылку на этот же самый контекстный объект.

Свойство UserName позволяет получить логин текущего пользователя.

Свойство NegotiateAuth позволяет получить признак доменной аутентификации пользователя.

Свойство Language позволяет получать и устанавливать текущий языковой контекст, в котором будут выполняться обращения к БД. Значение свойства либо пустая строка (используется язык БД по умолчанию), либо имя объекта класса TLanguage

Свойство Variable позволяет сохранять и получать произвольные значения, которые могут хранится постоянно (в реестре) или только в текущем сеансе, в зависимости от параметра Persistent.
1'сохранить на время текущего сеанса значение в переменную с именем SameVariableName
2Variable("SameVariableName", False) = "Value"
3
4'получить значение переменной с именем SameVariableName хранимой в текущем сеансе
5LValue = Variable("SameVariableName", False)
Процедура showView осуществляет показ в модальном окне представления с именем ViewName. С помощью параметров DetailPropertyName и Key можно наложить на представление дополнительное условие отбора.

5.9.3.2. Интерфейс IContextDataSet
01  IContextDataSet = interface(IDispatch)
02    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
03    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
04      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant);
05    function Eof: WordBool;
06    function Field(const Name: WideString): OleVariant;
07    function FieldCount: Integer;
08    function FieldName(Index: Integer): WideString;
09    procedure Next;
10  end;
Интерфейс предоставляет возможности формирования и выполнения запросов к базе данных с целью получения свойств объектов определенного класса, предоставляет доступ к объекту набора данных. Работа с объектом, реализующим интерфейс IContextDataSet заключается в формировании структуры набора данных и последующих обращениях к ним.

Процедура AddQueryItem добавляет элемент набора данных. Элементы могут добавляться в любом порядке до первого обращения к данным набора. Символические имена всех предопределенных для параметров этого метода констант являются членами интерфейса IConstants.

часть запроса определяется параметром Part, который может принимать одно из следующих предопределенных значений:

Символическое имя

Числовое значение

Описание

qpWhat

0

Добавляет поле (столбец), определяемое параметром Name, к результирующему набору данных. Параметр Value игнорируется.

qpWhere

1

Определяет условие, налагаемое на свойства объектов класса, передаваемое остальными параметрами.

qpOrder

2

Определяет порядок сортировки записей результирующего набора данных. Параметр Value игнорируется.

qpGroup

3

Определяет, что записи результирующего набора данных будут сгруппированы по столбцу, переданному в параметре Name. Параметры Value и Special игнорируются.

параметр Name должен быть именем свойства класса, на котором основан набор данных, либо зарезервированным словом "ID" (без кавычек).

параметр Value (необязательный) определяет условия отбора, накладываемые на свойство, заданное параметром Name. Имеет смысл только если значение параметра Part равно qpWhere. Условие задается посредством строки, интерпретируемой следующим образом:

строка разделяется на части посредством системного разделителя

каждая часть интерпретируется самостоятельно, и эти части объединяются логическим "ИЛИ"

при интерпретации каждой части проверяются следующие условия:

*

проверка значения на непустоту (IS NOT NULL)

!*

проверка значения на пустоту (IS NULL)

начинается с символов
'<=', '<', '>=', '>'

проверка соответствующего отношения между значением свойства, переданного параметром Name и оставшейся частью строки

включает в себя символы '*' и/или '?'

проверка соответствия значения шаблону, в котором знак '?' соответствует одному любому символу, а знак '*' - любому количеству любых символов

начинается с символа '!'

символ '!' означает отрицание условия, переданного оставшейся частью строки

представляет собой строку в апострофах (одиночных кавычках)

содержание строки не анализируется по приведенным выше условиям

любая другая строка

проверка равенства значения свойства, переданного параметром Name значению, переданному строкой

параметр Special (необязательный) обеспечивает дополнительное поведение набора данных (если параметр Special используется, необходимо использовать и параметр Value, можно передавать пустую строку):

Символическое имя

Числовое значение

Описание

qsNone

0

Параметр не используется. Значение по умолчанию.

qsDescending

7

Используется при значении qpOrder параметра Part. В этом случае производится сортировка по убыванию.

qsCount

8

Используется при значении qpWhat параметра Part. Определяют тип агрегации по свойству, заданному параметром Name.

qsSum

9

qsMin

10

qsMax

11

qsAverage

12

qsFunction

22

Используется для включения в запрос вызова функции. Используется при значении qpWhat параметра Part.

параметр Context (необязательный) определяет дополнительные параметры элемента запроса.
01'включить в набор данных свойство Name
02LDataSet.AddQueryItem 0, "Name"
03'включить в набор данных среднее значение цены
04LDataSet.AddQueryItem 0, "Price", "", 12
05'включить в набор данных идентификатор объекта
06LDataSet.AddQueryItem 0, "ID"
07'включить в набор данных вызов функции. В поле IsCompany будет значение True, если объект является организацией
08LDataSet.AddQueryItem 0, "IsCompany", "TObject.IsInstanceOf", 22, Array(getClass("TCompany"))
09'наложить на набор данных условие
10LDataSet.AddQueryItem 1, "Organization", "фирма Елочка"
1LDataSet.AddQueryItem 0, "Organization"              '(1)
2LDataSet.AddQueryItem 0, "SalesCount", "", "9"       '(2)
3LDataSet.AddQueryItem 1, "SaleDate", ">10.09.2005"   '(3)
4LDataSet.AddQueryItem 2, "Organization"              '(4)
5LDataSet.AddQueryItem 3, "Organization"              '(5)
Производится отбор из класса, описывающего число продаж некоего продукта различными организациями. При этом в набор данных включаются колонки "Organization" (строка 1) и "SalesCount" (строка 2). При этом будет произведена группировка по свойству "Organization" (строка 5) (что гарантирует вхождение каждой организации в результирующий набор данных не более одного раза). Набор данных будет отсортирован по организации (строка 4). При этом в колонке "SalesCount" будет сумма (строка 2) всех продаж, осуществленных каждой организацией после 10.09.2005 (строка 3).

Функция FieldCount возвращает количество полей (столбцов) набора данных.

Функция FieldName возвращает имя поля (столбца) с номером, переданным в параметре Index.

Функция Field возвращает значение, содержащееся в поле с именем или индексом, заданным параметром Name (строкового типа) текущей записи набора данных. При первом обращении к набору данных текущей является первая запись. Если параметр определяет номер, то поиск поля производится по номеру. Если имя, то по имени.

Процедура Next осуществляет переход к следующей записи набора данных.

Функция Eof возвращает False, если текущая запись набора данных существует; в случаях, если набор данных пустой, или при помощи метода Next достигнут конец набора данных, возвращает True.
01If LDataSet.Eof then
02  'набор данных пуст. Ничего не отобрано.
03Else
04  While Not LDataSet.Eof
05    'работа с очередной отобранной записью
06    Cells(LRow, 1).Value = LDataSet.Field("Name")
07    Cells(LRow, 2).Value = LDataSet.Field("Description")
08    Cells(LRow, 2).Value = LDataSet.Field("Count")
09    'переход к следующей записи
10    LDataSet.Next
11    LRow = LRow + 1
12  Wend
13End If
5.9.3.3. Интерфейс IConstants
01  IConstants = interface(IDispatch)
02    ['{7E7B2D66-5E7C-496A-AE06-EFC485007500}']
03    property qpWhat: Integer;
04    property qpWhere: Integer;
05    property qpOrder: Integer;
06    property qpGroup: Integer;
07    property qpHaving: Integer;
08    property qsNone: Integer;
09    property qsObjectID: Integer;
10    property qsParentID: Integer;
11    property qsHasChildren: Integer;
12    property qsFilterCondition: Integer;
13    property qsUplink: Integer;
14    property qsRootOnly: Integer;
15    property qsDescending: Integer;
16    property qsCount: Integer;
17    property qsSum: Integer;
18    property qsMin: Integer;
19    property qsMax: Integer;
20    property qsAverage: Integer;
21    property qsMasterLink: Integer;
22    property qsSelectedOnly: Integer;
23  end;
Интерфейс предоставляет символические имена констант, необходимых для работы с объектом, реализующим интерфейс IContextDataSet.

Свойство

Значение

qpWhat

0

qpWhere

1

qpOrder

2

qpGroup

3

qpHaving

4

qsNone

0

qsObjectID

1

qsParentID

2

qsHasChildren

3

qsFilterCondition

4

qsUplink

5

qsRootOnly

6

qsDescending

7

qsCount

8

qsSum

9

qsMin

10

qsMax

11

qsAverage

12

qsMasterLink

13

qsSelectedOnly

14

5.9.3.4. Интерфейс IFormContext
01  IFormContext = interface(IDispatch)
02    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
03    function ChangedControl: OleVariant;
04    function ControlCount: Integer;
05    function ButtonCount: Integer;
06    function ID: WideString;
07    procedure Cancel;
08    function ControlExists(const Name: WideString): WordBool;
09    function ChangedControlName: WideString;
10    function ParentForm: OleVariant;
11    function RoutineID: WideString;
12    procedure PreInitControl(const Name: WideString; Value: OleVariant);
13    procedure NavigatorNext;
14    procedure NavigatorPrevious;
15    function NavigatorCanNext: WordBool;
16    function NavigatorCanPrevious: WordBool;
17    procedure RefreshView(RefreshAll: WordBool);
18    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
19    property Controls[Name: OleVariant]: IControl;
20    property Buttons[Name: OleVariant]: IButton;
21    property Enabled: WordBool;
22  end;
Представляет собой модель формы задания параметров. Члены интерфейса доступны для использования в скриптах форм задания параметров.

Функция ChangedControl возвращает объект, реализующий интерфейс IControl, соответствующий элементу управления, изменение которого вызвало исполнение скрипта формы параметров. Если выполнение скрипта вызвано инициализацией формы задания параметров, то значение функции - Empty. Пустоту значения можно проверить с помощью функции VBScript IsEmpty.

Функция ControlCount возвращает число элементов управления на форме параметров, как видимых так и невидимых.

Функция ButtonCount возвращает число командных кнопок на форме параметров, как видимых так и невидимых.

Функция ID возвращает значение идентификатора объекта, для которого вызван метод. Для методов класса возвращает пустое значение.

Функция ControlExists возвращает True, если элемент управления с именем Name существует на форме, и, соответственно, существует соответствующий параметр.

Функция ChangedControlName возвращает имя элемента управления, изменение которого вызвало исполнение скрипта формы параметров. Если выполнение скрипта вызвано инициализацией формы задания параметров, то значение функции - пустая строка.

Процедура Cancel прекращет работу формы задания параметров. Форма закрывается, выполнение действия блокируется.

Функция ParentForm возвращает ссылку на контекст родительской формы в цепочке вызовов. В контексте первой формы (вызванной с грида немодальной формы) возвращает пустое значение (Empty). Пустоту значения можно проверить с помощью функции VBScript IsEmpty.

Функция RoutineID возвращает идентификатор подпрограммы, для которой вызвана форма.

Процедура PreInitControl имитирует предварительную инициализацию элемента управления с именем Name значением, переданным в параметре Value. Сам элемент управления при этом будет скрыт, и не будет показан вплоть до следующего вызова формы пользователем.

Процедура NavigatorNext выполняет переход к следующему объекту набора данных, для которого показывается форма параметров.

Процедура NavigatorPrevious выполняет переход к предыдущему объекту набора данных, для которого показывается форма параметров.

Функция NavigatorCanNext возвращает True, если возможен переход к следующему объекту набора данных, для которого показывается форма параметров.

Функция NavigatorCanPrevious возвращает True, если возможен переход к предыдущему объекту набора данных, для которого показывается форма параметров.

Процедура RefreshView обновляет набор данных, для которого показывается форма параметров. Если значение параметра RefreshAll равно True, то будет обновлен весь набор, если False, то только выделенные записи.

Свойство Controls позволяет обращаться к элементам управления на форме задания параметров, их свойствам и методам. Каждый элемент управления реализует интерфейс IControl. В параметре Name (строкового типа)может быть передано как имя элемента управления, так и его индекс (в этом случае индекс должен быть передан как строка). Имена элементов управления на форме параметров соответствуют именам параметров подпрограммы (метода, отчета, etc).

Свойство Buttons позволяет обращаться к командным кнопкам на форме задания параметров, их свойствам и методам. Каждая командная кнопка реализует интерфейс IButton. В параметре Name (строкового типа)может быть передано как имя командной кнопки, так и ее индекс (в этом случае индекс должен быть передан как строка).

Свойство Enabled позволяет получать и устанавливать доступность кнопки OK на форме задания параметров. Если на форме есть невалидные (имеющие недопустимые значения) элементы управления, значение свойства всегда равно False и устанавливать его в явном виде в True не рекомендуется. Для учета дополнительного условия рекомендуется использовать следующую конструкцию: Enabled = Enabled and (Controls("SalesCount").Value > 10)

Функция ExpressionContextValue возвращает значение переменной контекста с именем Name, которая используется для интeрпретации выражений условий отбора на форме.

5.9.3.5. Интерфейс IControl
01  IControl = interface(IDispatch)
02    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
03    function Name: WideString;
04    procedure SetHint(const Value: WideString);
05    procedure RefreshLinkedView;
06    property Value: OleVariant;
07    property ReadOnly: WordBool;
08    property IsValid: WordBool;
09    property IsEmpty: WordBool;
10  end;
Моделирует элемент управления на форме задания параметров. Позволяет управлять поведением элементов управления на форме.

Функция Name возвращает имя элемента управления; имена элементов управления всегда совпадают с именамим соответствующих параметров подпрограммы.

Процедура SetHint устанавливает текст всплывающей подсказки элемента управления. Всплывыющая подсказка показывается только если значение элемента управления недопустимо (свойство IsValid равно False).

Процедура RefreshLinkedView обновит связанное с элементом управления представление.

Свойство Value позволяет получать и устанавливать значение, введенное в элемент управления.

Свойство ReadOnly позволяет получать и устанавливать доступность элемента управления для записи; при значении True элемент управления не доступен для записи и отображается неактивным.

Свойство IsValid позволяет получать и устанавливать "валидность" элемента управления; по умолчанию валидным элемент управления является в том случае, если введенное в него значение соответствует домену соответствующего параметра подпрограммы с учетом наложенного на него условия отбора.

Свойство IsEmpty имеет значение True в случае, если в элемент управления не введено никакого значения (элемент управления пустой), в противном случае имеет значение False.

5.9.3.6. Интерфейс IButton
1  IButton = interface(IDispatch)
2    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
3    function Name: WideString; safecall;
4    procedure Click; safecall;
5    property Enabled: WordBool;
6  end;
Моделирует командную кнопку на форме задания параметров. Позволяет управлять поведением кнопки на форме.

Функция Name возвращает имя кнопки.

Процедура Click эмулирует нажатие на кнопку.

Свойство Enabled позволяет получать и устанавливать доступность кнопки.

5.9.3.7. Интерфейс IBinaryData
01  IBinaryData = interface(IDispatch)
02    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
03    procedure Load(const Src: OleVariant);
04    procedure Append(const Src: OleVariant);
05    procedure Save(const Dst: OleVariant);
06    function Size: Cardinal;
07    function ToString(Encoding: WideString): WideString;
08    procedure FromString(Data: OleVariant);
09    procedure AppendString(Data: OleVariant);
10    function ToBase64: WideString;
11    procedure FromBase64(Data: OleVariant);
Представляет набор двоичных данных.

Процедура Load загружает двоичные данные из переданного источника. Источник может быть

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Строкой, содержащей имя файла

Процедура Append добавляет двоичные данные из переданного источника. Источник может быть

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Строкой, содержащей имя файла

Процедура Save сохраняет двоичные данные в переданный приемник. Приемник может быть

Объектом, реализующим интерфейс IStream

Объектом, реализующим интерфейс ISequentialStream

Строкой, содержащей имя файла

Функция ToString переводит данные в строку. Байты, содержашиеся в объекте, будут рассматриваться как содержащие строку в кодировке, заданной параметром Encoding. По умолчанию используется кодировка UTF-8

Процедура FromString загружает данные из строки, переданной в параметре Data, перекодировав ее в кодировку UTF-8

Процедура AppendString добавляет данные из строки, переданной в параметре Data, перекодировав ее в кодировку UTF-8

Функция ToBase64 возвращает строку, полученную путем кодирования в формат Base64, данных содержащихся в объекте

Процедура FromBase64 загружает данные из строки, переданной в параметре Data, раскодировав ее из формата Base64

5.9.3.8. Интерфейс IContextExpressionInfo
1  IContextExpressionInfo = interface(IUnknown)
2    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
3    function Count: Integer;
4    function ItemName(Index: Integer): WideString;
5    function ItemValue(Index: Integer): OleVariant;
6    function ItemDomain(Index: Integer): OleVariant;
7  end;
Через реализацию этого интерфейса передаются значения контекстных переменных при обращении к функции selectValue интерфейса IContext.

Функция Count возвращает количество используемых контекстных переменных. Нумерация контекстных переменных начинается с нуля.

Функция ItemName возвращает имя контекстной переменной c номером, переданным в параметре Index.

Функция ItemValue возвращает значение контекстной переменной c номером, переданным в параметре Index.

Функция ItemDomain возвращает имя домена контекстной переменной c номером, переданным в параметре Index.

5.9.3.9. Интерфейс IExceptionHandler
1  IExceptionHandler = interface(IDispatch)
2    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
3    procedure HandleException(ContextObject: OleVariant;
4      const Message: WideString;
5      const ExtentedInfo: WideString);
6  end;
Реализовав интерфейс IExceptionHandler разработчик решений может получать уведомления о возникающих при работе исключительных ситуациях. При возникновении исключения объект, реализующий интерфейс, получит текст сообщения об ошибке и расширенную информацию.

Для реализации интерфеса используется библиотека hse.tlb, входящая в состав поставки решения. Перед началом работы с ней, необходимо зарегистрировать ее в операционной системе.

Для установки настроек интерфейса необходимо открыть Системную форму раздела АДМИНИСТРАТОРУ, перейти на вкладку Настройки и в столбце "Заголовок закладки" установить фильтр "Обработка ошибок".

После этого в качестве значения Идентификатора класса установить "IExceptionHandler" без кавычек.

Для Библиотеки кода указать значение HSE.tlb

5.9.3.10. Справочник по интерфейсам

5.9.3.10.1. Перечисление TQueryPart
1type
2  TQueryPart = (qpWhat, qpWhere, qpOrder, qpGroup, qpHaving, qpInnerJoin,
3    qpOuterJoin);
Или
01type
02  TQueryPart = TOleEnum;
03const
04  qpWhat = $00000000;
05  qpWhere = $00000001;
06  qpOrder = $00000002;
07  qpGroup = $00000003;
08  qpHaving = $00000004;
09  qpInnerJoin = $00000005;
10  qpOuterJoin = $00000006;
Элементы перечисления:

Имя

Значение

Назначение

qpWhat

0

qpWhere

1

qpOrder

2

qpGroup

3

qpHaving

4

qpInnerJoin

5

qpOuterJoin

6

5.9.3.10.2. Перечисление TQuerySpecial
1type
2  TQuerySpecial = (qsNone, qsObjectID, qsParentID, qsHasChildren,
3    qsFilterCondition, qsUplink, qsRootOnly, qsDescending, qsCount, qsSum, qsMin,
4    qsMax, qsAverage, qsMasterLink, qsSelectedOnly, qsDistinct, qsViewCondition,
5    qsCaseInsensitive, qsAsString, qsListed, qsName, qsDescription, qsFunction,
6    qsCountDistinct, qsBoolean, qsExact, qsSearchIndex, qsOptimizationParameters);
Или
01type
02  TQuerySpecial = TOleEnum;
03const
04  qsNone = $00000000;
05  qsObjectID = $00000001;
06  qsParentID = $00000002;
07  qsHasChildren = $00000003;
08  qsFilterCondition = $00000004;
09  qsUplink = $00000005;
10  qsRootOnly = $00000006;
11  qsDescending = $00000007;
12  qsCount = $00000008;
13  qsSum = $00000009;
14  qsMin = $0000000A;
15  qsMax = $0000000B;
16  qsAverage = $0000000C;
17  qsMasterLink = $0000000D;
18  qsSelectedOnly = $0000000E;
19  qsDistinct = $0000000F;
20  qsViewCondition = $00000010;
21  qsCaseInsensitive = $00000011;
22  qsAsString = $00000012;
23  qsListed = $00000013;
24  qsName = $00000014;
25  qsDescription = $00000015;
26  qsFunction = $00000016;
27  qsCountDistinct = $00000017;
28  qsBoolean = $00000018;
29  qsExact = $00000019;
30  qsSearchIndex = $0000001A;
31  qsOptimizationParameters = $0000001B;
Элементы перечисления:

Имя

Значение

Назначение

qsNone

0

qsObjectID

1

qsParentID

2

qsHasChildren

3

qsFilterCondition

4

qsUplink

5

qsRootOnly

6

qsDescending

7

qsCount

8

qsSum

9

qsMin

10

qsMax

11

qsAverage

12

qsMasterLink

13

qsSelectedOnly

14

qsDistinct

15

qsViewCondition

16

qsCaseInsensitive

17

qsAsString

18

qsListed

19

qsName

20

qsDescription

21

qsFunction

22

qsCountDistinct

23

qsBoolean

24

qsExact

25

qsSearchIndex

26

qsOptimizationParameters

27

5.9.3.10.3. Интерфейс IButton
1type
2  IButton = interface(IDispatch)
3    ['{1618406F-B9F1-4C5F-BC35-C2A154837CA9}']
4    function Get_Enabled: WordBool; safecall;
5    procedure Set_Enabled(Value: WordBool); safecall;
6    function Name: WideString; safecall;
7    procedure Click; safecall;
8    property Enabled: WordBool read Get_Enabled write Set_Enabled;
9  end;
5.9.3.10.3.1. Свойства

Свойства интерфейса IButton:

Имя

Тип

Доступ

Назначение

Enabled

WordBool

Чтение/Запись

5.9.3.10.3.2. Метод Click

Метод интерфейса IButton.
procedure IButton.Click;
Метод не имеет параметров.

5.9.3.10.3.3. Метод Name

Метод интерфейса IButton.
function IButton.Name: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4. Интерфейс IContext
001type
002  IContext = interface(IDispatch)
003    ['{79847D79-A3BE-408F-B59F-662B91BC6350}']
004    function Get_ContextObject: IDispatch; safecall;
005    function Get_UserName: WideString; safecall;
006    function Get_NegotiateAuth: WordBool; safecall;
007    function Get_Language: WideString; safecall;
008    procedure Set_Language(Value: WideString); safecall;
009    function Get_TimeBias: Double; safecall;
010    function getName(ID: OleVariant): WideString; safecall;
011    function getDescription(ID: OleVariant): WideString; safecall;
012    function getPropValue(const ClassName: WideString; const PropName: WideString;
013      ID: OleVariant): OleVariant; safecall;
014    procedure setPropValue(const ClassName: WideString; const PropName: WideString;
015      ID: OleVariant; Value: OleVariant); safecall;
016    procedure getPropValues(const ClassName: WideString;
017      const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
018      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
019    procedure setPropValues(const ClassName: WideString;
020      const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
021      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
022    function createDataSet(const TargetClassName: WideString): IContextDataSet; safecall;
023    function select(const ClassName: WideString; QueryItems: OleVariant): IDispatch; safecall;
024    function executeMethod(const ClassName: WideString;
025      const MethodName: WideString; Params: OleVariant): OleVariant; safecall;
026    function getClass(const ClassName: WideString): WideString; safecall;
027    function enumerationItem(ItemIdentifier: OleVariant): WideString; safecall;
028    function getResource(const Name: WideString): WideString; safecall;
029    function bulkInsert(const ClassName: WideString;
030      const Data: IDispatch): IContextDataSet; safecall;
031    function PreProcessScript(const Script: WideString; Indent: WordBool;
032      const CommentMark: WideString): WideString; safecall;
033    function executeReport(const ClassName: WideString;
034      const TemplateName: WideString; Params: OleVariant): IDispatch; safecall;
035    procedure saveReport(const ClassName: WideString;
036      const TemplateName: WideString; Params: OleVariant; const FileName: WideString); safecall;
037    function Get_Variable(const Name: WideString; Persistent: WordBool): OleVariant; safecall;
038    procedure Set_Variable(const Name: WideString; Persistent: WordBool;
039      Value: OleVariant); safecall;
040    function DebugString(const Message: WideString): WideString; safecall;
041    procedure raiseManagedException(const ExceptionMessage: WideString); safecall;
042    function createGUID: WideString; safecall;
043    function getTempFileName(const Extension: WideString): WideString; safecall;
044    function HasUI: WordBool; safecall;
045    function Handle: Integer; safecall;
046    procedure processStart(const Description: WideString; ItemCount: Integer;
047      CanAbort: WordBool); safecall;
048    function processStep: WordBool; safecall;
049    procedure processStop; safecall;
050    procedure Sleep(MSecs: Integer); safecall;
051    function executeConsoleProcess(const CommandLine: WideString;
052      MaxDuration: Integer; const OutputData: OleVariant): Integer; safecall;
053    function downloadData(const Host: WideString; const Url: WideString;
054      const UserName: WideString; const Password: WideString;
055      NegotiateAuth: WordBool; PostData: OleVariant;
056      const PostContentType: WideString; PostDataIsBinary: WordBool;
057      CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant; safecall;
058    function LineBreak: WideString; safecall;
059    function Transliterate(const Value: WideString): WideString; safecall;
060    procedure CompareLists(var List1: OleVariant; var List2: OleVariant;
061      const Delimiter: WideString; CaseSensitive: WordBool); safecall;
062    function parseJSON(const JSON: WideString): WideString; safecall;
063    function ConvertExcel(Source: OleVariant; const Format: WideString): IDispatch; safecall;
064    function createBinaryData: IDispatch; safecall;
065    function getCRC(Data: OleVariant): WideString; safecall;
066    function buildNamedFile(const Data: IDispatch;
067      const StoredFileName: WideString; Propmpt: WordBool;
068      Compress: WordBool): IDispatch; safecall;
069    procedure parseNamedFile(NamedFile: OleVariant; out FileName: OleVariant;
070      out Data: OleVariant); safecall;
071    function createRaster: IDispatch; safecall;
072    function BinaryToBitmap(const Data: IDispatch): IDispatch; safecall;
073    function getOleObject(const ClassID: WideString;
074      const AccessibleFileName: WideString): IDispatch; safecall;
075    function PlaceDataSet(const Range: IDispatch; const DataSet: IContextDataSet;
076      ShiftRows: WordBool; ShiftColumns: WordBool): Integer; safecall;
077    procedure ExportObject(var Document: OleVariant; const ID: WideString;
078      const ClassID: WideString); safecall;
079    function createZIPArchive: IDispatch; safecall;
080    function callRoutine(const ClassName: WideString;
081      const RoutineName: WideString; var RetValue: OleVariant;
082      const ScriptPart: OleVariant): WordBool; safecall;
083    function selectVaue(const ClassDomain: WideString;
084      const ExpressionContext: IUnknown; var Value: OleVariant): WordBool; safecall;
085    function editValues(const ValuesList: WideString; const Title: WideString;
086      UseTabs: WordBool; HideOKButton: WordBool;
087      const ScriptPart: OleVariant): WordBool; safecall;
088    function MsgBox(const Prompt: WideString; Buttons: LongWord;
089      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
090    function ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
091      const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer; safecall;
092    procedure showView(const ViewName: WideString; Key: OleVariant;
093      const DetailPropertyName: WideString); safecall;
094    procedure showDataSet(const DataSet: ContextDataSet; const Caption: WideString;
095      ColumnCaptions: OleVariant; ColumnOnChangeHandlers: OleVariant;
096      TakeActionsFromView: OleVariant); safecall;
097    procedure SaveExternalDataToFolder(const Resource: WideString;
098      const Folder: WideString); safecall;
099    function PerformAsyncTask(ID: OleVariant): WordBool; safecall;
100    procedure RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
101      ThreadCount: Integer); safecall;
102    function MainHandle: Integer; safecall;
103    function IsHTMLDocumentSafe(const HTML: WideString): WordBool; safecall;
104    function EnsafeHTMLDocument(const HTML: WideString; RemoveHead: WordBool;
105      Format: WordBool; PureXML: WordBool): WideString; safecall;
106    property ContextObject: IDispatch read Get_ContextObject;
107    property UserName: WideString read Get_UserName;
108    property NegotiateAuth: WordBool read Get_NegotiateAuth;
109    property Language: WideString read Get_Language write Set_Language;
110    property TimeBias: Double read Get_TimeBias;
111    property Variable[const Name: WideString; Persistent: WordBool]: OleVariant
112      read Get_Variable write Set_Variable;
113  end;
5.9.3.10.4.1. Свойства

Свойства интерфейса IContext:

Имя

Тип

Доступ

Назначение

ContextObject

IDispatch

Только для чтения

Language

WideString

Чтение/Запись

NegotiateAuth

WordBool

Только для чтения

TimeBias

Double

Только для чтения

UserName

WideString

Только для чтения

Variable[const Name: WideString, Persistent: WordBool]

OleVariant

Чтение/Запись

5.9.3.10.4.2. Метод BinaryToBitmap

Метод интерфейса IContext.
function IContext.BinaryToBitmap(const Data: IDispatch): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Data

IDispatch

Да

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.4.3. Метод buildNamedFile

Метод интерфейса IContext.
1function IContext.buildNamedFile(const Data: IDispatch;
2  const StoredFileName: WideString; Propmpt: WordBool;
3  Compress: WordBool): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Data

IDispatch

Да

StoredFileName

WideString

Да

Propmpt

WordBool

Да

Compress

WordBool

Да

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.4.4. Метод bulkInsert

Метод интерфейса IContext.
1function IContext.bulkInsert(const ClassName: WideString;
2  const Data: IDispatch): IContextDataSet;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

Data

IDispatch

Да

Замечания:

Возвращает значение типа IContextDataSet.

5.9.3.10.4.5. Метод callRoutine

Метод интерфейса IContext.
1function IContext.callRoutine(const ClassName: WideString;
2  const RoutineName: WideString; var RetValue: OleVariant;
3  const ScriptPart: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

RoutineName

WideString

Да

RetValue

OleVariant

Нет

ScriptPart

OleVariant

Нет

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.4.6. Метод CompareLists

Метод интерфейса IContext.
1procedure IContext.CompareLists(var List1: OleVariant; var List2: OleVariant;
2  const Delimiter: WideString; CaseSensitive: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

List1

OleVariant

Да

List2

OleVariant

Да

Delimiter

WideString

Да

CaseSensitive

WordBool

Да

5.9.3.10.4.7. Метод ConvertExcel

Метод интерфейса IContext.
1function IContext.ConvertExcel(Source: OleVariant;
2  const Format: WideString): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Source

OleVariant

Да

Format

WideString

Да

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.4.8. Метод createBinaryData

Метод интерфейса IContext.
function IContext.createBinaryData: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.4.9. Метод createDataSet

Метод интерфейса IContext.
function IContext.createDataSet(const TargetClassName: WideString): IContextDataSet;
Параметры:

Имя

Тип

Обязательно

Значение

TargetClassName

WideString

Да

Замечания:

Возвращает значение типа IContextDataSet.

5.9.3.10.4.10. Метод createGUID

Метод интерфейса IContext.
function IContext.createGUID: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.11. Метод createRaster

Метод интерфейса IContext.
function IContext.createRaster: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.4.12. Метод createZIPArchive

Метод интерфейса IContext.
function IContext.createZIPArchive: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.4.13. Метод DebugString

Метод интерфейса IContext.
function IContext.DebugString(const Message: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Message

WideString

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.14. Метод downloadData

Метод интерфейса IContext.
1function IContext.downloadData(const Host: WideString; const Url: WideString;
2  const UserName: WideString; const Password: WideString;
3  NegotiateAuth: WordBool; PostData: OleVariant;
4  const PostContentType: WideString; PostDataIsBinary: WordBool;
5  CanCache: WordBool; NewSession: WordBool; TimeOut: Integer): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

Host

WideString

Да

Url

WideString

Да

UserName

WideString

Да

Password

WideString

Да

NegotiateAuth

WordBool

Да

PostData

OleVariant

Да

PostContentType

WideString

Да

PostDataIsBinary

WordBool

Да

CanCache

WordBool

Да

NewSession

WordBool

Да

TimeOut

Integer

Да

Замечания:

Возвращает значение типа OleVariant.

5.9.3.10.4.15. Метод editValues

Метод интерфейса IContext.
1function IContext.editValues(const ValuesList: WideString;
2  const Title: WideString; UseTabs: WordBool; HideOKButton: WordBool;
3  const ScriptPart: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ValuesList

WideString

Да

Title

WideString

Да

UseTabs

WordBool

Да

HideOKButton

WordBool

Да

ScriptPart

OleVariant

Нет

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.4.16. Метод EnsafeHTMLDocument

Метод интерфейса IContext.
1function IContext.EnsafeHTMLDocument(const HTML: WideString;
2  RemoveHead: WordBool; Format: WordBool; PureXML: WordBool): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

HTML

WideString

Да

RemoveHead

WordBool

Да

Format

WordBool

Да

PureXML

WordBool

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.17. Метод enumerationItem

Метод интерфейса IContext.
function IContext.enumerationItem(ItemIdentifier: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ItemIdentifier

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.18. Метод executeConsoleProcess

Метод интерфейса IContext.
1function IContext.executeConsoleProcess(const CommandLine: WideString;
2  MaxDuration: Integer; const OutputData: OleVariant): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

CommandLine

WideString

Да

MaxDuration

Integer

Да

OutputData

OleVariant

Да

Замечания:

Возвращает значение типа Integer.

5.9.3.10.4.19. Метод executeMethod

Метод интерфейса IContext.
1function IContext.executeMethod(const ClassName: WideString;
2  const MethodName: WideString; Params: OleVariant): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

MethodName

WideString

Да

Params

OleVariant

Да

Замечания:

Возвращает значение типа OleVariant.

5.9.3.10.4.20. Метод executeReport

Метод интерфейса IContext.
1function IContext.executeReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

TemplateName

WideString

Да

Params

OleVariant

Да

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.4.21. Метод ExportObject

Метод интерфейса IContext.
1procedure IContext.ExportObject(var Document: OleVariant; const ID: WideString;
2  const ClassID: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Document

OleVariant

Да

ID

WideString

Да

ClassID

WideString

Да

5.9.3.10.4.22. Метод getClass

Метод интерфейса IContext.
function IContext.getClass(const ClassName: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.23. Метод getCRC

Метод интерфейса IContext.
function IContext.getCRC(Data: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.24. Метод getDescription

Метод интерфейса IContext.
function IContext.getDescription(ID: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ID

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.25. Метод getName

Метод интерфейса IContext.
function IContext.getName(ID: OleVariant): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

ID

OleVariant

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.26. Метод getOleObject

Метод интерфейса IContext.
1function IContext.getOleObject(const ClassID: WideString;
2  const AccessibleFileName: WideString): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

ClassID

WideString

Да

AccessibleFileName

WideString

Да

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.4.27. Метод getPropValue

Метод интерфейса IContext.
1function IContext.getPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

ID

OleVariant

Да

Замечания:

Возвращает значение типа OleVariant.

5.9.3.10.4.28. Метод getPropValues

Метод интерфейса IContext.
1procedure IContext.getPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

IDS

OleVariant

Да

OnValueEvent

OleVariant

Да

ThreadCount

Integer

Да

ThreadSafe

WordBool

Да

5.9.3.10.4.29. Метод getResource

Метод интерфейса IContext.
function IContext.getResource(const Name: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.30. Метод getTempFileName

Метод интерфейса IContext.
function IContext.getTempFileName(const Extension: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Extension

WideString

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.31. Метод Handle

Метод интерфейса IContext.
function IContext.Handle: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.3.10.4.32. Метод HasUI

Метод интерфейса IContext.
function IContext.HasUI: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.4.33. Метод IsHTMLDocumentSafe

Метод интерфейса IContext.
function IContext.IsHTMLDocumentSafe(const HTML: WideString): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

HTML

WideString

Да

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.4.34. Метод LineBreak

Метод интерфейса IContext.
function IContext.LineBreak: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.35. Метод MainHandle

Метод интерфейса IContext.
function IContext.MainHandle: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.3.10.4.36. Метод MsgBox

Метод интерфейса IContext.
1function IContext.MsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

Prompt

WideString

Да

Buttons

LongWord

Нет

Title

WideString

Нет

HelpFile

WideString

Нет

Context

LongWord

Нет

Замечания:

Возвращает значение типа Integer.

5.9.3.10.4.37. Метод parseJSON

Метод интерфейса IContext.
function IContext.parseJSON(const JSON: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

JSON

WideString

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.38. Метод parseNamedFile

Метод интерфейса IContext.
1procedure IContext.parseNamedFile(NamedFile: OleVariant;
2  out FileName: OleVariant; out Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

NamedFile

OleVariant

Да

FileName

OleVariant

Да

Data

OleVariant

Да

5.9.3.10.4.39. Метод PerformAsyncTask

Метод интерфейса IContext.
function IContext.PerformAsyncTask(ID: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ID

OleVariant

Да

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.4.40. Метод PlaceDataSet

Метод интерфейса IContext.
1function IContext.PlaceDataSet(const Range: IDispatch;
2  const DataSet: IContextDataSet; ShiftRows: WordBool;
3  ShiftColumns: WordBool): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

Range

IDispatch

Да

DataSet

IContextDataSet

Да

ShiftRows

WordBool

Нет

ShiftColumns

WordBool

Нет

Замечания:

Возвращает значение типа Integer.

5.9.3.10.4.41. Метод PreProcessScript

Метод интерфейса IContext.
1function IContext.PreProcessScript(const Script: WideString; Indent: WordBool;
2  const CommentMark: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Script

WideString

Да

Indent

WordBool

Да

CommentMark

WideString

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.4.42. Метод processStart

Метод интерфейса IContext.
1procedure IContext.processStart(const Description: WideString;
2  ItemCount: Integer; CanAbort: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Description

WideString

Да

ItemCount

Integer

Нет

CanAbort

WordBool

Нет

5.9.3.10.4.43. Метод processStep

Метод интерфейса IContext.
function IContext.processStep: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.4.44. Метод processStop

Метод интерфейса IContext.
procedure IContext.processStop;
Метод не имеет параметров.

5.9.3.10.4.45. Метод raiseManagedException

Метод интерфейса IContext.
procedure IContext.raiseManagedException(const ExceptionMessage: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

ExceptionMessage

WideString

Да

5.9.3.10.4.46. Метод RebuildTextIndex

Метод интерфейса IContext.
1procedure IContext.RebuildTextIndex(ClassID: OleVariant; FieldID: OleVariant;
2  ThreadCount: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

ClassID

OleVariant

Да

FieldID

OleVariant

Да

ThreadCount

Integer

Да

5.9.3.10.4.47. Метод SaveExternalDataToFolder

Метод интерфейса IContext.
1procedure IContext.SaveExternalDataToFolder(const Resource: WideString;
2  const Folder: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Resource

WideString

Да

Folder

WideString

Да

5.9.3.10.4.48. Метод saveReport

Метод интерфейса IContext.
1procedure IContext.saveReport(const ClassName: WideString;
2  const TemplateName: WideString; Params: OleVariant; const FileName: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

TemplateName

WideString

Да

Params

OleVariant

Да

FileName

WideString

Да

5.9.3.10.4.49. Метод select

Метод интерфейса IContext.
1function IContext.select(const ClassName: WideString;
2  QueryItems: OleVariant): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

QueryItems

OleVariant

Да

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.4.50. Метод selectVaue

Метод интерфейса IContext.
1function IContext.selectVaue(const ClassDomain: WideString;
2  const ExpressionContext: IUnknown; var Value: OleVariant): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

ClassDomain

WideString

Да

ExpressionContext

IUnknown

Да

Value

OleVariant

Да

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.4.51. Метод setPropValue

Метод интерфейса IContext.
1procedure IContext.setPropValue(const ClassName: WideString;
2  const PropName: WideString; ID: OleVariant; Value: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

ID

OleVariant

Да

Value

OleVariant

Да

5.9.3.10.4.52. Метод setPropValues

Метод интерфейса IContext.
1procedure IContext.setPropValues(const ClassName: WideString;
2  const PropName: WideString; IDS: OleVariant; OnValueNeededEvent: OleVariant;
3  ThreadCount: Integer; ThreadSafe: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

ClassName

WideString

Да

PropName

WideString

Да

IDS

OleVariant

Да

OnValueNeededEvent

OleVariant

Да

ThreadCount

Integer

Да

ThreadSafe

WordBool

Да

5.9.3.10.4.53. Метод showDataSet

Метод интерфейса IContext.
1procedure IContext.showDataSet(const DataSet: ContextDataSet;
2  const Caption: WideString; ColumnCaptions: OleVariant;
3  ColumnOnChangeHandlers: OleVariant; TakeActionsFromView: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

DataSet

ContextDataSet

Да

Caption

WideString

Да

ColumnCaptions

OleVariant

Да

ColumnOnChangeHandlers

OleVariant

Да

TakeActionsFromView

OleVariant

Да

5.9.3.10.4.54. Метод ShowMsgBox

Метод интерфейса IContext.
1function IContext.ShowMsgBox(const Prompt: WideString; Buttons: LongWord;
2  const Title: WideString; const HelpFile: WideString; Context: LongWord): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

Prompt

WideString

Да

Buttons

LongWord

Нет

Title

WideString

Нет

HelpFile

WideString

Нет

Context

LongWord

Нет

Замечания:

Возвращает значение типа Integer.

5.9.3.10.4.55. Метод showView

Метод интерфейса IContext.
1procedure IContext.showView(const ViewName: WideString; Key: OleVariant;
2  const DetailPropertyName: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

ViewName

WideString

Да

Key

OleVariant

Да

DetailPropertyName

WideString

Да

5.9.3.10.4.56. Метод Sleep

Метод интерфейса IContext.
procedure IContext.Sleep(MSecs: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

MSecs

Integer

Да

5.9.3.10.4.57. Метод Transliterate

Метод интерфейса IContext.
function IContext.Transliterate(const Value: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Value

WideString

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.5. Интерфейс IContextDataSet
01type
02  IContextDataSet = interface(IDispatch)
03    ['{466F3AF7-F899-4BC1-869D-1B17DCB86159}']
04    procedure AddQueryItem(Part: TQueryPart; const Name: WideString;
05      Value: OleVariant; Special: TQuerySpecial; Context: OleVariant); safecall;
06    function Eof: WordBool; safecall;
07    function Field(const Name: WideString): OleVariant; safecall;
08    function FieldCount: Integer; safecall;
09    function FieldName(Index: Integer): WideString; safecall;
10    procedure Next; safecall;
11    procedure Split(OnRowEvent: OleVariant; ChunkSize: Integer;
12      ThreadCount: Integer; ThreadSafe: WordBool); safecall;
13    function AsJSON: WideString; safecall;
14    function AsXML: WideString; safecall;
15    function AsBinaryData: IDispatch; safecall;
16  end;
5.9.3.10.5.1. Метод AddQueryItem

Метод интерфейса IContextDataSet.
1procedure IContextDataSet.AddQueryItem(Part: TQueryPart;
2  const Name: WideString; Value: OleVariant; Special: TQuerySpecial;
3  Context: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Part

TQueryPart

Да

Name

WideString

Да

Value

OleVariant

Нет

Special

TQuerySpecial

Нет

Context

OleVariant

Нет

5.9.3.10.5.2. Метод AsBinaryData

Метод интерфейса IContextDataSet.
function IContextDataSet.AsBinaryData: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.5.3. Метод AsJSON

Метод интерфейса IContextDataSet.
function IContextDataSet.AsJSON: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5.9.3.10.5.4. Метод AsXML

Метод интерфейса IContextDataSet.
function IContextDataSet.AsXML: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5.9.3.10.5.5. Метод Eof

Метод интерфейса IContextDataSet.
function IContextDataSet.Eof: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.5.6. Метод Field

Метод интерфейса IContextDataSet.
function IContextDataSet.Field(const Name: WideString): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа OleVariant.

5.9.3.10.5.7. Метод FieldCount

Метод интерфейса IContextDataSet.
function IContextDataSet.FieldCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.3.10.5.8. Метод FieldName

Метод интерфейса IContextDataSet.
function IContextDataSet.FieldName(Index: Integer): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Index

Integer

Да

Замечания:

Возвращает значение типа WideString.

5.9.3.10.5.9. Метод Next

Метод интерфейса IContextDataSet.
procedure IContextDataSet.Next;
Метод не имеет параметров.

5.9.3.10.5.10. Метод Split

Метод интерфейса IContextDataSet.
1procedure IContextDataSet.Split(OnRowEvent: OleVariant; ChunkSize: Integer;
2  ThreadCount: Integer; ThreadSafe: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

OnRowEvent

OleVariant

Да

ChunkSize

Integer

Да

ThreadCount

Integer

Да

ThreadSafe

WordBool

Да

5.9.3.10.6. Интерфейс IContextExpressionInfo
1type
2  IContextExpressionInfo = interface(IUnknown)
3    ['{C7518427-B515-4EB4-B698-88656E6CBF7C}']
4    function LookupExpressionContext(const Identifier: WideString;
5      out DomainID: WideString; out Value: WideString): WordBool; safecall;
6    procedure SerializeExpressionContext(const RootNode: IDispatch); safecall;
7  end;
5.9.3.10.6.1. Метод LookupExpressionContext

Метод интерфейса IContextExpressionInfo.
1function IContextExpressionInfo.LookupExpressionContext(const Identifier: WideString;
2  out DomainID: WideString; out Value: WideString): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

Identifier

WideString

Да

DomainID

WideString

Да

Value

WideString

Да

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.6.2. Метод SerializeExpressionContext

Метод интерфейса IContextExpressionInfo.
procedure IContextExpressionInfo.SerializeExpressionContext(const RootNode: IDispatch);
Параметры:

Имя

Тип

Обязательно

Значение

RootNode

IDispatch

Да

5.9.3.10.7. Интерфейс IControl
01type
02  IControl = interface(IDispatch)
03    ['{0662001F-D3D5-4F28-98AC-9B499F70E856}']
04    function Name: WideString; safecall;
05    function Get_Value: OleVariant; safecall;
06    procedure Set_Value(Value: OleVariant); safecall;
07    function Get_ReadOnly: WordBool; safecall;
08    procedure Set_ReadOnly(Value: WordBool); safecall;
09    function Get_IsValid: WordBool; safecall;
10    procedure Set_IsValid(Value: WordBool); safecall;
11    function Get_IsEmpty: WordBool; safecall;
12    procedure SetHint(const Value: WideString); safecall;
13    procedure RefreshLinkedView; safecall;
14    function Get_Visible: WordBool; safecall;
15    property Value: OleVariant read Get_Value write Set_Value;
16    property ReadOnly: WordBool read Get_ReadOnly write Set_ReadOnly;
17    property IsValid: WordBool read Get_IsValid write Set_IsValid;
18    property IsEmpty: WordBool read Get_IsEmpty;
19    property Visible: WordBool read Get_Visible;
20  end;
5.9.3.10.7.1. Свойства

Свойства интерфейса IControl:

Имя

Тип

Доступ

Назначение

IsEmpty

WordBool

Только для чтения

IsValid

WordBool

Чтение/Запись

ReadOnly

WordBool

Чтение/Запись

Value

OleVariant

Чтение/Запись

Visible

WordBool

Только для чтения

5.9.3.10.7.2. Метод Name

Метод интерфейса IControl.
function IControl.Name: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5.9.3.10.7.3. Метод RefreshLinkedView

Метод интерфейса IControl.
procedure IControl.RefreshLinkedView;
Метод не имеет параметров.

5.9.3.10.7.4. Метод SetHint

Метод интерфейса IControl.
procedure IControl.SetHint(const Value: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Value

WideString

Да

5.9.3.10.8. Интерфейс IExceptionHandler
1type
2  IExceptionHandler = interface(IDispatch)
3    ['{3C3C7202-5ED5-4EB4-9CDD-A929C18CA8BD}']
4    procedure HandleException(ContextObject: OleVariant; const Message: WideString;
5      const ExtentedInfo: WideString; SupportServiceData: OleVariant); safecall;
6  end;
5.9.3.10.8.1. Метод HandleException

Метод интерфейса IExceptionHandler.
1procedure IExceptionHandler.HandleException(ContextObject: OleVariant;
2  const Message: WideString; const ExtentedInfo: WideString;
3  SupportServiceData: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

ContextObject

OleVariant

Да

Message

WideString

Да

ExtentedInfo

WideString

Да

SupportServiceData

OleVariant

Да

5.9.3.10.9. Интерфейс IExternalContext
1type
2  IExternalContext = interface(IDispatch)
3    ['{EA2F1CDA-53F6-40E9-A2B7-0A80AB84D177}']
4    procedure Connect(const Database: WideString); safecall;
5  end;
5.9.3.10.9.1. Метод Connect

Метод интерфейса IExternalContext.
procedure IExternalContext.Connect(const Database: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Database

WideString

Да

5.9.3.10.10. Интерфейс IFormContext
01type
02  IFormContext = interface(IDispatch)
03    ['{1944F1C8-CAEA-4CF9-9A4D-CE3423508FF7}']
04    function ID: WideString; safecall;
05    function RoutineID: WideString; safecall;
06    function ControlCount: Integer; safecall;
07    function Get_Controls(Name: OleVariant): IControl; safecall;
08    function ControlExists(const Name: WideString): WordBool; safecall;
09    function ButtonCount: Integer; safecall;
10    function Get_Buttons(Name: OleVariant): IButton; safecall;
11    function Get_Enabled: WordBool; safecall;
12    procedure Set_Enabled(Value: WordBool); safecall;
13    function ChangedControl: OleVariant; safecall;
14    function ChangedControlName: WideString; safecall;
15    procedure Cancel; safecall;
16    function ParentForm: OleVariant; safecall;
17    procedure PreInitControl(const Name: WideString; Value: OleVariant); safecall;
18    procedure NavigatorNext; safecall;
19    procedure NavigatorPrevious; safecall;
20    function NavigatorCanNext: WordBool; safecall;
21    function NavigatorCanPrevious: WordBool; safecall;
22    procedure RefreshView(RefreshAll: WordBool); safecall;
23    function ExpressionContextValue(const Name: WideString): OleVariant; safecall;
24    property Controls[Name: OleVariant]: IControl read Get_Controls;
25    property Buttons[Name: OleVariant]: IButton read Get_Buttons;
26    property Enabled: WordBool read Get_Enabled write Set_Enabled;
27  end;
5.9.3.10.10.1. Свойства

Свойства интерфейса IFormContext:

Имя

Тип

Доступ

Назначение

Buttons[Name: OleVariant]

IButton

Только для чтения

Controls[Name: OleVariant]

IControl

Только для чтения

Enabled

WordBool

Чтение/Запись

5.9.3.10.10.2. Метод ButtonCount

Метод интерфейса IFormContext.
function IFormContext.ButtonCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.3.10.10.3. Метод Cancel

Метод интерфейса IFormContext.
procedure IFormContext.Cancel;
Метод не имеет параметров.

5.9.3.10.10.4. Метод ChangedControl

Метод интерфейса IFormContext.
function IFormContext.ChangedControl: OleVariant;
Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

5.9.3.10.10.5. Метод ChangedControlName

Метод интерфейса IFormContext.
function IFormContext.ChangedControlName: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5.9.3.10.10.6. Метод ControlCount

Метод интерфейса IFormContext.
function IFormContext.ControlCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.3.10.10.7. Метод ControlExists

Метод интерфейса IFormContext.
function IFormContext.ControlExists(const Name: WideString): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.10.8. Метод ExpressionContextValue

Метод интерфейса IFormContext.
function IFormContext.ExpressionContextValue(const Name: WideString): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Замечания:

Возвращает значение типа OleVariant.

5.9.3.10.10.9. Метод ID

Метод интерфейса IFormContext.
function IFormContext.ID: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5.9.3.10.10.10. Метод NavigatorCanNext

Метод интерфейса IFormContext.
function IFormContext.NavigatorCanNext: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.10.11. Метод NavigatorCanPrevious

Метод интерфейса IFormContext.
function IFormContext.NavigatorCanPrevious: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

5.9.3.10.10.12. Метод NavigatorNext

Метод интерфейса IFormContext.
procedure IFormContext.NavigatorNext;
Метод не имеет параметров.

5.9.3.10.10.13. Метод NavigatorPrevious

Метод интерфейса IFormContext.
procedure IFormContext.NavigatorPrevious;
Метод не имеет параметров.

5.9.3.10.10.14. Метод ParentForm

Метод интерфейса IFormContext.
function IFormContext.ParentForm: OleVariant;
Метод не имеет параметров.

Замечания:

Возвращает значение типа OleVariant.

5.9.3.10.10.15. Метод PreInitControl

Метод интерфейса IFormContext.
procedure IFormContext.PreInitControl(const Name: WideString; Value: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Name

WideString

Да

Value

OleVariant

Да

5.9.3.10.10.16. Метод RefreshView

Метод интерфейса IFormContext.
procedure IFormContext.RefreshView(RefreshAll: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

RefreshAll

WordBool

Да

5.9.3.10.10.17. Метод RoutineID

Метод интерфейса IFormContext.
function IFormContext.RoutineID: WideString;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WideString.

5.9.3.10.11. Интерфейс IRaster
01type
02  IRaster = interface(IDispatch)
03    ['{4F27D016-03C2-4D48-ABF7-FD547E859F79}']
04    function Get_Width: Integer; safecall;
05    procedure Set_Width(Value: Integer); safecall;
06    function Get_Height: Integer; safecall;
07    procedure Set_Height(Value: Integer); safecall;
08    function Get_DefaultColor: Integer; safecall;
09    procedure Set_DefaultColor(Value: Integer); safecall;
10    procedure Load(Src: OleVariant); safecall;
11    procedure SaveBitmap(Dst: OleVariant); safecall;
12    procedure SavePNG(Dst: OleVariant); safecall;
13    procedure SaveJPG(Dst: OleVariant; Quality: Integer); safecall;
14    procedure FlipVertical; safecall;
15    procedure FlipHorizontal; safecall;
16    procedure Rotate; safecall;
17    procedure Resize(NewWidth: Integer; NewHeight: Integer; Center: WordBool); safecall;
18    procedure Stretch(NewWidth: Integer; NewHeight: Integer); safecall;
19    procedure StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
20      MaxSize: OleVariant); safecall;
21    procedure Overlay(Src: OleVariant; X: Integer; Y: Integer; Width: Integer;
22      Height: Integer); safecall;
23    property Width: Integer read Get_Width write Set_Width;
24    property Height: Integer read Get_Height write Set_Height;
25    property DefaultColor: Integer read Get_DefaultColor write Set_DefaultColor;
26  end;
5.9.3.10.11.1. Свойства

Свойства интерфейса IRaster:

Имя

Тип

Доступ

Назначение

DefaultColor

Integer

Чтение/Запись

Height

Integer

Чтение/Запись

Width

Integer

Чтение/Запись

5.9.3.10.11.2. Метод FlipHorizontal

Метод интерфейса IRaster.
procedure IRaster.FlipHorizontal;
Метод не имеет параметров.

5.9.3.10.11.3. Метод FlipVertical

Метод интерфейса IRaster.
procedure IRaster.FlipVertical;
Метод не имеет параметров.

5.9.3.10.11.4. Метод Load

Метод интерфейса IRaster.
procedure IRaster.Load(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

5.9.3.10.11.5. Метод Overlay

Метод интерфейса IRaster.
1procedure IRaster.Overlay(Src: OleVariant; X: Integer; Y: Integer;
2  Width: Integer; Height: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

X

Integer

Да

Y

Integer

Да

Width

Integer

Да

Height

Integer

Да

5.9.3.10.11.6. Метод Resize

Метод интерфейса IRaster.
1procedure IRaster.Resize(NewWidth: Integer; NewHeight: Integer;
2  Center: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

NewWidth

Integer

Да

NewHeight

Integer

Да

Center

WordBool

Да

5.9.3.10.11.7. Метод Rotate

Метод интерфейса IRaster.
procedure IRaster.Rotate;
Метод не имеет параметров.

5.9.3.10.11.8. Метод SaveBitmap

Метод интерфейса IRaster.
procedure IRaster.SaveBitmap(Dst: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

5.9.3.10.11.9. Метод SaveJPG

Метод интерфейса IRaster.
procedure IRaster.SaveJPG(Dst: OleVariant; Quality: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

Quality

Integer

Да

5.9.3.10.11.10. Метод SavePNG

Метод интерфейса IRaster.
procedure IRaster.SavePNG(Dst: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

5.9.3.10.11.11. Метод Stretch

Метод интерфейса IRaster.
procedure IRaster.Stretch(NewWidth: Integer; NewHeight: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

NewWidth

Integer

Да

NewHeight

Integer

Да

5.9.3.10.11.12. Метод StretchToSize

Метод интерфейса IRaster.
1procedure IRaster.StretchToSize(MaxWidth: OleVariant; MaxHeight: OleVariant;
2  MaxSize: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

MaxWidth

OleVariant

Да

MaxHeight

OleVariant

Да

MaxSize

OleVariant

Да

5.9.3.10.12. Интерфейс IScannerTools
1type
2  IScannerTools = interface(IDispatch)
3    ['{FC1B3C9F-7DE9-4909-B57D-6D33E3B0A87A}']
4    function AcquireImage(Silent: WordBool): IDispatch; safecall;
5    function AcquirePDF: IDispatch; safecall;
6  end;
5.9.3.10.12.1. Метод AcquireImage

Метод интерфейса IScannerTools.
function IScannerTools.AcquireImage(Silent: WordBool): IDispatch;
Параметры:

Имя

Тип

Обязательно

Значение

Silent

WordBool

Да

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.12.2. Метод AcquirePDF

Метод интерфейса IScannerTools.
function IScannerTools.AcquirePDF: IDispatch;
Метод не имеет параметров.

Замечания:

Возвращает значение типа IDispatch.

5.9.3.10.13. Интерфейс ISetOfObjectsEditor
1type
2  ISetOfObjectsEditor = interface(IDispatch)
3    ['{6D3662A7-D9FF-4BD6-8D92-A4EA2058C74E}']
4    function Get_DomainName: WideString; safecall;
5    procedure Set_DomainName(Value: WideString); safecall;
6    function Get_SelectedCount: Integer; safecall;
7    property DomainName: WideString read Get_DomainName write Set_DomainName;
8    property SelectedCount: Integer read Get_SelectedCount;
9  end;
5.9.3.10.13.1. Свойства

Свойства интерфейса ISetOfObjectsEditor:

Имя

Тип

Доступ

Назначение

DomainName

WideString

Чтение/Запись

SelectedCount

Integer

Только для чтения

5.9.3.10.14. Интерфейс IZIPArchive
01type
02  IZIPArchive = interface(IDispatch)
03    ['{11C9400F-F262-4F72-882F-5AA5A4531591}']
04    procedure Load(Src: OleVariant); safecall;
05    procedure Save(Src: OleVariant); safecall;
06    function Get_FileCount: Integer; safecall;
07    function Get_FileName(Index: Integer): WideString; safecall;
08    function Get_FileData(Index: Integer): OleVariant; safecall;
09    procedure AddFile(const FileName: WideString; Data: OleVariant); safecall;
10    function Get_FileSize(Index: Integer): Int64; safecall;
11    function Get_FileDateTime(Index: Integer): TDateTime; safecall;
12    function Get_FileCRC(Index: Integer): WideString; safecall;
13    function Get_UTF8Support: WordBool; safecall;
14    procedure Set_UTF8Support(Value: WordBool); safecall;
15    property FileCount: Integer read Get_FileCount;
16    property FileName[Index: Integer]: WideString read Get_FileName;
17    property FileData[Index: Integer]: OleVariant read Get_FileData;
18    property FileSize[Index: Integer]: Int64 read Get_FileSize;
19    property FileDateTime[Index: Integer]: TDateTime read Get_FileDateTime;
20    property FileCRC[Index: Integer]: WideString read Get_FileCRC;
21    property UTF8Support: WordBool read Get_UTF8Support write Set_UTF8Support;
22  end;
5.9.3.10.14.1. Свойства

Свойства интерфейса IZIPArchive:

Имя

Тип

Доступ

Назначение

FileCRC[Index: Integer]

WideString

Только для чтения

FileCount

Integer

Только для чтения

FileData[Index: Integer]

OleVariant

Только для чтения

FileDateTime[Index: Integer]

TDateTime

Только для чтения

FileName[Index: Integer]

WideString

Только для чтения

FileSize[Index: Integer]

Int64

Только для чтения

UTF8Support

WordBool

Чтение/Запись

5.9.3.10.14.2. Метод AddFile

Метод интерфейса IZIPArchive.
procedure IZIPArchive.AddFile(const FileName: WideString; Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

FileName

WideString

Да

Data

OleVariant

Да

5.9.3.10.14.3. Метод Load

Метод интерфейса IZIPArchive.
procedure IZIPArchive.Load(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

5.9.3.10.14.4. Метод Save

Метод интерфейса IZIPArchive.
procedure IZIPArchive.Save(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

5.9.3.11. Дополнительные интерфейсы

5.9.3.11.1. Интерфейс IBinaryData
01type
02  IBinaryData = interface(IDispatch)
03    ['{8A9F7CB3-230A-4048-B938-852CBF6ADB2D}']
04    procedure Append(Src: OleVariant); safecall;
05    procedure Load(Src: OleVariant); safecall;
06    procedure Save(Dst: OleVariant); safecall;
07    function Size: LongWord; safecall;
08    procedure AppendData(Data: OleVariant; DataSize: LongWord); safecall;
09    procedure SetData(Data: OleVariant; DataSize: LongWord); safecall;
10    procedure GetData(Data: OleVariant); safecall;
11    function ToString(const Encoding: WideString): WideString; safecall;
12    procedure FromString(Data: OleVariant); safecall;
13    procedure AppendString(Data: OleVariant); safecall;
14    function ToBase64(Width: Integer): WideString; safecall;
15    procedure FromBase64(Data: OleVariant); safecall;
16    function ContentIsText: WordBool; safecall;
17  end;
5.9.3.11.1.1. Метод Append

Метод интерфейса IBinaryData.
procedure IBinaryData.Append(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

5.9.3.11.1.2. Метод AppendData

Метод интерфейса IBinaryData.
procedure IBinaryData.AppendData(Data: OleVariant; DataSize: LongWord);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

DataSize

LongWord

Да

5.9.3.11.1.3. Метод AppendString

Метод интерфейса IBinaryData.
procedure IBinaryData.AppendString(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

5.9.3.11.1.4. Метод ContentIsText

Метод интерфейса IBinaryData.
function IBinaryData.ContentIsText: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

5.9.3.11.1.5. Метод FromBase64

Метод интерфейса IBinaryData.
procedure IBinaryData.FromBase64(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

5.9.3.11.1.6. Метод FromString

Метод интерфейса IBinaryData.
procedure IBinaryData.FromString(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

5.9.3.11.1.7. Метод GetData

Метод интерфейса IBinaryData.
procedure IBinaryData.GetData(Data: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

5.9.3.11.1.8. Метод Load

Метод интерфейса IBinaryData.
procedure IBinaryData.Load(Src: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Src

OleVariant

Да

5.9.3.11.1.9. Метод Save

Метод интерфейса IBinaryData.
procedure IBinaryData.Save(Dst: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Dst

OleVariant

Да

5.9.3.11.1.10. Метод SetData

Метод интерфейса IBinaryData.
procedure IBinaryData.SetData(Data: OleVariant; DataSize: LongWord);
Параметры:

Имя

Тип

Обязательно

Значение

Data

OleVariant

Да

DataSize

LongWord

Да

5.9.3.11.1.11. Метод Size

Метод интерфейса IBinaryData.
function IBinaryData.Size: LongWord;
Метод не имеет параметров.

Замечания:

Возвращает значение типа LongWord.

5.9.3.11.1.12. Метод ToBase64

Метод интерфейса IBinaryData.
function IBinaryData.ToBase64(Width: Integer): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Width

Integer

Нет

Замечания:

Возвращает значение типа WideString.

5.9.3.11.1.13. Метод ToString

Метод интерфейса IBinaryData.
function IBinaryData.ToString(const Encoding: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Encoding

WideString

Да

Замечания:

Возвращает значение типа WideString.

5.9.4. Справочник по метаданным

5.9.4.1. Перечисление Resource strings (Ресурсные строки)
01type
02  Resource strings = (rssRole, rssUser, rssIsMemberOf,
03    rssRoleCannotBeMemberOfItself, rssRoleCannotHavePrimaryRole, rssCanUse,
04    rssVirtualException, rssDataBaseIdentifierTooLong,
05    rssDefaultConstructorDescription, rssDefaultConstructorActionDescription,
06    rssDefaultDesctructorActionDescription, rssDefaultExcelActionDescription,
07    rssUsersActivityOn, rssHours, rssLocalCharacters, rssCannotLocalizeClass,
08    rssCannotLocalizeField, rssCannotTranslateUntranslatable,
09    rssCannotSendMessageToNotApprovedContact, rssCannotCreateContactForYourself,
10    rssCannotSendMessageForYourself, rssOverwriteFile, rssOverwriteAccessibleFile,
11    rssReplaceCurrentTemplate, rssReplaceAllImages, rssReplaceAllMethods,
12    rssReplaceAllTemplates, rssLoadingProcess, rssDoNotFogetMacroName,
13    rssCheckOleObjectMethodErrorMethodNotSpecified,
14    rssCheckOleObjectMethodErrorClassIDNotSpecified,
15    rssCheckOleObjectMethodErrorCodeLibraryNotSpecified,
16    rssCheckOleObjectMethodErrorCodeLibraryNotFound,
17    rssCheckOleObjectMethodErrorXMLIsNotValid,
18    rssCheckOleObjectMethodErrorProgIDNotImplemented,
19    rssCheckOleObjectMethodErrorMethodNotImplemented,
20    rssCheckOleObjectMethodErrorNoParameters,
21    rssCheckOleObjectMethodErrorNoIDParameter,
22    rssCheckOleObjectMethodErrorParameterNames,
23    rssCheckOleObjectMethodErrorParameterCount, rssLoadingResources, rssMethodCall,
24    rssDMLOperation, rssReplaceAllBlobsContent,
25    rssCheckXSLTTemplateErrorXMLIsNotValid,
26    rssCheckXSLTTemplateErrorNoTemplateData,
27    rssCheckXSLTTemplateErrorNoIDParameter, rssCheckXSLTTemplateErrorNoParameter,
28    rssCheckXSLTTemplateErrorExcessParameter,
29    rssCheckOleObjectMethodErrorNoFunctionFound,
30    rssCheckExcelTemplateErrorNoTemplateData, rssCheckExcelTemplateErrorNoMacro,
31    rssCheckExcelTemplateErrorNoFunctionFound,
32    rssCheckWordTemplateErrorNoTemplateData, rssCheckWordTemplateErrorNoMacro,
33    rssCheckWordTemplateErrorNoFunctionFound, rssCheckTemplates,
34    rssUnexpectedDatabase, rssCannotSaveDatabaseLanguage, rssDomainNotFound,
35    rssCheckOfficeTemplateErrorMissingParameters,
36    rssCheckOfficeTemplateErrorMissingImplementationParameter,
37    rssCheckOfficeTemplateErrorParametersCountMismatched,
38    rssCheckOfficeTemplateErrorNoFunctionFound,
39    rssCheckOfficeTemplateErrorProjectSyntaxIncorrect,
40    rssCheckOfficeTemplateErrorIncludedModuleNotFound,
41    rssCheckOfficeTemplateWarningMethodBodyTooLong,
42    rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped,
43    rssCheckOfficeTemplateWarningOptionValueIncorrect,
44    rssCannotPerformTaskAlreadyRunning, rssCannotPerformTaskDueToStatus,
45    rssAsyncMethodInstantSuccess, rssAsyncMethodInstantError,
46    rssAsyncReportInstantSuccess, rssAsyncReportInstantError,
47    rssViewCannotContainColumns, rssMasterNotDefined, rssAbstractDomain);
Или
01type
02  Resource strings = TOleEnum;
03const
04  rssRole = $00000000;
05  rssUser = $00000001;
06  rssIsMemberOf = $00000002;
07  rssRoleCannotBeMemberOfItself = $00000003;
08  rssRoleCannotHavePrimaryRole = $00000004;
09  rssCanUse = $00000005;
10  rssVirtualException = $00000006;
11  rssDataBaseIdentifierTooLong = $00000007;
12  rssDefaultConstructorDescription = $00000008;
13  rssDefaultConstructorActionDescription = $00000009;
14  rssDefaultDesctructorActionDescription = $0000000A;
15  rssDefaultExcelActionDescription = $0000000B;
16  rssUsersActivityOn = $0000000C;
17  rssHours = $0000000D;
18  rssLocalCharacters = $0000000E;
19  rssCannotLocalizeClass = $0000000F;
20  rssCannotLocalizeField = $00000010;
21  rssCannotTranslateUntranslatable = $00000011;
22  rssCannotSendMessageToNotApprovedContact = $00000012;
23  rssCannotCreateContactForYourself = $00000013;
24  rssCannotSendMessageForYourself = $00000014;
25  rssOverwriteFile = $00000015;
26  rssOverwriteAccessibleFile = $00000016;
27  rssReplaceCurrentTemplate = $00000017;
28  rssReplaceAllImages = $00000018;
29  rssReplaceAllMethods = $00000019;
30  rssReplaceAllTemplates = $0000001A;
31  rssLoadingProcess = $0000001B;
32  rssDoNotFogetMacroName = $0000001C;
33  rssCheckOleObjectMethodErrorMethodNotSpecified = $0000001D;
34  rssCheckOleObjectMethodErrorClassIDNotSpecified = $0000001E;
35  rssCheckOleObjectMethodErrorCodeLibraryNotSpecified = $0000001F;
36  rssCheckOleObjectMethodErrorCodeLibraryNotFound = $00000020;
37  rssCheckOleObjectMethodErrorXMLIsNotValid = $00000021;
38  rssCheckOleObjectMethodErrorProgIDNotImplemented = $00000022;
39  rssCheckOleObjectMethodErrorMethodNotImplemented = $00000023;
40  rssCheckOleObjectMethodErrorNoParameters = $00000024;
41  rssCheckOleObjectMethodErrorNoIDParameter = $00000025;
42  rssCheckOleObjectMethodErrorParameterNames = $00000026;
43  rssCheckOleObjectMethodErrorParameterCount = $00000027;
44  rssLoadingResources = $00000028;
45  rssMethodCall = $00000029;
46  rssDMLOperation = $0000002A;
47  rssReplaceAllBlobsContent = $0000002B;
48  rssCheckXSLTTemplateErrorXMLIsNotValid = $0000002C;
49  rssCheckXSLTTemplateErrorNoTemplateData = $0000002D;
50  rssCheckXSLTTemplateErrorNoIDParameter = $0000002E;
51  rssCheckXSLTTemplateErrorNoParameter = $0000002F;
52  rssCheckXSLTTemplateErrorExcessParameter = $00000030;
53  rssCheckOleObjectMethodErrorNoFunctionFound = $00000031;
54  rssCheckExcelTemplateErrorNoTemplateData = $00000032;
55  rssCheckExcelTemplateErrorNoMacro = $00000033;
56  rssCheckExcelTemplateErrorNoFunctionFound = $00000034;
57  rssCheckWordTemplateErrorNoTemplateData = $00000035;
58  rssCheckWordTemplateErrorNoMacro = $00000036;
59  rssCheckWordTemplateErrorNoFunctionFound = $00000037;
60  rssCheckTemplates = $00000038;
61  rssUnexpectedDatabase = $00000039;
62  rssCannotSaveDatabaseLanguage = $0000003A;
63  rssDomainNotFound = $0000003B;
64  rssCheckOfficeTemplateErrorMissingParameters = $0000003C;
65  rssCheckOfficeTemplateErrorMissingImplementationParameter = $0000003D;
66  rssCheckOfficeTemplateErrorParametersCountMismatched = $0000003E;
67  rssCheckOfficeTemplateErrorNoFunctionFound = $0000003F;
68  rssCheckOfficeTemplateErrorProjectSyntaxIncorrect = $00000040;
69  rssCheckOfficeTemplateErrorIncludedModuleNotFound = $00000041;
70  rssCheckOfficeTemplateWarningMethodBodyTooLong = $00000042;
71  rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped = $00000043;
72  rssCheckOfficeTemplateWarningOptionValueIncorrect = $00000044;
73  rssCannotPerformTaskAlreadyRunning = $00000045;
74  rssCannotPerformTaskDueToStatus = $00000046;
75  rssAsyncMethodInstantSuccess = $00000047;
76  rssAsyncMethodInstantError = $00000048;
77  rssAsyncReportInstantSuccess = $00000049;
78  rssAsyncReportInstantError = $0000004A;
79  rssViewCannotContainColumns = $0000004B;
80  rssMasterNotDefined = $0000004C;
81  rssAbstractDomain = $0000004D;
Элементы перечисления:

Имя

Значение

Назначение

rssRole

0

Роль

rssUser

1

Пользователь

rssIsMemberOf

2

является членом роли

rssRoleCannotBeMemberOfItself

3

Роль не может включать сама себя.

rssRoleCannotHavePrimaryRole

4

Роль не может иметь основную роль.

rssCanUse

5

использует(ют) объект

rssVirtualException

6

Ошибка вызова виртуального метода.

rssDataBaseIdentifierTooLong

7

Длина имени объекта, отображаемого на объект базы данных, не должна превышать 29 символов

rssDefaultConstructorDescription

8

создание

rssDefaultConstructorActionDescription

9

Создать

rssDefaultDesctructorActionDescription

10

Удалить

rssDefaultExcelActionDescription

11

Перенести в Excel

rssUsersActivityOn

12

Активность пользователей за

rssHours

13

Часы

rssLocalCharacters

14

АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯабвгдеёжзийклмнопрстуфхцчшщъыьэюя

rssCannotLocalizeClass

15

Нельзя локализовать класс

rssCannotLocalizeField

16

Нельзя локализовать поле

rssCannotTranslateUntranslatable

17

Нельзя перевести непереводимый элемент.

rssCannotSendMessageToNotApprovedContact

18

Нельзя отправить сообщение неодобренному контакту.

rssCannotCreateContactForYourself

19

Нельзя создать контакт для самого себя.

rssCannotSendMessageForYourself

20

Нельзя отправить сообщение самому себе.

rssOverwriteFile

21

Заменить содержимое файла "%FileName%"?

rssOverwriteAccessibleFile

22

Заменить содержимое доступного файла "%FileName%"?

rssReplaceCurrentTemplate

23

Заменить содержимое шаблона?

rssReplaceAllImages

24

Заменить содержимое всех изображений?

rssReplaceAllMethods

25

Заменить содержимое всех скриптов и тел методов?

rssReplaceAllTemplates

26

Заменить содержимое всех шаблонов всех отчетов?

rssLoadingProcess

27

Загрузка

rssDoNotFogetMacroName

28

Не забудьте установить имя макроса.

rssCheckOleObjectMethodErrorMethodNotSpecified

29

Имя метода не задано

rssCheckOleObjectMethodErrorClassIDNotSpecified

30

Идентификатор класса не задан

rssCheckOleObjectMethodErrorCodeLibraryNotSpecified

31

Библиотека кода не задана

rssCheckOleObjectMethodErrorCodeLibraryNotFound

32

Невозможно загрузить библиотеку кода "%CodeLibrary%"

rssCheckOleObjectMethodErrorXMLIsNotValid

33

Невалидный XML-документ

rssCheckOleObjectMethodErrorProgIDNotImplemented

34

Указанный ProgID "%ProgID%" не реализован в скриптлете

rssCheckOleObjectMethodErrorMethodNotImplemented

35

Метод не реализован

rssCheckOleObjectMethodErrorNoParameters

36

Метод должен объявлять хотя бы один параметр

rssCheckOleObjectMethodErrorNoIDParameter

37

Метод должен объявлять параметр с именем "ID"

rssCheckOleObjectMethodErrorParameterNames

38

Параметр с именем "%RealName%" не соответствует ожидаемому "%ExpectedName%"

rssCheckOleObjectMethodErrorParameterCount

39

Количество параметров "%RealCount%" в объявлении метода не совпадает с ожидаемым "%ExpectedCount%"

rssLoadingResources

40

Загрузка ресурсов

rssMethodCall

41

Вызов метода

rssDMLOperation

42

Операция с данными

rssReplaceAllBlobsContent

43

Заменить содержимое свойства %Class%.%Description% для всех объектов?

rssCheckXSLTTemplateErrorXMLIsNotValid

44

Невалидный XML-документ

rssCheckXSLTTemplateErrorNoTemplateData

45

Данные шаблона отсутствуют

rssCheckXSLTTemplateErrorNoIDParameter

46

Шаблон XSLT как метод экземпляра должен объявлять параметр "ID"

rssCheckXSLTTemplateErrorNoParameter

47

Параметр "%Name%" не найден в шаблоне

rssCheckXSLTTemplateErrorExcessParameter

48

Параметр шаблона "%Name%" не зарегистрирован в метаданных

rssCheckOleObjectMethodErrorNoFunctionFound

49

Подпрограмма, соответствующая макросу, отсутствует в скриптлете

rssCheckExcelTemplateErrorNoTemplateData

50

Данные шаблона отсутствуют

rssCheckExcelTemplateErrorNoMacro

51

Имя макроса не задано

rssCheckExcelTemplateErrorNoFunctionFound

52

Подпрограмма, соответствующая макросу, отсутствует в проекте VBA

rssCheckWordTemplateErrorNoTemplateData

53

Данные шаблона отсутствуют

rssCheckWordTemplateErrorNoMacro

54

Имя макроса не задано

rssCheckWordTemplateErrorNoFunctionFound

55

Подпрограмма, соответствующая макросу, отсутствует в проекте VBA

rssCheckTemplates

56

Проверка шаблонов

rssUnexpectedDatabase

57

Не поддерживается в этой БД

rssCannotSaveDatabaseLanguage

58

Язык базы данных не может быть сохранен в ресурсный файл.

rssDomainNotFound

59

Домен не найден

rssCheckOfficeTemplateErrorMissingParameters

60

Параметры, не найденные в реализации:

rssCheckOfficeTemplateErrorMissingImplementationParameter

61

Параметр %ParamName% не найден в реализации

rssCheckOfficeTemplateErrorParametersCountMismatched

62

Декларированное и реализованное количество параметров не соответствуют: %DeclaredCount% <> %ImplementedCount%

rssCheckOfficeTemplateErrorNoFunctionFound

63

Указанный макрос %MacroName% не найден

rssCheckOfficeTemplateErrorProjectSyntaxIncorrect

64

VBA проект синтаксически некорректный

rssCheckOfficeTemplateErrorIncludedModuleNotFound

65

Модуль кода %ModuleFileName% (в шаблоне %LinesCount% строк) не найден в Доступных файлах

rssCheckOfficeTemplateWarningMethodBodyTooLong

66

Возможно, тело метода %ProcName% (%ModuleFileName%) чрезмерно длинное (%ProcLineCount% строк)

rssCheckOfficeTemplateWarningVBASyntaxCheckSkiped

67

Синтаксическая проверка проектов VBA не будет произведена, т.к. значение следующих настроек не удовлетворяют требуемым:

rssCheckOfficeTemplateWarningOptionValueIncorrect

68

Неверное значение VBA настройки "%OptionName%" - Включено

rssCannotPerformTaskAlreadyRunning

69

Выполнение невозможно, задача уже выполняется

rssCannotPerformTaskDueToStatus

70

Выполнение невозможно, задача имеет недопустимое состояние

rssAsyncMethodInstantSuccess

71

Метод выполнен

rssAsyncMethodInstantError

72

Ошибка выполнения метода

rssAsyncReportInstantSuccess

73

Отчет сформирован

rssAsyncReportInstantError

74

Ошибка выполнения отчета

rssViewCannotContainColumns

75

Это представление не может содержать колонки.

rssMasterNotDefined

76

Не задан мастер для объекта %Name% (%Description%) класса "%Class%".

rssAbstractDomain

77

Абстрактный домен

5.9.4.2. Перечисление TAggregateKind (Тип агрегата)
1type
2  TAggregateKind = (agCount = 1, agSumm = 2, agMax = 3, agMin = 4, agAverage = 5,
3    agCountDistinct = 6);
Или
1type
2  TAggregateKind = TOleEnum;
3const
4  agCount = $00000001;
5  agSumm = $00000002;
6  agMax = $00000003;
7  agMin = $00000004;
8  agAverage = $00000005;
9  agCountDistinct = $00000006;
Элементы перечисления:

Имя

Значение

Назначение

agCount

1

Количество

agSumm

2

Сумма

agMax

3

Максимальное значение

agMin

4

Минимальное значение

agAverage

5

Среднее значение

agCountDistinct

6

Количество уникальных

5.9.4.3. Перечисление TAsyncTaskStatus (Состояние задачи отложенного выполнения)
1type
2  TAsyncTaskStatus = (astCreated, astReady, astRunning, astSuccess, astError);
Или
1type
2  TAsyncTaskStatus = TOleEnum;
3const
4  astCreated = $00000000;
5  astReady = $00000001;
6  astRunning = $00000002;
7  astSuccess = $00000003;
8  astError = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

astCreated

0

Создано

astReady

1

Готово к выполнению

astRunning

2

Выполняется

astSuccess

3

Завершено

astError

4

Прервано

5.9.4.4. Перечисление TBlobSubtype (Подтип)
1type
2  TBlobSubtype = (btBinaryData, btText, btImage, btSourceCode, btXML,
3    btNamedFile, btVisualBasicScript, btXHTML, btJavaScript, btHTML);
Или
01type
02  TBlobSubtype = TOleEnum;
03const
04  btBinaryData = $00000000;
05  btText = $00000001;
06  btImage = $00000002;
07  btSourceCode = $00000003;
08  btXML = $00000004;
09  btNamedFile = $00000005;
10  btVisualBasicScript = $00000006;
11  btXHTML = $00000007;
12  btJavaScript = $00000008;
13  btHTML = $00000009;
Элементы перечисления:

Имя

Значение

Назначение

btBinaryData

0

Двоичные данные

btText

1

Текст

btImage

2

Изображение

btSourceCode

3

Исходный код

btXML

4

XML-документ

btNamedFile

5

Именованный файл

btVisualBasicScript

6

Скрипт Visual Basic

btXHTML

7

XHTML-документ

btJavaScript

8

Скрипт JavaScript

btHTML

9

HTML-документ

5.9.4.5. Перечисление TChangeAction (Действие при изменении)
1type
2  TChangeAction = (atCreated, atChanging, atChanged, atDestroying, atPasted);
Или
1type
2  TChangeAction = TOleEnum;
3const
4  atCreated = $00000000;
5  atChanging = $00000001;
6  atChanged = $00000002;
7  atDestroying = $00000003;
8  atPasted = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

atCreated

0

Создан

atChanging

1

Изменится

atChanged

2

Изменен

atDestroying

3

Удаляется

atPasted

4

Вставлен из буфера

5.9.4.6. Перечисление TComparisonType (Типы сравнения)
1type
2  TComparisonType = (ctEqual, ctNotEqual, ctGreater, ctGreaterOrEqual, ctLess,
3    ctLessOrEqual, ctLike, ctNotLike, ctRegexpLike, ctNotRegexpLike, ctIsParent,
4    ctIsChild);
Или
01type
02  TComparisonType = TOleEnum;
03const
04  ctEqual = $00000000;
05  ctNotEqual = $00000001;
06  ctGreater = $00000002;
07  ctGreaterOrEqual = $00000003;
08  ctLess = $00000004;
09  ctLessOrEqual = $00000005;
10  ctLike = $00000006;
11  ctNotLike = $00000007;
12  ctRegexpLike = $00000008;
13  ctNotRegexpLike = $00000009;
14  ctIsParent = $0000000A;
15  ctIsChild = $0000000B;
Элементы перечисления:

Имя

Значение

Назначение

ctEqual

0

Равно

ctNotEqual

1

Не равно

ctGreater

2

Больше

ctGreaterOrEqual

3

Больше или равно

ctLess

4

Меньше

ctLessOrEqual

5

Меньше или равно

ctLike

6

Подобно

ctNotLike

7

Не подобно

ctRegexpLike

8

Удовлетворяет регулярному выражению

ctNotRegexpLike

9

Не удовлетворяет регулярному выражению

ctIsParent

10

Является родителем

ctIsChild

11

Является потомком

5.9.4.7. Перечисление TDateTimePart (Часть даты или времени)
1type
2  TDateTimePart = (dpYear, dpMonth, dpDay, dpHour, dpMinute, dpSecond,
3    dpDayOfWeek);
Или
01type
02  TDateTimePart = TOleEnum;
03const
04  dpYear = $00000000;
05  dpMonth = $00000001;
06  dpDay = $00000002;
07  dpHour = $00000003;
08  dpMinute = $00000004;
09  dpSecond = $00000005;
10  dpDayOfWeek = $00000006;
Элементы перечисления:

Имя

Значение

Назначение

dpYear

0

Год

dpMonth

1

Месяц

dpDay

2

День

dpHour

3

Час

dpMinute

4

Минута

dpSecond

5

Секунда

dpDayOfWeek

6

День недели

5.9.4.8. Перечисление TDeleteRule (Правило удаления)
1type
2  TDeleteRule = (drRestrict, drCascade, drSetNull);
Или
1type
2  TDeleteRule = TOleEnum;
3const
4  drRestrict = $00000000;
5  drCascade = $00000001;
6  drSetNull = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

drRestrict

0

Нет правила

drCascade

1

Каскадное удаление

drSetNull

2

Очистить ссылку

5.9.4.9. Перечисление TDuplicates (Дубликаты)
1type
2  TDuplicates = (dupIgnore, dupAccept, dupError);
Или
1type
2  TDuplicates = TOleEnum;
3const
4  dupIgnore = $00000000;
5  dupAccept = $00000001;
6  dupError = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

dupIgnore

0

Игнорировать дубликаты

dupAccept

1

Разрешить дублирование

dupError

2

Генерировать ошибку дублирования

5.9.4.10. Перечисление TExcelOutputFormat (Формат результата отчета Excel)
1type
2  TExcelOutputFormat = (eofDefault, eof2003, eofHTML, eofPDF, eofNativePDF,
3    eofXPS);
Или
1type
2  TExcelOutputFormat = TOleEnum;
3const
4  eofDefault = $00000000;
5  eof2003 = $00000001;
6  eofHTML = $00000002;
7  eofPDF = $00000003;
8  eofNativePDF = $00000004;
9  eofXPS = $00000005;
Элементы перечисления:

Имя

Значение

Назначение

eofDefault

0

По умолчанию

eof2003

1

Рабочая книга Excel 97-2003

eofHTML

2

Документ HTML

eofPDF

3

Документ PDF

eofNativePDF

4

Документ PDF, сформированный Excel

eofXPS

5

Документ XPS

5.9.4.11. Перечисление TExcelSheetKind (Тип листа Excel)
1type
2  TExcelSheetKind = (skNone, skFirst, skFirstHidden, skLast, skNew);
Или
1type
2  TExcelSheetKind = TOleEnum;
3const
4  skNone = $00000000;
5  skFirst = $00000001;
6  skFirstHidden = $00000002;
7  skLast = $00000003;
8  skNew = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

skNone

0

Не переносить данные на лист

skFirst

1

На первый лист

skFirstHidden

2

На первый скрытый лист

skLast

3

На последний лист

skNew

4

На новый лист

5.9.4.12. Перечисление TExternalDataProtocol (Протокол доступа к внешним данным)
1type
2  TExternalDataProtocol = (prLocal, prHTTP, prHTTPS, prFTP, prFTPS, prSMB);
Или
1type
2  TExternalDataProtocol = TOleEnum;
3const
4  prLocal = $00000000;
5  prHTTP = $00000001;
6  prHTTPS = $00000002;
7  prFTP = $00000003;
8  prFTPS = $00000004;
9  prSMB = $00000005;
Элементы перечисления:

Имя

Значение

Назначение

prLocal

0

Файл доступен локально

prHTTP

1

Протокол HTTP

prHTTPS

2

Протокол HTTPS

prFTP

3

Протокол FTP

prFTPS

4

Протокол FTPS

prSMB

5

Протокол SMB

5.9.4.13. Перечисление TFormViewLayout (Виды расположения)
1type
2  TFormViewLayout = (vlHorizontal, vlVertical);
Или
1type
2  TFormViewLayout = TOleEnum;
3const
4  vlHorizontal = $00000000;
5  vlVertical = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

vlHorizontal

0

Горизонтальное

vlVertical

1

Вертикально

5.9.4.14. Перечисление TInstantContactStatus (Статус контакта)
1type
2  TInstantContactStatus = (icsPending, icsRefused, icsApproved);
Или
1type
2  TInstantContactStatus = TOleEnum;
3const
4  icsPending = $00000000;
5  icsRefused = $00000001;
6  icsApproved = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

icsPending

0

Рассматривается

icsRefused

1

Отказано

icsApproved

2

Утвержденный

5.9.4.15. Перечисление TInstantMessageAttachmentType (Тип вложения мгновенного сообщения)
1type
2  TInstantMessageAttachmentType = (imaFile, imaImage, imaHyperLink, imaObject);
Или
1type
2  TInstantMessageAttachmentType = TOleEnum;
3const
4  imaFile = $00000000;
5  imaImage = $00000001;
6  imaHyperLink = $00000002;
7  imaObject = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

imaFile

0

Файл

imaImage

1

Изображение

imaHyperLink

2

Гиперссылка

imaObject

3

Объект

5.9.4.16. Перечисление TInstantMessageAttachmentType (None) (Тип вложения мгновенного сообщения (None))
1type
2  TInstantMessageAttachmentType (None) = (imaFile, imaImage, imaHyperLink,
3    imaObject, imaNone);
Или
1type
2  TInstantMessageAttachmentType (None) = TOleEnum;
3const
4  imaFile = $00000000;
5  imaImage = $00000001;
6  imaHyperLink = $00000002;
7  imaObject = $00000003;
8  imaNone = $00000004;
Это перечисление использует элементы TInstantMessageAttachmentType.

Элементы перечисления:

Имя

Значение

Назначение

imaFile

0

Определено в базовом перечислении TInstantMessageAttachmentType

imaImage

1

Определено в базовом перечислении TInstantMessageAttachmentType

imaHyperLink

2

Определено в базовом перечислении TInstantMessageAttachmentType

imaObject

3

Определено в базовом перечислении TInstantMessageAttachmentType

imaNone

4

Нет

5.9.4.17. Перечисление TNotificationType (Тип уведомления)
1type
2  TNotificationType = (ntInformation, ntWarning, ntCaution);
Или
1type
2  TNotificationType = TOleEnum;
3const
4  ntInformation = $00000000;
5  ntWarning = $00000001;
6  ntCaution = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

ntInformation

0

Информация

ntWarning

1

Предупреждение

ntCaution

2

Проблема

5.9.4.18. Перечисление TOutputColorMode (Режим цветопередачи)
1type
2  TOutputColorMode = (wcmNormal, wcmGrayscale, wcmMonochrome);
Или
1type
2  TOutputColorMode = TOleEnum;
3const
4  wcmNormal = $00000000;
5  wcmGrayscale = $00000001;
6  wcmMonochrome = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

wcmNormal

0

Цветной

wcmGrayscale

1

В градациях серого

wcmMonochrome

2

Монохромный

5.9.4.19. Перечисление TReplicationStatus (Статус репликации)
1type
2  TReplicationStatus = (rsNotReplicatable, rsReplicatableMetadata, rsReplicatable);
Или
1type
2  TReplicationStatus = TOleEnum;
3const
4  rsNotReplicatable = $00000000;
5  rsReplicatableMetadata = $00000001;
6  rsReplicatable = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

rsNotReplicatable

0

Не реплицировать

rsReplicatableMetadata

1

Вместе с метаданными

rsReplicatable

2

Вместе с бизнес-данными

5.9.4.20. Перечисление TRowColor (Цвет строки таблицы)
1type
2  TRowColor = (rcDefault, rcRed, rcGreen, rcBlue, rcPale, rcCyan, rcMagenta,
3    rcYellow);
Или
01type
02  TRowColor = TOleEnum;
03const
04  rcDefault = $00000000;
05  rcRed = $00000001;
06  rcGreen = $00000002;
07  rcBlue = $00000003;
08  rcPale = $00000004;
09  rcCyan = $00000005;
10  rcMagenta = $00000006;
11  rcYellow = $00000007;
Элементы перечисления:

Имя

Значение

Назначение

rcDefault

0

По умолчанию

rcRed

1

Красная строка

rcGreen

2

Зеленая строка

rcBlue

3

Синяя строка

rcPale

4

Бледная строка

rcCyan

5

Голубая строка

rcMagenta

6

Пурпурная строка

rcYellow

7

Желтая строка

5.9.4.21. Перечисление TScope (Область видимости)
1type
2  TScope = (scPrivate, scPublic);
Или
1type
2  TScope = TOleEnum;
3const
4  scPrivate = $00000000;
5  scPublic = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

scPrivate

0

Не видимо пользователям

scPublic

1

Видимо пользователям

5.9.4.22. Перечисление TSecurityModel (Модели безопасности)
1type
2  TSecurityModel = (smFullAccess, smPublic, smPrivate, smByAffiliation);
Или
1type
2  TSecurityModel = TOleEnum;
3const
4  smFullAccess = $00000000;
5  smPublic = $00000001;
6  smPrivate = $00000002;
7  smByAffiliation = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

smFullAccess

0

Доступ не ограничен

smPublic

1

Публичный объект

smPrivate

2

Приватный объект

smByAffiliation

3

Доступ по принадлежности

5.9.4.23. Перечисление TShowObjectInfoType (Тип представления объектов)
1type
2  TShowObjectInfoType = (soName, soDescription);
Или
1type
2  TShowObjectInfoType = TOleEnum;
3const
4  soName = $00000000;
5  soDescription = $00000001;
Элементы перечисления:

Имя

Значение

Назначение

soName

0

Показывать имена

soDescription

1

Показывать наименования

5.9.4.24. Перечисление TSortDirection (Направление сортировки)
1type
2  TSortDirection = (sdNone, sdAscending, sdDescending);
Или
1type
2  TSortDirection = TOleEnum;
3const
4  sdNone = $00000000;
5  sdAscending = $00000001;
6  sdDescending = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

sdNone

0

Нет

sdAscending

1

По возрастанию

sdDescending

2

По убыванию

5.9.4.25. Перечисление TTranslationStatus (Состояния перевода)
1type
2  TTranslationStatus = (tsNotTranslated, tsTranslated, tsUntranslatable, tsDirty);
Или
1type
2  TTranslationStatus = TOleEnum;
3const
4  tsNotTranslated = $00000000;
5  tsTranslated = $00000001;
6  tsUntranslatable = $00000002;
7  tsDirty = $00000003;
Элементы перечисления:

Имя

Значение

Назначение

tsNotTranslated

0

Не переведено

tsTranslated

1

Переведено

tsUntranslatable

2

Не нуждается в переводе

tsDirty

3

Грязный

5.9.4.26. Перечисление TUserAccessMode (Режим доступа)
1type
2  TUserAccessMode = (uaFullAccess, uaReadOnly, uaAccessDenied);
Или
1type
2  TUserAccessMode = TOleEnum;
3const
4  uaFullAccess = $00000000;
5  uaReadOnly = $00000001;
6  uaAccessDenied = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

uaFullAccess

0

Полный доступ

uaReadOnly

1

Доступ только для чтения

uaAccessDenied

2

Доступ запрещен

5.9.4.27. Перечисление TWordOutputFormat (Формат результата отчета Word)
1type
2  TWordOutputFormat = (wofDefault, wof2003, wofHTML, wofRTF, wofPDF);
Или
1type
2  TWordOutputFormat = TOleEnum;
3const
4  wofDefault = $00000000;
5  wof2003 = $00000001;
6  wofHTML = $00000002;
7  wofRTF = $00000003;
8  wofPDF = $00000004;
Элементы перечисления:

Имя

Значение

Назначение

wofDefault

0

По умолчанию

wof2003

1

Документ Word 97-2003

wofHTML

2

Документ HTML

wofRTF

3

Документ RTF

wofPDF

4

Документ PDF

5.9.4.28. Класс TAccessibleFile (Доступный файл)

5.9.4.28.1. Свойства

Свойства класса TAccessibleFile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

FileData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные файла

CRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

5.9.4.28.2. Конструктор Create (Конструктор доступного файла)

Конструктор класса TAccessibleFile.
1constructor TAccessibleFile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  FileData: blob): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

FileData

blob

Нет

Данные файла

Замечания:

Создает новый объект класса TAccessibleFile.

5.9.4.28.3. Метод SetData (Установить значение свойства "Данные файла")

Метод экземпляра класса TAccessibleFile.
procedure TAccessibleFile.SetData(FileData: blob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

FileData

blob

Нет

Данные файла

5.9.4.28.4. Метод Ole-объекта CheckAllCRC (Обновить отсутствующие контрольные суммы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

5.9.4.28.5. Метод Ole-объекта CheckCRC (Обновить контрольную сумму)

Метод Ole-объекта класса TAccessibleFile.

Метод Ole-объекта не имеет параметров.

5.9.4.28.6. Метод Ole-объекта LoadFromFolder (Загрузить из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TAccessibleFile.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

5.9.4.28.7. Метод Ole-объекта SaveToFolder (Сохранить в папку)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

5.9.4.28.8. Метод Ole-объекта UpdateFromFolder (Обновить из папки)

Метод Ole-объекта класса TAccessibleFile.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

5.9.4.29. Класс TAccessItem (Элементы доступа)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.29.1. Свойства

Свойства класса TAccessItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Скрыто от пользователя

Чтение/Запись

Имя

Description

string[128]

Да

Скрыто от пользователя

Чтение/Запись

Наименование

Class

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

Элемент

MasterName

string[64]

Да

Видимо пользователю

Только для чтения

Имя элемента

MasterDescription

string[128]

Да

Видимо пользователю

Только для чтения

Наименование элемента

MasterClass

TClass

Да

Видимо пользователю

Только для чтения

Класс элемента

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

SecurityAccountName

string[64]

Да

Видимо пользователю

Чтение/Запись

Имя роли безопасности

SecurityAccountDescription

string[128]

Да

Видимо пользователю

Чтение/Запись

Наименование роли безопасности

SecurityAccountClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс роли безопасности

5.9.4.29.2. Конструктор Create (Конструктор элемента доступа)

Конструктор класса TAccessItem.
1constructor TAccessItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TAccessItem.

5.9.4.29.3. Метод GetIsAccessible (Проверка доступности)

Метод класса (статический метод) класса TAccessItem.
class function TAccessItem.GetIsAccessible(Master: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Boolean.

5.9.4.30. Класс TAccessProfile (Профили доступа)

5.9.4.30.1. Свойства

Свойства класса TAccessProfile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TProfile

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

ComparisonType

TComparisonType

Да

Видимо пользователю

Чтение/Запись

BasedOnProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Active

Boolean

Да

Видимо пользователю

Только для чтения

Access

Boolean

Да

Видимо пользователю

Чтение/Запись

Доступ

5.9.4.30.2. Конструктор Create (Конструктор профиля доступа)

Конструктор класса TAccessProfile.
1constructor TAccessProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType; BasedOnProfile: TProfile;
4  Access: Boolean): TObject;
Переопределяет метод в TProfile.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Унаследовано от TProfile.Create

ComparisonType

TComparisonType

Да

BasedOnProfile

TProfile

Нет

Access

Boolean

Да

Доступ

Замечания:

Создает новый объект класса TAccessProfile.

5.9.4.31. Класс TAction (Действия)

Объекты класса образуют иерархию.

5.9.4.31.1. Свойства

Свойства класса TAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Горячая клавиша

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Отделено

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

По умолчанию

5.9.4.31.2. Конструктор Create (Конструктор действия)

Конструктор класса TAction.
1constructor TAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean;
4  Default: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Shortcut

string[20]

Нет

Горячая клавиша

Separated

Boolean

Да

Отделено

Default

Boolean

Да

По умолчанию

Замечания:

Создает новый объект класса TAction.

5.9.4.31.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TAction.
1class function TAction.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Parent

TObject

Нет

Родитель

Step

Integer

Да

Шаг

Замечания:

Возвращает значение типа Integer.

5.9.4.32. Класс TActionContextProperty (Свойство контекста)

Имена объектов класса генерируются.

5.9.4.32.1. Свойства

Свойства класса TActionContextProperty:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Property

TProperty

Да

Видимо пользователю

Чтение/Запись

Свойство

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

5.9.4.32.2. Конструктор Create (Конструктор контекстного свойства)

Конструктор класса TActionContextProperty.
1constructor TActionContextProperty.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Property: TProperty; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Property

TProperty

Да

Свойство

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TActionContextProperty.

5.9.4.32.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TActionContextProperty.
class function TActionContextProperty.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

5.9.4.33. Класс TAsyncHandler (Обработчики отложенного выполнения)

5.9.4.33.1. Свойства

Свойства класса TAsyncHandler:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Validator

TMethod

Нет

Видимо пользователю

Чтение/Запись

Процедура-валидатор

Handler

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Процедура-обработчик

5.9.4.33.2. Конструктор Create (Конструктор обработчика отложенного выполнения)

Конструктор класса TAsyncHandler.
1constructor TAsyncHandler.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Validator: TMethod; Handler: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Validator

TMethod

Нет

Процедура-валидатор

Handler

TRoutine

Нет

Процедура-обработчик

Замечания:

Создает новый объект класса TAsyncHandler.

5.9.4.33.3. Метод GetIsAccessible (Доступен)

Метод экземпляра класса TAsyncHandler.
function TAsyncHandler.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.33.4. Метод ValidateInstantMessage (Доступен обработчик с уведомлением сообщением)

Метод класса (статический метод) класса TAsyncHandler.
class function TAsyncHandler.ValidateInstantMessage(Routine: TRoutine): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Замечания:

Возвращает значение типа Boolean.

5.9.4.33.5. Метод ValidateWithoutNotification (Доступен обработчик без уведомления)

Метод класса (статический метод) класса TAsyncHandler.
class function TAsyncHandler.ValidateWithoutNotification(Routine: TRoutine): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Замечания:

Возвращает значение типа Boolean.

5.9.4.34. Класс TAsyncHandlerAccess (Доступ к обработчикам отложенного выполнения)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.34.1. Конструктор Create (Конструктор доступа к обработчикам отложенного выполнения)

Конструктор класса TAsyncHandlerAccess.
1constructor TAsyncHandlerAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TAsyncHandlerAccess.

5.9.4.35. Класс TAsyncTask (Задачи отложенного выполнения)

Объекты класса не именованы.

5.9.4.35.1. Свойства

Свойства класса TAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Created

datetime

Да

Видимо пользователю

Только для чтения

Время создания

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Состояние

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Язык

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

Обработчик

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Представление формы

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Объект

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Время начала выполнения

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Время завершения выполнения

Duration

time

Нет

Видимо пользователю

Только для чтения

Длительность

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

Выделено

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Цвет строки

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

Группа

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Содержимое группы готово

5.9.4.35.2. Конструктор Create (Конструктор задачи отложенного выполнения)

Конструктор класса TAsyncTask.
1constructor TAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Подпрограмма

Object

TObject

Нет

Объект

FormView

TFormView

Нет

Представление формы

Handler

TAsyncHandler

Да

Обработчик

Language

TLanguage

Да

Язык

Замечания:

Создает новый объект класса TAsyncTask.

5.9.4.35.3. Деструктор Destroy (Деструктор объекта)

Деструктор класса TAsyncTask.
destructor TAsyncTask.Destroy;
Переопределяет метод в TObject.Destroy.

Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TAsyncTask или его наследника.

5.9.4.35.4. Метод Archive (Отправить в архив)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Archive;
Метод не имеет параметров.

5.9.4.35.5. Метод CreateGroup (Создать группу)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.CreateGroup(Group: clob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Group

clob

Нет

Группа

5.9.4.35.6. Метод Finish (Зафиксировать завершение выполнения)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Finish(Success: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Success

Boolean

Да

Выполнено успешно

5.9.4.35.7. Метод HandleInstantMessage (Обработчик с уведомлением сообщением)

Метод экземпляра класса TAsyncTask.
1procedure TAsyncTask.HandleInstantMessage(Success: Boolean;
2  ErrorMessage: string[2000]; ExceptionClass: string[2000];
3  NativeMessage: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Success

Boolean

Да

Выполнено успешно

ErrorMessage

string[2000]

Нет

Сообщение об ошибке

ExceptionClass

string[2000]

Нет

Класс ошибки

NativeMessage

string[2000]

Нет

Системное сообщение об ошибке

5.9.4.35.8. Метод HasAsyncTasks (Имеются задачи отложенного выполнения)

Метод класса (статический метод) класса TAsyncTask.
class function TAsyncTask.HasAsyncTasks: Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.35.9. Метод Start (Зафиксировать начало выполнения)

Метод экземпляра класса TAsyncTask.
procedure TAsyncTask.Start;
Метод скрыт от пользователя.

Метод не имеет параметров.

5.9.4.35.10. Метод Ole-объекта PerformImmediate (Выполнить немедленно)

Метод Ole-объекта класса TAsyncTask.

Метод Ole-объекта не имеет параметров.

5.9.4.36. Класс TAsyncTaskParameterValue (Значения параметров задачи отложенного выполнения)

Объекты класса не именованы.

5.9.4.36.1. Свойства

Свойства класса TAsyncTaskParameterValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Temporary

Boolean

Да

Видимо пользователю

Чтение/Запись

Временный объект

5.9.4.36.2. Конструктор Create (Конструктор значения параметров задачи отложенного выполнения)

Конструктор класса TAsyncTaskParameterValue.
1constructor TAsyncTaskParameterValue.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Domain: TDomain; Position: Integer;
4  Group: string[128]; Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]; IntValue: Integer; FloatValue: float; DateValue: date;
6  TimeValue: time; DateTimeValue: datetime; ObjectValue: TObject;
7  BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
8  ExternalDataValue: <external data>; Temporary: Boolean): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Унаследовано от TTypedValue.Create

Position

Integer

Да

Group

string[128]

Нет

Tab

string[128]

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

StrValue

string[2000]

Нет

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

Temporary

Boolean

Да

Временный объект

Замечания:

Создает новый объект класса TAsyncTaskParameterValue.

5.9.4.36.3. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TAsyncTaskParameterValue.
function TAsyncTaskParameterValue.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

5.9.4.37. Класс TBanGroup (Группы запретов)

5.9.4.37.1. Свойства

Свойства класса TBanGroup:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступна

5.9.4.37.2. Конструктор Create (Конструктор группы запретов)

Конструктор класса TBanGroup.
1constructor TBanGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TBanGroup.

5.9.4.37.3. Метод CreateAllBans (Сгенерировать запреты для класса)

Метод экземпляра класса TBanGroup.
1procedure TBanGroup.CreateAllBans(BannedClass: TClass; BanClass: Boolean;
2  BanRoutines: Boolean; BanProperties: Boolean; AllowRead: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

BannedClass

TClass

Да

Запрещаемый класс

BanClass

Boolean

Да

Запретить доступ к объектам класса

BanRoutines

Boolean

Да

Запретить подпрограммы

BanProperties

Boolean

Да

Запретить свойства

AllowRead

Boolean

Да

Чтение свойств разрешено

5.9.4.37.4. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TBanGroup.
function TBanGroup.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.38. Класс TBanGroupAccess (Доступ к группам запретов)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.38.1. Конструктор Create (Конструктор доступа к группе запретов)

Конструктор класса TBanGroupAccess.
1constructor TBanGroupAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TBanGroup; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TBanGroup

Да

Группа запретов

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TBanGroupAccess.

5.9.4.39. Класс TBanGroupItem (Элементы группы запретов)

5.9.4.39.1. Свойства

Свойства класса TBanGroupItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Мастер

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

5.9.4.39.2. Конструктор Create (Конструктор элемента группы запретов)

Конструктор класса TBanGroupItem.
1constructor TBanGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TBanGroupItem.

5.9.4.40. Класс TBlobDomain (Большие объекты)

5.9.4.40.1. Свойства

Свойства класса TBlobDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

BlobSubtype

TBlobSubtype

Да

Видимо пользователю

Чтение/Запись

Подтип

Extension

string[10]

Нет

Видимо пользователю

Чтение/Запись

Расширение

ShowInPlace

Boolean

Да

Видимо пользователю

Чтение/Запись

Редактировать по месту

EditorClassID

string[128]

Нет

Видимо пользователю

Чтение/Запись

Идентификатор класса-редактора

EditorCodeLibrary

TAccessibleFile

Нет

Видимо пользователю

Чтение/Запись

Библиотека кода редактора

SizeLimit

Integer

Нет

Видимо пользователю

Чтение/Запись

Ограничение на размер

IsBinary

Boolean

Да

Видимо пользователю

Только для чтения

Двоичные данные

5.9.4.40.2. Конструктор Create (Конструктор домена больших объектов)

Конструктор класса TBlobDomain.
1constructor TBlobDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; BlobSubtype: TBlobSubtype; SizeLimit: Integer;
4  Extension: string[10]; ShowInPlace: Boolean; EditorClassID: string[128];
5  EditorCodeLibrary: TAccessibleFile): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

BlobSubtype

TBlobSubtype

Да

Подтип

SizeLimit

Integer

Нет

Ограничение на размер

Extension

string[10]

Нет

Расширение

ShowInPlace

Boolean

Да

Редактировать по месту

EditorClassID

string[128]

Нет

Идентификатор класса-редактора

EditorCodeLibrary

TAccessibleFile

Нет

Библиотека кода редактора

Замечания:

Создает новый объект класса TBlobDomain.

5.9.4.40.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TBlobDomain.
function TBlobDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.41. Класс TBooleanDomain (Логические)

5.9.4.41.1. Свойства

Свойства класса TBooleanDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

TrueValue

string[64]

Да

Видимо пользователю

Чтение/Запись

Значение "Истина"

FalseValue

string[64]

Да

Видимо пользователю

Чтение/Запись

Значение "Ложь"

5.9.4.41.2. Конструктор Create (Конструктор логического домена)

Конструктор класса TBooleanDomain.
1constructor TBooleanDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; TrueValue: string[64]; FalseValue: string[64]): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

TrueValue

string[64]

Да

Значение "Истина"

FalseValue

string[64]

Да

Значение "Ложь"

Замечания:

Создает новый объект класса TBooleanDomain.

5.9.4.41.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TBooleanDomain.
function TBooleanDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.42. Класс TClass (Классы)

Объекты класса образуют иерархию.

5.9.4.42.1. Свойства

Свойства класса TClass:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Чтение/Запись

Статус репликации

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Унаследовано от TObject

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Является иерархическим

SecurityModel

TSecurityModel

Да

Видимо пользователю

Чтение/Запись

Модель безопасности

DefaultAccessor

TSecurityAccount

Нет

Видимо пользователю

Чтение/Запись

Роль доступа по умолчанию

UnNamed

Boolean

Да

Видимо пользователю

Чтение/Запись

Неименованный

NameExpression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение имени объекта

DescriptionExpression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение наименования объекта

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

ModelX

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Положение в модели (абсцисса)

ModelY

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Положение в модели (ордината)

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Indexed

Boolean

Да

Видимо пользователю

Чтение/Запись

Индексируется

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

Localizable

Boolean

Да

Видимо пользователю

Чтение/Запись

Локализуемый

DBMSName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта СУБД

CreatorsCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество ролей-создателей

MasterClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс-мастер

HasProfiles

Boolean

Да

Видимо пользователю

Только для чтения

Контролируется профилями

ApproxObjectCount

Integer

Нет

Видимо пользователю

Только для чтения

Оценка количества объектов

5.9.4.42.2. Конструктор Create (Конструктор класса)

Конструктор класса TClass.
1constructor TClass.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  MasterClass: TClass; IsHierarhical: Boolean;
4  ReplicationStatus: TReplicationStatus; SecurityModel: TSecurityModel;
5  DefaultAccessor: TSecurityAccount; Logged: Boolean; UnNamed: Boolean;
6  NameExpression: clob; DescriptionExpression: clob; CreateConstructor: Boolean;
7  Category: string[128]; Indexed: Boolean; Localizable: Boolean): TClass;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

MasterClass

TClass

Нет

Класс-мастер

IsHierarhical

Boolean

Да

Является иерархическим

ReplicationStatus

TReplicationStatus

Да

Статус репликации

SecurityModel

TSecurityModel

Да

Модель безопасности

DefaultAccessor

TSecurityAccount

Нет

Роль доступа по умолчанию

Logged

Boolean

Да

Протоколировать

UnNamed

Boolean

Да

Неименованный

NameExpression

clob

Нет

Выражение имени объекта

DescriptionExpression

clob

Нет

Выражение наименования объекта

CreateConstructor

Boolean

Да

Создать конструктор

Category

string[128]

Нет

Категория

Indexed

Boolean

Да

Индексируется

Localizable

Boolean

Да

Локализуемый

Замечания:

Создает новый объект класса TClass.

5.9.4.42.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TClass.
procedure TClass.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

5.9.4.42.4. Метод GenerateConstructor (Сгенерировать текст конструктора)

Метод экземпляра класса TClass.
procedure TClass.GenerateConstructor;
Метод не имеет параметров.

5.9.4.42.5. Метод GetApproxObjectsCount (Получить оценку количества объектов)

Метод экземпляра класса TClass.
function TClass.GetApproxObjectsCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.42.6. Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TClass.
function TClass.GetDBMSName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

5.9.4.42.7. Метод GetHasProfiles (Контролируется профилями)

Метод экземпляра класса TClass.
function TClass.GetHasProfiles: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.42.8. Метод GetObjectCount (Количество объектов)

Метод экземпляра класса TClass.
function TClass.GetObjectCount(Exact: Boolean): string[20];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Exact

Boolean

Да

Строго

Замечания:

Возвращает значение типа string[20].

5.9.4.42.9. Метод ListChildProperties (Список дочерних свойств)

Метод класса (статический метод) класса TClass.
1class procedure TClass.ListChildProperties(ParentName: string[64];
2  TemporaryList: TObjectList; PersistentList: TObjectList);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ParentName

string[64]

Да

Имя свойства

TemporaryList

TObjectList

Нет

Временный список

PersistentList

TObjectList

Нет

Постоянный список

5.9.4.42.10. Метод ListProperties (Список свойств)

Метод экземпляра класса TClass.
function TClass.ListProperties(Scope: TScope): TObjectList;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Scope

TScope

Да

Область видимости

Замечания:

Возвращает значение типа TObjectList.

5.9.4.42.11. Метод ListRoutines (Список подпрограмм)

Метод экземпляра класса TClass.
function TClass.ListRoutines(Scope: TScope): TObjectList;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Scope

TScope

Да

Область видимости

Замечания:

Возвращает значение типа TObjectList.

5.9.4.42.12. Метод MarkLocalizableMetadata (Установить поля метаданных как локализуемые)

Метод класса (статический метод) класса TClass.
class procedure TClass.MarkLocalizableMetadata;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

5.9.4.42.13. Метод MemberByName (Член класса по имени)

Метод экземпляра класса TClass.
function TClass.MemberByName(Name: string[64]; Class: TClass): TClassMember;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Class

TClass

Да

Класс

Замечания:

Возвращает значение типа TClassMember.

5.9.4.42.14. Метод SetLocalizable (Установить значение свойства "Локализуемый")

Метод экземпляра класса TClass.
procedure TClass.SetLocalizable(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

5.9.4.42.15. Метод Ole-объекта CheckAllExcelTemplates (Проверить шаблоны отчетов Excel)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

5.9.4.42.16. Метод Ole-объекта CheckAllOleObjectMethods (Проверить все методы Ole-объекта)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

5.9.4.42.17. Метод Ole-объекта CheckAllTemplates (Проверить все шаблоны)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

5.9.4.42.18. Метод Ole-объекта CheckAllWordTemplates (Проверить шаблоны отчетов Word)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

5.9.4.42.19. Метод Ole-объекта CheckAllXSLTTemplates (Проверить шаблоны отчетов XSLT)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Метод Ole-объекта не имеет параметров.

5.9.4.42.20. Метод Ole-объекта LoadImagesFromFolder (Загрузить изображения из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Prefix

string[128]

Нет

Префикс имени файла

Замечания:

Возвращает значение типа Integer.

5.9.4.42.21. Метод Ole-объекта LoadMethodsFromFolder (Загрузить методы из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

5.9.4.42.22. Метод Ole-объекта LoadResourceFile (Загрузить файл ресурсов)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

XliffFileName

string[255]

Да

Файл ресурсов

Замечания:

Возвращает значение типа Integer.

5.9.4.42.23. Метод Ole-объекта LoadTemplatesFromFolder (Загрузить шаблоны из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

5.9.4.42.24. Метод Ole-объекта SaveImagesToFolder (Сохранить изображения в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Prefix

string[128]

Нет

Префикс имени файла

Замечания:

Возвращает значение типа Integer.

5.9.4.42.25. Метод Ole-объекта SaveMethodsToFolder (Сохранить методы в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Замечания:

Возвращает значение типа Integer.

5.9.4.42.26. Метод Ole-объекта SaveTemplatesToFolder (Сохранить шаблоны в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TClass.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

ExportCodeModules

Boolean

Да

Экспортировать программные модули

Замечания:

Возвращает значение типа Integer.

5.9.4.42.27. Шаблон XSLT-отчета ClassesDiagram (Диаграмма классов)

Шаблон XSLT-отчета класса (статический шаблон) класса TClass.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ShowFields

Boolean

Да

Показывать поля

ShowMethods

Boolean

Да

Показывать методы

ShowProperties

Boolean

Да

Показывать свойства

ShowParameters

Boolean

Да

Показывать параметры

ShowMetadata

Boolean

Да

Показывать метаданные

GroupByMaster

Boolean

Да

Группировать по принадлежности

5.9.4.43. Класс TClassBan (Запрет на класс)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.43.1. Свойства

Свойства класса TClassBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

5.9.4.43.2. Конструктор Create (Конструктор запрета на класс)

Конструктор класса TClassBan.
1constructor TClassBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

Замечания:

Создает новый объект класса TClassBan.

5.9.4.44. Класс TClassDomain (Ссылки на объекты)

5.9.4.44.1. Свойства

Свойства класса TClassDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

ClassOfDomain

TClass

Нет

Видимо пользователю

Чтение/Запись

Класс домена

ClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Чтение/Запись

Статус репликации класса

ShowObjectInfoType

TShowObjectInfoType

Да

Видимо пользователю

Чтение/Запись

Тип представления объектов

DeleteRule

TDeleteRule

Да

Видимо пользователю

Чтение/Запись

Правило удаления

FilterCondition

clob

Нет

Видимо пользователю

Чтение/Запись

Условие отбора

View

TCustomView

Нет

Видимо пользователю

Чтение/Запись

Представление

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

5.9.4.44.2. Конструктор Create (Конструктор домена-ссылки)

Конструктор класса TClassDomain.
1constructor TClassDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; ClassOfDomain: TClass; View: TCustomView;
4  FilterCondition: clob; ShowObjectInfoType: TShowObjectInfoType;
5  DeleteRule: TDeleteRule; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

ClassOfDomain

TClass

Да

Класс домена

View

TCustomView

Нет

Представление для выбора

FilterCondition

clob

Нет

Условие отбора

ShowObjectInfoType

TShowObjectInfoType

Да

Тип представления объектов

DeleteRule

TDeleteRule

Да

Правило удаления

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TClassDomain.

5.9.4.44.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TClassDomain.
function TClassDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.45. Класс TClassMember (Члены класса)

5.9.4.45.1. Свойства

Свойства класса TClassMember:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределен

5.9.4.45.2. Конструктор Create (Конструктор члена класса)

Конструктор класса TClassMember.
1constructor TClassMember.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TClassMember.

5.9.4.45.3. Метод GetOverride (Переопределен)

Метод экземпляра класса TClassMember.
function TClassMember.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.45.4. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TClassMember.
function TClassMember.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

5.9.4.46. Класс TCommandButton (Командные кнопки)

5.9.4.46.1. Свойства

Свойства класса TCommandButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TRoutine

Да

Видимо пользователю

Только для чтения

Мастер

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

MasterMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер подпрограммы

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomButton

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределена

Parameter

TParameter

Нет

Видимо пользователю

Чтение/Запись

Связанный параметр

5.9.4.46.2. Конструктор Create (Конструктор командной кнопки)

Конструктор класса TCommandButton.
1constructor TCommandButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean; Parameter: TParameter): TObject;
Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Group

string[128]

Нет

Унаследовано от TCustomButton.Create

Tab

string[128]

Нет

Script

clob

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

Parameter

TParameter

Нет

Связанный параметр

Замечания:

Создает новый объект класса TCommandButton.

5.9.4.46.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TCommandButton.
class function TCommandButton.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

5.9.4.46.4. Метод GetOverride (Переопределена)

Метод экземпляра класса TCommandButton.
function TCommandButton.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.47. Класс TContextKey (Ключи контекстной помощи)

Объекты класса не именованы.

5.9.4.47.1. Свойства

Свойства класса TContextKey:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Storage

string[64]

Да

Видимо пользователю

Чтение/Запись

Хранилище

LinkedObject

TObject

Нет

Видимо пользователю

Чтение/Запись

Связанный объект

LinkedObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс связанного объекта

LinkedObjectMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер связанного объекта

5.9.4.47.2. Конструктор Create (Конструктор ключа)

Конструктор класса TContextKey.
1constructor TContextKey.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Storage: string[64]; LinkedObject: TObject): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Ключевое словосочетание

Class

TClass

Нет

Унаследовано от TObject.Create

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Storage

string[64]

Да

Хранилище

LinkedObject

TObject

Нет

Связанный объект

Замечания:

Создает новый объект класса TContextKey.

5.9.4.47.3. Метод GenerateAllKeys (Сгенерировать ключи)

Метод класса (статический метод) класса TContextKey.
class procedure TContextKey.GenerateAllKeys(Storage: string[64]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

5.9.4.48. Класс TCustomButton (Кнопки)

5.9.4.48.1. Свойства

Свойства класса TCustomButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

5.9.4.48.2. Конструктор Create (Конструктор кнопки)

Конструктор класса TCustomButton.
1constructor TCustomButton.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Group: string[128]; Tab: string[128]; Script: clob;
4  Scope: TScope; OutOfTabs: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Script

clob

Нет

Скрипт

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

Замечания:

Создает новый объект класса TCustomButton.

5.9.4.49. Класс TCustomView (Абстрактное представление)

5.9.4.49.1. Свойства

Свойства класса TCustomView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Класс

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс-мастер показываемого

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

Статус репликации класса

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Иерархическое

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

Количество данных незначительно

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство выделенного шрифта

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

Предсобранное

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Вызывать перед открытием

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство цвета

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Параметры оптимизации

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

Имеются условия отбора

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

Имеет колонки со специфическими именами

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

5.9.4.49.2. Конструктор Create (Конструктор абстрактного представления)

Конструктор класса TCustomView.
1constructor TCustomView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Класс

ColorProperty

TProperty

Нет

Свойство цвета

BoldProperty

TProperty

Нет

Свойство выделенного шрифта

Skimpy

Boolean

Да

Количество данных незначительно

PreCompiled

Boolean

Да

Предсобранное

PreOpenRoutine

TRoutine

Нет

Вызывать перед открытием

Замечания:

Создает новый объект класса TCustomView.

5.9.4.49.3. Метод BuildDefaultActions (Создать действия по умолчанию)

Метод экземпляра класса TCustomView.
1procedure TCustomView.BuildDefaultActions(AddConstructor: Boolean;
2  AddDestructor: Boolean; AddMethods: Boolean; AddReports: Boolean;
3  AddCopyPasteActions: Boolean; AddStandartActions: Boolean;
4  PositionStep: Integer);
Параметры:

Имя

Тип

Обязательно

Значение

AddConstructor

Boolean

Да

Добавить конструктор

AddDestructor

Boolean

Да

Добавить деструктор

AddMethods

Boolean

Да

Добавить методы

AddReports

Boolean

Да

Добавить шаблоны отчетов

AddCopyPasteActions

Boolean

Да

Добавить работу с буфером обмена

AddStandartActions

Boolean

Да

Добавить стандартные действия

PositionStep

Integer

Да

Шаг

5.9.4.49.4. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TCustomView.
procedure TCustomView.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

5.9.4.50. Класс TDataBase (Базы данных)

5.9.4.50.1. Свойства

Свойства класса TDataBase:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

GUID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущей

Protected

Boolean

Да

Видимо пользователю

Чтение/Запись

Защищена от изменений

5.9.4.50.2. Конструктор Create (Конструктор базы данных)

Конструктор класса TDataBase.
1constructor TDataBase.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  GUID: string[38]; Protected: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

GUID

string[38]

Да

GUID

Protected

Boolean

Да

Защищена

Замечания:

Создает новый объект класса TDataBase.

5.9.4.51. Класс TDateDomain (Даты)

5.9.4.51.1. Конструктор Create (Конструктор домена даты)

Конструктор класса TDateDomain.
1constructor TDateDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Замечания:

Создает новый объект класса TDateDomain.

5.9.4.51.2. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateDomain.
function TDateDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.52. Класс TDateTimeDomain (Даты со временем)

5.9.4.52.1. Свойства

Свойства класса TDateTimeDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

HideSeconds

Boolean

Да

Видимо пользователю

Чтение/Запись

Не показывать секунды

5.9.4.52.2. Конструктор Create (Конструктор домена даты со временем)

Конструктор класса TDateTimeDomain.
1constructor TDateTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

HideSeconds

Boolean

Да

Не показывать секунды

Замечания:

Создает новый объект класса TDateTimeDomain.

5.9.4.52.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDateTimeDomain.
function TDateTimeDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.53. Класс TDependency (Зависимости)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.53.1. Свойства

Свойства класса TDependency:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Dependent

TObject

Нет

Видимо пользователю

Чтение/Запись

Зависимый объект

DependentClass

TClass

Да

Видимо пользователю

Только для чтения

Класс зависимого объекта

DependentMaster

TObject

Да

Видимо пользователю

Только для чтения

Мастер зависимого объекта

DependentExternal

string[256]

Нет

Видимо пользователю

Чтение/Запись

Внешний зависимый объект

DependedOn

TObject

Да

Видимо пользователю

Чтение/Запись

Зависит от

DependedOnClass

TClass

Да

Видимо пользователю

Только для чтения

Класс объекта, от которого зависит

DependedOnMaster

TObject

Да

Видимо пользователю

Только для чтения

Мастер объекта, от которого зависит

5.9.4.53.2. Конструктор Create (Конструктор зависимости)

Конструктор класса TDependency.
1constructor TDependency.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Dependent: TObject; DependentExternal: string[256];
4  DependedOn: TObject): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Dependent

TObject

Нет

Зависимый объект

DependentExternal

string[256]

Нет

Внешний зависимый объект

DependedOn

TObject

Да

Зависит от

Замечания:

Создает новый объект класса TDependency.

5.9.4.53.3. Метод Install (Установить)

Метод класса (статический метод) класса TDependency.
1class procedure TDependency.Install(ADependent: TObject;
2  ADependentExternal: string[256]; ADependedOn: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ADependent

TObject

Нет

Зависимый объект

ADependentExternal

string[256]

Нет

Внешний зависимый объект

ADependedOn

TObject

Да

Зависит от

5.9.4.54. Класс TDomain (Домены)

5.9.4.54.1. Свойства

Свойства класса TDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Обязательно для заполнения

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество внешних зависимостей

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Сводка

5.9.4.54.2. Конструктор Create (Конструктор домена)

Конструктор класса TDomain.
1constructor TDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean): TDomain;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Обязательно для заполнения

Замечания:

Создает новый объект класса TDomain.

5.9.4.54.3. Метод GetDefinition (Определение домена)

Метод экземпляра класса TDomain.
function TDomain.GetDefinition: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

5.9.4.54.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TDomain.
function TDomain.GetSummary: string[2000];
Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.55. Класс TEnumerationDomain (Перечисления)

5.9.4.55.1. Свойства

Свойства класса TEnumerationDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

ShowNames

Boolean

Да

Видимо пользователю

Чтение/Запись

Показывать имена

BasedOnDomain

TEnumerationDomain

Нет

Видимо пользователю

Чтение/Запись

Расширяет домен

ItemCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество элементов

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

5.9.4.55.2. Конструктор Create (Конструктор перечисления)

Конструктор класса TEnumerationDomain.
1constructor TEnumerationDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; ShowNames: Boolean;
4  BasedOnDomain: TEnumerationDomain; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

ShowNames

Boolean

Да

Показывать имена элементов

BasedOnDomain

TEnumerationDomain

Нет

Расширяет домен

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TEnumerationDomain.

5.9.4.55.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TEnumerationDomain.
function TEnumerationDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.55.4. Метод ListItems (Список элементов)

Метод экземпляра класса TEnumerationDomain.
function TEnumerationDomain.ListItems: TObjectList;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.

5.9.4.56. Класс TEnumerationItem (Элементы перечислений)

5.9.4.56.1. Свойства

Свойства класса TEnumerationItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

5.9.4.56.2. Конструктор Create (Конструктор элемента перечисления)

Конструктор класса TEnumerationItem.
1constructor TEnumerationItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TEnumerationItem.

5.9.4.56.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TEnumerationItem.
class function TEnumerationItem.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

5.9.4.57. Класс TExcelAsyncTask (Задачи отложенного выполнения отчетов Excel)

Объекты класса не именованы.

5.9.4.57.1. Свойства

Свойства класса TExcelAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TAsyncTask

Created

datetime

Да

Видимо пользователю

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TAsyncTask

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Duration

time

Нет

Видимо пользователю

Только для чтения

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Format

TExcelOutputFormat

Да

Видимо пользователю

Чтение/Запись

Формат

ColorMode

TOutputColorMode

Да

Видимо пользователю

Чтение/Запись

Режим цветопередачи

EmbedFonts

Boolean

Да

Видимо пользователю

Чтение/Запись

Внедрять шрифты

5.9.4.57.2. Конструктор Create (Конструктор задачи отложенного выполнения отчетов Excel)

Конструктор класса TExcelAsyncTask.
1constructor TExcelAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TExcelOutputFormat;
5  ColorMode: TOutputColorMode; EmbedFonts: Boolean): TObject;
Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Унаследовано от TAsyncTask.Create

Object

TObject

Нет

FormView

TFormView

Нет

Handler

TAsyncHandler

Да

Language

TLanguage

Да

Format

TExcelOutputFormat

Да

Формат

ColorMode

TOutputColorMode

Да

Режим цветопередачи

EmbedFonts

Boolean

Да

Внедрять шрифты

Замечания:

Создает новый объект класса TExcelAsyncTask.

5.9.4.58. Класс TExcelTemplate (Шаблоны отчетов Excel)

5.9.4.58.1. Свойства

Свойства класса TExcelTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

PlaceDataOnSheet

TExcelSheetKind

Да

Видимо пользователю

Чтение/Запись

Лист для переноса данных

MacroName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя макроса

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

5.9.4.58.2. Конструктор Create (Конструктор шаблона Excel)

Конструктор класса TExcelTemplate.
1constructor TExcelTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  PlaceDataOnSheet: TExcelSheetKind; MacroName: string[128];
7  IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

blob

Нет

Данные шаблона

PlaceDataOnSheet

TExcelSheetKind

Да

Лист для переноса данных

MacroName

string[128]

Нет

Имя макроса

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TExcelTemplate.

5.9.4.58.3. Метод Ole-объекта CheckExcelTemplate (Проверить шаблон отчетов Excel)

Метод Ole-объекта класса TExcelTemplate.

Метод Ole-объекта не имеет параметров.

5.9.4.59. Класс TExternalDataDomain (Внешние данные)

5.9.4.59.1. Свойства

Свойства класса TExternalDataDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

NamesSequence

TSequence

Нет

Видимо пользователю

Чтение/Запись

Последовательность для формирования имен

ContentDomain

TBlobDomain

Да

Видимо пользователю

Чтение/Запись

Домен содержимого

ContentDomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена содержимого

ContentDomainBlobSubtype

TBlobSubtype

Да

Видимо пользователю

Только для чтения

Подтип домена содержимого

ContentDomainExtension

string[10]

Нет

Видимо пользователю

Только для чтения

Расширение домена содержимого

ResourceCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество ресурсов

ContentDependentNames

Boolean

Да

Видимо пользователю

Чтение/Запись

Имя зависит от содержимого

Compress

Boolean

Да

Видимо пользователю

Чтение/Запись

Сжимать содержимое

5.9.4.59.2. Конструктор Create (Конструктор домена внешних данных)

Конструктор класса TExternalDataDomain.
1constructor TExternalDataDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; NamesSequence: TSequence;
4  ContentDomain: TBlobDomain; ContentDependentNames: Boolean;
5  Compress: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

NamesSequence

TSequence

Нет

Последовательность для формирования имен

ContentDomain

TBlobDomain

Да

Домен содержимого

ContentDependentNames

Boolean

Да

Имя зависит от содержимого

Compress

Boolean

Да

Сжимать содержимое

Замечания:

Создает новый объект класса TExternalDataDomain.

5.9.4.59.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TExternalDataDomain.
function TExternalDataDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.60. Класс TExternalDataResource (Ресурсы внешних данных)

5.9.4.60.1. Свойства

Свойства класса TExternalDataResource:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

GUID

string[38]

Да

Видимо пользователю

Чтение/Запись

GUID

Protocol

TExternalDataProtocol

Да

Видимо пользователю

Чтение/Запись

Протокол доступа

Host

string[64]

Да

Видимо пользователю

Чтение/Запись

Хост

Port

Integer

Нет

Видимо пользователю

Чтение/Запись

Порт

Path

string[255]

Да

Видимо пользователю

Чтение/Запись

Папка

UserName

string[255]

Нет

Видимо пользователю

Чтение/Запись

Имя пользователя

Password

string[255]

Нет

Видимо пользователю

Чтение/Запись

Пароль

ReadOnly

Boolean

Да

Видимо пользователю

Чтение/Запись

Только для чтения

5.9.4.60.2. Конструктор Create (Конструктор ресурса внешних данных)

Конструктор класса TExternalDataResource.
1constructor TExternalDataResource.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; GUID: string[38]; Protocol: TExternalDataProtocol;
4  Host: string[64]; Port: Integer; Path: string[255]; UserName: string[255];
5  Password: string[255]; ReadOnly: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

GUID

string[38]

Да

GUID

Protocol

TExternalDataProtocol

Да

Протокол доступа

Host

string[64]

Да

Хост

Port

Integer

Нет

Порт

Path

string[255]

Да

Папка

UserName

string[255]

Нет

Имя пользователя

Password

string[255]

Нет

Пароль

ReadOnly

Boolean

Да

Только для чтения

Замечания:

Создает новый объект класса TExternalDataResource.

5.9.4.60.3. Метод FileNameClause (Кляуза имени поля)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.FileNameClause(FieldName: string[64]): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

FieldName

string[64]

Да

Имя поля

Замечания:

Возвращает значение типа string[2000].

5.9.4.60.4. Метод FindUsedName (Найти использованное имя)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.FindUsedName(Name: string[77]): clob;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[77]

Да

Имя

Замечания:

Возвращает значение типа clob.

5.9.4.60.5. Метод GetUsedFileNames (Получить список использованных имен)

Метод экземпляра класса TExternalDataResource.
function TExternalDataResource.GetUsedFileNames: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

5.9.4.60.6. Метод Ole-объекта CheckExternalData (Проверить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя

Тип

Обязательно

Значение

FilesFolder

string[255]

Да

Файлы внешних данных

TrashFolder

string[255]

Да

Папка для неиспользуемых файлов

5.9.4.60.7. Метод Ole-объекта SaveExternalData (Сохранить внешние данные)

Метод Ole-объекта класса TExternalDataResource.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка для сохранения

5.9.4.61. Класс TField (Поля)

5.9.4.61.1. Свойства

Свойства класса TField:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Indexed

Boolean

Да

Видимо пользователю

Чтение/Запись

Индексируется

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

Localizable

Boolean

Да

Видимо пользователю

Чтение/Запись

Локализуемое

5.9.4.61.2. Конструктор Create (Конструктор поля)

Конструктор класса TField.
1constructor TField.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; CreateProperty: Boolean; CreateConstructorParameter: Boolean;
4  CreateViewColumns: Boolean; Logged: Boolean; Indexed: Boolean;
5  Localizable: Boolean): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

CreateProperty

Boolean

Да

Создать свойство

CreateConstructorParameter

Boolean

Да

Создать параметр конструктора

CreateViewColumns

Boolean

Да

Создать колонку во всех представлениях

Logged

Boolean

Да

Протоколировать

Indexed

Boolean

Да

Индексируется

Localizable

Boolean

Да

Локализуемое

Замечания:

Создает новый объект класса TField.

5.9.4.61.3. Метод SetLocalizable (Установить значение свойства "Локализуемое")

Метод экземпляра класса TField.
procedure TField.SetLocalizable(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

5.9.4.62. Класс TFileNameDomain (Имена файлов)

5.9.4.62.1. Свойства

Свойства класса TFileNameDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TStringDomain

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

FileMustExist

Boolean

Да

Видимо пользователю

Чтение/Запись

Файл должен существовать

DefaultExtension

string[10]

Нет

Видимо пользователю

Чтение/Запись

Расширение по умолчанию

OverwritePrompt

Boolean

Да

Видимо пользователю

Чтение/Запись

Запрос перезаписи

5.9.4.62.2. Конструктор Create (Конструктор имени файла)

Конструктор класса TFileNameDomain.
1constructor TFileNameDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean; FileMustExist: Boolean;
7  DefaultExtension: string[10]; OverwritePrompt: Boolean): TObject;
Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Унаследовано от TStringDomain.Create

AllowLeadingSpaces

Boolean

Да

AllowTrailingSpaces

Boolean

Да

AllowSpaceDuplication

Boolean

Да

CharacterSet

string[2000]

Нет

FirstCharacterSet

string[2000]

Нет

CaseMode

Boolean

Нет

Mask

string[2000]

Нет

CaseInsensitiveSearch

Boolean

Да

FileMustExist

Boolean

Да

Файл должен существовать

DefaultExtension

string[10]

Нет

Расширение по умолчанию

OverwritePrompt

Boolean

Да

Запрос перезаписи

Замечания:

Создает новый объект класса TFileNameDomain.

5.9.4.62.3. Метод Change (Изменение объекта)

Метод экземпляра класса TFileNameDomain.
procedure TFileNameDomain.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

5.9.4.62.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFileNameDomain.
function TFileNameDomain.GetSummary: string[2000];
Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.63. Класс TFilmstripView (Представление-диафильм)

5.9.4.63.1. Свойства

Свойства класса TFilmstripView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomView

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

LegendProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-подпись

ThumbnailProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-значок

ImageProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-изображение

ThumbnailSize

Integer

Да

Видимо пользователю

Чтение/Запись

Размер значка

OrderProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство, определяющее порядок

5.9.4.63.2. Конструктор Create (Конструктор представления-диафильма)

Конструктор класса TFilmstripView.
1constructor TFilmstripView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  LegendProperty: TProperty; ThumbnailProperty: TProperty;
6  ImageProperty: TProperty; ThumbnailSize: Integer;
7  OrderProperty: TProperty): TObject;
Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Унаследовано от TCustomView.Create

ColorProperty

TProperty

Нет

BoldProperty

TProperty

Нет

Skimpy

Boolean

Да

PreCompiled

Boolean

Да

PreOpenRoutine

TRoutine

Нет

LegendProperty

TProperty

Нет

Свойство-подпись

ThumbnailProperty

TProperty

Нет

Свойство-значок

ImageProperty

TProperty

Нет

Свойство-изображение

ThumbnailSize

Integer

Да

Размер значка

OrderProperty

TProperty

Нет

Свойство, определяющее порядок

Замечания:

Создает новый объект класса TFilmstripView.

5.9.4.64. Класс TFloatDomain (Вещественные числа)

5.9.4.64.1. Свойства

Свойства класса TFloatDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Нет

Видимо пользователю

Чтение/Запись

Длина

DecimalPlaces

Integer

Нет

Видимо пользователю

Чтение/Запись

Количество десятичных знаков

MinValue

float

Нет

Видимо пользователю

Чтение/Запись

Минимальное значение

MaxValue

float

Нет

Видимо пользователю

Чтение/Запись

Максимальное значение

DigitGrouping

Boolean

Да

Видимо пользователю

Чтение/Запись

Разделять группы разрядов

5.9.4.64.2. Конструктор Create (Конструктор вещественного домена)

Конструктор класса TFloatDomain.
1constructor TFloatDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; DecimalPlaces: Integer; MinValue: float;
4  MaxValue: float; DigitGrouping: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Нет

Длина

DecimalPlaces

Integer

Нет

Количество десятичных знаков

MinValue

float

Нет

Минимальное значение

MaxValue

float

Нет

Максимальное значение

DigitGrouping

Boolean

Да

Разделять группы разрядов

Замечания:

Создает новый объект класса TFloatDomain.

5.9.4.64.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFloatDomain.
function TFloatDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.65. Класс TFolderNameDomain (Имена папок файловой системы)

5.9.4.65.1. Свойства

Свойства класса TFolderNameDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TStringDomain

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

FolderMustExist

Boolean

Да

Видимо пользователю

Чтение/Запись

Папка должна существовать

5.9.4.65.2. Конструктор Create (Конструктор имени папки)

Конструктор класса TFolderNameDomain.
1constructor TFolderNameDomain.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Required: Boolean; Length: Integer;
4  AllowLeadingSpaces: Boolean; AllowTrailingSpaces: Boolean;
5  AllowSpaceDuplication: Boolean; CharacterSet: string[2000];
6  FirstCharacterSet: string[2000]; CaseMode: Boolean; Mask: string[2000];
7  CaseInsensitiveSearch: Boolean; FolderMustExist: Boolean): TObject;
Переопределяет метод в TStringDomain.Create, TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Унаследовано от TStringDomain.Create

AllowLeadingSpaces

Boolean

Да

AllowTrailingSpaces

Boolean

Да

AllowSpaceDuplication

Boolean

Да

CharacterSet

string[2000]

Нет

FirstCharacterSet

string[2000]

Нет

CaseMode

Boolean

Нет

Mask

string[2000]

Нет

CaseInsensitiveSearch

Boolean

Да

FolderMustExist

Boolean

Да

Папка должна существовать

Замечания:

Создает новый объект класса TFolderNameDomain.

5.9.4.65.3. Метод Change (Изменение объекта)

Метод экземпляра класса TFolderNameDomain.
procedure TFolderNameDomain.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

5.9.4.65.4. Метод GetSummary (Получить сводку)

Метод экземпляра класса TFolderNameDomain.
function TFolderNameDomain.GetSummary: string[2000];
Переопределяет метод в TStringDomain.GetSummary, TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.66. Класс TForm (Формы)

5.9.4.66.1. Свойства

Свойства класса TForm:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

AutoOpen

Boolean

Да

Видимо пользователю

Чтение/Запись

Открывать автоматически

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение-иконка

IsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Доступна

IsAlive

Boolean

Да

Видимо пользователю

Чтение/Запись

"Живая"

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

Вызывать перед открытием

5.9.4.66.2. Конструктор Create (Конструктор формы)

Конструктор класса TForm.
1constructor TForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  AutoOpen: Boolean; Position: Integer; Scope: TScope; Image: blob;
4  IsAlive: Boolean; PreOpenRoutine: TRoutine): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

AutoOpen

Boolean

Да

Открывать автоматически

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

Image

blob

Нет

Изображение-иконка

IsAlive

Boolean

Да

"Живая"

PreOpenRoutine

TRoutine

Нет

Вызывать перед открытием

Замечания:

Создает новый объект класса TForm.

5.9.4.66.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TForm.
procedure TForm.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

5.9.4.66.4. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TForm.
function TForm.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.66.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TForm.
class function TForm.GetNextPos: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.67. Класс TFormAccess (Доступ к формам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.67.1. Конструктор Create (Конструктор доступа к форме)

Конструктор класса TFormAccess.
1constructor TFormAccess.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TForm; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TForm

Да

Форма

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TFormAccess.

5.9.4.68. Класс TFormBan (Запрет на форму)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.68.1. Свойства

Свойства класса TFormBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedForm

TForm

Да

Видимо пользователю

Чтение/Запись

Запрещаемая форма

5.9.4.68.2. Конструктор Create (Конструктор запрета на форму)

Конструктор класса TFormBan.
1constructor TFormBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedForm: TForm): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedForm

TForm

Да

Запрещаемая форма

Замечания:

Создает новый объект класса TFormBan.

5.9.4.69. Класс TFormOption (Настройки формы)

Имена объектов класса генерируются.

5.9.4.69.1. Свойства

Свойства класса TFormOption:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Option

TOption

Да

Видимо пользователю

Чтение/Запись

Настройка

Position

Integer

Нет

Видимо пользователю

Чтение/Запись

Позиция

ShowEmptyValue

Boolean

Да

Видимо пользователю

Чтение/Запись

Показывать пустое значение

5.9.4.69.2. Конструктор Create (Конструктор настройки формы)

Конструктор класса TFormOption.
1constructor TFormOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Option: TOption; Position: Integer; ShowEmptyValue: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Option

TOption

Да

Настройка

Position

Integer

Нет

Позиция

ShowEmptyValue

Boolean

Да

Показывать пустое значение

Замечания:

Создает новый объект класса TFormOption.

5.9.4.69.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormOption.
class function TFormOption.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Да

Мастер

Замечания:

Возвращает значение типа Integer.

5.9.4.70. Класс TFormView (Представления формы)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

5.9.4.70.1. Свойства

Свойства класса TFormView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления минимизированы

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство выделенного шрифта

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство цвета

Layout

TFormViewLayout

Да

Видимо пользователю

Чтение/Запись

Расположение

ChildrenOnTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления на закладках

ExplicitQuery

Boolean

Да

Видимо пользователю

Чтение/Запись

Явный запрос

SpacePercentage

Integer

Нет

Видимо пользователю

Чтение/Запись

Площадь, %

5.9.4.70.2. Конструктор Create (Конструктор представления формы)

Конструктор класса TFormView.
1constructor TFormView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout;
6  ExplicitQuery: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Представление

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

ChildrenOnTabs

Boolean

Да

Дочерние представления на закладках

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

Position

Integer

Да

Позиция

SpacePercentage

Integer

Нет

Площадь, %

Layout

TFormViewLayout

Да

Расположение

ExplicitQuery

Boolean

Да

Явный запрос

Замечания:

Создает новый объект класса TFormView.

5.9.4.70.3. Метод GetName (Сгенерировать имя объекта)

Метод экземпляра класса TFormView.
function TFormView.GetName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

5.9.4.70.4. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TFormView.
class function TFormView.GetNextPos(Parent: TObject; Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Master

TObject

Да

Мастер

Замечания:

Возвращает значение типа Integer.

5.9.4.71. Класс TFormViewAction (Действие-форма)

Объекты класса образуют иерархию.

5.9.4.71.1. Свойства

Свойства класса TFormViewAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Да

Видимо пользователю

Чтение/Запись

Представление формы

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

OverrideMasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Подменить свойство-главное

OverrideDetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Подменить свойство-подчиненное

5.9.4.71.2. Конструктор Create (Конструктор действия-формы)

Конструктор класса TFormViewAction.
1constructor TFormViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  FormView: TFormView; OverrideMasterProperty: TProperty;
5  OverrideDetailProperty: TClassMember): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

FormView

TFormView

Да

Представление формы

OverrideMasterProperty

TProperty

Нет

Подменить свойство-главное свойством

OverrideDetailProperty

TClassMember

Нет

Подменить свойство-подчиненное свойством

Замечания:

Создает новый объект класса TFormViewAction.

5.9.4.72. Класс TImportedReplica (Импортированные реплики)

Объекты класса не именованы.

5.9.4.72.1. Свойства

Свойства класса TImportedReplica:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

CRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма

MetadataCRC

string[8]

Нет

Видимо пользователю

Чтение/Запись

Контрольная сумма метаданных

5.9.4.72.2. Конструктор Create (Конструктор импортированной реплики)

Конструктор класса TImportedReplica.
1constructor TImportedReplica.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CRC: string[8]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

CRC

string[8]

Нет

Контрольная сумма

Замечания:

Создает новый объект класса TImportedReplica.

5.9.4.73. Класс TInlineExpression (Встраиваемое выражение)

5.9.4.73.1. Свойства

Свойства класса TInlineExpression:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Expression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

5.9.4.73.2. Конструктор Create (Конструктор встраиваемого выражения)

Конструктор класса TInlineExpression.
1constructor TInlineExpression.Create(Name: string[30];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Expression: clob; Domain: TDomain): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Expression

clob

Нет

Выражение

Domain

TDomain

Да

Домен

Замечания:

Создает новый объект класса TInlineExpression.

5.9.4.74. Класс TInstantContact (Контакты)

Имена объектов класса генерируются.

5.9.4.74.1. Свойства

Свойства класса TInstantContact:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Владелец

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Владелец - текущий пользователь

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Status

TInstantContactStatus

Да

Видимо пользователю

Чтение/Запись

Статус

BackContact

TInstantContact

Нет

Видимо пользователю

Только для чтения

Ответный контакт

BackContactStatus

TInstantContactStatus

Да

Видимо пользователю

Только для чтения

Состояние ответного контакта

5.9.4.74.2. Конструктор Create (Конструктор контакта)

Конструктор класса TInstantContact.
1constructor TInstantContact.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Status: TInstantContactStatus): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Пользователь

Status

TInstantContactStatus

Да

Статус

Замечания:

Создает новый объект класса TInstantContact.

5.9.4.74.3. Метод AddContact (Добавить контакт)

Метод класса (статический метод) класса TInstantContact.
class function TInstantContact.AddContact(Master: TUser; User: TUser): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TUser

Да

Мастер

User

TUser

Да

Пользователь

Замечания:

Возвращает значение типа TObject.

5.9.4.74.4. Метод LastUsedContact (Получить последний использованный контакт)

Метод класса (статический метод) класса TInstantContact.
class function TInstantContact.LastUsedContact(AUser: TUser): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AUser

TUser

Да

Пользователь

Замечания:

Возвращает значение типа TObject.

5.9.4.75. Класс TInstantMessage (Сообщения)

Объекты класса не именованы.

5.9.4.75.1. Свойства

Свойства класса TInstantMessage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Владелец

User

TUser

Да

Видимо пользователю

Чтение/Запись

Пользователь

Message

string[255]

Да

Видимо пользователю

Только для чтения

Сообщение

DeliveryTime

datetime

Да

Видимо пользователю

Только для чтения

Время доставки

AttachmentType

TInstantMessageAttachmentType (None)

Да

Скрыто от пользователя

Только для чтения

Тип вложения

5.9.4.75.2. Конструктор Create (Конструктор сообщения)

Конструктор класса TInstantMessage.
1constructor TInstantMessage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  User: TUser; Message: string[255]; DeliveryTime: datetime): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Пользователь

Message

string[255]

Да

Сообщение

DeliveryTime

datetime

Нет

Время доставки

Замечания:

Создает новый объект класса TInstantMessage.

5.9.4.75.3. Метод Archive (Отправить в архив)

Метод класса (статический метод) класса TInstantMessage.
1class procedure TInstantMessage.Archive(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

5.9.4.75.4. Метод Clear (Очистить)

Метод класса (статический метод) класса TInstantMessage.
1class procedure TInstantMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

5.9.4.76. Класс TInstantMessageAttachment (Сообщения с вложением)

Объекты класса не именованы.

5.9.4.76.1. Свойства

Свойства класса TInstantMessageAttachment:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Owner

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TInstantMessage

User

TUser

Да

Видимо пользователю

Чтение/Запись

Message

string[255]

Да

Видимо пользователю

Только для чтения

DeliveryTime

datetime

Да

Видимо пользователю

Только для чтения

AttachmentType

TInstantMessageAttachmentType

Да

Видимо пользователю

Только для чтения

Тип вложения

FileBody

blob

Нет

Видимо пользователю

Только для чтения

Содержимое файла

FormView

TFormView

Нет

Видимо пользователю

Только для чтения

Представление формы

Form

TForm

Да

Видимо пользователю

Только для чтения

Форма

FormIsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Форма доступна

Object

TObject

Нет

Видимо пользователю

Только для чтения

Объект

HyperLink

string[256]

Нет

Видимо пользователю

Только для чтения

Гиперссылка

5.9.4.76.2. Конструктор Create (Конструктор сообщения с вложением)

Конструктор класса TInstantMessageAttachment.
1constructor TInstantMessageAttachment.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; User: TUser; Message: string[255];
4  DeliveryTime: datetime; FileName: string[255]; FileBaseName: string[128];
5  FileBody: blob; FormView: TFormView; Object: TObject; HyperLink: string[256];
6  AttachmentType: TInstantMessageAttachmentType): TObject;
Переопределяет метод в TInstantMessage.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

User

TUser

Да

Унаследовано от TInstantMessage.Create

Message

string[255]

Да

DeliveryTime

datetime

Нет

FileName

string[255]

Нет

Имя файла

FileBaseName

string[128]

Да

Базовое имя файла

FileBody

blob

Нет

Содержимое файла

FormView

TFormView

Нет

Представление

Object

TObject

Нет

Объект

HyperLink

string[256]

Нет

Гиперссылка

AttachmentType

TInstantMessageAttachmentType

Да

Тип приложения

Замечания:

Создает новый объект класса TInstantMessageAttachment.

5.9.4.77. Класс TIntegerDomain (Целые числа)

5.9.4.77.1. Свойства

Свойства класса TIntegerDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

MinValue

Integer

Нет

Видимо пользователю

Чтение/Запись

Минимальное значение

MaxValue

Integer

Нет

Видимо пользователю

Чтение/Запись

Максимальное значение

5.9.4.77.2. Конструктор Create (Конструктор целочисленного домена)

Конструктор класса TIntegerDomain.
1constructor TIntegerDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; MinValue: Integer; MaxValue: Integer): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

MinValue

Integer

Нет

Минимальное значение

MaxValue

Integer

Нет

Максимальное значение

Замечания:

Создает новый объект класса TIntegerDomain.

5.9.4.77.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TIntegerDomain.
function TIntegerDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.78. Класс TLanguage (Языки)

5.9.4.78.1. Свойства

Свойства класса TLanguage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

DatabaseLanguage

Boolean

Да

Видимо пользователю

Только для чтения

По умолчанию

IsCurrent

Boolean

Да

Видимо пользователю

Чтение/Запись

Является текущим

5.9.4.78.2. Конструктор Create (Конструктор языка)

Конструктор класса TLanguage.
1constructor TLanguage.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TLanguage.

5.9.4.78.3. Метод GetCurrentLanguage (Получить текущий язык)

Метод класса (статический метод) класса TLanguage.
class function TLanguage.GetCurrentLanguage: TLanguage;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TLanguage.

5.9.4.78.4. Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TLanguage.
function TLanguage.GetIsCurrent: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.78.5. Метод SetIsCurrent (Установить язык как текущий)

Метод экземпляра класса TLanguage.
procedure TLanguage.SetIsCurrent(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

5.9.4.78.6. Метод Ole-объекта SaveResourceFile (Сохранить файл ресурсов)

Метод Ole-объекта класса TLanguage.

Параметры:

Имя

Тип

Обязательно

Значение

XliffFileName

string[255]

Да

Файл ресурсов

5.9.4.79. Класс TLanguageTranslation (Переводы)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.79.1. Свойства

Свойства класса TLanguageTranslation:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Language

TLanguage

Да

Видимо пользователю

Только для чтения

Язык

DatabaseLanguage

Boolean

Да

Видимо пользователю

Только для чтения

Язык используется по умолчанию

CurrentLanguage

Boolean

Да

Видимо пользователю

Только для чтения

Язык является текущим

Status

TTranslationStatus

Да

Видимо пользователю

Только для чтения

Состояние

OwnerObject

TObject

Нет

Скрыто от пользователя

Только для чтения

Владелец-объект

OwnerObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс объекта-владельца

OwnerField

TField

Нет

Скрыто от пользователя

Только для чтения

Владелец-поле

Owner

string[64]

Нет

Скрыто от пользователя

Только для чтения

Владелец

Translation

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Перевод

Original

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Оригинал

Identifier

string[2000]

Нет

Видимо пользователю

Только для чтения

Идентификатор

GlobalIdentifier

string[2000]

Нет

Видимо пользователю

Только для чтения

Глобальный идентификатор

5.9.4.79.2. Конструктор Create (Конструктор перевода)

Конструктор класса TLanguageTranslation.
1constructor TLanguageTranslation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Language: TLanguage; OwnerObject: TObject;
4  OwnerField: TField; Owner: string[64]; Translation: string[2000]): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Language

TLanguage

Да

Язык

OwnerObject

TObject

Нет

Владелец-объект

OwnerField

TField

Нет

Владелец-поле

Owner

string[64]

Нет

Владелец

Translation

string[2000]

Нет

Перевод

Замечания:

Создает новый объект класса TLanguageTranslation.

5.9.4.79.3. Метод Add (Создать набор переводов)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.Add(Owner: string[64];
2  Original: string[2000]): TLanguageTranslation;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Owner

string[64]

Да

Идентификатор

Original

string[2000]

Нет

Оригинал

Замечания:

Возвращает значение типа TLanguageTranslation.

5.9.4.79.4. Метод Append (Добавить перевод)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.Append(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]): TLanguageTranslation;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

AValue

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TLanguageTranslation.

5.9.4.79.5. Метод GetGlobalIdent (Получить глобальный идентификатор)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetGlobalIdent: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.79.6. Метод GetIdent (Получить идентификатор)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetIdent: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.79.7. Метод GetLanguageTranslation (Получить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.
1class function TLanguageTranslation.GetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

Замечания:

Возвращает значение типа string[2000].

5.9.4.79.8. Метод GetOriginal (Получить оригинал)

Метод экземпляра класса TLanguageTranslation.
function TLanguageTranslation.GetOriginal: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.79.9. Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TLanguageTranslation.
class function TLanguageTranslation.GetResource(AOwner: string[64]): string[2000];
Переопределяет метод в TObject.GetResource.

Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

Замечания:

Возвращает значение типа string[2000].

5.9.4.79.10. Метод Load (Загрузить значение)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.Load(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

5.9.4.79.11. Метод MarkAsTranslatable (Отметить как переводимый)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.MarkAsTranslatable;
Метод не имеет параметров.

5.9.4.79.12. Метод MarkAsUntranslatable (Отметить как непереводимый)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.MarkAsUntranslatable;
Метод не имеет параметров.

5.9.4.79.13. Метод SetLanguageTranslation (Установить перевод на языке)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.SetLanguageTranslation(ALanguage: TLanguage;
2  AOwner: string[64]; AOwnerObject: TObject; AOwnerField: TField;
3  AValue: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ALanguage

TLanguage

Да

Язык

AOwner

string[64]

Нет

Владелец

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

AValue

string[2000]

Нет

Значение

5.9.4.79.14. Метод SetOriginal (Установить оригинал)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.SetOriginal(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

5.9.4.79.15. Метод SetOwnerSecurity (Установить атрибуты безопасности по владельцу-объекту)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.SetOwnerSecurity(AOwnerObject: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwnerObject

TObject

Нет

Владелец-объект

5.9.4.79.16. Метод SetTranslation (Установить перевод)

Метод экземпляра класса TLanguageTranslation.
procedure TLanguageTranslation.SetTranslation(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

5.9.4.79.17. Метод Validate (Актуализировать)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.Validate(ValidateResources: Boolean;
2  ValidateData: Boolean; ValidateClass: TClass; ValidateField: TField);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ValidateResources

Boolean

Да

Актуализировать ресурсы

ValidateData

Boolean

Да

Актуализировать данные

ValidateClass

TClass

Нет

Актуализировать объекты класса

ValidateField

TField

Нет

Актуализировать значения поля

5.9.4.79.18. Метод ValidateAllObjects (Актуализировать все объекты)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.ValidateAllObjects(ValidateClass: TClass;
2  ValidateField: TField);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ValidateClass

TClass

Нет

Актуализировать объекты класса

ValidateField

TField

Нет

Актуализировать значения поля

5.9.4.79.19. Метод ValidateObject (Актуализировать объект)

Метод класса (статический метод) класса TLanguageTranslation.
1class procedure TLanguageTranslation.ValidateObject(AOwnerObject: TObject;
2  AOwnerField: TField);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwnerObject

TObject

Нет

Владелец-объект

AOwnerField

TField

Нет

Владелец-поле

5.9.4.79.20. Метод ValidateOwned (Актуализировать имеющих владельца)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.ValidateOwned;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

5.9.4.79.21. Метод ValidateOwner (Актуализировать по владельцу)

Метод класса (статический метод) класса TLanguageTranslation.
class procedure TLanguageTranslation.ValidateOwner(AOwner: string[64]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

5.9.4.80. Класс TMethod (Методы)

5.9.4.80.1. Свойства

Свойства класса TMethod:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Body

clob

Нет

Видимо пользователю

Чтение/Запись

Тело

CallTemplate

string[2000]

Нет

Видимо пользователю

Только для чтения

Шаблон вызова

Virtual

Boolean

Да

Видимо пользователю

Чтение/Запись

Виртуальный

DBMSName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта СУБД

5.9.4.80.2. Конструктор Create (Конструктор метода)

Конструктор класса TMethod.
1constructor TMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; Body: clob;
6  Virtual: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

Body

clob

Нет

Тело

Virtual

Boolean

Да

Метод является виртуальным

Замечания:

Создает новый объект класса TMethod.

5.9.4.80.3. Метод Call (Вызвать)

Метод экземпляра класса TMethod.
procedure TMethod.Call(Parameters: TObjectList);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Parameters

TObjectList

Нет

Параметры

5.9.4.80.4. Метод CallTemplate (Шаблон вызова)

Метод экземпляра класса TMethod.
function TMethod.CallTemplate: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.80.5. Метод GetDBMSName (Получить имя объекта СУБД)

Метод экземпляра класса TMethod.
function TMethod.GetDBMSName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

5.9.4.80.6. Метод VirtualChainRoot (Корень виртуальной цепи)

Метод экземпляра класса TMethod.
function TMethod.VirtualChainRoot: TMethod;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TMethod.

5.9.4.81. Класс TObject (Объекты)

5.9.4.81.1. Свойства

Свойства класса TObject:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Имя

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Наименование

Class

TClass

Да

Скрыто от пользователя

Только для чтения

Класс

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Статус репликации

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Родитель

Master

TObject

Да

Скрыто от пользователя

Только для чтения

Мастер

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

База данных-источник

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

GUID базы данных-источника

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

База данных-источник является текущей

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Идентификатор при создании

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Создано пользователем

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Создано

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Изменено пользователем

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Изменено

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Роль для чтения

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Роль для записи

5.9.4.81.2. Конструктор Create (Конструктор объекта)

Конструктор класса TObject.
1constructor TObject.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Class

TClass

Нет

Класс

Parent

TObject

Нет

Родитель

Master

TObject

Да

Мастер

Accessor

TSecurityAccount

Нет

Роль доступа

Замечания:

Создает новый объект класса TObject.

5.9.4.81.3. Деструктор Destroy (Деструктор объекта)

Деструктор класса TObject.
destructor TObject.Destroy;
Метод не имеет параметров.

Замечания:

Уничтожает объект класса TObject или его наследника.

5.9.4.81.4. Метод ApplyStringBuilder (Применить шаблон)

Метод экземпляра класса TObject.
function TObject.ApplyStringBuilder(Template: string[2000]): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.5. Метод ApplyStringBuilderClob (Применить шаблон-большой текстовый объект)

Метод экземпляра класса TObject.
function TObject.ApplyStringBuilderClob(Template: string[2000]): clob;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа clob.

5.9.4.81.6. Метод ASCII (ASCII-код)

Метод класса (статический метод) класса TObject.
class function TObject.ASCII(Value: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

5.9.4.81.7. Метод Assigned (Проверка пустоты значения)

Метод класса (статический метод) класса TObject.
class function TObject.Assigned(Value: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.8. Метод BlobToClob (Большой двоичный объект в большой текстовый объект)

Метод класса (статический метод) класса TObject.
class function TObject.BlobToClob(Value: blob): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

blob

Нет

Значение

Замечания:

Возвращает значение типа clob.

5.9.4.81.9. Метод BoolToStr (Логическое значение в строку)

Метод класса (статический метод) класса TObject.
1class function TObject.BoolToStr(Value: Boolean;
2  Domain: TBooleanDomain): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

Domain

TBooleanDomain

Нет

Домен

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.10. Метод Change (Изменение объекта)

Метод экземпляра класса TObject.
procedure TObject.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

5.9.4.81.11. Метод Char (Символ)

Метод класса (статический метод) класса TObject.
class function TObject.Char(Value: Integer): string[2];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2].

5.9.4.81.12. Метод ClobReplace (Заменить содержимое большого текстового объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.ClobReplace(Value: clob; OldPattern: string[2000];
2  NewPattern: string[2000]; ReplaceAll: Boolean): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

OldPattern

string[2000]

Нет

Старый шаблон

NewPattern

string[2000]

Нет

Новый шаблон

ReplaceAll

Boolean

Да

Заменять все

Замечания:

Возвращает значение типа clob.

5.9.4.81.13. Метод ClobToBlob (Большой текстовый объект в большой двоичный объект)

Метод класса (статический метод) класса TObject.
class function TObject.ClobToBlob(Value: clob): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа blob.

5.9.4.81.14. Метод Concatenate (Управляемая конкатенация строк)

Метод класса (статический метод) класса TObject.
1class function TObject.Concatenate(Value: string[2000]; AddOn: string[2000];
2  MaxLength: Integer; Delimiter: string[2000]; Ellipsis: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

AddOn

string[2000]

Нет

Присоединяемая строка

MaxLength

Integer

Да

Максимальная длина

Delimiter

string[2000]

Нет

Разделитель

Ellipsis

Boolean

Да

Эллипсис

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.15. Метод Copy (Копировать)

Метод класса (статический метод) класса TObject.
1class function TObject.Copy(String: string[2000]; StartPos: Integer;
2  Length: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

String

string[2000]

Нет

Строка

StartPos

Integer

Нет

Позиция

Length

Integer

Нет

Длина

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.16. Метод CopyClob (Копировать из большого текстового объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.CopyClob(Value: clob; StartPos: Integer;
2  Length: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

StartPos

Integer

Нет

Позиция

Length

Integer

Нет

Длина

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.17. Метод CreateGUID (Создать GUID)

Метод класса (статический метод) класса TObject.
class function TObject.CreateGUID: string[38];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[38].

5.9.4.81.18. Метод DateOf (Дату из даты со временем)

Метод класса (статический метод) класса TObject.
class function TObject.DateOf(Value: datetime): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа date.

5.9.4.81.19. Метод DatePart (Часть даты)

Метод класса (статический метод) класса TObject.
class function TObject.DatePart(Value: date; Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

5.9.4.81.20. Метод DateTimePart (Часть даты со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.DateTimePart(Value: datetime;
2  Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

5.9.4.81.21. Метод DateTimeToStr (Дату и время в строку)

Метод класса (статический метод) класса TObject.
class function TObject.DateTimeToStr(Value: datetime): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Да

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.22. Метод DateToStr (Дату в строку)

Метод класса (статический метод) класса TObject.
class function TObject.DateToStr(Value: date): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.23. Метод Dequeue (Удалить из очереди)

Метод экземпляра класса TObject.
procedure TObject.Dequeue(Permanently: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Permanently

Boolean

Да

Удалить навсегда

5.9.4.81.24. Метод DescribeObject (Описание объекта для сообщений пользователю)

Метод экземпляра класса TObject.
function TObject.DescribeObject: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.25. Метод DumpString (Строка в виде списка кодов символов)

Метод класса (статический метод) класса TObject.
1class function TObject.DumpString(Value: string[2000]; Delimiter: string[2000];
2  Hexadecimal: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Hexadecimal

Boolean

Да

Использовать шестнадцатеричные значения

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.26. Метод Ellipsis (Эллипсис)

Метод класса (статический метод) класса TObject.
1class function TObject.Ellipsis(Value: string[2000]; MaxLength: Integer;
2  WholeWords: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

WholeWords

Boolean

Да

По целым словам

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.27. Метод EncodeDate (Собрать дату)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeDate(Year: Integer; Month: Integer;
2  Day: Integer): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Year

Integer

Нет

Год

Month

Integer

Нет

Месяц

Day

Integer

Нет

День

Замечания:

Возвращает значение типа date.

5.9.4.81.28. Метод EncodeDateTime (Собрать дату со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeDateTime(Year: Integer; Month: Integer;
2  Day: Integer; Hours: Integer; Minutes: Integer; Seconds: Integer): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Year

Integer

Нет

Год

Month

Integer

Нет

Месяц

Day

Integer

Нет

День

Hours

Integer

Нет

Часы

Minutes

Integer

Нет

Минуты

Seconds

Integer

Нет

Секунды

Замечания:

Возвращает значение типа datetime.

5.9.4.81.29. Метод EncodeTime (Собрать время)

Метод класса (статический метод) класса TObject.
1class function TObject.EncodeTime(Hours: Integer; Minutes: Integer;
2  Seconds: Integer): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Hours

Integer

Нет

Часы

Minutes

Integer

Нет

Минуты

Seconds

Integer

Нет

Секунды

Замечания:

Возвращает значение типа time.

5.9.4.81.30. Метод Enqueue (Поставить в очередь)

Метод экземпляра класса TObject.
function TObject.Enqueue(QueueName: string[64]): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

QueueName

string[64]

Да

Имя очереди

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.31. Метод Find (Поиск объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.Find(Name: string[64]; Class: TClass; Parent: TObject;
2  Master: TObject): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Class

TClass

Нет

Класс объекта

Parent

TObject

Нет

Родительский объект

Master

TObject

Да

Мастер объекта

Замечания:

Возвращает значение типа TObject.

5.9.4.81.32. Метод FindGlobal (Глобальный поиск объекта)

Метод класса (статический метод) класса TObject.
1class function TObject.FindGlobal(SourceDataBaseGUID: string[38];
2  OldID: string[38]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

SourceDataBaseGUID

string[38]

Да

GUID базы данных-источника

OldID

string[38]

Да

Идентификатор при создании

Замечания:

Возвращает значение типа TObject.

5.9.4.81.33. Метод FloatToStr (Вещественное в строку)

Метод класса (статический метод) класса TObject.
class function TObject.FloatToStr(Value: float): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.34. Метод FormatDate (Форматировать дату)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatDate(Value: date;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.35. Метод FormatDateTime (Форматировать дату со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatDateTime(Value: datetime;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.36. Метод FormatFloat (Форматировать вещественное значение)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatFloat(Value: float; DecimalPlaces: Integer;
2  DecimalSeparator: string[2]; GroupSeparator: string[2]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

DecimalPlaces

Integer

Нет

Количество десятичных знаков

DecimalSeparator

string[2]

Нет

Десятичный разделитель

GroupSeparator

string[2]

Нет

Разделитель групп разрядов

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.37. Метод FormatTime (Форматировать время)

Метод класса (статический метод) класса TObject.
1class function TObject.FormatTime(Value: time;
2  Format: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Format

string[2000]

Нет

Формат

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.38. Метод GenerateAllNames (Сгенерировать имена для всех объектов)

Метод класса (статический метод) класса TObject.
class function TObject.GenerateAllNames: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.81.39. Метод GeneratedDescription (Сгенерированное наименование)

Метод экземпляра класса TObject.
function TObject.GeneratedDescription: string[128];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].

5.9.4.81.40. Метод GeneratedName (Сгенерированное имя)

Метод экземпляра класса TObject.
function TObject.GeneratedName: string[64];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

5.9.4.81.41. Метод GetBlobSize (Размер большого двоичного объекта)

Метод класса (статический метод) класса TObject.
class function TObject.GetBlobSize(Value: blob): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

blob

Нет

Значение

Замечания:

Возвращает значение типа Integer.

5.9.4.81.42. Метод GetChildCount (Получить количество дочерних объектов)

Метод экземпляра класса TObject.
function TObject.GetChildCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.81.43. Метод GetClobSize (Размер большого текстового объекта)

Метод класса (статический метод) класса TObject.
class function TObject.GetClobSize(Value: clob): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа Integer.

5.9.4.81.44. Метод GetDescendantCount (Получить количество объектов-потомков)

Метод экземпляра класса TObject.
function TObject.GetDescendantCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.81.45. Метод GetDetailCount (Получить количество подчиненных объектов)

Метод экземпляра класса TObject.
function TObject.GetDetailCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.81.46. Метод GetLevel (Уровень в иерархии)

Метод экземпляра класса TObject.
function TObject.GetLevel: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.81.47. Метод GetResource (Получить ресурсную строку)

Метод класса (статический метод) класса TObject.
class function TObject.GetResource(AOwner: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.48. Метод GetRoot (Получить корень иерархии)

Метод экземпляра класса TObject.
function TObject.GetRoot: TObject;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.

5.9.4.81.49. Метод GetTop (Получить объект верхнего уровня)

Метод экземпляра класса TObject.
function TObject.GetTop: TObject;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObject.

5.9.4.81.50. Метод HasAsChild (Объект является ребенком данного)

Метод экземпляра класса TObject.
function TObject.HasAsChild(Child: TObject): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Child

TObject

Нет

Дочерний объект

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.51. Метод HasAsParent (Объект является родителем данного)

Метод экземпляра класса TObject.
function TObject.HasAsParent(Parent: TObject): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.52. Метод HasChildren (Имеет детей)

Метод экземпляра класса TObject.
function TObject.HasChildren: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.53. Метод HasDetails (Имеет подчиненные объекты)

Метод экземпляра класса TObject.
function TObject.HasDetails: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.54. Метод Hash (Хеш-функция конца строки)

Метод класса (статический метод) класса TObject.
1class function TObject.Hash(Value: string[2000];
2  MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.55. Метод HashReverse (Хеш-функция начала строки)

Метод класса (статический метод) класса TObject.
1class function TObject.HashReverse(Value: string[2000];
2  MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.56. Метод HexToInt (Шестнадцатеричное представление в целое число)

Метод класса (статический метод) класса TObject.
class function TObject.HexToInt(Hexadecimal: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Hexadecimal

string[64]

Да

Шестнадцатеричное значение

Замечания:

Возвращает значение типа Integer.

5.9.4.81.57. Метод IfThenDate (Выбор из двух дат)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenDate(Value: Boolean; ATrue: date;
2  AFalse: date): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

date

Нет

Значение при выполнении условия

AFalse

date

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа date.

5.9.4.81.58. Метод IfThenDateTime (Выбор из двух дат со временем)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenDateTime(Value: Boolean; ATrue: datetime;
2  AFalse: datetime): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

datetime

Нет

Значение при выполнении условия

AFalse

datetime

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа datetime.

5.9.4.81.59. Метод IfThenExternalData (Выбор из двух значений - внешних данных)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenExternalData(Value: Boolean; ATrue: <external
2  data>; AFalse: <external data>): <external data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

<external data>

Нет

Значение при выполнении условия

AFalse

<external data>

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа <external data>.

5.9.4.81.60. Метод IfThenFloat (Выбор из двух вещественных)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenFloat(Value: Boolean; ATrue: float;
2  AFalse: float): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

float

Нет

Значение при выполнении условия

AFalse

float

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа float.

5.9.4.81.61. Метод IfThenInt (Выбор из двух целых)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenInt(Value: Boolean; ATrue: Integer;
2  AFalse: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

Integer

Нет

Значение при выполнении условия

AFalse

Integer

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа Integer.

5.9.4.81.62. Метод IfThenObject (Выбор из двух объектов)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenObject(Value: Boolean; ATrue: TObject;
2  AFalse: TObject): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

TObject

Нет

Значение при выполнении условия

AFalse

TObject

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа TObject.

5.9.4.81.63. Метод IfThenStr (Выбор из двух строк)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenStr(Value: Boolean; ATrue: string[2000];
2  AFalse: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

string[2000]

Нет

Значение при выполнении условия

AFalse

string[2000]

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.64. Метод IfThenTime (Выбор из двух времен)

Метод класса (статический метод) класса TObject.
1class function TObject.IfThenTime(Value: Boolean; ATrue: time;
2  AFalse: time): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

ATrue

time

Нет

Значение при выполнении условия

AFalse

time

Нет

Значение при невыполнении условия

Замечания:

Возвращает значение типа time.

5.9.4.81.65. Метод InstanceObject (Объект по строковому представлению идентификатора (объект может не существовать))

Метод класса (статический метод) класса TObject.
class function TObject.InstanceObject(Value: string[38]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[38]

Да

Значение

Замечания:

Возвращает значение типа TObject.

5.9.4.81.66. Метод IntToHex (Целое число в шестнадцатеричное представление)

Метод класса (статический метод) класса TObject.
class function TObject.IntToHex(IntValue: Integer): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

IntValue

Integer

Нет

Целое значение

Замечания:

Возвращает значение типа string[64].

5.9.4.81.67. Метод IntToStr (Целое в строку)

Метод класса (статический метод) класса TObject.
class function TObject.IntToStr(Value: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.68. Метод IsBadHierarchy (Ошибка в иерархии)

Метод экземпляра класса TObject.
function TObject.IsBadHierarchy: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.69. Метод IsBadPtr (Не указывает на существующий объект)

Метод экземпляра класса TObject.
function TObject.IsBadPtr: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.70. Метод IsCharAlpha (Символ является алфавитным)

Метод класса (статический метод) класса TObject.
class function TObject.IsCharAlpha(Value: string[2]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.71. Метод IsCharAlphaNumeric (Символ является алфавитно-числовым)

Метод класса (статический метод) класса TObject.
class function TObject.IsCharAlphaNumeric(Value: string[2]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.72. Метод IsInList (Объект входит в список)

Метод экземпляра класса TObject.
function TObject.IsInList(Value: TObjectList): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectList

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.73. Метод IsInSet (Объект входит в множество)

Метод экземпляра класса TObject.
function TObject.IsInSet(Value: TObjectSet): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.74. Метод IsInstanceOf (Является экземпляром класса)

Метод экземпляра класса TObject.
function TObject.IsInstanceOf(Class: TClass): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Class

TClass

Нет

Класс

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.75. Метод IsNotInList (Объект не входит в список)

Метод экземпляра класса TObject.
function TObject.IsNotInList(Value: TObjectList): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectList

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.76. Метод IsNotInSet (Объект не входит в множество)

Метод экземпляра класса TObject.
function TObject.IsNotInSet(Value: TObjectSet): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.77. Метод LineBreak (Разделитель строк)

Метод класса (статический метод) класса TObject.
class function TObject.LineBreak: string[2];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2].

5.9.4.81.78. Метод LinkClobs (Присоединить большой объект к другому)

Метод класса (статический метод) класса TObject.
class function TObject.LinkClobs(PrefData: clob; PostData: clob): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

PrefData

clob

Нет

Данные первого объекта

PostData

clob

Нет

Данные второго объекта

Замечания:

Возвращает значение типа clob.

5.9.4.81.79. Метод LinkToClob (Присоединить строки к большому объекту)

Метод класса (статический метод) класса TObject.
1class function TObject.LinkToClob(Prefix: string[2000]; Data: clob;
2  Postfix: string[2000]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Prefix

string[2000]

Нет

Префикс

Data

clob

Нет

Данные

Postfix

string[2000]

Нет

Постфикс

Замечания:

Возвращает значение типа clob.

5.9.4.81.80. Метод Locate (Поиск объекта по локатору)

Метод класса (статический метод) класса TObject.
class function TObject.Locate(Locator: string[2000]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Locator

string[2000]

Нет

Локатор

Замечания:

Возвращает значение типа TObject.

5.9.4.81.81. Метод Locator (Локатор объекта)

Метод экземпляра класса TObject.
function TObject.Locator: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.82. Метод LowerCase (Преобразовать к нижнему регистру)

Метод класса (статический метод) класса TObject.
class function TObject.LowerCase(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.83. Метод MatchRegExp (Проверка соответствия строки регулярному выражению)

Метод класса (статический метод) класса TObject.
1class function TObject.MatchRegExp(Value: string[2000];
2  RegExp: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

RegExp

string[2000]

Нет

Регулярное выражение

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.84. Метод MergeIdentifiers (Объединенный идентификатор)

Метод класса (статический метод) класса TObject.
1class function TObject.MergeIdentifiers(Identifier: string[64];
2  Modifier: string[64]; MaxLength: Integer): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Identifier

string[64]

Да

Идентификатор

Modifier

string[64]

Да

Модификатор

MaxLength

Integer

Да

Максимальная длина

Замечания:

Возвращает значение типа string[64].

5.9.4.81.85. Метод MergeTo (Отождествить с)

Метод экземпляра класса TObject.
procedure TObject.MergeTo(PrimaryObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

PrimaryObject

TObject

Да

Первичный объект

5.9.4.81.86. Метод Modulus (Остаток деления)

Метод класса (статический метод) класса TObject.
class function TObject.Modulus(Value: Integer; Base: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Делимое

Base

Integer

Нет

Делитель

Замечания:

Возвращает значение типа Integer.

5.9.4.81.87. Метод ObjectInstance (Текстовое представление идентификатора объекта (объект может не существовать))

Метод класса (статический метод) класса TObject.
class function TObject.ObjectInstance(Value: TObject): string[38];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа string[38].

5.9.4.81.88. Метод Pos (Поиск подстроки)

Метод класса (статический метод) класса TObject.
1class function TObject.Pos(Substring: string[2000];
2  Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Substring

string[2000]

Нет

Подстрока

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

5.9.4.81.89. Метод PreprocessRegExp (Адаптировать регулярное выражение к требованиям СУБД)

Метод класса (статический метод) класса TObject.
class function TObject.PreprocessRegExp(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.90. Метод QualifiedName (Квалифицированное имя)

Метод экземпляра класса TObject.
function TObject.QualifiedName: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.91. Метод QuotedStr (Строку в апострофы)

Метод класса (статический метод) класса TObject.
class function TObject.QuotedStr(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.92. Метод RaiseException (Возбудить исключение)

Метод класса (статический метод) класса TObject.
class procedure TObject.RaiseException(Message: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Message

string[2000]

Нет

Сообщение

5.9.4.81.93. Метод RaiseResource (Возбудить исключение по ресурсной строке)

Метод класса (статический метод) класса TObject.
class procedure TObject.RaiseResource(AOwner: string[64]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AOwner

string[64]

Да

Владелец

5.9.4.81.94. Метод ReadFromClob (Считать строку из большого текстового объекта)

Метод класса (статический метод) класса TObject.
class function TObject.ReadFromClob(Value: clob): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.95. Метод ResourceByItem (Значение ресурсной строки)

Метод класса (статический метод) класса TObject.
class function TObject.ResourceByItem(Resource: Resource strings): string[128];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Resource

Resource strings

Нет

Ресурс

Замечания:

Возвращает значение типа string[128].

5.9.4.81.96. Метод Round (Округление)

Метод класса (статический метод) класса TObject.
class function TObject.Round(Value: float; Decimals: Integer): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Decimals

Integer

Нет

Количество десятичных знаков

Замечания:

Возвращает значение типа float.

5.9.4.81.97. Метод SendInstantMessage (Отправить мгновенное сообщение)

Метод класса (статический метод) класса TObject.
1class procedure TObject.SendInstantMessage(Recipient: TUser;
2  MessageText: string[255]; DeliveryTime: datetime; AttachSelected: Boolean;
3  Selected: TObjectList; CurrentFormView: TFormView; HyperLink: string[256];
4  FileName: string[255]; FileBaseName: string[128]; FileBody: blob;
5  AttachmentType: TInstantMessageAttachmentType);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Recipient

TUser

Да

Получатель

MessageText

string[255]

Да

Сообщение

DeliveryTime

datetime

Нет

Время доставки

AttachSelected

Boolean

Да

Присоединить выбранные объекты

Selected

TObjectList

Нет

Список выбранных

CurrentFormView

TFormView

Нет

Текущее представление формы

HyperLink

string[256]

Нет

Гиперссылка

FileName

string[255]

Нет

Файл

FileBaseName

string[128]

Да

Имя файла (без пути)

FileBody

blob

Нет

Содержимое файла

AttachmentType

TInstantMessageAttachmentType

Да

Тип приложения

5.9.4.81.98. Метод Sleep (Задержка выполнения)

Метод класса (статический метод) класса TObject.
class procedure TObject.Sleep(Seconds: Integer);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Seconds

Integer

Да

Количество секунд

5.9.4.81.99. Метод StringReplace (Заменить содержимое строки)

Метод класса (статический метод) класса TObject.
1class function TObject.StringReplace(Value: string[2000];
2  OldPattern: string[2000]; NewPattern: string[2000];
3  ReplaceAll: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

OldPattern

string[2000]

Нет

Старый шаблон

NewPattern

string[2000]

Нет

Новый шаблон

ReplaceAll

Boolean

Да

Заменять все

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.100. Метод StrLength (Длина строки)

Метод класса (статический метод) класса TObject.
class function TObject.StrLength(String: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

String

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

5.9.4.81.101. Метод StrLike (Сопоставить строку с шаблоном)

Метод класса (статический метод) класса TObject.
1class function TObject.StrLike(Value: string[2000];
2  Pattern: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Pattern

string[2000]

Нет

Шаблон

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.102. Метод StrPad (Заполнить строку)

Метод класса (статический метод) класса TObject.
1class function TObject.StrPad(Value: string[2000]; Padding: string[2000];
2  PadRight: Boolean; MaxLength: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Padding

string[2000]

Нет

Заполнитель

PadRight

Boolean

Да

Заполнять справа

MaxLength

Integer

Нет

Максимальная длина

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.103. Метод StrToBool (Строку в логическое значение)

Метод класса (статический метод) класса TObject.
class function TObject.StrToBool(Value: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.81.104. Метод StrToDate (Строку в дату)

Метод класса (статический метод) класса TObject.
class function TObject.StrToDate(Value: string[2000]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа date.

5.9.4.81.105. Метод StrToDateTime (Строку в дату и время)

Метод класса (статический метод) класса TObject.
class function TObject.StrToDateTime(Value: string[2000]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа datetime.

5.9.4.81.106. Метод StrToFloat (Строку в вещественное)

Метод класса (статический метод) класса TObject.
class function TObject.StrToFloat(Value: string[2000]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа float.

5.9.4.81.107. Метод StrToInt (Строку в целое)

Метод класса (статический метод) класса TObject.
class function TObject.StrToInt(Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

5.9.4.81.108. Метод StrToTime (Строку во время)

Метод класса (статический метод) класса TObject.
class function TObject.StrToTime(Value: string[2000]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа time.

5.9.4.81.109. Метод StrTranslate (Транслировать символы в строке)

Метод класса (статический метод) класса TObject.
1class function TObject.StrTranslate(Value: string[2000];
2  OldChars: string[2000]; NewChars: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

OldChars

string[2000]

Нет

Старый набор символов

NewChars

string[2000]

Нет

Новый набор символов

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.110. Метод StrWrap (Выровнять строку)

Метод класса (статический метод) класса TObject.
1class function TObject.StrWrap(Value: string[2000]; Delimiter: string[2000];
2  MaxCol: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

MaxCol

Integer

Нет

Максимальное количество символов

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.111. Метод SuggestDescription (Предложить наименование)

Метод экземпляра класса TObject.
procedure TObject.SuggestDescription(Description: string[128]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Description

string[128]

Да

Наименование

5.9.4.81.112. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TObject.
function TObject.SuggestFileName(Domain: TDomain): string[128];
Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Домен

Замечания:

Возвращает значение типа string[128].

5.9.4.81.113. Метод TimeOf (Время из даты со временем)

Метод класса (статический метод) класса TObject.
class function TObject.TimeOf(Value: datetime): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа time.

5.9.4.81.114. Метод TimePart (Часть времени)

Метод класса (статический метод) класса TObject.
class function TObject.TimePart(Value: time; Part: TDateTimePart): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Part

TDateTimePart

Да

Часть

Замечания:

Возвращает значение типа Integer.

5.9.4.81.115. Метод TimeToStr (Время в строку)

Метод класса (статический метод) класса TObject.
class function TObject.TimeToStr(Value: time): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.116. Метод Touch (Модификация объекта)

Метод экземпляра класса TObject.
procedure TObject.Touch;
Метод скрыт от пользователя.

Метод не имеет параметров.

5.9.4.81.117. Метод Trim (Убрать лишние пробелы)

Метод класса (статический метод) класса TObject.
class function TObject.Trim(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.118. Метод Trunc (Отсечение дробной части)

Метод класса (статический метод) класса TObject.
class function TObject.Trunc(Value: float): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа Integer.

5.9.4.81.119. Метод UniqueValue (Уникальный идентификатор)

Метод класса (статический метод) класса TObject.
class function TObject.UniqueValue: string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[64].

5.9.4.81.120. Метод UpperCase (Преобразовать к верхнему регистру)

Метод класса (статический метод) класса TObject.
class function TObject.UpperCase(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.121. Метод Ole-объекта CheckSGMLContent (Проверить SGML-содержимое)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Property

TProperty

Да

Свойство

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.122. Метод Ole-объекта ExportAfter (Экспортировать модифицированные)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла-реплики

FromDate

datetime

Нет

Модифицировано после

5.9.4.81.123. Метод Ole-объекта FixSGMLContentErrors (Исправить ошибки SGML-содержимого)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Property

TProperty

Да

Свойство

Замечания:

Возвращает значение типа string[2000].

5.9.4.81.124. Метод Ole-объекта LoadBlobsFromFolder (Загрузить данные из папки)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Property

TProperty

Да

Свойство

Template

string[128]

Да

Шаблон

Замечания:

Возвращает значение типа Integer.

5.9.4.81.125. Метод Ole-объекта SaveBlobsToFolder (Сохранить данные в папку)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Folder

string[255]

Да

Папка

Property

TProperty

Да

Свойство

Template

string[128]

Да

Шаблон

List

TObjectList

Нет

Список объектов

Замечания:

Возвращает значение типа Integer.

5.9.4.81.126. Метод Ole-объекта SplitExcelSheetsToFiles (Разделить Excel листы на файлы)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObject.

Метод Ole-объекта скрыт от пользователя.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

WorkBook

blob

Нет

Книга (объект)

FileName

string[255]

Нет

Имя Excel-файла

FileNameMappingSheetName

string[128]

Нет

Имя листа с сопоставлениями имен файлов (по умолчанию MapSheetNameToFileName)

Folder

string[255]

Да

Каталог

5.9.4.81.127. Шаблон отчета Excel Excel (Перенести в Excel)

Шаблон отчета Excel класса (статический шаблон) класса TObject.

Шаблон отчета Excel является методом класса.

Шаблон отчета Excel не имеет параметров.

5.9.4.81.128. Шаблон отчета Word SpellCheck (Проверка правописания)

Шаблон отчета Word класса (статический шаблон) класса TObject.

Шаблон отчета Word скрыт от пользователя.

Шаблон отчета Word является методом класса.

Шаблон отчета Word не имеет параметров.

5.9.4.81.129. Шаблон XSLT-отчета ObjectInformation (Информация об объекте)

Шаблон XSLT-отчета класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ShowHiddenProps

Boolean

Да

Показывать скрытые свойства

5.9.4.81.130. Шаблон XSLT-отчета SelectDataToText (Выполнить запрос в текст)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

Query

clob

Нет

Запрос

5.9.4.81.131. Шаблон XSLT-отчета SelectDataToXML (Выполнить запрос в xml-документ)

Шаблон XSLT-отчета класса (статический шаблон) класса TObject.

Шаблон XSLT-отчета скрыт от пользователя.

Шаблон отчета Word является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

Query

clob

Нет

Запрос

5.9.4.81.132. Подпрограмма Column (Колонка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.133. Подпрограмма CopyToClipboard (Копировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

5.9.4.81.134. Подпрограмма CurrentFormView (Текущее представление формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.135. Подпрограмма CurrentlySelected (Список выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.136. Подпрограмма CurrentlySelectedSet (Множество выбранных)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.137. Подпрограмма CurrentlyVisible (Список видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.138. Подпрограмма CurrentlyVisibleSet (Множество видимых)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.139. Подпрограмма Dependencies (Зависимости)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

5.9.4.81.140. Подпрограмма Edit columns (Редактировать строку)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

5.9.4.81.141. Подпрограмма Edit filters (Редактировать фильтры)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.142. Подпрограмма Edit properties (Редактировать свойства)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

5.9.4.81.143. Подпрограмма Export (Экспортировать)

Подпрограмма класса TObject.

Подпрограмма не имеет параметров.

5.9.4.81.144. Подпрограмма ExportReport (Выгрузить в отчет)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.145. Подпрограмма FormOptions (Настройки формы)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.146. Подпрограмма Import (Импортировать)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.147. Подпрограмма Merge (Объединить)

Подпрограмма класса TObject.

Подпрограмма скрыта от пользователя.

Подпрограмма не имеет параметров.

5.9.4.81.148. Подпрограмма Messages (Проверить сообщения)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.149. Подпрограмма Options (Настройки)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.150. Подпрограмма Paste (Вставить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.151. Подпрограмма PasteSpecial (Специальная вставка)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.152. Подпрограмма Presentations (Виды)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.153. Подпрограмма Refresh (Обновить)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.154. Подпрограмма Search (Поиск)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.155. Подпрограмма Selection (Выбранные)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.81.156. Подпрограмма Tree (Дерево)

Подпрограмма класса (статическая подпрограмма) класса TObject.

Подпрограмма является методом класса.

Подпрограмма не имеет параметров.

5.9.4.82. Класс TObjectArchive (Архив объектов)

5.9.4.82.1. Свойства

Свойства класса TObjectArchive:

Имя

Тип

Обязательно

Доступ

Назначение

Object

TObject

Да

Только для чтения

Объект

ObjectName

string[64]

Да

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Только для чтения

Наименование объекта

ObjectClass

TClass

Да

Только для чтения

Класс объекта

ObjectParent

TObject

Нет

Только для чтения

Объект-родитель

ObjectMaster

TObject

Да

Только для чтения

Объект-мастер

ObjectSourceDataBase

TDataBase

Да

Только для чтения

База данных-источник

ObjectOldID

string[38]

Да

Только для чтения

Идентификатор объекта при создании

ObjectCreator

TUser

Да

Только для чтения

Объект создан пользователем

ObjectCreated

datetime

Да

Только для чтения

Объект создан

ObjectModifier

TUser

Да

Только для чтения

Объект изменен пользователем

ObjectModified

datetime

Да

Только для чтения

Объект изменен

User

TUser

Да

Только для чтения

Пользователь

UserName

string[64]

Да

Только для чтения

Имя пользователя

5.9.4.82.2. Метод Purge (Очистить архив)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Purge(TimeLimit: time);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeLimit

time

Нет

Лимит времени выполнения

5.9.4.82.3. Метод Put (Положить объект в архив)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Put(Object: TObject);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

5.9.4.82.4. Метод PutAutonomous (Положить объект в архив в автономной транзакции)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.PutAutonomous(Object: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

5.9.4.82.5. Метод Remove (Исключить объект из архива)

Метод класса (статический метод) класса TObjectArchive.
class procedure TObjectArchive.Remove(Object: TObject);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

5.9.4.83. Класс TObjectCreator (Роли-создатели)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.83.1. Свойства

Свойства класса TObjectCreator:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

5.9.4.83.2. Конструктор Create (Конструктор роли-создателя)

Конструктор класса TObjectCreator.
1constructor TObjectCreator.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TObjectCreator.

5.9.4.84. Класс TObjectHistory (История объектов)

5.9.4.84.1. Свойства

Свойства класса TObjectHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Только для чтения

Имя

Description

string[128]

Да

Видимо пользователю

Только для чтения

Наименование

Class

TClass

Да

Видимо пользователю

Только для чтения

Класс

Master

string[2000]

Нет

Видимо пользователю

Только для чтения

Мастер

Parent

string[2000]

Нет

Видимо пользователю

Только для чтения

Родитель

Data

string[2000]

Нет

Видимо пользователю

Только для чтения

Содержимое

Action

TChangeAction

Да

Видимо пользователю

Только для чтения

Действие

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

ObjectOldID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор при создании

ObjectDataBase

TDataBase

Да

Видимо пользователю

Только для чтения

База данных объекта

ObjectID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор объекта

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

FieldName

string[64]

Да

Видимо пользователю

Только для чтения

Поле

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

5.9.4.84.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TObjectHistory.
1class procedure TObjectHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

5.9.4.84.3. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TObjectHistory.
1class procedure TObjectHistory.Log(Object: TObject; Action: TChangeAction;
2  Field: TField; Data: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

Action

TChangeAction

Да

Действие

Field

TField

Нет

Поле

Data

string[2000]

Нет

Содержимое

5.9.4.84.4. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TObjectHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

5.9.4.84.5. Шаблон отчета Excel UserActivityReport (Отчет об активности пользователей)

Шаблон отчета Excel класса (статический шаблон) класса TObjectHistory.

Шаблон отчета Excel является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

UDate

date

Нет

Дата

5.9.4.85. Класс TObjectList (Списки)

Объекты класса не именованы.

5.9.4.85.1. Свойства

Свойства класса TObjectList:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

AsString

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

Список в текстовом представлении

AsClob

clob

Нет

Скрыто от пользователя

Чтение/Запись

Список в виде большого текстового объекта

5.9.4.85.2. Конструктор Create (Конструктор списка)

Конструктор класса TObjectList.
1constructor TObjectList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TObjectList.

5.9.4.85.3. Метод Add (Добавить объект в список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Add(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

5.9.4.85.4. Метод Archive (Отправить список в архив)

Метод экземпляра класса TObjectList.
procedure TObjectList.Archive;
Метод не имеет параметров.

5.9.4.85.5. Метод ArchiveAll (Отправить список в архив со всем содержимым)

Метод экземпляра класса TObjectList.
procedure TObjectList.ArchiveAll;
Метод не имеет параметров.

5.9.4.85.6. Метод ByName (Поиск по имени)

Метод экземпляра класса TObjectList.
function TObjectList.ByName(Name: string[64]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Замечания:

Возвращает значение типа Integer.

5.9.4.85.7. Метод Clear (Очистить список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Clear;
Метод скрыт от пользователя.

Метод не имеет параметров.

5.9.4.85.8. Метод CreateFromClob (Создать список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromClob(Value: clob): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

5.9.4.85.9. Метод CreateFromOrderedClob (Создать упорядоченный список на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromOrderedClob(Value: clob): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

5.9.4.85.10. Метод CreateFromOrderedString (Создать упорядоченный список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromOrderedString(Value: string[2000]): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

5.9.4.85.11. Метод CreateFromString (Создать список на основе текстового представления)

Метод класса (статический метод) класса TObjectList.
class function TObjectList.CreateFromString(Value: string[2000]): TObjectList;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectList.

5.9.4.85.12. Метод Delete (Удалить объект)

Метод экземпляра класса TObjectList.
procedure TObjectList.Delete(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

5.9.4.85.13. Метод DestroyAll (Удалить вместе с содержащимися в списке объектами)

Метод экземпляра класса TObjectList.
procedure TObjectList.DestroyAll;
Метод не имеет параметров.

5.9.4.85.14. Метод Force (Добавить, игнорируя ограничения)

Метод экземпляра класса TObjectList.
procedure TObjectList.Force(ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

5.9.4.85.15. Метод GetAsClob (Получить в виде большого текстового объекта)

Метод экземпляра класса TObjectList.
function TObjectList.GetAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

5.9.4.85.16. Метод GetAsString (Список в текстовом представлении)

Метод экземпляра класса TObjectList.
function TObjectList.GetAsString: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.85.17. Метод GetItem (Получить объект из списка)

Метод экземпляра класса TObjectList.
function TObjectList.GetItem(ItemIndex: Integer): TObject;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

Замечания:

Возвращает значение типа TObject.

5.9.4.85.18. Метод IndexOf (Индекс объекта в списке)

Метод экземпляра класса TObjectList.
function TObjectList.IndexOf(ItemObject: TObject): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

Замечания:

Возвращает значение типа Integer.

5.9.4.85.19. Метод Insert (Вставить объект в список)

Метод экземпляра класса TObjectList.
procedure TObjectList.Insert(ItemIndex: Integer; ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemObject

TObject

Да

Элемент

5.9.4.85.20. Метод IsExcluded (Объект не входит в список)

Метод экземпляра класса TObjectList.
function TObjectList.IsExcluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.85.21. Метод IsIncluded (Объект входит в список)

Метод экземпляра класса TObjectList.
function TObjectList.IsIncluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.85.22. Метод Length (Длина списка)

Метод экземпляра класса TObjectList.
function TObjectList.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.85.23. Метод LoadFromClob (Загрузить содержимое списка из большого текстового объекта)

Метод экземпляра класса TObjectList.
1procedure TObjectList.LoadFromClob(Value: clob; Ordered: Boolean;
2  Clear: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Ordered

Boolean

Да

Сохранить порядок объектов

Clear

Boolean

Да

Очистить перед загрузкой

5.9.4.85.24. Метод LoadFromString (Загрузить содержимое списка из текстового представления)

Метод экземпляра класса TObjectList.
1procedure TObjectList.LoadFromString(Value: string[2000]; Ordered: Boolean;
2  Clear: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Ordered

Boolean

Да

Сохранить порядок объектов

Clear

Boolean

Да

Очистить перед загрузкой

5.9.4.85.25. Метод Remove (Вычистить объект)

Метод экземпляра класса TObjectList.
procedure TObjectList.Remove(ItemObject: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

ItemObject

TObject

Да

Элемент

5.9.4.85.26. Метод Reorder (Перенумеровать объекты в списке)

Метод экземпляра класса TObjectList.
procedure TObjectList.Reorder;
Метод не имеет параметров.

5.9.4.85.27. Метод SetAsClob (Установить список в виде большого текстового объекта)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetAsClob(Value: clob);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

5.9.4.85.28. Метод SetAsString (Установить список в текстовом представлении)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetAsString(Value: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

5.9.4.85.29. Метод SetItem (Установить объект в списке)

Метод экземпляра класса TObjectList.
procedure TObjectList.SetItem(ItemIndex: Integer; ItemObject: TObject);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemObject

TObject

Да

Элемент

5.9.4.86. Класс TObjectListItem (Элементы списков)

5.9.4.86.1. Свойства

Свойства класса TObjectListItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Object

TObject

Да

Видимо пользователю

Только для чтения

Объект

Position

Integer

Да

Видимо пользователю

Только для чтения

Позиция

5.9.4.86.2. Конструктор Create (Конструктор элемента списка)

Конструктор класса TObjectListItem.
1constructor TObjectListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ItemObject: TObject; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ItemObject

TObject

Да

Элемент

Position

Integer

Нет

Позиция

Замечания:

Создает новый объект класса TObjectListItem.

5.9.4.87. Класс TObjectSet (Множества объектов)

5.9.4.87.1. Конструктор Create (Создать множество)

Конструктор класса TObjectSet.
constructor TObjectSet.Create: TObjectSet;
Метод не имеет параметров.

Замечания:

Создает новый объект класса TObjectSet.

5.9.4.87.2. Метод Add (Добавить множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Add(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

5.9.4.87.3. Метод Change (Изменение объекта)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

5.9.4.87.4. Метод Clear (Очистить множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Clear;
Метод не имеет параметров.

5.9.4.87.5. Метод Clone (Клонировать множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.Clone: TObjectSet;
Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectSet.

5.9.4.87.6. Метод CreateFromClob (Создать множество на основе большого текстового объекта)

Метод класса (статический метод) класса TObjectSet.
class function TObjectSet.CreateFromClob(Value: clob): TObjectSet;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TObjectSet.

5.9.4.87.7. Метод CreateFromString (Создать множество на основе строки)

Метод класса (статический метод) класса TObjectSet.
class function TObjectSet.CreateFromString(Value: string[2000]): TObjectSet;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TObjectSet.

5.9.4.87.8. Метод Exclude (Исключить объект из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Exclude(Value: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

5.9.4.87.9. Метод ExcludeClob (Исключить содержимое большого текстового объекта из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.ExcludeClob(Value: clob);
Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

5.9.4.87.10. Метод ExcludeString (Исключить содержимое строки из множества)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.ExcludeString(Value: string[2000]);
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

5.9.4.87.11. Метод GetAsClob (Множество в виде большого текстового объекта)

Метод экземпляра класса TObjectSet.
function TObjectSet.GetAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

5.9.4.87.12. Метод GetAsString (Множество в виде строки)

Метод экземпляра класса TObjectSet.
function TObjectSet.GetAsString: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.87.13. Метод Include (Включить объект в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Include(Value: TObject);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

5.9.4.87.14. Метод IncludeClob (Включить содержимое большого текстового объекта в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.IncludeClob(Value: clob);
Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

5.9.4.87.15. Метод IncludeString (Включить содержимое строки в множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.IncludeString(Value: string[2000]);
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

5.9.4.87.16. Метод IsExcluded (Объект не входит в множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.IsExcluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.87.17. Метод IsIncluded (Объект входит в множество)

Метод экземпляра класса TObjectSet.
function TObjectSet.IsIncluded(Value: TObject): Boolean;
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа Boolean.

5.9.4.87.18. Метод Length (Количество элементов)

Метод экземпляра класса TObjectSet.
function TObjectSet.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.87.19. Метод Multiply (Умножить на множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Multiply(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

5.9.4.87.20. Метод Subtract (Вычесть множество)

Метод экземпляра класса TObjectSet.
procedure TObjectSet.Subtract(Value: TObjectSet);
Параметры:

Имя

Тип

Обязательно

Значение

Value

TObjectSet

Нет

Значение

5.9.4.88. Класс TOleObjectMethod (Метод Ole-объекта)

5.9.4.88.1. Свойства

Свойства класса TOleObjectMethod:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

ClassID

string[128]

Нет

Видимо пользователю

Чтение/Запись

Идентификатор класса

Method

string[128]

Нет

Видимо пользователю

Чтение/Запись

Метод

CodeLibrary

TAccessibleFile

Нет

Видимо пользователю

Чтение/Запись

Библиотека кода

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

5.9.4.88.2. Конструктор Create (Конструктор метода Ole-объекта)

Конструктор класса TOleObjectMethod.
1constructor TOleObjectMethod.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; CodeLibrary: TAccessibleFile;
6  ClassID: string[128]; Method: string[128]; IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

CodeLibrary

TAccessibleFile

Нет

Библиотека кода

ClassID

string[128]

Нет

Идентификатор класса

Method

string[128]

Нет

Метод

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TOleObjectMethod.

5.9.4.88.3. Метод Ole-объекта CheckOleObjectMethod (Проверить метод Ole-объекта)

Метод Ole-объекта класса TOleObjectMethod.

Метод Ole-объекта не имеет параметров.

5.9.4.89. Класс TOption (Настройки)

5.9.4.89.1. Свойства

Свойства класса TOption:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Global

Boolean

Да

Видимо пользователю

Чтение/Запись

Глобальная

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Value

TOptionValue

Нет

Скрыто от пользователя

Только для чтения

Значение

User

TUser

Нет

Видимо пользователю

Чтение/Запись

Пользователь

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

Видимое значение

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

5.9.4.89.2. Конструктор Create (Конструктор настройки)

Конструктор класса TOption.
1constructor TOption.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Global: Boolean; Group: string[128]; Tab: string[128];
4  Position: Integer; Scope: TScope): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Global

Boolean

Да

Глобальная

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Position

Integer

Нет

Позиция

Scope

TScope

Да

Область видимости

Замечания:

Создает новый объект класса TOption.

5.9.4.89.3. Метод AreValid (Настройки действительны)

Метод класса (статический метод) класса TOption.
class function TOption.AreValid: Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.89.4. Метод GetBlobValue (Значение-большой объект)

Метод класса (статический метод) класса TOption.
class function TOption.GetBlobValue(OptionName: string[64]): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа blob.

5.9.4.89.5. Метод GetBoolValue (Логическое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetBoolValue(OptionName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа Boolean.

5.9.4.89.6. Метод GetClobValue (Значение-текст)

Метод класса (статический метод) класса TOption.
class function TOption.GetClobValue(OptionName: string[64]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа clob.

5.9.4.89.7. Метод GetDateTimeValue (Значение даты со временем)

Метод класса (статический метод) класса TOption.
class function TOption.GetDateTimeValue(OptionName: string[64]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа datetime.

5.9.4.89.8. Метод GetDateValue (Значение даты)

Метод класса (статический метод) класса TOption.
class function TOption.GetDateValue(OptionName: string[64]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа date.

5.9.4.89.9. Метод GetExternalDataValue (Значение внешних данных)

Метод класса (статический метод) класса TOption.
1class function TOption.GetExternalDataValue(OptionName: string[64]): <external
2  data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа <external data>.

5.9.4.89.10. Метод GetFloatValue (Вещественное значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetFloatValue(OptionName: string[64]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа float.

5.9.4.89.11. Метод GetIntValue (Целое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetIntValue(OptionName: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа Integer.

5.9.4.89.12. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TOption.
class function TOption.GetNextPos: Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.89.13. Метод GetObjectValue (Значение-объект)

Метод класса (статический метод) класса TOption.
class function TOption.GetObjectValue(OptionName: string[64]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа TObject.

5.9.4.89.14. Метод GetStrValue (Строковое значение)

Метод класса (статический метод) класса TOption.
class function TOption.GetStrValue(OptionName: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа string[2000].

5.9.4.89.15. Метод GetTimeValue (Значение времени)

Метод класса (статический метод) класса TOption.
class function TOption.GetTimeValue(OptionName: string[64]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

OptionName

string[64]

Да

Имя настройки

Замечания:

Возвращает значение типа time.

5.9.4.89.16. Метод GetValue (Значение)

Метод экземпляра класса TOption.
function TOption.GetValue: TOptionValue;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TOptionValue.

5.9.4.89.17. Метод SetValue (Установка значения)

Метод экземпляра класса TOption.
1procedure TOption.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>; Default: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Default

Boolean

Да

По умолчанию

5.9.4.90. Класс TOptionValue (Значения настроек)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.90.1. Свойства

Свойства класса TOptionValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

User

TUser

Нет

Видимо пользователю

Чтение/Запись

Пользователь

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущим

Option

TOption

Да

Скрыто от пользователя

Только для чтения

Настройка

Domain

TDomain

Да

Видимо пользователю

Только для чтения

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Global

Boolean

Да

Видимо пользователю

Только для чтения

Глобальная

5.9.4.90.2. Конструктор Create (Конструктор значения настройки)

Конструктор класса TOptionValue.
1constructor TOptionValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Унаследовано от TTypedValue.Create

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

User

TUser

Нет

Пользователь

Замечания:

Создает новый объект класса TOptionValue.

5.9.4.91. Класс TParameter (Параметры)

5.9.4.91.1. Свойства

Свойства класса TParameter:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

RoutineClass

TClass

Нет

Видимо пользователю

Только для чтения

Класс подпрограммы

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

InitializationMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Инициализируется членом класса

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

Override

Boolean

Да

Видимо пользователю

Только для чтения

Переопределен

LinkedView

TParametersFormView

Нет

Видимо пользователю

Чтение/Запись

Связанное представление

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

5.9.4.91.2. Конструктор Create (Конструктор параметра)

Конструктор класса TParameter.
1constructor TParameter.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; InitializationMember: TClassMember; OutOfTabs: Boolean;
5  LinkedView: TParametersFormView; Logged: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Имя

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

InitializationMember

TClassMember

Нет

Инициализируется членом класса

OutOfTabs

Boolean

Да

За пределами закладок

LinkedView

TParametersFormView

Нет

Связанное представление

Logged

Boolean

Да

Протоколировать

Замечания:

Создает новый объект класса TParameter.

5.9.4.91.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TParameter.
class function TParameter.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

5.9.4.91.4. Метод GetOverride (Переопределен)

Метод экземпляра класса TParameter.
function TParameter.GetOverride: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.92. Класс TParameterHistory (Параметры вызовов)

5.9.4.92.1. Свойства

Свойства класса TParameterHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Routine

TRoutineHistory

Да

Скрыто от пользователя

Только для чтения

Вызов подпрограммы

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

ParameterName

string[64]

Да

Видимо пользователю

Только для чтения

Параметр

Data

string[2000]

Нет

Видимо пользователю

Только для чтения

Содержимое

ObjectID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

5.9.4.92.2. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TParameterHistory.
1class procedure TParameterHistory.Log(Routine: TRoutineHistory;
2  Parameter: TParameter; Data: string[2000]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutineHistory

Да

Вызов подпрограммы

Parameter

TParameter

Да

Параметр

Data

string[2000]

Нет

Содержимое

5.9.4.93. Класс TParametersFormView (Представления формы параметров)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

5.9.4.93.1. Конструктор Create (Конструктор представления формы параметров)

Конструктор класса TParametersFormView.
1constructor TParametersFormView.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; View: TCustomView; ChildrenMinimized: Boolean;
4  ChildrenOnTabs: Boolean; MasterProperty: TProperty;
5  DetailProperty: TClassMember; Position: Integer; SpacePercentage: Integer;
6  Layout: TFormViewLayout; ExplicitQuery: Boolean): TObject;
Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Унаследовано от TFormView.Create

ChildrenMinimized

Boolean

Да

ChildrenOnTabs

Boolean

Да

MasterProperty

TProperty

Нет

DetailProperty

TClassMember

Нет

Position

Integer

Да

SpacePercentage

Integer

Нет

Layout

TFormViewLayout

Да

ExplicitQuery

Boolean

Да

Замечания:

Создает новый объект класса TParametersFormView.

5.9.4.94. Класс TPDFTemplate (Шаблоны отчетов PDF)

5.9.4.94.1. Свойства

Свойства класса TPDFTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateScript

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт шаблона

5.9.4.94.2. Конструктор Create (Конструктор шаблона PDF)

Конструктор класса TPDFTemplate.
1constructor TPDFTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateScript: clob): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateScript

clob

Нет

Скрипт шаблона

Замечания:

Создает новый объект класса TPDFTemplate.

5.9.4.95. Класс TProfile (Профили)

5.9.4.95.1. Свойства

Свойства класса TProfile:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

ComparisonType

TComparisonType

Да

Видимо пользователю

Чтение/Запись

Тип сравнения

BasedOnProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Расширяет профиль пользователями

Active

Boolean

Да

Видимо пользователю

Только для чтения

Активен

5.9.4.95.2. Конструктор Create (Конструктор профиля)

Конструктор класса TProfile.
1constructor TProfile.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ComparisonType: TComparisonType;
4  BasedOnProfile: TProfile): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

ComparisonType

TComparisonType

Да

Тип сравнения

BasedOnProfile

TProfile

Нет

Расширяет профиль пользователями

Замечания:

Создает новый объект класса TProfile.

5.9.4.95.3. Метод Check (Проверка профиля)

Метод класса (статический метод) класса TProfile.
class procedure TProfile.Check(Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

5.9.4.95.4. Метод GetIsActive (Активен для текущего пользователя)

Метод экземпляра класса TProfile.
function TProfile.GetIsActive: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.95.5. Метод GetValueDomain (Получить домен значения)

Метод экземпляра класса TProfile.
function TProfile.GetValueDomain: TDomain;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TDomain.

5.9.4.95.6. Метод Match (Проверка совпадения)

Метод экземпляра класса TProfile.
1function TProfile.Match(Object: TObject; ObjectClass: TClass;
2  ValueGiven: Boolean; StrValue: string[2000]; IntValue: Integer;
3  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
4  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
5  ExternalDataValue: <external data>): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

ValueGiven

Boolean

Да

Значение задано

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Возвращает значение типа Boolean.

5.9.4.95.7. Метод MatchObject (Проверка совпадения объекта)

Метод экземпляра класса TProfile.
function TProfile.MatchObject(Object: TObject; ObjectClass: TClass): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

Замечания:

Возвращает значение типа Boolean.

5.9.4.95.8. Метод TryCheck (Проверка профиля с возвратом результата)

Метод класса (статический метод) класса TProfile.
class function TProfile.TryCheck(Object: TObject; ObjectClass: TClass): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

ObjectClass

TClass

Нет

Класс объекта

Замечания:

Возвращает значение типа Boolean.

5.9.4.96. Класс TProfileEvent (События профиля)

5.9.4.96.1. Свойства

Свойства класса TProfileEvent:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Method

TProfileMethod

Да

Скрыто от пользователя

Только для чтения

Метод профилировщика

Class

TClass

Да

Видимо пользователю

Только для чтения

Класс

ObjectID

string[38]

Да

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Видимо пользователю

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

Action

TChangeAction

Да

Видимо пользователю

Только для чтения

Действия

5.9.4.97. Класс TProfileItem (Состав профиля)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.97.1. Свойства

Свойства класса TProfileItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ProfileClass

TClass

Да

Видимо пользователю

Чтение/Запись

Профилируемый класс

ProfileProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Профилируемое свойство

Comparator

TMethod

Нет

Видимо пользователю

Чтение/Запись

Сравнивающая функция

Group

string[64]

Нет

Видимо пользователю

Чтение/Запись

Группа

AllowNulls

Boolean

Да

Видимо пользователю

Чтение/Запись

Пропускать пустые значения

HasCrossCondition

Boolean

Да

Видимо пользователю

Только для чтения

Имеется пересечение условий

5.9.4.97.2. Конструктор Create (Конструктор элемента профиля)

Конструктор класса TProfileItem.
1constructor TProfileItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ProfileClass: TClass; ProfileProperty: TProperty; Comparator: TMethod;
4  Group: string[64]; AllowNulls: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ProfileClass

TClass

Да

Профилируемый класс

ProfileProperty

TProperty

Нет

Профилируемое свойство

Comparator

TMethod

Нет

Сравнивающая функция

Group

string[64]

Нет

Группа

AllowNulls

Boolean

Да

Пропускать пустые значения

Замечания:

Создает новый объект класса TProfileItem.

5.9.4.97.3. Метод GetHasCrossConditions (Имеется пересечение условий)

Метод экземпляра класса TProfileItem.
function TProfileItem.GetHasCrossConditions: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.98. Класс TProfileMethod (Методы профиля)

Объекты класса образуют иерархию.

5.9.4.98.1. Свойства

Свойства класса TProfileMethod:

Имя

Тип

Обязательно

Доступ

Назначение

Parent

TProfileMethod

Нет

Только для чтения

Родитель

Method

TMethod

Да

Только для чтения

Метод профилировщика

MethodClass

TClass

Да

Только для чтения

Класс

Position

Integer

Да

Только для чтения

Позиция

Duration

Integer

Нет

Только для чтения

Общее время

CodeDuration

Integer

Нет

Только для чтения

Время собственного кода

Calls

Integer

Нет

Только для чтения

Количество непосредственных вызовов

Events

Integer

Нет

Только для чтения

Непосредственных операций с данными

CommonCalls

Integer

Нет

Только для чтения

Всего вызовов

CommonEvents

Integer

Нет

Только для чтения

Всего операций с данными

ObjectID

string[38]

Да

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Только для чтения

Идентификатор при создании

5.9.4.98.2. Метод BuildReport (Перестроить отчет)

Метод класса (статический метод) класса TProfileMethod.
class procedure TProfileMethod.BuildReport(QualifyObjects: Boolean);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

QualifyObjects

Boolean

Да

Квалифицировать объекты

5.9.4.98.3. Метод Clear (Очистить статистику)

Метод класса (статический метод) класса TProfileMethod.
class procedure TProfileMethod.Clear;
Метод является методом класса.

Метод не имеет параметров.

5.9.4.98.4. Метод Ole-объекта ExportProfilerReport (Экспортировать отчет)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TProfileMethod.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

5.9.4.99. Класс TProfileStatistics (Статистика профиля)

5.9.4.99.1. Свойства

Свойства класса TProfileStatistics:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Method

TProfileMethod

Да

Скрыто от пользователя

Только для чтения

Метод профилировщика

CalledMethod

TMethod

Нет

Видимо пользователю

Только для чтения

Вызываемый метод

CalledMethodClass

TObject

Да

Видимо пользователю

Только для чтения

Класс

Calls

Integer

Нет

Видимо пользователю

Только для чтения

Количество вызовов

Class

TClass

Нет

Видимо пользователю

Только для чтения

Класс

Inserts

Integer

Нет

Видимо пользователю

Только для чтения

Количество добавлений

Updates

Integer

Нет

Видимо пользователю

Только для чтения

Количество изменений

Deletes

Integer

Нет

Видимо пользователю

Только для чтения

Количество удалений

Type

string[128]

Нет

Видимо пользователю

Только для чтения

Тип

5.9.4.100. Класс TProfileUser (Пользователи профиля)

Объекты класса не именованы.

Наименования объектов класса генерируются.

5.9.4.100.1. Свойства

Свойства класса TProfileUser:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TTypedValue

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

UserIsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Пользователь является текущим

Profile

TProfile

Да

Скрыто от пользователя

Только для чтения

Профиль

Domain

TDomain

Да

Скрыто от пользователя

Только для чтения

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TTypedValue

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

5.9.4.100.2. Конструктор Create (Конструктор пользовательского профиля)

Конструктор класса TProfileUser.
1constructor TProfileUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TProfile; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>; User: TUser): TObject;
Переопределяет метод в TTypedValue.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TProfile

Да

Профиль

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Унаследовано от TTypedValue.Create

IntValue

Integer

Нет

FloatValue

float

Нет

DateValue

date

Нет

TimeValue

time

Нет

DateTimeValue

datetime

Нет

ObjectValue

TObject

Нет

BoolValue

Boolean

Нет

BlobValue

blob

Нет

ClobValue

clob

Нет

ExternalDataValue

<external data>

Нет

User

TUser

Да

Пользователь

Замечания:

Создает новый объект класса TProfileUser.

5.9.4.101. Класс TProperty (Свойства)

Объекты класса образуют иерархию.

5.9.4.101.1. Свойства

Свойства класса TProperty:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainClass

TClass

Да

Видимо пользователю

Только для чтения

Класс домена

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

ReadMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Член класса для чтения

ReadMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для чтения

WriteMember

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Член класса для записи

WriteMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для записи

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

IsExportable

Boolean

Да

Видимо пользователю

Чтение/Запись

Для экспорта

IsSuspended

Boolean

Да

Видимо пользователю

Чтение/Запись

Отложенное

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

IsUnupdatable

Boolean

Да

Видимо пользователю

Чтение/Запись

Необновляемое при импорте

NullHandler

TMethod

Нет

Видимо пользователю

Чтение/Запись

Обработчик пустого значения

OnDemand

Boolean

Да

Видимо пользователю

Чтение/Запись

По требованию

5.9.4.101.2. Конструктор Create (Конструктор свойства)

Конструктор класса TProperty.
1constructor TProperty.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; ReadMember: TClassMember; WriteMember: TClassMember;
4  Position: Integer; Scope: TScope; IsExportable: Boolean; IsSuspended: Boolean;
5  CreateViewColumns: Boolean; Category: string[128]): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

ReadMember

TClassMember

Нет

Член класса для чтения

WriteMember

TClassMember

Нет

Член класса для записи

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

IsExportable

Boolean

Да

Для экспорта

IsSuspended

Boolean

Да

Отложенное

CreateViewColumns

Boolean

Да

Создать колонку во всех представлениях

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TProperty.

5.9.4.101.3. Метод Change (Изменение объекта)

Метод экземпляра класса TProperty.
procedure TProperty.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

5.9.4.101.4. Метод CreateChildren (Создать дочерние свойства)

Метод экземпляра класса TProperty.
1procedure TProperty.CreateChildren(ClearWriteMember: Boolean;
2  PublicOnly: Boolean; ExactName: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

ClearWriteMember

Boolean

Да

Создавать свойства только для чтения

PublicOnly

Boolean

Да

Создавать только видимые свойства

ExactName

Boolean

Да

Не изменять имя свойства

5.9.4.101.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TProperty.
class function TProperty.GetNextPos(Master: TObject; Parent: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Integer.

5.9.4.101.6. Метод LocalizableFieldName (Получить имя локализуемого поля)

Метод класса (статический метод) класса TProperty.
1class function TProperty.LocalizableFieldName(Class: TClass;
2  Name: string[64]): string[64];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Class

TClass

Нет

Класс

Name

string[64]

Да

Имя

Замечания:

Возвращает значение типа string[64].

5.9.4.101.7. Метод LocalizableProperty (Локализуемое свойство)

Метод класса (статический метод) класса TProperty.
1class function TProperty.LocalizableProperty(ClassName: string[64];
2  PropertyName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ClassName

string[64]

Да

Имя класса

PropertyName

string[64]

Да

Имя свойства

Замечания:

Возвращает значение типа Boolean.

5.9.4.101.8. Метод SuggestFileName (Предложить имя файла)

Метод экземпляра класса TProperty.
function TProperty.SuggestFileName(Domain: TDomain): string[128];
Переопределяет метод в TClassMember.SuggestFileName, TObject.SuggestFileName.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Параметры:

Имя

Тип

Обязательно

Значение

Domain

TDomain

Нет

Унаследовано от TObject.SuggestFileName

Замечания:

Возвращает значение типа string[128].

5.9.4.102. Класс TPropertyBan (Запрет на свойство)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.102.1. Свойства

Свойства класса TPropertyBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

BannedProperty

TProperty

Да

Видимо пользователю

Только для чтения

Запрещаемое свойство

AllowRead

Boolean

Да

Видимо пользователю

Чтение/Запись

Чтение разрешено

5.9.4.102.2. Конструктор Create (Конструктор запрета на свойство)

Конструктор класса TPropertyBan.
1constructor TPropertyBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedProperty: TProperty; AllowRead: Boolean): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

BannedProperty

TProperty

Да

Запрещаемое свойство

AllowRead

Boolean

Да

Чтение разрешено

Замечания:

Создает новый объект класса TPropertyBan.

5.9.4.103. Класс TQueue (Очередь)

5.9.4.103.1. Свойства

Свойства класса TQueue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

QueueName

string[64]

Да

Видимо пользователю

Только для чтения

Имя очереди

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время входа в очередь

Object

TObject

Нет

Видимо пользователю

Только для чтения

Объект

ObjectName

string[64]

Да

Видимо пользователю

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Видимо пользователю

Только для чтения

Наименование объекта

ObjectClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс объекта

ObjectParent

TObject

Нет

Скрыто от пользователя

Только для чтения

Объект-родитель

ObjectMaster

TObject

Да

Скрыто от пользователя

Только для чтения

Объект-мастер

ObjectSourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

База данных-источник

ObjectOldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Идентификатор объекта при создании

ObjectCreator

TUser

Да

Скрыто от пользователя

Только для чтения

Объект создан пользователем

ObjectCreated

datetime

Да

Скрыто от пользователя

Только для чтения

Объект создан

ObjectModifier

TUser

Да

Скрыто от пользователя

Только для чтения

Объект изменен пользователем

ObjectModified

datetime

Да

Скрыто от пользователя

Только для чтения

Объект изменен

Processed

Boolean

Да

Видимо пользователю

Только для чтения

Обработан

5.9.4.103.2. Конструктор Create (Конструктор объекта в очереди)

Конструктор класса TQueue.
constructor TQueue.Create(Object: TObject; QueueName: string[64]): TObject;
Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Да

Объект

QueueName

string[64]

Да

Имя очереди

Замечания:

Создает новый объект класса TQueue.

5.9.4.103.3. Деструктор Destroy (Деструктор объекта в очереди)

Деструктор класса TQueue.
destructor TQueue.Destroy;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Уничтожает объект класса TQueue или его наследника.

5.9.4.103.4. Метод Clear (Очистить очередь)

Метод класса (статический метод) класса TQueue.
class procedure TQueue.Clear(QueueName: string[64]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

QueueName

string[64]

Да

Имя очереди

5.9.4.104. Класс TRole (Роли)

5.9.4.104.1. Свойства

Свойства класса TRole:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущей

5.9.4.104.2. Конструктор Create (Конструктор роли)

Конструктор класса TRole.
1constructor TRole.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TRole.

5.9.4.104.3. Метод GetIsCurrent (Является текущей)

Метод экземпляра класса TRole.
function TRole.GetIsCurrent: Boolean;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.105. Класс TRoleMember (Пользователи в ролях)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.105.1. Свойства

Свойства класса TRoleMember:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

User

TSecurityAccount

Да

Видимо пользователю

Только для чтения

Пользователь

UserClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс члена роли

IsPrimary

Boolean

Да

Видимо пользователю

Чтение/Запись

Основная роль

5.9.4.105.2. Конструктор Create (Конструктор члена роли)

Конструктор класса TRoleMember.
1constructor TRoleMember.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TRole; Accessor: TSecurityAccount;
3  User: TSecurityAccount; IsPrimary: Boolean; AddLinked: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TRole

Да

Роль

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

User

TSecurityAccount

Да

Пользователь

IsPrimary

Boolean

Да

Основная роль

AddLinked

Boolean

Да

Добавить связанные роли

Замечания:

Создает новый объект класса TRoleMember.

5.9.4.105.3. Метод SetIsPrimary (Установка значения свойства "Является основной")

Метод экземпляра класса TRoleMember.
procedure TRoleMember.SetIsPrimary(Value: Boolean);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

5.9.4.106. Класс TRoutine (Подпрограмма)

5.9.4.106.1. Свойства

Свойства класса TRoutine:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Домен результата

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена результата

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена результата

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Является методом класса

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Текст подтверждения

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Использовать закладки

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Скрипт формы параметров

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение-иконка

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество параметров

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

Протоколировать

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

Сообщение о выполнении

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

Вызывать только для одного объекта

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Количество зависимостей

5.9.4.106.2. Конструктор Create (Конструктор подпрограммы)

Конструктор класса TRoutine.
1constructor TRoutine.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean): TObject;
Переопределяет метод в TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Является методом класса

SingleObject

Boolean

Да

Вызывать только для одного объекта

Domain

TDomain

Нет

Домен результата

Scope

TScope

Да

Область видимости

Confirmation

string[512]

Нет

Текст подтверждения

ReportMessage

string[512]

Нет

Сообщение о выполнении

UseTabs

Boolean

Да

Использовать закладки

Script

clob

Нет

Скрипт формы параметров

Image

blob

Нет

Изображение-иконка

Logged

Boolean

Да

Протоколировать

Замечания:

Создает новый объект класса TRoutine.

5.9.4.106.3. Метод CreateContextKey (Создать ключ контекстной помощи)

Метод экземпляра класса TRoutine.
procedure TRoutine.CreateContextKey(Storage: string[64]);
Параметры:

Имя

Тип

Обязательно

Значение

Storage

string[64]

Да

Хранилище

5.9.4.106.4. Метод GetParamCount (Количество параметров)

Метод экземпляра класса TRoutine.
function TRoutine.GetParamCount: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.106.5. Метод ListParameters (Список параметров)

Метод экземпляра класса TRoutine.
function TRoutine.ListParameters: TObjectList;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TObjectList.

5.9.4.106.6. Метод ParameterByName (Получить параметр по имени)

Метод экземпляра класса TRoutine.
function TRoutine.ParameterByName(AName: string[64]): TParameter;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

AName

string[64]

Да

Имя

Замечания:

Возвращает значение типа TParameter.

5.9.4.106.7. Метод Ole-объекта CreateReportTemplate (Сгенерировать шаблон отчета)

Метод Ole-объекта класса TRoutine.

Метод Ole-объекта не имеет параметров.

5.9.4.107. Класс TRoutineAction (Программируемое действие)

Объекты класса образуют иерархию.

5.9.4.107.1. Свойства

Свойства класса TRoutineAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

ContextProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Выполнять в контексте свойства

AllowNavigation

Boolean

Да

Видимо пользователю

Чтение/Запись

Доступна навигация

5.9.4.107.2. Конструктор Create (Конструктор программируемого действия)

Конструктор класса TRoutineAction.
1constructor TRoutineAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  Routine: TRoutine; ContextProperty: TProperty;
5  AllowNavigation: Boolean): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

Routine

TRoutine

Да

Реализовано посредством

ContextProperty

TProperty

Нет

выполнять в контексте

AllowNavigation

Boolean

Да

Доступна навигация

Замечания:

Создает новый объект класса TRoutineAction.

5.9.4.107.3. Метод EnsureAction (Обеспечить наличие действия)

Метод класса (статический метод) класса TRoutineAction.
1class function TRoutineAction.EnsureAction(AView: TObject; AName: string[64];
2  ADescription: string[128]; APosition: Integer; AShortcut: string[20];
3  ASeparated: Boolean; ARoutine: TRoutine): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AView

TObject

Да

Мастер

AName

string[64]

Да

Имя

ADescription

string[128]

Да

Наименование

APosition

Integer

Да

Позиция

AShortcut

string[20]

Нет

Горячая клавиша

ASeparated

Boolean

Да

Отделено

ARoutine

TRoutine

Да

Реализовано посредством

Замечания:

Возвращает значение типа TObject.

5.9.4.108. Класс TRoutineBan (Запрет на подпрограмму)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.108.1. Свойства

Свойства класса TRoutineBan:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TBanGroup

Да

Видимо пользователю

Только для чтения

Унаследовано от TBanGroupItem

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

BannedClass

TClass

Да

Видимо пользователю

Только для чтения

Запрещаемый класс

BannedRoutine

TRoutine

Да

Видимо пользователю

Только для чтения

Запрещаемая подпрограмма

5.9.4.108.2. Конструктор Create (Конструктор запрета на подпрограмму)

Конструктор класса TRoutineBan.
1constructor TRoutineBan.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  BannedClass: TClass; BannedRoutine: TRoutine): TObject;
Переопределяет метод в TBanGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

BannedClass

TClass

Да

Запрещаемый класс

BannedRoutine

TRoutine

Да

Запрещаемая подпрограмма

Замечания:

Создает новый объект класса TRoutineBan.

5.9.4.109. Класс TRoutineHistory (Вызовы)

5.9.4.109.1. Свойства

Свойства класса TRoutineHistory:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

ObjectID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор объекта

ObjectQualifiedName

string[2000]

Нет

Видимо пользователю

Только для чтения

Квалифицированное имя объекта

ObjectDataBase

TDataBase

Нет

Видимо пользователю

Только для чтения

База данных объекта

ObjectOldID

string[38]

Нет

Видимо пользователю

Только для чтения

Идентификатор при создании

RoutineName

string[64]

Да

Видимо пользователю

Только для чтения

Подпрограмма

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс подпрограммы

RoutineClassName

string[64]

Да

Видимо пользователю

Только для чтения

Имя класса подпрограммы

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

5.9.4.109.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TRoutineHistory.
1class procedure TRoutineHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

5.9.4.109.3. Метод Log (Создать запись протокола)

Метод класса (статический метод) класса TRoutineHistory.
1class function TRoutineHistory.Log(Routine: TRoutine;
2  Object: TObject): TRoutineHistory;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Routine

TRoutine

Да

Подпрограмма

Object

TObject

Нет

Объект

Замечания:

Возвращает значение типа TRoutineHistory.

5.9.4.109.4. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TRoutineHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

5.9.4.110. Класс TSecurityAccount (Роли безопасности)

5.9.4.111. Класс TSequence (Последовательности)

5.9.4.111.1. Свойства

Свойства класса TSequence:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Value

string[20]

Да

Видимо пользователю

Чтение/Запись

Текущее значение

Cache

Integer

Нет

Видимо пользователю

Чтение/Запись

Кэш

5.9.4.111.2. Конструктор Create (Конструктор последовательности)

Конструктор класса TSequence.
1constructor TSequence.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TSequence.

5.9.4.111.3. Метод GetCache (Получить кеш)

Метод экземпляра класса TSequence.
function TSequence.GetCache: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.111.4. Метод GetValue (Получить текущее значение)

Метод экземпляра класса TSequence.
function TSequence.GetValue: string[20];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].

5.9.4.111.5. Метод Promote (Получить следующее значение)

Метод экземпляра класса TSequence.
function TSequence.Promote: string[20];
Метод не имеет параметров.

Замечания:

Возвращает значение типа string[20].

5.9.4.111.6. Метод SetCache (Установить кеш)

Метод экземпляра класса TSequence.
procedure TSequence.SetCache(Value: Integer);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

5.9.4.111.7. Метод SetValue (Установить текущее значение)

Метод экземпляра класса TSequence.
procedure TSequence.SetValue(Value: string[20]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[20]

Да

Значение

5.9.4.112. Класс TSessionHistory (Сессии)

5.9.4.112.1. Свойства

Свойства класса TSessionHistory:

Имя

Тип

Обязательно

Доступ

Назначение

IntStamp

Integer

Нет

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Только для чтения

Время

User

TUser

Нет

Только для чтения

Пользователь

Login

string[64]

Да

Только для чтения

Логин

CloseStamp

datetime

Нет

Только для чтения

Время закрытия

UserAgent

string[2000]

Нет

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Только для чтения

Информация о соединении

Duration

time

Нет

Только для чтения

Продолжительность

5.9.4.112.2. Метод Clear (Очистить историю)

Метод класса (статический метод) класса TSessionHistory.
1class procedure TSessionHistory.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

5.9.4.112.3. Метод DBMSConnectionInfo (Информация о соединении от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSConnectionInfo: string[2000];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.112.4. Метод DBMSGetIPAddress (IP-адрес клиента от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSGetIPAddress: string[16];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[16].

5.9.4.112.5. Метод DBMSGetUserAgent (Пользовательский агент от СУБД)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.DBMSGetUserAgent: string[2000];
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.112.6. Метод GetCurrentSession (Идентификатор текущей сессии)

Метод класса (статический метод) класса TSessionHistory.
class function TSessionHistory.GetCurrentSession: TSessionHistory;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TSessionHistory.

5.9.4.112.7. Метод Ole-объекта ExportHistoryLogs (Экспортировать протоколы истории)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TSessionHistory.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

FileName

string[255]

Да

Имя файла

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

5.9.4.113. Класс TStatement (Операторы)

5.9.4.113.1. Конструктор Create (Конструктор оператора)

Конструктор класса TStatement.
constructor TStatement.Create: TObject;
Метод не имеет параметров.

Замечания:

Создает новый объект класса TStatement.

5.9.4.113.2. Метод BoolLiteral (Логический литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.BoolLiteral(Value: Boolean): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Boolean

Да

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.3. Метод BuildFunctionCall (Построить вызов функции)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildFunctionCall(Function: TMethod;
2  Parameters: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Function

TMethod

Нет

Функция

Parameters

string[2000]

Нет

Параметры вызова

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.4. Метод BuildInsertStatement (Построить скрипт добавления объекта)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildInsertStatement(AObject: TObject;
2  AClass: TClass): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AObject

TObject

Да

Объект

AClass

TClass

Нет

Класс

Замечания:

Возвращает значение типа clob.

5.9.4.113.5. Метод BuildProcedureCall (Построить вызов процедуры)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildProcedureCall(Procedure: TMethod;
2  Parameters: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Procedure

TMethod

Нет

Процедура

Parameters

string[2000]

Нет

Параметры вызова

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.6. Метод BuildUpdateStatement (Построить скрипт изменения объекта)

Метод класса (статический метод) класса TStatement.
1class function TStatement.BuildUpdateStatement(AObject: TObject;
2  AClass: TClass): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AObject

TObject

Да

Объект

AClass

TClass

Нет

Класс

Замечания:

Возвращает значение типа clob.

5.9.4.113.7. Метод Change (Изменение объекта)

Метод экземпляра класса TStatement.
procedure TStatement.Change(Action: TChangeAction);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Действие

5.9.4.113.8. Метод DateLiteral (Литерал типа "дата")

Метод класса (статический метод) класса TStatement.
class function TStatement.DateLiteral(Value: date): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

date

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.9. Метод DateTimeLiteral (Литерал типа "дата со временем")

Метод класса (статический метод) класса TStatement.
class function TStatement.DateTimeLiteral(Value: datetime): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

datetime

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.10. Метод Execute (Выполнить)

Метод класса (статический метод) класса TStatement.
class procedure TStatement.Execute(Statement: string[2000]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

5.9.4.113.11. Метод ExecuteClob (Выполнить большой текстовый объект)

Метод класса (статический метод) класса TStatement.
class procedure TStatement.ExecuteClob(Statement: clob);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

5.9.4.113.12. Метод ExecuteClobToBlobValue (Выполнить большой текстовый объект и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToBlobValue(Statement: clob): blob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа blob.

5.9.4.113.13. Метод ExecuteClobToBoolValue (Выполнить большой текстовый объект и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToBoolValue(Statement: clob): Boolean;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа Boolean.

5.9.4.113.14. Метод ExecuteClobToClobValue (Выполнить большой текстовый объект и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToClobValue(Statement: clob): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа clob.

5.9.4.113.15. Метод ExecuteClobToDateTimeValue (Выполнить большой текстовый объект и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToDateTimeValue(Statement: clob): datetime;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа datetime.

5.9.4.113.16. Метод ExecuteClobToDateValue (Выполнить большой текстовый объект и вернуть значение даты)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToDateValue(Statement: clob): date;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа date.

5.9.4.113.17. Метод ExecuteClobToExternalDataValue (Выполнить большой текстовый объект и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ExecuteClobToExternalDataValue(Statement: clob): <external
2  data>;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа <external data>.

5.9.4.113.18. Метод ExecuteClobToFloatValue (Выполнить большой текстовый объект и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToFloatValue(Statement: clob): float;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа float.

5.9.4.113.19. Метод ExecuteClobToIntValue (Выполнить большой текстовый объект и вернуть целое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToIntValue(Statement: clob): Integer;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа Integer.

5.9.4.113.20. Метод ExecuteClobToObjectValue (Выполнить большой текстовый объект и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToObjectValue(Statement: clob): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа TObject.

5.9.4.113.21. Метод ExecuteClobToStrValue (Выполнить большой текстовый объект и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToStrValue(Statement: clob): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.22. Метод ExecuteClobToTimeValue (Выполнить большой текстовый объект и вернуть значение времени)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteClobToTimeValue(Statement: clob): time;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

clob

Нет

Оператор

Замечания:

Возвращает значение типа time.

5.9.4.113.23. Метод ExecuteToBlobValue (Выполнить и вернуть значение-большой объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToBlobValue(Statement: string[2000]): blob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа blob.

5.9.4.113.24. Метод ExecuteToBoolValue (Выполнить и вернуть логическое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToBoolValue(Statement: string[2000]): Boolean;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа Boolean.

5.9.4.113.25. Метод ExecuteToClobValue (Выполнить и вернуть значение-большой текст)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToClobValue(Statement: string[2000]): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа clob.

5.9.4.113.26. Метод ExecuteToDateTimeValue (Выполнить и вернуть значение даты со временем)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToDateTimeValue(Statement: string[2000]): datetime;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа datetime.

5.9.4.113.27. Метод ExecuteToDateValue (Выполнить и вернуть значение даты)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToDateValue(Statement: string[2000]): date;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа date.

5.9.4.113.28. Метод ExecuteToExternalDataValue (Выполнить и вернуть значение внешних данных)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ExecuteToExternalDataValue(Statement: string[2000]): <external
2  data>;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа <external data>.

5.9.4.113.29. Метод ExecuteToFloatValue (Выполнить и вернуть вещественное значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToFloatValue(Statement: string[2000]): float;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа float.

5.9.4.113.30. Метод ExecuteToIntValue (Выполнить и вернуть целое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToIntValue(Statement: string[2000]): Integer;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа Integer.

5.9.4.113.31. Метод ExecuteToObjectValue (Выполнить и вернуть значение-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToObjectValue(Statement: string[2000]): TObject;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа TObject.

5.9.4.113.32. Метод ExecuteToStrValue (Выполнить и вернуть строковое значение)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToStrValue(Statement: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.33. Метод ExecuteToTimeValue (Выполнить и вернуть значение времени)

Метод класса (статический метод) класса TStatement.
class function TStatement.ExecuteToTimeValue(Statement: string[2000]): time;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Замечания:

Возвращает значение типа time.

5.9.4.113.34. Метод FloatLiteral (Вещественный литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.FloatLiteral(Value: float): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

float

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.35. Метод IntLiteral (Целочисленный литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.IntLiteral(Value: Integer): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

Integer

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.36. Метод ObjectLiteral (Литерал-объект)

Метод класса (статический метод) класса TStatement.
class function TStatement.ObjectLiteral(Value: TObject): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

TObject

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.37. Метод QualifyDBMSName (Квалифицировать имя объекта БД)

Метод класса (статический метод) класса TStatement.
class function TStatement.QualifyDBMSName(DBMSName: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DBMSName

string[2000]

Нет

Имя объекта БД

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.38. Метод SequenceLiteral (Литерал значения последовательности)

Метод класса (статический метод) класса TStatement.
class function TStatement.SequenceLiteral(SequenceName: string[64]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

SequenceName

string[64]

Да

Имя последовательности

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.39. Метод StringAggregate (Агрегировать строки запроса)

Метод класса (статический метод) класса TStatement.
1class function TStatement.StringAggregate(Statement: string[2000];
2  Delimiter: string[2000]): clob;
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Statement

string[2000]

Нет

Оператор

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа clob.

5.9.4.113.40. Метод StringLiteral (Строковый литерал)

Метод класса (статический метод) класса TStatement.
class function TStatement.StringLiteral(Value: string[2000]): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.41. Метод TimeLiteral (Литерал типа "время")

Метод класса (статический метод) класса TStatement.
class function TStatement.TimeLiteral(Value: time): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

time

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.113.42. Метод ToString (Приведение литерала к строке)

Метод класса (статический метод) класса TStatement.
1class function TStatement.ToString(Literal: string[2000]; Domain: TDomain;
2  CanUseTables: Boolean): string[2000];
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Literal

string[2000]

Нет

Литерал

Domain

TDomain

Нет

Домен

CanUseTables

Boolean

Да

Использовать таблицы

Замечания:

Возвращает значение типа string[2000].

5.9.4.114. Класс TStringBuilder (Шаблоны строк)

5.9.4.114.1. Свойства

Свойства класса TStringBuilder:

Имя

Тип

Обязательно

Доступ

Назначение

Template

string[2000]

Нет

Чтение/Запись

Шаблон

TemplateClob

clob

Нет

Чтение/Запись

Шаблон - большой текстовый объект

5.9.4.114.2. Конструктор Create (Конструктор шаблона строк)

Конструктор класса TStringBuilder.
1constructor TStringBuilder.Create(Template: string[2000];
2  TemplateClob: clob): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

TemplateClob

clob

Нет

Шаблон - большой текстовый объект

Замечания:

Создает новый объект класса TStringBuilder.

5.9.4.114.3. Метод Append (Добавить строку)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.Append(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа TStringBuilder.

5.9.4.114.4. Метод AppendToClob (Добавить строку к большому текстовому объекту)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.AppendToClob(Value: string[2000];
2  Delimiter: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Delimiter

string[2000]

Нет

Разделитель

Замечания:

Возвращает значение типа TStringBuilder.

5.9.4.114.5. Метод Apply (Применить значение)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.Apply(Name: string[2000];
2  Value: string[2000]): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа TStringBuilder.

5.9.4.114.6. Метод ApplyClob (Применить значение - большой текстовый объект)

Метод экземпляра класса TStringBuilder.
1function TStringBuilder.ApplyClob(Name: string[2000];
2  Value: clob): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Name

string[2000]

Нет

Имя

Value

clob

Нет

Значение

Замечания:

Возвращает значение типа TStringBuilder.

5.9.4.114.7. Метод ApplyObject (Применить свойства объекта)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.ApplyObject(Object: TObject): TStringBuilder;
Параметры:

Имя

Тип

Обязательно

Значение

Object

TObject

Нет

Объект

Замечания:

Возвращает значение типа TStringBuilder.

5.9.4.114.8. Метод Build (Построить строку)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.Build: string[2000];
Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.114.9. Метод BuildClob (Построить большой текстовый объект)

Метод экземпляра класса TStringBuilder.
function TStringBuilder.BuildClob: clob;
Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

5.9.4.114.10. Метод ClearAll (Очистить все шаблоны строк)

Метод класса (статический метод) класса TStringBuilder.
class procedure TStringBuilder.ClearAll;
Метод является методом класса.

Метод не имеет параметров.

5.9.4.114.11. Метод ClobApply (Применить значение к большому текстовому объекту)

Метод класса (статический метод) класса TStringBuilder.
1class function TStringBuilder.ClobApply(Template: clob; Name: string[2000];
2  Value: string[2000]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

clob

Нет

Шаблон

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа clob.

5.9.4.114.12. Метод DebugTemplate (Отладить шаблон)

Метод класса (статический метод) класса TStringBuilder.
1class procedure TStringBuilder.DebugTemplate(Template: clob; Names: clob;
2  ApplyResult: clob);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

clob

Нет

Шаблон

Names

clob

Нет

Имена

ApplyResult

clob

Нет

Результат применения

5.9.4.114.13. Метод StrApply (Применить значение к строке)

Метод класса (статический метод) класса TStringBuilder.
1class function TStringBuilder.StrApply(Template: string[2000];
2  Name: string[2000]; Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Template

string[2000]

Нет

Шаблон

Name

string[2000]

Нет

Имя

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.115. Класс TStringDomain (Строковые)

5.9.4.115.1. Свойства

Свойства класса TStringDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

Length

Integer

Да

Видимо пользователю

Чтение/Запись

Длина

AllowLeadingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимы начальные пробелы

AllowTrailingSpaces

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимы конечные пробелы

AllowSpaceDuplication

Boolean

Да

Видимо пользователю

Чтение/Запись

Допустимо дублирование пробелов

CharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Набор символов

FirstCharacterSet

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Набор символов первого символа

CaseMode

Boolean

Нет

Видимо пользователю

Чтение/Запись

Режим регистра

Mask

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Маска

CaseInsensitiveSearch

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистронезависимый поиск

5.9.4.115.2. Конструктор Create (Конструктор строкового домена)

Конструктор класса TStringDomain.
1constructor TStringDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; Length: Integer; AllowLeadingSpaces: Boolean;
4  AllowTrailingSpaces: Boolean; AllowSpaceDuplication: Boolean;
5  CharacterSet: string[2000]; FirstCharacterSet: string[2000]; CaseMode: Boolean;
6  Mask: string[2000]; CaseInsensitiveSearch: Boolean): TDomain;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

Length

Integer

Да

Максимальная длина

AllowLeadingSpaces

Boolean

Да

Допустимы начальные пробелы

AllowTrailingSpaces

Boolean

Да

Допустимы конечные пробелы

AllowSpaceDuplication

Boolean

Да

Допустимо дублирование пробелов

CharacterSet

string[2000]

Нет

Набор символов

FirstCharacterSet

string[2000]

Нет

Набор символов первого символа

CaseMode

Boolean

Нет

Режим регистра

Mask

string[2000]

Нет

Маска

CaseInsensitiveSearch

Boolean

Да

Регистронезависимый поиск

Замечания:

Создает новый объект класса TStringDomain.

5.9.4.115.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TStringDomain.
function TStringDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.116. Класс TStringList (Список строк)

Объекты класса не именованы.

5.9.4.116.1. Свойства

Свойства класса TStringList:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Duplicates

TDuplicates

Да

Видимо пользователю

Чтение/Запись

Дублирование

Sorted

Boolean

Да

Видимо пользователю

Чтение/Запись

Сортированный

Delimiter

string[2]

Нет

Видимо пользователю

Чтение/Запись

Разделитель

CaseSensitive

Boolean

Да

Видимо пользователю

Чтение/Запись

Регистрозависимый

5.9.4.116.2. Конструктор Create (Конструктор списка строк)

Конструктор класса TStringList.
1constructor TStringList.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TStringList.

5.9.4.116.3. Метод Add (Добавить строку в список)

Метод экземпляра класса TStringList.
function TStringList.Add(ItemString: string[2000]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

5.9.4.116.4. Метод Archive (Отправить список в архив)

Метод экземпляра класса TStringList.
procedure TStringList.Archive;
Метод не имеет параметров.

5.9.4.116.5. Метод Clear (Очистить список)

Метод экземпляра класса TStringList.
procedure TStringList.Clear;
Метод скрыт от пользователя.

Метод не имеет параметров.

5.9.4.116.6. Метод ClobField (Поле в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobField(Text: clob; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

FieldIndex

Integer

Нет

Номер поля

Замечания:

Возвращает значение типа string[2000].

5.9.4.116.7. Метод ClobFieldCount (Количество полей в составе большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobFieldCount(Text: clob;
2  Delimiter: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Замечания:

Возвращает значение типа Integer.

5.9.4.116.8. Метод ClobFieldIndexOf (Индекс вхождения в состав большого текстового объекта)

Метод класса (статический метод) класса TStringList.
1class function TStringList.ClobFieldIndexOf(Text: clob; Delimiter: string[2];
2  Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

clob

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

5.9.4.116.9. Метод Delete (Удалить элемент из списка по индексу)

Метод экземпляра класса TStringList.
procedure TStringList.Delete(ItemIndex: Integer);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

5.9.4.116.10. Метод GetDelimitedText (Получить в виде разделенного текста)

Метод экземпляра класса TStringList.
function TStringList.GetDelimitedText: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.116.11. Метод GetDelimitedTextAsClob (Получить в виде разделенного большого текстового объекта)

Метод экземпляра класса TStringList.
function TStringList.GetDelimitedTextAsClob: clob;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа clob.

5.9.4.116.12. Метод GetItem (Получить строку по индексу)

Метод экземпляра класса TStringList.
function TStringList.GetItem(ItemIndex: Integer): string[2000];
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

Замечания:

Возвращает значение типа string[2000].

5.9.4.116.13. Метод IndexOf (Получить индекс строки в списке)

Метод экземпляра класса TStringList.
function TStringList.IndexOf(ItemString: string[2000]): Integer;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

Замечания:

Возвращает значение типа Integer.

5.9.4.116.14. Метод Insert (Вставить строку в список)

Метод экземпляра класса TStringList.
procedure TStringList.Insert(ItemIndex: Integer; ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemString

string[2000]

Нет

Строка

5.9.4.116.15. Метод Length (Длина списка)

Метод экземпляра класса TStringList.
function TStringList.Length: Integer;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

5.9.4.116.16. Метод Remove (Удалить строку из списка)

Метод экземпляра класса TStringList.
procedure TStringList.Remove(ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemString

string[2000]

Нет

Строка

5.9.4.116.17. Метод SetDelimitedText (Создать элементы списка на основе разделенного текста)

Метод экземпляра класса TStringList.
procedure TStringList.SetDelimitedText(Text: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

5.9.4.116.18. Метод SetItem (Установить значение элемента)

Метод экземпляра класса TStringList.
procedure TStringList.SetItem(ItemIndex: Integer; ItemString: string[2000]);
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

ItemIndex

Integer

Да

Индекс

ItemString

string[2000]

Нет

Строка

5.9.4.116.19. Метод Sort (Сортировать)

Метод экземпляра класса TStringList.
procedure TStringList.Sort;
Метод скрыт от пользователя.

Метод не имеет параметров.

5.9.4.116.20. Метод StrField (Поле в составе строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrField(Text: string[2000]; Delimiter: string[2];
2  FieldIndex: Integer): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

FieldIndex

Integer

Нет

Номер поля

Замечания:

Возвращает значение типа string[2000].

5.9.4.116.21. Метод StrFieldCount (Количество полей в составе строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrFieldCount(Text: string[2000];
2  Delimiter: string[2]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Замечания:

Возвращает значение типа Integer.

5.9.4.116.22. Метод StrFieldIndexOf (Индекс вхождения в состав строки)

Метод класса (статический метод) класса TStringList.
1class function TStringList.StrFieldIndexOf(Text: string[2000];
2  Delimiter: string[2]; Value: string[2000]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Delimiter

string[2]

Нет

Разделитель

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа Integer.

5.9.4.117. Класс TStringListItem (Элемент списка строк)

Объекты класса не именованы.

5.9.4.117.1. Свойства

Свойства класса TStringListItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

StringItem

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Строка

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

5.9.4.117.2. Конструктор Create (Конструктор элемента списка строк)

Конструктор класса TStringListItem.
1constructor TStringListItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  StringItem: string[2000]; Position: Integer): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

StringItem

string[2000]

Нет

Строка

Position

Integer

Да

Позиция

Замечания:

Создает новый объект класса TStringListItem.

5.9.4.118. Класс TSystemMessage (Системные сообщения)

5.9.4.118.1. Свойства

Свойства класса TSystemMessage:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Session

TSessionHistory

Нет

Скрыто от пользователя

Только для чтения

Сессия

SessionTimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время начала сессии

SessionCloseStamp

datetime

Нет

Видимо пользователю

Только для чтения

Время завершения сессии

IntStamp

Integer

Нет

Видимо пользователю

Только для чтения

Целочисленный номер

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

Login

string[64]

Да

Видимо пользователю

Только для чтения

Логин

UserAgent

string[2000]

Нет

Видимо пользователю

Только для чтения

Пользовательский агент

IPAddress

string[16]

Нет

Видимо пользователю

Только для чтения

IP-адрес

ConnectionInfo

string[2000]

Нет

Видимо пользователю

Только для чтения

Информация о соединении

Text

string[2000]

Нет

Видимо пользователю

Чтение/Запись

Текст

Data

blob

Нет

Видимо пользователю

Чтение/Запись

Данные

DataAsText

clob

Нет

Видимо пользователю

Только для чтения

Данные как текст

5.9.4.118.2. Метод Allow (Системные сообщения разрешены)

Метод класса (статический метод) класса TSystemMessage.
class function TSystemMessage.Allow: Boolean;
Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.118.3. Метод Clear (Очистить системные сообщения)

Метод класса (статический метод) класса TSystemMessage.
1class procedure TSystemMessage.Clear(TimeStampFrom: datetime;
2  TimeStampTo: datetime);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

TimeStampFrom

datetime

Нет

С

TimeStampTo

datetime

Нет

По

5.9.4.118.4. Метод Post (Отправить системное сообщение)

Метод класса (статический метод) класса TSystemMessage.
class procedure TSystemMessage.Post(Text: string[2000]; Data: blob);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Text

string[2000]

Нет

Текст

Data

blob

Нет

Данные

5.9.4.119. Класс TSystemMetadata (Системные метаданные)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.119.1. Свойства

Свойства класса TSystemMetadata:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Data

clob

Нет

Видимо пользователю

Только для чтения

Данные

CRC

string[8]

Нет

Видимо пользователю

Только для чтения

Контрольная сумма

5.9.4.119.2. Метод Change (Изменение объекта)

Метод экземпляра класса TSystemMetadata.
procedure TSystemMetadata.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

5.9.4.119.3. Метод InternalHash (Вычислить внутренний хеш)

Метод класса (статический метод) класса TSystemMetadata.
class function TSystemMetadata.InternalHash: string[128];
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[128].

5.9.4.119.4. Метод Store (Сохранить метаданные)

Метод класса (статический метод) класса TSystemMetadata.
class procedure TSystemMetadata.Store(Data: clob; CRC: string[8]);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Data

clob

Нет

Данные

CRC

string[8]

Нет

Контрольная сумма

5.9.4.120. Класс TTextIndex (Индекс текстового поиска)

5.9.4.120.1. Свойства

Свойства класса TTextIndex:

Имя

Тип

Обязательно

Доступ

Назначение

Field

TField

Да

Только для чтения

Поле

ObjectClass

TClass

Да

Только для чтения

Класс объекта

Object

TObject

Да

Только для чтения

Объект

ObjectName

string[64]

Да

Только для чтения

Имя объекта

ObjectDescription

string[128]

Да

Только для чтения

Наименование объекта

ObjectParent

TObject

Нет

Только для чтения

Родитель объекта

ObjectMaster

TObject

Да

Только для чтения

Мастер объекта

TopLevelObject

TObject

Нет

Только для чтения

Объект верхнего уровня

Entry

TTextIndexEntry

Да

Только для чтения

Вхождение

Word

string[64]

Да

Только для чтения

Слово

UpperWord

string[64]

Да

Только для чтения

Слово в верхнем регистре

5.9.4.120.2. Метод CleanUp (Очистить индекс)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.CleanUp(Field: TField; Object: TObject);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Field

TField

Нет

Поле

Object

TObject

Да

Объект

5.9.4.120.3. Метод HashClob (Хэш индекса большого текстового объекта)

Метод класса (статический метод) класса TTextIndex.
class function TTextIndex.HashClob(Value: clob; IsXHTML: Boolean): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

clob

Нет

Значение

IsXHTML

Boolean

Да

Содержимое является XHTML

Замечания:

Возвращает значение типа string[2000].

5.9.4.120.4. Метод HashIndex (Хэш индекса)

Метод класса (статический метод) класса TTextIndex.
1class function TTextIndex.HashIndex(Field: TField;
2  Object: TObject): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

Замечания:

Возвращает значение типа string[2000].

5.9.4.120.5. Метод HashValue (Хэш значения)

Метод класса (статический метод) класса TTextIndex.
class function TTextIndex.HashValue(Value: string[2000]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Замечания:

Возвращает значение типа string[2000].

5.9.4.120.6. Метод IndexClob (Индексировать большой текстовый объект)

Метод класса (статический метод) класса TTextIndex.
1class procedure TTextIndex.IndexClob(DeleteExistant: Boolean; Value: clob;
2  Field: TField; Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DeleteExistant

Boolean

Да

Удалять существующие

Value

clob

Нет

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

ObjectClass

TClass

Да

Класс объекта

5.9.4.120.7. Метод IndexValue (Индексировать значение)

Метод класса (статический метод) класса TTextIndex.
1class procedure TTextIndex.IndexValue(DeleteExistant: Boolean;
2  Value: string[2000]; Field: TField; Object: TObject; ObjectClass: TClass);
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

DeleteExistant

Boolean

Да

Удалять существующие

Value

string[2000]

Нет

Значение

Field

TField

Да

Поле

Object

TObject

Да

Объект

ObjectClass

TClass

Да

Класс объекта

5.9.4.120.8. Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.LoadFromBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

5.9.4.120.9. Метод PrepareBuffer (Подготовить буфер)

Метод класса (статический метод) класса TTextIndex.
class procedure TTextIndex.PrepareBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

5.9.4.120.10. Метод Ole-объекта Rebuild (Перестроить индекс)

Метод Ole-объекта класса (статический метод Ole-объекта) класса TTextIndex.

Метод Ole-объекта является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AClass

TClass

Нет

Класс

AField

TField

Нет

Поле

ThreadCount

Integer

Нет

Количество потоков

5.9.4.121. Класс TTextIndexEntry (Вхождения индекса текстового поиска)

5.9.4.121.1. Свойства

Свойства класса TTextIndexEntry:

Имя

Тип

Обязательно

Доступ

Назначение

Word

string[64]

Да

Только для чтения

Слово

UpperWord

string[64]

Да

Только для чтения

Слово в верхнем регистре

5.9.4.121.2. Метод LoadFromBuffer (Загрузить из буфера)

Метод класса (статический метод) класса TTextIndexEntry.
class procedure TTextIndexEntry.LoadFromBuffer;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

5.9.4.122. Класс TTimeDomain (Время)

5.9.4.122.1. Свойства

Свойства класса TTimeDomain:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Required

Boolean

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TDomain

DependencyCount

Integer

Нет

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

Definition

string[64]

Да

Видимо пользователю

Только для чтения

Summary

string[2000]

Нет

Видимо пользователю

Только для чтения

HideSeconds

Boolean

Да

Видимо пользователю

Чтение/Запись

Не показывать секунды

5.9.4.122.2. Конструктор Create (Конструктор домена времени)

Конструктор класса TTimeDomain.
1constructor TTimeDomain.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Required: Boolean; HideSeconds: Boolean): TObject;
Переопределяет метод в TDomain.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Required

Boolean

Да

Унаследовано от TDomain.Create

HideSeconds

Boolean

Да

Не показывать секунды

Замечания:

Создает новый объект класса TTimeDomain.

5.9.4.122.3. Метод GetSummary (Получить сводку)

Метод экземпляра класса TTimeDomain.
function TTimeDomain.GetSummary: string[2000];
Переопределяет метод в TDomain.GetSummary.

Метод скрыт от пользователя.

Метод является виртуальным методом.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.123. Класс TTypedValue (Типизированные значения)

Объекты класса не именованы.

5.9.4.123.1. Свойства

Свойства класса TTypedValue:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Нет

Скрыто от пользователя

Только для чтения

Мастер

MasterClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс мастера

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Domain

TDomain

Да

Видимо пользователю

Чтение/Запись

Домен

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

Класс домена

DomainRequired

Boolean

Да

Видимо пользователю

Только для чтения

Обязательно для заполнения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок закладки

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Заголовок группы

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

За пределами закладок

StrValue

string[2000]

Нет

Скрыто от пользователя

Чтение/Запись

Строковое значение

IntValue

Integer

Нет

Скрыто от пользователя

Чтение/Запись

Целое значение

FloatValue

float

Нет

Скрыто от пользователя

Чтение/Запись

Вещественное значение

DateValue

date

Нет

Скрыто от пользователя

Чтение/Запись

Значение даты

TimeValue

time

Нет

Скрыто от пользователя

Чтение/Запись

Значение времени

DateTimeValue

datetime

Нет

Скрыто от пользователя

Чтение/Запись

Значение даты со временем

ObjectValue

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Значение-объект

BoolValue

Boolean

Нет

Скрыто от пользователя

Чтение/Запись

Логическое значение

BlobValue

blob

Нет

Видимо пользователю

Чтение/Запись

Значение-большой объект

ClobValue

clob

Нет

Видимо пользователю

Чтение/Запись

Значение-текст

ExternalDataValue

<external data>

Нет

Видимо пользователю

Чтение/Запись

Значение-внешние данные

VisibleValue

string[2000]

Нет

Видимо пользователю

Только для чтения

Видимое значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

5.9.4.123.2. Конструктор Create (Конструктор типизированного значения)

Конструктор класса TTypedValue.
1constructor TTypedValue.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Domain: TDomain; Position: Integer; Group: string[128]; Tab: string[128];
4  Scope: TScope; OutOfTabs: Boolean; StrValue: string[2000]; IntValue: Integer;
5  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
6  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
7  ExternalDataValue: <external data>): TTypedValue;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Domain

TDomain

Да

Домен

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Создает новый объект класса TTypedValue.

5.9.4.123.3. Метод CompareBlob (Сравнить большие объекты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareBlob(ComparisonTypeName: string[64];
2  ValueA: blob; ValueB: blob): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

blob

Нет

Значение A

ValueB

blob

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.4. Метод CompareBoolean (Сравнить логические значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareBoolean(ComparisonTypeName: string[64];
2  ValueA: Boolean; ValueB: Boolean): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

Boolean

Да

Значение A

ValueB

Boolean

Да

Значение B

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.5. Метод CompareClob (Сравнить тексты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareClob(ComparisonTypeName: string[64];
2  ValueA: clob; ValueB: clob): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

clob

Нет

Значение A

ValueB

clob

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.6. Метод CompareDate (Сравнить значения дат)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareDate(ComparisonTypeName: string[64];
2  ValueA: date; ValueB: date): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

date

Нет

Значение A

ValueB

date

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.7. Метод CompareDateTime (Сравнить значения даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareDateTime(ComparisonTypeName: string[64];
2  ValueA: datetime; ValueB: datetime): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

datetime

Нет

Значение A

ValueB

datetime

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.8. Метод CompareFloat (Сравнить вещественные значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareFloat(ComparisonTypeName: string[64];
2  ValueA: float; ValueB: float): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

float

Нет

Значение A

ValueB

float

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.9. Метод CompareInt (Сравнить целые значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareInt(ComparisonTypeName: string[64];
2  ValueA: Integer; ValueB: Integer): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

Integer

Нет

Значение A

ValueB

Integer

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.10. Метод CompareList (Сравнить со списком)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareList(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

string[2000]

Нет

Значение A

ValueB

TObject

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.11. Метод CompareObject (Сравнить значения-объекты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareObject(ComparisonTypeName: string[64];
2  ValueA: TObject; ValueB: TObject): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

TObject

Нет

Значение A

ValueB

TObject

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.12. Метод CompareStr (Сравнить строковые значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareStr(ComparisonTypeName: string[64];
2  ValueA: string[2000]; ValueB: string[2000]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

string[2000]

Нет

Значение A

ValueB

string[2000]

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.13. Метод CompareTime (Сравнить значения времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CompareTime(ComparisonTypeName: string[64];
2  ValueA: time; ValueB: time): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

ComparisonTypeName

string[64]

Да

Имя типа сравнения

ValueA

time

Нет

Значение A

ValueB

time

Нет

Значение B

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.14. Метод CreateBlobValue (Создать значение-большой объект)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateBlobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BlobValue: blob): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

BlobValue

blob

Нет

Значение-большой объект

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.15. Метод CreateBoolValue (Создать логическое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateBoolValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  BoolValue: Boolean): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

BoolValue

Boolean

Нет

Логическое значение

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.16. Метод CreateClobValue (Создать значение-текст)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateClobValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ClobValue: clob): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Группа

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ClobValue

clob

Нет

Значение-текст

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.17. Метод CreateDateTimeValue (Создать значение даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateDateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateTimeValue: datetime): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

DateTimeValue

datetime

Нет

Значение даты со временем

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.18. Метод CreateDateValue (Создать значение даты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateDateValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  DateValue: date): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

DateValue

date

Нет

Значение даты

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.19. Метод CreateExternalDataValue (Создать значение внешних данных)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateExternalDataValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ExternalDataValue: <external data>): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ExternalDataValue

<external data>

Нет

Значение-внешние данные

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.20. Метод CreateFloatValue (Создать вещественное значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateFloatValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  FloatValue: float): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

FloatValue

float

Нет

Вещественное значение

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.21. Метод CreateIntValue (Создать целое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateIntValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  IntValue: Integer): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

IntValue

Integer

Нет

Целое значение

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.22. Метод CreateObjectValue (Создать значение-объект)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateObjectValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  ObjectValue: TObject): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

ObjectValue

TObject

Нет

Значение-объект

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.23. Метод CreateStrValue (Создать строковое значение)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateStrValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  StrValue: string[2000]): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

StrValue

string[2000]

Нет

Строковое значение

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.24. Метод CreateTimeValue (Создать значение времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.CreateTimeValue(Name: string[64];
2  Description: string[128]; Master: TObject; Parent: TObject;
3  DomainName: string[64]; Position: Integer; Group: string[128];
4  Tab: string[128]; Scope: TScope; OutOfTabs: Boolean;
5  TimeValue: time): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Имя

Description

string[128]

Да

Наименование

Master

TObject

Да

Мастер

Parent

TObject

Нет

Родитель

DomainName

string[64]

Да

Имя домена

Position

Integer

Да

Позиция

Group

string[128]

Нет

Заголовок группы

Tab

string[128]

Нет

Заголовок закладки

Scope

TScope

Да

Область видимости

OutOfTabs

Boolean

Да

За пределами закладок

TimeValue

time

Нет

Значение времени

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.25. Метод FindBlobValue (Поиск значения-большого объекта)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindBlobValue(Master: TObject;
2  ControlName: string[64]): blob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа blob.

5.9.4.123.26. Метод FindBoolValue (Поиск логического значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindBoolValue(Master: TObject;
2  ControlName: string[64]): Boolean;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа Boolean.

5.9.4.123.27. Метод FindClobValue (Поиск значения-текста)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindClobValue(Master: TObject;
2  ControlName: string[64]): clob;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа clob.

5.9.4.123.28. Метод FindDateTimeValue (Поиск значения даты со временем)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindDateTimeValue(Master: TObject;
2  ControlName: string[64]): datetime;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа datetime.

5.9.4.123.29. Метод FindDateValue (Поиск значения даты)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindDateValue(Master: TObject;
2  ControlName: string[64]): date;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа date.

5.9.4.123.30. Метод FindExternalDataValue (Поиск значения внешних данных)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindExternalDataValue(Master: TObject;
2  ControlName: string[64]): <external data>;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа <external data>.

5.9.4.123.31. Метод FindFloatValue (Поиск вещественного значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindFloatValue(Master: TObject;
2  ControlName: string[64]): float;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа float.

5.9.4.123.32. Метод FindIntValue (Поиск целого значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindIntValue(Master: TObject;
2  ControlName: string[64]): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа Integer.

5.9.4.123.33. Метод FindObjectValue (Поиск значения-объекта)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindObjectValue(Master: TObject;
2  ControlName: string[64]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа TObject.

5.9.4.123.34. Метод FindStrValue (Поиск строкового значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindStrValue(Master: TObject;
2  ControlName: string[64]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа string[2000].

5.9.4.123.35. Метод FindTimeValue (Поиск значения времени)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindTimeValue(Master: TObject;
2  ControlName: string[64]): time;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Объект-мастер

ControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа time.

5.9.4.123.36. Метод FindValue (Поиск значения)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.FindValue(AMaster: TObject;
2  AControlName: string[64]): TTypedValue;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

AMaster

TObject

Нет

Объект-мастер

AControlName

string[64]

Да

Имя элемента управления

Замечания:

Возвращает значение типа TTypedValue.

5.9.4.123.37. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.GetNextPos(Master: TObject; Parent: TObject;
2  Step: Integer): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер объекта

Parent

TObject

Нет

Родитель

Step

Integer

Да

Шаг

Замечания:

Возвращает значение типа Integer.

5.9.4.123.38. Метод GetVisibleValue (Видимое значение)

Метод экземпляра класса TTypedValue.
function TTypedValue.GetVisibleValue: string[2000];
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа string[2000].

5.9.4.123.39. Метод ReplaceWildcards (Заменить подстановочные символы)

Метод класса (статический метод) класса TTypedValue.
1class function TTypedValue.ReplaceWildcards(Value: string[2000];
2  Escape: string[2]): string[2000];
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Value

string[2000]

Нет

Значение

Escape

string[2]

Нет

Экранирующий символ

Замечания:

Возвращает значение типа string[2000].

5.9.4.123.40. Метод SetValue (Установить значение)

Метод экземпляра класса TTypedValue.
1procedure TTypedValue.SetValue(StrValue: string[2000]; IntValue: Integer;
2  FloatValue: float; DateValue: date; TimeValue: time; DateTimeValue: datetime;
3  ObjectValue: TObject; BoolValue: Boolean; BlobValue: blob; ClobValue: clob;
4  ExternalDataValue: <external data>);
Параметры:

Имя

Тип

Обязательно

Значение

StrValue

string[2000]

Нет

Строковое значение

IntValue

Integer

Нет

Целое значение

FloatValue

float

Нет

Вещественное значение

DateValue

date

Нет

Значение даты

TimeValue

time

Нет

Значение времени

DateTimeValue

datetime

Нет

Значение даты со временем

ObjectValue

TObject

Нет

Значение-объект

BoolValue

Boolean

Нет

Логическое значение

BlobValue

blob

Нет

Значение-большой объект

ClobValue

clob

Нет

Значение-текст

ExternalDataValue

<external data>

Нет

Значение-внешние данные

5.9.4.124. Класс TTypedValueButton (Кнопки на форме редактирования значений)

5.9.4.124.1. Свойства

Свойства класса TTypedValueButton:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Tab

string[128]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomButton

Group

string[128]

Нет

Видимо пользователю

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

OutOfTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

TypedValue

TTypedValue

Нет

Видимо пользователю

Чтение/Запись

Связанное типизированное значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

5.9.4.124.2. Конструктор Create (Конструктор кнопки формы редактирования значений)

Конструктор класса TTypedValueButton.
1constructor TTypedValueButton.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Group: string[128];
4  Tab: string[128]; Script: clob; Scope: TScope; OutOfTabs: Boolean;
5  TypedValue: TTypedValue): TObject;
Переопределяет метод в TCustomButton.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TCustomButton.Create

Group

string[128]

Нет

Tab

string[128]

Нет

Script

clob

Нет

Scope

TScope

Да

OutOfTabs

Boolean

Да

TypedValue

TTypedValue

Нет

Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueButton.

5.9.4.125. Класс TTypedValueView (Представления на форме редактирования значений)

Объекты класса образуют иерархию.

Имена объектов класса генерируются.

5.9.4.125.1. Свойства

Свойства класса TTypedValueView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TFormView

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Layout

TFormViewLayout

Да

Видимо пользователю

Чтение/Запись

ChildrenOnTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

ExplicitQuery

Boolean

Да

Видимо пользователю

Чтение/Запись

SpacePercentage

Integer

Нет

Видимо пользователю

Чтение/Запись

TypedValue

TTypedValue

Нет

Видимо пользователю

Чтение/Запись

Связанное типизированное значение

ControlName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор связанного типизированного значения

ViewName

string[64]

Да

Видимо пользователю

Чтение/Запись

Идентификатор элемента управления

5.9.4.125.2. Конструктор Create (Конструктор представления на форме редактирования значений)

Конструктор класса TTypedValueView.
1constructor TTypedValueView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  View: TCustomView; ChildrenMinimized: Boolean; ChildrenOnTabs: Boolean;
4  MasterProperty: TProperty; DetailProperty: TClassMember; Position: Integer;
5  SpacePercentage: Integer; Layout: TFormViewLayout; ExplicitQuery: Boolean;
6  TypedValue: TTypedValue): TObject;
Переопределяет метод в TFormView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

View

TCustomView

Да

Унаследовано от TFormView.Create

ChildrenMinimized

Boolean

Да

ChildrenOnTabs

Boolean

Да

MasterProperty

TProperty

Нет

DetailProperty

TClassMember

Нет

Position

Integer

Да

SpacePercentage

Integer

Нет

Layout

TFormViewLayout

Да

ExplicitQuery

Boolean

Да

TypedValue

TTypedValue

Нет

Связанное типизированное значение

Замечания:

Создает новый объект класса TTypedValueView.

5.9.4.126. Класс TUser (Пользователи)

5.9.4.126.1. Свойства

Свойства класса TUser:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

IsCurrent

Boolean

Да

Видимо пользователю

Только для чтения

Является текущим

AccessMode

TUserAccessMode

Да

Видимо пользователю

Чтение/Запись

Режим доступа

CanRecieveMessages

Boolean

Да

Видимо пользователю

Чтение/Запись

Получает сообщения

5.9.4.126.2. Конструктор Create (Конструктор пользователя)

Конструктор класса TUser.
1constructor TUser.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  CanRecieveMessages: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

CanRecieveMessages

Boolean

Да

Получает сообщения

Замечания:

Создает новый объект класса TUser.

5.9.4.126.3. Метод EffectiveMemberOf (Является эффективным членом)

Метод экземпляра класса TUser.
function TUser.EffectiveMemberOf(Role: TRole): Boolean;
Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Role

TRole

Да

Роль

Замечания:

Возвращает значение типа Boolean.

5.9.4.126.4. Метод GetCurrentUser (Получить текущего пользователя)

Метод класса (статический метод) класса TUser.
class function TUser.GetCurrentUser: TUser;
Метод скрыт от пользователя.

Метод является методом класса.

Метод не имеет параметров.

Замечания:

Возвращает значение типа TUser.

5.9.4.126.5. Метод GetIsCurrent (Является текущим)

Метод экземпляра класса TUser.
function TUser.GetIsCurrent: Boolean;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.127. Класс TUserNotification (Уведомления)

5.9.4.127.1. Свойства

Свойства класса TUserNotification:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Type

TNotificationType

Да

Видимо пользователю

Чтение/Запись

Тип

Text

clob

Нет

Видимо пользователю

Чтение/Запись

Текст

Active

Boolean

Да

Видимо пользователю

Чтение/Запись

Активно

ShowFrom

datetime

Нет

Видимо пользователю

Чтение/Запись

Показывать с

ShowTo

datetime

Нет

Видимо пользователю

Чтение/Запись

Показывать по

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

Выделено

ShowNeeded

Boolean

Да

Скрыто от пользователя

Только для чтения

Необходимо показывать

5.9.4.127.2. Конструктор Create (Конструктор уведомления)

Конструктор класса TUserNotification.
1constructor TUserNotification.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Type: TNotificationType; Text: clob;
4  Active: Boolean; ShowFrom: datetime; ShowTo: datetime): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Type

TNotificationType

Да

Тип

Text

clob

Нет

Текст

Active

Boolean

Да

Активно

ShowFrom

datetime

Нет

Показывать с

ShowTo

datetime

Нет

Показывать по

Замечания:

Создает новый объект класса TUserNotification.

5.9.4.127.3. Метод GetShowNeeded (Необходимо показывать)

Метод экземпляра класса TUserNotification.
function TUserNotification.GetShowNeeded: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.127.4. Метод Preview (Предпросмотр)

Метод экземпляра класса TUserNotification.
procedure TUserNotification.Preview;
Метод не имеет параметров.

5.9.4.127.5. Метод Shown (Отметить как показанное)

Метод экземпляра класса TUserNotification.
procedure TUserNotification.Shown;
Метод скрыт от пользователя.

Метод не имеет параметров.

5.9.4.128. Класс TUserNotificationAddressee (Адресаты уведомлений)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.128.1. Свойства

Свойства класса TUserNotificationAddressee:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

SecurityAccount

TSecurityAccount

Да

Видимо пользователю

Чтение/Запись

Роль безопасности

5.9.4.128.2. Конструктор Create (Конструктор адресата уведомления)

Конструктор класса TUserNotificationAddressee.
1constructor TUserNotificationAddressee.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Роль безопасности

Замечания:

Создает новый объект класса TUserNotificationAddressee.

5.9.4.129. Класс TUserNotificationShown (Показы уведомлений)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.129.1. Свойства

Свойства класса TUserNotificationShown:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TUserNotification

Да

Скрыто от пользователя

Только для чтения

Уведомление

Type

TNotificationType

Да

Видимо пользователю

Только для чтения

Тип уведомления

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

User

TUser

Да

Видимо пользователю

Только для чтения

Пользователь

TimeStamp

datetime

Да

Видимо пользователю

Только для чтения

Время

5.9.4.129.2. Конструктор Create (Конструктор показа уведомления)

Конструктор класса TUserNotificationShown.
1constructor TUserNotificationShown.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Замечания:

Создает новый объект класса TUserNotificationShown.

5.9.4.130. Класс TView (Представления)

5.9.4.130.1. Свойства

Свойства класса TView:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ShownClass

TClass

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TCustomView

ShownClassMasterClass

TClass

Нет

Видимо пользователю

Только для чтения

ShownClassReplicationStatus

TReplicationStatus

Да

Видимо пользователю

Только для чтения

ShownClassIsHierarhical

Boolean

Да

Видимо пользователю

Только для чтения

Skimpy

Boolean

Да

Видимо пользователю

Чтение/Запись

BoldProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

PreCompiled

Boolean

Да

Видимо пользователю

Чтение/Запись

PreOpenRoutine

TRoutine

Нет

Видимо пользователю

Чтение/Запись

ColorProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

OptimizationParameters

string[2000]

Нет

Видимо пользователю

Чтение/Запись

HasConditions

Boolean

Да

Видимо пользователю

Только для чтения

HasSpecificalyNamedColumns

Boolean

Да

Видимо пользователю

Только для чтения

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

IsGrouped

Boolean

Да

Видимо пользователю

Только для чтения

Сгруппировано

LinesPerRow

Integer

Да

Видимо пользователю

Чтение/Запись

Строк на ячейку

Collapsed

Boolean

Да

Видимо пользователю

Чтение/Запись

Свернуть

HasPresentations

Boolean

Да

Видимо пользователю

Только для чтения

Имеет виды

IsSorted

Boolean

Да

Видимо пользователю

Только для чтения

Отсортировано

IsAggregated

Boolean

Да

Видимо пользователю

Только для чтения

Агрегировано

5.9.4.130.2. Конструктор Create (Конструктор представления)

Конструктор класса TView.
1constructor TView.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  ShownClass: TClass; ColorProperty: TProperty; BoldProperty: TProperty;
4  Skimpy: Boolean; PreCompiled: Boolean; PreOpenRoutine: TRoutine;
5  Collapsed: Boolean): TObject;
Переопределяет метод в TCustomView.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

ShownClass

TClass

Да

Унаследовано от TCustomView.Create

ColorProperty

TProperty

Нет

BoldProperty

TProperty

Нет

Skimpy

Boolean

Да

PreCompiled

Boolean

Да

PreOpenRoutine

TRoutine

Нет

Collapsed

Boolean

Да

Свернуто

Замечания:

Создает новый объект класса TView.

5.9.4.130.3. Метод BuildDefaultColumns (Создать колонки по умолчанию)

Метод экземпляра класса TView.
1procedure TView.BuildDefaultColumns(AddNameColumn: Boolean;
2  AddDescColumn: Boolean);
Параметры:

Имя

Тип

Обязательно

Значение

AddNameColumn

Boolean

Да

Создать колонку имени

AddDescColumn

Boolean

Да

Создать колонку наименования

5.9.4.130.4. Метод GetHasPresentations (Имеет виды)

Метод экземпляра класса TView.
function TView.GetHasPresentations: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.130.5. Метод GetIsAggregated (Агрегировано)

Метод экземпляра класса TView.
function TView.GetIsAggregated: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.130.6. Метод GetIsGrouped (Сгруппировано)

Метод экземпляра класса TView.
function TView.GetIsGrouped: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.130.7. Метод GetIsSorted (Отсортировано)

Метод экземпляра класса TView.
function TView.GetIsSorted: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.131. Класс TViewAction (Действие-представление)

Объекты класса образуют иерархию.

5.9.4.131.1. Свойства

Свойства класса TViewAction:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Shortcut

string[20]

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TAction

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Separated

Boolean

Да

Видимо пользователю

Чтение/Запись

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

View

TCustomView

Да

Видимо пользователю

Чтение/Запись

Представление

ShownClass

TClass

Да

Видимо пользователю

Только для чтения

Показываемый класс

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

5.9.4.131.2. Конструктор Create (Конструктор действия-представления)

Конструктор класса TViewAction.
1constructor TViewAction.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Shortcut: string[20]; Separated: Boolean; Default: Boolean;
4  View: TCustomView; MasterProperty: TProperty;
5  DetailProperty: TClassMember): TObject;
Переопределяет метод в TAction.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TAction.Create

Shortcut

string[20]

Нет

Separated

Boolean

Да

Default

Boolean

Да

View

TCustomView

Да

Представление

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

Замечания:

Создает новый объект класса TViewAction.

5.9.4.132. Класс TViewColumn (Колонки представлений)

5.9.4.132.1. Свойства

Свойства класса TViewColumn:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Property

TProperty

Да

Видимо пользователю

Чтение/Запись

Свойство

PropertyDomain

TDomain

Да

Видимо пользователю

Только для чтения

Домен

PropertyDomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

Определение домена

PropertyReadMember

TClassMember

Нет

Видимо пользователю

Только для чтения

Член класса для чтения

PropertyReadMemberClass

TClass

Да

Видимо пользователю

Только для чтения

Класс члена класса для чтения

PropertyWriteMember

TClassMember

Нет

Видимо пользователю

Только для чтения

Член класса для записи

PropertyName

string[64]

Да

Видимо пользователю

Только для чтения

Имя свойства

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Grouped

Boolean

Да

Видимо пользователю

Чтение/Запись

Группировать

Aggregate

TAggregateKind

Нет

Видимо пользователю

Чтение/Запись

Агрегат

SortDirection

TSortDirection

Да

Видимо пользователю

Чтение/Запись

Направление сортировки

Width

Integer

Да

Видимо пользователю

Чтение/Запись

Ширина

Filter

string[128]

Нет

Видимо пользователю

Чтение/Запись

Фильтр

ForceReadOnly

Boolean

Да

Видимо пользователю

Чтение/Запись

Только для чтения

Fixed

Boolean

Да

Видимо пользователю

Чтение/Запись

Зафиксирована

IsFilterHidden

Boolean

Да

Видимо пользователю

Чтение/Запись

Фильтр скрыт

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

Bold

Boolean

Да

Видимо пользователю

Чтение/Запись

Выделить шрифтом

DirectAction

TAction

Нет

Видимо пользователю

Чтение/Запись

Непосредственное действие

IsSpecificalyNamed

Boolean

Да

Видимо пользователю

Только для чтения

Специфическое имя

5.9.4.132.2. Конструктор Create (Конструктор колонки представления)

Конструктор класса TViewColumn.
1constructor TViewColumn.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Property: TProperty; Position: Integer; Grouped: Boolean;
4  Aggregate: TAggregateKind; SortDirection: TSortDirection; Fixed: Boolean;
5  Category: string[128]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Property

TProperty

Да

Свойство

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TViewColumn.

5.9.4.132.3. Метод Change (Изменение объекта)

Метод экземпляра класса TViewColumn.
procedure TViewColumn.Change(Action: TChangeAction);
Переопределяет метод в TObject.Change.

Метод скрыт от пользователя.

Параметры:

Имя

Тип

Обязательно

Значение

Action

TChangeAction

Да

Унаследовано от TObject.Change

5.9.4.132.4. Метод CreateByNames (Добавить по списку свойств)

Метод класса (статический метод) класса TViewColumn.
1class procedure TViewColumn.CreateByNames(Master: TCustomView;
2  Names: string[2000]);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TCustomView

Да

Мастер

Names

string[2000]

Нет

Имена свойств

5.9.4.132.5. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TViewColumn.
class function TViewColumn.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

5.9.4.132.6. Метод NameAfterProperty (Дать имя свойства)

Метод экземпляра класса TViewColumn.
procedure TViewColumn.NameAfterProperty;
Метод скрыт от пользователя.

Метод не имеет параметров.

5.9.4.133. Класс TViewCondition (Условия отбора)

Объекты класса образуют иерархию.

5.9.4.133.1. Свойства

Свойства класса TViewCondition:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

LinkedClass

TClass

Нет

Видимо пользователю

Чтение/Запись

Присоединяемый класс

MasterProperty

TProperty

Нет

Видимо пользователю

Чтение/Запись

Свойство-главное

DetailProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство-подчиненное

LinkedOption

TOption

Нет

Видимо пользователю

Чтение/Запись

Присоединенная настройка

LinkedOptionName

string[64]

Да

Видимо пользователю

Только для чтения

Имя присоединяемой настройки

LinkedOptionProperty

TClassMember

Нет

Видимо пользователю

Чтение/Запись

Свойство присоединенной настройки

Expression

clob

Нет

Видимо пользователю

Чтение/Запись

Выражение условия

Negation

Boolean

Да

Видимо пользователю

Чтение/Запись

Отрицание

LinkNonRequired

Boolean

Да

Видимо пользователю

Чтение/Запись

Присоединять необязательное свойство

LinkedProfile

TProfile

Нет

Видимо пользователю

Чтение/Запись

Присоединенный профиль

5.9.4.133.2. Конструктор Create (Конструктор условия отбора)

Конструктор класса TViewCondition.
1constructor TViewCondition.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  LinkedClass: TClass; MasterProperty: TProperty; DetailProperty: TClassMember;
4  LinkedOption: TOption; LinkedOptionProperty: TClassMember; Expression: clob;
5  Negation: Boolean; LinkNonRequired: Boolean; LinkedProfile: TProfile): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

LinkedClass

TClass

Нет

Присоединяемый класс

MasterProperty

TProperty

Нет

Свойство-главное

DetailProperty

TClassMember

Нет

Свойство-подчиненное

LinkedOption

TOption

Нет

Присоединенная настройка

LinkedOptionProperty

TClassMember

Нет

Свойство присоединенной настройки

Expression

clob

Нет

Выражение условия отбора

Negation

Boolean

Да

Отрицание

LinkNonRequired

Boolean

Да

Присоединять необязательное свойство

LinkedProfile

TProfile

Нет

Присоединенный профиль

Замечания:

Создает новый объект класса TViewCondition.

5.9.4.134. Класс TViewPresentation (Виды)

Имена объектов класса генерируются.

5.9.4.134.1. Свойства

Свойства класса TViewPresentation:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

ChildrenMinimized

Boolean

Да

Видимо пользователю

Чтение/Запись

Дочерние представления минимизированы

Default

Boolean

Да

Видимо пользователю

Чтение/Запись

Использовать по умолчанию

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

5.9.4.134.2. Конструктор Create (Конструктор вида)

Конструктор класса TViewPresentation.
1constructor TViewPresentation.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer;
4  ChildrenMinimized: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

Замечания:

Создает новый объект класса TViewPresentation.

5.9.4.134.3. Метод GetIsAccessible (Проверка доступности)

Метод экземпляра класса TViewPresentation.
function TViewPresentation.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.134.4. Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentation.
1class function TViewPresentation.Save(Master: TObject;
2  Description: string[128]; ChildrenMinimized: Boolean): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Да

Мастер

Description

string[128]

Да

Наименование

ChildrenMinimized

Boolean

Да

Дочерние представления минимизированы

Замечания:

Возвращает значение типа TObject.

5.9.4.135. Класс TViewPresentationAccess (Доступ к видам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.135.1. Конструктор Create (Конструктор доступа к виду)

Конструктор класса TViewPresentationAccess.
1constructor TViewPresentationAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TViewPresentationAccess.

5.9.4.136. Класс TViewPresentationColumn (Колонки вида)

Имена объектов класса генерируются.

5.9.4.136.1. Свойства

Свойства класса TViewPresentationColumn:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Column

TViewColumn

Да

Видимо пользователю

Только для чтения

Колонка представления

Presentation

TViewPresentation

Да

Скрыто от пользователя

Только для чтения

Вид

View

TObject

Да

Скрыто от пользователя

Только для чтения

Представление

IsAccessible

Boolean

Да

Видимо пользователю

Только для чтения

Доступен

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Grouped

Boolean

Да

Видимо пользователю

Чтение/Запись

Сгруппирована

Aggregate

TAggregateKind

Нет

Видимо пользователю

Чтение/Запись

Агрегат

SortDirection

TSortDirection

Да

Видимо пользователю

Чтение/Запись

Направление сортировки

Width

Integer

Да

Видимо пользователю

Чтение/Запись

Ширина

Filter

string[128]

Нет

Видимо пользователю

Чтение/Запись

Фильтр

Fixed

Boolean

Да

Видимо пользователю

Чтение/Запись

Зафиксирована

Category

string[128]

Нет

Видимо пользователю

Чтение/Запись

Категория

5.9.4.136.2. Конструктор Create (Конструктор колонки вида)

Конструктор класса TViewPresentationColumn.
1constructor TViewPresentationColumn.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Column: TViewColumn; Position: Integer;
4  Grouped: Boolean; Aggregate: TAggregateKind; SortDirection: TSortDirection;
5  Width: Integer; Filter: string[128]; Fixed: Boolean;
6  Category: string[128]): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Column

TViewColumn

Да

Колонка

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Width

Integer

Да

Ширина

Filter

string[128]

Нет

Фильтр

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Создает новый объект класса TViewPresentationColumn.

5.9.4.136.3. Метод AddColumns (Создать колонки)

Метод класса (статический метод) класса TViewPresentationColumn.
class procedure TViewPresentationColumn.AddColumns(Master: TViewPresentation);
Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TViewPresentation

Да

Мастер

5.9.4.136.4. Метод Save (Сохранить)

Метод класса (статический метод) класса TViewPresentationColumn.
1class function TViewPresentationColumn.Save(Master: TViewPresentation;
2  Column: TViewColumn; Position: Integer; Grouped: Boolean;
3  Aggregate: TAggregateKind; SortDirection: TSortDirection; Width: Integer;
4  Filter: string[128]; Fixed: Boolean; Category: string[128]): TObject;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TViewPresentation

Да

Мастер

Column

TViewColumn

Да

Колонка

Position

Integer

Да

Позиция

Grouped

Boolean

Да

Группировать

Aggregate

TAggregateKind

Нет

Агрегат

SortDirection

TSortDirection

Да

Направление сортировки

Width

Integer

Да

Ширина

Filter

string[128]

Нет

Фильтр

Fixed

Boolean

Да

Зафиксирована

Category

string[128]

Нет

Категория

Замечания:

Возвращает значение типа TObject.

5.9.4.137. Класс TVisualGroup (Визуальные группы)

Объекты класса образуют иерархию.

5.9.4.137.1. Свойства

Свойства класса TVisualGroup:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение

IsAccessible

Boolean

Да

Скрыто от пользователя

Только для чтения

Доступна

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

Область видимости

Collapsed

Boolean

Да

Видимо пользователю

Чтение/Запись

Свернута

5.9.4.137.2. Конструктор Create (Конструктор визуальной группы)

Конструктор класса TVisualGroup.
1constructor TVisualGroup.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Image: blob; Position: Integer; Scope: TScope; Collapsed: Boolean): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Image

blob

Нет

Изображение

Position

Integer

Да

Позиция

Scope

TScope

Да

Область видимости

Collapsed

Boolean

Да

Свернута

Замечания:

Создает новый объект класса TVisualGroup.

5.9.4.137.3. Метод GetIsAccessible (Доступна)

Метод экземпляра класса TVisualGroup.
function TVisualGroup.GetIsAccessible: Boolean;
Метод скрыт от пользователя.

Метод не имеет параметров.

Замечания:

Возвращает значение типа Boolean.

5.9.4.137.4. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroup.
class function TVisualGroup.GetNextPos(Parent: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Parent

TObject

Нет

Родитель

Замечания:

Возвращает значение типа Integer.

5.9.4.138. Класс TVisualGroupAccess (Доступ к визуальным группам)

Имена объектов класса генерируются.

Наименования объектов класса генерируются.

5.9.4.138.1. Конструктор Create (Конструктор доступа к визуальной группе)

Конструктор класса TVisualGroupAccess.
1constructor TVisualGroupAccess.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TVisualGroup;
3  Accessor: TSecurityAccount; SecurityAccount: TSecurityAccount): TObject;
Переопределяет метод в TAccessItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TVisualGroup

Да

Группа доступа

Accessor

TSecurityAccount

Нет

Унаследовано от TObject.Create

SecurityAccount

TSecurityAccount

Да

Унаследовано от TAccessItem.Create

Замечания:

Создает новый объект класса TVisualGroupAccess.

5.9.4.139. Класс TVisualGroupForm (Форма визуальной группы)

5.9.4.139.1. Свойства

Свойства класса TVisualGroupForm:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TVisualGroupItem

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Form

TForm

Да

Видимо пользователю

Чтение/Запись

Форма

Image

blob

Нет

Видимо пользователю

Чтение/Запись

Изображение

5.9.4.139.2. Конструктор Create (Конструктор формы визуальной группы)

Конструктор класса TVisualGroupForm.
1constructor TVisualGroupForm.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob; Form: TForm): TObject;
Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TVisualGroupItem.Create

Comment

clob

Нет

Form

TForm

Да

Форма

Замечания:

Создает новый объект класса TVisualGroupForm.

5.9.4.140. Класс TVisualGroupItem (Элемент визуальной группы)

5.9.4.140.1. Свойства

Свойства класса TVisualGroupItem:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Позиция

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Комментарий

5.9.4.140.2. Конструктор Create (Конструктор элемента визуальной группы)

Конструктор класса TVisualGroupItem.
1constructor TVisualGroupItem.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Position: Integer; Comment: clob): TObject;
Переопределяет метод в TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Позиция

Comment

clob

Нет

Комментарий

Замечания:

Создает новый объект класса TVisualGroupItem.

5.9.4.140.3. Метод GetNextPos (Следующая позиция)

Метод класса (статический метод) класса TVisualGroupItem.
class function TVisualGroupItem.GetNextPos(Master: TObject): Integer;
Метод скрыт от пользователя.

Метод является методом класса.

Параметры:

Имя

Тип

Обязательно

Значение

Master

TObject

Нет

Мастер

Замечания:

Возвращает значение типа Integer.

5.9.4.141. Класс TVisualGroupRoutine (Подпрограмма визуальной группы)

5.9.4.141.1. Свойства

Свойства класса TVisualGroupRoutine:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Position

Integer

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TVisualGroupItem

Comment

clob

Нет

Видимо пользователю

Чтение/Запись

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

Подпрограмма

5.9.4.141.2. Конструктор Create (Конструктор подпрограммы визуальной группы)

Конструктор класса TVisualGroupRoutine.
1constructor TVisualGroupRoutine.Create(Name: string[64];
2  Description: string[128]; Class: TClass; Parent: TObject; Master: TObject;
3  Accessor: TSecurityAccount; Position: Integer; Comment: clob;
4  Routine: TRoutine): TObject;
Переопределяет метод в TVisualGroupItem.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Position

Integer

Да

Унаследовано от TVisualGroupItem.Create

Comment

clob

Нет

Routine

TRoutine

Да

Подпрограмма

Замечания:

Создает новый объект класса TVisualGroupRoutine.

5.9.4.142. Класс TWordAsyncTask (Задачи отложенного выполнения отчетов Word)

Объекты класса не именованы.

5.9.4.142.1. Свойства

Свойства класса TWordAsyncTask:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Видимо пользователю

Только для чтения

Унаследовано от TAsyncTask

Created

datetime

Да

Видимо пользователю

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Унаследовано от TObject

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Status

TAsyncTaskStatus

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TAsyncTask

Routine

TRoutine

Да

Видимо пользователю

Чтение/Запись

RoutineClass

TClass

Да

Скрыто от пользователя

Только для чтения

Language

TLanguage

Да

Видимо пользователю

Чтение/Запись

Handler

TAsyncHandler

Да

Видимо пользователю

Чтение/Запись

FormView

TFormView

Нет

Видимо пользователю

Чтение/Запись

Object

TObject

Нет

Видимо пользователю

Чтение/Запись

Started

datetime

Нет

Видимо пользователю

Чтение/Запись

Finished

datetime

Нет

Видимо пользователю

Чтение/Запись

Duration

time

Нет

Видимо пользователю

Только для чтения

Bold

Boolean

Да

Скрыто от пользователя

Только для чтения

RowColor

TRowColor

Нет

Скрыто от пользователя

Только для чтения

Group

TAsyncTask

Нет

Видимо пользователю

Только для чтения

GroupContentReady

Boolean

Да

Скрыто от пользователя

Только для чтения

Format

TWordOutputFormat

Да

Видимо пользователю

Чтение/Запись

Формат

5.9.4.142.2. Конструктор Create (Конструктор задачи отложенного выполнения отчетов Word)

Конструктор класса TWordAsyncTask.
1constructor TWordAsyncTask.Create(Name: string[64]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  Routine: TRoutine; Object: TObject; FormView: TFormView;
4  Handler: TAsyncHandler; Language: TLanguage; Format: TWordOutputFormat): TObject;
Переопределяет метод в TAsyncTask.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[64]

Да

Унаследовано от TObject.Create

Description

string[128]

Да

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

Routine

TRoutine

Да

Унаследовано от TAsyncTask.Create

Object

TObject

Нет

FormView

TFormView

Нет

Handler

TAsyncHandler

Да

Language

TLanguage

Да

Format

TWordOutputFormat

Да

Формат

Замечания:

Создает новый объект класса TWordAsyncTask.

5.9.4.143. Класс TWordTemplate (Шаблоны отчетов Word)

5.9.4.143.1. Свойства

Свойства класса TWordTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

blob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

MacroName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя макроса

IsInteractive

Boolean

Да

Видимо пользователю

Чтение/Запись

Интерактивный

5.9.4.143.2. Конструктор Create (Конструктор шаблона отчета Word)

Конструктор класса TWordTemplate.
1constructor TWordTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: blob;
6  MacroName: string[128]; IsInteractive: Boolean): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

blob

Нет

Данные шаблона

MacroName

string[128]

Нет

Имя макроса

IsInteractive

Boolean

Да

Интерактивный

Замечания:

Создает новый объект класса TWordTemplate.

5.9.4.143.3. Метод Ole-объекта CheckWordTemplate (Проверить шаблон отчетов Word)

Метод Ole-объекта класса TWordTemplate.

Метод Ole-объекта не имеет параметров.

5.9.4.144. Класс TXSLTTemplate (Шаблоны отчетов XSLT)

5.9.4.144.1. Свойства

Свойства класса TXSLTTemplate:

Имя

Тип

Обязательно

Видимость

Доступ

Назначение

Name

string[64]

Да

Видимо пользователю

Чтение/Запись

Унаследовано от TObject

Description

string[128]

Да

Видимо пользователю

Чтение/Запись

Class

TClass

Да

Скрыто от пользователя

Только для чтения

ReplicationStatus

TReplicationStatus

Да

Скрыто от пользователя

Только для чтения

Parent

TObject

Нет

Скрыто от пользователя

Чтение/Запись

Master

TObject

Да

Скрыто от пользователя

Только для чтения

SourceDataBase

TDataBase

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseGUID

string[38]

Да

Скрыто от пользователя

Только для чтения

SourceDataBaseIsCurrent

Boolean

Да

Скрыто от пользователя

Только для чтения

OldID

string[38]

Да

Скрыто от пользователя

Только для чтения

Creator

TUser

Да

Скрыто от пользователя

Только для чтения

Created

datetime

Да

Скрыто от пользователя

Только для чтения

Modifier

TUser

Да

Скрыто от пользователя

Только для чтения

Modified

datetime

Да

Скрыто от пользователя

Только для чтения

Reader

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Writer

TSecurityAccount

Нет

Скрыто от пользователя

Чтение/Запись

Override

Boolean

Да

Видимо пользователю

Только для чтения

Унаследовано от TClassMember

Domain

TDomain

Нет

Видимо пользователю

Чтение/Запись

Унаследовано от TRoutine

DomainClass

TClass

Да

Скрыто от пользователя

Только для чтения

DomainDefinition

string[64]

Да

Видимо пользователю

Только для чтения

IsClassMethod

Boolean

Да

Видимо пользователю

Чтение/Запись

Confirmation

string[512]

Нет

Видимо пользователю

Чтение/Запись

Scope

TScope

Да

Видимо пользователю

Чтение/Запись

UseTabs

Boolean

Да

Видимо пользователю

Чтение/Запись

Script

clob

Нет

Видимо пользователю

Чтение/Запись

Image

blob

Нет

Видимо пользователю

Чтение/Запись

ParamCount

Integer

Нет

Видимо пользователю

Только для чтения

Logged

Boolean

Да

Видимо пользователю

Чтение/Запись

ReportMessage

string[512]

Нет

Видимо пользователю

Чтение/Запись

SingleObject

Boolean

Да

Видимо пользователю

Чтение/Запись

DependenciesCount

Integer

Нет

Видимо пользователю

Только для чтения

TemplateData

clob

Нет

Видимо пользователю

Чтение/Запись

Данные шаблона

FunctionName

string[128]

Нет

Видимо пользователю

Чтение/Запись

Имя функции

5.9.4.144.2. Конструктор Create (Конструктор шаблона отчета XSLT)

Конструктор класса TXSLTTemplate.
1constructor TXSLTTemplate.Create(Name: string[30]; Description: string[128];
2  Class: TClass; Parent: TObject; Master: TObject; Accessor: TSecurityAccount;
3  IsClassMethod: Boolean; SingleObject: Boolean; Domain: TDomain; Scope: TScope;
4  Confirmation: string[512]; ReportMessage: string[512]; UseTabs: Boolean;
5  Script: clob; Image: blob; Logged: Boolean; TemplateData: clob;
6  FunctionName: string[128]): TObject;
Переопределяет метод в TRoutine.Create, TClassMember.Create, TObject.Create.

Параметры:

Имя

Тип

Обязательно

Значение

Name

string[30]

Да

Унаследовано от TClassMember.Create

Description

string[128]

Да

Унаследовано от TObject.Create

Class

TClass

Нет

Parent

TObject

Нет

Master

TObject

Да

Accessor

TSecurityAccount

Нет

IsClassMethod

Boolean

Да

Унаследовано от TRoutine.Create

SingleObject

Boolean

Да

Domain

TDomain

Нет

Scope

TScope

Да

Confirmation

string[512]

Нет

ReportMessage

string[512]

Нет

UseTabs

Boolean

Да

Script

clob

Нет

Image

blob

Нет

Logged

Boolean

Да

TemplateData

clob

Нет

Данные шаблона

FunctionName

string[128]

Нет

Имя вызываемой функции

Замечания:

Создает новый объект класса TXSLTTemplate.

5.9.4.144.3. Метод Ole-объекта CheckXSLTTemplate (Проверить шаблон отчетов XSLT)

Метод Ole-объекта класса TXSLTTemplate.

Метод Ole-объекта не имеет параметров.

5.9.5. Терминология

Интеграция - комплекс работ по настройке механизмов взаимодействия между различными учетными системами, которые функционируют независимо друг от друга в одной организационной структуре ("лоскутная" автоматизация).

Реплика - копия объекта (например, базы данных), обновляемая автоматически при обновлении оригинала.

Модальная форма - подчиененная форма, вызываемая из процедуры, накладывающая ограничения на использование процедуры пока модальная форма не будет закрыта.

5.10. Облачные вычисления

Под терминами "Облака", "Облачные вычисления" подразумеваются способы организации распределенных вычислений данных, функций, всего того, что требуется для автоматизации бизнес-процессов. Реализация подобной технологии иначе называется DNS (Domain Name System - система доменных имен). Упрощенно можно сказать, что существует база данных, где каждому зарегистрированному доменному имени соответствует некий IP-адрес. Также в записях этой базы данных предусмотрены настройки, указывающие на использование записей для различных действий (для электронной почты, для web и т.д.). База данных является распределенной, она хранится на множестве серверов в сети Internet одновременно, и каждый из этих серверов по стандартному описанному протоколу отдает записи этой базы данных. При необходимости можно осуществить сбор всей информации DNS, однако данные меняются настолько быстро, что в результате такой операции будут получены устаревшие значения, не соответствующие реальным.

В то же время с данными DNS вполне допустимо производить кэширование, периодическое обновление и т.п. Смысл "облачной" технологии в том, что данные заменяются на функции доступа к ним. Таким образом, нет необходимости хранить данные о соответствии DNS-имен IP-адресам. При этом всегда доступна информация о том как и куда необходимо обратиться с запросом данных и как использовать полученный ответ.

Одной из причин внедрения "облачных" технологий на предприятиях заказчика зачастую является имиджевый аспект, когда во главу угла ставится погоня за новыми технологиями на предприятии.

Для понимания, приведем пример одного из московских ВУЗов с широкой сетью филиалов.

В начале создания внутрикорпоративной системы ВУЗа ее построение происходило постепенно, по частям. Было создано централизованное хранилище всех данных, база данных с необходимыми данными и бизнес-функциями, которые выполнялись над этими данными. Все пользователи системы осуществляли свою работу из единой локальной сети с включенной в нее базой данных. Соединения осуществлялись по стандартному потоколу, предоставляемому СУБД. Этот протокол требовал низколатентных соединений и пользователи были удовлетворены, однако существловали достаточно критичные ограничения на доступ к базе данных. Данная технология представляла собой технологию "клиент-сервер".

В дальнейшем потребовалось распространение решения для удаленных филиалов ВУЗа. Было принято внутреннее решение IT-служб ВУЗа о разделении базы данных, то есть каждый филиал получил собственную базу данных (изначально пустую) и начал работать с ней. Попытка синхронизации справочников собственными усилиями не удалась. Синхронизация данных - удалась частично. Сопутствующие сопровождению системы задачи (например, распространение обновлений и др.) решались с переменным успехом.

В результате было принято решение о внедрении "облачных" технологий. Для реализации использовались сервера приложений Платформы "Мельница Данных". С их помощью были построены точки входа в единое хранилище данных. Все данные были объединены в одну централизованную базу данных и доступ к ней осуществляется каждым филиалом через собственный "обработчик", созданный для конкретного филиала. В итоге каждому филиалу достаточно знать только точку входа, через которую доступна соответствующая функция Системы. При этом пользователей филиала не должно интересовать, куда перенаправляются их запросы и какие действия осуществляются в базе данных. В следствии такого внедрения отпала необходимость в дополнительных администраторах Системы, в отслеживании вычислительных мощностей и т.д.

Вопросы по разграничению доступа, настроек и т.п. в данный момент решаются централизованно.

Простым и правильным способом организации корпоративных "облачных" SaaS-технологий будет поддержка такого решения в пределах одной организации.

Другой реальный пример внедрения "облачных" технологий - другой крупный ВУЗ:

При внедрении Системы не оказалось сил, способных осуществлять обслуживание серверных мощностей. В итоге компания "Мельница Технолгий" на собственных подконтрольных площадях самостоятельно развернула всю инфраструктуру, требующуюся для функционирования базы данных ВУЗа. Далее, на базе решения сервер приложений Платформы были созданы точки входа, через которые все функции Системы, а также все данные были доступны пользователям ВУЗа.

Основным аргументом представителей ВУЗа против подобного внедрения был тот факт, что данные хранятся не на собственных мощностях, а у стороннего поставщика услуг. Для разрешения спорного вопроса, каждую ночь на мощностях компании "Мельница Технологий" автоматически создается реплика с самыми актуальными данными. Таким образом ВУЗ всегда имеет в своем распоряжении ежедневный backup для оперативного развертывания в случае форс-мажора.

Из примера понятно, что компания "Мельница Технологий" имеет все возможности и ресурсы для подключения новых пользователей "облака", которые не желают или не имеют возможности заниматься обслуживанием Системы. При этом на заказчика не ложатся затраты на закупку и развертывание инфраструктуры и базы данных, на содержание администраторов Системы.

Второй частой причиной организации "облака" на предприятии является насущная необходимость. В этом случае Заказчик понимает технологию "облака", знает какие бизнес-функции могут быть реализованы, при этом предприятие имеет широкую разветвленную сеть удаленных филиалов, нуждающихся в доступе к централизованным данным.

Следует обратить внимание, что понятия "Облако", "Облачные вычисления" носят сугубо маркетинговый характер и не несут какой-то четкой логики построения решений. Технология заключается только в создании точек входа, за которыми функции распределяются по собственным алгоритмам, которые не должны интересовать конечного пользователя. Данные алгоритмы всегда могут быть изменены в зависимости от необходимости. Так, при возрастании нагрузки на "облако", она может быть перераспределена по тому количеству серверов, которое необходимо и удобно.

5.11. OLTP и OLAP

OLTP (OnLine Transaction Processing) - обработка транзакций онлайн.

Задача, которая решается с помощью OLTP-метода называется здесь и дальше "учет". Т.е. это в первую очередь учетные задачи. Характерным элементом управления решенной OLTP-задачи является так называемый "grid" - таблица, состоящая из колонок и строк.

Когда ставится и решается задача постановки учета чего бы то ни было, например, продаж мороженого, пользователь должен увидеть в результате "grid" (таблицу, табличное представление), где каждая строка соответствует одному объекту учета, в данном случае - продаже мороженого, а каждый столбец соответствует атрибуту этого самого элемента учета. В нашем случае, с продажами мороженого это точка, которая продала, сорт, количество, цена, сумма продажи и т.д.

Сорт мороженного

Точка продаж

Кол-во

Цена

Сумма

Пломбир

ул. Ленина

50

20

1000

Ленинградское

ул. Ленина

20

18

360

Эскимо

ул. Ленина

100

23

2300

Лакомка

ул. Ленина

30

25

750

В стаканчике

ул. Ленина

150

12

1800

Эта таблица должна храниться в базе данных и пользователю не важно при помощи какой технологии построена база данных (на реляционных принципах, на объектных принципах или других). Важно то, что клиентское приложение, с которым пользователь непосредственно взаимодействует, может получить данные и показать их в виде таблицы.

Как правило, у пользователя есть несколько стандартных действий для управления данными в таблице - сортировка, группировка, отбор по колонкам, по дополнительным критериям. Все эти действия предназначены быстрого поиска ошибок в данных. Таким образом поиск ошибок учета осуществляется именно в таблицах. Для исправления ошибок используются следующие методы:

1. В таблице, соответствующая ячейка переводится в режим редактирования, данные изменяются непосредственно в ней, нажатием клавиши Enter подтверждается изменение, и, если новое значение удовлетворяет внутренним ограничениям Системы, то оно будет записано в базу данных.

2. Исправление может рассматриваться как операция, в этом случае: выделяется один или несколько объектов таблицы, т.е. одна или несколько строчек, вызывается действие (либо кнопкой в панели инструментов, либо через контекстное меню, либо каким-то более экзотическим способом). Будет показана модальная форма ввода значений и параметров. При этом пользователь не сможет продолжить работы с системой пока эта форма не будет закрыта после внесения изменений или без них. Только после закрытия модальной формы действие начинает выполняться.

3. Для Платформы "Мельница Данных" также разработан элемент управления, который называется "инспектор объектов". Он используется для установки одинаковых значений для выбранных в таблице однородных объектов. Также инспектор объектов используется, для удобного просмотра всех атрибутов объекта, так как зачастую таблица содержит такое большое количество колонок, что работа с ними в таблице.

После поиска ошибок какие-то из объектов таблицы участвуют в дальнейших бизнес-процессах, которые должны быть реализованы, какие-то не участвуют и просто хранятся.

Для конечного пользователя простой ввод бизнес-данных в систему учета не имеет никакого практического смысла без возможности дальнейшей обработки и формирования отчетности.

Первичные данные, полученные в результате решения OLTP-задачи, должны использоваться для решения бизнес-задач.

OLАP (Online Analisys Processing) - аналитическая обработка в реальном времени.

В результате решения задачи OLAP система может получить следующее:

1. Результаты обработки, готовые к публикации.

2. Информация для дальнейшего принятия управленческих решений.

Данные, полученные в результате решения OLTP-задачи, поступают на вход и рассматриваются в качестве входных данных для задачи OLАP. Такие данные принято называть "Фактами". Факты должны быть предварительно выверены, подготовлены. В зависимости от разработанных стандартов для Системы не все данные могут быть переданы в OLAP-задачу в качестве фактов. Для данных могут использоваться дополнительные признаки, такие как: "Выверено", "Обработано", "Проверено", "Утверждено". Соответственно на вход OLAP-задачи можно направить данные, для которых один, несколько или все признаки (определяется логикой при разработке) имеют значение "Истина". Факты, которые попали на вход OLAP-задачи, составляют таблицу фактов. В таблице фактов выделяются факты, которые являются "мерой" (measure) или "показателем" (index).

Для примера, самый простой показатель - это количество самих фактов, а также средняя сумма, дисперсия, любой агрегат над этим значением.

Далее выверяют измерение анализа - это, как правило, ссылки на справочные таблицы, и по этим справочным таблицам строится список соответствующий измерению (dimension). На основании таблицы фактов и информации о том, что у нас является показателем, что у нас является измерениями, строится так называемый "куб". Структура данных "куба" сложная. Для наглядности, ниже приведен "куб" для нашего простого примера продаж мороженного:

В качестве меры выбрано количество сумма продаж по деньгам, а в качестве измерения - сорт мороженого, дата и точка, которая эту продажу осуществила. По первой оси - дата. По этой оси выстраиваются все дни соответствующего периода, 01.01.2012, 02.01.2012 и так далее. За год - 365 точек. По другой оси выстраиваются все имеющиеся в продаже сорта. По третьей оси мы ставим точки, соответствующие точкам продаж. В получившемся кубе, в каждой ячейке пишем общую сумму продаж этого сорта мороженного в этой точке и за этот день. В каждой из ячеек может быть несколько различных значений измерений. В этом случае ячейка делится на несколько частей. Например, для примера с мороженным, ячейка также может содержать, кроме суммы продаж, количество проданных единиц данного сорта мороженного. В более сложных случаях, количество показателей может быть большим чем три, как в примере.

Для хранения описанной информации используется специализированное многомерное хранилище. Платформа "Мельница Данных" аккумулирует такие многомерные хранилища с помощью реляционных структур.

Второе требование для OLAP задачи - визуализация данных. Табличный вид описанного выше "куба" это сводная таблица, позволяющая группировать измерения, а также показывать факты, то есть значения показателей в ячейках. Для таблицы доступны различные варианты просмотра данных в различных разрезах.

Следующее требование - публикация данных. Здесь нужно отметить, что публикация одного единственного среза данных не несет большого смысла. С точки зрения конечного пользователя, оптимальным вариантом публикации будет являться такой вид на данные, при котором пользователь может "вживую" менять измерения, перетаскивать их и т.д. Такая публикация может быть полезна при принятии управленческих решений руководством предприятия, а также будет удобна для анализа конечными пользователями. Кроме того, для публикации активно используются всевозможные графики, диаграммы, построенные по актуальным данным.

Достаточно востребованным для конечных пользователей является также свойство Системы, называемое Drill Down (проваливание). Данное свойство подразумевает, что пользователь выбрав каким-либо образом значение показателя, имеет возможность посмотреть, каким образом этот показатель был посчитан, на основании чего, и собственно, на основании каких конкретно данных был сформирован этот показатель. Для этого OLАP-системе необходим доступ к первичным данным. Такое требование не является существенной проблемой, так как у хранилище одно и то же и для OLTP-задачи и для OLАP-задачи.

5.12. RESTful-service стандартного обработчика

Функции стандартного обработчика сервера приложений доступны при обращении по следующим url:
Схема://хост/Имя обработчика/Функция сервиса.расширение
Запрос к функциям сервиса может содержать один параметр с именем query, который может быть передан методом GET или методом POST.

Ниже рассмотрены конкретные функции, которые можно вызывать.

5.12.1. Функция accesslist

Функция accesslist позволяет получить список всех ролей безопасности, в которые включен текущий пользователь. В список войдут идентификаторы всех ролей и идентификатор пользователя. В случае, если вызов выполняется пользователем, являющимся администратором БД, то возвращаемый список будет пустым. Это означает, что для пользователя нет ограничений в доступе к данным и функциональности системы.

Допустимое расширение .xml.

Функция не имеет параметров.

Функция возвращает ответ в виде XML-документа с элементом data, имеющим набор подчиненных узлов row, соответствующих каждому объекту полученного списка. Каждый узел row содержит в качестве значения идентификатор (ID) роли или пользователя.

Пример запроса:
https://techmill.ru/demo/accesslist.xml
Пример ответа:
01<data eof="1">
02  <row>
03    <ID type="int64">460</ID>
04  </row>
05  <row>
06    <ID type="int64">70540</ID>
07  </row>
08  <row>
09    <ID type="int64">891142</ID>
10  </row>
11  <row>
12    <ID type="int64">2533983</ID>
13  </row>
14  <row>
15    <ID type="int64">741846296</ID>
16  </row>
17</data>
5.12.2. Функция batch

Функция batch дает возможность однократным ее вызовом отправить на выполнение несколько запросов на получение данных или на вызов методов и получить набор запрошенных данных и результаты выполнения методов.

Допустимые расширения:

.xml - для получения ответа в формате xml

.js/.json - для получения ответа в формате JSON

Функция осуществляет серию запросов и/или вызовов методов и возвращает данные, соответствующие структуре и условиям переданных запросов и вызовов. Запросы и вызовы передаются в виде параметра GET или POST-запроса с именем query. Значение параметра представляет собой xml-документ следующей структуры:
01<root>
02  <query  class="TRemoteUser">
03    <item part="0" name="FullName"/>
04    <item part="1" name="ID" value="1320218"/>
05  </query>
06  <query  class="TPerson">
07    <item part="0" name="LastName"/>
08    <item part="0" name="FirstName"/>
09    <item part="1" name="ID" value="5652545"/>
10  </query>
11  <execute class="TSchoolAbiturSt" method="RegCount">
12    <row>
13      <AdmissionYear>7427462</AdmissionYear>
14      <AdmStage>8608398</AdmStage>
15      <PrevAdmissionYear>6843737</PrevAdmissionYear>
16      <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
17    </row>
18  </execute>
19</root>
Элемент root может включать в себя набор элементов двух типов:

query - эти элементы позволяют выполнять запросы к данным; принципы формирования этих элементов совпадают с принципами, описанными для функции cursor: Функция cursor

execute - эти элементы позволяют выполнять вызовы методов; принципы формирования этих элементов совпадают с принципами, описанными для функции execute: Функция execute

При использовании функции batch при выполнении запросов к данным, соответствующим элементам query, всегда используется значение атрибута fetchall="1", даже если этот атрибут не передан, или для него передано значение "0". Подробнее об использовании атрибута fetchall="1": Использование возвращаемого ответа.

Желательно не включать в вызовы функции batch запросы, которые потенциально могут вернуть очень большой набор данных. Для таких запросов лучше использовать функцию cursor (Функция cursor).

5.12.3. Функция bulkinsert

Функция bulkinsert позволяет выполнить пакетное добавление данных в поля таблицы. Для использования данной функции подключение должно осуществлять под пользователем, имеющим права доступа на запись к полям таблиц.

Допустимые расширения: .xml, .js / .json.

Функция имеет параметр query, который должен представлять собой XML документ, содержащий информацию о таблице (имя таблицы совпадает с именем класса), в которую должно быть выполнено добавление записей, именах полей и их значениях. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML документ - значение параметра query должен иметь элемент data (можно использовать другое имя элемента, оно не анализируется) с атрибутом handle, в значении которого должно быть передано имя таблицы (имя класса). Корневой элемент должен иметь набор дочерних узлов row, каждый из которых должен иметь дочерние узлы, соответствующие каждой паре имя поля (имя узла) - значение (значение узла).

При успешном выполнении функции будет возвращен ответ в формате XML-документа или в формате JSON с элементом data, который будет включать в себя набор узлов с одним значением id. Значения id будут представлять собой идентификаторы созданных объектов.
01https://techmill.ru/demo/bulkinsert.xml?query=
02  <data handle="TTemporaryList">
03    <row>
04      <FName>Name1</FName>
05      <FDescription>Desc1</FDescription>
06      <FItemInfo>ItemInfo1</FItemInfo>
07    </row>
08    <row>
09      <FName>Name2</FName>
10      <FDescription>Desc2</FDescription>
11      <FItemInfo>ItemInfo2</FItemInfo>
12    </row>
13    <row>
14      <FName>Name3</FName>
15      <FDescription>Desc3</FDescription>
16      <FItemInfo>ItemInfo3</FItemInfo>
17    </row>
18    <row>
19      <FName>Name4</FName>
20      <FDescription>Desc4</FDescription>
21      <FItemInfo>ItemInfo4</FItemInfo>
22    </row>
23  </data>
5.12.4. Функция closecursor

Функция closecursor позволяет закрыть ранее открытый курсор, который был открыт при предшествующем вызове функции cursor (Функция cursor).

Допустимое расширение: .xml.

Значением параметра функции query должно быть значение handle, которое было возвращено при вызове функции cursor.

Ответом будет xml-документ с одним пустым элементом data.

Запрос:
https://techmill.ru/demo/closecursor.xml?query="{9197829A-AFA3-49D1-BD03-D860ECCB901F}"
Ответ:
<data/>
Открытые курсоры закрываются автоматически при завершении сессии. В рамках одной сессии желательно явно вызывать функцию closecursor при работе с большими объемами данных, когда данные были получены не полностью (при вызове функции cursor было получено eof="0") и результаты запроса более не нужны.

5.12.5. Функция commonproperties

Функция commonproperties позволяет получить значения общих свойств списка объектов, включенных в ранее созданный буфер.

Принципы формирования списка общих свойств объектов и возврата их значений совпадают с принципами работы Инспектора объектов: Отображение свойств Инспектором объектов.

Возможности создания буфера и добавление в него объектов описаны в статьях Функция selectedbuffer, Функция selectionchanged.

Допустимое расширение .xml.

В значении параметра функции с именем query необходимо передать xml-документ, содержащий идентификатор буфера и указания о принципе отбора свойств. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML документ должен иметь элемент query со следующими атрибутами:

handle (обязательный) - идентификатор буфера

propid - идентификатор свойства; если данный атрибут не передан или для него передано пустое значение, то будет возвращен полный набор полученных свойств, если будет передан идентификатор одного свойства, то будет возвращено значение только этого одного свойства.

publiconly - значение "0" (по умолчанию) будет означать, что в ответ будут включены все общие свойства набора объектов, значение "1" будет означать что в ответ будут включены только свойства с областью видимости "Видимо пользователям" (Scope = scPublic).

Пример запроса:
https://techmill.ru/demo/commonproperties.xml?query=<query handle="221024" publiconly="1"/>
Запрос на общие свойства списка объектов, предварительно добавленных в буфер с идентификатором "221024". В ответ будет включены только свойство с областью видимости "Видимо пользователям".

В качестве ответа будет возвращен XML-документ с элементом data, который будет включать в себя набор узлов row, соответствующих каждому свойству из полученного набора свойств. Каждый узел row будет иметь подчиненные узлы:

ID - идентификатор свойства

Value - значение свойства

Value-N - для свойств с доменом ссылочного типа (объектов) будет возвращено Имя объекта; для свойств других доменов значение будет пустым

Value-D - для свойств с доменом ссылочного типа (объектов) будет возвращено Наименование объекта; для свойств других доменов значение будет пустым

Recieved - для свойств типа "Отложенное" (Suspended) будет возвращено значение "0", для прочих свойств будет возвращено значение "1"; в случае получения значение "0" значение такого свойства можно будет получить другим отдельным запросом именно на это свойство, например, при помощи функции cursor (Функция cursor).

Пример ответа:
01<data eof="1">
02  <row>
03    <ID type="int64">69174</ID>
04    <Value>76208</Value>
05    <Value-N>город Москва</Value-N>
06    <Value-D>Москва</Value-D>
07    <Recieved type="int">1</Recieved>
08  </row>
09  <row>
10    <ID type="int64">69175</ID>
11    <Value>67991</Value>
12    <Value-N>РФ</Value-N>
13    <Value-D>Российская Федерация</Value-D>
14    <Recieved type="int">1</Recieved>
15  </row>
16  <row>
17    <ID type="int64">69176</ID>
18    <Value/>
19    <Value-N/>
20    <Value-D/>
21    <Recieved type="int">0</Recieved>
22  </row>
23  <row>
24    <ID type="int64">4503868</ID>
25    <Value>77</Value>
26    <Value-N/>
27    <Value-D/>
28    <Recieved type="int">1</Recieved>
29  </row>
30</data>
5.12.6. Функция cursor

Функция cursor позволяет отправлять запросы на получение данных, доступных через обработчик сервера приложений, получать ответ с запрошенными данными в форматах xml или JSON.

Допустимые расширения:

.xml - для получения ответа в формате XML

.js/.json - для получения ответа в формате JSON

Функция осуществляет запрос к указанному классу или представлению и возвращает данные, соответствующие структуре и условиям переданного запроса. Запрос к данным передается в виде параметра GET или POST-запроса с именем query. Значение параметра представляет собой xml-документ следующей структуры:
01<query class="TWorker">
02  <item part="what" name="LastName" />
03  <item part="what" name="FirstName"/>
04  <item part="what" name="MiddleName"/>
05  <item part="what" name="BirthDate"/>
06  <item part="what" name="ContactList" value="TPerson.GetContactList" special="function">
07    <parameters>
08      <ContactType>63474</ContactType>
09    </parameters>
10  </item>
11  <item part="where" name="LastName" value="А*"/>
12  <item part="order" name="LastName"/>
13  <item part="order" name="FirstName"/>
14</query>
Элемент query имеет обязательный атрибут class. Значением атрибута class должно быть имя класса или представления, к которому будет выполняться запрос. Также может использоваться необязательный атрибут fetchall, который может принимать значения "0" (значение по умолчанию) или "1". Использование атрибута fetchall подробнее описано ниже в разделе Использование возвращаемого ответа.

Элемент query может включать в себя элементы item, передающие структуру запроса, условия отбора, сортировки, группировки. Элементы item могут включать в себя необязательные элементы (context, parameters, и т.п.; имя этого элемента не анализируется).

Состав атрибутов элемента item (обязательным является только атрибут part, остальные атрибуты можно опускать, в зависимости от использования других атрибутов):

part (обязательный атрибут) - часть запроса (what, where, order,...)

name - в простом случае (без использования special) - имя свойства класса (или поля представления), которое будет использовано в запросе; при использовании special может быть как именем свойства класса, так и другой строкой (см. подробнее ниже).

value - значение, которое в зависимости от значения атрибутов part и special, будет использовано для сравнений или для других целей; в простом случае (если part = "where", special отсутствует) будет использовано для сравнения в условии отбора при выполнении запроса.

special - вводит дополнительные возможности формирования запроса (возможности описаны ниже); от использованного значения данного атрибута может зависеть трактовка значений других атрибутов.

subQuery

joinKey

joinLink

joinSource

Допустимые значения атрибута part (можно использовать как строковые, так и числовые значения):

Строковое
значение

Числовое
значение

Назначение и пример использования

what

0

Элементы со значением "what" (0) атрибута part используются для формирования what-кляузы запроса. В полученном ответе каждому такому элементу будет соответствовать один xml или json элемент с именем, переданным атрибутом name.
<item part="what" name="LastName"/>
Получить значение свойства "LastName".

where

1

Элементы со значением "where" (1) атрибута part используются для формирования условия отбора объектов (where-кляузы запроса).
Для условий допустимо использовать "маску" (*, ?), условия ">", "<", ">=", "<=";
использование значений через ";" будет трактовано как условие "или", использование "&" будет трактовано как условие "и";
для отрицания нужно использовать "!", для условия "not null" нужно использовать "*", для условия "is null" нужно использовать "!*".
Каждый следующий where-элемент добавляет к запросу одно условие "и".
1<item part="where" name="LastName" value="Петров"/>
2<item part="where" name="FirstName" value="А*"/>
Отобрать объекты класса со значением свойства "LastName", равным "Петров", и значениями "FirstName", начинающимися с символа "А".

order

2

Элементы со значением "order" (2) атрибута part используются для управления сортировкой данных в возвращаемом ответе. По умолчанию (без использования атрибута special) будет выполнена сортировка "по возрастанию". Задать сортировку "по убыванию" можно, использовав значение "desc" (7) для атрибута special. Если в запросе использовано несколько элементов "order", то возвращаемый результат будет отсортирован по нескольким полям в том порядке, в котором они указаны в запросе.
1<item part="order" name="LastName/>
2<item part="order" name="BirthDate" special="desc"/>
Отсортировать результат запроса по значению свойства "LastName" по возрастанию, затем по значению свойства "BirthDate" по убыванию.

group

3

Элементы со значением "group" (3) атрибута part используются для управления группировкой данных в возвращаемом ответе. Если в запросе использовано несколько элементов "group", то возвращаемый результат будет сгруппирован по нескольким полям в том порядке, в котором они указаны в запросе. Для свойств, не входящих в условия группировки, можно получать значения агрегатов (количество, наименьшее/наибольшее/среднее и т.п.), используя атрибут special.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="what" name="BirthDate" special="min"/>
4<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region", количество записей в группе и минимальное значение свойства "BirthDate" в этой группе.

having

4

Элементы со значением "having" (4) атрибута part позволяют накладывать условия отбора на группы в запросе с группировкой.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="what" name="BirthDate" special="min"/>
4<item part="group" name="Region"/>
5<item part="having" name="ID" value=">3" special="count"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region", количество записей в группе и минимальное значение свойства "BirthDate" в этой группе, отобрав при этом только такие группы, количество объектов в которых больше 3-х.

innerJoin

5

outerJoin

6

Допустимые значения атрибута special (можно использовать как строковые, так и числовые значения):

Строковое
значение

Числовое
значение

Части запроса

Назначение и пример использования

ID

1

what
where

Позволяет запрашивать идентификатор объекта или накладывать условия по идентификатору.
1<query class="TWorker">
2  <item part="what" special="ID"/>
3  <item part="what" name="LastName"/>
4  <item part="what" name="FirstName"/>
5  <item part="where" value="5500921" special="ID"/>
6</query>
Получить идентификатор объекта, значения свойств LastName, FirstName объекта с идентификатором, равным 5500921. Ответ на запрос будет содержать элемент с именем ID.

parent

2

what
where

Позволяет использовать в запросах идентификатор "родителя" объекта.
1<query class="TCountry">
2  <item part="what" special="ID"/>
3  <item part="what" special="parent"/>
4  <item part="what" name="Name"/>
5  <item part="what" name="Description"/>
6</query>
Получить идентификатор объекта, идентификатор родительского объекта, значения свойств Name, Description всех объектов класса TCountry. Ответ на запрос будет содержать элемент с именем Parent.

haschildren

3

what
where

Признак наличия дочерних объектов в иерархии. Ответ на запрос будет содержать элемент с именем HasChildren и значением "1" в случае наличия дочерних объектов и значением "0" в случае их отсутствия.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" special="haschildren"/>
5</query>
Получить значения свойств Name, Description, а также признак наличия дочерних объектов всех объектов класса TCountry.

filter

4

where

Позволяет использовать для отбора условия, заданные доменами, использованными в решении на платформе. Имя или идентификатор домена указывается в атрибуте name. Условие отбора этого домена будет интерпретировано с учетом значений, переданных в дочернем элементе context. Для каждого из этих значений должны быть указаны его имя, домен и значение.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name = "TRegion of UnivCountry domain" special="filter>
5      <context>
6        <UnivCountry domain="4565848">67991</UnivCountry>
7      </context>
8  </item>
9</query>
Получить значения свойств Name, Description объектов класса TCountry, подходящих под условие отбора домена "TRegion of UnivCountry domain", используя значение "67991" вместо идентификатора UnivCountry.
Условие отбора домена "TRegion of UnivCountry domain":
((Self.Parent = UnivCountry) or (Self = UnivCountry))

uplink

5

what
where

Используется для отбора данных в контексте выбранных родительских объектов. Связь отбираемых объектов с выборкой связанных родительских объектов будет установлена по свойству, переданному атрибутом name. В атрибуте value может быть передан идентификатор одного объекта, список идентификаторов объектов через ";" или идентификатор буфера, в который предварительного сохранен список объектов.
1<query class="TCountry">
2  <item part="where" name="Parent" value="14750" special="uplink"/>
3  <item part="what" name="Name"/>
4  <item part="what" name="Description"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, у которых значение свойства Parent равно "14750" (или входит в состав объектов, сохраненных в буфере с идентификатором "14750").

root

6

where

Будут отобраны только объекты, не имеющие родителя, после наложения других условий отбора.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" special="root"/>
5</query>
Получить значения свойств Name, Description "корневых" (не имеющих родителя) объектов класса TCountry.

desc

7

order

Используется для сортировки "по убыванию" для элементов с атрибутом part ="order". Без указания атрибута special будет выполнена сортировка "по возрастанию".
1<item part="order" name="LastName"/>
2<item part="order" name="BirthDate" special="desc"/>
Отсортировать результат запроса по значению свойства "LastName" по возрастанию, затем по значению свойства "BirthDate" по убыванию.

count

8

what
having

Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения количества объектов в группе.
1<item part="what" name="Region"/>
2<item part="what" name="ID" special="count"/>
3<item part="group" name="Region"/>
4<item part="having" name="ID" value=">3" special="count"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и количество записей в группе, отобрав при этом только такие группы, количество объектов в которых больше 3-х.

sum

9

what
having

Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения суммы значений свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="PayedSum" special="sum"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и сумму значений свойства "PayedSum" для всех объектов группы.

min

10

what
having

Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения минимального значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="BirthDate" special="min"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и минимальное значение свойства "BirthDate" среди всех объектов группы.

max

11

what
having

Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения максимального значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"/>
2<item part="what" name="BirthDate" special="max"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и максимальное значение свойства "BirthDate" среди всех объектов группы.

avg

12

what
having

Используется для запросов с группировкой, в элементах, у которых part = "what" или "having" для получения среднего значения свойства, имя которого передано атрибутом name.
1<item part="what" name="Region"
2<item part="what" name="PayedSum" special="avg"/>
3<item part="group" name="Region"/>
Сгруппировать результат запроса по значению свойства "Region", для каждой группы вернуть значение свойства "Region" и среднее значение свойства "PayedSum" среди всех объектов группы.

masterLink

13

where

Позволят наложить отбор на объекты класса ("подчиненный" класс) в контексте выбранных объектов класса-мастера или класса, связанного с исходным по другому свойству ("главный" класс). В атрибуте name в этом случае передаются имена свойства "главного" класса и свойства "подчиненного" класса, по которым эти классы связаны. Имена свойств указываются следующим образом:

Если одним из этих свойств является идентификатор (ID), то имя этого свойства не указывается (это свойство используется по умолчанию)

Если оба свойства отличаются от ID, то их имена указываются через разделитель ";", например, "Master;Person"

Если только свойство "подчиненного" класса отличается от ID, то указывается только имя этого свойства, например, "Person"

Если только свойство "главного" отличается от ID, то вместо свойства-подчиненного указывается *, например, "Master;*"

В свойстве value передается идентификатор буфера, содержащего список выбранных объектов "главного" класса.
1<query class="TContact">
2  <item part="what" name="ContactInfo"/>
3  <item part="what" name="ContactType" special="name"/>
4  <item part="where" name="Person" value="246889" special="masterLink"/>
5</query>
Получить значения свойств ContactInfo, ContactType (Имя) объектов класса TContact, для объектов, список которых сохранен в буфере с идентификатором "246889", связанным с классом TContact по свойству Person.

selectedOnly

14

where

Позволят наложить отбор по списку идентификаторов объектов класса, ранее сохраненных в буфере.
1<query class="TPerson">
2  <item part="what" name="LastName"/>
3  <item part="what" name="FirstName"/>
4  <item part="where" value="246889" special="selectedOnly"/>
5</query>
Получить значения свойств LastName, FirstName объектов класса TPerson, список которых сохранен в буфере с идентификатором "246889".

distinct

15

what

Позволяет получить все уникальные значения определенного свойства или сочетания значений свойств класса.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" special="distinct"/>
4</query>
Получить набор уникальных значений свойства FirstName класса TPerson.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="MiddleName"/>
4  <item part="what" special="distinct"/>
5</query>
Получить набор уникальных сочетаний значений свойств FirstName и MiddleName класса TPerson.

view

16

where

Позволяет при выполнении запроса наложить отбор, используемый для определенного представления. Имя (или идентификатор) представления указывается в атрибуте name.
1<query class="TPerson">
2  <item part="where" name="Persons older 25" special="view"/>
3  <item part="what" name="FirstName"/>
4  <item part="what" name="LastName"/>
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, соответствующих условиям отбора представления Persons older 25.

caseInsensitive

17

where

Позволяет наложить отбор на значение свойства строкового типа без учета регистра. Без использования special поиск ведется с учетом регистра.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="LastName"/>
4  <item part="where" name="FirstName" value="АНДРЕЙ" special="caseInsensitive"/>
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, с отбором по значению свойства FirstName без учета регистра символов. TPerson.

string

18

where

Позволят явно приводить к строковому типу значения свойства, переданного атрибутом name.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="Code" value="00002" special="string"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, со значением свойства Code, равным "00002".

listed

19

where

Позволяет выполнять отбор по списку объектов, входящих в список, сохраненный в системе как объект класса TObjectList ("Списки"), идентификатор которого нужно передать в качестве значения атрибута value.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="ID" value="5245654" special="listed"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry, входящих в список, сохраненный как объект класса TObjectList с идентификатором "5245654".

name

20

what
where

Для свойств-ссылок на объекты позволяет получить Имя объекта, переданного атрибутом name. В полученном ответе соответствующий элемент будет иметь имя ИмяСвойства-N.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Parent"/>
5  <item part="what" name="Parent" special="name"/>
6</query>
Для всех объектов класса TCountry получить значения свойств Name, Description, Parent, а также Имя объекта Parent.

description

21

what
where

Для свойств-ссылок на объекты позволяет получить Наименование объекта, переданного атрибутом name. В полученном ответе соответствующий элемент будет иметь имя ИмяСвойства-D.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Parent"/>
5  <item part="what" name="Parent" special="description"/>
6</query>
Для всех объектов класса TCountry получить значения свойств Name, Description, Parent, а также Наименование объекта Parent.

function

22

what
where

Позволяет использовать значения, полученные в результате вызова функций, как в элементах с атрибутом part ="what", так и в элементах с атрибутом part ="where". Имя функции должно быть передано в атрибуте value в формате Имя класса.Имя функции. Если функция имеет параметры, то для их передачи необходимо добавить дочерний элемент context, со своими дочерними элементами для каждого из параметров в формате <ИмяПараметра>Значение параметра</ИмяПараметра>. Если функция является "методом объекта", параметр "ID" добавлять не нужно, он будет использован автоматически. В элементах с атрибутом part ="what" значение атрибута name может быть любым, оно не будет использовано при выполнении запроса, но станет именем элемента данных в получаемом ответе.
01<item part="what" name="InitAndLast" value="TPerson.GetInitAndLast" special="22"/>
02<item part="what" name="ContactList" value="TPerson.GetContactList" special="22">
03  <context>
04    <ContactType>63474</ContactType>
05  </context>
06</item>
07<item part="where" name="TWorker.IsSuperior" value="1" special = "function">
08  <context>
09    <OtherWorker>625186</OtherWorker>
10    <Department></Department>
11  </context>
12</item>
Получить результат выполнения функции GetInitAndLast класса TPerson (функция не имеет параметров), получить результат выполнения функции GetContactList класса TPerson с параметром ContactType = 625186. Отобрать только те объекты, для которых результат выполнения функции IsSuperior класса TWorker равен "1". Функция IsSuperior вызывается со значением 625186 параметра OtherWorker и пустым значением параметра Department.

countdistinct

23

what
having

Позволяет получить количество уникальных значений свойства.
1<query class="TPerson">
2  <item part="what" name="FirstName" special="countdistinct"/>
3</query>
Получить количество уникальных значений свойства FirstName класса TPerson.

boolean

24

what
where

Позволят приводить к "логическому" типу значения свойства, переданного атрибутом name. Приведение выполняется по следующему принципу:

значение Null преобразуется в пустое значение в ответе

значение "0" остается значением "0" в ответе

любое непустое значение преобразуется в значение "1" в ответе

Такая возможность позволяет, например, более эффективно (без получения самих значений) определять пустоту/непустоту значений типа "большой объект".
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="what" name="Code" special="boolean"/>
5</query>
Получить значения свойств Name, Description, а также значение свойства Code, преобразованное к "логическому" всех объектов класса TCountry.

exact

25

where

При использовании значения "exact" (25) атрибута special значение, переданное в атрибуте value, будет использовано "как есть" - без преобразования типов, без трактовки символов "*", "?" как маски и т.п.
1<query class="TCountry">
2  <item part="what" name="Name"/>
3  <item part="what" name="Description"/>
4  <item part="where" name="Code" value = "002*25?" special="exact"/>
5</query>
Получить значения свойств Name, Description объектов класса TCountry со значением свойства Code, равным "002*25?".

searchindex

26

where

Позволяет использовать индексы полнотекстового поиска при отборах. Поиск по выполняться по всем полям класса, значение атрибута name будет проигнорировано.
1<query class="TMailMessage">
2  <item part="what" name="Theme"/>
3  <item part="what" name="Body"/>
4  <item part="what" name="Created"/>
5  <item part="where" value="приглашаем *на семинар *Современные" special="searchindex">
6</query>
Получить значения свойств Theme, Body, Created объектов класса TMailMessage, среди значений свойств которых будет найдена указанная строка, с использованием индекса полнотекстового поиска.

optimization

27

where

Позволяет использовать имеющиеся подсказки оптимизатору при выполнении запроса.
1<query class="TPerson">
2  <item part="what" name="FirstName"/>
3  <item part="what" name="LastName"/>
4  <item part="what" value="ORARefreshOnFetch=true;APPRefreshOnFetch=true" special="optimization">
5</query>
Получить значения свойств FirstName, LastName объектов класса TPerson, используя при выполнении запроса подсказки оптимизатору.

5.12.6.1. Использование возвращаемого ответа

При корректном выполнении запроса ответ будет представлять собой набор данных следующей структуры:

При использовании формата xml будет возвращен xml-документ с корневым элементом data, который будет иметь атрибуты handle (GUID) и eof ("1" или "0"). Элемент data будет иметь подчиненные элементы row, каждый из которых будет соответствовать одной записи, полученной при выполнении запроса. Каждый элемент row будет иметь подчиненные элементы, соответствующие what-элементам запроса.

При использовании формата JSON будет возвращен JSON-объект, содержащий пары ключ-значение handle (значение типа GUID), eof (значения "0" или "1") и data. Значением data будет массив пар ключ-значение, каждая из которых будет соответствовать одной записи, полученной при выполнении запроса.

Обработчик сервера приложений, обеспечивающий работу функций RESTfull-сервисов, в том числе функции cursor, имеет параметры, ограничивающие размер пакета возвращаемых данных, выраженные в количестве объектов в ответе и в объеме ответа в байтах. В случае, если размер ответа укладывается в оба этих ограничения, все полученные данные будут возвращены полностью, и в ответе будет передан атрибут (значение) eof="1". В случае, если размер ответа превысит одно из ограничений, и при этом в запросе атрибут fetchall не задан или равен "0", то в ответ войдет только такой набор записей, который позволит соблюсти ограничения, и при этом в ответе будет передан атрибут (значение) eof="0". Если в запросе был передан атрибут fetchall="1", то будет выполнена попытка вернуть весь ответ полностью, несмотря на установленные ограничения. При успешной передаче атрибут (значение) eof будет равен "1".

Пример запроса:
1  <query class="TWorker" fetchall="1">
2    <item part="0" name="LastName"/>
3    <item part="0" name="FirstName"/>
4    <item part="0" name="BirthDate"/>
5    <item part="0" name="AcademicStatus"/>
6    <item part="1" name="BirthDate" value=">12.05.2000"/>
7  </query>
Пример ответа в формате xml:
01  <data handle="{FDF9EE70-9948-4A99-8233-349C3ADD3CE8}" eof="1">
02    <row>
03      <LastName>Абишин</LastName>
04      <FirstName>Вячеслав</FirstName>
05      <BirthDate type="date">10.06.2014</BirthDate>
06      <AcademicStatus>к.э.н.</AcademicStatus>
07    </row>
08    <row>
09      <LastName>Агринская</LastName>
10      <FirstName>Ольга</FirstName>
11      <BirthDate type="date">24.08.2016</BirthDate>
12      <AcademicStatus>PhD</AcademicStatus>
13    </row>
14    <row>
15      <LastName>Абрамов</LastName>
16      <FirstName>Александр</FirstName>
17      <BirthDate type="date">05.09.2016</BirthDate>
18     <AcademicStatus/>
19    </row>
20  </data>
Пример ответа в формате JSON:
01  {
02      "handle": "{C57F629E-583C-4477-ACBF-E436F6D01628}",
03      "eof": true,
04      "data": [
05          {
06              "LastName": "Абишин",
07              "FirstName": "Вячеслав",
08              "BirthDate": {
09                  "year": 2014,
10                  "month": 5,
11                  "day": 10
12              },
13              "AcademicStatus": "к.э.н."
14          },
15          {
16              "LastName": "Агринская",
17              "FirstName": "Ольга",
18              "BirthDate": {
19                  "year": 2016,
20                  "month": 7,
21                  "day": 24
22              },
23              "AcademicStatus": "PhD"
24          },
25          {
26              "LastName": "Абрамов",
27              "FirstName": "Александр",
28              "BirthDate": {
29                  "year": 2016,
30                  "month": 8,
31                  "day": 5
32              },
33              "AcademicStatus": null
34          }
35      ]
36  }
Значение eof = "1" означает, что данные получены полностью. Если в ответе такого значения (атрибута) нет, или eof = "0", это означает, что получены не все данные. Дополучить эти данные можно, повторно выполнив вызов функции cursor, передав в качестве значения параметра query полученное при первом вызове значение handle.
https://techmill.ru/demo/cursor.xml?query={FDF9EE70-9948-4A99-8233-349C3ADD3CE8}
В ответе на запрос с использованием handle вернется то же самое значение handle. Таким образом, запрос можно повторять с одним и тем же значением handle до тех пор, пока в ответе не будет получено eof = "1", что позволит убедиться в том, что данные получены полностью.

5.12.7. Функция excelreport

Функция excelreport позволяет вызывать на выполнение отчеты класса TExcelTemplate и получать файлы, формируемые как результат выполнения отчетов. Файлы могут быть возвращены как в форматах Excel (.xls,.xlsx), так и с преобразованием в другие форматы. Исключением являются интерактивные отчеты (требующие при формировании диалога с пользователем). Такие отчеты не могут вызваться при помощи данной функции.

Допустимые расширения:

.xls - для получения файла отчета в формате XLS

.xlsx - для получения файла отчета в формате XSLX

.html - для получения файла отчета в формате HTML; поддерживается формирование html-документа в монохромном цветовом режиме, в режиме "в градациях серого"

.pdf - для получения файла отчета в формате PDF; поддерживаются способы преобразования.xls/.xslx-файла в pdf-документ как средствами платформы, так и средствами самого Excel; возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"

.xps - для получения файла отчета в формате XPS

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, отчет которого будет вызываться

"template" (обязательный) - имя отчета, который будет вызываться

"format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:

цветовой режим - допустимые значения "mono", "grey"; значение по умолчанию - "обычный" цветовой режим

внедрение шрифтов (для формата PDF) - допустимые значения "embed", "embedded"; значение по умолчанию - без внедрения шрифтов

способ преобразования (для случая преобразования в формат PDF) - допустимое значение "native"; значение по умолчанию - средствами платформы "Мельница данных" в случае, если такой способ реализован; иначе - средствами приложения MS Office.

тип файла результата - допустимые значения совпадают с возможными расширениями вызова функции (без дополнительной точки)

"filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="StatisticReport.embed.pdf", что будет говорить о том, что будет возвращен pdf-документ с внедренными шрифтами.
Значение по умолчанию: "excelreport" с расширением, совпадающим с расширением вызываемой функции.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного атрибутами параметра query или расширением функции excelreport (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове Excel-отчета:
1  <execute class="TSchoolAbiturSt" template="RegStatistics" format="mono.embed.native.pdf" filename="StatisticReport.pdf">
2    <row>
3      <AdmissionYear>7427462</AdmissionYear>
4      <AdmStage>8608398</AdmStage>
5      <PrevAdmissionYear>6843737</PrevAdmissionYear>
6      <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
7    </row>
8  </execute>
При таком вызове будет выполнен Excel-отчет "RegStatistics" класса "TSchoolAbiturSt" с параметрами, переданными в элементе row. Данный отчет является "методом класса", поэтому параметр "ID" в состав параметров не добавлен. Полученный файл отчета будет преобразован в формат PDF с внедрением шрифтов в монохромном режиме. Преобразование будет выполнено средствами приложения MS Excel. В качестве ответа будет возвращен .pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("StatisticReport.pdf"), в содержимом ответа будет передано содержимое файла.

5.12.7.1. Принципы разбора информации о формате результирующего файла

Информация о формате файла, который будет сформирован и возвращен в качестве ответа, может быть извлечена из атрибутов xml-документа запроса, или из расширения функции. Порядок разбора переданной информации следующий:

Значение атрибута format. Если данный атрибут указан, но в нем нет одной из составляющих формата, то для этой составляющей будет использовано значение по умолчанию (значение из атрибута filename использовано не будет).

Значение атрибута filename. В этом атрибуте, кроме имени файла как такового и его расширения, может передаваться информация о цветовом режиме (.mono/.grey,...), внедрении шрифтов (.embed/.embedded), способе преобразования файла (.native). Значения для этих составляющих будут получены из атрибута filename только в случае, если атрибут format не указан при вызове.

Расширение будет получено из расширения вызываемой функции. Для других составляющих формата будут использованы значения по умолчанию.

Строка, определяющая формат, разбирается как последовательность элементов, разделенных символом "." (точка). Элементы разбираются последовательно, независимо друг от друга, и имеют следующие значения:

mono

Формируется монохромный документ

grey

Формируется документ в градациях серого

embedded

Шрифты внедряются в выходной документ

native

Используется встроенный в MSOffice механизм формирования документов

PDF

Выгружается файл в формате PDF

HTML

Выгружается файл в формате HTML

BMP

Выгружается файл в формате BMP

RTF

Выгружается файл в формате RTF

DOC

Выгружается файл в формате DOC

XLS

Выгружается файл в формате XLS

DOCX

Выгружается файл в формате DOCX

XLSX

Выгружается файл в формате XLSX

XPS

Выгружается файл в формате XPS

Остальные элементы игнорируются. Порядок следования элементов не важен.

Строка формата "pdf.mono.embedded" указывает сформировать монохромный документ в формате PDF со встроенными шрифтами.

5.12.8. Функция execute

Функция execute позволяет вызывать методы, доступные для вызова через обработчик сервера приложений, получать результат выполнения методов.

Допустимо использовать любые расширения, в том числе не указывать расширение. Расширение повлияет на формат возвращаемого результата следующим образом:

.xml - для получения результата выполнения в формате xml

.js/.json - для получения результата выполнения в формате JSON

пустое расширение - результат выполнения будет возвращен в формате xml

другие расширения - имеет смысл использовать в случаях, когда результатом выполнения метода является "большой объект" (blob, clob) и его тип известен; это позволит получить результат в виде файла или структуры данных определенного типа (.xslt,.pdf, форматы изображений и т.п.)
если результат выполнения не удастся привести к формату, заданному расширением, результат будет возвращен в формате xml

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый метод и значения его параметров. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, метод которого будет вызываться

"method" (обязательный) - имя метода, который будет вызываться

Корневой элемент xml-документа может содержать список узлов row, каждый из которых определяет набор параметров для вызова метода. Таким образом, при помощи одного вызова функции (одним обращением к url) можно вызывать один и тот же метод для набора объектов.

Принципы передачи параметров для вызова метода, включая использование параметров типа "большой объект", описаны в статье Принципы передачи параметров функциям RESTful-service.

Для вызова методов экземпляра необходимо указывать значение неявного параметра с именем "ID". Значением этого параметра должен быть идентификатор объекта, для которого вызывается метод.
01  <execute class="TPerson" method="GetContactList">
02    <row>
03      <ID>931669</ID>
04      <ContactType>63478</ContactType>
05    </row>
06    <row>
07      <ID>76443</ID>
08      <ContactType>63478</ContactType>
09    </row>
10  </execute>
Получить результат вызовов метода GetContactList класса TPerson для объектов с идентификаторами (ID), равными 931669 и 76443 и со значением параметра ContactType, равным 63478.

Пример ответа:
1  <data eof="1">
2    <row>
3      <Result>8-903-73-210-73</Result>
4    </row>
5    <row>
6      <Result>8-916-862-27-77; 8-916-862-2777</Result>
7    </row>
8  </data>
Если возвращаемый результат имеет домен класса "большой объект" (clob, clob, "внешний файл"), то возвращаемое значение может быто подвергнуто пост-обработке. Подробнее этот случай описан в разделе: Особенности передачи возвращаемых значений типа "большой объект"

5.12.8.1. Принципы передачи параметров функциям RESTful-service

При вызове функций RESTful-service стандартного обмена применяются следующие принципы передачи и связывания параметров:

Параметры связываются по их именам. Порядок указания параметров при вызове функции не существенен.

Если вызываемый метод или отчет является "методом класса", то дополнительно должен быть передан параметр "ID" со значением идентификатора объекта, для которого вызывается метод или отчет.

Если параметр имеет clob-домен подтипов "btHTML" (HTML-документ), "btXHTML" (XHTML-документ), то содержимое такого документа будет "обезврежено" (будут удалены ссылки, скрипты и т.п.)

Если вызываемый метод имеет параметр blob-домена, но при его вызове в xml-документе не найден узел с таким именем, то будет выполнен поиск параметра с тем же именем среди параметров сессии. Если такой параметр сессии будет найден, то его значение будет передано в качестве blob-значения одноименного параметра вызываемого метода. При этом в случае, если параметр имеет blob-домен подтипа "btNamedFile" (Именованный файл), то содержимое файла будет взято из одноименного параметра сессии (например, "param1"), а имя файла будет взято из параметра сессии с именем, дополненным постфиксом ".filename" (например, "param1.filename").

Если вызываемый метод имеет параметр blob-домена с подтипом "btImage" (Изображение), то для переданного значения будет предпринята попытка его преобразования в формат, заданный свойством "Расширение" домена.

В других случаях переданное или найденное в параметрах сессии blob/clob значение будет передано "как есть" в качестве значения параметра при вызове метода.

Если для параметра было использовано значение параметра сессии, то такой параметр удаляется из сессии после вызова функции (повторное использование параметра сессии невозможно).

5.12.8.2. Особенности передачи возвращаемых значений типа "большой объект"

Если функция сервиса имеет возвращаемое значение, имеющее домен типа blob, clob или "внешний файл", то такое значение может быть подвергнуто пост-обработке по следующим принципам:

Если задано расширение .js или .json, атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет clob-домен или домен "Внешние данные" подтипа "btJavaScript" (Скрипт JavaScript), то будет возвращено полученное из метода значение "как есть" (без каких-либо дополнительных преобразований)

Если задано расширение .xml, атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет clob-домен или домен "Внешние данные" подтипа "btXML" (XML-документ) или "btXHTML" (XHTML-документ), то будет возвращено полученное из метода значение "как есть" (без каких-либо дополнительных преобразований)

При использовании других расширений, если атрибут "noanalyze" не указан или имеет значение "0", и при этом возвращаемое значение имеет blob-домен подтипа "btNamedFile" (Именованный файл), то в заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Если для атрибута "noanalyze" будет передано значение "1", и при этом возвращаемое значение имеет blob-домен и его размер окажется большим, то возвращаемое значение будет сохранено в параметре сессии, а в xml-ответе будет представлен только его идентификатор.

Во всех других случаях возвращаемое значение типа "большой объект" (blob) будет двоично закодировано и возвращено в разделе CDATA xml-документа.

5.12.9. Функция executeoleobjectmethod

Функция executeoleobjectmethod позволяет вызывать методы OLE-объекта, доступные для вызова через обработчик сервера приложений, получать результат выполнения методов. Исключением методы не могут вызваться при помощи данной функции.

Допустимо использовать любые расширения, в том числе не указывать расширение. Расширение повлияет на формат возвращаемого результата следующим образом:

.xml - для получения результата выполнения в формате xml

.js/.json - для получения результата выполнения в формате JSON

пустое расширение - результат выполнения будет возвращен в формате xml

другие расширения - имеет смысл использовать в случаях, когда результатом выполнения метода является "большой объект" (blob, clob) и его тип известен; это позволит получить результат в виде файла или структуры данных определенного типа (.xslt,.pdf, форматы изображений и т.п.)
если результат выполнения не удастся привести к формату, заданному расширением, результат будет возвращен в формате xml

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый метод и значения его параметров. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, метод которого будет вызываться

"method" (обязательный) - имя метода OLE-объекта, который будет вызываться

Корневой элемент xml-документа может содержать список узлов row, каждый из которых определяет набор параметров для вызова метода. Таким образом, при помощи одного вызова функции (одним обращением к url) можно вызывать один и тот же метод для набора объектов.

Принципы передачи параметров для вызова метода, включая использование параметров типа "большой объект", описаны в статье Принципы передачи параметров функциям RESTful-service.

Для вызова методов экземпляра необходимо указывать значение неявного параметра с именем "ID". Значением этого параметра должен быть идентификатор объекта, для которого вызывается метод.
1  <execute class="TBachAbiturSt" method="AddComposition">
2    <row>
3      <ID>7927267</ID>
4      <AdmissionYear>6617171</AdmissionYear>
5      <CompYear>5639232</CompYear>
6      <Theme>742348353</Theme>
7    </row>
8  </execute>
Получить результат вызовов метода AddComposition класса TBachAbiturSt для объекта с идентификаторами (ID), равными 7927267 и с параметрами, заданными в элементе row.

Если возвращаемый результат имеет домен класса "большой объект" (clob, clob, "внешний файл"), то возвращаемое значение может быто подвергнуто пост-обработке. Подробнее этот случай описан в разделе: Особенности передачи возвращаемых значений типа "большой объект"

5.12.10. Функция getblob

Функция getblob позволяет сторонним приложениям или веб-страницам формировать ссылки на содержимое, хранящееся как значение свойства объекта системы типа "большие данные" (изображения, файлы и т.п.).

При вызове функции допустимо указывать любые расширения. Расширение должно определяться содержимым, которое ожидается получить. В случае, если об этом нет достаточной информации, можно вызывать функцию с пустым расширением.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

class (обязательный) - имя класса, значение свойства которого нужно получить

propname (обязательный) - имя свойства, значение свойства которого нужно получить

id (обязательный) - идентификатор объекта, свойство которого нужно получить

filename - имя файла, которое будет использовано для полученного файла; если свойство имеет домен подтипа "Именованный файл", то имя файла будет получено из свойства, значение которого запрашивается, иначе будет использовано значение данного атрибута

disposition - если для данного атрибута будет указано значение "inline", то будет предпринята попытка открыть содержимое в браузере (на отдельной вкладке или встроить в страницу); если атрибут не указан, то будет выполняться скачивание файла; атрибут применим для изображений, PDF-документов

width, height - атрибуты применимы в случае, если функция вызывается с расширениями .jpg или .png, или если содержимое является изображением;
в случае, если данные атрибут указаны, будет произведена попытка сжать/растянуть изображение под указанные размеры ширины и высоты
1https://techmill.ru/demo/getblob?query=
2<query class="TPersonalDocument" propname="DocFile" ID="4562944" filename="DocumentCopy1.pdf"/>
Будет выполнена попытка получения файла PDF-документа и его скачивание.

5.12.11. Функция imagelist

Функция imagelist позволяет получить набор изображений, хранящихся в системе как значения свойства определенного класса, в компактном виде, удобном для их дальнейшего использования.

Допустимые расширения:

.png - для получения ответа в виде PNG-файла

.js / .json - для получения ответа в формате JSON

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

class (обязательный) - имя или идентификатор класса, значение свойства которого содержит изображения

proprty (обязательный) - имя свойства, значения свойства которого содержат изображения

width, height - ширина и высота в пикселях, к которой будут приведены отдельные изображения; если эти значения не указаны, используются значения по умолчанию 32х32

perrow - количество изображений в одной строке при компоновке изображений; если это значение не указано, используются значение по умолчанию 12

Элемент query может иметь дочерние узлы item, за счет которых можно передать условия отбора, которые будут наложены на записи класса. Если узлы item не будут добавлены, то изображения будут получены из всех записей класса (без условий отбора).
Узлы item должны иметь атрибут part со значением where, в остальном набор атрибутов и принципы формирования узлов item совпадают с принципами использования узлов item part="where"... в функции cursor (Функция cursor) для задания условий отбора запроса.

При вызове функции с расширением .png в качестве результата будет возвращено содержимое.png-файла с набором изображений.

При вызове функции с расширением .js или .json результат будет представлять собой JSON-объект с набором полей id: index, где id - идентификатор объекта класса, index - порядковый номер изображения в структуре изображений, после которых будут следовать поля

.filename: "запрос на получение.png-файла"

.width: "32"

.height: "32"

.perrow: "12"

Вызов функции с расширением.png:
techmill.ru/sup/imagelist.png?query=<query class='TAvatar' property='Image' width='32' height='32'/>
Вызов функции с расширением.js:
techmill.ru/sup/imagelist.js?query=<query class='TAvatar' property='Image' width='32' height='32'/>
Результат, возвращаемый при вызове с расширением.js:
01{
02"12008":0,
03"12009":1,
04"12010":2,
05"13917":3,
06"27570":4,
07"68807":5,
08"1786530":6,
09"6574243":7,
10"9376694":8,
11"9376695":9,
12"38740400":10,
13"39019504":11,
14"39019505":12,
15"118496347":13,
16".filename":"/sup/imagelist.png?query=%3Cquery%20class%3D%27TAvatar%27%20property%3D%27Image%27%20width%3D%2732%27%20height%3D%2732%27%20perrow%3D%2712%27/%3E",
17".width":32,
18".height":32,
19".perrow":12}
5.12.12. Функция loadexternaldata

Функция loadexternaldata позволяет получить файл из файлового хранилища по идентификатору файла в хранилище.

Допустимые расширения:

.xml

другие расширения, которые будут соответствовать типу и расширению запрашиваемого файла.

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент loadexternaldata с атрибутами

domain - имя или идентификатор домена "внешних данных"

value - идентификатор файла в файловом хранилище

Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.
1https://techmill.ru/demo/loadexternaldata.xml?query=
2<loadexternaldata domain="TPhotoFile" value="{D4A74981-336D-474B-9585-11716BA4232B}">
3</loadexternaldata>
В качестве результата выполнения функции будут возвращены двоичные данные запрошенного файла.

5.12.13. Функция partitions

Функция partitions позволяет получить информацию о количестве объектов, возвращаемых запросом с разбиением на группы определенного размера, по каждой группе получить минимальный и максимальный идентификатор объектов и количество объектов в группе.

Допустимое расширение: .xml.

Функция имеет параметр query, значением которого должен быть.xml-документ, содержащий информацию о запросе к данным, который должен быть выполнен, и о размере групп, на которые должен быть разделен результат. Структура xml-документа должна повторять структуру, используемую при вызове функции cursor (см. Функция cursor) со следующими отличиями:

Элемент query, в дополнение к обязательному атрибуту class, должен иметь еще один обязательный атрибут chunksize - размер группы (целое число - количество записей в группе).

Узлы item со значениями атрибута part, равными what, можно не добавлять, в запросе всегда будет использоваться только идентификатор объекта (свойство ID).

Узлы item со значениями атрибута part, равными order, group, having использоваться не должны. При выполнении запроса группировка применяться не будет, а сортировка всегда будет выполняться по идентификаторам объектов (свойство ID) по убыванию.

Результат, возвращаемый функцией, всегда будет возвращен полностью, независимого от переданного значения атрибута fetchall.

В качестве результата функция вернет XML-документ с элементом data с атрибутом eof="1", имеющий дочерние узлы row, соответствующие каждой полученной группе. Каждый узел row будет иметь следующий набор дочерних узлов:

min - минимальный ID в группе объектов;

max - максимальный ID в группе объектов;

count - количество объектов в группе; во всех узлах row, кроме последнего значение count будет равно значению атрибута chunksize, переданному в запросе.

Узлы row будут отсортированы по убыванию значений ID объектов.

Пример запроса:
1  https://techmill.ru/demo/partitions.xml?query=
2    <query class="TPerson" chunksize="1000">
3      <item part="0" name="ID"/>
4      <item part="1" name="TaxID" value="*"/>
5    </query>
Пример ответа:
01  <data eof="1">
02    <row>
03      <Min type="int64">76211</Min>
04      <Max type="int64">1158488</Max>
05      <Count type="int">1000</Count>
06    </row>
07    <row>
08      <Min type="int64">1158489</Min>
09      <Max type="int64">2112571</Max>
10      <Count type="int">1000</Count>
11    </row>
12    <row>
13      <Min type="int64">2112572</Min>
14      <Max type="int64">6605306</Max>
15      <Count type="int">1000</Count>
16    </row>
17    <row>
18      <Min type="int64">6605312</Min>
19      <Max type="int64">8424606</Max>
20      <Count type="int">1000</Count>
21    </row>
22    <row>
23      <Min type="int64">8424612</Min>
24      <Max type="int64">739895343</Max>
25      <Count type="int">1000</Count>
26    </row>
27    <row>
28      <Min type="int64">739895363</Min>
29      <Max type="int64">742336003</Max>
30      <Count type="int">121</Count>
31    </row>
32  </data>
5.12.14. Функция paste

Функция paste используется для вставки данных при выполнении операций Копировать/Вставить в приложении Обозреватель данных.

Функция имеет расширение .xml.

Значение параметра функции "query" должно представлять собой XML-документ с элементом paste, который должен включать в себя элемент root, представляющий собой стандартную XML-реплику со значениями свойств вставляемых объектов.

Элемент paste должен иметь атрибуты:

ClassID - идентификатор класса, объекты которого будут "вставлены"

ParentViewCurrentRecordID - идентификатор объекта, выбранного в "родительской" таблице данных в момент выполнения "вставки"

ParentClassID - идентификатор класса, отображаемого в "родительской" таблице данных в момент выполнения "вставки"

LinkMasterPropertyID, LinkDetailPropertyID - идентификаторы свойства-главного и свойства-подчиненного, по которым таблица данных, в которую выполняется вставка, связана с "родительской" таблицей данных

При удачном выполнении "вставки" функция вернет список идентификаторов добавленных объектов.
01https://techmill.ru/demo/paste.xml?query=
02  <paste ClassID="7291"
03       LinkDetailPropertyID="348"
04       LinkMasterPropertyID=""
05       ParentClassID="7291"
06       ParentViewCurrentRecordID="2559350">
07  <root Class="7291"
08        Connection="demo - techmill.ru/demo"
09        DBGUID="{C84A02C7-51EA-4068-A0BD-D6FB0BAD15F4}">
10    <object Class="7291" ID="1384201" IsMainObject="1" Parent="1384183">
11      <Description>сентябрь 2023/2024 учебный год</Description>
12      <LearnPeriodType IDREF="10849"/>
13      <BeginDate>2023-09-01</BeginDate>
14      <EndDate>2023-09-30</EndDate>
15      <PeriodNumber>9</PeriodNumber>
16      <LastMarkDate/>
17      <Name>сентябрь</Name>
18      <Creator IDREF="1276001"/>
19      <Created>2023-03-21 17:54:59</Created>
20      <Modifier IDREF="1276001"/>
21      <Modified>2023-05-06 00:00:42</Modified>
22      <Reader/>
23      <Writer IDREF="7001"/>
24    </object>
25    <object Class="7291" ID="1384203" IsMainObject="1" Parent="1384183">
26      <Description>октябрь 2023/2024 учебный год</Description>
27      <LearnPeriodType IDREF="10849"/>
28      <BeginDate>2023-10-01</BeginDate>
29      <EndDate>2023-10-31</EndDate>
30      <PeriodNumber>10</PeriodNumber>
31      <LastMarkDate/>
32      <Name>октябрь</Name>
33      <Creator IDREF="1276001"/>
34      <Created>2023-03-21 17:54:59</Created>
35      <Modifier IDREF="1276001"/>
36      <Modified>2023-05-06 00:00:42</Modified>
37      <Reader/>
38      <Writer IDREF="7001"/>
39    </object>
40  </root>
41</paste>
5.12.15. Функция pdfreport

Функция pdfreport позволяет вызывать на выполнение отчеты класса TPDFTemplate и получать файлы, формируемые как результат выполнения отчетов.

Допустимые расширения:

.pdf - возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, отчет которого будет вызываться

"template" (обязательный) - имя отчета, который будет вызываться

"format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:

цветовой режим - допустимые значения "mono", "grey"; значение по умолчанию - "обычный" цветовой режим

внедрение шрифтов (для формата PDF) - допустимые значения "embed", "embedded"; значение по умолчанию - без внедрения шрифтов

"filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="Consent.mono.embed.pdf", что будет говорить о том, что будет возвращен pdf-документ, сформированный в монохромном режиме с внедренными шрифтами; значение по умолчанию: "pdfreport.pdf".

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата PDF, сформированный в режиме, определенном атрибутами параметра query (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове PDF-отчета:
1  <execute class="TBachAbiturSt" template="ConsEnrollment" format="grey.embedded.pdf" filename="Consent.pdf">
2    <row>
3      <ID>7926329</ID>
4      <BachCompetition>4327519</BachCompetition>
5      <PlaceType>7927327</PlaceType>
6    </row>
7  </execute>
При таком вызове будет выполнен PDF-отчет "ConsEnrollment" класса "TBachAbiturSt" с параметрами, переданными в элементе row. Данный отчет является "методом объекта", поэтому дополнительно использован параметр "ID". Полученный файл отчета будет сформирован с внедрением шрифтов в цветовом режиме "в градациях серого". В качестве ответа будет возвращен.pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("Consent.pdf"), в содержимом ответа будет передано содержимое файла.

5.12.16. Функция postblob

Функция postblob позволяет установить значение поля таблицы, имеющее тип "большой объект". Функция может вызываться под пользователем, имеющим права доступа на запись к таблицам СУБД.

Функция имеет расширение .xml.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

id (обязательный) - идентификатор объекта, свойство которого нужно получить, или список идентификаторов объектов, разделенных ";" при передаче списка объектов для всех этих объектов будет установлено одинаковое значение поля

table (обязательный) - имя таблицы, содержащей поле, значение свойства которого нужно установить

field (обязательный) - имя поля таблицы, значение свойства которого нужно установить

subtype (обязательный) - порядковый номер элемента перечисления "TBlobSubtype" (Подтипы), определяющий подтип домена класса "большой объект", использованного для устанавливаемого значения

В качестве значения элемента query должно быть передано устанавливаемое значение в двоичном формате. При передаче этого значения функции могут быть выполнены преобразования, описанные в статье Принципы передачи параметров функциям RESTful-service.
1https://techmill.ru/demo/postblob.xml?query=
2    <query id="76328;5256545" table="TPersonPhoto" field="FPhotoFile" subtype="2">
3      <![CDATA[Q09NUFJFU1NFRAAABwAAADExMS5ibXBCTRYBAAAAAAAAPgAAACgAAAAiAAAAGwAAAAEAAQAAAAAA2AAAAMQOAADEDgAAAAAAAAAAAAAAAAAA////AP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/B/wf8AAAAD8H/B/wAAAAPwf8H/AAAAA/B/wf8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAA==]]>
4    </query>
5.12.17. Функция routinelog

Функция routinelog предназначена для создании записей истории вызова подпрограммы (метода, метода OLE-объекта, отчета) и набора значений параметров без вызова самой этой подпрограммы. Запись об истории вызова создается как объект класса "Вызовы" (TRoutineHistory) записи о значениях параметра создаются как объекты класса "Параметры вызовов" (TParameterHistory).

Допустимое расширение: .xml.

Функция имеет параметр query, который должен представлять собой XML документ, содержащий информацию о подпрограмме и значениях ее параметров. Параметр query можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент XML-документа должен иметь атрибут routine, значением которого должен быть идентификатор подпрограммы. Элемент должен иметь набор узлов, соответствующих параметрам подпрограммы и их значениям.

При передаче информации о параметрах необходимо учитывать Принципы передачи параметров функциям RESTful-service.
1https://techmill.ru/demo/routinelog.xml?query=
2<query routine="756584">
3  <AdmissionYear>7427462</AdmissionYear>
4  <AdmStage>8608398</AdmStage>
5  <PrevAdmissionYear>6843737</PrevAdmissionYear>
6  <RegDatePrevAdmYear>14.05.2014</RegDatePrevAdmYear>
7</query>
При успешном выполнении функции будет возвращен ответ с одним пустым элементом <data eof="1"/>.

5.12.18. Функция rtti

Функция rtti позволяет получить информацию о типах (run-time type information, RTTI) в форматах XML или JSON.

Допустимые расширения:

.xml - для получения ответа в формате XML

.js/.json - для получения ответа в формате JSON

Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/rtti.xml
В качестве ответа будет возвращен XML-документ или JSON полученный рядом запросов к метаданных системы. Ответ будет состоять из элементов data, соответствующих каждому запросу, которые имеют узлы row на каждую запись возвращаемых данных. Для каждой записи будут узлы с именами, совпадающими со значениями свойств и значениями этих свойств.

Пример ответа:
01<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
02  ...
03</data>
04<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
05  <row>
06    <ID>1669</ID>
07    <Name>TFolder domain</Name>
08    <Description>Папка</Description>
09    <Required type="int">1</Required>
10    <Length type="int">255</Length>
11    <FolderMustExist type="int">1</FolderMustExist>
12  </row>
13</data>
14<data eof="1" handle="{06399069-7150-4087-8ACB-D14C809497C2}">
15  <row>
16    <ID>28</ID>
17    <Name>Boolean</Name>
18    <Description>Обычное логическое</Description>
19    <Required type="int">1</Required>
20    <TrueValue>Да</TrueValue>
21    <FalseValue>Нет</FalseValue>
22  </row>
23  <row>
24    <ID>170</ID>
25    <Name>Non-required boolean</Name>
26    <Description>Необязательное логическое</Description>
27    <Required type="int">0</Required>
28    <TrueValue>Да</TrueValue>
29    <FalseValue>Нет</FalseValue>
30  </row>
31  <row>
32    <ID>662765452</ID>
33    <Name>TProfileConditionAccess</Name>
34    <Description>Условия доступа профиля</Description>
35    <Required type="int">1</Required>
36    <TrueValue>Контролировать чтение и запись</TrueValue>
37    <FalseValue>Контролировать только запись</FalseValue>
38  </row>
39</data>
40<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
41  ...
42</data>
43<data eof="1" handle="{121B38C1-C6FE-4B10-8745-13B4D10DB006}">
44  ...
45</data>
5.12.19. Функция selectblob

Функция selectblob позволяет получить значение свойства объекта имеющий тип "большие данные" (файл, изображение, и т.п.), а также позволяет сравнивать значения типа "большие данные" без получения самих этих данных.

При вызове функции допустимо указывать любые расширения. Расширение должно определяться содержимым, которое ожидается получить. В случае, если об этом нет достаточной информации, можно вызывать функцию с пустым расширением.

Значение параметра функции "query" должно представлять собой XML-документ, который должен содержать элемент query со следующими атрибутами:

class (обязательный) - имя класса, значение свойства которого нужно получить (или сравнить)

propname (обязательный) - имя свойства, значение свойства которого нужно получить (или сравнить)

id (обязательный) - в качестве значения этого параметрам может быть передано:

идентификатор объекта, значение свойства которого нужно получить

список идентификаторов объектов, разделенных ";"

идентификатор буфера, содержащего список объектов (подробнее о создании и наполнении буфера: Функция selectedbuffer, Функция selectionchanged)

Функция вернет следующий результат:

если в атрибуте ID был передан один объект или если содержимое (значение свойства) для всех переданных объектов одинаково, то вернется это одно значение

в других случаях вернется значение NULL

Таким образом, можно выполнять сравнение значений типа "большой объект" - если получено отличное от NULL значение, значит значения равны, иначе значения не равны. Получения самих значений во втором случае не происходит.
1https://techmill.ru/demo/selectblob?query=
2<query class="TPersonalDocument" propname="DocFile" ID="4562944;398621"/>
5.12.20. Функция selectedbuffer

Функция selectedbuffer возвращает новый идентификатор буфера, в который далее можно добавлять объекты, что позволит выполнять различные операции с созданным таким образом набором объектов как с единым целым.
Для манипуляций списком объектов в буфере предназначена Функция selectionchanged.

Допустимое расширение: .xml

Функция возвращает XML-документ в узле которого с именем ID возвращается идентификатор созданного буфера.

Пример запроса:
  https://techmill.ru/demo/selectedbuffer.xml
Пример ответа:
1  <data eof="1">
2    <row>
3      <ID>1186174</ID>
4    </row>
5  </data>
5.12.21. Функция selectionchanged

Функция selectionchanged позволяет манипулировать списком объектов буфера. Для создания нового буфера предназначена функция Функция selectedbuffer.

Допустимое расширение: .xml

В значении параметра с именем "query" необходимо передать xml-документ, содержащий данные о существующем буфере и действиях, которые должны быть с ним проведены. Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

XML-документ query должен иметь один элемент selectionchanged со следующим набором атрибутов:

handle (обязательный) - идентификатор буфера

ID - список идентификаторов объектов с разделителем ";", которые будут добавлены в буфер или исключены из него; значение может быть пустым только в случае, если выполняется полная очистка буфера, что предается значением атрибута cleanup

selected (обязательный) - указание о том, какое действие должно быть выполнено с переданным списком объектов; допустимые значения:

"0" - удалить объекты из буфера

"1" - добавить объекты в буфер

cleanup - указание о том, что нужно сделать перед добавлением или удалением объектов; допустимые значения:

"0" (значение по умолчанию) - не выполнять предварительных действий

"1" - очистить буфер перед выполнением действия

При успешном выполнении функция вернет XML-документ с одним элементом data и атрибутом eof="1".
1  https://techmill.ru/demo/selectionchanged.xml?query=
2    <selectionchanged handle="221024" ID="227222;76923;77312" selected="1" cleanup="1"/>
В буфер с идентификатором 1186175 будут добавлены объекты с идентификаторами 77222;76923;77312; перед добавлением буфер будет очищен.

5.12.22. Функция sessionlogoff

Функция sessionlogoff позволяет удалить текущую сессию.

Допустимое расширение: .xml. Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/sessionlogoff.xml
Пример ответа:
  <data eof="1"/>
5.12.23. Функция setpropvalue

Функция setpropvalue позволяет изменять значения свойств объектов, доступные для изменения через обработчик сервера приложений.

Допустимое расширение: .xml.

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент setpropvalue с атрибутами, позволяющими идентифицировать объект и принадлежащее ему свойство, значение которого требуется изменить. Значение, которое должно быть установлено для свойства, передается как текст элемента setpropvalue Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Атрибуты элемента setpropvalue:

ID (обязательный) - идентификатор объекта, свойство которого должно быть изменено

class (обязательный, если не указан атрибут "propid") - имя класса, свойство которого должно быть изменено

propname (обязательный, если не указан атрибут "propid") - имя свойства, принадлежащего классу, переданному значением атрибута "class", значение которого должно быть изменено

propid (обязательный, если не указаны атрибуты "class" и "propname") - идентификатор свойства, значение которого должно быть изменено

noanalyze

Для передачи информации о свойстве, значение которого должно быть изменено, можно использовать атрибут "propid" или пару атрибутов "class" и "propname".
1  <setpropvalue ID="4912468" class="TPerson" propname="MiddleName">
2    "Алексеевич"
3  </setpropvalue>
Установить значение "Алексеевич" для свойства класса "TPerson" с именем "MiddleName" для объекта с идентификатором "4912468".

При успешном выполнении функция возвращает xml-документ с пустым набором данных:
<data eof="1"/>
При неуспешном выполнении функция возвращает xml-документ с текстом сообщения об ошибке, например:
1<error>
2  <message>Property not found.</message>
3  <className>Exception</className>
4</error>
5.12.24. Функция storeexternaldata

Функция storeexternaldata позволяет выполнить сохранение файла как "внешних данных" определенного домена. Файл данных будет записан в файловое хранилище, в виде, определяемом доменом.

Допустимое расширение: .xml

В значении параметра с именем "query" необходимо передать xml-документ, содержащий один элемент storeexternaldata с атрибутом domain, значением которого должно быть имя или идентификатор домена класса "Внешние данные". Этот параметр можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Запрос:
1  https://techmill.ru/demo/storeexternaldata.xml?query=
2    <storeexternaldata domain="TPhotoFile">
3      <![CDATA[Q09NUFJFU1NFRAAABwAAADExMS5ibXBCTRYBAAAAAAAAPgAAACgAAAAiAAAAGwAAAAEAAQAAAAAA2AAAAMQOAADEDgAAAAAAAAAAAAAAAAAA////AP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/B/wf8AAAAD8H/B/wAAAAPwf8H/AAAAA/B/wf8AAAAD8AAB/wAAAAPwAAH/AAAAA/AAAf8AAAAD8AAB/wAAAAPwAAH/AAAAA/////8AAAAD/////wAAAAP/////AAAAA/////8AAAAD/////wAAAAA==]]>
4    </storeexternaldata>
Ответ:
1  <data eof="1">
2    <row>
3      <Result>{1B8C156B-76F6-4EC1-987D-F6C0000DB343}</Result>
4    </row>
5  </data>
5.12.25. Функция sysinfo

Функция sysinfo позволяет получить информацию о системе в формате XML с набором атрибутов, соответствующих характеристикам системы.

Допустимое расширение: .xml. Функция не имеет параметров.

Пример запроса:
  https://techmill.ru/demo/sysinfo.xml
Пример ответа:
  <sysinfo major="3" minor="2" release="2" build="304" PerformExcelReports="0" PerformOleObjectMethods="0" PerformPDFReports="0" PerformWordReports="0" PerformXSLTReports="0" GroupMethods="0"/>
5.12.26. Функция timebias

Допустимое расширение - .xml

Используется JavaScript-клиентом и "Обозревателем данных".

Параметр query содержит текст xml-документа, в котором в атрибутах корневого узла разложены компоненты текущей даты и текущего времени клиента:
<timebias Y="2024" M="03" D="22" H="12" Mi="30" S="00" Ms="100"/>
Имя корневого элемента не имеет значения. АтрибутY содержит год, M - месяц (нумеруются с 1, январь - "1", декабрь - "12"), D - число внутри месяца, H - часы, Mi - минуты, S - секунды, Ms - миллисекунды.

Ответ представляет собой xml-документ следующей структуры:
1  <data eof="1">
2    <row>
3      <Bias type="dbl">
4        0,19860191
5      </Bias>
6    </row>
7  </data>
здесь числовое значение в элементе Bias содержит количество суток (в данном примере - 0 целых, 1 десятая, 9 сотых, 8 тысячных и так далее), которые нужно прибавлять к датам, полученным с сервера приложений, чтобы получить даты в часовом поясе клиента. Атрибут type, атрибут eof (оба - вместе со значениями), и имена всех элементов ответа являются неизменными, и передаются для унификации процедуры разбора ответа.

5.12.27. Функция wordreport

Функция wordreport позволяет вызывать на выполнение отчеты класса TWordTemplate и получать файлы, формируемые как результат выполнения отчетов. Файлы могут быть возвращены как в форматах Word (.doc,.docx), так и с преобразованием в другие форматы. Исключением являются интерактивные отчеты (требующие при формировании диалога с пользователем). Такие отчеты не могут вызваться при помощи данной функции.

Допустимые расширения:

.doc - для получения файла отчета в формате DOC

.docx - для получения файла отчета в формате DOCX

.html - для получения файла отчета в формате HTML; формирование html-документа выполняется средствами MS Word;

.rtf - для получения файла отчета в формате RTF

.pdf - для получения файла отчета в формате PDF; преобразование.doc/.docx-файла в pdf-документ выполняется средствами самого Word; возможно формирование pdf-документа с внедрением шрифтов и без внедрения, в монохромном цветовом режиме и в режиме "в градациях серого"

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, отчет которого будет вызываться

"template" (обязательный) - имя отчета, который будет вызываться

"format" - указания по формату, в котором нужно вернуть файл ответа; составляющие информации о формате должны быть переданы в виде строковых литералов, разделенных точкой; составляющими формата могут быть:

тип файла результата - допустимые значения совпадают с возможными расширениями вызова функции (без дополнительной точки)

"filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition; имя файла также может содержать в себе указания по формату получаемого файла, которые будут применены в случае, если атрибут format отсутствует. Например, имя файла может иметь вид filename="ListenerCard.pdf", что будет говорить о том, что будет возвращен pdf-документ.
Значение по умолчанию: "wordreport" с расширением, совпадающим с расширением вызываемой функции.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного атрибутами параметра query или расширением функции wordreport (подробнее: Принципы разбора информации о формате результирующего файла). В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове Word-отчета:
1  <execute class="TDPOStatus" template="ListenerCard" format="grey.embed.pdf" filename="ListenerCard.pdf">
2    <row>
3      <ID>5201838</ID>
4      <DPOInstitute>4327519</DPOInstitute>
5      <SecondSigner>4469840</SecondSigner>
6    </row>
7  </execute>
При таком вызове будет выполнен Word-отчет "ListenerCard" класса "TDPOStatus" с параметрами, переданными в элементе row. Данный отчет является "методом объекта", поэтому дополнительно использован параметр "ID". Полученный файл отчета будет преобразован в формат PDF с внедрением шрифтов в цветовом режиме "в градациях серого". Преобразование будет выполнено средствами приложения MS Word. В качестве ответа будет возвращен.pdf-документ. В заголовке ответа в поле Content-Disposition будет передано имя файла ("ListenerCard.pdf"), в содержимом ответа будет передано содержимое файла.

5.12.28. Функция xsltreport

Функция xsltreport позволяет вызывать на выполнение отчеты класса TXSLTTemplate и получать файлы, формируемые как результат выполнения отчетов.

Допустимые расширения:

.xml

.html

.txt

без расширения

Для данного вида отчета тип и расширение возвращаемого файла будут определены самим XSLT-отчетом (будут заданы в элементе "xsl:output" в шаблоне отчета). Вызов функции с тем или иным расширением не повлияет на тип и расширение файла-результата.

В значении параметра с именем "query" необходимо передать xml-документ, описывающий вызываемый отчет, указания по способу формирования ответа и значения параметров отчета. Параметр "query" можно передавать, обращаясь к url как методом GET, так и методом POST. Значение параметра должно быть закодировано по правилам представления url.

Корневой элемент документа-запроса должен иметь имя execute и может иметь атрибуты:

"class" (обязательный) - имя класса, отчет которого будет вызываться

"template" (обязательный) - имя отчета, который будет вызываться

"filename" - имя файла, которое будет передано в заголовке ответа в поле Content-Disposition.
Значение по умолчанию: имя вызываемого отчета с расширением, которое будет определено самим отчетом.

Подчиненные узлы row предназначены для передачи параметров отчета. Для каждого параметра должен быть добавлен подчиненный узел с именем, совпадающим с именем параметра, и значением параметра. Если отчет является "методом объекта", до дополнительно должен быть передан неявный параметр с именем "ID" и идентификатором объекта, для которого вызывается отчет, в качестве значения. Общие принципы передачи параметров описаны в разделе Принципы передачи параметров функциям RESTful-service

В качестве ответа будет возвращен файл формата, определенного самим отчетом. В заголовке ответа в поле Content-Disposition будет передано имя файла, в содержимом ответа будет передано содержимое файла.

Значение параметра query при вызове XSLT-отчета:
1  <execute class="TObject" template="SelectDataToText" filename="QueryResult.txt">
2    <row>
3      <ClassName>TCountry</ClassName>
4      <Query></Query>
5    </row>
6  </execute>
При таком вызове будет выполнен XSLT-отчет "SelectDataToText" класса "TObject" с параметрами, переданными в элементе row. Данный отчет является "методом класса", поэтому параметр "ID" в состав параметров не добавлен. В качестве ответа будет возвращен текстовый файл. В заголовке ответа в поле Content-Disposition будет передано имя файла ("QueryResult.txt"), в содержимом ответа будет передано содержимое файла.

6. Руководство разработчика для построителя запросов

6.1. Информация о приложении

Приложение QueryBuilder представляет собой документ-ориентированное MDI-проиложение.
Документом является запрос. Запросы сохраняются в файле с расширением .MQR. Файлы запросов представляют собой xml-документы определенной структуры. Для доступа к данным БД приложение использует провайдеры данных - библиотеки объектов, реализующих опубликованные интерфейсы. Идентификатор использованного для построения запроса провайдера сохраняется в файле запроса. Если открыть файл с провайдером, не соответствующим текущему, будет выдано предупреждение.

6.2. Требования к провайдеру

Интерфейсы провайдера описаны в библиотеке типов файла QueryBuilder.exe и в файле QueryBuilder_TLB.pas. Собственно, объект-провайдер реализует Интерфейс IInfoProvider. Каждый CoClass, реализующий указанный интерфейс, прописывается в ветке реестра HKLM\Software\QueryBuilder\Providers добавлением параметра, имя которого определяет наименование провайдера, а значение - CLSID провайдера.

Метаданные (информация о таблицах, полях и типах данных) предоставляются в виде именованных элементов, то есть каждый из них реализует интерфейс INamedItemInfo

6.2.1. Интерфейс IInfoProvider

Провайдер реализует интерфейс
01  IInfoProvider = interface(IUnknown)
02    ['{64F8072B-7250-4C57-BA8E-D018C7B72CC7}']
03    function Get_TableCount: Integer; safecall;
04    function Get_Table(Index: Integer): ITableInfo; safecall;
05    function Perform(const SQL: WideString): IDataSet; safecall;
06    procedure Connect(const DataBase: WideString;
07      const UserName: WideString;
08      const Password: WideString); safecall;
09    function Get_CLSID: TGUID; safecall;
10    function Get_DateLiteral: WideString; safecall;
11    function Get_TimeLiteral: WideString; safecall;
12    function Get_DateTimeLiteral: WideString; safecall;
13  end;
функция Get_CLSID возвращает GUID класса-провайдера.

процедура Connect осуществляет соединение с БД.

функция Get_TableCount возвращает количество таблиц, доступ к которым предоставляется провайдером.

функция Get_Table возвращает ссылку на информацию о таблице с номером Index. Ссылка на интерфейс ITableInfo или интерфейс ITableInfo2

функция Perform принимает текст сформированного SQL-запроса и возвращает ссылку на набор данных. Набор данных реализует интерфейс IDataSet.

функция Get_DateLiteral возвращает строку, определяющую способ включения в запрос литерала типа "Дата".

функция Get_TimeLiteral возвращает строку, определяющую способ включения в запрос литерала типа "Время".

функция Get_DateTimeLiteralвозвращает строку, определяющую способ включения в запрос литерала типа "Дата со временем".

6.2.2. Интерфейс IDataSet

Набор данных реализует интерфейс
1   IDataSet = interface(IUnknown)
2    ['{3CED7395-8482-4EF6-8A15-7744348063C2}']
3    function Get_FieldCount: Integer; safecall;
4    function Get_FieldName(Index: Integer): WideString; safecall;
5    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
6    procedure Next; safecall;
7    function Eof: WordBool; safecall;
8  end;
Набор данных представляет собой однонаправленный курсор, каждая строка которого является набором именованных и нумерованных полей.

процедура Next осуществляет переход к следующей записи курсора.

функция Eof возвращает True в случае достижения конца курсора.

функция Get_FieldCount возвращает количество полей в строке курсора.

функция Get_FieldName возвращает имя поля с номером Index.

функция Get_Field возвращает значение поля, имя или номер которого задан параметром (если строка, то имя, если число, то номер). Допустимо возвращать значение Null для пустых полей.

6.2.3. Интерфейс INamedItemInfo

Каждый элемент метаданных (таблица, поле, тип) обязательно реализует интерфейс
1  INamedItemInfo = interface(IUnknown)
2    ['{14894363-28DA-4E71-B0BC-9C5CE811BC8F}']
3    function Get_Name: WideString; safecall;
4    function Get_Caption: WideString; safecall;
5    function Get_ID: WideString; safecall;
6  end;
Именованный элемент имеет имя, наименование и идентификатор. Имя используется для именования сущности в сформированном SQL-запросе, идентификатор необходим для идентификации сущности в рамках провайдера, таблицы и типы данных имеют глобальное пространство идентификаторов, поля имеют уникальные идентификаторы в пределах последовательности наследуемых таблиц. Никаких ограничений на значения идентификаторов, кроме уникальности, не накладывается.

функция Get_Name возвращает имя сущности.

функция Get_Caption возвращает наименование сущности.

функция Get_ID возвращает идентификатор сущности.

6.2.4. Интерфейс ITableInfo

Информация о таблице представляется объектом через интерфейс (наследник INamedItemInfo )
1  ITableInfo = interface(INamedItemInfo)
2    ['{3FC1998A-9031-4936-82B5-8CAA2219085E}']
3    function Get_FieldCount: Integer; safecall;
4    function Get_Field(Index: Integer): IFieldInfo; safecall;
5    function Get_PrimaryKey: IFieldInfo; safecall;
6    function Get_Uplink: IFieldInfo; safecall;
7    function Get_Parent: ITableInfo; safecall;
8  end;
функция Get_FieldCount возвращает количество полей в таблице.

функция Get_Field возвращает ссылку на поле с номером Index. Ссылка на интерфейс IFieldInfo

функция Get_PrimaryKey возвращает ссылку на поле, являющееся первичным ключем. Это поле должно быть задано.

функция Get_Uplink возвращает ссылку на поле, осуществляющее иерархическую связь между записями таблицы. Если это поле задано, записи отображаются в виде иерархии.

функция Get_Parent возвращает ссылку на родительскую таблицу. Дочерняя таблица связана с родительской первичными ключами, т. е. соотношением 1:1. Если таблица не имеет родительской, возвращается nil.

6.2.4.1. Интерфейс ITableInfo2

Для таблиц, имеющих полиморфные ссылки, реализуется интерфейс (наследник ITableInfo )
1  ITableInfo2 = interface(ITableInfo)
2    ['{9DF4C8AC-1DA2-4E7B-BF44-7EDD7A269418}']
3    function Get_PolymorphCount: Integer; safecall;
4    function Get_PolymorphTable(Index: Integer): ITableInfo; safecall;
5    function Get_PolymorphField(Index: Integer): IFieldInfo; safecall;
6  end;
Полиморфной ссылкой является, например, ссылка, физически размещенная в родительской таблице, указывающая на свою запись. Реализация этого интерфейса не является обязательной.

функция Get_PolymorphCount возвращает количество полиморфных ссылок.

функция Get_PolymorphTable возвращает ссылку на таблицу, на которую указывает полиморфная ссылка номер Index.

функция Get_PolymorphTable возвращает ссылку на поле, реализующее полиморфную ссылку номер Index. Это поле должно иметь тип dtReference, информация о его типе должна реализовать интерфейс IReferenceInfo. Значение, возвращаемое функцией Get_TargetTable этого интерфейса в данном случае не имеет значения и игнорируется.

6.2.4.2. Интерфейс ITableInfo3

Для таблиц, при запросах к которым требуется наложение дополнительных условий отбора, реализуется интерфейс (наследник ITableInfo )
01  ITableInfo3 = interface(ITableInfo)
02    ['{3FB73AA9-010C-48DA-81C7-E1DCFE2E6136}']
03    function GetPersistentClause(const Alias: WideString): WideString; safecall;
04    function GetPreConditionsCount: Integer; safecall;
05    function GetPreConditionCaption(Index: Integer): WideString; safecall;
06    function GetPreConditionCategory(Index: Integer): WideString; safecall;
07    function Get_ActivePreCondition(Index: Integer): WordBool; safecall;
08    procedure Set_ActivePreCondition(Index: Integer; Value: WordBool); safecall;
09    function GetPreConditionParamsCount(Index: Integer): Integer; safecall;
10    function GetPreConditionParam(Index: Integer; PreConditionIndex: Integer): IOptionInfo; safecall;
11  end;
функция GetPersistentClause возвращает выражение дополнительного условия отбора. Алиас таблицы передается в параметре Alias.

6.2.5. Интерфейс IFieldInfo

Информация о поле поставляется объектом, реализующим интерфейс (наследник INamedItemInfo )
1  IFieldInfo = interface(INamedItemInfo)
2    ['{19054DAD-8D35-4B39-8EB7-FD3254BD2934}']
3    function Get_TypeInfo: ITypeInfo; safecall;
4    function Get_DisplayMode: TDisplayMode; safecall;
5  end;
функция Get_DisplayMode возвращает роль поля при показе таблицы. Возможные значения (тип TDisplayMode):

dmAlways - поле является ключевым, всегда показывается

dmNever - поле является служебным (первичным ключем, например). Никогда не показывается.

dmOnDemand - поле является обычным информационным, показывается по требованию пользователя.

функция Get_TypeInfo возвращает ссылку на информацию о типе данных поля. Возвращаете ссылку на один из интерфейсов-наследников интерфейса ITypeInfo

6.2.6. Интерфейс ITypeInfo

Информация о типах полей поставляется в виде набора объектов, каждый из которых реализует интерфейс (наследник INamedItemInfo )
1  ITypeInfo = interface(INamedItemInfo)
2    ['{2B6A5E20-3C36-4574-89DB-7C873A5C4A00}']
3    function Get_Required: WordBool; safecall;
4    function Get_SimpleType: TSimpleType; safecall;
5  end;
Информация о конкретном типе передается при помощи реализации одного из наследников этого интерфейса.

функция Get_Required возвращает True, если значение поля обязательно для задания.

функция Get_SimpleType возвращает информацию о простом типе данных. В зависимости от возвращаемого значения объект должен также реализовывать один из интерфейсов конкретных типов (см. далее). Возможные значения (тип TSimpleType ):

dtString - строковый тип. Обязательно реализуется интерфейс IStringInfo

dtInteger - целочисленный тип. Обязательно реализуется интерфейс IIntegerInfo

dtFloat - вещественный тип. Обязательно реализуется интерфейс IFloatInfo

dtDate - тип "дата". Обязательно реализуется интерфейс IDateInfo

dtTime - тип "время". Обязательно реализуется интерфейс ITimeInfo

dtDateTime - тип "дата со временем". Обязательно реализуется интерфейс IDateTimeInfo

dtBoolean - логический тип. Обязательно реализуется интерфейс IBooleanInfo

dtEnumeration - перечисление. Обязательно реализуется интерфейс IEnumerationInfo

dtReference - ссылка. Обязательно реализуется интерфейс IReferenceInfo

dtBlob - Большой двоичный объект. Обязательно реализуется интерфейс IBlobInfo.

6.2.6.1. Интерфейс ITypeInfo2

Информация о предоставляемых провайдером дополнительных возможностях фильтрации (наследник интерфейса ITypeInfo)
1  ITypeInfo2 = interface(ITypeInfo)
2    ['{77F58BDF-F01C-40F3-B193-1027AD8C4EDA}']
3    function GetSpecialFilterCount: Integer; safecall;
4    function GetSpecialFilterText(Index: Integer): WideString; safecall;
5    function EditSpecialFilter(Index: Integer; var Filter: WideString): WordBool; safecall;
6  end;
функция GetSpecialFilterCount возвращает количество дополнительных элементов списка, выпадающего при выборе фильтра по колонке.

функция GetSpecialFilterText возвращает текст дополнительного элемента списка, выпадающего при выборе фильтра по колонке, с номером Index.

функция EditSpecialFilter вызывается в момент выбора пользователем дополнительного элемента списка, выпадающего при выборе фильтра по колонке, с номером Index. Значение выражения фильтра передается и возвращается в параметре Filter. Функция возвращает True в случае, если выражение, возвращенное в параметре Filter нужно применить для фильтрации столбца запроса, False - в противном случае.

6.2.6.2. Интерфейс IStringInfo

Информация о строковом типе (наследник интерфейса ITypeInfo)
1  IStringInfo = interface(ITypeInfo)
2    ['{74AC4C03-E803-421B-B30D-1A2D2C49827F}']
3    function Get_Length: Integer; safecall;
4  end;
функция Get_Length возвращает максимальную длину строки.

6.2.6.3. Интерфейс IIntegerInfo

Информация о целочисленном типе (наследник интерфейса ITypeInfo)
1  IIntegerInfo = interface(ITypeInfo)
2    ['{9003B25E-926D-42AE-A907-813DF3A8343E}']
3    function Get_MaxValue: Integer; safecall;
4    function Get_MaxValueUsed: WordBool; safecall;
5    function Get_MinValue: Integer; safecall;
6    function Get_MinValueUsed: WordBool; safecall;
7  end;
функция Get_MaxValueUsed возвращает True, если значение имеет верхнюю границу.

функция Get_MaxValue возвращает верхнюю границу значения, если есть.

функция Get_MinValueUsed возвращает True, если значение имеет нижнюю границу.

функция Get_MinValue возвращает нижнюю границу значения, если есть.

6.2.6.4. Интерфейс IFloatInfo

Информация о вещественном типе (наследник интерфейса ITypeInfo )
1  IFloatInfo = interface(ITypeInfo)
2    ['{E9B56C6D-47DC-4AB9-9E80-6EEF77708704}']
3    function Get_MaxValue: Double; safecall;
4    function Get_MaxValueUsed: WordBool; safecall;
5    function Get_MinValue: Double; safecall;
6    function Get_MinValueUsed: WordBool; safecall;
7    function Get_Precision: Integer; safecall;
8    function Get_Scale: Integer; safecall;
9  end;
функция Get_MaxValueUsed возвращает True, если значение имеет верхнюю границу.

функция Get_MaxValue возвращает верхнюю границу значения, если есть.

функция Get_MinValueUsed возвращает True, если значение имеет нижнюю границу.

функция Get_MinValue возвращает нижнюю границу значения, если есть.

функция Get_Precision возвращает максимальное количество значащих десятичных цифр в значении.

функция Get_Scale возвращает максимальное количество десятичных цифр после запятой.

6.2.6.5. Интерфейс IDateInfo

Информация о типе "Дата" (без времени) (наследник интерфейса ITypeInfo )
1  IDateInfo = interface(ITypeInfo)
2    ['{DA392510-105F-4655-9A38-18ECA2FBEB97}']
3  end;
Не имеет методов.

6.2.6.6. Интерфейс ITimeInfo

Информация о типе "Время" (без даты) (наследник интерфейса ITypeInfo )
1  ITimeInfo = interface(ITypeInfo)
2    ['{D7067CAC-67A5-41DB-8D95-40409D8658AB}']
3  end;
Не имеет методов.

6.2.6.7. Интерфейс IDateTimeInfo

Информация о типе "Дата со времемем" (наследник интерфейса ITypeInfo )
1  IDateTimeInfo = interface(ITypeInfo)
2    ['{7F5CC8F9-8CE1-4DB7-8932-884EF3BAB538}']
3  end;
Не имеет методов.

6.2.6.8. Интерфейс IBooleanInfo

Информация о логическом типе (наследник интерфейса ITypeInfo )
1  IBooleanInfo = interface(ITypeInfo)
2    ['{8256EDF9-8613-4970-850C-50047839D6BF}']
3    function Get_TrueValue: WideString; safecall;
4    function Get_FalseValue: WideString; safecall;
5  end;
функция Get_TrueValue возвращает отображаемую строку для значения True (например, "Да").

функция Get_FalseValue возвращает отображаемую строку для значения False (например, "Нет").

6.2.6.9. Интерфейс IEnumerationInfo

Информация о перечислимом типе (наследник интерфейса ITypeInfo )
1  IEnumerationInfo = interface(ITypeInfo)
2    ['{B58A3F23-1AAC-4420-ADFF-B23B9938A994}']
3    function Get_ItemCount: Integer; safecall;
4    function Get_Item(Index: Integer): IEnumerationItem; safecall;
5  end;
Перечислимый тип определяет набор значений, которые может принимать поле. Значения в таблице трактуются как равные имени элемента перечисления.

функция Get_ItemCount возвращает количество элементов перечисления.

функция Get_Item возвращает ссылку на элемент перечисления с номером Index, реализующий интерфейс IEnumerationItem

6.2.6.10. Интерфейс IReferenceInfo

Информация о типе "ссылка" (наследник интерфейса ITypeInfo )
1  IReferenceInfo = interface(ITypeInfo)
2    ['{309C8CB1-4A1C-4E58-BC3F-D1AF27861A8F}']
3    function Get_TargetTable: ITableInfo; safecall;
4  end;
функция Get_TargetTable возвращает ссылку на таблицу, с которой осуществляется связь. Возвращается ссылка на интерфейс ITableInfo

6.2.6.11. Интерфейс IBlobInfo

Информация о типе "больших двоичных объектов" (наследник интерфейса ITypeInfo )
1  IBlobInfo = interface(ITypeInfo)
2    ['{3905C9C4-EAEB-4844-BB55-3F524F1F3FAC}']
3    function Get_SubType: TBlobSubType; safecall;
4  end;
функция Get_SubType возвращает подтип большого двоичного объекта. Одно из следующих значений (тип TBlobSubType ):

bsText - текст

bsImage - изображение

bsBinary - двоичные данные

6.2.7. Интерфейс IEnumerationItem

Информация об элементе перечисления (наследник INamedItemInfo )
1  IEnumerationItem = interface(INamedItemInfo)
2    ['{6953507C-D477-4B8D-9443-A9E5FE7137ED}']
3    function Get_Position: Integer; safecall;
4  end;
Значения в таблице трактуются как равные имени элемента перечисления.

функция Get_Position возвращает позицию элемента перечисления.

6.3. Использование провайдера БД Парус8

6.3.1. Использование пользовательских приложений.

Библиотека ParusInfoProvider.dll содержит реализацию провайдера для БД Парус8. Провайдер реализует, в дополнение к обязательным, интерфейс, позволяющий управлять им посредством механизма "Пользовательских приложений":
1  IParusProvider = interface(IDispatch)
2    ['{4864AE99-80E6-4FC6-9DB0-EAB248F72362}']
3    procedure Connect(const Database: WideString;
4      const UserName: WideString;
5      const Password: WideString); safecall;
6    property QueryObject: OleVariant;
7    property StoredProcObject: OleVariant;
8  end;
Объект-провайдер может установить связь с БД либо самостоятельно с использованием переданных в метод Connect параметров соединения, либо с помощью объектов Query и StoredProc , предоставляемых системой Парус8 для использования в пользовательских приложениях. В свою очередь, созданный провайдер с установленным соединением может быть передан в метод Execute объекта QueryBuilder.Application . Вторым параметром может быть передано значение, представляющее структуру запроса. Это может быть либо строка с указанием имени файла, либо объект, реализующий интерфейс IStream (например, MSXML.DOMDocument ), либо строка, представляющая собой xml-документ. Все средства манипуляции структурой и поведением запроса предоставляются на уровне работы с xml-документом, описывающим запрос.

Пример скрипта пользовательского приложения на DelphiScript
01procedure QueryBuilderTest;
02var
03  LApplication: OleVarint;
04  LProvider: OleVarint;
05  LDocument: OleVariant;
06begin
07  //описание структуры запроса. Из BLOB, из файла, из строки - откуда угодно
08  LDocument := CreateOleObject('MSXML.DOMDocument');
09  //LDocument реализует IXMLDOMDocument и IStream
10  LDocument.loadXML('<Query Provider="{B3079C97-6EBC-43EB-880F-58F094B322B0}">' +
11    '<Item Type="Table" Table="AGNLIST" Alias="MAIN" TableAlias="MAIN">'  +
12      '<Item ColumnIndex="0" Type="Field" Field="AGNABBR" Table="AGNLIST" ' +
13        'Alias="MAIN_AGNABBR" TableAlias="MAIN"/>' +
14      '<Item ColumnIndex="1" Type="Field" Field="VERSION" Table="AGNLIST" ' +
15        'Alias="MAIN_VERSION" TableAlias="MAIN"/>' +
16    '</Item>' +
17  '</Query>');
18
19  //Скрытие дерева структуры
20  LDocument.documentElement.setAttribute('TreeWidth', 0);
21
22  //Наложение условий отбора на колонку
23  LDocument.selectSingleNode('/*/Item/Item[@Field="AGNABBR" and @Table="AGNLIST"]').
24    setAttribute('ColumnFilter', 'Б*');
25
26  //Переименование колонки
27  LDocument.selectSingleNode('/*/Item/Item[@Field="VERSION" and @Table="AGNLIST"]').
28    setAttribute('Caption', 'Версия');
29
30
31  //создание провайдера и передача ему объектов для соединения с БД
32  LProvider := CreateOleObject('ParusInfoProvider.ParusProvider');
33  LProvider.QueryObject := Query;
34  LProvider.StoredProcObject := StoredProc;
35
36  //создание и использование объекта-приложения QueryBuilder
37  LApplication := CreateOleObject('QueryBuilder.Application');
38
39  //В качестве второго параметра передается ОБЪЕКТ, через
40  //   IStream содержащий структуру запроса
41  LApplication.Execute(LProvider, LDocument);
42  LApplication.Visible := True;
43
44  //Ожидание завершения работы с приложением
45  repeat
46    Application.ProcessMessages;
47  until not LApplication.Visible;
48
49end;
50
Интерфейс автоматизации поддерживает также метод для автоматического применения шаблона для переноса в Excel.

Допустим, .MQR-файл, описывающий запрос, содержащий шаблон с именем "Простой Перенос" загружен в раздел "Модули пользовательских приложений" с мнемокодом "QueryData". Для этого необходимо создать модуль пользовательского приложения с типом "COM-сервер" или "Надстройка Excel" и загрузить из файла .MQR-файл. Проверки соответствия формата загружаемого файла заявленному типу модуля пользовательского приложения Парус не производит, что позволяет воспользоваться этим трюком. Тогда:
01procedure QueryBuilderTemplateTest;
02var
03  LApplication: OleVarint;
04  LProvider: OleVarint;
05  S: string;
06begin
07  Query.SQL.Text := 'select BMODULE from V_UAMODULES where SCODE = :CODE';
08  //мнемокод модуля пользовательского приложения, содержащего
09  //загруженный .MQR-файл
10  Query.ParamByName('CODE').Value := 'QueryData';
11  Query.Open;
12  S := Query.FieldByName('BMODULE').AsString;
13  Query.Close;
14
15 //создание провайдера и передача ему объектов для соединения с БД
16  LProvider := CreateOleObject('ParusInfoProvider.ParusProvider');
17  LProvider.QueryObject := Query;
18  LProvider.StoredProcObject := StoredProc;
19
20  //создание и использование объекта-приложения QueryBuilder
21  LApplication := CreateOleObject('QueryBuilder.Application');
22
23  //В качестве второго параметра передается СТРОКА, содержащая xml с описанием
24  //структуры запроса и шаблоны для переноса в Excel
25  LApplication.ExecuteTemplate(LProvider, S, 'Простой Перенос');
26end;
6.3.2. Информация о базе данных

Провайдер Парус8 предоставляет информацию о четырех типах таблиц:

Представление, описанное при помощи метаданных Парус8 как "вызываемое с клиента". В этом случае полями таблицы являются описанные атрибуты класса с соответствующими типами.

Таблица, имеющая клиентский доступ и связанная с разделом, не имеющим ни одного описанного доступного представления, но имеющим описанные физические атрибуты. Информация о полях берется из метаданных Парус8

Таблица, имеющая клиентский доступ и связанная с разделом, не имеющим ни одного описанного доступного представления, и не имеющим описанных атрибутов. Информация о полях берется из метаданных Oracle.

Таблица, имеющая клиентский доступ и не связанная ни с каким разделом. Информация о полях берется из метаданных Oracle.

6.4. Разработка шаблонов

Шаблон представляет собой обычную рабочую книгу Excel.

Шаблоны для переноса данных в Excel физически интегрируются внутрь .MQR-файла и хранятся вместе с запросом. Разработку шаблона можно вести независимо, используя только Microsoft Excel (запуская его самостоятельно), а потом загрузить в файл запроса, а можно воспользоваться пунктом меню "Редактировать" на странице "Шаблоны".

Для взаимодействия с источником данных рабочая книга-шаблон должна содержать в любом модуле макрос с именем "Template" (без кавычек) с одним параметром. При выполнении переноса данных по этому шаблону QueryBuilder произведет вызов этого метода, передав в качестве фактического значения параметра объект, реализующий интерфейс IExternalQuery. Никаких других требований к рабочей книге-шаблону не выдвигается.

В примере показан запрос на таблицу AGNLIST (провайдер Oracle), показывающий как простой перенос данных, так и сводную таблицу со сводной диаграммой распределения записей таблицы по полю CRN.
Пример запроса с шаблонами

В примере показан запрос на таблицу "TField" (провайдер Мельницы Данных), показывающий как простой перенос данных, так и сводную таблицу со сводной диаграммой распределения записей таблицы.
Пример запроса с шаблонами для Мельницы Данных`

6.4.1. Интерфейс IExternalQuery

Объект, реализующий этот интерфейс, передается в макрос генерации отчета Excel (Template). Все его свойства и методы доступны для испоьзования в процессе генерации отчета
01  IExternalQuery = interface(IDispatch)
02    ['{1A86D1DA-A56E-4D53-88F9-7A035D7D12B4}']
03    function Select(const SQL: WideString): IExternalDataSet; safecall;
04    function SelectedRecordsCount: Integer; safecall;
05    function SelectedRecord(Index: Integer): OleVariant; safecall;
06    procedure PlaceCurrentQuery(const Sheet: IDispatch;
07      CaptionsNeeded: WordBool = False; Row: Integer = 1;
08      Column: Integer = 1; ShiftRows: WordBool = True;
09      ShiftColumns: WordBool = False); safecall;
10    procedure PlaceQuery(const Sheet: IDispatch; const DataSet: ExternalDataSet;
11      Row: Integer = 1; Column: Integer = 1; ShiftRows: WordBool = True;
12      ShiftColumns: WordBool = False); safecall;
13    property CurrentQuery: WideString;
14  end;
функция Select возвращает объект, реализующий интерфейс IExternalDataSet с данными, полученными в результате запроса, заданного параметром SQL. Фактически метод является оберткой метода Perform объекта-провайдера IInfoProvider

функция SelectedRecordsCount возвращает количество записей, отмеченных пользователем в гриде в момент выгрузки в Excel

функция SelectedRecord возвращает первичный ключ отмеченной пользователем записи с номером Index

процедура PlaceCurrentQuery осуществляет перенос в указанное положение указанного рабочего листа данных текущего табличного представления. Параметр Sheet указывает на рабочий лист Excel, на который будет осуществляться перенос, параметр CaptionsNeeded определяет необходимость переноса заголовков колонок, параметры Row и Column определяют соответственно номер строки и столбца на рабочем листе Excel, начиная с которых будут расположены данные. Параметр ShiftRows определяет необходимость сдвига строк вниз при переносе данных (информация в ячейках, лежащих НИЖЕ строки, определенной параметром Row, будет либо затерта, либо сдвинута на требуемое число строк вниз. Параметр ShiftColumns определяет необходимость сдвига колонок вправо при переносе данных (информация в ячейках, лежащих ПРАВЕЕ столбца, определенного параметром Column, будет либо затерта, либо сдвинута на требуемое число строк вниз.

процедура PlaceQuery осуществляет перенос в указанное положение указанного рабочего листа данных заданного параметром DataSet набора данных. Параметр Sheet указывает на рабочий лист Excel, на который будет осуществляться перенос, параметр CaptionsNeeded определяет необходимость переноса заголовков колонок, параметры Row и Column определяют соответственно номер строки и столбца на рабочем листе Excel, начиная с которых будут расположены данные. Параметр ShiftRows определяет необходимость сдвига строк вниз при переносе данных (информация в ячейках, лежащих НИЖЕ строки, определенной параметром Row, будет либо затерта, либо сдвинута на требуемое число строк вниз. Параметр ShiftColumns определяет необходимость сдвига колонок вправо при переносе данных (информация в ячейках, лежащих ПРАВЕЕ столбца, определенного параметром Column, будет либо затерта, либо сдвинута на требуемое число строк вниз.

свойство CurrentQuery возвращает строку запроса, на основе которого постоено текущее табличное представление.

6.4.2. Интерфейс IExternalDataSet

Фактически, обертка над интерфейсом IDataSet .
1  IExternalDataSet = interface(IDispatch)
2    ['{CDC7992C-BB30-431C-9F81-3215175AD5AB}']
3    procedure Next; safecall;
4    function Eof: WordBool; safecall;
5    property FieldCount: Integer;
6    property FieldName[Index: Integer]: WideString;
7    property Field[FieldIndex: OleVariant]: OleVariant;
8  end;
Набор данных представляет собой однонаправленный курсор, каждая строка которого является набором именованных и нумерованных полей.

процедура Next осуществляет переход к следующей записи курсора.

функция Eof возвращает True в случае достижения конца курсора.

свойство FieldCount возвращает количество полей в строке курсора.

свойство FieldName возвращает имя поля с номером Index.

свойство Field возвращает значение поля, имя или номер которого задан параметром (если строка, то имя, если число, то номер). Допустимо возвращать значение Null для пустых полей.

6.5. Интерфейс автоматизации

Взаимодействие внешних приложений с QueryBuilder'ом осуществляется при помощи интерфейса
1  IApplication = interface(IDispatch)
2    ['{0E59D500-7A6A-43CA-8007-B7BB7E393CD4}']
3    procedure Execute(const Provider: IUnknown; var Query: OleVariant); safecall;
4    procedure ExecuteTemplate(const Provider: IUnknown; var Query: OleVariant;
5      const TemplateName: WideString); safecall;
6    property Visible: WordBool;
7  end;
Свойство Visible определяет видимость приложения

Процедура Execute осуществляет выполнение запроса. Первым параметром является объект-провайдер (созданный заранее внешним образом и установивший соединение с БД также заранее). Вторым параметром может быть передано значение, представляющее структуру запроса. Это может быть либо строка с указанием имени файла, либо объект, реализующий интерфейс IStream (например, MSXML.DOMDocument ), либо строка, представляющая собой xml-документ. Все средства манипуляции структурой и поведением запроса предоставляются на уровне работы с xml-документом, описывающим запрос.

Процедура ExecuteTemplate осуществляет выполнение запроса и применяет к результатам шаблон с именем, переданным в параметре TemplateName. Первые два параметра аналогичны параметрам метода Execute

Интерфейс автоматизации может быть использован в тех случаях, когда необходима интергация QueryBuilder'a в третьестороннюю информационную систему.

6.6. Справочник по интерфейсам

6.6.1. Перечисление TAggregateType
1type
2  TAggregateType = (atCount, atSumm, atAverage, atMinimum, atMaximum, atAny,
3    atAll, atCountDistinct);
Или
01type
02  TAggregateType = TOleEnum;
03const
04  atCount = $00000000;
05  atSumm = $00000001;
06  atAverage = $00000002;
07  atMinimum = $00000003;
08  atMaximum = $00000004;
09  atAny = $00000005;
10  atAll = $00000006;
11  atCountDistinct = $00000007;
Элементы перечисления:

Имя

Значение

Назначение

atCount

0

atSumm

1

atAverage

2

atMinimum

3

atMaximum

4

atAny

5

atAll

6

atCountDistinct

7

6.6.2. Перечисление TBlobSubType
1type
2  TBlobSubType = (bsText, bsImage, bsBinary);
Или
1type
2  TBlobSubType = TOleEnum;
3const
4  bsText = $00000000;
5  bsImage = $00000001;
6  bsBinary = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

bsText

0

bsImage

1

bsBinary

2

6.6.3. Перечисление TDisplayMode
1type
2  TDisplayMode = (dmAlways, dmNever, dmOnDemand);
Или
1type
2  TDisplayMode = TOleEnum;
3const
4  dmAlways = $00000000;
5  dmNever = $00000001;
6  dmOnDemand = $00000002;
Элементы перечисления:

Имя

Значение

Назначение

dmAlways

0

dmNever

1

dmOnDemand

2

6.6.4. Перечисление TSimpleType
1type
2  TSimpleType = (dtString, dtInteger, dtFloat, dtDate, dtTime, dtDateTime,
3    dtBoolean, dtEnumeration, dtReference, dtBlob);
Или
01type
02  TSimpleType = TOleEnum;
03const
04  dtString = $00000000;
05  dtInteger = $00000001;
06  dtFloat = $00000002;
07  dtDate = $00000003;
08  dtTime = $00000004;
09  dtDateTime = $00000005;
10  dtBoolean = $00000006;
11  dtEnumeration = $00000007;
12  dtReference = $00000008;
13  dtBlob = $00000009;
Элементы перечисления:

Имя

Значение

Назначение

dtString

0

dtInteger

1

dtFloat

2

dtDate

3

dtTime

4

dtDateTime

5

dtBoolean

6

dtEnumeration

7

dtReference

8

dtBlob

9

6.6.5. Интерфейс IApplication
01type
02  IApplication = interface(IDispatch)
03    ['{0E59D500-7A6A-43CA-8007-B7BB7E393CD4}']
04    procedure Execute(const Provider: IUnknown; const Query: OleVariant); safecall;
05    function Get_Visible: WordBool; safecall;
06    procedure Set_Visible(Value: WordBool); safecall;
07    procedure ExecuteTemplate(const Provider: IUnknown; const Query: OleVariant;
08      const TemplateName: WideString); safecall;
09    property Visible: WordBool read Get_Visible write Set_Visible;
10  end;
6.6.5.1. Свойства

Свойства интерфейса IApplication:

Имя

Тип

Доступ

Назначение

Visible

WordBool

Чтение/Запись

6.6.5.2. Метод Execute

Метод интерфейса IApplication.
1procedure IApplication.Execute(const Provider: IUnknown;
2  const Query: OleVariant);
Параметры:

Имя

Тип

Обязательно

Значение

Provider

IUnknown

Да

Query

OleVariant

Да

6.6.5.3. Метод ExecuteTemplate

Метод интерфейса IApplication.
1procedure IApplication.ExecuteTemplate(const Provider: IUnknown;
2  const Query: OleVariant; const TemplateName: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Provider

IUnknown

Да

Query

OleVariant

Да

TemplateName

WideString

Да

6.6.6. Интерфейс IBlobInfo
1type
2  IBlobInfo = interface(ITypeInfo)
3    ['{3905C9C4-EAEB-4844-BB55-3F524F1F3FAC}']
4    function Get_SubType: TBlobSubType; safecall;
5    property SubType: TBlobSubType read Get_SubType;
6  end;
6.6.6.1. Свойства

Свойства интерфейса IBlobInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Required

WordBool

Только для чтения

Унаследовано от ITypeInfo

SimpleType

TSimpleType

Только для чтения

SubType

TBlobSubType

Только для чтения

6.6.7. Интерфейс IBooleanInfo
1type
2  IBooleanInfo = interface(ITypeInfo)
3    ['{8256EDF9-8613-4970-850C-50047839D6BF}']
4    function Get_TrueValue: WideString; safecall;
5    function Get_FalseValue: WideString; safecall;
6    property TrueValue: WideString read Get_TrueValue;
7    property FalseValue: WideString read Get_FalseValue;
8  end;
6.6.7.1. Свойства

Свойства интерфейса IBooleanInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Required

WordBool

Только для чтения

Унаследовано от ITypeInfo

SimpleType

TSimpleType

Только для чтения

FalseValue

WideString

Только для чтения

TrueValue

WideString

Только для чтения

6.6.8. Интерфейс IDataSet
01type
02  IDataSet = interface(IUnknown)
03    ['{3CED7395-8482-4EF6-8A15-7744348063C2}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_FieldName(Index: Integer): WideString; safecall;
06    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
07    procedure Next; safecall;
08    function Eof: WordBool; safecall;
09    property FieldCount: Integer read Get_FieldCount;
10    property FieldName[Index: Integer]: WideString read Get_FieldName;
11    property Field[FieldIndex: OleVariant]: OleVariant read Get_Field;
12  end;
6.6.8.1. Свойства

Свойства интерфейса IDataSet:

Имя

Тип

Доступ

Назначение

Field[FieldIndex: OleVariant]

OleVariant

Только для чтения

FieldCount

Integer

Только для чтения

FieldName[Index: Integer]

WideString

Только для чтения

6.6.8.2. Метод Eof

Метод интерфейса IDataSet.
function IDataSet.Eof: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

6.6.8.3. Метод Next

Метод интерфейса IDataSet.
procedure IDataSet.Next;
Метод не имеет параметров.

6.6.9. Интерфейс IDateInfo
1type
2  IDateInfo = interface(ITypeInfo)
3    ['{DA392510-105F-4655-9A38-18ECA2FBEB97}']
4  end;
6.6.10. Интерфейс IDateTimeInfo
1type
2  IDateTimeInfo = interface(ITypeInfo)
3    ['{7F5CC8F9-8CE1-4DB7-8932-884EF3BAB538}']
4  end;
6.6.11. Интерфейс IEnumerationInfo
1type
2  IEnumerationInfo = interface(ITypeInfo)
3    ['{B58A3F23-1AAC-4420-ADFF-B23B9938A994}']
4    function Get_ItemCount: Integer; safecall;
5    function Get_Item(Index: Integer): IEnumerationItem; safecall;
6    property ItemCount: Integer read Get_ItemCount;
7    property Item[Index: Integer]: IEnumerationItem read Get_Item;
8  end;
6.6.11.1. Свойства

Свойства интерфейса IEnumerationInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Required

WordBool

Только для чтения

Унаследовано от ITypeInfo

SimpleType

TSimpleType

Только для чтения

Item[Index: Integer]

IEnumerationItem

Только для чтения

ItemCount

Integer

Только для чтения

6.6.12. Интерфейс IEnumerationItem
1type
2  IEnumerationItem = interface(INamedItemInfo)
3    ['{6953507C-D477-4B8D-9443-A9E5FE7137ED}']
4    function Get_Position: Integer; safecall;
5    property Position: Integer read Get_Position;
6  end;
6.6.12.1. Свойства

Свойства интерфейса IEnumerationItem:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Position

Integer

Только для чтения

6.6.13. Интерфейс IExternalDataSet
01type
02  IExternalDataSet = interface(IDispatch)
03    ['{CDC7992C-BB30-431C-9F81-3215175AD5AB}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_FieldName(Index: Integer): WideString; safecall;
06    function Get_Field(FieldIndex: OleVariant): OleVariant; safecall;
07    procedure Next; safecall;
08    function Eof: WordBool; safecall;
09    property FieldCount: Integer read Get_FieldCount;
10    property FieldName[Index: Integer]: WideString read Get_FieldName;
11    property Field[FieldIndex: OleVariant]: OleVariant read Get_Field;
12  end;
6.6.13.1. Свойства

Свойства интерфейса IExternalDataSet:

Имя

Тип

Доступ

Назначение

Field[FieldIndex: OleVariant]

OleVariant

Только для чтения

FieldCount

Integer

Только для чтения

FieldName[Index: Integer]

WideString

Только для чтения

6.6.13.2. Метод Eof

Метод интерфейса IExternalDataSet.
function IExternalDataSet.Eof: WordBool;
Метод не имеет параметров.

Замечания:

Возвращает значение типа WordBool.

6.6.13.3. Метод Next

Метод интерфейса IExternalDataSet.
procedure IExternalDataSet.Next;
Метод не имеет параметров.

6.6.14. Интерфейс IExternalQuery
01type
02  IExternalQuery = interface(IDispatch)
03    ['{1A86D1DA-A56E-4D53-88F9-7A035D7D12B4}']
04    function Get_CurrentQuery: WideString; safecall;
05    function Select(const SQL: WideString): IExternalDataSet; safecall;
06    function SelectedRecordsCount: Integer; safecall;
07    function SelectedRecord(Index: Integer): OleVariant; safecall;
08    procedure PlaceCurrentQuery(const Sheet: IDispatch; CaptionsNeeded: WordBool;
09      Row: Integer; Column: Integer; ShiftRows: WordBool; ShiftColumns: WordBool); safecall;
10    procedure PlaceQuery(const Sheet: IDispatch; const DataSet: ExternalDataSet;
11      Row: Integer; Column: Integer; ShiftRows: WordBool; ShiftColumns: WordBool); safecall;
12    property CurrentQuery: WideString read Get_CurrentQuery;
13  end;
6.6.14.1. Свойства

Свойства интерфейса IExternalQuery:

Имя

Тип

Доступ

Назначение

CurrentQuery

WideString

Только для чтения

6.6.14.2. Метод PlaceCurrentQuery

Метод интерфейса IExternalQuery.
1procedure IExternalQuery.PlaceCurrentQuery(const Sheet: IDispatch;
2  CaptionsNeeded: WordBool; Row: Integer; Column: Integer; ShiftRows: WordBool;
3  ShiftColumns: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Sheet

IDispatch

Да

CaptionsNeeded

WordBool

Нет

Row

Integer

Нет

Column

Integer

Нет

ShiftRows

WordBool

Нет

ShiftColumns

WordBool

Нет

6.6.14.3. Метод PlaceQuery

Метод интерфейса IExternalQuery.
1procedure IExternalQuery.PlaceQuery(const Sheet: IDispatch;
2  const DataSet: ExternalDataSet; Row: Integer; Column: Integer;
3  ShiftRows: WordBool; ShiftColumns: WordBool);
Параметры:

Имя

Тип

Обязательно

Значение

Sheet

IDispatch

Да

DataSet

ExternalDataSet

Да

Row

Integer

Нет

Column

Integer

Нет

ShiftRows

WordBool

Нет

ShiftColumns

WordBool

Нет

6.6.14.4. Метод Select

Метод интерфейса IExternalQuery.
function IExternalQuery.Select(const SQL: WideString): IExternalDataSet;
Параметры:

Имя

Тип

Обязательно

Значение

SQL

WideString

Да

Замечания:

Возвращает значение типа IExternalDataSet.

6.6.14.5. Метод SelectedRecord

Метод интерфейса IExternalQuery.
function IExternalQuery.SelectedRecord(Index: Integer): OleVariant;
Параметры:

Имя

Тип

Обязательно

Значение

Index

Integer

Да

Замечания:

Возвращает значение типа OleVariant.

6.6.14.6. Метод SelectedRecordsCount

Метод интерфейса IExternalQuery.
function IExternalQuery.SelectedRecordsCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

6.6.15. Интерфейс IFieldInfo
1type
2  IFieldInfo = interface(INamedItemInfo)
3    ['{19054DAD-8D35-4B39-8EB7-FD3254BD2934}']
4    function Get_TypeInfo: ITypeInfo; safecall;
5    function Get_DisplayMode: TDisplayMode; safecall;
6    property TypeInfo: ITypeInfo read Get_TypeInfo;
7    property DisplayMode: TDisplayMode read Get_DisplayMode;
8  end;
6.6.15.1. Свойства

Свойства интерфейса IFieldInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

DisplayMode

TDisplayMode

Только для чтения

TypeInfo

ITypeInfo

Только для чтения

6.6.16. Интерфейс IFieldInfo2
1type
2  IFieldInfo2 = interface(IFieldInfo)
3    ['{82D93CF0-0E2F-4A85-AD74-9B1B9199B76B}']
4    function Get_Category: WideString; safecall;
5    property Category: WideString read Get_Category;
6  end;
6.6.16.1. Свойства

Свойства интерфейса IFieldInfo2:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

DisplayMode

TDisplayMode

Только для чтения

Унаследовано от IFieldInfo

TypeInfo

ITypeInfo

Только для чтения

Category

WideString

Только для чтения

6.6.17. Интерфейс IFloatInfo
01type
02  IFloatInfo = interface(ITypeInfo)
03    ['{E9B56C6D-47DC-4AB9-9E80-6EEF77708704}']
04    function Get_MaxValue: Double; safecall;
05    function Get_MaxValueUsed: WordBool; safecall;
06    function Get_MinValue: Double; safecall;
07    function Get_MinValueUsed: WordBool; safecall;
08    function Get_Precision: Integer; safecall;
09    function Get_Scale: Integer; safecall;
10    property MaxValue: Double read Get_MaxValue;
11    property MaxValueUsed: WordBool read Get_MaxValueUsed;
12    property MinValue: Double read Get_MinValue;
13    property MinValueUsed: WordBool read Get_MinValueUsed;
14    property Precision: Integer read Get_Precision;
15    property Scale: Integer read Get_Scale;
16  end;
6.6.17.1. Свойства

Свойства интерфейса IFloatInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Required

WordBool

Только для чтения

Унаследовано от ITypeInfo

SimpleType

TSimpleType

Только для чтения

MaxValue

Double

Только для чтения

MaxValueUsed

WordBool

Только для чтения

MinValue

Double

Только для чтения

MinValueUsed

WordBool

Только для чтения

Precision

Integer

Только для чтения

Scale

Integer

Только для чтения

6.6.18. Интерфейс IInfoProvider
01type
02  IInfoProvider = interface(IUnknown)
03    ['{64F8072B-7250-4C57-BA8E-D018C7B72CC7}']
04    function Get_TableCount: Integer; safecall;
05    function Get_Table(Index: Integer): ITableInfo; safecall;
06    function Perform(const SQL: WideString): IDataSet; safecall;
07    procedure Connect(const DataBase: WideString; const UserName: WideString;
08      const Password: WideString); safecall;
09    function Get_CLSID: GUID; safecall;
10    function Get_DateLiteral: WideString; safecall;
11    function Get_TimeLiteral: WideString; safecall;
12    function Get_DateTimeLiteral: WideString; safecall;
13    function Get_RegExpLiteral: WideString; safecall;
14    function Get_ToBooleanLiteral: WideString; safecall;
15    function Get_ToStringLiteral: WideString; safecall;
16    function Get_AllowStartingWith: WordBool; safecall;
17    function Get_AllowArrays: WordBool; safecall;
18    function Get_DisallowNullsSorting: WordBool; safecall;
19    function Get_DisallowSubqueries: WordBool; safecall;
20    function Get_DisallowBetween: WordBool; safecall;
21    function Get_LikeAlwaysEscaped: WordBool; safecall;
22    function Get_MaxIdentLength: Integer; safecall;
23    function Get_ReplaceRegExpDotsWithUnderscore: WordBool; safecall;
24    function Get_Epsilon: WideString; safecall;
25    property TableCount: Integer read Get_TableCount;
26    property Table[Index: Integer]: ITableInfo read Get_Table;
27    property CLSID: GUID read Get_CLSID;
28    property DateLiteral: WideString read Get_DateLiteral;
29    property TimeLiteral: WideString read Get_TimeLiteral;
30    property DateTimeLiteral: WideString read Get_DateTimeLiteral;
31    property RegExpLiteral: WideString read Get_RegExpLiteral;
32    property ToBooleanLiteral: WideString read Get_ToBooleanLiteral;
33    property ToStringLiteral: WideString read Get_ToStringLiteral;
34    property AllowStartingWith: WordBool read Get_AllowStartingWith;
35    property AllowArrays: WordBool read Get_AllowArrays;
36    property DisallowNullsSorting: WordBool read Get_DisallowNullsSorting;
37    property DisallowSubqueries: WordBool read Get_DisallowSubqueries;
38    property DisallowBetween: WordBool read Get_DisallowBetween;
39    property LikeAlwaysEscaped: WordBool read Get_LikeAlwaysEscaped;
40    property MaxIdentLength: Integer read Get_MaxIdentLength;
41    property ReplaceRegExpDotsWithUnderscore: WordBool
42      read Get_ReplaceRegExpDotsWithUnderscore;
43    property Epsilon: WideString read Get_Epsilon;
44  end;
6.6.18.1. Свойства

Свойства интерфейса IInfoProvider:

Имя

Тип

Доступ

Назначение

AllowArrays

WordBool

Только для чтения

AllowStartingWith

WordBool

Только для чтения

CLSID

GUID

Только для чтения

DateLiteral

WideString

Только для чтения

DateTimeLiteral

WideString

Только для чтения

DisallowBetween

WordBool

Только для чтения

DisallowNullsSorting

WordBool

Только для чтения

DisallowSubqueries

WordBool

Только для чтения

Epsilon

WideString

Только для чтения

LikeAlwaysEscaped

WordBool

Только для чтения

MaxIdentLength

Integer

Только для чтения

RegExpLiteral

WideString

Только для чтения

ReplaceRegExpDotsWithUnderscore

WordBool

Только для чтения

Table[Index: Integer]

ITableInfo

Только для чтения

TableCount

Integer

Только для чтения

TimeLiteral

WideString

Только для чтения

ToBooleanLiteral

WideString

Только для чтения

ToStringLiteral

WideString

Только для чтения

6.6.18.2. Метод Connect

Метод интерфейса IInfoProvider.
1procedure IInfoProvider.Connect(const DataBase: WideString;
2  const UserName: WideString; const Password: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

DataBase

WideString

Да

UserName

WideString

Да

Password

WideString

Да

6.6.18.3. Метод Perform

Метод интерфейса IInfoProvider.
function IInfoProvider.Perform(const SQL: WideString): IDataSet;
Параметры:

Имя

Тип

Обязательно

Значение

SQL

WideString

Да

Замечания:

Возвращает значение типа IDataSet.

6.6.19. Интерфейс IInfoProvider2
01type
02  IInfoProvider2 = interface(IDispatch)
03    ['{BED44934-BCF9-4942-933D-591AB40D4CFE}']
04    function Get_AutoCheckKeys: WordBool; safecall;
05    function Get_OptionCount: Integer; safecall;
06    function Get_Option(Index: Integer): IOptionInfo; safecall;
07    property AutoCheckKeys: WordBool read Get_AutoCheckKeys;
08    property OptionCount: Integer read Get_OptionCount;
09    property Option[Index: Integer]: IOptionInfo read Get_Option;
10  end;
6.6.19.1. Свойства

Свойства интерфейса IInfoProvider2:

Имя

Тип

Доступ

Назначение

AutoCheckKeys

WordBool

Только для чтения

Option[Index: Integer]

IOptionInfo

Только для чтения

OptionCount

Integer

Только для чтения

6.6.20. Интерфейс IInfoProvider3
1type
2  IInfoProvider3 = interface(IDispatch)
3    ['{EF0E186A-4C72-4C40-B61C-72D7D03B2D10}']
4    procedure SetLogonInfo(const Login: WideString); safecall;
5  end;
6.6.20.1. Метод SetLogonInfo

Метод интерфейса IInfoProvider3.
procedure IInfoProvider3.SetLogonInfo(const Login: WideString);
Параметры:

Имя

Тип

Обязательно

Значение

Login

WideString

Да

6.6.21. Интерфейс IIntegerInfo
01type
02  IIntegerInfo = interface(ITypeInfo)
03    ['{9003B25E-926D-42AE-A907-813DF3A8343E}']
04    function Get_MaxValue: Integer; safecall;
05    function Get_MaxValueUsed: WordBool; safecall;
06    function Get_MinValue: Integer; safecall;
07    function Get_MinValueUsed: WordBool; safecall;
08    property MaxValue: Integer read Get_MaxValue;
09    property MaxValueUsed: WordBool read Get_MaxValueUsed;
10    property MinValue: Integer read Get_MinValue;
11    property MinValueUsed: WordBool read Get_MinValueUsed;
12  end;
6.6.21.1. Свойства

Свойства интерфейса IIntegerInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Required

WordBool

Только для чтения

Унаследовано от ITypeInfo

SimpleType

TSimpleType

Только для чтения

MaxValue

Integer

Только для чтения

MaxValueUsed

WordBool

Только для чтения

MinValue

Integer

Только для чтения

MinValueUsed

WordBool

Только для чтения

6.6.22. Интерфейс INamedItemInfo
01type
02  INamedItemInfo = interface(IUnknown)
03    ['{14894363-28DA-4E71-B0BC-9C5CE811BC8F}']
04    function Get_Name: WideString; safecall;
05    function Get_Caption: WideString; safecall;
06    function Get_ID: WideString; safecall;
07    property Name: WideString read Get_Name;
08    property Caption: WideString read Get_Caption;
09    property ID: WideString read Get_ID;
10  end;
6.6.22.1. Свойства

Свойства интерфейса INamedItemInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

ID

WideString

Только для чтения

Name

WideString

Только для чтения

6.6.23. Интерфейс IOptionInfo
01type
02  IOptionInfo = interface(INamedItemInfo)
03    ['{453E81A2-969D-49DC-B3C6-ACAD411D63FC}']
04    function Get_TypeInfo: ITypeInfo; safecall;
05    function Get_Group: WideString; safecall;
06    function Get_Tab: WideString; safecall;
07    function Get_Value: OleVariant; safecall;
08    procedure Set_Value(Value: OleVariant); safecall;
09    property TypeInfo: ITypeInfo read Get_TypeInfo;
10    property Group: WideString read Get_Group;
11    property Tab: WideString read Get_Tab;
12    property Value: OleVariant read Get_Value write Set_Value;
13  end;
6.6.23.1. Свойства

Свойства интерфейса IOptionInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Group

WideString

Только для чтения

Tab

WideString

Только для чтения

TypeInfo

ITypeInfo

Только для чтения

Value

OleVariant

Чтение/Запись

6.6.24. Интерфейс IReferenceInfo
1type
2  IReferenceInfo = interface(ITypeInfo)
3    ['{309C8CB1-4A1C-4E58-BC3F-D1AF27861A8F}']
4    function Get_TargetTable: ITableInfo; safecall;
5    property TargetTable: ITableInfo read Get_TargetTable;
6  end;
6.6.24.1. Свойства

Свойства интерфейса IReferenceInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Required

WordBool

Только для чтения

Унаследовано от ITypeInfo

SimpleType

TSimpleType

Только для чтения

TargetTable

ITableInfo

Только для чтения

6.6.25. Интерфейс IStringInfo
1type
2  IStringInfo = interface(ITypeInfo)
3    ['{74AC4C03-E803-421B-B30D-1A2D2C49827F}']
4    function Get_Length: Integer; safecall;
5    property Length: Integer read Get_Length;
6  end;
6.6.25.1. Свойства

Свойства интерфейса IStringInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Required

WordBool

Только для чтения

Унаследовано от ITypeInfo

SimpleType

TSimpleType

Только для чтения

Length

Integer

Только для чтения

6.6.26. Интерфейс ITableInfo
01type
02  ITableInfo = interface(INamedItemInfo)
03    ['{3FC1998A-9031-4936-82B5-8CAA2219085E}']
04    function Get_FieldCount: Integer; safecall;
05    function Get_Field(Index: Integer): IFieldInfo; safecall;
06    function Get_PrimaryKey: IFieldInfo; safecall;
07    function Get_Uplink: IFieldInfo; safecall;
08    function Get_Parent: ITableInfo; safecall;
09    function Get_RootAvailable: WordBool; safecall;
10    property FieldCount: Integer read Get_FieldCount;
11    property Field[Index: Integer]: IFieldInfo read Get_Field;
12    property PrimaryKey: IFieldInfo read Get_PrimaryKey;
13    property Uplink: IFieldInfo read Get_Uplink;
14    property Parent: ITableInfo read Get_Parent;
15    property RootAvailable: WordBool read Get_RootAvailable;
16  end;
6.6.26.1. Свойства

Свойства интерфейса ITableInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Field[Index: Integer]

IFieldInfo

Только для чтения

FieldCount

Integer

Только для чтения

Parent

ITableInfo

Только для чтения

PrimaryKey

IFieldInfo

Только для чтения

RootAvailable

WordBool

Только для чтения

Uplink

IFieldInfo

Только для чтения

6.6.27. Интерфейс ITableInfo2
01type
02  ITableInfo2 = interface(ITableInfo)
03    ['{9DF4C8AC-1DA2-4E7B-BF44-7EDD7A269418}']
04    function Get_PolymorphCount: Integer; safecall;
05    function Get_PolymorphTable(Index: Integer): ITableInfo; safecall;
06    function Get_PolymorphField(Index: Integer): IFieldInfo; safecall;
07    property PolymorphCount: Integer read Get_PolymorphCount;
08    property PolymorphTable[Index: Integer]: ITableInfo read Get_PolymorphTable;
09    property PolymorphField[Index: Integer]: IFieldInfo read Get_PolymorphField;
10  end;
6.6.27.1. Свойства

Свойства интерфейса ITableInfo2:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Field[Index: Integer]

IFieldInfo

Только для чтения

Унаследовано от ITableInfo

FieldCount

Integer

Только для чтения

Parent

ITableInfo

Только для чтения

PrimaryKey

IFieldInfo

Только для чтения

RootAvailable

WordBool

Только для чтения

Uplink

IFieldInfo

Только для чтения

PolymorphCount

Integer

Только для чтения

PolymorphField[Index: Integer]

IFieldInfo

Только для чтения

PolymorphTable[Index: Integer]

ITableInfo

Только для чтения

6.6.28. Интерфейс ITableInfo3
01type
02  ITableInfo3 = interface(ITableInfo)
03    ['{3FB73AA9-010C-48DA-81C7-E1DCFE2E6136}']
04    function GetPersistentClause(const Alias: WideString): WideString; safecall;
05    function GetPreConditionsCount: Integer; safecall;
06    function GetPreConditionCaption(Index: Integer): WideString; safecall;
07    function Get_ActivePreCondition(Index: Integer): WordBool; safecall;
08    procedure Set_ActivePreCondition(Index: Integer; Value: WordBool); safecall;
09    function GetPreConditionParamsCount(Index: Integer): Integer; safecall;
10    function GetPreConditionParam(Index: Integer;
11      PreConditionIndex: Integer): IOptionInfo; safecall;
12    function GetPreConditionCategory(Index: Integer): WideString; safecall;
13    property ActivePreCondition[Index: Integer]: WordBool
14      read Get_ActivePreCondition write Set_ActivePreCondition;
15  end;
6.6.28.1. Свойства

Свойства интерфейса ITableInfo3:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Field[Index: Integer]

IFieldInfo

Только для чтения

Унаследовано от ITableInfo

FieldCount

Integer

Только для чтения

Parent

ITableInfo

Только для чтения

PrimaryKey

IFieldInfo

Только для чтения

RootAvailable

WordBool

Только для чтения

Uplink

IFieldInfo

Только для чтения

ActivePreCondition[Index: Integer]

WordBool

Чтение/Запись

6.6.28.2. Метод GetPersistentClause

Метод интерфейса ITableInfo3.
function ITableInfo3.GetPersistentClause(const Alias: WideString): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Alias

WideString

Да

Замечания:

Возвращает значение типа WideString.

6.6.28.3. Метод GetPreConditionCaption

Метод интерфейса ITableInfo3.
function ITableInfo3.GetPreConditionCaption(Index: Integer): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Index

Integer

Да

Замечания:

Возвращает значение типа WideString.

6.6.28.4. Метод GetPreConditionCategory

Метод интерфейса ITableInfo3.
function ITableInfo3.GetPreConditionCategory(Index: Integer): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Index

Integer

Да

Замечания:

Возвращает значение типа WideString.

6.6.28.5. Метод GetPreConditionParam

Метод интерфейса ITableInfo3.
1function ITableInfo3.GetPreConditionParam(Index: Integer;
2  PreConditionIndex: Integer): IOptionInfo;
Параметры:

Имя

Тип

Обязательно

Значение

Index

Integer

Да

PreConditionIndex

Integer

Да

Замечания:

Возвращает значение типа IOptionInfo.

6.6.28.6. Метод GetPreConditionParamsCount

Метод интерфейса ITableInfo3.
function ITableInfo3.GetPreConditionParamsCount(Index: Integer): Integer;
Параметры:

Имя

Тип

Обязательно

Значение

Index

Integer

Да

Замечания:

Возвращает значение типа Integer.

6.6.28.7. Метод GetPreConditionsCount

Метод интерфейса ITableInfo3.
function ITableInfo3.GetPreConditionsCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

6.6.29. Интерфейс ITimeInfo
1type
2  ITimeInfo = interface(ITypeInfo)
3    ['{D7067CAC-67A5-41DB-8D95-40409D8658AB}']
4  end;
6.6.30. Интерфейс ITypeInfo
1type
2  ITypeInfo = interface(INamedItemInfo)
3    ['{2B6A5E20-3C36-4574-89DB-7C873A5C4A00}']
4    function Get_Required: WordBool; safecall;
5    function Get_SimpleType: TSimpleType; safecall;
6    property Required: WordBool read Get_Required;
7    property SimpleType: TSimpleType read Get_SimpleType;
8  end;
6.6.30.1. Свойства

Свойства интерфейса ITypeInfo:

Имя

Тип

Доступ

Назначение

Caption

WideString

Только для чтения

Унаследовано от INamedItemInfo

ID

WideString

Только для чтения

Name

WideString

Только для чтения

Required

WordBool

Только для чтения

SimpleType

TSimpleType

Только для чтения

6.6.31. Интерфейс ITypeInfo2
1type
2  ITypeInfo2 = interface(ITypeInfo)
3    ['{77F58BDF-F01C-40F3-B193-1027AD8C4EDA}']
4    function GetSpecialFilterCount: Integer; safecall;
5    function GetSpecialFilterText(Index: Integer): WideString; safecall;
6    function EditSpecialFilter(Index: Integer; var Filter: WideString): WordBool; safecall;
7  end;
6.6.31.1. Метод EditSpecialFilter

Метод интерфейса ITypeInfo2.
1function ITypeInfo2.EditSpecialFilter(Index: Integer;
2  var Filter: WideString): WordBool;
Параметры:

Имя

Тип

Обязательно

Значение

Index

Integer

Да

Filter

WideString

Да

Замечания:

Возвращает значение типа WordBool.

6.6.31.2. Метод GetSpecialFilterCount

Метод интерфейса ITypeInfo2.
function ITypeInfo2.GetSpecialFilterCount: Integer;
Метод не имеет параметров.

Замечания:

Возвращает значение типа Integer.

6.6.31.3. Метод GetSpecialFilterText

Метод интерфейса ITypeInfo2.
function ITypeInfo2.GetSpecialFilterText(Index: Integer): WideString;
Параметры:

Имя

Тип

Обязательно

Значение

Index

Integer

Да

Замечания:

Возвращает значение типа WideString.